Rainer's Cascading Style Sheet 2.0 Handbook

苏昱作品·版权所有
©2002 Rainer Su . All rights reserved .


Rainer's Cascading Style Sheet 2.0 Handbook

Introduction To CSS2样式表简介
什么是样式表：
CSS 是 Cascading Style Sheet 的缩写。译作「层叠样式表单」。是用于(增强)控制网页样式并允许将样式信息与网页内容分离的一种标记性语言。
如何将样式表加入您的网页：
你可以用以下三种方式将样式表加入您的网页。而最接近目标的样式定义优先权越高。高优先权样式将继承低优先权样式的未重叠定义但覆盖重叠的定义。例外请参阅 !important 声明。
链入外部样式表文件 (Linking to a Style Sheet)
你可以先建立外部样式表文件（.css），然后使用HTML的link对象。示例如下：

<head>
<title>文档标题</title>
<link rel=stylesheet href="http://www.dhtmlet.com/dhtmlet.css" type="text/css">
</head>

而在XML中，你应该如下例所示在声明区中加入：

<? xml-stylesheet type="text/css" href="http://www.dhtmlet.com/dhtmlet.css" ?>
定义内部样式块对象 (Embedding a Style Block)
你可以在你的HTML文档的<HTML>和<BODY>标记之间插入一个<STYLE>...</STYLE>块对象。 定义方式请参阅样式表语法。示例如下：

<html>
<head>
<title>文档标题</title>
<style type="text/css">
<!--
body {font: 10pt "Arial"}
h1 {font: 15pt/17pt "Arial"; font-weight: bold; color: maroon}
h2 {font: 13pt/15pt "Arial"; font-weight: bold; color: blue}
p {font: 10pt/12pt "Arial"; color: black}
-->
</style>
</head>
<body>

请注意，这里将style对象的type属性设置为"text/css"，是允许不支持这类型的浏览器忽略样式表单。
内联定义 (Inline Styles)
内联定义即是在对象的标记内使用对象的style属性定义适用其的样式表属性。示例如下：

<p style="margin-left: 0.5in; margin-right:0.5in">这一行被增加了左右的外补丁<p>
样式表语法 (CSS Syntax)
Selector { property: value }

参数说明：
Selector -- 选择符
property : value -- 样式表定义。属性和属性值之间用冒号(:)隔开。多个定义之间用分号(;)隔开
继承的值 (The ' Inherit ' Value)
每个属性都有一个指定的值： Inherit 。它的意思是：将父对象的值等同为计算机值得到。这个值通常仅仅是备用的。显式的声明它可用来强调。


Rainer's Cascading Style Sheet 2.0 Handbook

Introduction To This Book关于此手册
手册说明：
    本手册是 Rainer's DHTML Library 产品的一部分。

    本手册针对的是已有一定网页设计制作经验的读者。其目的是提供完整清晰的样式表内容的快速索引及进阶帮助。所以对于网页制作和样式表的基础知识，仅简单介绍，恕不赘述。
    手册提供了完整的 CSS2.0 的属性(Properties)、规则(At-Rules)、伪类(Pseudo-Classes)、伪元素(Pseudo-Elements)、声明(Declarations)、单位(Units)、选择符(Selectors)的介绍。其内容涵括了 W3C 的 CSS2.0 标准，以及 Internet Explorer 和 Netscape 各自的私有内容。出于种种众所周知的原因考虑，本手册以浏览器的事实标准—— Internet Explorer 为主。
    手册中为几乎所有的已被支持的属性、伪类、单位等，除了基本的语法示范外，都度身制作了可以对照源代码即时察看运行演示的实例。
    本手册的升级信息与版权声明请参阅关于本书页面。
    限于篇幅，对于一些过于繁杂的相关内容，如动态样式属性(Dynamic Properties)，滤镜(Filters)，行为(Behaviors)请参阅我的其它相关著作。
    本书中涉及到的所有HTML对象(Object，Element)，HTML属性(Attributes)和特性(Properties)请参阅我的相关著作。

如果您对本手册有什么疑问，或您有事想同苏昱联系，请：
    访问：http://www.rainersu.com 　　致信：rainersu@hotmail.com


Rainer's Cascading Style Sheet 2.0 Handbook

End User License Agreement最终用户许可协议
重要须知：
    本《最终用户许可协议》（以下称《协议》）是您（个人或单一实体）与苏昱之间有关苏昱之作品的法律协议。本作品包括计算机软件，并可能包括相关媒体、印刷材料，电子文档，图片。还包括对苏昱提供给您的原作品的任何更新和补充资料。您一旦安装、复制、下载、访问或以其它方式使用本作品，即表示您同意接受本《协议》各项条款的约束。如您不同意本《协议》中的条款，请不要安装或使用本作品。
协议条款：
    本作品受著作权法及国际著作权条约和其它知识产权法和条约的保护。
    本作品（包括但不限于本作品中所含的任何图象、照片、动画、录像、录音、音乐、文字和附加程序）、随附的印刷材料、及本作品的任何副本的产权和著作权，均由苏昱或相关作者拥有。
    本《协议》授予您下列权利：您可以安装、使用、访问、显示、运行本作品。您可以保留多份副本，可以自由传播本作品。
    上述权利不适用于您的任何商业行为或商业用途。否则您务必与苏昱联系。
    苏昱不为本"软件产品"做任何担保。本"软件产品"及任何相关文档以"即此"形式提供，无任何明示的或暗示的担保，包括（但不限于）对可销售性、适用性、或无侵权的暗示担保。使用本"软件产品"所引起的全部风险由您自己承担。
    本协议未明示授予的一切其它权利均为苏昱或相关作者所有。对于此处所指的其他权利，如篡改、反编译、改编、引用、拆解（破坏本作品原始完整性）等，同样请您务必与苏昱先行联系。
    如您未遵守本《协议》的各项条款和条件，在不损害其它权利的情况下，苏昱可终止本《协议》。如此类情况发生，您必须销毁本作品的所有副本及其所有组成部分。苏昱保留对本产品及本协议的最终修改权。

    本《协议》受中华人民共和国法律管辖。

如果您对本《协议》有什么疑问，或您有事想同 苏昱联系，请：
    访问：http://www.rainersu.com 　　致信：rainersu@hotmail.com


关于 - Rainer's PicSchema

重要说明：
以下信息截至本文档发布之日止。最新个人信息请在 www.rainersu.com 查阅。
基本情况：
姓名： | 苏昱(Rainer Su)
性别： | 男
生日： | 一九七七年九月十四日
学历： | 小学
形象描述：
长发。麻花辫。为了省事买的都是灰黑色系的衣服。不上相。故照片和本人的观感有较大出入。
如果没被照片吓死或恶心死，建议看看本人。此段信息征女友用。
工作经历：
1996.07-2000.03 | 中国航空油料安徽分工司 (CAOSC) | 油品化验员
2000.03-2000.08 | 北京易得方舟信息技术有限公司 (www.chineseall.com) | 栏目主编 频道经理
2000.09-2001.05 | 上海榕树下计算机有限公司 (www.rongshu.com) | 网页设计 前台工程师
2001.05-2002.04 | 异联信息技术上海有限公司 (Erry) | 软件UI设计师 软件工程师
2002.04-? | 上海贝塔斯曼文化实业有限公司 (Bertelsmann) | 网站负责人
能力自述：
精通网络开发的客户端(前台)技术。专家级的网页技术和丰富的工作经验。
有参与实际大型商业软件产品开发的经历。
多篇小说、散文等发表于《青年作家》、《作家天地》等杂志。
独立开发过多种桌面应用软件产品。
联系方式：

    致信：rainersu@hotmail.com
    访问：www.rainersu.com

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - ©版权所有 苏昱(Rainer Su)，2002 | rainersu@hotmail.com - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


font版本：CSS1/CSS2　 兼容性：IE4+ NS4+　继承性：有
语法：
font : font-style || font-variant || font-weight || font-size || line-height || font-family
font : caption | icon | menu | message-box | small-caption | status-bar
取值：
font-style | : | CSS1 | 请参阅 font-style 属性
font-variant | : | CSS1 | 请参阅 font-variant 属性
font-weight | : | CSS1 | 请参阅 font-weight 属性
font-size | : | CSS1 | 请参阅 font-size 属性
line-height | : | CSS1 | 请参阅 line-height 属性
font-family | : | CSS1 | 请参阅 font-family 属性
caption | : | CSS2 | 使用有标题的系统控件的文本字体(如按钮，菜单等)
icon | : | CSS2 | 使用图标标签的字体
menu | : | CSS2 | 使用菜单的字体
message-box | : | CSS2 | 使用信息对话框的文本字体
small-caption | : | CSS2 | 使用小控件的字体
status-bar | : | CSS2 | 使用窗口状态栏的字体
说明：
设置或检索对象中的文本特性。该属性是复合属性。
默认值为： normal normal normal medium normal "Times New Roman" 。
第一种声明方式参数必须按照如上的排列顺序。每个参数仅允许有一个值。忽略的将使用其参数对应的独立属性的默认值。
对于如何使用用户端系统可能没有的字体，可以参阅 @font-face 规则。
对应的脚本特性为 font 。
示例：
p { font: italic small-caps 600 12pts/18pts 宋体; }
p { font: italic small-caps 600 12pts/150% Courier; }
p { font: italic small-caps 600 12pts/1.5 Courier; }
p { font: italic small-caps 600 12pts/18pts Courier; }
p { font: /18pts serif; }
p { font: oblique 100 24pts; }
H1 { font: 15pt/17pt bold "Arial" normal }


color版本：CSS1　 兼容性：IE4+ NS4+　继承性：有
语法：
color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
检索或设置对象的文本颜色。无默认值。
注意，用颜色名称指定 color 不被一些浏览器接受。但使用 RGB 值指定颜色能被所有里浏览器识别并正确显示。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 color 。
示例：
div {color: #345456; }
div { color: rgb(100,14,200); }
div {color: menu; }
div {color: red; }


font-family版本：CSS1　 兼容性：IE4+ NS4+　继承性：有
语法：
  • font-family : name
  • font-family :ncursive | fantasy | monospace | serif | sans-serif
取值：
name : 字体名称。按优先顺序排列。以逗号隔开。如果字体名称包含空格，则应使用引号括起
第二种声明方式使用所列出的字体序列名称。如果使用fantasy序列，将提供默认字体序列
说明：
设置或检索用于对象中文本的字体名称序列。默认值为 "Times New Roman" 。
序列可包含嵌入字体字体。请参阅 @font-face 规则。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 fontFamily 。
示例：
div.fixedwidth { font-family: Courier, "Courier New", monospace }


font-size版本：CSS1　 兼容性：IE4+ NS4+　继承性：有
语法：
font-size : xx-small | x-small | small | medium | large | x-large | xx-large | larger | smaller | length
取值：
xx-small | : | 绝对字体尺寸。根据对象字体进行调整。最小
x-small | : | 绝对字体尺寸。根据对象字体进行调整。较小
small | : | 绝对字体尺寸。根据对象字体进行调整。小
medium | : | 默认值。绝对字体尺寸。根据对象字体进行调整。正常
large | : | 绝对字体尺寸。根据对象字体进行调整。大
x-large | : | 绝对字体尺寸。根据对象字体进行调整。较大
xx-large | : | 绝对字体尺寸。根据对象字体进行调整。最大
larger | : | 相对字体尺寸。相对于父对像中字体尺寸进行相对增大。使用成比例的 em 单位计算
smaller | : | 相对字体尺寸。相对于父对像中字体尺寸进行相对减小。使用成比例的 em 单位计算
length | : | 百分数 | 由浮点数字和单位标识符组成的长度值，不可为负值。其百分比取值是基于父对象中字体的尺寸。请参阅 长度单位
说明：
设置或检索对象中的字体尺寸。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 fontSize 。
示例：
p { font-style: normal; }
p { font-size: 12px; }
p { font-size: 20%; }


font-size-adjust版本：CSS2　 兼容性：无　继承性：有
语法：
font-size-adjust : none | number
取值：
none | : | 默认值。允许字体序列中每一字体遵守它的自己的尺寸
number | : | 为字体序列中所有字体强迫指定同一尺寸
说明：
设置或检索用于对象中文本的字体名称序列是否强制使用同一尺寸。
对应的脚本特性为 fontSizeAdjust 。
示例：
p { font-family: arial, courier; font-size-adjust: none; }
p { font-family: verdana, courier; font-size-adjust: .56; }


font-stretch版本：CSS2　 兼容性：无　继承性：有
语法：
font-stretch : normal | narrower | wider | ultra-condensed | extra-condensed | condensed | semi-condensed | semi-expanded | expanded | extra-expanded | ultra-expanded
取值：
normal | : | 默认值。不应用拉伸变形
narrower | : | 使用比当前设置的值导致字体宽度更小的值
wider | : | 使用比当前设置的值导致字体宽度更大的值
说明：
设置或检索用于对象中文本的文字是否横向的拉伸变形。
改变是相对于浏览器显示的字体的正常宽度的。
对应的脚本特性为 fontStretch 。
示例：
p { font-stretch: wider; }
p { font-stretch: ultra-expanded; }


font-style版本：CSS1　 兼容性：IE4+ NS4+　继承性：有
语法：
font-style : normal | italic | oblique
取值：
normal | : | 默认值。正常的字体
italic | : | 斜体。对于没有斜体变量的特殊字体，将应用 oblique
oblique | : | 倾斜的字体
说明：
设置或检索对象中的字体样式。
对于此属性的默认值来说，IE提供了预定义样式。但是你可以在浏览器菜单的 Internet 选项 中更改它。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 fontStyle 。
示例：
p { font-style: normal; }
p { font-style: italic; }
p { font-style: oblique; }


font-weight版本：CSS1　 兼容性：IE4+ NS4+　继承性：有
语法：
font-weight : normal | bold | bolder | lighter | 100 | 200 | 300 | 400 | 500 | 600 | 700 | 800 | 900
取值：
normal | : | 默认值。正常的字体。相当于 400 。声明此值将取消之前任何设置
bold | : | 粗体。相当于 700 。也相当于 b 对象的作用
bolder | : | 比 normal >粗
lighter | : | 比 normal >细
100 | : | 字体至少像 200 那样细
200 | : | 字体至少像 100 那样粗，像 300 那样细
300 | : | 字体至少像 200 那样粗，像 400 那样细
400 | : | 相当于 normal
500 | : | 字体至少像 400 那样粗，像 600 那样细
600 | : | 字体至少像 500 那样粗，像 700 那样细
700 | : | 相当于 bold
800 | : | 字体至少像 700 那样粗，像 900 那样细
900 | : | 字体至少像 800 那样粗
说明：
设置或检索对象中的文本字体的粗细。
作用由用户端系统安装的字体的特定字体变量映射决定。系统选择最近的匹配。也就是说，用户可能看不到不同值之间的差异。
IE4.0仅仅支持 normal 和 bold 值。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 fontWeight 。
示例：
span { font-weight:800; }


text-decoration版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
text-decoration : none || underline || blink || overline || line-through
取值：
none | : | 默认值。无装饰
blink | : | 闪烁
underline | : | 下划线
line-through | : | 贯穿线
overline | : | 上划线
说明：
检索或设置对象中的文本的装饰。
有 href 特性的 a ，以及 u ， ins 对象默认值为 underline 。
对象 strike ， s ， del ，默认值是 line-through 。
假如 none 值在属性声明的最后，所有的先前的其他取值都会被清除。例如，声明 text-decoration: underline overline blink none 等于声明 text-decoration: none 。
假如对象没有文本(如 img 元素)或者是空元素(如：<EM></EM>)， 此属性不会发生作用。
假如你设置 body 对象的此属性值为 none ， a 对象将依然保持其原有的下划线样式。除非你针对 a 对象声明此属性值。
指定块对象的此属性将影响其所有内联子对象。而此影响一旦发生，块对象容器最终会受到影响。
在IE4+中可用的值为 overline 和 blink 。虽然 blink 值被提供，但它不会被作用。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 textDecoration 。
示例：
div { text-decoration : underline; }
div { text-decoration : underline overline; }


text-underline-position版本：IE5.5+专有属性　继承性：有
语法：
text-underline-position : below | above
取值：
below | : | 默认值。在文本下面
above | : | 在文本上面
说明：
设置或检索 text-decoration 属性定义的下划线的位置。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 textUnderlinePosition 。
示例：
p { text-underline-position: above; text-decoration: underline; }


text-shadow版本：CSS2　 兼容性：无　继承性：无
语法：
text-shadow : color || length || length || opacity
取值：
color | : | 指定颜色。请参阅 颜色单位 和 附录：颜色表
length | : | 由浮点数字和单位标识符组成的长度值。可为负值。指定阴影的水平延伸距离。请参阅 长度单位
length | : | 由浮点数字和单位标识符组成的长度值。可为负值。指定阴影的垂直延伸距离。请参阅 长度单位
opacity | : | 由浮点数字和单位标识符组成的长度值。不可为负值。指定模糊效果的作用距离。如果你仅仅需要模糊效果，将前两个 length 全部设定为 0 。请参阅 长度单位
说明：
设置或检索对象中文本的文字是否有阴影及模糊效果。
可以设定多组效果，方式是用逗号隔开。
可以被用于伪类 :first-letter 和 :first-line 。
对应的脚本特性为 textShadow 。
示例：
p { text-shadow: 0px 0px 20px yellow, 0px 0px 10px orange, red 5px -5px; }
p:first-letter { font-size: 36px; color: red; text-shadow: red 0px 0px 5px;}


font-variant版本：CSS1　 兼容性：IE4+ NS6+　继承性：有
语法：
font-variant : normal | small-caps
取值：
normal | : | 默认值。正常的字体
small-caps | : | 小型的大写字母字体
说明：
设置或检索对象中的文本是否为小型的大写字母。
IE4.0将此属性的 small-caps 处理为大写字母的较小尺寸。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 fontVariant 。
示例：
span { font-variant: small-caps; }


text-transform版本：CSS1　 兼容性：IE4+ NS4+　继承性：有
语法：
text-transform : none | capitalize | uppercase | lowercase
取值：
none | : | 默认值。无转换发生
capitalize | : | 将每个单词的第一个字母转换成大写，其余无转换发生
uppercase | : | 转换成大写
lowercase | : | 转换成小写
说明：
检索或设置对象中的文本的大小写。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 textTransform 。
示例：
div { text-transform : uppercase; }


line-height版本：CSS1　 兼容性：IE4+ NS4+　继承性：有
语法：
line-height : normal | length
取值：
normal | : | 默认值。默认行高
length | : | 百分比数字 | 由浮点数字和单位标识符组成的长度值，允许为负值。其百分比取值是基于字体的高度尺寸。请参阅 长度单位
说明：
检索或设置对象的行高。即字体最底端与字体内部顶端之间的距离。
行高是字体下延与字体内部高度的顶端之间的距离。为负值的行高可用来实现阴影效果。
假如一个格式化的行包括不止一个对象，则最大行高会被应用。在这种情况下，此属性不可以为负值。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 lineHeight 。
示例：
div {line-height:6px; }
div {line-height:10.5; }


letter-spacing版本：CSS1　 兼容性：IE4+ NS6+　继承性：有
语法：
letter-spacing : normal | length
取值：
normal | : | 默认值。默认间隔
length | : | 由浮点数字和单位标识符组成的长度值，允许为负值。请参阅长度单位
说明：
检索或设置对象中的文字之间的间隔。
该属性将指定的间隔添加到每个文字之后，但最后一个字将被排除在外。
字符间距会受对齐调整影响。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 letterSpacing 。
示例：
div {letter-spacing:6px; }
div {letter-spacing:0.5pt; }


word-spacing版本：CSS1　 兼容性：IE6+ NS6+　继承性：有
语法：
word-spacing : normal | length
取值：
normal | : | 默认值。默认间隔
length | : | 由浮点数字和单位标识符组成的长度值，允许为负值。请参阅长度单位
说明：
检索或设置对象中的单词之间插入的空隔。
对于IE4+而言仅在MAC平台上可用。对于其他系统平台的支持由IE6开始。
单词间距会受对齐调整影响。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 wordSpacing 。
示例：
div { word-spacing : 10; }
div { word-spacing : 10px; }


text-indent版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
text-indent : length
取值：
length : 百分比数字 | 由浮点数字和单位标识符组成的长度值，允许为负值。请参阅 长度单位
说明：
检索或设置对象中的文本的缩进。默认值为 0 。
在被另一个对象(如 br )断开的对象内不能应用本属性。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 textIndent 。
示例：
DIV { text-indent:2cm }
.click1 { text-indent:50% }
.click2 { text-indent: }


text-overflow版本：IE6+专有属性　继承性：无
语法：
text-overflow : clip | ellipsis
取值：
clip | : | 默认值。不显示省略标记(...)，而是简单的裁切
ellipsis | : | 当对象内文本溢出时显示省略标记(...)
说明：
设置或检索是否使用一个省略标记(...)标示对象内文本的溢出。
这个属性仅仅作用于水平内联方向的，普通的西方文本的溢出。内联溢出发生在行内的文本超出可用宽度却没有换行机会的时候。
要强制溢出发生并且应用 ellipsis 值，作者必须设置对象的 white-space 属性值为 nowrap 。
假如没有换行机会(例如，对象容器的宽度是狭窄的，而内有很长的没有合理断行的文本)，没有应用 nowrap 也有可能溢出。
为了使 ellipsis 值被应用，此属性必须被设置到具有不可视区域的对象。最好的选择是设置 overflow 属性为 hidden 。设置 overflow 属性为 scroll 或者 auto 时，此属性也会应用。但是会有滚动条出现。
通过选择省略标记，隐藏的文本可以被选择。当选择发生时，省略标记会隐藏而被文本替换。
此属性为在DHTML中制作省略标记提供了高效的方法。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 textOverflow 。
示例：
div { overflow: hidden; text-overflow:ellipsis; }


vertical-align版本：CSS1/CSS2　 兼容性：IE4+ NS4+　继承性：无
语法：
vertical-align : auto | baseline | sub | super | top | text-top | middle | bottom | text-bottom | length
取值：
auto | : | CSS1 | 根据 layout-flow 属性的值对齐对象内容
baseline | : | CSS1 | 默认值。将支持 valign 特性的对象的内容与基线对齐
sub | : | CSS1 | 垂直对齐文本的下标
super | : | CSS1 | 垂直对齐文本的上标
top | : | CSS1 | 将支持 valign 特性的对象的内容对象顶端对齐
text-top | : | CSS1 | 将支持 valign 特性的对象的文本与对象顶端对齐
middle | : | CSS1 | 将支持 valign 特性的对象的内容与对象中部对齐
bottom | : | CSS1 | 将支持 valign 特性的对象的内容与对象底端对齐
text-bottom | : | CSS1 | 将支持 valign 特性的对象的文本与对象顶端对齐
length | : | CSS2 | 由浮点数字和单位标识符组成的长度值 | 百分数。可为负数。定义由基线算起的偏移量。基线对于数值来说为0，对于百分数来说就是0%。请参阅 长度单位 。目前IE尚未实现此参数
说明：
设置或检索对象内容的垂直对其方式。
对于 currentStyle 对象而言此属性的默认值为 auto 。对于其他对象而言是 baseline 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 verticalAlign 。
示例：
td { vertical-align : middle; }


text-align版本：CSS1　 兼容性：IE4+　继承性：有
语法：
text-align : left | right | center | justify
取值：
left | : | 默认值。左对齐
right | : | 右对齐
center | : | 居中对齐
justify | : | 两端对齐
说明：
设置或检索对象中文本的对齐方式。
此属性作用于所有块对象(block elements)。在一个 div 对象里的所有块对象的会继承此属性值。 假如属性没有设置，这个参数将获取 null 值。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 textAlign 。
示例：
div { text-align : center; }


layout-flow版本：IE5.5+专有属性　继承性：有
语法：
layout-flow : horizontal | vertical-ideographic
取值：
horizontal | : | 默认值。对象中的内容自左边流入。下一行在前一行下面。这个值适用于拉丁语系
vertical-ideographic | : | 对象中的内容自上而下流入，下一行在前一行左面。这个值适用于亚洲语系
说明：
设置或检索对象内文本的流动和方向。
当此属性值发生变化时， text-align 属性与 vertical-align 属性的作用也将发生变化。
这是一个不建议使用的属性。建议使用 writing-mode 属性替代它。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 layoutFlow 。
示例：
div { layout-flow : horizontal; }


writing-mode版本：IE5.5+专有属性　继承性：有
语法：
writing-mode : lr-tb | tb-rl
取值：
lr-tb | : | 默认值。对象中的内容在水平方向上从左向右流入，后一行在前一行的下面。 所有的字形都是竖直向上的。这种布局是罗马语系使用的
tb-rl | : | 上-下，右-左。对象中的内容在垂直方向上从上向下流入，自右向左。后一竖行在前一竖行的左面。全角字符是竖直向上的，半角字符如拉丁字母或片假名顺时针旋转90度。这种布局是东亚语系通常使用的
说明：
设置或检索对象的内容块固有的书写方向。西方语言确省的是左-右，上-下的书写方式。但是亚洲语言常有上-下，右-左的书写方式。
当此属性值发生变化时， text-align 属性与 vertical-align 属性的作用也将发生变化。
对于下列元素来说，样式表属性不可继承：
BUTTON CAPTION INPUT INPUT type=button INPUT type=file INPUT type=password INPUT type=reset INPUT type=submit INPUT type=text ISINDEX OPTION TEXTAREA

此属性效果不会被累积作用。例如，假如父对象的此属性值设为 tb-rl ，子对象的此属性值设为 tb-rl 不会导致子对象的旋转。
假如对象的 writing-mode 属性设置和它的父对象不一样则其将获得自己的布局。那样一个对象的宽度是通过使用它第一个有布局的父对象的高度而确定的。
当你使用具有不同 writing-mode 属性值的对象时，给每一个对象指定确定的尺寸能够让你更好的整体控制它们的布局。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 writingMode 。
示例：
div { writing-mode: tb-rl; }


direction版本：CSS2　 兼容性：IE5+　继承性：有
语法：
direction : ltr | rtl | inherit
取值：
ltr | : | 默认值。文本从左到右流入
rtl | : | 文本从右到左流入
inherit | : | 文本流入方向由继承获得
说明：
用于设置文本流入的方向。请参阅对象的 dir 属性。
此属性不会影响拉丁文的字母数字字符，它们总是以 ltr 值被呈递。但是此属性会作用于拉丁文的标点符号。
假如您想应用此属性于内联文本，您必须设定 unicode-bidi 属性为 embed 或 bidi-override 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 direction 。
示例：
div { direction: rtl; unicode-bidi: bidi-override; }


unicode-bidi版本：CSS2　 兼容性：IE5+　继承性：无
语法：
unicode-bidi : normal | bidi-override | embed
取值：
normal | : | 默认值。对象不打开附加的嵌入层，对于内联要素，隐式重排序跨对象边界进行工作
bidi-override | : | 严格按照 direction 属性的值重排序。忽略隐式双向运算规则
embed | : | 对象打开附加的嵌入层， direction 属性的值指定嵌入层，在对象内部进行隐式重排序
说明：
用于同一个页面里存在从不同方向读进的文本显示。与 direction 属性一起使用。
假如您想应用 direction 属性于内联文本，您必须设定此属性值为 embed 或 bidi-override 。
Unicode 双向运算法则自动翻转嵌入字符顺序依照它们固有的流动方向。例如，英文文档的默认书写方向是左-右，假如其中包含的部分其他语种的字符其书写方向是右-左，双向运算法则就可以用来代理用户正确的反转其流动方向。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 unicodeBidi 。
示例：
div { direction: rtl; unicode-bidi: bidi-override; }


word-break版本：IE5+专有属性　继承性：有
语法：
word-break : normal | break-all | keep-all
取值：
normal | : | 默认值。允许在词间换行
break-all | : | 该行为与亚洲语言的 normal 相同。也允许非亚洲语言文本行的任意字内断开。该值适合包含一些非亚洲文本的亚洲文本
keep-all | : | 与所有非亚洲语言的 normal 相同。对于中文，韩文，日文，不允许字断开。适合包含少量亚洲文本的非亚洲文本
说明：
设置或检索对象内文本的字内换行行为。尤其在出现多种语言时。
对于中文，应该使用 break-all 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 wordBreak 。
示例：
div {word-break : break-all; }


line-break版本：IE5+专有属性　继承性：有
语法：
line-break : normal | strict
取值：
normal | : | 默认值。应用日文文本的默认换行规则
strict | : | 强制日文文本换行规则的严谨性
说明：
设置或检索用于日文文本的换行规则。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 lineBreak 。
示例：
div { line-break : strict; }


white-space版本：CSS1　 兼容性：IE5.5+ NS4+　继承性：有
语法：
white-space : normal | pre | nowrap
取值：
normal | : | 默认值。默认处理方式。文本自动处理换行。假如抵达容器边界内容会转到下一行
pre | : | 换行和其他空白字符都将受到保护。这个值需要IE6+或者 !DOCTYPE 声明为 standards-compliant mode 支持。如果 !DOCTYPE 声明没有指定为 standards-compliant mode ，此属性可以使用，但是不会发生作用。结果等同于 normal 。参阅 pre 对象
nowrap | : | 强制在同一行内显示所有文本，直到文本结束或者遭遇 br 对象。参阅 noWrap 属性
说明：
设置或检索对象内空格字符的处理方式。
空格字符，像换行，空格，TAB，在HTML文档中默认的是被忽略的。当此属性设置为 normal 或者 nowrap 时，你可以使用不换行空格的命名实体 &nbsp; 来添加空格，用 br 元素来添加换行。 此属性对你使用文档对象模型(DOM)操作的内容的影响与其对IE显示内容的影响一样。
此属性作用于块对象。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 whiteSpace 。
示例：
p { white-space: nowrap; }


word-wrap版本：IE5.5+专有属性　继承性：有
语法：
word-wrap : normal | break-word
取值：
normal | : | 默认值。允许内容顶开指定的容器边界
break-word | : | 内容将在边界内换行。如果需要，词内换行( word-break )也将发生
说明：
设置或检索当当前行超过指定容器的边界时是否断开转行。
此属性仅作用于有布局的对象，如块对象。内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 wordWrap 。
示例：
div { word-wrap: break-word; word-break: break-all; }


text-autospace版本：IE5+专有属性　继承性：无
语法：
text-autospace : none | ideograph-alpha|ideograph-numeric | ideograph-parenthesis | ideograph-space
取值：
none | : | 默认值。无调整发生
ideograph-alpha | : | 在表意字和非表意字(如Latin-based，Greek，Cyrillic，Arabic，Hebrew文本)之间创建额外空格
ideograph-numeric | : | 在表意字和数字字符之间创建额外空格
ideograph-parenthesis | : | 在常规(非等宽)插入语和表意字之间创建额外空格
ideograph-space | : | 当空格相邻表意字符时，扩展空格的宽度
说明：
设置或检索对象文本的自动空格和紧缩空格宽度调整的方式。
表意字是东亚编写系统中的字符，表示一个概念或方法，但不是一个特定的字或词。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 textAutospace 。
示例：
div {text-autospace: ideograph-alpha; }


text-kashida-space版本：IE5.5+专有属性　继承性：有
语法：
text-kashida-space : length | inherit
取值：
length | : | 百分数。标示kashida膨胀与空格膨胀的比例。为100%，仅有kashida膨胀。为0%，仅有空格膨胀
inherit | : | 遵循父对象的设置
说明：
设置或检索如何拉伸字符来调节文本行排列。默认值为 0% 。
Kashida是一种印刷效果，通过在恰当的位置拉长字符来调整文本行。它通常用于阿拉伯书写系统。
此属性可以在任何应用Kashida样式的场合使用。例如 text-justify 属性值为 auto ， distribute ， kashida ， newspaper 时。
此属性仅作用于块对象。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 textKashidaSpace 。
示例：
div { text-kashida-space : 50%;text-justify: kashida; }


text-justify版本：IE5+专有属性　继承性：无
语法：
text-justify : auto | distribute | distribute-all-lines | distribute-center-last | inter-cluster | inter-ideograph | inter-word | kashida | newspaper
取值：
auto | : | 默认值。允许浏览器代理用户确定使用的两端对齐法则
distribute | : | 处理空格很像 newspaper ，适用于东亚文档。尤其是泰文
distribute-all-lines | : | 两端对齐行的方式与 distribute 相同，也同样不包含两段对齐段落的最后一行。适用于表意字文档
distribute-center-last | : | 未实现
inter-cluster | : | 调整文本无词间空格的行。这种模式的调整是用于优化亚洲语言文档的
inter-ideograph | : | 为表意字文本提供完全两端对齐。他增加或减少表意字和词间的空格
inter-word | : | 通过增加字之间的空格对齐文本。该行为是对齐所有文本行最快的方法。它的两端对齐行为对段落的最后一行无效
kashida | : | 通过拉长选定点的字符调整文本。这种调整模式是特别为阿拉伯脚本语言提供的。需要IE5.5+支持
newspaper | : | 通过增加或减少字或字母之间的空格对齐文本。是用于拉丁文字母表两端对齐的最精确格式
说明：
设置或检索对象内调整文本使用的对齐方式。
因为这个属性影响文本布局，所以 text-align 属性必须被设置为 justify 。
此属性只作用于块对象。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 textJustify 。
示例：
div {text-justify : auto; text-align:justify; }


ruby-align版本：IE5+专有属性　继承性：无
语法：
ruby-align : auto | left | center | right | distribute-letter | distribute-space | line-edge
取值：
auto | : | 默认值。由浏览器确定对齐方式。对于ideographic(东亚)文本以 distribute-space 值对齐。对于Latin文本以 center 值对齐
left | : | 根据基本宽度左对齐
center | : | 根据基本宽度居中对齐。如果基本宽度小于 ruby 文本的宽度，那么基本宽度在 ruby 文本的宽度中居中
right | : | 根据基本宽度右对齐
distribute-letter | : | 如果ruby文本的宽度小于基本宽度，则 ruby 文本在基本宽度中均匀分布。如果 ruby 文本的宽度大于或等于基本宽度，居中对齐
distribute-space | : | 如果 ruby 文本的宽度小于基本宽度，则 ruby 文本在基本宽度中均匀分布。在 ruby 文本中，在第一个字符的前面后最后字符的后面有半个字距的空白区域。如果 ruby 文本的宽度大于或等于基本宽度，居中对齐
line-edge | : | 如果 ruby 文本不相邻行边缘，则其被居中。否则 ruby 文本行在基本文本边的上方
说明：
设置或检索通过 rt 对象指定的注释文本或发音指南(参考 ruby 对象)的对齐位置。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 rubyAlign 。
示例：
ruby { ruby-align: right; }


ruby-overhang版本：IE5+专有属性　继承性：无
语法：
ruby-overhang : auto | whitespace | none
取值：
auto | : | 默认值。 ruby 文本突出相邻基本文本的任何其他文本
whitespace | : | ruby 文本只突出空白区域的字符
none | : | ruby 文本只突出相邻基本文本的任何其他文本
说明：
设置或检索通过 rt 对象指定的注释文本或发音指南(参考 ruby 对象)的位置。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 rubyOverhang 。
示例：
ruby { ruby-overhang: auto; }


ruby-position版本：IE5+专有属性　继承性：无
语法：
ruby-position : above | inline
取值：
above | : | 默认值。在基本文本上方定位 ruby 文本
inline | : | ruby 文本与基本文本内联
说明：
设置或检索通过 rt 对象指定的注释文本或发音指南(参考 ruby 对象)的位置。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 rubyPosition 。
示例：
ruby { ruby-position: above; }


ime-mode版本：IE5+专有属性　继承性：无
语法：
ime-mode : auto | active | inactive | disabled
取值：
auto | : | 默认值。不影响IME的状态。与不指定 ime-mode 属性时相同
active | : | 指定所有使用IME输入的字符。即激活本地语言输入法。用户仍可以撤销激活IME
inactive | : | 指定所有不使用IME输入的字符。即激活非本地语言。用户仍可以撤销激活IME
disabled | : | 完全禁用IME。对于有焦点的控件(如输入框)，用户不可以激活IME
说明：
设置或检索是否允许用户激活输入中文，韩文，日文等的输入法(IME)状态。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 imeMode 。
示例：
input {ime-mode: auto; }


layout-grid版本：IE5+专有属性　继承性：有
语法：
layout-grid : layout-grid-mode || layout-grid-type || layout-grid-line || layout-grid-char
取值：
该属性是复合属性。请参阅各参数对应的属性。
默认值为：both loose none none。
说明：
设置或检索复合文档中指定文本字符版式的网格特性。
以东亚语言(如中文，日文)编写的文档通常根据一维或二维网格使用字符的页面版式。
对应的脚本特性为 layoutGrid 。
示例：
div { layout-grid:both loose none none; }


layout-grid-char版本：IE5+专有属性　继承性：无
语法：
layout-grid-char : none | auto | length
取值：
none | : | 默认值。无字符网格设定
auto | : | 在对象文本中按最大的字符确定网格
length | : | 百分数 | 由浮点数字和单位标识符组成的长度值，其百分比取值是基于父对象尺寸。请参阅 长度单位
说明：
设置或检索应用于对象内容文本的字符网格尺寸。
其视觉效果类似于 line-height 属性。
以东亚语言(如中文，日文)写的文档通常根据一维或二维网格使用字符的页面版式。你可以用 layout-grid 属性将这种布局加入到网页文档中去。
此属性只应用于块对象(如 div )。
要使此属性发生作用， layout-grid-mode 属性值必须设置为 line 或 both 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 layoutGridChar 。
示例：
div { layout-grid-char: auto; }


layout-grid-line版本：IE5+专有属性　继承性：无
语法：
layout-grid-line : none | auto | length
取值：
none | : | 默认值。无行网格设定
auto | : | 在对象文本中按最大的字符确定网格
length | : | 百分数 | 由浮点数字和单位标识符组成的长度值，其百分比取值是基于父对象尺寸。请参阅 长度单位
说明：
设置或检索应用于对象文本的行网格尺寸。
其视觉效果类似于 line-height 属性。
以东亚语言(如中文，日文)写的文档通常根据一维或二维网格使用字符的页面版式。你可以用 layout-grid 属性将这种布局加入到网页文档中去。
此属性只应用于块对象(如 div )。
要使此属性发生作用， layout-grid-mode 属性值必须设置为 line 或 both 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 layoutGridLine 。
示例：
div { layout-grid-line: auto; }


layout-grid-mode版本：IE5+专有属性　继承性：有
语法：
layout-grid-mode : both | line | char | none
取值：
both | : | 默认值。指定 char 和 line 都被启用。要在一个对象上完全启用网格版式，此值是必须的
line | : | 指定只使用行网格。建议与内联对象(如 span )一起使用
char | : | 指定只使用字符网格。建议和块对象(如 div )一起使用
none | : | 不使用网格
说明：
设置或检索文本网格版式是否使用二维。
以东亚语言（如中文，日文）编写的文档通常根据一维或二维网格使用字符的页面版式。你可以用 layout-grid 属性将这种布局加入到网页文档中去。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 layoutGridMode 。
示例：
div { layout-grid-mode: char; }


layout-grid-type版本：IE5+专有属性　继承性：有
语法：
layout-grid-type : loose | strict | fixed
取值：
loose | : | 默认值。指定在中文或韩文中使用网格的文本，只有象形文字，假名，宽字符域网格对齐。其余的和通常一样，尽管包含这些字符的文本范围的 layout-grid-mode 被设置为 none 或 line 。该模式还禁用通常用于对象文本的特殊文本对齐和字符宽度调整。最后，如果不能再换行边界的文本中找到一个换行机会，那么文本将被推至下一行，并且上一行的最后留出空白
strict | : | 指定在日文中使用网格。规则为：如果没有其他的宽度调整效果，则增加宽字符以获取精确的网格填充。窄字符(除了草书字体)按照应用于宽字符的一半增量增加
fixed | : | 指定使用于等宽版式网格。规则为：所有非草书符号视为等宽。默认情况下，每个字符在单一网格中居中。禁止对齐或任何其他改变字符宽度的行为
说明：
设置或检索应用于对象文本的网格类型。
其视觉效果类似于 line-height 属性。
以东亚语言(如中文，日文)写的文档通常根据一维或二维网格使用字符的页面版式。你可以用 layout-grid 属性将这种布局加入到网页文档中去。
此属性只应用于块对象(如 div )。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 layoutGridType 。
示例：
div { layout-grid-type: strict; }


background版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
background : background-color || background-image || background-repeat || background-attachment || background-position
取值：
该属性是复合属性。请参阅各参数对应的属性。
默认值为：transparent none repeat scroll 0% 0%。
说明：
设置对象的背景样式。
如使用该复合属性定义其单个参数，则其他参数的默认值将无条件覆盖各自对应的单个属性设置。
例如：设置 background : white 等于设置 background : white none repeat scroll 0% 0% 。如果在此之前设置了 background-image 属性，则其设置将被 background-image 的默认值 none 覆盖。
背景样式属性的作用区域为对象的内容区域与内补丁( padding )区域。不包括边框( border )与外补丁( margin )区域。 尽管该属性不可继承，但如果未指定，其父对象的背景颜色和背景图将在对象下面显示。
对应的脚本特性为 background 。
示例：
div { background: red no-repeat scroll 5% 60%; }
body { background: url("images/aardvark.gif") repeat-y; }
pre { background: url("images/aardvark.gif") top; }
caption { background: fuchsia; }


background-attachment版本：CSS1　 兼容性：IE4+ NS6+　继承性：无
语法：
background-attachment : scroll | fixed
取值：
scroll | : | 默认值。背景图像是随对象内容滚动
fixed | : | 背景图像固定
说明：
设置或检索背景图像是随对象内容滚动还是固定的。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
请参阅 bgProperties 属性(特性)。 对应的脚本特性为 backgroundAttachment 。
示例：
html { background-image: url("anasazi.tif"); background-attachment: fixed; }
body { background-attachment: scroll; }


background-color版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
background-color : transparent | color
取值：
transparent | : | 默认值。背景色透明
color | : | 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置或检索对象的背景颜色。
当背景颜色与背景图像( background-image )都被设定了时，背景图片将覆盖于背景颜色之上。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 backgroundColor 。
示例：
p { background-color: silver }
div { background-color: rgb(223,71,177) }
body { background-color: #98AB6F }
pre { background-color: transparent; }


background-image版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
background-image : none | url ( url )
取值：
none | : | 默认值。无背景图
url ( url ) | : | 使用绝对或相对 url 地址指定背景图像
说明：
设置或检索对象的背景图像。
当背景图像与背景颜色( background-color )都被设定了时，背景图片将覆盖于背景颜色之上。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 backgroundImage 。
示例：
code { background-image: url("comet.jpg"); }
blockquote { background-image: url("c:\InetPub\MyPixs\comet.jpg"); }
br { background-image: url(http://Fred.com/ImageFile/Q.gif); }
body { background-image: none; }


background-position版本：CSS1　 兼容性：IE4+ NS6+　继承性：无
语法：
background-position : length || length
background-position : position || position
取值：
length | : | 百分数 | 由浮点数字和单位标识符组成的长度值。请参阅 长度单位
position | : | top | center | bottom | left | center | right
说明：
设置或检索对象的背景图像位置。必须先指定 background-image 属性。
该属性定位不受对象的补丁属性( padding )设置影响。
默认值为： 0% 0% 。此时背景图片将被定位于对象不包括补丁( padding )的内容区域的左上角。
如果只指定了一个值，该值将用于横坐标。纵坐标将默认为 50% 。如果指定了两个值，第二个值将用于纵坐标。
如果设置值为 right center ，因为 right 作为横坐标值将会覆盖 center 值，所以背景图片将被居右定位。
对应的脚本特性为 backgroundPosition 。
示例：
div { background: url("images/aardvark.gif"); background-position: 35% 80%; }
menu { background: url("images/aardvark.gif"); background-position: 35% 2.5cm; }
a { background: url("images/aardvark.gif"); background-position: 3.25in; }
body { background: url("images/aardvark.gif"); background-position: top right; }


background-position-x版本：IE4+专有属性　继承性：无
语法：
background-position-x : length | left | center | right
取值：
length | : | 百分数 | 由浮点数字和单位标识符组成的长度值。请参阅 长度单位
left | : | 居左
center | : | 居中
right | : | 居右
说明：
设置或检索对象的背景图像横坐标位置。必须先指定 background-image 属性。
该属性定位不受对象的补丁属性( padding )设置影响。
默认值为： 0% 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 backgroundPositionX 。
示例：
p { background-image: url("images/aardvark.gif"); background-position-x: 35%; background-repeat:no-repeat; }


background-position-y版本：IE4+专有属性　继承性：无
语法：
background-position-y : length | top | center | bottom
取值：
length | : | 百分数 | 由浮点数字和单位标识符组成的长度值。请参阅 长度单位
top | : | 居顶
center | : | 居中
bottom | : | 居底
说明：
设置或检索对象的背景图像纵坐标位置。必须先指定 background-image 属性。
该属性定位不受对象的补丁属性( padding )设置影响。
默认值为： 0% 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 backgroundPositionY 。
示例：
div { background-image: url("images/aardvark.gif"); background-position-y: 35%; background-repeat:no-repeat; }


background-repeat版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
background-repeat : repeat | no-repeat | repeat-x | repeat-y
取值：
repeat | : | 默认值。背景图像在纵向和横向上平铺
no-repeat | : | 背景图像不平铺
repeat-x | : | 背景图像仅在横向上平铺
repeat-y | : | 背景图像仅在纵向上平铺
说明：
设置或检索对象的背景图像是否及如何铺排。必须先指定对象的背景图像( background-image )。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 backgroundRepeat 。
示例：
menu { background: url("images/aardvark.gif"); background-repeat: repeat-y; }
p { background: url("images/aardvark.gif"); background-repeat: no-repeat; }


layer-background-color版本：NS4+专有属性　继承性：无
语法：
layer-background-color : transparent | color
取值：
transparent | : | 默认值。背景色透明
color | : | 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置或检索对象整个区域的背景颜色。
示例：
div { layer-background-color: transparent; }


layer-background-image版本：NS4+专有属性　继承性：无
语法：
layer-background-image : none | url ( url )
取值：
none | : | 默认值。无背景图
url ( url ) | : | 使用绝对或相对 url 地址指定背景图像
说明：
设置或检索对象整个区域的背景图像。
示例：
code { position: absolute; top: 100px; left: 300px; width: 200px; border: thin solid black; background-image: url("comet.jpg"); layer-background-image: url("bb_comet.jpg"); }


position版本：CSS2　 兼容性：IE4+ NS4+　继承性：无
语法：
position : static | absolute | fixed | relative
取值：
static | : | 默认值。无特殊定位，对象遵循HTML定位规则
absolute | : | 将对象从文档流中拖出，使用 left ， right ， top ， bottom 等属性相对于其最接近的一个最有定位设置的父对象进行绝对定位。如果不存在这样的父对象，则依据 body 对象。而其层叠通过 z-index 属性定义
fixed | : | 未支持。对象定位遵从绝对(absolute)方式。但是要遵守一些规范
relative | : | 对象不可层叠，但将依据 left ， right ， top ， bottom 等属性在正常文档流中偏移位置
说明：
检索对象的定位方式。
设置此属性值为 absolute 会将对象拖离出正常的文档流绝对定位而不考虑它周围内容的布局。假如其他具有不同 z-index 属性的对象已经占据了给定的位置，他们之间不会相互影响，而会在同一位置层叠。此时对象不具有外补丁( margin )，但仍有内补丁( padding )和边框( border )。
要激活对象的绝对(absolute)定位，必须指定 left ， right ， top ， bottom 属性中的至少一个，并且设置此属性值为 absolute 。否则上述属性会使用他们的默认值 auto ，这将导致对象遵从正常的HTML布局规则，在前一个对象之后立即被呈递。
设置此属性值为 relative 会保持对象在正常的HTML流中，但是它的位置可以根据它的前一个对象进行偏移。在相对(relative)定位对象之后的文本或对象占有他们自己的空间而不会覆盖被定位对象的自然空间。与此不同的，在绝对(absolute)定位对象之后的文本或对象在被定位对象被拖离正常文档流之前会占有它的自然空间。放置绝对(absolute)定位对象在可视区域之外会导致滚动条出现。而放置相对(relative)定位对象在可视区域之外，滚动条不会出现。
内容的尺寸会根据布局确定对象的尺寸。例如，设置一个 div 对象的 height 和 position 属性，则 div 对象的内容将决定它的宽度( width )。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 position 。
示例：
div { position:relative; top:-3px }


z-index版本：CSS2　 兼容性：IE4+ NS6+　继承性：无
语法：
z-index : auto | number
取值：
auto | : | 默认值。遵从其父对象的定位
number | : | 无单位的整数值。可为负数
说明：
检索或设置对象的层叠顺序。
较大 number 值的对象会覆盖在较小 number 值的对象之上。如两个绝对定位对象的此属性具有同样的 number 值，那么将依据它们在HTML文档中声明的顺序层叠。对于未指定此属性的绝对定位对象，此属性的 number 值为正数的对象会在其之上，而 number 值为负数的对象在其之下。设置参数为 null 可以移除此属性。
此属性仅仅作用于 position 属性值为 relative 或 absolute 的对象。
这个属性不会作用于窗口控件，如 select 对象。
在IE5.5+中， iframe 对象开始支持此属性。而在之前的浏览器版本中， iframe 对象是窗口控件，会忽略此属性。 此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 zIndex 。
示例：
div { position:absolute; z-index:3; width:6px; }


top版本：CSS2　 兼容性：IE4+ NS4+　继承性：无
语法：
top : auto | length
取值：
auto | : | 默认值。无特殊定位，根据HTML定位规则在文档流中分配
length | : | 由浮点数字和单位标识符组成的长度值 | 百分数。必须定义 position 属性值为 absolute 或者 relative 此取值方可生效。请参阅 长度单位
说明：
检索或设置对象与其最近一个具有定位设置的父对象顶边相关的位置。
此属性仅仅在对象的定位( position )属性被设置时可用。否则，此属性设置会被忽略。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 top 。其值为一字符串，所以不可用于脚本(Scripts)中的计算。请使用 style 对象的 posTop ， pixelTop 等运行时特性，以及对象的offsetTop 等特性。
示例：
div { position: absolute; top: 1in; }
div { position:relative; top:-3px; left:6px; }


right版本：CSS2　 兼容性：IE4+　继承性：无
语法：
right : auto | length
取值：
auto | : | 默认值。无特殊定位，根据HTML定位规则在文档流中分配
length | : | 由浮点数字和单位标识符组成的长度值 | 百分数。必须定义 position 属性值为 absolute 或者 relative 此取值方可生效。请参阅 长度单位
说明：
检索或设置对象与其最近一个具有定位设置的父对象右边相关的位置。
此属性仅仅在对象的定位( position )属性被设置时可用。否则，此属性设置会被忽略。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 right 。其值为一字符串，所以不可用于脚本(Scripts)中的计算。请使用 style 对象的 posRight ， pixelRight 等运行时特性。
示例：
div { position: absolute; right: 1in; }
div { position:relative; top:-3px; right:6px; }


bottom版本：CSS2　 兼容性：IE4+　继承性：无
语法：
bottom : auto | length
取值：
auto | : | 默认值。无特殊定位，根据HTML定位规则在文档流中分配
length | : | 由浮点数字和单位标识符组成的长度值 | 百分数。必须定义 position 属性值为 absolute 或者 relative 此取值方可生效。请参阅 长度单位
说明：
检索或设置对象与其最近一个具有定位设置的父对象底边相关的位置。
此属性仅仅在对象的定位( position )属性被设置时可用。否则，此属性设置会被忽略。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 bottom 。其值为一字符串，所以不可用于脚本(Scripts)中的计算。请使用 style 对象的 posBottom ， pixelBottom 等运行时特性。
示例：
div { position: absolute; bottom: 1in; }
div { position:relative; bottom:6px; }


left版本：CSS2　 兼容性：IE4+ NS4+　继承性：无
语法：
left : auto | length
取值：
auto | : | 默认值。无特殊定位，根据HTML定位规则在文档流中分配
length | : | 由浮点数字和单位标识符组成的长度值 | 百分数。必须定义 position 属性值为 absolute 或者 relative 此取值方可生效。请参阅 长度单位
说明：
检索或设置对象与其最近一个具有定位设置的父对象左边相关的位置。
此属性仅仅在对象的定位( position )属性被设置时可用。否则，此属性设置会被忽略。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 left 。其值为一字符串，所以不可用于脚本(Scripts)中的计算。请使用 style 对象的 posLeft ， pixelLeft 等运行时特性，以及对象的offsetLeft 等特性。
示例：
div { position: absolute; left: 1in; }
div { position:relative; top:-3px; left:6px; }


height版本：CSS1　 兼容性：IE4+ NS6+　继承性：无
语法：
height : auto | length
取值：
auto | : | 默认值。无特殊定位，根据HTML定位规则分配
length | : | 由浮点数字和单位标识符组成的长度值 | 百分数。百分数是基于父对象的高度。不可为负数。请参阅 长度单位
说明：
检索或设置对象的高度。
对于 img 对象来说，仅指定此属性，其 width 值将根据图片源尺寸等比例缩放。
按照样式表的规则，对象的实际高度为其下列属性值之和：
margin-top + border-top + padding-top + height + padding-bottom + border-bottom + margin-bottom
在IE6中使用 !DOCTYPE 声明指定 standards-compliant mode 可以实现这一点。
而在IE6中如果没有将 !DOCTYPE 声明指定 standards-compliant 模式，以及以前的浏览器版本，对象的实际高度等于：
margin-top + height+ margin-bottom
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 height 。其值为一字符串，所以不可用于脚本(Scripts)中的计算。请使用 style 对象的 posHeight ， pixelHeight ，以及对象的 offsetHeight 等特性。
示例：
div { height: 1in; }
div { position:absolute; top:-3px; height:6px; }


max-height版本：CSS2　 兼容性：无　继承性：无
语法：
max-height : none | length
取值：
auto | : | 默认值。无最大高度限制
length | : | 由浮点数字和单位标识符组成的长度值 | 或者百分数。不可为负数。请参阅 长度单位
说明：
设置或检索对象的最大高度。
如果此属性的值小于 min-height 属性的值，将会被自动转设为 min-height 属性的值。

对应的脚本特性为 maxHeight 。
示例：
p { max-height: 200%; }


min-height版本：CSS2　 兼容性：IE6+　继承性：无
语法：
min-height : none | length
取值：
auto | : | 默认值。无最小高度限制
length | : | 由浮点数字和单位标识符组成的长度值 | 或者百分数。不可为负数。请参阅 长度单位
说明：
设置或检索对象的最小高度。
如果此属性的值大于 max-height 属性的值，将会被自动转设为 max-height 属性的值。
在IE6中这个属性仅仅作用于固定布局的表格内的 td 对象， th 对象， tr 对象。表格的默认布局是自动计算的，要得到固定布局的表格，设置表格的 table-layout 属性的值为 fixed 。固定布局的算法比默认的自动算法要快很多。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。

对应的脚本特性为 minHeight 。
示例：
p { min-height: 200px; }


width版本：CSS1　 兼容性：IE4+ NS6+　继承性：无
语法：
width : auto | length
取值：
auto | : | 默认值。无特殊定位，根据HTML定位规则分配
length | : | 由浮点数字和单位标识符组成的长度值 | 百分数。百分数是基于父对象的宽度。不可为负数。请参阅 长度单位
说明：
检索或设置对象的宽度。
对于 img 来说，仅指定此属性，其 height 值将根据图片源尺寸等比例缩放。
按照样式表的规则，对象的实际宽度为其下列属性值之和：
margin-left + border-left + padding-left + width + padding-right + border-right + margin-right
在IE6中使用 !DOCTYPE 声明指定 standards-compliant 模式可以实现这一点。
而在IE6中如果没有将 !DOCTYPE 声明指定 standards-compliant mode，以及以前的浏览器版本，对象的实际宽度等于：
margin-left + width + margin-right
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 width 。其值为一字符串，所以不可用于脚本(Scripts)中的计算。请使用 style 对象的 posWidth ， pixelWidth ，以及对象的 offsetWidth 等特性。
示例：
div { width: 1in; }
div { position:absolute; top:-3px; width:6px; }


max-width版本：CSS2　 兼容性：无　继承性：无
语法：
max-width : none | length
取值：
auto | : | 默认值。无最大宽度限制
length | : | 由浮点数字和单位标识符组成的长度值 | 或者百分数。不可为负数。请参阅 长度单位
说明：
设置或检索对象的最大宽度。
如果此属性的值小于 minwidth 属性的值，将会被自动转设为 minwidth 属性的值。

对应的脚本特性为 maxWidth 。
示例：
p { min-width: 200px; }


min-width版本：CSS2　 兼容性：无　继承性：无
语法：
min-width : none | length
取值：
auto | : | 默认值。无最小宽度限制
length | : | 由浮点数字和单位标识符组成的长度值 | 或者百分数。不可为负数。请参阅 长度单位
说明：
设置或检索对象的最小宽度。
如果此属性的值大于 max-width 属性的值，将会被自动转设为 max-width 属性的值。

对应的脚本特性为 minWidth 。
示例：
p { min-width: 200px; }


clear版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
clear : none | left | right | both
取值：
none | : | 默认值。允许两边都可以有浮动对象
left | : | 不允许左边有浮动对象
right | : | 不允许右边有浮动对象
both | : | 不允许有浮动对象
说明：
该属性的值指出了不允许有浮动对象的边。请参阅 float 属性。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 clear 。
示例：
div { clear : left }
img { float: right }


float版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
float : none | left | right
取值：
none | : | 默认值。对象不飘浮
left | : | 文本流向对象的右边
right | : | 文本流向对象的左边
说明：
该属性的值指出了对象是否及如何浮动。请参阅 clear 属性。
当该属性不等于 none 引起对象浮动时，对象将被视作块对象( block-level )，即 display 属性等于 block 。也就是说，浮动对象的 display 属性将被忽略。
跟随浮动对象的对象将移动到浮动对象的位置。浮动对象会向左或向右移动直到遇到边框( border 、内补丁( padding 、外补丁( margin 或者另一个块对象( block-level )为止。
在IE5+中， div 和 span 对象假如没有指定宽度会被分配默认的宽度，而在此前的浏览器版本中则必须指定宽度值才可以呈递此属性。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 styleFloat 。
示例：
div { clear : left }
img { float: right }


clip版本：CSS2　 兼容性：IE4+ NS6+　继承性：无
语法：
clip : auto | rect ( number number number number )
取值：
auto | : | 默认值。对象无剪切
rect ( number number number number ) | : | 依据上-右-下-左的顺序提供自对象左上角为(0,0)坐标计算的四个偏移数值，其中任一数值都可用 auto 替换，即此边不剪切
说明：
检索或设置对象的可视区域。可视区域外的部分是透明的。
此属性定义了绝对(absolute)定位对象可视区域的尺寸。必须将 position 属性的值设为 absolute ，此属性方可使用。
自IE5开始，此属性在MAC平台上可用。
对应的脚本特性为 clip 。
示例：
div { position:absolute; width:60px; height:60px; clip:rect(0 20 50 10); }
div { position:absolute; width:60px; height:60px; clip:rect(1cm auto 50px 10cm); }


overflow版本：CSS2　 兼容性：IE4+ NS6+　继承性：无
语法：
overflow : visible | auto | hidden | scroll
取值：
visible | : | 默认值。不剪切内容也不添加滚动条。假如显式声明此默认值，对象将以包含对象的 window 或 frame 的尺寸裁切。并且 clip 属性设置将失效
auto | : | 在必需时对象内容才会被裁切或显示滚动条
hidden | : | 不显示超过对象尺寸的内容
scroll | : | 总是显示滚动条
说明：
检索或设置当对象的内容超过其指定高度及宽度时如何管理内容。
所有对象的默认值是 visible ，除了 textarea 对象和 body 对象的默认值是 auto 。设置 textarea 对象此属性值为 hidden 将隐藏其滚动条。
对于 table 来说，假如 table-layout 属性设置为 fixed ，则 td 对象支持带有默认值为 hidden 的 overflow 属性。如果设为 scroll 或者 auto ，那么超出 td 尺寸的内容将被剪切。如果设为 visible ，将导致额外的文本溢出到右边或左边（视 direction 属性设置而定）的单元格。
自IE5开始，此属性在MAC平台上可用。
自IE6开始，当你使用 !DOCTYPE 声明指定了 standards-compliant 模式，此属性可以应用于 html 对象。
对应的脚本特性为 overflow 。
示例：
body { overflow: hidden; }
div { overflow: scroll; height: 100px; width: 100px; }


overflow-x版本：IE4+专有属性　继承性：无
语法：
overflow-x : visible | auto | hidden | scroll
取值：
visible | : | 默认值。不剪切内容也不添加滚动条。假如显式声明此默认值，对象将以包含对象的 window 或 frame 的尺寸裁切。并且 clip 属性设置将失效
auto | : | 在必需时对象内容才会被裁切或显示横向滚动条
hidden | : | 不显示超过对象尺寸的内容
scroll | : | 总是显示横向滚动条
说明：
检索或设置当对象的内容超过其指定宽度时如何管理内容。
所有对象的默认值是 visible ，除了 textarea 对象和 body 对象的默认值是 auto 。设置 textarea 对象此属性值为 hidden 将隐藏其滚动条。
对于 table 来说，假如 table-layout 属性设置为 fixed ，则 td 对象支持带有默认值为 hidden 的 overflow 属性。如果设为 scroll 或者 auto ，那么超出 td 尺寸的内容将被剪切。如果设为 visible ，将导致额外的文本溢出到右边或左边（视 direction 属性设置而定）的单元格。
自IE5开始，此属性在MAC平台上可用。
自IE6开始，当你使用 !DOCTYPE 声明指定了 standards-compliant 模式，此属性可以应用于 html 对象。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 overflowX 。
示例：
body { overflow-x: hidden; }
div { overflow-x: scroll; height: 100px; width: 100px; }


overflow-y版本：IE4+专有属性　继承性：无
语法：
overflow-y : visible | auto | hidden | scroll
取值：
visible | : | 默认值。不剪切内容也不添加滚动条。假如显式声明此默认值，对象将以包含对象的 window 或 frame 的尺寸裁切。并且 clip 属性设置将失效
auto | : | 在必需时对象内容才会被裁切或显示纵向滚动条
hidden | : | 不显示超过对象尺寸的内容
scroll | : | 总是显示纵向滚动条
说明：
检索或设置当对象的内容超过其指定宽度时如何管理内容。
所有对象的默认值是 visible ，除了 textarea 对象和 body 对象的默认值是 auto 。设置 textarea 对象此属性值为 hidden 将隐藏其滚动条。
对于 table 来说，假如 table-layout 属性设置为 fixed ，则 td 对象支持带有默认值为 hidden 的 overflow 属性。如果设为 scroll 或者 auto ，那么超出 td 尺寸的内容将被剪切。如果设为 visible ，将导致额外的文本溢出到右边或左边（视 direction 属性设置而定）的单元格。
自IE5开始，此属性在MAC平台上可用。
自IE6开始，当你使用 !DOCTYPE 声明指定了 standards-compliant 模式，此属性可以应用于 html 对象。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 overflowY 。
示例：
body { : hidden; }
div { overflow-y: scroll; height: 100px; width: 100px; }


display版本：CSS1/CSS2　 兼容性：IE4+ NS4+　继承性：有
语法：
display : block | none | inline | compact | marker | inline-table | list-item | run-in | table | table-caption | table-cell | table-column | table-column-group | table-footer-group | table-header-group | table-row | table-row-group
取值：
block | : | CSS1 | 块对象的默认值。将对象强制作为块对象呈递，为对象之后添加新行
none | : | CSS1 | 隐藏对象。与 visibility 属性的hidden值不同，其不为被隐藏的对象保留其物理空间
inline | : | CSS1 | 内联对象的默认值。将对象强制作为内联对象呈递，从对象中删除行
inline-block | : | IE5.5 | 将对象呈递为内联对象，但是对象的内容作为块对象呈递。旁边的内联对象会被呈递在同一行内
compact | : | CSS2 | 未支持。分配对象为块对象或基于内容之上的内联对象
marker | : | CSS2 | 未支持。指定内容在容器对象之前或之后。要使用此参数，对象必须和 :after 及 :before 伪元素一起使用
inline-table | : | CSS2 | 未支持。将表格显示为无前后换行的内联对象或内联容器
list-item | : | CSS2 | 将块对象指定为列表项目。并可以添加可选项目标志
run-in | : | CSS2 | 未支持。分配对象为块对象或基于内容之上的内联对象
table | : | CSS2 | 未支持。将对象作为块元素级的表格显示
table-caption | : | CSS2 | 未支持。将对象作为表格标题显示
table-cell | : | CSS2 | 未支持。将对象作为表格单元格显示
table-column | : | CSS2 | 未支持。将对象作为表格列显示
table-column-group | : | CSS2 | 未支持。将对象作为表格列组显示
table-header-group | : | CSS2 | 将对象作为表格标题组显示
table-footer-group | : | CSS2 | 将对象作为表格脚注组显示
table-row | : | CSS2 | 未支持。将对象作为表格行显示
table-row-group | : | CSS2 | 未支持。将对象作为表格行组显示
说明：
设置或检索对象是否及如何显示。
对于下列元素来说，此属性的默认值为 block ：
ADDRESS QUOTE BODY XMP CENTER COL COLGROUP DD DIR DIV DL DT FIELDSET FORM Hn HR IFRAME LEGEND LISTING MARQUEE MENU OL P PLAINTEXT PRE TABLE TD TH TR UL

对于下列元素来说，此属性的默认值为 none ：
BR FRAME nextID TBODY TFOOT THEAD

对于下列元素来说，此属性的默认值为 list-item ：
LI

其他元素默认值都是 inline 。
在IE6.0以前的版本中， LI 对象的默认值为 block 。
在IE4.0中， block ， inline ， list-item 值不被支持。但是对象仍然会被呈递。
在IE5.0中开始支持 block 和 inline 。
在IE5.5中开始支持 inline-block 。你可以使用 inline-block 使对象获得布局而无需指定确切的高( height )和宽( width )。
在IE6.0中开始支持 list-item 。
所有可视的文档对象都是块对象(block element)或者内联对象(inline element)。例如， div 是一个块对象。 span 是一个内联对象。块对象的特征是从新的一行开始且能包含其他块对象和内联对象。内联对象被呈递时不会从新行开始，能够包含其他内联对象和数据。
改变此属性值对其周围内容布局的影响可能是：
  • 在属性值设为 block 的对象后面添加新行。
  • 从属性值设为 inline 的对象中删除一行。
  • 隐藏属性值设为 none 的对象并释放其在文档中的物理空间。
table-header-group 和 table-footer-group 属性值可用来指定当表格( table )跨越了多页时， tHead 和 tFoot 对象的内容在每一页都显示。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为display。
示例：
img { disply: block; float: right; }


visibility版本：CSS2　 兼容性：IE4+ NS6+　继承性：无
语法：
visibility : inherit | visible | collapse | hidden
取值：
inherit | : | 默认值。继承父对象的可见性
visible | : | 对象可视
collapse | : | 未支持。主要用来隐藏表格的行或列。隐藏的行或列能够被其他内容使用。对于表格外的其他对象，其作用等同于 hidden
hidden | : | 对象隐藏
说明：
设置或检索是否显示对象。
与 display 属性不同，此属性为隐藏的对象保留其占据的物理空间。
在IE5.0+中，当父对象不可视时子对象是能被设为可视的。而在此前的浏览器版本中，如果希望对象为可视，其父对象也必须是可视的。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 visibility 。
示例：
img { visibility: inherit; float: right; }


margin版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
margin : auto | length
取值：
auto | : | 取计算机值
length | : | 由浮点数字和单位标识符组成的长度值 | 百分数。百分数是基于父对象的高度。除了内联对象的上下外补丁外，支持使用负数值。请参阅 长度单位
说明：
检索或设置对象四边的外补丁。默认值为 0 0。
如果提供全部四个参数值，将按上－右－下－左的顺序作用于四边。如果只提供一个，将用于全部的四边。如果提供两个，第一个用于上－下，第二个用于左－右。如果提供三个，第一个用于上，第二个用于左－右，第三个用于下。
在IE4.0+中你可以使用 em 和 ex 单位。
在IE4.0+中此属性不支持用于 td 和 th 对象。要设置单元格内的外补丁，请使用单元格内的如 div 、 p 等类型对象的此属性。
在IE5.5+中此属性支持内联对象使用。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对于内联对象来说，上下外补丁如果被设置了，将是用于计算环绕内联对象的边框区域的。它们的值不会影响内联对象所在行的高度( height )。
外补丁总是透明( transparent )的。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 margin 。
示例：
body { margin: 36pt 24pt 36pt; }
body { margin: 11.5%; }
body { margin: 10% 10% 10% 10%; }


margin-top版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
margin-top : auto | length
取值：
auto | : | 取计算机值
length | : | 由浮点数字和单位标识符组成的长度值 | 百分数。百分数是基于父对象的高度。除了内联对象外支持使用负数值。请参阅 长度单位
说明：
检索或设置对象顶边的外补丁。
在IE4.0+中你可以使用 em 和 ex 单位。
在IE4.0+中此属性不支持用于 td 和 th 对象。要设置单元格内的外补丁，请使用单元格内的如 div 、 p 等类型对象的此属性。
在IE5.5+中此属性支持内联对象使用。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对于内联对象来说，此属性被提供的值是用于计算环绕内联对象的边框区域的。不会影响内联对象所在行的高度( height )。
外补丁总是透明( transparent )的。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 marginTop 。
示例：
body { margin: 36pt 24pt 36pt; }
body { margin-top: 11.5%; }
body { margin: 10% 10% 10% 10%; }


margin-right版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
margin-right : auto | length
取值：
auto | : | 取计算机值
length | : | 由浮点数字和单位标识符组成的长度值 | 百分数。百分数是基于父对象的高度。支持使用负数值。请参阅 长度单位
说明：
检索或设置对象右边的外补丁。
在IE4.0+中你可以使用 em 和 ex 单位。
在IE4.0+中此属性不支持用于 td 和 th 对象。要设置单元格内的外补丁，请使用单元格内的如 div 、 p 等类型对象的此属性。
在IE5.5+中此属性支持内联对象使用。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
外补丁总是透明( transparent )的。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 marginBottom 。
示例：
body { margin: 36pt 24pt 36pt; }
body { margin: 11.5%; }
body { margin: 10% 10% 10% 10%; }


margin-bottom版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
margin-bottom : auto | length
取值：
auto | : | 取计算机值
length | : | 由浮点数字和单位标识符组成的长度值 | 百分数。百分数是基于父对象的高度。除了内联对象外支持使用负数值。请参阅 长度单位
说明：
检索或设置对象底边的外补丁。
在IE4.0+中你可以使用 em 和 ex 单位。
在IE4.0+中此属性不支持用于 td 和 th 对象。要设置单元格内的外补丁，请使用单元格内的如 div 、 p 等类型对象的此属性。
在IE5.5+中此属性支持内联对象使用。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对于内联对象来说，此属性被提供的值是用于计算环绕内联对象的边框区域的。不会影响内联对象所在行的高度( height )。
外补丁总是透明( transparent )的。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 marginBottom 。
示例：
body { margin: 36pt 24pt 36pt; }
body { margin: 11.5%; }
body { margin: 10% 10% 10% 10%; }


margin-left版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
margin-left : auto | length
取值：
auto | : | 取计算机值
length | : | 由浮点数字和单位标识符组成的长度值 | 百分数。百分数是基于父对象的高度。支持使用负数值。请参阅 长度单位
说明：
检索或设置对象左边的外补丁。
在IE4.0+中你可以使用 em 和 ex 单位。
在IE4.0+中此属性不支持用于 td 和 th 对象。要设置单元格内的外补丁，请使用单元格内的如 div 、 p 等类型对象的此属性。
在IE5.5+中此属性支持内联对象使用。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
外补丁总是透明( transparent )的。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 marginBottom 。
示例：
body { margin: 36pt 24pt 36pt; }
body { margin: 11.5%; }
body { margin: 10% 10% 10% 10%; }


outline版本：CSS2　 兼容性：无　继承性：无
语法：
outline : outline-color || outline-style || outline-width
取值：
该属性是复合属性。请参阅各参数对应的属性。
说明：
设置或检索对象外的线条轮廓。外轮廓( outline )画在边框( border )外面，并且不一定是矩形。
对应的脚本特性为 outline 。
示例：
img { outline: red }
p { outline: double 5px }
button { outline: #E9E9E9 double thin }


outline-color版本：CSS2　 兼容性：无　继承性：无
语法：
outline-color : color | invert
取值：
color | : | 指定颜色。请参阅 颜色单位 和 附录：颜色表
invert | : | 默认值。使用背景色的反色
说明：
设置或检索对象外的线条轮廓( outline )的颜色。参见属性。
对应的脚本特性为 outlineColor 。
示例：
img { outline-color: red }
p { outline-color: #E9E9E9 }


outline-style版本：CSS2　 兼容性：无　继承性：无
语法：
outline-style : none | dotted | dashed | solid | double | groove | ridge | inset | outset
取值：
none | : | 默认值。无边框。与任何指定的 outline-width 值无关
dotted | : | 点线外轮廓
dashed | : | 虚线外轮廓
solid | : | 实线外轮廓
double | : | 双线外轮廓。两条单线与其间隔的和等于指定的 oueline-width 值
groove | : | 根据 outline-color 的值画3D凹槽外轮廓
ridge | : | 根据 outline-color 的值画3D凸槽外轮廓
inset | : | 根据 outline-color 的值画3D凹边外轮廓
outset | : | 根据 outline-color 的值画3D凸边外轮廓
说明：
设置或检索对象外的线条轮廓( outline )的样式。
对应的脚本特性为 outlineStyle 。
示例：
img { outline-color: orange; outline-style: solid ; outline-width: medium ; }


outline-width版本：CSS2　 兼容性：无　继承性：无
语法：
outline-width : medium | thin | thick | length
取值：
medium | : | 默认值。默认宽度
thin | : | 小于默认宽度
thick | : | 大于默认宽度
length | : | 由浮点数字和单位标识符组成的长度值。不可为负值。请参阅 长度单位
说明：
设置或检索对象外的线条轮廓( outline )的宽度。
对应的脚本特性为 outlineWidth 。
示例：
img { outline-color: orange; outline-style: solid ; outline-width: medium ; }


border版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
border : border-width || border-style || border-color
取值：
该属性是复合属性。请参阅各参数对应的属性。
默认值为： medium none 。 border-color 的默认值将采用文本颜色。
说明：
设置对象的边框样式。
当你指定了边框颜色( border-color )和边框宽度( border-width )时，你必须同时指定边框样式( border-style )，否则边框不会被呈现。
如使用该复合属性定义其单个参数，则其他参数的默认值将无条件覆盖各自对应的单个属性设置。
例如：设置 border : thin 等于设置 border : thin none ，而 border-color 的默认值将采用文本颜色。因此此前的任何 border-color 和 border-width 设置都会被清除。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对应的脚本特性为 border 。
示例：
p { border: thick double yellow; }
blockquote { border: dotted gray; }
p { border: 25px; }


border-color版本：CSS1　 兼容性：IE4+ NS6+　继承性：无
语法：
border-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置对象边框的颜色。
如果提供全部四个参数值，将按上－右－下－左的顺序作用于四个边框。如果只提供一个，将用于全部的四条边。如果提供两个，第一个用于上－下，第二个用于左－右。如果提供三个，第一个用于上，第二个用于左－右，第三个用于下。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
如果 border-style 设置为 none ，本属性将失去作用。
对应的脚本特性为 borderColor 。
示例：
ody { border-color: silver ;red; }
body { border-color: silver red RGB(223, 94, 77); }
body { border-color: silver red RGB(223, 94, 77) black; }


border-style版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
border-style : none | hidden | dotted | dashed | solid | double | groove | ridge | inset | outset
取值：
none | : | 默认值。无边框。不受任何指定的 border-width 值影响
hidden | : | 隐藏边框。IE不支持
dotted | : | 在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为点线。否则为实线
dashed | : | 在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为虚线。否则为实线
solid | : | 实线边框
double | : | 双线边框。两条单线与其间隔的和等于指定的 border-width 值
groove | : | 根据 border-color 的值画3D凹槽
ridge | : | 根据 border-color 的值画3D凸槽
inset | : | 根据 border-color 的值画3D凹边
outset | : | 根据 border-color 的值画3D凸边
说明：
设置对象边框的样式。
如果提供全部四个参数值，将按上－右－下－左的顺序作用于四个边框。如果只提供一个，将用于全部的四条边。如果提供两个，第一个用于上－下，第二个用于左－右。如果提供三个，第一个用于上，第二个用于左－右，第三个用于下。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对应的脚本特性为 borderStyle 。
示例：
body { border-style: double groove; }
body { border-style: double groove dashed; }


border-width版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
border-width : medium | thin | thick | length
取值：
medium | : | 默认值。默认宽度
thin | : | 小于默认宽度
thick | : | 大于默认宽度
length | : | 由浮点数字和单位标识符组成的长度值。不可为负值。请参阅 长度单位
说明：
设置对象边框的宽度。
如果提供全部四个参数值，将按上－右－下－左的顺序作用于四个边框。如果只提供一个，将用于全部的四条边。如果提供两个，第一个用于上－下，第二个用于左－右。如果提供三个，第一个用于上，第二个用于左－右，第三个用于下。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
如果 border-style 设置为 none ，本属性将失去作用。
对应的脚本特性为 borderWidth 。
示例：
div { border-style: solid; border-width: thin; }
span { display: block; border-style: solid; border-width: 1px thin; }
p { border-color: #000000; border-width: 1px 1px 2px 3px; }


border-top版本：CSS1　 兼容性：IE4+ NS6+　继承性：无
语法：
border-top : border-width || border-style || border-color
取值：
该属性是复合属性。请参阅各参数对应的属性。
默认值为： medium none 。 border-color 的默认值将采用文本颜色。
说明：
设置对象上边框的样式。
当你指定了边框颜色( border-top-color )和边框宽度( border-top-width )时，你必须同时指定边框样式( border-top-style )，否则边框不会被呈现。
如使用该复合属性定义其单个参数，则其他参数的默认值将无条件覆盖各自对应的单个属性设置。
例如：设置 border-top : thin 等于设置 border-top : thin none ，而 border-top-color 的默认值将采用文本颜色。因此此前的任何 border-top-color 和 border-top-width 设置都会被清除。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对应的脚本特性为 borderTop 。
示例：
div { border-bottom: 25px solid red; border-left: 25px solid yellow; border-right: 25px solid blue; border-top: 25px solid green; }


border-top-color版本：CSS2　 兼容性：IE4+ NS6+　继承性：无
语法：
border-top-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置对象上边框的颜色。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
如果 border-top-style 设置为 none 或 border-top-width 设置为 0 ，本属性将失去作用。
对应的脚本特性为 borderTopColor 。
示例：
div { border-top-color: red; border-bottom-color: RGB(223, 94, 77); border-right-color: red; border-left-color: black;}


border-top-style版本：CSS2　 兼容性：IE4+ NS6+　继承性：无
语法：
border-top-style : none | hidden | dotted | dashed | solid | double | groove | ridge | inset | outset
取值：
none | : | 默认值。无边框。不受任何指定的 border-width 值影响
hidden | : | 隐藏边框。IE不支持
dotted | : | 在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为点线。否则为实线
dashed | : | 在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为虚线。否则为实线
solid | : | 实线边框
double | : | 双线边框。两条单线与其间隔的和等于指定的 border-width 值
groove | : | 根据 border-color 的值画3D凹槽
ridge | : | 根据 border-color 的值画菱形边框
inset | : | 根据 border-color 的值画3D凹边
outset | : | 根据 border-color 的值画3D凸边
说明：
设置对象上边框的样式。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
如果 border-top-width 设置为 0 ，本属性将失去作用。
对应的脚本特性为 borderTopStyle 。
示例：
body { border-top-style: double; border-bottom-style: groove; border-left-style: dashed; border-right-style: dotted; }


border-top-width版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
border-top-width : medium | thin | thick | length
取值：
medium | : | 默认值。默认宽度
thin | : | 小于默认宽度
thick | : | 大于默认宽度
length | : | 由浮点数字和单位标识符组成的长度值。不可为负值。请参阅 长度单位
说明：
设置对象上边框的宽度。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对应的脚本特性为 borderTopWidth 。
示例：
span { border-top-width: thin; border-top-style: solid; }
span { border-bottom-width: thin; border-bottom-style: solid; }
span { border-left-width: thin; border-left-style: solid; }
span { border-right-width: thin; border-right-style: solid; }


border-right版本：CSS1　 兼容性：IE4+ NS6+　继承性：无
语法：
border-right : border-width || border-style || border-color
取值：
该属性是复合属性。请参阅各参数对应的属性。
默认值为： medium none 。 border-color 的默认值将采用文本颜色。
说明：
设置对象右边框的样式。
当你指定了边框颜色( border-right-color )和边框宽度( border-right-width )时，你必须同时指定边框样式( border-right-style )，否则边框不会被呈现。
如使用该复合属性定义其单个参数，则其他参数的默认值将无条件覆盖各自对应的单个属性设置。
例如：设置 border-right : thin 等于设置 border-right : thin none ，而 border-right-color 的默认值将采用文本颜色。因此此前的任何 border-right-color 和 border-right-width 设置都会被清除。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对应的脚本特性为 borderRight 。
示例：
div { border-bottom: 25px solid red; border-left: 25px solid yellow; border-right: 25px solid blue; border-top: 25px solid green; }


border-right-color版本：CSS2　 兼容性：IE4+ NS6+　继承性：无
语法：
border-right-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置对象右边框的颜色。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
如果 border-right-style 设置为 none 或 border-right-width 设置为 0 ，本属性将失去作用。
对应的脚本特性为 borderRightColor 。
示例：
div { border-top-color: red; border-bottom-color: RGB(223, 94, 77); border-right-color: red; border-left-color: black;}


border-right-style版本：CSS2　 兼容性：IE4+ NS6+　继承性：无
语法：
border-right-style : none | hidden | dotted | dashed | solid | double | groove | ridge | inset | outset
取值：
none | : | 默认值。无边框。不受任何指定的 border-width 值影响
hidden | : | 隐藏边框。IE不支持
dotted | : | 在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为点线。否则为实线
dashed | : | 在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为虚线。否则为实线
solid | : | 实线边框
double | : | 双线边框。两条单线与其间隔的和等于指定的 border-width 值
groove | : | 根据 border-color 的值画3D凹槽
ridge | : | 根据 border-color 的值画菱形边框
inset | : | 根据 border-color 的值画3D凹边
outset | : | 根据 border-color 的值画3D凸边
说明：
设置对象右边框的样式。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
如果 border-right-width 设置为 0 ，本属性将失去作用。
对应的脚本特性为 borderRightStyle 。
示例：
body { border-top-style: double; border-bottom-style: groove; border-left-style: dashed; border-right-style: dotted; }


border-right-width版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
border-right-width : medium | thin | thick | length
取值：
medium | : | 默认值。默认宽度
thin | : | 小于默认宽度
thick | : | 大于默认宽度
length | : | 由浮点数字和单位标识符组成的长度值。不可为负值。请参阅 长度单位
说明：
设置对象右边框的宽度。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对应的脚本特性为 borderRightWidth 。
示例：
span { border-top-width: thin; border-top-style: solid; }
span { border-bottom-width: thin; border-bottom-style: solid; }
span { border-left-width: thin; border-left-style: solid; }
span { border-right-width: thin; border-right-style: solid; }


border-bottom版本：CSS1　 兼容性：IE4+ NS6+　继承性：无
语法：
border-bottom : border-width || border-style || border-color
取值：
该属性是复合属性。请参阅各参数对应的属性。
默认值为： medium none 。 border-color 的默认值将采用文本颜色。
说明：
设置对象下边框的样式。
当你指定了边框颜色( border-bottom-color )和边框宽度( border-bottom-width )时，你必须同时指定边框样式( border-bottom-style )，否则边框不会被呈现。
如使用该复合属性定义其单个参数，则其他参数的默认值将无条件覆盖各自对应的单个属性设置。
例如：设置 border-bottom : thin 等于设置 border-bottom : thin none ，而 border-bottom-color 的默认值将采用文本颜色。因此此前的任何 border-bottom-color 和 border-bottom-width 设置都会被清除。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对应的脚本特性为 borderBottom 。
示例：
div { border-bottom: 25px solid red; border-left: 25px solid yellow; border-right: 25px solid blue; border-top: 25px solid green; }


border-bottom-color版本：CSS2　 兼容性：IE4+ NS6+　继承性：无
语法：
border-bottom-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置对象下边框的颜色。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
如果 border-bottom-style 设置为 none 或 border-bottom-width 设置为 0 ，本属性将失去作用。
对应的脚本特性为 borderBottomColor 。
示例：
div { border-top-color: red; border-bottom-color: RGB(223, 94, 77); border-right-color: red; border-left-color: black;}


border-bottom-style版本：CSS2　 兼容性：IE4+ NS6+　继承性：无
语法：
border-bottom-style : none | hidden | dotted | dashed | solid | double | groove | ridge | inset | outset
取值：
none | : | 默认值。无边框。不受任何指定的 border-width 值影响
hidden | : | 隐藏边框。IE不支持
dotted | : | 在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为点线。否则为实线
dashed | : | 在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为虚线。否则为实线
solid | : | 实线边框
double | : | 双线边框。两条单线与其间隔的和等于指定的 border-width 值
groove | : | 根据 border-color 的值画3D凹槽
ridge | : | 根据 border-color 的值画菱形边框
inset | : | 根据 border-color 的值画3D凹边
outset | : | 根据 border-color 的值画3D凸边
说明：
设置对象下边框的样式。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
如果 border-bottom-width 设置为 0 ，本属性将失去作用。
对应的脚本特性为 borderBottomStyle 。
示例：
body { border-top-style: double; border-bottom-style: groove; border-left-style: dashed; border-right-style: dotted; }


border-bottom-width版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
border-bottom-width : medium | thin | thick | length
取值：
medium | : | 默认值。默认宽度
thin | : | 小于默认宽度
thick | : | 大于默认宽度
length | : | 由浮点数字和单位标识符组成的长度值。不可为负值。请参阅 长度单位
说明：
设置对象下边框的宽度。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对应的脚本特性为 borderBottomWidth 。
示例：
span { border-top-width: thin; border-top-style: solid; }
span { border-bottom-width: thin; border-bottom-style: solid; }
span { border-left-width: thin; border-left-style: solid; }
span { border-right-width: thin; border-right-style: solid; }


border-left版本：CSS1　 兼容性：IE4+ NS6+　继承性：无
语法：
border-left : border-width || border-style || border-color
取值：
该属性是复合属性。请参阅各参数对应的属性。
默认值为： medium none 。 border-color 的默认值将采用文本颜色。
说明：
设置对象左边框的样式。
当你指定了边框颜色( border-left-color )和边框宽度( border-left-width )时，你必须同时指定边框样式( border-left-style )，否则边框不会被呈现。
如使用该复合属性定义其单个参数，则其他参数的默认值将无条件覆盖各自对应的单个属性设置。
例如：设置 border-left : thin 等于设置 border-left : thin none ，而 border-left-color 的默认值将采用文本颜色。因此此前的任何 border-left-color 和 border-left-width 设置都会被清除。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对应的脚本特性为 borderLeft 。
示例：
div { border-bottom: 25px solid red; border-left: 25px solid yellow; border-right: 25px solid blue; border-top: 25px solid green; }


border-left-color版本：CSS2　 兼容性：IE4+ NS6+　继承性：无
语法：
border-left-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置对象左边框的颜色。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
如果 border-left-style 设置为 none 或 border-left-width 设置为 0 ，本属性将失去作用。
对应的脚本特性为 borderLeftColor 。
示例：
div { border-top-color: red; border-bottom-color: RGB(223, 94, 77); border-right-color: red; border-left-color: black;}


border-left-style版本：CSS2　 兼容性：IE4+ NS6+　继承性：无
语法：
border-left-style : none | hidden | dotted | dashed | solid | double | groove | ridge | inset | outset
取值：
none | : | 默认值。无边框。不受任何指定的 border-width 值影响
hidden | : | 隐藏边框。IE不支持
dotted | : | 在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为点线。否则为实线
dashed | : | 在MAC平台上IE4+与WINDOWS和UNIX平台上IE5.5+为虚线。否则为实线
solid | : | 实线边框
double | : | 双线边框。两条单线与其间隔的和等于指定的 border-width 值
groove | : | 根据 border-color 的值画3D凹槽
ridge | : | 根据 border-color 的值画菱形边框
inset | : | 根据 border-color 的值画3D凹边
outset | : | 根据 border-color 的值画3D凸边
说明：
设置对象左边框的样式。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
如果 border-left-width 设置为 0 ，本属性将失去作用。
对应的脚本特性为 borderLeftStyle 。
示例：
body { border-top-style: double; border-bottom-style: groove; border-left-style: dashed; border-right-style: dotted; }


border-left-width版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
border-left-width : medium | thin | thick | length
取值：
medium | : | 默认值。默认宽度
thin | : | 小于默认宽度
thick | : | 大于默认宽度
length | : | 由浮点数字和单位标识符组成的长度值。不可为负值。请参阅 长度单位
说明：
设置对象左边框的宽度。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
在 IE5.5+ 中，边框属性可以直接应用于内联要素。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
对应的脚本特性为 borderLeftWidth 。
示例：
span { border-top-width: thin; border-top-style: solid; }
span { border-bottom-width: thin; border-bottom-style: solid; }
span { border-left-width: thin; border-left-style: solid; }
span { border-right-width: thin; border-right-style: solid; }


include-source版本：CSS2　 兼容性：无　继承性：无
语法：
include-source : url ( url )
取值：
url ( url ) : 使用绝对或相对 url 地址指定插入文档。假如该文档不存在，当前对象的内容将被显示
说明：
这个属性插入另一个文档到当前文档，取代当前对象的内容。插入文档的样式属性从当前对象继承。
对应的脚本特性为 includeSource 。
示例：
div { position: absolute; top: 100px; left: 300px; width: 200px; height: 200px; border: thin solid black; include-source: url("http://www.dhtmlet.com/dream.html"); }


quotes版本：CSS2　 兼容性：无　继承性：无
语法：
quotes : none | string
取值：
none | : | 默认值。 content 属性的 open-quote 和 close-quote 值将不会生成任何嵌套标记
string | : | 用引号括起的嵌套标记定义。两个为一组。第一个 string 定义前标记（例："<"），第二个 string 定义后标记（例：">"）。组之间用空格格开。嵌套标记的应用深度按定义顺序内推
说明：
设置或检索对象内使用的嵌套标记。
对应的脚本特性为 quotes 。
示例：
blockquote[lang-=fr] { quotes: "\201C" "\201D" }
blockquote[lang-=en] { quotes: "\00AB" "\00BB" }
blockquote:before { content: open-quote }
blockquote:after { content: close-quote }

q { quotes: """ """ "'" "'"; }

<q>This is an <q>emedded</q> quote.</q>

显示结果如下：

"This is an 'embedded' quote."


content版本：CSS2　 兼容性：无　继承性：无
语法：
content : attr(alt) | counter(name) | counter(name , list-style-type) | counters(name , string) | counters(name , string , list-style-type) | no-close-quote | no-open-quote | close-quote | open-quote | string | url(url)
取值：
attr(alt) | : | 使用对象的 alt 属性的文字
counter(name) | : | 使用已命名的计数器
counter(name, list-style-type) | : | 使用已命名的计数器并遵从指定的 list-style-type 属性
counters(name, string) | : | 使用所有已命名的计数器
counters(name, string, list-style-type) | : | 使用所有已命名的计数器并遵从指定的 list-style-type 属性
no-close-quote | : | 并不插入 quotes 属性的后标记。但增加其嵌套级别
no-open-quote | : | 并不插入 quotes 属性的前标记。但减少其嵌套级别
close-quote | : | 插入 quotes 属性的后标记
open-quote | : | 插入 quotes 属性的前标记
string | : | 使用用引号括起的字符串
url(url) | : | 使用指定的绝对或相对 url 地址
说明：
用来和 :after 及 :before 伪元素一起使用，在对象前或后显示内容。
对应的脚本特性为 content 。
示例：
p:after { content: url("http:www.devguru.com"); text-decoration: none; }
p:before { content: url("beep.wav") }


counter-increment版版本：CSS2　 兼容性：无　继承性：无
语法：
counter-increment : none | identifier number
取值：
none | : | 默认值。阻止计数器增加
identifier number | : | identifier 定义一个将被增加计数的选择符(selector)，id，或者class。 number 定义增加的数值。可以为负值。默认值是 1
说明：
设定当一个选择符(selector)发生时计数器增加的值。
对应的脚本特性为 counterIncrement 。
示例：
p:before { content: "paragraph" counter(paragraph); counter-increment: paragraph; }


counter-reset版版本：CSS2　 兼容性：无　继承性：无
语法：
counter-reset : none | identifier number
取值：
none | : | 默认值。阻止计数器复位
identifier number | : | identifier 定义一个将被复位的选择符(selector)，id，或者class。 number 定义复位的数值。可以为负值。默认值是 0
说明：
将指定选择符(selector)的计数器复位。
对应的脚本特性为 counterReset 。
示例：
h1:before { counter-increment: main-heading; counter-reset: sub-heading; content: "Section " counter(main-heading) ":" }


padding版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
padding : length
取值：
length : 由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的宽度。不允许负值。请参阅 长度单位
说明：
检索或设置对象四边的内补丁。对于 td 和 th 对象而言默认值为 1 。其他对象的默认值为 0 。
如果提供全部四个参数值，将按上－右－下－左的顺序作用于四边。如果只提供一个，将用于全部的四条边。如果提供两个，第一个用于上－下，第二个用于左－右。如果提供三个，第一个用于上，第二个用于左－右，第三个用于下。
在IE5.5+中此属性支持内联对象使用。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 padding 。
示例：
body { padding: 36pt 24pt 36pt; }
body { padding: 11.5%; }
body { padding: 10% 10% 10% 10%; }


padding-Top版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
padding-top : length
取值：
length : 由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的宽度。不允许负值。请参阅 长度单位
说明：
检索或设置对象上边的内补丁。对于 td 和 th 对象而言默认值为 1 。其他对象的默认值为 0 。
在IE5.5+中此属性支持内联对象使用。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 paddingTop 。
示例：
body { padding: 36pt 24pt 36pt; }
body { padding-top: 11.5%; }
body { padding: 10% 10% 10% 10%; }


padding-right版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
padding-right : length
取值：
length : 由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的宽度。不允许负值。请参阅 长度单位
说明：
检索或设置对象右边的内补丁。对于 td 和 th 对象而言默认值为 1 。其他对象的默认值为 0 。
在IE5.5+中此属性支持内联对象使用。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 paddingRight 。
示例：
body { padding: 36pt 24pt 36pt; }
body { padding-right: 11.5%; }
body { padding: 10% 10% 10% 10%; }


padding-Bottom版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
padding-bottom : length
取值：
length : 由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的宽度。不允许负值。请参阅 长度单位
说明：
检索或设置对象底边的内补丁。对于 td 和 th 对象而言默认值为 1 。其他对象的默认值为 0 。
在IE5.5+中此属性支持内联对象使用。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 paddingBottom 。
示例：
body { padding: 36pt 24pt 36pt; }
body { padding-bottom: 11.5%; }
body { padding: 10% 10% 10% 10%; }


padding-left版本：CSS1　 兼容性：IE4+ NS4+　继承性：无
语法：
padding-left : length
取值：
length : 由浮点数字和单位标识符组成的长度值 | 或者百分数。百分数是基于父对象的宽度。不允许负值。请参阅 长度单位
说明：
检索或设置对象左边的内补丁。对于 td 和 th 对象而言默认值为 1 。其他对象的默认值为 0 。
在IE5.5+中此属性支持内联对象使用。而在此前的版本中，内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 paddingLeft 。
示例：
body { padding: 36pt 24pt 36pt; }
body { padding-left: 11.5%; }
body { padding: 10% 10% 10% 10%; }


list-style版本：CSS1　 兼容性：IE4+ NS4+　继承性：有
语法：
list-style : list-style-image || list-style-position || list-style-type
取值：
该属性是复合属性。请参阅各参数对应的属性。
默认值为：disc outside none。
说明：
设置列表项目相关样式。
当 list-style-image 和 list-style-type 都被指定了时， list-style-image 将获得优先权。除非 list-style-image 设置为 none 或指定 url 地址的图片不能被显示。
对应的脚本特性为 listStyle 。
示例：
li { list-style: url("http://www.dhtmlet.com/devgurupix.gif") inside circle; }
ul { list-style: outside upper-roman; }
ol { list-style: square; }


list-style-image版本：CSS1　 兼容性：IE4+ NS6+　继承性：有
语法：
list-style-image : none | url ( url )
取值：
none | : | 默认值。不指定图像
url ( url ) | : | 使用绝对或相对 url 地址指定图像
说明：
设置或检索作为对象的列表项标记的图像。
若此属性值为 none 或指定 url 地址的图片不能被显示时， list-style-type 属性将发生作用。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 listStyleImage 。
示例：
ul.out { list-style-position: outside; list-style-image: url("images/ie.gif"); }


list-style-position版本：CSS1　 兼容性：IE4+ NS6+　继承性：有
语法：
list-style-position : outside | inside
取值：
outside | : | 默认值。列表项目标记放置在文本以外，且环绕文本不根据标记对齐
inside | : | 列表项目标记放置在文本以内，且环绕文本根据标记对齐
说明：
设置或检索作为对象的列表项标记如何根据文本排列。
假如一个列表项目的左外补丁( margin-left )被设置为 0 ，则列表项目标记不会被显示。左外补丁( margin-left )最小可以被设置为 30 。
仅作用于具有 display 属性值等于 list-item 的对象。如 li 对象。
注意： ol 对象和 ul 对象的 type 属性为其后的所有列表项目(如 li 对象)指明列表属性。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 listStylePosition 。
示例：
ul.in { display: list-item; list-style-position: inside; }


list-style-type版本：CSS1/CSS2　 兼容性：IE4+ NS6+　继承性：有
语法：
list-style-type : disc | circle | square | decimal | lower-roman | upper-roman | lower-alpha | upper-alpha | none | armenian | cjk-ideographic | georgian | lower-greek | hebrew | hiragana | hiragana-iroha | katakana | katakana-iroha | lower-latin | upper-latin
取值：
disc | : | CSS1 | 默认值。实心圆
circle | : | CSS1 | 空心圆
square | : | CSS1 | 实心方块
decimal | : | CSS1 | 阿拉伯数字
lower-roman | : | CSS1 | 小写罗马数字
upper-roman | : | CSS1 | 大写罗马数字
lower-alpha | : | CSS1 | 小写英文字母
upper-alpha | : | CSS1 | 大写英文字母
none | : | CSS1 | 不使用项目符号
armenianl | : | CSS2 | 未支持。传统的亚美尼亚数字
cjk-ideographic | : | CSS2 | 未支持。浅白的表意数字
georgian | : | CSS2 | 未支持。传统的乔治数字
lower-greek | : | CSS2 | 未支持。基本的希腊小写字母
hebrew | : | CSS2 | 未支持。传统的希伯莱数字
hiragana | : | CSS2 | 未支持。日文平假名字符
hiragana-iroha | : | CSS2 | 未支持。日文平假名序号
katakana | : | CSS2 | 未支持。日文片假名字符
katakana-iroha | : | CSS2 | 未支持。日文片假名序号
lower-latin | : | CSS2 | 未支持。小写拉丁字母
upper-latin | : | CSS2 | 未支持。大写拉丁字母
说明：
设置或检索对象的列表项所使用的预设标记。
若 list-style-image 属性值为 none 或指定 url 地址的图片不能被显示时，此属性将发生作用。
假如一个列表项目的左外补丁( margin-left )被设置为 0 ，则列表项目标记不会被显示。左外补丁( margin-left )最小可以被设置为 30 。
仅作用于具有 display 属性值等于 list-item 的对象。如 li 对象。
注意： ol 对象和 ul 对象的 type 属性为其后的所有列表项目(如 li 对象)指明列表属性。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 listStyleType 。
示例：
ul.in { display: list-item; list-style-position: inside; }


marker-offset版本：CSS2　 兼容性：无　继承性：有
语法：
marker-offset : auto | length
取值：
auto | : | 默认值。浏览器自动设置间距
length | : | 由浮点数字和单位标识符组成的长度值。可为负值。请参阅 长度单位
说明：
设置或检索标记容器和主容器之间水平补白。即两个容器靠近的一边的间距。
作用于 display 属性值为 marker 的元素。
对应的脚本特性为 markerOffset 。
示例：
li:before { display: marker; marker-offset: 5px; }


border-collapse版本：CSS2　 兼容性：IE5+　继承性：无
语法：
border-collapse : separate | collapse
取值：
separate | : | 默认值。边框独立（标准HTML）
collapse | : | 相邻边被合并
说明：
设置或检索表格的行和单元格的边是合并在一起还是按照标准的HTML样式分开。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 borderCollapse 。
示例：
table { border-collapse: separate; }


border-spacing版本：CSS2　 兼容性：无　继承性：无
语法：
border-spacing : length
取值：
length : 由浮点数字和单位标识符组成的长度值。不可为负值。请参阅 长度单位
说明：
设置或检索当表格边框独立(例如当 border-collapse 属性等于 separate 时)，行和单元格的边在横向和纵向上的间距。
当只指定一个 length 值时，这个值将作用于横向和纵向上的间距。
当指定了两个 length 值时，第一个作用于横向间距，第二个作用于纵向间距。
对应的脚本特性为borderSpacing。
示例：
table { border-collapse: separate; border-spacing: 10px; }


caption-side版本：CSS2　 兼容性：无　继承性：有
语法：
caption-side : top | right | bottom | left
取值：
top | : | 默认值。 caption 在表格的上边
right | : | caption 在表格的右边
bottom | : | caption 在表格的下边
left | : | caption 在表格的左边
说明：
设置或检索表格( table )的 caption 对象是在表格的那一边。它是和 caption 对象一起使用的属性。
对应的脚本特性为 captionSide 。
示例：
table caption { caption-side: top; width: auto; text-align: left; }


empty-cells版本：CSS2　 兼容性：无　继承性：有
语法：
empty-cells : show | hide
取值：
show | : | 默认值。显示边框
hide | : | 隐藏边框
说明：
设置或检索当表格的单元格无内容时，是否显示该单元格的边框。
只有当表格行和列的边框独立（例如当 border-collapse 属性等于 separate ）时此属性才起作用。
对应的脚本特性为 emptyCells 。
示例：
table { caption-side: top; width: auto; border-collapse: separate; empty-cells: hide; }


table-layout版本：CSS2　 兼容性：IE5+　继承性：无
语法：
table-layout : auto | fixed
取值：
auto | : | 默认值。默认的自动算法。布局将基于各单元格的内容。表格在每一单元格内所有内容读取计算之后才会显示出来
fixed | : | 固定布局的算法。在这种算法中，表格和列的宽度取决于 col 对象的宽度总和，假如没有指定，则会取决于第一行每个单元格的宽度。假如表格没有指定宽度( width )属性，则表格被呈递的默认宽度为 100% 。
说明：
设置或检索表格的布局算法。
你可以通过此属性改善表格呈递性能。此属性导致IE以一次一行的方式呈递表格内容从而提供给信息用户更快的速度。此属性依据此下顺序使用其中一种方式布置表格栏宽度：
  1. 使用 col 或 colGroup 对象的宽度( width )属性信息。
  2. 使用表格第一行内的单元格的宽度( width )信息。
  3. 依据表格列数等分表格宽度。而不考虑表格内容的实际宽度。
假如单元格的内容超过了列宽度，内容将会被换行。假如无法换行，则内容会被裁切。假如此属性被设置为 fixed ，则 overflow 能够被用于控制处理溢出单元格( td )宽度的内容。假如表格行高度被指定了，那么换行的内容如果超出了指定表格行高度也会在纵向上被裁切。
设置此属性值为 fixed ，有助于提高表格性能。对于长表格效果尤其显著。
设置表格行高可以进一步提高呈递速度，浏览器不需要检测行内每一个单元格内容去确定行高就可以开始解析以及呈递。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 tableLayout 。
示例：
table { table-layout: fixed; }


speak-header版本：CSS2　 兼容性：无　继承性：有
语法：
speak-header : once | always
取值：
once | : | 默认值。表格标题在一系列单元格之前发声一次
always | : | 标题在每一个与之关联的单元格前发声
说明：
当表格( table )通过语音发生器说话时，数据单元格( td )和表格标题之间的关联必须被迅速确定。
一些语音浏览器允许用户在二维空间内移动。因而给他们机会映射空间区域关联。当这一点不可实现的时候，就需要通过样式表指定表格标题的发声点。
此属性设置或检索表格标题是在所有的单元格之前发声，还是到一个不与之关联的单元格就结束发声。
对应的脚本特性为 speakHeader 。
示例：
table { speak-header: once }


scrollbar-3dlight-color版本：IE5.5+专有属性　继承性：有
语法：
scrollbar-3dlight-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置或检索滚动条亮边框颜色。
请参阅 overflow 属性 。
对应的脚本特性为 scrollbar3dLightColor 。
示例：
div {scrollbar-3dlight-color :threedhighlight; }


scrollbar-highlight-color版本：IE5.5+专有属性　继承性：有
语法：
scrollbar-highlight-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置或检索滚动条3D界面的亮边(ThreedHighlight)颜色。
请参阅 overflow 属性 。
对应的脚本特性为 scrollbarHighlightColor 。
示例：
div {scrollbar-highlight-color :threedhighlight; }


scrollbar-face-color版本：IE5.5+专有属性　继承性：有
语法：
scrollbar-face-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置或检索滚动条3D表面(ThreedFace)的颜色。
请参阅 overflow 属性 。
对应的脚本特性为 scrollbarFaceColor 。
示例：
div {scrollbar-face-color : threedface; }


scrollbar-arrow-color版本：IE5.5+专有属性　继承性：有
语法：
scrollbar-arrow-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置或检索滚动条方向箭头的颜色。当滚动条出现但不可用时，此属性失效。
请参阅 overflow 属性 。
对应的脚本特性为 scrollbarArrowColor 。
示例：
div {scrollbar-arrow-color : buttontext; }


scrollbar-shadow-color版本：IE5.5+专有属性　继承性：有
语法：
scrollbar-shadow-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置或检索滚动条3D界面的暗边(ThreedShadow)颜色。
请参阅 overflow 属性 。
对应的脚本特性为 scrollbarShadowColor 。
示例：
div {scrollbar-shadow-color :ThreedDarkShadow; }


scrollbar-darkshadow-color 版本：IE5.5+专有属性　继承性：有
语法：
scrollbar-darkshadow-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置或检索滚动条暗边框(ThreedDarkShadow)颜色。
请参阅 overflow 属性 。
对应的脚本特性为 scrollbarDarkShadowColor 。
示例：
div {scrollbar-darkshadow-color :threeddarkshadow; }


scrollbar-base-color版本：IE5.5+专有属性　继承性：有
语法：
scrollbar-base-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置或检索滚动条基准颜色。其它界面颜色将据此自动调整。
请参阅 overflow 属性 。
对应的脚本特性为 scrollbarBaseColor 。
示例：
div {scrollbar-base-color : buttonface; }


scrollbar-track-color版本：IE5.5+专有属性　继承性：有
语法：
scrollbar-track-color : color
取值：
color : 指定颜色。请参阅 颜色单位 和 附录：颜色表
说明：
设置或检索滚动条的拖动区域(TrackBar)颜色。
请参阅 overflow 属性 。
对应的脚本特性为 scrollbarTrackColor 。
示例：
div {scrollbar-track-color :ThreedDarkShadow; }


page版本：CSS2　 兼容性：无　继承性：有
语法：
page : auto | pagetype
取值：
auto | : | 参照当前的默认页面
pagetype | : | 指定 @page 规则里的一个页面类型( pagetype )定义
说明：
检索或指定显示对象容器时使用的页面类型( pagetype )。
参阅@page规则。
对应的脚本特性为 page 。
示例：
@page doublepage { size: 8.5in 11in; page-break-after: left }
body { page: doublepage; page-break-after: right }


page-break-after版本：CSS2　 兼容性：IE4+　继承性：无
语法：
page-break-after : auto | always | avoid | left | right | null
取值：
auto | : | 假如需要在对象之后插入页分割符
always | : | 始终在对象之后插入页分割符
avoid | : | 未支持。避免在对象后面插入页分割符
left | : | 未支持。在对象后面插入页分割符直到它到达一个空白的左页边
right | : | 未支持。在对象后面插入页分割符直到它到达一个空白的右页边
null | : | 空白字符串。取消页分割符设置
说明：
检索或设置对象后出现的页分割符。
此属性在打印文档时发生作用。此属性不作用于 BR 或 HR 对象。
假如在浏览器已显示的对象上此属性和 page-break-before 属性的值之间发生冲突，则导致最大数目分页的值被使用。
页分隔符不允许出现在定位对象内部。
在IE6及之前版本浏览器中， left 和 right 值的作用结果等同于 always 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 pageBreakAfter 。
示例：
p { page-break-after: always;}


page-break-before版本：CSS2　 兼容性：IE4+　继承性：无
语法：
page-break-before : auto | always | avoid | left | right | null
取值：
auto | : | 假如需要在对象之前插入页分割符
always | : | 始终在对象之前插入页分割符
avoid | : | 未支持。避免在对象之前插入页分割符
left | : | 未支持。在对象之前插入页分割符直到它到达一个空白的左页边
right | : | 未支持。在对象之前插入页分割符直到它到达一个空白的右页边
null | : | 空白字符串。取消页分割符设置
说明：
检索或设置对象前出现的页分割符。
此属性在打印文档时发生作用。此属性不作用于 BR 或 HR 对象。
假如在浏览器已显示的对象上此属性和 page-break-after 属性的值之间发生冲突，则导致最大数目分页的值被使用。
页分隔符不允许出现在定位对象内部。
在IE6及之前版本浏览器中， left 和 right 值的作用结果等同于 always 。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 pageBreakBefore 。
示例：
p { page-break-before: always;}


page-break-inside版本：CSS2　 兼容性：无　继承性：有
语法：
page-break-inside : auto | avoid
取值：
auto | : | 假如需要在对象容器中插入页分割符
avoid | : | 使当前对象容器中禁止插入页分割符
说明：
检索或设置对象容器中出现的页分割符。
对应的脚本特性为 pageBreakInside 。
示例：
p { page-break-inside: auto }


marks版本：CSS2　 兼容性：无　继承性：无
语法：
marks : none | crop || cross
取值：
none | : | 无页标记出现
crop | : | 在页面将会被裁切处指定切割标记
lcross | : | 指定交叉线标记用来供页面对齐
说明：
印刷业的印刷文档通常在页面内容区域外带有一些标记，用来校正和调整所有的页面。此属性用来设置或检索什么样的标志是应该在页容器外边被给予。
对应的脚本特性为 marks 。
示例：
body { marks: crop cross }


orphans版本：CSS2　 兼容性：无　继承性：有
语法：
orphans : number
取值：
number : 无单位整数。不可为负值
说明：
设置或检索对象内容内一定要留在一页范围底端以内的行的最少数量。
对应的脚本特性为 orphans 。
示例：
p { orphans: 4; }


size版本：CSS2　 兼容性：无　继承性：有
语法：
size : auto | portrait | landscape | length
取值：
auto | : | 指定为适应目标纸张尺寸和方向的相对(Relative)页面容器
portrait | : | 指定为适应目标纸张尺寸和方向的相对(Relative)页面容器，不理会目标页的当前缺省的内容方向，使用文档流从左到右短距离跨越，向下长距离跨越的典型范例(纵向方式)
landscape | : | 指定为适应目标纸张尺寸和方向的相对(Relative)页面容器，不理会目标页的当前缺省的内容方向，使用横向方式
length | : | 由浮点数字和单位标识符组成的长度值。指定为固定尺寸和方向的绝对(Absolute)页面容器。只有一个参数，则指定高度和宽度。用空格分开的两个，第一个指定高度，第二个指定宽度。请参阅 长度单位
说明：
对应的脚本特性为 size 。
示例：
body { size: 8.5in 11in }


widows版本：CSS2　 兼容性：无　继承性：有
语法：
widows : number
取值：
number : 无单位整数。不可为负值
说明：
检索或指定一定要留在页面顶部的行数。
对应的脚本特性为 widows 。
示例：
p { widows: 1 }


voice-family版本：CSS2　 兼容性：无　继承性：有
语法：
voice-family : child | female | male || name
取值：
child | : | 童声
female | : | 女声
male | : | 男声
name | : | 声音名称。按优先顺序排列。以逗号隔开。如果声音名称包含空格，则应使用引号括起
说明：
设置或检索当前声音类型。
对应的脚本特性为 voiceFamily 。
示例：
strong { voice-family: "Bob Barker", "Monty Hall", male }


volume版本：CSS2　 兼容性：无　继承性：有
语法：
volume : silent | x-soft | soft | medium | loud | x-loud | number
取值：
silent | : | 不同于 speak 的 none 值，当前声音仍将占用时间，但是没有声音发出
x-soft | : | 相当于 number 的值为0
soft | : | 相当于 number 的值为25
medium | : | 默认值。相当于 number 的值为50
loud | : | 相当于 number 的值为75
x-loud | : | 相当于 number 的值为100
number | : | 整数|分数。整数值取值范围为0-100。百分数值是相对于此属性继承而得的值
说明：
设置或检索音量。
对应的脚本特性为 volume 。
示例：
body { volume: soft }


elevation版本：CSS2　 兼容性：无　继承性：有
语法：
elevation : below | level | above | lower | higher | angle
取值：
below | : | -90deg
level | : | 默认值。0deg
above | : | 90deg
lower | : | 相对于继承值或绝对参考角度减（逆时针）10deg
higher | : | 相对于继承值或绝对参考角度加（顺时针）10deg
angle | : | 角度值。整数值取值范围为-90deg到90deg。单位为deg。请参阅 角度单位
说明：
设置或检索当前声音的音源仰角。
对应的脚本特性为 elevation 。
示例：
body { elevation: 75deg }


azimuth版本：CSS2　 兼容性：无　继承性：有
语法：
azimuth : left-side | far-left | left | center-left | center | center-right | right | far-right | right-side | leftwards | rightwards | angle
取值：
left-side | : | 角度值为 270deg | 90deg
far-left | : | 角度值为 300deg | -60deg
left | : | 角度值为 320deg | -40deg
center-left | : | 角度值为 340deg | -20deg
center | : | 默认值。角度值为 0deg
center-right | : | 角度值为 20deg | -340deg
right | : | 角度值为 40deg | -320deg
far-right | : | 角度值为 60deg | -300deg
right-side | : | 角度值为 90deg | -270deg
leftwards | : | 相对于继承值或绝对参考角度减（逆时针）20deg
rightwards | : | 相对于继承值或绝对参考角度加（顺时针）20deg
angle | : | 指定角度值。有单位整数。取值范围为-360deg到360deg。单位为deg。请参阅 角度单位
说明：
设置或检索当前声音的音场角度。
对应的脚本特性为 azimuth 。
示例：
div { azimuth : 30deg; }
p { azimuth : center-left; }
body { azimuth: 75deg; }


stress版本：CSS2　 兼容性：无　继承性：有
语法：
stress : number
取值：
number : 整数。整数值取值范围为0-100。默认值为 50
说明：
和 pitch-range 相似。设置或检索当前声音波形的最高峰值。
对应的脚本特性为 stress 。
示例：
body { stress: 75 }


richness版本：CSS2　 兼容性：无　继承性：有
语法：
richness : number
取值：
number : 整数。整数值取值范围为0-100。默认值为 50
说明：
设置或检索当前声音的音色。
对应的脚本特性为 richness 。
示例：
body { richness: 75 }


speech-rate版本：CSS2　 兼容性：无　继承性：有
语法：
speech-rate : x-slow | slow | medium | fast | x-fast | slower | faster | number
取值：
x-slow | : | 80字/分钟
slow | : | 120字/分钟
medium | : | 默认值。180-200字/分钟
fast | : | 300字/分钟
x-fast | : | 500字/分钟
slower | : | 根据当前的速度每分钟减少40个字
faster | : | 根据当前的速度每分钟增加40个字
number | : | 整数。指定每分钟发音字数
说明：
设置或检索发音速度。
对应的脚本特性为 speechRate 。
示例：
strong { speech-rate: fast }


cue-before版本：CSS2　 兼容性：无　继承性：无
语法：
cue : cue-before || cue-after
取值：
该属性是复合属性。请参阅各参数对应的属性。
说明：
设置在对象前后播放的声音。
假如只给出了一个值，它将用于 cue-before 属性和 cue-after 属性。假如给出了两个值，则第一个用于 cue-before 属性，第二个用于 cue-after 属性。
对应的脚本特性为 cue 。
示例：
div { cue: url(orchestralsneeze.wav) none }
div { cue: url(orchestralsneeze.wav); }


cue-after版本：CSS2　 兼容性：无　继承性：无
语法：
cue-after : none | url ( url )
取值：
none | : | 默认值。无声音播放
url ( url ) | : | 使用绝对或相对 url 地址指定音乐文件
说明：
设置在对象后播放的声音。
对应的脚本特性为 cueAfter 。
示例：
div { cue-after: url(orchestralsneeze.wav) ; }


cue-before版本：CSS2　 兼容性：无　继承性：无
语法：
cue-before : none | url ( url )
取值：
none | : | 默认值。无声音播放
url ( url ) | : | 使用绝对或相对 url 地址指定音乐文件
说明：
设置在对象前播放的声音。
对应的脚本特性为 cueBefore 。
示例：
div { cue-before: url(orchestralsneeze.wav); }


pause版本：CSS2　 兼容性：无　继承性：无
语法：
pause : pause-before || pause-after
取值：
该属性是复合属性。请参阅各参数对应的属性。
说明：
设置对象前后的声音暂停。
假如只给出了一个值，它将用于 pause-before 属性和 pause-after 属性。假如给出了两个值，则第一个用于 pause-before 属性，第二个用于 pause-after 属性。
对应的脚本特性为 pause 。
示例：
div { pause: 2s 3s }
div { pause: 2s; }


pause-after版本：CSS2　 兼容性：无　继承性：无
语法：
pause-after : time
取值：
time : 由浮点数字与时间单位组成的时间值|百分数。百分数值是相对于 speech-rate 属性的值。对于值为60字/分钟的 speech-rate 属性来说，值为 100% 的 pause-after 属性即相当于暂停1秒。请参阅 时间单位
说明：
定义对象内容被发音后的暂停。
对应的脚本特性为 pauseAfter 。
示例：
div { pause-after: 2s; }


pause-before版本：CSS2　 兼容性：无　继承性：无
语法：
pause-before : time
取值：
time : 由浮点数字与时间单位组成的时间值|百分数。百分数值是相对于 speech-rate 属性的值。对于值为60字/分钟的 speech-rate 属性来说，值为 100% 的 pause-before 属性即相当于暂停1秒。请参阅 时间单位
说明：
定义对象内容发音前的暂停。
对应的脚本特性为 pauseBefore 。
示例：
div { pause-before: 2s; }


pitch版本：CSS2　 兼容性：无　继承性：有
语法：
pitch : x-low | low | medium | high | x-high | number
取值：
number : 数字。指定赫兹（HZ）值。其他参数取决于 voice-family 属性指定的声音种类。请参阅 频率单位
说明：
设置或检索音高。
对应的脚本特性为 pitch 。
示例：
strong { pitch: x-high }
strong { pitch: 75hz }


pitch-range版本：CSS2　 兼容性：无　继承性：有
语法：
pitch-range : number
取值：
number : 数字。取值范围为0-100。默认值为 50 ，表示普通发音。小于50趋向于平缓，大于50趋向于颤抖
说明：
设置或检索声音的平滑程度。
对应的脚本特性为 pitchRange 。
示例：
strong { pitch-range: 80 }


play-during版本：CSS2　 兼容性：无　继承性：有
语法：
play-during : url ( url ) | mix | repeat | auto | none
取值：
url ( url ) | : | 使用绝对或相对 url 地址指定背景音乐
mix | : | 在播放对象的背景音乐的同时并不停止父对象的背景音乐
repeat | : | 循环播放对象的背景音乐
auto | : | 默认值。仅仅再一次执行父对象的 play-during 属性值
none | : | 背景音乐。甚至取消父对象的 play-during 属性值的作用
说明：
设置或检索背景音乐的播放。
对应的脚本特性为 playDuring 。
示例：
p { play-during: url(accordian.wav) mix }


speak版本：CSS2　 兼容性：无　继承性：有
语法：
speak : normal | none | spell-out
取值：
normal | : | 默认值。使用当前语言的正常发音尺度
none | : | 取消发音。不同于 volume 的 silent 值，未发出的声音不占用时间。这个值不会被子对象继承
spell-out | : | 一次一字的拼写内容
说明：
设置或检索声音是否给出。
对应的脚本特性为 speak 。
示例：
acronym { speak: spell-out }


speak-numeral版本：CSS2　 兼容性：无　继承性：有
语法：
speak-numeral : continuous | digits
取值：
continuous | : | 默认值。根据默认语言对数字的词语描述阅读
digits | : | 逐位阅读数字
说明：
设置或检索数字如何发音。
对应的脚本特性为 speakNumeral 。
示例：
.telephone { speak-numeral: digits }


speak-punctuation版本：CSS2　 兼容性：无　继承性：有
语法：
speak-punctuation : none | code
取值：
none | : | 默认值。取消标点符号发音。替代为停顿
code | : | 标点符号被发音
说明：
设置或检索标点符号如何发音。
对应的脚本特性为 speakPunctuation 。
示例：
.telephone { speak-punctuation: code; speak-numeral: digits }


cursor版本：CSS2　 兼容性：IE4.0+ NS6.0+　继承性：有
语法：
cursor : auto | all-scroll | col-resize| crosshair | default | hand | move | help | no-drop | not-allowed | pointer | progress | row-resize | text | vertical-text | wait | *-resize | url ( url )
取值：
auto | : |  | 默认值。浏览器根据当前情况自动确定鼠标光标类型。
all-scroll | : | IE6.0 | 有上下左右四个箭头，中间有一个圆点的光标。用于标示页面可以向上下左右任何方向滚动。
col-resize | : | IE6.0 | 有左右两个箭头，中间由竖线分隔开的光标。用于标示项目或标题栏可以被水平改变尺寸。
crosshair | : |  | 简单的十字线光标。
default | : |  | 客户端平台的默认光标。通常是一个箭头。
hand | : |  | 竖起一只手指的手形光标。就像通常用户将光标移到超链接上时那样。
move | : |  | 十字箭头光标。用于标示对象可被移动。
help | : |  | 带有问号标记的箭头。用于标示有帮助信息存在。
no-drop | : | IE6.0 | 带有一个被斜线贯穿的圆圈的手形光标。用于标示被拖起的对象不允许在光标的当前位置被放下。
not-allowed | : | IE6.0 | 禁止标记(一个被斜线贯穿的圆圈)光标。用于标示请求的操作不允许被执行。
pointer | : | IE6.0 | 和 hand 一样。竖起一只手指的手形光标。就像通常用户将光标移到超链接上时那样。
progress | : | IE6.0 | 带有沙漏标记的箭头光标。用于标示一个进程正在后台运行。
row-resize | : | IE6.0 | 有上下两个箭头，中间由横线分隔开的光标。用于标示项目或标题栏可以被垂直改变尺寸。
text | : |  | 用于标示可编辑的水平文本的光标。通常是大写字母 I 的形状。
vertical-text | : | IE6.0 | 用于标示可编辑的垂直文本的光标。通常是大写字母 I 旋转90度的形状。
wait | : |  | 用于标示程序忙用户需要等待的光标。通常是沙漏或手表的形状。
*-resize | : |  | 用于标示对象可被改变尺寸方向的箭头光标。w-resize | s-resize | n-resize | e-resize | ne-resize | sw-resize | se-resize | nw-resize
url ( url ) | : | IE6.0 | 用户自定义光标。使用绝对或相对 url 地址指定光标文件(后缀为 .cur 或者 .ani )。
说明：
设置或检索在对象上移动的鼠标指针采用的光标形状。
此属性的值可以是多个，其间用逗号分隔。假如第一个值不可以被客户端系统理解或所指定的光标无法找到及显示，则第二个值将被尝试使用。依此类推。假如全部值都不可用的话，则此属性不会发生作用。光标不会被改变。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 cursor 。
示例：
p { cursor: text; }
a { cursor: pointer; }
body { cursor: url("mycursor.gif"), url("images/cursors/footcursor.jpg"), default; }


behavior版本：IE5+专有属性　继承性：无
语法：
behavior : url ( url ) | url ( #objID ) | url ( #default#behaviorName )
取值：
url ( url ) | : | 使用绝对或相对 url 地址指定DHTML行为组件（.htc）
url ( #objID ) | : | 使用二进制实现(作为 ActiveX® 控件)的行为。此处的 #objID 为 object 对象的 id 属性值
url ( #default#behaviorName ) | : | IE的默认行为。由行为的名称标识( #behaviorName )指定
说明：
设置或检索对象的DHTML行为。多个行为之间用空格隔开。
当多个附加到同一要素的行为发生冲突时，其结果确决于行为应用于要素的顺序。后一个行为的优先权高于前一个行为。例如，假如多个行为用于设置对象颜色，其结果将会由最后一个应用到要素的行为决定。同样的规则适用于不同行为提供的属性、事件、方法所发生的名称冲突。
可以使用 addBehavior 方法动态的将行为附着到对象。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
务必注意使用样式表(CSS)的 behavior 属性内联定义或使用 addBehavior 方法附着的行为不会在对象从文档树中移除时被自动分离。而在文档中的样式表规则定义的行为会在对象从文档树中移除时被自动分离。
对应的脚本特性为 behavior 。
示例：
p { behavior: url(#default#download); }
div { behavior: url(fly.htc) url(shy.htc); }
div { behavior: url(#myObject); }


filter版本：IE5.5+专有属性　继承性：无
语法：
filter : filter
取值：
filter : 要使用的滤镜效果。多个滤镜之间用空格隔开。请参阅样式表滤镜(Visual Filters and Transitions Reference)。
说明：
设置或检索对象所应用的滤镜或滤镜集合。
此属性仅作用于有布局的对象，如块对象。内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。请参阅对象的 hasLayout 属性。
若要在 img 对象上应用 shadow 滤镜，可以在该对象 img 对象的父容器上应用。
滤镜的机制是可扩展的。通过利用Microsoft® DirectX® Media SDK，你可以使用C++开发和使用第三方滤镜。
该属性在MAC平台上不可用。
对应的脚本特性为 filter 。
示例：
div { width:200px; filter:blur(strength=50) flipv() ; }
img { filter: invert(); }
input.aFilter {filter: alpha(opacity=50);}
div { width:200px; filter:redirect ; }
.aFilter {background-color: #FFFFFF; filter: light(); color: #000000; width: 150;}
div.aFilter {filter: glow(Color=blue,Strength=5); width: 150;}
div.aFilter {filter: shadow(color=#0000FF,direction=45); width: 150; color: FF0000;}


zoom版本：IE5.5+专有属性　继承性：无
语法：
zoom : normal | number
取值：
normal | : | 默认值。使用对象的实际尺寸
number | : | 百分数 | 无符号浮点实数。浮点实数值为1.0或百分数为100%时相当于此属性的 normal 值
说明：
设置或检索对象的缩放比例。
设置或更改一个已被呈递的对象的此属性值将导致环绕对象的内容重新流动。
虽然此属性不可继承，但是它会影响对象的所有子对象( children )。这种影响很像 background 和 filter 属性导致的变化。
此属性对于 currentStyle 对象而言是只读的。对于其他对象而言是可读写的。
对应的脚本特性为 zoom 。
示例：
div {zoom : 0.75; }
.clsTeenyWeeny { zoom: 0.10 }


Universal Selector　版本：CSS2　 兼容性：无
语法：
* { sRules }
说明：
通配选择符。选定文档目录树(DOM)中的所有类型的单一对象。
假如通配选择符不是单一选择符中的唯一组成，“*”可以省略。
示例：
*[lang=fr] { font-size:14px; width:120px; }
*.div { text-decoration:none; }


Type Selectors　版本：CSS1　 兼容性：IE4+ NS4+
语法：
E { sRules }
说明：
类型选择符。以文档语言对象(Element)类型作为选择符。
示例：
td { font-size:14px; width:120px; }
a { text-decoration:none; }


Attribute Selectors　版本：CSS2　 兼容性：无
语法：
  1. E [ attr ] { sRules }
  2. E [ attr = value ] { sRules }
  3. E [ attr ~= value ] { sRules }
  4. E [ attr |= value ] { sRules }
说明：
属性选择符。
  1. 选择具有 attr 属性的 E
  2. 选择具有 attr 属性且属性值等于 value 的 E
  3. 选择具有 attr 属性且属性值为一用空格分隔的字词列表，其中一个等于 value 的 E 。这里的 value 不能包含空格
  4. 选择具有 attr 属性且属性值为一用连字符分隔的字词列表，由 value 开始的 E
示例：
h[title] { color: blue; }
/* 所有具有title属性的h对象 */

span[class=demo] { color: red; }

div[speed="fast"][dorun="no"] { color: red; }

a[rel~="copyright"] { color:black; }


Descendant Selectors　版本：CSS1　 兼容性：IE4+ NS4+
语法：
E1 E2 { sRules }
说明：
包含选择符。选择所有被 E1 包含的 E2 。即 E1.contains(E2)==true 。
示例：
table td { font-size:14px; }

div.sub a { font-size:14px; }


Child Selectors　版本：CSS2　 兼容性：无
语法：
E1 > E2 { sRules }
说明：
子对象选择符。选择所有作为 E1 子对象的 E2 。
示例：
body > p { font-size:14px; }
/* 所有作为body的子对象的p对象字体尺寸为14px */

div ul>li p { font-size:14px; }


ID Selectors　版本：CSS1　 兼容性：IE4+ NS4+
语法：
#ID { sRules }
说明：
ID选择符。以文档目录树(DOM)中作为对象的唯一标识符的 ID 作为选择符。
示例：
#note { font-size:14px; width:120px;}


Class Selectors　版本：CSS1　 兼容性：IE4+ NS4+
语法：
E.className { sRules }
说明：
类选择符。在HTML中可以使用此种选择符。其效果等同于E [ class ~= className ] 。请参阅属性选择符( Attribute Selectors )。
在IE5+，可以为对象的 class 属性(特性)指定多于一个值( className )，其方法是指定用空格隔开的一组样式表的类名。例如：<div class="class1 class2">。
示例：
div.note { font-size:14px; }
/* 所有class属性值等于（包含）"note"的div对象字体尺寸为14px */

.dream { font-size:14px; }
/* 所有class属性值等于（包含）"note"的对象字体尺寸为14px */


Grouping　版本：CSS1　 兼容性：IE4+ NS4+
语法：
E1 , E2 , E3 { sRules }
说明：
选择符分组。将同样的定义应用于多个选择符，可以将选择符以逗号分隔的方式并为组。
示例：
.td1,div a,body { font-size:14px; }
td,div,a { font-size:14px; }


Pseudo Selectors　版本：CSS1　 兼容性：IE4+ NS4+
语法：
  1. E : Pseudo-Classes { sRules }
  2. E : Pseudo-Elements { sRules }
说明：
伪类及伪对象选择符。
  1. 伪类选择符。请参阅伪类( Pseudo-Classes )。
  2. 伪对象选择符。请参阅伪对象( Pseudo-Elements )。
示例：
div:first-letter { font-size:14px; }
a.fly :hover { font-size:14px; color:red; }


:link版本：CSS1　 兼容性：IE4+ NS4+
语法：
Selector : link { sRules }
说明：
设置 a 对象在未被访问前的样式。
默认值由浏览器决定。
对于无 href 属性(特性)的 a 对象，此伪类不发生作用。
请参阅 body 对象的 link 属性(特性)和 document 对象的 linkColor 特性。
IE3将 :link 伪类的样式表属性作用于 visited 伪类。
示例：
a:link { font-size: 14pt; text-decoration: underline; color: blue; }


:hover版本：CSS1/CSS2　 兼容性：IE4+ NS4+
语法：
Selector : hover { sRules }
说明：
设置对象在其鼠标悬停时的样式。
在CSS1中此伪类仅可用于 a 对象。对于无 href 属性(特性)的 a 对象，此伪类不发生作用。
在CSS2中此伪类可以应用于任何对象。
示例：
a:hover { font-size: 14pt; text-decoration: underline; color: blue; }
a:hover span{ color:red; }


:active版本：CSS1/CSS2　 兼容性：IE4+ NS4+
语法：
Selector : active { sRules }
说明：
设置对象在被用户激活(在鼠标点击与释放之间发生的事件)时的样式。
在CSS1中此伪类仅可用于 a 对象。对于无 href 属性(特性)的 a 对象，此伪类不发生作用。
在CSS2中此伪类可以应用于任何对象。
并且 :active 可以和 :link 以及 :visited 状态同时发生。
示例：
a:active { font-size: 14pt; text-decoration: underline; color: blue; }


:visited版本：CSS1/CSS2　 兼容性：IE4+ NS4+
语法：
Selector : visited { sRules }
说明：
设置 a 对象在其链接地址已被访问过时的样式。
IE3将 :link 伪类的样式表属性作用于 :visited 伪类。
默认值由浏览器决定。定义网页过期时间或用户清空历史记录将影响此伪类的作用。
对于无 href 属性(特性)的 a 对象，此伪类不发生作用。
请参阅 body 对象的 vlink 属性(特性)和 document 对象的 vlinkColor 特性。
示例：
a:visited { font-size: 14pt; text-decoration: underline; color: blue; }


:first-child版本：CSS2　 兼容性：无
语法：
Selector : first-child { sRules }
说明：
设置 E 的第一个子对象的样式。
示例：
p a:first-child { color: green }
table td:first-child { width:200px; }


:first版本：CSS2　 兼容性：IE5.5+
语法：
Selector : first { sRules }
说明：
设置页面容器第一页使用的样式。仅用于 @page 规则。
示例：
@page :first { margin: 4cm }


:left版本：CSS1　 兼容性：IE5.5+
语法：
Selector : left { sRules }
说明：
设置页面容器位于装订线左边的所有页面使用的样式。仅用于 @page 规则。
示例：
@page :left { margin: 4cm }


:right版本：CSS1　 兼容性：IE5.5+
语法：
Selector : right { sRules }
说明：
设置页面容器位于装订线右边的所有页面使用的样式。仅用于 @page 规则。
示例：
@page :right { margin: 4cm }


:lang版本：CSS2　 兼容性：无
语法：
Selector : lang { sRules }
说明：
设置对象使用特殊语言的内容的样式。
示例：
blockquote:lang(fr) { quotes: '?' ' ?' }
/* 使用法语显示由quotes属性指定的法语的嵌套标记 */


:focus版本：CSS2　 兼容性：无
语法：
Selector : focus { sRules }
说明：
设置对象在成为输入焦点(该对象的 onfocus 事件发生)时的样式。
示例：
a:focus { font-size: 14pt; text-decoration: underline; color: blue; }
a:focus img { border: thin solid green }


:after版本：CSS1　 兼容性：无
语法：
Selector : after { sRules }
说明：
用来和 content 属性一起使用，设置在对象后(依据对象树的逻辑结构)发生的内容。
示例：
table:after { content: END OF TABLE }


:first-letter版本：CSS2　 兼容性：IE5.5+
语法：
Selector : first-letter { sRules }
说明：
设置对象内的第一个字符的样式。
此伪对象仅作用于块对象。内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。

在此伪对象中配合使用 font-size 属性和 float 属性可以制作首字下沉效果。
示例：
p a:first-letter { color: green }
div:first-letter { color:red;font-size:16px;float:left; }


:first-line版本：CSS2　 兼容性：IE5.5+
语法：
Selector : first-line { sRules }
说明：
设置对象内的第一行的样式。
此伪对象仅作用于块对象。内联要素要使用该属性，必须先设定对象的 height 或 width 属性，或者设定 position 属性为 absolute ，或者设定 display 属性为 block 。
如果未强制指定对象的 width 属性， 首行的内容长度可能不是固定的。
示例：
p a:first-line { color: green }
div:first-line { color:red;font-size:16px; }


:before版本：CSS2　 兼容性：无
语法：
Selector : before { sRules }
说明：
用来和 content 属性一起使用，设置在对象前(依据对象树的逻辑结构)发生的内容。
示例：
em:before { content: url("ding.wav"); }


@import版本：CSS1/CSS2　 兼容性：IE4+
语法：
@import url ( url ) sMedia ;
取值：
url ( url ) | : | 使用绝对或相对 url 地址指定导入的外部样式表文件。请参阅 link 对象
sMedia | : | 未支持。指定设备类型。请参阅 附录：设备类型
说明：
指定导入的外部样式表及目标设备类型。此规则无默认值。
此规则其后的分号是必需的，如果省略了此分号，外部样式表将无法正确导入，并会生成错误信息。 url () 是可选的。
此规则像 link 对象一样，链接一个外部样式表到文档。用此规则导入的样式表，其 owningElement 特性是一个 link 对象或 style 对象。
此规则必须出现在样式表内的任何声明之前。虽然IE4.0+允许此规则出现在样式表定义的任何位置，但是此规则导入的样式定义将在内部样式表之前作用。这个定义顺序会影响您预期的结果。
导入的外部样式表中的定义会被文档中的定义覆盖。
示例：
@import url("foo.css") screen, print;
@import "print.css";
@import url(print.css);


@charset版本：CSS2　 兼容性：IE4+
语法：
@charset sCharacterSet
取值：
sCharacterSet : 字符集名称
说明：
在外部样式表文件内使用。指定该样式表使用的字符集。不可以在内部样式表中使用。
此规则无默认值。请参阅 附录：字符集 。
在外部样式表文件内，此规则只允许使用一次。且必须在样式表的最前面。
对于内部样式表来说，其字符集由HTML文档的字符集指定。请参阅 meta 对象的 content 属性(特性)。
示例：
@charset "Windows-1251";
@charset "Shift-JIS";


@font-face版本：CSS2　 兼容性：IE4+
语法：
@font-face { font-family : name ; src : url ( url ) ; sRules }
取值：
name | : | 字体名称。任何可能的 font-family 属性的值
url ( url ) | : | 使用绝对或相对 url 地址指定OpenType字体文件
sRules | : | 样式表定义
说明：
设置嵌入HTML文档的字体。此规则无默认值。
此规则使你能够在网页上使用客户端本地系统上可能没有的字体。 url 地址必须指向 OpenType 字体文件(.eot或.ote)。此文件包含可以转换为 TrueType 字体的压缩字体数据，可以用来提供HTML文档使用该字体，或取代客户端系统已有的同名字体。此文件可以使用 Microsoft WEFT 工具制作。
示例：
@font-face { font-family:comic;src:url(http://valid_url/some_font_file.eot); }
@font-face { font-family: dreamy; font-weight: bold; src: url(http://www.example.com/font.eot); }


@fontdef版本：NS4+专有规则　 兼容性：NS4+
语法：
@fontdef { url ( url ) }
取值：
url ( url ) : 使用绝对或相对 url 地址指定嵌入HTML文档的字体定义文件
说明：
设置嵌入HTML文档的字体。
示例：
@fontdef url("http://www.example.com/sample.pfr");


@page版本：CSS1　 兼容性：IE5.5+
语法：
@page pseudo-class { sRules }
取值：
pseudo-class | : | 伪类。:first | :left | :right
sRules | : | 样式表定义
说明：
设置页面容器的版式，方向，补丁等。此规则无默认值。
页面容器是一个矩形区域，包括页面内容区域和补丁区域。页面内容区域包含页面的内容，像文本和图片等，补丁区域环绕内容区域外围。
虽然此规则定义会被描述在IE5.5+的样式表对象模型内，但是这些定义并不会被IE默认的打印模板使用。它们能够被MSHTML宿主程序用于打印模板开发。在这些程序中，像 size 和 margin 等不被明确提供的属性作为自定义( expando )属性被使用。
示例：
@page thin:first { size: 3in 8in }


@media版本：CSS2　 兼容性：IE5+
语法：
@media sMedia { sRules }
取值：
sMedia | : | 指定设备名称。请参阅 附录：设备类型
sRules | : | 样式表定义
说明：
指定样式表规则用于指定的设备类型。此规则无默认值。
请参阅 link 对象的 media 属性(特性)。
示例：
// 设置显示器用字体尺寸
@media screen {
BODY {font-size:12pt; }
}

// 设置打印机用字体尺寸
@media print {
@import "print.css"
BODY {font-size:8pt;}
}


!important　版本：CSS1　 兼容性：IE4+
语法：
{ sRule!important }
取值：
sRules : 样式表定义
说明：
提升指定样式规则的应用优先权。
示例：
div { color:red!important }


px版本：CSS1　 兼容性：IE3+ NS4+
说明：
相对长度单位。像素（Pixel）。
像素是相对于显示器屏幕分辨率而言的。譬如，WONDOWS的用户所使用的分辨率一般是96像素/英寸。而MAC的用户所使用的分辨率一般是72像素/英寸。
示例：
div { font-size : 12px; }


em版本：CSS1　 兼容性：IE4+ NS4+
说明：
相对长度单位。相对于当前对象内文本的字体尺寸。
如当前行内文本的字体尺寸未被人为设置，则相对于浏览器的默认字体尺寸。
示例：
div { font-size : 1.2em; }


ex版本：CSS1　 兼容性：IE4+ NS4+
说明：
相对长度单位。相对于字符“x”的高度。此高度通常为字体尺寸的一半。
如当前对行内文本的字体尺寸未被人为设置，则相对于浏览器的默认字体尺寸。
示例：
div { font-size : 1.2ex; }


pt版本：CSS1　 兼容性：IE3+ NS4+
说明：
绝对长度单位。点（Point）。
1in = 2.54cm = 25.4 mm = 72pt = 6pc
示例：
div { font-size : 9pt; }


pc版本：CSS1　 兼容性：IE3+ NS4+
说明：
绝对长度单位。派卡（Pica）。相当于我国新四号铅字的尺寸。
1in = 2.54cm = 25.4 mm = 72pt = 6pc
示例：
div { font-size : 0.75pc; }


in版本：CSS1　 兼容性：IE3+ NS4+
说明：
绝对长度单位。英寸（Inch）。
1in = 2.54cm = 25.4 mm = 72pt = 6pc
示例：
div { font-size : 0.13in; }


mm版本：CSS1　 兼容性：IE3+ NS4+
说明：
绝对长度单位。毫米（Millimeter）。
1in = 2.54cm = 25.4 mm = 72pt = 6pc
示例：
div { font-size : 3.3mm; }


cm版本：CSS1　 兼容性：IE3+ NS4+
说明：
绝对长度单位。厘米（Centimeter）。
1in = 2.54cm = 25.4 mm = 72pt = 6pc
示例：
div { font-size : 0.33cm; }


rgb ( R , G , B ) 版本：CSS1　 兼容性：IE4+ NS4+
参数：
R | : | 红色值。正整数 | 百分数
G | : | 绿色值。正整数 | 百分数
B | : | 蓝色值。正整数 | 百分数
说明：
颜色单位。
以上三个参数，正整数值的取值范围为：0 - 255。百分数值的取值范围为：0.0% - 100.0%。超出范围的数值将被截至其最接近的取值极限。
并非所有浏览器都支持使用百分数值。
请参阅 附录：颜色表 。
示例：
div { color: rgb(132,20,180); }
div { color: rgb(12%,200,50%); }


#RRGGBB版本：CSS1　 兼容性：IE4+ NS4+
参数：
RR | : | 红色值。十六进制正整数
GG | : | 绿色值。十六进制正整数
BB | : | 蓝色值。十六进制正整数
说明：
颜色单位。
以上三个参数，取值范围为：00 - FF。
参数必须是两位数。对于只有一位的，应在前面补零。
如果每个参数各自在两位上的数字都相同，那么本单位也可缩写为 #RGB 的方式。例如：#FF8800 可以缩写为 #F80。
请参阅 附录：颜色表 。
示例：
div { color: #FF0000; }
div { color: #F00; }


Color Name版本：CSS1　 兼容性：IE4+ NS4+
说明：
颜色单位。颜色名称。不同的浏览器会有不同的预定义颜色名称。请查看 附录：颜色表 。
示例：
div {color: red; }


deg版本：CSS2　 兼容性：无
说明：
角度单位。度。一个圆圈的360等分之一。
示例：
body { azimuth: 75deg }
body { elevation: 75deg }


grad版本：CSS2　 兼容性：无
说明：
角度单位。梯度。一个直角的100等分之一。一个圆圈相当于400grad。
示例：
body { azimuth: 75grad }
body { elevation: 75grad }


rad版本：CSS2　 兼容性：无
说明：
角度单位。弧度。把一个圆圈分成2*PI单位。
示例：
body { azimuth: 3rad }
body { elevation: 5rad }


s版本：CSS2　 兼容性：无
说明：
时间单位。秒。时间的国际主单位。
1s = 1000 ms
示例：
div { pause-after: 2s; }
div { pause-before: 2s; }


ms版本：CSS2　 兼容性：无
说明：
时间单位。微秒。
1s = 1000 ms
示例：
div { pause-after: 2s; }
div { pause-before: 2s; }


Hz版本：CSS2　 兼容性：无
说明：
频率单位。赫兹。声波的基本单位。
1kHz = 1000 Hz
示例：
strong { pitch: 75hz }


kHz版本：CSS2　 兼容性：无
说明：
频率单位。千赫。声波的基本单位。
1kHz = 1000 Hz
示例：
strong { pitch: 8kHz }


Gradient兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Gradient ( enabled=bEnabled , startColorStr=iWidth , endColorStr=iWidth )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
startColorStr : 可选项。字符串(String)。设置或检索色彩渐变的开始颜色和透明度。
其格式为 #AARRGGBB 。 AA 、 RR 、 GG 、 BB 为十六进制正整数。取值范围为 00 - FF 。 RR 指定红色值， GG 指定绿色值， BB 指定蓝色值，参阅 #RRGGBB 颜色单位。 AA 指定透明度。 00 是完全透明。 FF 是完全不透明。超出取值范围的值将被恢复为默认值。
取值范围为 #FF000000 - #FFFFFFFF 。默认值为 #FF0000FF 。不透明蓝色。
EndColorStr : 可选项。字符串(String)。设置或检索色彩渐变的结束颜色和透明度。参阅 startColorStr 属性。默认值为 #FF000000 。不透明黑色。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
GradientType : 可读写。整数值(Integer)。设置或检索色彩渐变的方向。1 | 0
1 | : | 默认值。水平渐变。
0 | : | 垂直渐变。
StartColorStr : 可读写。字符串(String)。参阅 startColorStr 属性。
StartColor : 可读写。整数值(Integer)。设置或检索色彩渐变的开始颜色。 取值范围为 0 - 4294967295 。 0 为透明。 4294967295 为不透明白色。
EndColorStr : 可读写。字符串(String)。设置或检索色彩渐变的结束颜色和透明度。参阅 startColorStr 属性。默认值为 #FF000000 。不透明黑色。
EndColor : 可读写。整数值(Integer)。设置或检索色彩渐变的结束颜色。 取值范围为 0 - 4294967295 。 0 为透明。 4294967295 为不透明白色。当在脚本中使用此特性时，也可以用十六进制格式： 0xAARRGGBB 。
说明：
在对象的背景和内容之间显示定制的色彩层。
当此效果通过转变显示时，在渐变册色彩层之上的文本程序性的初始化为透明的，当色彩渐变实现后，文本颜色会以其定义的值更新。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.gradient(enabled='false',startColorstr=#550000FF, endColorstr=#55FFFF00) ;}
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.gradient() ;}


AlphaImageLoader兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.AlphaImageLoader ( enabled=bEnabled , sizingMethod=sSize , src=sURL )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
sizingMethod : 可选项。字符串(String)。设置或检索滤镜作用的对象的图片在对象容器边界内的显示方式。
crop | : | 剪切图片以适应对象尺寸。
image | : | 默认值。增大或减小对象的尺寸边界以适应图片的尺寸。
scale | : | 缩放图片以适应对象的尺寸边界。
src : 必选项。字符串(String)。使用绝对或相对 url 地址指定背景图像。假如忽略此参数，滤镜将不会作用。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
sizingMethod | : | 可读写。字符串(String)。参阅 sizingMethod 属性。
src | : | 可读写。字符串(String)。参阅 src 属性。
说明：
在对象容器边界内，在对象的背景和内容之间显示一张图片。并提供对此图片的剪切和改变尺寸的操作。如果载入的是PNG(Portable Network Graphics)格式，则0%-100%的透明度也被提供。
PNG(Portable Network Graphics)格式的图片的透明度不妨碍你选择文本。也就是说，你可以选择显示在PNG(Portable Network Graphics)格式的图片完全透明区域后面的内容。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='rain1977.gif',sizingMethod='scale');}
.dream{filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='images/earglobe.gif');}


Alpha兼容性：IE4.0+
语法：
filter : progid:DXImageTransform.Microsoft.Alpha ( enabled=bEnabled , style=iStyle , opacity=iOpacity , finishOpacity=iFinishOpacity , startX=iPercent , startY=iPercent , finishX=iPercent , finishY=iPercent )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
style : 可选项。整数值(Integer)。设置或检索透明渐变的样式。0 | 1 | 2 | 3
0 | : | 默认值。整体透明度。将 Opacity 值均匀的作用于对象。
1 | : | 线性渐变透明度。从由 StartX 和 StartY 决定的点，由 Opacity 决定的透明度开始，到由 FinishX 和 FinishY 决定的点，由 FinishOpacity 决定的透明度结束。
2 | : | 圆形放射渐变透明度。圆形放射区域的圆心为对象的中心，圆周到与对象的边相切为止。透明渐变由圆心开始，到圆周结束。开始透明度由 Opacity 决定，结束透明度由 FinishOpacity 决定。
3 | : | 矩形放射渐变透明度。由对象的边开始，到对象的中心结束。开始透明度由 Opacity 决定，结束透明度由 FinishOpacity 决定。
opacity : 可选项。整数值(Integer)。设置或检索透明渐变的开始透明度。取值范围为 0 - 100 。默认值为 0 ，即完全透明。 100 为完全不透明。
finishOpacity : 可选项。整数值(Integer)。设置或检索透明渐变的结束透明度。取值范围为 0 - 100 。默认值为 0 ，即完全透明。 100 为完全不透明。
startX : 可选项。整数值(Integer)。设置或检索透明渐变开始点的水平坐标。其数值作为对象宽度的百分比值处理。默认值为 0 。
startY : 可选项。整数值(Integer)。设置或检索透明渐变开始点的垂直坐标。其数值作为对象高度的百分比值处理。默认值为 0 。
finishX : 可选项。整数值(Integer)。设置或检索透明渐变结束点的水平坐标。其数值作为对象宽度的百分比值处理。默认值为 0 。
finishY : 可选项。整数值(Integer)。设置或检索透明渐变结束点的垂直坐标。其数值作为对象高度的百分比值处理。默认值为 0 。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
Style | : | 可读写。整数值(Integer)。参阅 style 属性。
Opacity | : | 可读写。整数值(Integer)。参阅 opacity 属性。
FinishOpacity | : | 可读写。整数值(Integer)。参阅 finishOpacity 属性。
StartX | : | 可读写。整数值(Integer)。参阅 startX 属性。
StartY | : | 可读写。整数值(Integer)。参阅 startY 属性。
FinishX | : | 可读写。整数值(Integer)。参阅 finishX 属性。
FinishY | : | 可读写。整数值(Integer)。参阅 finishY 属性。
说明：
调整对象内容的透明度。
你可以设置整体透明度，或线性渐变和放射渐变的透明度。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.Alpha(opacity=50);}
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.Alpha(opacity=10,finishOpacity=100,style=2);}


BasicImage兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.BasicImage ( enabled=bEnabled , grayScale=bGray , mirror=bMirror , opacity=fOpacity , XRay=bXRay )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
grayScale : 可选项。布尔值(Boolean)。设置或检索是否以灰度显示对象内容。0 | 1
1 | : | 以灰度效果显示对象内容。
0 | : | 默认值。显示对象的原始色彩。
mirror : 可选项。布尔值(Boolean)。设置或检索是否反转显示对象内容。0 | 1
1 | : | 反转显示对象内容。
0 | : | 默认值。正常显示对象内容。
opacity : 可选项。浮点数(Float)。设置对象内容的透明度。取值范围为 0.0 - 1.0 。默认值为 1.0 。不透明黑色。 0.0 为完全透明。
XRay : 可选项。布尔值(Boolean)。设置或检索是否以X光效果显示对象内容。0 | 1
1 | : | 以X光效果显示对象内容。
0 | : | 默认值。正常显示对象内容。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
GrayScale : 可读写。布尔值(Boolean)。参阅 grayScale 属性。
Invert : 可读写。布尔值(Boolean)。设置或检索对象内容是否反相显示。0 | 1
1 | : | 反相显示对象内容。
0 | : | 默认值。显示对象的原始色彩。
Mask : 可读写。布尔值(Boolean)。设置或检索是否依据 MaskColor 的值为对象添加遮罩(Mask)。0 | 1
1 | : | 添加遮罩。
0 | : | 默认值。显示对象的原始色彩。
MaskColor : 可读写。整数值(Integer)。设置或检索遮罩颜色。
其格式为 0xAARRGGBB 。 AA 、 RR 、 GG 、 BB 为十六进制正整数。取值范围为 00 - FF 。 RR 指定红色值， GG 指定绿色值， BB 指定蓝色值，参阅 #RRGGBB 颜色单位。 AA 指定透明度。 00 是完全透明。 FF 是完全不透明。
取值范围为 0x00000000 - 0xFFFFFFFF 。默认值为 0x00000000 。不透明黑色。
Mirror : 可读写。布尔值(Boolean)。参阅 mirror 属性。
Opacity : 可读写。浮点数(Float)。参阅 opacity 属性。
Rotation : 可读写。整数值(Integer)。设置或检索对象内容的旋转。0 | 1 | 2 | 3
0 | : | 默认值。内容不旋转。
1 | : | 内容旋转90度。
2 | : | 内容旋转180度。
3 | : | 内容旋转270度。
XRay : 可读写。布尔值(Boolean)。参阅 XRay 属性。
说明：
用于色彩处理，图像旋转，或对象内容的透明度。
当此效果通过转变显示时，在渐变册色彩层之上的文本程序性的初始化为透明的，当色彩渐变实现后，文本颜色会以其定义的值更新。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.BasicImage(opacity=.2); }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.BasicImage(invert=1); }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.BasicImage(invert=1,GrayScale=1); }


Blur兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Blur ( enabled=bEnabled , makeShadow=bShadow , pixelRadius=flRadius , shadowOpacity=fOpacity )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
makeShadow : 可选项。布尔值(Boolean)。设置或检索对象的内容是否被处理为阴影显示。 true | false
true | : | 对象的内容被处理为阴影。此时，整个对象被设置为黑色，然后被添加模糊效果。调整 ShadowOpacity 参数值可以控制其暗度。
false | : | 默认值。显示对象的原始色彩。
pixelRadius : 可选项。浮点数(Float)。设置或检索模糊效果的作用深度。默认单位为像素( px )。
取值范围为 1.0 - 100.0 。默认值为 2.0 。当此参数值小于 1.0 时滤镜失去作用。当此参数值大于 100.0 时，此参数使用默认值 2.0 。
shadowOpacity : 可选项。浮点数(Float)。设置或检索使用 makeShadow 制作成的阴影的透明度(暗度)。
取值范围为 0.0 - 1.0 。 0.0 为完全透明。 1.0 为完全不透明。默认值为 0.75 。当此参数值不在取值范围内时，此参数使用默认值 0.75 。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
MakeShadow | : | 可读写。布尔值(Boolean)。参阅 makeShadow 属性。
PixelRadius | : | 可读写。浮点数(Float)。参阅 pixelRadius 属性。
ShadowOpacity | : | 可读写。浮点数(Float)。参阅 shadowOpacity 属性。
说明：
制作对象内容的模糊效果。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.blur() ; }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.blur(pixelradius=3.0, makeshadow='true', ShadowOpacity=1.0); }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.blur(pixelradius=3, enabled='false') ; }


Chroma兼容性：IE4.0+
语法：
filter : progid:DXImageTransform.Microsoft.Chroma ( enabled=bEnabled , color=sColor )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
color : 可选项。字符串(String)。设置或检索此滤镜作用的颜色值。
其格式为 #AARRGGBB 。 AA 、 RR 、 GG 、 BB 为十六进制正整数。取值范围为 00 - FF 。 RR 指定红色值， GG 指定绿色值， BB 指定蓝色值，参阅 #RRGGBB 颜色单位。 AA 指定透明度。 00 是完全透明。 FF 是完全不透明。
默认值为 #FF0000FF 。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
Color | : | 可读写。字符串(String)。参阅 color 属性。
说明：
将对象中指定的颜色显示为透明。
不建议在8位到24位抖动的图片文件上使用此滤镜。例如保存时会抖动和压缩的JPEG格式图片文件，应用此滤镜，其结果会很难看。
此效果在羽化(柔化色彩以同周围相邻的颜色平和的过渡)的线条等处也不会很好的作用。
确定的 color 参数值可能会导致图片自身的透明颜色变为不透明。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.Chroma(color='yellow'), progid:DXImageTransform.Microsoft.Chroma(color='red') ; }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.Chroma(color='yellow') ; }


Compositor兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Compositor ( function=sFunction )
属性：
function : 可选项。整数值(Integer)。设置或检索混合方式。 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 19 | 20 | 21 | 22 | 23 | 24 | 25
0 | : | 默认值。清除。不执行任何操作。
1 | : | MIN 。比较A和B的每一个像素的亮度，将亮度较低的像素点显示出来。
2 | : | MAX 。比较A和B的每一个像素的亮度，将亮度较高的像素点显示出来。
3 | : | A。仅仅显示A。
4 | : | A OVER B。在B之上显示A。A被完全显示，B通过A的透明区域显示出来。
5 | : | A IN B。显示被A被B包含的部分。只有两个图像 alpha 值都不为 0 的区域被显示。B不会有任何部分穿透显示。
6 | : | A OUT B。显示A没有被B包含的部分。B不会有任何部分穿透显示。
7 | : | A ATOP B。 显示A遮盖B，每个取样都通过B的 alpha 通道依比例测定获得。
8 | : | A SUBTRACT B。以B的颜色取样值减去A的相应颜色取样值的方式显示A。结果颜色通过A的 alpha 通道依比例测定获得。
9 | : | A ADD B。以B的颜色取样值加上A的相应颜色取样值的方式显示A。 结果颜色通过A的 alpha 通道依比例测定获得。
10 | : | A XOR B。显示A和B没有相互交叠的像素点。交叠的像素通过它们反转的 alpha 值依比例测定。
19 | : | B。仅仅显示B。
20 | : | B OVER A。在A之上显示B。B被完全显示，A通过B的透明区域显示出来。
21 | : | B IN A。显示被B被A包含的部分。只有两个图像 alpha 值都不为 0 的区域被显示。A不会有任何部分穿透显示。
22 | : | B OUT A。显示B没有被A包含的部分。A不会有任何部分穿透显示。
23 | : | B ATOP A。 显示B遮盖A，每个取样都通过A的 alpha 通道依比例测定获得。
24 | : | B SUBTRACT A。以A的颜色取样值减去B的相应颜色取样值的方式显示B。结果颜色通过B的 alpha 通道依比例测定获得。
25 | : | B ADD A。以A的颜色取样值加上B的相应颜色取样值的方式显示B。 结果颜色通过B的 alpha 通道依比例测定获得。
特性：
Function : 可读写。整数值(Integer)。参阅 function 属性。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
说明：
依据初始对象和新对象色彩的特定混合方式显示新的对象内容。
这个滤镜提供了丰富的将输入对象的色彩和透明度相互作用的图像合成的功能设置。要建立转换滤镜，遵循下列步骤：
  1. 选择一个功能( function )。
  2. 设置对象的合成滤镜( filter )的属性声明。
  3. 确定滤镜对象初始显示的内容。合成功能将此作为输入 A 。
  4. 使用合成滤镜的 apply 方法。捕获对象内容的初始显示，为转换做必要的准备。
  5. 改变对象的属性，如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。合成功能将此作为输入 B 。
  6. 使用合成滤镜的 play 方法。这会将合成功能输出的图像变化显示出来。
示例：
#idDiv{ filter:progid:DXImageTransform.Microsoft.Compositor(function=20, duration=7);}


DropShadow兼容性：IE4.0+
语法：
filter : progid:DXImageTransform.Microsoft.DropShadow ( enabled=bEnabled , color=sColor , offX=iOffsetX , offY=iOffsetY , positive=bPositive )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
color : 可选项。字符串(String)。设置或检索此滤镜作用的颜色值。
其格式为 #AARRGGBB 。 AA 、 RR 、 GG 、 BB 为十六进制正整数。取值范围为 00 - FF 。 RR 指定红色值， GG 指定绿色值， BB 指定蓝色值，参阅 #RRGGBB 颜色单位。 AA 指定透明度。 00 是完全透明。 FF 是完全不透明。
默认值为 #FF404040 。
offX : 可选项。整数值(Integer)。单位为像素( px )。设置或检索阴影在横坐标轴上以对象为基准的偏移量。正值向右偏移，负值向左偏移。默认值为 5 。
offY : 可选项。整数值(Integer)。单位为像素( px )。设置或检索阴影在纵坐标轴上以对象为基准的偏移量。正值向下偏移，负值向上偏移。默认值为 5 。
positive : 可选项。布尔值(Boolean)。设置或检索滤镜是否从对象的非透明像素建立阴影。假如你有一个透明的对象但想给它建立普通的阴影，设置此参数值为 true。这会让透明对象的阴影在透明区域外，而非在透明区域内。true | false
true | : | 默认值。滤镜从对象的非透明像素建立阴影。
false | : | 滤镜从对象的透明像素建立阴影。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
Color | : | 可读写。字符串(String)。参阅 color 属性。
OffX | : | 可读写。整数值(Integer)。参阅 offX 属性。
OffY | : | 可读写。整数值(Integer)。参阅 offY 属性。
Positive | : | 可读写。布尔值(Boolean)。参阅 positive 属性。
说明：
制作对象的阴影效果。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.dropshadow(OffX=5, OffY=5, Color='gray', Positive=true); }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.dropshadow(Positive=true) ; }


Emboss兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Emboss ( enabled=bEnabled , Bias=fBias )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
Bias : 可选项。浮点数(Float)。设置或检索添加到滤镜结果的每种颜色组分的值的百分比。取值范围为 -1.0 - 1.0 。默认值为 0.7 。大的此参数值产生高亮滤光效果。高对比度的图片受此滤镜的影响较小。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
Bias | : | 可读写。浮点数(Float)。参阅 Bias 属性。
说明：
用灰度值为对象内容制作浮雕纹理效果。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.emboss(enabled='false') ; }


Engrave兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Engrave ( enabled=bEnabled , Bias=fBias )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
Bias : 可选项。浮点数(Float)。设置或检索添加到滤镜结果的每种颜色组分的值的百分比。取值范围为 -1.0 - 1.0 。默认值为 0.7 。大的此参数值产生高亮滤光效果。高对比度的图片受此滤镜的影响较小。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
Bias | : | 可读写。浮点数(Float)。参阅 Bias 属性。
说明：
用灰度值为对象内容制作浮雕纹理效果。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.emboss(enabled='false') ; }


Glow兼容性：IE4.0+
语法：
filter : progid:DXImageTransform.Microsoft.Glow ( enabled=bEnabled , color=sColor , strength=iDistance )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
color : 可选项。字符串(String)。设置或检索此滤镜作用的颜色值。
其格式为 #RRGGBB 。 RR 、 GG 、 BB 为十六进制正整数。取值范围为 00 - FF 。 RR 指定红色值， GG 指定绿色值， BB 指定蓝色值，参阅 #RRGGBB 颜色单位。
默认值为 #FF0000 。
strength : 可选项。整数值(Integer)。单位为像素( px )。设置或检索以对象为基准的向外扩散距离。取值范围为 1 - 255 。默认值为 5 。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
Color | : | 可读写。字符串(String)。参阅 color 属性。
Strength | : | 可读写。整数值(Integer)。参阅 strength 属性。
说明：
环绕对象内容边缘添加辉光制作发热效果。辉光将出现在对象边界内的内容的最外轮廓之外。
  • 假如对象内有文本而无背景( background )和图片，则每个文本字符将会被辉光环绕。
  • 假如对象内有背景( background )或图片，则整个对象容器会被辉光环绕。
  • 假如对象的子对象定位超出了对象边界，则仅仅在对象容器内的内容会被辉光环绕。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter: glow(Color=blue,Strength=5) ; }
#idDiv{position:absolute; left:140px; height:400; width:400;filter: glow(color=#000000) ; }


Light兼容性：IE4.0+
语法：
filter : progid:DXImageTransform.Microsoft.Light ( enabled=bEnabled )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
方法：
addAmbient (iRed,iGreen,iBlue,iStrength) : 为滤镜添加环境光。环境光是无方向的，并且均匀的洒在页面的表面。环境光有颜色和强度值，可以为对象田家更多的颜色。它通常和其他光一起使用。无返回值。参数见下表。
iRed | : | 必选项。整数值(Integer)。 指定红色值。取值范围为 0 - 255 。
iGreen | : | 必选项。整数值(Integer)。 指定绿色值。取值范围为 0 - 255 。
iBlue | : | 必选项。整数值(Integer)。 指定蓝色值。取值范围为 0 - 255 。
iStrength | : | 必选项。整数值(Integer)。 指定光强度。取值范围为 0 - 100 。
addCone (iX1,iY1,iZ1,iX2,iY,iRed,iGreen,iBlue,iStrength,iSpread) : 为滤镜添加锥形光以向对象的表面投射有方向的光束。光束会随延伸的距离而逐渐减弱。无返回值。参数见下表。
iX1 | : | 必选项。整数值(Integer)。指定光源的左坐标值。
iY1 | : | 必选项。整数值(Integer)。指定光源的上坐标值。
iZ1 | : | 必选项。整数值(Integer)。指定光源的Z坐标值。
iX2 | : | 必选项。整数值(Integer)。指定光焦点的左坐标值。
iY2 | : | 必选项。整数值(Integer)。指定光焦点的上坐标值。
iRed | : | 必选项。整数值(Integer)。指定红色值。取值范围为 0 - 255 。
iGreen | : | 必选项。整数值(Integer)。指定绿色值。取值范围为 0 - 255 。
iBlue | : | 必选项。整数值(Integer)。指定蓝色值。取值范围为 0 - 255 。
iStrength | : | 必选项。整数值(Integer)。指定光强度。取值范围为 0 - 100 。
iSpread | : | 必选项。整数值(Integer)。指定光源的虚拟位置与对象的表面之间的角度或张度。取值范围为 0 - 90 。
addPoint (iX,iY,iZ,iRed,iGreen,iBlue,iStrength) : 为滤镜添加点光。无返回值。参数见下表。
iX | : | 必选项。整数值(Integer)。指定光源的左坐标值。
iY | : | 必选项。整数值(Integer)。指定光源的上坐标值。
iZ | : | 必选项。整数值(Integer)。指定光源的Z坐标值。
iRed | : | 必选项。整数值(Integer)。指定红色值。取值范围为 0 - 255 。
iGreen | : | 必选项。整数值(Integer)。指定绿色值。取值范围为 0 - 255 。
iBlue | : | 必选项。整数值(Integer)。指定蓝色值。取值范围为 0 - 255 。
iStrength | : | 必选项。整数值(Integer)。指定光强度。取值范围为 0 - 100 。
changeColor (iLightNumber,iRed,iGreen,iBlue,fAbsolute) : 改变光的颜色。无返回值。参数见下表。
iLightNumber | : | 必选项。整数值(Integer)。 指定光的标识符。
iRed | : | 必选项。整数值(Integer)。指定红色值。取值范围为 0 - 255 。
iGreen | : | 必选项。整数值(Integer)。指定绿色值。取值范围为 0 - 255 。
iBlue | : | 必选项。整数值(Integer)。指定蓝色值。取值范围为 0 - 255 。
fAbsolute | : | 必选项。布尔值(Boolean)。指定改变是替换当前设置的绝对值，还是加到当前设置的相对值。此参数不等于零表示采用绝对值。否则表示采用相对值。
changeStrength (iLightNumber,iStrength,fAbsolute) : 改变光的强度。无返回值。参数见下表。
iLightNumber | : | 必选项。整数值(Integer)。 指定光的标识符。
iStrength | : | 必选项。整数值(Integer)。指定光强度。取值范围为 0 - 100 。
fAbsolute | : | 必选项。布尔值(Boolean)。指定改变是替换当前设置的绝对值，还是加到当前设置的相对值。此参数不等于零表示采用绝对值。否则表示采用相对值。
clear () : 清除所有与当前滤镜关联的光。无返回值。
moveLight (iLightNumber,iX,iY,iZ,fAbsolute) : 移动锥形光的焦点或点光的原点。对于锥形光来说，此方法改变 x,y 目标坐标值；对于点光来说，此方法改变 x,y,z 源坐标值。 此方法不作用于环境光。
无返回值。参数见下表。
iLightNumber | : | 必选项。整数值(Integer)。 指定光的标识符。
iX | : | 必选项。整数值(Integer)。指定光源的左坐标值。
iY | : | 必选项。整数值(Integer)。指定光源的上坐标值。
iZ | : | 必选项。整数值(Integer)。指定光源的Z坐标值。
fAbsolute | : | 必选项。布尔值(Boolean)。指定改变是替换当前设置的绝对值，还是加到当前设置的相对值。此参数等于 true 表示采用绝对值。等于 false 表示采用相对值。
说明：
为对象的内容建立光照效果。
你可以控制光源的虚拟位置，还可以控制光焦点的横纵坐标值。以及光的类型和强度。每个滤镜最多可以添加 10 束光。要想在页面上添加更多的光，你必须使用多个滤镜。
当每束光被建立后，都有默认的环境光与之关联。你添加到对象的第一束光会替换掉它的默认的环境光。
示例：
.aFilter { background-color: #FFFFFF; filter:light();color: cyan;width: 150;}


MaskFilter兼容性：IE4.0+
语法：
filter : progid:DXImageTransform.Microsoft.MaskFilter ( enabled=bEnabled , color=sColor )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
color : 可选项。字符串(String)。设置或检索此滤镜作用的颜色值。
其格式为 #AARRGGBB 。 AA 、 RR 、 GG 、 BB 为十六进制正整数。取值范围为 00 - FF 。 RR 指定红色值， GG 指定绿色值， BB 指定蓝色值，参阅 #RRGGBB 颜色单位。 AA 指定透明度。 00 是完全透明。 FF 是完全不透明。
默认值为 #FF000000 。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
Color | : | 可读写。字符串(String)。参阅 color 属性。
说明：
将对象内容的透明像素用 color 参数指定的颜色显示作为一个遮罩，而非透明像素则转为透明。
使用 BasicImage 滤镜能够更有效率的实现这一效果。
示例：
DIV.aFilter {filter:mask(color=#008800); width: 100;}


Matrix兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Matrix ( enabled=bEnabled , SizingMethod=sMethod , FilterType=sType , Dx=fDx , Dy=fDy , M11=fM11 , M12=fM12 , M21=fM21 , M22=fM22 )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
SizingMethod : 可选项。字符串(String)。设置或检索容器是否改变尺寸去适应目标图像。clip to original | auto expand
clip to original | : | 默认值。容器不改变尺寸。
auto expand | : | 容器改变尺寸以适应目标图像。
FilterType : 可选项。字符串(String)。设置或检索定义新内容的像素的方法。bilinear | nearest neighbor
要想获得最好的平滑的静态滤镜效果，请使用 bilinear 方法参数。而当用于动画图像时， nearest neighbor 方法参数因其运算速度较快从而能够提供动画每秒更多图像。
bilinear | : | 默认值。使用 bilinear 方法定义目标像素的色彩内容。
nearest neighbor | : | 使用 nearest neighbor 方法定义目标像素的色彩内容。
Dx : 可选项。浮点数(Float)。设置或检索线性转换的向量增加 X 。默认值为 1.0 。当 SizingMethod 属性设置为 auto expand 时此属性设置被忽略。
Dy : 可选项。浮点数(Float)。设置或检索线性转换的向量增加 Y 。默认值为 1.0 。当 SizingMethod 属性设置为 auto expand 时此属性设置被忽略。
M11 : 可选项。浮点数(Float)。设置或检索线性转换的第一行/第一列矩阵输入。默认值为 1.0 。
M12 : 可选项。浮点数(Float)。设置或检索线性转换的第一行/第二列矩阵输入。默认值为 0.0 。
M21 : 可选项。浮点数(Float)。设置或检索线性转换的第二行/第一列矩阵输入。默认值为 0.0 。
M22 : 可选项。浮点数(Float)。设置或检索线性转换的第二行/第二列矩阵输入。默认值为 1.0 。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
SizingMethod | : | 可读写。字符串(String)。参阅 SizingMethod 属性。
FilterType | : | 可读写。字符串(String)。参阅 FilterType 属性。
Dx | : | 可读写。浮点数(Float)。参阅 Dx 属性。
Dy | : | 可读写。浮点数(Float)。参阅 Dy 属性。
M11 | : | 可读写。浮点数(Float)。参阅 M11 属性。
M12 | : | 可读写。浮点数(Float)。参阅 M12 属性。
M21 | : | 可读写。浮点数(Float)。参阅 M21 属性。
M22 | : | 可读写。浮点数(Float)。参阅 M22 属性。
说明：
使用矩阵变形实现对象内容的改变尺寸、旋转、上下或左右反转。
使用此滤镜可以建立下列效果：
  1. 左右反转。将 M11 和 M12 的值取负。
  2. 上下反转。将 M21 和 M22 的值取负。
  3. 改变尺寸。将 M11 和 M12 和 M21 和 M22 的值乘以相同的因数。对象内容尺寸会按比例增大或缩小。
使用 padding 属性能够使最终图像边角被剪切的机会降到最小。
示例：
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.Matrix(enabled='false') ; }
#idDiv{position:absolute; left:140px; height:400; width:400;filter:progid:DXImageTransform.Microsoft.Matrix(M11=1.0, sizingmethod="auto expand"); }


MotionBlur兼容性：IE4.0+
语法：
filter : progid:DXImageTransform.Microsoft.MotionBlur ( enabled=bEnabled , add=bAddImage , direction=iOffset , strength=iDistance )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
add : 可选项。布尔值(Boolean)。设置或检索滤镜作用图像是否覆盖原始图像。true | false
true | : | 滤镜作用图像覆盖原始图像。
false | : | 默认值。只显示滤镜作用图像。
direction : 可选项。整数值(Integer)。设置或检索滤镜效果的运动偏移方向。默认单位为角度。0 | 45 | 90 | 135 | 180 | 225 | 270 | 315
小于 0 或大于 360 的值会自动转换为 0 - 360 之间的值。例如， -45 会转换为 315 。
0 | : | 上。
45 | : | 右上。
90 | : | 下。
135 | : | 右下。
180 | : | 下。
225 | : | 左下。
270 | : | 默认值。左。
315 | : | 左上。
strength : 可选项。整数值(Integer)。单位为像素( px )。设置或检索以对象为基准的在运动方向上的向外扩散距离。取值范围为 >=0 。默认值为 5 。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
Add | : | 可读写。布尔值(Boolean)。参阅 add 属性。
Direction | : | 可读写。整数值(Integer)。参阅 direction 属性。
Strength | : | 可读写。整数值(Integer)。参阅 strength 属性。
说明：
为对象内容制作运动模糊效果。
示例：
DIV.aFilter {filter:progid:DXImageTransform.Microsoft.MotionBlur(Strength=5,Direction=90);}
#oDIV {filter:progid:DXImageTransform.Microsoft.MotionBlur(Strength=10, Direction=45, Add='true');}


Shadow兼容性：IE4.0+
语法：
filter : progid:DXImageTransform.Microsoft.Shadow ( enabled=bEnabled , color=sColor , direction=iOffset , strength=iDistance )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
color : 可选项。字符串(String)。设置或检索此滤镜作用的颜色值。
其格式为 #RRGGBB 。 RR 、 GG 、 BB 为十六进制正整数。取值范围为 00 - FF 。 RR 指定红色值， GG 指定绿色值， BB 指定蓝色值，参阅 #RRGGBB 颜色单位。
direction : 可选项。整数值(Integer)。设置或检索滤镜效果的运动偏移方向。默认单位为角度。0 | 45 | 90 | 135 | 180 | 225 | 270 | 315
小于 0 或大于 360 的值会自动转换为 0 - 360 之间的值。例如， -45 会转换为 315 。
0 | : | 上。
45 | : | 右上。
90 | : | 下。
135 | : | 右下。
180 | : | 下。
225 | : | 默认值。左下。
270 | : | 左。
315 | : | 左上。
strength : 可选项。整数值(Integer)。单位为像素( px )。设置或检索以对象为基准的在运动方向上的向外扩散距离。取值范围为 >=0 。默认值为 5 。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
Color | : | 可读写。字符串(String)。参阅 color 属性。
Direction | : | 可读写。整数值(Integer)。参阅 direction 属性。
Strength | : | 可读写。整数值(Integer)。参阅 strength 属性。
说明：
为对象内容建立阴影效果。
示例：
DIV.aFilter {filter:progid:DXImageTransform.Microsoft.Shadow(Strength=5,Direction=90);}
#oDIV {filter:progid:DXImageTransform.Microsoft.Shadow(Strength=10, Direction=45, color=blue);}


Wave兼容性：IE4.0+
语法：
filter : progid:DXImageTransform.Microsoft.Wave ( enabled=bEnabled , add=bAddImage , freq=iWaveCount , lightStrength=iPercentage , phase=iPercentage , strength=iDistance )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
add : 可选项。布尔值(Boolean)。设置或检索滤镜作用图像是否覆盖原始图像。true | false
true | : | 滤镜作用图像覆盖原始图像。
false | : | 默认值。只显示滤镜作用图像。
freq : 可选项。整数值(Integer)。设置或检索滤镜建立的波浪数目。默认值为 3 。
lightStrength : 可选项。整数值(Integer)。设置或检索滤镜建立的波浪浪尖和波谷之间的距离。取值范围为 0 - 100 。默认值为 100 。
phase : 可选项。整数值(Integer)。设置或检索正弦波开始处的相位偏移。取值范围为 0 - 100 。默认值为 0 。
strength : 可选项。整数值(Integer)。单位为像素( px )。设置或检索以对象为基准的在运动方向上的向外扩散距离。取值范围为 >=1 。默认值为 1 。
特性：
Enabled | : | 可读写。布尔值(Boolean)。参阅 enabled 属性。
Add | : | 可读写。布尔值(Boolean)。参阅 add 属性。
Freq | : | 可读写。整数值(Integer)。参阅 freq 属性。
LightStrength | : | 可读写。整数值(Integer)。参阅 lightStrength 属性。
Phase | : | 可读写。整数值(Integer)。参阅 phase 属性。
Strength | : | 可读写。整数值(Integer)。参阅 strength 属性。
说明：
为对象内容建立波纹扭曲效果。
示例：
DIV.aFilter {filter:progid:DXImageTransform.Microsoft.Wave(Strength=5);}
#oDIV {filter:progid:DXImageTransform.Microsoft.Wave(Strength=10, Add=true);}


ICMFilter兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.ICMFilter ( colorSpace=sPathFilename , intent =sIntent )
属性：
colorSpace : 可选项。字符串(String)。设置或检索颜色配置文件(.icm)的路径和名称。如果颜色配置文件(.icm)被指定，滤镜输出将模拟使用此颜色配置文件(.icm)的硬件设备的输出。
颜色配置文件(.icm)为硬件装置定义了色彩内容与 sRGB 标准的映射比较。 sFile | sRGB
sFile | : | 默认值。确定颜色配置文件(.icm)的路径和名称。
sRGB | : | 确定标准颜色空间。
intent : 可选项。字符串(String)。设置或检索对象的色彩内容的预定效果。滤镜会根据选择的效果调整色彩输出改善内容显示。
要获取你的显示器或打印机的色彩处理能力的最大优势，选择最符合你的内容的此属性值。 Picture | Graphic | Proof | Match
Picture | : | 默认值。强调色彩连续性。适用于图像和照片。
Graphic | : | 强调颜色的饱和度胜过其色调和明度。适用于商业图片。
Proof | : | 使用最接近的颜色匹配不被支持的颜色。白点不被保护。
Match | : | 使用最接近的颜色匹配不被支持的颜色。白点受到保护。
特性：
ColorSpace | : | 可读写。字符串(String)。参阅 colorSpace 属性。
Intent | : | 可读写。字符串(String)。参阅 intent 属性。
说明：
根据颜色配置文件(.icm)转换对象的色彩内容。这样能激活对某些细节内容的显示改良，或对硬件设备输出的模拟显示。像打印机或显示器。
通过根据要显示内容的类型匹配恰当的 Intent 特性值可以改善内容显示或打印的质量。例如，当你打印时，可以设置 Intent 特性值为 Graphic 从而确保颜色对比度的恰当。较高的对比度能够使打印出的内容清晰易读。
要模拟硬件设备的色彩输出，你必须定位硬件设备的颜色配置文件(.icm)，假如制造商提供了这个文件。将这个颜色配置文件(.icm)的路径和名称指给 ColorSpace 特性，并且对硬件装置要使用的内容应用此滤镜。颜色配置文件(.icm)为你的显示器定义了内容的颜色与显示器标准颜色的偏差。这样滤镜显示就可以模拟 其他硬件设备的输出。
示例：
#idDiv{ filter:progid:DXImageTransform.Microsoft.ICMFilter(colorSpace=sRGB, intent=Picture);}


Xray兼容性：IE4.0+
语法：
filter : Xray ( enabled=bEnabled )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
说明：
以X光效果显示对象内容。
使用 BasicImage 滤镜可以更有效率的建立效果。
示例：
#idDiv{ height:250px; width:250px; filter:Xray(); }


Gray兼容性：IE4.0+
语法：
filter : Gray ( enabled=bEnabled )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
说明：
灰度显示对象内容。
使用 BasicImage 滤镜可以更有效率的建立效果。
示例：
#idDiv{ height:250px; width:250px; filter:Gray(); }


Invert兼容性：IE4.0+
语法：
filter : Invert ( enabled=bEnabled )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
说明：
反相显示对象内容。
使用 BasicImage 滤镜可以更有效率的建立效果。
示例：
#idDiv{ height:250px; width:250px; filter:Invert(); }


FlipH兼容性：IE4.0+
语法：
filter : FlipH ( enabled=bEnabled )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
说明：
水平翻转对象内容。
使用 BasicImage 滤镜可以更有效率的建立效果。
示例：
#idDiv{ height:250px; width:250px; filter:FlipH(); }


FlipV兼容性：IE4.0+
语法：
filter : FlipV ( enabled=bEnabled )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
说明：
垂直翻转对象内容。
使用 BasicImage 滤镜可以更有效率的建立效果。
示例：
#idDiv{ height:250px; width:250px; filter:FlipV(); }


Redirect兼容性：无
说明：
目前未被支持。


Barn兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Barn ( enabled=bEnabled , duration=fDuration , motion=sMotion , orientation=sOrientation )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
motion : 可选项。字符串(String)。设置或检索对象的新内容是先从外显示还是先从内显示。out | in
out | : | 默认值。转换从对象的中心向四边进行。
in | : | 转换从对象的四边向中心进行。
orientation : 可选项。字符串(String)。设置或检索滤镜效果模拟的开关门是横向的还是纵向的。vertical | horizontal
vertical | : | 默认值。纵向线条转换。
horizontal | : | 横向线条转换。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
Motion : 可读写。字符串(String)。参阅 motion 属性。
Orientation : 可读写。字符串(String)。参阅 orientation 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用模拟开关门效果转换对象内容。
示例：
#idDiv{ filter:progid:DXImageTransform.Microsoft.Barn(function=20, duration=7);}


Blinds兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Blinds ( enabled=bEnabled , duration=fDuration , bands=iBands , Direction=sDirection )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
bands : 可选项。整数值(Integer)。设置或检索滤镜效果中有多少条百叶窗的窗格出现。取值范围为 1 - 100 。默认值为 10 。
Direction : 可选项。字符串(String)。设置或检索百叶窗开关的方向。down | up | right | left
down | : | 默认值。向下。
up | : | 向上。
right | : | 向右。
left | : | 向左。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
Bands : 可读写。整数值(Integer)。参阅 bands 属性。
Direction : 可读写。字符串(String)。参阅 Direction 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用百叶窗开关效果转换对象内容。
示例：
#idDiv{ filter:progid:DXImageTransform.Microsoft.Blinds(direction='down');}


CheckerBoard兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.CheckerBoard ( enabled=bEnabled , duration=fDuration , squaresX=iColumns , squaresY=iColumns , Direction=sDirection )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
squaresX : 可选项。整数值(Integer)。设置或检索滤镜效果中横向有多少条。取值范围为 >=2 。默认值为 12 。任何小于 2 的值都会被转为默认值 12 。
squaresY : 可选项。整数值(Integer)。设置或检索滤镜效果中纵向有多少条。取值范围为 >=2 。默认值为 10 。任何小于 2 的值都会被转为默认值 10 。
Direction : 可选项。字符串(String)。设置或检索网格推拉的方向。down | up | right | left
down | : | 向下。
up | : | 向上。
right | : | 默认值。向右。
left | : | 向左。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
SquaresX : 可读写。整数值(Integer)。参阅 squaresX 属性。
SquaresY : 可读写。整数值(Integer)。参阅 squaresY 属性。
Direction : 可读写。字符串(String)。参阅 Direction 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用类似国际象棋棋盘的网格推拉效果转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.CheckerBoard(duration=5, direction='left'); }


Fade兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Fade ( enabled=bEnabled , duration=fDuration , overlap=fOverlap )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
overlap : 可选项。浮点数(Real)。设置或检索在转换进程中源内容和目标内容都被显示的比例。取值范围为 0.0 - 1.0 。默认值为 1.0 。
假如此属性值设为 0.4 ， duration 属性值设为 10 ，则转换会发生下属行为：
  1. 前三秒，源对象开始隐出。
  2. 随后的四秒，源对象完全隐出，新内容同时隐入。
  3. 最后三秒，新内容完全隐入。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
Overlap : 可读写。浮点数(Real)。参阅 overlap 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用渐隐效果转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.Fade(duration=2);}


GradientWipe兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.GradientWipe ( enabled=bEnabled , duration=fDuration , gradientSize=fGradientWidth , motion=sMotion )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
gradientSize : 可选项。浮点数(Real)。设置或检索对象内容被梯度渐隐条覆盖的百分比。取值范围为 0.0 - 1.0 。默认值为 0.25 。
motion : 可选项。字符串(String)。设置或检索对象内容出现的方向是依据 WipeStyle 特性的设定，还是取反。forward | reverse
forward | : | 默认值。对象内容依据 WipeStyle 特性设定的流向出现。
reverse | : | 对象内容依据 WipeStyle 特性设定的流向的反方向出现。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
GradientSize : 可读写。浮点数(Real)。参阅 gradientSize 属性。
Motion : 可读写。字符串(String)。参阅 motion 属性。
WipeStyle : 可读写。字符串(String)。0 | 1
0 | : | 默认值。转换在水平方向上自左至右。
1 | : | 转换在垂直方向上自上至下。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用滚动渐隐效果转换对象内容。
示例：
#idDiv{height:250px; width:250px; background-color: orange; filter:progid:DXImageTransform.Microsoft.gradientWipe(duration=3, gradientsize=0.5);}


Inset兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Inset ( enabled=bEnabled , duration=fDuration )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用对角扩张效果转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.Inset();}


Iris兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Iris ( enabled=bEnabled , duration=fDuration , irisStyle=sShape , motion=sMotion )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
irisStyle : 可选项。字符串(String)。设置或检索剪切轮廓的外形。PLUS | DIAMOND | CIRCLE | CROSS | SQUARE | STAR
PLUS | : | 默认值。十字形。
DIAMOND | : | 菱形。
CIRCLE | : | 圆形。
CROSS | : | 交叉对角线形。
SQUARE | : | 矩形。
STAR | : | 星形。
motion : 可选项。字符串(String)。设置或检索对象的新内容是先从外显示还是先从内显示。out | in
out | : | 默认值。转换从对象的中心向四边进行。
in | : | 转换从对象的四边向中心进行。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
IrisStyle : 可读写。字符串(String)。参阅 irisStyle 属性。
Motion : 可读写。字符串(String)。参阅 motion 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用特殊形状剪切轮廓扩张或收缩显示效果转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.Iris(duration=3);}


Pixelate兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Pixelate ( enabled=bEnabled , duration=fDuration , maxSquare=iWidth )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
maxSquare : 可选项。整数值(Integer)。设置或检索转换中矩形色块的最大宽度。取值范围为 2 - 50 。默认值为 50 。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
MaxSquare : 可读写。整数值(Integer)。参阅 maxSquare 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
这个转换滤镜是一个复杂的视觉效果。在转换的前半段，对象内容先显示为矩形色块拼贴，然后矩形的宽度由一个像素增加至 MaxSquare 属性所设置的值。每个矩形的颜色由其所覆盖区域的像素的颜色平均值决定。接下来的转换的后半段，矩形被还原为新内容具体的图像像素，显示出新的内容。
在使用此转换滤镜前设置此滤镜的 Enabled 特性值为 false 。这将预防在转换发生前彩色拼贴效果的静态滤镜先在对象内容上发生作用。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.Pixelate(duration=3, enabled='false');}


RadialWipe兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.RadialWipe ( enabled=bEnabled , duration=fDuration ,wipeStyle=sStyle )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
wipeStyle : 可读写。字符串(String)。设置或检索转换所使用的擦除方式。CLOCK | WEDGE | RADIAL
CLOCK | : | 默认值。围绕对象的中心，自上方开始，顺时针旋转擦除。
WEDGE | : | 围绕对象的中心，自上方开始，同时向两边旋转擦除。
RADIAL | : | 以对象的左上角为圆心旋转擦除。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
WipeStyle : 可读写。字符串(String)。参阅 wipeStyle 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用放射状擦除效果转换对象内容。效果类似汽车挡风玻璃的刮雨刀。
示例：
#idDiv{height:250px; width:250px; background-color: orange; filter:progid:DXImageTransform.Microsoft.RadialWipe(duration=3);}


RandomBars兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.RandomBars ( enabled=bEnabled , duration=fDuration , orientation=sOrientation )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
orientation : 可读写。字符串(String)。设置或检索转换所使用的随机线条是横向的还是纵向的。horizontal | vertical
horizontal | : | 默认值。横向线条。
vertical | : | 纵向线条。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
Orientation : 可读写。字符串(String)。参阅 orientation 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用随机发生的线条转换对象内容。
示例：
#idDiv{height:250px; width:250px; background-color: orange; filter:progid:DXImageTransform.Microsoft.RandomBars(duration=3);}


RandomDissolve兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.RandomDissolve ( enabled=bEnabled , duration=fDuration )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用随机像素溶解效果转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.RandomDissolve();}


Slide兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Slide ( enabled=bEnabled , duration=fDuration , bands=iBands , slideStyle=sslideStyle )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
bands : 可选项。整数值(Integer)。设置或检索滤镜效果中有多少滑条被抽离。取值范围为 1 - 100 。默认值为 1 。
slideStyle : 可选项。字符串(String)。设置或检索滑条抽离效果的方式。HIDE | PUSH | SWAP
HIDE | : | 默认值。在新内容上抽离旧内容。
PUSH | : | 抽离旧内容时同步同向拉进新内容。
SWAP | : | 在抽离的同时交换新旧内容。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
Bands : 可读写。整数值(Integer)。参阅 bands 属性。
SlideStyle : 可读写。字符串(String)。参阅 slideStyle 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用滑条抽离效果转换对象内容。
示例：
#idDiv{ filter:progid:DXImageTransform.Microsoft.Slide(bands=8, duration=7);}


Spiral兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Spiral ( enabled=bEnabled , duration=fDuration , gridSizeX=iColumns , gridSizeY=iColumns )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
gridSizeX : 可选项。整数值(Integer)。设置或检索滤镜效果中横向盘旋多少次。取值范围为 1 - 100 。默认值为 16 。
gridSizeY : 可选项。整数值(Integer)。设置或检索滤镜效果中纵向盘旋多少次。取值范围为 1 - 100 。默认值为 16 。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
GridSizeX : 可读写。整数值(Integer)。参阅 gridSizeX 属性。
GridSizeY : 可读写。整数值(Integer)。参阅 gridSizeY 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用矩形螺旋方式转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.Spiral(duration=5, GridSizeX=25, GridSizeY=25); }


Stretch兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Stretch ( enabled=bEnabled , duration=fDuration , stretchStyle=sStretchStyle )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
stretchStyle : 可读写。字符串(String)。设置或检索拉伸变形转换的方式。SPIN | HIDE | PUSH
SPIN | : | 默认值。在旧内容上自中心向左右两边拉伸新内容。
HIDE | : | 在旧内容上自左向右拉伸(缩)新内容。
PUSH | : | 自左向右拉伸新内容近来同时挤压旧内容出去。这种转换方式的视觉效果类似立方体从一面转到另一面。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
StretchStyle : 可读写。字符串(String)。参阅 stretchStyle 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用拉伸(缩)变形效果转换对象内容。
示例：
#idDiv{height:250px; width:250px; background-color: orange; filter:progid:DXImageTransform.Microsoft.Stretch(duration=3);}


Strips兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Strips ( enabled=bEnabled , duration=fDuration , motion=sMotion )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
motion : 可读写。字符串(String)。设置或检索转换新内容从哪一个角开始。leftdown | leftup | rightdown | Prightup
leftdown | : | 默认值。从左下角到右上角。
leftup | : | 从左上角到右下角。
rightdown | : | 从右下角到左上角。
rightup | : | 从右上角到左下角。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
Motion : 可读写。字符串(String)。参阅 motion 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用锯齿边覆盖效果转换对象内容。
示例：
#idDiv{height:250px; width:250px; background-color: orange; filter:progid:DXImageTransform.Microsoft.Strips(duration=3);}


Wheel兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Wheel ( enabled=bEnabled , duration=fDuration , spokes=iSpokes )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
spokes : 可读写。整数值(Integer)。设置或检索风车叶轮数目。取值范围为 2 - 20 。默认值为 4 。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
spokes : 可读写。字符串(String)。参阅 spokes 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用风车叶轮旋转效果转换对象内容。
示例：
#idDiv{height:250px; width:250px; background-color: orange; filter:progid:DXImageTransform.Microsoft.Wheel(duration=3,spokes=8);}


Zigzag兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.Zigzag ( enabled=bEnabled , duration=fDuration , gridSizeX=iColumns , gridSizeY=iColumns )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
gridSizeX : 可选项。整数值(Integer)。设置或检索滤镜效果中横向盘旋多少次。取值范围为 1 - 100 。默认值为 16 。
gridSizeY : 可选项。整数值(Integer)。设置或检索滤镜效果中纵向盘旋多少次。取值范围为 1 - 100 。默认值为 16 。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
GridSizeX : 可读写。整数值(Integer)。参阅 gridSizeX 属性。
GridSizeY : 可读写。整数值(Integer)。参阅 gridSizeY 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用类似擦地板的效果转换对象内容。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.Zigzag(duration=5, GridSizeX=25, GridSizeY=25); }


RevealTrans兼容性：IE5.5+
语法：
filter : progid:DXImageTransform.Microsoft.RevealTrans ( enabled=bEnabled , duration=fDuration , transition=iTransitionType )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
transition : 可选项。整数值(Integer)。设置或检索转换所使用的方式。
0 | : | 矩形收缩转换。
1 | : | 矩形扩张转换。
2 | : | 圆形收缩转换。
3 | : | 圆形扩张转换。
4 | : | 向上擦除。
5 | : | 向下擦除。
6 | : | 向右擦除。
7 | : | 向左擦除。
8 | : | 纵向百叶窗转换。
9 | : | 横向百叶窗转换。
10 | : | 国际象棋棋盘横向转换。
11 | : | 国际象棋棋盘纵向转换。
12 | : | 随机杂点干扰转换。
13 | : | 左右关门效果转换。
14 | : | 左右开门效果转换。
15 | : | 上下关门效果转换。
16 | : | 上下开门效果转换。
17 | : | 从右上角到左下角的锯齿边覆盖效果转换。
18 | : | 从右下角到左上角的锯齿边覆盖效果转换。
19 | : | 从左上角到右下角的锯齿边覆盖效果转换。
20 | : | 从左下角到右上角的锯齿边覆盖效果转换。
21 | : | 随机横线条转换。
22 | : | 随机竖线条转换。
23 | : | 随机使用上面可能的值转换。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
Transition : 可读写。整数值(Integer)。参阅 transition 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
提供了24种转换对象内容的效果。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:progid:DXImageTransform.Microsoft.RevealTrans(duration=5, transition=2); }


BlendTrans兼容性：IE4.0+
语法：
filter : BlendTrans ( enabled=bEnabled , duration=fDuration )
属性：
enabled : 可选项。布尔值(Boolean)。设置或检索滤镜是否激活。true | false
true | : | 默认值。滤镜激活。
false | : | 滤镜被禁止。
duration : 可选项。浮点数(Real)。设置或检索转换完成所用的时间。其值为秒.毫秒(0.0000)格式。
你可以使用 play 方法的 iDuration 参数设置转换回放的持续时间。然而，当你一旦调用了 play 方法，在回放持续过程中 Duration 特性就变为只读特性。
特性：
Enabled : 可读写。布尔值(Boolean)。参阅 enabled 属性。
Duration : 可读写。浮点数(Real)。参阅 duration 属性。
Percent : 可读写。字符串(String)。设置或检索当前静态滤镜输出在转换进程中所处的点。取值范围为 0 - 100 。默认值为 0 ，转换尚未开始。 100 为转换完成。
此特性可用于使用转换滤镜建立静态滤镜效果。设置其值等于定义了转换进程停止的点。使用转换滤镜建立静态滤镜效果可遵循以下步骤：
  1. 使用转换滤镜的 apply 方法。这将捕获对象内容的初始显示，设置 Percent 特性值为 0 。
  2. 改变对象内容。如 visibility ， innerText ， background-color ， border ，或者其子对象的属性。
  3. 设置转换滤镜的 Percent 特性。即确定你希望的转换进程中某一点。这将捕获到转换进程中在该点处的一张内容图像。
  4. 设置转换滤镜的 Enabled 特性值为 true 。则滤镜作用的对象将依据获取到的图像更新其内容。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
status : 只读。整数值(Integer)。检索转换的当前状态。0 | 1 | 2
0 | : | 转换停止(stop)。
1 | : | 转换被应用(apply)。
2 | : | 转换在进行(play)。
方法：
apply : 捕获对象内容的初始显示，为转换做必要的准备。无返回值。
当此方法一旦被调用后，对象属性的任何改变都不会被显示，直到你调用 play 方法开始转换。
请注意：你只能使用 visibility 属性来改变对象的子对象。否则，对子对象的直接改变会被立即显示出来，而不会被转换滤镜捕获。
当你调用 play 方法时，转换呈现出内容的变化结果(对象的属性和子对象的 visibility 属性的改变)。
play ( iDuration ) : 开始转换。无返回值。参数见下表。
iDuration : 可选项。浮点数(Real)。 指定滤镜作用持续的时间。默认单位为秒。
使用 play 方法的 iDuration 参数设置转换回放的持续时间，其值在转换的当前一个周期内会替换 Duration 属性的设置。但是下一次转换会恢复使用 Duration 属性设置的值。
stop : 停止转换回放。并呈现转换结果图像。同时激发 onfilterchange 事件。无返回值。
说明：
用渐隐效果转换对象内容。
使用 BasicImage 滤镜可以更有效率的建立效果。
示例：
#idDiv{ height:250px; width:250px; background-color: gold; filter:BlendTrans(duration=5); }


Appendix　附 录

  1. Media Types 设备类型
  2. Color Table 颜色表
  3. Language Codes 语言代码
  4. Character Set Recognition 字符集识别
  5. ISO Latin-1 Character Set ISO Latin-1字符集
  6. Additional Named Entities for HTML HTML附加命名实体
  7. Character Entities for Special Symbols and BIDI Text 特殊文本和BIDI文本的字符实体


Character Entities for Special Symbols and BIDI Text
特殊文本和BIDI文本的字符实体

Using NE | NE | NCR | Using NCR
C0 Controls and Basic Latin
" | &quot | &#34; | quotation mark, =apl quote, U0022 ISOnum
& | &amp | &#38; | ampersand, U0026 ISOnum
< | &lt | &#60; | less-than sign, U003C ISOnum
> | &gt | &#62; | greater-than sign, U003E ISOnum
Latin Extended-A
Œ | &OElig | &#338; | latin capital ligature oe, U0152 ISOlat2
œ | &oelig | &#339; | latin small ligature oe, U0153 ISOlat2
Š | &Scaron | &#352; | latin capital letter s with caron, U0160 ISOlat2
š | &scaron | &#353; | latin small letter s with caron, U0161 ISOlat2
Ÿ | &Yuml | &#376; | latin capital letter y with diaeresis, U0178 ISOlat2
Spacing Modifier Letters
ˆ | &circ | &#710; | modifier letter circumflex accent, U02C6 ISOpub
˜ | &tilde | &#732; | small tilde, U02DC ISOdia
General Punctuation
 | &ensp | &#8194; | en space, U2002 ISOpub
 | &emsp | &#8195; | em space, U2003 ISOpub
 | &thinsp | &#8201; | thin space, U2009 ISOpub
‌ | &zwnj | &#8204; | zero width non-joiner, U200C NEW RFC 2070
‍ | &zwj | &#8205; | zero width joiner, U200D NEW RFC 2070
‎ | &lrm | &#8206; | left-to-right mark, U200E NEW RFC 2070
‏ | &rlm | &#8207; | right-to-left mark, U200F NEW RFC 2070
– | &ndash | &#8211; | en dash, U2013 ISOpub
— | &mdash | &#8212; | em dash, U2014 ISOpub
‘ | &lsquo | &#8216; | left single quotation mark, U2018 ISOnum
’ | &rsquo | &#8217; | right single quotation mark, U2019 ISOnum
‚ | &sbquo | &#8218; | single low-9 quotation mark, U201A NEW
“ | &ldquo | &#8220; | left double quotation mark, U201C ISOnum
” | &rdquo | &#8221; | right double quotation mark, U201D ISOnum
„ | &bdquo | &#8222; | double low-9 quotation mark, U201E NEW
† | &dagger | &#8224; | dagger, U2020 ISOpub
‡ | &Dagger | &#8225; | double dagger, U2021 ISOpub
‰ | &permil | &#8240; | per mille sign, U2030 ISOtech
‹ | &lsaquo | &#8249; | single left-pointing angle quotation mark, U2039 ISO proposed
› | &rsaquo | &#8250; | single right-pointing angle quotation mark, U203A ISO proposed


Language Codes 　语言代码

代码(Code) | 语言(Language) | 代码(Code) | 语言(Language) | 代码(Code) | 语言(Language)
af | Afrikaans | sq | Albanian | zu | Zulu
ar-sa | Arabic (Saudi Arabia) | ar-iq | Arabic (Iraq) | xh | Xhosa
ar-eg | Arabic (Egypt) | ar-ly | Arabic (Libya) | ji | Yiddish
ar-dz | Arabic (Algeria) | ar-ma | Arabic (Morocco) | ve | Venda
ar-tn | Arabic (Tunisia) | ar-om | Arabic (Oman) | vi | Vietnamese
ar-ye | Arabic (Yemen) | ar-sy | Arabic (Syria) | uk | Ukrainian
ar-jo | Arabic (Jordan) | ar-lb | Arabic (Lebanon) | ur | Urdu
ar-kw | Arabic (Kuwait) | ar-ae | Arabic (U.A.E.) | tn | Tswana
ar-bh | Arabic (Bahrain) | ar-qa | Arabic (Qatar) | tr | Turkish
eu | Basque | bg | Bulgarian | th | Thai
be | Belarusian | ca | Catalan | ts | Tsonga
zh-tw | Chinese (Taiwan) | zh-cn | Chinese (PRC) | sv | Swedish
zh-hk | Chinese (Hong Kong, S.A.R. China) | zh-sg | Chinese (Singapore) | sv-fi | Swedish (Finland)
hr | Croatian | cs | Czech | es-pr | Spanish (Puerto Rico)
da | Danish | nl | Dutch (Standard) | sx | Sutu
nl-be | Dutch (Belgium) | en | English | es-hn | Spanish (Honduras)
en-us | English (United States) | en-gb | English (Great Britain) | es-ni | Spanish (Nicaragua)
en-au | English (Australia) | en-ca | English (Canada) | es-bo | Spanish (Bolivia)
en-nz | English (New Zealand) | en-ie | English (Ireland) | es-sv | Spanish (El Salvador)
en | English (Caribbean) | en-bz | English (Belize) | en-za | English (South Africa)
en-tt | English (Trinidad) | et | Estonian | en-jm | English (Jamaica)
fi | Finnish | fr | French (Standard) | fo | Faeroese
fr-be | French (Belgium) | fr-ca | French (Canada) | fa | Farsi
gd | Gaelic (Scotland) | gd-ie | Gaelic (Ireland) | fr-ch | French (Switzerland)
de | German (Standard) | de-ch | German (Switzerland) | fr-lu | French (Luxembourg)
de-li | German (Liechtenstein) | el | Greek | de-at | German (Austria)
he | Hebrew | hi | Hindi | de-lu | German (Luxembourg)
in | Indonesian | it | Italian (Standard) | hu | Hungarian
it-ch | Italian (Switzerland) | ja | Japanese | is | Icelandic
lv | Latvian | lt | Lithuanian | ko | Korean
mk | FYRO Macedonian | ms | Malaysian | ko | Korean (Johab)
no | Norwegian (Nynorsk) | pl | Polish | mt | Maltese
pt-br | Portuguese (Brazil) | pt | Portuguese (Standard) | no | Norwegian (Bokmal)
ro-mo | Romanian (Moldavia) | ru | Russian | rm | Rhaeto-Romanic
ru-mo | Russian (Moldavia) | sz | Sami (Lappish) | ro | Romanian
sk | Slovak | sl | Slovenian | sr | Serbian (Cyrillic)
sb | Sorbian | es | Spanish (Spain – Traditional) | sr | Serbian (Latin)
es-gt | Spanish (Guatemala) | es-cr | Spanish (Costa Rica) | es-mx | Spanish (Mexico)
es-pa | Spanish (Panama) | es-do | Spanish (Dominican Republic) | es | Spanish (Spain – Modern)
es-pe | Spanish (Peru) | es-ar | Spanish (Argentina) | es-ve | Spanish (Venezuela)
es-ec | Spanish (Ecuador) | es-cl | Spanish (Chile) | es-co | Spanish (Colombia)
es-uy | Spanish (Uruguay) | es-py | Spanish (Paraguay) |  |


Character Set Recognition　字符集识别

CharsetFriendlyName 显示名称 | Preferred Charset Label 首选字符集标示 | Aliases 附加别名 | IE Ver 浏览器版本 | Min OS 操作系统 | CodePage 代码页 | FamilyCodePage 内部代码页
Arabic (ASMO 708) | ASMO-708 |  | IE5 | Win95 | 708 | 1256
Arabic (DOS) | DOS-720 |  | IE5 | Win95 | 720 | 1256
Arabic (ISO) | iso-8859-6 | arabiccsISOLatinArabicECMA-114ISO_8859-6ISO_8859-6:1987iso-ir-127 | IE5,IE4 | Win95 | 28596 | 1256
Arabic (Mac) | x-mac-arabic |  | IE5 | Win2000 | 10004 | 1256
Arabic (Windows) | windows-1256 | cp1256 | IE5 | Win95 | 1256 | 1256
Baltic (DOS) | ibm775 | CP500 | IE5 | Win2000 | 775 | 1257
Baltic (ISO) | iso-8859-4 | csISOLatin4ISO_8859-4ISO_8859-4:1988iso-ir-110l4latin4 | IE5 | Win95 | 28594 | 1257
Baltic (Windows) | windows-1257 |  | IE5 | Win95 | 1257 | 1257
Central European (DOS) | ibm852 | cp852 | IE5,IE4 | Win95 | 852 | 1250
Central European (ISO) | iso-8859-2 | csISOLatin2iso_8859-2iso_8859-2:1987iso8859-2iso-ir-101l2latin2 | IE5,IE4 | Win95 | 28592 | 1250
Central European (Mac) | x-mac-ce |  | IE5 | Win2000 | 10029 | 1250
Central European (Windows) | windows-1250 | x-cp1250 | IE5 | Win95 | 1250 | 1250
Chinese Simplified (EUC) | EUC-CN | x-euc-cn | IE5 | Win2000 | 51936 | 936
Chinese Simplified (GB2312) | gb2312 | chineseCN-GBcsGB2312csGB231280csISO58GB231280GB_2312-80GB231280GB2312-80GBKiso-ir-58 | IE5,IE4 | Win95 | 936 | 936
Chinese Simplified (HZ) | hz-gb-2312 |  | IE5,IE4 | Win95 | 52936 | 936
Chinese Simplified (Mac) | x-mac-chinesesimp |  | IE5 | Win2000 | 10008 | 936
Chinese Traditional (Big5) | big5 | cn-big5csbig5x-x-big5 | IE5,IE4 | Win95 | 950 | 950
Chinese Traditional (CNS) | x-Chinese-CNS |  | IE5 | Win2000 | 20000 | 950
Chinese Traditional (Eten) | x-Chinese-Eten |  | IE5 | Win2000 | 20002 | 950
Chinese Traditional (Mac) | x-mac-chinesetrad |  | IE5 | Win2000 | 10002 | 950
Cyrillic (DOS) | cp866 | ibm866 | IE5,IE4 | Win95 | 866 | 1251
Cyrillic (ISO) | iso-8859-5 | csISOLatin5csISOLatinCyrilliccyrillicISO_8859-5ISO_8859-5:1988iso-ir-144l5 | IE5,IE4 | Win95 | 28595 | 1251
Cyrillic (KOI8-R) | koi8-r | csKOI8Rkoikoi8koi8r | IE5,IE4 | Win95 | 20866 | 1251
Cyrillic (KOI8-U) | koi8-u | koi8-ru | IE5 | Win95 | 21866 | 1251
Cyrillic (Mac) | x-mac-cyrillic |  | IE5 | Win2000 | 10007 | 1251
Cyrillic (Windows) | windows-1251 | x-cp1251 | IE5 | Win95 | 1251 | 1251
Europa | x-Europa |  | IE5 | n.a. | 29001 | 1252
German (IA5) | x-IA5-German |  | IE5 | Win2000 | 20106 | 1252
Greek (DOS) | ibm737 |  | IE5 | Win2000 | 737 | 1253
Greek (ISO) | iso-8859-7 | csISOLatinGreekECMA-118ELOT_928greekgreek8ISO_8859-7ISO_8859-7:1987iso-ir-126 | IE5,IE4 | Win95 | 28597 | 1253
Greek (Mac) | x-mac-greek |  | IE5 | Win2000 | 10006 | 1253
Greek (Windows) | windows-1253 |  | IE5 | Win95 | 1253 | 1253
Greek, Modern (DOS) | ibm869 |  | IE5 | Win2000 | 869 | 1253
Hebrew (DOS) | DOS-862 |  | IE5 | Win95 | 862 | 1255
Hebrew (ISO-Logical) | iso-8859-8-i | logical | IE5,IE4 | Win95 | 38598 | 1255
Hebrew (ISO-Visual) | iso-8859-8 | csISOLatinHebrewhebrewISO_8859-8ISO_8859-8:1988ISO-8859-8iso-ir-138visual | IE5,IE4 | Win95 | 28598 | 1255
Hebrew (Mac) | x-mac-hebrew |  | IE5 | Win2000 | 10005 | 1255
Hebrew (Windows) | windows-1255 | ISO_8859-8-IISO-8859-8visual | IE5 | Win95 | 1255 | 1255
IBM EBCDIC (Arabic) | x-EBCDIC-Arabic |  | IE5 | Win2000 | 20420 | 1256
IBM EBCDIC (Cyrillic Russian) | x-EBCDIC-CyrillicRussian |  | IE5 | Win2000 | 20880 | 1251
IBM EBCDIC (Cyrillic Serbian-Bulgarian) | x-EBCDIC-CyrillicSerbianBulgarian |  | IE5 | Win2000 | 21025 | 1251
IBM EBCDIC (Denmark-Norway) | x-EBCDIC-DenmarkNorway |  | IE5 | Win2000 | 20277 | 1252
IBM EBCDIC (Denmark-Norway-Euro) | x-ebcdic-denmarknorway-euro |  | IE5 | Win2000 | 1142 | 1252
IBM EBCDIC (Finland-Sweden) | x-EBCDIC-FinlandSweden |  | IE5 | Win2000 | 20278 | 1252
IBM EBCDIC (Finland-Sweden-Euro) | x-ebcdic-finlandsweden-euro |  | IE5 | Win2000 | 1143 | 1252
IBM EBCDIC (Finland-Sweden-Euro) | x-ebcdic-finlandsweden-euro | X-EBCDIC-France | IE5 | Win2000 | 1143 | 1252
IBM EBCDIC (France-Euro) | x-ebcdic-france-euro |  | IE5 | Win2000 | 1147 | 1252
IBM EBCDIC (Germany) | x-EBCDIC-Germany |  | IE5 | Win2000 | 20273 | 1252
IBM EBCDIC (Germany-Euro) | x-ebcdic-germany-euro |  | IE5 | Win2000 | 1141 | 1252
IBM EBCDIC (Greek Modern) | x-EBCDIC-GreekModern |  | IE5 | Win2000 | 875 | 1253
IBM EBCDIC (Greek) | x-EBCDIC-Greek |  | IE5 | Win2000 | 20423 | 1253
IBM EBCDIC (Hebrew) | x-EBCDIC-Hebrew |  | IE5 | Win2000 | 20424 | 1255
IBM EBCDIC (Icelandic) | x-EBCDIC-Icelandic |  | IE5 | Win2000 | 20871 | 1252
IBM EBCDIC (Icelandic-Euro) | x-ebcdic-icelandic-euro |  | IE5 | Win2000 | 1149 | 1252
IBM EBCDIC (International-Euro) | x-ebcdic-international-euro |  | IE5 | Win2000 | 1148 | 1252
IBM EBCDIC (Italy) | x-EBCDIC-Italy |  | IE5 | Win2000 | 20280 | 1252
IBM EBCDIC (Italy-Euro) | x-ebcdic-italy-euro |  | IE5 | Win2000 | 1144 | 1252
IBM EBCDIC (Japanese and Japanese Katakana) | x-EBCDIC-JapaneseAndKana |  | IE5 | Win2000 | 50930 | 932
IBM EBCDIC (Japanese and Japanese-Latin) | x-EBCDIC-JapaneseAndJapaneseLatin |  | IE5 | Win2000 | 50939 | 932
IBM EBCDIC (Japanese and US-Canada) | x-EBCDIC-JapaneseAndUSCanada |  | IE5 | Win2000 | 50931 | 932
IBM EBCDIC (Japanese katakana) | x-EBCDIC-JapaneseKatakana |  | IE5 | Win2000 | 20290 | 932
IBM EBCDIC (Korean and Korean Extended) | x-EBCDIC-KoreanAndKoreanExtended |  | IE5 | Win2000 | 50933 | 949
IBM EBCDIC (Korean Extended) | x-EBCDIC-KoreanExtended |  | IE5 | Win2000 | 20833 | 949
IBM EBCDIC (Multilingual Latin-2) | CP870 |  | IE5 | Win2000 | 870 | 1250
IBM EBCDIC (Simplified Chinese) | x-EBCDIC-SimplifiedChinese |  | IE5 | Win2000 | 50935 | 936
IBM EBCDIC (Spain) | X-EBCDIC-Spain |  | IE5 | Win2000 | 20284 | 1252
IBM EBCDIC (Spain-Euro) | x-ebcdic-spain-euro |  | IE5 | Win2000 | 1145 | 1252
IBM EBCDIC (tdai) | x-EBCDIC-tdai |  | IE5 | Win2000 | 20838 | 874
IBM EBCDIC (Traditional Chinese) | x-EBCDIC-TraditionalChinese |  | IE5 | Win2000 | 50937 | 950
IBM EBCDIC (Turkish Latin-5) | CP1026 |  | IE5 | Win2000 | 1026 | 1254
IBM EBCDIC (Turkish) | x-EBCDIC-Turkish |  | IE5 | Win2000 | 20905 | 1254
IBM EBCDIC (UK) | x-EBCDIC-UK |  | IE5 | Win2000 | 20285 | 1252
IBM EBCDIC (UK-Euro) | x-ebcdic-uk-euro |  | IE5 | Win2000 | 1146 | 1252
IBM EBCDIC (US-Canada) | ebcdic-cp-us |  | IE5 | Win2000 | 37 | 1252
IBM EBCDIC (US-Canada-Euro) | x-ebcdic-cp-us-euro |  | IE5 | Win2000 | 1140 | 1252
Icelandic (DOS) | ibm861 |  | IE5 | Win2000 | 861 | 1252
Icelandic (Mac) | x-mac-icelandic |  | IE5 | Win2000 | 10079 | 1252
ISCII Assamese | x-iscii-as |  | IE5 | Win2000 | 57006 | 57006
ISCII Bengali | x-iscii-be |  | IE5 | Win2000 | 57003 | 57003
ISCII Devanagari | x-iscii-de |  | IE5 | Win2000 | 57002 | 57002
ISCII Gujaratdi | x-iscii-gu |  | IE5 | Win2000 | 57010 | 57010
ISCII Kannada | x-iscii-ka |  | IE5 | Win2000 | 57008 | 57008
ISCII Malayalam | x-iscii-ma |  | IE5 | Win2000 | 57009 | 57009
ISCII Oriya | x-iscii-or |  | IE5 | Win2000 | 57007 | 57007
ISCII Panjabi | x-iscii-pa |  | IE5 | Win2000 | 57011 | 57011
ISCII Tamil | x-iscii-ta |  | IE5 | Win2000 | 57004 | 57004
ISCII Telugu | x-iscii-te |  | IE5 | Win2000 | 57005 | 57005
Japanese (EUC) | euc-jp | csEUCPkdFmtJapaneseExtended_UNIX_Code_Packed_牋牋Format_for_Japanesex-eucx-euc-jp | IE5,IE4 | Win95 | 51932 | 932
Japanese (JIS) | iso-2022-jp |  | IE5,IE4 | Win95 | 50220 | 932
Japanese (JIS-Allow 1 byte Kana - SO/SI) | iso-2022-jp | _iso-2022-jp$SIO | IE5 | Win95 | 50222 | 932
Japanese (JIS-Allow 1 byte Kana) | csISO2022JP | _iso-2022-jp$ESC | IE5 | Win95 | 50221 | 932
Japanese (Mac) | x-mac-japanese |  | IE5 | Win2000 | 10001 | 932
Japanese (Shift-JIS) | shift_jis | csShiftJIScsWindows31Jms_Kanjishift-jisx-ms-cp932x-sjis | IE5,IE4 | Win95 | 932 | 932
Korean | ks_c_5601-1987 | csKSC56011987euc-kriso-ir-149koreanks_c_5601ks_c_5601_1987ks_c_5601-1989KSC_5601KSC5601 | IE5 | Win95 | 949 | 949
Korean (EUC) | euc-kr | csEUCKR | IE5 | Win95 | 51949 | 949
Korean (ISO) | iso-2022-kr | csISO2022KR | IE5 | Win95 | 50225 | 949
Korean (Johab) | Johab |  | IE5 | Win2000 | 1361 | 1361
Korean (Mac) | x-mac-korean |  | IE5 | Win2000 | 10003 | 949
Latin 3 (ISO) | iso-8859-3 | csISOLatin3ISO_8859-3ISO_8859-3:1988iso-ir-109l3latin3 | IE5,IE4 | Win95 | 28593 | 1254
Latin 9 (ISO) | iso-8859-15 | csISOLatin9ISO_8859-15l9latin9 | IE5 | Win95 | 28605 | 1252
Norwegian (IA5) | x-IA5-Norwegian |  | IE5 | Win2000 | 20108 | 1252
OEM United States | IBM437 | 437cp437csPC8CodePage437 | IE5 | Win2000 | 437 | 1252
Swedish (IA5) | x-IA5-Swedish |  | IE5 | Win2000 | 20107 | 1252
tdai (Windows) | windows-874 | DOS-874iso-8859-11TIS-620 | IE5,IE4 | Win95 | 874 | 874
Turkish (DOS) | ibm857 |  | IE5 | Win2000 | 857 | 1254
Turkish (ISO) | iso-8859-9 | csISOLatin5ISO_8859-9ISO_8859-9:1989iso-ir-148l5latin5 | IE5 | Win95 | 28599 | 1254
Turkish (Mac) | x-mac-turkish |  | IE5 | Win2000 | 10081 | 1254
Turkish (Windows) | windows-1254 | ISO_8859-9ISO_8859-9:1989iso-8859-9iso-ir-148latin5 | IE5 | Win95 | 1254 | 1254
Unicode | unicode | utf-16 | IE5,IE4 | Win95 | 1200 | 1200
Unicode (Big-Endian) | unicodeFFFE |  | IE5,IE4 | Win95 | 1201 | 1200
Unicode (UTF-7) | utf-7 | csUnicode11UTF7unicode-1-1-utf-7x-unicode-2-0-utf-7 | IE5,IE4 | Win95 | 65000 | 1200
Unicode (UTF-8) | utf-8 | unicode-1-1-utf-8unicode-2-0-utf-8x-unicode-2-0-utf-8 | IE5,IE4 | Win95 | 65001 | 1200
US-ASCII | us-ascii | ANSI_X3.4-1968ANSI_X3.4-1986asciicp367csASCIIIBM367ISO_646.irv:1991ISO646-USiso-ir-6us | IE5 | Win95 | 20127 | 1252
Vietnamese (Windows) | windows-1258 |  | IE5,IE4 | Win95 | 1258 | 1258
Western European (DOS) | ibm850 |  | IE5 | Win2000 | 850 | 1252
Western European (IA5) | x-IA5 |  | IE5 | Win2000 | 20105 | 1252
Western European (ISO) | iso-8859-1 | cp819csISOLatin1ibm819iso_8859-1iso_8859-1:1987iso8859-1iso-ir-100l1latin1 | IE5 | Win95 | 28591 | 1252
Western European (Mac) | macintosh |  | IE5 | Win2000 | 10000 | 1252
Western European (Windows) | Windows-1252 | ANSI_X3.4-1968ANSI_X3.4-1986asciicp367cp819csASCIIIBM367ibm819ISO_646.irv:1991iso_8859-1iso_8859-1:1987ISO646-USiso8859-1iso-8859-1iso-ir-100iso-ir-6latin1usus-asciix-ansi | IE5 | Win95 | 1252 | 1252


Additional Named Entities for HTML　HTML附加命名实体

Character 字符 | Named entity 已命名实体 | Numeric character reference 十进制编码 | Description 简介
扩展拉丁字符 Latin Extended-B
ƒ | &fnof; | &#402; | Latin small f with hook, =function, =florin, U0192 ISOtech
希腊字符 Greek
Α | &Alpha; | &#913; | Greek capital letter alpha, U0391
Β | &Beta; | &#914; | Greek capital letter beta, U0392
Γ | &Gamma; | &#915; | Greek capital letter gamma, U0393 ISOgrk3
Δ | &Delta; | &#916; | Greek capital letter delta, U0394 ISOgrk3
Ε | &Epsilon; | &#917; | Greek capital letter epsilon, U0395
Ζ | &Zeta; | &#918; | Greek capital letter zeta, U0396
Η | &Eta; | &#919; | Greek capital letter eta, U0397
Θ | &Theta; | &#920; | Greek capital letter theta, U0398 ISOgrk3
Ι | &Iota; | &#921; | Greek capital letter iota, U0399
Κ | &Kappa; | &#922; | Greek capital letter kappa, U039A
Λ | &Lambda; | &#923; | Greek capital letter lambda, U039B ISOgrk3
Μ | &Mu; | &#924; | Greek capital letter mu, U039C
Ν | &Nu; | &#925; | Greek capital letter nu, U039D
Ξ | &Xi; | &#926; | Greek capital letter xi, U039E ISOgrk3
Ο | &Omicron; | &#927; | Greek capital letter omicron, U039F
Π | &Pi; | &#928; | Greek capital letter pi, U03A0 ISOgrk3
Ρ | &Rho; | &#929; | Greek capital letter rho, U03A1
Σ | &Sigma; | &#931; | Greek capital letter sigma, U03A3 ISOgrk3
Τ | &Tau; | &#932; | Greek capital letter tau, U03A4
Υ | &Upsilon; | &#933; | Greek capital letter upsilon, U03A5 ISOgrk3
Φ | &Phi; | &#934; | Greek capital letter phi, U03A6 ISOgrk3
Χ | &Chi; | &#935; | Greek capital letter chi, U03A7
Ψ | &Psi; | &#936; | Greek capital letter psi, U03A8 ISOgrk3
Ω | &Omega; | &#937; | Greek capital letter omega, U03A9 ISOgrk3
α | &alpha; | &#945; | Greek small letter alpha, U03B1 ISOgrk3
β | &beta; | &#946; | Greek small letter beta, U03B2 ISOgrk3
γ | &gamma; | &#947; | Greek small letter gamma, U03B3 ISOgrk3
δ | &delta; | &#948; | Greek small letter delta, U03B4 ISOgrk3
ε | &epsilon; | &#949; | Greek small letter epsilon, U03B5 ISOgrk3
ζ | &zeta; | &#950; | Greek small letter zeta, U03B6 ISOgrk3
η | &eta; | &#951; | Greek small letter eta, U03B7 ISOgrk3
θ | &theta; | &#952; | Greek small letter theta, U03B8 ISOgrk3
ι | &iota; | &#953; | Greek small letter iota, U03B9 ISOgrk3
κ | &kappa; | &#954; | Greek small letter kappa, U03BA ISOgrk3
λ | &lambda; | &#955; | Greek small letter lambda, U03BB ISOgrk3
μ | &mu; | &#956; | Greek small letter mu, U03BC ISOgrk3
ν | &nu; | &#957; | Greek small letter nu, U03BD ISOgrk3
ξ | &xi; | &#958; | Greek small letter xi, U03BE ISOgrk3
ο | &omicron; | &#959; | Greek small letter omicron, U03BF NEW
π | &pi; | &#960; | Greek small letter pi, U03C0 ISOgrk3
ρ | &rho; | &#961; | Greek small letter rho, U03C1 ISOgrk3
ς | &sigmaf; | &#962; | Greek small letter final sigma, U03C2 ISOgrk3
σ | &sigma; | &#963; | Greek small letter sigma, U03C3 ISOgrk3
τ | &tau; | &#964; | Greek small letter tau, U03C4 ISOgrk3
υ | &upsilon; | &#965; | Greek small letter upsilon, U03C5 ISOgrk3
φ | &phi; | &#966; | Greek small letter phi, U03C6 ISOgrk3
χ | &chi; | &#967; | Greek small letter chi, U03C7 ISOgrk3
ψ | &psi; | &#968; | Greek small letter psi, U03C8 ISOgrk3
ω | &omega; | &#969; | Greek small letter omega, U03C9 ISOgrk3
ϑ | &thetasym; | &#977; | Greek small letter theta symbol, U03D1 NEW
ϒ | &upsih; | &#978; | Greek upsilon with hook symbol, U03D2 NEW
ϖ | &piv; | &#982; | Greek pi symbol, U03D6 ISOgrk3
通用标点符号 General Punctuation
• | &bull; | &#8226; | bullet, =black small circle, U2022 ISOpub
… | &hellip; | &#8230; | horizontal ellipsis, =three dot leader, U2026 ISOpub
′ | &prime; | &#8242; | prime, =minutes, =feet, U2032 ISOtech
″ | &Prime; | &#8243; | double prime, =seconds, =inches, U2033 ISOtech
‾ | &oline; | &#8254; | overline, =spacing overscore, U203E NEW
⁄ | &frasl; | &#8260; | fraction slash, U2044 NEW
字符标记 Letterlike Symbols
℘ | &weierp; | &#8472; | script capital P, =power set, =Weierstrass p, U2118 ISOamso
ℑ | &image; | &#8465; | blackletter capital I, =imaginary part, U2111 ISOamso
ℜ | &real; | &#8476; | blackletter capital R, =real part symbol, U211C ISOamso
™ | &trade; | &#8482; | trade mark sign, U2122 ISOnum
ℵ | &alefsym; | &#8501; | alef symbol, =first transfinite cardinal, U2135 NEW
箭头 Arrows
← | &larr; | &#8592; | leftward arrow, U2190 ISOnum
↑ | &uarr; | &#8593; | upward arrow, U2191 ISOnum
→ | &rarr; | &#8594; | rightward arrow, U2192 ISOnum
↓ | &darr; | &#8595; | downward arrow, U2193 ISOnum
↔ | &harr; | &#8596; | left right arrow, U2194 ISOamsa
↵ | &crarr; | &#8629; | downward arrow with corner leftward, =carriage return, U21B5 NEW
⇐ | &lArr; | &#8656; | leftward double arrow, U21D0 ISOtech
⇑ | &uArr; | &#8657; | upward double arrow, U21D1 ISOamsa
⇒ | &rArr; | &#8658; | rightward double arrow, U21D2 ISOtech
⇓ | &dArr; | &#8659; | downward double arrow, U21D3 ISOamsa
⇔ | &hArr; | &#8660; | left right double arrow, U21D4 ISOamsa
数学符号 Mathematical Operators
∀ | &forall; | &#8704; | for all, U2200 ISOtech
∂ | &part; | &#8706; | partial differential, U2202 ISOtech
∃ | &exist; | &#8707; | there exists, U2203 ISOtech
∅ | &empty; | &#8709; | empty set, =null set, =diameter, U2205 ISOamso
∇ | &nabla; | &#8711; | nabla, =backward difference, U2207 ISOtech
∈ | &isin; | &#8712; | element of, U2208 ISOtech
∉ | &notin; | &#8713; | not an element of, U2209 ISOtech
∋ | &ni; | &#8715; | contains as member, U220B ISOtech
∏ | &prod; | &#8719; | n-ary product, =product sign, U220F ISOamsb
− | &sum; | &#8722; | n-ary sumation, U2211 ISOamsb
− | &minus; | &#8722; | minus sign, U2212 ISOtech
∗ | &lowast; | &#8727; | asterisk operator, U2217 ISOtech
√ | &radic; | &#8730; | square root, =radical sign, U221A ISOtech
∝ | &prop; | &#8733; | proportional to, U221D ISOtech
∞ | &infin; | &#8734; | infinity, U221E ISOtech
∠ | &ang; | &#8736; | angle, U2220 ISOamso
⊥ | &and; | &#8869; | logical and, =wedge, U2227 ISOtech
⊦ | &or; | &#8870; | logical or, =vee, U2228 ISOtech
∩ | &cap; | &#8745; | intersection, =cap, U2229 ISOtech
∪ | &cup; | &#8746; | union, =cup, U222A ISOtech
∫ | &int; | &#8747; | integral, U222B ISOtech
∴ | &there4; | &#8756; | therefore, U2234 ISOtech
∼ | &sim; | &#8764; | tilde operator, =varies with, =similar to, U223C ISOtech
≅ | &cong; | &#8773; | approximately equal to, U2245 ISOtech
≅ | &asymp; | &#8773; | almost equal to, =asymptotic to, U2248 ISOamsr
≠ | &ne; | &#8800; | not equal to, U2260 ISOtech
≡ | &equiv; | &#8801; | identical to, U2261 ISOtech
≤ | &le; | &#8804; | less-than or equal to, U2264 ISOtech
≥ | &ge; | &#8805; | greater-than or equal to, U2265 ISOtech
⊂ | &sub; | &#8834; | subset of, U2282 ISOtech
⊃ | &sup; | &#8835; | superset of, U2283 ISOtech
⊄ | &nsub; | &#8836; | not a subset of, U2284 ISOamsn
⊆ | &sube; | &#8838; | subset of or equal to, U2286 ISOtech
⊇ | &supe; | &#8839; | superset of or equal to, U2287 ISOtech
⊕ | &oplus; | &#8853; | circled plus, =direct sum, U2295 ISOamsb
⊗ | &otimes; | &#8855; | circled times, =vector product, U2297 ISOamsb
⊥ | &perp; | &#8869; | up tack, =orthogonal to, =perpendicular, U22A5 ISOtech
⋅ | &sdot; | &#8901; | dot operator, U22C5 ISOamsb
其他技术符号 Miscellaneous Technical
⌈ | &lceil; | &#8968; | left ceiling, =apl upstile, U2308, ISOamsc
⌉ | &rceil; | &#8969; | right ceiling, U2309, ISOamsc
⌊ | &lfloor; | &#8970; | left floor, =apl downstile, U230A, ISOamsc
⌋ | &rfloor; | &#8971; | right floor, U230B, ISOamsc
〈 | &lang; | &#9001; | left-pointing angle bracket, =bra, U2329 ISOtech
〉 | &rang; | &#9002; | right-pointing angle bracket, =ket, U232A ISOtech
几何图形 Geometric Shapes
◊ | &loz; | &#9674; | lozenge, U25CA ISOpub
其他标记 Miscellaneous Symbols
♠ | &spades; | &#9824; | black spade suit, U2660 ISOpub
♣ | &clubs; | &#9827; | black club suit, =shamrock, U2663 ISOpub
♥ | &hearts; | &#9829; | black heart suit, =valentine, U2665 ISOpub
♦ | &diams; | &#9830; | black diamond suit, U2666 ISOpub

以上命名实体使用 Lucida sans Unicode 给出。


ISO Latin-1 Character Set　ISO Latin-1字符集

Character 字符 | Decimal code 十进制编码 | Named entity 已命名实体 | Character 字符 | Decimal code 十进制编码 | Named entity 已命名实体
--- | &#00; | --- | --- | &#01; | ---
--- | &#02; | --- | --- | &#03; | ---
--- | &#04; | --- | --- | &#05; | ---
--- | &#06; | --- | --- | &#07; | ---
--- | &#08; | --- | --- | &#09; | ---
--- | &#10; | --- | --- | &#11; | ---
--- | &#12; | --- | --- | &#13; | ---
--- | &#14; | --- | --- | &#15; | ---
--- | &#16; | --- | --- | &#17; | ---
--- | &#18; | --- | --- | &#19; | ---
--- | &#20; | --- | --- | &#21; | ---
--- | &#22; | --- | --- | &#23; | ---
--- | &#24; | --- | --- | &#25; | ---
--- | &#26; | --- | --- | &#27; | ---
--- | &#28; | --- | --- | &#29; | ---
--- | &#30; | --- | --- | &#31; | ---
 | &#32; | --- | ! | &#33; | ---
" | &#34; | &quot; | # | &#35; | ---
$ | &#36; | --- | % | &#37; | ---
& | &#38; | &amp; | ' | &#39; | ---
( | &#40; | --- | ) | &#41; | ---
* | &#42; | --- | + | &#43; | ---
, | &#44; | --- | - | &#45; | ---
. | &#46; | --- | / | &#47; | ---
0 | &#48; | --- | 1 | &#49; | ---
2 | &#50; | --- | 3 | &#51; | ---
4 | &#52; | --- | 5 | &#53; | ---
6 | &#54; | --- | 7 | &#55; | ---
8 | &#56; | --- | 9 | &#57; | ---
: | &#58; | --- | ; | &#59; | ---
< | &#60; | &lt; | = | &#61; | ---
> | &#62; | &gt; | ? | &#63; | ---
@ | &#64; | --- | A | &#65; | ---
B | &#66; | --- | C | &#67; | ---
D | &#68; | --- | E | &#69; | ---
F | &#70; | --- | G | &#71; | ---
H | &#72; | --- | I | &#73; | ---
J | &#74; | --- | K | &#75; | ---
L | &#76; | --- | M | &#77; | ---
N | &#78; | --- | O | &#79; | ---
P | &#80; | --- | Q | &#81; | ---
R | &#82; | --- | S | &#83; | ---
T | &#84; | --- | U | &#85; | ---
V | &#86; | --- | W | &#87; | ---
X | &#88; | --- | Y | &#89; | ---
Z | &#90; | --- | [ | &#91; | ---
\ | &#92; | --- | ] | &#93; | ---
^ | &#94; | --- | _ | &#95; | ---
` | &#96; | --- | a | &#97; | ---
b | &#98; | --- | c | &#99; | ---
d | &#100; | --- | e | &#101; | ---
f | &#102; | --- | g | &#103; | ---
h | &#104; | --- | i | &#105; | ---
j | &#106; | --- | k | &#107; | ---
l | &#108; | --- | m | &#109; | ---
n | &#110; | --- | o | &#111; | ---
p | &#112; | --- | q | &#113; | ---
r | &#114; | --- | s | &#115; | ---
t | &#116; | --- | u | &#117; | ---
v | &#118; | --- | w | &#119; | ---
x | &#120; | --- | y | &#121; | ---
z | &#122; | --- | { | &#123; | ---
| | &#124; | --- | } | &#125; | ---
~ | &#126; | --- | --- | &#127; | ---
 | &#160; | &nbsp; | ¡ | &#161; | &iexcl;
¢ | &#162; | &cent; | £ | &#163; | &pound;
¤ | &#164; | &curren; | ¥ | &#165; | &yen;
¦ | &#166; | &brvbar; or &brkbar; | § | &#167; | &sect;
¨ | &#168; | &uml; or &die; | © | &#169; | &copy;
ª | &#170; | &ordf; | « | &#171; | &laquo;
¬ | &#172; | &not |  | &#173; | &shy;
® | &#174; | &reg; | ¯ | &#175; | &macr; or &hibar;
° | &#176; | &deg; | ± | &#177; | &plusmn;
² | &#178; | &sup2; | ³ | &#179; | &sup3;
´ | &#180; | &acute; | µ | &#181; | &micro;
¶ | &#182; | &para; | · | &#183; | &middot;
¸ | &#184; | &cedil; | ¹ | &#185; | &sup1;
º | &#186; | &ordm; | » | &#187; | &raquo;
¼ | &#188; | &frac14; | ½ | &#189; | &frac12;
¾ | &#190; | &frac34; | ¿ | &#191; | &iquest;
À | &#192; | &Agrave; | Á | &#193; | &Aacute;
Â | &#194; | &Acirc; | Ã | &#195; | &Atilde;
Ä | &#196; | &Auml; | Å | &#197; | &Aring;
Æ | &#198; | &AElig; | Ç | &#199; | &Ccedil;
È | &#200; | &Egrave; | É | &#201; | &Eacute;
Ê | &#202; | &Ecirc; | Ë | &#203; | &Euml;
Ì | &#204; | &Igrave; | Í | &#205; | &Iacute;
Î | &#206; | &Icirc; | Ï | &#207; | &Iuml;
Ð | &#208; | &ETH; | Ñ | &#209; | &Ntilde;
Ò | &#210; | &Ograve; | Ó | &#211; | &Oacute;
Ô | &#212; | &Ocirc; | Õ | &#213; | &Otilde;
Ö | &#214; | &Ouml; | × | &#215; | &times;
Ø | &#216; | &Oslash; | Ù | &#217; | &Ugrave;
Ú | &#218; | &Uacute; | Û | &#219; | &Ucirc;
Ü | &#220; | &Uuml; | Ý | &#221; | &Yacute;
Þ | &#222; | &THORN; | ß | &#223; | &szlig;
à | &#224; | &agrave; | á | &#225; | &aacute;
â | &#226; | &acirc; | ã | &#227; | &atilde;
ä | &#228; | &auml; | å | &#229; | &aring;
æ | &#230; | &aelig; | ç | &#231; | &ccedil;
è | &#232; | &egrave; | é | &#233; | &eacute;
ê | &#234; | &ecirc; | ë | &#235; | &euml;
ì | &#236; | &igrave; | í | &#237; | &iacute;
î | &#238; | &icirc; | ï | &#239; | &iuml;
&etd; | &#240; | &etd; | ñ | &#241; | &ntilde;
ò | &#242; | &ograve; | ó | &#243; | &oacute;
ô | &#244; | &ocirc; | õ | &#245; | &otilde;
ö | &#246; | &ouml; | ÷ | &#247; | &divide;
ø | &#248; | &oslash; | ù | &#249; | &ugrave;
ú | &#250; | &uacute; | û | &#251; | &ucirc;
ü | &#252; | &uuml; | ý | &#253; | &yacute;
&tdorn; | &#254; | &tdorn; | ÿ | &#255; | &yuml;

上表包含全部的ISO Latin-1字符集，对应于IE4+中Unicode字符指令表的前256个条目。该表提供了每个字符及字符的十进制编码，HTML已命名实体。


Adjacent Sibling Selectors　版本：CSS2　 兼容性：无
语法：
E1 + E2 { sRules }
说明：
相邻选择符。选择紧贴在 E1 之后的所有 E2 。 E1 和 E2 在文档目录结构树(DOM)中有共同的父对象。
示例：
div + p { font-size:14px; }
/* 所有紧贴在div对象之后的p对象的字体尺寸为14px */

div.fly + p { font-size:14px; }


中英文词汇对照表

英文(English) | 中文(Chinese) | 英文(English) | 中文(Chinese) | 英文(English) | 中文(Chinese)
Element | 要素 ，元素 | Object | 对象 | Property | 特性
Attribute | 属性 | Event | 事件 | Method | 方法
Collection | 集合 | Document | 文档 | Window | 窗口
Frame | 框架 | Table | 表格 | Form | 表单
Script | 脚本 | Media | 设备 | Flter | 滤镜
Pseudo-Element | 伪元素 | Pseudo-Class | 伪类 | Selector | 选择符
Unit | 单位 | Declaration | 声明 | At-Rule | 规则
String | 字符串 | Boolean()。 | 声明 | At-Rule | 规则