DHTMLET(TM)

苏昱作品·版权所有
©2002 Rainer Su . All rights reserved .


Rainer's Cascading Style Sheet 2.0 Handbook

End User License Agreement最终用户许可协议
重要须知：
    本《最终用户许可协议》（以下称《协议》）是您（个人或单一实体）与苏昱之间有关苏昱之作品的法律协议。本作品包括计算机软件，并可能包括相关媒体、印刷材料，电子文档，图片。还包括对苏昱提供给您的原作品的任何更新和补充资料。您一旦安装、复制、下载、访问或以其它方式使用本作品，即表示您同意接受本《协议》各项条款的约束。如您不同意本《协议》中的条款，请不要安装或使用本作品。
协议条款：
    本作品受著作权法及国际著作权条约和其它知识产权法和条约的保护。
    本作品（包括但不限于本作品中所含的任何图象、照片、动画、录像、录音、音乐、文字和附加程序）、随附的印刷材料、及本作品的任何副本的产权和著作权，均由苏昱或相关作者拥有。
    本《协议》授予您下列权利：您可以安装、使用、访问、显示、运行本作品。您可以保留多份副本，可以自由传播本作品。
    上述权利不适用于您的任何商业行为或商业用途。否则您务必与苏昱联系。
    苏昱不为本"软件产品"做任何担保。本"软件产品"及任何相关文档以"即此"形式提供，无任何明示的或暗示的担保，包括（但不限于）对可销售性、适用性、或无侵权的暗示担保。使用本"软件产品"所引起的全部风险由您自己承担。
    本协议未明示授予的一切其它权利均为苏昱或相关作者所有。对于此处所指的其他权利，如篡改、反编译、改编、引用、拆解（破坏本作品原始完整性）等，同样请您务必与苏昱先行联系。
    如您未遵守本《协议》的各项条款和条件，在不损害其它权利的情况下，苏昱可终止本《协议》。如此类情况发生，您必须销毁本作品的所有副本及其所有组成部分。苏昱保留对本产品及本协议的最终修改权。

    本《协议》受中华人民共和国法律管辖。

如果您对本《协议》有什么疑问，或您有事想同苏昱联系，请：
    访问：http://www.rainersu.com 　　致信：dhtmlet@hotmail.com


关于 - Rainer's PicSchema

重要说明：
以下信息截至本文档发布之日止。最新个人信息请在 www.rainersu.com 查阅。
基本情况：
姓名： | 苏昱(Rainer Su)
性别： | 男
生日： | 一九七七年九月十四日
学历： | 小学
形象描述：
长发。麻花辫。为了省事买的都是灰黑色系的衣服。不上相。故照片和本人的观感有较大出入。
如果没被照片吓死或恶心死，建议看看本人。此段信息征女友用。
工作经历：
1996.07-2000.03 | 中国航空油料安徽分工司 (CAOSC) | 油品化验员
2000.03-2000.08 | 北京易得方舟信息技术有限公司 (www.chineseall.com) | 栏目主编 频道经理
2000.09-2001.05 | 上海榕树下计算机有限公司 (www.rongshu.com) | 网页设计 前台工程师
2001.05-2002.04 | 异联信息技术上海有限公司 (Erry) | 软件UI设计师 软件工程师
2002.04-? | 上海贝塔斯曼文化实业有限公司 (Bertelsmann) | 网站负责人
能力自述：
精通网络开发的客户端(前台)技术。专家级的网页技术和丰富的工作经验。
有参与实际大型商业软件产品开发的经历。
多篇小说、散文等发表于《青年作家》、《作家天地》等杂志。
独立开发过多种桌面应用软件产品。
联系方式：

    致信：dhtmlet@hotmail.com
    访问：www.rainersu.com

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - ©版权所有 苏昱(Rainer Su)，2002 | dhtmlet@hotmail.com - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


addBehavior版本：DHTML Object Model　返回值：有
语法：
iID = object . addBehavior ( sUrl )
参数：
sUrl : 必选项。字符串(String)。sValue | #default#behaviorName | #objID
sValue | : | 指定行为( behavior) 的 URL 地址。此 URL 地址应用成对引号括起。
#default#behaviorName | : | 使用Microsoft® Internet Explorer的默认行为。由行为的名称标识( #behaviorName )指定。 如：behavior : url ( #default#download ) 。
#objID | : | 使用二进制实现(作为 ActiveX® 控件)的行为。此处的 #objID 为 object 对象的 id 属性值。
返回值：
iID : 整数(Integet)。返回可在被用来将行为从对象分离的标识。
说明：
将行为绑定到对象。
这个方法正如说明的那样，是依据最初的 Internet Explorer 5.0 里所提出DHTML行为的概念，用来将行为附着到要素的。而对于Internet Explorer 5.5里所提出的新的元素行为( Element behaviors )而言，行为是不可以被向元素添加或分离的。
这个方法允许你附着行为而不需要通过使用样式表(CSS)。
除非此方法绑定的行为是 Internet Explorer 内置的默认行为，否则此方法的调用将激发 Internet Explorer 的异步下载。在行为附着到要素之前。
因为此方法的异步性，所以不能依赖它的返回值来判断行为是否成功的附着到对象。请等待 onreadystatechange 事件并校验对象的 readyState 属性值为 complete 从而确保行为已经完全附着到对象并且行为的所有组分可以被脚本使用。否则，试图使用行为内定义的任何部分将导致报告“对象不支持”的脚本错误。
务必注意使用此方法或使用样式表(CSS)的 behavior 属性内联定义附着的行为不会在对象从文档树中移除时被自动分离。而在文档中的样式表规则定义的行为会在对象从文档树中移除时被自动分离。
示例：
----- #default#behaviorName 行为示例-----

<script>
function onDownloadDone(s) {oHandler.innerText=s;}
</script>

<ul>
<li id=oDownload style="behavior:url(#default#download);">那时花开</li>
<li id=oHandler onclick="oDownload.startDownload("cherry.html",onDownloadDone);">菊花茶</li>
</ul>

----- #objID 行为示例-----

<object id=myObject></object>

<ul>
<li style="behavior:url(#myObject);">我的寂寞比这座城市的罪恶还深</li>
</ul>


AddChannel版本：DHTML Object Model　返回值：无
语法：
window . external . AddChanne ( sURL )
参数：
sURL : 必选项。字符串(String)。指定要安装的 CDF 文件的 URL 地址。 CDF 文件是频道定义格式( Channel Definition Format )文件。
返回值：
无
说明：
显示一个对话框允许用户决定是否安装指定的频道( CDF )。
假如出错，会有错误对话框出现。你可以通过使用 onerror 事件禁止该对话框可能的出现。
此方法是用于 Microsoft® Active Channel® 内容发布预定的。Microsoft® Internet Explorer 4. 0及更高版本支持 Active Channel 技术。
此方法不支持HTML应用程式( HTA )。
示例：
window.external.AddChannel("http://www.dhtmlet.com/rdl_dom.cdf");


AddDesktopComponent版本：DHTML Object Model　返回值：无
语法：
window . external . AddDesktopComponent ( sURL , sType , iLeft , iTop , iWidth , iHeight )
参数：
sURL : 必选项。字符串(String)。指定要被加入到 Microsoft® Active Desktop® 的站点或图片的 URL 地址。
sType : 必选项。字符串(String)。image | website
image | : | 要被加入的是一张图片。
website | : | 要被加入的是一个站点。
iLeft : 可选项。整数(Integer)。在屏幕坐标内指定左边距。
iTop : 可选项。整数(Integer)。在屏幕坐标内指定顶边距。
iWidth : 可选项。整数(Integer)。以屏幕单位指定宽度。
iHeight : 可选项。整数(Integer)。以屏幕单位指定高度。
返回值：
无
说明：
添加一个站点或图片到 Microsoft® Active Desktop® 。
用户必须安装了 Microsoft® Active Desktop® 才可以使用本方法。假如 Microsoft® Active Desktop® 没有安装，此方法将不会被调用。
此方法不支持HTML应用程式( HTA )。
示例：
window.external.AddDesktopComponent("http://www.dhtmlet.com","website",100,100,200,200);


AddFavorite版本：DHTML Object Model　返回值：无
语法：
window . external . AddFavorite ( sURL , sTitle )
参数：
sURL | : | 必选项。字符串(String)。指定要加入收藏夹的 URL 地址。
sTitle | : | 可选项。字符串(String)。指定加入收藏夹后显示用的标题名称。
返回值：
无
说明：
提供一个对话框让用户将指定的 URL 加入收藏夹。
使用此方法等同于用户从浏览器的「收藏」菜单内选择「 添加到收藏夹...」。
此方法不支持HTML应用程式( HTA )。
示例：
window.external.AddChannel(window.location.href,window.document.title);


addImport版本：DHTML Object Model　返回值：有
语法：
iIndex = styleSheet . addImport ( sURL , iIndex )
参数：
sURL | : | 必选项。字符串(String)。指定样式表文件的 URL 地址。
iIndex | : | 可选项。整数值(Integer)。指定样式表被放入集合中的位置。忽略此参数将被添加到集合的最后。
返回值：
iIndexL : 整数值(Integer)。被导入的样式表在 imports 集合中的位置。
说明：
添加样式表文件到指定样式表的 imports 集合中。


addPageRule版本：DHTML Object Model　返回值：有
语法：
plNewIndex = styleSheet . addPageRule ( sSelector , sStyle , iIndex )
参数：
sSelector | : | 必选项。字符串(String)。为新的 page 对象指定选择符(Selector)。
sStyle | : | 必选项。字符串(String)。为新的 page 对象指定样式信息。使用内联(Inline)样式定义的格式。如： "color : blue" 。
iIndex | : | 必选项。整数值(Integer)。指定新的 page 对象在 pages 集合里的位置。默认值为 -1 。即加入到 pages 集合的最后。
返回值：
plNewIndex : 此返回值为保留专用值。请勿使用。
说明：
为一个样式表单建立一个新的 page 对象。
每个 page 对象的样式定义对应于文档中的一个 @page 规则。


add版本：DOM1　返回值：无
语法：
object . add ( oElement , iIndex )
参数：
oElement | : | 必选项。对象(Element)。要被添加的对象。
iIndex | : | 可选项。整数(Integer)。指定 oElement 被添加到集合 object 内的序号。如果省略，默认将被添加为最后一项。
返回值：
无
说明：
将 oElement 添加到数组对象 object (Array)中的序号为 iIndex 处。
示例：
var oOption = document.createElement("option");
oSelect.options.add(oOption,0);


add版本：DHTML Object Model　返回值：有
语法：
oNamespace = namespaces . add ( sNamespace , sUrn , sUrl )
参数：
sNamespace | : | 必选项。字符串(String)。指定 namespace 的名字。
sUrn | : | 必选项。字符串(String)。指定 namespace 的通用资源名称( URN )。
sUrl | : | 可选项。字符串(String)。指定要导入 namespace 的元素行为( Element Behavior )的 URL 地址。指定此参数等同于使用 doImport 方法。
返回值：
oNamespace : 对象(Element)。返回 namespace 对象。
说明：
建立一个新的 namespace 对象并加入 namespaces 集合。
如果同名的 namespace 已经存在，它将被覆盖。
示例：
document.namespaces.add("rdl","rdl:demo","rdl_namespace_demo.htc");


alert版本：DHTML Object Model　返回值：无
语法：
window . alert ( sMessage )
参数：
sMessage : 可选项。字符串(String)。指定在对话框内要被显示的信息。如果忽略此参数，将不显示任何信息。
返回值：
无
说明：
显示一个包含可选信息以及「确定」按钮的提示对话框。
此对话框为模式对话框，其标题栏文字不可以被改变。
示例：
window.alert("Dream is my reality .");


appendChild版本：DOM1　返回值：有
语法：
oElement = object . appendChild ( oNode )
参数：
oNode : 必选项。对象(Element)。要被添加的对象。
返回值：
oElement : 对象(Element)。返回被添加对象的引用。
说明：
将 oNode 添加为 object 的最后一个子对象。即 object 的 childNodes 集合的最后一项。
oNode 被添加前，必须先被建立。
要使被添加的 oNode 可视，它必须在文档结构中位于 body 对象以内。
如果 oNode 是已经在文档结构中存在定位的对象，该对象将被移动到你指定的插入位置，而不会有新对象被创建。
在运行时使用此方法是可以的。在对象的关闭标签被解析之前移除对象，则文档空间可能未被呈递。
示例：
var oNewNode=document.createElement("div");
document.body.appendChild(oNewNode);


applyElement版本：DHTML Object Model　返回值：无
语法：
object . applyElement ( oElement , sWhere )
参数：
oElement : 必选项。对象(Element)。要被添加的对象。
sWhere : 可选项。字符串(String)。outside | inside
outside | : | 默认值。将 oElement 添加为 object 的父对象。
inside | : | 将 oElement 添加为 object 的子对象。但 oElement 将成为 object 的原所有子对象的父对象。
返回值：
无
说明：
将 oElement 添加为 object 的父对象或子对象。
oElement 被添加前，必须先被建立。
在运行时使用此方法是可以的。在对象的关闭标签被解析之前移除对象，则文档空间可能未被呈递。


assign版本：DHTML Object Model　返回值：无
语法：
location . assign ( sURL )
参数：
sURL : 必选项。字符串(String)。要被加载的HTML文档的 URL 地址。
返回值：
无
说明：
加载一个新的HTML文档到当前窗口。
示例：
window.location.assign(window.opener.location);


back版本：DHTML Object Model　返回值：无
语法：
history . back ( iDistance )
参数：
iDistance : 可选项。整数(Integet)。指定要后退的 URL 地址数目。假如不提供此参数，将载入历史( history )列表里的上一个 URL 地址。
返回值：
无
说明：
载入历史( history )列表里的一个 URL 地址。
此方法作用等同于用户点击浏览器的「后退」按钮。也等同于 history . go(-1) 。假如用户已经到达历史( history )列表的最后一项，则会停留在当前的 URL 地址而不会发生错误。
示例：
window.history.back(1);


blur版本：DOM1　返回值：无
语法：
object . blur ()
参数：
无
返回值：
无
说明：
导致控件失去焦点。然后激发 onblur 事件。
在 Microsoft® Internet Explorer 5.0+ 中，能使用此方法的元素必须拥有 tabindex 属性。


clearAttributes版本：DHTML Object Model　返回值：无
语法：
object . clearAttributes ()
参数：
无
返回值：
无
说明：
清除 object 的所有属性和属性值。
此方法仅仅清除掉持久性的 HTML 属性。像 id 属性，样式(不包括用 style 属性内联定义的)，以及脚本专用的特性等不会受影响。


clear版本：DOM1　返回值：无
语法：
document . clear ()
参数：
无
返回值：
无
说明：
清除当前文档所有内容。
现在 Internet Explorer 6.0 已不再支持此方法。要清除当前文档内的所有元素，请使用如下代码：

document.write("") ;
document.close();


clear版本：DOM1　返回值：无
语法：
selection . clear ()
参数：
无
返回值：
无
说明：
清除选择区( selection )内的内容。
示例：
document.selection.clear();


click版本：DOM1　返回值：无
语法：
object . click ()
参数：
无
返回值：
无
说明：
模拟对象的一次单击激发 onclick 事件。
请注意此方法不会导致对象获得焦点激发 onfocus 事件。


cloneNode版本：DOM1　返回值：有
语法：
oElement = object . cloneNode ( bCloneChildren )
参数：
bCloneChildren : 可选项。布尔值(Boolean)。false | true
false | : | 默认值。克隆 object 时不包括 object 的 childNodes 集合。即其所有子对象。
true | : | 克隆 object 时包括 object 的 childNodes 集合。即其所有子对象。
返回值：
oElement:对象(Element)。返回克隆后的新对象的引用。
说明：
在文档结构中克隆 object 。
克隆后，获取克隆对象的 id 时，将返回一个集合。
在运行时使用此方法是可以的。在对象的关闭标签被解析前，文档空间可能不能被呈递。


close版本：DOM1　返回值：无
语法：
window . close ()
参数：
无
返回值：
无
说明：
关闭当前浏览器窗口或HTML应用程式( HTA )。
你关闭窗口的步骤决定了用户是否会得到确认提示。假如你对一个不是用脚本打开的窗口调用此方法，用户会看到一个确认对话框。这同样会发生在你用此方法离开当前最后一个 Microsoft® Internet Explorer 运行的实例时。当你用此方法关闭HTML应用程式( HTA )时则不会被提示。因为此种情况下，程序是被信任的并遵循另一个不同的安全模型。
当文档内的对象上的事件( event )激发的函数调用 close 方法时， window 对象的 close 方法被使用。而当文档内的对象上的事件( event )直接使用 close 方法时， document 对象的 close 方法被使用。


close版本：DOM1　返回值：无
语法：
document . close ()
参数：
无
返回值：
无
说明：
关闭输入流，并强制发送数据显示。
当文档内的对象上的事件( event )激发的函数调用 close 方法时， window 对象的 close 方法被使用。而当文档内的对象上的事件( event )直接使用 close 方法时， document 对象的 close 方法被使用。


confirm版本：DHTML Object Model　返回值：有
语法：
bConfirmed = window . confirm ( sMessage )
参数：
sMessage : 可选项。字符串(String)。指定在对话框内要被显示的信息。如果忽略此参数，将不显示任何信息。
返回值：
bConfirmed : 布尔值(Boolean)。false | true
false | : | 用户点击了对话框的「取消」。
true | : | 用户点击了对话框的「确定」。
说明：
显示一个包含可选信息以及「确定」和「取消」按钮的确认对话框。
此对话框为模式对话框，其标题栏文字不可以被改变。
示例：
var bConfirm=window.confirm("Dream is my reality .");


contains版本：DHTML Object Model　返回值：有
语法：
bFound = object . contains ( oElement )
参数：
oElement : 必选项。对象(Element)。要被检查的对象。
返回值：
bFound : 布尔值(Boolean)。false | true
false | : | object 不包含 oElement 。
true | : | object 包含 oElement 。
说明：
检查 object 是否包含 oElement 。


createCaption版本：DOM1　返回值：有
语法：
oCaption = TABLE . createCaption()
参数：
无
返回值：
oElement : 对象(Element)。返回被建立的 caption 对象的引用。
说明：
在 table 对象中建立空的 caption 对象。
假如 table 没有 caption ，则此方法和将建立空的 caption 对象并添加到表格。假如一个或多个 caption 已经存在，则该方法将仅仅返回对其中第一个 caption 的引用。


createControlRange版本：DHTML Object Model　返回值：有
语法：
arrControlRange = BODY . createControlRange ()
参数：
无
返回值：
arrControlRange : 数组(Array)。如果成功的话返回被建立的 ControlRange 集合。
说明：
为非文本对象建立 ControlRange 集合。
为控件选择区而非文本选择区建立选择范围对象。
假如一个 ControlRange 集合已经存在了，此方法会将它覆盖。否则，将返回被建立对象的引用指针。


createElement版本：DOM1　返回值：有
语法：
oElement = document . createElement ( sTagName )
参数：
sTagName : 必选项。字符串(String)。
返回值：
oElement : 对象(Element)。返回新建对象的引用。
说明：
根据指定的标签建立新的对象实例。
在IE4.0上仅仅可以用于新建 img ， area ， option 。在IE5.0上你可以用于新建除了 frame 和 iframe 以外的所有对象类型。
新建对象的属性是可读取以及被程序控制的。
在使用本方法新建对象后，你必须明确的将对象置入集合或文档层次结构中，方可使用它们。
对于 input 而言，因其默认的 type 属性值为 text ，所以新建的实例默认为文本输入框。若期望其他种类的 input ，则使用本方法建立对象时，要设置其 type 属性。
sTagName 可以包含属性，只要整个字符串(String)是有效的HTML。如果你希望在运行时用本方法建立的对象包含 name 属性，你应该这样做。


createPopup版本：DHTML Object Model　返回值：有
语法：
oPopup = window . createPopup ( vArgs )
参数：
vArgs : 可选项。为将来的使用保留的变量。
返回值：
oPopups : 对象(Object)。返回弹出窗口( popup )对象。
说明：
建立一个弹出窗口( popup )。
弹出窗口( popup )初始化为隐藏模式。
当一个激活的对象导致弹出窗口( popup )显示时，此对象不会失去焦点。所以，对象建立一个弹出窗口( popup )时不会激发自己的 onblur 事件。


createRange版本：DHTML Object Model　返回值：有
语法：
range = selection . createRange ()
参数：
无
返回值：
range : 对象(Element)。返回被建立的 TextRange 对象。
说明：
从当前的文本选择区( selection )建立 TextRange 对象。或从当前的控件选择区( selection )建立 controlRange 集合。


createStyleSheet版本：DHTML Object Model　返回值：有
语法：
oStylesheet = document . createStyleSheet ( sURL , iIndex )
参数：
sURL | : | 可选项。字符串(String)。指定怎样将样式规则加入文档。假如是一个文件名，样式信息将作为 link 对象加入。假如包含样式信息，则作为 style 对象加入。
iIndex | : | 可选项。整数值(Integer)。指定加入的样式信息在 styleSheets 集合里的索引序号。默认值为加入到 styleSheets 集合的最后。
返回值：
oStylesheet : 对象(Element)。返回一个 styleSheet 对象。
说明：
为文档建立样式规则。


createTextRange版本：DHTML Object Model　返回值：有
语法：
oTextRange = object . createTextRange ()
参数：
无
返回值：
oTextRange : 对象(Element)。如果成功的话返回被建立的 TextRange 对象。
说明：
为 object 建立 TextRange 对象。
使用此 TextRange 对象可以检索和修改 object 内的文本。 TextRange 对象的 htmlText 特性尤其提供了方便。


createTFoot版本：DOM1　返回值：有
语法：
oTFoot = TABLE . createTFoot()
参数：
无
返回值：
oTFoot : 对象(Element)。成功则返回新建 tfoot 的引用。否则返回 null 。
说明：
在 table 中建立一个新的无内容的 tfoot 。
假如 table 中没有 tfoot ，则此方法和将建立空的 tfoot 对象并添加到表格。假如一个或多个 tfoot 已经存在，则该方法将仅仅返回对其中第一个 tfoot 的引用。


createTHead版本：DOM1　返回值：有
语法：
oTHead = TABLE . createTHead()
参数：
无
返回值：
oTHead : 对象(Element)。成功则返回新建 thead 的引用。否则返回 null 。
说明：
在 table 中建立一个新的无内容的 thead 。
假如 table 中没有 thead ，则此方法和将建立空的 thead 对象并添加到表格。假如一个或多个 thead 已经存在，则该方法将仅仅返回对其中第一个 thead 的引用。


deleteCaption版本：DOM1　返回值：无
语法：
TABLE . deleteCaption()
参数：
无
返回值：
无
说明：
从 table 中删除 caption 及其内容。
假如 table 中存在一个或多个 caption ，则该方法将仅仅删除其中第一个 caption 及其内容。


deleteCell版本：DOM1　返回值：无
语法：
TR . deleteCell( iIndex )
参数：
iIndex : 可选项。整数值(Integer)。指定从表格内删除的 td 或 th 的序号。如果忽略此参数，默认将删除 cells 集合内的最后一个。
返回值：
无
说明：
从从表格行内删除指定的单元格( td 或 th )。也即从 tr 的 cells 集合内删除指定的项目。


deleteRow版本：DOM1　返回值：无
语法：
object . deleteRow ( iIndex )
参数：
iIndex : 可选项。整数值(Integer)。指定从表格内删除的行的序号。如果忽略此参数，默认将删除 rows 集合内的最后一个。
返回值：
无
说明：
从 object 中删除指定的行(Row)。也即从 rows 集合中删除指定的项目( tr )。
指定的行从 tFoot ， tBody ， tHead 中删除，也同时从 table 的 rows 集合中删除。此时 iIndex 应该是表示 tr 的 sectionRowIndex 属性。
指定的行从 table 中删除，等于从 tBody 的 rows 集合中删除。此时 iIndex 应该是表示 tr 的 rowIndex 属性。


deleteTFoot版本：DOM1　返回值：无
语法：
TABLE . deleteTFoot()
参数：
无
返回值：
无
说明：
从 table 中删除 tfoot 及其内容。
假如 table 中存在一个或多个 tfoot ，则该方法将仅仅删除其中第一个 tfoot 及其内容。


deleteTHead版本：DOM1　返回值：无
语法：
TABLE . deleteTHead()
参数：
无
返回值：
无
说明：
从 table 中删除 thead 及其内容。
假如 table 中存在一个或多个 thead ，则该方法将仅仅删除其中第一个 thead 及其内容。


elementFromPoint版本：DHTML Object Model　返回值：有
语法：
oElement = document . elementFromPoint ( iX , iY )
参数：
iX | : | 必选项。整数(Integer)。单位：象素(Pixel)。定位横坐标偏移量。
iY | : | 必选项。整数(Integer)。单位：象素(Pixel)。定位纵坐标偏移量。
返回值：
oElement : 对象(Element)。返回获取的对象的引用。
说明：
根据横纵坐标值 iX 和 iY 获取对象 oElement 。 oElement 必须支持和响应鼠标事件。
提供的坐标是客户区坐标。客户区的左上角为 (0,0)。
当将此方法用于 Structured Graphics 或 Sprite 对象时，必须设置 MouseEventsEnabled 属性值为 1 。


empty版本：DHTML Object Model　返回值：无
语法：
selection . empty ()
参数：
无
返回值：
无
说明：
撤销选择区( selection )内容的选定。设定 selection 的 type 属性值为 none ，并且设置项目属性为 null 。


execCommand版本：DHTML Object Model　返回值：有
语法：
bSuccess = object . execCommand ( sCommand , bUserInterface , vValue )
参数：
sCommand : 必选项。字符串(String)。要被执行的命令。其可以是任何正确的命令标识符( Command Identifier )。
bUserInterface : 可选项。布尔值(Boolean)。false | true
false | : | 默认值。不显示用户接口。
true | : | 显示命令支持的用户接口。
vValue : 可选项。可以分配为任何类型值的变量。其可能的值取决于所执行的命令标识符( Command Identifier )。
返回值：
bSuccess : 布尔值(Boolean)。false | true
false | : | 命令未被成功执行。
true | : | 命令被成功执行。
说明：
在指定的选择区( selection )或文本区( TextRange )上执行一个命令。
bUserInterface 和 vValue 参数是否需要取决于要被执行的命令。
在文档被完全载入前不要调用此方法。


execScript版本：DHTML Object Model　返回值：有
语法：
vReturn = window . execScript ( sExpression , sLanguage )
参数：
sExpression | : | 必选项。字符串(String)。要被执行的代码。
sLanguage | : | 必选项。字符串(String)。指定执行的代码的语言。默认值为 Microsoft JScript (符合 ECMA 262 语言标准)。参阅 script 对象的 language 属性。
返回值：
vReturn : 总是返回 null 。
说明：
执行指定语言的脚本代码。
通过此方法执行的脚本代码可以访问所有其调用脚本可以用到的全局变量。当你想得到当前脚本语言不支持的另一种脚本语言的功能时，这个方法是有用的。例如 Microsoft JScript 里没有的 Microsoft® Visual Basic® Scripting Edition (VBScript) 的 MsgBox 函数。


expand版本：DHTML Object Model　返回值：有
语法：
bSuccess = TextRange . expand ( sUnit )
参数：
sUnit : 必选项。字符串(String)。character | word | sentence | textedit
character | : | 扩展一个字符。
word | : | 扩展一个词。一个词是以空格或其他空白字符(如：tab)为分隔的一组字符。
sentence | : | 扩展一个句子。一个句子是以结束标点符号(如：句号)为分隔的一组词。
textedit | : | 扩展整个封闭区域。
返回值：
bSuccess : 布尔值(Boolean)。false | true
false | : | 区域没有被扩展。
true | : | 区域扩展成功。
说明：
扩展区域使局部单位能够被完全包含进去。
此方法在非 Microsoft® Win32® 平台上不可用。


focus版本：DOM1　返回值：无
语法：
object . focus ()
参数：
无
返回值：
无
说明：
导致控件获得焦点。然后激发 onfocus 事件。
在 Microsoft® Internet Explorer 5.0+ 中，能使用此方法的元素必须拥有 tabindex 属性。
在文档完全载入结束前元素无法获取焦点。


forward版本：DHTML Object Model　返回值：无
语法：
history . forward ()
参数：
无
返回值：
无
说明：
载入历史( history )列表里的下一个 URL 地址。
此方法作用等同于用户点击浏览器的「前进」按钮。也等同于 history . go(1) 。假如用户已经到达历史( history )列表的最前一项，则会停留在当前的 URL 地址而不会发生错误。
示例：
window.history.forward();


getAttribute版本：DOM1　返回值：有
语法：
vAttrValue = object . getAttribute ( sAttrName , iFlags )
参数：
sAttrName : 必选项。字符串(String)。指定属性的名称。
iFlags : 可选项。整数值(Integer)。0 | 1 | 2
0 | : | 默认值。执行不考虑字母大小写的搜索，假如特性被找到了返回一个以内插值替换的值。假如 setAttribute 方法的 iFlags 参数设置为 1 而此方法的 iFlags 参数设置为 0 ， 则满足 sAttrName 指定的特性名称不一定能被找到。
1 | : | 执行严格考虑字母大小写的搜索。
2 | : | 严格的按照脚本或源文档里的设置返回值。
返回值：
vAttrValue : 返回属性的值。可能是任意类型的变量。假如属性没有被呈递，则返回 null 。
说明：
获取指定属性的值。
假如对象有多个名字一样但字母大小写不同的属性，并且 iFlags 参数被设为 0 ，那么只有其中最后被建立的那一个会被此方法获取。而其他的则会被忽略。
当使用此方法获取 CLASS 属性的值时，需要将 sName 参数指定为 className 。这是 CLASS 属性所对应的 DHTML 特性。
此方法仅仅可以由从 HTML 组件建立的事件使用。


getAttribute版本：DOM1　返回值：有
语法：
sValue = userProfile . getAttribute ( )
参数：
sAttributeName : 必选项。字符串(String)。指定一个基本的 vCard 名称。假如这些名称中的一个没有被使用，则请求会被忽略。
返回值：
sValue : 字符串(String)。假如对 sAttributeName 的读访问不可用将返回一个空字符串。
说明：
返回 userProfile 对象的具名属性的值。
下面的数据结构模式语句用于用户数据存储的域名称。当你使用 userProfile 对象的此方法时指定这些名称。请注意格式已经由 vCard_xxx 改为了 vCard.xxx 。旧的格式不再被支持。
vCardNamesvCard.Business.CityvCard.Business.CountryvCard.Business.FaxvCard.Business.PhonevCard.Business.StatevCard.Business.StreetAddressvCard.Business.URLvCard.Business.ZipcodevCard.CellularvCard.CompanyvCard.DepartmentvCard.DisplayNamevCard.EmailvCard.FirstNamevCard.Gender*vCard.Home.CityvCard.Home.CountryvCard.Home.FaxvCard.Home.PhonevCard.Home.StatevCard.Home.StreetAddressvCard.Home.ZipcodevCard.HomepagevCard.JobTitlevCard.LastNamevCard.MiddleNamevCard.NotesvCard.OfficevCard.Pager

注意: 星号(*)表示数据结构模式扩展。扩展是作为在 vCard 模式内定义的 X- 元素被提供引用的。


getElementById版本：DOM1　返回值：有
语法：
oElement = document . getElementById ( sID )
参数：
sID : 必选项。字符串(String)。
返回值：
oElement : 对象(Element)。
说明：
根据指定的 id 属性值得到对象。返回 id 属性值等于 sID 的第一个对象的引用。假如对应的为一组对象，则返回该组对象中的第一个。
如果无符合条件的对象，则返回 null 。


getElementsByName版本：DOM1　返回值：有
语法：
oElements = document . getElementsByName ( sName )
参数：
sName : 必选项。字符串(String)。
返回值：
oElements : 数组(Array)。如果无符合条件的对象，则返回空数组。
说明：
返回 name 属性值或 id 属性值等于 sName 的一组对象的引用。
该数组中只包含本身拥有 name 属性和 id 属性的对象。使用自定义( expando )的 name 属性的对象不会被获取。


getElementsByTagName版本：DOM1　返回值：有
语法：
arrElements = object . getElementsByTagName ( sTagName )
参数：
sTagName : 必选项。字符串(String)。
返回值：
arrElements : 数组(Array)。如果无符合条件的对象，则返回空数组。
说明：
在 object 中获取并返回标记名称等于 sTagName 的一组对象的引用。
该DOM方法等同于DHTML Object Model的 all 集合的 tags 方法。


go版本：DHTML Object Model　返回值：无
语法：
history . go ( vLocation )
参数：
vLocation : 必选项。
整数(Integet) | : | 指定要到达的历史( history )列表里的 URL 地址的相对距离。
字符串(String) | : | 指定要到达的历史( history )列表里的 URL 的完整或部分地址。
返回值：
无
说明：
载入历史( history )列表里的一个 URL 地址。
假如用户试图跨越历史( history )列表的最后一项或最前一项，则会停留在当前的 URL 地址而不会发生错误。
示例：
window.history.go(-1);


hasChildNodes版本：DOM1　返回值：有
语法：
bChildNodes = object . hasChildNodes()
参数：
无
返回值：
bChildNodes : 布尔值(Boolean)。false | true
false | : | object 不包含网页元素( HTML Elements )或 TextNode 对象。
true | : | object 包含网页元素( HTML Elements )或 TextNode 对象。
说明：
检测 object 是否包含有网页元素( HTML Elements )或 TextNodes 对象。
如果 object 包含网页元素( HTML Elements )或 TextNodes ，它们可以通过 object 的 childNodes 集合访问。


hasFocus版本：DHTML Object Model　返回值：有
语法：
bActive = object . hasFocus ()
参数：
无
返回值：
bActive : 布尔值(Boolean)。false | true
false | : | 对象当前有焦点。
true | : | 对象当前不具有焦点。
说明：
检索对象当前是否具有焦点。


hide版本：DHTML Object Model　返回值：无
语法：
popup . hide ()
参数：
无
返回值：
无
说明：
关闭弹出窗口( popup )。


ImportExportFavorites版本：DHTML Object Model　返回值：无
语法：
window . external . ImportExportFavorites ( bImportExport , sImportExportPath )
参数：
bImportExport : 必选项。布尔值(Boolean)。true | false
true | : | 导入请求。
false | : | 导出请求。
sImportExportPath : 可选项。字符串(String)。指定导入或导出的 URL 地址。假如忽略此参数，一个打开文件对话框会被显示。
返回值：
无
说明：
导入或导出 Microsoft® Internet Explorer 的收藏夹。
在导入或导出开始前需要确认。
导出时收藏夹所有内容被上传到服务器。建议将服务器设置为接受更新前删除已存在收藏内容。
从服务器导入的收藏和客户端已存在的收藏内容合并。服务器上的删除不会波及到客户端。
此方法不支持HTML应用程式( HTA )。


insertAdjacentElement版本：DHTML Object Model　返回值：有
语法：
oElement = object . insertAdjacentElement ( sWhere , oElement )
参数：
oElement : 必选项。对象(Element)。要插入到 object 邻近的对象。
sWhere : 必选项。字符串(String)。beforeBegin | afterBegin | beforeEnd | afterEnd
beforeBegin | : | 将 oElement 插到 object 的开始标签之前。
afterBegin | : | 将 oElement 插到 object 的开始标签之后。但是在 object 的所有原有内容之前。
beforeEnd | : | 将 oElement 插到 object 的结束标签之前。但是在 object 的所有原有内容之后。
afterEnd | : | 将 oElement 插到 object 的结束标签之后。
返回值：
oElement : 对象(Element)。返回插入的对象的引用。
说明：
将 oElement 依据 object 定位插入文档结构。
当文档正在载入时，不可以尝试此方法。必须在 onload 事件触发以后。
假如你尝试插入一个已经在文档结构中存在定位的对象，该对象将被移动到你指定的插入位置，而不会有新对象被创建。


insertBefore版本：DOM1　返回值：有
语法：
oElement = object . insertBefore ( oNewNode , oChildNode )
参数：
oNewNode | : | 必选项。对象(Element)。要被插入文档结构的对象。
oChildNode | : | 可选项。对象(Element)。定位插入点。 oNewNode 被插入到紧贴这个子对象的前面。
返回值：
oElement : 对象(Element)。返回插入的对象的引用。
说明：
将 oNewNode 插入文档结构作为 object 的子对象。即对象的 childNodes 集合的最后一项。
oNewNode 被添加前，必须先被建立。
object 没有子对象时使用此方法插入 oNewNode 不要使用 oChildNode 参数。
对于已有子对象的 object 而言，如果忽略 oChildNode 参数， oNewNode 将被插入为 object 的最后一个子对象。即 object 的 childNodes 集合的最后一项。
在运行时使用此方法是可以的。在对象的关闭标签被解析之前移除对象，则文档空间可能未被呈递。


insertCell版本：DOM1　返回值：有
语法：
oTD = TR . insertCell ( iIndex )
参数：
iIndex : 可选项。整数值(Integer)。指定插入 td 的序号。默认值为 -1 ，插入单元格到 cells 集合内的最后一个。
返回值：
oTD : 对象(Element)。成功则返回新建 td 的引用。否则返回 null 。
说明：
在表格行内建立新的单元格( td )，同时添加到 cells 集合内。
推荐使用的方法，是依据默认值将单元格插入到 cells 集合内的最后一个。这是速度最快的插入方式。


insertRow版本：DOM1　返回值：有
语法：
oTR = object . insertRow ( iIndex )
参数：
iIndex : 可选项。整数值(Integer)。指定插入 tr 的序号。默认值为 -1 ，插入单元格到 rows 集合内的最后一个。
返回值：
oTR : 对象(Element)。成功则返回新建 tr 的引用。否则返回 null 。
说明：
在表格行内建立新的行( tr )，同时添加到 rows 集合内。
假如你插入行(Row)到 tFoot ， tBody ， tHead 内，你也需要将行加入 table 的 rows 集合内。加入你指定了 iIndex ，这个序号应该是相对于其最接近的父对象的 rows 集合。例如，假如你插入 tr 到 tFoot 内，那么 iIndex 应该是相对于 tFoot 的 rows 集合，而不是 table 的。
推荐使用的方法，是依据默认值将单元格插入到 rows 集合内的最后一个。这是速度最快的插入方式。


javaEnabled版本：DHTML Object Model　返回值：有
语法：
bEnabled = object . javaEnabled ()
参数：
无
返回值：
bEnabled : 布尔值(Boolean)。false | true
false | : | Java 被禁止。
true | : | Java 被启用。
说明：
返回 Java 是否被启用。


mergeAttributes版本：DHTML Object Model　返回值：无
语法：
object . mergeAttributes ( oSource , bPreserve )
参数：
oSource : IE5.0 必选项。对象(Element)。指定属性要被复制到 object 的对象。
bPreserve : IE5.5 可选项。布尔值(Boolean)。false | true
false | : | 不保护目标对象 object 的身份属性。
true | : | 默认值。保护目标对象 object 的身份属性。
返回值：
无
说明：
复制 oSource 的所有可读写属性到 object 。包括持久的 HTML 属性，事件( event )，和样式。
在 IE5.0 及之前的版本中，只读属性不会被复制。如 id 属性。
在 IE5.5+ 中，通过设置 bPreserve 参数值为 false ，可以使 oSource 的所有属性被复制到 object 。包括 ID 属性和 NAME 属性。


moveRow版本：DHTML Object Model　返回值：有
语法：
oRow = object . moveRow ( iSource , iTarget )
参数：
iSource | : | 必选项。整数值(Integer)。指定被移动的行(Row)在 rows 集合内的序号。默认值是 -1 。
iTarget | : | 可选项。整数值(Integer)。指定移动的目标位置在 rows 集合内的序号。默认值是 -1 。
返回值：
oRow : 对象(Element)。返回被移动的行(Row)的引用。
说明：
移动表格内的行(Row)到新位置。
在 rows 集合内 iSource 与 iTarget 之间跨越的行数是依据行(Row)移动的方向而变化的。


moveToElementText版本：DHTML Object Model　返回值：无
语法：
TextRange . moveToElementText ( oElement )
参数：
oElement : 必选项。对象(Element)。指定要移动到的对象。
返回值：
无
说明：
移动 TextRange 对象使其起始点之间包含指定对象内的文本。
此方法在非 Microsoft® Win32® 平台上不可用。


namedItem版本：DOM1　返回值：有
语法：
oItem = object . namedItem ( sName )
参数：
sName : 必选项。字符串(String)。
返回值：
oItem : 对象(Object)或数组(Array)。如果不成功返回 null 。
说明：
返回集合中 name 属性值或 id 属性值等于 sName 的对象或一组对象的集合。
此方法先在集合中搜寻 id 属性值等于 sName 的对象，如果没有找到，再搜寻 name 属性值等于 sName 的对象。但只获取本身拥有 name 属性和 id 属性的对象。使用自定义( expando )的 name 属性的对象不会被获取。


open版本：DOM1　返回值：有
语法：
oNewDoc = document . open ( sURL , sName )
参数：
sUrl : 必选项。字符串(String)。当打开一个新的文档( document )时，此参数用于指定文档( document )的多用途网际邮件扩充协议(MIME - Multipurpose Internet Mail Extensions)。默认值为 text/html 。目前此方法仅支持此种 MIME 类型。
sName : 可选项。字符串(String)。当打开一个新的文档( document )时，指定此参数值为 replace ，则新文档会覆盖掉历史列表里的当前文档。忽略此参数则新文档被简单的添加到历史列表的最后。
replace : 新文档覆盖历史列表里的当前文档。
返回值：
oNewDoc : 对象(Element)。返回对新的 document 对象的引用。
说明：
打开新文档为 write 和 writeln 的输出做准备。
当文档内的对象上的事件( event )激发的函数调用 open 方法时， window 对象的 open 方法被使用。而当文档内的对象上的事件( event )直接使用 open 方法时， document 对象的 open 方法被使用。


open版本：DOM1　返回值：有
语法：
oNewWindow = window . open ( sURL , sName , sFeatures , bReplace )
参数：
sUrl : 可选项。字符串(String)。指定要被加载的HTML文档的 URL 地址。假如无指定值，则 about:blank 的新窗口会被显示。
sName : 可选项。字符串(String)。 指定打开的窗口的名字。这个名字可以用于 form 或 a 对象的 TARGET 属性。此名字也可以使用下列通用名称:
_media | : | IE6.0 | 在浏览器左边的媒体面板内打开 sUrl 。
_blank | : |  | 在新窗口中打开 sUrl 。
_parent | : |  | 在当前框架的父框架内打开。假如当前框架无父框架，此参数值等同于 _self 。
_search | : | IE5.0 | 在浏览器左边的搜索面板内打开 sUrl 。
_self | : |  | sUrl 在当前窗口中打开，覆盖当前文档。
_top | : |  | 在所有框架之外的最顶层窗口中打开 sUrl 。假如当前窗口无框架结构，此参数值等同于 _self 。
sFeatures : 可选项。字符串(String)。 指定窗口装饰样式。使用下面的值。多个之间用逗号隔开。只有当新的浏览器窗口被建立时，此参数的设置才会发生作用。
channelmode = { yes | no | 1 | 0 } |  | 指定是否将窗口显示为频道模式。默认值为 no 。
directories = { yes | no | 1 | 0 } |  | 指定是否显示「链接」按钮。默认值为 yes 。
fullscreen = { yes | no | 1 | 0 } |  | 指定是否以全屏方式显示窗口。默认值为 no 。要小心使用全屏模式，因为这种模式会隐藏浏览器窗口的标题栏和菜单。如果没有在页面内提供关闭窗口的功能，用户可以使用 ALT+F4 快捷键关闭窗口。
height = number |  | 设置窗口的高度。最小值为 100 。
left = number |  | 设置窗口左上角相对于桌面的横坐标。单位为像素( px )。
width = number |  | 设置窗口的宽度。最小值为 100 。
top = number |  | 设置窗口左上角相对于桌面的纵坐标。单位为像素( px )。
location = { yes | no | 1 | 0 } |  | 设置是否显示浏览器窗口的地址栏。默认值为 yes 。
menubar = { yes | no | 1 | 0 } |  | 设置是否显示浏览器窗口的菜单栏。默认值为 yes 。
resizable = { yes | no | 1 | 0 } |  | 设置窗口是否允许被用户改变尺寸。默认值为 yes 。
scrollbars = { yes | no | 1 | 0 } |  | 设置窗口是否可以具有滚动条。默认值为 yes 。
status = { yes | no | 1 | 0 } |  | 设置是否显示浏览器窗口的状态栏。默认值为 yes 。
titlebar = { yes | no | 1 | 0 } |  | 设置是否显示浏览器窗口的标题栏。除非调用程序是HTML应用程式( HTA )或被信任的对话框，否则此参数将被忽略。默认值为 yes 。
toolbar = { yes | no | 1 | 0 } |  | 设置是否显示浏览器窗口的工具条。默认值为 yes 。
bReplace : 可选项。布尔值(Boolean)。false | true
false | : | 新打开的文档覆盖历史列表里的当前文档。
true | : | 文新打开的文档被简单的添加到历史列表的最后。
返回值：
oNewWindow : 对象(Element)。返回对新的 window 对象的引用。
说明：
打开新窗口并载入 sUrl 指定的HTML文档。 默认情况下，此方法建立的新窗口具有默认的高度、宽度，以及菜单、工具条等。您可以使用 sFeatures 参数改变它们的设置。
当 sFeatures 参数被指定时，没有在参数值的列表中出现的装饰样式都会被自动设置为 no 。
IE5+ 中允许控制打开的窗口的标题栏。通过在被信任的程序像 Microsoft® Visual Basic 或者HTML应用程式( HTA )中打开窗口可以关闭标题栏。他们是可信任的因为他们使用 Microsoft® Internet Explorer 作为浏览器接口。
当文档内的对象上的事件( event )激发的函数调用 open 方法时， window 对象的 open 方法被使用。而当文档内的对象上的事件( event )直接使用 open 方法时， document 对象的 open 方法被使用。
示例：
window.open('about:blank');
window.open('rdl_demo.html');
window.open('http://www.dhtmlet.com/rdl_demo.html',null,'height=200,width=400,status=yes,toolbar=no,menubar=no,location=no');


print版本：DHTML Object Model　返回值：无
语法：
window . print ()
参数：
无
返回值：
无
说明：
打印当前窗口内的文档。
调用此方法等同于从 Microsoft® Internet Explorer 文件菜单内选择「打印」。此方法将激活系统打印对话框供用户选择打印设置。
当用户点击「确定」时，将依次发生下列事件：
  1. onbeforeprint 事件被触发。
  2. 文档被打印。
  3. onafterprint 事件被触发。
当并非所有页面信息在任何时候总是可见的情况下， onbeforeprint 和 onafterprint 事件是非常有用的。使用 onbeforeprint 事件可以检测文档以保障打印时所有页面信息都是可见的。使用 onafterprint 事件可以恢复文档到它的最初状态。


prompt版本：DOM1　返回值：有
语法：
vTextData = window . prompt ( sMessage , sDefaultValue )
参数：
sMessage | : | 可选项。字符串(String)。指定在对话框内要被显示的信息。如果忽略此参数，将不显示任何信息。
sDefaultValue | : | 可选项。字符串(String)。指定对话框内输入框( input )的值( value )。如果忽略此参数，将被设置为 undefined 。
返回值：
vTextData : 字符串(String) | 整数(Integet)。返回用户在对话框的输入框( input )内输入的值( value )。
说明：
显示一个包含提示信息以及输入框( input )的提示对话框。
此对话框为模式对话框，其标题栏文字不可以被改变。
示例：
document.title = window.prompt(document.title,"返回的信息");


DHTMLET(TM)

苏沈小雨制作·保留所有权利
©2001 rain1977.comer . All rights reserved . Terms of Use .


remove版本：DOM1　返回值：无
语法：
object . remove ( iIndex )
参数：
iIndex : 必选项。整数(Integer)。
返回值：
无
说明：
从数组对象 object (Array)中删除序号为 iIndex 的对象。


removeAttribute版本：DOM1　返回值：有
语法：
bSuccess = object . removeAttribute ( sName , iCaseSensitive )
参数：
sName | : | 必选项。字符串(String)。指定要被移除的属性。
iCaseSensitive | : | 可选项。整数值(Integer)。指定是否使用大小写敏感的搜索方式定位属性。默认值为 1 。表明严格的按照 sName 每一个字母的大小写判断确定要被删除的属性。这样，假如对象有多个名字一样但字母大小写不同的属性，那么在不同的平台上，此方法获取的属性可能会不同。
返回值：
bSuccess : 布尔值(Boolean)。false | true
false | : | 没有成功删除属性。
true | : | 属性被成功的删除了。
说明：
从 object 删除指定的属性。
假如对象有多个名字一样但字母大小写不同的属性，并且 iCaseSensitive 参数被设为 0 ，那么只有其中最后被建立的那一个会被删除。而其他的则会被忽略。
当使用此方法删除 CLASS 属性时，需要将 sName 参数指定为 className 。这是 CLASS 属性所对应的 DHTML 特性。
对于 INPUT 对象而言，其 TYPE 属性不可以被删除。
此方法仅仅可以由从 HTML 组件建立的事件使用。


removeChild版本：DOM1　返回值：有
语法：
oElement = object . removeChild ( oChild )
参数：
oChild : 必选项。对象(Element)。要被删除的子对象。
返回值：
oElement : 对象(Element)。返回被删除对象的引用。
说明：
从 object 的子对象中删除 oChild 。
oChild 为 object 的直系子对象。即必须为 object 的 children 集合中的一项。
删除 oChild 时， oChild 的所有子对象将被一起删除。
在运行时使用此方法是可以的。在对象的关闭标签被解析之前移除对象，则文档空间可能未被呈递。


removeNode版本：DHTML Object Model　返回值：有
语法：
oElement = object . removeNode ( bRemoveChildren )
参数：
bRemoveChildren : 可选项。布尔值(Boolean)。false | true
false | : | 默认值。删除 object 时保留 object 的 childNodes 集合。即其所有子对象。
true | : | 删除 object 时也删除 object 的 childNodes 集合。即其所有子对象。
返回值：
oElement : 对象(Element)。返回被删除对象的引用。
说明：
从文档树中删除 object 。
在运行时使用此方法是可以的。在对象的关闭标签被解析前，文档空间的其他区域不能被呈递。


replaceChild版本：DOM1　返回值：有
语法：
oElement = object . replaceChild ( oNewNode , oChild )
参数：
oNewNode | : | 必选项。对象(Element)。用于替换 oChild 的对象。
oChild | : | 必选项。对象(Element)。被 oNewNode 替换的对象。
返回值：
oElement : 对象(Element)。返回被替换对象的引用。
说明：
用 oNewNode 替换 object 的子对象 oChild 。
oChild 为 object 的直系子对象。即必须为 object 的 children 集合中的一项。
当 oChild 被替换时，所有与之相关的属性内容都将被移除。
oNewNode 必须先被建立。
在运行时使用此方法是可以的。在对象的关闭标签被解析前，文档空间可能不能被呈递。


replaceNode版本：DHTML Object Model　返回值：有
语法：
oElement = object . replaceNode ( oNewNode )
参数：
oNewNode : 必选项。对象(Element)。用于替换 object 的对象。
返回值：
oElement : 对象(Element)。返回被替换对象的引用。
说明：
在文档树用 oNewNode 替换 object 。
当 object 被替换时，所有与之相关的属性内容都将被移除。
oNewNode 必须先被建立。
在运行时使用此方法是可以的。在对象的关闭标签被解析前，文档空间可能不能被呈递。


reset版本：DOM1　返回值：无
语法：
form . reset ()
参数：
无
返回值：
无
说明：
重置一个表单( form )。即模拟重置按钮( INPUT type=reset )的一次单击( click )。同时激发 onreset 事件。


resizeBy版本：DOM1　返回值：无
语法：
window . resizeBy ( iX , iY )
参数：
iX | : | 必选项。整数(Integet)。指定窗口宽度改变的偏移量。单位为像素( px )。
iY | : | 必选项。整数(Integet)。指定窗口高度改变的偏移量。单位为像素( px )。
返回值：
无
说明：
根据指定的横向和纵向偏移量改变窗口尺寸。
此方法不可用于对话框窗口。要改变对话框窗口的尺寸，请使用 dialogHeight , dialogWidth , dialogTop , dialogLeft 属性。


resizeTo版本：DHTML Object Model　返回值：无
语法：
window . resizeTo ( iWidth , iHeight )
参数：
iWidth | : | 必选项。整数(Integet)。指定窗口宽度。单位为像素( px )。
iHeight | : | 必选项。整数(Integet)。指定窗口高度。单位为像素( px )。
返回值：
无
说明：
根据指定的宽度和高度改变窗口尺寸。
此方法不可用于对话框窗口。要改变对话框窗口的尺寸，请使用 dialogHeight , dialogWidth , dialogTop , dialogLeft 属性。


select版本：DOM1　返回值：无
语法：
object . select ()
参数：
无
返回值：
无
说明：
高亮显示一个表单( form )组件的输入区域以成为当前选定内容。并为用户的响应安排鼠标光标的位置。


select版本：DOM1　返回值：无
语法：
object . select ()
参数：
无
返回值：
无
说明：
让当前对象成为被激活的选择区( selection )。
此方法在非 Microsoft® Win32® 平台上不可用。


setActive版本：DHTML Object Model　返回值：无
语法：
object . setActive ()
参数：
无
返回值：
无
说明：
使 object 成为当前对象但不赋予焦点。


setAttribute版本：DOM1　返回值：无
语法：
object . setAttribute ( sName , vValue , iFlags )
参数：
sName : 必选项。字符串(String)。指定属性的名称。
vValue : 必选项。要赋给属性的值。可以是任何需要的变量类型。
iFlags : 可选项。整数值(Integer)。0 | 1
0 | : | 当属性被设置的时候，对象任何已有的同名属性设置都会被覆盖，而不会考虑它们的大小写。
1 | : | 默认值。执行严格考虑字母大小写的属性设置。假如此方法的 iFlags 参数设置为 1 ，则执行 iFlags 参数设置为 0 的 getAttribute 方法时，满足 sAttrName 指定的特性名称不一定能被找到。
返回值：
无
说明：
设置指定的属性值。
假如指定的属性尚不存在，则此方法会为对象添加属性并赋值。
请务必小心拼写属性名称。假如你设置 iFlags 参数为 1 ，但是 sName 参数的字母大小写不符合您所期望赋值的属性名称，则此方法的执行结果会是新的属性被建立并赋值。
假如对象有多个名字一样但字母大小写不同的属性，并且 iFlags 参数被设为 0 ，那么只有其中第一个被建立的那一个会被此方法获取。而其他的则会被忽略。
当使用此方法获取 CLASS 属性的值时，需要将 sName 参数指定为 className 。这是 CLASS 属性所对应的 DHTML 特性。


show版本：DHTML Object Model　返回值：无
语法：
popup . show ( iX , iY , iWidth , iHeight , oElement )
参数：
iX | : | 必选项。整数(Integet)。指定弹出窗口( popup )左上角横坐标。单位为像素( px )。
iY | : | 必选项。整数(Integet)。指定弹出窗口( popup )左上角纵坐标。单位为像素( px )。
iWidth | : | 必选项。整数(Integet)。指定弹出窗口( popup )宽度。单位为像素( px )。
iHeight | : | 必选项。整数(Integet)。指定弹出窗口( popup )高度。单位为像素( px )。
oElement | : | 可选项。对象(Element)。指定 iX 和 iY 坐标所相对于的对象。如果忽略此参数，则默认相对于桌面(Desktop)。
返回值：
无
说明：
显示弹出窗口( popup )。


ShowBrowserUI版本：DHTML Object Model　返回值：有
语法：
vReturn = external . ShowBrowserUI ( sUI , null )
参数：
sUI : 必选项。字符串(String)。指定一种浏览器对话框。LanguageDialog | OrganizeFavorites
LanguageDialog | : | 打开「选择语言」对话框。
OrganizeFavorites | : | 打开「整理收藏夹」对话框。
null : 必选项。 null 值。
返回值：
vReturn : 返回值由对话框决定。可能是任何类型的变量。
说明：
打开指定的一种浏览器对话框。


showModalDialog版本：DHTML Object Model　返回值：有
语法：
vReturnValue = window . showModalDialog ( sURL , vArguments , sFeatures )
参数：
sURL  必选项。字符串(String)。指定要载入和显示的 URL 。
vArguments  可选项。指定供显示文档时使用的变量。利用这个参数可以传递任何类型的值，包括包含多个值得的数组。对话框可以通过调用程序从 window 对象的 dialogArguments 属性提取这些值。
sFeatures  可选项。字符串(String)。指定对话框的窗口装饰。使用下面的值。多个之间用分号隔开。
dialogHeight : sHeight |  | 设置对话框的高度。
dialogLeft : sXPos |  | 设置对话框左上角相对于桌面的横坐标。
dialogTop : sYPos |  | 设置对话框左上角相对于桌面的纵坐标。
dialogWidth : sWidth |  | 设置对话框的宽度。
center : yes | no | 1 | 0 | on | off |  | 指定对话框是否显示于桌面正中。默认值为 yes 。
dialogHide : yes | no| 1 | 0 | on | off |  | 指定当打印或打印预览时对话框是否隐藏。仅仅当对话框是由被信任的程式打开的时候此参数才可用。默认值为 no 。
edge : sunken | raised |  | 指定对话框窗口边框样式为凹下还是凸起的。默认值为 raised 。
help : yes | no | 1 | 0 | on | off |  | 指定对话框是否显示上下文相关的帮助图标。默认值为 yes 。
resizable : yes | no | 1 | 0 | on | off |  | 指定对话框是否可以被用户改变尺寸。默认值为 no 。
scroll : yes | no | 1 | 0 | on | off |  | 指定对话框是否显示滚动条。默认值为 yes 。
status : yes | no | 1 | 0 | on | off |  | 指定对话框是否显示状态条。对于不被信任的对话框默认值为 yes 。对于被信任的对话框默认值为 no 。
unadorned : yes | no | 1 | 0 | on | off |  | 指定对话框是否显示 chrome 样式边框。仅仅当对话框是由被信任的程式打开的时候此参数才可用。默认值为 no 。
返回值：
vReturnValue:返回等同于打开的对话框窗口( window )的 returnValue 属性值的值。
说明：
建立模式对话框显示指定的文档。
模式对话框被打开后就会始终保持输入焦点。除非对话框被关闭，否则用户无法切换窗口。
因为无模式对话框能够包含链接指向不同域名下的资源，请不要使用 vArguments 参数传递用户可能认为私有的信息。在模式对话框内部 vArguments 参数可以被模式对话框使用 window 对象的 dialogArguments 属性提取和使用。假如 vArguments 参数被定义为字符串(String)，其可以被传递到无模式对话框的最大长度为 4096 个字符。超出的会被截去。
在 IE4+ 中，你可以禁止对话框窗口的滚动条。要关闭滚动条，可以设置对话框窗口内文档的 body 对象的 SCROLL 属性值为 false ，或是从可信任的程式里调用对话框。
在 IE5+ 中，你可以通过使用 sFeatures 参数中的 status 和 resizable 值控制模式对话框。 你可以用和使用样式表同样的方法设置默认的字体设置。例如： "font:3; font-size:4" 。
使用多种字体属性，你可以定义多种字体值。
在 Internet Explorer 4.0 中， dialogHeight 和 dialogWidth 的缺省单位为 em ，而在 Internet Explorer 5.0 及以上版本中默认单位为 px 。其值可以是整数(Integer)或浮点数(Floating-point number)。因为绝对长度单位(cm, mm, in, pt, pc, px)和相对长度单位(em , ex)的差别， 要想保证预期的显示结果，在设计时应使用 px 单位。
倘若对话框是可以被改变尺寸的，虽然用户的手动改变可以达到更小的值，但是设计时你可以指定的 dialogHeight 的最小值为 100px 。 你可以通过指定 dialogLeft 或 dialogTop 的值来取消对话框显示的居中。即使 center 默认值为 yes 。


showModelessDialog版本：DHTML Object Model　返回值：有
语法：
vReturnValue = window . showModelessDialog ( sURL , vArguments , sFeatures )
参数：
sURL  必选项。字符串(String)。指定要载入和显示的 URL 。
vArguments  可选项。指定供显示文档时使用的变量。利用这个参数可以传递任何类型的值，包括包含多个值得的数组。对话框可以通过调用程序从 window 对象的 dialogArguments 属性提取这些值。
sFeatures  可选项。字符串(String)。指定对话框的窗口装饰。使用下面的值。多个之间用分号隔开。
dialogHeight : sHeight |  | 设置对话框的高度。
dialogLeft : sXPos |  | 设置对话框左上角相对于桌面的横坐标。
dialogTop : sYPos |  | 设置对话框左上角相对于桌面的纵坐标。
dialogWidth : sWidth |  | 设置对话框的宽度。
center : yes | no | 1 | 0 | on | off |  | 指定对话框是否显示于桌面正中。默认值为 yes 。
dialogHide : yes | no| 1 | 0 | on | off |  | 指定当打印或打印预览时对话框是否隐藏。仅仅当对话框是由被信任的程式打开的时候此参数才可用。默认值为 no 。
edge : sunken | raised |  | 指定对话框窗口边框样式为凹下还是凸起的。默认值为 raised 。
help : yes | no | 1 | 0 | on | off |  | 指定对话框是否显示上下文相关的帮助图标。默认值为 yes 。
resizable : yes | no | 1 | 0 | on | off |  | 指定对话框是否可以被用户改变尺寸。默认值为 no 。
scroll : yes | no | 1 | 0 | on | off |  | 指定对话框是否显示滚动条。默认值为 yes 。
status : yes | no | 1 | 0 | on | off |  | 指定对话框是否显示状态条。对于不被信任的对话框默认值为 yes 。对于被信任的对话框默认值为 no 。
unadorned : yes | no | 1 | 0 | on | off |  | 指定对话框是否显示 chrome 样式边框。仅仅当对话框是由被信任的程式打开的时候此参数才可用。默认值为 no 。
返回值：
vReturnValue  返回用于脚本方法的对此对话框( window )对象的引用。
说明：
建立无模式对话框显示指定的文档。
在用户切换输入焦点时，无模式对话框依然会被显示。
此方法对于菜单和帮助系统来说是有用的。当你调用此方法，对话框会被叠放显示在浏览器窗口或HTML应用程式( HTA )前面。
因为无模式对话框能够包含链接指向不同域名下的资源，请不要使用 vArguments 参数传递用户可能认为私有的信息。在模式对话框内部 vArguments 参数可以被模式对话框使用 window 对象的 dialogArguments 属性提取和使用。假如 vArguments 参数被定义为字符串(String)，其可以被传递到无模式对话框的最大长度为 4096 个字符。超出的会被截去。
按照惯例，无模式对话框能够区别于程序窗口在于它们没有滚动条，状态条，或者不可被用户改变尺寸。要建立这样的对话框，执行如下步骤：
1、关闭滚动条。指定对话框中的文档的 body 对象的 scroll 属性值为 no 。
2、关闭状态条。在 sFeatures 参数里指定 status 值为 no 。第二种可能是从可信任的程式里调用对话框，如 Microsoft® Visual Basic 或 HTML应用程式( HTA )，或从被信任的窗口，如可信任的对话框。他们是可信任的因为他们使用 Microsoft® Internet Explorer 作为浏览器接口。对于从被信任的源发生的对话框而言，滚动条默认的是被隐藏的。
3、不可被用户改变尺寸。这是默认的。
建立此方法的返回值，在调用此方法时设置 vArguments 参数为一个回调函数或者一个对象。在无模式对话框中，你可以通过 window 对象的 dialogArguments 属性提取这个函数或者对象。对于无模式对话框和模式对话框来说，同样的参数使用都是正确的。
你可以用和使用样式表同样的方法设置默认的字体设置。例如： "font:3; font-size:4" 。
使用多种字体属性，你可以定义多种字体值。
你可以通过指定 dialogLeft 或 dialogTop 的值来取消对话框显示的居中。即使 center 默认值为 yes 。
在 Internet Explorer 4.0 中， dialogHeight 和 dialogWidth 的缺省单位为 em ，而在 Internet Explorer 5.0 及以上版本中默认单位为 px 。其值可以是整数(Integer)或浮点数(Floating-point number)。因为绝对长度单位(cm, mm, in, pt, pc, px)和相对长度单位(em , ex)的差别， 要想保证预期的显示结果，在设计时应使用 px 单位。
倘若对话框是可以被改变尺寸的，虽然用户的手动改变可以达到更小的值，但是设计时你可以指定的 dialogHeight 的最小值为 100px 。


splitText版本：DOM1　返回值：有
语法：
oTextNode = TextNode . splitText ( iIndex )
参数：
iIndex : 可选项。整数(Integet)。指定从第几个字符处切割。假如未提供此参数，则一个没有值的 TextNode 对象会被建立。
返回值：
oTextNode : 对象(Object)。 TextNode 对象。
说明：
调用此方法的 TextNode 的 nodeValue 属性将变为等于从0到 iIndex 位的子字符串。生成的 oTextNode 的 nodeValue 属性等于从 iIndex 位到结束的子字符串。
当文档保存或持续时， TextNode 的完整性不会被保存。
示例：
var oSplitNode = oTextNode.splitText(oTextNode.nodeValue.length\/2);
document.body.appendChild(oSplitNode);


start版本：DHTML Object Model　返回值：无
语法：
MARQUEE . start ()
参数：
无
返回值：
无
说明：
开始 marquee 对象的滚动。


stop版本：DHTML Object Model　返回值：无
语法：
MARQUEE . stop ()
参数：
无
返回值：
无
说明：
停止 marquee 对象的滚动。


submit版本：DOM1　返回值：无
语法：
form . submit ()
参数：
无
返回值：
无
说明：
提交一个表单( form )。
这个方法不会激发 onsubmit 事件句柄。请直接调用响应 onsubmit 事件的脚本。当使用 IE5 及更高版本时，你可以调用 sEvent 参数为 onsubmit 的 fireEvent 方法。
示例：
document.forms[0].submit();


substringData版本：DOM1　返回值：有
语法：
sSubstring = object . substringData ( nOffset , nCount )
参数：
nOffset | : | 必选项。整数(Integer)。指定从第几个字符开始。
nCount | : | 必选项。整数(Integet)。指定提取字符的数量。
返回值：
sSubstring : 字符串(String)。返回被提取的字符串的引用。
说明：
从对象中提取一定范围的字符。
如果 nOffset 与 nCount 相加的和超过了对象中字符的总数，那么对象中到结束为止的所有字符将被返回。
示例：
txtObj = document.createTextNode("我的寂寞比这座城市的罪恶还深。");
var sSubstring = txtObj.substringData(4,60);


swapNode版本：DHTML Object Model　返回值：有
语法：
oElement = object . swapNode ( oNode )
参数：
oNode : 必选项。对象(Element)。用于与 object 交换的对象。
返回值：
oElement : 对象(Element)。返回调用本方法的对象的引用。
说明：
交换在文档结构中 object 与 oNode 的位置。
当交换发生时，所有与之相关的属性内容都将被交换。
oNode 与 object 必须已经存在。
在运行时使用此方法是可以的。在对象的关闭标签被解析前，文档空间可能不能被呈递。
示例：
document.body.children(2).swapNode(document.body.children(1));


tags版本：DHTML Object Model　返回值：有
语法：
oElements = object . tags ( sTagName )
参数：
sTagName : 必选项。字符串(String)。
返回值：
oElements : 数组(Array)。
说明：
在 object 中获取并返回标记名称等于 sTagName 的一组对象的引用。
该 DHTML 方法等同于 DOM 的 getElementsByTagName 方法。
如果无符合条件的对象，则返回空数组。
示例：
var aReturn=event.srcElement.parentElement.all.tags("a");


taintEnabled版本：DHTML Object Model　返回值：有
语法：
bEnabled = navigator . taintEnabled ()
参数：
无
返回值：
bEnabled : 布尔值(Boolean)。false | true
false | : | 不支持( data tainting )。
true | : | 支持( data tainting )。
说明：
返回( data tainting )是否被激活。
因为 IE5 及其更早版本不支持( data tainting )，所以总是返回 false 。
示例：
var bEnabled = navigator.taintEnabled();


urns版本：DHTML Object Model　返回值：有
语法：
arrObjects = object . urns ( sUrn )
参数：
sUrn : 必选项。字符串(String)。指定行为( behavior ) 的通用资源名称( URN )。
返回值：
arrObjects : 数组(Array)。成功则返回对象集合，否则返回 null 。
说明：
返回绑定了指定行为( behavior) 的一组对象的引用。
使用 length 属性可以获取 arrObjects 包含的对象数目。使用 item 方法可以获取 arrObjects 中某个对象的具体细节。
示例：
var coll = document.all.urns("rdl:demo");


write版本：DOM1　返回值：无
语法：
document . write ( sText )
参数：
sText : 必选项。字符串(String)。指定写入文档的文本或HTML代码。
返回值：
无
说明：
在指定窗口的文档( sText )中写入一个或多个HTML表达式。
示例：
document.white("Every man dies , Not every man really lives .");


writeln版本：DOM1　返回值：无
语法：
document . writeln ( sText )
参数：
sText : 必选项。字符串(String)。指定写入文档的文本或HTML代码。
返回值：
无
说明：
在指定窗口的文档( sText )中写入一个或多个HTML表达式。后跟一个回车。
示例：
document.whiteln("Every man dies , Not every man really lives .");


Appendix　附 录

  1. Color Table 颜色表


execCommand版本：DHTML Object Model　返回值：有
语法：
bSuccess = object . execCommand ( sCommand , bUserInterface , vValue )
参数：
sCommand:必选项。字符串(String)。要被执行的命令。其可以是任何正确的命令标识符(Command Identifier)。
sWhere:必选项。字符串(String)。beforeBegin | afterBegin | beforeEnd | afterEnd
返回值：
range:对象(Element)。返回被建立的 TextRange 对象。
说明：
从当前的文本选择区( selection )建立 TextRange 对象。或从当前的控件选择区( selection )建立 controlRange 集合。


DHTMLET(TM)

Introduction手册简介
手册说明：
本手册针对的是已有一定网页设计制作经验的读者。其目的是提供完整清晰的样式表内容的快速索引及进阶帮助。所以对于网页制作和样式表的基础知识，仅简单介绍，恕不赘述。


Language Codes 　语言代码

代码(Code) | 语言(Language) | 代码(Code) | 语言(Language) | 代码(Code) | 语言(Language)
af | Afrikaans | sq | Albanian | zu | Zulu
ar-sa | Arabic (Saudi Arabia) | ar-iq | Arabic (Iraq) | xh | Xhosa
ar-eg | Arabic (Egypt) | ar-ly | Arabic (Libya) | ji | Yiddish
ar-dz | Arabic (Algeria) | ar-ma | Arabic (Morocco) | ve | Venda
ar-tn | Arabic (Tunisia) | ar-om | Arabic (Oman) | vi | Vietnamese
ar-ye | Arabic (Yemen) | ar-sy | Arabic (Syria) | uk | Ukrainian
ar-jo | Arabic (Jordan) | ar-lb | Arabic (Lebanon) | ur | Urdu
ar-kw | Arabic (Kuwait) | ar-ae | Arabic (U.A.E.) | tn | Tswana
ar-bh | Arabic (Bahrain) | ar-qa | Arabic (Qatar) | tr | Turkish
eu | Basque | bg | Bulgarian | th | Thai
be | Belarusian | ca | Catalan | ts | Tsonga
zh-tw | Chinese (Taiwan) | zh-cn | Chinese (PRC) | sv | Swedish
zh-hk | Chinese (Hong Kong, S.A.R. China) | zh-sg | Chinese (Singapore) | sv-fi | Swedish (Finland)
hr | Croatian | cs | Czech | es-pr | Spanish (Puerto Rico)
da | Danish | nl | Dutch (Standard) | sx | Sutu
nl-be | Dutch (Belgium) | en | English | es-hn | Spanish (Honduras)
en-us | English (United States) | en-gb | English (Great Britain) | es-ni | Spanish (Nicaragua)
en-au | English (Australia) | en-ca | English (Canada) | es-bo | Spanish (Bolivia)
en-nz | English (New Zealand) | en-ie | English (Ireland) | es-sv | Spanish (El Salvador)
en | English (Caribbean) | en-bz | English (Belize) | en-za | English (South Africa)
en-tt | English (Trinidad) | et | Estonian | en-jm | English (Jamaica)
fi | Finnish | fr | French (Standard) | fo | Faeroese
fr-be | French (Belgium) | fr-ca | French (Canada) | fa | Farsi
gd | Gaelic (Scotland) | gd-ie | Gaelic (Ireland) | fr-ch | French (Switzerland)
de | German (Standard) | de-ch | German (Switzerland) | fr-lu | French (Luxembourg)
de-li | German (Liechtenstein) | el | Greek | de-at | German (Austria)
he | Hebrew | hi | Hindi | de-lu | German (Luxembourg)
in | Indonesian | it | Italian (Standard) | hu | Hungarian
it-ch | Italian (Switzerland) | ja | Japanese | is | Icelandic
lv | Latvian | lt | Lithuanian | ko | Korean
mk | FYRO Macedonian | ms | Malaysian | ko | Korean (Johab)
no | Norwegian (Nynorsk) | pl | Polish | mt | Maltese
pt-br | Portuguese (Brazil) | pt | Portuguese (Standard) | no | Norwegian (Bokmal)
ro-mo | Romanian (Moldavia) | ru | Russian | rm | Rhaeto-Romanic
ru-mo | Russian (Moldavia) | sz | Sami (Lappish) | ro | Romanian
sk | Slovak | sl | Slovenian | sr | Serbian (Cyrillic)
sb | Sorbian | es | Spanish (Spain – Traditional) | sr | Serbian (Latin)
es-gt | Spanish (Guatemala) | es-cr | Spanish (Costa Rica) | es-mx | Spanish (Mexico)
es-pa | Spanish (Panama) | es-do | Spanish (Dominican Republic) | es | Spanish (Spain – Modern)
es-pe | Spanish (Peru) | es-ar | Spanish (Argentina) | es-ve | Spanish (Venezuela)
es-ec | Spanish (Ecuador) | es-cl | Spanish (Chile) | es-co | Spanish (Colombia)
es-uy | Spanish (Uruguay) | es-py | Spanish (Paraguay) |  |

请参阅属性: userLanguage 、 systemLanguage