About Jd2chm...

The project files of this HTML Help
Were generated with Jd2chm version 0.3
Copyright © 2000-2003 Andre Burgaud
http://www.burgaud.com


Overview (Hibernate API Documentation)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES

Hibernate API Documentation (3.2.0.ga)

Hibernate API

See:
Description

Core API
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.classic | This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.metadata | This package defines an API for accessing the Hibernate runtime metamodel.
org.hibernate.usertype | Interfaces for user-defined custom types.

Extension API
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.connection | This package abstracts the mechanism for obtaining a JDBC connection.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function | A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.dialect.lock |
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.custom.sql |
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.proxy | This package defines a framework for lazy-initializing entity proxies.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.
org.hibernate.transform | Defines strategies for post-processing criteria query result sets into a form convenient to the application.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Miscellaneous API
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.stat | This package exposes statistics about a running Hibernate instance to the application.
org.hibernate.tool.hbm2ddl | The hbm2ddl tool.
org.hibernate.tool.instrument | The instrument tool for adding field-interception hooks to persistent classes using built-time bytecode processing.

Internal Implementation
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.exception | This package is a fork of Apache commons-lang nestable exceptions.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.antlr | A special package for ANTLR-generated parser classes.
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.intercept | This package implements an interception mechanism for lazy property fetching, based on CGLIB bytecode instrumentation.
org.hibernate.lob | This package defines dummy and wrapper implementations of java.sql.Clob and java.sql.Blob.
org.hibernate.pretty | Classes for pretty printing things for exception and log messages.
org.hibernate.secure | Declarative security for CRUD operations on entities.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.
org.hibernate.util | Utility classes.

Other Packages
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.bytecode.javassist |
org.hibernate.bytecode.util |
org.hibernate.context |
org.hibernate.engine.query |
org.hibernate.engine.query.sql |
org.hibernate.engine.transaction |
org.hibernate.hql.ast.exec |
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.id.insert |
org.hibernate.intercept.cglib |
org.hibernate.intercept.javassist |
org.hibernate.param |
org.hibernate.proxy.dom4j |
org.hibernate.proxy.map |
org.hibernate.proxy.pojo |
org.hibernate.proxy.pojo.cglib |
org.hibernate.proxy.pojo.javassist |
org.hibernate.tool.instrument.cglib |
org.hibernate.tool.instrument.javassist |
org.hibernate.tuple.component |
org.hibernate.tuple.entity |

Hibernate API

This documentation concentrates upon the following Core API interfaces:
  • org.hibernate.Hibernate
  • org.hibernate.Session
  • org.hibernate.SessionFactory
  • org.hibernate.Transaction
  • org.hibernate.Query
  • org.hibernate.Criteria
  • org.hibernate.ScrollableResults
  • org.hibernate.cfg.Configuration
  • org.hibernate.expression.Expression
  • org.hibernate.expression.Order
  • org.hibernate.expression.Example
    • These interfaces are fully intended to be exposed to application code.

    The Extension API is intended to be used by application programmers to extend Hibernate functionality. None of these interfaces are intended to be called by the application - they are called internally by Hibernate. This API is less stable than the Core API. The safest way to extend functionality is to contribute extensions back to the project; that way extensions will be updated when the Extension API changes.

    Full Hibernate documentation may be found at hibernate.org.

    See Also:
    Hibernate, Session, SessionFactory, Transaction, Query, Criteria, ScrollableResults, Configuration, org.hibernate.expression.Expression, org.hibernate.expression.Order, org.hibernate.expression.Example
    Overview Package Class Use Tree Deprecated Index Help
    PREV NEXT FRAMES NO FRAMES


Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For All Packages

Package Hierarchies:
org.hibernate, org.hibernate.action, org.hibernate.bytecode, org.hibernate.bytecode.cglib, org.hibernate.bytecode.javassist, org.hibernate.bytecode.util, org.hibernate.cache, org.hibernate.cache.entry, org.hibernate.cfg, org.hibernate.classic, org.hibernate.collection, org.hibernate.connection, org.hibernate.context, org.hibernate.criterion, org.hibernate.dialect, org.hibernate.dialect.function, org.hibernate.dialect.lock, org.hibernate.engine, org.hibernate.engine.query, org.hibernate.engine.query.sql, org.hibernate.engine.transaction, org.hibernate.event, org.hibernate.event.def, org.hibernate.exception, org.hibernate.hql, org.hibernate.hql.antlr, org.hibernate.hql.ast, org.hibernate.hql.ast.exec, org.hibernate.hql.ast.tree, org.hibernate.hql.ast.util, org.hibernate.hql.classic, org.hibernate.id, org.hibernate.id.insert, org.hibernate.impl, org.hibernate.intercept, org.hibernate.intercept.cglib, org.hibernate.intercept.javassist, org.hibernate.jdbc, org.hibernate.jmx, org.hibernate.loader, org.hibernate.loader.collection, org.hibernate.loader.criteria, org.hibernate.loader.custom, org.hibernate.loader.custom.sql, org.hibernate.loader.entity, org.hibernate.loader.hql, org.hibernate.lob, org.hibernate.mapping, org.hibernate.metadata, org.hibernate.param, org.hibernate.persister, org.hibernate.persister.collection, org.hibernate.persister.entity, org.hibernate.pretty, org.hibernate.property, org.hibernate.proxy, org.hibernate.proxy.dom4j, org.hibernate.proxy.map, org.hibernate.proxy.pojo, org.hibernate.proxy.pojo.cglib, org.hibernate.proxy.pojo.javassist, org.hibernate.secure, org.hibernate.sql, org.hibernate.stat, org.hibernate.tool.hbm2ddl, org.hibernate.tool.instrument, org.hibernate.tool.instrument.cglib, org.hibernate.tool.instrument.javassist, org.hibernate.transaction, org.hibernate.transform, org.hibernate.tuple, org.hibernate.tuple.component, org.hibernate.tuple.entity, org.hibernate.type, org.hibernate.usertype, org.hibernate.util

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.mapping.AbstractAuxiliaryDatabaseObject (implements org.hibernate.mapping.AuxiliaryDatabaseObject)
      • class org.hibernate.mapping.SimpleAuxiliaryDatabaseObject
    • class org.hibernate.jdbc.AbstractBatcher (implements org.hibernate.jdbc.Batcher)
      • class org.hibernate.jdbc.BatchingBatcher
      • class org.hibernate.jdbc.NonBatchingBatcher
    • class org.hibernate.bytecode.AbstractClassTransformerImpl (implements org.hibernate.bytecode.ClassTransformer)
      • class org.hibernate.bytecode.cglib.CglibClassTransformer
      • class org.hibernate.bytecode.javassist.JavassistClassTransformer
    • class org.hibernate.persister.collection.AbstractCollectionPersister (implements org.hibernate.metadata.CollectionMetadata, org.hibernate.persister.collection.SQLLoadableCollection)
      • class org.hibernate.persister.collection.BasicCollectionPersister
      • class org.hibernate.persister.collection.OneToManyPersister
    • class org.hibernate.tuple.component.AbstractComponentTuplizer (implements org.hibernate.tuple.component.ComponentTuplizer)
      • class org.hibernate.tuple.component.Dom4jComponentTuplizer
      • class org.hibernate.tuple.component.DynamicMapComponentTuplizer
      • class org.hibernate.tuple.component.PojoComponentTuplizer
    • class org.hibernate.criterion.AbstractEmptinessExpression (implements org.hibernate.criterion.Criterion)
      • class org.hibernate.criterion.EmptyExpression (implements org.hibernate.criterion.Criterion)
      • class org.hibernate.criterion.NotEmptyExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.persister.entity.AbstractEntityPersister (implements org.hibernate.metadata.ClassMetadata, org.hibernate.intercept.LazyPropertyInitializer, org.hibernate.persister.entity.Lockable, org.hibernate.persister.entity.OuterJoinLoadable, org.hibernate.id.PostInsertIdentityPersister, org.hibernate.persister.entity.Queryable, org.hibernate.persister.entity.SQLLoadable, org.hibernate.persister.entity.UniqueKeyLoadable)
      • class org.hibernate.persister.entity.JoinedSubclassEntityPersister
      • class org.hibernate.persister.entity.SingleTableEntityPersister
      • class org.hibernate.persister.entity.UnionSubclassEntityPersister
    • class org.hibernate.tuple.entity.AbstractEntityTuplizer (implements org.hibernate.tuple.entity.EntityTuplizer)
      • class org.hibernate.tuple.entity.Dom4jEntityTuplizer
      • class org.hibernate.tuple.entity.DynamicMapEntityTuplizer
      • class org.hibernate.tuple.entity.PojoEntityTuplizer
    • class org.hibernate.event.AbstractEvent (implements java.io.Serializable)
      • class org.hibernate.event.DeleteEvent
      • class org.hibernate.event.EvictEvent
      • class org.hibernate.event.FlushEntityEvent
      • class org.hibernate.event.FlushEvent
        • class org.hibernate.event.AutoFlushEvent
        • class org.hibernate.event.DirtyCheckEvent
      • class org.hibernate.event.InitializeCollectionEvent
      • class org.hibernate.event.LoadEvent
      • class org.hibernate.event.LockEvent
      • class org.hibernate.event.MergeEvent
      • class org.hibernate.event.PersistEvent
      • class org.hibernate.event.PostLoadEvent
      • class org.hibernate.event.PostUpdateEvent
      • class org.hibernate.event.PreLoadEvent
      • class org.hibernate.event.RefreshEvent
      • class org.hibernate.event.ReplicateEvent
      • class org.hibernate.event.SaveOrUpdateEvent
    • class org.hibernate.param.AbstractExplicitParameterSpecification (implements org.hibernate.param.ExplicitParameterSpecification)
      • class org.hibernate.param.NamedParameterSpecification (implements org.hibernate.param.ParameterSpecification)
      • class org.hibernate.param.PositionalParameterSpecification (implements org.hibernate.param.ParameterSpecification)
    • class org.hibernate.intercept.AbstractFieldInterceptor (implements org.hibernate.intercept.FieldInterceptor, java.io.Serializable)
      • class org.hibernate.intercept.cglib.FieldInterceptorImpl (implements net.sf.cglib.transform.impl.InterceptFieldCallback, java.io.Serializable)
      • class org.hibernate.intercept.javassist.FieldInterceptorImpl (implements org.hibernate.bytecode.javassist.FieldHandler, java.io.Serializable)
    • class org.hibernate.event.def.AbstractFlushingEventListener (implements java.io.Serializable)
      • class org.hibernate.event.def.DefaultAutoFlushEventListener (implements org.hibernate.event.AutoFlushEventListener)
      • class org.hibernate.event.def.DefaultDirtyCheckEventListener (implements org.hibernate.event.DirtyCheckEventListener)
      • class org.hibernate.event.def.DefaultFlushEventListener (implements org.hibernate.event.FlushEventListener)
    • class org.hibernate.cache.AbstractJndiBoundCacheProvider (implements org.hibernate.cache.CacheProvider)
      • class org.hibernate.cache.JndiBoundTreeCacheProvider
    • class org.hibernate.proxy.AbstractLazyInitializer (implements org.hibernate.proxy.LazyInitializer)
      • class org.hibernate.proxy.pojo.BasicLazyInitializer
        • class org.hibernate.proxy.pojo.cglib.CGLIBLazyInitializer (implements net.sf.cglib.proxy.InvocationHandler)
        • class org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer (implements javassist.util.proxy.MethodHandler)
      • class org.hibernate.proxy.dom4j.Dom4jLazyInitializer (implements java.io.Serializable)
      • class org.hibernate.proxy.map.MapLazyInitializer (implements java.io.Serializable)
    • class org.hibernate.collection.AbstractPersistentCollection (implements org.hibernate.collection.PersistentCollection, java.io.Serializable)
      • class org.hibernate.collection.PersistentArrayHolder
      • class org.hibernate.collection.PersistentBag (implements java.util.List)
      • class org.hibernate.collection.PersistentElementHolder
      • class org.hibernate.collection.PersistentIdentifierBag (implements java.util.List)
      • class org.hibernate.collection.PersistentIndexedElementHolder
        • class org.hibernate.collection.PersistentListElementHolder
        • class org.hibernate.collection.PersistentMapElementHolder
      • class org.hibernate.collection.PersistentList (implements java.util.List)
      • class org.hibernate.collection.PersistentMap (implements java.util.Map)
        • class org.hibernate.collection.PersistentSortedMap (implements java.util.SortedMap)
      • class org.hibernate.collection.PersistentSet (implements java.util.Set)
        • class org.hibernate.collection.PersistentSortedSet (implements java.util.SortedSet)
    • class org.hibernate.id.AbstractPostInsertGenerator (implements org.hibernate.id.PostInsertIdentifierGenerator)
      • class org.hibernate.id.IdentityGenerator
      • class org.hibernate.id.SelectGenerator (implements org.hibernate.id.Configurable)
    • class org.hibernate.persister.entity.AbstractPropertyMapping (implements org.hibernate.persister.entity.PropertyMapping)
      • class org.hibernate.persister.entity.BasicEntityPropertyMapping
      • class org.hibernate.persister.collection.CompositeElementPropertyMapping
    • class org.hibernate.impl.AbstractQueryImpl (implements org.hibernate.Query)
      • class org.hibernate.impl.QueryImpl
        • class org.hibernate.impl.CollectionFilterImpl
      • class org.hibernate.impl.SQLQueryImpl (implements org.hibernate.SQLQuery)
    • class org.hibernate.event.def.AbstractReassociateEventListener (implements java.io.Serializable)
      • class org.hibernate.event.def.AbstractLockUpgradeEventListener
        • class org.hibernate.event.def.DefaultLoadEventListener (implements org.hibernate.event.LoadEventListener)
        • class org.hibernate.event.def.DefaultLockEventListener (implements org.hibernate.event.LockEventListener)
      • class org.hibernate.event.def.AbstractSaveEventListener
        • class org.hibernate.event.def.DefaultMergeEventListener (implements org.hibernate.event.MergeEventListener)
          • class org.hibernate.event.def.DefaultSaveOrUpdateCopyEventListener
        • class org.hibernate.event.def.DefaultPersistEventListener (implements org.hibernate.event.PersistEventListener)
          • class org.hibernate.event.def.DefaultPersistOnFlushEventListener
        • class org.hibernate.event.def.DefaultReplicateEventListener (implements org.hibernate.event.ReplicateEventListener)
        • class org.hibernate.event.def.DefaultSaveOrUpdateEventListener (implements org.hibernate.event.SaveOrUpdateEventListener)
          • class org.hibernate.event.def.DefaultSaveEventListener
          • class org.hibernate.event.def.DefaultUpdateEventListener
    • class org.hibernate.id.insert.AbstractReturningDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
      • class org.hibernate.id.IdentityGenerator.GetGeneratedKeysDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
      • class org.hibernate.id.IdentityGenerator.InsertSelectDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
      • class org.hibernate.id.SequenceIdentityGenerator.Delegate
    • class org.hibernate.impl.AbstractScrollableResults (implements org.hibernate.ScrollableResults)
      • class org.hibernate.impl.FetchingScrollableResultsImpl
      • class org.hibernate.impl.ScrollableResultsImpl (implements org.hibernate.ScrollableResults)
    • class org.hibernate.id.insert.AbstractSelectingDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
      • class org.hibernate.id.IdentityGenerator.BasicDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
      • class org.hibernate.id.SelectGenerator.SelectGeneratorDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
    • class org.hibernate.impl.AbstractSessionImpl (implements org.hibernate.engine.SessionImplementor)
      • class org.hibernate.impl.SessionImpl (implements org.hibernate.event.EventSource, org.hibernate.jdbc.JDBCContext.Context, org.hibernate.classic.Session)
      • class org.hibernate.impl.StatelessSessionImpl (implements org.hibernate.jdbc.JDBCContext.Context, org.hibernate.StatelessSession)
    • class org.hibernate.hql.ast.exec.AbstractStatementExecutor (implements org.hibernate.hql.ast.exec.StatementExecutor)
      • class org.hibernate.hql.ast.exec.BasicExecutor
      • class org.hibernate.hql.ast.exec.MultiTableDeleteExecutor
      • class org.hibernate.hql.ast.exec.MultiTableUpdateExecutor
    • class org.hibernate.type.AbstractType (implements org.hibernate.type.Type)
      • class org.hibernate.type.AnyType (implements org.hibernate.type.AbstractComponentType, org.hibernate.type.AssociationType)
      • class org.hibernate.type.BlobType
      • class org.hibernate.type.ClobType
      • class org.hibernate.type.CollectionType (implements org.hibernate.type.AssociationType)
        • class org.hibernate.type.ArrayType
        • class org.hibernate.type.BagType
        • class org.hibernate.type.CustomCollectionType
        • class org.hibernate.type.IdentifierBagType
        • class org.hibernate.type.ListType
        • class org.hibernate.type.MapType
          • class org.hibernate.type.OrderedMapType
          • class org.hibernate.type.SortedMapType
        • class org.hibernate.type.SetType
          • class org.hibernate.type.OrderedSetType
          • class org.hibernate.type.SortedSetType
      • class org.hibernate.type.ComponentType (implements org.hibernate.type.AbstractComponentType)
        • class org.hibernate.type.EmbeddedComponentType
      • class org.hibernate.type.CompositeCustomType (implements org.hibernate.type.AbstractComponentType)
      • class org.hibernate.type.CustomType (implements org.hibernate.type.DiscriminatorType, org.hibernate.type.IdentifierType, org.hibernate.type.VersionType)
      • class org.hibernate.type.EntityType (implements org.hibernate.type.AssociationType)
        • class org.hibernate.type.ManyToOneType
        • class org.hibernate.type.OneToOneType
          • class org.hibernate.type.SpecialOneToOneType
      • class org.hibernate.type.MetaType
      • class org.hibernate.type.NullableType
        • class org.hibernate.type.ImmutableType
          • class org.hibernate.type.AdaptedImmutableType
          • class org.hibernate.type.BigDecimalType
          • class org.hibernate.type.BigIntegerType (implements org.hibernate.type.DiscriminatorType)
          • class org.hibernate.type.ClassType
          • class org.hibernate.type.CurrencyType (implements org.hibernate.type.LiteralType)
          • class org.hibernate.type.LocaleType (implements org.hibernate.type.LiteralType)
          • class org.hibernate.type.PrimitiveType (implements org.hibernate.type.LiteralType)
            • class org.hibernate.type.BooleanType (implements org.hibernate.type.DiscriminatorType)
              • class org.hibernate.type.CharBooleanType
                • class org.hibernate.type.TrueFalseType
                • class org.hibernate.type.YesNoType
            • class org.hibernate.type.ByteType (implements org.hibernate.type.DiscriminatorType, org.hibernate.type.VersionType)
            • class org.hibernate.type.CharacterType (implements org.hibernate.type.DiscriminatorType)
            • class org.hibernate.type.DoubleType
            • class org.hibernate.type.FloatType
            • class org.hibernate.type.IntegerType (implements org.hibernate.type.DiscriminatorType, org.hibernate.type.VersionType)
            • class org.hibernate.type.LongType (implements org.hibernate.type.DiscriminatorType, org.hibernate.type.VersionType)
            • class org.hibernate.type.ShortType (implements org.hibernate.type.DiscriminatorType, org.hibernate.type.VersionType)
          • class org.hibernate.type.StringType (implements org.hibernate.type.DiscriminatorType)
          • class org.hibernate.type.TextType
          • class org.hibernate.type.TimeZoneType (implements org.hibernate.type.LiteralType)
        • class org.hibernate.type.MutableType
          • class org.hibernate.type.AbstractBynaryType (implements java.util.Comparator, org.hibernate.type.VersionType)
            • class org.hibernate.type.BinaryType
            • class org.hibernate.type.WrapperBinaryType
          • class org.hibernate.type.AbstractCharArrayType
            • class org.hibernate.type.CharacterArrayType
            • class org.hibernate.type.CharArrayType
          • class org.hibernate.type.CalendarDateType
          • class org.hibernate.type.CalendarType (implements org.hibernate.type.VersionType)
          • class org.hibernate.type.DateType (implements org.hibernate.type.IdentifierType, org.hibernate.type.LiteralType)
          • class org.hibernate.type.SerializableType
          • class org.hibernate.type.TimestampType (implements org.hibernate.type.LiteralType, org.hibernate.type.VersionType)
            • class org.hibernate.type.DbTimestampType (implements org.hibernate.type.VersionType)
          • class org.hibernate.type.TimeType (implements org.hibernate.type.LiteralType)
    • class org.hibernate.id.AbstractUUIDGenerator (implements org.hibernate.id.IdentifierGenerator)
      • class org.hibernate.id.UUIDHexGenerator (implements org.hibernate.id.Configurable)
    • class org.hibernate.event.def.AbstractVisitor
      • class org.hibernate.event.def.DirtyCollectionSearchVisitor
      • class org.hibernate.event.def.EvictVisitor
      • class org.hibernate.event.def.FlushVisitor
      • class org.hibernate.event.def.ProxyVisitor
        • class org.hibernate.event.def.ReattachVisitor
          • class org.hibernate.event.def.OnLockVisitor
          • class org.hibernate.event.def.OnReplicateVisitor
          • class org.hibernate.event.def.OnUpdateVisitor
        • class org.hibernate.event.def.WrapVisitor
    • class org.hibernate.bytecode.cglib.AccessOptimizerAdapter (implements org.hibernate.bytecode.ReflectionOptimizer.AccessOptimizer, java.io.Serializable)
    • class org.hibernate.bytecode.javassist.AccessOptimizerAdapter (implements org.hibernate.bytecode.ReflectionOptimizer.AccessOptimizer, java.io.Serializable)
    • class org.hibernate.engine.ActionQueue
    • class org.hibernate.sql.Alias
    • class org.hibernate.criterion.AliasedProjection (implements org.hibernate.criterion.Projection)
    • class org.hibernate.hql.ast.util.AliasGenerator
    • class org.hibernate.transform.AliasToBeanConstructorResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.transform.AliasToBeanResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.transform.AliasToEntityMapResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.dialect.function.AnsiTrimEmulationFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.type.AnyType.ObjectTypeCacheEntry (implements java.io.Serializable)
    • class org.hibernate.util.ArrayHelper
    • class org.hibernate.id.Assigned (implements org.hibernate.id.Configurable, org.hibernate.id.IdentifierGenerator)
    • class org.hibernate.hql.ast.tree.AssignmentSpecification
    • class org.hibernate.hql.ast.util.ASTAppender
    • class antlr.ASTFactory
      • class org.hibernate.hql.ast.HqlASTFactory
      • class org.hibernate.hql.ast.SqlASTFactory (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)
    • class org.hibernate.hql.ast.util.ASTIterator (implements java.util.Iterator)
    • class org.hibernate.hql.ast.util.ASTParentsFirstIterator (implements java.util.Iterator)
    • class org.hibernate.hql.ast.util.ASTPrinter
    • class org.hibernate.hql.ast.ASTQueryTranslatorFactory (implements org.hibernate.hql.QueryTranslatorFactory)
    • class org.hibernate.hql.ast.util.ASTUtil
    • class org.hibernate.hql.ast.util.ASTUtil.IncludePredicate (implements org.hibernate.hql.ast.util.ASTUtil.FilterPredicate)
    • class org.hibernate.property.BackrefPropertyAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.BackrefPropertyAccessor.BackrefGetter (implements org.hibernate.property.Getter)
    • class org.hibernate.property.BackrefPropertyAccessor.BackrefSetter (implements org.hibernate.property.Setter)
    • class antlr.BaseAST (implements antlr.collections.AST, java.io.Serializable)
      • class antlr.CommonAST
        • class org.hibernate.hql.ast.tree.Node
          • class org.hibernate.hql.ast.tree.JavaConstantNode (implements org.hibernate.hql.ast.tree.ExpectedTypeAwareNode, org.hibernate.hql.ast.tree.SessionFactoryAwareNode)
          • class org.hibernate.hql.ast.tree.SqlFragment
          • class org.hibernate.hql.ast.tree.SqlNode
            • class org.hibernate.hql.ast.tree.BetweenOperatorNode (implements org.hibernate.hql.ast.tree.OperatorNode)
            • class org.hibernate.hql.ast.tree.HqlSqlWalkerNode (implements org.hibernate.hql.ast.tree.InitializeableNode)
              • class org.hibernate.hql.ast.tree.AbstractSelectExpression (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.AggregateNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode (implements org.hibernate.hql.ast.tree.BinaryOperatorNode, org.hibernate.hql.ast.tree.DisplayableNode)
                • class org.hibernate.hql.ast.tree.Case2Node (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.CaseNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.CountNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.FromReferenceNode (implements org.hibernate.hql.ast.tree.DisplayableNode, org.hibernate.hql.ast.tree.InitializeableNode, org.hibernate.hql.ast.tree.PathNode, org.hibernate.hql.ast.tree.ResolvableNode)
                  • class org.hibernate.hql.ast.tree.DotNode (implements org.hibernate.hql.ast.tree.DisplayableNode, org.hibernate.hql.ast.tree.SelectExpression)
                  • class org.hibernate.hql.ast.tree.IdentNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                  • class org.hibernate.hql.ast.tree.IndexNode
                  • class org.hibernate.hql.ast.tree.SelectExpressionImpl (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.LiteralNode (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)
                  • class org.hibernate.hql.ast.tree.BooleanLiteralNode (implements org.hibernate.hql.ast.tree.ExpectedTypeAwareNode)
                • class org.hibernate.hql.ast.tree.MethodNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                  • class org.hibernate.hql.ast.tree.CollectionFunction (implements org.hibernate.hql.ast.tree.DisplayableNode)
                • class org.hibernate.hql.ast.tree.UnaryArithmeticNode (implements org.hibernate.hql.ast.tree.UnaryOperatorNode)
              • class org.hibernate.hql.ast.tree.AbstractStatement (implements org.hibernate.hql.ast.tree.DisplayableNode, org.hibernate.hql.ast.tree.Statement)
                • class org.hibernate.hql.ast.tree.AbstractRestrictableStatement (implements org.hibernate.hql.ast.tree.RestrictableStatement)
                  • class org.hibernate.hql.ast.tree.DeleteStatement
                  • class org.hibernate.hql.ast.tree.QueryNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                  • class org.hibernate.hql.ast.tree.UpdateStatement
                • class org.hibernate.hql.ast.tree.InsertStatement
              • class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode (implements org.hibernate.hql.ast.tree.BinaryOperatorNode)
                • class org.hibernate.hql.ast.tree.InLogicOperatorNode (implements org.hibernate.hql.ast.tree.BinaryOperatorNode)
              • class org.hibernate.hql.ast.tree.FromClause (implements org.hibernate.hql.ast.tree.DisplayableNode, org.hibernate.hql.antlr.HqlSqlTokenTypes)
              • class org.hibernate.hql.ast.tree.FromElement (implements org.hibernate.hql.ast.tree.DisplayableNode)
                • class org.hibernate.hql.ast.tree.ImpliedFromElement
              • class org.hibernate.hql.ast.tree.IntoClause (implements org.hibernate.hql.ast.tree.DisplayableNode)
              • class org.hibernate.hql.ast.tree.OrderByClause (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)
              • class org.hibernate.hql.ast.tree.ParameterNode (implements org.hibernate.hql.ast.tree.DisplayableNode, org.hibernate.hql.ast.tree.ExpectedTypeAwareNode)
              • class org.hibernate.hql.ast.tree.SelectExpressionList
                • class org.hibernate.hql.ast.tree.ConstructorNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.SelectClause
            • class org.hibernate.hql.ast.tree.UnaryLogicOperatorNode (implements org.hibernate.hql.ast.tree.UnaryOperatorNode)
    • class org.hibernate.bytecode.util.BasicClassFilter (implements org.hibernate.bytecode.util.ClassFilter)
    • class org.hibernate.tool.instrument.BasicInstrumentationTask.CustomFieldFilter (implements org.hibernate.bytecode.util.FieldFilter)
    • class org.hibernate.tool.instrument.BasicInstrumentationTask.Logger
    • class org.hibernate.property.BasicPropertyAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.BasicPropertyAccessor.BasicGetter (implements org.hibernate.property.Getter)
    • class org.hibernate.property.BasicPropertyAccessor.BasicSetter (implements org.hibernate.property.Setter)
    • class org.hibernate.engine.BatchFetchQueue
    • class org.hibernate.jdbc.BatchingBatcherFactory (implements org.hibernate.jdbc.BatcherFactory)
    • class org.hibernate.loader.collection.BatchingCollectionInitializer (implements org.hibernate.loader.collection.CollectionInitializer)
    • class org.hibernate.loader.entity.BatchingEntityLoader (implements org.hibernate.loader.entity.UniqueEntityLoader)
    • class org.hibernate.criterion.BetweenExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.lob.BlobImpl (implements java.sql.Blob)
    • class org.hibernate.jdbc.BorrowedConnectionProxy (implements java.lang.reflect.InvocationHandler)
    • class org.hibernate.bytecode.javassist.BulkAccessor (implements java.io.Serializable)
    • class org.hibernate.action.BulkOperationCleanupAction (implements org.hibernate.action.Executable, java.io.Serializable)
    • class org.hibernate.bytecode.util.ByteCodeHelper
    • class org.hibernate.bytecode.cglib.BytecodeProviderImpl (implements org.hibernate.bytecode.BytecodeProvider)
    • class org.hibernate.bytecode.javassist.BytecodeProviderImpl (implements org.hibernate.bytecode.BytecodeProvider)
    • class org.hibernate.util.BytesHelper
    • class org.hibernate.connection.C3P0ConnectionProvider (implements org.hibernate.connection.ConnectionProvider)
    • class org.hibernate.cache.entry.CacheEntry (implements java.io.Serializable)
    • class org.hibernate.cache.CacheFactory
    • class org.hibernate.cache.CacheKey (implements java.io.Serializable)
    • class org.hibernate.CacheMode (implements java.io.Serializable)
    • class org.hibernate.transaction.CacheSynchronization (implements javax.transaction.Synchronization)
    • class org.hibernate.util.CalendarComparator (implements java.util.Comparator)
    • class org.hibernate.engine.Cascade
    • class org.hibernate.engine.CascadeStyle (implements java.io.Serializable)
      • class org.hibernate.engine.CascadeStyle.MultipleCascadeStyle
    • class org.hibernate.engine.CascadingAction
    • class org.hibernate.sql.CaseFragment
      • class org.hibernate.sql.ANSICaseFragment
      • class org.hibernate.sql.DecodeCaseFragment
      • class org.hibernate.sql.DerbyCaseFragment
      • class org.hibernate.sql.HSQLCaseFragment
      • class org.hibernate.sql.MckoiCaseFragment
    • class org.hibernate.dialect.function.CastFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.stat.CategorizedStatistics (implements java.io.Serializable)
      • class org.hibernate.stat.CollectionStatistics
      • class org.hibernate.stat.EntityStatistics
      • class org.hibernate.stat.QueryStatistics
      • class org.hibernate.stat.SecondLevelCacheStatistics
    • class org.hibernate.intercept.cglib.CGLIBHelper
    • class org.hibernate.proxy.pojo.cglib.CGLIBProxyFactory (implements org.hibernate.proxy.ProxyFactory)
    • class org.hibernate.property.ChainedPropertyAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.dialect.function.CharIndexFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class antlr.CharScanner (implements antlr.TokenStream)
      • class org.hibernate.hql.antlr.HqlBaseLexer (implements org.hibernate.hql.antlr.HqlTokenTypes, antlr.TokenStream)
    • class org.hibernate.hql.classic.ClassicQueryTranslatorFactory (implements org.hibernate.hql.QueryTranslatorFactory)
    • class java.lang.ClassLoader
      • class org.hibernate.bytecode.InstrumentedClassLoader
      • class org.hibernate.bytecode.javassist.TransformingClassLoader
    • class org.hibernate.hql.classic.ClauseParser (implements org.hibernate.hql.classic.Parser)
    • class org.hibernate.lob.ClobImpl (implements java.sql.Clob)
    • class org.hibernate.util.Cloneable
      • class org.hibernate.event.EventListeners (implements java.io.Serializable)
    • class org.hibernate.transaction.CMTTransaction (implements org.hibernate.Transaction)
    • class org.hibernate.transaction.CMTTransactionFactory (implements org.hibernate.transaction.TransactionFactory)
    • class org.hibernate.mapping.Collection (implements org.hibernate.mapping.Fetchable, org.hibernate.mapping.Filterable, org.hibernate.mapping.Value)
      • class org.hibernate.mapping.Bag
      • class org.hibernate.mapping.IdentifierCollection
        • class org.hibernate.mapping.IdentifierBag
      • class org.hibernate.mapping.IndexedCollection
        • class org.hibernate.mapping.List
          • class org.hibernate.mapping.Array
            • class org.hibernate.mapping.PrimitiveArray
        • class org.hibernate.mapping.Map
      • class org.hibernate.mapping.Set
    • class org.hibernate.action.CollectionAction (implements java.lang.Comparable, org.hibernate.action.Executable, java.io.Serializable)
      • class org.hibernate.action.CollectionRecreateAction
      • class org.hibernate.action.CollectionRemoveAction
      • class org.hibernate.action.CollectionUpdateAction
    • class org.hibernate.cache.entry.CollectionCacheEntry (implements java.io.Serializable)
    • class org.hibernate.engine.CollectionEntry (implements java.io.Serializable)
    • class org.hibernate.util.CollectionHelper
    • class org.hibernate.engine.CollectionKey (implements java.io.Serializable)
    • class org.hibernate.engine.CollectionLoadContext
    • class org.hibernate.hql.CollectionProperties
    • class org.hibernate.persister.collection.CollectionPropertyMapping (implements org.hibernate.persister.entity.PropertyMapping)
    • class org.hibernate.persister.collection.CollectionPropertyNames
    • class org.hibernate.engine.Collections
    • class org.hibernate.cfg.CollectionSecondPass (implements org.hibernate.cfg.SecondPass)
    • class org.hibernate.hql.CollectionSubqueryFactory
    • class org.hibernate.mapping.Column (implements java.lang.Cloneable, org.hibernate.mapping.Selectable, java.io.Serializable)
    • class org.hibernate.loader.custom.ColumnCollectionAliases (implements org.hibernate.loader.CollectionAliases)
    • class org.hibernate.hql.ast.util.ColumnHelper
    • class org.hibernate.tool.hbm2ddl.ColumnMetadata
    • class org.hibernate.jdbc.ColumnNameCache
    • class org.hibernate.util.ComparableComparator (implements java.util.Comparator)
    • class org.hibernate.tuple.component.ComponentMetamodel (implements java.io.Serializable)
    • class org.hibernate.sql.ConditionFragment
    • class org.hibernate.util.ConfigHelper
    • class org.hibernate.cfg.Configuration (implements java.io.Serializable)
    • class org.hibernate.jdbc.ConnectionManager (implements java.io.Serializable)
    • class org.hibernate.connection.ConnectionProviderFactory
    • class org.hibernate.ConnectionReleaseMode (implements java.io.Serializable)
    • class org.hibernate.mapping.Constraint (implements org.hibernate.mapping.RelationalModel, java.io.Serializable)
      • class org.hibernate.mapping.ForeignKey
      • class org.hibernate.mapping.PrimaryKey
      • class org.hibernate.mapping.UniqueKey
    • class org.hibernate.impl.CriteriaImpl (implements org.hibernate.Criteria, java.io.Serializable)
    • class org.hibernate.impl.CriteriaImpl.CriterionEntry (implements java.io.Serializable)
    • class org.hibernate.impl.CriteriaImpl.OrderEntry (implements java.io.Serializable)
    • class org.hibernate.impl.CriteriaImpl.Subcriteria (implements org.hibernate.Criteria, java.io.Serializable)
    • class org.hibernate.loader.criteria.CriteriaQueryTranslator (implements org.hibernate.criterion.CriteriaQuery)
    • class org.hibernate.loader.custom.CustomLoader.NonScalarResultColumnProcessor (implements org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor)
    • class org.hibernate.loader.custom.CustomLoader.ResultRowProcessor
    • class org.hibernate.loader.custom.CustomLoader.ScalarResultColumnProcessor (implements org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor)
    • class org.hibernate.tool.hbm2ddl.DatabaseMetadata
    • class org.hibernate.connection.DatasourceConnectionProvider (implements org.hibernate.connection.ConnectionProvider)
    • class org.hibernate.pretty.DDLFormatter
    • class org.hibernate.event.def.DefaultDeleteEventListener (implements org.hibernate.event.DeleteEventListener)
    • class org.hibernate.loader.DefaultEntityAliases (implements org.hibernate.loader.EntityAliases)
      • class org.hibernate.loader.ColumnEntityAliases
    • class org.hibernate.event.def.DefaultEvictEventListener (implements org.hibernate.event.EvictEventListener)
    • class org.hibernate.event.def.DefaultFlushEntityEventListener (implements org.hibernate.event.FlushEntityEventListener)
    • class org.hibernate.event.def.DefaultInitializeCollectionEventListener (implements org.hibernate.event.InitializeCollectionEventListener)
    • class org.hibernate.cfg.DefaultNamingStrategy (implements org.hibernate.cfg.NamingStrategy, java.io.Serializable)
    • class org.hibernate.event.def.DefaultPostLoadEventListener (implements org.hibernate.event.PostLoadEventListener)
    • class org.hibernate.event.def.DefaultPreLoadEventListener (implements org.hibernate.event.PreLoadEventListener)
    • class org.hibernate.event.def.DefaultRefreshEventListener (implements org.hibernate.event.RefreshEventListener)
    • class org.hibernate.action.DelayedPostInsertIdentifier (implements java.io.Serializable)
    • class org.hibernate.sql.Delete
    • class org.hibernate.dialect.DerbyDialect.DerbyTrimFunctionEmulation (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.criterion.DetachedCriteria (implements org.hibernate.criterion.CriteriaSpecification, java.io.Serializable)
    • class org.hibernate.dialect.Dialect
      • class org.hibernate.dialect.DB2Dialect
        • class org.hibernate.dialect.DB2390Dialect
        • class org.hibernate.dialect.DB2400Dialect
        • class org.hibernate.dialect.DerbyDialect
      • class org.hibernate.dialect.FrontBaseDialect
      • class org.hibernate.dialect.H2Dialect
      • class org.hibernate.dialect.HSQLDialect
      • class org.hibernate.dialect.InformixDialect
      • class org.hibernate.dialect.IngresDialect
      • class org.hibernate.dialect.InterbaseDialect
        • class org.hibernate.dialect.FirebirdDialect
      • class org.hibernate.dialect.JDataStoreDialect
      • class org.hibernate.dialect.MckoiDialect
      • class org.hibernate.dialect.MimerSQLDialect
      • class org.hibernate.dialect.MySQLDialect
        • class org.hibernate.dialect.MySQL5Dialect
          • class org.hibernate.dialect.MySQL5InnoDBDialect
        • class org.hibernate.dialect.MySQLInnoDBDialect
        • class org.hibernate.dialect.MySQLMyISAMDialect
      • class org.hibernate.dialect.Oracle9Dialect
        • class org.hibernate.dialect.DataDirectOracle9Dialect
        • class org.hibernate.dialect.OracleDialect
      • class org.hibernate.dialect.PointbaseDialect
      • class org.hibernate.dialect.PostgreSQLDialect
      • class org.hibernate.dialect.ProgressDialect
      • class org.hibernate.dialect.RDMSOS2200Dialect
      • class org.hibernate.dialect.SAPDBDialect
      • class org.hibernate.dialect.SybaseDialect
        • class org.hibernate.dialect.SQLServerDialect
        • class org.hibernate.dialect.Sybase11Dialect
        • class org.hibernate.dialect.SybaseAnywhereDialect
      • class org.hibernate.dialect.TimesTenDialect
    • class org.hibernate.dialect.DialectFactory
    • class org.hibernate.dialect.DialectFactory.VersionInsensitiveMapper (implements org.hibernate.dialect.DialectFactory.DatabaseDialectMapper)
    • class org.hibernate.property.DirectPropertyAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.DirectPropertyAccessor.DirectGetter (implements org.hibernate.property.Getter)
    • class org.hibernate.property.DirectPropertyAccessor.DirectSetter (implements org.hibernate.property.Setter)
    • class org.hibernate.sql.DisjunctionFragment
    • class org.hibernate.criterion.Distinct (implements org.hibernate.criterion.Projection)
    • class org.hibernate.transform.DistinctRootEntityResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.property.Dom4jAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.Dom4jAccessor.Dom4jGetter (implements org.hibernate.property.Getter)
      • class org.hibernate.property.Dom4jAccessor.AttributeGetter
      • class org.hibernate.property.Dom4jAccessor.ElementAttributeGetter
      • class org.hibernate.property.Dom4jAccessor.ElementGetter
      • class org.hibernate.property.Dom4jAccessor.TextGetter
    • class org.hibernate.property.Dom4jAccessor.Dom4jSetter (implements org.hibernate.property.Setter)
      • class org.hibernate.property.Dom4jAccessor.AttributeSetter
      • class org.hibernate.property.Dom4jAccessor.ElementAttributeSetter
      • class org.hibernate.property.Dom4jAccessor.ElementSetter
      • class org.hibernate.property.Dom4jAccessor.TextSetter
    • class org.hibernate.tuple.Dom4jInstantiator (implements org.hibernate.tuple.Instantiator)
    • class org.hibernate.proxy.dom4j.Dom4jProxy (implements org.dom4j.Element, org.hibernate.proxy.HibernateProxy, java.io.Serializable)
    • class org.hibernate.proxy.dom4j.Dom4jProxyFactory (implements org.hibernate.proxy.ProxyFactory)
    • class org.hibernate.connection.DriverManagerConnectionProvider (implements org.hibernate.connection.ConnectionProvider)
    • class org.hibernate.util.DTDEntityResolver (implements org.xml.sax.EntityResolver, java.io.Serializable)
    • class org.hibernate.tuple.DynamicMapInstantiator (implements org.hibernate.tuple.Instantiator)
    • class org.hibernate.cache.EhCache (implements org.hibernate.cache.Cache)
    • class org.hibernate.cache.EhCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class org.hibernate.persister.collection.ElementPropertyMapping (implements org.hibernate.persister.entity.PropertyMapping)
    • class org.hibernate.tuple.ElementWrapper (implements org.dom4j.Element, java.io.Serializable)
    • class org.hibernate.property.EmbeddedPropertyAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter (implements org.hibernate.property.Getter)
    • class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedSetter (implements org.hibernate.property.Setter)
    • class org.hibernate.EmptyInterceptor (implements org.hibernate.Interceptor, java.io.Serializable)
    • class org.hibernate.util.EmptyIterator (implements java.util.Iterator)
    • class org.hibernate.action.EntityAction (implements java.lang.Comparable, org.hibernate.action.Executable, java.io.Serializable)
      • class org.hibernate.action.EntityDeleteAction
      • class org.hibernate.action.EntityIdentityInsertAction
      • class org.hibernate.action.EntityInsertAction
      • class org.hibernate.action.EntityUpdateAction
    • class org.hibernate.engine.EntityEntry (implements java.io.Serializable)
    • class org.hibernate.engine.EntityKey (implements java.io.Serializable)
    • class org.hibernate.tuple.entity.EntityMetamodel (implements java.io.Serializable)
    • class org.hibernate.EntityMode (implements java.io.Serializable)
    • class org.hibernate.tuple.EntityModeToTuplizerMapping (implements java.io.Serializable)
      • class org.hibernate.tuple.entity.EntityEntityModeToTuplizerMapping (implements java.io.Serializable)
    • class org.hibernate.engine.EntityUniqueKey (implements java.io.Serializable)
    • class org.hibernate.cfg.Environment
    • class org.hibernate.util.EqualsHelper
    • class org.hibernate.hql.ast.ErrorCounter (implements org.hibernate.hql.ast.ParseErrorHandler)
    • class org.hibernate.criterion.Example (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.exception.ExceptionUtils
    • class org.hibernate.engine.ExecuteUpdateResultCheckStyle (implements java.io.Serializable)
    • class org.hibernate.jdbc.Expectations
    • class org.hibernate.jdbc.Expectations.BasicExpectation (implements org.hibernate.jdbc.Expectation)
      • class org.hibernate.jdbc.Expectations.BasicParamExpectation
    • class org.hibernate.cfg.ExtendsQueueEntry
    • class org.hibernate.util.ExternalSessionFactoryConfig
      • class org.hibernate.jmx.HibernateService (implements org.hibernate.jmx.HibernateServiceMBean)
    • class org.hibernate.bytecode.javassist.FastClass (implements java.io.Serializable)
    • class org.hibernate.util.FastHashMap (implements java.util.Map, java.io.Serializable)
    • class org.hibernate.FetchMode (implements java.io.Serializable)
    • class org.hibernate.intercept.FieldInterceptionHelper
    • class org.hibernate.bytecode.javassist.FieldTransformer
    • class org.hibernate.engine.FilterDefinition (implements java.io.Serializable)
    • class org.hibernate.util.FilterHelper
    • class org.hibernate.impl.FilterImpl (implements org.hibernate.Filter, java.io.Serializable)
    • class org.hibernate.cache.FilterKey (implements java.io.Serializable)
    • class org.hibernate.FlushMode (implements java.io.Serializable)
    • class org.hibernate.id.ForeignGenerator (implements org.hibernate.id.Configurable, org.hibernate.id.IdentifierGenerator)
    • class org.hibernate.type.ForeignKeyDirection (implements java.io.Serializable)
    • class org.hibernate.tool.hbm2ddl.ForeignKeyMetadata
    • class org.hibernate.engine.ForeignKeys
    • class org.hibernate.engine.ForeignKeys.Nullifier
    • class org.hibernate.pretty.Formatter
    • class org.hibernate.mapping.Formula (implements org.hibernate.mapping.Selectable, java.io.Serializable)
    • class org.hibernate.sql.ForUpdateFragment
    • class org.hibernate.hql.classic.FromParser (implements org.hibernate.hql.classic.Parser)
    • class org.hibernate.loader.GeneratedCollectionAliases (implements org.hibernate.loader.CollectionAliases)
    • class org.hibernate.util.GetGeneratedKeysHelper
    • class org.hibernate.hql.classic.GroupByParser (implements org.hibernate.hql.classic.Parser)
    • class org.hibernate.id.GUIDGenerator (implements org.hibernate.id.IdentifierGenerator)
    • class org.hibernate.cache.HashtableCache (implements org.hibernate.cache.Cache)
    • class org.hibernate.cache.HashtableCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class org.hibernate.cfg.HbmBinder
    • class org.hibernate.Hibernate
    • class org.hibernate.proxy.HibernateProxyHelper
    • class org.hibernate.hql.HolderInstantiator
    • class org.hibernate.engine.query.HQLQueryPlan (implements java.io.Serializable)
      • class org.hibernate.engine.query.FilterQueryPlan (implements java.io.Serializable)
    • class org.hibernate.criterion.IdentifierEqExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.id.IdentifierGeneratorFactory
    • class org.hibernate.engine.IdentifierValue
    • class org.hibernate.util.IdentityMap (implements java.util.Map)
    • class org.hibernate.util.IdentityMap.IdentityKey (implements java.io.Serializable)
    • class org.hibernate.util.IdentityMap.IdentityMapEntry (implements java.util.Map.Entry)
    • class org.hibernate.util.IdentitySet (implements java.util.Set)
    • class org.hibernate.criterion.IlikeExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.cfg.ImprovedNamingStrategy (implements org.hibernate.cfg.NamingStrategy, java.io.Serializable)
    • class org.hibernate.id.IncrementGenerator (implements org.hibernate.id.Configurable, org.hibernate.id.IdentifierGenerator)
    • class org.hibernate.mapping.Index (implements org.hibernate.mapping.RelationalModel, java.io.Serializable)
    • class org.hibernate.tool.hbm2ddl.IndexMetadata
    • class org.hibernate.property.IndexPropertyAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.IndexPropertyAccessor.IndexGetter (implements org.hibernate.property.Getter)
    • class org.hibernate.property.IndexPropertyAccessor.IndexSetter (implements org.hibernate.property.Setter)
    • class org.hibernate.criterion.InExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.sql.InFragment
    • class java.io.InputStream
      • class org.hibernate.lob.ReaderInputStream
    • class org.hibernate.sql.Insert
      • class org.hibernate.id.insert.IdentifierGeneratingInsert
        • class org.hibernate.id.insert.InsertSelectIdentityInsert
        • class org.hibernate.id.SequenceIdentityGenerator.NoCommentsInsert
    • class org.hibernate.sql.InsertSelect
    • class org.hibernate.bytecode.cglib.InstantiationOptimizerAdapter (implements org.hibernate.bytecode.ReflectionOptimizer.InstantiationOptimizer, java.io.Serializable)
    • class org.hibernate.bytecode.javassist.InstantiationOptimizerAdapter (implements org.hibernate.bytecode.ReflectionOptimizer.InstantiationOptimizer, java.io.Serializable)
    • class org.hibernate.engine.transaction.Isolater
    • class org.hibernate.engine.transaction.Isolater.JdbcDelegate (implements org.hibernate.engine.transaction.Isolater.Delegate)
    • class org.hibernate.engine.transaction.Isolater.JtaDelegate (implements org.hibernate.engine.transaction.Isolater.Delegate)
    • class org.hibernate.impl.IteratorImpl (implements org.hibernate.engine.HibernateIterator)
    • class org.hibernate.secure.JACCConfiguration
    • class org.hibernate.secure.JACCPermissions
    • class org.hibernate.secure.JACCPreDeleteEventListener (implements org.hibernate.event.Initializable, org.hibernate.secure.JACCSecurityListener, org.hibernate.event.PreDeleteEventListener)
    • class org.hibernate.secure.JACCPreInsertEventListener (implements org.hibernate.event.Initializable, org.hibernate.secure.JACCSecurityListener, org.hibernate.event.PreInsertEventListener)
    • class org.hibernate.secure.JACCPreLoadEventListener (implements org.hibernate.event.Initializable, org.hibernate.secure.JACCSecurityListener, org.hibernate.event.PreLoadEventListener)
    • class org.hibernate.secure.JACCPreUpdateEventListener (implements org.hibernate.event.Initializable, org.hibernate.secure.JACCSecurityListener, org.hibernate.event.PreUpdateEventListener)
    • class org.hibernate.intercept.javassist.JavassistHelper
    • class org.hibernate.proxy.pojo.javassist.JavassistProxyFactory (implements org.hibernate.proxy.ProxyFactory, java.io.Serializable)
    • class org.hibernate.jdbc.JDBCContext (implements org.hibernate.jdbc.ConnectionManager.Callback, java.io.Serializable)
    • class org.hibernate.exception.JDBCExceptionHelper
    • class org.hibernate.util.JDBCExceptionReporter
    • class org.hibernate.transaction.JDBCTransaction (implements org.hibernate.Transaction)
    • class org.hibernate.transaction.JDBCTransactionFactory (implements org.hibernate.transaction.TransactionFactory)
    • class org.hibernate.transaction.JNDITransactionManagerLookup (implements org.hibernate.transaction.TransactionManagerLookup)
      • class org.hibernate.transaction.BESTransactionManagerLookup
      • class org.hibernate.transaction.JBossTransactionManagerLookup
      • class org.hibernate.transaction.JRun4TransactionManagerLookup
      • class org.hibernate.transaction.OC4JTransactionManagerLookup
      • class org.hibernate.transaction.OrionTransactionManagerLookup
      • class org.hibernate.transaction.ResinTransactionManagerLookup
      • class org.hibernate.transaction.SunONETransactionManagerLookup
      • class org.hibernate.transaction.WeblogicTransactionManagerLookup
    • class org.hibernate.mapping.Join (implements java.io.Serializable)
    • class org.hibernate.util.JoinedIterator (implements java.util.Iterator)
    • class org.hibernate.sql.JoinFragment
      • class org.hibernate.sql.ANSIJoinFragment
      • class org.hibernate.sql.OracleJoinFragment
      • class org.hibernate.sql.QueryJoinFragment
      • class org.hibernate.sql.Sybase11JoinFragment
    • class org.hibernate.engine.JoinHelper
    • class org.hibernate.hql.ast.util.JoinProcessor (implements org.hibernate.hql.antlr.SqlTokenTypes)
    • class org.hibernate.engine.JoinSequence
    • class org.hibernate.loader.JoinWalker
      • class org.hibernate.loader.AbstractEntityJoinWalker
        • class org.hibernate.loader.entity.CascadeEntityJoinWalker
        • class org.hibernate.loader.criteria.CriteriaJoinWalker
        • class org.hibernate.loader.entity.EntityJoinWalker
      • class org.hibernate.loader.collection.CollectionJoinWalker
        • class org.hibernate.loader.collection.BasicCollectionJoinWalker
        • class org.hibernate.loader.collection.OneToManyJoinWalker
    • class org.hibernate.transaction.JOnASTransactionManagerLookup (implements org.hibernate.transaction.TransactionManagerLookup)
    • class org.hibernate.transaction.JOTMTransactionManagerLookup (implements org.hibernate.transaction.TransactionManagerLookup)
    • class org.hibernate.util.JTAHelper
    • class org.hibernate.context.JTASessionContext (implements org.hibernate.context.CurrentSessionContext)
    • class org.hibernate.context.JTASessionContext.CleanupSynch (implements javax.transaction.Synchronization)
    • class org.hibernate.transaction.JTATransaction (implements org.hibernate.Transaction)
    • class org.hibernate.transaction.JTATransactionFactory (implements org.hibernate.transaction.TransactionFactory)
    • class org.hibernate.criterion.Junction (implements org.hibernate.criterion.Criterion)
      • class org.hibernate.criterion.Conjunction
      • class org.hibernate.criterion.Disjunction
    • class org.hibernate.util.LazyIterator (implements java.util.Iterator)
    • class org.hibernate.criterion.LikeExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.util.LinkedHashCollectionHelper
    • class org.hibernate.hql.ast.util.LiteralProcessor (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)
    • class org.hibernate.loader.Loader
      • class org.hibernate.loader.BasicLoader
        • class org.hibernate.loader.OuterJoinLoader
          • class org.hibernate.loader.entity.AbstractEntityLoader (implements org.hibernate.loader.entity.UniqueEntityLoader)
            • class org.hibernate.loader.entity.CascadeEntityLoader
            • class org.hibernate.loader.entity.EntityLoader
          • class org.hibernate.loader.entity.CollectionElementLoader
          • class org.hibernate.loader.collection.CollectionLoader (implements org.hibernate.loader.collection.CollectionInitializer)
            • class org.hibernate.loader.collection.BasicCollectionLoader
              • class org.hibernate.loader.collection.SubselectCollectionLoader
            • class org.hibernate.loader.collection.OneToManyLoader
              • class org.hibernate.loader.collection.SubselectOneToManyLoader
          • class org.hibernate.loader.criteria.CriteriaLoader
        • class org.hibernate.loader.hql.QueryLoader
        • class org.hibernate.hql.classic.QueryTranslatorImpl (implements org.hibernate.hql.FilterTranslator)
      • class org.hibernate.loader.custom.CustomLoader
    • class org.hibernate.event.LoadEventListener.LoadType
    • class org.hibernate.LockMode (implements java.io.Serializable)
    • class org.hibernate.criterion.LogicalExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.context.ManagedSessionContext (implements org.hibernate.context.CurrentSessionContext)
    • class org.hibernate.property.MapAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.MapAccessor.MapGetter (implements org.hibernate.property.Getter)
    • class org.hibernate.property.MapAccessor.MapSetter (implements org.hibernate.property.Setter)
    • class org.hibernate.cfg.Mappings (implements java.io.Serializable)
    • class org.hibernate.cfg.Mappings.ColumnNames (implements java.io.Serializable)
    • class org.hibernate.cfg.Mappings.TableDescription (implements java.io.Serializable)
    • class org.hibernate.proxy.map.MapProxy (implements org.hibernate.proxy.HibernateProxy, java.util.Map, java.io.Serializable)
    • class org.hibernate.proxy.map.MapProxyFactory (implements org.hibernate.proxy.ProxyFactory)
    • class org.hibernate.util.MarkerObject
    • class org.hibernate.criterion.MatchMode (implements java.io.Serializable)
    • class org.hibernate.pretty.MessageHelper
    • class org.hibernate.mapping.MetaAttribute (implements java.io.Serializable)
    • class org.hibernate.util.NamedGeneratedKeysHelper
    • class org.hibernate.engine.query.NamedParameterDescriptor (implements java.io.Serializable)
    • class org.hibernate.persister.collection.NamedQueryCollectionInitializer (implements org.hibernate.loader.collection.CollectionInitializer)
    • class org.hibernate.engine.NamedQueryDefinition (implements java.io.Serializable)
      • class org.hibernate.engine.NamedSQLQueryDefinition
    • class org.hibernate.persister.entity.NamedQueryLoader (implements org.hibernate.loader.entity.UniqueEntityLoader)
    • class org.hibernate.hql.NameGenerator
    • class org.hibernate.util.NamingHelper
    • class org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn (implements org.hibernate.engine.query.sql.NativeSQLQueryReturn, java.io.Serializable)
      • class org.hibernate.engine.query.sql.NativeSQLQueryCollectionReturn
      • class org.hibernate.engine.query.sql.NativeSQLQueryJoinReturn
      • class org.hibernate.engine.query.sql.NativeSQLQueryRootReturn
    • class org.hibernate.engine.query.NativeSQLQueryPlan (implements java.io.Serializable)
    • class org.hibernate.engine.query.sql.NativeSQLQueryScalarReturn (implements org.hibernate.engine.query.sql.NativeSQLQueryReturn)
    • class org.hibernate.engine.query.sql.NativeSQLQuerySpecification
    • class org.hibernate.criterion.NaturalIdentifier (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.exception.NestableDelegate (implements java.io.Serializable)
    • class org.hibernate.dialect.function.NoArgSQLFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.cache.NoCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class org.hibernate.hql.ast.util.NodeTraverser
    • class org.hibernate.jdbc.NonBatchingBatcherFactory (implements org.hibernate.jdbc.BatcherFactory)
    • class org.hibernate.loader.custom.NonScalarReturn (implements org.hibernate.loader.custom.Return)
      • class org.hibernate.loader.custom.CollectionReturn
      • class org.hibernate.loader.custom.FetchReturn
        • class org.hibernate.loader.custom.CollectionFetchReturn
        • class org.hibernate.loader.custom.EntityFetchReturn
      • class org.hibernate.loader.custom.RootReturn
    • class org.hibernate.cache.NonstrictReadWriteCache (implements org.hibernate.cache.CacheConcurrencyStrategy)
    • class org.hibernate.property.NoopAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.criterion.NotExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.NotNullExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.engine.Nullability
    • class org.hibernate.criterion.NullExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.dialect.function.NvlFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.mapping.OneToMany (implements org.hibernate.mapping.Value)
    • class org.hibernate.cache.OptimisticTreeCache (implements org.hibernate.cache.OptimisticCache)
    • class org.hibernate.cache.OptimisticTreeCache.CircumventChecksDataVersion (implements org.jboss.cache.optimistic.DataVersion)
    • class org.hibernate.cache.OptimisticTreeCache.DataVersionAdapter (implements org.jboss.cache.optimistic.DataVersion)
    • class org.hibernate.cache.OptimisticTreeCache.NonLockingDataVersion (implements org.jboss.cache.optimistic.DataVersion)
    • class org.hibernate.cache.OptimisticTreeCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class org.hibernate.criterion.Order (implements java.io.Serializable)
    • class org.hibernate.hql.classic.OrderByParser (implements org.hibernate.hql.classic.Parser)
    • class org.hibernate.engine.query.OrdinalParameterDescriptor (implements java.io.Serializable)
    • class org.hibernate.cache.OSCache (implements org.hibernate.cache.Cache)
    • class org.hibernate.cache.OSCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class org.hibernate.loader.OuterJoinableAssociation
    • class org.hibernate.engine.ParameterBinder
    • class org.hibernate.engine.query.ParameterMetadata (implements java.io.Serializable)
    • class org.hibernate.engine.query.ParameterParser
    • class org.hibernate.hql.ast.ParameterTranslationsImpl (implements org.hibernate.hql.ParameterTranslations)
    • class org.hibernate.hql.ast.ParameterTranslationsImpl.ParameterInfo (implements java.io.Serializable)
    • class org.hibernate.engine.query.ParamLocationRecognizer (implements org.hibernate.engine.query.ParameterParser.Recognizer)
    • class org.hibernate.engine.query.ParamLocationRecognizer.NamedParameterDescription
    • class antlr.Parser
      • class antlr.LLkParser
        • class org.hibernate.hql.antlr.HqlBaseParser (implements org.hibernate.hql.antlr.HqlTokenTypes)
          • class org.hibernate.hql.ast.HqlParser
    • class org.hibernate.hql.classic.ParserHelper
    • class org.hibernate.transform.PassThroughResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.hql.classic.PathExpressionParser (implements org.hibernate.hql.classic.Parser)
      • class org.hibernate.hql.classic.FromPathExpressionParser
      • class org.hibernate.hql.classic.SelectPathExpressionParser
    • class org.hibernate.hql.ast.util.PathHelper
    • class java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • class org.hibernate.secure.HibernatePermission
    • class org.hibernate.mapping.PersistentClass (implements org.hibernate.mapping.Filterable, org.hibernate.mapping.MetaAttributable, java.io.Serializable)
      • class org.hibernate.mapping.RootClass (implements org.hibernate.mapping.TableOwner)
      • class org.hibernate.mapping.Subclass
        • class org.hibernate.mapping.JoinedSubclass (implements org.hibernate.mapping.TableOwner)
        • class org.hibernate.mapping.SingleTableSubclass
        • class org.hibernate.mapping.UnionSubclass (implements org.hibernate.mapping.TableOwner)
    • class org.hibernate.collection.PersistentIndexedElementHolder.IndexedValue
    • class org.hibernate.persister.PersisterFactory
    • class org.hibernate.tuple.PojoInstantiator (implements org.hibernate.tuple.Instantiator, java.io.Serializable)
    • class org.hibernate.dialect.function.PositionSubstringFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.event.PostDeleteEvent
    • class org.hibernate.event.PostInsertEvent
    • class org.hibernate.event.PreDeleteEvent
    • class org.hibernate.event.PreInsertEvent
    • class org.hibernate.hql.classic.PreprocessingParser (implements org.hibernate.hql.classic.Parser)
    • class org.hibernate.event.PreUpdateEvent
    • class org.hibernate.pretty.Printer
    • class org.apache.tools.ant.ProjectComponent
      • class org.apache.tools.ant.Task
        • class org.hibernate.tool.instrument.BasicInstrumentationTask
          • class org.hibernate.tool.instrument.cglib.InstrumentTask
          • class org.hibernate.tool.instrument.javassist.InstrumentTask
        • class org.apache.tools.ant.taskdefs.MatchingTask (implements org.apache.tools.ant.types.selectors.SelectorContainer)
          • class org.hibernate.tool.hbm2ddl.SchemaExportTask
          • class org.hibernate.tool.hbm2ddl.SchemaUpdateTask
          • class org.hibernate.tool.hbm2ddl.SchemaValidatorTask
    • class org.hibernate.criterion.ProjectionList (implements org.hibernate.criterion.Projection)
    • class org.hibernate.criterion.Projections
    • class org.hibernate.util.PropertiesHelper
    • class org.hibernate.mapping.Property (implements org.hibernate.mapping.MetaAttributable, java.io.Serializable)
      • class org.hibernate.mapping.Backref
      • class org.hibernate.mapping.IndexBackref
    • class org.hibernate.tuple.Property (implements java.io.Serializable)
      • class org.hibernate.tuple.IdentifierProperty
      • class org.hibernate.tuple.StandardProperty
        • class org.hibernate.tuple.VersionProperty
    • class org.hibernate.property.PropertyAccessorFactory
    • class org.hibernate.criterion.PropertyExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.tuple.PropertyFactory
    • class org.hibernate.mapping.PropertyGeneration (implements java.io.Serializable)
    • class org.hibernate.connection.ProxoolConnectionProvider (implements org.hibernate.connection.ConnectionProvider)
    • class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl (implements org.hibernate.bytecode.ProxyFactoryFactory)
    • class org.hibernate.bytecode.javassist.ProxyFactoryFactoryImpl (implements org.hibernate.bytecode.ProxyFactoryFactory)
    • class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl.BasicProxyFactoryImpl (implements org.hibernate.bytecode.BasicProxyFactory)
    • class org.hibernate.cache.QueryKey (implements java.io.Serializable)
    • class org.hibernate.engine.query.QueryMetadata (implements java.io.Serializable)
    • class org.hibernate.engine.QueryParameters
    • class org.hibernate.engine.query.QueryPlanCache (implements java.io.Serializable)
    • class org.hibernate.sql.QuerySelect
    • class org.hibernate.hql.QuerySplitter
    • class org.hibernate.hql.ast.QueryTranslatorImpl (implements org.hibernate.hql.FilterTranslator)
    • class org.hibernate.hql.ast.QueryTranslatorImpl.JavaConstantConverter (implements org.hibernate.hql.ast.util.NodeTraverser.VisitationStrategy)
    • class org.hibernate.util.Range
    • class org.hibernate.cache.ReadOnlyCache (implements org.hibernate.cache.CacheConcurrencyStrategy)
    • class org.hibernate.cache.ReadWriteCache (implements org.hibernate.cache.CacheConcurrencyStrategy)
    • class org.hibernate.cache.ReadWriteCache.Item (implements org.hibernate.cache.ReadWriteCache.Lockable, java.io.Serializable)
    • class org.hibernate.cache.ReadWriteCache.Lock (implements org.hibernate.cache.CacheConcurrencyStrategy.SoftLock, org.hibernate.cache.ReadWriteCache.Lockable, java.io.Serializable)
    • class org.hibernate.util.ReflectHelper
    • class org.hibernate.bytecode.cglib.ReflectionOptimizerImpl (implements org.hibernate.bytecode.ReflectionOptimizer, java.io.Serializable)
    • class org.hibernate.bytecode.javassist.ReflectionOptimizerImpl (implements org.hibernate.bytecode.ReflectionOptimizer, java.io.Serializable)
    • class org.hibernate.ReplicationMode (implements java.io.Serializable)
    • class org.hibernate.criterion.Restrictions
      • class org.hibernate.criterion.Expression
    • class org.hibernate.cfg.ResultSetMappingBinder
      • class org.hibernate.cfg.NamedSQLQuerySecondPass (implements org.hibernate.cfg.QuerySecondPass)
      • class org.hibernate.cfg.ResultSetMappingSecondPass (implements org.hibernate.cfg.QuerySecondPass)
    • class org.hibernate.engine.ResultSetMappingDefinition (implements java.io.Serializable)
    • class org.hibernate.jdbc.ResultSetWrapper (implements java.sql.ResultSet)
    • class org.hibernate.engine.query.ReturnMetadata (implements java.io.Serializable)
    • class org.hibernate.transform.RootEntityResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.engine.RowSelection
    • class org.hibernate.loader.custom.ScalarReturn (implements org.hibernate.loader.custom.Return)
    • class org.hibernate.tool.hbm2ddl.SchemaExport
    • class org.hibernate.tool.hbm2ddl.SchemaUpdate
    • class org.hibernate.tool.hbm2ddl.SchemaValidator
    • class org.hibernate.ScrollMode (implements java.io.Serializable)
    • class org.hibernate.sql.Select
    • class org.hibernate.sql.SelectFragment
    • class org.hibernate.dialect.lock.SelectLockingStrategy (implements org.hibernate.dialect.lock.LockingStrategy)
      • class org.hibernate.dialect.HSQLDialect.ReadUncommittedLockingStrategy
    • class org.hibernate.hql.classic.SelectParser (implements org.hibernate.hql.classic.Parser)
    • class org.hibernate.id.SequenceGenerator (implements org.hibernate.id.Configurable, org.hibernate.id.PersistentIdentifierGenerator)
      • class org.hibernate.id.SequenceHiLoGenerator
      • class org.hibernate.id.SequenceIdentityGenerator (implements org.hibernate.id.PostInsertIdentifierGenerator)
    • class org.hibernate.lob.SerializableBlob (implements java.sql.Blob, java.io.Serializable)
    • class org.hibernate.lob.SerializableClob (implements java.sql.Clob, java.io.Serializable)
    • class org.hibernate.proxy.pojo.cglib.SerializableProxy (implements java.io.Serializable)
    • class org.hibernate.proxy.pojo.javassist.SerializableProxy (implements java.io.Serializable)
    • class org.hibernate.util.SerializationHelper
    • class org.hibernate.hql.ast.util.SessionFactoryHelper
    • class org.hibernate.impl.SessionFactoryImpl (implements org.hibernate.SessionFactory, org.hibernate.engine.SessionFactoryImplementor)
    • class org.hibernate.impl.SessionFactoryObjectFactory (implements javax.naming.spi.ObjectFactory)
    • class org.hibernate.jmx.SessionFactoryStub (implements org.hibernate.SessionFactory)
    • class org.hibernate.stat.SessionStatisticsImpl (implements org.hibernate.stat.SessionStatistics)
    • class org.hibernate.cfg.Settings
    • class org.hibernate.cfg.SettingsFactory (implements java.io.Serializable)
    • class org.hibernate.criterion.SimpleExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.util.SimpleMRUCache (implements java.io.Serializable)
    • class org.hibernate.criterion.SimpleProjection (implements org.hibernate.criterion.Projection)
      • class org.hibernate.criterion.AggregateProjection
        • class org.hibernate.criterion.AvgProjection
        • class org.hibernate.criterion.CountProjection
      • class org.hibernate.criterion.IdentifierProjection
      • class org.hibernate.criterion.PropertyProjection
        • class org.hibernate.criterion.Property
      • class org.hibernate.criterion.RowCountProjection
    • class org.hibernate.sql.SimpleSelect
    • class org.hibernate.mapping.SimpleValue (implements org.hibernate.mapping.KeyValue)
      • class org.hibernate.mapping.Any
      • class org.hibernate.mapping.Component (implements org.hibernate.mapping.MetaAttributable)
      • class org.hibernate.mapping.DependantValue
      • class org.hibernate.mapping.ToOne (implements org.hibernate.mapping.Fetchable)
        • class org.hibernate.mapping.ManyToOne
        • class org.hibernate.mapping.OneToOne
    • class org.hibernate.util.SingletonIterator (implements java.util.Iterator)
    • class org.hibernate.criterion.SizeExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.util.SoftLimitMRUCache (implements java.io.Serializable)
    • class org.hibernate.criterion.SQLCriterion (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.loader.custom.sql.SQLCustomQuery (implements org.hibernate.loader.custom.CustomQuery)
    • class org.hibernate.exception.SQLExceptionConverterFactory
    • class org.hibernate.dialect.function.SQLFunctionRegistry
    • class org.hibernate.dialect.function.SQLFunctionTemplate (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.criterion.SQLProjection (implements org.hibernate.criterion.Projection)
    • class org.hibernate.loader.custom.sql.SQLQueryParser
    • class org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer (implements org.hibernate.engine.query.ParameterParser.Recognizer)
    • class org.hibernate.loader.custom.sql.SQLQueryReturnProcessor
    • class org.hibernate.exception.SQLStateConverter (implements org.hibernate.exception.SQLExceptionConverter)
    • class org.hibernate.cache.StandardQueryCache (implements org.hibernate.cache.QueryCache)
    • class org.hibernate.cache.StandardQueryCacheFactory (implements org.hibernate.cache.QueryCacheFactory)
    • class org.hibernate.dialect.function.StandardSQLFunction (implements org.hibernate.dialect.function.SQLFunction)
      • class org.hibernate.dialect.function.ClassicAvgFunction
      • class org.hibernate.dialect.function.ClassicCountFunction
      • class org.hibernate.dialect.function.ClassicSumFunction
    • class org.hibernate.engine.StatefulPersistenceContext (implements org.hibernate.engine.PersistenceContext)
    • class org.hibernate.stat.StatisticsImpl (implements org.hibernate.stat.Statistics, org.hibernate.stat.StatisticsImplementor)
    • class org.hibernate.jmx.StatisticsService (implements org.hibernate.jmx.StatisticsServiceMBean)
    • class org.hibernate.engine.Status (implements java.io.Serializable)
    • class org.hibernate.util.StringHelper
    • class org.hibernate.cache.entry.StructuredCacheEntry (implements org.hibernate.cache.entry.CacheEntryStructure)
    • class org.hibernate.cache.entry.StructuredCollectionCacheEntry (implements org.hibernate.cache.entry.CacheEntryStructure)
    • class org.hibernate.cache.entry.StructuredMapCacheEntry (implements org.hibernate.cache.entry.CacheEntryStructure)
    • class org.hibernate.criterion.Subqueries
    • class org.hibernate.criterion.SubqueryExpression (implements org.hibernate.criterion.Criterion)
      • class org.hibernate.criterion.ExistsSubqueryExpression
      • class org.hibernate.criterion.PropertySubqueryExpression
      • class org.hibernate.criterion.SimpleSubqueryExpression
    • class org.hibernate.engine.SubselectFetch
    • class org.hibernate.cache.SwarmCache (implements org.hibernate.cache.Cache)
    • class org.hibernate.cache.SwarmCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class org.hibernate.hql.ast.util.SyntheticAndFactory (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)
    • class org.hibernate.mapping.Table (implements org.hibernate.mapping.RelationalModel, java.io.Serializable)
      • class org.hibernate.mapping.DenormalizedTable
    • class org.hibernate.tool.hbm2ddl.TableMetadata
    • class org.hibernate.sql.Template
    • class org.hibernate.exception.TemplatedViolatedConstraintNameExtracter (implements org.hibernate.exception.ViolatedConstraintNameExtracter)
    • class org.hibernate.context.ThreadLocalSessionContext (implements org.hibernate.context.CurrentSessionContext)
    • class org.hibernate.context.ThreadLocalSessionContext.CleanupSynch (implements java.io.Serializable, javax.transaction.Synchronization)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class antlr.ANTLRException
          • class antlr.RecognitionException
            • class antlr.SemanticException
              • class org.hibernate.hql.ast.DetailedSemanticException
              • class org.hibernate.hql.ast.InvalidPathException
        • class org.hibernate.exception.NestableException (implements org.hibernate.exception.Nestable)
        • class java.lang.RuntimeException
          • class org.hibernate.bytecode.javassist.BulkAccessorException
          • class org.hibernate.exception.NestableRuntimeException (implements org.hibernate.exception.Nestable)
            • class org.hibernate.AssertionFailure
            • class org.hibernate.HibernateException
              • class org.hibernate.jdbc.BatchFailedException
              • class org.hibernate.cache.CacheException
                • class org.hibernate.cache.NoCachingEnabledException
              • class org.hibernate.CallbackException
              • class org.hibernate.id.IdentifierGenerationException
              • class org.hibernate.InstantiationException
              • class org.hibernate.JDBCException
                • class org.hibernate.exception.ConstraintViolationException
                • class org.hibernate.exception.DataException
                • class org.hibernate.exception.GenericJDBCException
                • class org.hibernate.exception.JDBCConnectionException
                • class org.hibernate.exception.LockAcquisitionException
                • class org.hibernate.exception.SQLGrammarException
              • class org.hibernate.LazyInitializationException
              • class org.hibernate.MappingException
                • class org.hibernate.DuplicateMappingException
                • class org.hibernate.InvalidMappingException
                • class org.hibernate.MappingNotFoundException
                • class org.hibernate.PropertyNotFoundException
              • class org.hibernate.NonUniqueObjectException
              • class org.hibernate.NonUniqueResultException
              • class org.hibernate.PersistentObjectException
              • class org.hibernate.PropertyAccessException
              • class org.hibernate.PropertyValueException
              • class org.hibernate.QueryException
                • class org.hibernate.hql.QueryExecutionRequestException
                • class org.hibernate.QueryParameterException
                • class org.hibernate.hql.ast.QuerySyntaxException
              • class org.hibernate.type.SerializationException
              • class org.hibernate.SessionException
              • class org.hibernate.StaleStateException
                • class org.hibernate.StaleObjectStateException
              • class org.hibernate.jdbc.TooManyRowsAffectedException
                • class org.hibernate.jdbc.BatchedTooManyRowsAffectedException
              • class org.hibernate.TransactionException
              • class org.hibernate.TransientObjectException
              • class org.hibernate.TypeMismatchException
              • class org.hibernate.UnresolvableObjectException
                • class org.hibernate.ObjectDeletedException
                • class org.hibernate.ObjectNotFoundException
              • class org.hibernate.classic.ValidationFailure
              • class org.hibernate.WrongClassException
    • class org.hibernate.cache.Timestamper
    • class antlr.Token (implements java.lang.Cloneable)
      • class antlr.CommonToken
        • class org.hibernate.hql.ast.HqlToken
    • class org.hibernate.transform.ToListResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.cache.TransactionalCache (implements org.hibernate.cache.CacheConcurrencyStrategy)
    • class org.hibernate.transaction.TransactionFactoryFactory
    • class org.hibernate.engine.TransactionHelper
      • class org.hibernate.id.MultipleHiLoPerTableGenerator (implements org.hibernate.id.Configurable, org.hibernate.id.PersistentIdentifierGenerator)
      • class org.hibernate.id.TableGenerator (implements org.hibernate.id.Configurable, org.hibernate.id.PersistentIdentifierGenerator)
        • class org.hibernate.id.TableHiLoGenerator
    • class org.hibernate.transaction.TransactionManagerLookupFactory
    • class org.hibernate.transform.Transformers
    • class org.hibernate.cache.TreeCache (implements org.hibernate.cache.Cache)
    • class org.hibernate.cache.TreeCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class antlr.TreeParser
      • class org.hibernate.hql.antlr.HqlSqlBaseWalker (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)
        • class org.hibernate.hql.ast.HqlSqlWalker (implements org.hibernate.hql.ast.ErrorReporter, org.hibernate.engine.ParameterBinder.NamedParameterSource)
      • class org.hibernate.hql.antlr.SqlGeneratorBase (implements org.hibernate.hql.antlr.SqlTokenTypes)
        • class org.hibernate.hql.ast.SqlGenerator (implements org.hibernate.hql.ast.ErrorReporter)
    • class org.hibernate.engine.TwoPhaseLoad
    • class org.hibernate.mapping.TypeDef (implements java.io.Serializable)
    • class org.hibernate.engine.TypedValue (implements java.io.Serializable)
    • class org.hibernate.type.TypeFactory
    • class org.hibernate.dialect.TypeNames
    • class org.hibernate.engine.UnsavedValueFactory
    • class org.hibernate.cache.entry.UnstructuredCacheEntry (implements org.hibernate.cache.entry.CacheEntryStructure)
    • class org.hibernate.sql.Update
    • class org.hibernate.dialect.lock.UpdateLockingStrategy (implements org.hibernate.dialect.lock.LockingStrategy)
    • class org.hibernate.cache.UpdateTimestampsCache
    • class org.hibernate.connection.UserSuppliedConnectionProvider (implements org.hibernate.connection.ConnectionProvider)
    • class org.hibernate.dialect.function.VarArgsSQLFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.engine.Versioning
    • class org.hibernate.param.VersionTypeSeedParameterSpecification (implements org.hibernate.param.ParameterSpecification)
    • class org.hibernate.engine.VersionValue
    • class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup (implements org.hibernate.transaction.TransactionManagerLookup)
    • class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter (implements javax.transaction.TransactionManager)
    • class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter (implements javax.transaction.Transaction)
    • class org.hibernate.transaction.WebSphereTransactionManagerLookup (implements org.hibernate.transaction.TransactionManagerLookup)
    • class org.hibernate.hql.classic.WhereParser (implements org.hibernate.hql.classic.Parser)
      • class org.hibernate.hql.classic.HavingParser
    • class org.hibernate.util.XMLHelper
    • class org.hibernate.util.XMLHelper.ErrorLogger (implements org.xml.sax.ErrorHandler)

Interface Hierarchy

  • interface org.hibernate.collection.AbstractPersistentCollection.DelayedOperation
  • interface org.hibernate.hql.ast.util.ASTUtil.FilterPredicate
  • interface org.hibernate.bytecode.BasicProxyFactory
  • interface org.hibernate.jdbc.Batcher
  • interface org.hibernate.jdbc.BatcherFactory
  • interface org.hibernate.id.insert.Binder
  • interface org.hibernate.bytecode.BytecodeProvider
  • interface org.hibernate.cache.Cache
    • interface org.hibernate.cache.OptimisticCache
  • interface org.hibernate.cache.CacheConcurrencyStrategy
  • interface org.hibernate.cache.CacheConcurrencyStrategy.SoftLock
  • interface org.hibernate.cache.entry.CacheEntryStructure
  • interface org.hibernate.cache.CacheProvider
  • interface org.hibernate.bytecode.util.ClassDescriptor
  • interface org.hibernate.bytecode.util.ClassFilter
  • interface org.hibernate.metadata.ClassMetadata
  • interface org.hibernate.bytecode.ClassTransformer
  • interface org.hibernate.loader.CollectionAliases
  • interface org.hibernate.loader.collection.CollectionInitializer
  • interface org.hibernate.metadata.CollectionMetadata
  • interface org.hibernate.persister.collection.CollectionPersister
    • interface org.hibernate.persister.collection.QueryableCollection (also extends org.hibernate.persister.entity.Joinable, org.hibernate.persister.entity.PropertyMapping)
      • interface org.hibernate.persister.collection.SQLLoadableCollection
    • interface org.hibernate.persister.collection.SQLLoadableCollection
  • interface java.util.Comparator
    • interface org.hibernate.usertype.UserVersionType (also extends org.hibernate.usertype.UserType)
  • interface org.hibernate.usertype.CompositeUserType
  • interface org.hibernate.exception.Configurable
  • interface org.hibernate.id.Configurable
  • interface org.hibernate.jdbc.ConnectionManager.Callback
  • interface org.hibernate.connection.ConnectionProvider
  • interface org.hibernate.criterion.CriteriaQuery
  • interface org.hibernate.criterion.CriteriaSpecification
    • interface org.hibernate.Criteria
  • interface org.hibernate.loader.custom.CustomQuery
  • interface org.hibernate.dialect.DialectFactory.DatabaseDialectMapper
  • interface org.hibernate.hql.ast.tree.DisplayableNode
  • interface org.hibernate.loader.EntityAliases
  • interface org.hibernate.proxy.EntityNotFoundDelegate
  • interface org.hibernate.hql.ast.ErrorReporter
    • interface org.hibernate.hql.ast.ParseErrorHandler
  • interface org.hibernate.action.Executable
  • interface org.hibernate.jdbc.Expectation
  • interface org.hibernate.hql.ast.tree.ExpectedTypeAwareNode
  • interface org.hibernate.mapping.Fetchable
  • interface org.hibernate.bytecode.javassist.FieldFilter
  • interface org.hibernate.bytecode.util.FieldFilter
  • interface org.hibernate.bytecode.javassist.FieldHandled
  • interface org.hibernate.bytecode.javassist.FieldHandler
  • interface org.hibernate.intercept.FieldInterceptor
  • interface org.hibernate.Filter
  • interface org.hibernate.mapping.Filterable
  • interface org.hibernate.jmx.HibernateServiceMBean
  • interface org.hibernate.hql.antlr.HqlSqlTokenTypes
  • interface org.hibernate.hql.antlr.HqlTokenTypes
  • interface org.hibernate.id.IdentifierGenerator
    • interface org.hibernate.id.PersistentIdentifierGenerator
    • interface org.hibernate.id.PostInsertIdentifierGenerator
  • interface org.hibernate.event.Initializable
  • interface org.hibernate.hql.ast.tree.InitializeableNode
  • interface org.hibernate.id.insert.InsertGeneratedIdentifierDelegate
  • interface org.hibernate.Interceptor
  • interface org.hibernate.engine.transaction.IsolatedWork
  • interface java.util.Iterator
    • interface org.hibernate.engine.HibernateIterator
  • interface org.hibernate.secure.JACCSecurityListener
  • interface org.hibernate.persister.entity.Joinable
    • interface org.hibernate.persister.entity.OuterJoinLoadable (also extends org.hibernate.persister.entity.Loadable)
    • interface org.hibernate.persister.entity.Queryable (also extends org.hibernate.persister.entity.Loadable, org.hibernate.persister.entity.PropertyMapping)
    • interface org.hibernate.persister.collection.QueryableCollection (also extends org.hibernate.persister.collection.CollectionPersister, org.hibernate.persister.entity.PropertyMapping)
      • interface org.hibernate.persister.collection.SQLLoadableCollection
    • interface org.hibernate.persister.collection.SQLLoadableCollection
  • interface org.hibernate.engine.JoinSequence.Selector
  • interface org.hibernate.proxy.LazyInitializer
  • interface org.hibernate.intercept.LazyPropertyInitializer
  • interface org.hibernate.classic.Lifecycle
  • interface org.hibernate.type.LiteralType
    • interface org.hibernate.type.DiscriminatorType (also extends org.hibernate.type.IdentifierType)
  • interface org.hibernate.dialect.lock.LockingStrategy
  • interface org.hibernate.usertype.LoggableUserType
  • interface org.hibernate.engine.Mapping
    • interface org.hibernate.engine.SessionFactoryImplementor (also extends org.hibernate.SessionFactory)
  • interface org.hibernate.mapping.MetaAttributable
  • interface org.hibernate.cfg.NamingStrategy
  • interface org.hibernate.engine.query.sql.NativeSQLQueryReturn
  • interface org.hibernate.exception.Nestable
  • interface org.hibernate.hql.ast.util.NodeTraverser.VisitationStrategy
  • interface org.hibernate.hql.ast.tree.OperatorNode
    • interface org.hibernate.hql.ast.tree.BinaryOperatorNode
    • interface org.hibernate.hql.ast.tree.UnaryOperatorNode
  • interface org.hibernate.cache.OptimisticCacheSource
    • interface org.hibernate.persister.entity.EntityPersister
      • interface org.hibernate.persister.entity.Loadable
        • interface org.hibernate.persister.entity.OuterJoinLoadable (also extends org.hibernate.persister.entity.Joinable)
        • interface org.hibernate.persister.entity.Queryable (also extends org.hibernate.persister.entity.Joinable, org.hibernate.persister.entity.PropertyMapping)
        • interface org.hibernate.persister.entity.SQLLoadable
        • interface org.hibernate.persister.entity.UniqueKeyLoadable
      • interface org.hibernate.persister.entity.Lockable
      • interface org.hibernate.persister.entity.OuterJoinLoadable (also extends org.hibernate.persister.entity.Joinable, org.hibernate.persister.entity.Loadable)
      • interface org.hibernate.id.PostInsertIdentityPersister
      • interface org.hibernate.persister.entity.Queryable (also extends org.hibernate.persister.entity.Joinable, org.hibernate.persister.entity.Loadable, org.hibernate.persister.entity.PropertyMapping)
      • interface org.hibernate.persister.entity.SQLLoadable
      • interface org.hibernate.persister.entity.UniqueKeyLoadable
    • interface org.hibernate.persister.entity.Loadable
      • interface org.hibernate.persister.entity.OuterJoinLoadable (also extends org.hibernate.persister.entity.Joinable)
      • interface org.hibernate.persister.entity.Queryable (also extends org.hibernate.persister.entity.Joinable, org.hibernate.persister.entity.PropertyMapping)
      • interface org.hibernate.persister.entity.SQLLoadable
      • interface org.hibernate.persister.entity.UniqueKeyLoadable
    • interface org.hibernate.persister.entity.Lockable
    • interface org.hibernate.persister.entity.OuterJoinLoadable (also extends org.hibernate.persister.entity.Joinable, org.hibernate.persister.entity.Loadable)
    • interface org.hibernate.id.PostInsertIdentityPersister
    • interface org.hibernate.persister.entity.Queryable (also extends org.hibernate.persister.entity.Joinable, org.hibernate.persister.entity.Loadable, org.hibernate.persister.entity.PropertyMapping)
    • interface org.hibernate.persister.entity.SQLLoadable
    • interface org.hibernate.persister.entity.UniqueKeyLoadable
  • interface org.hibernate.engine.ParameterBinder.NamedParameterSource
  • interface org.hibernate.usertype.ParameterizedType
  • interface org.hibernate.engine.query.ParameterParser.Recognizer
  • interface org.hibernate.param.ParameterSpecification
    • interface org.hibernate.param.ExplicitParameterSpecification
  • interface org.hibernate.hql.ParameterTranslations
  • interface org.hibernate.hql.classic.Parser
  • interface org.hibernate.hql.ast.tree.PathNode
  • interface org.hibernate.engine.PersistenceContext
  • interface org.hibernate.mapping.PersistentClassVisitor
  • interface org.hibernate.collection.PersistentCollection
  • interface org.hibernate.property.PropertyAccessor
  • interface org.hibernate.persister.entity.PropertyMapping
    • interface org.hibernate.persister.entity.Queryable (also extends org.hibernate.persister.entity.Joinable, org.hibernate.persister.entity.Loadable)
    • interface org.hibernate.persister.collection.QueryableCollection (also extends org.hibernate.persister.collection.CollectionPersister, org.hibernate.persister.entity.Joinable)
      • interface org.hibernate.persister.collection.SQLLoadableCollection
    • interface org.hibernate.persister.collection.SQLLoadableCollection
  • interface org.hibernate.proxy.ProxyFactory
  • interface org.hibernate.bytecode.ProxyFactoryFactory
  • interface org.hibernate.Query
    • interface org.hibernate.SQLQuery
  • interface org.hibernate.cache.QueryCache
  • interface org.hibernate.cache.QueryCacheFactory
  • interface org.hibernate.hql.QueryTranslator
    • interface org.hibernate.hql.FilterTranslator
  • interface org.hibernate.hql.QueryTranslatorFactory
  • interface org.hibernate.cache.ReadWriteCache.Lockable
  • interface javax.naming.Referenceable
    • interface org.hibernate.SessionFactory (also extends java.io.Serializable)
      • interface org.hibernate.engine.SessionFactoryImplementor (also extends org.hibernate.engine.Mapping)
    • interface org.hibernate.engine.SessionFactoryImplementor (also extends org.hibernate.engine.Mapping, org.hibernate.SessionFactory)
  • interface org.hibernate.bytecode.ReflectionOptimizer
  • interface org.hibernate.bytecode.ReflectionOptimizer.AccessOptimizer
  • interface org.hibernate.bytecode.ReflectionOptimizer.InstantiationOptimizer
  • interface org.hibernate.mapping.RelationalModel
    • interface org.hibernate.mapping.AuxiliaryDatabaseObject (also extends java.io.Serializable)
  • interface org.hibernate.hql.ast.tree.ResolvableNode
  • interface org.hibernate.loader.custom.Return
  • interface org.hibernate.ScrollableResults
  • interface org.hibernate.mapping.Selectable
  • interface org.hibernate.hql.ast.tree.SelectExpression
  • interface java.io.Serializable
    • interface org.hibernate.type.AbstractComponentType
    • interface org.hibernate.type.AssociationType
    • interface org.hibernate.event.AutoFlushEventListener
    • interface org.hibernate.mapping.AuxiliaryDatabaseObject (also extends org.hibernate.mapping.RelationalModel)
    • interface org.hibernate.tuple.component.ComponentTuplizer (also extends org.hibernate.tuple.Tuplizer)
    • interface org.hibernate.criterion.Criterion
    • interface org.hibernate.context.CurrentSessionContext
    • interface org.hibernate.event.DeleteEventListener
    • interface org.hibernate.event.DirtyCheckEventListener
    • interface org.hibernate.type.DiscriminatorType (also extends org.hibernate.type.IdentifierType, org.hibernate.type.LiteralType)
    • interface org.hibernate.event.EventSource (also extends org.hibernate.Session, org.hibernate.engine.SessionImplementor)
    • interface org.hibernate.event.EvictEventListener
    • interface org.hibernate.criterion.Example.PropertySelector
    • interface org.hibernate.event.FlushEntityEventListener
    • interface org.hibernate.event.FlushEventListener
    • interface org.hibernate.property.Getter
    • interface org.hibernate.proxy.HibernateProxy
    • interface org.hibernate.type.IdentifierType
      • interface org.hibernate.type.DiscriminatorType (also extends org.hibernate.type.LiteralType)
    • interface org.hibernate.event.InitializeCollectionEventListener
    • interface org.hibernate.tuple.Instantiator
    • interface org.hibernate.mapping.KeyValue
    • interface org.hibernate.event.LoadEventListener
    • interface org.hibernate.event.LockEventListener
    • interface org.hibernate.event.MergeEventListener
    • interface org.hibernate.event.PersistEventListener
    • interface org.hibernate.event.PostDeleteEventListener
    • interface org.hibernate.event.PostInsertEventListener
    • interface org.hibernate.event.PostLoadEventListener
    • interface org.hibernate.event.PostUpdateEventListener
    • interface org.hibernate.event.PreDeleteEventListener
    • interface org.hibernate.event.PreInsertEventListener
    • interface org.hibernate.event.PreLoadEventListener
    • interface org.hibernate.event.PreUpdateEventListener
    • interface org.hibernate.criterion.Projection
    • interface org.hibernate.cfg.QuerySecondPass
    • interface org.hibernate.event.RefreshEventListener
    • interface org.hibernate.event.ReplicateEventListener
    • interface org.hibernate.transform.ResultTransformer
    • interface org.hibernate.event.SaveOrUpdateEventListener
    • interface org.hibernate.cfg.SecondPass
      • interface org.hibernate.cfg.QuerySecondPass
    • interface org.hibernate.Session
      • interface org.hibernate.event.EventSource (also extends org.hibernate.engine.SessionImplementor)
      • interface org.hibernate.classic.Session
    • interface org.hibernate.classic.Session
    • interface org.hibernate.SessionFactory (also extends javax.naming.Referenceable)
      • interface org.hibernate.engine.SessionFactoryImplementor (also extends org.hibernate.engine.Mapping)
    • interface org.hibernate.engine.SessionFactoryImplementor (also extends org.hibernate.engine.Mapping, org.hibernate.SessionFactory)
    • interface org.hibernate.engine.SessionImplementor
      • interface org.hibernate.event.EventSource (also extends org.hibernate.Session)
    • interface org.hibernate.property.Setter
    • interface org.hibernate.StatelessSession
    • interface org.hibernate.type.Type
      • interface org.hibernate.type.AbstractComponentType
      • interface org.hibernate.type.AssociationType
      • interface org.hibernate.type.DiscriminatorType (also extends org.hibernate.type.IdentifierType, org.hibernate.type.LiteralType)
      • interface org.hibernate.type.IdentifierType
        • interface org.hibernate.type.DiscriminatorType (also extends org.hibernate.type.LiteralType)
      • interface org.hibernate.type.VersionType
    • interface org.hibernate.mapping.Value
      • interface org.hibernate.mapping.KeyValue
    • interface org.hibernate.type.VersionType
  • interface org.hibernate.hql.ast.tree.SessionFactoryAwareNode
  • interface org.hibernate.stat.SessionStatistics
  • interface org.hibernate.exception.SQLExceptionConverter
  • interface org.hibernate.dialect.function.SQLFunction
  • interface org.hibernate.hql.antlr.SqlTokenTypes
  • interface org.hibernate.hql.ast.tree.Statement
    • interface org.hibernate.hql.ast.tree.RestrictableStatement
  • interface org.hibernate.hql.ast.exec.StatementExecutor
  • interface org.hibernate.stat.Statistics
    • interface org.hibernate.jmx.StatisticsServiceMBean
  • interface org.hibernate.stat.StatisticsImplementor
  • interface org.hibernate.mapping.TableOwner
  • interface org.hibernate.Transaction
  • interface org.hibernate.transaction.TransactionFactory
  • interface org.hibernate.transaction.TransactionFactory.Context
    • interface org.hibernate.jdbc.JDBCContext.Context
  • interface org.hibernate.transaction.TransactionManagerLookup
  • interface org.hibernate.tuple.Tuplizer
    • interface org.hibernate.tuple.component.ComponentTuplizer (also extends java.io.Serializable)
    • interface org.hibernate.tuple.entity.EntityTuplizer
  • interface org.hibernate.loader.entity.UniqueEntityLoader
  • interface org.hibernate.usertype.UserCollectionType
  • interface org.hibernate.usertype.UserType
    • interface org.hibernate.usertype.EnhancedUserType
    • interface org.hibernate.usertype.UserVersionType (also extends java.util.Comparator)
  • interface org.hibernate.classic.Validatable
  • interface org.hibernate.mapping.ValueVisitor
  • interface org.hibernate.exception.ViolatedConstraintNameExtracter
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate

This package defines the central Hibernate APIs.

See:
Description

Interface Summary
Criteria | Criteria is a simplified API for retrieving entities by composing Criterion objects.
Filter | Type definition of Filter.
Interceptor | Allows user code to inspect and/or change property values.
Query | An object-oriented representation of a Hibernate query.
ScrollableResults | A result iterator that allows moving around within the results by arbitrary increments.
Session | The main runtime interface between a Java application and Hibernate.
SessionFactory | Creates Sessions.
SQLQuery | Allows the user to declare the types and select list injection points of all entities returned by the query.
StatelessSession | A command-oriented API for performing bulk operations against a database. A stateless session does not implement a first-level cache nor interact with any second-level cache, nor does it implement transactional write-behind or automatic dirty checking, nor do operations cascade to associated instances.
Transaction | Allows the application to define units of work, while maintaining abstraction from the underlying transaction implementation (eg.

Class Summary
CacheMode | Controls how the session interacts with the second-level cache and query cache.
ConnectionReleaseMode | Defines the various policies by which Hibernate might release its underlying JDBC connection.
EmptyInterceptor | An interceptor that does nothing.
EntityMode | Defines the representation modes available for entities.
FetchMode | Represents an association fetching strategy.
FlushMode | Represents a flushing strategy.
Hibernate | Provides access to the full range of Hibernate built-in types.
LockMode | Instances represent a lock mode for a row of a relational database table.
ReplicationMode | Represents a replication strategy.
ScrollMode | Specifies the type of JDBC scrollable result set to use underneath a ScrollableResults

Exception Summary
AssertionFailure | Indicates failure of an assertion: a possible bug in Hibernate.
CallbackException | Should be thrown by persistent objects from Lifecycle or Interceptor callbacks.
DuplicateMappingException | Raised whenever a duplicate for a certain type occurs.
HibernateException | Any exception that occurs inside the persistence layer or JDBC driver.
InstantiationException | Thrown if Hibernate can't instantiate an entity or component class at runtime.
InvalidMappingException | Thrown when a mapping is found to be invalid.
JDBCException | Wraps an SQLException.
LazyInitializationException | Indicates access to unfetched data outside of a session context.
MappingException | An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
MappingNotFoundException | Thrown when a resource for a mapping could not be found.
NonUniqueObjectException | This exception is thrown when an operation would break session-scoped identity.
NonUniqueResultException | Thrown when the application calls Query.uniqueResult() and the query returned more than one result.
ObjectDeletedException | Thrown when the user tries to do something illegal with a deleted object.
ObjectNotFoundException | Thrown when Session.load() fails to select a row with the given primary key (identifier value).
PersistentObjectException | Thrown when the user passes a persistent instance to a Session method that expects a transient instance.
PropertyAccessException | A problem occurred accessing a property of an instance of a persistent class by reflection, or via CGLIB.
PropertyNotFoundException | Indicates that an expected getter or setter method could not be found on a class.
PropertyValueException | Thrown when the (illegal) value of a property can not be persisted.
QueryException | A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
QueryParameterException | Parameter invalid or not found in the query
SessionException | Thrown when the user calls a method of a Session that is in an inappropropriate state for the given call (for example, the the session is closed or disconnected).
StaleObjectStateException | A StaleStateException that carries information about a particular entity instance that was the source of the failure.
StaleStateException | Thrown when a version number or timestamp check failed, indicating that the Session contained stale data (when using long transactions with versioning).
TransactionException | Indicates that a transaction could not be begun, committed or rolled back.
TransientObjectException | Thrown when the user passes a transient instance to a Session method that expects a persistent instance.
TypeMismatchException | Used when a user provided type does not match the expected one
UnresolvableObjectException | Thrown when Hibernate could not resolve an object by id, especially when loading an association.
WrongClassException | Thrown when Session.load() selects a row with the given primary key (identifier value) but the row's discriminator value specifies a subclass that is not assignable to the class requested by the user.

Package org.hibernate Description

This package defines the central Hibernate APIs.

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


org.hibernate Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.CacheMode (implements java.io.Serializable)
    • class org.hibernate.ConnectionReleaseMode (implements java.io.Serializable)
    • class org.hibernate.EmptyInterceptor (implements org.hibernate.Interceptor, java.io.Serializable)
    • class org.hibernate.EntityMode (implements java.io.Serializable)
    • class org.hibernate.FetchMode (implements java.io.Serializable)
    • class org.hibernate.FlushMode (implements java.io.Serializable)
    • class org.hibernate.Hibernate
    • class org.hibernate.LockMode (implements java.io.Serializable)
    • class org.hibernate.ReplicationMode (implements java.io.Serializable)
    • class org.hibernate.ScrollMode (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class org.hibernate.exception.NestableRuntimeException (implements org.hibernate.exception.Nestable)
            • class org.hibernate.AssertionFailure
            • class org.hibernate.HibernateException
              • class org.hibernate.CallbackException
              • class org.hibernate.InstantiationException
              • class org.hibernate.JDBCException
              • class org.hibernate.LazyInitializationException
              • class org.hibernate.MappingException
                • class org.hibernate.DuplicateMappingException
                • class org.hibernate.InvalidMappingException
                • class org.hibernate.MappingNotFoundException
                • class org.hibernate.PropertyNotFoundException
              • class org.hibernate.NonUniqueObjectException
              • class org.hibernate.NonUniqueResultException
              • class org.hibernate.PersistentObjectException
              • class org.hibernate.PropertyAccessException
              • class org.hibernate.PropertyValueException
              • class org.hibernate.QueryException
                • class org.hibernate.QueryParameterException
              • class org.hibernate.SessionException
              • class org.hibernate.StaleStateException
                • class org.hibernate.StaleObjectStateException
              • class org.hibernate.TransactionException
              • class org.hibernate.TransientObjectException
              • class org.hibernate.TypeMismatchException
              • class org.hibernate.UnresolvableObjectException
                • class org.hibernate.ObjectDeletedException
                • class org.hibernate.ObjectNotFoundException
              • class org.hibernate.WrongClassException

Interface Hierarchy

  • interface org.hibernate.criterion.CriteriaSpecification
    • interface org.hibernate.Criteria
  • interface org.hibernate.Filter
  • interface org.hibernate.Interceptor
  • interface org.hibernate.Query
    • interface org.hibernate.SQLQuery
  • interface javax.naming.Referenceable
    • interface org.hibernate.SessionFactory (also extends java.io.Serializable)
  • interface org.hibernate.ScrollableResults
  • interface java.io.Serializable
    • interface org.hibernate.Session
    • interface org.hibernate.SessionFactory (also extends javax.naming.Referenceable)
    • interface org.hibernate.StatelessSession
  • interface org.hibernate.Transaction
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package org.hibernate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate

Packages that use org.hibernate
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.classic | This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.connection | This package abstracts the mechanism for obtaining a JDBC connection.
org.hibernate.context |
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function | A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.dialect.lock |
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.engine.query.sql |
org.hibernate.engine.transaction |
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.exception | This package is a fork of Apache commons-lang nestable exceptions.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.exec |
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.intercept | This package implements an interception mechanism for lazy property fetching, based on CGLIB bytecode instrumentation.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.custom.sql |
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.metadata | This package defines an API for accessing the Hibernate runtime metamodel.
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.pretty | Classes for pretty printing things for exception and log messages.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.proxy | This package defines a framework for lazy-initializing entity proxies.
org.hibernate.proxy.dom4j |
org.hibernate.proxy.map |
org.hibernate.proxy.pojo.cglib |
org.hibernate.proxy.pojo.javassist |
org.hibernate.secure | Declarative security for CRUD operations on entities.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.
org.hibernate.tool.hbm2ddl | The hbm2ddl tool.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.usertype | Interfaces for user-defined custom types.
org.hibernate.util | Utility classes.

Classes in org.hibernate used by org.hibernate
CacheMode
Controls how the session interacts with the second-level cache and query cache.
CallbackException
Should be thrown by persistent objects from Lifecycle or Interceptor callbacks.
ConnectionReleaseMode
Defines the various policies by which Hibernate might release its underlying JDBC connection.
Criteria
Criteria is a simplified API for retrieving entities by composing Criterion objects.
EntityMode
Defines the representation modes available for entities.
FetchMode
Represents an association fetching strategy.
Filter
Type definition of Filter.
FlushMode
Represents a flushing strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
Interceptor
Allows user code to inspect and/or change property values.
LockMode
Instances represent a lock mode for a row of a relational database table.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
Query
An object-oriented representation of a Hibernate query.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
ReplicationMode
Represents a replication strategy.
ScrollableResults
A result iterator that allows moving around within the results by arbitrary increments.
ScrollMode
Specifies the type of JDBC scrollable result set to use underneath a ScrollableResults
SessionFactory
Creates Sessions.
SQLQuery
Allows the user to declare the types and select list injection points of all entities returned by the query.
StaleStateException
Thrown when a version number or timestamp check failed, indicating that the Session contained stale data (when using long transactions with versioning).
StatelessSession
A command-oriented API for performing bulk operations against a database.

A stateless session does not implement a first-level cache nor interact with any second-level cache, nor does it implement transactional write-behind or automatic dirty checking, nor do operations cascade to associated instances.
Transaction
Allows the application to define units of work, while maintaining abstraction from the underlying transaction implementation (eg.
UnresolvableObjectException
Thrown when Hibernate could not resolve an object by id, especially when loading an association.

Classes in org.hibernate used by org.hibernate.action
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.cache
EntityMode
Defines the representation modes available for entities.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.cache.entry
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
Interceptor
Allows user code to inspect and/or change property values.

Classes in org.hibernate used by org.hibernate.cfg
CacheMode
Controls how the session interacts with the second-level cache and query cache.
ConnectionReleaseMode
Defines the various policies by which Hibernate might release its underlying JDBC connection.
EntityMode
Defines the representation modes available for entities.
FlushMode
Represents a flushing strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
Interceptor
Allows user code to inspect and/or change property values.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
SessionFactory
Creates Sessions.

Classes in org.hibernate used by org.hibernate.classic
CallbackException
Should be thrown by persistent objects from Lifecycle or Interceptor callbacks.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
Session
The main runtime interface between a Java application and Hibernate.

Classes in org.hibernate used by org.hibernate.collection
EntityMode
Defines the representation modes available for entities.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.connection
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.context
ConnectionReleaseMode
Defines the various policies by which Hibernate might release its underlying JDBC connection.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
Session
The main runtime interface between a Java application and Hibernate.
SessionFactory
Creates Sessions.

Classes in org.hibernate used by org.hibernate.criterion
Criteria
Criteria is a simplified API for retrieving entities by composing Criterion objects.
FetchMode
Represents an association fetching strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
Session
The main runtime interface between a Java application and Hibernate.

Classes in org.hibernate used by org.hibernate.dialect
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
JDBCException
Wraps an SQLException.
LockMode
Instances represent a lock mode for a row of a relational database table.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
StaleObjectStateException
A StaleStateException that carries information about a particular entity instance that was the source of the failure.

Classes in org.hibernate used by org.hibernate.dialect.function
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.

Classes in org.hibernate used by org.hibernate.dialect.lock
JDBCException
Wraps an SQLException.
LockMode
Instances represent a lock mode for a row of a relational database table.
StaleObjectStateException
A StaleStateException that carries information about a particular entity instance that was the source of the failure.

Classes in org.hibernate used by org.hibernate.engine
CacheMode
Controls how the session interacts with the second-level cache and query cache.
ConnectionReleaseMode
Defines the various policies by which Hibernate might release its underlying JDBC connection.
EntityMode
Defines the representation modes available for entities.
FlushMode
Represents a flushing strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
Interceptor
Allows user code to inspect and/or change property values.
JDBCException
Wraps an SQLException.
LockMode
Instances represent a lock mode for a row of a relational database table.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
PropertyValueException
Thrown when the (illegal) value of a property can not be persisted.
Query
An object-oriented representation of a Hibernate query.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
ScrollableResults
A result iterator that allows moving around within the results by arbitrary increments.
ScrollMode
Specifies the type of JDBC scrollable result set to use underneath a ScrollableResults
SessionFactory
Creates Sessions.
Transaction
Allows the application to define units of work, while maintaining abstraction from the underlying transaction implementation (eg.

Classes in org.hibernate used by org.hibernate.engine.query
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
ScrollableResults
A result iterator that allows moving around within the results by arbitrary increments.

Classes in org.hibernate used by org.hibernate.engine.query.sql
LockMode
Instances represent a lock mode for a row of a relational database table.

Classes in org.hibernate used by org.hibernate.engine.transaction
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.event
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
LockMode
Instances represent a lock mode for a row of a relational database table.
ReplicationMode
Represents a replication strategy.
Session
The main runtime interface between a Java application and Hibernate.

Classes in org.hibernate used by org.hibernate.event.def
EntityMode
Defines the representation modes available for entities.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
LockMode
Instances represent a lock mode for a row of a relational database table.

Classes in org.hibernate used by org.hibernate.exception
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
JDBCException
Wraps an SQLException.

Classes in org.hibernate used by org.hibernate.hql
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
ScrollableResults
A result iterator that allows moving around within the results by arbitrary increments.

Classes in org.hibernate used by org.hibernate.hql.ast
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
ScrollableResults
A result iterator that allows moving around within the results by arbitrary increments.

Classes in org.hibernate used by org.hibernate.hql.ast.exec
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.hql.ast.tree
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.

Classes in org.hibernate used by org.hibernate.hql.ast.util
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.

Classes in org.hibernate used by org.hibernate.hql.classic
LockMode
Instances represent a lock mode for a row of a relational database table.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.

Classes in org.hibernate used by org.hibernate.id
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.

Classes in org.hibernate used by org.hibernate.impl
CacheMode
Controls how the session interacts with the second-level cache and query cache.
ConnectionReleaseMode
Defines the various policies by which Hibernate might release its underlying JDBC connection.
Criteria
Criteria is a simplified API for retrieving entities by composing Criterion objects.
EntityMode
Defines the representation modes available for entities.
FetchMode
Represents an association fetching strategy.
Filter
Type definition of Filter.
FlushMode
Represents a flushing strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
Interceptor
Allows user code to inspect and/or change property values.
JDBCException
Wraps an SQLException.
LockMode
Instances represent a lock mode for a row of a relational database table.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
Query
An object-oriented representation of a Hibernate query.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
ReplicationMode
Represents a replication strategy.
ScrollableResults
A result iterator that allows moving around within the results by arbitrary increments.
ScrollMode
Specifies the type of JDBC scrollable result set to use underneath a ScrollableResults
Session
The main runtime interface between a Java application and Hibernate.
SessionFactory
Creates Sessions.
SQLQuery
Allows the user to declare the types and select list injection points of all entities returned by the query.
StatelessSession
A command-oriented API for performing bulk operations against a database.

A stateless session does not implement a first-level cache nor interact with any second-level cache, nor does it implement transactional write-behind or automatic dirty checking, nor do operations cascade to associated instances.
Transaction
Allows the application to define units of work, while maintaining abstraction from the underlying transaction implementation (eg.

Classes in org.hibernate used by org.hibernate.intercept
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.jdbc
ConnectionReleaseMode
Defines the various policies by which Hibernate might release its underlying JDBC connection.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
Interceptor
Allows user code to inspect and/or change property values.
ScrollMode
Specifies the type of JDBC scrollable result set to use underneath a ScrollableResults
Transaction
Allows the application to define units of work, while maintaining abstraction from the underlying transaction implementation (eg.

Classes in org.hibernate used by org.hibernate.jmx
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
Interceptor
Allows user code to inspect and/or change property values.
SessionFactory
Creates Sessions.
StatelessSession
A command-oriented API for performing bulk operations against a database.

A stateless session does not implement a first-level cache nor interact with any second-level cache, nor does it implement transactional write-behind or automatic dirty checking, nor do operations cascade to associated instances.

Classes in org.hibernate used by org.hibernate.loader
FetchMode
Represents an association fetching strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
LockMode
Instances represent a lock mode for a row of a relational database table.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
ScrollableResults
A result iterator that allows moving around within the results by arbitrary increments.

Classes in org.hibernate used by org.hibernate.loader.collection
FetchMode
Represents an association fetching strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.

Classes in org.hibernate used by org.hibernate.loader.criteria
Criteria
Criteria is a simplified API for retrieving entities by composing Criterion objects.
FetchMode
Represents an association fetching strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
LockMode
Instances represent a lock mode for a row of a relational database table.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
ScrollableResults
A result iterator that allows moving around within the results by arbitrary increments.
ScrollMode
Specifies the type of JDBC scrollable result set to use underneath a ScrollableResults

Classes in org.hibernate used by org.hibernate.loader.custom
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
LockMode
Instances represent a lock mode for a row of a relational database table.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
ScrollableResults
A result iterator that allows moving around within the results by arbitrary increments.

Classes in org.hibernate used by org.hibernate.loader.custom.sql
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.loader.entity
FetchMode
Represents an association fetching strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
LockMode
Instances represent a lock mode for a row of a relational database table.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.

Classes in org.hibernate used by org.hibernate.loader.hql
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
LockMode
Instances represent a lock mode for a row of a relational database table.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
ScrollableResults
A result iterator that allows moving around within the results by arbitrary increments.

Classes in org.hibernate used by org.hibernate.mapping
EntityMode
Defines the representation modes available for entities.
FetchMode
Represents an association fetching strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
PropertyNotFoundException
Indicates that an expected getter or setter method could not be found on a class.

Classes in org.hibernate used by org.hibernate.metadata
EntityMode
Defines the representation modes available for entities.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.persister
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.persister.collection
FetchMode
Represents an association fetching strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.

Classes in org.hibernate used by org.hibernate.persister.entity
EntityMode
Defines the representation modes available for entities.
FetchMode
Represents an association fetching strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
LockMode
Instances represent a lock mode for a row of a relational database table.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.

Classes in org.hibernate used by org.hibernate.pretty
EntityMode
Defines the representation modes available for entities.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.property
EntityMode
Defines the representation modes available for entities.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
PropertyNotFoundException
Indicates that an expected getter or setter method could not be found on a class.

Classes in org.hibernate used by org.hibernate.proxy
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.proxy.dom4j
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.proxy.map
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.proxy.pojo.cglib
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.proxy.pojo.javassist
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.secure
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.sql
LockMode
Instances represent a lock mode for a row of a relational database table.
QueryException
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.

Classes in org.hibernate used by org.hibernate.tool.hbm2ddl
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.transaction
ConnectionReleaseMode
Defines the various policies by which Hibernate might release its underlying JDBC connection.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
Transaction
Allows the application to define units of work, while maintaining abstraction from the underlying transaction implementation (eg.
TransactionException
Indicates that a transaction could not be begun, committed or rolled back.

Classes in org.hibernate used by org.hibernate.tuple
EntityMode
Defines the representation modes available for entities.
FetchMode
Represents an association fetching strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.tuple.component
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.tuple.entity
EntityMode
Defines the representation modes available for entities.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.type
EntityMode
Defines the representation modes available for entities.
FetchMode
Represents an association fetching strategy.
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.

Classes in org.hibernate used by org.hibernate.usertype
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.

Classes in org.hibernate used by org.hibernate.util
HibernateException
Any exception that occurs inside the persistence layer or JDBC driver.
LockMode
Instances represent a lock mode for a row of a relational database table.
MappingException
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
PropertyNotFoundException
Indicates that an expected getter or setter method could not be found on a class.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Criteria (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Interface Criteria

All Superinterfaces:
CriteriaSpecification
All Known Implementing Classes:
CriteriaImpl, CriteriaImpl.Subcriteria
public interface Criteria
extends CriteriaSpecification

Criteria is a simplified API for retrieving entities by composing Criterion objects. This is a very convenient approach for functionality like "search" screens where there is a variable number of conditions to be placed upon the result set.

The Session is a factory for Criteria. Criterion instances are usually obtained via the factory methods on Restrictions. eg.

 List cats = session.createCriteria(Cat.class)
     .add( Restrictions.like("name", "Iz%") )
     .add( Restrictions.gt( "weight", new Float(minWeight) ) )
     .addOrder( Order.asc("age") )
     .list();
You may navigate associations using createAlias() or createCriteria().
 List cats = session.createCriteria(Cat.class)
     .createCriteria("kittens")
         .add( Restrictions.like("name", "Iz%") )
     .list();

 List cats = session.createCriteria(Cat.class)
     .createAlias("kittens", "kit")
     .add( Restrictions.like("kit.name", "Iz%") )
     .list();
You may specify projection and aggregation using Projection instances obtained via the factory methods on Projections.
 List cats = session.createCriteria(Cat.class)
     .setProjection( Projections.projectionList()
         .add( Projections.rowCount() )
         .add( Projections.avg("weight") )
         .add( Projections.max("weight") )
         .add( Projections.min("weight") )
         .add( Projections.groupProperty("color") )
     )
     .addOrder( Order.asc("color") )
     .list();

Author:
Gavin King
See Also:
Session.createCriteria(java.lang.Class), Restrictions, Projections, Order, Criterion, Projection, a disconnected version of this API

Field Summary
Fields inherited from interface org.hibernate.criterion.CriteriaSpecification
ALIAS_TO_ENTITY_MAP, DISTINCT_ROOT_ENTITY, FULL_JOIN, INNER_JOIN, LEFT_JOIN, PROJECTION, ROOT_ALIAS, ROOT_ENTITY
Method Summary
Criteria | add(Criterion criterion) Add a restriction to constrain the results to be retrieved.
Criteria | addOrder(Order order) Add an ordering to the result set.
Criteria | createAlias(String associationPath, String alias) Join an association, assigning an alias to the joined association.
Criteria | createAlias(String associationPath, String alias, int joinType) Join an association using the specified join-type, assigning an alias to the joined association.
Criteria | createCriteria(String associationPath) Create a new Criteria, "rooted" at the associated entity.
Criteria | createCriteria(String associationPath, int joinType) Create a new Criteria, "rooted" at the associated entity, using the specified join type.
Criteria | createCriteria(String associationPath, String alias) Create a new Criteria, "rooted" at the associated entity, assigning the given alias.
Criteria | createCriteria(String associationPath, String alias, int joinType) Create a new Criteria, "rooted" at the associated entity, assigning the given alias and using the specified join type.
String | getAlias() Get the alias of the entity encapsulated by this criteria instance.
List | list() Get the results.
ScrollableResults | scroll() Get the results as an instance of ScrollableResults
ScrollableResults | scroll(ScrollMode scrollMode) Get the results as an instance of ScrollableResults based on the given scroll mode.
Criteria | setCacheable(boolean cacheable) Enable caching of this query result, provided query caching is enabled for the underlying session factory.
Criteria | setCacheMode(CacheMode cacheMode) Override the cache mode for this particular query.
Criteria | setCacheRegion(String cacheRegion) Set the name of the cache region to use for query result caching.
Criteria | setComment(String comment) Add a comment to the generated SQL.
Criteria | setFetchMode(String associationPath, FetchMode mode) Specify an association fetching strategy for an association or a collection of values.
Criteria | setFetchSize(int fetchSize) Set a fetch size for the underlying JDBC query.
Criteria | setFirstResult(int firstResult) Set the first result to be retrieved.
Criteria | setFlushMode(FlushMode flushMode) Override the flush mode for this particular query.
Criteria | setLockMode(LockMode lockMode) Set the lock mode of the current entity
Criteria | setLockMode(String alias, LockMode lockMode) Set the lock mode of the aliased entity
Criteria | setMaxResults(int maxResults) Set a limit upon the number of objects to be retrieved.
Criteria | setProjection(Projection projection) Used to specify that the query results will be a projection (scalar in nature).
Criteria | setResultTransformer(ResultTransformer resultTransformer) Set a strategy for handling the query results.
Criteria | setTimeout(int timeout) Set a timeout for the underlying JDBC query.
Object | uniqueResult() Convenience method to return a single instance that matches the query, or null if the query returns no results.

Method Detail

getAlias

public String getAlias()
Get the alias of the entity encapsulated by this criteria instance.

Returns:
The alias for the encapsulated entity.

setProjection

public Criteria setProjection(Projection projection)
Used to specify that the query results will be a projection (scalar in nature). Implicitly specifies the CriteriaSpecification.PROJECTION result transformer.

The individual components contained within the given projection determines the overall "shape" of the query result.

Parameters:
projection - The projection representing the overall "shape" of the query results.
Returns:
this (for method chaining)

add

public Criteria add(Criterion criterion)
Add a restriction to constrain the results to be retrieved.

Parameters:
criterion - The criterion object representing the restriction to be applied.
Returns:
this (for method chaining)

addOrder

public Criteria addOrder(Order order)
Add an ordering to the result set.

Parameters:
order - The order object representing an ordering to be applied to the results.
Returns:
this (for method chaining)

setFetchMode

public Criteria setFetchMode(String associationPath,
                             FetchMode mode)
                      throws HibernateException
Specify an association fetching strategy for an association or a collection of values.

Parameters:
associationPath - a dot seperated property path
mode - The fetch mode for the referenced association
Returns:
this (for method chaining)
Throws:
HibernateException

setLockMode

public Criteria setLockMode(LockMode lockMode)
Set the lock mode of the current entity

Parameters:
lockMode - The lock mode to be applied
Returns:
this (for method chaining)

setLockMode

public Criteria setLockMode(String alias,
                            LockMode lockMode)
Set the lock mode of the aliased entity

Parameters:
alias - The previously assigned alias representing the entity to which the given lock mode should apply.
lockMode - The lock mode to be applied
Returns:
this (for method chaining)

createAlias

public Criteria createAlias(String associationPath,
                            String alias)
                     throws HibernateException
Join an association, assigning an alias to the joined association.

Functionally equivalent to createAlias(String, String, int) using CriteriaSpecification.INNER_JOIN for the joinType.

Parameters:
associationPath - A dot-seperated property path
alias - The alias to assign to the joined association (for later reference).
Returns:
this (for method chaining)
Throws:
HibernateException

createAlias

public Criteria createAlias(String associationPath,
                            String alias,
                            int joinType)
                     throws HibernateException
Join an association using the specified join-type, assigning an alias to the joined association.

The joinType is expected to be one of CriteriaSpecification.INNER_JOIN (the default), CriteriaSpecification.FULL_JOIN, or CriteriaSpecification.LEFT_JOIN.

Parameters:
associationPath - A dot-seperated property path
alias - The alias to assign to the joined association (for later reference).
joinType - The type of join to use.
Returns:
this (for method chaining)
Throws:
HibernateException

createCriteria

public Criteria createCriteria(String associationPath)
                        throws HibernateException
Create a new Criteria, "rooted" at the associated entity.

Functionally equivalent to createCriteria(String, int) using CriteriaSpecification.INNER_JOIN for the joinType.

Parameters:
associationPath - A dot-seperated property path
Returns:
the created "sub criteria"
Throws:
HibernateException

createCriteria

public Criteria createCriteria(String associationPath,
                               int joinType)
                        throws HibernateException
Create a new Criteria, "rooted" at the associated entity, using the specified join type.

Parameters:
associationPath - A dot-seperated property path
joinType - The type of join to use.
Returns:
the created "sub criteria"
Throws:
HibernateException

createCriteria

public Criteria createCriteria(String associationPath,
                               String alias)
                        throws HibernateException
Create a new Criteria, "rooted" at the associated entity, assigning the given alias.

Functionally equivalent to createCriteria(String, String, int) using CriteriaSpecification.INNER_JOIN for the joinType.

Parameters:
associationPath - A dot-seperated property path
alias - The alias to assign to the joined association (for later reference).
Returns:
the created "sub criteria"
Throws:
HibernateException

createCriteria

public Criteria createCriteria(String associationPath,
                               String alias,
                               int joinType)
                        throws HibernateException
Create a new Criteria, "rooted" at the associated entity, assigning the given alias and using the specified join type.

Parameters:
associationPath - A dot-seperated property path
alias - The alias to assign to the joined association (for later reference).
joinType - The type of join to use.
Returns:
the created "sub criteria"
Throws:
HibernateException

setResultTransformer

public Criteria setResultTransformer(ResultTransformer resultTransformer)
Set a strategy for handling the query results. This determines the "shape" of the query result.

Parameters:
resultTransformer - The transformer to apply
Returns:
this (for method chaining)
See Also:
CriteriaSpecification.ROOT_ENTITY, CriteriaSpecification.DISTINCT_ROOT_ENTITY, CriteriaSpecification.ALIAS_TO_ENTITY_MAP, CriteriaSpecification.PROJECTION

setMaxResults

public Criteria setMaxResults(int maxResults)
Set a limit upon the number of objects to be retrieved.

Parameters:
maxResults - the maximum number of results
Returns:
this (for method chaining)

setFirstResult

public Criteria setFirstResult(int firstResult)
Set the first result to be retrieved.

Parameters:
firstResult - the first result to retrieve, numbered from 0
Returns:
this (for method chaining)

setFetchSize

public Criteria setFetchSize(int fetchSize)
Set a fetch size for the underlying JDBC query.

Parameters:
fetchSize - the fetch size
Returns:
this (for method chaining)
See Also:
Statement.setFetchSize(int)

setTimeout

public Criteria setTimeout(int timeout)
Set a timeout for the underlying JDBC query.

Parameters:
timeout - The timeout value to apply.
Returns:
this (for method chaining)
See Also:
Statement.setQueryTimeout(int)

setCacheable

public Criteria setCacheable(boolean cacheable)
Enable caching of this query result, provided query caching is enabled for the underlying session factory.

Parameters:
cacheable - Should the result be considered cacheable; default is to not cache (false).
Returns:
this (for method chaining)

setCacheRegion

public Criteria setCacheRegion(String cacheRegion)
Set the name of the cache region to use for query result caching.

Parameters:
cacheRegion - the name of a query cache region, or null for the default query cache
Returns:
this (for method chaining)
See Also:
setCacheable(boolean)

setComment

public Criteria setComment(String comment)
Add a comment to the generated SQL.

Parameters:
comment - a human-readable string
Returns:
this (for method chaining)

setFlushMode

public Criteria setFlushMode(FlushMode flushMode)
Override the flush mode for this particular query.

Parameters:
flushMode - The flush mode to use.
Returns:
this (for method chaining)

setCacheMode

public Criteria setCacheMode(CacheMode cacheMode)
Override the cache mode for this particular query.

Parameters:
cacheMode - The cache mode to use.
Returns:
this (for method chaining)

list

public List list()
          throws HibernateException
Get the results.

Returns:
The list of matched query results.
Throws:
HibernateException

scroll

public ScrollableResults scroll()
                         throws HibernateException
Get the results as an instance of ScrollableResults

Returns:
The ScrollableResults representing the matched query results.
Throws:
HibernateException

scroll

public ScrollableResults scroll(ScrollMode scrollMode)
                         throws HibernateException
Get the results as an instance of ScrollableResults based on the given scroll mode.

Parameters:
scrollMode - Indicates the type of underlying database cursor to request.
Returns:
The ScrollableResults representing the matched query results.
Throws:
HibernateException

uniqueResult

public Object uniqueResult()
                    throws HibernateException
Convenience method to return a single instance that matches the query, or null if the query returns no results.

Returns:
the single result or null
Throws:
HibernateException - if there is more than one matching result
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Filter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Interface Filter

All Known Implementing Classes:
FilterImpl
public interface Filter

Type definition of Filter. Filter defines the user's view into enabled dynamic filters, allowing them to set filter parameter values.

Author:
Steve Ebersole

Method Summary
FilterDefinition | getFilterDefinition() Get the filter definition containing additional information about the filter (such as default-condition and expected parameter names/types).
String | getName() Get the name of this filter.
Filter | setParameter(String name, Object value) Set the named parameter's value for this filter.
Filter | setParameterList(String name, Collection values) Set the named parameter's value list for this filter.
Filter | setParameterList(String name, Object[] values) Set the named parameter's value list for this filter.
void | validate() Perform validation of the filter state.

Method Detail

getName

public String getName()
Get the name of this filter.

Returns:
This filter's name.

getFilterDefinition

public FilterDefinition getFilterDefinition()
Get the filter definition containing additional information about the filter (such as default-condition and expected parameter names/types).

Returns:
The filter definition

setParameter

public Filter setParameter(String name,
                           Object value)
Set the named parameter's value for this filter.

Parameters:
name - The parameter's name.
value - The value to be applied.
Returns:
This FilterImpl instance (for method chaining).

setParameterList

public Filter setParameterList(String name,
                               Collection values)
Set the named parameter's value list for this filter. Used in conjunction with IN-style filter criteria.

Parameters:
name - The parameter's name.
values - The values to be expanded into an SQL IN list.
Returns:
This FilterImpl instance (for method chaining).

setParameterList

public Filter setParameterList(String name,
                               Object[] values)
Set the named parameter's value list for this filter. Used in conjunction with IN-style filter criteria.

Parameters:
name - The parameter's name.
values - The values to be expanded into an SQL IN list.
Returns:
This FilterImpl instance (for method chaining).

validate

public void validate()
              throws HibernateException
Perform validation of the filter state. This is used to verify the state of the filter after its enablement and before its use.

Throws:
HibernateException - If the state is not currently valid.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Interceptor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Interface Interceptor

All Known Implementing Classes:
EmptyInterceptor
public interface Interceptor

Allows user code to inspect and/or change property values.

Inspection occurs before property values are written and after they are read from the database.

There might be a single instance of Interceptor for a SessionFactory, or a new instance might be specified for each Session. Whichever approach is used, the interceptor must be serializable if the Session is to be serializable. This means that SessionFactory-scoped interceptors should implement readResolve().

The Session may not be invoked from a callback (nor may a callback cause a collection or proxy to be lazily initialized).

Instead of implementing this interface directly, it is usually better to extend EmptyInterceptor and override only the callback methods of interest.

Author:
Gavin King
See Also:
SessionFactory.openSession(Interceptor), Configuration.setInterceptor(Interceptor), EmptyInterceptor

Method Summary
 void afterTransactionBegin(Transaction tx)
Called when a Hibernate transaction is begun via the Hibernate Transaction API.
 void afterTransactionCompletion(Transaction tx)
Called after a transaction is committed or rolled back.
 void beforeTransactionCompletion(Transaction tx)
Called before a transaction is committed (but not before rollback).
 int[] findDirty(Object entity, Serializable id, Object[] currentState, Object[] previousState, String[] propertyNames, Type[] types)
Called from flush().
 Object getEntity(String entityName, Serializable id)
Get a fully loaded entity instance that is cached externally
 String getEntityName(Object object)
Get the entity name for a persistent or transient instance
 Object instantiate(String entityName, EntityMode entityMode, Serializable id)
Instantiate the entity class.
 Boolean isTransient(Object entity)
Called to distinguish between transient and detached entities.
 void onCollectionRecreate(Object collection, Serializable key)
Called before a collection is (re)created.
 void onCollectionRemove(Object collection, Serializable key)
Called before a collection is deleted.
 void onCollectionUpdate(Object collection, Serializable key)
Called before a collection is updated.
 void onDelete(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types)
Called before an object is deleted.
 boolean onFlushDirty(Object entity, Serializable id, Object[] currentState, Object[] previousState, String[] propertyNames, Type[] types)
Called when an object is detected to be dirty, during a flush.
 boolean onLoad(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types)
Called just before an object is initialized.
 String onPrepareStatement(String sql)
Called when sql string is being prepared.
 boolean onSave(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types)
Called before an object is saved.
 void postFlush(Iterator entities)
Called after a flush that actually ends in execution of the SQL statements required to synchronize in-memory state with the database.
 void preFlush(Iterator entities)
Called before a flush

Method Detail

onLoad

public boolean onLoad(Object entity,
                      Serializable id,
                      Object[] state,
                      String[] propertyNames,
                      Type[] types)
               throws CallbackException
Called just before an object is initialized. The interceptor may change the state, which will be propagated to the persistent object. Note that when this method is called, entity will be an empty uninitialized instance of the class.

Returns:
true if the user modified the state in any way.
Throws:
CallbackException

onFlushDirty

public boolean onFlushDirty(Object entity,
                            Serializable id,
                            Object[] currentState,
                            Object[] previousState,
                            String[] propertyNames,
                            Type[] types)
                     throws CallbackException
Called when an object is detected to be dirty, during a flush. The interceptor may modify the detected currentState, which will be propagated to both the database and the persistent object. Note that not all flushes end in actual synchronization with the database, in which case the new currentState will be propagated to the object, but not necessarily (immediately) to the database. It is strongly recommended that the interceptor not modify the previousState.

Returns:
true if the user modified the currentState in any way.
Throws:
CallbackException

onSave

public boolean onSave(Object entity,
                      Serializable id,
                      Object[] state,
                      String[] propertyNames,
                      Type[] types)
               throws CallbackException
Called before an object is saved. The interceptor may modify the state, which will be used for the SQL INSERT and propagated to the persistent object.

Returns:
true if the user modified the state in any way.
Throws:
CallbackException

onDelete

public void onDelete(Object entity,
                     Serializable id,
                     Object[] state,
                     String[] propertyNames,
                     Type[] types)
              throws CallbackException
Called before an object is deleted. It is not recommended that the interceptor modify the state.

Throws:
CallbackException

onCollectionRecreate

public void onCollectionRecreate(Object collection,
                                 Serializable key)
                          throws CallbackException
Called before a collection is (re)created.

Throws:
CallbackException

onCollectionRemove

public void onCollectionRemove(Object collection,
                               Serializable key)
                        throws CallbackException
Called before a collection is deleted.

Throws:
CallbackException

onCollectionUpdate

public void onCollectionUpdate(Object collection,
                               Serializable key)
                        throws CallbackException
Called before a collection is updated.

Throws:
CallbackException

preFlush

public void preFlush(Iterator entities)
              throws CallbackException
Called before a flush

Throws:
CallbackException

postFlush

public void postFlush(Iterator entities)
               throws CallbackException
Called after a flush that actually ends in execution of the SQL statements required to synchronize in-memory state with the database.

Throws:
CallbackException

isTransient

public Boolean isTransient(Object entity)
Called to distinguish between transient and detached entities. The return value determines the state of the entity with respect to the current session.
  • Boolean.TRUE - the entity is transient
  • Boolean.FALSE - the entity is detached
  • null - Hibernate uses the unsaved-value mapping and other heuristics to determine if the object is unsaved

Parameters:
entity - a transient or detached entity
Returns:
Boolean or null to choose default behaviour

findDirty

public int[] findDirty(Object entity,
                       Serializable id,
                       Object[] currentState,
                       Object[] previousState,
                       String[] propertyNames,
                       Type[] types)
Called from flush(). The return value determines whether the entity is updated
  • an array of property indices - the entity is dirty
  • an empty array - the entity is not dirty
  • null - use Hibernate's default dirty-checking algorithm

Parameters:
entity - a persistent entity
Returns:
array of dirty property indices or null to choose default behaviour

instantiate

public Object instantiate(String entityName,
                          EntityMode entityMode,
                          Serializable id)
                   throws CallbackException
Instantiate the entity class. Return null to indicate that Hibernate should use the default constructor of the class. The identifier property of the returned instance should be initialized with the given identifier.

Parameters:
entityName - the name of the entity
entityMode - The type of entity instance to be returned.
id - the identifier of the new instance
Returns:
an instance of the class, or null to choose default behaviour
Throws:
CallbackException

getEntityName

public String getEntityName(Object object)
                     throws CallbackException
Get the entity name for a persistent or transient instance

Parameters:
object - an entity instance
Returns:
the name of the entity
Throws:
CallbackException

getEntity

public Object getEntity(String entityName,
                        Serializable id)
                 throws CallbackException
Get a fully loaded entity instance that is cached externally

Parameters:
entityName - the name of the entity
id - the instance identifier
Returns:
a fully initialized entity
Throws:
CallbackException

afterTransactionBegin

public void afterTransactionBegin(Transaction tx)
Called when a Hibernate transaction is begun via the Hibernate Transaction API. Will not be called if transactions are being controlled via some other mechanism (CMT, for example).

beforeTransactionCompletion

public void beforeTransactionCompletion(Transaction tx)
Called before a transaction is committed (but not before rollback).

afterTransactionCompletion

public void afterTransactionCompletion(Transaction tx)
Called after a transaction is committed or rolled back.

onPrepareStatement

public String onPrepareStatement(String sql)
Called when sql string is being prepared.

Parameters:
sql - sql to be prepared
Returns:
original or modified sql
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Query (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Interface Query

All Known Subinterfaces:
SQLQuery
All Known Implementing Classes:
AbstractQueryImpl, SQLQueryImpl
public interface Query

An object-oriented representation of a Hibernate query. A Query instance is obtained by calling Session.createQuery(). This interface exposes some extra functionality beyond that provided by Session.iterate() and Session.find():

  • a particular page of the result set may be selected by calling setMaxResults(), setFirstResult()
  • named query parameters may be used
  • the results may be returned as an instance of ScrollableResults

Named query parameters are tokens of the form :name in the query string. A value is bound to the integer parameter :foo by calling

setParameter("foo", foo, Hibernate.INTEGER);

for example. A name may appear multiple times in the query string.

JDBC-style ? parameters are also supported. To bind a value to a JDBC-style parameter use a set method that accepts an int positional argument (numbered from zero, contrary to JDBC).

You may not mix and match JDBC-style parameters and named parameters in the same query.

Queries are executed by calling list(), scroll() or iterate(). A query may be re-executed by subsequent invocations. Its lifespan is, however, bounded by the lifespan of the Session that created it.

Implementors are not intended to be threadsafe.

Author:
Gavin King
See Also:
Session.createQuery(java.lang.String), ScrollableResults

Method Summary
int | executeUpdate() Execute the update or delete statement.
String[] | getNamedParameters() Return the names of all named parameters of the query.
String | getQueryString() Get the query string.
String[] | getReturnAliases() Return the HQL select clause aliases (if any)
Type[] | getReturnTypes() Return the Hibernate types of the query result set.
Iterator | iterate() Return the query results as an Iterator.
List | list() Return the query results as a List.
ScrollableResults | scroll() Return the query results as ScrollableResults.
ScrollableResults | scroll(ScrollMode scrollMode) Return the query results as ScrollableResults.
Query | setBigDecimal(int position, BigDecimal number)
Query | setBigDecimal(String name, BigDecimal number)
Query | setBigInteger(int position, BigInteger number)
Query | setBigInteger(String name, BigInteger number)
Query | setBinary(int position, byte[] val)
Query | setBinary(String name, byte[] val)
Query | setBoolean(int position, boolean val)
Query | setBoolean(String name, boolean val)
Query | setByte(int position, byte val)
Query | setByte(String name, byte val)
Query | setCacheable(boolean cacheable) Enable caching of this query result set.
Query | setCacheMode(CacheMode cacheMode) Override the current session cache mode, just for this query.
Query | setCacheRegion(String cacheRegion) Set the name of the cache region.
Query | setCalendar(int position, Calendar calendar)
Query | setCalendar(String name, Calendar calendar)
Query | setCalendarDate(int position, Calendar calendar)
Query | setCalendarDate(String name, Calendar calendar)
Query | setCharacter(int position, char val)
Query | setCharacter(String name, char val)
Query | setComment(String comment) Add a comment to the generated SQL.
Query | setDate(int position, Date date)
Query | setDate(String name, Date date)
Query | setDouble(int position, double val)
Query | setDouble(String name, double val)
Query | setEntity(int position, Object val) Bind an instance of a mapped persistent class to a JDBC-style query parameter.
Query | setEntity(String name, Object val) Bind an instance of a mapped persistent class to a named query parameter.
Query | setFetchSize(int fetchSize) Set a fetch size for the underlying JDBC query.
Query | setFirstResult(int firstResult) Set the first row to retrieve.
Query | setFloat(int position, float val)
Query | setFloat(String name, float val)
Query | setFlushMode(FlushMode flushMode) Override the current session flush mode, just for this query.
Query | setInteger(int position, int val)
Query | setInteger(String name, int val)
Query | setLocale(int position, Locale locale)
Query | setLocale(String name, Locale locale)
Query | setLockMode(String alias, LockMode lockMode) Set the lockmode for the objects idententified by the given alias that appears in the FROM clause.
Query | setLong(int position, long val)
Query | setLong(String name, long val)
Query | setMaxResults(int maxResults) Set the maximum number of rows to retrieve.
Query | setParameter(int position, Object val) Bind a value to a JDBC-style query parameter, guessing the Hibernate type from the class of the given object.
Query | setParameter(int position, Object val, Type type) Bind a value to a JDBC-style query parameter.
Query | setParameter(String name, Object val) Bind a value to a named query parameter, guessing the Hibernate type from the class of the given object.
Query | setParameter(String name, Object val, Type type) Bind a value to a named query parameter.
Query | setParameterList(String name, Collection vals) Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the collection.
Query | setParameterList(String name, Collection vals, Type type) Bind multiple values to a named query parameter.
Query | setParameterList(String name, Object[] vals) Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the array.
Query | setParameterList(String name, Object[] vals, Type type) Bind multiple values to a named query parameter.
Query | setParameters(Object[] values, Type[] types) Bind values and types to positional parameters.
Query | setProperties(Object bean) Bind the property values of the given bean to named parameters of the query, matching property names with parameter names and mapping property types to Hibernate types using hueristics.
Query | setReadOnly(boolean readOnly) Entities retrieved by this query will be loaded in a read-only mode where Hibernate will never dirty-check them or make changes persistent.
Query | setResultTransformer(ResultTransformer transformer) Set a strategy for handling the query results.
Query | setSerializable(int position, Serializable val)
Query | setSerializable(String name, Serializable val)
Query | setShort(int position, short val)
Query | setShort(String name, short val)
Query | setString(int position, String val)
Query | setString(String name, String val)
Query | setText(int position, String val)
Query | setText(String name, String val)
Query | setTime(int position, Date date)
Query | setTime(String name, Date date)
Query | setTimeout(int timeout) Set a timeout for the underlying JDBC query.
Query | setTimestamp(int position, Date date)
Query | setTimestamp(String name, Date date)
Object | uniqueResult() Convenience method to return a single instance that matches the query, or null if the query returns no results.

Method Detail

getQueryString

public String getQueryString()
Get the query string.

Returns:
the query string

getReturnTypes

public Type[] getReturnTypes()
                      throws HibernateException
Return the Hibernate types of the query result set.

Returns:
an array of types
Throws:
HibernateException

getReturnAliases

public String[] getReturnAliases()
                          throws HibernateException
Return the HQL select clause aliases (if any)

Returns:
an array of aliases as strings
Throws:
HibernateException

getNamedParameters

public String[] getNamedParameters()
                            throws HibernateException
Return the names of all named parameters of the query.

Returns:
the parameter names, in no particular order
Throws:
HibernateException

iterate

public Iterator iterate()
                 throws HibernateException
Return the query results as an Iterator. If the query contains multiple results pre row, the results are returned in an instance of Object[].

Entities returned as results are initialized on demand. The first SQL query returns identifiers only.

Returns:
the result iterator
Throws:
HibernateException

scroll

public ScrollableResults scroll()
                         throws HibernateException
Return the query results as ScrollableResults. The scrollability of the returned results depends upon JDBC driver support for scrollable ResultSets.

Returns:
the result iterator
Throws:
HibernateException
See Also:
ScrollableResults

scroll

public ScrollableResults scroll(ScrollMode scrollMode)
                         throws HibernateException
Return the query results as ScrollableResults. The scrollability of the returned results depends upon JDBC driver support for scrollable ResultSets.

Returns:
the result iterator
Throws:
HibernateException
See Also:
ScrollableResults, ScrollMode

list

public List list()
          throws HibernateException
Return the query results as a List. If the query contains multiple results pre row, the results are returned in an instance of Object[].

Returns:
the result list
Throws:
HibernateException

uniqueResult

public Object uniqueResult()
                    throws HibernateException
Convenience method to return a single instance that matches the query, or null if the query returns no results.

Returns:
the single result or null
Throws:
NonUniqueResultException - if there is more than one matching result
HibernateException

executeUpdate

public int executeUpdate()
                  throws HibernateException
Execute the update or delete statement.

The semantics are compliant with the ejb3 Query.executeUpdate() method.

Returns:
The number of entities updated or deleted.
Throws:
HibernateException

setMaxResults

public Query setMaxResults(int maxResults)
Set the maximum number of rows to retrieve. If not set, there is no limit to the number of rows retrieved.

Parameters:
maxResults - the maximum number of rows

setFirstResult

public Query setFirstResult(int firstResult)
Set the first row to retrieve. If not set, rows will be retrieved beginnning from row 0.

Parameters:
firstResult - a row number, numbered from 0

setReadOnly

public Query setReadOnly(boolean readOnly)
Entities retrieved by this query will be loaded in a read-only mode where Hibernate will never dirty-check them or make changes persistent.

setCacheable

public Query setCacheable(boolean cacheable)
Enable caching of this query result set.

Parameters:
cacheable - Should the query results be cacheable?

setCacheRegion

public Query setCacheRegion(String cacheRegion)
Set the name of the cache region.

Parameters:
cacheRegion - the name of a query cache region, or null for the default query cache

setTimeout

public Query setTimeout(int timeout)
Set a timeout for the underlying JDBC query.

Parameters:
timeout - the timeout in seconds

setFetchSize

public Query setFetchSize(int fetchSize)
Set a fetch size for the underlying JDBC query.

Parameters:
fetchSize - the fetch size

setLockMode

public Query setLockMode(String alias,
                         LockMode lockMode)
Set the lockmode for the objects idententified by the given alias that appears in the FROM clause.

Parameters:
alias - a query alias, or this for a collection filter

setComment

public Query setComment(String comment)
Add a comment to the generated SQL.

Parameters:
comment - a human-readable string

setFlushMode

public Query setFlushMode(FlushMode flushMode)
Override the current session flush mode, just for this query.

See Also:
FlushMode

setCacheMode

public Query setCacheMode(CacheMode cacheMode)
Override the current session cache mode, just for this query.

See Also:
CacheMode

setParameter

public Query setParameter(int position,
                          Object val,
                          Type type)
Bind a value to a JDBC-style query parameter.

Parameters:
position - the position of the parameter in the query string, numbered from 0.
val - the possibly-null parameter value
type - the Hibernate type

setParameter

public Query setParameter(String name,
                          Object val,
                          Type type)
Bind a value to a named query parameter.

Parameters:
name - the name of the parameter
val - the possibly-null parameter value
type - the Hibernate type

setParameter

public Query setParameter(int position,
                          Object val)
                   throws HibernateException
Bind a value to a JDBC-style query parameter, guessing the Hibernate type from the class of the given object.

Parameters:
position - the position of the parameter in the query string, numbered from 0.
val - the non-null parameter value
Throws:
HibernateException - if no type could be determined

setParameter

public Query setParameter(String name,
                          Object val)
                   throws HibernateException
Bind a value to a named query parameter, guessing the Hibernate type from the class of the given object.

Parameters:
name - the name of the parameter
val - the non-null parameter value
Throws:
HibernateException - if no type could be determined

setParameters

public Query setParameters(Object[] values,
                           Type[] types)
                    throws HibernateException
Bind values and types to positional parameters.

Throws:
HibernateException

setParameterList

public Query setParameterList(String name,
                              Collection vals,
                              Type type)
                       throws HibernateException
Bind multiple values to a named query parameter. This is useful for binding a list of values to an expression such as foo.bar in (:value_list).

Parameters:
name - the name of the parameter
vals - a collection of values to list
type - the Hibernate type of the values
Throws:
HibernateException

setParameterList

public Query setParameterList(String name,
                              Collection vals)
                       throws HibernateException
Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the collection. This is useful for binding a list of values to an expression such as foo.bar in (:value_list).

Parameters:
name - the name of the parameter
vals - a collection of values to list
Throws:
HibernateException

setParameterList

public Query setParameterList(String name,
                              Object[] vals,
                              Type type)
                       throws HibernateException
Bind multiple values to a named query parameter. This is useful for binding a list of values to an expression such as foo.bar in (:value_list).

Parameters:
name - the name of the parameter
vals - a collection of values to list
type - the Hibernate type of the values
Throws:
HibernateException

setParameterList

public Query setParameterList(String name,
                              Object[] vals)
                       throws HibernateException
Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the array. This is useful for binding a list of values to an expression such as foo.bar in (:value_list).

Parameters:
name - the name of the parameter
vals - a collection of values to list
Throws:
HibernateException

setProperties

public Query setProperties(Object bean)
                    throws HibernateException
Bind the property values of the given bean to named parameters of the query, matching property names with parameter names and mapping property types to Hibernate types using hueristics.

Parameters:
bean - any JavaBean or POJO
Throws:
HibernateException

setString

public Query setString(int position,
                       String val)

setCharacter

public Query setCharacter(int position,
                          char val)

setBoolean

public Query setBoolean(int position,
                        boolean val)

setByte

public Query setByte(int position,
                     byte val)

setShort

public Query setShort(int position,
                      short val)

setInteger

public Query setInteger(int position,
                        int val)

setLong

public Query setLong(int position,
                     long val)

setFloat

public Query setFloat(int position,
                      float val)

setDouble

public Query setDouble(int position,
                       double val)

setBinary

public Query setBinary(int position,
                       byte[] val)

setText

public Query setText(int position,
                     String val)

setSerializable

public Query setSerializable(int position,
                             Serializable val)

setLocale

public Query setLocale(int position,
                       Locale locale)

setBigDecimal

public Query setBigDecimal(int position,
                           BigDecimal number)

setBigInteger

public Query setBigInteger(int position,
                           BigInteger number)

setDate

public Query setDate(int position,
                     Date date)

setTime

public Query setTime(int position,
                     Date date)

setTimestamp

public Query setTimestamp(int position,
                          Date date)

setCalendar

public Query setCalendar(int position,
                         Calendar calendar)

setCalendarDate

public Query setCalendarDate(int position,
                             Calendar calendar)

setString

public Query setString(String name,
                       String val)

setCharacter

public Query setCharacter(String name,
                          char val)

setBoolean

public Query setBoolean(String name,
                        boolean val)

setByte

public Query setByte(String name,
                     byte val)

setShort

public Query setShort(String name,
                      short val)

setInteger

public Query setInteger(String name,
                        int val)

setLong

public Query setLong(String name,
                     long val)

setFloat

public Query setFloat(String name,
                      float val)

setDouble

public Query setDouble(String name,
                       double val)

setBinary

public Query setBinary(String name,
                       byte[] val)

setText

public Query setText(String name,
                     String val)

setSerializable

public Query setSerializable(String name,
                             Serializable val)

setLocale

public Query setLocale(String name,
                       Locale locale)

setBigDecimal

public Query setBigDecimal(String name,
                           BigDecimal number)

setBigInteger

public Query setBigInteger(String name,
                           BigInteger number)

setDate

public Query setDate(String name,
                     Date date)

setTime

public Query setTime(String name,
                     Date date)

setTimestamp

public Query setTimestamp(String name,
                          Date date)

setCalendar

public Query setCalendar(String name,
                         Calendar calendar)

setCalendarDate

public Query setCalendarDate(String name,
                             Calendar calendar)

setEntity

public Query setEntity(int position,
                       Object val)
Bind an instance of a mapped persistent class to a JDBC-style query parameter.

Parameters:
position - the position of the parameter in the query string, numbered from 0.
val - a non-null instance of a persistent class

setEntity

public Query setEntity(String name,
                       Object val)
Bind an instance of a mapped persistent class to a named query parameter.

Parameters:
name - the name of the parameter
val - a non-null instance of a persistent class

setResultTransformer

public Query setResultTransformer(ResultTransformer transformer)
Set a strategy for handling the query results. This can be used to change "shape" of the query result.

Parameters:
transformer - The transformer to apply
Returns:
this (for method chaining)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScrollableResults (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Interface ScrollableResults

All Known Implementing Classes:
AbstractScrollableResults, ScrollableResultsImpl
public interface ScrollableResults

A result iterator that allows moving around within the results by arbitrary increments. The Query / ScrollableResults pattern is very similar to the JDBC PreparedStatement/ ResultSet pattern and the semantics of methods of this interface are similar to the similarly named methods on ResultSet.

Contrary to JDBC, columns of results are numbered from zero.

Author:
Gavin King
See Also:
Query.scroll()

Method Summary
void | afterLast() Go to a location just after the last result
void | beforeFirst() Go to a location just before first result (this is the initial location)
void | close() Release resources immediately.
boolean | first() Go to the first result
Object[] | get() Get the current row of results
Object | get(int i) Get the ith object in the current row of results, without initializing any other results in the row.
BigDecimal | getBigDecimal(int col) Convenience method to read a big_decimal
BigInteger | getBigInteger(int col) Convenience method to read a big_integer
byte[] | getBinary(int col) Convenience method to read a binary
Blob | getBlob(int col) Convenience method to read a blob
Boolean | getBoolean(int col) Convenience method to read a boolean
Byte | getByte(int col) Convenience method to read a byte
Calendar | getCalendar(int col) Convenience method to read a calendar or calendar_date
Character | getCharacter(int col) Convenience method to read a character
Clob | getClob(int col) Convenience method to read a clob
Date | getDate(int col) Convenience method to read a date, time or timestamp
Double | getDouble(int col) Convenience method to read a double
Float | getFloat(int col) Convenience method to read a float
Integer | getInteger(int col) Convenience method to read an integer
Locale | getLocale(int col) Convenience method to read a locale
Long | getLong(int col) Convenience method to read a long
int | getRowNumber() Get the current location in the result set.
Short | getShort(int col) Convenience method to read a short
String | getString(int col) Convenience method to read a string
String | getText(int col) Convenience method to read text
TimeZone | getTimeZone(int col) Convenience method to read a timezone
Type | getType(int i) Get the type of the ith column of results
boolean | isFirst() Is this the first result?
boolean | isLast() Is this the last result?
boolean | last() Go to the last result
boolean | next() Advance to the next result
boolean | previous() Retreat to the previous result
boolean | scroll(int i) Scroll an arbitrary number of locations
boolean | setRowNumber(int rowNumber) Set the current location in the result set, numbered from either the first row (row number 0), or the last row (row number -1).

Method Detail

next

public boolean next()
             throws HibernateException
Advance to the next result

Returns:
true if there is another result
Throws:
HibernateException

previous

public boolean previous()
                 throws HibernateException
Retreat to the previous result

Returns:
true if there is a previous result
Throws:
HibernateException

scroll

public boolean scroll(int i)
               throws HibernateException
Scroll an arbitrary number of locations

Parameters:
i - a positive (forward) or negative (backward) number of rows
Returns:
true if there is a result at the new location
Throws:
HibernateException

last

public boolean last()
             throws HibernateException
Go to the last result

Returns:
true if there are any results
Throws:
HibernateException

first

public boolean first()
              throws HibernateException
Go to the first result

Returns:
true if there are any results
Throws:
HibernateException

beforeFirst

public void beforeFirst()
                 throws HibernateException
Go to a location just before first result (this is the initial location)

Throws:
HibernateException

afterLast

public void afterLast()
               throws HibernateException
Go to a location just after the last result

Throws:
HibernateException

isFirst

public boolean isFirst()
                throws HibernateException
Is this the first result?

Returns:
true if this is the first row of results
Throws:
HibernateException

isLast

public boolean isLast()
               throws HibernateException
Is this the last result?

Returns:
true if this is the last row of results
Throws:
HibernateException

close

public void close()
           throws HibernateException
Release resources immediately.

Throws:
HibernateException

get

public Object[] get()
             throws HibernateException
Get the current row of results

Returns:
an object or array
Throws:
HibernateException

get

public Object get(int i)
           throws HibernateException
Get the ith object in the current row of results, without initializing any other results in the row. This method may be used safely, regardless of the type of the column (ie. even for scalar results).

Parameters:
i - the column, numbered from zero
Returns:
an object of any Hibernate type or null
Throws:
HibernateException

getType

public Type getType(int i)
Get the type of the ith column of results

Parameters:
i - the column, numbered from zero
Returns:
the Hibernate type

getInteger

public Integer getInteger(int col)
                   throws HibernateException
Convenience method to read an integer

Throws:
HibernateException

getLong

public Long getLong(int col)
             throws HibernateException
Convenience method to read a long

Throws:
HibernateException

getFloat

public Float getFloat(int col)
               throws HibernateException
Convenience method to read a float

Throws:
HibernateException

getBoolean

public Boolean getBoolean(int col)
                   throws HibernateException
Convenience method to read a boolean

Throws:
HibernateException

getDouble

public Double getDouble(int col)
                 throws HibernateException
Convenience method to read a double

Throws:
HibernateException

getShort

public Short getShort(int col)
               throws HibernateException
Convenience method to read a short

Throws:
HibernateException

getByte

public Byte getByte(int col)
             throws HibernateException
Convenience method to read a byte

Throws:
HibernateException

getCharacter

public Character getCharacter(int col)
                       throws HibernateException
Convenience method to read a character

Throws:
HibernateException

getBinary

public byte[] getBinary(int col)
                 throws HibernateException
Convenience method to read a binary

Throws:
HibernateException

getText

public String getText(int col)
               throws HibernateException
Convenience method to read text

Throws:
HibernateException

getBlob

public Blob getBlob(int col)
             throws HibernateException
Convenience method to read a blob

Throws:
HibernateException

getClob

public Clob getClob(int col)
             throws HibernateException
Convenience method to read a clob

Throws:
HibernateException

getString

public String getString(int col)
                 throws HibernateException
Convenience method to read a string

Throws:
HibernateException

getBigDecimal

public BigDecimal getBigDecimal(int col)
                         throws HibernateException
Convenience method to read a big_decimal

Throws:
HibernateException

getBigInteger

public BigInteger getBigInteger(int col)
                         throws HibernateException
Convenience method to read a big_integer

Throws:
HibernateException

getDate

public Date getDate(int col)
             throws HibernateException
Convenience method to read a date, time or timestamp

Throws:
HibernateException

getLocale

public Locale getLocale(int col)
                 throws HibernateException
Convenience method to read a locale

Throws:
HibernateException

getCalendar

public Calendar getCalendar(int col)
                     throws HibernateException
Convenience method to read a calendar or calendar_date

Throws:
HibernateException

getTimeZone

public TimeZone getTimeZone(int col)
                     throws HibernateException
Convenience method to read a timezone

Throws:
HibernateException

getRowNumber

public int getRowNumber()
                 throws HibernateException
Get the current location in the result set. The first row is number 0, contrary to JDBC.

Returns:
the row number, numbered from 0, or -1 if there is no current row
Throws:
HibernateException

setRowNumber

public boolean setRowNumber(int rowNumber)
                     throws HibernateException
Set the current location in the result set, numbered from either the first row (row number 0), or the last row (row number -1).

Parameters:
rowNumber - the row number, numbered from the last row, in the case of a negative row number
Returns:
true if there is a row at that row number
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Session (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Interface Session

All Superinterfaces:
Serializable
All Known Subinterfaces:
EventSource, Session
All Known Implementing Classes:
SessionImpl
public interface Session
extends Serializable

The main runtime interface between a Java application and Hibernate. This is the central API class abstracting the notion of a persistence service.

The lifecycle of a Session is bounded by the beginning and end of a logical transaction. (Long transactions might span several database transactions.)

The main function of the Session is to offer create, read and delete operations for instances of mapped entity classes. Instances may exist in one of three states:

transient: never persistent, not associated with any Session
persistent: associated with a unique Session
detached: previously persistent, not associated with any Session

Transient instances may be made persistent by calling save(), persist() or saveOrUpdate(). Persistent instances may be made transient by calling delete(). Any instance returned by a get() or load() method is persistent. Detached instances may be made persistent by calling update(), saveOrUpdate(), lock() or replicate(). The state of a transient or detached instance may also be made persistent as a new persistent instance by calling merge().

save() and persist() result in an SQL INSERT, delete() in an SQL DELETE and update() or merge() in an SQL UPDATE. Changes to persistent instances are detected at flush time and also result in an SQL UPDATE. saveOrUpdate() and replicate() result in either an INSERT or an UPDATE.

It is not intended that implementors be threadsafe. Instead each thread/transaction should obtain its own instance from a SessionFactory.

A Session instance is serializable if its persistent classes are serializable.

A typical transaction should use the following idiom:

 Session sess = factory.openSession();
 Transaction tx;
 try {
     tx = sess.beginTransaction();
     //do some work
     ...
     tx.commit();
 }
 catch (Exception e) {
     if (tx!=null) tx.rollback();
     throw e;
 }
 finally {
     sess.close();
 }

If the Session throws an exception, the transaction must be rolled back and the session discarded. The internal state of the Session might not be consistent with the database after the exception occurs.

Author:
Gavin King
See Also:
SessionFactory

Method Summary
 Transaction beginTransaction()
Begin a unit of work and return the associated Transaction object.
 void cancelQuery()
Cancel execution of the current query.
 void clear()
Completely clear the session.
 Connection close()
End the Session by disconnecting from the JDBC connection and cleaning up.
 Connection connection()
Get the JDBC connection of this Session.

If the session is using aggressive collection release (as in a CMT environment), it is the application's responsibility to close the connection returned by this call.
 boolean contains(Object object)
Check if this instance is associated with this Session.
 Criteria createCriteria(Class persistentClass)
Create a new Criteria instance, for the given entity class, or a superclass of an entity class.
 Criteria createCriteria(Class persistentClass, String alias)
Create a new Criteria instance, for the given entity class, or a superclass of an entity class, with the given alias.
 Criteria createCriteria(String entityName)
Create a new Criteria instance, for the given entity name.
 Criteria createCriteria(String entityName, String alias)
Create a new Criteria instance, for the given entity name, with the given alias.
 Query createFilter(Object collection, String queryString)
Create a new instance of Query for the given collection and filter string.
 Query createQuery(String queryString)
Create a new instance of Query for the given HQL query string.
 SQLQuery createSQLQuery(String queryString)
Create a new instance of SQLQuery for the given SQL query string.
 void delete(Object object)
Remove a persistent instance from the datastore.
 void delete(String entityName, Object object)
Remove a persistent instance from the datastore.
 void disableFilter(String filterName)
Disable the named filter for the current session.
 Connection disconnect()
Disconnect the Session from the current JDBC connection.
 Filter enableFilter(String filterName)
Enable the named filter for this current session.
 void evict(Object object)
Remove this instance from the session cache.
 void flush()
Force the Session to flush.
 Object get(Class clazz, Serializable id)
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
 Object get(Class clazz, Serializable id, LockMode lockMode)
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
 Object get(String entityName, Serializable id)
Return the persistent instance of the given named entity with the given identifier, or null if there is no such persistent instance.
 Object get(String entityName, Serializable id, LockMode lockMode)
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
 CacheMode getCacheMode()
Get the current cache mode.
 LockMode getCurrentLockMode(Object object)
Determine the current lock mode of the given object.
 Filter getEnabledFilter(String filterName)
Retrieve a currently enabled filter by name.
 EntityMode getEntityMode()
Retrieve the entity mode in effect for this session.
 String getEntityName(Object object)
Return the entity name for a persistent entity
 FlushMode getFlushMode()
Get the current flush mode.
 Serializable getIdentifier(Object object)
Return the identifier of an entity instance cached by the Session, or throw an exception if the instance is transient or associated with a different Session.
 Query getNamedQuery(String queryName)
Obtain an instance of Query for a named query string defined in the mapping file.
 Session getSession(EntityMode entityMode)
Starts a new Session with the given entity mode in effect.
 SessionFactory getSessionFactory()
Get the SessionFactory that created this instance.
 SessionStatistics getStatistics()
Get the statistics for this session.
 Transaction getTransaction()
Get the Transaction instance associated with this session.
 boolean isConnected()
Check if the Session is currently connected.
 boolean isDirty()
Does this Session contain any changes which must be synchronized with the database? Would any SQL be executed if we flushed this session?
 boolean isOpen()
Check if the Session is still open.
 Object load(Class theClass, Serializable id)
Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.
 Object load(Class theClass, Serializable id, LockMode lockMode)
Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.
 void load(Object object, Serializable id)
Read the persistent state associated with the given identifier into the given transient instance.
 Object load(String entityName, Serializable id)
Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.
 Object load(String entityName, Serializable id, LockMode lockMode)
Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.
 void lock(Object object, LockMode lockMode)
Obtain the specified lock level upon the given object.
 void lock(String entityName, Object object, LockMode lockMode)
Obtain the specified lock level upon the given object.
 Object merge(Object object)
Copy the state of the given object onto the persistent object with the same identifier.
 Object merge(String entityName, Object object)
Copy the state of the given object onto the persistent object with the same identifier.
 void persist(Object object)
Make a transient instance persistent.
 void persist(String entityName, Object object)
Make a transient instance persistent.
 void reconnect()
Deprecated. Manual reconnection is only needed in the case of application-supplied connections, in which case the reconnect(java.sql.Connection) for should be used.
 void reconnect(Connection connection)
Reconnect to the given JDBC connection.
 void refresh(Object object)
Re-read the state of the given instance from the underlying database.
 void refresh(Object object, LockMode lockMode)
Re-read the state of the given instance from the underlying database, with the given LockMode.
 void replicate(Object object, ReplicationMode replicationMode)
Persist the state of the given detached instance, reusing the current identifier value.
 void replicate(String entityName, Object object, ReplicationMode replicationMode)
Persist the state of the given detached instance, reusing the current identifier value.
 Serializable save(Object object)
Persist the given transient instance, first assigning a generated identifier.
 Serializable save(String entityName, Object object)
Persist the given transient instance, first assigning a generated identifier.
 void saveOrUpdate(Object object)
Either save() or update() the given instance, depending upon the value of its identifier property.
 void saveOrUpdate(String entityName, Object object)
Either save() or update() the given instance, depending upon the value of its identifier property.
 void setCacheMode(CacheMode cacheMode)
Set the cache mode.
 void setFlushMode(FlushMode flushMode)
Set the flush mode.
 void setReadOnly(Object entity, boolean readOnly)
Set an unmodified persistent object to read only mode, or a read only object to modifiable mode.
 void update(Object object)
Update the persistent instance with the identifier of the given detached instance.
 void update(String entityName, Object object)
Update the persistent instance with the identifier of the given detached instance.

Method Detail

getEntityMode

public EntityMode getEntityMode()
Retrieve the entity mode in effect for this session.

Returns:
The entity mode for this session.

getSession

public Session getSession(EntityMode entityMode)
Starts a new Session with the given entity mode in effect. This secondary Session inherits the connection, transaction, and other context information from the primary Session. It doesn't need to be flushed or closed by the developer.

Parameters:
entityMode - The entity mode to use for the new session.
Returns:
The new session

flush

public void flush()
           throws HibernateException
Force the Session to flush. Must be called at the end of a unit of work, before commiting the transaction and closing the session (Transaction.commit() calls this method). Flushing is the process of synchronising the underlying persistent store with persistable state held in memory.

Throws:
HibernateException

setFlushMode

public void setFlushMode(FlushMode flushMode)
Set the flush mode. The flush mode determines at which points Hibernate automatically flushes the session. For a readonly session, it is reasonable to set the flush mode to FlushMode.NEVER at the start of the session (in order to achieve some extra performance).

Parameters:
flushMode - the FlushMode
See Also:
FlushMode

getFlushMode

public FlushMode getFlushMode()
Get the current flush mode.

Returns:
FlushMode

setCacheMode

public void setCacheMode(CacheMode cacheMode)
Set the cache mode.

getCacheMode

public CacheMode getCacheMode()
Get the current cache mode.

getSessionFactory

public SessionFactory getSessionFactory()
Get the SessionFactory that created this instance.

See Also:
SessionFactory

connection

public Connection connection()
                      throws HibernateException
Get the JDBC connection of this Session.

If the session is using aggressive collection release (as in a CMT environment), it is the application's responsibility to close the connection returned by this call. Otherwise, the application should not close the connection.

Returns:
the JDBC connection in use by the Session
Throws:
HibernateException - if the Session is disconnected

close

public Connection close()
                 throws HibernateException
End the Session by disconnecting from the JDBC connection and cleaning up. It is not strictly necessary to close() the Session but you must at least disconnect() it.

Returns:
the connection provided by the application or null
Throws:
HibernateException

cancelQuery

public void cancelQuery()
                 throws HibernateException
Cancel execution of the current query. May be called from one thread to stop execution of a query in another thread. Use with care!

Throws:
HibernateException

isOpen

public boolean isOpen()
Check if the Session is still open.

Returns:
boolean

isConnected

public boolean isConnected()
Check if the Session is currently connected.

Returns:
boolean

isDirty

public boolean isDirty()
                throws HibernateException
Does this Session contain any changes which must be synchronized with the database? Would any SQL be executed if we flushed this session?

Returns:
boolean
Throws:
HibernateException

getIdentifier

public Serializable getIdentifier(Object object)
                           throws HibernateException
Return the identifier of an entity instance cached by the Session, or throw an exception if the instance is transient or associated with a different Session.

Parameters:
object - a persistent instance
Returns:
the identifier
Throws:
TransientObjectException - if the instance is transient or associated with a different session
HibernateException

contains

public boolean contains(Object object)
Check if this instance is associated with this Session.

Parameters:
object - an instance of a persistent class
Returns:
true if the given instance is associated with this Session

evict

public void evict(Object object)
           throws HibernateException
Remove this instance from the session cache. Changes to the instance will not be synchronized with the database. This operation cascades to associated instances if the association is mapped with cascade="evict".

Parameters:
object - a persistent instance
Throws:
HibernateException

load

public Object load(Class theClass,
                   Serializable id,
                   LockMode lockMode)
            throws HibernateException
Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.

Parameters:
theClass - a persistent class
id - a valid identifier of an existing persistent instance of the class
lockMode - the lock level
Returns:
the persistent instance or proxy
Throws:
HibernateException

load

public Object load(String entityName,
                   Serializable id,
                   LockMode lockMode)
            throws HibernateException
Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.

Parameters:
entityName - a persistent class
id - a valid identifier of an existing persistent instance of the class
lockMode - the lock level
Returns:
the persistent instance or proxy
Throws:
HibernateException

load

public Object load(Class theClass,
                   Serializable id)
            throws HibernateException
Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.

You should not use this method to determine if an instance exists (use get() instead). Use this only to retrieve an instance that you assume exists, where non-existence would be an actual error.

Parameters:
theClass - a persistent class
id - a valid identifier of an existing persistent instance of the class
Returns:
the persistent instance or proxy
Throws:
HibernateException

load

public Object load(String entityName,
                   Serializable id)
            throws HibernateException
Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.

You should not use this method to determine if an instance exists (use get() instead). Use this only to retrieve an instance that you assume exists, where non-existence would be an actual error.

Parameters:
entityName - a persistent class
id - a valid identifier of an existing persistent instance of the class
Returns:
the persistent instance or proxy
Throws:
HibernateException

load

public void load(Object object,
                 Serializable id)
          throws HibernateException
Read the persistent state associated with the given identifier into the given transient instance.

Parameters:
object - an "empty" instance of the persistent class
id - a valid identifier of an existing persistent instance of the class
Throws:
HibernateException

replicate

public void replicate(Object object,
                      ReplicationMode replicationMode)
               throws HibernateException
Persist the state of the given detached instance, reusing the current identifier value. This operation cascades to associated instances if the association is mapped with cascade="replicate".

Parameters:
object - a detached instance of a persistent class
Throws:
HibernateException

replicate

public void replicate(String entityName,
                      Object object,
                      ReplicationMode replicationMode)
               throws HibernateException
Persist the state of the given detached instance, reusing the current identifier value. This operation cascades to associated instances if the association is mapped with cascade="replicate".

Parameters:
object - a detached instance of a persistent class
Throws:
HibernateException

save

public Serializable save(Object object)
                  throws HibernateException
Persist the given transient instance, first assigning a generated identifier. (Or using the current value of the identifier property if the assigned generator is used.) This operation cascades to associated instances if the association is mapped with cascade="save-update".

Parameters:
object - a transient instance of a persistent class
Returns:
the generated identifier
Throws:
HibernateException

save

public Serializable save(String entityName,
                         Object object)
                  throws HibernateException
Persist the given transient instance, first assigning a generated identifier. (Or using the current value of the identifier property if the assigned generator is used.) This operation cascades to associated instances if the association is mapped with cascade="save-update".

Parameters:
object - a transient instance of a persistent class
Returns:
the generated identifier
Throws:
HibernateException

saveOrUpdate

public void saveOrUpdate(Object object)
                  throws HibernateException
Either save() or update() the given instance, depending upon the value of its identifier property. By default the instance is always saved. This behaviour may be adjusted by specifying an unsaved-value attribute of the identifier property mapping. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Parameters:
object - a transient or detached instance containing new or updated state
Throws:
HibernateException
See Also:
save(java.lang.Object), Session#update(Object object, Serializable id)

saveOrUpdate

public void saveOrUpdate(String entityName,
                         Object object)
                  throws HibernateException
Either save() or update() the given instance, depending upon the value of its identifier property. By default the instance is always saved. This behaviour may be adjusted by specifying an unsaved-value attribute of the identifier property mapping. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Parameters:
object - a transient or detached instance containing new or updated state
Throws:
HibernateException
See Also:
save(java.lang.Object), Session#update(Object object, Serializable id)

update

public void update(Object object)
            throws HibernateException
Update the persistent instance with the identifier of the given detached instance. If there is a persistent instance with the same identifier, an exception is thrown. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Parameters:
object - a detached instance containing updated state
Throws:
HibernateException

update

public void update(String entityName,
                   Object object)
            throws HibernateException
Update the persistent instance with the identifier of the given detached instance. If there is a persistent instance with the same identifier, an exception is thrown. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Parameters:
object - a detached instance containing updated state
Throws:
HibernateException

merge

public Object merge(Object object)
             throws HibernateException
Copy the state of the given object onto the persistent object with the same identifier. If there is no persistent instance currently associated with the session, it will be loaded. Return the persistent instance. If the given instance is unsaved, save a copy of and return it as a newly persistent instance. The given instance does not become associated with the session. This operation cascades to associated instances if the association is mapped with cascade="merge".

The semantics of this method are defined by JSR-220.

Parameters:
object - a detached instance with state to be copied
Returns:
an updated persistent instance
Throws:
HibernateException

merge

public Object merge(String entityName,
                    Object object)
             throws HibernateException
Copy the state of the given object onto the persistent object with the same identifier. If there is no persistent instance currently associated with the session, it will be loaded. Return the persistent instance. If the given instance is unsaved, save a copy of and return it as a newly persistent instance. The given instance does not become associated with the session. This operation cascades to associated instances if the association is mapped with cascade="merge".

The semantics of this method are defined by JSR-220.

Parameters:
object - a detached instance with state to be copied
Returns:
an updated persistent instance
Throws:
HibernateException

persist

public void persist(Object object)
             throws HibernateException
Make a transient instance persistent. This operation cascades to associated instances if the association is mapped with cascade="persist".

The semantics of this method are defined by JSR-220.

Parameters:
object - a transient instance to be made persistent
Throws:
HibernateException

persist

public void persist(String entityName,
                    Object object)
             throws HibernateException
Make a transient instance persistent. This operation cascades to associated instances if the association is mapped with cascade="persist".

The semantics of this method are defined by JSR-220.

Parameters:
object - a transient instance to be made persistent
Throws:
HibernateException

delete

public void delete(Object object)
            throws HibernateException
Remove a persistent instance from the datastore. The argument may be an instance associated with the receiving Session or a transient instance with an identifier associated with existing persistent state. This operation cascades to associated instances if the association is mapped with cascade="delete".

Parameters:
object - the instance to be removed
Throws:
HibernateException

delete

public void delete(String entityName,
                   Object object)
            throws HibernateException
Remove a persistent instance from the datastore. The object argument may be an instance associated with the receiving Session or a transient instance with an identifier associated with existing persistent state. This operation cascades to associated instances if the association is mapped with cascade="delete".

Parameters:
entityName - The entity name for the instance to be removed.
object - the instance to be removed
Throws:
HibernateException

lock

public void lock(Object object,
                 LockMode lockMode)
          throws HibernateException
Obtain the specified lock level upon the given object. This may be used to perform a version check (LockMode.READ), to upgrade to a pessimistic lock (LockMode.UPGRADE), or to simply reassociate a transient instance with a session (LockMode.NONE). This operation cascades to associated instances if the association is mapped with cascade="lock".

Parameters:
object - a persistent or transient instance
lockMode - the lock level
Throws:
HibernateException

lock

public void lock(String entityName,
                 Object object,
                 LockMode lockMode)
          throws HibernateException
Obtain the specified lock level upon the given object. This may be used to perform a version check (LockMode.READ), to upgrade to a pessimistic lock (LockMode.UPGRADE), or to simply reassociate a transient instance with a session (LockMode.NONE). This operation cascades to associated instances if the association is mapped with cascade="lock".

Parameters:
object - a persistent or transient instance
lockMode - the lock level
Throws:
HibernateException

refresh

public void refresh(Object object)
             throws HibernateException
Re-read the state of the given instance from the underlying database. It is inadvisable to use this to implement long-running sessions that span many business tasks. This method is, however, useful in certain special circumstances. For example
  • where a database trigger alters the object state upon insert or update
  • after executing direct SQL (eg. a mass update) in the same session
  • after inserting a Blob or Clob

Parameters:
object - a persistent or detached instance
Throws:
HibernateException

refresh

public void refresh(Object object,
                    LockMode lockMode)
             throws HibernateException
Re-read the state of the given instance from the underlying database, with the given LockMode. It is inadvisable to use this to implement long-running sessions that span many business tasks. This method is, however, useful in certain special circumstances.

Parameters:
object - a persistent or detached instance
lockMode - the lock mode to use
Throws:
HibernateException

getCurrentLockMode

public LockMode getCurrentLockMode(Object object)
                            throws HibernateException
Determine the current lock mode of the given object.

Parameters:
object - a persistent instance
Returns:
the current lock mode
Throws:
HibernateException

beginTransaction

public Transaction beginTransaction()
                             throws HibernateException
Begin a unit of work and return the associated Transaction object. If a new underlying transaction is required, begin the transaction. Otherwise continue the new work in the context of the existing underlying transaction. The class of the returned Transaction object is determined by the property hibernate.transaction_factory.

Returns:
a Transaction instance
Throws:
HibernateException
See Also:
Transaction

getTransaction

public Transaction getTransaction()
Get the Transaction instance associated with this session. The class of the returned Transaction object is determined by the property hibernate.transaction_factory.

Returns:
a Transaction instance
Throws:
HibernateException
See Also:
Transaction

createCriteria

public Criteria createCriteria(Class persistentClass)
Create a new Criteria instance, for the given entity class, or a superclass of an entity class.

Parameters:
persistentClass - a class, which is persistent, or has persistent subclasses
Returns:
Criteria

createCriteria

public Criteria createCriteria(Class persistentClass,
                               String alias)
Create a new Criteria instance, for the given entity class, or a superclass of an entity class, with the given alias.

Parameters:
persistentClass - a class, which is persistent, or has persistent subclasses
Returns:
Criteria

createCriteria

public Criteria createCriteria(String entityName)
Create a new Criteria instance, for the given entity name.

Parameters:
entityName -
Returns:
Criteria

createCriteria

public Criteria createCriteria(String entityName,
                               String alias)
Create a new Criteria instance, for the given entity name, with the given alias.

Parameters:
entityName -
Returns:
Criteria

createQuery

public Query createQuery(String queryString)
                  throws HibernateException
Create a new instance of Query for the given HQL query string.

Parameters:
queryString - a HQL query
Returns:
Query
Throws:
HibernateException

createSQLQuery

public SQLQuery createSQLQuery(String queryString)
                        throws HibernateException
Create a new instance of SQLQuery for the given SQL query string.

Parameters:
queryString - a SQL query
Returns:
SQLQuery
Throws:
HibernateException

createFilter

public Query createFilter(Object collection,
                          String queryString)
                   throws HibernateException
Create a new instance of Query for the given collection and filter string.

Parameters:
collection - a persistent collection
queryString - a Hibernate query
Returns:
Query
Throws:
HibernateException

getNamedQuery

public Query getNamedQuery(String queryName)
                    throws HibernateException
Obtain an instance of Query for a named query string defined in the mapping file.

Parameters:
queryName - the name of a query defined externally
Returns:
Query
Throws:
HibernateException

clear

public void clear()
Completely clear the session. Evict all loaded instances and cancel all pending saves, updates and deletions. Do not close open iterators or instances of ScrollableResults.

get

public Object get(Class clazz,
                  Serializable id)
           throws HibernateException
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance. (If the instance, or a proxy for the instance, is already associated with the session, return that instance or proxy.)

Parameters:
clazz - a persistent class
id - an identifier
Returns:
a persistent instance or null
Throws:
HibernateException

get

public Object get(Class clazz,
                  Serializable id,
                  LockMode lockMode)
           throws HibernateException
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance. Obtain the specified lock mode if the instance exists.

Parameters:
clazz - a persistent class
id - an identifier
lockMode - the lock mode
Returns:
a persistent instance or null
Throws:
HibernateException

get

public Object get(String entityName,
                  Serializable id)
           throws HibernateException
Return the persistent instance of the given named entity with the given identifier, or null if there is no such persistent instance. (If the instance, or a proxy for the instance, is already associated with the session, return that instance or proxy.)

Parameters:
entityName - the entity name
id - an identifier
Returns:
a persistent instance or null
Throws:
HibernateException

get

public Object get(String entityName,
                  Serializable id,
                  LockMode lockMode)
           throws HibernateException
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance. Obtain the specified lock mode if the instance exists.

Parameters:
entityName - the entity name
id - an identifier
lockMode - the lock mode
Returns:
a persistent instance or null
Throws:
HibernateException

getEntityName

public String getEntityName(Object object)
                     throws HibernateException
Return the entity name for a persistent entity

Parameters:
object - a persistent entity
Returns:
the entity name
Throws:
HibernateException

enableFilter

public Filter enableFilter(String filterName)
Enable the named filter for this current session.

Parameters:
filterName - The name of the filter to be enabled.
Returns:
The Filter instance representing the enabled fiter.

getEnabledFilter

public Filter getEnabledFilter(String filterName)
Retrieve a currently enabled filter by name.

Parameters:
filterName - The name of the filter to be retrieved.
Returns:
The Filter instance representing the enabled fiter.

disableFilter

public void disableFilter(String filterName)
Disable the named filter for the current session.

Parameters:
filterName - The name of the filter to be disabled.

getStatistics

public SessionStatistics getStatistics()
Get the statistics for this session.

setReadOnly

public void setReadOnly(Object entity,
                        boolean readOnly)
Set an unmodified persistent object to read only mode, or a read only object to modifiable mode. In read only mode, no snapshot is maintained and the instance is never dirty checked.

See Also:
Query.setReadOnly(boolean)

disconnect

public Connection disconnect()
                      throws HibernateException
Disconnect the Session from the current JDBC connection. If the connection was obtained by Hibernate close it and return it to the connection pool; otherwise, return it to the application.

This is used by applications which supply JDBC connections to Hibernate and which require long-sessions (or long-conversations)

Note that disconnect() called on a session where the connection was retrieved by Hibernate through its configured ConnectionProvider has no effect, provided ConnectionReleaseMode.ON_CLOSE is not in effect.

Returns:
the application-supplied connection or null
Throws:
HibernateException
See Also:
reconnect(Connection), reconnect()

reconnect

public void reconnect()
               throws HibernateException
Deprecated. Manual reconnection is only needed in the case of application-supplied connections, in which case the reconnect(java.sql.Connection) for should be used.

Obtain a new JDBC connection. This is used by applications which require long transactions and do not supply connections to the session.

Throws:
HibernateException
See Also:
disconnect()

reconnect

public void reconnect(Connection connection)
               throws HibernateException
Reconnect to the given JDBC connection. This is used by applications which require long transactions and use application-supplied connections.

Parameters:
connection - a JDBC connection
Throws:
HibernateException
See Also:
disconnect()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SessionFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Interface SessionFactory

All Superinterfaces:
Referenceable, Serializable
All Known Subinterfaces:
SessionFactoryImplementor
All Known Implementing Classes:
SessionFactoryImpl, SessionFactoryStub
public interface SessionFactory
extends Referenceable, Serializable

Creates Sessions. Usually an application has a single SessionFactory. Threads servicing client requests obtain Sessions from the factory.

Implementors must be threadsafe.

SessionFactorys are immutable. The behaviour of a SessionFactory is controlled by properties supplied at configuration time. These properties are defined on Environment.

Author:
Gavin King
See Also:
Session, Environment, Configuration, ConnectionProvider, TransactionFactory

Method Summary
void | close() Destroy this SessionFactory and release all resources (caches, connection pools, etc).
void | evict(Class persistentClass) Evict all entries from the second-level cache.
void | evict(Class persistentClass, Serializable id) Evict an entry from the second-level cache.
void | evictCollection(String roleName) Evict all entries from the second-level cache.
void | evictCollection(String roleName, Serializable id) Evict an entry from the second-level cache.
void | evictEntity(String entityName) Evict all entries from the second-level cache.
void | evictEntity(String entityName, Serializable id) Evict an entry from the second-level cache.
void | evictQueries() Evict any query result sets cached in the default query cache region.
void | evictQueries(String cacheRegion) Evict any query result sets cached in the named query cache region.
Map | getAllClassMetadata() Get all ClassMetadata as a Map from entityname String to metadata object
Map | getAllCollectionMetadata() Get all CollectionMetadata as a Map from role name to metadata object
ClassMetadata | getClassMetadata(Class persistentClass) Get the ClassMetadata associated with the given entity class
ClassMetadata | getClassMetadata(String entityName) Get the ClassMetadata associated with the given entity name
CollectionMetadata | getCollectionMetadata(String roleName) Get the CollectionMetadata associated with the named collection role
Session | getCurrentSession() Obtains the current session.
Set | getDefinedFilterNames() Obtain a set of the names of all filters defined on this SessionFactory.
FilterDefinition | getFilterDefinition(String filterName) Obtain the definition of a filter by name.
Statistics | getStatistics() Get the statistics for this session factory
boolean | isClosed() Was this SessionFactory already closed?
Session | openSession() Create database connection and open a Session on it.
Session | openSession(Connection connection) Open a Session on the given connection.
Session | openSession(Connection connection, Interceptor interceptor) Open a Session on the given connection, specifying an interceptor.
Session | openSession(Interceptor interceptor) Create database connection and open a Session on it, specifying an interceptor.
StatelessSession | openStatelessSession() Get a new stateless session.
StatelessSession | openStatelessSession(Connection connection) Get a new stateless session for the given JDBC connection.
Methods inherited from interface javax.naming.Referenceable
getReference

Method Detail

openSession

public Session openSession(Connection connection)
Open a Session on the given connection.

Note that the second-level cache will be disabled if you supply a JDBC connection. Hibernate will not be able to track any statements you might have executed in the same transaction. Consider implementing your own ConnectionProvider.

Parameters:
connection - a connection provided by the application.
Returns:
Session

openSession

public Session openSession(Interceptor interceptor)
                    throws HibernateException
Create database connection and open a Session on it, specifying an interceptor.

Parameters:
interceptor - a session-scoped interceptor
Returns:
Session
Throws:
HibernateException

openSession

public Session openSession(Connection connection,
                           Interceptor interceptor)
Open a Session on the given connection, specifying an interceptor.

Note that the second-level cache will be disabled if you supply a JDBC connection. Hibernate will not be able to track any statements you might have executed in the same transaction. Consider implementing your own ConnectionProvider.

Parameters:
connection - a connection provided by the application.
interceptor - a session-scoped interceptor
Returns:
Session

openSession

public Session openSession()
                    throws HibernateException
Create database connection and open a Session on it.

Returns:
Session
Throws:
HibernateException

getCurrentSession

public Session getCurrentSession()
                          throws HibernateException
Obtains the current session. The definition of what exactly "current" means controlled by the CurrentSessionContext impl configured for use.

Note that for backwards compatibility, if a CurrentSessionContext is not configured but a JTA TransactionManagerLookup is configured this will default to the JTASessionContext impl.

Returns:
The current session.
Throws:
HibernateException - Indicates an issue locating a suitable current session.

getClassMetadata

public ClassMetadata getClassMetadata(Class persistentClass)
                               throws HibernateException
Get the ClassMetadata associated with the given entity class

Throws:
HibernateException
See Also:
ClassMetadata

getClassMetadata

public ClassMetadata getClassMetadata(String entityName)
                               throws HibernateException
Get the ClassMetadata associated with the given entity name

Throws:
HibernateException
Since:
3.0
See Also:
ClassMetadata

getCollectionMetadata

public CollectionMetadata getCollectionMetadata(String roleName)
                                         throws HibernateException
Get the CollectionMetadata associated with the named collection role

Throws:
HibernateException
See Also:
CollectionMetadata

getAllClassMetadata

public Map getAllClassMetadata()
                        throws HibernateException
Get all ClassMetadata as a Map from entityname String to metadata object

Returns:
a map from String an entity name to ClassMetaData
Throws:
HibernateException
Since:
3.0 changed key from Class to String
See Also:
ClassMetadata

getAllCollectionMetadata

public Map getAllCollectionMetadata()
                             throws HibernateException
Get all CollectionMetadata as a Map from role name to metadata object

Returns:
a map from String to CollectionMetadata
Throws:
HibernateException
See Also:
CollectionMetadata

getStatistics

public Statistics getStatistics()
Get the statistics for this session factory

close

public void close()
           throws HibernateException
Destroy this SessionFactory and release all resources (caches, connection pools, etc). It is the responsibility of the application to ensure that there are no open Sessions before calling close().

Throws:
HibernateException

isClosed

public boolean isClosed()
Was this SessionFactory already closed?

evict

public void evict(Class persistentClass)
           throws HibernateException
Evict all entries from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Throws:
HibernateException

evict

public void evict(Class persistentClass,
                  Serializable id)
           throws HibernateException
Evict an entry from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Throws:
HibernateException

evictEntity

public void evictEntity(String entityName)
                 throws HibernateException
Evict all entries from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Throws:
HibernateException

evictEntity

public void evictEntity(String entityName,
                        Serializable id)
                 throws HibernateException
Evict an entry from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Throws:
HibernateException

evictCollection

public void evictCollection(String roleName)
                     throws HibernateException
Evict all entries from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Throws:
HibernateException

evictCollection

public void evictCollection(String roleName,
                            Serializable id)
                     throws HibernateException
Evict an entry from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Throws:
HibernateException

evictQueries

public void evictQueries()
                  throws HibernateException
Evict any query result sets cached in the default query cache region.

Throws:
HibernateException

evictQueries

public void evictQueries(String cacheRegion)
                  throws HibernateException
Evict any query result sets cached in the named query cache region.

Throws:
HibernateException

openStatelessSession

public StatelessSession openStatelessSession()
Get a new stateless session.

openStatelessSession

public StatelessSession openStatelessSession(Connection connection)
Get a new stateless session for the given JDBC connection.

getDefinedFilterNames

public Set getDefinedFilterNames()
Obtain a set of the names of all filters defined on this SessionFactory.

Returns:
The set of filter names.

getFilterDefinition

public FilterDefinition getFilterDefinition(String filterName)
                                     throws HibernateException
Obtain the definition of a filter by name.

Parameters:
filterName - The name of the filter for which to obtain the definition.
Returns:
The filter definition.
Throws:
HibernateException - If no filter defined with the given name.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLQuery (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Interface SQLQuery

All Superinterfaces:
Query
All Known Implementing Classes:
SQLQueryImpl
public interface SQLQuery
extends Query

Allows the user to declare the types and select list injection points of all entities returned by the query. Also allows declaration of the type and column alias of any scalar results of the query.

Author:
Gavin King

Method Summary
SQLQuery | addEntity(Class entityClass) Declare a "root" entity, without specifying an alias
SQLQuery | addEntity(String entityName) Declare a "root" entity, without specifying an alias
SQLQuery | addEntity(String alias, Class entityClass) Declare a "root" entity
SQLQuery | addEntity(String alias, Class entityClass, LockMode lockMode) Declare a "root" entity, specifying a lock mode
SQLQuery | addEntity(String alias, String entityName) Declare a "root" entity
SQLQuery | addEntity(String alias, String entityName, LockMode lockMode) Declare a "root" entity, specifying a lock mode
SQLQuery | addJoin(String alias, String path) Declare a "joined" entity
SQLQuery | addJoin(String alias, String path, LockMode lockMode) Declare a "joined" entity, specifying a lock mode
SQLQuery | addScalar(String columnAlias) Declare a scalar query.
SQLQuery | addScalar(String columnAlias, Type type) Declare a scalar query result
SQLQuery | setResultSetMapping(String name) Use a predefined named ResultSetMapping
Methods inherited from interface org.hibernate.Query
executeUpdate, getNamedParameters, getQueryString, getReturnAliases, getReturnTypes, iterate, list, scroll, scroll, setBigDecimal, setBigDecimal, setBigInteger, setBigInteger, setBinary, setBinary, setBoolean, setBoolean, setByte, setByte, setCacheable, setCacheMode, setCacheRegion, setCalendar, setCalendar, setCalendarDate, setCalendarDate, setCharacter, setCharacter, setComment, setDate, setDate, setDouble, setDouble, setEntity, setEntity, setFetchSize, setFirstResult, setFloat, setFloat, setFlushMode, setInteger, setInteger, setLocale, setLocale, setLockMode, setLong, setLong, setMaxResults, setParameter, setParameter, setParameter, setParameter, setParameterList, setParameterList, setParameterList, setParameterList, setParameters, setProperties, setReadOnly, setResultTransformer, setSerializable, setSerializable, setShort, setShort, setString, setString, setText, setText, setTime, setTime, setTimeout, setTimestamp, setTimestamp, uniqueResult

Method Detail

addEntity

public SQLQuery addEntity(String entityName)
Declare a "root" entity, without specifying an alias

addEntity

public SQLQuery addEntity(String alias,
                          String entityName)
Declare a "root" entity

addEntity

public SQLQuery addEntity(String alias,
                          String entityName,
                          LockMode lockMode)
Declare a "root" entity, specifying a lock mode

addEntity

public SQLQuery addEntity(Class entityClass)
Declare a "root" entity, without specifying an alias

addEntity

public SQLQuery addEntity(String alias,
                          Class entityClass)
Declare a "root" entity

addEntity

public SQLQuery addEntity(String alias,
                          Class entityClass,
                          LockMode lockMode)
Declare a "root" entity, specifying a lock mode

addJoin

public SQLQuery addJoin(String alias,
                        String path)
Declare a "joined" entity

addJoin

public SQLQuery addJoin(String alias,
                        String path,
                        LockMode lockMode)
Declare a "joined" entity, specifying a lock mode

addScalar

public SQLQuery addScalar(String columnAlias,
                          Type type)
Declare a scalar query result

addScalar

public SQLQuery addScalar(String columnAlias)
Declare a scalar query. Hibernate will attempt to automatically detect the underlying type.

setResultSetMapping

public SQLQuery setResultSetMapping(String name)
Use a predefined named ResultSetMapping

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StatelessSession (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Interface StatelessSession

All Superinterfaces:
Serializable
All Known Implementing Classes:
StatelessSessionImpl
public interface StatelessSession
extends Serializable

A command-oriented API for performing bulk operations against a database.

A stateless session does not implement a first-level cache nor interact with any second-level cache, nor does it implement transactional write-behind or automatic dirty checking, nor do operations cascade to associated instances. Collections are ignored by a stateless session. Operations performed via a stateless session bypass Hibernate's event model and interceptors. Stateless sessions are vulnerable to data aliasing effects, due to the lack of a first-level cache.

For certain kinds of transactions, a stateless session may perform slightly faster than a stateful session.

Author:
Gavin King

Method Summary
Transaction | beginTransaction() Begin a Hibernate transaction.
void | close() Close the stateless session and release the JDBC connection.
Connection | connection() Returns the current JDBC connection associated with this instance. If the session is using aggressive connection release (as in a CMT environment), it is the application's responsibility to close the connection returned by this call.
Criteria | createCriteria(Class persistentClass) Create a new Criteria instance, for the given entity class, or a superclass of an entity class.
Criteria | createCriteria(Class persistentClass, String alias) Create a new Criteria instance, for the given entity class, or a superclass of an entity class, with the given alias.
Criteria | createCriteria(String entityName) Create a new Criteria instance, for the given entity name.
Criteria | createCriteria(String entityName, String alias) Create a new Criteria instance, for the given entity name, with the given alias.
Query | createQuery(String queryString) Create a new instance of Query for the given HQL query string.
SQLQuery | createSQLQuery(String queryString) Create a new instance of SQLQuery for the given SQL query string.
void | delete(Object entity) Delete a row.
void | delete(String entityName, Object entity) Delete a row.
Object | get(Class entityClass, Serializable id) Retrieve a row.
Object | get(Class entityClass, Serializable id, LockMode lockMode) Retrieve a row, obtaining the specified lock mode.
Object | get(String entityName, Serializable id) Retrieve a row.
Object | get(String entityName, Serializable id, LockMode lockMode) Retrieve a row, obtaining the specified lock mode.
Query | getNamedQuery(String queryName) Obtain an instance of Query for a named query string defined in the mapping file.
Transaction | getTransaction() Get the current Hibernate transaction.
Serializable | insert(Object entity) Insert a row.
Serializable | insert(String entityName, Object entity) Insert a row.
void | refresh(Object entity) Refresh the entity instance state from the database.
void | refresh(Object entity, LockMode lockMode) Refresh the entity instance state from the database.
void | refresh(String entityName, Object entity) Refresh the entity instance state from the database.
void | refresh(String entityName, Object entity, LockMode lockMode) Refresh the entity instance state from the database.
void | update(Object entity) Update a row.
void | update(String entityName, Object entity) Update a row.

Method Detail

close

public void close()
Close the stateless session and release the JDBC connection.

insert

public Serializable insert(Object entity)
Insert a row.

Parameters:
entity - a new transient instance

insert

public Serializable insert(String entityName,
                           Object entity)
Insert a row.

Parameters:
entityName - The entityName for the entity to be inserted
entity - a new transient instance
Returns:
the identifier of the instance

update

public void update(Object entity)
Update a row.

Parameters:
entity - a detached entity instance

update

public void update(String entityName,
                   Object entity)
Update a row.

Parameters:
entityName - The entityName for the entity to be updated
entity - a detached entity instance

delete

public void delete(Object entity)
Delete a row.

Parameters:
entity - a detached entity instance

delete

public void delete(String entityName,
                   Object entity)
Delete a row.

Parameters:
entityName - The entityName for the entity to be deleted
entity - a detached entity instance

get

public Object get(String entityName,
                  Serializable id)
Retrieve a row.

Returns:
a detached entity instance

get

public Object get(Class entityClass,
                  Serializable id)
Retrieve a row.

Returns:
a detached entity instance

get

public Object get(String entityName,
                  Serializable id,
                  LockMode lockMode)
Retrieve a row, obtaining the specified lock mode.

Returns:
a detached entity instance

get

public Object get(Class entityClass,
                  Serializable id,
                  LockMode lockMode)
Retrieve a row, obtaining the specified lock mode.

Returns:
a detached entity instance

refresh

public void refresh(Object entity)
Refresh the entity instance state from the database.

Parameters:
entity - The entity to be refreshed.

refresh

public void refresh(String entityName,
                    Object entity)
Refresh the entity instance state from the database.

Parameters:
entityName - The entityName for the entity to be refreshed.
entity - The entity to be refreshed.

refresh

public void refresh(Object entity,
                    LockMode lockMode)
Refresh the entity instance state from the database.

Parameters:
entity - The entity to be refreshed.
lockMode - The LockMode to be applied.

refresh

public void refresh(String entityName,
                    Object entity,
                    LockMode lockMode)
Refresh the entity instance state from the database.

Parameters:
entityName - The entityName for the entity to be refreshed.
entity - The entity to be refreshed.
lockMode - The LockMode to be applied.

createQuery

public Query createQuery(String queryString)
Create a new instance of Query for the given HQL query string. Entities returned by the query are detached.

getNamedQuery

public Query getNamedQuery(String queryName)
Obtain an instance of Query for a named query string defined in the mapping file. Entities returned by the query are detached.

createCriteria

public Criteria createCriteria(Class persistentClass)
Create a new Criteria instance, for the given entity class, or a superclass of an entity class. Entities returned by the query are detached.

Parameters:
persistentClass - a class, which is persistent, or has persistent subclasses
Returns:
Criteria

createCriteria

public Criteria createCriteria(Class persistentClass,
                               String alias)
Create a new Criteria instance, for the given entity class, or a superclass of an entity class, with the given alias. Entities returned by the query are detached.

Parameters:
persistentClass - a class, which is persistent, or has persistent subclasses
Returns:
Criteria

createCriteria

public Criteria createCriteria(String entityName)
Create a new Criteria instance, for the given entity name. Entities returned by the query are detached.

Parameters:
entityName -
Returns:
Criteria

createCriteria

public Criteria createCriteria(String entityName,
                               String alias)
Create a new Criteria instance, for the given entity name, with the given alias. Entities returned by the query are detached.

Parameters:
entityName -
Returns:
Criteria

createSQLQuery

public SQLQuery createSQLQuery(String queryString)
                        throws HibernateException
Create a new instance of SQLQuery for the given SQL query string. Entities returned by the query are detached.

Parameters:
queryString - a SQL query
Returns:
SQLQuery
Throws:
HibernateException

beginTransaction

public Transaction beginTransaction()
Begin a Hibernate transaction.

getTransaction

public Transaction getTransaction()
Get the current Hibernate transaction.

connection

public Connection connection()
Returns the current JDBC connection associated with this instance.

If the session is using aggressive connection release (as in a CMT environment), it is the application's responsibility to close the connection returned by this call. Otherwise, the application should not close the connection.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Transaction (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Interface Transaction

All Known Implementing Classes:
CMTTransaction, JDBCTransaction, JTATransaction
public interface Transaction

Allows the application to define units of work, while maintaining abstraction from the underlying transaction implementation (eg. JTA, JDBC).

A transaction is associated with a Session and is usually instantiated by a call to Session.beginTransaction(). A single session might span multiple transactions since the notion of a session (a conversation between the application and the datastore) is of coarser granularity than the notion of a transaction. However, it is intended that there be at most one uncommitted Transaction associated with a particular Session at any time.

Implementors are not intended to be threadsafe.

Author:
Anton van Straaten
See Also:
Session.beginTransaction(), TransactionFactory

Method Summary
void | begin() Begin a new transaction.
void | commit() Flush the associated Session and end the unit of work (unless we are in FlushMode.NEVER.
boolean | isActive() Is this transaction still active? Again, this only returns information in relation to the local transaction, not the actual underlying transaction.
void | registerSynchronization(Synchronization synchronization) Register a user synchronization callback for this transaction.
void | rollback() Force the underlying transaction to roll back.
void | setTimeout(int seconds) Set the transaction timeout for any transaction started by a subsequent call to begin() on this instance.
boolean | wasCommitted() Check if this transaction was successfully committed.
boolean | wasRolledBack() Was this transaction rolled back or set to rollback only? This only accounts for actions initiated from this local transaction.

Method Detail

begin

public void begin()
           throws HibernateException
Begin a new transaction.

Throws:
HibernateException

commit

public void commit()
            throws HibernateException
Flush the associated Session and end the unit of work (unless we are in FlushMode.NEVER.

This method will commit the underlying transaction if and only if the underlying transaction was initiated by this object.

Throws:
HibernateException

rollback

public void rollback()
              throws HibernateException
Force the underlying transaction to roll back.

Throws:
HibernateException

wasRolledBack

public boolean wasRolledBack()
                      throws HibernateException
Was this transaction rolled back or set to rollback only?

This only accounts for actions initiated from this local transaction. If, for example, the underlying transaction is forced to rollback via some other means, this method still reports false because the rollback was not initiated from here.

Returns:
boolean True if the transaction was rolled back via this local transaction; false otherwise.
Throws:
HibernateException

wasCommitted

public boolean wasCommitted()
                     throws HibernateException
Check if this transaction was successfully committed.

This method could return false even after successful invocation of commit(). As an example, JTA based strategies no-op on commit() calls if they did not start the transaction; in that case, they also report wasCommitted() as false.

Returns:
boolean True if the transaction was (unequivocally) committed via this local transaction; false otherwise.
Throws:
HibernateException

isActive

public boolean isActive()
                 throws HibernateException
Is this transaction still active?

Again, this only returns information in relation to the local transaction, not the actual underlying transaction.

Returns:
boolean Treu if this local transaction is still active.
Throws:
HibernateException

registerSynchronization

public void registerSynchronization(Synchronization synchronization)
                             throws HibernateException
Register a user synchronization callback for this transaction.

Parameters:
synchronization - The Synchronization callback to register.
Throws:
HibernateException

setTimeout

public void setTimeout(int seconds)
Set the transaction timeout for any transaction started by a subsequent call to begin() on this instance.

Parameters:
seconds - The number of seconds before a timeout.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CacheMode (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class CacheMode

java.lang.Object
    extended by org.hibernate.CacheMode
All Implemented Interfaces:
Serializable
public final class CacheMode
extends Object
implements Serializable

Controls how the session interacts with the second-level cache and query cache.

Author:
Gavin King
See Also:
Session.setCacheMode(CacheMode), Serialized Form

Field Summary
static CacheMode | GET The session may read items from the cache, but will not add items, except to invalidate items when updates occur
static CacheMode | IGNORE The session will never interact with the cache, except to invalidate cache items when updates occur
static CacheMode | NORMAL The session may read items from the cache, and add items to the cache
static CacheMode | PUT The session will never read items from the cache, but will add items to the cache as it reads them from the database.
static CacheMode | REFRESH The session will never read items from the cache, but will add items to the cache as it reads them from the database.
Method Summary
boolean | isGetEnabled()
boolean | isPutEnabled()
static CacheMode | parse(String name)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NORMAL

public static final CacheMode NORMAL
The session may read items from the cache, and add items to the cache

IGNORE

public static final CacheMode IGNORE
The session will never interact with the cache, except to invalidate cache items when updates occur

GET

public static final CacheMode GET
The session may read items from the cache, but will not add items, except to invalidate items when updates occur

PUT

public static final CacheMode PUT
The session will never read items from the cache, but will add items to the cache as it reads them from the database.

REFRESH

public static final CacheMode REFRESH
The session will never read items from the cache, but will add items to the cache as it reads them from the database. In this mode, the effect of hibernate.cache.use_minimal_puts is bypassed, in order to force a cache refresh

Method Detail

toString

public String toString()

isPutEnabled

public boolean isPutEnabled()

isGetEnabled

public boolean isGetEnabled()

parse

public static CacheMode parse(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ConnectionReleaseMode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class ConnectionReleaseMode

java.lang.Object
    extended by org.hibernate.ConnectionReleaseMode
All Implemented Interfaces:
Serializable
public class ConnectionReleaseMode
extends Object
implements Serializable

Defines the various policies by which Hibernate might release its underlying JDBC connection.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
static ConnectionReleaseMode | AFTER_STATEMENT Indicates that JDBC connection should be aggressively released after each SQL statement is executed.
static ConnectionReleaseMode | AFTER_TRANSACTION Indicates that JDBC connections should be released after each transaction ends (works with both JTA-registered synch and HibernateTransaction API).
static ConnectionReleaseMode | ON_CLOSE Indicates that connections should only be released when the Session is explicitly closed or disconnected; this is the legacy (Hibernate2 and pre-3.1) behavior.
Method Summary
static ConnectionReleaseMode parse(String modeName)
Determine the correct ConnectionReleaseMode instance based on the given name.
 String toString()
Override of Object.toString().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

AFTER_STATEMENT

public static final ConnectionReleaseMode AFTER_STATEMENT
Indicates that JDBC connection should be aggressively released after each SQL statement is executed. In this mode, the application must explicitly close all iterators and scrollable results. This mode may only be used with a JTA datasource.

AFTER_TRANSACTION

public static final ConnectionReleaseMode AFTER_TRANSACTION
Indicates that JDBC connections should be released after each transaction ends (works with both JTA-registered synch and HibernateTransaction API). This mode may not be used with an application server JTA datasource.

This is the default mode starting in 3.1; was previously ON_CLOSE.

ON_CLOSE

public static final ConnectionReleaseMode ON_CLOSE
Indicates that connections should only be released when the Session is explicitly closed or disconnected; this is the legacy (Hibernate2 and pre-3.1) behavior.

Method Detail

toString

public String toString()
Override of Object.toString(). Returns the release mode name.

Returns:
The release mode name.

parse

public static ConnectionReleaseMode parse(String modeName)
                                   throws HibernateException
Determine the correct ConnectionReleaseMode instance based on the given name.

Parameters:
modeName - The release mode name.
Returns:
The appropriate ConnectionReleaseMode instance
Throws:
HibernateException - Indicates the modeName param did not match any known modes.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmptyInterceptor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class EmptyInterceptor

java.lang.Object
    extended by org.hibernate.EmptyInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class EmptyInterceptor
extends Object
implements Interceptor, Serializable

An interceptor that does nothing. May be used as a base class for application-defined custom interceptors.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
static Interceptor INSTANCE
Constructor Summary
protected EmptyInterceptor()
Method Summary
 void afterTransactionBegin(Transaction tx)
Called when a Hibernate transaction is begun via the Hibernate Transaction API.
 void afterTransactionCompletion(Transaction tx)
Called after a transaction is committed or rolled back.
 void beforeTransactionCompletion(Transaction tx)
Called before a transaction is committed (but not before rollback).
 int[] findDirty(Object entity, Serializable id, Object[] currentState, Object[] previousState, String[] propertyNames, Type[] types)
Called from flush().
 Object getEntity(String entityName, Serializable id)
Get a fully loaded entity instance that is cached externally
 String getEntityName(Object object)
Get the entity name for a persistent or transient instance
 Object instantiate(String entityName, EntityMode entityMode, Serializable id)
Instantiate the entity class.
 Boolean isTransient(Object entity)
Called to distinguish between transient and detached entities.
 void onCollectionRecreate(Object collection, Serializable key)
Called before a collection is (re)created.
 void onCollectionRemove(Object collection, Serializable key)
Called before a collection is deleted.
 void onCollectionUpdate(Object collection, Serializable key)
Called before a collection is updated.
 void onDelete(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types)
Called before an object is deleted.
 boolean onFlushDirty(Object entity, Serializable id, Object[] currentState, Object[] previousState, String[] propertyNames, Type[] types)
Called when an object is detected to be dirty, during a flush.
 boolean onLoad(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types)
Called just before an object is initialized.
 String onPrepareStatement(String sql)
Called when sql string is being prepared.
 boolean onSave(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types)
Called before an object is saved.
 void postFlush(Iterator entities)
Called after a flush that actually ends in execution of the SQL statements required to synchronize in-memory state with the database.
 void preFlush(Iterator entities)
Called before a flush
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INSTANCE

public static final Interceptor INSTANCE
Constructor Detail

EmptyInterceptor

protected EmptyInterceptor()
Method Detail

onDelete

public void onDelete(Object entity,
                     Serializable id,
                     Object[] state,
                     String[] propertyNames,
                     Type[] types)
Description copied from interface: Interceptor
Called before an object is deleted. It is not recommended that the interceptor modify the state.

Specified by:
onDelete in interface Interceptor

onFlushDirty

public boolean onFlushDirty(Object entity,
                            Serializable id,
                            Object[] currentState,
                            Object[] previousState,
                            String[] propertyNames,
                            Type[] types)
Description copied from interface: Interceptor
Called when an object is detected to be dirty, during a flush. The interceptor may modify the detected currentState, which will be propagated to both the database and the persistent object. Note that not all flushes end in actual synchronization with the database, in which case the new currentState will be propagated to the object, but not necessarily (immediately) to the database. It is strongly recommended that the interceptor not modify the previousState.

Specified by:
onFlushDirty in interface Interceptor
Returns:
true if the user modified the currentState in any way.

onLoad

public boolean onLoad(Object entity,
                      Serializable id,
                      Object[] state,
                      String[] propertyNames,
                      Type[] types)
Description copied from interface: Interceptor
Called just before an object is initialized. The interceptor may change the state, which will be propagated to the persistent object. Note that when this method is called, entity will be an empty uninitialized instance of the class.

Specified by:
onLoad in interface Interceptor
Returns:
true if the user modified the state in any way.

onSave

public boolean onSave(Object entity,
                      Serializable id,
                      Object[] state,
                      String[] propertyNames,
                      Type[] types)
Description copied from interface: Interceptor
Called before an object is saved. The interceptor may modify the state, which will be used for the SQL INSERT and propagated to the persistent object.

Specified by:
onSave in interface Interceptor
Returns:
true if the user modified the state in any way.

postFlush

public void postFlush(Iterator entities)
Description copied from interface: Interceptor
Called after a flush that actually ends in execution of the SQL statements required to synchronize in-memory state with the database.

Specified by:
postFlush in interface Interceptor

preFlush

public void preFlush(Iterator entities)
Description copied from interface: Interceptor
Called before a flush

Specified by:
preFlush in interface Interceptor

isTransient

public Boolean isTransient(Object entity)
Description copied from interface: Interceptor
Called to distinguish between transient and detached entities. The return value determines the state of the entity with respect to the current session.
  • Boolean.TRUE - the entity is transient
  • Boolean.FALSE - the entity is detached
  • null - Hibernate uses the unsaved-value mapping and other heuristics to determine if the object is unsaved

Specified by:
isTransient in interface Interceptor
Parameters:
entity - a transient or detached entity
Returns:
Boolean or null to choose default behaviour

instantiate

public Object instantiate(String entityName,
                          EntityMode entityMode,
                          Serializable id)
Description copied from interface: Interceptor
Instantiate the entity class. Return null to indicate that Hibernate should use the default constructor of the class. The identifier property of the returned instance should be initialized with the given identifier.

Specified by:
instantiate in interface Interceptor
Parameters:
entityName - the name of the entity
entityMode - The type of entity instance to be returned.
id - the identifier of the new instance
Returns:
an instance of the class, or null to choose default behaviour

findDirty

public int[] findDirty(Object entity,
                       Serializable id,
                       Object[] currentState,
                       Object[] previousState,
                       String[] propertyNames,
                       Type[] types)
Description copied from interface: Interceptor
Called from flush(). The return value determines whether the entity is updated
  • an array of property indices - the entity is dirty
  • an empty array - the entity is not dirty
  • null - use Hibernate's default dirty-checking algorithm

Specified by:
findDirty in interface Interceptor
Parameters:
entity - a persistent entity
Returns:
array of dirty property indices or null to choose default behaviour

getEntityName

public String getEntityName(Object object)
Description copied from interface: Interceptor
Get the entity name for a persistent or transient instance

Specified by:
getEntityName in interface Interceptor
Parameters:
object - an entity instance
Returns:
the name of the entity

getEntity

public Object getEntity(String entityName,
                        Serializable id)
Description copied from interface: Interceptor
Get a fully loaded entity instance that is cached externally

Specified by:
getEntity in interface Interceptor
Parameters:
entityName - the name of the entity
id - the instance identifier
Returns:
a fully initialized entity

afterTransactionBegin

public void afterTransactionBegin(Transaction tx)
Description copied from interface: Interceptor
Called when a Hibernate transaction is begun via the Hibernate Transaction API. Will not be called if transactions are being controlled via some other mechanism (CMT, for example).

Specified by:
afterTransactionBegin in interface Interceptor

afterTransactionCompletion

public void afterTransactionCompletion(Transaction tx)
Description copied from interface: Interceptor
Called after a transaction is committed or rolled back.

Specified by:
afterTransactionCompletion in interface Interceptor

beforeTransactionCompletion

public void beforeTransactionCompletion(Transaction tx)
Description copied from interface: Interceptor
Called before a transaction is committed (but not before rollback).

Specified by:
beforeTransactionCompletion in interface Interceptor

onPrepareStatement

public String onPrepareStatement(String sql)
Description copied from interface: Interceptor
Called when sql string is being prepared.

Specified by:
onPrepareStatement in interface Interceptor
Parameters:
sql - sql to be prepared
Returns:
original or modified sql

onCollectionRemove

public void onCollectionRemove(Object collection,
                               Serializable key)
                        throws CallbackException
Description copied from interface: Interceptor
Called before a collection is deleted.

Specified by:
onCollectionRemove in interface Interceptor
Throws:
CallbackException

onCollectionRecreate

public void onCollectionRecreate(Object collection,
                                 Serializable key)
                          throws CallbackException
Description copied from interface: Interceptor
Called before a collection is (re)created.

Specified by:
onCollectionRecreate in interface Interceptor
Throws:
CallbackException

onCollectionUpdate

public void onCollectionUpdate(Object collection,
                               Serializable key)
                        throws CallbackException
Description copied from interface: Interceptor
Called before a collection is updated.

Specified by:
onCollectionUpdate in interface Interceptor
Throws:
CallbackException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityMode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class EntityMode

java.lang.Object
    extended by org.hibernate.EntityMode
All Implemented Interfaces:
Serializable
public class EntityMode
extends Object
implements Serializable

Defines the representation modes available for entities.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
static EntityMode | DOM4J
static EntityMode | MAP
static EntityMode | POJO
Constructor Summary
EntityMode(String name)
Method Summary
static EntityMode | parse(String name)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

POJO

public static final EntityMode POJO

DOM4J

public static final EntityMode DOM4J

MAP

public static final EntityMode MAP
Constructor Detail

EntityMode

public EntityMode(String name)
Method Detail

toString

public String toString()

parse

public static EntityMode parse(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FetchMode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class FetchMode

java.lang.Object
    extended by org.hibernate.FetchMode
All Implemented Interfaces:
Serializable
public final class FetchMode
extends Object
implements Serializable

Represents an association fetching strategy. This is used together with the Criteria API to specify runtime fetching strategies.

For HQL queries, use the FETCH keyword instead.

Author:
Gavin King
See Also:
Criteria.setFetchMode(java.lang.String, FetchMode), Serialized Form

Field Summary
static FetchMode | DEFAULT Default to the setting configured in the mapping file.
static FetchMode | EAGER Deprecated. use FetchMode.JOIN
static FetchMode | JOIN Fetch using an outer join.
static FetchMode | LAZY Deprecated. use FetchMode.SELECT
static FetchMode | SELECT Fetch eagerly, using a separate select.
Method Summary
 String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

DEFAULT

public static final FetchMode DEFAULT
Default to the setting configured in the mapping file.

JOIN

public static final FetchMode JOIN
Fetch using an outer join. Equivalent to fetch="join".

SELECT

public static final FetchMode SELECT
Fetch eagerly, using a separate select. Equivalent to fetch="select".

LAZY

public static final FetchMode LAZY
Deprecated. use FetchMode.SELECT

Fetch lazily. Equivalent to outer-join="false".

EAGER

public static final FetchMode EAGER
Deprecated. use FetchMode.JOIN

Fetch eagerly, using an outer join. Equivalent to outer-join="true".

Method Detail

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FlushMode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class FlushMode

java.lang.Object
    extended by org.hibernate.FlushMode
All Implemented Interfaces:
Serializable
public final class FlushMode
extends Object
implements Serializable

Represents a flushing strategy. The flush process synchronizes database state with session state by detecting state changes and executing SQL statements.

Author:
Gavin King
See Also:
Session.setFlushMode(FlushMode),
Query.setFlushMode(FlushMode),
Criteria.setFlushMode(FlushMode),
Serialized Form

Field Summary
static FlushMode | ALWAYS The Session is flushed before every query.
static FlushMode | AUTO The Session is sometimes flushed before query execution in order to ensure that queries never return stale state.
static FlushMode | COMMIT The Session is flushed when Transaction.commit() is called.
static FlushMode | MANUAL The Session is only ever flushed when Session.flush() is explicitly called by the application.
static FlushMode | NEVER Deprecated. use MANUAL instead.
Method Summary
static boolean | isManualFlushMode(FlushMode mode)
boolean | lessThan(FlushMode other)
static FlushMode | parse(String name)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NEVER

public static final FlushMode NEVER
Deprecated. use MANUAL instead.

The Session is never flushed unless Session.flush() is explicitly called by the application. This mode is very efficient for read only transactions.

MANUAL

public static final FlushMode MANUAL
The Session is only ever flushed when Session.flush() is explicitly called by the application. This mode is very efficient for read only transactions.

COMMIT

public static final FlushMode COMMIT
The Session is flushed when Transaction.commit() is called.

AUTO

public static final FlushMode AUTO
The Session is sometimes flushed before query execution in order to ensure that queries never return stale state. This is the default flush mode.

ALWAYS

public static final FlushMode ALWAYS
The Session is flushed before every query. This is almost always unnecessary and inefficient.

Method Detail

toString

public String toString()

lessThan

public boolean lessThan(FlushMode other)

isManualFlushMode

public static boolean isManualFlushMode(FlushMode mode)

parse

public static FlushMode parse(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Hibernate (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class Hibernate

java.lang.Object
    extended by org.hibernate.Hibernate
public final class Hibernate
extends Object

  • Provides access to the full range of Hibernate built-in types. Type instances may be used to bind values to query parameters.
  • A factory for new Blobs and Clobs.
  • Defines static methods for manipulation of proxies.

Author:
Gavin King
See Also:
Clob, Blob, Type

Field Summary
static NullableType | BIG_DECIMAL Hibernate big_decimal type.
static NullableType | BIG_INTEGER Hibernate big_integer type.
static NullableType | BINARY Hibernate binary type.
static Type | BLOB Hibernate blob type.
static NullableType | BOOLEAN Hibernate boolean type.
static NullableType | BYTE Hibernate byte type.
static NullableType | CALENDAR Hibernate calendar type.
static NullableType | CALENDAR_DATE Hibernate calendar_date type.
static NullableType | CHAR_ARRAY Hibernate char[] type.
static NullableType | CHARACTER Hibernate character type.
static NullableType | CHARACTER_ARRAY Hibernate Character[] type.
static NullableType | CLASS Hibernate class type.
static Type | CLOB Hibernate clob type.
static NullableType | CURRENCY Hibernate currency type.
static NullableType | DATE Hibernate date type.
static NullableType | DOUBLE Hibernate double type.
static NullableType | FLOAT Hibernate float type.
static NullableType | INTEGER Hibernate integer type.
static NullableType | LOCALE Hibernate locale type.
static NullableType | LONG Hibernate long type.
static Type | OBJECT Hibernate object type.
static NullableType | SERIALIZABLE Hibernate serializable type.
static NullableType | SHORT Hibernate short type.
static NullableType | STRING Hibernate string type.
static NullableType | TEXT Hibernate text type.
static NullableType | TIME Hibernate time type.
static NullableType | TIMESTAMP Hibernate timestamp type.
static NullableType | TIMEZONE Hibernate timezone type.
static NullableType | TRUE_FALSE Hibernate true_false type.
static NullableType | WRAPPER_BINARY Hibernate wrapper-binary type.
static NullableType | YES_NO Hibernate yes_no type.
Method Summary
static Type | any(Type metaType, Type identifierType) A Hibernate any type.
static void | close(Iterator iterator) Close an Iterator created by iterate() immediately, instead of waiting until the session is closed or disconnected.
static Blob | createBlob(byte[] bytes) Create a new Blob.
static Blob | createBlob(InputStream stream) Create a new Blob.
static Blob | createBlob(InputStream stream, int length) Create a new Blob.
static Clob | createClob(Reader reader, int length) Create a new Clob.
static Clob | createClob(String string) Create a new Clob.
static Type | custom(Class userTypeClass) A Hibernate custom type.
static Type | custom(Class userTypeClass, Properties parameters) A Hibernate parameterizable custom type.
static Type | custom(Class userTypeClass, String[] parameterNames, String[] parameterValues) A Hibernate parameterizable custom type.
static Type | entity(Class persistentClass) A Hibernate persistent object (entity) type.
static Type | entity(String entityName) A Hibernate persistent object (entity) type.
static Class | getClass(Object proxy) Get the true, underlying class of a proxied persistent class.
static void | initialize(Object proxy) Force initialization of a proxy or persistent collection.
static boolean | isInitialized(Object proxy) Check if the proxy or persistent collection is initialized.
static boolean | isPropertyInitialized(Object proxy, String propertyName) Check if the property is initialized.
static Type | serializable(Class serializableClass) A Hibernate serializable type.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LONG

public static final NullableType LONG
Hibernate long type.

SHORT

public static final NullableType SHORT
Hibernate short type.

INTEGER

public static final NullableType INTEGER
Hibernate integer type.

BYTE

public static final NullableType BYTE
Hibernate byte type.

FLOAT

public static final NullableType FLOAT
Hibernate float type.

DOUBLE

public static final NullableType DOUBLE
Hibernate double type.

CHARACTER

public static final NullableType CHARACTER
Hibernate character type.

STRING

public static final NullableType STRING
Hibernate string type.

TIME

public static final NullableType TIME
Hibernate time type.

DATE

public static final NullableType DATE
Hibernate date type.

TIMESTAMP

public static final NullableType TIMESTAMP
Hibernate timestamp type.

BOOLEAN

public static final NullableType BOOLEAN
Hibernate boolean type.

TRUE_FALSE

public static final NullableType TRUE_FALSE
Hibernate true_false type.

YES_NO

public static final NullableType YES_NO
Hibernate yes_no type.

BIG_DECIMAL

public static final NullableType BIG_DECIMAL
Hibernate big_decimal type.

BIG_INTEGER

public static final NullableType BIG_INTEGER
Hibernate big_integer type.

BINARY

public static final NullableType BINARY
Hibernate binary type.

WRAPPER_BINARY

public static final NullableType WRAPPER_BINARY
Hibernate wrapper-binary type.

CHAR_ARRAY

public static final NullableType CHAR_ARRAY
Hibernate char[] type.

CHARACTER_ARRAY

public static final NullableType CHARACTER_ARRAY
Hibernate Character[] type.

TEXT

public static final NullableType TEXT
Hibernate text type.

BLOB

public static final Type BLOB
Hibernate blob type.

CLOB

public static final Type CLOB
Hibernate clob type.

CALENDAR

public static final NullableType CALENDAR
Hibernate calendar type.

CALENDAR_DATE

public static final NullableType CALENDAR_DATE
Hibernate calendar_date type.

LOCALE

public static final NullableType LOCALE
Hibernate locale type.

CURRENCY

public static final NullableType CURRENCY
Hibernate currency type.

TIMEZONE

public static final NullableType TIMEZONE
Hibernate timezone type.

CLASS

public static final NullableType CLASS
Hibernate class type.

SERIALIZABLE

public static final NullableType SERIALIZABLE
Hibernate serializable type.

OBJECT

public static final Type OBJECT
Hibernate object type.

Method Detail

serializable

public static Type serializable(Class serializableClass)
A Hibernate serializable type.

any

public static Type any(Type metaType,
                       Type identifierType)
A Hibernate any type.

Parameters:
metaType - a type mapping java.lang.Class to a single column
identifierType - the entity identifier type
Returns:
the Type

entity

public static Type entity(Class persistentClass)
A Hibernate persistent object (entity) type.

Parameters:
persistentClass - a mapped entity class

entity

public static Type entity(String entityName)
A Hibernate persistent object (entity) type.

Parameters:
entityName - a mapped entity class

custom

public static Type custom(Class userTypeClass)
                   throws HibernateException
A Hibernate custom type.

Parameters:
userTypeClass - a class that implements UserType
Throws:
HibernateException

custom

public static Type custom(Class userTypeClass,
                          String[] parameterNames,
                          String[] parameterValues)
                   throws HibernateException
A Hibernate parameterizable custom type.

Parameters:
userTypeClass - a class that implements UserType and ParameterizableType
parameterNames - the names of the parameters passed to the type
parameterValues - the values of the parameters passed to the type. They must match up with the order and length of the parameterNames array.
Throws:
HibernateException

custom

public static Type custom(Class userTypeClass,
                          Properties parameters)
                   throws HibernateException
A Hibernate parameterizable custom type.

Parameters:
userTypeClass - a class that implements UserType and ParameterizableType
parameters - the parameters as a collection of name/value pairs
Throws:
HibernateException

initialize

public static void initialize(Object proxy)
                       throws HibernateException
Force initialization of a proxy or persistent collection.

Note: This only ensures intialization of a proxy object or collection; it is not guaranteed that the elements INSIDE the collection will be initialized/materialized.

Parameters:
proxy - a persistable object, proxy, persistent collection or null
Throws:
HibernateException - if we can't initialize the proxy at this time, eg. the Session was closed

isInitialized

public static boolean isInitialized(Object proxy)
Check if the proxy or persistent collection is initialized.

Parameters:
proxy - a persistable object, proxy, persistent collection or null
Returns:
true if the argument is already initialized, or is not a proxy or collection

getClass

public static Class getClass(Object proxy)
Get the true, underlying class of a proxied persistent class. This operation will initialize a proxy by side-effect.

Parameters:
proxy - a persistable object or proxy
Returns:
the true class of the instance
Throws:
HibernateException

createBlob

public static Blob createBlob(byte[] bytes)
Create a new Blob. The returned object will be initially immutable.

Parameters:
bytes - a byte array
Returns:
the Blob

createBlob

public static Blob createBlob(InputStream stream,
                              int length)
Create a new Blob. The returned object will be initially immutable.

Parameters:
stream - a binary stream
length - the number of bytes in the stream
Returns:
the Blob

createBlob

public static Blob createBlob(InputStream stream)
                       throws IOException
Create a new Blob. The returned object will be initially immutable.

Parameters:
stream - a binary stream
Returns:
the Blob
Throws:
IOException

createClob

public static Clob createClob(String string)
Create a new Clob. The returned object will be initially immutable.

Parameters:
string - a String

createClob

public static Clob createClob(Reader reader,
                              int length)
Create a new Clob. The returned object will be initially immutable.

Parameters:
reader - a character stream
length - the number of characters in the stream

close

public static void close(Iterator iterator)
                  throws HibernateException
Close an Iterator created by iterate() immediately, instead of waiting until the session is closed or disconnected.

Parameters:
iterator - an Iterator created by iterate()
Throws:
HibernateException
See Also:
Query.iterate(), Query.iterate()

isPropertyInitialized

public static boolean isPropertyInitialized(Object proxy,
                                            String propertyName)
Check if the property is initialized. If the named property does not exist or is not persistent, this method always returns true.

Parameters:
proxy - The potential proxy
propertyName - the name of a persistent attribute of the object
Returns:
true if the named property of the object is not listed as uninitialized
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LockMode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class LockMode

java.lang.Object
    extended by org.hibernate.LockMode
All Implemented Interfaces:
Serializable
public final class LockMode
extends Object
implements Serializable

Instances represent a lock mode for a row of a relational database table. It is not intended that users spend much time worrying about locking since Hibernate usually obtains exactly the right lock level automatically. Some "advanced" users may wish to explicitly specify lock levels.

Author:
Gavin King
See Also:
Session.lock(Object,LockMode), Serialized Form

Field Summary
static LockMode | FORCE Similiar to UPGRADE except that, for versioned entities, it results in a forced version increment.
static LockMode | NONE No lock required.
static LockMode | READ A shared lock.
static LockMode | UPGRADE An upgrade lock.
static LockMode | UPGRADE_NOWAIT Attempt to obtain an upgrade lock, using an Oracle-style select for update nowait.
static LockMode | WRITE A WRITE lock is obtained when an object is updated or inserted.
Method Summary
boolean | greaterThan(LockMode mode) Check if this lock mode is more restrictive than the given lock mode.
boolean | lessThan(LockMode mode) Check if this lock mode is less restrictive than the given lock mode.
static LockMode | parse(String name)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NONE

public static final LockMode NONE
No lock required. If an object is requested with this lock mode, a READ lock will be obtained if it is necessary to actually read the state from the database, rather than pull it from a cache.

This is the "default" lock mode.

READ

public static final LockMode READ
A shared lock. Objects in this lock mode were read from the database in the current transaction, rather than being pulled from a cache.

UPGRADE

public static final LockMode UPGRADE
An upgrade lock. Objects loaded in this lock mode are materialized using an SQL select ... for update.

UPGRADE_NOWAIT

public static final LockMode UPGRADE_NOWAIT
Attempt to obtain an upgrade lock, using an Oracle-style select for update nowait. The semantics of this lock mode, once obtained, are the same as UPGRADE.

WRITE

public static final LockMode WRITE
A WRITE lock is obtained when an object is updated or inserted. This lock mode is for internal use only and is not a valid mode for load() or lock() (both of which throw exceptions if WRITE is specified).

FORCE

public static final LockMode FORCE
Similiar to UPGRADE except that, for versioned entities, it results in a forced version increment.

Method Detail

toString

public String toString()

greaterThan

public boolean greaterThan(LockMode mode)
Check if this lock mode is more restrictive than the given lock mode.

Parameters:
mode - LockMode to check
Returns:
true if this lock mode is more restrictive than given lock mode

lessThan

public boolean lessThan(LockMode mode)
Check if this lock mode is less restrictive than the given lock mode.

Parameters:
mode - LockMode to check
Returns:
true if this lock mode is less restrictive than given lock mode

parse

public static LockMode parse(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReplicationMode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class ReplicationMode

java.lang.Object
    extended by org.hibernate.ReplicationMode
All Implemented Interfaces:
Serializable
public abstract class ReplicationMode
extends Object
implements Serializable

Represents a replication strategy.

Author:
Gavin King
See Also:
Session.replicate(Object, ReplicationMode), Serialized Form

Field Summary
static ReplicationMode | EXCEPTION Throw an exception when a row already exists.
static ReplicationMode | IGNORE Ignore replicated entities when a row already exists.
static ReplicationMode | LATEST_VERSION When a row already exists, choose the latest version.
static ReplicationMode | OVERWRITE Overwrite existing rows when a row already exists.
Constructor Summary
ReplicationMode(String name)
Method Summary
abstract boolean | shouldOverwriteCurrentVersion(Object entity, Object currentVersion, Object newVersion, VersionType versionType)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

EXCEPTION

public static final ReplicationMode EXCEPTION
Throw an exception when a row already exists.

IGNORE

public static final ReplicationMode IGNORE
Ignore replicated entities when a row already exists.

OVERWRITE

public static final ReplicationMode OVERWRITE
Overwrite existing rows when a row already exists.

LATEST_VERSION

public static final ReplicationMode LATEST_VERSION
When a row already exists, choose the latest version.

Constructor Detail

ReplicationMode

public ReplicationMode(String name)
Method Detail

toString

public String toString()

shouldOverwriteCurrentVersion

public abstract boolean shouldOverwriteCurrentVersion(Object entity,
                                                      Object currentVersion,
                                                      Object newVersion,
                                                      VersionType versionType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScrollMode (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class ScrollMode

java.lang.Object
    extended by org.hibernate.ScrollMode
All Implemented Interfaces:
Serializable
public final class ScrollMode
extends Object
implements Serializable

Specifies the type of JDBC scrollable result set to use underneath a ScrollableResults

Author:
Gavin King
See Also:
Query.scroll(ScrollMode), ScrollableResults, Serialized Form

Field Summary
static ScrollMode | FORWARD_ONLY
static ScrollMode | SCROLL_INSENSITIVE Note that since the Hibernate session acts as a cache, you might need to expicitly evict objects, if you need to see changes made by other transactions.
static ScrollMode | SCROLL_SENSITIVE
Method Summary
boolean | lessThan(ScrollMode other)
int | toResultSetType()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

FORWARD_ONLY

public static final ScrollMode FORWARD_ONLY
See Also:
ResultSet.TYPE_FORWARD_ONLY

SCROLL_SENSITIVE

public static final ScrollMode SCROLL_SENSITIVE
See Also:
ResultSet.TYPE_SCROLL_SENSITIVE

SCROLL_INSENSITIVE

public static final ScrollMode SCROLL_INSENSITIVE
Note that since the Hibernate session acts as a cache, you might need to expicitly evict objects, if you need to see changes made by other transactions.

See Also:
ResultSet.TYPE_SCROLL_INSENSITIVE
Method Detail

toString

public String toString()

toResultSetType

public int toResultSetType()
Returns:
the JDBC result set type code

lessThan

public boolean lessThan(ScrollMode other)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AssertionFailure (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class AssertionFailure

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.AssertionFailure
All Implemented Interfaces:
Nestable, Serializable
public class AssertionFailure
extends NestableRuntimeException

Indicates failure of an assertion: a possible bug in Hibernate.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
AssertionFailure(String s)
AssertionFailure(String s, Throwable t)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AssertionFailure

public AssertionFailure(String s)

AssertionFailure

public AssertionFailure(String s,
                        Throwable t)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CallbackException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class CallbackException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.CallbackException
All Implemented Interfaces:
Nestable, Serializable
public class CallbackException
extends HibernateException

Should be thrown by persistent objects from Lifecycle or Interceptor callbacks.

Author:
Gavin King
See Also:
Lifecycle, Interceptor, Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
CallbackException(Exception root)
CallbackException(String message)
CallbackException(String message, Exception e)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CallbackException

public CallbackException(Exception root)

CallbackException

public CallbackException(String message)

CallbackException

public CallbackException(String message,
                         Exception e)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DuplicateMappingException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class DuplicateMappingException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.MappingException
                            extended by org.hibernate.DuplicateMappingException
All Implemented Interfaces:
Nestable, Serializable
public class DuplicateMappingException
extends MappingException

Raised whenever a duplicate for a certain type occurs. Duplicate class, table, property name etc.

Author:
Max Rydahl Andersen
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
DuplicateMappingException(String type, String name)
DuplicateMappingException(String customMessage, String type, String name)
Method Summary
String | getName()
String | getType()
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DuplicateMappingException

public DuplicateMappingException(String customMessage,
                                 String type,
                                 String name)

DuplicateMappingException

public DuplicateMappingException(String type,
                                 String name)
Method Detail

getType

public String getType()

getName

public String getName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HibernateException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class HibernateException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
All Implemented Interfaces:
Nestable, Serializable
Direct Known Subclasses:
BatchFailedException, CacheException, CallbackException, IdentifierGenerationException, InstantiationException, JDBCException, LazyInitializationException, MappingException, NonUniqueObjectException, NonUniqueResultException, PersistentObjectException, PropertyAccessException, PropertyValueException, QueryException, SerializationException, SessionException, StaleStateException, TooManyRowsAffectedException, TransactionException, TransientObjectException, TypeMismatchException, UnresolvableObjectException, ValidationFailure, WrongClassException
public class HibernateException
extends NestableRuntimeException

Any exception that occurs inside the persistence layer or JDBC driver. SQLExceptions are always wrapped by instances of JDBCException.

Author:
Gavin King
See Also:
JDBCException, Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
HibernateException(String s)
HibernateException(String string, Throwable root)
HibernateException(Throwable root)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HibernateException

public HibernateException(Throwable root)

HibernateException

public HibernateException(String string,
                          Throwable root)

HibernateException

public HibernateException(String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InstantiationException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class InstantiationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.InstantiationException
All Implemented Interfaces:
Nestable, Serializable
public class InstantiationException
extends HibernateException

Thrown if Hibernate can't instantiate an entity or component class at runtime.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
InstantiationException(String s, Class clazz)
InstantiationException(String s, Class clazz, Exception e)
InstantiationException(String s, Class clazz, Throwable root)
Method Summary
String | getMessage() Returns the detail message string of this throwable.
Class | getPersistentClass()
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InstantiationException

public InstantiationException(String s,
                              Class clazz,
                              Throwable root)

InstantiationException

public InstantiationException(String s,
                              Class clazz)

InstantiationException

public InstantiationException(String s,
                              Class clazz,
                              Exception e)
Method Detail

getPersistentClass

public Class getPersistentClass()

getMessage

public String getMessage()
Description copied from class: NestableRuntimeException
Returns the detail message string of this throwable. If it was created with a null message, returns the following: ( cause==null ? null : cause.toString( ).

Specified by:
getMessage in interface Nestable
Overrides:
getMessage in class NestableRuntimeException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InvalidMappingException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class InvalidMappingException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.MappingException
                            extended by org.hibernate.InvalidMappingException
All Implemented Interfaces:
Nestable, Serializable
public class InvalidMappingException
extends MappingException

Thrown when a mapping is found to be invalid. Similar to MappingException, but this contains more info about the path and type of mapping (e.g. file, resource or url)

Author:
Max Rydahl Andersen
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
InvalidMappingException(String type, String path)
InvalidMappingException(String customMessage, String type, String path)
InvalidMappingException(String customMessage, String type, String path, Throwable cause)
InvalidMappingException(String type, String path, Throwable cause)
Method Summary
String | getPath()
String | getType()
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidMappingException

public InvalidMappingException(String customMessage,
                               String type,
                               String path,
                               Throwable cause)

InvalidMappingException

public InvalidMappingException(String customMessage,
                               String type,
                               String path)

InvalidMappingException

public InvalidMappingException(String type,
                               String path)

InvalidMappingException

public InvalidMappingException(String type,
                               String path,
                               Throwable cause)
Method Detail

getType

public String getType()

getPath

public String getPath()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JDBCException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class JDBCException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.JDBCException
All Implemented Interfaces:
Nestable, Serializable
Direct Known Subclasses:
ConstraintViolationException, DataException, GenericJDBCException, JDBCConnectionException, LockAcquisitionException, SQLGrammarException
public class JDBCException
extends HibernateException

Wraps an SQLException. Indicates that an exception occurred during a JDBC call.

Author:
Gavin King
See Also:
SQLException, Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
JDBCException(String string, SQLException root)
JDBCException(String string, SQLException root, String sql)
Method Summary
int | getErrorCode() Get the errorCode of the underlying SQLException.
String | getSQL() Get the actual SQL statement that caused the exception (may be null)
SQLException | getSQLException() Get the underlying SQLException.
String | getSQLState() Get the SQLState of the underlying SQLException.
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JDBCException

public JDBCException(String string,
                     SQLException root)

JDBCException

public JDBCException(String string,
                     SQLException root,
                     String sql)
Method Detail

getSQLState

public String getSQLState()
Get the SQLState of the underlying SQLException.

Returns:
String
See Also:
SQLException

getErrorCode

public int getErrorCode()
Get the errorCode of the underlying SQLException.

Returns:
int the error code
See Also:
SQLException

getSQLException

public SQLException getSQLException()
Get the underlying SQLException.

Returns:
SQLException

getSQL

public String getSQL()
Get the actual SQL statement that caused the exception (may be null)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LazyInitializationException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class LazyInitializationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.LazyInitializationException
All Implemented Interfaces:
Nestable, Serializable
public class LazyInitializationException
extends HibernateException

Indicates access to unfetched data outside of a session context. For example, when an uninitialized proxy or collection is accessed after the session was closed.

Author:
Gavin King
See Also:
Hibernate.initialize(java.lang.Object), Hibernate.isInitialized(java.lang.Object), Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
LazyInitializationException(String msg)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LazyInitializationException

public LazyInitializationException(String msg)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MappingException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class MappingException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.MappingException
All Implemented Interfaces:
Nestable, Serializable
Direct Known Subclasses:
DuplicateMappingException, InvalidMappingException, MappingNotFoundException, PropertyNotFoundException
public class MappingException
extends HibernateException

An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
MappingException(String s)
MappingException(String msg, Throwable root)
MappingException(Throwable root)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MappingException

public MappingException(String msg,
                        Throwable root)

MappingException

public MappingException(Throwable root)

MappingException

public MappingException(String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MappingNotFoundException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class MappingNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.MappingException
                            extended by org.hibernate.MappingNotFoundException
All Implemented Interfaces:
Nestable, Serializable
public class MappingNotFoundException
extends MappingException

Thrown when a resource for a mapping could not be found.

Author:
Max Rydahl Andersen
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
MappingNotFoundException(String type, String path)
MappingNotFoundException(String customMessage, String type, String path)
MappingNotFoundException(String customMessage, String type, String path, Throwable cause)
MappingNotFoundException(String type, String path, Throwable cause)
Method Summary
String | getPath()
String | getType()
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MappingNotFoundException

public MappingNotFoundException(String customMessage,
                                String type,
                                String path,
                                Throwable cause)

MappingNotFoundException

public MappingNotFoundException(String customMessage,
                                String type,
                                String path)

MappingNotFoundException

public MappingNotFoundException(String type,
                                String path)

MappingNotFoundException

public MappingNotFoundException(String type,
                                String path,
                                Throwable cause)
Method Detail

getType

public String getType()

getPath

public String getPath()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonUniqueObjectException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class NonUniqueObjectException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.NonUniqueObjectException
All Implemented Interfaces:
Nestable, Serializable
public class NonUniqueObjectException
extends HibernateException

This exception is thrown when an operation would break session-scoped identity. This occurs if the user tries to associate two different instances of the same Java class with a particular identifier, in the scope of a single Session.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
NonUniqueObjectException(Serializable id, String clazz)
NonUniqueObjectException(String message, Serializable id, String clazz)
Method Summary
String | getEntityName()
Serializable | getIdentifier()
String | getMessage() Returns the detail message string of this throwable.
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NonUniqueObjectException

public NonUniqueObjectException(String message,
                                Serializable id,
                                String clazz)

NonUniqueObjectException

public NonUniqueObjectException(Serializable id,
                                String clazz)
Method Detail

getIdentifier

public Serializable getIdentifier()

getMessage

public String getMessage()
Description copied from class: NestableRuntimeException
Returns the detail message string of this throwable. If it was created with a null message, returns the following: ( cause==null ? null : cause.toString( ).

Specified by:
getMessage in interface Nestable
Overrides:
getMessage in class NestableRuntimeException

getEntityName

public String getEntityName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonUniqueResultException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class NonUniqueResultException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.NonUniqueResultException
All Implemented Interfaces:
Nestable, Serializable
public class NonUniqueResultException
extends HibernateException

Thrown when the application calls Query.uniqueResult() and the query returned more than one result. Unlike all other Hibernate exceptions, this one is recoverable!

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
NonUniqueResultException(int resultCount)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NonUniqueResultException

public NonUniqueResultException(int resultCount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectDeletedException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class ObjectDeletedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.UnresolvableObjectException
                            extended by org.hibernate.ObjectDeletedException
All Implemented Interfaces:
Nestable, Serializable
public class ObjectDeletedException
extends UnresolvableObjectException

Thrown when the user tries to do something illegal with a deleted object.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
ObjectDeletedException(String message, Serializable identifier, String clazz)
Methods inherited from class org.hibernate.UnresolvableObjectException
getEntityName, getIdentifier, getMessage, throwIfNull
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ObjectDeletedException

public ObjectDeletedException(String message,
                              Serializable identifier,
                              String clazz)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectNotFoundException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class ObjectNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.UnresolvableObjectException
                            extended by org.hibernate.ObjectNotFoundException
All Implemented Interfaces:
Nestable, Serializable
public class ObjectNotFoundException
extends UnresolvableObjectException

Thrown when Session.load() fails to select a row with the given primary key (identifier value). This exception might not be thrown when load() is called, even if there was no row on the database, because load() returns a proxy if possible. Applications should use Session.get() to test if a row exists in the database.

Like all Hibernate exceptions, this exception is considered unrecoverable.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
ObjectNotFoundException(Serializable identifier, String clazz)
Methods inherited from class org.hibernate.UnresolvableObjectException
getEntityName, getIdentifier, getMessage, throwIfNull
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ObjectNotFoundException

public ObjectNotFoundException(Serializable identifier,
                               String clazz)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentObjectException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class PersistentObjectException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.PersistentObjectException
All Implemented Interfaces:
Nestable, Serializable
public class PersistentObjectException
extends HibernateException

Thrown when the user passes a persistent instance to a Session method that expects a transient instance.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
PersistentObjectException(String s)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PersistentObjectException

public PersistentObjectException(String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyAccessException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class PropertyAccessException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.PropertyAccessException
All Implemented Interfaces:
Nestable, Serializable
public class PropertyAccessException
extends HibernateException

A problem occurred accessing a property of an instance of a persistent class by reflection, or via CGLIB. There are a number of possible underlying causes, including

  • failure of a security check
  • an exception occurring inside the getter or setter method
  • a nullable database column was mapped to a primitive-type property
  • the Hibernate type was not castable to the property type (or vice-versa)

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
PropertyAccessException(Throwable root, String s, boolean wasSetter, Class persistentClass, String propertyName)
Method Summary
String | getMessage() Returns the detail message string of this throwable.
Class | getPersistentClass()
String | getPropertyName()
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PropertyAccessException

public PropertyAccessException(Throwable root,
                               String s,
                               boolean wasSetter,
                               Class persistentClass,
                               String propertyName)
Method Detail

getPersistentClass

public Class getPersistentClass()

getPropertyName

public String getPropertyName()

getMessage

public String getMessage()
Description copied from class: NestableRuntimeException
Returns the detail message string of this throwable. If it was created with a null message, returns the following: ( cause==null ? null : cause.toString( ).

Specified by:
getMessage in interface Nestable
Overrides:
getMessage in class NestableRuntimeException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyNotFoundException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class PropertyNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.MappingException
                            extended by org.hibernate.PropertyNotFoundException
All Implemented Interfaces:
Nestable, Serializable
public class PropertyNotFoundException
extends MappingException

Indicates that an expected getter or setter method could not be found on a class.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
PropertyNotFoundException(String s)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PropertyNotFoundException

public PropertyNotFoundException(String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyValueException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class PropertyValueException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.PropertyValueException
All Implemented Interfaces:
Nestable, Serializable
public class PropertyValueException
extends HibernateException

Thrown when the (illegal) value of a property can not be persisted. There are two main causes:

  • a property declared not-null="true" is null
  • an association references an unsaved transient instance

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
PropertyValueException(String s, String entityName, String propertyName)
Method Summary
static String | buildPropertyPath(String parent, String child) Return a well formed property path.
String | getEntityName()
String | getMessage() Returns the detail message string of this throwable.
String | getPropertyName()
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PropertyValueException

public PropertyValueException(String s,
                              String entityName,
                              String propertyName)
Method Detail

getEntityName

public String getEntityName()

getPropertyName

public String getPropertyName()

getMessage

public String getMessage()
Description copied from class: NestableRuntimeException
Returns the detail message string of this throwable. If it was created with a null message, returns the following: ( cause==null ? null : cause.toString( ).

Specified by:
getMessage in interface Nestable
Overrides:
getMessage in class NestableRuntimeException

buildPropertyPath

public static String buildPropertyPath(String parent,
                                       String child)
Return a well formed property path. Basicaly, it will return parent.child

Parameters:
parent - parent in path
child - child in path
Returns:
parent-child path
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class QueryException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.QueryException
All Implemented Interfaces:
Nestable, Serializable
Direct Known Subclasses:
QueryExecutionRequestException, QueryParameterException, QuerySyntaxException
public class QueryException
extends HibernateException

A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
QueryException(Exception e)
QueryException(String message)
QueryException(String message, String queryString)
QueryException(String message, Throwable e)
Method Summary
String | getMessage() Returns the detail message string of this throwable.
String | getQueryString()
void | setQueryString(String queryString)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

QueryException

public QueryException(String message)

QueryException

public QueryException(String message,
                      Throwable e)

QueryException

public QueryException(String message,
                      String queryString)

QueryException

public QueryException(Exception e)
Method Detail

getQueryString

public String getQueryString()

setQueryString

public void setQueryString(String queryString)

getMessage

public String getMessage()
Description copied from class: NestableRuntimeException
Returns the detail message string of this throwable. If it was created with a null message, returns the following: ( cause==null ? null : cause.toString( ).

Specified by:
getMessage in interface Nestable
Overrides:
getMessage in class NestableRuntimeException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryParameterException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class QueryParameterException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.QueryException
                            extended by org.hibernate.QueryParameterException
All Implemented Interfaces:
Nestable, Serializable
public class QueryParameterException
extends QueryException

Parameter invalid or not found in the query

Author:
Emmanuel Bernard
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
QueryParameterException(Exception e)
QueryParameterException(String message)
QueryParameterException(String message, String queryString)
QueryParameterException(String message, Throwable e)
Methods inherited from class org.hibernate.QueryException
getMessage, getQueryString, setQueryString
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

QueryParameterException

public QueryParameterException(Exception e)

QueryParameterException

public QueryParameterException(String message)

QueryParameterException

public QueryParameterException(String message,
                               Throwable e)

QueryParameterException

public QueryParameterException(String message,
                               String queryString)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SessionException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class SessionException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.SessionException
All Implemented Interfaces:
Nestable, Serializable
public class SessionException
extends HibernateException

Thrown when the user calls a method of a Session that is in an inappropropriate state for the given call (for example, the the session is closed or disconnected).

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
SessionException(String message)
Constructs a new SessionException with the given message.
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SessionException

public SessionException(String message)
Constructs a new SessionException with the given message.

Parameters:
message - The message indicating the specific problem.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StaleObjectStateException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class StaleObjectStateException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.StaleStateException
                            extended by org.hibernate.StaleObjectStateException
All Implemented Interfaces:
Nestable, Serializable
public class StaleObjectStateException
extends StaleStateException

A StaleStateException that carries information about a particular entity instance that was the source of the failure.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
StaleObjectStateException(String persistentClass, Serializable identifier)
Method Summary
String | getEntityName()
Serializable | getIdentifier()
String | getMessage() Returns the detail message string of this throwable.
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

StaleObjectStateException

public StaleObjectStateException(String persistentClass,
                                 Serializable identifier)
Method Detail

getEntityName

public String getEntityName()

getIdentifier

public Serializable getIdentifier()

getMessage

public String getMessage()
Description copied from class: NestableRuntimeException
Returns the detail message string of this throwable. If it was created with a null message, returns the following: ( cause==null ? null : cause.toString( ).

Specified by:
getMessage in interface Nestable
Overrides:
getMessage in class NestableRuntimeException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StaleStateException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class StaleStateException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.StaleStateException
All Implemented Interfaces:
Nestable, Serializable
Direct Known Subclasses:
StaleObjectStateException
public class StaleStateException
extends HibernateException

Thrown when a version number or timestamp check failed, indicating that the Session contained stale data (when using long transactions with versioning). Also occurs if we try delete or update a row that does not exist.

Note that this exception often indicates that the user failed to specify the correct unsaved-value strategy for a class!

Author:
Gavin King
See Also:
StaleObjectStateException, Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
StaleStateException(String s)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

StaleStateException

public StaleStateException(String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransactionException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class TransactionException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.TransactionException
All Implemented Interfaces:
Nestable, Serializable
public class TransactionException
extends HibernateException

Indicates that a transaction could not be begun, committed or rolled back.

Author:
Anton van Straaten
See Also:
Transaction, Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
TransactionException(String message)
TransactionException(String message, Exception root)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionException

public TransactionException(String message,
                            Exception root)

TransactionException

public TransactionException(String message)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransientObjectException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class TransientObjectException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.TransientObjectException
All Implemented Interfaces:
Nestable, Serializable
public class TransientObjectException
extends HibernateException

Thrown when the user passes a transient instance to a Session method that expects a persistent instance.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
TransientObjectException(String s)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransientObjectException

public TransientObjectException(String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TypeMismatchException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class TypeMismatchException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.TypeMismatchException
All Implemented Interfaces:
Nestable, Serializable
public class TypeMismatchException
extends HibernateException

Used when a user provided type does not match the expected one

Author:
Emmanuel Bernard
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
TypeMismatchException(String s)
TypeMismatchException(String string, Throwable root)
TypeMismatchException(Throwable root)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TypeMismatchException

public TypeMismatchException(Throwable root)

TypeMismatchException

public TypeMismatchException(String s)

TypeMismatchException

public TypeMismatchException(String string,
                             Throwable root)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnresolvableObjectException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class UnresolvableObjectException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.UnresolvableObjectException
All Implemented Interfaces:
Nestable, Serializable
Direct Known Subclasses:
ObjectDeletedException, ObjectNotFoundException
public class UnresolvableObjectException
extends HibernateException

Thrown when Hibernate could not resolve an object by id, especially when loading an association.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
UnresolvableObjectException(Serializable identifier, String clazz)
Method Summary
String | getEntityName()
Serializable | getIdentifier()
String | getMessage() Returns the detail message string of this throwable.
static void | throwIfNull(Object o, Serializable id, String clazz)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnresolvableObjectException

public UnresolvableObjectException(Serializable identifier,
                                   String clazz)
Method Detail

getIdentifier

public Serializable getIdentifier()

getMessage

public String getMessage()
Description copied from class: NestableRuntimeException
Returns the detail message string of this throwable. If it was created with a null message, returns the following: ( cause==null ? null : cause.toString( ).

Specified by:
getMessage in interface Nestable
Overrides:
getMessage in class NestableRuntimeException

getEntityName

public String getEntityName()

throwIfNull

public static void throwIfNull(Object o,
                               Serializable id,
                               String clazz)
                        throws UnresolvableObjectException
Throws:
UnresolvableObjectException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WrongClassException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate
Class WrongClassException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.WrongClassException
All Implemented Interfaces:
Nestable, Serializable
public class WrongClassException
extends HibernateException

Thrown when Session.load() selects a row with the given primary key (identifier value) but the row's discriminator value specifies a subclass that is not assignable to the class requested by the user.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
WrongClassException(String msg, Serializable identifier, String clazz)
Method Summary
String | getEntityName()
Serializable | getIdentifier()
String | getMessage() Returns the detail message string of this throwable.
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

WrongClassException

public WrongClassException(String msg,
                           Serializable identifier,
                           String clazz)
Method Detail

getIdentifier

public Serializable getIdentifier()

getMessage

public String getMessage()
Description copied from class: NestableRuntimeException
Returns the detail message string of this throwable. If it was created with a null message, returns the following: ( cause==null ? null : cause.toString( ).

Specified by:
getMessage in interface Nestable
Overrides:
getMessage in class NestableRuntimeException

getEntityName

public String getEntityName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.action (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.action

This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.

See:
Description

Interface Summary
Executable An operation which may be scheduled for later execution.

Class Summary
BulkOperationCleanupAction | Implementation of BulkOperationCleanupAction.
CollectionAction | Any action relating to insert/update/delete of a collection
CollectionRecreateAction |
CollectionRemoveAction |
CollectionUpdateAction |
DelayedPostInsertIdentifier | Acts as a stand-in for an entity identifier which is supposed to be generated on insert (like an IDENTITY column) where the insert needed to be delayed because we were outside a transaction when the persist occurred (save currently still performs the insert).
EntityAction | Any action relating to insert/update/delete of an entity instance
EntityDeleteAction |
EntityIdentityInsertAction |
EntityInsertAction |
EntityUpdateAction |

Package org.hibernate.action Description

This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.

Overview Package Class Use Tree Deprecated Index Help


org.hibernate.action Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.action

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.action.BulkOperationCleanupAction (implements org.hibernate.action.Executable, java.io.Serializable)
    • class org.hibernate.action.CollectionAction (implements java.lang.Comparable, org.hibernate.action.Executable, java.io.Serializable)
      • class org.hibernate.action.CollectionRecreateAction
      • class org.hibernate.action.CollectionRemoveAction
      • class org.hibernate.action.CollectionUpdateAction
    • class org.hibernate.action.DelayedPostInsertIdentifier (implements java.io.Serializable)
    • class org.hibernate.action.EntityAction (implements java.lang.Comparable, org.hibernate.action.Executable, java.io.Serializable)
      • class org.hibernate.action.EntityDeleteAction
      • class org.hibernate.action.EntityIdentityInsertAction
      • class org.hibernate.action.EntityInsertAction
      • class org.hibernate.action.EntityUpdateAction

Interface Hierarchy

  • interface org.hibernate.action.Executable


Uses of Package org.hibernate.action (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.action

Packages that use org.hibernate.action
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Classes in org.hibernate.action used by org.hibernate.action
CollectionAction
Any action relating to insert/update/delete of a collection
EntityAction
Any action relating to insert/update/delete of an entity instance
Executable
An operation which may be scheduled for later execution.

Classes in org.hibernate.action used by org.hibernate.engine
BulkOperationCleanupAction
Implementation of BulkOperationCleanupAction.
CollectionRecreateAction
CollectionRemoveAction
CollectionUpdateAction
EntityDeleteAction
EntityIdentityInsertAction
EntityInsertAction
EntityUpdateAction
Executable
An operation which may be scheduled for later execution.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Executable (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.action
Interface Executable

All Known Implementing Classes:
BulkOperationCleanupAction, CollectionAction, EntityAction
public interface Executable

An operation which may be scheduled for later execution. Usually, the operation is a database insert/update/delete, together with required second-level cache management.

Author:
Gavin King

Method Summary
void | afterTransactionCompletion(boolean success) Called after the transaction completes
void | beforeExecutions() Called before executing any actions
void | execute() Execute this action
Serializable[] | getPropertySpaces() What spaces (tables) are affected by this action?
boolean | hasAfterTransactionCompletion() Do we need to retain this instance until after the transaction completes?

Method Detail

beforeExecutions

public void beforeExecutions()
                      throws HibernateException
Called before executing any actions

Throws:
HibernateException

execute

public void execute()
             throws HibernateException
Execute this action

Throws:
HibernateException

hasAfterTransactionCompletion

public boolean hasAfterTransactionCompletion()
Do we need to retain this instance until after the transaction completes?

Returns:
false if this class defines a no-op hasAfterTransactionCompletion()

afterTransactionCompletion

public void afterTransactionCompletion(boolean success)
                                throws HibernateException
Called after the transaction completes

Throws:
HibernateException

getPropertySpaces

public Serializable[] getPropertySpaces()
What spaces (tables) are affected by this action?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BulkOperationCleanupAction (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.action
Class BulkOperationCleanupAction

java.lang.Object
    extended by org.hibernate.action.BulkOperationCleanupAction
All Implemented Interfaces:
Executable, Serializable
public class BulkOperationCleanupAction
extends Object
implements Executable, Serializable

Implementation of BulkOperationCleanupAction.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
BulkOperationCleanupAction(SessionImplementor session, Queryable[] affectedQueryables)
BulkOperationCleanupAction(SessionImplementor session, Set querySpaces)
Create an action that will evict collection and entity regions based on queryspaces (table names).
Method Summary
void | afterTransactionCompletion(boolean success) Called after the transaction completes
void | beforeExecutions() Called before executing any actions
void | execute() Execute this action
Serializable[] | getPropertySpaces() What spaces (tables) are affected by this action?
boolean | hasAfterTransactionCompletion() Do we need to retain this instance until after the transaction completes?
void | init()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BulkOperationCleanupAction

public BulkOperationCleanupAction(SessionImplementor session,
                                  Queryable[] affectedQueryables)

BulkOperationCleanupAction

public BulkOperationCleanupAction(SessionImplementor session,
                                  Set querySpaces)
Create an action that will evict collection and entity regions based on queryspaces (table names). TODO: cache the autodetected information and pass it in instead.

Method Detail

init

public void init()

hasAfterTransactionCompletion

public boolean hasAfterTransactionCompletion()
Description copied from interface: Executable
Do we need to retain this instance until after the transaction completes?

Specified by:
hasAfterTransactionCompletion in interface Executable
Returns:
false if this class defines a no-op hasAfterTransactionCompletion()

afterTransactionCompletion

public void afterTransactionCompletion(boolean success)
                                throws HibernateException
Description copied from interface: Executable
Called after the transaction completes

Specified by:
afterTransactionCompletion in interface Executable
Throws:
HibernateException

getPropertySpaces

public Serializable[] getPropertySpaces()
Description copied from interface: Executable
What spaces (tables) are affected by this action?

Specified by:
getPropertySpaces in interface Executable

beforeExecutions

public void beforeExecutions()
                      throws HibernateException
Description copied from interface: Executable
Called before executing any actions

Specified by:
beforeExecutions in interface Executable
Throws:
HibernateException

execute

public void execute()
             throws HibernateException
Description copied from interface: Executable
Execute this action

Specified by:
execute in interface Executable
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CollectionAction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.action
Class CollectionAction

java.lang.Object
    extended by org.hibernate.action.CollectionAction
All Implemented Interfaces:
Comparable, Executable, Serializable
Direct Known Subclasses:
CollectionRecreateAction, CollectionRemoveAction, CollectionUpdateAction
public abstract class CollectionAction
extends Object
implements Executable, Serializable, Comparable

Any action relating to insert/update/delete of a collection

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
CollectionAction(CollectionPersister persister, PersistentCollection collection, Serializable key, SessionImplementor session)
Method Summary
void | afterTransactionCompletion(boolean success) Called after the transaction completes
void | beforeExecutions() Called before executing any actions
int | compareTo(Object other)
protected void | evict()
protected PersistentCollection | getCollection()
protected Serializable | getKey()
protected CollectionPersister | getPersister()
Serializable[] | getPropertySpaces() What spaces (tables) are affected by this action?
protected SessionImplementor | getSession()
boolean | hasAfterTransactionCompletion() Do we need to retain this instance until after the transaction completes?
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.action.Executable
execute

Constructor Detail

CollectionAction

public CollectionAction(CollectionPersister persister,
                        PersistentCollection collection,
                        Serializable key,
                        SessionImplementor session)
                 throws CacheException
Method Detail

getCollection

protected PersistentCollection getCollection()

afterTransactionCompletion

public void afterTransactionCompletion(boolean success)
                                throws CacheException
Description copied from interface: Executable
Called after the transaction completes

Specified by:
afterTransactionCompletion in interface Executable
Throws:
CacheException

hasAfterTransactionCompletion

public boolean hasAfterTransactionCompletion()
Description copied from interface: Executable
Do we need to retain this instance until after the transaction completes?

Specified by:
hasAfterTransactionCompletion in interface Executable
Returns:
false if this class defines a no-op hasAfterTransactionCompletion()

getPropertySpaces

public Serializable[] getPropertySpaces()
Description copied from interface: Executable
What spaces (tables) are affected by this action?

Specified by:
getPropertySpaces in interface Executable

getPersister

protected final CollectionPersister getPersister()

getKey

protected final Serializable getKey()

getSession

protected final SessionImplementor getSession()

beforeExecutions

public final void beforeExecutions()
                            throws CacheException
Description copied from interface: Executable
Called before executing any actions

Specified by:
beforeExecutions in interface Executable
Throws:
CacheException

evict

protected final void evict()
                    throws CacheException
Throws:
CacheException

toString

public String toString()

compareTo

public int compareTo(Object other)
Specified by:
compareTo in interface Comparable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionRecreateAction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.action
Class CollectionRecreateAction

java.lang.Object
    extended by org.hibernate.action.CollectionAction
        extended by org.hibernate.action.CollectionRecreateAction
All Implemented Interfaces:
Comparable, Executable, Serializable
public final class CollectionRecreateAction
extends CollectionAction

See Also:
Serialized Form

Constructor Summary
CollectionRecreateAction(PersistentCollection collection, CollectionPersister persister, Serializable id, SessionImplementor session)
Method Summary
 void execute()
Execute this action
Methods inherited from class org.hibernate.action.CollectionAction
afterTransactionCompletion, beforeExecutions, compareTo, evict, getCollection, getKey, getPersister, getPropertySpaces, getSession, hasAfterTransactionCompletion, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CollectionRecreateAction

public CollectionRecreateAction(PersistentCollection collection,
                                CollectionPersister persister,
                                Serializable id,
                                SessionImplementor session)
                         throws CacheException
Method Detail

execute

public void execute()
             throws HibernateException
Description copied from interface: Executable
Execute this action

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionRemoveAction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.action
Class CollectionRemoveAction

java.lang.Object
    extended by org.hibernate.action.CollectionAction
        extended by org.hibernate.action.CollectionRemoveAction
All Implemented Interfaces:
Comparable, Executable, Serializable
public final class CollectionRemoveAction
extends CollectionAction

See Also:
Serialized Form

Constructor Summary
CollectionRemoveAction(PersistentCollection collection, CollectionPersister persister, Serializable id, boolean emptySnapshot, SessionImplementor session)
Method Summary
 void execute()
Execute this action
Methods inherited from class org.hibernate.action.CollectionAction
afterTransactionCompletion, beforeExecutions, compareTo, evict, getCollection, getKey, getPersister, getPropertySpaces, getSession, hasAfterTransactionCompletion, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CollectionRemoveAction

public CollectionRemoveAction(PersistentCollection collection,
                              CollectionPersister persister,
                              Serializable id,
                              boolean emptySnapshot,
                              SessionImplementor session)
                       throws CacheException
Method Detail

execute

public void execute()
             throws HibernateException
Description copied from interface: Executable
Execute this action

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionUpdateAction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.action
Class CollectionUpdateAction

java.lang.Object
    extended by org.hibernate.action.CollectionAction
        extended by org.hibernate.action.CollectionUpdateAction
All Implemented Interfaces:
Comparable, Executable, Serializable
public final class CollectionUpdateAction
extends CollectionAction

See Also:
Serialized Form

Constructor Summary
CollectionUpdateAction(PersistentCollection collection, CollectionPersister persister, Serializable id, boolean emptySnapshot, SessionImplementor session)
Method Summary
 void execute()
Execute this action
Methods inherited from class org.hibernate.action.CollectionAction
afterTransactionCompletion, beforeExecutions, compareTo, evict, getCollection, getKey, getPersister, getPropertySpaces, getSession, hasAfterTransactionCompletion, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CollectionUpdateAction

public CollectionUpdateAction(PersistentCollection collection,
                              CollectionPersister persister,
                              Serializable id,
                              boolean emptySnapshot,
                              SessionImplementor session)
                       throws CacheException
Method Detail

execute

public void execute()
             throws HibernateException
Description copied from interface: Executable
Execute this action

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DelayedPostInsertIdentifier (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.action
Class DelayedPostInsertIdentifier

java.lang.Object
    extended by org.hibernate.action.DelayedPostInsertIdentifier
All Implemented Interfaces:
Serializable
public class DelayedPostInsertIdentifier
extends Object
implements Serializable

Acts as a stand-in for an entity identifier which is supposed to be generated on insert (like an IDENTITY column) where the insert needed to be delayed because we were outside a transaction when the persist occurred (save currently still performs the insert).

The stand-in is only used within the PersistenceContext in order to distinguish one instance from another; it is never injected into the entity instance or returned to the client...

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
DelayedPostInsertIdentifier()
Method Summary
boolean | equals(Object o)
int | hashCode()
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DelayedPostInsertIdentifier

public DelayedPostInsertIdentifier()
Method Detail

equals

public boolean equals(Object o)

hashCode

public int hashCode()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityAction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.action
Class EntityAction

java.lang.Object
    extended by org.hibernate.action.EntityAction
All Implemented Interfaces:
Comparable, Executable, Serializable
Direct Known Subclasses:
EntityDeleteAction, EntityIdentityInsertAction, EntityInsertAction, EntityUpdateAction
public abstract class EntityAction
extends Object
implements Executable, Serializable, Comparable

Any action relating to insert/update/delete of an entity instance

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected EntityAction(SessionImplementor session, Serializable id, Object instance, EntityPersister persister)
Method Summary
void | beforeExecutions() Called before executing any actions
int | compareTo(Object other)
protected Serializable | getId()
protected Object | getInstance()
protected EntityPersister | getPersister()
Serializable[] | getPropertySpaces() What spaces (tables) are affected by this action?
protected SessionImplementor | getSession()
boolean | hasAfterTransactionCompletion() Do we need to retain this instance until after the transaction completes?
protected abstract boolean | hasPostCommitEventListeners()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.action.Executable
afterTransactionCompletion, execute

Constructor Detail

EntityAction

protected EntityAction(SessionImplementor session,
                       Serializable id,
                       Object instance,
                       EntityPersister persister)
Method Detail

getPropertySpaces

public final Serializable[] getPropertySpaces()
Description copied from interface: Executable
What spaces (tables) are affected by this action?

Specified by:
getPropertySpaces in interface Executable

getSession

protected final SessionImplementor getSession()

getId

protected final Serializable getId()

getPersister

protected final EntityPersister getPersister()

getInstance

protected final Object getInstance()

beforeExecutions

public void beforeExecutions()
Description copied from interface: Executable
Called before executing any actions

Specified by:
beforeExecutions in interface Executable

hasAfterTransactionCompletion

public boolean hasAfterTransactionCompletion()
Description copied from interface: Executable
Do we need to retain this instance until after the transaction completes?

Specified by:
hasAfterTransactionCompletion in interface Executable
Returns:
false if this class defines a no-op hasAfterTransactionCompletion()

hasPostCommitEventListeners

protected abstract boolean hasPostCommitEventListeners()

toString

public String toString()

compareTo

public int compareTo(Object other)
Specified by:
compareTo in interface Comparable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityDeleteAction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.action
Class EntityDeleteAction

java.lang.Object
    extended by org.hibernate.action.EntityAction
        extended by org.hibernate.action.EntityDeleteAction
All Implemented Interfaces:
Comparable, Executable, Serializable
public final class EntityDeleteAction
extends EntityAction

See Also:
Serialized Form

Constructor Summary
EntityDeleteAction(Serializable id, Object[] state, Object version, Object instance, EntityPersister persister, boolean isCascadeDeleteEnabled, SessionImplementor session)
Method Summary
void | afterTransactionCompletion(boolean success) Called after the transaction completes
void | execute() Execute this action
protected boolean | hasPostCommitEventListeners()
Methods inherited from class org.hibernate.action.EntityAction
beforeExecutions, compareTo, getId, getInstance, getPersister, getPropertySpaces, getSession, hasAfterTransactionCompletion, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EntityDeleteAction

public EntityDeleteAction(Serializable id,
                          Object[] state,
                          Object version,
                          Object instance,
                          EntityPersister persister,
                          boolean isCascadeDeleteEnabled,
                          SessionImplementor session)
Method Detail

execute

public void execute()
             throws HibernateException
Description copied from interface: Executable
Execute this action

Throws:
HibernateException

afterTransactionCompletion

public void afterTransactionCompletion(boolean success)
                                throws HibernateException
Description copied from interface: Executable
Called after the transaction completes

Throws:
HibernateException

hasPostCommitEventListeners

protected boolean hasPostCommitEventListeners()
Specified by:
hasPostCommitEventListeners in class EntityAction
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityIdentityInsertAction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.action
Class EntityIdentityInsertAction

java.lang.Object
    extended by org.hibernate.action.EntityAction
        extended by org.hibernate.action.EntityIdentityInsertAction
All Implemented Interfaces:
Comparable, Executable, Serializable
public final class EntityIdentityInsertAction
extends EntityAction

See Also:
Serialized Form

Constructor Summary
EntityIdentityInsertAction(Object[] state, Object instance, EntityPersister persister, SessionImplementor session, boolean isDelayed)
Method Summary
void | afterTransactionCompletion(boolean success) Called after the transaction completes
void | execute() Execute this action
EntityKey | getDelayedEntityKey()
Serializable | getGeneratedId()
boolean | hasAfterTransactionCompletion() Do we need to retain this instance until after the transaction completes?
protected boolean | hasPostCommitEventListeners()
Methods inherited from class org.hibernate.action.EntityAction
beforeExecutions, compareTo, getId, getInstance, getPersister, getPropertySpaces, getSession, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EntityIdentityInsertAction

public EntityIdentityInsertAction(Object[] state,
                                  Object instance,
                                  EntityPersister persister,
                                  SessionImplementor session,
                                  boolean isDelayed)
                           throws HibernateException
Method Detail

execute

public void execute()
             throws HibernateException
Description copied from interface: Executable
Execute this action

Throws:
HibernateException

afterTransactionCompletion

public void afterTransactionCompletion(boolean success)
                                throws HibernateException
Description copied from interface: Executable
Called after the transaction completes

Throws:
HibernateException

hasAfterTransactionCompletion

public boolean hasAfterTransactionCompletion()
Description copied from interface: Executable
Do we need to retain this instance until after the transaction completes?

Specified by:
hasAfterTransactionCompletion in interface Executable
Overrides:
hasAfterTransactionCompletion in class EntityAction

hasPostCommitEventListeners

protected boolean hasPostCommitEventListeners()
Specified by:
hasPostCommitEventListeners in class EntityAction

getGeneratedId

public final Serializable getGeneratedId()

getDelayedEntityKey

public EntityKey getDelayedEntityKey()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityInsertAction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.action
Class EntityInsertAction

java.lang.Object
    extended by org.hibernate.action.EntityAction
        extended by org.hibernate.action.EntityInsertAction
All Implemented Interfaces:
Comparable, Executable, Serializable
public final class EntityInsertAction
extends EntityAction

See Also:
Serialized Form

Constructor Summary
EntityInsertAction(Serializable id, Object[] state, Object instance, Object version, EntityPersister persister, SessionImplementor session)
Method Summary
void | afterTransactionCompletion(boolean success) Called after the transaction completes
void | execute() Execute this action
protected boolean | hasPostCommitEventListeners()
Methods inherited from class org.hibernate.action.EntityAction
beforeExecutions, compareTo, getId, getInstance, getPersister, getPropertySpaces, getSession, hasAfterTransactionCompletion, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EntityInsertAction

public EntityInsertAction(Serializable id,
                          Object[] state,
                          Object instance,
                          Object version,
                          EntityPersister persister,
                          SessionImplementor session)
                   throws HibernateException
Method Detail

execute

public void execute()
             throws HibernateException
Description copied from interface: Executable
Execute this action

Throws:
HibernateException

afterTransactionCompletion

public void afterTransactionCompletion(boolean success)
                                throws HibernateException
Description copied from interface: Executable
Called after the transaction completes

Throws:
HibernateException

hasPostCommitEventListeners

protected boolean hasPostCommitEventListeners()
Specified by:
hasPostCommitEventListeners in class EntityAction
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityUpdateAction (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.action
Class EntityUpdateAction

java.lang.Object
    extended by org.hibernate.action.EntityAction
        extended by org.hibernate.action.EntityUpdateAction
All Implemented Interfaces:
Comparable, Executable, Serializable
public final class EntityUpdateAction
extends EntityAction

See Also:
Serialized Form

Constructor Summary
EntityUpdateAction(Serializable id, Object[] state, int[] dirtyProperties, boolean hasDirtyCollection, Object[] previousState, Object previousVersion, Object nextVersion, Object instance, Object rowId, EntityPersister persister, SessionImplementor session)
Method Summary
void | afterTransactionCompletion(boolean success) Called after the transaction completes
void | execute() Execute this action
protected boolean | hasPostCommitEventListeners()
Methods inherited from class org.hibernate.action.EntityAction
beforeExecutions, compareTo, getId, getInstance, getPersister, getPropertySpaces, getSession, hasAfterTransactionCompletion, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EntityUpdateAction

public EntityUpdateAction(Serializable id,
                          Object[] state,
                          int[] dirtyProperties,
                          boolean hasDirtyCollection,
                          Object[] previousState,
                          Object previousVersion,
                          Object nextVersion,
                          Object instance,
                          Object rowId,
                          EntityPersister persister,
                          SessionImplementor session)
                   throws HibernateException
Method Detail

execute

public void execute()
             throws HibernateException
Description copied from interface: Executable
Execute this action

Throws:
HibernateException

afterTransactionCompletion

public void afterTransactionCompletion(boolean success)
                                throws CacheException
Description copied from interface: Executable
Called after the transaction completes

Throws:
CacheException

hasPostCommitEventListeners

protected boolean hasPostCommitEventListeners()
Specified by:
hasPostCommitEventListeners in class EntityAction
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.bytecode (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.bytecode

This package defines the API for plugging in bytecode libraries for usage by Hibernate.

See:
Description

Interface Summary
BasicProxyFactory | A proxy factory for "basic proxy" generation
BytecodeProvider | Contract for providers of bytecode services to Hibernate.
ClassTransformer | A persistence provider provides an instance of this interface to the PersistenceUnitInfo.addTransformer method.
ProxyFactoryFactory | An interface for factories of proxy factory instances.
ReflectionOptimizer | Represents reflection optimization for a particular class.
ReflectionOptimizer.AccessOptimizer | Represents optimized entity property access.
ReflectionOptimizer.InstantiationOptimizer | Represents optimized entity instantiation.

Class Summary
AbstractClassTransformerImpl |
InstrumentedClassLoader | A specialized classloader which performs bytecode enhancement on class definitions as they are loaded into the classloader scope.

Package org.hibernate.bytecode Description

This package defines the API for plugging in bytecode libraries for usage by Hibernate. Hibernate uses these bytecode libraries in three scenarios:

  1. Reflection optimization - to speed up the performance of POJO entity and component conctruction and field/property access
  2. Proxy generation - runtime building of proxies used for deferred loading of lazy entities
  3. Field-level interception - build-time instrumentation of entity classes for the purpose of intercepting field-level access (read/write) for both lazy loading and dirty tracking.

Currently, both CGLIB and Javassist are supported out-of-the-box.

Note that for field-level interception, simply plugging in a new BytecodeProvider is not enough for Hibernate to be able to recognize new providers. You would additionally need to make appropriate code changes to the org.hibernate.intercept.Helper class. This is because the detection of these enhanced classes is needed in a static environment (i.e. outside the scope of any SessionFactory.

Note that in the current form the ability to specify a different bytecode provider is actually considered a global settings (global to the JVM).


org.hibernate.bytecode Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.bytecode

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.bytecode.AbstractClassTransformerImpl (implements org.hibernate.bytecode.ClassTransformer)
    • class java.lang.ClassLoader
      • class org.hibernate.bytecode.InstrumentedClassLoader

Interface Hierarchy

  • interface org.hibernate.bytecode.BasicProxyFactory
  • interface org.hibernate.bytecode.BytecodeProvider
  • interface org.hibernate.bytecode.ClassTransformer
  • interface org.hibernate.bytecode.ProxyFactoryFactory
  • interface org.hibernate.bytecode.ReflectionOptimizer
  • interface org.hibernate.bytecode.ReflectionOptimizer.AccessOptimizer
  • interface org.hibernate.bytecode.ReflectionOptimizer.InstantiationOptimizer


Uses of Package org.hibernate.bytecode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.bytecode

Packages that use org.hibernate.bytecode
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.bytecode.javassist |
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.tool.instrument | The instrument tool for adding field-interception hooks to persistent classes using built-time bytecode processing.
org.hibernate.tool.instrument.cglib |
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.

Classes in org.hibernate.bytecode used by org.hibernate.bytecode
BasicProxyFactory
A proxy factory for "basic proxy" generation
ClassTransformer
A persistence provider provides an instance of this interface to the PersistenceUnitInfo.addTransformer method.
ProxyFactoryFactory
An interface for factories of proxy factory instances.
ReflectionOptimizer
Represents reflection optimization for a particular class.
ReflectionOptimizer.AccessOptimizer
Represents optimized entity property access.
ReflectionOptimizer.InstantiationOptimizer
Represents optimized entity instantiation.

Classes in org.hibernate.bytecode used by org.hibernate.bytecode.cglib
AbstractClassTransformerImpl
BasicProxyFactory
A proxy factory for "basic proxy" generation
BytecodeProvider
Contract for providers of bytecode services to Hibernate.
ClassTransformer
A persistence provider provides an instance of this interface to the PersistenceUnitInfo.addTransformer method.
ProxyFactoryFactory
An interface for factories of proxy factory instances.
ReflectionOptimizer
Represents reflection optimization for a particular class.
ReflectionOptimizer.AccessOptimizer
Represents optimized entity property access.
ReflectionOptimizer.InstantiationOptimizer
Represents optimized entity instantiation.

Classes in org.hibernate.bytecode used by org.hibernate.bytecode.javassist
AbstractClassTransformerImpl
ClassTransformer
A persistence provider provides an instance of this interface to the PersistenceUnitInfo.addTransformer method.

Classes in org.hibernate.bytecode used by org.hibernate.cfg
BytecodeProvider
Contract for providers of bytecode services to Hibernate.

Classes in org.hibernate.bytecode used by org.hibernate.tool.instrument
ClassTransformer
A persistence provider provides an instance of this interface to the PersistenceUnitInfo.addTransformer method.

Classes in org.hibernate.bytecode used by org.hibernate.tool.instrument.cglib
ClassTransformer
A persistence provider provides an instance of this interface to the PersistenceUnitInfo.addTransformer method.

Classes in org.hibernate.bytecode used by org.hibernate.tuple
ReflectionOptimizer.InstantiationOptimizer
Represents optimized entity instantiation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BasicProxyFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode
Interface BasicProxyFactory

All Known Implementing Classes:
ProxyFactoryFactoryImpl.BasicProxyFactoryImpl
public interface BasicProxyFactory

A proxy factory for "basic proxy" generation

Author:
Steve Ebersole

Method Summary
 Object getProxy()

Method Detail

getProxy

public Object getProxy()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BytecodeProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode
Interface BytecodeProvider

All Known Implementing Classes:
BytecodeProviderImpl, BytecodeProviderImpl
public interface BytecodeProvider

Contract for providers of bytecode services to Hibernate.

Bytecode requirements break down into basically 3 areas

  1. proxy generation (both for runtime-lazy-loading and basic proxy generation) getProxyFactoryFactory()
  2. bean relection optimization getReflectionOptimizer(java.lang.Class, java.lang.String[], java.lang.String[], java.lang.Class[])
  3. field-access instumentation getTransformer(org.hibernate.bytecode.util.ClassFilter, org.hibernate.bytecode.util.FieldFilter)

Author:
Steve Ebersole

Method Summary
ProxyFactoryFactory | getProxyFactoryFactory() Retrieve the specific factory for this provider capable of generating run-time proxies for lazy-loading purposes.
ReflectionOptimizer | getReflectionOptimizer(Class clazz, String[] getterNames, String[] setterNames, Class[] types) Retrieve the ReflectionOptimizer delegate for this provider capable of generating reflection optimization components.
ClassTransformer | getTransformer(ClassFilter classFilter, FieldFilter fieldFilter) Generate a ClassTransformer capable of performing bytecode manipulation.

Method Detail

getProxyFactoryFactory

public ProxyFactoryFactory getProxyFactoryFactory()
Retrieve the specific factory for this provider capable of generating run-time proxies for lazy-loading purposes.

Returns:
The provider specifc factory.

getReflectionOptimizer

public ReflectionOptimizer getReflectionOptimizer(Class clazz,
                                                  String[] getterNames,
                                                  String[] setterNames,
                                                  Class[] types)
Retrieve the ReflectionOptimizer delegate for this provider capable of generating reflection optimization components.

Parameters:
clazz - The class to be reflected upon.
getterNames - Names of all property getters to be accessed via reflection.
setterNames - Names of all property setters to be accessed via reflection.
types - The types of all properties to be accessed.
Returns:
The reflection optimization delegate.

getTransformer

public ClassTransformer getTransformer(ClassFilter classFilter,
                                       FieldFilter fieldFilter)
Generate a ClassTransformer capable of performing bytecode manipulation.

Parameters:
classFilter - filter used to limit which classes are to be instrumented via this ClassTransformer.
fieldFilter - filter used to limit which fields are to be instrumented via this ClassTransformer.
Returns:
The appropriate ClassTransformer.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassTransformer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode
Interface ClassTransformer

All Known Implementing Classes:
AbstractClassTransformerImpl
public interface ClassTransformer

A persistence provider provides an instance of this interface to the PersistenceUnitInfo.addTransformer method. The supplied transformer instance will get called to transform entity class files when they are loaded and redefined. The transformation occurs before the class is defined by the JVM

Author:
Bill Burke, Emmanuel Bernard

Method Summary
 byte[] transform(ClassLoader loader, String classname, Class classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
Invoked when a class is being loaded or redefined to add hooks for persistence bytecode manipulation

Method Detail

transform

public byte[] transform(ClassLoader loader,
                        String classname,
                        Class classBeingRedefined,
                        ProtectionDomain protectionDomain,
                        byte[] classfileBuffer)
Invoked when a class is being loaded or redefined to add hooks for persistence bytecode manipulation

Parameters:
loader - the defining class loaderof the class being transformed. It may be null if using bootstrap loader
classname - The name of the class being transformed
classBeingRedefined - If an already loaded class is being redefined, then pass this as a parameter
protectionDomain - ProtectionDomain of the class being (re)-defined
classfileBuffer - The input byte buffer in class file format
Returns:
A well-formed class file that can be loaded
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyFactoryFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode
Interface ProxyFactoryFactory

All Known Implementing Classes:
ProxyFactoryFactoryImpl, ProxyFactoryFactoryImpl
public interface ProxyFactoryFactory

An interface for factories of proxy factory instances.

Currently used to abstract from the tupizer whether we are using CGLIB or Javassist for lazy proxy generation.

Author:
Steve Ebersole

Method Summary
BasicProxyFactory | buildBasicProxyFactory(Class superClass, Class[] interfaces) Build a proxy factory for basic proxy concerns.
ProxyFactory | buildProxyFactory() Build a proxy factory specifically for handling runtime lazy loading.

Method Detail

buildProxyFactory

public ProxyFactory buildProxyFactory()
Build a proxy factory specifically for handling runtime lazy loading.

Returns:
The lazy-load proxy factory.

buildBasicProxyFactory

public BasicProxyFactory buildBasicProxyFactory(Class superClass,
                                                Class[] interfaces)
Build a proxy factory for basic proxy concerns. The return should be capable of properly handling newInstance() calls.

Should build basic proxies essentially equivalent to JDK proxies in terms of capabilities, but should be able to deal with abstract super classes in addition to proxy interfaces.

Must pass in either superClass or interfaces (or both).

Parameters:
superClass - The abstract super class (or null if none).
interfaces - Interfaces to be proxied (or null if none).
Returns:
The proxy class
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReflectionOptimizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode
Interface ReflectionOptimizer

All Known Implementing Classes:
ReflectionOptimizerImpl, ReflectionOptimizerImpl
public interface ReflectionOptimizer

Represents reflection optimization for a particular class.

Author:
Steve Ebersole

Nested Class Summary
static interface | ReflectionOptimizer.AccessOptimizer Represents optimized entity property access.
static interface | ReflectionOptimizer.InstantiationOptimizer Represents optimized entity instantiation.
Method Summary
ReflectionOptimizer.AccessOptimizer | getAccessOptimizer()
ReflectionOptimizer.InstantiationOptimizer | getInstantiationOptimizer()

Method Detail

getInstantiationOptimizer

public ReflectionOptimizer.InstantiationOptimizer getInstantiationOptimizer()

getAccessOptimizer

public ReflectionOptimizer.AccessOptimizer getAccessOptimizer()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReflectionOptimizer.AccessOptimizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode
Interface ReflectionOptimizer.AccessOptimizer

All Known Implementing Classes:
AccessOptimizerAdapter, AccessOptimizerAdapter
Enclosing interface:
ReflectionOptimizer
public static interface ReflectionOptimizer.AccessOptimizer

Represents optimized entity property access.

Author:
Steve Ebersole

Method Summary
String[] | getPropertyNames()
Object[] | getPropertyValues(Object object)
void | setPropertyValues(Object object, Object[] values)

Method Detail

getPropertyNames

public String[] getPropertyNames()

getPropertyValues

public Object[] getPropertyValues(Object object)

setPropertyValues

public void setPropertyValues(Object object,
                              Object[] values)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReflectionOptimizer.InstantiationOptimizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode
Interface ReflectionOptimizer.InstantiationOptimizer

All Known Implementing Classes:
InstantiationOptimizerAdapter, InstantiationOptimizerAdapter
Enclosing interface:
ReflectionOptimizer
public static interface ReflectionOptimizer.InstantiationOptimizer

Represents optimized entity instantiation.

Method Summary
 Object newInstance()
Perform instantiation of an instance of the underlying class.

Method Detail

newInstance

public Object newInstance()
Perform instantiation of an instance of the underlying class.

Returns:
The new instance.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractClassTransformerImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode
Class AbstractClassTransformerImpl

java.lang.Object
    extended by org.hibernate.bytecode.AbstractClassTransformerImpl
All Implemented Interfaces:
ClassTransformer
Direct Known Subclasses:
CglibClassTransformer, JavassistClassTransformer
public abstract class AbstractClassTransformerImpl
extends Object
implements ClassTransformer

Author:
Emmanuel Bernard, Steve Ebersole

Field Summary
protected ClassFilter | classFilter
protected FieldFilter | fieldFilter
Constructor Summary
protected AbstractClassTransformerImpl(ClassFilter classFilter, FieldFilter fieldFilter)
Method Summary
protected abstract byte[] | doTransform(ClassLoader loader, String className, Class classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
byte[] | transform(ClassLoader loader, String className, Class classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer) Invoked when a class is being loaded or redefined to add hooks for persistence bytecode manipulation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

classFilter

protected final ClassFilter classFilter

fieldFilter

protected final FieldFilter fieldFilter
Constructor Detail

AbstractClassTransformerImpl

protected AbstractClassTransformerImpl(ClassFilter classFilter,
                                       FieldFilter fieldFilter)
Method Detail

transform

public byte[] transform(ClassLoader loader,
                        String className,
                        Class classBeingRedefined,
                        ProtectionDomain protectionDomain,
                        byte[] classfileBuffer)
Description copied from interface: ClassTransformer
Invoked when a class is being loaded or redefined to add hooks for persistence bytecode manipulation

Specified by:
transform in interface ClassTransformer
Parameters:
loader - the defining class loaderof the class being transformed. It may be null if using bootstrap loader
className - The name of the class being transformed
classBeingRedefined - If an already loaded class is being redefined, then pass this as a parameter
protectionDomain - ProtectionDomain of the class being (re)-defined
classfileBuffer - The input byte buffer in class file format
Returns:
A well-formed class file that can be loaded

doTransform

protected abstract byte[] doTransform(ClassLoader loader,
                                      String className,
                                      Class classBeingRedefined,
                                      ProtectionDomain protectionDomain,
                                      byte[] classfileBuffer)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InstrumentedClassLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode
Class InstrumentedClassLoader

java.lang.Object
    extended by java.lang.ClassLoader
        extended by org.hibernate.bytecode.InstrumentedClassLoader
public class InstrumentedClassLoader
extends ClassLoader

A specialized classloader which performs bytecode enhancement on class definitions as they are loaded into the classloader scope.

Author:
Emmanuel Bernard, Steve Ebersole

Constructor Summary
InstrumentedClassLoader(ClassLoader parent, ClassTransformer classTransformer)
Method Summary
 Class loadClass(String name)
Methods inherited from class java.lang.ClassLoader
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findClass, findLibrary, findLoadedClass, findResource, findResources, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InstrumentedClassLoader

public InstrumentedClassLoader(ClassLoader parent,
                               ClassTransformer classTransformer)
Method Detail

loadClass

public Class loadClass(String name)
                throws ClassNotFoundException
Throws:
ClassNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.bytecode.cglib (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.bytecode.cglib

Class Summary
AccessOptimizerAdapter | The ReflectionOptimizer.AccessOptimizer implementation for CGLIB which simply acts as an adpater to the BulkBean class.
BytecodeProviderImpl | Bytecode provider implementation for CGLIB.
CglibClassTransformer | Enhance the classes allowing them to implements InterceptFieldEnabled This interface is then used by Hibernate for some optimizations.
InstantiationOptimizerAdapter | The ReflectionOptimizer.InstantiationOptimizer implementation for CGLIB which simply acts as an adpater to the FastClass class.
ProxyFactoryFactoryImpl | A factory for CGLIB-based ProxyFactory instances.
ProxyFactoryFactoryImpl.BasicProxyFactoryImpl |
ReflectionOptimizerImpl | ReflectionOptimizer implementation for CGLIB.


org.hibernate.bytecode.cglib Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.bytecode.cglib

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.bytecode.AbstractClassTransformerImpl (implements org.hibernate.bytecode.ClassTransformer)
      • class org.hibernate.bytecode.cglib.CglibClassTransformer
    • class org.hibernate.bytecode.cglib.AccessOptimizerAdapter (implements org.hibernate.bytecode.ReflectionOptimizer.AccessOptimizer, java.io.Serializable)
    • class org.hibernate.bytecode.cglib.BytecodeProviderImpl (implements org.hibernate.bytecode.BytecodeProvider)
    • class org.hibernate.bytecode.cglib.InstantiationOptimizerAdapter (implements org.hibernate.bytecode.ReflectionOptimizer.InstantiationOptimizer, java.io.Serializable)
    • class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl (implements org.hibernate.bytecode.ProxyFactoryFactory)
    • class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl.BasicProxyFactoryImpl (implements org.hibernate.bytecode.BasicProxyFactory)
    • class org.hibernate.bytecode.cglib.ReflectionOptimizerImpl (implements org.hibernate.bytecode.ReflectionOptimizer, java.io.Serializable)


Uses of Package org.hibernate.bytecode.cglib (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.bytecode.cglib

Packages that use org.hibernate.bytecode.cglib
org.hibernate.bytecode.cglib

Classes in org.hibernate.bytecode.cglib used by org.hibernate.bytecode.cglib
AccessOptimizerAdapter
The ReflectionOptimizer.AccessOptimizer implementation for CGLIB which simply acts as an adpater to the BulkBean class.
InstantiationOptimizerAdapter
The ReflectionOptimizer.InstantiationOptimizer implementation for CGLIB which simply acts as an adpater to the FastClass class.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AccessOptimizerAdapter (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.cglib
Class AccessOptimizerAdapter

java.lang.Object
    extended by org.hibernate.bytecode.cglib.AccessOptimizerAdapter
All Implemented Interfaces:
ReflectionOptimizer.AccessOptimizer, Serializable
public class AccessOptimizerAdapter
extends Object
implements ReflectionOptimizer.AccessOptimizer, Serializable

The ReflectionOptimizer.AccessOptimizer implementation for CGLIB which simply acts as an adpater to the BulkBean class.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
static String | PROPERTY_GET_EXCEPTION
static String | PROPERTY_SET_EXCEPTION
Constructor Summary
AccessOptimizerAdapter(net.sf.cglib.beans.BulkBean bulkBean, Class mappedClass)
Method Summary
String[] | getPropertyNames()
Object[] | getPropertyValues(Object object)
void | setPropertyValues(Object object, Object[] values)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PROPERTY_GET_EXCEPTION

public static final String PROPERTY_GET_EXCEPTION
See Also:
Constant Field Values

PROPERTY_SET_EXCEPTION

public static final String PROPERTY_SET_EXCEPTION
See Also:
Constant Field Values
Constructor Detail

AccessOptimizerAdapter

public AccessOptimizerAdapter(net.sf.cglib.beans.BulkBean bulkBean,
                              Class mappedClass)
Method Detail

getPropertyNames

public String[] getPropertyNames()
Specified by:
getPropertyNames in interface ReflectionOptimizer.AccessOptimizer

getPropertyValues

public Object[] getPropertyValues(Object object)
Specified by:
getPropertyValues in interface ReflectionOptimizer.AccessOptimizer

setPropertyValues

public void setPropertyValues(Object object,
                              Object[] values)
Specified by:
setPropertyValues in interface ReflectionOptimizer.AccessOptimizer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BytecodeProviderImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.cglib
Class BytecodeProviderImpl

java.lang.Object
    extended by org.hibernate.bytecode.cglib.BytecodeProviderImpl
All Implemented Interfaces:
BytecodeProvider
public class BytecodeProviderImpl
extends Object
implements BytecodeProvider

Bytecode provider implementation for CGLIB.

Author:
Steve Ebersole

Constructor Summary
BytecodeProviderImpl()
Method Summary
ProxyFactoryFactory | getProxyFactoryFactory() Retrieve the specific factory for this provider capable of generating run-time proxies for lazy-loading purposes.
ReflectionOptimizer | getReflectionOptimizer(Class clazz, String[] getterNames, String[] setterNames, Class[] types) Retrieve the ReflectionOptimizer delegate for this provider capable of generating reflection optimization components.
ClassTransformer | getTransformer(ClassFilter classFilter, FieldFilter fieldFilter) Generate a ClassTransformer capable of performing bytecode manipulation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BytecodeProviderImpl

public BytecodeProviderImpl()
Method Detail

getProxyFactoryFactory

public ProxyFactoryFactory getProxyFactoryFactory()
Description copied from interface: BytecodeProvider
Retrieve the specific factory for this provider capable of generating run-time proxies for lazy-loading purposes.

Specified by:
getProxyFactoryFactory in interface BytecodeProvider
Returns:
The provider specifc factory.

getReflectionOptimizer

public ReflectionOptimizer getReflectionOptimizer(Class clazz,
                                                  String[] getterNames,
                                                  String[] setterNames,
                                                  Class[] types)
Description copied from interface: BytecodeProvider
Retrieve the ReflectionOptimizer delegate for this provider capable of generating reflection optimization components.

Specified by:
getReflectionOptimizer in interface BytecodeProvider
Parameters:
clazz - The class to be reflected upon.
getterNames - Names of all property getters to be accessed via reflection.
setterNames - Names of all property setters to be accessed via reflection.
types - The types of all properties to be accessed.
Returns:
The reflection optimization delegate.

getTransformer

public ClassTransformer getTransformer(ClassFilter classFilter,
                                       FieldFilter fieldFilter)
Description copied from interface: BytecodeProvider
Generate a ClassTransformer capable of performing bytecode manipulation.

Specified by:
getTransformer in interface BytecodeProvider
Parameters:
classFilter - filter used to limit which classes are to be instrumented via this ClassTransformer.
fieldFilter - filter used to limit which fields are to be instrumented via this ClassTransformer.
Returns:
The appropriate ClassTransformer.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CglibClassTransformer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.cglib
Class CglibClassTransformer

java.lang.Object
    extended by org.hibernate.bytecode.AbstractClassTransformerImpl
        extended by org.hibernate.bytecode.cglib.CglibClassTransformer
All Implemented Interfaces:
ClassTransformer
public class CglibClassTransformer
extends AbstractClassTransformerImpl

Enhance the classes allowing them to implements InterceptFieldEnabled This interface is then used by Hibernate for some optimizations.

Author:
Emmanuel Bernard, Steve Ebersole

Field Summary
Fields inherited from class org.hibernate.bytecode.AbstractClassTransformerImpl
classFilter, fieldFilter
Constructor Summary
CglibClassTransformer(ClassFilter classFilter, FieldFilter fieldFilter)
Method Summary
protected  byte[] doTransform(ClassLoader loader, String className, Class classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
Methods inherited from class org.hibernate.bytecode.AbstractClassTransformerImpl
transform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CglibClassTransformer

public CglibClassTransformer(ClassFilter classFilter,
                             FieldFilter fieldFilter)
Method Detail

doTransform

protected byte[] doTransform(ClassLoader loader,
                             String className,
                             Class classBeingRedefined,
                             ProtectionDomain protectionDomain,
                             byte[] classfileBuffer)
Specified by:
doTransform in class AbstractClassTransformerImpl
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InstantiationOptimizerAdapter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.cglib
Class InstantiationOptimizerAdapter

java.lang.Object
    extended by org.hibernate.bytecode.cglib.InstantiationOptimizerAdapter
All Implemented Interfaces:
ReflectionOptimizer.InstantiationOptimizer, Serializable
public class InstantiationOptimizerAdapter
extends Object
implements ReflectionOptimizer.InstantiationOptimizer, Serializable

The ReflectionOptimizer.InstantiationOptimizer implementation for CGLIB which simply acts as an adpater to the FastClass class.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
InstantiationOptimizerAdapter(net.sf.cglib.reflect.FastClass fastClass)
Method Summary
 Object newInstance()
Perform instantiation of an instance of the underlying class.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InstantiationOptimizerAdapter

public InstantiationOptimizerAdapter(net.sf.cglib.reflect.FastClass fastClass)
Method Detail

newInstance

public Object newInstance()
Description copied from interface: ReflectionOptimizer.InstantiationOptimizer
Perform instantiation of an instance of the underlying class.

Specified by:
newInstance in interface ReflectionOptimizer.InstantiationOptimizer
Returns:
The new instance.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyFactoryFactoryImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.cglib
Class ProxyFactoryFactoryImpl

java.lang.Object
    extended by org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl
All Implemented Interfaces:
ProxyFactoryFactory
public class ProxyFactoryFactoryImpl
extends Object
implements ProxyFactoryFactory

A factory for CGLIB-based ProxyFactory instances.

Author:
Steve Ebersole

Nested Class Summary
static class ProxyFactoryFactoryImpl.BasicProxyFactoryImpl
Constructor Summary
ProxyFactoryFactoryImpl()
Method Summary
BasicProxyFactory | buildBasicProxyFactory(Class superClass, Class[] interfaces) Build a proxy factory for basic proxy concerns.
ProxyFactory | buildProxyFactory() Builds a CGLIB-based proxy factory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProxyFactoryFactoryImpl

public ProxyFactoryFactoryImpl()
Method Detail

buildProxyFactory

public ProxyFactory buildProxyFactory()
Builds a CGLIB-based proxy factory.

Specified by:
buildProxyFactory in interface ProxyFactoryFactory
Returns:
a new CGLIB-based proxy factory.

buildBasicProxyFactory

public BasicProxyFactory buildBasicProxyFactory(Class superClass,
                                                Class[] interfaces)
Description copied from interface: ProxyFactoryFactory
Build a proxy factory for basic proxy concerns. The return should be capable of properly handling newInstance() calls.

Should build basic proxies essentially equivalent to JDK proxies in terms of capabilities, but should be able to deal with abstract super classes in addition to proxy interfaces.

Must pass in either superClass or interfaces (or both).

Specified by:
buildBasicProxyFactory in interface ProxyFactoryFactory
Parameters:
superClass - The abstract super class (or null if none).
interfaces - Interfaces to be proxied (or null if none).
Returns:
The proxy class
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyFactoryFactoryImpl.BasicProxyFactoryImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.cglib
Class ProxyFactoryFactoryImpl.BasicProxyFactoryImpl

java.lang.Object
    extended by org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl.BasicProxyFactoryImpl
All Implemented Interfaces:
BasicProxyFactory
Enclosing class:
ProxyFactoryFactoryImpl
public static class ProxyFactoryFactoryImpl.BasicProxyFactoryImpl
extends Object
implements BasicProxyFactory

Constructor Summary
ProxyFactoryFactoryImpl.BasicProxyFactoryImpl(Class superClass, Class[] interfaces)
Method Summary
 Object getProxy()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProxyFactoryFactoryImpl.BasicProxyFactoryImpl

public ProxyFactoryFactoryImpl.BasicProxyFactoryImpl(Class superClass,
                                                     Class[] interfaces)
Method Detail

getProxy

public Object getProxy()
Specified by:
getProxy in interface BasicProxyFactory
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReflectionOptimizerImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.cglib
Class ReflectionOptimizerImpl

java.lang.Object
    extended by org.hibernate.bytecode.cglib.ReflectionOptimizerImpl
All Implemented Interfaces:
ReflectionOptimizer, Serializable
public class ReflectionOptimizerImpl
extends Object
implements ReflectionOptimizer, Serializable

ReflectionOptimizer implementation for CGLIB.

Author:
Steve Ebersole
See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.bytecode.ReflectionOptimizer
ReflectionOptimizer.AccessOptimizer, ReflectionOptimizer.InstantiationOptimizer
Constructor Summary
ReflectionOptimizerImpl(InstantiationOptimizerAdapter instantiationOptimizer, AccessOptimizerAdapter accessOptimizer)
Method Summary
ReflectionOptimizer.AccessOptimizer | getAccessOptimizer()
ReflectionOptimizer.InstantiationOptimizer | getInstantiationOptimizer()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReflectionOptimizerImpl

public ReflectionOptimizerImpl(InstantiationOptimizerAdapter instantiationOptimizer,
                               AccessOptimizerAdapter accessOptimizer)
Method Detail

getInstantiationOptimizer

public ReflectionOptimizer.InstantiationOptimizer getInstantiationOptimizer()
Specified by:
getInstantiationOptimizer in interface ReflectionOptimizer

getAccessOptimizer

public ReflectionOptimizer.AccessOptimizer getAccessOptimizer()
Specified by:
getAccessOptimizer in interface ReflectionOptimizer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.bytecode.javassist (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.bytecode.javassist

Interface Summary
FieldFilter | Contract for deciding whether fields should be read and/or write intercepted.
FieldHandled | Interface introduced to the enhanced class in order to be able to inject a FieldHandler to define the interception behavior.
FieldHandler | The interface defining how interception of a field should be handled.

Class Summary
AccessOptimizerAdapter | The ReflectionOptimizer.AccessOptimizer implementation for Javassist which simply acts as an adpater to the BulkAccessor class.
BulkAccessor | A JavaBean accessor.
BytecodeProviderImpl | Bytecode provider implementation for Javassist.
FastClass |
FieldTransformer | The thing that handles actual class enhancement in regards to intercepting field accesses.
InstantiationOptimizerAdapter | The ReflectionOptimizer.InstantiationOptimizer implementation for Javassist which simply acts as an adpater to the FastClass class.
JavassistClassTransformer | Enhance the classes allowing them to implements InterceptFieldEnabled This interface is then used by Hibernate for some optimizations.
ProxyFactoryFactoryImpl | A factory for Javassist-based ProxyFactory instances.
ReflectionOptimizerImpl | ReflectionOptimizer implementation for Javassist.
TransformingClassLoader |

Exception Summary
BulkAccessorException An exception thrown while generating a bulk accessor.


org.hibernate.bytecode.javassist Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.bytecode.javassist

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.bytecode.AbstractClassTransformerImpl (implements org.hibernate.bytecode.ClassTransformer)
      • class org.hibernate.bytecode.javassist.JavassistClassTransformer
    • class org.hibernate.bytecode.javassist.AccessOptimizerAdapter (implements org.hibernate.bytecode.ReflectionOptimizer.AccessOptimizer, java.io.Serializable)
    • class org.hibernate.bytecode.javassist.BulkAccessor (implements java.io.Serializable)
    • class org.hibernate.bytecode.javassist.BytecodeProviderImpl (implements org.hibernate.bytecode.BytecodeProvider)
    • class java.lang.ClassLoader
      • class org.hibernate.bytecode.javassist.TransformingClassLoader
    • class org.hibernate.bytecode.javassist.FastClass (implements java.io.Serializable)
    • class org.hibernate.bytecode.javassist.FieldTransformer
    • class org.hibernate.bytecode.javassist.InstantiationOptimizerAdapter (implements org.hibernate.bytecode.ReflectionOptimizer.InstantiationOptimizer, java.io.Serializable)
    • class org.hibernate.bytecode.javassist.ProxyFactoryFactoryImpl (implements org.hibernate.bytecode.ProxyFactoryFactory)
    • class org.hibernate.bytecode.javassist.ReflectionOptimizerImpl (implements org.hibernate.bytecode.ReflectionOptimizer, java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class org.hibernate.bytecode.javassist.BulkAccessorException

Interface Hierarchy

  • interface org.hibernate.bytecode.javassist.FieldFilter
  • interface org.hibernate.bytecode.javassist.FieldHandled
  • interface org.hibernate.bytecode.javassist.FieldHandler


Uses of Package org.hibernate.bytecode.javassist (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.bytecode.javassist

Packages that use org.hibernate.bytecode.javassist
org.hibernate.bytecode.javassist
org.hibernate.intercept.javassist

Classes in org.hibernate.bytecode.javassist used by org.hibernate.bytecode.javassist
BulkAccessor
A JavaBean accessor.
FastClass
FieldFilter
Contract for deciding whether fields should be read and/or write intercepted.
FieldHandler
The interface defining how interception of a field should be handled.
FieldTransformer
The thing that handles actual class enhancement in regards to intercepting field accesses.

Classes in org.hibernate.bytecode.javassist used by org.hibernate.intercept.javassist
FieldHandler
The interface defining how interception of a field should be handled.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


FieldFilter (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Interface FieldFilter

public interface FieldFilter

Contract for deciding whether fields should be read and/or write intercepted.

Author:
Muga Nishizawa

Method Summary
boolean | handleRead(String desc, String name) Should the given field be read intercepted?
boolean | handleWrite(String desc, String name) Should the given field be write intercepted?

Method Detail

handleRead

public boolean handleRead(String desc,
                          String name)
Should the given field be read intercepted?

Parameters:
desc -
name -
Returns:
true if the given field should be read intercepted; otherwise false.

handleWrite

public boolean handleWrite(String desc,
                           String name)
Should the given field be write intercepted?

Parameters:
desc -
name -
Returns:
true if the given field should be write intercepted; otherwise false.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FieldHandled (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Interface FieldHandled

public interface FieldHandled

Interface introduced to the enhanced class in order to be able to inject a FieldHandler to define the interception behavior.

Author:
Muga Nishizawa

Method Summary
FieldHandler | getFieldHandler() Access to the current field interception handler.
void | setFieldHandler(FieldHandler handler) Inject the field interception handler to be used.

Method Detail

setFieldHandler

public void setFieldHandler(FieldHandler handler)
Inject the field interception handler to be used.

Parameters:
handler - The field interception handler.

getFieldHandler

public FieldHandler getFieldHandler()
Access to the current field interception handler.

Returns:
The current field interception handler.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldHandler (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Interface FieldHandler

All Known Implementing Classes:
FieldInterceptorImpl
public interface FieldHandler

The interface defining how interception of a field should be handled.

Author:
Muga Nishizawa

Method Summary
boolean | readBoolean(Object obj, String name, boolean oldValue)
byte | readByte(Object obj, String name, byte oldValue)
char | readChar(Object obj, String name, char oldValue)
double | readDouble(Object obj, String name, double oldValue)
float | readFloat(Object obj, String name, float oldValue)
int | readInt(Object obj, String name, int oldValue)
long | readLong(Object obj, String name, long oldValue)
Object | readObject(Object obj, String name, Object oldValue)
short | readShort(Object obj, String name, short oldValue)
boolean | writeBoolean(Object obj, String name, boolean oldValue, boolean newValue)
byte | writeByte(Object obj, String name, byte oldValue, byte newValue)
char | writeChar(Object obj, String name, char oldValue, char newValue)
double | writeDouble(Object obj, String name, double oldValue, double newValue)
float | writeFloat(Object obj, String name, float oldValue, float newValue)
int | writeInt(Object obj, String name, int oldValue, int newValue) Called to handle writing an int value to a given field.
long | writeLong(Object obj, String name, long oldValue, long newValue)
Object | writeObject(Object obj, String name, Object oldValue, Object newValue)
short | writeShort(Object obj, String name, short oldValue, short newValue)

Method Detail

writeInt

public int writeInt(Object obj,
                    String name,
                    int oldValue,
                    int newValue)
Called to handle writing an int value to a given field.

Parameters:
obj - ?
name - The name of the field being written
oldValue - The old field value
newValue - The new field value.
Returns:
?

writeChar

public char writeChar(Object obj,
                      String name,
                      char oldValue,
                      char newValue)

writeByte

public byte writeByte(Object obj,
                      String name,
                      byte oldValue,
                      byte newValue)

writeBoolean

public boolean writeBoolean(Object obj,
                            String name,
                            boolean oldValue,
                            boolean newValue)

writeShort

public short writeShort(Object obj,
                        String name,
                        short oldValue,
                        short newValue)

writeFloat

public float writeFloat(Object obj,
                        String name,
                        float oldValue,
                        float newValue)

writeDouble

public double writeDouble(Object obj,
                          String name,
                          double oldValue,
                          double newValue)

writeLong

public long writeLong(Object obj,
                      String name,
                      long oldValue,
                      long newValue)

writeObject

public Object writeObject(Object obj,
                          String name,
                          Object oldValue,
                          Object newValue)

readInt

public int readInt(Object obj,
                   String name,
                   int oldValue)

readChar

public char readChar(Object obj,
                     String name,
                     char oldValue)

readByte

public byte readByte(Object obj,
                     String name,
                     byte oldValue)

readBoolean

public boolean readBoolean(Object obj,
                           String name,
                           boolean oldValue)

readShort

public short readShort(Object obj,
                       String name,
                       short oldValue)

readFloat

public float readFloat(Object obj,
                       String name,
                       float oldValue)

readDouble

public double readDouble(Object obj,
                         String name,
                         double oldValue)

readLong

public long readLong(Object obj,
                     String name,
                     long oldValue)

readObject

public Object readObject(Object obj,
                         String name,
                         Object oldValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AccessOptimizerAdapter (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Class AccessOptimizerAdapter

java.lang.Object
    extended by org.hibernate.bytecode.javassist.AccessOptimizerAdapter
All Implemented Interfaces:
ReflectionOptimizer.AccessOptimizer, Serializable
public class AccessOptimizerAdapter
extends Object
implements ReflectionOptimizer.AccessOptimizer, Serializable

The ReflectionOptimizer.AccessOptimizer implementation for Javassist which simply acts as an adpater to the BulkAccessor class.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
static String | PROPERTY_GET_EXCEPTION
static String | PROPERTY_SET_EXCEPTION
Constructor Summary
AccessOptimizerAdapter(BulkAccessor bulkAccessor, Class mappedClass)
Method Summary
String[] | getPropertyNames()
Object[] | getPropertyValues(Object object)
void | setPropertyValues(Object object, Object[] values)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PROPERTY_GET_EXCEPTION

public static final String PROPERTY_GET_EXCEPTION
See Also:
Constant Field Values

PROPERTY_SET_EXCEPTION

public static final String PROPERTY_SET_EXCEPTION
See Also:
Constant Field Values
Constructor Detail

AccessOptimizerAdapter

public AccessOptimizerAdapter(BulkAccessor bulkAccessor,
                              Class mappedClass)
Method Detail

getPropertyNames

public String[] getPropertyNames()
Specified by:
getPropertyNames in interface ReflectionOptimizer.AccessOptimizer

getPropertyValues

public Object[] getPropertyValues(Object object)
Specified by:
getPropertyValues in interface ReflectionOptimizer.AccessOptimizer

setPropertyValues

public void setPropertyValues(Object object,
                              Object[] values)
Specified by:
setPropertyValues in interface ReflectionOptimizer.AccessOptimizer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BulkAccessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Class BulkAccessor

java.lang.Object
    extended by org.hibernate.bytecode.javassist.BulkAccessor
All Implemented Interfaces:
Serializable
public abstract class BulkAccessor
extends Object
implements Serializable

A JavaBean accessor.

This object provides methods that set/get multiple properties of a JavaBean at once. This class and its support classes have been developed for the comaptibility with cglib (http://cglib.sourceforge.net/).

Author:
Muga Nishizawa, modified by Shigeru Chiba
See Also:
Serialized Form

Field Summary
protected String[] | getters
protected String[] | setters
protected Class | target
protected Class[] | types
Constructor Summary
protected BulkAccessor()
Method Summary
static BulkAccessor | create(Class beanClass, String[] getters, String[] setters, Class[] types) Creates a new instance of BulkAccessor.
String[] | getGetters() Returns the setter names of properties.
Class[] | getPropertyTypes() Returns the types of properties.
Object[] | getPropertyValues(Object bean) Returns the values of properties of a given bean.
abstract void | getPropertyValues(Object bean, Object[] values) Obtains the values of properties of a given bean.
String[] | getSetters() Returns the getter names of the properties.
abstract void | setPropertyValues(Object bean, Object[] values) Sets properties of a given bean to specified values.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

target

protected Class target

getters

protected String[] getters

setters

protected String[] setters

types

protected Class[] types
Constructor Detail

BulkAccessor

protected BulkAccessor()
Method Detail

getPropertyValues

public abstract void getPropertyValues(Object bean,
                                       Object[] values)
Obtains the values of properties of a given bean.

Parameters:
bean - JavaBean.
values - the obtained values are stored in this array.

setPropertyValues

public abstract void setPropertyValues(Object bean,
                                       Object[] values)
Sets properties of a given bean to specified values.

Parameters:
bean - JavaBean.
values - the values assinged to properties.

getPropertyValues

public Object[] getPropertyValues(Object bean)
Returns the values of properties of a given bean.

Parameters:
bean - JavaBean.

getPropertyTypes

public Class[] getPropertyTypes()
Returns the types of properties.

getGetters

public String[] getGetters()
Returns the setter names of properties.

getSetters

public String[] getSetters()
Returns the getter names of the properties.

create

public static BulkAccessor create(Class beanClass,
                                  String[] getters,
                                  String[] setters,
                                  Class[] types)
Creates a new instance of BulkAccessor. The created instance provides methods for setting/getting specified properties at once.

Parameters:
beanClass - the class of the JavaBeans accessed through the created object.
getters - the names of setter methods for specified properties.
setters - the names of getter methods for specified properties.
types - the types of specified properties.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BytecodeProviderImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Class BytecodeProviderImpl

java.lang.Object
    extended by org.hibernate.bytecode.javassist.BytecodeProviderImpl
All Implemented Interfaces:
BytecodeProvider
public class BytecodeProviderImpl
extends Object
implements BytecodeProvider

Bytecode provider implementation for Javassist.

Author:
Steve Ebersole

Constructor Summary
BytecodeProviderImpl()
Method Summary
ProxyFactoryFactory | getProxyFactoryFactory() Retrieve the specific factory for this provider capable of generating run-time proxies for lazy-loading purposes.
ReflectionOptimizer | getReflectionOptimizer(Class clazz, String[] getterNames, String[] setterNames, Class[] types) Retrieve the ReflectionOptimizer delegate for this provider capable of generating reflection optimization components.
ClassTransformer | getTransformer(ClassFilter classFilter, FieldFilter fieldFilter) Generate a ClassTransformer capable of performing bytecode manipulation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BytecodeProviderImpl

public BytecodeProviderImpl()
Method Detail

getProxyFactoryFactory

public ProxyFactoryFactory getProxyFactoryFactory()
Description copied from interface: BytecodeProvider
Retrieve the specific factory for this provider capable of generating run-time proxies for lazy-loading purposes.

Specified by:
getProxyFactoryFactory in interface BytecodeProvider
Returns:
The provider specifc factory.

getReflectionOptimizer

public ReflectionOptimizer getReflectionOptimizer(Class clazz,
                                                  String[] getterNames,
                                                  String[] setterNames,
                                                  Class[] types)
Description copied from interface: BytecodeProvider
Retrieve the ReflectionOptimizer delegate for this provider capable of generating reflection optimization components.

Specified by:
getReflectionOptimizer in interface BytecodeProvider
Parameters:
clazz - The class to be reflected upon.
getterNames - Names of all property getters to be accessed via reflection.
setterNames - Names of all property setters to be accessed via reflection.
types - The types of all properties to be accessed.
Returns:
The reflection optimization delegate.

getTransformer

public ClassTransformer getTransformer(ClassFilter classFilter,
                                       FieldFilter fieldFilter)
Description copied from interface: BytecodeProvider
Generate a ClassTransformer capable of performing bytecode manipulation.

Specified by:
getTransformer in interface BytecodeProvider
Parameters:
classFilter - filter used to limit which classes are to be instrumented via this ClassTransformer.
fieldFilter - filter used to limit which fields are to be instrumented via this ClassTransformer.
Returns:
The appropriate ClassTransformer.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FastClass (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Class FastClass

java.lang.Object
    extended by org.hibernate.bytecode.javassist.FastClass
All Implemented Interfaces:
Serializable
public class FastClass
extends Object
implements Serializable

Author:
Muga Nishizawa
See Also:
Serialized Form

Method Summary
static FastClass | create(Class type)
boolean | equals(Object o)
int | getIndex(Class[] parameterTypes)
int | getIndex(String name, Class[] parameterTypes)
Class | getJavaClass()
int | getMaxIndex()
String | getName()
int | hashCode()
Object | invoke(int index, Object obj, Object[] args)
Object | invoke(String name, Class[] parameterTypes, Object obj, Object[] args)
Object | newInstance()
Object | newInstance(Class[] parameterTypes, Object[] args)
Object | newInstance(int index, Object[] args)
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Method Detail

invoke

public Object invoke(String name,
                     Class[] parameterTypes,
                     Object obj,
                     Object[] args)
              throws InvocationTargetException
Throws:
InvocationTargetException

invoke

public Object invoke(int index,
                     Object obj,
                     Object[] args)
              throws InvocationTargetException
Throws:
InvocationTargetException

newInstance

public Object newInstance()
                   throws InvocationTargetException
Throws:
InvocationTargetException

newInstance

public Object newInstance(Class[] parameterTypes,
                          Object[] args)
                   throws InvocationTargetException
Throws:
InvocationTargetException

newInstance

public Object newInstance(int index,
                          Object[] args)
                   throws InvocationTargetException
Throws:
InvocationTargetException

getIndex

public int getIndex(String name,
                    Class[] parameterTypes)

getIndex

public int getIndex(Class[] parameterTypes)

getMaxIndex

public int getMaxIndex()

getName

public String getName()

getJavaClass

public Class getJavaClass()

toString

public String toString()

hashCode

public int hashCode()

equals

public boolean equals(Object o)

create

public static FastClass create(Class type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldTransformer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Class FieldTransformer

java.lang.Object
    extended by org.hibernate.bytecode.javassist.FieldTransformer
public class FieldTransformer
extends Object

The thing that handles actual class enhancement in regards to intercepting field accesses.

Author:
Muga Nishizawa

Constructor Summary
FieldTransformer()
FieldTransformer(FieldFilter f)
Method Summary
void | setFieldFilter(FieldFilter f)
void | transform(javassist.bytecode.ClassFile classfile)
void | transform(File file)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FieldTransformer

public FieldTransformer()

FieldTransformer

public FieldTransformer(FieldFilter f)
Method Detail

setFieldFilter

public void setFieldFilter(FieldFilter f)

transform

public void transform(File file)
               throws Exception
Throws:
Exception

transform

public void transform(javassist.bytecode.ClassFile classfile)
               throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InstantiationOptimizerAdapter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Class InstantiationOptimizerAdapter

java.lang.Object
    extended by org.hibernate.bytecode.javassist.InstantiationOptimizerAdapter
All Implemented Interfaces:
ReflectionOptimizer.InstantiationOptimizer, Serializable
public class InstantiationOptimizerAdapter
extends Object
implements ReflectionOptimizer.InstantiationOptimizer, Serializable

The ReflectionOptimizer.InstantiationOptimizer implementation for Javassist which simply acts as an adpater to the FastClass class.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
InstantiationOptimizerAdapter(FastClass fastClass)
Method Summary
 Object newInstance()
Perform instantiation of an instance of the underlying class.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InstantiationOptimizerAdapter

public InstantiationOptimizerAdapter(FastClass fastClass)
Method Detail

newInstance

public Object newInstance()
Description copied from interface: ReflectionOptimizer.InstantiationOptimizer
Perform instantiation of an instance of the underlying class.

Specified by:
newInstance in interface ReflectionOptimizer.InstantiationOptimizer
Returns:
The new instance.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JavassistClassTransformer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Class JavassistClassTransformer

java.lang.Object
    extended by org.hibernate.bytecode.AbstractClassTransformerImpl
        extended by org.hibernate.bytecode.javassist.JavassistClassTransformer
All Implemented Interfaces:
ClassTransformer
public class JavassistClassTransformer
extends AbstractClassTransformerImpl

Enhance the classes allowing them to implements InterceptFieldEnabled This interface is then used by Hibernate for some optimizations.

Author:
Emmanuel Bernard, Steve Ebersole

Field Summary
Fields inherited from class org.hibernate.bytecode.AbstractClassTransformerImpl
classFilter, fieldFilter
Constructor Summary
JavassistClassTransformer(ClassFilter classFilter, FieldFilter fieldFilter)
Method Summary
protected byte[] | doTransform(ClassLoader loader, String className, Class classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
protected FieldTransformer | getFieldTransformer(javassist.bytecode.ClassFile classfile)
Methods inherited from class org.hibernate.bytecode.AbstractClassTransformerImpl
transform
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JavassistClassTransformer

public JavassistClassTransformer(ClassFilter classFilter,
                                 FieldFilter fieldFilter)
Method Detail

doTransform

protected byte[] doTransform(ClassLoader loader,
                             String className,
                             Class classBeingRedefined,
                             ProtectionDomain protectionDomain,
                             byte[] classfileBuffer)
Specified by:
doTransform in class AbstractClassTransformerImpl

getFieldTransformer

protected FieldTransformer getFieldTransformer(javassist.bytecode.ClassFile classfile)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyFactoryFactoryImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Class ProxyFactoryFactoryImpl

java.lang.Object
    extended by org.hibernate.bytecode.javassist.ProxyFactoryFactoryImpl
All Implemented Interfaces:
ProxyFactoryFactory
public class ProxyFactoryFactoryImpl
extends Object
implements ProxyFactoryFactory

A factory for Javassist-based ProxyFactory instances.

Author:
Steve Ebersole

Constructor Summary
ProxyFactoryFactoryImpl()
Method Summary
BasicProxyFactory | buildBasicProxyFactory(Class superClass, Class[] interfaces) Build a proxy factory for basic proxy concerns.
ProxyFactory | buildProxyFactory() Builds a Javassist-based proxy factory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProxyFactoryFactoryImpl

public ProxyFactoryFactoryImpl()
Method Detail

buildProxyFactory

public ProxyFactory buildProxyFactory()
Builds a Javassist-based proxy factory.

Specified by:
buildProxyFactory in interface ProxyFactoryFactory
Returns:
a new Javassist-based proxy factory.

buildBasicProxyFactory

public BasicProxyFactory buildBasicProxyFactory(Class superClass,
                                                Class[] interfaces)
Description copied from interface: ProxyFactoryFactory
Build a proxy factory for basic proxy concerns. The return should be capable of properly handling newInstance() calls.

Should build basic proxies essentially equivalent to JDK proxies in terms of capabilities, but should be able to deal with abstract super classes in addition to proxy interfaces.

Must pass in either superClass or interfaces (or both).

Specified by:
buildBasicProxyFactory in interface ProxyFactoryFactory
Parameters:
superClass - The abstract super class (or null if none).
interfaces - Interfaces to be proxied (or null if none).
Returns:
The proxy class
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReflectionOptimizerImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Class ReflectionOptimizerImpl

java.lang.Object
    extended by org.hibernate.bytecode.javassist.ReflectionOptimizerImpl
All Implemented Interfaces:
ReflectionOptimizer, Serializable
public class ReflectionOptimizerImpl
extends Object
implements ReflectionOptimizer, Serializable

ReflectionOptimizer implementation for Javassist.

Author:
Steve Ebersole
See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.bytecode.ReflectionOptimizer
ReflectionOptimizer.AccessOptimizer, ReflectionOptimizer.InstantiationOptimizer
Constructor Summary
ReflectionOptimizerImpl(ReflectionOptimizer.InstantiationOptimizer instantiationOptimizer, ReflectionOptimizer.AccessOptimizer accessOptimizer)
Method Summary
ReflectionOptimizer.AccessOptimizer | getAccessOptimizer()
ReflectionOptimizer.InstantiationOptimizer | getInstantiationOptimizer()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReflectionOptimizerImpl

public ReflectionOptimizerImpl(ReflectionOptimizer.InstantiationOptimizer instantiationOptimizer,
                               ReflectionOptimizer.AccessOptimizer accessOptimizer)
Method Detail

getInstantiationOptimizer

public ReflectionOptimizer.InstantiationOptimizer getInstantiationOptimizer()
Specified by:
getInstantiationOptimizer in interface ReflectionOptimizer

getAccessOptimizer

public ReflectionOptimizer.AccessOptimizer getAccessOptimizer()
Specified by:
getAccessOptimizer in interface ReflectionOptimizer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransformingClassLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Class TransformingClassLoader

java.lang.Object
    extended by java.lang.ClassLoader
        extended by org.hibernate.bytecode.javassist.TransformingClassLoader
public class TransformingClassLoader
extends ClassLoader

Author:
Steve Ebersole

Method Summary
protected Class | findClass(String name)
void | release()
Methods inherited from class java.lang.ClassLoader
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findLibrary, findLoadedClass, findResource, findResources, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

findClass

protected Class findClass(String name)
                   throws ClassNotFoundException
Throws:
ClassNotFoundException

release

public void release()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BulkAccessorException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.javassist
Class BulkAccessorException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.bytecode.javassist.BulkAccessorException
All Implemented Interfaces:
Serializable
public class BulkAccessorException
extends RuntimeException

An exception thrown while generating a bulk accessor.

Author:
Muga Nishizawa, modified by Shigeru Chiba
See Also:
Serialized Form

Constructor Summary
BulkAccessorException(String message)
Constructs an exception.
BulkAccessorException(String message, int index)
Constructs an exception.
BulkAccessorException(String message, Throwable cause)
Constructs an exception.
BulkAccessorException(Throwable cause, int index)
Constructs an exception.
Method Summary
Throwable | getCause() Gets the cause of this throwable.
int | getIndex() Returns the index of the property that causes this exception.
Throwable | initCause(Throwable cause) Initializes the cause of this throwable.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BulkAccessorException

public BulkAccessorException(String message)
Constructs an exception.

BulkAccessorException

public BulkAccessorException(String message,
                             int index)
Constructs an exception.

Parameters:
index - the index of the property that causes an exception.

BulkAccessorException

public BulkAccessorException(String message,
                             Throwable cause)
Constructs an exception.

BulkAccessorException

public BulkAccessorException(Throwable cause,
                             int index)
Constructs an exception.

Parameters:
index - the index of the property that causes an exception.
Method Detail

getCause

public Throwable getCause()
Gets the cause of this throwable. It is for JDK 1.3 compatibility.

initCause

public Throwable initCause(Throwable cause)
Initializes the cause of this throwable. It is for JDK 1.3 compatibility.

getIndex

public int getIndex()
Returns the index of the property that causes this exception.

Returns:
-1 if the index is not specified.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.bytecode.util (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.bytecode.util

Interface Summary
ClassDescriptor | Contract describing the information Hibernate needs in terms of instrumenting a class, either via ant task or dynamic classloader.
ClassFilter | Used to determine whether a class should be instrumented.
FieldFilter | Used to determine whether a field reference should be instrumented.

Class Summary
BasicClassFilter | BasicClassFilter provides class filtering based on a series of packages to be included and/or a series of explicit class names to be included.
ByteCodeHelper | A helper for reading byte code from various input sources.


org.hibernate.bytecode.util Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.bytecode.util

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.bytecode.util.BasicClassFilter (implements org.hibernate.bytecode.util.ClassFilter)
    • class org.hibernate.bytecode.util.ByteCodeHelper

Interface Hierarchy

  • interface org.hibernate.bytecode.util.ClassDescriptor
  • interface org.hibernate.bytecode.util.ClassFilter
  • interface org.hibernate.bytecode.util.FieldFilter


Uses of Package org.hibernate.bytecode.util (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.bytecode.util

Packages that use org.hibernate.bytecode.util
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.bytecode.javassist |
org.hibernate.bytecode.util |
org.hibernate.tool.instrument | The instrument tool for adding field-interception hooks to persistent classes using built-time bytecode processing.
org.hibernate.tool.instrument.cglib |

Classes in org.hibernate.bytecode.util used by org.hibernate.bytecode
ClassFilter
Used to determine whether a class should be instrumented.
FieldFilter
Used to determine whether a field reference should be instrumented.

Classes in org.hibernate.bytecode.util used by org.hibernate.bytecode.cglib
ClassFilter
Used to determine whether a class should be instrumented.
FieldFilter
Used to determine whether a field reference should be instrumented.

Classes in org.hibernate.bytecode.util used by org.hibernate.bytecode.javassist
ClassFilter
Used to determine whether a class should be instrumented.
FieldFilter
Used to determine whether a field reference should be instrumented.

Classes in org.hibernate.bytecode.util used by org.hibernate.bytecode.util
ClassFilter
Used to determine whether a class should be instrumented.

Classes in org.hibernate.bytecode.util used by org.hibernate.tool.instrument
ClassDescriptor
Contract describing the information Hibernate needs in terms of instrumenting a class, either via ant task or dynamic classloader.
FieldFilter
Used to determine whether a field reference should be instrumented.

Classes in org.hibernate.bytecode.util used by org.hibernate.tool.instrument.cglib
ClassDescriptor
Contract describing the information Hibernate needs in terms of instrumenting a class, either via ant task or dynamic classloader.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ClassDescriptor (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.util
Interface ClassDescriptor

public interface ClassDescriptor

Contract describing the information Hibernate needs in terms of instrumenting a class, either via ant task or dynamic classloader.

Author:
Steve Ebersole

Method Summary
byte[] | getBytes() The bytes making up the class' bytecode.
String | getName() The name of the class.
boolean | isInstrumented() Determine if the class is already instrumented.

Method Detail

getName

public String getName()
The name of the class.

Returns:
The class name.

isInstrumented

public boolean isInstrumented()
Determine if the class is already instrumented.

Returns:
True if already instrumented; false otherwise.

getBytes

public byte[] getBytes()
The bytes making up the class' bytecode.

Returns:
The bytecode bytes.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ClassFilter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.util
Interface ClassFilter

All Known Implementing Classes:
BasicClassFilter
public interface ClassFilter

Used to determine whether a class should be instrumented.

Author:
Steve Ebersole

Method Summary
 boolean shouldInstrumentClass(String className)

Method Detail

shouldInstrumentClass

public boolean shouldInstrumentClass(String className)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldFilter (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.util
Interface FieldFilter

All Known Implementing Classes:
BasicInstrumentationTask.CustomFieldFilter
public interface FieldFilter

Used to determine whether a field reference should be instrumented.

Author:
Steve Ebersole

Method Summary
boolean | shouldInstrumentField(String className, String fieldName) Should this field definition be instrumented?
boolean | shouldTransformFieldAccess(String transformingClassName, String fieldOwnerClassName, String fieldName) Should we instrument *access to* the given field.

Method Detail

shouldInstrumentField

public boolean shouldInstrumentField(String className,
                                     String fieldName)
Should this field definition be instrumented?

Parameters:
className - The name of the class currently being processed
fieldName - The name of the field being checked.
Returns:
True if we should instrument this field.

shouldTransformFieldAccess

public boolean shouldTransformFieldAccess(String transformingClassName,
                                          String fieldOwnerClassName,
                                          String fieldName)
Should we instrument *access to* the given field. This differs from shouldInstrumentField(java.lang.String, java.lang.String) in that here we are talking about a particular usage of a field.

Parameters:
transformingClassName - The class currently being transformed.
fieldOwnerClassName - The name of the class owning this field being checked.
fieldName - The name of the field being checked.
Returns:
True if this access should be transformed.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BasicClassFilter (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.util
Class BasicClassFilter

java.lang.Object
    extended by org.hibernate.bytecode.util.BasicClassFilter
All Implemented Interfaces:
ClassFilter
public class BasicClassFilter
extends Object
implements ClassFilter

BasicClassFilter provides class filtering based on a series of packages to be included and/or a series of explicit class names to be included. If neither is specified, then no restrictions are applied.

Author:
Steve Ebersole

Constructor Summary
BasicClassFilter()
BasicClassFilter(String[] includedPackages, String[] includedClassNames)
Method Summary
 boolean shouldInstrumentClass(String className)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BasicClassFilter

public BasicClassFilter()

BasicClassFilter

public BasicClassFilter(String[] includedPackages,
                        String[] includedClassNames)
Method Detail

shouldInstrumentClass

public boolean shouldInstrumentClass(String className)
Specified by:
shouldInstrumentClass in interface ClassFilter
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ByteCodeHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.bytecode.util
Class ByteCodeHelper

java.lang.Object
    extended by org.hibernate.bytecode.util.ByteCodeHelper
public class ByteCodeHelper
extends Object

A helper for reading byte code from various input sources.

Author:
Steve Ebersole

Method Summary
static byte[] | readByteCode(File file)
static byte[] | readByteCode(InputStream inputStream) Reads class byte array info from the given input stream.
static byte[] | readByteCode(ZipInputStream zip)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

readByteCode

public static byte[] readByteCode(InputStream inputStream)
                           throws IOException
Reads class byte array info from the given input stream.

The stream is closed within this method!

Parameters:
inputStream -
Returns:
Throws:
IOException

readByteCode

public static byte[] readByteCode(File file)
                           throws IOException
Throws:
IOException

readByteCode

public static byte[] readByteCode(ZipInputStream zip)
                           throws IOException
Throws:
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.cache (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.cache

This package defines APIs and implementations for the second-level cache and query cache.

See:
Description

Interface Summary
Cache | Implementors define a caching algorithm.
CacheConcurrencyStrategy | Implementors manage transactional access to cached data.
CacheConcurrencyStrategy.SoftLock | Marker interface, denoting a client-visible "soft lock" on a cached item.
CacheProvider | Support for pluggable caches.
OptimisticCache | A contract for transactional cache implementations which support optimistic locking of items within the cache.
OptimisticCacheSource | Contract for sources of optimistically lockable data sent to the second level cache.
QueryCache | Defines the contract for caches capable of storing query results.
QueryCacheFactory | Defines a factory for query cache instances.
ReadWriteCache.Lockable |

Class Summary
AbstractJndiBoundCacheProvider | Support for CacheProvider implementations which are backed by caches bound into JNDI namespace.
CacheFactory |
CacheKey | Allows multiple entity classes / collection roles to be stored in the same cache region.
EhCache | EHCache plugin for Hibernate EHCache uses a MemoryStore and a DiskStore.
EhCacheProvider | Cache Provider plugin for ehcache-1.2.
FilterKey | Allows cached queries to be keyed by enabled filters.
HashtableCache | A lightweight implementation of the Cache interface
HashtableCacheProvider | A simple in-memory Hashtable-based cache impl.
JndiBoundTreeCacheProvider | Support for JBossCache (TreeCache), where the cache instance is available via JNDI lookup.
NoCacheProvider | Implementation of NoCacheProvider.
NonstrictReadWriteCache | Caches data that is sometimes updated without ever locking the cache.
OptimisticTreeCache | Represents a particular region within the given JBossCache TreeCache utilizing TreeCache's optimistic locking capabilities.
OptimisticTreeCache.CircumventChecksDataVersion | Used to signal to a DataVersionAdapter to simply not perform any checks.
OptimisticTreeCache.DataVersionAdapter |
OptimisticTreeCache.NonLockingDataVersion | Used in regions where no locking should ever occur.
OptimisticTreeCacheProvider | Support for a standalone JBossCache TreeCache instance utilizing TreeCache's optimistic locking capabilities.
OSCache |
OSCacheProvider | Support for OpenSymphony OSCache.
QueryKey | A key that identifies a particular query with bound parameter values
ReadOnlyCache | Caches data that is never updated.
ReadWriteCache | Caches data that is sometimes updated while maintaining the semantics of "read committed" isolation level.
ReadWriteCache.Item | An item of cached data, timestamped with the time it was cached,.
ReadWriteCache.Lock | A soft lock which supports concurrent locking, timestamped with the time it was released
StandardQueryCache | The standard implementation of the Hibernate QueryCache interface.
StandardQueryCacheFactory | Standard Hibernate implementation of the QueryCacheFactory interface.
SwarmCache |
SwarmCacheProvider | Support for SwarmCache replicated cache.
Timestamper | Generates increasing identifiers (in a single VM only).
TransactionalCache | Support for fully transactional cache implementations like JBoss TreeCache.
TreeCache | Represents a particular region within the given JBossCache TreeCache.
TreeCacheProvider | Support for a standalone JBossCache (TreeCache) instance.
UpdateTimestampsCache | Tracks the timestamps of the most recent updates to particular tables.

Exception Summary
CacheException | Something went wrong in the cache
NoCachingEnabledException | Implementation of NoCachingEnabledException.

Package org.hibernate.cache Description

This package defines APIs and implementations for the second-level cache and query cache.

Cache abstracts the underlying cache implementation. CacheConcurrencyStrategy abstracts various strategies for maintaining consistency between the cache and database. QueryCache abstracts the query result set cache.


org.hibernate.cache Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.cache

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.cache.AbstractJndiBoundCacheProvider (implements org.hibernate.cache.CacheProvider)
      • class org.hibernate.cache.JndiBoundTreeCacheProvider
    • class org.hibernate.cache.CacheFactory
    • class org.hibernate.cache.CacheKey (implements java.io.Serializable)
    • class org.hibernate.cache.EhCache (implements org.hibernate.cache.Cache)
    • class org.hibernate.cache.EhCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class org.hibernate.cache.FilterKey (implements java.io.Serializable)
    • class org.hibernate.cache.HashtableCache (implements org.hibernate.cache.Cache)
    • class org.hibernate.cache.HashtableCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class org.hibernate.cache.NoCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class org.hibernate.cache.NonstrictReadWriteCache (implements org.hibernate.cache.CacheConcurrencyStrategy)
    • class org.hibernate.cache.OptimisticTreeCache (implements org.hibernate.cache.OptimisticCache)
    • class org.hibernate.cache.OptimisticTreeCache.CircumventChecksDataVersion (implements org.jboss.cache.optimistic.DataVersion)
    • class org.hibernate.cache.OptimisticTreeCache.DataVersionAdapter (implements org.jboss.cache.optimistic.DataVersion)
    • class org.hibernate.cache.OptimisticTreeCache.NonLockingDataVersion (implements org.jboss.cache.optimistic.DataVersion)
    • class org.hibernate.cache.OptimisticTreeCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class org.hibernate.cache.OSCache (implements org.hibernate.cache.Cache)
    • class org.hibernate.cache.OSCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class org.hibernate.cache.QueryKey (implements java.io.Serializable)
    • class org.hibernate.cache.ReadOnlyCache (implements org.hibernate.cache.CacheConcurrencyStrategy)
    • class org.hibernate.cache.ReadWriteCache (implements org.hibernate.cache.CacheConcurrencyStrategy)
    • class org.hibernate.cache.ReadWriteCache.Item (implements org.hibernate.cache.ReadWriteCache.Lockable, java.io.Serializable)
    • class org.hibernate.cache.ReadWriteCache.Lock (implements org.hibernate.cache.CacheConcurrencyStrategy.SoftLock, org.hibernate.cache.ReadWriteCache.Lockable, java.io.Serializable)
    • class org.hibernate.cache.StandardQueryCache (implements org.hibernate.cache.QueryCache)
    • class org.hibernate.cache.StandardQueryCacheFactory (implements org.hibernate.cache.QueryCacheFactory)
    • class org.hibernate.cache.SwarmCache (implements org.hibernate.cache.Cache)
    • class org.hibernate.cache.SwarmCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class org.hibernate.exception.NestableRuntimeException (implements org.hibernate.exception.Nestable)
            • class org.hibernate.HibernateException
              • class org.hibernate.cache.CacheException
                • class org.hibernate.cache.NoCachingEnabledException
    • class org.hibernate.cache.Timestamper
    • class org.hibernate.cache.TransactionalCache (implements org.hibernate.cache.CacheConcurrencyStrategy)
    • class org.hibernate.cache.TreeCache (implements org.hibernate.cache.Cache)
    • class org.hibernate.cache.TreeCacheProvider (implements org.hibernate.cache.CacheProvider)
    • class org.hibernate.cache.UpdateTimestampsCache

Interface Hierarchy

  • interface org.hibernate.cache.Cache
    • interface org.hibernate.cache.OptimisticCache
  • interface org.hibernate.cache.CacheConcurrencyStrategy
  • interface org.hibernate.cache.CacheConcurrencyStrategy.SoftLock
  • interface org.hibernate.cache.CacheProvider
  • interface org.hibernate.cache.OptimisticCacheSource
  • interface org.hibernate.cache.QueryCache
  • interface org.hibernate.cache.QueryCacheFactory
  • interface org.hibernate.cache.ReadWriteCache.Lockable


Uses of Package org.hibernate.cache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.cache

Packages that use org.hibernate.cache
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Classes in org.hibernate.cache used by org.hibernate.action
CacheException
Something went wrong in the cache

Classes in org.hibernate.cache used by org.hibernate.cache
AbstractJndiBoundCacheProvider
Support for CacheProvider implementations which are backed by caches bound into JNDI namespace.
Cache
Implementors define a caching algorithm.
CacheConcurrencyStrategy
Implementors manage transactional access to cached data.
CacheConcurrencyStrategy.SoftLock
Marker interface, denoting a client-visible "soft lock" on a cached item.
CacheException
Something went wrong in the cache
CacheProvider
Support for pluggable caches.
OptimisticCache
A contract for transactional cache implementations which support optimistic locking of items within the cache.
OptimisticCacheSource
Contract for sources of optimistically lockable data sent to the second level cache.
QueryCache
Defines the contract for caches capable of storing query results.
QueryCacheFactory
Defines a factory for query cache instances.
QueryKey
A key that identifies a particular query with bound parameter values
ReadWriteCache.Lock
A soft lock which supports concurrent locking, timestamped with the time it was released
ReadWriteCache.Lockable
UpdateTimestampsCache
Tracks the timestamps of the most recent updates to particular tables.

Classes in org.hibernate.cache used by org.hibernate.cfg
CacheProvider
Support for pluggable caches.
QueryCacheFactory
Defines a factory for query cache instances.

Classes in org.hibernate.cache used by org.hibernate.engine
Cache
Implementors define a caching algorithm.
QueryCache
Defines the contract for caches capable of storing query results.
UpdateTimestampsCache
Tracks the timestamps of the most recent updates to particular tables.

Classes in org.hibernate.cache used by org.hibernate.id
OptimisticCacheSource
Contract for sources of optimistically lockable data sent to the second level cache.

Classes in org.hibernate.cache used by org.hibernate.impl
Cache
Implementors define a caching algorithm.
QueryCache
Defines the contract for caches capable of storing query results.
UpdateTimestampsCache
Tracks the timestamps of the most recent updates to particular tables.

Classes in org.hibernate.cache used by org.hibernate.persister
CacheConcurrencyStrategy
Implementors manage transactional access to cached data.

Classes in org.hibernate.cache used by org.hibernate.persister.collection
CacheConcurrencyStrategy
Implementors manage transactional access to cached data.
CacheException
Something went wrong in the cache

Classes in org.hibernate.cache used by org.hibernate.persister.entity
CacheConcurrencyStrategy
Implementors manage transactional access to cached data.
OptimisticCacheSource
Contract for sources of optimistically lockable data sent to the second level cache.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Cache (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Interface Cache

All Known Subinterfaces:
OptimisticCache
All Known Implementing Classes:
EhCache, HashtableCache, OptimisticTreeCache, OSCache, SwarmCache, TreeCache
public interface Cache

Implementors define a caching algorithm. All implementors must be threadsafe.

Method Summary
void | clear() Clear the cache
void | destroy() Clean up
Object | get(Object key) Get an item from the cache, nontransactionally
long | getElementCountInMemory() The count of entries currently contained in the regions in-memory store.
long | getElementCountOnDisk() The count of entries currently contained in the regions disk store.
String | getRegionName() Get the name of the cache region
long | getSizeInMemory() The number of bytes is this cache region currently consuming in memory.
int | getTimeout() Get a reasonable "lock timeout"
void | lock(Object key) If this is a clustered cache, lock the item
long | nextTimestamp() Generate a timestamp
void | put(Object key, Object value) Add an item to the cache, nontransactionally, with failfast semantics
Object | read(Object key) Get an item from the cache
void | remove(Object key) Remove an item from the cache
Map | toMap() optional operation
void | unlock(Object key) If this is a clustered cache, unlock the item
void | update(Object key, Object value) Add an item to the cache

Method Detail

read

public Object read(Object key)
            throws CacheException
Get an item from the cache

Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

get

public Object get(Object key)
           throws CacheException
Get an item from the cache, nontransactionally

Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

put

public void put(Object key,
                Object value)
         throws CacheException
Add an item to the cache, nontransactionally, with failfast semantics

Parameters:
key -
value -
Throws:
CacheException

update

public void update(Object key,
                   Object value)
            throws CacheException
Add an item to the cache

Parameters:
key -
value -
Throws:
CacheException

remove

public void remove(Object key)
            throws CacheException
Remove an item from the cache

Throws:
CacheException

clear

public void clear()
           throws CacheException
Clear the cache

Throws:
CacheException

destroy

public void destroy()
             throws CacheException
Clean up

Throws:
CacheException

lock

public void lock(Object key)
          throws CacheException
If this is a clustered cache, lock the item

Throws:
CacheException

unlock

public void unlock(Object key)
            throws CacheException
If this is a clustered cache, unlock the item

Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Generate a timestamp

getTimeout

public int getTimeout()
Get a reasonable "lock timeout"

getRegionName

public String getRegionName()
Get the name of the cache region

getSizeInMemory

public long getSizeInMemory()
The number of bytes is this cache region currently consuming in memory.

Returns:
The number of bytes consumed by this region; -1 if unknown or unsupported.

getElementCountInMemory

public long getElementCountInMemory()
The count of entries currently contained in the regions in-memory store.

Returns:
The count of entries in memory; -1 if unknown or unsupported.

getElementCountOnDisk

public long getElementCountOnDisk()
The count of entries currently contained in the regions disk store.

Returns:
The count of entries on disk; -1 if unknown or unsupported.

toMap

public Map toMap()
optional operation

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CacheConcurrencyStrategy (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Interface CacheConcurrencyStrategy

All Known Implementing Classes:
NonstrictReadWriteCache, ReadOnlyCache, ReadWriteCache, TransactionalCache
public interface CacheConcurrencyStrategy

Implementors manage transactional access to cached data. Transactions pass in a timestamp indicating transaction start time. Two different implementation patterns are provided for.

  • A transaction-aware cache implementation might be wrapped by a "synchronous" concurrency strategy, where updates to the cache are written to the cache inside the transaction.
  • A non transaction-aware cache would be wrapped by an "asynchronous" concurrency strategy, where items are merely "soft locked" during the transaction and then updated during the "after transaction completion" phase; the soft lock is not an actual lock on the database row - only upon the cached representation of the item.

In terms of entity caches, the expected call sequences are:

  • DELETES : lock(java.lang.Object, java.lang.Object) -> evict(java.lang.Object) -> release(java.lang.Object, org.hibernate.cache.CacheConcurrencyStrategy.SoftLock)
  • UPDATES : lock(java.lang.Object, java.lang.Object) -> update(java.lang.Object, java.lang.Object, java.lang.Object, java.lang.Object) -> afterUpdate(java.lang.Object, java.lang.Object, java.lang.Object, org.hibernate.cache.CacheConcurrencyStrategy.SoftLock)
  • INSERTS : insert(java.lang.Object, java.lang.Object, java.lang.Object) -> afterInsert(java.lang.Object, java.lang.Object, java.lang.Object)

In terms of collection caches, all modification actions actually just invalidate the entry(s). The call sequence here is: lock(java.lang.Object, java.lang.Object) -> evict(java.lang.Object) -> release(java.lang.Object, org.hibernate.cache.CacheConcurrencyStrategy.SoftLock)

Note that, for an asynchronous cache, cache invalidation must be a two step process (lock->release, or lock-afterUpdate), since this is the only way to guarantee consistency with the database for a nontransactional cache implementation. For a synchronous cache, cache invalidation is a single step process (evict, or update). Hence, this interface defines a three step process, to cater for both models.

Note that query result caching does not go through a concurrency strategy; they are managed directly against the underlying cache regions.

Nested Class Summary
static interface CacheConcurrencyStrategy.SoftLock
Marker interface, denoting a client-visible "soft lock" on a cached item.
Method Summary
 boolean afterInsert(Object key, Object value, Object version)
Called after an item has been inserted (after the transaction completes), instead of calling release().
 boolean afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock lock)
Called after an item has been updated (after the transaction completes), instead of calling release().
 void clear()
Evict all items from the cache immediately.
 void destroy()
Clean up all resources.
 void evict(Object key)
Called after an item has become stale (before the transaction completes).
 Object get(Object key, long txTimestamp)
Attempt to retrieve an object from the cache.
 Cache getCache()
Get the wrapped cache implementation
 String getRegionName()
Get the cache region name
 boolean insert(Object key, Object value, Object currentVersion)
Called after an item has been inserted (before the transaction completes), instead of calling evict().
 CacheConcurrencyStrategy.SoftLock lock(Object key, Object version)
We are going to attempt to update/delete the keyed object.
 boolean put(Object key, Object value, long txTimestamp, Object version, Comparator versionComparator, boolean minimalPut)
Attempt to cache an object, after loading from the database.
 void release(Object key, CacheConcurrencyStrategy.SoftLock lock)
Called when we have finished the attempted update/delete (which may or may not have been successful), after transaction completion.
 void remove(Object key)
Evict an item from the cache immediately (without regard for transaction isolation).
 void setCache(Cache cache)
Set the underlying cache implementation.
 boolean update(Object key, Object value, Object currentVersion, Object previousVersion)
Called after an item has been updated (before the transaction completes), instead of calling evict().

Method Detail

get

public Object get(Object key,
                  long txTimestamp)
           throws CacheException
Attempt to retrieve an object from the cache. Mainly used in attempting to resolve entities/collections from the second level cache.

Parameters:
key -
txTimestamp - a timestamp prior to the transaction start time
Returns:
the cached object or null
Throws:
CacheException

put

public boolean put(Object key,
                   Object value,
                   long txTimestamp,
                   Object version,
                   Comparator versionComparator,
                   boolean minimalPut)
            throws CacheException
Attempt to cache an object, after loading from the database.

Parameters:
key -
value -
txTimestamp - a timestamp prior to the transaction start time
version - the item version number
versionComparator - a comparator used to compare version numbers
minimalPut - indicates that the cache should avoid a put is the item is already cached
Returns:
true if the object was successfully cached
Throws:
CacheException

lock

public CacheConcurrencyStrategy.SoftLock lock(Object key,
                                              Object version)
                                       throws CacheException
We are going to attempt to update/delete the keyed object. This method is used by "asynchronous" concurrency strategies.

The returned object must be passed back to release(), to release the lock. Concurrency strategies which do not support client-visible locks may silently return null.

Parameters:
key -
version -
Throws:
CacheException

evict

public void evict(Object key)
           throws CacheException
Called after an item has become stale (before the transaction completes). This method is used by "synchronous" concurrency strategies.

Throws:
CacheException

update

public boolean update(Object key,
                      Object value,
                      Object currentVersion,
                      Object previousVersion)
               throws CacheException
Called after an item has been updated (before the transaction completes), instead of calling evict(). This method is used by "synchronous" concurrency strategies.

Throws:
CacheException

insert

public boolean insert(Object key,
                      Object value,
                      Object currentVersion)
               throws CacheException
Called after an item has been inserted (before the transaction completes), instead of calling evict(). This method is used by "synchronous" concurrency strategies.

Throws:
CacheException

release

public void release(Object key,
                    CacheConcurrencyStrategy.SoftLock lock)
             throws CacheException
Called when we have finished the attempted update/delete (which may or may not have been successful), after transaction completion. This method is used by "asynchronous" concurrency strategies.

Parameters:
key -
Throws:
CacheException

afterUpdate

public boolean afterUpdate(Object key,
                           Object value,
                           Object version,
                           CacheConcurrencyStrategy.SoftLock lock)
                    throws CacheException
Called after an item has been updated (after the transaction completes), instead of calling release(). This method is used by "asynchronous" concurrency strategies.

Throws:
CacheException

afterInsert

public boolean afterInsert(Object key,
                           Object value,
                           Object version)
                    throws CacheException
Called after an item has been inserted (after the transaction completes), instead of calling release(). This method is used by "asynchronous" concurrency strategies.

Throws:
CacheException

remove

public void remove(Object key)
            throws CacheException
Evict an item from the cache immediately (without regard for transaction isolation).

Parameters:
key -
Throws:
CacheException

clear

public void clear()
           throws CacheException
Evict all items from the cache immediately.

Throws:
CacheException

destroy

public void destroy()
Clean up all resources.

setCache

public void setCache(Cache cache)
Set the underlying cache implementation.

Parameters:
cache -

getRegionName

public String getRegionName()
Get the cache region name

getCache

public Cache getCache()
Get the wrapped cache implementation

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CacheConcurrencyStrategy.SoftLock (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Interface CacheConcurrencyStrategy.SoftLock

All Known Implementing Classes:
ReadWriteCache.Lock
Enclosing interface:
CacheConcurrencyStrategy
public static interface CacheConcurrencyStrategy.SoftLock

Marker interface, denoting a client-visible "soft lock" on a cached item.

Author:
Gavin King

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CacheProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Interface CacheProvider

All Known Implementing Classes:
AbstractJndiBoundCacheProvider, EhCacheProvider, HashtableCacheProvider, NoCacheProvider, OptimisticTreeCacheProvider, OSCacheProvider, SwarmCacheProvider, TreeCacheProvider
public interface CacheProvider

Support for pluggable caches.

Author:
Gavin King

Method Summary
 Cache buildCache(String regionName, Properties properties)
Configure the cache
 boolean isMinimalPutsEnabledByDefault()
 long nextTimestamp()
Generate a timestamp
 void start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().

Method Detail

buildCache

public Cache buildCache(String regionName,
                        Properties properties)
                 throws CacheException
Configure the cache

Parameters:
regionName - the name of the cache region
properties - configuration settings
Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Generate a timestamp

start

public void start(Properties properties)
           throws CacheException
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.

Parameters:
properties - current configuration settings.
Throws:
CacheException

stop

public void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().

isMinimalPutsEnabledByDefault

public boolean isMinimalPutsEnabledByDefault()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptimisticCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Interface OptimisticCache

All Superinterfaces:
Cache
All Known Implementing Classes:
OptimisticTreeCache
public interface OptimisticCache
extends Cache

A contract for transactional cache implementations which support optimistic locking of items within the cache.

The optimisitic locking capabilities are only utilized for the entity cache regions.

Unlike the methods on the Cache interface, all the methods here will only ever be called from access scenarios where versioned data is actually a possiblity (i.e., entity data). Be sure to consult with OptimisticCacheSource.isVersioned() to determine whether versioning is actually in effect.

Author:
Steve Ebersole

Method Summary
 void setSource(OptimisticCacheSource source)
Indicates the "source" of the cached data.
 void writeInsert(Object key, Object value, Object currentVersion)
Called during CacheConcurrencyStrategy.insert(java.lang.Object, java.lang.Object, java.lang.Object) processing for transactional strategies.
 void writeLoad(Object key, Object value, Object currentVersion)
Called during CacheConcurrencyStrategy.put(java.lang.Object, java.lang.Object, long, java.lang.Object, java.util.Comparator, boolean) processing for transactional strategies.
 void writeUpdate(Object key, Object value, Object currentVersion, Object previousVersion)
Called during CacheConcurrencyStrategy.update(java.lang.Object, java.lang.Object, java.lang.Object, java.lang.Object) processing for transactional strategies.
Methods inherited from interface org.hibernate.cache.Cache
clear, destroy, get, getElementCountInMemory, getElementCountOnDisk, getRegionName, getSizeInMemory, getTimeout, lock, nextTimestamp, put, read, remove, toMap, unlock, update

Method Detail

setSource

public void setSource(OptimisticCacheSource source)
Indicates the "source" of the cached data. Currently this will only ever represent an EntityPersister.

Made available to the cache so that it can access certain information about versioning strategy.

Parameters:
source - The source.

writeInsert

public void writeInsert(Object key,
                        Object value,
                        Object currentVersion)
Called during CacheConcurrencyStrategy.insert(java.lang.Object, java.lang.Object, java.lang.Object) processing for transactional strategies. Indicates we have just performed an insert into the DB and now need to cache that entity's data.

Parameters:
key - The cache key.
value - The data to be cached.
currentVersion - The entity's version; or null if not versioned.

writeUpdate

public void writeUpdate(Object key,
                        Object value,
                        Object currentVersion,
                        Object previousVersion)
Called during CacheConcurrencyStrategy.update(java.lang.Object, java.lang.Object, java.lang.Object, java.lang.Object) processing for transactional strategies. Indicates we have just performed an update against the DB and now need to cache the updated state.

Parameters:
key - The cache key.
value - The data to be cached.
currentVersion - The entity's current version
previousVersion - The entity's previous version (before the update); or null if not versioned.

writeLoad

public void writeLoad(Object key,
                      Object value,
                      Object currentVersion)
Called during CacheConcurrencyStrategy.put(java.lang.Object, java.lang.Object, long, java.lang.Object, java.util.Comparator, boolean) processing for transactional strategies. Indicates we have just loaded an entity's state from the database and need it cached.

Parameters:
key - The cache key.
value - The data to be cached.
currentVersion - The entity's version; or null if not versioned.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptimisticCacheSource (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Interface OptimisticCacheSource

All Known Subinterfaces:
EntityPersister, Loadable, Lockable, OuterJoinLoadable, PostInsertIdentityPersister, Queryable, SQLLoadable, UniqueKeyLoadable
All Known Implementing Classes:
AbstractEntityPersister
public interface OptimisticCacheSource

Contract for sources of optimistically lockable data sent to the second level cache.

Note currently EntityPersisters are the only viable source.

Author:
Steve Ebersole

Method Summary
Comparator | getVersionComparator() Get the comparator used to compare two different version values together.
boolean | isVersioned() Does this source represent versioned (i.e., and thus optimistically lockable) data?

Method Detail

isVersioned

public boolean isVersioned()
Does this source represent versioned (i.e., and thus optimistically lockable) data?

Returns:
True if this source represents versioned data; false otherwise.

getVersionComparator

public Comparator getVersionComparator()
Get the comparator used to compare two different version values together.

Returns:
An appropriate comparator.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Interface QueryCache

All Known Implementing Classes:
StandardQueryCache
public interface QueryCache

Defines the contract for caches capable of storing query results. These caches should only concern themselves with storing the matching result ids. The transactional semantics are necessarily less strict than the semantics of an item cache.

Author:
Gavin King

Method Summary
void | clear()
void | destroy()
List | get(QueryKey key, Type[] returnTypes, boolean isNaturalKeyLookup, Set spaces, SessionImplementor session)
Cache | getCache()
String | getRegionName()
boolean | put(QueryKey key, Type[] returnTypes, List result, boolean isNaturalKeyLookup, SessionImplementor session)

Method Detail

clear

public void clear()
           throws CacheException
Throws:
CacheException

put

public boolean put(QueryKey key,
                   Type[] returnTypes,
                   List result,
                   boolean isNaturalKeyLookup,
                   SessionImplementor session)
            throws HibernateException
Throws:
HibernateException

get

public List get(QueryKey key,
                Type[] returnTypes,
                boolean isNaturalKeyLookup,
                Set spaces,
                SessionImplementor session)
         throws HibernateException
Throws:
HibernateException

destroy

public void destroy()

getCache

public Cache getCache()

getRegionName

public String getRegionName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryCacheFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Interface QueryCacheFactory

All Known Implementing Classes:
StandardQueryCacheFactory
public interface QueryCacheFactory

Defines a factory for query cache instances. These factories are responsible for creating individual QueryCache instances.

Author:
Steve Ebersole

Method Summary
 QueryCache getQueryCache(String regionName, UpdateTimestampsCache updateTimestampsCache, Settings settings, Properties props)

Method Detail

getQueryCache

public QueryCache getQueryCache(String regionName,
                                UpdateTimestampsCache updateTimestampsCache,
                                Settings settings,
                                Properties props)
                         throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractJndiBoundCacheProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class AbstractJndiBoundCacheProvider

java.lang.Object
    extended by org.hibernate.cache.AbstractJndiBoundCacheProvider
All Implemented Interfaces:
CacheProvider
Direct Known Subclasses:
JndiBoundTreeCacheProvider
public abstract class AbstractJndiBoundCacheProvider
extends Object
implements CacheProvider

Support for CacheProvider implementations which are backed by caches bound into JNDI namespace.

Author:
Steve Ebersole

Constructor Summary
AbstractJndiBoundCacheProvider()
Method Summary
 Object getCache()
protected  void prepare(Properties properties)
protected  void release()
 void start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.cache.CacheProvider
buildCache, isMinimalPutsEnabledByDefault, nextTimestamp

Constructor Detail

AbstractJndiBoundCacheProvider

public AbstractJndiBoundCacheProvider()
Method Detail

prepare

protected void prepare(Properties properties)

release

protected void release()

start

public final void start(Properties properties)
                 throws CacheException
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.

Specified by:
start in interface CacheProvider
Parameters:
properties - current configuration settings.
Throws:
CacheException

stop

public final void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().

Specified by:
stop in interface CacheProvider

getCache

public Object getCache()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CacheFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class CacheFactory

java.lang.Object
    extended by org.hibernate.cache.CacheFactory
public final class CacheFactory
extends Object

Author:
Gavin King

Field Summary
static String | NONSTRICT_READ_WRITE
static String | READ_ONLY
static String | READ_WRITE
static String | TRANSACTIONAL
Method Summary
static CacheConcurrencyStrategy createCache(String concurrencyStrategy, String regionName, boolean mutable, Settings settings, Properties properties)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

READ_ONLY

public static final String READ_ONLY
See Also:
Constant Field Values

READ_WRITE

public static final String READ_WRITE
See Also:
Constant Field Values

NONSTRICT_READ_WRITE

public static final String NONSTRICT_READ_WRITE
See Also:
Constant Field Values

TRANSACTIONAL

public static final String TRANSACTIONAL
See Also:
Constant Field Values
Method Detail

createCache

public static CacheConcurrencyStrategy createCache(String concurrencyStrategy,
                                                   String regionName,
                                                   boolean mutable,
                                                   Settings settings,
                                                   Properties properties)
                                            throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CacheKey (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class CacheKey

java.lang.Object
    extended by org.hibernate.cache.CacheKey
All Implemented Interfaces:
Serializable
public class CacheKey
extends Object
implements Serializable

Allows multiple entity classes / collection roles to be stored in the same cache region. Also allows for composite keys which do not properly implement equals()/hashCode().

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
CacheKey(Serializable id, Type type, String entityOrRoleName, EntityMode entityMode, SessionFactoryImplementor factory)
Construct a new key for a collection or entity instance.
Method Summary
boolean | equals(Object other)
String | getEntityOrRoleName()
Serializable | getKey()
int | hashCode()
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CacheKey

public CacheKey(Serializable id,
                Type type,
                String entityOrRoleName,
                EntityMode entityMode,
                SessionFactoryImplementor factory)
Construct a new key for a collection or entity instance. Note that an entity name should always be the root entity name, not a subclass entity name.

Method Detail

toString

public String toString()

equals

public boolean equals(Object other)

hashCode

public int hashCode()

getKey

public Serializable getKey()

getEntityOrRoleName

public String getEntityOrRoleName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EhCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class EhCache

java.lang.Object
    extended by org.hibernate.cache.EhCache
All Implemented Interfaces:
Cache
public class EhCache
extends Object
implements Cache

EHCache plugin for Hibernate

EHCache uses a MemoryStore and a DiskStore. The DiskStore requires that both keys and values be Serializable. However the MemoryStore does not and in ehcache-1.2 nonSerializable Objects are permitted. They are discarded if an attempt it made to overflow them to Disk or to replicate them to remote cache peers.

Author:
Greg Luck, Emmanuel Bernard

Constructor Summary
EhCache(net.sf.ehcache.Cache cache)
Creates a new Hibernate pluggable cache based on a cache name.
Method Summary
 void clear()
Remove all elements in the cache, but leave the cache in a useable state.
 void destroy()
Remove the cache and make it unuseable.
 Object get(Object key)
Gets a value of an element which matches the given key.
 long getElementCountInMemory()
The count of entries currently contained in the regions in-memory store.
 long getElementCountOnDisk()
The count of entries currently contained in the regions disk store.
 String getRegionName()
Get the name of the cache region
 long getSizeInMemory()
Warning: This method can be very expensive to run.
 int getTimeout()
Returns the lock timeout for this cache.
 void lock(Object key)
Calls to this method should perform there own synchronization.
 long nextTimestamp()
Gets the next timestamp;
 void put(Object key, Object value)
Puts an object into the cache.
 Object read(Object key)
Get an item from the cache
 void remove(Object key)
Removes the element which matches the key.
 Map toMap()
optional operation
 String toString()
 void unlock(Object key)
Calls to this method should perform there own synchronization.
 void update(Object key, Object value)
Puts an object into the cache.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EhCache

public EhCache(net.sf.ehcache.Cache cache)
Creates a new Hibernate pluggable cache based on a cache name.

Parameters:
cache - The underlying EhCache instance to use.
Method Detail

get

public Object get(Object key)
           throws CacheException
Gets a value of an element which matches the given key.

Specified by:
get in interface Cache
Parameters:
key - the key of the element to return.
Returns:
The value placed into the cache with an earlier put, or null if not found or expired
Throws:
CacheException

read

public Object read(Object key)
            throws CacheException
Description copied from interface: Cache
Get an item from the cache

Specified by:
read in interface Cache
Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

update

public void update(Object key,
                   Object value)
            throws CacheException
Puts an object into the cache.

Specified by:
update in interface Cache
Parameters:
key - a key
value - a value
Throws:
CacheException - if the CacheManager is shutdown or another Exception occurs.

put

public void put(Object key,
                Object value)
         throws CacheException
Puts an object into the cache.

Specified by:
put in interface Cache
Parameters:
key - a key
value - a value
Throws:
CacheException - if the CacheManager is shutdown or another Exception occurs.

remove

public void remove(Object key)
            throws CacheException
Removes the element which matches the key.

If no element matches, nothing is removed and no Exception is thrown.

Specified by:
remove in interface Cache
Parameters:
key - the key of the element to remove
Throws:
CacheException

clear

public void clear()
           throws CacheException
Remove all elements in the cache, but leave the cache in a useable state.

Specified by:
clear in interface Cache
Throws:
CacheException

destroy

public void destroy()
             throws CacheException
Remove the cache and make it unuseable.

Specified by:
destroy in interface Cache
Throws:
CacheException

lock

public void lock(Object key)
          throws CacheException
Calls to this method should perform there own synchronization. It is provided for distributed caches. Because EHCache is not distributed this method does nothing.

Specified by:
lock in interface Cache
Throws:
CacheException

unlock

public void unlock(Object key)
            throws CacheException
Calls to this method should perform there own synchronization. It is provided for distributed caches. Because EHCache is not distributed this method does nothing.

Specified by:
unlock in interface Cache
Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Gets the next timestamp;

Specified by:
nextTimestamp in interface Cache

getTimeout

public int getTimeout()
Returns the lock timeout for this cache.

Specified by:
getTimeout in interface Cache

getRegionName

public String getRegionName()
Description copied from interface: Cache
Get the name of the cache region

Specified by:
getRegionName in interface Cache

getSizeInMemory

public long getSizeInMemory()
Warning: This method can be very expensive to run. Allow approximately 1 second per 1MB of entries. Running this method could create liveness problems because the object lock is held for a long period

Specified by:
getSizeInMemory in interface Cache
Returns:
the approximate size of memory ehcache is using for the MemoryStore for this cache

getElementCountInMemory

public long getElementCountInMemory()
Description copied from interface: Cache
The count of entries currently contained in the regions in-memory store.

Specified by:
getElementCountInMemory in interface Cache
Returns:
The count of entries in memory; -1 if unknown or unsupported.

getElementCountOnDisk

public long getElementCountOnDisk()
Description copied from interface: Cache
The count of entries currently contained in the regions disk store.

Specified by:
getElementCountOnDisk in interface Cache
Returns:
The count of entries on disk; -1 if unknown or unsupported.

toMap

public Map toMap()
Description copied from interface: Cache
optional operation

Specified by:
toMap in interface Cache

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EhCacheProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class EhCacheProvider

java.lang.Object
    extended by org.hibernate.cache.EhCacheProvider
All Implemented Interfaces:
CacheProvider
public class EhCacheProvider
extends Object
implements CacheProvider

Cache Provider plugin for ehcache-1.2. New in this provider are ehcache support for multiple Hibernate session factories, each with its own ehcache configuration, and non Serializable keys and values. Ehcache-1.2 also has many other features such as cluster support and listeners, which can be used seamlessly simply by configurion in ehcache.xml.

Use hibernate.cache.provider_class=org.hibernate.cache.EhCacheProvider in the Hibernate configuration to enable this provider for Hibernate's second level cache.

When configuring multiple ehcache CacheManagers, as you would where you have multiple Hibernate Configurations and multiple SessionFactories, specify in each Hibernate configuration the ehcache configuration using the property hibernate.cache.provider_configuration_file_resource_path An example to set an ehcache configuration called ehcache-2.xml would be hibernate.cache.provider_configuration_file_resource_path=/ehcache-2.xml. If the leading slash is not there one will be added. The configuration file will be looked for in the root of the classpath.

Updated for ehcache-1.2. Note this provider requires ehcache-1.2.jar. Make sure ehcache-1.1.jar or earlier is not in the classpath or it will not work.

See http://ehcache.sf.net for documentation on ehcache

Author:
Greg Luck, Emmanuel Bernard

Constructor Summary
EhCacheProvider()
Method Summary
 Cache buildCache(String name, Properties properties)
Builds a Cache.
 boolean isMinimalPutsEnabledByDefault()
 long nextTimestamp()
Returns the next timestamp.
 void start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EhCacheProvider

public EhCacheProvider()
Method Detail

buildCache

public Cache buildCache(String name,
                        Properties properties)
                 throws CacheException
Builds a Cache.

Even though this method provides properties, they are not used. Properties for EHCache are specified in the ehcache.xml file. Configuration will be read from ehcache.xml for a cache declaration where the name attribute matches the name parameter in this builder.

Specified by:
buildCache in interface CacheProvider
Parameters:
name - the name of the cache. Must match a cache configured in ehcache.xml
properties - not used
Returns:
a newly built cache will be built and initialised
Throws:
CacheException - inter alia, if a cache of the same name already exists

nextTimestamp

public long nextTimestamp()
Returns the next timestamp.

Specified by:
nextTimestamp in interface CacheProvider

start

public void start(Properties properties)
           throws CacheException
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.

Specified by:
start in interface CacheProvider
Parameters:
properties - current configuration settings.
Throws:
CacheException

stop

public void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().

Specified by:
stop in interface CacheProvider

isMinimalPutsEnabledByDefault

public boolean isMinimalPutsEnabledByDefault()
Specified by:
isMinimalPutsEnabledByDefault in interface CacheProvider
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FilterKey (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class FilterKey

java.lang.Object
    extended by org.hibernate.cache.FilterKey
All Implemented Interfaces:
Serializable
public final class FilterKey
extends Object
implements Serializable

Allows cached queries to be keyed by enabled filters.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
FilterKey(String name, Map params, Map types, EntityMode entityMode)
Method Summary
static Set | createFilterKeys(Map enabledFilters, EntityMode entityMode)
boolean | equals(Object other)
int | hashCode()
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

FilterKey

public FilterKey(String name,
                 Map params,
                 Map types,
                 EntityMode entityMode)
Method Detail

hashCode

public int hashCode()

equals

public boolean equals(Object other)

toString

public String toString()

createFilterKeys

public static Set createFilterKeys(Map enabledFilters,
                                   EntityMode entityMode)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HashtableCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class HashtableCache

java.lang.Object
    extended by org.hibernate.cache.HashtableCache
All Implemented Interfaces:
Cache
public class HashtableCache
extends Object
implements Cache

A lightweight implementation of the Cache interface

Author:
Gavin King

Constructor Summary
HashtableCache(String regionName)
Method Summary
void | clear() Clear the cache
void | destroy() Clean up
Object | get(Object key) Get an item from the cache, nontransactionally
long | getElementCountInMemory() The count of entries currently contained in the regions in-memory store.
long | getElementCountOnDisk() The count of entries currently contained in the regions disk store.
String | getRegionName() Get the name of the cache region
long | getSizeInMemory() The number of bytes is this cache region currently consuming in memory.
int | getTimeout() Get a reasonable "lock timeout"
void | lock(Object key) If this is a clustered cache, lock the item
long | nextTimestamp() Generate a timestamp
void | put(Object key, Object value) Add an item to the cache, nontransactionally, with failfast semantics
Object | read(Object key) Get an item from the cache
void | remove(Object key) Remove an item from the cache
Map | toMap() optional operation
String | toString()
void | unlock(Object key) If this is a clustered cache, unlock the item
void | update(Object key, Object value) Add an item to the cache
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HashtableCache

public HashtableCache(String regionName)
Method Detail

getRegionName

public String getRegionName()
Description copied from interface: Cache
Get the name of the cache region

Specified by:
getRegionName in interface Cache

read

public Object read(Object key)
            throws CacheException
Description copied from interface: Cache
Get an item from the cache

Specified by:
read in interface Cache
Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

get

public Object get(Object key)
           throws CacheException
Description copied from interface: Cache
Get an item from the cache, nontransactionally

Specified by:
get in interface Cache
Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

update

public void update(Object key,
                   Object value)
            throws CacheException
Description copied from interface: Cache
Add an item to the cache

Specified by:
update in interface Cache
Parameters:
key -
value -
Throws:
CacheException

put

public void put(Object key,
                Object value)
         throws CacheException
Description copied from interface: Cache
Add an item to the cache, nontransactionally, with failfast semantics

Specified by:
put in interface Cache
Parameters:
key -
value -
Throws:
CacheException

remove

public void remove(Object key)
            throws CacheException
Description copied from interface: Cache
Remove an item from the cache

Specified by:
remove in interface Cache
Throws:
CacheException

clear

public void clear()
           throws CacheException
Description copied from interface: Cache
Clear the cache

Specified by:
clear in interface Cache
Throws:
CacheException

destroy

public void destroy()
             throws CacheException
Description copied from interface: Cache
Clean up

Specified by:
destroy in interface Cache
Throws:
CacheException

lock

public void lock(Object key)
          throws CacheException
Description copied from interface: Cache
If this is a clustered cache, lock the item

Specified by:
lock in interface Cache
Throws:
CacheException

unlock

public void unlock(Object key)
            throws CacheException
Description copied from interface: Cache
If this is a clustered cache, unlock the item

Specified by:
unlock in interface Cache
Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Description copied from interface: Cache
Generate a timestamp

Specified by:
nextTimestamp in interface Cache

getTimeout

public int getTimeout()
Description copied from interface: Cache
Get a reasonable "lock timeout"

Specified by:
getTimeout in interface Cache

getSizeInMemory

public long getSizeInMemory()
Description copied from interface: Cache
The number of bytes is this cache region currently consuming in memory.

Specified by:
getSizeInMemory in interface Cache
Returns:
The number of bytes consumed by this region; -1 if unknown or unsupported.

getElementCountInMemory

public long getElementCountInMemory()
Description copied from interface: Cache
The count of entries currently contained in the regions in-memory store.

Specified by:
getElementCountInMemory in interface Cache
Returns:
The count of entries in memory; -1 if unknown or unsupported.

getElementCountOnDisk

public long getElementCountOnDisk()
Description copied from interface: Cache
The count of entries currently contained in the regions disk store.

Specified by:
getElementCountOnDisk in interface Cache
Returns:
The count of entries on disk; -1 if unknown or unsupported.

toMap

public Map toMap()
Description copied from interface: Cache
optional operation

Specified by:
toMap in interface Cache

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HashtableCacheProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class HashtableCacheProvider

java.lang.Object
    extended by org.hibernate.cache.HashtableCacheProvider
All Implemented Interfaces:
CacheProvider
public class HashtableCacheProvider
extends Object
implements CacheProvider

A simple in-memory Hashtable-based cache impl.

Author:
Gavin King

Constructor Summary
HashtableCacheProvider()
Method Summary
 Cache buildCache(String regionName, Properties properties)
Configure the cache
 boolean isMinimalPutsEnabledByDefault()
 long nextTimestamp()
Generate a timestamp
 void start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HashtableCacheProvider

public HashtableCacheProvider()
Method Detail

buildCache

public Cache buildCache(String regionName,
                        Properties properties)
                 throws CacheException
Description copied from interface: CacheProvider
Configure the cache

Specified by:
buildCache in interface CacheProvider
Parameters:
regionName - the name of the cache region
properties - configuration settings
Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Description copied from interface: CacheProvider
Generate a timestamp

Specified by:
nextTimestamp in interface CacheProvider

start

public void start(Properties properties)
           throws CacheException
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.

Specified by:
start in interface CacheProvider
Parameters:
properties - current configuration settings.
Throws:
CacheException

stop

public void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().

Specified by:
stop in interface CacheProvider

isMinimalPutsEnabledByDefault

public boolean isMinimalPutsEnabledByDefault()
Specified by:
isMinimalPutsEnabledByDefault in interface CacheProvider
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JndiBoundTreeCacheProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class JndiBoundTreeCacheProvider

java.lang.Object
    extended by org.hibernate.cache.AbstractJndiBoundCacheProvider
        extended by org.hibernate.cache.JndiBoundTreeCacheProvider
All Implemented Interfaces:
CacheProvider
public class JndiBoundTreeCacheProvider
extends AbstractJndiBoundCacheProvider

Support for JBossCache (TreeCache), where the cache instance is available via JNDI lookup.

Author:
Steve Ebersole

Constructor Summary
JndiBoundTreeCacheProvider()
Method Summary
Cache | buildCache(String regionName, Properties properties) Construct a Cache representing the "region" within in the underlying cache provider.
org.jboss.cache.TreeCache | getTreeCacheInstance()
boolean | isMinimalPutsEnabledByDefault() By default, should minimal-puts mode be enabled when using this cache.
long | nextTimestamp() Generate a timestamp
void | prepare(Properties properties)
Methods inherited from class org.hibernate.cache.AbstractJndiBoundCacheProvider
getCache, release, start, stop
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JndiBoundTreeCacheProvider

public JndiBoundTreeCacheProvider()
Method Detail

buildCache

public Cache buildCache(String regionName,
                        Properties properties)
                 throws CacheException
Construct a Cache representing the "region" within in the underlying cache provider.

Parameters:
regionName - the name of the cache region
properties - configuration settings
Throws:
CacheException

prepare

public void prepare(Properties properties)
             throws CacheException
Overrides:
prepare in class AbstractJndiBoundCacheProvider
Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Generate a timestamp

isMinimalPutsEnabledByDefault

public boolean isMinimalPutsEnabledByDefault()
By default, should minimal-puts mode be enabled when using this cache.

Since TreeCache is a clusterable cache and we are only getting a reference the instance from JNDI, safest to assume a clustered setup and return true here.

Returns:
True.

getTreeCacheInstance

public org.jboss.cache.TreeCache getTreeCacheInstance()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoCacheProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class NoCacheProvider

java.lang.Object
    extended by org.hibernate.cache.NoCacheProvider
All Implemented Interfaces:
CacheProvider
public class NoCacheProvider
extends Object
implements CacheProvider

Implementation of NoCacheProvider.

Author:
Steve Ebersole

Constructor Summary
NoCacheProvider()
Method Summary
 Cache buildCache(String regionName, Properties properties)
Configure the cache
 boolean isMinimalPutsEnabledByDefault()
 long nextTimestamp()
Generate a timestamp
 void start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NoCacheProvider

public NoCacheProvider()
Method Detail

buildCache

public Cache buildCache(String regionName,
                        Properties properties)
                 throws CacheException
Configure the cache

Specified by:
buildCache in interface CacheProvider
Parameters:
regionName - the name of the cache region
properties - configuration settings
Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Generate a timestamp

Specified by:
nextTimestamp in interface CacheProvider

start

public void start(Properties properties)
           throws CacheException
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.

Specified by:
start in interface CacheProvider
Parameters:
properties - current configuration settings.
Throws:
CacheException

stop

public void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().

Specified by:
stop in interface CacheProvider

isMinimalPutsEnabledByDefault

public boolean isMinimalPutsEnabledByDefault()
Specified by:
isMinimalPutsEnabledByDefault in interface CacheProvider
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonstrictReadWriteCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class NonstrictReadWriteCache

java.lang.Object
    extended by org.hibernate.cache.NonstrictReadWriteCache
All Implemented Interfaces:
CacheConcurrencyStrategy
public class NonstrictReadWriteCache
extends Object
implements CacheConcurrencyStrategy

Caches data that is sometimes updated without ever locking the cache. If concurrent access to an item is possible, this concurrency strategy makes no guarantee that the item returned from the cache is the latest version available in the database. Configure your cache timeout accordingly! This is an "asynchronous" concurrency strategy.

Author:
Gavin King
See Also:
for a much stricter algorithm

Nested Class Summary
Nested classes inherited from class org.hibernate.cache.CacheConcurrencyStrategy
CacheConcurrencyStrategy.SoftLock
Constructor Summary
NonstrictReadWriteCache()
Method Summary
boolean | afterInsert(Object key, Object value, Object version) Do nothing.
boolean | afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock lock) Invalidate the item (again, for safety).
void | clear() Evict all items from the cache immediately.
void | destroy() Clean up all resources.
void | evict(Object key) Invalidate the item
Object | get(Object key, long txTimestamp) Get the most recent version, if available.
Cache | getCache() Get the wrapped cache implementation
String | getRegionName() Get the cache region name
boolean | insert(Object key, Object value, Object currentVersion) Invalidate the item
CacheConcurrencyStrategy.SoftLock | lock(Object key, Object version) Do nothing.
boolean | put(Object key, Object value, long txTimestamp, Object version, Comparator versionComparator, boolean minimalPut) Add an item to the cache.
void | release(Object key, CacheConcurrencyStrategy.SoftLock lock) Invalidate the item (again, for safety).
void | remove(Object key) Evict an item from the cache immediately (without regard for transaction isolation).
void | setCache(Cache cache) Set the underlying cache implementation.
String | toString()
boolean | update(Object key, Object value, Object currentVersion, Object previousVersion) Do nothing.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NonstrictReadWriteCache

public NonstrictReadWriteCache()
Method Detail

setCache

public void setCache(Cache cache)
Description copied from interface: CacheConcurrencyStrategy
Set the underlying cache implementation.

Specified by:
setCache in interface CacheConcurrencyStrategy
Parameters:
cache -

getCache

public Cache getCache()
Description copied from interface: CacheConcurrencyStrategy
Get the wrapped cache implementation

Specified by:
getCache in interface CacheConcurrencyStrategy

get

public Object get(Object key,
                  long txTimestamp)
           throws CacheException
Get the most recent version, if available.

Specified by:
get in interface CacheConcurrencyStrategy
Parameters:
key -
txTimestamp - a timestamp prior to the transaction start time
Returns:
the cached object or null
Throws:
CacheException

put

public boolean put(Object key,
                   Object value,
                   long txTimestamp,
                   Object version,
                   Comparator versionComparator,
                   boolean minimalPut)
            throws CacheException
Add an item to the cache.

Specified by:
put in interface CacheConcurrencyStrategy
Parameters:
key -
value -
txTimestamp - a timestamp prior to the transaction start time
version - the item version number
versionComparator - a comparator used to compare version numbers
minimalPut - indicates that the cache should avoid a put is the item is already cached
Returns:
true if the object was successfully cached
Throws:
CacheException

lock

public CacheConcurrencyStrategy.SoftLock lock(Object key,
                                              Object version)
                                       throws CacheException
Do nothing.

Specified by:
lock in interface CacheConcurrencyStrategy
Parameters:
key -
version -
Returns:
null, no lock
Throws:
CacheException

remove

public void remove(Object key)
            throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Evict an item from the cache immediately (without regard for transaction isolation).

Specified by:
remove in interface CacheConcurrencyStrategy
Parameters:
key -
Throws:
CacheException

clear

public void clear()
           throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Evict all items from the cache immediately.

Specified by:
clear in interface CacheConcurrencyStrategy
Throws:
CacheException

destroy

public void destroy()
Description copied from interface: CacheConcurrencyStrategy
Clean up all resources.

Specified by:
destroy in interface CacheConcurrencyStrategy

evict

public void evict(Object key)
           throws CacheException
Invalidate the item

Specified by:
evict in interface CacheConcurrencyStrategy
Throws:
CacheException

insert

public boolean insert(Object key,
                      Object value,
                      Object currentVersion)
Invalidate the item

Specified by:
insert in interface CacheConcurrencyStrategy

update

public boolean update(Object key,
                      Object value,
                      Object currentVersion,
                      Object previousVersion)
Do nothing.

Specified by:
update in interface CacheConcurrencyStrategy

release

public void release(Object key,
                    CacheConcurrencyStrategy.SoftLock lock)
             throws CacheException
Invalidate the item (again, for safety).

Specified by:
release in interface CacheConcurrencyStrategy
Parameters:
key -
Throws:
CacheException

afterUpdate

public boolean afterUpdate(Object key,
                           Object value,
                           Object version,
                           CacheConcurrencyStrategy.SoftLock lock)
                    throws CacheException
Invalidate the item (again, for safety).

Specified by:
afterUpdate in interface CacheConcurrencyStrategy
Throws:
CacheException

afterInsert

public boolean afterInsert(Object key,
                           Object value,
                           Object version)
                    throws CacheException
Do nothing.

Specified by:
afterInsert in interface CacheConcurrencyStrategy
Throws:
CacheException

getRegionName

public String getRegionName()
Description copied from interface: CacheConcurrencyStrategy
Get the cache region name

Specified by:
getRegionName in interface CacheConcurrencyStrategy

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptimisticTreeCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class OptimisticTreeCache

java.lang.Object
    extended by org.hibernate.cache.OptimisticTreeCache
All Implemented Interfaces:
Cache, OptimisticCache
public class OptimisticTreeCache
extends Object
implements OptimisticCache

Represents a particular region within the given JBossCache TreeCache utilizing TreeCache's optimistic locking capabilities.

Author:
Steve Ebersole
See Also:
for more details

Nested Class Summary
static class | OptimisticTreeCache.CircumventChecksDataVersion Used to signal to a DataVersionAdapter to simply not perform any checks.
static class | OptimisticTreeCache.DataVersionAdapter
static class | OptimisticTreeCache.NonLockingDataVersion Used in regions where no locking should ever occur.
Constructor Summary
OptimisticTreeCache(org.jboss.cache.TreeCache cache, String regionName)
Method Summary
 void clear()
Clear the cache
 void destroy()
Clean up
 Object get(Object key)
Get an item from the cache, nontransactionally
 long getElementCountInMemory()
The count of entries currently contained in the regions in-memory store.
 long getElementCountOnDisk()
The count of entries currently contained in the regions disk store.
 String getRegionName()
Get the name of the cache region
 long getSizeInMemory()
The number of bytes is this cache region currently consuming in memory.
 int getTimeout()
Get a reasonable "lock timeout"
 void lock(Object key)
If this is a clustered cache, lock the item
 long nextTimestamp()
Generate a timestamp
 void put(Object key, Object value)
Add an item to the cache, nontransactionally, with failfast semantics
 Object read(Object key)
Get an item from the cache
 void remove(Object key)
Remove an item from the cache
 void setSource(OptimisticCacheSource source)
Indicates the "source" of the cached data.
 Map toMap()
optional operation
 String toString()
 void unlock(Object key)
If this is a clustered cache, unlock the item
 void update(Object key, Object value)
Add an item to the cache
 void writeInsert(Object key, Object value, Object currentVersion)
Called during CacheConcurrencyStrategy.insert(java.lang.Object, java.lang.Object, java.lang.Object) processing for transactional strategies.
 void writeLoad(Object key, Object value, Object currentVersion)
Called during CacheConcurrencyStrategy.put(java.lang.Object, java.lang.Object, long, java.lang.Object, java.util.Comparator, boolean) processing for transactional strategies.
 void writeUpdate(Object key, Object value, Object currentVersion, Object previousVersion)
Called during CacheConcurrencyStrategy.update(java.lang.Object, java.lang.Object, java.lang.Object, java.lang.Object) processing for transactional strategies.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OptimisticTreeCache

public OptimisticTreeCache(org.jboss.cache.TreeCache cache,
                           String regionName)
                    throws CacheException
Method Detail

setSource

public void setSource(OptimisticCacheSource source)
Description copied from interface: OptimisticCache
Indicates the "source" of the cached data. Currently this will only ever represent an EntityPersister.

Made available to the cache so that it can access certain information about versioning strategy.

Specified by:
setSource in interface OptimisticCache
Parameters:
source - The source.

writeInsert

public void writeInsert(Object key,
                        Object value,
                        Object currentVersion)
Description copied from interface: OptimisticCache
Called during CacheConcurrencyStrategy.insert(java.lang.Object, java.lang.Object, java.lang.Object) processing for transactional strategies. Indicates we have just performed an insert into the DB and now need to cache that entity's data.

Specified by:
writeInsert in interface OptimisticCache
Parameters:
key - The cache key.
value - The data to be cached.
currentVersion - The entity's version; or null if not versioned.

writeUpdate

public void writeUpdate(Object key,
                        Object value,
                        Object currentVersion,
                        Object previousVersion)
Description copied from interface: OptimisticCache
Called during CacheConcurrencyStrategy.update(java.lang.Object, java.lang.Object, java.lang.Object, java.lang.Object) processing for transactional strategies. Indicates we have just performed an update against the DB and now need to cache the updated state.

Specified by:
writeUpdate in interface OptimisticCache
Parameters:
key - The cache key.
value - The data to be cached.
currentVersion - The entity's current version
previousVersion - The entity's previous version (before the update); or null if not versioned.

writeLoad

public void writeLoad(Object key,
                      Object value,
                      Object currentVersion)
Description copied from interface: OptimisticCache
Called during CacheConcurrencyStrategy.put(java.lang.Object, java.lang.Object, long, java.lang.Object, java.util.Comparator, boolean) processing for transactional strategies. Indicates we have just loaded an entity's state from the database and need it cached.

Specified by:
writeLoad in interface OptimisticCache
Parameters:
key - The cache key.
value - The data to be cached.
currentVersion - The entity's version; or null if not versioned.

get

public Object get(Object key)
           throws CacheException
Description copied from interface: Cache
Get an item from the cache, nontransactionally

Specified by:
get in interface Cache
Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

read

public Object read(Object key)
            throws CacheException
Description copied from interface: Cache
Get an item from the cache

Specified by:
read in interface Cache
Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

update

public void update(Object key,
                   Object value)
            throws CacheException
Description copied from interface: Cache
Add an item to the cache

Specified by:
update in interface Cache
Parameters:
key -
value -
Throws:
CacheException

put

public void put(Object key,
                Object value)
         throws CacheException
Description copied from interface: Cache
Add an item to the cache, nontransactionally, with failfast semantics

Specified by:
put in interface Cache
Parameters:
key -
value -
Throws:
CacheException

remove

public void remove(Object key)
            throws CacheException
Description copied from interface: Cache
Remove an item from the cache

Specified by:
remove in interface Cache
Throws:
CacheException

clear

public void clear()
           throws CacheException
Description copied from interface: Cache
Clear the cache

Specified by:
clear in interface Cache
Throws:
CacheException

destroy

public void destroy()
             throws CacheException
Description copied from interface: Cache
Clean up

Specified by:
destroy in interface Cache
Throws:
CacheException

lock

public void lock(Object key)
          throws CacheException
Description copied from interface: Cache
If this is a clustered cache, lock the item

Specified by:
lock in interface Cache
Throws:
CacheException

unlock

public void unlock(Object key)
            throws CacheException
Description copied from interface: Cache
If this is a clustered cache, unlock the item

Specified by:
unlock in interface Cache
Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Description copied from interface: Cache
Generate a timestamp

Specified by:
nextTimestamp in interface Cache

getTimeout

public int getTimeout()
Description copied from interface: Cache
Get a reasonable "lock timeout"

Specified by:
getTimeout in interface Cache

getRegionName

public String getRegionName()
Description copied from interface: Cache
Get the name of the cache region

Specified by:
getRegionName in interface Cache

getSizeInMemory

public long getSizeInMemory()
Description copied from interface: Cache
The number of bytes is this cache region currently consuming in memory.

Specified by:
getSizeInMemory in interface Cache
Returns:
The number of bytes consumed by this region; -1 if unknown or unsupported.

getElementCountInMemory

public long getElementCountInMemory()
Description copied from interface: Cache
The count of entries currently contained in the regions in-memory store.

Specified by:
getElementCountInMemory in interface Cache
Returns:
The count of entries in memory; -1 if unknown or unsupported.

getElementCountOnDisk

public long getElementCountOnDisk()
Description copied from interface: Cache
The count of entries currently contained in the regions disk store.

Specified by:
getElementCountOnDisk in interface Cache
Returns:
The count of entries on disk; -1 if unknown or unsupported.

toMap

public Map toMap()
Description copied from interface: Cache
optional operation

Specified by:
toMap in interface Cache

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptimisticTreeCache.CircumventChecksDataVersion (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class OptimisticTreeCache.CircumventChecksDataVersion

java.lang.Object
    extended by org.hibernate.cache.OptimisticTreeCache.CircumventChecksDataVersion
All Implemented Interfaces:
org.jboss.cache.optimistic.DataVersion, Serializable
Enclosing class:
OptimisticTreeCache
public static class OptimisticTreeCache.CircumventChecksDataVersion
extends Object
implements org.jboss.cache.optimistic.DataVersion

Used to signal to a DataVersionAdapter to simply not perform any checks. This is currently needed for proper handling of remove() calls for entity cache regions (we do not know the version info...).

See Also:
Serialized Form

Field Summary
static org.jboss.cache.optimistic.DataVersion INSTANCE
Constructor Summary
OptimisticTreeCache.CircumventChecksDataVersion()
Method Summary
 boolean newerThan(org.jboss.cache.optimistic.DataVersion dataVersion)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INSTANCE

public static final org.jboss.cache.optimistic.DataVersion INSTANCE
Constructor Detail

OptimisticTreeCache.CircumventChecksDataVersion

public OptimisticTreeCache.CircumventChecksDataVersion()
Method Detail

newerThan

public boolean newerThan(org.jboss.cache.optimistic.DataVersion dataVersion)
Specified by:
newerThan in interface org.jboss.cache.optimistic.DataVersion
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptimisticTreeCache.DataVersionAdapter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class OptimisticTreeCache.DataVersionAdapter

java.lang.Object
    extended by org.hibernate.cache.OptimisticTreeCache.DataVersionAdapter
All Implemented Interfaces:
org.jboss.cache.optimistic.DataVersion, Serializable
Enclosing class:
OptimisticTreeCache
public static class OptimisticTreeCache.DataVersionAdapter
extends Object
implements org.jboss.cache.optimistic.DataVersion

See Also:
Serialized Form

Constructor Summary
OptimisticTreeCache.DataVersionAdapter(Object currentVersion, Object previousVersion, Comparator versionComparator, String sourceIdentifer)
Method Summary
 boolean newerThan(org.jboss.cache.optimistic.DataVersion dataVersion)
newerThan() call is dispatched against the DataVersion currently associated with the node; the passed dataVersion param is the DataVersion associated with the data we are trying to put into the node.
 String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OptimisticTreeCache.DataVersionAdapter

public OptimisticTreeCache.DataVersionAdapter(Object currentVersion,
                                              Object previousVersion,
                                              Comparator versionComparator,
                                              String sourceIdentifer)
Method Detail

newerThan

public boolean newerThan(org.jboss.cache.optimistic.DataVersion dataVersion)
newerThan() call is dispatched against the DataVersion currently associated with the node; the passed dataVersion param is the DataVersion associated with the data we are trying to put into the node.

we are expected to return true in the case where we (the current node DataVersion) are newer that then incoming value. Returning true here essentially means that a optimistic lock failure has occured (because conversely, the value we are trying to put into the node is "older than" the value already there...)

Specified by:
newerThan in interface org.jboss.cache.optimistic.DataVersion

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptimisticTreeCache.NonLockingDataVersion (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class OptimisticTreeCache.NonLockingDataVersion

java.lang.Object
    extended by org.hibernate.cache.OptimisticTreeCache.NonLockingDataVersion
All Implemented Interfaces:
org.jboss.cache.optimistic.DataVersion, Serializable
Enclosing class:
OptimisticTreeCache
public static class OptimisticTreeCache.NonLockingDataVersion
extends Object
implements org.jboss.cache.optimistic.DataVersion

Used in regions where no locking should ever occur. This includes query-caches, update-timestamps caches, collection caches, and entity caches where the entity is not versioned.

See Also:
Serialized Form

Field Summary
static org.jboss.cache.optimistic.DataVersion INSTANCE
Constructor Summary
OptimisticTreeCache.NonLockingDataVersion()
Method Summary
 boolean newerThan(org.jboss.cache.optimistic.DataVersion dataVersion)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INSTANCE

public static final org.jboss.cache.optimistic.DataVersion INSTANCE
Constructor Detail

OptimisticTreeCache.NonLockingDataVersion

public OptimisticTreeCache.NonLockingDataVersion()
Method Detail

newerThan

public boolean newerThan(org.jboss.cache.optimistic.DataVersion dataVersion)
Specified by:
newerThan in interface org.jboss.cache.optimistic.DataVersion
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptimisticTreeCacheProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class OptimisticTreeCacheProvider

java.lang.Object
    extended by org.hibernate.cache.OptimisticTreeCacheProvider
All Implemented Interfaces:
CacheProvider
public class OptimisticTreeCacheProvider
extends Object
implements CacheProvider

Support for a standalone JBossCache TreeCache instance utilizing TreeCache's optimistic locking capabilities. This capability was added in JBossCache version 1.3.0; as such this provider will only work with that version or higher.

The TreeCache instance is configured via a local config resource. The resource to be used for configuration can be controlled by specifying a value for the CONFIG_RESOURCE config property.

Author:
Steve Ebersole

Field Summary
static String | CONFIG_RESOURCE Deprecated. use Environment.CACHE_PROVIDER_CONFIG
static String | DEFAULT_CONFIG
Constructor Summary
OptimisticTreeCacheProvider()
Method Summary
 Cache buildCache(String regionName, Properties properties)
Construct and configure the Cache representation of a named cache region.
 org.jboss.cache.TreeCache getUnderlyingCache()
 boolean isMinimalPutsEnabledByDefault()
 long nextTimestamp()
Generate a timestamp
 void start(Properties properties)
Prepare the underlying JBossCache TreeCache instance.
 void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONFIG_RESOURCE

public static final String CONFIG_RESOURCE
Deprecated. use Environment.CACHE_PROVIDER_CONFIG

See Also:
Constant Field Values

DEFAULT_CONFIG

public static final String DEFAULT_CONFIG
See Also:
Constant Field Values
Constructor Detail

OptimisticTreeCacheProvider

public OptimisticTreeCacheProvider()
Method Detail

buildCache

public Cache buildCache(String regionName,
                        Properties properties)
                 throws CacheException
Construct and configure the Cache representation of a named cache region.

Specified by:
buildCache in interface CacheProvider
Parameters:
regionName - the name of the cache region
properties - configuration settings
Returns:
The Cache representation of the named cache region.
Throws:
CacheException - Indicates an error building the cache region.

nextTimestamp

public long nextTimestamp()
Description copied from interface: CacheProvider
Generate a timestamp

Specified by:
nextTimestamp in interface CacheProvider

start

public void start(Properties properties)
Prepare the underlying JBossCache TreeCache instance.

Specified by:
start in interface CacheProvider
Parameters:
properties - All current config settings.
Throws:
CacheException - Indicates a problem preparing cache for use.

stop

public void stop()
Description copied from interface: CacheProvider
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().

Specified by:
stop in interface CacheProvider

isMinimalPutsEnabledByDefault

public boolean isMinimalPutsEnabledByDefault()
Specified by:
isMinimalPutsEnabledByDefault in interface CacheProvider

getUnderlyingCache

public org.jboss.cache.TreeCache getUnderlyingCache()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OSCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class OSCache

java.lang.Object
    extended by org.hibernate.cache.OSCache
All Implemented Interfaces:
Cache
public class OSCache
extends Object
implements Cache

Author:
Mathias Bogaert

Constructor Summary
OSCache(int refreshPeriod, String cron, String region)
Method Summary
void | clear() Clear the cache
void | destroy() Clean up
Object | get(Object key) Get an item from the cache, nontransactionally
long | getElementCountInMemory() The count of entries currently contained in the regions in-memory store.
long | getElementCountOnDisk() The count of entries currently contained in the regions disk store.
String | getRegionName() Get the name of the cache region
long | getSizeInMemory() The number of bytes is this cache region currently consuming in memory.
int | getTimeout() Get a reasonable "lock timeout"
void | lock(Object key) If this is a clustered cache, lock the item
long | nextTimestamp() Generate a timestamp
void | put(Object key, Object value) Add an item to the cache, nontransactionally, with failfast semantics
Object | read(Object key) Get an item from the cache
void | remove(Object key) Remove an item from the cache
void | setCacheCapacity(int cacheCapacity)
Map | toMap() optional operation
String | toString()
void | unlock(Object key) If this is a clustered cache, unlock the item
void | update(Object key, Object value) Add an item to the cache
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OSCache

public OSCache(int refreshPeriod,
               String cron,
               String region)
Method Detail

setCacheCapacity

public void setCacheCapacity(int cacheCapacity)

get

public Object get(Object key)
           throws CacheException
Description copied from interface: Cache
Get an item from the cache, nontransactionally

Specified by:
get in interface Cache
Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

read

public Object read(Object key)
            throws CacheException
Description copied from interface: Cache
Get an item from the cache

Specified by:
read in interface Cache
Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

update

public void update(Object key,
                   Object value)
            throws CacheException
Description copied from interface: Cache
Add an item to the cache

Specified by:
update in interface Cache
Parameters:
key -
value -
Throws:
CacheException

put

public void put(Object key,
                Object value)
         throws CacheException
Description copied from interface: Cache
Add an item to the cache, nontransactionally, with failfast semantics

Specified by:
put in interface Cache
Parameters:
key -
value -
Throws:
CacheException

remove

public void remove(Object key)
            throws CacheException
Description copied from interface: Cache
Remove an item from the cache

Specified by:
remove in interface Cache
Throws:
CacheException

clear

public void clear()
           throws CacheException
Description copied from interface: Cache
Clear the cache

Specified by:
clear in interface Cache
Throws:
CacheException

destroy

public void destroy()
             throws CacheException
Description copied from interface: Cache
Clean up

Specified by:
destroy in interface Cache
Throws:
CacheException

lock

public void lock(Object key)
          throws CacheException
Description copied from interface: Cache
If this is a clustered cache, lock the item

Specified by:
lock in interface Cache
Throws:
CacheException

unlock

public void unlock(Object key)
            throws CacheException
Description copied from interface: Cache
If this is a clustered cache, unlock the item

Specified by:
unlock in interface Cache
Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Description copied from interface: Cache
Generate a timestamp

Specified by:
nextTimestamp in interface Cache

getTimeout

public int getTimeout()
Description copied from interface: Cache
Get a reasonable "lock timeout"

Specified by:
getTimeout in interface Cache

getRegionName

public String getRegionName()
Description copied from interface: Cache
Get the name of the cache region

Specified by:
getRegionName in interface Cache

getSizeInMemory

public long getSizeInMemory()
Description copied from interface: Cache
The number of bytes is this cache region currently consuming in memory.

Specified by:
getSizeInMemory in interface Cache
Returns:
The number of bytes consumed by this region; -1 if unknown or unsupported.

getElementCountInMemory

public long getElementCountInMemory()
Description copied from interface: Cache
The count of entries currently contained in the regions in-memory store.

Specified by:
getElementCountInMemory in interface Cache
Returns:
The count of entries in memory; -1 if unknown or unsupported.

getElementCountOnDisk

public long getElementCountOnDisk()
Description copied from interface: Cache
The count of entries currently contained in the regions disk store.

Specified by:
getElementCountOnDisk in interface Cache
Returns:
The count of entries on disk; -1 if unknown or unsupported.

toMap

public Map toMap()
Description copied from interface: Cache
optional operation

Specified by:
toMap in interface Cache

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OSCacheProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class OSCacheProvider

java.lang.Object
    extended by org.hibernate.cache.OSCacheProvider
All Implemented Interfaces:
CacheProvider
public class OSCacheProvider
extends Object
implements CacheProvider

Support for OpenSymphony OSCache. This implementation assumes that identifiers have well-behaved toString() methods.

Author:
Mathias Bogaert

Field Summary
static String | OSCACHE_CAPACITY The OSCache cache capacity property suffix.
static String | OSCACHE_CRON The OSCache CRON expression property suffix.
static String | OSCACHE_REFRESH_PERIOD The OSCache refresh period property suffix.
Constructor Summary
OSCacheProvider()
Method Summary
 Cache buildCache(String region, Properties properties)
Builds a new Cache instance, and gets it's properties from the OSCache Config which reads the properties file (oscache.properties) from the classpath.
 boolean isMinimalPutsEnabledByDefault()
 long nextTimestamp()
Generate a timestamp
 void start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

OSCACHE_REFRESH_PERIOD

public static final String OSCACHE_REFRESH_PERIOD
The OSCache refresh period property suffix.

See Also:
Constant Field Values

OSCACHE_CRON

public static final String OSCACHE_CRON
The OSCache CRON expression property suffix.

See Also:
Constant Field Values

OSCACHE_CAPACITY

public static final String OSCACHE_CAPACITY
The OSCache cache capacity property suffix.

See Also:
Constant Field Values
Constructor Detail

OSCacheProvider

public OSCacheProvider()
Method Detail

buildCache

public Cache buildCache(String region,
                        Properties properties)
                 throws CacheException
Builds a new Cache instance, and gets it's properties from the OSCache Config which reads the properties file (oscache.properties) from the classpath. If the file cannot be found or loaded, an the defaults are used.

Specified by:
buildCache in interface CacheProvider
Parameters:
region -
properties -
Returns:
Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Description copied from interface: CacheProvider
Generate a timestamp

Specified by:
nextTimestamp in interface CacheProvider

start

public void start(Properties properties)
           throws CacheException
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.

Specified by:
start in interface CacheProvider
Parameters:
properties - current configuration settings.
Throws:
CacheException

stop

public void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().

Specified by:
stop in interface CacheProvider

isMinimalPutsEnabledByDefault

public boolean isMinimalPutsEnabledByDefault()
Specified by:
isMinimalPutsEnabledByDefault in interface CacheProvider
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryKey (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class QueryKey

java.lang.Object
    extended by org.hibernate.cache.QueryKey
All Implemented Interfaces:
Serializable
public class QueryKey
extends Object
implements Serializable

A key that identifies a particular query with bound parameter values

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
QueryKey(String queryString, QueryParameters queryParameters, Set filters, EntityMode entityMode)
Method Summary
boolean | equals(Object other)
int | hashCode()
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

QueryKey

public QueryKey(String queryString,
                QueryParameters queryParameters,
                Set filters,
                EntityMode entityMode)
Method Detail

equals

public boolean equals(Object other)

hashCode

public int hashCode()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReadOnlyCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class ReadOnlyCache

java.lang.Object
    extended by org.hibernate.cache.ReadOnlyCache
All Implemented Interfaces:
CacheConcurrencyStrategy
public class ReadOnlyCache
extends Object
implements CacheConcurrencyStrategy

Caches data that is never updated.

See Also:
CacheConcurrencyStrategy

Nested Class Summary
Nested classes inherited from class org.hibernate.cache.CacheConcurrencyStrategy
CacheConcurrencyStrategy.SoftLock
Constructor Summary
ReadOnlyCache()
Method Summary
boolean | afterInsert(Object key, Object value, Object version) Do nothing.
boolean | afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock lock) Unsupported!
void | clear() Evict all items from the cache immediately.
void | destroy() Clean up all resources.
void | evict(Object key) Do nothing.
Object | get(Object key, long timestamp) Attempt to retrieve an object from the cache.
Cache | getCache() Get the wrapped cache implementation
String | getRegionName() Get the cache region name
boolean | insert(Object key, Object value, Object currentVersion) Do nothing.
CacheConcurrencyStrategy.SoftLock | lock(Object key, Object version) Unsupported!
boolean | put(Object key, Object value, long timestamp, Object version, Comparator versionComparator, boolean minimalPut) Attempt to cache an object, after loading from the database.
void | release(Object key, CacheConcurrencyStrategy.SoftLock lock) Unsupported!
void | remove(Object key) Evict an item from the cache immediately (without regard for transaction isolation).
void | setCache(Cache cache) Set the underlying cache implementation.
String | toString()
boolean | update(Object key, Object value, Object currentVersion, Object previousVersion) Unsupported!
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ReadOnlyCache

public ReadOnlyCache()
Method Detail

setCache

public void setCache(Cache cache)
Description copied from interface: CacheConcurrencyStrategy
Set the underlying cache implementation.

Specified by:
setCache in interface CacheConcurrencyStrategy
Parameters:
cache -

getCache

public Cache getCache()
Description copied from interface: CacheConcurrencyStrategy
Get the wrapped cache implementation

Specified by:
getCache in interface CacheConcurrencyStrategy

getRegionName

public String getRegionName()
Description copied from interface: CacheConcurrencyStrategy
Get the cache region name

Specified by:
getRegionName in interface CacheConcurrencyStrategy

get

public Object get(Object key,
                  long timestamp)
           throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Attempt to retrieve an object from the cache. Mainly used in attempting to resolve entities/collections from the second level cache.

Specified by:
get in interface CacheConcurrencyStrategy
Parameters:
key -
timestamp - a timestamp prior to the transaction start time
Returns:
the cached object or null
Throws:
CacheException

lock

public CacheConcurrencyStrategy.SoftLock lock(Object key,
                                              Object version)
Unsupported!

Specified by:
lock in interface CacheConcurrencyStrategy
Parameters:
key -
version -

put

public boolean put(Object key,
                   Object value,
                   long timestamp,
                   Object version,
                   Comparator versionComparator,
                   boolean minimalPut)
            throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Attempt to cache an object, after loading from the database.

Specified by:
put in interface CacheConcurrencyStrategy
Parameters:
key -
value -
timestamp - a timestamp prior to the transaction start time
version - the item version number
versionComparator - a comparator used to compare version numbers
minimalPut - indicates that the cache should avoid a put is the item is already cached
Returns:
true if the object was successfully cached
Throws:
CacheException

release

public void release(Object key,
                    CacheConcurrencyStrategy.SoftLock lock)
Unsupported!

Specified by:
release in interface CacheConcurrencyStrategy
Parameters:
key -

clear

public void clear()
           throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Evict all items from the cache immediately.

Specified by:
clear in interface CacheConcurrencyStrategy
Throws:
CacheException

remove

public void remove(Object key)
            throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Evict an item from the cache immediately (without regard for transaction isolation).

Specified by:
remove in interface CacheConcurrencyStrategy
Parameters:
key -
Throws:
CacheException

destroy

public void destroy()
Description copied from interface: CacheConcurrencyStrategy
Clean up all resources.

Specified by:
destroy in interface CacheConcurrencyStrategy

afterUpdate

public boolean afterUpdate(Object key,
                           Object value,
                           Object version,
                           CacheConcurrencyStrategy.SoftLock lock)
                    throws CacheException
Unsupported!

Specified by:
afterUpdate in interface CacheConcurrencyStrategy
Throws:
CacheException

afterInsert

public boolean afterInsert(Object key,
                           Object value,
                           Object version)
                    throws CacheException
Do nothing.

Specified by:
afterInsert in interface CacheConcurrencyStrategy
Throws:
CacheException

evict

public void evict(Object key)
           throws CacheException
Do nothing.

Specified by:
evict in interface CacheConcurrencyStrategy
Throws:
CacheException

insert

public boolean insert(Object key,
                      Object value,
                      Object currentVersion)
Do nothing.

Specified by:
insert in interface CacheConcurrencyStrategy

update

public boolean update(Object key,
                      Object value,
                      Object currentVersion,
                      Object previousVersion)
Unsupported!

Specified by:
update in interface CacheConcurrencyStrategy

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReadWriteCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class ReadWriteCache

java.lang.Object
    extended by org.hibernate.cache.ReadWriteCache
All Implemented Interfaces:
CacheConcurrencyStrategy
public class ReadWriteCache
extends Object
implements CacheConcurrencyStrategy

Caches data that is sometimes updated while maintaining the semantics of "read committed" isolation level. If the database is set to "repeatable read", this concurrency strategy almost maintains the semantics. Repeatable read isolation is compromised in the case of concurrent writes. This is an "asynchronous" concurrency strategy.

If this strategy is used in a cluster, the underlying cache implementation must support distributed hard locks (which are held only momentarily). This strategy also assumes that the underlying cache implementation does not do asynchronous replication and that state has been fully replicated as soon as the lock is released.

See Also:
for a faster algorithm, CacheConcurrencyStrategy

Nested Class Summary
static class | ReadWriteCache.Item An item of cached data, timestamped with the time it was cached,.
static class | ReadWriteCache.Lock A soft lock which supports concurrent locking, timestamped with the time it was released
static interface | ReadWriteCache.Lockable
Nested classes inherited from class org.hibernate.cache.CacheConcurrencyStrategy
CacheConcurrencyStrategy.SoftLock
Constructor Summary
ReadWriteCache()
Method Summary
boolean | afterInsert(Object key, Object value, Object version) Add the new item to the cache, checking that no other transaction has accessed the item.
boolean | afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock clientLock) Re-cache the updated state, if and only if there there are no other concurrent soft locks.
void | clear() Evict all items from the cache immediately.
void | destroy() Clean up all resources.
void | evict(Object key) Do nothing.
Object | get(Object key, long txTimestamp) Do not return an item whose timestamp is later than the current transaction timestamp.
Cache | getCache() Get the wrapped cache implementation
String | getRegionName() Get the cache region name
boolean | insert(Object key, Object value, Object currentVersion) Do nothing.
CacheConcurrencyStrategy.SoftLock | lock(Object key, Object version) Stop any other transactions reading or writing this item to/from the cache.
boolean | put(Object key, Object value, long txTimestamp, Object version, Comparator versionComparator, boolean minimalPut) Do not add an item to the cache unless the current transaction timestamp is later than the timestamp at which the item was invalidated.
void | release(Object key, CacheConcurrencyStrategy.SoftLock clientLock) Release the soft lock on the item.
void | remove(Object key) Evict an item from the cache immediately (without regard for transaction isolation).
void | setCache(Cache cache) Set the underlying cache implementation.
String | toString()
boolean | update(Object key, Object value, Object currentVersion, Object previousVersion) Do nothing.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ReadWriteCache

public ReadWriteCache()
Method Detail

setCache

public void setCache(Cache cache)
Description copied from interface: CacheConcurrencyStrategy
Set the underlying cache implementation.

Specified by:
setCache in interface CacheConcurrencyStrategy
Parameters:
cache -

getCache

public Cache getCache()
Description copied from interface: CacheConcurrencyStrategy
Get the wrapped cache implementation

Specified by:
getCache in interface CacheConcurrencyStrategy

getRegionName

public String getRegionName()
Description copied from interface: CacheConcurrencyStrategy
Get the cache region name

Specified by:
getRegionName in interface CacheConcurrencyStrategy

get

public Object get(Object key,
                  long txTimestamp)
           throws CacheException
Do not return an item whose timestamp is later than the current transaction timestamp. (Otherwise we might compromise repeatable read unnecessarily.) Do not return an item which is soft-locked. Always go straight to the database instead.

Note that since reading an item from that cache does not actually go to the database, it is possible to see a kind of phantom read due to the underlying row being updated after we have read it from the cache. This would not be possible in a lock-based implementation of repeatable read isolation. It is also possible to overwrite changes made and committed by another transaction after the current transaction read the item from the cache. This problem would be caught by the update-time version-checking, if the data is versioned or timestamped.

Specified by:
get in interface CacheConcurrencyStrategy
Parameters:
key -
txTimestamp - a timestamp prior to the transaction start time
Returns:
the cached object or null
Throws:
CacheException

lock

public CacheConcurrencyStrategy.SoftLock lock(Object key,
                                              Object version)
                                       throws CacheException
Stop any other transactions reading or writing this item to/from the cache. Send them straight to the database instead. (The lock does time out eventually.) This implementation tracks concurrent locks of transactions which simultaneously attempt to write to an item.

Specified by:
lock in interface CacheConcurrencyStrategy
Parameters:
key -
version -
Throws:
CacheException

put

public boolean put(Object key,
                   Object value,
                   long txTimestamp,
                   Object version,
                   Comparator versionComparator,
                   boolean minimalPut)
            throws CacheException
Do not add an item to the cache unless the current transaction timestamp is later than the timestamp at which the item was invalidated. (Otherwise, a stale item might be re-added if the database is operating in repeatable read isolation mode.) For versioned data, don't add the item unless it is the later version.

Specified by:
put in interface CacheConcurrencyStrategy
Parameters:
key -
value -
txTimestamp - a timestamp prior to the transaction start time
version - the item version number
versionComparator - a comparator used to compare version numbers
minimalPut - indicates that the cache should avoid a put is the item is already cached
Returns:
true if the object was successfully cached
Throws:
CacheException

release

public void release(Object key,
                    CacheConcurrencyStrategy.SoftLock clientLock)
             throws CacheException
Release the soft lock on the item. Other transactions may now re-cache the item (assuming that no other transaction holds a simultaneous lock).

Specified by:
release in interface CacheConcurrencyStrategy
Parameters:
key -
Throws:
CacheException

clear

public void clear()
           throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Evict all items from the cache immediately.

Specified by:
clear in interface CacheConcurrencyStrategy
Throws:
CacheException

remove

public void remove(Object key)
            throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Evict an item from the cache immediately (without regard for transaction isolation).

Specified by:
remove in interface CacheConcurrencyStrategy
Parameters:
key -
Throws:
CacheException

destroy

public void destroy()
Description copied from interface: CacheConcurrencyStrategy
Clean up all resources.

Specified by:
destroy in interface CacheConcurrencyStrategy

afterUpdate

public boolean afterUpdate(Object key,
                           Object value,
                           Object version,
                           CacheConcurrencyStrategy.SoftLock clientLock)
                    throws CacheException
Re-cache the updated state, if and only if there there are no other concurrent soft locks. Release our lock.

Specified by:
afterUpdate in interface CacheConcurrencyStrategy
Throws:
CacheException

afterInsert

public boolean afterInsert(Object key,
                           Object value,
                           Object version)
                    throws CacheException
Add the new item to the cache, checking that no other transaction has accessed the item.

Specified by:
afterInsert in interface CacheConcurrencyStrategy
Throws:
CacheException

evict

public void evict(Object key)
           throws CacheException
Do nothing.

Specified by:
evict in interface CacheConcurrencyStrategy
Throws:
CacheException

insert

public boolean insert(Object key,
                      Object value,
                      Object currentVersion)
Do nothing.

Specified by:
insert in interface CacheConcurrencyStrategy

update

public boolean update(Object key,
                      Object value,
                      Object currentVersion,
                      Object previousVersion)
Do nothing.

Specified by:
update in interface CacheConcurrencyStrategy

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReadWriteCache.Item (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class ReadWriteCache.Item

java.lang.Object
    extended by org.hibernate.cache.ReadWriteCache.Item
All Implemented Interfaces:
ReadWriteCache.Lockable, Serializable
Enclosing class:
ReadWriteCache
public static final class ReadWriteCache.Item
extends Object
implements Serializable, ReadWriteCache.Lockable

An item of cached data, timestamped with the time it was cached,.

See Also:
ReadWriteCache, Serialized Form

Constructor Summary
ReadWriteCache.Item(Object value, Object version, long currentTimestamp)
Method Summary
long | getFreshTimestamp() The timestamp on the cached data
Object | getValue() The actual cached data
boolean | isGettable(long txTimestamp) Is this item visible to the timestamped transaction?
boolean | isLock() Not a lock!
boolean | isPuttable(long txTimestamp, Object newVersion, Comparator comparator) Don't overwite already cached items
ReadWriteCache.Lock | lock(long timeout, int id) Lock the item
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ReadWriteCache.Item

public ReadWriteCache.Item(Object value,
                           Object version,
                           long currentTimestamp)
Method Detail

getFreshTimestamp

public long getFreshTimestamp()
The timestamp on the cached data

getValue

public Object getValue()
The actual cached data

lock

public ReadWriteCache.Lock lock(long timeout,
                                int id)
Lock the item

Specified by:
lock in interface ReadWriteCache.Lockable

isLock

public boolean isLock()
Not a lock!

Specified by:
isLock in interface ReadWriteCache.Lockable

isGettable

public boolean isGettable(long txTimestamp)
Is this item visible to the timestamped transaction?

Specified by:
isGettable in interface ReadWriteCache.Lockable

isPuttable

public boolean isPuttable(long txTimestamp,
                          Object newVersion,
                          Comparator comparator)
Don't overwite already cached items

Specified by:
isPuttable in interface ReadWriteCache.Lockable

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReadWriteCache.Lock (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class ReadWriteCache.Lock

java.lang.Object
    extended by org.hibernate.cache.ReadWriteCache.Lock
All Implemented Interfaces:
CacheConcurrencyStrategy.SoftLock, ReadWriteCache.Lockable, Serializable
Enclosing class:
ReadWriteCache
public static final class ReadWriteCache.Lock
extends Object
implements Serializable, ReadWriteCache.Lockable, CacheConcurrencyStrategy.SoftLock

A soft lock which supports concurrent locking, timestamped with the time it was released

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
ReadWriteCache.Lock(long timeout, int id, Object version)
Method Summary
int | getId()
long | getUnlockTimestamp()
boolean | isGettable(long txTimestamp) locks are not returned to the client!
boolean | isLock() Yes, this is a lock
boolean | isPuttable(long txTimestamp, Object newVersion, Comparator comparator) Can the timestamped transaction re-cache this locked item now?
ReadWriteCache.Lock | lock(long timeout, int id) Increment the lock, setting the new lock timeout
String | toString()
void | unlock(long currentTimestamp) Decrement the lock, setting the unlock timestamp if now unlocked
boolean | wasLockedConcurrently() Was this lock held concurrently by multiple transactions?
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ReadWriteCache.Lock

public ReadWriteCache.Lock(long timeout,
                           int id,
                           Object version)
Method Detail

getUnlockTimestamp

public long getUnlockTimestamp()

lock

public ReadWriteCache.Lock lock(long timeout,
                                int id)
Increment the lock, setting the new lock timeout

Specified by:
lock in interface ReadWriteCache.Lockable

unlock

public void unlock(long currentTimestamp)
Decrement the lock, setting the unlock timestamp if now unlocked

Parameters:
currentTimestamp -

isPuttable

public boolean isPuttable(long txTimestamp,
                          Object newVersion,
                          Comparator comparator)
Can the timestamped transaction re-cache this locked item now?

Specified by:
isPuttable in interface ReadWriteCache.Lockable

wasLockedConcurrently

public boolean wasLockedConcurrently()
Was this lock held concurrently by multiple transactions?

isLock

public boolean isLock()
Yes, this is a lock

Specified by:
isLock in interface ReadWriteCache.Lockable

isGettable

public boolean isGettable(long txTimestamp)
locks are not returned to the client!

Specified by:
isGettable in interface ReadWriteCache.Lockable

getId

public int getId()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReadWriteCache.Lockable (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Interface ReadWriteCache.Lockable

All Known Implementing Classes:
ReadWriteCache.Item, ReadWriteCache.Lock
Enclosing interface:
ReadWriteCache
public static interface ReadWriteCache.Lockable

Method Summary
boolean | isGettable(long txTimestamp)
boolean | isLock()
boolean | isPuttable(long txTimestamp, Object newVersion, Comparator comparator)
ReadWriteCache.Lock | lock(long timeout, int id)

Method Detail

lock

public ReadWriteCache.Lock lock(long timeout,
                                int id)

isLock

public boolean isLock()

isGettable

public boolean isGettable(long txTimestamp)

isPuttable

public boolean isPuttable(long txTimestamp,
                          Object newVersion,
                          Comparator comparator)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


StandardQueryCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class StandardQueryCache

java.lang.Object
    extended by org.hibernate.cache.StandardQueryCache
All Implemented Interfaces:
QueryCache
public class StandardQueryCache
extends Object
implements QueryCache

The standard implementation of the Hibernate QueryCache interface. This implementation is very good at recognizing stale query results and and re-running queries when it detects this condition, recaching the new results.

Author:
Gavin King

Constructor Summary
StandardQueryCache(Settings settings, Properties props, UpdateTimestampsCache updateTimestampsCache, String regionName)
Method Summary
void | clear()
void | destroy()
List | get(QueryKey key, Type[] returnTypes, boolean isNaturalKeyLookup, Set spaces, SessionImplementor session)
Cache | getCache()
String | getRegionName()
protected boolean | isUpToDate(Set spaces, Long timestamp)
boolean | put(QueryKey key, Type[] returnTypes, List result, boolean isNaturalKeyLookup, SessionImplementor session)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

StandardQueryCache

public StandardQueryCache(Settings settings,
                          Properties props,
                          UpdateTimestampsCache updateTimestampsCache,
                          String regionName)
                   throws HibernateException
Method Detail

clear

public void clear()
           throws CacheException
Specified by:
clear in interface QueryCache
Throws:
CacheException

put

public boolean put(QueryKey key,
                   Type[] returnTypes,
                   List result,
                   boolean isNaturalKeyLookup,
                   SessionImplementor session)
            throws HibernateException
Specified by:
put in interface QueryCache
Throws:
HibernateException

get

public List get(QueryKey key,
                Type[] returnTypes,
                boolean isNaturalKeyLookup,
                Set spaces,
                SessionImplementor session)
         throws HibernateException
Specified by:
get in interface QueryCache
Throws:
HibernateException

isUpToDate

protected boolean isUpToDate(Set spaces,
                             Long timestamp)

destroy

public void destroy()
Specified by:
destroy in interface QueryCache

getCache

public Cache getCache()
Specified by:
getCache in interface QueryCache

getRegionName

public String getRegionName()
Specified by:
getRegionName in interface QueryCache

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StandardQueryCacheFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class StandardQueryCacheFactory

java.lang.Object
    extended by org.hibernate.cache.StandardQueryCacheFactory
All Implemented Interfaces:
QueryCacheFactory
public class StandardQueryCacheFactory
extends Object
implements QueryCacheFactory

Standard Hibernate implementation of the QueryCacheFactory interface. Returns instances of StandardQueryCache.

Constructor Summary
StandardQueryCacheFactory()
Method Summary
 QueryCache getQueryCache(String regionName, UpdateTimestampsCache updateTimestampsCache, Settings settings, Properties props)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StandardQueryCacheFactory

public StandardQueryCacheFactory()
Method Detail

getQueryCache

public QueryCache getQueryCache(String regionName,
                                UpdateTimestampsCache updateTimestampsCache,
                                Settings settings,
                                Properties props)
                         throws HibernateException
Specified by:
getQueryCache in interface QueryCacheFactory
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwarmCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class SwarmCache

java.lang.Object
    extended by org.hibernate.cache.SwarmCache
All Implemented Interfaces:
Cache
public class SwarmCache
extends Object
implements Cache

Author:
Jason Carreira, Gavin King

Constructor Summary
SwarmCache(net.sf.swarmcache.ObjectCache cache, String regionName)
Method Summary
void | clear() Clear the cache
void | destroy() Clean up
Object | get(Object key) Get an item from the cache
long | getElementCountInMemory() The count of entries currently contained in the regions in-memory store.
long | getElementCountOnDisk() The count of entries currently contained in the regions disk store.
String | getRegionName() Get the name of the cache region
long | getSizeInMemory() The number of bytes is this cache region currently consuming in memory.
int | getTimeout() Get a reasonable "lock timeout"
void | lock(Object key) If this is a clustered cache, lock the item
long | nextTimestamp() Generate a (coarse) timestamp
void | put(Object key, Object value) Add an item to the cache
Object | read(Object key) Get an item from the cache
void | remove(Object key) Remove an item from the cache
Map | toMap() optional operation
String | toString()
void | unlock(Object key) If this is a clustered cache, unlock the item
void | update(Object key, Object value) Add an item to the cache
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SwarmCache

public SwarmCache(net.sf.swarmcache.ObjectCache cache,
                  String regionName)
Method Detail

get

public Object get(Object key)
           throws CacheException
Get an item from the cache

Specified by:
get in interface Cache
Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

read

public Object read(Object key)
            throws CacheException
Description copied from interface: Cache
Get an item from the cache

Specified by:
read in interface Cache
Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

update

public void update(Object key,
                   Object value)
            throws CacheException
Add an item to the cache

Specified by:
update in interface Cache
Parameters:
key -
value -
Throws:
CacheException

put

public void put(Object key,
                Object value)
         throws CacheException
Add an item to the cache

Specified by:
put in interface Cache
Parameters:
key -
value -
Throws:
CacheException

remove

public void remove(Object key)
            throws CacheException
Remove an item from the cache

Specified by:
remove in interface Cache
Throws:
CacheException

clear

public void clear()
           throws CacheException
Clear the cache

Specified by:
clear in interface Cache
Throws:
CacheException

destroy

public void destroy()
             throws CacheException
Clean up

Specified by:
destroy in interface Cache
Throws:
CacheException

lock

public void lock(Object key)
          throws CacheException
If this is a clustered cache, lock the item

Specified by:
lock in interface Cache
Throws:
CacheException

unlock

public void unlock(Object key)
            throws CacheException
If this is a clustered cache, unlock the item

Specified by:
unlock in interface Cache
Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Generate a (coarse) timestamp

Specified by:
nextTimestamp in interface Cache

getTimeout

public int getTimeout()
Get a reasonable "lock timeout"

Specified by:
getTimeout in interface Cache

getRegionName

public String getRegionName()
Description copied from interface: Cache
Get the name of the cache region

Specified by:
getRegionName in interface Cache

getSizeInMemory

public long getSizeInMemory()
Description copied from interface: Cache
The number of bytes is this cache region currently consuming in memory.

Specified by:
getSizeInMemory in interface Cache
Returns:
The number of bytes consumed by this region; -1 if unknown or unsupported.

getElementCountInMemory

public long getElementCountInMemory()
Description copied from interface: Cache
The count of entries currently contained in the regions in-memory store.

Specified by:
getElementCountInMemory in interface Cache
Returns:
The count of entries in memory; -1 if unknown or unsupported.

getElementCountOnDisk

public long getElementCountOnDisk()
Description copied from interface: Cache
The count of entries currently contained in the regions disk store.

Specified by:
getElementCountOnDisk in interface Cache
Returns:
The count of entries on disk; -1 if unknown or unsupported.

toMap

public Map toMap()
Description copied from interface: Cache
optional operation

Specified by:
toMap in interface Cache

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SwarmCacheProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class SwarmCacheProvider

java.lang.Object
    extended by org.hibernate.cache.SwarmCacheProvider
All Implemented Interfaces:
CacheProvider
public class SwarmCacheProvider
extends Object
implements CacheProvider

Support for SwarmCache replicated cache. SwarmCache does not support locking, so strict "read-write" semantics are unsupported.

Author:
Jason Carreira

Constructor Summary
SwarmCacheProvider()
Method Summary
 Cache buildCache(String regionName, Properties properties)
Configure the cache
 boolean isMinimalPutsEnabledByDefault()
 long nextTimestamp()
Generate a timestamp
 void start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SwarmCacheProvider

public SwarmCacheProvider()
Method Detail

buildCache

public Cache buildCache(String regionName,
                        Properties properties)
                 throws CacheException
Description copied from interface: CacheProvider
Configure the cache

Specified by:
buildCache in interface CacheProvider
Parameters:
regionName - the name of the cache region
properties - configuration settings
Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Description copied from interface: CacheProvider
Generate a timestamp

Specified by:
nextTimestamp in interface CacheProvider

start

public void start(Properties properties)
           throws CacheException
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.

Specified by:
start in interface CacheProvider
Parameters:
properties - current configuration settings.
Throws:
CacheException

stop

public void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().

Specified by:
stop in interface CacheProvider

isMinimalPutsEnabledByDefault

public boolean isMinimalPutsEnabledByDefault()
Specified by:
isMinimalPutsEnabledByDefault in interface CacheProvider
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Timestamper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class Timestamper

java.lang.Object
    extended by org.hibernate.cache.Timestamper
public final class Timestamper
extends Object

Generates increasing identifiers (in a single VM only). Not valid across multiple VMs. Identifiers are not necessarily strictly increasing, but usually are.

Field Summary
static short ONE_MS
Method Summary
static long next()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ONE_MS

public static final short ONE_MS
See Also:
Constant Field Values
Method Detail

next

public static long next()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransactionalCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class TransactionalCache

java.lang.Object
    extended by org.hibernate.cache.TransactionalCache
All Implemented Interfaces:
CacheConcurrencyStrategy
public class TransactionalCache
extends Object
implements CacheConcurrencyStrategy

Support for fully transactional cache implementations like JBoss TreeCache. Note that this might be a less scalable concurrency strategy than ReadWriteCache. This is a "synchronous" concurrency strategy.

Author:
Gavin King

Nested Class Summary
Nested classes inherited from class org.hibernate.cache.CacheConcurrencyStrategy
CacheConcurrencyStrategy.SoftLock
Constructor Summary
TransactionalCache()
Method Summary
 boolean afterInsert(Object key, Object value, Object version)
Do nothing.
 boolean afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock clientLock)
Do nothing.
 void clear()
Evict all items from the cache immediately.
 void destroy()
Clean up all resources.
 void evict(Object key)
Called after an item has become stale (before the transaction completes).
 Object get(Object key, long txTimestamp)
Attempt to retrieve an object from the cache.
 Cache getCache()
Get the wrapped cache implementation
 String getRegionName()
Get the cache region name
 boolean insert(Object key, Object value, Object currentVersion)
Called after an item has been inserted (before the transaction completes), instead of calling evict().
 CacheConcurrencyStrategy.SoftLock lock(Object key, Object version)
Do nothing, returning null.
 boolean put(Object key, Object value, long txTimestamp, Object version, Comparator versionComparator, boolean minimalPut)
Attempt to cache an object, after loading from the database.
 void release(Object key, CacheConcurrencyStrategy.SoftLock clientLock)
Do nothing.
 void remove(Object key)
Evict an item from the cache immediately (without regard for transaction isolation).
 void setCache(Cache cache)
Set the underlying cache implementation.
 String toString()
 boolean update(Object key, Object value, Object currentVersion, Object previousVersion)
Called after an item has been updated (before the transaction completes), instead of calling evict().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TransactionalCache

public TransactionalCache()
Method Detail

getRegionName

public String getRegionName()
Description copied from interface: CacheConcurrencyStrategy
Get the cache region name

Specified by:
getRegionName in interface CacheConcurrencyStrategy

get

public Object get(Object key,
                  long txTimestamp)
           throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Attempt to retrieve an object from the cache. Mainly used in attempting to resolve entities/collections from the second level cache.

Specified by:
get in interface CacheConcurrencyStrategy
Parameters:
key -
txTimestamp - a timestamp prior to the transaction start time
Returns:
the cached object or null
Throws:
CacheException

put

public boolean put(Object key,
                   Object value,
                   long txTimestamp,
                   Object version,
                   Comparator versionComparator,
                   boolean minimalPut)
            throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Attempt to cache an object, after loading from the database.

Specified by:
put in interface CacheConcurrencyStrategy
Parameters:
key -
value -
txTimestamp - a timestamp prior to the transaction start time
version - the item version number
versionComparator - a comparator used to compare version numbers
minimalPut - indicates that the cache should avoid a put is the item is already cached
Returns:
true if the object was successfully cached
Throws:
CacheException

lock

public CacheConcurrencyStrategy.SoftLock lock(Object key,
                                              Object version)
                                       throws CacheException
Do nothing, returning null.

Specified by:
lock in interface CacheConcurrencyStrategy
Parameters:
key -
version -
Throws:
CacheException

release

public void release(Object key,
                    CacheConcurrencyStrategy.SoftLock clientLock)
             throws CacheException
Do nothing.

Specified by:
release in interface CacheConcurrencyStrategy
Parameters:
key -
Throws:
CacheException

update

public boolean update(Object key,
                      Object value,
                      Object currentVersion,
                      Object previousVersion)
               throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Called after an item has been updated (before the transaction completes), instead of calling evict(). This method is used by "synchronous" concurrency strategies.

Specified by:
update in interface CacheConcurrencyStrategy
Throws:
CacheException

insert

public boolean insert(Object key,
                      Object value,
                      Object currentVersion)
               throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Called after an item has been inserted (before the transaction completes), instead of calling evict(). This method is used by "synchronous" concurrency strategies.

Specified by:
insert in interface CacheConcurrencyStrategy
Throws:
CacheException

evict

public void evict(Object key)
           throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Called after an item has become stale (before the transaction completes). This method is used by "synchronous" concurrency strategies.

Specified by:
evict in interface CacheConcurrencyStrategy
Throws:
CacheException

remove

public void remove(Object key)
            throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Evict an item from the cache immediately (without regard for transaction isolation).

Specified by:
remove in interface CacheConcurrencyStrategy
Parameters:
key -
Throws:
CacheException

clear

public void clear()
           throws CacheException
Description copied from interface: CacheConcurrencyStrategy
Evict all items from the cache immediately.

Specified by:
clear in interface CacheConcurrencyStrategy
Throws:
CacheException

destroy

public void destroy()
Description copied from interface: CacheConcurrencyStrategy
Clean up all resources.

Specified by:
destroy in interface CacheConcurrencyStrategy

setCache

public void setCache(Cache cache)
Description copied from interface: CacheConcurrencyStrategy
Set the underlying cache implementation.

Specified by:
setCache in interface CacheConcurrencyStrategy
Parameters:
cache -

getCache

public Cache getCache()
Description copied from interface: CacheConcurrencyStrategy
Get the wrapped cache implementation

Specified by:
getCache in interface CacheConcurrencyStrategy

afterInsert

public boolean afterInsert(Object key,
                           Object value,
                           Object version)
                    throws CacheException
Do nothing.

Specified by:
afterInsert in interface CacheConcurrencyStrategy
Throws:
CacheException

afterUpdate

public boolean afterUpdate(Object key,
                           Object value,
                           Object version,
                           CacheConcurrencyStrategy.SoftLock clientLock)
                    throws CacheException
Do nothing.

Specified by:
afterUpdate in interface CacheConcurrencyStrategy
Throws:
CacheException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TreeCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class TreeCache

java.lang.Object
    extended by org.hibernate.cache.TreeCache
All Implemented Interfaces:
Cache
public class TreeCache
extends Object
implements Cache

Represents a particular region within the given JBossCache TreeCache.

Author:
Gavin King

Constructor Summary
TreeCache(org.jboss.cache.TreeCache cache, String regionName, TransactionManager transactionManager)
Method Summary
void | clear() Clear the cache
void | destroy() Clean up
Object | get(Object key) Get an item from the cache, nontransactionally
long | getElementCountInMemory() The count of entries currently contained in the regions in-memory store.
long | getElementCountOnDisk() The count of entries currently contained in the regions disk store.
String | getRegionName() Get the name of the cache region
long | getSizeInMemory() The number of bytes is this cache region currently consuming in memory.
int | getTimeout() Get a reasonable "lock timeout"
void | lock(Object key) If this is a clustered cache, lock the item
long | nextTimestamp() Generate a timestamp
void | put(Object key, Object value) Add an item to the cache, nontransactionally, with failfast semantics
Object | read(Object key) Get an item from the cache
void | remove(Object key) Remove an item from the cache
Map | toMap() optional operation
String | toString()
void | unlock(Object key) If this is a clustered cache, unlock the item
void | update(Object key, Object value) Add an item to the cache
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TreeCache

public TreeCache(org.jboss.cache.TreeCache cache,
                 String regionName,
                 TransactionManager transactionManager)
          throws CacheException
Method Detail

get

public Object get(Object key)
           throws CacheException
Description copied from interface: Cache
Get an item from the cache, nontransactionally

Specified by:
get in interface Cache
Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

read

public Object read(Object key)
            throws CacheException
Description copied from interface: Cache
Get an item from the cache

Specified by:
read in interface Cache
Parameters:
key -
Returns:
the cached object or null
Throws:
CacheException

update

public void update(Object key,
                   Object value)
            throws CacheException
Description copied from interface: Cache
Add an item to the cache

Specified by:
update in interface Cache
Parameters:
key -
value -
Throws:
CacheException

put

public void put(Object key,
                Object value)
         throws CacheException
Description copied from interface: Cache
Add an item to the cache, nontransactionally, with failfast semantics

Specified by:
put in interface Cache
Parameters:
key -
value -
Throws:
CacheException

remove

public void remove(Object key)
            throws CacheException
Description copied from interface: Cache
Remove an item from the cache

Specified by:
remove in interface Cache
Throws:
CacheException

clear

public void clear()
           throws CacheException
Description copied from interface: Cache
Clear the cache

Specified by:
clear in interface Cache
Throws:
CacheException

destroy

public void destroy()
             throws CacheException
Description copied from interface: Cache
Clean up

Specified by:
destroy in interface Cache
Throws:
CacheException

lock

public void lock(Object key)
          throws CacheException
Description copied from interface: Cache
If this is a clustered cache, lock the item

Specified by:
lock in interface Cache
Throws:
CacheException

unlock

public void unlock(Object key)
            throws CacheException
Description copied from interface: Cache
If this is a clustered cache, unlock the item

Specified by:
unlock in interface Cache
Throws:
CacheException

nextTimestamp

public long nextTimestamp()
Description copied from interface: Cache
Generate a timestamp

Specified by:
nextTimestamp in interface Cache

getTimeout

public int getTimeout()
Description copied from interface: Cache
Get a reasonable "lock timeout"

Specified by:
getTimeout in interface Cache

getRegionName

public String getRegionName()
Description copied from interface: Cache
Get the name of the cache region

Specified by:
getRegionName in interface Cache

getSizeInMemory

public long getSizeInMemory()
Description copied from interface: Cache
The number of bytes is this cache region currently consuming in memory.

Specified by:
getSizeInMemory in interface Cache
Returns:
The number of bytes consumed by this region; -1 if unknown or unsupported.

getElementCountInMemory

public long getElementCountInMemory()
Description copied from interface: Cache
The count of entries currently contained in the regions in-memory store.

Specified by:
getElementCountInMemory in interface Cache
Returns:
The count of entries in memory; -1 if unknown or unsupported.

getElementCountOnDisk

public long getElementCountOnDisk()
Description copied from interface: Cache
The count of entries currently contained in the regions disk store.

Specified by:
getElementCountOnDisk in interface Cache
Returns:
The count of entries on disk; -1 if unknown or unsupported.

toMap

public Map toMap()
Description copied from interface: Cache
optional operation

Specified by:
toMap in interface Cache

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TreeCacheProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class TreeCacheProvider

java.lang.Object
    extended by org.hibernate.cache.TreeCacheProvider
All Implemented Interfaces:
CacheProvider
public class TreeCacheProvider
extends Object
implements CacheProvider

Support for a standalone JBossCache (TreeCache) instance. The JBossCache is configured via a local config resource.

Author:
Gavin King

Field Summary
static String | CONFIG_RESOURCE Deprecated. use org.hibernate.cfg.Environment.CACHE_PROVIDER_CONFIG
static String | DEFAULT_CONFIG
Constructor Summary
TreeCacheProvider()
Method Summary
 Cache buildCache(String regionName, Properties properties)
Construct and configure the Cache representation of a named cache region.
 org.jboss.cache.TreeCache getUnderlyingCache()
 boolean isMinimalPutsEnabledByDefault()
 long nextTimestamp()
Generate a timestamp
 void start(Properties properties)
Prepare the underlying JBossCache TreeCache instance.
 void stop()
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONFIG_RESOURCE

public static final String CONFIG_RESOURCE
Deprecated. use org.hibernate.cfg.Environment.CACHE_PROVIDER_CONFIG

See Also:
Constant Field Values

DEFAULT_CONFIG

public static final String DEFAULT_CONFIG
See Also:
Constant Field Values
Constructor Detail

TreeCacheProvider

public TreeCacheProvider()
Method Detail

buildCache

public Cache buildCache(String regionName,
                        Properties properties)
                 throws CacheException
Construct and configure the Cache representation of a named cache region.

Specified by:
buildCache in interface CacheProvider
Parameters:
regionName - the name of the cache region
properties - configuration settings
Returns:
The Cache representation of the named cache region.
Throws:
CacheException - Indicates an error building the cache region.

nextTimestamp

public long nextTimestamp()
Description copied from interface: CacheProvider
Generate a timestamp

Specified by:
nextTimestamp in interface CacheProvider

start

public void start(Properties properties)
Prepare the underlying JBossCache TreeCache instance.

Specified by:
start in interface CacheProvider
Parameters:
properties - All current config settings.
Throws:
CacheException - Indicates a problem preparing cache for use.

stop

public void stop()
Description copied from interface: CacheProvider
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().

Specified by:
stop in interface CacheProvider

isMinimalPutsEnabledByDefault

public boolean isMinimalPutsEnabledByDefault()
Specified by:
isMinimalPutsEnabledByDefault in interface CacheProvider

getUnderlyingCache

public org.jboss.cache.TreeCache getUnderlyingCache()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UpdateTimestampsCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class UpdateTimestampsCache

java.lang.Object
    extended by org.hibernate.cache.UpdateTimestampsCache
public class UpdateTimestampsCache
extends Object

Tracks the timestamps of the most recent updates to particular tables. It is important that the cache timeout of the underlying cache implementation be set to a higher value than the timeouts of any of the query caches. In fact, we recommend that the the underlying cache not be configured for expiry at all. Note, in particular, that an LRU cache expiry policy is never appropriate.

Author:
Gavin King, Mikheil Kapanadze

Field Summary
static String REGION_NAME
Constructor Summary
UpdateTimestampsCache(Settings settings, Properties props)
Method Summary
void | clear()
void | destroy()
Cache | getCache()
String | getRegionName()
void | invalidate(Serializable[] spaces)
boolean | isUpToDate(Set spaces, Long timestamp)
void | preinvalidate(Serializable[] spaces)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

REGION_NAME

public static final String REGION_NAME
Constructor Detail

UpdateTimestampsCache

public UpdateTimestampsCache(Settings settings,
                             Properties props)
                      throws HibernateException
Method Detail

clear

public void clear()
           throws CacheException
Throws:
CacheException

preinvalidate

public void preinvalidate(Serializable[] spaces)
                   throws CacheException
Throws:
CacheException

invalidate

public void invalidate(Serializable[] spaces)
                throws CacheException
Throws:
CacheException

isUpToDate

public boolean isUpToDate(Set spaces,
                          Long timestamp)
                   throws HibernateException
Throws:
HibernateException

destroy

public void destroy()

getCache

public Cache getCache()

getRegionName

public String getRegionName()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CacheException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class CacheException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.cache.CacheException
All Implemented Interfaces:
Nestable, Serializable
Direct Known Subclasses:
NoCachingEnabledException
public class CacheException
extends HibernateException

Something went wrong in the cache

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
CacheException(Exception e)
CacheException(String s)
CacheException(String s, Exception e)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CacheException

public CacheException(String s)

CacheException

public CacheException(String s,
                      Exception e)

CacheException

public CacheException(Exception e)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


NoCachingEnabledException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache
Class NoCachingEnabledException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.cache.CacheException
                            extended by org.hibernate.cache.NoCachingEnabledException
All Implemented Interfaces:
Nestable, Serializable
public class NoCachingEnabledException
extends CacheException

Implementation of NoCachingEnabledException.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
NoCachingEnabledException()
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoCachingEnabledException

public NoCachingEnabledException()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.cache.entry (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.cache.entry

This package defines formats for disassembled state kept in the second level cache.

See:
Description

Interface Summary
CacheEntryStructure

Class Summary
CacheEntry | A cached instance of a persistent class
CollectionCacheEntry |
StructuredCacheEntry |
StructuredCollectionCacheEntry |
StructuredMapCacheEntry |
UnstructuredCacheEntry |

Package org.hibernate.cache.entry Description

This package defines formats for disassembled state kept in the second level cache.


org.hibernate.cache.entry Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.cache.entry

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.cache.entry.CacheEntry (implements java.io.Serializable)
    • class org.hibernate.cache.entry.CollectionCacheEntry (implements java.io.Serializable)
    • class org.hibernate.cache.entry.StructuredCacheEntry (implements org.hibernate.cache.entry.CacheEntryStructure)
    • class org.hibernate.cache.entry.StructuredCollectionCacheEntry (implements org.hibernate.cache.entry.CacheEntryStructure)
    • class org.hibernate.cache.entry.StructuredMapCacheEntry (implements org.hibernate.cache.entry.CacheEntryStructure)
    • class org.hibernate.cache.entry.UnstructuredCacheEntry (implements org.hibernate.cache.entry.CacheEntryStructure)

Interface Hierarchy

  • interface org.hibernate.cache.entry.CacheEntryStructure


Uses of Package org.hibernate.cache.entry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.cache.entry

Packages that use org.hibernate.cache.entry
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Classes in org.hibernate.cache.entry used by org.hibernate.cache.entry
CacheEntryStructure

Classes in org.hibernate.cache.entry used by org.hibernate.persister.collection
CacheEntryStructure

Classes in org.hibernate.cache.entry used by org.hibernate.persister.entity
CacheEntryStructure

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CacheEntryStructure (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache.entry
Interface CacheEntryStructure

All Known Implementing Classes:
StructuredCacheEntry, StructuredCollectionCacheEntry, StructuredMapCacheEntry, UnstructuredCacheEntry
public interface CacheEntryStructure

Author:
Gavin King

Method Summary
Object | destructure(Object map, SessionFactoryImplementor factory)
Object | structure(Object item)

Method Detail

structure

public Object structure(Object item)

destructure

public Object destructure(Object map,
                          SessionFactoryImplementor factory)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CacheEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache.entry
Class CacheEntry

java.lang.Object
    extended by org.hibernate.cache.entry.CacheEntry
All Implemented Interfaces:
Serializable
public final class CacheEntry
extends Object
implements Serializable

A cached instance of a persistent class

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
CacheEntry(Object[] state, EntityPersister persister, boolean unfetched, Object version, SessionImplementor session, Object owner)
Method Summary
boolean | areLazyPropertiesUnfetched()
Object[] | assemble(Object instance, Serializable id, EntityPersister persister, Interceptor interceptor, EventSource session)
Serializable[] | getDisassembledState()
String | getSubclass()
Object | getVersion()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CacheEntry

public CacheEntry(Object[] state,
                  EntityPersister persister,
                  boolean unfetched,
                  Object version,
                  SessionImplementor session,
                  Object owner)
           throws HibernateException
Method Detail

getSubclass

public String getSubclass()

areLazyPropertiesUnfetched

public boolean areLazyPropertiesUnfetched()

getVersion

public Object getVersion()

assemble

public Object[] assemble(Object instance,
                         Serializable id,
                         EntityPersister persister,
                         Interceptor interceptor,
                         EventSource session)
                  throws HibernateException
Throws:
HibernateException

getDisassembledState

public Serializable[] getDisassembledState()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CollectionCacheEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache.entry
Class CollectionCacheEntry

java.lang.Object
    extended by org.hibernate.cache.entry.CollectionCacheEntry
All Implemented Interfaces:
Serializable
public class CollectionCacheEntry
extends Object
implements Serializable

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
CollectionCacheEntry(PersistentCollection collection, CollectionPersister persister)
Method Summary
void | assemble(PersistentCollection collection, CollectionPersister persister, Object owner)
Serializable[] | getState()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CollectionCacheEntry

public CollectionCacheEntry(PersistentCollection collection,
                            CollectionPersister persister)
Method Detail

getState

public Serializable[] getState()

assemble

public void assemble(PersistentCollection collection,
                     CollectionPersister persister,
                     Object owner)

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StructuredCacheEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache.entry
Class StructuredCacheEntry

java.lang.Object
    extended by org.hibernate.cache.entry.StructuredCacheEntry
All Implemented Interfaces:
CacheEntryStructure
public class StructuredCacheEntry
extends Object
implements CacheEntryStructure

Author:
Gavin King

Constructor Summary
StructuredCacheEntry(EntityPersister persister)
Method Summary
Object | destructure(Object item, SessionFactoryImplementor factory)
Object | structure(Object item)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StructuredCacheEntry

public StructuredCacheEntry(EntityPersister persister)
Method Detail

destructure

public Object destructure(Object item,
                          SessionFactoryImplementor factory)
Specified by:
destructure in interface CacheEntryStructure

structure

public Object structure(Object item)
Specified by:
structure in interface CacheEntryStructure
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StructuredCollectionCacheEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache.entry
Class StructuredCollectionCacheEntry

java.lang.Object
    extended by org.hibernate.cache.entry.StructuredCollectionCacheEntry
All Implemented Interfaces:
CacheEntryStructure
public class StructuredCollectionCacheEntry
extends Object
implements CacheEntryStructure

Author:
Gavin King

Constructor Summary
StructuredCollectionCacheEntry()
Method Summary
Object | destructure(Object item, SessionFactoryImplementor factory)
Object | structure(Object item)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StructuredCollectionCacheEntry

public StructuredCollectionCacheEntry()
Method Detail

structure

public Object structure(Object item)
Specified by:
structure in interface CacheEntryStructure

destructure

public Object destructure(Object item,
                          SessionFactoryImplementor factory)
Specified by:
destructure in interface CacheEntryStructure
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StructuredMapCacheEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache.entry
Class StructuredMapCacheEntry

java.lang.Object
    extended by org.hibernate.cache.entry.StructuredMapCacheEntry
All Implemented Interfaces:
CacheEntryStructure
public class StructuredMapCacheEntry
extends Object
implements CacheEntryStructure

Author:
Gavin King

Constructor Summary
StructuredMapCacheEntry()
Method Summary
Object | destructure(Object item, SessionFactoryImplementor factory)
Object | structure(Object item)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StructuredMapCacheEntry

public StructuredMapCacheEntry()
Method Detail

structure

public Object structure(Object item)
Specified by:
structure in interface CacheEntryStructure

destructure

public Object destructure(Object item,
                          SessionFactoryImplementor factory)
Specified by:
destructure in interface CacheEntryStructure
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnstructuredCacheEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cache.entry
Class UnstructuredCacheEntry

java.lang.Object
    extended by org.hibernate.cache.entry.UnstructuredCacheEntry
All Implemented Interfaces:
CacheEntryStructure
public class UnstructuredCacheEntry
extends Object
implements CacheEntryStructure

Author:
Gavin King

Constructor Summary
UnstructuredCacheEntry()
Method Summary
Object | destructure(Object map, SessionFactoryImplementor factory)
Object | structure(Object item)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnstructuredCacheEntry

public UnstructuredCacheEntry()
Method Detail

structure

public Object structure(Object item)
Specified by:
structure in interface CacheEntryStructure

destructure

public Object destructure(Object map,
                          SessionFactoryImplementor factory)
Specified by:
destructure in interface CacheEntryStructure
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.cfg (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.cfg

This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

See:
Description

Interface Summary
NamingStrategy | A set of rules for determining the physical column and table names given the information in the mapping document.
QuerySecondPass | Bind query
SecondPass | Second pass operation

Class Summary
CollectionSecondPass | Collection second pass
Configuration | An instance of Configuration allows the application to specify properties and mapping documents to be used when creating a SessionFactory.
DefaultNamingStrategy | The default NamingStrategy
Environment | Provides access to configuration info passed in Properties objects.
ExtendsQueueEntry | Represents a mapping queued for delayed processing to await processing of an extends entity upon which it depends.
HbmBinder | Walks an XML mapping document and produces the Hibernate configuration-time metamodel (the classes in the mapping package)
ImprovedNamingStrategy | An improved naming strategy that prefers embedded underscores to mixed case names
Mappings | A collection of mappings from classes and collections to relational database tables.
Mappings.ColumnNames |
Mappings.TableDescription |
NamedSQLQuerySecondPass |
ResultSetMappingBinder |
ResultSetMappingSecondPass |
Settings | Settings that affect the behaviour of Hibernate at runtime.
SettingsFactory | Reads configuration properties and configures a Settings instance.

Package org.hibernate.cfg Description

This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.


org.hibernate.cfg Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.cfg

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.cfg.CollectionSecondPass (implements org.hibernate.cfg.SecondPass)
    • class org.hibernate.cfg.Configuration (implements java.io.Serializable)
    • class org.hibernate.cfg.DefaultNamingStrategy (implements org.hibernate.cfg.NamingStrategy, java.io.Serializable)
    • class org.hibernate.cfg.Environment
    • class org.hibernate.cfg.ExtendsQueueEntry
    • class org.hibernate.cfg.HbmBinder
    • class org.hibernate.cfg.ImprovedNamingStrategy (implements org.hibernate.cfg.NamingStrategy, java.io.Serializable)
    • class org.hibernate.cfg.Mappings (implements java.io.Serializable)
    • class org.hibernate.cfg.Mappings.ColumnNames (implements java.io.Serializable)
    • class org.hibernate.cfg.Mappings.TableDescription (implements java.io.Serializable)
    • class org.hibernate.cfg.ResultSetMappingBinder
      • class org.hibernate.cfg.NamedSQLQuerySecondPass (implements org.hibernate.cfg.QuerySecondPass)
      • class org.hibernate.cfg.ResultSetMappingSecondPass (implements org.hibernate.cfg.QuerySecondPass)
    • class org.hibernate.cfg.Settings
    • class org.hibernate.cfg.SettingsFactory (implements java.io.Serializable)

Interface Hierarchy

  • interface org.hibernate.cfg.NamingStrategy
  • interface java.io.Serializable
    • interface org.hibernate.cfg.SecondPass
      • interface org.hibernate.cfg.QuerySecondPass


Uses of Package org.hibernate.cfg (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.cfg

Packages that use org.hibernate.cfg
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.secure | Declarative security for CRUD operations on entities.
org.hibernate.tool.hbm2ddl | The hbm2ddl tool.
org.hibernate.util | Utility classes.

Classes in org.hibernate.cfg used by org.hibernate.cache
Settings
Settings that affect the behaviour of Hibernate at runtime.

Classes in org.hibernate.cfg used by org.hibernate.cfg
Configuration
An instance of Configuration allows the application to specify properties and mapping documents to be used when creating a SessionFactory.
ExtendsQueueEntry
Represents a mapping queued for delayed processing to await processing of an extends entity upon which it depends.
Mappings
A collection of mappings from classes and collections to relational database tables.
NamingStrategy
A set of rules for determining the physical column and table names given the information in the mapping document.
QuerySecondPass
Bind query
ResultSetMappingBinder
SecondPass
Second pass operation
Settings
Settings that affect the behaviour of Hibernate at runtime.
SettingsFactory
Reads configuration properties and configures a Settings instance.

Classes in org.hibernate.cfg used by org.hibernate.engine
Settings
Settings that affect the behaviour of Hibernate at runtime.

Classes in org.hibernate.cfg used by org.hibernate.event
Configuration
An instance of Configuration allows the application to specify properties and mapping documents to be used when creating a SessionFactory.

Classes in org.hibernate.cfg used by org.hibernate.impl
Configuration
An instance of Configuration allows the application to specify properties and mapping documents to be used when creating a SessionFactory.
Settings
Settings that affect the behaviour of Hibernate at runtime.

Classes in org.hibernate.cfg used by org.hibernate.persister
Configuration
An instance of Configuration allows the application to specify properties and mapping documents to be used when creating a SessionFactory.

Classes in org.hibernate.cfg used by org.hibernate.persister.collection
Configuration
An instance of Configuration allows the application to specify properties and mapping documents to be used when creating a SessionFactory.

Classes in org.hibernate.cfg used by org.hibernate.secure
Configuration
An instance of Configuration allows the application to specify properties and mapping documents to be used when creating a SessionFactory.

Classes in org.hibernate.cfg used by org.hibernate.tool.hbm2ddl
Configuration
An instance of Configuration allows the application to specify properties and mapping documents to be used when creating a SessionFactory.
Settings
Settings that affect the behaviour of Hibernate at runtime.

Classes in org.hibernate.cfg used by org.hibernate.util
Configuration
An instance of Configuration allows the application to specify properties and mapping documents to be used when creating a SessionFactory.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


NamingStrategy (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Interface NamingStrategy

All Known Implementing Classes:
DefaultNamingStrategy, ImprovedNamingStrategy
public interface NamingStrategy

A set of rules for determining the physical column and table names given the information in the mapping document. May be used to implement project-scoped naming standards for database objects. #propertyToTableName(String, String) should be replaced by collectionTableName(String,String,String,String,String)

Author:
Gavin King, Emmanuel Bernard
See Also:
DefaultNamingStrategy, ImprovedNamingStrategy

Method Summary
String | classToTableName(String className) Return a table name for an entity class
String | collectionTableName(String ownerEntity, String ownerEntityTable, String associatedEntity, String associatedEntityTable, String propertyName) Return a collection table name ie an association having a join table
String | columnName(String columnName) Alter the column name given in the mapping document
String | foreignKeyColumnName(String propertyName, String propertyEntityName, String propertyTableName, String referencedColumnName) Return the foreign key column name for the given parameters
String | joinKeyColumnName(String joinedColumn, String joinedTable) Return the join key column name ie a FK column used in a JOINED strategy or for a secondary table
String | logicalCollectionColumnName(String columnName, String propertyName, String referencedColumn) Returns the logical foreign key column name used to refer to this column in the mapping metadata
String | logicalCollectionTableName(String tableName, String ownerEntityTable, String associatedEntityTable, String propertyName) Returns the logical collection table name used to refer to a table in the mapping metadata
String | logicalColumnName(String columnName, String propertyName) Return the logical column name used to refer to a column in the metadata (like index, unique constraints etc) A full bijection is required between logicalNames and physical ones logicalName have to be case insersitively unique for a given table
String | propertyToColumnName(String propertyName) Return a column name for a property path expression
String | tableName(String tableName) Alter the table name given in the mapping document

Method Detail

classToTableName

public String classToTableName(String className)
Return a table name for an entity class

Parameters:
className - the fully-qualified class name
Returns:
a table name

propertyToColumnName

public String propertyToColumnName(String propertyName)
Return a column name for a property path expression

Parameters:
propertyName - a property path
Returns:
a column name

tableName

public String tableName(String tableName)
Alter the table name given in the mapping document

Parameters:
tableName - a table name
Returns:
a table name

columnName

public String columnName(String columnName)
Alter the column name given in the mapping document

Parameters:
columnName - a column name
Returns:
a column name

collectionTableName

public String collectionTableName(String ownerEntity,
                                  String ownerEntityTable,
                                  String associatedEntity,
                                  String associatedEntityTable,
                                  String propertyName)
Return a collection table name ie an association having a join table

Parameters:
ownerEntity -
ownerEntityTable - owner side table name
associatedEntity -
associatedEntityTable - reverse side table name if any
propertyName - collection role

joinKeyColumnName

public String joinKeyColumnName(String joinedColumn,
                                String joinedTable)
Return the join key column name ie a FK column used in a JOINED strategy or for a secondary table

Parameters:
joinedColumn - joined column name (logical one) used to join with
joinedTable - joined table name (ie the referenced table) used to join with

foreignKeyColumnName

public String foreignKeyColumnName(String propertyName,
                                   String propertyEntityName,
                                   String propertyTableName,
                                   String referencedColumnName)
Return the foreign key column name for the given parameters

Parameters:
propertyName - the property name involved
propertyEntityName -
propertyTableName - the property table name involved (logical one)
referencedColumnName - the referenced column name involved (logical one)

logicalColumnName

public String logicalColumnName(String columnName,
                                String propertyName)
Return the logical column name used to refer to a column in the metadata (like index, unique constraints etc) A full bijection is required between logicalNames and physical ones logicalName have to be case insersitively unique for a given table

Parameters:
columnName - given column name if any
propertyName - property name of this column

logicalCollectionTableName

public String logicalCollectionTableName(String tableName,
                                         String ownerEntityTable,
                                         String associatedEntityTable,
                                         String propertyName)
Returns the logical collection table name used to refer to a table in the mapping metadata

Parameters:
tableName - the metadata explicit name
ownerEntityTable - owner table entity table name (logical one)
associatedEntityTable - reverse side table name if any (logical one)
propertyName - collection role

logicalCollectionColumnName

public String logicalCollectionColumnName(String columnName,
                                          String propertyName,
                                          String referencedColumn)
Returns the logical foreign key column name used to refer to this column in the mapping metadata

Parameters:
columnName - given column name in the metadata if any
propertyName - property name
referencedColumn - referenced column name (logical one) in the join
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


QuerySecondPass (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Interface QuerySecondPass

All Superinterfaces:
SecondPass, Serializable
All Known Implementing Classes:
NamedSQLQuerySecondPass, ResultSetMappingSecondPass
public interface QuerySecondPass
extends SecondPass

Bind query

Author:
Emmanuel Bernard

Methods inherited from interface org.hibernate.cfg.SecondPass
doSecondPass

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SecondPass (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Interface SecondPass

All Superinterfaces:
Serializable
All Known Subinterfaces:
QuerySecondPass
All Known Implementing Classes:
CollectionSecondPass, NamedSQLQuerySecondPass, ResultSetMappingSecondPass
public interface SecondPass
extends Serializable

Second pass operation

Author:
Emmanuel Bernard

Method Summary
 void doSecondPass(Map persistentClasses)

Method Detail

doSecondPass

public void doSecondPass(Map persistentClasses)
                  throws MappingException
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CollectionSecondPass (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class CollectionSecondPass

java.lang.Object
    extended by org.hibernate.cfg.CollectionSecondPass
All Implemented Interfaces:
SecondPass, Serializable
public abstract class CollectionSecondPass
extends Object
implements SecondPass

Collection second pass

Author:
Emmanuel Bernard
See Also:
Serialized Form

Constructor Summary
CollectionSecondPass(Mappings mappings, Collection collection)
CollectionSecondPass(Mappings mappings, Collection collection, Map inheritedMetas)
Method Summary
void | doSecondPass(Map persistentClasses)
abstract void | secondPass(Map persistentClasses, Map inheritedMetas)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CollectionSecondPass

public CollectionSecondPass(Mappings mappings,
                            Collection collection,
                            Map inheritedMetas)

CollectionSecondPass

public CollectionSecondPass(Mappings mappings,
                            Collection collection)
Method Detail

doSecondPass

public void doSecondPass(Map persistentClasses)
                  throws MappingException
Specified by:
doSecondPass in interface SecondPass
Throws:
MappingException

secondPass

public abstract void secondPass(Map persistentClasses,
                                Map inheritedMetas)
                         throws MappingException
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Configuration (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class Configuration

java.lang.Object
    extended by org.hibernate.cfg.Configuration
All Implemented Interfaces:
Serializable
public class Configuration
extends Object
implements Serializable

An instance of Configuration allows the application to specify properties and mapping documents to be used when creating a SessionFactory. Usually an application will create a single Configuration, build a single instance of SessionFactory and then instantiate Sessions in threads servicing client requests. The Configuration is meant only as an initialization-time object. SessionFactorys are immutable and do not retain any association back to the Configuration.

A new Configuration will use the properties specified in hibernate.properties by default.

Author:
Gavin King
See Also:
SessionFactory, Serialized Form

Field Summary
protected List | auxiliaryDatabaseObjects
protected Map | classes
protected Map | collections
protected Map | columnNameBindingPerTable
protected Map | extendsQueue
protected Map | filterDefinitions
protected Map | imports
protected Map | namedQueries
protected Map | namedSqlQueries
protected NamingStrategy | namingStrategy
protected List | propertyReferences
protected List | secondPasses
protected SettingsFactory | settingsFactory
protected Map | sqlFunctions
protected Map | sqlResultSetMappings Map result set name, result set description
protected Map | tableNameBinding
protected Map | tables
protected Map | typeDefs
protected XMLHelper | xmlHelper
Constructor Summary
 | Configuration()
protected | Configuration(SettingsFactory settingsFactory)
Method Summary
protected void | add(org.dom4j.Document doc)
void | addAuxiliaryDatabaseObject(AuxiliaryDatabaseObject object)
Configuration | addCacheableFile(File xmlFile) If a cached xmlFile + ".bin" exists and is newer than xmlFile the ".bin" file will be read directly.
Configuration | addCacheableFile(String xmlFile)
Configuration | addClass(Class persistentClass) Read a mapping from an application resource, using a convention.
Configuration | addDirectory(File dir) Read all mapping documents from a directory tree.
Configuration | addDocument(org.w3c.dom.Document doc) Read mappings from a DOM Document
Configuration | addFile(File xmlFile) Read mappings from a particular XML file
Configuration | addFile(String xmlFile) Read mappings from a particular XML file
void | addFilterDefinition(FilterDefinition definition)
Configuration | addInputStream(InputStream xmlInputStream) Read mappings from an InputStream
Configuration | addJar(File jar) Read all mappings from a jar file
Configuration | addProperties(Properties extraProperties) Set the given properties
Configuration | addResource(String path) Read mappings from an application resource trying different classloaders.
Configuration | addResource(String path, ClassLoader classLoader) Read mappings from an application resource
void | addSqlFunction(String functionName, SQLFunction function)
Configuration | addURL(URL url) Read mappings from a URL
Configuration | addXML(String xml) Read mappings from a String
Mapping | buildMapping()
void | buildMappings() Call this to ensure the mappings are fully compiled/built.
SessionFactory | buildSessionFactory() Instantiate a new SessionFactory, using the properties and mappings in this configuration.
Settings | buildSettings() Create an object-oriented view of the configuration properties
Settings | buildSettings(Properties props)
Configuration | configure() Use the mappings and properties specified in an application resource named hibernate.cfg.xml.
Configuration | configure(org.w3c.dom.Document document) Use the mappings and properties specified in the given XML document.
Configuration | configure(File configFile) Use the mappings and properties specified in the given application file.
Configuration | configure(String resource) Use the mappings and properties specified in the given application resource.
Configuration | configure(URL url) Use the mappings and properties specified in the given document.
Mappings | createMappings() Create a new Mappings to add class and collection mappings to.
protected Configuration | doConfigure(org.dom4j.Document doc)
protected Configuration | doConfigure(InputStream stream, String resourceName) Use the mappings and properties specified in the given application resource.
protected org.dom4j.Document | findPossibleExtends() Find the first possible element in the queue of extends.
String[] | generateDropSchemaScript(Dialect dialect) Generate DDL for dropping tables
String[] | generateSchemaCreationScript(Dialect dialect) Generate DDL for creating tables
String[] | generateSchemaUpdateScript(Dialect dialect, DatabaseMetadata databaseMetadata) Generate DDL for altering tables
PersistentClass | getClassMapping(String persistentClass) Get the mapping for a particular class
Iterator | getClassMappings() Iterate the class mappings
Collection | getCollectionMapping(String role) Get the mapping for a particular collection role
Iterator | getCollectionMappings() Iterate the collection mappings
protected InputStream | getConfigurationInputStream(String resource) Get the configuration file as an InputStream.
EntityNotFoundDelegate | getEntityNotFoundDelegate() Retrieve the user-supplied delegate to handle non-existent entity scenarios.
org.xml.sax.EntityResolver | getEntityResolver()
EventListeners | getEventListeners()
Map | getFilterDefinitions()
Map | getImports() Get the query language imports
Interceptor | getInterceptor() Return the configured Interceptor
Map | getNamedQueries() Get the named queries
Map | getNamedSQLQueries()
NamingStrategy | getNamingStrategy()
Properties | getProperties() Get all properties
String | getProperty(String propertyName) Get a property
Map | getSqlFunctions()
Map | getSqlResultSetMappings()
Iterator | getTableMappings() Iterate the table mappings
Configuration | mergeProperties(Properties properties) Adds the incoming properties to the internap properties structure, as long as the internal structure does not already contain an entry for the given key.
protected void | parseMappingElement(org.dom4j.Element subelement, String name)
protected void | reset()
protected void | secondPassCompile()
protected void | secondPassCompileForeignKeys(Table table, Set done)
Configuration | setCacheConcurrencyStrategy(String clazz, String concurrencyStrategy) Set up a cache for an entity class
void | setCacheConcurrencyStrategy(String clazz, String concurrencyStrategy, String region)
Configuration | setCollectionCacheConcurrencyStrategy(String collectionRole, String concurrencyStrategy) Set up a cache for a collection role
void | setCollectionCacheConcurrencyStrategy(String collectionRole, String concurrencyStrategy, String region)
void | setEntityNotFoundDelegate(EntityNotFoundDelegate entityNotFoundDelegate) Specify a user-supplied delegate to be used to handle scenarios where an entity could not be located by specified id.
void | setEntityResolver(org.xml.sax.EntityResolver entityResolver) Set a custom entity resolver.
Configuration | setInterceptor(Interceptor interceptor) Configure an Interceptor
void | setListener(String type, Object listener)
void | setListeners(String type, Object[] listeners)
void | setListeners(String type, String[] listenerClasses)
Configuration | setNamingStrategy(NamingStrategy namingStrategy) Set a custom naming strategy
Configuration | setProperties(Properties properties) Specify a completely new set of properties
Configuration | setProperty(String propertyName, String value) Set a property
void | validateSchema(Dialect dialect, DatabaseMetadata databaseMetadata)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

classes

protected Map classes

imports

protected Map imports

collections

protected Map collections

tables

protected Map tables

auxiliaryDatabaseObjects

protected List auxiliaryDatabaseObjects

sqlFunctions

protected Map sqlFunctions

namedQueries

protected Map namedQueries

namedSqlQueries

protected Map namedSqlQueries

sqlResultSetMappings

protected Map sqlResultSetMappings
Map result set name, result set description

filterDefinitions

protected Map filterDefinitions

secondPasses

protected List secondPasses

propertyReferences

protected List propertyReferences

extendsQueue

protected Map extendsQueue

tableNameBinding

protected Map tableNameBinding

columnNameBindingPerTable

protected Map columnNameBindingPerTable

xmlHelper

protected transient XMLHelper xmlHelper

typeDefs

protected transient Map typeDefs

namingStrategy

protected NamingStrategy namingStrategy

settingsFactory

protected final SettingsFactory settingsFactory
Constructor Detail

Configuration

protected Configuration(SettingsFactory settingsFactory)

Configuration

public Configuration()
Method Detail

reset

protected void reset()

getClassMappings

public Iterator getClassMappings()
Iterate the class mappings

getCollectionMappings

public Iterator getCollectionMappings()
Iterate the collection mappings

getTableMappings

public Iterator getTableMappings()
Iterate the table mappings

getClassMapping

public PersistentClass getClassMapping(String persistentClass)
Get the mapping for a particular class

getCollectionMapping

public Collection getCollectionMapping(String role)
Get the mapping for a particular collection role

Parameters:
role - a collection role
Returns:
Collection

setEntityResolver

public void setEntityResolver(org.xml.sax.EntityResolver entityResolver)
Set a custom entity resolver. This entity resolver must be set before addXXX(misc) call. Default value is DTDEntityResolver

Parameters:
entityResolver - entity resolver to use

getEntityResolver

public org.xml.sax.EntityResolver getEntityResolver()

getEntityNotFoundDelegate

public EntityNotFoundDelegate getEntityNotFoundDelegate()
Retrieve the user-supplied delegate to handle non-existent entity scenarios. May be null.

Returns:
The user-supplied delegate

setEntityNotFoundDelegate

public void setEntityNotFoundDelegate(EntityNotFoundDelegate entityNotFoundDelegate)
Specify a user-supplied delegate to be used to handle scenarios where an entity could not be located by specified id. This is mainly intended for EJB3 implementations to be able to control how proxy initialization errors should be handled...

Parameters:
entityNotFoundDelegate - The delegate to use

addFile

public Configuration addFile(String xmlFile)
                      throws MappingException
Read mappings from a particular XML file

Parameters:
xmlFile - a path to a file
Throws:
MappingException

addFile

public Configuration addFile(File xmlFile)
                      throws MappingException
Read mappings from a particular XML file

Parameters:
xmlFile - a path to a file
Throws:
MappingException

addCacheableFile

public Configuration addCacheableFile(File xmlFile)
                               throws MappingException
If a cached xmlFile + ".bin" exists and is newer than xmlFile the ".bin" file will be read directly. Otherwise xmlFile is read and then serialized to xmlFile + ".bin" for use the next time.

Throws:
MappingException

addCacheableFile

public Configuration addCacheableFile(String xmlFile)
                               throws MappingException
Throws:
MappingException

addXML

public Configuration addXML(String xml)
                     throws MappingException
Read mappings from a String

Parameters:
xml - an XML string
Throws:
MappingException

addURL

public Configuration addURL(URL url)
                     throws MappingException
Read mappings from a URL

Parameters:
url -
Throws:
MappingException

addDocument

public Configuration addDocument(org.w3c.dom.Document doc)
                          throws MappingException
Read mappings from a DOM Document

Parameters:
doc - a DOM document
Throws:
MappingException

add

protected void add(org.dom4j.Document doc)
            throws MappingException
Throws:
MappingException

createMappings

public Mappings createMappings()
Create a new Mappings to add class and collection mappings to.

addInputStream

public Configuration addInputStream(InputStream xmlInputStream)
                             throws MappingException
Read mappings from an InputStream

Parameters:
xmlInputStream - an InputStream containing XML
Throws:
MappingException

addResource

public Configuration addResource(String path,
                                 ClassLoader classLoader)
                          throws MappingException
Read mappings from an application resource

Parameters:
path - a resource
classLoader - a ClassLoader to use
Throws:
MappingException

addResource

public Configuration addResource(String path)
                          throws MappingException
Read mappings from an application resource trying different classloaders. This method will try to load the resource first from the thread context classloader and then from the classloader that loaded Hibernate.

Throws:
MappingException

addClass

public Configuration addClass(Class persistentClass)
                       throws MappingException
Read a mapping from an application resource, using a convention. The class foo.bar.Foo is mapped by the file foo/bar/Foo.hbm.xml.

Parameters:
persistentClass - the mapped class
Throws:
MappingException

addJar

public Configuration addJar(File jar)
                     throws MappingException
Read all mappings from a jar file

Parameters:
jar - a jar file
Throws:
MappingException

addDirectory

public Configuration addDirectory(File dir)
                           throws MappingException
Read all mapping documents from a directory tree. Assume that any file named *.hbm.xml is a mapping document.

Parameters:
dir - a directory
Throws:
MappingException

generateDropSchemaScript

public String[] generateDropSchemaScript(Dialect dialect)
                                  throws HibernateException
Generate DDL for dropping tables

Throws:
HibernateException
See Also:
SchemaExport

generateSchemaCreationScript

public String[] generateSchemaCreationScript(Dialect dialect)
                                      throws HibernateException
Generate DDL for creating tables

Throws:
HibernateException
See Also:
SchemaExport

generateSchemaUpdateScript

public String[] generateSchemaUpdateScript(Dialect dialect,
                                           DatabaseMetadata databaseMetadata)
                                    throws HibernateException
Generate DDL for altering tables

Throws:
HibernateException
See Also:
SchemaUpdate

validateSchema

public void validateSchema(Dialect dialect,
                           DatabaseMetadata databaseMetadata)
                    throws HibernateException
Throws:
HibernateException

buildMappings

public void buildMappings()
Call this to ensure the mappings are fully compiled/built. Usefull to ensure getting access to all information in the metamodel when calling e.g. getClassMappings().

secondPassCompile

protected void secondPassCompile()
                          throws MappingException
Throws:
MappingException

findPossibleExtends

protected org.dom4j.Document findPossibleExtends()
Find the first possible element in the queue of extends.

secondPassCompileForeignKeys

protected void secondPassCompileForeignKeys(Table table,
                                            Set done)
                                     throws MappingException
Throws:
MappingException

getNamedQueries

public Map getNamedQueries()
Get the named queries

buildSessionFactory

public SessionFactory buildSessionFactory()
                                   throws HibernateException
Instantiate a new SessionFactory, using the properties and mappings in this configuration. The SessionFactory will be immutable, so changes made to the Configuration after building the SessionFactory will not affect it.

Returns:
a new factory for Sessions
Throws:
HibernateException
See Also:
SessionFactory

getInterceptor

public Interceptor getInterceptor()
Return the configured Interceptor

getProperties

public Properties getProperties()
Get all properties

setInterceptor

public Configuration setInterceptor(Interceptor interceptor)
Configure an Interceptor

setProperties

public Configuration setProperties(Properties properties)
Specify a completely new set of properties

addProperties

public Configuration addProperties(Properties extraProperties)
Set the given properties

mergeProperties

public Configuration mergeProperties(Properties properties)
Adds the incoming properties to the internap properties structure, as long as the internal structure does not already contain an entry for the given key.

Parameters:
properties -
Returns:
this

setProperty

public Configuration setProperty(String propertyName,
                                 String value)
Set a property

getProperty

public String getProperty(String propertyName)
Get a property

getConfigurationInputStream

protected InputStream getConfigurationInputStream(String resource)
                                           throws HibernateException
Get the configuration file as an InputStream. Might be overridden by subclasses to allow the configuration to be located by some arbitrary mechanism.

Throws:
HibernateException

configure

public Configuration configure()
                        throws HibernateException
Use the mappings and properties specified in an application resource named hibernate.cfg.xml.

Throws:
HibernateException

configure

public Configuration configure(String resource)
                        throws HibernateException
Use the mappings and properties specified in the given application resource. The format of the resource is defined in hibernate-configuration-3.0.dtd.

The resource is found via getConfigurationInputStream(resource).

Throws:
HibernateException

configure

public Configuration configure(URL url)
                        throws HibernateException
Use the mappings and properties specified in the given document. The format of the document is defined in hibernate-configuration-3.0.dtd.

Parameters:
url - URL from which you wish to load the configuration
Returns:
A configuration configured via the file
Throws:
HibernateException

configure

public Configuration configure(File configFile)
                        throws HibernateException
Use the mappings and properties specified in the given application file. The format of the file is defined in hibernate-configuration-3.0.dtd.

Parameters:
configFile - File from which you wish to load the configuration
Returns:
A configuration configured via the file
Throws:
HibernateException

doConfigure

protected Configuration doConfigure(InputStream stream,
                                    String resourceName)
                             throws HibernateException
Use the mappings and properties specified in the given application resource. The format of the resource is defined in hibernate-configuration-3.0.dtd.

Parameters:
stream - Inputstream to be read from
resourceName - The name to use in warning/error messages
Returns:
A configuration configured via the stream
Throws:
HibernateException

configure

public Configuration configure(org.w3c.dom.Document document)
                        throws HibernateException
Use the mappings and properties specified in the given XML document. The format of the file is defined in hibernate-configuration-3.0.dtd.

Parameters:
document - an XML document from which you wish to load the configuration
Returns:
A configuration configured via the Document
Throws:
HibernateException - if there is problem in accessing the file.

doConfigure

protected Configuration doConfigure(org.dom4j.Document doc)
                             throws HibernateException
Throws:
HibernateException

parseMappingElement

protected void parseMappingElement(org.dom4j.Element subelement,
                                   String name)

setListeners

public void setListeners(String type,
                         String[] listenerClasses)

setListener

public void setListener(String type,
                        Object listener)

setListeners

public void setListeners(String type,
                         Object[] listeners)

getEventListeners

public EventListeners getEventListeners()

setCacheConcurrencyStrategy

public Configuration setCacheConcurrencyStrategy(String clazz,
                                                 String concurrencyStrategy)
                                          throws MappingException
Set up a cache for an entity class

Parameters:
clazz -
concurrencyStrategy -
Returns:
Configuration
Throws:
MappingException

setCacheConcurrencyStrategy

public void setCacheConcurrencyStrategy(String clazz,
                                        String concurrencyStrategy,
                                        String region)
                                 throws MappingException
Throws:
MappingException

setCollectionCacheConcurrencyStrategy

public Configuration setCollectionCacheConcurrencyStrategy(String collectionRole,
                                                           String concurrencyStrategy)
                                                    throws MappingException
Set up a cache for a collection role

Parameters:
collectionRole -
concurrencyStrategy -
Returns:
Configuration
Throws:
MappingException

setCollectionCacheConcurrencyStrategy

public void setCollectionCacheConcurrencyStrategy(String collectionRole,
                                                  String concurrencyStrategy,
                                                  String region)
                                           throws MappingException
Throws:
MappingException

getImports

public Map getImports()
Get the query language imports

Returns:
a mapping from "import" names to fully qualified class names

buildSettings

public Settings buildSettings()
                       throws HibernateException
Create an object-oriented view of the configuration properties

Throws:
HibernateException

buildSettings

public Settings buildSettings(Properties props)
                       throws HibernateException
Throws:
HibernateException

getNamedSQLQueries

public Map getNamedSQLQueries()

getSqlResultSetMappings

public Map getSqlResultSetMappings()

getNamingStrategy

public NamingStrategy getNamingStrategy()
Returns:
the NamingStrategy.

setNamingStrategy

public Configuration setNamingStrategy(NamingStrategy namingStrategy)
Set a custom naming strategy

Parameters:
namingStrategy - the NamingStrategy to set

buildMapping

public Mapping buildMapping()

getFilterDefinitions

public Map getFilterDefinitions()

addFilterDefinition

public void addFilterDefinition(FilterDefinition definition)

addAuxiliaryDatabaseObject

public void addAuxiliaryDatabaseObject(AuxiliaryDatabaseObject object)

getSqlFunctions

public Map getSqlFunctions()

addSqlFunction

public void addSqlFunction(String functionName,
                           SQLFunction function)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultNamingStrategy (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class DefaultNamingStrategy

java.lang.Object
    extended by org.hibernate.cfg.DefaultNamingStrategy
All Implemented Interfaces:
NamingStrategy, Serializable
public class DefaultNamingStrategy
extends Object
implements NamingStrategy, Serializable

The default NamingStrategy

Author:
Gavin King
See Also:
a better alternative, Serialized Form

Field Summary
static NamingStrategy INSTANCE
The singleton instance
Constructor Summary
DefaultNamingStrategy()
Method Summary
String | classToTableName(String className) Return the unqualified class name
String | collectionTableName(String ownerEntity, String ownerEntityTable, String associatedEntity, String associatedEntityTable, String propertyName) Return the unqualified property name, not the best strategy but a backward compatible one
String | columnName(String columnName) Return the argument
String | foreignKeyColumnName(String propertyName, String propertyEntityName, String propertyTableName, String referencedColumnName) Return the property name or propertyTableName
String | joinKeyColumnName(String joinedColumn, String joinedTable) Return the argument
String | logicalCollectionColumnName(String columnName, String propertyName, String referencedColumn) Return the column name if explicit or the concatenation of the property name and the referenced column
String | logicalCollectionTableName(String tableName, String ownerEntityTable, String associatedEntityTable, String propertyName) Returns either the table name if explicit or if there is an associated table, the concatenation of owner entity table and associated table otherwise the concatenation of owner entity table and the unqualified property name
String | logicalColumnName(String columnName, String propertyName) Return the column name or the unqualified property name
String | propertyToColumnName(String propertyName) Return the unqualified property name
String | tableName(String tableName) Return the argument
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INSTANCE

public static final NamingStrategy INSTANCE
The singleton instance

Constructor Detail

DefaultNamingStrategy

public DefaultNamingStrategy()
Method Detail

classToTableName

public String classToTableName(String className)
Return the unqualified class name

Specified by:
classToTableName in interface NamingStrategy
Parameters:
className - the fully-qualified class name
Returns:
a table name

propertyToColumnName

public String propertyToColumnName(String propertyName)
Return the unqualified property name

Specified by:
propertyToColumnName in interface NamingStrategy
Parameters:
propertyName - a property path
Returns:
a column name

tableName

public String tableName(String tableName)
Return the argument

Specified by:
tableName in interface NamingStrategy
Parameters:
tableName - a table name
Returns:
a table name

columnName

public String columnName(String columnName)
Return the argument

Specified by:
columnName in interface NamingStrategy
Parameters:
columnName - a column name
Returns:
a column name

collectionTableName

public String collectionTableName(String ownerEntity,
                                  String ownerEntityTable,
                                  String associatedEntity,
                                  String associatedEntityTable,
                                  String propertyName)
Return the unqualified property name, not the best strategy but a backward compatible one

Specified by:
collectionTableName in interface NamingStrategy
Parameters:
ownerEntity -
ownerEntityTable - owner side table name
associatedEntity -
associatedEntityTable - reverse side table name if any
propertyName - collection role

joinKeyColumnName

public String joinKeyColumnName(String joinedColumn,
                                String joinedTable)
Return the argument

Specified by:
joinKeyColumnName in interface NamingStrategy
Parameters:
joinedColumn - joined column name (logical one) used to join with
joinedTable - joined table name (ie the referenced table) used to join with

foreignKeyColumnName

public String foreignKeyColumnName(String propertyName,
                                   String propertyEntityName,
                                   String propertyTableName,
                                   String referencedColumnName)
Return the property name or propertyTableName

Specified by:
foreignKeyColumnName in interface NamingStrategy
Parameters:
propertyName - the property name involved
propertyEntityName -
propertyTableName - the property table name involved (logical one)
referencedColumnName - the referenced column name involved (logical one)

logicalColumnName

public String logicalColumnName(String columnName,
                                String propertyName)
Return the column name or the unqualified property name

Specified by:
logicalColumnName in interface NamingStrategy
Parameters:
columnName - given column name if any
propertyName - property name of this column

logicalCollectionTableName

public String logicalCollectionTableName(String tableName,
                                         String ownerEntityTable,
                                         String associatedEntityTable,
                                         String propertyName)
Returns either the table name if explicit or if there is an associated table, the concatenation of owner entity table and associated table otherwise the concatenation of owner entity table and the unqualified property name

Specified by:
logicalCollectionTableName in interface NamingStrategy
Parameters:
tableName - the metadata explicit name
ownerEntityTable - owner table entity table name (logical one)
associatedEntityTable - reverse side table name if any (logical one)
propertyName - collection role

logicalCollectionColumnName

public String logicalCollectionColumnName(String columnName,
                                          String propertyName,
                                          String referencedColumn)
Return the column name if explicit or the concatenation of the property name and the referenced column

Specified by:
logicalCollectionColumnName in interface NamingStrategy
Parameters:
columnName - given column name in the metadata if any
propertyName - property name
referencedColumn - referenced column name (logical one) in the join
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Environment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class Environment

java.lang.Object
    extended by org.hibernate.cfg.Environment
public final class Environment
extends Object

Provides access to configuration info passed in Properties objects.

Hibernate has two property scopes:

  • Factory-level properties may be passed to the SessionFactory when it instantiated. Each instance might have different property values. If no properties are specified, the factory calls Environment.getProperties().
  • System-level properties are shared by all factory instances and are always determined by the Environment properties.
The only system-level properties are
  • hibernate.jdbc.use_streams_for_binary
  • hibernate.cglib.use_reflection_optimizer
Environment properties are populated by calling System.getProperties() and then from a resource named /hibernate.properties if it exists. System properties override properties specified in hibernate.properties.

The SessionFactory is controlled by the following properties. Properties may be either be System properties, properties defined in a resource named /hibernate.properties or an instance of java.util.Properties passed to Configuration.buildSessionFactory()

property | meaning
hibernate.dialect | classname of org.hibernate.dialect.Dialect subclass
hibernate.cache.provider_class | classname of org.hibernate.cache.CacheProvider subclass (if not specified EHCache is used)
hibernate.connection.provider_class | classname of org.hibernate.connection.ConnectionProvider subclass (if not specified hueristics are used)
hibernate.connection.username | database username
hibernate.connection.password | database password
hibernate.connection.url | JDBC URL (when using java.sql.DriverManager)
hibernate.connection.driver_class | classname of JDBC driver
hibernate.connection.isolation | JDBC transaction isolation level (only when using java.sql.DriverManager)
hibernate.connection.pool_size | the maximum size of the connection pool (only when using java.sql.DriverManager)
hibernate.connection.datasource | databasource JNDI name (when using javax.sql.Datasource)
hibernate.jndi.url | JNDI InitialContext URL
hibernate.jndi.class | JNDI InitialContext classname
hibernate.max_fetch_depth | maximum depth of outer join fetching
hibernate.jdbc.batch_size | enable use of JDBC2 batch API for drivers which support it
hibernate.jdbc.fetch_size | set the JDBC fetch size
hibernate.jdbc.use_scrollable_resultset | enable use of JDBC2 scrollable resultsets (you only need this specify this property when using user supplied connections)
hibernate.jdbc.use_getGeneratedKeys | enable use of JDBC3 PreparedStatement.getGeneratedKeys() to retrieve natively generated keys after insert. Requires JDBC3+ driver and JRE1.4+
hibernate.hbm2ddl.auto | enable auto DDL export
hibernate.default_schema | use given schema name for unqualified tables (always optional)
hibernate.default_catalog | use given catalog name for unqualified tables (always optional)
hibernate.session_factory_name | If set, the factory attempts to bind this name to itself in the JNDI context. This name is also used to support cross JVM Session (de)serialization.
hibernate.transaction.manager_lookup_class | classname of org.hibernate.transaction.TransactionManagerLookup implementor
hibernate.transaction.factory_class | the factory to use for instantiating Transactions. (Defaults to JDBCTransactionFactory.)
hibernate.query.substitutions | query language token substitutions

Author:
Gavin King
See Also:
SessionFactory

Field Summary
static String | AUTO_CLOSE_SESSION Enable automatic session close at end of transaction
static String | AUTOCOMMIT JDBC autocommit mode
static String | BATCH_STRATEGY Select a custom batcher.
static String | BATCH_VERSIONED_DATA Should versioned data be included in batching?
static String | BYTECODE_PROVIDER
static String | C3P0_ACQUIRE_INCREMENT Number of connections acquired when pool is exhausted
static String | C3P0_IDLE_TEST_PERIOD Idle time before a C3P0 pooled connection is validated
static String | C3P0_MAX_SIZE Maximum size of C3P0 connection pool
static String | C3P0_MAX_STATEMENTS Maximum size of C3P0 statement cache
static String | C3P0_MIN_SIZE Minimum size of C3P0 connection pool
static String | C3P0_TIMEOUT Maximum idle time for C3P0 connection pool
static String | CACHE_NAMESPACE The CacheProvider JNDI namespace, if pre-bound to JNDI.
static String | CACHE_PROVIDER The CacheProvider implementation class
static String | CACHE_PROVIDER_CONFIG The CacheProvider implementation class
static String | CACHE_REGION_PREFIX The CacheProvider region name prefix
static String | CONNECTION_PREFIX prefix for arbitrary JDBC connection properties
static String | CONNECTION_PROVIDER ConnectionProvider implementor to use when obtaining connections
static String | CURRENT_SESSION_CONTEXT_CLASS Context scoping impl for SessionFactory.getCurrentSession() processing.
static String | DATASOURCE java.sql.Datasource JNDI name
static String | DEFAULT_BATCH_FETCH_SIZE The default batch size for batch fetching
static String | DEFAULT_CATALOG A default database catalog name to use for unqualified tablenames
static String | DEFAULT_ENTITY_MODE The EntityMode in which set the Session opened from the SessionFactory.
static String | DEFAULT_SCHEMA A default database schema (owner) name to use for unqualified tablenames
static String | DIALECT Hibernate SQL Dialect class
static String | DRIVER JDBC driver class
static String | FLUSH_BEFORE_COMPLETION Enable automatic flush during the JTA beforeCompletion() callback
static String | FORMAT_SQL Enable formatting of SQL logged to the console
static String | GENERATE_STATISTICS Enable statistics collection
static String | HBM2DDL_AUTO Auto export/update schema using hbm2ddl tool.
static String | ISOLATION JDBC transaction isolation level
static String | JACC_CONTEXTID The jacc context id of the deployment
static String | JNDI_CLASS JNDI initial context class, Context.INITIAL_CONTEXT_FACTORY
static String | JNDI_PREFIX prefix for arbitrary JNDI InitialContext properties
static String | JNDI_URL JNDI provider URL, Context.PROVIDER_URL
static String | JPAQL_STRICT_COMPLIANCE
static String | MAX_FETCH_DEPTH Maximum depth of outer join fetching
static String | ORDER_UPDATES Enable ordering of update statements by primary key value
static String | OUTPUT_STYLESHEET An XSLT resource used to generate "custom" XML
static String | PASS JDBC password
static String | POOL_SIZE Maximum number of inactive connections for Hibernate's connection pool
static String | PROXOOL_EXISTING_POOL Proxool property to configure the Proxool Provider from an already existing pool (true / false)
static String | PROXOOL_POOL_ALIAS Proxool property with the Proxool pool alias to use (Required for PROXOOL_EXISTING_POOL, PROXOOL_PROPERTIES, or PROXOOL_XML)
static String | PROXOOL_PREFIX Proxool/Hibernate property prefix
static String | PROXOOL_PROPERTIES Proxool property to configure the Proxool Provider using a properties file (/path/to/proxool.properties)
static String | PROXOOL_XML Proxool property to configure the Proxool Provider using an XML (/path/to/file.xml)
static String | QUERY_CACHE_FACTORY The QueryCacheFactory implementation class.
static String | QUERY_SUBSTITUTIONS A comma-seperated list of token substitutions to use when translating a Hibernate query to SQL
static String | QUERY_TRANSLATOR The classname of the HQL query parser factory
static String | RELEASE_CONNECTIONS Specifies how Hibernate should release JDBC connections.
static String | SESSION_FACTORY_NAME JNDI name to bind to SessionFactory
static String | SHOW_SQL Enable logging of generated SQL to the console
static String | SQL_EXCEPTION_CONVERTER The SQLExceptionConverter to use for converting SQLExceptions to Hibernate's JDBCException hierarchy.
static String | STATEMENT_BATCH_SIZE Maximum JDBC batch size.
static String | STATEMENT_FETCH_SIZE Gives the JDBC driver a hint as to the number of rows that should be fetched from the database when more rows are needed.
static String | TRANSACTION_MANAGER_STRATEGY TransactionManagerLookup implementor to use for obtaining the TransactionManager
static String | TRANSACTION_STRATEGY TransactionFactory implementor to use for creating Transactions
static String | URL JDBC URL
static String | USE_GET_GENERATED_KEYS Tells the JDBC driver to attempt to retrieve row Id with the JDBC 3.0 PreparedStatement.getGeneratedKeys() method.
static String | USE_IDENTIFIER_ROLLBACK
static String | USE_MINIMAL_PUTS Optimize the cache for mimimal puts instead of minimal gets
static String | USE_QUERY_CACHE Enable the query cache (disabled by default)
static String | USE_REFLECTION_OPTIMIZER Use bytecode libraries optimized property access
static String | USE_SCROLLABLE_RESULTSET Use JDBC scrollable ResultSets.
static String | USE_SECOND_LEVEL_CACHE Enable the second-level cache (enabled by default)
static String | USE_SQL_COMMENTS Add comments to the generated SQL
static String | USE_STREAMS_FOR_BINARY Use java.io streams to read / write binary data from / to JDBC
static String | USE_STRUCTURED_CACHE Enable use of structured second-level cache entries
static String | USER JDBC user
static String | USER_TRANSACTION JNDI name of JTA UserTransaction object
static String | VERSION
static String | WRAP_RESULT_SETS Enable wrapping of JDBC result sets in order to speed up column name lookups for broken JDBC drivers
Method Summary
static BytecodeProvider | buildBytecodeProvider(Properties properties)
static BytecodeProvider | getBytecodeProvider()
static Properties | getProperties() Return System properties, extended by any properties specified in hibernate.properties.
static String | isolationLevelToString(int isolation) Get the name of a JDBC transaction isolation level
static boolean | jvmHasJDK14Timestamp() Does this JVM handle Timestamp in the JDK 1.4 compliant way?
static boolean | jvmHasTimestampBug() Does this JVM have the IBM JDK 1.3.1.
static boolean | jvmSupportsGetGeneratedKeys()
static boolean | jvmSupportsLinkedHashCollections() Does this JVM support LinkedHashSet, LinkedHashMap.
static boolean | useReflectionOptimizer() Should we use CGLIB reflection optimizer.
static boolean | useStreamsForBinary() Should we use streams to bind binary types to JDBC IN parameters.
static void | verifyProperties(Properties props) Issues warnings to the user when any obsolete property names are used.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

VERSION

public static final String VERSION
See Also:
Constant Field Values

CONNECTION_PROVIDER

public static final String CONNECTION_PROVIDER
ConnectionProvider implementor to use when obtaining connections

See Also:
Constant Field Values

DRIVER

public static final String DRIVER
JDBC driver class

See Also:
Constant Field Values

ISOLATION

public static final String ISOLATION
JDBC transaction isolation level

See Also:
Constant Field Values

URL

public static final String URL
JDBC URL

See Also:
Constant Field Values

USER

public static final String USER
JDBC user

See Also:
Constant Field Values

PASS

public static final String PASS
JDBC password

See Also:
Constant Field Values

AUTOCOMMIT

public static final String AUTOCOMMIT
JDBC autocommit mode

See Also:
Constant Field Values

POOL_SIZE

public static final String POOL_SIZE
Maximum number of inactive connections for Hibernate's connection pool

See Also:
Constant Field Values

DATASOURCE

public static final String DATASOURCE
java.sql.Datasource JNDI name

See Also:
Constant Field Values

CONNECTION_PREFIX

public static final String CONNECTION_PREFIX
prefix for arbitrary JDBC connection properties

See Also:
Constant Field Values

JNDI_CLASS

public static final String JNDI_CLASS
JNDI initial context class, Context.INITIAL_CONTEXT_FACTORY

See Also:
Constant Field Values

JNDI_URL

public static final String JNDI_URL
JNDI provider URL, Context.PROVIDER_URL

See Also:
Constant Field Values

JNDI_PREFIX

public static final String JNDI_PREFIX
prefix for arbitrary JNDI InitialContext properties

See Also:
Constant Field Values

SESSION_FACTORY_NAME

public static final String SESSION_FACTORY_NAME
JNDI name to bind to SessionFactory

See Also:
Constant Field Values

DIALECT

public static final String DIALECT
Hibernate SQL Dialect class

See Also:
Constant Field Values

DEFAULT_SCHEMA

public static final String DEFAULT_SCHEMA
A default database schema (owner) name to use for unqualified tablenames

See Also:
Constant Field Values

DEFAULT_CATALOG

public static final String DEFAULT_CATALOG
A default database catalog name to use for unqualified tablenames

See Also:
Constant Field Values

SHOW_SQL

public static final String SHOW_SQL
Enable logging of generated SQL to the console

See Also:
Constant Field Values

FORMAT_SQL

public static final String FORMAT_SQL
Enable formatting of SQL logged to the console

See Also:
Constant Field Values

USE_SQL_COMMENTS

public static final String USE_SQL_COMMENTS
Add comments to the generated SQL

See Also:
Constant Field Values

MAX_FETCH_DEPTH

public static final String MAX_FETCH_DEPTH
Maximum depth of outer join fetching

See Also:
Constant Field Values

DEFAULT_BATCH_FETCH_SIZE

public static final String DEFAULT_BATCH_FETCH_SIZE
The default batch size for batch fetching

See Also:
Constant Field Values

USE_STREAMS_FOR_BINARY

public static final String USE_STREAMS_FOR_BINARY
Use java.io streams to read / write binary data from / to JDBC

See Also:
Constant Field Values

USE_SCROLLABLE_RESULTSET

public static final String USE_SCROLLABLE_RESULTSET
Use JDBC scrollable ResultSets. This property is only necessary when there is no ConnectionProvider, ie. the user is supplying JDBC connections.

See Also:
Constant Field Values

USE_GET_GENERATED_KEYS

public static final String USE_GET_GENERATED_KEYS
Tells the JDBC driver to attempt to retrieve row Id with the JDBC 3.0 PreparedStatement.getGeneratedKeys() method. In general, performance will be better if this property is set to true and the underlying JDBC driver supports getGeneratedKeys().

See Also:
Constant Field Values

STATEMENT_FETCH_SIZE

public static final String STATEMENT_FETCH_SIZE
Gives the JDBC driver a hint as to the number of rows that should be fetched from the database when more rows are needed. If 0, JDBC driver default settings will be used.

See Also:
Constant Field Values

STATEMENT_BATCH_SIZE

public static final String STATEMENT_BATCH_SIZE
Maximum JDBC batch size. A nonzero value enables batch updates.

See Also:
Constant Field Values

BATCH_STRATEGY

public static final String BATCH_STRATEGY
Select a custom batcher.

See Also:
Constant Field Values

BATCH_VERSIONED_DATA

public static final String BATCH_VERSIONED_DATA
Should versioned data be included in batching?

See Also:
Constant Field Values

OUTPUT_STYLESHEET

public static final String OUTPUT_STYLESHEET
An XSLT resource used to generate "custom" XML

See Also:
Constant Field Values

C3P0_MAX_SIZE

public static final String C3P0_MAX_SIZE
Maximum size of C3P0 connection pool

See Also:
Constant Field Values

C3P0_MIN_SIZE

public static final String C3P0_MIN_SIZE
Minimum size of C3P0 connection pool

See Also:
Constant Field Values

C3P0_TIMEOUT

public static final String C3P0_TIMEOUT
Maximum idle time for C3P0 connection pool

See Also:
Constant Field Values

C3P0_MAX_STATEMENTS

public static final String C3P0_MAX_STATEMENTS
Maximum size of C3P0 statement cache

See Also:
Constant Field Values

C3P0_ACQUIRE_INCREMENT

public static final String C3P0_ACQUIRE_INCREMENT
Number of connections acquired when pool is exhausted

See Also:
Constant Field Values

C3P0_IDLE_TEST_PERIOD

public static final String C3P0_IDLE_TEST_PERIOD
Idle time before a C3P0 pooled connection is validated

See Also:
Constant Field Values

PROXOOL_PREFIX

public static final String PROXOOL_PREFIX
Proxool/Hibernate property prefix

See Also:
Constant Field Values

PROXOOL_XML

public static final String PROXOOL_XML
Proxool property to configure the Proxool Provider using an XML (/path/to/file.xml)

See Also:
Constant Field Values

PROXOOL_PROPERTIES

public static final String PROXOOL_PROPERTIES
Proxool property to configure the Proxool Provider using a properties file (/path/to/proxool.properties)

See Also:
Constant Field Values

PROXOOL_EXISTING_POOL

public static final String PROXOOL_EXISTING_POOL
Proxool property to configure the Proxool Provider from an already existing pool (true / false)

See Also:
Constant Field Values

PROXOOL_POOL_ALIAS

public static final String PROXOOL_POOL_ALIAS
Proxool property with the Proxool pool alias to use (Required for PROXOOL_EXISTING_POOL, PROXOOL_PROPERTIES, or PROXOOL_XML)

See Also:
Constant Field Values

AUTO_CLOSE_SESSION

public static final String AUTO_CLOSE_SESSION
Enable automatic session close at end of transaction

See Also:
Constant Field Values

FLUSH_BEFORE_COMPLETION

public static final String FLUSH_BEFORE_COMPLETION
Enable automatic flush during the JTA beforeCompletion() callback

See Also:
Constant Field Values

RELEASE_CONNECTIONS

public static final String RELEASE_CONNECTIONS
Specifies how Hibernate should release JDBC connections.

See Also:
Constant Field Values

CURRENT_SESSION_CONTEXT_CLASS

public static final String CURRENT_SESSION_CONTEXT_CLASS
Context scoping impl for SessionFactory.getCurrentSession() processing.

See Also:
Constant Field Values

TRANSACTION_STRATEGY

public static final String TRANSACTION_STRATEGY
TransactionFactory implementor to use for creating Transactions

See Also:
Constant Field Values

TRANSACTION_MANAGER_STRATEGY

public static final String TRANSACTION_MANAGER_STRATEGY
TransactionManagerLookup implementor to use for obtaining the TransactionManager

See Also:
Constant Field Values

USER_TRANSACTION

public static final String USER_TRANSACTION
JNDI name of JTA UserTransaction object

See Also:
Constant Field Values

CACHE_PROVIDER

public static final String CACHE_PROVIDER
The CacheProvider implementation class

See Also:
Constant Field Values

CACHE_PROVIDER_CONFIG

public static final String CACHE_PROVIDER_CONFIG
The CacheProvider implementation class

See Also:
Constant Field Values

CACHE_NAMESPACE

public static final String CACHE_NAMESPACE
The CacheProvider JNDI namespace, if pre-bound to JNDI.

See Also:
Constant Field Values

USE_QUERY_CACHE

public static final String USE_QUERY_CACHE
Enable the query cache (disabled by default)

See Also:
Constant Field Values

QUERY_CACHE_FACTORY

public static final String QUERY_CACHE_FACTORY
The QueryCacheFactory implementation class.

See Also:
Constant Field Values

USE_SECOND_LEVEL_CACHE

public static final String USE_SECOND_LEVEL_CACHE
Enable the second-level cache (enabled by default)

See Also:
Constant Field Values

USE_MINIMAL_PUTS

public static final String USE_MINIMAL_PUTS
Optimize the cache for mimimal puts instead of minimal gets

See Also:
Constant Field Values

CACHE_REGION_PREFIX

public static final String CACHE_REGION_PREFIX
The CacheProvider region name prefix

See Also:
Constant Field Values

USE_STRUCTURED_CACHE

public static final String USE_STRUCTURED_CACHE
Enable use of structured second-level cache entries

See Also:
Constant Field Values

GENERATE_STATISTICS

public static final String GENERATE_STATISTICS
Enable statistics collection

See Also:
Constant Field Values

USE_IDENTIFIER_ROLLBACK

public static final String USE_IDENTIFIER_ROLLBACK
See Also:
Constant Field Values

USE_REFLECTION_OPTIMIZER

public static final String USE_REFLECTION_OPTIMIZER
Use bytecode libraries optimized property access

See Also:
Constant Field Values

QUERY_TRANSLATOR

public static final String QUERY_TRANSLATOR
The classname of the HQL query parser factory

See Also:
Constant Field Values

QUERY_SUBSTITUTIONS

public static final String QUERY_SUBSTITUTIONS
A comma-seperated list of token substitutions to use when translating a Hibernate query to SQL

See Also:
Constant Field Values

HBM2DDL_AUTO

public static final String HBM2DDL_AUTO
Auto export/update schema using hbm2ddl tool. Valid values are update, create, create-drop and validate.

See Also:
Constant Field Values

SQL_EXCEPTION_CONVERTER

public static final String SQL_EXCEPTION_CONVERTER
The SQLExceptionConverter to use for converting SQLExceptions to Hibernate's JDBCException hierarchy. The default is to use the configured Dialect's preferred SQLExceptionConverter.

See Also:
Constant Field Values

WRAP_RESULT_SETS

public static final String WRAP_RESULT_SETS
Enable wrapping of JDBC result sets in order to speed up column name lookups for broken JDBC drivers

See Also:
Constant Field Values

ORDER_UPDATES

public static final String ORDER_UPDATES
Enable ordering of update statements by primary key value

See Also:
Constant Field Values

DEFAULT_ENTITY_MODE

public static final String DEFAULT_ENTITY_MODE
The EntityMode in which set the Session opened from the SessionFactory.

See Also:
Constant Field Values

JACC_CONTEXTID

public static final String JACC_CONTEXTID
The jacc context id of the deployment

See Also:
Constant Field Values

BYTECODE_PROVIDER

public static final String BYTECODE_PROVIDER
See Also:
Constant Field Values

JPAQL_STRICT_COMPLIANCE

public static final String JPAQL_STRICT_COMPLIANCE
See Also:
Constant Field Values
Method Detail

verifyProperties

public static void verifyProperties(Properties props)
Issues warnings to the user when any obsolete property names are used.

getBytecodeProvider

public static BytecodeProvider getBytecodeProvider()

jvmHasTimestampBug

public static boolean jvmHasTimestampBug()
Does this JVM have the IBM JDK 1.3.1. The bug is new Timestamp(x).getTime()!=x.

jvmHasJDK14Timestamp

public static boolean jvmHasJDK14Timestamp()
Does this JVM handle Timestamp in the JDK 1.4 compliant way?

jvmSupportsLinkedHashCollections

public static boolean jvmSupportsLinkedHashCollections()
Does this JVM support LinkedHashSet, LinkedHashMap.

See Also:
LinkedHashSet, LinkedHashMap

jvmSupportsGetGeneratedKeys

public static boolean jvmSupportsGetGeneratedKeys()

useStreamsForBinary

public static boolean useStreamsForBinary()
Should we use streams to bind binary types to JDBC IN parameters. Property hibernate.jdbc.use_streams_for_binary.

See Also:
USE_STREAMS_FOR_BINARY

useReflectionOptimizer

public static boolean useReflectionOptimizer()
Should we use CGLIB reflection optimizer. Property hibernate.jdbc.use_refection_optimizer.

See Also:
USE_REFLECTION_OPTIMIZER

getProperties

public static Properties getProperties()
Return System properties, extended by any properties specified in hibernate.properties.

Returns:
Properties

isolationLevelToString

public static String isolationLevelToString(int isolation)
Get the name of a JDBC transaction isolation level

Parameters:
isolation - as defined by java.sql.Connection
Returns:
a human-readable name
See Also:
Connection

buildBytecodeProvider

public static BytecodeProvider buildBytecodeProvider(Properties properties)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExtendsQueueEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class ExtendsQueueEntry

java.lang.Object
    extended by org.hibernate.cfg.ExtendsQueueEntry
public class ExtendsQueueEntry
extends Object

Represents a mapping queued for delayed processing to await processing of an extends entity upon which it depends.

Author:
Steve Ebersole

Constructor Summary
ExtendsQueueEntry(String explicitName, String mappingPackage, org.dom4j.Document document)
Method Summary
org.dom4j.Document | getDocument()
String | getExplicitName()
String | getMappingPackage()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExtendsQueueEntry

public ExtendsQueueEntry(String explicitName,
                         String mappingPackage,
                         org.dom4j.Document document)
Method Detail

getExplicitName

public String getExplicitName()

getMappingPackage

public String getMappingPackage()

getDocument

public org.dom4j.Document getDocument()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HbmBinder (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class HbmBinder

java.lang.Object
    extended by org.hibernate.cfg.HbmBinder
public final class HbmBinder
extends Object

Walks an XML mapping document and produces the Hibernate configuration-time metamodel (the classes in the mapping package)

Author:
Gavin King

Method Summary
static void | bindAny(org.dom4j.Element node, Any any, boolean isNullable, Mappings mappings)
static void | bindArray(org.dom4j.Element node, Array array, String prefix, String path, Mappings mappings, Map inheritedMetas) Called for arrays and primitive arrays
static void | bindClass(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas)
static void | bindCollection(org.dom4j.Element node, Collection collection, String className, String path, Mappings mappings, Map inheritedMetas) Called for all collections
static void | bindCollectionSecondPass(org.dom4j.Element node, Collection collection, Map persistentClasses, Mappings mappings, Map inheritedMetas) Called for all collections
static void | bindColumn(org.dom4j.Element node, Column column, boolean isNullable)
static void | bindColumns(org.dom4j.Element node, SimpleValue simpleValue, boolean isNullable, boolean autoColumn, String propertyPath, Mappings mappings)
static void | bindComponent(org.dom4j.Element node, Component component, String ownerClassName, String parentProperty, String path, boolean isNullable, boolean isEmbedded, Mappings mappings, Map inheritedMetas, boolean isIdentifierMapper)
static void | bindComposite(org.dom4j.Element node, Component component, String path, boolean isNullable, Mappings mappings, Map inheritedMetas)
static void | bindCompositeId(org.dom4j.Element node, Component component, PersistentClass persistentClass, String propertyName, Mappings mappings, Map inheritedMetas)
static void | bindIdentifierCollectionSecondPass(org.dom4j.Element node, IdentifierCollection collection, Map persistentClasses, Mappings mappings, Map inheritedMetas)
static void | bindJoinedSubclass(org.dom4j.Element node, JoinedSubclass joinedSubclass, Mappings mappings, Map inheritedMetas)
static void | bindListSecondPass(org.dom4j.Element node, List list, Map classes, Mappings mappings, Map inheritedMetas) Called for Lists, arrays, primitive arrays
static void | bindManyToOne(org.dom4j.Element node, ManyToOne manyToOne, String path, boolean isNullable, Mappings mappings)
static void | bindMapSecondPass(org.dom4j.Element node, Map map, Map classes, Mappings mappings, Map inheritedMetas) Called for Maps
static void | bindOneToMany(org.dom4j.Element node, OneToMany oneToMany, Mappings mappings)
static void | bindOneToOne(org.dom4j.Element node, OneToOne oneToOne, String path, boolean isNullable, Mappings mappings)
static void | bindProperty(org.dom4j.Element node, Property property, Mappings mappings, Map inheritedMetas)
static void | bindRoot(org.dom4j.Document doc, Mappings mappings, Map inheritedMetas) The main contract into the hbm.xml-based binder.
static void | bindRootClass(org.dom4j.Element node, RootClass rootClass, Mappings mappings, Map inheritedMetas) Responsible for perfoming the bind operation related to an <class/> mapping element.
static void | bindSimpleValue(org.dom4j.Element node, SimpleValue simpleValue, boolean isNullable, String path, Mappings mappings)
static void | bindSubclass(org.dom4j.Element node, Subclass subclass, Mappings mappings, Map inheritedMetas)
static void | bindUnionSubclass(org.dom4j.Element node, UnionSubclass unionSubclass, Mappings mappings, Map inheritedMetas)
protected static void | createClassProperties(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas)
protected static void | createClassProperties(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas, UniqueKey uniqueKey, boolean mutable, boolean nullable, boolean naturalId)
static CacheMode | getCacheMode(String cacheMode)
static String | getClassName(String unqualifiedName, Mappings model)
static String | getClassName(String unqualifiedName, String defaultPackage)
static String | getEntityName(org.dom4j.Element elem, Mappings model)
static List | getExtendsNeeded(org.dom4j.Document doc, Mappings mappings) For the given document, locate all extends attributes which refer to entities (entity-name or class-name) not defined within said document.
static FlushMode | getFlushMode(String flushMode)
static Map | getMetas(org.dom4j.Element node, Map inheritedMeta, boolean onlyInheritable)
static Map | getParameterTypes(org.dom4j.Element queryElem)
static String | getTypeFromXML(org.dom4j.Element node)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

bindRoot

public static void bindRoot(org.dom4j.Document doc,
                            Mappings mappings,
                            Map inheritedMetas)
                     throws MappingException
The main contract into the hbm.xml-based binder. Performs necessary binding operations represented by the given DOM.

Parameters:
doc - The DOM to be parsed and bound.
mappings - Current bind state.
inheritedMetas - Any inherited meta-tag information.
Throws:
MappingException

bindRootClass

public static void bindRootClass(org.dom4j.Element node,
                                 RootClass rootClass,
                                 Mappings mappings,
                                 Map inheritedMetas)
                          throws MappingException
Responsible for perfoming the bind operation related to an <class/> mapping element.

Parameters:
node - The DOM Element for the <class/> element.
rootClass - The mapping instance to which to bind the information.
mappings - The current bind state.
inheritedMetas - Any inherited meta-tag information.
Throws:
MappingException

bindClass

public static void bindClass(org.dom4j.Element node,
                             PersistentClass persistentClass,
                             Mappings mappings,
                             Map inheritedMetas)
                      throws MappingException
Throws:
MappingException

bindUnionSubclass

public static void bindUnionSubclass(org.dom4j.Element node,
                                     UnionSubclass unionSubclass,
                                     Mappings mappings,
                                     Map inheritedMetas)
                              throws MappingException
Throws:
MappingException

bindSubclass

public static void bindSubclass(org.dom4j.Element node,
                                Subclass subclass,
                                Mappings mappings,
                                Map inheritedMetas)
                         throws MappingException
Throws:
MappingException

bindJoinedSubclass

public static void bindJoinedSubclass(org.dom4j.Element node,
                                      JoinedSubclass joinedSubclass,
                                      Mappings mappings,
                                      Map inheritedMetas)
                               throws MappingException
Throws:
MappingException

bindColumns

public static void bindColumns(org.dom4j.Element node,
                               SimpleValue simpleValue,
                               boolean isNullable,
                               boolean autoColumn,
                               String propertyPath,
                               Mappings mappings)
                        throws MappingException
Throws:
MappingException

bindSimpleValue

public static void bindSimpleValue(org.dom4j.Element node,
                                   SimpleValue simpleValue,
                                   boolean isNullable,
                                   String path,
                                   Mappings mappings)
                            throws MappingException
Throws:
MappingException

bindProperty

public static void bindProperty(org.dom4j.Element node,
                                Property property,
                                Mappings mappings,
                                Map inheritedMetas)
                         throws MappingException
Throws:
MappingException

bindCollection

public static void bindCollection(org.dom4j.Element node,
                                  Collection collection,
                                  String className,
                                  String path,
                                  Mappings mappings,
                                  Map inheritedMetas)
                           throws MappingException
Called for all collections

Throws:
MappingException

bindManyToOne

public static void bindManyToOne(org.dom4j.Element node,
                                 ManyToOne manyToOne,
                                 String path,
                                 boolean isNullable,
                                 Mappings mappings)
                          throws MappingException
Throws:
MappingException

bindAny

public static void bindAny(org.dom4j.Element node,
                           Any any,
                           boolean isNullable,
                           Mappings mappings)
                    throws MappingException
Throws:
MappingException

bindOneToOne

public static void bindOneToOne(org.dom4j.Element node,
                                OneToOne oneToOne,
                                String path,
                                boolean isNullable,
                                Mappings mappings)
                         throws MappingException
Throws:
MappingException

bindOneToMany

public static void bindOneToMany(org.dom4j.Element node,
                                 OneToMany oneToMany,
                                 Mappings mappings)
                          throws MappingException
Throws:
MappingException

bindColumn

public static void bindColumn(org.dom4j.Element node,
                              Column column,
                              boolean isNullable)

bindArray

public static void bindArray(org.dom4j.Element node,
                             Array array,
                             String prefix,
                             String path,
                             Mappings mappings,
                             Map inheritedMetas)
                      throws MappingException
Called for arrays and primitive arrays

Throws:
MappingException

bindComposite

public static void bindComposite(org.dom4j.Element node,
                                 Component component,
                                 String path,
                                 boolean isNullable,
                                 Mappings mappings,
                                 Map inheritedMetas)
                          throws MappingException
Throws:
MappingException

bindCompositeId

public static void bindCompositeId(org.dom4j.Element node,
                                   Component component,
                                   PersistentClass persistentClass,
                                   String propertyName,
                                   Mappings mappings,
                                   Map inheritedMetas)
                            throws MappingException
Throws:
MappingException

bindComponent

public static void bindComponent(org.dom4j.Element node,
                                 Component component,
                                 String ownerClassName,
                                 String parentProperty,
                                 String path,
                                 boolean isNullable,
                                 boolean isEmbedded,
                                 Mappings mappings,
                                 Map inheritedMetas,
                                 boolean isIdentifierMapper)
                          throws MappingException
Throws:
MappingException

getTypeFromXML

public static String getTypeFromXML(org.dom4j.Element node)
                             throws MappingException
Throws:
MappingException

createClassProperties

protected static void createClassProperties(org.dom4j.Element node,
                                            PersistentClass persistentClass,
                                            Mappings mappings,
                                            Map inheritedMetas)
                                     throws MappingException
Throws:
MappingException

createClassProperties

protected static void createClassProperties(org.dom4j.Element node,
                                            PersistentClass persistentClass,
                                            Mappings mappings,
                                            Map inheritedMetas,
                                            UniqueKey uniqueKey,
                                            boolean mutable,
                                            boolean nullable,
                                            boolean naturalId)
                                     throws MappingException
Throws:
MappingException

bindListSecondPass

public static void bindListSecondPass(org.dom4j.Element node,
                                      List list,
                                      Map classes,
                                      Mappings mappings,
                                      Map inheritedMetas)
                               throws MappingException
Called for Lists, arrays, primitive arrays

Throws:
MappingException

bindIdentifierCollectionSecondPass

public static void bindIdentifierCollectionSecondPass(org.dom4j.Element node,
                                                      IdentifierCollection collection,
                                                      Map persistentClasses,
                                                      Mappings mappings,
                                                      Map inheritedMetas)
                                               throws MappingException
Throws:
MappingException

bindMapSecondPass

public static void bindMapSecondPass(org.dom4j.Element node,
                                     Map map,
                                     Map classes,
                                     Mappings mappings,
                                     Map inheritedMetas)
                              throws MappingException
Called for Maps

Throws:
MappingException

bindCollectionSecondPass

public static void bindCollectionSecondPass(org.dom4j.Element node,
                                            Collection collection,
                                            Map persistentClasses,
                                            Mappings mappings,
                                            Map inheritedMetas)
                                     throws MappingException
Called for all collections

Throws:
MappingException

getFlushMode

public static final FlushMode getFlushMode(String flushMode)

getCacheMode

public static CacheMode getCacheMode(String cacheMode)

getParameterTypes

public static Map getParameterTypes(org.dom4j.Element queryElem)

getMetas

public static final Map getMetas(org.dom4j.Element node,
                                 Map inheritedMeta,
                                 boolean onlyInheritable)

getEntityName

public static String getEntityName(org.dom4j.Element elem,
                                   Mappings model)

getClassName

public static String getClassName(String unqualifiedName,
                                  Mappings model)

getClassName

public static String getClassName(String unqualifiedName,
                                  String defaultPackage)

getExtendsNeeded

public static List getExtendsNeeded(org.dom4j.Document doc,
                                    Mappings mappings)
For the given document, locate all extends attributes which refer to entities (entity-name or class-name) not defined within said document.

Parameters:
doc - The document to check
mappings - The already processed mappings.
Returns:
The list of unresolved extends names.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ImprovedNamingStrategy (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class ImprovedNamingStrategy

java.lang.Object
    extended by org.hibernate.cfg.ImprovedNamingStrategy
All Implemented Interfaces:
NamingStrategy, Serializable
public class ImprovedNamingStrategy
extends Object
implements NamingStrategy, Serializable

An improved naming strategy that prefers embedded underscores to mixed case names

Author:
Gavin King
See Also:
the default strategy, Serialized Form

Field Summary
static NamingStrategy INSTANCE
A convenient singleton instance
Constructor Summary
ImprovedNamingStrategy()
Method Summary
protected static String | addUnderscores(String name)
String | classToTableName(String className) Return the unqualified class name, mixed case converted to underscores
String | collectionTableName(String ownerEntity, String ownerEntityTable, String associatedEntity, String associatedEntityTable, String propertyName) Return a collection table name ie an association having a join table
String | columnName(String columnName) Convert mixed case to underscores
String | foreignKeyColumnName(String propertyName, String propertyEntityName, String propertyTableName, String referencedColumnName) Return the property name or propertyTableName
String | joinKeyColumnName(String joinedColumn, String joinedTable) Return the argument
String | logicalCollectionColumnName(String columnName, String propertyName, String referencedColumn) Return the column name if explicit or the concatenation of the property name and the referenced column
String | logicalCollectionTableName(String tableName, String ownerEntityTable, String associatedEntityTable, String propertyName) Returns either the table name if explicit or if there is an associated table, the concatenation of owner entity table and associated table otherwise the concatenation of owner entity table and the unqualified property name
String | logicalColumnName(String columnName, String propertyName) Return the column name or the unqualified property name
String | propertyToColumnName(String propertyName) Return the full property path with underscore seperators, mixed case converted to underscores
String | tableName(String tableName) Convert mixed case to underscores
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INSTANCE

public static final NamingStrategy INSTANCE
A convenient singleton instance

Constructor Detail

ImprovedNamingStrategy

public ImprovedNamingStrategy()
Method Detail

classToTableName

public String classToTableName(String className)
Return the unqualified class name, mixed case converted to underscores

Specified by:
classToTableName in interface NamingStrategy
Parameters:
className - the fully-qualified class name
Returns:
a table name

propertyToColumnName

public String propertyToColumnName(String propertyName)
Return the full property path with underscore seperators, mixed case converted to underscores

Specified by:
propertyToColumnName in interface NamingStrategy
Parameters:
propertyName - a property path
Returns:
a column name

tableName

public String tableName(String tableName)
Convert mixed case to underscores

Specified by:
tableName in interface NamingStrategy
Parameters:
tableName - a table name
Returns:
a table name

columnName

public String columnName(String columnName)
Convert mixed case to underscores

Specified by:
columnName in interface NamingStrategy
Parameters:
columnName - a column name
Returns:
a column name

addUnderscores

protected static String addUnderscores(String name)

collectionTableName

public String collectionTableName(String ownerEntity,
                                  String ownerEntityTable,
                                  String associatedEntity,
                                  String associatedEntityTable,
                                  String propertyName)
Description copied from interface: NamingStrategy
Return a collection table name ie an association having a join table

Specified by:
collectionTableName in interface NamingStrategy
Parameters:
ownerEntity -
ownerEntityTable - owner side table name
associatedEntity -
associatedEntityTable - reverse side table name if any
propertyName - collection role

joinKeyColumnName

public String joinKeyColumnName(String joinedColumn,
                                String joinedTable)
Return the argument

Specified by:
joinKeyColumnName in interface NamingStrategy
Parameters:
joinedColumn - joined column name (logical one) used to join with
joinedTable - joined table name (ie the referenced table) used to join with

foreignKeyColumnName

public String foreignKeyColumnName(String propertyName,
                                   String propertyEntityName,
                                   String propertyTableName,
                                   String referencedColumnName)
Return the property name or propertyTableName

Specified by:
foreignKeyColumnName in interface NamingStrategy
Parameters:
propertyName - the property name involved
propertyEntityName -
propertyTableName - the property table name involved (logical one)
referencedColumnName - the referenced column name involved (logical one)

logicalColumnName

public String logicalColumnName(String columnName,
                                String propertyName)
Return the column name or the unqualified property name

Specified by:
logicalColumnName in interface NamingStrategy
Parameters:
columnName - given column name if any
propertyName - property name of this column

logicalCollectionTableName

public String logicalCollectionTableName(String tableName,
                                         String ownerEntityTable,
                                         String associatedEntityTable,
                                         String propertyName)
Returns either the table name if explicit or if there is an associated table, the concatenation of owner entity table and associated table otherwise the concatenation of owner entity table and the unqualified property name

Specified by:
logicalCollectionTableName in interface NamingStrategy
Parameters:
tableName - the metadata explicit name
ownerEntityTable - owner table entity table name (logical one)
associatedEntityTable - reverse side table name if any (logical one)
propertyName - collection role

logicalCollectionColumnName

public String logicalCollectionColumnName(String columnName,
                                          String propertyName,
                                          String referencedColumn)
Return the column name if explicit or the concatenation of the property name and the referenced column

Specified by:
logicalCollectionColumnName in interface NamingStrategy
Parameters:
columnName - given column name in the metadata if any
propertyName - property name
referencedColumn - referenced column name (logical one) in the join
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Mappings (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class Mappings

java.lang.Object
    extended by org.hibernate.cfg.Mappings
All Implemented Interfaces:
Serializable
public class Mappings
extends Object
implements Serializable

A collection of mappings from classes and collections to relational database tables. (Represents a single <hibernate-mapping> element.)

Author:
Gavin King
See Also:
Serialized Form

Nested Class Summary
static class | Mappings.ColumnNames
static class | Mappings.TableDescription
Field Summary
protected boolean | autoImport
protected List | auxiliaryDatabaseObjects
protected String | catalogName
protected Map | classes
protected Map | collections
protected Map | columnNameBindingPerTable binding table between the logical column name and the name out of the naming strategy for each table.
protected String | defaultAccess
protected String | defaultCascade
protected boolean | defaultLazy
protected String | defaultPackage
protected Map | extendsQueue
protected Map | filterDefinitions
protected Map | imports
protected NamingStrategy | namingStrategy
protected List | propertyReferences
protected Map | queries
protected Map | resultSetMappings
protected String | schemaName
protected List | secondPasses
protected Map | sqlqueries
protected Map | tableNameBinding binding between logical table name and physical one (ie after the naming strategy has been applied)
protected Map | tables
protected Map | typeDefs
Method Summary
void | addAuxiliaryDatabaseObject(AuxiliaryDatabaseObject auxiliaryDatabaseObject)
void | addClass(PersistentClass persistentClass)
void | addCollection(Collection collection)
void | addColumnBinding(String logicalName, Column finalColumn, Table table)
Table | addDenormalizedTable(String schema, String catalog, String name, boolean isAbstract, String subselect, Table includedTable)
void | addFilterDefinition(FilterDefinition definition)
void | addImport(String className, String rename)
void | addQuery(String name, NamedQueryDefinition query)
void | addResultSetMapping(ResultSetMappingDefinition sqlResultSetMapping)
void | addSecondPass(SecondPass sp)
void | addSecondPass(SecondPass sp, boolean onTopOfTheQueue)
void | addSQLQuery(String name, NamedSQLQueryDefinition query)
Table | addTable(String schema, String catalog, String name, String subselect, boolean isAbstract)
void | addTableBinding(String schema, String catalog, String logicalName, String physicalName, Table denormalizedSuperTable)
void | addToExtendsQueue(ExtendsQueueEntry entry)
void | addTypeDef(String typeName, String typeClass, Properties paramMap)
String | getCatalogName()
PersistentClass | getClass(String className)
Collection | getCollection(String role)
String | getDefaultAccess()
String | getDefaultCascade()
String | getDefaultPackage()
FilterDefinition | getFilterDefinition(String name)
Map | getFilterDefinitions()
String | getLogicalColumnName(String physicalName, Table table)
String | getLogicalTableName(Table table)
NamingStrategy | getNamingStrategy()
String | getPhysicalColumnName(String logicalName, Table table)
NamedQueryDefinition | getQuery(String name)
ResultSetMappingDefinition | getResultSetMapping(String name)
String | getSchemaName()
Table | getTable(String schema, String catalog, String name)
TypeDef | getTypeDef(String typeName)
boolean | isAutoImport() Returns the autoImport.
boolean | isDefaultLazy()
Iterator | iterateCollections()
Iterator | iterateTables()
PersistentClass | locatePersistentClassByEntityName(String entityName)
void | setAutoImport(boolean autoImport) Sets the autoImport.
void | setCatalogName(String catalogName) Sets the catalogName.
void | setDefaultAccess(String defaultAccess) sets the default access strategy
void | setDefaultCascade(String defaultCascade) Sets the defaultCascade.
void | setDefaultLazy(boolean defaultLazy)
void | setDefaultPackage(String defaultPackage)
void | setSchemaName(String schemaName) Sets the schemaName.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

classes

protected final Map classes

collections

protected final Map collections

tables

protected final Map tables

queries

protected final Map queries

sqlqueries

protected final Map sqlqueries

resultSetMappings

protected final Map resultSetMappings

typeDefs

protected final Map typeDefs

secondPasses

protected final List secondPasses

imports

protected final Map imports

schemaName

protected String schemaName

catalogName

protected String catalogName

defaultCascade

protected String defaultCascade

defaultPackage

protected String defaultPackage

defaultAccess

protected String defaultAccess

autoImport

protected boolean autoImport

defaultLazy

protected boolean defaultLazy

propertyReferences

protected final List propertyReferences

namingStrategy

protected final NamingStrategy namingStrategy

filterDefinitions

protected final Map filterDefinitions

auxiliaryDatabaseObjects

protected final List auxiliaryDatabaseObjects

extendsQueue

protected final Map extendsQueue

columnNameBindingPerTable

protected final Map columnNameBindingPerTable
binding table between the logical column name and the name out of the naming strategy for each table. According that when the column name is not set, the property name is considered as such This means that while theorically possible through the naming strategy contract, it is forbidden to have 2 real columns having the same logical name

tableNameBinding

protected final Map tableNameBinding
binding between logical table name and physical one (ie after the naming strategy has been applied)

Method Detail

addClass

public void addClass(PersistentClass persistentClass)
              throws MappingException
Throws:
MappingException

addCollection

public void addCollection(Collection collection)
                   throws MappingException
Throws:
MappingException

getClass

public PersistentClass getClass(String className)

getCollection

public Collection getCollection(String role)

addImport

public void addImport(String className,
                      String rename)
               throws MappingException
Throws:
MappingException

addTable

public Table addTable(String schema,
                      String catalog,
                      String name,
                      String subselect,
                      boolean isAbstract)

addDenormalizedTable

public Table addDenormalizedTable(String schema,
                                  String catalog,
                                  String name,
                                  boolean isAbstract,
                                  String subselect,
                                  Table includedTable)
                           throws MappingException
Throws:
MappingException

getTable

public Table getTable(String schema,
                      String catalog,
                      String name)

getSchemaName

public String getSchemaName()

getCatalogName

public String getCatalogName()

getDefaultCascade

public String getDefaultCascade()

setSchemaName

public void setSchemaName(String schemaName)
Sets the schemaName.

Parameters:
schemaName - The schemaName to set

setCatalogName

public void setCatalogName(String catalogName)
Sets the catalogName.

Parameters:
catalogName - The catalogName to set

setDefaultCascade

public void setDefaultCascade(String defaultCascade)
Sets the defaultCascade.

Parameters:
defaultCascade - The defaultCascade to set

setDefaultAccess

public void setDefaultAccess(String defaultAccess)
sets the default access strategy

Parameters:
defaultAccess - the default access strategy.

getDefaultAccess

public String getDefaultAccess()

addQuery

public void addQuery(String name,
                     NamedQueryDefinition query)
              throws MappingException
Throws:
MappingException

addSQLQuery

public void addSQLQuery(String name,
                        NamedSQLQueryDefinition query)
                 throws MappingException
Throws:
MappingException

addResultSetMapping

public void addResultSetMapping(ResultSetMappingDefinition sqlResultSetMapping)

getResultSetMapping

public ResultSetMappingDefinition getResultSetMapping(String name)

getQuery

public NamedQueryDefinition getQuery(String name)

addSecondPass

public void addSecondPass(SecondPass sp)

addSecondPass

public void addSecondPass(SecondPass sp,
                          boolean onTopOfTheQueue)

isAutoImport

public boolean isAutoImport()
Returns the autoImport.

Returns:
boolean

setAutoImport

public void setAutoImport(boolean autoImport)
Sets the autoImport.

Parameters:
autoImport - The autoImport to set

getDefaultPackage

public String getDefaultPackage()
Returns:
Returns the defaultPackage.

setDefaultPackage

public void setDefaultPackage(String defaultPackage)
Parameters:
defaultPackage - The defaultPackage to set.

getNamingStrategy

public NamingStrategy getNamingStrategy()

addTypeDef

public void addTypeDef(String typeName,
                       String typeClass,
                       Properties paramMap)

getTypeDef

public TypeDef getTypeDef(String typeName)

iterateCollections

public Iterator iterateCollections()

iterateTables

public Iterator iterateTables()

getFilterDefinitions

public Map getFilterDefinitions()

addFilterDefinition

public void addFilterDefinition(FilterDefinition definition)

getFilterDefinition

public FilterDefinition getFilterDefinition(String name)

isDefaultLazy

public boolean isDefaultLazy()

setDefaultLazy

public void setDefaultLazy(boolean defaultLazy)

addToExtendsQueue

public void addToExtendsQueue(ExtendsQueueEntry entry)

locatePersistentClassByEntityName

public PersistentClass locatePersistentClassByEntityName(String entityName)

addAuxiliaryDatabaseObject

public void addAuxiliaryDatabaseObject(AuxiliaryDatabaseObject auxiliaryDatabaseObject)

addTableBinding

public void addTableBinding(String schema,
                            String catalog,
                            String logicalName,
                            String physicalName,
                            Table denormalizedSuperTable)

addColumnBinding

public void addColumnBinding(String logicalName,
                             Column finalColumn,
                             Table table)

getPhysicalColumnName

public String getPhysicalColumnName(String logicalName,
                                    Table table)

getLogicalColumnName

public String getLogicalColumnName(String physicalName,
                                   Table table)

getLogicalTableName

public String getLogicalTableName(Table table)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Mappings.ColumnNames (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class Mappings.ColumnNames

java.lang.Object
    extended by org.hibernate.cfg.Mappings.ColumnNames
All Implemented Interfaces:
Serializable
Enclosing class:
Mappings
public static class Mappings.ColumnNames
extends Object
implements Serializable

See Also:
Serialized Form

Field Summary
Map | logicalToPhysical
Map | physicalToLogical
Constructor Summary
Mappings.ColumnNames()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logicalToPhysical

public Map logicalToPhysical

physicalToLogical

public Map physicalToLogical
Constructor Detail

Mappings.ColumnNames

public Mappings.ColumnNames()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Mappings.TableDescription (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class Mappings.TableDescription

java.lang.Object
    extended by org.hibernate.cfg.Mappings.TableDescription
All Implemented Interfaces:
Serializable
Enclosing class:
Mappings
public static class Mappings.TableDescription
extends Object
implements Serializable

See Also:
Serialized Form

Field Summary
Table | denormalizedSupertable
String | logicalName
Constructor Summary
Mappings.TableDescription(String logicalName, Table denormalizedSupertable)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logicalName

public String logicalName

denormalizedSupertable

public Table denormalizedSupertable
Constructor Detail

Mappings.TableDescription

public Mappings.TableDescription(String logicalName,
                                 Table denormalizedSupertable)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamedSQLQuerySecondPass (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class NamedSQLQuerySecondPass

java.lang.Object
    extended by org.hibernate.cfg.ResultSetMappingBinder
        extended by org.hibernate.cfg.NamedSQLQuerySecondPass
All Implemented Interfaces:
QuerySecondPass, SecondPass, Serializable
public class NamedSQLQuerySecondPass
extends ResultSetMappingBinder
implements QuerySecondPass

Author:
Emmanuel Bernard
See Also:
Serialized Form

Constructor Summary
NamedSQLQuerySecondPass(org.dom4j.Element queryElem, String path, Mappings mappings)
Method Summary
 void doSecondPass(Map persistentClasses)
Methods inherited from class org.hibernate.cfg.ResultSetMappingBinder
buildResultSetMappingDefinition
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NamedSQLQuerySecondPass

public NamedSQLQuerySecondPass(org.dom4j.Element queryElem,
                               String path,
                               Mappings mappings)
Method Detail

doSecondPass

public void doSecondPass(Map persistentClasses)
                  throws MappingException
Specified by:
doSecondPass in interface SecondPass
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResultSetMappingBinder (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class ResultSetMappingBinder

java.lang.Object
    extended by org.hibernate.cfg.ResultSetMappingBinder
Direct Known Subclasses:
NamedSQLQuerySecondPass, ResultSetMappingSecondPass
public abstract class ResultSetMappingBinder
extends Object

Author:
Emmanuel Bernard

Constructor Summary
ResultSetMappingBinder()
Method Summary
protected static ResultSetMappingDefinition buildResultSetMappingDefinition(org.dom4j.Element resultSetElem, String path, Mappings mappings)
Build a ResultSetMappingDefinition given a containing element for the "return-XXX" elements
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResultSetMappingBinder

public ResultSetMappingBinder()
Method Detail

buildResultSetMappingDefinition

protected static ResultSetMappingDefinition buildResultSetMappingDefinition(org.dom4j.Element resultSetElem,
                                                                            String path,
                                                                            Mappings mappings)
Build a ResultSetMappingDefinition given a containing element for the "return-XXX" elements

Parameters:
resultSetElem - The element containing the return definitions.
path - No clue...
mappings - The current processing state.
Returns:
The description of the mappings...
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResultSetMappingSecondPass (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class ResultSetMappingSecondPass

java.lang.Object
    extended by org.hibernate.cfg.ResultSetMappingBinder
        extended by org.hibernate.cfg.ResultSetMappingSecondPass
All Implemented Interfaces:
QuerySecondPass, SecondPass, Serializable
public class ResultSetMappingSecondPass
extends ResultSetMappingBinder
implements QuerySecondPass

Author:
Emmanuel Bernard
See Also:
Serialized Form

Constructor Summary
ResultSetMappingSecondPass(org.dom4j.Element element, String path, Mappings mappings)
Method Summary
 void doSecondPass(Map persistentClasses)
Methods inherited from class org.hibernate.cfg.ResultSetMappingBinder
buildResultSetMappingDefinition
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResultSetMappingSecondPass

public ResultSetMappingSecondPass(org.dom4j.Element element,
                                  String path,
                                  Mappings mappings)
Method Detail

doSecondPass

public void doSecondPass(Map persistentClasses)
                  throws MappingException
Specified by:
doSecondPass in interface SecondPass
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Settings (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class Settings

java.lang.Object
    extended by org.hibernate.cfg.Settings
public final class Settings
extends Object

Settings that affect the behaviour of Hibernate at runtime.

Author:
Gavin King

Method Summary
BatcherFactory | getBatcherFactory()
CacheProvider | getCacheProvider()
String | getCacheRegionPrefix()
ConnectionProvider | getConnectionProvider()
ConnectionReleaseMode | getConnectionReleaseMode()
int | getDefaultBatchFetchSize()
String | getDefaultCatalogName()
EntityMode | getDefaultEntityMode()
String | getDefaultSchemaName()
Dialect | getDialect()
int | getJdbcBatchSize()
Integer | getJdbcFetchSize()
Integer | getMaximumFetchDepth()
QueryCacheFactory | getQueryCacheFactory()
Map | getQuerySubstitutions()
QueryTranslatorFactory | getQueryTranslatorFactory()
String | getSessionFactoryName()
SQLExceptionConverter | getSQLExceptionConverter()
TransactionFactory | getTransactionFactory()
TransactionManagerLookup | getTransactionManagerLookup()
boolean | isAutoCloseSessionEnabled()
boolean | isAutoCreateSchema()
boolean | isAutoDropSchema()
boolean | isAutoUpdateSchema()
boolean | isAutoValidateSchema()
boolean | isCommentsEnabled()
boolean | isDataDefinitionImplicitCommit()
boolean | isDataDefinitionInTransactionSupported()
boolean | isFlushBeforeCompletionEnabled()
boolean | isFormatSqlEnabled()
boolean | isGetGeneratedKeysEnabled()
boolean | isIdentifierRollbackEnabled()
boolean | isJdbcBatchVersionedData()
boolean | isMinimalPutsEnabled()
boolean | isOrderUpdatesEnabled()
boolean | isQueryCacheEnabled()
boolean | isScrollableResultSetsEnabled()
boolean | isSecondLevelCacheEnabled()
boolean | isShowSqlEnabled()
boolean | isStatisticsEnabled()
boolean | isStrictJPAQLCompliance()
boolean | isStructuredCacheEntriesEnabled()
boolean | isWrapResultSetsEnabled()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getDefaultSchemaName

public String getDefaultSchemaName()

getDefaultCatalogName

public String getDefaultCatalogName()

getDialect

public Dialect getDialect()

getJdbcBatchSize

public int getJdbcBatchSize()

getDefaultBatchFetchSize

public int getDefaultBatchFetchSize()

getQuerySubstitutions

public Map getQuerySubstitutions()

isShowSqlEnabled

public boolean isShowSqlEnabled()

isFormatSqlEnabled

public boolean isFormatSqlEnabled()

isIdentifierRollbackEnabled

public boolean isIdentifierRollbackEnabled()

isScrollableResultSetsEnabled

public boolean isScrollableResultSetsEnabled()

isGetGeneratedKeysEnabled

public boolean isGetGeneratedKeysEnabled()

isMinimalPutsEnabled

public boolean isMinimalPutsEnabled()

getJdbcFetchSize

public Integer getJdbcFetchSize()

getConnectionProvider

public ConnectionProvider getConnectionProvider()

getTransactionFactory

public TransactionFactory getTransactionFactory()

getSessionFactoryName

public String getSessionFactoryName()

isAutoCreateSchema

public boolean isAutoCreateSchema()

isAutoDropSchema

public boolean isAutoDropSchema()

isAutoUpdateSchema

public boolean isAutoUpdateSchema()

getMaximumFetchDepth

public Integer getMaximumFetchDepth()

getCacheProvider

public CacheProvider getCacheProvider()

getTransactionManagerLookup

public TransactionManagerLookup getTransactionManagerLookup()

isQueryCacheEnabled

public boolean isQueryCacheEnabled()

isCommentsEnabled

public boolean isCommentsEnabled()

isSecondLevelCacheEnabled

public boolean isSecondLevelCacheEnabled()

getCacheRegionPrefix

public String getCacheRegionPrefix()

getQueryCacheFactory

public QueryCacheFactory getQueryCacheFactory()

isStatisticsEnabled

public boolean isStatisticsEnabled()

isJdbcBatchVersionedData

public boolean isJdbcBatchVersionedData()

isFlushBeforeCompletionEnabled

public boolean isFlushBeforeCompletionEnabled()

getBatcherFactory

public BatcherFactory getBatcherFactory()

isAutoCloseSessionEnabled

public boolean isAutoCloseSessionEnabled()

getConnectionReleaseMode

public ConnectionReleaseMode getConnectionReleaseMode()

getQueryTranslatorFactory

public QueryTranslatorFactory getQueryTranslatorFactory()

getSQLExceptionConverter

public SQLExceptionConverter getSQLExceptionConverter()

isWrapResultSetsEnabled

public boolean isWrapResultSetsEnabled()

isOrderUpdatesEnabled

public boolean isOrderUpdatesEnabled()

isStructuredCacheEntriesEnabled

public boolean isStructuredCacheEntriesEnabled()

getDefaultEntityMode

public EntityMode getDefaultEntityMode()

isAutoValidateSchema

public boolean isAutoValidateSchema()

isDataDefinitionImplicitCommit

public boolean isDataDefinitionImplicitCommit()

isDataDefinitionInTransactionSupported

public boolean isDataDefinitionInTransactionSupported()

isStrictJPAQLCompliance

public boolean isStrictJPAQLCompliance()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SettingsFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.cfg
Class SettingsFactory

java.lang.Object
    extended by org.hibernate.cfg.SettingsFactory
All Implemented Interfaces:
Serializable
public class SettingsFactory
extends Object
implements Serializable

Reads configuration properties and configures a Settings instance.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
static String DEF_CACHE_PROVIDER
Constructor Summary
protected SettingsFactory()
Method Summary
protected BytecodeProvider | buildBytecodeProvider(String providerName)
Settings | buildSettings(Properties props)
protected BatcherFactory | createBatcherFactory(Properties properties, int batchSize)
protected CacheProvider | createCacheProvider(Properties properties)
protected ConnectionProvider | createConnectionProvider(Properties properties)
protected QueryCacheFactory | createQueryCacheFactory(Properties properties)
protected QueryTranslatorFactory | createQueryTranslatorFactory(Properties properties)
protected TransactionFactory | createTransactionFactory(Properties properties)
protected TransactionManagerLookup | createTransactionManagerLookup(Properties properties)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEF_CACHE_PROVIDER

public static final String DEF_CACHE_PROVIDER
Constructor Detail

SettingsFactory

protected SettingsFactory()
                   throws HibernateException
Method Detail

buildSettings

public Settings buildSettings(Properties props)

buildBytecodeProvider

protected BytecodeProvider buildBytecodeProvider(String providerName)

createQueryCacheFactory

protected QueryCacheFactory createQueryCacheFactory(Properties properties)

createCacheProvider

protected CacheProvider createCacheProvider(Properties properties)

createQueryTranslatorFactory

protected QueryTranslatorFactory createQueryTranslatorFactory(Properties properties)

createBatcherFactory

protected BatcherFactory createBatcherFactory(Properties properties,
                                              int batchSize)

createConnectionProvider

protected ConnectionProvider createConnectionProvider(Properties properties)

createTransactionFactory

protected TransactionFactory createTransactionFactory(Properties properties)

createTransactionManagerLookup

protected TransactionManagerLookup createTransactionManagerLookup(Properties properties)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.classic (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.classic

This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.

See:
Description

Interface Summary
Lifecycle | Provides callbacks from the Session to the persistent object.
Session | An extension of the Session API, including all deprecated methods from Hibernate2.
Validatable | Implemented by persistent classes with invariants that must be checked before inserting into or updating the database.

Exception Summary
ValidationFailure Thrown from Validatable.validate() when an invariant was violated.

Package org.hibernate.classic Description

This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.


org.hibernate.classic Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.classic

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class org.hibernate.exception.NestableRuntimeException (implements org.hibernate.exception.Nestable)
            • class org.hibernate.HibernateException
              • class org.hibernate.classic.ValidationFailure

Interface Hierarchy

  • interface org.hibernate.classic.Lifecycle
  • interface java.io.Serializable
    • interface org.hibernate.Session
      • interface org.hibernate.classic.Session
  • interface org.hibernate.classic.Validatable


Uses of Package org.hibernate.classic (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.classic

Packages that use org.hibernate.classic
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.classic | This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.
org.hibernate.context |
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.

Classes in org.hibernate.classic used by org.hibernate
Session
An extension of the Session API, including all deprecated methods from Hibernate2.

Classes in org.hibernate.classic used by org.hibernate.classic
ValidationFailure
Thrown from Validatable.validate() when an invariant was violated.

Classes in org.hibernate.classic used by org.hibernate.context
Session
An extension of the Session API, including all deprecated methods from Hibernate2.

Classes in org.hibernate.classic used by org.hibernate.engine
Session
An extension of the Session API, including all deprecated methods from Hibernate2.

Classes in org.hibernate.classic used by org.hibernate.impl
Session
An extension of the Session API, including all deprecated methods from Hibernate2.

Classes in org.hibernate.classic used by org.hibernate.jmx
Session
An extension of the Session API, including all deprecated methods from Hibernate2.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Lifecycle (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.classic
Interface Lifecycle

public interface Lifecycle

Provides callbacks from the Session to the persistent object. Persistent classes may implement this interface but they are not required to.

onSave: called just before the object is saved
onUpdate: called just before an object is updated, ie. when Session.update() is called
onDelete: called just before an object is deleted
onLoad: called just after an object is loaded

onLoad() may be used to initialize transient properties of the object from its persistent state. It may not be used to load dependent objects since the Session interface may not be invoked from inside this method.

A further intended usage of onLoad(), onSave() and onUpdate() is to store a reference to the Session for later use.

If onSave(), onUpdate() or onDelete() return VETO, the operation is silently vetoed. If a CallbackException is thrown, the operation is vetoed and the exception is passed back to the application.

Note that onSave() is called after an identifier is assigned to the object, except when identity column key generation is used.

Author:
Gavin King
See Also:
CallbackException

Field Summary
static boolean | NO_VETO Return value to accept the action (false)
static boolean | VETO Return value to veto the action (true)
Method Summary
boolean | onDelete(Session s) Called when an entity is deleted.
void | onLoad(Session s, Serializable id) Called after an entity is loaded.
boolean | onSave(Session s) Called when an entity is saved.
boolean | onUpdate(Session s) Called when an entity is passed to Session.update().

Field Detail

VETO

public static final boolean VETO
Return value to veto the action (true)

See Also:
Constant Field Values

NO_VETO

public static final boolean NO_VETO
Return value to accept the action (false)

See Also:
Constant Field Values
Method Detail

onSave

public boolean onSave(Session s)
               throws CallbackException
Called when an entity is saved.

Parameters:
s - the session
Returns:
true to veto save
Throws:
CallbackException

onUpdate

public boolean onUpdate(Session s)
                 throws CallbackException
Called when an entity is passed to Session.update(). This method is not called every time the object's state is persisted during a flush.

Parameters:
s - the session
Returns:
true to veto update
Throws:
CallbackException

onDelete

public boolean onDelete(Session s)
                 throws CallbackException
Called when an entity is deleted.

Parameters:
s - the session
Returns:
true to veto delete
Throws:
CallbackException

onLoad

public void onLoad(Session s,
                   Serializable id)
Called after an entity is loaded. It is illegal to access the Session from inside this method. However, the object may keep a reference to the session for later use.

Parameters:
s - the session
id - the identifier
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Session (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.classic
Interface Session

All Superinterfaces:
Serializable, Session
All Known Implementing Classes:
SessionImpl
public interface Session
extends Session

An extension of the Session API, including all deprecated methods from Hibernate2. This interface is provided to allow easier migration of existing applications. New code should use org.hibernate.Session.

Author:
Gavin King

Method Summary
 Query createSQLQuery(String sql, String[] returnAliases, Class[] returnClasses)
Deprecated. will be replaced with a more Query like interface in later release
 Query createSQLQuery(String sql, String returnAlias, Class returnClass)
Deprecated. will be replaced with a more Query like interface in later release
 int delete(String query)
Deprecated. consider using HQL delete statements
 int delete(String query, Object[] values, Type[] types)
Deprecated. consider using HQL delete statements
 int delete(String query, Object value, Type type)
Deprecated. consider using HQL delete statements
 Collection filter(Object collection, String filter)
Deprecated. use Session.createFilter(Object, String).Query.list()
 Collection filter(Object collection, String filter, Object[] values, Type[] types)
Deprecated. use Session.createFilter(Object, String).setXYZ.Query.list()
 Collection filter(Object collection, String filter, Object value, Type type)
Deprecated. use Session.createFilter(Object, String).setXYZ.Query.list()
 List find(String query)
Deprecated. use Session.createQuery(java.lang.String).Query.list()
 List find(String query, Object[] values, Type[] types)
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.list()
 List find(String query, Object value, Type type)
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.list()
 Iterator iterate(String query)
Deprecated. use Session.createQuery(java.lang.String).Query.iterate()
 Iterator iterate(String query, Object[] values, Type[] types)
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.iterate()
 Iterator iterate(String query, Object value, Type type)
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.iterate()
 void save(Object object, Serializable id)
Deprecated. declare identifier properties for all classes
 void save(String entityName, Object object, Serializable id)
Deprecated. declare identifier properties for all classes
 Object saveOrUpdateCopy(Object object)
Deprecated. use Session.merge(Object)
 Object saveOrUpdateCopy(Object object, Serializable id)
Deprecated. with no replacement
 Object saveOrUpdateCopy(String entityName, Object object)
Deprecated. use Session.merge(String, Object)
 Object saveOrUpdateCopy(String entityName, Object object, Serializable id)
Deprecated. with no replacement
 void update(Object object, Serializable id)
Deprecated. declare identifier properties for all classes
 void update(String entityName, Object object, Serializable id)
Deprecated. declare identifier properties for all classes
Methods inherited from interface org.hibernate.Session
beginTransaction, cancelQuery, clear, close, connection, contains, createCriteria, createCriteria, createCriteria, createCriteria, createFilter, createQuery, createSQLQuery, delete, delete, disableFilter, disconnect, enableFilter, evict, flush, get, get, get, get, getCacheMode, getCurrentLockMode, getEnabledFilter, getEntityMode, getEntityName, getFlushMode, getIdentifier, getNamedQuery, getSession, getSessionFactory, getStatistics, getTransaction, isConnected, isDirty, isOpen, load, load, load, load, load, lock, lock, merge, merge, persist, persist, reconnect, reconnect, refresh, refresh, replicate, replicate, save, save, saveOrUpdate, saveOrUpdate, setCacheMode, setFlushMode, setReadOnly, update, update

Method Detail

saveOrUpdateCopy

public Object saveOrUpdateCopy(Object object)
                        throws HibernateException
Deprecated. use Session.merge(Object)

Copy the state of the given object onto the persistent object with the same identifier. If there is no persistent instance currently associated with the session, it will be loaded. Return the persistent instance. If the given instance is unsaved or does not exist in the database, save it and return it as a newly persistent instance. Otherwise, the given instance does not become associated with the session.

Parameters:
object - a transient instance with state to be copied
Returns:
an updated persistent instance
Throws:
HibernateException

saveOrUpdateCopy

public Object saveOrUpdateCopy(Object object,
                               Serializable id)
                        throws HibernateException
Deprecated. with no replacement

Copy the state of the given object onto the persistent object with the given identifier. If there is no persistent instance currently associated with the session, it will be loaded. Return the persistent instance. If there is no database row with the given identifier, save the given instance and return it as a newly persistent instance. Otherwise, the given instance does not become associated with the session.

Parameters:
object - a persistent or transient instance with state to be copied
id - the identifier of the instance to copy to
Returns:
an updated persistent instance
Throws:
HibernateException

saveOrUpdateCopy

public Object saveOrUpdateCopy(String entityName,
                               Object object)
                        throws HibernateException
Deprecated. use Session.merge(String, Object)

Copy the state of the given object onto the persistent object with the same identifier. If there is no persistent instance currently associated with the session, it will be loaded. Return the persistent instance. If the given instance is unsaved or does not exist in the database, save it and return it as a newly persistent instance. Otherwise, the given instance does not become associated with the session.

Parameters:
object - a transient instance with state to be copied
Returns:
an updated persistent instance
Throws:
HibernateException

saveOrUpdateCopy

public Object saveOrUpdateCopy(String entityName,
                               Object object,
                               Serializable id)
                        throws HibernateException
Deprecated. with no replacement

Copy the state of the given object onto the persistent object with the given identifier. If there is no persistent instance currently associated with the session, it will be loaded. Return the persistent instance. If there is no database row with the given identifier, save the given instance and return it as a newly persistent instance. Otherwise, the given instance does not become associated with the session.

Parameters:
object - a persistent or transient instance with state to be copied
id - the identifier of the instance to copy to
Returns:
an updated persistent instance
Throws:
HibernateException

find

public List find(String query)
          throws HibernateException
Deprecated. use Session.createQuery(java.lang.String).Query.list()

Execute a query.

Parameters:
query - a query expressed in Hibernate's query language
Returns:
a distinct list of instances (or arrays of instances)
Throws:
HibernateException

find

public List find(String query,
                 Object value,
                 Type type)
          throws HibernateException
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.list()

Execute a query with bind parameters, binding a value to a "?" parameter in the query string.

Parameters:
query - the query string
value - a value to be bound to a "?" placeholder (JDBC IN parameter).
type - the Hibernate type of the value
Returns:
a distinct list of instances (or arrays of instances)
Throws:
HibernateException
See Also:
for access to Type instances

find

public List find(String query,
                 Object[] values,
                 Type[] types)
          throws HibernateException
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.list()

Execute a query with bind parameters, binding an array of values to "?" parameters in the query string.

Parameters:
query - the query string
values - an array of values to be bound to the "?" placeholders (JDBC IN parameters).
types - an array of Hibernate types of the values
Returns:
a distinct list of instances
Throws:
HibernateException
See Also:
for access to Type instances

iterate

public Iterator iterate(String query)
                 throws HibernateException
Deprecated. use Session.createQuery(java.lang.String).Query.iterate()

Execute a query and return the results in an iterator. If the query has multiple return values, values will be returned in an array of type Object[].

Entities returned as results are initialized on demand. The first SQL query returns identifiers only. So iterate() is usually a less efficient way to retrieve objects than find().

Parameters:
query - the query string
Returns:
an iterator
Throws:
HibernateException

iterate

public Iterator iterate(String query,
                        Object value,
                        Type type)
                 throws HibernateException
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.iterate()

Execute a query and return the results in an iterator. Write the given value to "?" in the query string. If the query has multiple return values, values will be returned in an array of type Object[].

Entities returned as results are initialized on demand. The first SQL query returns identifiers only. So iterate() is usually a less efficient way to retrieve objects than find().

Parameters:
query - the query string
value - a value to be witten to a "?" placeholder in the query string
type - the hibernate type of value
Returns:
an iterator
Throws:
HibernateException

iterate

public Iterator iterate(String query,
                        Object[] values,
                        Type[] types)
                 throws HibernateException
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.iterate()

Execute a query and return the results in an iterator. Write the given values to "?" in the query string. If the query has multiple return values, values will be returned in an array of type Object[].

Entities returned as results are initialized on demand. The first SQL query returns identifiers only. So iterate() is usually a less efficient way to retrieve objects than find().

Parameters:
query - the query string
values - a list of values to be written to "?" placeholders in the query
types - a list of Hibernate types of the values
Returns:
an iterator
Throws:
HibernateException

filter

public Collection filter(Object collection,
                         String filter)
                  throws HibernateException
Deprecated. use Session.createFilter(Object, String).Query.list()

Apply a filter to a persistent collection. A filter is a Hibernate query that may refer to this, the collection element. Filters allow efficient access to very large lazy collections. (Executing the filter does not initialize the collection.)

Parameters:
collection - a persistent collection to filter
filter - a filter query string
Returns:
Collection the resulting collection
Throws:
HibernateException

filter

public Collection filter(Object collection,
                         String filter,
                         Object value,
                         Type type)
                  throws HibernateException
Deprecated. use Session.createFilter(Object, String).setXYZ.Query.list()

Apply a filter to a persistent collection. A filter is a Hibernate query that may refer to this, the collection element.

Parameters:
collection - a persistent collection to filter
filter - a filter query string
value - a value to be witten to a "?" placeholder in the query string
type - the hibernate type of value
Returns:
Collection
Throws:
HibernateException

filter

public Collection filter(Object collection,
                         String filter,
                         Object[] values,
                         Type[] types)
                  throws HibernateException
Deprecated. use Session.createFilter(Object, String).setXYZ.Query.list()

Apply a filter to a persistent collection. Bind the given parameters to "?" placeholders. A filter is a Hibernate query that may refer to this, the collection element.

Parameters:
collection - a persistent collection to filter
filter - a filter query string
values - a list of values to be written to "?" placeholders in the query
types - a list of Hibernate types of the values
Returns:
Collection
Throws:
HibernateException

delete

public int delete(String query)
           throws HibernateException
Deprecated. consider using HQL delete statements

Delete all objects returned by the query. Return the number of objects deleted.

Note that this is very different from the delete-statement support added in HQL since 3.1. The functionality here is to actually peform the query and then iterate the results calling Session.delete(Object) individually.

Parameters:
query - the query string
Returns:
the number of instances deleted
Throws:
HibernateException

delete

public int delete(String query,
                  Object value,
                  Type type)
           throws HibernateException
Deprecated. consider using HQL delete statements

Delete all objects returned by the query. Return the number of objects deleted.

Note that this is very different from the delete-statement support added in HQL since 3.1. The functionality here is to actually peform the query and then iterate the results calling Session.delete(Object) individually.

Parameters:
query - the query string
value - a value to be witten to a "?" placeholder in the query string.
type - the hibernate type of value.
Returns:
the number of instances deleted
Throws:
HibernateException

delete

public int delete(String query,
                  Object[] values,
                  Type[] types)
           throws HibernateException
Deprecated. consider using HQL delete statements

Delete all objects returned by the query. Return the number of objects deleted.

Note that this is very different from the delete-statement support added in HQL since 3.1. The functionality here is to actually peform the query and then iterate the results calling Session.delete(Object) individually.

Parameters:
query - the query string
values - a list of values to be written to "?" placeholders in the query.
types - a list of Hibernate types of the values
Returns:
the number of instances deleted
Throws:
HibernateException

createSQLQuery

public Query createSQLQuery(String sql,
                            String returnAlias,
                            Class returnClass)
Deprecated. will be replaced with a more Query like interface in later release

Create a new instance of Query for the given SQL string.

Parameters:
sql - a query expressed in SQL
returnAlias - a table alias that appears inside {} in the SQL string
returnClass - the returned persistent class

createSQLQuery

public Query createSQLQuery(String sql,
                            String[] returnAliases,
                            Class[] returnClasses)
Deprecated. will be replaced with a more Query like interface in later release

Create a new instance of Query for the given SQL string.

Parameters:
sql - a query expressed in SQL
returnAliases - an array of table aliases that appear inside {} in the SQL string
returnClasses - the returned persistent classes

save

public void save(Object object,
                 Serializable id)
          throws HibernateException
Deprecated. declare identifier properties for all classes

Persist the given transient instance, using the given identifier. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Parameters:
object - a transient instance of a persistent class
id - an unused valid identifier
Throws:
HibernateException

save

public void save(String entityName,
                 Object object,
                 Serializable id)
          throws HibernateException
Deprecated. declare identifier properties for all classes

Persist the given transient instance, using the given identifier. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Parameters:
object - a transient instance of a persistent class
id - an unused valid identifier
Throws:
HibernateException

update

public void update(Object object,
                   Serializable id)
            throws HibernateException
Deprecated. declare identifier properties for all classes

Update the persistent state associated with the given identifier. An exception is thrown if there is a persistent instance with the same identifier in the current session. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Parameters:
object - a detached instance containing updated state
id - identifier of persistent instance
Throws:
HibernateException

update

public void update(String entityName,
                   Object object,
                   Serializable id)
            throws HibernateException
Deprecated. declare identifier properties for all classes

Update the persistent state associated with the given identifier. An exception is thrown if there is a persistent instance with the same identifier in the current session. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Parameters:
object - a detached instance containing updated state
id - identifier of persistent instance
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Validatable (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.classic
Interface Validatable

public interface Validatable

Implemented by persistent classes with invariants that must be checked before inserting into or updating the database.

Author:
Gavin King

Method Summary
 void validate()
Validate the state of the object before persisting it.

Method Detail

validate

public void validate()
              throws ValidationFailure
Validate the state of the object before persisting it. If a violation occurs, throw a ValidationFailure. This method must not change the state of the object by side-effect.

Throws:
ValidationFailure - if an invariant is violated
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ValidationFailure (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.classic
Class ValidationFailure

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.classic.ValidationFailure
All Implemented Interfaces:
Nestable, Serializable
public class ValidationFailure
extends HibernateException

Thrown from Validatable.validate() when an invariant was violated. Some applications might subclass this exception in order to provide more information about the violation.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
ValidationFailure(Exception e)
ValidationFailure(String message)
ValidationFailure(String message, Exception e)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ValidationFailure

public ValidationFailure(String message)

ValidationFailure

public ValidationFailure(String message,
                         Exception e)

ValidationFailure

public ValidationFailure(Exception e)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.collection (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.collection

This package defines a framework for collection wrappers.

See:
Description

Interface Summary
AbstractPersistentCollection.DelayedOperation |
PersistentCollection | Persistent collections are treated as value objects by Hibernate.

Class Summary
AbstractPersistentCollection | Base class implementing PersistentCollection
PersistentArrayHolder | A persistent wrapper for an array.
PersistentBag | An unordered, unkeyed collection that can contain the same element multiple times.
PersistentElementHolder | A persistent wrapper for an XML element
PersistentIdentifierBag | An IdentifierBag implements "bag" semantics more efficiently than a regular Bag by adding a synthetic identifier column to the table.
PersistentIndexedElementHolder | A persistent wrapper for an XML element
PersistentIndexedElementHolder.IndexedValue |
PersistentList | A persistent wrapper for a java.util.List.
PersistentListElementHolder |
PersistentMap | A persistent wrapper for a java.util.Map.
PersistentMapElementHolder |
PersistentSet | A persistent wrapper for a java.util.Set.
PersistentSortedMap | A persistent wrapper for a java.util.SortedMap.
PersistentSortedSet | A persistent wrapper for a java.util.SortedSet.

Package org.hibernate.collection Description

This package defines a framework for collection wrappers.


org.hibernate.collection Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.collection

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.collection.AbstractPersistentCollection (implements org.hibernate.collection.PersistentCollection, java.io.Serializable)
      • class org.hibernate.collection.PersistentArrayHolder
      • class org.hibernate.collection.PersistentBag (implements java.util.List)
      • class org.hibernate.collection.PersistentElementHolder
      • class org.hibernate.collection.PersistentIdentifierBag (implements java.util.List)
      • class org.hibernate.collection.PersistentIndexedElementHolder
        • class org.hibernate.collection.PersistentListElementHolder
        • class org.hibernate.collection.PersistentMapElementHolder
      • class org.hibernate.collection.PersistentList (implements java.util.List)
      • class org.hibernate.collection.PersistentMap (implements java.util.Map)
        • class org.hibernate.collection.PersistentSortedMap (implements java.util.SortedMap)
      • class org.hibernate.collection.PersistentSet (implements java.util.Set)
        • class org.hibernate.collection.PersistentSortedSet (implements java.util.SortedSet)
    • class org.hibernate.collection.PersistentIndexedElementHolder.IndexedValue

Interface Hierarchy

  • interface org.hibernate.collection.AbstractPersistentCollection.DelayedOperation
  • interface org.hibernate.collection.PersistentCollection


Uses of Package org.hibernate.collection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.collection

Packages that use org.hibernate.collection
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.usertype | Interfaces for user-defined custom types.

Classes in org.hibernate.collection used by org.hibernate.action
PersistentCollection
Persistent collections are treated as value objects by Hibernate.

Classes in org.hibernate.collection used by org.hibernate.cache.entry
PersistentCollection
Persistent collections are treated as value objects by Hibernate.

Classes in org.hibernate.collection used by org.hibernate.collection
AbstractPersistentCollection
Base class implementing PersistentCollection
PersistentCollection
Persistent collections are treated as value objects by Hibernate.
PersistentIndexedElementHolder
A persistent wrapper for an XML element
PersistentMap
A persistent wrapper for a java.util.Map.
PersistentSet
A persistent wrapper for a java.util.Set.

Classes in org.hibernate.collection used by org.hibernate.engine
PersistentCollection
Persistent collections are treated as value objects by Hibernate.

Classes in org.hibernate.collection used by org.hibernate.event
PersistentCollection
Persistent collections are treated as value objects by Hibernate.

Classes in org.hibernate.collection used by org.hibernate.event.def
PersistentCollection
Persistent collections are treated as value objects by Hibernate.

Classes in org.hibernate.collection used by org.hibernate.impl
PersistentCollection
Persistent collections are treated as value objects by Hibernate.

Classes in org.hibernate.collection used by org.hibernate.persister.collection
PersistentCollection
Persistent collections are treated as value objects by Hibernate.

Classes in org.hibernate.collection used by org.hibernate.type
PersistentCollection
Persistent collections are treated as value objects by Hibernate.

Classes in org.hibernate.collection used by org.hibernate.usertype
PersistentCollection
Persistent collections are treated as value objects by Hibernate.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PersistentCollection (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Interface PersistentCollection

All Known Implementing Classes:
AbstractPersistentCollection
public interface PersistentCollection

Persistent collections are treated as value objects by Hibernate. ie. they have no independent existence beyond the object holding a reference to them. Unlike instances of entity classes, they are automatically deleted when unreferenced and automatically become persistent when held by a persistent object. Collections can be passed between different objects (change "roles") and this might cause their elements to move from one database table to another.

Hibernate "wraps" a java collection in an instance of PersistentCollection. This mechanism is designed to support tracking of changes to the collection's persistent state and lazy instantiation of collection elements. The downside is that only certain abstract collection types are supported and any extra semantics are lost

Applications should never use classes in this package directly, unless extending the "framework" here.

Changes to structure of the collection are recorded by the collection calling back to the session. Changes to mutable elements (ie. composite elements) are discovered by cloning their state when the collection is initialized and comparing at flush time.

Author:
Gavin King

Method Summary
boolean | afterInitialize() Called after initializing from cache
void | afterRowInsert(CollectionPersister persister, Object entry, int i) Called after inserting a row, to fetch the natively generated id
void | beforeInitialize(CollectionPersister persister, int anticipatedSize) Called before any elements are read into the collection, allowing appropriate initializations to occur.
void | beginRead() Called just before reading any rows from the JDBC result set
void | clearDirty() Clear the dirty flag, after flushing changes to the database.
void | dirty() Mark the collection as dirty
Serializable | disassemble(CollectionPersister persister) Disassemble the collection, ready for the cache
boolean | empty() Is the collection empty? (don't try to initialize the collection)
boolean | endRead() Called after reading all rows from the JDBC result set
Iterator | entries(CollectionPersister persister) Iterate all collection entries, during update of the database
boolean | entryExists(Object entry, int i) Does an element exist at this entry in the collection?
boolean | equalsSnapshot(CollectionPersister persister) Does the current state exactly match the snapshot?
void | forceInitialization() To be called internally by the session, forcing immediate initialization.
Iterator | getDeletes(CollectionPersister persister, boolean indexIsFormula) Get all the elements that need deleting
Object | getElement(Object entry) Get the value of the given collection entry
Object | getIdentifier(Object entry, int i) Get the index of the given collection entry
Object | getIndex(Object entry, int i, CollectionPersister persister) Get the index of the given collection entry
Serializable | getKey() Get the current collection key value
Collection | getOrphans(Serializable snapshot, String entityName) get all "orphaned" elements
Object | getOwner() Get the owning entity.
Collection | getQueuedOrphans(String entityName) Get the "queued" orphans
String | getRole() Get the current role name
Serializable | getSnapshot(CollectionPersister persister) Return a new snapshot of the current state of the collection
Object | getSnapshotElement(Object entry, int i) Get the snapshot value of the given collection entry
Serializable | getStoredSnapshot() Get the snapshot cached by the collection instance
Object | getValue() return the user-visible collection (or array) instance
boolean | hasQueuedOperations() Does this instance have any "queued" additions?
void | initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner) Read the state of the collection from a disassembled cached value
boolean | isDirectlyAccessible() Could the application possibly have a direct reference to the underlying collection implementation?
boolean | isDirty() Is the collection dirty? Note that this is only reliable during the flush cycle, after the collection elements are dirty checked against the snapshot.
boolean | isRowUpdatePossible()
boolean | isSnapshotEmpty(Serializable snapshot) Is the snapshot empty?
boolean | isUnreferenced() Is the collection unreferenced?
boolean | isWrapper(Object collection) Is this the wrapper for the given underlying collection instance?
boolean | needsInserting(Object entry, int i, Type elemType) Do we need to insert this element?
boolean | needsRecreate(CollectionPersister persister) Do we need to completely recreate this collection when it changes?
boolean | needsUpdating(Object entry, int i, Type elemType) Do we need to update this element?
void | postAction() After flushing, clear any "queued" additions, since the database state is now synchronized with the memory state.
void | preInsert(CollectionPersister persister) Called before inserting rows, to ensure that any surrogate keys are fully generated
Iterator | queuedAdditionIterator() Iterate the "queued" additions
Object | readFrom(ResultSet rs, CollectionPersister role, CollectionAliases descriptor, Object owner) Read a row from the JDBC result set
boolean | setCurrentSession(SessionImplementor session) Associate the collection with the given session.
void | setOwner(Object entity) Set the reference to the owning entity
void | setSnapshot(Serializable key, String role, Serializable snapshot) After flushing, re-init snapshot state.
boolean | unsetSession(SessionImplementor currentSession) Disassociate this collection from the given session.
boolean | wasInitialized() Is this instance initialized?

Method Detail

getOwner

public Object getOwner()
Get the owning entity. Note that the owner is only set during the flush cycle, and when a new collection wrapper is created while loading an entity.

setOwner

public void setOwner(Object entity)
Set the reference to the owning entity

empty

public boolean empty()
Is the collection empty? (don't try to initialize the collection)

setSnapshot

public void setSnapshot(Serializable key,
                        String role,
                        Serializable snapshot)
After flushing, re-init snapshot state.

postAction

public void postAction()
After flushing, clear any "queued" additions, since the database state is now synchronized with the memory state.

getValue

public Object getValue()
return the user-visible collection (or array) instance

beginRead

public void beginRead()
Called just before reading any rows from the JDBC result set

endRead

public boolean endRead()
Called after reading all rows from the JDBC result set

afterInitialize

public boolean afterInitialize()
Called after initializing from cache

isDirectlyAccessible

public boolean isDirectlyAccessible()
Could the application possibly have a direct reference to the underlying collection implementation?

unsetSession

public boolean unsetSession(SessionImplementor currentSession)
Disassociate this collection from the given session.

Returns:
true if this was currently associated with the given session

setCurrentSession

public boolean setCurrentSession(SessionImplementor session)
                          throws HibernateException
Associate the collection with the given session.

Returns:
false if the collection was already associated with the session
Throws:
HibernateException - if the collection was already associated with another open session

initializeFromCache

public void initializeFromCache(CollectionPersister persister,
                                Serializable disassembled,
                                Object owner)
                         throws HibernateException
Read the state of the collection from a disassembled cached value

Throws:
HibernateException

entries

public Iterator entries(CollectionPersister persister)
Iterate all collection entries, during update of the database

readFrom

public Object readFrom(ResultSet rs,
                       CollectionPersister role,
                       CollectionAliases descriptor,
                       Object owner)
                throws HibernateException,
                       SQLException
Read a row from the JDBC result set

Throws:
HibernateException
SQLException

getIdentifier

public Object getIdentifier(Object entry,
                            int i)
Get the index of the given collection entry

getIndex

public Object getIndex(Object entry,
                       int i,
                       CollectionPersister persister)
Get the index of the given collection entry

Parameters:
persister - it was more elegant before we added this...

getElement

public Object getElement(Object entry)
Get the value of the given collection entry

getSnapshotElement

public Object getSnapshotElement(Object entry,
                                 int i)
Get the snapshot value of the given collection entry

beforeInitialize

public void beforeInitialize(CollectionPersister persister,
                             int anticipatedSize)
Called before any elements are read into the collection, allowing appropriate initializations to occur.

Parameters:
persister - The underlying collection persister.
anticipatedSize - The anticipated size of the collection after initilization is complete.

equalsSnapshot

public boolean equalsSnapshot(CollectionPersister persister)
                       throws HibernateException
Does the current state exactly match the snapshot?

Throws:
HibernateException

isSnapshotEmpty

public boolean isSnapshotEmpty(Serializable snapshot)
Is the snapshot empty?

disassemble

public Serializable disassemble(CollectionPersister persister)
                         throws HibernateException
Disassemble the collection, ready for the cache

Throws:
HibernateException

needsRecreate

public boolean needsRecreate(CollectionPersister persister)
Do we need to completely recreate this collection when it changes?

getSnapshot

public Serializable getSnapshot(CollectionPersister persister)
                         throws HibernateException
Return a new snapshot of the current state of the collection

Throws:
HibernateException

forceInitialization

public void forceInitialization()
                         throws HibernateException
To be called internally by the session, forcing immediate initialization.

Throws:
HibernateException

entryExists

public boolean entryExists(Object entry,
                           int i)
Does an element exist at this entry in the collection?

needsInserting

public boolean needsInserting(Object entry,
                              int i,
                              Type elemType)
                       throws HibernateException
Do we need to insert this element?

Throws:
HibernateException

needsUpdating

public boolean needsUpdating(Object entry,
                             int i,
                             Type elemType)
                      throws HibernateException
Do we need to update this element?

Throws:
HibernateException

isRowUpdatePossible

public boolean isRowUpdatePossible()

getDeletes

public Iterator getDeletes(CollectionPersister persister,
                           boolean indexIsFormula)
                    throws HibernateException
Get all the elements that need deleting

Throws:
HibernateException

isWrapper

public boolean isWrapper(Object collection)
Is this the wrapper for the given underlying collection instance?

wasInitialized

public boolean wasInitialized()
Is this instance initialized?

hasQueuedOperations

public boolean hasQueuedOperations()
Does this instance have any "queued" additions?

queuedAdditionIterator

public Iterator queuedAdditionIterator()
Iterate the "queued" additions

getQueuedOrphans

public Collection getQueuedOrphans(String entityName)
Get the "queued" orphans

getKey

public Serializable getKey()
Get the current collection key value

getRole

public String getRole()
Get the current role name

isUnreferenced

public boolean isUnreferenced()
Is the collection unreferenced?

isDirty

public boolean isDirty()
Is the collection dirty? Note that this is only reliable during the flush cycle, after the collection elements are dirty checked against the snapshot.

clearDirty

public void clearDirty()
Clear the dirty flag, after flushing changes to the database.

getStoredSnapshot

public Serializable getStoredSnapshot()
Get the snapshot cached by the collection instance

dirty

public void dirty()
Mark the collection as dirty

preInsert

public void preInsert(CollectionPersister persister)
               throws HibernateException
Called before inserting rows, to ensure that any surrogate keys are fully generated

Throws:
HibernateException

afterRowInsert

public void afterRowInsert(CollectionPersister persister,
                           Object entry,
                           int i)
                    throws HibernateException
Called after inserting a row, to fetch the natively generated id

Throws:
HibernateException

getOrphans

public Collection getOrphans(Serializable snapshot,
                             String entityName)
                      throws HibernateException
get all "orphaned" elements

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractPersistentCollection (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class AbstractPersistentCollection

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
All Implemented Interfaces:
PersistentCollection, Serializable
Direct Known Subclasses:
PersistentArrayHolder, PersistentBag, PersistentElementHolder, PersistentIdentifierBag, PersistentIndexedElementHolder, PersistentList, PersistentMap, PersistentSet
public abstract class AbstractPersistentCollection
extends Object
implements Serializable, PersistentCollection

Base class implementing PersistentCollection

Author:
Gavin King
See Also:
PersistentCollection, Serialized Form

Nested Class Summary
protected static interface AbstractPersistentCollection.DelayedOperation
Field Summary
protected static Object UNKNOWN
Constructor Summary
 | AbstractPersistentCollection() Not called by Hibernate, but used by non-JDK serialization, eg.
protected | AbstractPersistentCollection(SessionImplementor session)
Method Summary
 boolean afterInitialize()
Called after initializing from cache
 void afterRowInsert(CollectionPersister persister, Object entry, int i)
Called after inserting a row, to fetch the natively generated id
 void beginRead()
Called just before reading any rows from the JDBC result set
 void clearDirty()
Clear the dirty flag, after flushing changes to the database.
 void dirty()
Mark the collection as dirty
abstract  boolean empty()
Is the initialized collection empty?
 boolean endRead()
Called after reading all rows from the JDBC result set
 void forceInitialization()
To be called internally by the session, forcing immediate initialization.
protected  int getCachedSize()
 Object getIdentifier(Object entry, int i)
Get the index of the given collection entry
 Serializable getKey()
Get the current collection key value
protected static Collection getOrphans(Collection oldElements, Collection currentElements, String entityName, SessionImplementor session)
Given a collection of entity instances that used to belong to the collection, and a collection of instances that currently belong, return a collection of orphans
abstract  Collection getOrphans(Serializable snapshot, String entityName)
get all "orphaned" elements
 Object getOwner()
Get the owning entity.
 Collection getQueuedOrphans(String entityName)
Iterate the "queued" additions
 String getRole()
Get the current role name
protected  SessionImplementor getSession()
Get the current session
protected  Serializable getSnapshot()
Get the current snapshot from the session
 Serializable getStoredSnapshot()
Get the snapshot cached by the collection instance
 Object getValue()
return the user-visible collection (or array) instance
 boolean hasQueuedOperations()
Does this instance have any "queued" additions?
protected  void initialize(boolean writing)
Initialize the collection, if possible, wrapping any exceptions in a runtime exception
protected  boolean isClearQueueEnabled()
Is this collection in a state that would allow us to "queue" clear? This is a special case, because of orphan delete.
 boolean isDirectlyAccessible()
Could the application possibly have a direct reference to the underlying collection implementation?
 boolean isDirty()
Is the collection dirty? Note that this is only reliable during the flush cycle, after the collection elements are dirty checked against the snapshot.
protected  boolean isOperationQueueEnabled()
Is this collection in a state that would allow us to "queue" operations?
protected  boolean isPutQueueEnabled()
Is this collection in a state that would allow us to "queue" puts? This is a special case, because of orphan delete.
 boolean isRowUpdatePossible()
 boolean isUnreferenced()
Is the collection unreferenced?
 boolean needsRecreate(CollectionPersister persister)
Do we need to completely recreate this collection when it changes?
protected  void performQueuedOperations()
After reading all existing elements from the database, add the queued elements to the underlying collection.
 void postAction()
After flushing, clear any "queued" additions, since the database state is now synchronized with the memory state.
 void preInsert(CollectionPersister persister)
Called before inserting rows, to ensure that any surrogate keys are fully generated
 Iterator queuedAdditionIterator()
Iterate the "queued" additions
protected  void queueOperation(Object element)
Queue an addition
protected  void read()
Called by any read-only method of the collection interface
protected  Object readElementByIndex(Object index)
protected  Boolean readElementExistence(Object element)
protected  Boolean readIndexExistence(Object index)
protected  boolean readSize()
Called by the size() method
 boolean setCurrentSession(SessionImplementor session)
Associate the collection with the given session.
protected  void setDirectlyAccessible(boolean directlyAccessible)
protected  void setInitialized()
 void setOwner(Object owner)
Set the reference to the owning entity
 void setSnapshot(Serializable key, String role, Serializable snapshot)
After flushing, re-init snapshot state.
 boolean unsetSession(SessionImplementor currentSession)
Disassociate this collection from the given session.
 boolean wasInitialized()
Is this instance initialized?
protected  void write()
Called by any writer method of the collection interface
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.collection.PersistentCollection
beforeInitialize, disassemble, entries, entryExists, equalsSnapshot, getDeletes, getElement, getIndex, getSnapshot, getSnapshotElement, initializeFromCache, isSnapshotEmpty, isWrapper, needsInserting, needsUpdating, readFrom

Field Detail

UNKNOWN

protected static final Object UNKNOWN
Constructor Detail

AbstractPersistentCollection

public AbstractPersistentCollection()
Not called by Hibernate, but used by non-JDK serialization, eg. SOAP libraries.

AbstractPersistentCollection

protected AbstractPersistentCollection(SessionImplementor session)
Method Detail

getRole

public final String getRole()
Description copied from interface: PersistentCollection
Get the current role name

Specified by:
getRole in interface PersistentCollection

getKey

public final Serializable getKey()
Description copied from interface: PersistentCollection
Get the current collection key value

Specified by:
getKey in interface PersistentCollection

isUnreferenced

public final boolean isUnreferenced()
Description copied from interface: PersistentCollection
Is the collection unreferenced?

Specified by:
isUnreferenced in interface PersistentCollection

isDirty

public final boolean isDirty()
Description copied from interface: PersistentCollection
Is the collection dirty? Note that this is only reliable during the flush cycle, after the collection elements are dirty checked against the snapshot.

Specified by:
isDirty in interface PersistentCollection

clearDirty

public final void clearDirty()
Description copied from interface: PersistentCollection
Clear the dirty flag, after flushing changes to the database.

Specified by:
clearDirty in interface PersistentCollection

dirty

public final void dirty()
Description copied from interface: PersistentCollection
Mark the collection as dirty

Specified by:
dirty in interface PersistentCollection

getStoredSnapshot

public final Serializable getStoredSnapshot()
Description copied from interface: PersistentCollection
Get the snapshot cached by the collection instance

Specified by:
getStoredSnapshot in interface PersistentCollection

empty

public abstract boolean empty()
Is the initialized collection empty?

Specified by:
empty in interface PersistentCollection

read

protected final void read()
Called by any read-only method of the collection interface

readSize

protected boolean readSize()
Called by the size() method

readIndexExistence

protected Boolean readIndexExistence(Object index)

readElementExistence

protected Boolean readElementExistence(Object element)

readElementByIndex

protected Object readElementByIndex(Object index)

getCachedSize

protected int getCachedSize()

write

protected final void write()
Called by any writer method of the collection interface

isOperationQueueEnabled

protected boolean isOperationQueueEnabled()
Is this collection in a state that would allow us to "queue" operations?

isPutQueueEnabled

protected boolean isPutQueueEnabled()
Is this collection in a state that would allow us to "queue" puts? This is a special case, because of orphan delete.

isClearQueueEnabled

protected boolean isClearQueueEnabled()
Is this collection in a state that would allow us to "queue" clear? This is a special case, because of orphan delete.

queueOperation

protected final void queueOperation(Object element)
Queue an addition

performQueuedOperations

protected final void performQueuedOperations()
After reading all existing elements from the database, add the queued elements to the underlying collection.

setSnapshot

public void setSnapshot(Serializable key,
                        String role,
                        Serializable snapshot)
After flushing, re-init snapshot state.

Specified by:
setSnapshot in interface PersistentCollection

postAction

public void postAction()
After flushing, clear any "queued" additions, since the database state is now synchronized with the memory state.

Specified by:
postAction in interface PersistentCollection

getValue

public Object getValue()
return the user-visible collection (or array) instance

Specified by:
getValue in interface PersistentCollection

beginRead

public void beginRead()
Called just before reading any rows from the JDBC result set

Specified by:
beginRead in interface PersistentCollection

endRead

public boolean endRead()
Called after reading all rows from the JDBC result set

Specified by:
endRead in interface PersistentCollection

afterInitialize

public boolean afterInitialize()
Description copied from interface: PersistentCollection
Called after initializing from cache

Specified by:
afterInitialize in interface PersistentCollection

initialize

protected final void initialize(boolean writing)
Initialize the collection, if possible, wrapping any exceptions in a runtime exception

Parameters:
writing - currently obsolete
Throws:
LazyInitializationException - if we cannot initialize

setInitialized

protected final void setInitialized()

setDirectlyAccessible

protected final void setDirectlyAccessible(boolean directlyAccessible)

isDirectlyAccessible

public boolean isDirectlyAccessible()
Could the application possibly have a direct reference to the underlying collection implementation?

Specified by:
isDirectlyAccessible in interface PersistentCollection

unsetSession

public final boolean unsetSession(SessionImplementor currentSession)
Disassociate this collection from the given session.

Specified by:
unsetSession in interface PersistentCollection
Returns:
true if this was currently associated with the given session

setCurrentSession

public final boolean setCurrentSession(SessionImplementor session)
                                throws HibernateException
Associate the collection with the given session.

Specified by:
setCurrentSession in interface PersistentCollection
Returns:
false if the collection was already associated with the session
Throws:
HibernateException - if the collection was already associated with another open session

needsRecreate

public boolean needsRecreate(CollectionPersister persister)
Do we need to completely recreate this collection when it changes?

Specified by:
needsRecreate in interface PersistentCollection

forceInitialization

public final void forceInitialization()
                               throws HibernateException
To be called internally by the session, forcing immediate initialization.

Specified by:
forceInitialization in interface PersistentCollection
Throws:
HibernateException

getSnapshot

protected final Serializable getSnapshot()
Get the current snapshot from the session

wasInitialized

public final boolean wasInitialized()
Is this instance initialized?

Specified by:
wasInitialized in interface PersistentCollection

isRowUpdatePossible

public boolean isRowUpdatePossible()
Specified by:
isRowUpdatePossible in interface PersistentCollection

hasQueuedOperations

public final boolean hasQueuedOperations()
Does this instance have any "queued" additions?

Specified by:
hasQueuedOperations in interface PersistentCollection

queuedAdditionIterator

public final Iterator queuedAdditionIterator()
Iterate the "queued" additions

Specified by:
queuedAdditionIterator in interface PersistentCollection

getQueuedOrphans

public final Collection getQueuedOrphans(String entityName)
Iterate the "queued" additions

Specified by:
getQueuedOrphans in interface PersistentCollection

preInsert

public void preInsert(CollectionPersister persister)
               throws HibernateException
Called before inserting rows, to ensure that any surrogate keys are fully generated

Specified by:
preInsert in interface PersistentCollection
Throws:
HibernateException

afterRowInsert

public void afterRowInsert(CollectionPersister persister,
                           Object entry,
                           int i)
                    throws HibernateException
Called after inserting a row, to fetch the natively generated id

Specified by:
afterRowInsert in interface PersistentCollection
Throws:
HibernateException

getOrphans

public abstract Collection getOrphans(Serializable snapshot,
                                      String entityName)
                               throws HibernateException
get all "orphaned" elements

Specified by:
getOrphans in interface PersistentCollection
Throws:
HibernateException

getSession

protected final SessionImplementor getSession()
Get the current session

getOrphans

protected static Collection getOrphans(Collection oldElements,
                                       Collection currentElements,
                                       String entityName,
                                       SessionImplementor session)
                                throws HibernateException
Given a collection of entity instances that used to belong to the collection, and a collection of instances that currently belong, return a collection of orphans

Throws:
HibernateException

getIdentifier

public Object getIdentifier(Object entry,
                            int i)
Description copied from interface: PersistentCollection
Get the index of the given collection entry

Specified by:
getIdentifier in interface PersistentCollection

getOwner

public Object getOwner()
Description copied from interface: PersistentCollection
Get the owning entity. Note that the owner is only set during the flush cycle, and when a new collection wrapper is created while loading an entity.

Specified by:
getOwner in interface PersistentCollection

setOwner

public void setOwner(Object owner)
Description copied from interface: PersistentCollection
Set the reference to the owning entity

Specified by:
setOwner in interface PersistentCollection
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractPersistentCollection.DelayedOperation (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Interface AbstractPersistentCollection.DelayedOperation

Enclosing interface:
AbstractPersistentCollection
protected static interface AbstractPersistentCollection.DelayedOperation

Method Summary
Object | getAddedInstance()
Object | getOrphan()
void | operate()

Method Detail

operate

public void operate()

getAddedInstance

public Object getAddedInstance()

getOrphan

public Object getOrphan()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PersistentArrayHolder (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentArrayHolder

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
        extended by org.hibernate.collection.PersistentArrayHolder
All Implemented Interfaces:
PersistentCollection, Serializable
public class PersistentArrayHolder
extends AbstractPersistentCollection

A persistent wrapper for an array. Lazy initialization is NOT supported. Use of Hibernate arrays is not really recommended.

Author:
Gavin King
See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.collection.AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
Field Summary
protected  Object array
Fields inherited from class org.hibernate.collection.AbstractPersistentCollection
UNKNOWN
Constructor Summary
PersistentArrayHolder(SessionImplementor session, CollectionPersister persister)
PersistentArrayHolder(SessionImplementor session, Object array)
Method Summary
void | beforeInitialize(CollectionPersister persister, int anticipatedSize) Called before any elements are read into the collection, allowing appropriate initializations to occur.
void | beginRead() Called just before reading any rows from the JDBC result set
Serializable | disassemble(CollectionPersister persister) Disassemble the collection, ready for the cache
Iterator | elements()
boolean | empty() Is the initialized collection empty?
boolean | endRead() Called after reading all rows from the JDBC result set
Iterator | entries(CollectionPersister persister) Iterate all collection entries, during update of the database
boolean | entryExists(Object entry, int i) Does an element exist at this entry in the collection?
boolean | equalsSnapshot(CollectionPersister persister) Does the current state exactly match the snapshot?
Object | getArray()
Iterator | getDeletes(CollectionPersister persister, boolean indexIsFormula) Get all the elements that need deleting
Object | getElement(Object entry) Get the value of the given collection entry
Object | getIndex(Object entry, int i, CollectionPersister persister) Get the index of the given collection entry
Collection | getOrphans(Serializable snapshot, String entityName) get all "orphaned" elements
Serializable | getSnapshot(CollectionPersister persister) Return a new snapshot of the current state of the collection
Object | getSnapshotElement(Object entry, int i) Get the snapshot value of the given collection entry
Object | getValue() return the user-visible collection (or array) instance
void | initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner) Read the state of the collection from a disassembled cached value
boolean | isDirectlyAccessible() Could the application possibly have a direct reference to the underlying collection implementation?
boolean | isSnapshotEmpty(Serializable snapshot) Is the snapshot empty?
boolean | isWrapper(Object collection) Is this the wrapper for the given underlying collection instance?
boolean | needsInserting(Object entry, int i, Type elemType) Do we need to insert this element?
boolean | needsUpdating(Object entry, int i, Type elemType) Do we need to update this element?
Object | readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner) Read a row from the JDBC result set
Methods inherited from class org.hibernate.collection.AbstractPersistentCollection
afterInitialize, afterRowInsert, clearDirty, dirty, forceInitialization, getCachedSize, getIdentifier, getKey, getOrphans, getOwner, getQueuedOrphans, getRole, getSession, getSnapshot, getStoredSnapshot, hasQueuedOperations, initialize, isClearQueueEnabled, isDirty, isOperationQueueEnabled, isPutQueueEnabled, isRowUpdatePossible, isUnreferenced, needsRecreate, performQueuedOperations, postAction, preInsert, queuedAdditionIterator, queueOperation, read, readElementByIndex, readElementExistence, readIndexExistence, readSize, setCurrentSession, setDirectlyAccessible, setInitialized, setOwner, setSnapshot, unsetSession, wasInitialized, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

array

protected Object array
Constructor Detail

PersistentArrayHolder

public PersistentArrayHolder(SessionImplementor session,
                             Object array)

PersistentArrayHolder

public PersistentArrayHolder(SessionImplementor session,
                             CollectionPersister persister)
                      throws HibernateException
Method Detail

getSnapshot

public Serializable getSnapshot(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Return a new snapshot of the current state of the collection

Throws:
HibernateException

isSnapshotEmpty

public boolean isSnapshotEmpty(Serializable snapshot)
Description copied from interface: PersistentCollection
Is the snapshot empty?

getOrphans

public Collection getOrphans(Serializable snapshot,
                             String entityName)
                      throws HibernateException
Description copied from class: AbstractPersistentCollection
get all "orphaned" elements

Specified by:
getOrphans in interface PersistentCollection
Specified by:
getOrphans in class AbstractPersistentCollection
Throws:
HibernateException

getArray

public Object getArray()

isWrapper

public boolean isWrapper(Object collection)
Description copied from interface: PersistentCollection
Is this the wrapper for the given underlying collection instance?

equalsSnapshot

public boolean equalsSnapshot(CollectionPersister persister)
                       throws HibernateException
Description copied from interface: PersistentCollection
Does the current state exactly match the snapshot?

Throws:
HibernateException

elements

public Iterator elements()

empty

public boolean empty()
Description copied from class: AbstractPersistentCollection
Is the initialized collection empty?

Specified by:
empty in interface PersistentCollection
Specified by:
empty in class AbstractPersistentCollection

readFrom

public Object readFrom(ResultSet rs,
                       CollectionPersister persister,
                       CollectionAliases descriptor,
                       Object owner)
                throws HibernateException,
                       SQLException
Description copied from interface: PersistentCollection
Read a row from the JDBC result set

Throws:
HibernateException
SQLException

entries

public Iterator entries(CollectionPersister persister)
Description copied from interface: PersistentCollection
Iterate all collection entries, during update of the database

beginRead

public void beginRead()
Description copied from class: AbstractPersistentCollection
Called just before reading any rows from the JDBC result set

Specified by:
beginRead in interface PersistentCollection
Overrides:
beginRead in class AbstractPersistentCollection

endRead

public boolean endRead()
Description copied from class: AbstractPersistentCollection
Called after reading all rows from the JDBC result set

Specified by:
endRead in interface PersistentCollection
Overrides:
endRead in class AbstractPersistentCollection

beforeInitialize

public void beforeInitialize(CollectionPersister persister,
                             int anticipatedSize)
Description copied from interface: PersistentCollection
Called before any elements are read into the collection, allowing appropriate initializations to occur.

Parameters:
persister - The underlying collection persister.
anticipatedSize - The anticipated size of the collection after initilization is complete.

isDirectlyAccessible

public boolean isDirectlyAccessible()
Description copied from class: AbstractPersistentCollection
Could the application possibly have a direct reference to the underlying collection implementation?

Specified by:
isDirectlyAccessible in interface PersistentCollection
Overrides:
isDirectlyAccessible in class AbstractPersistentCollection

initializeFromCache

public void initializeFromCache(CollectionPersister persister,
                                Serializable disassembled,
                                Object owner)
                         throws HibernateException
Description copied from interface: PersistentCollection
Read the state of the collection from a disassembled cached value

Throws:
HibernateException

disassemble

public Serializable disassemble(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Disassemble the collection, ready for the cache

Throws:
HibernateException

getValue

public Object getValue()
Description copied from class: AbstractPersistentCollection
return the user-visible collection (or array) instance

Specified by:
getValue in interface PersistentCollection
Overrides:
getValue in class AbstractPersistentCollection

getDeletes

public Iterator getDeletes(CollectionPersister persister,
                           boolean indexIsFormula)
                    throws HibernateException
Description copied from interface: PersistentCollection
Get all the elements that need deleting

Throws:
HibernateException

needsInserting

public boolean needsInserting(Object entry,
                              int i,
                              Type elemType)
                       throws HibernateException
Description copied from interface: PersistentCollection
Do we need to insert this element?

Throws:
HibernateException

needsUpdating

public boolean needsUpdating(Object entry,
                             int i,
                             Type elemType)
                      throws HibernateException
Description copied from interface: PersistentCollection
Do we need to update this element?

Throws:
HibernateException

getIndex

public Object getIndex(Object entry,
                       int i,
                       CollectionPersister persister)
Description copied from interface: PersistentCollection
Get the index of the given collection entry

Parameters:
persister - it was more elegant before we added this...

getElement

public Object getElement(Object entry)
Description copied from interface: PersistentCollection
Get the value of the given collection entry

getSnapshotElement

public Object getSnapshotElement(Object entry,
                                 int i)
Description copied from interface: PersistentCollection
Get the snapshot value of the given collection entry

entryExists

public boolean entryExists(Object entry,
                           int i)
Description copied from interface: PersistentCollection
Does an element exist at this entry in the collection?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentBag (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentBag

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
        extended by org.hibernate.collection.PersistentBag
All Implemented Interfaces:
Collection, List, PersistentCollection, Serializable
public class PersistentBag
extends AbstractPersistentCollection
implements List

An unordered, unkeyed collection that can contain the same element multiple times. The Java collections API, curiously, has no Bag. Most developers seem to use Lists to represent bag semantics, so Hibernate follows this practice.

Author:
Gavin King
See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.collection.AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
Field Summary
protected  List bag
Fields inherited from class org.hibernate.collection.AbstractPersistentCollection
UNKNOWN
Constructor Summary
PersistentBag()
PersistentBag(SessionImplementor session)
PersistentBag(SessionImplementor session, Collection coll)
Method Summary
void | add(int i, Object o)
boolean | add(Object object)
boolean | addAll(Collection values)
boolean | addAll(int i, Collection c)
void | beforeInitialize(CollectionPersister persister, int anticipatedSize) Called before any elements are read into the collection, allowing appropriate initializations to occur.
void | clear()
boolean | contains(Object object)
boolean | containsAll(Collection c)
Serializable | disassemble(CollectionPersister persister) Disassemble the collection, ready for the cache
boolean | empty() Is the initialized collection empty?
Iterator | entries(CollectionPersister persister) Iterate all collection entries, during update of the database
boolean | entryExists(Object entry, int i) Does an element exist at this entry in the collection?
boolean | equals(Object obj) Bag does not respect the collection API and do an JVM instance comparison to do the equals.
boolean | equalsSnapshot(CollectionPersister persister) Does the current state exactly match the snapshot?
Object | get(int i)
Iterator | getDeletes(CollectionPersister persister, boolean indexIsFormula) Get all the elements that need deleting
Object | getElement(Object entry) Get the value of the given collection entry
Object | getIndex(Object entry, int i, CollectionPersister persister) Get the index of the given collection entry
Collection | getOrphans(Serializable snapshot, String entityName) get all "orphaned" elements
Serializable | getSnapshot(CollectionPersister persister) Return a new snapshot of the current state of the collection
Object | getSnapshotElement(Object entry, int i) Get the snapshot value of the given collection entry
int | hashCode()
int | indexOf(Object o)
void | initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner) Read the state of the collection from a disassembled cached value
boolean | isEmpty()
boolean | isRowUpdatePossible()
boolean | isSnapshotEmpty(Serializable snapshot) Is the snapshot empty?
boolean | isWrapper(Object collection) Is this the wrapper for the given underlying collection instance?
Iterator | iterator()
int | lastIndexOf(Object o)
ListIterator | listIterator()
ListIterator | listIterator(int i)
boolean | needsInserting(Object entry, int i, Type elemType) Do we need to insert this element?
boolean | needsRecreate(CollectionPersister persister) Do we need to completely recreate this collection when it changes?
boolean | needsUpdating(Object entry, int i, Type elemType) Do we need to update this element?
int | occurrences(Object o)
Object | readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner) Read a row from the JDBC result set
Object | remove(int i)
boolean | remove(Object o)
boolean | removeAll(Collection c)
boolean | retainAll(Collection c)
Object | set(int i, Object o)
int | size()
List | subList(int start, int end)
Object[] | toArray()
Object[] | toArray(Object[] a)
String | toString()
Methods inherited from class org.hibernate.collection.AbstractPersistentCollection
afterInitialize, afterRowInsert, beginRead, clearDirty, dirty, endRead, forceInitialization, getCachedSize, getIdentifier, getKey, getOrphans, getOwner, getQueuedOrphans, getRole, getSession, getSnapshot, getStoredSnapshot, getValue, hasQueuedOperations, initialize, isClearQueueEnabled, isDirectlyAccessible, isDirty, isOperationQueueEnabled, isPutQueueEnabled, isUnreferenced, performQueuedOperations, postAction, preInsert, queuedAdditionIterator, queueOperation, read, readElementByIndex, readElementExistence, readIndexExistence, readSize, setCurrentSession, setDirectlyAccessible, setInitialized, setOwner, setSnapshot, unsetSession, wasInitialized, write
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

bag

protected List bag
Constructor Detail

PersistentBag

public PersistentBag(SessionImplementor session)

PersistentBag

public PersistentBag(SessionImplementor session,
                     Collection coll)

PersistentBag

public PersistentBag()
Method Detail

isWrapper

public boolean isWrapper(Object collection)
Description copied from interface: PersistentCollection
Is this the wrapper for the given underlying collection instance?

Specified by:
isWrapper in interface PersistentCollection

empty

public boolean empty()
Description copied from class: AbstractPersistentCollection
Is the initialized collection empty?

Specified by:
empty in interface PersistentCollection
Specified by:
empty in class AbstractPersistentCollection

entries

public Iterator entries(CollectionPersister persister)
Description copied from interface: PersistentCollection
Iterate all collection entries, during update of the database

Specified by:
entries in interface PersistentCollection

readFrom

public Object readFrom(ResultSet rs,
                       CollectionPersister persister,
                       CollectionAliases descriptor,
                       Object owner)
                throws HibernateException,
                       SQLException
Description copied from interface: PersistentCollection
Read a row from the JDBC result set

Specified by:
readFrom in interface PersistentCollection
Throws:
HibernateException
SQLException

beforeInitialize

public void beforeInitialize(CollectionPersister persister,
                             int anticipatedSize)
Description copied from interface: PersistentCollection
Called before any elements are read into the collection, allowing appropriate initializations to occur.

Specified by:
beforeInitialize in interface PersistentCollection
Parameters:
persister - The underlying collection persister.
anticipatedSize - The anticipated size of the collection after initilization is complete.

equalsSnapshot

public boolean equalsSnapshot(CollectionPersister persister)
                       throws HibernateException
Description copied from interface: PersistentCollection
Does the current state exactly match the snapshot?

Specified by:
equalsSnapshot in interface PersistentCollection
Throws:
HibernateException

isSnapshotEmpty

public boolean isSnapshotEmpty(Serializable snapshot)
Description copied from interface: PersistentCollection
Is the snapshot empty?

Specified by:
isSnapshotEmpty in interface PersistentCollection

getSnapshot

public Serializable getSnapshot(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Return a new snapshot of the current state of the collection

Specified by:
getSnapshot in interface PersistentCollection
Throws:
HibernateException

getOrphans

public Collection getOrphans(Serializable snapshot,
                             String entityName)
                      throws HibernateException
Description copied from class: AbstractPersistentCollection
get all "orphaned" elements

Specified by:
getOrphans in interface PersistentCollection
Specified by:
getOrphans in class AbstractPersistentCollection
Throws:
HibernateException

disassemble

public Serializable disassemble(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Disassemble the collection, ready for the cache

Specified by:
disassemble in interface PersistentCollection
Throws:
HibernateException

initializeFromCache

public void initializeFromCache(CollectionPersister persister,
                                Serializable disassembled,
                                Object owner)
                         throws HibernateException
Description copied from interface: PersistentCollection
Read the state of the collection from a disassembled cached value

Specified by:
initializeFromCache in interface PersistentCollection
Throws:
HibernateException

needsRecreate

public boolean needsRecreate(CollectionPersister persister)
Description copied from class: AbstractPersistentCollection
Do we need to completely recreate this collection when it changes?

Specified by:
needsRecreate in interface PersistentCollection
Overrides:
needsRecreate in class AbstractPersistentCollection

getDeletes

public Iterator getDeletes(CollectionPersister persister,
                           boolean indexIsFormula)
                    throws HibernateException
Description copied from interface: PersistentCollection
Get all the elements that need deleting

Specified by:
getDeletes in interface PersistentCollection
Throws:
HibernateException

needsInserting

public boolean needsInserting(Object entry,
                              int i,
                              Type elemType)
                       throws HibernateException
Description copied from interface: PersistentCollection
Do we need to insert this element?

Specified by:
needsInserting in interface PersistentCollection
Throws:
HibernateException

isRowUpdatePossible

public boolean isRowUpdatePossible()
Specified by:
isRowUpdatePossible in interface PersistentCollection
Overrides:
isRowUpdatePossible in class AbstractPersistentCollection

needsUpdating

public boolean needsUpdating(Object entry,
                             int i,
                             Type elemType)
Description copied from interface: PersistentCollection
Do we need to update this element?

Specified by:
needsUpdating in interface PersistentCollection

size

public int size()
Specified by:
size in interface List
See Also:
Collection.size()

isEmpty

public boolean isEmpty()
Specified by:
isEmpty in interface List
See Also:
Collection.isEmpty()

contains

public boolean contains(Object object)
Specified by:
contains in interface List
See Also:
Collection.contains(Object)

iterator

public Iterator iterator()
Specified by:
iterator in interface List
See Also:
Collection.iterator()

toArray

public Object[] toArray()
Specified by:
toArray in interface List
See Also:
Collection.toArray()

toArray

public Object[] toArray(Object[] a)
Specified by:
toArray in interface List
See Also:
Collection.toArray(Object[])

add

public boolean add(Object object)
Specified by:
add in interface List
See Also:
Collection.add(Object)

remove

public boolean remove(Object o)
Specified by:
remove in interface List
See Also:
Collection.remove(Object)

containsAll

public boolean containsAll(Collection c)
Specified by:
containsAll in interface List
See Also:
Collection.containsAll(Collection)

addAll

public boolean addAll(Collection values)
Specified by:
addAll in interface List
See Also:
Collection.addAll(Collection)

removeAll

public boolean removeAll(Collection c)
Specified by:
removeAll in interface List
See Also:
Collection.removeAll(Collection)

retainAll

public boolean retainAll(Collection c)
Specified by:
retainAll in interface List
See Also:
Collection.retainAll(Collection)

clear

public void clear()
Specified by:
clear in interface List
See Also:
Collection.clear()

getIndex

public Object getIndex(Object entry,
                       int i,
                       CollectionPersister persister)
Description copied from interface: PersistentCollection
Get the index of the given collection entry

Specified by:
getIndex in interface PersistentCollection
Parameters:
persister - it was more elegant before we added this...

getElement

public Object getElement(Object entry)
Description copied from interface: PersistentCollection
Get the value of the given collection entry

Specified by:
getElement in interface PersistentCollection

getSnapshotElement

public Object getSnapshotElement(Object entry,
                                 int i)
Description copied from interface: PersistentCollection
Get the snapshot value of the given collection entry

Specified by:
getSnapshotElement in interface PersistentCollection

occurrences

public int occurrences(Object o)

add

public void add(int i,
                Object o)
Specified by:
add in interface List
See Also:
List.add(int, Object)

addAll

public boolean addAll(int i,
                      Collection c)
Specified by:
addAll in interface List
See Also:
List.addAll(int, Collection)

get

public Object get(int i)
Specified by:
get in interface List
See Also:
List.get(int)

indexOf

public int indexOf(Object o)
Specified by:
indexOf in interface List
See Also:
List.indexOf(Object)

lastIndexOf

public int lastIndexOf(Object o)
Specified by:
lastIndexOf in interface List
See Also:
List.lastIndexOf(Object)

listIterator

public ListIterator listIterator()
Specified by:
listIterator in interface List
See Also:
List.listIterator()

listIterator

public ListIterator listIterator(int i)
Specified by:
listIterator in interface List
See Also:
List.listIterator(int)

remove

public Object remove(int i)
Specified by:
remove in interface List
See Also:
List.remove(int)

set

public Object set(int i,
                  Object o)
Specified by:
set in interface List
See Also:
List.set(int, Object)

subList

public List subList(int start,
                    int end)
Specified by:
subList in interface List
See Also:
List.subList(int, int)

toString

public String toString()

entryExists

public boolean entryExists(Object entry,
                           int i)
Description copied from interface: PersistentCollection
Does an element exist at this entry in the collection?

Specified by:
entryExists in interface PersistentCollection

equals

public boolean equals(Object obj)
Bag does not respect the collection API and do an JVM instance comparison to do the equals. The semantic is broken not to have to initialize a collection for a simple equals() operation.

Specified by:
equals in interface List
See Also:
Object.equals(java.lang.Object)

hashCode

public int hashCode()
Specified by:
hashCode in interface List
See Also:
Object.hashCode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentElementHolder (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentElementHolder

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
        extended by org.hibernate.collection.PersistentElementHolder
All Implemented Interfaces:
PersistentCollection, Serializable
public class PersistentElementHolder
extends AbstractPersistentCollection

A persistent wrapper for an XML element

Author:
Gavin King
See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.collection.AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
Field Summary
protected  org.dom4j.Element element
Fields inherited from class org.hibernate.collection.AbstractPersistentCollection
UNKNOWN
Constructor Summary
PersistentElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentElementHolder(SessionImplementor session, org.dom4j.Element element)
Method Summary
void | beforeInitialize(CollectionPersister persister, int anticipatedSize) Called before any elements are read into the collection, allowing appropriate initializations to occur.
Serializable | disassemble(CollectionPersister persister) Disassemble the collection, ready for the cache
boolean | empty() Is the initialized collection empty?
Iterator | entries(CollectionPersister persister) Iterate all collection entries, during update of the database
boolean | entryExists(Object entry, int i) Does an element exist at this entry in the collection?
boolean | equalsSnapshot(CollectionPersister persister) Does the current state exactly match the snapshot?
Iterator | getDeletes(CollectionPersister persister, boolean indexIsFormula) Get all the elements that need deleting
Object | getElement(Object entry) Get the value of the given collection entry
Object | getIndex(Object entry, int i, CollectionPersister persister) Get the index of the given collection entry
Collection | getOrphans(Serializable snapshot, String entityName) get all "orphaned" elements
Serializable | getSnapshot(CollectionPersister persister) Return a new snapshot of the current state of the collection
Object | getSnapshotElement(Object entry, int i) Get the snapshot value of the given collection entry
Object | getValue() return the user-visible collection (or array) instance
void | initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner) Read the state of the collection from a disassembled cached value
boolean | isDirectlyAccessible() Could the application possibly have a direct reference to the underlying collection implementation?
boolean | isSnapshotEmpty(Serializable snapshot) Is the snapshot empty?
boolean | isWrapper(Object collection) Is this the wrapper for the given underlying collection instance?
boolean | needsInserting(Object entry, int i, Type elementType) Do we need to insert this element?
boolean | needsUpdating(Object entry, int i, Type elementType) Do we need to update this element?
Object | readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner) Read a row from the JDBC result set
Methods inherited from class org.hibernate.collection.AbstractPersistentCollection
afterInitialize, afterRowInsert, beginRead, clearDirty, dirty, endRead, forceInitialization, getCachedSize, getIdentifier, getKey, getOrphans, getOwner, getQueuedOrphans, getRole, getSession, getSnapshot, getStoredSnapshot, hasQueuedOperations, initialize, isClearQueueEnabled, isDirty, isOperationQueueEnabled, isPutQueueEnabled, isRowUpdatePossible, isUnreferenced, needsRecreate, performQueuedOperations, postAction, preInsert, queuedAdditionIterator, queueOperation, read, readElementByIndex, readElementExistence, readIndexExistence, readSize, setCurrentSession, setDirectlyAccessible, setInitialized, setOwner, setSnapshot, unsetSession, wasInitialized, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

element

protected org.dom4j.Element element
Constructor Detail

PersistentElementHolder

public PersistentElementHolder(SessionImplementor session,
                               org.dom4j.Element element)

PersistentElementHolder

public PersistentElementHolder(SessionImplementor session,
                               CollectionPersister persister,
                               Serializable key)
                        throws HibernateException
Method Detail

getSnapshot

public Serializable getSnapshot(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Return a new snapshot of the current state of the collection

Throws:
HibernateException

getOrphans

public Collection getOrphans(Serializable snapshot,
                             String entityName)
                      throws HibernateException
Description copied from class: AbstractPersistentCollection
get all "orphaned" elements

Specified by:
getOrphans in interface PersistentCollection
Specified by:
getOrphans in class AbstractPersistentCollection
Throws:
HibernateException

isWrapper

public boolean isWrapper(Object collection)
Description copied from interface: PersistentCollection
Is this the wrapper for the given underlying collection instance?

equalsSnapshot

public boolean equalsSnapshot(CollectionPersister persister)
                       throws HibernateException
Description copied from interface: PersistentCollection
Does the current state exactly match the snapshot?

Throws:
HibernateException

isSnapshotEmpty

public boolean isSnapshotEmpty(Serializable snapshot)
Description copied from interface: PersistentCollection
Is the snapshot empty?

empty

public boolean empty()
Description copied from class: AbstractPersistentCollection
Is the initialized collection empty?

Specified by:
empty in interface PersistentCollection
Specified by:
empty in class AbstractPersistentCollection

readFrom

public Object readFrom(ResultSet rs,
                       CollectionPersister persister,
                       CollectionAliases descriptor,
                       Object owner)
                throws HibernateException,
                       SQLException
Description copied from interface: PersistentCollection
Read a row from the JDBC result set

Throws:
HibernateException
SQLException

entries

public Iterator entries(CollectionPersister persister)
Description copied from interface: PersistentCollection
Iterate all collection entries, during update of the database

beforeInitialize

public void beforeInitialize(CollectionPersister persister,
                             int anticipatedSize)
Description copied from interface: PersistentCollection
Called before any elements are read into the collection, allowing appropriate initializations to occur.

Parameters:
persister - The underlying collection persister.
anticipatedSize - The anticipated size of the collection after initilization is complete.

isDirectlyAccessible

public boolean isDirectlyAccessible()
Description copied from class: AbstractPersistentCollection
Could the application possibly have a direct reference to the underlying collection implementation?

Specified by:
isDirectlyAccessible in interface PersistentCollection
Overrides:
isDirectlyAccessible in class AbstractPersistentCollection

initializeFromCache

public void initializeFromCache(CollectionPersister persister,
                                Serializable disassembled,
                                Object owner)
                         throws HibernateException
Description copied from interface: PersistentCollection
Read the state of the collection from a disassembled cached value

Throws:
HibernateException

disassemble

public Serializable disassemble(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Disassemble the collection, ready for the cache

Throws:
HibernateException

getValue

public Object getValue()
Description copied from class: AbstractPersistentCollection
return the user-visible collection (or array) instance

Specified by:
getValue in interface PersistentCollection
Overrides:
getValue in class AbstractPersistentCollection

getDeletes

public Iterator getDeletes(CollectionPersister persister,
                           boolean indexIsFormula)
                    throws HibernateException
Description copied from interface: PersistentCollection
Get all the elements that need deleting

Throws:
HibernateException

needsInserting

public boolean needsInserting(Object entry,
                              int i,
                              Type elementType)
                       throws HibernateException
Description copied from interface: PersistentCollection
Do we need to insert this element?

Throws:
HibernateException

needsUpdating

public boolean needsUpdating(Object entry,
                             int i,
                             Type elementType)
                      throws HibernateException
Description copied from interface: PersistentCollection
Do we need to update this element?

Throws:
HibernateException

getIndex

public Object getIndex(Object entry,
                       int i,
                       CollectionPersister persister)
Description copied from interface: PersistentCollection
Get the index of the given collection entry

Parameters:
persister - it was more elegant before we added this...

getElement

public Object getElement(Object entry)
Description copied from interface: PersistentCollection
Get the value of the given collection entry

getSnapshotElement

public Object getSnapshotElement(Object entry,
                                 int i)
Description copied from interface: PersistentCollection
Get the snapshot value of the given collection entry

entryExists

public boolean entryExists(Object entry,
                           int i)
Description copied from interface: PersistentCollection
Does an element exist at this entry in the collection?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentIdentifierBag (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentIdentifierBag

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
        extended by org.hibernate.collection.PersistentIdentifierBag
All Implemented Interfaces:
Collection, List, PersistentCollection, Serializable
public class PersistentIdentifierBag
extends AbstractPersistentCollection
implements List

An IdentifierBag implements "bag" semantics more efficiently than a regular Bag by adding a synthetic identifier column to the table. This identifier is unique for all rows in the table, allowing very efficient updates and deletes. The value of the identifier is never exposed to the application.

IdentifierBags may not be used for a many-to-one association. Furthermore, there is no reason to use inverse="true".

Author:
Gavin King
See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.collection.AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
Field Summary
protected Map | identifiers
protected List | values
Fields inherited from class org.hibernate.collection.AbstractPersistentCollection
UNKNOWN
Constructor Summary
PersistentIdentifierBag()
PersistentIdentifierBag(SessionImplementor session)
PersistentIdentifierBag(SessionImplementor session, Collection coll)
Method Summary
void | add(int index, Object element)
boolean | add(Object o)
boolean | addAll(Collection c)
boolean | addAll(int index, Collection c)
void | afterRowInsert(CollectionPersister persister, Object entry, int i) Called after inserting a row, to fetch the natively generated id
void | beforeInitialize(CollectionPersister persister, int anticipatedSize) Called before any elements are read into the collection, allowing appropriate initializations to occur.
void | clear()
boolean | contains(Object o)
boolean | containsAll(Collection c)
Serializable | disassemble(CollectionPersister persister) Disassemble the collection, ready for the cache
boolean | empty() Is the initialized collection empty?
Iterator | entries(CollectionPersister persister) Iterate all collection entries, during update of the database
boolean | entryExists(Object entry, int i) Does an element exist at this entry in the collection?
boolean | equalsSnapshot(CollectionPersister persister) Does the current state exactly match the snapshot?
Object | get(int index)
Iterator | getDeletes(CollectionPersister persister, boolean indexIsFormula) Get all the elements that need deleting
Object | getElement(Object entry) Get the value of the given collection entry
Object | getIdentifier(Object entry, int i) Get the index of the given collection entry
Object | getIndex(Object entry, int i, CollectionPersister persister) Get the index of the given collection entry
Collection | getOrphans(Serializable snapshot, String entityName) get all "orphaned" elements
Serializable | getSnapshot(CollectionPersister persister) Return a new snapshot of the current state of the collection
Object | getSnapshotElement(Object entry, int i) Get the snapshot value of the given collection entry
int | indexOf(Object o)
void | initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner) Read the state of the collection from a disassembled cached value
boolean | isEmpty()
boolean | isSnapshotEmpty(Serializable snapshot) Is the snapshot empty?
boolean | isWrapper(Object collection) Is this the wrapper for the given underlying collection instance?
Iterator | iterator()
int | lastIndexOf(Object o)
ListIterator | listIterator()
ListIterator | listIterator(int index)
boolean | needsInserting(Object entry, int i, Type elemType) Do we need to insert this element?
boolean | needsUpdating(Object entry, int i, Type elemType) Do we need to update this element?
void | preInsert(CollectionPersister persister) Called before inserting rows, to ensure that any surrogate keys are fully generated
Object | readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner) Read a row from the JDBC result set
Object | remove(int index)
boolean | remove(Object o)
boolean | removeAll(Collection c)
boolean | retainAll(Collection c)
Object | set(int index, Object element)
int | size()
List | subList(int fromIndex, int toIndex)
Object[] | toArray()
Object[] | toArray(Object[] a)
Methods inherited from class org.hibernate.collection.AbstractPersistentCollection
afterInitialize, beginRead, clearDirty, dirty, endRead, forceInitialization, getCachedSize, getKey, getOrphans, getOwner, getQueuedOrphans, getRole, getSession, getSnapshot, getStoredSnapshot, getValue, hasQueuedOperations, initialize, isClearQueueEnabled, isDirectlyAccessible, isDirty, isOperationQueueEnabled, isPutQueueEnabled, isRowUpdatePossible, isUnreferenced, needsRecreate, performQueuedOperations, postAction, queuedAdditionIterator, queueOperation, read, readElementByIndex, readElementExistence, readIndexExistence, readSize, setCurrentSession, setDirectlyAccessible, setInitialized, setOwner, setSnapshot, unsetSession, wasInitialized, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.List
equals, hashCode

Field Detail

values

protected List values

identifiers

protected Map identifiers
Constructor Detail

PersistentIdentifierBag

public PersistentIdentifierBag(SessionImplementor session)

PersistentIdentifierBag

public PersistentIdentifierBag()

PersistentIdentifierBag

public PersistentIdentifierBag(SessionImplementor session,
                               Collection coll)
Method Detail

initializeFromCache

public void initializeFromCache(CollectionPersister persister,
                                Serializable disassembled,
                                Object owner)
                         throws HibernateException
Description copied from interface: PersistentCollection
Read the state of the collection from a disassembled cached value

Specified by:
initializeFromCache in interface PersistentCollection
Throws:
HibernateException

getIdentifier

public Object getIdentifier(Object entry,
                            int i)
Description copied from interface: PersistentCollection
Get the index of the given collection entry

Specified by:
getIdentifier in interface PersistentCollection
Overrides:
getIdentifier in class AbstractPersistentCollection

isWrapper

public boolean isWrapper(Object collection)
Description copied from interface: PersistentCollection
Is this the wrapper for the given underlying collection instance?

Specified by:
isWrapper in interface PersistentCollection

add

public boolean add(Object o)
Specified by:
add in interface List

clear

public void clear()
Specified by:
clear in interface List

contains

public boolean contains(Object o)
Specified by:
contains in interface List

containsAll

public boolean containsAll(Collection c)
Specified by:
containsAll in interface List

isEmpty

public boolean isEmpty()
Specified by:
isEmpty in interface List

iterator

public Iterator iterator()
Specified by:
iterator in interface List

remove

public boolean remove(Object o)
Specified by:
remove in interface List

removeAll

public boolean removeAll(Collection c)
Specified by:
removeAll in interface List

retainAll

public boolean retainAll(Collection c)
Specified by:
retainAll in interface List

size

public int size()
Specified by:
size in interface List

toArray

public Object[] toArray()
Specified by:
toArray in interface List

toArray

public Object[] toArray(Object[] a)
Specified by:
toArray in interface List

beforeInitialize

public void beforeInitialize(CollectionPersister persister,
                             int anticipatedSize)
Description copied from interface: PersistentCollection
Called before any elements are read into the collection, allowing appropriate initializations to occur.

Specified by:
beforeInitialize in interface PersistentCollection
Parameters:
persister - The underlying collection persister.
anticipatedSize - The anticipated size of the collection after initilization is complete.

disassemble

public Serializable disassemble(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Disassemble the collection, ready for the cache

Specified by:
disassemble in interface PersistentCollection
Throws:
HibernateException

empty

public boolean empty()
Description copied from class: AbstractPersistentCollection
Is the initialized collection empty?

Specified by:
empty in interface PersistentCollection
Specified by:
empty in class AbstractPersistentCollection

entries

public Iterator entries(CollectionPersister persister)
Description copied from interface: PersistentCollection
Iterate all collection entries, during update of the database

Specified by:
entries in interface PersistentCollection

entryExists

public boolean entryExists(Object entry,
                           int i)
Description copied from interface: PersistentCollection
Does an element exist at this entry in the collection?

Specified by:
entryExists in interface PersistentCollection

equalsSnapshot

public boolean equalsSnapshot(CollectionPersister persister)
                       throws HibernateException
Description copied from interface: PersistentCollection
Does the current state exactly match the snapshot?

Specified by:
equalsSnapshot in interface PersistentCollection
Throws:
HibernateException

isSnapshotEmpty

public boolean isSnapshotEmpty(Serializable snapshot)
Description copied from interface: PersistentCollection
Is the snapshot empty?

Specified by:
isSnapshotEmpty in interface PersistentCollection

getDeletes

public Iterator getDeletes(CollectionPersister persister,
                           boolean indexIsFormula)
                    throws HibernateException
Description copied from interface: PersistentCollection
Get all the elements that need deleting

Specified by:
getDeletes in interface PersistentCollection
Throws:
HibernateException

getIndex

public Object getIndex(Object entry,
                       int i,
                       CollectionPersister persister)
Description copied from interface: PersistentCollection
Get the index of the given collection entry

Specified by:
getIndex in interface PersistentCollection
Parameters:
persister - it was more elegant before we added this...

getElement

public Object getElement(Object entry)
Description copied from interface: PersistentCollection
Get the value of the given collection entry

Specified by:
getElement in interface PersistentCollection

getSnapshotElement

public Object getSnapshotElement(Object entry,
                                 int i)
Description copied from interface: PersistentCollection
Get the snapshot value of the given collection entry

Specified by:
getSnapshotElement in interface PersistentCollection

needsInserting

public boolean needsInserting(Object entry,
                              int i,
                              Type elemType)
                       throws HibernateException
Description copied from interface: PersistentCollection
Do we need to insert this element?

Specified by:
needsInserting in interface PersistentCollection
Throws:
HibernateException

needsUpdating

public boolean needsUpdating(Object entry,
                             int i,
                             Type elemType)
                      throws HibernateException
Description copied from interface: PersistentCollection
Do we need to update this element?

Specified by:
needsUpdating in interface PersistentCollection
Throws:
HibernateException

readFrom

public Object readFrom(ResultSet rs,
                       CollectionPersister persister,
                       CollectionAliases descriptor,
                       Object owner)
                throws HibernateException,
                       SQLException
Description copied from interface: PersistentCollection
Read a row from the JDBC result set

Specified by:
readFrom in interface PersistentCollection
Throws:
HibernateException
SQLException

getSnapshot

public Serializable getSnapshot(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Return a new snapshot of the current state of the collection

Specified by:
getSnapshot in interface PersistentCollection
Throws:
HibernateException

getOrphans

public Collection getOrphans(Serializable snapshot,
                             String entityName)
                      throws HibernateException
Description copied from class: AbstractPersistentCollection
get all "orphaned" elements

Specified by:
getOrphans in interface PersistentCollection
Specified by:
getOrphans in class AbstractPersistentCollection
Throws:
HibernateException

preInsert

public void preInsert(CollectionPersister persister)
               throws HibernateException
Description copied from class: AbstractPersistentCollection
Called before inserting rows, to ensure that any surrogate keys are fully generated

Specified by:
preInsert in interface PersistentCollection
Overrides:
preInsert in class AbstractPersistentCollection
Throws:
HibernateException

add

public void add(int index,
                Object element)
Specified by:
add in interface List

addAll

public boolean addAll(int index,
                      Collection c)
Specified by:
addAll in interface List

get

public Object get(int index)
Specified by:
get in interface List

indexOf

public int indexOf(Object o)
Specified by:
indexOf in interface List

lastIndexOf

public int lastIndexOf(Object o)
Specified by:
lastIndexOf in interface List

listIterator

public ListIterator listIterator()
Specified by:
listIterator in interface List

listIterator

public ListIterator listIterator(int index)
Specified by:
listIterator in interface List

remove

public Object remove(int index)
Specified by:
remove in interface List

set

public Object set(int index,
                  Object element)
Specified by:
set in interface List

subList

public List subList(int fromIndex,
                    int toIndex)
Specified by:
subList in interface List

addAll

public boolean addAll(Collection c)
Specified by:
addAll in interface List

afterRowInsert

public void afterRowInsert(CollectionPersister persister,
                           Object entry,
                           int i)
                    throws HibernateException
Description copied from class: AbstractPersistentCollection
Called after inserting a row, to fetch the natively generated id

Specified by:
afterRowInsert in interface PersistentCollection
Overrides:
afterRowInsert in class AbstractPersistentCollection
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentIndexedElementHolder (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentIndexedElementHolder

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
        extended by org.hibernate.collection.PersistentIndexedElementHolder
All Implemented Interfaces:
PersistentCollection, Serializable
Direct Known Subclasses:
PersistentListElementHolder, PersistentMapElementHolder
public abstract class PersistentIndexedElementHolder
extends AbstractPersistentCollection

A persistent wrapper for an XML element

Author:
Gavin King
See Also:
Serialized Form

Nested Class Summary
static class PersistentIndexedElementHolder.IndexedValue
Nested classes inherited from class org.hibernate.collection.AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
Field Summary
protected  org.dom4j.Element element
Fields inherited from class org.hibernate.collection.AbstractPersistentCollection
UNKNOWN
Constructor Summary
PersistentIndexedElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentIndexedElementHolder(SessionImplementor session, org.dom4j.Element element)
Method Summary
void | beforeInitialize(CollectionPersister persister, int anticipatedSize) Called before any elements are read into the collection, allowing appropriate initializations to occur.
boolean | empty() Is the initialized collection empty?
Iterator | entries(CollectionPersister persister) Iterate all collection entries, during update of the database
boolean | entryExists(Object entry, int i) Does an element exist at this entry in the collection?
boolean | equalsSnapshot(CollectionPersister persister) Does the current state exactly match the snapshot?
Iterator | getDeletes(CollectionPersister persister, boolean indexIsFormula) Get all the elements that need deleting
Object | getElement(Object entry) Get the value of the given collection entry
protected static String | getIndex(org.dom4j.Element element, String indexNodeName, int i)
Object | getIndex(Object entry, int i, CollectionPersister persister) Get the index of the given collection entry
protected static String | getIndexAttributeName(CollectionPersister persister)
Collection | getOrphans(Serializable snapshot, String entityName) get all "orphaned" elements
Serializable | getSnapshot(CollectionPersister persister) Return a new snapshot of the current state of the collection
Object | getSnapshotElement(Object entry, int i) Get the snapshot value of the given collection entry
Object | getValue() return the user-visible collection (or array) instance
boolean | isDirectlyAccessible() Could the application possibly have a direct reference to the underlying collection implementation?
boolean | isSnapshotEmpty(Serializable snapshot) Is the snapshot empty?
boolean | isWrapper(Object collection) Is this the wrapper for the given underlying collection instance?
boolean | needsInserting(Object entry, int i, Type elementType) Do we need to insert this element?
boolean | needsUpdating(Object entry, int i, Type elementType) Do we need to update this element?
Object | readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner) Read a row from the JDBC result set
protected static void | setIndex(org.dom4j.Element element, String indexNodeName, String index)
Methods inherited from class org.hibernate.collection.AbstractPersistentCollection
afterInitialize, afterRowInsert, beginRead, clearDirty, dirty, endRead, forceInitialization, getCachedSize, getIdentifier, getKey, getOrphans, getOwner, getQueuedOrphans, getRole, getSession, getSnapshot, getStoredSnapshot, hasQueuedOperations, initialize, isClearQueueEnabled, isDirty, isOperationQueueEnabled, isPutQueueEnabled, isRowUpdatePossible, isUnreferenced, needsRecreate, performQueuedOperations, postAction, preInsert, queuedAdditionIterator, queueOperation, read, readElementByIndex, readElementExistence, readIndexExistence, readSize, setCurrentSession, setDirectlyAccessible, setInitialized, setOwner, setSnapshot, unsetSession, wasInitialized, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.collection.PersistentCollection
disassemble, initializeFromCache

Field Detail

element

protected org.dom4j.Element element
Constructor Detail

PersistentIndexedElementHolder

public PersistentIndexedElementHolder(SessionImplementor session,
                                      org.dom4j.Element element)

PersistentIndexedElementHolder

public PersistentIndexedElementHolder(SessionImplementor session,
                                      CollectionPersister persister,
                                      Serializable key)
                               throws HibernateException
Method Detail

getIndex

protected static String getIndex(org.dom4j.Element element,
                                 String indexNodeName,
                                 int i)

setIndex

protected static void setIndex(org.dom4j.Element element,
                               String indexNodeName,
                               String index)

getIndexAttributeName

protected static String getIndexAttributeName(CollectionPersister persister)

getSnapshot

public Serializable getSnapshot(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Return a new snapshot of the current state of the collection

Throws:
HibernateException

getOrphans

public Collection getOrphans(Serializable snapshot,
                             String entityName)
                      throws HibernateException
Description copied from class: AbstractPersistentCollection
get all "orphaned" elements

Specified by:
getOrphans in interface PersistentCollection
Specified by:
getOrphans in class AbstractPersistentCollection
Throws:
HibernateException

isWrapper

public boolean isWrapper(Object collection)
Description copied from interface: PersistentCollection
Is this the wrapper for the given underlying collection instance?

equalsSnapshot

public boolean equalsSnapshot(CollectionPersister persister)
                       throws HibernateException
Description copied from interface: PersistentCollection
Does the current state exactly match the snapshot?

Throws:
HibernateException

isSnapshotEmpty

public boolean isSnapshotEmpty(Serializable snapshot)
Description copied from interface: PersistentCollection
Is the snapshot empty?

empty

public boolean empty()
Description copied from class: AbstractPersistentCollection
Is the initialized collection empty?

Specified by:
empty in interface PersistentCollection
Specified by:
empty in class AbstractPersistentCollection

readFrom

public Object readFrom(ResultSet rs,
                       CollectionPersister persister,
                       CollectionAliases descriptor,
                       Object owner)
                throws HibernateException,
                       SQLException
Description copied from interface: PersistentCollection
Read a row from the JDBC result set

Throws:
HibernateException
SQLException

entries

public Iterator entries(CollectionPersister persister)
Description copied from interface: PersistentCollection
Iterate all collection entries, during update of the database

beforeInitialize

public void beforeInitialize(CollectionPersister persister,
                             int anticipatedSize)
Description copied from interface: PersistentCollection
Called before any elements are read into the collection, allowing appropriate initializations to occur.

Parameters:
persister - The underlying collection persister.
anticipatedSize - The anticipated size of the collection after initilization is complete.

isDirectlyAccessible

public boolean isDirectlyAccessible()
Description copied from class: AbstractPersistentCollection
Could the application possibly have a direct reference to the underlying collection implementation?

Specified by:
isDirectlyAccessible in interface PersistentCollection
Overrides:
isDirectlyAccessible in class AbstractPersistentCollection

getValue

public Object getValue()
Description copied from class: AbstractPersistentCollection
return the user-visible collection (or array) instance

Specified by:
getValue in interface PersistentCollection
Overrides:
getValue in class AbstractPersistentCollection

getDeletes

public Iterator getDeletes(CollectionPersister persister,
                           boolean indexIsFormula)
                    throws HibernateException
Description copied from interface: PersistentCollection
Get all the elements that need deleting

Throws:
HibernateException

needsInserting

public boolean needsInserting(Object entry,
                              int i,
                              Type elementType)
                       throws HibernateException
Description copied from interface: PersistentCollection
Do we need to insert this element?

Throws:
HibernateException

needsUpdating

public boolean needsUpdating(Object entry,
                             int i,
                             Type elementType)
                      throws HibernateException
Description copied from interface: PersistentCollection
Do we need to update this element?

Throws:
HibernateException

getIndex

public Object getIndex(Object entry,
                       int i,
                       CollectionPersister persister)
Description copied from interface: PersistentCollection
Get the index of the given collection entry

Parameters:
persister - it was more elegant before we added this...

getElement

public Object getElement(Object entry)
Description copied from interface: PersistentCollection
Get the value of the given collection entry

getSnapshotElement

public Object getSnapshotElement(Object entry,
                                 int i)
Description copied from interface: PersistentCollection
Get the snapshot value of the given collection entry

entryExists

public boolean entryExists(Object entry,
                           int i)
Description copied from interface: PersistentCollection
Does an element exist at this entry in the collection?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentIndexedElementHolder.IndexedValue (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentIndexedElementHolder.IndexedValue

java.lang.Object
    extended by org.hibernate.collection.PersistentIndexedElementHolder.IndexedValue
Enclosing class:
PersistentIndexedElementHolder
public static final class PersistentIndexedElementHolder.IndexedValue
extends Object

Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentList (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentList

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
        extended by org.hibernate.collection.PersistentList
All Implemented Interfaces:
Collection, List, PersistentCollection, Serializable
public class PersistentList
extends AbstractPersistentCollection
implements List

A persistent wrapper for a java.util.List. Underlying collection is an ArrayList.

Author:
Gavin King
See Also:
ArrayList, Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.collection.AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
Field Summary
protected  List list
Fields inherited from class org.hibernate.collection.AbstractPersistentCollection
UNKNOWN
Constructor Summary
PersistentList()
PersistentList(SessionImplementor session)
PersistentList(SessionImplementor session, List list)
Method Summary
void | add(int index, Object value)
boolean | add(Object object)
boolean | addAll(Collection values)
boolean | addAll(int index, Collection coll)
void | beforeInitialize(CollectionPersister persister, int anticipatedSize) Called before any elements are read into the collection, allowing appropriate initializations to occur.
void | clear()
boolean | contains(Object object)
boolean | containsAll(Collection coll)
Serializable | disassemble(CollectionPersister persister) Disassemble the collection, ready for the cache
boolean | empty() Is the initialized collection empty?
Iterator | entries(CollectionPersister persister) Iterate all collection entries, during update of the database
boolean | entryExists(Object entry, int i) Does an element exist at this entry in the collection?
boolean | equals(Object other)
boolean | equalsSnapshot(CollectionPersister persister) Does the current state exactly match the snapshot?
Object | get(int index)
Iterator | getDeletes(CollectionPersister persister, boolean indexIsFormula) Get all the elements that need deleting
Object | getElement(Object entry) Get the value of the given collection entry
Object | getIndex(Object entry, int i, CollectionPersister persister) Get the index of the given collection entry
Collection | getOrphans(Serializable snapshot, String entityName) get all "orphaned" elements
Serializable | getSnapshot(CollectionPersister persister) Return a new snapshot of the current state of the collection
Object | getSnapshotElement(Object entry, int i) Get the snapshot value of the given collection entry
int | hashCode()
int | indexOf(Object value)
void | initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner) Read the state of the collection from a disassembled cached value
boolean | isEmpty()
boolean | isSnapshotEmpty(Serializable snapshot) Is the snapshot empty?
boolean | isWrapper(Object collection) Is this the wrapper for the given underlying collection instance?
Iterator | iterator()
int | lastIndexOf(Object value)
ListIterator | listIterator()
ListIterator | listIterator(int index)
boolean | needsInserting(Object entry, int i, Type elemType) Do we need to insert this element?
boolean | needsUpdating(Object entry, int i, Type elemType) Do we need to update this element?
Object | readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner) Read a row from the JDBC result set
Object | remove(int index)
boolean | remove(Object value)
boolean | removeAll(Collection coll)
boolean | retainAll(Collection coll)
Object | set(int index, Object value)
int | size()
List | subList(int from, int to)
Object[] | toArray()
Object[] | toArray(Object[] array)
String | toString()
Methods inherited from class org.hibernate.collection.AbstractPersistentCollection
afterInitialize, afterRowInsert, beginRead, clearDirty, dirty, endRead, forceInitialization, getCachedSize, getIdentifier, getKey, getOrphans, getOwner, getQueuedOrphans, getRole, getSession, getSnapshot, getStoredSnapshot, getValue, hasQueuedOperations, initialize, isClearQueueEnabled, isDirectlyAccessible, isDirty, isOperationQueueEnabled, isPutQueueEnabled, isRowUpdatePossible, isUnreferenced, needsRecreate, performQueuedOperations, postAction, preInsert, queuedAdditionIterator, queueOperation, read, readElementByIndex, readElementExistence, readIndexExistence, readSize, setCurrentSession, setDirectlyAccessible, setInitialized, setOwner, setSnapshot, unsetSession, wasInitialized, write
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

list

protected List list
Constructor Detail

PersistentList

public PersistentList(SessionImplementor session)

PersistentList

public PersistentList(SessionImplementor session,
                      List list)

PersistentList

public PersistentList()
Method Detail

getSnapshot

public Serializable getSnapshot(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Return a new snapshot of the current state of the collection

Specified by:
getSnapshot in interface PersistentCollection
Throws:
HibernateException

getOrphans

public Collection getOrphans(Serializable snapshot,
                             String entityName)
                      throws HibernateException
Description copied from class: AbstractPersistentCollection
get all "orphaned" elements

Specified by:
getOrphans in interface PersistentCollection
Specified by:
getOrphans in class AbstractPersistentCollection
Throws:
HibernateException

equalsSnapshot

public boolean equalsSnapshot(CollectionPersister persister)
                       throws HibernateException
Description copied from interface: PersistentCollection
Does the current state exactly match the snapshot?

Specified by:
equalsSnapshot in interface PersistentCollection
Throws:
HibernateException

isSnapshotEmpty

public boolean isSnapshotEmpty(Serializable snapshot)
Description copied from interface: PersistentCollection
Is the snapshot empty?

Specified by:
isSnapshotEmpty in interface PersistentCollection

beforeInitialize

public void beforeInitialize(CollectionPersister persister,
                             int anticipatedSize)
Description copied from interface: PersistentCollection
Called before any elements are read into the collection, allowing appropriate initializations to occur.

Specified by:
beforeInitialize in interface PersistentCollection
Parameters:
persister - The underlying collection persister.
anticipatedSize - The anticipated size of the collection after initilization is complete.

isWrapper

public boolean isWrapper(Object collection)
Description copied from interface: PersistentCollection
Is this the wrapper for the given underlying collection instance?

Specified by:
isWrapper in interface PersistentCollection

size

public int size()
Specified by:
size in interface List
See Also:
List.size()

isEmpty

public boolean isEmpty()
Specified by:
isEmpty in interface List
See Also:
List.isEmpty()

contains

public boolean contains(Object object)
Specified by:
contains in interface List
See Also:
List.contains(Object)

iterator

public Iterator iterator()
Specified by:
iterator in interface List
See Also:
List.iterator()

toArray

public Object[] toArray()
Specified by:
toArray in interface List
See Also:
List.toArray()

toArray

public Object[] toArray(Object[] array)
Specified by:
toArray in interface List
See Also:
List.toArray(Object[])

add

public boolean add(Object object)
Specified by:
add in interface List
See Also:
List.add(Object)

remove

public boolean remove(Object value)
Specified by:
remove in interface List
See Also:
List.remove(Object)

containsAll

public boolean containsAll(Collection coll)
Specified by:
containsAll in interface List
See Also:
List.containsAll(Collection)

addAll

public boolean addAll(Collection values)
Specified by:
addAll in interface List
See Also:
List.addAll(Collection)

addAll

public boolean addAll(int index,
                      Collection coll)
Specified by:
addAll in interface List
See Also:
List.addAll(int, Collection)

removeAll

public boolean removeAll(Collection coll)
Specified by:
removeAll in interface List
See Also:
List.removeAll(Collection)

retainAll

public boolean retainAll(Collection coll)
Specified by:
retainAll in interface List
See Also:
List.retainAll(Collection)

clear

public void clear()
Specified by:
clear in interface List
See Also:
List.clear()

get

public Object get(int index)
Specified by:
get in interface List
See Also:
List.get(int)

set

public Object set(int index,
                  Object value)
Specified by:
set in interface List
See Also:
List.set(int, Object)

add

public void add(int index,
                Object value)
Specified by:
add in interface List
See Also:
List.add(int, Object)

remove

public Object remove(int index)
Specified by:
remove in interface List
See Also:
List.remove(int)

indexOf

public int indexOf(Object value)
Specified by:
indexOf in interface List
See Also:
List.indexOf(Object)

lastIndexOf

public int lastIndexOf(Object value)
Specified by:
lastIndexOf in interface List
See Also:
List.lastIndexOf(Object)

listIterator

public ListIterator listIterator()
Specified by:
listIterator in interface List
See Also:
List.listIterator()

listIterator

public ListIterator listIterator(int index)
Specified by:
listIterator in interface List
See Also:
List.listIterator(int)

subList

public List subList(int from,
                    int to)
Specified by:
subList in interface List
See Also:
List.subList(int, int)

empty

public boolean empty()
Description copied from class: AbstractPersistentCollection
Is the initialized collection empty?

Specified by:
empty in interface PersistentCollection
Specified by:
empty in class AbstractPersistentCollection

toString

public String toString()

readFrom

public Object readFrom(ResultSet rs,
                       CollectionPersister persister,
                       CollectionAliases descriptor,
                       Object owner)
                throws HibernateException,
                       SQLException
Description copied from interface: PersistentCollection
Read a row from the JDBC result set

Specified by:
readFrom in interface PersistentCollection
Throws:
HibernateException
SQLException

entries

public Iterator entries(CollectionPersister persister)
Description copied from interface: PersistentCollection
Iterate all collection entries, during update of the database

Specified by:
entries in interface PersistentCollection

initializeFromCache

public void initializeFromCache(CollectionPersister persister,
                                Serializable disassembled,
                                Object owner)
                         throws HibernateException
Description copied from interface: PersistentCollection
Read the state of the collection from a disassembled cached value

Specified by:
initializeFromCache in interface PersistentCollection
Throws:
HibernateException

disassemble

public Serializable disassemble(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Disassemble the collection, ready for the cache

Specified by:
disassemble in interface PersistentCollection
Throws:
HibernateException

getDeletes

public Iterator getDeletes(CollectionPersister persister,
                           boolean indexIsFormula)
                    throws HibernateException
Description copied from interface: PersistentCollection
Get all the elements that need deleting

Specified by:
getDeletes in interface PersistentCollection
Throws:
HibernateException

needsInserting

public boolean needsInserting(Object entry,
                              int i,
                              Type elemType)
                       throws HibernateException
Description copied from interface: PersistentCollection
Do we need to insert this element?

Specified by:
needsInserting in interface PersistentCollection
Throws:
HibernateException

needsUpdating

public boolean needsUpdating(Object entry,
                             int i,
                             Type elemType)
                      throws HibernateException
Description copied from interface: PersistentCollection
Do we need to update this element?

Specified by:
needsUpdating in interface PersistentCollection
Throws:
HibernateException

getIndex

public Object getIndex(Object entry,
                       int i,
                       CollectionPersister persister)
Description copied from interface: PersistentCollection
Get the index of the given collection entry

Specified by:
getIndex in interface PersistentCollection
Parameters:
persister - it was more elegant before we added this...

getElement

public Object getElement(Object entry)
Description copied from interface: PersistentCollection
Get the value of the given collection entry

Specified by:
getElement in interface PersistentCollection

getSnapshotElement

public Object getSnapshotElement(Object entry,
                                 int i)
Description copied from interface: PersistentCollection
Get the snapshot value of the given collection entry

Specified by:
getSnapshotElement in interface PersistentCollection

equals

public boolean equals(Object other)
Specified by:
equals in interface List

hashCode

public int hashCode()
Specified by:
hashCode in interface List

entryExists

public boolean entryExists(Object entry,
                           int i)
Description copied from interface: PersistentCollection
Does an element exist at this entry in the collection?

Specified by:
entryExists in interface PersistentCollection
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentListElementHolder (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentListElementHolder

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
        extended by org.hibernate.collection.PersistentIndexedElementHolder
            extended by org.hibernate.collection.PersistentListElementHolder
All Implemented Interfaces:
PersistentCollection, Serializable
public class PersistentListElementHolder
extends PersistentIndexedElementHolder

Author:
Gavin King
See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.collection.PersistentIndexedElementHolder
PersistentIndexedElementHolder.IndexedValue
Nested classes inherited from class org.hibernate.collection.AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
Field Summary
Fields inherited from class org.hibernate.collection.PersistentIndexedElementHolder
element
Fields inherited from class org.hibernate.collection.AbstractPersistentCollection
UNKNOWN
Constructor Summary
PersistentListElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentListElementHolder(SessionImplementor session, org.dom4j.Element element)
Method Summary
Serializable | disassemble(CollectionPersister persister) Disassemble the collection, ready for the cache
void | initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner) Read the state of the collection from a disassembled cached value
Methods inherited from class org.hibernate.collection.PersistentIndexedElementHolder
beforeInitialize, empty, entries, entryExists, equalsSnapshot, getDeletes, getElement, getIndex, getIndex, getIndexAttributeName, getOrphans, getSnapshot, getSnapshotElement, getValue, isDirectlyAccessible, isSnapshotEmpty, isWrapper, needsInserting, needsUpdating, readFrom, setIndex
Methods inherited from class org.hibernate.collection.AbstractPersistentCollection
afterInitialize, afterRowInsert, beginRead, clearDirty, dirty, endRead, forceInitialization, getCachedSize, getIdentifier, getKey, getOrphans, getOwner, getQueuedOrphans, getRole, getSession, getSnapshot, getStoredSnapshot, hasQueuedOperations, initialize, isClearQueueEnabled, isDirty, isOperationQueueEnabled, isPutQueueEnabled, isRowUpdatePossible, isUnreferenced, needsRecreate, performQueuedOperations, postAction, preInsert, queuedAdditionIterator, queueOperation, read, readElementByIndex, readElementExistence, readIndexExistence, readSize, setCurrentSession, setDirectlyAccessible, setInitialized, setOwner, setSnapshot, unsetSession, wasInitialized, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PersistentListElementHolder

public PersistentListElementHolder(SessionImplementor session,
                                   org.dom4j.Element element)

PersistentListElementHolder

public PersistentListElementHolder(SessionImplementor session,
                                   CollectionPersister persister,
                                   Serializable key)
                            throws HibernateException
Method Detail

initializeFromCache

public void initializeFromCache(CollectionPersister persister,
                                Serializable disassembled,
                                Object owner)
                         throws HibernateException
Description copied from interface: PersistentCollection
Read the state of the collection from a disassembled cached value

Throws:
HibernateException

disassemble

public Serializable disassemble(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Disassemble the collection, ready for the cache

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentMap (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentMap

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
        extended by org.hibernate.collection.PersistentMap
All Implemented Interfaces:
Map, PersistentCollection, Serializable
Direct Known Subclasses:
PersistentSortedMap
public class PersistentMap
extends AbstractPersistentCollection
implements Map

A persistent wrapper for a java.util.Map. Underlying collection is a HashMap.

Author:
Gavin King
See Also:
HashMap, Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.collection.AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
Nested classes inherited from class java.util.Map
Map.Entry
Field Summary
protected  Map map
Fields inherited from class org.hibernate.collection.AbstractPersistentCollection
UNKNOWN
Constructor Summary
PersistentMap()
Empty constructor.
PersistentMap(SessionImplementor session)
Instantiates a lazy map (the underlying map is un-initialized).
PersistentMap(SessionImplementor session, Map map)
Instantiates a non-lazy map (the underlying map is constructed from the incoming map reference).
Method Summary
void | beforeInitialize(CollectionPersister persister, int anticipatedSize) Called before any elements are read into the collection, allowing appropriate initializations to occur.
void | clear()
boolean | containsKey(Object key)
boolean | containsValue(Object value)
Serializable | disassemble(CollectionPersister persister) Disassemble the collection, ready for the cache
boolean | empty() Is the initialized collection empty?
Iterator | entries(CollectionPersister persister) Iterate all collection entries, during update of the database
boolean | entryExists(Object entry, int i) Does an element exist at this entry in the collection?
Set | entrySet()
boolean | equals(Object other)
boolean | equalsSnapshot(CollectionPersister persister) Does the current state exactly match the snapshot?
Object | get(Object key)
Iterator | getDeletes(CollectionPersister persister, boolean indexIsFormula) Get all the elements that need deleting
Object | getElement(Object entry) Get the value of the given collection entry
Object | getIndex(Object entry, int i, CollectionPersister persister) Get the index of the given collection entry
Collection | getOrphans(Serializable snapshot, String entityName) get all "orphaned" elements
Serializable | getSnapshot(CollectionPersister persister) Return a new snapshot of the current state of the collection
Object | getSnapshotElement(Object entry, int i) Get the snapshot value of the given collection entry
int | hashCode()
void | initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner) Read the state of the collection from a disassembled cached value
boolean | isEmpty()
boolean | isSnapshotEmpty(Serializable snapshot) Is the snapshot empty?
boolean | isWrapper(Object collection) Is this the wrapper for the given underlying collection instance?
Set | keySet()
boolean | needsInserting(Object entry, int i, Type elemType) Do we need to insert this element?
boolean | needsUpdating(Object entry, int i, Type elemType) Do we need to update this element?
Object | put(Object key, Object value)
void | putAll(Map puts)
Object | readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner) Read a row from the JDBC result set
Object | remove(Object key)
int | size()
String | toString()
Collection | values()
Methods inherited from class org.hibernate.collection.AbstractPersistentCollection
afterInitialize, afterRowInsert, beginRead, clearDirty, dirty, endRead, forceInitialization, getCachedSize, getIdentifier, getKey, getOrphans, getOwner, getQueuedOrphans, getRole, getSession, getSnapshot, getStoredSnapshot, getValue, hasQueuedOperations, initialize, isClearQueueEnabled, isDirectlyAccessible, isDirty, isOperationQueueEnabled, isPutQueueEnabled, isRowUpdatePossible, isUnreferenced, needsRecreate, performQueuedOperations, postAction, preInsert, queuedAdditionIterator, queueOperation, read, readElementByIndex, readElementExistence, readIndexExistence, readSize, setCurrentSession, setDirectlyAccessible, setInitialized, setOwner, setSnapshot, unsetSession, wasInitialized, write
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

map

protected Map map
Constructor Detail

PersistentMap

public PersistentMap()
Empty constructor.

Note: this form is not ever ever ever used by Hibernate; it is, however, needed for SOAP libraries and other such marshalling code.

PersistentMap

public PersistentMap(SessionImplementor session)
Instantiates a lazy map (the underlying map is un-initialized).

Parameters:
session - The session to which this map will belong.

PersistentMap

public PersistentMap(SessionImplementor session,
                     Map map)
Instantiates a non-lazy map (the underlying map is constructed from the incoming map reference).

Parameters:
session - The session to which this map will belong.
map - The underlying map data.
Method Detail

getSnapshot

public Serializable getSnapshot(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Return a new snapshot of the current state of the collection

Specified by:
getSnapshot in interface PersistentCollection
Throws:
HibernateException

getOrphans

public Collection getOrphans(Serializable snapshot,
                             String entityName)
                      throws HibernateException
Description copied from class: AbstractPersistentCollection
get all "orphaned" elements

Specified by:
getOrphans in interface PersistentCollection
Specified by:
getOrphans in class AbstractPersistentCollection
Throws:
HibernateException

equalsSnapshot

public boolean equalsSnapshot(CollectionPersister persister)
                       throws HibernateException
Description copied from interface: PersistentCollection
Does the current state exactly match the snapshot?

Specified by:
equalsSnapshot in interface PersistentCollection
Throws:
HibernateException

isSnapshotEmpty

public boolean isSnapshotEmpty(Serializable snapshot)
Description copied from interface: PersistentCollection
Is the snapshot empty?

Specified by:
isSnapshotEmpty in interface PersistentCollection

isWrapper

public boolean isWrapper(Object collection)
Description copied from interface: PersistentCollection
Is this the wrapper for the given underlying collection instance?

Specified by:
isWrapper in interface PersistentCollection

beforeInitialize

public void beforeInitialize(CollectionPersister persister,
                             int anticipatedSize)
Description copied from interface: PersistentCollection
Called before any elements are read into the collection, allowing appropriate initializations to occur.

Specified by:
beforeInitialize in interface PersistentCollection
Parameters:
persister - The underlying collection persister.
anticipatedSize - The anticipated size of the collection after initilization is complete.

size

public int size()
Specified by:
size in interface Map
See Also:
Map.size()

isEmpty

public boolean isEmpty()
Specified by:
isEmpty in interface Map
See Also:
Map.isEmpty()

containsKey

public boolean containsKey(Object key)
Specified by:
containsKey in interface Map
See Also:
Map.containsKey(Object)

containsValue

public boolean containsValue(Object value)
Specified by:
containsValue in interface Map
See Also:
Map.containsValue(Object)

get

public Object get(Object key)
Specified by:
get in interface Map
See Also:
Map.get(Object)

put

public Object put(Object key,
                  Object value)
Specified by:
put in interface Map
See Also:
Map.put(Object, Object)

remove

public Object remove(Object key)
Specified by:
remove in interface Map
See Also:
Map.remove(Object)

putAll

public void putAll(Map puts)
Specified by:
putAll in interface Map
See Also:
Map.putAll(java.util.Map puts)

clear

public void clear()
Specified by:
clear in interface Map
See Also:
Map.clear()

keySet

public Set keySet()
Specified by:
keySet in interface Map
See Also:
Map.keySet()

values

public Collection values()
Specified by:
values in interface Map
See Also:
Map.values()

entrySet

public Set entrySet()
Specified by:
entrySet in interface Map
See Also:
Map.entrySet()

empty

public boolean empty()
Description copied from class: AbstractPersistentCollection
Is the initialized collection empty?

Specified by:
empty in interface PersistentCollection
Specified by:
empty in class AbstractPersistentCollection

toString

public String toString()

readFrom

public Object readFrom(ResultSet rs,
                       CollectionPersister persister,
                       CollectionAliases descriptor,
                       Object owner)
                throws HibernateException,
                       SQLException
Description copied from interface: PersistentCollection
Read a row from the JDBC result set

Specified by:
readFrom in interface PersistentCollection
Throws:
HibernateException
SQLException

entries

public Iterator entries(CollectionPersister persister)
Description copied from interface: PersistentCollection
Iterate all collection entries, during update of the database

Specified by:
entries in interface PersistentCollection

initializeFromCache

public void initializeFromCache(CollectionPersister persister,
                                Serializable disassembled,
                                Object owner)
                         throws HibernateException
Description copied from interface: PersistentCollection
Read the state of the collection from a disassembled cached value

Specified by:
initializeFromCache in interface PersistentCollection
Throws:
HibernateException

disassemble

public Serializable disassemble(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Disassemble the collection, ready for the cache

Specified by:
disassemble in interface PersistentCollection
Throws:
HibernateException

getDeletes

public Iterator getDeletes(CollectionPersister persister,
                           boolean indexIsFormula)
                    throws HibernateException
Description copied from interface: PersistentCollection
Get all the elements that need deleting

Specified by:
getDeletes in interface PersistentCollection
Throws:
HibernateException

needsInserting

public boolean needsInserting(Object entry,
                              int i,
                              Type elemType)
                       throws HibernateException
Description copied from interface: PersistentCollection
Do we need to insert this element?

Specified by:
needsInserting in interface PersistentCollection
Throws:
HibernateException

needsUpdating

public boolean needsUpdating(Object entry,
                             int i,
                             Type elemType)
                      throws HibernateException
Description copied from interface: PersistentCollection
Do we need to update this element?

Specified by:
needsUpdating in interface PersistentCollection
Throws:
HibernateException

getIndex

public Object getIndex(Object entry,
                       int i,
                       CollectionPersister persister)
Description copied from interface: PersistentCollection
Get the index of the given collection entry

Specified by:
getIndex in interface PersistentCollection
Parameters:
persister - it was more elegant before we added this...

getElement

public Object getElement(Object entry)
Description copied from interface: PersistentCollection
Get the value of the given collection entry

Specified by:
getElement in interface PersistentCollection

getSnapshotElement

public Object getSnapshotElement(Object entry,
                                 int i)
Description copied from interface: PersistentCollection
Get the snapshot value of the given collection entry

Specified by:
getSnapshotElement in interface PersistentCollection

equals

public boolean equals(Object other)
Specified by:
equals in interface Map

hashCode

public int hashCode()
Specified by:
hashCode in interface Map

entryExists

public boolean entryExists(Object entry,
                           int i)
Description copied from interface: PersistentCollection
Does an element exist at this entry in the collection?

Specified by:
entryExists in interface PersistentCollection
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentMapElementHolder (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentMapElementHolder

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
        extended by org.hibernate.collection.PersistentIndexedElementHolder
            extended by org.hibernate.collection.PersistentMapElementHolder
All Implemented Interfaces:
PersistentCollection, Serializable
public class PersistentMapElementHolder
extends PersistentIndexedElementHolder

Author:
Gavin King
See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.collection.PersistentIndexedElementHolder
PersistentIndexedElementHolder.IndexedValue
Nested classes inherited from class org.hibernate.collection.AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
Field Summary
Fields inherited from class org.hibernate.collection.PersistentIndexedElementHolder
element
Fields inherited from class org.hibernate.collection.AbstractPersistentCollection
UNKNOWN
Constructor Summary
PersistentMapElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentMapElementHolder(SessionImplementor session, org.dom4j.Element element)
Method Summary
Serializable | disassemble(CollectionPersister persister) Disassemble the collection, ready for the cache
void | initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner) Read the state of the collection from a disassembled cached value
Methods inherited from class org.hibernate.collection.PersistentIndexedElementHolder
beforeInitialize, empty, entries, entryExists, equalsSnapshot, getDeletes, getElement, getIndex, getIndex, getIndexAttributeName, getOrphans, getSnapshot, getSnapshotElement, getValue, isDirectlyAccessible, isSnapshotEmpty, isWrapper, needsInserting, needsUpdating, readFrom, setIndex
Methods inherited from class org.hibernate.collection.AbstractPersistentCollection
afterInitialize, afterRowInsert, beginRead, clearDirty, dirty, endRead, forceInitialization, getCachedSize, getIdentifier, getKey, getOrphans, getOwner, getQueuedOrphans, getRole, getSession, getSnapshot, getStoredSnapshot, hasQueuedOperations, initialize, isClearQueueEnabled, isDirty, isOperationQueueEnabled, isPutQueueEnabled, isRowUpdatePossible, isUnreferenced, needsRecreate, performQueuedOperations, postAction, preInsert, queuedAdditionIterator, queueOperation, read, readElementByIndex, readElementExistence, readIndexExistence, readSize, setCurrentSession, setDirectlyAccessible, setInitialized, setOwner, setSnapshot, unsetSession, wasInitialized, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PersistentMapElementHolder

public PersistentMapElementHolder(SessionImplementor session,
                                  org.dom4j.Element element)

PersistentMapElementHolder

public PersistentMapElementHolder(SessionImplementor session,
                                  CollectionPersister persister,
                                  Serializable key)
                           throws HibernateException
Method Detail

initializeFromCache

public void initializeFromCache(CollectionPersister persister,
                                Serializable disassembled,
                                Object owner)
                         throws HibernateException
Description copied from interface: PersistentCollection
Read the state of the collection from a disassembled cached value

Throws:
HibernateException

disassemble

public Serializable disassemble(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Disassemble the collection, ready for the cache

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentSet (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentSet

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
        extended by org.hibernate.collection.PersistentSet
All Implemented Interfaces:
Collection, PersistentCollection, Serializable, Set
Direct Known Subclasses:
PersistentSortedSet
public class PersistentSet
extends AbstractPersistentCollection
implements Set

A persistent wrapper for a java.util.Set. The underlying collection is a HashSet.

Author:
Gavin King
See Also:
HashSet, Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.collection.AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
Field Summary
protected Set | set
protected List | tempList
Fields inherited from class org.hibernate.collection.AbstractPersistentCollection
UNKNOWN
Constructor Summary
PersistentSet()
Empty constructor.
PersistentSet(SessionImplementor session)
Constructor matching super.
PersistentSet(SessionImplementor session, Set set)
Instantiates a non-lazy set (the underlying set is constructed from the incoming set reference).
Method Summary
boolean | add(Object value)
boolean | addAll(Collection coll)
void | beforeInitialize(CollectionPersister persister, int anticipatedSize) Called before any elements are read into the collection, allowing appropriate initializations to occur.
void | beginRead() Called just before reading any rows from the JDBC result set
void | clear()
boolean | contains(Object object)
boolean | containsAll(Collection coll)
Serializable | disassemble(CollectionPersister persister) Disassemble the collection, ready for the cache
boolean | empty() Is the initialized collection empty?
boolean | endRead() Called after reading all rows from the JDBC result set
Iterator | entries(CollectionPersister persister) Iterate all collection entries, during update of the database
boolean | entryExists(Object key, int i) Does an element exist at this entry in the collection?
boolean | equals(Object other)
boolean | equalsSnapshot(CollectionPersister persister) Does the current state exactly match the snapshot?
Iterator | getDeletes(CollectionPersister persister, boolean indexIsFormula) Get all the elements that need deleting
Object | getElement(Object entry) Get the value of the given collection entry
Object | getIndex(Object entry, int i, CollectionPersister persister) Get the index of the given collection entry
Collection | getOrphans(Serializable snapshot, String entityName) get all "orphaned" elements
Serializable | getSnapshot(CollectionPersister persister) Return a new snapshot of the current state of the collection
Object | getSnapshotElement(Object entry, int i) Get the snapshot value of the given collection entry
int | hashCode()
void | initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner) Read the state of the collection from a disassembled cached value
boolean | isEmpty()
boolean | isRowUpdatePossible()
boolean | isSnapshotEmpty(Serializable snapshot) Is the snapshot empty?
boolean | isWrapper(Object collection) Is this the wrapper for the given underlying collection instance?
Iterator | iterator()
boolean | needsInserting(Object entry, int i, Type elemType) Do we need to insert this element?
boolean | needsUpdating(Object entry, int i, Type elemType) Do we need to update this element?
Object | readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner) Read a row from the JDBC result set
boolean | remove(Object value)
boolean | removeAll(Collection coll)
boolean | retainAll(Collection coll)
int | size()
Object[] | toArray()
Object[] | toArray(Object[] array)
String | toString()
Methods inherited from class org.hibernate.collection.AbstractPersistentCollection
afterInitialize, afterRowInsert, clearDirty, dirty, forceInitialization, getCachedSize, getIdentifier, getKey, getOrphans, getOwner, getQueuedOrphans, getRole, getSession, getSnapshot, getStoredSnapshot, getValue, hasQueuedOperations, initialize, isClearQueueEnabled, isDirectlyAccessible, isDirty, isOperationQueueEnabled, isPutQueueEnabled, isUnreferenced, needsRecreate, performQueuedOperations, postAction, preInsert, queuedAdditionIterator, queueOperation, read, readElementByIndex, readElementExistence, readIndexExistence, readSize, setCurrentSession, setDirectlyAccessible, setInitialized, setOwner, setSnapshot, unsetSession, wasInitialized, write
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

set

protected Set set

tempList

protected transient List tempList
Constructor Detail

PersistentSet

public PersistentSet()
Empty constructor.

Note: this form is not ever ever ever used by Hibernate; it is, however, needed for SOAP libraries and other such marshalling code.

PersistentSet

public PersistentSet(SessionImplementor session)
Constructor matching super. Instantiates a lazy set (the underlying set is un-initialized).

Parameters:
session - The session to which this set will belong.

PersistentSet

public PersistentSet(SessionImplementor session,
                     Set set)
Instantiates a non-lazy set (the underlying set is constructed from the incoming set reference).

Parameters:
session - The session to which this set will belong.
set - The underlying set data.
Method Detail

getSnapshot

public Serializable getSnapshot(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Return a new snapshot of the current state of the collection

Specified by:
getSnapshot in interface PersistentCollection
Throws:
HibernateException

getOrphans

public Collection getOrphans(Serializable snapshot,
                             String entityName)
                      throws HibernateException
Description copied from class: AbstractPersistentCollection
get all "orphaned" elements

Specified by:
getOrphans in interface PersistentCollection
Specified by:
getOrphans in class AbstractPersistentCollection
Throws:
HibernateException

equalsSnapshot

public boolean equalsSnapshot(CollectionPersister persister)
                       throws HibernateException
Description copied from interface: PersistentCollection
Does the current state exactly match the snapshot?

Specified by:
equalsSnapshot in interface PersistentCollection
Throws:
HibernateException

isSnapshotEmpty

public boolean isSnapshotEmpty(Serializable snapshot)
Description copied from interface: PersistentCollection
Is the snapshot empty?

Specified by:
isSnapshotEmpty in interface PersistentCollection

beforeInitialize

public void beforeInitialize(CollectionPersister persister,
                             int anticipatedSize)
Description copied from interface: PersistentCollection
Called before any elements are read into the collection, allowing appropriate initializations to occur.

Specified by:
beforeInitialize in interface PersistentCollection
Parameters:
persister - The underlying collection persister.
anticipatedSize - The anticipated size of the collection after initilization is complete.

initializeFromCache

public void initializeFromCache(CollectionPersister persister,
                                Serializable disassembled,
                                Object owner)
                         throws HibernateException
Description copied from interface: PersistentCollection
Read the state of the collection from a disassembled cached value

Specified by:
initializeFromCache in interface PersistentCollection
Throws:
HibernateException

empty

public boolean empty()
Description copied from class: AbstractPersistentCollection
Is the initialized collection empty?

Specified by:
empty in interface PersistentCollection
Specified by:
empty in class AbstractPersistentCollection

size

public int size()
Specified by:
size in interface Set
See Also:
Set.size()

isEmpty

public boolean isEmpty()
Specified by:
isEmpty in interface Set
See Also:
Set.isEmpty()

contains

public boolean contains(Object object)
Specified by:
contains in interface Set
See Also:
Set.contains(Object)

iterator

public Iterator iterator()
Specified by:
iterator in interface Set
See Also:
Set.iterator()

toArray

public Object[] toArray()
Specified by:
toArray in interface Set
See Also:
Set.toArray()

toArray

public Object[] toArray(Object[] array)
Specified by:
toArray in interface Set
See Also:
Set.toArray(Object[])

add

public boolean add(Object value)
Specified by:
add in interface Set
See Also:
Set.add(Object)

remove

public boolean remove(Object value)
Specified by:
remove in interface Set
See Also:
Set.remove(Object)

containsAll

public boolean containsAll(Collection coll)
Specified by:
containsAll in interface Set
See Also:
Set.containsAll(Collection)

addAll

public boolean addAll(Collection coll)
Specified by:
addAll in interface Set
See Also:
Set.addAll(Collection)

retainAll

public boolean retainAll(Collection coll)
Specified by:
retainAll in interface Set
See Also:
Set.retainAll(Collection)

removeAll

public boolean removeAll(Collection coll)
Specified by:
removeAll in interface Set
See Also:
Set.removeAll(Collection)

clear

public void clear()
Specified by:
clear in interface Set
See Also:
Set.clear()

toString

public String toString()

readFrom

public Object readFrom(ResultSet rs,
                       CollectionPersister persister,
                       CollectionAliases descriptor,
                       Object owner)
                throws HibernateException,
                       SQLException
Description copied from interface: PersistentCollection
Read a row from the JDBC result set

Specified by:
readFrom in interface PersistentCollection
Throws:
HibernateException
SQLException

beginRead

public void beginRead()
Description copied from class: AbstractPersistentCollection
Called just before reading any rows from the JDBC result set

Specified by:
beginRead in interface PersistentCollection
Overrides:
beginRead in class AbstractPersistentCollection

endRead

public boolean endRead()
Description copied from class: AbstractPersistentCollection
Called after reading all rows from the JDBC result set

Specified by:
endRead in interface PersistentCollection
Overrides:
endRead in class AbstractPersistentCollection

entries

public Iterator entries(CollectionPersister persister)
Description copied from interface: PersistentCollection
Iterate all collection entries, during update of the database

Specified by:
entries in interface PersistentCollection

disassemble

public Serializable disassemble(CollectionPersister persister)
                         throws HibernateException
Description copied from interface: PersistentCollection
Disassemble the collection, ready for the cache

Specified by:
disassemble in interface PersistentCollection
Throws:
HibernateException

getDeletes

public Iterator getDeletes(CollectionPersister persister,
                           boolean indexIsFormula)
                    throws HibernateException
Description copied from interface: PersistentCollection
Get all the elements that need deleting

Specified by:
getDeletes in interface PersistentCollection
Throws:
HibernateException

needsInserting

public boolean needsInserting(Object entry,
                              int i,
                              Type elemType)
                       throws HibernateException
Description copied from interface: PersistentCollection
Do we need to insert this element?

Specified by:
needsInserting in interface PersistentCollection
Throws:
HibernateException

needsUpdating

public boolean needsUpdating(Object entry,
                             int i,
                             Type elemType)
Description copied from interface: PersistentCollection
Do we need to update this element?

Specified by:
needsUpdating in interface PersistentCollection

isRowUpdatePossible

public boolean isRowUpdatePossible()
Specified by:
isRowUpdatePossible in interface PersistentCollection
Overrides:
isRowUpdatePossible in class AbstractPersistentCollection

getIndex

public Object getIndex(Object entry,
                       int i,
                       CollectionPersister persister)
Description copied from interface: PersistentCollection
Get the index of the given collection entry

Specified by:
getIndex in interface PersistentCollection
Parameters:
persister - it was more elegant before we added this...

getElement

public Object getElement(Object entry)
Description copied from interface: PersistentCollection
Get the value of the given collection entry

Specified by:
getElement in interface PersistentCollection

getSnapshotElement

public Object getSnapshotElement(Object entry,
                                 int i)
Description copied from interface: PersistentCollection
Get the snapshot value of the given collection entry

Specified by:
getSnapshotElement in interface PersistentCollection

equals

public boolean equals(Object other)
Specified by:
equals in interface Set

hashCode

public int hashCode()
Specified by:
hashCode in interface Set

entryExists

public boolean entryExists(Object key,
                           int i)
Description copied from interface: PersistentCollection
Does an element exist at this entry in the collection?

Specified by:
entryExists in interface PersistentCollection

isWrapper

public boolean isWrapper(Object collection)
Description copied from interface: PersistentCollection
Is this the wrapper for the given underlying collection instance?

Specified by:
isWrapper in interface PersistentCollection
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentSortedMap (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentSortedMap

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
        extended by org.hibernate.collection.PersistentMap
            extended by org.hibernate.collection.PersistentSortedMap
All Implemented Interfaces:
Map, PersistentCollection, Serializable, SortedMap
public class PersistentSortedMap
extends PersistentMap
implements SortedMap

A persistent wrapper for a java.util.SortedMap. Underlying collection is a TreeMap.

Author:
e
See Also:
TreeMap, Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.collection.AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
Nested classes inherited from class java.util.Map
Map.Entry
Field Summary
protected  Comparator comparator
Fields inherited from class org.hibernate.collection.PersistentMap
map
Fields inherited from class org.hibernate.collection.AbstractPersistentCollection
UNKNOWN
Constructor Summary
PersistentSortedMap()
PersistentSortedMap(SessionImplementor session)
PersistentSortedMap(SessionImplementor session, SortedMap map)
Method Summary
Comparator | comparator()
Object | firstKey()
SortedMap | headMap(Object toKey)
Object | lastKey()
void | setComparator(Comparator comparator)
protected Serializable | snapshot(BasicCollectionPersister persister, EntityMode entityMode)
SortedMap | subMap(Object fromKey, Object toKey)
SortedMap | tailMap(Object fromKey)
Methods inherited from class org.hibernate.collection.PersistentMap
beforeInitialize, clear, containsKey, containsValue, disassemble, empty, entries, entryExists, entrySet, equals, equalsSnapshot, get, getDeletes, getElement, getIndex, getOrphans, getSnapshot, getSnapshotElement, hashCode, initializeFromCache, isEmpty, isSnapshotEmpty, isWrapper, keySet, needsInserting, needsUpdating, put, putAll, readFrom, remove, size, toString, values
Methods inherited from class org.hibernate.collection.AbstractPersistentCollection
afterInitialize, afterRowInsert, beginRead, clearDirty, dirty, endRead, forceInitialization, getCachedSize, getIdentifier, getKey, getOrphans, getOwner, getQueuedOrphans, getRole, getSession, getSnapshot, getStoredSnapshot, getValue, hasQueuedOperations, initialize, isClearQueueEnabled, isDirectlyAccessible, isDirty, isOperationQueueEnabled, isPutQueueEnabled, isRowUpdatePossible, isUnreferenced, needsRecreate, performQueuedOperations, postAction, preInsert, queuedAdditionIterator, queueOperation, read, readElementByIndex, readElementExistence, readIndexExistence, readSize, setCurrentSession, setDirectlyAccessible, setInitialized, setOwner, setSnapshot, unsetSession, wasInitialized, write
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.Map
clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

Field Detail

comparator

protected Comparator comparator
Constructor Detail

PersistentSortedMap

public PersistentSortedMap(SessionImplementor session)

PersistentSortedMap

public PersistentSortedMap(SessionImplementor session,
                           SortedMap map)

PersistentSortedMap

public PersistentSortedMap()
Method Detail

snapshot

protected Serializable snapshot(BasicCollectionPersister persister,
                                EntityMode entityMode)
                         throws HibernateException
Throws:
HibernateException

setComparator

public void setComparator(Comparator comparator)

comparator

public Comparator comparator()
Specified by:
comparator in interface SortedMap
See Also:
comparator()

subMap

public SortedMap subMap(Object fromKey,
                        Object toKey)
Specified by:
subMap in interface SortedMap
See Also:
subMap(Object, Object)

headMap

public SortedMap headMap(Object toKey)
Specified by:
headMap in interface SortedMap
See Also:
headMap(Object)

tailMap

public SortedMap tailMap(Object fromKey)
Specified by:
tailMap in interface SortedMap
See Also:
tailMap(Object)

firstKey

public Object firstKey()
Specified by:
firstKey in interface SortedMap
See Also:
firstKey()

lastKey

public Object lastKey()
Specified by:
lastKey in interface SortedMap
See Also:
lastKey()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentSortedSet (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.collection
Class PersistentSortedSet

java.lang.Object
    extended by org.hibernate.collection.AbstractPersistentCollection
        extended by org.hibernate.collection.PersistentSet
            extended by org.hibernate.collection.PersistentSortedSet
All Implemented Interfaces:
Collection, PersistentCollection, Serializable, Set, SortedSet
public class PersistentSortedSet
extends PersistentSet
implements SortedSet

A persistent wrapper for a java.util.SortedSet. Underlying collection is a TreeSet.

Author:
e
See Also:
TreeSet, Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.collection.AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
Field Summary
protected  Comparator comparator
Fields inherited from class org.hibernate.collection.PersistentSet
set, tempList
Fields inherited from class org.hibernate.collection.AbstractPersistentCollection
UNKNOWN
Constructor Summary
PersistentSortedSet()
PersistentSortedSet(SessionImplementor session)
PersistentSortedSet(SessionImplementor session, SortedSet set)
Method Summary
Comparator | comparator()
Object | first()
SortedSet | headSet(Object toElement)
Object | last()
void | setComparator(Comparator comparator)
protected Serializable | snapshot(BasicCollectionPersister persister, EntityMode entityMode)
SortedSet | subSet(Object fromElement, Object toElement)
SortedSet | tailSet(Object fromElement)
Methods inherited from class org.hibernate.collection.PersistentSet
add, addAll, beforeInitialize, beginRead, clear, contains, containsAll, disassemble, empty, endRead, entries, entryExists, equals, equalsSnapshot, getDeletes, getElement, getIndex, getOrphans, getSnapshot, getSnapshotElement, hashCode, initializeFromCache, isEmpty, isRowUpdatePossible, isSnapshotEmpty, isWrapper, iterator, needsInserting, needsUpdating, readFrom, remove, removeAll, retainAll, size, toArray, toArray, toString
Methods inherited from class org.hibernate.collection.AbstractPersistentCollection
afterInitialize, afterRowInsert, clearDirty, dirty, forceInitialization, getCachedSize, getIdentifier, getKey, getOrphans, getOwner, getQueuedOrphans, getRole, getSession, getSnapshot, getStoredSnapshot, getValue, hasQueuedOperations, initialize, isClearQueueEnabled, isDirectlyAccessible, isDirty, isOperationQueueEnabled, isPutQueueEnabled, isUnreferenced, needsRecreate, performQueuedOperations, postAction, preInsert, queuedAdditionIterator, queueOperation, read, readElementByIndex, readElementExistence, readIndexExistence, readSize, setCurrentSession, setDirectlyAccessible, setInitialized, setOwner, setSnapshot, unsetSession, wasInitialized, write
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.Set
add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, remove, removeAll, retainAll, size, toArray, toArray

Field Detail

comparator

protected Comparator comparator
Constructor Detail

PersistentSortedSet

public PersistentSortedSet(SessionImplementor session)

PersistentSortedSet

public PersistentSortedSet(SessionImplementor session,
                           SortedSet set)

PersistentSortedSet

public PersistentSortedSet()
Method Detail

snapshot

protected Serializable snapshot(BasicCollectionPersister persister,
                                EntityMode entityMode)
                         throws HibernateException
Throws:
HibernateException

setComparator

public void setComparator(Comparator comparator)

comparator

public Comparator comparator()
Specified by:
comparator in interface SortedSet
See Also:
comparator()

subSet

public SortedSet subSet(Object fromElement,
                        Object toElement)
Specified by:
subSet in interface SortedSet
See Also:
subSet(Object,Object)

headSet

public SortedSet headSet(Object toElement)
Specified by:
headSet in interface SortedSet
See Also:
headSet(Object)

tailSet

public SortedSet tailSet(Object fromElement)
Specified by:
tailSet in interface SortedSet
See Also:
tailSet(Object)

first

public Object first()
Specified by:
first in interface SortedSet
See Also:
first()

last

public Object last()
Specified by:
last in interface SortedSet
See Also:
last()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.connection (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.connection

This package abstracts the mechanism for obtaining a JDBC connection.

See:
Description

Interface Summary
ConnectionProvider A strategy for obtaining JDBC connections.

Class Summary
C3P0ConnectionProvider | A connection provider that uses a C3P0 connection pool.
ConnectionProviderFactory | Instantiates a connection provider given either System properties or a java.util.Properties instance.
DatasourceConnectionProvider | A connection provider that uses a DataSource registered with JNDI.
DriverManagerConnectionProvider | A connection provider that uses java.sql.DriverManager.
ProxoolConnectionProvider | A connection provider that uses a Proxool connection pool.
UserSuppliedConnectionProvider | An implementation of the ConnectionProvider interface that simply throws an exception when a connection is requested.

Package org.hibernate.connection Description

This package abstracts the mechanism for obtaining a JDBC connection.

A concrete implementation of ConnectionProvider may be selected by specifying hibernate.connection.provider_class.


org.hibernate.connection Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.connection

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.connection.C3P0ConnectionProvider (implements org.hibernate.connection.ConnectionProvider)
    • class org.hibernate.connection.ConnectionProviderFactory
    • class org.hibernate.connection.DatasourceConnectionProvider (implements org.hibernate.connection.ConnectionProvider)
    • class org.hibernate.connection.DriverManagerConnectionProvider (implements org.hibernate.connection.ConnectionProvider)
    • class org.hibernate.connection.ProxoolConnectionProvider (implements org.hibernate.connection.ConnectionProvider)
    • class org.hibernate.connection.UserSuppliedConnectionProvider (implements org.hibernate.connection.ConnectionProvider)

Interface Hierarchy

  • interface org.hibernate.connection.ConnectionProvider


Uses of Package org.hibernate.connection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.connection

Packages that use org.hibernate.connection
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.connection | This package abstracts the mechanism for obtaining a JDBC connection.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Classes in org.hibernate.connection used by org.hibernate.cfg
ConnectionProvider
A strategy for obtaining JDBC connections.

Classes in org.hibernate.connection used by org.hibernate.connection
ConnectionProvider
A strategy for obtaining JDBC connections.

Classes in org.hibernate.connection used by org.hibernate.engine
ConnectionProvider
A strategy for obtaining JDBC connections.

Classes in org.hibernate.connection used by org.hibernate.impl
ConnectionProvider
A strategy for obtaining JDBC connections.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ConnectionProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.connection
Interface ConnectionProvider

All Known Implementing Classes:
C3P0ConnectionProvider, DatasourceConnectionProvider, DriverManagerConnectionProvider, ProxoolConnectionProvider, UserSuppliedConnectionProvider
public interface ConnectionProvider

A strategy for obtaining JDBC connections.

Implementors might also implement connection pooling.

The ConnectionProvider interface is not intended to be exposed to the application. Instead it is used internally by Hibernate to obtain connections.

Implementors should provide a public default constructor.

Author:
Gavin King
See Also:
ConnectionProviderFactory

Method Summary
void | close() Release all resources held by this provider.
void | closeConnection(Connection conn) Dispose of a used connection.
void | configure(Properties props) Initialize the connection provider from given properties.
Connection | getConnection() Grab a connection, with the autocommit mode specified by hibernate.connection.autocommit.
boolean | supportsAggressiveRelease() Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later? This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections.

Method Detail

configure

public void configure(Properties props)
               throws HibernateException
Initialize the connection provider from given properties.

Parameters:
props - SessionFactory properties
Throws:
HibernateException

getConnection

public Connection getConnection()
                         throws SQLException
Grab a connection, with the autocommit mode specified by hibernate.connection.autocommit.

Returns:
a JDBC connection
Throws:
SQLException

closeConnection

public void closeConnection(Connection conn)
                     throws SQLException
Dispose of a used connection.

Parameters:
conn - a JDBC connection
Throws:
SQLException

close

public void close()
           throws HibernateException
Release all resources held by this provider. JavaDoc requires a second sentence.

Throws:
HibernateException

supportsAggressiveRelease

public boolean supportsAggressiveRelease()
Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later?

This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections. However, the configured ConnectionProvider must support re-acquisition of the same underlying connection for that semantic to work.

Typically, this is only true in managed environments where a container tracks connections by transaction or thread. Note that JTA semantic depends on the fact that the underlying connection provider does support aggressive release.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


C3P0ConnectionProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.connection
Class C3P0ConnectionProvider

java.lang.Object
    extended by org.hibernate.connection.C3P0ConnectionProvider
All Implemented Interfaces:
ConnectionProvider
public class C3P0ConnectionProvider
extends Object
implements ConnectionProvider

A connection provider that uses a C3P0 connection pool. Hibernate will use this by default if the hibernate.c3p0.* properties are set.

Author:
various people
See Also:
ConnectionProvider

Constructor Summary
C3P0ConnectionProvider()
Method Summary
void | close() Release all resources held by this provider.
void | closeConnection(Connection conn) Dispose of a used connection.
void | configure(Properties props) Initialize the connection provider from given properties.
Connection | getConnection() Grab a connection, with the autocommit mode specified by hibernate.connection.autocommit.
boolean | supportsAggressiveRelease() Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later? This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

C3P0ConnectionProvider

public C3P0ConnectionProvider()
Method Detail

getConnection

public Connection getConnection()
                         throws SQLException
Description copied from interface: ConnectionProvider
Grab a connection, with the autocommit mode specified by hibernate.connection.autocommit.

Specified by:
getConnection in interface ConnectionProvider
Returns:
a JDBC connection
Throws:
SQLException

closeConnection

public void closeConnection(Connection conn)
                     throws SQLException
Description copied from interface: ConnectionProvider
Dispose of a used connection.

Specified by:
closeConnection in interface ConnectionProvider
Parameters:
conn - a JDBC connection
Throws:
SQLException

configure

public void configure(Properties props)
               throws HibernateException
Description copied from interface: ConnectionProvider
Initialize the connection provider from given properties.

Specified by:
configure in interface ConnectionProvider
Parameters:
props - SessionFactory properties
Throws:
HibernateException

close

public void close()
Description copied from interface: ConnectionProvider
Release all resources held by this provider. JavaDoc requires a second sentence.

Specified by:
close in interface ConnectionProvider

supportsAggressiveRelease

public boolean supportsAggressiveRelease()
Description copied from interface: ConnectionProvider
Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later?

This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections. However, the configured ConnectionProvider must support re-acquisition of the same underlying connection for that semantic to work.

Typically, this is only true in managed environments where a container tracks connections by transaction or thread. Note that JTA semantic depends on the fact that the underlying connection provider does support aggressive release.

Specified by:
supportsAggressiveRelease in interface ConnectionProvider
See Also:
ConnectionProvider.supportsAggressiveRelease()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ConnectionProviderFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.connection
Class ConnectionProviderFactory

java.lang.Object
    extended by org.hibernate.connection.ConnectionProviderFactory
public final class ConnectionProviderFactory
extends Object

Instantiates a connection provider given either System properties or a java.util.Properties instance. The ConnectionProviderFactory first attempts to find a name of a ConnectionProvider subclass in the property hibernate.connection.provider_class. If missing, heuristics are used to choose either DriverManagerConnectionProvider, DatasourceConnectionProvider, C3P0ConnectionProvider or DBCPConnectionProvider.

Author:
Gavin King
See Also:
ConnectionProvider

Method Summary
static Properties | getConnectionProperties(Properties properties) Transform JDBC connection properties.
static ConnectionProvider | newConnectionProvider() Instantiate a ConnectionProvider using System properties.
static ConnectionProvider | newConnectionProvider(Properties properties) Instantiate a ConnectionProvider using given properties.
static ConnectionProvider | newConnectionProvider(Properties properties, Map connectionProviderInjectionData) Instantiate a ConnectionProvider using given properties.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

newConnectionProvider

public static ConnectionProvider newConnectionProvider()
                                                throws HibernateException
Instantiate a ConnectionProvider using System properties.

Returns:
ConnectionProvider
Throws:
HibernateException

newConnectionProvider

public static ConnectionProvider newConnectionProvider(Properties properties)
                                                throws HibernateException
Instantiate a ConnectionProvider using given properties. Method newConnectionProvider.

Parameters:
properties - hibernate SessionFactory properties
Returns:
ConnectionProvider
Throws:
HibernateException

newConnectionProvider

public static ConnectionProvider newConnectionProvider(Properties properties,
                                                       Map connectionProviderInjectionData)
                                                throws HibernateException
Instantiate a ConnectionProvider using given properties. Method newConnectionProvider.

Parameters:
properties - hibernate SessionFactory properties
Returns:
ConnectionProvider
Throws:
HibernateException

getConnectionProperties

public static Properties getConnectionProperties(Properties properties)
Transform JDBC connection properties. Passed in the form hibernate.connection.* to the format accepted by DriverManager by triming the leading "hibernate.connection".

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DatasourceConnectionProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.connection
Class DatasourceConnectionProvider

java.lang.Object
    extended by org.hibernate.connection.DatasourceConnectionProvider
All Implemented Interfaces:
ConnectionProvider
public class DatasourceConnectionProvider
extends Object
implements ConnectionProvider

A connection provider that uses a DataSource registered with JNDI. Hibernate will use this ConnectionProvider by default if the property hibernate.connection.datasource is set.

Author:
Gavin King
See Also:
ConnectionProvider

Constructor Summary
DatasourceConnectionProvider()
Method Summary
void | close() Release all resources held by this provider.
void | closeConnection(Connection conn) Dispose of a used connection.
void | configure(Properties props) Initialize the connection provider from given properties.
Connection | getConnection() Grab a connection, with the autocommit mode specified by hibernate.connection.autocommit.
javax.sql.DataSource | getDataSource()
void | setDataSource(javax.sql.DataSource ds)
boolean | supportsAggressiveRelease() Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later? This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DatasourceConnectionProvider

public DatasourceConnectionProvider()
Method Detail

getDataSource

public javax.sql.DataSource getDataSource()

setDataSource

public void setDataSource(javax.sql.DataSource ds)

configure

public void configure(Properties props)
               throws HibernateException
Description copied from interface: ConnectionProvider
Initialize the connection provider from given properties.

Specified by:
configure in interface ConnectionProvider
Parameters:
props - SessionFactory properties
Throws:
HibernateException

getConnection

public Connection getConnection()
                         throws SQLException
Description copied from interface: ConnectionProvider
Grab a connection, with the autocommit mode specified by hibernate.connection.autocommit.

Specified by:
getConnection in interface ConnectionProvider
Returns:
a JDBC connection
Throws:
SQLException

closeConnection

public void closeConnection(Connection conn)
                     throws SQLException
Description copied from interface: ConnectionProvider
Dispose of a used connection.

Specified by:
closeConnection in interface ConnectionProvider
Parameters:
conn - a JDBC connection
Throws:
SQLException

close

public void close()
Description copied from interface: ConnectionProvider
Release all resources held by this provider. JavaDoc requires a second sentence.

Specified by:
close in interface ConnectionProvider

supportsAggressiveRelease

public boolean supportsAggressiveRelease()
Description copied from interface: ConnectionProvider
Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later?

This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections. However, the configured ConnectionProvider must support re-acquisition of the same underlying connection for that semantic to work.

Typically, this is only true in managed environments where a container tracks connections by transaction or thread. Note that JTA semantic depends on the fact that the underlying connection provider does support aggressive release.

Specified by:
supportsAggressiveRelease in interface ConnectionProvider
See Also:
ConnectionProvider.supportsAggressiveRelease()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DriverManagerConnectionProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.connection
Class DriverManagerConnectionProvider

java.lang.Object
    extended by org.hibernate.connection.DriverManagerConnectionProvider
All Implemented Interfaces:
ConnectionProvider
public class DriverManagerConnectionProvider
extends Object
implements ConnectionProvider

A connection provider that uses java.sql.DriverManager. This provider also implements a very rudimentary connection pool.

Author:
Gavin King
See Also:
ConnectionProvider

Constructor Summary
DriverManagerConnectionProvider()
Method Summary
void | close() Release all resources held by this provider.
void | closeConnection(Connection conn) Dispose of a used connection.
void | configure(Properties props) Initialize the connection provider from given properties.
protected void | finalize()
Connection | getConnection() Grab a connection, with the autocommit mode specified by hibernate.connection.autocommit.
boolean | supportsAggressiveRelease() Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later? This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections.
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DriverManagerConnectionProvider

public DriverManagerConnectionProvider()
Method Detail

configure

public void configure(Properties props)
               throws HibernateException
Description copied from interface: ConnectionProvider
Initialize the connection provider from given properties.

Specified by:
configure in interface ConnectionProvider
Parameters:
props - SessionFactory properties
Throws:
HibernateException

getConnection

public Connection getConnection()
                         throws SQLException
Description copied from interface: ConnectionProvider
Grab a connection, with the autocommit mode specified by hibernate.connection.autocommit.

Specified by:
getConnection in interface ConnectionProvider
Returns:
a JDBC connection
Throws:
SQLException

closeConnection

public void closeConnection(Connection conn)
                     throws SQLException
Description copied from interface: ConnectionProvider
Dispose of a used connection.

Specified by:
closeConnection in interface ConnectionProvider
Parameters:
conn - a JDBC connection
Throws:
SQLException

finalize

protected void finalize()

close

public void close()
Description copied from interface: ConnectionProvider
Release all resources held by this provider. JavaDoc requires a second sentence.

Specified by:
close in interface ConnectionProvider

supportsAggressiveRelease

public boolean supportsAggressiveRelease()
Description copied from interface: ConnectionProvider
Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later?

This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections. However, the configured ConnectionProvider must support re-acquisition of the same underlying connection for that semantic to work.

Typically, this is only true in managed environments where a container tracks connections by transaction or thread. Note that JTA semantic depends on the fact that the underlying connection provider does support aggressive release.

Specified by:
supportsAggressiveRelease in interface ConnectionProvider
See Also:
ConnectionProvider.supportsAggressiveRelease()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxoolConnectionProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.connection
Class ProxoolConnectionProvider

java.lang.Object
    extended by org.hibernate.connection.ProxoolConnectionProvider
All Implemented Interfaces:
ConnectionProvider
public class ProxoolConnectionProvider
extends Object
implements ConnectionProvider

A connection provider that uses a Proxool connection pool. Hibernate will use this by default if the hibernate.proxool.* properties are set.

See Also:
ConnectionProvider

Constructor Summary
ProxoolConnectionProvider()
Method Summary
void | close() Release all resources held by this provider.
void | closeConnection(Connection conn) Dispose of a used connection.
void | configure(Properties props) Initialize the connection provider from given properties.
Connection | getConnection() Grab a connection
boolean | supportsAggressiveRelease() Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later? This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProxoolConnectionProvider

public ProxoolConnectionProvider()
Method Detail

getConnection

public Connection getConnection()
                         throws SQLException
Grab a connection

Specified by:
getConnection in interface ConnectionProvider
Returns:
a JDBC connection
Throws:
SQLException

closeConnection

public void closeConnection(Connection conn)
                     throws SQLException
Dispose of a used connection.

Specified by:
closeConnection in interface ConnectionProvider
Parameters:
conn - a JDBC connection
Throws:
SQLException

configure

public void configure(Properties props)
               throws HibernateException
Initialize the connection provider from given properties.

Specified by:
configure in interface ConnectionProvider
Parameters:
props - SessionFactory properties
Throws:
HibernateException

close

public void close()
           throws HibernateException
Release all resources held by this provider. JavaDoc requires a second sentence.

Specified by:
close in interface ConnectionProvider
Throws:
HibernateException

supportsAggressiveRelease

public boolean supportsAggressiveRelease()
Description copied from interface: ConnectionProvider
Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later?

This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections. However, the configured ConnectionProvider must support re-acquisition of the same underlying connection for that semantic to work.

Typically, this is only true in managed environments where a container tracks connections by transaction or thread. Note that JTA semantic depends on the fact that the underlying connection provider does support aggressive release.

Specified by:
supportsAggressiveRelease in interface ConnectionProvider
See Also:
ConnectionProvider.supportsAggressiveRelease()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserSuppliedConnectionProvider (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.connection
Class UserSuppliedConnectionProvider

java.lang.Object
    extended by org.hibernate.connection.UserSuppliedConnectionProvider
All Implemented Interfaces:
ConnectionProvider
public class UserSuppliedConnectionProvider
extends Object
implements ConnectionProvider

An implementation of the ConnectionProvider interface that simply throws an exception when a connection is requested. This implementation indicates that the user is expected to supply a JDBC connection.

Author:
Gavin King
See Also:
ConnectionProvider

Constructor Summary
UserSuppliedConnectionProvider()
Method Summary
void | close() Release all resources held by this provider.
void | closeConnection(Connection conn) Dispose of a used connection.
void | configure(Properties props) Initialize the connection provider from given properties.
Connection | getConnection() Grab a connection, with the autocommit mode specified by hibernate.connection.autocommit.
boolean | supportsAggressiveRelease() Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later? This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UserSuppliedConnectionProvider

public UserSuppliedConnectionProvider()
Method Detail

configure

public void configure(Properties props)
               throws HibernateException
Description copied from interface: ConnectionProvider
Initialize the connection provider from given properties.

Specified by:
configure in interface ConnectionProvider
Parameters:
props - SessionFactory properties
Throws:
HibernateException
See Also:
ConnectionProvider.configure(Properties)

getConnection

public Connection getConnection()
Description copied from interface: ConnectionProvider
Grab a connection, with the autocommit mode specified by hibernate.connection.autocommit.

Specified by:
getConnection in interface ConnectionProvider
Returns:
a JDBC connection
See Also:
ConnectionProvider.getConnection()

closeConnection

public void closeConnection(Connection conn)
Description copied from interface: ConnectionProvider
Dispose of a used connection.

Specified by:
closeConnection in interface ConnectionProvider
Parameters:
conn - a JDBC connection
See Also:
ConnectionProvider.closeConnection(Connection)

close

public void close()
Description copied from interface: ConnectionProvider
Release all resources held by this provider. JavaDoc requires a second sentence.

Specified by:
close in interface ConnectionProvider

supportsAggressiveRelease

public boolean supportsAggressiveRelease()
Description copied from interface: ConnectionProvider
Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later?

This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections. However, the configured ConnectionProvider must support re-acquisition of the same underlying connection for that semantic to work.

Typically, this is only true in managed environments where a container tracks connections by transaction or thread. Note that JTA semantic depends on the fact that the underlying connection provider does support aggressive release.

Specified by:
supportsAggressiveRelease in interface ConnectionProvider
See Also:
ConnectionProvider.supportsAggressiveRelease()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.context (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.context

Interface Summary
CurrentSessionContext Defines the contract for implementations which know how to scope the notion of a current session.

Class Summary
JTASessionContext | An implementation of CurrentSessionContext which scopes the notion of a current session to a JTA transaction.
JTASessionContext.CleanupSynch | JTA transaction synch used for cleanup of the internal session map.
ManagedSessionContext | Represents a CurrentSessionContext the notion of a contextual session is managed by some external entity (generally some form of interceptor, etc).
ThreadLocalSessionContext | A CurrentSessionContext impl which scopes the notion of current session by the current thread of execution.
ThreadLocalSessionContext.CleanupSynch | JTA transaction synch used for cleanup of the internal session map.


org.hibernate.context Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.context

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.context.JTASessionContext (implements org.hibernate.context.CurrentSessionContext)
    • class org.hibernate.context.JTASessionContext.CleanupSynch (implements javax.transaction.Synchronization)
    • class org.hibernate.context.ManagedSessionContext (implements org.hibernate.context.CurrentSessionContext)
    • class org.hibernate.context.ThreadLocalSessionContext (implements org.hibernate.context.CurrentSessionContext)
    • class org.hibernate.context.ThreadLocalSessionContext.CleanupSynch (implements java.io.Serializable, javax.transaction.Synchronization)

Interface Hierarchy

  • interface java.io.Serializable
    • interface org.hibernate.context.CurrentSessionContext


Uses of Package org.hibernate.context (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.context

Packages that use org.hibernate.context
org.hibernate.context

Classes in org.hibernate.context used by org.hibernate.context
CurrentSessionContext
Defines the contract for implementations which know how to scope the notion of a current session.
JTASessionContext
An implementation of CurrentSessionContext which scopes the notion of a current session to a JTA transaction.
ThreadLocalSessionContext.CleanupSynch
JTA transaction synch used for cleanup of the internal session map.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CurrentSessionContext (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.context
Interface CurrentSessionContext

All Superinterfaces:
Serializable
All Known Implementing Classes:
JTASessionContext, ManagedSessionContext, ThreadLocalSessionContext
public interface CurrentSessionContext
extends Serializable

Defines the contract for implementations which know how to scope the notion of a current session.

Implementations should adhere to the following:

  • contain a constructor accepting a single argument of type SessionFactoryImplementor
  • should be thread safe
  • should be fully serializable

Implementors should be aware that they are also fully responsible for cleanup of any generated current-sessions.

Note that there will be exactly one instance of the configured CurrentSessionContext implementation per SessionFactory.

Author:
Steve Ebersole

Method Summary
 Session currentSession()
Retrieve the current session according to the scoping defined by this implementation.

Method Detail

currentSession

public Session currentSession()
                       throws HibernateException
Retrieve the current session according to the scoping defined by this implementation.

Returns:
The current session.
Throws:
HibernateException - Typically indicates an issue locating or creating the current session.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JTASessionContext (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.context
Class JTASessionContext

java.lang.Object
    extended by org.hibernate.context.JTASessionContext
All Implemented Interfaces:
CurrentSessionContext, Serializable
public class JTASessionContext
extends Object
implements CurrentSessionContext

An implementation of CurrentSessionContext which scopes the notion of a current session to a JTA transaction. Because JTA gives us a nice tie-in to clean up after ourselves, this implementation will generate Sessions as needed provided a JTA transaction is in effect. If a session is not already associated with the current JTA transaction at the time currentSession() is called, a new session will be opened and it will be associated with that JTA transaction.

Note that the sessions returned from this method are automatically configured with both the auto-flush and auto-close attributes set to true, meaning that the Session will be automatically flushed and closed as part of the lifecycle for the JTA transaction to which it is associated. Additionally, it will also be configured to aggressively release JDBC connections after each statement is executed. These settings are governed by the isAutoFlushEnabled(), isAutoCloseEnabled(), and getConnectionReleaseMode() methods; these are provided (along with the buildOrObtainSession() method) for easier subclassing for custom JTA-based session tracking logic (like maybe long-session semantics).

Author:
Steve Ebersole
See Also:
Serialized Form

Nested Class Summary
protected static class JTASessionContext.CleanupSynch
JTA transaction synch used for cleanup of the internal session map.
Field Summary
protected  SessionFactoryImplementor factory
Constructor Summary
JTASessionContext(SessionFactoryImplementor factory)
Method Summary
protected Session | buildOrObtainSession() Strictly provided for subclassing purposes; specifically to allow long-session support.
Session | currentSession() Retrieve the current session according to the scoping defined by this implementation.
protected ConnectionReleaseMode | getConnectionReleaseMode() Mainly for subclass usage.
protected boolean | isAutoCloseEnabled() Mainly for subclass usage.
protected boolean | isAutoFlushEnabled() Mainly for subclass usage.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

factory

protected final SessionFactoryImplementor factory
Constructor Detail

JTASessionContext

public JTASessionContext(SessionFactoryImplementor factory)
Method Detail

currentSession

public Session currentSession()
                       throws HibernateException
Description copied from interface: CurrentSessionContext
Retrieve the current session according to the scoping defined by this implementation.

Specified by:
currentSession in interface CurrentSessionContext
Returns:
The current session.
Throws:
HibernateException - Typically indicates an issue locating or creating the current session.

buildOrObtainSession

protected Session buildOrObtainSession()
Strictly provided for subclassing purposes; specifically to allow long-session support.

This implementation always just opens a new session.

Returns:
the built or (re)obtained session.

isAutoCloseEnabled

protected boolean isAutoCloseEnabled()
Mainly for subclass usage. This impl always returns true.

Returns:
Whether or not the the session should be closed by transaction completion.

isAutoFlushEnabled

protected boolean isAutoFlushEnabled()
Mainly for subclass usage. This impl always returns true.

Returns:
Whether or not the the session should be flushed prior transaction completion.

getConnectionReleaseMode

protected ConnectionReleaseMode getConnectionReleaseMode()
Mainly for subclass usage. This impl always returns after_statement.

Returns:
The connection release mode for any built sessions.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JTASessionContext.CleanupSynch (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.context
Class JTASessionContext.CleanupSynch

java.lang.Object
    extended by org.hibernate.context.JTASessionContext.CleanupSynch
All Implemented Interfaces:
Synchronization
Enclosing class:
JTASessionContext
protected static class JTASessionContext.CleanupSynch
extends Object
implements Synchronization

JTA transaction synch used for cleanup of the internal session map.

Constructor Summary
JTASessionContext.CleanupSynch(Transaction txn, JTASessionContext context)
Method Summary
void | afterCompletion(int i)
void | beforeCompletion()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JTASessionContext.CleanupSynch

public JTASessionContext.CleanupSynch(Transaction txn,
                                      JTASessionContext context)
Method Detail

beforeCompletion

public void beforeCompletion()
Specified by:
beforeCompletion in interface Synchronization

afterCompletion

public void afterCompletion(int i)
Specified by:
afterCompletion in interface Synchronization
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManagedSessionContext (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.context
Class ManagedSessionContext

java.lang.Object
    extended by org.hibernate.context.ManagedSessionContext
All Implemented Interfaces:
CurrentSessionContext, Serializable
public class ManagedSessionContext
extends Object
implements CurrentSessionContext

Represents a CurrentSessionContext the notion of a contextual session is managed by some external entity (generally some form of interceptor, etc). This external manager is responsible for scoping these contextual sessions appropriately binding/unbinding them here for exposure to the application through SessionFactory.getCurrentSession() calls.

Basically exposes two interfaces.

  • First is the implementation of CurrentSessionContext which is then used by the SessionFactory.getCurrentSession() calls. This portion is instance-based specific to the session factory owning the given instance of this impl (there will be one instance of this per each session factory using this strategy).
  • Second is the externally facing methods hasBind(org.hibernate.SessionFactory), bind(org.hibernate.classic.Session), and unbind(org.hibernate.SessionFactory) used by the external thing to manage exposure of the current session it is scoping. This portion is static to allow easy reference from that external thing.
The underlying storage of the current sessions here is a static ThreadLocal-based map where the sessions are keyed by the the owning session factory.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
ManagedSessionContext(SessionFactoryImplementor factory)
Method Summary
static Session | bind(Session session) Binds the given session to the current context for its session factory.
Session | currentSession() Retrieve the current session according to the scoping defined by this implementation.
static boolean | hasBind(SessionFactory factory) Check to see if there is already a session associated with the current thread for the given session factory.
protected static Map | sessionMap()
static Session | unbind(SessionFactory factory) Unbinds the session (if one) current associated with the context for the given session.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ManagedSessionContext

public ManagedSessionContext(SessionFactoryImplementor factory)
Method Detail

currentSession

public Session currentSession()
Description copied from interface: CurrentSessionContext
Retrieve the current session according to the scoping defined by this implementation.

Specified by:
currentSession in interface CurrentSessionContext
Returns:
The current session.
See Also:
CurrentSessionContext.currentSession()

hasBind

public static boolean hasBind(SessionFactory factory)
Check to see if there is already a session associated with the current thread for the given session factory.

Parameters:
factory - The factory against which to check for a given session within the current thread.
Returns:
True if there is currently a session bound.

bind

public static Session bind(Session session)
Binds the given session to the current context for its session factory.

Parameters:
session - The session to be bound.
Returns:
Any previously bound session (should be null in most cases).

unbind

public static Session unbind(SessionFactory factory)
Unbinds the session (if one) current associated with the context for the given session.

Parameters:
factory - The factory for which to unbind the current session.
Returns:
The bound session if one, else null.

sessionMap

protected static Map sessionMap()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ThreadLocalSessionContext (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.context
Class ThreadLocalSessionContext

java.lang.Object
    extended by org.hibernate.context.ThreadLocalSessionContext
All Implemented Interfaces:
CurrentSessionContext, Serializable
public class ThreadLocalSessionContext
extends Object
implements CurrentSessionContext

A CurrentSessionContext impl which scopes the notion of current session by the current thread of execution. Unlike the JTA counterpart, threads do not give us a nice hook to perform any type of cleanup making it questionable for this impl to actually generate Session instances. In the interest of usability, it was decided to have this default impl actually generate a session upon first request and then clean it up after the Transaction associated with that session is committed/rolled-back. In order for ensuring that happens, the sessions generated here are unusable until after Session.beginTransaction() has been called. If close() is called on a session managed by this class, it will be automatically unbound.

Additionally, the static bind(org.hibernate.Session) and unbind(org.hibernate.SessionFactory) methods are provided to allow application code to explicitly control opening and closing of these sessions. This, with some from of interception, is the preferred approach. It also allows easy framework integration and one possible approach for implementing long-sessions.

The buildOrObtainSession(), isAutoCloseEnabled(), isAutoFlushEnabled(), getConnectionReleaseMode(), and buildCleanupSynch() methods are all provided to allow easy subclassing (for long- running session scenarios, for example).

Author:
Steve Ebersole
See Also:
Serialized Form

Nested Class Summary
protected static class ThreadLocalSessionContext.CleanupSynch
JTA transaction synch used for cleanup of the internal session map.
Field Summary
protected  SessionFactoryImplementor factory
Constructor Summary
ThreadLocalSessionContext(SessionFactoryImplementor factory)
Method Summary
static void | bind(Session session) Associates the given session with the current thread of execution.
protected ThreadLocalSessionContext.CleanupSynch | buildCleanupSynch()
protected Session | buildOrObtainSession() Strictly provided for subclassing purposes; specifically to allow long-session support.
Session | currentSession() Retrieve the current session according to the scoping defined by this implementation.
protected ConnectionReleaseMode | getConnectionReleaseMode() Mainly for subclass usage.
protected SessionFactoryImplementor | getFactory()
protected boolean | isAutoCloseEnabled() Mainly for subclass usage.
protected boolean | isAutoFlushEnabled() Mainly for subclass usage.
protected static Map | sessionMap()
static Session | unbind(SessionFactory factory) Unassociate a previously bound session from the current thread of execution.
protected Session | wrap(Session session)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

factory

protected final SessionFactoryImplementor factory
Constructor Detail

ThreadLocalSessionContext

public ThreadLocalSessionContext(SessionFactoryImplementor factory)
Method Detail

currentSession

public final Session currentSession()
                             throws HibernateException
Description copied from interface: CurrentSessionContext
Retrieve the current session according to the scoping defined by this implementation.

Specified by:
currentSession in interface CurrentSessionContext
Returns:
The current session.
Throws:
HibernateException - Typically indicates an issue locating or creating the current session.

getFactory

protected SessionFactoryImplementor getFactory()

buildOrObtainSession

protected Session buildOrObtainSession()
Strictly provided for subclassing purposes; specifically to allow long-session support.

This implementation always just opens a new session.

Returns:
the built or (re)obtained session.

buildCleanupSynch

protected ThreadLocalSessionContext.CleanupSynch buildCleanupSynch()

isAutoCloseEnabled

protected boolean isAutoCloseEnabled()
Mainly for subclass usage. This impl always returns true.

Returns:
Whether or not the the session should be closed by transaction completion.

isAutoFlushEnabled

protected boolean isAutoFlushEnabled()
Mainly for subclass usage. This impl always returns true.

Returns:
Whether or not the the session should be flushed prior transaction completion.

getConnectionReleaseMode

protected ConnectionReleaseMode getConnectionReleaseMode()
Mainly for subclass usage. This impl always returns after_transaction.

Returns:
The connection release mode for any built sessions.

wrap

protected Session wrap(Session session)

bind

public static void bind(Session session)
Associates the given session with the current thread of execution.

Parameters:
session - The session to bind.

unbind

public static Session unbind(SessionFactory factory)
Unassociate a previously bound session from the current thread of execution.

Returns:
The session which was unbound.

sessionMap

protected static Map sessionMap()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ThreadLocalSessionContext.CleanupSynch (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.context
Class ThreadLocalSessionContext.CleanupSynch

java.lang.Object
    extended by org.hibernate.context.ThreadLocalSessionContext.CleanupSynch
All Implemented Interfaces:
Serializable, Synchronization
Enclosing class:
ThreadLocalSessionContext
protected static class ThreadLocalSessionContext.CleanupSynch
extends Object
implements Synchronization, Serializable

JTA transaction synch used for cleanup of the internal session map.

See Also:
Serialized Form

Field Summary
protected  SessionFactory factory
Constructor Summary
ThreadLocalSessionContext.CleanupSynch(SessionFactory factory)
Method Summary
void | afterCompletion(int i)
void | beforeCompletion()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

factory

protected final SessionFactory factory
Constructor Detail

ThreadLocalSessionContext.CleanupSynch

public ThreadLocalSessionContext.CleanupSynch(SessionFactory factory)
Method Detail

beforeCompletion

public void beforeCompletion()
Specified by:
beforeCompletion in interface Synchronization

afterCompletion

public void afterCompletion(int i)
Specified by:
afterCompletion in interface Synchronization
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.criterion (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.criterion

A framework for defining restriction criteria and order criteria.

See:
Description

Interface Summary
CriteriaQuery | An instance of CriteriaQuery is passed to criterion, order and projection instances when actually compiling and executing the query.
CriteriaSpecification |
Criterion | An object-oriented representation of a query criterion that may be used as a restriction in a Criteria query.
Example.PropertySelector | A strategy for choosing property values for inclusion in the query criteria
Projection | An object-oriented representation of a query result set projection in a Criteria query.

Class Summary
AbstractEmptinessExpression | Implementation of AbstractEmptinessExpression.
AggregateProjection | An aggregation
AliasedProjection |
AvgProjection |
BetweenExpression | Constrains a property to between two values
Conjunction |
CountProjection | A count
DetachedCriteria | Some applications need to create criteria queries in "detached mode", where the Hibernate session is not available.
Disjunction |
Distinct |
EmptyExpression |
Example | Support for query by example.
ExistsSubqueryExpression |
Expression | This class is semi-deprecated.
IdentifierEqExpression | An identifier constraint
IdentifierProjection | A property value, or grouped property value
IlikeExpression | A case-insensitive "like"
InExpression | Constrains the property to a specified list of values
Junction | A sequence of a logical expressions combined by some associative logical operator
LikeExpression | A criterion representing a "like" expression
LogicalExpression | Superclass of binary logical expressions
MatchMode | Represents an strategy for matching strings using "like".
NaturalIdentifier |
NotEmptyExpression |
NotExpression | Negates another criterion
NotNullExpression | Constrains a property to be non-null
NullExpression | Constrains a property to be null
Order | Represents an order imposed upon a Criteria result set
ProjectionList |
Projections | The criterion package may be used by applications as a framework for building new kinds of Projection.
Property | A factory for property-specific criterion and projection instances
PropertyExpression | superclass for comparisons between two properties (with SQL binary operators)
PropertyProjection | A property value, or grouped property value
PropertySubqueryExpression | A comparison between a property value in the outer query and the result of a subquery
Restrictions | The criterion package may be used by applications as a framework for building new kinds of Criterion.
RowCountProjection | A row count
SimpleExpression | superclass for "simple" comparisons (with SQL binary operators)
SimpleProjection | A single-column projection that may be aliased
SimpleSubqueryExpression | A comparison between a constant value and the the result of a subquery
SizeExpression |
SQLCriterion | A SQL fragment.
SQLProjection | A SQL fragment.
Subqueries | Factory class for criterion instances that represent expressions involving subqueries.
SubqueryExpression |

Package org.hibernate.criterion Description

A framework for defining restriction criteria and order criteria.


org.hibernate.criterion Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.criterion

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.criterion.AbstractEmptinessExpression (implements org.hibernate.criterion.Criterion)
      • class org.hibernate.criterion.EmptyExpression (implements org.hibernate.criterion.Criterion)
      • class org.hibernate.criterion.NotEmptyExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.AliasedProjection (implements org.hibernate.criterion.Projection)
    • class org.hibernate.criterion.BetweenExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.DetachedCriteria (implements org.hibernate.criterion.CriteriaSpecification, java.io.Serializable)
    • class org.hibernate.criterion.Distinct (implements org.hibernate.criterion.Projection)
    • class org.hibernate.criterion.Example (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.IdentifierEqExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.IlikeExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.InExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.Junction (implements org.hibernate.criterion.Criterion)
      • class org.hibernate.criterion.Conjunction
      • class org.hibernate.criterion.Disjunction
    • class org.hibernate.criterion.LikeExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.LogicalExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.MatchMode (implements java.io.Serializable)
    • class org.hibernate.criterion.NaturalIdentifier (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.NotExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.NotNullExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.NullExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.Order (implements java.io.Serializable)
    • class org.hibernate.criterion.ProjectionList (implements org.hibernate.criterion.Projection)
    • class org.hibernate.criterion.Projections
    • class org.hibernate.criterion.PropertyExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.Restrictions
      • class org.hibernate.criterion.Expression
    • class org.hibernate.criterion.SimpleExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.SimpleProjection (implements org.hibernate.criterion.Projection)
      • class org.hibernate.criterion.AggregateProjection
        • class org.hibernate.criterion.AvgProjection
        • class org.hibernate.criterion.CountProjection
      • class org.hibernate.criterion.IdentifierProjection
      • class org.hibernate.criterion.PropertyProjection
        • class org.hibernate.criterion.Property
      • class org.hibernate.criterion.RowCountProjection
    • class org.hibernate.criterion.SizeExpression (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.SQLCriterion (implements org.hibernate.criterion.Criterion)
    • class org.hibernate.criterion.SQLProjection (implements org.hibernate.criterion.Projection)
    • class org.hibernate.criterion.Subqueries
    • class org.hibernate.criterion.SubqueryExpression (implements org.hibernate.criterion.Criterion)
      • class org.hibernate.criterion.ExistsSubqueryExpression
      • class org.hibernate.criterion.PropertySubqueryExpression
      • class org.hibernate.criterion.SimpleSubqueryExpression

Interface Hierarchy

  • interface org.hibernate.criterion.CriteriaQuery
  • interface org.hibernate.criterion.CriteriaSpecification
  • interface java.io.Serializable
    • interface org.hibernate.criterion.Criterion
    • interface org.hibernate.criterion.Example.PropertySelector
    • interface org.hibernate.criterion.Projection


Uses of Package org.hibernate.criterion (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.criterion

Packages that use org.hibernate.criterion
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader

Classes in org.hibernate.criterion used by org.hibernate
CriteriaSpecification
Criterion
An object-oriented representation of a query criterion that may be used as a restriction in a Criteria query.
Order
Represents an order imposed upon a Criteria result set
Projection
An object-oriented representation of a query result set projection in a Criteria query.

Classes in org.hibernate.criterion used by org.hibernate.criterion
AbstractEmptinessExpression
Implementation of AbstractEmptinessExpression.
AggregateProjection
An aggregation
Conjunction
CountProjection
A count
CriteriaQuery
An instance of CriteriaQuery is passed to criterion, order and projection instances when actually compiling and executing the query.
CriteriaSpecification
Criterion
An object-oriented representation of a query criterion that may be used as a restriction in a Criteria query.
DetachedCriteria
Some applications need to create criteria queries in "detached mode", where the Hibernate session is not available.
Disjunction
Example
Support for query by example.
Example.PropertySelector
A strategy for choosing property values for inclusion in the query criteria
IdentifierProjection
A property value, or grouped property value
Junction
A sequence of a logical expressions combined by some associative logical operator
LogicalExpression
Superclass of binary logical expressions
MatchMode
Represents an strategy for matching strings using "like".
NaturalIdentifier
Order
Represents an order imposed upon a Criteria result set
Projection
An object-oriented representation of a query result set projection in a Criteria query.
ProjectionList
Property
A factory for property-specific criterion and projection instances
PropertyExpression
superclass for comparisons between two properties (with SQL binary operators)
PropertyProjection
A property value, or grouped property value
Restrictions
The criterion package may be used by applications as a framework for building new kinds of Criterion.
SimpleExpression
superclass for "simple" comparisons (with SQL binary operators)
SimpleProjection
A single-column projection that may be aliased
SubqueryExpression

Classes in org.hibernate.criterion used by org.hibernate.impl
CriteriaSpecification
Criterion
An object-oriented representation of a query criterion that may be used as a restriction in a Criteria query.
Order
Represents an order imposed upon a Criteria result set
Projection
An object-oriented representation of a query result set projection in a Criteria query.

Classes in org.hibernate.criterion used by org.hibernate.loader.criteria
CriteriaQuery
An instance of CriteriaQuery is passed to criterion, order and projection instances when actually compiling and executing the query.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CriteriaQuery (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Interface CriteriaQuery

All Known Implementing Classes:
CriteriaQueryTranslator
public interface CriteriaQuery

An instance of CriteriaQuery is passed to criterion, order and projection instances when actually compiling and executing the query. This interface is not used by application code.

Author:
Gavin King

Method Summary
String | generateSQLAlias()
String | getColumn(Criteria criteria, String propertyPath) Get the names of the columns mapped by a property path, ignoring projection aliases
String[] | getColumnsUsingProjection(Criteria criteria, String propertyPath) Get the names of the columns mapped by a property path
String | getEntityName(Criteria criteria) Get the entity name of an entity
String | getEntityName(Criteria criteria, String propertyPath) Get the entity name of an entity, taking into account the qualifier of the property path
SessionFactoryImplementor | getFactory()
String[] | getIdentifierColumns(Criteria subcriteria) Get the identifier column names of this entity
Type | getIdentifierType(Criteria subcriteria) Get the identifier type of this entity
String | getPropertyName(String propertyName) Get the property name, given a possibly qualified property name
String | getSQLAlias(Criteria subcriteria) Get the root table alias of an entity
String | getSQLAlias(Criteria criteria, String propertyPath) Get the root table alias of an entity, taking into account the qualifier of the property path
Type | getType(Criteria criteria, String propertyPath) Get the type of a property path, ignoring projection aliases
TypedValue | getTypedIdentifierValue(Criteria subcriteria, Object value)
TypedValue | getTypedValue(Criteria criteria, String propertyPath, Object value) Get the a typed value for the given property value.
Type | getTypeUsingProjection(Criteria criteria, String propertyPath) Get the type of a property path

Method Detail

getFactory

public SessionFactoryImplementor getFactory()

getColumn

public String getColumn(Criteria criteria,
                        String propertyPath)
                 throws HibernateException
Get the names of the columns mapped by a property path, ignoring projection aliases

Throws:
HibernateException

getType

public Type getType(Criteria criteria,
                    String propertyPath)
             throws HibernateException
Get the type of a property path, ignoring projection aliases

Throws:
HibernateException

getColumnsUsingProjection

public String[] getColumnsUsingProjection(Criteria criteria,
                                          String propertyPath)
                                   throws HibernateException
Get the names of the columns mapped by a property path

Throws:
HibernateException

getTypeUsingProjection

public Type getTypeUsingProjection(Criteria criteria,
                                   String propertyPath)
                            throws HibernateException
Get the type of a property path

Throws:
HibernateException

getTypedValue

public TypedValue getTypedValue(Criteria criteria,
                                String propertyPath,
                                Object value)
                         throws HibernateException
Get the a typed value for the given property value.

Throws:
HibernateException

getEntityName

public String getEntityName(Criteria criteria)
Get the entity name of an entity

getEntityName

public String getEntityName(Criteria criteria,
                            String propertyPath)
Get the entity name of an entity, taking into account the qualifier of the property path

getSQLAlias

public String getSQLAlias(Criteria subcriteria)
Get the root table alias of an entity

getSQLAlias

public String getSQLAlias(Criteria criteria,
                          String propertyPath)
Get the root table alias of an entity, taking into account the qualifier of the property path

getPropertyName

public String getPropertyName(String propertyName)
Get the property name, given a possibly qualified property name

getIdentifierColumns

public String[] getIdentifierColumns(Criteria subcriteria)
Get the identifier column names of this entity

getIdentifierType

public Type getIdentifierType(Criteria subcriteria)
Get the identifier type of this entity

getTypedIdentifierValue

public TypedValue getTypedIdentifierValue(Criteria subcriteria,
                                          Object value)

generateSQLAlias

public String generateSQLAlias()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CriteriaSpecification (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Interface CriteriaSpecification

All Known Subinterfaces:
Criteria
All Known Implementing Classes:
CriteriaImpl, CriteriaImpl.Subcriteria, DetachedCriteria
public interface CriteriaSpecification

Author:
Gavin King

Field Summary
static ResultTransformer | ALIAS_TO_ENTITY_MAP Each row of results is a Map from alias to entity instance
static ResultTransformer | DISTINCT_ROOT_ENTITY Each row of results is a distinct instance of the root entity
static int | FULL_JOIN Specifies joining to an entity based on a full join.
static int | INNER_JOIN Specifies joining to an entity based on an inner join.
static int | LEFT_JOIN Specifies joining to an entity based on a left outer join.
static ResultTransformer | PROJECTION This result transformer is selected implicitly by calling setProjection()
static String | ROOT_ALIAS The alias that refers to the "root" entity of the criteria query.
static ResultTransformer | ROOT_ENTITY Each row of results is an instance of the root entity

Field Detail

ROOT_ALIAS

public static final String ROOT_ALIAS
The alias that refers to the "root" entity of the criteria query.

See Also:
Constant Field Values

ALIAS_TO_ENTITY_MAP

public static final ResultTransformer ALIAS_TO_ENTITY_MAP
Each row of results is a Map from alias to entity instance

ROOT_ENTITY

public static final ResultTransformer ROOT_ENTITY
Each row of results is an instance of the root entity

DISTINCT_ROOT_ENTITY

public static final ResultTransformer DISTINCT_ROOT_ENTITY
Each row of results is a distinct instance of the root entity

PROJECTION

public static final ResultTransformer PROJECTION
This result transformer is selected implicitly by calling setProjection()

INNER_JOIN

public static final int INNER_JOIN
Specifies joining to an entity based on an inner join.

See Also:
Constant Field Values

FULL_JOIN

public static final int FULL_JOIN
Specifies joining to an entity based on a full join.

See Also:
Constant Field Values

LEFT_JOIN

public static final int LEFT_JOIN
Specifies joining to an entity based on a left outer join.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Criterion (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Interface Criterion

All Superinterfaces:
Serializable
All Known Implementing Classes:
AbstractEmptinessExpression, BetweenExpression, EmptyExpression, Example, IdentifierEqExpression, IlikeExpression, InExpression, Junction, LikeExpression, LogicalExpression, NaturalIdentifier, NotEmptyExpression, NotExpression, NotNullExpression, NullExpression, PropertyExpression, SimpleExpression, SizeExpression, SQLCriterion, SubqueryExpression
public interface Criterion
extends Serializable

An object-oriented representation of a query criterion that may be used as a restriction in a Criteria query. Built-in criterion types are provided by the Restrictions factory class. This interface might be implemented by application classes that define custom restriction criteria.

Author:
Gavin King
See Also:
Restrictions, Criteria

Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment

Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Render the SQL fragment

Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Return typed values for all parameters in the rendered SQL fragment

Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Projection (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Interface Projection

All Superinterfaces:
Serializable
All Known Implementing Classes:
AliasedProjection, Distinct, ProjectionList, SimpleProjection, SQLProjection
public interface Projection
extends Serializable

An object-oriented representation of a query result set projection in a Criteria query. Built-in projection types are provided by the Projections factory class. This interface might be implemented by application classes that define custom projections.

Author:
Gavin King
See Also:
Projections, Criteria

Method Summary
String[] | getAliases() Get the user-visible aliases for this projection (ie.
String[] | getColumnAliases(int loc) Get the SQL select clause column aliases
String[] | getColumnAliases(String alias, int loc) Get the SQL select clause column aliases for a particular user-visible alias
Type[] | getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
Type[] | getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery) Return types for a particular user-visible alias
boolean | isGrouped() Does this projection specify grouping attributes?
String | toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment to be used in the group by clause
String | toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery) Render the SQL fragment

Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          int position,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Render the SQL fragment

Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

toGroupSqlString

public String toGroupSqlString(Criteria criteria,
                               CriteriaQuery criteriaQuery)
                        throws HibernateException
Render the SQL fragment to be used in the group by clause

Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypes

public Type[] getTypes(Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Return types returned by the rendered SQL fragment

Parameters:
criteria -
criteriaQuery -
Returns:
Type[]
Throws:
HibernateException

getTypes

public Type[] getTypes(String alias,
                       Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Return types for a particular user-visible alias

Throws:
HibernateException

getColumnAliases

public String[] getColumnAliases(int loc)
Get the SQL select clause column aliases

getColumnAliases

public String[] getColumnAliases(String alias,
                                 int loc)
Get the SQL select clause column aliases for a particular user-visible alias

getAliases

public String[] getAliases()
Get the user-visible aliases for this projection (ie. the ones that will be passed to the ResultTransformer)

isGrouped

public boolean isGrouped()
Does this projection specify grouping attributes?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractEmptinessExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class AbstractEmptinessExpression

java.lang.Object
    extended by org.hibernate.criterion.AbstractEmptinessExpression
All Implemented Interfaces:
Criterion, Serializable
Direct Known Subclasses:
EmptyExpression, NotEmptyExpression
public abstract class AbstractEmptinessExpression
extends Object
implements Criterion

Implementation of AbstractEmptinessExpression.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
protected  String propertyName
Constructor Summary
protected AbstractEmptinessExpression(String propertyName)
Method Summary
protected abstract boolean | excludeEmpty()
protected QueryableCollection | getQueryableCollection(String entityName, String propertyName, SessionFactoryImplementor factory)
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

propertyName

protected final String propertyName
Constructor Detail

AbstractEmptinessExpression

protected AbstractEmptinessExpression(String propertyName)
Method Detail

excludeEmpty

protected abstract boolean excludeEmpty()

toSqlString

public final String toSqlString(Criteria criteria,
                                CriteriaQuery criteriaQuery)
                         throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getQueryableCollection

protected QueryableCollection getQueryableCollection(String entityName,
                                                     String propertyName,
                                                     SessionFactoryImplementor factory)
                                              throws HibernateException
Throws:
HibernateException

getTypedValues

public final TypedValue[] getTypedValues(Criteria criteria,
                                         CriteriaQuery criteriaQuery)
                                  throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toString

public final String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AggregateProjection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class AggregateProjection

java.lang.Object
    extended by org.hibernate.criterion.SimpleProjection
        extended by org.hibernate.criterion.AggregateProjection
All Implemented Interfaces:
Projection, Serializable
Direct Known Subclasses:
AvgProjection, CountProjection
public class AggregateProjection
extends SimpleProjection

An aggregation

Author:
max
See Also:
Serialized Form

Field Summary
protected  String propertyName
Constructor Summary
protected AggregateProjection(String aggregate, String propertyName)
Method Summary
Type[] | getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
String | toSqlString(Criteria criteria, int loc, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class org.hibernate.criterion.SimpleProjection
as, getAliases, getColumnAliases, getColumnAliases, getTypes, isGrouped, toGroupSqlString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

propertyName

protected final String propertyName
Constructor Detail

AggregateProjection

protected AggregateProjection(String aggregate,
                              String propertyName)
Method Detail

toString

public String toString()

getTypes

public Type[] getTypes(Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types returned by the rendered SQL fragment

Parameters:
criteria -
criteriaQuery -
Returns:
Type[]
Throws:
HibernateException

toSqlString

public String toSqlString(Criteria criteria,
                          int loc,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Projection
Render the SQL fragment

Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AliasedProjection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class AliasedProjection

java.lang.Object
    extended by org.hibernate.criterion.AliasedProjection
All Implemented Interfaces:
Projection, Serializable
public class AliasedProjection
extends Object
implements Projection

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected AliasedProjection(Projection projection, String alias)
Method Summary
String[] | getAliases() Get the user-visible aliases for this projection (ie.
String[] | getColumnAliases(int loc) Get the SQL select clause column aliases
String[] | getColumnAliases(String alias, int loc) Get the SQL select clause column aliases for a particular user-visible alias
Type[] | getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
Type[] | getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery) Return types for a particular user-visible alias
boolean | isGrouped() Does this projection specify grouping attributes?
String | toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment to be used in the group by clause
String | toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AliasedProjection

protected AliasedProjection(Projection projection,
                            String alias)
Method Detail

toString

public String toString()

toSqlString

public String toSqlString(Criteria criteria,
                          int position,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Projection
Render the SQL fragment

Specified by:
toSqlString in interface Projection
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

toGroupSqlString

public String toGroupSqlString(Criteria criteria,
                               CriteriaQuery criteriaQuery)
                        throws HibernateException
Description copied from interface: Projection
Render the SQL fragment to be used in the group by clause

Specified by:
toGroupSqlString in interface Projection
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypes

public Type[] getTypes(Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types returned by the rendered SQL fragment

Specified by:
getTypes in interface Projection
Parameters:
criteria -
criteriaQuery -
Returns:
Type[]
Throws:
HibernateException

getColumnAliases

public String[] getColumnAliases(int loc)
Description copied from interface: Projection
Get the SQL select clause column aliases

Specified by:
getColumnAliases in interface Projection

getTypes

public Type[] getTypes(String alias,
                       Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types for a particular user-visible alias

Specified by:
getTypes in interface Projection
Throws:
HibernateException

getColumnAliases

public String[] getColumnAliases(String alias,
                                 int loc)
Description copied from interface: Projection
Get the SQL select clause column aliases for a particular user-visible alias

Specified by:
getColumnAliases in interface Projection

getAliases

public String[] getAliases()
Description copied from interface: Projection
Get the user-visible aliases for this projection (ie. the ones that will be passed to the ResultTransformer)

Specified by:
getAliases in interface Projection

isGrouped

public boolean isGrouped()
Description copied from interface: Projection
Does this projection specify grouping attributes?

Specified by:
isGrouped in interface Projection
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AvgProjection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class AvgProjection

java.lang.Object
    extended by org.hibernate.criterion.SimpleProjection
        extended by org.hibernate.criterion.AggregateProjection
            extended by org.hibernate.criterion.AvgProjection
All Implemented Interfaces:
Projection, Serializable
public class AvgProjection
extends AggregateProjection

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.criterion.AggregateProjection
propertyName
Constructor Summary
AvgProjection(String propertyName)
Method Summary
 Type[] getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Return types returned by the rendered SQL fragment
Methods inherited from class org.hibernate.criterion.AggregateProjection
toSqlString, toString
Methods inherited from class org.hibernate.criterion.SimpleProjection
as, getAliases, getColumnAliases, getColumnAliases, getTypes, isGrouped, toGroupSqlString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AvgProjection

public AvgProjection(String propertyName)
Method Detail

getTypes

public Type[] getTypes(Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types returned by the rendered SQL fragment

Specified by:
getTypes in interface Projection
Overrides:
getTypes in class AggregateProjection
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BetweenExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class BetweenExpression

java.lang.Object
    extended by org.hibernate.criterion.BetweenExpression
All Implemented Interfaces:
Criterion, Serializable
public class BetweenExpression
extends Object
implements Criterion

Constrains a property to between two values

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected BetweenExpression(String propertyName, Object lo, Object hi)
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BetweenExpression

protected BetweenExpression(String propertyName,
                            Object lo,
                            Object hi)
Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Conjunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class Conjunction

java.lang.Object
    extended by org.hibernate.criterion.Junction
        extended by org.hibernate.criterion.Conjunction
All Implemented Interfaces:
Criterion, Serializable
public class Conjunction
extends Junction

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
Conjunction()
Methods inherited from class org.hibernate.criterion.Junction
add, getOp, getTypedValues, toSqlString, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Conjunction

public Conjunction()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CountProjection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class CountProjection

java.lang.Object
    extended by org.hibernate.criterion.SimpleProjection
        extended by org.hibernate.criterion.AggregateProjection
            extended by org.hibernate.criterion.CountProjection
All Implemented Interfaces:
Projection, Serializable
public class CountProjection
extends AggregateProjection

A count

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.criterion.AggregateProjection
propertyName
Constructor Summary
protected CountProjection(String prop)
Method Summary
Type[] | getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
CountProjection | setDistinct()
String | toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class org.hibernate.criterion.SimpleProjection
as, getAliases, getColumnAliases, getColumnAliases, getTypes, isGrouped, toGroupSqlString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CountProjection

protected CountProjection(String prop)
Method Detail

toString

public String toString()
Overrides:
toString in class AggregateProjection

getTypes

public Type[] getTypes(Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types returned by the rendered SQL fragment

Specified by:
getTypes in interface Projection
Overrides:
getTypes in class AggregateProjection
Throws:
HibernateException

toSqlString

public String toSqlString(Criteria criteria,
                          int position,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Projection
Render the SQL fragment

Specified by:
toSqlString in interface Projection
Overrides:
toSqlString in class AggregateProjection
Throws:
HibernateException

setDistinct

public CountProjection setDistinct()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DetachedCriteria (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class DetachedCriteria

java.lang.Object
    extended by org.hibernate.criterion.DetachedCriteria
All Implemented Interfaces:
CriteriaSpecification, Serializable
public class DetachedCriteria
extends Object
implements CriteriaSpecification, Serializable

Some applications need to create criteria queries in "detached mode", where the Hibernate session is not available. This class may be instantiated anywhere, and then a Criteria may be obtained by passing a session to getExecutableCriteria(). All methods have the same semantics and behavior as the corresponding methods of the Criteria interface.

Author:
Gavin King
See Also:
Criteria, Serialized Form

Field Summary
Fields inherited from interface org.hibernate.criterion.CriteriaSpecification
ALIAS_TO_ENTITY_MAP, DISTINCT_ROOT_ENTITY, FULL_JOIN, INNER_JOIN, LEFT_JOIN, PROJECTION, ROOT_ALIAS, ROOT_ENTITY
Constructor Summary
protected | DetachedCriteria(CriteriaImpl impl, Criteria criteria)
protected | DetachedCriteria(String entityName)
protected | DetachedCriteria(String entityName, String alias)
Method Summary
DetachedCriteria | add(Criterion criterion)
DetachedCriteria | addOrder(Order order)
DetachedCriteria | createAlias(String associationPath, String alias)
DetachedCriteria | createCriteria(String associationPath)
DetachedCriteria | createCriteria(String associationPath, String alias)
static DetachedCriteria | forClass(Class clazz)
static DetachedCriteria | forClass(Class clazz, String alias)
static DetachedCriteria | forEntityName(String entityName)
static DetachedCriteria | forEntityName(String entityName, String alias)
String | getAlias()
Criteria | getExecutableCriteria(Session session) Get an executable instance of Criteria, to actually run the query.
DetachedCriteria | setFetchMode(String associationPath, FetchMode mode)
DetachedCriteria | setProjection(Projection projection)
DetachedCriteria | setResultTransformer(ResultTransformer resultTransformer)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DetachedCriteria

protected DetachedCriteria(String entityName)

DetachedCriteria

protected DetachedCriteria(String entityName,
                           String alias)

DetachedCriteria

protected DetachedCriteria(CriteriaImpl impl,
                           Criteria criteria)
Method Detail

getExecutableCriteria

public Criteria getExecutableCriteria(Session session)
Get an executable instance of Criteria, to actually run the query.

forEntityName

public static DetachedCriteria forEntityName(String entityName)

forEntityName

public static DetachedCriteria forEntityName(String entityName,
                                             String alias)

forClass

public static DetachedCriteria forClass(Class clazz)

forClass

public static DetachedCriteria forClass(Class clazz,
                                        String alias)

add

public DetachedCriteria add(Criterion criterion)

addOrder

public DetachedCriteria addOrder(Order order)

createAlias

public DetachedCriteria createAlias(String associationPath,
                                    String alias)
                             throws HibernateException
Throws:
HibernateException

createCriteria

public DetachedCriteria createCriteria(String associationPath,
                                       String alias)
                                throws HibernateException
Throws:
HibernateException

createCriteria

public DetachedCriteria createCriteria(String associationPath)
                                throws HibernateException
Throws:
HibernateException

getAlias

public String getAlias()

setFetchMode

public DetachedCriteria setFetchMode(String associationPath,
                                     FetchMode mode)
                              throws HibernateException
Throws:
HibernateException

setProjection

public DetachedCriteria setProjection(Projection projection)

setResultTransformer

public DetachedCriteria setResultTransformer(ResultTransformer resultTransformer)

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Disjunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class Disjunction

java.lang.Object
    extended by org.hibernate.criterion.Junction
        extended by org.hibernate.criterion.Disjunction
All Implemented Interfaces:
Criterion, Serializable
public class Disjunction
extends Junction

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected Disjunction()
Methods inherited from class org.hibernate.criterion.Junction
add, getOp, getTypedValues, toSqlString, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Disjunction

protected Disjunction()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Distinct (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class Distinct

java.lang.Object
    extended by org.hibernate.criterion.Distinct
All Implemented Interfaces:
Projection, Serializable
public class Distinct
extends Object
implements Projection

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
Distinct(Projection proj)
Method Summary
String[] | getAliases() Get the user-visible aliases for this projection (ie.
String[] | getColumnAliases(int loc) Get the SQL select clause column aliases
String[] | getColumnAliases(String alias, int loc) Get the SQL select clause column aliases for a particular user-visible alias
Type[] | getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
Type[] | getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery) Return types for a particular user-visible alias
boolean | isGrouped() Does this projection specify grouping attributes?
String | toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment to be used in the group by clause
String | toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Distinct

public Distinct(Projection proj)
Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          int position,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Projection
Render the SQL fragment

Specified by:
toSqlString in interface Projection
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

toGroupSqlString

public String toGroupSqlString(Criteria criteria,
                               CriteriaQuery criteriaQuery)
                        throws HibernateException
Description copied from interface: Projection
Render the SQL fragment to be used in the group by clause

Specified by:
toGroupSqlString in interface Projection
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypes

public Type[] getTypes(Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types returned by the rendered SQL fragment

Specified by:
getTypes in interface Projection
Parameters:
criteria -
criteriaQuery -
Returns:
Type[]
Throws:
HibernateException

getTypes

public Type[] getTypes(String alias,
                       Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types for a particular user-visible alias

Specified by:
getTypes in interface Projection
Throws:
HibernateException

getColumnAliases

public String[] getColumnAliases(int loc)
Description copied from interface: Projection
Get the SQL select clause column aliases

Specified by:
getColumnAliases in interface Projection

getColumnAliases

public String[] getColumnAliases(String alias,
                                 int loc)
Description copied from interface: Projection
Get the SQL select clause column aliases for a particular user-visible alias

Specified by:
getColumnAliases in interface Projection

getAliases

public String[] getAliases()
Description copied from interface: Projection
Get the user-visible aliases for this projection (ie. the ones that will be passed to the ResultTransformer)

Specified by:
getAliases in interface Projection

isGrouped

public boolean isGrouped()
Description copied from interface: Projection
Does this projection specify grouping attributes?

Specified by:
isGrouped in interface Projection

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmptyExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class EmptyExpression

java.lang.Object
    extended by org.hibernate.criterion.AbstractEmptinessExpression
        extended by org.hibernate.criterion.EmptyExpression
All Implemented Interfaces:
Criterion, Serializable
public class EmptyExpression
extends AbstractEmptinessExpression
implements Criterion

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.criterion.AbstractEmptinessExpression
propertyName
Constructor Summary
protected EmptyExpression(String propertyName)
Method Summary
protected  boolean excludeEmpty()
Methods inherited from class org.hibernate.criterion.AbstractEmptinessExpression
getQueryableCollection, getTypedValues, toSqlString, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.criterion.Criterion
getTypedValues, toSqlString

Constructor Detail

EmptyExpression

protected EmptyExpression(String propertyName)
Method Detail

excludeEmpty

protected boolean excludeEmpty()
Specified by:
excludeEmpty in class AbstractEmptinessExpression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Example (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class Example

java.lang.Object
    extended by org.hibernate.criterion.Example
All Implemented Interfaces:
Criterion, Serializable
public class Example
extends Object
implements Criterion

Support for query by example.

 List results = session.createCriteria(Parent.class)
     .add( Example.create(parent).ignoreCase() )
     .createCriteria("child")
         .add( Example.create( parent.getChild() ) )
     .list();
"Examples" may be mixed and matched with "Expressions" in the same Criteria.

Author:
Gavin King
See Also:
Criteria, Serialized Form

Nested Class Summary
static interface Example.PropertySelector
A strategy for choosing property values for inclusion in the query criteria
Constructor Summary
protected Example(Object entity, Example.PropertySelector selector)
Method Summary
protected void | addComponentTypedValues(String path, Object component, AbstractComponentType type, List list, Criteria criteria, CriteriaQuery criteriaQuery)
protected void | addPropertyTypedValue(Object value, Type type, List list)
protected void | appendComponentCondition(String path, Object component, AbstractComponentType type, Criteria criteria, CriteriaQuery criteriaQuery, StringBuffer buf)
protected void | appendPropertyCondition(String propertyName, Object propertyValue, Criteria criteria, CriteriaQuery cq, StringBuffer buf)
static Example | create(Object entity) Create a new instance, which includes all non-null properties by default
Example | enableLike() Use the "like" operator for all string-valued properties
Example | enableLike(MatchMode matchMode) Use the "like" operator for all string-valued properties
Example | excludeNone() Don't exclude null or zero-valued properties
Example | excludeProperty(String name) Exclude a particular named property
Example | excludeZeroes() Exclude zero-valued properties
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
Example | ignoreCase() Ignore case for all string-valued properties
Example | setEscapeCharacter(Character escapeCharacter) Set escape character for "like" clause
Example | setPropertySelector(Example.PropertySelector selector) Set the property selector
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Example

protected Example(Object entity,
                  Example.PropertySelector selector)
Method Detail

setEscapeCharacter

public Example setEscapeCharacter(Character escapeCharacter)
Set escape character for "like" clause

setPropertySelector

public Example setPropertySelector(Example.PropertySelector selector)
Set the property selector

excludeZeroes

public Example excludeZeroes()
Exclude zero-valued properties

excludeNone

public Example excludeNone()
Don't exclude null or zero-valued properties

enableLike

public Example enableLike(MatchMode matchMode)
Use the "like" operator for all string-valued properties

enableLike

public Example enableLike()
Use the "like" operator for all string-valued properties

ignoreCase

public Example ignoreCase()
Ignore case for all string-valued properties

excludeProperty

public Example excludeProperty(String name)
Exclude a particular named property

create

public static Example create(Object entity)
Create a new instance, which includes all non-null properties by default

Parameters:
entity -
Returns:
a new instance of Example

toString

public String toString()

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

addPropertyTypedValue

protected void addPropertyTypedValue(Object value,
                                     Type type,
                                     List list)

addComponentTypedValues

protected void addComponentTypedValues(String path,
                                       Object component,
                                       AbstractComponentType type,
                                       List list,
                                       Criteria criteria,
                                       CriteriaQuery criteriaQuery)
                                throws HibernateException
Throws:
HibernateException

appendPropertyCondition

protected void appendPropertyCondition(String propertyName,
                                       Object propertyValue,
                                       Criteria criteria,
                                       CriteriaQuery cq,
                                       StringBuffer buf)
                                throws HibernateException
Throws:
HibernateException

appendComponentCondition

protected void appendComponentCondition(String path,
                                        Object component,
                                        AbstractComponentType type,
                                        Criteria criteria,
                                        CriteriaQuery criteriaQuery,
                                        StringBuffer buf)
                                 throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Example.PropertySelector (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Interface Example.PropertySelector

All Superinterfaces:
Serializable
Enclosing interface:
Example
public static interface Example.PropertySelector
extends Serializable

A strategy for choosing property values for inclusion in the query criteria

Method Summary
 boolean include(Object propertyValue, String propertyName, Type type)

Method Detail

include

public boolean include(Object propertyValue,
                       String propertyName,
                       Type type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExistsSubqueryExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class ExistsSubqueryExpression

java.lang.Object
    extended by org.hibernate.criterion.SubqueryExpression
        extended by org.hibernate.criterion.ExistsSubqueryExpression
All Implemented Interfaces:
Criterion, Serializable
public class ExistsSubqueryExpression
extends SubqueryExpression

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected ExistsSubqueryExpression(String quantifier, DetachedCriteria dc)
Method Summary
protected  String toLeftSqlString(Criteria criteria, CriteriaQuery outerQuery)
Methods inherited from class org.hibernate.criterion.SubqueryExpression
getTypedValues, getTypes, toSqlString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExistsSubqueryExpression

protected ExistsSubqueryExpression(String quantifier,
                                   DetachedCriteria dc)
Method Detail

toLeftSqlString

protected String toLeftSqlString(Criteria criteria,
                                 CriteriaQuery outerQuery)
Specified by:
toLeftSqlString in class SubqueryExpression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Expression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class Expression

java.lang.Object
    extended by org.hibernate.criterion.Restrictions
        extended by org.hibernate.criterion.Expression
public final class Expression
extends Restrictions

This class is semi-deprecated. Use Restrictions.

Author:
Gavin King
See Also:
Restrictions

Method Summary
static Criterion | sql(String sql) Apply a constraint expressed in SQL.
static Criterion | sql(String sql, Object[] values, Type[] types) Apply a constraint expressed in SQL, with the given JDBC parameters.
static Criterion | sql(String sql, Object value, Type type) Apply a constraint expressed in SQL, with the given JDBC parameter.
Methods inherited from class org.hibernate.criterion.Restrictions
allEq, and, between, conjunction, disjunction, eq, eqProperty, ge, geProperty, gt, gtProperty, idEq, ilike, ilike, in, in, isEmpty, isNotEmpty, isNotNull, isNull, le, leProperty, like, like, lt, ltProperty, naturalId, ne, neProperty, not, or, sizeEq, sizeGe, sizeGt, sizeLe, sizeLt, sizeNe, sqlRestriction, sqlRestriction, sqlRestriction
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

sql

public static Criterion sql(String sql,
                            Object[] values,
                            Type[] types)
Apply a constraint expressed in SQL, with the given JDBC parameters. Any occurrences of {alias} will be replaced by the table alias.

Parameters:
sql -
values -
types -
Returns:
Criterion

sql

public static Criterion sql(String sql,
                            Object value,
                            Type type)
Apply a constraint expressed in SQL, with the given JDBC parameter. Any occurrences of {alias} will be replaced by the table alias.

Parameters:
sql -
value -
type -
Returns:
Criterion

sql

public static Criterion sql(String sql)
Apply a constraint expressed in SQL. Any occurrences of {alias} will be replaced by the table alias.

Parameters:
sql -
Returns:
Criterion
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentifierEqExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class IdentifierEqExpression

java.lang.Object
    extended by org.hibernate.criterion.IdentifierEqExpression
All Implemented Interfaces:
Criterion, Serializable
public class IdentifierEqExpression
extends Object
implements Criterion

An identifier constraint

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected IdentifierEqExpression(Object value)
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IdentifierEqExpression

protected IdentifierEqExpression(Object value)
Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentifierProjection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class IdentifierProjection

java.lang.Object
    extended by org.hibernate.criterion.SimpleProjection
        extended by org.hibernate.criterion.IdentifierProjection
All Implemented Interfaces:
Projection, Serializable
public class IdentifierProjection
extends SimpleProjection

A property value, or grouped property value

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected | IdentifierProjection()
protected | IdentifierProjection(boolean grouped)
Method Summary
Type[] | getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
boolean | isGrouped() Does this projection specify grouping attributes?
String | toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment to be used in the group by clause
String | toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class org.hibernate.criterion.SimpleProjection
as, getAliases, getColumnAliases, getColumnAliases, getTypes
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IdentifierProjection

protected IdentifierProjection(boolean grouped)

IdentifierProjection

protected IdentifierProjection()
Method Detail

toString

public String toString()

getTypes

public Type[] getTypes(Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types returned by the rendered SQL fragment

Parameters:
criteria -
criteriaQuery -
Returns:
Type[]
Throws:
HibernateException

toSqlString

public String toSqlString(Criteria criteria,
                          int position,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Projection
Render the SQL fragment

Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

isGrouped

public boolean isGrouped()
Description copied from interface: Projection
Does this projection specify grouping attributes?

Specified by:
isGrouped in interface Projection
Overrides:
isGrouped in class SimpleProjection

toGroupSqlString

public String toGroupSqlString(Criteria criteria,
                               CriteriaQuery criteriaQuery)
                        throws HibernateException
Description copied from interface: Projection
Render the SQL fragment to be used in the group by clause

Specified by:
toGroupSqlString in interface Projection
Overrides:
toGroupSqlString in class SimpleProjection
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IlikeExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class IlikeExpression

java.lang.Object
    extended by org.hibernate.criterion.IlikeExpression
All Implemented Interfaces:
Criterion, Serializable
public class IlikeExpression
extends Object
implements Criterion

A case-insensitive "like"

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected | IlikeExpression(String propertyName, Object value)
protected | IlikeExpression(String propertyName, String value, MatchMode matchMode)
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IlikeExpression

protected IlikeExpression(String propertyName,
                          Object value)

IlikeExpression

protected IlikeExpression(String propertyName,
                          String value,
                          MatchMode matchMode)
Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class InExpression

java.lang.Object
    extended by org.hibernate.criterion.InExpression
All Implemented Interfaces:
Criterion, Serializable
public class InExpression
extends Object
implements Criterion

Constrains the property to a specified list of values

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected InExpression(String propertyName, Object[] values)
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InExpression

protected InExpression(String propertyName,
                       Object[] values)
Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Junction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class Junction

java.lang.Object
    extended by org.hibernate.criterion.Junction
All Implemented Interfaces:
Criterion, Serializable
Direct Known Subclasses:
Conjunction, Disjunction
public class Junction
extends Object
implements Criterion

A sequence of a logical expressions combined by some associative logical operator

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected Junction(String op)
Method Summary
Junction | add(Criterion criterion)
String | getOp()
TypedValue[] | getTypedValues(Criteria crit, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria crit, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Junction

protected Junction(String op)
Method Detail

add

public Junction add(Criterion criterion)

getOp

public String getOp()

getTypedValues

public TypedValue[] getTypedValues(Criteria crit,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
crit - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toSqlString

public String toSqlString(Criteria crit,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

toString

public String toString()
See Also:
Object.toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LikeExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class LikeExpression

java.lang.Object
    extended by org.hibernate.criterion.LikeExpression
All Implemented Interfaces:
Criterion, Serializable
public class LikeExpression
extends Object
implements Criterion

A criterion representing a "like" expression

Author:
Scott Marlow, Steve Ebersole
See Also:
Serialized Form

Constructor Summary
protected | LikeExpression(String propertyName, String value)
protected | LikeExpression(String propertyName, String value, Character escapeChar, boolean ignoreCase)
protected | LikeExpression(String propertyName, String value, MatchMode matchMode)
protected | LikeExpression(String propertyName, String value, MatchMode matchMode, Character escapeChar, boolean ignoreCase)
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LikeExpression

protected LikeExpression(String propertyName,
                         String value,
                         Character escapeChar,
                         boolean ignoreCase)

LikeExpression

protected LikeExpression(String propertyName,
                         String value)

LikeExpression

protected LikeExpression(String propertyName,
                         String value,
                         MatchMode matchMode)

LikeExpression

protected LikeExpression(String propertyName,
                         String value,
                         MatchMode matchMode,
                         Character escapeChar,
                         boolean ignoreCase)
Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LogicalExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class LogicalExpression

java.lang.Object
    extended by org.hibernate.criterion.LogicalExpression
All Implemented Interfaces:
Criterion, Serializable
public class LogicalExpression
extends Object
implements Criterion

Superclass of binary logical expressions

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected LogicalExpression(Criterion lhs, Criterion rhs, String op)
Method Summary
String | getOp()
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LogicalExpression

protected LogicalExpression(Criterion lhs,
                            Criterion rhs,
                            String op)
Method Detail

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getOp

public String getOp()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MatchMode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class MatchMode

java.lang.Object
    extended by org.hibernate.criterion.MatchMode
All Implemented Interfaces:
Serializable
public abstract class MatchMode
extends Object
implements Serializable

Represents an strategy for matching strings using "like".

Author:
Gavin King
See Also:
Example.enableLike(MatchMode), Serialized Form

Field Summary
static MatchMode | ANYWHERE Match the pattern anywhere in the string
static MatchMode | END Match the end of the string to the pattern
static MatchMode | EXACT Match the entire string to the pattern
static MatchMode | START Match the start of the string to the pattern
Constructor Summary
protected MatchMode(String name)
Method Summary
abstract String | toMatchString(String pattern) convert the pattern, by appending/prepending "%"
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

EXACT

public static final MatchMode EXACT
Match the entire string to the pattern

START

public static final MatchMode START
Match the start of the string to the pattern

END

public static final MatchMode END
Match the end of the string to the pattern

ANYWHERE

public static final MatchMode ANYWHERE
Match the pattern anywhere in the string

Constructor Detail

MatchMode

protected MatchMode(String name)
Method Detail

toString

public String toString()

toMatchString

public abstract String toMatchString(String pattern)
convert the pattern, by appending/prepending "%"

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NaturalIdentifier (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class NaturalIdentifier

java.lang.Object
    extended by org.hibernate.criterion.NaturalIdentifier
All Implemented Interfaces:
Criterion, Serializable
public class NaturalIdentifier
extends Object
implements Criterion

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
NaturalIdentifier()
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
NaturalIdentifier | set(String property, Object value)
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NaturalIdentifier

public NaturalIdentifier()
Method Detail

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

set

public NaturalIdentifier set(String property,
                             Object value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NotEmptyExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class NotEmptyExpression

java.lang.Object
    extended by org.hibernate.criterion.AbstractEmptinessExpression
        extended by org.hibernate.criterion.NotEmptyExpression
All Implemented Interfaces:
Criterion, Serializable
public class NotEmptyExpression
extends AbstractEmptinessExpression
implements Criterion

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.criterion.AbstractEmptinessExpression
propertyName
Constructor Summary
protected NotEmptyExpression(String propertyName)
Method Summary
protected  boolean excludeEmpty()
Methods inherited from class org.hibernate.criterion.AbstractEmptinessExpression
getQueryableCollection, getTypedValues, toSqlString, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.criterion.Criterion
getTypedValues, toSqlString

Constructor Detail

NotEmptyExpression

protected NotEmptyExpression(String propertyName)
Method Detail

excludeEmpty

protected boolean excludeEmpty()
Specified by:
excludeEmpty in class AbstractEmptinessExpression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NotExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class NotExpression

java.lang.Object
    extended by org.hibernate.criterion.NotExpression
All Implemented Interfaces:
Criterion, Serializable
public class NotExpression
extends Object
implements Criterion

Negates another criterion

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected NotExpression(Criterion criterion)
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NotExpression

protected NotExpression(Criterion criterion)
Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NotNullExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class NotNullExpression

java.lang.Object
    extended by org.hibernate.criterion.NotNullExpression
All Implemented Interfaces:
Criterion, Serializable
public class NotNullExpression
extends Object
implements Criterion

Constrains a property to be non-null

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected NotNullExpression(String propertyName)
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NotNullExpression

protected NotNullExpression(String propertyName)
Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NullExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class NullExpression

java.lang.Object
    extended by org.hibernate.criterion.NullExpression
All Implemented Interfaces:
Criterion, Serializable
public class NullExpression
extends Object
implements Criterion

Constrains a property to be null

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected NullExpression(String propertyName)
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NullExpression

protected NullExpression(String propertyName)
Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Order (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class Order

java.lang.Object
    extended by org.hibernate.criterion.Order
All Implemented Interfaces:
Serializable
public class Order
extends Object
implements Serializable

Represents an order imposed upon a Criteria result set

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected Order(String propertyName, boolean ascending)
Constructor for Order.
Method Summary
static Order | asc(String propertyName) Ascending order
static Order | desc(String propertyName) Descending order
Order | ignoreCase()
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Order

protected Order(String propertyName,
                boolean ascending)
Constructor for Order.

Method Detail

toString

public String toString()

ignoreCase

public Order ignoreCase()

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Render the SQL fragment

Throws:
HibernateException

asc

public static Order asc(String propertyName)
Ascending order

Parameters:
propertyName -
Returns:
Order

desc

public static Order desc(String propertyName)
Descending order

Parameters:
propertyName -
Returns:
Order
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProjectionList (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class ProjectionList

java.lang.Object
    extended by org.hibernate.criterion.ProjectionList
All Implemented Interfaces:
Projection, Serializable
public class ProjectionList
extends Object
implements Projection

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected ProjectionList()
Method Summary
ProjectionList | add(Projection proj)
ProjectionList | add(Projection projection, String alias)
ProjectionList | create()
String[] | getAliases() Get the user-visible aliases for this projection (ie.
String[] | getColumnAliases(int loc) Get the SQL select clause column aliases
String[] | getColumnAliases(String alias, int loc) Get the SQL select clause column aliases for a particular user-visible alias
int | getLength()
Projection | getProjection(int i)
Type[] | getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
Type[] | getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery) Return types for a particular user-visible alias
boolean | isGrouped() Does this projection specify grouping attributes?
String | toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment to be used in the group by clause
String | toSqlString(Criteria criteria, int loc, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ProjectionList

protected ProjectionList()
Method Detail

create

public ProjectionList create()

add

public ProjectionList add(Projection proj)

add

public ProjectionList add(Projection projection,
                          String alias)

getTypes

public Type[] getTypes(Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types returned by the rendered SQL fragment

Specified by:
getTypes in interface Projection
Parameters:
criteria -
criteriaQuery -
Returns:
Type[]
Throws:
HibernateException

toSqlString

public String toSqlString(Criteria criteria,
                          int loc,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Projection
Render the SQL fragment

Specified by:
toSqlString in interface Projection
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

toGroupSqlString

public String toGroupSqlString(Criteria criteria,
                               CriteriaQuery criteriaQuery)
                        throws HibernateException
Description copied from interface: Projection
Render the SQL fragment to be used in the group by clause

Specified by:
toGroupSqlString in interface Projection
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getColumnAliases

public String[] getColumnAliases(int loc)
Description copied from interface: Projection
Get the SQL select clause column aliases

Specified by:
getColumnAliases in interface Projection

getColumnAliases

public String[] getColumnAliases(String alias,
                                 int loc)
Description copied from interface: Projection
Get the SQL select clause column aliases for a particular user-visible alias

Specified by:
getColumnAliases in interface Projection

getTypes

public Type[] getTypes(String alias,
                       Criteria criteria,
                       CriteriaQuery criteriaQuery)
Description copied from interface: Projection
Return types for a particular user-visible alias

Specified by:
getTypes in interface Projection

getAliases

public String[] getAliases()
Description copied from interface: Projection
Get the user-visible aliases for this projection (ie. the ones that will be passed to the ResultTransformer)

Specified by:
getAliases in interface Projection

getProjection

public Projection getProjection(int i)

getLength

public int getLength()

toString

public String toString()

isGrouped

public boolean isGrouped()
Description copied from interface: Projection
Does this projection specify grouping attributes?

Specified by:
isGrouped in interface Projection
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Projections (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class Projections

java.lang.Object
    extended by org.hibernate.criterion.Projections
public final class Projections
extends Object

The criterion package may be used by applications as a framework for building new kinds of Projection. However, it is intended that most applications will simply use the built-in projection types via the static factory methods of this class.

The factory methods that take an alias allow the projected value to be referred to by criterion and order instances.

Author:
Gavin King
See Also:
Criteria, factory methods for Criterion instances

Method Summary
static Projection | alias(Projection projection, String alias) Assign an alias to a projection, by wrapping it
static AggregateProjection | avg(String propertyName) A property average value
static CountProjection | count(String propertyName) A property value count
static CountProjection | countDistinct(String propertyName) A distinct property value count
static Projection | distinct(Projection proj) Create a distinct projection from a projection
static PropertyProjection | groupProperty(String propertyName) A grouping property value
static IdentifierProjection | id() A projected identifier value
static AggregateProjection | max(String propertyName) A property maximum value
static AggregateProjection | min(String propertyName) A property minimum value
static ProjectionList | projectionList() Create a new projection list
static PropertyProjection | property(String propertyName) A projected property value
static Projection | rowCount() The query row count, ie.
static Projection | sqlGroupProjection(String sql, String groupBy, String[] columnAliases, Type[] types) A grouping SQL projection, specifying both select clause and group by clause fragments
static Projection | sqlProjection(String sql, String[] columnAliases, Type[] types) A SQL projection, a typed select clause fragment
static AggregateProjection | sum(String propertyName) A property value sum
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

distinct

public static Projection distinct(Projection proj)
Create a distinct projection from a projection

projectionList

public static ProjectionList projectionList()
Create a new projection list

rowCount

public static Projection rowCount()
The query row count, ie. count(*)

count

public static CountProjection count(String propertyName)
A property value count

countDistinct

public static CountProjection countDistinct(String propertyName)
A distinct property value count

max

public static AggregateProjection max(String propertyName)
A property maximum value

min

public static AggregateProjection min(String propertyName)
A property minimum value

avg

public static AggregateProjection avg(String propertyName)
A property average value

sum

public static AggregateProjection sum(String propertyName)
A property value sum

sqlProjection

public static Projection sqlProjection(String sql,
                                       String[] columnAliases,
                                       Type[] types)
A SQL projection, a typed select clause fragment

sqlGroupProjection

public static Projection sqlGroupProjection(String sql,
                                            String groupBy,
                                            String[] columnAliases,
                                            Type[] types)
A grouping SQL projection, specifying both select clause and group by clause fragments

groupProperty

public static PropertyProjection groupProperty(String propertyName)
A grouping property value

property

public static PropertyProjection property(String propertyName)
A projected property value

id

public static IdentifierProjection id()
A projected identifier value

alias

public static Projection alias(Projection projection,
                               String alias)
Assign an alias to a projection, by wrapping it

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Property (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class Property

java.lang.Object
    extended by org.hibernate.criterion.SimpleProjection
        extended by org.hibernate.criterion.PropertyProjection
            extended by org.hibernate.criterion.Property
All Implemented Interfaces:
Projection, Serializable
public class Property
extends PropertyProjection

A factory for property-specific criterion and projection instances

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected Property(String propertyName)
Method Summary
Order | asc()
AggregateProjection | avg()
Criterion | between(Object min, Object max)
CountProjection | count()
Order | desc()
Criterion | eq(DetachedCriteria subselect)
SimpleExpression | eq(Object value)
Criterion | eqAll(DetachedCriteria subselect)
PropertyExpression | eqProperty(Property other)
PropertyExpression | eqProperty(String other)
static Property | forName(String propertyName)
Criterion | ge(DetachedCriteria subselect)
SimpleExpression | ge(Object value)
Criterion | geAll(DetachedCriteria subselect)
PropertyExpression | geProperty(Property other)
PropertyExpression | geProperty(String other)
Criterion | geSome(DetachedCriteria subselect)
Property | getProperty(String propertyName) Get a component attribute of this property
PropertyProjection | group()
Criterion | gt(DetachedCriteria subselect)
SimpleExpression | gt(Object value)
Criterion | gtAll(DetachedCriteria subselect)
PropertyExpression | gtProperty(Property other)
PropertyExpression | gtProperty(String other)
Criterion | gtSome(DetachedCriteria subselect)
Criterion | in(Collection values)
Criterion | in(DetachedCriteria subselect)
Criterion | in(Object[] values)
Criterion | isEmpty()
Criterion | isNotEmpty()
Criterion | isNotNull()
Criterion | isNull()
Criterion | le(DetachedCriteria subselect)
SimpleExpression | le(Object value)
Criterion | leAll(DetachedCriteria subselect)
PropertyExpression | leProperty(Property other)
PropertyExpression | leProperty(String other)
Criterion | leSome(DetachedCriteria subselect)
SimpleExpression | like(Object value)
SimpleExpression | like(String value, MatchMode matchMode)
Criterion | lt(DetachedCriteria subselect)
SimpleExpression | lt(Object value)
Criterion | ltAll(DetachedCriteria subselect)
PropertyExpression | ltProperty(Property other)
PropertyExpression | ltProperty(String other)
Criterion | ltSome(DetachedCriteria subselect)
AggregateProjection | max()
AggregateProjection | min()
Criterion | ne(DetachedCriteria subselect)
SimpleExpression | ne(Object value)
PropertyExpression | neProperty(Property other)
PropertyExpression | neProperty(String other)
Criterion | notIn(DetachedCriteria subselect)
Methods inherited from class org.hibernate.criterion.PropertyProjection
getPropertyName, getTypes, isGrouped, toGroupSqlString, toSqlString, toString
Methods inherited from class org.hibernate.criterion.SimpleProjection
as, getAliases, getColumnAliases, getColumnAliases, getTypes
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Property

protected Property(String propertyName)
Method Detail

between

public Criterion between(Object min,
                         Object max)

in

public Criterion in(Collection values)

in

public Criterion in(Object[] values)

like

public SimpleExpression like(Object value)

like

public SimpleExpression like(String value,
                             MatchMode matchMode)

eq

public SimpleExpression eq(Object value)

ne

public SimpleExpression ne(Object value)

gt

public SimpleExpression gt(Object value)

lt

public SimpleExpression lt(Object value)

le

public SimpleExpression le(Object value)

ge

public SimpleExpression ge(Object value)

eqProperty

public PropertyExpression eqProperty(Property other)

neProperty

public PropertyExpression neProperty(Property other)

leProperty

public PropertyExpression leProperty(Property other)

geProperty

public PropertyExpression geProperty(Property other)

ltProperty

public PropertyExpression ltProperty(Property other)

gtProperty

public PropertyExpression gtProperty(Property other)

eqProperty

public PropertyExpression eqProperty(String other)

neProperty

public PropertyExpression neProperty(String other)

leProperty

public PropertyExpression leProperty(String other)

geProperty

public PropertyExpression geProperty(String other)

ltProperty

public PropertyExpression ltProperty(String other)

gtProperty

public PropertyExpression gtProperty(String other)

isNull

public Criterion isNull()

isNotNull

public Criterion isNotNull()

isEmpty

public Criterion isEmpty()

isNotEmpty

public Criterion isNotEmpty()

count

public CountProjection count()

max

public AggregateProjection max()

min

public AggregateProjection min()

avg

public AggregateProjection avg()

group

public PropertyProjection group()

asc

public Order asc()

desc

public Order desc()

forName

public static Property forName(String propertyName)

getProperty

public Property getProperty(String propertyName)
Get a component attribute of this property

eq

public Criterion eq(DetachedCriteria subselect)

ne

public Criterion ne(DetachedCriteria subselect)

lt

public Criterion lt(DetachedCriteria subselect)

le

public Criterion le(DetachedCriteria subselect)

gt

public Criterion gt(DetachedCriteria subselect)

ge

public Criterion ge(DetachedCriteria subselect)

notIn

public Criterion notIn(DetachedCriteria subselect)

in

public Criterion in(DetachedCriteria subselect)

eqAll

public Criterion eqAll(DetachedCriteria subselect)

gtAll

public Criterion gtAll(DetachedCriteria subselect)

ltAll

public Criterion ltAll(DetachedCriteria subselect)

leAll

public Criterion leAll(DetachedCriteria subselect)

geAll

public Criterion geAll(DetachedCriteria subselect)

gtSome

public Criterion gtSome(DetachedCriteria subselect)

ltSome

public Criterion ltSome(DetachedCriteria subselect)

leSome

public Criterion leSome(DetachedCriteria subselect)

geSome

public Criterion geSome(DetachedCriteria subselect)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class PropertyExpression

java.lang.Object
    extended by org.hibernate.criterion.PropertyExpression
All Implemented Interfaces:
Criterion, Serializable
public class PropertyExpression
extends Object
implements Criterion

superclass for comparisons between two properties (with SQL binary operators)

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected PropertyExpression(String propertyName, String otherPropertyName, String op)
Method Summary
String | getOp()
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PropertyExpression

protected PropertyExpression(String propertyName,
                             String otherPropertyName,
                             String op)
Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toString

public String toString()

getOp

public String getOp()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyProjection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class PropertyProjection

java.lang.Object
    extended by org.hibernate.criterion.SimpleProjection
        extended by org.hibernate.criterion.PropertyProjection
All Implemented Interfaces:
Projection, Serializable
Direct Known Subclasses:
Property
public class PropertyProjection
extends SimpleProjection

A property value, or grouped property value

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected | PropertyProjection(String prop)
protected | PropertyProjection(String prop, boolean grouped)
Method Summary
String | getPropertyName()
Type[] | getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
boolean | isGrouped() Does this projection specify grouping attributes?
String | toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment to be used in the group by clause
String | toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class org.hibernate.criterion.SimpleProjection
as, getAliases, getColumnAliases, getColumnAliases, getTypes
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PropertyProjection

protected PropertyProjection(String prop,
                             boolean grouped)

PropertyProjection

protected PropertyProjection(String prop)
Method Detail

getPropertyName

public String getPropertyName()

toString

public String toString()

getTypes

public Type[] getTypes(Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types returned by the rendered SQL fragment

Parameters:
criteria -
criteriaQuery -
Returns:
Type[]
Throws:
HibernateException

toSqlString

public String toSqlString(Criteria criteria,
                          int position,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Projection
Render the SQL fragment

Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

isGrouped

public boolean isGrouped()
Description copied from interface: Projection
Does this projection specify grouping attributes?

Specified by:
isGrouped in interface Projection
Overrides:
isGrouped in class SimpleProjection

toGroupSqlString

public String toGroupSqlString(Criteria criteria,
                               CriteriaQuery criteriaQuery)
                        throws HibernateException
Description copied from interface: Projection
Render the SQL fragment to be used in the group by clause

Specified by:
toGroupSqlString in interface Projection
Overrides:
toGroupSqlString in class SimpleProjection
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertySubqueryExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class PropertySubqueryExpression

java.lang.Object
    extended by org.hibernate.criterion.SubqueryExpression
        extended by org.hibernate.criterion.PropertySubqueryExpression
All Implemented Interfaces:
Criterion, Serializable
public class PropertySubqueryExpression
extends SubqueryExpression

A comparison between a property value in the outer query and the result of a subquery

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected PropertySubqueryExpression(String propertyName, String op, String quantifier, DetachedCriteria dc)
Method Summary
protected  String toLeftSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Methods inherited from class org.hibernate.criterion.SubqueryExpression
getTypedValues, getTypes, toSqlString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PropertySubqueryExpression

protected PropertySubqueryExpression(String propertyName,
                                     String op,
                                     String quantifier,
                                     DetachedCriteria dc)
Method Detail

toLeftSqlString

protected String toLeftSqlString(Criteria criteria,
                                 CriteriaQuery criteriaQuery)
Specified by:
toLeftSqlString in class SubqueryExpression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Restrictions (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class Restrictions

java.lang.Object
    extended by org.hibernate.criterion.Restrictions
Direct Known Subclasses:
Expression
public class Restrictions
extends Object

The criterion package may be used by applications as a framework for building new kinds of Criterion. However, it is intended that most applications will simply use the built-in criterion types via the static factory methods of this class.

Author:
Gavin King
See Also:
Criteria, factory methods for Projection instances

Method Summary
static Criterion | allEq(Map propertyNameValues) Apply an "equals" constraint to each property in the key set of a Map
static LogicalExpression | and(Criterion lhs, Criterion rhs) Return the conjuction of two expressions
static Criterion | between(String propertyName, Object lo, Object hi) Apply a "between" constraint to the named property
static Conjunction | conjunction() Group expressions together in a single conjunction (A and B and C...)
static Disjunction | disjunction() Group expressions together in a single disjunction (A or B or C...)
static SimpleExpression | eq(String propertyName, Object value) Apply an "equal" constraint to the named property
static PropertyExpression | eqProperty(String propertyName, String otherPropertyName) Apply an "equal" constraint to two properties
static SimpleExpression | ge(String propertyName, Object value) Apply a "greater than or equal" constraint to the named property
static PropertyExpression | geProperty(String propertyName, String otherPropertyName) Apply a "greater than or equal" constraint to two properties
static SimpleExpression | gt(String propertyName, Object value) Apply a "greater than" constraint to the named property
static PropertyExpression | gtProperty(String propertyName, String otherPropertyName) Apply a "greater than" constraint to two properties
static Criterion | idEq(Object value) Apply an "equal" constraint to the identifier property
static Criterion | ilike(String propertyName, Object value) A case-insensitive "like", similar to Postgres ilike operator
static Criterion | ilike(String propertyName, String value, MatchMode matchMode) A case-insensitive "like", similar to Postgres ilike operator
static Criterion | in(String propertyName, Collection values) Apply an "in" constraint to the named property
static Criterion | in(String propertyName, Object[] values) Apply an "in" constraint to the named property
static Criterion | isEmpty(String propertyName) Constrain a collection valued property to be empty
static Criterion | isNotEmpty(String propertyName) Constrain a collection valued property to be non-empty
static Criterion | isNotNull(String propertyName) Apply an "is not null" constraint to the named property
static Criterion | isNull(String propertyName) Apply an "is null" constraint to the named property
static SimpleExpression | le(String propertyName, Object value) Apply a "less than or equal" constraint to the named property
static PropertyExpression | leProperty(String propertyName, String otherPropertyName) Apply a "less than or equal" constraint to two properties
static SimpleExpression | like(String propertyName, Object value) Apply a "like" constraint to the named property
static SimpleExpression | like(String propertyName, String value, MatchMode matchMode) Apply a "like" constraint to the named property
static SimpleExpression | lt(String propertyName, Object value) Apply a "less than" constraint to the named property
static PropertyExpression | ltProperty(String propertyName, String otherPropertyName) Apply a "less than" constraint to two properties
static NaturalIdentifier | naturalId()
static SimpleExpression | ne(String propertyName, Object value) Apply a "not equal" constraint to the named property
static PropertyExpression | neProperty(String propertyName, String otherPropertyName) Apply a "not equal" constraint to two properties
static Criterion | not(Criterion expression) Return the negation of an expression
static LogicalExpression | or(Criterion lhs, Criterion rhs) Return the disjuction of two expressions
static Criterion | sizeEq(String propertyName, int size) Constrain a collection valued property by size
static Criterion | sizeGe(String propertyName, int size) Constrain a collection valued property by size
static Criterion | sizeGt(String propertyName, int size) Constrain a collection valued property by size
static Criterion | sizeLe(String propertyName, int size) Constrain a collection valued property by size
static Criterion | sizeLt(String propertyName, int size) Constrain a collection valued property by size
static Criterion | sizeNe(String propertyName, int size) Constrain a collection valued property by size
static Criterion | sqlRestriction(String sql) Apply a constraint expressed in SQL.
static Criterion | sqlRestriction(String sql, Object[] values, Type[] types) Apply a constraint expressed in SQL, with the given JDBC parameters.
static Criterion | sqlRestriction(String sql, Object value, Type type) Apply a constraint expressed in SQL, with the given JDBC parameter.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

idEq

public static Criterion idEq(Object value)
Apply an "equal" constraint to the identifier property

Parameters:
value -
Returns:
Criterion

eq

public static SimpleExpression eq(String propertyName,
                                  Object value)
Apply an "equal" constraint to the named property

Parameters:
propertyName -
value -
Returns:
Criterion

ne

public static SimpleExpression ne(String propertyName,
                                  Object value)
Apply a "not equal" constraint to the named property

Parameters:
propertyName -
value -
Returns:
Criterion

like

public static SimpleExpression like(String propertyName,
                                    Object value)
Apply a "like" constraint to the named property

Parameters:
propertyName -
value -
Returns:
Criterion

like

public static SimpleExpression like(String propertyName,
                                    String value,
                                    MatchMode matchMode)
Apply a "like" constraint to the named property

Parameters:
propertyName -
value -
Returns:
Criterion

ilike

public static Criterion ilike(String propertyName,
                              String value,
                              MatchMode matchMode)
A case-insensitive "like", similar to Postgres ilike operator

Parameters:
propertyName -
value -
Returns:
Criterion

ilike

public static Criterion ilike(String propertyName,
                              Object value)
A case-insensitive "like", similar to Postgres ilike operator

Parameters:
propertyName -
value -
Returns:
Criterion

gt

public static SimpleExpression gt(String propertyName,
                                  Object value)
Apply a "greater than" constraint to the named property

Parameters:
propertyName -
value -
Returns:
Criterion

lt

public static SimpleExpression lt(String propertyName,
                                  Object value)
Apply a "less than" constraint to the named property

Parameters:
propertyName -
value -
Returns:
Criterion

le

public static SimpleExpression le(String propertyName,
                                  Object value)
Apply a "less than or equal" constraint to the named property

Parameters:
propertyName -
value -
Returns:
Criterion

ge

public static SimpleExpression ge(String propertyName,
                                  Object value)
Apply a "greater than or equal" constraint to the named property

Parameters:
propertyName -
value -
Returns:
Criterion

between

public static Criterion between(String propertyName,
                                Object lo,
                                Object hi)
Apply a "between" constraint to the named property

Parameters:
propertyName -
lo - value
hi - value
Returns:
Criterion

in

public static Criterion in(String propertyName,
                           Object[] values)
Apply an "in" constraint to the named property

Parameters:
propertyName -
values -
Returns:
Criterion

in

public static Criterion in(String propertyName,
                           Collection values)
Apply an "in" constraint to the named property

Parameters:
propertyName -
values -
Returns:
Criterion

isNull

public static Criterion isNull(String propertyName)
Apply an "is null" constraint to the named property

Returns:
Criterion

eqProperty

public static PropertyExpression eqProperty(String propertyName,
                                            String otherPropertyName)
Apply an "equal" constraint to two properties

neProperty

public static PropertyExpression neProperty(String propertyName,
                                            String otherPropertyName)
Apply a "not equal" constraint to two properties

ltProperty

public static PropertyExpression ltProperty(String propertyName,
                                            String otherPropertyName)
Apply a "less than" constraint to two properties

leProperty

public static PropertyExpression leProperty(String propertyName,
                                            String otherPropertyName)
Apply a "less than or equal" constraint to two properties

gtProperty

public static PropertyExpression gtProperty(String propertyName,
                                            String otherPropertyName)
Apply a "greater than" constraint to two properties

geProperty

public static PropertyExpression geProperty(String propertyName,
                                            String otherPropertyName)
Apply a "greater than or equal" constraint to two properties

isNotNull

public static Criterion isNotNull(String propertyName)
Apply an "is not null" constraint to the named property

Returns:
Criterion

and

public static LogicalExpression and(Criterion lhs,
                                    Criterion rhs)
Return the conjuction of two expressions

Parameters:
lhs -
rhs -
Returns:
Criterion

or

public static LogicalExpression or(Criterion lhs,
                                   Criterion rhs)
Return the disjuction of two expressions

Parameters:
lhs -
rhs -
Returns:
Criterion

not

public static Criterion not(Criterion expression)
Return the negation of an expression

Parameters:
expression -
Returns:
Criterion

sqlRestriction

public static Criterion sqlRestriction(String sql,
                                       Object[] values,
                                       Type[] types)
Apply a constraint expressed in SQL, with the given JDBC parameters. Any occurrences of {alias} will be replaced by the table alias.

Parameters:
sql -
values -
types -
Returns:
Criterion

sqlRestriction

public static Criterion sqlRestriction(String sql,
                                       Object value,
                                       Type type)
Apply a constraint expressed in SQL, with the given JDBC parameter. Any occurrences of {alias} will be replaced by the table alias.

Parameters:
sql -
value -
type -
Returns:
Criterion

sqlRestriction

public static Criterion sqlRestriction(String sql)
Apply a constraint expressed in SQL. Any occurrences of {alias} will be replaced by the table alias.

Parameters:
sql -
Returns:
Criterion

conjunction

public static Conjunction conjunction()
Group expressions together in a single conjunction (A and B and C...)

Returns:
Conjunction

disjunction

public static Disjunction disjunction()
Group expressions together in a single disjunction (A or B or C...)

Returns:
Conjunction

allEq

public static Criterion allEq(Map propertyNameValues)
Apply an "equals" constraint to each property in the key set of a Map

Parameters:
propertyNameValues - a map from property names to values
Returns:
Criterion

isEmpty

public static Criterion isEmpty(String propertyName)
Constrain a collection valued property to be empty

isNotEmpty

public static Criterion isNotEmpty(String propertyName)
Constrain a collection valued property to be non-empty

sizeEq

public static Criterion sizeEq(String propertyName,
                               int size)
Constrain a collection valued property by size

sizeNe

public static Criterion sizeNe(String propertyName,
                               int size)
Constrain a collection valued property by size

sizeGt

public static Criterion sizeGt(String propertyName,
                               int size)
Constrain a collection valued property by size

sizeLt

public static Criterion sizeLt(String propertyName,
                               int size)
Constrain a collection valued property by size

sizeGe

public static Criterion sizeGe(String propertyName,
                               int size)
Constrain a collection valued property by size

sizeLe

public static Criterion sizeLe(String propertyName,
                               int size)
Constrain a collection valued property by size

naturalId

public static NaturalIdentifier naturalId()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RowCountProjection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class RowCountProjection

java.lang.Object
    extended by org.hibernate.criterion.SimpleProjection
        extended by org.hibernate.criterion.RowCountProjection
All Implemented Interfaces:
Projection, Serializable
public class RowCountProjection
extends SimpleProjection

A row count

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected RowCountProjection()
Method Summary
Type[] | getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
String | toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class org.hibernate.criterion.SimpleProjection
as, getAliases, getColumnAliases, getColumnAliases, getTypes, isGrouped, toGroupSqlString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RowCountProjection

protected RowCountProjection()
Method Detail

toString

public String toString()

getTypes

public Type[] getTypes(Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types returned by the rendered SQL fragment

Parameters:
criteria -
criteriaQuery -
Returns:
Type[]
Throws:
HibernateException

toSqlString

public String toSqlString(Criteria criteria,
                          int position,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Projection
Render the SQL fragment

Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class SimpleExpression

java.lang.Object
    extended by org.hibernate.criterion.SimpleExpression
All Implemented Interfaces:
Criterion, Serializable
public class SimpleExpression
extends Object
implements Criterion

superclass for "simple" comparisons (with SQL binary operators)

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected | SimpleExpression(String propertyName, Object value, String op)
protected | SimpleExpression(String propertyName, Object value, String op, boolean ignoreCase)
Method Summary
protected String | getOp()
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
SimpleExpression | ignoreCase()
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SimpleExpression

protected SimpleExpression(String propertyName,
                           Object value,
                           String op)

SimpleExpression

protected SimpleExpression(String propertyName,
                           Object value,
                           String op,
                           boolean ignoreCase)
Method Detail

ignoreCase

public SimpleExpression ignoreCase()

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toString

public String toString()

getOp

protected final String getOp()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleProjection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class SimpleProjection

java.lang.Object
    extended by org.hibernate.criterion.SimpleProjection
All Implemented Interfaces:
Projection, Serializable
Direct Known Subclasses:
AggregateProjection, IdentifierProjection, PropertyProjection, RowCountProjection
public abstract class SimpleProjection
extends Object
implements Projection

A single-column projection that may be aliased

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
SimpleProjection()
Method Summary
Projection | as(String alias)
String[] | getAliases() Get the user-visible aliases for this projection (ie.
String[] | getColumnAliases(int loc) Get the SQL select clause column aliases
String[] | getColumnAliases(String alias, int loc) Get the SQL select clause column aliases for a particular user-visible alias
Type[] | getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery) Return types for a particular user-visible alias
boolean | isGrouped() Does this projection specify grouping attributes?
String | toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment to be used in the group by clause
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.criterion.Projection
getTypes, toSqlString

Constructor Detail

SimpleProjection

public SimpleProjection()
Method Detail

as

public Projection as(String alias)

getColumnAliases

public String[] getColumnAliases(String alias,
                                 int loc)
Description copied from interface: Projection
Get the SQL select clause column aliases for a particular user-visible alias

Specified by:
getColumnAliases in interface Projection

getTypes

public Type[] getTypes(String alias,
                       Criteria criteria,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types for a particular user-visible alias

Specified by:
getTypes in interface Projection
Throws:
HibernateException

getColumnAliases

public String[] getColumnAliases(int loc)
Description copied from interface: Projection
Get the SQL select clause column aliases

Specified by:
getColumnAliases in interface Projection

getAliases

public String[] getAliases()
Description copied from interface: Projection
Get the user-visible aliases for this projection (ie. the ones that will be passed to the ResultTransformer)

Specified by:
getAliases in interface Projection

toGroupSqlString

public String toGroupSqlString(Criteria criteria,
                               CriteriaQuery criteriaQuery)
                        throws HibernateException
Description copied from interface: Projection
Render the SQL fragment to be used in the group by clause

Specified by:
toGroupSqlString in interface Projection
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

isGrouped

public boolean isGrouped()
Description copied from interface: Projection
Does this projection specify grouping attributes?

Specified by:
isGrouped in interface Projection
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleSubqueryExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class SimpleSubqueryExpression

java.lang.Object
    extended by org.hibernate.criterion.SubqueryExpression
        extended by org.hibernate.criterion.SimpleSubqueryExpression
All Implemented Interfaces:
Criterion, Serializable
public class SimpleSubqueryExpression
extends SubqueryExpression

A comparison between a constant value and the the result of a subquery

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected SimpleSubqueryExpression(Object value, String op, String quantifier, DetachedCriteria dc)
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
protected String | toLeftSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Methods inherited from class org.hibernate.criterion.SubqueryExpression
getTypes, toSqlString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SimpleSubqueryExpression

protected SimpleSubqueryExpression(Object value,
                                   String op,
                                   String quantifier,
                                   DetachedCriteria dc)
Method Detail

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Overrides:
getTypedValues in class SubqueryExpression
Throws:
HibernateException

toLeftSqlString

protected String toLeftSqlString(Criteria criteria,
                                 CriteriaQuery criteriaQuery)
Specified by:
toLeftSqlString in class SubqueryExpression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SizeExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class SizeExpression

java.lang.Object
    extended by org.hibernate.criterion.SizeExpression
All Implemented Interfaces:
Criterion, Serializable
public class SizeExpression
extends Object
implements Criterion

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected SizeExpression(String propertyName, int size, String op)
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SizeExpression

protected SizeExpression(String propertyName,
                         int size,
                         String op)
Method Detail

toString

public String toString()

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLCriterion (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class SQLCriterion

java.lang.Object
    extended by org.hibernate.criterion.SQLCriterion
All Implemented Interfaces:
Criterion, Serializable
public class SQLCriterion
extends Object
implements Criterion

A SQL fragment. The string {alias} will be replaced by the alias of the root entity.

See Also:
Serialized Form

Constructor Summary
protected SQLCriterion(String sql, Object[] values, Type[] types)
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SQLCriterion

protected SQLCriterion(String sql,
                       Object[] values,
                       Type[] types)
Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLProjection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class SQLProjection

java.lang.Object
    extended by org.hibernate.criterion.SQLProjection
All Implemented Interfaces:
Projection, Serializable
public class SQLProjection
extends Object
implements Projection

A SQL fragment. The string {alias} will be replaced by the alias of the root entity.

See Also:
Serialized Form

Constructor Summary
protected | SQLProjection(String sql, String[] columnAliases, Type[] types)
protected | SQLProjection(String sql, String groupBy, String[] columnAliases, Type[] types)
Method Summary
String[] | getAliases() Get the user-visible aliases for this projection (ie.
String[] | getColumnAliases(int loc) Get the SQL select clause column aliases
String[] | getColumnAliases(String alias, int loc) Get the SQL select clause column aliases for a particular user-visible alias
Type[] | getTypes(Criteria crit, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
Type[] | getTypes(String alias, Criteria crit, CriteriaQuery criteriaQuery) Return types for a particular user-visible alias
boolean | isGrouped() Does this projection specify grouping attributes?
String | toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment to be used in the group by clause
String | toSqlString(Criteria criteria, int loc, CriteriaQuery criteriaQuery) Render the SQL fragment
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SQLProjection

protected SQLProjection(String sql,
                        String[] columnAliases,
                        Type[] types)

SQLProjection

protected SQLProjection(String sql,
                        String groupBy,
                        String[] columnAliases,
                        Type[] types)
Method Detail

toSqlString

public String toSqlString(Criteria criteria,
                          int loc,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Projection
Render the SQL fragment

Specified by:
toSqlString in interface Projection
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

toGroupSqlString

public String toGroupSqlString(Criteria criteria,
                               CriteriaQuery criteriaQuery)
                        throws HibernateException
Description copied from interface: Projection
Render the SQL fragment to be used in the group by clause

Specified by:
toGroupSqlString in interface Projection
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypes

public Type[] getTypes(Criteria crit,
                       CriteriaQuery criteriaQuery)
                throws HibernateException
Description copied from interface: Projection
Return types returned by the rendered SQL fragment

Specified by:
getTypes in interface Projection
Parameters:
crit -
criteriaQuery -
Returns:
Type[]
Throws:
HibernateException

toString

public String toString()

getAliases

public String[] getAliases()
Description copied from interface: Projection
Get the user-visible aliases for this projection (ie. the ones that will be passed to the ResultTransformer)

Specified by:
getAliases in interface Projection

getColumnAliases

public String[] getColumnAliases(int loc)
Description copied from interface: Projection
Get the SQL select clause column aliases

Specified by:
getColumnAliases in interface Projection

isGrouped

public boolean isGrouped()
Description copied from interface: Projection
Does this projection specify grouping attributes?

Specified by:
isGrouped in interface Projection

getTypes

public Type[] getTypes(String alias,
                       Criteria crit,
                       CriteriaQuery criteriaQuery)
Description copied from interface: Projection
Return types for a particular user-visible alias

Specified by:
getTypes in interface Projection

getColumnAliases

public String[] getColumnAliases(String alias,
                                 int loc)
Description copied from interface: Projection
Get the SQL select clause column aliases for a particular user-visible alias

Specified by:
getColumnAliases in interface Projection
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Subqueries (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class Subqueries

java.lang.Object
    extended by org.hibernate.criterion.Subqueries
public class Subqueries
extends Object

Factory class for criterion instances that represent expressions involving subqueries.

Author:
Gavin King
See Also:
Restriction, Projection, Criteria

Constructor Summary
Subqueries()
Method Summary
static Criterion | eq(Object value, DetachedCriteria dc)
static Criterion | eqAll(Object value, DetachedCriteria dc)
static Criterion | exists(DetachedCriteria dc)
static Criterion | ge(Object value, DetachedCriteria dc)
static Criterion | geAll(Object value, DetachedCriteria dc)
static Criterion | geSome(Object value, DetachedCriteria dc)
static Criterion | gt(Object value, DetachedCriteria dc)
static Criterion | gtAll(Object value, DetachedCriteria dc)
static Criterion | gtSome(Object value, DetachedCriteria dc)
static Criterion | in(Object value, DetachedCriteria dc)
static Criterion | le(Object value, DetachedCriteria dc)
static Criterion | leAll(Object value, DetachedCriteria dc)
static Criterion | leSome(Object value, DetachedCriteria dc)
static Criterion | lt(Object value, DetachedCriteria dc)
static Criterion | ltAll(Object value, DetachedCriteria dc)
static Criterion | ltSome(Object value, DetachedCriteria dc)
static Criterion | ne(Object value, DetachedCriteria dc)
static Criterion | notExists(DetachedCriteria dc)
static Criterion | notIn(Object value, DetachedCriteria dc)
static Criterion | propertyEq(String propertyName, DetachedCriteria dc)
static Criterion | propertyEqAll(String propertyName, DetachedCriteria dc)
static Criterion | propertyGe(String propertyName, DetachedCriteria dc)
static Criterion | propertyGeAll(String propertyName, DetachedCriteria dc)
static Criterion | propertyGeSome(String propertyName, DetachedCriteria dc)
static Criterion | propertyGt(String propertyName, DetachedCriteria dc)
static Criterion | propertyGtAll(String propertyName, DetachedCriteria dc)
static Criterion | propertyGtSome(String propertyName, DetachedCriteria dc)
static Criterion | propertyIn(String propertyName, DetachedCriteria dc)
static Criterion | propertyLe(String propertyName, DetachedCriteria dc)
static Criterion | propertyLeAll(String propertyName, DetachedCriteria dc)
static Criterion | propertyLeSome(String propertyName, DetachedCriteria dc)
static Criterion | propertyLt(String propertyName, DetachedCriteria dc)
static Criterion | propertyLtAll(String propertyName, DetachedCriteria dc)
static Criterion | propertyLtSome(String propertyName, DetachedCriteria dc)
static Criterion | propertyNe(String propertyName, DetachedCriteria dc)
static Criterion | propertyNotIn(String propertyName, DetachedCriteria dc)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Subqueries

public Subqueries()
Method Detail

exists

public static Criterion exists(DetachedCriteria dc)

notExists

public static Criterion notExists(DetachedCriteria dc)

propertyEqAll

public static Criterion propertyEqAll(String propertyName,
                                      DetachedCriteria dc)

propertyIn

public static Criterion propertyIn(String propertyName,
                                   DetachedCriteria dc)

propertyNotIn

public static Criterion propertyNotIn(String propertyName,
                                      DetachedCriteria dc)

propertyEq

public static Criterion propertyEq(String propertyName,
                                   DetachedCriteria dc)

propertyNe

public static Criterion propertyNe(String propertyName,
                                   DetachedCriteria dc)

propertyGt

public static Criterion propertyGt(String propertyName,
                                   DetachedCriteria dc)

propertyLt

public static Criterion propertyLt(String propertyName,
                                   DetachedCriteria dc)

propertyGe

public static Criterion propertyGe(String propertyName,
                                   DetachedCriteria dc)

propertyLe

public static Criterion propertyLe(String propertyName,
                                   DetachedCriteria dc)

propertyGtAll

public static Criterion propertyGtAll(String propertyName,
                                      DetachedCriteria dc)

propertyLtAll

public static Criterion propertyLtAll(String propertyName,
                                      DetachedCriteria dc)

propertyGeAll

public static Criterion propertyGeAll(String propertyName,
                                      DetachedCriteria dc)

propertyLeAll

public static Criterion propertyLeAll(String propertyName,
                                      DetachedCriteria dc)

propertyGtSome

public static Criterion propertyGtSome(String propertyName,
                                       DetachedCriteria dc)

propertyLtSome

public static Criterion propertyLtSome(String propertyName,
                                       DetachedCriteria dc)

propertyGeSome

public static Criterion propertyGeSome(String propertyName,
                                       DetachedCriteria dc)

propertyLeSome

public static Criterion propertyLeSome(String propertyName,
                                       DetachedCriteria dc)

eqAll

public static Criterion eqAll(Object value,
                              DetachedCriteria dc)

in

public static Criterion in(Object value,
                           DetachedCriteria dc)

notIn

public static Criterion notIn(Object value,
                              DetachedCriteria dc)

eq

public static Criterion eq(Object value,
                           DetachedCriteria dc)

gt

public static Criterion gt(Object value,
                           DetachedCriteria dc)

lt

public static Criterion lt(Object value,
                           DetachedCriteria dc)

ge

public static Criterion ge(Object value,
                           DetachedCriteria dc)

le

public static Criterion le(Object value,
                           DetachedCriteria dc)

ne

public static Criterion ne(Object value,
                           DetachedCriteria dc)

gtAll

public static Criterion gtAll(Object value,
                              DetachedCriteria dc)

ltAll

public static Criterion ltAll(Object value,
                              DetachedCriteria dc)

geAll

public static Criterion geAll(Object value,
                              DetachedCriteria dc)

leAll

public static Criterion leAll(Object value,
                              DetachedCriteria dc)

gtSome

public static Criterion gtSome(Object value,
                               DetachedCriteria dc)

ltSome

public static Criterion ltSome(Object value,
                               DetachedCriteria dc)

geSome

public static Criterion geSome(Object value,
                               DetachedCriteria dc)

leSome

public static Criterion leSome(Object value,
                               DetachedCriteria dc)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubqueryExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.criterion
Class SubqueryExpression

java.lang.Object
    extended by org.hibernate.criterion.SubqueryExpression
All Implemented Interfaces:
Criterion, Serializable
Direct Known Subclasses:
ExistsSubqueryExpression, PropertySubqueryExpression, SimpleSubqueryExpression
public abstract class SubqueryExpression
extends Object
implements Criterion

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
protected SubqueryExpression(String op, String quantifier, DetachedCriteria dc)
Method Summary
TypedValue[] | getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
protected Type[] | getTypes()
protected abstract String | toLeftSqlString(Criteria criteria, CriteriaQuery outerQuery)
String | toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SubqueryExpression

protected SubqueryExpression(String op,
                             String quantifier,
                             DetachedCriteria dc)
Method Detail

getTypes

protected Type[] getTypes()

toLeftSqlString

protected abstract String toLeftSqlString(Criteria criteria,
                                          CriteriaQuery outerQuery)

toSqlString

public String toSqlString(Criteria criteria,
                          CriteriaQuery criteriaQuery)
                   throws HibernateException
Description copied from interface: Criterion
Render the SQL fragment

Specified by:
toSqlString in interface Criterion
Parameters:
criteriaQuery -
Returns:
String
Throws:
HibernateException

getTypedValues

public TypedValue[] getTypedValues(Criteria criteria,
                                   CriteriaQuery criteriaQuery)
                            throws HibernateException
Description copied from interface: Criterion
Return typed values for all parameters in the rendered SQL fragment

Specified by:
getTypedValues in interface Criterion
Parameters:
criteria - TODO
criteriaQuery -
Returns:
TypedValue[]
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.dialect (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.dialect

This package abstracts the SQL dialect of the underlying database.

See:
Description

Interface Summary
DialectFactory.DatabaseDialectMapper For a given database product name, instances of DatabaseDialectMapper know which Dialect to use for different versions.

Class Summary
DataDirectOracle9Dialect |
DB2390Dialect | An SQL dialect for DB2/390.
DB2400Dialect | An SQL dialect for DB2/400
DB2Dialect | An SQL dialect for DB2.
DerbyDialect |
DerbyDialect.DerbyTrimFunctionEmulation | A specialized function template to emulate the ANSI trim function on Derby DB since it does not support the full trim specification.
Dialect | Represents a dialect of SQL implemented by a particular RDBMS.
DialectFactory | A factory for generating Dialect instances.
DialectFactory.VersionInsensitiveMapper | A simple DatabaseDialectMapper for dialects which are independent of the underlying database product version.
FirebirdDialect | An SQL dialect for Firebird.
FrontBaseDialect | An SQL Dialect for Frontbase.
H2Dialect | A dialect compatible with the H2 database.
HSQLDialect | An SQL dialect compatible with HSQLDB (Hypersonic SQL).
HSQLDialect.ReadUncommittedLockingStrategy |
InformixDialect | Informix dialect. Seems to work with Informix Dynamic Server Version 7.31.UD3, Informix JDBC driver version 2.21JC3.
IngresDialect | An Ingres SQL dialect
InterbaseDialect | An SQL dialect for Interbase.
JDataStoreDialect | A Dialect for JDataStore.
MckoiDialect | An SQL dialect compatible with McKoi SQL
MimerSQLDialect | An Hibernate 3 SQL dialect for Mimer SQL.
MySQL5Dialect | An SQL dialect for MySQL 5.x specific features.
MySQL5InnoDBDialect |
MySQLDialect | An SQL dialect for MySQL (prior to 5.x).
MySQLInnoDBDialect |
MySQLMyISAMDialect |
Oracle9Dialect | An SQL dialect for Oracle 9 (uses ANSI-style syntax where possible).
OracleDialect | An SQL dialect for Oracle, compatible with Oracle 8.
PointbaseDialect | A Dialect for Pointbase.
PostgreSQLDialect | An SQL dialect for Postgres
ProgressDialect | An SQL dialect compatible with Progress 9.1C Connection Parameters required: hibernate.dialect org.hibernate.sql.ProgressDialect hibernate.driver com.progress.sql.jdbc.JdbcProgressDriver hibernate.url jdbc:JdbcProgress:T:host:port:dbname;WorkArounds=536870912 hibernate.username username hibernate.password password The WorkArounds parameter in the URL is required to avoid an error in the Progress 9.1C JDBC driver related to PreparedStatements.
RDMSOS2200Dialect |
SAPDBDialect | An SQL dialect compatible with SAP DB.
SQLServerDialect | A dialect for Microsoft SQL Server 2000
Sybase11Dialect | A SQL dialect suitable for use with Sybase 11.9.2 (specifically: avoids ANSI JOIN syntax)
SybaseAnywhereDialect | SQL Dialect for Sybase Anywhere extending Sybase (Enterprise) Dialect (Tested on ASA 8.x)
SybaseDialect | An SQL dialect compatible with Sybase and MS SQL Server.
TimesTenDialect | A SQL dialect for TimesTen 5.1.
TypeNames | This class maps a type to names.

Package org.hibernate.dialect Description

This package abstracts the SQL dialect of the underlying database.

A concrete Dialect may be specifed using hibernate.dialect.


org.hibernate.dialect Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.dialect

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.dialect.DerbyDialect.DerbyTrimFunctionEmulation (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.dialect.Dialect
      • class org.hibernate.dialect.DB2Dialect
        • class org.hibernate.dialect.DB2390Dialect
        • class org.hibernate.dialect.DB2400Dialect
        • class org.hibernate.dialect.DerbyDialect
      • class org.hibernate.dialect.FrontBaseDialect
      • class org.hibernate.dialect.H2Dialect
      • class org.hibernate.dialect.HSQLDialect
      • class org.hibernate.dialect.InformixDialect
      • class org.hibernate.dialect.IngresDialect
      • class org.hibernate.dialect.InterbaseDialect
        • class org.hibernate.dialect.FirebirdDialect
      • class org.hibernate.dialect.JDataStoreDialect
      • class org.hibernate.dialect.MckoiDialect
      • class org.hibernate.dialect.MimerSQLDialect
      • class org.hibernate.dialect.MySQLDialect
        • class org.hibernate.dialect.MySQL5Dialect
          • class org.hibernate.dialect.MySQL5InnoDBDialect
        • class org.hibernate.dialect.MySQLInnoDBDialect
        • class org.hibernate.dialect.MySQLMyISAMDialect
      • class org.hibernate.dialect.Oracle9Dialect
        • class org.hibernate.dialect.DataDirectOracle9Dialect
        • class org.hibernate.dialect.OracleDialect
      • class org.hibernate.dialect.PointbaseDialect
      • class org.hibernate.dialect.PostgreSQLDialect
      • class org.hibernate.dialect.ProgressDialect
      • class org.hibernate.dialect.RDMSOS2200Dialect
      • class org.hibernate.dialect.SAPDBDialect
      • class org.hibernate.dialect.SybaseDialect
        • class org.hibernate.dialect.SQLServerDialect
        • class org.hibernate.dialect.Sybase11Dialect
        • class org.hibernate.dialect.SybaseAnywhereDialect
      • class org.hibernate.dialect.TimesTenDialect
    • class org.hibernate.dialect.DialectFactory
    • class org.hibernate.dialect.DialectFactory.VersionInsensitiveMapper (implements org.hibernate.dialect.DialectFactory.DatabaseDialectMapper)
    • class org.hibernate.dialect.lock.SelectLockingStrategy (implements org.hibernate.dialect.lock.LockingStrategy)
      • class org.hibernate.dialect.HSQLDialect.ReadUncommittedLockingStrategy
    • class org.hibernate.dialect.TypeNames

Interface Hierarchy

  • interface org.hibernate.dialect.DialectFactory.DatabaseDialectMapper


Uses of Package org.hibernate.dialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.dialect

Packages that use org.hibernate.dialect
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function | A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.exception | This package is a fork of Apache commons-lang nestable exceptions.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.id.insert |
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.
org.hibernate.tool.hbm2ddl | The hbm2ddl tool.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.util | Utility classes.

Classes in org.hibernate.dialect used by org.hibernate.cfg
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.dialect
DB2Dialect
An SQL dialect for DB2.
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.
DialectFactory.DatabaseDialectMapper
For a given database product name, instances of DatabaseDialectMapper know which Dialect to use for different versions.
InterbaseDialect
An SQL dialect for Interbase.
MySQL5Dialect
An SQL dialect for MySQL 5.x specific features.
MySQLDialect
An SQL dialect for MySQL (prior to 5.x).
Oracle9Dialect
An SQL dialect for Oracle 9 (uses ANSI-style syntax where possible).
SybaseDialect
An SQL dialect compatible with Sybase and MS SQL Server.

Classes in org.hibernate.dialect used by org.hibernate.dialect.function
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.engine
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.exception
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.hql.classic
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.id
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.id.insert
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.impl
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.jdbc
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.loader
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.loader.criteria
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.loader.hql
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.mapping
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.persister.collection
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.sql
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.tool.hbm2ddl
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.type
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Classes in org.hibernate.dialect used by org.hibernate.util
Dialect
Represents a dialect of SQL implemented by a particular RDBMS.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DataDirectOracle9Dialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class DataDirectOracle9Dialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.Oracle9Dialect
            extended by org.hibernate.dialect.DataDirectOracle9Dialect
public class DataDirectOracle9Dialect
extends Oracle9Dialect

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
DataDirectOracle9Dialect()
Method Summary
ResultSet | getResultSet(CallableStatement ps)
int | registerResultSetOutParameter(CallableStatement statement, int col)
Methods inherited from class org.hibernate.dialect.Oracle9Dialect
bindLimitParametersInReverseOrder, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddColumnString, getCascadeConstraintsString, getCreateSequenceString, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getDropSequenceString, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getLimitString, getQuerySequencesString, getSelectGUIDString, getSelectSequenceNextValString, getSequenceNextValString, getViolatedConstraintNameExtracter, isCurrentTimestampSelectStringCallable, supportsCommentOn, supportsCurrentTimestampSelection, supportsLimit, supportsSequences, supportsTemporaryTables, supportsUnionAll, useMaxForLimit
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getSelectClauseNullString, getTableComment, getTableTypeString, getTypeName, getTypeName, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsCascadeDelete, supportsColumnCheck, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DataDirectOracle9Dialect

public DataDirectOracle9Dialect()
Method Detail

registerResultSetOutParameter

public int registerResultSetOutParameter(CallableStatement statement,
                                         int col)
                                  throws SQLException
Overrides:
registerResultSetOutParameter in class Oracle9Dialect
Throws:
SQLException

getResultSet

public ResultSet getResultSet(CallableStatement ps)
                       throws SQLException
Overrides:
getResultSet in class Oracle9Dialect
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DB2390Dialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class DB2390Dialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.DB2Dialect
            extended by org.hibernate.dialect.DB2390Dialect
public class DB2390Dialect
extends DB2Dialect

An SQL dialect for DB2/390. This class provides support for DB2 Universal Database for OS/390, also known as DB2/390.

Author:
Kristoffer Dyrkorn

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
DB2390Dialect()
Method Summary
String | getIdentitySelectString()
String | getLimitString(String sql, int offset, int limit)
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsLimitOffset() Does this dialect support an offset?
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsVariableLimit()
boolean | useMaxForLimit() Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?
Methods inherited from class org.hibernate.dialect.DB2Dialect
dropConstraints, generateTemporaryTableName, getAddColumnString, getCreateSequenceString, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDropSequenceString, getForUpdateString, getIdentityColumnString, getIdentityInsertString, getLimitString, getLowercaseFunction, getQuerySequencesString, getResultSet, getSelectClauseNullString, getSequenceNextValString, isCurrentTimestampSelectStringCallable, main, registerResultSetOutParameter, supportsCommentOn, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsTemporaryTables, supportsUnionAll
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropTemporaryTableAfterUse, forUpdateOfColumns, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentitySelectString, getKeywords, getLockingStrategy, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getSelectGUIDString, getSelectSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsCascadeDelete, supportsColumnCheck, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsRowValueConstructorSyntax, supportsTableCheck, supportsUnique, supportsUniqueConstraintInCreateAlterTable, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DB2390Dialect

public DB2390Dialect()
Method Detail

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class DB2Dialect

getIdentitySelectString

public String getIdentitySelectString()
Overrides:
getIdentitySelectString in class DB2Dialect

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class DB2Dialect

supportsLimitOffset

public boolean supportsLimitOffset()
Description copied from class: Dialect
Does this dialect support an offset?

Overrides:
supportsLimitOffset in class Dialect

getLimitString

public String getLimitString(String sql,
                             int offset,
                             int limit)
Overrides:
getLimitString in class Dialect

useMaxForLimit

public boolean useMaxForLimit()
Description copied from class: Dialect
Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?

Overrides:
useMaxForLimit in class DB2Dialect

supportsVariableLimit

public boolean supportsVariableLimit()
Overrides:
supportsVariableLimit in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DB2400Dialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class DB2400Dialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.DB2Dialect
            extended by org.hibernate.dialect.DB2400Dialect
public class DB2400Dialect
extends DB2Dialect

An SQL dialect for DB2/400

Author:
Peter DeGregorio (pdegregorio) This class provides support for DB2 Universal Database for iSeries, also known as DB2/400.

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
DB2400Dialect()
Method Summary
String | getIdentitySelectString()
String | getLimitString(String sql, int offset, int limit)
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsLimitOffset() Does this dialect support an offset?
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsVariableLimit()
boolean | useMaxForLimit() Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?
Methods inherited from class org.hibernate.dialect.DB2Dialect
dropConstraints, generateTemporaryTableName, getAddColumnString, getCreateSequenceString, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDropSequenceString, getForUpdateString, getIdentityColumnString, getIdentityInsertString, getLimitString, getLowercaseFunction, getQuerySequencesString, getResultSet, getSelectClauseNullString, getSequenceNextValString, isCurrentTimestampSelectStringCallable, main, registerResultSetOutParameter, supportsCommentOn, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsTemporaryTables, supportsUnionAll
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropTemporaryTableAfterUse, forUpdateOfColumns, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentitySelectString, getKeywords, getLockingStrategy, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getSelectGUIDString, getSelectSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsCascadeDelete, supportsColumnCheck, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsRowValueConstructorSyntax, supportsTableCheck, supportsUnique, supportsUniqueConstraintInCreateAlterTable, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DB2400Dialect

public DB2400Dialect()
Method Detail

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class DB2Dialect

getIdentitySelectString

public String getIdentitySelectString()
Overrides:
getIdentitySelectString in class DB2Dialect

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class DB2Dialect

supportsLimitOffset

public boolean supportsLimitOffset()
Description copied from class: Dialect
Does this dialect support an offset?

Overrides:
supportsLimitOffset in class Dialect

getLimitString

public String getLimitString(String sql,
                             int offset,
                             int limit)
Overrides:
getLimitString in class Dialect

useMaxForLimit

public boolean useMaxForLimit()
Description copied from class: Dialect
Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?

Overrides:
useMaxForLimit in class DB2Dialect

supportsVariableLimit

public boolean supportsVariableLimit()
Overrides:
supportsVariableLimit in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DB2Dialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class DB2Dialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.DB2Dialect
Direct Known Subclasses:
DB2390Dialect, DB2400Dialect, DerbyDialect
public class DB2Dialect
extends Dialect

An SQL dialect for DB2.

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
DB2Dialect()
Method Summary
boolean | dropConstraints() Do we need to drop constraints before dropping tables in this dialect?
String | generateTemporaryTableName(String baseTableName)
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getCreateSequenceString(String sequenceName) The syntax used to create a sequence, if sequences are supported.
String | getCreateTemporaryTablePostfix()
String | getCreateTemporaryTableString()
String | getCurrentTimestampSelectString()
String | getCurrentTimestampSQLFunctionName() The name of the database-specific SQL function for retrieving the current timestamp.
String | getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String | getForUpdateString() Retrieves the FOR UPDATE syntax specific to this dialect.
String | getIdentityColumnString()
String | getIdentityInsertString() The keyword used to insert a generated value into an identity column (or null).
String | getIdentitySelectString()
String | getLimitString(String sql, boolean hasOffset) Add a LIMIT clause to the given SQL SELECT
String | getLowercaseFunction() The name of the SQL function that transforms a string to lowercase
String | getQuerySequencesString() A query used to find all sequences
ResultSet | getResultSet(CallableStatement ps)
String | getSelectClauseNullString(int sqlType)
String | getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
boolean | isCurrentTimestampSelectStringCallable()
static void | main(String[] args)
int | registerResultSetOutParameter(CallableStatement statement, int col)
boolean | supportsCommentOn()
boolean | supportsCurrentTimestampSelection()
boolean | supportsIdentityColumns() Does this dialect support identity column key generation?
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsNotNullUnique()
boolean | supportsOuterJoinForUpdate()
boolean | supportsParametersInInsertSelect() Does this dialect support parameters within the select clause of INSERT ...
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsTemporaryTables()
boolean | supportsUnionAll()
boolean | useMaxForLimit() Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropTemporaryTableAfterUse, forUpdateOfColumns, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getSelectGUIDString, getSelectSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsCascadeDelete, supportsColumnCheck, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsRowValueConstructorSyntax, supportsTableCheck, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DB2Dialect

public DB2Dialect()
Method Detail

getLowercaseFunction

public String getLowercaseFunction()
Description copied from class: Dialect
The name of the SQL function that transforms a string to lowercase

Overrides:
getLowercaseFunction in class Dialect
Returns:
String

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

dropConstraints

public boolean dropConstraints()
Description copied from class: Dialect
Do we need to drop constraints before dropping tables in this dialect?

Overrides:
dropConstraints in class Dialect
Returns:
boolean

supportsIdentityColumns

public boolean supportsIdentityColumns()
Description copied from class: Dialect
Does this dialect support identity column key generation?

Overrides:
supportsIdentityColumns in class Dialect
Returns:
boolean

getIdentitySelectString

public String getIdentitySelectString()
Overrides:
getIdentitySelectString in class Dialect

getIdentityColumnString

public String getIdentityColumnString()
Overrides:
getIdentityColumnString in class Dialect

getIdentityInsertString

public String getIdentityInsertString()
Description copied from class: Dialect
The keyword used to insert a generated value into an identity column (or null). Need if the dialect does not support inserts that specify no column values.

Overrides:
getIdentityInsertString in class Dialect
Returns:
String

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.

This should be a "stand alone" select statement.

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.

getCreateSequenceString

public String getCreateSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to create a sequence, if sequences are supported.

Overrides:
getCreateSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getDropSequenceString

public String getDropSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class Dialect
Returns:
boolean

getQuerySequencesString

public String getQuerySequencesString()
Description copied from class: Dialect
A query used to find all sequences

Overrides:
getQuerySequencesString in class Dialect
See Also:
SchemaUpdate

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class Dialect

getLimitString

public String getLimitString(String sql,
                             boolean hasOffset)
Description copied from class: Dialect
Add a LIMIT clause to the given SQL SELECT

Overrides:
getLimitString in class Dialect
Returns:
the modified SQL

getForUpdateString

public String getForUpdateString()
Description copied from class: Dialect
Retrieves the FOR UPDATE syntax specific to this dialect.

Overrides:
getForUpdateString in class Dialect
Returns:
The appropriate FOR UPDATE clause string.

useMaxForLimit

public boolean useMaxForLimit()
Description copied from class: Dialect
Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?

Overrides:
useMaxForLimit in class Dialect

supportsOuterJoinForUpdate

public boolean supportsOuterJoinForUpdate()
Overrides:
supportsOuterJoinForUpdate in class Dialect

supportsNotNullUnique

public boolean supportsNotNullUnique()
Overrides:
supportsNotNullUnique in class Dialect

getSelectClauseNullString

public String getSelectClauseNullString(int sqlType)
Overrides:
getSelectClauseNullString in class Dialect

main

public static void main(String[] args)

supportsUnionAll

public boolean supportsUnionAll()
Overrides:
supportsUnionAll in class Dialect

registerResultSetOutParameter

public int registerResultSetOutParameter(CallableStatement statement,
                                         int col)
                                  throws SQLException
Overrides:
registerResultSetOutParameter in class Dialect
Throws:
SQLException

getResultSet

public ResultSet getResultSet(CallableStatement ps)
                       throws SQLException
Overrides:
getResultSet in class Dialect
Throws:
SQLException

supportsCommentOn

public boolean supportsCommentOn()
Overrides:
supportsCommentOn in class Dialect

supportsTemporaryTables

public boolean supportsTemporaryTables()
Overrides:
supportsTemporaryTables in class Dialect

getCreateTemporaryTableString

public String getCreateTemporaryTableString()
Overrides:
getCreateTemporaryTableString in class Dialect

getCreateTemporaryTablePostfix

public String getCreateTemporaryTablePostfix()
Overrides:
getCreateTemporaryTablePostfix in class Dialect

generateTemporaryTableName

public String generateTemporaryTableName(String baseTableName)
Overrides:
generateTemporaryTableName in class Dialect

supportsCurrentTimestampSelection

public boolean supportsCurrentTimestampSelection()
Overrides:
supportsCurrentTimestampSelection in class Dialect

getCurrentTimestampSelectString

public String getCurrentTimestampSelectString()
Overrides:
getCurrentTimestampSelectString in class Dialect

isCurrentTimestampSelectStringCallable

public boolean isCurrentTimestampSelectStringCallable()
Overrides:
isCurrentTimestampSelectStringCallable in class Dialect

supportsParametersInInsertSelect

public boolean supportsParametersInInsertSelect()
Description copied from class: Dialect
Does this dialect support parameters within the select clause of INSERT ... SELECT ... statements?

Overrides:
supportsParametersInInsertSelect in class Dialect
Returns:
True if this is supported; false otherwise.

getCurrentTimestampSQLFunctionName

public String getCurrentTimestampSQLFunctionName()
Description copied from class: Dialect
The name of the database-specific SQL function for retrieving the current timestamp.

Overrides:
getCurrentTimestampSQLFunctionName in class Dialect
Returns:
The function name.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DerbyDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class DerbyDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.DB2Dialect
            extended by org.hibernate.dialect.DerbyDialect
public class DerbyDialect
extends DB2Dialect

Author:
Simon Johnston Hibernate Dialect for Cloudscape 10 - aka Derby. This implements both an override for the identity column generator as well as for the case statement issue documented at: http://www.jroller.com/comments/kenlars99/Weblog/cloudscape_soon_to_be_derby

Nested Class Summary
static class DerbyDialect.DerbyTrimFunctionEmulation
A specialized function template to emulate the ANSI trim function on Derby DB since it does not support the full trim specification.
Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
DerbyDialect()
Method Summary
CaseFragment | createCaseFragment() Return the case statement modified for Cloudscape.
boolean | dropConstraints() Do we need to drop constraints before dropping tables in this dialect?
String | getIdentityColumnString() This is different in Cloudscape to DB2.
Class | getNativeIdentifierGeneratorClass()
String | getQuerySequencesString() A query used to find all sequences
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsLimitOffset() Does this dialect support an offset?
boolean | supportsSequences() Does this dialect support sequences?
Methods inherited from class org.hibernate.dialect.DB2Dialect
generateTemporaryTableName, getAddColumnString, getCreateSequenceString, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDropSequenceString, getForUpdateString, getIdentityInsertString, getIdentitySelectString, getLimitString, getLowercaseFunction, getResultSet, getSelectClauseNullString, getSequenceNextValString, isCurrentTimestampSelectStringCallable, main, registerResultSetOutParameter, supportsCommentOn, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsTemporaryTables, supportsUnionAll, useMaxForLimit
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createOuterJoinFragment, dropTemporaryTableAfterUse, forUpdateOfColumns, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getMaxAliasLength, getNoColumnsInsertString, getNullColumnString, getSelectGUIDString, getSelectSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsCascadeDelete, supportsColumnCheck, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsRowValueConstructorSyntax, supportsTableCheck, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DerbyDialect

public DerbyDialect()
Method Detail

getIdentityColumnString

public String getIdentityColumnString()
This is different in Cloudscape to DB2.

Overrides:
getIdentityColumnString in class DB2Dialect

createCaseFragment

public CaseFragment createCaseFragment()
Return the case statement modified for Cloudscape.

Overrides:
createCaseFragment in class Dialect
Returns:
OuterJoinGenerator

dropConstraints

public boolean dropConstraints()
Description copied from class: Dialect
Do we need to drop constraints before dropping tables in this dialect?

Overrides:
dropConstraints in class DB2Dialect

getNativeIdentifierGeneratorClass

public Class getNativeIdentifierGeneratorClass()
Overrides:
getNativeIdentifierGeneratorClass in class Dialect

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class DB2Dialect

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class DB2Dialect

supportsLimitOffset

public boolean supportsLimitOffset()
Description copied from class: Dialect
Does this dialect support an offset?

Overrides:
supportsLimitOffset in class Dialect

getQuerySequencesString

public String getQuerySequencesString()
Description copied from class: Dialect
A query used to find all sequences

Overrides:
getQuerySequencesString in class DB2Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DerbyDialect.DerbyTrimFunctionEmulation (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class DerbyDialect.DerbyTrimFunctionEmulation

java.lang.Object
    extended by org.hibernate.dialect.DerbyDialect.DerbyTrimFunctionEmulation
All Implemented Interfaces:
SQLFunction
Enclosing class:
DerbyDialect
public static class DerbyDialect.DerbyTrimFunctionEmulation
extends Object
implements SQLFunction

A specialized function template to emulate the ANSI trim function on Derby DB since it does not support the full trim specification. However, we cannot even fully emulate it because there is not standard 'replace' function either. :(

Constructor Summary
DerbyDialect.DerbyTrimFunctionEmulation()
Method Summary
Type | getReturnType(Type columnType, Mapping mapping) The function return type
boolean | hasArguments() Does this function have any arguments?
boolean | hasParenthesesIfNoArguments() If there are no arguments, are parens required?
String | render(List args, SessionFactoryImplementor factory) Render the function call as SQL
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DerbyDialect.DerbyTrimFunctionEmulation

public DerbyDialect.DerbyTrimFunctionEmulation()
Method Detail

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
                   throws QueryException
Description copied from interface: SQLFunction
The function return type

Specified by:
getReturnType in interface SQLFunction
Parameters:
columnType - the type of the first argument
Throws:
QueryException

hasArguments

public boolean hasArguments()
Description copied from interface: SQLFunction
Does this function have any arguments?

Specified by:
hasArguments in interface SQLFunction

hasParenthesesIfNoArguments

public boolean hasParenthesesIfNoArguments()
Description copied from interface: SQLFunction
If there are no arguments, are parens required?

Specified by:
hasParenthesesIfNoArguments in interface SQLFunction

render

public String render(List args,
                     SessionFactoryImplementor factory)
              throws QueryException
Description copied from interface: SQLFunction
Render the function call as SQL

Specified by:
render in interface SQLFunction
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class Dialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
Direct Known Subclasses:
DB2Dialect, FrontBaseDialect, H2Dialect, HSQLDialect, InformixDialect, IngresDialect, InterbaseDialect, JDataStoreDialect, MckoiDialect, MimerSQLDialect, MySQLDialect, Oracle9Dialect, PointbaseDialect, PostgreSQLDialect, ProgressDialect, RDMSOS2200Dialect, SAPDBDialect, SybaseDialect, TimesTenDialect
public abstract class Dialect
extends Object

Represents a dialect of SQL implemented by a particular RDBMS. Subclasses implement Hibernate compatibility with different systems.

Subclasses should provide a public default constructor that register() a set of type mappings and default Hibernate properties.

Subclasses should be immutable.

Author:
Gavin King, David Channon

Field Summary
static String | CLOSED_QUOTE
static String | QUOTE Characters used for quoting SQL identifiers
Constructor Summary
protected Dialect()
Method Summary
String | appendIdentitySelectToInsert(String insertString) Append a clause to retrieve the generated identity value for the given INSERT statement.
String | appendLockHint(LockMode mode, String tableName) Method appendLockHint appends according to the given lock mode a lock hint behind the given table name, if this dialect needs this.
boolean | bindLimitParametersFirst() Does the LIMIT clause come at the start of the SELECT statement, rather than at the end?
boolean | bindLimitParametersInReverseOrder() Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?
SQLExceptionConverter | buildSQLExceptionConverter() Build an instance of the SQLExceptionConverter preferred by this dialect for converting SQLExceptions into Hibernate's JDBCException hierarchy.
char | closeQuote() The closing quote for a quoted identifier
CaseFragment | createCaseFragment() Create a CaseFragment for this dialect.
JoinFragment | createOuterJoinFragment() Create an OuterJoinGenerator for this dialect.
boolean | dropConstraints() Do we need to drop constraints before dropping tables in this dialect?
boolean | dropTemporaryTableAfterUse()
boolean | forUpdateOfColumns() Does the FOR UPDATE OF syntax specify particular columns?
String | generateTemporaryTableName(String baseTableName)
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getAddForeignKeyConstraintString(String constraintName, String[] foreignKey, String referencedTable, String[] primaryKey, boolean referencesPrimaryKey) The syntax used to add a foreign key constraint to a table.
String | getAddPrimaryKeyConstraintString(String constraintName) The syntax used to add a primary key constraint to a table.
String | getCascadeConstraintsString() Completely optional cascading drop clause
String | getCastTypeName(int code)
String | getColumnComment(String comment)
protected String | getCreateSequenceString(String sequenceName) The syntax used to create a sequence, if sequences are supported.
String[] | getCreateSequenceStrings(String sequenceName) The multiline script used to create a sequence, if sequences are supported.
String | getCreateTemporaryTablePostfix()
String | getCreateTemporaryTableString()
String | getCurrentTimestampSelectString()
String | getCurrentTimestampSQLFunctionName() The name of the database-specific SQL function for retrieving the current timestamp.
Properties | getDefaultProperties() Retrieve a set of default Hibernate properties for this database.
static Dialect | getDialect() Get the Dialect specified by the current System properties.
static Dialect | getDialect(Properties props) Get the Dialect specified by the given properties or system properties.
String | getDropForeignKeyString()
protected String | getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String[] | getDropSequenceStrings(String sequenceName) The multiline script used to drop a sequence, if sequences are supported.
String | getForUpdateNowaitString() Retrieves the FOR UPDATE NOWAIT syntax specific to this dialect.
String | getForUpdateNowaitString(String aliases) Retrieves the FOR UPDATE OF column_list NOWAIT syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.
String | getForUpdateString() Retrieves the FOR UPDATE syntax specific to this dialect.
String | getForUpdateString(LockMode lockMode)
String | getForUpdateString(String aliases) Retrieves the FOR UPDATE OF column_list syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.
Map | getFunctions() SQL functions as defined in general.
String | getHibernateTypeName(int code)
String | getHibernateTypeName(int code, int length, int precision, int scale)
protected String | getIdentityColumnString()
String | getIdentityColumnString(int type) The keyword used to specify an identity column, if identity column key generation is supported.
String | getIdentityInsertString() The keyword used to insert a generated value into an identity column (or null).
protected String | getIdentitySelectString()
String | getIdentitySelectString(String table, String column, int type) The syntax that returns the identity value of the last insert, if identity column key generation is supported.
Set | getKeywords()
String | getLimitString(String querySelect, boolean hasOffset) Add a LIMIT clause to the given SQL SELECT
String | getLimitString(String querySelect, int offset, int limit)
LockingStrategy | getLockingStrategy(Lockable lockable, LockMode lockMode) Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.
String | getLowercaseFunction() The name of the SQL function that transforms a string to lowercase
int | getMaxAliasLength()
Class | getNativeIdentifierGeneratorClass()
String | getNoColumnsInsertString() The keyword used to insert a row without specifying any column values.
String | getNullColumnString() The keyword used to specify a nullable column.
String | getQuerySequencesString() A query used to find all sequences
ResultSet | getResultSet(CallableStatement ps)
String | getSelectClauseNullString(int sqlType)
String | getSelectGUIDString()
String | getSelectSequenceNextValString(String sequenceName) Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.
String | getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
String | getTableComment(String comment)
String | getTableTypeString()
String | getTypeName(int code) Get the name of the database type associated with the given java.sql.Types typecode.
String | getTypeName(int code, int length, int precision, int scale) Get the name of the database type associated with the given java.sql.Types typecode.
ViolatedConstraintNameExtracter | getViolatedConstraintNameExtracter()
boolean | hasAlterTable() Does this dialect support the ALTER TABLE syntax?
boolean | hasDataTypeInIdentityColumn() Whether this dialect have an Identity clause added to the data type or a completely seperate identity data type
boolean | hasSelfReferentialForeignKeyBug()
boolean | isCurrentTimestampSelectStringCallable()
char | openQuote() The opening quote for a quoted identifier
boolean | performTemporaryTableDDLInIsolation()
boolean | qualifyIndexName() Do we need to qualify index names with the schema name?
String | quote(String column)
protected void | registerColumnType(int code, int capacity, String name) Subclasses register a typename for the given type code and maximum column length.
protected void | registerColumnType(int code, String name) Subclasses register a typename for the given type code.
protected void | registerFunction(String name, SQLFunction function)
protected void | registerHibernateType(int sqlcode, int capacity, String name)
protected void | registerHibernateType(int sqlcode, String name)
protected void | registerKeyword(String word)
int | registerResultSetOutParameter(CallableStatement statement, int col)
boolean | supportsCascadeDelete()
boolean | supportsColumnCheck() Does this dialect support column-level check constraints?
boolean | supportsCommentOn()
boolean | supportsCurrentTimestampSelection()
boolean | supportsIdentityColumns() Does this dialect support identity column key generation?
boolean | supportsIfExistsAfterTableName()
boolean | supportsIfExistsBeforeTableName()
boolean | supportsInsertSelectIdentity()
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsLimitOffset() Does this dialect support an offset?
boolean | supportsNotNullUnique()
boolean | supportsOuterJoinForUpdate()
boolean | supportsParametersInInsertSelect() Does this dialect support parameters within the select clause of INSERT ...
boolean | supportsRowValueConstructorSyntax() Is this dialect known to support what ANSI-SQL terms "row value constructor" syntax; sometimes called tuple syntax.
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsTableCheck() Does this dialect support table-level check constraints?
boolean | supportsTemporaryTables()
boolean | supportsUnionAll()
boolean | supportsUnique() Does this dialect support the UNIQUE column syntax?
boolean | supportsUniqueConstraintInCreateAlterTable() Does this dialect support adding Unique constraints via create and alter table ?
boolean | supportsVariableLimit()
String | toBooleanValueString(boolean bool) The SQL value that the JDBC driver maps boolean values to
String | toString()
String | transformSelectString(String select)
boolean | useInputStreamToInsertBlob()
boolean | useMaxForLimit() Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

QUOTE

public static final String QUOTE
Characters used for quoting SQL identifiers

See Also:
Constant Field Values

CLOSED_QUOTE

public static final String CLOSED_QUOTE
See Also:
Constant Field Values
Constructor Detail

Dialect

protected Dialect()
Method Detail

toString

public String toString()

getTypeName

public String getTypeName(int code)
                   throws HibernateException
Get the name of the database type associated with the given java.sql.Types typecode.

Parameters:
code - java.sql.Types typecode
Returns:
the database type name
Throws:
HibernateException

getHibernateTypeName

public String getHibernateTypeName(int code)
                            throws HibernateException
Throws:
HibernateException

getHibernateTypeName

public String getHibernateTypeName(int code,
                                   int length,
                                   int precision,
                                   int scale)
                            throws HibernateException
Throws:
HibernateException

getTypeName

public String getTypeName(int code,
                          int length,
                          int precision,
                          int scale)
                   throws HibernateException
Get the name of the database type associated with the given java.sql.Types typecode.

Parameters:
code - java.sql.Types typecode
length - the length or precision of the column
precision - the precision of the column
scale - the scale of the column
Returns:
the database type name
Throws:
HibernateException

getCastTypeName

public String getCastTypeName(int code)

registerFunction

protected void registerFunction(String name,
                                SQLFunction function)

registerKeyword

protected void registerKeyword(String word)

getKeywords

public Set getKeywords()

registerColumnType

protected void registerColumnType(int code,
                                  int capacity,
                                  String name)
Subclasses register a typename for the given type code and maximum column length. $l in the type name with be replaced by the column length (if appropriate).

Parameters:
code - java.sql.Types typecode
capacity - maximum length of database type
name - the database type name

registerColumnType

protected void registerColumnType(int code,
                                  String name)
Subclasses register a typename for the given type code. $l in the type name with be replaced by the column length (if appropriate).

Parameters:
code - java.sql.Types typecode
name - the database type name

registerHibernateType

protected void registerHibernateType(int sqlcode,
                                     String name)

registerHibernateType

protected void registerHibernateType(int sqlcode,
                                     int capacity,
                                     String name)

hasAlterTable

public boolean hasAlterTable()
Does this dialect support the ALTER TABLE syntax?

Returns:
boolean

dropConstraints

public boolean dropConstraints()
Do we need to drop constraints before dropping tables in this dialect?

Returns:
boolean

qualifyIndexName

public boolean qualifyIndexName()
Do we need to qualify index names with the schema name?

Returns:
boolean

forUpdateOfColumns

public boolean forUpdateOfColumns()
Does the FOR UPDATE OF syntax specify particular columns?

getForUpdateString

public String getForUpdateString(String aliases)
Retrieves the FOR UPDATE OF column_list syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.

Returns:
The appropriate FOR UPDATE OF column_list clause string.

getForUpdateNowaitString

public String getForUpdateNowaitString(String aliases)
Retrieves the FOR UPDATE OF column_list NOWAIT syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.

Returns:
The appropriate FOR UPDATE colunm_list NOWAIT clause string.

getForUpdateString

public String getForUpdateString()
Retrieves the FOR UPDATE syntax specific to this dialect.

Returns:
The appropriate FOR UPDATE clause string.

getForUpdateNowaitString

public String getForUpdateNowaitString()
Retrieves the FOR UPDATE NOWAIT syntax specific to this dialect.

Returns:
The appropriate FOR UPDATE NOWAIT clause string.

supportsUnique

public boolean supportsUnique()
Does this dialect support the UNIQUE column syntax?

Returns:
boolean

supportsUniqueConstraintInCreateAlterTable

public boolean supportsUniqueConstraintInCreateAlterTable()
Does this dialect support adding Unique constraints via create and alter table ?

Returns:
boolean

getAddColumnString

public String getAddColumnString()
The syntax used to add a column to a table (optional).

getDropForeignKeyString

public String getDropForeignKeyString()

getTableTypeString

public String getTableTypeString()

getAddForeignKeyConstraintString

public String getAddForeignKeyConstraintString(String constraintName,
                                               String[] foreignKey,
                                               String referencedTable,
                                               String[] primaryKey,
                                               boolean referencesPrimaryKey)
The syntax used to add a foreign key constraint to a table.

Parameters:
referencesPrimaryKey - if false, constraint should be explicit about which column names the constraint refers to
Returns:
String

getAddPrimaryKeyConstraintString

public String getAddPrimaryKeyConstraintString(String constraintName)
The syntax used to add a primary key constraint to a table.

Returns:
String

getNullColumnString

public String getNullColumnString()
The keyword used to specify a nullable column.

Returns:
String

supportsIdentityColumns

public boolean supportsIdentityColumns()
Does this dialect support identity column key generation?

Returns:
boolean

supportsSequences

public boolean supportsSequences()
Does this dialect support sequences?

Returns:
boolean

supportsInsertSelectIdentity

public boolean supportsInsertSelectIdentity()

appendIdentitySelectToInsert

public String appendIdentitySelectToInsert(String insertString)
Append a clause to retrieve the generated identity value for the given INSERT statement.

getIdentitySelectString

protected String getIdentitySelectString()
                                  throws MappingException
Throws:
MappingException

getIdentitySelectString

public String getIdentitySelectString(String table,
                                      String column,
                                      int type)
                               throws MappingException
The syntax that returns the identity value of the last insert, if identity column key generation is supported.

Parameters:
type - TODO
Throws:
MappingException - if no native key generation

getIdentityColumnString

protected String getIdentityColumnString()
                                  throws MappingException
Throws:
MappingException

getIdentityColumnString

public String getIdentityColumnString(int type)
                               throws MappingException
The keyword used to specify an identity column, if identity column key generation is supported.

Parameters:
type - the SQL column type, as defined by java.sql.Types
Throws:
MappingException - if no native key generation

getIdentityInsertString

public String getIdentityInsertString()
The keyword used to insert a generated value into an identity column (or null). Need if the dialect does not support inserts that specify no column values.

Returns:
String

getNoColumnsInsertString

public String getNoColumnsInsertString()
The keyword used to insert a row without specifying any column values. This is not possible on some databases.

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
                                throws MappingException
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.

This should be a "stand alone" select statement.

Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.
Throws:
MappingException - if no sequences

getSelectSequenceNextValString

public String getSelectSequenceNextValString(String sequenceName)
                                      throws MappingException
Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.

This differs from getSequenceNextValString(String) in that this should return an expression usable within another select statement.

Parameters:
sequenceName - the name of the sequence
Returns:
String
Throws:
MappingException - if no sequences

getCreateSequenceString

protected String getCreateSequenceString(String sequenceName)
                                  throws MappingException
The syntax used to create a sequence, if sequences are supported.

Parameters:
sequenceName - the name of the sequence
Returns:
String
Throws:
MappingException - if no sequences

getCreateSequenceStrings

public String[] getCreateSequenceStrings(String sequenceName)
                                  throws MappingException
The multiline script used to create a sequence, if sequences are supported.

Parameters:
sequenceName - the name of the sequence
Returns:
String[]
Throws:
MappingException - if no sequences

getDropSequenceString

protected String getDropSequenceString(String sequenceName)
                                throws MappingException
The syntax used to drop a sequence, if sequences are supported.

Parameters:
sequenceName - the name of the sequence
Returns:
String
Throws:
MappingException - if no sequences

getDropSequenceStrings

public String[] getDropSequenceStrings(String sequenceName)
                                throws MappingException
The multiline script used to drop a sequence, if sequences are supported.

Parameters:
sequenceName - the name of the sequence
Returns:
String[]
Throws:
MappingException - if no sequences

getQuerySequencesString

public String getQuerySequencesString()
A query used to find all sequences

See Also:
SchemaUpdate

getDialect

public static Dialect getDialect()
                          throws HibernateException
Get the Dialect specified by the current System properties.

Returns:
Dialect
Throws:
HibernateException

getDialect

public static Dialect getDialect(Properties props)
                          throws HibernateException
Get the Dialect specified by the given properties or system properties.

Parameters:
props -
Returns:
Dialect
Throws:
HibernateException

getDefaultProperties

public final Properties getDefaultProperties()
Retrieve a set of default Hibernate properties for this database.

Returns:
a set of Hibernate properties

getCascadeConstraintsString

public String getCascadeConstraintsString()
Completely optional cascading drop clause

Returns:
String

createOuterJoinFragment

public JoinFragment createOuterJoinFragment()
Create an OuterJoinGenerator for this dialect.

Returns:
OuterJoinGenerator

createCaseFragment

public CaseFragment createCaseFragment()
Create a CaseFragment for this dialect.

Returns:
OuterJoinGenerator

getLowercaseFunction

public String getLowercaseFunction()
The name of the SQL function that transforms a string to lowercase

Returns:
String

supportsLimit

public boolean supportsLimit()
Does this Dialect have some kind of LIMIT syntax?

supportsLimitOffset

public boolean supportsLimitOffset()
Does this dialect support an offset?

getLimitString

public String getLimitString(String querySelect,
                             boolean hasOffset)
Add a LIMIT clause to the given SQL SELECT

Returns:
the modified SQL

getLimitString

public String getLimitString(String querySelect,
                             int offset,
                             int limit)

supportsVariableLimit

public boolean supportsVariableLimit()

bindLimitParametersInReverseOrder

public boolean bindLimitParametersInReverseOrder()
Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?

Returns:
true if the correct order is limit, offset

bindLimitParametersFirst

public boolean bindLimitParametersFirst()
Does the LIMIT clause come at the start of the SELECT statement, rather than at the end?

Returns:
true if limit parameters should come before other parameters

useMaxForLimit

public boolean useMaxForLimit()
Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?

openQuote

public char openQuote()
The opening quote for a quoted identifier

closeQuote

public char closeQuote()
The closing quote for a quoted identifier

getFunctions

public final Map getFunctions()
SQL functions as defined in general. The results of this method should be integrated with the specialisation's data.

supportsIfExistsBeforeTableName

public boolean supportsIfExistsBeforeTableName()

supportsIfExistsAfterTableName

public boolean supportsIfExistsAfterTableName()

supportsColumnCheck

public boolean supportsColumnCheck()
Does this dialect support column-level check constraints?

supportsTableCheck

public boolean supportsTableCheck()
Does this dialect support table-level check constraints?

hasDataTypeInIdentityColumn

public boolean hasDataTypeInIdentityColumn()
Whether this dialect have an Identity clause added to the data type or a completely seperate identity data type

Returns:
boolean

supportsCascadeDelete

public boolean supportsCascadeDelete()

appendLockHint

public String appendLockHint(LockMode mode,
                             String tableName)
Method appendLockHint appends according to the given lock mode a lock hint behind the given table name, if this dialect needs this. MS SQL Server for example doesn't support the standard "select ... for update" syntax and use a special "select ... from TABLE as ALIAS with (updlock, rowlock) where ..." syntax instead.

Parameters:
tableName - name of table to append lock hint
Returns:
String

author Helge Schulz

getNativeIdentifierGeneratorClass

public Class getNativeIdentifierGeneratorClass()

getSelectGUIDString

public String getSelectGUIDString()

supportsOuterJoinForUpdate

public boolean supportsOuterJoinForUpdate()

getSelectClauseNullString

public String getSelectClauseNullString(int sqlType)

supportsNotNullUnique

public boolean supportsNotNullUnique()

buildSQLExceptionConverter

public SQLExceptionConverter buildSQLExceptionConverter()
Build an instance of the SQLExceptionConverter preferred by this dialect for converting SQLExceptions into Hibernate's JDBCException hierarchy. The default Dialect implementation simply returns a converter based on X/Open SQLState codes.

It is strongly recommended that specific Dialect implementations override this method, since interpretation of a SQL error is much more accurate when based on the ErrorCode rather than the SQLState. Unfortunately, the ErrorCode is a vendor- specific approach.

Returns:
The Dialect's preferred SQLExceptionConverter.

getViolatedConstraintNameExtracter

public ViolatedConstraintNameExtracter getViolatedConstraintNameExtracter()

quote

public final String quote(String column)

hasSelfReferentialForeignKeyBug

public boolean hasSelfReferentialForeignKeyBug()

useInputStreamToInsertBlob

public boolean useInputStreamToInsertBlob()

registerResultSetOutParameter

public int registerResultSetOutParameter(CallableStatement statement,
                                         int col)
                                  throws SQLException
Throws:
SQLException

getResultSet

public ResultSet getResultSet(CallableStatement ps)
                       throws SQLException
Throws:
SQLException

supportsUnionAll

public boolean supportsUnionAll()

supportsCommentOn

public boolean supportsCommentOn()

getTableComment

public String getTableComment(String comment)

getColumnComment

public String getColumnComment(String comment)

transformSelectString

public String transformSelectString(String select)

supportsTemporaryTables

public boolean supportsTemporaryTables()

generateTemporaryTableName

public String generateTemporaryTableName(String baseTableName)

getCreateTemporaryTableString

public String getCreateTemporaryTableString()

performTemporaryTableDDLInIsolation

public boolean performTemporaryTableDDLInIsolation()

getCreateTemporaryTablePostfix

public String getCreateTemporaryTablePostfix()

dropTemporaryTableAfterUse

public boolean dropTemporaryTableAfterUse()

getForUpdateString

public String getForUpdateString(LockMode lockMode)

getMaxAliasLength

public int getMaxAliasLength()

supportsCurrentTimestampSelection

public boolean supportsCurrentTimestampSelection()

getCurrentTimestampSelectString

public String getCurrentTimestampSelectString()

isCurrentTimestampSelectStringCallable

public boolean isCurrentTimestampSelectStringCallable()

toBooleanValueString

public String toBooleanValueString(boolean bool)
The SQL value that the JDBC driver maps boolean values to

supportsParametersInInsertSelect

public boolean supportsParametersInInsertSelect()
Does this dialect support parameters within the select clause of INSERT ... SELECT ... statements?

Returns:
True if this is supported; false otherwise.

getCurrentTimestampSQLFunctionName

public String getCurrentTimestampSQLFunctionName()
The name of the database-specific SQL function for retrieving the current timestamp.

Returns:
The function name.

getLockingStrategy

public LockingStrategy getLockingStrategy(Lockable lockable,
                                          LockMode lockMode)
Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.

Parameters:
lockable - The persister for the entity to be locked.
lockMode - The type of lock to be acquired.
Returns:
The appropriate locking strategy.
Since:
3.2

supportsRowValueConstructorSyntax

public boolean supportsRowValueConstructorSyntax()
Is this dialect known to support what ANSI-SQL terms "row value constructor" syntax; sometimes called tuple syntax.

Basically, does it support syntax like "... where (FIRST_NAME, LAST_NAME) = ('Steve', 'Ebersole') ...".

Returns:
True if this SQL dialect is known to support "row value constructor" syntax; false otherwise.
Since:
3.2
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DialectFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class DialectFactory

java.lang.Object
    extended by org.hibernate.dialect.DialectFactory
public class DialectFactory
extends Object

A factory for generating Dialect instances.

Author:
Steve Ebersole

Nested Class Summary
static interface | DialectFactory.DatabaseDialectMapper For a given database product name, instances of DatabaseDialectMapper know which Dialect to use for different versions.
static class | DialectFactory.VersionInsensitiveMapper A simple DatabaseDialectMapper for dialects which are independent of the underlying database product version.
Constructor Summary
DialectFactory()
Method Summary
static Dialect | buildDialect(Properties props, String databaseName, int databaseMajorVersion) Builds an appropriate Dialect instance.
static Dialect | buildDialect(String dialectName) Returns a dialect instance given the name of the class to use.
static Dialect | determineDialect(String databaseName, int databaseMajorVersion) Determine the appropriate Dialect to use given the database product name and major version.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DialectFactory

public DialectFactory()
Method Detail

buildDialect

public static Dialect buildDialect(Properties props,
                                   String databaseName,
                                   int databaseMajorVersion)
                            throws HibernateException
Builds an appropriate Dialect instance.

If a dialect is explicitly named in the incoming properties, it is used. Otherwise, the database name and version (obtained from connection metadata) are used to make the dertemination.

An exception is thrown if a dialect was not explicitly set and the database name is not known.

Parameters:
props - The configuration properties.
databaseName - The name of the database product (obtained from metadata).
databaseMajorVersion - The major version of the database product (obtained from metadata).
Returns:
The appropriate dialect.
Throws:
HibernateException - No dialect specified and database name not known.

determineDialect

public static Dialect determineDialect(String databaseName,
                                       int databaseMajorVersion)
Determine the appropriate Dialect to use given the database product name and major version.

Parameters:
databaseName - The name of the database product (obtained from metadata).
databaseMajorVersion - The major version of the database product (obtained from metadata).
Returns:
An appropriate dialect instance.

buildDialect

public static Dialect buildDialect(String dialectName)
Returns a dialect instance given the name of the class to use.

Parameters:
dialectName - The name of the dialect class.
Returns:
The dialect instance.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DialectFactory.DatabaseDialectMapper (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Interface DialectFactory.DatabaseDialectMapper

All Known Implementing Classes:
DialectFactory.VersionInsensitiveMapper
Enclosing interface:
DialectFactory
public static interface DialectFactory.DatabaseDialectMapper

For a given database product name, instances of DatabaseDialectMapper know which Dialect to use for different versions.

Method Summary
 String getDialectClass(int majorVersion)

Method Detail

getDialectClass

public String getDialectClass(int majorVersion)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DialectFactory.VersionInsensitiveMapper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class DialectFactory.VersionInsensitiveMapper

java.lang.Object
    extended by org.hibernate.dialect.DialectFactory.VersionInsensitiveMapper
All Implemented Interfaces:
DialectFactory.DatabaseDialectMapper
Enclosing class:
DialectFactory
public static class DialectFactory.VersionInsensitiveMapper
extends Object
implements DialectFactory.DatabaseDialectMapper

A simple DatabaseDialectMapper for dialects which are independent of the underlying database product version.

Constructor Summary
DialectFactory.VersionInsensitiveMapper(String dialectClassName)
Method Summary
 String getDialectClass(int majorVersion)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DialectFactory.VersionInsensitiveMapper

public DialectFactory.VersionInsensitiveMapper(String dialectClassName)
Method Detail

getDialectClass

public String getDialectClass(int majorVersion)
Specified by:
getDialectClass in interface DialectFactory.DatabaseDialectMapper
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FirebirdDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class FirebirdDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.InterbaseDialect
            extended by org.hibernate.dialect.FirebirdDialect
public class FirebirdDialect
extends InterbaseDialect

An SQL dialect for Firebird.

Author:
Reha CENANI

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
FirebirdDialect()
Method Summary
boolean | bindLimitParametersFirst() Does the LIMIT clause come at the start of the SELECT statement, rather than at the end?
boolean | bindLimitParametersInReverseOrder() Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?
String | getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String | getLimitString(String sql, boolean hasOffset) Add a LIMIT clause to the given SQL SELECT
Methods inherited from class org.hibernate.dialect.InterbaseDialect
getAddColumnString, getCreateSequenceString, getCurrentTimestampCallString, getForUpdateString, getForUpdateString, getQuerySequencesString, getSelectSequenceNextValString, getSequenceNextValString, isCurrentTimestampSelectStringCallable, supportsLimit, supportsSequences
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsTemporaryTables, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FirebirdDialect

public FirebirdDialect()
Method Detail

getDropSequenceString

public String getDropSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceString in class InterbaseDialect

getLimitString

public String getLimitString(String sql,
                             boolean hasOffset)
Description copied from class: Dialect
Add a LIMIT clause to the given SQL SELECT

Overrides:
getLimitString in class InterbaseDialect

bindLimitParametersFirst

public boolean bindLimitParametersFirst()
Description copied from class: Dialect
Does the LIMIT clause come at the start of the SELECT statement, rather than at the end?

Overrides:
bindLimitParametersFirst in class InterbaseDialect

bindLimitParametersInReverseOrder

public boolean bindLimitParametersInReverseOrder()
Description copied from class: Dialect
Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?

Overrides:
bindLimitParametersInReverseOrder in class InterbaseDialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FrontBaseDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class FrontBaseDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.FrontBaseDialect
public class FrontBaseDialect
extends Dialect

An SQL Dialect for Frontbase. Assumes you're using the latest version of the FrontBase JDBC driver, available from http://frontbase.com/

NOTE: The latest JDBC driver is not always included with the latest release of FrontBase. Download the driver separately, and enjoy the informative release notes.

This dialect was tested with JDBC driver version 2.3.1. This driver contains a bug that causes batches of updates to fail. (The bug should be fixed in the next release of the JDBC driver.) If you are using JDBC driver 2.3.1, you can work-around this problem by setting the following in your hibernate.properties file: hibernate.jdbc.batch_size=15

Author:
Ron Lussier rlussier@lenscraft.com

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
FrontBaseDialect()
Method Summary
boolean | dropConstraints() Do we need to drop constraints before dropping tables in this dialect?
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getCascadeConstraintsString() Completely optional cascading drop clause
String | getCurrentTimestampCallString()
String | getForUpdateString() Does this dialect support the FOR UPDATE syntax.
LockingStrategy | getLockingStrategy(Lockable lockable, LockMode lockMode) Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.
boolean | isCurrentTimestampSelectStringCallable()
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCastTypeName, getColumnComment, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLimitString, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getQuerySequencesString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getSelectSequenceNextValString, getSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimit, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsSequences, supportsTableCheck, supportsTemporaryTables, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FrontBaseDialect

public FrontBaseDialect()
Method Detail

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

getCascadeConstraintsString

public String getCascadeConstraintsString()
Description copied from class: Dialect
Completely optional cascading drop clause

Overrides:
getCascadeConstraintsString in class Dialect
Returns:
String

dropConstraints

public boolean dropConstraints()
Description copied from class: Dialect
Do we need to drop constraints before dropping tables in this dialect?

Overrides:
dropConstraints in class Dialect
Returns:
boolean

getForUpdateString

public String getForUpdateString()
Does this dialect support the FOR UPDATE syntax. No!

Overrides:
getForUpdateString in class Dialect
Returns:
false always. FrontBase doesn't support this syntax, which was dropped with SQL92

getCurrentTimestampCallString

public String getCurrentTimestampCallString()

isCurrentTimestampSelectStringCallable

public boolean isCurrentTimestampSelectStringCallable()
Overrides:
isCurrentTimestampSelectStringCallable in class Dialect

getLockingStrategy

public LockingStrategy getLockingStrategy(Lockable lockable,
                                          LockMode lockMode)
Description copied from class: Dialect
Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.

Overrides:
getLockingStrategy in class Dialect
Parameters:
lockable - The persister for the entity to be locked.
lockMode - The type of lock to be acquired.
Returns:
The appropriate locking strategy.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


H2Dialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class H2Dialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.H2Dialect
public class H2Dialect
extends Dialect

A dialect compatible with the H2 database.

Author:
Thomas Mueller

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
H2Dialect()
Method Summary
boolean | bindLimitParametersFirst() Does the LIMIT clause come at the start of the SELECT statement, rather than at the end?
boolean | bindLimitParametersInReverseOrder() Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?
String | getAddColumnString() The syntax used to add a column to a table (optional).
String[] | getCreateSequenceStrings(String sequenceName) The multiline script used to create a sequence, if sequences are supported.
String | getCreateTemporaryTableString()
String | getCurrentTimestampSelectString()
String[] | getDropSequenceStrings(String sequenceName) The multiline script used to drop a sequence, if sequences are supported.
String | getForUpdateString() Retrieves the FOR UPDATE syntax specific to this dialect.
String | getIdentityColumnString()
String | getIdentityInsertString() The keyword used to insert a generated value into an identity column (or null).
String | getIdentitySelectString()
String | getLimitString(String sql, boolean hasOffset) Add a LIMIT clause to the given SQL SELECT
String | getQuerySequencesString() A query used to find all sequences
String | getSelectSequenceNextValString(String sequenceName) Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.
String | getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
ViolatedConstraintNameExtracter | getViolatedConstraintNameExtracter()
boolean | isCurrentTimestampSelectStringCallable()
boolean | supportsCurrentTimestampSelection()
boolean | supportsIdentityColumns() Does this dialect support identity column key generation?
boolean | supportsIfExistsAfterTableName()
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsTemporaryTables()
boolean | supportsUnionAll()
boolean | supportsUnique() Does this dialect support the UNIQUE column syntax?
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceString, getCreateTemporaryTablePostfix, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceString, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getTableComment, getTableTypeString, getTypeName, getTypeName, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

H2Dialect

public H2Dialect()
Method Detail

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

supportsIdentityColumns

public boolean supportsIdentityColumns()
Description copied from class: Dialect
Does this dialect support identity column key generation?

Overrides:
supportsIdentityColumns in class Dialect
Returns:
boolean

getIdentityColumnString

public String getIdentityColumnString()
Overrides:
getIdentityColumnString in class Dialect

getIdentitySelectString

public String getIdentitySelectString()
Overrides:
getIdentitySelectString in class Dialect

getIdentityInsertString

public String getIdentityInsertString()
Description copied from class: Dialect
The keyword used to insert a generated value into an identity column (or null). Need if the dialect does not support inserts that specify no column values.

Overrides:
getIdentityInsertString in class Dialect
Returns:
String

getForUpdateString

public String getForUpdateString()
Description copied from class: Dialect
Retrieves the FOR UPDATE syntax specific to this dialect.

Overrides:
getForUpdateString in class Dialect
Returns:
The appropriate FOR UPDATE clause string.

supportsUnique

public boolean supportsUnique()
Description copied from class: Dialect
Does this dialect support the UNIQUE column syntax?

Overrides:
supportsUnique in class Dialect
Returns:
boolean

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class Dialect

getLimitString

public String getLimitString(String sql,
                             boolean hasOffset)
Description copied from class: Dialect
Add a LIMIT clause to the given SQL SELECT

Overrides:
getLimitString in class Dialect
Returns:
the modified SQL

bindLimitParametersInReverseOrder

public boolean bindLimitParametersInReverseOrder()
Description copied from class: Dialect
Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?

Overrides:
bindLimitParametersInReverseOrder in class Dialect
Returns:
true if the correct order is limit, offset

bindLimitParametersFirst

public boolean bindLimitParametersFirst()
Description copied from class: Dialect
Does the LIMIT clause come at the start of the SELECT statement, rather than at the end?

Overrides:
bindLimitParametersFirst in class Dialect
Returns:
true if limit parameters should come before other parameters

supportsIfExistsAfterTableName

public boolean supportsIfExistsAfterTableName()
Overrides:
supportsIfExistsAfterTableName in class Dialect

getCreateSequenceStrings

public String[] getCreateSequenceStrings(String sequenceName)
Description copied from class: Dialect
The multiline script used to create a sequence, if sequences are supported.

Overrides:
getCreateSequenceStrings in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String[]

getDropSequenceStrings

public String[] getDropSequenceStrings(String sequenceName)
Description copied from class: Dialect
The multiline script used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceStrings in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String[]

getSelectSequenceNextValString

public String getSelectSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.

This differs from Dialect.getSequenceNextValString(String) in that this should return an expression usable within another select statement.

Overrides:
getSelectSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.

This should be a "stand alone" select statement.

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.

getQuerySequencesString

public String getQuerySequencesString()
Description copied from class: Dialect
A query used to find all sequences

Overrides:
getQuerySequencesString in class Dialect
See Also:
SchemaUpdate

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class Dialect
Returns:
boolean

getViolatedConstraintNameExtracter

public ViolatedConstraintNameExtracter getViolatedConstraintNameExtracter()
Overrides:
getViolatedConstraintNameExtracter in class Dialect

supportsTemporaryTables

public boolean supportsTemporaryTables()
Overrides:
supportsTemporaryTables in class Dialect

getCreateTemporaryTableString

public String getCreateTemporaryTableString()
Overrides:
getCreateTemporaryTableString in class Dialect

supportsCurrentTimestampSelection

public boolean supportsCurrentTimestampSelection()
Overrides:
supportsCurrentTimestampSelection in class Dialect

isCurrentTimestampSelectStringCallable

public boolean isCurrentTimestampSelectStringCallable()
Overrides:
isCurrentTimestampSelectStringCallable in class Dialect

getCurrentTimestampSelectString

public String getCurrentTimestampSelectString()
Overrides:
getCurrentTimestampSelectString in class Dialect

supportsUnionAll

public boolean supportsUnionAll()
Overrides:
supportsUnionAll in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSQLDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class HSQLDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.HSQLDialect
public class HSQLDialect
extends Dialect

An SQL dialect compatible with HSQLDB (Hypersonic SQL).

Note this version supports HSQLDB version 1.8 and higher, only.

Author:
Christoph Sturm, Phillip Baird

Nested Class Summary
static class HSQLDialect.ReadUncommittedLockingStrategy
Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
HSQLDialect()
Method Summary
boolean | bindLimitParametersFirst() Does the LIMIT clause come at the start of the SELECT statement, rather than at the end?
String | getAddColumnString() The syntax used to add a column to a table (optional).
String[] | getCreateSequenceStrings(String sequenceName) The multiline script used to create a sequence, if sequences are supported.
String[] | getDropSequenceStrings(String sequenceName) The multiline script used to drop a sequence, if sequences are supported.
String | getForUpdateString() Retrieves the FOR UPDATE syntax specific to this dialect.
String | getIdentityColumnString()
String | getIdentityInsertString() The keyword used to insert a generated value into an identity column (or null).
String | getIdentitySelectString()
String | getLimitString(String sql, boolean hasOffset) Add a LIMIT clause to the given SQL SELECT
LockingStrategy | getLockingStrategy(Lockable lockable, LockMode lockMode) Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.
String | getQuerySequencesString() A query used to find all sequences
String | getSelectSequenceNextValString(String sequenceName) Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.
String | getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
ViolatedConstraintNameExtracter | getViolatedConstraintNameExtracter()
boolean | supportsColumnCheck() Does this dialect support column-level check constraints?
boolean | supportsCurrentTimestampSelection()
boolean | supportsIdentityColumns() Does this dialect support identity column key generation?
boolean | supportsIfExistsAfterTableName()
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsTemporaryTables() HSQL does not really support temp tables; just take advantage of the fact that it is a single user db...
boolean | supportsUnique() Does this dialect support the UNIQUE column syntax?
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceString, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceString, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentitySelectString, getKeywords, getLimitString, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getTableComment, getTableTypeString, getTypeName, getTypeName, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, isCurrentTimestampSelectStringCallable, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsCommentOn, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsUnionAll, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HSQLDialect

public HSQLDialect()
Method Detail

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

supportsIdentityColumns

public boolean supportsIdentityColumns()
Description copied from class: Dialect
Does this dialect support identity column key generation?

Overrides:
supportsIdentityColumns in class Dialect
Returns:
boolean

getIdentityColumnString

public String getIdentityColumnString()
Overrides:
getIdentityColumnString in class Dialect

getIdentitySelectString

public String getIdentitySelectString()
Overrides:
getIdentitySelectString in class Dialect

getIdentityInsertString

public String getIdentityInsertString()
Description copied from class: Dialect
The keyword used to insert a generated value into an identity column (or null). Need if the dialect does not support inserts that specify no column values.

Overrides:
getIdentityInsertString in class Dialect
Returns:
String

getForUpdateString

public String getForUpdateString()
Description copied from class: Dialect
Retrieves the FOR UPDATE syntax specific to this dialect.

Overrides:
getForUpdateString in class Dialect
Returns:
The appropriate FOR UPDATE clause string.

supportsUnique

public boolean supportsUnique()
Description copied from class: Dialect
Does this dialect support the UNIQUE column syntax?

Overrides:
supportsUnique in class Dialect
Returns:
boolean

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class Dialect

getLimitString

public String getLimitString(String sql,
                             boolean hasOffset)
Description copied from class: Dialect
Add a LIMIT clause to the given SQL SELECT

Overrides:
getLimitString in class Dialect
Returns:
the modified SQL

bindLimitParametersFirst

public boolean bindLimitParametersFirst()
Description copied from class: Dialect
Does the LIMIT clause come at the start of the SELECT statement, rather than at the end?

Overrides:
bindLimitParametersFirst in class Dialect
Returns:
true if limit parameters should come before other parameters

supportsIfExistsAfterTableName

public boolean supportsIfExistsAfterTableName()
Overrides:
supportsIfExistsAfterTableName in class Dialect

supportsColumnCheck

public boolean supportsColumnCheck()
Description copied from class: Dialect
Does this dialect support column-level check constraints?

Overrides:
supportsColumnCheck in class Dialect

getCreateSequenceStrings

public String[] getCreateSequenceStrings(String sequenceName)
Description copied from class: Dialect
The multiline script used to create a sequence, if sequences are supported.

Overrides:
getCreateSequenceStrings in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String[]

getDropSequenceStrings

public String[] getDropSequenceStrings(String sequenceName)
Description copied from class: Dialect
The multiline script used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceStrings in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String[]

getSelectSequenceNextValString

public String getSelectSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.

This differs from Dialect.getSequenceNextValString(String) in that this should return an expression usable within another select statement.

Overrides:
getSelectSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.

This should be a "stand alone" select statement.

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.

getQuerySequencesString

public String getQuerySequencesString()
Description copied from class: Dialect
A query used to find all sequences

Overrides:
getQuerySequencesString in class Dialect
See Also:
SchemaUpdate

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class Dialect
Returns:
boolean

getViolatedConstraintNameExtracter

public ViolatedConstraintNameExtracter getViolatedConstraintNameExtracter()
Overrides:
getViolatedConstraintNameExtracter in class Dialect

supportsTemporaryTables

public boolean supportsTemporaryTables()
HSQL does not really support temp tables; just take advantage of the fact that it is a single user db...

Overrides:
supportsTemporaryTables in class Dialect

supportsCurrentTimestampSelection

public boolean supportsCurrentTimestampSelection()
Overrides:
supportsCurrentTimestampSelection in class Dialect

getLockingStrategy

public LockingStrategy getLockingStrategy(Lockable lockable,
                                          LockMode lockMode)
Description copied from class: Dialect
Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.

Overrides:
getLockingStrategy in class Dialect
Parameters:
lockable - The persister for the entity to be locked.
lockMode - The type of lock to be acquired.
Returns:
The appropriate locking strategy.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSQLDialect.ReadUncommittedLockingStrategy (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class HSQLDialect.ReadUncommittedLockingStrategy

java.lang.Object
    extended by org.hibernate.dialect.lock.SelectLockingStrategy
        extended by org.hibernate.dialect.HSQLDialect.ReadUncommittedLockingStrategy
All Implemented Interfaces:
LockingStrategy
Enclosing class:
HSQLDialect
public static class HSQLDialect.ReadUncommittedLockingStrategy
extends SelectLockingStrategy

Constructor Summary
HSQLDialect.ReadUncommittedLockingStrategy(Lockable lockable, LockMode lockMode)
Method Summary
 void lock(Serializable id, Object version, Object object, SessionImplementor session)
Acquire an appropriate type of lock on the underlying data that will endure until the end of the current transaction.
Methods inherited from class org.hibernate.dialect.lock.SelectLockingStrategy
generateLockString, getLockMode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSQLDialect.ReadUncommittedLockingStrategy

public HSQLDialect.ReadUncommittedLockingStrategy(Lockable lockable,
                                                  LockMode lockMode)
Method Detail

lock

public void lock(Serializable id,
                 Object version,
                 Object object,
                 SessionImplementor session)
          throws StaleObjectStateException,
                 JDBCException
Description copied from interface: LockingStrategy
Acquire an appropriate type of lock on the underlying data that will endure until the end of the current transaction.

Specified by:
lock in interface LockingStrategy
Overrides:
lock in class SelectLockingStrategy
Throws:
StaleObjectStateException
JDBCException
See Also:
LockingStrategy.lock(java.io.Serializable, java.lang.Object, java.lang.Object, org.hibernate.engine.SessionImplementor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InformixDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class InformixDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.InformixDialect
public class InformixDialect
extends Dialect

Informix dialect.

Seems to work with Informix Dynamic Server Version 7.31.UD3, Informix JDBC driver version 2.21JC3.

Author:
Steve Molitor

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
InformixDialect()
Creates new InformixDialect instance.
Method Summary
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getAddForeignKeyConstraintString(String constraintName, String[] foreignKey, String referencedTable, String[] primaryKey, boolean referencesPrimaryKey) The syntax used to add a foreign key constraint to a table.
String | getAddPrimaryKeyConstraintString(String constraintName) The syntax used to add a primary key constraint to a table.
String | getCreateSequenceString(String sequenceName) The syntax used to create a sequence, if sequences are supported.
String | getCurrentTimestampSelectString()
String | getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String | getIdentityColumnString(int type) The keyword used to specify an identity column, if identity column key generation is supported.
String | getIdentitySelectString(String table, String column, int type) The syntax that returns the identity value of the last insert, if identity column key generation is supported.
String | getLimitString(String querySelect, int offset, int limit)
String | getSelectSequenceNextValString(String sequenceName) Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.
String | getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
ViolatedConstraintNameExtracter | getViolatedConstraintNameExtracter()
boolean | hasDataTypeInIdentityColumn() Whether this dialect have an Identity clause added to the data type or a completely seperate identity data type
boolean | isCurrentTimestampSelectStringCallable()
boolean | supportsCurrentTimestampSelection()
boolean | supportsIdentityColumns() Does this dialect support identity column key generation?
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsLimitOffset() Does this dialect support an offset?
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsVariableLimit()
boolean | useMaxForLimit() Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getQuerySequencesString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getTableComment, getTableTypeString, getTypeName, getTypeName, hasAlterTable, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsTemporaryTables, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InformixDialect

public InformixDialect()
Creates new InformixDialect instance. Sets up the JDBC / Informix type mappings.

Method Detail

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

supportsIdentityColumns

public boolean supportsIdentityColumns()
Description copied from class: Dialect
Does this dialect support identity column key generation?

Overrides:
supportsIdentityColumns in class Dialect
Returns:
boolean

getIdentitySelectString

public String getIdentitySelectString(String table,
                                      String column,
                                      int type)
                               throws MappingException
Description copied from class: Dialect
The syntax that returns the identity value of the last insert, if identity column key generation is supported.

Overrides:
getIdentitySelectString in class Dialect
Parameters:
type - TODO
Throws:
MappingException - if no native key generation

getIdentityColumnString

public String getIdentityColumnString(int type)
                               throws MappingException
Description copied from class: Dialect
The keyword used to specify an identity column, if identity column key generation is supported.

Overrides:
getIdentityColumnString in class Dialect
Parameters:
type - the SQL column type, as defined by java.sql.Types
Throws:
MappingException - if no native key generation

hasDataTypeInIdentityColumn

public boolean hasDataTypeInIdentityColumn()
Description copied from class: Dialect
Whether this dialect have an Identity clause added to the data type or a completely seperate identity data type

Overrides:
hasDataTypeInIdentityColumn in class Dialect
Returns:
boolean

getAddForeignKeyConstraintString

public String getAddForeignKeyConstraintString(String constraintName,
                                               String[] foreignKey,
                                               String referencedTable,
                                               String[] primaryKey,
                                               boolean referencesPrimaryKey)
The syntax used to add a foreign key constraint to a table. Informix constraint name must be at the end.

Overrides:
getAddForeignKeyConstraintString in class Dialect
Parameters:
referencesPrimaryKey - if false, constraint should be explicit about which column names the constraint refers to
Returns:
String

getAddPrimaryKeyConstraintString

public String getAddPrimaryKeyConstraintString(String constraintName)
The syntax used to add a primary key constraint to a table. Informix constraint name must be at the end.

Overrides:
getAddPrimaryKeyConstraintString in class Dialect
Returns:
String

getCreateSequenceString

public String getCreateSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to create a sequence, if sequences are supported.

Overrides:
getCreateSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getDropSequenceString

public String getDropSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.

This should be a "stand alone" select statement.

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.

getSelectSequenceNextValString

public String getSelectSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.

This differs from Dialect.getSequenceNextValString(String) in that this should return an expression usable within another select statement.

Overrides:
getSelectSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class Dialect
Returns:
boolean

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class Dialect

useMaxForLimit

public boolean useMaxForLimit()
Description copied from class: Dialect
Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?

Overrides:
useMaxForLimit in class Dialect

supportsLimitOffset

public boolean supportsLimitOffset()
Description copied from class: Dialect
Does this dialect support an offset?

Overrides:
supportsLimitOffset in class Dialect

getLimitString

public String getLimitString(String querySelect,
                             int offset,
                             int limit)
Overrides:
getLimitString in class Dialect

supportsVariableLimit

public boolean supportsVariableLimit()
Overrides:
supportsVariableLimit in class Dialect

getViolatedConstraintNameExtracter

public ViolatedConstraintNameExtracter getViolatedConstraintNameExtracter()
Overrides:
getViolatedConstraintNameExtracter in class Dialect

supportsCurrentTimestampSelection

public boolean supportsCurrentTimestampSelection()
Overrides:
supportsCurrentTimestampSelection in class Dialect

isCurrentTimestampSelectStringCallable

public boolean isCurrentTimestampSelectStringCallable()
Overrides:
isCurrentTimestampSelectStringCallable in class Dialect

getCurrentTimestampSelectString

public String getCurrentTimestampSelectString()
Overrides:
getCurrentTimestampSelectString in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IngresDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class IngresDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.IngresDialect
public class IngresDialect
extends Dialect

An Ingres SQL dialect

Author:
Ian Booth, Bruce Lunsford

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
IngresDialect()
Method Summary
boolean | dropConstraints() Do we need to drop constraints before dropping tables in this dialect?
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getCreateSequenceString(String sequenceName) The syntax used to create a sequence, if sequences are supported.
String | getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String | getLimitString(String querySelect, int offset, int limit) Add a LIMIT clause to the given SQL SELECT
String | getLowercaseFunction() The name of the SQL function that transforms a string to lowercase
String | getNullColumnString() The keyword used to specify a nullable column.
String | getQuerySequencesString() A query used to find all sequences
String | getSequenceNextValString(String sequenceName) The syntax that fetches the next value of a sequence, if sequences are supported.
boolean | supportsForUpdateOf() Does this dialect support FOR UPDATE OF, allowing particular rows to be locked?
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsLimitOffset() Does this dialect support an offset?
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsVariableLimit()
boolean | useMaxForLimit() Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getSelectSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, isCurrentTimestampSelectStringCallable, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsTemporaryTables, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IngresDialect

public IngresDialect()
Method Detail

dropConstraints

public boolean dropConstraints()
Do we need to drop constraints before dropping tables in this dialect?

Overrides:
dropConstraints in class Dialect
Returns:
boolean

supportsForUpdateOf

public boolean supportsForUpdateOf()
Does this dialect support FOR UPDATE OF, allowing particular rows to be locked?

getAddColumnString

public String getAddColumnString()
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

getNullColumnString

public String getNullColumnString()
The keyword used to specify a nullable column.

Overrides:
getNullColumnString in class Dialect
Returns:
String

supportsSequences

public boolean supportsSequences()
Does this dialect support sequences?

Overrides:
supportsSequences in class Dialect
Returns:
boolean

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
The syntax that fetches the next value of a sequence, if sequences are supported.

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String
Throws:
MappingException - if no sequences

getCreateSequenceString

public String getCreateSequenceString(String sequenceName)
The syntax used to create a sequence, if sequences are supported.

Overrides:
getCreateSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String
Throws:
MappingException - if no sequences

getDropSequenceString

public String getDropSequenceString(String sequenceName)
The syntax used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String
Throws:
MappingException - if no sequences

getQuerySequencesString

public String getQuerySequencesString()
A query used to find all sequences

Overrides:
getQuerySequencesString in class Dialect
See Also:
SchemaUpdate

getLowercaseFunction

public String getLowercaseFunction()
The name of the SQL function that transforms a string to lowercase

Overrides:
getLowercaseFunction in class Dialect
Returns:
String

supportsLimit

public boolean supportsLimit()
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class Dialect

supportsLimitOffset

public boolean supportsLimitOffset()
Does this dialect support an offset?

Overrides:
supportsLimitOffset in class Dialect

getLimitString

public String getLimitString(String querySelect,
                             int offset,
                             int limit)
Add a LIMIT clause to the given SQL SELECT

Overrides:
getLimitString in class Dialect
Returns:
the modified SQL

supportsVariableLimit

public boolean supportsVariableLimit()
Overrides:
supportsVariableLimit in class Dialect

useMaxForLimit

public boolean useMaxForLimit()
Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?

Overrides:
useMaxForLimit in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterbaseDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class InterbaseDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.InterbaseDialect
Direct Known Subclasses:
FirebirdDialect
public class InterbaseDialect
extends Dialect

An SQL dialect for Interbase.

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
InterbaseDialect()
Method Summary
boolean | bindLimitParametersFirst() Does the LIMIT clause come at the start of the SELECT statement, rather than at the end?
boolean | bindLimitParametersInReverseOrder() Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getCreateSequenceString(String sequenceName) The syntax used to create a sequence, if sequences are supported.
String | getCurrentTimestampCallString()
String | getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String | getForUpdateString() Retrieves the FOR UPDATE syntax specific to this dialect.
String | getForUpdateString(String aliases) Retrieves the FOR UPDATE OF column_list syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.
String | getLimitString(String sql, boolean hasOffset) Add a LIMIT clause to the given SQL SELECT
String | getQuerySequencesString() A query used to find all sequences
String | getSelectSequenceNextValString(String sequenceName) Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.
String | getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
boolean | isCurrentTimestampSelectStringCallable()
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsSequences() Does this dialect support sequences?
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsTemporaryTables, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InterbaseDialect

public InterbaseDialect()
Method Detail

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.

This should be a "stand alone" select statement.

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.

getSelectSequenceNextValString

public String getSelectSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.

This differs from Dialect.getSequenceNextValString(String) in that this should return an expression usable within another select statement.

Overrides:
getSelectSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getCreateSequenceString

public String getCreateSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to create a sequence, if sequences are supported.

Overrides:
getCreateSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getDropSequenceString

public String getDropSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getQuerySequencesString

public String getQuerySequencesString()
Description copied from class: Dialect
A query used to find all sequences

Overrides:
getQuerySequencesString in class Dialect
See Also:
SchemaUpdate

getForUpdateString

public String getForUpdateString()
Description copied from class: Dialect
Retrieves the FOR UPDATE syntax specific to this dialect.

Overrides:
getForUpdateString in class Dialect
Returns:
The appropriate FOR UPDATE clause string.

getForUpdateString

public String getForUpdateString(String aliases)
Description copied from class: Dialect
Retrieves the FOR UPDATE OF column_list syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.

Overrides:
getForUpdateString in class Dialect
Returns:
The appropriate FOR UPDATE OF column_list clause string.

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class Dialect
Returns:
boolean

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class Dialect

getLimitString

public String getLimitString(String sql,
                             boolean hasOffset)
Description copied from class: Dialect
Add a LIMIT clause to the given SQL SELECT

Overrides:
getLimitString in class Dialect
Returns:
the modified SQL

bindLimitParametersFirst

public boolean bindLimitParametersFirst()
Description copied from class: Dialect
Does the LIMIT clause come at the start of the SELECT statement, rather than at the end?

Overrides:
bindLimitParametersFirst in class Dialect
Returns:
true if limit parameters should come before other parameters

bindLimitParametersInReverseOrder

public boolean bindLimitParametersInReverseOrder()
Description copied from class: Dialect
Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?

Overrides:
bindLimitParametersInReverseOrder in class Dialect
Returns:
true if the correct order is limit, offset

getCurrentTimestampCallString

public String getCurrentTimestampCallString()

isCurrentTimestampSelectStringCallable

public boolean isCurrentTimestampSelectStringCallable()
Overrides:
isCurrentTimestampSelectStringCallable in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JDataStoreDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class JDataStoreDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.JDataStoreDialect
public class JDataStoreDialect
extends Dialect

A Dialect for JDataStore.

Author:
Vishy Kasar

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
JDataStoreDialect()
Creates new JDataStoreDialect
Method Summary
boolean | dropConstraints() Do we need to drop constraints before dropping tables in this dialect?
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getCascadeConstraintsString() Completely optional cascading drop clause
String | getIdentityColumnString()
String | getIdentitySelectString()
String | getNoColumnsInsertString() The keyword used to insert a row without specifying any column values.
boolean | supportsColumnCheck() Does this dialect support column-level check constraints?
boolean | supportsIdentityColumns() Does this dialect support identity column key generation?
boolean | supportsTableCheck() Does this dialect support table-level check constraints?
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCastTypeName, getColumnComment, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getKeywords, getLimitString, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNullColumnString, getQuerySequencesString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getSelectSequenceNextValString, getSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, isCurrentTimestampSelectStringCallable, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsCommentOn, supportsCurrentTimestampSelection, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimit, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsSequences, supportsTemporaryTables, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JDataStoreDialect

public JDataStoreDialect()
Creates new JDataStoreDialect

Method Detail

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

dropConstraints

public boolean dropConstraints()
Description copied from class: Dialect
Do we need to drop constraints before dropping tables in this dialect?

Overrides:
dropConstraints in class Dialect
Returns:
boolean

getCascadeConstraintsString

public String getCascadeConstraintsString()
Description copied from class: Dialect
Completely optional cascading drop clause

Overrides:
getCascadeConstraintsString in class Dialect
Returns:
String

supportsIdentityColumns

public boolean supportsIdentityColumns()
Description copied from class: Dialect
Does this dialect support identity column key generation?

Overrides:
supportsIdentityColumns in class Dialect
Returns:
boolean

getIdentitySelectString

public String getIdentitySelectString()
Overrides:
getIdentitySelectString in class Dialect

getIdentityColumnString

public String getIdentityColumnString()
Overrides:
getIdentityColumnString in class Dialect

getNoColumnsInsertString

public String getNoColumnsInsertString()
Description copied from class: Dialect
The keyword used to insert a row without specifying any column values. This is not possible on some databases.

Overrides:
getNoColumnsInsertString in class Dialect

supportsColumnCheck

public boolean supportsColumnCheck()
Description copied from class: Dialect
Does this dialect support column-level check constraints?

Overrides:
supportsColumnCheck in class Dialect

supportsTableCheck

public boolean supportsTableCheck()
Description copied from class: Dialect
Does this dialect support table-level check constraints?

Overrides:
supportsTableCheck in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MckoiDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class MckoiDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.MckoiDialect
public class MckoiDialect
extends Dialect

An SQL dialect compatible with McKoi SQL

Author:
Doug Currie, Gabe Hicks

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
MckoiDialect()
Method Summary
CaseFragment | createCaseFragment() Create a CaseFragment for this dialect.
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getCreateSequenceString(String sequenceName) The syntax used to create a sequence, if sequences are supported.
String | getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String | getForUpdateString() Retrieves the FOR UPDATE syntax specific to this dialect.
LockingStrategy | getLockingStrategy(Lockable lockable, LockMode lockMode) Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.
String | getSelectSequenceNextValString(String sequenceName) Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.
String | getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
boolean | supportsSequences() Does this dialect support sequences?
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createOuterJoinFragment, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLimitString, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getQuerySequencesString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, isCurrentTimestampSelectStringCallable, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimit, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsTemporaryTables, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MckoiDialect

public MckoiDialect()
Method Detail

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.

This should be a "stand alone" select statement.

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.

getSelectSequenceNextValString

public String getSelectSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.

This differs from Dialect.getSequenceNextValString(String) in that this should return an expression usable within another select statement.

Overrides:
getSelectSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getCreateSequenceString

public String getCreateSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to create a sequence, if sequences are supported.

Overrides:
getCreateSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getDropSequenceString

public String getDropSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getForUpdateString

public String getForUpdateString()
Description copied from class: Dialect
Retrieves the FOR UPDATE syntax specific to this dialect.

Overrides:
getForUpdateString in class Dialect
Returns:
The appropriate FOR UPDATE clause string.

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class Dialect
Returns:
boolean

createCaseFragment

public CaseFragment createCaseFragment()
Description copied from class: Dialect
Create a CaseFragment for this dialect.

Overrides:
createCaseFragment in class Dialect
Returns:
OuterJoinGenerator

getLockingStrategy

public LockingStrategy getLockingStrategy(Lockable lockable,
                                          LockMode lockMode)
Description copied from class: Dialect
Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.

Overrides:
getLockingStrategy in class Dialect
Parameters:
lockable - The persister for the entity to be locked.
lockMode - The type of lock to be acquired.
Returns:
The appropriate locking strategy.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MimerSQLDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class MimerSQLDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.MimerSQLDialect
public class MimerSQLDialect
extends Dialect

An Hibernate 3 SQL dialect for Mimer SQL. This dialect requires Mimer SQL 9.2.1 or later because of the mappings to NCLOB, BINARY, and BINARY VARYING.

Author:
Fredrik Ålund

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
MimerSQLDialect()
Even thoug Mimer SQL supports character and binary columns up to 15 000 in lenght, this is also the maximum width of the table (exluding LOBs).
Method Summary
boolean | dropConstraints() We do not have to drop constraints before we drop the table
boolean | forUpdateOfColumns() Does the FOR UPDATE OF syntax specify particular columns?
String | getAddColumnString() The syntax used to add a column to a table
String | getCascadeConstraintsString() The syntax for using cascade on constraints
String | getCreateSequenceString(String sequenceName) The syntax used to create a sequence.
String | getDropSequenceString(String sequenceName) The syntax used to drop sequences
String | getQuerySequencesString() The syntax for fetching all sequnces avialable in the current schema.
String | getSequenceNextValString(String sequenceName) The syntax used to get the next value of a sequence in Mimer SQL
boolean | supportsForUpdate() Support the FOR UPDATE syntax? For now, returns false since the current version of the Mimer SQL JDBC Driver does not support updatable resultsets.
boolean | supportsIdentityColumns() TODO: Check if Mimer SQL cannot handle the way DB2 does
boolean | supportsLimit() Mimer SQL does not support limit
boolean | supportsOuterJoinForUpdate() For now, simply return false since we don't updatable result sets.
boolean | supportsSequences() Mimer SQL supports sequences
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropTemporaryTableAfterUse, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getSelectSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, isCurrentTimestampSelectStringCallable, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsCurrentTimestampSelection, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsTemporaryTables, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MimerSQLDialect

public MimerSQLDialect()
Even thoug Mimer SQL supports character and binary columns up to 15 000 in lenght, this is also the maximum width of the table (exluding LOBs). To avoid breaking the limit all the time we limit the length of the character columns to CHAR_MAX_LENTH, NATIONAL_CHAR_LENGTH for national characters, and BINARY_MAX_LENGTH for binary types.

Method Detail

getAddColumnString

public String getAddColumnString()
The syntax used to add a column to a table

Overrides:
getAddColumnString in class Dialect

dropConstraints

public boolean dropConstraints()
We do not have to drop constraints before we drop the table

Overrides:
dropConstraints in class Dialect
Returns:
boolean

supportsIdentityColumns

public boolean supportsIdentityColumns()
TODO: Check if Mimer SQL cannot handle the way DB2 does

Overrides:
supportsIdentityColumns in class Dialect
Returns:
boolean

supportsSequences

public boolean supportsSequences()
Mimer SQL supports sequences

Overrides:
supportsSequences in class Dialect
Returns:
boolean

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
The syntax used to get the next value of a sequence in Mimer SQL

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.

getCreateSequenceString

public String getCreateSequenceString(String sequenceName)
The syntax used to create a sequence. Since we presume the sequences will be used as keys, we make them unique.

Overrides:
getCreateSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getDropSequenceString

public String getDropSequenceString(String sequenceName)
The syntax used to drop sequences

Overrides:
getDropSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

supportsLimit

public boolean supportsLimit()
Mimer SQL does not support limit

Overrides:
supportsLimit in class Dialect

getCascadeConstraintsString

public String getCascadeConstraintsString()
The syntax for using cascade on constraints

Overrides:
getCascadeConstraintsString in class Dialect
Returns:
String

getQuerySequencesString

public String getQuerySequencesString()
The syntax for fetching all sequnces avialable in the current schema.

Overrides:
getQuerySequencesString in class Dialect
See Also:
SchemaUpdate

forUpdateOfColumns

public boolean forUpdateOfColumns()
Does the FOR UPDATE OF syntax specify particular columns?

Overrides:
forUpdateOfColumns in class Dialect

supportsForUpdate

public boolean supportsForUpdate()
Support the FOR UPDATE syntax? For now, returns false since the current version of the Mimer SQL JDBC Driver does not support updatable resultsets. Otherwise, Mimer SQL actually supports the for update syntax.

Returns:
boolean

supportsOuterJoinForUpdate

public boolean supportsOuterJoinForUpdate()
For now, simply return false since we don't updatable result sets.

Overrides:
supportsOuterJoinForUpdate in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MySQL5Dialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class MySQL5Dialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.MySQLDialect
            extended by org.hibernate.dialect.MySQL5Dialect
Direct Known Subclasses:
MySQL5InnoDBDialect
public class MySQL5Dialect
extends MySQLDialect

An SQL dialect for MySQL 5.x specific features.

Author:
Steve Ebersole

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
MySQL5Dialect()
Method Summary
protected  void registerVarcharTypes()
Methods inherited from class org.hibernate.dialect.MySQLDialect
closeQuote, getAddColumnString, getAddForeignKeyConstraintString, getCastTypeName, getColumnComment, getCreateTemporaryTableString, getCurrentTimestampSelectString, getDropForeignKeyString, getIdentityColumnString, getIdentitySelectString, getLimitString, getResultSet, getSelectGUIDString, getTableComment, isCurrentTimestampSelectStringCallable, openQuote, qualifyIndexName, registerResultSetOutParameter, supportsCascadeDelete, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsBeforeTableName, supportsLimit, supportsRowValueConstructorSyntax, supportsTemporaryTables
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, createCaseFragment, createOuterJoinFragment, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getQuerySequencesString, getSelectClauseNullString, getSelectSequenceNextValString, getSequenceNextValString, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, performTemporaryTableDDLInIsolation, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsColumnCheck, supportsCommentOn, supportsIfExistsAfterTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsSequences, supportsTableCheck, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MySQL5Dialect

public MySQL5Dialect()
Method Detail

registerVarcharTypes

protected void registerVarcharTypes()
Overrides:
registerVarcharTypes in class MySQLDialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MySQL5InnoDBDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class MySQL5InnoDBDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.MySQLDialect
            extended by org.hibernate.dialect.MySQL5Dialect
                extended by org.hibernate.dialect.MySQL5InnoDBDialect
public class MySQL5InnoDBDialect
extends MySQL5Dialect

Author:
Gavin King, Scott Marlow

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
MySQL5InnoDBDialect()
Method Summary
String | getTableTypeString()
boolean | hasSelfReferentialForeignKeyBug()
boolean | supportsCascadeDelete()
Methods inherited from class org.hibernate.dialect.MySQL5Dialect
registerVarcharTypes
Methods inherited from class org.hibernate.dialect.MySQLDialect
closeQuote, getAddColumnString, getAddForeignKeyConstraintString, getCastTypeName, getColumnComment, getCreateTemporaryTableString, getCurrentTimestampSelectString, getDropForeignKeyString, getIdentityColumnString, getIdentitySelectString, getLimitString, getResultSet, getSelectGUIDString, getTableComment, isCurrentTimestampSelectStringCallable, openQuote, qualifyIndexName, registerResultSetOutParameter, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsBeforeTableName, supportsLimit, supportsRowValueConstructorSyntax, supportsTemporaryTables
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, createCaseFragment, createOuterJoinFragment, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getQuerySequencesString, getSelectClauseNullString, getSelectSequenceNextValString, getSequenceNextValString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, performTemporaryTableDDLInIsolation, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsColumnCheck, supportsCommentOn, supportsIfExistsAfterTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsSequences, supportsTableCheck, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MySQL5InnoDBDialect

public MySQL5InnoDBDialect()
Method Detail

supportsCascadeDelete

public boolean supportsCascadeDelete()
Overrides:
supportsCascadeDelete in class MySQLDialect

getTableTypeString

public String getTableTypeString()
Overrides:
getTableTypeString in class Dialect

hasSelfReferentialForeignKeyBug

public boolean hasSelfReferentialForeignKeyBug()
Overrides:
hasSelfReferentialForeignKeyBug in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MySQLDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class MySQLDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.MySQLDialect
Direct Known Subclasses:
MySQL5Dialect, MySQLInnoDBDialect, MySQLMyISAMDialect
public class MySQLDialect
extends Dialect

An SQL dialect for MySQL (prior to 5.x).

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
MySQLDialect()
Method Summary
char | closeQuote() The closing quote for a quoted identifier
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getAddForeignKeyConstraintString(String constraintName, String[] foreignKey, String referencedTable, String[] primaryKey, boolean referencesPrimaryKey) The syntax used to add a foreign key constraint to a table.
String | getCastTypeName(int code)
String | getColumnComment(String comment)
String | getCreateTemporaryTableString()
String | getCurrentTimestampSelectString()
String | getDropForeignKeyString()
String | getIdentityColumnString()
String | getIdentitySelectString()
String | getLimitString(String sql, boolean hasOffset) Add a LIMIT clause to the given SQL SELECT
ResultSet | getResultSet(CallableStatement ps)
String | getSelectGUIDString()
String | getTableComment(String comment)
boolean | isCurrentTimestampSelectStringCallable()
char | openQuote() The opening quote for a quoted identifier
boolean | qualifyIndexName() Do we need to qualify index names with the schema name?
int | registerResultSetOutParameter(CallableStatement statement, int col)
protected void | registerVarcharTypes()
boolean | supportsCascadeDelete()
boolean | supportsCurrentTimestampSelection()
boolean | supportsIdentityColumns() Does this dialect support identity column key generation?
boolean | supportsIfExistsBeforeTableName()
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsRowValueConstructorSyntax() Is this dialect known to support what ANSI-SQL terms "row value constructor" syntax; sometimes called tuple syntax.
boolean | supportsTemporaryTables()
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, createCaseFragment, createOuterJoinFragment, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getQuerySequencesString, getSelectClauseNullString, getSelectSequenceNextValString, getSequenceNextValString, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, performTemporaryTableDDLInIsolation, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsColumnCheck, supportsCommentOn, supportsIfExistsAfterTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsSequences, supportsTableCheck, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MySQLDialect

public MySQLDialect()
Method Detail

registerVarcharTypes

protected void registerVarcharTypes()

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

qualifyIndexName

public boolean qualifyIndexName()
Description copied from class: Dialect
Do we need to qualify index names with the schema name?

Overrides:
qualifyIndexName in class Dialect
Returns:
boolean

supportsIdentityColumns

public boolean supportsIdentityColumns()
Description copied from class: Dialect
Does this dialect support identity column key generation?

Overrides:
supportsIdentityColumns in class Dialect
Returns:
boolean

getIdentitySelectString

public String getIdentitySelectString()
Overrides:
getIdentitySelectString in class Dialect

getIdentityColumnString

public String getIdentityColumnString()
Overrides:
getIdentityColumnString in class Dialect

getAddForeignKeyConstraintString

public String getAddForeignKeyConstraintString(String constraintName,
                                               String[] foreignKey,
                                               String referencedTable,
                                               String[] primaryKey,
                                               boolean referencesPrimaryKey)
Description copied from class: Dialect
The syntax used to add a foreign key constraint to a table.

Overrides:
getAddForeignKeyConstraintString in class Dialect
Parameters:
referencesPrimaryKey - if false, constraint should be explicit about which column names the constraint refers to
Returns:
String

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class Dialect

getDropForeignKeyString

public String getDropForeignKeyString()
Overrides:
getDropForeignKeyString in class Dialect

getLimitString

public String getLimitString(String sql,
                             boolean hasOffset)
Description copied from class: Dialect
Add a LIMIT clause to the given SQL SELECT

Overrides:
getLimitString in class Dialect
Returns:
the modified SQL

closeQuote

public char closeQuote()
Description copied from class: Dialect
The closing quote for a quoted identifier

Overrides:
closeQuote in class Dialect

openQuote

public char openQuote()
Description copied from class: Dialect
The opening quote for a quoted identifier

Overrides:
openQuote in class Dialect

supportsIfExistsBeforeTableName

public boolean supportsIfExistsBeforeTableName()
Overrides:
supportsIfExistsBeforeTableName in class Dialect

getSelectGUIDString

public String getSelectGUIDString()
Overrides:
getSelectGUIDString in class Dialect

supportsCascadeDelete

public boolean supportsCascadeDelete()
Overrides:
supportsCascadeDelete in class Dialect

getTableComment

public String getTableComment(String comment)
Overrides:
getTableComment in class Dialect

getColumnComment

public String getColumnComment(String comment)
Overrides:
getColumnComment in class Dialect

supportsTemporaryTables

public boolean supportsTemporaryTables()
Overrides:
supportsTemporaryTables in class Dialect

getCreateTemporaryTableString

public String getCreateTemporaryTableString()
Overrides:
getCreateTemporaryTableString in class Dialect

getCastTypeName

public String getCastTypeName(int code)
Overrides:
getCastTypeName in class Dialect

supportsCurrentTimestampSelection

public boolean supportsCurrentTimestampSelection()
Overrides:
supportsCurrentTimestampSelection in class Dialect

isCurrentTimestampSelectStringCallable

public boolean isCurrentTimestampSelectStringCallable()
Overrides:
isCurrentTimestampSelectStringCallable in class Dialect

getCurrentTimestampSelectString

public String getCurrentTimestampSelectString()
Overrides:
getCurrentTimestampSelectString in class Dialect

registerResultSetOutParameter

public int registerResultSetOutParameter(CallableStatement statement,
                                         int col)
                                  throws SQLException
Overrides:
registerResultSetOutParameter in class Dialect
Throws:
SQLException

getResultSet

public ResultSet getResultSet(CallableStatement ps)
                       throws SQLException
Overrides:
getResultSet in class Dialect
Throws:
SQLException

supportsRowValueConstructorSyntax

public boolean supportsRowValueConstructorSyntax()
Description copied from class: Dialect
Is this dialect known to support what ANSI-SQL terms "row value constructor" syntax; sometimes called tuple syntax.

Basically, does it support syntax like "... where (FIRST_NAME, LAST_NAME) = ('Steve', 'Ebersole') ...".

Overrides:
supportsRowValueConstructorSyntax in class Dialect
Returns:
True if this SQL dialect is known to support "row value constructor" syntax; false otherwise.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MySQLInnoDBDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class MySQLInnoDBDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.MySQLDialect
            extended by org.hibernate.dialect.MySQLInnoDBDialect
public class MySQLInnoDBDialect
extends MySQLDialect

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
MySQLInnoDBDialect()
Method Summary
String | getTableTypeString()
boolean | hasSelfReferentialForeignKeyBug()
boolean | supportsCascadeDelete()
Methods inherited from class org.hibernate.dialect.MySQLDialect
closeQuote, getAddColumnString, getAddForeignKeyConstraintString, getCastTypeName, getColumnComment, getCreateTemporaryTableString, getCurrentTimestampSelectString, getDropForeignKeyString, getIdentityColumnString, getIdentitySelectString, getLimitString, getResultSet, getSelectGUIDString, getTableComment, isCurrentTimestampSelectStringCallable, openQuote, qualifyIndexName, registerResultSetOutParameter, registerVarcharTypes, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsBeforeTableName, supportsLimit, supportsRowValueConstructorSyntax, supportsTemporaryTables
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, createCaseFragment, createOuterJoinFragment, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getQuerySequencesString, getSelectClauseNullString, getSelectSequenceNextValString, getSequenceNextValString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, performTemporaryTableDDLInIsolation, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsColumnCheck, supportsCommentOn, supportsIfExistsAfterTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsSequences, supportsTableCheck, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MySQLInnoDBDialect

public MySQLInnoDBDialect()
Method Detail

supportsCascadeDelete

public boolean supportsCascadeDelete()
Overrides:
supportsCascadeDelete in class MySQLDialect

getTableTypeString

public String getTableTypeString()
Overrides:
getTableTypeString in class Dialect

hasSelfReferentialForeignKeyBug

public boolean hasSelfReferentialForeignKeyBug()
Overrides:
hasSelfReferentialForeignKeyBug in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MySQLMyISAMDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class MySQLMyISAMDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.MySQLDialect
            extended by org.hibernate.dialect.MySQLMyISAMDialect
public class MySQLMyISAMDialect
extends MySQLDialect

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
MySQLMyISAMDialect()
Method Summary
boolean | dropConstraints() Do we need to drop constraints before dropping tables in this dialect?
String | getTableTypeString()
Methods inherited from class org.hibernate.dialect.MySQLDialect
closeQuote, getAddColumnString, getAddForeignKeyConstraintString, getCastTypeName, getColumnComment, getCreateTemporaryTableString, getCurrentTimestampSelectString, getDropForeignKeyString, getIdentityColumnString, getIdentitySelectString, getLimitString, getResultSet, getSelectGUIDString, getTableComment, isCurrentTimestampSelectStringCallable, openQuote, qualifyIndexName, registerResultSetOutParameter, registerVarcharTypes, supportsCascadeDelete, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsBeforeTableName, supportsLimit, supportsRowValueConstructorSyntax, supportsTemporaryTables
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, createCaseFragment, createOuterJoinFragment, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getQuerySequencesString, getSelectClauseNullString, getSelectSequenceNextValString, getSequenceNextValString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, performTemporaryTableDDLInIsolation, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsColumnCheck, supportsCommentOn, supportsIfExistsAfterTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsSequences, supportsTableCheck, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MySQLMyISAMDialect

public MySQLMyISAMDialect()
Method Detail

getTableTypeString

public String getTableTypeString()
Overrides:
getTableTypeString in class Dialect

dropConstraints

public boolean dropConstraints()
Description copied from class: Dialect
Do we need to drop constraints before dropping tables in this dialect?

Overrides:
dropConstraints in class Dialect
Returns:
boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Oracle9Dialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class Oracle9Dialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.Oracle9Dialect
Direct Known Subclasses:
DataDirectOracle9Dialect, OracleDialect
public class Oracle9Dialect
extends Dialect

An SQL dialect for Oracle 9 (uses ANSI-style syntax where possible).

Author:
Gavin King, David Channon

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
Oracle9Dialect()
Method Summary
boolean | bindLimitParametersInReverseOrder() Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?
boolean | dropConstraints() Do we need to drop constraints before dropping tables in this dialect?
boolean | dropTemporaryTableAfterUse()
boolean | forUpdateOfColumns() Does the FOR UPDATE OF syntax specify particular columns?
String | generateTemporaryTableName(String baseTableName)
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getCascadeConstraintsString() Completely optional cascading drop clause
String | getCreateSequenceString(String sequenceName) The syntax used to create a sequence, if sequences are supported.
String | getCreateTemporaryTablePostfix()
String | getCreateTemporaryTableString()
String | getCurrentTimestampSelectString()
String | getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String | getForUpdateNowaitString() Retrieves the FOR UPDATE NOWAIT syntax specific to this dialect.
String | getForUpdateNowaitString(String aliases) Retrieves the FOR UPDATE OF column_list NOWAIT syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.
String | getForUpdateString(String aliases) Retrieves the FOR UPDATE OF column_list syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.
String | getLimitString(String sql, boolean hasOffset) Add a LIMIT clause to the given SQL SELECT
String | getQuerySequencesString() A query used to find all sequences
ResultSet | getResultSet(CallableStatement ps)
String | getSelectGUIDString()
String | getSelectSequenceNextValString(String sequenceName) Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.
String | getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
ViolatedConstraintNameExtracter | getViolatedConstraintNameExtracter()
boolean | isCurrentTimestampSelectStringCallable()
int | registerResultSetOutParameter(CallableStatement statement, int col)
boolean | supportsCommentOn()
boolean | supportsCurrentTimestampSelection()
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsTemporaryTables()
boolean | supportsUnionAll()
boolean | useMaxForLimit() Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getSelectClauseNullString, getTableComment, getTableTypeString, getTypeName, getTypeName, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsCascadeDelete, supportsColumnCheck, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Oracle9Dialect

public Oracle9Dialect()
Method Detail

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.

This should be a "stand alone" select statement.

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.

getSelectSequenceNextValString

public String getSelectSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.

This differs from Dialect.getSequenceNextValString(String) in that this should return an expression usable within another select statement.

Overrides:
getSelectSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getCreateSequenceString

public String getCreateSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to create a sequence, if sequences are supported.

Overrides:
getCreateSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getDropSequenceString

public String getDropSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getCascadeConstraintsString

public String getCascadeConstraintsString()
Description copied from class: Dialect
Completely optional cascading drop clause

Overrides:
getCascadeConstraintsString in class Dialect
Returns:
String

dropConstraints

public boolean dropConstraints()
Description copied from class: Dialect
Do we need to drop constraints before dropping tables in this dialect?

Overrides:
dropConstraints in class Dialect
Returns:
boolean

getForUpdateNowaitString

public String getForUpdateNowaitString()
Description copied from class: Dialect
Retrieves the FOR UPDATE NOWAIT syntax specific to this dialect.

Overrides:
getForUpdateNowaitString in class Dialect
Returns:
The appropriate FOR UPDATE NOWAIT clause string.

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class Dialect
Returns:
boolean

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class Dialect

getLimitString

public String getLimitString(String sql,
                             boolean hasOffset)
Description copied from class: Dialect
Add a LIMIT clause to the given SQL SELECT

Overrides:
getLimitString in class Dialect
Returns:
the modified SQL

getForUpdateString

public String getForUpdateString(String aliases)
Description copied from class: Dialect
Retrieves the FOR UPDATE OF column_list syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.

Overrides:
getForUpdateString in class Dialect
Returns:
The appropriate FOR UPDATE OF column_list clause string.

getForUpdateNowaitString

public String getForUpdateNowaitString(String aliases)
Description copied from class: Dialect
Retrieves the FOR UPDATE OF column_list NOWAIT syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.

Overrides:
getForUpdateNowaitString in class Dialect
Returns:
The appropriate FOR UPDATE colunm_list NOWAIT clause string.

bindLimitParametersInReverseOrder

public boolean bindLimitParametersInReverseOrder()
Description copied from class: Dialect
Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?

Overrides:
bindLimitParametersInReverseOrder in class Dialect
Returns:
true if the correct order is limit, offset

useMaxForLimit

public boolean useMaxForLimit()
Description copied from class: Dialect
Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?

Overrides:
useMaxForLimit in class Dialect

forUpdateOfColumns

public boolean forUpdateOfColumns()
Description copied from class: Dialect
Does the FOR UPDATE OF syntax specify particular columns?

Overrides:
forUpdateOfColumns in class Dialect

getQuerySequencesString

public String getQuerySequencesString()
Description copied from class: Dialect
A query used to find all sequences

Overrides:
getQuerySequencesString in class Dialect
See Also:
SchemaUpdate

getSelectGUIDString

public String getSelectGUIDString()
Overrides:
getSelectGUIDString in class Dialect

getViolatedConstraintNameExtracter

public ViolatedConstraintNameExtracter getViolatedConstraintNameExtracter()
Overrides:
getViolatedConstraintNameExtracter in class Dialect

registerResultSetOutParameter

public int registerResultSetOutParameter(CallableStatement statement,
                                         int col)
                                  throws SQLException
Overrides:
registerResultSetOutParameter in class Dialect
Throws:
SQLException

getResultSet

public ResultSet getResultSet(CallableStatement ps)
                       throws SQLException
Overrides:
getResultSet in class Dialect
Throws:
SQLException

supportsUnionAll

public boolean supportsUnionAll()
Overrides:
supportsUnionAll in class Dialect

supportsCommentOn

public boolean supportsCommentOn()
Overrides:
supportsCommentOn in class Dialect

supportsTemporaryTables

public boolean supportsTemporaryTables()
Overrides:
supportsTemporaryTables in class Dialect

generateTemporaryTableName

public String generateTemporaryTableName(String baseTableName)
Overrides:
generateTemporaryTableName in class Dialect

getCreateTemporaryTableString

public String getCreateTemporaryTableString()
Overrides:
getCreateTemporaryTableString in class Dialect

getCreateTemporaryTablePostfix

public String getCreateTemporaryTablePostfix()
Overrides:
getCreateTemporaryTablePostfix in class Dialect

dropTemporaryTableAfterUse

public boolean dropTemporaryTableAfterUse()
Overrides:
dropTemporaryTableAfterUse in class Dialect

supportsCurrentTimestampSelection

public boolean supportsCurrentTimestampSelection()
Overrides:
supportsCurrentTimestampSelection in class Dialect

getCurrentTimestampSelectString

public String getCurrentTimestampSelectString()
Overrides:
getCurrentTimestampSelectString in class Dialect

isCurrentTimestampSelectStringCallable

public boolean isCurrentTimestampSelectStringCallable()
Overrides:
isCurrentTimestampSelectStringCallable in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OracleDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class OracleDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.Oracle9Dialect
            extended by org.hibernate.dialect.OracleDialect
public class OracleDialect
extends Oracle9Dialect

An SQL dialect for Oracle, compatible with Oracle 8.

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
OracleDialect()
Method Summary
CaseFragment | createCaseFragment() Create a CaseFragment for this dialect.
JoinFragment | createOuterJoinFragment() Create an OuterJoinGenerator for this dialect.
String | getCurrentTimestampSelectString()
String | getCurrentTimestampSQLFunctionName() The name of the database-specific SQL function for retrieving the current timestamp.
String | getLimitString(String sql, boolean hasOffset) Add a LIMIT clause to the given SQL SELECT
String | getSelectClauseNullString(int sqlType)
Methods inherited from class org.hibernate.dialect.Oracle9Dialect
bindLimitParametersInReverseOrder, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddColumnString, getCascadeConstraintsString, getCreateSequenceString, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getDropSequenceString, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getQuerySequencesString, getResultSet, getSelectGUIDString, getSelectSequenceNextValString, getSequenceNextValString, getViolatedConstraintNameExtracter, isCurrentTimestampSelectStringCallable, registerResultSetOutParameter, supportsCommentOn, supportsCurrentTimestampSelection, supportsLimit, supportsSequences, supportsTemporaryTables, supportsUnionAll, useMaxForLimit
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, buildSQLExceptionConverter, closeQuote, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getTableComment, getTableTypeString, getTypeName, getTypeName, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsCascadeDelete, supportsColumnCheck, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OracleDialect

public OracleDialect()
Method Detail

createOuterJoinFragment

public JoinFragment createOuterJoinFragment()
Description copied from class: Dialect
Create an OuterJoinGenerator for this dialect.

Overrides:
createOuterJoinFragment in class Dialect
Returns:
OuterJoinGenerator

createCaseFragment

public CaseFragment createCaseFragment()
Description copied from class: Dialect
Create a CaseFragment for this dialect.

Overrides:
createCaseFragment in class Dialect
Returns:
OuterJoinGenerator

getLimitString

public String getLimitString(String sql,
                             boolean hasOffset)
Description copied from class: Dialect
Add a LIMIT clause to the given SQL SELECT

Overrides:
getLimitString in class Oracle9Dialect

getSelectClauseNullString

public String getSelectClauseNullString(int sqlType)
Overrides:
getSelectClauseNullString in class Dialect

getCurrentTimestampSelectString

public String getCurrentTimestampSelectString()
Overrides:
getCurrentTimestampSelectString in class Oracle9Dialect

getCurrentTimestampSQLFunctionName

public String getCurrentTimestampSQLFunctionName()
Description copied from class: Dialect
The name of the database-specific SQL function for retrieving the current timestamp.

Overrides:
getCurrentTimestampSQLFunctionName in class Dialect
Returns:
The function name.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PointbaseDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class PointbaseDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.PointbaseDialect
public class PointbaseDialect
extends Dialect

A Dialect for Pointbase.

Author:
Ed Mackenzie

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
PointbaseDialect()
Creates new PointbaseDialect
Method Summary
boolean | dropConstraints() Do we need to drop constraints before dropping tables in this dialect?
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getCascadeConstraintsString() Completely optional cascading drop clause
String | getForUpdateString() Retrieves the FOR UPDATE syntax specific to this dialect.
LockingStrategy | getLockingStrategy(Lockable lockable, LockMode lockMode) Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCastTypeName, getColumnComment, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLimitString, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getQuerySequencesString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getSelectSequenceNextValString, getSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, isCurrentTimestampSelectStringCallable, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimit, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsSequences, supportsTableCheck, supportsTemporaryTables, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PointbaseDialect

public PointbaseDialect()
Creates new PointbaseDialect

Method Detail

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

dropConstraints

public boolean dropConstraints()
Description copied from class: Dialect
Do we need to drop constraints before dropping tables in this dialect?

Overrides:
dropConstraints in class Dialect
Returns:
boolean

getCascadeConstraintsString

public String getCascadeConstraintsString()
Description copied from class: Dialect
Completely optional cascading drop clause

Overrides:
getCascadeConstraintsString in class Dialect
Returns:
String

getForUpdateString

public String getForUpdateString()
Description copied from class: Dialect
Retrieves the FOR UPDATE syntax specific to this dialect.

Overrides:
getForUpdateString in class Dialect
Returns:
The appropriate FOR UPDATE clause string.

getLockingStrategy

public LockingStrategy getLockingStrategy(Lockable lockable,
                                          LockMode lockMode)
Description copied from class: Dialect
Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.

Overrides:
getLockingStrategy in class Dialect
Parameters:
lockable - The persister for the entity to be locked.
lockMode - The type of lock to be acquired.
Returns:
The appropriate locking strategy.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PostgreSQLDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class PostgreSQLDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.PostgreSQLDialect
public class PostgreSQLDialect
extends Dialect

An SQL dialect for Postgres

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
PostgreSQLDialect()
Method Summary
boolean | bindLimitParametersInReverseOrder() Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?
boolean | dropConstraints() Do we need to drop constraints before dropping tables in this dialect?
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getCascadeConstraintsString() Completely optional cascading drop clause
String | getCreateSequenceString(String sequenceName) The syntax used to create a sequence, if sequences are supported.
String | getCreateTemporaryTablePostfix()
String | getCreateTemporaryTableString()
String | getCurrentTimestampSelectString()
String | getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String | getForUpdateString(String aliases) Retrieves the FOR UPDATE OF column_list syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.
String | getIdentityColumnString(int type) The keyword used to specify an identity column, if identity column key generation is supported.
String | getIdentitySelectString(String table, String column, int type) The syntax that returns the identity value of the last insert, if identity column key generation is supported.
String | getLimitString(String sql, boolean hasOffset) Add a LIMIT clause to the given SQL SELECT
Class | getNativeIdentifierGeneratorClass()
String | getNoColumnsInsertString() The keyword used to insert a row without specifying any column values.
String | getQuerySequencesString() A query used to find all sequences
String | getSelectClauseNullString(int sqlType) Workaround for postgres bug #1453
String | getSelectSequenceNextValString(String sequenceName) Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.
String | getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
ViolatedConstraintNameExtracter | getViolatedConstraintNameExtracter()
boolean | hasDataTypeInIdentityColumn() Whether this dialect have an Identity clause added to the data type or a completely seperate identity data type
boolean | isCurrentTimestampSelectStringCallable()
boolean | supportsCommentOn()
boolean | supportsCurrentTimestampSelection()
boolean | supportsIdentityColumns() Does this dialect support identity column key generation?
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsOuterJoinForUpdate()
boolean | supportsRowValueConstructorSyntax() Is this dialect known to support what ANSI-SQL terms "row value constructor" syntax; sometimes called tuple syntax.
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsTemporaryTables()
boolean | supportsUnionAll()
String | toBooleanValueString(boolean bool) The SQL value that the JDBC driver maps boolean values to
boolean | useInputStreamToInsertBlob()
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNullColumnString, getResultSet, getSelectGUIDString, getTableComment, getTableTypeString, getTypeName, getTypeName, hasAlterTable, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsColumnCheck, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimitOffset, supportsNotNullUnique, supportsParametersInInsertSelect, supportsTableCheck, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toString, transformSelectString, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PostgreSQLDialect

public PostgreSQLDialect()
Method Detail

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.

This should be a "stand alone" select statement.

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.

getSelectSequenceNextValString

public String getSelectSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.

This differs from Dialect.getSequenceNextValString(String) in that this should return an expression usable within another select statement.

Overrides:
getSelectSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getCreateSequenceString

public String getCreateSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to create a sequence, if sequences are supported.

Overrides:
getCreateSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getDropSequenceString

public String getDropSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getCascadeConstraintsString

public String getCascadeConstraintsString()
Description copied from class: Dialect
Completely optional cascading drop clause

Overrides:
getCascadeConstraintsString in class Dialect
Returns:
String

dropConstraints

public boolean dropConstraints()
Description copied from class: Dialect
Do we need to drop constraints before dropping tables in this dialect?

Overrides:
dropConstraints in class Dialect
Returns:
boolean

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class Dialect
Returns:
boolean

getQuerySequencesString

public String getQuerySequencesString()
Description copied from class: Dialect
A query used to find all sequences

Overrides:
getQuerySequencesString in class Dialect
See Also:
SchemaUpdate

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class Dialect

getLimitString

public String getLimitString(String sql,
                             boolean hasOffset)
Description copied from class: Dialect
Add a LIMIT clause to the given SQL SELECT

Overrides:
getLimitString in class Dialect
Returns:
the modified SQL

bindLimitParametersInReverseOrder

public boolean bindLimitParametersInReverseOrder()
Description copied from class: Dialect
Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?

Overrides:
bindLimitParametersInReverseOrder in class Dialect
Returns:
true if the correct order is limit, offset

supportsIdentityColumns

public boolean supportsIdentityColumns()
Description copied from class: Dialect
Does this dialect support identity column key generation?

Overrides:
supportsIdentityColumns in class Dialect
Returns:
boolean

getForUpdateString

public String getForUpdateString(String aliases)
Description copied from class: Dialect
Retrieves the FOR UPDATE OF column_list syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.

Overrides:
getForUpdateString in class Dialect
Returns:
The appropriate FOR UPDATE OF column_list clause string.

getIdentitySelectString

public String getIdentitySelectString(String table,
                                      String column,
                                      int type)
Description copied from class: Dialect
The syntax that returns the identity value of the last insert, if identity column key generation is supported.

Overrides:
getIdentitySelectString in class Dialect
Parameters:
type - TODO

getIdentityColumnString

public String getIdentityColumnString(int type)
Description copied from class: Dialect
The keyword used to specify an identity column, if identity column key generation is supported.

Overrides:
getIdentityColumnString in class Dialect
Parameters:
type - the SQL column type, as defined by java.sql.Types

hasDataTypeInIdentityColumn

public boolean hasDataTypeInIdentityColumn()
Description copied from class: Dialect
Whether this dialect have an Identity clause added to the data type or a completely seperate identity data type

Overrides:
hasDataTypeInIdentityColumn in class Dialect
Returns:
boolean

getNoColumnsInsertString

public String getNoColumnsInsertString()
Description copied from class: Dialect
The keyword used to insert a row without specifying any column values. This is not possible on some databases.

Overrides:
getNoColumnsInsertString in class Dialect

getNativeIdentifierGeneratorClass

public Class getNativeIdentifierGeneratorClass()
Overrides:
getNativeIdentifierGeneratorClass in class Dialect

supportsOuterJoinForUpdate

public boolean supportsOuterJoinForUpdate()
Overrides:
supportsOuterJoinForUpdate in class Dialect

useInputStreamToInsertBlob

public boolean useInputStreamToInsertBlob()
Overrides:
useInputStreamToInsertBlob in class Dialect

supportsUnionAll

public boolean supportsUnionAll()
Overrides:
supportsUnionAll in class Dialect

getSelectClauseNullString

public String getSelectClauseNullString(int sqlType)
Workaround for postgres bug #1453

Overrides:
getSelectClauseNullString in class Dialect

supportsCommentOn

public boolean supportsCommentOn()
Overrides:
supportsCommentOn in class Dialect

supportsTemporaryTables

public boolean supportsTemporaryTables()
Overrides:
supportsTemporaryTables in class Dialect

getCreateTemporaryTableString

public String getCreateTemporaryTableString()
Overrides:
getCreateTemporaryTableString in class Dialect

getCreateTemporaryTablePostfix

public String getCreateTemporaryTablePostfix()
Overrides:
getCreateTemporaryTablePostfix in class Dialect

supportsCurrentTimestampSelection

public boolean supportsCurrentTimestampSelection()
Overrides:
supportsCurrentTimestampSelection in class Dialect

isCurrentTimestampSelectStringCallable

public boolean isCurrentTimestampSelectStringCallable()
Overrides:
isCurrentTimestampSelectStringCallable in class Dialect

getCurrentTimestampSelectString

public String getCurrentTimestampSelectString()
Overrides:
getCurrentTimestampSelectString in class Dialect

toBooleanValueString

public String toBooleanValueString(boolean bool)
Description copied from class: Dialect
The SQL value that the JDBC driver maps boolean values to

Overrides:
toBooleanValueString in class Dialect

getViolatedConstraintNameExtracter

public ViolatedConstraintNameExtracter getViolatedConstraintNameExtracter()
Overrides:
getViolatedConstraintNameExtracter in class Dialect

supportsRowValueConstructorSyntax

public boolean supportsRowValueConstructorSyntax()
Description copied from class: Dialect
Is this dialect known to support what ANSI-SQL terms "row value constructor" syntax; sometimes called tuple syntax.

Basically, does it support syntax like "... where (FIRST_NAME, LAST_NAME) = ('Steve', 'Ebersole') ...".

Overrides:
supportsRowValueConstructorSyntax in class Dialect
Returns:
True if this SQL dialect is known to support "row value constructor" syntax; false otherwise.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProgressDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class ProgressDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.ProgressDialect
public class ProgressDialect
extends Dialect

An SQL dialect compatible with Progress 9.1C

Connection Parameters required:

  • hibernate.dialect org.hibernate.sql.ProgressDialect
  • hibernate.driver com.progress.sql.jdbc.JdbcProgressDriver
  • hibernate.url jdbc:JdbcProgress:T:host:port:dbname;WorkArounds=536870912
  • hibernate.username username
  • hibernate.password password
The WorkArounds parameter in the URL is required to avoid an error in the Progress 9.1C JDBC driver related to PreparedStatements.

Author:
Phillip Baird

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
ProgressDialect()
Method Summary
String | getAddColumnString() The syntax used to add a column to a table (optional).
boolean | hasAlterTable() Does this dialect support the ALTER TABLE syntax?
boolean | qualifyIndexName() Do we need to qualify index names with the schema name?
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropConstraints, dropTemporaryTableAfterUse, forUpdateOfColumns, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getQuerySequencesString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getSelectSequenceNextValString, getSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, isCurrentTimestampSelectStringCallable, openQuote, performTemporaryTableDDLInIsolation, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimit, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsSequences, supportsTableCheck, supportsTemporaryTables, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ProgressDialect

public ProgressDialect()
Method Detail

hasAlterTable

public boolean hasAlterTable()
Description copied from class: Dialect
Does this dialect support the ALTER TABLE syntax?

Overrides:
hasAlterTable in class Dialect
Returns:
boolean

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

qualifyIndexName

public boolean qualifyIndexName()
Description copied from class: Dialect
Do we need to qualify index names with the schema name?

Overrides:
qualifyIndexName in class Dialect
Returns:
boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RDMSOS2200Dialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class RDMSOS2200Dialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.RDMSOS2200Dialect
public class RDMSOS2200Dialect
extends Dialect

Author:
Ploski and Hanson

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
RDMSOS2200Dialect()
Method Summary
CaseFragment | createCaseFragment() Create a CaseFragment for this dialect.
boolean | forUpdateOfColumns() The RDMS DB supports the 'FOR UPDATE OF' clause.
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getCascadeConstraintsString() Completely optional cascading drop clause
String | getCreateSequenceString(String sequenceName) The syntax used to create a sequence, if sequences are supported.
String | getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String | getForUpdateString() Since the RDMS-JDBC driver does not support for updates, this string is set to an empty string.
String | getLimitString(String sql, int offset, int limit)
LockingStrategy | getLockingStrategy(Lockable lockable, LockMode lockMode) Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.
String | getNullColumnString() The keyword used to specify a nullable column.
String | getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
boolean | qualifyIndexName() RDMS does not support qualifing index names with the schema name.
boolean | supportsCascadeDelete() RDMS does not support Cascade Deletes.
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsLimitOffset() Does this dialect support an offset?
boolean | supportsOuterJoinForUpdate() Currently, RDMS-JDBC does not support ForUpdate.
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsUnionAll()
boolean | supportsUniqueConstraintInCreateAlterTable() RDMS does not support adding Unique constraints via create and alter table.
boolean | supportsVariableLimit()
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createOuterJoinFragment, dropConstraints, dropTemporaryTableAfterUse, generateTemporaryTableName, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getQuerySequencesString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getSelectSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, isCurrentTimestampSelectStringCallable, openQuote, performTemporaryTableDDLInIsolation, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsColumnCheck, supportsCommentOn, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsNotNullUnique, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsTemporaryTables, supportsUnique, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RDMSOS2200Dialect

public RDMSOS2200Dialect()
Method Detail

qualifyIndexName

public boolean qualifyIndexName()
RDMS does not support qualifing index names with the schema name.

Overrides:
qualifyIndexName in class Dialect
Returns:
boolean

forUpdateOfColumns

public boolean forUpdateOfColumns()
The RDMS DB supports the 'FOR UPDATE OF' clause. However, the RDMS-JDBC driver does not support this feature, so a false is return. The base dialect also returns a false, but we will leave this over-ride in to make sure it stays false.

Overrides:
forUpdateOfColumns in class Dialect

getForUpdateString

public String getForUpdateString()
Since the RDMS-JDBC driver does not support for updates, this string is set to an empty string. Whenever, the driver does support this feature, the returned string should be " FOR UPDATE OF". Note that RDMS does not support the string 'FOR UPDATE' string.

Overrides:
getForUpdateString in class Dialect
Returns:
The appropriate FOR UPDATE clause string.

supportsUniqueConstraintInCreateAlterTable

public boolean supportsUniqueConstraintInCreateAlterTable()
RDMS does not support adding Unique constraints via create and alter table.

Overrides:
supportsUniqueConstraintInCreateAlterTable in class Dialect
Returns:
boolean

supportsCascadeDelete

public boolean supportsCascadeDelete()
RDMS does not support Cascade Deletes. Need to review this in the future when support is provided.

Overrides:
supportsCascadeDelete in class Dialect

supportsOuterJoinForUpdate

public boolean supportsOuterJoinForUpdate()
Currently, RDMS-JDBC does not support ForUpdate. Need to review this in the future when support is provided.

Overrides:
supportsOuterJoinForUpdate in class Dialect

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

getNullColumnString

public String getNullColumnString()
Description copied from class: Dialect
The keyword used to specify a nullable column.

Overrides:
getNullColumnString in class Dialect
Returns:
String

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class Dialect
Returns:
boolean

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.

This should be a "stand alone" select statement.

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.

getCreateSequenceString

public String getCreateSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to create a sequence, if sequences are supported.

Overrides:
getCreateSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getDropSequenceString

public String getDropSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getCascadeConstraintsString

public String getCascadeConstraintsString()
Description copied from class: Dialect
Completely optional cascading drop clause

Overrides:
getCascadeConstraintsString in class Dialect
Returns:
String

createCaseFragment

public CaseFragment createCaseFragment()
Description copied from class: Dialect
Create a CaseFragment for this dialect.

Overrides:
createCaseFragment in class Dialect
Returns:
OuterJoinGenerator

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class Dialect

supportsLimitOffset

public boolean supportsLimitOffset()
Description copied from class: Dialect
Does this dialect support an offset?

Overrides:
supportsLimitOffset in class Dialect

getLimitString

public String getLimitString(String sql,
                             int offset,
                             int limit)
Overrides:
getLimitString in class Dialect

supportsVariableLimit

public boolean supportsVariableLimit()
Overrides:
supportsVariableLimit in class Dialect

supportsUnionAll

public boolean supportsUnionAll()
Overrides:
supportsUnionAll in class Dialect

getLockingStrategy

public LockingStrategy getLockingStrategy(Lockable lockable,
                                          LockMode lockMode)
Description copied from class: Dialect
Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.

Overrides:
getLockingStrategy in class Dialect
Parameters:
lockable - The persister for the entity to be locked.
lockMode - The type of lock to be acquired.
Returns:
The appropriate locking strategy.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SAPDBDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class SAPDBDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.SAPDBDialect
public class SAPDBDialect
extends Dialect

An SQL dialect compatible with SAP DB.

Author:
Brad Clow

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
SAPDBDialect()
Method Summary
CaseFragment | createCaseFragment() Create a CaseFragment for this dialect.
JoinFragment | createOuterJoinFragment() Create an OuterJoinGenerator for this dialect.
boolean | dropConstraints() Do we need to drop constraints before dropping tables in this dialect?
String | generateTemporaryTableName(String baseTableName)
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getAddForeignKeyConstraintString(String constraintName, String[] foreignKey, String referencedTable, String[] primaryKey, boolean referencesPrimaryKey) The syntax used to add a foreign key constraint to a table.
String | getAddPrimaryKeyConstraintString(String constraintName) The syntax used to add a primary key constraint to a table.
String | getCreateSequenceString(String sequenceName) The syntax used to create a sequence, if sequences are supported.
String | getCreateTemporaryTablePostfix()
String | getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String | getNullColumnString() The keyword used to specify a nullable column.
String | getQuerySequencesString() A query used to find all sequences
String | getSelectSequenceNextValString(String sequenceName) Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.
String | getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsTemporaryTables()
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, dropTemporaryTableAfterUse, forUpdateOfColumns, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getCreateTemporaryTableString, getCurrentTimestampSelectString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, isCurrentTimestampSelectStringCallable, openQuote, performTemporaryTableDDLInIsolation, qualifyIndexName, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsLimit, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsTableCheck, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SAPDBDialect

public SAPDBDialect()
Method Detail

dropConstraints

public boolean dropConstraints()
Description copied from class: Dialect
Do we need to drop constraints before dropping tables in this dialect?

Overrides:
dropConstraints in class Dialect
Returns:
boolean

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

getAddForeignKeyConstraintString

public String getAddForeignKeyConstraintString(String constraintName,
                                               String[] foreignKey,
                                               String referencedTable,
                                               String[] primaryKey,
                                               boolean referencesPrimaryKey)
Description copied from class: Dialect
The syntax used to add a foreign key constraint to a table.

Overrides:
getAddForeignKeyConstraintString in class Dialect
Parameters:
referencesPrimaryKey - if false, constraint should be explicit about which column names the constraint refers to
Returns:
String

getAddPrimaryKeyConstraintString

public String getAddPrimaryKeyConstraintString(String constraintName)
Description copied from class: Dialect
The syntax used to add a primary key constraint to a table.

Overrides:
getAddPrimaryKeyConstraintString in class Dialect
Returns:
String

getNullColumnString

public String getNullColumnString()
Description copied from class: Dialect
The keyword used to specify a nullable column.

Overrides:
getNullColumnString in class Dialect
Returns:
String

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.

This should be a "stand alone" select statement.

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.

getSelectSequenceNextValString

public String getSelectSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.

This differs from Dialect.getSequenceNextValString(String) in that this should return an expression usable within another select statement.

Overrides:
getSelectSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getCreateSequenceString

public String getCreateSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to create a sequence, if sequences are supported.

Overrides:
getCreateSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getDropSequenceString

public String getDropSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getQuerySequencesString

public String getQuerySequencesString()
Description copied from class: Dialect
A query used to find all sequences

Overrides:
getQuerySequencesString in class Dialect
See Also:
SchemaUpdate

createOuterJoinFragment

public JoinFragment createOuterJoinFragment()
Description copied from class: Dialect
Create an OuterJoinGenerator for this dialect.

Overrides:
createOuterJoinFragment in class Dialect
Returns:
OuterJoinGenerator

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class Dialect
Returns:
boolean

createCaseFragment

public CaseFragment createCaseFragment()
Description copied from class: Dialect
Create a CaseFragment for this dialect.

Overrides:
createCaseFragment in class Dialect
Returns:
OuterJoinGenerator

supportsTemporaryTables

public boolean supportsTemporaryTables()
Overrides:
supportsTemporaryTables in class Dialect

getCreateTemporaryTablePostfix

public String getCreateTemporaryTablePostfix()
Overrides:
getCreateTemporaryTablePostfix in class Dialect

generateTemporaryTableName

public String generateTemporaryTableName(String baseTableName)
Overrides:
generateTemporaryTableName in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLServerDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class SQLServerDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.SybaseDialect
            extended by org.hibernate.dialect.SQLServerDialect
public class SQLServerDialect
extends SybaseDialect

A dialect for Microsoft SQL Server 2000

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
SQLServerDialect()
Method Summary
String | appendIdentitySelectToInsert(String insertSQL) Use insert table(...) values(...) select SCOPE_IDENTITY()
String | appendLockHint(LockMode mode, String tableName) Method appendLockHint appends according to the given lock mode a lock hint behind the given table name, if this dialect needs this.
char | closeQuote() The closing quote for a quoted identifier
String | getCurrentTimestampSelectString()
String | getLimitString(String querySelect, int offset, int limit)
String | getNoColumnsInsertString() The keyword used to insert a row without specifying any column values.
String | getSelectGUIDString()
char | openQuote() The opening quote for a quoted identifier
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsLimitOffset() Does this dialect support an offset?
boolean | supportsVariableLimit()
boolean | useMaxForLimit() Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?
Methods inherited from class org.hibernate.dialect.SybaseDialect
dropTemporaryTableAfterUse, generateTemporaryTableName, getAddColumnString, getForUpdateString, getIdentityColumnString, getIdentitySelectString, getNullColumnString, getResultSet, isCurrentTimestampSelectStringCallable, qualifyIndexName, registerResultSetOutParameter, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsInsertSelectIdentity, supportsTemporaryTables
Methods inherited from class org.hibernate.dialect.Dialect
bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, createCaseFragment, createOuterJoinFragment, dropConstraints, forUpdateOfColumns, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getKeywords, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getQuerySequencesString, getSelectClauseNullString, getSelectSequenceNextValString, getSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, performTemporaryTableDDLInIsolation, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsSequences, supportsTableCheck, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SQLServerDialect

public SQLServerDialect()
Method Detail

getNoColumnsInsertString

public String getNoColumnsInsertString()
Description copied from class: Dialect
The keyword used to insert a row without specifying any column values. This is not possible on some databases.

Overrides:
getNoColumnsInsertString in class Dialect

getLimitString

public String getLimitString(String querySelect,
                             int offset,
                             int limit)
Overrides:
getLimitString in class Dialect

appendIdentitySelectToInsert

public String appendIdentitySelectToInsert(String insertSQL)
Use insert table(...) values(...) select SCOPE_IDENTITY()

Overrides:
appendIdentitySelectToInsert in class SybaseDialect

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class Dialect

useMaxForLimit

public boolean useMaxForLimit()
Description copied from class: Dialect
Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?

Overrides:
useMaxForLimit in class Dialect

supportsLimitOffset

public boolean supportsLimitOffset()
Description copied from class: Dialect
Does this dialect support an offset?

Overrides:
supportsLimitOffset in class Dialect

supportsVariableLimit

public boolean supportsVariableLimit()
Overrides:
supportsVariableLimit in class Dialect

closeQuote

public char closeQuote()
Description copied from class: Dialect
The closing quote for a quoted identifier

Overrides:
closeQuote in class Dialect

openQuote

public char openQuote()
Description copied from class: Dialect
The opening quote for a quoted identifier

Overrides:
openQuote in class Dialect

appendLockHint

public String appendLockHint(LockMode mode,
                             String tableName)
Description copied from class: Dialect
Method appendLockHint appends according to the given lock mode a lock hint behind the given table name, if this dialect needs this. MS SQL Server for example doesn't support the standard "select ... for update" syntax and use a special "select ... from TABLE as ALIAS with (updlock, rowlock) where ..." syntax instead.

Overrides:
appendLockHint in class SybaseDialect

getSelectGUIDString

public String getSelectGUIDString()
Overrides:
getSelectGUIDString in class Dialect

getCurrentTimestampSelectString

public String getCurrentTimestampSelectString()
Overrides:
getCurrentTimestampSelectString in class SybaseDialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sybase11Dialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class Sybase11Dialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.SybaseDialect
            extended by org.hibernate.dialect.Sybase11Dialect
public class Sybase11Dialect
extends SybaseDialect

A SQL dialect suitable for use with Sybase 11.9.2 (specifically: avoids ANSI JOIN syntax)

Author:
Colm O' Flaherty

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
Sybase11Dialect()
Method Summary
 JoinFragment createOuterJoinFragment()
Create an OuterJoinGenerator for this dialect.
Methods inherited from class org.hibernate.dialect.SybaseDialect
appendIdentitySelectToInsert, appendLockHint, dropTemporaryTableAfterUse, generateTemporaryTableName, getAddColumnString, getCurrentTimestampSelectString, getForUpdateString, getIdentityColumnString, getIdentitySelectString, getNullColumnString, getResultSet, isCurrentTimestampSelectStringCallable, qualifyIndexName, registerResultSetOutParameter, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsInsertSelectIdentity, supportsTemporaryTables
Methods inherited from class org.hibernate.dialect.Dialect
bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, dropConstraints, forUpdateOfColumns, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getKeywords, getLimitString, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getQuerySequencesString, getSelectClauseNullString, getSelectGUIDString, getSelectSequenceNextValString, getSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsLimit, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsSequences, supportsTableCheck, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Sybase11Dialect

public Sybase11Dialect()
Method Detail

createOuterJoinFragment

public JoinFragment createOuterJoinFragment()
Description copied from class: Dialect
Create an OuterJoinGenerator for this dialect.

Overrides:
createOuterJoinFragment in class Dialect
Returns:
OuterJoinGenerator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SybaseAnywhereDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class SybaseAnywhereDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.SybaseDialect
            extended by org.hibernate.dialect.SybaseAnywhereDialect
public class SybaseAnywhereDialect
extends SybaseDialect

SQL Dialect for Sybase Anywhere extending Sybase (Enterprise) Dialect (Tested on ASA 8.x)

Author:
?

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
SybaseAnywhereDialect()
Method Summary
boolean | dropConstraints() ASA does not require to drop constraint before dropping tables, and DROP statement syntax used by Hibernate to drop constraint is not compatible with ASA, so disable it
String | getNoColumnsInsertString() Sybase Anywhere syntax would require a "DEFAULT" for each column specified, but I suppose Hibernate use this syntax only with tables with just 1 column
boolean | supportsInsertSelectIdentity()
Methods inherited from class org.hibernate.dialect.SybaseDialect
appendIdentitySelectToInsert, appendLockHint, dropTemporaryTableAfterUse, generateTemporaryTableName, getAddColumnString, getCurrentTimestampSelectString, getForUpdateString, getIdentityColumnString, getIdentitySelectString, getNullColumnString, getResultSet, isCurrentTimestampSelectStringCallable, qualifyIndexName, registerResultSetOutParameter, supportsCurrentTimestampSelection, supportsIdentityColumns, supportsTemporaryTables
Methods inherited from class org.hibernate.dialect.Dialect
bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, forUpdateOfColumns, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getKeywords, getLimitString, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getQuerySequencesString, getSelectClauseNullString, getSelectGUIDString, getSelectSequenceNextValString, getSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsLimit, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsSequences, supportsTableCheck, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SybaseAnywhereDialect

public SybaseAnywhereDialect()
Method Detail

getNoColumnsInsertString

public String getNoColumnsInsertString()
Sybase Anywhere syntax would require a "DEFAULT" for each column specified, but I suppose Hibernate use this syntax only with tables with just 1 column

Overrides:
getNoColumnsInsertString in class Dialect

dropConstraints

public boolean dropConstraints()
ASA does not require to drop constraint before dropping tables, and DROP statement syntax used by Hibernate to drop constraint is not compatible with ASA, so disable it

Overrides:
dropConstraints in class Dialect
Returns:
boolean

supportsInsertSelectIdentity

public boolean supportsInsertSelectIdentity()
Overrides:
supportsInsertSelectIdentity in class SybaseDialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SybaseDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class SybaseDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.SybaseDialect
Direct Known Subclasses:
SQLServerDialect, Sybase11Dialect, SybaseAnywhereDialect
public class SybaseDialect
extends Dialect

An SQL dialect compatible with Sybase and MS SQL Server.

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
SybaseDialect()
Method Summary
String | appendIdentitySelectToInsert(String insertSQL) Append a clause to retrieve the generated identity value for the given INSERT statement.
String | appendLockHint(LockMode mode, String tableName) Method appendLockHint appends according to the given lock mode a lock hint behind the given table name, if this dialect needs this.
boolean | dropTemporaryTableAfterUse()
String | generateTemporaryTableName(String baseTableName)
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getCurrentTimestampSelectString()
String | getForUpdateString() Retrieves the FOR UPDATE syntax specific to this dialect.
String | getIdentityColumnString()
String | getIdentitySelectString()
String | getNullColumnString() The keyword used to specify a nullable column.
ResultSet | getResultSet(CallableStatement ps)
boolean | isCurrentTimestampSelectStringCallable()
boolean | qualifyIndexName() Do we need to qualify index names with the schema name?
int | registerResultSetOutParameter(CallableStatement statement, int col)
boolean | supportsCurrentTimestampSelection()
boolean | supportsIdentityColumns() Does this dialect support identity column key generation?
boolean | supportsInsertSelectIdentity()
boolean | supportsTemporaryTables()
Methods inherited from class org.hibernate.dialect.Dialect
bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, createOuterJoinFragment, dropConstraints, forUpdateOfColumns, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceString, getCreateSequenceStrings, getCreateTemporaryTablePostfix, getCreateTemporaryTableString, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getKeywords, getLimitString, getLimitString, getLockingStrategy, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getQuerySequencesString, getSelectClauseNullString, getSelectGUIDString, getSelectSequenceNextValString, getSequenceNextValString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, supportsCascadeDelete, supportsColumnCheck, supportsCommentOn, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsLimit, supportsLimitOffset, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsSequences, supportsTableCheck, supportsUnionAll, supportsUnique, supportsUniqueConstraintInCreateAlterTable, supportsVariableLimit, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob, useMaxForLimit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SybaseDialect

public SybaseDialect()
Method Detail

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

getNullColumnString

public String getNullColumnString()
Description copied from class: Dialect
The keyword used to specify a nullable column.

Overrides:
getNullColumnString in class Dialect
Returns:
String

qualifyIndexName

public boolean qualifyIndexName()
Description copied from class: Dialect
Do we need to qualify index names with the schema name?

Overrides:
qualifyIndexName in class Dialect
Returns:
boolean

getForUpdateString

public String getForUpdateString()
Description copied from class: Dialect
Retrieves the FOR UPDATE syntax specific to this dialect.

Overrides:
getForUpdateString in class Dialect
Returns:
The appropriate FOR UPDATE clause string.

supportsIdentityColumns

public boolean supportsIdentityColumns()
Description copied from class: Dialect
Does this dialect support identity column key generation?

Overrides:
supportsIdentityColumns in class Dialect
Returns:
boolean

getIdentitySelectString

public String getIdentitySelectString()
Overrides:
getIdentitySelectString in class Dialect

getIdentityColumnString

public String getIdentityColumnString()
Overrides:
getIdentityColumnString in class Dialect

supportsInsertSelectIdentity

public boolean supportsInsertSelectIdentity()
Overrides:
supportsInsertSelectIdentity in class Dialect

appendIdentitySelectToInsert

public String appendIdentitySelectToInsert(String insertSQL)
Description copied from class: Dialect
Append a clause to retrieve the generated identity value for the given INSERT statement.

Overrides:
appendIdentitySelectToInsert in class Dialect

appendLockHint

public String appendLockHint(LockMode mode,
                             String tableName)
Description copied from class: Dialect
Method appendLockHint appends according to the given lock mode a lock hint behind the given table name, if this dialect needs this. MS SQL Server for example doesn't support the standard "select ... for update" syntax and use a special "select ... from TABLE as ALIAS with (updlock, rowlock) where ..." syntax instead.

Overrides:
appendLockHint in class Dialect
Parameters:
tableName - name of table to append lock hint
Returns:
String

author Helge Schulz

registerResultSetOutParameter

public int registerResultSetOutParameter(CallableStatement statement,
                                         int col)
                                  throws SQLException
Overrides:
registerResultSetOutParameter in class Dialect
Throws:
SQLException

getResultSet

public ResultSet getResultSet(CallableStatement ps)
                       throws SQLException
Overrides:
getResultSet in class Dialect
Throws:
SQLException

supportsCurrentTimestampSelection

public boolean supportsCurrentTimestampSelection()
Overrides:
supportsCurrentTimestampSelection in class Dialect

isCurrentTimestampSelectStringCallable

public boolean isCurrentTimestampSelectStringCallable()
Overrides:
isCurrentTimestampSelectStringCallable in class Dialect

getCurrentTimestampSelectString

public String getCurrentTimestampSelectString()
Overrides:
getCurrentTimestampSelectString in class Dialect

supportsTemporaryTables

public boolean supportsTemporaryTables()
Overrides:
supportsTemporaryTables in class Dialect

generateTemporaryTableName

public String generateTemporaryTableName(String baseTableName)
Overrides:
generateTemporaryTableName in class Dialect

dropTemporaryTableAfterUse

public boolean dropTemporaryTableAfterUse()
Overrides:
dropTemporaryTableAfterUse in class Dialect
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TimesTenDialect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class TimesTenDialect

java.lang.Object
    extended by org.hibernate.dialect.Dialect
        extended by org.hibernate.dialect.TimesTenDialect
public class TimesTenDialect
extends Dialect

A SQL dialect for TimesTen 5.1. Known limitations: joined-subclass support because of no CASE support in TimesTen No support for subqueries that includes aggregation - size() in HQL not supported - user queries that does subqueries with aggregation No CLOB/BLOB support No cascade delete support. No Calendar support No support for updating primary keys.

Author:
Sherry Listgarten and Max Andersen

Field Summary
Fields inherited from class org.hibernate.dialect.Dialect
CLOSED_QUOTE, QUOTE
Constructor Summary
TimesTenDialect()
Method Summary
JoinFragment | createOuterJoinFragment() Create an OuterJoinGenerator for this dialect.
boolean | dropConstraints() Do we need to drop constraints before dropping tables in this dialect?
String | generateTemporaryTableName(String baseTableName)
String | getAddColumnString() The syntax used to add a column to a table (optional).
String | getCreateSequenceString(String sequenceName) The syntax used to create a sequence, if sequences are supported.
String | getCreateTemporaryTablePostfix()
String | getCreateTemporaryTableString()
String | getCurrentTimestampSelectString()
String | getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String | getForUpdateString() Retrieves the FOR UPDATE syntax specific to this dialect.
String | getLimitString(String querySelect, int offset, int limit)
LockingStrategy | getLockingStrategy(Lockable lockable, LockMode lockMode) Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.
String | getQuerySequencesString() A query used to find all sequences
String | getSelectSequenceNextValString(String sequenceName) Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.
String | getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
boolean | isCurrentTimestampSelectStringCallable()
boolean | qualifyIndexName() Do we need to qualify index names with the schema name?
boolean | supportsColumnCheck() Does this dialect support column-level check constraints?
boolean | supportsCurrentTimestampSelection()
boolean | supportsLimit() Does this Dialect have some kind of LIMIT syntax?
boolean | supportsLimitOffset() Does this dialect support an offset?
boolean | supportsSequences() Does this dialect support sequences?
boolean | supportsTableCheck() Does this dialect support table-level check constraints?
boolean | supportsTemporaryTables()
boolean | supportsUnique() Does this dialect support the UNIQUE column syntax?
boolean | supportsUniqueConstraintInCreateAlterTable() Does this dialect support adding Unique constraints via create and alter table ?
boolean | supportsVariableLimit()
boolean | useMaxForLimit() Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?
Methods inherited from class org.hibernate.dialect.Dialect
appendIdentitySelectToInsert, appendLockHint, bindLimitParametersFirst, bindLimitParametersInReverseOrder, buildSQLExceptionConverter, closeQuote, createCaseFragment, dropTemporaryTableAfterUse, forUpdateOfColumns, getAddForeignKeyConstraintString, getAddPrimaryKeyConstraintString, getCascadeConstraintsString, getCastTypeName, getColumnComment, getCreateSequenceStrings, getCurrentTimestampSQLFunctionName, getDefaultProperties, getDialect, getDialect, getDropForeignKeyString, getDropSequenceStrings, getForUpdateNowaitString, getForUpdateNowaitString, getForUpdateString, getForUpdateString, getFunctions, getHibernateTypeName, getHibernateTypeName, getIdentityColumnString, getIdentityColumnString, getIdentityInsertString, getIdentitySelectString, getIdentitySelectString, getKeywords, getLimitString, getLowercaseFunction, getMaxAliasLength, getNativeIdentifierGeneratorClass, getNoColumnsInsertString, getNullColumnString, getResultSet, getSelectClauseNullString, getSelectGUIDString, getTableComment, getTableTypeString, getTypeName, getTypeName, getViolatedConstraintNameExtracter, hasAlterTable, hasDataTypeInIdentityColumn, hasSelfReferentialForeignKeyBug, openQuote, performTemporaryTableDDLInIsolation, quote, registerColumnType, registerColumnType, registerFunction, registerHibernateType, registerHibernateType, registerKeyword, registerResultSetOutParameter, supportsCascadeDelete, supportsCommentOn, supportsIdentityColumns, supportsIfExistsAfterTableName, supportsIfExistsBeforeTableName, supportsInsertSelectIdentity, supportsNotNullUnique, supportsOuterJoinForUpdate, supportsParametersInInsertSelect, supportsRowValueConstructorSyntax, supportsUnionAll, toBooleanValueString, toString, transformSelectString, useInputStreamToInsertBlob
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TimesTenDialect

public TimesTenDialect()
Method Detail

dropConstraints

public boolean dropConstraints()
Description copied from class: Dialect
Do we need to drop constraints before dropping tables in this dialect?

Overrides:
dropConstraints in class Dialect
Returns:
boolean

qualifyIndexName

public boolean qualifyIndexName()
Description copied from class: Dialect
Do we need to qualify index names with the schema name?

Overrides:
qualifyIndexName in class Dialect
Returns:
boolean

supportsUnique

public boolean supportsUnique()
Description copied from class: Dialect
Does this dialect support the UNIQUE column syntax?

Overrides:
supportsUnique in class Dialect
Returns:
boolean

supportsUniqueConstraintInCreateAlterTable

public boolean supportsUniqueConstraintInCreateAlterTable()
Description copied from class: Dialect
Does this dialect support adding Unique constraints via create and alter table ?

Overrides:
supportsUniqueConstraintInCreateAlterTable in class Dialect
Returns:
boolean

getAddColumnString

public String getAddColumnString()
Description copied from class: Dialect
The syntax used to add a column to a table (optional).

Overrides:
getAddColumnString in class Dialect

supportsSequences

public boolean supportsSequences()
Description copied from class: Dialect
Does this dialect support sequences?

Overrides:
supportsSequences in class Dialect
Returns:
boolean

getSelectSequenceNextValString

public String getSelectSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.

This differs from Dialect.getSequenceNextValString(String) in that this should return an expression usable within another select statement.

Overrides:
getSelectSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getSequenceNextValString

public String getSequenceNextValString(String sequenceName)
Description copied from class: Dialect
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.

This should be a "stand alone" select statement.

Overrides:
getSequenceNextValString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String The "nextval" select string.

getCreateSequenceString

public String getCreateSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to create a sequence, if sequences are supported.

Overrides:
getCreateSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getDropSequenceString

public String getDropSequenceString(String sequenceName)
Description copied from class: Dialect
The syntax used to drop a sequence, if sequences are supported.

Overrides:
getDropSequenceString in class Dialect
Parameters:
sequenceName - the name of the sequence
Returns:
String

getQuerySequencesString

public String getQuerySequencesString()
Description copied from class: Dialect
A query used to find all sequences

Overrides:
getQuerySequencesString in class Dialect
See Also:
SchemaUpdate

createOuterJoinFragment

public JoinFragment createOuterJoinFragment()
Description copied from class: Dialect
Create an OuterJoinGenerator for this dialect.

Overrides:
createOuterJoinFragment in class Dialect
Returns:
OuterJoinGenerator

getForUpdateString

public String getForUpdateString()
Description copied from class: Dialect
Retrieves the FOR UPDATE syntax specific to this dialect.

Overrides:
getForUpdateString in class Dialect
Returns:
The appropriate FOR UPDATE clause string.

supportsColumnCheck

public boolean supportsColumnCheck()
Description copied from class: Dialect
Does this dialect support column-level check constraints?

Overrides:
supportsColumnCheck in class Dialect

supportsTableCheck

public boolean supportsTableCheck()
Description copied from class: Dialect
Does this dialect support table-level check constraints?

Overrides:
supportsTableCheck in class Dialect

supportsLimitOffset

public boolean supportsLimitOffset()
Description copied from class: Dialect
Does this dialect support an offset?

Overrides:
supportsLimitOffset in class Dialect

supportsVariableLimit

public boolean supportsVariableLimit()
Overrides:
supportsVariableLimit in class Dialect

supportsLimit

public boolean supportsLimit()
Description copied from class: Dialect
Does this Dialect have some kind of LIMIT syntax?

Overrides:
supportsLimit in class Dialect

useMaxForLimit

public boolean useMaxForLimit()
Description copied from class: Dialect
Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?

Overrides:
useMaxForLimit in class Dialect

getLimitString

public String getLimitString(String querySelect,
                             int offset,
                             int limit)
Overrides:
getLimitString in class Dialect

supportsCurrentTimestampSelection

public boolean supportsCurrentTimestampSelection()
Overrides:
supportsCurrentTimestampSelection in class Dialect

getCurrentTimestampSelectString

public String getCurrentTimestampSelectString()
Overrides:
getCurrentTimestampSelectString in class Dialect

isCurrentTimestampSelectStringCallable

public boolean isCurrentTimestampSelectStringCallable()
Overrides:
isCurrentTimestampSelectStringCallable in class Dialect

supportsTemporaryTables

public boolean supportsTemporaryTables()
Overrides:
supportsTemporaryTables in class Dialect

generateTemporaryTableName

public String generateTemporaryTableName(String baseTableName)
Overrides:
generateTemporaryTableName in class Dialect

getCreateTemporaryTableString

public String getCreateTemporaryTableString()
Overrides:
getCreateTemporaryTableString in class Dialect

getCreateTemporaryTablePostfix

public String getCreateTemporaryTablePostfix()
Overrides:
getCreateTemporaryTablePostfix in class Dialect

getLockingStrategy

public LockingStrategy getLockingStrategy(Lockable lockable,
                                          LockMode lockMode)
Description copied from class: Dialect
Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.

Overrides:
getLockingStrategy in class Dialect
Parameters:
lockable - The persister for the entity to be locked.
lockMode - The type of lock to be acquired.
Returns:
The appropriate locking strategy.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TypeNames (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect
Class TypeNames

java.lang.Object
    extended by org.hibernate.dialect.TypeNames
public class TypeNames
extends Object

This class maps a type to names. Associations may be marked with a capacity. Calling the get() method with a type and actual size n will return the associated name with smallest capacity >= n, if available and an unmarked default type otherwise. Eg, setting

    names.put(type,        "TEXT" );
    names.put(type,   255, "VARCHAR($l)" );
    names.put(type, 65534, "LONGVARCHAR($l)" );
will give you back the following:
  names.get(type)         // --> "TEXT" (default)
  names.get(type,    100) // --> "VARCHAR(100)" (100 is in [0:255])
  names.get(type,   1000) // --> "LONGVARCHAR(1000)" (1000 is in [256:65534])
  names.get(type, 100000) // --> "TEXT" (default)
On the other hand, simply putting
    names.put(type, "VARCHAR($l)" );
would result in
  names.get(type)        // --> "VARCHAR($l)" (will cause trouble)
  names.get(type, 100)   // --> "VARCHAR(100)"
  names.get(type, 10000) // --> "VARCHAR(10000)"

Author:
Christoph Beck

Constructor Summary
TypeNames()
Method Summary
String | get(int typecode) get default type name for specified type
String | get(int typecode, int size, int precision, int scale) get type name for specified type and size
void | put(int typecode, int capacity, String value) set a type name for specified type key and capacity
void | put(int typecode, String value) set a default type name for specified type key
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TypeNames

public TypeNames()
Method Detail

get

public String get(int typecode)
           throws MappingException
get default type name for specified type

Parameters:
typecode - the type key
Returns:
the default type name associated with specified key
Throws:
MappingException

get

public String get(int typecode,
                  int size,
                  int precision,
                  int scale)
           throws MappingException
get type name for specified type and size

Parameters:
typecode - the type key
size - the SQL length
scale - the SQL scale
precision - the SQL precision
Returns:
the associated name with smallest capacity >= size, if available and the default type name otherwise
Throws:
MappingException

put

public void put(int typecode,
                int capacity,
                String value)
set a type name for specified type key and capacity

Parameters:
typecode - the type key

put

public void put(int typecode,
                String value)
set a default type name for specified type key

Parameters:
typecode - the type key
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.dialect.function (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.dialect.function

A framework for defining database-specific SQL functions that are available via the dialect.

See:
Description

Interface Summary
SQLFunction Provides support routines for the HQL functions as used in the various SQL Dialects Provides an interface for supporting various HQL functions that are translated to SQL.

Class Summary
AnsiTrimEmulationFunction | A SQLFunction implementation that emulates the ANSI SQL trim function on dialects which do not support the full definition.
CastFunction | ANSI-SQL style cast(foo as type) where the type is a Hibernate type
CharIndexFunction | Emulation of locate() on Sybase
ClassicAvgFunction | Classic AVG sqlfunction that return types as it was done in Hibernate 3.1
ClassicCountFunction | Classic COUNT sqlfunction that return types as it was done in Hibernate 3.1
ClassicSumFunction | Classic SUM sqlfunction that return types as it was done in Hibernate 3.1
NoArgSQLFunction | A function which takes no arguments
NvlFunction | Emulation of coalesce() on Oracle, using multiple nvl() calls
PositionSubstringFunction | Emulation of locate() on PostgreSQL
SQLFunctionRegistry |
SQLFunctionTemplate | Represents HQL functions that can have different representations in different SQL dialects.
StandardSQLFunction | Provides a standard implementation that supports the majority of the HQL functions that are translated to SQL.
VarArgsSQLFunction | Support for slightly more general templating than StandardSQLFunction, with an unlimited number of arguments.

Package org.hibernate.dialect.function Description

A framework for defining database-specific SQL functions that are available via the dialect.


org.hibernate.dialect.function Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.dialect.function

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.dialect.function.AnsiTrimEmulationFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.dialect.function.CastFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.dialect.function.CharIndexFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.dialect.function.NoArgSQLFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.dialect.function.NvlFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.dialect.function.PositionSubstringFunction (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.dialect.function.SQLFunctionRegistry
    • class org.hibernate.dialect.function.SQLFunctionTemplate (implements org.hibernate.dialect.function.SQLFunction)
    • class org.hibernate.dialect.function.StandardSQLFunction (implements org.hibernate.dialect.function.SQLFunction)
      • class org.hibernate.dialect.function.ClassicAvgFunction
      • class org.hibernate.dialect.function.ClassicCountFunction
      • class org.hibernate.dialect.function.ClassicSumFunction
    • class org.hibernate.dialect.function.VarArgsSQLFunction (implements org.hibernate.dialect.function.SQLFunction)

Interface Hierarchy

  • interface org.hibernate.dialect.function.SQLFunction


Uses of Package org.hibernate.dialect.function (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.dialect.function

Packages that use org.hibernate.dialect.function
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function | A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.
org.hibernate.util | Utility classes.

Classes in org.hibernate.dialect.function used by org.hibernate.cfg
SQLFunction
Provides support routines for the HQL functions as used in the various SQL Dialects Provides an interface for supporting various HQL functions that are translated to SQL.

Classes in org.hibernate.dialect.function used by org.hibernate.dialect
SQLFunction
Provides support routines for the HQL functions as used in the various SQL Dialects Provides an interface for supporting various HQL functions that are translated to SQL.

Classes in org.hibernate.dialect.function used by org.hibernate.dialect.function
SQLFunction
Provides support routines for the HQL functions as used in the various SQL Dialects Provides an interface for supporting various HQL functions that are translated to SQL.
StandardSQLFunction
Provides a standard implementation that supports the majority of the HQL functions that are translated to SQL.

Classes in org.hibernate.dialect.function used by org.hibernate.engine
SQLFunctionRegistry

Classes in org.hibernate.dialect.function used by org.hibernate.hql.ast.tree
SQLFunction
Provides support routines for the HQL functions as used in the various SQL Dialects Provides an interface for supporting various HQL functions that are translated to SQL.

Classes in org.hibernate.dialect.function used by org.hibernate.hql.ast.util
SQLFunction
Provides support routines for the HQL functions as used in the various SQL Dialects Provides an interface for supporting various HQL functions that are translated to SQL.

Classes in org.hibernate.dialect.function used by org.hibernate.impl
SQLFunctionRegistry

Classes in org.hibernate.dialect.function used by org.hibernate.mapping
SQLFunctionRegistry

Classes in org.hibernate.dialect.function used by org.hibernate.sql
SQLFunctionRegistry

Classes in org.hibernate.dialect.function used by org.hibernate.util
SQLFunctionRegistry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SQLFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Interface SQLFunction

All Known Implementing Classes:
AnsiTrimEmulationFunction, CastFunction, CharIndexFunction, DerbyDialect.DerbyTrimFunctionEmulation, NoArgSQLFunction, NvlFunction, PositionSubstringFunction, SQLFunctionTemplate, StandardSQLFunction, VarArgsSQLFunction
public interface SQLFunction

Provides support routines for the HQL functions as used in the various SQL Dialects Provides an interface for supporting various HQL functions that are translated to SQL. The Dialect and its sub-classes use this interface to provide details required for processing of the function.

Author:
David Channon

Method Summary
Type | getReturnType(Type columnType, Mapping mapping) The function return type
boolean | hasArguments() Does this function have any arguments?
boolean | hasParenthesesIfNoArguments() If there are no arguments, are parens required?
String | render(List args, SessionFactoryImplementor factory) Render the function call as SQL

Method Detail

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
                   throws QueryException
The function return type

Parameters:
columnType - the type of the first argument
Throws:
QueryException

hasArguments

public boolean hasArguments()
Does this function have any arguments?

hasParenthesesIfNoArguments

public boolean hasParenthesesIfNoArguments()
If there are no arguments, are parens required?

render

public String render(List args,
                     SessionFactoryImplementor factory)
              throws QueryException
Render the function call as SQL

Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AnsiTrimEmulationFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class AnsiTrimEmulationFunction

java.lang.Object
    extended by org.hibernate.dialect.function.AnsiTrimEmulationFunction
All Implemented Interfaces:
SQLFunction
public class AnsiTrimEmulationFunction
extends Object
implements SQLFunction

A SQLFunction implementation that emulates the ANSI SQL trim function on dialects which do not support the full definition. However, this function definition does assume the availability of ltrim, rtrim, and replace functions which it uses in various combinations to emulate the desired ANSI trim() functionality.

Author:
Steve Ebersole

Constructor Summary
AnsiTrimEmulationFunction()
Method Summary
Type | getReturnType(Type columnType, Mapping mapping) The function return type
boolean | hasArguments() Does this function have any arguments?
boolean | hasParenthesesIfNoArguments() If there are no arguments, are parens required?
String | render(List args, SessionFactoryImplementor factory) Render the function call as SQL
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AnsiTrimEmulationFunction

public AnsiTrimEmulationFunction()
Method Detail

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
                   throws QueryException
Description copied from interface: SQLFunction
The function return type

Specified by:
getReturnType in interface SQLFunction
Parameters:
columnType - the type of the first argument
Throws:
QueryException

hasArguments

public boolean hasArguments()
Description copied from interface: SQLFunction
Does this function have any arguments?

Specified by:
hasArguments in interface SQLFunction

hasParenthesesIfNoArguments

public boolean hasParenthesesIfNoArguments()
Description copied from interface: SQLFunction
If there are no arguments, are parens required?

Specified by:
hasParenthesesIfNoArguments in interface SQLFunction

render

public String render(List args,
                     SessionFactoryImplementor factory)
              throws QueryException
Description copied from interface: SQLFunction
Render the function call as SQL

Specified by:
render in interface SQLFunction
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CastFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class CastFunction

java.lang.Object
    extended by org.hibernate.dialect.function.CastFunction
All Implemented Interfaces:
SQLFunction
public class CastFunction
extends Object
implements SQLFunction

ANSI-SQL style cast(foo as type) where the type is a Hibernate type

Author:
Gavin King

Constructor Summary
CastFunction()
Method Summary
Type | getReturnType(Type columnType, Mapping mapping) The function return type
boolean | hasArguments() Does this function have any arguments?
boolean | hasParenthesesIfNoArguments() If there are no arguments, are parens required?
String | render(List args, SessionFactoryImplementor factory) Render the function call as SQL
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CastFunction

public CastFunction()
Method Detail

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
                   throws QueryException
Description copied from interface: SQLFunction
The function return type

Specified by:
getReturnType in interface SQLFunction
Parameters:
columnType - the type of the first argument
Throws:
QueryException

hasArguments

public boolean hasArguments()
Description copied from interface: SQLFunction
Does this function have any arguments?

Specified by:
hasArguments in interface SQLFunction

hasParenthesesIfNoArguments

public boolean hasParenthesesIfNoArguments()
Description copied from interface: SQLFunction
If there are no arguments, are parens required?

Specified by:
hasParenthesesIfNoArguments in interface SQLFunction

render

public String render(List args,
                     SessionFactoryImplementor factory)
              throws QueryException
Description copied from interface: SQLFunction
Render the function call as SQL

Specified by:
render in interface SQLFunction
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CharIndexFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class CharIndexFunction

java.lang.Object
    extended by org.hibernate.dialect.function.CharIndexFunction
All Implemented Interfaces:
SQLFunction
public class CharIndexFunction
extends Object
implements SQLFunction

Emulation of locate() on Sybase

Author:
Nathan Moon

Constructor Summary
CharIndexFunction()
Method Summary
Type | getReturnType(Type columnType, Mapping mapping) The function return type
boolean | hasArguments() Does this function have any arguments?
boolean | hasParenthesesIfNoArguments() If there are no arguments, are parens required?
String | render(List args, SessionFactoryImplementor factory) Render the function call as SQL
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CharIndexFunction

public CharIndexFunction()
Method Detail

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
                   throws QueryException
Description copied from interface: SQLFunction
The function return type

Specified by:
getReturnType in interface SQLFunction
Parameters:
columnType - the type of the first argument
Throws:
QueryException

hasArguments

public boolean hasArguments()
Description copied from interface: SQLFunction
Does this function have any arguments?

Specified by:
hasArguments in interface SQLFunction

hasParenthesesIfNoArguments

public boolean hasParenthesesIfNoArguments()
Description copied from interface: SQLFunction
If there are no arguments, are parens required?

Specified by:
hasParenthesesIfNoArguments in interface SQLFunction

render

public String render(List args,
                     SessionFactoryImplementor factory)
              throws QueryException
Description copied from interface: SQLFunction
Render the function call as SQL

Specified by:
render in interface SQLFunction
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassicAvgFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class ClassicAvgFunction

java.lang.Object
    extended by org.hibernate.dialect.function.StandardSQLFunction
        extended by org.hibernate.dialect.function.ClassicAvgFunction
All Implemented Interfaces:
SQLFunction
public class ClassicAvgFunction
extends StandardSQLFunction

Classic AVG sqlfunction that return types as it was done in Hibernate 3.1

Author:
Max Rydahl Andersen

Constructor Summary
ClassicAvgFunction()
Method Summary
 Type getReturnType(Type columnType, Mapping mapping)
The function return type
Methods inherited from class org.hibernate.dialect.function.StandardSQLFunction
hasArguments, hasParenthesesIfNoArguments, render, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ClassicAvgFunction

public ClassicAvgFunction()
Method Detail

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
                   throws QueryException
Description copied from interface: SQLFunction
The function return type

Specified by:
getReturnType in interface SQLFunction
Overrides:
getReturnType in class StandardSQLFunction
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassicCountFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class ClassicCountFunction

java.lang.Object
    extended by org.hibernate.dialect.function.StandardSQLFunction
        extended by org.hibernate.dialect.function.ClassicCountFunction
All Implemented Interfaces:
SQLFunction
public class ClassicCountFunction
extends StandardSQLFunction

Classic COUNT sqlfunction that return types as it was done in Hibernate 3.1

Author:
Max Rydahl Andersen

Constructor Summary
ClassicCountFunction()
Method Summary
 Type getReturnType(Type columnType, Mapping mapping)
The function return type
Methods inherited from class org.hibernate.dialect.function.StandardSQLFunction
hasArguments, hasParenthesesIfNoArguments, render, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ClassicCountFunction

public ClassicCountFunction()
Method Detail

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
Description copied from interface: SQLFunction
The function return type

Specified by:
getReturnType in interface SQLFunction
Overrides:
getReturnType in class StandardSQLFunction
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassicSumFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class ClassicSumFunction

java.lang.Object
    extended by org.hibernate.dialect.function.StandardSQLFunction
        extended by org.hibernate.dialect.function.ClassicSumFunction
All Implemented Interfaces:
SQLFunction
public class ClassicSumFunction
extends StandardSQLFunction

Classic SUM sqlfunction that return types as it was done in Hibernate 3.1

Author:
Max Rydahl Andersen

Constructor Summary
ClassicSumFunction()
Methods inherited from class org.hibernate.dialect.function.StandardSQLFunction
getReturnType, hasArguments, hasParenthesesIfNoArguments, render, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ClassicSumFunction

public ClassicSumFunction()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoArgSQLFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class NoArgSQLFunction

java.lang.Object
    extended by org.hibernate.dialect.function.NoArgSQLFunction
All Implemented Interfaces:
SQLFunction
public class NoArgSQLFunction
extends Object
implements SQLFunction

A function which takes no arguments

Author:
Michi

Constructor Summary
NoArgSQLFunction(String name, Type returnType)
NoArgSQLFunction(String name, Type returnType, boolean hasParenthesesIfNoArguments)
Method Summary
Type | getReturnType(Type columnType, Mapping mapping) The function return type
boolean | hasArguments() Does this function have any arguments?
boolean | hasParenthesesIfNoArguments() If there are no arguments, are parens required?
String | render(List args, SessionFactoryImplementor factory) Render the function call as SQL
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NoArgSQLFunction

public NoArgSQLFunction(String name,
                        Type returnType)

NoArgSQLFunction

public NoArgSQLFunction(String name,
                        Type returnType,
                        boolean hasParenthesesIfNoArguments)
Method Detail

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
                   throws QueryException
Description copied from interface: SQLFunction
The function return type

Specified by:
getReturnType in interface SQLFunction
Parameters:
columnType - the type of the first argument
Throws:
QueryException

hasArguments

public boolean hasArguments()
Description copied from interface: SQLFunction
Does this function have any arguments?

Specified by:
hasArguments in interface SQLFunction

hasParenthesesIfNoArguments

public boolean hasParenthesesIfNoArguments()
Description copied from interface: SQLFunction
If there are no arguments, are parens required?

Specified by:
hasParenthesesIfNoArguments in interface SQLFunction

render

public String render(List args,
                     SessionFactoryImplementor factory)
              throws QueryException
Description copied from interface: SQLFunction
Render the function call as SQL

Specified by:
render in interface SQLFunction
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NvlFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class NvlFunction

java.lang.Object
    extended by org.hibernate.dialect.function.NvlFunction
All Implemented Interfaces:
SQLFunction
public class NvlFunction
extends Object
implements SQLFunction

Emulation of coalesce() on Oracle, using multiple nvl() calls

Author:
Gavin King

Constructor Summary
NvlFunction()
Method Summary
Type | getReturnType(Type columnType, Mapping mapping) The function return type
boolean | hasArguments() Does this function have any arguments?
boolean | hasParenthesesIfNoArguments() If there are no arguments, are parens required?
String | render(List args, SessionFactoryImplementor factory) Render the function call as SQL
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NvlFunction

public NvlFunction()
Method Detail

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
                   throws QueryException
Description copied from interface: SQLFunction
The function return type

Specified by:
getReturnType in interface SQLFunction
Parameters:
columnType - the type of the first argument
Throws:
QueryException

hasArguments

public boolean hasArguments()
Description copied from interface: SQLFunction
Does this function have any arguments?

Specified by:
hasArguments in interface SQLFunction

hasParenthesesIfNoArguments

public boolean hasParenthesesIfNoArguments()
Description copied from interface: SQLFunction
If there are no arguments, are parens required?

Specified by:
hasParenthesesIfNoArguments in interface SQLFunction

render

public String render(List args,
                     SessionFactoryImplementor factory)
              throws QueryException
Description copied from interface: SQLFunction
Render the function call as SQL

Specified by:
render in interface SQLFunction
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PositionSubstringFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class PositionSubstringFunction

java.lang.Object
    extended by org.hibernate.dialect.function.PositionSubstringFunction
All Implemented Interfaces:
SQLFunction
public class PositionSubstringFunction
extends Object
implements SQLFunction

Emulation of locate() on PostgreSQL

Author:
Gavin King

Constructor Summary
PositionSubstringFunction()
Method Summary
Type | getReturnType(Type columnType, Mapping mapping) The function return type
boolean | hasArguments() Does this function have any arguments?
boolean | hasParenthesesIfNoArguments() If there are no arguments, are parens required?
String | render(List args, SessionFactoryImplementor factory) Render the function call as SQL
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PositionSubstringFunction

public PositionSubstringFunction()
Method Detail

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
                   throws QueryException
Description copied from interface: SQLFunction
The function return type

Specified by:
getReturnType in interface SQLFunction
Parameters:
columnType - the type of the first argument
Throws:
QueryException

hasArguments

public boolean hasArguments()
Description copied from interface: SQLFunction
Does this function have any arguments?

Specified by:
hasArguments in interface SQLFunction

hasParenthesesIfNoArguments

public boolean hasParenthesesIfNoArguments()
Description copied from interface: SQLFunction
If there are no arguments, are parens required?

Specified by:
hasParenthesesIfNoArguments in interface SQLFunction

render

public String render(List args,
                     SessionFactoryImplementor factory)
              throws QueryException
Description copied from interface: SQLFunction
Render the function call as SQL

Specified by:
render in interface SQLFunction
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLFunctionRegistry (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class SQLFunctionRegistry

java.lang.Object
    extended by org.hibernate.dialect.function.SQLFunctionRegistry
public class SQLFunctionRegistry
extends Object

Constructor Summary
SQLFunctionRegistry(Dialect dialect, Map userFunctions)
Method Summary
SQLFunction | findSQLFunction(String functionName)
boolean | hasFunction(String functionName)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SQLFunctionRegistry

public SQLFunctionRegistry(Dialect dialect,
                           Map userFunctions)
Method Detail

findSQLFunction

public SQLFunction findSQLFunction(String functionName)

hasFunction

public boolean hasFunction(String functionName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLFunctionTemplate (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class SQLFunctionTemplate

java.lang.Object
    extended by org.hibernate.dialect.function.SQLFunctionTemplate
All Implemented Interfaces:
SQLFunction
public class SQLFunctionTemplate
extends Object
implements SQLFunction

Represents HQL functions that can have different representations in different SQL dialects. E.g. in HQL we can define function concat(?1, ?2) to concatenate two strings p1 and p2. Target SQL function will be dialect-specific, e.g. (?1 || ?2) for Oracle, concat(?1, ?2) for MySql, (?1 + ?2) for MS SQL. Each dialect will define a template as a string (exactly like above) marking function parameters with '?' followed by parameter's index (first index is 1).

Version:
$Revision: 6608 $
Author:
Alexey Loubyansky

Constructor Summary
SQLFunctionTemplate(Type type, String template)
SQLFunctionTemplate(Type type, String template, boolean hasParenthesesIfNoArgs)
Method Summary
Type | getReturnType(Type columnType, Mapping mapping) The function return type
boolean | hasArguments() Does this function have any arguments?
boolean | hasParenthesesIfNoArguments() If there are no arguments, are parens required?
String | render(List args, SessionFactoryImplementor factory) Applies the template to passed in arguments.
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SQLFunctionTemplate

public SQLFunctionTemplate(Type type,
                           String template)

SQLFunctionTemplate

public SQLFunctionTemplate(Type type,
                           String template,
                           boolean hasParenthesesIfNoArgs)
Method Detail

render

public String render(List args,
                     SessionFactoryImplementor factory)
Applies the template to passed in arguments.

Specified by:
render in interface SQLFunction
Parameters:
args - function arguments
Returns:
generated SQL function call

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
                   throws QueryException
Description copied from interface: SQLFunction
The function return type

Specified by:
getReturnType in interface SQLFunction
Parameters:
columnType - the type of the first argument
Throws:
QueryException

hasArguments

public boolean hasArguments()
Description copied from interface: SQLFunction
Does this function have any arguments?

Specified by:
hasArguments in interface SQLFunction

hasParenthesesIfNoArguments

public boolean hasParenthesesIfNoArguments()
Description copied from interface: SQLFunction
If there are no arguments, are parens required?

Specified by:
hasParenthesesIfNoArguments in interface SQLFunction

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StandardSQLFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class StandardSQLFunction

java.lang.Object
    extended by org.hibernate.dialect.function.StandardSQLFunction
All Implemented Interfaces:
SQLFunction
Direct Known Subclasses:
ClassicAvgFunction, ClassicCountFunction, ClassicSumFunction
public class StandardSQLFunction
extends Object
implements SQLFunction

Provides a standard implementation that supports the majority of the HQL functions that are translated to SQL. The Dialect and its sub-classes use this class to provide details required for processing of the associated function.

Author:
David Channon

Constructor Summary
StandardSQLFunction(String name)
StandardSQLFunction(String name, Type typeValue)
Method Summary
Type | getReturnType(Type columnType, Mapping mapping) The function return type
boolean | hasArguments() Does this function have any arguments?
boolean | hasParenthesesIfNoArguments() If there are no arguments, are parens required?
String | render(List args, SessionFactoryImplementor factory) Render the function call as SQL
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

StandardSQLFunction

public StandardSQLFunction(String name)

StandardSQLFunction

public StandardSQLFunction(String name,
                           Type typeValue)
Method Detail

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
Description copied from interface: SQLFunction
The function return type

Specified by:
getReturnType in interface SQLFunction
Parameters:
columnType - the type of the first argument

hasArguments

public boolean hasArguments()
Description copied from interface: SQLFunction
Does this function have any arguments?

Specified by:
hasArguments in interface SQLFunction

hasParenthesesIfNoArguments

public boolean hasParenthesesIfNoArguments()
Description copied from interface: SQLFunction
If there are no arguments, are parens required?

Specified by:
hasParenthesesIfNoArguments in interface SQLFunction

render

public String render(List args,
                     SessionFactoryImplementor factory)
Description copied from interface: SQLFunction
Render the function call as SQL

Specified by:
render in interface SQLFunction

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VarArgsSQLFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.function
Class VarArgsSQLFunction

java.lang.Object
    extended by org.hibernate.dialect.function.VarArgsSQLFunction
All Implemented Interfaces:
SQLFunction
public class VarArgsSQLFunction
extends Object
implements SQLFunction

Support for slightly more general templating than StandardSQLFunction, with an unlimited number of arguments.

Author:
Gavin King

Constructor Summary
VarArgsSQLFunction(String begin, String sep, String end)
VarArgsSQLFunction(Type type, String begin, String sep, String end)
Method Summary
Type | getReturnType(Type columnType, Mapping mapping) The function return type
boolean | hasArguments() Does this function have any arguments?
boolean | hasParenthesesIfNoArguments() If there are no arguments, are parens required?
String | render(List args, SessionFactoryImplementor factory) Render the function call as SQL
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VarArgsSQLFunction

public VarArgsSQLFunction(Type type,
                          String begin,
                          String sep,
                          String end)

VarArgsSQLFunction

public VarArgsSQLFunction(String begin,
                          String sep,
                          String end)
Method Detail

getReturnType

public Type getReturnType(Type columnType,
                          Mapping mapping)
                   throws QueryException
Description copied from interface: SQLFunction
The function return type

Specified by:
getReturnType in interface SQLFunction
Parameters:
columnType - the type of the first argument
Throws:
QueryException

hasArguments

public boolean hasArguments()
Description copied from interface: SQLFunction
Does this function have any arguments?

Specified by:
hasArguments in interface SQLFunction

hasParenthesesIfNoArguments

public boolean hasParenthesesIfNoArguments()
Description copied from interface: SQLFunction
If there are no arguments, are parens required?

Specified by:
hasParenthesesIfNoArguments in interface SQLFunction

render

public String render(List args,
                     SessionFactoryImplementor factory)
              throws QueryException
Description copied from interface: SQLFunction
Render the function call as SQL

Specified by:
render in interface SQLFunction
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.dialect.lock (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.dialect.lock

Interface Summary
LockingStrategy A strategy abstraction for how locks are obtained in the underlying database.

Class Summary
SelectLockingStrategy | A locking strategy where the locks are obtained through select statements.
UpdateLockingStrategy | A locking strategy where the locks are obtained through update statements.


org.hibernate.dialect.lock Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.dialect.lock

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.dialect.lock.SelectLockingStrategy (implements org.hibernate.dialect.lock.LockingStrategy)
    • class org.hibernate.dialect.lock.UpdateLockingStrategy (implements org.hibernate.dialect.lock.LockingStrategy)

Interface Hierarchy

  • interface org.hibernate.dialect.lock.LockingStrategy


Uses of Package org.hibernate.dialect.lock (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.dialect.lock

Packages that use org.hibernate.dialect.lock
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.lock |
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Classes in org.hibernate.dialect.lock used by org.hibernate.dialect
LockingStrategy
A strategy abstraction for how locks are obtained in the underlying database.
SelectLockingStrategy
A locking strategy where the locks are obtained through select statements.

Classes in org.hibernate.dialect.lock used by org.hibernate.dialect.lock
LockingStrategy
A strategy abstraction for how locks are obtained in the underlying database.

Classes in org.hibernate.dialect.lock used by org.hibernate.persister.entity
LockingStrategy
A strategy abstraction for how locks are obtained in the underlying database.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


LockingStrategy (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.lock
Interface LockingStrategy

All Known Implementing Classes:
SelectLockingStrategy, UpdateLockingStrategy
public interface LockingStrategy

A strategy abstraction for how locks are obtained in the underlying database.

All locking provided implemenations assume the underlying database supports (and that the connection is in) at least read-committed transaction isolation. The most glaring exclusion to this is HSQLDB which only offers support for READ_UNCOMMITTED isolation.

Since:
3.2
Author:
Steve Ebersole
See Also:
Dialect.getLockingStrategy(org.hibernate.persister.entity.Lockable, org.hibernate.LockMode)

Method Summary
 void lock(Serializable id, Object version, Object object, SessionImplementor session)
Acquire an appropriate type of lock on the underlying data that will endure until the end of the current transaction.

Method Detail

lock

public void lock(Serializable id,
                 Object version,
                 Object object,
                 SessionImplementor session)
          throws StaleObjectStateException,
                 JDBCException
Acquire an appropriate type of lock on the underlying data that will endure until the end of the current transaction.

Parameters:
id - The id of the row to be locked
version - The current version (or null if not versioned)
object - The object logically being locked (currently not used)
session - The session from which the lock request originated
Throws:
StaleObjectStateException - Indicates an optimisitic lock failure as part of acquiring the requested database lock.
JDBCException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


SelectLockingStrategy (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.lock
Class SelectLockingStrategy

java.lang.Object
    extended by org.hibernate.dialect.lock.SelectLockingStrategy
All Implemented Interfaces:
LockingStrategy
Direct Known Subclasses:
HSQLDialect.ReadUncommittedLockingStrategy
public class SelectLockingStrategy
extends Object
implements LockingStrategy

A locking strategy where the locks are obtained through select statements.

For non-read locks, this is achieved through the Dialect's specific SELECT ... FOR UPDATE syntax.

Since:
3.2
Author:
Steve Ebersole
See Also:
Dialect.getForUpdateString(org.hibernate.LockMode), Dialect.appendLockHint(org.hibernate.LockMode, String)

Constructor Summary
SelectLockingStrategy(Lockable lockable, LockMode lockMode)
Construct a locking strategy based on SQL SELECT statements.
Method Summary
protected String | generateLockString()
protected LockMode | getLockMode()
void | lock(Serializable id, Object version, Object object, SessionImplementor session) Acquire an appropriate type of lock on the underlying data that will endure until the end of the current transaction.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SelectLockingStrategy

public SelectLockingStrategy(Lockable lockable,
                             LockMode lockMode)
Construct a locking strategy based on SQL SELECT statements.

Parameters:
lockable - The metadata for the entity to be locked.
lockMode - Indictates the type of lock to be acquired.
Method Detail

lock

public void lock(Serializable id,
                 Object version,
                 Object object,
                 SessionImplementor session)
          throws StaleObjectStateException,
                 JDBCException
Description copied from interface: LockingStrategy
Acquire an appropriate type of lock on the underlying data that will endure until the end of the current transaction.

Specified by:
lock in interface LockingStrategy
Parameters:
id - The id of the row to be locked
version - The current version (or null if not versioned)
object - The object logically being locked (currently not used)
session - The session from which the lock request originated
Throws:
StaleObjectStateException - Indicates an optimisitic lock failure as part of acquiring the requested database lock.
JDBCException
See Also:
LockingStrategy.lock(java.io.Serializable, java.lang.Object, java.lang.Object, org.hibernate.engine.SessionImplementor)

getLockMode

protected LockMode getLockMode()

generateLockString

protected String generateLockString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


UpdateLockingStrategy (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.dialect.lock
Class UpdateLockingStrategy

java.lang.Object
    extended by org.hibernate.dialect.lock.UpdateLockingStrategy
All Implemented Interfaces:
LockingStrategy
public class UpdateLockingStrategy
extends Object
implements LockingStrategy

A locking strategy where the locks are obtained through update statements.

This strategy is not valid for read style locks.

Since:
3.2
Author:
Steve Ebersole

Constructor Summary
UpdateLockingStrategy(Lockable lockable, LockMode lockMode)
Construct a locking strategy based on SQL UPDATE statements.
Method Summary
protected String | generateLockString()
protected LockMode | getLockMode()
void | lock(Serializable id, Object version, Object object, SessionImplementor session) Acquire an appropriate type of lock on the underlying data that will endure until the end of the current transaction.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UpdateLockingStrategy

public UpdateLockingStrategy(Lockable lockable,
                             LockMode lockMode)
Construct a locking strategy based on SQL UPDATE statements.

Parameters:
lockable - The metadata for the entity to be locked.
lockMode - Indictates the type of lock to be acquired. Note that read-locks are not valid for this strategy.
Method Detail

lock

public void lock(Serializable id,
                 Object version,
                 Object object,
                 SessionImplementor session)
          throws StaleObjectStateException,
                 JDBCException
Description copied from interface: LockingStrategy
Acquire an appropriate type of lock on the underlying data that will endure until the end of the current transaction.

Specified by:
lock in interface LockingStrategy
Parameters:
id - The id of the row to be locked
version - The current version (or null if not versioned)
object - The object logically being locked (currently not used)
session - The session from which the lock request originated
Throws:
StaleObjectStateException - Indicates an optimisitic lock failure as part of acquiring the requested database lock.
JDBCException
See Also:
LockingStrategy.lock(java.io.Serializable, java.lang.Object, java.lang.Object, org.hibernate.engine.SessionImplementor)

generateLockString

protected String generateLockString()

getLockMode

protected LockMode getLockMode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.engine (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.engine

This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

See:
Description

Interface Summary
HibernateIterator | An iterator that may be "closed"
JoinSequence.Selector |
Mapping | Defines operations common to "compiled" mappings (ie.
ParameterBinder.NamedParameterSource |
PersistenceContext | Holds the state of the persistence context, including the first-level cache, entries, snapshots, proxies, etc.
SessionFactoryImplementor | Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor | Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Class Summary
ActionQueue | Responsible for maintaining the queue of actions related to events.
BatchFetchQueue | Tracks entity and collection keys that are available for batch fetching, and the queries which were used to load entities, which can be re-used as a subquery for loading owned collections.
Cascade | Delegate responsible for, in conjunction with the various actions, implementing cascade processing.
CascadeStyle | A style of cascade that can be specified by the mapping for an association.
CascadeStyle.MultipleCascadeStyle |
CascadingAction | A session action that may be cascaded from parent entity to its children
CollectionEntry | We need an entry to tell us all about the current state of a collection with respect to its persistent state
CollectionKey | Uniquely identifies a collection instance in a particular session.
CollectionLoadContext | Represents the state of collections currently being loaded.
Collections | Implements book-keeping for the collection persistence by reachability algorithm
EntityEntry | We need an entry to tell us all about the current state of an object with respect to its persistent state
EntityKey | Uniquely identifies of an entity instance in a particular session by identifier.
EntityUniqueKey | Used to uniquely key an entity instance in relation to a particular session by some unique property reference, as opposed to identifier.
ExecuteUpdateResultCheckStyle | For persistence operations (INSERT, UPDATE, DELETE) what style of determining results (success/failure) is to be used.
FilterDefinition | A FilterDefinition defines the global attributes of a dynamic filter.
ForeignKeys | Algorithms related to foreign key constraint transparency
ForeignKeys.Nullifier |
IdentifierValue | A strategy for determining if an identifier value is an identifier of a new transient instance or a previously persistent transient instance.
JoinHelper |
JoinSequence |
NamedQueryDefinition | Definition of a named query, defined in the mapping metadata.
NamedSQLQueryDefinition | Definition of a named native SQL query, defined in the mapping metadata.
Nullability | Implements the algorithm for validating property values for illegal null values
ParameterBinder | Centralizes the commonality regarding binding of parameter values into PreparedStatements as this logic is used in many places.
QueryParameters |
ResultSetMappingDefinition | Keep a description of the resultset mapping
RowSelection | Represents a selection of rows in a JDBC ResultSet
StatefulPersistenceContext | A PersistenceContext represents the state of persistent "stuff" which Hibernate is tracking.
Status | Represents the status of an entity with respect to this session.
SubselectFetch |
TransactionHelper | Allows work to be done outside the current transaction, by suspending it, and performing work in a new transaction
TwoPhaseLoad | Functionality relating to Hibernate's two-phase loading process, that may be reused by persisters that do not use the Loader framework
TypedValue | An ordered pair of a value and its Hibernate type.
UnsavedValueFactory |
Versioning | Utility methods for managing versions and timestamps
VersionValue | A strategy for determining if a version value is an version of a new transient instance or a previously persistent transient instance.

Package org.hibernate.engine Description

This package contains classes that are "shared" by other packages, and implementations of some key algorithms.


org.hibernate.engine Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.engine

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.engine.ActionQueue
    • class org.hibernate.engine.BatchFetchQueue
    • class org.hibernate.engine.Cascade
    • class org.hibernate.engine.CascadeStyle (implements java.io.Serializable)
      • class org.hibernate.engine.CascadeStyle.MultipleCascadeStyle
    • class org.hibernate.engine.CascadingAction
    • class org.hibernate.engine.CollectionEntry (implements java.io.Serializable)
    • class org.hibernate.engine.CollectionKey (implements java.io.Serializable)
    • class org.hibernate.engine.CollectionLoadContext
    • class org.hibernate.engine.Collections
    • class org.hibernate.engine.EntityEntry (implements java.io.Serializable)
    • class org.hibernate.engine.EntityKey (implements java.io.Serializable)
    • class org.hibernate.engine.EntityUniqueKey (implements java.io.Serializable)
    • class org.hibernate.engine.ExecuteUpdateResultCheckStyle (implements java.io.Serializable)
    • class org.hibernate.engine.FilterDefinition (implements java.io.Serializable)
    • class org.hibernate.engine.ForeignKeys
    • class org.hibernate.engine.ForeignKeys.Nullifier
    • class org.hibernate.engine.IdentifierValue
    • class org.hibernate.engine.JoinHelper
    • class org.hibernate.engine.JoinSequence
    • class org.hibernate.engine.NamedQueryDefinition (implements java.io.Serializable)
      • class org.hibernate.engine.NamedSQLQueryDefinition
    • class org.hibernate.engine.Nullability
    • class org.hibernate.engine.ParameterBinder
    • class org.hibernate.engine.QueryParameters
    • class org.hibernate.engine.ResultSetMappingDefinition (implements java.io.Serializable)
    • class org.hibernate.engine.RowSelection
    • class org.hibernate.engine.StatefulPersistenceContext (implements org.hibernate.engine.PersistenceContext)
    • class org.hibernate.engine.Status (implements java.io.Serializable)
    • class org.hibernate.engine.SubselectFetch
    • class org.hibernate.engine.TransactionHelper
    • class org.hibernate.engine.TwoPhaseLoad
    • class org.hibernate.engine.TypedValue (implements java.io.Serializable)
    • class org.hibernate.engine.UnsavedValueFactory
    • class org.hibernate.engine.Versioning
    • class org.hibernate.engine.VersionValue

Interface Hierarchy

  • interface java.util.Iterator
    • interface org.hibernate.engine.HibernateIterator
  • interface org.hibernate.engine.JoinSequence.Selector
  • interface org.hibernate.engine.Mapping
    • interface org.hibernate.engine.SessionFactoryImplementor (also extends org.hibernate.SessionFactory)
  • interface org.hibernate.engine.ParameterBinder.NamedParameterSource
  • interface org.hibernate.engine.PersistenceContext
  • interface javax.naming.Referenceable
    • interface org.hibernate.SessionFactory (also extends java.io.Serializable)
      • interface org.hibernate.engine.SessionFactoryImplementor (also extends org.hibernate.engine.Mapping)
  • interface java.io.Serializable
    • interface org.hibernate.SessionFactory (also extends javax.naming.Referenceable)
      • interface org.hibernate.engine.SessionFactoryImplementor (also extends org.hibernate.engine.Mapping)
    • interface org.hibernate.engine.SessionImplementor


Uses of Package org.hibernate.engine (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.engine

Packages that use org.hibernate.engine
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.context |
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function | A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.dialect.lock |
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.engine.transaction |
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.exec |
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.id.insert |
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.intercept | This package implements an interception mechanism for lazy property fetching, based on CGLIB bytecode instrumentation.
org.hibernate.intercept.cglib |
org.hibernate.intercept.javassist |
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.custom.sql |
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.metadata | This package defines an API for accessing the Hibernate runtime metamodel.
org.hibernate.param |
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.pretty | Classes for pretty printing things for exception and log messages.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.proxy | This package defines a framework for lazy-initializing entity proxies.
org.hibernate.proxy.dom4j |
org.hibernate.proxy.map |
org.hibernate.proxy.pojo |
org.hibernate.proxy.pojo.cglib |
org.hibernate.proxy.pojo.javassist |
org.hibernate.stat | This package exposes statistics about a running Hibernate instance to the application.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.usertype | Interfaces for user-defined custom types.
org.hibernate.util | Utility classes.

Classes in org.hibernate.engine used by org.hibernate
FilterDefinition
A FilterDefinition defines the global attributes of a dynamic filter.

Classes in org.hibernate.engine used by org.hibernate.action
EntityKey
Uniquely identifies of an entity instance in a particular session by identifier.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.cache
QueryParameters
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.cache.entry
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.cfg
FilterDefinition
A FilterDefinition defines the global attributes of a dynamic filter.
Mapping
Defines operations common to "compiled" mappings (ie.
NamedQueryDefinition
Definition of a named query, defined in the mapping metadata.
NamedSQLQueryDefinition
Definition of a named native SQL query, defined in the mapping metadata.
ResultSetMappingDefinition
Keep a description of the resultset mapping

Classes in org.hibernate.engine used by org.hibernate.collection
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.context
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Classes in org.hibernate.engine used by org.hibernate.criterion
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
TypedValue
An ordered pair of a value and its Hibernate type.

Classes in org.hibernate.engine used by org.hibernate.dialect
Mapping
Defines operations common to "compiled" mappings (ie.
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.dialect.function
Mapping
Defines operations common to "compiled" mappings (ie.
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Classes in org.hibernate.engine used by org.hibernate.dialect.lock
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.engine
ActionQueue
Responsible for maintaining the queue of actions related to events.
BatchFetchQueue
Tracks entity and collection keys that are available for batch fetching, and the queries which were used to load entities, which can be re-used as a subquery for loading owned collections.
CascadeStyle
A style of cascade that can be specified by the mapping for an association.
CascadingAction
A session action that may be cascaded from parent entity to its children
CollectionEntry
We need an entry to tell us all about the current state of a collection with respect to its persistent state
CollectionKey
Uniquely identifies a collection instance in a particular session.
CollectionLoadContext
Represents the state of collections currently being loaded.
EntityEntry
We need an entry to tell us all about the current state of an object with respect to its persistent state
EntityKey
Uniquely identifies of an entity instance in a particular session by identifier.
EntityUniqueKey
Used to uniquely key an entity instance in relation to a particular session by some unique property reference, as opposed to identifier.
ExecuteUpdateResultCheckStyle
For persistence operations (INSERT, UPDATE, DELETE) what style of determining results (success/failure) is to be used.
IdentifierValue
A strategy for determining if an identifier value is an identifier of a new transient instance or a previously persistent transient instance.
JoinSequence
JoinSequence.Selector
Mapping
Defines operations common to "compiled" mappings (ie.
NamedQueryDefinition
Definition of a named query, defined in the mapping metadata.
NamedSQLQueryDefinition
Definition of a named native SQL query, defined in the mapping metadata.
ParameterBinder.NamedParameterSource
PersistenceContext
Holds the state of the persistence context, including the first-level cache, entries, snapshots, proxies, etc.
QueryParameters
ResultSetMappingDefinition
Keep a description of the resultset mapping
RowSelection
Represents a selection of rows in a JDBC ResultSet
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.
StatefulPersistenceContext
A PersistenceContext represents the state of persistent "stuff" which Hibernate is tracking.
Status
Represents the status of an entity with respect to this session.
SubselectFetch
VersionValue
A strategy for determining if a version value is an version of a new transient instance or a previously persistent transient instance.

Classes in org.hibernate.engine used by org.hibernate.engine.query
QueryParameters
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.engine.transaction
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.event
ActionQueue
Responsible for maintaining the queue of actions related to events.
EntityEntry
We need an entry to tell us all about the current state of an object with respect to its persistent state
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.event.def
CascadingAction
A session action that may be cascaded from parent entity to its children
EntityEntry
We need an entry to tell us all about the current state of an object with respect to its persistent state
EntityKey
Uniquely identifies of an entity instance in a particular session by identifier.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.
Status
Represents the status of an entity with respect to this session.

Classes in org.hibernate.engine used by org.hibernate.hql
JoinSequence
QueryParameters
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.hql.ast
ParameterBinder.NamedParameterSource
QueryParameters
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.hql.ast.exec
QueryParameters
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.hql.ast.tree
JoinSequence
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Classes in org.hibernate.engine used by org.hibernate.hql.ast.util
JoinSequence
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Classes in org.hibernate.engine used by org.hibernate.hql.classic
JoinSequence
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Classes in org.hibernate.engine used by org.hibernate.id
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.
TransactionHelper
Allows work to be done outside the current transaction, by suspending it, and performing work in a new transaction

Classes in org.hibernate.engine used by org.hibernate.id.insert
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.impl
ActionQueue
Responsible for maintaining the queue of actions related to events.
EntityEntry
We need an entry to tell us all about the current state of an object with respect to its persistent state
EntityKey
Uniquely identifies of an entity instance in a particular session by identifier.
FilterDefinition
A FilterDefinition defines the global attributes of a dynamic filter.
HibernateIterator
An iterator that may be "closed"
Mapping
Defines operations common to "compiled" mappings (ie.
NamedQueryDefinition
Definition of a named query, defined in the mapping metadata.
NamedSQLQueryDefinition
Definition of a named native SQL query, defined in the mapping metadata.
PersistenceContext
Holds the state of the persistence context, including the first-level cache, entries, snapshots, proxies, etc.
QueryParameters
ResultSetMappingDefinition
Keep a description of the resultset mapping
RowSelection
Represents a selection of rows in a JDBC ResultSet
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.intercept
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.intercept.cglib
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.intercept.javassist
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.jdbc
ExecuteUpdateResultCheckStyle
For persistence operations (INSERT, UPDATE, DELETE) what style of determining results (success/failure) is to be used.
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Classes in org.hibernate.engine used by org.hibernate.jmx
FilterDefinition
A FilterDefinition defines the global attributes of a dynamic filter.

Classes in org.hibernate.engine used by org.hibernate.loader
CascadeStyle
A style of cascade that can be specified by the mapping for an association.
QueryParameters
RowSelection
Represents a selection of rows in a JDBC ResultSet
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.loader.collection
QueryParameters
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.loader.criteria
CascadeStyle
A style of cascade that can be specified by the mapping for an association.
QueryParameters
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.
TypedValue
An ordered pair of a value and its Hibernate type.

Classes in org.hibernate.engine used by org.hibernate.loader.custom
QueryParameters
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.loader.custom.sql
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Classes in org.hibernate.engine used by org.hibernate.loader.entity
CascadeStyle
A style of cascade that can be specified by the mapping for an association.
CascadingAction
A session action that may be cascaded from parent entity to its children
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.loader.hql
QueryParameters
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.mapping
CascadeStyle
A style of cascade that can be specified by the mapping for an association.
ExecuteUpdateResultCheckStyle
For persistence operations (INSERT, UPDATE, DELETE) what style of determining results (success/failure) is to be used.
Mapping
Defines operations common to "compiled" mappings (ie.

Classes in org.hibernate.engine used by org.hibernate.metadata
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.param
QueryParameters
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.persister
Mapping
Defines operations common to "compiled" mappings (ie.
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Classes in org.hibernate.engine used by org.hibernate.persister.collection
ExecuteUpdateResultCheckStyle
For persistence operations (INSERT, UPDATE, DELETE) what style of determining results (success/failure) is to be used.
Mapping
Defines operations common to "compiled" mappings (ie.
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.
SubselectFetch

Classes in org.hibernate.engine used by org.hibernate.persister.entity
CascadeStyle
A style of cascade that can be specified by the mapping for an association.
ExecuteUpdateResultCheckStyle
For persistence operations (INSERT, UPDATE, DELETE) what style of determining results (success/failure) is to be used.
Mapping
Defines operations common to "compiled" mappings (ie.
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.pretty
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Classes in org.hibernate.engine used by org.hibernate.property
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.proxy
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.proxy.dom4j
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.proxy.map
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.proxy.pojo
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.proxy.pojo.cglib
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.proxy.pojo.javassist
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.stat
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.transaction
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Classes in org.hibernate.engine used by org.hibernate.tuple
CascadeStyle
A style of cascade that can be specified by the mapping for an association.
IdentifierValue
A strategy for determining if an identifier value is an identifier of a new transient instance or a previously persistent transient instance.
VersionValue
A strategy for determining if a version value is an version of a new transient instance or a previously persistent transient instance.

Classes in org.hibernate.engine used by org.hibernate.tuple.component
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Classes in org.hibernate.engine used by org.hibernate.tuple.entity
CascadeStyle
A style of cascade that can be specified by the mapping for an association.
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.type
CascadeStyle
A style of cascade that can be specified by the mapping for an association.
Mapping
Defines operations common to "compiled" mappings (ie.
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.usertype
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionImplementor
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Classes in org.hibernate.engine used by org.hibernate.util
SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HibernateIterator (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Interface HibernateIterator

All Superinterfaces:
Iterator
All Known Implementing Classes:
IteratorImpl
public interface HibernateIterator
extends Iterator

An iterator that may be "closed"

Author:
Gavin King
See Also:
Hibernate.close(java.util.Iterator)

Method Summary
 void close()
Methods inherited from interface java.util.Iterator
hasNext, next, remove

Method Detail

close

public void close()
           throws JDBCException
Throws:
JDBCException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Mapping (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Interface Mapping

All Known Subinterfaces:
SessionFactoryImplementor
All Known Implementing Classes:
SessionFactoryImpl
public interface Mapping

Defines operations common to "compiled" mappings (ie. SessionFactory) and "uncompiled" mappings (ie. Configuration) that are used by implementors of Type.

Author:
Gavin King
See Also:
Type, SessionFactoryImpl, Configuration

Method Summary
String | getIdentifierPropertyName(String className)
Type | getIdentifierType(String className)
Type | getReferencedPropertyType(String className, String propertyName)

Method Detail

getIdentifierType

public Type getIdentifierType(String className)
                       throws MappingException
Throws:
MappingException

getIdentifierPropertyName

public String getIdentifierPropertyName(String className)
                                 throws MappingException
Throws:
MappingException

getReferencedPropertyType

public Type getReferencedPropertyType(String className,
                                      String propertyName)
                               throws MappingException
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistenceContext (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Interface PersistenceContext

All Known Implementing Classes:
StatefulPersistenceContext
public interface PersistenceContext

Holds the state of the persistence context, including the first-level cache, entries, snapshots, proxies, etc.

Author:
Gavin King

Method Summary
 void addCollectionHolder(PersistentCollection holder)
Register a PersistentCollection object for an array.
 void addEntity(EntityKey key, Object entity)
Add a canonical mapping from entity key to entity instance
 void addEntity(EntityUniqueKey euk, Object entity)
Add an entity to the cache by unique key
 EntityEntry addEntity(Object entity, Status status, Object[] loadedState, EntityKey entityKey, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched)
Adds an entity to the internal caches.
 EntityEntry addEntry(Object entity, Status status, Object[] loadedState, Object rowId, Serializable id, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched)
Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.
 CollectionEntry addInitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just pulled out of the cache (does not need initializing)
 void addInitializedDetachedCollection(CollectionPersister collectionPersister, PersistentCollection collection)
add an (initialized) collection that was created by another session and passed into update() (ie.
 void addNewCollection(CollectionPersister persister, PersistentCollection collection)
Add a new collection (ie.
 void addNonLazyCollection(PersistentCollection collection)
Register a collection for non-lazy loading at the end of the two-phase load
 void addNullProperty(EntityKey ownerKey, String propertyName)
Record the fact that the association belonging to the keyed entity is null.
 void addProxy(EntityKey key, Object proxy)
Add a proxy to the session cache
 void addUninitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just loaded up (still needs initializing)
 void addUninitializedDetachedCollection(CollectionPersister persister, PersistentCollection collection)
add a detached uninitialized collection
 void addUnownedCollection(CollectionKey key, PersistentCollection collection)
Add a collection which has no owner loaded
 void afterLoad()
Call this after finishing a two-phase load
 void afterTransactionCompletion()
Called after transactions end
 void beforeLoad()
Call this before begining a two-phase load
 void checkUniqueness(EntityKey key, Object object)
Attempts to check whether the given key represents an entity already loaded within the current session.
 void clear()
Clear the state of the persistence context
 boolean containsCollection(PersistentCollection collection)
Is the given collection associated with this persistence context?
 boolean containsEntity(EntityKey key)
Is there an entity with the given key in the persistence context
 boolean containsProxy(Object proxy)
Is the given proxy associated with this persistence context?
 int decrementCascadeLevel()
Called after cascading
 BatchFetchQueue getBatchFetchQueue()
Get the BatchFetchQueue, instantiating one if necessary.
 Object[] getCachedDatabaseSnapshot(EntityKey key)
 int getCascadeLevel()
How deep are we cascaded?
 PersistentCollection getCollection(CollectionKey collectionKey)
Get the collection instance associated with the CollectionKey
 Map getCollectionEntries()
Get the mapping from collection instance to collection entry
 CollectionEntry getCollectionEntry(PersistentCollection coll)
Get the collection entry for a persistent collection
 CollectionEntry getCollectionEntryOrNull(Object collection)
Get the collection entry for a collection passed to filter, which might be a collection wrapper, an array, or an unwrapped collection.
 PersistentCollection getCollectionHolder(Object array)
Get the PersistentCollection object for an array
 CollectionLoadContext getCollectionLoadContext()
Get the context for collection loading
 Object getCollectionOwner(Serializable key, CollectionPersister collectionPersister)
Get the entity that owns this persistent collection
 Map getCollectionsByKey()
Get the mapping from collection key to collection instance
 Object[] getDatabaseSnapshot(Serializable id, EntityPersister persister)
Get the current state of the entity as known to the underlying database, or null if there is no corresponding row
 Map getEntitiesByKey()
Get the mapping from key value to entity instance
 Object getEntity(EntityKey key)
Get the entity instance associated with the given EntityKey
 Object getEntity(EntityUniqueKey euk)
Get an entity cached by unique key
 Map getEntityEntries()
Get the mapping from entity instance to entity entry
 EntityEntry getEntry(Object entity)
Retreive the EntityEntry representation of the given entity.
 Object getIndexInOwner(String entity, String property, Object childObject, Map mergeMap)
Search the persistence context for an index of the child object, given a collection role
 Object[] getNaturalIdSnapshot(Serializable id, EntityPersister persister)
 HashSet getNullifiableEntityKeys()
Retrieve the set of EntityKeys representing nullifiable references
 Serializable getOwnerId(String entity, String property, Object childObject, Map mergeMap)
Search the persistence context for an owner for the child object, given a collection role
 Object getProxy(EntityKey key)
Get an existing proxy by key
 SessionImplementor getSession()
Get the session
 Serializable getSnapshot(PersistentCollection coll)
Get the snapshot of the pre-flush collection state
 boolean hasNonReadOnlyEntities()
 int incrementCascadeLevel()
Called before cascading
 void initializeNonLazyCollections()
Force initialization of all non-lazy collections encountered during the current two-phase load (actually, this is a no-op, unless this is the "outermost" load)
 boolean isEntryFor(Object entity)
Is there an EntityEntry for this instance?
 boolean isFlushing()
Is a flush cycle currently in process?
 boolean isPropertyNull(EntityKey ownerKey, String propertyName)
Is the association property belonging to the keyed entity null?
 boolean isStateless()
 Object narrowProxy(Object proxy, EntityPersister persister, EntityKey key, Object object)
If the existing proxy is insufficiently "narrow" (derived), instantiate a new proxy and overwrite the registration of the old one.
 Object proxyFor(EntityPersister persister, EntityKey key, Object impl)
Return the existing proxy associated with the given EntityKey, or the third argument (the entity associated with the key) if no proxy exists.
 Object proxyFor(Object impl)
Return the existing proxy associated with the given EntityKey, or the argument (the entity associated with the key) if no proxy exists.
 boolean reassociateIfUninitializedProxy(Object value)
Takes the given object and, if it represents a proxy, reassociates it with this event source.
 void reassociateProxy(Object value, Serializable id)
If a deleted entity instance is re-saved, and it has a proxy, we need to reset the identifier of the proxy
 PersistentCollection removeCollectionHolder(Object array)
Remove the mapping of collection to holder during eviction of the owning entity
 Object removeEntity(EntityKey key)
Remove an entity from the session cache, also clear up other state associated with the entity, all except for the EntityEntry
 EntityEntry removeEntry(Object entity)
Remove an entity entry from the session cache
 Object removeProxy(EntityKey key)
Remove a proxy from the session cache
 void replaceDelayedEntityIdentityInsertKeys(EntityKey oldKey, Serializable generatedId)
 void setEntryStatus(EntityEntry entry, Status status)
Set the status of an entry
 void setFlushing(boolean flushing)
Called before and after the flushcycle
 void setReadOnly(Object entity, boolean readOnly)
Set the object to read only and discard it's snapshot
 String toString()
Returns a string representation of the object.
 Object unproxy(Object maybeProxy)
Get the entity instance underlying the given proxy, throwing an exception if the proxy is uninitialized.
 Object unproxyAndReassociate(Object maybeProxy)
Possibly unproxy the given reference and reassociate it with the current session.
 PersistentCollection useUnownedCollection(CollectionKey key)
Get and remove a collection whose owner is not yet loaded, when its owner is being loaded

Method Detail

isStateless

public boolean isStateless()

getSession

public SessionImplementor getSession()
Get the session

getCollectionLoadContext

public CollectionLoadContext getCollectionLoadContext()
Get the context for collection loading

addUnownedCollection

public void addUnownedCollection(CollectionKey key,
                                 PersistentCollection collection)
Add a collection which has no owner loaded

useUnownedCollection

public PersistentCollection useUnownedCollection(CollectionKey key)
Get and remove a collection whose owner is not yet loaded, when its owner is being loaded

getBatchFetchQueue

public BatchFetchQueue getBatchFetchQueue()
Get the BatchFetchQueue, instantiating one if necessary.

clear

public void clear()
Clear the state of the persistence context

hasNonReadOnlyEntities

public boolean hasNonReadOnlyEntities()
Returns:
false if we know for certain that all the entities are read-only

setEntryStatus

public void setEntryStatus(EntityEntry entry,
                           Status status)
Set the status of an entry

afterTransactionCompletion

public void afterTransactionCompletion()
Called after transactions end

getDatabaseSnapshot

public Object[] getDatabaseSnapshot(Serializable id,
                                    EntityPersister persister)
                             throws HibernateException
Get the current state of the entity as known to the underlying database, or null if there is no corresponding row

Throws:
HibernateException

getCachedDatabaseSnapshot

public Object[] getCachedDatabaseSnapshot(EntityKey key)

getNaturalIdSnapshot

public Object[] getNaturalIdSnapshot(Serializable id,
                                     EntityPersister persister)
                              throws HibernateException
Throws:
HibernateException

addEntity

public void addEntity(EntityKey key,
                      Object entity)
Add a canonical mapping from entity key to entity instance

getEntity

public Object getEntity(EntityKey key)
Get the entity instance associated with the given EntityKey

containsEntity

public boolean containsEntity(EntityKey key)
Is there an entity with the given key in the persistence context

removeEntity

public Object removeEntity(EntityKey key)
Remove an entity from the session cache, also clear up other state associated with the entity, all except for the EntityEntry

getEntity

public Object getEntity(EntityUniqueKey euk)
Get an entity cached by unique key

addEntity

public void addEntity(EntityUniqueKey euk,
                      Object entity)
Add an entity to the cache by unique key

getEntry

public EntityEntry getEntry(Object entity)
Retreive the EntityEntry representation of the given entity.

Parameters:
entity - The entity for which to locate the EntityEntry.
Returns:
The EntityEntry for the given entity.

removeEntry

public EntityEntry removeEntry(Object entity)
Remove an entity entry from the session cache

isEntryFor

public boolean isEntryFor(Object entity)
Is there an EntityEntry for this instance?

getCollectionEntry

public CollectionEntry getCollectionEntry(PersistentCollection coll)
Get the collection entry for a persistent collection

addEntity

public EntityEntry addEntity(Object entity,
                             Status status,
                             Object[] loadedState,
                             EntityKey entityKey,
                             Object version,
                             LockMode lockMode,
                             boolean existsInDatabase,
                             EntityPersister persister,
                             boolean disableVersionIncrement,
                             boolean lazyPropertiesAreUnfetched)
Adds an entity to the internal caches.

addEntry

public EntityEntry addEntry(Object entity,
                            Status status,
                            Object[] loadedState,
                            Object rowId,
                            Serializable id,
                            Object version,
                            LockMode lockMode,
                            boolean existsInDatabase,
                            EntityPersister persister,
                            boolean disableVersionIncrement,
                            boolean lazyPropertiesAreUnfetched)
Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.

containsCollection

public boolean containsCollection(PersistentCollection collection)
Is the given collection associated with this persistence context?

containsProxy

public boolean containsProxy(Object proxy)
Is the given proxy associated with this persistence context?

reassociateIfUninitializedProxy

public boolean reassociateIfUninitializedProxy(Object value)
                                        throws MappingException
Takes the given object and, if it represents a proxy, reassociates it with this event source.

Parameters:
value - The possible proxy to be reassociated.
Returns:
Whether the passed value represented an actual proxy which got initialized.
Throws:
MappingException

reassociateProxy

public void reassociateProxy(Object value,
                             Serializable id)
                      throws MappingException
If a deleted entity instance is re-saved, and it has a proxy, we need to reset the identifier of the proxy

Throws:
MappingException

unproxy

public Object unproxy(Object maybeProxy)
               throws HibernateException
Get the entity instance underlying the given proxy, throwing an exception if the proxy is uninitialized. If the given object is not a proxy, simply return the argument.

Throws:
HibernateException

unproxyAndReassociate

public Object unproxyAndReassociate(Object maybeProxy)
                             throws HibernateException
Possibly unproxy the given reference and reassociate it with the current session.

Parameters:
maybeProxy - The reference to be unproxied if it currently represents a proxy.
Returns:
The unproxied instance.
Throws:
HibernateException

checkUniqueness

public void checkUniqueness(EntityKey key,
                            Object object)
                     throws HibernateException
Attempts to check whether the given key represents an entity already loaded within the current session.

Parameters:
object - The entity reference against which to perform the uniqueness check.
Throws:
HibernateException

narrowProxy

public Object narrowProxy(Object proxy,
                          EntityPersister persister,
                          EntityKey key,
                          Object object)
                   throws HibernateException
If the existing proxy is insufficiently "narrow" (derived), instantiate a new proxy and overwrite the registration of the old one. This breaks == and occurs only for "class" proxies rather than "interface" proxies. Also init the proxy to point to the given target implementation if necessary.

Parameters:
proxy - The proxy instance to be narrowed.
persister - The persister for the proxied entity.
key - The internal cache key for the proxied entity.
object - (optional) the actual proxied entity instance.
Returns:
An appropriately narrowed instance.
Throws:
HibernateException

proxyFor

public Object proxyFor(EntityPersister persister,
                       EntityKey key,
                       Object impl)
                throws HibernateException
Return the existing proxy associated with the given EntityKey, or the third argument (the entity associated with the key) if no proxy exists. Init the proxy to the target implementation, if necessary.

Throws:
HibernateException

proxyFor

public Object proxyFor(Object impl)
                throws HibernateException
Return the existing proxy associated with the given EntityKey, or the argument (the entity associated with the key) if no proxy exists. (slower than the form above)

Throws:
HibernateException

getCollectionOwner

public Object getCollectionOwner(Serializable key,
                                 CollectionPersister collectionPersister)
                          throws MappingException
Get the entity that owns this persistent collection

Throws:
MappingException

addUninitializedCollection

public void addUninitializedCollection(CollectionPersister persister,
                                       PersistentCollection collection,
                                       Serializable id)
add a collection we just loaded up (still needs initializing)

addUninitializedDetachedCollection

public void addUninitializedDetachedCollection(CollectionPersister persister,
                                               PersistentCollection collection)
add a detached uninitialized collection

addNewCollection

public void addNewCollection(CollectionPersister persister,
                             PersistentCollection collection)
                      throws HibernateException
Add a new collection (ie. a newly created one, just instantiated by the application, with no database state or snapshot)

Parameters:
collection - The collection to be associated with the persistence context
Throws:
HibernateException

addInitializedDetachedCollection

public void addInitializedDetachedCollection(CollectionPersister collectionPersister,
                                             PersistentCollection collection)
                                      throws HibernateException
add an (initialized) collection that was created by another session and passed into update() (ie. one with a snapshot and existing state on the database)

Throws:
HibernateException

addInitializedCollection

public CollectionEntry addInitializedCollection(CollectionPersister persister,
                                                PersistentCollection collection,
                                                Serializable id)
                                         throws HibernateException
add a collection we just pulled out of the cache (does not need initializing)

Throws:
HibernateException

getCollection

public PersistentCollection getCollection(CollectionKey collectionKey)
Get the collection instance associated with the CollectionKey

addNonLazyCollection

public void addNonLazyCollection(PersistentCollection collection)
Register a collection for non-lazy loading at the end of the two-phase load

initializeNonLazyCollections

public void initializeNonLazyCollections()
                                  throws HibernateException
Force initialization of all non-lazy collections encountered during the current two-phase load (actually, this is a no-op, unless this is the "outermost" load)

Throws:
HibernateException

getCollectionHolder

public PersistentCollection getCollectionHolder(Object array)
Get the PersistentCollection object for an array

addCollectionHolder

public void addCollectionHolder(PersistentCollection holder)
Register a PersistentCollection object for an array. Associates a holder with an array - MUST be called after loading array, since the array instance is not created until endLoad().

removeCollectionHolder

public PersistentCollection removeCollectionHolder(Object array)
Remove the mapping of collection to holder during eviction of the owning entity

getSnapshot

public Serializable getSnapshot(PersistentCollection coll)
Get the snapshot of the pre-flush collection state

getCollectionEntryOrNull

public CollectionEntry getCollectionEntryOrNull(Object collection)
Get the collection entry for a collection passed to filter, which might be a collection wrapper, an array, or an unwrapped collection. Return null if there is no entry.

getProxy

public Object getProxy(EntityKey key)
Get an existing proxy by key

addProxy

public void addProxy(EntityKey key,
                     Object proxy)
Add a proxy to the session cache

removeProxy

public Object removeProxy(EntityKey key)
Remove a proxy from the session cache

getNullifiableEntityKeys

public HashSet getNullifiableEntityKeys()
Retrieve the set of EntityKeys representing nullifiable references

getEntitiesByKey

public Map getEntitiesByKey()
Get the mapping from key value to entity instance

getEntityEntries

public Map getEntityEntries()
Get the mapping from entity instance to entity entry

getCollectionEntries

public Map getCollectionEntries()
Get the mapping from collection instance to collection entry

getCollectionsByKey

public Map getCollectionsByKey()
Get the mapping from collection key to collection instance

getCascadeLevel

public int getCascadeLevel()
How deep are we cascaded?

incrementCascadeLevel

public int incrementCascadeLevel()
Called before cascading

decrementCascadeLevel

public int decrementCascadeLevel()
Called after cascading

isFlushing

public boolean isFlushing()
Is a flush cycle currently in process?

setFlushing

public void setFlushing(boolean flushing)
Called before and after the flushcycle

beforeLoad

public void beforeLoad()
Call this before begining a two-phase load

afterLoad

public void afterLoad()
Call this after finishing a two-phase load

toString

public String toString()
Returns a string representation of the object.

Returns:
a string representation of the object.

getOwnerId

public Serializable getOwnerId(String entity,
                               String property,
                               Object childObject,
                               Map mergeMap)
Search the persistence context for an owner for the child object, given a collection role

getIndexInOwner

public Object getIndexInOwner(String entity,
                              String property,
                              Object childObject,
                              Map mergeMap)
Search the persistence context for an index of the child object, given a collection role

addNullProperty

public void addNullProperty(EntityKey ownerKey,
                            String propertyName)
Record the fact that the association belonging to the keyed entity is null.

isPropertyNull

public boolean isPropertyNull(EntityKey ownerKey,
                              String propertyName)
Is the association property belonging to the keyed entity null?

setReadOnly

public void setReadOnly(Object entity,
                        boolean readOnly)
Set the object to read only and discard it's snapshot

replaceDelayedEntityIdentityInsertKeys

public void replaceDelayedEntityIdentityInsertKeys(EntityKey oldKey,
                                                   Serializable generatedId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SessionFactoryImplementor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Interface SessionFactoryImplementor

All Superinterfaces:
Mapping, Referenceable, Serializable, SessionFactory
All Known Implementing Classes:
SessionFactoryImpl
public interface SessionFactoryImplementor
extends Mapping, SessionFactory

Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Author:
Gavin King
See Also:
SessionFactory, SessionFactoryImpl

Method Summary
Map | getAllSecondLevelCacheRegions()
CollectionPersister | getCollectionPersister(String role) Get the persister object for a collection role
Set | getCollectionRolesByEntityParticipant(String entityName) Retrieves a set of all the collection roles in which the given entity is a participant, as either an index or an element.
ConnectionProvider | getConnectionProvider() Get the connection provider
Dialect | getDialect() Get the SQL Dialect
EntityNotFoundDelegate | getEntityNotFoundDelegate()
EntityPersister | getEntityPersister(String entityName) Get the persister for the named entity
IdentifierGenerator | getIdentifierGenerator(String rootEntityName) Get the identifier generator for the hierarchy
String[] | getImplementors(String className) Get the names of all persistent classes that implement/extend the given interface/class
String | getImportedClassName(String name) Get a class name, using query language imports
Interceptor | getInterceptor()
NamedQueryDefinition | getNamedQuery(String queryName)
NamedSQLQueryDefinition | getNamedSQLQuery(String queryName)
QueryCache | getQueryCache() Get the default query cache
QueryCache | getQueryCache(String regionName) Get a particular named query cache, or the default cache
QueryPlanCache | getQueryPlanCache()
ResultSetMappingDefinition | getResultSetMapping(String name)
String[] | getReturnAliases(String queryString) Get the return aliases of a query
Type[] | getReturnTypes(String queryString) Get the return types of a query
Cache | getSecondLevelCacheRegion(String regionName) Get a named second-level cache region
Settings | getSettings()
SQLExceptionConverter | getSQLExceptionConverter() Retrieves the SQLExceptionConverter in effect for this SessionFactory.
SQLFunctionRegistry | getSqlFunctionRegistry()
StatisticsImplementor | getStatisticsImplementor() Statistics SPI
TransactionManager | getTransactionManager() Get the JTA transaction manager
UpdateTimestampsCache | getUpdateTimestampsCache() Get the cache of table update timestamps
Session | openSession(Connection connection, boolean flushBeforeCompletionEnabled, boolean autoCloseSessionEnabled, ConnectionReleaseMode connectionReleaseMode) Open a session conforming to the given parameters.
Session | openTemporarySession() Get a nontransactional "current" session for Hibernate EntityManager
Methods inherited from interface org.hibernate.engine.Mapping
getIdentifierPropertyName, getIdentifierType, getReferencedPropertyType
Methods inherited from interface org.hibernate.SessionFactory
close, evict, evict, evictCollection, evictCollection, evictEntity, evictEntity, evictQueries, evictQueries, getAllClassMetadata, getAllCollectionMetadata, getClassMetadata, getClassMetadata, getCollectionMetadata, getCurrentSession, getDefinedFilterNames, getFilterDefinition, getStatistics, isClosed, openSession, openSession, openSession, openSession, openStatelessSession, openStatelessSession
Methods inherited from interface javax.naming.Referenceable
getReference

Method Detail

getEntityPersister

public EntityPersister getEntityPersister(String entityName)
                                   throws MappingException
Get the persister for the named entity

Throws:
MappingException

getCollectionPersister

public CollectionPersister getCollectionPersister(String role)
                                           throws MappingException
Get the persister object for a collection role

Throws:
MappingException

getDialect

public Dialect getDialect()
Get the SQL Dialect

getInterceptor

public Interceptor getInterceptor()

getQueryPlanCache

public QueryPlanCache getQueryPlanCache()

getReturnTypes

public Type[] getReturnTypes(String queryString)
                      throws HibernateException
Get the return types of a query

Throws:
HibernateException

getReturnAliases

public String[] getReturnAliases(String queryString)
                          throws HibernateException
Get the return aliases of a query

Throws:
HibernateException

getConnectionProvider

public ConnectionProvider getConnectionProvider()
Get the connection provider

getImplementors

public String[] getImplementors(String className)
                         throws MappingException
Get the names of all persistent classes that implement/extend the given interface/class

Throws:
MappingException

getImportedClassName

public String getImportedClassName(String name)
Get a class name, using query language imports

getTransactionManager

public TransactionManager getTransactionManager()
Get the JTA transaction manager

getQueryCache

public QueryCache getQueryCache()
Get the default query cache

getQueryCache

public QueryCache getQueryCache(String regionName)
                         throws HibernateException
Get a particular named query cache, or the default cache

Parameters:
regionName - the name of the cache region, or null for the default query cache
Returns:
the existing cache, or a newly created cache if none by that region name
Throws:
HibernateException

getUpdateTimestampsCache

public UpdateTimestampsCache getUpdateTimestampsCache()
Get the cache of table update timestamps

getStatisticsImplementor

public StatisticsImplementor getStatisticsImplementor()
Statistics SPI

getNamedQuery

public NamedQueryDefinition getNamedQuery(String queryName)

getNamedSQLQuery

public NamedSQLQueryDefinition getNamedSQLQuery(String queryName)

getResultSetMapping

public ResultSetMappingDefinition getResultSetMapping(String name)

getIdentifierGenerator

public IdentifierGenerator getIdentifierGenerator(String rootEntityName)
Get the identifier generator for the hierarchy

getSecondLevelCacheRegion

public Cache getSecondLevelCacheRegion(String regionName)
Get a named second-level cache region

getAllSecondLevelCacheRegions

public Map getAllSecondLevelCacheRegions()

getSQLExceptionConverter

public SQLExceptionConverter getSQLExceptionConverter()
Retrieves the SQLExceptionConverter in effect for this SessionFactory.

Returns:
The SQLExceptionConverter for this SessionFactory.

getSettings

public Settings getSettings()

openTemporarySession

public Session openTemporarySession()
                             throws HibernateException
Get a nontransactional "current" session for Hibernate EntityManager

Throws:
HibernateException

openSession

public Session openSession(Connection connection,
                           boolean flushBeforeCompletionEnabled,
                           boolean autoCloseSessionEnabled,
                           ConnectionReleaseMode connectionReleaseMode)
                    throws HibernateException
Open a session conforming to the given parameters. Used mainly by JTASessionContext for current session processing.

Parameters:
connection - The external jdbc connection to use, if one (i.e., optional).
flushBeforeCompletionEnabled - Should the session be auto-flushed prior to transaction completion?
autoCloseSessionEnabled - Should the session be auto-closed after transaction completion?
connectionReleaseMode - The release mode for managed jdbc connections.
Returns:
An appropriate session.
Throws:
HibernateException

getCollectionRolesByEntityParticipant

public Set getCollectionRolesByEntityParticipant(String entityName)
Retrieves a set of all the collection roles in which the given entity is a participant, as either an index or an element.

Parameters:
entityName - The entity name for which to get the collection roles.
Returns:
set of all the collection roles in which the given entityName participates.

getEntityNotFoundDelegate

public EntityNotFoundDelegate getEntityNotFoundDelegate()

getSqlFunctionRegistry

public SQLFunctionRegistry getSqlFunctionRegistry()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SessionImplementor (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Interface SessionImplementor

All Superinterfaces:
Serializable
All Known Subinterfaces:
EventSource
All Known Implementing Classes:
AbstractSessionImpl, SessionImpl
public interface SessionImplementor
extends Serializable

Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.

Author:
Gavin King
See Also:
the interface to the application, the actual implementation

Method Summary
 void afterScrollOperation()
 void afterTransactionCompletion(boolean successful, Transaction tx)
Notify the session that the transaction completed, so we no longer own the old locks.
 void beforeTransactionCompletion(Transaction tx)
Notify the session that the transaction is about to complete
 String bestGuessEntityName(Object object)
The best guess entity name for an entity not in an association
 Connection connection()
 int executeNativeUpdate(NativeSQLQuerySpecification specification, QueryParameters queryParameters)
Execute a native SQL update or delete query
 int executeUpdate(String query, QueryParameters queryParameters)
Execute a HQL update or delete query
 void flush()
 Batcher getBatcher()
Get the prepared statement Batcher for this session
 CacheMode getCacheMode()
 Serializable getContextEntityIdentifier(Object object)
Return the identifier of the persistent object, or null if not associated with the session
 int getDontFlushFromFind()
 Map getEnabledFilters()
Return the currently enabled filters.
 EntityMode getEntityMode()
 EntityPersister getEntityPersister(String entityName, Object object)
Get the EntityPersister for any instance
 Object getEntityUsingInterceptor(EntityKey key)
Get the entity instance associated with the given Key, calling the Interceptor if necessary
 SessionFactoryImplementor getFactory()
Get the creating SessionFactoryImplementor
 String getFetchProfile()
 Type getFilterParameterType(String filterParameterName)
Retreive the type for a given filter parrameter.
 Object getFilterParameterValue(String filterParameterName)
Retreive the currently set value for a filter parameter.
 FlushMode getFlushMode()
 Interceptor getInterceptor()
Retrieves the interceptor currently in use by this event source.
 JDBCContext getJDBCContext()
 EventListeners getListeners()
Retrieves the configured event listeners from this event source.
 Query getNamedQuery(String name)
Get a Query instance for a named query or named native SQL query
 Query getNamedSQLQuery(String name)
Get a Query instance for a named native SQL query
 PersistenceContext getPersistenceContext()
Get the persistence context for this session
 long getTimestamp()
System time before the start of the transaction
 String guessEntityName(Object entity)
The guessed entity name for an entity not in an association
 Object immediateLoad(String entityName, Serializable id)
Load an instance immediately.
 void initializeCollection(PersistentCollection collection, boolean writing)
Initialize the collection (if not already initialized)
 Object instantiate(String entityName, Serializable id)
Instantiate the entity class, initializing with the given identifier
 Object internalLoad(String entityName, Serializable id, boolean eager, boolean nullable)
Load an instance without checking if it was deleted.
 boolean isClosed()
Determine whether the session is closed.
 boolean isConnected()
 boolean isEventSource()
 boolean isOpen()
 boolean isTransactionInProgress()
Does this Session have an active Hibernate transaction or is there a JTA transaction in progress?
 Iterator iterate(String query, QueryParameters queryParameters)
Execute an iterate() query
 Iterator iterateFilter(Object collection, String filter, QueryParameters queryParameters)
Iterate a filter
 List list(CriteriaImpl criteria)
Execute a criteria query
 List list(NativeSQLQuerySpecification spec, QueryParameters queryParameters)
Execute a native SQL query, and return the results as a fully built list.
 List list(String query, QueryParameters queryParameters)
Execute a find() query
 List listCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
Execute an SQL Query
 List listFilter(Object collection, String filter, QueryParameters queryParameters)
Execute a filter
 ScrollableResults scroll(CriteriaImpl criteria, ScrollMode scrollMode)
Execute a criteria query
 ScrollableResults scroll(NativeSQLQuerySpecification spec, QueryParameters queryParameters)
Execute a native SQL query, and return the results as a scrollable result.
 ScrollableResults scroll(String query, QueryParameters queryParameters)
Execute a scroll() query
 ScrollableResults scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
Execute an SQL Query
 void setAutoClear(boolean enabled)
Enable/disable automatic cache clearing from after transaction completion (for EJB3)
 void setCacheMode(CacheMode cm)
 void setFetchProfile(String name)
 void setFlushMode(FlushMode fm)

Method Detail

getInterceptor

public Interceptor getInterceptor()
Retrieves the interceptor currently in use by this event source.

Returns:
The interceptor.

setAutoClear

public void setAutoClear(boolean enabled)
Enable/disable automatic cache clearing from after transaction completion (for EJB3)

isTransactionInProgress

public boolean isTransactionInProgress()
Does this Session have an active Hibernate transaction or is there a JTA transaction in progress?

initializeCollection

public void initializeCollection(PersistentCollection collection,
                                 boolean writing)
                          throws HibernateException
Initialize the collection (if not already initialized)

Throws:
HibernateException

internalLoad

public Object internalLoad(String entityName,
                           Serializable id,
                           boolean eager,
                           boolean nullable)
                    throws HibernateException
Load an instance without checking if it was deleted. When nullable is disabled this method may create a new proxy or return an existing proxy; if it does not exist, throw an exception. When nullable is enabled, the method does not create new proxies (but might return an existing proxy); if it does not exist, return null. When eager is enabled, the object is eagerly fetched

Throws:
HibernateException

immediateLoad

public Object immediateLoad(String entityName,
                            Serializable id)
                     throws HibernateException
Load an instance immediately. This method is only called when lazily initializing a proxy. Do not return the proxy.

Throws:
HibernateException

getTimestamp

public long getTimestamp()
System time before the start of the transaction

getFactory

public SessionFactoryImplementor getFactory()
Get the creating SessionFactoryImplementor

getBatcher

public Batcher getBatcher()
Get the prepared statement Batcher for this session

list

public List list(String query,
                 QueryParameters queryParameters)
          throws HibernateException
Execute a find() query

Throws:
HibernateException

iterate

public Iterator iterate(String query,
                        QueryParameters queryParameters)
                 throws HibernateException
Execute an iterate() query

Throws:
HibernateException

scroll

public ScrollableResults scroll(String query,
                                QueryParameters queryParameters)
                         throws HibernateException
Execute a scroll() query

Throws:
HibernateException

scroll

public ScrollableResults scroll(CriteriaImpl criteria,
                                ScrollMode scrollMode)
Execute a criteria query

list

public List list(CriteriaImpl criteria)
Execute a criteria query

listFilter

public List listFilter(Object collection,
                       String filter,
                       QueryParameters queryParameters)
                throws HibernateException
Execute a filter

Throws:
HibernateException

iterateFilter

public Iterator iterateFilter(Object collection,
                              String filter,
                              QueryParameters queryParameters)
                       throws HibernateException
Iterate a filter

Throws:
HibernateException

getEntityPersister

public EntityPersister getEntityPersister(String entityName,
                                          Object object)
                                   throws HibernateException
Get the EntityPersister for any instance

Parameters:
entityName - optional entity name
object - the entity instance
Throws:
HibernateException

getEntityUsingInterceptor

public Object getEntityUsingInterceptor(EntityKey key)
                                 throws HibernateException
Get the entity instance associated with the given Key, calling the Interceptor if necessary

Throws:
HibernateException

afterTransactionCompletion

public void afterTransactionCompletion(boolean successful,
                                       Transaction tx)
Notify the session that the transaction completed, so we no longer own the old locks. (Also we should release cache softlocks.) May be called multiple times during the transaction completion process. Also called after an autocommit, in which case the second argument is null.

beforeTransactionCompletion

public void beforeTransactionCompletion(Transaction tx)
Notify the session that the transaction is about to complete

getContextEntityIdentifier

public Serializable getContextEntityIdentifier(Object object)
Return the identifier of the persistent object, or null if not associated with the session

bestGuessEntityName

public String bestGuessEntityName(Object object)
The best guess entity name for an entity not in an association

guessEntityName

public String guessEntityName(Object entity)
                       throws HibernateException
The guessed entity name for an entity not in an association

Throws:
HibernateException

instantiate

public Object instantiate(String entityName,
                          Serializable id)
                   throws HibernateException
Instantiate the entity class, initializing with the given identifier

Throws:
HibernateException

listCustomQuery

public List listCustomQuery(CustomQuery customQuery,
                            QueryParameters queryParameters)
                     throws HibernateException
Execute an SQL Query

Throws:
HibernateException

scrollCustomQuery

public ScrollableResults scrollCustomQuery(CustomQuery customQuery,
                                           QueryParameters queryParameters)
                                    throws HibernateException
Execute an SQL Query

Throws:
HibernateException

list

public List list(NativeSQLQuerySpecification spec,
                 QueryParameters queryParameters)
          throws HibernateException
Execute a native SQL query, and return the results as a fully built list.

Parameters:
spec - The specification of the native SQL query to execute.
queryParameters - The parameters by which to perform the execution.
Returns:
The result list.
Throws:
HibernateException

scroll

public ScrollableResults scroll(NativeSQLQuerySpecification spec,
                                QueryParameters queryParameters)
                         throws HibernateException
Execute a native SQL query, and return the results as a scrollable result.

Parameters:
spec - The specification of the native SQL query to execute.
queryParameters - The parameters by which to perform the execution.
Returns:
The resulting scrollable result.
Throws:
HibernateException

getFilterParameterValue

public Object getFilterParameterValue(String filterParameterName)
Retreive the currently set value for a filter parameter.

Parameters:
filterParameterName - The filter parameter name in the format {FILTER_NAME.PARAMETER_NAME}.
Returns:
The filter parameter value.

getFilterParameterType

public Type getFilterParameterType(String filterParameterName)
Retreive the type for a given filter parrameter.

Parameters:
filterParameterName - The filter parameter name in the format {FILTER_NAME.PARAMETER_NAME}.

getEnabledFilters

public Map getEnabledFilters()
Return the currently enabled filters. The filter map is keyed by filter name, with values corresponding to the FilterImpl instance.

Returns:
The currently enabled filters.

getDontFlushFromFind

public int getDontFlushFromFind()

getListeners

public EventListeners getListeners()
Retrieves the configured event listeners from this event source.

Returns:
The configured event listeners.

getPersistenceContext

public PersistenceContext getPersistenceContext()
Get the persistence context for this session

executeUpdate

public int executeUpdate(String query,
                         QueryParameters queryParameters)
                  throws HibernateException
Execute a HQL update or delete query

Throws:
HibernateException

executeNativeUpdate

public int executeNativeUpdate(NativeSQLQuerySpecification specification,
                               QueryParameters queryParameters)
                        throws HibernateException
Execute a native SQL update or delete query

Throws:
HibernateException

getEntityMode

public EntityMode getEntityMode()

getCacheMode

public CacheMode getCacheMode()

setCacheMode

public void setCacheMode(CacheMode cm)

isOpen

public boolean isOpen()

isConnected

public boolean isConnected()

getFlushMode

public FlushMode getFlushMode()

setFlushMode

public void setFlushMode(FlushMode fm)

connection

public Connection connection()

flush

public void flush()

getNamedQuery

public Query getNamedQuery(String name)
Get a Query instance for a named query or named native SQL query

getNamedSQLQuery

public Query getNamedSQLQuery(String name)
Get a Query instance for a named native SQL query

isEventSource

public boolean isEventSource()

afterScrollOperation

public void afterScrollOperation()

setFetchProfile

public void setFetchProfile(String name)

getFetchProfile

public String getFetchProfile()

getJDBCContext

public JDBCContext getJDBCContext()

isClosed

public boolean isClosed()
Determine whether the session is closed. Provided seperately from isOpen() as this method does not attempt any JTA synch registration, where as isOpen() does; which makes this one nicer to use for most internal purposes.

Returns:
True if the session is closed; false otherwise.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActionQueue (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class ActionQueue

java.lang.Object
    extended by org.hibernate.engine.ActionQueue
public class ActionQueue
extends Object

Responsible for maintaining the queue of actions related to events.

The ActionQueue holds the DML operations queued as part of a session's transactional-write-behind semantics. DML operations are queued here until a flush forces them to be executed against the database.

Author:
Steve Ebersole

Constructor Summary
ActionQueue(SessionImplementor session)
Constructs an action queue bound to the given session.
Method Summary
void | addAction(BulkOperationCleanupAction cleanupAction)
void | addAction(CollectionRecreateAction action)
void | addAction(CollectionRemoveAction action)
void | addAction(CollectionUpdateAction action)
void | addAction(EntityDeleteAction action)
void | addAction(EntityIdentityInsertAction insert)
void | addAction(EntityInsertAction action)
void | addAction(EntityUpdateAction action)
void | afterTransactionCompletion(boolean success) Performs cleanup of any held cache softlocks.
boolean | areInsertionsOrDeletionsQueued() Check whether any insertion or deletion actions are currently queued.
boolean | areTablesToBeUpdated(Set tables) Check whether the given tables/query-spaces are to be executed against given the currently queued actions.
void | clear()
void | clearFromFlushNeededCheck(int previousCollectionRemovalSize)
ArrayList | cloneDeletions()
static ActionQueue | deserialize(ObjectInputStream ois, SessionImplementor session) Used by the owning session to explicitly control deserialization of the action queue
void | execute(Executable executable)
void | executeActions() Perform all currently queued actions.
void | executeInserts() Perform all currently queued entity-insertion actions.
boolean | hasAnyQueuedActions()
int | numberOfCollectionCreations()
int | numberOfCollectionRemovals()
int | numberOfCollectionUpdates()
int | numberOfDeletions()
int | numberOfInsertions()
int | numberOfUpdates()
void | prepareActions() Prepares the internal action queues for execution.
void | serialize(ObjectOutputStream oos) Used by the owning session to explicitly control serialization of the action queue
void | sortCollectionActions()
void | sortUpdateActions()
String | toString() Returns a string representation of the object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ActionQueue

public ActionQueue(SessionImplementor session)
Constructs an action queue bound to the given session.

Parameters:
session - The session "owning" this queue.
Method Detail

clear

public void clear()

addAction

public void addAction(EntityInsertAction action)

addAction

public void addAction(EntityDeleteAction action)

addAction

public void addAction(EntityUpdateAction action)

addAction

public void addAction(CollectionRecreateAction action)

addAction

public void addAction(CollectionRemoveAction action)

addAction

public void addAction(CollectionUpdateAction action)

addAction

public void addAction(EntityIdentityInsertAction insert)

addAction

public void addAction(BulkOperationCleanupAction cleanupAction)

executeInserts

public void executeInserts()
                    throws HibernateException
Perform all currently queued entity-insertion actions.

Throws:
HibernateException - error executing queued insertion actions.

executeActions

public void executeActions()
                    throws HibernateException
Perform all currently queued actions.

Throws:
HibernateException - error executing queued actions.

prepareActions

public void prepareActions()
                    throws HibernateException
Prepares the internal action queues for execution.

Throws:
HibernateException - error preparing actions.

afterTransactionCompletion

public void afterTransactionCompletion(boolean success)
Performs cleanup of any held cache softlocks.

Parameters:
success - Was the transaction successful.

areTablesToBeUpdated

public boolean areTablesToBeUpdated(Set tables)
Check whether the given tables/query-spaces are to be executed against given the currently queued actions.

Parameters:
tables - The table/query-spaces to check.
Returns:
True if we contain pending actions against any of the given tables; false otherwise.

areInsertionsOrDeletionsQueued

public boolean areInsertionsOrDeletionsQueued()
Check whether any insertion or deletion actions are currently queued.

Returns:
True if insertions or deletions are currently queued; false otherwise.

execute

public void execute(Executable executable)

toString

public String toString()
Returns a string representation of the object.

Returns:
a string representation of the object.

numberOfCollectionRemovals

public int numberOfCollectionRemovals()

numberOfCollectionUpdates

public int numberOfCollectionUpdates()

numberOfCollectionCreations

public int numberOfCollectionCreations()

numberOfDeletions

public int numberOfDeletions()

numberOfUpdates

public int numberOfUpdates()

numberOfInsertions

public int numberOfInsertions()

sortCollectionActions

public void sortCollectionActions()

sortUpdateActions

public void sortUpdateActions()

cloneDeletions

public ArrayList cloneDeletions()

clearFromFlushNeededCheck

public void clearFromFlushNeededCheck(int previousCollectionRemovalSize)

hasAnyQueuedActions

public boolean hasAnyQueuedActions()

serialize

public void serialize(ObjectOutputStream oos)
               throws IOException
Used by the owning session to explicitly control serialization of the action queue

Parameters:
oos - The stream to which the action queue should get written
Throws:
IOException

deserialize

public static ActionQueue deserialize(ObjectInputStream ois,
                                      SessionImplementor session)
                               throws IOException,
                                      ClassNotFoundException
Used by the owning session to explicitly control deserialization of the action queue

Parameters:
ois - The stream from which to read the action queue
Throws:
IOException
ClassNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BatchFetchQueue (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class BatchFetchQueue

java.lang.Object
    extended by org.hibernate.engine.BatchFetchQueue
public class BatchFetchQueue
extends Object

Tracks entity and collection keys that are available for batch fetching, and the queries which were used to load entities, which can be re-used as a subquery for loading owned collections.

Author:
Gavin King

Field Summary
static Object MARKER
Constructor Summary
BatchFetchQueue(PersistenceContext context)
Constructs a queue for the given context.
Method Summary
void | addBatchLoadableEntityKey(EntityKey key) If an EntityKey represents a batch loadable entity, add it to the queue.
void | addSubselect(EntityKey key, SubselectFetch subquery) Adds a subselect fetch decriptor for the given entity key.
void | clear() Clears all entries from this fetch queue.
void | clearSubselects() Clears all pending subselect fetches from the queue.
Serializable[] | getCollectionBatch(CollectionPersister collectionPersister, Serializable id, int batchSize, EntityMode entityMode) Get a batch of uninitialized collection keys for a given role
Serializable[] | getEntityBatch(EntityPersister persister, Serializable id, int batchSize, EntityMode entityMode) Get a batch of unloaded identifiers for this class, using a slightly complex algorithm that tries to grab keys registered immediately after the given key.
SubselectFetch | getSubselect(EntityKey key) Retrieve the fetch descriptor associated with the given entity key.
void | removeBatchLoadableEntityKey(EntityKey key) After evicting or deleting or loading an entity, we don't need to batch fetch it anymore, remove it from the queue if necessary
void | removeSubselect(EntityKey key) After evicting or deleting an entity, we don't need to know the query that was used to load it anymore (don't call this after loading the entity, since we might still need to load its collections)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MARKER

public static final Object MARKER
Constructor Detail

BatchFetchQueue

public BatchFetchQueue(PersistenceContext context)
Constructs a queue for the given context.

Parameters:
context - The owning context.
Method Detail

clear

public void clear()
Clears all entries from this fetch queue.

getSubselect

public SubselectFetch getSubselect(EntityKey key)
Retrieve the fetch descriptor associated with the given entity key.

Parameters:
key - The entity key for which to locate any defined subselect fetch.
Returns:
The fetch descriptor; may return null if no subselect fetch queued for this entity key.

addSubselect

public void addSubselect(EntityKey key,
                         SubselectFetch subquery)
Adds a subselect fetch decriptor for the given entity key.

Parameters:
key - The entity for which to register the subselect fetch.
subquery - The fetch descriptor.

removeSubselect

public void removeSubselect(EntityKey key)
After evicting or deleting an entity, we don't need to know the query that was used to load it anymore (don't call this after loading the entity, since we might still need to load its collections)

clearSubselects

public void clearSubselects()
Clears all pending subselect fetches from the queue.

Called after flushing.

addBatchLoadableEntityKey

public void addBatchLoadableEntityKey(EntityKey key)
If an EntityKey represents a batch loadable entity, add it to the queue.

Note that the contract here is such that any key passed in should previously have been been checked for existence within the PersistenceContext; failure to do so may cause the referenced entity to be included in a batch even though it is already associated with the PersistenceContext.

removeBatchLoadableEntityKey

public void removeBatchLoadableEntityKey(EntityKey key)
After evicting or deleting or loading an entity, we don't need to batch fetch it anymore, remove it from the queue if necessary

getCollectionBatch

public Serializable[] getCollectionBatch(CollectionPersister collectionPersister,
                                         Serializable id,
                                         int batchSize,
                                         EntityMode entityMode)
Get a batch of uninitialized collection keys for a given role

Parameters:
collectionPersister - The persister for the collection role.
id - A key that must be included in the batch fetch
batchSize - the maximum number of keys to return
Returns:
an array of collection keys, of length batchSize (padded with nulls)

getEntityBatch

public Serializable[] getEntityBatch(EntityPersister persister,
                                     Serializable id,
                                     int batchSize,
                                     EntityMode entityMode)
Get a batch of unloaded identifiers for this class, using a slightly complex algorithm that tries to grab keys registered immediately after the given key.

Parameters:
persister - The persister for the entities being loaded.
id - The identifier of the entity currently demanding load.
batchSize - The maximum number of keys to return
Returns:
an array of identifiers, of length batchSize (possibly padded with nulls)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Cascade (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class Cascade

java.lang.Object
    extended by org.hibernate.engine.Cascade
public final class Cascade
extends Object

Delegate responsible for, in conjunction with the various actions, implementing cascade processing.

Author:
Gavin King
See Also:
CascadingAction

Field Summary
static int | AFTER_EVICT A cascade point that occurs just after eviction of the parent entity from the session cache
static int | AFTER_INSERT_BEFORE_DELETE A cascade point that occurs just after the insertion of the parent entity and just before deletion
static int | AFTER_INSERT_BEFORE_DELETE_VIA_COLLECTION A cascade point that occurs just after the insertion of the parent entity and just before deletion, inside a collection
static int | AFTER_LOCK A cascade point that occurs just after refreshing a parent entity
static int | AFTER_UPDATE A cascade point that occurs just after update of the parent entity
static int | BEFORE_FLUSH A cascade point that occurs just before the session is flushed
static int | BEFORE_INSERT_AFTER_DELETE A cascade point that occurs just before the insertion of the parent entity and just after deletion
static int | BEFORE_MERGE A cascade point that occurs just before merging from a transient parent entity into the object in the session cache
static int | BEFORE_REFRESH A cascade point that occurs just after locking a transient parent entity into the session cache
Constructor Summary
Cascade(CascadingAction action, int cascadeTo, EventSource eventSource)
Method Summary
void | cascade(EntityPersister persister, Object parent) Cascade an action from the parent entity instance to all its children.
void | cascade(EntityPersister persister, Object parent, Object anything) Cascade an action from the parent entity instance to all its children.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

AFTER_INSERT_BEFORE_DELETE

public static final int AFTER_INSERT_BEFORE_DELETE
A cascade point that occurs just after the insertion of the parent entity and just before deletion

See Also:
Constant Field Values

BEFORE_INSERT_AFTER_DELETE

public static final int BEFORE_INSERT_AFTER_DELETE
A cascade point that occurs just before the insertion of the parent entity and just after deletion

See Also:
Constant Field Values

AFTER_INSERT_BEFORE_DELETE_VIA_COLLECTION

public static final int AFTER_INSERT_BEFORE_DELETE_VIA_COLLECTION
A cascade point that occurs just after the insertion of the parent entity and just before deletion, inside a collection

See Also:
Constant Field Values

AFTER_UPDATE

public static final int AFTER_UPDATE
A cascade point that occurs just after update of the parent entity

See Also:
Constant Field Values

BEFORE_FLUSH

public static final int BEFORE_FLUSH
A cascade point that occurs just before the session is flushed

See Also:
Constant Field Values

AFTER_EVICT

public static final int AFTER_EVICT
A cascade point that occurs just after eviction of the parent entity from the session cache

See Also:
Constant Field Values

BEFORE_REFRESH

public static final int BEFORE_REFRESH
A cascade point that occurs just after locking a transient parent entity into the session cache

See Also:
Constant Field Values

AFTER_LOCK

public static final int AFTER_LOCK
A cascade point that occurs just after refreshing a parent entity

See Also:
Constant Field Values

BEFORE_MERGE

public static final int BEFORE_MERGE
A cascade point that occurs just before merging from a transient parent entity into the object in the session cache

See Also:
Constant Field Values
Constructor Detail

Cascade

public Cascade(CascadingAction action,
               int cascadeTo,
               EventSource eventSource)
Method Detail

cascade

public void cascade(EntityPersister persister,
                    Object parent)
             throws HibernateException
Cascade an action from the parent entity instance to all its children.

Parameters:
persister - The parent's entity persister
parent - The parent reference.
Throws:
HibernateException

cascade

public void cascade(EntityPersister persister,
                    Object parent,
                    Object anything)
             throws HibernateException
Cascade an action from the parent entity instance to all its children. This form is typicaly called from within cascade actions.

Parameters:
persister - The parent's entity persister
parent - The parent reference.
anything - Anything ;) Typically some form of cascade-local cache which is specific to each CascadingAction type
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CascadeStyle (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class CascadeStyle

java.lang.Object
    extended by org.hibernate.engine.CascadeStyle
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
CascadeStyle.MultipleCascadeStyle
public abstract class CascadeStyle
extends Object
implements Serializable

A style of cascade that can be specified by the mapping for an association. The style is specified by the cascade attribute in the mapping file.

Author:
Gavin King
See Also:
Serialized Form

Nested Class Summary
static class CascadeStyle.MultipleCascadeStyle
Field Summary
static CascadeStyle | ALL save / delete / update / evict / lock / replicate / merge / persist
static CascadeStyle | ALL_DELETE_ORPHAN save / delete / update / evict / lock / replicate / merge / persist + delete orphans
static CascadeStyle | DELETE delete
static CascadeStyle | DELETE_ORPHAN delete + delete orphans
static CascadeStyle | EVICT evict
static CascadeStyle | LOCK lock
static CascadeStyle | MERGE merge
static CascadeStyle | NONE no cascades
static CascadeStyle | PERSIST create
static CascadeStyle | REFRESH refresh
static CascadeStyle | REPLICATE replicate
static CascadeStyle | UPDATE save / update
Method Summary
abstract boolean | doCascade(CascadingAction action) Should the given action be cascaded?
static CascadeStyle | getCascadeStyle(String cascade)
boolean | hasOrphanDelete() Do we need to delete orphaned collection elements?
boolean | reallyDoCascade(CascadingAction action) Should the given action really, really be cascaded?
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ALL_DELETE_ORPHAN

public static final CascadeStyle ALL_DELETE_ORPHAN
save / delete / update / evict / lock / replicate / merge / persist + delete orphans

ALL

public static final CascadeStyle ALL
save / delete / update / evict / lock / replicate / merge / persist

UPDATE

public static final CascadeStyle UPDATE
save / update

LOCK

public static final CascadeStyle LOCK
lock

REFRESH

public static final CascadeStyle REFRESH
refresh

EVICT

public static final CascadeStyle EVICT
evict

REPLICATE

public static final CascadeStyle REPLICATE
replicate

MERGE

public static final CascadeStyle MERGE
merge

PERSIST

public static final CascadeStyle PERSIST
create

DELETE

public static final CascadeStyle DELETE
delete

DELETE_ORPHAN

public static final CascadeStyle DELETE_ORPHAN
delete + delete orphans

NONE

public static final CascadeStyle NONE
no cascades

Method Detail

doCascade

public abstract boolean doCascade(CascadingAction action)
Should the given action be cascaded?

reallyDoCascade

public boolean reallyDoCascade(CascadingAction action)
Should the given action really, really be cascaded?

hasOrphanDelete

public boolean hasOrphanDelete()
Do we need to delete orphaned collection elements?

getCascadeStyle

public static CascadeStyle getCascadeStyle(String cascade)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CascadeStyle.MultipleCascadeStyle (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class CascadeStyle.MultipleCascadeStyle

java.lang.Object
    extended by org.hibernate.engine.CascadeStyle
        extended by org.hibernate.engine.CascadeStyle.MultipleCascadeStyle
All Implemented Interfaces:
Serializable
Enclosing class:
CascadeStyle
public static final class CascadeStyle.MultipleCascadeStyle
extends CascadeStyle

See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.engine.CascadeStyle
CascadeStyle.MultipleCascadeStyle
Field Summary
Fields inherited from class org.hibernate.engine.CascadeStyle
ALL, ALL_DELETE_ORPHAN, DELETE, DELETE_ORPHAN, EVICT, LOCK, MERGE, NONE, PERSIST, REFRESH, REPLICATE, UPDATE
Constructor Summary
CascadeStyle.MultipleCascadeStyle(CascadeStyle[] styles)
Method Summary
boolean | doCascade(CascadingAction action) Should the given action be cascaded?
boolean | hasOrphanDelete() Do we need to delete orphaned collection elements?
boolean | reallyDoCascade(CascadingAction action) Should the given action really, really be cascaded?
String | toString()
Methods inherited from class org.hibernate.engine.CascadeStyle
getCascadeStyle
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CascadeStyle.MultipleCascadeStyle

public CascadeStyle.MultipleCascadeStyle(CascadeStyle[] styles)
Method Detail

doCascade

public boolean doCascade(CascadingAction action)
Description copied from class: CascadeStyle
Should the given action be cascaded?

Specified by:
doCascade in class CascadeStyle

reallyDoCascade

public boolean reallyDoCascade(CascadingAction action)
Description copied from class: CascadeStyle
Should the given action really, really be cascaded?

Overrides:
reallyDoCascade in class CascadeStyle

hasOrphanDelete

public boolean hasOrphanDelete()
Description copied from class: CascadeStyle
Do we need to delete orphaned collection elements?

Overrides:
hasOrphanDelete in class CascadeStyle

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CascadingAction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class CascadingAction

java.lang.Object
    extended by org.hibernate.engine.CascadingAction
public abstract class CascadingAction
extends Object

A session action that may be cascaded from parent entity to its children

Author:
Gavin King

Field Summary
static CascadingAction | DELETE
static CascadingAction | EVICT
static CascadingAction | LOCK
static CascadingAction | MERGE
static CascadingAction | PERSIST
static CascadingAction | PERSIST_ON_FLUSH Execute persist during flush time
static CascadingAction | REFRESH
static CascadingAction | REPLICATE
static CascadingAction | SAVE_UPDATE
static CascadingAction | SAVE_UPDATE_COPY
Method Summary
abstract  void cascade(EventSource session, Object child, String entityName, Object anything, boolean isCascadeDeleteEnabled)
Cascade the action to the child object.
abstract  boolean deleteOrphans()
Does this action potentially extrapolate to orphan deletes?
abstract  Iterator getCascadableChildrenIterator(EventSource session, CollectionType collectionType, Object collection)
Given a collection, get an iterator of the children upon which the current cascading action should be visited.
static Iterator getLoadedElementsIterator(SessionImplementor session, CollectionType collectionType, Object collection)
Iterate just the elements of the collection that are already there.
 void noCascade(EventSource session, Object child, Object parent, EntityPersister persister, int propertyIndex)
Called (in the case of requiresNoCascadeChecking() returning true) to validate that no cascade on the given property is considered a valid semantic.
 boolean performOnLazyProperty()
Should this action be performed (or noCascade consulted) in the case of lazy properties.
 boolean requiresNoCascadeChecking()
Does the specified cascading action require verification of no cascade validity?
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DELETE

public static final CascadingAction DELETE
See Also:
Session.delete(Object)

LOCK

public static final CascadingAction LOCK
See Also:
Session.lock(Object, LockMode)

REFRESH

public static final CascadingAction REFRESH
See Also:
Session.refresh(Object)

EVICT

public static final CascadingAction EVICT
See Also:
Session.evict(Object)

SAVE_UPDATE

public static final CascadingAction SAVE_UPDATE
See Also:
Session.saveOrUpdate(Object)

MERGE

public static final CascadingAction MERGE
See Also:
Session.merge(Object)

SAVE_UPDATE_COPY

public static final CascadingAction SAVE_UPDATE_COPY
See Also:
Session.saveOrUpdateCopy(Object)

PERSIST

public static final CascadingAction PERSIST
See Also:
Session.persist(Object)

PERSIST_ON_FLUSH

public static final CascadingAction PERSIST_ON_FLUSH
Execute persist during flush time

See Also:
Session.persist(Object)

REPLICATE

public static final CascadingAction REPLICATE
See Also:
Session.replicate(Object, org.hibernate.ReplicationMode)
Method Detail

cascade

public abstract void cascade(EventSource session,
                             Object child,
                             String entityName,
                             Object anything,
                             boolean isCascadeDeleteEnabled)
                      throws HibernateException
Cascade the action to the child object.

Parameters:
session - The session within which the cascade is occuring.
child - The child to which cascading should be performed.
entityName - The child's entity name
anything - Anything ;) Typically some form of cascade-local cache which is specific to each CascadingAction type
isCascadeDeleteEnabled - Are cascading deletes enabled.
Throws:
HibernateException

getCascadableChildrenIterator

public abstract Iterator getCascadableChildrenIterator(EventSource session,
                                                       CollectionType collectionType,
                                                       Object collection)
Given a collection, get an iterator of the children upon which the current cascading action should be visited.

Parameters:
session - The session within which the cascade is occuring.
collectionType - The mapping type of the collection.
collection - The collection instance.
Returns:
The children iterator.

deleteOrphans

public abstract boolean deleteOrphans()
Does this action potentially extrapolate to orphan deletes?

Returns:
True if this action can lead to deletions of orphans.

requiresNoCascadeChecking

public boolean requiresNoCascadeChecking()
Does the specified cascading action require verification of no cascade validity?

Returns:
True if this action requires no-cascade verification; false otherwise.

noCascade

public void noCascade(EventSource session,
                      Object child,
                      Object parent,
                      EntityPersister persister,
                      int propertyIndex)
Called (in the case of requiresNoCascadeChecking() returning true) to validate that no cascade on the given property is considered a valid semantic.

Parameters:
session - The session witin which the cascade is occurring.
child - The property value
parent - The property value owner
persister - The entity persister for the owner
propertyIndex - The index of the property within the owner.

performOnLazyProperty

public boolean performOnLazyProperty()
Should this action be performed (or noCascade consulted) in the case of lazy properties.

getLoadedElementsIterator

public static Iterator getLoadedElementsIterator(SessionImplementor session,
                                                 CollectionType collectionType,
                                                 Object collection)
Iterate just the elements of the collection that are already there. Don't load any new elements from the database.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class CollectionEntry

java.lang.Object
    extended by org.hibernate.engine.CollectionEntry
All Implemented Interfaces:
Serializable
public final class CollectionEntry
extends Object
implements Serializable

We need an entry to tell us all about the current state of a collection with respect to its persistent state

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
CollectionEntry(CollectionPersister persister, PersistentCollection collection)
For newly wrapped collections, or dereferenced collection wrappers
CollectionEntry(CollectionPersister loadedPersister, Serializable loadedKey)
For uninitialized detached collections
CollectionEntry(PersistentCollection collection, CollectionPersister loadedPersister, Serializable loadedKey, boolean ignore)
For collections just loaded from the database
Method Summary
void | afterAction(PersistentCollection collection) Called after execution of an action
Serializable | getCurrentKey() This is only available late during the flush cycle
CollectionPersister | getCurrentPersister()
Serializable | getKey()
Serializable | getLoadedKey()
CollectionPersister | getLoadedPersister() This is only available late during the flush cycle
Collection | getOrphans(String entityName, PersistentCollection collection) Get the collection orphans (entities which were removed from the collection)
String | getRole()
Serializable | getSnapshot()
boolean | isDorecreate()
boolean | isDoremove()
boolean | isDoupdate()
boolean | isIgnore()
boolean | isProcessed()
boolean | isReached()
boolean | isSnapshotEmpty(PersistentCollection collection)
void | postFlush(PersistentCollection collection) Called after a successful flush
void | postInitialize(PersistentCollection collection)
void | preFlush(PersistentCollection collection)
void | setCurrentKey(Serializable currentKey)
void | setCurrentPersister(CollectionPersister currentPersister)
void | setDorecreate(boolean dorecreate)
void | setDoremove(boolean doremove)
void | setDoupdate(boolean doupdate)
void | setProcessed(boolean processed)
void | setReached(boolean reached)
void | setRole(String role)
String | toString()
boolean | wasDereferenced()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CollectionEntry

public CollectionEntry(CollectionPersister persister,
                       PersistentCollection collection)
For newly wrapped collections, or dereferenced collection wrappers

CollectionEntry

public CollectionEntry(PersistentCollection collection,
                       CollectionPersister loadedPersister,
                       Serializable loadedKey,
                       boolean ignore)
For collections just loaded from the database

CollectionEntry

public CollectionEntry(CollectionPersister loadedPersister,
                       Serializable loadedKey)
For uninitialized detached collections

Method Detail

preFlush

public void preFlush(PersistentCollection collection)
              throws HibernateException
Throws:
HibernateException

postInitialize

public void postInitialize(PersistentCollection collection)
                    throws HibernateException
Throws:
HibernateException

postFlush

public void postFlush(PersistentCollection collection)
               throws HibernateException
Called after a successful flush

Throws:
HibernateException

afterAction

public void afterAction(PersistentCollection collection)
Called after execution of an action

getKey

public Serializable getKey()

getRole

public String getRole()

getSnapshot

public Serializable getSnapshot()

wasDereferenced

public boolean wasDereferenced()

isReached

public boolean isReached()

setReached

public void setReached(boolean reached)

isProcessed

public boolean isProcessed()

setProcessed

public void setProcessed(boolean processed)

isDoupdate

public boolean isDoupdate()

setDoupdate

public void setDoupdate(boolean doupdate)

isDoremove

public boolean isDoremove()

setDoremove

public void setDoremove(boolean doremove)

isDorecreate

public boolean isDorecreate()

setDorecreate

public void setDorecreate(boolean dorecreate)

isIgnore

public boolean isIgnore()

getCurrentPersister

public CollectionPersister getCurrentPersister()

setCurrentPersister

public void setCurrentPersister(CollectionPersister currentPersister)

getCurrentKey

public Serializable getCurrentKey()
This is only available late during the flush cycle

setCurrentKey

public void setCurrentKey(Serializable currentKey)

getLoadedPersister

public CollectionPersister getLoadedPersister()
This is only available late during the flush cycle

getLoadedKey

public Serializable getLoadedKey()

setRole

public void setRole(String role)

toString

public String toString()

getOrphans

public Collection getOrphans(String entityName,
                             PersistentCollection collection)
                      throws HibernateException
Get the collection orphans (entities which were removed from the collection)

Throws:
HibernateException

isSnapshotEmpty

public boolean isSnapshotEmpty(PersistentCollection collection)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionKey (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class CollectionKey

java.lang.Object
    extended by org.hibernate.engine.CollectionKey
All Implemented Interfaces:
Serializable
public final class CollectionKey
extends Object
implements Serializable

Uniquely identifies a collection instance in a particular session.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
CollectionKey(CollectionPersister persister, Serializable key, EntityMode em)
Method Summary
boolean | equals(Object other)
int | generateHashCode()
Serializable | getKey()
String | getRole()
int | hashCode()
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

CollectionKey

public CollectionKey(CollectionPersister persister,
                     Serializable key,
                     EntityMode em)
Method Detail

equals

public boolean equals(Object other)

generateHashCode

public int generateHashCode()

hashCode

public int hashCode()

getRole

public String getRole()

getKey

public Serializable getKey()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionLoadContext (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class CollectionLoadContext

java.lang.Object
    extended by org.hibernate.engine.CollectionLoadContext
public class CollectionLoadContext
extends Object

Represents the state of collections currently being loaded. Eventually, I would like to have multiple instances of this per session - one per JDBC result set, instead of the resultSetId being passed.

Author:
Gavin King

Constructor Summary
CollectionLoadContext(PersistenceContext context)
Method Summary
void | endLoadingCollections(CollectionPersister persister, Object resultSetId, SessionImplementor session) Finish the process of loading collections for a particular result set
PersistentCollection | getLoadingCollection(CollectionPersister persister, Serializable id, EntityMode em) Retrieve a collection that is in the process of being loaded, returning null if there is no loading collection with the given id
PersistentCollection | getLoadingCollection(CollectionPersister persister, Serializable key, Object resultSetId, EntityMode em) Retrieve a collection that is in the process of being loaded, instantiating a new collection if there is nothing for the given id, or returning null if the collection with the given id is already fully loaded in the session
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CollectionLoadContext

public CollectionLoadContext(PersistenceContext context)
Method Detail

getLoadingCollection

public PersistentCollection getLoadingCollection(CollectionPersister persister,
                                                 Serializable key,
                                                 Object resultSetId,
                                                 EntityMode em)
                                          throws HibernateException
Retrieve a collection that is in the process of being loaded, instantiating a new collection if there is nothing for the given id, or returning null if the collection with the given id is already fully loaded in the session

Throws:
HibernateException

getLoadingCollection

public PersistentCollection getLoadingCollection(CollectionPersister persister,
                                                 Serializable id,
                                                 EntityMode em)
Retrieve a collection that is in the process of being loaded, returning null if there is no loading collection with the given id

endLoadingCollections

public void endLoadingCollections(CollectionPersister persister,
                                  Object resultSetId,
                                  SessionImplementor session)
                           throws HibernateException
Finish the process of loading collections for a particular result set

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Collections (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class Collections

java.lang.Object
    extended by org.hibernate.engine.Collections
public final class Collections
extends Object

Implements book-keeping for the collection persistence by reachability algorithm

Author:
Gavin King

Method Summary
static void | processReachableCollection(PersistentCollection collection, CollectionType type, Object entity, SessionImplementor session) Initialize the role of the collection.
static void | processUnreachableCollection(PersistentCollection coll, SessionImplementor session) record the fact that this collection was dereferenced
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

processUnreachableCollection

public static void processUnreachableCollection(PersistentCollection coll,
                                                SessionImplementor session)
                                         throws HibernateException
record the fact that this collection was dereferenced

Parameters:
coll - The collection to be updated by unreachability.
Throws:
HibernateException

processReachableCollection

public static void processReachableCollection(PersistentCollection collection,
                                              CollectionType type,
                                              Object entity,
                                              SessionImplementor session)
                                       throws HibernateException
Initialize the role of the collection.

Parameters:
collection - The collection to be updated by reachibility.
type - The type of the collection.
entity - The owner of the collection.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class EntityEntry

java.lang.Object
    extended by org.hibernate.engine.EntityEntry
All Implemented Interfaces:
Serializable
public final class EntityEntry
extends Object
implements Serializable

We need an entry to tell us all about the current state of an object with respect to its persistent state

Author:
Gavin King
See Also:
Serialized Form

Method Summary
void | forceLocked(Object entity, Object nextVersion)
Object[] | getDeletedState()
String | getEntityName()
Serializable | getId()
Object[] | getLoadedState()
Object | getLoadedValue(String propertyName)
LockMode | getLockMode()
EntityPersister | getPersister()
Object | getRowId()
Status | getStatus()
Object | getVersion()
boolean | isBeingReplicated()
boolean | isExistsInDatabase()
boolean | isLoadedWithLazyPropertiesUnfetched()
boolean | isNullifiable(boolean earlyInsert, SessionImplementor session)
void | postDelete() After actually deleting a row, record the fact that the instance no longer exists in the database
void | postInsert() After actually inserting a row, record the fact that the instance exists on the database (needed for identity-column key generation)
void | postUpdate(Object entity, Object[] updatedState, Object nextVersion) After actually updating the database, update the snapshot information, and escalate the lock mode
boolean | requiresDirtyCheck(Object entity)
void | setDeletedState(Object[] deletedState)
void | setLockMode(LockMode lockMode)
void | setReadOnly(boolean readOnly, Object entity)
void | setStatus(Status status)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getLockMode

public LockMode getLockMode()

setLockMode

public void setLockMode(LockMode lockMode)

getStatus

public Status getStatus()

setStatus

public void setStatus(Status status)

getId

public Serializable getId()

getLoadedState

public Object[] getLoadedState()

getDeletedState

public Object[] getDeletedState()

setDeletedState

public void setDeletedState(Object[] deletedState)

isExistsInDatabase

public boolean isExistsInDatabase()

getVersion

public Object getVersion()

getPersister

public EntityPersister getPersister()

getEntityName

public String getEntityName()

isBeingReplicated

public boolean isBeingReplicated()

getRowId

public Object getRowId()

postUpdate

public void postUpdate(Object entity,
                       Object[] updatedState,
                       Object nextVersion)
After actually updating the database, update the snapshot information, and escalate the lock mode

postDelete

public void postDelete()
After actually deleting a row, record the fact that the instance no longer exists in the database

postInsert

public void postInsert()
After actually inserting a row, record the fact that the instance exists on the database (needed for identity-column key generation)

isNullifiable

public boolean isNullifiable(boolean earlyInsert,
                             SessionImplementor session)

getLoadedValue

public Object getLoadedValue(String propertyName)

requiresDirtyCheck

public boolean requiresDirtyCheck(Object entity)

forceLocked

public void forceLocked(Object entity,
                        Object nextVersion)

setReadOnly

public void setReadOnly(boolean readOnly,
                        Object entity)

toString

public String toString()

isLoadedWithLazyPropertiesUnfetched

public boolean isLoadedWithLazyPropertiesUnfetched()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityKey (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class EntityKey

java.lang.Object
    extended by org.hibernate.engine.EntityKey
All Implemented Interfaces:
Serializable
public final class EntityKey
extends Object
implements Serializable

Uniquely identifies of an entity instance in a particular session by identifier.

Uniqueing information consists of the entity-name and the identifier value.

Author:
Gavin King
See Also:
EntityUniqueKey, Serialized Form

Constructor Summary
EntityKey(Serializable id, EntityPersister persister, EntityMode entityMode)
Construct a unique identifier for an entity class instance
Method Summary
boolean | equals(Object other)
String | getEntityName()
Serializable | getIdentifier() Get the user-visible identifier
int | hashCode()
boolean | isBatchLoadable()
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EntityKey

public EntityKey(Serializable id,
                 EntityPersister persister,
                 EntityMode entityMode)
Construct a unique identifier for an entity class instance

Method Detail

isBatchLoadable

public boolean isBatchLoadable()

getIdentifier

public Serializable getIdentifier()
Get the user-visible identifier

getEntityName

public String getEntityName()

equals

public boolean equals(Object other)

hashCode

public int hashCode()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityUniqueKey (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class EntityUniqueKey

java.lang.Object
    extended by org.hibernate.engine.EntityUniqueKey
All Implemented Interfaces:
Serializable
public class EntityUniqueKey
extends Object
implements Serializable

Used to uniquely key an entity instance in relation to a particular session by some unique property reference, as opposed to identifier.

Uniqueing information consists of the entity-name, the referenced property name, and the referenced property value.

Author:
Gavin King
See Also:
EntityKey, Serialized Form

Constructor Summary
EntityUniqueKey(String entityName, String uniqueKeyName, Object semiResolvedKey, Type keyType, EntityMode entityMode, SessionFactoryImplementor factory)
Method Summary
boolean | equals(Object other)
int | generateHashCode(SessionFactoryImplementor factory)
String | getEntityName()
Object | getKey()
String | getUniqueKeyName()
int | hashCode()
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

EntityUniqueKey

public EntityUniqueKey(String entityName,
                       String uniqueKeyName,
                       Object semiResolvedKey,
                       Type keyType,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
Method Detail

getEntityName

public String getEntityName()

getKey

public Object getKey()

getUniqueKeyName

public String getUniqueKeyName()

generateHashCode

public int generateHashCode(SessionFactoryImplementor factory)

hashCode

public int hashCode()

equals

public boolean equals(Object other)

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExecuteUpdateResultCheckStyle (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class ExecuteUpdateResultCheckStyle

java.lang.Object
    extended by org.hibernate.engine.ExecuteUpdateResultCheckStyle
All Implemented Interfaces:
Serializable
public class ExecuteUpdateResultCheckStyle
extends Object
implements Serializable

For persistence operations (INSERT, UPDATE, DELETE) what style of determining results (success/failure) is to be used.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
static ExecuteUpdateResultCheckStyle | COUNT Perform row-count checking.
static ExecuteUpdateResultCheckStyle | NONE Do not perform checking.
static ExecuteUpdateResultCheckStyle | PARAM Essentially the same as COUNT except that the row count actually comes from an output parameter registered as part of a CallableStatement.
Method Summary
static ExecuteUpdateResultCheckStyle | determineDefault(String customSql, boolean callable)
static ExecuteUpdateResultCheckStyle | parse(String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NONE

public static final ExecuteUpdateResultCheckStyle NONE
Do not perform checking. Either user simply does not want checking, or is indicating a CallableStatement execution in which the checks are being performed explicitly and failures are handled through propogation of SQLExceptions.

COUNT

public static final ExecuteUpdateResultCheckStyle COUNT
Perform row-count checking. Row counts are the int values returned by both PreparedStatement.executeUpdate() and Statement.executeBatch(). These values are checked against some expected count.

PARAM

public static final ExecuteUpdateResultCheckStyle PARAM
Essentially the same as COUNT except that the row count actually comes from an output parameter registered as part of a CallableStatement. This style explicitly prohibits statement batching from being used...

Method Detail

parse

public static ExecuteUpdateResultCheckStyle parse(String name)

determineDefault

public static ExecuteUpdateResultCheckStyle determineDefault(String customSql,
                                                             boolean callable)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FilterDefinition (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class FilterDefinition

java.lang.Object
    extended by org.hibernate.engine.FilterDefinition
All Implemented Interfaces:
Serializable
public class FilterDefinition
extends Object
implements Serializable

A FilterDefinition defines the global attributes of a dynamic filter. This information includes its name as well as its defined parameters (name and type).

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
FilterDefinition(String name, String defaultCondition, Map parameterTypes)
Construct a new FilterDefinition instance.
Method Summary
String | getDefaultFilterCondition()
String | getFilterName() Get the name of the filter this configuration defines.
Set | getParameterNames() Get a set of the parameters defined by this configuration.
Type | getParameterType(String parameterName) Retreive the type of the named parameter defined for this filter.
Map | getParameterTypes()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FilterDefinition

public FilterDefinition(String name,
                        String defaultCondition,
                        Map parameterTypes)
Construct a new FilterDefinition instance.

Parameters:
name - The name of the filter for which this configuration is in effect.
Method Detail

getFilterName

public String getFilterName()
Get the name of the filter this configuration defines.

Returns:
The filter name for this configuration.

getParameterNames

public Set getParameterNames()
Get a set of the parameters defined by this configuration.

Returns:
The parameters named by this configuration.

getParameterType

public Type getParameterType(String parameterName)
Retreive the type of the named parameter defined for this filter.

Parameters:
parameterName - The name of the filter parameter for which to return the type.
Returns:
The type of the named parameter.

getDefaultFilterCondition

public String getDefaultFilterCondition()

getParameterTypes

public Map getParameterTypes()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ForeignKeys (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class ForeignKeys

java.lang.Object
    extended by org.hibernate.engine.ForeignKeys
public final class ForeignKeys
extends Object

Algorithms related to foreign key constraint transparency

Author:
Gavin King

Nested Class Summary
static class ForeignKeys.Nullifier
Method Summary
static Serializable | getEntityIdentifierIfNotUnsaved(String entityName, Object object, SessionImplementor session) Return the identifier of the persistent or transient object, or throw an exception if the instance is "unsaved" Used by OneToOneType and ManyToOneType to determine what id value should be used for an object that may or may not be associated with the session.
static boolean | isNotTransient(String entityName, Object entity, Boolean assumed, SessionImplementor session) Is this instance persistent or detached? If assumed is non-null, don't hit the database to make the determination, instead assume that value; the client code must be prepared to "recover" in the case that this assumed result is incorrect.
static boolean | isTransient(String entityName, Object entity, Boolean assumed, SessionImplementor session) Is this instance, which we know is not persistent, actually transient? If assumed is non-null, don't hit the database to make the determination, instead assume that value; the client code must be prepared to "recover" in the case that this assumed result is incorrect.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

isNotTransient

public static boolean isNotTransient(String entityName,
                                     Object entity,
                                     Boolean assumed,
                                     SessionImplementor session)
                              throws HibernateException
Is this instance persistent or detached? If assumed is non-null, don't hit the database to make the determination, instead assume that value; the client code must be prepared to "recover" in the case that this assumed result is incorrect.

Throws:
HibernateException

isTransient

public static boolean isTransient(String entityName,
                                  Object entity,
                                  Boolean assumed,
                                  SessionImplementor session)
                           throws HibernateException
Is this instance, which we know is not persistent, actually transient? If assumed is non-null, don't hit the database to make the determination, instead assume that value; the client code must be prepared to "recover" in the case that this assumed result is incorrect.

Throws:
HibernateException

getEntityIdentifierIfNotUnsaved

public static Serializable getEntityIdentifierIfNotUnsaved(String entityName,
                                                           Object object,
                                                           SessionImplementor session)
                                                    throws HibernateException
Return the identifier of the persistent or transient object, or throw an exception if the instance is "unsaved" Used by OneToOneType and ManyToOneType to determine what id value should be used for an object that may or may not be associated with the session. This does a "best guess" using any/all info available to use (not just the EntityEntry).

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ForeignKeys.Nullifier (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class ForeignKeys.Nullifier

java.lang.Object
    extended by org.hibernate.engine.ForeignKeys.Nullifier
Enclosing class:
ForeignKeys
public static class ForeignKeys.Nullifier
extends Object

Constructor Summary
ForeignKeys.Nullifier(Object self, boolean isDelete, boolean isEarlyInsert, SessionImplementor session)
Method Summary
 void nullifyTransientReferences(Object[] values, Type[] types)
Nullify all references to entities that have not yet been inserted in the database, where the foreign key points toward that entity
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ForeignKeys.Nullifier

public ForeignKeys.Nullifier(Object self,
                             boolean isDelete,
                             boolean isEarlyInsert,
                             SessionImplementor session)
Method Detail

nullifyTransientReferences

public void nullifyTransientReferences(Object[] values,
                                       Type[] types)
                                throws HibernateException
Nullify all references to entities that have not yet been inserted in the database, where the foreign key points toward that entity

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentifierValue (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class IdentifierValue

java.lang.Object
    extended by org.hibernate.engine.IdentifierValue
public class IdentifierValue
extends Object

A strategy for determining if an identifier value is an identifier of a new transient instance or a previously persistent transient instance. The strategy is determined by the unsaved-value attribute in the mapping file.

Author:
Gavin King

Field Summary
static IdentifierValue | ANY Always assume the transient instance is newly instantiated
static IdentifierValue | NONE Never assume the transient instance is newly instantiated
static IdentifierValue | NULL Assume the transient instance is newly instantiated if the identifier is null.
static IdentifierValue | UNDEFINED Assume nothing.
Constructor Summary
protected | IdentifierValue()
 | IdentifierValue(Serializable value) Assume the transient instance is newly instantiated if its identifier is null or equal to value
Method Summary
Serializable | getDefaultValue(Serializable currentValue)
Boolean | isUnsaved(Serializable id) Does the given identifier belong to a new instance?
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ANY

public static final IdentifierValue ANY
Always assume the transient instance is newly instantiated

NONE

public static final IdentifierValue NONE
Never assume the transient instance is newly instantiated

NULL

public static final IdentifierValue NULL
Assume the transient instance is newly instantiated if the identifier is null.

UNDEFINED

public static final IdentifierValue UNDEFINED
Assume nothing.

Constructor Detail

IdentifierValue

protected IdentifierValue()

IdentifierValue

public IdentifierValue(Serializable value)
Assume the transient instance is newly instantiated if its identifier is null or equal to value

Method Detail

isUnsaved

public Boolean isUnsaved(Serializable id)
Does the given identifier belong to a new instance?

getDefaultValue

public Serializable getDefaultValue(Serializable currentValue)

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JoinHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class JoinHelper

java.lang.Object
    extended by org.hibernate.engine.JoinHelper
public final class JoinHelper
extends Object

Author:
Gavin King

Method Summary
static String[] | getAliasedLHSColumnNames(AssociationType type, String alias, int property, int begin, OuterJoinLoadable lhsPersister, Mapping mapping) Get the aliased columns of the owning entity which are to be used in the join
static String[] | getAliasedLHSColumnNames(AssociationType type, String alias, int property, OuterJoinLoadable lhsPersister, Mapping mapping) Get the aliased columns of the owning entity which are to be used in the join
static String[] | getLHSColumnNames(AssociationType type, int property, int begin, OuterJoinLoadable lhsPersister, Mapping mapping) Get the columns of the owning entity which are to be used in the join
static String[] | getLHSColumnNames(AssociationType type, int property, OuterJoinLoadable lhsPersister, Mapping mapping) Get the columns of the owning entity which are to be used in the join
static String | getLHSTableName(AssociationType type, int property, OuterJoinLoadable lhsPersister)
static String[] | getRHSColumnNames(AssociationType type, SessionFactoryImplementor factory) Get the columns of the associated table which are to be used in the join
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getAliasedLHSColumnNames

public static String[] getAliasedLHSColumnNames(AssociationType type,
                                                String alias,
                                                int property,
                                                OuterJoinLoadable lhsPersister,
                                                Mapping mapping)
Get the aliased columns of the owning entity which are to be used in the join

getLHSColumnNames

public static String[] getLHSColumnNames(AssociationType type,
                                         int property,
                                         OuterJoinLoadable lhsPersister,
                                         Mapping mapping)
Get the columns of the owning entity which are to be used in the join

getAliasedLHSColumnNames

public static String[] getAliasedLHSColumnNames(AssociationType type,
                                                String alias,
                                                int property,
                                                int begin,
                                                OuterJoinLoadable lhsPersister,
                                                Mapping mapping)
Get the aliased columns of the owning entity which are to be used in the join

getLHSColumnNames

public static String[] getLHSColumnNames(AssociationType type,
                                         int property,
                                         int begin,
                                         OuterJoinLoadable lhsPersister,
                                         Mapping mapping)
Get the columns of the owning entity which are to be used in the join

getLHSTableName

public static String getLHSTableName(AssociationType type,
                                     int property,
                                     OuterJoinLoadable lhsPersister)

getRHSColumnNames

public static String[] getRHSColumnNames(AssociationType type,
                                         SessionFactoryImplementor factory)
Get the columns of the associated table which are to be used in the join

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JoinSequence (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class JoinSequence

java.lang.Object
    extended by org.hibernate.engine.JoinSequence
public class JoinSequence
extends Object

Author:
Gavin King

Nested Class Summary
static interface JoinSequence.Selector
Constructor Summary
JoinSequence(SessionFactoryImplementor factory)
Method Summary
JoinSequence | addCondition(String condition)
JoinSequence | addCondition(String alias, String[] columns, String condition)
JoinSequence | addJoin(AssociationType associationType, String alias, int joinType, String[] referencingKey)
JoinSequence | copy()
JoinSequence | getFromPart()
int | getJoinCount()
boolean | isThetaStyle()
JoinSequence | setNext(JoinSequence next)
JoinSequence | setRoot(Joinable joinable, String alias)
JoinSequence | setSelector(JoinSequence.Selector s)
JoinSequence | setUseThetaStyle(boolean useThetaStyle)
JoinFragment | toJoinFragment()
JoinFragment | toJoinFragment(Map enabledFilters, boolean includeExtraJoins)
JoinFragment | toJoinFragment(Map enabledFilters, boolean includeExtraJoins, String withClauseFragment, String withClauseJoinAlias)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JoinSequence

public JoinSequence(SessionFactoryImplementor factory)
Method Detail

toString

public String toString()

getFromPart

public JoinSequence getFromPart()

copy

public JoinSequence copy()

addJoin

public JoinSequence addJoin(AssociationType associationType,
                            String alias,
                            int joinType,
                            String[] referencingKey)
                     throws MappingException
Throws:
MappingException

toJoinFragment

public JoinFragment toJoinFragment()
                            throws MappingException
Throws:
MappingException

toJoinFragment

public JoinFragment toJoinFragment(Map enabledFilters,
                                   boolean includeExtraJoins)
                            throws MappingException
Throws:
MappingException

toJoinFragment

public JoinFragment toJoinFragment(Map enabledFilters,
                                   boolean includeExtraJoins,
                                   String withClauseFragment,
                                   String withClauseJoinAlias)
                            throws MappingException
Throws:
MappingException

addCondition

public JoinSequence addCondition(String condition)

addCondition

public JoinSequence addCondition(String alias,
                                 String[] columns,
                                 String condition)

setRoot

public JoinSequence setRoot(Joinable joinable,
                            String alias)

setNext

public JoinSequence setNext(JoinSequence next)

setSelector

public JoinSequence setSelector(JoinSequence.Selector s)

setUseThetaStyle

public JoinSequence setUseThetaStyle(boolean useThetaStyle)

isThetaStyle

public boolean isThetaStyle()

getJoinCount

public int getJoinCount()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JoinSequence.Selector (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Interface JoinSequence.Selector

Enclosing interface:
JoinSequence
public static interface JoinSequence.Selector

Method Summary
 boolean includeSubclasses(String alias)

Method Detail

includeSubclasses

public boolean includeSubclasses(String alias)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamedQueryDefinition (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class NamedQueryDefinition

java.lang.Object
    extended by org.hibernate.engine.NamedQueryDefinition
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
NamedSQLQueryDefinition
public class NamedQueryDefinition
extends Object
implements Serializable

Definition of a named query, defined in the mapping metadata.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
NamedQueryDefinition(String query, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, CacheMode cacheMode, boolean readOnly, String comment, Map parameterTypes)
NamedQueryDefinition(String query, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, Map parameterTypes)
Method Summary
CacheMode | getCacheMode()
String | getCacheRegion()
String | getComment()
Integer | getFetchSize()
FlushMode | getFlushMode()
Map | getParameterTypes()
String | getQuery()
String | getQueryString()
Integer | getTimeout()
boolean | isCacheable()
boolean | isReadOnly()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NamedQueryDefinition

public NamedQueryDefinition(String query,
                            boolean cacheable,
                            String cacheRegion,
                            Integer timeout,
                            Integer fetchSize,
                            FlushMode flushMode,
                            Map parameterTypes)

NamedQueryDefinition

public NamedQueryDefinition(String query,
                            boolean cacheable,
                            String cacheRegion,
                            Integer timeout,
                            Integer fetchSize,
                            FlushMode flushMode,
                            CacheMode cacheMode,
                            boolean readOnly,
                            String comment,
                            Map parameterTypes)
Method Detail

getQueryString

public String getQueryString()

isCacheable

public boolean isCacheable()

getCacheRegion

public String getCacheRegion()

getFetchSize

public Integer getFetchSize()

getTimeout

public Integer getTimeout()

getFlushMode

public FlushMode getFlushMode()

toString

public String toString()

getParameterTypes

public Map getParameterTypes()

getQuery

public String getQuery()

getCacheMode

public CacheMode getCacheMode()

isReadOnly

public boolean isReadOnly()

getComment

public String getComment()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamedSQLQueryDefinition (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class NamedSQLQueryDefinition

java.lang.Object
    extended by org.hibernate.engine.NamedQueryDefinition
        extended by org.hibernate.engine.NamedSQLQueryDefinition
All Implemented Interfaces:
Serializable
public class NamedSQLQueryDefinition
extends NamedQueryDefinition

Definition of a named native SQL query, defined in the mapping metadata.

Author:
Max Andersen
See Also:
Serialized Form

Constructor Summary
NamedSQLQueryDefinition(String query, NativeSQLQueryReturn[] queryReturns, List querySpaces, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, CacheMode cacheMode, boolean readOnly, String comment, Map parameterTypes, boolean callable)
This form used to construct a NamedSQLQueryDefinition from the binder code when a the result-set mapping information is explicitly provided in the query definition (i.e., no resultset-mapping used)
NamedSQLQueryDefinition(String query, String resultSetRef, List querySpaces, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, CacheMode cacheMode, boolean readOnly, String comment, Map parameterTypes, boolean callable)
This form used to construct a NamedSQLQueryDefinition from the binder code when a resultset-mapping reference is used.
NamedSQLQueryDefinition(String query, String resultSetRef, List querySpaces, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, Map parameterTypes, boolean callable)
This form used from annotations (?).
Method Summary
NativeSQLQueryReturn[] | getQueryReturns()
List | getQuerySpaces()
String | getResultSetRef()
boolean | isCallable()
Methods inherited from class org.hibernate.engine.NamedQueryDefinition
getCacheMode, getCacheRegion, getComment, getFetchSize, getFlushMode, getParameterTypes, getQuery, getQueryString, getTimeout, isCacheable, isReadOnly, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NamedSQLQueryDefinition

public NamedSQLQueryDefinition(String query,
                               NativeSQLQueryReturn[] queryReturns,
                               List querySpaces,
                               boolean cacheable,
                               String cacheRegion,
                               Integer timeout,
                               Integer fetchSize,
                               FlushMode flushMode,
                               CacheMode cacheMode,
                               boolean readOnly,
                               String comment,
                               Map parameterTypes,
                               boolean callable)
This form used to construct a NamedSQLQueryDefinition from the binder code when a the result-set mapping information is explicitly provided in the query definition (i.e., no resultset-mapping used)

Parameters:
query - The sql query string
queryReturns - The in-lined query return definitions
querySpaces - Any specified query spaces (used for auto-flushing)
cacheable - Whether the query results are cacheable
cacheRegion - If cacheable, the region into which to store the results
timeout - A JDBC-level timeout to be applied
fetchSize - A JDBC-level fetch-size to be applied
flushMode - The flush mode to use for this query
cacheMode - The cache mode to use during execution and subsequent result loading
readOnly - Whether returned entities should be marked as read-only in the session
comment - Any sql comment to be applied to the query
parameterTypes - parameter type map
callable - Does the query string represent a callable object (i.e., proc)

NamedSQLQueryDefinition

public NamedSQLQueryDefinition(String query,
                               String resultSetRef,
                               List querySpaces,
                               boolean cacheable,
                               String cacheRegion,
                               Integer timeout,
                               Integer fetchSize,
                               FlushMode flushMode,
                               CacheMode cacheMode,
                               boolean readOnly,
                               String comment,
                               Map parameterTypes,
                               boolean callable)
This form used to construct a NamedSQLQueryDefinition from the binder code when a resultset-mapping reference is used.

Parameters:
query - The sql query string
resultSetRef - The resultset-mapping name
querySpaces - Any specified query spaces (used for auto-flushing)
cacheable - Whether the query results are cacheable
cacheRegion - If cacheable, the region into which to store the results
timeout - A JDBC-level timeout to be applied
fetchSize - A JDBC-level fetch-size to be applied
flushMode - The flush mode to use for this query
cacheMode - The cache mode to use during execution and subsequent result loading
readOnly - Whether returned entities should be marked as read-only in the session
comment - Any sql comment to be applied to the query
parameterTypes - parameter type map
callable - Does the query string represent a callable object (i.e., proc)

NamedSQLQueryDefinition

public NamedSQLQueryDefinition(String query,
                               String resultSetRef,
                               List querySpaces,
                               boolean cacheable,
                               String cacheRegion,
                               Integer timeout,
                               Integer fetchSize,
                               FlushMode flushMode,
                               Map parameterTypes,
                               boolean callable)
This form used from annotations (?). Essentially the same as the above using a resultset-mapping reference, but without cacheMode, readOnly, and comment.

Parameters:
query - The sql query string
resultSetRef - The result-set-mapping name
querySpaces - Any specified query spaces (used for auto-flushing)
cacheable - Whether the query results are cacheable
cacheRegion - If cacheable, the region into which to store the results
timeout - A JDBC-level timeout to be applied
fetchSize - A JDBC-level fetch-size to be applied
flushMode - The flush mode to use for this query
parameterTypes - parameter type map
callable - Does the query string represent a callable object (i.e., proc)
Method Detail

getQueryReturns

public NativeSQLQueryReturn[] getQueryReturns()

getQuerySpaces

public List getQuerySpaces()

isCallable

public boolean isCallable()

getResultSetRef

public String getResultSetRef()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Nullability (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class Nullability

java.lang.Object
    extended by org.hibernate.engine.Nullability
public final class Nullability
extends Object

Implements the algorithm for validating property values for illegal null values

Author:
Gavin King

Constructor Summary
Nullability(SessionImplementor session)
Method Summary
 void checkNullability(Object[] values, EntityPersister persister, boolean isUpdate)
Check nullability of the class persister properties
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Nullability

public Nullability(SessionImplementor session)
Method Detail

checkNullability

public void checkNullability(Object[] values,
                             EntityPersister persister,
                             boolean isUpdate)
                      throws PropertyValueException,
                             HibernateException
Check nullability of the class persister properties

Parameters:
values - entity properties
persister - class persister
isUpdate - wether it is intended to be updated or saved
Throws:
PropertyValueException - Break the nullability of one property
HibernateException - error while getting Component values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterBinder (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class ParameterBinder

java.lang.Object
    extended by org.hibernate.engine.ParameterBinder
public class ParameterBinder
extends Object

Centralizes the commonality regarding binding of parameter values into PreparedStatements as this logic is used in many places.

Ideally would like to move to the parameter handling as it is done in the hql.ast package.

Author:
Steve Ebersole

Nested Class Summary
static interface ParameterBinder.NamedParameterSource
Method Summary
static int | bindNamedParameters(PreparedStatement ps, Map namedParams, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)
static int | bindNamedParameters(PreparedStatement ps, QueryParameters queryParameters, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)
static int | bindPositionalParameters(PreparedStatement st, Object[] values, Type[] types, int start, SessionImplementor session)
static int | bindPositionalParameters(PreparedStatement st, QueryParameters queryParameters, int start, SessionImplementor session)
static int | bindQueryParameters(PreparedStatement st, QueryParameters queryParameters, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

bindQueryParameters

public static int bindQueryParameters(PreparedStatement st,
                                      QueryParameters queryParameters,
                                      int start,
                                      ParameterBinder.NamedParameterSource source,
                                      SessionImplementor session)
                               throws SQLException,
                                      HibernateException
Throws:
SQLException
HibernateException

bindPositionalParameters

public static int bindPositionalParameters(PreparedStatement st,
                                           QueryParameters queryParameters,
                                           int start,
                                           SessionImplementor session)
                                    throws SQLException,
                                           HibernateException
Throws:
SQLException
HibernateException

bindPositionalParameters

public static int bindPositionalParameters(PreparedStatement st,
                                           Object[] values,
                                           Type[] types,
                                           int start,
                                           SessionImplementor session)
                                    throws SQLException,
                                           HibernateException
Throws:
SQLException
HibernateException

bindNamedParameters

public static int bindNamedParameters(PreparedStatement ps,
                                      QueryParameters queryParameters,
                                      int start,
                                      ParameterBinder.NamedParameterSource source,
                                      SessionImplementor session)
                               throws SQLException,
                                      HibernateException
Throws:
SQLException
HibernateException

bindNamedParameters

public static int bindNamedParameters(PreparedStatement ps,
                                      Map namedParams,
                                      int start,
                                      ParameterBinder.NamedParameterSource source,
                                      SessionImplementor session)
                               throws SQLException,
                                      HibernateException
Throws:
SQLException
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterBinder.NamedParameterSource (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Interface ParameterBinder.NamedParameterSource

All Known Implementing Classes:
HqlSqlWalker
Enclosing interface:
ParameterBinder
public static interface ParameterBinder.NamedParameterSource

Method Summary
 int[] getNamedParameterLocations(String name)

Method Detail

getNamedParameterLocations

public int[] getNamedParameterLocations(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryParameters (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class QueryParameters

java.lang.Object
    extended by org.hibernate.engine.QueryParameters
public final class QueryParameters
extends Object

Author:
Gavin King

Constructor Summary
QueryParameters()
QueryParameters(Type[] positionalParameterTypes, Object[] postionalParameterValues)
QueryParameters(Type[] positionalParameterTypes, Object[] positionalParameterValues, Map namedParameters, Map lockModes, RowSelection rowSelection, boolean readOnly, boolean cacheable, String cacheRegion, String comment, Serializable[] collectionKeys, Object optionalObject, String optionalEntityName, Serializable optionalId, ResultTransformer transformer)
QueryParameters(Type[] positionalParameterTypes, Object[] positionalParameterValues, Map namedParameters, Map lockModes, RowSelection rowSelection, boolean readOnly, boolean cacheable, String cacheRegion, String comment, Serializable[] collectionKeys, ResultTransformer transformer)
QueryParameters(Type[] positionalParameterTypes, Object[] positionalParameterValues, Map lockModes, RowSelection rowSelection, boolean cacheable, String cacheRegion, String comment, boolean isLookupByNaturalKey, ResultTransformer transformer)
QueryParameters(Type[] positionalParameterTypes, Object[] postionalParameterValues, Map namedParameters, Serializable[] collectionKeys)
QueryParameters(Type[] positionalParameterTypes, Object[] postionalParameterValues, Object optionalObject, String optionalEntityName, Serializable optionalObjectId)
QueryParameters(Type[] positionalParameterTypes, Object[] postionalParameterValues, Serializable[] collectionKeys)
QueryParameters(Type type, Object value)
Method Summary
QueryParameters | createCopyUsing(RowSelection selection)
String | getCacheRegion()
Serializable[] | getCollectionKeys()
String | getComment()
Type[] | getFilteredPositionalParameterTypes()
Object[] | getFilteredPositionalParameterValues()
String | getFilteredSQL()
Map | getLockModes()
Map | getNamedParameters()
String | getOptionalEntityName()
Serializable | getOptionalId()
Object | getOptionalObject()
Type[] | getPositionalParameterTypes()
Object[] | getPositionalParameterValues()
ResultTransformer | getResultTransformer()
RowSelection | getRowSelection()
ScrollMode | getScrollMode()
boolean | hasAutoDiscoverScalarTypes()
boolean | hasRowSelection()
boolean | isCacheable()
boolean | isCallable()
boolean | isNaturalKeyLookup()
boolean | isReadOnly()
void | processFilters(String sql, SessionImplementor session)
void | setAutoDiscoverScalarTypes(boolean autodiscovertypes)
void | setCacheable(boolean b)
void | setCacheRegion(String cacheRegion)
void | setCallable(boolean callable)
void | setCollectionKeys(Serializable[] collectionKeys)
void | setComment(String comment)
void | setLockModes(Map map)
void | setNamedParameters(Map map)
void | setNaturalKeyLookup(boolean isNaturalKeyLookup)
void | setOptionalEntityName(String optionalEntityName)
void | setOptionalId(Serializable optionalId)
void | setOptionalObject(Object optionalObject)
void | setPositionalParameterTypes(Type[] types)
void | setPositionalParameterValues(Object[] objects)
void | setReadOnly(boolean readOnly)
void | setRowSelection(RowSelection selection)
void | setScrollMode(ScrollMode scrollMode)
void | traceParameters(SessionFactoryImplementor factory)
void | validateParameters()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryParameters

public QueryParameters()

QueryParameters

public QueryParameters(Type type,
                       Object value)

QueryParameters

public QueryParameters(Type[] positionalParameterTypes,
                       Object[] postionalParameterValues,
                       Object optionalObject,
                       String optionalEntityName,
                       Serializable optionalObjectId)

QueryParameters

public QueryParameters(Type[] positionalParameterTypes,
                       Object[] postionalParameterValues)

QueryParameters

public QueryParameters(Type[] positionalParameterTypes,
                       Object[] postionalParameterValues,
                       Serializable[] collectionKeys)

QueryParameters

public QueryParameters(Type[] positionalParameterTypes,
                       Object[] postionalParameterValues,
                       Map namedParameters,
                       Serializable[] collectionKeys)

QueryParameters

public QueryParameters(Type[] positionalParameterTypes,
                       Object[] positionalParameterValues,
                       Map lockModes,
                       RowSelection rowSelection,
                       boolean cacheable,
                       String cacheRegion,
                       String comment,
                       boolean isLookupByNaturalKey,
                       ResultTransformer transformer)

QueryParameters

public QueryParameters(Type[] positionalParameterTypes,
                       Object[] positionalParameterValues,
                       Map namedParameters,
                       Map lockModes,
                       RowSelection rowSelection,
                       boolean readOnly,
                       boolean cacheable,
                       String cacheRegion,
                       String comment,
                       Serializable[] collectionKeys,
                       ResultTransformer transformer)

QueryParameters

public QueryParameters(Type[] positionalParameterTypes,
                       Object[] positionalParameterValues,
                       Map namedParameters,
                       Map lockModes,
                       RowSelection rowSelection,
                       boolean readOnly,
                       boolean cacheable,
                       String cacheRegion,
                       String comment,
                       Serializable[] collectionKeys,
                       Object optionalObject,
                       String optionalEntityName,
                       Serializable optionalId,
                       ResultTransformer transformer)
Method Detail

hasRowSelection

public boolean hasRowSelection()

getNamedParameters

public Map getNamedParameters()

getPositionalParameterTypes

public Type[] getPositionalParameterTypes()

getPositionalParameterValues

public Object[] getPositionalParameterValues()

getRowSelection

public RowSelection getRowSelection()

getResultTransformer

public ResultTransformer getResultTransformer()

setNamedParameters

public void setNamedParameters(Map map)

setPositionalParameterTypes

public void setPositionalParameterTypes(Type[] types)

setPositionalParameterValues

public void setPositionalParameterValues(Object[] objects)

setRowSelection

public void setRowSelection(RowSelection selection)

getLockModes

public Map getLockModes()

setLockModes

public void setLockModes(Map map)

traceParameters

public void traceParameters(SessionFactoryImplementor factory)
                     throws HibernateException
Throws:
HibernateException

isCacheable

public boolean isCacheable()

setCacheable

public void setCacheable(boolean b)

getCacheRegion

public String getCacheRegion()

setCacheRegion

public void setCacheRegion(String cacheRegion)

validateParameters

public void validateParameters()
                        throws QueryException
Throws:
QueryException

getComment

public String getComment()

setComment

public void setComment(String comment)

getScrollMode

public ScrollMode getScrollMode()

setScrollMode

public void setScrollMode(ScrollMode scrollMode)

getCollectionKeys

public Serializable[] getCollectionKeys()

setCollectionKeys

public void setCollectionKeys(Serializable[] collectionKeys)

getOptionalEntityName

public String getOptionalEntityName()

setOptionalEntityName

public void setOptionalEntityName(String optionalEntityName)

getOptionalId

public Serializable getOptionalId()

setOptionalId

public void setOptionalId(Serializable optionalId)

getOptionalObject

public Object getOptionalObject()

setOptionalObject

public void setOptionalObject(Object optionalObject)

isReadOnly

public boolean isReadOnly()

setReadOnly

public void setReadOnly(boolean readOnly)

setCallable

public void setCallable(boolean callable)

isCallable

public boolean isCallable()

hasAutoDiscoverScalarTypes

public boolean hasAutoDiscoverScalarTypes()

processFilters

public void processFilters(String sql,
                           SessionImplementor session)

getFilteredSQL

public String getFilteredSQL()

getFilteredPositionalParameterValues

public Object[] getFilteredPositionalParameterValues()

getFilteredPositionalParameterTypes

public Type[] getFilteredPositionalParameterTypes()

isNaturalKeyLookup

public boolean isNaturalKeyLookup()

setNaturalKeyLookup

public void setNaturalKeyLookup(boolean isNaturalKeyLookup)

setAutoDiscoverScalarTypes

public void setAutoDiscoverScalarTypes(boolean autodiscovertypes)

createCopyUsing

public QueryParameters createCopyUsing(RowSelection selection)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResultSetMappingDefinition (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class ResultSetMappingDefinition

java.lang.Object
    extended by org.hibernate.engine.ResultSetMappingDefinition
All Implemented Interfaces:
Serializable
public class ResultSetMappingDefinition
extends Object
implements Serializable

Keep a description of the resultset mapping

Author:
Emmanuel Bernard
See Also:
Serialized Form

Constructor Summary
ResultSetMappingDefinition(String name)
Method Summary
void | addQueryReturn(NativeSQLQueryReturn queryReturn)
String | getName()
NativeSQLQueryReturn[] | getQueryReturns()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResultSetMappingDefinition

public ResultSetMappingDefinition(String name)
Method Detail

getName

public String getName()

addQueryReturn

public void addQueryReturn(NativeSQLQueryReturn queryReturn)

getQueryReturns

public NativeSQLQueryReturn[] getQueryReturns()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RowSelection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class RowSelection

java.lang.Object
    extended by org.hibernate.engine.RowSelection
public final class RowSelection
extends Object

Represents a selection of rows in a JDBC ResultSet

Author:
Gavin King

Constructor Summary
RowSelection()
Method Summary
boolean | definesLimits()
Integer | getFetchSize()
Integer | getFirstRow()
Integer | getMaxRows()
Integer | getTimeout()
void | setFetchSize(Integer fetchSize)
void | setFirstRow(Integer firstRow)
void | setMaxRows(Integer maxRows)
void | setTimeout(Integer timeout)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RowSelection

public RowSelection()
Method Detail

setFirstRow

public void setFirstRow(Integer firstRow)

getFirstRow

public Integer getFirstRow()

setMaxRows

public void setMaxRows(Integer maxRows)

getMaxRows

public Integer getMaxRows()

setTimeout

public void setTimeout(Integer timeout)

getTimeout

public Integer getTimeout()

getFetchSize

public Integer getFetchSize()

setFetchSize

public void setFetchSize(Integer fetchSize)

definesLimits

public boolean definesLimits()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StatefulPersistenceContext (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class StatefulPersistenceContext

java.lang.Object
    extended by org.hibernate.engine.StatefulPersistenceContext
All Implemented Interfaces:
PersistenceContext
public class StatefulPersistenceContext
extends Object
implements PersistenceContext

A PersistenceContext represents the state of persistent "stuff" which Hibernate is tracking. This includes persistent entities, collections, as well as proxies generated.

There is meant to be a one-to-one correspondence between a SessionImpl and a PersistentContext. The SessionImpl uses the PersistentContext to track the current state of its context. Event-listeners then use the PersistentContext to drive their processing.

Author:
Steve Ebersole

Field Summary
static Object NO_ROW
Constructor Summary
StatefulPersistenceContext(SessionImplementor session)
Constructs a PersistentContext, bound to the given session.
Method Summary
 void addCollectionHolder(PersistentCollection holder)
Register a PersistentCollection object for an array.
 void addEntity(EntityKey key, Object entity)
Add a canonical mapping from entity key to entity instance
 void addEntity(EntityUniqueKey euk, Object entity)
Add an entity to the cache by unique key
 EntityEntry addEntity(Object entity, Status status, Object[] loadedState, EntityKey entityKey, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched)
Adds an entity to the internal caches.
 EntityEntry addEntry(Object entity, Status status, Object[] loadedState, Object rowId, Serializable id, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched)
Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.
 CollectionEntry addInitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just pulled out of the cache (does not need initializing)
 void addInitializedDetachedCollection(CollectionPersister collectionPersister, PersistentCollection collection)
add an (initialized) collection that was created by another session and passed into update() (ie.
 void addNewCollection(CollectionPersister persister, PersistentCollection collection)
Add a new collection (ie.
 void addNonLazyCollection(PersistentCollection collection)
Register a collection for non-lazy loading at the end of the two-phase load
 void addNullProperty(EntityKey ownerKey, String propertyName)
Record the fact that the association belonging to the keyed entity is null.
 void addProxy(EntityKey key, Object proxy)
Add a proxy to the session cache
 void addUninitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just loaded up (still needs initializing)
 void addUninitializedDetachedCollection(CollectionPersister persister, PersistentCollection collection)
add a detached uninitialized collection
 void addUnownedCollection(CollectionKey key, PersistentCollection collection)
Add a collection which has no owner loaded
 void afterLoad()
Call this after finishing a two-phase load
 void afterTransactionCompletion()
Called after transactions end
 void beforeLoad()
Call this before begining a two-phase load
 void checkUniqueness(EntityKey key, Object object)
Attempts to check whether the given key represents an entity already loaded within the current session.
 void clear()
Clear the state of the persistence context
 boolean containsCollection(PersistentCollection collection)
Is the given collection associated with this persistence context?
 boolean containsEntity(EntityKey key)
Is there an entity with the given key in the persistence context
 boolean containsProxy(Object entity)
Is the given proxy associated with this persistence context?
 int decrementCascadeLevel()
Called after cascading
static StatefulPersistenceContext deserialize(ObjectInputStream ois, SessionImplementor session)
 BatchFetchQueue getBatchFetchQueue()
Get the BatchFetchQueue, instantiating one if necessary.
 Object[] getCachedDatabaseSnapshot(EntityKey key)
 int getCascadeLevel()
Do we already know that the entity does not exist in the database?
 PersistentCollection getCollection(CollectionKey collectionKey)
Get the collection instance associated with the CollectionKey
 Map getCollectionEntries()
Get the mapping from collection instance to collection entry
 CollectionEntry getCollectionEntry(PersistentCollection coll)
Get the collection entry for a persistent collection
 CollectionEntry getCollectionEntryOrNull(Object collection)
Get the collection entry for a collection passed to filter, which might be a collection wrapper, an array, or an unwrapped collection.
 PersistentCollection getCollectionHolder(Object array)
Get the PersistentCollection object for an array
 CollectionLoadContext getCollectionLoadContext()
Get the context for collection loading
 Object getCollectionOwner(Serializable key, CollectionPersister collectionPersister)
Get the entity that owns this persistent collection
 Map getCollectionsByKey()
Get the mapping from collection key to collection instance
 Object[] getDatabaseSnapshot(Serializable id, EntityPersister persister)
Get the current state of the entity as known to the underlying database, or null if there is no corresponding row
 Map getEntitiesByKey()
Get the mapping from key value to entity instance
 Object getEntity(EntityKey key)
Get the entity instance associated with the given EntityKey
 Object getEntity(EntityUniqueKey euk)
Get an entity cached by unique key
 Map getEntityEntries()
Get the mapping from entity instance to entity entry
 EntityEntry getEntry(Object entity)
Retreive the EntityEntry representation of the given entity.
 Object getIndexInOwner(String entity, String property, Object childEntity, Map mergeMap)
Search the persistence context for an index of the child object, given a collection role
 Object[] getNaturalIdSnapshot(Serializable id, EntityPersister persister)
 HashSet getNullifiableEntityKeys()
Retrieve the set of EntityKeys representing nullifiable references
 Serializable getOwnerId(String entity, String property, Object childEntity, Map mergeMap)
Search the persistence context for an owner for the child object, given a collection role.
 Object getProxy(EntityKey key)
Get an existing proxy by key
 SessionImplementor getSession()
Get the session
 Serializable getSnapshot(PersistentCollection coll)
Get the snapshot of the pre-flush collection state
 boolean hasNonReadOnlyEntities()
 int incrementCascadeLevel()
Called before cascading
 void initializeNonLazyCollections()
Force initialization of all non-lazy collections encountered during the current two-phase load (actually, this is a no-op, unless this is the "outermost" load)
 boolean isEntryFor(Object entity)
Is there an EntityEntry for this instance?
 boolean isFlushing()
Is a flush cycle currently in process?
 boolean isPropertyNull(EntityKey ownerKey, String propertyName)
Is the association property belonging to the keyed entity null?
 boolean isStateless()
 Object narrowProxy(Object proxy, EntityPersister persister, EntityKey key, Object object)
If the existing proxy is insufficiently "narrow" (derived), instantiate a new proxy and overwrite the registration of the old one.
 Object proxyFor(EntityPersister persister, EntityKey key, Object impl)
Return the existing proxy associated with the given EntityKey, or the third argument (the entity associated with the key) if no proxy exists.
 Object proxyFor(Object impl)
Return the existing proxy associated with the given EntityKey, or the argument (the entity associated with the key) if no proxy exists.
 boolean reassociateIfUninitializedProxy(Object value)
Takes the given object and, if it represents a proxy, reassociates it with this event source.
 void reassociateProxy(Object value, Serializable id)
If a deleted entity instance is re-saved, and it has a proxy, we need to reset the identifier of the proxy
 PersistentCollection removeCollectionHolder(Object array)
Remove the mapping of collection to holder during eviction of the owning entity
 Object removeEntity(EntityKey key)
Remove an entity from the session cache, also clear up other state associated with the entity, all except for the EntityEntry
 EntityEntry removeEntry(Object entity)
Remove an entity entry from the session cache
 Object removeProxy(EntityKey key)
Remove a proxy from the session cache
 void replaceDelayedEntityIdentityInsertKeys(EntityKey oldKey, Serializable generatedId)
 void serialize(ObjectOutputStream oos)
Used by the owning session to explicitly control serialization of the persistence context.
 void setEntryStatus(EntityEntry entry, Status status)
Set the status of an entry
 void setFlushing(boolean flushing)
Called before and after the flushcycle
 void setReadOnly(Object entity, boolean readOnly)
Set the object to read only and discard it's snapshot
 String toString()
Returns a string representation of the object.
 Object unproxy(Object maybeProxy)
Get the entity instance underlying the given proxy, throwing an exception if the proxy is uninitialized.
 Object unproxyAndReassociate(Object maybeProxy)
Possibly unproxy the given reference and reassociate it with the current session.
 PersistentCollection useUnownedCollection(CollectionKey key)
Get and remove a collection whose owner is not yet loaded, when its owner is being loaded
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NO_ROW

public static final Object NO_ROW
Constructor Detail

StatefulPersistenceContext

public StatefulPersistenceContext(SessionImplementor session)
Constructs a PersistentContext, bound to the given session.

Parameters:
session - The session "owning" this context.
Method Detail

isStateless

public boolean isStateless()
Specified by:
isStateless in interface PersistenceContext

getSession

public SessionImplementor getSession()
Description copied from interface: PersistenceContext
Get the session

Specified by:
getSession in interface PersistenceContext

getCollectionLoadContext

public CollectionLoadContext getCollectionLoadContext()
Description copied from interface: PersistenceContext
Get the context for collection loading

Specified by:
getCollectionLoadContext in interface PersistenceContext

addUnownedCollection

public void addUnownedCollection(CollectionKey key,
                                 PersistentCollection collection)
Description copied from interface: PersistenceContext
Add a collection which has no owner loaded

Specified by:
addUnownedCollection in interface PersistenceContext

useUnownedCollection

public PersistentCollection useUnownedCollection(CollectionKey key)
Description copied from interface: PersistenceContext
Get and remove a collection whose owner is not yet loaded, when its owner is being loaded

Specified by:
useUnownedCollection in interface PersistenceContext

getBatchFetchQueue

public BatchFetchQueue getBatchFetchQueue()
Get the BatchFetchQueue, instantiating one if necessary.

Specified by:
getBatchFetchQueue in interface PersistenceContext

clear

public void clear()
Description copied from interface: PersistenceContext
Clear the state of the persistence context

Specified by:
clear in interface PersistenceContext

hasNonReadOnlyEntities

public boolean hasNonReadOnlyEntities()
Specified by:
hasNonReadOnlyEntities in interface PersistenceContext
Returns:
false if we know for certain that all the entities are read-only

setEntryStatus

public void setEntryStatus(EntityEntry entry,
                           Status status)
Description copied from interface: PersistenceContext
Set the status of an entry

Specified by:
setEntryStatus in interface PersistenceContext

afterTransactionCompletion

public void afterTransactionCompletion()
Description copied from interface: PersistenceContext
Called after transactions end

Specified by:
afterTransactionCompletion in interface PersistenceContext

getDatabaseSnapshot

public Object[] getDatabaseSnapshot(Serializable id,
                                    EntityPersister persister)
                             throws HibernateException
Get the current state of the entity as known to the underlying database, or null if there is no corresponding row

Specified by:
getDatabaseSnapshot in interface PersistenceContext
Throws:
HibernateException

getNaturalIdSnapshot

public Object[] getNaturalIdSnapshot(Serializable id,
                                     EntityPersister persister)
                              throws HibernateException
Specified by:
getNaturalIdSnapshot in interface PersistenceContext
Throws:
HibernateException

getCachedDatabaseSnapshot

public Object[] getCachedDatabaseSnapshot(EntityKey key)
Specified by:
getCachedDatabaseSnapshot in interface PersistenceContext

addEntity

public void addEntity(EntityKey key,
                      Object entity)
Description copied from interface: PersistenceContext
Add a canonical mapping from entity key to entity instance

Specified by:
addEntity in interface PersistenceContext

getEntity

public Object getEntity(EntityKey key)
Get the entity instance associated with the given EntityKey

Specified by:
getEntity in interface PersistenceContext

containsEntity

public boolean containsEntity(EntityKey key)
Description copied from interface: PersistenceContext
Is there an entity with the given key in the persistence context

Specified by:
containsEntity in interface PersistenceContext

removeEntity

public Object removeEntity(EntityKey key)
Remove an entity from the session cache, also clear up other state associated with the entity, all except for the EntityEntry

Specified by:
removeEntity in interface PersistenceContext

getEntity

public Object getEntity(EntityUniqueKey euk)
Get an entity cached by unique key

Specified by:
getEntity in interface PersistenceContext

addEntity

public void addEntity(EntityUniqueKey euk,
                      Object entity)
Add an entity to the cache by unique key

Specified by:
addEntity in interface PersistenceContext

getEntry

public EntityEntry getEntry(Object entity)
Retreive the EntityEntry representation of the given entity.

Specified by:
getEntry in interface PersistenceContext
Parameters:
entity - The entity for which to locate the EntityEntry.
Returns:
The EntityEntry for the given entity.

removeEntry

public EntityEntry removeEntry(Object entity)
Remove an entity entry from the session cache

Specified by:
removeEntry in interface PersistenceContext

isEntryFor

public boolean isEntryFor(Object entity)
Is there an EntityEntry for this instance?

Specified by:
isEntryFor in interface PersistenceContext

getCollectionEntry

public CollectionEntry getCollectionEntry(PersistentCollection coll)
Get the collection entry for a persistent collection

Specified by:
getCollectionEntry in interface PersistenceContext

addEntity

public EntityEntry addEntity(Object entity,
                             Status status,
                             Object[] loadedState,
                             EntityKey entityKey,
                             Object version,
                             LockMode lockMode,
                             boolean existsInDatabase,
                             EntityPersister persister,
                             boolean disableVersionIncrement,
                             boolean lazyPropertiesAreUnfetched)
Adds an entity to the internal caches.

Specified by:
addEntity in interface PersistenceContext

addEntry

public EntityEntry addEntry(Object entity,
                            Status status,
                            Object[] loadedState,
                            Object rowId,
                            Serializable id,
                            Object version,
                            LockMode lockMode,
                            boolean existsInDatabase,
                            EntityPersister persister,
                            boolean disableVersionIncrement,
                            boolean lazyPropertiesAreUnfetched)
Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.

Specified by:
addEntry in interface PersistenceContext

containsCollection

public boolean containsCollection(PersistentCollection collection)
Description copied from interface: PersistenceContext
Is the given collection associated with this persistence context?

Specified by:
containsCollection in interface PersistenceContext

containsProxy

public boolean containsProxy(Object entity)
Description copied from interface: PersistenceContext
Is the given proxy associated with this persistence context?

Specified by:
containsProxy in interface PersistenceContext

reassociateIfUninitializedProxy

public boolean reassociateIfUninitializedProxy(Object value)
                                        throws MappingException
Takes the given object and, if it represents a proxy, reassociates it with this event source.

Specified by:
reassociateIfUninitializedProxy in interface PersistenceContext
Parameters:
value - The possible proxy to be reassociated.
Returns:
Whether the passed value represented an actual proxy which got initialized.
Throws:
MappingException

reassociateProxy

public void reassociateProxy(Object value,
                             Serializable id)
                      throws MappingException
If a deleted entity instance is re-saved, and it has a proxy, we need to reset the identifier of the proxy

Specified by:
reassociateProxy in interface PersistenceContext
Throws:
MappingException

unproxy

public Object unproxy(Object maybeProxy)
               throws HibernateException
Get the entity instance underlying the given proxy, throwing an exception if the proxy is uninitialized. If the given object is not a proxy, simply return the argument.

Specified by:
unproxy in interface PersistenceContext
Throws:
HibernateException

unproxyAndReassociate

public Object unproxyAndReassociate(Object maybeProxy)
                             throws HibernateException
Possibly unproxy the given reference and reassociate it with the current session.

Specified by:
unproxyAndReassociate in interface PersistenceContext
Parameters:
maybeProxy - The reference to be unproxied if it currently represents a proxy.
Returns:
The unproxied instance.
Throws:
HibernateException

checkUniqueness

public void checkUniqueness(EntityKey key,
                            Object object)
                     throws HibernateException
Attempts to check whether the given key represents an entity already loaded within the current session.

Specified by:
checkUniqueness in interface PersistenceContext
Parameters:
object - The entity reference against which to perform the uniqueness check.
Throws:
HibernateException

narrowProxy

public Object narrowProxy(Object proxy,
                          EntityPersister persister,
                          EntityKey key,
                          Object object)
                   throws HibernateException
If the existing proxy is insufficiently "narrow" (derived), instantiate a new proxy and overwrite the registration of the old one. This breaks == and occurs only for "class" proxies rather than "interface" proxies. Also init the proxy to point to the given target implementation if necessary.

Specified by:
narrowProxy in interface PersistenceContext
Parameters:
proxy - The proxy instance to be narrowed.
persister - The persister for the proxied entity.
key - The internal cache key for the proxied entity.
object - (optional) the actual proxied entity instance.
Returns:
An appropriately narrowed instance.
Throws:
HibernateException

proxyFor

public Object proxyFor(EntityPersister persister,
                       EntityKey key,
                       Object impl)
                throws HibernateException
Return the existing proxy associated with the given EntityKey, or the third argument (the entity associated with the key) if no proxy exists. Init the proxy to the target implementation, if necessary.

Specified by:
proxyFor in interface PersistenceContext
Throws:
HibernateException

proxyFor

public Object proxyFor(Object impl)
                throws HibernateException
Return the existing proxy associated with the given EntityKey, or the argument (the entity associated with the key) if no proxy exists. (slower than the form above)

Specified by:
proxyFor in interface PersistenceContext
Throws:
HibernateException

getCollectionOwner

public Object getCollectionOwner(Serializable key,
                                 CollectionPersister collectionPersister)
                          throws MappingException
Get the entity that owns this persistent collection

Specified by:
getCollectionOwner in interface PersistenceContext
Throws:
MappingException

addUninitializedCollection

public void addUninitializedCollection(CollectionPersister persister,
                                       PersistentCollection collection,
                                       Serializable id)
add a collection we just loaded up (still needs initializing)

Specified by:
addUninitializedCollection in interface PersistenceContext

addUninitializedDetachedCollection

public void addUninitializedDetachedCollection(CollectionPersister persister,
                                               PersistentCollection collection)
add a detached uninitialized collection

Specified by:
addUninitializedDetachedCollection in interface PersistenceContext

addNewCollection

public void addNewCollection(CollectionPersister persister,
                             PersistentCollection collection)
                      throws HibernateException
Add a new collection (ie. a newly created one, just instantiated by the application, with no database state or snapshot)

Specified by:
addNewCollection in interface PersistenceContext
Parameters:
collection - The collection to be associated with the persistence context
Throws:
HibernateException

addInitializedDetachedCollection

public void addInitializedDetachedCollection(CollectionPersister collectionPersister,
                                             PersistentCollection collection)
                                      throws HibernateException
add an (initialized) collection that was created by another session and passed into update() (ie. one with a snapshot and existing state on the database)

Specified by:
addInitializedDetachedCollection in interface PersistenceContext
Throws:
HibernateException

addInitializedCollection

public CollectionEntry addInitializedCollection(CollectionPersister persister,
                                                PersistentCollection collection,
                                                Serializable id)
                                         throws HibernateException
add a collection we just pulled out of the cache (does not need initializing)

Specified by:
addInitializedCollection in interface PersistenceContext
Throws:
HibernateException

getCollection

public PersistentCollection getCollection(CollectionKey collectionKey)
Get the collection instance associated with the CollectionKey

Specified by:
getCollection in interface PersistenceContext

addNonLazyCollection

public void addNonLazyCollection(PersistentCollection collection)
Register a collection for non-lazy loading at the end of the two-phase load

Specified by:
addNonLazyCollection in interface PersistenceContext

initializeNonLazyCollections

public void initializeNonLazyCollections()
                                  throws HibernateException
Force initialization of all non-lazy collections encountered during the current two-phase load (actually, this is a no-op, unless this is the "outermost" load)

Specified by:
initializeNonLazyCollections in interface PersistenceContext
Throws:
HibernateException

getCollectionHolder

public PersistentCollection getCollectionHolder(Object array)
Get the PersistentCollection object for an array

Specified by:
getCollectionHolder in interface PersistenceContext

addCollectionHolder

public void addCollectionHolder(PersistentCollection holder)
Register a PersistentCollection object for an array. Associates a holder with an array - MUST be called after loading array, since the array instance is not created until endLoad().

Specified by:
addCollectionHolder in interface PersistenceContext

removeCollectionHolder

public PersistentCollection removeCollectionHolder(Object array)
Description copied from interface: PersistenceContext
Remove the mapping of collection to holder during eviction of the owning entity

Specified by:
removeCollectionHolder in interface PersistenceContext

getSnapshot

public Serializable getSnapshot(PersistentCollection coll)
Get the snapshot of the pre-flush collection state

Specified by:
getSnapshot in interface PersistenceContext

getCollectionEntryOrNull

public CollectionEntry getCollectionEntryOrNull(Object collection)
Get the collection entry for a collection passed to filter, which might be a collection wrapper, an array, or an unwrapped collection. Return null if there is no entry.

Specified by:
getCollectionEntryOrNull in interface PersistenceContext

getProxy

public Object getProxy(EntityKey key)
Get an existing proxy by key

Specified by:
getProxy in interface PersistenceContext

addProxy

public void addProxy(EntityKey key,
                     Object proxy)
Add a proxy to the session cache

Specified by:
addProxy in interface PersistenceContext

removeProxy

public Object removeProxy(EntityKey key)
Remove a proxy from the session cache

Specified by:
removeProxy in interface PersistenceContext

getNullifiableEntityKeys

public HashSet getNullifiableEntityKeys()
Retrieve the set of EntityKeys representing nullifiable references

Specified by:
getNullifiableEntityKeys in interface PersistenceContext

getEntitiesByKey

public Map getEntitiesByKey()
Description copied from interface: PersistenceContext
Get the mapping from key value to entity instance

Specified by:
getEntitiesByKey in interface PersistenceContext

getEntityEntries

public Map getEntityEntries()
Description copied from interface: PersistenceContext
Get the mapping from entity instance to entity entry

Specified by:
getEntityEntries in interface PersistenceContext

getCollectionEntries

public Map getCollectionEntries()
Description copied from interface: PersistenceContext
Get the mapping from collection instance to collection entry

Specified by:
getCollectionEntries in interface PersistenceContext

getCollectionsByKey

public Map getCollectionsByKey()
Description copied from interface: PersistenceContext
Get the mapping from collection key to collection instance

Specified by:
getCollectionsByKey in interface PersistenceContext

getCascadeLevel

public int getCascadeLevel()
Do we already know that the entity does not exist in the database?

Specified by:
getCascadeLevel in interface PersistenceContext

incrementCascadeLevel

public int incrementCascadeLevel()
Description copied from interface: PersistenceContext
Called before cascading

Specified by:
incrementCascadeLevel in interface PersistenceContext

decrementCascadeLevel

public int decrementCascadeLevel()
Description copied from interface: PersistenceContext
Called after cascading

Specified by:
decrementCascadeLevel in interface PersistenceContext

isFlushing

public boolean isFlushing()
Description copied from interface: PersistenceContext
Is a flush cycle currently in process?

Specified by:
isFlushing in interface PersistenceContext

setFlushing

public void setFlushing(boolean flushing)
Description copied from interface: PersistenceContext
Called before and after the flushcycle

Specified by:
setFlushing in interface PersistenceContext

beforeLoad

public void beforeLoad()
Call this before begining a two-phase load

Specified by:
beforeLoad in interface PersistenceContext

afterLoad

public void afterLoad()
Call this after finishing a two-phase load

Specified by:
afterLoad in interface PersistenceContext

toString

public String toString()
Returns a string representation of the object.

Specified by:
toString in interface PersistenceContext
Returns:
a string representation of the object.

getOwnerId

public Serializable getOwnerId(String entity,
                               String property,
                               Object childEntity,
                               Map mergeMap)
Search the persistence context for an owner for the child object, given a collection role. If mergeMap is non-null, also check the detached graph being merged for a parent.

Specified by:
getOwnerId in interface PersistenceContext

getIndexInOwner

public Object getIndexInOwner(String entity,
                              String property,
                              Object childEntity,
                              Map mergeMap)
Search the persistence context for an index of the child object, given a collection role

Specified by:
getIndexInOwner in interface PersistenceContext

addNullProperty

public void addNullProperty(EntityKey ownerKey,
                            String propertyName)
Record the fact that the association belonging to the keyed entity is null.

Specified by:
addNullProperty in interface PersistenceContext

isPropertyNull

public boolean isPropertyNull(EntityKey ownerKey,
                              String propertyName)
Is the association property belonging to the keyed entity null?

Specified by:
isPropertyNull in interface PersistenceContext

setReadOnly

public void setReadOnly(Object entity,
                        boolean readOnly)
Description copied from interface: PersistenceContext
Set the object to read only and discard it's snapshot

Specified by:
setReadOnly in interface PersistenceContext

replaceDelayedEntityIdentityInsertKeys

public void replaceDelayedEntityIdentityInsertKeys(EntityKey oldKey,
                                                   Serializable generatedId)
Specified by:
replaceDelayedEntityIdentityInsertKeys in interface PersistenceContext

serialize

public void serialize(ObjectOutputStream oos)
               throws IOException
Used by the owning session to explicitly control serialization of the persistence context.

Parameters:
oos - The stream to which the persistence context should get written
Throws:
IOException

deserialize

public static StatefulPersistenceContext deserialize(ObjectInputStream ois,
                                                     SessionImplementor session)
                                              throws IOException,
                                                     ClassNotFoundException
Throws:
IOException
ClassNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Status (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class Status

java.lang.Object
    extended by org.hibernate.engine.Status
All Implemented Interfaces:
Serializable
public final class Status
extends Object
implements Serializable

Represents the status of an entity with respect to this session. These statuses are for internal book-keeping only and are not intended to represent any notion that is visible to the _application_.

See Also:
Serialized Form

Field Summary
static Status | DELETED
static Status | GONE
static Status | LOADING
static Status | MANAGED
static Status | READ_ONLY
static Status | SAVING
Method Summary
static Status | parse(String name)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

MANAGED

public static final Status MANAGED

READ_ONLY

public static final Status READ_ONLY

DELETED

public static final Status DELETED

GONE

public static final Status GONE

LOADING

public static final Status LOADING

SAVING

public static final Status SAVING
Method Detail

toString

public String toString()

parse

public static Status parse(String name)
                    throws InvalidObjectException
Throws:
InvalidObjectException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubselectFetch (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class SubselectFetch

java.lang.Object
    extended by org.hibernate.engine.SubselectFetch
public class SubselectFetch
extends Object

Author:
Gavin King

Constructor Summary
SubselectFetch(String alias, Loadable loadable, QueryParameters queryParameters, Set resultingEntityKeys, Map namedParameterLocMap)
Method Summary
Map | getNamedParameterLocMap()
QueryParameters | getQueryParameters()
Set | getResult() Get the Set of EntityKeys
String | toString()
String | toSubselectString(String ukname)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SubselectFetch

public SubselectFetch(String alias,
                      Loadable loadable,
                      QueryParameters queryParameters,
                      Set resultingEntityKeys,
                      Map namedParameterLocMap)
Method Detail

getQueryParameters

public QueryParameters getQueryParameters()

getResult

public Set getResult()
Get the Set of EntityKeys

toSubselectString

public String toSubselectString(String ukname)

toString

public String toString()

getNamedParameterLocMap

public Map getNamedParameterLocMap()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransactionHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class TransactionHelper

java.lang.Object
    extended by org.hibernate.engine.TransactionHelper
Direct Known Subclasses:
MultipleHiLoPerTableGenerator, TableGenerator
public abstract class TransactionHelper
extends Object

Allows work to be done outside the current transaction, by suspending it, and performing work in a new transaction

Author:
Emmanuel Bernard

Constructor Summary
TransactionHelper()
Method Summary
protected abstract Serializable | doWorkInCurrentTransaction(Connection conn, String sql) The work to be done
Serializable | doWorkInNewTransaction(SessionImplementor session) Suspend the current transaction and perform work in a new transaction
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TransactionHelper

public TransactionHelper()
Method Detail

doWorkInCurrentTransaction

protected abstract Serializable doWorkInCurrentTransaction(Connection conn,
                                                           String sql)
                                                    throws SQLException
The work to be done

Throws:
SQLException

doWorkInNewTransaction

public Serializable doWorkInNewTransaction(SessionImplementor session)
                                    throws HibernateException
Suspend the current transaction and perform work in a new transaction

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TwoPhaseLoad (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class TwoPhaseLoad

java.lang.Object
    extended by org.hibernate.engine.TwoPhaseLoad
public final class TwoPhaseLoad
extends Object

Functionality relating to Hibernate's two-phase loading process, that may be reused by persisters that do not use the Loader framework

Author:
Gavin King

Method Summary
static void | addUninitializedCachedEntity(EntityKey key, Object object, EntityPersister persister, LockMode lockMode, boolean lazyPropertiesAreUnfetched, Object version, SessionImplementor session)
static void | addUninitializedEntity(EntityKey key, Object object, EntityPersister persister, LockMode lockMode, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Add an uninitialized instance of an entity class, as a placeholder to ensure object identity.
static void | initializeEntity(Object entity, boolean readOnly, SessionImplementor session, PreLoadEvent preLoadEvent, PostLoadEvent postLoadEvent) Perform the second step of 2-phase load.
static void | postHydrate(EntityPersister persister, Serializable id, Object[] values, Object rowId, Object object, LockMode lockMode, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Register the "hydrated" state of an entity instance, after the first step of 2-phase loading.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

postHydrate

public static void postHydrate(EntityPersister persister,
                               Serializable id,
                               Object[] values,
                               Object rowId,
                               Object object,
                               LockMode lockMode,
                               boolean lazyPropertiesAreUnfetched,
                               SessionImplementor session)
                        throws HibernateException
Register the "hydrated" state of an entity instance, after the first step of 2-phase loading. Add the "hydrated state" (an array) of an uninitialized entity to the session. We don't try to resolve any associations yet, because there might be other entities waiting to be read from the JDBC result set we are currently processing

Throws:
HibernateException

initializeEntity

public static void initializeEntity(Object entity,
                                    boolean readOnly,
                                    SessionImplementor session,
                                    PreLoadEvent preLoadEvent,
                                    PostLoadEvent postLoadEvent)
                             throws HibernateException
Perform the second step of 2-phase load. Fully initialize the entity instance. After processing a JDBC result set, we "resolve" all the associations between the entities which were instantiated and had their state "hydrated" into an array

Throws:
HibernateException

addUninitializedEntity

public static void addUninitializedEntity(EntityKey key,
                                          Object object,
                                          EntityPersister persister,
                                          LockMode lockMode,
                                          boolean lazyPropertiesAreUnfetched,
                                          SessionImplementor session)
Add an uninitialized instance of an entity class, as a placeholder to ensure object identity. Must be called before postHydrate(). Create a "temporary" entry for a newly instantiated entity. The entity is uninitialized, but we need the mapping from id to instance in order to guarantee uniqueness.

addUninitializedCachedEntity

public static void addUninitializedCachedEntity(EntityKey key,
                                                Object object,
                                                EntityPersister persister,
                                                LockMode lockMode,
                                                boolean lazyPropertiesAreUnfetched,
                                                Object version,
                                                SessionImplementor session)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TypedValue (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class TypedValue

java.lang.Object
    extended by org.hibernate.engine.TypedValue
All Implemented Interfaces:
Serializable
public final class TypedValue
extends Object
implements Serializable

An ordered pair of a value and its Hibernate type.

Author:
Gavin King
See Also:
Type, Serialized Form

Constructor Summary
TypedValue(Type type, Object value, EntityMode entityMode)
Method Summary
boolean | equals(Object other)
Type | getType()
Object | getValue()
int | hashCode()
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

TypedValue

public TypedValue(Type type,
                  Object value,
                  EntityMode entityMode)
Method Detail

getValue

public Object getValue()

getType

public Type getType()

toString

public String toString()

hashCode

public int hashCode()

equals

public boolean equals(Object other)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnsavedValueFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class UnsavedValueFactory

java.lang.Object
    extended by org.hibernate.engine.UnsavedValueFactory
public class UnsavedValueFactory
extends Object

Author:
Gavin King

Constructor Summary
UnsavedValueFactory()
Method Summary
static IdentifierValue | getUnsavedIdentifierValue(String unsavedValue, Getter identifierGetter, Type identifierType, Constructor constructor) Return an IdentifierValue for the specified unsaved-value.
static VersionValue | getUnsavedVersionValue(String versionUnsavedValue, Getter versionGetter, VersionType versionType, Constructor constructor)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnsavedValueFactory

public UnsavedValueFactory()
Method Detail

getUnsavedIdentifierValue

public static IdentifierValue getUnsavedIdentifierValue(String unsavedValue,
                                                        Getter identifierGetter,
                                                        Type identifierType,
                                                        Constructor constructor)
Return an IdentifierValue for the specified unsaved-value. If none is specified, guess the unsaved value by instantiating a test instance of the class and reading it's id property, or if that is not possible, using the java default value for the type

getUnsavedVersionValue

public static VersionValue getUnsavedVersionValue(String versionUnsavedValue,
                                                  Getter versionGetter,
                                                  VersionType versionType,
                                                  Constructor constructor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Versioning (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class Versioning

java.lang.Object
    extended by org.hibernate.engine.Versioning
public final class Versioning
extends Object

Utility methods for managing versions and timestamps

Author:
Gavin King

Field Summary
static int | OPTIMISTIC_LOCK_ALL
static int | OPTIMISTIC_LOCK_DIRTY
static int | OPTIMISTIC_LOCK_NONE
static int | OPTIMISTIC_LOCK_VERSION
Method Summary
static Object | getVersion(Object[] fields, EntityPersister persister) Get the version number of the given instance state snapshot
static Object | increment(Object version, VersionType versionType, SessionImplementor session) Increment the given version number
static boolean | isVersionIncrementRequired(int[] dirtyProperties, boolean hasDirtyCollections, boolean[] propertyVersionability) Do we need to increment the version number, given the dirty properties?
static boolean | seedVersion(Object[] fields, int versionProperty, VersionType versionType, SessionImplementor session) Seed the given instance state snapshot with an initial version number
static void | setVersion(Object[] fields, Object version, EntityPersister persister) Set the version number of the given instance state snapshot
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

OPTIMISTIC_LOCK_NONE

public static final int OPTIMISTIC_LOCK_NONE
See Also:
Constant Field Values

OPTIMISTIC_LOCK_ALL

public static final int OPTIMISTIC_LOCK_ALL
See Also:
Constant Field Values

OPTIMISTIC_LOCK_DIRTY

public static final int OPTIMISTIC_LOCK_DIRTY
See Also:
Constant Field Values

OPTIMISTIC_LOCK_VERSION

public static final int OPTIMISTIC_LOCK_VERSION
See Also:
Constant Field Values
Method Detail

increment

public static Object increment(Object version,
                               VersionType versionType,
                               SessionImplementor session)
Increment the given version number

seedVersion

public static boolean seedVersion(Object[] fields,
                                  int versionProperty,
                                  VersionType versionType,
                                  SessionImplementor session)
Seed the given instance state snapshot with an initial version number

setVersion

public static void setVersion(Object[] fields,
                              Object version,
                              EntityPersister persister)
Set the version number of the given instance state snapshot

getVersion

public static Object getVersion(Object[] fields,
                                EntityPersister persister)
                         throws HibernateException
Get the version number of the given instance state snapshot

Throws:
HibernateException

isVersionIncrementRequired

public static boolean isVersionIncrementRequired(int[] dirtyProperties,
                                                 boolean hasDirtyCollections,
                                                 boolean[] propertyVersionability)
Do we need to increment the version number, given the dirty properties?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VersionValue (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine
Class VersionValue

java.lang.Object
    extended by org.hibernate.engine.VersionValue
public class VersionValue
extends Object

A strategy for determining if a version value is an version of a new transient instance or a previously persistent transient instance. The strategy is determined by the unsaved-value attribute in the mapping file.

Author:
Gavin King

Field Summary
static VersionValue | NEGATIVE Assume the transient instance is newly instantiated if the version is negative, otherwise assume it is a detached instance.
static VersionValue | NULL Assume the transient instance is newly instantiated if the version is null, otherwise assume it is a detached instance.
static VersionValue | UNDEFINED Assume the transient instance is newly instantiated if the version is null, otherwise defer to the identifier unsaved-value.
Constructor Summary
protected | VersionValue()
 | VersionValue(Object value) Assume the transient instance is newly instantiated if its version is null or equal to value
Method Summary
Object | getDefaultValue(Object currentValue)
Boolean | isUnsaved(Object version) Does the given version belong to a new instance?
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NULL

public static final VersionValue NULL
Assume the transient instance is newly instantiated if the version is null, otherwise assume it is a detached instance.

UNDEFINED

public static final VersionValue UNDEFINED
Assume the transient instance is newly instantiated if the version is null, otherwise defer to the identifier unsaved-value.

NEGATIVE

public static final VersionValue NEGATIVE
Assume the transient instance is newly instantiated if the version is negative, otherwise assume it is a detached instance.

Constructor Detail

VersionValue

protected VersionValue()

VersionValue

public VersionValue(Object value)
Assume the transient instance is newly instantiated if its version is null or equal to value

Parameters:
value - value to compare to
Method Detail

isUnsaved

public Boolean isUnsaved(Object version)
                  throws MappingException
Does the given version belong to a new instance?

Parameters:
version - version to check
Returns:
true is unsaved, false is saved, null is undefined
Throws:
MappingException

getDefaultValue

public Object getDefaultValue(Object currentValue)

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.engine.query (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.engine.query

Interface Summary
ParameterParser.Recognizer

Class Summary
FilterQueryPlan | Extends an HQLQueryPlan to maintain a reference to the collection-role name being filtered.
HQLQueryPlan | Defines a query execution plan for an HQL query (or filter).
NamedParameterDescriptor | Descriptor regarding a named parameter.
NativeSQLQueryPlan | Defines a query execution plan for a native-SQL query.
OrdinalParameterDescriptor |
ParameterMetadata | Encapsulates metadata about parameters encountered within a query.
ParameterParser | The single available method ParameterParser.parse(java.lang.String, org.hibernate.engine.query.ParameterParser.Recognizer) is responsible for parsing a query string and recognizing tokens in relation to parameters (either named, JPA-style, or ordinal) and providing callbacks about such recognitions.
ParamLocationRecognizer | Implements a parameter parser recognizer specifically for the purpose of journaling parameter locations.
ParamLocationRecognizer.NamedParameterDescription |
QueryMetadata | Defines metadata regarding a translated HQL or native-SQL query.
QueryPlanCache | Acts as a cache for compiled query plans, as well as query-parameter metadata.
ReturnMetadata |


org.hibernate.engine.query Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.engine.query

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.engine.query.HQLQueryPlan (implements java.io.Serializable)
      • class org.hibernate.engine.query.FilterQueryPlan (implements java.io.Serializable)
    • class org.hibernate.engine.query.NamedParameterDescriptor (implements java.io.Serializable)
    • class org.hibernate.engine.query.NativeSQLQueryPlan (implements java.io.Serializable)
    • class org.hibernate.engine.query.OrdinalParameterDescriptor (implements java.io.Serializable)
    • class org.hibernate.engine.query.ParameterMetadata (implements java.io.Serializable)
    • class org.hibernate.engine.query.ParameterParser
    • class org.hibernate.engine.query.ParamLocationRecognizer (implements org.hibernate.engine.query.ParameterParser.Recognizer)
    • class org.hibernate.engine.query.ParamLocationRecognizer.NamedParameterDescription
    • class org.hibernate.engine.query.QueryMetadata (implements java.io.Serializable)
    • class org.hibernate.engine.query.QueryPlanCache (implements java.io.Serializable)
    • class org.hibernate.engine.query.ReturnMetadata (implements java.io.Serializable)

Interface Hierarchy

  • interface org.hibernate.engine.query.ParameterParser.Recognizer


Uses of Package org.hibernate.engine.query (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.engine.query

Packages that use org.hibernate.engine.query
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader.custom.sql |

Classes in org.hibernate.engine.query used by org.hibernate.engine
QueryPlanCache
Acts as a cache for compiled query plans, as well as query-parameter metadata.

Classes in org.hibernate.engine.query used by org.hibernate.engine.query
FilterQueryPlan
Extends an HQLQueryPlan to maintain a reference to the collection-role name being filtered.
HQLQueryPlan
Defines a query execution plan for an HQL query (or filter).
NamedParameterDescriptor
Descriptor regarding a named parameter.
NativeSQLQueryPlan
Defines a query execution plan for a native-SQL query.
OrdinalParameterDescriptor
ParameterMetadata
Encapsulates metadata about parameters encountered within a query.
ParameterParser.Recognizer
ParamLocationRecognizer
Implements a parameter parser recognizer specifically for the purpose of journaling parameter locations.
ReturnMetadata

Classes in org.hibernate.engine.query used by org.hibernate.impl
HQLQueryPlan
Defines a query execution plan for an HQL query (or filter).
NativeSQLQueryPlan
Defines a query execution plan for a native-SQL query.
ParameterMetadata
Encapsulates metadata about parameters encountered within a query.
QueryPlanCache
Acts as a cache for compiled query plans, as well as query-parameter metadata.

Classes in org.hibernate.engine.query used by org.hibernate.loader.custom.sql
ParameterParser.Recognizer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


FilterQueryPlan (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Class FilterQueryPlan

java.lang.Object
    extended by org.hibernate.engine.query.HQLQueryPlan
        extended by org.hibernate.engine.query.FilterQueryPlan
All Implemented Interfaces:
Serializable
public class FilterQueryPlan
extends HQLQueryPlan
implements Serializable

Extends an HQLQueryPlan to maintain a reference to the collection-role name being filtered.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
FilterQueryPlan(String hql, String collectionRole, boolean shallow, Map enabledFilters, SessionFactoryImplementor factory)
Method Summary
 String getCollectionRole()
Methods inherited from class org.hibernate.engine.query.HQLQueryPlan
getEnabledFilterNames, getParameterMetadata, getQuerySpaces, getReturnMetadata, getSourceQuery, getSqlStrings, getTranslators, getUtilizedFilterNames, isShallow, performExecuteUpdate, performIterate, performList, performScroll
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FilterQueryPlan

public FilterQueryPlan(String hql,
                       String collectionRole,
                       boolean shallow,
                       Map enabledFilters,
                       SessionFactoryImplementor factory)
Method Detail

getCollectionRole

public String getCollectionRole()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HQLQueryPlan (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Class HQLQueryPlan

java.lang.Object
    extended by org.hibernate.engine.query.HQLQueryPlan
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
FilterQueryPlan
public class HQLQueryPlan
extends Object
implements Serializable

Defines a query execution plan for an HQL query (or filter).

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
 | HQLQueryPlan(String hql, boolean shallow, Map enabledFilters, SessionFactoryImplementor factory)
protected | HQLQueryPlan(String hql, String collectionRole, boolean shallow, Map enabledFilters, SessionFactoryImplementor factory)
Method Summary
Set | getEnabledFilterNames()
ParameterMetadata | getParameterMetadata()
Set | getQuerySpaces()
ReturnMetadata | getReturnMetadata()
String | getSourceQuery()
String[] | getSqlStrings()
QueryTranslator[] | getTranslators()
Set | getUtilizedFilterNames()
boolean | isShallow()
int | performExecuteUpdate(QueryParameters queryParameters, SessionImplementor session)
Iterator | performIterate(QueryParameters queryParameters, EventSource session)
List | performList(QueryParameters queryParameters, SessionImplementor session)
ScrollableResults | performScroll(QueryParameters queryParameters, SessionImplementor session)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HQLQueryPlan

public HQLQueryPlan(String hql,
                    boolean shallow,
                    Map enabledFilters,
                    SessionFactoryImplementor factory)

HQLQueryPlan

protected HQLQueryPlan(String hql,
                       String collectionRole,
                       boolean shallow,
                       Map enabledFilters,
                       SessionFactoryImplementor factory)
Method Detail

getSourceQuery

public String getSourceQuery()

getQuerySpaces

public Set getQuerySpaces()

getParameterMetadata

public ParameterMetadata getParameterMetadata()

getReturnMetadata

public ReturnMetadata getReturnMetadata()

getEnabledFilterNames

public Set getEnabledFilterNames()

getSqlStrings

public String[] getSqlStrings()

getUtilizedFilterNames

public Set getUtilizedFilterNames()

isShallow

public boolean isShallow()

performList

public List performList(QueryParameters queryParameters,
                        SessionImplementor session)
                 throws HibernateException
Throws:
HibernateException

performIterate

public Iterator performIterate(QueryParameters queryParameters,
                               EventSource session)
                        throws HibernateException
Throws:
HibernateException

performScroll

public ScrollableResults performScroll(QueryParameters queryParameters,
                                       SessionImplementor session)
                                throws HibernateException
Throws:
HibernateException

performExecuteUpdate

public int performExecuteUpdate(QueryParameters queryParameters,
                                SessionImplementor session)
                         throws HibernateException
Throws:
HibernateException

getTranslators

public QueryTranslator[] getTranslators()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamedParameterDescriptor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Class NamedParameterDescriptor

java.lang.Object
    extended by org.hibernate.engine.query.NamedParameterDescriptor
All Implemented Interfaces:
Serializable
public class NamedParameterDescriptor
extends Object
implements Serializable

Descriptor regarding a named parameter.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
NamedParameterDescriptor(String name, Type expectedType, int[] sourceLocations, boolean jpaStyle)
Method Summary
Type | getExpectedType()
String | getName()
int[] | getSourceLocations()
boolean | isJpaStyle()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NamedParameterDescriptor

public NamedParameterDescriptor(String name,
                                Type expectedType,
                                int[] sourceLocations,
                                boolean jpaStyle)
Method Detail

getName

public String getName()

getExpectedType

public Type getExpectedType()

getSourceLocations

public int[] getSourceLocations()

isJpaStyle

public boolean isJpaStyle()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NativeSQLQueryPlan (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Class NativeSQLQueryPlan

java.lang.Object
    extended by org.hibernate.engine.query.NativeSQLQueryPlan
All Implemented Interfaces:
Serializable
public class NativeSQLQueryPlan
extends Object
implements Serializable

Defines a query execution plan for a native-SQL query.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
NativeSQLQueryPlan(NativeSQLQuerySpecification specification, SessionFactoryImplementor factory)
Method Summary
protected void | coordinateSharedCacheCleanup(SessionImplementor session)
SQLCustomQuery | getCustomQuery()
String | getSourceQuery()
int | performExecuteUpdate(QueryParameters queryParameters, SessionImplementor session)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NativeSQLQueryPlan

public NativeSQLQueryPlan(NativeSQLQuerySpecification specification,
                          SessionFactoryImplementor factory)
Method Detail

getSourceQuery

public String getSourceQuery()

getCustomQuery

public SQLCustomQuery getCustomQuery()

coordinateSharedCacheCleanup

protected void coordinateSharedCacheCleanup(SessionImplementor session)

performExecuteUpdate

public int performExecuteUpdate(QueryParameters queryParameters,
                                SessionImplementor session)
                         throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrdinalParameterDescriptor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Class OrdinalParameterDescriptor

java.lang.Object
    extended by org.hibernate.engine.query.OrdinalParameterDescriptor
All Implemented Interfaces:
Serializable
public class OrdinalParameterDescriptor
extends Object
implements Serializable

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
OrdinalParameterDescriptor(int ordinalPosition, Type expectedType, int sourceLocation)
Method Summary
Type | getExpectedType()
int | getOrdinalPosition()
int | getSourceLocation()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OrdinalParameterDescriptor

public OrdinalParameterDescriptor(int ordinalPosition,
                                  Type expectedType,
                                  int sourceLocation)
Method Detail

getOrdinalPosition

public int getOrdinalPosition()

getExpectedType

public Type getExpectedType()

getSourceLocation

public int getSourceLocation()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterMetadata (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Class ParameterMetadata

java.lang.Object
    extended by org.hibernate.engine.query.ParameterMetadata
All Implemented Interfaces:
Serializable
public class ParameterMetadata
extends Object
implements Serializable

Encapsulates metadata about parameters encountered within a query.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
ParameterMetadata(OrdinalParameterDescriptor[] ordinalDescriptors, Map namedDescriptorMap)
Instantiates a ParameterMetadata container.
Method Summary
NamedParameterDescriptor | getNamedParameterDescriptor(String name)
Type | getNamedParameterExpectedType(String name)
Set | getNamedParameterNames()
int[] | getNamedParameterSourceLocations(String name)
int | getOrdinalParameterCount()
OrdinalParameterDescriptor | getOrdinalParameterDescriptor(int position)
Type | getOrdinalParameterExpectedType(int position)
int | getOrdinalParameterSourceLocation(int position)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParameterMetadata

public ParameterMetadata(OrdinalParameterDescriptor[] ordinalDescriptors,
                         Map namedDescriptorMap)
Instantiates a ParameterMetadata container.

Parameters:
ordinalDescriptors -
namedDescriptorMap -
Method Detail

getOrdinalParameterCount

public int getOrdinalParameterCount()

getOrdinalParameterDescriptor

public OrdinalParameterDescriptor getOrdinalParameterDescriptor(int position)

getOrdinalParameterExpectedType

public Type getOrdinalParameterExpectedType(int position)

getOrdinalParameterSourceLocation

public int getOrdinalParameterSourceLocation(int position)

getNamedParameterNames

public Set getNamedParameterNames()

getNamedParameterDescriptor

public NamedParameterDescriptor getNamedParameterDescriptor(String name)

getNamedParameterExpectedType

public Type getNamedParameterExpectedType(String name)

getNamedParameterSourceLocations

public int[] getNamedParameterSourceLocations(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Class ParameterParser

java.lang.Object
    extended by org.hibernate.engine.query.ParameterParser
public class ParameterParser
extends Object

The single available method parse(java.lang.String, org.hibernate.engine.query.ParameterParser.Recognizer) is responsible for parsing a query string and recognizing tokens in relation to parameters (either named, JPA-style, or ordinal) and providing callbacks about such recognitions.

Author:
Steve Ebersole

Nested Class Summary
static interface ParameterParser.Recognizer
Method Summary
static void parse(String sqlString, ParameterParser.Recognizer recognizer)
Performs the actual parsing and tokenizing of the query string making appropriate callbacks to the given recognizer upon recognition of the various tokens.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

parse

public static void parse(String sqlString,
                         ParameterParser.Recognizer recognizer)
                  throws QueryException
Performs the actual parsing and tokenizing of the query string making appropriate callbacks to the given recognizer upon recognition of the various tokens.

Note that currently, this only knows how to deal with a single output parameter (for callable statements). If we later add support for multiple output params, this, obviously, needs to change.

Parameters:
sqlString - The string to be parsed/tokenized.
recognizer - The thing which handles recognition events.
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterParser.Recognizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Interface ParameterParser.Recognizer

All Known Implementing Classes:
ParamLocationRecognizer, SQLQueryParser.ParameterSubstitutionRecognizer
Enclosing interface:
ParameterParser
public static interface ParameterParser.Recognizer

Method Summary
void | jpaPositionalParameter(String name, int position)
void | namedParameter(String name, int position)
void | ordinalParameter(int position)
void | other(char character)
void | outParameter(int position)

Method Detail

outParameter

public void outParameter(int position)

ordinalParameter

public void ordinalParameter(int position)

namedParameter

public void namedParameter(String name,
                           int position)

jpaPositionalParameter

public void jpaPositionalParameter(String name,
                                   int position)

other

public void other(char character)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ParamLocationRecognizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Class ParamLocationRecognizer

java.lang.Object
    extended by org.hibernate.engine.query.ParamLocationRecognizer
All Implemented Interfaces:
ParameterParser.Recognizer
public class ParamLocationRecognizer
extends Object
implements ParameterParser.Recognizer

Implements a parameter parser recognizer specifically for the purpose of journaling parameter locations.

Author:
Steve Ebersole

Nested Class Summary
static class ParamLocationRecognizer.NamedParameterDescription
Constructor Summary
ParamLocationRecognizer()
Method Summary
Map | getNamedParameterDescriptionMap() Returns the map of named parameter locations.
List | getOrdinalParameterLocationList() Returns the list of ordinal parameter locations.
void | jpaPositionalParameter(String name, int position)
void | namedParameter(String name, int position)
void | ordinalParameter(int position)
void | other(char character)
void | outParameter(int position)
static ParamLocationRecognizer | parseLocations(String query) Convenience method for creating a param location recognizer and initiating the parse.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParamLocationRecognizer

public ParamLocationRecognizer()
Method Detail

parseLocations

public static ParamLocationRecognizer parseLocations(String query)
Convenience method for creating a param location recognizer and initiating the parse.

Parameters:
query - The query to be parsed for parameter locations.
Returns:
The generated recognizer, with journaled location info.

getNamedParameterDescriptionMap

public Map getNamedParameterDescriptionMap()
Returns the map of named parameter locations. The map is keyed by parameter name; the corresponding value is a (@link NamedParameterDescription}.

Returns:
The map of named parameter locations.

getOrdinalParameterLocationList

public List getOrdinalParameterLocationList()
Returns the list of ordinal parameter locations. The list elements are Integers, representing the location for that given ordinal. Thus getOrdinalParameterLocationList().elementAt(n) represents the location for the nth parameter.

Returns:
The list of ordinal parameter locations.

ordinalParameter

public void ordinalParameter(int position)
Specified by:
ordinalParameter in interface ParameterParser.Recognizer

namedParameter

public void namedParameter(String name,
                           int position)
Specified by:
namedParameter in interface ParameterParser.Recognizer

jpaPositionalParameter

public void jpaPositionalParameter(String name,
                                   int position)
Specified by:
jpaPositionalParameter in interface ParameterParser.Recognizer

other

public void other(char character)
Specified by:
other in interface ParameterParser.Recognizer

outParameter

public void outParameter(int position)
Specified by:
outParameter in interface ParameterParser.Recognizer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParamLocationRecognizer.NamedParameterDescription (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Class ParamLocationRecognizer.NamedParameterDescription

java.lang.Object
    extended by org.hibernate.engine.query.ParamLocationRecognizer.NamedParameterDescription
Enclosing class:
ParamLocationRecognizer
public static class ParamLocationRecognizer.NamedParameterDescription
extends Object

Constructor Summary
ParamLocationRecognizer.NamedParameterDescription(boolean jpaStyle)
Method Summary
int[] | buildPositionsArray()
boolean | isJpaStyle()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParamLocationRecognizer.NamedParameterDescription

public ParamLocationRecognizer.NamedParameterDescription(boolean jpaStyle)
Method Detail

isJpaStyle

public boolean isJpaStyle()

buildPositionsArray

public int[] buildPositionsArray()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryMetadata (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Class QueryMetadata

java.lang.Object
    extended by org.hibernate.engine.query.QueryMetadata
All Implemented Interfaces:
Serializable
public class QueryMetadata
extends Object
implements Serializable

Defines metadata regarding a translated HQL or native-SQL query.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
QueryMetadata(String sourceQuery, ParameterMetadata parameterMetadata, String[] returnAliases, Type[] returnTypes, Set querySpaces)
Method Summary
ParameterMetadata | getParameterMetadata()
Set | getQuerySpaces() The set of query spaces affected by this source query.
String[] | getReturnAliases() Return source query select clause aliases (if any)
Type[] | getReturnTypes() An array of types describing the returns of the source query.
String | getSourceQuery() Get the source HQL or native-SQL query.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryMetadata

public QueryMetadata(String sourceQuery,
                     ParameterMetadata parameterMetadata,
                     String[] returnAliases,
                     Type[] returnTypes,
                     Set querySpaces)
Method Detail

getSourceQuery

public String getSourceQuery()
Get the source HQL or native-SQL query.

Returns:
The source query.

getParameterMetadata

public ParameterMetadata getParameterMetadata()

getReturnAliases

public String[] getReturnAliases()
Return source query select clause aliases (if any)

Returns:
an array of aliases as strings.

getReturnTypes

public Type[] getReturnTypes()
An array of types describing the returns of the source query.

Returns:
The return type array.

getQuerySpaces

public Set getQuerySpaces()
The set of query spaces affected by this source query.

Returns:
The set of query spaces.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryPlanCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Class QueryPlanCache

java.lang.Object
    extended by org.hibernate.engine.query.QueryPlanCache
All Implemented Interfaces:
Serializable
public class QueryPlanCache
extends Object
implements Serializable

Acts as a cache for compiled query plans, as well as query-parameter metadata.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
QueryPlanCache(SessionFactoryImplementor factory)
Method Summary
FilterQueryPlan | getFilterQueryPlan(String filterString, String collectionRole, boolean shallow, Map enabledFilters)
HQLQueryPlan | getHQLQueryPlan(String queryString, boolean shallow, Map enabledFilters)
NativeSQLQueryPlan | getNativeSQLQueryPlan(NativeSQLQuerySpecification spec)
ParameterMetadata | getSQLParameterMetadata(String query)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryPlanCache

public QueryPlanCache(SessionFactoryImplementor factory)
Method Detail

getSQLParameterMetadata

public ParameterMetadata getSQLParameterMetadata(String query)

getHQLQueryPlan

public HQLQueryPlan getHQLQueryPlan(String queryString,
                                    boolean shallow,
                                    Map enabledFilters)
                             throws QueryException,
                                    MappingException
Throws:
QueryException
MappingException

getFilterQueryPlan

public FilterQueryPlan getFilterQueryPlan(String filterString,
                                          String collectionRole,
                                          boolean shallow,
                                          Map enabledFilters)
                                   throws QueryException,
                                          MappingException
Throws:
QueryException
MappingException

getNativeSQLQueryPlan

public NativeSQLQueryPlan getNativeSQLQueryPlan(NativeSQLQuerySpecification spec)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReturnMetadata (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query
Class ReturnMetadata

java.lang.Object
    extended by org.hibernate.engine.query.ReturnMetadata
All Implemented Interfaces:
Serializable
public class ReturnMetadata
extends Object
implements Serializable

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
ReturnMetadata(String[] returnAliases, Type[] returnTypes)
Method Summary
String[] | getReturnAliases()
Type[] | getReturnTypes()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReturnMetadata

public ReturnMetadata(String[] returnAliases,
                      Type[] returnTypes)
Method Detail

getReturnAliases

public String[] getReturnAliases()

getReturnTypes

public Type[] getReturnTypes()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.engine.query.sql (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.engine.query.sql

Interface Summary
NativeSQLQueryReturn Describes a return in a native SQL query.

Class Summary
NativeSQLQueryCollectionReturn | Represents a return defined as part of a native sql query which names a collection role in the form {classname}.{collectionrole}; it is used in defining a custom sql query for loading an entity's collection in non-fetching scenarios (i.e., loading the collection itself as the "root" of the result).
NativeSQLQueryJoinReturn | Represents a return defined as part of a native sql query which names a fetched role.
NativeSQLQueryNonScalarReturn | Represents the base information for a non-scalar return defined as part of a native sql query.
NativeSQLQueryRootReturn | Represents a return defined as part of a native sql query which names a "root" entity.
NativeSQLQueryScalarReturn | Describes a scalar return in a native SQL query.
NativeSQLQuerySpecification | Defines the specification or blue-print for a native-sql query.


org.hibernate.engine.query.sql Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.engine.query.sql

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn (implements org.hibernate.engine.query.sql.NativeSQLQueryReturn, java.io.Serializable)
      • class org.hibernate.engine.query.sql.NativeSQLQueryCollectionReturn
      • class org.hibernate.engine.query.sql.NativeSQLQueryJoinReturn
      • class org.hibernate.engine.query.sql.NativeSQLQueryRootReturn
    • class org.hibernate.engine.query.sql.NativeSQLQueryScalarReturn (implements org.hibernate.engine.query.sql.NativeSQLQueryReturn)
    • class org.hibernate.engine.query.sql.NativeSQLQuerySpecification

Interface Hierarchy

  • interface org.hibernate.engine.query.sql.NativeSQLQueryReturn


Uses of Package org.hibernate.engine.query.sql (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.engine.query.sql

Packages that use org.hibernate.engine.query.sql
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.engine.query.sql |
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader.custom.sql |

Classes in org.hibernate.engine.query.sql used by org.hibernate.engine
NativeSQLQueryReturn
Describes a return in a native SQL query.
NativeSQLQuerySpecification
Defines the specification or blue-print for a native-sql query.

Classes in org.hibernate.engine.query.sql used by org.hibernate.engine.query
NativeSQLQuerySpecification
Defines the specification or blue-print for a native-sql query.

Classes in org.hibernate.engine.query.sql used by org.hibernate.engine.query.sql
NativeSQLQueryNonScalarReturn
Represents the base information for a non-scalar return defined as part of a native sql query.
NativeSQLQueryReturn
Describes a return in a native SQL query.

Classes in org.hibernate.engine.query.sql used by org.hibernate.impl
NativeSQLQuerySpecification
Defines the specification or blue-print for a native-sql query.

Classes in org.hibernate.engine.query.sql used by org.hibernate.loader.custom.sql
NativeSQLQueryReturn
Describes a return in a native SQL query.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


NativeSQLQueryReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query.sql
Interface NativeSQLQueryReturn

All Known Implementing Classes:
NativeSQLQueryNonScalarReturn, NativeSQLQueryScalarReturn
public interface NativeSQLQueryReturn

Describes a return in a native SQL query.

Author:
Steve Ebersole

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


NativeSQLQueryCollectionReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query.sql
Class NativeSQLQueryCollectionReturn

java.lang.Object
    extended by org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn
        extended by org.hibernate.engine.query.sql.NativeSQLQueryCollectionReturn
All Implemented Interfaces:
NativeSQLQueryReturn, Serializable
public class NativeSQLQueryCollectionReturn
extends NativeSQLQueryNonScalarReturn

Represents a return defined as part of a native sql query which names a collection role in the form {classname}.{collectionrole}; it is used in defining a custom sql query for loading an entity's collection in non-fetching scenarios (i.e., loading the collection itself as the "root" of the result).

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
NativeSQLQueryCollectionReturn(String alias, String ownerEntityName, String ownerProperty, Map propertyResults, LockMode lockMode)
Construct a native-sql return representing a collection initializer
Method Summary
 String getOwnerEntityName()
Returns the class owning the collection.
 String getOwnerProperty()
Returns the name of the property representing the collection from the getOwnerEntityName().
Methods inherited from class org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn
getAlias, getLockMode, getPropertyResultsMap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NativeSQLQueryCollectionReturn

public NativeSQLQueryCollectionReturn(String alias,
                                      String ownerEntityName,
                                      String ownerProperty,
                                      Map propertyResults,
                                      LockMode lockMode)
Construct a native-sql return representing a collection initializer

Parameters:
alias - The result alias
ownerEntityName - The entity-name of the entity owning the collection to be initialized.
ownerProperty - The property name (on the owner) which represents the collection to be initialized.
propertyResults - Any user-supplied column->property mappings
lockMode - The lock mode to apply to the collection.
Method Detail

getOwnerEntityName

public String getOwnerEntityName()
Returns the class owning the collection.

Returns:
The class owning the collection.

getOwnerProperty

public String getOwnerProperty()
Returns the name of the property representing the collection from the getOwnerEntityName().

Returns:
The name of the property representing the collection on the owner class.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


NativeSQLQueryJoinReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query.sql
Class NativeSQLQueryJoinReturn

java.lang.Object
    extended by org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn
        extended by org.hibernate.engine.query.sql.NativeSQLQueryJoinReturn
All Implemented Interfaces:
NativeSQLQueryReturn, Serializable
public class NativeSQLQueryJoinReturn
extends NativeSQLQueryNonScalarReturn

Represents a return defined as part of a native sql query which names a fetched role.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
NativeSQLQueryJoinReturn(String alias, String ownerAlias, String ownerProperty, Map propertyResults, LockMode lockMode)
Construct a return descriptor representing some form of fetch.
Method Summary
String | getOwnerAlias() Retrieve the alias of the owner of this fetched association.
String | getOwnerProperty() Retrieve the property name (relative to the owner) which maps to the association to be fetched.
Methods inherited from class org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn
getAlias, getLockMode, getPropertyResultsMap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NativeSQLQueryJoinReturn

public NativeSQLQueryJoinReturn(String alias,
                                String ownerAlias,
                                String ownerProperty,
                                Map propertyResults,
                                LockMode lockMode)
Construct a return descriptor representing some form of fetch.

Parameters:
alias - The result alias
ownerAlias - The owner's result alias
ownerProperty - The owner's property representing the thing to be fetched
propertyResults - Any user-supplied column->property mappings
lockMode - The lock mode to apply
Method Detail

getOwnerAlias

public String getOwnerAlias()
Retrieve the alias of the owner of this fetched association.

Returns:
The owner's alias.

getOwnerProperty

public String getOwnerProperty()
Retrieve the property name (relative to the owner) which maps to the association to be fetched.

Returns:
The property name.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NativeSQLQueryNonScalarReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query.sql
Class NativeSQLQueryNonScalarReturn

java.lang.Object
    extended by org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn
All Implemented Interfaces:
NativeSQLQueryReturn, Serializable
Direct Known Subclasses:
NativeSQLQueryCollectionReturn, NativeSQLQueryJoinReturn, NativeSQLQueryRootReturn
public abstract class NativeSQLQueryNonScalarReturn
extends Object
implements NativeSQLQueryReturn, Serializable

Represents the base information for a non-scalar return defined as part of a native sql query.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
protected NativeSQLQueryNonScalarReturn(String alias, Map propertyResults, LockMode lockMode)
Constructs some form of non-scalar return descriptor
Method Summary
 String getAlias()
Retrieve the defined result alias
 LockMode getLockMode()
Retrieve the lock-mode to apply to this return
 Map getPropertyResultsMap()
Retrieve the user-supplied column->property mappings.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NativeSQLQueryNonScalarReturn

protected NativeSQLQueryNonScalarReturn(String alias,
                                        Map propertyResults,
                                        LockMode lockMode)
Constructs some form of non-scalar return descriptor

Parameters:
alias - The result alias
propertyResults - Any user-supplied column->property mappings
lockMode - The lock mode to apply to the return.
Method Detail

getAlias

public String getAlias()
Retrieve the defined result alias

Returns:
The result alias.

getLockMode

public LockMode getLockMode()
Retrieve the lock-mode to apply to this return

Returns:
The lock mode

getPropertyResultsMap

public Map getPropertyResultsMap()
Retrieve the user-supplied column->property mappings.

Returns:
The property mappings.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NativeSQLQueryRootReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query.sql
Class NativeSQLQueryRootReturn

java.lang.Object
    extended by org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn
        extended by org.hibernate.engine.query.sql.NativeSQLQueryRootReturn
All Implemented Interfaces:
NativeSQLQueryReturn, Serializable
public class NativeSQLQueryRootReturn
extends NativeSQLQueryNonScalarReturn

Represents a return defined as part of a native sql query which names a "root" entity. A root entity means it is explicitly a "column" in the result, as opposed to a fetched relationship or role.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
NativeSQLQueryRootReturn(String alias, String entityName, LockMode lockMode)
Construct a return representing an entity returned at the root of the result.
NativeSQLQueryRootReturn(String alias, String entityName, Map propertyResults, LockMode lockMode)
Method Summary
 String getReturnEntityName()
The name of the entity to be returned.
Methods inherited from class org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn
getAlias, getLockMode, getPropertyResultsMap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NativeSQLQueryRootReturn

public NativeSQLQueryRootReturn(String alias,
                                String entityName,
                                LockMode lockMode)
Construct a return representing an entity returned at the root of the result.

Parameters:
alias - The result alias
entityName - The entity name.
lockMode - The lock mode to apply

NativeSQLQueryRootReturn

public NativeSQLQueryRootReturn(String alias,
                                String entityName,
                                Map propertyResults,
                                LockMode lockMode)
Parameters:
alias - The result alias
entityName - The entity name.
propertyResults - Any user-supplied column->property mappings
lockMode - The lock mode to apply
Method Detail

getReturnEntityName

public String getReturnEntityName()
The name of the entity to be returned.

Returns:
The entity name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NativeSQLQueryScalarReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query.sql
Class NativeSQLQueryScalarReturn

java.lang.Object
    extended by org.hibernate.engine.query.sql.NativeSQLQueryScalarReturn
All Implemented Interfaces:
NativeSQLQueryReturn
public class NativeSQLQueryScalarReturn
extends Object
implements NativeSQLQueryReturn

Describes a scalar return in a native SQL query.

Author:
gloegl

Constructor Summary
NativeSQLQueryScalarReturn(String alias, Type type)
Method Summary
String | getColumnAlias()
Type | getType()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NativeSQLQueryScalarReturn

public NativeSQLQueryScalarReturn(String alias,
                                  Type type)
Method Detail

getColumnAlias

public String getColumnAlias()

getType

public Type getType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NativeSQLQuerySpecification (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.query.sql
Class NativeSQLQuerySpecification

java.lang.Object
    extended by org.hibernate.engine.query.sql.NativeSQLQuerySpecification
public class NativeSQLQuerySpecification
extends Object

Defines the specification or blue-print for a native-sql query. Essentially a simple struct containing the information needed to "translate" a native-sql query and cache that translated representation. Also used as the key by which the native-sql query plans are cached.

Author:
Steve Ebersole

Constructor Summary
NativeSQLQuerySpecification(String queryString, NativeSQLQueryReturn[] queryReturns, Collection querySpaces)
Method Summary
boolean | equals(Object o)
NativeSQLQueryReturn[] | getQueryReturns()
Set | getQuerySpaces()
String | getQueryString()
int | hashCode()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NativeSQLQuerySpecification

public NativeSQLQuerySpecification(String queryString,
                                   NativeSQLQueryReturn[] queryReturns,
                                   Collection querySpaces)
Method Detail

getQueryString

public String getQueryString()

getQueryReturns

public NativeSQLQueryReturn[] getQueryReturns()

getQuerySpaces

public Set getQuerySpaces()

equals

public boolean equals(Object o)

hashCode

public int hashCode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.engine.transaction (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.engine.transaction

Interface Summary
IsolatedWork Represents work that needs to be performed in a manner which isolates it from any current application unit of work transaction.

Class Summary
Isolater | Class which provides the isolation semantics required by an IsolatedWork.
Isolater.JdbcDelegate | An isolation delegate for JDBC-based transactions.
Isolater.JtaDelegate | An isolation delegate for JTA-based transactions.


org.hibernate.engine.transaction Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.engine.transaction

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.engine.transaction.Isolater
    • class org.hibernate.engine.transaction.Isolater.JdbcDelegate (implements org.hibernate.engine.transaction.Isolater.Delegate)
    • class org.hibernate.engine.transaction.Isolater.JtaDelegate (implements org.hibernate.engine.transaction.Isolater.Delegate)

Interface Hierarchy

  • interface org.hibernate.engine.transaction.IsolatedWork


Uses of Package org.hibernate.engine.transaction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.engine.transaction

Packages that use org.hibernate.engine.transaction
org.hibernate.engine.transaction

Classes in org.hibernate.engine.transaction used by org.hibernate.engine.transaction
IsolatedWork
Represents work that needs to be performed in a manner which isolates it from any current application unit of work transaction.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


IsolatedWork (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.transaction
Interface IsolatedWork

public interface IsolatedWork

Represents work that needs to be performed in a manner which isolates it from any current application unit of work transaction.

Author:
Steve Ebersole

Method Summary
 void doWork(Connection connection)
Perform the actual work to be done.

Method Detail

doWork

public void doWork(Connection connection)
            throws HibernateException
Perform the actual work to be done.

Parameters:
connection - The JDBC connection to use.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Isolater (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.transaction
Class Isolater

java.lang.Object
    extended by org.hibernate.engine.transaction.Isolater
public class Isolater
extends Object

Class which provides the isolation semantics required by an IsolatedWork. Processing comes in two flavors:

  • doIsolatedWork(org.hibernate.engine.transaction.IsolatedWork, org.hibernate.engine.SessionImplementor) : makes sure the work to be done is performed in a seperate, distinct transaction
  • doNonTransactedWork(org.hibernate.engine.transaction.IsolatedWork, org.hibernate.engine.SessionImplementor) : makes sure the work to be done is performed outside the scope of any transaction

Author:
Steve Ebersole

Nested Class Summary
static class | Isolater.JdbcDelegate An isolation delegate for JDBC-based transactions.
static class | Isolater.JtaDelegate An isolation delegate for JTA-based transactions.
Constructor Summary
Isolater()
Method Summary
static void | doIsolatedWork(IsolatedWork work, SessionImplementor session) Ensures that all processing actually performed by the given work will occur on a seperate transaction.
static void | doNonTransactedWork(IsolatedWork work, SessionImplementor session) Ensures that all processing actually performed by the given work will occur outside of a transaction.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Isolater

public Isolater()
Method Detail

doIsolatedWork

public static void doIsolatedWork(IsolatedWork work,
                                  SessionImplementor session)
                           throws HibernateException
Ensures that all processing actually performed by the given work will occur on a seperate transaction.

Parameters:
work - The work to be performed.
session - The session from which this request is originating.
Throws:
HibernateException

doNonTransactedWork

public static void doNonTransactedWork(IsolatedWork work,
                                       SessionImplementor session)
                                throws HibernateException
Ensures that all processing actually performed by the given work will occur outside of a transaction.

Parameters:
work - The work to be performed.
session - The session from which this request is originating.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Isolater.JdbcDelegate (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.transaction
Class Isolater.JdbcDelegate

java.lang.Object
    extended by org.hibernate.engine.transaction.Isolater.JdbcDelegate
All Implemented Interfaces:
org.hibernate.engine.transaction.Isolater.Delegate
Enclosing class:
Isolater
public static class Isolater.JdbcDelegate
extends Object
implements org.hibernate.engine.transaction.Isolater.Delegate

An isolation delegate for JDBC-based transactions. Basically just grabs a new connection and does the work on that.

Constructor Summary
Isolater.JdbcDelegate(SessionImplementor session)
Method Summary
 void delegateWork(IsolatedWork work, boolean transacted)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Isolater.JdbcDelegate

public Isolater.JdbcDelegate(SessionImplementor session)
Method Detail

delegateWork

public void delegateWork(IsolatedWork work,
                         boolean transacted)
                  throws HibernateException
Specified by:
delegateWork in interface org.hibernate.engine.transaction.Isolater.Delegate
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Isolater.JtaDelegate (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.engine.transaction
Class Isolater.JtaDelegate

java.lang.Object
    extended by org.hibernate.engine.transaction.Isolater.JtaDelegate
All Implemented Interfaces:
org.hibernate.engine.transaction.Isolater.Delegate
Enclosing class:
Isolater
public static class Isolater.JtaDelegate
extends Object
implements org.hibernate.engine.transaction.Isolater.Delegate

An isolation delegate for JTA-based transactions. Essentially susepnds any current transaction, does the work in a new transaction, and then resumes the initial transaction (if there was one).

Constructor Summary
Isolater.JtaDelegate(SessionImplementor session)
Method Summary
 void delegateWork(IsolatedWork work, boolean transacted)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Isolater.JtaDelegate

public Isolater.JtaDelegate(SessionImplementor session)
Method Detail

delegateWork

public void delegateWork(IsolatedWork work,
                         boolean transacted)
                  throws HibernateException
Specified by:
delegateWork in interface org.hibernate.engine.transaction.Isolater.Delegate
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.event (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.event

This package defines an event framework for Hibernate.

See:
Description

Interface Summary
AutoFlushEventListener | Defines the contract for handling of session auto-flush events.
DeleteEventListener | Defines the contract for handling of deletion events generated from a session.
DirtyCheckEventListener | Defines the contract for handling of session dirty-check events.
EventSource |
EvictEventListener | Defines the contract for handling of evict events generated from a session.
FlushEntityEventListener |
FlushEventListener | Defines the contract for handling of session flush events.
Initializable | An event listener that requires access to mappings to initialize state at initialization time.
InitializeCollectionEventListener | Defines the contract for handling of collection initialization events generated by a session.
LoadEventListener | Defines the contract for handling of load events generated from a session.
LockEventListener | Defines the contract for handling of lock events generated from a session.
MergeEventListener | Defines the contract for handling of merge events generated from a session.
PersistEventListener | Defines the contract for handling of create events generated from a session.
PostDeleteEventListener | Called after deleting an item from the datastore
PostInsertEventListener | Called after insterting an item in the datastore
PostLoadEventListener | Occurs after an an entity instance is fully loaded.
PostUpdateEventListener | Called after updating the datastore
PreDeleteEventListener | Called before deleting an item from the datastore
PreInsertEventListener | Called before inserting an item in the datastore
PreLoadEventListener | Called before injecting property values into a newly loaded entity instance.
PreUpdateEventListener | Called before updating the datastore
RefreshEventListener | Defines the contract for handling of refresh events generated from a session.
ReplicateEventListener | Defines the contract for handling of replicate events generated from a session.
SaveOrUpdateEventListener | Defines the contract for handling of update events generated from a session.

Class Summary
AbstractEvent | Defines a base class for Session generated events.
AutoFlushEvent | Defines an event class for the auto-flushing of a session.
DeleteEvent | Defines an event class for the deletion of an entity.
DirtyCheckEvent | Defines an event class for the dirty-checking of a session.
EventListeners | A convience holder for all defined session event listeners.
EvictEvent | Defines an event class for the evicting of an entity.
FlushEntityEvent |
FlushEvent | Defines an event class for the flushing of a session.
InitializeCollectionEvent | An event that occurs when a collection wants to be initialized
LoadEvent | Defines an event class for the loading of an entity.
LoadEventListener.LoadType |
LockEvent | Defines an event class for the locking of an entity.
MergeEvent | An event class for merge() and saveOrUpdateCopy()
PersistEvent | An event class for persist()
PostDeleteEvent | Occurs after deleting an item from the datastore
PostInsertEvent | Occurs after inserting an item in the datastore
PostLoadEvent | Occurs after an an entity instance is fully loaded.
PostUpdateEvent | Occurs after the datastore is updated
PreDeleteEvent | Occurs before deleting an item from the datastore
PreInsertEvent | Occurs before inserting an item in the datastore
PreLoadEvent | Called before injecting property values into a newly loaded entity instance.
PreUpdateEvent | Occurs before updating the datastore
RefreshEvent | Defines an event class for the refreshing of an object.
ReplicateEvent | Defines an event class for the replication of an entity.
SaveOrUpdateEvent | An event class for saveOrUpdate()

Package org.hibernate.event Description

This package defines an event framework for Hibernate.


org.hibernate.event Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.event

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.event.AbstractEvent (implements java.io.Serializable)
      • class org.hibernate.event.DeleteEvent
      • class org.hibernate.event.EvictEvent
      • class org.hibernate.event.FlushEntityEvent
      • class org.hibernate.event.FlushEvent
        • class org.hibernate.event.AutoFlushEvent
        • class org.hibernate.event.DirtyCheckEvent
      • class org.hibernate.event.InitializeCollectionEvent
      • class org.hibernate.event.LoadEvent
      • class org.hibernate.event.LockEvent
      • class org.hibernate.event.MergeEvent
      • class org.hibernate.event.PersistEvent
      • class org.hibernate.event.PostLoadEvent
      • class org.hibernate.event.PostUpdateEvent
      • class org.hibernate.event.PreLoadEvent
      • class org.hibernate.event.RefreshEvent
      • class org.hibernate.event.ReplicateEvent
      • class org.hibernate.event.SaveOrUpdateEvent
    • class org.hibernate.util.Cloneable
      • class org.hibernate.event.EventListeners (implements java.io.Serializable)
    • class org.hibernate.event.LoadEventListener.LoadType
    • class org.hibernate.event.PostDeleteEvent
    • class org.hibernate.event.PostInsertEvent
    • class org.hibernate.event.PreDeleteEvent
    • class org.hibernate.event.PreInsertEvent
    • class org.hibernate.event.PreUpdateEvent

Interface Hierarchy

  • interface org.hibernate.event.Initializable
  • interface java.io.Serializable
    • interface org.hibernate.event.AutoFlushEventListener
    • interface org.hibernate.event.DeleteEventListener
    • interface org.hibernate.event.DirtyCheckEventListener
    • interface org.hibernate.event.EvictEventListener
    • interface org.hibernate.event.FlushEntityEventListener
    • interface org.hibernate.event.FlushEventListener
    • interface org.hibernate.event.InitializeCollectionEventListener
    • interface org.hibernate.event.LoadEventListener
    • interface org.hibernate.event.LockEventListener
    • interface org.hibernate.event.MergeEventListener
    • interface org.hibernate.event.PersistEventListener
    • interface org.hibernate.event.PostDeleteEventListener
    • interface org.hibernate.event.PostInsertEventListener
    • interface org.hibernate.event.PostLoadEventListener
    • interface org.hibernate.event.PostUpdateEventListener
    • interface org.hibernate.event.PreDeleteEventListener
    • interface org.hibernate.event.PreInsertEventListener
    • interface org.hibernate.event.PreLoadEventListener
    • interface org.hibernate.event.PreUpdateEventListener
    • interface org.hibernate.event.RefreshEventListener
    • interface org.hibernate.event.ReplicateEventListener
    • interface org.hibernate.event.SaveOrUpdateEventListener
    • interface org.hibernate.Session
      • interface org.hibernate.event.EventSource (also extends org.hibernate.engine.SessionImplementor)
    • interface org.hibernate.engine.SessionImplementor
      • interface org.hibernate.event.EventSource (also extends org.hibernate.Session)


Uses of Package org.hibernate.event (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.event

Packages that use org.hibernate.event
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.secure | Declarative security for CRUD operations on entities.

Classes in org.hibernate.event used by org.hibernate.cache.entry
EventSource

Classes in org.hibernate.event used by org.hibernate.cfg
EventListeners
A convience holder for all defined session event listeners.

Classes in org.hibernate.event used by org.hibernate.engine
EventListeners
A convience holder for all defined session event listeners.
EventSource
PostLoadEvent
Occurs after an an entity instance is fully loaded.
PreLoadEvent
Called before injecting property values into a newly loaded entity instance.

Classes in org.hibernate.event used by org.hibernate.engine.query
EventSource

Classes in org.hibernate.event used by org.hibernate.event
AbstractEvent
Defines a base class for Session generated events.
AutoFlushEvent
Defines an event class for the auto-flushing of a session.
AutoFlushEventListener
Defines the contract for handling of session auto-flush events.
DeleteEvent
Defines an event class for the deletion of an entity.
DeleteEventListener
Defines the contract for handling of deletion events generated from a session.
DirtyCheckEvent
Defines an event class for the dirty-checking of a session.
DirtyCheckEventListener
Defines the contract for handling of session dirty-check events.
EventSource
EvictEvent
Defines an event class for the evicting of an entity.
EvictEventListener
Defines the contract for handling of evict events generated from a session.
FlushEntityEvent
FlushEntityEventListener
FlushEvent
Defines an event class for the flushing of a session.
FlushEventListener
Defines the contract for handling of session flush events.
InitializeCollectionEvent
An event that occurs when a collection wants to be initialized
InitializeCollectionEventListener
Defines the contract for handling of collection initialization events generated by a session.
LoadEvent
Defines an event class for the loading of an entity.
LoadEventListener
Defines the contract for handling of load events generated from a session.
LoadEventListener.LoadType
LockEvent
Defines an event class for the locking of an entity.
LockEventListener
Defines the contract for handling of lock events generated from a session.
MergeEvent
An event class for merge() and saveOrUpdateCopy()
MergeEventListener
Defines the contract for handling of merge events generated from a session.
PersistEvent
An event class for persist()
PersistEventListener
Defines the contract for handling of create events generated from a session.
PostDeleteEvent
Occurs after deleting an item from the datastore
PostDeleteEventListener
Called after deleting an item from the datastore
PostInsertEvent
Occurs after inserting an item in the datastore
PostInsertEventListener
Called after insterting an item in the datastore
PostLoadEvent
Occurs after an an entity instance is fully loaded.
PostLoadEventListener
Occurs after an an entity instance is fully loaded.
PostUpdateEvent
Occurs after the datastore is updated
PostUpdateEventListener
Called after updating the datastore
PreDeleteEvent
Occurs before deleting an item from the datastore
PreDeleteEventListener
Called before deleting an item from the datastore
PreInsertEvent
Occurs before inserting an item in the datastore
PreInsertEventListener
Called before inserting an item in the datastore
PreLoadEvent
Called before injecting property values into a newly loaded entity instance.
PreLoadEventListener
Called before injecting property values into a newly loaded entity instance.
PreUpdateEvent
Occurs before updating the datastore
PreUpdateEventListener
Called before updating the datastore
RefreshEvent
Defines an event class for the refreshing of an object.
RefreshEventListener
Defines the contract for handling of refresh events generated from a session.
ReplicateEvent
Defines an event class for the replication of an entity.
ReplicateEventListener
Defines the contract for handling of replicate events generated from a session.
SaveOrUpdateEvent
An event class for saveOrUpdate()
SaveOrUpdateEventListener
Defines the contract for handling of update events generated from a session.

Classes in org.hibernate.event used by org.hibernate.event.def
AbstractEvent
Defines a base class for Session generated events.
AutoFlushEvent
Defines an event class for the auto-flushing of a session.
AutoFlushEventListener
Defines the contract for handling of session auto-flush events.
DeleteEvent
Defines an event class for the deletion of an entity.
DeleteEventListener
Defines the contract for handling of deletion events generated from a session.
DirtyCheckEvent
Defines an event class for the dirty-checking of a session.
DirtyCheckEventListener
Defines the contract for handling of session dirty-check events.
EventSource
EvictEvent
Defines an event class for the evicting of an entity.
EvictEventListener
Defines the contract for handling of evict events generated from a session.
FlushEntityEvent
FlushEntityEventListener
FlushEvent
Defines an event class for the flushing of a session.
FlushEventListener
Defines the contract for handling of session flush events.
InitializeCollectionEvent
An event that occurs when a collection wants to be initialized
InitializeCollectionEventListener
Defines the contract for handling of collection initialization events generated by a session.
LoadEvent
Defines an event class for the loading of an entity.
LoadEventListener
Defines the contract for handling of load events generated from a session.
LoadEventListener.LoadType
LockEvent
Defines an event class for the locking of an entity.
LockEventListener
Defines the contract for handling of lock events generated from a session.
MergeEvent
An event class for merge() and saveOrUpdateCopy()
MergeEventListener
Defines the contract for handling of merge events generated from a session.
PersistEvent
An event class for persist()
PersistEventListener
Defines the contract for handling of create events generated from a session.
PostLoadEvent
Occurs after an an entity instance is fully loaded.
PostLoadEventListener
Occurs after an an entity instance is fully loaded.
PreLoadEvent
Called before injecting property values into a newly loaded entity instance.
PreLoadEventListener
Called before injecting property values into a newly loaded entity instance.
RefreshEvent
Defines an event class for the refreshing of an object.
RefreshEventListener
Defines the contract for handling of refresh events generated from a session.
ReplicateEvent
Defines an event class for the replication of an entity.
ReplicateEventListener
Defines the contract for handling of replicate events generated from a session.
SaveOrUpdateEvent
An event class for saveOrUpdate()
SaveOrUpdateEventListener
Defines the contract for handling of update events generated from a session.

Classes in org.hibernate.event used by org.hibernate.hql
EventSource

Classes in org.hibernate.event used by org.hibernate.hql.ast
EventSource

Classes in org.hibernate.event used by org.hibernate.impl
EventListeners
A convience holder for all defined session event listeners.
EventSource

Classes in org.hibernate.event used by org.hibernate.loader.hql
EventSource

Classes in org.hibernate.event used by org.hibernate.secure
Initializable
An event listener that requires access to mappings to initialize state at initialization time.
PreDeleteEvent
Occurs before deleting an item from the datastore
PreDeleteEventListener
Called before deleting an item from the datastore
PreInsertEvent
Occurs before inserting an item in the datastore
PreInsertEventListener
Called before inserting an item in the datastore
PreLoadEvent
Called before injecting property values into a newly loaded entity instance.
PreLoadEventListener
Called before injecting property values into a newly loaded entity instance.
PreUpdateEvent
Occurs before updating the datastore
PreUpdateEventListener
Called before updating the datastore

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AutoFlushEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface AutoFlushEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultAutoFlushEventListener
public interface AutoFlushEventListener
extends Serializable

Defines the contract for handling of session auto-flush events.

Author:
Steve Ebersole

Method Summary
 void onAutoFlush(AutoFlushEvent event)
Handle the given auto-flush event.

Method Detail

onAutoFlush

public void onAutoFlush(AutoFlushEvent event)
                 throws HibernateException
Handle the given auto-flush event.

Parameters:
event - The auto-flush event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DeleteEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface DeleteEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultDeleteEventListener
public interface DeleteEventListener
extends Serializable

Defines the contract for handling of deletion events generated from a session.

Author:
Steve Ebersole

Method Summary
void | onDelete(DeleteEvent event) Handle the given delete event.
void | onDelete(DeleteEvent event, Set transientEntities)

Method Detail

onDelete

public void onDelete(DeleteEvent event)
              throws HibernateException
Handle the given delete event.

Parameters:
event - The delete event to be handled.
Throws:
HibernateException

onDelete

public void onDelete(DeleteEvent event,
                     Set transientEntities)
              throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DirtyCheckEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface DirtyCheckEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultDirtyCheckEventListener
public interface DirtyCheckEventListener
extends Serializable

Defines the contract for handling of session dirty-check events.

Author:
Steve Ebersole

Method Summary
 void onDirtyCheck(DirtyCheckEvent event)
Handle the given dirty-check event.

Method Detail

onDirtyCheck

public void onDirtyCheck(DirtyCheckEvent event)
                  throws HibernateException
Handle the given dirty-check event.

Parameters:
event - The dirty-check event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EventSource (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface EventSource

All Superinterfaces:
Serializable, Session, SessionImplementor
All Known Implementing Classes:
SessionImpl
public interface EventSource
extends SessionImplementor, Session

Author:
Gavin King

Method Summary
void | delete(String entityName, Object child, boolean isCascadeDeleteEnabled, Set transientEntities) Cascade delete an entity instance
void | forceFlush(EntityEntry e) Force an immediate flush
ActionQueue | getActionQueue() Get the ActionQueue for this session
Object | instantiate(EntityPersister persister, Serializable id) Instantiate an entity instance, using either an interceptor, or the given persister
void | merge(String entityName, Object object, Map copiedAlready) Cascade merge an entity instance
void | persist(String entityName, Object object, Map createdAlready) Cascade persist an entity instance
void | persistOnFlush(String entityName, Object object, Map copiedAlready) Cascade persist an entity instance during the flush process
void | refresh(Object object, Map refreshedAlready) Cascade refesh an entity instance
void | saveOrUpdateCopy(String entityName, Object object, Map copiedAlready) Cascade copy an entity instance
Methods inherited from interface org.hibernate.engine.SessionImplementor
afterScrollOperation, afterTransactionCompletion, beforeTransactionCompletion, bestGuessEntityName, connection, executeNativeUpdate, executeUpdate, flush, getBatcher, getCacheMode, getContextEntityIdentifier, getDontFlushFromFind, getEnabledFilters, getEntityMode, getEntityPersister, getEntityUsingInterceptor, getFactory, getFetchProfile, getFilterParameterType, getFilterParameterValue, getFlushMode, getInterceptor, getJDBCContext, getListeners, getNamedQuery, getNamedSQLQuery, getPersistenceContext, getTimestamp, guessEntityName, immediateLoad, initializeCollection, instantiate, internalLoad, isClosed, isConnected, isEventSource, isOpen, isTransactionInProgress, iterate, iterateFilter, list, list, list, listCustomQuery, listFilter, scroll, scroll, scroll, scrollCustomQuery, setAutoClear, setCacheMode, setFetchProfile, setFlushMode
Methods inherited from interface org.hibernate.Session
beginTransaction, cancelQuery, clear, close, connection, contains, createCriteria, createCriteria, createCriteria, createCriteria, createFilter, createQuery, createSQLQuery, delete, delete, disableFilter, disconnect, enableFilter, evict, flush, get, get, get, get, getCacheMode, getCurrentLockMode, getEnabledFilter, getEntityMode, getEntityName, getFlushMode, getIdentifier, getNamedQuery, getSession, getSessionFactory, getStatistics, getTransaction, isConnected, isDirty, isOpen, load, load, load, load, load, lock, lock, merge, merge, persist, persist, reconnect, reconnect, refresh, refresh, replicate, replicate, save, save, saveOrUpdate, saveOrUpdate, setCacheMode, setFlushMode, setReadOnly, update, update

Method Detail

getActionQueue

public ActionQueue getActionQueue()
Get the ActionQueue for this session

instantiate

public Object instantiate(EntityPersister persister,
                          Serializable id)
                   throws HibernateException
Instantiate an entity instance, using either an interceptor, or the given persister

Throws:
HibernateException

forceFlush

public void forceFlush(EntityEntry e)
                throws HibernateException
Force an immediate flush

Throws:
HibernateException

merge

public void merge(String entityName,
                  Object object,
                  Map copiedAlready)
           throws HibernateException
Cascade merge an entity instance

Throws:
HibernateException

persist

public void persist(String entityName,
                    Object object,
                    Map createdAlready)
             throws HibernateException
Cascade persist an entity instance

Throws:
HibernateException

persistOnFlush

public void persistOnFlush(String entityName,
                           Object object,
                           Map copiedAlready)
Cascade persist an entity instance during the flush process

refresh

public void refresh(Object object,
                    Map refreshedAlready)
             throws HibernateException
Cascade refesh an entity instance

Throws:
HibernateException

saveOrUpdateCopy

public void saveOrUpdateCopy(String entityName,
                             Object object,
                             Map copiedAlready)
                      throws HibernateException
Cascade copy an entity instance

Throws:
HibernateException

delete

public void delete(String entityName,
                   Object child,
                   boolean isCascadeDeleteEnabled,
                   Set transientEntities)
Cascade delete an entity instance

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EvictEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface EvictEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultEvictEventListener
public interface EvictEventListener
extends Serializable

Defines the contract for handling of evict events generated from a session.

Author:
Steve Ebersole

Method Summary
 void onEvict(EvictEvent event)
Handle the given evict event.

Method Detail

onEvict

public void onEvict(EvictEvent event)
             throws HibernateException
Handle the given evict event.

Parameters:
event - The evict event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FlushEntityEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface FlushEntityEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultFlushEntityEventListener
public interface FlushEntityEventListener
extends Serializable

Author:
Gavin King

Method Summary
 void onFlushEntity(FlushEntityEvent event)

Method Detail

onFlushEntity

public void onFlushEntity(FlushEntityEvent event)
                   throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FlushEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface FlushEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultFlushEventListener
public interface FlushEventListener
extends Serializable

Defines the contract for handling of session flush events.

Author:
Steve Ebersole

Method Summary
 void onFlush(FlushEvent event)
Handle the given flush event.

Method Detail

onFlush

public void onFlush(FlushEvent event)
             throws HibernateException
Handle the given flush event.

Parameters:
event - The flush event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Initializable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface Initializable

All Known Implementing Classes:
JACCPreDeleteEventListener, JACCPreInsertEventListener, JACCPreLoadEventListener, JACCPreUpdateEventListener
public interface Initializable

An event listener that requires access to mappings to initialize state at initialization time.

Author:
Gavin King

Method Summary
 void initialize(Configuration cfg)

Method Detail

initialize

public void initialize(Configuration cfg)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InitializeCollectionEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface InitializeCollectionEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultInitializeCollectionEventListener
public interface InitializeCollectionEventListener
extends Serializable

Defines the contract for handling of collection initialization events generated by a session.

Author:
Gavin King

Method Summary
 void onInitializeCollection(InitializeCollectionEvent event)

Method Detail

onInitializeCollection

public void onInitializeCollection(InitializeCollectionEvent event)
                            throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LoadEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface LoadEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultLoadEventListener
public interface LoadEventListener
extends Serializable

Defines the contract for handling of load events generated from a session.

Author:
Steve Ebersole

Nested Class Summary
static class LoadEventListener.LoadType
Field Summary
static LoadEventListener.LoadType | GET
static LoadEventListener.LoadType | IMMEDIATE_LOAD
static LoadEventListener.LoadType | INTERNAL_LOAD_EAGER
static LoadEventListener.LoadType | INTERNAL_LOAD_LAZY
static LoadEventListener.LoadType | INTERNAL_LOAD_NULLABLE
static LoadEventListener.LoadType | LOAD
static LoadEventListener.LoadType | RELOAD
Method Summary
 void onLoad(LoadEvent event, LoadEventListener.LoadType loadType)
Handle the given load event.

Field Detail

RELOAD

public static final LoadEventListener.LoadType RELOAD

GET

public static final LoadEventListener.LoadType GET

LOAD

public static final LoadEventListener.LoadType LOAD

IMMEDIATE_LOAD

public static final LoadEventListener.LoadType IMMEDIATE_LOAD

INTERNAL_LOAD_EAGER

public static final LoadEventListener.LoadType INTERNAL_LOAD_EAGER

INTERNAL_LOAD_LAZY

public static final LoadEventListener.LoadType INTERNAL_LOAD_LAZY

INTERNAL_LOAD_NULLABLE

public static final LoadEventListener.LoadType INTERNAL_LOAD_NULLABLE
Method Detail

onLoad

public void onLoad(LoadEvent event,
                   LoadEventListener.LoadType loadType)
            throws HibernateException
Handle the given load event.

Parameters:
event - The load event to be handled.
Returns:
The result (i.e., the loaded entity).
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LoadEventListener.LoadType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class LoadEventListener.LoadType

java.lang.Object
    extended by org.hibernate.event.LoadEventListener.LoadType
Enclosing class:
LoadEventListener
public static final class LoadEventListener.LoadType
extends Object

Method Summary
String | getName()
boolean | isAllowNulls()
boolean | isAllowProxyCreation()
boolean | isCheckDeleted()
boolean | isNakedEntityReturned()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

isAllowNulls

public boolean isAllowNulls()

isNakedEntityReturned

public boolean isNakedEntityReturned()

isCheckDeleted

public boolean isCheckDeleted()

isAllowProxyCreation

public boolean isAllowProxyCreation()

getName

public String getName()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LockEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface LockEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultLockEventListener
public interface LockEventListener
extends Serializable

Defines the contract for handling of lock events generated from a session.

Author:
Steve Ebersole

Method Summary
 void onLock(LockEvent event)
Handle the given lock event.

Method Detail

onLock

public void onLock(LockEvent event)
            throws HibernateException
Handle the given lock event.

Parameters:
event - The lock event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MergeEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface MergeEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultMergeEventListener
public interface MergeEventListener
extends Serializable

Defines the contract for handling of merge events generated from a session.

Author:
Gavin King

Method Summary
void | onMerge(MergeEvent event) Handle the given merge event.
void | onMerge(MergeEvent event, Map copiedAlready) Handle the given merge event.

Method Detail

onMerge

public void onMerge(MergeEvent event)
             throws HibernateException
Handle the given merge event.

Parameters:
event - The merge event to be handled.
Throws:
HibernateException

onMerge

public void onMerge(MergeEvent event,
                    Map copiedAlready)
             throws HibernateException
Handle the given merge event.

Parameters:
event - The merge event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface PersistEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultPersistEventListener
public interface PersistEventListener
extends Serializable

Defines the contract for handling of create events generated from a session.

Author:
Gavin King

Method Summary
void | onPersist(PersistEvent event) Handle the given create event.
void | onPersist(PersistEvent event, Map createdAlready) Handle the given create event.

Method Detail

onPersist

public void onPersist(PersistEvent event)
               throws HibernateException
Handle the given create event.

Parameters:
event - The create event to be handled.
Throws:
HibernateException

onPersist

public void onPersist(PersistEvent event,
                      Map createdAlready)
               throws HibernateException
Handle the given create event.

Parameters:
event - The create event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PostDeleteEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface PostDeleteEventListener

All Superinterfaces:
Serializable
public interface PostDeleteEventListener
extends Serializable

Called after deleting an item from the datastore

Author:
Gavin King

Method Summary
 void onPostDelete(PostDeleteEvent event)

Method Detail

onPostDelete

public void onPostDelete(PostDeleteEvent event)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PostInsertEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface PostInsertEventListener

All Superinterfaces:
Serializable
public interface PostInsertEventListener
extends Serializable

Called after insterting an item in the datastore

Author:
Gavin King

Method Summary
 void onPostInsert(PostInsertEvent event)

Method Detail

onPostInsert

public void onPostInsert(PostInsertEvent event)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PostLoadEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface PostLoadEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultPostLoadEventListener
public interface PostLoadEventListener
extends Serializable

Occurs after an an entity instance is fully loaded.

Author:
Kabir Khan

Method Summary
 void onPostLoad(PostLoadEvent event)

Method Detail

onPostLoad

public void onPostLoad(PostLoadEvent event)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PostUpdateEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface PostUpdateEventListener

All Superinterfaces:
Serializable
public interface PostUpdateEventListener
extends Serializable

Called after updating the datastore

Author:
Gavin King

Method Summary
 void onPostUpdate(PostUpdateEvent event)

Method Detail

onPostUpdate

public void onPostUpdate(PostUpdateEvent event)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreDeleteEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface PreDeleteEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
JACCPreDeleteEventListener
public interface PreDeleteEventListener
extends Serializable

Called before deleting an item from the datastore

Author:
Gavin King

Method Summary
 boolean onPreDelete(PreDeleteEvent event)

Method Detail

onPreDelete

public boolean onPreDelete(PreDeleteEvent event)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreInsertEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface PreInsertEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
JACCPreInsertEventListener
public interface PreInsertEventListener
extends Serializable

Called before inserting an item in the datastore

Author:
Gavin King

Method Summary
 boolean onPreInsert(PreInsertEvent event)

Method Detail

onPreInsert

public boolean onPreInsert(PreInsertEvent event)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreLoadEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface PreLoadEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultPreLoadEventListener, JACCPreLoadEventListener
public interface PreLoadEventListener
extends Serializable

Called before injecting property values into a newly loaded entity instance.

Author:
Gavin King

Method Summary
 void onPreLoad(PreLoadEvent event)

Method Detail

onPreLoad

public void onPreLoad(PreLoadEvent event)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreUpdateEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface PreUpdateEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
JACCPreUpdateEventListener
public interface PreUpdateEventListener
extends Serializable

Called before updating the datastore

Author:
Gavin King

Method Summary
 boolean onPreUpdate(PreUpdateEvent event)

Method Detail

onPreUpdate

public boolean onPreUpdate(PreUpdateEvent event)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RefreshEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface RefreshEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultRefreshEventListener
public interface RefreshEventListener
extends Serializable

Defines the contract for handling of refresh events generated from a session.

Author:
Steve Ebersole

Method Summary
void | onRefresh(RefreshEvent event) Handle the given refresh event.
void | onRefresh(RefreshEvent event, Map refreshedAlready)

Method Detail

onRefresh

public void onRefresh(RefreshEvent event)
               throws HibernateException
Handle the given refresh event.

Parameters:
event - The refresh event to be handled.
Throws:
HibernateException

onRefresh

public void onRefresh(RefreshEvent event,
                      Map refreshedAlready)
               throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReplicateEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface ReplicateEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultReplicateEventListener
public interface ReplicateEventListener
extends Serializable

Defines the contract for handling of replicate events generated from a session.

Author:
Steve Ebersole

Method Summary
 void onReplicate(ReplicateEvent event)
Handle the given replicate event.

Method Detail

onReplicate

public void onReplicate(ReplicateEvent event)
                 throws HibernateException
Handle the given replicate event.

Parameters:
event - The replicate event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SaveOrUpdateEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Interface SaveOrUpdateEventListener

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultSaveOrUpdateEventListener
public interface SaveOrUpdateEventListener
extends Serializable

Defines the contract for handling of update events generated from a session.

Author:
Steve Ebersole

Method Summary
 void onSaveOrUpdate(SaveOrUpdateEvent event)
Handle the given update event.

Method Detail

onSaveOrUpdate

public void onSaveOrUpdate(SaveOrUpdateEvent event)
                    throws HibernateException
Handle the given update event.

Parameters:
event - The update event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class AbstractEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
DeleteEvent, EvictEvent, FlushEntityEvent, FlushEvent, InitializeCollectionEvent, LoadEvent, LockEvent, MergeEvent, PersistEvent, PostLoadEvent, PostUpdateEvent, PreLoadEvent, RefreshEvent, ReplicateEvent, SaveOrUpdateEvent
public abstract class AbstractEvent
extends Object
implements Serializable

Defines a base class for Session generated events.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
AbstractEvent(EventSource source)
Constructs an event from the given event session.
Method Summary
 EventSource getSession()
Returns the session event source for this event.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbstractEvent

public AbstractEvent(EventSource source)
Constructs an event from the given event session.

Parameters:
source - The session event source.
Method Detail

getSession

public final EventSource getSession()
Returns the session event source for this event. This is the underlying session from which this event was generated.

Returns:
The session event source.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AutoFlushEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class AutoFlushEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.FlushEvent
            extended by org.hibernate.event.AutoFlushEvent
All Implemented Interfaces:
Serializable
public class AutoFlushEvent
extends FlushEvent

Defines an event class for the auto-flushing of a session.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
AutoFlushEvent(Set querySpaces, EventSource source)
Method Summary
Set | getQuerySpaces()
boolean | isFlushRequired()
void | setFlushRequired(boolean dirty)
void | setQuerySpaces(Set querySpaces)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AutoFlushEvent

public AutoFlushEvent(Set querySpaces,
                      EventSource source)
Method Detail

getQuerySpaces

public Set getQuerySpaces()

setQuerySpaces

public void setQuerySpaces(Set querySpaces)

isFlushRequired

public boolean isFlushRequired()

setFlushRequired

public void setFlushRequired(boolean dirty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DeleteEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class DeleteEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.DeleteEvent
All Implemented Interfaces:
Serializable
public class DeleteEvent
extends AbstractEvent

Defines an event class for the deletion of an entity.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
DeleteEvent(Object object, EventSource source)
Constructs a new DeleteEvent instance.
DeleteEvent(String entityName, Object object, boolean isCascadeDeleteEnabled, EventSource source)
DeleteEvent(String entityName, Object object, EventSource source)
Method Summary
String | getEntityName()
Object | getObject() Returns the encapsulated entity to be deleed.
boolean | isCascadeDeleteEnabled()
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DeleteEvent

public DeleteEvent(Object object,
                   EventSource source)
Constructs a new DeleteEvent instance.

Parameters:
object - The entity to be deleted.
source - The session from which the delete event was generated.

DeleteEvent

public DeleteEvent(String entityName,
                   Object object,
                   EventSource source)

DeleteEvent

public DeleteEvent(String entityName,
                   Object object,
                   boolean isCascadeDeleteEnabled,
                   EventSource source)
Method Detail

getObject

public Object getObject()
Returns the encapsulated entity to be deleed.

Returns:
The entity to be deleted.

getEntityName

public String getEntityName()

isCascadeDeleteEnabled

public boolean isCascadeDeleteEnabled()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DirtyCheckEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class DirtyCheckEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.FlushEvent
            extended by org.hibernate.event.DirtyCheckEvent
All Implemented Interfaces:
Serializable
public class DirtyCheckEvent
extends FlushEvent

Defines an event class for the dirty-checking of a session.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
DirtyCheckEvent(EventSource source)
Method Summary
boolean | isDirty()
void | setDirty(boolean dirty)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DirtyCheckEvent

public DirtyCheckEvent(EventSource source)
Method Detail

isDirty

public boolean isDirty()

setDirty

public void setDirty(boolean dirty)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EventListeners (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class EventListeners

java.lang.Object
    extended by org.hibernate.util.Cloneable
        extended by org.hibernate.event.EventListeners
All Implemented Interfaces:
Serializable
public class EventListeners
extends Cloneable
implements Serializable

A convience holder for all defined session event listeners.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
EventListeners()
Method Summary
AutoFlushEventListener[] | getAutoFlushEventListeners()
DeleteEventListener[] | getDeleteEventListeners()
DirtyCheckEventListener[] | getDirtyCheckEventListeners()
EvictEventListener[] | getEvictEventListeners()
FlushEntityEventListener[] | getFlushEntityEventListeners()
FlushEventListener[] | getFlushEventListeners()
InitializeCollectionEventListener[] | getInitializeCollectionEventListeners()
Class | getListenerClassFor(String type)
LoadEventListener[] | getLoadEventListeners()
LockEventListener[] | getLockEventListeners()
MergeEventListener[] | getMergeEventListeners()
PersistEventListener[] | getPersistEventListeners()
PersistEventListener[] | getPersistOnFlushEventListeners()
PostDeleteEventListener[] | getPostCommitDeleteEventListeners()
PostInsertEventListener[] | getPostCommitInsertEventListeners()
PostUpdateEventListener[] | getPostCommitUpdateEventListeners()
PostDeleteEventListener[] | getPostDeleteEventListeners()
PostInsertEventListener[] | getPostInsertEventListeners()
PostLoadEventListener[] | getPostLoadEventListeners()
PostUpdateEventListener[] | getPostUpdateEventListeners()
PreDeleteEventListener[] | getPreDeleteEventListeners()
PreInsertEventListener[] | getPreInsertEventListeners()
PreLoadEventListener[] | getPreLoadEventListeners()
PreUpdateEventListener[] | getPreUpdateEventListeners()
RefreshEventListener[] | getRefreshEventListeners()
ReplicateEventListener[] | getReplicateEventListeners()
SaveOrUpdateEventListener[] | getSaveEventListeners()
MergeEventListener[] | getSaveOrUpdateCopyEventListeners()
SaveOrUpdateEventListener[] | getSaveOrUpdateEventListeners()
SaveOrUpdateEventListener[] | getUpdateEventListeners()
void | initializeListeners(Configuration cfg) Call initialize() on any listeners that implement Initializable.
void | setAutoFlushEventListeners(AutoFlushEventListener[] autoFlushEventListener)
void | setDeleteEventListeners(DeleteEventListener[] deleteEventListener)
void | setDirtyCheckEventListeners(DirtyCheckEventListener[] dirtyCheckEventListener)
void | setEvictEventListeners(EvictEventListener[] evictEventListener)
void | setFlushEntityEventListeners(FlushEntityEventListener[] flushEntityEventListener)
void | setFlushEventListeners(FlushEventListener[] flushEventListener)
void | setInitializeCollectionEventListeners(InitializeCollectionEventListener[] initializeCollectionEventListener)
void | setLoadEventListeners(LoadEventListener[] loadEventListener)
void | setLockEventListeners(LockEventListener[] lockEventListener)
void | setMergeEventListeners(MergeEventListener[] mergeEventListener)
void | setPersistEventListeners(PersistEventListener[] createEventListener)
void | setPersistOnFlushEventListeners(PersistEventListener[] createEventListener)
void | setPostCommitDeleteEventListeners(PostDeleteEventListener[] postCommitDeleteEventListeners)
void | setPostCommitInsertEventListeners(PostInsertEventListener[] postCommitInsertEventListeners)
void | setPostCommitUpdateEventListeners(PostUpdateEventListener[] postCommitUpdateEventListeners)
void | setPostDeleteEventListeners(PostDeleteEventListener[] postDeleteEventListener)
void | setPostInsertEventListeners(PostInsertEventListener[] postInsertEventListener)
void | setPostLoadEventListeners(PostLoadEventListener[] postLoadEventListener)
void | setPostUpdateEventListeners(PostUpdateEventListener[] postUpdateEventListener)
void | setPreDeleteEventListeners(PreDeleteEventListener[] preDeleteEventListener)
void | setPreInsertEventListeners(PreInsertEventListener[] preInsertEventListener)
void | setPreLoadEventListeners(PreLoadEventListener[] preLoadEventListener)
void | setPreUpdateEventListeners(PreUpdateEventListener[] preUpdateEventListener)
void | setRefreshEventListeners(RefreshEventListener[] refreshEventListener)
void | setReplicateEventListeners(ReplicateEventListener[] replicateEventListener)
void | setSaveEventListeners(SaveOrUpdateEventListener[] saveEventListener)
void | setSaveOrUpdateCopyEventListeners(MergeEventListener[] saveOrUpdateCopyEventListener)
void | setSaveOrUpdateEventListeners(SaveOrUpdateEventListener[] saveOrUpdateEventListener)
void | setUpdateEventListeners(SaveOrUpdateEventListener[] updateEventListener)
Methods inherited from class org.hibernate.util.Cloneable
shallowCopy, validate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EventListeners

public EventListeners()
Method Detail

getListenerClassFor

public Class getListenerClassFor(String type)

getLoadEventListeners

public LoadEventListener[] getLoadEventListeners()

setLoadEventListeners

public void setLoadEventListeners(LoadEventListener[] loadEventListener)

getReplicateEventListeners

public ReplicateEventListener[] getReplicateEventListeners()

setReplicateEventListeners

public void setReplicateEventListeners(ReplicateEventListener[] replicateEventListener)

getDeleteEventListeners

public DeleteEventListener[] getDeleteEventListeners()

setDeleteEventListeners

public void setDeleteEventListeners(DeleteEventListener[] deleteEventListener)

getAutoFlushEventListeners

public AutoFlushEventListener[] getAutoFlushEventListeners()

setAutoFlushEventListeners

public void setAutoFlushEventListeners(AutoFlushEventListener[] autoFlushEventListener)

getDirtyCheckEventListeners

public DirtyCheckEventListener[] getDirtyCheckEventListeners()

setDirtyCheckEventListeners

public void setDirtyCheckEventListeners(DirtyCheckEventListener[] dirtyCheckEventListener)

getFlushEventListeners

public FlushEventListener[] getFlushEventListeners()

setFlushEventListeners

public void setFlushEventListeners(FlushEventListener[] flushEventListener)

getEvictEventListeners

public EvictEventListener[] getEvictEventListeners()

setEvictEventListeners

public void setEvictEventListeners(EvictEventListener[] evictEventListener)

getLockEventListeners

public LockEventListener[] getLockEventListeners()

setLockEventListeners

public void setLockEventListeners(LockEventListener[] lockEventListener)

getRefreshEventListeners

public RefreshEventListener[] getRefreshEventListeners()

setRefreshEventListeners

public void setRefreshEventListeners(RefreshEventListener[] refreshEventListener)

getInitializeCollectionEventListeners

public InitializeCollectionEventListener[] getInitializeCollectionEventListeners()

setInitializeCollectionEventListeners

public void setInitializeCollectionEventListeners(InitializeCollectionEventListener[] initializeCollectionEventListener)

getFlushEntityEventListeners

public FlushEntityEventListener[] getFlushEntityEventListeners()

setFlushEntityEventListeners

public void setFlushEntityEventListeners(FlushEntityEventListener[] flushEntityEventListener)

getSaveOrUpdateEventListeners

public SaveOrUpdateEventListener[] getSaveOrUpdateEventListeners()

setSaveOrUpdateEventListeners

public void setSaveOrUpdateEventListeners(SaveOrUpdateEventListener[] saveOrUpdateEventListener)

getMergeEventListeners

public MergeEventListener[] getMergeEventListeners()

setMergeEventListeners

public void setMergeEventListeners(MergeEventListener[] mergeEventListener)

getPersistEventListeners

public PersistEventListener[] getPersistEventListeners()

setPersistEventListeners

public void setPersistEventListeners(PersistEventListener[] createEventListener)

getPersistOnFlushEventListeners

public PersistEventListener[] getPersistOnFlushEventListeners()

setPersistOnFlushEventListeners

public void setPersistOnFlushEventListeners(PersistEventListener[] createEventListener)

getSaveOrUpdateCopyEventListeners

public MergeEventListener[] getSaveOrUpdateCopyEventListeners()

setSaveOrUpdateCopyEventListeners

public void setSaveOrUpdateCopyEventListeners(MergeEventListener[] saveOrUpdateCopyEventListener)

getSaveEventListeners

public SaveOrUpdateEventListener[] getSaveEventListeners()

setSaveEventListeners

public void setSaveEventListeners(SaveOrUpdateEventListener[] saveEventListener)

getUpdateEventListeners

public SaveOrUpdateEventListener[] getUpdateEventListeners()

setUpdateEventListeners

public void setUpdateEventListeners(SaveOrUpdateEventListener[] updateEventListener)

getPostLoadEventListeners

public PostLoadEventListener[] getPostLoadEventListeners()

setPostLoadEventListeners

public void setPostLoadEventListeners(PostLoadEventListener[] postLoadEventListener)

getPreLoadEventListeners

public PreLoadEventListener[] getPreLoadEventListeners()

setPreLoadEventListeners

public void setPreLoadEventListeners(PreLoadEventListener[] preLoadEventListener)

getPostDeleteEventListeners

public PostDeleteEventListener[] getPostDeleteEventListeners()

getPostInsertEventListeners

public PostInsertEventListener[] getPostInsertEventListeners()

getPostUpdateEventListeners

public PostUpdateEventListener[] getPostUpdateEventListeners()

setPostDeleteEventListeners

public void setPostDeleteEventListeners(PostDeleteEventListener[] postDeleteEventListener)

setPostInsertEventListeners

public void setPostInsertEventListeners(PostInsertEventListener[] postInsertEventListener)

setPostUpdateEventListeners

public void setPostUpdateEventListeners(PostUpdateEventListener[] postUpdateEventListener)

getPreDeleteEventListeners

public PreDeleteEventListener[] getPreDeleteEventListeners()

setPreDeleteEventListeners

public void setPreDeleteEventListeners(PreDeleteEventListener[] preDeleteEventListener)

getPreInsertEventListeners

public PreInsertEventListener[] getPreInsertEventListeners()

setPreInsertEventListeners

public void setPreInsertEventListeners(PreInsertEventListener[] preInsertEventListener)

getPreUpdateEventListeners

public PreUpdateEventListener[] getPreUpdateEventListeners()

setPreUpdateEventListeners

public void setPreUpdateEventListeners(PreUpdateEventListener[] preUpdateEventListener)

initializeListeners

public void initializeListeners(Configuration cfg)
Call initialize() on any listeners that implement Initializable.

See Also:
Initializable

getPostCommitDeleteEventListeners

public PostDeleteEventListener[] getPostCommitDeleteEventListeners()

setPostCommitDeleteEventListeners

public void setPostCommitDeleteEventListeners(PostDeleteEventListener[] postCommitDeleteEventListeners)

getPostCommitInsertEventListeners

public PostInsertEventListener[] getPostCommitInsertEventListeners()

setPostCommitInsertEventListeners

public void setPostCommitInsertEventListeners(PostInsertEventListener[] postCommitInsertEventListeners)

getPostCommitUpdateEventListeners

public PostUpdateEventListener[] getPostCommitUpdateEventListeners()

setPostCommitUpdateEventListeners

public void setPostCommitUpdateEventListeners(PostUpdateEventListener[] postCommitUpdateEventListeners)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EvictEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class EvictEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.EvictEvent
All Implemented Interfaces:
Serializable
public class EvictEvent
extends AbstractEvent

Defines an event class for the evicting of an entity.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
EvictEvent(Object object, EventSource source)
Method Summary
Object | getObject()
void | setObject(Object object)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EvictEvent

public EvictEvent(Object object,
                  EventSource source)
Method Detail

getObject

public Object getObject()

setObject

public void setObject(Object object)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FlushEntityEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class FlushEntityEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.FlushEntityEvent
All Implemented Interfaces:
Serializable
public class FlushEntityEvent
extends AbstractEvent

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
FlushEntityEvent(EventSource source, Object entity, EntityEntry entry)
Method Summary
Object[] | getDatabaseSnapshot()
int[] | getDirtyProperties()
Object | getEntity()
EntityEntry | getEntityEntry()
Object[] | getPropertyValues()
boolean | hasDatabaseSnapshot()
boolean | hasDirtyCollection()
boolean | isDirtyCheckHandledByInterceptor()
boolean | isDirtyCheckPossible()
void | setDatabaseSnapshot(Object[] databaseSnapshot)
void | setDirtyCheckHandledByInterceptor(boolean dirtyCheckHandledByInterceptor)
void | setDirtyCheckPossible(boolean dirtyCheckPossible)
void | setDirtyProperties(int[] dirtyProperties)
void | setHasDirtyCollection(boolean hasDirtyCollection)
void | setPropertyValues(Object[] propertyValues)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FlushEntityEvent

public FlushEntityEvent(EventSource source,
                        Object entity,
                        EntityEntry entry)
Method Detail

getEntityEntry

public EntityEntry getEntityEntry()

getDatabaseSnapshot

public Object[] getDatabaseSnapshot()

setDatabaseSnapshot

public void setDatabaseSnapshot(Object[] databaseSnapshot)

hasDatabaseSnapshot

public boolean hasDatabaseSnapshot()

isDirtyCheckHandledByInterceptor

public boolean isDirtyCheckHandledByInterceptor()

setDirtyCheckHandledByInterceptor

public void setDirtyCheckHandledByInterceptor(boolean dirtyCheckHandledByInterceptor)

isDirtyCheckPossible

public boolean isDirtyCheckPossible()

setDirtyCheckPossible

public void setDirtyCheckPossible(boolean dirtyCheckPossible)

getDirtyProperties

public int[] getDirtyProperties()

setDirtyProperties

public void setDirtyProperties(int[] dirtyProperties)

hasDirtyCollection

public boolean hasDirtyCollection()

setHasDirtyCollection

public void setHasDirtyCollection(boolean hasDirtyCollection)

getPropertyValues

public Object[] getPropertyValues()

setPropertyValues

public void setPropertyValues(Object[] propertyValues)

getEntity

public Object getEntity()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FlushEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class FlushEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.FlushEvent
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AutoFlushEvent, DirtyCheckEvent
public class FlushEvent
extends AbstractEvent

Defines an event class for the flushing of a session.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
FlushEvent(EventSource source)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FlushEvent

public FlushEvent(EventSource source)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InitializeCollectionEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class InitializeCollectionEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.InitializeCollectionEvent
All Implemented Interfaces:
Serializable
public class InitializeCollectionEvent
extends AbstractEvent

An event that occurs when a collection wants to be initialized

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
InitializeCollectionEvent(PersistentCollection collection, EventSource source)
Method Summary
 PersistentCollection getCollection()
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InitializeCollectionEvent

public InitializeCollectionEvent(PersistentCollection collection,
                                 EventSource source)
Method Detail

getCollection

public PersistentCollection getCollection()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LoadEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class LoadEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.LoadEvent
All Implemented Interfaces:
Serializable
public class LoadEvent
extends AbstractEvent

Defines an event class for the loading of an entity.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
static LockMode DEFAULT_LOCK_MODE
Constructor Summary
LoadEvent(Serializable entityId, Object instanceToLoad, EventSource source)
LoadEvent(Serializable entityId, String entityClassName, boolean isAssociationFetch, EventSource source)
LoadEvent(Serializable entityId, String entityClassName, LockMode lockMode, EventSource source)
Method Summary
String | getEntityClassName()
Serializable | getEntityId()
Object | getInstanceToLoad()
LockMode | getLockMode()
Object | getResult()
boolean | isAssociationFetch()
void | setEntityClassName(String entityClassName)
void | setEntityId(Serializable entityId)
void | setInstanceToLoad(Object instanceToLoad)
void | setLockMode(LockMode lockMode)
void | setResult(Object result)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_LOCK_MODE

public static final LockMode DEFAULT_LOCK_MODE
Constructor Detail

LoadEvent

public LoadEvent(Serializable entityId,
                 Object instanceToLoad,
                 EventSource source)

LoadEvent

public LoadEvent(Serializable entityId,
                 String entityClassName,
                 LockMode lockMode,
                 EventSource source)

LoadEvent

public LoadEvent(Serializable entityId,
                 String entityClassName,
                 boolean isAssociationFetch,
                 EventSource source)
Method Detail

isAssociationFetch

public boolean isAssociationFetch()

getEntityId

public Serializable getEntityId()

setEntityId

public void setEntityId(Serializable entityId)

getEntityClassName

public String getEntityClassName()

setEntityClassName

public void setEntityClassName(String entityClassName)

getInstanceToLoad

public Object getInstanceToLoad()

setInstanceToLoad

public void setInstanceToLoad(Object instanceToLoad)

getLockMode

public LockMode getLockMode()

setLockMode

public void setLockMode(LockMode lockMode)

getResult

public Object getResult()

setResult

public void setResult(Object result)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LockEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class LockEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.LockEvent
All Implemented Interfaces:
Serializable
public class LockEvent
extends AbstractEvent

Defines an event class for the locking of an entity.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
LockEvent(Object object, LockMode lockMode, EventSource source)
LockEvent(String entityName, Object original, LockMode lockMode, EventSource source)
Method Summary
String | getEntityName()
LockMode | getLockMode()
Object | getObject()
void | setEntityName(String entityName)
void | setLockMode(LockMode lockMode)
void | setObject(Object object)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LockEvent

public LockEvent(String entityName,
                 Object original,
                 LockMode lockMode,
                 EventSource source)

LockEvent

public LockEvent(Object object,
                 LockMode lockMode,
                 EventSource source)
Method Detail

getObject

public Object getObject()

setObject

public void setObject(Object object)

getLockMode

public LockMode getLockMode()

setLockMode

public void setLockMode(LockMode lockMode)

getEntityName

public String getEntityName()

setEntityName

public void setEntityName(String entityName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MergeEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class MergeEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.MergeEvent
All Implemented Interfaces:
Serializable
public class MergeEvent
extends AbstractEvent

An event class for merge() and saveOrUpdateCopy()

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
MergeEvent(Object object, EventSource source)
MergeEvent(String entityName, Object original, EventSource source)
MergeEvent(String entityName, Object original, Serializable id, EventSource source)
Method Summary
Object | getEntity()
String | getEntityName()
Object | getOriginal()
Serializable | getRequestedId()
Object | getResult()
void | setEntity(Object entity)
void | setEntityName(String entityName)
void | setOriginal(Object object)
void | setRequestedId(Serializable requestedId)
void | setResult(Object result)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MergeEvent

public MergeEvent(String entityName,
                  Object original,
                  EventSource source)

MergeEvent

public MergeEvent(String entityName,
                  Object original,
                  Serializable id,
                  EventSource source)

MergeEvent

public MergeEvent(Object object,
                  EventSource source)
Method Detail

getOriginal

public Object getOriginal()

setOriginal

public void setOriginal(Object object)

getRequestedId

public Serializable getRequestedId()

setRequestedId

public void setRequestedId(Serializable requestedId)

getEntityName

public String getEntityName()

setEntityName

public void setEntityName(String entityName)

getEntity

public Object getEntity()

setEntity

public void setEntity(Object entity)

getResult

public Object getResult()

setResult

public void setResult(Object result)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class PersistEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.PersistEvent
All Implemented Interfaces:
Serializable
public class PersistEvent
extends AbstractEvent

An event class for persist()

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
PersistEvent(Object object, EventSource source)
PersistEvent(String entityName, Object original, EventSource source)
Method Summary
String | getEntityName()
Object | getObject()
void | setEntityName(String entityName)
void | setObject(Object object)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PersistEvent

public PersistEvent(String entityName,
                    Object original,
                    EventSource source)

PersistEvent

public PersistEvent(Object object,
                    EventSource source)
Method Detail

getObject

public Object getObject()

setObject

public void setObject(Object object)

getEntityName

public String getEntityName()

setEntityName

public void setEntityName(String entityName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PostDeleteEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class PostDeleteEvent

java.lang.Object
    extended by org.hibernate.event.PostDeleteEvent
public class PostDeleteEvent
extends Object

Occurs after deleting an item from the datastore

Author:
Gavin King

Constructor Summary
PostDeleteEvent(Object entity, Serializable id, Object[] deletedState, EntityPersister persister)
Method Summary
Object[] | getDeletedState()
Object | getEntity()
Serializable | getId()
EntityPersister | getPersister()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PostDeleteEvent

public PostDeleteEvent(Object entity,
                       Serializable id,
                       Object[] deletedState,
                       EntityPersister persister)
Method Detail

getId

public Serializable getId()

getPersister

public EntityPersister getPersister()

getEntity

public Object getEntity()

getDeletedState

public Object[] getDeletedState()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PostInsertEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class PostInsertEvent

java.lang.Object
    extended by org.hibernate.event.PostInsertEvent
public class PostInsertEvent
extends Object

Occurs after inserting an item in the datastore

Author:
Gavin King

Constructor Summary
PostInsertEvent(Object entity, Serializable id, Object[] state, EntityPersister persister)
Method Summary
Object | getEntity()
Serializable | getId()
EntityPersister | getPersister()
Object[] | getState()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PostInsertEvent

public PostInsertEvent(Object entity,
                       Serializable id,
                       Object[] state,
                       EntityPersister persister)
Method Detail

getEntity

public Object getEntity()

getId

public Serializable getId()

getPersister

public EntityPersister getPersister()

getState

public Object[] getState()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PostLoadEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class PostLoadEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.PostLoadEvent
All Implemented Interfaces:
Serializable
public class PostLoadEvent
extends AbstractEvent

Occurs after an an entity instance is fully loaded.

Author:
Kabir Khan, Gavin King
See Also:
Serialized Form

Constructor Summary
PostLoadEvent(EventSource session)
Method Summary
Object | getEntity()
Serializable | getId()
EntityPersister | getPersister()
PostLoadEvent | setEntity(Object entity)
PostLoadEvent | setId(Serializable id)
PostLoadEvent | setPersister(EntityPersister persister)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PostLoadEvent

public PostLoadEvent(EventSource session)
Method Detail

getEntity

public Object getEntity()

getPersister

public EntityPersister getPersister()

getId

public Serializable getId()

setEntity

public PostLoadEvent setEntity(Object entity)

setId

public PostLoadEvent setId(Serializable id)

setPersister

public PostLoadEvent setPersister(EntityPersister persister)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PostUpdateEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class PostUpdateEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.PostUpdateEvent
All Implemented Interfaces:
Serializable
public class PostUpdateEvent
extends AbstractEvent

Occurs after the datastore is updated

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
PostUpdateEvent(Object entity, Serializable id, Object[] state, Object[] oldState, EntityPersister persister, EventSource source)
Method Summary
Object | getEntity()
Serializable | getId()
Object[] | getOldState()
EntityPersister | getPersister()
Object[] | getState()
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PostUpdateEvent

public PostUpdateEvent(Object entity,
                       Serializable id,
                       Object[] state,
                       Object[] oldState,
                       EntityPersister persister,
                       EventSource source)
Method Detail

getEntity

public Object getEntity()

getId

public Serializable getId()

getOldState

public Object[] getOldState()

getPersister

public EntityPersister getPersister()

getState

public Object[] getState()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreDeleteEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class PreDeleteEvent

java.lang.Object
    extended by org.hibernate.event.PreDeleteEvent
public class PreDeleteEvent
extends Object

Occurs before deleting an item from the datastore

Author:
Gavin King

Constructor Summary
PreDeleteEvent(Object entity, Serializable id, Object[] deletedState, EntityPersister persister)
Method Summary
Object[] | getDeletedState()
Object | getEntity()
Serializable | getId()
EntityPersister | getPersister()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PreDeleteEvent

public PreDeleteEvent(Object entity,
                      Serializable id,
                      Object[] deletedState,
                      EntityPersister persister)
Method Detail

getEntity

public Object getEntity()

getId

public Serializable getId()

getPersister

public EntityPersister getPersister()

getDeletedState

public Object[] getDeletedState()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreInsertEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class PreInsertEvent

java.lang.Object
    extended by org.hibernate.event.PreInsertEvent
public class PreInsertEvent
extends Object

Occurs before inserting an item in the datastore

Author:
Gavin King

Constructor Summary
PreInsertEvent(Object entity, Serializable id, Object[] state, EntityPersister persister, SessionImplementor source)
Method Summary
Object | getEntity()
Serializable | getId()
EntityPersister | getPersister()
SessionImplementor | getSource()
Object[] | getState()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PreInsertEvent

public PreInsertEvent(Object entity,
                      Serializable id,
                      Object[] state,
                      EntityPersister persister,
                      SessionImplementor source)
Method Detail

getEntity

public Object getEntity()

getId

public Serializable getId()

getPersister

public EntityPersister getPersister()

getState

public Object[] getState()

getSource

public SessionImplementor getSource()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreLoadEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class PreLoadEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.PreLoadEvent
All Implemented Interfaces:
Serializable
public class PreLoadEvent
extends AbstractEvent

Called before injecting property values into a newly loaded entity instance.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
PreLoadEvent(EventSource session)
Method Summary
Object | getEntity()
Serializable | getId()
EntityPersister | getPersister()
Object[] | getState()
PreLoadEvent | setEntity(Object entity)
PreLoadEvent | setId(Serializable id)
PreLoadEvent | setPersister(EntityPersister persister)
PreLoadEvent | setState(Object[] state)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PreLoadEvent

public PreLoadEvent(EventSource session)
Method Detail

getEntity

public Object getEntity()

getId

public Serializable getId()

getPersister

public EntityPersister getPersister()

getState

public Object[] getState()

setEntity

public PreLoadEvent setEntity(Object entity)

setId

public PreLoadEvent setId(Serializable id)

setPersister

public PreLoadEvent setPersister(EntityPersister persister)

setState

public PreLoadEvent setState(Object[] state)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreUpdateEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class PreUpdateEvent

java.lang.Object
    extended by org.hibernate.event.PreUpdateEvent
public class PreUpdateEvent
extends Object

Occurs before updating the datastore

Author:
Gavin King

Constructor Summary
PreUpdateEvent(Object entity, Serializable id, Object[] state, Object[] oldState, EntityPersister persister, SessionImplementor source)
Method Summary
Object | getEntity()
Serializable | getId()
Object[] | getOldState()
EntityPersister | getPersister()
SessionImplementor | getSource()
Object[] | getState()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PreUpdateEvent

public PreUpdateEvent(Object entity,
                      Serializable id,
                      Object[] state,
                      Object[] oldState,
                      EntityPersister persister,
                      SessionImplementor source)
Method Detail

getEntity

public Object getEntity()

getId

public Serializable getId()

getOldState

public Object[] getOldState()

getPersister

public EntityPersister getPersister()

getState

public Object[] getState()

getSource

public SessionImplementor getSource()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RefreshEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class RefreshEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.RefreshEvent
All Implemented Interfaces:
Serializable
public class RefreshEvent
extends AbstractEvent

Defines an event class for the refreshing of an object.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
RefreshEvent(Object object, EventSource source)
RefreshEvent(Object object, LockMode lockMode, EventSource source)
Method Summary
LockMode | getLockMode()
Object | getObject()
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RefreshEvent

public RefreshEvent(Object object,
                    EventSource source)

RefreshEvent

public RefreshEvent(Object object,
                    LockMode lockMode,
                    EventSource source)
Method Detail

getObject

public Object getObject()

getLockMode

public LockMode getLockMode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReplicateEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class ReplicateEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.ReplicateEvent
All Implemented Interfaces:
Serializable
public class ReplicateEvent
extends AbstractEvent

Defines an event class for the replication of an entity.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
ReplicateEvent(Object object, ReplicationMode replicationMode, EventSource source)
ReplicateEvent(String entityName, Object object, ReplicationMode replicationMode, EventSource source)
Method Summary
String | getEntityName()
Object | getObject()
ReplicationMode | getReplicationMode()
void | setEntityName(String entityName)
void | setObject(Object object)
void | setReplicationMode(ReplicationMode replicationMode)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReplicateEvent

public ReplicateEvent(Object object,
                      ReplicationMode replicationMode,
                      EventSource source)

ReplicateEvent

public ReplicateEvent(String entityName,
                      Object object,
                      ReplicationMode replicationMode,
                      EventSource source)
Method Detail

getObject

public Object getObject()

setObject

public void setObject(Object object)

getReplicationMode

public ReplicationMode getReplicationMode()

setReplicationMode

public void setReplicationMode(ReplicationMode replicationMode)

getEntityName

public String getEntityName()

setEntityName

public void setEntityName(String entityName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SaveOrUpdateEvent (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event
Class SaveOrUpdateEvent

java.lang.Object
    extended by org.hibernate.event.AbstractEvent
        extended by org.hibernate.event.SaveOrUpdateEvent
All Implemented Interfaces:
Serializable
public class SaveOrUpdateEvent
extends AbstractEvent

An event class for saveOrUpdate()

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
SaveOrUpdateEvent(Object object, EventSource source)
SaveOrUpdateEvent(String entityName, Object original, EventSource source)
SaveOrUpdateEvent(String entityName, Object original, Serializable id, EventSource source)
Method Summary
Object | getEntity()
String | getEntityName()
EntityEntry | getEntry()
Object | getObject()
Serializable | getRequestedId()
Serializable | getResultId()
void | setEntity(Object entity)
void | setEntityName(String entityName)
void | setEntry(EntityEntry entry)
void | setObject(Object object)
void | setRequestedId(Serializable requestedId)
void | setResultId(Serializable resultId)
Methods inherited from class org.hibernate.event.AbstractEvent
getSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SaveOrUpdateEvent

public SaveOrUpdateEvent(String entityName,
                         Object original,
                         EventSource source)

SaveOrUpdateEvent

public SaveOrUpdateEvent(String entityName,
                         Object original,
                         Serializable id,
                         EventSource source)

SaveOrUpdateEvent

public SaveOrUpdateEvent(Object object,
                         EventSource source)
Method Detail

getObject

public Object getObject()

setObject

public void setObject(Object object)

getRequestedId

public Serializable getRequestedId()

setRequestedId

public void setRequestedId(Serializable requestedId)

getEntityName

public String getEntityName()

setEntityName

public void setEntityName(String entityName)

getEntity

public Object getEntity()

setEntity

public void setEntity(Object entity)

getEntry

public EntityEntry getEntry()

setEntry

public void setEntry(EntityEntry entry)

getResultId

public Serializable getResultId()

setResultId

public void setResultId(Serializable resultId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.event.def (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.event.def

This package defines a default set of event listeners that implements the default behaviors of Hibernate.

See:
Description

Class Summary
AbstractFlushingEventListener | A convenience base class for listeners whose functionality results in flushing.
AbstractLockUpgradeEventListener | A convenience base class for listeners that respond to requests to perform a pessimistic lock upgrade on an entity.
AbstractReassociateEventListener | A convenience base class for listeners that respond to requests to reassociate an entity to a session ( such as through lock() or update() ).
AbstractSaveEventListener | A convenience bas class for listeners responding to save events.
AbstractVisitor | Abstract superclass of algorithms that walk a tree of property values of an entity, and perform specific functionality for collections, components and associated entities.
DefaultAutoFlushEventListener | Defines the default flush event listeners used by hibernate for flushing session state in response to generated auto-flush events.
DefaultDeleteEventListener | Defines the default delete event listener used by hibernate for deleting entities from the datastore in response to generated delete events.
DefaultDirtyCheckEventListener | Defines the default dirty-check event listener used by hibernate for checking the session for dirtiness in response to generated dirty-check events.
DefaultEvictEventListener | Defines the default evict event listener used by hibernate for evicting entities in response to generated flush events.
DefaultFlushEntityEventListener | An event that occurs for each entity instance at flush time
DefaultFlushEventListener | Defines the default flush event listeners used by hibernate for flushing session state in response to generated flush events.
DefaultInitializeCollectionEventListener |
DefaultLoadEventListener | Defines the default load event listeners used by hibernate for loading entities in response to generated load events.
DefaultLockEventListener | Defines the default lock event listeners used by hibernate to lock entities in response to generated lock events.
DefaultMergeEventListener | Defines the default copy event listener used by hibernate for copying entities in response to generated copy events.
DefaultPersistEventListener | Defines the default create event listener used by hibernate for creating transient entities in response to generated create events.
DefaultPersistOnFlushEventListener | When persist is used as the cascade action, persistOnFlush should be used
DefaultPostLoadEventListener | Call Lifecycle interface if necessary
DefaultPreLoadEventListener | Called before injecting property values into a newly loaded entity instance.
DefaultRefreshEventListener | Defines the default refresh event listener used by hibernate for refreshing entities in response to generated refresh events.
DefaultReplicateEventListener | Defines the default replicate event listener used by Hibernate to replicate entities in response to generated replicate events.
DefaultSaveEventListener | An event handler for save() events
DefaultSaveOrUpdateCopyEventListener |
DefaultSaveOrUpdateEventListener | Defines the default update event listener used by hibernate for updating transient entities in response to generated update events.
DefaultUpdateEventListener | An event handler for update() events
DirtyCollectionSearchVisitor | Do we have a dirty collection here? 1.
EvictVisitor | Evict any collections referenced by the object from the session cache.
FlushVisitor | Process collections reachable from an entity.
OnLockVisitor | When a transient entity is passed to lock(), we must inspect all its collections and 1.
OnReplicateVisitor | When an entity is passed to replicate(), and there is an existing row, we must inspect all its collections and 1.
OnUpdateVisitor | When an entity is passed to update(), we must inspect all its collections and 1.
ProxyVisitor | Reassociates uninitialized proxies with the session
ReattachVisitor | Abstract superclass of visitors that reattach collections
WrapVisitor | Wrap collections in a Hibernate collection wrapper.

Package org.hibernate.event.def Description

This package defines a default set of event listeners that implements the default behaviors of Hibernate.


org.hibernate.event.def Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.event.def

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.event.def.AbstractFlushingEventListener (implements java.io.Serializable)
      • class org.hibernate.event.def.DefaultAutoFlushEventListener (implements org.hibernate.event.AutoFlushEventListener)
      • class org.hibernate.event.def.DefaultDirtyCheckEventListener (implements org.hibernate.event.DirtyCheckEventListener)
      • class org.hibernate.event.def.DefaultFlushEventListener (implements org.hibernate.event.FlushEventListener)
    • class org.hibernate.event.def.AbstractReassociateEventListener (implements java.io.Serializable)
      • class org.hibernate.event.def.AbstractLockUpgradeEventListener
        • class org.hibernate.event.def.DefaultLoadEventListener (implements org.hibernate.event.LoadEventListener)
        • class org.hibernate.event.def.DefaultLockEventListener (implements org.hibernate.event.LockEventListener)
      • class org.hibernate.event.def.AbstractSaveEventListener
        • class org.hibernate.event.def.DefaultMergeEventListener (implements org.hibernate.event.MergeEventListener)
          • class org.hibernate.event.def.DefaultSaveOrUpdateCopyEventListener
        • class org.hibernate.event.def.DefaultPersistEventListener (implements org.hibernate.event.PersistEventListener)
          • class org.hibernate.event.def.DefaultPersistOnFlushEventListener
        • class org.hibernate.event.def.DefaultReplicateEventListener (implements org.hibernate.event.ReplicateEventListener)
        • class org.hibernate.event.def.DefaultSaveOrUpdateEventListener (implements org.hibernate.event.SaveOrUpdateEventListener)
          • class org.hibernate.event.def.DefaultSaveEventListener
          • class org.hibernate.event.def.DefaultUpdateEventListener
    • class org.hibernate.event.def.AbstractVisitor
      • class org.hibernate.event.def.DirtyCollectionSearchVisitor
      • class org.hibernate.event.def.EvictVisitor
      • class org.hibernate.event.def.FlushVisitor
      • class org.hibernate.event.def.ProxyVisitor
        • class org.hibernate.event.def.ReattachVisitor
          • class org.hibernate.event.def.OnLockVisitor
          • class org.hibernate.event.def.OnReplicateVisitor
          • class org.hibernate.event.def.OnUpdateVisitor
        • class org.hibernate.event.def.WrapVisitor
    • class org.hibernate.event.def.DefaultDeleteEventListener (implements org.hibernate.event.DeleteEventListener)
    • class org.hibernate.event.def.DefaultEvictEventListener (implements org.hibernate.event.EvictEventListener)
    • class org.hibernate.event.def.DefaultFlushEntityEventListener (implements org.hibernate.event.FlushEntityEventListener)
    • class org.hibernate.event.def.DefaultInitializeCollectionEventListener (implements org.hibernate.event.InitializeCollectionEventListener)
    • class org.hibernate.event.def.DefaultPostLoadEventListener (implements org.hibernate.event.PostLoadEventListener)
    • class org.hibernate.event.def.DefaultPreLoadEventListener (implements org.hibernate.event.PreLoadEventListener)
    • class org.hibernate.event.def.DefaultRefreshEventListener (implements org.hibernate.event.RefreshEventListener)


Uses of Package org.hibernate.event.def (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.event.def

Packages that use org.hibernate.event.def
org.hibernate.event.def This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Classes in org.hibernate.event.def used by org.hibernate.event.def
AbstractFlushingEventListener
A convenience base class for listeners whose functionality results in flushing.
AbstractLockUpgradeEventListener
A convenience base class for listeners that respond to requests to perform a pessimistic lock upgrade on an entity.
AbstractReassociateEventListener
A convenience base class for listeners that respond to requests to reassociate an entity to a session ( such as through lock() or update() ).
AbstractSaveEventListener
A convenience bas class for listeners responding to save events.
AbstractVisitor
Abstract superclass of algorithms that walk a tree of property values of an entity, and perform specific functionality for collections, components and associated entities.
DefaultMergeEventListener
Defines the default copy event listener used by hibernate for copying entities in response to generated copy events.
DefaultPersistEventListener
Defines the default create event listener used by hibernate for creating transient entities in response to generated create events.
DefaultSaveOrUpdateEventListener
Defines the default update event listener used by hibernate for updating transient entities in response to generated update events.
ProxyVisitor
Reassociates uninitialized proxies with the session
ReattachVisitor
Abstract superclass of visitors that reattach collections

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractFlushingEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class AbstractFlushingEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractFlushingEventListener
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
DefaultAutoFlushEventListener, DefaultDirtyCheckEventListener, DefaultFlushEventListener
public abstract class AbstractFlushingEventListener
extends Object
implements Serializable

A convenience base class for listeners whose functionality results in flushing.

Author:
Steve Eberole
See Also:
Serialized Form

Constructor Summary
AbstractFlushingEventListener()
Method Summary
protected void | flushEverythingToExecutions(FlushEvent event) Coordinates the processing necessary to get things ready for executions as db calls by preping the session caches and moving the appropriate entities and collections to their respective execution queues.
protected Object | getAnything()
protected CascadingAction | getCascadingAction()
protected void | performExecutions(EventSource session) Execute all SQL and second-level cache updates, in a special order so that foreign-key constraints cannot be violated: Inserts, in the order they were performed Updates Deletion of collection elements Insertion of collection elements Deletes, in the order they were performed
protected void | postFlush(SessionImplementor session) 1.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbstractFlushingEventListener

public AbstractFlushingEventListener()
Method Detail

flushEverythingToExecutions

protected void flushEverythingToExecutions(FlushEvent event)
                                    throws HibernateException
Coordinates the processing necessary to get things ready for executions as db calls by preping the session caches and moving the appropriate entities and collections to their respective execution queues.

Parameters:
event - The flush event.
Throws:
HibernateException - Error flushing caches to execution queues.

getAnything

protected Object getAnything()

getCascadingAction

protected CascadingAction getCascadingAction()

performExecutions

protected void performExecutions(EventSource session)
                          throws HibernateException
Execute all SQL and second-level cache updates, in a special order so that foreign-key constraints cannot be violated:
  1. Inserts, in the order they were performed
  2. Updates
  3. Deletion of collection elements
  4. Insertion of collection elements
  5. Deletes, in the order they were performed

Throws:
HibernateException

postFlush

protected void postFlush(SessionImplementor session)
                  throws HibernateException
1. Recreate the collection key -> collection map 2. rebuild the collection entries 3. call Interceptor.postFlush()

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractLockUpgradeEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class AbstractLockUpgradeEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
        extended by org.hibernate.event.def.AbstractLockUpgradeEventListener
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
DefaultLoadEventListener, DefaultLockEventListener
public class AbstractLockUpgradeEventListener
extends AbstractReassociateEventListener

A convenience base class for listeners that respond to requests to perform a pessimistic lock upgrade on an entity.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
AbstractLockUpgradeEventListener()
Method Summary
protected  void upgradeLock(Object object, EntityEntry entry, LockMode requestedLockMode, SessionImplementor source)
Performs a pessimistic lock upgrade on a given entity, if needed.
Methods inherited from class org.hibernate.event.def.AbstractReassociateEventListener
reassociate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbstractLockUpgradeEventListener

public AbstractLockUpgradeEventListener()
Method Detail

upgradeLock

protected void upgradeLock(Object object,
                           EntityEntry entry,
                           LockMode requestedLockMode,
                           SessionImplementor source)
                    throws HibernateException
Performs a pessimistic lock upgrade on a given entity, if needed.

Parameters:
object - The entity for which to upgrade the lock.
entry - The entity's EntityEntry instance.
requestedLockMode - The lock mode being requested for locking.
source - The session which is the source of the event being processed.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractReassociateEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class AbstractReassociateEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
AbstractLockUpgradeEventListener, AbstractSaveEventListener
public class AbstractReassociateEventListener
extends Object
implements Serializable

A convenience base class for listeners that respond to requests to reassociate an entity to a session ( such as through lock() or update() ).

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
AbstractReassociateEventListener()
Method Summary
protected  EntityEntry reassociate(AbstractEvent event, Object object, Serializable id, EntityPersister persister)
Associates a given entity (either transient or associated with another session) to the given session.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbstractReassociateEventListener

public AbstractReassociateEventListener()
Method Detail

reassociate

protected final EntityEntry reassociate(AbstractEvent event,
                                        Object object,
                                        Serializable id,
                                        EntityPersister persister)
                                 throws HibernateException
Associates a given entity (either transient or associated with another session) to the given session.

Parameters:
event - The event triggering the re-association
object - The entity to be associated
id - The id of the entity.
persister - The entity's persister instance.
Returns:
An EntityEntry representing the entity within this session.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractSaveEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class AbstractSaveEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
        extended by org.hibernate.event.def.AbstractSaveEventListener
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
DefaultMergeEventListener, DefaultPersistEventListener, DefaultReplicateEventListener, DefaultSaveOrUpdateEventListener
public abstract class AbstractSaveEventListener
extends AbstractReassociateEventListener

A convenience bas class for listeners responding to save events.

Author:
Steve Ebersole.
See Also:
Serialized Form

Field Summary
protected static int | DELETED
protected static int | DETACHED
protected static int | PERSISTENT
protected static int | TRANSIENT
Constructor Summary
AbstractSaveEventListener()
Method Summary
protected void | cascadeAfterSave(EventSource source, EntityPersister persister, Object entity, Object anything) Handles to calls needed to perform post-save cascades.
protected void | cascadeBeforeSave(EventSource source, EntityPersister persister, Object entity, Object anything) Handles the calls needed to perform pre-save cascades for the given entity.
protected Boolean | getAssumedUnsaved()
protected abstract CascadingAction | getCascadeAction()
protected int | getEntityState(Object entity, String entityName, EntityEntry entry, SessionImplementor source) Determine whether the entity is persistent, detached, or transient
protected String | getLoggableName(String entityName, Object entity)
protected Map | getMergeMap(Object anything)
protected boolean | invokeSaveLifecycle(Object entity, EntityPersister persister, EventSource source)
protected boolean | isVersionIncrementDisabled() After the save, will te version number be incremented if the instance is modified?
protected Serializable | performSave(Object entity, Serializable id, EntityPersister persister, boolean useIdentityColumn, Object anything, EventSource source, boolean requiresImmediateIdAccess) Ppepares the save call by checking the session caches for a pre-existing entity and performing any lifecycle callbacks.
protected Serializable | performSaveOrReplicate(Object entity, EntityKey key, EntityPersister persister, boolean useIdentityColumn, Object anything, EventSource source, boolean requiresImmediateIdAccess) Performs all the actual work needed to save an entity (well to get the save moved to the execution queue).
protected Serializable | saveWithGeneratedId(Object entity, String entityName, Object anything, EventSource source, boolean requiresImmediateIdAccess) Prepares the save call using a newly generated id.
protected Serializable | saveWithRequestedId(Object entity, Serializable requestedId, String entityName, Object anything, EventSource source) Prepares the save call using the given requested id.
protected boolean | substituteValuesIfNecessary(Object entity, Serializable id, Object[] values, EntityPersister persister, SessionImplementor source) Perform any property value substitution that is necessary (interceptor callback, version initialization...)
protected void | validate(Object entity, EntityPersister persister, EventSource source)
protected boolean | visitCollectionsBeforeSave(Serializable id, Object[] values, Type[] types, EventSource source)
Methods inherited from class org.hibernate.event.def.AbstractReassociateEventListener
reassociate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PERSISTENT

protected static final int PERSISTENT
See Also:
Constant Field Values

TRANSIENT

protected static final int TRANSIENT
See Also:
Constant Field Values

DETACHED

protected static final int DETACHED
See Also:
Constant Field Values

DELETED

protected static final int DELETED
See Also:
Constant Field Values
Constructor Detail

AbstractSaveEventListener

public AbstractSaveEventListener()
Method Detail

saveWithRequestedId

protected Serializable saveWithRequestedId(Object entity,
                                           Serializable requestedId,
                                           String entityName,
                                           Object anything,
                                           EventSource source)
                                    throws HibernateException
Prepares the save call using the given requested id.

Parameters:
entity - The entity to be saved.
requestedId - The id to which to associate the entity.
source - The session which is the source of this save event.
Returns:
The id used to save the entity.
Throws:
HibernateException

saveWithGeneratedId

protected Serializable saveWithGeneratedId(Object entity,
                                           String entityName,
                                           Object anything,
                                           EventSource source,
                                           boolean requiresImmediateIdAccess)
                                    throws HibernateException
Prepares the save call using a newly generated id.

Parameters:
entity - The entity to be saved
entityName - The entity-name for the entity to be saved
source - The session which is the source of this save event.
requiresImmediateIdAccess - does the event context require access to the identifier immediately after execution of this method (if not, post-insert style id generators may be postponed if we are outside a transaction).
Returns:
The id used to save the entity; may be null depending on the type of id generator used and the requiresImmediateIdAccess value
Throws:
HibernateException

performSave

protected Serializable performSave(Object entity,
                                   Serializable id,
                                   EntityPersister persister,
                                   boolean useIdentityColumn,
                                   Object anything,
                                   EventSource source,
                                   boolean requiresImmediateIdAccess)
                            throws HibernateException
Ppepares the save call by checking the session caches for a pre-existing entity and performing any lifecycle callbacks.

Parameters:
entity - The entity to be saved.
id - The id by which to save the entity.
persister - The entity's persister instance.
useIdentityColumn - Is an identity column in use?
source - The session from which the event originated.
requiresImmediateIdAccess - does the event context require access to the identifier immediately after execution of this method (if not, post-insert style id generators may be postponed if we are outside a transaction).
Returns:
The id used to save the entity; may be null depending on the type of id generator used and the requiresImmediateIdAccess value
Throws:
HibernateException

invokeSaveLifecycle

protected boolean invokeSaveLifecycle(Object entity,
                                      EntityPersister persister,
                                      EventSource source)

validate

protected void validate(Object entity,
                        EntityPersister persister,
                        EventSource source)

performSaveOrReplicate

protected Serializable performSaveOrReplicate(Object entity,
                                              EntityKey key,
                                              EntityPersister persister,
                                              boolean useIdentityColumn,
                                              Object anything,
                                              EventSource source,
                                              boolean requiresImmediateIdAccess)
                                       throws HibernateException
Performs all the actual work needed to save an entity (well to get the save moved to the execution queue).

Parameters:
entity - The entity to be saved
key - The id to be used for saving the entity (or null, in the case of identity columns)
persister - The entity's persister instance.
useIdentityColumn - Should an identity column be used for id generation?
source - The session which is the source of the current event.
Returns:
The id used to save the entity; may be null depending on the type of id generator used and the requiresImmediateIdAccess value
Throws:
HibernateException

getMergeMap

protected Map getMergeMap(Object anything)

isVersionIncrementDisabled

protected boolean isVersionIncrementDisabled()
After the save, will te version number be incremented if the instance is modified?

visitCollectionsBeforeSave

protected boolean visitCollectionsBeforeSave(Serializable id,
                                             Object[] values,
                                             Type[] types,
                                             EventSource source)

substituteValuesIfNecessary

protected boolean substituteValuesIfNecessary(Object entity,
                                              Serializable id,
                                              Object[] values,
                                              EntityPersister persister,
                                              SessionImplementor source)
Perform any property value substitution that is necessary (interceptor callback, version initialization...)

cascadeBeforeSave

protected void cascadeBeforeSave(EventSource source,
                                 EntityPersister persister,
                                 Object entity,
                                 Object anything)
                          throws HibernateException
Handles the calls needed to perform pre-save cascades for the given entity.

Parameters:
source - The session from whcih the save event originated.
persister - The entity's persister instance.
entity - The entity to be saved.
Throws:
HibernateException

cascadeAfterSave

protected void cascadeAfterSave(EventSource source,
                                EntityPersister persister,
                                Object entity,
                                Object anything)
                         throws HibernateException
Handles to calls needed to perform post-save cascades.

Parameters:
source - The session from which the event originated.
persister - The entity's persister instance.
entity - The entity beng saved.
Throws:
HibernateException

getCascadeAction

protected abstract CascadingAction getCascadeAction()

getEntityState

protected int getEntityState(Object entity,
                             String entityName,
                             EntityEntry entry,
                             SessionImplementor source)
Determine whether the entity is persistent, detached, or transient

getLoggableName

protected String getLoggableName(String entityName,
                                 Object entity)

getAssumedUnsaved

protected Boolean getAssumedUnsaved()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractVisitor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class AbstractVisitor

java.lang.Object
    extended by org.hibernate.event.def.AbstractVisitor
Direct Known Subclasses:
DirtyCollectionSearchVisitor, EvictVisitor, FlushVisitor, ProxyVisitor
public abstract class AbstractVisitor
extends Object

Abstract superclass of algorithms that walk a tree of property values of an entity, and perform specific functionality for collections, components and associated entities.

Author:
Gavin King

Method Summary
 void processEntityPropertyValues(Object[] values, Type[] types)
Dispatch each property value to processValue().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

processEntityPropertyValues

public void processEntityPropertyValues(Object[] values,
                                        Type[] types)
                                 throws HibernateException
Dispatch each property value to processValue().

Parameters:
values -
types -
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultAutoFlushEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultAutoFlushEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractFlushingEventListener
        extended by org.hibernate.event.def.DefaultAutoFlushEventListener
All Implemented Interfaces:
AutoFlushEventListener, Serializable
public class DefaultAutoFlushEventListener
extends AbstractFlushingEventListener
implements AutoFlushEventListener

Defines the default flush event listeners used by hibernate for flushing session state in response to generated auto-flush events.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
DefaultAutoFlushEventListener()
Method Summary
 void onAutoFlush(AutoFlushEvent event)
Handle the given auto-flush event.
Methods inherited from class org.hibernate.event.def.AbstractFlushingEventListener
flushEverythingToExecutions, getAnything, getCascadingAction, performExecutions, postFlush
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultAutoFlushEventListener

public DefaultAutoFlushEventListener()
Method Detail

onAutoFlush

public void onAutoFlush(AutoFlushEvent event)
                 throws HibernateException
Handle the given auto-flush event.

Specified by:
onAutoFlush in interface AutoFlushEventListener
Parameters:
event - The auto-flush event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultDeleteEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultDeleteEventListener

java.lang.Object
    extended by org.hibernate.event.def.DefaultDeleteEventListener
All Implemented Interfaces:
DeleteEventListener, Serializable
public class DefaultDeleteEventListener
extends Object
implements DeleteEventListener

Defines the default delete event listener used by hibernate for deleting entities from the datastore in response to generated delete events.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
DefaultDeleteEventListener()
Method Summary
protected void | cascadeAfterDelete(EventSource session, EntityPersister persister, Object entity, Set transientEntities)
protected void | cascadeBeforeDelete(EventSource session, EntityPersister persister, Object entity, EntityEntry entityEntry, Set transientEntities)
protected void | deleteEntity(EventSource session, Object entity, EntityEntry entityEntry, boolean isCascadeDeleteEnabled, EntityPersister persister, Set transientEntities)
protected void | deleteTransientEntity(EventSource session, Object entity, boolean cascadeDeleteEnabled, EntityPersister persister, Set transientEntities) We encountered a delete request on a transient instance.
protected boolean | invokeDeleteLifecycle(EventSource session, Object entity, EntityPersister persister)
void | onDelete(DeleteEvent event) Handle the given delete event.
void | onDelete(DeleteEvent event, Set transientEntities)
protected void | performDetachedEntityDeletionCheck(DeleteEvent event)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultDeleteEventListener

public DefaultDeleteEventListener()
Method Detail

onDelete

public void onDelete(DeleteEvent event)
              throws HibernateException
Handle the given delete event.

Specified by:
onDelete in interface DeleteEventListener
Parameters:
event - The delete event to be handled.
Throws:
HibernateException

onDelete

public void onDelete(DeleteEvent event,
                     Set transientEntities)
              throws HibernateException
Specified by:
onDelete in interface DeleteEventListener
Throws:
HibernateException

performDetachedEntityDeletionCheck

protected void performDetachedEntityDeletionCheck(DeleteEvent event)

deleteTransientEntity

protected void deleteTransientEntity(EventSource session,
                                     Object entity,
                                     boolean cascadeDeleteEnabled,
                                     EntityPersister persister,
                                     Set transientEntities)
We encountered a delete request on a transient instance.

This is a deviation from historical Hibernate (pre-3.2) behavior to align with the JPA spec, which states that transient entities can be passed to remove operation in which case cascades still need to be performed.

Parameters:
session - The session which is the source of the event
entity - The entity being delete processed
cascadeDeleteEnabled -
persister - The entity persister

deleteEntity

protected final void deleteEntity(EventSource session,
                                  Object entity,
                                  EntityEntry entityEntry,
                                  boolean isCascadeDeleteEnabled,
                                  EntityPersister persister,
                                  Set transientEntities)
                           throws HibernateException
Throws:
HibernateException

invokeDeleteLifecycle

protected boolean invokeDeleteLifecycle(EventSource session,
                                        Object entity,
                                        EntityPersister persister)

cascadeBeforeDelete

protected void cascadeBeforeDelete(EventSource session,
                                   EntityPersister persister,
                                   Object entity,
                                   EntityEntry entityEntry,
                                   Set transientEntities)
                            throws HibernateException
Throws:
HibernateException

cascadeAfterDelete

protected void cascadeAfterDelete(EventSource session,
                                  EntityPersister persister,
                                  Object entity,
                                  Set transientEntities)
                           throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultDirtyCheckEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultDirtyCheckEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractFlushingEventListener
        extended by org.hibernate.event.def.DefaultDirtyCheckEventListener
All Implemented Interfaces:
DirtyCheckEventListener, Serializable
public class DefaultDirtyCheckEventListener
extends AbstractFlushingEventListener
implements DirtyCheckEventListener

Defines the default dirty-check event listener used by hibernate for checking the session for dirtiness in response to generated dirty-check events.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
DefaultDirtyCheckEventListener()
Method Summary
 void onDirtyCheck(DirtyCheckEvent event)
Handle the given dirty-check event.
Methods inherited from class org.hibernate.event.def.AbstractFlushingEventListener
flushEverythingToExecutions, getAnything, getCascadingAction, performExecutions, postFlush
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultDirtyCheckEventListener

public DefaultDirtyCheckEventListener()
Method Detail

onDirtyCheck

public void onDirtyCheck(DirtyCheckEvent event)
                  throws HibernateException
Handle the given dirty-check event.

Specified by:
onDirtyCheck in interface DirtyCheckEventListener
Parameters:
event - The dirty-check event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultEvictEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultEvictEventListener

java.lang.Object
    extended by org.hibernate.event.def.DefaultEvictEventListener
All Implemented Interfaces:
EvictEventListener, Serializable
public class DefaultEvictEventListener
extends Object
implements EvictEventListener

Defines the default evict event listener used by hibernate for evicting entities in response to generated flush events. In particular, this implementation will remove any hard references to the entity that are held by the infrastructure (references held by application or other persistent instances are okay)

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
DefaultEvictEventListener()
Method Summary
protected void | doEvict(Object object, EntityKey key, EntityPersister persister, EventSource session)
void | onEvict(EvictEvent event) Handle the given evict event.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultEvictEventListener

public DefaultEvictEventListener()
Method Detail

onEvict

public void onEvict(EvictEvent event)
             throws HibernateException
Handle the given evict event.

Specified by:
onEvict in interface EvictEventListener
Parameters:
event - The evict event to be handled.
Throws:
HibernateException

doEvict

protected void doEvict(Object object,
                       EntityKey key,
                       EntityPersister persister,
                       EventSource session)
                throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultFlushEntityEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultFlushEntityEventListener

java.lang.Object
    extended by org.hibernate.event.def.DefaultFlushEntityEventListener
All Implemented Interfaces:
FlushEntityEventListener, Serializable
public class DefaultFlushEntityEventListener
extends Object
implements FlushEntityEventListener

An event that occurs for each entity instance at flush time

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
DefaultFlushEntityEventListener()
Method Summary
void | checkId(Object object, EntityPersister persister, Serializable id, EntityMode entityMode) make sure user didn't mangle the id
protected void | dirtyCheck(FlushEntityEvent event) Perform a dirty check, and attach the results to the event
protected boolean | handleInterception(FlushEntityEvent event)
protected boolean | invokeInterceptor(SessionImplementor session, Object entity, EntityEntry entry, Object[] values, EntityPersister persister)
protected boolean | isUpdateNecessary(FlushEntityEvent event) Performs all necessary checking to determine if an entity needs an SQL update to synchronize its state to the database.
void | onFlushEntity(FlushEntityEvent event) Flushes a single entity's state to the database, by scheduling an update action, if necessary
protected void | validate(Object entity, EntityPersister persister, Status status, EntityMode entityMode)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultFlushEntityEventListener

public DefaultFlushEntityEventListener()
Method Detail

checkId

public void checkId(Object object,
                    EntityPersister persister,
                    Serializable id,
                    EntityMode entityMode)
             throws HibernateException
make sure user didn't mangle the id

Throws:
HibernateException

onFlushEntity

public void onFlushEntity(FlushEntityEvent event)
                   throws HibernateException
Flushes a single entity's state to the database, by scheduling an update action, if necessary

Specified by:
onFlushEntity in interface FlushEntityEventListener
Throws:
HibernateException

validate

protected void validate(Object entity,
                        EntityPersister persister,
                        Status status,
                        EntityMode entityMode)

handleInterception

protected boolean handleInterception(FlushEntityEvent event)

invokeInterceptor

protected boolean invokeInterceptor(SessionImplementor session,
                                    Object entity,
                                    EntityEntry entry,
                                    Object[] values,
                                    EntityPersister persister)

isUpdateNecessary

protected final boolean isUpdateNecessary(FlushEntityEvent event)
                                   throws HibernateException
Performs all necessary checking to determine if an entity needs an SQL update to synchronize its state to the database. Modifies the event by side-effect! Note: this method is quite slow, avoid calling if possible!

Throws:
HibernateException

dirtyCheck

protected void dirtyCheck(FlushEntityEvent event)
                   throws HibernateException
Perform a dirty check, and attach the results to the event

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultFlushEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultFlushEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractFlushingEventListener
        extended by org.hibernate.event.def.DefaultFlushEventListener
All Implemented Interfaces:
FlushEventListener, Serializable
public class DefaultFlushEventListener
extends AbstractFlushingEventListener
implements FlushEventListener

Defines the default flush event listeners used by hibernate for flushing session state in response to generated flush events.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
DefaultFlushEventListener()
Method Summary
 void onFlush(FlushEvent event)
Handle the given flush event.
Methods inherited from class org.hibernate.event.def.AbstractFlushingEventListener
flushEverythingToExecutions, getAnything, getCascadingAction, performExecutions, postFlush
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultFlushEventListener

public DefaultFlushEventListener()
Method Detail

onFlush

public void onFlush(FlushEvent event)
             throws HibernateException
Handle the given flush event.

Specified by:
onFlush in interface FlushEventListener
Parameters:
event - The flush event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultInitializeCollectionEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultInitializeCollectionEventListener

java.lang.Object
    extended by org.hibernate.event.def.DefaultInitializeCollectionEventListener
All Implemented Interfaces:
InitializeCollectionEventListener, Serializable
public class DefaultInitializeCollectionEventListener
extends Object
implements InitializeCollectionEventListener

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
DefaultInitializeCollectionEventListener()
Method Summary
 void onInitializeCollection(InitializeCollectionEvent event)
called by a collection that wants to initialize itself
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultInitializeCollectionEventListener

public DefaultInitializeCollectionEventListener()
Method Detail

onInitializeCollection

public void onInitializeCollection(InitializeCollectionEvent event)
                            throws HibernateException
called by a collection that wants to initialize itself

Specified by:
onInitializeCollection in interface InitializeCollectionEventListener
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultLoadEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultLoadEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
        extended by org.hibernate.event.def.AbstractLockUpgradeEventListener
            extended by org.hibernate.event.def.DefaultLoadEventListener
All Implemented Interfaces:
LoadEventListener, Serializable
public class DefaultLoadEventListener
extends AbstractLockUpgradeEventListener
implements LoadEventListener

Defines the default load event listeners used by hibernate for loading entities in response to generated load events.

Author:
Steve Ebersole
See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class org.hibernate.event.LoadEventListener
LoadEventListener.LoadType
Field Summary
static LockMode | DEFAULT_LOCK_MODE
protected static Object | REMOVED_ENTITY_MARKER
Fields inherited from interface org.hibernate.event.LoadEventListener
GET, IMMEDIATE_LOAD, INTERNAL_LOAD_EAGER, INTERNAL_LOAD_LAZY, INTERNAL_LOAD_NULLABLE, LOAD, RELOAD
Constructor Summary
DefaultLoadEventListener()
Method Summary
protected Object | doLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Coordinates the efforts to load a given entity.
protected Object | load(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Perfoms the load of an entity.
protected Object | loadFromDatasource(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Performs the process of loading an entity from the configured underlying datasource.
protected Object | loadFromSecondLevelCache(LoadEvent event, EntityPersister persister, LoadEventListener.LoadType options) Attempts to load the entity from the second-level cache.
protected Object | loadFromSessionCache(LoadEvent event, EntityKey keyToLoad, LoadEventListener.LoadType options) Attempts to locate the entity in the session-level cache.
protected Object | lockAndLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options, SessionImplementor source) If the class to be loaded has been configured with a cache, then lock given id in that cache and then perform the load.
void | onLoad(LoadEvent event, LoadEventListener.LoadType loadType) Handle the given load event.
protected Object | proxyOrLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Based on configured options, will either return a pre-existing proxy, generate a new proxy, or perform an actual load.
Methods inherited from class org.hibernate.event.def.AbstractLockUpgradeEventListener
upgradeLock
Methods inherited from class org.hibernate.event.def.AbstractReassociateEventListener
reassociate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_LOCK_MODE

public static final LockMode DEFAULT_LOCK_MODE

REMOVED_ENTITY_MARKER

protected static final Object REMOVED_ENTITY_MARKER
Constructor Detail

DefaultLoadEventListener

public DefaultLoadEventListener()
Method Detail

onLoad

public void onLoad(LoadEvent event,
                   LoadEventListener.LoadType loadType)
            throws HibernateException
Handle the given load event.

Specified by:
onLoad in interface LoadEventListener
Parameters:
event - The load event to be handled.
Returns:
The result (i.e., the loaded entity).
Throws:
HibernateException

load

protected Object load(LoadEvent event,
                      EntityPersister persister,
                      EntityKey keyToLoad,
                      LoadEventListener.LoadType options)
               throws HibernateException
Perfoms the load of an entity.

Returns:
The loaded entity.
Throws:
HibernateException

proxyOrLoad

protected Object proxyOrLoad(LoadEvent event,
                             EntityPersister persister,
                             EntityKey keyToLoad,
                             LoadEventListener.LoadType options)
                      throws HibernateException
Based on configured options, will either return a pre-existing proxy, generate a new proxy, or perform an actual load.

Returns:
The result of the proxy/load operation.
Throws:
HibernateException

lockAndLoad

protected Object lockAndLoad(LoadEvent event,
                             EntityPersister persister,
                             EntityKey keyToLoad,
                             LoadEventListener.LoadType options,
                             SessionImplementor source)
                      throws HibernateException
If the class to be loaded has been configured with a cache, then lock given id in that cache and then perform the load.

Returns:
The loaded entity
Throws:
HibernateException

doLoad

protected Object doLoad(LoadEvent event,
                        EntityPersister persister,
                        EntityKey keyToLoad,
                        LoadEventListener.LoadType options)
                 throws HibernateException
Coordinates the efforts to load a given entity. First, an attempt is made to load the entity from the session-level cache. If not found there, an attempt is made to locate it in second-level cache. Lastly, an attempt is made to load it directly from the datasource.

Returns:
The loaded entity.
Throws:
HibernateException

loadFromDatasource

protected Object loadFromDatasource(LoadEvent event,
                                    EntityPersister persister,
                                    EntityKey keyToLoad,
                                    LoadEventListener.LoadType options)
                             throws HibernateException
Performs the process of loading an entity from the configured underlying datasource.

Returns:
The object loaded from the datasource, or null if not found.
Throws:
HibernateException

loadFromSessionCache

protected Object loadFromSessionCache(LoadEvent event,
                                      EntityKey keyToLoad,
                                      LoadEventListener.LoadType options)
                               throws HibernateException
Attempts to locate the entity in the session-level cache. If checkDeleted was set to true, then if the entity is found in the session-level cache, it's current status within the session cache is checked to see if it has previously been scheduled for deletion.

Returns:
The entity from the session-level cache, or null.
Throws:
HibernateException

loadFromSecondLevelCache

protected Object loadFromSecondLevelCache(LoadEvent event,
                                          EntityPersister persister,
                                          LoadEventListener.LoadType options)
                                   throws HibernateException
Attempts to load the entity from the second-level cache.

Returns:
The entity from the second-level cache, or null.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultLockEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultLockEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
        extended by org.hibernate.event.def.AbstractLockUpgradeEventListener
            extended by org.hibernate.event.def.DefaultLockEventListener
All Implemented Interfaces:
LockEventListener, Serializable
public class DefaultLockEventListener
extends AbstractLockUpgradeEventListener
implements LockEventListener

Defines the default lock event listeners used by hibernate to lock entities in response to generated lock events.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
DefaultLockEventListener()
Method Summary
 void onLock(LockEvent event)
Handle the given lock event.
Methods inherited from class org.hibernate.event.def.AbstractLockUpgradeEventListener
upgradeLock
Methods inherited from class org.hibernate.event.def.AbstractReassociateEventListener
reassociate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultLockEventListener

public DefaultLockEventListener()
Method Detail

onLock

public void onLock(LockEvent event)
            throws HibernateException
Handle the given lock event.

Specified by:
onLock in interface LockEventListener
Parameters:
event - The lock event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultMergeEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultMergeEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
        extended by org.hibernate.event.def.AbstractSaveEventListener
            extended by org.hibernate.event.def.DefaultMergeEventListener
All Implemented Interfaces:
MergeEventListener, Serializable
Direct Known Subclasses:
DefaultSaveOrUpdateCopyEventListener
public class DefaultMergeEventListener
extends AbstractSaveEventListener
implements MergeEventListener

Defines the default copy event listener used by hibernate for copying entities in response to generated copy events.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.event.def.AbstractSaveEventListener
DELETED, DETACHED, PERSISTENT, TRANSIENT
Constructor Summary
DefaultMergeEventListener()
Method Summary
protected void | cascadeAfterSave(EventSource source, EntityPersister persister, Object entity, Object anything) Cascade behavior is redefined by this subclass, disable superclass behavior
protected void | cascadeBeforeSave(EventSource source, EntityPersister persister, Object entity, Object anything) Cascade behavior is redefined by this subclass, disable superclass behavior
protected void | cascadeOnMerge(EventSource source, EntityPersister persister, Object entity, Map copyCache) Perform any cascades needed as part of this copy event.
protected void | copyValues(EntityPersister persister, Object entity, Object target, SessionImplementor source, Map copyCache)
protected void | copyValues(EntityPersister persister, Object entity, Object target, SessionImplementor source, Map copyCache, ForeignKeyDirection foreignKeyDirection)
protected void | entityIsDetached(MergeEvent event, Map copyCache)
protected void | entityIsPersistent(MergeEvent event, Map copyCache)
protected void | entityIsTransient(MergeEvent event, Map copyCache)
protected Boolean | getAssumedUnsaved()
protected CascadingAction | getCascadeAction()
protected Map | getMergeMap(Object anything)
void | onMerge(MergeEvent event) Handle the given merge event.
void | onMerge(MergeEvent event, Map copyCache) Handle the given merge event.
Methods inherited from class org.hibernate.event.def.AbstractSaveEventListener
getEntityState, getLoggableName, invokeSaveLifecycle, isVersionIncrementDisabled, performSave, performSaveOrReplicate, saveWithGeneratedId, saveWithRequestedId, substituteValuesIfNecessary, validate, visitCollectionsBeforeSave
Methods inherited from class org.hibernate.event.def.AbstractReassociateEventListener
reassociate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultMergeEventListener

public DefaultMergeEventListener()
Method Detail

getMergeMap

protected Map getMergeMap(Object anything)
Overrides:
getMergeMap in class AbstractSaveEventListener

onMerge

public void onMerge(MergeEvent event)
             throws HibernateException
Handle the given merge event.

Specified by:
onMerge in interface MergeEventListener
Parameters:
event - The merge event to be handled.
Throws:
HibernateException

onMerge

public void onMerge(MergeEvent event,
                    Map copyCache)
             throws HibernateException
Handle the given merge event.

Specified by:
onMerge in interface MergeEventListener
Parameters:
event - The merge event to be handled.
Throws:
HibernateException

entityIsPersistent

protected void entityIsPersistent(MergeEvent event,
                                  Map copyCache)

entityIsTransient

protected void entityIsTransient(MergeEvent event,
                                 Map copyCache)

entityIsDetached

protected void entityIsDetached(MergeEvent event,
                                Map copyCache)

copyValues

protected void copyValues(EntityPersister persister,
                          Object entity,
                          Object target,
                          SessionImplementor source,
                          Map copyCache)

copyValues

protected void copyValues(EntityPersister persister,
                          Object entity,
                          Object target,
                          SessionImplementor source,
                          Map copyCache,
                          ForeignKeyDirection foreignKeyDirection)

cascadeOnMerge

protected void cascadeOnMerge(EventSource source,
                              EntityPersister persister,
                              Object entity,
                              Map copyCache)
Perform any cascades needed as part of this copy event.

Parameters:
source - The merge event being processed.
persister - The persister of the entity being copied.
entity - The entity being copied.
copyCache - A cache of already copied instance.

getCascadeAction

protected CascadingAction getCascadeAction()
Specified by:
getCascadeAction in class AbstractSaveEventListener

getAssumedUnsaved

protected Boolean getAssumedUnsaved()
Overrides:
getAssumedUnsaved in class AbstractSaveEventListener

cascadeAfterSave

protected void cascadeAfterSave(EventSource source,
                                EntityPersister persister,
                                Object entity,
                                Object anything)
                         throws HibernateException
Cascade behavior is redefined by this subclass, disable superclass behavior

Overrides:
cascadeAfterSave in class AbstractSaveEventListener
Parameters:
source - The session from which the event originated.
persister - The entity's persister instance.
entity - The entity beng saved.
Throws:
HibernateException

cascadeBeforeSave

protected void cascadeBeforeSave(EventSource source,
                                 EntityPersister persister,
                                 Object entity,
                                 Object anything)
                          throws HibernateException
Cascade behavior is redefined by this subclass, disable superclass behavior

Overrides:
cascadeBeforeSave in class AbstractSaveEventListener
Parameters:
source - The session from whcih the save event originated.
persister - The entity's persister instance.
entity - The entity to be saved.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultPersistEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultPersistEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
        extended by org.hibernate.event.def.AbstractSaveEventListener
            extended by org.hibernate.event.def.DefaultPersistEventListener
All Implemented Interfaces:
PersistEventListener, Serializable
Direct Known Subclasses:
DefaultPersistOnFlushEventListener
public class DefaultPersistEventListener
extends AbstractSaveEventListener
implements PersistEventListener

Defines the default create event listener used by hibernate for creating transient entities in response to generated create events.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.event.def.AbstractSaveEventListener
DELETED, DETACHED, PERSISTENT, TRANSIENT
Constructor Summary
DefaultPersistEventListener()
Method Summary
protected void | entityIsPersistent(PersistEvent event, Map createCache)
protected void | entityIsTransient(PersistEvent event, Map createCache) Handle the given create event.
protected Boolean | getAssumedUnsaved()
protected CascadingAction | getCascadeAction()
void | onPersist(PersistEvent event) Handle the given create event.
void | onPersist(PersistEvent event, Map createCache) Handle the given create event.
Methods inherited from class org.hibernate.event.def.AbstractSaveEventListener
cascadeAfterSave, cascadeBeforeSave, getEntityState, getLoggableName, getMergeMap, invokeSaveLifecycle, isVersionIncrementDisabled, performSave, performSaveOrReplicate, saveWithGeneratedId, saveWithRequestedId, substituteValuesIfNecessary, validate, visitCollectionsBeforeSave
Methods inherited from class org.hibernate.event.def.AbstractReassociateEventListener
reassociate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultPersistEventListener

public DefaultPersistEventListener()
Method Detail

onPersist

public void onPersist(PersistEvent event)
               throws HibernateException
Handle the given create event.

Specified by:
onPersist in interface PersistEventListener
Parameters:
event - The create event to be handled.
Throws:
HibernateException

onPersist

public void onPersist(PersistEvent event,
                      Map createCache)
               throws HibernateException
Handle the given create event.

Specified by:
onPersist in interface PersistEventListener
Parameters:
event - The create event to be handled.
Throws:
HibernateException

entityIsPersistent

protected void entityIsPersistent(PersistEvent event,
                                  Map createCache)

entityIsTransient

protected void entityIsTransient(PersistEvent event,
                                 Map createCache)
                          throws HibernateException
Handle the given create event.

Parameters:
event - The save event to be handled.
Throws:
HibernateException

getCascadeAction

protected CascadingAction getCascadeAction()
Specified by:
getCascadeAction in class AbstractSaveEventListener

getAssumedUnsaved

protected Boolean getAssumedUnsaved()
Overrides:
getAssumedUnsaved in class AbstractSaveEventListener
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultPersistOnFlushEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultPersistOnFlushEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
        extended by org.hibernate.event.def.AbstractSaveEventListener
            extended by org.hibernate.event.def.DefaultPersistEventListener
                extended by org.hibernate.event.def.DefaultPersistOnFlushEventListener
All Implemented Interfaces:
PersistEventListener, Serializable
public class DefaultPersistOnFlushEventListener
extends DefaultPersistEventListener

When persist is used as the cascade action, persistOnFlush should be used

Author:
Emmanuel Bernard
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.event.def.AbstractSaveEventListener
DELETED, DETACHED, PERSISTENT, TRANSIENT
Constructor Summary
DefaultPersistOnFlushEventListener()
Method Summary
protected  CascadingAction getCascadeAction()
Methods inherited from class org.hibernate.event.def.DefaultPersistEventListener
entityIsPersistent, entityIsTransient, getAssumedUnsaved, onPersist, onPersist
Methods inherited from class org.hibernate.event.def.AbstractSaveEventListener
cascadeAfterSave, cascadeBeforeSave, getEntityState, getLoggableName, getMergeMap, invokeSaveLifecycle, isVersionIncrementDisabled, performSave, performSaveOrReplicate, saveWithGeneratedId, saveWithRequestedId, substituteValuesIfNecessary, validate, visitCollectionsBeforeSave
Methods inherited from class org.hibernate.event.def.AbstractReassociateEventListener
reassociate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultPersistOnFlushEventListener

public DefaultPersistOnFlushEventListener()
Method Detail

getCascadeAction

protected CascadingAction getCascadeAction()
Overrides:
getCascadeAction in class DefaultPersistEventListener
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultPostLoadEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultPostLoadEventListener

java.lang.Object
    extended by org.hibernate.event.def.DefaultPostLoadEventListener
All Implemented Interfaces:
PostLoadEventListener, Serializable
public class DefaultPostLoadEventListener
extends Object
implements PostLoadEventListener

Call Lifecycle interface if necessary

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
DefaultPostLoadEventListener()
Method Summary
 void onPostLoad(PostLoadEvent event)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultPostLoadEventListener

public DefaultPostLoadEventListener()
Method Detail

onPostLoad

public void onPostLoad(PostLoadEvent event)
Specified by:
onPostLoad in interface PostLoadEventListener
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultPreLoadEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultPreLoadEventListener

java.lang.Object
    extended by org.hibernate.event.def.DefaultPreLoadEventListener
All Implemented Interfaces:
PreLoadEventListener, Serializable
public class DefaultPreLoadEventListener
extends Object
implements PreLoadEventListener

Called before injecting property values into a newly loaded entity instance.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
DefaultPreLoadEventListener()
Method Summary
 void onPreLoad(PreLoadEvent event)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultPreLoadEventListener

public DefaultPreLoadEventListener()
Method Detail

onPreLoad

public void onPreLoad(PreLoadEvent event)
Specified by:
onPreLoad in interface PreLoadEventListener
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultRefreshEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultRefreshEventListener

java.lang.Object
    extended by org.hibernate.event.def.DefaultRefreshEventListener
All Implemented Interfaces:
RefreshEventListener, Serializable
public class DefaultRefreshEventListener
extends Object
implements RefreshEventListener

Defines the default refresh event listener used by hibernate for refreshing entities in response to generated refresh events.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
DefaultRefreshEventListener()
Method Summary
void | onRefresh(RefreshEvent event) Handle the given refresh event.
void | onRefresh(RefreshEvent event, Map refreshedAlready) Handle the given refresh event.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultRefreshEventListener

public DefaultRefreshEventListener()
Method Detail

onRefresh

public void onRefresh(RefreshEvent event)
               throws HibernateException
Description copied from interface: RefreshEventListener
Handle the given refresh event.

Specified by:
onRefresh in interface RefreshEventListener
Parameters:
event - The refresh event to be handled.
Throws:
HibernateException

onRefresh

public void onRefresh(RefreshEvent event,
                      Map refreshedAlready)
               throws HibernateException
Handle the given refresh event.

Specified by:
onRefresh in interface RefreshEventListener
Parameters:
event - The refresh event to be handled.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultReplicateEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultReplicateEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
        extended by org.hibernate.event.def.AbstractSaveEventListener
            extended by org.hibernate.event.def.DefaultReplicateEventListener
All Implemented Interfaces:
ReplicateEventListener, Serializable
public class DefaultReplicateEventListener
extends AbstractSaveEventListener
implements ReplicateEventListener

Defines the default replicate event listener used by Hibernate to replicate entities in response to generated replicate events.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.event.def.AbstractSaveEventListener
DELETED, DETACHED, PERSISTENT, TRANSIENT
Constructor Summary
DefaultReplicateEventListener()
Method Summary
protected CascadingAction | getCascadeAction()
protected boolean | isVersionIncrementDisabled() After the save, will te version number be incremented if the instance is modified?
void | onReplicate(ReplicateEvent event) Handle the given replicate event.
protected boolean | substituteValuesIfNecessary(Object entity, Serializable id, Object[] values, EntityPersister persister, SessionImplementor source) Perform any property value substitution that is necessary (interceptor callback, version initialization...)
protected boolean | visitCollectionsBeforeSave(Serializable id, Object[] values, Type[] types, EventSource source)
Methods inherited from class org.hibernate.event.def.AbstractSaveEventListener
cascadeAfterSave, cascadeBeforeSave, getAssumedUnsaved, getEntityState, getLoggableName, getMergeMap, invokeSaveLifecycle, performSave, performSaveOrReplicate, saveWithGeneratedId, saveWithRequestedId, validate
Methods inherited from class org.hibernate.event.def.AbstractReassociateEventListener
reassociate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultReplicateEventListener

public DefaultReplicateEventListener()
Method Detail

onReplicate

public void onReplicate(ReplicateEvent event)
                 throws HibernateException
Handle the given replicate event.

Specified by:
onReplicate in interface ReplicateEventListener
Parameters:
event - The replicate event to be handled.
Throws:
HibernateException

visitCollectionsBeforeSave

protected boolean visitCollectionsBeforeSave(Serializable id,
                                             Object[] values,
                                             Type[] types,
                                             EventSource source)
Overrides:
visitCollectionsBeforeSave in class AbstractSaveEventListener

substituteValuesIfNecessary

protected boolean substituteValuesIfNecessary(Object entity,
                                              Serializable id,
                                              Object[] values,
                                              EntityPersister persister,
                                              SessionImplementor source)
Description copied from class: AbstractSaveEventListener
Perform any property value substitution that is necessary (interceptor callback, version initialization...)

Overrides:
substituteValuesIfNecessary in class AbstractSaveEventListener

isVersionIncrementDisabled

protected boolean isVersionIncrementDisabled()
Description copied from class: AbstractSaveEventListener
After the save, will te version number be incremented if the instance is modified?

Overrides:
isVersionIncrementDisabled in class AbstractSaveEventListener

getCascadeAction

protected CascadingAction getCascadeAction()
Specified by:
getCascadeAction in class AbstractSaveEventListener
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultSaveEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultSaveEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
        extended by org.hibernate.event.def.AbstractSaveEventListener
            extended by org.hibernate.event.def.DefaultSaveOrUpdateEventListener
                extended by org.hibernate.event.def.DefaultSaveEventListener
All Implemented Interfaces:
SaveOrUpdateEventListener, Serializable
public class DefaultSaveEventListener
extends DefaultSaveOrUpdateEventListener

An event handler for save() events

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.event.def.AbstractSaveEventListener
DELETED, DETACHED, PERSISTENT, TRANSIENT
Constructor Summary
DefaultSaveEventListener()
Method Summary
protected Serializable | performSaveOrUpdate(SaveOrUpdateEvent event)
protected boolean | reassociateIfUninitializedProxy(Object object, SessionImplementor source)
protected Serializable | saveWithGeneratedOrRequestedId(SaveOrUpdateEvent event) Save the transient instance, assigning the right identifier
Methods inherited from class org.hibernate.event.def.DefaultSaveOrUpdateEventListener
entityIsDetached, entityIsPersistent, entityIsTransient, getCascadeAction, getUpdateId, invokeUpdateLifecycle, onSaveOrUpdate, performUpdate
Methods inherited from class org.hibernate.event.def.AbstractSaveEventListener
cascadeAfterSave, cascadeBeforeSave, getAssumedUnsaved, getEntityState, getLoggableName, getMergeMap, invokeSaveLifecycle, isVersionIncrementDisabled, performSave, performSaveOrReplicate, saveWithGeneratedId, saveWithRequestedId, substituteValuesIfNecessary, validate, visitCollectionsBeforeSave
Methods inherited from class org.hibernate.event.def.AbstractReassociateEventListener
reassociate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultSaveEventListener

public DefaultSaveEventListener()
Method Detail

performSaveOrUpdate

protected Serializable performSaveOrUpdate(SaveOrUpdateEvent event)
Overrides:
performSaveOrUpdate in class DefaultSaveOrUpdateEventListener

saveWithGeneratedOrRequestedId

protected Serializable saveWithGeneratedOrRequestedId(SaveOrUpdateEvent event)
Description copied from class: DefaultSaveOrUpdateEventListener
Save the transient instance, assigning the right identifier

Overrides:
saveWithGeneratedOrRequestedId in class DefaultSaveOrUpdateEventListener

reassociateIfUninitializedProxy

protected boolean reassociateIfUninitializedProxy(Object object,
                                                  SessionImplementor source)
Overrides:
reassociateIfUninitializedProxy in class DefaultSaveOrUpdateEventListener
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultSaveOrUpdateCopyEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultSaveOrUpdateCopyEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
        extended by org.hibernate.event.def.AbstractSaveEventListener
            extended by org.hibernate.event.def.DefaultMergeEventListener
                extended by org.hibernate.event.def.DefaultSaveOrUpdateCopyEventListener
All Implemented Interfaces:
MergeEventListener, Serializable
public class DefaultSaveOrUpdateCopyEventListener
extends DefaultMergeEventListener

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.event.def.AbstractSaveEventListener
DELETED, DETACHED, PERSISTENT, TRANSIENT
Constructor Summary
DefaultSaveOrUpdateCopyEventListener()
Method Summary
protected  CascadingAction getCascadeAction()
Methods inherited from class org.hibernate.event.def.DefaultMergeEventListener
cascadeAfterSave, cascadeBeforeSave, cascadeOnMerge, copyValues, copyValues, entityIsDetached, entityIsPersistent, entityIsTransient, getAssumedUnsaved, getMergeMap, onMerge, onMerge
Methods inherited from class org.hibernate.event.def.AbstractSaveEventListener
getEntityState, getLoggableName, invokeSaveLifecycle, isVersionIncrementDisabled, performSave, performSaveOrReplicate, saveWithGeneratedId, saveWithRequestedId, substituteValuesIfNecessary, validate, visitCollectionsBeforeSave
Methods inherited from class org.hibernate.event.def.AbstractReassociateEventListener
reassociate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultSaveOrUpdateCopyEventListener

public DefaultSaveOrUpdateCopyEventListener()
Method Detail

getCascadeAction

protected CascadingAction getCascadeAction()
Overrides:
getCascadeAction in class DefaultMergeEventListener
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultSaveOrUpdateEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultSaveOrUpdateEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
        extended by org.hibernate.event.def.AbstractSaveEventListener
            extended by org.hibernate.event.def.DefaultSaveOrUpdateEventListener
All Implemented Interfaces:
SaveOrUpdateEventListener, Serializable
Direct Known Subclasses:
DefaultSaveEventListener, DefaultUpdateEventListener
public class DefaultSaveOrUpdateEventListener
extends AbstractSaveEventListener
implements SaveOrUpdateEventListener

Defines the default update event listener used by hibernate for updating transient entities in response to generated update events.

Author:
Steve Ebersole, Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.event.def.AbstractSaveEventListener
DELETED, DETACHED, PERSISTENT, TRANSIENT
Constructor Summary
DefaultSaveOrUpdateEventListener()
Method Summary
protected void | entityIsDetached(SaveOrUpdateEvent event) Handle the given update event.
protected Serializable | entityIsPersistent(SaveOrUpdateEvent event)
protected Serializable | entityIsTransient(SaveOrUpdateEvent event) Handle the given save event.
protected CascadingAction | getCascadeAction()
protected Serializable | getUpdateId(Object entity, EntityPersister persister, Serializable requestedId, EntityMode entityMode)
protected boolean | invokeUpdateLifecycle(Object entity, EntityPersister persister, EventSource source)
void | onSaveOrUpdate(SaveOrUpdateEvent event) Handle the given update event.
protected Serializable | performSaveOrUpdate(SaveOrUpdateEvent event)
protected void | performUpdate(SaveOrUpdateEvent event, Object entity, EntityPersister persister)
protected boolean | reassociateIfUninitializedProxy(Object object, SessionImplementor source)
protected Serializable | saveWithGeneratedOrRequestedId(SaveOrUpdateEvent event) Save the transient instance, assigning the right identifier
Methods inherited from class org.hibernate.event.def.AbstractSaveEventListener
cascadeAfterSave, cascadeBeforeSave, getAssumedUnsaved, getEntityState, getLoggableName, getMergeMap, invokeSaveLifecycle, isVersionIncrementDisabled, performSave, performSaveOrReplicate, saveWithGeneratedId, saveWithRequestedId, substituteValuesIfNecessary, validate, visitCollectionsBeforeSave
Methods inherited from class org.hibernate.event.def.AbstractReassociateEventListener
reassociate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultSaveOrUpdateEventListener

public DefaultSaveOrUpdateEventListener()
Method Detail

onSaveOrUpdate

public void onSaveOrUpdate(SaveOrUpdateEvent event)
                    throws HibernateException
Handle the given update event.

Specified by:
onSaveOrUpdate in interface SaveOrUpdateEventListener
Parameters:
event - The update event to be handled.
Throws:
HibernateException

reassociateIfUninitializedProxy

protected boolean reassociateIfUninitializedProxy(Object object,
                                                  SessionImplementor source)

performSaveOrUpdate

protected Serializable performSaveOrUpdate(SaveOrUpdateEvent event)

entityIsPersistent

protected Serializable entityIsPersistent(SaveOrUpdateEvent event)
                                   throws HibernateException
Throws:
HibernateException

entityIsTransient

protected Serializable entityIsTransient(SaveOrUpdateEvent event)
                                  throws HibernateException
Handle the given save event.

Parameters:
event - The save event to be handled.
Throws:
HibernateException

saveWithGeneratedOrRequestedId

protected Serializable saveWithGeneratedOrRequestedId(SaveOrUpdateEvent event)
Save the transient instance, assigning the right identifier

entityIsDetached

protected void entityIsDetached(SaveOrUpdateEvent event)
                         throws HibernateException
Handle the given update event.

Parameters:
event - The update event to be handled.
Throws:
HibernateException

getUpdateId

protected Serializable getUpdateId(Object entity,
                                   EntityPersister persister,
                                   Serializable requestedId,
                                   EntityMode entityMode)
                            throws HibernateException
Throws:
HibernateException

performUpdate

protected void performUpdate(SaveOrUpdateEvent event,
                             Object entity,
                             EntityPersister persister)
                      throws HibernateException
Throws:
HibernateException

invokeUpdateLifecycle

protected boolean invokeUpdateLifecycle(Object entity,
                                        EntityPersister persister,
                                        EventSource source)

getCascadeAction

protected CascadingAction getCascadeAction()
Specified by:
getCascadeAction in class AbstractSaveEventListener
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultUpdateEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DefaultUpdateEventListener

java.lang.Object
    extended by org.hibernate.event.def.AbstractReassociateEventListener
        extended by org.hibernate.event.def.AbstractSaveEventListener
            extended by org.hibernate.event.def.DefaultSaveOrUpdateEventListener
                extended by org.hibernate.event.def.DefaultUpdateEventListener
All Implemented Interfaces:
SaveOrUpdateEventListener, Serializable
public class DefaultUpdateEventListener
extends DefaultSaveOrUpdateEventListener

An event handler for update() events

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.event.def.AbstractSaveEventListener
DELETED, DETACHED, PERSISTENT, TRANSIENT
Constructor Summary
DefaultUpdateEventListener()
Method Summary
protected Serializable | getUpdateId(Object entity, EntityPersister persister, Serializable requestedId, EntityMode entityMode) If the user specified an id, assign it to the instance and use that, otherwise use the id already assigned to the instance
protected Serializable | performSaveOrUpdate(SaveOrUpdateEvent event)
Methods inherited from class org.hibernate.event.def.DefaultSaveOrUpdateEventListener
entityIsDetached, entityIsPersistent, entityIsTransient, getCascadeAction, invokeUpdateLifecycle, onSaveOrUpdate, performUpdate, reassociateIfUninitializedProxy, saveWithGeneratedOrRequestedId
Methods inherited from class org.hibernate.event.def.AbstractSaveEventListener
cascadeAfterSave, cascadeBeforeSave, getAssumedUnsaved, getEntityState, getLoggableName, getMergeMap, invokeSaveLifecycle, isVersionIncrementDisabled, performSave, performSaveOrReplicate, saveWithGeneratedId, saveWithRequestedId, substituteValuesIfNecessary, validate, visitCollectionsBeforeSave
Methods inherited from class org.hibernate.event.def.AbstractReassociateEventListener
reassociate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultUpdateEventListener

public DefaultUpdateEventListener()
Method Detail

performSaveOrUpdate

protected Serializable performSaveOrUpdate(SaveOrUpdateEvent event)
Overrides:
performSaveOrUpdate in class DefaultSaveOrUpdateEventListener

getUpdateId

protected Serializable getUpdateId(Object entity,
                                   EntityPersister persister,
                                   Serializable requestedId,
                                   EntityMode entityMode)
                            throws HibernateException
If the user specified an id, assign it to the instance and use that, otherwise use the id already assigned to the instance

Overrides:
getUpdateId in class DefaultSaveOrUpdateEventListener
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DirtyCollectionSearchVisitor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class DirtyCollectionSearchVisitor

java.lang.Object
    extended by org.hibernate.event.def.AbstractVisitor
        extended by org.hibernate.event.def.DirtyCollectionSearchVisitor
public class DirtyCollectionSearchVisitor
extends AbstractVisitor

Do we have a dirty collection here? 1. if it is a new application-instantiated collection, return true (does not occur anymore!) 2. if it is a component, recurse 3. if it is a wrappered collection, ask the collection entry

Author:
Gavin King

Methods inherited from class org.hibernate.event.def.AbstractVisitor
processEntityPropertyValues
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EvictVisitor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class EvictVisitor

java.lang.Object
    extended by org.hibernate.event.def.AbstractVisitor
        extended by org.hibernate.event.def.EvictVisitor
public class EvictVisitor
extends AbstractVisitor

Evict any collections referenced by the object from the session cache. This will NOT pick up any collections that were dereferenced, so they will be deleted (suboptimal but not exactly incorrect).

Author:
Gavin King

Method Summary
 void evictCollection(Object value, CollectionType type)
Methods inherited from class org.hibernate.event.def.AbstractVisitor
processEntityPropertyValues
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

evictCollection

public void evictCollection(Object value,
                            CollectionType type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FlushVisitor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class FlushVisitor

java.lang.Object
    extended by org.hibernate.event.def.AbstractVisitor
        extended by org.hibernate.event.def.FlushVisitor
public class FlushVisitor
extends AbstractVisitor

Process collections reachable from an entity. This visitor assumes that wrap was already performed for the entity.

Author:
Gavin King

Methods inherited from class org.hibernate.event.def.AbstractVisitor
processEntityPropertyValues
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnLockVisitor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class OnLockVisitor

java.lang.Object
    extended by org.hibernate.event.def.AbstractVisitor
        extended by org.hibernate.event.def.ProxyVisitor
            extended by org.hibernate.event.def.ReattachVisitor
                extended by org.hibernate.event.def.OnLockVisitor
public class OnLockVisitor
extends ReattachVisitor

When a transient entity is passed to lock(), we must inspect all its collections and 1. associate any uninitialized PersistentCollections with this session 2. associate any initialized PersistentCollections with this session, using the existing snapshot 3. throw an exception for each "new" collection

Author:
Gavin King

Constructor Summary
OnLockVisitor(EventSource session, Serializable key)
Methods inherited from class org.hibernate.event.def.ReattachVisitor
removeCollection
Methods inherited from class org.hibernate.event.def.ProxyVisitor
isOwnerUnchanged, reattachCollection
Methods inherited from class org.hibernate.event.def.AbstractVisitor
processEntityPropertyValues
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OnLockVisitor

public OnLockVisitor(EventSource session,
                     Serializable key)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnReplicateVisitor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class OnReplicateVisitor

java.lang.Object
    extended by org.hibernate.event.def.AbstractVisitor
        extended by org.hibernate.event.def.ProxyVisitor
            extended by org.hibernate.event.def.ReattachVisitor
                extended by org.hibernate.event.def.OnReplicateVisitor
public class OnReplicateVisitor
extends ReattachVisitor

When an entity is passed to replicate(), and there is an existing row, we must inspect all its collections and 1. associate any uninitialized PersistentCollections with this session 2. associate any initialized PersistentCollections with this session, using the existing snapshot 3. execute a collection removal (SQL DELETE) for each null collection property or "new" collection

Author:
Gavin King

Methods inherited from class org.hibernate.event.def.ReattachVisitor
removeCollection
Methods inherited from class org.hibernate.event.def.ProxyVisitor
isOwnerUnchanged, reattachCollection
Methods inherited from class org.hibernate.event.def.AbstractVisitor
processEntityPropertyValues
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OnUpdateVisitor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class OnUpdateVisitor

java.lang.Object
    extended by org.hibernate.event.def.AbstractVisitor
        extended by org.hibernate.event.def.ProxyVisitor
            extended by org.hibernate.event.def.ReattachVisitor
                extended by org.hibernate.event.def.OnUpdateVisitor
public class OnUpdateVisitor
extends ReattachVisitor

When an entity is passed to update(), we must inspect all its collections and 1. associate any uninitialized PersistentCollections with this session 2. associate any initialized PersistentCollections with this session, using the existing snapshot 3. execute a collection removal (SQL DELETE) for each null collection property or "new" collection

Author:
Gavin King

Methods inherited from class org.hibernate.event.def.ReattachVisitor
removeCollection
Methods inherited from class org.hibernate.event.def.ProxyVisitor
isOwnerUnchanged, reattachCollection
Methods inherited from class org.hibernate.event.def.AbstractVisitor
processEntityPropertyValues
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyVisitor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class ProxyVisitor

java.lang.Object
    extended by org.hibernate.event.def.AbstractVisitor
        extended by org.hibernate.event.def.ProxyVisitor
Direct Known Subclasses:
ReattachVisitor, WrapVisitor
public abstract class ProxyVisitor
extends AbstractVisitor

Reassociates uninitialized proxies with the session

Author:
Gavin King

Constructor Summary
ProxyVisitor(EventSource session)
Method Summary
protected static boolean | isOwnerUnchanged(PersistentCollection snapshot, CollectionPersister persister, Serializable id) Has the owner of the collection changed since the collection was snapshotted and detached?
protected void | reattachCollection(PersistentCollection collection, CollectionType type) Reattach a detached (disassociated) initialized or uninitialized collection wrapper, using a snapshot carried with the collection wrapper
Methods inherited from class org.hibernate.event.def.AbstractVisitor
processEntityPropertyValues
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProxyVisitor

public ProxyVisitor(EventSource session)
Method Detail

isOwnerUnchanged

protected static boolean isOwnerUnchanged(PersistentCollection snapshot,
                                          CollectionPersister persister,
                                          Serializable id)
Has the owner of the collection changed since the collection was snapshotted and detached?

reattachCollection

protected void reattachCollection(PersistentCollection collection,
                                  CollectionType type)
                           throws HibernateException
Reattach a detached (disassociated) initialized or uninitialized collection wrapper, using a snapshot carried with the collection wrapper

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReattachVisitor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class ReattachVisitor

java.lang.Object
    extended by org.hibernate.event.def.AbstractVisitor
        extended by org.hibernate.event.def.ProxyVisitor
            extended by org.hibernate.event.def.ReattachVisitor
Direct Known Subclasses:
OnLockVisitor, OnReplicateVisitor, OnUpdateVisitor
public abstract class ReattachVisitor
extends ProxyVisitor

Abstract superclass of visitors that reattach collections

Author:
Gavin King

Constructor Summary
ReattachVisitor(EventSource session, Serializable key)
Method Summary
 void removeCollection(CollectionPersister role, Serializable id, EventSource source)
Schedules a collection for deletion.
Methods inherited from class org.hibernate.event.def.ProxyVisitor
isOwnerUnchanged, reattachCollection
Methods inherited from class org.hibernate.event.def.AbstractVisitor
processEntityPropertyValues
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReattachVisitor

public ReattachVisitor(EventSource session,
                       Serializable key)
Method Detail

removeCollection

public void removeCollection(CollectionPersister role,
                             Serializable id,
                             EventSource source)
                      throws HibernateException
Schedules a collection for deletion.

Parameters:
role - The persister representing the collection to be removed.
id - The id of the entity containing the collection to be removed.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WrapVisitor (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.event.def
Class WrapVisitor

java.lang.Object
    extended by org.hibernate.event.def.AbstractVisitor
        extended by org.hibernate.event.def.ProxyVisitor
            extended by org.hibernate.event.def.WrapVisitor
public class WrapVisitor
extends ProxyVisitor

Wrap collections in a Hibernate collection wrapper.

Author:
Gavin King

Methods inherited from class org.hibernate.event.def.ProxyVisitor
isOwnerUnchanged, reattachCollection
Methods inherited from class org.hibernate.event.def.AbstractVisitor
processEntityPropertyValues
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.exception (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.exception

This package is a fork of Apache commons-lang nestable exceptions.

See:
Description

Interface Summary
Configurable | The Configurable interface defines the contract for SQLExceptionConverter impls that want to be configured prior to usage given the currently defined Hibernate properties.
Nestable | An interface to be implemented by Throwable extensions which would like to be able to nest root exceptions inside themselves.
SQLExceptionConverter | Defines a contract for implementations that know how to convert a SQLException into Hibernate's JDBCException hierarchy.
ViolatedConstraintNameExtracter | Defines a contract for implementations that can extract the name of a violated constraint from a SQLException that is the result of that constraint violation.

Class Summary
ExceptionUtils | Provides utilities for manipulating and examining Throwable objects.
JDBCExceptionHelper | Implementation of JDBCExceptionHelper.
NestableDelegate | A shared implementation of the nestable exception functionality.
SQLExceptionConverterFactory | A factory for building SQLExceptionConverter instances.
SQLStateConverter | A SQLExceptionConverter implementation which performs converion based on the underlying SQLState.
TemplatedViolatedConstraintNameExtracter | Knows how to extract a violated constraint name from an error message based on the fact that the constraint name is templated within the message.

Exception Summary
ConstraintViolationException | Implementation of JDBCException indicating that the requested DML operation resulted in a violation of a defined integrity constraint.
DataException | Implementation of JDBCException indicating that evaluation of the valid SQL statement against the given data resulted in some illegal operation, mismatched types or incorrect cardinality.
GenericJDBCException | Generic, non-specific JDBCException.
JDBCConnectionException | Implementation of JDBCException indicating problems with communicating with the database (can also include incorrect JDBC setup).
LockAcquisitionException | Implementation of JDBCException indicating a problem acquiring lock on the database.
NestableException | The base class of all exceptions which can contain other exceptions.
NestableRuntimeException | The base class of all runtime exceptions which can contain other exceptions.
SQLGrammarException | Implementation of JDBCException indicating that the SQL sent to the database server was invalid (syntax error, invalid object references, etc).

Package org.hibernate.exception Description

This package is a fork of Apache commons-lang nestable exceptions.


org.hibernate.exception Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.exception

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.exception.ExceptionUtils
    • class org.hibernate.exception.JDBCExceptionHelper
    • class org.hibernate.exception.NestableDelegate (implements java.io.Serializable)
    • class org.hibernate.exception.SQLExceptionConverterFactory
    • class org.hibernate.exception.SQLStateConverter (implements org.hibernate.exception.SQLExceptionConverter)
    • class org.hibernate.exception.TemplatedViolatedConstraintNameExtracter (implements org.hibernate.exception.ViolatedConstraintNameExtracter)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class org.hibernate.exception.NestableException (implements org.hibernate.exception.Nestable)
        • class java.lang.RuntimeException
          • class org.hibernate.exception.NestableRuntimeException (implements org.hibernate.exception.Nestable)
            • class org.hibernate.HibernateException
              • class org.hibernate.JDBCException
                • class org.hibernate.exception.ConstraintViolationException
                • class org.hibernate.exception.DataException
                • class org.hibernate.exception.GenericJDBCException
                • class org.hibernate.exception.JDBCConnectionException
                • class org.hibernate.exception.LockAcquisitionException
                • class org.hibernate.exception.SQLGrammarException

Interface Hierarchy

  • interface org.hibernate.exception.Configurable
  • interface org.hibernate.exception.Nestable
  • interface org.hibernate.exception.SQLExceptionConverter
  • interface org.hibernate.exception.ViolatedConstraintNameExtracter


Uses of Package org.hibernate.exception (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.exception

Packages that use org.hibernate.exception
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.classic | This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.exception | This package is a fork of Apache commons-lang nestable exceptions.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Classes in org.hibernate.exception used by org.hibernate
Nestable
An interface to be implemented by Throwable extensions which would like to be able to nest root exceptions inside themselves.
NestableRuntimeException
The base class of all runtime exceptions which can contain other exceptions.

Classes in org.hibernate.exception used by org.hibernate.cache
Nestable
An interface to be implemented by Throwable extensions which would like to be able to nest root exceptions inside themselves.
NestableRuntimeException
The base class of all runtime exceptions which can contain other exceptions.

Classes in org.hibernate.exception used by org.hibernate.cfg
SQLExceptionConverter
Defines a contract for implementations that know how to convert a SQLException into Hibernate's JDBCException hierarchy.

Classes in org.hibernate.exception used by org.hibernate.classic
Nestable
An interface to be implemented by Throwable extensions which would like to be able to nest root exceptions inside themselves.
NestableRuntimeException
The base class of all runtime exceptions which can contain other exceptions.

Classes in org.hibernate.exception used by org.hibernate.dialect
SQLExceptionConverter
Defines a contract for implementations that know how to convert a SQLException into Hibernate's JDBCException hierarchy.
ViolatedConstraintNameExtracter
Defines a contract for implementations that can extract the name of a violated constraint from a SQLException that is the result of that constraint violation.

Classes in org.hibernate.exception used by org.hibernate.engine
SQLExceptionConverter
Defines a contract for implementations that know how to convert a SQLException into Hibernate's JDBCException hierarchy.

Classes in org.hibernate.exception used by org.hibernate.exception
Nestable
An interface to be implemented by Throwable extensions which would like to be able to nest root exceptions inside themselves.
NestableDelegate
A shared implementation of the nestable exception functionality.
NestableRuntimeException
The base class of all runtime exceptions which can contain other exceptions.
SQLExceptionConverter
Defines a contract for implementations that know how to convert a SQLException into Hibernate's JDBCException hierarchy.
ViolatedConstraintNameExtracter
Defines a contract for implementations that can extract the name of a violated constraint from a SQLException that is the result of that constraint violation.

Classes in org.hibernate.exception used by org.hibernate.hql
Nestable
An interface to be implemented by Throwable extensions which would like to be able to nest root exceptions inside themselves.
NestableRuntimeException
The base class of all runtime exceptions which can contain other exceptions.

Classes in org.hibernate.exception used by org.hibernate.hql.ast
Nestable
An interface to be implemented by Throwable extensions which would like to be able to nest root exceptions inside themselves.
NestableRuntimeException
The base class of all runtime exceptions which can contain other exceptions.

Classes in org.hibernate.exception used by org.hibernate.id
Nestable
An interface to be implemented by Throwable extensions which would like to be able to nest root exceptions inside themselves.
NestableRuntimeException
The base class of all runtime exceptions which can contain other exceptions.

Classes in org.hibernate.exception used by org.hibernate.impl
SQLExceptionConverter
Defines a contract for implementations that know how to convert a SQLException into Hibernate's JDBCException hierarchy.

Classes in org.hibernate.exception used by org.hibernate.jdbc
Nestable
An interface to be implemented by Throwable extensions which would like to be able to nest root exceptions inside themselves.
NestableRuntimeException
The base class of all runtime exceptions which can contain other exceptions.

Classes in org.hibernate.exception used by org.hibernate.persister.collection
SQLExceptionConverter
Defines a contract for implementations that know how to convert a SQLException into Hibernate's JDBCException hierarchy.

Classes in org.hibernate.exception used by org.hibernate.type
Nestable
An interface to be implemented by Throwable extensions which would like to be able to nest root exceptions inside themselves.
NestableRuntimeException
The base class of all runtime exceptions which can contain other exceptions.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Configurable (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Interface Configurable

public interface Configurable

The Configurable interface defines the contract for SQLExceptionConverter impls that want to be configured prior to usage given the currently defined Hibernate properties.

Author:
Steve Ebersole

Method Summary
 void configure(Properties properties)
Configure the component, using the given settings and properties.

Method Detail

configure

public void configure(Properties properties)
               throws HibernateException
Configure the component, using the given settings and properties.

Parameters:
properties - All defined startup properties.
Throws:
HibernateException - Indicates a configuration exception.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Nestable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Interface Nestable

All Known Implementing Classes:
NestableException, NestableRuntimeException
public interface Nestable

An interface to be implemented by Throwable extensions which would like to be able to nest root exceptions inside themselves.

Since:
1.0
Version:
$Id: Nestable.java 4782 2004-11-21 00:11:27Z pgmjsd $
Author:
Daniel Rall, Kasper Nielsen, Steven Caswell, Pete Gieser

Method Summary
Throwable | getCause() Returns the reference to the exception or error that caused the exception implementing the Nestable to be thrown.
String | getMessage() Returns the error message of this and any nested Throwable.
String | getMessage(int index) Returns the error message of the Throwable in the chain of Throwables at the specified index, numbererd from 0.
String[] | getMessages() Returns the error message of this and any nested Throwables in an array of Strings, one element for each message.
Throwable | getThrowable(int index) Returns the Throwable in the chain of Throwables at the specified index, numbererd from 0.
int | getThrowableCount() Returns the number of nested Throwables represented by this Nestable, including this Nestable.
Throwable[] | getThrowables() Returns this Nestable and any nested Throwables in an array of Throwables, one element for each Throwable.
int | indexOfThrowable(Class type) Returns the index, numbered from 0, of the first occurrence of the specified type in the chain of Throwables, or -1 if the specified type is not found in the chain.
int | indexOfThrowable(Class type, int fromIndex) Returns the index, numbered from 0, of the first Throwable that matches the specified type in the chain of Throwables with an index greater than or equal to the specified index, or -1 if the type is not found.
void | printPartialStackTrace(PrintWriter out) Prints the stack trace for this exception only--root cause not included--using the provided writer.
void | printStackTrace(PrintStream out) Prints the stack trace of this exception to the specified print stream.
void | printStackTrace(PrintWriter out) Prints the stack trace of this exception to the specified print writer.

Method Detail

getCause

public Throwable getCause()
Returns the reference to the exception or error that caused the exception implementing the Nestable to be thrown.

Returns:
throwable that caused the original exception

getMessage

public String getMessage()
Returns the error message of this and any nested Throwable.

Returns:
the error message

getMessage

public String getMessage(int index)
Returns the error message of the Throwable in the chain of Throwables at the specified index, numbererd from 0.

Parameters:
index - the index of the Throwable in the chain of Throwables
Returns:
the error message, or null if the Throwable at the specified index in the chain does not contain a message
Throws:
IndexOutOfBoundsException - if the index argument is negative or not less than the count of Throwables in the chain

getMessages

public String[] getMessages()
Returns the error message of this and any nested Throwables in an array of Strings, one element for each message. Any Throwable not containing a message is represented in the array by a null. This has the effect of cause the length of the returned array to be equal to the result of the getThrowableCount() operation.

Returns:
the error messages

getThrowable

public Throwable getThrowable(int index)
Returns the Throwable in the chain of Throwables at the specified index, numbererd from 0.

Parameters:
index - the index, numbered from 0, of the Throwable in the chain of Throwables
Returns:
the Throwable
Throws:
IndexOutOfBoundsException - if the index argument is negative or not less than the count of Throwables in the chain

getThrowableCount

public int getThrowableCount()
Returns the number of nested Throwables represented by this Nestable, including this Nestable.

Returns:
the throwable count

getThrowables

public Throwable[] getThrowables()
Returns this Nestable and any nested Throwables in an array of Throwables, one element for each Throwable.

Returns:
the Throwables

indexOfThrowable

public int indexOfThrowable(Class type)
Returns the index, numbered from 0, of the first occurrence of the specified type in the chain of Throwables, or -1 if the specified type is not found in the chain.

Parameters:
type - Class to be found
Returns:
index of the first occurrence of the type in the chain, or -1 if the type is not found

indexOfThrowable

public int indexOfThrowable(Class type,
                            int fromIndex)
Returns the index, numbered from 0, of the first Throwable that matches the specified type in the chain of Throwables with an index greater than or equal to the specified index, or -1 if the type is not found.

Parameters:
type - Class to be found
fromIndex - the index, numbered from 0, of the starting position in the chain to be searched
Returns:
index of the first occurrence of the type in the chain, or -1 if the type is not found
Throws:
IndexOutOfBoundsException - if the fromIndex argument is negative or not less than the count of Throwables in the chain

printStackTrace

public void printStackTrace(PrintWriter out)
Prints the stack trace of this exception to the specified print writer. Includes information from the exception, if any, which caused this exception.

Parameters:
out - PrintWriter to use for output.

printStackTrace

public void printStackTrace(PrintStream out)
Prints the stack trace of this exception to the specified print stream. Includes inforamation from the exception, if any, which caused this exception.

Parameters:
out - PrintStream to use for output.

printPartialStackTrace

public void printPartialStackTrace(PrintWriter out)
Prints the stack trace for this exception only--root cause not included--using the provided writer. Used by org.apache.commons.lang.exception.NestableDelegate to write individual stack traces to a buffer. The implementation of this method should call super.printStackTrace(out); in most cases.

Parameters:
out - The writer to use.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLExceptionConverter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Interface SQLExceptionConverter

All Known Implementing Classes:
SQLStateConverter
public interface SQLExceptionConverter

Defines a contract for implementations that know how to convert a SQLException into Hibernate's JDBCException hierarchy. Inspired by Spring's SQLExceptionTranslator.

Implementations must have a constructor which takes a ViolatedConstraintNameExtracter parameter.

Implementations may implement Configurable if they need to perform configuration steps prior to first use.

Author:
Steve Ebersole
See Also:
SQLExceptionConverterFactory

Method Summary
 JDBCException convert(SQLException sqlException, String message, String sql)
Convert the given SQLException into Hibernate's JDBCException hierarchy.

Method Detail

convert

public JDBCException convert(SQLException sqlException,
                             String message,
                             String sql)
Convert the given SQLException into Hibernate's JDBCException hierarchy.

Parameters:
sqlException - The SQLException to be converted.
message - An optional error message.
Returns:
The resulting JDBCException.
See Also:
ConstraintViolationException, JDBCConnectionException, SQLGrammarException, LockAcquisitionException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ViolatedConstraintNameExtracter (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Interface ViolatedConstraintNameExtracter

All Known Implementing Classes:
TemplatedViolatedConstraintNameExtracter
public interface ViolatedConstraintNameExtracter

Defines a contract for implementations that can extract the name of a violated constraint from a SQLException that is the result of that constraint violation.

Author:
Steve Ebersole

Method Summary
 String extractConstraintName(SQLException sqle)
Extract the name of the violated constraint from the given SQLException.

Method Detail

extractConstraintName

public String extractConstraintName(SQLException sqle)
Extract the name of the violated constraint from the given SQLException.

Parameters:
sqle - The exception that was the result of the constraint violation.
Returns:
The extracted constraint name.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ExceptionUtils (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class ExceptionUtils

java.lang.Object
    extended by org.hibernate.exception.ExceptionUtils
public final class ExceptionUtils
extends Object

Provides utilities for manipulating and examining Throwable objects.

Since:
1.0
Version:
$Id: ExceptionUtils.java 4782 2004-11-21 00:11:27Z pgmjsd $
Author:
Daniel Rall, Dmitri Plotnikov, Stephen Colebourne, Gary Gregory, Pete Gieser

Method Summary
static Throwable | getCause(Throwable throwable) Introspects the Throwable to obtain the cause.
static Throwable | getCause(Throwable throwable, String[] methodNames) Introspects the Throwable to obtain the cause.
static String | getFullStackTrace(Throwable throwable) A way to get the entire nested stack-trace of an throwable.
static Throwable | getRootCause(Throwable throwable) Introspects the Throwable to obtain the root cause.
static String[] | getRootCauseStackTrace(Throwable throwable) Creates a compact stack trace for the root cause of the supplied Throwable.
static String[] | getStackFrames(Throwable throwable) Captures the stack trace associated with the specified Throwable object, decomposing it into a list of stack frames.
static String | getStackTrace(Throwable throwable) Gets the stack trace from a Throwable as a String.
static int | getThrowableCount(Throwable throwable) Counts the number of Throwable objects in the exception chain.
static Throwable[] | getThrowables(Throwable throwable) Returns the list of Throwable objects in the exception chain.
static int | indexOfThrowable(Throwable throwable, Class type) Returns the (zero based) index of the first Throwable that matches the specified type in the exception chain.
static int | indexOfThrowable(Throwable throwable, Class type, int fromIndex) Returns the (zero based) index of the first Throwable that matches the specified type in the exception chain from a specified index.
static boolean | isNestedThrowable(Throwable throwable) Checks whether this Throwable class can store a cause.
static boolean | isThrowableNested() Checks if the Throwable class has a getCause method.
static void | printRootCauseStackTrace(Throwable throwable) Prints a compact stack trace for the root cause of a throwable to System.err.
static void | printRootCauseStackTrace(Throwable throwable, PrintStream stream) Prints a compact stack trace for the root cause of a throwable.
static void | printRootCauseStackTrace(Throwable throwable, PrintWriter writer) Prints a compact stack trace for the root cause of a throwable.
static void | removeCommonFrames(List causeFrames, List wrapperFrames) Removes common frames from the cause trace given the two stack traces.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getCause

public static Throwable getCause(Throwable throwable)

Introspects the Throwable to obtain the cause.

The method searches for methods with specific names that return a Throwable object. This will pick up most wrapping exceptions, including those from JDK 1.4, and NestableException. The method names can be added to using #addCauseMethodName(String).

The default list searched for are:

  • getCause()
  • getNextException()
  • getTargetException()
  • getException()
  • getSourceException()
  • getRootCause()
  • getCausedByException()
  • getNested()

In the absence of any such method, the object is inspected for a detail field assignable to a Throwable.

If none of the above is found, returns null.

Parameters:
throwable - the throwable to introspect for a cause, may be null
Returns:
the cause of the Throwable, null if none found or null throwable input

getCause

public static Throwable getCause(Throwable throwable,
                                 String[] methodNames)

Introspects the Throwable to obtain the cause.

  1. Try known exception types.
  2. Try the supplied array of method names.
  3. Try the field 'detail'.

A null set of method names means use the default set. A null in the set of method names will be ignored.

Parameters:
throwable - the throwable to introspect for a cause, may be null
methodNames - the method names, null treated as default set
Returns:
the cause of the Throwable, null if none found or null throwable input

getRootCause

public static Throwable getRootCause(Throwable throwable)

Introspects the Throwable to obtain the root cause.

This method walks through the exception chain to the last element, "root" of the tree, using getCause(Throwable), and returns that exception.

Parameters:
throwable - the throwable to get the root cause for, may be null
Returns:
the root cause of the Throwable, null if none found or null throwable input

isThrowableNested

public static boolean isThrowableNested()

Checks if the Throwable class has a getCause method.

This is true for JDK 1.4 and above.

Returns:
true if Throwable is nestable
Since:
2.0

isNestedThrowable

public static boolean isNestedThrowable(Throwable throwable)

Checks whether this Throwable class can store a cause.

This method does not check whether it actually does store a cause.

Parameters:
throwable - the Throwable to examine, may be null
Returns:
boolean true if nested otherwise false
Since:
2.0

getThrowableCount

public static int getThrowableCount(Throwable throwable)

Counts the number of Throwable objects in the exception chain.

A throwable without cause will return 1. A throwable with one cause will return 2 and so on. A null throwable will return 0.

Parameters:
throwable - the throwable to inspect, may be null
Returns:
the count of throwables, zero if null input

getThrowables

public static Throwable[] getThrowables(Throwable throwable)

Returns the list of Throwable objects in the exception chain.

A throwable without cause will return an array containing one element - the input throwable. A throwable with one cause will return an array containing two elements. - the input throwable and the cause throwable. A null throwable will return an array size zero.

Parameters:
throwable - the throwable to inspect, may be null
Returns:
the array of throwables, never null

indexOfThrowable

public static int indexOfThrowable(Throwable throwable,
                                   Class type)

Returns the (zero based) index of the first Throwable that matches the specified type in the exception chain.

A null throwable returns -1. A null type returns -1. No match in the chain returns -1.

Parameters:
throwable - the throwable to inspect, may be null
type - the type to search for
Returns:
the index into the throwable chain, -1 if no match or null input

indexOfThrowable

public static int indexOfThrowable(Throwable throwable,
                                   Class type,
                                   int fromIndex)

Returns the (zero based) index of the first Throwable that matches the specified type in the exception chain from a specified index.

A null throwable returns -1. A null type returns -1. No match in the chain returns -1. A negative start index is treated as zero. A start index greater than the number of throwables returns -1.

Parameters:
throwable - the throwable to inspect, may be null
type - the type to search for
fromIndex - the (zero based) index of the starting position, negative treated as zero, larger than chain size returns -1
Returns:
the index into the throwable chain, -1 if no match or null input

printRootCauseStackTrace

public static void printRootCauseStackTrace(Throwable throwable)

Prints a compact stack trace for the root cause of a throwable to System.err.

The compact stack trace starts with the root cause and prints stack frames up to the place where it was caught and wrapped. Then it prints the wrapped exception and continues with stack frames until the wrapper exception is caught and wrapped again, etc.

The method is equivalent to printStackTrace for throwables that don't have nested causes.

Parameters:
throwable - the throwable to output
Since:
2.0

printRootCauseStackTrace

public static void printRootCauseStackTrace(Throwable throwable,
                                            PrintStream stream)

Prints a compact stack trace for the root cause of a throwable.

The compact stack trace starts with the root cause and prints stack frames up to the place where it was caught and wrapped. Then it prints the wrapped exception and continues with stack frames until the wrapper exception is caught and wrapped again, etc.

The method is equivalent to printStackTrace for throwables that don't have nested causes.

Parameters:
throwable - the throwable to output, may be null
stream - the stream to output to, may not be null
Throws:
IllegalArgumentException - if the stream is null
Since:
2.0

printRootCauseStackTrace

public static void printRootCauseStackTrace(Throwable throwable,
                                            PrintWriter writer)

Prints a compact stack trace for the root cause of a throwable.

The compact stack trace starts with the root cause and prints stack frames up to the place where it was caught and wrapped. Then it prints the wrapped exception and continues with stack frames until the wrapper exception is caught and wrapped again, etc.

The method is equivalent to printStackTrace for throwables that don't have nested causes.

Parameters:
throwable - the throwable to output, may be null
writer - the writer to output to, may not be null
Throws:
IllegalArgumentException - if the writer is null
Since:
2.0

getRootCauseStackTrace

public static String[] getRootCauseStackTrace(Throwable throwable)

Creates a compact stack trace for the root cause of the supplied Throwable.

Parameters:
throwable - the throwable to examine, may be null
Returns:
an array of stack trace frames, never null
Since:
2.0

removeCommonFrames

public static void removeCommonFrames(List causeFrames,
                                      List wrapperFrames)

Removes common frames from the cause trace given the two stack traces.

Parameters:
causeFrames - stack trace of a cause throwable
wrapperFrames - stack trace of a wrapper throwable
Throws:
IllegalArgumentException - if either argument is null
Since:
2.0

getStackTrace

public static String getStackTrace(Throwable throwable)

Gets the stack trace from a Throwable as a String.

Parameters:
throwable - the Throwable to be examined
Returns:
the stack trace as generated by the exception's printStackTrace(PrintWriter) method

getFullStackTrace

public static String getFullStackTrace(Throwable throwable)

A way to get the entire nested stack-trace of an throwable.

Parameters:
throwable - the Throwable to be examined
Returns:
the nested stack trace, with the root cause first
Since:
2.0

getStackFrames

public static String[] getStackFrames(Throwable throwable)

Captures the stack trace associated with the specified Throwable object, decomposing it into a list of stack frames.

Parameters:
throwable - the Throwable to exaamine, may be null
Returns:
an array of strings describing each stack frame, never null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JDBCExceptionHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class JDBCExceptionHelper

java.lang.Object
    extended by org.hibernate.exception.JDBCExceptionHelper
public final class JDBCExceptionHelper
extends Object

Implementation of JDBCExceptionHelper.

Author:
Steve Ebersole

Method Summary
static JDBCException | convert(SQLExceptionConverter converter, SQLException sqlException, String message) Converts the given SQLException into Hibernate's JDBCException hierarchy, as well as performing appropriate logging.
static JDBCException | convert(SQLExceptionConverter converter, SQLException sqlException, String message, String sql) Converts the given SQLException into Hibernate's JDBCException hierarchy, as well as performing appropriate logging.
static String | determineSqlStateClassCode(String sqlState)
static int | extractErrorCode(SQLException sqlException) For the given SQLException, locates the vendor-specific error code.
static String | extractSqlState(SQLException sqlException) For the given SQLException, locates the X/Open-compliant SQLState.
static String | extractSqlStateClassCode(SQLException sqlException) For the given SQLException, locates the X/Open-compliant SQLState's class code.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

convert

public static JDBCException convert(SQLExceptionConverter converter,
                                    SQLException sqlException,
                                    String message)
Converts the given SQLException into Hibernate's JDBCException hierarchy, as well as performing appropriate logging.

Parameters:
converter - The converter to use.
sqlException - The exception to convert.
message - An optional error message.
Returns:
The converted JDBCException.

convert

public static JDBCException convert(SQLExceptionConverter converter,
                                    SQLException sqlException,
                                    String message,
                                    String sql)
Converts the given SQLException into Hibernate's JDBCException hierarchy, as well as performing appropriate logging.

Parameters:
converter - The converter to use.
sqlException - The exception to convert.
message - An optional error message.
Returns:
The converted JDBCException.

extractErrorCode

public static int extractErrorCode(SQLException sqlException)
For the given SQLException, locates the vendor-specific error code.

Parameters:
sqlException - The exception from which to extract the SQLState
Returns:
The error code.

extractSqlState

public static String extractSqlState(SQLException sqlException)
For the given SQLException, locates the X/Open-compliant SQLState.

Parameters:
sqlException - The exception from which to extract the SQLState
Returns:
The SQLState code, or null.

extractSqlStateClassCode

public static String extractSqlStateClassCode(SQLException sqlException)
For the given SQLException, locates the X/Open-compliant SQLState's class code.

Parameters:
sqlException - The exception from which to extract the SQLState class code
Returns:
The SQLState class code, or null.

determineSqlStateClassCode

public static String determineSqlStateClassCode(String sqlState)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NestableDelegate (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class NestableDelegate

java.lang.Object
    extended by org.hibernate.exception.NestableDelegate
All Implemented Interfaces:
Serializable
public class NestableDelegate
extends Object
implements Serializable

A shared implementation of the nestable exception functionality.

The code is shared between NestableError, NestableException and NestableRuntimeException.

Since:
1.0
Version:
$Id: NestableDelegate.java 4782 2004-11-21 00:11:27Z pgmjsd $
Author:
Rafal Krzewski, Daniel Rall, Kasper Nielsen, Steven Caswell, Sean C. Sullivan, Stephen Colebourne
See Also:
Serialized Form

Constructor Summary
NestableDelegate(Nestable nestable)
Constructs a new NestableDelegate instance to manage the specified Nestable.
Method Summary
String | getMessage(int index) Returns the error message of the Throwable in the chain of Throwables at the specified index, numbererd from 0.
String | getMessage(String baseMsg) Returns the full message contained by the Nestable and any nested Throwables.
String[] | getMessages() Returns the error message of this and any nested Throwables in an array of Strings, one element for each message.
protected String[] | getStackFrames(Throwable t) Captures the stack trace associated with the specified Throwable object, decomposing it into a list of stack frames.
Throwable | getThrowable(int index) Returns the Throwable in the chain of Throwables at the specified index, numbererd from 0.
int | getThrowableCount() Returns the number of Throwables contained in the Nestable contained by this delegate.
Throwable[] | getThrowables() Returns this delegate's Nestable and any nested Throwables in an array of Throwables, one element for each Throwable.
int | indexOfThrowable(Class type, int fromIndex) Returns the index, numbered from 0, of the first Throwable that matches the specified type in the chain of Throwables held in this delegate's Nestable with an index greater than or equal to the specified index, or -1 if the type is not found.
void | printStackTrace() Prints the stack trace of this exception the the standar error stream.
void | printStackTrace(PrintStream out) Prints the stack trace of this exception to the specified stream.
void | printStackTrace(PrintWriter out) Prints the stack trace of this exception to the specified writer.
protected void | trimStackFrames(List stacks) Trims the stack frames.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NestableDelegate

public NestableDelegate(Nestable nestable)
Constructs a new NestableDelegate instance to manage the specified Nestable.

Parameters:
nestable - the Nestable implementation (must extend Throwable)
Since:
2.0
Method Detail

getMessage

public String getMessage(int index)
Returns the error message of the Throwable in the chain of Throwables at the specified index, numbererd from 0.

Parameters:
index - the index of the Throwable in the chain of Throwables
Returns:
the error message, or null if the Throwable at the specified index in the chain does not contain a message
Throws:
IndexOutOfBoundsException - if the index argument is negative or not less than the count of Throwables in the chain
Since:
2.0

getMessage

public String getMessage(String baseMsg)
Returns the full message contained by the Nestable and any nested Throwables.

Parameters:
baseMsg - the base message to use when creating the full message. Should be generally be called via nestableHelper.getMessage( super.getMessage() ), where super is an instance of Throwable.
Returns:
The concatenated message for this and all nested Throwables
Since:
2.0

getMessages

public String[] getMessages()
Returns the error message of this and any nested Throwables in an array of Strings, one element for each message. Any Throwable not containing a message is represented in the array by a null. This has the effect of cause the length of the returned array to be equal to the result of the getThrowableCount() operation.

Returns:
the error messages
Since:
2.0

getThrowable

public Throwable getThrowable(int index)
Returns the Throwable in the chain of Throwables at the specified index, numbererd from 0.

Parameters:
index - the index, numbered from 0, of the Throwable in the chain of Throwables
Returns:
the Throwable
Throws:
IndexOutOfBoundsException - if the index argument is negative or not less than the count of Throwables in the chain
Since:
2.0

getThrowableCount

public int getThrowableCount()
Returns the number of Throwables contained in the Nestable contained by this delegate.

Returns:
the throwable count
Since:
2.0

getThrowables

public Throwable[] getThrowables()
Returns this delegate's Nestable and any nested Throwables in an array of Throwables, one element for each Throwable.

Returns:
the Throwables
Since:
2.0

indexOfThrowable

public int indexOfThrowable(Class type,
                            int fromIndex)
Returns the index, numbered from 0, of the first Throwable that matches the specified type in the chain of Throwables held in this delegate's Nestable with an index greater than or equal to the specified index, or -1 if the type is not found.

Parameters:
type - Class to be found
fromIndex - the index, numbered from 0, of the starting position in the chain to be searched
Returns:
index of the first occurrence of the type in the chain, or -1 if the type is not found
Throws:
IndexOutOfBoundsException - if the fromIndex argument is negative or not less than the count of Throwables in the chain
Since:
2.0

printStackTrace

public void printStackTrace()
Prints the stack trace of this exception the the standar error stream.

printStackTrace

public void printStackTrace(PrintStream out)
Prints the stack trace of this exception to the specified stream.

Parameters:
out - PrintStream to use for output.
See Also:
printStackTrace(PrintWriter)

printStackTrace

public void printStackTrace(PrintWriter out)
Prints the stack trace of this exception to the specified writer. If the Throwable class has a getCause method (i.e. running on jre1.4 or higher), this method just uses Throwable's printStackTrace() method. Otherwise, generates the stack-trace, by taking into account the 'topDown' and 'trimStackFrames' parameters. The topDown and trimStackFrames are set to 'true' by default (produces jre1.4-like stack trace).

Parameters:
out - PrintWriter to use for output.

getStackFrames

protected String[] getStackFrames(Throwable t)
Captures the stack trace associated with the specified Throwable object, decomposing it into a list of stack frames.

Parameters:
t - The Throwable.
Returns:
An array of strings describing each stack frame.
Since:
2.0

trimStackFrames

protected void trimStackFrames(List stacks)
Trims the stack frames. The first set is left untouched. The rest of the frames are truncated from the bottom by comparing with one just on top.

Parameters:
stacks - The list containing String[] elements
Since:
2.0
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLExceptionConverterFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class SQLExceptionConverterFactory

java.lang.Object
    extended by org.hibernate.exception.SQLExceptionConverterFactory
public class SQLExceptionConverterFactory
extends Object

A factory for building SQLExceptionConverter instances.

Author:
Steve Ebersole

Method Summary
static SQLExceptionConverter | buildMinimalSQLExceptionConverter() Builds a minimal converter.
static SQLExceptionConverter | buildSQLExceptionConverter(Dialect dialect, Properties properties) Build a SQLExceptionConverter instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

buildSQLExceptionConverter

public static SQLExceptionConverter buildSQLExceptionConverter(Dialect dialect,
                                                               Properties properties)
                                                        throws HibernateException
Build a SQLExceptionConverter instance.

First, looks for a Environment.SQL_EXCEPTION_CONVERTER property to see if the configuration specified the class of a specific converter to use. If this property is set, attempt to construct an instance of that class. If not set, or if construction fails, the converter specific to the dialect will be used.

Parameters:
dialect - The defined dialect.
properties - The configuration properties.
Returns:
An appropriate SQLExceptionConverter instance.
Throws:
HibernateException - There was an error building the SQLExceptionConverter.

buildMinimalSQLExceptionConverter

public static SQLExceptionConverter buildMinimalSQLExceptionConverter()
Builds a minimal converter. The instance returned here just always converts to GenericJDBCException.

Returns:
The minimal converter.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLStateConverter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class SQLStateConverter

java.lang.Object
    extended by org.hibernate.exception.SQLStateConverter
All Implemented Interfaces:
SQLExceptionConverter
public class SQLStateConverter
extends Object
implements SQLExceptionConverter

A SQLExceptionConverter implementation which performs converion based on the underlying SQLState. Interpretation of a SQL error based on SQLState is not nearly as accurate as using the ErrorCode (which is, however, vendor- specific). Use of a ErrorCode-based converter should be preferred approach for converting/interpreting SQLExceptions.

Author:
Steve Ebersole

Constructor Summary
SQLStateConverter(ViolatedConstraintNameExtracter extracter)
Method Summary
JDBCException | convert(SQLException sqlException, String message, String sql) Convert the given SQLException into Hibernate's JDBCException hierarchy.
protected JDBCException | handledNonSpecificException(SQLException sqlException, String message, String sql) Handle an exception not converted to a specific type based on the SQLState.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SQLStateConverter

public SQLStateConverter(ViolatedConstraintNameExtracter extracter)
Method Detail

convert

public JDBCException convert(SQLException sqlException,
                             String message,
                             String sql)
Convert the given SQLException into Hibernate's JDBCException hierarchy.

Specified by:
convert in interface SQLExceptionConverter
Parameters:
sqlException - The SQLException to be converted.
message - An optional error message.
sql - Optionally, the sql being performed when the exception occurred.
Returns:
The resulting JDBCException.
See Also:
ConstraintViolationException, JDBCConnectionException, SQLGrammarException, LockAcquisitionException

handledNonSpecificException

protected JDBCException handledNonSpecificException(SQLException sqlException,
                                                    String message,
                                                    String sql)
Handle an exception not converted to a specific type based on the SQLState.

Parameters:
sqlException - The exception to be handled.
message - An optional message
sql - Optionally, the sql being performed when the exception occurred.
Returns:
The converted exception; should never be null.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TemplatedViolatedConstraintNameExtracter (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class TemplatedViolatedConstraintNameExtracter

java.lang.Object
    extended by org.hibernate.exception.TemplatedViolatedConstraintNameExtracter
All Implemented Interfaces:
ViolatedConstraintNameExtracter
public abstract class TemplatedViolatedConstraintNameExtracter
extends Object
implements ViolatedConstraintNameExtracter

Knows how to extract a violated constraint name from an error message based on the fact that the constraint name is templated within the message.

Author:
Steve Ebersole

Constructor Summary
TemplatedViolatedConstraintNameExtracter()
Method Summary
protected  String extractUsingTemplate(String templateStart, String templateEnd, String message)
Extracts the constraint name based on a template (i.e., templateStart constraintName templateEnd).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.exception.ViolatedConstraintNameExtracter
extractConstraintName

Constructor Detail

TemplatedViolatedConstraintNameExtracter

public TemplatedViolatedConstraintNameExtracter()
Method Detail

extractUsingTemplate

protected String extractUsingTemplate(String templateStart,
                                      String templateEnd,
                                      String message)
Extracts the constraint name based on a template (i.e., templateStart constraintName templateEnd).

Parameters:
templateStart - The pattern denoting the start of the constraint name within the message.
templateEnd - The pattern denoting the end of the constraint name within the message.
message - The templated error message containing the constraint name.
Returns:
The found constraint name, or null.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ConstraintViolationException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class ConstraintViolationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.JDBCException
                            extended by org.hibernate.exception.ConstraintViolationException
All Implemented Interfaces:
Nestable, Serializable
public class ConstraintViolationException
extends JDBCException

Implementation of JDBCException indicating that the requested DML operation resulted in a violation of a defined integrity constraint.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
ConstraintViolationException(String message, SQLException root, String constraintName)
ConstraintViolationException(String message, SQLException root, String sql, String constraintName)
Method Summary
 String getConstraintName()
Returns the name of the violated constraint, if known.
Methods inherited from class org.hibernate.JDBCException
getErrorCode, getSQL, getSQLException, getSQLState
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ConstraintViolationException

public ConstraintViolationException(String message,
                                    SQLException root,
                                    String constraintName)

ConstraintViolationException

public ConstraintViolationException(String message,
                                    SQLException root,
                                    String sql,
                                    String constraintName)
Method Detail

getConstraintName

public String getConstraintName()
Returns the name of the violated constraint, if known.

Returns:
The name of the violated constraint, or null if not known.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DataException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class DataException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.JDBCException
                            extended by org.hibernate.exception.DataException
All Implemented Interfaces:
Nestable, Serializable
public class DataException
extends JDBCException

Implementation of JDBCException indicating that evaluation of the valid SQL statement against the given data resulted in some illegal operation, mismatched types or incorrect cardinality.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
DataException(String message, SQLException root)
Constructor for JDBCException.
DataException(String message, SQLException root, String sql)
Constructor for JDBCException.
Methods inherited from class org.hibernate.JDBCException
getErrorCode, getSQL, getSQLException, getSQLState
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DataException

public DataException(String message,
                     SQLException root)
Constructor for JDBCException.

Parameters:
root - The underlying exception.

DataException

public DataException(String message,
                     SQLException root,
                     String sql)
Constructor for JDBCException.

Parameters:
message - Optional message.
root - The underlying exception.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GenericJDBCException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class GenericJDBCException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.JDBCException
                            extended by org.hibernate.exception.GenericJDBCException
All Implemented Interfaces:
Nestable, Serializable
public class GenericJDBCException
extends JDBCException

Generic, non-specific JDBCException.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
GenericJDBCException(String string, SQLException root)
GenericJDBCException(String string, SQLException root, String sql)
Methods inherited from class org.hibernate.JDBCException
getErrorCode, getSQL, getSQLException, getSQLState
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

GenericJDBCException

public GenericJDBCException(String string,
                            SQLException root)

GenericJDBCException

public GenericJDBCException(String string,
                            SQLException root,
                            String sql)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JDBCConnectionException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class JDBCConnectionException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.JDBCException
                            extended by org.hibernate.exception.JDBCConnectionException
All Implemented Interfaces:
Nestable, Serializable
public class JDBCConnectionException
extends JDBCException

Implementation of JDBCException indicating problems with communicating with the database (can also include incorrect JDBC setup).

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
JDBCConnectionException(String string, SQLException root)
JDBCConnectionException(String string, SQLException root, String sql)
Methods inherited from class org.hibernate.JDBCException
getErrorCode, getSQL, getSQLException, getSQLState
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JDBCConnectionException

public JDBCConnectionException(String string,
                               SQLException root)

JDBCConnectionException

public JDBCConnectionException(String string,
                               SQLException root,
                               String sql)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LockAcquisitionException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class LockAcquisitionException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.JDBCException
                            extended by org.hibernate.exception.LockAcquisitionException
All Implemented Interfaces:
Nestable, Serializable
public class LockAcquisitionException
extends JDBCException

Implementation of JDBCException indicating a problem acquiring lock on the database.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
LockAcquisitionException(String string, SQLException root)
LockAcquisitionException(String string, SQLException root, String sql)
Methods inherited from class org.hibernate.JDBCException
getErrorCode, getSQL, getSQLException, getSQLState
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LockAcquisitionException

public LockAcquisitionException(String string,
                                SQLException root)

LockAcquisitionException

public LockAcquisitionException(String string,
                                SQLException root,
                                String sql)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NestableException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class NestableException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by org.hibernate.exception.NestableException
All Implemented Interfaces:
Nestable, Serializable
public class NestableException
extends Exception
implements Nestable

The base class of all exceptions which can contain other exceptions.

It is intended to ease the debugging by carrying on the information about the exception which was caught and provoked throwing the current exception. Catching and rethrowing may occur multiple times, and provided that all exceptions except the first one are descendands of NestedException, when the exception is finally printed out using any of the printStackTrace() methods, the stacktrace will contain the information about all exceptions thrown and caught on the way.

Running the following program

  1 import org.apache.commons.lang.exception.NestableException;
  2
  3 public class Test {
  4     public static void main( String[] args ) {
  5         try {
  6             a();
  7         } catch(Exception e) {
  8             e.printStackTrace();
  9         }
 10      }
 11
 12      public static void a() throws Exception {
 13          try {
 14              b();
 15          } catch(Exception e) {
 16              throw new NestableException("foo", e);
 17          }
 18      }
 19
 20      public static void b() throws Exception {
 21          try {
 22              c();
 23          } catch(Exception e) {
 24              throw new NestableException("bar", e);
 25          }
 26      }
 27
 28      public static void c() throws Exception {
 29          throw new Exception("baz");
 30      }
 31 }

Yields the following stacktrace:

 org.apache.commons.lang.exception.NestableException: foo
         at Test.a(Test.java:16)
         at Test.main(Test.java:6)
 Caused by: org.apache.commons.lang.exception.NestableException: bar
         at Test.b(Test.java:24)
         at Test.a(Test.java:14)
         ... 1 more
 Caused by: java.lang.Exception: baz
         at Test.c(Test.java:29)
         at Test.b(Test.java:22)
         ... 2 more

Since:
1.0
Version:
$Id: NestableException.java 4782 2004-11-21 00:11:27Z pgmjsd $
Author:
Rafal Krzewski, Daniel Rall, Kasper Nielsen, Steven Caswell
See Also:
Serialized Form

Field Summary
protected  NestableDelegate delegate
The helper instance which contains much of the code which we delegate to.
Constructor Summary
NestableException()
Constructs a new NestableException without specified detail message.
NestableException(String msg)
Constructs a new NestableException with specified detail message.
NestableException(String msg, Throwable cause)
Constructs a new NestableException with specified detail message and nested Throwable.
NestableException(Throwable cause)
Constructs a new NestableException with specified nested Throwable.
Method Summary
Throwable | getCause() Returns the reference to the exception or error that caused the exception implementing the Nestable to be thrown.
String | getMessage() Returns the detail message string of this throwable.
String | getMessage(int index) Returns the error message of the Throwable in the chain of Throwables at the specified index, numbererd from 0.
String[] | getMessages() Returns the error message of this and any nested Throwables in an array of Strings, one element for each message.
Throwable | getThrowable(int index) Returns the Throwable in the chain of Throwables at the specified index, numbererd from 0.
int | getThrowableCount() Returns the number of nested Throwables represented by this Nestable, including this Nestable.
Throwable[] | getThrowables() Returns this Nestable and any nested Throwables in an array of Throwables, one element for each Throwable.
int | indexOfThrowable(Class type) Returns the index, numbered from 0, of the first occurrence of the specified type in the chain of Throwables, or -1 if the specified type is not found in the chain.
int | indexOfThrowable(Class type, int fromIndex) Returns the index, numbered from 0, of the first Throwable that matches the specified type in the chain of Throwables with an index greater than or equal to the specified index, or -1 if the type is not found.
void | printPartialStackTrace(PrintWriter out) Prints the stack trace for this exception only--root cause not included--using the provided writer.
void | printStackTrace()
void | printStackTrace(PrintStream out) Prints the stack trace of this exception to the specified print stream.
void | printStackTrace(PrintWriter out) Prints the stack trace of this exception to the specified print writer.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

delegate

protected NestableDelegate delegate
The helper instance which contains much of the code which we delegate to.

Constructor Detail

NestableException

public NestableException()
Constructs a new NestableException without specified detail message.

NestableException

public NestableException(String msg)
Constructs a new NestableException with specified detail message.

Parameters:
msg - The error message.

NestableException

public NestableException(Throwable cause)
Constructs a new NestableException with specified nested Throwable.

Parameters:
cause - the exception or error that caused this exception to be thrown

NestableException

public NestableException(String msg,
                         Throwable cause)
Constructs a new NestableException with specified detail message and nested Throwable.

Parameters:
msg - the error message
cause - the exception or error that caused this exception to be thrown
Method Detail

getCause

public Throwable getCause()
Description copied from interface: Nestable
Returns the reference to the exception or error that caused the exception implementing the Nestable to be thrown.

Specified by:
getCause in interface Nestable

getMessage

public String getMessage()
Returns the detail message string of this throwable. If it was created with a null message, returns the following: ( cause==null ? null : cause.toString() ).

Specified by:
getMessage in interface Nestable

getMessage

public String getMessage(int index)
Description copied from interface: Nestable
Returns the error message of the Throwable in the chain of Throwables at the specified index, numbererd from 0.

Specified by:
getMessage in interface Nestable
Parameters:
index - the index of the Throwable in the chain of Throwables
Returns:
the error message, or null if the Throwable at the specified index in the chain does not contain a message

getMessages

public String[] getMessages()
Description copied from interface: Nestable
Returns the error message of this and any nested Throwables in an array of Strings, one element for each message. Any Throwable not containing a message is represented in the array by a null. This has the effect of cause the length of the returned array to be equal to the result of the Nestable.getThrowableCount() operation.

Specified by:
getMessages in interface Nestable
Returns:
the error messages

getThrowable

public Throwable getThrowable(int index)
Description copied from interface: Nestable
Returns the Throwable in the chain of Throwables at the specified index, numbererd from 0.

Specified by:
getThrowable in interface Nestable
Parameters:
index - the index, numbered from 0, of the Throwable in the chain of Throwables
Returns:
the Throwable

getThrowableCount

public int getThrowableCount()
Description copied from interface: Nestable
Returns the number of nested Throwables represented by this Nestable, including this Nestable.

Specified by:
getThrowableCount in interface Nestable
Returns:
the throwable count

getThrowables

public Throwable[] getThrowables()
Description copied from interface: Nestable
Returns this Nestable and any nested Throwables in an array of Throwables, one element for each Throwable.

Specified by:
getThrowables in interface Nestable
Returns:
the Throwables

indexOfThrowable

public int indexOfThrowable(Class type)
Description copied from interface: Nestable
Returns the index, numbered from 0, of the first occurrence of the specified type in the chain of Throwables, or -1 if the specified type is not found in the chain.

Specified by:
indexOfThrowable in interface Nestable
Parameters:
type - Class to be found
Returns:
index of the first occurrence of the type in the chain, or -1 if the type is not found

indexOfThrowable

public int indexOfThrowable(Class type,
                            int fromIndex)
Description copied from interface: Nestable
Returns the index, numbered from 0, of the first Throwable that matches the specified type in the chain of Throwables with an index greater than or equal to the specified index, or -1 if the type is not found.

Specified by:
indexOfThrowable in interface Nestable
Parameters:
type - Class to be found
fromIndex - the index, numbered from 0, of the starting position in the chain to be searched
Returns:
index of the first occurrence of the type in the chain, or -1 if the type is not found

printStackTrace

public void printStackTrace()

printStackTrace

public void printStackTrace(PrintStream out)
Description copied from interface: Nestable
Prints the stack trace of this exception to the specified print stream. Includes inforamation from the exception, if any, which caused this exception.

Specified by:
printStackTrace in interface Nestable

printStackTrace

public void printStackTrace(PrintWriter out)
Description copied from interface: Nestable
Prints the stack trace of this exception to the specified print writer. Includes information from the exception, if any, which caused this exception.

Specified by:
printStackTrace in interface Nestable

printPartialStackTrace

public final void printPartialStackTrace(PrintWriter out)
Description copied from interface: Nestable
Prints the stack trace for this exception only--root cause not included--using the provided writer. Used by org.apache.commons.lang.exception.NestableDelegate to write individual stack traces to a buffer. The implementation of this method should call super.printStackTrace(out); in most cases.

Specified by:
printPartialStackTrace in interface Nestable
Parameters:
out - The writer to use.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NestableRuntimeException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class NestableRuntimeException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
All Implemented Interfaces:
Nestable, Serializable
Direct Known Subclasses:
AssertionFailure, HibernateException
public class NestableRuntimeException
extends RuntimeException
implements Nestable

The base class of all runtime exceptions which can contain other exceptions.

Since:
1.0
Version:
$Id: NestableRuntimeException.java 8137 2005-09-09 15:21:10Z epbernard $
Author:
Rafal Krzewski, Daniel Rall, Kasper Nielsen, Steven Caswell
See Also:
org.apache.commons.lang.exception.NestableException, Serialized Form

Field Summary
protected  NestableDelegate delegate
The helper instance which contains much of the code which we delegate to.
Constructor Summary
NestableRuntimeException()
Constructs a new NestableRuntimeException without specified detail message.
NestableRuntimeException(String msg)
Constructs a new NestableRuntimeException with specified detail message.
NestableRuntimeException(String msg, Throwable cause)
Constructs a new NestableRuntimeException with specified detail message and nested Throwable.
NestableRuntimeException(Throwable cause)
Constructs a new NestableRuntimeException with specified nested Throwable.
Method Summary
Throwable | getCause() Returns the reference to the exception or error that caused the exception implementing the Nestable to be thrown.
String | getMessage() Returns the detail message string of this throwable.
String | getMessage(int index) Returns the error message of the Throwable in the chain of Throwables at the specified index, numbererd from 0.
String[] | getMessages() Returns the error message of this and any nested Throwables in an array of Strings, one element for each message.
Throwable | getThrowable(int index) Returns the Throwable in the chain of Throwables at the specified index, numbererd from 0.
int | getThrowableCount() Returns the number of nested Throwables represented by this Nestable, including this Nestable.
Throwable[] | getThrowables() Returns this Nestable and any nested Throwables in an array of Throwables, one element for each Throwable.
int | indexOfThrowable(Class type) Returns the index, numbered from 0, of the first occurrence of the specified type in the chain of Throwables, or -1 if the specified type is not found in the chain.
int | indexOfThrowable(Class type, int fromIndex) Returns the index, numbered from 0, of the first Throwable that matches the specified type in the chain of Throwables with an index greater than or equal to the specified index, or -1 if the type is not found.
void | printPartialStackTrace(PrintWriter out) Prints the stack trace for this exception only--root cause not included--using the provided writer.
void | printStackTrace()
void | printStackTrace(PrintStream out) Prints the stack trace of this exception to the specified print stream.
void | printStackTrace(PrintWriter out) Prints the stack trace of this exception to the specified print writer.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

delegate

protected NestableDelegate delegate
The helper instance which contains much of the code which we delegate to.

Constructor Detail

NestableRuntimeException

public NestableRuntimeException()
Constructs a new NestableRuntimeException without specified detail message.

NestableRuntimeException

public NestableRuntimeException(String msg)
Constructs a new NestableRuntimeException with specified detail message.

Parameters:
msg - the error message

NestableRuntimeException

public NestableRuntimeException(Throwable cause)
Constructs a new NestableRuntimeException with specified nested Throwable.

Parameters:
cause - the exception or error that caused this exception to be thrown

NestableRuntimeException

public NestableRuntimeException(String msg,
                                Throwable cause)
Constructs a new NestableRuntimeException with specified detail message and nested Throwable.

Parameters:
msg - the error message
cause - the exception or error that caused this exception to be thrown
Method Detail

getCause

public Throwable getCause()
Description copied from interface: Nestable
Returns the reference to the exception or error that caused the exception implementing the Nestable to be thrown.

Specified by:
getCause in interface Nestable

getMessage

public String getMessage()
Returns the detail message string of this throwable. If it was created with a null message, returns the following: ( cause==null ? null : cause.toString( ).

Specified by:
getMessage in interface Nestable

getMessage

public String getMessage(int index)
Description copied from interface: Nestable
Returns the error message of the Throwable in the chain of Throwables at the specified index, numbererd from 0.

Specified by:
getMessage in interface Nestable
Parameters:
index - the index of the Throwable in the chain of Throwables
Returns:
the error message, or null if the Throwable at the specified index in the chain does not contain a message

getMessages

public String[] getMessages()
Description copied from interface: Nestable
Returns the error message of this and any nested Throwables in an array of Strings, one element for each message. Any Throwable not containing a message is represented in the array by a null. This has the effect of cause the length of the returned array to be equal to the result of the Nestable.getThrowableCount() operation.

Specified by:
getMessages in interface Nestable
Returns:
the error messages

getThrowable

public Throwable getThrowable(int index)
Description copied from interface: Nestable
Returns the Throwable in the chain of Throwables at the specified index, numbererd from 0.

Specified by:
getThrowable in interface Nestable
Parameters:
index - the index, numbered from 0, of the Throwable in the chain of Throwables
Returns:
the Throwable

getThrowableCount

public int getThrowableCount()
Description copied from interface: Nestable
Returns the number of nested Throwables represented by this Nestable, including this Nestable.

Specified by:
getThrowableCount in interface Nestable
Returns:
the throwable count

getThrowables

public Throwable[] getThrowables()
Description copied from interface: Nestable
Returns this Nestable and any nested Throwables in an array of Throwables, one element for each Throwable.

Specified by:
getThrowables in interface Nestable
Returns:
the Throwables

indexOfThrowable

public int indexOfThrowable(Class type)
Description copied from interface: Nestable
Returns the index, numbered from 0, of the first occurrence of the specified type in the chain of Throwables, or -1 if the specified type is not found in the chain.

Specified by:
indexOfThrowable in interface Nestable
Parameters:
type - Class to be found
Returns:
index of the first occurrence of the type in the chain, or -1 if the type is not found

indexOfThrowable

public int indexOfThrowable(Class type,
                            int fromIndex)
Description copied from interface: Nestable
Returns the index, numbered from 0, of the first Throwable that matches the specified type in the chain of Throwables with an index greater than or equal to the specified index, or -1 if the type is not found.

Specified by:
indexOfThrowable in interface Nestable
Parameters:
type - Class to be found
fromIndex - the index, numbered from 0, of the starting position in the chain to be searched
Returns:
index of the first occurrence of the type in the chain, or -1 if the type is not found

printStackTrace

public void printStackTrace()

printStackTrace

public void printStackTrace(PrintStream out)
Description copied from interface: Nestable
Prints the stack trace of this exception to the specified print stream. Includes inforamation from the exception, if any, which caused this exception.

Specified by:
printStackTrace in interface Nestable

printStackTrace

public void printStackTrace(PrintWriter out)
Description copied from interface: Nestable
Prints the stack trace of this exception to the specified print writer. Includes information from the exception, if any, which caused this exception.

Specified by:
printStackTrace in interface Nestable

printPartialStackTrace

public final void printPartialStackTrace(PrintWriter out)
Description copied from interface: Nestable
Prints the stack trace for this exception only--root cause not included--using the provided writer. Used by org.apache.commons.lang.exception.NestableDelegate to write individual stack traces to a buffer. The implementation of this method should call super.printStackTrace(out); in most cases.

Specified by:
printPartialStackTrace in interface Nestable
Parameters:
out - The writer to use.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLGrammarException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.exception
Class SQLGrammarException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.JDBCException
                            extended by org.hibernate.exception.SQLGrammarException
All Implemented Interfaces:
Nestable, Serializable
public class SQLGrammarException
extends JDBCException

Implementation of JDBCException indicating that the SQL sent to the database server was invalid (syntax error, invalid object references, etc).

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
SQLGrammarException(String message, SQLException root)
Constructor for JDBCException.
SQLGrammarException(String message, SQLException root, String sql)
Constructor for JDBCException.
Methods inherited from class org.hibernate.JDBCException
getErrorCode, getSQL, getSQLException, getSQLState
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SQLGrammarException

public SQLGrammarException(String message,
                           SQLException root)
Constructor for JDBCException.

Parameters:
root - The underlying exception.

SQLGrammarException

public SQLGrammarException(String message,
                           SQLException root,
                           String sql)
Constructor for JDBCException.

Parameters:
message - Optional message.
root - The underlying exception.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.hql (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.hql

This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).

See:
Description

Interface Summary
FilterTranslator | Specialized interface for filters.
ParameterTranslations | Defines available information about the parameters encountered during query translation.
QueryTranslator | Defines the constract of an HQL->SQL translator.
QueryTranslatorFactory | Facade for generation of QueryTranslator and FilterTranslator instances.

Class Summary
CollectionProperties | Provides a map of collection function names to the corresponding property names.
CollectionSubqueryFactory | Provides the SQL for collection subqueries.
HolderInstantiator |
NameGenerator | Provides utility methods for generating HQL / SQL names.
QuerySplitter | Provides query splitting methods, which were originally in QueryTranslator.

Exception Summary
QueryExecutionRequestException Expecting to execute an illegal operation regarding the query type

Package org.hibernate.hql Description

This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).


org.hibernate.hql Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.hql

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.hql.CollectionProperties
    • class org.hibernate.hql.CollectionSubqueryFactory
    • class org.hibernate.hql.HolderInstantiator
    • class org.hibernate.hql.NameGenerator
    • class org.hibernate.hql.QuerySplitter
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class org.hibernate.exception.NestableRuntimeException (implements org.hibernate.exception.Nestable)
            • class org.hibernate.HibernateException
              • class org.hibernate.QueryException
                • class org.hibernate.hql.QueryExecutionRequestException

Interface Hierarchy

  • interface org.hibernate.hql.ParameterTranslations
  • interface org.hibernate.hql.QueryTranslator
    • interface org.hibernate.hql.FilterTranslator
  • interface org.hibernate.hql.QueryTranslatorFactory


Uses of Package org.hibernate.hql (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.hql

Packages that use org.hibernate.hql
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine.query |
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser

Classes in org.hibernate.hql used by org.hibernate.cfg
QueryTranslatorFactory
Facade for generation of QueryTranslator and FilterTranslator instances.

Classes in org.hibernate.hql used by org.hibernate.engine.query
QueryTranslator
Defines the constract of an HQL->SQL translator.

Classes in org.hibernate.hql used by org.hibernate.hql
FilterTranslator
Specialized interface for filters.
HolderInstantiator
ParameterTranslations
Defines available information about the parameters encountered during query translation.
QueryTranslator
Defines the constract of an HQL->SQL translator.

Classes in org.hibernate.hql used by org.hibernate.hql.ast
FilterTranslator
Specialized interface for filters.
ParameterTranslations
Defines available information about the parameters encountered during query translation.
QueryTranslator
Defines the constract of an HQL->SQL translator.
QueryTranslatorFactory
Facade for generation of QueryTranslator and FilterTranslator instances.

Classes in org.hibernate.hql used by org.hibernate.hql.classic
FilterTranslator
Specialized interface for filters.
QueryTranslator
Defines the constract of an HQL->SQL translator.
QueryTranslatorFactory
Facade for generation of QueryTranslator and FilterTranslator instances.

Classes in org.hibernate.hql used by org.hibernate.impl
HolderInstantiator

Classes in org.hibernate.hql used by org.hibernate.loader
HolderInstantiator

Classes in org.hibernate.hql used by org.hibernate.loader.hql
QueryTranslator
Defines the constract of an HQL->SQL translator.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


FilterTranslator (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql
Interface FilterTranslator

All Superinterfaces:
QueryTranslator
All Known Implementing Classes:
QueryTranslatorImpl, QueryTranslatorImpl
public interface FilterTranslator
extends QueryTranslator

Specialized interface for filters.

Author:
josh Mar 14, 2004 11:33:35 AM

Field Summary
Fields inherited from interface org.hibernate.hql.QueryTranslator
ERROR_CANNOT_DETERMINE_TYPE, ERROR_CANNOT_FETCH_WITH_ITERATE, ERROR_CANNOT_FORMAT_LITERAL, ERROR_NAMED_PARAMETER_DOES_NOT_APPEAR
Method Summary
 void compile(String collectionRole, Map replacements, boolean shallow)
Compile a filter.
Methods inherited from interface org.hibernate.hql.QueryTranslator
collectSqlStrings, compile, containsCollectionFetches, executeUpdate, getColumnNames, getEnabledFilters, getParameterTranslations, getQueryIdentifier, getQuerySpaces, getQueryString, getReturnAliases, getReturnTypes, getSQLString, isManipulationStatement, iterate, list, scroll, validateScrollability

Method Detail

compile

public void compile(String collectionRole,
                    Map replacements,
                    boolean shallow)
             throws QueryException,
                    MappingException
Compile a filter. This method may be called multiple times. Subsequent invocations are no-ops.

Parameters:
collectionRole - the role name of the collection used as the basis for the filter.
replacements - Defined query substitutions.
shallow - Does this represent a shallow (scalar or entity-id) select?
Throws:
QueryException - There was a problem parsing the query string.
MappingException - There was a problem querying defined mappings.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ParameterTranslations (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql
Interface ParameterTranslations

All Known Implementing Classes:
ParameterTranslationsImpl
public interface ParameterTranslations

Defines available information about the parameters encountered during query translation.

Author:
Steve Ebersole

Method Summary
Type | getNamedParameterExpectedType(String name)
Set | getNamedParameterNames()
int[] | getNamedParameterSqlLocations(String name)
int | getOrdinalParameterCount()
Type | getOrdinalParameterExpectedType(int ordinalPosition)
int | getOrdinalParameterSqlLocation(int ordinalPosition)
boolean | supportsOrdinalParameterMetadata()

Method Detail

supportsOrdinalParameterMetadata

public boolean supportsOrdinalParameterMetadata()

getOrdinalParameterCount

public int getOrdinalParameterCount()

getOrdinalParameterSqlLocation

public int getOrdinalParameterSqlLocation(int ordinalPosition)

getOrdinalParameterExpectedType

public Type getOrdinalParameterExpectedType(int ordinalPosition)

getNamedParameterNames

public Set getNamedParameterNames()

getNamedParameterSqlLocations

public int[] getNamedParameterSqlLocations(String name)

getNamedParameterExpectedType

public Type getNamedParameterExpectedType(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryTranslator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql
Interface QueryTranslator

All Known Subinterfaces:
FilterTranslator
All Known Implementing Classes:
QueryTranslatorImpl, QueryTranslatorImpl
public interface QueryTranslator

Defines the constract of an HQL->SQL translator.

Author:
josh

Field Summary
static String | ERROR_CANNOT_DETERMINE_TYPE
static String | ERROR_CANNOT_FETCH_WITH_ITERATE
static String | ERROR_CANNOT_FORMAT_LITERAL
static String | ERROR_NAMED_PARAMETER_DOES_NOT_APPEAR
Method Summary
List | collectSqlStrings()
void | compile(Map replacements, boolean shallow) Compile a "normal" query.
boolean | containsCollectionFetches() Does the translated query contain collection fetches?
int | executeUpdate(QueryParameters queryParameters, SessionImplementor session) Perform a bulk update/delete operation given the underlying query defintion.
String[][] | getColumnNames() Returns the column names in the generated SQL.
Map | getEnabledFilters() Returns the filters enabled for this query translator.
ParameterTranslations | getParameterTranslations() Return information about any parameters encountered during translation.
String | getQueryIdentifier() Retrieve the query identifier for this translator.
Set | getQuerySpaces() Returns the set of query spaces (table names) that the query referrs to.
String | getQueryString() Returns the HQL string processed by the translator.
String[] | getReturnAliases() Returns an array of HQL aliases
Type[] | getReturnTypes() Returns an array of Types represented in the query result.
String | getSQLString() Returns the SQL string generated by the translator.
boolean | isManipulationStatement()
Iterator | iterate(QueryParameters queryParameters, EventSource session) Perform an iterate operation given the underlying query defintion.
List | list(SessionImplementor session, QueryParameters queryParameters) Perform a list operation given the underlying query definition.
ScrollableResults | scroll(QueryParameters queryParameters, SessionImplementor session) Perform a scroll operation given the underlying query defintion.
void | validateScrollability() Validate the scrollability of the translated query.

Field Detail

ERROR_CANNOT_FETCH_WITH_ITERATE

public static final String ERROR_CANNOT_FETCH_WITH_ITERATE
See Also:
Constant Field Values

ERROR_NAMED_PARAMETER_DOES_NOT_APPEAR

public static final String ERROR_NAMED_PARAMETER_DOES_NOT_APPEAR
See Also:
Constant Field Values

ERROR_CANNOT_DETERMINE_TYPE

public static final String ERROR_CANNOT_DETERMINE_TYPE
See Also:
Constant Field Values

ERROR_CANNOT_FORMAT_LITERAL

public static final String ERROR_CANNOT_FORMAT_LITERAL
See Also:
Constant Field Values
Method Detail

compile

public void compile(Map replacements,
                    boolean shallow)
             throws QueryException,
                    MappingException
Compile a "normal" query. This method may be called multiple times. Subsequent invocations are no-ops.

Parameters:
replacements - Defined query substitutions.
shallow - Does this represent a shallow (scalar or entity-id) select?
Throws:
QueryException - There was a problem parsing the query string.
MappingException - There was a problem querying defined mappings.

list

public List list(SessionImplementor session,
                 QueryParameters queryParameters)
          throws HibernateException
Perform a list operation given the underlying query definition.

Parameters:
session - The session owning this query.
queryParameters - The query bind parameters.
Returns:
The query list results.
Throws:
HibernateException

iterate

public Iterator iterate(QueryParameters queryParameters,
                        EventSource session)
                 throws HibernateException
Perform an iterate operation given the underlying query defintion.

Parameters:
queryParameters - The query bind parameters.
session - The session owning this query.
Returns:
An iterator over the query results.
Throws:
HibernateException

scroll

public ScrollableResults scroll(QueryParameters queryParameters,
                                SessionImplementor session)
                         throws HibernateException
Perform a scroll operation given the underlying query defintion.

Parameters:
queryParameters - The query bind parameters.
session - The session owning this query.
Returns:
The ScrollableResults wrapper around the query results.
Throws:
HibernateException

executeUpdate

public int executeUpdate(QueryParameters queryParameters,
                         SessionImplementor session)
                  throws HibernateException
Perform a bulk update/delete operation given the underlying query defintion.

Parameters:
queryParameters - The query bind parameters.
session - The session owning this query.
Returns:
The number of entities updated or deleted.
Throws:
HibernateException

getQuerySpaces

public Set getQuerySpaces()
Returns the set of query spaces (table names) that the query referrs to.

Returns:
A set of query spaces (table names).

getQueryIdentifier

public String getQueryIdentifier()
Retrieve the query identifier for this translator. The query identifier is used in stats collection.

Returns:
the identifier

getSQLString

public String getSQLString()
Returns the SQL string generated by the translator.

Returns:
the SQL string generated by the translator.

collectSqlStrings

public List collectSqlStrings()

getQueryString

public String getQueryString()
Returns the HQL string processed by the translator.

Returns:
the HQL string processed by the translator.

getEnabledFilters

public Map getEnabledFilters()
Returns the filters enabled for this query translator.

Returns:
Filters enabled for this query execution.

getReturnTypes

public Type[] getReturnTypes()
Returns an array of Types represented in the query result.

Returns:
Query return types.

getReturnAliases

public String[] getReturnAliases()
Returns an array of HQL aliases

getColumnNames

public String[][] getColumnNames()
Returns the column names in the generated SQL.

Returns:
the column names in the generated SQL.

getParameterTranslations

public ParameterTranslations getParameterTranslations()
Return information about any parameters encountered during translation.

Returns:
The parameter information.

validateScrollability

public void validateScrollability()
                           throws HibernateException
Validate the scrollability of the translated query.

Throws:
HibernateException

containsCollectionFetches

public boolean containsCollectionFetches()
Does the translated query contain collection fetches?

Returns:
tru if the query does contain collection fetched; false otherwise.

isManipulationStatement

public boolean isManipulationStatement()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryTranslatorFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql
Interface QueryTranslatorFactory

All Known Implementing Classes:
ASTQueryTranslatorFactory, ClassicQueryTranslatorFactory
public interface QueryTranslatorFactory

Facade for generation of QueryTranslator and FilterTranslator instances.

Author:
Gavin King

Method Summary
FilterTranslator | createFilterTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory) Construct a FilterTranslator instance capable of translating an HQL filter string.
QueryTranslator | createQueryTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory) Construct a QueryTranslator instance capable of translating an HQL query string.

Method Detail

createQueryTranslator

public QueryTranslator createQueryTranslator(String queryIdentifier,
                                             String queryString,
                                             Map filters,
                                             SessionFactoryImplementor factory)
Construct a QueryTranslator instance capable of translating an HQL query string.

Parameters:
queryIdentifier - The query-identifier (used in QueryStatistics collection). This is typically the same as the queryString parameter except for the case of split polymorphic queries which result in multiple physical sql queries.
queryString - The query string to be translated
filters - Currently enabled filters
factory - The session factory.
Returns:
an appropriate translator.

createFilterTranslator

public FilterTranslator createFilterTranslator(String queryIdentifier,
                                               String queryString,
                                               Map filters,
                                               SessionFactoryImplementor factory)
Construct a FilterTranslator instance capable of translating an HQL filter string.

See Also:
createQueryTranslator(java.lang.String, java.lang.String, java.util.Map, org.hibernate.engine.SessionFactoryImplementor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CollectionProperties (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql
Class CollectionProperties

java.lang.Object
    extended by org.hibernate.hql.CollectionProperties
public final class CollectionProperties
extends Object

Provides a map of collection function names to the corresponding property names.

Author:
josh Aug 16, 2004 7:51:45 PM

Field Summary
static Map HQL_COLLECTION_PROPERTIES
Method Summary
static String | getNormalizedPropertyName(String name)
static boolean | isAnyCollectionProperty(String name)
static boolean | isCollectionProperty(String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

HQL_COLLECTION_PROPERTIES

public static final Map HQL_COLLECTION_PROPERTIES
Method Detail

isCollectionProperty

public static boolean isCollectionProperty(String name)

getNormalizedPropertyName

public static String getNormalizedPropertyName(String name)

isAnyCollectionProperty

public static boolean isAnyCollectionProperty(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CollectionSubqueryFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql
Class CollectionSubqueryFactory

java.lang.Object
    extended by org.hibernate.hql.CollectionSubqueryFactory
public final class CollectionSubqueryFactory
extends Object

Provides the SQL for collection subqueries.
Moved here from PathExpressionParser to make it re-useable.

Author:
josh

Method Summary
static String createCollectionSubquery(JoinSequence joinSequence, Map enabledFilters, String[] columns)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createCollectionSubquery

public static String createCollectionSubquery(JoinSequence joinSequence,
                                              Map enabledFilters,
                                              String[] columns)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HolderInstantiator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql
Class HolderInstantiator

java.lang.Object
    extended by org.hibernate.hql.HolderInstantiator
public final class HolderInstantiator
extends Object

Author:
Gavin King

Field Summary
static HolderInstantiator NOOP_INSTANTIATOR
Constructor Summary
HolderInstantiator(ResultTransformer transformer, String[] queryReturnAliases)
Method Summary
static HolderInstantiator | createClassicHolderInstantiator(Constructor constructor, ResultTransformer transformer)
static ResultTransformer | createSelectNewTransformer(Constructor constructor, boolean returnMaps, boolean returnLists)
static HolderInstantiator | getHolderInstantiator(ResultTransformer selectNewTransformer, ResultTransformer customTransformer, String[] queryReturnAliases)
String[] | getQueryReturnAliases()
ResultTransformer | getResultTransformer()
Object | instantiate(Object[] row)
boolean | isRequired()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NOOP_INSTANTIATOR

public static final HolderInstantiator NOOP_INSTANTIATOR
Constructor Detail

HolderInstantiator

public HolderInstantiator(ResultTransformer transformer,
                          String[] queryReturnAliases)
Method Detail

getHolderInstantiator

public static HolderInstantiator getHolderInstantiator(ResultTransformer selectNewTransformer,
                                                       ResultTransformer customTransformer,
                                                       String[] queryReturnAliases)

createSelectNewTransformer

public static ResultTransformer createSelectNewTransformer(Constructor constructor,
                                                           boolean returnMaps,
                                                           boolean returnLists)

createClassicHolderInstantiator

public static HolderInstantiator createClassicHolderInstantiator(Constructor constructor,
                                                                 ResultTransformer transformer)

isRequired

public boolean isRequired()

instantiate

public Object instantiate(Object[] row)

getQueryReturnAliases

public String[] getQueryReturnAliases()

getResultTransformer

public ResultTransformer getResultTransformer()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NameGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql
Class NameGenerator

java.lang.Object
    extended by org.hibernate.hql.NameGenerator
public final class NameGenerator
extends Object

Provides utility methods for generating HQL / SQL names. Shared by both the 'classic' and 'new' query translators.

Author:
josh Mar 18, 2004 7:17:25 AM

Method Summary
static String[][] | generateColumnNames(Type[] types, SessionFactoryImplementor f)
static String | scalarName(int x, int y)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

generateColumnNames

public static String[][] generateColumnNames(Type[] types,
                                             SessionFactoryImplementor f)
                                      throws MappingException
Throws:
MappingException

scalarName

public static String scalarName(int x,
                                int y)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuerySplitter (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql
Class QuerySplitter

java.lang.Object
    extended by org.hibernate.hql.QuerySplitter
public final class QuerySplitter
extends Object

Provides query splitting methods, which were originally in QueryTranslator.
TODO: This will need to be refactored at some point.

Author:
josh Mar 14, 2004 10:50:23 AM

Method Summary
static String[] | concreteQueries(String query, SessionFactoryImplementor factory) Handle Hibernate "implicit" polymorphism, by translating the query string into several "concrete" queries against mapped classes.
static String | getImportedClass(String name, SessionFactoryImplementor factory)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

concreteQueries

public static String[] concreteQueries(String query,
                                       SessionFactoryImplementor factory)
                                throws MappingException
Handle Hibernate "implicit" polymorphism, by translating the query string into several "concrete" queries against mapped classes.

Throws:
MappingException

getImportedClass

public static String getImportedClass(String name,
                                      SessionFactoryImplementor factory)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


QueryExecutionRequestException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql
Class QueryExecutionRequestException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.QueryException
                            extended by org.hibernate.hql.QueryExecutionRequestException
All Implemented Interfaces:
Nestable, Serializable
public class QueryExecutionRequestException
extends QueryException

Expecting to execute an illegal operation regarding the query type

Author:
Emmanuel Bernard
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
QueryExecutionRequestException(String message, String queryString)
Methods inherited from class org.hibernate.QueryException
getMessage, getQueryString, setQueryString
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

QueryExecutionRequestException

public QueryExecutionRequestException(String message,
                                      String queryString)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.hql.antlr (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.hql.antlr

A special package for ANTLR-generated parser classes.

See:
Description

Interface Summary
HqlSqlTokenTypes
HqlTokenTypes
SqlTokenTypes

Class Summary
HqlBaseLexer | Hibernate Query Language Lexer This lexer provides the HQL parser with tokens.
HqlBaseParser | Hibernate Query Language Grammar This grammar parses the query language for Hibernate (an Open Source, Object-Relational mapping library).
HqlSqlBaseWalker | Hibernate Query Language to SQL Tree Transform. This is a tree grammar that transforms an HQL AST into a intermediate SQL AST with bindings to Hibernate interfaces (Queryable, etc.).
SqlGeneratorBase | SQL Generator Tree Parser, providing SQL rendering of SQL ASTs produced by the previous phase, HqlSqlWalker.

Package org.hibernate.hql.antlr Description

A special package for ANTLR-generated parser classes.

NOTE: The classes in this package are generated from the ANTLR grammar files, do not register them into version control.


org.hibernate.hql.antlr Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.hql.antlr

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class antlr.CharScanner (implements antlr.TokenStream)
      • class org.hibernate.hql.antlr.HqlBaseLexer (implements org.hibernate.hql.antlr.HqlTokenTypes, antlr.TokenStream)
    • class antlr.Parser
      • class antlr.LLkParser
        • class org.hibernate.hql.antlr.HqlBaseParser (implements org.hibernate.hql.antlr.HqlTokenTypes)
    • class antlr.TreeParser
      • class org.hibernate.hql.antlr.HqlSqlBaseWalker (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)
      • class org.hibernate.hql.antlr.SqlGeneratorBase (implements org.hibernate.hql.antlr.SqlTokenTypes)

Interface Hierarchy

  • interface org.hibernate.hql.antlr.HqlSqlTokenTypes
  • interface org.hibernate.hql.antlr.HqlTokenTypes
  • interface org.hibernate.hql.antlr.SqlTokenTypes


Uses of Package org.hibernate.hql.antlr (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.hql.antlr

Packages that use org.hibernate.hql.antlr
org.hibernate.hql.antlr | A special package for ANTLR-generated parser classes.
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |

Classes in org.hibernate.hql.antlr used by org.hibernate.hql.antlr
HqlSqlTokenTypes
HqlTokenTypes
SqlTokenTypes

Classes in org.hibernate.hql.antlr used by org.hibernate.hql.ast
HqlBaseParser
Hibernate Query Language Grammar
This grammar parses the query language for Hibernate (an Open Source, Object-Relational mapping library).
HqlSqlBaseWalker
Hibernate Query Language to SQL Tree Transform.
This is a tree grammar that transforms an HQL AST into a intermediate SQL AST with bindings to Hibernate interfaces (Queryable, etc.).
HqlSqlTokenTypes
HqlTokenTypes
SqlGeneratorBase
SQL Generator Tree Parser, providing SQL rendering of SQL ASTs produced by the previous phase, HqlSqlWalker.
SqlTokenTypes

Classes in org.hibernate.hql.antlr used by org.hibernate.hql.ast.tree
HqlSqlTokenTypes

Classes in org.hibernate.hql.antlr used by org.hibernate.hql.ast.util
HqlSqlTokenTypes
SqlTokenTypes

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HqlSqlTokenTypes (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.antlr
Interface HqlSqlTokenTypes

All Known Implementing Classes:
FromClause, HqlSqlBaseWalker, LiteralNode, LiteralProcessor, OrderByClause, SqlASTFactory, SyntheticAndFactory
public interface HqlSqlTokenTypes

Field Summary
static int | AGGREGATE
static int | ALIAS
static int | ALIAS_REF
static int | ALL
static int | AND
static int | ANY
static int | AS
static int | ASCENDING
static int | AVG
static int | BETWEEN
static int | BOGUS
static int | BOTH
static int | CASE
static int | CASE2
static int | CLASS
static int | CLOSE
static int | CLOSE_BRACKET
static int | COLON
static int | COMMA
static int | CONCAT
static int | CONSTANT
static int | CONSTRUCTOR
static int | COUNT
static int | DELETE
static int | DESCENDING
static int | DISTINCT
static int | DIV
static int | DOT
static int | ELEMENTS
static int | ELSE
static int | EMPTY
static int | END
static int | EOF
static int | EQ
static int | ESCAPE
static int | ESCqs
static int | EXISTS
static int | EXPONENT
static int | EXPR_LIST
static int | FALSE
static int | FETCH
static int | FILTER_ENTITY
static int | FILTERS
static int | FLOAT_SUFFIX
static int | FROM
static int | FROM_FRAGMENT
static int | FULL
static int | GE
static int | GROUP
static int | GT
static int | HAVING
static int | HEX_DIGIT
static int | ID_LETTER
static int | ID_START_LETTER
static int | IDENT
static int | IMPLIED_FROM
static int | IN
static int | IN_LIST
static int | INDEX_OP
static int | INDICES
static int | INNER
static int | INSERT
static int | INTO
static int | IS
static int | IS_NOT_NULL
static int | IS_NULL
static int | JAVA_CONSTANT
static int | JOIN
static int | JOIN_FRAGMENT
static int | LE
static int | LEADING
static int | LEFT
static int | LEFT_OUTER
static int | LIKE
static int | LITERAL_ascending
static int | LITERAL_by
static int | LITERAL_descending
static int | LT
static int | MAX
static int | MEMBER
static int | METHOD_CALL
static int | METHOD_NAME
static int | MIN
static int | MINUS
static int | NAMED_PARAM
static int | NE
static int | NEW
static int | NOT
static int | NOT_BETWEEN
static int | NOT_IN
static int | NOT_LIKE
static int | NULL
static int | NULL_TREE_LOOKAHEAD
static int | NUM_DOUBLE
static int | NUM_FLOAT
static int | NUM_INT
static int | NUM_LONG
static int | OBJECT
static int | OF
static int | ON
static int | OPEN
static int | OPEN_BRACKET
static int | OR
static int | ORDER
static int | ORDER_ELEMENT
static int | OUTER
static int | PARAM
static int | PLUS
static int | PROPERTIES
static int | PROPERTY_REF
static int | QUERY
static int | QUOTED_STRING
static int | RANGE
static int | RIGHT
static int | RIGHT_OUTER
static int | ROW_STAR
static int | SELECT
static int | SELECT_CLAUSE
static int | SELECT_COLUMNS
static int | SELECT_EXPR
static int | SELECT_FROM
static int | SET
static int | SOME
static int | SQL_NE
static int | SQL_TOKEN
static int | STAR
static int | SUM
static int | THEN
static int | THETA_JOINS
static int | TRAILING
static int | TRUE
static int | UNARY_MINUS
static int | UNARY_PLUS
static int | UNION
static int | UPDATE
static int | VECTOR_EXPR
static int | VERSIONED
static int | WEIRD_IDENT
static int | WHEN
static int | WHERE
static int | WITH
static int | WS

Field Detail

EOF

public static final int EOF
See Also:
Constant Field Values

NULL_TREE_LOOKAHEAD

public static final int NULL_TREE_LOOKAHEAD
See Also:
Constant Field Values

ALL

public static final int ALL
See Also:
Constant Field Values

ANY

public static final int ANY
See Also:
Constant Field Values

AND

public static final int AND
See Also:
Constant Field Values

AS

public static final int AS
See Also:
Constant Field Values

ASCENDING

public static final int ASCENDING
See Also:
Constant Field Values

AVG

public static final int AVG
See Also:
Constant Field Values

BETWEEN

public static final int BETWEEN
See Also:
Constant Field Values

CLASS

public static final int CLASS
See Also:
Constant Field Values

COUNT

public static final int COUNT
See Also:
Constant Field Values

DELETE

public static final int DELETE
See Also:
Constant Field Values

DESCENDING

public static final int DESCENDING
See Also:
Constant Field Values

DOT

public static final int DOT
See Also:
Constant Field Values

DISTINCT

public static final int DISTINCT
See Also:
Constant Field Values

ELEMENTS

public static final int ELEMENTS
See Also:
Constant Field Values

ESCAPE

public static final int ESCAPE
See Also:
Constant Field Values

EXISTS

public static final int EXISTS
See Also:
Constant Field Values

FALSE

public static final int FALSE
See Also:
Constant Field Values

FETCH

public static final int FETCH
See Also:
Constant Field Values

FROM

public static final int FROM
See Also:
Constant Field Values

FULL

public static final int FULL
See Also:
Constant Field Values

GROUP

public static final int GROUP
See Also:
Constant Field Values

HAVING

public static final int HAVING
See Also:
Constant Field Values

IN

public static final int IN
See Also:
Constant Field Values

INDICES

public static final int INDICES
See Also:
Constant Field Values

INNER

public static final int INNER
See Also:
Constant Field Values

INSERT

public static final int INSERT
See Also:
Constant Field Values

INTO

public static final int INTO
See Also:
Constant Field Values

IS

public static final int IS
See Also:
Constant Field Values

JOIN

public static final int JOIN
See Also:
Constant Field Values

LEFT

public static final int LEFT
See Also:
Constant Field Values

LIKE

public static final int LIKE
See Also:
Constant Field Values

MAX

public static final int MAX
See Also:
Constant Field Values

MIN

public static final int MIN
See Also:
Constant Field Values

NEW

public static final int NEW
See Also:
Constant Field Values

NOT

public static final int NOT
See Also:
Constant Field Values

NULL

public static final int NULL
See Also:
Constant Field Values

OR

public static final int OR
See Also:
Constant Field Values

ORDER

public static final int ORDER
See Also:
Constant Field Values

OUTER

public static final int OUTER
See Also:
Constant Field Values

PROPERTIES

public static final int PROPERTIES
See Also:
Constant Field Values

RIGHT

public static final int RIGHT
See Also:
Constant Field Values

SELECT

public static final int SELECT
See Also:
Constant Field Values

SET

public static final int SET
See Also:
Constant Field Values

SOME

public static final int SOME
See Also:
Constant Field Values

SUM

public static final int SUM
See Also:
Constant Field Values

TRUE

public static final int TRUE
See Also:
Constant Field Values

UNION

public static final int UNION
See Also:
Constant Field Values

UPDATE

public static final int UPDATE
See Also:
Constant Field Values

VERSIONED

public static final int VERSIONED
See Also:
Constant Field Values

WHERE

public static final int WHERE
See Also:
Constant Field Values

CASE

public static final int CASE
See Also:
Constant Field Values

END

public static final int END
See Also:
Constant Field Values

ELSE

public static final int ELSE
See Also:
Constant Field Values

THEN

public static final int THEN
See Also:
Constant Field Values

WHEN

public static final int WHEN
See Also:
Constant Field Values

ON

public static final int ON
See Also:
Constant Field Values

WITH

public static final int WITH
See Also:
Constant Field Values

BOTH

public static final int BOTH
See Also:
Constant Field Values

EMPTY

public static final int EMPTY
See Also:
Constant Field Values

LEADING

public static final int LEADING
See Also:
Constant Field Values

MEMBER

public static final int MEMBER
See Also:
Constant Field Values

OBJECT

public static final int OBJECT
See Also:
Constant Field Values

OF

public static final int OF
See Also:
Constant Field Values

TRAILING

public static final int TRAILING
See Also:
Constant Field Values

AGGREGATE

public static final int AGGREGATE
See Also:
Constant Field Values

ALIAS

public static final int ALIAS
See Also:
Constant Field Values

CONSTRUCTOR

public static final int CONSTRUCTOR
See Also:
Constant Field Values

CASE2

public static final int CASE2
See Also:
Constant Field Values

EXPR_LIST

public static final int EXPR_LIST
See Also:
Constant Field Values

FILTER_ENTITY

public static final int FILTER_ENTITY
See Also:
Constant Field Values

IN_LIST

public static final int IN_LIST
See Also:
Constant Field Values

INDEX_OP

public static final int INDEX_OP
See Also:
Constant Field Values

IS_NOT_NULL

public static final int IS_NOT_NULL
See Also:
Constant Field Values

IS_NULL

public static final int IS_NULL
See Also:
Constant Field Values

METHOD_CALL

public static final int METHOD_CALL
See Also:
Constant Field Values

NOT_BETWEEN

public static final int NOT_BETWEEN
See Also:
Constant Field Values

NOT_IN

public static final int NOT_IN
See Also:
Constant Field Values

NOT_LIKE

public static final int NOT_LIKE
See Also:
Constant Field Values

ORDER_ELEMENT

public static final int ORDER_ELEMENT
See Also:
Constant Field Values

QUERY

public static final int QUERY
See Also:
Constant Field Values

RANGE

public static final int RANGE
See Also:
Constant Field Values

ROW_STAR

public static final int ROW_STAR
See Also:
Constant Field Values

SELECT_FROM

public static final int SELECT_FROM
See Also:
Constant Field Values

UNARY_MINUS

public static final int UNARY_MINUS
See Also:
Constant Field Values

UNARY_PLUS

public static final int UNARY_PLUS
See Also:
Constant Field Values

VECTOR_EXPR

public static final int VECTOR_EXPR
See Also:
Constant Field Values

WEIRD_IDENT

public static final int WEIRD_IDENT
See Also:
Constant Field Values

CONSTANT

public static final int CONSTANT
See Also:
Constant Field Values

NUM_DOUBLE

public static final int NUM_DOUBLE
See Also:
Constant Field Values

NUM_FLOAT

public static final int NUM_FLOAT
See Also:
Constant Field Values

NUM_LONG

public static final int NUM_LONG
See Also:
Constant Field Values

JAVA_CONSTANT

public static final int JAVA_CONSTANT
See Also:
Constant Field Values

COMMA

public static final int COMMA
See Also:
Constant Field Values

EQ

public static final int EQ
See Also:
Constant Field Values

OPEN

public static final int OPEN
See Also:
Constant Field Values

CLOSE

public static final int CLOSE
See Also:
Constant Field Values

LITERAL_by

public static final int LITERAL_by
See Also:
Constant Field Values

LITERAL_ascending

public static final int LITERAL_ascending
See Also:
Constant Field Values

LITERAL_descending

public static final int LITERAL_descending
See Also:
Constant Field Values

NE

public static final int NE
See Also:
Constant Field Values

SQL_NE

public static final int SQL_NE
See Also:
Constant Field Values

LT

public static final int LT
See Also:
Constant Field Values

GT

public static final int GT
See Also:
Constant Field Values

LE

public static final int LE
See Also:
Constant Field Values

GE

public static final int GE
See Also:
Constant Field Values

CONCAT

public static final int CONCAT
See Also:
Constant Field Values

PLUS

public static final int PLUS
See Also:
Constant Field Values

MINUS

public static final int MINUS
See Also:
Constant Field Values

STAR

public static final int STAR
See Also:
Constant Field Values

DIV

public static final int DIV
See Also:
Constant Field Values

OPEN_BRACKET

public static final int OPEN_BRACKET
See Also:
Constant Field Values

CLOSE_BRACKET

public static final int CLOSE_BRACKET
See Also:
Constant Field Values

COLON

public static final int COLON
See Also:
Constant Field Values

PARAM

public static final int PARAM
See Also:
Constant Field Values

NUM_INT

public static final int NUM_INT
See Also:
Constant Field Values

QUOTED_STRING

public static final int QUOTED_STRING
See Also:
Constant Field Values

IDENT

public static final int IDENT
See Also:
Constant Field Values

ID_START_LETTER

public static final int ID_START_LETTER
See Also:
Constant Field Values

ID_LETTER

public static final int ID_LETTER
See Also:
Constant Field Values

ESCqs

public static final int ESCqs
See Also:
Constant Field Values

WS

public static final int WS
See Also:
Constant Field Values

HEX_DIGIT

public static final int HEX_DIGIT
See Also:
Constant Field Values

EXPONENT

public static final int EXPONENT
See Also:
Constant Field Values

FLOAT_SUFFIX

public static final int FLOAT_SUFFIX
See Also:
Constant Field Values

FROM_FRAGMENT

public static final int FROM_FRAGMENT
See Also:
Constant Field Values

IMPLIED_FROM

public static final int IMPLIED_FROM
See Also:
Constant Field Values

JOIN_FRAGMENT

public static final int JOIN_FRAGMENT
See Also:
Constant Field Values

SELECT_CLAUSE

public static final int SELECT_CLAUSE
See Also:
Constant Field Values

LEFT_OUTER

public static final int LEFT_OUTER
See Also:
Constant Field Values

RIGHT_OUTER

public static final int RIGHT_OUTER
See Also:
Constant Field Values

ALIAS_REF

public static final int ALIAS_REF
See Also:
Constant Field Values

PROPERTY_REF

public static final int PROPERTY_REF
See Also:
Constant Field Values

SQL_TOKEN

public static final int SQL_TOKEN
See Also:
Constant Field Values

SELECT_COLUMNS

public static final int SELECT_COLUMNS
See Also:
Constant Field Values

SELECT_EXPR

public static final int SELECT_EXPR
See Also:
Constant Field Values

THETA_JOINS

public static final int THETA_JOINS
See Also:
Constant Field Values

FILTERS

public static final int FILTERS
See Also:
Constant Field Values

METHOD_NAME

public static final int METHOD_NAME
See Also:
Constant Field Values

NAMED_PARAM

public static final int NAMED_PARAM
See Also:
Constant Field Values

BOGUS

public static final int BOGUS
See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HqlTokenTypes (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.antlr
Interface HqlTokenTypes

All Known Implementing Classes:
HqlBaseLexer, HqlBaseParser
public interface HqlTokenTypes

Field Summary
static int | AGGREGATE
static int | ALIAS
static int | ALL
static int | AND
static int | ANY
static int | AS
static int | ASCENDING
static int | AVG
static int | BETWEEN
static int | BOTH
static int | CASE
static int | CASE2
static int | CLASS
static int | CLOSE
static int | CLOSE_BRACKET
static int | COLON
static int | COMMA
static int | CONCAT
static int | CONSTANT
static int | CONSTRUCTOR
static int | COUNT
static int | DELETE
static int | DESCENDING
static int | DISTINCT
static int | DIV
static int | DOT
static int | ELEMENTS
static int | ELSE
static int | EMPTY
static int | END
static int | EOF
static int | EQ
static int | ESCAPE
static int | ESCqs
static int | EXISTS
static int | EXPONENT
static int | EXPR_LIST
static int | FALSE
static int | FETCH
static int | FILTER_ENTITY
static int | FLOAT_SUFFIX
static int | FROM
static int | FULL
static int | GE
static int | GROUP
static int | GT
static int | HAVING
static int | HEX_DIGIT
static int | ID_LETTER
static int | ID_START_LETTER
static int | IDENT
static int | IN
static int | IN_LIST
static int | INDEX_OP
static int | INDICES
static int | INNER
static int | INSERT
static int | INTO
static int | IS
static int | IS_NOT_NULL
static int | IS_NULL
static int | JAVA_CONSTANT
static int | JOIN
static int | LE
static int | LEADING
static int | LEFT
static int | LIKE
static int | LITERAL_ascending
static int | LITERAL_by
static int | LITERAL_descending
static int | LT
static int | MAX
static int | MEMBER
static int | METHOD_CALL
static int | MIN
static int | MINUS
static int | NE
static int | NEW
static int | NOT
static int | NOT_BETWEEN
static int | NOT_IN
static int | NOT_LIKE
static int | NULL
static int | NULL_TREE_LOOKAHEAD
static int | NUM_DOUBLE
static int | NUM_FLOAT
static int | NUM_INT
static int | NUM_LONG
static int | OBJECT
static int | OF
static int | ON
static int | OPEN
static int | OPEN_BRACKET
static int | OR
static int | ORDER
static int | ORDER_ELEMENT
static int | OUTER
static int | PARAM
static int | PLUS
static int | PROPERTIES
static int | QUERY
static int | QUOTED_STRING
static int | RANGE
static int | RIGHT
static int | ROW_STAR
static int | SELECT
static int | SELECT_FROM
static int | SET
static int | SOME
static int | SQL_NE
static int | STAR
static int | SUM
static int | THEN
static int | TRAILING
static int | TRUE
static int | UNARY_MINUS
static int | UNARY_PLUS
static int | UNION
static int | UPDATE
static int | VECTOR_EXPR
static int | VERSIONED
static int | WEIRD_IDENT
static int | WHEN
static int | WHERE
static int | WITH
static int | WS

Field Detail

EOF

public static final int EOF
See Also:
Constant Field Values

NULL_TREE_LOOKAHEAD

public static final int NULL_TREE_LOOKAHEAD
See Also:
Constant Field Values

ALL

public static final int ALL
See Also:
Constant Field Values

ANY

public static final int ANY
See Also:
Constant Field Values

AND

public static final int AND
See Also:
Constant Field Values

AS

public static final int AS
See Also:
Constant Field Values

ASCENDING

public static final int ASCENDING
See Also:
Constant Field Values

AVG

public static final int AVG
See Also:
Constant Field Values

BETWEEN

public static final int BETWEEN
See Also:
Constant Field Values

CLASS

public static final int CLASS
See Also:
Constant Field Values

COUNT

public static final int COUNT
See Also:
Constant Field Values

DELETE

public static final int DELETE
See Also:
Constant Field Values

DESCENDING

public static final int DESCENDING
See Also:
Constant Field Values

DOT

public static final int DOT
See Also:
Constant Field Values

DISTINCT

public static final int DISTINCT
See Also:
Constant Field Values

ELEMENTS

public static final int ELEMENTS
See Also:
Constant Field Values

ESCAPE

public static final int ESCAPE
See Also:
Constant Field Values

EXISTS

public static final int EXISTS
See Also:
Constant Field Values

FALSE

public static final int FALSE
See Also:
Constant Field Values

FETCH

public static final int FETCH
See Also:
Constant Field Values

FROM

public static final int FROM
See Also:
Constant Field Values

FULL

public static final int FULL
See Also:
Constant Field Values

GROUP

public static final int GROUP
See Also:
Constant Field Values

HAVING

public static final int HAVING
See Also:
Constant Field Values

IN

public static final int IN
See Also:
Constant Field Values

INDICES

public static final int INDICES
See Also:
Constant Field Values

INNER

public static final int INNER
See Also:
Constant Field Values

INSERT

public static final int INSERT
See Also:
Constant Field Values

INTO

public static final int INTO
See Also:
Constant Field Values

IS

public static final int IS
See Also:
Constant Field Values

JOIN

public static final int JOIN
See Also:
Constant Field Values

LEFT

public static final int LEFT
See Also:
Constant Field Values

LIKE

public static final int LIKE
See Also:
Constant Field Values

MAX

public static final int MAX
See Also:
Constant Field Values

MIN

public static final int MIN
See Also:
Constant Field Values

NEW

public static final int NEW
See Also:
Constant Field Values

NOT

public static final int NOT
See Also:
Constant Field Values

NULL

public static final int NULL
See Also:
Constant Field Values

OR

public static final int OR
See Also:
Constant Field Values

ORDER

public static final int ORDER
See Also:
Constant Field Values

OUTER

public static final int OUTER
See Also:
Constant Field Values

PROPERTIES

public static final int PROPERTIES
See Also:
Constant Field Values

RIGHT

public static final int RIGHT
See Also:
Constant Field Values

SELECT

public static final int SELECT
See Also:
Constant Field Values

SET

public static final int SET
See Also:
Constant Field Values

SOME

public static final int SOME
See Also:
Constant Field Values

SUM

public static final int SUM
See Also:
Constant Field Values

TRUE

public static final int TRUE
See Also:
Constant Field Values

UNION

public static final int UNION
See Also:
Constant Field Values

UPDATE

public static final int UPDATE
See Also:
Constant Field Values

VERSIONED

public static final int VERSIONED
See Also:
Constant Field Values

WHERE

public static final int WHERE
See Also:
Constant Field Values

CASE

public static final int CASE
See Also:
Constant Field Values

END

public static final int END
See Also:
Constant Field Values

ELSE

public static final int ELSE
See Also:
Constant Field Values

THEN

public static final int THEN
See Also:
Constant Field Values

WHEN

public static final int WHEN
See Also:
Constant Field Values

ON

public static final int ON
See Also:
Constant Field Values

WITH

public static final int WITH
See Also:
Constant Field Values

BOTH

public static final int BOTH
See Also:
Constant Field Values

EMPTY

public static final int EMPTY
See Also:
Constant Field Values

LEADING

public static final int LEADING
See Also:
Constant Field Values

MEMBER

public static final int MEMBER
See Also:
Constant Field Values

OBJECT

public static final int OBJECT
See Also:
Constant Field Values

OF

public static final int OF
See Also:
Constant Field Values

TRAILING

public static final int TRAILING
See Also:
Constant Field Values

AGGREGATE

public static final int AGGREGATE
See Also:
Constant Field Values

ALIAS

public static final int ALIAS
See Also:
Constant Field Values

CONSTRUCTOR

public static final int CONSTRUCTOR
See Also:
Constant Field Values

CASE2

public static final int CASE2
See Also:
Constant Field Values

EXPR_LIST

public static final int EXPR_LIST
See Also:
Constant Field Values

FILTER_ENTITY

public static final int FILTER_ENTITY
See Also:
Constant Field Values

IN_LIST

public static final int IN_LIST
See Also:
Constant Field Values

INDEX_OP

public static final int INDEX_OP
See Also:
Constant Field Values

IS_NOT_NULL

public static final int IS_NOT_NULL
See Also:
Constant Field Values

IS_NULL

public static final int IS_NULL
See Also:
Constant Field Values

METHOD_CALL

public static final int METHOD_CALL
See Also:
Constant Field Values

NOT_BETWEEN

public static final int NOT_BETWEEN
See Also:
Constant Field Values

NOT_IN

public static final int NOT_IN
See Also:
Constant Field Values

NOT_LIKE

public static final int NOT_LIKE
See Also:
Constant Field Values

ORDER_ELEMENT

public static final int ORDER_ELEMENT
See Also:
Constant Field Values

QUERY

public static final int QUERY
See Also:
Constant Field Values

RANGE

public static final int RANGE
See Also:
Constant Field Values

ROW_STAR

public static final int ROW_STAR
See Also:
Constant Field Values

SELECT_FROM

public static final int SELECT_FROM
See Also:
Constant Field Values

UNARY_MINUS

public static final int UNARY_MINUS
See Also:
Constant Field Values

UNARY_PLUS

public static final int UNARY_PLUS
See Also:
Constant Field Values

VECTOR_EXPR

public static final int VECTOR_EXPR
See Also:
Constant Field Values

WEIRD_IDENT

public static final int WEIRD_IDENT
See Also:
Constant Field Values

CONSTANT

public static final int CONSTANT
See Also:
Constant Field Values

NUM_DOUBLE

public static final int NUM_DOUBLE
See Also:
Constant Field Values

NUM_FLOAT

public static final int NUM_FLOAT
See Also:
Constant Field Values

NUM_LONG

public static final int NUM_LONG
See Also:
Constant Field Values

JAVA_CONSTANT

public static final int JAVA_CONSTANT
See Also:
Constant Field Values

COMMA

public static final int COMMA
See Also:
Constant Field Values

EQ

public static final int EQ
See Also:
Constant Field Values

OPEN

public static final int OPEN
See Also:
Constant Field Values

CLOSE

public static final int CLOSE
See Also:
Constant Field Values

LITERAL_by

public static final int LITERAL_by
See Also:
Constant Field Values

LITERAL_ascending

public static final int LITERAL_ascending
See Also:
Constant Field Values

LITERAL_descending

public static final int LITERAL_descending
See Also:
Constant Field Values

NE

public static final int NE
See Also:
Constant Field Values

SQL_NE

public static final int SQL_NE
See Also:
Constant Field Values

LT

public static final int LT
See Also:
Constant Field Values

GT

public static final int GT
See Also:
Constant Field Values

LE

public static final int LE
See Also:
Constant Field Values

GE

public static final int GE
See Also:
Constant Field Values

CONCAT

public static final int CONCAT
See Also:
Constant Field Values

PLUS

public static final int PLUS
See Also:
Constant Field Values

MINUS

public static final int MINUS
See Also:
Constant Field Values

STAR

public static final int STAR
See Also:
Constant Field Values

DIV

public static final int DIV
See Also:
Constant Field Values

OPEN_BRACKET

public static final int OPEN_BRACKET
See Also:
Constant Field Values

CLOSE_BRACKET

public static final int CLOSE_BRACKET
See Also:
Constant Field Values

COLON

public static final int COLON
See Also:
Constant Field Values

PARAM

public static final int PARAM
See Also:
Constant Field Values

NUM_INT

public static final int NUM_INT
See Also:
Constant Field Values

QUOTED_STRING

public static final int QUOTED_STRING
See Also:
Constant Field Values

IDENT

public static final int IDENT
See Also:
Constant Field Values

ID_START_LETTER

public static final int ID_START_LETTER
See Also:
Constant Field Values

ID_LETTER

public static final int ID_LETTER
See Also:
Constant Field Values

ESCqs

public static final int ESCqs
See Also:
Constant Field Values

WS

public static final int WS
See Also:
Constant Field Values

HEX_DIGIT

public static final int HEX_DIGIT
See Also:
Constant Field Values

EXPONENT

public static final int EXPONENT
See Also:
Constant Field Values

FLOAT_SUFFIX

public static final int FLOAT_SUFFIX
See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SqlTokenTypes (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.antlr
Interface SqlTokenTypes

All Known Implementing Classes:
JoinProcessor, SqlGeneratorBase
public interface SqlTokenTypes

Field Summary
static int | AGGREGATE
static int | ALIAS
static int | ALIAS_REF
static int | ALL
static int | AND
static int | ANY
static int | AS
static int | ASCENDING
static int | AVG
static int | BETWEEN
static int | BOGUS
static int | BOTH
static int | CASE
static int | CASE2
static int | CLASS
static int | CLOSE
static int | CLOSE_BRACKET
static int | COLON
static int | COMMA
static int | CONCAT
static int | CONSTANT
static int | CONSTRUCTOR
static int | COUNT
static int | DELETE
static int | DESCENDING
static int | DISTINCT
static int | DIV
static int | DOT
static int | ELEMENTS
static int | ELSE
static int | EMPTY
static int | END
static int | EOF
static int | EQ
static int | ESCAPE
static int | ESCqs
static int | EXISTS
static int | EXPONENT
static int | EXPR_LIST
static int | FALSE
static int | FETCH
static int | FILTER_ENTITY
static int | FILTERS
static int | FLOAT_SUFFIX
static int | FROM
static int | FROM_FRAGMENT
static int | FULL
static int | GE
static int | GROUP
static int | GT
static int | HAVING
static int | HEX_DIGIT
static int | ID_LETTER
static int | ID_START_LETTER
static int | IDENT
static int | IMPLIED_FROM
static int | IN
static int | IN_LIST
static int | INDEX_OP
static int | INDICES
static int | INNER
static int | INSERT
static int | INTO
static int | IS
static int | IS_NOT_NULL
static int | IS_NULL
static int | JAVA_CONSTANT
static int | JOIN
static int | JOIN_FRAGMENT
static int | LE
static int | LEADING
static int | LEFT
static int | LEFT_OUTER
static int | LIKE
static int | LITERAL_ascending
static int | LITERAL_by
static int | LITERAL_descending
static int | LT
static int | MAX
static int | MEMBER
static int | METHOD_CALL
static int | METHOD_NAME
static int | MIN
static int | MINUS
static int | NAMED_PARAM
static int | NE
static int | NEW
static int | NOT
static int | NOT_BETWEEN
static int | NOT_IN
static int | NOT_LIKE
static int | NULL
static int | NULL_TREE_LOOKAHEAD
static int | NUM_DOUBLE
static int | NUM_FLOAT
static int | NUM_INT
static int | NUM_LONG
static int | OBJECT
static int | OF
static int | ON
static int | OPEN
static int | OPEN_BRACKET
static int | OR
static int | ORDER
static int | ORDER_ELEMENT
static int | OUTER
static int | PARAM
static int | PLUS
static int | PROPERTIES
static int | PROPERTY_REF
static int | QUERY
static int | QUOTED_STRING
static int | RANGE
static int | RIGHT
static int | RIGHT_OUTER
static int | ROW_STAR
static int | SELECT
static int | SELECT_CLAUSE
static int | SELECT_COLUMNS
static int | SELECT_EXPR
static int | SELECT_FROM
static int | SET
static int | SOME
static int | SQL_NE
static int | SQL_NODE
static int | SQL_TOKEN
static int | STAR
static int | SUM
static int | THEN
static int | THETA_JOINS
static int | TRAILING
static int | TRUE
static int | UNARY_MINUS
static int | UNARY_PLUS
static int | UNION
static int | UPDATE
static int | VECTOR_EXPR
static int | VERSIONED
static int | WEIRD_IDENT
static int | WHEN
static int | WHERE
static int | WITH
static int | WS

Field Detail

EOF

public static final int EOF
See Also:
Constant Field Values

NULL_TREE_LOOKAHEAD

public static final int NULL_TREE_LOOKAHEAD
See Also:
Constant Field Values

ALL

public static final int ALL
See Also:
Constant Field Values

ANY

public static final int ANY
See Also:
Constant Field Values

AND

public static final int AND
See Also:
Constant Field Values

AS

public static final int AS
See Also:
Constant Field Values

ASCENDING

public static final int ASCENDING
See Also:
Constant Field Values

AVG

public static final int AVG
See Also:
Constant Field Values

BETWEEN

public static final int BETWEEN
See Also:
Constant Field Values

CLASS

public static final int CLASS
See Also:
Constant Field Values

COUNT

public static final int COUNT
See Also:
Constant Field Values

DELETE

public static final int DELETE
See Also:
Constant Field Values

DESCENDING

public static final int DESCENDING
See Also:
Constant Field Values

DOT

public static final int DOT
See Also:
Constant Field Values

DISTINCT

public static final int DISTINCT
See Also:
Constant Field Values

ELEMENTS

public static final int ELEMENTS
See Also:
Constant Field Values

ESCAPE

public static final int ESCAPE
See Also:
Constant Field Values

EXISTS

public static final int EXISTS
See Also:
Constant Field Values

FALSE

public static final int FALSE
See Also:
Constant Field Values

FETCH

public static final int FETCH
See Also:
Constant Field Values

FROM

public static final int FROM
See Also:
Constant Field Values

FULL

public static final int FULL
See Also:
Constant Field Values

GROUP

public static final int GROUP
See Also:
Constant Field Values

HAVING

public static final int HAVING
See Also:
Constant Field Values

IN

public static final int IN
See Also:
Constant Field Values

INDICES

public static final int INDICES
See Also:
Constant Field Values

INNER

public static final int INNER
See Also:
Constant Field Values

INSERT

public static final int INSERT
See Also:
Constant Field Values

INTO

public static final int INTO
See Also:
Constant Field Values

IS

public static final int IS
See Also:
Constant Field Values

JOIN

public static final int JOIN
See Also:
Constant Field Values

LEFT

public static final int LEFT
See Also:
Constant Field Values

LIKE

public static final int LIKE
See Also:
Constant Field Values

MAX

public static final int MAX
See Also:
Constant Field Values

MIN

public static final int MIN
See Also:
Constant Field Values

NEW

public static final int NEW
See Also:
Constant Field Values

NOT

public static final int NOT
See Also:
Constant Field Values

NULL

public static final int NULL
See Also:
Constant Field Values

OR

public static final int OR
See Also:
Constant Field Values

ORDER

public static final int ORDER
See Also:
Constant Field Values

OUTER

public static final int OUTER
See Also:
Constant Field Values

PROPERTIES

public static final int PROPERTIES
See Also:
Constant Field Values

RIGHT

public static final int RIGHT
See Also:
Constant Field Values

SELECT

public static final int SELECT
See Also:
Constant Field Values

SET

public static final int SET
See Also:
Constant Field Values

SOME

public static final int SOME
See Also:
Constant Field Values

SUM

public static final int SUM
See Also:
Constant Field Values

TRUE

public static final int TRUE
See Also:
Constant Field Values

UNION

public static final int UNION
See Also:
Constant Field Values

UPDATE

public static final int UPDATE
See Also:
Constant Field Values

VERSIONED

public static final int VERSIONED
See Also:
Constant Field Values

WHERE

public static final int WHERE
See Also:
Constant Field Values

CASE

public static final int CASE
See Also:
Constant Field Values

END

public static final int END
See Also:
Constant Field Values

ELSE

public static final int ELSE
See Also:
Constant Field Values

THEN

public static final int THEN
See Also:
Constant Field Values

WHEN

public static final int WHEN
See Also:
Constant Field Values

ON

public static final int ON
See Also:
Constant Field Values

WITH

public static final int WITH
See Also:
Constant Field Values

BOTH

public static final int BOTH
See Also:
Constant Field Values

EMPTY

public static final int EMPTY
See Also:
Constant Field Values

LEADING

public static final int LEADING
See Also:
Constant Field Values

MEMBER

public static final int MEMBER
See Also:
Constant Field Values

OBJECT

public static final int OBJECT
See Also:
Constant Field Values

OF

public static final int OF
See Also:
Constant Field Values

TRAILING

public static final int TRAILING
See Also:
Constant Field Values

AGGREGATE

public static final int AGGREGATE
See Also:
Constant Field Values

ALIAS

public static final int ALIAS
See Also:
Constant Field Values

CONSTRUCTOR

public static final int CONSTRUCTOR
See Also:
Constant Field Values

CASE2

public static final int CASE2
See Also:
Constant Field Values

EXPR_LIST

public static final int EXPR_LIST
See Also:
Constant Field Values

FILTER_ENTITY

public static final int FILTER_ENTITY
See Also:
Constant Field Values

IN_LIST

public static final int IN_LIST
See Also:
Constant Field Values

INDEX_OP

public static final int INDEX_OP
See Also:
Constant Field Values

IS_NOT_NULL

public static final int IS_NOT_NULL
See Also:
Constant Field Values

IS_NULL

public static final int IS_NULL
See Also:
Constant Field Values

METHOD_CALL

public static final int METHOD_CALL
See Also:
Constant Field Values

NOT_BETWEEN

public static final int NOT_BETWEEN
See Also:
Constant Field Values

NOT_IN

public static final int NOT_IN
See Also:
Constant Field Values

NOT_LIKE

public static final int NOT_LIKE
See Also:
Constant Field Values

ORDER_ELEMENT

public static final int ORDER_ELEMENT
See Also:
Constant Field Values

QUERY

public static final int QUERY
See Also:
Constant Field Values

RANGE

public static final int RANGE
See Also:
Constant Field Values

ROW_STAR

public static final int ROW_STAR
See Also:
Constant Field Values

SELECT_FROM

public static final int SELECT_FROM
See Also:
Constant Field Values

UNARY_MINUS

public static final int UNARY_MINUS
See Also:
Constant Field Values

UNARY_PLUS

public static final int UNARY_PLUS
See Also:
Constant Field Values

VECTOR_EXPR

public static final int VECTOR_EXPR
See Also:
Constant Field Values

WEIRD_IDENT

public static final int WEIRD_IDENT
See Also:
Constant Field Values

CONSTANT

public static final int CONSTANT
See Also:
Constant Field Values

NUM_DOUBLE

public static final int NUM_DOUBLE
See Also:
Constant Field Values

NUM_FLOAT

public static final int NUM_FLOAT
See Also:
Constant Field Values

NUM_LONG

public static final int NUM_LONG
See Also:
Constant Field Values

JAVA_CONSTANT

public static final int JAVA_CONSTANT
See Also:
Constant Field Values

COMMA

public static final int COMMA
See Also:
Constant Field Values

EQ

public static final int EQ
See Also:
Constant Field Values

OPEN

public static final int OPEN
See Also:
Constant Field Values

CLOSE

public static final int CLOSE
See Also:
Constant Field Values

LITERAL_by

public static final int LITERAL_by
See Also:
Constant Field Values

LITERAL_ascending

public static final int LITERAL_ascending
See Also:
Constant Field Values

LITERAL_descending

public static final int LITERAL_descending
See Also:
Constant Field Values

NE

public static final int NE
See Also:
Constant Field Values

SQL_NE

public static final int SQL_NE
See Also:
Constant Field Values

LT

public static final int LT
See Also:
Constant Field Values

GT

public static final int GT
See Also:
Constant Field Values

LE

public static final int LE
See Also:
Constant Field Values

GE

public static final int GE
See Also:
Constant Field Values

CONCAT

public static final int CONCAT
See Also:
Constant Field Values

PLUS

public static final int PLUS
See Also:
Constant Field Values

MINUS

public static final int MINUS
See Also:
Constant Field Values

STAR

public static final int STAR
See Also:
Constant Field Values

DIV

public static final int DIV
See Also:
Constant Field Values

OPEN_BRACKET

public static final int OPEN_BRACKET
See Also:
Constant Field Values

CLOSE_BRACKET

public static final int CLOSE_BRACKET
See Also:
Constant Field Values

COLON

public static final int COLON
See Also:
Constant Field Values

PARAM

public static final int PARAM
See Also:
Constant Field Values

NUM_INT

public static final int NUM_INT
See Also:
Constant Field Values

QUOTED_STRING

public static final int QUOTED_STRING
See Also:
Constant Field Values

IDENT

public static final int IDENT
See Also:
Constant Field Values

ID_START_LETTER

public static final int ID_START_LETTER
See Also:
Constant Field Values

ID_LETTER

public static final int ID_LETTER
See Also:
Constant Field Values

ESCqs

public static final int ESCqs
See Also:
Constant Field Values

WS

public static final int WS
See Also:
Constant Field Values

HEX_DIGIT

public static final int HEX_DIGIT
See Also:
Constant Field Values

EXPONENT

public static final int EXPONENT
See Also:
Constant Field Values

FLOAT_SUFFIX

public static final int FLOAT_SUFFIX
See Also:
Constant Field Values

FROM_FRAGMENT

public static final int FROM_FRAGMENT
See Also:
Constant Field Values

IMPLIED_FROM

public static final int IMPLIED_FROM
See Also:
Constant Field Values

JOIN_FRAGMENT

public static final int JOIN_FRAGMENT
See Also:
Constant Field Values

SELECT_CLAUSE

public static final int SELECT_CLAUSE
See Also:
Constant Field Values

LEFT_OUTER

public static final int LEFT_OUTER
See Also:
Constant Field Values

RIGHT_OUTER

public static final int RIGHT_OUTER
See Also:
Constant Field Values

ALIAS_REF

public static final int ALIAS_REF
See Also:
Constant Field Values

PROPERTY_REF

public static final int PROPERTY_REF
See Also:
Constant Field Values

SQL_TOKEN

public static final int SQL_TOKEN
See Also:
Constant Field Values

SELECT_COLUMNS

public static final int SELECT_COLUMNS
See Also:
Constant Field Values

SELECT_EXPR

public static final int SELECT_EXPR
See Also:
Constant Field Values

THETA_JOINS

public static final int THETA_JOINS
See Also:
Constant Field Values

FILTERS

public static final int FILTERS
See Also:
Constant Field Values

METHOD_NAME

public static final int METHOD_NAME
See Also:
Constant Field Values

NAMED_PARAM

public static final int NAMED_PARAM
See Also:
Constant Field Values

BOGUS

public static final int BOGUS
See Also:
Constant Field Values

SQL_NODE

public static final int SQL_NODE
See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HqlBaseLexer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.antlr
Class HqlBaseLexer

java.lang.Object
    extended by antlr.CharScanner
        extended by org.hibernate.hql.antlr.HqlBaseLexer
All Implemented Interfaces:
HqlTokenTypes, antlr.TokenStream
public class HqlBaseLexer
extends antlr.CharScanner
implements HqlTokenTypes, antlr.TokenStream

Hibernate Query Language Lexer
This lexer provides the HQL parser with tokens.

Author:
Joshua Davis (pgmjsd@sourceforge.net)

Field Summary
static antlr.collections.impl.BitSet | _tokenSet_0
static antlr.collections.impl.BitSet | _tokenSet_1
static antlr.collections.impl.BitSet | _tokenSet_2
static antlr.collections.impl.BitSet | _tokenSet_3
static antlr.collections.impl.BitSet | _tokenSet_4
Fields inherited from class antlr.CharScanner
_returnToken, caseSensitive, caseSensitiveLiterals, commitToPath, EOF_CHAR, hashString, inputState, literals, saveConsumedInput, tabsize, text, tokenObjectClass, traceDepth
Fields inherited from interface org.hibernate.hql.antlr.HqlTokenTypes
AGGREGATE, ALIAS, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FLOAT_SUFFIX, FROM, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, LE, LEADING, LEFT, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, MIN, MINUS, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, QUERY, QUOTED_STRING, RANGE, RIGHT, ROW_STAR, SELECT, SELECT_FROM, SET, SOME, SQL_NE, STAR, SUM, THEN, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
HqlBaseLexer(antlr.InputBuffer ib)
HqlBaseLexer(InputStream in)
HqlBaseLexer(antlr.LexerSharedInputState state)
HqlBaseLexer(Reader in)
Method Summary
void | mCLOSE_BRACKET(boolean _createToken)
void | mCLOSE(boolean _createToken)
void | mCOLON(boolean _createToken)
void | mCOMMA(boolean _createToken)
void | mCONCAT(boolean _createToken)
void | mDIV(boolean _createToken)
void | mEQ(boolean _createToken)
protected void | mESCqs(boolean _createToken)
protected void | mEXPONENT(boolean _createToken)
protected void | mFLOAT_SUFFIX(boolean _createToken)
void | mGE(boolean _createToken)
void | mGT(boolean _createToken)
protected void | mHEX_DIGIT(boolean _createToken)
protected void | mID_LETTER(boolean _createToken)
protected void | mID_START_LETTER(boolean _createToken)
void | mIDENT(boolean _createToken)
void | mLE(boolean _createToken)
void | mLT(boolean _createToken)
void | mMINUS(boolean _createToken)
void | mNE(boolean _createToken)
void | mNUM_INT(boolean _createToken)
void | mOPEN_BRACKET(boolean _createToken)
void | mOPEN(boolean _createToken)
void | mPARAM(boolean _createToken)
void | mPLUS(boolean _createToken)
void | mQUOTED_STRING(boolean _createToken)
void | mSQL_NE(boolean _createToken)
void | mSTAR(boolean _createToken)
void | mWS(boolean _createToken)
antlr.Token | nextToken()
protected void | setPossibleID(boolean possibleID)
Methods inherited from class antlr.CharScanner
append, append, commit, consume, consumeUntil, consumeUntil, getCaseSensitive, getCaseSensitiveLiterals, getColumn, getCommitToPath, getFilename, getInputBuffer, getInputState, getLine, getTabSize, getText, getTokenObject, LA, makeToken, mark, match, match, match, matchNot, matchRange, newline, panic, panic, reportError, reportError, reportWarning, resetText, rewind, setCaseSensitive, setColumn, setCommitToPath, setFilename, setInputState, setLine, setTabSize, setText, setTokenObjectClass, tab, testLiteralsTable, testLiteralsTable, toLower, traceIn, traceIndent, traceOut, uponEOF
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_tokenSet_0

public static final antlr.collections.impl.BitSet _tokenSet_0

_tokenSet_1

public static final antlr.collections.impl.BitSet _tokenSet_1

_tokenSet_2

public static final antlr.collections.impl.BitSet _tokenSet_2

_tokenSet_3

public static final antlr.collections.impl.BitSet _tokenSet_3

_tokenSet_4

public static final antlr.collections.impl.BitSet _tokenSet_4
Constructor Detail

HqlBaseLexer

public HqlBaseLexer(InputStream in)

HqlBaseLexer

public HqlBaseLexer(Reader in)

HqlBaseLexer

public HqlBaseLexer(antlr.InputBuffer ib)

HqlBaseLexer

public HqlBaseLexer(antlr.LexerSharedInputState state)
Method Detail

setPossibleID

protected void setPossibleID(boolean possibleID)

nextToken

public antlr.Token nextToken()
                      throws antlr.TokenStreamException
Specified by:
nextToken in interface antlr.TokenStream
Throws:
antlr.TokenStreamException

mEQ

public final void mEQ(boolean _createToken)
               throws antlr.RecognitionException,
                      antlr.CharStreamException,
                      antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mLT

public final void mLT(boolean _createToken)
               throws antlr.RecognitionException,
                      antlr.CharStreamException,
                      antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mGT

public final void mGT(boolean _createToken)
               throws antlr.RecognitionException,
                      antlr.CharStreamException,
                      antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mSQL_NE

public final void mSQL_NE(boolean _createToken)
                   throws antlr.RecognitionException,
                          antlr.CharStreamException,
                          antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mNE

public final void mNE(boolean _createToken)
               throws antlr.RecognitionException,
                      antlr.CharStreamException,
                      antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mLE

public final void mLE(boolean _createToken)
               throws antlr.RecognitionException,
                      antlr.CharStreamException,
                      antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mGE

public final void mGE(boolean _createToken)
               throws antlr.RecognitionException,
                      antlr.CharStreamException,
                      antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mCOMMA

public final void mCOMMA(boolean _createToken)
                  throws antlr.RecognitionException,
                         antlr.CharStreamException,
                         antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mOPEN

public final void mOPEN(boolean _createToken)
                 throws antlr.RecognitionException,
                        antlr.CharStreamException,
                        antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mCLOSE

public final void mCLOSE(boolean _createToken)
                  throws antlr.RecognitionException,
                         antlr.CharStreamException,
                         antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mOPEN_BRACKET

public final void mOPEN_BRACKET(boolean _createToken)
                         throws antlr.RecognitionException,
                                antlr.CharStreamException,
                                antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mCLOSE_BRACKET

public final void mCLOSE_BRACKET(boolean _createToken)
                          throws antlr.RecognitionException,
                                 antlr.CharStreamException,
                                 antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mCONCAT

public final void mCONCAT(boolean _createToken)
                   throws antlr.RecognitionException,
                          antlr.CharStreamException,
                          antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mPLUS

public final void mPLUS(boolean _createToken)
                 throws antlr.RecognitionException,
                        antlr.CharStreamException,
                        antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mMINUS

public final void mMINUS(boolean _createToken)
                  throws antlr.RecognitionException,
                         antlr.CharStreamException,
                         antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mSTAR

public final void mSTAR(boolean _createToken)
                 throws antlr.RecognitionException,
                        antlr.CharStreamException,
                        antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mDIV

public final void mDIV(boolean _createToken)
                throws antlr.RecognitionException,
                       antlr.CharStreamException,
                       antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mCOLON

public final void mCOLON(boolean _createToken)
                  throws antlr.RecognitionException,
                         antlr.CharStreamException,
                         antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mPARAM

public final void mPARAM(boolean _createToken)
                  throws antlr.RecognitionException,
                         antlr.CharStreamException,
                         antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mIDENT

public final void mIDENT(boolean _createToken)
                  throws antlr.RecognitionException,
                         antlr.CharStreamException,
                         antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mID_START_LETTER

protected final void mID_START_LETTER(boolean _createToken)
                               throws antlr.RecognitionException,
                                      antlr.CharStreamException,
                                      antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mID_LETTER

protected final void mID_LETTER(boolean _createToken)
                         throws antlr.RecognitionException,
                                antlr.CharStreamException,
                                antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mQUOTED_STRING

public final void mQUOTED_STRING(boolean _createToken)
                          throws antlr.RecognitionException,
                                 antlr.CharStreamException,
                                 antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mESCqs

protected final void mESCqs(boolean _createToken)
                     throws antlr.RecognitionException,
                            antlr.CharStreamException,
                            antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mWS

public final void mWS(boolean _createToken)
               throws antlr.RecognitionException,
                      antlr.CharStreamException,
                      antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mNUM_INT

public final void mNUM_INT(boolean _createToken)
                    throws antlr.RecognitionException,
                           antlr.CharStreamException,
                           antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mEXPONENT

protected final void mEXPONENT(boolean _createToken)
                        throws antlr.RecognitionException,
                               antlr.CharStreamException,
                               antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mFLOAT_SUFFIX

protected final void mFLOAT_SUFFIX(boolean _createToken)
                            throws antlr.RecognitionException,
                                   antlr.CharStreamException,
                                   antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException

mHEX_DIGIT

protected final void mHEX_DIGIT(boolean _createToken)
                         throws antlr.RecognitionException,
                                antlr.CharStreamException,
                                antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.CharStreamException
antlr.TokenStreamException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HqlBaseParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.antlr
Class HqlBaseParser

java.lang.Object
    extended by antlr.Parser
        extended by antlr.LLkParser
            extended by org.hibernate.hql.antlr.HqlBaseParser
All Implemented Interfaces:
HqlTokenTypes
Direct Known Subclasses:
HqlParser
public class HqlBaseParser
extends antlr.LLkParser
implements HqlTokenTypes

Hibernate Query Language Grammar
This grammar parses the query language for Hibernate (an Open Source, Object-Relational mapping library). A partial BNF grammar description is available for reference here: http://www.hibernate.org/Documentation/HQLBNF Text from the original reference BNF is prefixed with '//##'.

Author:
Joshua Davis (pgmjsd@sourceforge.net)

Field Summary
static String[] | _tokenNames
static antlr.collections.impl.BitSet | _tokenSet_0
static antlr.collections.impl.BitSet | _tokenSet_1
static antlr.collections.impl.BitSet | _tokenSet_10
static antlr.collections.impl.BitSet | _tokenSet_11
static antlr.collections.impl.BitSet | _tokenSet_12
static antlr.collections.impl.BitSet | _tokenSet_13
static antlr.collections.impl.BitSet | _tokenSet_14
static antlr.collections.impl.BitSet | _tokenSet_15
static antlr.collections.impl.BitSet | _tokenSet_16
static antlr.collections.impl.BitSet | _tokenSet_17
static antlr.collections.impl.BitSet | _tokenSet_18
static antlr.collections.impl.BitSet | _tokenSet_19
static antlr.collections.impl.BitSet | _tokenSet_2
static antlr.collections.impl.BitSet | _tokenSet_20
static antlr.collections.impl.BitSet | _tokenSet_21
static antlr.collections.impl.BitSet | _tokenSet_22
static antlr.collections.impl.BitSet | _tokenSet_23
static antlr.collections.impl.BitSet | _tokenSet_24
static antlr.collections.impl.BitSet | _tokenSet_25
static antlr.collections.impl.BitSet | _tokenSet_26
static antlr.collections.impl.BitSet | _tokenSet_27
static antlr.collections.impl.BitSet | _tokenSet_28
static antlr.collections.impl.BitSet | _tokenSet_29
static antlr.collections.impl.BitSet | _tokenSet_3
static antlr.collections.impl.BitSet | _tokenSet_30
static antlr.collections.impl.BitSet | _tokenSet_31
static antlr.collections.impl.BitSet | _tokenSet_32
static antlr.collections.impl.BitSet | _tokenSet_33
static antlr.collections.impl.BitSet | _tokenSet_34
static antlr.collections.impl.BitSet | _tokenSet_35
static antlr.collections.impl.BitSet | _tokenSet_4
static antlr.collections.impl.BitSet | _tokenSet_5
static antlr.collections.impl.BitSet | _tokenSet_6
static antlr.collections.impl.BitSet | _tokenSet_7
static antlr.collections.impl.BitSet | _tokenSet_8
static antlr.collections.impl.BitSet | _tokenSet_9
Fields inherited from class antlr.Parser
astFactory, inputState, returnAST, tokenNames, tokenTypeToASTClassMap, traceDepth
Fields inherited from interface org.hibernate.hql.antlr.HqlTokenTypes
AGGREGATE, ALIAS, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FLOAT_SUFFIX, FROM, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, LE, LEADING, LEFT, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, MIN, MINUS, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, QUERY, QUOTED_STRING, RANGE, RIGHT, ROW_STAR, SELECT, SELECT_FROM, SET, SOME, SQL_NE, STAR, SUM, THEN, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
 | HqlBaseParser(antlr.ParserSharedInputState state)
 | HqlBaseParser(antlr.TokenBuffer tokenBuf)
protected | HqlBaseParser(antlr.TokenBuffer tokenBuf, int k)
 | HqlBaseParser(antlr.TokenStream lexer)
protected | HqlBaseParser(antlr.TokenStream lexer, int k)
Method Summary
void | additiveExpression()
void | aggregate()
void | alias()
void | aliasedExpression()
void | altWhenClause()
void | asAlias()
void | ascendingOrDescending()
void | assignment()
void | atom()
void | betweenList()
protected void | buildTokenTypeASTClassMap()
void | caseExpression()
void | collectionExpr()
void | compoundExpr()
void | concatenation()
void | constant()
void | deleteStatement()
void | elseClause()
void | equalityExpression()
void | expression()
void | expressionOrVector()
void | exprList()
void | fromClassOrOuterQueryPath()
void | fromClause()
void | fromJoin()
void | fromRange()
void | groupByClause()
void | handleDotIdent() This method looks ahead and converts .
antlr.collections.AST | handleIdentifierError(antlr.Token token, antlr.RecognitionException ex) This method is overriden in the sub class in order to provide the 'keyword as identifier' hack.
void | havingClause()
void | identifier()
void | identPrimary()
void | inClassDeclaration()
void | inCollectionDeclaration()
void | inCollectionElementsDeclaration()
void | inList()
void | insertablePropertySpec()
void | insertStatement()
void | intoClause()
boolean | isFilter() Returns true if this is a filter query, false if not.
void | likeEscape()
void | logicalAndExpression()
void | logicalExpression()
void | logicalOrExpression()
void | multiplyExpression()
void | negatedExpression()
antlr.collections.AST | negateNode(antlr.collections.AST x) Returns the negated equivalent of the expression.
void | newExpression()
void | newValue()
void | optionalFromTokenFromClause()
void | orderByClause()
void | orderElement()
void | path()
void | primaryExpression()
antlr.collections.AST | processEqualityExpression(antlr.collections.AST x) Returns the 'cleaned up' version of a comparison operator sub-tree.
void | processMemberOf(antlr.Token n, antlr.collections.AST p, antlr.ASTPair currentAST)
void | propertyFetch()
void | quantifiedExpression()
void | queryRule()
void | relationalExpression()
void | selectClause()
void | selectedPropertiesList()
void | selectFrom()
void | selectObject()
void | selectStatement()
void | setClause()
void | setFilter(boolean f) Sets the filter flag.
void | stateField()
void | statement()
void | subQuery()
void | unaryExpression()
void | union()
void | updateStatement()
void | vectorExpr()
void | weakKeywords()
void | whenClause()
void | whereClause()
void | withClause()
Methods inherited from class antlr.LLkParser
consume, LA, LT, traceIn, traceOut
Methods inherited from class antlr.Parser
addMessageListener, addParserListener, addParserMatchListener, addParserTokenListener, addSemanticPredicateListener, addSyntacticPredicateListener, addTraceListener, consumeUntil, consumeUntil, defaultDebuggingSetup, getAST, getASTFactory, getFilename, getInputState, getTokenName, getTokenNames, getTokenTypeToASTClassMap, isDebugMode, mark, match, match, matchNot, panic, recover, removeMessageListener, removeParserListener, removeParserMatchListener, removeParserTokenListener, removeSemanticPredicateListener, removeSyntacticPredicateListener, removeTraceListener, reportError, reportError, reportWarning, rewind, setASTFactory, setASTNodeClass, setASTNodeType, setDebugMode, setFilename, setIgnoreInvalidDebugCalls, setInputState, setTokenBuffer, traceIndent
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_tokenNames

public static final String[] _tokenNames

_tokenSet_0

public static final antlr.collections.impl.BitSet _tokenSet_0

_tokenSet_1

public static final antlr.collections.impl.BitSet _tokenSet_1

_tokenSet_2

public static final antlr.collections.impl.BitSet _tokenSet_2

_tokenSet_3

public static final antlr.collections.impl.BitSet _tokenSet_3

_tokenSet_4

public static final antlr.collections.impl.BitSet _tokenSet_4

_tokenSet_5

public static final antlr.collections.impl.BitSet _tokenSet_5

_tokenSet_6

public static final antlr.collections.impl.BitSet _tokenSet_6

_tokenSet_7

public static final antlr.collections.impl.BitSet _tokenSet_7

_tokenSet_8

public static final antlr.collections.impl.BitSet _tokenSet_8

_tokenSet_9

public static final antlr.collections.impl.BitSet _tokenSet_9

_tokenSet_10

public static final antlr.collections.impl.BitSet _tokenSet_10

_tokenSet_11

public static final antlr.collections.impl.BitSet _tokenSet_11

_tokenSet_12

public static final antlr.collections.impl.BitSet _tokenSet_12

_tokenSet_13

public static final antlr.collections.impl.BitSet _tokenSet_13

_tokenSet_14

public static final antlr.collections.impl.BitSet _tokenSet_14

_tokenSet_15

public static final antlr.collections.impl.BitSet _tokenSet_15

_tokenSet_16

public static final antlr.collections.impl.BitSet _tokenSet_16

_tokenSet_17

public static final antlr.collections.impl.BitSet _tokenSet_17

_tokenSet_18

public static final antlr.collections.impl.BitSet _tokenSet_18

_tokenSet_19

public static final antlr.collections.impl.BitSet _tokenSet_19

_tokenSet_20

public static final antlr.collections.impl.BitSet _tokenSet_20

_tokenSet_21

public static final antlr.collections.impl.BitSet _tokenSet_21

_tokenSet_22

public static final antlr.collections.impl.BitSet _tokenSet_22

_tokenSet_23

public static final antlr.collections.impl.BitSet _tokenSet_23

_tokenSet_24

public static final antlr.collections.impl.BitSet _tokenSet_24

_tokenSet_25

public static final antlr.collections.impl.BitSet _tokenSet_25

_tokenSet_26

public static final antlr.collections.impl.BitSet _tokenSet_26

_tokenSet_27

public static final antlr.collections.impl.BitSet _tokenSet_27

_tokenSet_28

public static final antlr.collections.impl.BitSet _tokenSet_28

_tokenSet_29

public static final antlr.collections.impl.BitSet _tokenSet_29

_tokenSet_30

public static final antlr.collections.impl.BitSet _tokenSet_30

_tokenSet_31

public static final antlr.collections.impl.BitSet _tokenSet_31

_tokenSet_32

public static final antlr.collections.impl.BitSet _tokenSet_32

_tokenSet_33

public static final antlr.collections.impl.BitSet _tokenSet_33

_tokenSet_34

public static final antlr.collections.impl.BitSet _tokenSet_34

_tokenSet_35

public static final antlr.collections.impl.BitSet _tokenSet_35
Constructor Detail

HqlBaseParser

protected HqlBaseParser(antlr.TokenBuffer tokenBuf,
                        int k)

HqlBaseParser

public HqlBaseParser(antlr.TokenBuffer tokenBuf)

HqlBaseParser

protected HqlBaseParser(antlr.TokenStream lexer,
                        int k)

HqlBaseParser

public HqlBaseParser(antlr.TokenStream lexer)

HqlBaseParser

public HqlBaseParser(antlr.ParserSharedInputState state)
Method Detail

setFilter

public void setFilter(boolean f)
Sets the filter flag.

Parameters:
f - True for a filter query, false for a normal query.

isFilter

public boolean isFilter()
Returns true if this is a filter query, false if not.

Returns:
true if this is a filter query, false if not.

handleIdentifierError

public antlr.collections.AST handleIdentifierError(antlr.Token token,
                                                   antlr.RecognitionException ex)
                                            throws antlr.RecognitionException,
                                                   antlr.TokenStreamException
This method is overriden in the sub class in order to provide the 'keyword as identifier' hack.

Parameters:
token - The token to retry as an identifier.
ex - The exception to throw if it cannot be retried as an identifier.
Throws:
antlr.RecognitionException
antlr.TokenStreamException

handleDotIdent

public void handleDotIdent()
                    throws antlr.TokenStreamException
This method looks ahead and converts . into . IDENT when appropriate.

Throws:
antlr.TokenStreamException

negateNode

public antlr.collections.AST negateNode(antlr.collections.AST x)
Returns the negated equivalent of the expression.

Parameters:
x - The expression to negate.

processEqualityExpression

public antlr.collections.AST processEqualityExpression(antlr.collections.AST x)
                                                throws antlr.RecognitionException
Returns the 'cleaned up' version of a comparison operator sub-tree.

Parameters:
x - The comparison operator to clean up.
Throws:
antlr.RecognitionException

weakKeywords

public void weakKeywords()
                  throws antlr.TokenStreamException
Throws:
antlr.TokenStreamException

processMemberOf

public void processMemberOf(antlr.Token n,
                            antlr.collections.AST p,
                            antlr.ASTPair currentAST)

statement

public final void statement()
                     throws antlr.RecognitionException,
                            antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

updateStatement

public final void updateStatement()
                           throws antlr.RecognitionException,
                                  antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

deleteStatement

public final void deleteStatement()
                           throws antlr.RecognitionException,
                                  antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

selectStatement

public final void selectStatement()
                           throws antlr.RecognitionException,
                                  antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

insertStatement

public final void insertStatement()
                           throws antlr.RecognitionException,
                                  antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

optionalFromTokenFromClause

public final void optionalFromTokenFromClause()
                                       throws antlr.RecognitionException,
                                              antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

setClause

public final void setClause()
                     throws antlr.RecognitionException,
                            antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

whereClause

public final void whereClause()
                       throws antlr.RecognitionException,
                              antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

assignment

public final void assignment()
                      throws antlr.RecognitionException,
                             antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

stateField

public final void stateField()
                      throws antlr.RecognitionException,
                             antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

newValue

public final void newValue()
                    throws antlr.RecognitionException,
                           antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

path

public final void path()
                throws antlr.RecognitionException,
                       antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

concatenation

public final void concatenation()
                         throws antlr.RecognitionException,
                                antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

asAlias

public final void asAlias()
                   throws antlr.RecognitionException,
                          antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

queryRule

public final void queryRule()
                     throws antlr.RecognitionException,
                            antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

intoClause

public final void intoClause()
                      throws antlr.RecognitionException,
                             antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

insertablePropertySpec

public final void insertablePropertySpec()
                                  throws antlr.RecognitionException,
                                         antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

primaryExpression

public final void primaryExpression()
                             throws antlr.RecognitionException,
                                    antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

union

public final void union()
                 throws antlr.RecognitionException,
                        antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

selectFrom

public final void selectFrom()
                      throws antlr.RecognitionException,
                             antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

groupByClause

public final void groupByClause()
                         throws antlr.RecognitionException,
                                antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

orderByClause

public final void orderByClause()
                         throws antlr.RecognitionException,
                                antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

selectClause

public final void selectClause()
                        throws antlr.RecognitionException,
                               antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

fromClause

public final void fromClause()
                      throws antlr.RecognitionException,
                             antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

selectedPropertiesList

public final void selectedPropertiesList()
                                  throws antlr.RecognitionException,
                                         antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

newExpression

public final void newExpression()
                         throws antlr.RecognitionException,
                                antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

selectObject

public final void selectObject()
                        throws antlr.RecognitionException,
                               antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

identifier

public final void identifier()
                      throws antlr.RecognitionException,
                             antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

fromRange

public final void fromRange()
                     throws antlr.RecognitionException,
                            antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

fromJoin

public final void fromJoin()
                    throws antlr.RecognitionException,
                           antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

propertyFetch

public final void propertyFetch()
                         throws antlr.RecognitionException,
                                antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

withClause

public final void withClause()
                      throws antlr.RecognitionException,
                             antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

logicalExpression

public final void logicalExpression()
                             throws antlr.RecognitionException,
                                    antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

fromClassOrOuterQueryPath

public final void fromClassOrOuterQueryPath()
                                     throws antlr.RecognitionException,
                                            antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

inClassDeclaration

public final void inClassDeclaration()
                              throws antlr.RecognitionException,
                                     antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

inCollectionDeclaration

public final void inCollectionDeclaration()
                                   throws antlr.RecognitionException,
                                          antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

inCollectionElementsDeclaration

public final void inCollectionElementsDeclaration()
                                           throws antlr.RecognitionException,
                                                  antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

alias

public final void alias()
                 throws antlr.RecognitionException,
                        antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

expression

public final void expression()
                      throws antlr.RecognitionException,
                             antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

havingClause

public final void havingClause()
                        throws antlr.RecognitionException,
                               antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

orderElement

public final void orderElement()
                        throws antlr.RecognitionException,
                               antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

ascendingOrDescending

public final void ascendingOrDescending()
                                 throws antlr.RecognitionException,
                                        antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

aliasedExpression

public final void aliasedExpression()
                             throws antlr.RecognitionException,
                                    antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

logicalOrExpression

public final void logicalOrExpression()
                               throws antlr.RecognitionException,
                                      antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

logicalAndExpression

public final void logicalAndExpression()
                                throws antlr.RecognitionException,
                                       antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

negatedExpression

public final void negatedExpression()
                             throws antlr.RecognitionException,
                                    antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

equalityExpression

public final void equalityExpression()
                              throws antlr.RecognitionException,
                                     antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

relationalExpression

public final void relationalExpression()
                                throws antlr.RecognitionException,
                                       antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

additiveExpression

public final void additiveExpression()
                              throws antlr.RecognitionException,
                                     antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

inList

public final void inList()
                  throws antlr.RecognitionException,
                         antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

betweenList

public final void betweenList()
                       throws antlr.RecognitionException,
                              antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

likeEscape

public final void likeEscape()
                      throws antlr.RecognitionException,
                             antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

compoundExpr

public final void compoundExpr()
                        throws antlr.RecognitionException,
                               antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

multiplyExpression

public final void multiplyExpression()
                              throws antlr.RecognitionException,
                                     antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

unaryExpression

public final void unaryExpression()
                           throws antlr.RecognitionException,
                                  antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

caseExpression

public final void caseExpression()
                          throws antlr.RecognitionException,
                                 antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

quantifiedExpression

public final void quantifiedExpression()
                                throws antlr.RecognitionException,
                                       antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

atom

public final void atom()
                throws antlr.RecognitionException,
                       antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

whenClause

public final void whenClause()
                      throws antlr.RecognitionException,
                             antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

elseClause

public final void elseClause()
                      throws antlr.RecognitionException,
                             antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

altWhenClause

public final void altWhenClause()
                         throws antlr.RecognitionException,
                                antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

collectionExpr

public final void collectionExpr()
                          throws antlr.RecognitionException,
                                 antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

subQuery

public final void subQuery()
                    throws antlr.RecognitionException,
                           antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

exprList

public final void exprList()
                    throws antlr.RecognitionException,
                           antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

identPrimary

public final void identPrimary()
                        throws antlr.RecognitionException,
                               antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

constant

public final void constant()
                    throws antlr.RecognitionException,
                           antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

expressionOrVector

public final void expressionOrVector()
                              throws antlr.RecognitionException,
                                     antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

vectorExpr

public final void vectorExpr()
                      throws antlr.RecognitionException,
                             antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

aggregate

public final void aggregate()
                     throws antlr.RecognitionException,
                            antlr.TokenStreamException
Throws:
antlr.RecognitionException
antlr.TokenStreamException

buildTokenTypeASTClassMap

protected void buildTokenTypeASTClassMap()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HqlSqlBaseWalker (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.antlr
Class HqlSqlBaseWalker

java.lang.Object
    extended by antlr.TreeParser
        extended by org.hibernate.hql.antlr.HqlSqlBaseWalker
All Implemented Interfaces:
HqlSqlTokenTypes
Direct Known Subclasses:
HqlSqlWalker
public class HqlSqlBaseWalker
extends antlr.TreeParser
implements HqlSqlTokenTypes

Hibernate Query Language to SQL Tree Transform.
This is a tree grammar that transforms an HQL AST into a intermediate SQL AST with bindings to Hibernate interfaces (Queryable, etc.). The Hibernate specific methods are all implemented in the HqlSqlWalker subclass, allowing the ANTLR-generated class to have only the minimum dependencies on the Hibernate code base. This will also allow the sub-class to be easily edited using an IDE (most IDE's don't support ANTLR).
NOTE: The java class is generated from hql-sql.g by ANTLR. DO NOT EDIT THE GENERATED JAVA SOURCE CODE.

Author:
Joshua Davis (joshua@hibernate.org)

Field Summary
static String[] | _tokenNames
static antlr.collections.impl.BitSet | _tokenSet_0
Fields inherited from class antlr.TreeParser
_retTree, astFactory, ASTNULL, inputState, returnAST, tokenNames, traceDepth
Fields inherited from interface org.hibernate.hql.antlr.HqlSqlTokenTypes
AGGREGATE, ALIAS, ALIAS_REF, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOGUS, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FILTERS, FLOAT_SUFFIX, FROM, FROM_FRAGMENT, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IMPLIED_FROM, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, JOIN_FRAGMENT, LE, LEADING, LEFT, LEFT_OUTER, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, METHOD_NAME, MIN, MINUS, NAMED_PARAM, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, PROPERTY_REF, QUERY, QUOTED_STRING, RANGE, RIGHT, RIGHT_OUTER, ROW_STAR, SELECT, SELECT_CLAUSE, SELECT_COLUMNS, SELECT_EXPR, SELECT_FROM, SET, SOME, SQL_NE, SQL_TOKEN, STAR, SUM, THEN, THETA_JOINS, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
HqlSqlBaseWalker()
Method Summary
void | addrExpr(antlr.collections.AST _t, boolean root)
void | addrExprLhs(antlr.collections.AST _t)
void | aggregateExpr(antlr.collections.AST _t)
void | aliasedSelectExpr(antlr.collections.AST _t)
void | aliasRef(antlr.collections.AST _t)
void | arithmeticExpr(antlr.collections.AST _t)
void | assignment(antlr.collections.AST _t)
protected void | beforeSelectClause()
void | caseExpr(antlr.collections.AST _t)
void | collectionFunction(antlr.collections.AST _t)
void | collectionFunctionOrSubselect(antlr.collections.AST _t)
void | comparisonExpr(antlr.collections.AST _t)
void | constant(antlr.collections.AST _t)
void | constructor(antlr.collections.AST _t)
void | count(antlr.collections.AST _t)
protected antlr.collections.AST | createFromElement(String path, antlr.collections.AST alias, antlr.collections.AST propertyFetch)
protected antlr.collections.AST | createFromFilterElement(antlr.collections.AST filterEntity, antlr.collections.AST alias)
protected void | createFromJoinElement(antlr.collections.AST path, antlr.collections.AST alias, int joinType, antlr.collections.AST fetch, antlr.collections.AST propertyFetch, antlr.collections.AST with)
protected antlr.collections.AST | createIntoClause(String path, antlr.collections.AST propertySpec)
void | deleteStatement(antlr.collections.AST _t)
protected void | evaluateAssignment(antlr.collections.AST eq)
void | expr(antlr.collections.AST _t)
void | exprOrSubquery(antlr.collections.AST _t)
void | fromClause(antlr.collections.AST _t)
void | fromElement(antlr.collections.AST _t)
void | fromElementList(antlr.collections.AST _t)
void | functionCall(antlr.collections.AST _t)
protected antlr.collections.AST | generateNamedParameter(antlr.collections.AST delimiterNode, antlr.collections.AST nameNode)
protected antlr.collections.AST | generatePositionalParameter(antlr.collections.AST inputNode)
int | getCurrentClauseType()
int | getCurrentStatementType()
int | getCurrentTopLevelClauseType()
int | getStatementType()
void | groupClause(antlr.collections.AST _t)
void | identifier(antlr.collections.AST _t)
void | inRhs(antlr.collections.AST _t)
void | insertablePropertySpec(antlr.collections.AST _t)
void | insertStatement(antlr.collections.AST _t)
void | intoClause(antlr.collections.AST _t)
boolean | isComparativeExpressionClause()
boolean | isInCase()
boolean | isInFrom()
boolean | isInFunctionCall()
boolean | isInSelect()
protected boolean | isNonQualifiedPropertyRef(antlr.collections.AST ident)
boolean | isSelectStatement()
boolean | isSubQuery()
void | joinElement(antlr.collections.AST _t)
int | joinType(antlr.collections.AST _t)
void | literal(antlr.collections.AST _t)
void | logicalExpr(antlr.collections.AST _t)
protected void | lookupAlias(antlr.collections.AST ident)
protected antlr.collections.AST | lookupNonQualifiedProperty(antlr.collections.AST property)
protected antlr.collections.AST | lookupProperty(antlr.collections.AST dot, boolean root, boolean inSelect)
void | newValue(antlr.collections.AST _t)
void | numericInteger(antlr.collections.AST _t)
void | orderClause(antlr.collections.AST _t)
void | orderExprs(antlr.collections.AST _t)
void | parameter(antlr.collections.AST _t)
String | path(antlr.collections.AST _t)
void | pathAsIdent(antlr.collections.AST _t)
protected void | postProcessDelete(antlr.collections.AST delete)
protected void | postProcessInsert(antlr.collections.AST insert)
protected void | postProcessUpdate(antlr.collections.AST update)
protected void | prepareArithmeticOperator(antlr.collections.AST operator)
protected void | prepareFromClauseInputTree(antlr.collections.AST fromClauseInput) Pre-process the from clause input tree.
protected void | prepareLogicOperator(antlr.collections.AST operator)
protected void | prepareVersioned(antlr.collections.AST updateNode, antlr.collections.AST versionedNode)
protected void | processBoolean(antlr.collections.AST constant)
protected void | processConstant(antlr.collections.AST constant)
protected void | processConstructor(antlr.collections.AST constructor)
protected void | processFunction(antlr.collections.AST functionCall, boolean inSelect)
protected void | processIndex(antlr.collections.AST indexOp)
protected void | processNumericLiteral(antlr.collections.AST literal)
protected void | processQuery(antlr.collections.AST select, antlr.collections.AST query)
void | propertyName(antlr.collections.AST _t)
void | propertyRef(antlr.collections.AST _t)
void | propertyRefLhs(antlr.collections.AST _t)
protected void | pushFromClause(antlr.collections.AST fromClause, antlr.collections.AST inputFromNode) Sets the current 'FROM' context.
void | query(antlr.collections.AST _t)
protected void | resolve(antlr.collections.AST node)
protected void | resolveSelectExpression(antlr.collections.AST dotNode)
void | selectClause(antlr.collections.AST _t)
void | selectExpr(antlr.collections.AST _t)
void | selectExprList(antlr.collections.AST _t)
void | selectStatement(antlr.collections.AST _t)
protected void | setAlias(antlr.collections.AST selectExpr, antlr.collections.AST ident)
void | setClause(antlr.collections.AST _t)
protected void | setImpliedJoinType(int joinType)
void | statement(antlr.collections.AST _t)
void | updateStatement(antlr.collections.AST _t)
void | whereClause(antlr.collections.AST _t)
void | withClause(antlr.collections.AST _t)
Methods inherited from class antlr.TreeParser
getAST, getASTFactory, getTokenName, getTokenNames, match, match, matchNot, panic, reportError, reportError, reportWarning, setASTFactory, setASTNodeClass, setASTNodeType, traceIn, traceIndent, traceOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_tokenNames

public static final String[] _tokenNames

_tokenSet_0

public static final antlr.collections.impl.BitSet _tokenSet_0
Constructor Detail

HqlSqlBaseWalker

public HqlSqlBaseWalker()
Method Detail

isSubQuery

public final boolean isSubQuery()

isInFrom

public final boolean isInFrom()

isInFunctionCall

public final boolean isInFunctionCall()

isInSelect

public final boolean isInSelect()

isInCase

public final boolean isInCase()

getStatementType

public final int getStatementType()

getCurrentClauseType

public final int getCurrentClauseType()

getCurrentTopLevelClauseType

public final int getCurrentTopLevelClauseType()

getCurrentStatementType

public final int getCurrentStatementType()

isComparativeExpressionClause

public final boolean isComparativeExpressionClause()

isSelectStatement

public final boolean isSelectStatement()

evaluateAssignment

protected void evaluateAssignment(antlr.collections.AST eq)
                           throws antlr.SemanticException
Throws:
antlr.SemanticException

prepareFromClauseInputTree

protected void prepareFromClauseInputTree(antlr.collections.AST fromClauseInput)
Pre-process the from clause input tree.

pushFromClause

protected void pushFromClause(antlr.collections.AST fromClause,
                              antlr.collections.AST inputFromNode)
Sets the current 'FROM' context.

createFromElement

protected antlr.collections.AST createFromElement(String path,
                                                  antlr.collections.AST alias,
                                                  antlr.collections.AST propertyFetch)
                                           throws antlr.SemanticException
Throws:
antlr.SemanticException

createFromJoinElement

protected void createFromJoinElement(antlr.collections.AST path,
                                     antlr.collections.AST alias,
                                     int joinType,
                                     antlr.collections.AST fetch,
                                     antlr.collections.AST propertyFetch,
                                     antlr.collections.AST with)
                              throws antlr.SemanticException
Throws:
antlr.SemanticException

createFromFilterElement

protected antlr.collections.AST createFromFilterElement(antlr.collections.AST filterEntity,
                                                        antlr.collections.AST alias)
                                                 throws antlr.SemanticException
Throws:
antlr.SemanticException

processQuery

protected void processQuery(antlr.collections.AST select,
                            antlr.collections.AST query)
                     throws antlr.SemanticException
Throws:
antlr.SemanticException

postProcessUpdate

protected void postProcessUpdate(antlr.collections.AST update)
                          throws antlr.SemanticException
Throws:
antlr.SemanticException

postProcessDelete

protected void postProcessDelete(antlr.collections.AST delete)
                          throws antlr.SemanticException
Throws:
antlr.SemanticException

postProcessInsert

protected void postProcessInsert(antlr.collections.AST insert)
                          throws antlr.SemanticException
Throws:
antlr.SemanticException

beforeSelectClause

protected void beforeSelectClause()
                           throws antlr.SemanticException
Throws:
antlr.SemanticException

processIndex

protected void processIndex(antlr.collections.AST indexOp)
                     throws antlr.SemanticException
Throws:
antlr.SemanticException

processConstant

protected void processConstant(antlr.collections.AST constant)
                        throws antlr.SemanticException
Throws:
antlr.SemanticException

processBoolean

protected void processBoolean(antlr.collections.AST constant)
                       throws antlr.SemanticException
Throws:
antlr.SemanticException

processNumericLiteral

protected void processNumericLiteral(antlr.collections.AST literal)
                              throws antlr.SemanticException
Throws:
antlr.SemanticException

resolve

protected void resolve(antlr.collections.AST node)
                throws antlr.SemanticException
Throws:
antlr.SemanticException

resolveSelectExpression

protected void resolveSelectExpression(antlr.collections.AST dotNode)
                                throws antlr.SemanticException
Throws:
antlr.SemanticException

processFunction

protected void processFunction(antlr.collections.AST functionCall,
                               boolean inSelect)
                        throws antlr.SemanticException
Throws:
antlr.SemanticException

processConstructor

protected void processConstructor(antlr.collections.AST constructor)
                           throws antlr.SemanticException
Throws:
antlr.SemanticException

generateNamedParameter

protected antlr.collections.AST generateNamedParameter(antlr.collections.AST delimiterNode,
                                                       antlr.collections.AST nameNode)
                                                throws antlr.SemanticException
Throws:
antlr.SemanticException

generatePositionalParameter

protected antlr.collections.AST generatePositionalParameter(antlr.collections.AST inputNode)
                                                     throws antlr.SemanticException
Throws:
antlr.SemanticException

lookupAlias

protected void lookupAlias(antlr.collections.AST ident)
                    throws antlr.SemanticException
Throws:
antlr.SemanticException

setAlias

protected void setAlias(antlr.collections.AST selectExpr,
                        antlr.collections.AST ident)

lookupProperty

protected antlr.collections.AST lookupProperty(antlr.collections.AST dot,
                                               boolean root,
                                               boolean inSelect)
                                        throws antlr.SemanticException
Throws:
antlr.SemanticException

isNonQualifiedPropertyRef

protected boolean isNonQualifiedPropertyRef(antlr.collections.AST ident)

lookupNonQualifiedProperty

protected antlr.collections.AST lookupNonQualifiedProperty(antlr.collections.AST property)
                                                    throws antlr.SemanticException
Throws:
antlr.SemanticException

setImpliedJoinType

protected void setImpliedJoinType(int joinType)

createIntoClause

protected antlr.collections.AST createIntoClause(String path,
                                                 antlr.collections.AST propertySpec)
                                          throws antlr.SemanticException
Throws:
antlr.SemanticException

prepareVersioned

protected void prepareVersioned(antlr.collections.AST updateNode,
                                antlr.collections.AST versionedNode)
                         throws antlr.SemanticException
Throws:
antlr.SemanticException

prepareLogicOperator

protected void prepareLogicOperator(antlr.collections.AST operator)
                             throws antlr.SemanticException
Throws:
antlr.SemanticException

prepareArithmeticOperator

protected void prepareArithmeticOperator(antlr.collections.AST operator)
                                  throws antlr.SemanticException
Throws:
antlr.SemanticException

statement

public final void statement(antlr.collections.AST _t)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException

selectStatement

public final void selectStatement(antlr.collections.AST _t)
                           throws antlr.RecognitionException
Throws:
antlr.RecognitionException

updateStatement

public final void updateStatement(antlr.collections.AST _t)
                           throws antlr.RecognitionException
Throws:
antlr.RecognitionException

deleteStatement

public final void deleteStatement(antlr.collections.AST _t)
                           throws antlr.RecognitionException
Throws:
antlr.RecognitionException

insertStatement

public final void insertStatement(antlr.collections.AST _t)
                           throws antlr.RecognitionException
Throws:
antlr.RecognitionException

query

public final void query(antlr.collections.AST _t)
                 throws antlr.RecognitionException
Throws:
antlr.RecognitionException

fromClause

public final void fromClause(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

setClause

public final void setClause(antlr.collections.AST _t)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException

whereClause

public final void whereClause(antlr.collections.AST _t)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

intoClause

public final void intoClause(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

path

public final String path(antlr.collections.AST _t)
                  throws antlr.RecognitionException
Throws:
antlr.RecognitionException

insertablePropertySpec

public final void insertablePropertySpec(antlr.collections.AST _t)
                                  throws antlr.RecognitionException
Throws:
antlr.RecognitionException

assignment

public final void assignment(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

propertyRef

public final void propertyRef(antlr.collections.AST _t)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

newValue

public final void newValue(antlr.collections.AST _t)
                    throws antlr.RecognitionException
Throws:
antlr.RecognitionException

expr

public final void expr(antlr.collections.AST _t)
                throws antlr.RecognitionException
Throws:
antlr.RecognitionException

selectClause

public final void selectClause(antlr.collections.AST _t)
                        throws antlr.RecognitionException
Throws:
antlr.RecognitionException

groupClause

public final void groupClause(antlr.collections.AST _t)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

orderClause

public final void orderClause(antlr.collections.AST _t)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

orderExprs

public final void orderExprs(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

logicalExpr

public final void logicalExpr(antlr.collections.AST _t)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

selectExprList

public final void selectExprList(antlr.collections.AST _t)
                          throws antlr.RecognitionException
Throws:
antlr.RecognitionException

selectExpr

public final void selectExpr(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

aliasedSelectExpr

public final void aliasedSelectExpr(antlr.collections.AST _t)
                             throws antlr.RecognitionException
Throws:
antlr.RecognitionException

identifier

public final void identifier(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

aliasRef

public final void aliasRef(antlr.collections.AST _t)
                    throws antlr.RecognitionException
Throws:
antlr.RecognitionException

constructor

public final void constructor(antlr.collections.AST _t)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

functionCall

public final void functionCall(antlr.collections.AST _t)
                        throws antlr.RecognitionException
Throws:
antlr.RecognitionException

count

public final void count(antlr.collections.AST _t)
                 throws antlr.RecognitionException
Throws:
antlr.RecognitionException

collectionFunction

public final void collectionFunction(antlr.collections.AST _t)
                              throws antlr.RecognitionException
Throws:
antlr.RecognitionException

literal

public final void literal(antlr.collections.AST _t)
                   throws antlr.RecognitionException
Throws:
antlr.RecognitionException

arithmeticExpr

public final void arithmeticExpr(antlr.collections.AST _t)
                          throws antlr.RecognitionException
Throws:
antlr.RecognitionException

aggregateExpr

public final void aggregateExpr(antlr.collections.AST _t)
                         throws antlr.RecognitionException
Throws:
antlr.RecognitionException

fromElementList

public final void fromElementList(antlr.collections.AST _t)
                           throws antlr.RecognitionException
Throws:
antlr.RecognitionException

fromElement

public final void fromElement(antlr.collections.AST _t)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

joinElement

public final void joinElement(antlr.collections.AST _t)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

joinType

public final int joinType(antlr.collections.AST _t)
                   throws antlr.RecognitionException
Throws:
antlr.RecognitionException

pathAsIdent

public final void pathAsIdent(antlr.collections.AST _t)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

withClause

public final void withClause(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

comparisonExpr

public final void comparisonExpr(antlr.collections.AST _t)
                          throws antlr.RecognitionException
Throws:
antlr.RecognitionException

exprOrSubquery

public final void exprOrSubquery(antlr.collections.AST _t)
                          throws antlr.RecognitionException
Throws:
antlr.RecognitionException

inRhs

public final void inRhs(antlr.collections.AST _t)
                 throws antlr.RecognitionException
Throws:
antlr.RecognitionException

collectionFunctionOrSubselect

public final void collectionFunctionOrSubselect(antlr.collections.AST _t)
                                         throws antlr.RecognitionException
Throws:
antlr.RecognitionException

addrExpr

public final void addrExpr(antlr.collections.AST _t,
                           boolean root)
                    throws antlr.RecognitionException
Throws:
antlr.RecognitionException

constant

public final void constant(antlr.collections.AST _t)
                    throws antlr.RecognitionException
Throws:
antlr.RecognitionException

parameter

public final void parameter(antlr.collections.AST _t)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException

caseExpr

public final void caseExpr(antlr.collections.AST _t)
                    throws antlr.RecognitionException
Throws:
antlr.RecognitionException

addrExprLhs

public final void addrExprLhs(antlr.collections.AST _t)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

propertyName

public final void propertyName(antlr.collections.AST _t)
                        throws antlr.RecognitionException
Throws:
antlr.RecognitionException

propertyRefLhs

public final void propertyRefLhs(antlr.collections.AST _t)
                          throws antlr.RecognitionException
Throws:
antlr.RecognitionException

numericInteger

public final void numericInteger(antlr.collections.AST _t)
                          throws antlr.RecognitionException
Throws:
antlr.RecognitionException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SqlGeneratorBase (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.antlr
Class SqlGeneratorBase

java.lang.Object
    extended by antlr.TreeParser
        extended by org.hibernate.hql.antlr.SqlGeneratorBase
All Implemented Interfaces:
SqlTokenTypes
Direct Known Subclasses:
SqlGenerator
public class SqlGeneratorBase
extends antlr.TreeParser
implements SqlTokenTypes

SQL Generator Tree Parser, providing SQL rendering of SQL ASTs produced by the previous phase, HqlSqlWalker. All syntax decoration such as extra spaces, lack of spaces, extra parens, etc. should be added by this class.
This grammar processes the HQL/SQL AST and produces an SQL string. The intent is to move dialect-specific code into a sub-class that will override some of the methods, just like the other two grammars in this system.

Author:
Joshua Davis (joshua@hibernate.org)

Field Summary
static String[] | _tokenNames
static antlr.collections.impl.BitSet | _tokenSet_0
static antlr.collections.impl.BitSet | _tokenSet_1
static antlr.collections.impl.BitSet | _tokenSet_2
static antlr.collections.impl.BitSet | _tokenSet_3
static antlr.collections.impl.BitSet | _tokenSet_4
static antlr.collections.impl.BitSet | _tokenSet_5
Fields inherited from class antlr.TreeParser
_retTree, astFactory, ASTNULL, inputState, returnAST, tokenNames, traceDepth
Fields inherited from interface org.hibernate.hql.antlr.SqlTokenTypes
AGGREGATE, ALIAS, ALIAS_REF, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOGUS, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FILTERS, FLOAT_SUFFIX, FROM, FROM_FRAGMENT, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IMPLIED_FROM, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, JOIN_FRAGMENT, LE, LEADING, LEFT, LEFT_OUTER, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, METHOD_NAME, MIN, MINUS, NAMED_PARAM, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, PROPERTY_REF, QUERY, QUOTED_STRING, RANGE, RIGHT, RIGHT_OUTER, ROW_STAR, SELECT, SELECT_CLAUSE, SELECT_COLUMNS, SELECT_EXPR, SELECT_FROM, SET, SOME, SQL_NE, SQL_NODE, SQL_TOKEN, STAR, SUM, THEN, THETA_JOINS, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
SqlGeneratorBase()
Method Summary
void | additiveExpr(antlr.collections.AST _t)
void | addrExpr(antlr.collections.AST _t)
void | aggregate(antlr.collections.AST _t)
void | arguments(antlr.collections.AST _t)
void | arithmeticExpr(antlr.collections.AST _t)
protected void | beginFunctionTemplate(antlr.collections.AST m, antlr.collections.AST i)
void | binaryComparisonExpression(antlr.collections.AST _t)
void | booleanExpr(antlr.collections.AST _t, boolean parens)
void | booleanOp(antlr.collections.AST _t, boolean parens)
void | caseExpr(antlr.collections.AST _t)
protected void | commaBetweenParameters(String comma)
void | comparisonExpr(antlr.collections.AST _t, boolean parens)
void | conditionList(antlr.collections.AST _t)
void | constant(antlr.collections.AST _t)
void | count(antlr.collections.AST _t)
void | countExpr(antlr.collections.AST _t)
void | deleteStatement(antlr.collections.AST _t)
void | distinctOrAll(antlr.collections.AST _t)
protected void | endFunctionTemplate(antlr.collections.AST m)
void | exoticComparisonExpression(antlr.collections.AST _t)
void | expr(antlr.collections.AST _t)
void | filters(antlr.collections.AST _t)
void | from(antlr.collections.AST _t)
protected void | fromFragmentSeparator(antlr.collections.AST a)
void | fromTable(antlr.collections.AST _t)
protected int | getLastChar() Returns the last character written to the output, or -1 if there isn't one.
protected StringBuffer | getStringBuffer()
void | groupExprs(antlr.collections.AST _t)
protected boolean | hasText(antlr.collections.AST a)
void | inList(antlr.collections.AST _t)
void | insertStatement(antlr.collections.AST _t)
void | likeEscape(antlr.collections.AST _t)
void | methodCall(antlr.collections.AST _t)
void | multiplicativeExpr(antlr.collections.AST _t)
void | nestedExpr(antlr.collections.AST _t)
void | nestedExprAfterMinusDiv(antlr.collections.AST _t)
protected void | nestedFromFragment(antlr.collections.AST d, antlr.collections.AST parent)
protected void | nyi(antlr.collections.AST n)
protected void | optionalSpace() Add a aspace if the previous token was not a space or a parenthesis.
void | orderDirection(antlr.collections.AST _t)
void | orderExprs(antlr.collections.AST _t)
protected void | out(antlr.collections.AST n)
protected void | out(String s)
void | parameter(antlr.collections.AST _t)
void | parenSelect(antlr.collections.AST _t)
void | quantified(antlr.collections.AST _t)
void | selectAtom(antlr.collections.AST _t)
void | selectClause(antlr.collections.AST _t)
void | selectColumn(antlr.collections.AST _t)
void | selectExpr(antlr.collections.AST _t)
void | selectStatement(antlr.collections.AST _t)
protected void | separator(antlr.collections.AST n, String sep)
void | setClause(antlr.collections.AST _t)
void | simpleExpr(antlr.collections.AST _t)
void | simpleExprList(antlr.collections.AST _t)
void | sqlToken(antlr.collections.AST _t)
void | statement(antlr.collections.AST _t)
void | tableJoin(antlr.collections.AST _t, antlr.collections.AST parent)
void | thetaJoins(antlr.collections.AST _t)
void | updateStatement(antlr.collections.AST _t)
void | whereClause(antlr.collections.AST _t)
void | whereClauseExpr(antlr.collections.AST _t)
void | whereExpr(antlr.collections.AST _t)
Methods inherited from class antlr.TreeParser
getAST, getASTFactory, getTokenName, getTokenNames, match, match, matchNot, panic, reportError, reportError, reportWarning, setASTFactory, setASTNodeClass, setASTNodeType, traceIn, traceIndent, traceOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_tokenNames

public static final String[] _tokenNames

_tokenSet_0

public static final antlr.collections.impl.BitSet _tokenSet_0

_tokenSet_1

public static final antlr.collections.impl.BitSet _tokenSet_1

_tokenSet_2

public static final antlr.collections.impl.BitSet _tokenSet_2

_tokenSet_3

public static final antlr.collections.impl.BitSet _tokenSet_3

_tokenSet_4

public static final antlr.collections.impl.BitSet _tokenSet_4

_tokenSet_5

public static final antlr.collections.impl.BitSet _tokenSet_5
Constructor Detail

SqlGeneratorBase

public SqlGeneratorBase()
Method Detail

out

protected void out(String s)

getLastChar

protected int getLastChar()
Returns the last character written to the output, or -1 if there isn't one.

optionalSpace

protected void optionalSpace()
Add a aspace if the previous token was not a space or a parenthesis.

out

protected void out(antlr.collections.AST n)

separator

protected void separator(antlr.collections.AST n,
                         String sep)

hasText

protected boolean hasText(antlr.collections.AST a)

fromFragmentSeparator

protected void fromFragmentSeparator(antlr.collections.AST a)

nestedFromFragment

protected void nestedFromFragment(antlr.collections.AST d,
                                  antlr.collections.AST parent)

getStringBuffer

protected StringBuffer getStringBuffer()

nyi

protected void nyi(antlr.collections.AST n)

beginFunctionTemplate

protected void beginFunctionTemplate(antlr.collections.AST m,
                                     antlr.collections.AST i)

endFunctionTemplate

protected void endFunctionTemplate(antlr.collections.AST m)

commaBetweenParameters

protected void commaBetweenParameters(String comma)

statement

public final void statement(antlr.collections.AST _t)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException

selectStatement

public final void selectStatement(antlr.collections.AST _t)
                           throws antlr.RecognitionException
Throws:
antlr.RecognitionException

updateStatement

public final void updateStatement(antlr.collections.AST _t)
                           throws antlr.RecognitionException
Throws:
antlr.RecognitionException

deleteStatement

public final void deleteStatement(antlr.collections.AST _t)
                           throws antlr.RecognitionException
Throws:
antlr.RecognitionException

insertStatement

public final void insertStatement(antlr.collections.AST _t)
                           throws antlr.RecognitionException
Throws:
antlr.RecognitionException

selectClause

public final void selectClause(antlr.collections.AST _t)
                        throws antlr.RecognitionException
Throws:
antlr.RecognitionException

from

public final void from(antlr.collections.AST _t)
                throws antlr.RecognitionException
Throws:
antlr.RecognitionException

whereExpr

public final void whereExpr(antlr.collections.AST _t)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException

groupExprs

public final void groupExprs(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

booleanExpr

public final void booleanExpr(antlr.collections.AST _t,
                              boolean parens)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

orderExprs

public final void orderExprs(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

fromTable

public final void fromTable(antlr.collections.AST _t)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException

setClause

public final void setClause(antlr.collections.AST _t)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException

whereClause

public final void whereClause(antlr.collections.AST _t)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

comparisonExpr

public final void comparisonExpr(antlr.collections.AST _t,
                                 boolean parens)
                          throws antlr.RecognitionException
Throws:
antlr.RecognitionException

whereClauseExpr

public final void whereClauseExpr(antlr.collections.AST _t)
                           throws antlr.RecognitionException
Throws:
antlr.RecognitionException

conditionList

public final void conditionList(antlr.collections.AST _t)
                         throws antlr.RecognitionException
Throws:
antlr.RecognitionException

expr

public final void expr(antlr.collections.AST _t)
                throws antlr.RecognitionException
Throws:
antlr.RecognitionException

orderDirection

public final void orderDirection(antlr.collections.AST _t)
                          throws antlr.RecognitionException
Throws:
antlr.RecognitionException

filters

public final void filters(antlr.collections.AST _t)
                   throws antlr.RecognitionException
Throws:
antlr.RecognitionException

thetaJoins

public final void thetaJoins(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

sqlToken

public final void sqlToken(antlr.collections.AST _t)
                    throws antlr.RecognitionException
Throws:
antlr.RecognitionException

distinctOrAll

public final void distinctOrAll(antlr.collections.AST _t)
                         throws antlr.RecognitionException
Throws:
antlr.RecognitionException

selectColumn

public final void selectColumn(antlr.collections.AST _t)
                        throws antlr.RecognitionException
Throws:
antlr.RecognitionException

selectExpr

public final void selectExpr(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

selectAtom

public final void selectAtom(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

count

public final void count(antlr.collections.AST _t)
                 throws antlr.RecognitionException
Throws:
antlr.RecognitionException

methodCall

public final void methodCall(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

aggregate

public final void aggregate(antlr.collections.AST _t)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException

constant

public final void constant(antlr.collections.AST _t)
                    throws antlr.RecognitionException
Throws:
antlr.RecognitionException

arithmeticExpr

public final void arithmeticExpr(antlr.collections.AST _t)
                          throws antlr.RecognitionException
Throws:
antlr.RecognitionException

countExpr

public final void countExpr(antlr.collections.AST _t)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException

simpleExpr

public final void simpleExpr(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

tableJoin

public final void tableJoin(antlr.collections.AST _t,
                            antlr.collections.AST parent)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException

booleanOp

public final void booleanOp(antlr.collections.AST _t,
                            boolean parens)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException

binaryComparisonExpression

public final void binaryComparisonExpression(antlr.collections.AST _t)
                                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

exoticComparisonExpression

public final void exoticComparisonExpression(antlr.collections.AST _t)
                                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

likeEscape

public final void likeEscape(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

inList

public final void inList(antlr.collections.AST _t)
                  throws antlr.RecognitionException
Throws:
antlr.RecognitionException

quantified

public final void quantified(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

parenSelect

public final void parenSelect(antlr.collections.AST _t)
                       throws antlr.RecognitionException
Throws:
antlr.RecognitionException

simpleExprList

public final void simpleExprList(antlr.collections.AST _t)
                          throws antlr.RecognitionException
Throws:
antlr.RecognitionException

addrExpr

public final void addrExpr(antlr.collections.AST _t)
                    throws antlr.RecognitionException
Throws:
antlr.RecognitionException

parameter

public final void parameter(antlr.collections.AST _t)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException

additiveExpr

public final void additiveExpr(antlr.collections.AST _t)
                        throws antlr.RecognitionException
Throws:
antlr.RecognitionException

multiplicativeExpr

public final void multiplicativeExpr(antlr.collections.AST _t)
                              throws antlr.RecognitionException
Throws:
antlr.RecognitionException

caseExpr

public final void caseExpr(antlr.collections.AST _t)
                    throws antlr.RecognitionException
Throws:
antlr.RecognitionException

nestedExprAfterMinusDiv

public final void nestedExprAfterMinusDiv(antlr.collections.AST _t)
                                   throws antlr.RecognitionException
Throws:
antlr.RecognitionException

nestedExpr

public final void nestedExpr(antlr.collections.AST _t)
                      throws antlr.RecognitionException
Throws:
antlr.RecognitionException

arguments

public final void arguments(antlr.collections.AST _t)
                     throws antlr.RecognitionException
Throws:
antlr.RecognitionException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.hql.ast (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.hql.ast

An ANTLR-based parser for Hibernate Query Language.

See:
Description

Interface Summary
ErrorReporter | Implementations will report or handle errors invoked by an ANTLR base parser.
ParseErrorHandler | Defines the behavior of an error handler for the HQL parsers.

Class Summary
ASTQueryTranslatorFactory | Generates translators which uses the Antlr-based parser to perform the translation.
ErrorCounter | An error handler that counts parsing errors and warnings.
HqlASTFactory | User: Joshua Davis Date: Sep 23, 2005 Time: 12:30:01 PM
HqlParser | Implements the semantic action methods defined in the HQL base parser to keep the grammar source file a little cleaner.
HqlSqlWalker | Implements methods used by the HQL->SQL tree transform grammar (a.k.a.
HqlToken | A custom token class for the HQL grammar.
ParameterTranslationsImpl | Defines the information available for parameters encountered during query translation through the antlr-based parser.
ParameterTranslationsImpl.ParameterInfo |
QueryTranslatorImpl | A QueryTranslator that uses an Antlr-based parser.
QueryTranslatorImpl.JavaConstantConverter |
SqlASTFactory | Custom AST factory the intermediate tree that causes ANTLR to create specialized AST nodes, given the AST node type (from HqlSqlTokenTypes).
SqlGenerator | Generates SQL by overriding callback methods in the base class, which does the actual SQL AST walking.

Exception Summary
DetailedSemanticException | Thrown when a call to the underlying Hibernate engine fails, indicating some form of semantic exception (e.g.
InvalidPathException | Exception thrown when an invalid path is found in a query.
QuerySyntaxException | Exception thrown when there is a syntax error in the HQL.

Package org.hibernate.hql.ast Description

An ANTLR-based parser for Hibernate Query Language.

Classes in this package extend the ANTLR-generated parser classes.


org.hibernate.hql.ast Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.hql.ast

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class antlr.ASTFactory
      • class org.hibernate.hql.ast.HqlASTFactory
      • class org.hibernate.hql.ast.SqlASTFactory (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)
    • class org.hibernate.hql.ast.ASTQueryTranslatorFactory (implements org.hibernate.hql.QueryTranslatorFactory)
    • class org.hibernate.hql.ast.ErrorCounter (implements org.hibernate.hql.ast.ParseErrorHandler)
    • class org.hibernate.hql.ast.ParameterTranslationsImpl (implements org.hibernate.hql.ParameterTranslations)
    • class org.hibernate.hql.ast.ParameterTranslationsImpl.ParameterInfo (implements java.io.Serializable)
    • class antlr.Parser
      • class antlr.LLkParser
        • class org.hibernate.hql.antlr.HqlBaseParser (implements org.hibernate.hql.antlr.HqlTokenTypes)
          • class org.hibernate.hql.ast.HqlParser
    • class org.hibernate.hql.ast.QueryTranslatorImpl (implements org.hibernate.hql.FilterTranslator)
    • class org.hibernate.hql.ast.QueryTranslatorImpl.JavaConstantConverter (implements org.hibernate.hql.ast.util.NodeTraverser.VisitationStrategy)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class antlr.ANTLRException
          • class antlr.RecognitionException
            • class antlr.SemanticException
              • class org.hibernate.hql.ast.DetailedSemanticException
              • class org.hibernate.hql.ast.InvalidPathException
        • class java.lang.RuntimeException
          • class org.hibernate.exception.NestableRuntimeException (implements org.hibernate.exception.Nestable)
            • class org.hibernate.HibernateException
              • class org.hibernate.QueryException
                • class org.hibernate.hql.ast.QuerySyntaxException
    • class antlr.Token (implements java.lang.Cloneable)
      • class antlr.CommonToken
        • class org.hibernate.hql.ast.HqlToken
    • class antlr.TreeParser
      • class org.hibernate.hql.antlr.HqlSqlBaseWalker (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)
        • class org.hibernate.hql.ast.HqlSqlWalker (implements org.hibernate.hql.ast.ErrorReporter, org.hibernate.engine.ParameterBinder.NamedParameterSource)
      • class org.hibernate.hql.antlr.SqlGeneratorBase (implements org.hibernate.hql.antlr.SqlTokenTypes)
        • class org.hibernate.hql.ast.SqlGenerator (implements org.hibernate.hql.ast.ErrorReporter)

Interface Hierarchy

  • interface org.hibernate.hql.ast.ErrorReporter
    • interface org.hibernate.hql.ast.ParseErrorHandler


Uses of Package org.hibernate.hql.ast (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.hql.ast

Packages that use org.hibernate.hql.ast
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.exec |
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |

Classes in org.hibernate.hql.ast used by org.hibernate.hql.ast
ErrorReporter
Implementations will report or handle errors invoked by an ANTLR base parser.
HqlParser
Implements the semantic action methods defined in the HQL base parser to keep the grammar source file a little cleaner.
HqlSqlWalker
Implements methods used by the HQL->SQL tree transform grammar (a.k.a.
ParameterTranslationsImpl.ParameterInfo
ParseErrorHandler
Defines the behavior of an error handler for the HQL parsers.
QuerySyntaxException
Exception thrown when there is a syntax error in the HQL.
QueryTranslatorImpl
A QueryTranslator that uses an Antlr-based parser.

Classes in org.hibernate.hql.ast used by org.hibernate.hql.ast.exec
HqlSqlWalker
Implements methods used by the HQL->SQL tree transform grammar (a.k.a.

Classes in org.hibernate.hql.ast used by org.hibernate.hql.ast.tree
HqlSqlWalker
Implements methods used by the HQL->SQL tree transform grammar (a.k.a.

Classes in org.hibernate.hql.ast used by org.hibernate.hql.ast.util
HqlSqlWalker
Implements methods used by the HQL->SQL tree transform grammar (a.k.a.
QueryTranslatorImpl
A QueryTranslator that uses an Antlr-based parser.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ErrorReporter (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Interface ErrorReporter

All Known Subinterfaces:
ParseErrorHandler
All Known Implementing Classes:
ErrorCounter, HqlSqlWalker, SqlGenerator
public interface ErrorReporter

Implementations will report or handle errors invoked by an ANTLR base parser.

Author:
josh Jun 27, 2004 9:49:55 PM

Method Summary
void | reportError(antlr.RecognitionException e)
void | reportError(String s)
void | reportWarning(String s)

Method Detail

reportError

public void reportError(antlr.RecognitionException e)

reportError

public void reportError(String s)

reportWarning

public void reportWarning(String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ParseErrorHandler (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Interface ParseErrorHandler

All Superinterfaces:
ErrorReporter
All Known Implementing Classes:
ErrorCounter
public interface ParseErrorHandler
extends ErrorReporter

Defines the behavior of an error handler for the HQL parsers. User: josh Date: Dec 6, 2003 Time: 12:20:43 PM

Method Summary
int | getErrorCount()
void | throwQueryException()
Methods inherited from interface org.hibernate.hql.ast.ErrorReporter
reportError, reportError, reportWarning

Method Detail

getErrorCount

public int getErrorCount()

throwQueryException

public void throwQueryException()
                         throws QueryException
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ASTQueryTranslatorFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class ASTQueryTranslatorFactory

java.lang.Object
    extended by org.hibernate.hql.ast.ASTQueryTranslatorFactory
All Implemented Interfaces:
QueryTranslatorFactory
public class ASTQueryTranslatorFactory
extends Object
implements QueryTranslatorFactory

Generates translators which uses the Antlr-based parser to perform the translation.

Author:
Gavin King

Constructor Summary
ASTQueryTranslatorFactory()
Method Summary
FilterTranslator | createFilterTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory) Construct a FilterTranslator instance capable of translating an HQL filter string.
QueryTranslator | createQueryTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory) Construct a QueryTranslator instance capable of translating an HQL query string.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ASTQueryTranslatorFactory

public ASTQueryTranslatorFactory()
Method Detail

createQueryTranslator

public QueryTranslator createQueryTranslator(String queryIdentifier,
                                             String queryString,
                                             Map filters,
                                             SessionFactoryImplementor factory)
Description copied from interface: QueryTranslatorFactory
Construct a QueryTranslator instance capable of translating an HQL query string.

Specified by:
createQueryTranslator in interface QueryTranslatorFactory
Parameters:
queryIdentifier - The query-identifier (used in QueryStatistics collection). This is typically the same as the queryString parameter except for the case of split polymorphic queries which result in multiple physical sql queries.
queryString - The query string to be translated
filters - Currently enabled filters
factory - The session factory.
Returns:
an appropriate translator.
See Also:
QueryTranslatorFactory.createQueryTranslator(java.lang.String, java.lang.String, java.util.Map, org.hibernate.engine.SessionFactoryImplementor)

createFilterTranslator

public FilterTranslator createFilterTranslator(String queryIdentifier,
                                               String queryString,
                                               Map filters,
                                               SessionFactoryImplementor factory)
Description copied from interface: QueryTranslatorFactory
Construct a FilterTranslator instance capable of translating an HQL filter string.

Specified by:
createFilterTranslator in interface QueryTranslatorFactory
See Also:
QueryTranslatorFactory.createFilterTranslator(java.lang.String, java.lang.String, java.util.Map, org.hibernate.engine.SessionFactoryImplementor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ErrorCounter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class ErrorCounter

java.lang.Object
    extended by org.hibernate.hql.ast.ErrorCounter
All Implemented Interfaces:
ErrorReporter, ParseErrorHandler
public class ErrorCounter
extends Object
implements ParseErrorHandler

An error handler that counts parsing errors and warnings.

Constructor Summary
ErrorCounter()
Method Summary
int | getErrorCount()
void | reportError(antlr.RecognitionException e)
void | reportError(String message)
void | reportWarning(String message)
void | throwQueryException()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ErrorCounter

public ErrorCounter()
Method Detail

reportError

public void reportError(antlr.RecognitionException e)
Specified by:
reportError in interface ErrorReporter

reportError

public void reportError(String message)
Specified by:
reportError in interface ErrorReporter

getErrorCount

public int getErrorCount()
Specified by:
getErrorCount in interface ParseErrorHandler

reportWarning

public void reportWarning(String message)
Specified by:
reportWarning in interface ErrorReporter

throwQueryException

public void throwQueryException()
                         throws QueryException
Specified by:
throwQueryException in interface ParseErrorHandler
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HqlASTFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class HqlASTFactory

java.lang.Object
    extended by antlr.ASTFactory
        extended by org.hibernate.hql.ast.HqlASTFactory
public class HqlASTFactory
extends antlr.ASTFactory

User: Joshua Davis
Date: Sep 23, 2005
Time: 12:30:01 PM

Field Summary
Fields inherited from class antlr.ASTFactory
theASTNodeType, theASTNodeTypeClass, tokenTypeToASTClassMap
Constructor Summary
HqlASTFactory()
Method Summary
 Class getASTNodeType(int tokenType)
Returns the class for a given token type (a.k.a.
Methods inherited from class antlr.ASTFactory
addASTChild, create, create, create, create, create, create, create, create, create, createUsingCtor, dup, dupList, dupTree, error, getTokenTypeToASTClassMap, make, make, makeASTRoot, setASTNodeClass, setASTNodeClass, setASTNodeType, setTokenTypeASTNodeType, setTokenTypeToASTClassMap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HqlASTFactory

public HqlASTFactory()
Method Detail

getASTNodeType

public Class getASTNodeType(int tokenType)
Returns the class for a given token type (a.k.a. AST node type).

Parameters:
tokenType - The token type.
Returns:
Class - The AST node class to instantiate.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HqlParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class HqlParser

java.lang.Object
    extended by antlr.Parser
        extended by antlr.LLkParser
            extended by org.hibernate.hql.antlr.HqlBaseParser
                extended by org.hibernate.hql.ast.HqlParser
All Implemented Interfaces:
HqlTokenTypes
public final class HqlParser
extends HqlBaseParser

Implements the semantic action methods defined in the HQL base parser to keep the grammar source file a little cleaner. Extends the parser class generated by ANTLR.

Author:
Joshua Davis (pgmjsd@sourceforge.net)

Field Summary
Fields inherited from class org.hibernate.hql.antlr.HqlBaseParser
_tokenNames, _tokenSet_0, _tokenSet_1, _tokenSet_10, _tokenSet_11, _tokenSet_12, _tokenSet_13, _tokenSet_14, _tokenSet_15, _tokenSet_16, _tokenSet_17, _tokenSet_18, _tokenSet_19, _tokenSet_2, _tokenSet_20, _tokenSet_21, _tokenSet_22, _tokenSet_23, _tokenSet_24, _tokenSet_25, _tokenSet_26, _tokenSet_27, _tokenSet_28, _tokenSet_29, _tokenSet_3, _tokenSet_30, _tokenSet_31, _tokenSet_32, _tokenSet_33, _tokenSet_34, _tokenSet_35, _tokenSet_4, _tokenSet_5, _tokenSet_6, _tokenSet_7, _tokenSet_8, _tokenSet_9
Fields inherited from class antlr.Parser
astFactory, inputState, returnAST, tokenNames, tokenTypeToASTClassMap, traceDepth
Fields inherited from interface org.hibernate.hql.antlr.HqlTokenTypes
AGGREGATE, ALIAS, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FLOAT_SUFFIX, FROM, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, LE, LEADING, LEFT, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, MIN, MINUS, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, QUERY, QUOTED_STRING, RANGE, RIGHT, ROW_STAR, SELECT, SELECT_FROM, SET, SOME, SQL_NE, STAR, SUM, THEN, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Method Summary
static HqlParser | getInstance(String hql)
ParseErrorHandler | getParseErrorHandler()
void | handleDotIdent() This method looks ahead and converts .
antlr.collections.AST | handleIdentifierError(antlr.Token token, antlr.RecognitionException ex) Overrides the base behavior to retry keywords as identifiers.
antlr.collections.AST | negateNode(antlr.collections.AST x) Returns an equivalent tree for (NOT (a relop b) ), for example:
static void | panic()
antlr.collections.AST | processEqualityExpression(antlr.collections.AST x) Post process equality expressions, clean up the subtree.
void | processMemberOf(antlr.Token n, antlr.collections.AST p, antlr.ASTPair currentAST)
void | reportError(antlr.RecognitionException e)
void | reportError(String s)
void | reportWarning(String s)
void | showAst(antlr.collections.AST ast, PrintStream out)
void | weakKeywords()
Methods inherited from class org.hibernate.hql.antlr.HqlBaseParser
additiveExpression, aggregate, alias, aliasedExpression, altWhenClause, asAlias, ascendingOrDescending, assignment, atom, betweenList, buildTokenTypeASTClassMap, caseExpression, collectionExpr, compoundExpr, concatenation, constant, deleteStatement, elseClause, equalityExpression, expression, expressionOrVector, exprList, fromClassOrOuterQueryPath, fromClause, fromJoin, fromRange, groupByClause, havingClause, identifier, identPrimary, inClassDeclaration, inCollectionDeclaration, inCollectionElementsDeclaration, inList, insertablePropertySpec, insertStatement, intoClause, isFilter, likeEscape, logicalAndExpression, logicalExpression, logicalOrExpression, multiplyExpression, negatedExpression, newExpression, newValue, optionalFromTokenFromClause, orderByClause, orderElement, path, primaryExpression, propertyFetch, quantifiedExpression, queryRule, relationalExpression, selectClause, selectedPropertiesList, selectFrom, selectObject, selectStatement, setClause, setFilter, stateField, statement, subQuery, unaryExpression, union, updateStatement, vectorExpr, whenClause, whereClause, withClause
Methods inherited from class antlr.LLkParser
consume, LA, LT, traceIn, traceOut
Methods inherited from class antlr.Parser
addMessageListener, addParserListener, addParserMatchListener, addParserTokenListener, addSemanticPredicateListener, addSyntacticPredicateListener, addTraceListener, consumeUntil, consumeUntil, defaultDebuggingSetup, getAST, getASTFactory, getFilename, getInputState, getTokenName, getTokenNames, getTokenTypeToASTClassMap, isDebugMode, mark, match, match, matchNot, recover, removeMessageListener, removeParserListener, removeParserMatchListener, removeParserTokenListener, removeSemanticPredicateListener, removeSyntacticPredicateListener, removeTraceListener, rewind, setASTFactory, setASTNodeClass, setASTNodeType, setDebugMode, setFilename, setIgnoreInvalidDebugCalls, setInputState, setTokenBuffer, traceIndent
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getInstance

public static HqlParser getInstance(String hql)

reportError

public void reportError(antlr.RecognitionException e)

reportError

public void reportError(String s)

reportWarning

public void reportWarning(String s)

getParseErrorHandler

public ParseErrorHandler getParseErrorHandler()

handleIdentifierError

public antlr.collections.AST handleIdentifierError(antlr.Token token,
                                                   antlr.RecognitionException ex)
                                            throws antlr.RecognitionException,
                                                   antlr.TokenStreamException
Overrides the base behavior to retry keywords as identifiers.

Overrides:
handleIdentifierError in class HqlBaseParser
Parameters:
token - The token.
ex - The recognition exception.
Returns:
AST - The new AST.
Throws:
antlr.RecognitionException - if the substitution was not possible.
antlr.TokenStreamException - if the substitution was not possible.

negateNode

public antlr.collections.AST negateNode(antlr.collections.AST x)
Returns an equivalent tree for (NOT (a relop b) ), for example:
 (NOT (GT a b) ) => (LE a b)

Overrides:
negateNode in class HqlBaseParser
Parameters:
x - The sub tree to transform, the parent is assumed to be NOT.
Returns:
AST - The equivalent sub-tree.

processEqualityExpression

public antlr.collections.AST processEqualityExpression(antlr.collections.AST x)
Post process equality expressions, clean up the subtree.

Overrides:
processEqualityExpression in class HqlBaseParser
Parameters:
x - The equality expression.
Returns:
AST - The clean sub-tree.

showAst

public void showAst(antlr.collections.AST ast,
                    PrintStream out)

weakKeywords

public void weakKeywords()
                  throws antlr.TokenStreamException
Overrides:
weakKeywords in class HqlBaseParser
Throws:
antlr.TokenStreamException

handleDotIdent

public void handleDotIdent()
                    throws antlr.TokenStreamException
Description copied from class: HqlBaseParser
This method looks ahead and converts . into . IDENT when appropriate.

Overrides:
handleDotIdent in class HqlBaseParser
Throws:
antlr.TokenStreamException

processMemberOf

public void processMemberOf(antlr.Token n,
                            antlr.collections.AST p,
                            antlr.ASTPair currentAST)
Overrides:
processMemberOf in class HqlBaseParser

panic

public static void panic()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HqlSqlWalker (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class HqlSqlWalker

java.lang.Object
    extended by antlr.TreeParser
        extended by org.hibernate.hql.antlr.HqlSqlBaseWalker
            extended by org.hibernate.hql.ast.HqlSqlWalker
All Implemented Interfaces:
ErrorReporter, HqlSqlTokenTypes, ParameterBinder.NamedParameterSource
public class HqlSqlWalker
extends HqlSqlBaseWalker
implements ErrorReporter, ParameterBinder.NamedParameterSource

Implements methods used by the HQL->SQL tree transform grammar (a.k.a. the second phase).

  • Isolates the Hibernate API-specific code from the ANTLR generated code.
  • Handles the SQL framgents generated by the persisters in order to create the SELECT and FROM clauses, taking into account the joins and projections that are implied by the mappings (persister/queryable).
  • Uses SqlASTFactory to create customized AST nodes.

See Also:
SqlASTFactory

Field Summary
Fields inherited from class org.hibernate.hql.antlr.HqlSqlBaseWalker
_tokenNames, _tokenSet_0
Fields inherited from class antlr.TreeParser
_retTree, astFactory, ASTNULL, inputState, returnAST, tokenNames, traceDepth
Fields inherited from interface org.hibernate.hql.antlr.HqlSqlTokenTypes
AGGREGATE, ALIAS, ALIAS_REF, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOGUS, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FILTERS, FLOAT_SUFFIX, FROM, FROM_FRAGMENT, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IMPLIED_FROM, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, JOIN_FRAGMENT, LE, LEADING, LEFT, LEFT_OUTER, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, METHOD_NAME, MIN, MINUS, NAMED_PARAM, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, PROPERTY_REF, QUERY, QUOTED_STRING, RANGE, RIGHT, RIGHT_OUTER, ROW_STAR, SELECT, SELECT_CLAUSE, SELECT_COLUMNS, SELECT_EXPR, SELECT_FROM, SET, SOME, SQL_NE, SQL_TOKEN, STAR, SUM, THEN, THETA_JOINS, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
HqlSqlWalker(QueryTranslatorImpl qti, SessionFactoryImplementor sfi, HqlParser parser, Map tokenReplacements, String collectionRole)
Create a new tree transformer.
Method Summary
void | addQuerySpaces(Serializable[] spaces)
protected void | beforeSelectClause()
protected antlr.collections.AST | createFromElement(String path, antlr.collections.AST alias, antlr.collections.AST propertyFetch)
protected antlr.collections.AST | createFromFilterElement(antlr.collections.AST filterEntity, antlr.collections.AST alias)
protected void | createFromJoinElement(antlr.collections.AST path, antlr.collections.AST alias, int joinType, antlr.collections.AST fetchNode, antlr.collections.AST propertyFetch, antlr.collections.AST with)
protected antlr.collections.AST | createIntoClause(String path, antlr.collections.AST propertySpec)
protected void | evaluateAssignment(antlr.collections.AST eq)
protected antlr.collections.AST | generateNamedParameter(antlr.collections.AST delimiterNode, antlr.collections.AST nameNode)
protected antlr.collections.AST | generatePositionalParameter(antlr.collections.AST inputNode)
AliasGenerator | getAliasGenerator()
ArrayList | getAssignmentSpecifications()
ASTPrinter | getASTPrinter()
FromClause | getCurrentFromClause()
Map | getEnabledFilters()
FromClause | getFinalFromClause()
int | getImpliedJoinType()
LiteralProcessor | getLiteralProcessor()
int[] | getNamedParameterLocations(String name) Returns the locations of all occurrences of the named parameter.
int | getNumberOfParametersInSetClause()
ArrayList | getParameters()
ParseErrorHandler | getParseErrorHandler()
Set | getQuerySpaces() Returns the set of unique query spaces (a.k.a.
String[] | getReturnAliases()
Type[] | getReturnTypes()
SelectClause | getSelectClause()
SessionFactoryHelper | getSessionFactoryHelper()
Map | getTokenReplacements()
protected boolean | isNonQualifiedPropertyRef(antlr.collections.AST ident)
boolean | isShallowQuery()
protected void | lookupAlias(antlr.collections.AST aliasRef)
protected antlr.collections.AST | lookupNonQualifiedProperty(antlr.collections.AST property)
protected antlr.collections.AST | lookupProperty(antlr.collections.AST dot, boolean root, boolean inSelect)
static void | panic()
protected void | postProcessDelete(antlr.collections.AST delete)
protected void | postProcessDML(RestrictableStatement statement)
protected void | postProcessInsert(antlr.collections.AST insert)
protected void | postProcessUpdate(antlr.collections.AST update)
protected void | prepareArithmeticOperator(antlr.collections.AST operator)
protected void | prepareFromClauseInputTree(antlr.collections.AST fromClauseInput) Pre-process the from clause input tree.
protected void | prepareLogicOperator(antlr.collections.AST operator)
protected void | prepareVersioned(antlr.collections.AST updateNode, antlr.collections.AST versioned)
protected void | processBoolean(antlr.collections.AST constant)
protected void | processConstant(antlr.collections.AST constant)
protected void | processConstructor(antlr.collections.AST constructor)
protected void | processFunction(antlr.collections.AST functionCall, boolean inSelect)
protected void | processIndex(antlr.collections.AST indexOp)
protected void | processNumericLiteral(antlr.collections.AST literal)
protected void | processQuery(antlr.collections.AST select, antlr.collections.AST query)
protected void | pushFromClause(antlr.collections.AST fromNode, antlr.collections.AST inputFromNode) Sets the current 'FROM' context.
void | reportError(antlr.RecognitionException e)
void | reportError(String s)
void | reportWarning(String s)
protected void | resolve(antlr.collections.AST node)
protected void | resolveSelectExpression(antlr.collections.AST node)
protected void | setAlias(antlr.collections.AST selectExpr, antlr.collections.AST ident)
protected void | setImpliedJoinType(int joinType)
static boolean | supportsIdGenWithBulkInsertion(IdentifierGenerator generator)
Methods inherited from class org.hibernate.hql.antlr.HqlSqlBaseWalker
addrExpr, addrExprLhs, aggregateExpr, aliasedSelectExpr, aliasRef, arithmeticExpr, assignment, caseExpr, collectionFunction, collectionFunctionOrSubselect, comparisonExpr, constant, constructor, count, deleteStatement, expr, exprOrSubquery, fromClause, fromElement, fromElementList, functionCall, getCurrentClauseType, getCurrentStatementType, getCurrentTopLevelClauseType, getStatementType, groupClause, identifier, inRhs, insertablePropertySpec, insertStatement, intoClause, isComparativeExpressionClause, isInCase, isInFrom, isInFunctionCall, isInSelect, isSelectStatement, isSubQuery, joinElement, joinType, literal, logicalExpr, newValue, numericInteger, orderClause, orderExprs, parameter, path, pathAsIdent, propertyName, propertyRef, propertyRefLhs, query, selectClause, selectExpr, selectExprList, selectStatement, setClause, statement, updateStatement, whereClause, withClause
Methods inherited from class antlr.TreeParser
getAST, getASTFactory, getTokenName, getTokenNames, match, match, matchNot, setASTFactory, setASTNodeClass, setASTNodeType, traceIn, traceIndent, traceOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HqlSqlWalker

public HqlSqlWalker(QueryTranslatorImpl qti,
                    SessionFactoryImplementor sfi,
                    HqlParser parser,
                    Map tokenReplacements,
                    String collectionRole)
Create a new tree transformer.

Parameters:
qti - Back pointer to the query translator implementation that is using this tree transform.
sfi - The session factory implementor where the Hibernate mappings can be found.
parser -
tokenReplacements - Registers the token replacement map with the walker. This map will be used to substitute function names and constants.
collectionRole - the role name of the collection used as the basis for the filter, NULL if this
Method Detail

prepareFromClauseInputTree

protected void prepareFromClauseInputTree(antlr.collections.AST fromClauseInput)
Description copied from class: HqlSqlBaseWalker
Pre-process the from clause input tree.

Overrides:
prepareFromClauseInputTree in class HqlSqlBaseWalker

getSessionFactoryHelper

public SessionFactoryHelper getSessionFactoryHelper()

getTokenReplacements

public Map getTokenReplacements()

getAliasGenerator

public AliasGenerator getAliasGenerator()

getCurrentFromClause

public FromClause getCurrentFromClause()

getParseErrorHandler

public ParseErrorHandler getParseErrorHandler()

reportError

public void reportError(antlr.RecognitionException e)
Specified by:
reportError in interface ErrorReporter

reportError

public void reportError(String s)
Specified by:
reportError in interface ErrorReporter

reportWarning

public void reportWarning(String s)
Specified by:
reportWarning in interface ErrorReporter

getQuerySpaces

public Set getQuerySpaces()
Returns the set of unique query spaces (a.k.a. table names) that occurred in the query.

Returns:
A set of table names (Strings).

createFromElement

protected antlr.collections.AST createFromElement(String path,
                                                  antlr.collections.AST alias,
                                                  antlr.collections.AST propertyFetch)
                                           throws antlr.SemanticException
Overrides:
createFromElement in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

createFromFilterElement

protected antlr.collections.AST createFromFilterElement(antlr.collections.AST filterEntity,
                                                        antlr.collections.AST alias)
                                                 throws antlr.SemanticException
Overrides:
createFromFilterElement in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

createFromJoinElement

protected void createFromJoinElement(antlr.collections.AST path,
                                     antlr.collections.AST alias,
                                     int joinType,
                                     antlr.collections.AST fetchNode,
                                     antlr.collections.AST propertyFetch,
                                     antlr.collections.AST with)
                              throws antlr.SemanticException
Overrides:
createFromJoinElement in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

pushFromClause

protected void pushFromClause(antlr.collections.AST fromNode,
                              antlr.collections.AST inputFromNode)
Sets the current 'FROM' context.

Overrides:
pushFromClause in class HqlSqlBaseWalker
Parameters:
fromNode - The new 'FROM' context.
inputFromNode - The from node from the input AST.

lookupAlias

protected void lookupAlias(antlr.collections.AST aliasRef)
                    throws antlr.SemanticException
Overrides:
lookupAlias in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

setImpliedJoinType

protected void setImpliedJoinType(int joinType)
Overrides:
setImpliedJoinType in class HqlSqlBaseWalker

getImpliedJoinType

public int getImpliedJoinType()

lookupProperty

protected antlr.collections.AST lookupProperty(antlr.collections.AST dot,
                                               boolean root,
                                               boolean inSelect)
                                        throws antlr.SemanticException
Overrides:
lookupProperty in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

isNonQualifiedPropertyRef

protected boolean isNonQualifiedPropertyRef(antlr.collections.AST ident)
Overrides:
isNonQualifiedPropertyRef in class HqlSqlBaseWalker

lookupNonQualifiedProperty

protected antlr.collections.AST lookupNonQualifiedProperty(antlr.collections.AST property)
                                                    throws antlr.SemanticException
Overrides:
lookupNonQualifiedProperty in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

processQuery

protected void processQuery(antlr.collections.AST select,
                            antlr.collections.AST query)
                     throws antlr.SemanticException
Overrides:
processQuery in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

postProcessDML

protected void postProcessDML(RestrictableStatement statement)
                       throws antlr.SemanticException
Throws:
antlr.SemanticException

postProcessUpdate

protected void postProcessUpdate(antlr.collections.AST update)
                          throws antlr.SemanticException
Overrides:
postProcessUpdate in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

postProcessDelete

protected void postProcessDelete(antlr.collections.AST delete)
                          throws antlr.SemanticException
Overrides:
postProcessDelete in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

supportsIdGenWithBulkInsertion

public static boolean supportsIdGenWithBulkInsertion(IdentifierGenerator generator)

postProcessInsert

protected void postProcessInsert(antlr.collections.AST insert)
                          throws antlr.SemanticException,
                                 QueryException
Overrides:
postProcessInsert in class HqlSqlBaseWalker
Throws:
antlr.SemanticException
QueryException

resolve

protected void resolve(antlr.collections.AST node)
                throws antlr.SemanticException
Overrides:
resolve in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

resolveSelectExpression

protected void resolveSelectExpression(antlr.collections.AST node)
                                throws antlr.SemanticException
Overrides:
resolveSelectExpression in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

beforeSelectClause

protected void beforeSelectClause()
                           throws antlr.SemanticException
Overrides:
beforeSelectClause in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

generatePositionalParameter

protected antlr.collections.AST generatePositionalParameter(antlr.collections.AST inputNode)
                                                     throws antlr.SemanticException
Overrides:
generatePositionalParameter in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

generateNamedParameter

protected antlr.collections.AST generateNamedParameter(antlr.collections.AST delimiterNode,
                                                       antlr.collections.AST nameNode)
                                                throws antlr.SemanticException
Overrides:
generateNamedParameter in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

processConstant

protected void processConstant(antlr.collections.AST constant)
                        throws antlr.SemanticException
Overrides:
processConstant in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

processBoolean

protected void processBoolean(antlr.collections.AST constant)
                       throws antlr.SemanticException
Overrides:
processBoolean in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

processNumericLiteral

protected void processNumericLiteral(antlr.collections.AST literal)
Overrides:
processNumericLiteral in class HqlSqlBaseWalker

processIndex

protected void processIndex(antlr.collections.AST indexOp)
                     throws antlr.SemanticException
Overrides:
processIndex in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

processFunction

protected void processFunction(antlr.collections.AST functionCall,
                               boolean inSelect)
                        throws antlr.SemanticException
Overrides:
processFunction in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

processConstructor

protected void processConstructor(antlr.collections.AST constructor)
                           throws antlr.SemanticException
Overrides:
processConstructor in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

setAlias

protected void setAlias(antlr.collections.AST selectExpr,
                        antlr.collections.AST ident)
Overrides:
setAlias in class HqlSqlBaseWalker

getNamedParameterLocations

public int[] getNamedParameterLocations(String name)
                                 throws QueryException
Returns the locations of all occurrences of the named parameter.

Specified by:
getNamedParameterLocations in interface ParameterBinder.NamedParameterSource
Throws:
QueryException

addQuerySpaces

public void addQuerySpaces(Serializable[] spaces)

getReturnTypes

public Type[] getReturnTypes()

getReturnAliases

public String[] getReturnAliases()

getSelectClause

public SelectClause getSelectClause()

getFinalFromClause

public FromClause getFinalFromClause()

isShallowQuery

public boolean isShallowQuery()

getEnabledFilters

public Map getEnabledFilters()

getLiteralProcessor

public LiteralProcessor getLiteralProcessor()

getASTPrinter

public ASTPrinter getASTPrinter()

getParameters

public ArrayList getParameters()

getNumberOfParametersInSetClause

public int getNumberOfParametersInSetClause()

evaluateAssignment

protected void evaluateAssignment(antlr.collections.AST eq)
                           throws antlr.SemanticException
Overrides:
evaluateAssignment in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

getAssignmentSpecifications

public ArrayList getAssignmentSpecifications()

createIntoClause

protected antlr.collections.AST createIntoClause(String path,
                                                 antlr.collections.AST propertySpec)
                                          throws antlr.SemanticException
Overrides:
createIntoClause in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

prepareVersioned

protected void prepareVersioned(antlr.collections.AST updateNode,
                                antlr.collections.AST versioned)
                         throws antlr.SemanticException
Overrides:
prepareVersioned in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

prepareLogicOperator

protected void prepareLogicOperator(antlr.collections.AST operator)
                             throws antlr.SemanticException
Overrides:
prepareLogicOperator in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

prepareArithmeticOperator

protected void prepareArithmeticOperator(antlr.collections.AST operator)
                                  throws antlr.SemanticException
Overrides:
prepareArithmeticOperator in class HqlSqlBaseWalker
Throws:
antlr.SemanticException

panic

public static void panic()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HqlToken (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class HqlToken

java.lang.Object
    extended by antlr.Token
        extended by antlr.CommonToken
            extended by org.hibernate.hql.ast.HqlToken
All Implemented Interfaces:
Cloneable
public class HqlToken
extends antlr.CommonToken

A custom token class for the HQL grammar.

NOTE: This class must be public becuase it is instantiated by the ANTLR library. Ignore any suggestions by various code 'analyzers' about this class being package local.

Field Summary
Fields inherited from class antlr.CommonToken
col, line, text
Fields inherited from class antlr.Token
badToken, EOF_TYPE, INVALID_TYPE, MIN_USER_TYPE, NULL_TREE_LOOKAHEAD, SKIP, type
Constructor Summary
HqlToken()
Method Summary
boolean | isPossibleID() Returns true if the token could be an identifier.
void | setPossibleID(boolean possibleID) Set to true if this token can be interpreted as an identifier, false if not.
void | setType(int t) Sets the type of the token, remembering the previous type.
String | toString() Returns a string representation of the object.
Methods inherited from class antlr.CommonToken
getColumn, getLine, getText, setColumn, setLine, setText
Methods inherited from class antlr.Token
getFilename, getType, setFilename
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HqlToken

public HqlToken()
Method Detail

isPossibleID

public boolean isPossibleID()
Returns true if the token could be an identifier.

Returns:
True if the token could be interpreted as in identifier, false if not.

setType

public void setType(int t)
Sets the type of the token, remembering the previous type.

Parameters:
t - The new token type.

setPossibleID

public void setPossibleID(boolean possibleID)
Set to true if this token can be interpreted as an identifier, false if not.

Parameters:
possibleID - True if this is a keyword/identifier, false if not.

toString

public String toString()
Returns a string representation of the object.

Returns:
String - The debug string.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterTranslationsImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class ParameterTranslationsImpl

java.lang.Object
    extended by org.hibernate.hql.ast.ParameterTranslationsImpl
All Implemented Interfaces:
ParameterTranslations
public class ParameterTranslationsImpl
extends Object
implements ParameterTranslations

Defines the information available for parameters encountered during query translation through the antlr-based parser.

Author:
Steve Ebersole

Nested Class Summary
static class ParameterTranslationsImpl.ParameterInfo
Constructor Summary
ParameterTranslationsImpl(List parameterSpecifications)
Constructs a parameter metadata object given a list of parameter specifications.
Method Summary
Type | getNamedParameterExpectedType(String name)
ParameterTranslationsImpl.ParameterInfo | getNamedParameterInfo(String name)
Set | getNamedParameterNames()
int[] | getNamedParameterSqlLocations(String name)
int | getOrdinalParameterCount()
Type | getOrdinalParameterExpectedType(int ordinalPosition)
ParameterTranslationsImpl.ParameterInfo | getOrdinalParameterInfo(int ordinalPosition)
int | getOrdinalParameterSqlLocation(int ordinalPosition)
boolean | supportsOrdinalParameterMetadata()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParameterTranslationsImpl

public ParameterTranslationsImpl(List parameterSpecifications)
Constructs a parameter metadata object given a list of parameter specifications.

Note: the order in the incoming list denotes the parameter's psudeo-position within the resulting sql statement.

Parameters:
parameterSpecifications -
Method Detail

supportsOrdinalParameterMetadata

public boolean supportsOrdinalParameterMetadata()
Specified by:
supportsOrdinalParameterMetadata in interface ParameterTranslations

getOrdinalParameterCount

public int getOrdinalParameterCount()
Specified by:
getOrdinalParameterCount in interface ParameterTranslations

getOrdinalParameterInfo

public ParameterTranslationsImpl.ParameterInfo getOrdinalParameterInfo(int ordinalPosition)

getOrdinalParameterSqlLocation

public int getOrdinalParameterSqlLocation(int ordinalPosition)
Specified by:
getOrdinalParameterSqlLocation in interface ParameterTranslations

getOrdinalParameterExpectedType

public Type getOrdinalParameterExpectedType(int ordinalPosition)
Specified by:
getOrdinalParameterExpectedType in interface ParameterTranslations

getNamedParameterNames

public Set getNamedParameterNames()
Specified by:
getNamedParameterNames in interface ParameterTranslations

getNamedParameterInfo

public ParameterTranslationsImpl.ParameterInfo getNamedParameterInfo(String name)

getNamedParameterSqlLocations

public int[] getNamedParameterSqlLocations(String name)
Specified by:
getNamedParameterSqlLocations in interface ParameterTranslations

getNamedParameterExpectedType

public Type getNamedParameterExpectedType(String name)
Specified by:
getNamedParameterExpectedType in interface ParameterTranslations
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterTranslationsImpl.ParameterInfo (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class ParameterTranslationsImpl.ParameterInfo

java.lang.Object
    extended by org.hibernate.hql.ast.ParameterTranslationsImpl.ParameterInfo
All Implemented Interfaces:
Serializable
Enclosing class:
ParameterTranslationsImpl
public static class ParameterTranslationsImpl.ParameterInfo
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
ParameterTranslationsImpl.ParameterInfo(int[] sqlPositions, Type expectedType)
ParameterTranslationsImpl.ParameterInfo(int sqlPosition, Type expectedType)
Method Summary
Type | getExpectedType()
int[] | getSqlLocations()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParameterTranslationsImpl.ParameterInfo

public ParameterTranslationsImpl.ParameterInfo(int[] sqlPositions,
                                               Type expectedType)

ParameterTranslationsImpl.ParameterInfo

public ParameterTranslationsImpl.ParameterInfo(int sqlPosition,
                                               Type expectedType)
Method Detail

getSqlLocations

public int[] getSqlLocations()

getExpectedType

public Type getExpectedType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryTranslatorImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class QueryTranslatorImpl

java.lang.Object
    extended by org.hibernate.hql.ast.QueryTranslatorImpl
All Implemented Interfaces:
FilterTranslator, QueryTranslator
public class QueryTranslatorImpl
extends Object
implements FilterTranslator

A QueryTranslator that uses an Antlr-based parser.

Author:
Joshua Davis (pgmjsd@sourceforge.net)

Nested Class Summary
static class QueryTranslatorImpl.JavaConstantConverter
Field Summary
Fields inherited from interface org.hibernate.hql.QueryTranslator
ERROR_CANNOT_DETERMINE_TYPE, ERROR_CANNOT_FETCH_WITH_ITERATE, ERROR_CANNOT_FORMAT_LITERAL, ERROR_NAMED_PARAMETER_DOES_NOT_APPEAR
Constructor Summary
QueryTranslatorImpl(String queryIdentifier, String query, Map enabledFilters, SessionFactoryImplementor factory)
Creates a new AST-based query translator.
Method Summary
 List collectSqlStrings()
 void compile(Map replacements, boolean shallow)
Compile a "normal" query.
 void compile(String collectionRole, Map replacements, boolean shallow)
Compile a filter.
 boolean containsCollectionFetches()
Does the translated query contain collection fetches?
 int executeUpdate(QueryParameters queryParameters, SessionImplementor session)
Perform a bulk update/delete operation given the underlying query defintion.
 String[][] getColumnNames()
Returns the column names in the generated SQL.
 Map getEnabledFilters()
Returns the filters enabled for this query translator.
 int[] getNamedParameterLocs(String name)
 ParameterTranslations getParameterTranslations()
Return information about any parameters encountered during translation.
 String getQueryIdentifier()
Retrieve the query identifier for this translator.
 Set getQuerySpaces()
Returns the set of query spaces (table names) that the query referrs to.
 String getQueryString()
Returns the HQL string processed by the translator.
 String[] getReturnAliases()
Returns an array of HQL aliases
 Type[] getReturnTypes()
Types of the return values of an iterate() style query.
 Statement getSqlAST()
 String getSQLString()
The SQL query string to be called; implemented by all subclasses
 boolean isManipulationStatement()
 boolean isShallowQuery()
 Iterator iterate(QueryParameters queryParameters, EventSource session)
Return the query results as an iterator
 List list(SessionImplementor session, QueryParameters queryParameters)
Perform a list operation given the underlying query definition.
 ScrollableResults scroll(QueryParameters queryParameters, SessionImplementor session)
Return the query results, as an instance of ScrollableResults
 void validateScrollability()
Validate the scrollability of the translated query.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryTranslatorImpl

public QueryTranslatorImpl(String queryIdentifier,
                           String query,
                           Map enabledFilters,
                           SessionFactoryImplementor factory)
Creates a new AST-based query translator.

Parameters:
queryIdentifier - The query-identifier (used in stats collection)
query - The hql query to translate
enabledFilters - Currently enabled filters
factory - The session factory constructing this translator instance.
Method Detail

compile

public void compile(Map replacements,
                    boolean shallow)
             throws QueryException,
                    MappingException
Compile a "normal" query. This method may be called multiple times. Subsequent invocations are no-ops.

Specified by:
compile in interface QueryTranslator
Parameters:
replacements - Defined query substitutions.
shallow - Does this represent a shallow (scalar or entity-id) select?
Throws:
QueryException - There was a problem parsing the query string.
MappingException - There was a problem querying defined mappings.

compile

public void compile(String collectionRole,
                    Map replacements,
                    boolean shallow)
             throws QueryException,
                    MappingException
Compile a filter. This method may be called multiple times. Subsequent invocations are no-ops.

Specified by:
compile in interface FilterTranslator
Parameters:
collectionRole - the role name of the collection used as the basis for the filter.
replacements - Defined query substitutions.
shallow - Does this represent a shallow (scalar or entity-id) select?
Throws:
QueryException - There was a problem parsing the query string.
MappingException - There was a problem querying defined mappings.

getQueryIdentifier

public String getQueryIdentifier()
Description copied from interface: QueryTranslator
Retrieve the query identifier for this translator. The query identifier is used in stats collection.

Specified by:
getQueryIdentifier in interface QueryTranslator
Returns:
the identifier

getSqlAST

public Statement getSqlAST()

getReturnTypes

public Type[] getReturnTypes()
Types of the return values of an iterate() style query.

Specified by:
getReturnTypes in interface QueryTranslator
Returns:
an array of Types.

getReturnAliases

public String[] getReturnAliases()
Description copied from interface: QueryTranslator
Returns an array of HQL aliases

Specified by:
getReturnAliases in interface QueryTranslator

getColumnNames

public String[][] getColumnNames()
Description copied from interface: QueryTranslator
Returns the column names in the generated SQL.

Specified by:
getColumnNames in interface QueryTranslator
Returns:
the column names in the generated SQL.

getQuerySpaces

public Set getQuerySpaces()
Description copied from interface: QueryTranslator
Returns the set of query spaces (table names) that the query referrs to.

Specified by:
getQuerySpaces in interface QueryTranslator
Returns:
A set of query spaces (table names).

list

public List list(SessionImplementor session,
                 QueryParameters queryParameters)
          throws HibernateException
Description copied from interface: QueryTranslator
Perform a list operation given the underlying query definition.

Specified by:
list in interface QueryTranslator
Parameters:
session - The session owning this query.
queryParameters - The query bind parameters.
Returns:
The query list results.
Throws:
HibernateException

iterate

public Iterator iterate(QueryParameters queryParameters,
                        EventSource session)
                 throws HibernateException
Return the query results as an iterator

Specified by:
iterate in interface QueryTranslator
Parameters:
queryParameters - The query bind parameters.
session - The session owning this query.
Returns:
An iterator over the query results.
Throws:
HibernateException

scroll

public ScrollableResults scroll(QueryParameters queryParameters,
                                SessionImplementor session)
                         throws HibernateException
Return the query results, as an instance of ScrollableResults

Specified by:
scroll in interface QueryTranslator
Parameters:
queryParameters - The query bind parameters.
session - The session owning this query.
Returns:
The ScrollableResults wrapper around the query results.
Throws:
HibernateException

executeUpdate

public int executeUpdate(QueryParameters queryParameters,
                         SessionImplementor session)
                  throws HibernateException
Description copied from interface: QueryTranslator
Perform a bulk update/delete operation given the underlying query defintion.

Specified by:
executeUpdate in interface QueryTranslator
Parameters:
queryParameters - The query bind parameters.
session - The session owning this query.
Returns:
The number of entities updated or deleted.
Throws:
HibernateException

getSQLString

public String getSQLString()
The SQL query string to be called; implemented by all subclasses

Specified by:
getSQLString in interface QueryTranslator
Returns:
the SQL string generated by the translator.

collectSqlStrings

public List collectSqlStrings()
Specified by:
collectSqlStrings in interface QueryTranslator

isShallowQuery

public boolean isShallowQuery()

getQueryString

public String getQueryString()
Description copied from interface: QueryTranslator
Returns the HQL string processed by the translator.

Specified by:
getQueryString in interface QueryTranslator
Returns:
the HQL string processed by the translator.

getEnabledFilters

public Map getEnabledFilters()
Description copied from interface: QueryTranslator
Returns the filters enabled for this query translator.

Specified by:
getEnabledFilters in interface QueryTranslator
Returns:
Filters enabled for this query execution.

getNamedParameterLocs

public int[] getNamedParameterLocs(String name)

containsCollectionFetches

public boolean containsCollectionFetches()
Description copied from interface: QueryTranslator
Does the translated query contain collection fetches?

Specified by:
containsCollectionFetches in interface QueryTranslator
Returns:
tru if the query does contain collection fetched; false otherwise.

isManipulationStatement

public boolean isManipulationStatement()
Specified by:
isManipulationStatement in interface QueryTranslator

validateScrollability

public void validateScrollability()
                           throws HibernateException
Description copied from interface: QueryTranslator
Validate the scrollability of the translated query.

Specified by:
validateScrollability in interface QueryTranslator
Throws:
HibernateException

getParameterTranslations

public ParameterTranslations getParameterTranslations()
Description copied from interface: QueryTranslator
Return information about any parameters encountered during translation.

Specified by:
getParameterTranslations in interface QueryTranslator
Returns:
The parameter information.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryTranslatorImpl.JavaConstantConverter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class QueryTranslatorImpl.JavaConstantConverter

java.lang.Object
    extended by org.hibernate.hql.ast.QueryTranslatorImpl.JavaConstantConverter
All Implemented Interfaces:
NodeTraverser.VisitationStrategy
Enclosing class:
QueryTranslatorImpl
public static class QueryTranslatorImpl.JavaConstantConverter
extends Object
implements NodeTraverser.VisitationStrategy

Constructor Summary
QueryTranslatorImpl.JavaConstantConverter()
Method Summary
 void visit(antlr.collections.AST node)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryTranslatorImpl.JavaConstantConverter

public QueryTranslatorImpl.JavaConstantConverter()
Method Detail

visit

public void visit(antlr.collections.AST node)
Specified by:
visit in interface NodeTraverser.VisitationStrategy
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SqlASTFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class SqlASTFactory

java.lang.Object
    extended by antlr.ASTFactory
        extended by org.hibernate.hql.ast.SqlASTFactory
All Implemented Interfaces:
HqlSqlTokenTypes
public class SqlASTFactory
extends antlr.ASTFactory
implements HqlSqlTokenTypes

Custom AST factory the intermediate tree that causes ANTLR to create specialized AST nodes, given the AST node type (from HqlSqlTokenTypes). HqlSqlWalker registers this factory with itself when it is initialized.

Author:
Joshua

Field Summary
Fields inherited from class antlr.ASTFactory
theASTNodeType, theASTNodeTypeClass, tokenTypeToASTClassMap
Fields inherited from interface org.hibernate.hql.antlr.HqlSqlTokenTypes
AGGREGATE, ALIAS, ALIAS_REF, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOGUS, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FILTERS, FLOAT_SUFFIX, FROM, FROM_FRAGMENT, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IMPLIED_FROM, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, JOIN_FRAGMENT, LE, LEADING, LEFT, LEFT_OUTER, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, METHOD_NAME, MIN, MINUS, NAMED_PARAM, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, PROPERTY_REF, QUERY, QUOTED_STRING, RANGE, RIGHT, RIGHT_OUTER, ROW_STAR, SELECT, SELECT_CLAUSE, SELECT_COLUMNS, SELECT_EXPR, SELECT_FROM, SET, SOME, SQL_NE, SQL_TOKEN, STAR, SUM, THEN, THETA_JOINS, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
SqlASTFactory(HqlSqlWalker walker)
Create factory with a specific mapping from token type to Java AST node type.
Method Summary
protected antlr.collections.AST | create(Class c) Actually instantiate the AST node.
protected antlr.collections.AST | createUsingCtor(antlr.Token token, String className)
Class | getASTNodeType(int tokenType) Returns the class for a given token type (a.k.a.
Methods inherited from class antlr.ASTFactory
addASTChild, create, create, create, create, create, create, create, create, dup, dupList, dupTree, error, getTokenTypeToASTClassMap, make, make, makeASTRoot, setASTNodeClass, setASTNodeClass, setASTNodeType, setTokenTypeASTNodeType, setTokenTypeToASTClassMap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SqlASTFactory

public SqlASTFactory(HqlSqlWalker walker)
Create factory with a specific mapping from token type to Java AST node type. Your subclasses of ASTFactory can override and reuse the map stuff.

Method Detail

getASTNodeType

public Class getASTNodeType(int tokenType)
Returns the class for a given token type (a.k.a. AST node type).

Parameters:
tokenType - The token type.
Returns:
Class - The AST node class to instantiate.

createUsingCtor

protected antlr.collections.AST createUsingCtor(antlr.Token token,
                                                String className)

create

protected antlr.collections.AST create(Class c)
Actually instantiate the AST node.

Parameters:
c - The class to instantiate.
Returns:
The instantiated and initialized node.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SqlGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class SqlGenerator

java.lang.Object
    extended by antlr.TreeParser
        extended by org.hibernate.hql.antlr.SqlGeneratorBase
            extended by org.hibernate.hql.ast.SqlGenerator
All Implemented Interfaces:
ErrorReporter, SqlTokenTypes
public class SqlGenerator
extends SqlGeneratorBase
implements ErrorReporter

Generates SQL by overriding callback methods in the base class, which does the actual SQL AST walking.

Author:
Joshua Davis, Steve Ebersole

Field Summary
Fields inherited from class org.hibernate.hql.antlr.SqlGeneratorBase
_tokenNames, _tokenSet_0, _tokenSet_1, _tokenSet_2, _tokenSet_3, _tokenSet_4, _tokenSet_5
Fields inherited from class antlr.TreeParser
_retTree, astFactory, ASTNULL, inputState, returnAST, tokenNames, traceDepth
Fields inherited from interface org.hibernate.hql.antlr.SqlTokenTypes
AGGREGATE, ALIAS, ALIAS_REF, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOGUS, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FILTERS, FLOAT_SUFFIX, FROM, FROM_FRAGMENT, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IMPLIED_FROM, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, JOIN_FRAGMENT, LE, LEADING, LEFT, LEFT_OUTER, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, METHOD_NAME, MIN, MINUS, NAMED_PARAM, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, PROPERTY_REF, QUERY, QUOTED_STRING, RANGE, RIGHT, RIGHT_OUTER, ROW_STAR, SELECT, SELECT_CLAUSE, SELECT_COLUMNS, SELECT_EXPR, SELECT_FROM, SET, SOME, SQL_NE, SQL_NODE, SQL_TOKEN, STAR, SUM, THEN, THETA_JOINS, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
SqlGenerator(SessionFactoryImplementor sfi)
Method Summary
protected void | beginFunctionTemplate(antlr.collections.AST m, antlr.collections.AST i)
protected void | commaBetweenParameters(String comma)
protected void | endFunctionTemplate(antlr.collections.AST m)
protected void | fromFragmentSeparator(antlr.collections.AST a)
ParseErrorHandler | getParseErrorHandler()
String | getSQL()
protected void | nestedFromFragment(antlr.collections.AST d, antlr.collections.AST parent)
protected void | optionalSpace() Add a aspace if the previous token was not a space or a parenthesis.
protected void | out(antlr.collections.AST n)
protected void | out(String s)
static void | panic()
void | reportError(antlr.RecognitionException e)
void | reportError(String s)
void | reportWarning(String s)
Methods inherited from class org.hibernate.hql.antlr.SqlGeneratorBase
additiveExpr, addrExpr, aggregate, arguments, arithmeticExpr, binaryComparisonExpression, booleanExpr, booleanOp, caseExpr, comparisonExpr, conditionList, constant, count, countExpr, deleteStatement, distinctOrAll, exoticComparisonExpression, expr, filters, from, fromTable, getLastChar, getStringBuffer, groupExprs, hasText, inList, insertStatement, likeEscape, methodCall, multiplicativeExpr, nestedExpr, nestedExprAfterMinusDiv, nyi, orderDirection, orderExprs, parameter, parenSelect, quantified, selectAtom, selectClause, selectColumn, selectExpr, selectStatement, separator, setClause, simpleExpr, simpleExprList, sqlToken, statement, tableJoin, thetaJoins, updateStatement, whereClause, whereClauseExpr, whereExpr
Methods inherited from class antlr.TreeParser
getAST, getASTFactory, getTokenName, getTokenNames, match, match, matchNot, setASTFactory, setASTNodeClass, setASTNodeType, traceIn, traceIndent, traceOut
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SqlGenerator

public SqlGenerator(SessionFactoryImplementor sfi)
Method Detail

out

protected void out(String s)
Overrides:
out in class SqlGeneratorBase

out

protected void out(antlr.collections.AST n)
Overrides:
out in class SqlGeneratorBase

commaBetweenParameters

protected void commaBetweenParameters(String comma)
Overrides:
commaBetweenParameters in class SqlGeneratorBase

reportError

public void reportError(antlr.RecognitionException e)
Specified by:
reportError in interface ErrorReporter

reportError

public void reportError(String s)
Specified by:
reportError in interface ErrorReporter

reportWarning

public void reportWarning(String s)
Specified by:
reportWarning in interface ErrorReporter

getParseErrorHandler

public ParseErrorHandler getParseErrorHandler()

getSQL

public String getSQL()

optionalSpace

protected void optionalSpace()
Description copied from class: SqlGeneratorBase
Add a aspace if the previous token was not a space or a parenthesis.

Overrides:
optionalSpace in class SqlGeneratorBase

beginFunctionTemplate

protected void beginFunctionTemplate(antlr.collections.AST m,
                                     antlr.collections.AST i)
Overrides:
beginFunctionTemplate in class SqlGeneratorBase

endFunctionTemplate

protected void endFunctionTemplate(antlr.collections.AST m)
Overrides:
endFunctionTemplate in class SqlGeneratorBase

panic

public static void panic()

fromFragmentSeparator

protected void fromFragmentSeparator(antlr.collections.AST a)
Overrides:
fromFragmentSeparator in class SqlGeneratorBase

nestedFromFragment

protected void nestedFromFragment(antlr.collections.AST d,
                                  antlr.collections.AST parent)
Overrides:
nestedFromFragment in class SqlGeneratorBase
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DetailedSemanticException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class DetailedSemanticException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by antlr.ANTLRException
                extended by antlr.RecognitionException
                    extended by antlr.SemanticException
                        extended by org.hibernate.hql.ast.DetailedSemanticException
All Implemented Interfaces:
Serializable
public class DetailedSemanticException
extends antlr.SemanticException

Thrown when a call to the underlying Hibernate engine fails, indicating some form of semantic exception (e.g. a class name was not found in the current mappings, etc.).

See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.RecognitionException
column, fileName, line
Constructor Summary
DetailedSemanticException(String message)
DetailedSemanticException(String s, Throwable e)
Method Summary
void | printStackTrace() Prints a stack trace.
void | printStackTrace(PrintStream s) Prints a stack trace to the specified print stream.
void | printStackTrace(PrintWriter w) Prints this throwable and its backtrace to the specified print writer.
String | toString() Converts everything to a string.
Methods inherited from class antlr.RecognitionException
getColumn, getErrorMessage, getFilename, getLine
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DetailedSemanticException

public DetailedSemanticException(String message)

DetailedSemanticException

public DetailedSemanticException(String s,
                                 Throwable e)
Method Detail

toString

public String toString()
Converts everything to a string.

Returns:
a string.

printStackTrace

public void printStackTrace()
Prints a stack trace.

printStackTrace

public void printStackTrace(PrintStream s)
Prints a stack trace to the specified print stream.

Parameters:
s - the print stream.

printStackTrace

public void printStackTrace(PrintWriter w)
Prints this throwable and its backtrace to the specified print writer.

Parameters:
w - the print writer.s
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InvalidPathException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class InvalidPathException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by antlr.ANTLRException
                extended by antlr.RecognitionException
                    extended by antlr.SemanticException
                        extended by org.hibernate.hql.ast.InvalidPathException
All Implemented Interfaces:
Serializable
public class InvalidPathException
extends antlr.SemanticException

Exception thrown when an invalid path is found in a query.

Author:
josh Dec 5, 2004 7:05:34 PM
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.RecognitionException
column, fileName, line
Constructor Summary
InvalidPathException(String s)
Methods inherited from class antlr.RecognitionException
getColumn, getErrorMessage, getFilename, getLine, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidPathException

public InvalidPathException(String s)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuerySyntaxException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast
Class QuerySyntaxException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.QueryException
                            extended by org.hibernate.hql.ast.QuerySyntaxException
All Implemented Interfaces:
Nestable, Serializable
public class QuerySyntaxException
extends QueryException

Exception thrown when there is a syntax error in the HQL.

Author:
josh
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
QuerySyntaxException(String message)
QuerySyntaxException(String message, String hql)
Method Summary
static QuerySyntaxException | convert(antlr.RecognitionException e)
static QuerySyntaxException | convert(antlr.RecognitionException e, String hql)
Methods inherited from class org.hibernate.QueryException
getMessage, getQueryString, setQueryString
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

QuerySyntaxException

public QuerySyntaxException(String message)

QuerySyntaxException

public QuerySyntaxException(String message,
                            String hql)
Method Detail

convert

public static QuerySyntaxException convert(antlr.RecognitionException e)

convert

public static QuerySyntaxException convert(antlr.RecognitionException e,
                                           String hql)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.hql.ast.exec (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.hql.ast.exec

Interface Summary
StatementExecutor Encapsulates the strategy required to execute various types of update, delete, and insert statements issued through HQL.

Class Summary
AbstractStatementExecutor | Implementation of AbstractStatementExecutor.
BasicExecutor | Implementation of BasicExecutor.
MultiTableDeleteExecutor | Implementation of MultiTableDeleteExecutor.
MultiTableUpdateExecutor | Implementation of MultiTableUpdateExecutor.


org.hibernate.hql.ast.exec Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.hql.ast.exec

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.hql.ast.exec.AbstractStatementExecutor (implements org.hibernate.hql.ast.exec.StatementExecutor)
      • class org.hibernate.hql.ast.exec.BasicExecutor
      • class org.hibernate.hql.ast.exec.MultiTableDeleteExecutor
      • class org.hibernate.hql.ast.exec.MultiTableUpdateExecutor

Interface Hierarchy

  • interface org.hibernate.hql.ast.exec.StatementExecutor


Uses of Package org.hibernate.hql.ast.exec (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.hql.ast.exec

Packages that use org.hibernate.hql.ast.exec
org.hibernate.hql.ast.exec

Classes in org.hibernate.hql.ast.exec used by org.hibernate.hql.ast.exec
AbstractStatementExecutor
Implementation of AbstractStatementExecutor.
StatementExecutor
Encapsulates the strategy required to execute various types of update, delete, and insert statements issued through HQL.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


StatementExecutor (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.exec
Interface StatementExecutor

All Known Implementing Classes:
AbstractStatementExecutor
public interface StatementExecutor

Encapsulates the strategy required to execute various types of update, delete, and insert statements issued through HQL.

Author:
Steve Ebersole

Method Summary
int | execute(QueryParameters parameters, SessionImplementor session) Execute the sql managed by this executor using the given parameters.
String[] | getSqlStatements()

Method Detail

getSqlStatements

public String[] getSqlStatements()

execute

public int execute(QueryParameters parameters,
                   SessionImplementor session)
            throws HibernateException
Execute the sql managed by this executor using the given parameters.

Parameters:
parameters - Essentially bind information for this processing.
session - The session originating the request.
Returns:
The number of entities updated/deleted.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractStatementExecutor (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.exec
Class AbstractStatementExecutor

java.lang.Object
    extended by org.hibernate.hql.ast.exec.AbstractStatementExecutor
All Implemented Interfaces:
StatementExecutor
Direct Known Subclasses:
BasicExecutor, MultiTableDeleteExecutor, MultiTableUpdateExecutor
public abstract class AbstractStatementExecutor
extends Object
implements StatementExecutor

Implementation of AbstractStatementExecutor.

Author:
Steve Ebersole

Constructor Summary
AbstractStatementExecutor(HqlSqlWalker walker, org.apache.commons.logging.Log log)
Method Summary
protected void | coordinateSharedCacheCleanup(SessionImplementor session)
protected void | createTemporaryTableIfNecessary(Queryable persister, SessionImplementor session)
protected void | dropTemporaryTableIfNecessary(Queryable persister, SessionImplementor session)
protected String | generateIdInsertSelect(Queryable persister, String tableAlias, antlr.collections.AST whereClause)
protected String | generateIdSubselect(Queryable persister)
protected abstract Queryable[] | getAffectedQueryables()
protected SessionFactoryImplementor | getFactory()
protected HqlSqlWalker | getWalker()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.exec.StatementExecutor
execute, getSqlStatements

Constructor Detail

AbstractStatementExecutor

public AbstractStatementExecutor(HqlSqlWalker walker,
                                 org.apache.commons.logging.Log log)
Method Detail

getWalker

protected HqlSqlWalker getWalker()

getFactory

protected SessionFactoryImplementor getFactory()

getAffectedQueryables

protected abstract Queryable[] getAffectedQueryables()

generateIdInsertSelect

protected String generateIdInsertSelect(Queryable persister,
                                        String tableAlias,
                                        antlr.collections.AST whereClause)

generateIdSubselect

protected String generateIdSubselect(Queryable persister)

createTemporaryTableIfNecessary

protected void createTemporaryTableIfNecessary(Queryable persister,
                                               SessionImplementor session)

dropTemporaryTableIfNecessary

protected void dropTemporaryTableIfNecessary(Queryable persister,
                                             SessionImplementor session)

coordinateSharedCacheCleanup

protected void coordinateSharedCacheCleanup(SessionImplementor session)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BasicExecutor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.exec
Class BasicExecutor

java.lang.Object
    extended by org.hibernate.hql.ast.exec.AbstractStatementExecutor
        extended by org.hibernate.hql.ast.exec.BasicExecutor
All Implemented Interfaces:
StatementExecutor
public class BasicExecutor
extends AbstractStatementExecutor

Implementation of BasicExecutor.

Author:
Steve Ebersole

Constructor Summary
BasicExecutor(HqlSqlWalker walker, Queryable persister)
Method Summary
int | execute(QueryParameters parameters, SessionImplementor session) Execute the sql managed by this executor using the given parameters.
protected Queryable[] | getAffectedQueryables()
String[] | getSqlStatements()
Methods inherited from class org.hibernate.hql.ast.exec.AbstractStatementExecutor
coordinateSharedCacheCleanup, createTemporaryTableIfNecessary, dropTemporaryTableIfNecessary, generateIdInsertSelect, generateIdSubselect, getFactory, getWalker
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BasicExecutor

public BasicExecutor(HqlSqlWalker walker,
                     Queryable persister)
Method Detail

getSqlStatements

public String[] getSqlStatements()

execute

public int execute(QueryParameters parameters,
                   SessionImplementor session)
            throws HibernateException
Description copied from interface: StatementExecutor
Execute the sql managed by this executor using the given parameters.

Parameters:
parameters - Essentially bind information for this processing.
session - The session originating the request.
Returns:
The number of entities updated/deleted.
Throws:
HibernateException

getAffectedQueryables

protected Queryable[] getAffectedQueryables()
Specified by:
getAffectedQueryables in class AbstractStatementExecutor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MultiTableDeleteExecutor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.exec
Class MultiTableDeleteExecutor

java.lang.Object
    extended by org.hibernate.hql.ast.exec.AbstractStatementExecutor
        extended by org.hibernate.hql.ast.exec.MultiTableDeleteExecutor
All Implemented Interfaces:
StatementExecutor
public class MultiTableDeleteExecutor
extends AbstractStatementExecutor

Implementation of MultiTableDeleteExecutor.

Author:
Steve Ebersole

Constructor Summary
MultiTableDeleteExecutor(HqlSqlWalker walker)
Method Summary
int | execute(QueryParameters parameters, SessionImplementor session) Execute the sql managed by this executor using the given parameters.
protected Queryable[] | getAffectedQueryables()
String[] | getSqlStatements()
Methods inherited from class org.hibernate.hql.ast.exec.AbstractStatementExecutor
coordinateSharedCacheCleanup, createTemporaryTableIfNecessary, dropTemporaryTableIfNecessary, generateIdInsertSelect, generateIdSubselect, getFactory, getWalker
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MultiTableDeleteExecutor

public MultiTableDeleteExecutor(HqlSqlWalker walker)
Method Detail

getSqlStatements

public String[] getSqlStatements()

execute

public int execute(QueryParameters parameters,
                   SessionImplementor session)
            throws HibernateException
Description copied from interface: StatementExecutor
Execute the sql managed by this executor using the given parameters.

Parameters:
parameters - Essentially bind information for this processing.
session - The session originating the request.
Returns:
The number of entities updated/deleted.
Throws:
HibernateException

getAffectedQueryables

protected Queryable[] getAffectedQueryables()
Specified by:
getAffectedQueryables in class AbstractStatementExecutor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MultiTableUpdateExecutor (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.exec
Class MultiTableUpdateExecutor

java.lang.Object
    extended by org.hibernate.hql.ast.exec.AbstractStatementExecutor
        extended by org.hibernate.hql.ast.exec.MultiTableUpdateExecutor
All Implemented Interfaces:
StatementExecutor
public class MultiTableUpdateExecutor
extends AbstractStatementExecutor

Implementation of MultiTableUpdateExecutor.

Author:
Steve Ebersole

Constructor Summary
MultiTableUpdateExecutor(HqlSqlWalker walker)
Method Summary
int | execute(QueryParameters parameters, SessionImplementor session) Execute the sql managed by this executor using the given parameters.
Queryable | getAffectedQueryable()
protected Queryable[] | getAffectedQueryables()
String[] | getSqlStatements()
Methods inherited from class org.hibernate.hql.ast.exec.AbstractStatementExecutor
coordinateSharedCacheCleanup, createTemporaryTableIfNecessary, dropTemporaryTableIfNecessary, generateIdInsertSelect, generateIdSubselect, getFactory, getWalker
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MultiTableUpdateExecutor

public MultiTableUpdateExecutor(HqlSqlWalker walker)
Method Detail

getAffectedQueryable

public Queryable getAffectedQueryable()

getSqlStatements

public String[] getSqlStatements()

execute

public int execute(QueryParameters parameters,
                   SessionImplementor session)
            throws HibernateException
Description copied from interface: StatementExecutor
Execute the sql managed by this executor using the given parameters.

Parameters:
parameters - Essentially bind information for this processing.
session - The session originating the request.
Returns:
The number of entities updated/deleted.
Throws:
HibernateException

getAffectedQueryables

protected Queryable[] getAffectedQueryables()
Specified by:
getAffectedQueryables in class AbstractStatementExecutor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.hql.ast.tree (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.hql.ast.tree

Interface Summary
BinaryOperatorNode | Contract for nodes representing binary operators.
DisplayableNode | Implementors will return additional display text, which will be used by the ASTPrinter to display information (besides the node type and node text).
ExpectedTypeAwareNode | Interface for nodes which wish to be made aware of any determined "expected type" based on the context within they appear in the query.
InitializeableNode | An interface for initializeable AST nodes.
OperatorNode | Contract for nodes representing operators (logic or arithmetic).
PathNode | An AST node with a path property.
ResolvableNode | The contract for expression sub-trees that can resolve themselves.
RestrictableStatement | Type definition for Statements which are restrictable via a where-clause (and thus also having a from-clause).
SelectExpression | Represents an element of a projection list, i.e.
SessionFactoryAwareNode | Interface for nodes which require access to the SessionFactory
Statement | Common interface modeling the different HQL statements (i.e., INSERT, UPDATE, DELETE, SELECT).
UnaryOperatorNode | Contract for nodes representing unary operators.

Class Summary
AbstractRestrictableStatement | Convenience implementation of RestrictableStatement to centralize common functionality.
AbstractSelectExpression | Partial implementation of SelectExpression for all the nodes that aren't constructors.
AbstractStatement | Convenience implementation of Statement to centralize common functionality.
AggregateNode | Represents an aggregate function i.e.
AssignmentSpecification | Encapsulates the information relating to an individual assignment within the set clause of an HQL update statement.
BetweenOperatorNode | Contract for nodes representing logcial BETWEEN (ternary) operators.
BinaryArithmeticOperatorNode | Nodes which represent binary arithmetic operators.
BinaryLogicOperatorNode | Contract for nodes representing binary operators.
BooleanLiteralNode | Represents a boolean literal within a query.
Case2Node | Represents a case ...
CaseNode | Represents a case ...
CollectionFunction | Represents 'elements()' or 'indices()'.
ConstructorNode | Represents a constructor (new) in a SELECT.
CountNode | Represents a COUNT expression in a select.
DeleteStatement | Defines a top-level AST node representing an HQL delete statement.
DotNode | Represents a reference to a property or alias expression.
FromClause | Represents the 'FROM' part of a query or subquery, containing all mapped class references.
FromElement | Represents a single mapped class mentioned in an HQL FROM clause.
FromReferenceNode | Represents a reference to a FROM element, for example a class alias in a WHERE clause.
HqlSqlWalkerNode | A semantic analysis node, that points back to the main analyzer.
IdentNode | Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.
ImpliedFromElement | Represents a FROM element implied by a path expression or a collection reference.
IndexNode | Represents the [] operator and provides it's semantics.
InLogicOperatorNode |
InsertStatement | Defines a top-level AST node representing an HQL "insert select" statement.
IntoClause | Represents an entity referenced in the INTO clause of an HQL INSERT statement.
JavaConstantNode | A node representing a static Java constant.
LiteralNode | Represents a literal.
MethodNode | Represents a method call.
Node | Base node class for use by Hibernate within its AST trees.
OrderByClause | Implementation of OrderByClause.
ParameterNode | Implementation of ParameterNode.
QueryNode | Defines a top-level AST node representing an HQL select statement.
SelectClause | Represents the list of expressions in a SELECT clause.
SelectExpressionImpl | A select expression that was generated by a FROM element.
SelectExpressionList | Common behavior - a node that contains a list of select expressions.
SqlFragment | Represents an SQL fragment in the AST.
SqlNode | A base AST node for the intermediate tree.
UnaryArithmeticNode |
UnaryLogicOperatorNode |
UpdateStatement | Defines a top-level AST node representing an HQL update statement.


org.hibernate.hql.ast.tree Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.hql.ast.tree

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.hql.ast.tree.AssignmentSpecification
    • class antlr.BaseAST (implements antlr.collections.AST, java.io.Serializable)
      • class antlr.CommonAST
        • class org.hibernate.hql.ast.tree.Node
          • class org.hibernate.hql.ast.tree.JavaConstantNode (implements org.hibernate.hql.ast.tree.ExpectedTypeAwareNode, org.hibernate.hql.ast.tree.SessionFactoryAwareNode)
          • class org.hibernate.hql.ast.tree.SqlFragment
          • class org.hibernate.hql.ast.tree.SqlNode
            • class org.hibernate.hql.ast.tree.BetweenOperatorNode (implements org.hibernate.hql.ast.tree.OperatorNode)
            • class org.hibernate.hql.ast.tree.HqlSqlWalkerNode (implements org.hibernate.hql.ast.tree.InitializeableNode)
              • class org.hibernate.hql.ast.tree.AbstractSelectExpression (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.AggregateNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode (implements org.hibernate.hql.ast.tree.BinaryOperatorNode, org.hibernate.hql.ast.tree.DisplayableNode)
                • class org.hibernate.hql.ast.tree.Case2Node (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.CaseNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.CountNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.FromReferenceNode (implements org.hibernate.hql.ast.tree.DisplayableNode, org.hibernate.hql.ast.tree.InitializeableNode, org.hibernate.hql.ast.tree.PathNode, org.hibernate.hql.ast.tree.ResolvableNode)
                  • class org.hibernate.hql.ast.tree.DotNode (implements org.hibernate.hql.ast.tree.DisplayableNode, org.hibernate.hql.ast.tree.SelectExpression)
                  • class org.hibernate.hql.ast.tree.IdentNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                  • class org.hibernate.hql.ast.tree.IndexNode
                  • class org.hibernate.hql.ast.tree.SelectExpressionImpl (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.LiteralNode (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)
                  • class org.hibernate.hql.ast.tree.BooleanLiteralNode (implements org.hibernate.hql.ast.tree.ExpectedTypeAwareNode)
                • class org.hibernate.hql.ast.tree.MethodNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                  • class org.hibernate.hql.ast.tree.CollectionFunction (implements org.hibernate.hql.ast.tree.DisplayableNode)
                • class org.hibernate.hql.ast.tree.UnaryArithmeticNode (implements org.hibernate.hql.ast.tree.UnaryOperatorNode)
              • class org.hibernate.hql.ast.tree.AbstractStatement (implements org.hibernate.hql.ast.tree.DisplayableNode, org.hibernate.hql.ast.tree.Statement)
                • class org.hibernate.hql.ast.tree.AbstractRestrictableStatement (implements org.hibernate.hql.ast.tree.RestrictableStatement)
                  • class org.hibernate.hql.ast.tree.DeleteStatement
                  • class org.hibernate.hql.ast.tree.QueryNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                  • class org.hibernate.hql.ast.tree.UpdateStatement
                • class org.hibernate.hql.ast.tree.InsertStatement
              • class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode (implements org.hibernate.hql.ast.tree.BinaryOperatorNode)
                • class org.hibernate.hql.ast.tree.InLogicOperatorNode (implements org.hibernate.hql.ast.tree.BinaryOperatorNode)
              • class org.hibernate.hql.ast.tree.FromClause (implements org.hibernate.hql.ast.tree.DisplayableNode, org.hibernate.hql.antlr.HqlSqlTokenTypes)
              • class org.hibernate.hql.ast.tree.FromElement (implements org.hibernate.hql.ast.tree.DisplayableNode)
                • class org.hibernate.hql.ast.tree.ImpliedFromElement
              • class org.hibernate.hql.ast.tree.IntoClause (implements org.hibernate.hql.ast.tree.DisplayableNode)
              • class org.hibernate.hql.ast.tree.OrderByClause (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)
              • class org.hibernate.hql.ast.tree.ParameterNode (implements org.hibernate.hql.ast.tree.DisplayableNode, org.hibernate.hql.ast.tree.ExpectedTypeAwareNode)
              • class org.hibernate.hql.ast.tree.SelectExpressionList
                • class org.hibernate.hql.ast.tree.ConstructorNode (implements org.hibernate.hql.ast.tree.SelectExpression)
                • class org.hibernate.hql.ast.tree.SelectClause
            • class org.hibernate.hql.ast.tree.UnaryLogicOperatorNode (implements org.hibernate.hql.ast.tree.UnaryOperatorNode)

Interface Hierarchy

  • interface org.hibernate.hql.ast.tree.DisplayableNode
  • interface org.hibernate.hql.ast.tree.ExpectedTypeAwareNode
  • interface org.hibernate.hql.ast.tree.InitializeableNode
  • interface org.hibernate.hql.ast.tree.OperatorNode
    • interface org.hibernate.hql.ast.tree.BinaryOperatorNode
    • interface org.hibernate.hql.ast.tree.UnaryOperatorNode
  • interface org.hibernate.hql.ast.tree.PathNode
  • interface org.hibernate.hql.ast.tree.ResolvableNode
  • interface org.hibernate.hql.ast.tree.SelectExpression
  • interface org.hibernate.hql.ast.tree.SessionFactoryAwareNode
  • interface org.hibernate.hql.ast.tree.Statement
    • interface org.hibernate.hql.ast.tree.RestrictableStatement


Uses of Package org.hibernate.hql.ast.tree (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.hql.ast.tree

Packages that use org.hibernate.hql.ast.tree
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser

Classes in org.hibernate.hql.ast.tree used by org.hibernate.hql.ast
FromClause
Represents the 'FROM' part of a query or subquery, containing all mapped class references.
RestrictableStatement
Type definition for Statements which are restrictable via a where-clause (and thus also having a from-clause).
SelectClause
Represents the list of expressions in a SELECT clause.
Statement
Common interface modeling the different HQL statements (i.e., INSERT, UPDATE, DELETE, SELECT).

Classes in org.hibernate.hql.ast.tree used by org.hibernate.hql.ast.tree
AbstractRestrictableStatement
Convenience implementation of RestrictableStatement to centralize common functionality.
AbstractSelectExpression
Partial implementation of SelectExpression for all the nodes that aren't constructors.
AbstractStatement
Convenience implementation of Statement to centralize common functionality.
BinaryLogicOperatorNode
Contract for nodes representing binary operators.
BinaryOperatorNode
Contract for nodes representing binary operators.
DisplayableNode
Implementors will return additional display text, which will be used by the ASTPrinter to display information (besides the node type and node text).
ExpectedTypeAwareNode
Interface for nodes which wish to be made aware of any determined "expected type" based on the context within they appear in the query.
FromClause
Represents the 'FROM' part of a query or subquery, containing all mapped class references.
FromElement
Represents a single mapped class mentioned in an HQL FROM clause.
FromReferenceNode
Represents a reference to a FROM element, for example a class alias in a WHERE clause.
HqlSqlWalkerNode
A semantic analysis node, that points back to the main analyzer.
InitializeableNode
An interface for initializeable AST nodes.
IntoClause
Represents an entity referenced in the INTO clause of an HQL INSERT statement.
LiteralNode
Represents a literal.
MethodNode
Represents a method call.
Node
Base node class for use by Hibernate within its AST trees.
OperatorNode
Contract for nodes representing operators (logic or arithmetic).
OrderByClause
Implementation of OrderByClause.
PathNode
An AST node with a path property.
ResolvableNode
The contract for expression sub-trees that can resolve themselves.
RestrictableStatement
Type definition for Statements which are restrictable via a where-clause (and thus also having a from-clause).
SelectClause
Represents the list of expressions in a SELECT clause.
SelectExpression
Represents an element of a projection list, i.e.
SelectExpressionList
Common behavior - a node that contains a list of select expressions.
SessionFactoryAwareNode
Interface for nodes which require access to the SessionFactory
SqlNode
A base AST node for the intermediate tree.
Statement
Common interface modeling the different HQL statements (i.e., INSERT, UPDATE, DELETE, SELECT).
UnaryOperatorNode
Contract for nodes representing unary operators.

Classes in org.hibernate.hql.ast.tree used by org.hibernate.hql.ast.util
DotNode
Represents a reference to a property or alias expression.
FromElement
Represents a single mapped class mentioned in an HQL FROM clause.
HqlSqlWalkerNode
A semantic analysis node, that points back to the main analyzer.
QueryNode
Defines a top-level AST node representing an HQL select statement.
RestrictableStatement
Type definition for Statements which are restrictable via a where-clause (and thus also having a from-clause).

Classes in org.hibernate.hql.ast.tree used by org.hibernate.loader.hql
SelectClause
Represents the list of expressions in a SELECT clause.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BinaryOperatorNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Interface BinaryOperatorNode

All Superinterfaces:
OperatorNode
All Known Implementing Classes:
BinaryArithmeticOperatorNode, BinaryLogicOperatorNode, InLogicOperatorNode
public interface BinaryOperatorNode
extends OperatorNode

Contract for nodes representing binary operators.

Author:
Steve Ebersole

Method Summary
Node | getLeftHandOperand() Retrieves the left-hand operand of the operator.
Node | getRightHandOperand() Retrieves the right-hand operand of the operator.
Methods inherited from interface org.hibernate.hql.ast.tree.OperatorNode
getDataType, initialize

Method Detail

getLeftHandOperand

public Node getLeftHandOperand()
Retrieves the left-hand operand of the operator.

Returns:
The left-hand operand

getRightHandOperand

public Node getRightHandOperand()
Retrieves the right-hand operand of the operator.

Returns:
The right-hand operand
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DisplayableNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Interface DisplayableNode

All Known Implementing Classes:
AbstractStatement, BinaryArithmeticOperatorNode, CollectionFunction, DotNode, FromClause, FromElement, FromReferenceNode, IntoClause, ParameterNode
public interface DisplayableNode

Implementors will return additional display text, which will be used by the ASTPrinter to display information (besides the node type and node text).

Method Summary
 String getDisplayText()
Returns additional display text for the AST node.

Method Detail

getDisplayText

public String getDisplayText()
Returns additional display text for the AST node.

Returns:
String - The additional display text.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExpectedTypeAwareNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Interface ExpectedTypeAwareNode

All Known Implementing Classes:
BooleanLiteralNode, JavaConstantNode, ParameterNode
public interface ExpectedTypeAwareNode

Interface for nodes which wish to be made aware of any determined "expected type" based on the context within they appear in the query.

Author:
Steve Ebersole

Method Summary
Type | getExpectedType()
void | setExpectedType(Type expectedType)

Method Detail

setExpectedType

public void setExpectedType(Type expectedType)

getExpectedType

public Type getExpectedType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InitializeableNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Interface InitializeableNode

All Known Implementing Classes:
FromReferenceNode, HqlSqlWalkerNode
public interface InitializeableNode

An interface for initializeable AST nodes.

Method Summary
 void initialize(Object param)
Initializes the node with the parameter.

Method Detail

initialize

public void initialize(Object param)
Initializes the node with the parameter.

Parameters:
param - the initialization parameter.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OperatorNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Interface OperatorNode

All Known Subinterfaces:
BinaryOperatorNode, UnaryOperatorNode
All Known Implementing Classes:
BetweenOperatorNode, BinaryArithmeticOperatorNode, BinaryLogicOperatorNode, InLogicOperatorNode, UnaryArithmeticNode, UnaryLogicOperatorNode
public interface OperatorNode

Contract for nodes representing operators (logic or arithmetic).

Author:
Steve Ebersole

Method Summary
Type | getDataType() Retrieves the data type for the overall operator expression.
void | initialize() Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.

Method Detail

initialize

public void initialize()
                throws antlr.SemanticException
Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.

Throws:
antlr.SemanticException

getDataType

public Type getDataType()
Retrieves the data type for the overall operator expression.

Returns:
The expression's data type.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PathNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Interface PathNode

All Known Implementing Classes:
FromReferenceNode
public interface PathNode

An AST node with a path property. This path property will be the fully qualified name.

Author:
josh Nov 7, 2004 10:56:49 AM

Method Summary
 String getPath()
Returns the full path name represented by the node.

Method Detail

getPath

public String getPath()
Returns the full path name represented by the node.

Returns:
the full path name represented by the node.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolvableNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Interface ResolvableNode

All Known Implementing Classes:
FromReferenceNode
public interface ResolvableNode

The contract for expression sub-trees that can resolve themselves.

Author:
josh Sep 25, 2004 11:27:36 AM

Method Summary
void | resolve(boolean generateJoin, boolean implicitJoin) Does the work of resolving an identifier or a dot, but without a parent node or alias
void | resolve(boolean generateJoin, boolean implicitJoin, String classAlias) Does the work of resolving an identifier or a dot, but without a parent node
void | resolve(boolean generateJoin, boolean implicitJoin, String classAlias, antlr.collections.AST parent) Does the work of resolving an identifier or a dot
void | resolveIndex(antlr.collections.AST parent) Does the work of resolving an an index [].
void | resolveInFunctionCall(boolean generateJoin, boolean implicitJoin) Does the work of resolving inside of the scope of a function call

Method Detail

resolve

public void resolve(boolean generateJoin,
                    boolean implicitJoin,
                    String classAlias,
                    antlr.collections.AST parent)
             throws antlr.SemanticException
Does the work of resolving an identifier or a dot

Throws:
antlr.SemanticException

resolve

public void resolve(boolean generateJoin,
                    boolean implicitJoin,
                    String classAlias)
             throws antlr.SemanticException
Does the work of resolving an identifier or a dot, but without a parent node

Throws:
antlr.SemanticException

resolve

public void resolve(boolean generateJoin,
                    boolean implicitJoin)
             throws antlr.SemanticException
Does the work of resolving an identifier or a dot, but without a parent node or alias

Throws:
antlr.SemanticException

resolveInFunctionCall

public void resolveInFunctionCall(boolean generateJoin,
                                  boolean implicitJoin)
                           throws antlr.SemanticException
Does the work of resolving inside of the scope of a function call

Throws:
antlr.SemanticException

resolveIndex

public void resolveIndex(antlr.collections.AST parent)
                  throws antlr.SemanticException
Does the work of resolving an an index [].

Throws:
antlr.SemanticException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RestrictableStatement (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Interface RestrictableStatement

All Superinterfaces:
Statement
All Known Implementing Classes:
AbstractRestrictableStatement
public interface RestrictableStatement
extends Statement

Type definition for Statements which are restrictable via a where-clause (and thus also having a from-clause).

Author:
Steve Ebersole

Method Summary
FromClause | getFromClause() Retreives the from-clause in effect for this statement.
antlr.collections.AST | getWhereClause() Retreives the where-clause defining the restriction(s) in effect for this statement.
boolean | hasWhereClause() Does this statement tree currently contain a where clause?
Methods inherited from interface org.hibernate.hql.ast.tree.Statement
getStatementType, getWalker, needsExecutor

Method Detail

getFromClause

public FromClause getFromClause()
Retreives the from-clause in effect for this statement.

Returns:
The from-clause for this statement; could be null if the from-clause has not yet been parsed/generated.

hasWhereClause

public boolean hasWhereClause()
Does this statement tree currently contain a where clause?

Returns:
True if a where-clause is found in the statement tree and that where clause actually defines restrictions; false otherwise.

getWhereClause

public antlr.collections.AST getWhereClause()
Retreives the where-clause defining the restriction(s) in effect for this statement.

Note that this will generate a where-clause if one was not found, so caution needs to taken prior to calling this that restrictions will actually exist in the resulting statement tree (otherwise "unexpected end of subtree" errors might occur during rendering).

Returns:
The where clause.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Interface SelectExpression

All Known Implementing Classes:
AbstractSelectExpression, AggregateNode, Case2Node, CaseNode, ConstructorNode, CountNode, DotNode, IdentNode, MethodNode, QueryNode, SelectExpressionImpl
public interface SelectExpression

Represents an element of a projection list, i.e. a select expression.

Author:
josh Sep 21, 2004 9:00:13 PM

Method Summary
String | getAlias()
Type | getDataType() Returns the data type of the select expression.
FromElement | getFromElement() Returns the FROM element that this expression refers to.
boolean | isConstructor() Returns true if the element is a constructor (e.g.
boolean | isReturnableEntity() Returns true if this select expression represents an entity that can be returned.
boolean | isScalar()
void | setAlias(String alias)
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
void | setText(String text) Sets the text of the node.

Method Detail

getDataType

public Type getDataType()
Returns the data type of the select expression.

Returns:
The data type of the select expression.

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException

getFromElement

public FromElement getFromElement()
Returns the FROM element that this expression refers to.

Returns:
The FROM element.

isConstructor

public boolean isConstructor()
Returns true if the element is a constructor (e.g. new Foo).

Returns:
true if the element is a constructor (e.g. new Foo).

isReturnableEntity

public boolean isReturnableEntity()
                           throws antlr.SemanticException
Returns true if this select expression represents an entity that can be returned.

Returns:
true if this select expression represents an entity that can be returned.
Throws:
antlr.SemanticException

setText

public void setText(String text)
Sets the text of the node.

Parameters:
text - the new node text.

isScalar

public boolean isScalar()
                 throws antlr.SemanticException
Throws:
antlr.SemanticException

setAlias

public void setAlias(String alias)

getAlias

public String getAlias()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SessionFactoryAwareNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Interface SessionFactoryAwareNode

All Known Implementing Classes:
JavaConstantNode
public interface SessionFactoryAwareNode

Interface for nodes which require access to the SessionFactory

Author:
Steve Ebersole

Method Summary
 void setSessionFactory(SessionFactoryImplementor sessionFactory)

Method Detail

setSessionFactory

public void setSessionFactory(SessionFactoryImplementor sessionFactory)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Statement (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Interface Statement

All Known Subinterfaces:
RestrictableStatement
All Known Implementing Classes:
AbstractRestrictableStatement, AbstractStatement
public interface Statement

Common interface modeling the different HQL statements (i.e., INSERT, UPDATE, DELETE, SELECT).

Author:
Steve Ebersole

Method Summary
int | getStatementType() Return the main token type representing the type of this statement.
HqlSqlWalker | getWalker() Retreive the "phase 2" walker which generated this statement tree.
boolean | needsExecutor() Does this statement require the StatementExecutor?

Method Detail

getWalker

public HqlSqlWalker getWalker()
Retreive the "phase 2" walker which generated this statement tree.

Returns:
The HqlSqlWalker instance which generated this statement tree.

getStatementType

public int getStatementType()
Return the main token type representing the type of this statement.

Returns:
The corresponding token type.

needsExecutor

public boolean needsExecutor()
Does this statement require the StatementExecutor?

Essentially, at the JDBC level, does this require an executeUpdate()?

Returns:
True if this statement should be handed off to the StatementExecutor to be executed; false otherwise.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnaryOperatorNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Interface UnaryOperatorNode

All Superinterfaces:
OperatorNode
All Known Implementing Classes:
UnaryArithmeticNode, UnaryLogicOperatorNode
public interface UnaryOperatorNode
extends OperatorNode

Contract for nodes representing unary operators.

Author:
Steve Ebersole

Method Summary
 Node getOperand()
Retrievs the node representing the operator's single operand.
Methods inherited from interface org.hibernate.hql.ast.tree.OperatorNode
getDataType, initialize

Method Detail

getOperand

public Node getOperand()
Retrievs the node representing the operator's single operand.

Returns:
The operator's single operand.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractRestrictableStatement (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class AbstractRestrictableStatement

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractStatement
                            extended by org.hibernate.hql.ast.tree.AbstractRestrictableStatement
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, RestrictableStatement, Serializable, Statement
Direct Known Subclasses:
DeleteStatement, QueryNode, UpdateStatement
public abstract class AbstractRestrictableStatement
extends AbstractStatement
implements RestrictableStatement

Convenience implementation of RestrictableStatement to centralize common functionality.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
AbstractRestrictableStatement()
Method Summary
FromClause | getFromClause() Retreives the from-clause in effect for this statement.
protected abstract org.apache.commons.logging.Log | getLog()
antlr.collections.AST | getWhereClause() Retreives the where-clause defining the restriction(s) in effect for this statement.
protected abstract int | getWhereClauseParentTokenType()
boolean | hasWhereClause() Does this statement tree currently contain a where clause?
protected antlr.collections.AST | locateWhereClause()
Methods inherited from class org.hibernate.hql.ast.tree.AbstractStatement
getDisplayText
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.Statement
getStatementType, getWalker, needsExecutor

Constructor Detail

AbstractRestrictableStatement

public AbstractRestrictableStatement()
Method Detail

getWhereClauseParentTokenType

protected abstract int getWhereClauseParentTokenType()

getLog

protected abstract org.apache.commons.logging.Log getLog()

getFromClause

public final FromClause getFromClause()
Description copied from interface: RestrictableStatement
Retreives the from-clause in effect for this statement.

Specified by:
getFromClause in interface RestrictableStatement
Returns:
The from-clause for this statement; could be null if the from-clause has not yet been parsed/generated.
See Also:
RestrictableStatement.getFromClause()

hasWhereClause

public final boolean hasWhereClause()
Description copied from interface: RestrictableStatement
Does this statement tree currently contain a where clause?

Specified by:
hasWhereClause in interface RestrictableStatement
Returns:
True if a where-clause is found in the statement tree and that where clause actually defines restrictions; false otherwise.
See Also:
RestrictableStatement.hasWhereClause()

getWhereClause

public final antlr.collections.AST getWhereClause()
Description copied from interface: RestrictableStatement
Retreives the where-clause defining the restriction(s) in effect for this statement.

Note that this will generate a where-clause if one was not found, so caution needs to taken prior to calling this that restrictions will actually exist in the resulting statement tree (otherwise "unexpected end of subtree" errors might occur during rendering).

Specified by:
getWhereClause in interface RestrictableStatement
Returns:
The where clause.
See Also:
RestrictableStatement.getWhereClause()

locateWhereClause

protected antlr.collections.AST locateWhereClause()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractSelectExpression (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class AbstractSelectExpression

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
All Implemented Interfaces:
antlr.collections.AST, InitializeableNode, SelectExpression, Serializable
Direct Known Subclasses:
AggregateNode, BinaryArithmeticOperatorNode, Case2Node, CaseNode, CountNode, FromReferenceNode, LiteralNode, MethodNode, UnaryArithmeticNode
public abstract class AbstractSelectExpression
extends HqlSqlWalkerNode
implements SelectExpression

Partial implementation of SelectExpression for all the nodes that aren't constructors.

Author:
josh Nov 11, 2004 7:09:11 AM
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
AbstractSelectExpression()
Method Summary
String | getAlias()
FromElement | getFromElement() Returns the FROM element that this expression refers to.
boolean | isConstructor() Returns true if the element is a constructor (e.g.
boolean | isReturnableEntity() Returns true if this select expression represents an entity that can be returned.
boolean | isScalar()
void | setAlias(String alias)
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
getDataType, setScalarColumnText, setText

Constructor Detail

AbstractSelectExpression

public AbstractSelectExpression()
Method Detail

setAlias

public final void setAlias(String alias)
Specified by:
setAlias in interface SelectExpression

getAlias

public final String getAlias()
Specified by:
getAlias in interface SelectExpression

isConstructor

public boolean isConstructor()
Description copied from interface: SelectExpression
Returns true if the element is a constructor (e.g. new Foo).

Specified by:
isConstructor in interface SelectExpression
Returns:
true if the element is a constructor (e.g. new Foo).

isReturnableEntity

public boolean isReturnableEntity()
                           throws antlr.SemanticException
Description copied from interface: SelectExpression
Returns true if this select expression represents an entity that can be returned.

Specified by:
isReturnableEntity in interface SelectExpression
Returns:
true if this select expression represents an entity that can be returned.
Throws:
antlr.SemanticException

getFromElement

public FromElement getFromElement()
Description copied from interface: SelectExpression
Returns the FROM element that this expression refers to.

Specified by:
getFromElement in interface SelectExpression
Returns:
The FROM element.

isScalar

public boolean isScalar()
                 throws antlr.SemanticException
Specified by:
isScalar in interface SelectExpression
Throws:
antlr.SemanticException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractStatement (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class AbstractStatement

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractStatement
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, Serializable, Statement
Direct Known Subclasses:
AbstractRestrictableStatement, InsertStatement
public abstract class AbstractStatement
extends HqlSqlWalkerNode
implements DisplayableNode, Statement

Convenience implementation of Statement to centralize common functionality.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
AbstractStatement()
Method Summary
 String getDisplayText()
Returns additional display text for the AST node.
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.Statement
getStatementType, getWalker, needsExecutor

Constructor Detail

AbstractStatement

public AbstractStatement()
Method Detail

getDisplayText

public String getDisplayText()
Returns additional display text for the AST node.

Specified by:
getDisplayText in interface DisplayableNode
Returns:
String - The additional display text.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AggregateNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class AggregateNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.AggregateNode
All Implemented Interfaces:
antlr.collections.AST, InitializeableNode, SelectExpression, Serializable
public class AggregateNode
extends AbstractSelectExpression
implements SelectExpression

Represents an aggregate function i.e. min, max, sum, avg.

Author:
josh Sep 21, 2004 9:22:02 PM
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
AggregateNode()
Method Summary
Type | getDataType() Returns the data type of the select expression.
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias, setText

Constructor Detail

AggregateNode

public AggregateNode()
Method Detail

getDataType

public Type getDataType()
Description copied from interface: SelectExpression
Returns the data type of the select expression.

Specified by:
getDataType in interface SelectExpression
Overrides:
getDataType in class SqlNode

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AssignmentSpecification (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class AssignmentSpecification

java.lang.Object
    extended by org.hibernate.hql.ast.tree.AssignmentSpecification
public class AssignmentSpecification
extends Object

Encapsulates the information relating to an individual assignment within the set clause of an HQL update statement. This information is used during execution of the update statements when the updates occur against "multi-table" stuff.

Author:
Steve Ebersole

Constructor Summary
AssignmentSpecification(antlr.collections.AST eq, Queryable persister)
Method Summary
boolean | affectsTable(String tableName)
ParameterSpecification[] | getParameters()
String | getSqlAssignmentFragment()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AssignmentSpecification

public AssignmentSpecification(antlr.collections.AST eq,
                               Queryable persister)
Method Detail

affectsTable

public boolean affectsTable(String tableName)

getParameters

public ParameterSpecification[] getParameters()

getSqlAssignmentFragment

public String getSqlAssignmentFragment()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BetweenOperatorNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class BetweenOperatorNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.BetweenOperatorNode
All Implemented Interfaces:
antlr.collections.AST, OperatorNode, Serializable
public class BetweenOperatorNode
extends SqlNode
implements OperatorNode

Contract for nodes representing logcial BETWEEN (ternary) operators.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
BetweenOperatorNode()
Method Summary
Type | getDataType() Retrieves the data type for the overall operator expression.
Node | getFixtureOperand()
Node | getHighOperand()
Node | getLowOperand()
void | initialize() Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BetweenOperatorNode

public BetweenOperatorNode()
Method Detail

initialize

public void initialize()
                throws antlr.SemanticException
Description copied from interface: OperatorNode
Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.

Specified by:
initialize in interface OperatorNode
Throws:
antlr.SemanticException

getDataType

public Type getDataType()
Description copied from interface: OperatorNode
Retrieves the data type for the overall operator expression.

Specified by:
getDataType in interface OperatorNode
Overrides:
getDataType in class SqlNode

getFixtureOperand

public Node getFixtureOperand()

getLowOperand

public Node getLowOperand()

getHighOperand

public Node getHighOperand()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BinaryArithmeticOperatorNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class BinaryArithmeticOperatorNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode
All Implemented Interfaces:
antlr.collections.AST, BinaryOperatorNode, DisplayableNode, InitializeableNode, OperatorNode, SelectExpression, Serializable
public class BinaryArithmeticOperatorNode
extends AbstractSelectExpression
implements BinaryOperatorNode, DisplayableNode

Nodes which represent binary arithmetic operators.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
BinaryArithmeticOperatorNode()
Method Summary
Type | getDataType() Figure out the type of the binary expression by looking at the types of the operands.
String | getDisplayText() Returns additional display text for the AST node.
Node | getLeftHandOperand() Retrieves the left-hand operand of the operator.
Node | getRightHandOperand() Retrieves the right-hand operand of the operator.
void | initialize() Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
setText

Constructor Detail

BinaryArithmeticOperatorNode

public BinaryArithmeticOperatorNode()
Method Detail

initialize

public void initialize()
                throws antlr.SemanticException
Description copied from interface: OperatorNode
Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.

Specified by:
initialize in interface OperatorNode
Throws:
antlr.SemanticException

getDataType

public Type getDataType()
Figure out the type of the binary expression by looking at the types of the operands. Sometimes we don't know both types, if, for example, one is a parameter.

Specified by:
getDataType in interface OperatorNode
Overrides:
getDataType in class SqlNode

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException

getLeftHandOperand

public Node getLeftHandOperand()
Retrieves the left-hand operand of the operator.

Specified by:
getLeftHandOperand in interface BinaryOperatorNode
Returns:
The left-hand operand

getRightHandOperand

public Node getRightHandOperand()
Retrieves the right-hand operand of the operator.

Specified by:
getRightHandOperand in interface BinaryOperatorNode
Returns:
The right-hand operand

getDisplayText

public String getDisplayText()
Description copied from interface: DisplayableNode
Returns additional display text for the AST node.

Specified by:
getDisplayText in interface DisplayableNode
Returns:
String - The additional display text.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BinaryLogicOperatorNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class BinaryLogicOperatorNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.BinaryLogicOperatorNode
All Implemented Interfaces:
antlr.collections.AST, BinaryOperatorNode, InitializeableNode, OperatorNode, Serializable
Direct Known Subclasses:
InLogicOperatorNode
public class BinaryLogicOperatorNode
extends HqlSqlWalkerNode
implements BinaryOperatorNode

Contract for nodes representing binary operators.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
BinaryLogicOperatorNode()
Method Summary
protected Type | extractDataType(Node operand)
Type | getDataType() Retrieves the data type for the overall operator expression.
Node | getLeftHandOperand() Retrieves the left-hand operand of the operator.
Node | getRightHandOperand() Retrieves the right-hand operand of the operator.
void | initialize() Performs the operator node initialization by seeking out any parameter nodes and setting their expected type, if possible.
protected void | mutateRowValueConstructorSyntaxesIfNecessary(Type lhsType, Type rhsType)
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BinaryLogicOperatorNode

public BinaryLogicOperatorNode()
Method Detail

initialize

public void initialize()
                throws antlr.SemanticException
Performs the operator node initialization by seeking out any parameter nodes and setting their expected type, if possible.

Specified by:
initialize in interface OperatorNode
Throws:
antlr.SemanticException

mutateRowValueConstructorSyntaxesIfNecessary

protected final void mutateRowValueConstructorSyntaxesIfNecessary(Type lhsType,
                                                                  Type rhsType)

extractDataType

protected Type extractDataType(Node operand)

getDataType

public Type getDataType()
Description copied from interface: OperatorNode
Retrieves the data type for the overall operator expression.

Specified by:
getDataType in interface OperatorNode
Overrides:
getDataType in class SqlNode

getLeftHandOperand

public Node getLeftHandOperand()
Retrieves the left-hand operand of the operator.

Specified by:
getLeftHandOperand in interface BinaryOperatorNode
Returns:
The left-hand operand

getRightHandOperand

public Node getRightHandOperand()
Retrieves the right-hand operand of the operator.

Specified by:
getRightHandOperand in interface BinaryOperatorNode
Returns:
The right-hand operand
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BooleanLiteralNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class BooleanLiteralNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.LiteralNode
                                extended by org.hibernate.hql.ast.tree.BooleanLiteralNode
All Implemented Interfaces:
antlr.collections.AST, ExpectedTypeAwareNode, HqlSqlTokenTypes, InitializeableNode, SelectExpression, Serializable
public class BooleanLiteralNode
extends LiteralNode
implements ExpectedTypeAwareNode

Represents a boolean literal within a query.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Fields inherited from interface org.hibernate.hql.antlr.HqlSqlTokenTypes
AGGREGATE, ALIAS, ALIAS_REF, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOGUS, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FILTERS, FLOAT_SUFFIX, FROM, FROM_FRAGMENT, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IMPLIED_FROM, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, JOIN_FRAGMENT, LE, LEADING, LEFT, LEFT_OUTER, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, METHOD_NAME, MIN, MINUS, NAMED_PARAM, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, PROPERTY_REF, QUERY, QUOTED_STRING, RANGE, RIGHT, RIGHT_OUTER, ROW_STAR, SELECT, SELECT_CLAUSE, SELECT_COLUMNS, SELECT_EXPR, SELECT_FROM, SET, SOME, SQL_NE, SQL_TOKEN, STAR, SUM, THEN, THETA_JOINS, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
BooleanLiteralNode()
Method Summary
Type | getDataType() Returns the data type of the select expression.
Type | getExpectedType()
String | getRenderText(SessionFactoryImplementor sessionFactory) Retrieve the text to be used for rendering this particular node.
BooleanType | getTypeInternal()
Boolean | getValue()
void | setExpectedType(Type expectedType) Expected-types really only pertinent here for boolean literals...
Methods inherited from class org.hibernate.hql.ast.tree.LiteralNode
setScalarColumnText
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
setText

Constructor Detail

BooleanLiteralNode

public BooleanLiteralNode()
Method Detail

getDataType

public Type getDataType()
Description copied from interface: SelectExpression
Returns the data type of the select expression.

Specified by:
getDataType in interface SelectExpression
Overrides:
getDataType in class LiteralNode

getTypeInternal

public BooleanType getTypeInternal()

getValue

public Boolean getValue()

setExpectedType

public void setExpectedType(Type expectedType)
Expected-types really only pertinent here for boolean literals...

Specified by:
setExpectedType in interface ExpectedTypeAwareNode
Parameters:
expectedType -

getExpectedType

public Type getExpectedType()
Specified by:
getExpectedType in interface ExpectedTypeAwareNode

getRenderText

public String getRenderText(SessionFactoryImplementor sessionFactory)
Description copied from class: Node
Retrieve the text to be used for rendering this particular node.

Overrides:
getRenderText in class Node
Parameters:
sessionFactory - The session factory
Returns:
The text to use for rendering
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Case2Node (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class Case2Node

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.Case2Node
All Implemented Interfaces:
antlr.collections.AST, InitializeableNode, SelectExpression, Serializable
public class Case2Node
extends AbstractSelectExpression
implements SelectExpression

Represents a case ... when .. then ... else ... end expression in a select.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
Case2Node()
Method Summary
Type | getDataType() Returns the data type of the select expression.
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias, setText

Constructor Detail

Case2Node

public Case2Node()
Method Detail

getDataType

public Type getDataType()
Description copied from interface: SelectExpression
Returns the data type of the select expression.

Specified by:
getDataType in interface SelectExpression
Overrides:
getDataType in class SqlNode

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CaseNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class CaseNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.CaseNode
All Implemented Interfaces:
antlr.collections.AST, InitializeableNode, SelectExpression, Serializable
public class CaseNode
extends AbstractSelectExpression
implements SelectExpression

Represents a case ... when .. then ... else ... end expression in a select.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
CaseNode()
Method Summary
Type | getDataType() Returns the data type of the select expression.
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias, setText

Constructor Detail

CaseNode

public CaseNode()
Method Detail

getDataType

public Type getDataType()
Description copied from interface: SelectExpression
Returns the data type of the select expression.

Specified by:
getDataType in interface SelectExpression
Overrides:
getDataType in class SqlNode

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionFunction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class CollectionFunction

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.MethodNode
                                extended by org.hibernate.hql.ast.tree.CollectionFunction
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, SelectExpression, Serializable
public class CollectionFunction
extends MethodNode
implements DisplayableNode

Represents 'elements()' or 'indices()'.

Author:
josh Dec 6, 2004 8:36:42 AM
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
CollectionFunction()
Method Summary
protected void | prepareSelectColumns(String[] selectColumns)
void | resolve(boolean inSelect)
Methods inherited from class org.hibernate.hql.ast.tree.MethodNode
getDisplayText, getFromElement, getSQLFunction, initializeMethodNode, isCollectionPropertyMethod, isScalar, resolveCollectionProperty, setScalarColumnText
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, isConstructor, isReturnableEntity, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.DisplayableNode
getDisplayText
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
getAlias, getDataType, isConstructor, isReturnableEntity, setAlias, setText

Constructor Detail

CollectionFunction

public CollectionFunction()
Method Detail

resolve

public void resolve(boolean inSelect)
             throws antlr.SemanticException
Overrides:
resolve in class MethodNode
Throws:
antlr.SemanticException

prepareSelectColumns

protected void prepareSelectColumns(String[] selectColumns)
Overrides:
prepareSelectColumns in class MethodNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConstructorNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class ConstructorNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.SelectExpressionList
                            extended by org.hibernate.hql.ast.tree.ConstructorNode
All Implemented Interfaces:
antlr.collections.AST, InitializeableNode, SelectExpression, Serializable
public class ConstructorNode
extends SelectExpressionList
implements SelectExpression

Represents a constructor (new) in a SELECT.

Author:
josh Sep 24, 2004 6:46:08 PM
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
ConstructorNode()
Method Summary
String | getAlias()
String[] | getAliases()
Constructor | getConstructor()
List | getConstructorArgumentTypeList()
Type | getDataType() Returns the data type of the select expression.
protected antlr.collections.AST | getFirstSelectExpression() Returns the first select expression node that should be considered when building the array of select expressions.
FromElement | getFromElement() Returns the FROM element that this expression refers to.
boolean | isConstructor() Returns true if the element is a constructor (e.g.
boolean | isList()
boolean | isMap()
boolean | isReturnableEntity() Returns true if this select expression represents an entity that can be returned.
boolean | isScalar()
void | prepare()
void | setAlias(String alias)
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.SelectExpressionList
collectSelectExpressions
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
setText

Constructor Detail

ConstructorNode

public ConstructorNode()
Method Detail

isMap

public boolean isMap()

isList

public boolean isList()

getAliases

public String[] getAliases()

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException

getFirstSelectExpression

protected antlr.collections.AST getFirstSelectExpression()
Description copied from class: SelectExpressionList
Returns the first select expression node that should be considered when building the array of select expressions.

Specified by:
getFirstSelectExpression in class SelectExpressionList
Returns:
the first select expression node that should be considered when building the array of select expressions

getDataType

public Type getDataType()
Deprecated. (tell clover to ignore this method)

Description copied from interface: SelectExpression
Returns the data type of the select expression.

Specified by:
getDataType in interface SelectExpression
Overrides:
getDataType in class SqlNode

prepare

public void prepare()
             throws antlr.SemanticException
Throws:
antlr.SemanticException

getConstructor

public Constructor getConstructor()

getConstructorArgumentTypeList

public List getConstructorArgumentTypeList()

getFromElement

public FromElement getFromElement()
Description copied from interface: SelectExpression
Returns the FROM element that this expression refers to.

Specified by:
getFromElement in interface SelectExpression
Returns:
The FROM element.

isConstructor

public boolean isConstructor()
Description copied from interface: SelectExpression
Returns true if the element is a constructor (e.g. new Foo).

Specified by:
isConstructor in interface SelectExpression
Returns:
true if the element is a constructor (e.g. new Foo).

isReturnableEntity

public boolean isReturnableEntity()
                           throws antlr.SemanticException
Description copied from interface: SelectExpression
Returns true if this select expression represents an entity that can be returned.

Specified by:
isReturnableEntity in interface SelectExpression
Returns:
true if this select expression represents an entity that can be returned.
Throws:
antlr.SemanticException

isScalar

public boolean isScalar()
Specified by:
isScalar in interface SelectExpression

setAlias

public void setAlias(String alias)
Specified by:
setAlias in interface SelectExpression

getAlias

public String getAlias()
Specified by:
getAlias in interface SelectExpression
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CountNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class CountNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.CountNode
All Implemented Interfaces:
antlr.collections.AST, InitializeableNode, SelectExpression, Serializable
public class CountNode
extends AbstractSelectExpression
implements SelectExpression

Represents a COUNT expression in a select.

Author:
josh Sep 21, 2004 9:23:40 PM
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
CountNode()
Method Summary
Type | getDataType() Returns the data type of the select expression.
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias, setText

Constructor Detail

CountNode

public CountNode()
Method Detail

getDataType

public Type getDataType()
Description copied from interface: SelectExpression
Returns the data type of the select expression.

Specified by:
getDataType in interface SelectExpression
Overrides:
getDataType in class SqlNode

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DeleteStatement (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class DeleteStatement

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractStatement
                            extended by org.hibernate.hql.ast.tree.AbstractRestrictableStatement
                                extended by org.hibernate.hql.ast.tree.DeleteStatement
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, RestrictableStatement, Serializable, Statement
public class DeleteStatement
extends AbstractRestrictableStatement

Defines a top-level AST node representing an HQL delete statement.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
DeleteStatement()
Method Summary
protected org.apache.commons.logging.Log | getLog()
int | getStatementType() Return the main token type representing the type of this statement.
protected int | getWhereClauseParentTokenType()
boolean | needsExecutor() Does this statement require the StatementExecutor?
Methods inherited from class org.hibernate.hql.ast.tree.AbstractRestrictableStatement
getFromClause, getWhereClause, hasWhereClause, locateWhereClause
Methods inherited from class org.hibernate.hql.ast.tree.AbstractStatement
getDisplayText
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.Statement
getWalker

Constructor Detail

DeleteStatement

public DeleteStatement()
Method Detail

getStatementType

public int getStatementType()
Description copied from interface: Statement
Return the main token type representing the type of this statement.

Returns:
The corresponding token type.
See Also:
Statement.getStatementType()

needsExecutor

public boolean needsExecutor()
Description copied from interface: Statement
Does this statement require the StatementExecutor?

Essentially, at the JDBC level, does this require an executeUpdate()?

Returns:
True if this statement should be handed off to the StatementExecutor to be executed; false otherwise.
See Also:
Statement.needsExecutor()

getWhereClauseParentTokenType

protected int getWhereClauseParentTokenType()
Specified by:
getWhereClauseParentTokenType in class AbstractRestrictableStatement

getLog

protected org.apache.commons.logging.Log getLog()
Specified by:
getLog in class AbstractRestrictableStatement
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DotNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class DotNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.FromReferenceNode
                                extended by org.hibernate.hql.ast.tree.DotNode
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, PathNode, ResolvableNode, SelectExpression, Serializable
public class DotNode
extends FromReferenceNode
implements DisplayableNode, SelectExpression

Represents a reference to a property or alias expression. This should duplicate the relevant behaviors in PathExpressionParser.

User: josh
Date: Dec 16, 2003
Time: 8:03:09 AM

See Also:
Serialized Form

Field Summary
static boolean useThetaStyleImplicitJoins
Used ONLY for regression testing!
Fields inherited from class org.hibernate.hql.ast.tree.FromReferenceNode
ROOT_LEVEL
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
DotNode()
Method Summary
Type | getDataType() Returns the data type of the select expression.
String | getDisplayText() Returns additional display text for the AST node.
FromElement | getImpliedJoin() Sub-classes can override this method if they produce implied joins (e.g.
FromReferenceNode | getLhs()
String | getPath() Returns the full path of the node.
String | getPropertyPath()
void | resolve(boolean generateJoin, boolean implicitJoin, String classAlias, antlr.collections.AST parent) Does the work of resolving an identifier or a dot
void | resolveFirstChild() Resolves the left hand side of the DOT.
void | resolveIndex(antlr.collections.AST parent) Does the work of resolving an an index [].
void | resolveInFunctionCall(boolean generateJoin, boolean implicitJoin) Does the work of resolving inside of the scope of a function call
void | resolveSelectExpression() Special method to resolve expressions in the SELECT list.
void | setFetch(boolean fetch)
void | setJoinType(int joinType) Sets the join type for the '.' node (JoinFragment.XXX).
void | setPropertyPath(String propertyPath)
void | setResolvedConstant(String text)
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.FromReferenceNode
getFromElement, isResolved, isReturnableEntity, prepareForDot, recursiveResolve, recursiveResolve, resolve, resolve, setFromElement, setResolved
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, isConstructor, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias, setText
Methods inherited from interface org.hibernate.hql.ast.tree.InitializeableNode
initialize

Field Detail

useThetaStyleImplicitJoins

public static boolean useThetaStyleImplicitJoins
Used ONLY for regression testing!

Constructor Detail

DotNode

public DotNode()
Method Detail

setJoinType

public void setJoinType(int joinType)
Sets the join type for the '.' node (JoinFragment.XXX).

Parameters:
joinType -
See Also:
JoinFragment

getDisplayText

public String getDisplayText()
Description copied from interface: DisplayableNode
Returns additional display text for the AST node.

Specified by:
getDisplayText in interface DisplayableNode
Overrides:
getDisplayText in class FromReferenceNode

resolveFirstChild

public void resolveFirstChild()
                       throws antlr.SemanticException
Resolves the left hand side of the DOT.

Overrides:
resolveFirstChild in class FromReferenceNode
Throws:
antlr.SemanticException

resolveInFunctionCall

public void resolveInFunctionCall(boolean generateJoin,
                                  boolean implicitJoin)
                           throws antlr.SemanticException
Description copied from interface: ResolvableNode
Does the work of resolving inside of the scope of a function call

Specified by:
resolveInFunctionCall in interface ResolvableNode
Overrides:
resolveInFunctionCall in class FromReferenceNode
Throws:
antlr.SemanticException

resolveIndex

public void resolveIndex(antlr.collections.AST parent)
                  throws antlr.SemanticException
Description copied from interface: ResolvableNode
Does the work of resolving an an index [].

Specified by:
resolveIndex in interface ResolvableNode
Throws:
antlr.SemanticException

resolve

public void resolve(boolean generateJoin,
                    boolean implicitJoin,
                    String classAlias,
                    antlr.collections.AST parent)
             throws antlr.SemanticException
Description copied from interface: ResolvableNode
Does the work of resolving an identifier or a dot

Specified by:
resolve in interface ResolvableNode
Throws:
antlr.SemanticException

getImpliedJoin

public FromElement getImpliedJoin()
Description copied from class: FromReferenceNode
Sub-classes can override this method if they produce implied joins (e.g. DotNode).

Overrides:
getImpliedJoin in class FromReferenceNode
Returns:
an implied join created by this from reference.

getDataType

public Type getDataType()
Description copied from interface: SelectExpression
Returns the data type of the select expression.

Specified by:
getDataType in interface SelectExpression
Overrides:
getDataType in class SqlNode

setPropertyPath

public void setPropertyPath(String propertyPath)

getPropertyPath

public String getPropertyPath()

getLhs

public FromReferenceNode getLhs()

getPath

public String getPath()
Returns the full path of the node.

Specified by:
getPath in interface PathNode
Overrides:
getPath in class FromReferenceNode
Returns:
the full path of the node.

setFetch

public void setFetch(boolean fetch)

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException

resolveSelectExpression

public void resolveSelectExpression()
                             throws antlr.SemanticException
Special method to resolve expressions in the SELECT list.

Throws:
antlr.SemanticException - if this cannot be resolved.

setResolvedConstant

public void setResolvedConstant(String text)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FromClause (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class FromClause

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.FromClause
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, HqlSqlTokenTypes, InitializeableNode, Serializable
public class FromClause
extends HqlSqlWalkerNode
implements HqlSqlTokenTypes, DisplayableNode

Represents the 'FROM' part of a query or subquery, containing all mapped class references.

Author:
josh
See Also:
Serialized Form

Field Summary
static int ROOT_LEVEL
Fields inherited from class antlr.BaseAST
down, right
Fields inherited from interface org.hibernate.hql.antlr.HqlSqlTokenTypes
AGGREGATE, ALIAS, ALIAS_REF, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOGUS, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FILTERS, FLOAT_SUFFIX, FROM, FROM_FRAGMENT, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IMPLIED_FROM, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, JOIN_FRAGMENT, LE, LEADING, LEFT, LEFT_OUTER, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, METHOD_NAME, MIN, MINUS, NAMED_PARAM, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, PROPERTY_REF, QUERY, QUOTED_STRING, RANGE, RIGHT, RIGHT_OUTER, ROW_STAR, SELECT, SELECT_CLAUSE, SELECT_COLUMNS, SELECT_EXPR, SELECT_FROM, SET, SOME, SQL_NE, SQL_TOKEN, STAR, SUM, THEN, THETA_JOINS, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
FromClause()
Method Summary
FromElement | addFromElement(String path, antlr.collections.AST alias) Adds a new from element to the from node.
void | addImpliedFromElement(FromElement element)
boolean | containsClassAlias(String alias) Returns true if the from node contains the class alias name.
boolean | containsTableAlias(String alias) Returns true if the from node contains the table alias name.
List | getCollectionFetches()
String | getDisplayText() Returns additional display text for the AST node.
List | getExplicitFromElements()
FromElement | getFromElement()
FromElement | getFromElement(String aliasOrClassName) Retreives the from-element represented by the given alias.
List | getFromElements() Returns the list of from elements in order.
int | getLevel()
FromClause | getParentFromClause()
List | getProjectionList() Returns the list of from elements that will be part of the result set.
boolean | hasCollectionFecthes()
boolean | isFromElementAlias(String possibleAlias) Convenience method to check whether a given token represents a from-element alias.
boolean | isSubQuery()
FromClause | locateChildFromClauseWithJoinByPath(String path)
int | nextFromElementCounter()
void | promoteJoin(FromElement elem)
void | resolve()
void | setParentFromClause(FromClause parentFromClause)
String | toString()
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

ROOT_LEVEL

public static final int ROOT_LEVEL
See Also:
Constant Field Values
Constructor Detail

FromClause

public FromClause()
Method Detail

addFromElement

public FromElement addFromElement(String path,
                                  antlr.collections.AST alias)
                           throws antlr.SemanticException
Adds a new from element to the from node.

Parameters:
path - The reference to the class.
alias - The alias AST.
Returns:
FromElement - The new FROM element.
Throws:
antlr.SemanticException

getFromElement

public FromElement getFromElement(String aliasOrClassName)
Retreives the from-element represented by the given alias.

Parameters:
aliasOrClassName - The alias by which to locate the from-element.
Returns:
The from-element assigned the given alias, or null if none.

isFromElementAlias

public boolean isFromElementAlias(String possibleAlias)
Convenience method to check whether a given token represents a from-element alias.

Parameters:
possibleAlias - The potential from-element alias to check.
Returns:
True if the possibleAlias is an alias to a from-element visible from this point in the query graph.

getFromElements

public List getFromElements()
Returns the list of from elements in order.

Returns:
the list of from elements (instances of FromElement).

getFromElement

public FromElement getFromElement()

getProjectionList

public List getProjectionList()
Returns the list of from elements that will be part of the result set.

Returns:
the list of from elements that will be part of the result set.

getCollectionFetches

public List getCollectionFetches()

hasCollectionFecthes

public boolean hasCollectionFecthes()

getExplicitFromElements

public List getExplicitFromElements()

containsClassAlias

public boolean containsClassAlias(String alias)
Returns true if the from node contains the class alias name.

Parameters:
alias - The HQL class alias name.
Returns:
true if the from node contains the class alias name.

containsTableAlias

public boolean containsTableAlias(String alias)
Returns true if the from node contains the table alias name.

Parameters:
alias - The SQL table alias name.
Returns:
true if the from node contains the table alias name.

getDisplayText

public String getDisplayText()
Description copied from interface: DisplayableNode
Returns additional display text for the AST node.

Specified by:
getDisplayText in interface DisplayableNode
Returns:
String - The additional display text.

setParentFromClause

public void setParentFromClause(FromClause parentFromClause)

locateChildFromClauseWithJoinByPath

public FromClause locateChildFromClauseWithJoinByPath(String path)

promoteJoin

public void promoteJoin(FromElement elem)

isSubQuery

public boolean isSubQuery()

getParentFromClause

public FromClause getParentFromClause()

getLevel

public int getLevel()

nextFromElementCounter

public int nextFromElementCounter()

resolve

public void resolve()

addImpliedFromElement

public void addImpliedFromElement(FromElement element)

toString

public String toString()
Specified by:
toString in interface antlr.collections.AST
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FromElement (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class FromElement

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.FromElement
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, Serializable
Direct Known Subclasses:
ImpliedFromElement
public class FromElement
extends HqlSqlWalkerNode
implements DisplayableNode

Represents a single mapped class mentioned in an HQL FROM clause. Each class reference will have the following symbols:

  • A class name - This is the name of the Java class that is mapped by Hibernate.
  • [optional] an HQL alias for the mapped class.
  • A table name - The name of the table that is mapped to the Java class.
  • A table alias - The alias for the table that will be used in the resulting SQL.

User: josh
Date: Dec 6, 2003
Time: 10:28:17 AM

See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
FromElement()
Method Summary
protected void | appendDisplayText(StringBuffer buf)
boolean | equals(Object obj)
String | getClassAlias()
String | getClassName()
String | getCollectionSuffix()
String | getCollectionTableAlias()
Type | getDataType()
List | getDestinations()
String | getDisplayText() Returns additional display text for the AST node.
EntityPersister | getEntityPersister()
FromClause | getFromClause()
String | getIdentityColumn()
JoinSequence | getJoinSequence()
FromElement | getOrigin()
PropertyMapping | getPropertyMapping(String propertyName)
Type | getPropertyType(String propertyName, String propertyPath) Returns the type of a property, given it's name (the last part) and the full path.
Queryable | getQueryable()
QueryableCollection | getQueryableCollection()
FromElement | getRealOrigin()
Type | getSelectType()
int | getSequence()
String | getTableAlias()
String | getWithClauseFragment()
String | getWithClauseJoinAlias()
boolean | hasCacheablePersister()
int | hashCode()
void | initializeCollection(FromClause fromClause, String classAlias, String tableAlias)
void | initializeEntity(FromClause fromClause, String className, EntityPersister persister, EntityType type, String classAlias, String tableAlias)
boolean | inProjectionList() Returns true if this element should be in the projection list.
boolean | isAllPropertyFetch()
boolean | isCollectionJoin()
boolean | isCollectionOfValuesOrComponents()
boolean | isEntity()
boolean | isFetch()
boolean | isFilter()
boolean | isFromOrJoinFragment()
boolean | isImplied() Returns true if this FromElement was implied by a path, or false if this FROM element is explicitly declared in the FROM clause.
boolean | isImpliedInFromClause()
boolean | isIncludeSubclasses()
boolean | isManyToMany()
void | setAllPropertyFetch(boolean fetch)
void | setCollectionJoin(boolean collectionJoin)
void | setCollectionSuffix(String suffix)
void | setCollectionTableAlias(String collectionTableAlias)
void | setColumns(String[] columns)
void | setFetch(boolean fetch)
void | setFilter(boolean b)
void | setImpliedInFromClause(boolean flag)
void | setIncludeSubclasses(boolean includeSubclasses)
void | setInProjectionList(boolean inProjectionList)
void | setJoinSequence(JoinSequence joinSequence)
void | setOrigin(FromElement origin, boolean manyToMany)
void | setQueryableCollection(QueryableCollection queryableCollection)
void | setRole(String role)
void | setUseFromFragment(boolean useFromFragment)
void | setUseWhereFragment(boolean b)
void | setWithClauseFragment(String withClauseJoinAlias, String withClauseFragment)
String[] | toColumns(String tableAlias, String path, boolean inSelect)
String[] | toColumns(String tableAlias, String path, boolean inSelect, boolean forceAlias)
boolean | useFromFragment() Returns true if the from fragment should be included in the from clause.
boolean | useWhereFragment()
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

FromElement

public FromElement()
Method Detail

getCollectionSuffix

public String getCollectionSuffix()

setCollectionSuffix

public void setCollectionSuffix(String suffix)

initializeCollection

public void initializeCollection(FromClause fromClause,
                                 String classAlias,
                                 String tableAlias)

initializeEntity

public void initializeEntity(FromClause fromClause,
                             String className,
                             EntityPersister persister,
                             EntityType type,
                             String classAlias,
                             String tableAlias)

getEntityPersister

public EntityPersister getEntityPersister()

getDataType

public Type getDataType()
Overrides:
getDataType in class SqlNode

getSelectType

public Type getSelectType()

getQueryable

public Queryable getQueryable()

getClassName

public String getClassName()

getClassAlias

public String getClassAlias()

getTableAlias

public String getTableAlias()

getFromClause

public FromClause getFromClause()

isImplied

public boolean isImplied()
Returns true if this FromElement was implied by a path, or false if this FROM element is explicitly declared in the FROM clause.

Returns:
true if this FromElement was implied by a path, or false if this FROM element is explicitly declared

getDisplayText

public String getDisplayText()
Returns additional display text for the AST node.

Specified by:
getDisplayText in interface DisplayableNode
Returns:
String - The additional display text.

appendDisplayText

protected void appendDisplayText(StringBuffer buf)

hashCode

public int hashCode()

equals

public boolean equals(Object obj)

setJoinSequence

public void setJoinSequence(JoinSequence joinSequence)

getJoinSequence

public JoinSequence getJoinSequence()

setIncludeSubclasses

public void setIncludeSubclasses(boolean includeSubclasses)

isIncludeSubclasses

public boolean isIncludeSubclasses()

getIdentityColumn

public String getIdentityColumn()

setCollectionJoin

public void setCollectionJoin(boolean collectionJoin)

isCollectionJoin

public boolean isCollectionJoin()

setRole

public void setRole(String role)

setQueryableCollection

public void setQueryableCollection(QueryableCollection queryableCollection)

getQueryableCollection

public QueryableCollection getQueryableCollection()

setColumns

public void setColumns(String[] columns)

setOrigin

public void setOrigin(FromElement origin,
                      boolean manyToMany)

isManyToMany

public boolean isManyToMany()

getDestinations

public List getDestinations()

getOrigin

public FromElement getOrigin()

getRealOrigin

public FromElement getRealOrigin()

getPropertyType

public Type getPropertyType(String propertyName,
                            String propertyPath)
Returns the type of a property, given it's name (the last part) and the full path.

Parameters:
propertyName - The last part of the full path to the property.
Returns:
The type.

toColumns

public String[] toColumns(String tableAlias,
                          String path,
                          boolean inSelect)

toColumns

public String[] toColumns(String tableAlias,
                          String path,
                          boolean inSelect,
                          boolean forceAlias)

getPropertyMapping

public PropertyMapping getPropertyMapping(String propertyName)

setFetch

public void setFetch(boolean fetch)

isFetch

public boolean isFetch()

getSequence

public int getSequence()

setFilter

public void setFilter(boolean b)

isFilter

public boolean isFilter()

useFromFragment

public boolean useFromFragment()
Returns true if the from fragment should be included in the from clause.

setUseFromFragment

public void setUseFromFragment(boolean useFromFragment)

useWhereFragment

public boolean useWhereFragment()

setUseWhereFragment

public void setUseWhereFragment(boolean b)

setCollectionTableAlias

public void setCollectionTableAlias(String collectionTableAlias)

getCollectionTableAlias

public String getCollectionTableAlias()

isCollectionOfValuesOrComponents

public boolean isCollectionOfValuesOrComponents()

isEntity

public boolean isEntity()

setImpliedInFromClause

public void setImpliedInFromClause(boolean flag)

isImpliedInFromClause

public boolean isImpliedInFromClause()

setInProjectionList

public void setInProjectionList(boolean inProjectionList)

inProjectionList

public boolean inProjectionList()
Returns true if this element should be in the projection list.

isFromOrJoinFragment

public boolean isFromOrJoinFragment()

isAllPropertyFetch

public boolean isAllPropertyFetch()

setAllPropertyFetch

public void setAllPropertyFetch(boolean fetch)

getWithClauseFragment

public String getWithClauseFragment()

getWithClauseJoinAlias

public String getWithClauseJoinAlias()

setWithClauseFragment

public void setWithClauseFragment(String withClauseJoinAlias,
                                  String withClauseFragment)

hasCacheablePersister

public boolean hasCacheablePersister()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FromReferenceNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class FromReferenceNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.FromReferenceNode
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, PathNode, ResolvableNode, SelectExpression, Serializable
Direct Known Subclasses:
DotNode, IdentNode, IndexNode, SelectExpressionImpl
public abstract class FromReferenceNode
extends AbstractSelectExpression
implements ResolvableNode, DisplayableNode, InitializeableNode, PathNode

Represents a reference to a FROM element, for example a class alias in a WHERE clause.

Author:
josh Jul 21, 2004 7:02:04 AM
See Also:
Serialized Form

Field Summary
static int ROOT_LEVEL
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
FromReferenceNode()
Method Summary
String | getDisplayText() Returns additional display text for the AST node.
FromElement | getFromElement() Returns the FROM element that this expression refers to.
FromElement | getImpliedJoin() Sub-classes can override this method if they produce implied joins (e.g.
String | getPath() Returns the full path name represented by the node.
boolean | isResolved()
boolean | isReturnableEntity() Returns true if this select expression represents an entity that can be returned.
void | prepareForDot(String propertyName)
void | recursiveResolve(int level, boolean impliedAtRoot, String classAlias)
void | recursiveResolve(int level, boolean impliedAtRoot, String classAlias, antlr.collections.AST parent)
void | resolve(boolean generateJoin, boolean implicitJoin) Does the work of resolving an identifier or a dot, but without a parent node or alias
void | resolve(boolean generateJoin, boolean implicitJoin, String classAlias) Does the work of resolving an identifier or a dot, but without a parent node
void | resolveFirstChild() Resolves the left hand side of the DOT.
void | resolveInFunctionCall(boolean generateJoin, boolean implicitJoin) Does the work of resolving inside of the scope of a function call
void | setFromElement(FromElement fromElement)
void | setResolved()
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, isConstructor, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.ResolvableNode
resolve, resolveIndex
Methods inherited from interface org.hibernate.hql.ast.tree.InitializeableNode
initialize
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
getDataType, setScalarColumnText, setText

Field Detail

ROOT_LEVEL

public static final int ROOT_LEVEL
See Also:
Constant Field Values
Constructor Detail

FromReferenceNode

public FromReferenceNode()
Method Detail

getFromElement

public FromElement getFromElement()
Description copied from interface: SelectExpression
Returns the FROM element that this expression refers to.

Specified by:
getFromElement in interface SelectExpression
Overrides:
getFromElement in class AbstractSelectExpression

setFromElement

public void setFromElement(FromElement fromElement)

resolveFirstChild

public void resolveFirstChild()
                       throws antlr.SemanticException
Resolves the left hand side of the DOT.

Throws:
antlr.SemanticException

getPath

public String getPath()
Description copied from interface: PathNode
Returns the full path name represented by the node.

Specified by:
getPath in interface PathNode
Returns:
the full path name represented by the node.

isResolved

public boolean isResolved()

setResolved

public void setResolved()

getDisplayText

public String getDisplayText()
Description copied from interface: DisplayableNode
Returns additional display text for the AST node.

Specified by:
getDisplayText in interface DisplayableNode
Returns:
String - The additional display text.

recursiveResolve

public void recursiveResolve(int level,
                             boolean impliedAtRoot,
                             String classAlias)
                      throws antlr.SemanticException
Throws:
antlr.SemanticException

recursiveResolve

public void recursiveResolve(int level,
                             boolean impliedAtRoot,
                             String classAlias,
                             antlr.collections.AST parent)
                      throws antlr.SemanticException
Throws:
antlr.SemanticException

isReturnableEntity

public boolean isReturnableEntity()
                           throws antlr.SemanticException
Description copied from interface: SelectExpression
Returns true if this select expression represents an entity that can be returned.

Specified by:
isReturnableEntity in interface SelectExpression
Overrides:
isReturnableEntity in class AbstractSelectExpression
Throws:
antlr.SemanticException

resolveInFunctionCall

public void resolveInFunctionCall(boolean generateJoin,
                                  boolean implicitJoin)
                           throws antlr.SemanticException
Description copied from interface: ResolvableNode
Does the work of resolving inside of the scope of a function call

Specified by:
resolveInFunctionCall in interface ResolvableNode
Throws:
antlr.SemanticException

resolve

public void resolve(boolean generateJoin,
                    boolean implicitJoin)
             throws antlr.SemanticException
Description copied from interface: ResolvableNode
Does the work of resolving an identifier or a dot, but without a parent node or alias

Specified by:
resolve in interface ResolvableNode
Throws:
antlr.SemanticException

resolve

public void resolve(boolean generateJoin,
                    boolean implicitJoin,
                    String classAlias)
             throws antlr.SemanticException
Description copied from interface: ResolvableNode
Does the work of resolving an identifier or a dot, but without a parent node

Specified by:
resolve in interface ResolvableNode
Throws:
antlr.SemanticException

prepareForDot

public void prepareForDot(String propertyName)
                   throws antlr.SemanticException
Throws:
antlr.SemanticException

getImpliedJoin

public FromElement getImpliedJoin()
Sub-classes can override this method if they produce implied joins (e.g. DotNode).

Returns:
an implied join created by this from reference.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HqlSqlWalkerNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class HqlSqlWalkerNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
All Implemented Interfaces:
antlr.collections.AST, InitializeableNode, Serializable
Direct Known Subclasses:
AbstractSelectExpression, AbstractStatement, BinaryLogicOperatorNode, FromClause, FromElement, IntoClause, OrderByClause, ParameterNode, SelectExpressionList
public class HqlSqlWalkerNode
extends SqlNode
implements InitializeableNode

A semantic analysis node, that points back to the main analyzer.

Author:
josh Sep 24, 2004 4:08:13 PM
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
HqlSqlWalkerNode()
Method Summary
AliasGenerator | getAliasGenerator()
antlr.ASTFactory | getASTFactory()
SessionFactoryHelper | getSessionFactoryHelper()
HqlSqlWalker | getWalker()
void | initialize(Object param) Initializes the node with the parameter.
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

HqlSqlWalkerNode

public HqlSqlWalkerNode()
Method Detail

initialize

public void initialize(Object param)
Description copied from interface: InitializeableNode
Initializes the node with the parameter.

Specified by:
initialize in interface InitializeableNode
Parameters:
param - the initialization parameter.

getWalker

public HqlSqlWalker getWalker()

getSessionFactoryHelper

public SessionFactoryHelper getSessionFactoryHelper()

getASTFactory

public antlr.ASTFactory getASTFactory()

getAliasGenerator

public AliasGenerator getAliasGenerator()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class IdentNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.FromReferenceNode
                                extended by org.hibernate.hql.ast.tree.IdentNode
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, PathNode, ResolvableNode, SelectExpression, Serializable
public class IdentNode
extends FromReferenceNode
implements SelectExpression

Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.

Author:
josh Aug 16, 2004 7:20:55 AM
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.hql.ast.tree.FromReferenceNode
ROOT_LEVEL
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
IdentNode()
Method Summary
Type | getDataType() Returns the data type of the select expression.
String | getDisplayText() Returns additional display text for the AST node.
void | resolve(boolean generateJoin, boolean implicitJoin, String classAlias, antlr.collections.AST parent) Does the work of resolving an identifier or a dot
void | resolveIndex(antlr.collections.AST parent) Does the work of resolving an an index [].
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.FromReferenceNode
getFromElement, getImpliedJoin, getPath, isResolved, isReturnableEntity, prepareForDot, recursiveResolve, recursiveResolve, resolve, resolve, resolveFirstChild, resolveInFunctionCall, setFromElement, setResolved
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, isConstructor, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias, setText
Methods inherited from interface org.hibernate.hql.ast.tree.InitializeableNode
initialize

Constructor Detail

IdentNode

public IdentNode()
Method Detail

resolveIndex

public void resolveIndex(antlr.collections.AST parent)
                  throws antlr.SemanticException
Description copied from interface: ResolvableNode
Does the work of resolving an an index [].

Specified by:
resolveIndex in interface ResolvableNode
Throws:
antlr.SemanticException

resolve

public void resolve(boolean generateJoin,
                    boolean implicitJoin,
                    String classAlias,
                    antlr.collections.AST parent)
Description copied from interface: ResolvableNode
Does the work of resolving an identifier or a dot

Specified by:
resolve in interface ResolvableNode

getDataType

public Type getDataType()
Description copied from interface: SelectExpression
Returns the data type of the select expression.

Specified by:
getDataType in interface SelectExpression
Overrides:
getDataType in class SqlNode

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException

getDisplayText

public String getDisplayText()
Description copied from interface: DisplayableNode
Returns additional display text for the AST node.

Specified by:
getDisplayText in interface DisplayableNode
Overrides:
getDisplayText in class FromReferenceNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ImpliedFromElement (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class ImpliedFromElement

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.FromElement
                            extended by org.hibernate.hql.ast.tree.ImpliedFromElement
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, Serializable
public class ImpliedFromElement
extends FromElement

Represents a FROM element implied by a path expression or a collection reference.

Author:
josh Feb 10, 2005 12:31:03 AM
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
ImpliedFromElement()
Method Summary
String | getDisplayText() Returns additional display text for the AST node.
boolean | inProjectionList() Returns true if this element should be in the projection list.
boolean | isImplied() Returns true if this FromElement was implied by a path, or false if this FROM element is explicitly declared in the FROM clause.
boolean | isImpliedInFromClause()
boolean | isIncludeSubclasses()
void | setImpliedInFromClause(boolean flag)
void | setInProjectionList(boolean inProjectionList)
Methods inherited from class org.hibernate.hql.ast.tree.FromElement
appendDisplayText, equals, getClassAlias, getClassName, getCollectionSuffix, getCollectionTableAlias, getDataType, getDestinations, getEntityPersister, getFromClause, getIdentityColumn, getJoinSequence, getOrigin, getPropertyMapping, getPropertyType, getQueryable, getQueryableCollection, getRealOrigin, getSelectType, getSequence, getTableAlias, getWithClauseFragment, getWithClauseJoinAlias, hasCacheablePersister, hashCode, initializeCollection, initializeEntity, isAllPropertyFetch, isCollectionJoin, isCollectionOfValuesOrComponents, isEntity, isFetch, isFilter, isFromOrJoinFragment, isManyToMany, setAllPropertyFetch, setCollectionJoin, setCollectionSuffix, setCollectionTableAlias, setColumns, setFetch, setFilter, setIncludeSubclasses, setJoinSequence, setOrigin, setQueryableCollection, setRole, setUseFromFragment, setUseWhereFragment, setWithClauseFragment, toColumns, toColumns, useFromFragment, useWhereFragment
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ImpliedFromElement

public ImpliedFromElement()
Method Detail

isImplied

public boolean isImplied()
Description copied from class: FromElement
Returns true if this FromElement was implied by a path, or false if this FROM element is explicitly declared in the FROM clause.

Overrides:
isImplied in class FromElement
Returns:
true if this FromElement was implied by a path, or false if this FROM element is explicitly declared

setImpliedInFromClause

public void setImpliedInFromClause(boolean flag)
Overrides:
setImpliedInFromClause in class FromElement

isImpliedInFromClause

public boolean isImpliedInFromClause()
Overrides:
isImpliedInFromClause in class FromElement

setInProjectionList

public void setInProjectionList(boolean inProjectionList)
Overrides:
setInProjectionList in class FromElement

inProjectionList

public boolean inProjectionList()
Description copied from class: FromElement
Returns true if this element should be in the projection list.

Overrides:
inProjectionList in class FromElement

isIncludeSubclasses

public boolean isIncludeSubclasses()
Overrides:
isIncludeSubclasses in class FromElement

getDisplayText

public String getDisplayText()
Returns additional display text for the AST node.

Specified by:
getDisplayText in interface DisplayableNode
Overrides:
getDisplayText in class FromElement
Returns:
String - The additional display text.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IndexNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class IndexNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.FromReferenceNode
                                extended by org.hibernate.hql.ast.tree.IndexNode
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, PathNode, ResolvableNode, SelectExpression, Serializable
public class IndexNode
extends FromReferenceNode

Represents the [] operator and provides it's semantics.

Author:
josh Aug 14, 2004 7:07:10 AM
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.hql.ast.tree.FromReferenceNode
ROOT_LEVEL
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
IndexNode()
Method Summary
void | prepareForDot(String propertyName)
void | resolve(boolean generateJoin, boolean implicitJoin, String classAlias, antlr.collections.AST parent) Does the work of resolving an identifier or a dot
void | resolveIndex(antlr.collections.AST parent) Does the work of resolving an an index [].
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.FromReferenceNode
getDisplayText, getFromElement, getImpliedJoin, getPath, isResolved, isReturnableEntity, recursiveResolve, recursiveResolve, resolve, resolve, resolveFirstChild, resolveInFunctionCall, setFromElement, setResolved
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, isConstructor, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.InitializeableNode
initialize
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
getDataType, setText

Constructor Detail

IndexNode

public IndexNode()
Method Detail

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException

prepareForDot

public void prepareForDot(String propertyName)
                   throws antlr.SemanticException
Overrides:
prepareForDot in class FromReferenceNode
Throws:
antlr.SemanticException

resolveIndex

public void resolveIndex(antlr.collections.AST parent)
                  throws antlr.SemanticException
Description copied from interface: ResolvableNode
Does the work of resolving an an index [].

Throws:
antlr.SemanticException

resolve

public void resolve(boolean generateJoin,
                    boolean implicitJoin,
                    String classAlias,
                    antlr.collections.AST parent)
             throws antlr.SemanticException
Description copied from interface: ResolvableNode
Does the work of resolving an identifier or a dot

Throws:
antlr.SemanticException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InLogicOperatorNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class InLogicOperatorNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.BinaryLogicOperatorNode
                            extended by org.hibernate.hql.ast.tree.InLogicOperatorNode
All Implemented Interfaces:
antlr.collections.AST, BinaryOperatorNode, InitializeableNode, OperatorNode, Serializable
public class InLogicOperatorNode
extends BinaryLogicOperatorNode
implements BinaryOperatorNode

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
InLogicOperatorNode()
Method Summary
Node | getInList()
void | initialize() Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.
Methods inherited from class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode
extractDataType, getDataType, getLeftHandOperand, getRightHandOperand, mutateRowValueConstructorSyntaxesIfNecessary
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.BinaryOperatorNode
getLeftHandOperand, getRightHandOperand
Methods inherited from interface org.hibernate.hql.ast.tree.OperatorNode
getDataType

Constructor Detail

InLogicOperatorNode

public InLogicOperatorNode()
Method Detail

getInList

public Node getInList()

initialize

public void initialize()
                throws antlr.SemanticException
Description copied from interface: OperatorNode
Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.

Specified by:
initialize in interface OperatorNode
Overrides:
initialize in class BinaryLogicOperatorNode
Throws:
antlr.SemanticException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InsertStatement (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class InsertStatement

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractStatement
                            extended by org.hibernate.hql.ast.tree.InsertStatement
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, Serializable, Statement
public class InsertStatement
extends AbstractStatement

Defines a top-level AST node representing an HQL "insert select" statement.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
InsertStatement()
Method Summary
IntoClause | getIntoClause() Retreive this insert statement's into-clause.
SelectClause | getSelectClause() Retreive this insert statement's select-clause.
int | getStatementType() Return the main token type representing the type of this statement.
boolean | needsExecutor() Does this statement require the StatementExecutor?
void | validate() Performs detailed semantic validation on this insert statement tree.
Methods inherited from class org.hibernate.hql.ast.tree.AbstractStatement
getDisplayText
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.Statement
getWalker

Constructor Detail

InsertStatement

public InsertStatement()
Method Detail

getStatementType

public int getStatementType()
Description copied from interface: Statement
Return the main token type representing the type of this statement.

Returns:
The corresponding token type.
See Also:
Statement.getStatementType()

needsExecutor

public boolean needsExecutor()
Description copied from interface: Statement
Does this statement require the StatementExecutor?

Essentially, at the JDBC level, does this require an executeUpdate()?

Returns:
True if this statement should be handed off to the StatementExecutor to be executed; false otherwise.
See Also:
Statement.needsExecutor()

validate

public void validate()
              throws QueryException
Performs detailed semantic validation on this insert statement tree.

Throws:
QueryException - Indicates validation failure.

getIntoClause

public IntoClause getIntoClause()
Retreive this insert statement's into-clause.

Returns:
The into-clause

getSelectClause

public SelectClause getSelectClause()
Retreive this insert statement's select-clause.

Returns:
The select-clause.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IntoClause (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class IntoClause

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.IntoClause
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, Serializable
public class IntoClause
extends HqlSqlWalkerNode
implements DisplayableNode

Represents an entity referenced in the INTO clause of an HQL INSERT statement.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
IntoClause()
Method Summary
String | getDisplayText() Returns additional display text for the AST node.
String | getEntityName()
Type[] | getInsertionTypes()
Queryable | getQueryable()
String | getTableName()
void | initialize(Queryable persister)
boolean | isDiscriminated()
boolean | isExplicitIdInsertion()
boolean | isExplicitVersionInsertion()
void | prependIdColumnSpec()
void | prependVersionColumnSpec()
void | validateTypes(SelectClause selectClause)
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IntoClause

public IntoClause()
Method Detail

initialize

public void initialize(Queryable persister)

getTableName

public String getTableName()

getQueryable

public Queryable getQueryable()

getEntityName

public String getEntityName()

getInsertionTypes

public Type[] getInsertionTypes()

isDiscriminated

public boolean isDiscriminated()

isExplicitIdInsertion

public boolean isExplicitIdInsertion()

isExplicitVersionInsertion

public boolean isExplicitVersionInsertion()

prependIdColumnSpec

public void prependIdColumnSpec()

prependVersionColumnSpec

public void prependVersionColumnSpec()

validateTypes

public void validateTypes(SelectClause selectClause)
                   throws QueryException
Throws:
QueryException

getDisplayText

public String getDisplayText()
Returns additional display text for the AST node.

Specified by:
getDisplayText in interface DisplayableNode
Returns:
String - The additional display text.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JavaConstantNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class JavaConstantNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.JavaConstantNode
All Implemented Interfaces:
antlr.collections.AST, ExpectedTypeAwareNode, Serializable, SessionFactoryAwareNode
public class JavaConstantNode
extends Node
implements ExpectedTypeAwareNode, SessionFactoryAwareNode

A node representing a static Java constant.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
JavaConstantNode()
Method Summary
Type | getExpectedType()
String | getRenderText(SessionFactoryImplementor sessionFactory) Retrieve the text to be used for rendering this particular node.
void | setExpectedType(Type expectedType)
void | setSessionFactory(SessionFactoryImplementor factory)
void | setText(String s)
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JavaConstantNode

public JavaConstantNode()
Method Detail

setText

public void setText(String s)
Specified by:
setText in interface antlr.collections.AST

setExpectedType

public void setExpectedType(Type expectedType)
Specified by:
setExpectedType in interface ExpectedTypeAwareNode

getExpectedType

public Type getExpectedType()
Specified by:
getExpectedType in interface ExpectedTypeAwareNode

setSessionFactory

public void setSessionFactory(SessionFactoryImplementor factory)
Specified by:
setSessionFactory in interface SessionFactoryAwareNode

getRenderText

public String getRenderText(SessionFactoryImplementor sessionFactory)
Description copied from class: Node
Retrieve the text to be used for rendering this particular node.

Overrides:
getRenderText in class Node
Parameters:
sessionFactory - The session factory
Returns:
The text to use for rendering
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LiteralNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class LiteralNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.LiteralNode
All Implemented Interfaces:
antlr.collections.AST, HqlSqlTokenTypes, InitializeableNode, SelectExpression, Serializable
Direct Known Subclasses:
BooleanLiteralNode
public class LiteralNode
extends AbstractSelectExpression
implements HqlSqlTokenTypes

Represents a literal.

Author:
josh Jan 8, 2005 10:09:53 AM
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Fields inherited from interface org.hibernate.hql.antlr.HqlSqlTokenTypes
AGGREGATE, ALIAS, ALIAS_REF, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOGUS, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FILTERS, FLOAT_SUFFIX, FROM, FROM_FRAGMENT, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IMPLIED_FROM, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, JOIN_FRAGMENT, LE, LEADING, LEFT, LEFT_OUTER, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, METHOD_NAME, MIN, MINUS, NAMED_PARAM, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, PROPERTY_REF, QUERY, QUOTED_STRING, RANGE, RIGHT, RIGHT_OUTER, ROW_STAR, SELECT, SELECT_CLAUSE, SELECT_COLUMNS, SELECT_EXPR, SELECT_FROM, SET, SOME, SQL_NE, SQL_TOKEN, STAR, SUM, THEN, THETA_JOINS, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
LiteralNode()
Method Summary
Type | getDataType() Returns the data type of the select expression.
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
setText

Constructor Detail

LiteralNode

public LiteralNode()
Method Detail

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException

getDataType

public Type getDataType()
Description copied from interface: SelectExpression
Returns the data type of the select expression.

Specified by:
getDataType in interface SelectExpression
Overrides:
getDataType in class SqlNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MethodNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class MethodNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.MethodNode
All Implemented Interfaces:
antlr.collections.AST, InitializeableNode, SelectExpression, Serializable
Direct Known Subclasses:
CollectionFunction
public class MethodNode
extends AbstractSelectExpression
implements SelectExpression

Represents a method call.

Author:
josh Aug 16, 2004 7:59:42 AM
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
MethodNode()
Method Summary
String | getDisplayText()
FromElement | getFromElement() Returns the FROM element that this expression refers to.
SQLFunction | getSQLFunction()
void | initializeMethodNode(antlr.collections.AST name, boolean inSelect)
boolean | isCollectionPropertyMethod()
boolean | isScalar()
protected void | prepareSelectColumns(String[] columns)
void | resolve(boolean inSelect)
void | resolveCollectionProperty(antlr.collections.AST expr)
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, isConstructor, isReturnableEntity, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
getAlias, getDataType, isConstructor, isReturnableEntity, setAlias, setText

Constructor Detail

MethodNode

public MethodNode()
Method Detail

resolve

public void resolve(boolean inSelect)
             throws antlr.SemanticException
Throws:
antlr.SemanticException

getSQLFunction

public SQLFunction getSQLFunction()

isCollectionPropertyMethod

public boolean isCollectionPropertyMethod()

initializeMethodNode

public void initializeMethodNode(antlr.collections.AST name,
                                 boolean inSelect)

isScalar

public boolean isScalar()
                 throws antlr.SemanticException
Specified by:
isScalar in interface SelectExpression
Overrides:
isScalar in class AbstractSelectExpression
Throws:
antlr.SemanticException

resolveCollectionProperty

public void resolveCollectionProperty(antlr.collections.AST expr)
                               throws antlr.SemanticException
Throws:
antlr.SemanticException

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException

prepareSelectColumns

protected void prepareSelectColumns(String[] columns)

getFromElement

public FromElement getFromElement()
Description copied from interface: SelectExpression
Returns the FROM element that this expression refers to.

Specified by:
getFromElement in interface SelectExpression
Overrides:
getFromElement in class AbstractSelectExpression

getDisplayText

public String getDisplayText()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Node (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class Node

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
All Implemented Interfaces:
antlr.collections.AST, Serializable
Direct Known Subclasses:
JavaConstantNode, SqlFragment, SqlNode
public class Node
extends antlr.CommonAST

Base node class for use by Hibernate within its AST trees.

Author:
Joshua Davis, Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
Node()
Node(antlr.Token tok)
Method Summary
int | getColumn()
String | getFilename()
int | getLine()
String | getRenderText(SessionFactoryImplementor sessionFactory) Retrieve the text to be used for rendering this particular node.
int | getTextLength()
void | initialize(antlr.collections.AST t)
void | initialize(antlr.Token tok)
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setText, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Node

public Node()

Node

public Node(antlr.Token tok)
Method Detail

getRenderText

public String getRenderText(SessionFactoryImplementor sessionFactory)
Retrieve the text to be used for rendering this particular node.

Parameters:
sessionFactory - The session factory
Returns:
The text to use for rendering

initialize

public void initialize(antlr.Token tok)

initialize

public void initialize(antlr.collections.AST t)

getFilename

public String getFilename()

getLine

public int getLine()

getColumn

public int getColumn()

getTextLength

public int getTextLength()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderByClause (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class OrderByClause

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.OrderByClause
All Implemented Interfaces:
antlr.collections.AST, HqlSqlTokenTypes, InitializeableNode, Serializable
public class OrderByClause
extends HqlSqlWalkerNode
implements HqlSqlTokenTypes

Implementation of OrderByClause.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Fields inherited from interface org.hibernate.hql.antlr.HqlSqlTokenTypes
AGGREGATE, ALIAS, ALIAS_REF, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOGUS, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FILTERS, FLOAT_SUFFIX, FROM, FROM_FRAGMENT, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IMPLIED_FROM, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, JOIN_FRAGMENT, LE, LEADING, LEFT, LEFT_OUTER, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, METHOD_NAME, MIN, MINUS, NAMED_PARAM, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, PROPERTY_REF, QUERY, QUOTED_STRING, RANGE, RIGHT, RIGHT_OUTER, ROW_STAR, SELECT, SELECT_CLAUSE, SELECT_COLUMNS, SELECT_EXPR, SELECT_FROM, SET, SOME, SQL_NE, SQL_TOKEN, STAR, SUM, THEN, THETA_JOINS, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
OrderByClause()
Method Summary
 void addOrderFragment(String orderByFragment)
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OrderByClause

public OrderByClause()
Method Detail

addOrderFragment

public void addOrderFragment(String orderByFragment)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class ParameterNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.ParameterNode
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, ExpectedTypeAwareNode, InitializeableNode, Serializable
public class ParameterNode
extends HqlSqlWalkerNode
implements DisplayableNode, ExpectedTypeAwareNode

Implementation of ParameterNode.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
ParameterNode()
Method Summary
String | getDisplayText() Returns additional display text for the AST node.
Type | getExpectedType()
ParameterSpecification | getHqlParameterSpecification()
String | getRenderText(SessionFactoryImplementor sessionFactory) Retrieve the text to be used for rendering this particular node.
void | setExpectedType(Type expectedType)
void | setHqlParameterSpecification(ParameterSpecification parameterSpecification)
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ParameterNode

public ParameterNode()
Method Detail

getHqlParameterSpecification

public ParameterSpecification getHqlParameterSpecification()

setHqlParameterSpecification

public void setHqlParameterSpecification(ParameterSpecification parameterSpecification)

getDisplayText

public String getDisplayText()
Description copied from interface: DisplayableNode
Returns additional display text for the AST node.

Specified by:
getDisplayText in interface DisplayableNode
Returns:
String - The additional display text.

setExpectedType

public void setExpectedType(Type expectedType)
Specified by:
setExpectedType in interface ExpectedTypeAwareNode

getExpectedType

public Type getExpectedType()
Specified by:
getExpectedType in interface ExpectedTypeAwareNode

getRenderText

public String getRenderText(SessionFactoryImplementor sessionFactory)
Description copied from class: Node
Retrieve the text to be used for rendering this particular node.

Overrides:
getRenderText in class Node
Parameters:
sessionFactory - The session factory
Returns:
The text to use for rendering
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class QueryNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractStatement
                            extended by org.hibernate.hql.ast.tree.AbstractRestrictableStatement
                                extended by org.hibernate.hql.ast.tree.QueryNode
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, RestrictableStatement, SelectExpression, Serializable, Statement
public class QueryNode
extends AbstractRestrictableStatement
implements SelectExpression

Defines a top-level AST node representing an HQL select statement.

Author:
Joshua Davis
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
QueryNode()
Method Summary
String | getAlias()
Type | getDataType() Returns the data type of the select expression.
FromElement | getFromElement() Returns the FROM element that this expression refers to.
protected org.apache.commons.logging.Log | getLog()
OrderByClause | getOrderByClause()
SelectClause | getSelectClause() Locate the select clause that is part of this select statement.
int | getStatementType() Return the main token type representing the type of this statement.
protected int | getWhereClauseParentTokenType()
boolean | hasOrderByClause()
boolean | isConstructor() Returns true if the element is a constructor (e.g.
boolean | isReturnableEntity() Returns true if this select expression represents an entity that can be returned.
boolean | isScalar()
boolean | needsExecutor() Does this statement require the StatementExecutor?
void | setAlias(String alias)
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.AbstractRestrictableStatement
getFromClause, getWhereClause, hasWhereClause, locateWhereClause
Methods inherited from class org.hibernate.hql.ast.tree.AbstractStatement
getDisplayText
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
setText
Methods inherited from interface org.hibernate.hql.ast.tree.Statement
getWalker

Constructor Detail

QueryNode

public QueryNode()
Method Detail

getStatementType

public int getStatementType()
Description copied from interface: Statement
Return the main token type representing the type of this statement.

Specified by:
getStatementType in interface Statement
Returns:
The corresponding token type.
See Also:
Statement.getStatementType()

needsExecutor

public boolean needsExecutor()
Description copied from interface: Statement
Does this statement require the StatementExecutor?

Essentially, at the JDBC level, does this require an executeUpdate()?

Specified by:
needsExecutor in interface Statement
Returns:
True if this statement should be handed off to the StatementExecutor to be executed; false otherwise.
See Also:
Statement.needsExecutor()

getWhereClauseParentTokenType

protected int getWhereClauseParentTokenType()
Specified by:
getWhereClauseParentTokenType in class AbstractRestrictableStatement

getLog

protected org.apache.commons.logging.Log getLog()
Specified by:
getLog in class AbstractRestrictableStatement

getSelectClause

public final SelectClause getSelectClause()
Locate the select clause that is part of this select statement.

Note, that this might return null as derived select clauses (i.e., no select clause at the HQL-level) get generated much later than when we get created; thus it depends upon lifecycle.

Returns:
Our select clause, or null.

hasOrderByClause

public final boolean hasOrderByClause()

getOrderByClause

public final OrderByClause getOrderByClause()

getAlias

public String getAlias()
Specified by:
getAlias in interface SelectExpression

getFromElement

public FromElement getFromElement()
Description copied from interface: SelectExpression
Returns the FROM element that this expression refers to.

Specified by:
getFromElement in interface SelectExpression
Returns:
The FROM element.

isConstructor

public boolean isConstructor()
Description copied from interface: SelectExpression
Returns true if the element is a constructor (e.g. new Foo).

Specified by:
isConstructor in interface SelectExpression
Returns:
true if the element is a constructor (e.g. new Foo).

isReturnableEntity

public boolean isReturnableEntity()
                           throws antlr.SemanticException
Description copied from interface: SelectExpression
Returns true if this select expression represents an entity that can be returned.

Specified by:
isReturnableEntity in interface SelectExpression
Returns:
true if this select expression represents an entity that can be returned.
Throws:
antlr.SemanticException

isScalar

public boolean isScalar()
                 throws antlr.SemanticException
Specified by:
isScalar in interface SelectExpression
Throws:
antlr.SemanticException

setAlias

public void setAlias(String alias)
Specified by:
setAlias in interface SelectExpression

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException

getDataType

public Type getDataType()
Description copied from interface: SelectExpression
Returns the data type of the select expression.

Specified by:
getDataType in interface SelectExpression
Overrides:
getDataType in class SqlNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectClause (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class SelectClause

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.SelectExpressionList
                            extended by org.hibernate.hql.ast.tree.SelectClause
All Implemented Interfaces:
antlr.collections.AST, InitializeableNode, Serializable
public class SelectClause
extends SelectExpressionList

Represents the list of expressions in a SELECT clause.

Author:
josh Sep 21, 2004 7:53:55 AM
See Also:
Serialized Form

Field Summary
static boolean VERSION2_SQL
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
SelectClause()
Method Summary
List | getCollectionFromElements()
String[][] | getColumnNames() The column alias names being used in the generated SQL.
Constructor | getConstructor() The constructor to use for dynamic instantiation queries.
protected antlr.collections.AST | getFirstSelectExpression() Returns the first select expression node that should be considered when building the array of select expressions.
List | getFromElementsForLoad() FromElements which need to be accounted for in the load phase (either for return or for fetch).
String[] | getQueryReturnAliases() The HQL aliases, or generated aliases
Type[] | getQueryReturnTypes() The types actually being returned from this query at the "object level".
void | initializeDerivedSelectClause(FromClause fromClause) Prepares a derived (i.e., not explicitly defined in the query) select clause.
void | initializeExplicitSelectClause(FromClause fromClause) Prepares an explicitly defined select clause.
boolean | isDistinct()
boolean | isList()
boolean | isMap()
boolean | isScalarSelect() Does this SelectClause represent a scalar query
Methods inherited from class org.hibernate.hql.ast.tree.SelectExpressionList
collectSelectExpressions
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

VERSION2_SQL

public static boolean VERSION2_SQL
Constructor Detail

SelectClause

public SelectClause()
Method Detail

isScalarSelect

public boolean isScalarSelect()
Does this SelectClause represent a scalar query

Returns:
True if this is a scalara select clause; false otherwise.

isDistinct

public boolean isDistinct()

getFromElementsForLoad

public List getFromElementsForLoad()
FromElements which need to be accounted for in the load phase (either for return or for fetch).

Returns:
List of appropriate FromElements.

getQueryReturnTypes

public Type[] getQueryReturnTypes()
The types actually being returned from this query at the "object level".

Returns:
The query return types.

getQueryReturnAliases

public String[] getQueryReturnAliases()
The HQL aliases, or generated aliases

getColumnNames

public String[][] getColumnNames()
The column alias names being used in the generated SQL.

Returns:
The SQL column aliases.

getConstructor

public Constructor getConstructor()
The constructor to use for dynamic instantiation queries.

Returns:
The appropriate Constructor reference, or null if not a dynamic instantiation query.

isMap

public boolean isMap()

isList

public boolean isList()

initializeExplicitSelectClause

public void initializeExplicitSelectClause(FromClause fromClause)
                                    throws antlr.SemanticException
Prepares an explicitly defined select clause.

Parameters:
fromClause - The from clause linked to this select clause.
Throws:
antlr.SemanticException

initializeDerivedSelectClause

public void initializeDerivedSelectClause(FromClause fromClause)
                                   throws antlr.SemanticException
Prepares a derived (i.e., not explicitly defined in the query) select clause.

Parameters:
fromClause - The from clause to which this select clause is linked.
Throws:
antlr.SemanticException

getFirstSelectExpression

protected antlr.collections.AST getFirstSelectExpression()
Description copied from class: SelectExpressionList
Returns the first select expression node that should be considered when building the array of select expressions.

Specified by:
getFirstSelectExpression in class SelectExpressionList
Returns:
the first select expression node that should be considered when building the array of select expressions

getCollectionFromElements

public List getCollectionFromElements()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectExpressionImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class SelectExpressionImpl

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.FromReferenceNode
                                extended by org.hibernate.hql.ast.tree.SelectExpressionImpl
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, PathNode, ResolvableNode, SelectExpression, Serializable
public class SelectExpressionImpl
extends FromReferenceNode
implements SelectExpression

A select expression that was generated by a FROM element.

Author:
josh Nov 6, 2004 8:27:38 AM
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.hql.ast.tree.FromReferenceNode
ROOT_LEVEL
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
SelectExpressionImpl()
Method Summary
void | resolve(boolean generateJoin, boolean implicitJoin, String classAlias, antlr.collections.AST parent) Does the work of resolving an identifier or a dot
void | resolveIndex(antlr.collections.AST parent) Does the work of resolving an an index [].
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.FromReferenceNode
getDisplayText, getFromElement, getImpliedJoin, getPath, isResolved, isReturnableEntity, prepareForDot, recursiveResolve, recursiveResolve, resolve, resolve, resolveFirstChild, resolveInFunctionCall, setFromElement, setResolved
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, isConstructor, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
getAlias, getDataType, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias, setText
Methods inherited from interface org.hibernate.hql.ast.tree.InitializeableNode
initialize

Constructor Detail

SelectExpressionImpl

public SelectExpressionImpl()
Method Detail

resolveIndex

public void resolveIndex(antlr.collections.AST parent)
                  throws antlr.SemanticException
Description copied from interface: ResolvableNode
Does the work of resolving an an index [].

Specified by:
resolveIndex in interface ResolvableNode
Throws:
antlr.SemanticException

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException

resolve

public void resolve(boolean generateJoin,
                    boolean implicitJoin,
                    String classAlias,
                    antlr.collections.AST parent)
             throws antlr.SemanticException
Description copied from interface: ResolvableNode
Does the work of resolving an identifier or a dot

Specified by:
resolve in interface ResolvableNode
Throws:
antlr.SemanticException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectExpressionList (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class SelectExpressionList

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.SelectExpressionList
All Implemented Interfaces:
antlr.collections.AST, InitializeableNode, Serializable
Direct Known Subclasses:
ConstructorNode, SelectClause
public abstract class SelectExpressionList
extends HqlSqlWalkerNode

Common behavior - a node that contains a list of select expressions.

Author:
josh Nov 6, 2004 8:51:00 AM
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
SelectExpressionList()
Method Summary
SelectExpression[] | collectSelectExpressions() Returns an array of SelectExpressions gathered from the children of the given parent AST node.
protected abstract antlr.collections.AST | getFirstSelectExpression() Returns the first select expression node that should be considered when building the array of select expressions.
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SelectExpressionList

public SelectExpressionList()
Method Detail

collectSelectExpressions

public SelectExpression[] collectSelectExpressions()
Returns an array of SelectExpressions gathered from the children of the given parent AST node.

Returns:
an array of SelectExpressions gathered from the children of the given parent AST node.

getFirstSelectExpression

protected abstract antlr.collections.AST getFirstSelectExpression()
Returns the first select expression node that should be considered when building the array of select expressions.

Returns:
the first select expression node that should be considered when building the array of select expressions
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SqlFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class SqlFragment

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlFragment
All Implemented Interfaces:
antlr.collections.AST, Serializable
public class SqlFragment
extends Node

Represents an SQL fragment in the AST.

Author:
josh Dec 5, 2004 9:01:52 AM
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
SqlFragment()
Method Summary
FromElement | getFromElement()
boolean | hasFilterCondition()
void | setFromElement(FromElement fromElement)
void | setJoinFragment(JoinFragment joinFragment)
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setText, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SqlFragment

public SqlFragment()
Method Detail

setJoinFragment

public void setJoinFragment(JoinFragment joinFragment)

hasFilterCondition

public boolean hasFilterCondition()

setFromElement

public void setFromElement(FromElement fromElement)

getFromElement

public FromElement getFromElement()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SqlNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class SqlNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
All Implemented Interfaces:
antlr.collections.AST, Serializable
Direct Known Subclasses:
BetweenOperatorNode, HqlSqlWalkerNode, UnaryLogicOperatorNode
public class SqlNode
extends Node

A base AST node for the intermediate tree. User: josh Date: Dec 6, 2003 Time: 10:29:14 AM

See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
SqlNode()
Method Summary
Type | getDataType()
String | getOriginalText()
void | setDataType(Type dataType)
void | setText(String s)
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SqlNode

public SqlNode()
Method Detail

setText

public void setText(String s)

getOriginalText

public String getOriginalText()

getDataType

public Type getDataType()

setDataType

public void setDataType(Type dataType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnaryArithmeticNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class UnaryArithmeticNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractSelectExpression
                            extended by org.hibernate.hql.ast.tree.UnaryArithmeticNode
All Implemented Interfaces:
antlr.collections.AST, InitializeableNode, OperatorNode, SelectExpression, Serializable, UnaryOperatorNode
public class UnaryArithmeticNode
extends AbstractSelectExpression
implements UnaryOperatorNode

See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
UnaryArithmeticNode()
Method Summary
Type | getDataType() Retrieves the data type for the overall operator expression.
Node | getOperand() Retrievs the node representing the operator's single operand.
void | initialize() Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.
void | setScalarColumnText(int i) Appends AST nodes that represent the columns after the current AST node.
Methods inherited from class org.hibernate.hql.ast.tree.AbstractSelectExpression
getAlias, getFromElement, isConstructor, isReturnableEntity, isScalar, setAlias
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.SelectExpression
setText

Constructor Detail

UnaryArithmeticNode

public UnaryArithmeticNode()
Method Detail

getDataType

public Type getDataType()
Description copied from interface: OperatorNode
Retrieves the data type for the overall operator expression.

Specified by:
getDataType in interface OperatorNode
Overrides:
getDataType in class SqlNode

setScalarColumnText

public void setScalarColumnText(int i)
                         throws antlr.SemanticException
Description copied from interface: SelectExpression
Appends AST nodes that represent the columns after the current AST node. (e.g. 'as col0_O_')

Specified by:
setScalarColumnText in interface SelectExpression
Parameters:
i - The index of the select expression in the projection list.
Throws:
antlr.SemanticException

initialize

public void initialize()
Description copied from interface: OperatorNode
Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.

Specified by:
initialize in interface OperatorNode

getOperand

public Node getOperand()
Description copied from interface: UnaryOperatorNode
Retrievs the node representing the operator's single operand.

Specified by:
getOperand in interface UnaryOperatorNode
Returns:
The operator's single operand.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnaryLogicOperatorNode (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class UnaryLogicOperatorNode

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.UnaryLogicOperatorNode
All Implemented Interfaces:
antlr.collections.AST, OperatorNode, Serializable, UnaryOperatorNode
public class UnaryLogicOperatorNode
extends SqlNode
implements UnaryOperatorNode

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
UnaryLogicOperatorNode()
Method Summary
Type | getDataType() Retrieves the data type for the overall operator expression.
Node | getOperand() Retrievs the node representing the operator's single operand.
void | initialize() Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnaryLogicOperatorNode

public UnaryLogicOperatorNode()
Method Detail

getOperand

public Node getOperand()
Description copied from interface: UnaryOperatorNode
Retrievs the node representing the operator's single operand.

Specified by:
getOperand in interface UnaryOperatorNode
Returns:
The operator's single operand.

initialize

public void initialize()
Description copied from interface: OperatorNode
Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.

Specified by:
initialize in interface OperatorNode

getDataType

public Type getDataType()
Description copied from interface: OperatorNode
Retrieves the data type for the overall operator expression.

Specified by:
getDataType in interface OperatorNode
Overrides:
getDataType in class SqlNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UpdateStatement (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.tree
Class UpdateStatement

java.lang.Object
    extended by antlr.BaseAST
        extended by antlr.CommonAST
            extended by org.hibernate.hql.ast.tree.Node
                extended by org.hibernate.hql.ast.tree.SqlNode
                    extended by org.hibernate.hql.ast.tree.HqlSqlWalkerNode
                        extended by org.hibernate.hql.ast.tree.AbstractStatement
                            extended by org.hibernate.hql.ast.tree.AbstractRestrictableStatement
                                extended by org.hibernate.hql.ast.tree.UpdateStatement
All Implemented Interfaces:
antlr.collections.AST, DisplayableNode, InitializeableNode, RestrictableStatement, Serializable, Statement
public class UpdateStatement
extends AbstractRestrictableStatement

Defines a top-level AST node representing an HQL update statement.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class antlr.BaseAST
down, right
Constructor Summary
UpdateStatement()
Method Summary
protected org.apache.commons.logging.Log | getLog()
antlr.collections.AST | getSetClause()
int | getStatementType() Return the main token type representing the type of this statement.
protected int | getWhereClauseParentTokenType()
boolean | needsExecutor() Does this statement require the StatementExecutor?
Methods inherited from class org.hibernate.hql.ast.tree.AbstractRestrictableStatement
getFromClause, getWhereClause, hasWhereClause, locateWhereClause
Methods inherited from class org.hibernate.hql.ast.tree.AbstractStatement
getDisplayText
Methods inherited from class org.hibernate.hql.ast.tree.HqlSqlWalkerNode
getAliasGenerator, getASTFactory, getSessionFactoryHelper, getWalker, initialize
Methods inherited from class org.hibernate.hql.ast.tree.SqlNode
getDataType, getOriginalText, setDataType, setText
Methods inherited from class org.hibernate.hql.ast.tree.Node
getColumn, getFilename, getLine, getRenderText, getTextLength, initialize, initialize
Methods inherited from class antlr.CommonAST
getText, getType, initialize, setType
Methods inherited from class antlr.BaseAST
addChild, decode, encode, equals, equalsList, equalsListPartial, equalsTree, equalsTreePartial, findAll, findAllPartial, getFirstChild, getNextSibling, getNumberOfChildren, getTokenNames, removeChildren, setFirstChild, setNextSibling, setVerboseStringConversion, toString, toStringList, toStringTree, xmlSerialize, xmlSerializeNode, xmlSerializeRootClose, xmlSerializeRootOpen
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.hql.ast.tree.Statement
getWalker

Constructor Detail

UpdateStatement

public UpdateStatement()
Method Detail

getStatementType

public int getStatementType()
Description copied from interface: Statement
Return the main token type representing the type of this statement.

Returns:
The corresponding token type.
See Also:
Statement.getStatementType()

needsExecutor

public boolean needsExecutor()
Description copied from interface: Statement
Does this statement require the StatementExecutor?

Essentially, at the JDBC level, does this require an executeUpdate()?

Returns:
True if this statement should be handed off to the StatementExecutor to be executed; false otherwise.
See Also:
Statement.needsExecutor()

getWhereClauseParentTokenType

protected int getWhereClauseParentTokenType()
Specified by:
getWhereClauseParentTokenType in class AbstractRestrictableStatement

getLog

protected org.apache.commons.logging.Log getLog()
Specified by:
getLog in class AbstractRestrictableStatement

getSetClause

public antlr.collections.AST getSetClause()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.hql.ast.util (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.hql.ast.util

Interface Summary
ASTUtil.FilterPredicate | Filters nodes out of a tree.
NodeTraverser.VisitationStrategy |

Class Summary
AliasGenerator | Generates class/table/column aliases during semantic analysis and SQL rendering.
ASTAppender | Appends child nodes to a parent efficiently.
ASTIterator | Depth first iteration of an ANTLR AST.
ASTParentsFirstIterator | Depth first iteration of an ANTLR AST.
ASTPrinter | An 'ASCII art' AST printer for debugging ANTLR grammars.
ASTUtil | Provides utility methods for AST traversal and manipulation.
ASTUtil.IncludePredicate | A predicate that uses inclusion, rather than exclusion semantics.
ColumnHelper | Provides utility methods for dealing with arrays of SQL column names.
JoinProcessor | Performs the post-processing of the join information gathered during semantic analysis.
LiteralProcessor | A delegate that handles literals and constants for HqlSqlWalker, performing the token replacement functions and classifying literals.
NodeTraverser | A visitor for traversing an AST tree.
PathHelper | Provides utility methods for paths.
SessionFactoryHelper | Wraps SessionFactoryImpl, adding more lookup behaviors and encapsulating some of the error handling.
SyntheticAndFactory | Creates synthetic and nodes based on the where fragment part of a JoinSequence.


org.hibernate.hql.ast.util Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.hql.ast.util

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.hql.ast.util.AliasGenerator
    • class org.hibernate.hql.ast.util.ASTAppender
    • class org.hibernate.hql.ast.util.ASTIterator (implements java.util.Iterator)
    • class org.hibernate.hql.ast.util.ASTParentsFirstIterator (implements java.util.Iterator)
    • class org.hibernate.hql.ast.util.ASTPrinter
    • class org.hibernate.hql.ast.util.ASTUtil
    • class org.hibernate.hql.ast.util.ASTUtil.IncludePredicate (implements org.hibernate.hql.ast.util.ASTUtil.FilterPredicate)
    • class org.hibernate.hql.ast.util.ColumnHelper
    • class org.hibernate.hql.ast.util.JoinProcessor (implements org.hibernate.hql.antlr.SqlTokenTypes)
    • class org.hibernate.hql.ast.util.LiteralProcessor (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)
    • class org.hibernate.hql.ast.util.NodeTraverser
    • class org.hibernate.hql.ast.util.PathHelper
    • class org.hibernate.hql.ast.util.SessionFactoryHelper
    • class org.hibernate.hql.ast.util.SyntheticAndFactory (implements org.hibernate.hql.antlr.HqlSqlTokenTypes)

Interface Hierarchy

  • interface org.hibernate.hql.ast.util.ASTUtil.FilterPredicate
  • interface org.hibernate.hql.ast.util.NodeTraverser.VisitationStrategy


Uses of Package org.hibernate.hql.ast.util (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.hql.ast.util

Packages that use org.hibernate.hql.ast.util
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |

Classes in org.hibernate.hql.ast.util used by org.hibernate.hql.ast
AliasGenerator
Generates class/table/column aliases during semantic analysis and SQL rendering.
ASTPrinter
An 'ASCII art' AST printer for debugging ANTLR grammars.
LiteralProcessor
A delegate that handles literals and constants for HqlSqlWalker, performing the token replacement functions and classifying literals.
NodeTraverser.VisitationStrategy
SessionFactoryHelper
Wraps SessionFactoryImpl, adding more lookup behaviors and encapsulating some of the error handling.

Classes in org.hibernate.hql.ast.util used by org.hibernate.hql.ast.tree
AliasGenerator
Generates class/table/column aliases during semantic analysis and SQL rendering.
SessionFactoryHelper
Wraps SessionFactoryImpl, adding more lookup behaviors and encapsulating some of the error handling.

Classes in org.hibernate.hql.ast.util used by org.hibernate.hql.ast.util
ASTUtil.FilterPredicate
Filters nodes out of a tree.
NodeTraverser.VisitationStrategy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AliasGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class AliasGenerator

java.lang.Object
    extended by org.hibernate.hql.ast.util.AliasGenerator
public class AliasGenerator
extends Object

Generates class/table/column aliases during semantic analysis and SQL rendering.

Its essential purpose is to keep an internal counter to ensure that the generated aliases are unique.

Constructor Summary
AliasGenerator()
Method Summary
 String createName(String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AliasGenerator

public AliasGenerator()
Method Detail

createName

public String createName(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ASTAppender (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class ASTAppender

java.lang.Object
    extended by org.hibernate.hql.ast.util.ASTAppender
public class ASTAppender
extends Object

Appends child nodes to a parent efficiently.

Author:
josh Jul 24, 2004 8:28:23 AM

Constructor Summary
ASTAppender(antlr.collections.AST parent)
ASTAppender(antlr.ASTFactory factory, antlr.collections.AST parent)
Method Summary
antlr.collections.AST | append(antlr.collections.AST child)
antlr.collections.AST | append(int type, String text, boolean appendIfEmpty)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ASTAppender

public ASTAppender(antlr.ASTFactory factory,
                   antlr.collections.AST parent)

ASTAppender

public ASTAppender(antlr.collections.AST parent)
Method Detail

append

public antlr.collections.AST append(int type,
                                    String text,
                                    boolean appendIfEmpty)

append

public antlr.collections.AST append(antlr.collections.AST child)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ASTIterator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class ASTIterator

java.lang.Object
    extended by org.hibernate.hql.ast.util.ASTIterator
All Implemented Interfaces:
Iterator
public class ASTIterator
extends Object
implements Iterator

Depth first iteration of an ANTLR AST.

Author:
josh Sep 25, 2004 7:44:39 AM

Constructor Summary
ASTIterator(antlr.collections.AST tree)
Method Summary
boolean | hasNext()
Object | next()
antlr.collections.AST | nextNode()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ASTIterator

public ASTIterator(antlr.collections.AST tree)
Method Detail

remove

public void remove()
Specified by:
remove in interface Iterator

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

nextNode

public antlr.collections.AST nextNode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ASTParentsFirstIterator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class ASTParentsFirstIterator

java.lang.Object
    extended by org.hibernate.hql.ast.util.ASTParentsFirstIterator
All Implemented Interfaces:
Iterator
public class ASTParentsFirstIterator
extends Object
implements Iterator

Depth first iteration of an ANTLR AST.

Author:
josh Sep 25, 2004 7:44:39 AM

Constructor Summary
ASTParentsFirstIterator(antlr.collections.AST tree)
Method Summary
boolean | hasNext()
Object | next()
antlr.collections.AST | nextNode()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ASTParentsFirstIterator

public ASTParentsFirstIterator(antlr.collections.AST tree)
Method Detail

remove

public void remove()
Specified by:
remove in interface Iterator

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

nextNode

public antlr.collections.AST nextNode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ASTPrinter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class ASTPrinter

java.lang.Object
    extended by org.hibernate.hql.ast.util.ASTPrinter
public class ASTPrinter
extends Object

An 'ASCII art' AST printer for debugging ANTLR grammars.

Author:
Joshua Davis (pgmjsd@sourceforge.net)

Constructor Summary
ASTPrinter(Class tokenTypeConstants)
Constructs an org.hibernate.hql.antlr.ASTPrinter, given the class that contains the token type constants (typically the '{grammar}TokenTypes' interface generated by ANTLR).
Method Summary
static void | appendEscapedMultibyteChars(String text, StringBuffer buf)
static String | escapeMultibyteChars(String text)
static String | getConstantName(Class tokenTypeConstants, int type) Get a single token type name in the specified set of token type constants (interface).
boolean | isShowClassNames() Returns true if the node class names will be displayed.
String | nodeToString(antlr.collections.AST ast, boolean showClassName)
void | setShowClassNames(boolean showClassNames) Enables or disables AST node class name display.
String | showAsString(antlr.collections.AST ast, String header) Prints the AST in 'ASCII art' tree form into a string.
void | showAst(antlr.collections.AST ast, PrintWriter pw) Prints the AST in 'ASCII art' tree form to the specified print writer.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ASTPrinter

public ASTPrinter(Class tokenTypeConstants)
Constructs an org.hibernate.hql.antlr.ASTPrinter, given the class that contains the token type constants (typically the '{grammar}TokenTypes' interface generated by ANTLR).

Parameters:
tokenTypeConstants - The class with token type constants in it.
Method Detail

isShowClassNames

public boolean isShowClassNames()
Returns true if the node class names will be displayed.

Returns:
true if the node class names will be displayed.

setShowClassNames

public void setShowClassNames(boolean showClassNames)
Enables or disables AST node class name display.

Parameters:
showClassNames - true to enable class name display, false to disable

showAst

public void showAst(antlr.collections.AST ast,
                    PrintWriter pw)
Prints the AST in 'ASCII art' tree form to the specified print writer.

Parameters:
ast - The AST to print.
pw - The print writer.

showAsString

public String showAsString(antlr.collections.AST ast,
                           String header)
Prints the AST in 'ASCII art' tree form into a string.

Parameters:
ast - The AST to display.
header - The header for the display.
Returns:
The AST in 'ASCII art' form, as a string.

getConstantName

public static String getConstantName(Class tokenTypeConstants,
                                     int type)
Get a single token type name in the specified set of token type constants (interface).

Parameters:
tokenTypeConstants - Token type constants interface (e.g. HqlSqlTokenTypes.class).
type - The token type ( typically from ast.getType() ).
Returns:
The token type name, *or* the integer value if the name could not be found for some reason.

nodeToString

public String nodeToString(antlr.collections.AST ast,
                           boolean showClassName)

appendEscapedMultibyteChars

public static void appendEscapedMultibyteChars(String text,
                                               StringBuffer buf)

escapeMultibyteChars

public static String escapeMultibyteChars(String text)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ASTUtil (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class ASTUtil

java.lang.Object
    extended by org.hibernate.hql.ast.util.ASTUtil
public final class ASTUtil
extends Object

Provides utility methods for AST traversal and manipulation.

Author:
Joshua Davis (pgmjsd@sourceforge.net)

Nested Class Summary
static interface | ASTUtil.FilterPredicate Filters nodes out of a tree.
static class | ASTUtil.IncludePredicate A predicate that uses inclusion, rather than exclusion semantics.
Method Summary
static void | appendSibling(antlr.collections.AST n, antlr.collections.AST s)
static List | collectChildren(antlr.collections.AST root, ASTUtil.FilterPredicate predicate)
static antlr.collections.AST | create(antlr.ASTFactory astFactory, int type, String text) Creates a single node AST.
static antlr.collections.AST | createBinarySubtree(antlr.ASTFactory factory, int parentType, String parentText, antlr.collections.AST child1, antlr.collections.AST child2) Creates a 'binary operator' subtree, given the information about the parent and the two child nodex.
static antlr.collections.AST | createParent(antlr.ASTFactory factory, int parentType, String parentText, antlr.collections.AST child) Creates a single parent of the specified child (i.e.
static antlr.collections.AST | createSibling(antlr.ASTFactory astFactory, int type, String text, antlr.collections.AST prevSibling) Creates a single node AST as a sibling.
static antlr.collections.AST | createTree(antlr.ASTFactory factory, antlr.collections.AST[] nestedChildren)
static antlr.collections.AST | findPreviousSibling(antlr.collections.AST parent, antlr.collections.AST child) Find the previous sibling in the parent for the given child.
static antlr.collections.AST | findTypeInChildren(antlr.collections.AST parent, int type) Finds the first node of the specified type in the chain of children.
static String | getDebugString(antlr.collections.AST n) Returns the 'list' representation with some brackets around it for debugging.
static antlr.collections.AST | getLastChild(antlr.collections.AST n) Returns the last direct child of 'n'.
static String | getPathText(antlr.collections.AST n)
static boolean | hasExactlyOneChild(antlr.collections.AST n)
static void | insertChild(antlr.collections.AST parent, antlr.collections.AST child) Inserts the child as the first child of the parent, all other children are shifted over to the 'right'.
static antlr.collections.AST | insertSibling(antlr.collections.AST node, antlr.collections.AST prevSibling)
static boolean | isDirectChild(antlr.collections.AST fixture, antlr.collections.AST test) Determine if a given node (test) is a direct (throtle to one level down) child of another given node (fixture).
static boolean | isSubtreeChild(antlr.collections.AST fixture, antlr.collections.AST test) Determine if a given node (test) is contained anywhere in the subtree of another given node (fixture).
static void | makeSiblingOfParent(antlr.collections.AST parent, antlr.collections.AST child) Makes the child node a sibling of the parent, reconnecting all siblings.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

create

public static antlr.collections.AST create(antlr.ASTFactory astFactory,
                                           int type,
                                           String text)
Creates a single node AST.

Parameters:
astFactory - The factory.
type - The node type.
text - The node text.
Returns:
AST - A single node tree.

createSibling

public static antlr.collections.AST createSibling(antlr.ASTFactory astFactory,
                                                  int type,
                                                  String text,
                                                  antlr.collections.AST prevSibling)
Creates a single node AST as a sibling.

Parameters:
astFactory - The factory.
type - The node type.
text - The node text.
prevSibling - The previous sibling.
Returns:
AST - A single node tree.

insertSibling

public static antlr.collections.AST insertSibling(antlr.collections.AST node,
                                                  antlr.collections.AST prevSibling)

createBinarySubtree

public static antlr.collections.AST createBinarySubtree(antlr.ASTFactory factory,
                                                        int parentType,
                                                        String parentText,
                                                        antlr.collections.AST child1,
                                                        antlr.collections.AST child2)
Creates a 'binary operator' subtree, given the information about the parent and the two child nodex.

Parameters:
factory - The AST factory.
parentType - The type of the parent node.
parentText - The text of the parent node.
child1 - The first child.
child2 - The second child.
Returns:
AST - A new sub-tree of the form "(parent child1 child2)"

createParent

public static antlr.collections.AST createParent(antlr.ASTFactory factory,
                                                 int parentType,
                                                 String parentText,
                                                 antlr.collections.AST child)
Creates a single parent of the specified child (i.e. a 'unary operator' subtree).

Parameters:
factory - The AST factory.
parentType - The type of the parent node.
parentText - The text of the parent node.
child - The child.
Returns:
AST - A new sub-tree of the form "(parent child)"

createTree

public static antlr.collections.AST createTree(antlr.ASTFactory factory,
                                               antlr.collections.AST[] nestedChildren)

findTypeInChildren

public static antlr.collections.AST findTypeInChildren(antlr.collections.AST parent,
                                                       int type)
Finds the first node of the specified type in the chain of children.

Parameters:
parent - The parent
type - The type to find.
Returns:
The first node of the specified type, or null if not found.

getLastChild

public static antlr.collections.AST getLastChild(antlr.collections.AST n)
Returns the last direct child of 'n'.

Parameters:
n - The parent
Returns:
The last direct child of 'n'.

getDebugString

public static String getDebugString(antlr.collections.AST n)
Returns the 'list' representation with some brackets around it for debugging.

Parameters:
n - The tree.
Returns:
The list representation of the tree.

findPreviousSibling

public static antlr.collections.AST findPreviousSibling(antlr.collections.AST parent,
                                                        antlr.collections.AST child)
Find the previous sibling in the parent for the given child.

Parameters:
parent - the parent node
child - the child to find the previous sibling of
Returns:
the previous sibling of the child

isDirectChild

public static boolean isDirectChild(antlr.collections.AST fixture,
                                    antlr.collections.AST test)
Determine if a given node (test) is a direct (throtle to one level down) child of another given node (fixture).

Parameters:
fixture - The node against which to testto be checked for children.
test - The node to be tested as being a child of the parent.
Returns:
True if test is contained in the fixtures's direct children; false otherwise.

isSubtreeChild

public static boolean isSubtreeChild(antlr.collections.AST fixture,
                                     antlr.collections.AST test)
Determine if a given node (test) is contained anywhere in the subtree of another given node (fixture).

Parameters:
fixture - The node against which to testto be checked for children.
test - The node to be tested as being a subtree child of the parent.
Returns:
True if child is contained in the parent's collection of children.

makeSiblingOfParent

public static void makeSiblingOfParent(antlr.collections.AST parent,
                                       antlr.collections.AST child)
Makes the child node a sibling of the parent, reconnecting all siblings.

Parameters:
parent - the parent
child - the child

getPathText

public static String getPathText(antlr.collections.AST n)

hasExactlyOneChild

public static boolean hasExactlyOneChild(antlr.collections.AST n)

appendSibling

public static void appendSibling(antlr.collections.AST n,
                                 antlr.collections.AST s)

insertChild

public static void insertChild(antlr.collections.AST parent,
                               antlr.collections.AST child)
Inserts the child as the first child of the parent, all other children are shifted over to the 'right'.

Parameters:
parent - the parent
child - the new first child

collectChildren

public static List collectChildren(antlr.collections.AST root,
                                   ASTUtil.FilterPredicate predicate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ASTUtil.FilterPredicate (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Interface ASTUtil.FilterPredicate

All Known Implementing Classes:
ASTUtil.IncludePredicate
Enclosing interface:
ASTUtil
public static interface ASTUtil.FilterPredicate

Filters nodes out of a tree.

Method Summary
 boolean exclude(antlr.collections.AST n)
Returns true if the node should be filtered out.

Method Detail

exclude

public boolean exclude(antlr.collections.AST n)
Returns true if the node should be filtered out.

Parameters:
n - The node.
Returns:
true if the node should be filtered out, false to keep the node.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ASTUtil.IncludePredicate (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class ASTUtil.IncludePredicate

java.lang.Object
    extended by org.hibernate.hql.ast.util.ASTUtil.IncludePredicate
All Implemented Interfaces:
ASTUtil.FilterPredicate
Enclosing class:
ASTUtil
public abstract static class ASTUtil.IncludePredicate
extends Object
implements ASTUtil.FilterPredicate

A predicate that uses inclusion, rather than exclusion semantics.

Constructor Summary
ASTUtil.IncludePredicate()
Method Summary
boolean | exclude(antlr.collections.AST node) Returns true if the node should be filtered out.
abstract boolean | include(antlr.collections.AST node)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ASTUtil.IncludePredicate

public ASTUtil.IncludePredicate()
Method Detail

exclude

public final boolean exclude(antlr.collections.AST node)
Description copied from interface: ASTUtil.FilterPredicate
Returns true if the node should be filtered out.

Specified by:
exclude in interface ASTUtil.FilterPredicate
Parameters:
node - The node.
Returns:
true if the node should be filtered out, false to keep the node.

include

public abstract boolean include(antlr.collections.AST node)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ColumnHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class ColumnHelper

java.lang.Object
    extended by org.hibernate.hql.ast.util.ColumnHelper
public final class ColumnHelper
extends Object

Provides utility methods for dealing with arrays of SQL column names.

Author:
josh Jan 3, 2005 9:08:47 AM

Method Summary
static void | generateScalarColumns(HqlSqlWalkerNode node, String[] sqlColumns, int i) Generates the scalar column AST nodes for a given array of SQL columns
static void | generateSingleScalarColumn(HqlSqlWalkerNode node, int i)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

generateSingleScalarColumn

public static void generateSingleScalarColumn(HqlSqlWalkerNode node,
                                              int i)

generateScalarColumns

public static void generateScalarColumns(HqlSqlWalkerNode node,
                                         String[] sqlColumns,
                                         int i)
Generates the scalar column AST nodes for a given array of SQL columns

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JoinProcessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class JoinProcessor

java.lang.Object
    extended by org.hibernate.hql.ast.util.JoinProcessor
All Implemented Interfaces:
SqlTokenTypes
public class JoinProcessor
extends Object
implements SqlTokenTypes

Performs the post-processing of the join information gathered during semantic analysis. The join generating classes are complex, this encapsulates some of the JoinSequence-related code.

Author:
josh Jul 22, 2004 7:33:42 AM

Field Summary
Fields inherited from interface org.hibernate.hql.antlr.SqlTokenTypes
AGGREGATE, ALIAS, ALIAS_REF, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOGUS, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FILTERS, FLOAT_SUFFIX, FROM, FROM_FRAGMENT, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IMPLIED_FROM, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, JOIN_FRAGMENT, LE, LEADING, LEFT, LEFT_OUTER, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, METHOD_NAME, MIN, MINUS, NAMED_PARAM, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, PROPERTY_REF, QUERY, QUOTED_STRING, RANGE, RIGHT, RIGHT_OUTER, ROW_STAR, SELECT, SELECT_CLAUSE, SELECT_COLUMNS, SELECT_EXPR, SELECT_FROM, SET, SOME, SQL_NE, SQL_NODE, SQL_TOKEN, STAR, SUM, THEN, THETA_JOINS, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
JoinProcessor(antlr.ASTFactory astFactory, QueryTranslatorImpl queryTranslatorImpl)
Constructs a new JoinProcessor.
Method Summary
void | processJoins(QueryNode query, boolean inSubquery)
static int | toHibernateJoinType(int astJoinType) Translates an AST join type (i.e., the token type) into a JoinFragment.XXX join type.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JoinProcessor

public JoinProcessor(antlr.ASTFactory astFactory,
                     QueryTranslatorImpl queryTranslatorImpl)
Constructs a new JoinProcessor.

Parameters:
astFactory - The factory for AST node creation.
queryTranslatorImpl - The query translator.
Method Detail

toHibernateJoinType

public static int toHibernateJoinType(int astJoinType)
Translates an AST join type (i.e., the token type) into a JoinFragment.XXX join type.

Parameters:
astJoinType - The AST join type (from HqlSqlTokenTypes or SqlTokenTypes)
Returns:
a JoinFragment.XXX join type.
See Also:
JoinFragment, SqlTokenTypes

processJoins

public void processJoins(QueryNode query,
                         boolean inSubquery)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LiteralProcessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class LiteralProcessor

java.lang.Object
    extended by org.hibernate.hql.ast.util.LiteralProcessor
All Implemented Interfaces:
HqlSqlTokenTypes
public class LiteralProcessor
extends Object
implements HqlSqlTokenTypes

A delegate that handles literals and constants for HqlSqlWalker, performing the token replacement functions and classifying literals.

Author:
josh Sep 2, 2004 7:15:30 AM

Field Summary
static int | APPROXIMATE Indicates that Float and Double literal values should be treated using the SQL "approximate" format (i.e., '1E-3')
static int | DECIMAL_LITERAL_FORMAT In what format should Float and Double literal values be sent to the database?
static int | EXACT Indicates that Float and Double literal values should be treated using the SQL "exact" format (i.e., '.001')
Fields inherited from interface org.hibernate.hql.antlr.HqlSqlTokenTypes
AGGREGATE, ALIAS, ALIAS_REF, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOGUS, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FILTERS, FLOAT_SUFFIX, FROM, FROM_FRAGMENT, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IMPLIED_FROM, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, JOIN_FRAGMENT, LE, LEADING, LEFT, LEFT_OUTER, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, METHOD_NAME, MIN, MINUS, NAMED_PARAM, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, PROPERTY_REF, QUERY, QUOTED_STRING, RANGE, RIGHT, RIGHT_OUTER, ROW_STAR, SELECT, SELECT_CLAUSE, SELECT_COLUMNS, SELECT_EXPR, SELECT_FROM, SET, SOME, SQL_NE, SQL_TOKEN, STAR, SUM, THEN, THETA_JOINS, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
LiteralProcessor(HqlSqlWalker hqlSqlWalker)
Method Summary
String | determineDecimalRepresentation(String text, int type)
boolean | isAlias(String alias)
void | lookupConstant(DotNode node)
void | processBoolean(antlr.collections.AST constant)
void | processConstant(antlr.collections.AST constant, boolean resolveIdent)
void | processNumeric(antlr.collections.AST literal)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EXACT

public static final int EXACT
Indicates that Float and Double literal values should be treated using the SQL "exact" format (i.e., '.001')

See Also:
Constant Field Values

APPROXIMATE

public static final int APPROXIMATE
Indicates that Float and Double literal values should be treated using the SQL "approximate" format (i.e., '1E-3')

See Also:
Constant Field Values

DECIMAL_LITERAL_FORMAT

public static int DECIMAL_LITERAL_FORMAT
In what format should Float and Double literal values be sent to the database?

See Also:
#EXACT, #APPROXIMATE
Constructor Detail

LiteralProcessor

public LiteralProcessor(HqlSqlWalker hqlSqlWalker)
Method Detail

isAlias

public boolean isAlias(String alias)

processConstant

public void processConstant(antlr.collections.AST constant,
                            boolean resolveIdent)
                     throws antlr.SemanticException
Throws:
antlr.SemanticException

lookupConstant

public void lookupConstant(DotNode node)
                    throws antlr.SemanticException
Throws:
antlr.SemanticException

processBoolean

public void processBoolean(antlr.collections.AST constant)

processNumeric

public void processNumeric(antlr.collections.AST literal)

determineDecimalRepresentation

public String determineDecimalRepresentation(String text,
                                             int type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NodeTraverser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class NodeTraverser

java.lang.Object
    extended by org.hibernate.hql.ast.util.NodeTraverser
public class NodeTraverser
extends Object

A visitor for traversing an AST tree.

Author:
Steve Ebersole

Nested Class Summary
static interface NodeTraverser.VisitationStrategy
Constructor Summary
NodeTraverser(NodeTraverser.VisitationStrategy strategy)
Method Summary
 void traverseDepthFirst(antlr.collections.AST ast)
Traverse the AST tree depth first.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NodeTraverser

public NodeTraverser(NodeTraverser.VisitationStrategy strategy)
Method Detail

traverseDepthFirst

public void traverseDepthFirst(antlr.collections.AST ast)
Traverse the AST tree depth first.

Note that the AST passed in is not visited itself. Visitation starts with its children.

Parameters:
ast -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NodeTraverser.VisitationStrategy (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Interface NodeTraverser.VisitationStrategy

All Known Implementing Classes:
QueryTranslatorImpl.JavaConstantConverter
Enclosing interface:
NodeTraverser
public static interface NodeTraverser.VisitationStrategy

Method Summary
 void visit(antlr.collections.AST node)

Method Detail

visit

public void visit(antlr.collections.AST node)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PathHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class PathHelper

java.lang.Object
    extended by org.hibernate.hql.ast.util.PathHelper
public final class PathHelper
extends Object

Provides utility methods for paths.

Author:
josh Sep 14, 2004 8:16:29 AM

Method Summary
static String | getAlias(String path)
static antlr.collections.AST | parsePath(String path, antlr.ASTFactory factory) Turns a path into an AST.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

parsePath

public static antlr.collections.AST parsePath(String path,
                                              antlr.ASTFactory factory)
Turns a path into an AST.

Parameters:
path - The path.
factory - The AST factory to use.
Returns:
An HQL AST representing the path.

getAlias

public static String getAlias(String path)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SessionFactoryHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class SessionFactoryHelper

java.lang.Object
    extended by org.hibernate.hql.ast.util.SessionFactoryHelper
public class SessionFactoryHelper
extends Object

Wraps SessionFactoryImpl, adding more lookup behaviors and encapsulating some of the error handling.

Author:
josh Jul 24, 2004 6:44:00 PM

Constructor Summary
SessionFactoryHelper(SessionFactoryImplementor sfi)
Construct a new SessionFactoryHelper instance.
Method Summary
JoinSequence | createCollectionJoinSequence(QueryableCollection collPersister, String collectionName) Create a join sequence rooted at the given collection.
JoinSequence | createJoinSequence() Generate an empty join sequence instance.
JoinSequence | createJoinSequence(boolean implicit, AssociationType associationType, String tableAlias, int joinType, String[] columns) Generate a join sequence representing the given association type.
Type | findFunctionReturnType(String functionName, antlr.collections.AST first) Find the function return type given the function name and the first argument expression node.
static Queryable | findQueryableUsingImports(SessionFactoryImplementor sfi, String className) Given a (potentially unqualified) class name, locate its persister.
Queryable | findQueryableUsingImports(String className) Given a (potentially unqualified) class name, locate its persister.
SQLFunction | findSQLFunction(String functionName) Locate a registered sql function by name.
String[][] | generateColumnNames(Type[] sqlResultTypes)
String | getAssociatedEntityName(CollectionType collectionType) Given a collection type, determine the entity name of the elements contained within instance of that collection.
String[] | getCollectionElementColumns(String role, String roleAlias) Retrieves the column names corresponding to the collection elements for the given collection role.
QueryableCollection | getCollectionPersister(String role) Locate the collection persister by the collection role.
int | getColumnSpan(Type type) Retreive the number of columns represented by this type.
AssociationType | getElementAssociationType(CollectionType collectionType) Essentially the same as #getElementType, but requiring that the element type be an association type.
SessionFactoryImplementor | getFactory() Get a handle to the encapsulated SessionFactory.
String | getIdentifierOrUniqueKeyPropertyName(EntityType entityType) Determine the name of the property for the entity encapsulated by the given type which represents the id or unique-key.
String | getImportedClassName(String className) Given a (potentially unqualified) class name, locate its imported qualified name.
boolean | hasPhysicalDiscriminatorColumn(Queryable persister) Does the given persister define a physical discriminator column for the purpose of inheritence discrimination?
boolean | isStrictJPAQLComplianceEnabled()
EntityPersister | requireClassPersister(String name) Locate the persister by class or entity name, requiring that such a persister exist.
QueryableCollection | requireQueryableCollection(String role) Locate the collection persister by the collection role, requiring that such a persister exist.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SessionFactoryHelper

public SessionFactoryHelper(SessionFactoryImplementor sfi)
Construct a new SessionFactoryHelper instance.

Parameters:
sfi - The SessionFactory impl to be encapsualted.
Method Detail

getFactory

public SessionFactoryImplementor getFactory()
Get a handle to the encapsulated SessionFactory.

Returns:
The encapsulated SessionFactory.

hasPhysicalDiscriminatorColumn

public boolean hasPhysicalDiscriminatorColumn(Queryable persister)
Does the given persister define a physical discriminator column for the purpose of inheritence discrimination?

Parameters:
persister - The persister to be checked.
Returns:
True if the persister does define an actual discriminator column.

getImportedClassName

public String getImportedClassName(String className)
Given a (potentially unqualified) class name, locate its imported qualified name.

Parameters:
className - The potentially unqualified class name
Returns:
The qualified class name.

findQueryableUsingImports

public Queryable findQueryableUsingImports(String className)
Given a (potentially unqualified) class name, locate its persister.

Parameters:
className - The (potentially unqualified) class name.
Returns:
The defined persister for this class, or null if none found.

findQueryableUsingImports

public static Queryable findQueryableUsingImports(SessionFactoryImplementor sfi,
                                                  String className)
Given a (potentially unqualified) class name, locate its persister. (static version)

Parameters:
sfi - The session factory implementor.
className - The (potentially unqualified) class name.
Returns:
The defined persister for this class, or null if none found.

requireClassPersister

public EntityPersister requireClassPersister(String name)
                                      throws antlr.SemanticException
Locate the persister by class or entity name, requiring that such a persister exist.

Parameters:
name - The class or entity name
Returns:
The defined persister for this entity
Throws:
antlr.SemanticException - Indicates the persister could not be found

getCollectionPersister

public QueryableCollection getCollectionPersister(String role)
Locate the collection persister by the collection role.

Parameters:
role - The collection role name.
Returns:
The defined CollectionPersister for this collection role, or null.

requireQueryableCollection

public QueryableCollection requireQueryableCollection(String role)
                                               throws QueryException
Locate the collection persister by the collection role, requiring that such a persister exist.

Parameters:
role - The collection role name.
Returns:
The defined CollectionPersister for this collection role.
Throws:
QueryException - Indicates that the collection persister could not be found.

getCollectionElementColumns

public String[] getCollectionElementColumns(String role,
                                            String roleAlias)
Retrieves the column names corresponding to the collection elements for the given collection role.

Parameters:
role - The collection role
roleAlias - The sql column-qualification alias (i.e., the table alias)
Returns:
the collection element columns

createJoinSequence

public JoinSequence createJoinSequence()
Generate an empty join sequence instance.

Returns:
The generate join sequence.

createJoinSequence

public JoinSequence createJoinSequence(boolean implicit,
                                       AssociationType associationType,
                                       String tableAlias,
                                       int joinType,
                                       String[] columns)
Generate a join sequence representing the given association type.

Parameters:
implicit - Should implicit joins (theta-style) or explicit joins (ANSI-style) be rendered
associationType - The type representing the thing to be joined into.
tableAlias - The table alias to use in qualifing the join conditions
joinType - The type of join to render (inner, outer, etc); see JoinFragment
columns - The columns making up the condition of the join.
Returns:
The generated join sequence.

createCollectionJoinSequence

public JoinSequence createCollectionJoinSequence(QueryableCollection collPersister,
                                                 String collectionName)
Create a join sequence rooted at the given collection.

Parameters:
collPersister - The persister for the collection at which the join should be rooted.
collectionName - The alias to use for qualifying column references.
Returns:
The generated join sequence.

getIdentifierOrUniqueKeyPropertyName

public String getIdentifierOrUniqueKeyPropertyName(EntityType entityType)
Determine the name of the property for the entity encapsulated by the given type which represents the id or unique-key.

Parameters:
entityType - The type representing the entity.
Returns:
The corresponding property name
Throws:
QueryException - Indicates such a property could not be found.

getColumnSpan

public int getColumnSpan(Type type)
Retreive the number of columns represented by this type.

Parameters:
type - The type.
Returns:
The number of columns.

getAssociatedEntityName

public String getAssociatedEntityName(CollectionType collectionType)
Given a collection type, determine the entity name of the elements contained within instance of that collection.

Parameters:
collectionType - The collection type to check.
Returns:
The entity name of the elements of this collection.

getElementAssociationType

public AssociationType getElementAssociationType(CollectionType collectionType)
Essentially the same as #getElementType, but requiring that the element type be an association type.

Parameters:
collectionType - The collection type to be checked.
Returns:
The AssociationType of the elements of the collection.

findSQLFunction

public SQLFunction findSQLFunction(String functionName)
Locate a registered sql function by name.

Parameters:
functionName - The name of the function to locate
Returns:
The sql function, or null if not found.

findFunctionReturnType

public Type findFunctionReturnType(String functionName,
                                   antlr.collections.AST first)
Find the function return type given the function name and the first argument expression node.

Parameters:
functionName - The function name.
first - The first argument expression.
Returns:
the function return type given the function name and the first argument expression node.

generateColumnNames

public String[][] generateColumnNames(Type[] sqlResultTypes)

isStrictJPAQLComplianceEnabled

public boolean isStrictJPAQLComplianceEnabled()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SyntheticAndFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.ast.util
Class SyntheticAndFactory

java.lang.Object
    extended by org.hibernate.hql.ast.util.SyntheticAndFactory
All Implemented Interfaces:
HqlSqlTokenTypes
public class SyntheticAndFactory
extends Object
implements HqlSqlTokenTypes

Creates synthetic and nodes based on the where fragment part of a JoinSequence.

Author:
josh Dec 5, 2004 12:25:20 PM

Field Summary
Fields inherited from interface org.hibernate.hql.antlr.HqlSqlTokenTypes
AGGREGATE, ALIAS, ALIAS_REF, ALL, AND, ANY, AS, ASCENDING, AVG, BETWEEN, BOGUS, BOTH, CASE, CASE2, CLASS, CLOSE, CLOSE_BRACKET, COLON, COMMA, CONCAT, CONSTANT, CONSTRUCTOR, COUNT, DELETE, DESCENDING, DISTINCT, DIV, DOT, ELEMENTS, ELSE, EMPTY, END, EOF, EQ, ESCAPE, ESCqs, EXISTS, EXPONENT, EXPR_LIST, FALSE, FETCH, FILTER_ENTITY, FILTERS, FLOAT_SUFFIX, FROM, FROM_FRAGMENT, FULL, GE, GROUP, GT, HAVING, HEX_DIGIT, ID_LETTER, ID_START_LETTER, IDENT, IMPLIED_FROM, IN, IN_LIST, INDEX_OP, INDICES, INNER, INSERT, INTO, IS, IS_NOT_NULL, IS_NULL, JAVA_CONSTANT, JOIN, JOIN_FRAGMENT, LE, LEADING, LEFT, LEFT_OUTER, LIKE, LITERAL_ascending, LITERAL_by, LITERAL_descending, LT, MAX, MEMBER, METHOD_CALL, METHOD_NAME, MIN, MINUS, NAMED_PARAM, NE, NEW, NOT, NOT_BETWEEN, NOT_IN, NOT_LIKE, NULL, NULL_TREE_LOOKAHEAD, NUM_DOUBLE, NUM_FLOAT, NUM_INT, NUM_LONG, OBJECT, OF, ON, OPEN, OPEN_BRACKET, OR, ORDER, ORDER_ELEMENT, OUTER, PARAM, PLUS, PROPERTIES, PROPERTY_REF, QUERY, QUOTED_STRING, RANGE, RIGHT, RIGHT_OUTER, ROW_STAR, SELECT, SELECT_CLAUSE, SELECT_COLUMNS, SELECT_EXPR, SELECT_FROM, SET, SOME, SQL_NE, SQL_TOKEN, STAR, SUM, THEN, THETA_JOINS, TRAILING, TRUE, UNARY_MINUS, UNARY_PLUS, UNION, UPDATE, VECTOR_EXPR, VERSIONED, WEIRD_IDENT, WHEN, WHERE, WITH, WS
Constructor Summary
SyntheticAndFactory(antlr.ASTFactory astFactory)
Method Summary
void | addDiscriminatorWhereFragment(RestrictableStatement statement, Queryable persister, Map enabledFilters, String alias)
void | addWhereFragment(JoinFragment joinFragment, String whereFragment, QueryNode query, FromElement fromElement)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SyntheticAndFactory

public SyntheticAndFactory(antlr.ASTFactory astFactory)
Method Detail

addWhereFragment

public void addWhereFragment(JoinFragment joinFragment,
                             String whereFragment,
                             QueryNode query,
                             FromElement fromElement)

addDiscriminatorWhereFragment

public void addDiscriminatorWhereFragment(RestrictableStatement statement,
                                          Queryable persister,
                                          Map enabledFilters,
                                          String alias)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.hql.classic (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.hql.classic

This package contains the Hibernate 2.x query parser which is being end-of-lifed.

See:
Description

Interface Summary
Parser A parser is a state machine that accepts a string of tokens, bounded by start() and end() and modifies a QueryTranslator.

Class Summary
ClassicQueryTranslatorFactory | Generates translators which uses the older hand-written parser to perform the translation.
ClauseParser | Parses the Hibernate query into its constituent clauses.
FromParser | Parses the from clause of a hibernate query, looking for tables and aliases for the SQL query.
FromPathExpressionParser |
GroupByParser | Parses the GROUP BY clause of an aggregate query
HavingParser | Parses the having clause of a hibernate query and translates it to an SQL having clause.
OrderByParser | Parses the ORDER BY clause of a query
ParserHelper |
PathExpressionParser | Parses an expression of the form foo.bar.baz and builds up an expression involving two less table joins than there are path components.
PreprocessingParser |
QueryTranslatorImpl | An instance of QueryTranslator translates a Hibernate query string to SQL.
SelectParser | Parsers the select clause of a Hibernate query.
SelectPathExpressionParser |
WhereParser | Parses the where clause of a hibernate query and translates it to an SQL where clause.

Package org.hibernate.hql.classic Description

This package contains the Hibernate 2.x query parser which is being end-of-lifed.


org.hibernate.hql.classic Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.hql.classic

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.hql.classic.ClassicQueryTranslatorFactory (implements org.hibernate.hql.QueryTranslatorFactory)
    • class org.hibernate.hql.classic.ClauseParser (implements org.hibernate.hql.classic.Parser)
    • class org.hibernate.hql.classic.FromParser (implements org.hibernate.hql.classic.Parser)
    • class org.hibernate.hql.classic.GroupByParser (implements org.hibernate.hql.classic.Parser)
    • class org.hibernate.loader.Loader
      • class org.hibernate.loader.BasicLoader
        • class org.hibernate.hql.classic.QueryTranslatorImpl (implements org.hibernate.hql.FilterTranslator)
    • class org.hibernate.hql.classic.OrderByParser (implements org.hibernate.hql.classic.Parser)
    • class org.hibernate.hql.classic.ParserHelper
    • class org.hibernate.hql.classic.PathExpressionParser (implements org.hibernate.hql.classic.Parser)
      • class org.hibernate.hql.classic.FromPathExpressionParser
      • class org.hibernate.hql.classic.SelectPathExpressionParser
    • class org.hibernate.hql.classic.PreprocessingParser (implements org.hibernate.hql.classic.Parser)
    • class org.hibernate.hql.classic.SelectParser (implements org.hibernate.hql.classic.Parser)
    • class org.hibernate.hql.classic.WhereParser (implements org.hibernate.hql.classic.Parser)
      • class org.hibernate.hql.classic.HavingParser

Interface Hierarchy

  • interface org.hibernate.hql.classic.Parser


Uses of Package org.hibernate.hql.classic (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.hql.classic

Packages that use org.hibernate.hql.classic
org.hibernate.hql.classic This package contains the Hibernate 2.x query parser which is being end-of-lifed.

Classes in org.hibernate.hql.classic used by org.hibernate.hql.classic
Parser
A parser is a state machine that accepts a string of tokens, bounded by start() and end() and modifies a QueryTranslator.
PathExpressionParser
Parses an expression of the form foo.bar.baz and builds up an expression involving two less table joins than there are path components.
QueryTranslatorImpl
An instance of QueryTranslator translates a Hibernate query string to SQL.
WhereParser
Parses the where clause of a hibernate query and translates it to an SQL where clause.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Parser (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Interface Parser

All Known Implementing Classes:
ClauseParser, FromParser, GroupByParser, OrderByParser, PathExpressionParser, PreprocessingParser, SelectParser, WhereParser
public interface Parser

A parser is a state machine that accepts a string of tokens, bounded by start() and end() and modifies a QueryTranslator. Parsers are NOT intended to be threadsafe. They SHOULD be reuseable for more than one token stream.

Method Summary
void | end(QueryTranslatorImpl q)
void | start(QueryTranslatorImpl q)
void | token(String token, QueryTranslatorImpl q)

Method Detail

token

public void token(String token,
                  QueryTranslatorImpl q)
           throws QueryException
Throws:
QueryException

start

public void start(QueryTranslatorImpl q)
           throws QueryException
Throws:
QueryException

end

public void end(QueryTranslatorImpl q)
         throws QueryException
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ClassicQueryTranslatorFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class ClassicQueryTranslatorFactory

java.lang.Object
    extended by org.hibernate.hql.classic.ClassicQueryTranslatorFactory
All Implemented Interfaces:
QueryTranslatorFactory
public class ClassicQueryTranslatorFactory
extends Object
implements QueryTranslatorFactory

Generates translators which uses the older hand-written parser to perform the translation.

Author:
Gavin King

Constructor Summary
ClassicQueryTranslatorFactory()
Method Summary
FilterTranslator | createFilterTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory) Construct a FilterTranslator instance capable of translating an HQL filter string.
QueryTranslator | createQueryTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory) Construct a QueryTranslator instance capable of translating an HQL query string.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClassicQueryTranslatorFactory

public ClassicQueryTranslatorFactory()
Method Detail

createQueryTranslator

public QueryTranslator createQueryTranslator(String queryIdentifier,
                                             String queryString,
                                             Map filters,
                                             SessionFactoryImplementor factory)
Description copied from interface: QueryTranslatorFactory
Construct a QueryTranslator instance capable of translating an HQL query string.

Specified by:
createQueryTranslator in interface QueryTranslatorFactory
Parameters:
queryIdentifier - The query-identifier (used in QueryStatistics collection). This is typically the same as the queryString parameter except for the case of split polymorphic queries which result in multiple physical sql queries.
queryString - The query string to be translated
filters - Currently enabled filters
factory - The session factory.
Returns:
an appropriate translator.
See Also:
QueryTranslatorFactory.createQueryTranslator(java.lang.String, java.lang.String, java.util.Map, org.hibernate.engine.SessionFactoryImplementor)

createFilterTranslator

public FilterTranslator createFilterTranslator(String queryIdentifier,
                                               String queryString,
                                               Map filters,
                                               SessionFactoryImplementor factory)
Description copied from interface: QueryTranslatorFactory
Construct a FilterTranslator instance capable of translating an HQL filter string.

Specified by:
createFilterTranslator in interface QueryTranslatorFactory
See Also:
QueryTranslatorFactory.createFilterTranslator(java.lang.String, java.lang.String, java.util.Map, org.hibernate.engine.SessionFactoryImplementor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ClauseParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class ClauseParser

java.lang.Object
    extended by org.hibernate.hql.classic.ClauseParser
All Implemented Interfaces:
Parser
public class ClauseParser
extends Object
implements Parser

Parses the Hibernate query into its constituent clauses.

Constructor Summary
ClauseParser()
Method Summary
void | end(QueryTranslatorImpl q)
void | start(QueryTranslatorImpl q)
void | token(String token, QueryTranslatorImpl q)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClauseParser

public ClauseParser()
Method Detail

token

public void token(String token,
                  QueryTranslatorImpl q)
           throws QueryException
Specified by:
token in interface Parser
Throws:
QueryException

start

public void start(QueryTranslatorImpl q)
Specified by:
start in interface Parser

end

public void end(QueryTranslatorImpl q)
         throws QueryException
Specified by:
end in interface Parser
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FromParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class FromParser

java.lang.Object
    extended by org.hibernate.hql.classic.FromParser
All Implemented Interfaces:
Parser
public class FromParser
extends Object
implements Parser

Parses the from clause of a hibernate query, looking for tables and aliases for the SQL query.

Constructor Summary
FromParser()
Method Summary
void | end(QueryTranslatorImpl q)
void | start(QueryTranslatorImpl q)
void | token(String token, QueryTranslatorImpl q)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FromParser

public FromParser()
Method Detail

token

public void token(String token,
                  QueryTranslatorImpl q)
           throws QueryException
Specified by:
token in interface Parser
Throws:
QueryException

start

public void start(QueryTranslatorImpl q)
Specified by:
start in interface Parser

end

public void end(QueryTranslatorImpl q)
Specified by:
end in interface Parser
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FromPathExpressionParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class FromPathExpressionParser

java.lang.Object
    extended by org.hibernate.hql.classic.PathExpressionParser
        extended by org.hibernate.hql.classic.FromPathExpressionParser
All Implemented Interfaces:
Parser
public class FromPathExpressionParser
extends PathExpressionParser

Constructor Summary
FromPathExpressionParser()
Method Summary
void | end(QueryTranslatorImpl q)
protected void | setExpectingCollectionIndex()
Methods inherited from class org.hibernate.hql.classic.PathExpressionParser
addAssociation, addFromAssociation, addFromCollection, currentColumns, fetch, getCollectionSubquery, getName, getPropertyType, getWhereColumn, getWhereColumns, getWhereColumnType, getWhereJoin, ignoreInitialJoin, isCollectionValued, isExpectingCollectionIndex, lastCollectionElement, setLastCollectionElementIndexValue, start, token
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FromPathExpressionParser

public FromPathExpressionParser()
Method Detail

end

public void end(QueryTranslatorImpl q)
         throws QueryException
Specified by:
end in interface Parser
Overrides:
end in class PathExpressionParser
Throws:
QueryException

setExpectingCollectionIndex

protected void setExpectingCollectionIndex()
                                    throws QueryException
Overrides:
setExpectingCollectionIndex in class PathExpressionParser
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GroupByParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class GroupByParser

java.lang.Object
    extended by org.hibernate.hql.classic.GroupByParser
All Implemented Interfaces:
Parser
public class GroupByParser
extends Object
implements Parser

Parses the GROUP BY clause of an aggregate query

Constructor Summary
GroupByParser()
Method Summary
void | end(QueryTranslatorImpl q)
void | start(QueryTranslatorImpl q)
void | token(String token, QueryTranslatorImpl q)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GroupByParser

public GroupByParser()
Method Detail

token

public void token(String token,
                  QueryTranslatorImpl q)
           throws QueryException
Specified by:
token in interface Parser
Throws:
QueryException

start

public void start(QueryTranslatorImpl q)
           throws QueryException
Specified by:
start in interface Parser
Throws:
QueryException

end

public void end(QueryTranslatorImpl q)
         throws QueryException
Specified by:
end in interface Parser
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HavingParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class HavingParser

java.lang.Object
    extended by org.hibernate.hql.classic.WhereParser
        extended by org.hibernate.hql.classic.HavingParser
All Implemented Interfaces:
Parser
public class HavingParser
extends WhereParser

Parses the having clause of a hibernate query and translates it to an SQL having clause.

Constructor Summary
HavingParser()
Methods inherited from class org.hibernate.hql.classic.WhereParser
end, start, token
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HavingParser

public HavingParser()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderByParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class OrderByParser

java.lang.Object
    extended by org.hibernate.hql.classic.OrderByParser
All Implemented Interfaces:
Parser
public class OrderByParser
extends Object
implements Parser

Parses the ORDER BY clause of a query

Constructor Summary
OrderByParser()
Method Summary
void | end(QueryTranslatorImpl q)
void | start(QueryTranslatorImpl q)
void | token(String token, QueryTranslatorImpl q)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OrderByParser

public OrderByParser()
Method Detail

token

public void token(String token,
                  QueryTranslatorImpl q)
           throws QueryException
Specified by:
token in interface Parser
Throws:
QueryException

start

public void start(QueryTranslatorImpl q)
           throws QueryException
Specified by:
start in interface Parser
Throws:
QueryException

end

public void end(QueryTranslatorImpl q)
         throws QueryException
Specified by:
end in interface Parser
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParserHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class ParserHelper

java.lang.Object
    extended by org.hibernate.hql.classic.ParserHelper
public final class ParserHelper
extends Object

Field Summary
static String | HQL_SEPARATORS
static String | HQL_VARIABLE_PREFIX
static String | PATH_SEPARATORS
Method Summary
static boolean | isWhitespace(String str)
static void | parse(Parser p, String text, String seperators, QueryTranslatorImpl q)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

HQL_VARIABLE_PREFIX

public static final String HQL_VARIABLE_PREFIX
See Also:
Constant Field Values

HQL_SEPARATORS

public static final String HQL_SEPARATORS
See Also:
Constant Field Values

PATH_SEPARATORS

public static final String PATH_SEPARATORS
See Also:
Constant Field Values
Method Detail

isWhitespace

public static boolean isWhitespace(String str)

parse

public static void parse(Parser p,
                         String text,
                         String seperators,
                         QueryTranslatorImpl q)
                  throws QueryException
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PathExpressionParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class PathExpressionParser

java.lang.Object
    extended by org.hibernate.hql.classic.PathExpressionParser
All Implemented Interfaces:
Parser
Direct Known Subclasses:
FromPathExpressionParser, SelectPathExpressionParser
public class PathExpressionParser
extends Object
implements Parser

Parses an expression of the form foo.bar.baz and builds up an expression involving two less table joins than there are path components.

Constructor Summary
PathExpressionParser()
Method Summary
void | addAssociation(QueryTranslatorImpl q)
String | addFromAssociation(QueryTranslatorImpl q)
String | addFromCollection(QueryTranslatorImpl q)
protected String[] | currentColumns()
void | end(QueryTranslatorImpl q)
void | fetch(QueryTranslatorImpl q, String entityName)
String | getCollectionSubquery(Map enabledFilters)
String | getName()
protected Type | getPropertyType()
String | getWhereColumn()
String[] | getWhereColumns()
Type | getWhereColumnType()
JoinSequence | getWhereJoin()
void | ignoreInitialJoin()
boolean | isCollectionValued()
boolean | isExpectingCollectionIndex()
org.hibernate.hql.classic.PathExpressionParser.CollectionElement | lastCollectionElement()
protected void | setExpectingCollectionIndex()
void | setLastCollectionElementIndexValue(String value)
void | start(QueryTranslatorImpl q)
void | token(String token, QueryTranslatorImpl q)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PathExpressionParser

public PathExpressionParser()
Method Detail

ignoreInitialJoin

public void ignoreInitialJoin()

token

public void token(String token,
                  QueryTranslatorImpl q)
           throws QueryException
Specified by:
token in interface Parser
Throws:
QueryException

getPropertyType

protected Type getPropertyType()
                        throws QueryException
Throws:
QueryException

currentColumns

protected String[] currentColumns()
                           throws QueryException
Throws:
QueryException

start

public void start(QueryTranslatorImpl q)
Specified by:
start in interface Parser

end

public void end(QueryTranslatorImpl q)
         throws QueryException
Specified by:
end in interface Parser
Throws:
QueryException

lastCollectionElement

public org.hibernate.hql.classic.PathExpressionParser.CollectionElement lastCollectionElement()

setLastCollectionElementIndexValue

public void setLastCollectionElementIndexValue(String value)

isExpectingCollectionIndex

public boolean isExpectingCollectionIndex()

setExpectingCollectionIndex

protected void setExpectingCollectionIndex()
                                    throws QueryException
Throws:
QueryException

getWhereJoin

public JoinSequence getWhereJoin()

getWhereColumn

public String getWhereColumn()
                      throws QueryException
Throws:
QueryException

getWhereColumns

public String[] getWhereColumns()

getWhereColumnType

public Type getWhereColumnType()

getName

public String getName()

getCollectionSubquery

public String getCollectionSubquery(Map enabledFilters)
                             throws QueryException
Throws:
QueryException

isCollectionValued

public boolean isCollectionValued()
                           throws QueryException
Throws:
QueryException

addAssociation

public void addAssociation(QueryTranslatorImpl q)
                    throws QueryException
Throws:
QueryException

addFromAssociation

public String addFromAssociation(QueryTranslatorImpl q)
                          throws QueryException
Throws:
QueryException

addFromCollection

public String addFromCollection(QueryTranslatorImpl q)
                         throws QueryException
Throws:
QueryException

fetch

public void fetch(QueryTranslatorImpl q,
                  String entityName)
           throws QueryException
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreprocessingParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class PreprocessingParser

java.lang.Object
    extended by org.hibernate.hql.classic.PreprocessingParser
All Implemented Interfaces:
Parser
public class PreprocessingParser
extends Object
implements Parser

Constructor Summary
PreprocessingParser(Map replacements)
Method Summary
void | end(QueryTranslatorImpl q)
void | start(QueryTranslatorImpl q)
void | token(String token, QueryTranslatorImpl q)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PreprocessingParser

public PreprocessingParser(Map replacements)
Method Detail

token

public void token(String token,
                  QueryTranslatorImpl q)
           throws QueryException
Specified by:
token in interface Parser
Throws:
QueryException

start

public void start(QueryTranslatorImpl q)
           throws QueryException
Specified by:
start in interface Parser
Throws:
QueryException

end

public void end(QueryTranslatorImpl q)
         throws QueryException
Specified by:
end in interface Parser
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryTranslatorImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class QueryTranslatorImpl

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.hql.classic.QueryTranslatorImpl
All Implemented Interfaces:
FilterTranslator, QueryTranslator
public class QueryTranslatorImpl
extends BasicLoader
implements FilterTranslator

An instance of QueryTranslator translates a Hibernate query string to SQL.

Field Summary
Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX
Fields inherited from interface org.hibernate.hql.QueryTranslator
ERROR_CANNOT_DETERMINE_TYPE, ERROR_CANNOT_FETCH_WITH_ITERATE, ERROR_CANNOT_FORMAT_LITERAL, ERROR_NAMED_PARAMETER_DOES_NOT_APPEAR
Constructor Summary
QueryTranslatorImpl(String queryString, Map enabledFilters, SessionFactoryImplementor factory)
Construct a query translator
QueryTranslatorImpl(String queryIdentifier, String queryString, Map enabledFilters, SessionFactoryImplementor factory)
Construct a query translator
Method Summary
protected  String applyLocks(String sql, Map lockModes, Dialect dialect)
Append FOR UPDATE OF clause, if necessary.
 List collectSqlStrings()
 void compile(Map replacements, boolean scalar)
Compile a "normal" query.
 void compile(String collectionRole, Map replacements, boolean scalar)
Compile a filter.
 boolean containsCollectionFetches()
Does the translated query contain collection fetches?
 int executeUpdate(QueryParameters queryParameters, SessionImplementor session)
Perform a bulk update/delete operation given the underlying query defintion.
protected  String[] getAliases()
Get the SQL table aliases of entities whose associations are subselect-loadable, returning null if this loader does not support subselect loading
 String getAliasName(String alias)
protected  int[] getCollectionOwners()
Get the index of the entity that owns the collection, or -1 if there is no owner in the query results (ie.
 CollectionPersister[] getCollectionPersisters()
Overrides method from Loader
protected  String[] getCollectionSuffixes()
 String[][] getColumnNames()
Returns the column names in the generated SQL.
 Map getEnabledFilters()
Returns the filters enabled for this query translator.
protected  Loadable[] getEntityPersisters()
Persisters for the return values of a find() style query.
 Class getHolderClass()
protected  LockMode[] getLockModes(Map lockModes)
What lock mode does this load entities with?
 int[] getNamedParameterLocs(String name)
protected  EntityType[] getOwnerAssociationTypes()
An array of unique key property names by which the corresponding entities are referenced by other entities in the result set
protected  int[] getOwners()
An array of indexes of the entity that owns a one-to-one association to the entity at the given index (-1 if there is no "owner")
 ParameterTranslations getParameterTranslations()
Return information about any parameters encountered during translation.
 String getQueryIdentifier()
Retrieve the query identifier for this translator.
 Set getQuerySpaces()
Returns the set of query spaces (table names) that the query referrs to.
 String getQueryString()
Returns the HQL string processed by the translator.
protected  Object getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
Get the actual object that is returned in the user-visible result list.
protected  List getResultList(List results, ResultTransformer resultTransformer)
 String[] getReturnAliases()
Returns an array of HQL aliases
 Type[] getReturnTypes()
Types of the return values of an iterate() style query.
 String getSQLString()
Returns the SQL string generated by the translator.
protected  String[] getSuffixes()
protected  boolean isCompiled()
 boolean isManipulationStatement()
protected  boolean isSubselectLoadingEnabled()
 Iterator iterate(QueryParameters queryParameters, EventSource session)
Return the query results as an iterator
 List list(SessionImplementor session, QueryParameters queryParameters)
Perform a list operation given the underlying query definition.
 ScrollableResults scroll(QueryParameters queryParameters, SessionImplementor session)
Perform a scroll operation given the underlying query defintion.
 String toString()
protected  boolean upgradeLocks()
Does this query return objects that might be already cached by the session, whose lock mode may need upgrading
 void validateScrollability()
Validate the scrollability of the translated query.
Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate
Methods inherited from class org.hibernate.loader.Loader
autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getEntityEagerPropertyFetches, getFactory, getResultSet, hasSubselectLoadableCollections, isSingleRowLoader, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

QueryTranslatorImpl

public QueryTranslatorImpl(String queryIdentifier,
                           String queryString,
                           Map enabledFilters,
                           SessionFactoryImplementor factory)
Construct a query translator

QueryTranslatorImpl

public QueryTranslatorImpl(String queryString,
                           Map enabledFilters,
                           SessionFactoryImplementor factory)
Construct a query translator

Method Detail

compile

public void compile(Map replacements,
                    boolean scalar)
             throws QueryException,
                    MappingException
Compile a "normal" query. This method may be called multiple times. Subsequent invocations are no-ops.

Specified by:
compile in interface QueryTranslator
Parameters:
replacements - Defined query substitutions.
scalar - Does this represent a shallow (scalar or entity-id) select?
Throws:
MappingException - There was a problem querying defined mappings.
QueryException - There was a problem parsing the query string.

compile

public void compile(String collectionRole,
                    Map replacements,
                    boolean scalar)
             throws QueryException,
                    MappingException
Compile a filter. This method may be called multiple times. Subsequent invocations are no-ops.

Specified by:
compile in interface FilterTranslator
Parameters:
collectionRole - the role name of the collection used as the basis for the filter.
replacements - Defined query substitutions.
scalar - Does this represent a shallow (scalar or entity-id) select?
Throws:
QueryException - There was a problem parsing the query string.
MappingException - There was a problem querying defined mappings.

getSQLString

public String getSQLString()
Description copied from interface: QueryTranslator
Returns the SQL string generated by the translator.

Specified by:
getSQLString in interface QueryTranslator
Specified by:
getSQLString in class Loader

collectSqlStrings

public List collectSqlStrings()
Specified by:
collectSqlStrings in interface QueryTranslator

getQueryString

public String getQueryString()
Description copied from interface: QueryTranslator
Returns the HQL string processed by the translator.

Specified by:
getQueryString in interface QueryTranslator
Returns:
the HQL string processed by the translator.

getEntityPersisters

protected Loadable[] getEntityPersisters()
Persisters for the return values of a find() style query.

Specified by:
getEntityPersisters in class Loader
Returns:
an array of EntityPersisters.

getReturnTypes

public Type[] getReturnTypes()
Types of the return values of an iterate() style query.

Specified by:
getReturnTypes in interface QueryTranslator
Returns:
an array of Types.

getReturnAliases

public String[] getReturnAliases()
Description copied from interface: QueryTranslator
Returns an array of HQL aliases

Specified by:
getReturnAliases in interface QueryTranslator

getColumnNames

public String[][] getColumnNames()
Description copied from interface: QueryTranslator
Returns the column names in the generated SQL.

Specified by:
getColumnNames in interface QueryTranslator
Returns:
the column names in the generated SQL.

getAliasName

public String getAliasName(String alias)

getNamedParameterLocs

public int[] getNamedParameterLocs(String name)
                            throws QueryException
Overrides:
getNamedParameterLocs in class Loader
Throws:
QueryException

getQuerySpaces

public final Set getQuerySpaces()
Description copied from interface: QueryTranslator
Returns the set of query spaces (table names) that the query referrs to.

Specified by:
getQuerySpaces in interface QueryTranslator
Returns:
A set of query spaces (table names).

getCollectionPersisters

public CollectionPersister[] getCollectionPersisters()
Overrides method from Loader

Overrides:
getCollectionPersisters in class Loader

getCollectionSuffixes

protected String[] getCollectionSuffixes()
Specified by:
getCollectionSuffixes in class BasicLoader

getSuffixes

protected String[] getSuffixes()
Specified by:
getSuffixes in class BasicLoader

getAliases

protected String[] getAliases()
Description copied from class: Loader
Get the SQL table aliases of entities whose associations are subselect-loadable, returning null if this loader does not support subselect loading

Overrides:
getAliases in class Loader

list

public List list(SessionImplementor session,
                 QueryParameters queryParameters)
          throws HibernateException
Description copied from interface: QueryTranslator
Perform a list operation given the underlying query definition.

Specified by:
list in interface QueryTranslator
Parameters:
session - The session owning this query.
queryParameters - The query bind parameters.
Returns:
The query list results.
Throws:
HibernateException

iterate

public Iterator iterate(QueryParameters queryParameters,
                        EventSource session)
                 throws HibernateException
Return the query results as an iterator

Specified by:
iterate in interface QueryTranslator
Parameters:
queryParameters - The query bind parameters.
session - The session owning this query.
Returns:
An iterator over the query results.
Throws:
HibernateException

executeUpdate

public int executeUpdate(QueryParameters queryParameters,
                         SessionImplementor session)
                  throws HibernateException
Description copied from interface: QueryTranslator
Perform a bulk update/delete operation given the underlying query defintion.

Specified by:
executeUpdate in interface QueryTranslator
Parameters:
queryParameters - The query bind parameters.
session - The session owning this query.
Returns:
The number of entities updated or deleted.
Throws:
HibernateException

getResultColumnOrRow

protected Object getResultColumnOrRow(Object[] row,
                                      ResultTransformer transformer,
                                      ResultSet rs,
                                      SessionImplementor session)
                               throws SQLException,
                                      HibernateException
Description copied from class: Loader
Get the actual object that is returned in the user-visible result list. This empty implementation merely returns its first argument. This is overridden by some subclasses.

Overrides:
getResultColumnOrRow in class Loader
Throws:
SQLException
HibernateException

getResultList

protected List getResultList(List results,
                             ResultTransformer resultTransformer)
                      throws QueryException
Overrides:
getResultList in class Loader
Throws:
QueryException

getLockModes

protected LockMode[] getLockModes(Map lockModes)
Description copied from class: Loader
What lock mode does this load entities with?

Specified by:
getLockModes in class Loader
Parameters:
lockModes - a collection of lock modes specified dynamically via the Query interface

applyLocks

protected String applyLocks(String sql,
                            Map lockModes,
                            Dialect dialect)
                     throws QueryException
Description copied from class: Loader
Append FOR UPDATE OF clause, if necessary. This empty superclass implementation merely returns its first argument.

Overrides:
applyLocks in class Loader
Throws:
QueryException

upgradeLocks

protected boolean upgradeLocks()
Description copied from class: Loader
Does this query return objects that might be already cached by the session, whose lock mode may need upgrading

Overrides:
upgradeLocks in class Loader

getCollectionOwners

protected int[] getCollectionOwners()
Description copied from class: Loader
Get the index of the entity that owns the collection, or -1 if there is no owner in the query results (ie. in the case of a collection initializer) or no collection.

Overrides:
getCollectionOwners in class Loader

isCompiled

protected boolean isCompiled()

toString

public String toString()
Overrides:
toString in class Loader

getOwners

protected int[] getOwners()
Description copied from class: Loader
An array of indexes of the entity that owns a one-to-one association to the entity at the given index (-1 if there is no "owner")

Overrides:
getOwners in class Loader

getOwnerAssociationTypes

protected EntityType[] getOwnerAssociationTypes()
Description copied from class: Loader
An array of unique key property names by which the corresponding entities are referenced by other entities in the result set

Overrides:
getOwnerAssociationTypes in class Loader

getHolderClass

public Class getHolderClass()

getEnabledFilters

public Map getEnabledFilters()
Description copied from interface: QueryTranslator
Returns the filters enabled for this query translator.

Specified by:
getEnabledFilters in interface QueryTranslator
Returns:
Filters enabled for this query execution.

scroll

public ScrollableResults scroll(QueryParameters queryParameters,
                                SessionImplementor session)
                         throws HibernateException
Description copied from interface: QueryTranslator
Perform a scroll operation given the underlying query defintion.

Specified by:
scroll in interface QueryTranslator
Parameters:
queryParameters - The query bind parameters.
session - The session owning this query.
Returns:
The ScrollableResults wrapper around the query results.
Throws:
HibernateException

getQueryIdentifier

public String getQueryIdentifier()
Description copied from interface: QueryTranslator
Retrieve the query identifier for this translator. The query identifier is used in stats collection.

Specified by:
getQueryIdentifier in interface QueryTranslator
Overrides:
getQueryIdentifier in class Loader

isSubselectLoadingEnabled

protected boolean isSubselectLoadingEnabled()
Overrides:
isSubselectLoadingEnabled in class Loader

validateScrollability

public void validateScrollability()
                           throws HibernateException
Description copied from interface: QueryTranslator
Validate the scrollability of the translated query.

Specified by:
validateScrollability in interface QueryTranslator
Throws:
HibernateException

containsCollectionFetches

public boolean containsCollectionFetches()
Description copied from interface: QueryTranslator
Does the translated query contain collection fetches?

Specified by:
containsCollectionFetches in interface QueryTranslator
Returns:
tru if the query does contain collection fetched; false otherwise.

isManipulationStatement

public boolean isManipulationStatement()
Specified by:
isManipulationStatement in interface QueryTranslator

getParameterTranslations

public ParameterTranslations getParameterTranslations()
Description copied from interface: QueryTranslator
Return information about any parameters encountered during translation.

Specified by:
getParameterTranslations in interface QueryTranslator
Returns:
The parameter information.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class SelectParser

java.lang.Object
    extended by org.hibernate.hql.classic.SelectParser
All Implemented Interfaces:
Parser
public class SelectParser
extends Object
implements Parser

Parsers the select clause of a Hibernate query.

Author:
Gavin King, David Channon

Constructor Summary
SelectParser()
Method Summary
boolean | aggregateFuncNoArgsHasParenthesis(String funcToken, QueryTranslatorImpl q)
boolean | aggregateHasArgs(String funcToken, QueryTranslatorImpl q)
Type | aggregateType(List funcTokenList, Type type, QueryTranslatorImpl q)
void | end(QueryTranslatorImpl q)
void | start(QueryTranslatorImpl q)
void | token(String token, QueryTranslatorImpl q)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SelectParser

public SelectParser()
Method Detail

token

public void token(String token,
                  QueryTranslatorImpl q)
           throws QueryException
Specified by:
token in interface Parser
Throws:
QueryException

aggregateHasArgs

public boolean aggregateHasArgs(String funcToken,
                                QueryTranslatorImpl q)

aggregateFuncNoArgsHasParenthesis

public boolean aggregateFuncNoArgsHasParenthesis(String funcToken,
                                                 QueryTranslatorImpl q)

aggregateType

public Type aggregateType(List funcTokenList,
                          Type type,
                          QueryTranslatorImpl q)
                   throws QueryException
Throws:
QueryException

start

public void start(QueryTranslatorImpl q)
Specified by:
start in interface Parser

end

public void end(QueryTranslatorImpl q)
Specified by:
end in interface Parser
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectPathExpressionParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class SelectPathExpressionParser

java.lang.Object
    extended by org.hibernate.hql.classic.PathExpressionParser
        extended by org.hibernate.hql.classic.SelectPathExpressionParser
All Implemented Interfaces:
Parser
public class SelectPathExpressionParser
extends PathExpressionParser

Constructor Summary
SelectPathExpressionParser()
Method Summary
void | end(QueryTranslatorImpl q)
String | getSelectName()
protected void | setExpectingCollectionIndex()
Methods inherited from class org.hibernate.hql.classic.PathExpressionParser
addAssociation, addFromAssociation, addFromCollection, currentColumns, fetch, getCollectionSubquery, getName, getPropertyType, getWhereColumn, getWhereColumns, getWhereColumnType, getWhereJoin, ignoreInitialJoin, isCollectionValued, isExpectingCollectionIndex, lastCollectionElement, setLastCollectionElementIndexValue, start, token
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SelectPathExpressionParser

public SelectPathExpressionParser()
Method Detail

end

public void end(QueryTranslatorImpl q)
         throws QueryException
Specified by:
end in interface Parser
Overrides:
end in class PathExpressionParser
Throws:
QueryException

setExpectingCollectionIndex

protected void setExpectingCollectionIndex()
                                    throws QueryException
Overrides:
setExpectingCollectionIndex in class PathExpressionParser
Throws:
QueryException

getSelectName

public String getSelectName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WhereParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.hql.classic
Class WhereParser

java.lang.Object
    extended by org.hibernate.hql.classic.WhereParser
All Implemented Interfaces:
Parser
Direct Known Subclasses:
HavingParser
public class WhereParser
extends Object
implements Parser

Parses the where clause of a hibernate query and translates it to an SQL where clause.

Constructor Summary
WhereParser()
Method Summary
void | end(QueryTranslatorImpl q)
void | start(QueryTranslatorImpl q)
void | token(String token, QueryTranslatorImpl q)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WhereParser

public WhereParser()
Method Detail

token

public void token(String token,
                  QueryTranslatorImpl q)
           throws QueryException
Specified by:
token in interface Parser
Throws:
QueryException

start

public void start(QueryTranslatorImpl q)
           throws QueryException
Specified by:
start in interface Parser
Throws:
QueryException

end

public void end(QueryTranslatorImpl q)
         throws QueryException
Specified by:
end in interface Parser
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.id (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.id

This package contains internal implementation classes for the main API interfaces.

See:
Description

Interface Summary
Configurable | An IdentifierGenerator that supports "configuration".
IdentifierGenerator | The general contract between a class that generates unique identifiers and the Session.
PersistentIdentifierGenerator | An IdentifierGenerator that requires creation of database objects.
PostInsertIdentifierGenerator |
PostInsertIdentityPersister | A persister that may have an identity assigned by execution of a SQL INSERT.

Class Summary
AbstractPostInsertGenerator |
AbstractUUIDGenerator | The base class for identifier generators that use a UUID algorithm.
Assigned | assigned An IdentifierGenerator that returns the current identifier assigned to an instance.
ForeignGenerator | foreign An Identifier generator that uses the value of the id property of an associated object One mapping parameter is required: property.
GUIDGenerator | Generates string values using the SQL Server NEWID() function.
IdentifierGeneratorFactory | Factory and helper methods for IdentifierGenerator framework.
IdentityGenerator | A generator for use with ANSI-SQL IDENTITY columns used as the primary key.
IdentityGenerator.BasicDelegate | Delegate for dealing with IDENTITY columns where the dialect requires an additional command execution to retrieve the generated IDENTITY value
IdentityGenerator.GetGeneratedKeysDelegate | Delegate for dealing with IDENTITY columns using JDBC3 getGeneratedKeys
IdentityGenerator.InsertSelectDelegate | Delegate for dealing with IDENTITY columns where the dialect supports returning the generated IDENTITY value directly from the insert statement.
IncrementGenerator | increment An IdentifierGenerator that returns a long, constructed by counting from the maximum primary key value at startup.
MultipleHiLoPerTableGenerator | A hilo IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.
SelectGenerator | A generator that selects the just inserted row to determine the identifier value assigned by the database.
SelectGenerator.SelectGeneratorDelegate | The delegate for the select generation strategy.
SequenceGenerator | sequence Generates long values using an oracle-style sequence.
SequenceHiLoGenerator | seqhilo An IdentifierGenerator that combines a hi/lo algorithm with an underlying oracle-style sequence that generates hi values.
SequenceIdentityGenerator | A generator which combines sequence generation with immediate retrieval through JDBC3 getGeneratedKeys.
SequenceIdentityGenerator.Delegate |
SequenceIdentityGenerator.NoCommentsInsert |
TableGenerator | An IdentifierGenerator that uses a database table to store the last generated value.
TableHiLoGenerator | hilo An IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.
UUIDHexGenerator | uuid A UUIDGenerator that returns a string of length 32, This string will consist of only hex digits.

Exception Summary
IdentifierGenerationException Thrown by IdentifierGenerator implementation class when ID generation fails.

Package org.hibernate.id Description

This package contains internal implementation classes for the main API interfaces.


org.hibernate.id Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.id

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.id.AbstractPostInsertGenerator (implements org.hibernate.id.PostInsertIdentifierGenerator)
      • class org.hibernate.id.IdentityGenerator
      • class org.hibernate.id.SelectGenerator (implements org.hibernate.id.Configurable)
    • class org.hibernate.id.insert.AbstractReturningDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
      • class org.hibernate.id.IdentityGenerator.GetGeneratedKeysDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
      • class org.hibernate.id.IdentityGenerator.InsertSelectDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
      • class org.hibernate.id.SequenceIdentityGenerator.Delegate
    • class org.hibernate.id.insert.AbstractSelectingDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
      • class org.hibernate.id.IdentityGenerator.BasicDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
      • class org.hibernate.id.SelectGenerator.SelectGeneratorDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
    • class org.hibernate.id.AbstractUUIDGenerator (implements org.hibernate.id.IdentifierGenerator)
      • class org.hibernate.id.UUIDHexGenerator (implements org.hibernate.id.Configurable)
    • class org.hibernate.id.Assigned (implements org.hibernate.id.Configurable, org.hibernate.id.IdentifierGenerator)
    • class org.hibernate.id.ForeignGenerator (implements org.hibernate.id.Configurable, org.hibernate.id.IdentifierGenerator)
    • class org.hibernate.id.GUIDGenerator (implements org.hibernate.id.IdentifierGenerator)
    • class org.hibernate.id.IdentifierGeneratorFactory
    • class org.hibernate.id.IncrementGenerator (implements org.hibernate.id.Configurable, org.hibernate.id.IdentifierGenerator)
    • class org.hibernate.sql.Insert
      • class org.hibernate.id.insert.IdentifierGeneratingInsert
        • class org.hibernate.id.SequenceIdentityGenerator.NoCommentsInsert
    • class org.hibernate.id.SequenceGenerator (implements org.hibernate.id.Configurable, org.hibernate.id.PersistentIdentifierGenerator)
      • class org.hibernate.id.SequenceHiLoGenerator
      • class org.hibernate.id.SequenceIdentityGenerator (implements org.hibernate.id.PostInsertIdentifierGenerator)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class org.hibernate.exception.NestableRuntimeException (implements org.hibernate.exception.Nestable)
            • class org.hibernate.HibernateException
              • class org.hibernate.id.IdentifierGenerationException
    • class org.hibernate.engine.TransactionHelper
      • class org.hibernate.id.MultipleHiLoPerTableGenerator (implements org.hibernate.id.Configurable, org.hibernate.id.PersistentIdentifierGenerator)
      • class org.hibernate.id.TableGenerator (implements org.hibernate.id.Configurable, org.hibernate.id.PersistentIdentifierGenerator)
        • class org.hibernate.id.TableHiLoGenerator

Interface Hierarchy

  • interface org.hibernate.id.Configurable
  • interface org.hibernate.id.IdentifierGenerator
    • interface org.hibernate.id.PersistentIdentifierGenerator
    • interface org.hibernate.id.PostInsertIdentifierGenerator
  • interface org.hibernate.cache.OptimisticCacheSource
    • interface org.hibernate.persister.entity.EntityPersister
      • interface org.hibernate.id.PostInsertIdentityPersister


Uses of Package org.hibernate.id (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.id

Packages that use org.hibernate.id
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.id.insert |
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.

Classes in org.hibernate.id used by org.hibernate.engine
IdentifierGenerator
The general contract between a class that generates unique identifiers and the Session.

Classes in org.hibernate.id used by org.hibernate.hql.ast
IdentifierGenerator
The general contract between a class that generates unique identifiers and the Session.

Classes in org.hibernate.id used by org.hibernate.id
AbstractPostInsertGenerator
AbstractUUIDGenerator
The base class for identifier generators that use a UUID algorithm.
Configurable
An IdentifierGenerator that supports "configuration".
IdentifierGenerationException
Thrown by IdentifierGenerator implementation class when ID generation fails.
IdentifierGenerator
The general contract between a class that generates unique identifiers and the Session.
PersistentIdentifierGenerator
An IdentifierGenerator that requires creation of database objects.
PostInsertIdentifierGenerator
PostInsertIdentityPersister
A persister that may have an identity assigned by execution of a SQL INSERT.
SequenceGenerator
sequence

Generates long values using an oracle-style sequence.
TableGenerator
An IdentifierGenerator that uses a database table to store the last generated value.

Classes in org.hibernate.id used by org.hibernate.id.insert
PostInsertIdentityPersister
A persister that may have an identity assigned by execution of a SQL INSERT.

Classes in org.hibernate.id used by org.hibernate.impl
IdentifierGenerator
The general contract between a class that generates unique identifiers and the Session.

Classes in org.hibernate.id used by org.hibernate.mapping
IdentifierGenerator
The general contract between a class that generates unique identifiers and the Session.

Classes in org.hibernate.id used by org.hibernate.persister.collection
IdentifierGenerator
The general contract between a class that generates unique identifiers and the Session.

Classes in org.hibernate.id used by org.hibernate.persister.entity
IdentifierGenerator
The general contract between a class that generates unique identifiers and the Session.
PostInsertIdentityPersister
A persister that may have an identity assigned by execution of a SQL INSERT.

Classes in org.hibernate.id used by org.hibernate.tuple
IdentifierGenerator
The general contract between a class that generates unique identifiers and the Session.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Configurable (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Interface Configurable

All Known Implementing Classes:
Assigned, ForeignGenerator, IncrementGenerator, MultipleHiLoPerTableGenerator, SelectGenerator, SequenceGenerator, TableGenerator, UUIDHexGenerator
public interface Configurable

An IdentifierGenerator that supports "configuration".

Author:
Gavin King
See Also:
IdentifierGenerator

Method Summary
 void configure(Type type, Properties params, Dialect d)
Configure this instance, given the value of parameters specified by the user as <param> elements.

Method Detail

configure

public void configure(Type type,
                      Properties params,
                      Dialect d)
               throws MappingException
Configure this instance, given the value of parameters specified by the user as <param> elements. This method is called just once, following instantiation.

Parameters:
params - param values, keyed by parameter name
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


IdentifierGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Interface IdentifierGenerator

All Known Subinterfaces:
PersistentIdentifierGenerator, PostInsertIdentifierGenerator
All Known Implementing Classes:
AbstractPostInsertGenerator, AbstractUUIDGenerator, Assigned, ForeignGenerator, GUIDGenerator, IncrementGenerator, MultipleHiLoPerTableGenerator, SequenceGenerator, SequenceIdentityGenerator, TableGenerator
public interface IdentifierGenerator

The general contract between a class that generates unique identifiers and the Session. It is not intended that this interface ever be exposed to the application. It is intended that users implement this interface to provide custom identifier generation strategies.

Implementors should provide a public default constructor.

Implementations that accept configuration parameters should also implement Configurable.
Implementors must be threadsafe

Author:
Gavin King
See Also:
PersistentIdentifierGenerator, Configurable

Field Summary
static String ENTITY_NAME
The configuration parameter holding the entity name
Method Summary
 Serializable generate(SessionImplementor session, Object object)
Generate a new identifier.

Field Detail

ENTITY_NAME

public static final String ENTITY_NAME
The configuration parameter holding the entity name

See Also:
Constant Field Values
Method Detail

generate

public Serializable generate(SessionImplementor session,
                             Object object)
                      throws HibernateException
Generate a new identifier.

Parameters:
session -
object - the entity or toplevel collection for which the id is being generated
Returns:
a new identifier
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentIdentifierGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Interface PersistentIdentifierGenerator

All Superinterfaces:
IdentifierGenerator
All Known Implementing Classes:
MultipleHiLoPerTableGenerator, SequenceGenerator, TableGenerator
public interface PersistentIdentifierGenerator
extends IdentifierGenerator

An IdentifierGenerator that requires creation of database objects.

All PersistentIdentifierGenerators that also implement Configurable have access to a special mapping parameter: schema

Author:
Gavin King
See Also:
IdentifierGenerator, Configurable

Field Summary
static String | CATALOG The configuration parameter holding the catalog name
static String | PK The configuration parameter holding the primary key column name of the generated id
static String | SCHEMA The configuration parameter holding the schema name
static org.apache.commons.logging.Log | SQL
static String | TABLE The configuration parameter holding the table name for the generated id
static String | TABLES The configuration parameter holding the table names for all tables for which the id must be unique
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Method Summary
Object | generatorKey() Return a key unique to the underlying database objects.
String[] | sqlCreateStrings(Dialect dialect) The SQL required to create the underlying database objects.
String[] | sqlDropStrings(Dialect dialect) The SQL required to remove the underlying database objects.
Methods inherited from interface org.hibernate.id.IdentifierGenerator
generate

Field Detail

SCHEMA

public static final String SCHEMA
The configuration parameter holding the schema name

See Also:
Constant Field Values

TABLE

public static final String TABLE
The configuration parameter holding the table name for the generated id

See Also:
Constant Field Values

TABLES

public static final String TABLES
The configuration parameter holding the table names for all tables for which the id must be unique

See Also:
Constant Field Values

PK

public static final String PK
The configuration parameter holding the primary key column name of the generated id

See Also:
Constant Field Values

CATALOG

public static final String CATALOG
The configuration parameter holding the catalog name

See Also:
Constant Field Values

SQL

public static final org.apache.commons.logging.Log SQL
Method Detail

sqlCreateStrings

public String[] sqlCreateStrings(Dialect dialect)
                          throws HibernateException
The SQL required to create the underlying database objects.

Parameters:
dialect -
Returns:
String[]
Throws:
HibernateException

sqlDropStrings

public String[] sqlDropStrings(Dialect dialect)
                        throws HibernateException
The SQL required to remove the underlying database objects.

Parameters:
dialect -
Returns:
String
Throws:
HibernateException

generatorKey

public Object generatorKey()
Return a key unique to the underlying database objects. Prevents us from trying to create/remove them multiple times.

Returns:
Object an identifying key for this generator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PostInsertIdentifierGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Interface PostInsertIdentifierGenerator

All Superinterfaces:
IdentifierGenerator
All Known Implementing Classes:
AbstractPostInsertGenerator, SequenceIdentityGenerator
public interface PostInsertIdentifierGenerator
extends IdentifierGenerator

Author:
Gavin King

Field Summary
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Method Summary
 InsertGeneratedIdentifierDelegate getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
Methods inherited from interface org.hibernate.id.IdentifierGenerator
generate

Method Detail

getInsertGeneratedIdentifierDelegate

public InsertGeneratedIdentifierDelegate getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister,
                                                                              Dialect dialect,
                                                                              boolean isGetGeneratedKeysEnabled)
                                                                       throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PostInsertIdentityPersister (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Interface PostInsertIdentityPersister

All Superinterfaces:
EntityPersister, OptimisticCacheSource
All Known Implementing Classes:
AbstractEntityPersister
public interface PostInsertIdentityPersister
extends EntityPersister

A persister that may have an identity assigned by execution of a SQL INSERT.

Author:
Gavin King

Field Summary
Fields inherited from interface org.hibernate.persister.entity.EntityPersister
ENTITY_ID
Method Summary
String | getIdentitySelectString() Get the database-specific SQL command to retrieve the last generated IDENTITY value.
String[] | getRootTableKeyColumnNames() The names of the primary key columns in the root table.
String | getSelectByUniqueKeyString(String propertyName) Get a SQL select string that performs a select based on a unique key determined by the given property name).
Methods inherited from interface org.hibernate.persister.entity.EntityPersister
afterInitialize, afterReassociate, canExtractIdOutOfEntity, createProxy, delete, findDirty, findModified, forceVersionIncrement, getCache, getCacheEntryStructure, getClassMetadata, getConcreteProxyClass, getCurrentVersion, getDatabaseSnapshot, getEntityName, getFactory, getIdentifier, getIdentifierGenerator, getIdentifierPropertyName, getIdentifierType, getMappedClass, getNaturalIdentifierProperties, getNaturalIdentifierSnapshot, getPropertyCascadeStyles, getPropertyCheckability, getPropertyInsertability, getPropertyInsertGeneration, getPropertyLaziness, getPropertyNames, getPropertyNullability, getPropertySpaces, getPropertyType, getPropertyTypes, getPropertyUpdateability, getPropertyUpdateGeneration, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValuesToInsert, getPropertyVersionability, getQuerySpaces, getRootEntityName, getSubclassEntityPersister, getVersion, getVersionProperty, getVersionType, guessEntityMode, hasCache, hasCascades, hasCollections, hasIdentifierProperty, hasInsertGeneratedProperties, hasLazyProperties, hasMutableProperties, hasNaturalIdentifier, hasProxy, hasSubselectLoadableCollections, hasUninitializedLazyProperties, hasUpdateGeneratedProperties, implementsLifecycle, implementsValidatable, insert, insert, instantiate, isBatchLoadable, isCacheInvalidationRequired, isIdentifierAssignedByInsert, isInherited, isInstance, isInstrumented, isLazyPropertiesCacheable, isMutable, isSelectBeforeUpdateRequired, isSubclassEntityName, isTransient, isVersioned, isVersionPropertyGenerated, load, lock, postInstantiate, processInsertGeneratedProperties, processUpdateGeneratedProperties, resetIdentifier, setIdentifier, setPropertyValue, setPropertyValues, update
Methods inherited from interface org.hibernate.cache.OptimisticCacheSource
getVersionComparator

Method Detail

getSelectByUniqueKeyString

public String getSelectByUniqueKeyString(String propertyName)
Get a SQL select string that performs a select based on a unique key determined by the given property name).

Parameters:
propertyName - The name of the property which maps to the column(s) to use in the select statement restriction.
Returns:
The SQL select string

getIdentitySelectString

public String getIdentitySelectString()
Get the database-specific SQL command to retrieve the last generated IDENTITY value.

Returns:
The SQL command string

getRootTableKeyColumnNames

public String[] getRootTableKeyColumnNames()
The names of the primary key columns in the root table.

Returns:
The primary key column names.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractPostInsertGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class AbstractPostInsertGenerator

java.lang.Object
    extended by org.hibernate.id.AbstractPostInsertGenerator
All Implemented Interfaces:
IdentifierGenerator, PostInsertIdentifierGenerator
Direct Known Subclasses:
IdentityGenerator, SelectGenerator
public abstract class AbstractPostInsertGenerator
extends Object
implements PostInsertIdentifierGenerator

Author:
Gavin King

Field Summary
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
AbstractPostInsertGenerator()
Method Summary
 Serializable generate(SessionImplementor s, Object obj)
Generate a new identifier.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.id.PostInsertIdentifierGenerator
getInsertGeneratedIdentifierDelegate

Constructor Detail

AbstractPostInsertGenerator

public AbstractPostInsertGenerator()
Method Detail

generate

public Serializable generate(SessionImplementor s,
                             Object obj)
Description copied from interface: IdentifierGenerator
Generate a new identifier.

Specified by:
generate in interface IdentifierGenerator
Parameters:
s -
obj - the entity or toplevel collection for which the id is being generated
Returns:
a new identifier
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractUUIDGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class AbstractUUIDGenerator

java.lang.Object
    extended by org.hibernate.id.AbstractUUIDGenerator
All Implemented Interfaces:
IdentifierGenerator
Direct Known Subclasses:
UUIDHexGenerator
public abstract class AbstractUUIDGenerator
extends Object
implements IdentifierGenerator

The base class for identifier generators that use a UUID algorithm. This class implements the algorithm, subclasses define the identifier format.

Author:
Gavin King
See Also:
UUIDHexGenerator

Field Summary
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
AbstractUUIDGenerator()
Method Summary
protected short | getCount() Unique in a millisecond for this JVM instance (unless there are > Short.MAX_VALUE instances created in a millisecond)
protected short | getHiTime() Unique down to millisecond
protected int | getIP() Unique in a local network
protected int | getJVM() Unique across JVMs on this machine (unless they load this class in the same quater second - very unlikely)
protected int | getLoTime()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.id.IdentifierGenerator
generate

Constructor Detail

AbstractUUIDGenerator

public AbstractUUIDGenerator()
Method Detail

getJVM

protected int getJVM()
Unique across JVMs on this machine (unless they load this class in the same quater second - very unlikely)

getCount

protected short getCount()
Unique in a millisecond for this JVM instance (unless there are > Short.MAX_VALUE instances created in a millisecond)

getIP

protected int getIP()
Unique in a local network

getHiTime

protected short getHiTime()
Unique down to millisecond

getLoTime

protected int getLoTime()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Assigned (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class Assigned

java.lang.Object
    extended by org.hibernate.id.Assigned
All Implemented Interfaces:
Configurable, IdentifierGenerator
public class Assigned
extends Object
implements IdentifierGenerator, Configurable

assigned

An IdentifierGenerator that returns the current identifier assigned to an instance.

Author:
Gavin King

Field Summary
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
Assigned()
Method Summary
void | configure(Type type, Properties params, Dialect d) Configure this instance, given the value of parameters specified by the user as <param> elements.
Serializable | generate(SessionImplementor session, Object obj) Generate a new identifier.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Assigned

public Assigned()
Method Detail

generate

public Serializable generate(SessionImplementor session,
                             Object obj)
                      throws HibernateException
Description copied from interface: IdentifierGenerator
Generate a new identifier.

Specified by:
generate in interface IdentifierGenerator
Parameters:
session -
obj - the entity or toplevel collection for which the id is being generated
Returns:
a new identifier
Throws:
HibernateException

configure

public void configure(Type type,
                      Properties params,
                      Dialect d)
               throws MappingException
Description copied from interface: Configurable
Configure this instance, given the value of parameters specified by the user as <param> elements. This method is called just once, following instantiation.

Specified by:
configure in interface Configurable
Parameters:
params - param values, keyed by parameter name
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ForeignGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class ForeignGenerator

java.lang.Object
    extended by org.hibernate.id.ForeignGenerator
All Implemented Interfaces:
Configurable, IdentifierGenerator
public class ForeignGenerator
extends Object
implements IdentifierGenerator, Configurable

foreign

An Identifier generator that uses the value of the id property of an associated object

One mapping parameter is required: property.

Author:
Gavin King

Field Summary
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
ForeignGenerator()
Method Summary
void | configure(Type type, Properties params, Dialect d) Configure this instance, given the value of parameters specified by the user as <param> elements.
Serializable | generate(SessionImplementor sessionImplementor, Object object) Generate a new identifier.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ForeignGenerator

public ForeignGenerator()
Method Detail

generate

public Serializable generate(SessionImplementor sessionImplementor,
                             Object object)
                      throws HibernateException
Description copied from interface: IdentifierGenerator
Generate a new identifier.

Specified by:
generate in interface IdentifierGenerator
Parameters:
sessionImplementor -
object - the entity or toplevel collection for which the id is being generated
Returns:
a new identifier
Throws:
HibernateException
See Also:
IdentifierGenerator.generate(org.hibernate.engine.SessionImplementor, java.lang.Object)

configure

public void configure(Type type,
                      Properties params,
                      Dialect d)
               throws MappingException
Description copied from interface: Configurable
Configure this instance, given the value of parameters specified by the user as <param> elements. This method is called just once, following instantiation.

Specified by:
configure in interface Configurable
Parameters:
params - param values, keyed by parameter name
Throws:
MappingException
See Also:
Configurable.configure(org.hibernate.type.Type, java.util.Properties, org.hibernate.dialect.Dialect)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GUIDGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class GUIDGenerator

java.lang.Object
    extended by org.hibernate.id.GUIDGenerator
All Implemented Interfaces:
IdentifierGenerator
public class GUIDGenerator
extends Object
implements IdentifierGenerator

Generates string values using the SQL Server NEWID() function.

Author:
Joseph Fifield

Field Summary
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
GUIDGenerator()
Method Summary
 Serializable generate(SessionImplementor session, Object obj)
Generate a new identifier.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GUIDGenerator

public GUIDGenerator()
Method Detail

generate

public Serializable generate(SessionImplementor session,
                             Object obj)
                      throws HibernateException
Description copied from interface: IdentifierGenerator
Generate a new identifier.

Specified by:
generate in interface IdentifierGenerator
Parameters:
session -
obj - the entity or toplevel collection for which the id is being generated
Returns:
a new identifier
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentifierGeneratorFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class IdentifierGeneratorFactory

java.lang.Object
    extended by org.hibernate.id.IdentifierGeneratorFactory
public final class IdentifierGeneratorFactory
extends Object

Factory and helper methods for IdentifierGenerator framework.

Author:
Gavin King

Field Summary
static Serializable | POST_INSERT_INDICATOR
static Serializable | SHORT_CIRCUIT_INDICATOR
Method Summary
static IdentifierGenerator | create(String strategy, Type type, Properties params, Dialect dialect)
static Number | createNumber(long value, Class clazz)
static Serializable | get(ResultSet rs, Type type)
static Serializable | getGeneratedIdentity(ResultSet rs, Type type) Get the generated identifier when using identity columns
static Class | getIdentifierGeneratorClass(String strategy, Dialect dialect)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SHORT_CIRCUIT_INDICATOR

public static final Serializable SHORT_CIRCUIT_INDICATOR

POST_INSERT_INDICATOR

public static final Serializable POST_INSERT_INDICATOR
Method Detail

getGeneratedIdentity

public static Serializable getGeneratedIdentity(ResultSet rs,
                                                Type type)
                                         throws SQLException,
                                                HibernateException,
                                                IdentifierGenerationException
Get the generated identifier when using identity columns

Throws:
SQLException
HibernateException
IdentifierGenerationException

get

public static Serializable get(ResultSet rs,
                               Type type)
                        throws SQLException,
                               IdentifierGenerationException
Throws:
SQLException
IdentifierGenerationException

create

public static IdentifierGenerator create(String strategy,
                                         Type type,
                                         Properties params,
                                         Dialect dialect)
                                  throws MappingException
Throws:
MappingException

getIdentifierGeneratorClass

public static Class getIdentifierGeneratorClass(String strategy,
                                                Dialect dialect)

createNumber

public static Number createNumber(long value,
                                  Class clazz)
                           throws IdentifierGenerationException
Throws:
IdentifierGenerationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentityGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class IdentityGenerator

java.lang.Object
    extended by org.hibernate.id.AbstractPostInsertGenerator
        extended by org.hibernate.id.IdentityGenerator
All Implemented Interfaces:
IdentifierGenerator, PostInsertIdentifierGenerator
public class IdentityGenerator
extends AbstractPostInsertGenerator

A generator for use with ANSI-SQL IDENTITY columns used as the primary key. The IdentityGenerator for autoincrement/identity key generation.

Indicates to the Session that identity (ie. identity/autoincrement column) key generation should be used.

Author:
Christoph Sturm

Nested Class Summary
static class | IdentityGenerator.BasicDelegate Delegate for dealing with IDENTITY columns where the dialect requires an additional command execution to retrieve the generated IDENTITY value
static class | IdentityGenerator.GetGeneratedKeysDelegate Delegate for dealing with IDENTITY columns using JDBC3 getGeneratedKeys
static class | IdentityGenerator.InsertSelectDelegate Delegate for dealing with IDENTITY columns where the dialect supports returning the generated IDENTITY value directly from the insert statement.
Field Summary
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
IdentityGenerator()
Method Summary
 InsertGeneratedIdentifierDelegate getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
Methods inherited from class org.hibernate.id.AbstractPostInsertGenerator
generate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IdentityGenerator

public IdentityGenerator()
Method Detail

getInsertGeneratedIdentifierDelegate

public InsertGeneratedIdentifierDelegate getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister,
                                                                              Dialect dialect,
                                                                              boolean isGetGeneratedKeysEnabled)
                                                                       throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentityGenerator.BasicDelegate (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class IdentityGenerator.BasicDelegate

java.lang.Object
    extended by org.hibernate.id.insert.AbstractSelectingDelegate
        extended by org.hibernate.id.IdentityGenerator.BasicDelegate
All Implemented Interfaces:
InsertGeneratedIdentifierDelegate
Enclosing class:
IdentityGenerator
public static class IdentityGenerator.BasicDelegate
extends AbstractSelectingDelegate
implements InsertGeneratedIdentifierDelegate

Delegate for dealing with IDENTITY columns where the dialect requires an additional command execution to retrieve the generated IDENTITY value

Constructor Summary
IdentityGenerator.BasicDelegate(PostInsertIdentityPersister persister, Dialect dialect)
Method Summary
protected Serializable | getResult(SessionImplementor session, ResultSet rs, Object object) Extract the generated key value from the given result set.
protected String | getSelectSQL() Get the SQL statement to be used to retrieve generated key values.
IdentifierGeneratingInsert | prepareIdentifierGeneratingInsert() Build a Insert specific to the delegate's mode of handling generated key values.
Methods inherited from class org.hibernate.id.insert.AbstractSelectingDelegate
bindParameters, performInsert
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.id.insert.InsertGeneratedIdentifierDelegate
performInsert

Constructor Detail

IdentityGenerator.BasicDelegate

public IdentityGenerator.BasicDelegate(PostInsertIdentityPersister persister,
                                       Dialect dialect)
Method Detail

prepareIdentifierGeneratingInsert

public IdentifierGeneratingInsert prepareIdentifierGeneratingInsert()
Description copied from interface: InsertGeneratedIdentifierDelegate
Build a Insert specific to the delegate's mode of handling generated key values.

Specified by:
prepareIdentifierGeneratingInsert in interface InsertGeneratedIdentifierDelegate
Returns:
The insert object.

getSelectSQL

protected String getSelectSQL()
Description copied from class: AbstractSelectingDelegate
Get the SQL statement to be used to retrieve generated key values.

Specified by:
getSelectSQL in class AbstractSelectingDelegate
Returns:
The SQL command string

getResult

protected Serializable getResult(SessionImplementor session,
                                 ResultSet rs,
                                 Object object)
                          throws SQLException
Description copied from class: AbstractSelectingDelegate
Extract the generated key value from the given result set.

Specified by:
getResult in class AbstractSelectingDelegate
Parameters:
session - The session
rs - The result set containing the generated primay key values.
object - The entity being saved.
Returns:
The generated identifier
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentityGenerator.GetGeneratedKeysDelegate (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class IdentityGenerator.GetGeneratedKeysDelegate

java.lang.Object
    extended by org.hibernate.id.insert.AbstractReturningDelegate
        extended by org.hibernate.id.IdentityGenerator.GetGeneratedKeysDelegate
All Implemented Interfaces:
InsertGeneratedIdentifierDelegate
Enclosing class:
IdentityGenerator
public static class IdentityGenerator.GetGeneratedKeysDelegate
extends AbstractReturningDelegate
implements InsertGeneratedIdentifierDelegate

Delegate for dealing with IDENTITY columns using JDBC3 getGeneratedKeys

Constructor Summary
IdentityGenerator.GetGeneratedKeysDelegate(PostInsertIdentityPersister persister, Dialect dialect)
Method Summary
Serializable | executeAndExtract(PreparedStatement insert)
protected PreparedStatement | prepare(String insertSQL, SessionImplementor session)
IdentifierGeneratingInsert | prepareIdentifierGeneratingInsert() Build a Insert specific to the delegate's mode of handling generated key values.
Methods inherited from class org.hibernate.id.insert.AbstractReturningDelegate
getPersister, performInsert, releaseStatement
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.id.insert.InsertGeneratedIdentifierDelegate
performInsert

Constructor Detail

IdentityGenerator.GetGeneratedKeysDelegate

public IdentityGenerator.GetGeneratedKeysDelegate(PostInsertIdentityPersister persister,
                                                  Dialect dialect)
Method Detail

prepareIdentifierGeneratingInsert

public IdentifierGeneratingInsert prepareIdentifierGeneratingInsert()
Description copied from interface: InsertGeneratedIdentifierDelegate
Build a Insert specific to the delegate's mode of handling generated key values.

Specified by:
prepareIdentifierGeneratingInsert in interface InsertGeneratedIdentifierDelegate
Returns:
The insert object.

prepare

protected PreparedStatement prepare(String insertSQL,
                                    SessionImplementor session)
                             throws SQLException
Specified by:
prepare in class AbstractReturningDelegate
Throws:
SQLException

executeAndExtract

public Serializable executeAndExtract(PreparedStatement insert)
                               throws SQLException
Specified by:
executeAndExtract in class AbstractReturningDelegate
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentityGenerator.InsertSelectDelegate (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class IdentityGenerator.InsertSelectDelegate

java.lang.Object
    extended by org.hibernate.id.insert.AbstractReturningDelegate
        extended by org.hibernate.id.IdentityGenerator.InsertSelectDelegate
All Implemented Interfaces:
InsertGeneratedIdentifierDelegate
Enclosing class:
IdentityGenerator
public static class IdentityGenerator.InsertSelectDelegate
extends AbstractReturningDelegate
implements InsertGeneratedIdentifierDelegate

Delegate for dealing with IDENTITY columns where the dialect supports returning the generated IDENTITY value directly from the insert statement.

Constructor Summary
IdentityGenerator.InsertSelectDelegate(PostInsertIdentityPersister persister, Dialect dialect)
Method Summary
Serializable | determineGeneratedIdentifier(SessionImplementor session, Object entity)
Serializable | executeAndExtract(PreparedStatement insert)
protected PreparedStatement | prepare(String insertSQL, SessionImplementor session)
IdentifierGeneratingInsert | prepareIdentifierGeneratingInsert() Build a Insert specific to the delegate's mode of handling generated key values.
Methods inherited from class org.hibernate.id.insert.AbstractReturningDelegate
getPersister, performInsert, releaseStatement
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.id.insert.InsertGeneratedIdentifierDelegate
performInsert

Constructor Detail

IdentityGenerator.InsertSelectDelegate

public IdentityGenerator.InsertSelectDelegate(PostInsertIdentityPersister persister,
                                              Dialect dialect)
Method Detail

prepareIdentifierGeneratingInsert

public IdentifierGeneratingInsert prepareIdentifierGeneratingInsert()
Description copied from interface: InsertGeneratedIdentifierDelegate
Build a Insert specific to the delegate's mode of handling generated key values.

Specified by:
prepareIdentifierGeneratingInsert in interface InsertGeneratedIdentifierDelegate
Returns:
The insert object.

prepare

protected PreparedStatement prepare(String insertSQL,
                                    SessionImplementor session)
                             throws SQLException
Specified by:
prepare in class AbstractReturningDelegate
Throws:
SQLException

executeAndExtract

public Serializable executeAndExtract(PreparedStatement insert)
                               throws SQLException
Specified by:
executeAndExtract in class AbstractReturningDelegate
Throws:
SQLException

determineGeneratedIdentifier

public Serializable determineGeneratedIdentifier(SessionImplementor session,
                                                 Object entity)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IncrementGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class IncrementGenerator

java.lang.Object
    extended by org.hibernate.id.IncrementGenerator
All Implemented Interfaces:
Configurable, IdentifierGenerator
public class IncrementGenerator
extends Object
implements IdentifierGenerator, Configurable

increment

An IdentifierGenerator that returns a long, constructed by counting from the maximum primary key value at startup. Not safe for use in a cluster!

Mapping parameters supported, but not usually needed: tables, column. (The tables parameter specified a comma-separated list of table names.)

Author:
Gavin King

Field Summary
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
IncrementGenerator()
Method Summary
void | configure(Type type, Properties params, Dialect dialect) Configure this instance, given the value of parameters specified by the user as <param> elements.
Serializable | generate(SessionImplementor session, Object object) Generate a new identifier.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IncrementGenerator

public IncrementGenerator()
Method Detail

generate

public Serializable generate(SessionImplementor session,
                             Object object)
                      throws HibernateException
Description copied from interface: IdentifierGenerator
Generate a new identifier.

Specified by:
generate in interface IdentifierGenerator
Parameters:
session -
object - the entity or toplevel collection for which the id is being generated
Returns:
a new identifier
Throws:
HibernateException

configure

public void configure(Type type,
                      Properties params,
                      Dialect dialect)
               throws MappingException
Description copied from interface: Configurable
Configure this instance, given the value of parameters specified by the user as <param> elements. This method is called just once, following instantiation.

Specified by:
configure in interface Configurable
Parameters:
params - param values, keyed by parameter name
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MultipleHiLoPerTableGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class MultipleHiLoPerTableGenerator

java.lang.Object
    extended by org.hibernate.engine.TransactionHelper
        extended by org.hibernate.id.MultipleHiLoPerTableGenerator
All Implemented Interfaces:
Configurable, IdentifierGenerator, PersistentIdentifierGenerator
public class MultipleHiLoPerTableGenerator
extends TransactionHelper
implements PersistentIdentifierGenerator, Configurable

A hilo IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm. The hi value MUST be fetched in a seperate transaction to the Session transaction so the generator must be able to obtain a new connection and commit it. Hence this implementation may not be used when the user is supplying connections. In this case a SequenceHiLoGenerator would be a better choice (where supported).

A hilo IdentifierGenerator that uses a database table to store the last generated values. A table can contains several hi values. They are distinct from each other through a key

This implementation is not compliant with a user connection

Allowed parameters (all of them are optional):

  • table: table name (default hibernate_sequences)
  • primary_key_column: key column name (default sequence_name)
  • value_column: hi value column name(default sequence_next_hi_value)
  • primary_key_value: key value for the current entity (default to the entity's primary table name)
  • primary_key_length: length of the key column in DB represented as a varchar (default to 255)
  • max_lo: max low value before increasing hi (default to Short.MAX_VALUE)

Author:
Emmanuel Bernard, Klaus Richarz.

Field Summary
static String | DEFAULT_TABLE
static String | ID_TABLE
static String | MAX_LO
static String | PK_COLUMN_NAME
static String | PK_LENGTH_NAME
static String | PK_VALUE_NAME
static String | VALUE_COLUMN_NAME
Fields inherited from interface org.hibernate.id.PersistentIdentifierGenerator
CATALOG, PK, SCHEMA, SQL, TABLE, TABLES
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
MultipleHiLoPerTableGenerator()
Method Summary
void | configure(Type type, Properties params, Dialect dialect) Configure this instance, given the value of parameters specified by the user as <param> elements.
Serializable | doWorkInCurrentTransaction(Connection conn, String sql) The work to be done
Serializable | generate(SessionImplementor session, Object obj) Generate a new identifier.
Object | generatorKey() Return a key unique to the underlying database objects.
String[] | sqlCreateStrings(Dialect dialect) The SQL required to create the underlying database objects.
String[] | sqlDropStrings(Dialect dialect) The SQL required to remove the underlying database objects.
Methods inherited from class org.hibernate.engine.TransactionHelper
doWorkInNewTransaction
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ID_TABLE

public static final String ID_TABLE
See Also:
Constant Field Values

PK_COLUMN_NAME

public static final String PK_COLUMN_NAME
See Also:
Constant Field Values

PK_VALUE_NAME

public static final String PK_VALUE_NAME
See Also:
Constant Field Values

VALUE_COLUMN_NAME

public static final String VALUE_COLUMN_NAME
See Also:
Constant Field Values

PK_LENGTH_NAME

public static final String PK_LENGTH_NAME
See Also:
Constant Field Values

DEFAULT_TABLE

public static final String DEFAULT_TABLE
See Also:
Constant Field Values

MAX_LO

public static final String MAX_LO
See Also:
Constant Field Values
Constructor Detail

MultipleHiLoPerTableGenerator

public MultipleHiLoPerTableGenerator()
Method Detail

sqlCreateStrings

public String[] sqlCreateStrings(Dialect dialect)
                          throws HibernateException
Description copied from interface: PersistentIdentifierGenerator
The SQL required to create the underlying database objects.

Specified by:
sqlCreateStrings in interface PersistentIdentifierGenerator
Parameters:
dialect -
Returns:
String[]
Throws:
HibernateException

sqlDropStrings

public String[] sqlDropStrings(Dialect dialect)
                        throws HibernateException
Description copied from interface: PersistentIdentifierGenerator
The SQL required to remove the underlying database objects.

Specified by:
sqlDropStrings in interface PersistentIdentifierGenerator
Parameters:
dialect -
Returns:
String
Throws:
HibernateException

generatorKey

public Object generatorKey()
Description copied from interface: PersistentIdentifierGenerator
Return a key unique to the underlying database objects. Prevents us from trying to create/remove them multiple times.

Specified by:
generatorKey in interface PersistentIdentifierGenerator
Returns:
Object an identifying key for this generator

doWorkInCurrentTransaction

public Serializable doWorkInCurrentTransaction(Connection conn,
                                               String sql)
                                        throws SQLException
Description copied from class: TransactionHelper
The work to be done

Specified by:
doWorkInCurrentTransaction in class TransactionHelper
Throws:
SQLException

generate

public Serializable generate(SessionImplementor session,
                             Object obj)
                      throws HibernateException
Description copied from interface: IdentifierGenerator
Generate a new identifier.

Specified by:
generate in interface IdentifierGenerator
Parameters:
session -
obj - the entity or toplevel collection for which the id is being generated
Returns:
a new identifier
Throws:
HibernateException

configure

public void configure(Type type,
                      Properties params,
                      Dialect dialect)
               throws MappingException
Description copied from interface: Configurable
Configure this instance, given the value of parameters specified by the user as <param> elements. This method is called just once, following instantiation.

Specified by:
configure in interface Configurable
Parameters:
params - param values, keyed by parameter name
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class SelectGenerator

java.lang.Object
    extended by org.hibernate.id.AbstractPostInsertGenerator
        extended by org.hibernate.id.SelectGenerator
All Implemented Interfaces:
Configurable, IdentifierGenerator, PostInsertIdentifierGenerator
public class SelectGenerator
extends AbstractPostInsertGenerator
implements Configurable

A generator that selects the just inserted row to determine the identifier value assigned by the database. The correct row is located using a unique key.

One mapping parameter is required: key (unless a natural-id is defined in the mapping).

Author:
Gavin King

Nested Class Summary
static class SelectGenerator.SelectGeneratorDelegate
The delegate for the select generation strategy.
Field Summary
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
SelectGenerator()
Method Summary
void | configure(Type type, Properties params, Dialect d) Configure this instance, given the value of parameters specified by the user as <param> elements.
InsertGeneratedIdentifierDelegate | getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
Methods inherited from class org.hibernate.id.AbstractPostInsertGenerator
generate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SelectGenerator

public SelectGenerator()
Method Detail

configure

public void configure(Type type,
                      Properties params,
                      Dialect d)
               throws MappingException
Description copied from interface: Configurable
Configure this instance, given the value of parameters specified by the user as <param> elements. This method is called just once, following instantiation.

Specified by:
configure in interface Configurable
Parameters:
params - param values, keyed by parameter name
Throws:
MappingException

getInsertGeneratedIdentifierDelegate

public InsertGeneratedIdentifierDelegate getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister,
                                                                              Dialect dialect,
                                                                              boolean isGetGeneratedKeysEnabled)
                                                                       throws HibernateException
Specified by:
getInsertGeneratedIdentifierDelegate in interface PostInsertIdentifierGenerator
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectGenerator.SelectGeneratorDelegate (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class SelectGenerator.SelectGeneratorDelegate

java.lang.Object
    extended by org.hibernate.id.insert.AbstractSelectingDelegate
        extended by org.hibernate.id.SelectGenerator.SelectGeneratorDelegate
All Implemented Interfaces:
InsertGeneratedIdentifierDelegate
Enclosing class:
SelectGenerator
public static class SelectGenerator.SelectGeneratorDelegate
extends AbstractSelectingDelegate
implements InsertGeneratedIdentifierDelegate

The delegate for the select generation strategy.

Method Summary
protected  void bindParameters(SessionImplementor session, PreparedStatement ps, Object entity)
Bind any required parameter values into the SQL command getSelectSQL().
protected  Serializable getResult(SessionImplementor session, ResultSet rs, Object entity)
Extract the generated key value from the given result set.
protected  String getSelectSQL()
Get the SQL statement to be used to retrieve generated key values.
 IdentifierGeneratingInsert prepareIdentifierGeneratingInsert()
Build a Insert specific to the delegate's mode of handling generated key values.
Methods inherited from class org.hibernate.id.insert.AbstractSelectingDelegate
performInsert
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.id.insert.InsertGeneratedIdentifierDelegate
performInsert

Method Detail

prepareIdentifierGeneratingInsert

public IdentifierGeneratingInsert prepareIdentifierGeneratingInsert()
Description copied from interface: InsertGeneratedIdentifierDelegate
Build a Insert specific to the delegate's mode of handling generated key values.

Specified by:
prepareIdentifierGeneratingInsert in interface InsertGeneratedIdentifierDelegate
Returns:
The insert object.

getSelectSQL

protected String getSelectSQL()
Description copied from class: AbstractSelectingDelegate
Get the SQL statement to be used to retrieve generated key values.

Specified by:
getSelectSQL in class AbstractSelectingDelegate
Returns:
The SQL command string

bindParameters

protected void bindParameters(SessionImplementor session,
                              PreparedStatement ps,
                              Object entity)
                       throws SQLException
Description copied from class: AbstractSelectingDelegate
Bind any required parameter values into the SQL command AbstractSelectingDelegate.getSelectSQL().

Overrides:
bindParameters in class AbstractSelectingDelegate
Parameters:
session - The session
ps - The prepared SQL command
entity - The entity being saved.
Throws:
SQLException

getResult

protected Serializable getResult(SessionImplementor session,
                                 ResultSet rs,
                                 Object entity)
                          throws SQLException
Description copied from class: AbstractSelectingDelegate
Extract the generated key value from the given result set.

Specified by:
getResult in class AbstractSelectingDelegate
Parameters:
session - The session
rs - The result set containing the generated primay key values.
entity - The entity being saved.
Returns:
The generated identifier
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SequenceGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class SequenceGenerator

java.lang.Object
    extended by org.hibernate.id.SequenceGenerator
All Implemented Interfaces:
Configurable, IdentifierGenerator, PersistentIdentifierGenerator
Direct Known Subclasses:
SequenceHiLoGenerator, SequenceIdentityGenerator
public class SequenceGenerator
extends Object
implements PersistentIdentifierGenerator, Configurable

sequence

Generates long values using an oracle-style sequence. A higher performance algorithm is SequenceHiLoGenerator.

Mapping parameters supported: sequence, parameters.

Author:
Gavin King
See Also:
SequenceHiLoGenerator, TableHiLoGenerator

Field Summary
static String | PARAMETERS The parameters parameter, appended to the create sequence DDL.
static String | SEQUENCE The sequence parameter
Fields inherited from interface org.hibernate.id.PersistentIdentifierGenerator
CATALOG, PK, SCHEMA, SQL, TABLE, TABLES
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
SequenceGenerator()
Method Summary
void | configure(Type type, Properties params, Dialect dialect) Configure this instance, given the value of parameters specified by the user as <param> elements.
Serializable | generate(SessionImplementor session, Object obj) Generate a new identifier.
Object | generatorKey() Return a key unique to the underlying database objects.
String | getSequenceName()
String[] | sqlCreateStrings(Dialect dialect) The SQL required to create the underlying database objects.
String[] | sqlDropStrings(Dialect dialect) The SQL required to remove the underlying database objects.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SEQUENCE

public static final String SEQUENCE
The sequence parameter

See Also:
Constant Field Values

PARAMETERS

public static final String PARAMETERS
The parameters parameter, appended to the create sequence DDL. For example (Oracle): INCREMENT BY 1 START WITH 1 MAXVALUE 100 NOCACHE.

See Also:
Constant Field Values
Constructor Detail

SequenceGenerator

public SequenceGenerator()
Method Detail

configure

public void configure(Type type,
                      Properties params,
                      Dialect dialect)
               throws MappingException
Description copied from interface: Configurable
Configure this instance, given the value of parameters specified by the user as <param> elements. This method is called just once, following instantiation.

Specified by:
configure in interface Configurable
Parameters:
params - param values, keyed by parameter name
Throws:
MappingException

generate

public Serializable generate(SessionImplementor session,
                             Object obj)
                      throws HibernateException
Description copied from interface: IdentifierGenerator
Generate a new identifier.

Specified by:
generate in interface IdentifierGenerator
Parameters:
session -
obj - the entity or toplevel collection for which the id is being generated
Returns:
a new identifier
Throws:
HibernateException

sqlCreateStrings

public String[] sqlCreateStrings(Dialect dialect)
                          throws HibernateException
Description copied from interface: PersistentIdentifierGenerator
The SQL required to create the underlying database objects.

Specified by:
sqlCreateStrings in interface PersistentIdentifierGenerator
Parameters:
dialect -
Returns:
String[]
Throws:
HibernateException

sqlDropStrings

public String[] sqlDropStrings(Dialect dialect)
                        throws HibernateException
Description copied from interface: PersistentIdentifierGenerator
The SQL required to remove the underlying database objects.

Specified by:
sqlDropStrings in interface PersistentIdentifierGenerator
Parameters:
dialect -
Returns:
String
Throws:
HibernateException

generatorKey

public Object generatorKey()
Description copied from interface: PersistentIdentifierGenerator
Return a key unique to the underlying database objects. Prevents us from trying to create/remove them multiple times.

Specified by:
generatorKey in interface PersistentIdentifierGenerator
Returns:
Object an identifying key for this generator

getSequenceName

public String getSequenceName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SequenceHiLoGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class SequenceHiLoGenerator

java.lang.Object
    extended by org.hibernate.id.SequenceGenerator
        extended by org.hibernate.id.SequenceHiLoGenerator
All Implemented Interfaces:
Configurable, IdentifierGenerator, PersistentIdentifierGenerator
public class SequenceHiLoGenerator
extends SequenceGenerator

seqhilo

An IdentifierGenerator that combines a hi/lo algorithm with an underlying oracle-style sequence that generates hi values. The user may specify a maximum lo value to determine how often new hi values are fetched.

If sequences are not available, TableHiLoGenerator might be an alternative.

Mapping parameters supported: sequence, max_lo, parameters.

Author:
Gavin King
See Also:
TableHiLoGenerator

Field Summary
static String MAX_LO
Fields inherited from class org.hibernate.id.SequenceGenerator
PARAMETERS, SEQUENCE
Fields inherited from interface org.hibernate.id.PersistentIdentifierGenerator
CATALOG, PK, SCHEMA, SQL, TABLE, TABLES
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
SequenceHiLoGenerator()
Method Summary
void | configure(Type type, Properties params, Dialect d) Configure this instance, given the value of parameters specified by the user as <param> elements.
Serializable | generate(SessionImplementor session, Object obj) Generate a new identifier.
Methods inherited from class org.hibernate.id.SequenceGenerator
generatorKey, getSequenceName, sqlCreateStrings, sqlDropStrings
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MAX_LO

public static final String MAX_LO
See Also:
Constant Field Values
Constructor Detail

SequenceHiLoGenerator

public SequenceHiLoGenerator()
Method Detail

configure

public void configure(Type type,
                      Properties params,
                      Dialect d)
               throws MappingException
Description copied from interface: Configurable
Configure this instance, given the value of parameters specified by the user as <param> elements. This method is called just once, following instantiation.

Specified by:
configure in interface Configurable
Overrides:
configure in class SequenceGenerator
Throws:
MappingException

generate

public Serializable generate(SessionImplementor session,
                             Object obj)
                      throws HibernateException
Description copied from interface: IdentifierGenerator
Generate a new identifier.

Specified by:
generate in interface IdentifierGenerator
Overrides:
generate in class SequenceGenerator
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SequenceIdentityGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class SequenceIdentityGenerator

java.lang.Object
    extended by org.hibernate.id.SequenceGenerator
        extended by org.hibernate.id.SequenceIdentityGenerator
All Implemented Interfaces:
Configurable, IdentifierGenerator, PersistentIdentifierGenerator, PostInsertIdentifierGenerator
public class SequenceIdentityGenerator
extends SequenceGenerator
implements PostInsertIdentifierGenerator

A generator which combines sequence generation with immediate retrieval through JDBC3 getGeneratedKeys. In this respect it works much like ANSI-SQL IDENTITY generation.

This generator only known to work with newer Oracle drivers compiled for JDK 1.4 (JDBC3).

Note: Due to a bug in Oracle drivers, sql comments on these insert statements are completely disabled.

Author:
Steve Ebersole

Nested Class Summary
static class | SequenceIdentityGenerator.Delegate
static class | SequenceIdentityGenerator.NoCommentsInsert
Field Summary
Fields inherited from class org.hibernate.id.SequenceGenerator
PARAMETERS, SEQUENCE
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Fields inherited from interface org.hibernate.id.PersistentIdentifierGenerator
CATALOG, PK, SCHEMA, SQL, TABLE, TABLES
Constructor Summary
SequenceIdentityGenerator()
Method Summary
void | configure(Type type, Properties params, Dialect dialect) Configure this instance, given the value of parameters specified by the user as <param> elements.
Serializable | generate(SessionImplementor s, Object obj) Generate a new identifier.
InsertGeneratedIdentifierDelegate | getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
Methods inherited from class org.hibernate.id.SequenceGenerator
generatorKey, getSequenceName, sqlCreateStrings, sqlDropStrings
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SequenceIdentityGenerator

public SequenceIdentityGenerator()
Method Detail

generate

public Serializable generate(SessionImplementor s,
                             Object obj)
Description copied from interface: IdentifierGenerator
Generate a new identifier.

Specified by:
generate in interface IdentifierGenerator
Overrides:
generate in class SequenceGenerator

getInsertGeneratedIdentifierDelegate

public InsertGeneratedIdentifierDelegate getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister,
                                                                              Dialect dialect,
                                                                              boolean isGetGeneratedKeysEnabled)
                                                                       throws HibernateException
Specified by:
getInsertGeneratedIdentifierDelegate in interface PostInsertIdentifierGenerator
Throws:
HibernateException

configure

public void configure(Type type,
                      Properties params,
                      Dialect dialect)
               throws MappingException
Description copied from interface: Configurable
Configure this instance, given the value of parameters specified by the user as <param> elements. This method is called just once, following instantiation.

Specified by:
configure in interface Configurable
Overrides:
configure in class SequenceGenerator
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SequenceIdentityGenerator.Delegate (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class SequenceIdentityGenerator.Delegate

java.lang.Object
    extended by org.hibernate.id.insert.AbstractReturningDelegate
        extended by org.hibernate.id.SequenceIdentityGenerator.Delegate
All Implemented Interfaces:
InsertGeneratedIdentifierDelegate
Enclosing class:
SequenceIdentityGenerator
public static class SequenceIdentityGenerator.Delegate
extends AbstractReturningDelegate

Constructor Summary
SequenceIdentityGenerator.Delegate(PostInsertIdentityPersister persister, Dialect dialect, String sequenceName)
Method Summary
protected Serializable | executeAndExtract(PreparedStatement insert)
protected PreparedStatement | prepare(String insertSQL, SessionImplementor session)
IdentifierGeneratingInsert | prepareIdentifierGeneratingInsert() Build a Insert specific to the delegate's mode of handling generated key values.
Methods inherited from class org.hibernate.id.insert.AbstractReturningDelegate
getPersister, performInsert, releaseStatement
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SequenceIdentityGenerator.Delegate

public SequenceIdentityGenerator.Delegate(PostInsertIdentityPersister persister,
                                          Dialect dialect,
                                          String sequenceName)
Method Detail

prepareIdentifierGeneratingInsert

public IdentifierGeneratingInsert prepareIdentifierGeneratingInsert()
Description copied from interface: InsertGeneratedIdentifierDelegate
Build a Insert specific to the delegate's mode of handling generated key values.

Returns:
The insert object.

prepare

protected PreparedStatement prepare(String insertSQL,
                                    SessionImplementor session)
                             throws SQLException
Specified by:
prepare in class AbstractReturningDelegate
Throws:
SQLException

executeAndExtract

protected Serializable executeAndExtract(PreparedStatement insert)
                                  throws SQLException
Specified by:
executeAndExtract in class AbstractReturningDelegate
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SequenceIdentityGenerator.NoCommentsInsert (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class SequenceIdentityGenerator.NoCommentsInsert

java.lang.Object
    extended by org.hibernate.sql.Insert
        extended by org.hibernate.id.insert.IdentifierGeneratingInsert
            extended by org.hibernate.id.SequenceIdentityGenerator.NoCommentsInsert
Enclosing class:
SequenceIdentityGenerator
public static class SequenceIdentityGenerator.NoCommentsInsert
extends IdentifierGeneratingInsert

Constructor Summary
SequenceIdentityGenerator.NoCommentsInsert(Dialect dialect)
Method Summary
 Insert setComment(String comment)
Methods inherited from class org.hibernate.sql.Insert
addColumn, addColumn, addColumn, addColumns, addColumns, addIdentityColumn, getDialect, setTableName, toStatementString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SequenceIdentityGenerator.NoCommentsInsert

public SequenceIdentityGenerator.NoCommentsInsert(Dialect dialect)
Method Detail

setComment

public Insert setComment(String comment)
Overrides:
setComment in class Insert
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class TableGenerator

java.lang.Object
    extended by org.hibernate.engine.TransactionHelper
        extended by org.hibernate.id.TableGenerator
All Implemented Interfaces:
Configurable, IdentifierGenerator, PersistentIdentifierGenerator
Direct Known Subclasses:
TableHiLoGenerator
public class TableGenerator
extends TransactionHelper
implements PersistentIdentifierGenerator, Configurable

An IdentifierGenerator that uses a database table to store the last generated value. It is not intended that applications use this strategy directly. However, it may be used to build other (efficient) strategies. The returned type is Integer.

The hi value MUST be fetched in a seperate transaction to the Session transaction so the generator must be able to obtain a new connection and commit it. Hence this implementation may not be used when Hibernate is fetching connections when the user is supplying connections.

The returned value is of type integer.

Mapping parameters supported: table, column

Author:
Gavin King
See Also:
TableHiLoGenerator

Field Summary
static String | COLUMN The column parameter
static String | DEFAULT_COLUMN_NAME Default column name
static String | DEFAULT_TABLE_NAME Default table name
static String | TABLE The table parameter
Fields inherited from interface org.hibernate.id.PersistentIdentifierGenerator
CATALOG, PK, SCHEMA, SQL, TABLES
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
TableGenerator()
Method Summary
void | configure(Type type, Properties params, Dialect dialect) Configure this instance, given the value of parameters specified by the user as <param> elements.
Serializable | doWorkInCurrentTransaction(Connection conn, String sql) The work to be done
Serializable | generate(SessionImplementor session, Object object) Generate a new identifier.
Object | generatorKey() Return a key unique to the underlying database objects.
String[] | sqlCreateStrings(Dialect dialect) The SQL required to create the underlying database objects.
String[] | sqlDropStrings(Dialect dialect) The SQL required to remove the underlying database objects.
Methods inherited from class org.hibernate.engine.TransactionHelper
doWorkInNewTransaction
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COLUMN

public static final String COLUMN
The column parameter

See Also:
Constant Field Values

DEFAULT_COLUMN_NAME

public static final String DEFAULT_COLUMN_NAME
Default column name

See Also:
Constant Field Values

TABLE

public static final String TABLE
The table parameter

See Also:
Constant Field Values

DEFAULT_TABLE_NAME

public static final String DEFAULT_TABLE_NAME
Default table name

See Also:
Constant Field Values
Constructor Detail

TableGenerator

public TableGenerator()
Method Detail

configure

public void configure(Type type,
                      Properties params,
                      Dialect dialect)
Description copied from interface: Configurable
Configure this instance, given the value of parameters specified by the user as <param> elements. This method is called just once, following instantiation.

Specified by:
configure in interface Configurable
Parameters:
params - param values, keyed by parameter name

generate

public Serializable generate(SessionImplementor session,
                             Object object)
                      throws HibernateException
Description copied from interface: IdentifierGenerator
Generate a new identifier.

Specified by:
generate in interface IdentifierGenerator
Parameters:
session -
object - the entity or toplevel collection for which the id is being generated
Returns:
a new identifier
Throws:
HibernateException

sqlCreateStrings

public String[] sqlCreateStrings(Dialect dialect)
                          throws HibernateException
Description copied from interface: PersistentIdentifierGenerator
The SQL required to create the underlying database objects.

Specified by:
sqlCreateStrings in interface PersistentIdentifierGenerator
Parameters:
dialect -
Returns:
String[]
Throws:
HibernateException

sqlDropStrings

public String[] sqlDropStrings(Dialect dialect)
Description copied from interface: PersistentIdentifierGenerator
The SQL required to remove the underlying database objects.

Specified by:
sqlDropStrings in interface PersistentIdentifierGenerator
Parameters:
dialect -
Returns:
String

generatorKey

public Object generatorKey()
Description copied from interface: PersistentIdentifierGenerator
Return a key unique to the underlying database objects. Prevents us from trying to create/remove them multiple times.

Specified by:
generatorKey in interface PersistentIdentifierGenerator
Returns:
Object an identifying key for this generator

doWorkInCurrentTransaction

public Serializable doWorkInCurrentTransaction(Connection conn,
                                               String sql)
                                        throws SQLException
Description copied from class: TransactionHelper
The work to be done

Specified by:
doWorkInCurrentTransaction in class TransactionHelper
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableHiLoGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class TableHiLoGenerator

java.lang.Object
    extended by org.hibernate.engine.TransactionHelper
        extended by org.hibernate.id.TableGenerator
            extended by org.hibernate.id.TableHiLoGenerator
All Implemented Interfaces:
Configurable, IdentifierGenerator, PersistentIdentifierGenerator
public class TableHiLoGenerator
extends TableGenerator

hilo

An IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm. The hi value MUST be fetched in a seperate transaction to the Session transaction so the generator must be able to obtain a new connection and commit it. Hence this implementation may not be used when the user is supplying connections. In this case a SequenceHiLoGenerator would be a better choice (where supported).

Mapping parameters supported: table, column, max_lo

Author:
Gavin King
See Also:
SequenceHiLoGenerator

Field Summary
static String MAX_LO
The max_lo parameter
Fields inherited from class org.hibernate.id.TableGenerator
COLUMN, DEFAULT_COLUMN_NAME, DEFAULT_TABLE_NAME, TABLE
Fields inherited from interface org.hibernate.id.PersistentIdentifierGenerator
CATALOG, PK, SCHEMA, SQL, TABLES
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
TableHiLoGenerator()
Method Summary
void | configure(Type type, Properties params, Dialect d) Configure this instance, given the value of parameters specified by the user as <param> elements.
Serializable | generate(SessionImplementor session, Object obj) Generate a new identifier.
Methods inherited from class org.hibernate.id.TableGenerator
doWorkInCurrentTransaction, generatorKey, sqlCreateStrings, sqlDropStrings
Methods inherited from class org.hibernate.engine.TransactionHelper
doWorkInNewTransaction
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MAX_LO

public static final String MAX_LO
The max_lo parameter

See Also:
Constant Field Values
Constructor Detail

TableHiLoGenerator

public TableHiLoGenerator()
Method Detail

configure

public void configure(Type type,
                      Properties params,
                      Dialect d)
Description copied from interface: Configurable
Configure this instance, given the value of parameters specified by the user as <param> elements. This method is called just once, following instantiation.

Specified by:
configure in interface Configurable
Overrides:
configure in class TableGenerator

generate

public Serializable generate(SessionImplementor session,
                             Object obj)
                      throws HibernateException
Description copied from interface: IdentifierGenerator
Generate a new identifier.

Specified by:
generate in interface IdentifierGenerator
Overrides:
generate in class TableGenerator
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UUIDHexGenerator (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class UUIDHexGenerator

java.lang.Object
    extended by org.hibernate.id.AbstractUUIDGenerator
        extended by org.hibernate.id.UUIDHexGenerator
All Implemented Interfaces:
Configurable, IdentifierGenerator
public class UUIDHexGenerator
extends AbstractUUIDGenerator
implements Configurable

uuid

A UUIDGenerator that returns a string of length 32, This string will consist of only hex digits. Optionally, the string may be generated with separators between each component of the UUID. Mapping parameters supported: separator.

Author:
Gavin King

Field Summary
Fields inherited from interface org.hibernate.id.IdentifierGenerator
ENTITY_NAME
Constructor Summary
UUIDHexGenerator()
Method Summary
void | configure(Type type, Properties params, Dialect d) Configure this instance, given the value of parameters specified by the user as <param> elements.
protected String | format(int intval)
protected String | format(short shortval)
Serializable | generate(SessionImplementor session, Object obj) Generate a new identifier.
static void | main(String[] args)
Methods inherited from class org.hibernate.id.AbstractUUIDGenerator
getCount, getHiTime, getIP, getJVM, getLoTime
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UUIDHexGenerator

public UUIDHexGenerator()
Method Detail

format

protected String format(int intval)

format

protected String format(short shortval)

generate

public Serializable generate(SessionImplementor session,
                             Object obj)
Description copied from interface: IdentifierGenerator
Generate a new identifier.

Specified by:
generate in interface IdentifierGenerator
Parameters:
session -
obj - the entity or toplevel collection for which the id is being generated
Returns:
a new identifier

configure

public void configure(Type type,
                      Properties params,
                      Dialect d)
Description copied from interface: Configurable
Configure this instance, given the value of parameters specified by the user as <param> elements. This method is called just once, following instantiation.

Specified by:
configure in interface Configurable
Parameters:
params - param values, keyed by parameter name

main

public static void main(String[] args)
                 throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


IdentifierGenerationException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id
Class IdentifierGenerationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.id.IdentifierGenerationException
All Implemented Interfaces:
Nestable, Serializable
public class IdentifierGenerationException
extends HibernateException

Thrown by IdentifierGenerator implementation class when ID generation fails.

Author:
Gavin King
See Also:
IdentifierGenerator, Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
IdentifierGenerationException(String msg)
IdentifierGenerationException(String msg, Throwable t)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IdentifierGenerationException

public IdentifierGenerationException(String msg)

IdentifierGenerationException

public IdentifierGenerationException(String msg,
                                     Throwable t)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.id.insert (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.id.insert

Interface Summary
Binder |
InsertGeneratedIdentifierDelegate | Responsible for handling delegation relating to variants in how insert-generated-identifier generator strategies dictate processing: building the sql insert statement determination of the generated identifier value

Class Summary
AbstractReturningDelegate | Abstract InsertGeneratedIdentifierDelegate implementation where the underlying strategy causes the enerated identitifer to be returned as an effect of performing the insert statement.
AbstractSelectingDelegate | Abstract InsertGeneratedIdentifierDelegate implementation where the underlying strategy requires an subsequent select after the insert to determine the generated identifier.
IdentifierGeneratingInsert | Nothing more than a distinguishing subclass of Insert used to indicate intent.
InsertSelectIdentityInsert | Specialized IdentifierGeneratingInsert which appends the database specific clause which signifies to return generated IDENTITY values to the end of the insert statement.


org.hibernate.id.insert Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.id.insert

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.id.insert.AbstractReturningDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
    • class org.hibernate.id.insert.AbstractSelectingDelegate (implements org.hibernate.id.insert.InsertGeneratedIdentifierDelegate)
    • class org.hibernate.sql.Insert
      • class org.hibernate.id.insert.IdentifierGeneratingInsert
        • class org.hibernate.id.insert.InsertSelectIdentityInsert

Interface Hierarchy

  • interface org.hibernate.id.insert.Binder
  • interface org.hibernate.id.insert.InsertGeneratedIdentifierDelegate


Uses of Package org.hibernate.id.insert (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.id.insert

Packages that use org.hibernate.id.insert
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.id.insert |

Classes in org.hibernate.id.insert used by org.hibernate.id
AbstractReturningDelegate
Abstract InsertGeneratedIdentifierDelegate implementation where the underlying strategy causes the enerated identitifer to be returned as an effect of performing the insert statement.
AbstractSelectingDelegate
Abstract InsertGeneratedIdentifierDelegate implementation where the underlying strategy requires an subsequent select after the insert to determine the generated identifier.
IdentifierGeneratingInsert
Nothing more than a distinguishing subclass of Insert used to indicate intent.
InsertGeneratedIdentifierDelegate
Responsible for handling delegation relating to variants in how insert-generated-identifier generator strategies dictate processing: building the sql insert statement determination of the generated identifier value

Classes in org.hibernate.id.insert used by org.hibernate.id.insert
Binder
IdentifierGeneratingInsert
Nothing more than a distinguishing subclass of Insert used to indicate intent.
InsertGeneratedIdentifierDelegate
Responsible for handling delegation relating to variants in how insert-generated-identifier generator strategies dictate processing: building the sql insert statement determination of the generated identifier value

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Binder (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id.insert
Interface Binder

public interface Binder

Author:
Steve Ebersole

Method Summary
void | bindValues(PreparedStatement ps)
Object | getEntity()

Method Detail

bindValues

public void bindValues(PreparedStatement ps)
                throws SQLException
Throws:
SQLException

getEntity

public Object getEntity()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InsertGeneratedIdentifierDelegate (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id.insert
Interface InsertGeneratedIdentifierDelegate

All Known Implementing Classes:
AbstractReturningDelegate, AbstractSelectingDelegate, IdentityGenerator.BasicDelegate, IdentityGenerator.GetGeneratedKeysDelegate, IdentityGenerator.InsertSelectDelegate, SelectGenerator.SelectGeneratorDelegate
public interface InsertGeneratedIdentifierDelegate

Responsible for handling delegation relating to variants in how insert-generated-identifier generator strategies dictate processing:

  • building the sql insert statement
  • determination of the generated identifier value

Author:
Steve Ebersole

Method Summary
Serializable | performInsert(String insertSQL, SessionImplementor session, Binder binder) Perform the indicated insert SQL statement and determine the identifier value generated.
IdentifierGeneratingInsert | prepareIdentifierGeneratingInsert() Build a Insert specific to the delegate's mode of handling generated key values.

Method Detail

prepareIdentifierGeneratingInsert

public IdentifierGeneratingInsert prepareIdentifierGeneratingInsert()
Build a Insert specific to the delegate's mode of handling generated key values.

Returns:
The insert object.

performInsert

public Serializable performInsert(String insertSQL,
                                  SessionImplementor session,
                                  Binder binder)
Perform the indicated insert SQL statement and determine the identifier value generated.

Parameters:
insertSQL -
session -
binder -
Returns:
The generated identifier value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractReturningDelegate (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id.insert
Class AbstractReturningDelegate

java.lang.Object
    extended by org.hibernate.id.insert.AbstractReturningDelegate
All Implemented Interfaces:
InsertGeneratedIdentifierDelegate
Direct Known Subclasses:
IdentityGenerator.GetGeneratedKeysDelegate, IdentityGenerator.InsertSelectDelegate, SequenceIdentityGenerator.Delegate
public abstract class AbstractReturningDelegate
extends Object
implements InsertGeneratedIdentifierDelegate

Abstract InsertGeneratedIdentifierDelegate implementation where the underlying strategy causes the enerated identitifer to be returned as an effect of performing the insert statement. Thus, there is no need for an additional sql statement to determine the generated identitifer.

Author:
Steve Ebersole

Constructor Summary
AbstractReturningDelegate(PostInsertIdentityPersister persister)
Method Summary
protected abstract Serializable | executeAndExtract(PreparedStatement insert)
protected PostInsertIdentityPersister | getPersister()
Serializable | performInsert(String insertSQL, SessionImplementor session, Binder binder) Perform the indicated insert SQL statement and determine the identifier value generated.
protected abstract PreparedStatement | prepare(String insertSQL, SessionImplementor session)
protected void | releaseStatement(PreparedStatement insert, SessionImplementor session)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.id.insert.InsertGeneratedIdentifierDelegate
prepareIdentifierGeneratingInsert

Constructor Detail

AbstractReturningDelegate

public AbstractReturningDelegate(PostInsertIdentityPersister persister)
Method Detail

performInsert

public final Serializable performInsert(String insertSQL,
                                        SessionImplementor session,
                                        Binder binder)
Description copied from interface: InsertGeneratedIdentifierDelegate
Perform the indicated insert SQL statement and determine the identifier value generated.

Specified by:
performInsert in interface InsertGeneratedIdentifierDelegate
Parameters:
insertSQL -
session -
binder -
Returns:
The generated identifier value.

getPersister

protected PostInsertIdentityPersister getPersister()

prepare

protected abstract PreparedStatement prepare(String insertSQL,
                                             SessionImplementor session)
                                      throws SQLException
Throws:
SQLException

executeAndExtract

protected abstract Serializable executeAndExtract(PreparedStatement insert)
                                           throws SQLException
Throws:
SQLException

releaseStatement

protected void releaseStatement(PreparedStatement insert,
                                SessionImplementor session)
                         throws SQLException
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractSelectingDelegate (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id.insert
Class AbstractSelectingDelegate

java.lang.Object
    extended by org.hibernate.id.insert.AbstractSelectingDelegate
All Implemented Interfaces:
InsertGeneratedIdentifierDelegate
Direct Known Subclasses:
IdentityGenerator.BasicDelegate, SelectGenerator.SelectGeneratorDelegate
public abstract class AbstractSelectingDelegate
extends Object
implements InsertGeneratedIdentifierDelegate

Abstract InsertGeneratedIdentifierDelegate implementation where the underlying strategy requires an subsequent select after the insert to determine the generated identifier.

Author:
Steve Ebersole

Constructor Summary
protected AbstractSelectingDelegate(PostInsertIdentityPersister persister)
Method Summary
protected  void bindParameters(SessionImplementor session, PreparedStatement ps, Object entity)
Bind any required parameter values into the SQL command getSelectSQL().
protected abstract  Serializable getResult(SessionImplementor session, ResultSet rs, Object entity)
Extract the generated key value from the given result set.
protected abstract  String getSelectSQL()
Get the SQL statement to be used to retrieve generated key values.
 Serializable performInsert(String insertSQL, SessionImplementor session, Binder binder)
Perform the indicated insert SQL statement and determine the identifier value generated.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.id.insert.InsertGeneratedIdentifierDelegate
prepareIdentifierGeneratingInsert

Constructor Detail

AbstractSelectingDelegate

protected AbstractSelectingDelegate(PostInsertIdentityPersister persister)
Method Detail

performInsert

public final Serializable performInsert(String insertSQL,
                                        SessionImplementor session,
                                        Binder binder)
Description copied from interface: InsertGeneratedIdentifierDelegate
Perform the indicated insert SQL statement and determine the identifier value generated.

Specified by:
performInsert in interface InsertGeneratedIdentifierDelegate
Parameters:
insertSQL -
session -
binder -
Returns:
The generated identifier value.

getSelectSQL

protected abstract String getSelectSQL()
Get the SQL statement to be used to retrieve generated key values.

Returns:
The SQL command string

bindParameters

protected void bindParameters(SessionImplementor session,
                              PreparedStatement ps,
                              Object entity)
                       throws SQLException
Bind any required parameter values into the SQL command getSelectSQL().

Parameters:
session - The session
ps - The prepared SQL command
entity - The entity being saved.
Throws:
SQLException

getResult

protected abstract Serializable getResult(SessionImplementor session,
                                          ResultSet rs,
                                          Object entity)
                                   throws SQLException
Extract the generated key value from the given result set.

Parameters:
session - The session
rs - The result set containing the generated primay key values.
entity - The entity being saved.
Returns:
The generated identifier
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentifierGeneratingInsert (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id.insert
Class IdentifierGeneratingInsert

java.lang.Object
    extended by org.hibernate.sql.Insert
        extended by org.hibernate.id.insert.IdentifierGeneratingInsert
Direct Known Subclasses:
InsertSelectIdentityInsert, SequenceIdentityGenerator.NoCommentsInsert
public class IdentifierGeneratingInsert
extends Insert

Nothing more than a distinguishing subclass of Insert used to indicate intent. Some subclasses of this also provided some additional functionality or semantic to the genernated SQL statement string.

Author:
Steve Ebersole

Constructor Summary
IdentifierGeneratingInsert(Dialect dialect)
Methods inherited from class org.hibernate.sql.Insert
addColumn, addColumn, addColumn, addColumns, addColumns, addIdentityColumn, getDialect, setComment, setTableName, toStatementString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IdentifierGeneratingInsert

public IdentifierGeneratingInsert(Dialect dialect)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InsertSelectIdentityInsert (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.id.insert
Class InsertSelectIdentityInsert

java.lang.Object
    extended by org.hibernate.sql.Insert
        extended by org.hibernate.id.insert.IdentifierGeneratingInsert
            extended by org.hibernate.id.insert.InsertSelectIdentityInsert
public class InsertSelectIdentityInsert
extends IdentifierGeneratingInsert

Specialized IdentifierGeneratingInsert which appends the database specific clause which signifies to return generated IDENTITY values to the end of the insert statement.

Author:
Steve Ebersole

Constructor Summary
InsertSelectIdentityInsert(Dialect dialect)
Method Summary
 String toStatementString()
Methods inherited from class org.hibernate.sql.Insert
addColumn, addColumn, addColumn, addColumns, addColumns, addIdentityColumn, getDialect, setComment, setTableName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InsertSelectIdentityInsert

public InsertSelectIdentityInsert(Dialect dialect)
Method Detail

toStatementString

public String toStatementString()
Overrides:
toStatementString in class Insert
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.impl (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.impl

This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

See:
Description

Class Summary
AbstractQueryImpl | Abstract implementation of the Query interface.
AbstractScrollableResults | Implementation of the ScrollableResults interface
AbstractSessionImpl | Functionality common to stateless and stateful sessions
CollectionFilterImpl | implementation of the Query interface for collection filters
CriteriaImpl | Implementation of the Criteria interface
CriteriaImpl.CriterionEntry |
CriteriaImpl.OrderEntry |
FetchingScrollableResultsImpl | Implementation of ScrollableResults which can handle collection fetches.
FilterImpl | Implementation of FilterImpl.
IteratorImpl | An implementation of java.util.Iterator that is returned by iterate() query execution methods.
QueryImpl | default implementation of the Query interface, for "ordinary" HQL queries (not collection filters)
ScrollableResultsImpl | Implementation of the ScrollableResults interface
SessionFactoryImpl | Concrete implementation of the SessionFactory interface.
SessionFactoryObjectFactory | Resolves SessionFactory JNDI lookups and deserialization
SessionImpl | Concrete implementation of a Session, and also the central, organizing component of Hibernate's internal implementation.
SQLQueryImpl | Implements SQL query passthrough.
StatelessSessionImpl |

Package org.hibernate.impl Description

This package contains implementations of the central Hibernate APIs, especially the Hibernate session.


org.hibernate.impl Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.impl

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.impl.AbstractQueryImpl (implements org.hibernate.Query)
      • class org.hibernate.impl.QueryImpl
        • class org.hibernate.impl.CollectionFilterImpl
      • class org.hibernate.impl.SQLQueryImpl (implements org.hibernate.SQLQuery)
    • class org.hibernate.impl.AbstractScrollableResults (implements org.hibernate.ScrollableResults)
      • class org.hibernate.impl.FetchingScrollableResultsImpl
      • class org.hibernate.impl.ScrollableResultsImpl (implements org.hibernate.ScrollableResults)
    • class org.hibernate.impl.AbstractSessionImpl (implements org.hibernate.engine.SessionImplementor)
      • class org.hibernate.impl.SessionImpl (implements org.hibernate.event.EventSource, org.hibernate.jdbc.JDBCContext.Context, org.hibernate.classic.Session)
      • class org.hibernate.impl.StatelessSessionImpl (implements org.hibernate.jdbc.JDBCContext.Context, org.hibernate.StatelessSession)
    • class org.hibernate.impl.CriteriaImpl (implements org.hibernate.Criteria, java.io.Serializable)
    • class org.hibernate.impl.CriteriaImpl.CriterionEntry (implements java.io.Serializable)
    • class org.hibernate.impl.CriteriaImpl.OrderEntry (implements java.io.Serializable)
    • class org.hibernate.impl.CriteriaImpl.Subcriteria (implements org.hibernate.Criteria, java.io.Serializable)
    • class org.hibernate.impl.FilterImpl (implements org.hibernate.Filter, java.io.Serializable)
    • class org.hibernate.impl.IteratorImpl (implements org.hibernate.engine.HibernateIterator)
    • class org.hibernate.impl.SessionFactoryImpl (implements org.hibernate.SessionFactory, org.hibernate.engine.SessionFactoryImplementor)
    • class org.hibernate.impl.SessionFactoryObjectFactory (implements javax.naming.spi.ObjectFactory)


Uses of Package org.hibernate.impl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.impl

Packages that use org.hibernate.impl
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader

Classes in org.hibernate.impl used by org.hibernate.criterion
CriteriaImpl
Implementation of the Criteria interface

Classes in org.hibernate.impl used by org.hibernate.engine
CriteriaImpl
Implementation of the Criteria interface

Classes in org.hibernate.impl used by org.hibernate.impl
AbstractQueryImpl
Abstract implementation of the Query interface.
AbstractScrollableResults
Implementation of the ScrollableResults interface
AbstractSessionImpl
Functionality common to stateless and stateful sessions
CriteriaImpl
Implementation of the Criteria interface
QueryImpl
default implementation of the Query interface, for "ordinary" HQL queries (not collection filters)
SessionFactoryImpl
Concrete implementation of the SessionFactory interface.

Classes in org.hibernate.impl used by org.hibernate.loader.criteria
CriteriaImpl
Implementation of the Criteria interface

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractQueryImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class AbstractQueryImpl

java.lang.Object
    extended by org.hibernate.impl.AbstractQueryImpl
All Implemented Interfaces:
Query
Direct Known Subclasses:
QueryImpl, SQLQueryImpl
public abstract class AbstractQueryImpl
extends Object
implements Query

Abstract implementation of the Query interface.

Author:
Gavin King, Max Andersen

Field Summary
protected ParameterMetadata | parameterMetadata
protected SessionImplementor | session
Constructor Summary
AbstractQueryImpl(String queryString, FlushMode flushMode, SessionImplementor session, ParameterMetadata parameterMetadata)
Method Summary
protected void | after()
protected void | before()
protected Type | determineType(int paramPosition, Object paramValue)
protected Type | determineType(int paramPosition, Object paramValue, Type defaultType)
protected Type | determineType(String paramName, Class clazz)
protected Type | determineType(String paramName, Object paramValue)
protected Type | determineType(String paramName, Object paramValue, Type defaultType)
protected String | expandParameterLists(Map namedParamsCopy) Warning: adds new parameters to the argument by side-effect, as well as mutating the query string!
protected abstract Map | getLockModes()
protected Map | getNamedParameterLists() Retreive the value map for any named parameter lists (i.e., for auto-expansion) bound to this query.
String[] | getNamedParameters() Returns an array representing all named parameter names encountered during (intial) parsing of the query.
protected Map | getNamedParams() Returns a shallow copy of the named parameter value map.
QueryParameters | getQueryParameters(Map namedParams)
String | getQueryString() Get the query string.
String[] | getReturnAliases() Return the HQL select clause aliases (if any)
Type[] | getReturnTypes() Return the Hibernate types of the query result set.
protected RowSelection | getRowSelection()
RowSelection | getSelection()
protected List | getTypes() Retreives the list of parameter types bound to this query for ordinal parameters.
protected List | getValues() Retreives the list of parameter values bound to this query for ordinal parameters.
boolean | hasNamedParameters() Does this query contain named parameters?
boolean | isReadOnly()
Query | setBigDecimal(int position, BigDecimal number)
Query | setBigDecimal(String name, BigDecimal number)
Query | setBigInteger(int position, BigInteger number)
Query | setBigInteger(String name, BigInteger number)
Query | setBinary(int position, byte[] val)
Query | setBinary(String name, byte[] val)
Query | setBoolean(int position, boolean val)
Query | setBoolean(String name, boolean val)
Query | setByte(int position, byte val)
Query | setByte(String name, byte val)
Query | setCacheable(boolean cacheable) Enable caching of this query result set.
Query | setCacheMode(CacheMode cacheMode) Override the current session cache mode, just for this query.
Query | setCacheRegion(String cacheRegion) Set the name of the cache region.
Query | setCalendar(int position, Calendar calendar)
Query | setCalendar(String name, Calendar calendar)
Query | setCalendarDate(int position, Calendar calendar)
Query | setCalendarDate(String name, Calendar calendar)
Query | setCharacter(int position, char val)
Query | setCharacter(String name, char val)
Query | setCollectionKey(Serializable collectionKey)
Query | setComment(String comment) Add a comment to the generated SQL.
Query | setDate(int position, Date date)
Query | setDate(String name, Date date)
Query | setDouble(int position, double val)
Query | setDouble(String name, double val)
Query | setEntity(int position, Object val) Bind an instance of a mapped persistent class to a JDBC-style query parameter.
Query | setEntity(String name, Object val) Bind an instance of a mapped persistent class to a named query parameter.
Query | setFetchSize(int fetchSize) Set a fetch size for the underlying JDBC query.
Query | setFirstResult(int firstResult) Set the first row to retrieve.
Query | setFloat(int position, float val)
Query | setFloat(String name, float val)
Query | setFlushMode(FlushMode flushMode) Override the current session flush mode, just for this query.
Query | setInteger(int position, int val)
Query | setInteger(String name, int val)
Query | setLocale(int position, Locale locale)
Query | setLocale(String name, Locale locale)
Query | setLong(int position, long val)
Query | setLong(String name, long val)
Query | setMaxResults(int maxResults) Set the maximum number of rows to retrieve.
void | setOptionalEntityName(String optionalEntityName)
void | setOptionalId(Serializable optionalId)
void | setOptionalObject(Object optionalObject)
Query | setParameter(int position, Object val) Bind a value to a JDBC-style query parameter, guessing the Hibernate type from the class of the given object.
Query | setParameter(int position, Object val, Type type) Bind a value to a JDBC-style query parameter.
Query | setParameter(String name, Object val) Bind a value to a named query parameter, guessing the Hibernate type from the class of the given object.
Query | setParameter(String name, Object val, Type type) Bind a value to a named query parameter.
Query | setParameterList(String name, Collection vals) Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the collection.
Query | setParameterList(String name, Collection vals, Type type) Bind multiple values to a named query parameter.
Query | setParameterList(String name, Object[] vals) Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the array.
Query | setParameterList(String name, Object[] vals, Type type) Bind multiple values to a named query parameter.
Query | setParameters(Object[] values, Type[] types) Bind values and types to positional parameters.
Query | setProperties(Object bean) Bind the property values of the given bean to named parameters of the query, matching property names with parameter names and mapping property types to Hibernate types using hueristics.
Query | setReadOnly(boolean readOnly) Entities retrieved by this query will be loaded in a read-only mode where Hibernate will never dirty-check them or make changes persistent.
Query | setResultTransformer(ResultTransformer transformer) Set a strategy for handling the query results.
Query | setSerializable(int position, Serializable val)
Query | setSerializable(String name, Serializable val)
Query | setShort(int position, short val)
Query | setShort(String name, short val)
Query | setString(int position, String val)
Query | setString(String name, String val)
Query | setText(int position, String val)
Query | setText(String name, String val)
Query | setTime(int position, Date date)
Query | setTime(String name, Date date)
Query | setTimeout(int timeout) Set a timeout for the underlying JDBC query.
Query | setTimestamp(int position, Date date)
Query | setTimestamp(String name, Date date)
String | toString()
Type[] | typeArray()
Object | uniqueResult() Convenience method to return a single instance that matches the query, or null if the query returns no results.
Object[] | valueArray()
protected void | verifyParameters() Perform parameter validation.
protected void | verifyParameters(boolean reserveFirstParameter) Perform parameter validation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.Query
executeUpdate, iterate, list, scroll, scroll, setLockMode

Field Detail

session

protected final SessionImplementor session

parameterMetadata

protected final ParameterMetadata parameterMetadata
Constructor Detail

AbstractQueryImpl

public AbstractQueryImpl(String queryString,
                         FlushMode flushMode,
                         SessionImplementor session,
                         ParameterMetadata parameterMetadata)
Method Detail

toString

public String toString()

getQueryString

public final String getQueryString()
Description copied from interface: Query
Get the query string.

Specified by:
getQueryString in interface Query
Returns:
the query string

getSelection

public RowSelection getSelection()

setFlushMode

public Query setFlushMode(FlushMode flushMode)
Description copied from interface: Query
Override the current session flush mode, just for this query.

Specified by:
setFlushMode in interface Query
See Also:
FlushMode

setCacheMode

public Query setCacheMode(CacheMode cacheMode)
Description copied from interface: Query
Override the current session cache mode, just for this query.

Specified by:
setCacheMode in interface Query
See Also:
CacheMode

setCacheable

public Query setCacheable(boolean cacheable)
Description copied from interface: Query
Enable caching of this query result set.

Specified by:
setCacheable in interface Query
Parameters:
cacheable - Should the query results be cacheable?

setCacheRegion

public Query setCacheRegion(String cacheRegion)
Description copied from interface: Query
Set the name of the cache region.

Specified by:
setCacheRegion in interface Query
Parameters:
cacheRegion - the name of a query cache region, or null for the default query cache

setComment

public Query setComment(String comment)
Description copied from interface: Query
Add a comment to the generated SQL.

Specified by:
setComment in interface Query
Parameters:
comment - a human-readable string

setFirstResult

public Query setFirstResult(int firstResult)
Description copied from interface: Query
Set the first row to retrieve. If not set, rows will be retrieved beginnning from row 0.

Specified by:
setFirstResult in interface Query
Parameters:
firstResult - a row number, numbered from 0

setMaxResults

public Query setMaxResults(int maxResults)
Description copied from interface: Query
Set the maximum number of rows to retrieve. If not set, there is no limit to the number of rows retrieved.

Specified by:
setMaxResults in interface Query
Parameters:
maxResults - the maximum number of rows

setTimeout

public Query setTimeout(int timeout)
Description copied from interface: Query
Set a timeout for the underlying JDBC query.

Specified by:
setTimeout in interface Query
Parameters:
timeout - the timeout in seconds

setFetchSize

public Query setFetchSize(int fetchSize)
Description copied from interface: Query
Set a fetch size for the underlying JDBC query.

Specified by:
setFetchSize in interface Query
Parameters:
fetchSize - the fetch size

getReturnTypes

public Type[] getReturnTypes()
                      throws HibernateException
Description copied from interface: Query
Return the Hibernate types of the query result set.

Specified by:
getReturnTypes in interface Query
Returns:
an array of types
Throws:
HibernateException

getReturnAliases

public String[] getReturnAliases()
                          throws HibernateException
Description copied from interface: Query
Return the HQL select clause aliases (if any)

Specified by:
getReturnAliases in interface Query
Returns:
an array of aliases as strings
Throws:
HibernateException

setCollectionKey

public Query setCollectionKey(Serializable collectionKey)

isReadOnly

public boolean isReadOnly()

setReadOnly

public Query setReadOnly(boolean readOnly)
Description copied from interface: Query
Entities retrieved by this query will be loaded in a read-only mode where Hibernate will never dirty-check them or make changes persistent.

Specified by:
setReadOnly in interface Query

setResultTransformer

public Query setResultTransformer(ResultTransformer transformer)
Description copied from interface: Query
Set a strategy for handling the query results. This can be used to change "shape" of the query result.

Specified by:
setResultTransformer in interface Query
Parameters:
transformer - The transformer to apply
Returns:
this (for method chaining)

setOptionalEntityName

public void setOptionalEntityName(String optionalEntityName)

setOptionalId

public void setOptionalId(Serializable optionalId)

setOptionalObject

public void setOptionalObject(Object optionalObject)

getLockModes

protected abstract Map getLockModes()

getNamedParams

protected Map getNamedParams()
Returns a shallow copy of the named parameter value map.

Returns:
Shallow copy of the named parameter value map

getNamedParameters

public String[] getNamedParameters()
                            throws HibernateException
Returns an array representing all named parameter names encountered during (intial) parsing of the query.

Note initial here means different things depending on whether this is a native-sql query or an HQL/filter query. For native-sql, a precursory inspection of the query string is performed specifically to locate defined parameters. For HQL/filter queries, this is the information returned from the query-translator. This distinction holds true for all parameter metadata exposed here.

Specified by:
getNamedParameters in interface Query
Returns:
Array of named parameter names.
Throws:
HibernateException

hasNamedParameters

public boolean hasNamedParameters()
Does this query contain named parameters?

Returns:
True if the query was found to contain named parameters; false otherwise;

getNamedParameterLists

protected Map getNamedParameterLists()
Retreive the value map for any named parameter lists (i.e., for auto-expansion) bound to this query.

Returns:
The parameter list value map.

getValues

protected List getValues()
Retreives the list of parameter values bound to this query for ordinal parameters.

Returns:
The ordinal parameter values.

getTypes

protected List getTypes()
Retreives the list of parameter types bound to this query for ordinal parameters.

Returns:
The ordinal parameter types.

verifyParameters

protected void verifyParameters()
                         throws QueryException
Perform parameter validation. Used prior to executing the encapsulated query.

Throws:
QueryException

verifyParameters

protected void verifyParameters(boolean reserveFirstParameter)
                         throws HibernateException
Perform parameter validation. Used prior to executing the encapsulated query.

Parameters:
reserveFirstParameter - if true, the first ? will not be verified since its needed for e.g. callable statements returning a out parameter
Throws:
HibernateException

setParameter

public Query setParameter(int position,
                          Object val,
                          Type type)
Description copied from interface: Query
Bind a value to a JDBC-style query parameter.

Specified by:
setParameter in interface Query
Parameters:
position - the position of the parameter in the query string, numbered from 0.
val - the possibly-null parameter value
type - the Hibernate type

setParameter

public Query setParameter(String name,
                          Object val,
                          Type type)
Description copied from interface: Query
Bind a value to a named query parameter.

Specified by:
setParameter in interface Query
Parameters:
name - the name of the parameter
val - the possibly-null parameter value
type - the Hibernate type

setParameter

public Query setParameter(int position,
                          Object val)
                   throws HibernateException
Description copied from interface: Query
Bind a value to a JDBC-style query parameter, guessing the Hibernate type from the class of the given object.

Specified by:
setParameter in interface Query
Parameters:
position - the position of the parameter in the query string, numbered from 0.
val - the non-null parameter value
Throws:
HibernateException - if no type could be determined

setParameter

public Query setParameter(String name,
                          Object val)
                   throws HibernateException
Description copied from interface: Query
Bind a value to a named query parameter, guessing the Hibernate type from the class of the given object.

Specified by:
setParameter in interface Query
Parameters:
name - the name of the parameter
val - the non-null parameter value
Throws:
HibernateException - if no type could be determined

determineType

protected Type determineType(int paramPosition,
                             Object paramValue,
                             Type defaultType)

determineType

protected Type determineType(int paramPosition,
                             Object paramValue)
                      throws HibernateException
Throws:
HibernateException

determineType

protected Type determineType(String paramName,
                             Object paramValue,
                             Type defaultType)

determineType

protected Type determineType(String paramName,
                             Object paramValue)
                      throws HibernateException
Throws:
HibernateException

determineType

protected Type determineType(String paramName,
                             Class clazz)
                      throws HibernateException
Throws:
HibernateException

setString

public Query setString(int position,
                       String val)
Specified by:
setString in interface Query

setCharacter

public Query setCharacter(int position,
                          char val)
Specified by:
setCharacter in interface Query

setBoolean

public Query setBoolean(int position,
                        boolean val)
Specified by:
setBoolean in interface Query

setByte

public Query setByte(int position,
                     byte val)
Specified by:
setByte in interface Query

setShort

public Query setShort(int position,
                      short val)
Specified by:
setShort in interface Query

setInteger

public Query setInteger(int position,
                        int val)
Specified by:
setInteger in interface Query

setLong

public Query setLong(int position,
                     long val)
Specified by:
setLong in interface Query

setFloat

public Query setFloat(int position,
                      float val)
Specified by:
setFloat in interface Query

setDouble

public Query setDouble(int position,
                       double val)
Specified by:
setDouble in interface Query

setBinary

public Query setBinary(int position,
                       byte[] val)
Specified by:
setBinary in interface Query

setText

public Query setText(int position,
                     String val)
Specified by:
setText in interface Query

setSerializable

public Query setSerializable(int position,
                             Serializable val)
Specified by:
setSerializable in interface Query

setDate

public Query setDate(int position,
                     Date date)
Specified by:
setDate in interface Query

setTime

public Query setTime(int position,
                     Date date)
Specified by:
setTime in interface Query

setTimestamp

public Query setTimestamp(int position,
                          Date date)
Specified by:
setTimestamp in interface Query

setEntity

public Query setEntity(int position,
                       Object val)
Description copied from interface: Query
Bind an instance of a mapped persistent class to a JDBC-style query parameter.

Specified by:
setEntity in interface Query
Parameters:
position - the position of the parameter in the query string, numbered from 0.
val - a non-null instance of a persistent class

setLocale

public Query setLocale(int position,
                       Locale locale)
Specified by:
setLocale in interface Query

setCalendar

public Query setCalendar(int position,
                         Calendar calendar)
Specified by:
setCalendar in interface Query

setCalendarDate

public Query setCalendarDate(int position,
                             Calendar calendar)
Specified by:
setCalendarDate in interface Query

setBinary

public Query setBinary(String name,
                       byte[] val)
Specified by:
setBinary in interface Query

setText

public Query setText(String name,
                     String val)
Specified by:
setText in interface Query

setBoolean

public Query setBoolean(String name,
                        boolean val)
Specified by:
setBoolean in interface Query

setByte

public Query setByte(String name,
                     byte val)
Specified by:
setByte in interface Query

setCharacter

public Query setCharacter(String name,
                          char val)
Specified by:
setCharacter in interface Query

setDate

public Query setDate(String name,
                     Date date)
Specified by:
setDate in interface Query

setDouble

public Query setDouble(String name,
                       double val)
Specified by:
setDouble in interface Query

setEntity

public Query setEntity(String name,
                       Object val)
Description copied from interface: Query
Bind an instance of a mapped persistent class to a named query parameter.

Specified by:
setEntity in interface Query
Parameters:
name - the name of the parameter
val - a non-null instance of a persistent class

setFloat

public Query setFloat(String name,
                      float val)
Specified by:
setFloat in interface Query

setInteger

public Query setInteger(String name,
                        int val)
Specified by:
setInteger in interface Query

setLocale

public Query setLocale(String name,
                       Locale locale)
Specified by:
setLocale in interface Query

setCalendar

public Query setCalendar(String name,
                         Calendar calendar)
Specified by:
setCalendar in interface Query

setCalendarDate

public Query setCalendarDate(String name,
                             Calendar calendar)
Specified by:
setCalendarDate in interface Query

setLong

public Query setLong(String name,
                     long val)
Specified by:
setLong in interface Query

setSerializable

public Query setSerializable(String name,
                             Serializable val)
Specified by:
setSerializable in interface Query

setShort

public Query setShort(String name,
                      short val)
Specified by:
setShort in interface Query

setString

public Query setString(String name,
                       String val)
Specified by:
setString in interface Query

setTime

public Query setTime(String name,
                     Date date)
Specified by:
setTime in interface Query

setTimestamp

public Query setTimestamp(String name,
                          Date date)
Specified by:
setTimestamp in interface Query

setBigDecimal

public Query setBigDecimal(int position,
                           BigDecimal number)
Specified by:
setBigDecimal in interface Query

setBigDecimal

public Query setBigDecimal(String name,
                           BigDecimal number)
Specified by:
setBigDecimal in interface Query

setBigInteger

public Query setBigInteger(int position,
                           BigInteger number)
Specified by:
setBigInteger in interface Query

setBigInteger

public Query setBigInteger(String name,
                           BigInteger number)
Specified by:
setBigInteger in interface Query

setParameterList

public Query setParameterList(String name,
                              Collection vals,
                              Type type)
                       throws HibernateException
Description copied from interface: Query
Bind multiple values to a named query parameter. This is useful for binding a list of values to an expression such as foo.bar in (:value_list).

Specified by:
setParameterList in interface Query
Parameters:
name - the name of the parameter
vals - a collection of values to list
type - the Hibernate type of the values
Throws:
HibernateException

expandParameterLists

protected String expandParameterLists(Map namedParamsCopy)
Warning: adds new parameters to the argument by side-effect, as well as mutating the query string!

setParameterList

public Query setParameterList(String name,
                              Collection vals)
                       throws HibernateException
Description copied from interface: Query
Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the collection. This is useful for binding a list of values to an expression such as foo.bar in (:value_list).

Specified by:
setParameterList in interface Query
Parameters:
name - the name of the parameter
vals - a collection of values to list
Throws:
HibernateException

setParameterList

public Query setParameterList(String name,
                              Object[] vals,
                              Type type)
                       throws HibernateException
Description copied from interface: Query
Bind multiple values to a named query parameter. This is useful for binding a list of values to an expression such as foo.bar in (:value_list).

Specified by:
setParameterList in interface Query
Parameters:
name - the name of the parameter
vals - a collection of values to list
type - the Hibernate type of the values
Throws:
HibernateException

setParameterList

public Query setParameterList(String name,
                              Object[] vals)
                       throws HibernateException
Description copied from interface: Query
Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the array. This is useful for binding a list of values to an expression such as foo.bar in (:value_list).

Specified by:
setParameterList in interface Query
Parameters:
name - the name of the parameter
vals - a collection of values to list
Throws:
HibernateException

setProperties

public Query setProperties(Object bean)
                    throws HibernateException
Description copied from interface: Query
Bind the property values of the given bean to named parameters of the query, matching property names with parameter names and mapping property types to Hibernate types using hueristics.

Specified by:
setProperties in interface Query
Parameters:
bean - any JavaBean or POJO
Throws:
HibernateException

setParameters

public Query setParameters(Object[] values,
                           Type[] types)
Description copied from interface: Query
Bind values and types to positional parameters.

Specified by:
setParameters in interface Query

uniqueResult

public Object uniqueResult()
                    throws HibernateException
Description copied from interface: Query
Convenience method to return a single instance that matches the query, or null if the query returns no results.

Specified by:
uniqueResult in interface Query
Returns:
the single result or null
Throws:
HibernateException

getRowSelection

protected RowSelection getRowSelection()

typeArray

public Type[] typeArray()

valueArray

public Object[] valueArray()

getQueryParameters

public QueryParameters getQueryParameters(Map namedParams)

before

protected void before()

after

protected void after()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractScrollableResults (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class AbstractScrollableResults

java.lang.Object
    extended by org.hibernate.impl.AbstractScrollableResults
All Implemented Interfaces:
ScrollableResults
Direct Known Subclasses:
FetchingScrollableResultsImpl, ScrollableResultsImpl
public abstract class AbstractScrollableResults
extends Object
implements ScrollableResults

Implementation of the ScrollableResults interface

Author:
Steve Ebersole

Constructor Summary
AbstractScrollableResults(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
Method Summary
protected void | afterScrollOperation()
void | close() Release resources immediately.
Object[] | get() Get the current row of results
Object | get(int col) Get the ith object in the current row of results, without initializing any other results in the row.
BigDecimal | getBigDecimal(int col) Convenience method to read a big_decimal
BigInteger | getBigInteger(int col) Convenience method to read a big_integer
byte[] | getBinary(int col) Convenience method to read a binary
Blob | getBlob(int col) Convenience method to read a blob
Boolean | getBoolean(int col) Convenience method to read a boolean
Byte | getByte(int col) Convenience method to read a byte
Calendar | getCalendar(int col) Convenience method to read a calendar or calendar_date
Character | getCharacter(int col) Convenience method to read a character
Clob | getClob(int col) Convenience method to read a clob
protected abstract Object[] | getCurrentRow()
Date | getDate(int col) Convenience method to read a date, time or timestamp
Double | getDouble(int col) Convenience method to read a double
protected Object | getFinal(int col, Type returnType) Check that the requested type is compatible with the result type, and return the column value.
Float | getFloat(int col) Convenience method to read a float
protected HolderInstantiator | getHolderInstantiator()
Integer | getInteger(int col) Convenience method to read an integer
protected Loader | getLoader()
Locale | getLocale(int col) Convenience method to read a locale
Long | getLong(int col) Convenience method to read a long
protected Object | getNonFinal(int col, Type returnType) Check that the requested type is compatible with the result type, and return the column value.
protected PreparedStatement | getPs()
protected QueryParameters | getQueryParameters()
protected ResultSet | getResultSet()
protected SessionImplementor | getSession()
Short | getShort(int col) Convenience method to read a short
String | getString(int col) Convenience method to read a string
String | getText(int col) Convenience method to read text
TimeZone | getTimeZone(int col) Convenience method to read a timezone
Type | getType(int i) Get the type of the ith column of results
protected Type[] | getTypes()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.ScrollableResults
afterLast, beforeFirst, first, getRowNumber, isFirst, isLast, last, next, previous, scroll, setRowNumber

Constructor Detail

AbstractScrollableResults

public AbstractScrollableResults(ResultSet rs,
                                 PreparedStatement ps,
                                 SessionImplementor sess,
                                 Loader loader,
                                 QueryParameters queryParameters,
                                 Type[] types,
                                 HolderInstantiator holderInstantiator)
                          throws MappingException
Method Detail

getCurrentRow

protected abstract Object[] getCurrentRow()

getResultSet

protected ResultSet getResultSet()

getPs

protected PreparedStatement getPs()

getSession

protected SessionImplementor getSession()

getLoader

protected Loader getLoader()

getQueryParameters

protected QueryParameters getQueryParameters()

getTypes

protected Type[] getTypes()

getHolderInstantiator

protected HolderInstantiator getHolderInstantiator()

close

public final void close()
                 throws HibernateException
Description copied from interface: ScrollableResults
Release resources immediately.

Specified by:
close in interface ScrollableResults
Throws:
HibernateException

get

public final Object[] get()
                   throws HibernateException
Description copied from interface: ScrollableResults
Get the current row of results

Specified by:
get in interface ScrollableResults
Returns:
an object or array
Throws:
HibernateException

get

public final Object get(int col)
                 throws HibernateException
Description copied from interface: ScrollableResults
Get the ith object in the current row of results, without initializing any other results in the row. This method may be used safely, regardless of the type of the column (ie. even for scalar results).

Specified by:
get in interface ScrollableResults
Parameters:
col - the column, numbered from zero
Returns:
an object of any Hibernate type or null
Throws:
HibernateException

getFinal

protected final Object getFinal(int col,
                                Type returnType)
                         throws HibernateException
Check that the requested type is compatible with the result type, and return the column value. This version makes sure the the classes are identical.

Parameters:
col - the column
returnType - a "final" type
Throws:
HibernateException

getNonFinal

protected final Object getNonFinal(int col,
                                   Type returnType)
                            throws HibernateException
Check that the requested type is compatible with the result type, and return the column value. This version makes sure the the classes are "assignable".

Parameters:
col - the column
returnType - any type
Throws:
HibernateException

getBigDecimal

public final BigDecimal getBigDecimal(int col)
                               throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a big_decimal

Specified by:
getBigDecimal in interface ScrollableResults
Throws:
HibernateException

getBigInteger

public final BigInteger getBigInteger(int col)
                               throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a big_integer

Specified by:
getBigInteger in interface ScrollableResults
Throws:
HibernateException

getBinary

public final byte[] getBinary(int col)
                       throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a binary

Specified by:
getBinary in interface ScrollableResults
Throws:
HibernateException

getText

public final String getText(int col)
                     throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read text

Specified by:
getText in interface ScrollableResults
Throws:
HibernateException

getBlob

public final Blob getBlob(int col)
                   throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a blob

Specified by:
getBlob in interface ScrollableResults
Throws:
HibernateException

getClob

public final Clob getClob(int col)
                   throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a clob

Specified by:
getClob in interface ScrollableResults
Throws:
HibernateException

getBoolean

public final Boolean getBoolean(int col)
                         throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a boolean

Specified by:
getBoolean in interface ScrollableResults
Throws:
HibernateException

getByte

public final Byte getByte(int col)
                   throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a byte

Specified by:
getByte in interface ScrollableResults
Throws:
HibernateException

getCharacter

public final Character getCharacter(int col)
                             throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a character

Specified by:
getCharacter in interface ScrollableResults
Throws:
HibernateException

getDate

public final Date getDate(int col)
                   throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a date, time or timestamp

Specified by:
getDate in interface ScrollableResults
Throws:
HibernateException

getCalendar

public final Calendar getCalendar(int col)
                           throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a calendar or calendar_date

Specified by:
getCalendar in interface ScrollableResults
Throws:
HibernateException

getDouble

public final Double getDouble(int col)
                       throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a double

Specified by:
getDouble in interface ScrollableResults
Throws:
HibernateException

getFloat

public final Float getFloat(int col)
                     throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a float

Specified by:
getFloat in interface ScrollableResults
Throws:
HibernateException

getInteger

public final Integer getInteger(int col)
                         throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read an integer

Specified by:
getInteger in interface ScrollableResults
Throws:
HibernateException

getLong

public final Long getLong(int col)
                   throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a long

Specified by:
getLong in interface ScrollableResults
Throws:
HibernateException

getShort

public final Short getShort(int col)
                     throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a short

Specified by:
getShort in interface ScrollableResults
Throws:
HibernateException

getString

public final String getString(int col)
                       throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a string

Specified by:
getString in interface ScrollableResults
Throws:
HibernateException

getLocale

public final Locale getLocale(int col)
                       throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a locale

Specified by:
getLocale in interface ScrollableResults
Throws:
HibernateException

getTimeZone

public final TimeZone getTimeZone(int col)
                           throws HibernateException
Description copied from interface: ScrollableResults
Convenience method to read a timezone

Specified by:
getTimeZone in interface ScrollableResults
Throws:
HibernateException

getType

public final Type getType(int i)
Description copied from interface: ScrollableResults
Get the type of the ith column of results

Specified by:
getType in interface ScrollableResults
Parameters:
i - the column, numbered from zero
Returns:
the Hibernate type

afterScrollOperation

protected void afterScrollOperation()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractSessionImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class AbstractSessionImpl

java.lang.Object
    extended by org.hibernate.impl.AbstractSessionImpl
All Implemented Interfaces:
Serializable, SessionImplementor
Direct Known Subclasses:
SessionImpl, StatelessSessionImpl
public abstract class AbstractSessionImpl
extends Object
implements SessionImplementor

Functionality common to stateless and stateful sessions

Author:
Gavin King
See Also:
Serialized Form

Field Summary
protected  SessionFactoryImpl factory
Constructor Summary
protected AbstractSessionImpl(SessionFactoryImpl factory)
Method Summary
Query | createQuery(String queryString)
SQLQuery | createSQLQuery(String sql)
protected void | errorIfClosed()
SessionFactoryImplementor | getFactory() Get the creating SessionFactoryImplementor
protected HQLQueryPlan | getHQLQueryPlan(String query, boolean shallow)
Query | getNamedQuery(String queryName) Get a Query instance for a named query or named native SQL query
Query | getNamedSQLQuery(String queryName) Get a Query instance for a named native SQL query
protected NativeSQLQueryPlan | getNativeSQLQueryPlan(NativeSQLQuerySpecification spec)
boolean | isClosed() Determine whether the session is closed.
List | list(NativeSQLQuerySpecification spec, QueryParameters queryParameters) Execute a native SQL query, and return the results as a fully built list.
ScrollableResults | scroll(NativeSQLQuerySpecification spec, QueryParameters queryParameters) Execute a native SQL query, and return the results as a scrollable result.
protected void | setClosed()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.engine.SessionImplementor
afterScrollOperation, afterTransactionCompletion, beforeTransactionCompletion, bestGuessEntityName, connection, executeNativeUpdate, executeUpdate, flush, getBatcher, getCacheMode, getContextEntityIdentifier, getDontFlushFromFind, getEnabledFilters, getEntityMode, getEntityPersister, getEntityUsingInterceptor, getFetchProfile, getFilterParameterType, getFilterParameterValue, getFlushMode, getInterceptor, getJDBCContext, getListeners, getPersistenceContext, getTimestamp, guessEntityName, immediateLoad, initializeCollection, instantiate, internalLoad, isConnected, isEventSource, isOpen, isTransactionInProgress, iterate, iterateFilter, list, list, listCustomQuery, listFilter, scroll, scroll, scrollCustomQuery, setAutoClear, setCacheMode, setFetchProfile, setFlushMode

Field Detail

factory

protected transient SessionFactoryImpl factory
Constructor Detail

AbstractSessionImpl

protected AbstractSessionImpl(SessionFactoryImpl factory)
Method Detail

getFactory

public SessionFactoryImplementor getFactory()
Description copied from interface: SessionImplementor
Get the creating SessionFactoryImplementor

Specified by:
getFactory in interface SessionImplementor

isClosed

public boolean isClosed()
Description copied from interface: SessionImplementor
Determine whether the session is closed. Provided seperately from SessionImplementor.isOpen() as this method does not attempt any JTA synch registration, where as SessionImplementor.isOpen() does; which makes this one nicer to use for most internal purposes.

Specified by:
isClosed in interface SessionImplementor
Returns:
True if the session is closed; false otherwise.

setClosed

protected void setClosed()

errorIfClosed

protected void errorIfClosed()

getNamedQuery

public Query getNamedQuery(String queryName)
                    throws MappingException
Description copied from interface: SessionImplementor
Get a Query instance for a named query or named native SQL query

Specified by:
getNamedQuery in interface SessionImplementor
Throws:
MappingException

getNamedSQLQuery

public Query getNamedSQLQuery(String queryName)
                       throws MappingException
Description copied from interface: SessionImplementor
Get a Query instance for a named native SQL query

Specified by:
getNamedSQLQuery in interface SessionImplementor
Throws:
MappingException

createQuery

public Query createQuery(String queryString)

createSQLQuery

public SQLQuery createSQLQuery(String sql)

getHQLQueryPlan

protected HQLQueryPlan getHQLQueryPlan(String query,
                                       boolean shallow)
                                throws HibernateException
Throws:
HibernateException

getNativeSQLQueryPlan

protected NativeSQLQueryPlan getNativeSQLQueryPlan(NativeSQLQuerySpecification spec)
                                            throws HibernateException
Throws:
HibernateException

list

public List list(NativeSQLQuerySpecification spec,
                 QueryParameters queryParameters)
          throws HibernateException
Description copied from interface: SessionImplementor
Execute a native SQL query, and return the results as a fully built list.

Specified by:
list in interface SessionImplementor
Parameters:
spec - The specification of the native SQL query to execute.
queryParameters - The parameters by which to perform the execution.
Returns:
The result list.
Throws:
HibernateException

scroll

public ScrollableResults scroll(NativeSQLQuerySpecification spec,
                                QueryParameters queryParameters)
                         throws HibernateException
Description copied from interface: SessionImplementor
Execute a native SQL query, and return the results as a scrollable result.

Specified by:
scroll in interface SessionImplementor
Parameters:
spec - The specification of the native SQL query to execute.
queryParameters - The parameters by which to perform the execution.
Returns:
The resulting scrollable result.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionFilterImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class CollectionFilterImpl

java.lang.Object
    extended by org.hibernate.impl.AbstractQueryImpl
        extended by org.hibernate.impl.QueryImpl
            extended by org.hibernate.impl.CollectionFilterImpl
All Implemented Interfaces:
Query
public class CollectionFilterImpl
extends QueryImpl

implementation of the Query interface for collection filters

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.impl.AbstractQueryImpl
parameterMetadata, session
Constructor Summary
CollectionFilterImpl(String queryString, Object collection, SessionImplementor session, ParameterMetadata parameterMetadata)
Method Summary
Iterator | iterate() Return the query results as an Iterator.
List | list() Return the query results as a List.
ScrollableResults | scroll() Return the query results as ScrollableResults.
Type[] | typeArray()
Object[] | valueArray()
Methods inherited from class org.hibernate.impl.QueryImpl
executeUpdate, getLockModes, scroll, setLockMode
Methods inherited from class org.hibernate.impl.AbstractQueryImpl
after, before, determineType, determineType, determineType, determineType, determineType, expandParameterLists, getNamedParameterLists, getNamedParameters, getNamedParams, getQueryParameters, getQueryString, getReturnAliases, getReturnTypes, getRowSelection, getSelection, getTypes, getValues, hasNamedParameters, isReadOnly, setBigDecimal, setBigDecimal, setBigInteger, setBigInteger, setBinary, setBinary, setBoolean, setBoolean, setByte, setByte, setCacheable, setCacheMode, setCacheRegion, setCalendar, setCalendar, setCalendarDate, setCalendarDate, setCharacter, setCharacter, setCollectionKey, setComment, setDate, setDate, setDouble, setDouble, setEntity, setEntity, setFetchSize, setFirstResult, setFloat, setFloat, setFlushMode, setInteger, setInteger, setLocale, setLocale, setLong, setLong, setMaxResults, setOptionalEntityName, setOptionalId, setOptionalObject, setParameter, setParameter, setParameter, setParameter, setParameterList, setParameterList, setParameterList, setParameterList, setParameters, setProperties, setReadOnly, setResultTransformer, setSerializable, setSerializable, setShort, setShort, setString, setString, setText, setText, setTime, setTime, setTimeout, setTimestamp, setTimestamp, toString, uniqueResult, verifyParameters, verifyParameters
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CollectionFilterImpl

public CollectionFilterImpl(String queryString,
                            Object collection,
                            SessionImplementor session,
                            ParameterMetadata parameterMetadata)
Method Detail

iterate

public Iterator iterate()
                 throws HibernateException
Description copied from interface: Query
Return the query results as an Iterator. If the query contains multiple results pre row, the results are returned in an instance of Object[].

Entities returned as results are initialized on demand. The first SQL query returns identifiers only.

Specified by:
iterate in interface Query
Overrides:
iterate in class QueryImpl
Throws:
HibernateException
See Also:
Query.iterate()

list

public List list()
          throws HibernateException
Description copied from interface: Query
Return the query results as a List. If the query contains multiple results pre row, the results are returned in an instance of Object[].

Specified by:
list in interface Query
Overrides:
list in class QueryImpl
Throws:
HibernateException
See Also:
Query.list()

scroll

public ScrollableResults scroll()
                         throws HibernateException
Description copied from interface: Query
Return the query results as ScrollableResults. The scrollability of the returned results depends upon JDBC driver support for scrollable ResultSets.

Specified by:
scroll in interface Query
Overrides:
scroll in class QueryImpl
Throws:
HibernateException
See Also:
Query.scroll()

typeArray

public Type[] typeArray()
Overrides:
typeArray in class AbstractQueryImpl

valueArray

public Object[] valueArray()
Overrides:
valueArray in class AbstractQueryImpl
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CriteriaImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class CriteriaImpl

java.lang.Object
    extended by org.hibernate.impl.CriteriaImpl
All Implemented Interfaces:
Criteria, CriteriaSpecification, Serializable
public class CriteriaImpl
extends Object
implements Criteria, Serializable

Implementation of the Criteria interface

Author:
Gavin King
See Also:
Serialized Form

Nested Class Summary
static class | CriteriaImpl.CriterionEntry
static class | CriteriaImpl.OrderEntry
class | CriteriaImpl.Subcriteria
Field Summary
Fields inherited from interface org.hibernate.criterion.CriteriaSpecification
ALIAS_TO_ENTITY_MAP, DISTINCT_ROOT_ENTITY, FULL_JOIN, INNER_JOIN, LEFT_JOIN, PROJECTION, ROOT_ALIAS, ROOT_ENTITY
Constructor Summary
CriteriaImpl(String entityOrClassName, SessionImplementor session)
CriteriaImpl(String entityOrClassName, String alias, SessionImplementor session)
Method Summary
Criteria | add(Criteria criteriaInst, Criterion expression)
Criteria | add(Criterion expression) Add a restriction to constrain the results to be retrieved.
Criteria | addOrder(Order ordering) Add an ordering to the result set.
protected void | after()
protected void | before()
Criteria | createAlias(String associationPath, String alias) Join an association, assigning an alias to the joined association.
Criteria | createAlias(String associationPath, String alias, int joinType) Join an association using the specified join-type, assigning an alias to the joined association.
Criteria | createCriteria(String associationPath) Create a new Criteria, "rooted" at the associated entity.
Criteria | createCriteria(String associationPath, int joinType) Create a new Criteria, "rooted" at the associated entity, using the specified join type.
Criteria | createCriteria(String associationPath, String alias) Create a new Criteria, "rooted" at the associated entity, assigning the given alias.
Criteria | createCriteria(String associationPath, String alias, int joinType) Create a new Criteria, "rooted" at the associated entity, assigning the given alias and using the specified join type.
String | getAlias() Get the alias of the entity encapsulated by this criteria instance.
boolean | getCacheable()
String | getCacheRegion()
String | getComment()
String | getEntityOrClassName()
FetchMode | getFetchMode(String path)
Integer | getFetchSize()
Integer | getFirstResult()
Map | getLockModes()
Integer | getMaxResults()
Projection | getProjection()
Criteria | getProjectionCriteria()
ResultTransformer | getResultTransformer()
SessionImplementor | getSession()
Integer | getTimeout()
boolean | isLookupByNaturalKey()
Iterator | iterateExpressionEntries()
Iterator | iterateOrderings()
Iterator | iterateSubcriteria()
List | list() Get the results.
ScrollableResults | scroll() Get the results as an instance of ScrollableResults
ScrollableResults | scroll(ScrollMode scrollMode) Get the results as an instance of ScrollableResults based on the given scroll mode.
Criteria | setCacheable(boolean cacheable) Enable caching of this query result, provided query caching is enabled for the underlying session factory.
Criteria | setCacheMode(CacheMode cacheMode) Override the cache mode for this particular query.
Criteria | setCacheRegion(String cacheRegion) Set the name of the cache region to use for query result caching.
Criteria | setComment(String comment) Add a comment to the generated SQL.
Criteria | setFetchMode(String associationPath, FetchMode mode) Specify an association fetching strategy for an association or a collection of values.
Criteria | setFetchSize(int fetchSize) Set a fetch size for the underlying JDBC query.
Criteria | setFirstResult(int firstResult) Set the first result to be retrieved.
Criteria | setFlushMode(FlushMode flushMode) Override the flush mode for this particular query.
Criteria | setLockMode(LockMode lockMode) Set the lock mode of the current entity
Criteria | setLockMode(String alias, LockMode lockMode) Set the lock mode of the aliased entity
Criteria | setMaxResults(int maxResults) Set a limit upon the number of objects to be retrieved.
Criteria | setProjection(Projection projection) Used to specify that the query results will be a projection (scalar in nature).
Criteria | setResultTransformer(ResultTransformer tupleMapper) Set a strategy for handling the query results.
void | setSession(SessionImplementor session)
Criteria | setTimeout(int timeout) Set a timeout for the underlying JDBC query.
String | toString()
Object | uniqueResult() Convenience method to return a single instance that matches the query, or null if the query returns no results.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CriteriaImpl

public CriteriaImpl(String entityOrClassName,
                    SessionImplementor session)

CriteriaImpl

public CriteriaImpl(String entityOrClassName,
                    String alias,
                    SessionImplementor session)
Method Detail

toString

public String toString()

getSession

public SessionImplementor getSession()

setSession

public void setSession(SessionImplementor session)

getEntityOrClassName

public String getEntityOrClassName()

getLockModes

public Map getLockModes()

getProjectionCriteria

public Criteria getProjectionCriteria()

iterateSubcriteria

public Iterator iterateSubcriteria()

iterateExpressionEntries

public Iterator iterateExpressionEntries()

iterateOrderings

public Iterator iterateOrderings()

add

public Criteria add(Criteria criteriaInst,
                    Criterion expression)

getAlias

public String getAlias()
Description copied from interface: Criteria
Get the alias of the entity encapsulated by this criteria instance.

Specified by:
getAlias in interface Criteria
Returns:
The alias for the encapsulated entity.

getProjection

public Projection getProjection()

setProjection

public Criteria setProjection(Projection projection)
Description copied from interface: Criteria
Used to specify that the query results will be a projection (scalar in nature). Implicitly specifies the CriteriaSpecification.PROJECTION result transformer.

The individual components contained within the given projection determines the overall "shape" of the query result.

Specified by:
setProjection in interface Criteria
Parameters:
projection - The projection representing the overall "shape" of the query results.
Returns:
this (for method chaining)

add

public Criteria add(Criterion expression)
Description copied from interface: Criteria
Add a restriction to constrain the results to be retrieved.

Specified by:
add in interface Criteria
Parameters:
expression - The criterion object representing the restriction to be applied.
Returns:
this (for method chaining)

addOrder

public Criteria addOrder(Order ordering)
Description copied from interface: Criteria
Add an ordering to the result set.

Specified by:
addOrder in interface Criteria
Parameters:
ordering - The order object representing an ordering to be applied to the results.
Returns:
this (for method chaining)

getFetchMode

public FetchMode getFetchMode(String path)

setFetchMode

public Criteria setFetchMode(String associationPath,
                             FetchMode mode)
Description copied from interface: Criteria
Specify an association fetching strategy for an association or a collection of values.

Specified by:
setFetchMode in interface Criteria
Parameters:
associationPath - a dot seperated property path
mode - The fetch mode for the referenced association
Returns:
this (for method chaining)

setLockMode

public Criteria setLockMode(LockMode lockMode)
Description copied from interface: Criteria
Set the lock mode of the current entity

Specified by:
setLockMode in interface Criteria
Parameters:
lockMode - The lock mode to be applied
Returns:
this (for method chaining)

setLockMode

public Criteria setLockMode(String alias,
                            LockMode lockMode)
Description copied from interface: Criteria
Set the lock mode of the aliased entity

Specified by:
setLockMode in interface Criteria
Parameters:
alias - The previously assigned alias representing the entity to which the given lock mode should apply.
lockMode - The lock mode to be applied
Returns:
this (for method chaining)

createAlias

public Criteria createAlias(String associationPath,
                            String alias)
Description copied from interface: Criteria
Join an association, assigning an alias to the joined association.

Functionally equivalent to Criteria.createAlias(String, String, int) using CriteriaSpecification.INNER_JOIN for the joinType.

Specified by:
createAlias in interface Criteria
Parameters:
associationPath - A dot-seperated property path
alias - The alias to assign to the joined association (for later reference).
Returns:
this (for method chaining)

createAlias

public Criteria createAlias(String associationPath,
                            String alias,
                            int joinType)
Description copied from interface: Criteria
Join an association using the specified join-type, assigning an alias to the joined association.

The joinType is expected to be one of CriteriaSpecification.INNER_JOIN (the default), CriteriaSpecification.FULL_JOIN, or CriteriaSpecification.LEFT_JOIN.

Specified by:
createAlias in interface Criteria
Parameters:
associationPath - A dot-seperated property path
alias - The alias to assign to the joined association (for later reference).
joinType - The type of join to use.
Returns:
this (for method chaining)

createCriteria

public Criteria createCriteria(String associationPath)
Description copied from interface: Criteria
Create a new Criteria, "rooted" at the associated entity.

Functionally equivalent to Criteria.createCriteria(String, int) using CriteriaSpecification.INNER_JOIN for the joinType.

Specified by:
createCriteria in interface Criteria
Parameters:
associationPath - A dot-seperated property path
Returns:
the created "sub criteria"

createCriteria

public Criteria createCriteria(String associationPath,
                               int joinType)
Description copied from interface: Criteria
Create a new Criteria, "rooted" at the associated entity, using the specified join type.

Specified by:
createCriteria in interface Criteria
Parameters:
associationPath - A dot-seperated property path
joinType - The type of join to use.
Returns:
the created "sub criteria"

createCriteria

public Criteria createCriteria(String associationPath,
                               String alias)
Description copied from interface: Criteria
Create a new Criteria, "rooted" at the associated entity, assigning the given alias.

Functionally equivalent to Criteria.createCriteria(String, String, int) using CriteriaSpecification.INNER_JOIN for the joinType.

Specified by:
createCriteria in interface Criteria
Parameters:
associationPath - A dot-seperated property path
alias - The alias to assign to the joined association (for later reference).
Returns:
the created "sub criteria"

createCriteria

public Criteria createCriteria(String associationPath,
                               String alias,
                               int joinType)
Description copied from interface: Criteria
Create a new Criteria, "rooted" at the associated entity, assigning the given alias and using the specified join type.

Specified by:
createCriteria in interface Criteria
Parameters:
associationPath - A dot-seperated property path
alias - The alias to assign to the joined association (for later reference).
joinType - The type of join to use.
Returns:
the created "sub criteria"

getResultTransformer

public ResultTransformer getResultTransformer()

setResultTransformer

public Criteria setResultTransformer(ResultTransformer tupleMapper)
Description copied from interface: Criteria
Set a strategy for handling the query results. This determines the "shape" of the query result.

Specified by:
setResultTransformer in interface Criteria
Parameters:
tupleMapper - The transformer to apply
Returns:
this (for method chaining)
See Also:
CriteriaSpecification.ROOT_ENTITY, CriteriaSpecification.DISTINCT_ROOT_ENTITY, CriteriaSpecification.ALIAS_TO_ENTITY_MAP, CriteriaSpecification.PROJECTION

getMaxResults

public Integer getMaxResults()

setMaxResults

public Criteria setMaxResults(int maxResults)
Description copied from interface: Criteria
Set a limit upon the number of objects to be retrieved.

Specified by:
setMaxResults in interface Criteria
Parameters:
maxResults - the maximum number of results
Returns:
this (for method chaining)

getFirstResult

public Integer getFirstResult()

setFirstResult

public Criteria setFirstResult(int firstResult)
Description copied from interface: Criteria
Set the first result to be retrieved.

Specified by:
setFirstResult in interface Criteria
Parameters:
firstResult - the first result to retrieve, numbered from 0
Returns:
this (for method chaining)

getFetchSize

public Integer getFetchSize()

setFetchSize

public Criteria setFetchSize(int fetchSize)
Description copied from interface: Criteria
Set a fetch size for the underlying JDBC query.

Specified by:
setFetchSize in interface Criteria
Parameters:
fetchSize - the fetch size
Returns:
this (for method chaining)
See Also:
Statement.setFetchSize(int)

getTimeout

public Integer getTimeout()

setTimeout

public Criteria setTimeout(int timeout)
Description copied from interface: Criteria
Set a timeout for the underlying JDBC query.

Specified by:
setTimeout in interface Criteria
Parameters:
timeout - The timeout value to apply.
Returns:
this (for method chaining)
See Also:
Statement.setQueryTimeout(int)

getCacheable

public boolean getCacheable()

setCacheable

public Criteria setCacheable(boolean cacheable)
Description copied from interface: Criteria
Enable caching of this query result, provided query caching is enabled for the underlying session factory.

Specified by:
setCacheable in interface Criteria
Parameters:
cacheable - Should the result be considered cacheable; default is to not cache (false).
Returns:
this (for method chaining)

getCacheRegion

public String getCacheRegion()

setCacheRegion

public Criteria setCacheRegion(String cacheRegion)
Description copied from interface: Criteria
Set the name of the cache region to use for query result caching.

Specified by:
setCacheRegion in interface Criteria
Parameters:
cacheRegion - the name of a query cache region, or null for the default query cache
Returns:
this (for method chaining)
See Also:
Criteria.setCacheable(boolean)

getComment

public String getComment()

setComment

public Criteria setComment(String comment)
Description copied from interface: Criteria
Add a comment to the generated SQL.

Specified by:
setComment in interface Criteria
Parameters:
comment - a human-readable string
Returns:
this (for method chaining)

setFlushMode

public Criteria setFlushMode(FlushMode flushMode)
Description copied from interface: Criteria
Override the flush mode for this particular query.

Specified by:
setFlushMode in interface Criteria
Parameters:
flushMode - The flush mode to use.
Returns:
this (for method chaining)

setCacheMode

public Criteria setCacheMode(CacheMode cacheMode)
Description copied from interface: Criteria
Override the cache mode for this particular query.

Specified by:
setCacheMode in interface Criteria
Parameters:
cacheMode - The cache mode to use.
Returns:
this (for method chaining)

list

public List list()
          throws HibernateException
Description copied from interface: Criteria
Get the results.

Specified by:
list in interface Criteria
Returns:
The list of matched query results.
Throws:
HibernateException

scroll

public ScrollableResults scroll()
Description copied from interface: Criteria
Get the results as an instance of ScrollableResults

Specified by:
scroll in interface Criteria
Returns:
The ScrollableResults representing the matched query results.

scroll

public ScrollableResults scroll(ScrollMode scrollMode)
Description copied from interface: Criteria
Get the results as an instance of ScrollableResults based on the given scroll mode.

Specified by:
scroll in interface Criteria
Parameters:
scrollMode - Indicates the type of underlying database cursor to request.
Returns:
The ScrollableResults representing the matched query results.

uniqueResult

public Object uniqueResult()
                    throws HibernateException
Description copied from interface: Criteria
Convenience method to return a single instance that matches the query, or null if the query returns no results.

Specified by:
uniqueResult in interface Criteria
Returns:
the single result or null
Throws:
HibernateException - if there is more than one matching result

before

protected void before()

after

protected void after()

isLookupByNaturalKey

public boolean isLookupByNaturalKey()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CriteriaImpl.CriterionEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class CriteriaImpl.CriterionEntry

java.lang.Object
    extended by org.hibernate.impl.CriteriaImpl.CriterionEntry
All Implemented Interfaces:
Serializable
Enclosing class:
CriteriaImpl
public static final class CriteriaImpl.CriterionEntry
extends Object
implements Serializable

See Also:
Serialized Form

Method Summary
Criteria | getCriteria()
Criterion | getCriterion()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getCriterion

public Criterion getCriterion()

getCriteria

public Criteria getCriteria()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CriteriaImpl.OrderEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class CriteriaImpl.OrderEntry

java.lang.Object
    extended by org.hibernate.impl.CriteriaImpl.OrderEntry
All Implemented Interfaces:
Serializable
Enclosing class:
CriteriaImpl
public static final class CriteriaImpl.OrderEntry
extends Object
implements Serializable

See Also:
Serialized Form

Method Summary
Criteria | getCriteria()
Order | getOrder()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getOrder

public Order getOrder()

getCriteria

public Criteria getCriteria()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CriteriaImpl.Subcriteria (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class CriteriaImpl.Subcriteria

java.lang.Object
    extended by org.hibernate.impl.CriteriaImpl.Subcriteria
All Implemented Interfaces:
Criteria, CriteriaSpecification, Serializable
Enclosing class:
CriteriaImpl
public final class CriteriaImpl.Subcriteria
extends Object
implements Criteria, Serializable

See Also:
Serialized Form

Field Summary
Fields inherited from interface org.hibernate.criterion.CriteriaSpecification
ALIAS_TO_ENTITY_MAP, DISTINCT_ROOT_ENTITY, FULL_JOIN, INNER_JOIN, LEFT_JOIN, PROJECTION, ROOT_ALIAS, ROOT_ENTITY
Method Summary
Criteria | add(Criterion expression) Add a restriction to constrain the results to be retrieved.
Criteria | addOrder(Order order) Add an ordering to the result set.
Criteria | createAlias(String associationPath, String alias) Join an association, assigning an alias to the joined association.
Criteria | createAlias(String associationPath, String alias, int joinType) Join an association using the specified join-type, assigning an alias to the joined association.
Criteria | createCriteria(String associationPath) Create a new Criteria, "rooted" at the associated entity.
Criteria | createCriteria(String associationPath, int joinType) Create a new Criteria, "rooted" at the associated entity, using the specified join type.
Criteria | createCriteria(String associationPath, String alias) Create a new Criteria, "rooted" at the associated entity, assigning the given alias.
Criteria | createCriteria(String associationPath, String alias, int joinType) Create a new Criteria, "rooted" at the associated entity, assigning the given alias and using the specified join type.
String | getAlias() Get the alias of the entity encapsulated by this criteria instance.
int | getJoinType()
LockMode | getLockMode()
Criteria | getParent()
String | getPath()
List | list() Get the results.
ScrollableResults | scroll() Get the results as an instance of ScrollableResults
ScrollableResults | scroll(ScrollMode scrollMode) Get the results as an instance of ScrollableResults based on the given scroll mode.
void | setAlias(String alias)
Criteria | setCacheable(boolean cacheable) Enable caching of this query result, provided query caching is enabled for the underlying session factory.
Criteria | setCacheMode(CacheMode cacheMode) Override the cache mode for this particular query.
Criteria | setCacheRegion(String cacheRegion) Set the name of the cache region to use for query result caching.
Criteria | setComment(String comment) Add a comment to the generated SQL.
Criteria | setFetchMode(String associationPath, FetchMode mode) Specify an association fetching strategy for an association or a collection of values.
Criteria | setFetchSize(int fetchSize) Set a fetch size for the underlying JDBC query.
Criteria | setFirstResult(int firstResult) Set the first result to be retrieved.
Criteria | setFlushMode(FlushMode flushMode) Override the flush mode for this particular query.
Criteria | setLockMode(LockMode lockMode) Set the lock mode of the current entity
Criteria | setLockMode(String alias, LockMode lockMode) Set the lock mode of the aliased entity
Criteria | setMaxResults(int maxResults) Set a limit upon the number of objects to be retrieved.
Criteria | setProjection(Projection projection) Used to specify that the query results will be a projection (scalar in nature).
Criteria | setResultTransformer(ResultTransformer resultProcessor) Set a strategy for handling the query results.
Criteria | setTimeout(int timeout) Set a timeout for the underlying JDBC query.
String | toString()
Object | uniqueResult() Convenience method to return a single instance that matches the query, or null if the query returns no results.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

toString

public String toString()

getAlias

public String getAlias()
Description copied from interface: Criteria
Get the alias of the entity encapsulated by this criteria instance.

Specified by:
getAlias in interface Criteria
Returns:
The alias for the encapsulated entity.

setAlias

public void setAlias(String alias)

getPath

public String getPath()

getParent

public Criteria getParent()

getLockMode

public LockMode getLockMode()

setLockMode

public Criteria setLockMode(LockMode lockMode)
Description copied from interface: Criteria
Set the lock mode of the current entity

Specified by:
setLockMode in interface Criteria
Parameters:
lockMode - The lock mode to be applied
Returns:
this (for method chaining)

getJoinType

public int getJoinType()

add

public Criteria add(Criterion expression)
Description copied from interface: Criteria
Add a restriction to constrain the results to be retrieved.

Specified by:
add in interface Criteria
Parameters:
expression - The criterion object representing the restriction to be applied.
Returns:
this (for method chaining)

addOrder

public Criteria addOrder(Order order)
Description copied from interface: Criteria
Add an ordering to the result set.

Specified by:
addOrder in interface Criteria
Parameters:
order - The order object representing an ordering to be applied to the results.
Returns:
this (for method chaining)

createAlias

public Criteria createAlias(String associationPath,
                            String alias)
Description copied from interface: Criteria
Join an association, assigning an alias to the joined association.

Functionally equivalent to Criteria.createAlias(String, String, int) using CriteriaSpecification.INNER_JOIN for the joinType.

Specified by:
createAlias in interface Criteria
Parameters:
associationPath - A dot-seperated property path
alias - The alias to assign to the joined association (for later reference).
Returns:
this (for method chaining)

createAlias

public Criteria createAlias(String associationPath,
                            String alias,
                            int joinType)
                     throws HibernateException
Description copied from interface: Criteria
Join an association using the specified join-type, assigning an alias to the joined association.

The joinType is expected to be one of CriteriaSpecification.INNER_JOIN (the default), CriteriaSpecification.FULL_JOIN, or CriteriaSpecification.LEFT_JOIN.

Specified by:
createAlias in interface Criteria
Parameters:
associationPath - A dot-seperated property path
alias - The alias to assign to the joined association (for later reference).
joinType - The type of join to use.
Returns:
this (for method chaining)
Throws:
HibernateException

createCriteria

public Criteria createCriteria(String associationPath)
Description copied from interface: Criteria
Create a new Criteria, "rooted" at the associated entity.

Functionally equivalent to Criteria.createCriteria(String, int) using CriteriaSpecification.INNER_JOIN for the joinType.

Specified by:
createCriteria in interface Criteria
Parameters:
associationPath - A dot-seperated property path
Returns:
the created "sub criteria"

createCriteria

public Criteria createCriteria(String associationPath,
                               int joinType)
                        throws HibernateException
Description copied from interface: Criteria
Create a new Criteria, "rooted" at the associated entity, using the specified join type.

Specified by:
createCriteria in interface Criteria
Parameters:
associationPath - A dot-seperated property path
joinType - The type of join to use.
Returns:
the created "sub criteria"
Throws:
HibernateException

createCriteria

public Criteria createCriteria(String associationPath,
                               String alias)
Description copied from interface: Criteria
Create a new Criteria, "rooted" at the associated entity, assigning the given alias.

Functionally equivalent to Criteria.createCriteria(String, String, int) using CriteriaSpecification.INNER_JOIN for the joinType.

Specified by:
createCriteria in interface Criteria
Parameters:
associationPath - A dot-seperated property path
alias - The alias to assign to the joined association (for later reference).
Returns:
the created "sub criteria"

createCriteria

public Criteria createCriteria(String associationPath,
                               String alias,
                               int joinType)
                        throws HibernateException
Description copied from interface: Criteria
Create a new Criteria, "rooted" at the associated entity, assigning the given alias and using the specified join type.

Specified by:
createCriteria in interface Criteria
Parameters:
associationPath - A dot-seperated property path
alias - The alias to assign to the joined association (for later reference).
joinType - The type of join to use.
Returns:
the created "sub criteria"
Throws:
HibernateException

setCacheable

public Criteria setCacheable(boolean cacheable)
Description copied from interface: Criteria
Enable caching of this query result, provided query caching is enabled for the underlying session factory.

Specified by:
setCacheable in interface Criteria
Parameters:
cacheable - Should the result be considered cacheable; default is to not cache (false).
Returns:
this (for method chaining)

setCacheRegion

public Criteria setCacheRegion(String cacheRegion)
Description copied from interface: Criteria
Set the name of the cache region to use for query result caching.

Specified by:
setCacheRegion in interface Criteria
Parameters:
cacheRegion - the name of a query cache region, or null for the default query cache
Returns:
this (for method chaining)
See Also:
Criteria.setCacheable(boolean)

list

public List list()
          throws HibernateException
Description copied from interface: Criteria
Get the results.

Specified by:
list in interface Criteria
Returns:
The list of matched query results.
Throws:
HibernateException

scroll

public ScrollableResults scroll()
                         throws HibernateException
Description copied from interface: Criteria
Get the results as an instance of ScrollableResults

Specified by:
scroll in interface Criteria
Returns:
The ScrollableResults representing the matched query results.
Throws:
HibernateException

scroll

public ScrollableResults scroll(ScrollMode scrollMode)
                         throws HibernateException
Description copied from interface: Criteria
Get the results as an instance of ScrollableResults based on the given scroll mode.

Specified by:
scroll in interface Criteria
Parameters:
scrollMode - Indicates the type of underlying database cursor to request.
Returns:
The ScrollableResults representing the matched query results.
Throws:
HibernateException

uniqueResult

public Object uniqueResult()
                    throws HibernateException
Description copied from interface: Criteria
Convenience method to return a single instance that matches the query, or null if the query returns no results.

Specified by:
uniqueResult in interface Criteria
Returns:
the single result or null
Throws:
HibernateException - if there is more than one matching result

setFetchMode

public Criteria setFetchMode(String associationPath,
                             FetchMode mode)
                      throws HibernateException
Description copied from interface: Criteria
Specify an association fetching strategy for an association or a collection of values.

Specified by:
setFetchMode in interface Criteria
Parameters:
associationPath - a dot seperated property path
mode - The fetch mode for the referenced association
Returns:
this (for method chaining)
Throws:
HibernateException

setFlushMode

public Criteria setFlushMode(FlushMode flushMode)
Description copied from interface: Criteria
Override the flush mode for this particular query.

Specified by:
setFlushMode in interface Criteria
Parameters:
flushMode - The flush mode to use.
Returns:
this (for method chaining)

setCacheMode

public Criteria setCacheMode(CacheMode cacheMode)
Description copied from interface: Criteria
Override the cache mode for this particular query.

Specified by:
setCacheMode in interface Criteria
Parameters:
cacheMode - The cache mode to use.
Returns:
this (for method chaining)

setFirstResult

public Criteria setFirstResult(int firstResult)
Description copied from interface: Criteria
Set the first result to be retrieved.

Specified by:
setFirstResult in interface Criteria
Parameters:
firstResult - the first result to retrieve, numbered from 0
Returns:
this (for method chaining)

setMaxResults

public Criteria setMaxResults(int maxResults)
Description copied from interface: Criteria
Set a limit upon the number of objects to be retrieved.

Specified by:
setMaxResults in interface Criteria
Parameters:
maxResults - the maximum number of results
Returns:
this (for method chaining)

setTimeout

public Criteria setTimeout(int timeout)
Description copied from interface: Criteria
Set a timeout for the underlying JDBC query.

Specified by:
setTimeout in interface Criteria
Parameters:
timeout - The timeout value to apply.
Returns:
this (for method chaining)
See Also:
Statement.setQueryTimeout(int)

setFetchSize

public Criteria setFetchSize(int fetchSize)
Description copied from interface: Criteria
Set a fetch size for the underlying JDBC query.

Specified by:
setFetchSize in interface Criteria
Parameters:
fetchSize - the fetch size
Returns:
this (for method chaining)
See Also:
Statement.setFetchSize(int)

setLockMode

public Criteria setLockMode(String alias,
                            LockMode lockMode)
Description copied from interface: Criteria
Set the lock mode of the aliased entity

Specified by:
setLockMode in interface Criteria
Parameters:
alias - The previously assigned alias representing the entity to which the given lock mode should apply.
lockMode - The lock mode to be applied
Returns:
this (for method chaining)

setResultTransformer

public Criteria setResultTransformer(ResultTransformer resultProcessor)
Description copied from interface: Criteria
Set a strategy for handling the query results. This determines the "shape" of the query result.

Specified by:
setResultTransformer in interface Criteria
Parameters:
resultProcessor - The transformer to apply
Returns:
this (for method chaining)
See Also:
CriteriaSpecification.ROOT_ENTITY, CriteriaSpecification.DISTINCT_ROOT_ENTITY, CriteriaSpecification.ALIAS_TO_ENTITY_MAP, CriteriaSpecification.PROJECTION

setComment

public Criteria setComment(String comment)
Description copied from interface: Criteria
Add a comment to the generated SQL.

Specified by:
setComment in interface Criteria
Parameters:
comment - a human-readable string
Returns:
this (for method chaining)

setProjection

public Criteria setProjection(Projection projection)
Description copied from interface: Criteria
Used to specify that the query results will be a projection (scalar in nature). Implicitly specifies the CriteriaSpecification.PROJECTION result transformer.

The individual components contained within the given projection determines the overall "shape" of the query result.

Specified by:
setProjection in interface Criteria
Parameters:
projection - The projection representing the overall "shape" of the query results.
Returns:
this (for method chaining)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FetchingScrollableResultsImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class FetchingScrollableResultsImpl

java.lang.Object
    extended by org.hibernate.impl.AbstractScrollableResults
        extended by org.hibernate.impl.FetchingScrollableResultsImpl
All Implemented Interfaces:
ScrollableResults
public class FetchingScrollableResultsImpl
extends AbstractScrollableResults

Implementation of ScrollableResults which can handle collection fetches.

Author:
Steve Ebersole

Constructor Summary
FetchingScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
Method Summary
void | afterLast() Go to a location just after the last result
void | beforeFirst() Go to a location just before first result (this is the initial location)
boolean | first() Go to the first result
protected Object[] | getCurrentRow()
int | getRowNumber() Get the current location in the result set.
boolean | isFirst() Is this the first result?
boolean | isLast() Is this the last result?
boolean | last() Go to the last result
boolean | next() Advance to the next result
boolean | previous() Retreat to the previous result
boolean | scroll(int positions) Scroll an arbitrary number of locations
boolean | setRowNumber(int rowNumber) Set the current location in the result set, numbered from either the first row (row number 0), or the last row (row number -1).
Methods inherited from class org.hibernate.impl.AbstractScrollableResults
afterScrollOperation, close, get, get, getBigDecimal, getBigInteger, getBinary, getBlob, getBoolean, getByte, getCalendar, getCharacter, getClob, getDate, getDouble, getFinal, getFloat, getHolderInstantiator, getInteger, getLoader, getLocale, getLong, getNonFinal, getPs, getQueryParameters, getResultSet, getSession, getShort, getString, getText, getTimeZone, getType, getTypes
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FetchingScrollableResultsImpl

public FetchingScrollableResultsImpl(ResultSet rs,
                                     PreparedStatement ps,
                                     SessionImplementor sess,
                                     Loader loader,
                                     QueryParameters queryParameters,
                                     Type[] types,
                                     HolderInstantiator holderInstantiator)
                              throws MappingException
Method Detail

getCurrentRow

protected Object[] getCurrentRow()
Specified by:
getCurrentRow in class AbstractScrollableResults

next

public boolean next()
             throws HibernateException
Advance to the next result

Returns:
true if there is another result
Throws:
HibernateException

previous

public boolean previous()
                 throws HibernateException
Retreat to the previous result

Returns:
true if there is a previous result
Throws:
HibernateException

scroll

public boolean scroll(int positions)
               throws HibernateException
Scroll an arbitrary number of locations

Parameters:
positions - a positive (forward) or negative (backward) number of rows
Returns:
true if there is a result at the new location
Throws:
HibernateException

last

public boolean last()
             throws HibernateException
Go to the last result

Returns:
true if there are any results
Throws:
HibernateException

first

public boolean first()
              throws HibernateException
Go to the first result

Returns:
true if there are any results
Throws:
HibernateException

beforeFirst

public void beforeFirst()
                 throws HibernateException
Go to a location just before first result (this is the initial location)

Throws:
HibernateException

afterLast

public void afterLast()
               throws HibernateException
Go to a location just after the last result

Throws:
HibernateException

isFirst

public boolean isFirst()
                throws HibernateException
Is this the first result?

Returns:
true if this is the first row of results
Throws:
HibernateException

isLast

public boolean isLast()
               throws HibernateException
Is this the last result?

Returns:
true if this is the last row of results
Throws:
HibernateException

getRowNumber

public int getRowNumber()
                 throws HibernateException
Get the current location in the result set. The first row is number 0, contrary to JDBC.

Returns:
the row number, numbered from 0, or -1 if there is no current row
Throws:
HibernateException

setRowNumber

public boolean setRowNumber(int rowNumber)
                     throws HibernateException
Set the current location in the result set, numbered from either the first row (row number 0), or the last row (row number -1).

Parameters:
rowNumber - the row number, numbered from the last row, in the case of a negative row number
Returns:
true if there is a row at that row number
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FilterImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class FilterImpl

java.lang.Object
    extended by org.hibernate.impl.FilterImpl
All Implemented Interfaces:
Filter, Serializable
public class FilterImpl
extends Object
implements Filter, Serializable

Implementation of FilterImpl. FilterImpl implements the user's view into enabled dynamic filters, allowing them to set filter parameter values.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
static String MARKER
Constructor Summary
FilterImpl(FilterDefinition configuration)
Constructs a new FilterImpl.
Method Summary
FilterDefinition | getFilterDefinition() Get the filter definition containing additional information about the filter (such as default-condition and expected parameter names/types).
String | getName() Get the name of this filter.
Object | getParameter(String name) Get the value of the named parameter for the current filter.
Map | getParameters()
Filter | setParameter(String name, Object value) Set the named parameter's value for this filter.
Filter | setParameterList(String name, Collection values) Set the named parameter's value list for this filter.
Filter | setParameterList(String name, Object[] values) Set the named parameter's value list for this filter.
void | validate() Perform validation of the filter state.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MARKER

public static final String MARKER
See Also:
Constant Field Values
Constructor Detail

FilterImpl

public FilterImpl(FilterDefinition configuration)
Constructs a new FilterImpl.

Parameters:
configuration - The filter's global configuration.
Method Detail

getFilterDefinition

public FilterDefinition getFilterDefinition()
Description copied from interface: Filter
Get the filter definition containing additional information about the filter (such as default-condition and expected parameter names/types).

Specified by:
getFilterDefinition in interface Filter
Returns:
The filter definition

getName

public String getName()
Get the name of this filter.

Specified by:
getName in interface Filter
Returns:
This filter's name.

getParameters

public Map getParameters()

setParameter

public Filter setParameter(String name,
                           Object value)
                    throws IllegalArgumentException
Set the named parameter's value for this filter.

Specified by:
setParameter in interface Filter
Parameters:
name - The parameter's name.
value - The value to be applied.
Returns:
This FilterImpl instance (for method chaining).
Throws:
IllegalArgumentException - Indicates that either the parameter was undefined or that the type of the passed value did not match the configured type.

setParameterList

public Filter setParameterList(String name,
                               Collection values)
                        throws HibernateException
Set the named parameter's value list for this filter. Used in conjunction with IN-style filter criteria.

Specified by:
setParameterList in interface Filter
Parameters:
name - The parameter's name.
values - The values to be expanded into an SQL IN list.
Returns:
This FilterImpl instance (for method chaining).
Throws:
HibernateException

setParameterList

public Filter setParameterList(String name,
                               Object[] values)
                        throws IllegalArgumentException
Set the named parameter's value list for this filter. Used in conjunction with IN-style filter criteria.

Specified by:
setParameterList in interface Filter
Parameters:
name - The parameter's name.
values - The values to be expanded into an SQL IN list.
Returns:
This FilterImpl instance (for method chaining).
Throws:
IllegalArgumentException

getParameter

public Object getParameter(String name)
Get the value of the named parameter for the current filter.

Parameters:
name - The name of the parameter for which to return the value.
Returns:
The value of the named parameter.

validate

public void validate()
              throws HibernateException
Perform validation of the filter state. This is used to verify the state of the filter after its enablement and before its use.

Specified by:
validate in interface Filter
Throws:
HibernateException - If the state is not currently valid.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IteratorImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class IteratorImpl

java.lang.Object
    extended by org.hibernate.impl.IteratorImpl
All Implemented Interfaces:
HibernateIterator, Iterator
public final class IteratorImpl
extends Object
implements HibernateIterator

An implementation of java.util.Iterator that is returned by iterate() query execution methods.

Author:
Gavin King

Constructor Summary
IteratorImpl(ResultSet rs, PreparedStatement ps, EventSource sess, Type[] types, String[][] columnNames, HolderInstantiator holderInstantiator)
Method Summary
void | close()
boolean | hasNext()
Object | next()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IteratorImpl

public IteratorImpl(ResultSet rs,
                    PreparedStatement ps,
                    EventSource sess,
                    Type[] types,
                    String[][] columnNames,
                    HolderInstantiator holderInstantiator)
             throws HibernateException,
                    SQLException
Method Detail

close

public void close()
           throws JDBCException
Specified by:
close in interface HibernateIterator
Throws:
JDBCException

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class QueryImpl

java.lang.Object
    extended by org.hibernate.impl.AbstractQueryImpl
        extended by org.hibernate.impl.QueryImpl
All Implemented Interfaces:
Query
Direct Known Subclasses:
CollectionFilterImpl
public class QueryImpl
extends AbstractQueryImpl

default implementation of the Query interface, for "ordinary" HQL queries (not collection filters)

Author:
Gavin King
See Also:
CollectionFilterImpl

Field Summary
Fields inherited from class org.hibernate.impl.AbstractQueryImpl
parameterMetadata, session
Constructor Summary
QueryImpl(String queryString, FlushMode flushMode, SessionImplementor session, ParameterMetadata parameterMetadata)
QueryImpl(String queryString, SessionImplementor session, ParameterMetadata parameterMetadata)
Method Summary
int | executeUpdate() Execute the update or delete statement.
protected Map | getLockModes()
Iterator | iterate() Return the query results as an Iterator.
List | list() Return the query results as a List.
ScrollableResults | scroll() Return the query results as ScrollableResults.
ScrollableResults | scroll(ScrollMode scrollMode) Return the query results as ScrollableResults.
Query | setLockMode(String alias, LockMode lockMode) Set the lockmode for the objects idententified by the given alias that appears in the FROM clause.
Methods inherited from class org.hibernate.impl.AbstractQueryImpl
after, before, determineType, determineType, determineType, determineType, determineType, expandParameterLists, getNamedParameterLists, getNamedParameters, getNamedParams, getQueryParameters, getQueryString, getReturnAliases, getReturnTypes, getRowSelection, getSelection, getTypes, getValues, hasNamedParameters, isReadOnly, setBigDecimal, setBigDecimal, setBigInteger, setBigInteger, setBinary, setBinary, setBoolean, setBoolean, setByte, setByte, setCacheable, setCacheMode, setCacheRegion, setCalendar, setCalendar, setCalendarDate, setCalendarDate, setCharacter, setCharacter, setCollectionKey, setComment, setDate, setDate, setDouble, setDouble, setEntity, setEntity, setFetchSize, setFirstResult, setFloat, setFloat, setFlushMode, setInteger, setInteger, setLocale, setLocale, setLong, setLong, setMaxResults, setOptionalEntityName, setOptionalId, setOptionalObject, setParameter, setParameter, setParameter, setParameter, setParameterList, setParameterList, setParameterList, setParameterList, setParameters, setProperties, setReadOnly, setResultTransformer, setSerializable, setSerializable, setShort, setShort, setString, setString, setText, setText, setTime, setTime, setTimeout, setTimestamp, setTimestamp, toString, typeArray, uniqueResult, valueArray, verifyParameters, verifyParameters
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

QueryImpl

public QueryImpl(String queryString,
                 FlushMode flushMode,
                 SessionImplementor session,
                 ParameterMetadata parameterMetadata)

QueryImpl

public QueryImpl(String queryString,
                 SessionImplementor session,
                 ParameterMetadata parameterMetadata)
Method Detail

iterate

public Iterator iterate()
                 throws HibernateException
Description copied from interface: Query
Return the query results as an Iterator. If the query contains multiple results pre row, the results are returned in an instance of Object[].

Entities returned as results are initialized on demand. The first SQL query returns identifiers only.

Returns:
the result iterator
Throws:
HibernateException

scroll

public ScrollableResults scroll()
                         throws HibernateException
Description copied from interface: Query
Return the query results as ScrollableResults. The scrollability of the returned results depends upon JDBC driver support for scrollable ResultSets.

Returns:
the result iterator
Throws:
HibernateException
See Also:
ScrollableResults

scroll

public ScrollableResults scroll(ScrollMode scrollMode)
                         throws HibernateException
Description copied from interface: Query
Return the query results as ScrollableResults. The scrollability of the returned results depends upon JDBC driver support for scrollable ResultSets.

Returns:
the result iterator
Throws:
HibernateException
See Also:
ScrollableResults, ScrollMode

list

public List list()
          throws HibernateException
Description copied from interface: Query
Return the query results as a List. If the query contains multiple results pre row, the results are returned in an instance of Object[].

Returns:
the result list
Throws:
HibernateException

executeUpdate

public int executeUpdate()
                  throws HibernateException
Description copied from interface: Query
Execute the update or delete statement.

The semantics are compliant with the ejb3 Query.executeUpdate() method.

Returns:
The number of entities updated or deleted.
Throws:
HibernateException

setLockMode

public Query setLockMode(String alias,
                         LockMode lockMode)
Description copied from interface: Query
Set the lockmode for the objects idententified by the given alias that appears in the FROM clause.

Parameters:
alias - a query alias, or this for a collection filter

getLockModes

protected Map getLockModes()
Specified by:
getLockModes in class AbstractQueryImpl
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScrollableResultsImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class ScrollableResultsImpl

java.lang.Object
    extended by org.hibernate.impl.AbstractScrollableResults
        extended by org.hibernate.impl.ScrollableResultsImpl
All Implemented Interfaces:
ScrollableResults
public class ScrollableResultsImpl
extends AbstractScrollableResults
implements ScrollableResults

Implementation of the ScrollableResults interface

Author:
Gavin King

Constructor Summary
ScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
Method Summary
void | afterLast() Go to a location just after the last result
void | beforeFirst() Go to a location just before first result (this is the initial location)
boolean | first() Go to the first result
protected Object[] | getCurrentRow()
int | getRowNumber() Get the current location in the result set.
boolean | isFirst() Is this the first result?
boolean | isLast() Is this the last result?
boolean | last() Go to the last result
boolean | next() Advance to the next result
boolean | previous() Retreat to the previous result
boolean | scroll(int i) Scroll an arbitrary number of locations
boolean | setRowNumber(int rowNumber) Set the current location in the result set, numbered from either the first row (row number 0), or the last row (row number -1).
Methods inherited from class org.hibernate.impl.AbstractScrollableResults
afterScrollOperation, close, get, get, getBigDecimal, getBigInteger, getBinary, getBlob, getBoolean, getByte, getCalendar, getCharacter, getClob, getDate, getDouble, getFinal, getFloat, getHolderInstantiator, getInteger, getLoader, getLocale, getLong, getNonFinal, getPs, getQueryParameters, getResultSet, getSession, getShort, getString, getText, getTimeZone, getType, getTypes
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.ScrollableResults
close, get, get, getBigDecimal, getBigInteger, getBinary, getBlob, getBoolean, getByte, getCalendar, getCharacter, getClob, getDate, getDouble, getFloat, getInteger, getLocale, getLong, getShort, getString, getText, getTimeZone, getType

Constructor Detail

ScrollableResultsImpl

public ScrollableResultsImpl(ResultSet rs,
                             PreparedStatement ps,
                             SessionImplementor sess,
                             Loader loader,
                             QueryParameters queryParameters,
                             Type[] types,
                             HolderInstantiator holderInstantiator)
                      throws MappingException
Method Detail

getCurrentRow

protected Object[] getCurrentRow()
Specified by:
getCurrentRow in class AbstractScrollableResults

scroll

public boolean scroll(int i)
               throws HibernateException
Description copied from interface: ScrollableResults
Scroll an arbitrary number of locations

Specified by:
scroll in interface ScrollableResults
Parameters:
i - a positive (forward) or negative (backward) number of rows
Returns:
true if there is a result at the new location
Throws:
HibernateException
See Also:
ScrollableResults.scroll(int)

first

public boolean first()
              throws HibernateException
Description copied from interface: ScrollableResults
Go to the first result

Specified by:
first in interface ScrollableResults
Returns:
true if there are any results
Throws:
HibernateException
See Also:
ScrollableResults.first()

last

public boolean last()
             throws HibernateException
Description copied from interface: ScrollableResults
Go to the last result

Specified by:
last in interface ScrollableResults
Returns:
true if there are any results
Throws:
HibernateException
See Also:
ScrollableResults.last()

next

public boolean next()
             throws HibernateException
Description copied from interface: ScrollableResults
Advance to the next result

Specified by:
next in interface ScrollableResults
Returns:
true if there is another result
Throws:
HibernateException
See Also:
ScrollableResults.next()

previous

public boolean previous()
                 throws HibernateException
Description copied from interface: ScrollableResults
Retreat to the previous result

Specified by:
previous in interface ScrollableResults
Returns:
true if there is a previous result
Throws:
HibernateException
See Also:
ScrollableResults.previous()

afterLast

public void afterLast()
               throws HibernateException
Description copied from interface: ScrollableResults
Go to a location just after the last result

Specified by:
afterLast in interface ScrollableResults
Throws:
HibernateException
See Also:
ScrollableResults.afterLast()

beforeFirst

public void beforeFirst()
                 throws HibernateException
Description copied from interface: ScrollableResults
Go to a location just before first result (this is the initial location)

Specified by:
beforeFirst in interface ScrollableResults
Throws:
HibernateException
See Also:
ScrollableResults.beforeFirst()

isFirst

public boolean isFirst()
                throws HibernateException
Description copied from interface: ScrollableResults
Is this the first result?

Specified by:
isFirst in interface ScrollableResults
Returns:
true if this is the first row of results
Throws:
HibernateException
See Also:
ScrollableResults.isFirst()

isLast

public boolean isLast()
               throws HibernateException
Description copied from interface: ScrollableResults
Is this the last result?

Specified by:
isLast in interface ScrollableResults
Returns:
true if this is the last row of results
Throws:
HibernateException
See Also:
ScrollableResults.isLast()

getRowNumber

public int getRowNumber()
                 throws HibernateException
Description copied from interface: ScrollableResults
Get the current location in the result set. The first row is number 0, contrary to JDBC.

Specified by:
getRowNumber in interface ScrollableResults
Returns:
the row number, numbered from 0, or -1 if there is no current row
Throws:
HibernateException

setRowNumber

public boolean setRowNumber(int rowNumber)
                     throws HibernateException
Description copied from interface: ScrollableResults
Set the current location in the result set, numbered from either the first row (row number 0), or the last row (row number -1).

Specified by:
setRowNumber in interface ScrollableResults
Parameters:
rowNumber - the row number, numbered from the last row, in the case of a negative row number
Returns:
true if there is a row at that row number
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SessionFactoryImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class SessionFactoryImpl

java.lang.Object
    extended by org.hibernate.impl.SessionFactoryImpl
All Implemented Interfaces:
Mapping, Referenceable, Serializable, SessionFactory, SessionFactoryImplementor
public final class SessionFactoryImpl
extends Object
implements SessionFactory, SessionFactoryImplementor

Concrete implementation of the SessionFactory interface. Has the following responsibilites

  • caches configuration settings (immutably)
  • caches "compiled" mappings ie. EntityPersisters and CollectionPersisters (immutable)
  • caches "compiled" queries (memory sensitive cache)
  • manages PreparedStatements
  • delegates JDBC Connection management to the ConnectionProvider
  • factory for instances of SessionImpl
This class must appear immutable to clients, even if it does all kinds of caching and pooling under the covers. It is crucial that the class is not only thread safe, but also highly concurrent. Synchronization must be used extremely sparingly.

Author:
Gavin King
See Also:
ConnectionProvider, Session, QueryTranslator, EntityPersister, CollectionPersister, Serialized Form

Constructor Summary
SessionFactoryImpl(Configuration cfg, Mapping mapping, Settings settings, EventListeners listeners)
Method Summary
void | close() Closes the session factory, releasing all held resources.
void | evict(Class persistentClass) Evict all entries from the second-level cache.
void | evict(Class persistentClass, Serializable id) Evict an entry from the second-level cache.
void | evictCollection(String roleName) Evict all entries from the second-level cache.
void | evictCollection(String roleName, Serializable id) Evict an entry from the second-level cache.
void | evictEntity(String entityName) Evict all entries from the second-level cache.
void | evictEntity(String entityName, Serializable id) Evict an entry from the second-level cache.
void | evictQueries() Evict any query result sets cached in the default query cache region.
void | evictQueries(String cacheRegion) Evict any query result sets cached in the named query cache region.
Map | getAllClassMetadata() Get all ClassMetadata as a Map from entityname String to metadata object
Map | getAllCollectionMetadata() Get all CollectionMetadata as a Map from role name to metadata object
Map | getAllSecondLevelCacheRegions()
BatcherFactory | getBatcherFactory()
ClassMetadata | getClassMetadata(Class persistentClass) Get the ClassMetadata associated with the given entity class
ClassMetadata | getClassMetadata(String entityName) Get the ClassMetadata associated with the given entity name
CollectionMetadata | getCollectionMetadata(String roleName) Get the CollectionMetadata associated with the named collection role
CollectionPersister | getCollectionPersister(String role) Get the persister object for a collection role
Set | getCollectionRolesByEntityParticipant(String entityName) Retrieves a set of all the collection roles in which the given entity is a participant, as either an index or an element.
ConnectionProvider | getConnectionProvider() Get the connection provider
Session | getCurrentSession() Obtains the current session.
Set | getDefinedFilterNames() Obtain a set of the names of all filters defined on this SessionFactory.
Dialect | getDialect() Get the SQL Dialect
EntityNotFoundDelegate | getEntityNotFoundDelegate()
EntityPersister | getEntityPersister(String entityName) Get the persister for the named entity
EventListeners | getEventListeners()
FilterDefinition | getFilterDefinition(String filterName) Obtain the definition of a filter by name.
IdentifierGenerator | getIdentifierGenerator(String rootEntityName) Get the identifier generator for the hierarchy
String | getIdentifierPropertyName(String className)
Type | getIdentifierType(String className)
String[] | getImplementors(String className) Return the names of all persistent (mapped) classes that extend or implement the given class or interface, accounting for implicit/explicit polymorphism settings and excluding mapped subclasses/joined-subclasses of other classes in the result.
String | getImportedClassName(String className) Get a class name, using query language imports
Interceptor | getInterceptor()
NamedQueryDefinition | getNamedQuery(String queryName)
NamedSQLQueryDefinition | getNamedSQLQuery(String queryName)
QueryCache | getQueryCache() Get the default query cache
QueryCache | getQueryCache(String cacheRegion) Get a particular named query cache, or the default cache
QueryPlanCache | getQueryPlanCache()
Reference | getReference()
Type | getReferencedPropertyType(String className, String propertyName)
ResultSetMappingDefinition | getResultSetMapping(String resultSetName)
String[] | getReturnAliases(String queryString) Get the return aliases of a query
Type[] | getReturnTypes(String queryString) Get the return types of a query
Cache | getSecondLevelCacheRegion(String regionName) Get a named second-level cache region
Settings | getSettings()
SQLExceptionConverter | getSQLExceptionConverter() Retrieves the SQLExceptionConverter in effect for this SessionFactory.
SQLFunctionRegistry | getSqlFunctionRegistry()
Statistics | getStatistics() Get the statistics for this session factory
StatisticsImplementor | getStatisticsImplementor() Statistics SPI
TransactionFactory | getTransactionFactory()
TransactionManager | getTransactionManager() Get the JTA transaction manager
UpdateTimestampsCache | getUpdateTimestampsCache() Get the cache of table update timestamps
boolean | isClosed() Was this SessionFactory already closed?
Session | openSession() Create database connection and open a Session on it.
Session | openSession(Connection connection) Open a Session on the given connection.
Session | openSession(Connection connection, boolean flushBeforeCompletionEnabled, boolean autoCloseSessionEnabled, ConnectionReleaseMode connectionReleaseMode) Open a session conforming to the given parameters.
Session | openSession(Connection connection, Interceptor sessionLocalInterceptor) Open a Session on the given connection, specifying an interceptor.
Session | openSession(Interceptor sessionLocalInterceptor) Create database connection and open a Session on it, specifying an interceptor.
StatelessSession | openStatelessSession() Get a new stateless session.
StatelessSession | openStatelessSession(Connection connection) Get a new stateless session for the given JDBC connection.
Session | openTemporarySession() Get a nontransactional "current" session for Hibernate EntityManager
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SessionFactoryImpl

public SessionFactoryImpl(Configuration cfg,
                          Mapping mapping,
                          Settings settings,
                          EventListeners listeners)
                   throws HibernateException
Method Detail

getQueryPlanCache

public QueryPlanCache getQueryPlanCache()
Specified by:
getQueryPlanCache in interface SessionFactoryImplementor

openStatelessSession

public StatelessSession openStatelessSession()
Description copied from interface: SessionFactory
Get a new stateless session.

Specified by:
openStatelessSession in interface SessionFactory

openStatelessSession

public StatelessSession openStatelessSession(Connection connection)
Description copied from interface: SessionFactory
Get a new stateless session for the given JDBC connection.

Specified by:
openStatelessSession in interface SessionFactory

openSession

public Session openSession(Connection connection,
                           Interceptor sessionLocalInterceptor)
Description copied from interface: SessionFactory
Open a Session on the given connection, specifying an interceptor.

Note that the second-level cache will be disabled if you supply a JDBC connection. Hibernate will not be able to track any statements you might have executed in the same transaction. Consider implementing your own ConnectionProvider.

Specified by:
openSession in interface SessionFactory
Parameters:
connection - a connection provided by the application.
sessionLocalInterceptor - a session-scoped interceptor
Returns:
Session

openSession

public Session openSession(Interceptor sessionLocalInterceptor)
                    throws HibernateException
Description copied from interface: SessionFactory
Create database connection and open a Session on it, specifying an interceptor.

Specified by:
openSession in interface SessionFactory
Parameters:
sessionLocalInterceptor - a session-scoped interceptor
Returns:
Session
Throws:
HibernateException

openSession

public Session openSession(Connection connection)
Description copied from interface: SessionFactory
Open a Session on the given connection.

Note that the second-level cache will be disabled if you supply a JDBC connection. Hibernate will not be able to track any statements you might have executed in the same transaction. Consider implementing your own ConnectionProvider.

Specified by:
openSession in interface SessionFactory
Parameters:
connection - a connection provided by the application.
Returns:
Session

openSession

public Session openSession()
                    throws HibernateException
Description copied from interface: SessionFactory
Create database connection and open a Session on it.

Specified by:
openSession in interface SessionFactory
Returns:
Session
Throws:
HibernateException

openTemporarySession

public Session openTemporarySession()
                             throws HibernateException
Description copied from interface: SessionFactoryImplementor
Get a nontransactional "current" session for Hibernate EntityManager

Specified by:
openTemporarySession in interface SessionFactoryImplementor
Throws:
HibernateException

openSession

public Session openSession(Connection connection,
                           boolean flushBeforeCompletionEnabled,
                           boolean autoCloseSessionEnabled,
                           ConnectionReleaseMode connectionReleaseMode)
                    throws HibernateException
Description copied from interface: SessionFactoryImplementor
Open a session conforming to the given parameters. Used mainly by JTASessionContext for current session processing.

Specified by:
openSession in interface SessionFactoryImplementor
Parameters:
connection - The external jdbc connection to use, if one (i.e., optional).
flushBeforeCompletionEnabled - Should the session be auto-flushed prior to transaction completion?
autoCloseSessionEnabled - Should the session be auto-closed after transaction completion?
connectionReleaseMode - The release mode for managed jdbc connections.
Returns:
An appropriate session.
Throws:
HibernateException

getCurrentSession

public Session getCurrentSession()
                          throws HibernateException
Description copied from interface: SessionFactory
Obtains the current session. The definition of what exactly "current" means controlled by the CurrentSessionContext impl configured for use.

Note that for backwards compatibility, if a CurrentSessionContext is not configured but a JTA TransactionManagerLookup is configured this will default to the JTASessionContext impl.

Specified by:
getCurrentSession in interface SessionFactory
Returns:
The current session.
Throws:
HibernateException - Indicates an issue locating a suitable current session.

getEntityPersister

public EntityPersister getEntityPersister(String entityName)
                                   throws MappingException
Description copied from interface: SessionFactoryImplementor
Get the persister for the named entity

Specified by:
getEntityPersister in interface SessionFactoryImplementor
Throws:
MappingException

getCollectionPersister

public CollectionPersister getCollectionPersister(String role)
                                           throws MappingException
Description copied from interface: SessionFactoryImplementor
Get the persister object for a collection role

Specified by:
getCollectionPersister in interface SessionFactoryImplementor
Throws:
MappingException

getSettings

public Settings getSettings()
Specified by:
getSettings in interface SessionFactoryImplementor

getDialect

public Dialect getDialect()
Description copied from interface: SessionFactoryImplementor
Get the SQL Dialect

Specified by:
getDialect in interface SessionFactoryImplementor

getInterceptor

public Interceptor getInterceptor()
Specified by:
getInterceptor in interface SessionFactoryImplementor

getTransactionFactory

public TransactionFactory getTransactionFactory()

getTransactionManager

public TransactionManager getTransactionManager()
Description copied from interface: SessionFactoryImplementor
Get the JTA transaction manager

Specified by:
getTransactionManager in interface SessionFactoryImplementor

getSQLExceptionConverter

public SQLExceptionConverter getSQLExceptionConverter()
Description copied from interface: SessionFactoryImplementor
Retrieves the SQLExceptionConverter in effect for this SessionFactory.

Specified by:
getSQLExceptionConverter in interface SessionFactoryImplementor
Returns:
The SQLExceptionConverter for this SessionFactory.

getCollectionRolesByEntityParticipant

public Set getCollectionRolesByEntityParticipant(String entityName)
Description copied from interface: SessionFactoryImplementor
Retrieves a set of all the collection roles in which the given entity is a participant, as either an index or an element.

Specified by:
getCollectionRolesByEntityParticipant in interface SessionFactoryImplementor
Parameters:
entityName - The entity name for which to get the collection roles.
Returns:
set of all the collection roles in which the given entityName participates.

getReference

public Reference getReference()
                       throws NamingException
Specified by:
getReference in interface Referenceable
Throws:
NamingException

getNamedQuery

public NamedQueryDefinition getNamedQuery(String queryName)
Specified by:
getNamedQuery in interface SessionFactoryImplementor

getNamedSQLQuery

public NamedSQLQueryDefinition getNamedSQLQuery(String queryName)
Specified by:
getNamedSQLQuery in interface SessionFactoryImplementor

getResultSetMapping

public ResultSetMappingDefinition getResultSetMapping(String resultSetName)
Specified by:
getResultSetMapping in interface SessionFactoryImplementor

getIdentifierType

public Type getIdentifierType(String className)
                       throws MappingException
Specified by:
getIdentifierType in interface Mapping
Throws:
MappingException

getIdentifierPropertyName

public String getIdentifierPropertyName(String className)
                                 throws MappingException
Specified by:
getIdentifierPropertyName in interface Mapping
Throws:
MappingException

getReturnTypes

public Type[] getReturnTypes(String queryString)
                      throws HibernateException
Description copied from interface: SessionFactoryImplementor
Get the return types of a query

Specified by:
getReturnTypes in interface SessionFactoryImplementor
Throws:
HibernateException

getReturnAliases

public String[] getReturnAliases(String queryString)
                          throws HibernateException
Description copied from interface: SessionFactoryImplementor
Get the return aliases of a query

Specified by:
getReturnAliases in interface SessionFactoryImplementor
Throws:
HibernateException

getClassMetadata

public ClassMetadata getClassMetadata(Class persistentClass)
                               throws HibernateException
Description copied from interface: SessionFactory
Get the ClassMetadata associated with the given entity class

Specified by:
getClassMetadata in interface SessionFactory
Throws:
HibernateException
See Also:
ClassMetadata

getCollectionMetadata

public CollectionMetadata getCollectionMetadata(String roleName)
                                         throws HibernateException
Description copied from interface: SessionFactory
Get the CollectionMetadata associated with the named collection role

Specified by:
getCollectionMetadata in interface SessionFactory
Throws:
HibernateException
See Also:
CollectionMetadata

getClassMetadata

public ClassMetadata getClassMetadata(String entityName)
                               throws HibernateException
Description copied from interface: SessionFactory
Get the ClassMetadata associated with the given entity name

Specified by:
getClassMetadata in interface SessionFactory
Throws:
HibernateException
See Also:
ClassMetadata

getImplementors

public String[] getImplementors(String className)
                         throws MappingException
Return the names of all persistent (mapped) classes that extend or implement the given class or interface, accounting for implicit/explicit polymorphism settings and excluding mapped subclasses/joined-subclasses of other classes in the result.

Specified by:
getImplementors in interface SessionFactoryImplementor
Throws:
MappingException

getImportedClassName

public String getImportedClassName(String className)
Description copied from interface: SessionFactoryImplementor
Get a class name, using query language imports

Specified by:
getImportedClassName in interface SessionFactoryImplementor

getAllClassMetadata

public Map getAllClassMetadata()
                        throws HibernateException
Description copied from interface: SessionFactory
Get all ClassMetadata as a Map from entityname String to metadata object

Specified by:
getAllClassMetadata in interface SessionFactory
Returns:
a map from String an entity name to ClassMetaData
Throws:
HibernateException
See Also:
ClassMetadata

getAllCollectionMetadata

public Map getAllCollectionMetadata()
                             throws HibernateException
Description copied from interface: SessionFactory
Get all CollectionMetadata as a Map from role name to metadata object

Specified by:
getAllCollectionMetadata in interface SessionFactory
Returns:
a map from String to CollectionMetadata
Throws:
HibernateException
See Also:
CollectionMetadata

close

public void close()
           throws HibernateException
Closes the session factory, releasing all held resources.
  1. cleans up used cache regions and "stops" the cache provider.
  2. close the JDBC connection
  3. remove the JNDI binding
Note: Be aware that the sessionfactory instance still can be a "heavy" object memory wise after close() has been called. Thus it is important to not keep referencing the instance to let the garbage collector release the memory.

Specified by:
close in interface SessionFactory
Throws:
HibernateException

evictEntity

public void evictEntity(String entityName,
                        Serializable id)
                 throws HibernateException
Description copied from interface: SessionFactory
Evict an entry from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Specified by:
evictEntity in interface SessionFactory
Throws:
HibernateException

evictEntity

public void evictEntity(String entityName)
                 throws HibernateException
Description copied from interface: SessionFactory
Evict all entries from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Specified by:
evictEntity in interface SessionFactory
Throws:
HibernateException

evict

public void evict(Class persistentClass,
                  Serializable id)
           throws HibernateException
Description copied from interface: SessionFactory
Evict an entry from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Specified by:
evict in interface SessionFactory
Throws:
HibernateException

evict

public void evict(Class persistentClass)
           throws HibernateException
Description copied from interface: SessionFactory
Evict all entries from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Specified by:
evict in interface SessionFactory
Throws:
HibernateException

evictCollection

public void evictCollection(String roleName,
                            Serializable id)
                     throws HibernateException
Description copied from interface: SessionFactory
Evict an entry from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Specified by:
evictCollection in interface SessionFactory
Throws:
HibernateException

evictCollection

public void evictCollection(String roleName)
                     throws HibernateException
Description copied from interface: SessionFactory
Evict all entries from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Specified by:
evictCollection in interface SessionFactory
Throws:
HibernateException

getReferencedPropertyType

public Type getReferencedPropertyType(String className,
                                      String propertyName)
                               throws MappingException
Specified by:
getReferencedPropertyType in interface Mapping
Throws:
MappingException

getConnectionProvider

public ConnectionProvider getConnectionProvider()
Description copied from interface: SessionFactoryImplementor
Get the connection provider

Specified by:
getConnectionProvider in interface SessionFactoryImplementor

getUpdateTimestampsCache

public UpdateTimestampsCache getUpdateTimestampsCache()
Description copied from interface: SessionFactoryImplementor
Get the cache of table update timestamps

Specified by:
getUpdateTimestampsCache in interface SessionFactoryImplementor

getQueryCache

public QueryCache getQueryCache()
Description copied from interface: SessionFactoryImplementor
Get the default query cache

Specified by:
getQueryCache in interface SessionFactoryImplementor

getQueryCache

public QueryCache getQueryCache(String cacheRegion)
                         throws HibernateException
Description copied from interface: SessionFactoryImplementor
Get a particular named query cache, or the default cache

Specified by:
getQueryCache in interface SessionFactoryImplementor
Parameters:
cacheRegion - the name of the cache region, or null for the default query cache
Returns:
the existing cache, or a newly created cache if none by that region name
Throws:
HibernateException

getSecondLevelCacheRegion

public Cache getSecondLevelCacheRegion(String regionName)
Description copied from interface: SessionFactoryImplementor
Get a named second-level cache region

Specified by:
getSecondLevelCacheRegion in interface SessionFactoryImplementor

getAllSecondLevelCacheRegions

public Map getAllSecondLevelCacheRegions()
Specified by:
getAllSecondLevelCacheRegions in interface SessionFactoryImplementor

isClosed

public boolean isClosed()
Description copied from interface: SessionFactory
Was this SessionFactory already closed?

Specified by:
isClosed in interface SessionFactory

getStatistics

public Statistics getStatistics()
Description copied from interface: SessionFactory
Get the statistics for this session factory

Specified by:
getStatistics in interface SessionFactory

getStatisticsImplementor

public StatisticsImplementor getStatisticsImplementor()
Description copied from interface: SessionFactoryImplementor
Statistics SPI

Specified by:
getStatisticsImplementor in interface SessionFactoryImplementor

evictQueries

public void evictQueries()
                  throws HibernateException
Description copied from interface: SessionFactory
Evict any query result sets cached in the default query cache region.

Specified by:
evictQueries in interface SessionFactory
Throws:
HibernateException

evictQueries

public void evictQueries(String cacheRegion)
                  throws HibernateException
Description copied from interface: SessionFactory
Evict any query result sets cached in the named query cache region.

Specified by:
evictQueries in interface SessionFactory
Throws:
HibernateException

getFilterDefinition

public FilterDefinition getFilterDefinition(String filterName)
                                     throws HibernateException
Description copied from interface: SessionFactory
Obtain the definition of a filter by name.

Specified by:
getFilterDefinition in interface SessionFactory
Parameters:
filterName - The name of the filter for which to obtain the definition.
Returns:
The filter definition.
Throws:
HibernateException - If no filter defined with the given name.

getDefinedFilterNames

public Set getDefinedFilterNames()
Description copied from interface: SessionFactory
Obtain a set of the names of all filters defined on this SessionFactory.

Specified by:
getDefinedFilterNames in interface SessionFactory
Returns:
The set of filter names.

getBatcherFactory

public BatcherFactory getBatcherFactory()

getIdentifierGenerator

public IdentifierGenerator getIdentifierGenerator(String rootEntityName)
Description copied from interface: SessionFactoryImplementor
Get the identifier generator for the hierarchy

Specified by:
getIdentifierGenerator in interface SessionFactoryImplementor

getEventListeners

public EventListeners getEventListeners()

getEntityNotFoundDelegate

public EntityNotFoundDelegate getEntityNotFoundDelegate()
Specified by:
getEntityNotFoundDelegate in interface SessionFactoryImplementor

getSqlFunctionRegistry

public SQLFunctionRegistry getSqlFunctionRegistry()
Specified by:
getSqlFunctionRegistry in interface SessionFactoryImplementor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SessionFactoryObjectFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class SessionFactoryObjectFactory

java.lang.Object
    extended by org.hibernate.impl.SessionFactoryObjectFactory
All Implemented Interfaces:
ObjectFactory
public class SessionFactoryObjectFactory
extends Object
implements ObjectFactory

Resolves SessionFactory JNDI lookups and deserialization

Constructor Summary
SessionFactoryObjectFactory()
Method Summary
static void | addInstance(String uid, String name, SessionFactory instance, Properties properties)
static Object | getInstance(String uid)
static Object | getNamedInstance(String name)
Object | getObjectInstance(Object reference, Name name, Context ctx, Hashtable env)
static void | removeInstance(String uid, String name, Properties properties)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SessionFactoryObjectFactory

public SessionFactoryObjectFactory()
Method Detail

getObjectInstance

public Object getObjectInstance(Object reference,
                                Name name,
                                Context ctx,
                                Hashtable env)
                         throws Exception
Specified by:
getObjectInstance in interface ObjectFactory
Throws:
Exception

addInstance

public static void addInstance(String uid,
                               String name,
                               SessionFactory instance,
                               Properties properties)

removeInstance

public static void removeInstance(String uid,
                                  String name,
                                  Properties properties)

getNamedInstance

public static Object getNamedInstance(String name)

getInstance

public static Object getInstance(String uid)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SessionImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class SessionImpl

java.lang.Object
    extended by org.hibernate.impl.AbstractSessionImpl
        extended by org.hibernate.impl.SessionImpl
All Implemented Interfaces:
EventSource, JDBCContext.Context, Serializable, Session, Session, SessionImplementor, TransactionFactory.Context
public final class SessionImpl
extends AbstractSessionImpl
implements EventSource, Session, JDBCContext.Context

Concrete implementation of a Session, and also the central, organizing component of Hibernate's internal implementation. As such, this class exposes two interfaces; Session itself, to the application, and SessionImplementor, to other components of Hibernate. This class is not threadsafe.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.impl.AbstractSessionImpl
factory
Method Summary
 void afterOperation(boolean success)
Check if there is a Hibernate or JTA transaction in progress and, if there is not, flush if necessary, make sure the connection has been committed (if it is not in autocommit mode) and run the after completion processing
 void afterScrollOperation()
 void afterTransactionBegin(Transaction tx)
We cannot rely upon this method being called! It is only called if we are using Hibernate Transaction API.
 void afterTransactionCompletion(boolean success, Transaction tx)
Notify the session that the transaction completed, so we no longer own the old locks.
protected  boolean autoFlushIfRequired(Set querySpaces)
detect in-memory changes, determine if the changes are to tables named in the query and, if so, complete execution the flush
 void beforeTransactionCompletion(Transaction tx)
Notify the session that the transaction is about to complete
 Transaction beginTransaction()
Begin a unit of work and return the associated Transaction object.
 String bestGuessEntityName(Object object)
The best guess entity name for an entity not in an association
 void cancelQuery()
Cancel execution of the current query.
 void clear()
Completely clear the session.
 Connection close()
End the Session by disconnecting from the JDBC connection and cleaning up.
 Connection connection()
Get the JDBC connection of this Session.

If the session is using aggressive collection release (as in a CMT environment), it is the application's responsibility to close the connection returned by this call.
 boolean contains(Object object)
Check if this instance is associated with this Session.
 Criteria createCriteria(Class persistentClass)
Create a new Criteria instance, for the given entity class, or a superclass of an entity class.
 Criteria createCriteria(Class persistentClass, String alias)
Create a new Criteria instance, for the given entity class, or a superclass of an entity class, with the given alias.
 Criteria createCriteria(String entityName)
Create a new Criteria instance, for the given entity name.
 Criteria createCriteria(String entityName, String alias)
Create a new Criteria instance, for the given entity name, with the given alias.
 Query createFilter(Object collection, String queryString)
Create a new instance of Query for the given collection and filter string.
 Query createQuery(String queryString)
Create a new instance of Query for the given HQL query string.
 SQLQuery createSQLQuery(String sql)
Create a new instance of SQLQuery for the given SQL query string.
 Query createSQLQuery(String sql, String[] returnAliases, Class[] returnClasses)
Create a new instance of Query for the given SQL string.
 Query createSQLQuery(String sql, String returnAlias, Class returnClass)
Create a new instance of Query for the given SQL string.
 void delete(Object object)
Delete a persistent object
 int delete(String query)
Delete all objects returned by the query.
 void delete(String entityName, Object object)
Delete a persistent object (by explicit entity name)
 int delete(String query, Object[] values, Type[] types)
Delete all objects returned by the query.
 void delete(String entityName, Object object, boolean isCascadeDeleteEnabled, Set transientEntities)
Delete a persistent object
 int delete(String query, Object value, Type type)
Delete all objects returned by the query.
 void disableFilter(String filterName)
Disable the named filter for the current session.
 Connection disconnect()
Disconnect the Session from the current JDBC connection.
 Filter enableFilter(String filterName)
Enable the named filter for this current session.
 void evict(Object object)
remove any hard references to the entity that are held by the infrastructure (references held by application or other persistant instances are okay)
 int executeNativeUpdate(NativeSQLQuerySpecification nativeQuerySpecification, QueryParameters queryParameters)
Execute a native SQL update or delete query
 int executeUpdate(String query, QueryParameters queryParameters)
Execute a HQL update or delete query
 Collection filter(Object collection, String filter)
Apply a filter to a persistent collection.
 Collection filter(Object collection, String filter, Object[] values, Type[] types)
Apply a filter to a persistent collection.
 Collection filter(Object collection, String filter, Object value, Type type)
Apply a filter to a persistent collection.
 List find(String query)
Retrieve a list of persistent objects using a hibernate query
 List find(String query, Object[] values, Type[] types)
Execute a query with bind parameters, binding an array of values to "?" parameters in the query string.
 List find(String query, Object value, Type type)
Execute a query with bind parameters, binding a value to a "?" parameter in the query string.
 void flush()
Force the Session to flush.
 void forceFlush(EntityEntry entityEntry)
Force an immediate flush
 Object get(Class entityClass, Serializable id)
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
 Object get(Class entityClass, Serializable id, LockMode lockMode)
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
 Object get(String entityName, Serializable id)
Return the persistent instance of the given named entity with the given identifier, or null if there is no such persistent instance.
 Object get(String entityName, Serializable id, LockMode lockMode)
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
 ActionQueue getActionQueue()
Get the ActionQueue for this session
 Batcher getBatcher()
Get the prepared statement Batcher for this session
 CacheMode getCacheMode()
Get the current cache mode.
 ConnectionReleaseMode getConnectionReleaseMode()
 Serializable getContextEntityIdentifier(Object object)
Get the id value for an object that is actually associated with the session.
 LockMode getCurrentLockMode(Object object)
Determine the current lock mode of the given object.
 int getDontFlushFromFind()
 Filter getEnabledFilter(String filterName)
Retrieve a currently enabled filter by name.
 Map getEnabledFilters()
Return the currently enabled filters.
 EntityMode getEntityMode()
Retrieve the entity mode in effect for this session.
 String getEntityName(Object object)
Return the entity name for a persistent entity
 EntityPersister getEntityPersister(String entityName, Object object)
Get the EntityPersister for any instance
 Object getEntityUsingInterceptor(EntityKey key)
Get the entity instance associated with the given Key, calling the Interceptor if necessary
 String getFetchProfile()
 Type getFilterParameterType(String filterParameterName)
Retreive the type for a given filter parrameter.
 Object getFilterParameterValue(String filterParameterName)
Retreive the currently set value for a filter parameter.
 FlushMode getFlushMode()
Get the current flush mode.
 Serializable getIdentifier(Object object)
Return the identifier of an entity instance cached by the Session, or throw an exception if the instance is transient or associated with a different Session.
 Interceptor getInterceptor()
Retrieves the interceptor currently in use by this event source.
 JDBCContext getJDBCContext()
 EventListeners getListeners()
Retrieves the configured event listeners from this event source.
 Query getNamedQuery(String queryName)
Get a Query instance for a named query or named native SQL query
 PersistenceContext getPersistenceContext()
Get the persistence context for this session
 Session getSession(EntityMode entityMode)
Starts a new Session with the given entity mode in effect.
 SessionFactory getSessionFactory()
Get the SessionFactory that created this instance.
 SessionStatistics getStatistics()
Get the statistics for this session.
 long getTimestamp()
System time before the start of the transaction
 Transaction getTransaction()
Get the Transaction instance associated with this session.
 String guessEntityName(Object object)
The guessed entity name for an entity not in an association
 Object immediateLoad(String entityName, Serializable id)
Load the data for the object with the specified id into a newly created object.
 void initializeCollection(PersistentCollection collection, boolean writing)
Initialize the collection (if not already initialized)
 Object instantiate(EntityPersister persister, Serializable id)
give the interceptor an opportunity to override the default instantiation
 Object instantiate(String entityName, Serializable id)
Instantiate the entity class, initializing with the given identifier
 Object internalLoad(String entityName, Serializable id, boolean eager, boolean nullable)
Load an instance without checking if it was deleted.
 boolean isAutoCloseSessionEnabled()
 boolean isConnected()
Check if the Session is currently connected.
 boolean isDirty()
Does this Session contain any changes which must be synchronized with the database? Would any SQL be executed if we flushed this session?
 boolean isEventSource()
 boolean isFlushBeforeCompletionEnabled()
 boolean isFlushModeNever()
 boolean isOpen()
Check if the Session is still open.
 boolean isTransactionInProgress()
Does this Session have an active Hibernate transaction or is there a JTA transaction in progress?
 Iterator iterate(String query)
Execute a query and return the results in an iterator.
 Iterator iterate(String query, Object[] values, Type[] types)
Execute a query and return the results in an iterator.
 Iterator iterate(String query, Object value, Type type)
Execute a query and return the results in an iterator.
 Iterator iterate(String query, QueryParameters queryParameters)
Execute an iterate() query
 Iterator iterateFilter(Object collection, String filter, QueryParameters queryParameters)
Iterate a filter
 List list(CriteriaImpl criteria)
Execute a criteria query
 List list(String query, QueryParameters queryParameters)
Execute a find() query
 List listCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
Execute an SQL Query
 List listFilter(Object collection, String filter, QueryParameters queryParameters)
Execute a filter
 Object load(Class entityClass, Serializable id)
Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.
 Object load(Class entityClass, Serializable id, LockMode lockMode)
Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.
 void load(Object object, Serializable id)
Read the persistent state associated with the given identifier into the given transient instance.
 Object load(String entityName, Serializable id)
Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.
 Object load(String entityName, Serializable id, LockMode lockMode)
Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.
 void lock(Object object, LockMode lockMode)
Obtain the specified lock level upon the given object.
 void lock(String entityName, Object object, LockMode lockMode)
Obtain the specified lock level upon the given object.
 void managedClose()
 void managedFlush()
 Object merge(Object object)
Copy the state of the given object onto the persistent object with the same identifier.
 Object merge(String entityName, Object object)
Copy the state of the given object onto the persistent object with the same identifier.
 void merge(String entityName, Object object, Map copiedAlready)
Cascade merge an entity instance
 void persist(Object object)
Make a transient instance persistent.
 void persist(String entityName, Object object)
Make a transient instance persistent.
 void persist(String entityName, Object object, Map copiedAlready)
Cascade persist an entity instance
 void persistOnFlush(Object object)
 void persistOnFlush(String entityName, Object object)
 void persistOnFlush(String entityName, Object object, Map copiedAlready)
Cascade persist an entity instance during the flush process
 void reconnect()
Obtain a new JDBC connection.
 void reconnect(Connection conn)
Reconnect to the given JDBC connection.
 void refresh(Object object)
Re-read the state of the given instance from the underlying database.
 void refresh(Object object, LockMode lockMode)
Re-read the state of the given instance from the underlying database, with the given LockMode.
 void refresh(Object object, Map refreshedAlready)
Cascade refesh an entity instance
 void replicate(Object obj, ReplicationMode replicationMode)
Persist the state of the given detached instance, reusing the current identifier value.
 void replicate(String entityName, Object obj, ReplicationMode replicationMode)
Persist the state of the given detached instance, reusing the current identifier value.
 Serializable save(Object obj)
Persist the given transient instance, first assigning a generated identifier.
 void save(Object obj, Serializable id)
Persist the given transient instance, using the given identifier.
 Serializable save(String entityName, Object object)
Persist the given transient instance, first assigning a generated identifier.
 void save(String entityName, Object object, Serializable id)
Persist the given transient instance, using the given identifier.
 void saveOrUpdate(Object object)
Either save() or update() the given instance, depending upon the value of its identifier property.
 void saveOrUpdate(String entityName, Object obj)
Either save() or update() the given instance, depending upon the value of its identifier property.
 Object saveOrUpdateCopy(Object object)
Copy the state of the given object onto the persistent object with the same identifier.
 Object saveOrUpdateCopy(Object object, Serializable id)
Copy the state of the given object onto the persistent object with the given identifier.
 Object saveOrUpdateCopy(String entityName, Object object)
Copy the state of the given object onto the persistent object with the same identifier.
 void saveOrUpdateCopy(String entityName, Object object, Map copiedAlready)
Cascade copy an entity instance
 Object saveOrUpdateCopy(String entityName, Object object, Serializable id)
Copy the state of the given object onto the persistent object with the given identifier.
 ScrollableResults scroll(CriteriaImpl criteria, ScrollMode scrollMode)
Execute a criteria query
 ScrollableResults scroll(String query, QueryParameters queryParameters)
Execute a scroll() query
 ScrollableResults scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
Execute an SQL Query
 void setAutoClear(boolean enabled)
Enable/disable automatic cache clearing from after transaction completion (for EJB3)
 void setCacheMode(CacheMode cacheMode)
Set the cache mode.
 void setFetchProfile(String fetchProfile)
 void setFlushMode(FlushMode flushMode)
Set the flush mode.
 void setReadOnly(Object entity, boolean readOnly)
Set an unmodified persistent object to read only mode, or a read only object to modifiable mode.
 boolean shouldAutoClose()
 String toString()
 void update(Object obj)
Update the persistent instance with the identifier of the given detached instance.
 void update(Object obj, Serializable id)
Update the persistent state associated with the given identifier.
 void update(String entityName, Object object)
Update the persistent instance with the identifier of the given detached instance.
 void update(String entityName, Object object, Serializable id)
Update the persistent state associated with the given identifier.
Methods inherited from class org.hibernate.impl.AbstractSessionImpl
errorIfClosed, getFactory, getHQLQueryPlan, getNamedSQLQuery, getNativeSQLQueryPlan, isClosed, list, scroll, setClosed
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.engine.SessionImplementor
getFactory, getNamedSQLQuery, isClosed, list, scroll
Methods inherited from interface org.hibernate.transaction.TransactionFactory.Context
getFactory, isClosed

Method Detail

getSession

public Session getSession(EntityMode entityMode)
Description copied from interface: Session
Starts a new Session with the given entity mode in effect. This secondary Session inherits the connection, transaction, and other context information from the primary Session. It doesn't need to be flushed or closed by the developer.

Specified by:
getSession in interface Session
Parameters:
entityMode - The entity mode to use for the new session.
Returns:
The new session

clear

public void clear()
Description copied from interface: Session
Completely clear the session. Evict all loaded instances and cancel all pending saves, updates and deletions. Do not close open iterators or instances of ScrollableResults.

Specified by:
clear in interface Session

getBatcher

public Batcher getBatcher()
Description copied from interface: SessionImplementor
Get the prepared statement Batcher for this session

Specified by:
getBatcher in interface SessionImplementor

getTimestamp

public long getTimestamp()
Description copied from interface: SessionImplementor
System time before the start of the transaction

Specified by:
getTimestamp in interface SessionImplementor

close

public Connection close()
                 throws HibernateException
Description copied from interface: Session
End the Session by disconnecting from the JDBC connection and cleaning up. It is not strictly necessary to close() the Session but you must at least disconnect() it.

Specified by:
close in interface Session
Returns:
the connection provided by the application or null
Throws:
HibernateException

getConnectionReleaseMode

public ConnectionReleaseMode getConnectionReleaseMode()
Specified by:
getConnectionReleaseMode in interface JDBCContext.Context

isAutoCloseSessionEnabled

public boolean isAutoCloseSessionEnabled()
Specified by:
isAutoCloseSessionEnabled in interface JDBCContext.Context

isOpen

public boolean isOpen()
Description copied from interface: Session
Check if the Session is still open.

Specified by:
isOpen in interface SessionImplementor

isFlushModeNever

public boolean isFlushModeNever()
Specified by:
isFlushModeNever in interface TransactionFactory.Context

isFlushBeforeCompletionEnabled

public boolean isFlushBeforeCompletionEnabled()
Specified by:
isFlushBeforeCompletionEnabled in interface TransactionFactory.Context

managedFlush

public void managedFlush()
Specified by:
managedFlush in interface TransactionFactory.Context

shouldAutoClose

public boolean shouldAutoClose()
Specified by:
shouldAutoClose in interface TransactionFactory.Context

managedClose

public void managedClose()
Specified by:
managedClose in interface TransactionFactory.Context

connection

public Connection connection()
                      throws HibernateException
Description copied from interface: Session
Get the JDBC connection of this Session.

If the session is using aggressive collection release (as in a CMT environment), it is the application's responsibility to close the connection returned by this call. Otherwise, the application should not close the connection.

Specified by:
connection in interface SessionImplementor
Throws:
HibernateException

isConnected

public boolean isConnected()
Description copied from interface: Session
Check if the Session is currently connected.

Specified by:
isConnected in interface SessionImplementor

isTransactionInProgress

public boolean isTransactionInProgress()
Description copied from interface: SessionImplementor
Does this Session have an active Hibernate transaction or is there a JTA transaction in progress?

Specified by:
isTransactionInProgress in interface SessionImplementor

disconnect

public Connection disconnect()
                      throws HibernateException
Description copied from interface: Session
Disconnect the Session from the current JDBC connection. If the connection was obtained by Hibernate close it and return it to the connection pool; otherwise, return it to the application.

This is used by applications which supply JDBC connections to Hibernate and which require long-sessions (or long-conversations)

Note that disconnect() called on a session where the connection was retrieved by Hibernate through its configured ConnectionProvider has no effect, provided ConnectionReleaseMode.ON_CLOSE is not in effect.

Specified by:
disconnect in interface Session
Returns:
the application-supplied connection or null
Throws:
HibernateException
See Also:
Session.reconnect(Connection), Session.reconnect()

reconnect

public void reconnect()
               throws HibernateException
Description copied from interface: Session
Obtain a new JDBC connection. This is used by applications which require long transactions and do not supply connections to the session.

Specified by:
reconnect in interface Session
Throws:
HibernateException
See Also:
Session.disconnect()

reconnect

public void reconnect(Connection conn)
               throws HibernateException
Description copied from interface: Session
Reconnect to the given JDBC connection. This is used by applications which require long transactions and use application-supplied connections.

Specified by:
reconnect in interface Session
Parameters:
conn - a JDBC connection
Throws:
HibernateException
See Also:
Session.disconnect()

beforeTransactionCompletion

public void beforeTransactionCompletion(Transaction tx)
Description copied from interface: SessionImplementor
Notify the session that the transaction is about to complete

Specified by:
beforeTransactionCompletion in interface SessionImplementor

setAutoClear

public void setAutoClear(boolean enabled)
Description copied from interface: SessionImplementor
Enable/disable automatic cache clearing from after transaction completion (for EJB3)

Specified by:
setAutoClear in interface SessionImplementor

afterOperation

public void afterOperation(boolean success)
Check if there is a Hibernate or JTA transaction in progress and, if there is not, flush if necessary, make sure the connection has been committed (if it is not in autocommit mode) and run the after completion processing

afterTransactionCompletion

public void afterTransactionCompletion(boolean success,
                                       Transaction tx)
Description copied from interface: SessionImplementor
Notify the session that the transaction completed, so we no longer own the old locks. (Also we should release cache softlocks.) May be called multiple times during the transaction completion process. Also called after an autocommit, in which case the second argument is null.

Specified by:
afterTransactionCompletion in interface SessionImplementor

getCurrentLockMode

public LockMode getCurrentLockMode(Object object)
                            throws HibernateException
Description copied from interface: Session
Determine the current lock mode of the given object.

Specified by:
getCurrentLockMode in interface Session
Parameters:
object - a persistent instance
Returns:
the current lock mode
Throws:
HibernateException

getEntityUsingInterceptor

public Object getEntityUsingInterceptor(EntityKey key)
                                 throws HibernateException
Description copied from interface: SessionImplementor
Get the entity instance associated with the given Key, calling the Interceptor if necessary

Specified by:
getEntityUsingInterceptor in interface SessionImplementor
Throws:
HibernateException

saveOrUpdate

public void saveOrUpdate(Object object)
                  throws HibernateException
Description copied from interface: Session
Either save() or update() the given instance, depending upon the value of its identifier property. By default the instance is always saved. This behaviour may be adjusted by specifying an unsaved-value attribute of the identifier property mapping. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Specified by:
saveOrUpdate in interface Session
Parameters:
object - a transient or detached instance containing new or updated state
Throws:
HibernateException
See Also:
Session.save(java.lang.Object), Session#update(Object object, Serializable id)

saveOrUpdate

public void saveOrUpdate(String entityName,
                         Object obj)
                  throws HibernateException
Description copied from interface: Session
Either save() or update() the given instance, depending upon the value of its identifier property. By default the instance is always saved. This behaviour may be adjusted by specifying an unsaved-value attribute of the identifier property mapping. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Specified by:
saveOrUpdate in interface Session
Parameters:
obj - a transient or detached instance containing new or updated state
Throws:
HibernateException
See Also:
Session.save(java.lang.Object), Session#update(Object object, Serializable id)

save

public void save(Object obj,
                 Serializable id)
          throws HibernateException
Description copied from interface: Session
Persist the given transient instance, using the given identifier. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Specified by:
save in interface Session
Parameters:
obj - a transient instance of a persistent class
id - an unused valid identifier
Throws:
HibernateException

save

public Serializable save(Object obj)
                  throws HibernateException
Description copied from interface: Session
Persist the given transient instance, first assigning a generated identifier. (Or using the current value of the identifier property if the assigned generator is used.) This operation cascades to associated instances if the association is mapped with cascade="save-update".

Specified by:
save in interface Session
Parameters:
obj - a transient instance of a persistent class
Returns:
the generated identifier
Throws:
HibernateException

save

public Serializable save(String entityName,
                         Object object)
                  throws HibernateException
Description copied from interface: Session
Persist the given transient instance, first assigning a generated identifier. (Or using the current value of the identifier property if the assigned generator is used.) This operation cascades to associated instances if the association is mapped with cascade="save-update".

Specified by:
save in interface Session
Parameters:
object - a transient instance of a persistent class
Returns:
the generated identifier
Throws:
HibernateException

save

public void save(String entityName,
                 Object object,
                 Serializable id)
          throws HibernateException
Description copied from interface: Session
Persist the given transient instance, using the given identifier. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Specified by:
save in interface Session
Parameters:
object - a transient instance of a persistent class
id - an unused valid identifier
Throws:
HibernateException

update

public void update(Object obj)
            throws HibernateException
Description copied from interface: Session
Update the persistent instance with the identifier of the given detached instance. If there is a persistent instance with the same identifier, an exception is thrown. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Specified by:
update in interface Session
Parameters:
obj - a detached instance containing updated state
Throws:
HibernateException

update

public void update(Object obj,
                   Serializable id)
            throws HibernateException
Description copied from interface: Session
Update the persistent state associated with the given identifier. An exception is thrown if there is a persistent instance with the same identifier in the current session. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Specified by:
update in interface Session
Parameters:
obj - a detached instance containing updated state
id - identifier of persistent instance
Throws:
HibernateException

update

public void update(String entityName,
                   Object object)
            throws HibernateException
Description copied from interface: Session
Update the persistent instance with the identifier of the given detached instance. If there is a persistent instance with the same identifier, an exception is thrown. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Specified by:
update in interface Session
Parameters:
object - a detached instance containing updated state
Throws:
HibernateException

update

public void update(String entityName,
                   Object object,
                   Serializable id)
            throws HibernateException
Description copied from interface: Session
Update the persistent state associated with the given identifier. An exception is thrown if there is a persistent instance with the same identifier in the current session. This operation cascades to associated instances if the association is mapped with cascade="save-update".

Specified by:
update in interface Session
Parameters:
object - a detached instance containing updated state
id - identifier of persistent instance
Throws:
HibernateException

lock

public void lock(String entityName,
                 Object object,
                 LockMode lockMode)
          throws HibernateException
Description copied from interface: Session
Obtain the specified lock level upon the given object. This may be used to perform a version check (LockMode.READ), to upgrade to a pessimistic lock (LockMode.UPGRADE), or to simply reassociate a transient instance with a session (LockMode.NONE). This operation cascades to associated instances if the association is mapped with cascade="lock".

Specified by:
lock in interface Session
Parameters:
object - a persistent or transient instance
lockMode - the lock level
Throws:
HibernateException

lock

public void lock(Object object,
                 LockMode lockMode)
          throws HibernateException
Description copied from interface: Session
Obtain the specified lock level upon the given object. This may be used to perform a version check (LockMode.READ), to upgrade to a pessimistic lock (LockMode.UPGRADE), or to simply reassociate a transient instance with a session (LockMode.NONE). This operation cascades to associated instances if the association is mapped with cascade="lock".

Specified by:
lock in interface Session
Parameters:
object - a persistent or transient instance
lockMode - the lock level
Throws:
HibernateException

persist

public void persist(String entityName,
                    Object object)
             throws HibernateException
Description copied from interface: Session
Make a transient instance persistent. This operation cascades to associated instances if the association is mapped with cascade="persist".

The semantics of this method are defined by JSR-220.

Specified by:
persist in interface Session
Parameters:
object - a transient instance to be made persistent
Throws:
HibernateException

persist

public void persist(Object object)
             throws HibernateException
Description copied from interface: Session
Make a transient instance persistent. This operation cascades to associated instances if the association is mapped with cascade="persist".

The semantics of this method are defined by JSR-220.

Specified by:
persist in interface Session
Parameters:
object - a transient instance to be made persistent
Throws:
HibernateException

persist

public void persist(String entityName,
                    Object object,
                    Map copiedAlready)
             throws HibernateException
Description copied from interface: EventSource
Cascade persist an entity instance

Specified by:
persist in interface EventSource
Throws:
HibernateException

persistOnFlush

public void persistOnFlush(String entityName,
                           Object object)
                    throws HibernateException
Throws:
HibernateException

persistOnFlush

public void persistOnFlush(Object object)
                    throws HibernateException
Throws:
HibernateException

persistOnFlush

public void persistOnFlush(String entityName,
                           Object object,
                           Map copiedAlready)
                    throws HibernateException
Description copied from interface: EventSource
Cascade persist an entity instance during the flush process

Specified by:
persistOnFlush in interface EventSource
Throws:
HibernateException

merge

public Object merge(String entityName,
                    Object object)
             throws HibernateException
Description copied from interface: Session
Copy the state of the given object onto the persistent object with the same identifier. If there is no persistent instance currently associated with the session, it will be loaded. Return the persistent instance. If the given instance is unsaved, save a copy of and return it as a newly persistent instance. The given instance does not become associated with the session. This operation cascades to associated instances if the association is mapped with cascade="merge".

The semantics of this method are defined by JSR-220.

Specified by:
merge in interface Session
Parameters:
object - a detached instance with state to be copied
Returns:
an updated persistent instance
Throws:
HibernateException

merge

public Object merge(Object object)
             throws HibernateException
Description copied from interface: Session
Copy the state of the given object onto the persistent object with the same identifier. If there is no persistent instance currently associated with the session, it will be loaded. Return the persistent instance. If the given instance is unsaved, save a copy of and return it as a newly persistent instance. The given instance does not become associated with the session. This operation cascades to associated instances if the association is mapped with cascade="merge".

The semantics of this method are defined by JSR-220.

Specified by:
merge in interface Session
Parameters:
object - a detached instance with state to be copied
Returns:
an updated persistent instance
Throws:
HibernateException

merge

public void merge(String entityName,
                  Object object,
                  Map copiedAlready)
           throws HibernateException
Description copied from interface: EventSource
Cascade merge an entity instance

Specified by:
merge in interface EventSource
Throws:
HibernateException

saveOrUpdateCopy

public Object saveOrUpdateCopy(String entityName,
                               Object object)
                        throws HibernateException
Description copied from interface: Session
Copy the state of the given object onto the persistent object with the same identifier. If there is no persistent instance currently associated with the session, it will be loaded. Return the persistent instance. If the given instance is unsaved or does not exist in the database, save it and return it as a newly persistent instance. Otherwise, the given instance does not become associated with the session.

Specified by:
saveOrUpdateCopy in interface Session
Parameters:
object - a transient instance with state to be copied
Returns:
an updated persistent instance
Throws:
HibernateException

saveOrUpdateCopy

public Object saveOrUpdateCopy(Object object)
                        throws HibernateException
Description copied from interface: Session
Copy the state of the given object onto the persistent object with the same identifier. If there is no persistent instance currently associated with the session, it will be loaded. Return the persistent instance. If the given instance is unsaved or does not exist in the database, save it and return it as a newly persistent instance. Otherwise, the given instance does not become associated with the session.

Specified by:
saveOrUpdateCopy in interface Session
Parameters:
object - a transient instance with state to be copied
Returns:
an updated persistent instance
Throws:
HibernateException

saveOrUpdateCopy

public Object saveOrUpdateCopy(String entityName,
                               Object object,
                               Serializable id)
                        throws HibernateException
Description copied from interface: Session
Copy the state of the given object onto the persistent object with the given identifier. If there is no persistent instance currently associated with the session, it will be loaded. Return the persistent instance. If there is no database row with the given identifier, save the given instance and return it as a newly persistent instance. Otherwise, the given instance does not become associated with the session.

Specified by:
saveOrUpdateCopy in interface Session
Parameters:
object - a persistent or transient instance with state to be copied
id - the identifier of the instance to copy to
Returns:
an updated persistent instance
Throws:
HibernateException

saveOrUpdateCopy

public Object saveOrUpdateCopy(Object object,
                               Serializable id)
                        throws HibernateException
Description copied from interface: Session
Copy the state of the given object onto the persistent object with the given identifier. If there is no persistent instance currently associated with the session, it will be loaded. Return the persistent instance. If there is no database row with the given identifier, save the given instance and return it as a newly persistent instance. Otherwise, the given instance does not become associated with the session.

Specified by:
saveOrUpdateCopy in interface Session
Parameters:
object - a persistent or transient instance with state to be copied
id - the identifier of the instance to copy to
Returns:
an updated persistent instance
Throws:
HibernateException

saveOrUpdateCopy

public void saveOrUpdateCopy(String entityName,
                             Object object,
                             Map copiedAlready)
                      throws HibernateException
Description copied from interface: EventSource
Cascade copy an entity instance

Specified by:
saveOrUpdateCopy in interface EventSource
Throws:
HibernateException

delete

public void delete(Object object)
            throws HibernateException
Delete a persistent object

Specified by:
delete in interface Session
Parameters:
object - the instance to be removed
Throws:
HibernateException

delete

public void delete(String entityName,
                   Object object)
            throws HibernateException
Delete a persistent object (by explicit entity name)

Specified by:
delete in interface Session
Parameters:
entityName - The entity name for the instance to be removed.
object - the instance to be removed
Throws:
HibernateException

delete

public void delete(String entityName,
                   Object object,
                   boolean isCascadeDeleteEnabled,
                   Set transientEntities)
            throws HibernateException
Delete a persistent object

Specified by:
delete in interface EventSource
Throws:
HibernateException

load

public void load(Object object,
                 Serializable id)
          throws HibernateException
Description copied from interface: Session
Read the persistent state associated with the given identifier into the given transient instance.

Specified by:
load in interface Session
Parameters:
object - an "empty" instance of the persistent class
id - a valid identifier of an existing persistent instance of the class
Throws:
HibernateException

load

public Object load(Class entityClass,
                   Serializable id)
            throws HibernateException
Description copied from interface: Session
Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.

You should not use this method to determine if an instance exists (use get() instead). Use this only to retrieve an instance that you assume exists, where non-existence would be an actual error.

Specified by:
load in interface Session
Parameters:
entityClass - a persistent class
id - a valid identifier of an existing persistent instance of the class
Returns:
the persistent instance or proxy
Throws:
HibernateException

load

public Object load(String entityName,
                   Serializable id)
            throws HibernateException
Description copied from interface: Session
Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.

You should not use this method to determine if an instance exists (use get() instead). Use this only to retrieve an instance that you assume exists, where non-existence would be an actual error.

Specified by:
load in interface Session
Parameters:
entityName - a persistent class
id - a valid identifier of an existing persistent instance of the class
Returns:
the persistent instance or proxy
Throws:
HibernateException

get

public Object get(Class entityClass,
                  Serializable id)
           throws HibernateException
Description copied from interface: Session
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance. (If the instance, or a proxy for the instance, is already associated with the session, return that instance or proxy.)

Specified by:
get in interface Session
Parameters:
entityClass - a persistent class
id - an identifier
Returns:
a persistent instance or null
Throws:
HibernateException

get

public Object get(String entityName,
                  Serializable id)
           throws HibernateException
Description copied from interface: Session
Return the persistent instance of the given named entity with the given identifier, or null if there is no such persistent instance. (If the instance, or a proxy for the instance, is already associated with the session, return that instance or proxy.)

Specified by:
get in interface Session
Parameters:
entityName - the entity name
id - an identifier
Returns:
a persistent instance or null
Throws:
HibernateException

immediateLoad

public Object immediateLoad(String entityName,
                            Serializable id)
                     throws HibernateException
Load the data for the object with the specified id into a newly created object. This is only called when lazily initializing a proxy. Do NOT return a proxy.

Specified by:
immediateLoad in interface SessionImplementor
Throws:
HibernateException

internalLoad

public Object internalLoad(String entityName,
                           Serializable id,
                           boolean eager,
                           boolean nullable)
                    throws HibernateException
Description copied from interface: SessionImplementor
Load an instance without checking if it was deleted. When nullable is disabled this method may create a new proxy or return an existing proxy; if it does not exist, throw an exception. When nullable is enabled, the method does not create new proxies (but might return an existing proxy); if it does not exist, return null. When eager is enabled, the object is eagerly fetched

Specified by:
internalLoad in interface SessionImplementor
Throws:
HibernateException

load

public Object load(Class entityClass,
                   Serializable id,
                   LockMode lockMode)
            throws HibernateException
Description copied from interface: Session
Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.

Specified by:
load in interface Session
Parameters:
entityClass - a persistent class
id - a valid identifier of an existing persistent instance of the class
lockMode - the lock level
Returns:
the persistent instance or proxy
Throws:
HibernateException

load

public Object load(String entityName,
                   Serializable id,
                   LockMode lockMode)
            throws HibernateException
Description copied from interface: Session
Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.

Specified by:
load in interface Session
Parameters:
entityName - a persistent class
id - a valid identifier of an existing persistent instance of the class
lockMode - the lock level
Returns:
the persistent instance or proxy
Throws:
HibernateException

get

public Object get(Class entityClass,
                  Serializable id,
                  LockMode lockMode)
           throws HibernateException
Description copied from interface: Session
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance. Obtain the specified lock mode if the instance exists.

Specified by:
get in interface Session
Parameters:
entityClass - a persistent class
id - an identifier
lockMode - the lock mode
Returns:
a persistent instance or null
Throws:
HibernateException

get

public Object get(String entityName,
                  Serializable id,
                  LockMode lockMode)
           throws HibernateException
Description copied from interface: Session
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance. Obtain the specified lock mode if the instance exists.

Specified by:
get in interface Session
Parameters:
entityName - the entity name
id - an identifier
lockMode - the lock mode
Returns:
a persistent instance or null
Throws:
HibernateException

refresh

public void refresh(Object object)
             throws HibernateException
Description copied from interface: Session
Re-read the state of the given instance from the underlying database. It is inadvisable to use this to implement long-running sessions that span many business tasks. This method is, however, useful in certain special circumstances. For example
  • where a database trigger alters the object state upon insert or update
  • after executing direct SQL (eg. a mass update) in the same session
  • after inserting a Blob or Clob

Specified by:
refresh in interface Session
Parameters:
object - a persistent or detached instance
Throws:
HibernateException

refresh

public void refresh(Object object,
                    LockMode lockMode)
             throws HibernateException
Description copied from interface: Session
Re-read the state of the given instance from the underlying database, with the given LockMode. It is inadvisable to use this to implement long-running sessions that span many business tasks. This method is, however, useful in certain special circumstances.

Specified by:
refresh in interface Session
Parameters:
object - a persistent or detached instance
lockMode - the lock mode to use
Throws:
HibernateException

refresh

public void refresh(Object object,
                    Map refreshedAlready)
             throws HibernateException
Description copied from interface: EventSource
Cascade refesh an entity instance

Specified by:
refresh in interface EventSource
Throws:
HibernateException

replicate

public void replicate(Object obj,
                      ReplicationMode replicationMode)
               throws HibernateException
Description copied from interface: Session
Persist the state of the given detached instance, reusing the current identifier value. This operation cascades to associated instances if the association is mapped with cascade="replicate".

Specified by:
replicate in interface Session
Parameters:
obj - a detached instance of a persistent class
Throws:
HibernateException

replicate

public void replicate(String entityName,
                      Object obj,
                      ReplicationMode replicationMode)
               throws HibernateException
Description copied from interface: Session
Persist the state of the given detached instance, reusing the current identifier value. This operation cascades to associated instances if the association is mapped with cascade="replicate".

Specified by:
replicate in interface Session
Parameters:
obj - a detached instance of a persistent class
Throws:
HibernateException

evict

public void evict(Object object)
           throws HibernateException
remove any hard references to the entity that are held by the infrastructure (references held by application or other persistant instances are okay)

Specified by:
evict in interface Session
Parameters:
object - a persistent instance
Throws:
HibernateException

autoFlushIfRequired

protected boolean autoFlushIfRequired(Set querySpaces)
                               throws HibernateException
detect in-memory changes, determine if the changes are to tables named in the query and, if so, complete execution the flush

Throws:
HibernateException

isDirty

public boolean isDirty()
                throws HibernateException
Description copied from interface: Session
Does this Session contain any changes which must be synchronized with the database? Would any SQL be executed if we flushed this session?

Specified by:
isDirty in interface Session
Returns:
boolean
Throws:
HibernateException

flush

public void flush()
           throws HibernateException
Description copied from interface: Session
Force the Session to flush. Must be called at the end of a unit of work, before commiting the transaction and closing the session (Transaction.commit() calls this method). Flushing is the process of synchronising the underlying persistent store with persistable state held in memory.

Specified by:
flush in interface SessionImplementor
Throws:
HibernateException

forceFlush

public void forceFlush(EntityEntry entityEntry)
                throws HibernateException
Description copied from interface: EventSource
Force an immediate flush

Specified by:
forceFlush in interface EventSource
Throws:
HibernateException

getEnabledFilter

public Filter getEnabledFilter(String filterName)
Description copied from interface: Session
Retrieve a currently enabled filter by name.

Specified by:
getEnabledFilter in interface Session
Parameters:
filterName - The name of the filter to be retrieved.
Returns:
The Filter instance representing the enabled fiter.

enableFilter

public Filter enableFilter(String filterName)
Description copied from interface: Session
Enable the named filter for this current session.

Specified by:
enableFilter in interface Session
Parameters:
filterName - The name of the filter to be enabled.
Returns:
The Filter instance representing the enabled fiter.

disableFilter

public void disableFilter(String filterName)
Description copied from interface: Session
Disable the named filter for the current session.

Specified by:
disableFilter in interface Session
Parameters:
filterName - The name of the filter to be disabled.

getFilterParameterValue

public Object getFilterParameterValue(String filterParameterName)
Description copied from interface: SessionImplementor
Retreive the currently set value for a filter parameter.

Specified by:
getFilterParameterValue in interface SessionImplementor
Parameters:
filterParameterName - The filter parameter name in the format {FILTER_NAME.PARAMETER_NAME}.
Returns:
The filter parameter value.

getFilterParameterType

public Type getFilterParameterType(String filterParameterName)
Description copied from interface: SessionImplementor
Retreive the type for a given filter parrameter.

Specified by:
getFilterParameterType in interface SessionImplementor
Parameters:
filterParameterName - The filter parameter name in the format {FILTER_NAME.PARAMETER_NAME}.

getEnabledFilters

public Map getEnabledFilters()
Description copied from interface: SessionImplementor
Return the currently enabled filters. The filter map is keyed by filter name, with values corresponding to the FilterImpl instance.

Specified by:
getEnabledFilters in interface SessionImplementor
Returns:
The currently enabled filters.

find

public List find(String query)
          throws HibernateException
Retrieve a list of persistent objects using a hibernate query

Specified by:
find in interface Session
Parameters:
query - a query expressed in Hibernate's query language
Returns:
a distinct list of instances (or arrays of instances)
Throws:
HibernateException

find

public List find(String query,
                 Object value,
                 Type type)
          throws HibernateException
Description copied from interface: Session
Execute a query with bind parameters, binding a value to a "?" parameter in the query string.

Specified by:
find in interface Session
Parameters:
query - the query string
value - a value to be bound to a "?" placeholder (JDBC IN parameter).
type - the Hibernate type of the value
Returns:
a distinct list of instances (or arrays of instances)
Throws:
HibernateException
See Also:
for access to Type instances

find

public List find(String query,
                 Object[] values,
                 Type[] types)
          throws HibernateException
Description copied from interface: Session
Execute a query with bind parameters, binding an array of values to "?" parameters in the query string.

Specified by:
find in interface Session
Parameters:
query - the query string
values - an array of values to be bound to the "?" placeholders (JDBC IN parameters).
types - an array of Hibernate types of the values
Returns:
a distinct list of instances
Throws:
HibernateException
See Also:
for access to Type instances

list

public List list(String query,
                 QueryParameters queryParameters)
          throws HibernateException
Description copied from interface: SessionImplementor
Execute a find() query

Specified by:
list in interface SessionImplementor
Throws:
HibernateException

executeUpdate

public int executeUpdate(String query,
                         QueryParameters queryParameters)
                  throws HibernateException
Description copied from interface: SessionImplementor
Execute a HQL update or delete query

Specified by:
executeUpdate in interface SessionImplementor
Throws:
HibernateException

executeNativeUpdate

public int executeNativeUpdate(NativeSQLQuerySpecification nativeQuerySpecification,
                               QueryParameters queryParameters)
                        throws HibernateException
Description copied from interface: SessionImplementor
Execute a native SQL update or delete query

Specified by:
executeNativeUpdate in interface SessionImplementor
Throws:
HibernateException

iterate

public Iterator iterate(String query)
                 throws HibernateException
Description copied from interface: Session
Execute a query and return the results in an iterator. If the query has multiple return values, values will be returned in an array of type Object[].

Entities returned as results are initialized on demand. The first SQL query returns identifiers only. So iterate() is usually a less efficient way to retrieve objects than find().

Specified by:
iterate in interface Session
Parameters:
query - the query string
Returns:
an iterator
Throws:
HibernateException

iterate

public Iterator iterate(String query,
                        Object value,
                        Type type)
                 throws HibernateException
Description copied from interface: Session
Execute a query and return the results in an iterator. Write the given value to "?" in the query string. If the query has multiple return values, values will be returned in an array of type Object[].

Entities returned as results are initialized on demand. The first SQL query returns identifiers only. So iterate() is usually a less efficient way to retrieve objects than find().

Specified by:
iterate in interface Session
Parameters:
query - the query string
value - a value to be witten to a "?" placeholder in the query string
type - the hibernate type of value
Returns:
an iterator
Throws:
HibernateException

iterate

public Iterator iterate(String query,
                        Object[] values,
                        Type[] types)
                 throws HibernateException
Description copied from interface: Session
Execute a query and return the results in an iterator. Write the given values to "?" in the query string. If the query has multiple return values, values will be returned in an array of type Object[].

Entities returned as results are initialized on demand. The first SQL query returns identifiers only. So iterate() is usually a less efficient way to retrieve objects than find().

Specified by:
iterate in interface Session
Parameters:
query - the query string
values - a list of values to be written to "?" placeholders in the query
types - a list of Hibernate types of the values
Returns:
an iterator
Throws:
HibernateException

iterate

public Iterator iterate(String query,
                        QueryParameters queryParameters)
                 throws HibernateException
Description copied from interface: SessionImplementor
Execute an iterate() query

Specified by:
iterate in interface SessionImplementor
Throws:
HibernateException

scroll

public ScrollableResults scroll(String query,
                                QueryParameters queryParameters)
                         throws HibernateException
Description copied from interface: SessionImplementor
Execute a scroll() query

Specified by:
scroll in interface SessionImplementor
Throws:
HibernateException

delete

public int delete(String query)
           throws HibernateException
Description copied from interface: Session
Delete all objects returned by the query. Return the number of objects deleted.

Note that this is very different from the delete-statement support added in HQL since 3.1. The functionality here is to actually peform the query and then iterate the results calling Session.delete(Object) individually.

Specified by:
delete in interface Session
Parameters:
query - the query string
Returns:
the number of instances deleted
Throws:
HibernateException

delete

public int delete(String query,
                  Object value,
                  Type type)
           throws HibernateException
Description copied from interface: Session
Delete all objects returned by the query. Return the number of objects deleted.

Note that this is very different from the delete-statement support added in HQL since 3.1. The functionality here is to actually peform the query and then iterate the results calling Session.delete(Object) individually.

Specified by:
delete in interface Session
Parameters:
query - the query string
value - a value to be witten to a "?" placeholder in the query string.
type - the hibernate type of value.
Returns:
the number of instances deleted
Throws:
HibernateException

delete

public int delete(String query,
                  Object[] values,
                  Type[] types)
           throws HibernateException
Description copied from interface: Session
Delete all objects returned by the query. Return the number of objects deleted.

Note that this is very different from the delete-statement support added in HQL since 3.1. The functionality here is to actually peform the query and then iterate the results calling Session.delete(Object) individually.

Specified by:
delete in interface Session
Parameters:
query - the query string
values - a list of values to be written to "?" placeholders in the query.
types - a list of Hibernate types of the values
Returns:
the number of instances deleted
Throws:
HibernateException

createFilter

public Query createFilter(Object collection,
                          String queryString)
Description copied from interface: Session
Create a new instance of Query for the given collection and filter string.

Specified by:
createFilter in interface Session
Parameters:
collection - a persistent collection
queryString - a Hibernate query
Returns:
Query

getNamedQuery

public Query getNamedQuery(String queryName)
                    throws MappingException
Description copied from interface: SessionImplementor
Get a Query instance for a named query or named native SQL query

Specified by:
getNamedQuery in interface SessionImplementor
Overrides:
getNamedQuery in class AbstractSessionImpl
Throws:
MappingException

instantiate

public Object instantiate(String entityName,
                          Serializable id)
                   throws HibernateException
Description copied from interface: SessionImplementor
Instantiate the entity class, initializing with the given identifier

Specified by:
instantiate in interface SessionImplementor
Throws:
HibernateException

instantiate

public Object instantiate(EntityPersister persister,
                          Serializable id)
                   throws HibernateException
give the interceptor an opportunity to override the default instantiation

Specified by:
instantiate in interface EventSource
Throws:
HibernateException

getEntityMode

public EntityMode getEntityMode()
Description copied from interface: Session
Retrieve the entity mode in effect for this session.

Specified by:
getEntityMode in interface SessionImplementor

setFlushMode

public void setFlushMode(FlushMode flushMode)
Description copied from interface: Session
Set the flush mode. The flush mode determines at which points Hibernate automatically flushes the session. For a readonly session, it is reasonable to set the flush mode to FlushMode.NEVER at the start of the session (in order to achieve some extra performance).

Specified by:
setFlushMode in interface SessionImplementor

getFlushMode

public FlushMode getFlushMode()
Description copied from interface: Session
Get the current flush mode.

Specified by:
getFlushMode in interface SessionImplementor

getCacheMode

public CacheMode getCacheMode()
Description copied from interface: Session
Get the current cache mode.

Specified by:
getCacheMode in interface SessionImplementor

setCacheMode

public void setCacheMode(CacheMode cacheMode)
Description copied from interface: Session
Set the cache mode.

Specified by:
setCacheMode in interface SessionImplementor

getTransaction

public Transaction getTransaction()
                           throws HibernateException
Description copied from interface: Session
Get the Transaction instance associated with this session. The class of the returned Transaction object is determined by the property hibernate.transaction_factory.

Specified by:
getTransaction in interface Session
Returns:
a Transaction instance
Throws:
HibernateException
See Also:
Transaction

beginTransaction

public Transaction beginTransaction()
                             throws HibernateException
Description copied from interface: Session
Begin a unit of work and return the associated Transaction object. If a new underlying transaction is required, begin the transaction. Otherwise continue the new work in the context of the existing underlying transaction. The class of the returned Transaction object is determined by the property hibernate.transaction_factory.

Specified by:
beginTransaction in interface Session
Returns:
a Transaction instance
Throws:
HibernateException
See Also:
Transaction

afterTransactionBegin

public void afterTransactionBegin(Transaction tx)
Description copied from interface: JDBCContext.Context
We cannot rely upon this method being called! It is only called if we are using Hibernate Transaction API.

Specified by:
afterTransactionBegin in interface JDBCContext.Context

getEntityPersister

public EntityPersister getEntityPersister(String entityName,
                                          Object object)
Description copied from interface: SessionImplementor
Get the EntityPersister for any instance

Specified by:
getEntityPersister in interface SessionImplementor
Parameters:
entityName - optional entity name
object - the entity instance

getIdentifier

public Serializable getIdentifier(Object object)
                           throws HibernateException
Description copied from interface: Session
Return the identifier of an entity instance cached by the Session, or throw an exception if the instance is transient or associated with a different Session.

Specified by:
getIdentifier in interface Session
Parameters:
object - a persistent instance
Returns:
the identifier
Throws:
HibernateException

getContextEntityIdentifier

public Serializable getContextEntityIdentifier(Object object)
Get the id value for an object that is actually associated with the session. This is a bit stricter than getEntityIdentifierIfNotUnsaved().

Specified by:
getContextEntityIdentifier in interface SessionImplementor

filter

public Collection filter(Object collection,
                         String filter)
                  throws HibernateException
Description copied from interface: Session
Apply a filter to a persistent collection. A filter is a Hibernate query that may refer to this, the collection element. Filters allow efficient access to very large lazy collections. (Executing the filter does not initialize the collection.)

Specified by:
filter in interface Session
Parameters:
collection - a persistent collection to filter
filter - a filter query string
Returns:
Collection the resulting collection
Throws:
HibernateException

filter

public Collection filter(Object collection,
                         String filter,
                         Object value,
                         Type type)
                  throws HibernateException
Description copied from interface: Session
Apply a filter to a persistent collection. A filter is a Hibernate query that may refer to this, the collection element.

Specified by:
filter in interface Session
Parameters:
collection - a persistent collection to filter
filter - a filter query string
value - a value to be witten to a "?" placeholder in the query string
type - the hibernate type of value
Returns:
Collection
Throws:
HibernateException

filter

public Collection filter(Object collection,
                         String filter,
                         Object[] values,
                         Type[] types)
                  throws HibernateException
Description copied from interface: Session
Apply a filter to a persistent collection. Bind the given parameters to "?" placeholders. A filter is a Hibernate query that may refer to this, the collection element.

Specified by:
filter in interface Session
Parameters:
collection - a persistent collection to filter
filter - a filter query string
values - a list of values to be written to "?" placeholders in the query
types - a list of Hibernate types of the values
Returns:
Collection
Throws:
HibernateException

listFilter

public List listFilter(Object collection,
                       String filter,
                       QueryParameters queryParameters)
                throws HibernateException
Description copied from interface: SessionImplementor
Execute a filter

Specified by:
listFilter in interface SessionImplementor
Throws:
HibernateException

iterateFilter

public Iterator iterateFilter(Object collection,
                              String filter,
                              QueryParameters queryParameters)
                       throws HibernateException
Description copied from interface: SessionImplementor
Iterate a filter

Specified by:
iterateFilter in interface SessionImplementor
Throws:
HibernateException

createCriteria

public Criteria createCriteria(Class persistentClass,
                               String alias)
Description copied from interface: Session
Create a new Criteria instance, for the given entity class, or a superclass of an entity class, with the given alias.

Specified by:
createCriteria in interface Session
Parameters:
persistentClass - a class, which is persistent, or has persistent subclasses
Returns:
Criteria

createCriteria

public Criteria createCriteria(String entityName,
                               String alias)
Description copied from interface: Session
Create a new Criteria instance, for the given entity name, with the given alias.

Specified by:
createCriteria in interface Session
Parameters:
entityName -
Returns:
Criteria

createCriteria

public Criteria createCriteria(Class persistentClass)
Description copied from interface: Session
Create a new Criteria instance, for the given entity class, or a superclass of an entity class.

Specified by:
createCriteria in interface Session
Parameters:
persistentClass - a class, which is persistent, or has persistent subclasses
Returns:
Criteria

createCriteria

public Criteria createCriteria(String entityName)
Description copied from interface: Session
Create a new Criteria instance, for the given entity name.

Specified by:
createCriteria in interface Session
Parameters:
entityName -
Returns:
Criteria

scroll

public ScrollableResults scroll(CriteriaImpl criteria,
                                ScrollMode scrollMode)
Description copied from interface: SessionImplementor
Execute a criteria query

Specified by:
scroll in interface SessionImplementor

list

public List list(CriteriaImpl criteria)
          throws HibernateException
Description copied from interface: SessionImplementor
Execute a criteria query

Specified by:
list in interface SessionImplementor
Throws:
HibernateException

contains

public boolean contains(Object object)
Description copied from interface: Session
Check if this instance is associated with this Session.

Specified by:
contains in interface Session
Parameters:
object - an instance of a persistent class
Returns:
true if the given instance is associated with this Session

createQuery

public Query createQuery(String queryString)
Description copied from interface: Session
Create a new instance of Query for the given HQL query string.

Specified by:
createQuery in interface Session
Overrides:
createQuery in class AbstractSessionImpl

createSQLQuery

public SQLQuery createSQLQuery(String sql)
Description copied from interface: Session
Create a new instance of SQLQuery for the given SQL query string.

Specified by:
createSQLQuery in interface Session
Overrides:
createSQLQuery in class AbstractSessionImpl

createSQLQuery

public Query createSQLQuery(String sql,
                            String returnAlias,
                            Class returnClass)
Description copied from interface: Session
Create a new instance of Query for the given SQL string.

Specified by:
createSQLQuery in interface Session
Parameters:
sql - a query expressed in SQL
returnAlias - a table alias that appears inside {} in the SQL string
returnClass - the returned persistent class

createSQLQuery

public Query createSQLQuery(String sql,
                            String[] returnAliases,
                            Class[] returnClasses)
Description copied from interface: Session
Create a new instance of Query for the given SQL string.

Specified by:
createSQLQuery in interface Session
Parameters:
sql - a query expressed in SQL
returnAliases - an array of table aliases that appear inside {} in the SQL string
returnClasses - the returned persistent classes

scrollCustomQuery

public ScrollableResults scrollCustomQuery(CustomQuery customQuery,
                                           QueryParameters queryParameters)
                                    throws HibernateException
Description copied from interface: SessionImplementor
Execute an SQL Query

Specified by:
scrollCustomQuery in interface SessionImplementor
Throws:
HibernateException

listCustomQuery

public List listCustomQuery(CustomQuery customQuery,
                            QueryParameters queryParameters)
                     throws HibernateException
Description copied from interface: SessionImplementor
Execute an SQL Query

Specified by:
listCustomQuery in interface SessionImplementor
Throws:
HibernateException

getSessionFactory

public SessionFactory getSessionFactory()
Description copied from interface: Session
Get the SessionFactory that created this instance.

Specified by:
getSessionFactory in interface Session
See Also:
SessionFactory

initializeCollection

public void initializeCollection(PersistentCollection collection,
                                 boolean writing)
                          throws HibernateException
Description copied from interface: SessionImplementor
Initialize the collection (if not already initialized)

Specified by:
initializeCollection in interface SessionImplementor
Throws:
HibernateException

bestGuessEntityName

public String bestGuessEntityName(Object object)
Description copied from interface: SessionImplementor
The best guess entity name for an entity not in an association

Specified by:
bestGuessEntityName in interface SessionImplementor

getEntityName

public String getEntityName(Object object)
Description copied from interface: Session
Return the entity name for a persistent entity

Specified by:
getEntityName in interface Session
Parameters:
object - a persistent entity
Returns:
the entity name

guessEntityName

public String guessEntityName(Object object)
                       throws HibernateException
Description copied from interface: SessionImplementor
The guessed entity name for an entity not in an association

Specified by:
guessEntityName in interface SessionImplementor
Throws:
HibernateException

cancelQuery

public void cancelQuery()
                 throws HibernateException
Description copied from interface: Session
Cancel execution of the current query. May be called from one thread to stop execution of a query in another thread. Use with care!

Specified by:
cancelQuery in interface Session
Throws:
HibernateException

getInterceptor

public Interceptor getInterceptor()
Description copied from interface: SessionImplementor
Retrieves the interceptor currently in use by this event source.

Specified by:
getInterceptor in interface SessionImplementor
Returns:
The interceptor.

getDontFlushFromFind

public int getDontFlushFromFind()
Specified by:
getDontFlushFromFind in interface SessionImplementor

toString

public String toString()

getListeners

public EventListeners getListeners()
Description copied from interface: SessionImplementor
Retrieves the configured event listeners from this event source.

Specified by:
getListeners in interface SessionImplementor
Returns:
The configured event listeners.

getActionQueue

public ActionQueue getActionQueue()
Description copied from interface: EventSource
Get the ActionQueue for this session

Specified by:
getActionQueue in interface EventSource

getPersistenceContext

public PersistenceContext getPersistenceContext()
Description copied from interface: SessionImplementor
Get the persistence context for this session

Specified by:
getPersistenceContext in interface SessionImplementor

getStatistics

public SessionStatistics getStatistics()
Description copied from interface: Session
Get the statistics for this session.

Specified by:
getStatistics in interface Session

isEventSource

public boolean isEventSource()
Specified by:
isEventSource in interface SessionImplementor

setReadOnly

public void setReadOnly(Object entity,
                        boolean readOnly)
Description copied from interface: Session
Set an unmodified persistent object to read only mode, or a read only object to modifiable mode. In read only mode, no snapshot is maintained and the instance is never dirty checked.

Specified by:
setReadOnly in interface Session
See Also:
Query.setReadOnly(boolean)

afterScrollOperation

public void afterScrollOperation()
Specified by:
afterScrollOperation in interface SessionImplementor

getFetchProfile

public String getFetchProfile()
Specified by:
getFetchProfile in interface SessionImplementor

getJDBCContext

public JDBCContext getJDBCContext()
Specified by:
getJDBCContext in interface SessionImplementor

setFetchProfile

public void setFetchProfile(String fetchProfile)
Specified by:
setFetchProfile in interface SessionImplementor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLQueryImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class SQLQueryImpl

java.lang.Object
    extended by org.hibernate.impl.AbstractQueryImpl
        extended by org.hibernate.impl.SQLQueryImpl
All Implemented Interfaces:
Query, SQLQuery
public class SQLQueryImpl
extends AbstractQueryImpl
implements SQLQuery

Implements SQL query passthrough.

   SELECT {person}.NAME AS {person.name}, {person}.AGE AS {person.age}, {person}.SEX AS {person.sex}
   FROM PERSON {person} WHERE {person}.NAME LIKE 'Hiber%'

Author:
Max Andersen

Field Summary
Fields inherited from class org.hibernate.impl.AbstractQueryImpl
parameterMetadata, session
Method Summary
SQLQuery | addEntity(Class entityClass) Declare a "root" entity, without specifying an alias
SQLQuery | addEntity(String entityName) Declare a "root" entity, without specifying an alias
SQLQuery | addEntity(String alias, Class entityClass) Declare a "root" entity
SQLQuery | addEntity(String alias, Class entityClass, LockMode lockMode) Declare a "root" entity, specifying a lock mode
SQLQuery | addEntity(String alias, String entityName) Declare a "root" entity
SQLQuery | addEntity(String alias, String entityName, LockMode lockMode) Declare a "root" entity, specifying a lock mode
SQLQuery | addJoin(String alias, String path) Declare a "joined" entity
SQLQuery | addJoin(String alias, String path, LockMode lockMode) Declare a "joined" entity, specifying a lock mode
SQLQuery | addScalar(String columnAlias) Declare a scalar query.
SQLQuery | addScalar(String columnAlias, Type type) Declare a scalar query result
int | executeUpdate() Execute the update or delete statement.
protected Map | getLockModes()
QueryParameters | getQueryParameters(Map namedParams)
String[] | getReturnAliases() Return the HQL select clause aliases (if any)
Type[] | getReturnTypes() Return the Hibernate types of the query result set.
Iterator | iterate() Return the query results as an Iterator.
List | list() Return the query results as a List.
ScrollableResults | scroll() Return the query results as ScrollableResults.
ScrollableResults | scroll(ScrollMode scrollMode) Return the query results as ScrollableResults.
Query | setLockMode(String alias, LockMode lockMode) Set the lockmode for the objects idententified by the given alias that appears in the FROM clause.
SQLQuery | setResultSetMapping(String name) Use a predefined named ResultSetMapping
protected void | verifyParameters() Perform parameter validation.
Methods inherited from class org.hibernate.impl.AbstractQueryImpl
after, before, determineType, determineType, determineType, determineType, determineType, expandParameterLists, getNamedParameterLists, getNamedParameters, getNamedParams, getQueryString, getRowSelection, getSelection, getTypes, getValues, hasNamedParameters, isReadOnly, setBigDecimal, setBigDecimal, setBigInteger, setBigInteger, setBinary, setBinary, setBoolean, setBoolean, setByte, setByte, setCacheable, setCacheMode, setCacheRegion, setCalendar, setCalendar, setCalendarDate, setCalendarDate, setCharacter, setCharacter, setCollectionKey, setComment, setDate, setDate, setDouble, setDouble, setEntity, setEntity, setFetchSize, setFirstResult, setFloat, setFloat, setFlushMode, setInteger, setInteger, setLocale, setLocale, setLong, setLong, setMaxResults, setOptionalEntityName, setOptionalId, setOptionalObject, setParameter, setParameter, setParameter, setParameter, setParameterList, setParameterList, setParameterList, setParameterList, setParameters, setProperties, setReadOnly, setResultTransformer, setSerializable, setSerializable, setShort, setShort, setString, setString, setText, setText, setTime, setTime, setTimeout, setTimestamp, setTimestamp, toString, typeArray, uniqueResult, valueArray, verifyParameters
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.Query
getNamedParameters, getQueryString, setBigDecimal, setBigDecimal, setBigInteger, setBigInteger, setBinary, setBinary, setBoolean, setBoolean, setByte, setByte, setCacheable, setCacheMode, setCacheRegion, setCalendar, setCalendar, setCalendarDate, setCalendarDate, setCharacter, setCharacter, setComment, setDate, setDate, setDouble, setDouble, setEntity, setEntity, setFetchSize, setFirstResult, setFloat, setFloat, setFlushMode, setInteger, setInteger, setLocale, setLocale, setLong, setLong, setMaxResults, setParameter, setParameter, setParameter, setParameter, setParameterList, setParameterList, setParameterList, setParameterList, setParameters, setProperties, setReadOnly, setResultTransformer, setSerializable, setSerializable, setShort, setShort, setString, setString, setText, setText, setTime, setTime, setTimeout, setTimestamp, setTimestamp, uniqueResult

Method Detail

list

public List list()
          throws HibernateException
Description copied from interface: Query
Return the query results as a List. If the query contains multiple results pre row, the results are returned in an instance of Object[].

Specified by:
list in interface Query
Returns:
the result list
Throws:
HibernateException

scroll

public ScrollableResults scroll(ScrollMode scrollMode)
                         throws HibernateException
Description copied from interface: Query
Return the query results as ScrollableResults. The scrollability of the returned results depends upon JDBC driver support for scrollable ResultSets.

Specified by:
scroll in interface Query
Returns:
the result iterator
Throws:
HibernateException
See Also:
ScrollableResults, ScrollMode

scroll

public ScrollableResults scroll()
                         throws HibernateException
Description copied from interface: Query
Return the query results as ScrollableResults. The scrollability of the returned results depends upon JDBC driver support for scrollable ResultSets.

Specified by:
scroll in interface Query
Returns:
the result iterator
Throws:
HibernateException
See Also:
ScrollableResults

iterate

public Iterator iterate()
                 throws HibernateException
Description copied from interface: Query
Return the query results as an Iterator. If the query contains multiple results pre row, the results are returned in an instance of Object[].

Entities returned as results are initialized on demand. The first SQL query returns identifiers only.

Specified by:
iterate in interface Query
Returns:
the result iterator
Throws:
HibernateException

getQueryParameters

public QueryParameters getQueryParameters(Map namedParams)
Overrides:
getQueryParameters in class AbstractQueryImpl

verifyParameters

protected void verifyParameters()
Description copied from class: AbstractQueryImpl
Perform parameter validation. Used prior to executing the encapsulated query.

Overrides:
verifyParameters in class AbstractQueryImpl

getReturnAliases

public String[] getReturnAliases()
                          throws HibernateException
Description copied from interface: Query
Return the HQL select clause aliases (if any)

Specified by:
getReturnAliases in interface Query
Overrides:
getReturnAliases in class AbstractQueryImpl
Throws:
HibernateException

getReturnTypes

public Type[] getReturnTypes()
                      throws HibernateException
Description copied from interface: Query
Return the Hibernate types of the query result set.

Specified by:
getReturnTypes in interface Query
Overrides:
getReturnTypes in class AbstractQueryImpl
Throws:
HibernateException

setLockMode

public Query setLockMode(String alias,
                         LockMode lockMode)
Description copied from interface: Query
Set the lockmode for the objects idententified by the given alias that appears in the FROM clause.

Specified by:
setLockMode in interface Query
Parameters:
alias - a query alias, or this for a collection filter

getLockModes

protected Map getLockModes()
Specified by:
getLockModes in class AbstractQueryImpl

addScalar

public SQLQuery addScalar(String columnAlias,
                          Type type)
Description copied from interface: SQLQuery
Declare a scalar query result

Specified by:
addScalar in interface SQLQuery

addScalar

public SQLQuery addScalar(String columnAlias)
Description copied from interface: SQLQuery
Declare a scalar query. Hibernate will attempt to automatically detect the underlying type.

Specified by:
addScalar in interface SQLQuery

addJoin

public SQLQuery addJoin(String alias,
                        String path)
Description copied from interface: SQLQuery
Declare a "joined" entity

Specified by:
addJoin in interface SQLQuery

addEntity

public SQLQuery addEntity(Class entityClass)
Description copied from interface: SQLQuery
Declare a "root" entity, without specifying an alias

Specified by:
addEntity in interface SQLQuery

addEntity

public SQLQuery addEntity(String entityName)
Description copied from interface: SQLQuery
Declare a "root" entity, without specifying an alias

Specified by:
addEntity in interface SQLQuery

addEntity

public SQLQuery addEntity(String alias,
                          String entityName)
Description copied from interface: SQLQuery
Declare a "root" entity

Specified by:
addEntity in interface SQLQuery

addEntity

public SQLQuery addEntity(String alias,
                          Class entityClass)
Description copied from interface: SQLQuery
Declare a "root" entity

Specified by:
addEntity in interface SQLQuery

addJoin

public SQLQuery addJoin(String alias,
                        String path,
                        LockMode lockMode)
Description copied from interface: SQLQuery
Declare a "joined" entity, specifying a lock mode

Specified by:
addJoin in interface SQLQuery

addEntity

public SQLQuery addEntity(String alias,
                          String entityName,
                          LockMode lockMode)
Description copied from interface: SQLQuery
Declare a "root" entity, specifying a lock mode

Specified by:
addEntity in interface SQLQuery

addEntity

public SQLQuery addEntity(String alias,
                          Class entityClass,
                          LockMode lockMode)
Description copied from interface: SQLQuery
Declare a "root" entity, specifying a lock mode

Specified by:
addEntity in interface SQLQuery

setResultSetMapping

public SQLQuery setResultSetMapping(String name)
Description copied from interface: SQLQuery
Use a predefined named ResultSetMapping

Specified by:
setResultSetMapping in interface SQLQuery

executeUpdate

public int executeUpdate()
                  throws HibernateException
Description copied from interface: Query
Execute the update or delete statement.

The semantics are compliant with the ejb3 Query.executeUpdate() method.

Specified by:
executeUpdate in interface Query
Returns:
The number of entities updated or deleted.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StatelessSessionImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.impl
Class StatelessSessionImpl

java.lang.Object
    extended by org.hibernate.impl.AbstractSessionImpl
        extended by org.hibernate.impl.StatelessSessionImpl
All Implemented Interfaces:
JDBCContext.Context, Serializable, SessionImplementor, StatelessSession, TransactionFactory.Context
public class StatelessSessionImpl
extends AbstractSessionImpl
implements JDBCContext.Context, StatelessSession

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.impl.AbstractSessionImpl
factory
Method Summary
 void afterOperation(boolean success)
 void afterScrollOperation()
 void afterTransactionBegin(Transaction tx)
We cannot rely upon this method being called! It is only called if we are using Hibernate Transaction API.
 void afterTransactionCompletion(boolean successful, Transaction tx)
Notify the session that the transaction completed, so we no longer own the old locks.
protected  boolean autoFlushIfRequired(Set querySpaces)
 void beforeTransactionCompletion(Transaction tx)
Notify the session that the transaction is about to complete
 Transaction beginTransaction()
Begin a Hibernate transaction.
 String bestGuessEntityName(Object object)
The best guess entity name for an entity not in an association
 void close()
Close the stateless session and release the JDBC connection.
 Connection connection()
Returns the current JDBC connection associated with this instance.

If the session is using aggressive connection release (as in a CMT environment), it is the application's responsibility to close the connection returned by this call.
 Criteria createCriteria(Class persistentClass)
Create a new Criteria instance, for the given entity class, or a superclass of an entity class.
 Criteria createCriteria(Class persistentClass, String alias)
Create a new Criteria instance, for the given entity class, or a superclass of an entity class, with the given alias.
 Criteria createCriteria(String entityName)
Create a new Criteria instance, for the given entity name.
 Criteria createCriteria(String entityName, String alias)
Create a new Criteria instance, for the given entity name, with the given alias.
 void delete(Object entity)
Delete a row.
 void delete(String entityName, Object entity)
Delete a row.
 int executeNativeUpdate(NativeSQLQuerySpecification nativeSQLQuerySpecification, QueryParameters queryParameters)
Execute a native SQL update or delete query
 int executeUpdate(String query, QueryParameters queryParameters)
Execute a HQL update or delete query
 void flush()
 Object get(Class entityClass, Serializable id)
Retrieve a row.
 Object get(Class entityClass, Serializable id, LockMode lockMode)
Retrieve a row, obtaining the specified lock mode.
 Object get(String entityName, Serializable id)
Retrieve a row.
 Object get(String entityName, Serializable id, LockMode lockMode)
Retrieve a row, obtaining the specified lock mode.
 Batcher getBatcher()
Get the prepared statement Batcher for this session
 CacheMode getCacheMode()
 ConnectionReleaseMode getConnectionReleaseMode()
 Serializable getContextEntityIdentifier(Object object)
Return the identifier of the persistent object, or null if not associated with the session
 int getDontFlushFromFind()
 Map getEnabledFilters()
Return the currently enabled filters.
 EntityMode getEntityMode()
 EntityPersister getEntityPersister(String entityName, Object object)
Get the EntityPersister for any instance
 Object getEntityUsingInterceptor(EntityKey key)
Get the entity instance associated with the given Key, calling the Interceptor if necessary
 String getFetchProfile()
 Type getFilterParameterType(String filterParameterName)
Retreive the type for a given filter parrameter.
 Object getFilterParameterValue(String filterParameterName)
Retreive the currently set value for a filter parameter.
 FlushMode getFlushMode()
 Interceptor getInterceptor()
Retrieves the interceptor currently in use by this event source.
 JDBCContext getJDBCContext()
 EventListeners getListeners()
Retrieves the configured event listeners from this event source.
 PersistenceContext getPersistenceContext()
Get the persistence context for this session
 long getTimestamp()
System time before the start of the transaction
 Transaction getTransaction()
Get the current Hibernate transaction.
 String guessEntityName(Object entity)
The guessed entity name for an entity not in an association
 Object immediateLoad(String entityName, Serializable id)
Load an instance immediately.
 void initializeCollection(PersistentCollection collection, boolean writing)
Initialize the collection (if not already initialized)
 Serializable insert(Object entity)
Insert a row.
 Serializable insert(String entityName, Object entity)
Insert a row.
 Object instantiate(String entityName, Serializable id)
Instantiate the entity class, initializing with the given identifier
 Object internalLoad(String entityName, Serializable id, boolean eager, boolean nullable)
Load an instance without checking if it was deleted.
 boolean isAutoCloseSessionEnabled()
 boolean isConnected()
 boolean isEventSource()
 boolean isFlushBeforeCompletionEnabled()
 boolean isFlushModeNever()
 boolean isOpen()
 boolean isTransactionInProgress()
Does this Session have an active Hibernate transaction or is there a JTA transaction in progress?
 Iterator iterate(String query, QueryParameters queryParameters)
Execute an iterate() query
 Iterator iterateFilter(Object collection, String filter, QueryParameters queryParameters)
Iterate a filter
 List list(CriteriaImpl criteria)
Execute a criteria query
 List list(String query, QueryParameters queryParameters)
Execute a find() query
 List listCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
Execute an SQL Query
 List listFilter(Object collection, String filter, QueryParameters queryParameters)
Execute a filter
 void managedClose()
 void managedFlush()
 void refresh(Object entity)
Refresh the entity instance state from the database.
 void refresh(Object entity, LockMode lockMode)
Refresh the entity instance state from the database.
 void refresh(String entityName, Object entity)
Refresh the entity instance state from the database.
 void refresh(String entityName, Object entity, LockMode lockMode)
Refresh the entity instance state from the database.
 ScrollableResults scroll(CriteriaImpl criteria, ScrollMode scrollMode)
Execute a criteria query
 ScrollableResults scroll(String query, QueryParameters queryParameters)
Execute a scroll() query
 ScrollableResults scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
Execute an SQL Query
 void setAutoClear(boolean enabled)
Enable/disable automatic cache clearing from after transaction completion (for EJB3)
 void setCacheMode(CacheMode cm)
 void setFetchProfile(String name)
 void setFlushMode(FlushMode fm)
 boolean shouldAutoClose()
 void update(Object entity)
Update a row.
 void update(String entityName, Object entity)
Update a row.
Methods inherited from class org.hibernate.impl.AbstractSessionImpl
createQuery, createSQLQuery, errorIfClosed, getFactory, getHQLQueryPlan, getNamedQuery, getNamedSQLQuery, getNativeSQLQueryPlan, isClosed, list, scroll, setClosed
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.transaction.TransactionFactory.Context
getFactory, isClosed
Methods inherited from interface org.hibernate.StatelessSession
createQuery, createSQLQuery, getNamedQuery

Method Detail

insert

public Serializable insert(Object entity)
Description copied from interface: StatelessSession
Insert a row.

Specified by:
insert in interface StatelessSession
Parameters:
entity - a new transient instance

insert

public Serializable insert(String entityName,
                           Object entity)
Description copied from interface: StatelessSession
Insert a row.

Specified by:
insert in interface StatelessSession
Parameters:
entityName - The entityName for the entity to be inserted
entity - a new transient instance
Returns:
the identifier of the instance

delete

public void delete(Object entity)
Description copied from interface: StatelessSession
Delete a row.

Specified by:
delete in interface StatelessSession
Parameters:
entity - a detached entity instance

delete

public void delete(String entityName,
                   Object entity)
Description copied from interface: StatelessSession
Delete a row.

Specified by:
delete in interface StatelessSession
Parameters:
entityName - The entityName for the entity to be deleted
entity - a detached entity instance

update

public void update(Object entity)
Description copied from interface: StatelessSession
Update a row.

Specified by:
update in interface StatelessSession
Parameters:
entity - a detached entity instance

update

public void update(String entityName,
                   Object entity)
Description copied from interface: StatelessSession
Update a row.

Specified by:
update in interface StatelessSession
Parameters:
entityName - The entityName for the entity to be updated
entity - a detached entity instance

get

public Object get(Class entityClass,
                  Serializable id)
Description copied from interface: StatelessSession
Retrieve a row.

Specified by:
get in interface StatelessSession
Returns:
a detached entity instance

get

public Object get(Class entityClass,
                  Serializable id,
                  LockMode lockMode)
Description copied from interface: StatelessSession
Retrieve a row, obtaining the specified lock mode.

Specified by:
get in interface StatelessSession
Returns:
a detached entity instance

get

public Object get(String entityName,
                  Serializable id)
Description copied from interface: StatelessSession
Retrieve a row.

Specified by:
get in interface StatelessSession
Returns:
a detached entity instance

get

public Object get(String entityName,
                  Serializable id,
                  LockMode lockMode)
Description copied from interface: StatelessSession
Retrieve a row, obtaining the specified lock mode.

Specified by:
get in interface StatelessSession
Returns:
a detached entity instance

refresh

public void refresh(Object entity)
Description copied from interface: StatelessSession
Refresh the entity instance state from the database.

Specified by:
refresh in interface StatelessSession
Parameters:
entity - The entity to be refreshed.

refresh

public void refresh(String entityName,
                    Object entity)
Description copied from interface: StatelessSession
Refresh the entity instance state from the database.

Specified by:
refresh in interface StatelessSession
Parameters:
entityName - The entityName for the entity to be refreshed.
entity - The entity to be refreshed.

refresh

public void refresh(Object entity,
                    LockMode lockMode)
Description copied from interface: StatelessSession
Refresh the entity instance state from the database.

Specified by:
refresh in interface StatelessSession
Parameters:
entity - The entity to be refreshed.
lockMode - The LockMode to be applied.

refresh

public void refresh(String entityName,
                    Object entity,
                    LockMode lockMode)
Description copied from interface: StatelessSession
Refresh the entity instance state from the database.

Specified by:
refresh in interface StatelessSession
Parameters:
entityName - The entityName for the entity to be refreshed.
entity - The entity to be refreshed.
lockMode - The LockMode to be applied.

immediateLoad

public Object immediateLoad(String entityName,
                            Serializable id)
                     throws HibernateException
Description copied from interface: SessionImplementor
Load an instance immediately. This method is only called when lazily initializing a proxy. Do not return the proxy.

Specified by:
immediateLoad in interface SessionImplementor
Throws:
HibernateException

initializeCollection

public void initializeCollection(PersistentCollection collection,
                                 boolean writing)
                          throws HibernateException
Description copied from interface: SessionImplementor
Initialize the collection (if not already initialized)

Specified by:
initializeCollection in interface SessionImplementor
Throws:
HibernateException

instantiate

public Object instantiate(String entityName,
                          Serializable id)
                   throws HibernateException
Description copied from interface: SessionImplementor
Instantiate the entity class, initializing with the given identifier

Specified by:
instantiate in interface SessionImplementor
Throws:
HibernateException

internalLoad

public Object internalLoad(String entityName,
                           Serializable id,
                           boolean eager,
                           boolean nullable)
                    throws HibernateException
Description copied from interface: SessionImplementor
Load an instance without checking if it was deleted. When nullable is disabled this method may create a new proxy or return an existing proxy; if it does not exist, throw an exception. When nullable is enabled, the method does not create new proxies (but might return an existing proxy); if it does not exist, return null. When eager is enabled, the object is eagerly fetched

Specified by:
internalLoad in interface SessionImplementor
Throws:
HibernateException

iterate

public Iterator iterate(String query,
                        QueryParameters queryParameters)
                 throws HibernateException
Description copied from interface: SessionImplementor
Execute an iterate() query

Specified by:
iterate in interface SessionImplementor
Throws:
HibernateException

iterateFilter

public Iterator iterateFilter(Object collection,
                              String filter,
                              QueryParameters queryParameters)
                       throws HibernateException
Description copied from interface: SessionImplementor
Iterate a filter

Specified by:
iterateFilter in interface SessionImplementor
Throws:
HibernateException

listFilter

public List listFilter(Object collection,
                       String filter,
                       QueryParameters queryParameters)
                throws HibernateException
Description copied from interface: SessionImplementor
Execute a filter

Specified by:
listFilter in interface SessionImplementor
Throws:
HibernateException

isOpen

public boolean isOpen()
Specified by:
isOpen in interface SessionImplementor

close

public void close()
Description copied from interface: StatelessSession
Close the stateless session and release the JDBC connection.

Specified by:
close in interface StatelessSession

getConnectionReleaseMode

public ConnectionReleaseMode getConnectionReleaseMode()
Specified by:
getConnectionReleaseMode in interface JDBCContext.Context

isAutoCloseSessionEnabled

public boolean isAutoCloseSessionEnabled()
Specified by:
isAutoCloseSessionEnabled in interface JDBCContext.Context

isFlushBeforeCompletionEnabled

public boolean isFlushBeforeCompletionEnabled()
Specified by:
isFlushBeforeCompletionEnabled in interface TransactionFactory.Context

isFlushModeNever

public boolean isFlushModeNever()
Specified by:
isFlushModeNever in interface TransactionFactory.Context

managedClose

public void managedClose()
Specified by:
managedClose in interface TransactionFactory.Context

managedFlush

public void managedFlush()
Specified by:
managedFlush in interface TransactionFactory.Context

shouldAutoClose

public boolean shouldAutoClose()
Specified by:
shouldAutoClose in interface TransactionFactory.Context

afterTransactionCompletion

public void afterTransactionCompletion(boolean successful,
                                       Transaction tx)
Description copied from interface: SessionImplementor
Notify the session that the transaction completed, so we no longer own the old locks. (Also we should release cache softlocks.) May be called multiple times during the transaction completion process. Also called after an autocommit, in which case the second argument is null.

Specified by:
afterTransactionCompletion in interface JDBCContext.Context

beforeTransactionCompletion

public void beforeTransactionCompletion(Transaction tx)
Description copied from interface: SessionImplementor
Notify the session that the transaction is about to complete

Specified by:
beforeTransactionCompletion in interface JDBCContext.Context

bestGuessEntityName

public String bestGuessEntityName(Object object)
Description copied from interface: SessionImplementor
The best guess entity name for an entity not in an association

Specified by:
bestGuessEntityName in interface SessionImplementor

connection

public Connection connection()
Description copied from interface: StatelessSession
Returns the current JDBC connection associated with this instance.

If the session is using aggressive connection release (as in a CMT environment), it is the application's responsibility to close the connection returned by this call. Otherwise, the application should not close the connection.

Specified by:
connection in interface StatelessSession

executeUpdate

public int executeUpdate(String query,
                         QueryParameters queryParameters)
                  throws HibernateException
Description copied from interface: SessionImplementor
Execute a HQL update or delete query

Specified by:
executeUpdate in interface SessionImplementor
Throws:
HibernateException

getBatcher

public Batcher getBatcher()
Description copied from interface: SessionImplementor
Get the prepared statement Batcher for this session

Specified by:
getBatcher in interface SessionImplementor

getCacheMode

public CacheMode getCacheMode()
Specified by:
getCacheMode in interface SessionImplementor

getDontFlushFromFind

public int getDontFlushFromFind()
Specified by:
getDontFlushFromFind in interface SessionImplementor

getEnabledFilters

public Map getEnabledFilters()
Description copied from interface: SessionImplementor
Return the currently enabled filters. The filter map is keyed by filter name, with values corresponding to the FilterImpl instance.

Specified by:
getEnabledFilters in interface SessionImplementor
Returns:
The currently enabled filters.

getContextEntityIdentifier

public Serializable getContextEntityIdentifier(Object object)
Description copied from interface: SessionImplementor
Return the identifier of the persistent object, or null if not associated with the session

Specified by:
getContextEntityIdentifier in interface SessionImplementor

getEntityMode

public EntityMode getEntityMode()
Specified by:
getEntityMode in interface SessionImplementor

getEntityPersister

public EntityPersister getEntityPersister(String entityName,
                                          Object object)
                                   throws HibernateException
Description copied from interface: SessionImplementor
Get the EntityPersister for any instance

Specified by:
getEntityPersister in interface SessionImplementor
Parameters:
entityName - optional entity name
object - the entity instance
Throws:
HibernateException

getEntityUsingInterceptor

public Object getEntityUsingInterceptor(EntityKey key)
                                 throws HibernateException
Description copied from interface: SessionImplementor
Get the entity instance associated with the given Key, calling the Interceptor if necessary

Specified by:
getEntityUsingInterceptor in interface SessionImplementor
Throws:
HibernateException

getFilterParameterType

public Type getFilterParameterType(String filterParameterName)
Description copied from interface: SessionImplementor
Retreive the type for a given filter parrameter.

Specified by:
getFilterParameterType in interface SessionImplementor
Parameters:
filterParameterName - The filter parameter name in the format {FILTER_NAME.PARAMETER_NAME}.

getFilterParameterValue

public Object getFilterParameterValue(String filterParameterName)
Description copied from interface: SessionImplementor
Retreive the currently set value for a filter parameter.

Specified by:
getFilterParameterValue in interface SessionImplementor
Parameters:
filterParameterName - The filter parameter name in the format {FILTER_NAME.PARAMETER_NAME}.
Returns:
The filter parameter value.

getFlushMode

public FlushMode getFlushMode()
Specified by:
getFlushMode in interface SessionImplementor

getInterceptor

public Interceptor getInterceptor()
Description copied from interface: SessionImplementor
Retrieves the interceptor currently in use by this event source.

Specified by:
getInterceptor in interface SessionImplementor
Returns:
The interceptor.

getListeners

public EventListeners getListeners()
Description copied from interface: SessionImplementor
Retrieves the configured event listeners from this event source.

Specified by:
getListeners in interface SessionImplementor
Returns:
The configured event listeners.

getPersistenceContext

public PersistenceContext getPersistenceContext()
Description copied from interface: SessionImplementor
Get the persistence context for this session

Specified by:
getPersistenceContext in interface SessionImplementor

getTimestamp

public long getTimestamp()
Description copied from interface: SessionImplementor
System time before the start of the transaction

Specified by:
getTimestamp in interface SessionImplementor

guessEntityName

public String guessEntityName(Object entity)
                       throws HibernateException
Description copied from interface: SessionImplementor
The guessed entity name for an entity not in an association

Specified by:
guessEntityName in interface SessionImplementor
Throws:
HibernateException

isConnected

public boolean isConnected()
Specified by:
isConnected in interface SessionImplementor

isTransactionInProgress

public boolean isTransactionInProgress()
Description copied from interface: SessionImplementor
Does this Session have an active Hibernate transaction or is there a JTA transaction in progress?

Specified by:
isTransactionInProgress in interface SessionImplementor

setAutoClear

public void setAutoClear(boolean enabled)
Description copied from interface: SessionImplementor
Enable/disable automatic cache clearing from after transaction completion (for EJB3)

Specified by:
setAutoClear in interface SessionImplementor

setCacheMode

public void setCacheMode(CacheMode cm)
Specified by:
setCacheMode in interface SessionImplementor

setFlushMode

public void setFlushMode(FlushMode fm)
Specified by:
setFlushMode in interface SessionImplementor

getTransaction

public Transaction getTransaction()
                           throws HibernateException
Description copied from interface: StatelessSession
Get the current Hibernate transaction.

Specified by:
getTransaction in interface StatelessSession
Throws:
HibernateException

beginTransaction

public Transaction beginTransaction()
                             throws HibernateException
Description copied from interface: StatelessSession
Begin a Hibernate transaction.

Specified by:
beginTransaction in interface StatelessSession
Throws:
HibernateException

isEventSource

public boolean isEventSource()
Specified by:
isEventSource in interface SessionImplementor

list

public List list(String query,
                 QueryParameters queryParameters)
          throws HibernateException
Description copied from interface: SessionImplementor
Execute a find() query

Specified by:
list in interface SessionImplementor
Throws:
HibernateException

afterOperation

public void afterOperation(boolean success)

createCriteria

public Criteria createCriteria(Class persistentClass,
                               String alias)
Description copied from interface: StatelessSession
Create a new Criteria instance, for the given entity class, or a superclass of an entity class, with the given alias. Entities returned by the query are detached.

Specified by:
createCriteria in interface StatelessSession
Parameters:
persistentClass - a class, which is persistent, or has persistent subclasses
Returns:
Criteria

createCriteria

public Criteria createCriteria(String entityName,
                               String alias)
Description copied from interface: StatelessSession
Create a new Criteria instance, for the given entity name, with the given alias. Entities returned by the query are detached.

Specified by:
createCriteria in interface StatelessSession
Parameters:
entityName -
Returns:
Criteria

createCriteria

public Criteria createCriteria(Class persistentClass)
Description copied from interface: StatelessSession
Create a new Criteria instance, for the given entity class, or a superclass of an entity class. Entities returned by the query are detached.

Specified by:
createCriteria in interface StatelessSession
Parameters:
persistentClass - a class, which is persistent, or has persistent subclasses
Returns:
Criteria

createCriteria

public Criteria createCriteria(String entityName)
Description copied from interface: StatelessSession
Create a new Criteria instance, for the given entity name. Entities returned by the query are detached.

Specified by:
createCriteria in interface StatelessSession
Parameters:
entityName -
Returns:
Criteria

scroll

public ScrollableResults scroll(CriteriaImpl criteria,
                                ScrollMode scrollMode)
Description copied from interface: SessionImplementor
Execute a criteria query

Specified by:
scroll in interface SessionImplementor

list

public List list(CriteriaImpl criteria)
          throws HibernateException
Description copied from interface: SessionImplementor
Execute a criteria query

Specified by:
list in interface SessionImplementor
Throws:
HibernateException

listCustomQuery

public List listCustomQuery(CustomQuery customQuery,
                            QueryParameters queryParameters)
                     throws HibernateException
Description copied from interface: SessionImplementor
Execute an SQL Query

Specified by:
listCustomQuery in interface SessionImplementor
Throws:
HibernateException

scrollCustomQuery

public ScrollableResults scrollCustomQuery(CustomQuery customQuery,
                                           QueryParameters queryParameters)
                                    throws HibernateException
Description copied from interface: SessionImplementor
Execute an SQL Query

Specified by:
scrollCustomQuery in interface SessionImplementor
Throws:
HibernateException

scroll

public ScrollableResults scroll(String query,
                                QueryParameters queryParameters)
                         throws HibernateException
Description copied from interface: SessionImplementor
Execute a scroll() query

Specified by:
scroll in interface SessionImplementor
Throws:
HibernateException

afterScrollOperation

public void afterScrollOperation()
Specified by:
afterScrollOperation in interface SessionImplementor

flush

public void flush()
Specified by:
flush in interface SessionImplementor

getFetchProfile

public String getFetchProfile()
Specified by:
getFetchProfile in interface SessionImplementor

getJDBCContext

public JDBCContext getJDBCContext()
Specified by:
getJDBCContext in interface SessionImplementor

setFetchProfile

public void setFetchProfile(String name)
Specified by:
setFetchProfile in interface SessionImplementor

afterTransactionBegin

public void afterTransactionBegin(Transaction tx)
Description copied from interface: JDBCContext.Context
We cannot rely upon this method being called! It is only called if we are using Hibernate Transaction API.

Specified by:
afterTransactionBegin in interface JDBCContext.Context

autoFlushIfRequired

protected boolean autoFlushIfRequired(Set querySpaces)
                               throws HibernateException
Throws:
HibernateException

executeNativeUpdate

public int executeNativeUpdate(NativeSQLQuerySpecification nativeSQLQuerySpecification,
                               QueryParameters queryParameters)
                        throws HibernateException
Description copied from interface: SessionImplementor
Execute a native SQL update or delete query

Specified by:
executeNativeUpdate in interface SessionImplementor
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.intercept (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.intercept

This package implements an interception mechanism for lazy property fetching, based on CGLIB bytecode instrumentation.

See:
Description

Interface Summary
FieldInterceptor | Contract for field interception handlers.
LazyPropertyInitializer | Contract for controlling how lazy properties get initialized.

Class Summary
AbstractFieldInterceptor |
FieldInterceptionHelper | Helper class for dealing with enhanced entity classes.

Package org.hibernate.intercept Description

This package implements an interception mechanism for lazy property fetching, based on CGLIB bytecode instrumentation.


org.hibernate.intercept Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.intercept

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.intercept.AbstractFieldInterceptor (implements org.hibernate.intercept.FieldInterceptor, java.io.Serializable)
    • class org.hibernate.intercept.FieldInterceptionHelper

Interface Hierarchy

  • interface org.hibernate.intercept.FieldInterceptor
  • interface org.hibernate.intercept.LazyPropertyInitializer


Uses of Package org.hibernate.intercept (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.intercept

Packages that use org.hibernate.intercept
org.hibernate.intercept | This package implements an interception mechanism for lazy property fetching, based on CGLIB bytecode instrumentation.
org.hibernate.intercept.cglib |
org.hibernate.intercept.javassist |
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Classes in org.hibernate.intercept used by org.hibernate.intercept
FieldInterceptor
Contract for field interception handlers.

Classes in org.hibernate.intercept used by org.hibernate.intercept.cglib
AbstractFieldInterceptor
FieldInterceptor
Contract for field interception handlers.

Classes in org.hibernate.intercept used by org.hibernate.intercept.javassist
FieldInterceptor
Contract for field interception handlers.

Classes in org.hibernate.intercept used by org.hibernate.persister.entity
LazyPropertyInitializer
Contract for controlling how lazy properties get initialized.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


FieldInterceptor (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.intercept
Interface FieldInterceptor

All Known Implementing Classes:
AbstractFieldInterceptor
public interface FieldInterceptor

Contract for field interception handlers.

Author:
Steve Ebersole

Method Summary
void | clearDirty() Clear the internal dirty flag.
void | dirty() Forcefully mark the entity as being dirty.
boolean | isDirty() Is the entity considered dirty?
boolean | isInitialized() Is the entity to which we are bound completely initialized?
boolean | isInitialized(String field) The the given field initialized for the entity to which we are bound?
void | setSession(SessionImplementor session) Use to associate the entity to which we are bound to the given session.

Method Detail

setSession

public void setSession(SessionImplementor session)
Use to associate the entity to which we are bound to the given session.

Parameters:
session - The session to which we are now associated.

isInitialized

public boolean isInitialized()
Is the entity to which we are bound completely initialized?

Returns:
True if the entity is initialized; otherwise false.

isInitialized

public boolean isInitialized(String field)
The the given field initialized for the entity to which we are bound?

Parameters:
field - The name of the field to check
Returns:
True if the given field is initialized; otherwise false.

dirty

public void dirty()
Forcefully mark the entity as being dirty.

isDirty

public boolean isDirty()
Is the entity considered dirty?

Returns:
True if the entity is dirty; otherwise false.

clearDirty

public void clearDirty()
Clear the internal dirty flag.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


LazyPropertyInitializer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.intercept
Interface LazyPropertyInitializer

All Known Implementing Classes:
AbstractEntityPersister
public interface LazyPropertyInitializer

Contract for controlling how lazy properties get initialized.

Author:
Gavin King

Field Summary
static Serializable UNFETCHED_PROPERTY
Marker value for uninitialized properties
Method Summary
 Object initializeLazyProperty(String fieldName, Object entity, SessionImplementor session)
Initialize the property, and return its new value

Field Detail

UNFETCHED_PROPERTY

public static final Serializable UNFETCHED_PROPERTY
Marker value for uninitialized properties

Method Detail

initializeLazyProperty

public Object initializeLazyProperty(String fieldName,
                                     Object entity,
                                     SessionImplementor session)
                              throws HibernateException
Initialize the property, and return its new value

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractFieldInterceptor (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.intercept
Class AbstractFieldInterceptor

java.lang.Object
    extended by org.hibernate.intercept.AbstractFieldInterceptor
All Implemented Interfaces:
FieldInterceptor, Serializable
Direct Known Subclasses:
FieldInterceptorImpl, FieldInterceptorImpl
public abstract class AbstractFieldInterceptor
extends Object
implements FieldInterceptor, Serializable

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
protected AbstractFieldInterceptor(SessionImplementor session, Set uninitializedFields, String entityName)
Method Summary
void | clearDirty() Clear the internal dirty flag.
void | dirty() Forcefully mark the entity as being dirty.
String | getEntityName()
SessionImplementor | getSession()
Set | getUninitializedFields()
protected Object | intercept(Object target, String fieldName, Object value)
boolean | isDirty() Is the entity considered dirty?
boolean | isInitialized() Is the entity to which we are bound completely initialized?
boolean | isInitialized(String field) The the given field initialized for the entity to which we are bound?
boolean | isInitializing()
void | setSession(SessionImplementor session) Use to associate the entity to which we are bound to the given session.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbstractFieldInterceptor

protected AbstractFieldInterceptor(SessionImplementor session,
                                   Set uninitializedFields,
                                   String entityName)
Method Detail

setSession

public final void setSession(SessionImplementor session)
Description copied from interface: FieldInterceptor
Use to associate the entity to which we are bound to the given session.

Specified by:
setSession in interface FieldInterceptor
Parameters:
session - The session to which we are now associated.

isInitialized

public final boolean isInitialized()
Description copied from interface: FieldInterceptor
Is the entity to which we are bound completely initialized?

Specified by:
isInitialized in interface FieldInterceptor
Returns:
True if the entity is initialized; otherwise false.

isInitialized

public final boolean isInitialized(String field)
Description copied from interface: FieldInterceptor
The the given field initialized for the entity to which we are bound?

Specified by:
isInitialized in interface FieldInterceptor
Parameters:
field - The name of the field to check
Returns:
True if the given field is initialized; otherwise false.

dirty

public final void dirty()
Description copied from interface: FieldInterceptor
Forcefully mark the entity as being dirty.

Specified by:
dirty in interface FieldInterceptor

isDirty

public final boolean isDirty()
Description copied from interface: FieldInterceptor
Is the entity considered dirty?

Specified by:
isDirty in interface FieldInterceptor
Returns:
True if the entity is dirty; otherwise false.

clearDirty

public final void clearDirty()
Description copied from interface: FieldInterceptor
Clear the internal dirty flag.

Specified by:
clearDirty in interface FieldInterceptor

intercept

protected final Object intercept(Object target,
                                 String fieldName,
                                 Object value)

getSession

public final SessionImplementor getSession()

getUninitializedFields

public final Set getUninitializedFields()

getEntityName

public final String getEntityName()

isInitializing

public final boolean isInitializing()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FieldInterceptionHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.intercept
Class FieldInterceptionHelper

java.lang.Object
    extended by org.hibernate.intercept.FieldInterceptionHelper
public class FieldInterceptionHelper
extends Object

Helper class for dealing with enhanced entity classes.

Author:
Steve Ebersole

Method Summary
static void | clearDirty(Object entity)
static FieldInterceptor | extractFieldInterceptor(Object entity)
static FieldInterceptor | injectFieldInterceptor(Object entity, String entityName, Set uninitializedFieldNames, SessionImplementor session)
static boolean | isInstrumented(Class entityClass)
static boolean | isInstrumented(Object entity)
static void | markDirty(Object entity)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

isInstrumented

public static boolean isInstrumented(Class entityClass)

isInstrumented

public static boolean isInstrumented(Object entity)

extractFieldInterceptor

public static FieldInterceptor extractFieldInterceptor(Object entity)

injectFieldInterceptor

public static FieldInterceptor injectFieldInterceptor(Object entity,
                                                      String entityName,
                                                      Set uninitializedFieldNames,
                                                      SessionImplementor session)

clearDirty

public static void clearDirty(Object entity)

markDirty

public static void markDirty(Object entity)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.intercept.cglib (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.intercept.cglib

Class Summary
CGLIBHelper |
FieldInterceptorImpl | A field-level interceptor that initializes lazily fetched properties.


org.hibernate.intercept.cglib Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.intercept.cglib

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.intercept.AbstractFieldInterceptor (implements org.hibernate.intercept.FieldInterceptor, java.io.Serializable)
      • class org.hibernate.intercept.cglib.FieldInterceptorImpl (implements net.sf.cglib.transform.impl.InterceptFieldCallback, java.io.Serializable)
    • class org.hibernate.intercept.cglib.CGLIBHelper


Uses of Package org.hibernate.intercept.cglib (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.intercept.cglib

No usage of org.hibernate.intercept.cglib

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CGLIBHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.intercept.cglib
Class CGLIBHelper

java.lang.Object
    extended by org.hibernate.intercept.cglib.CGLIBHelper
public class CGLIBHelper
extends Object

Author:
Steve Ebersole

Method Summary
static FieldInterceptor | extractFieldInterceptor(Object entity)
static FieldInterceptor | injectFieldInterceptor(Object entity, String entityName, Set uninitializedFieldNames, SessionImplementor session)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

extractFieldInterceptor

public static FieldInterceptor extractFieldInterceptor(Object entity)

injectFieldInterceptor

public static FieldInterceptor injectFieldInterceptor(Object entity,
                                                      String entityName,
                                                      Set uninitializedFieldNames,
                                                      SessionImplementor session)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FieldInterceptorImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.intercept.cglib
Class FieldInterceptorImpl

java.lang.Object
    extended by org.hibernate.intercept.AbstractFieldInterceptor
        extended by org.hibernate.intercept.cglib.FieldInterceptorImpl
All Implemented Interfaces:
FieldInterceptor, net.sf.cglib.transform.impl.InterceptFieldCallback, Serializable
public final class FieldInterceptorImpl
extends AbstractFieldInterceptor
implements net.sf.cglib.transform.impl.InterceptFieldCallback, Serializable

A field-level interceptor that initializes lazily fetched properties. This interceptor can be attached to classes instrumented by CGLIB. Note that this implementation assumes that the instance variable name is the same as the name of the persistent property that must be loaded.

Author:
Gavin King
See Also:
Serialized Form

Method Summary
boolean | readBoolean(Object target, String name, boolean oldValue)
byte | readByte(Object target, String name, byte oldValue)
char | readChar(Object target, String name, char oldValue)
double | readDouble(Object target, String name, double oldValue)
float | readFloat(Object target, String name, float oldValue)
int | readInt(Object target, String name, int oldValue)
long | readLong(Object target, String name, long oldValue)
Object | readObject(Object target, String name, Object oldValue)
short | readShort(Object target, String name, short oldValue)
String | toString()
boolean | writeBoolean(Object target, String name, boolean oldValue, boolean newValue)
byte | writeByte(Object target, String name, byte oldValue, byte newValue)
char | writeChar(Object target, String name, char oldValue, char newValue)
double | writeDouble(Object target, String name, double oldValue, double newValue)
float | writeFloat(Object target, String name, float oldValue, float newValue)
int | writeInt(Object target, String name, int oldValue, int newValue)
long | writeLong(Object target, String name, long oldValue, long newValue)
Object | writeObject(Object target, String name, Object oldValue, Object newValue)
short | writeShort(Object target, String name, short oldValue, short newValue)
Methods inherited from class org.hibernate.intercept.AbstractFieldInterceptor
clearDirty, dirty, getEntityName, getSession, getUninitializedFields, intercept, isDirty, isInitialized, isInitialized, isInitializing, setSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

readBoolean

public boolean readBoolean(Object target,
                           String name,
                           boolean oldValue)
Specified by:
readBoolean in interface net.sf.cglib.transform.impl.InterceptFieldCallback

readByte

public byte readByte(Object target,
                     String name,
                     byte oldValue)
Specified by:
readByte in interface net.sf.cglib.transform.impl.InterceptFieldCallback

readChar

public char readChar(Object target,
                     String name,
                     char oldValue)
Specified by:
readChar in interface net.sf.cglib.transform.impl.InterceptFieldCallback

readDouble

public double readDouble(Object target,
                         String name,
                         double oldValue)
Specified by:
readDouble in interface net.sf.cglib.transform.impl.InterceptFieldCallback

readFloat

public float readFloat(Object target,
                       String name,
                       float oldValue)
Specified by:
readFloat in interface net.sf.cglib.transform.impl.InterceptFieldCallback

readInt

public int readInt(Object target,
                   String name,
                   int oldValue)
Specified by:
readInt in interface net.sf.cglib.transform.impl.InterceptFieldCallback

readLong

public long readLong(Object target,
                     String name,
                     long oldValue)
Specified by:
readLong in interface net.sf.cglib.transform.impl.InterceptFieldCallback

readShort

public short readShort(Object target,
                       String name,
                       short oldValue)
Specified by:
readShort in interface net.sf.cglib.transform.impl.InterceptFieldCallback

readObject

public Object readObject(Object target,
                         String name,
                         Object oldValue)
Specified by:
readObject in interface net.sf.cglib.transform.impl.InterceptFieldCallback

writeBoolean

public boolean writeBoolean(Object target,
                            String name,
                            boolean oldValue,
                            boolean newValue)
Specified by:
writeBoolean in interface net.sf.cglib.transform.impl.InterceptFieldCallback

writeByte

public byte writeByte(Object target,
                      String name,
                      byte oldValue,
                      byte newValue)
Specified by:
writeByte in interface net.sf.cglib.transform.impl.InterceptFieldCallback

writeChar

public char writeChar(Object target,
                      String name,
                      char oldValue,
                      char newValue)
Specified by:
writeChar in interface net.sf.cglib.transform.impl.InterceptFieldCallback

writeDouble

public double writeDouble(Object target,
                          String name,
                          double oldValue,
                          double newValue)
Specified by:
writeDouble in interface net.sf.cglib.transform.impl.InterceptFieldCallback

writeFloat

public float writeFloat(Object target,
                        String name,
                        float oldValue,
                        float newValue)
Specified by:
writeFloat in interface net.sf.cglib.transform.impl.InterceptFieldCallback

writeInt

public int writeInt(Object target,
                    String name,
                    int oldValue,
                    int newValue)
Specified by:
writeInt in interface net.sf.cglib.transform.impl.InterceptFieldCallback

writeLong

public long writeLong(Object target,
                      String name,
                      long oldValue,
                      long newValue)
Specified by:
writeLong in interface net.sf.cglib.transform.impl.InterceptFieldCallback

writeShort

public short writeShort(Object target,
                        String name,
                        short oldValue,
                        short newValue)
Specified by:
writeShort in interface net.sf.cglib.transform.impl.InterceptFieldCallback

writeObject

public Object writeObject(Object target,
                          String name,
                          Object oldValue,
                          Object newValue)
Specified by:
writeObject in interface net.sf.cglib.transform.impl.InterceptFieldCallback

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.intercept.javassist (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.intercept.javassist

Class Summary
FieldInterceptorImpl | A field-level interceptor that initializes lazily fetched properties.
JavassistHelper |


org.hibernate.intercept.javassist Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.intercept.javassist

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.intercept.AbstractFieldInterceptor (implements org.hibernate.intercept.FieldInterceptor, java.io.Serializable)
      • class org.hibernate.intercept.javassist.FieldInterceptorImpl (implements org.hibernate.bytecode.javassist.FieldHandler, java.io.Serializable)
    • class org.hibernate.intercept.javassist.JavassistHelper


Uses of Package org.hibernate.intercept.javassist (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.intercept.javassist

No usage of org.hibernate.intercept.javassist

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


FieldInterceptorImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.intercept.javassist
Class FieldInterceptorImpl

java.lang.Object
    extended by org.hibernate.intercept.AbstractFieldInterceptor
        extended by org.hibernate.intercept.javassist.FieldInterceptorImpl
All Implemented Interfaces:
FieldHandler, FieldInterceptor, Serializable
public final class FieldInterceptorImpl
extends AbstractFieldInterceptor
implements FieldHandler, Serializable

A field-level interceptor that initializes lazily fetched properties. This interceptor can be attached to classes instrumented by Javassist. Note that this implementation assumes that the instance variable name is the same as the name of the persistent property that must be loaded.

Note: most of the interesting functionality here is farmed off to the super-class. The stuff here mainly acts as an adapter to the Javassist-specific functionality, routing interception through the super-class's intercept() method

Author:
Steve Ebersole
See Also:
Serialized Form

Method Summary
boolean | readBoolean(Object target, String name, boolean oldValue)
byte | readByte(Object target, String name, byte oldValue)
char | readChar(Object target, String name, char oldValue)
double | readDouble(Object target, String name, double oldValue)
float | readFloat(Object target, String name, float oldValue)
int | readInt(Object target, String name, int oldValue)
long | readLong(Object target, String name, long oldValue)
Object | readObject(Object target, String name, Object oldValue)
short | readShort(Object target, String name, short oldValue)
String | toString()
boolean | writeBoolean(Object target, String name, boolean oldValue, boolean newValue)
byte | writeByte(Object target, String name, byte oldValue, byte newValue)
char | writeChar(Object target, String name, char oldValue, char newValue)
double | writeDouble(Object target, String name, double oldValue, double newValue)
float | writeFloat(Object target, String name, float oldValue, float newValue)
int | writeInt(Object target, String name, int oldValue, int newValue) Called to handle writing an int value to a given field.
long | writeLong(Object target, String name, long oldValue, long newValue)
Object | writeObject(Object target, String name, Object oldValue, Object newValue)
short | writeShort(Object target, String name, short oldValue, short newValue)
Methods inherited from class org.hibernate.intercept.AbstractFieldInterceptor
clearDirty, dirty, getEntityName, getSession, getUninitializedFields, intercept, isDirty, isInitialized, isInitialized, isInitializing, setSession
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

readBoolean

public boolean readBoolean(Object target,
                           String name,
                           boolean oldValue)
Specified by:
readBoolean in interface FieldHandler

readByte

public byte readByte(Object target,
                     String name,
                     byte oldValue)
Specified by:
readByte in interface FieldHandler

readChar

public char readChar(Object target,
                     String name,
                     char oldValue)
Specified by:
readChar in interface FieldHandler

readDouble

public double readDouble(Object target,
                         String name,
                         double oldValue)
Specified by:
readDouble in interface FieldHandler

readFloat

public float readFloat(Object target,
                       String name,
                       float oldValue)
Specified by:
readFloat in interface FieldHandler

readInt

public int readInt(Object target,
                   String name,
                   int oldValue)
Specified by:
readInt in interface FieldHandler

readLong

public long readLong(Object target,
                     String name,
                     long oldValue)
Specified by:
readLong in interface FieldHandler

readShort

public short readShort(Object target,
                       String name,
                       short oldValue)
Specified by:
readShort in interface FieldHandler

readObject

public Object readObject(Object target,
                         String name,
                         Object oldValue)
Specified by:
readObject in interface FieldHandler

writeBoolean

public boolean writeBoolean(Object target,
                            String name,
                            boolean oldValue,
                            boolean newValue)
Specified by:
writeBoolean in interface FieldHandler

writeByte

public byte writeByte(Object target,
                      String name,
                      byte oldValue,
                      byte newValue)
Specified by:
writeByte in interface FieldHandler

writeChar

public char writeChar(Object target,
                      String name,
                      char oldValue,
                      char newValue)
Specified by:
writeChar in interface FieldHandler

writeDouble

public double writeDouble(Object target,
                          String name,
                          double oldValue,
                          double newValue)
Specified by:
writeDouble in interface FieldHandler

writeFloat

public float writeFloat(Object target,
                        String name,
                        float oldValue,
                        float newValue)
Specified by:
writeFloat in interface FieldHandler

writeInt

public int writeInt(Object target,
                    String name,
                    int oldValue,
                    int newValue)
Description copied from interface: FieldHandler
Called to handle writing an int value to a given field.

Specified by:
writeInt in interface FieldHandler
Parameters:
target - ?
name - The name of the field being written
oldValue - The old field value
newValue - The new field value.
Returns:
?

writeLong

public long writeLong(Object target,
                      String name,
                      long oldValue,
                      long newValue)
Specified by:
writeLong in interface FieldHandler

writeShort

public short writeShort(Object target,
                        String name,
                        short oldValue,
                        short newValue)
Specified by:
writeShort in interface FieldHandler

writeObject

public Object writeObject(Object target,
                          String name,
                          Object oldValue,
                          Object newValue)
Specified by:
writeObject in interface FieldHandler

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JavassistHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.intercept.javassist
Class JavassistHelper

java.lang.Object
    extended by org.hibernate.intercept.javassist.JavassistHelper
public class JavassistHelper
extends Object

Author:
Steve Ebersole

Method Summary
static FieldInterceptor | extractFieldInterceptor(Object entity)
static FieldInterceptor | injectFieldInterceptor(Object entity, String entityName, Set uninitializedFieldNames, SessionImplementor session)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

extractFieldInterceptor

public static FieldInterceptor extractFieldInterceptor(Object entity)

injectFieldInterceptor

public static FieldInterceptor injectFieldInterceptor(Object entity,
                                                      String entityName,
                                                      Set uninitializedFieldNames,
                                                      SessionImplementor session)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.jdbc (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.jdbc

This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.

See:
Description

Interface Summary
Batcher | Manages PreparedStatements for a session.
BatcherFactory | Factory for Batcher instances.
ConnectionManager.Callback |
Expectation | Defines an expected DML operation outcome.
JDBCContext.Context |

Class Summary
AbstractBatcher | Manages prepared statements and batching.
BatchingBatcher | An implementation of the Batcher interface that actually uses batching
BatchingBatcherFactory | A BatcherFactory implementation which constructs Batcher instances capable of actually performing batch operations.
BorrowedConnectionProxy | A proxy for borrowed connections which funnels all requests back into the ConnectionManager from which it was borrowed to be properly handled (in terms of connection release modes).
ColumnNameCache | Implementation of ColumnNameCache.
ConnectionManager | Encapsulates JDBC Connection management logic needed by Hibernate.
Expectations | Holds various often used Expectations.BasicExpectation definitions.
Expectations.BasicExpectation |
Expectations.BasicParamExpectation |
JDBCContext | Acts as the mediary between "entity-mode related" sessions in terms of their interaction with the JDBC data store.
NonBatchingBatcher | An implementation of the Batcher interface that does no batching
NonBatchingBatcherFactory | A BatcherFactory implementation which constructs Batcher instances that do not perform batch operations.
ResultSetWrapper | A ResultSet delegate, responsible for locally caching the columnName-to-columnIndex resolution that has been found to be inefficient in a few vendor's drivers (i.e., Oracle and Postgres).

Exception Summary
BatchedTooManyRowsAffectedException | Much like TooManyRowsAffectedException, indicates that more rows than what we were expcecting were affected.
BatchFailedException | Indicates a failed batch entry (-3 return).
TooManyRowsAffectedException | Indicates that more rows were affected then we were expecting to be.

Package org.hibernate.jdbc Description

This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.

Concrete implementations of the Batcher interface may be selected by specifying hibernate.jdbc.factory_class.


org.hibernate.jdbc Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.jdbc

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.jdbc.AbstractBatcher (implements org.hibernate.jdbc.Batcher)
      • class org.hibernate.jdbc.BatchingBatcher
      • class org.hibernate.jdbc.NonBatchingBatcher
    • class org.hibernate.jdbc.BatchingBatcherFactory (implements org.hibernate.jdbc.BatcherFactory)
    • class org.hibernate.jdbc.BorrowedConnectionProxy (implements java.lang.reflect.InvocationHandler)
    • class org.hibernate.jdbc.ColumnNameCache
    • class org.hibernate.jdbc.ConnectionManager (implements java.io.Serializable)
    • class org.hibernate.jdbc.Expectations
    • class org.hibernate.jdbc.Expectations.BasicExpectation (implements org.hibernate.jdbc.Expectation)
      • class org.hibernate.jdbc.Expectations.BasicParamExpectation
    • class org.hibernate.jdbc.JDBCContext (implements org.hibernate.jdbc.ConnectionManager.Callback, java.io.Serializable)
    • class org.hibernate.jdbc.NonBatchingBatcherFactory (implements org.hibernate.jdbc.BatcherFactory)
    • class org.hibernate.jdbc.ResultSetWrapper (implements java.sql.ResultSet)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class org.hibernate.exception.NestableRuntimeException (implements org.hibernate.exception.Nestable)
            • class org.hibernate.HibernateException
              • class org.hibernate.jdbc.BatchFailedException
              • class org.hibernate.jdbc.TooManyRowsAffectedException
                • class org.hibernate.jdbc.BatchedTooManyRowsAffectedException

Interface Hierarchy

  • interface org.hibernate.jdbc.Batcher
  • interface org.hibernate.jdbc.BatcherFactory
  • interface org.hibernate.jdbc.ConnectionManager.Callback
  • interface org.hibernate.jdbc.Expectation
  • interface org.hibernate.transaction.TransactionFactory.Context
    • interface org.hibernate.jdbc.JDBCContext.Context


Uses of Package org.hibernate.jdbc (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.jdbc

Packages that use org.hibernate.jdbc
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.

Classes in org.hibernate.jdbc used by org.hibernate.cfg
BatcherFactory
Factory for Batcher instances.

Classes in org.hibernate.jdbc used by org.hibernate.engine
Batcher
Manages PreparedStatements for a session.
JDBCContext
Acts as the mediary between "entity-mode related" sessions in terms of their interaction with the JDBC data store.

Classes in org.hibernate.jdbc used by org.hibernate.impl
Batcher
Manages PreparedStatements for a session.
BatcherFactory
Factory for Batcher instances.
JDBCContext
Acts as the mediary between "entity-mode related" sessions in terms of their interaction with the JDBC data store.
JDBCContext.Context

Classes in org.hibernate.jdbc used by org.hibernate.jdbc
AbstractBatcher
Manages prepared statements and batching.
Batcher
Manages PreparedStatements for a session.
BatcherFactory
Factory for Batcher instances.
ColumnNameCache
Implementation of ColumnNameCache.
ConnectionManager
Encapsulates JDBC Connection management logic needed by Hibernate.
ConnectionManager.Callback
Expectation
Defines an expected DML operation outcome.
Expectations.BasicExpectation
JDBCContext
Acts as the mediary between "entity-mode related" sessions in terms of their interaction with the JDBC data store.
JDBCContext.Context
ResultSetWrapper
A ResultSet delegate, responsible for locally caching the columnName-to-columnIndex resolution that has been found to be inefficient in a few vendor's drivers (i.e., Oracle and Postgres).
TooManyRowsAffectedException
Indicates that more rows were affected then we were expecting to be.

Classes in org.hibernate.jdbc used by org.hibernate.persister.entity
Expectation
Defines an expected DML operation outcome.

Classes in org.hibernate.jdbc used by org.hibernate.transaction
JDBCContext
Acts as the mediary between "entity-mode related" sessions in terms of their interaction with the JDBC data store.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Batcher (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Interface Batcher

All Known Implementing Classes:
AbstractBatcher
public interface Batcher

Manages PreparedStatements for a session. Abstracts JDBC batching to maintain the illusion that a single logical batch exists for the whole session, even when batching is disabled. Provides transparent PreparedStatement caching.

Author:
Gavin King
See Also:
PreparedStatement, SessionImpl

Method Summary
 void abortBatch(SQLException sqle)
Must be called when an exception occurs
 void addToBatch(Expectation expectation)
Add an insert / delete / update to the current batch (might be called multiple times for single prepareBatchStatement())
 void cancelLastQuery()
Cancel the current query statement
 void closeConnection(Connection conn)
Dispose of the JDBC connection
 void closeQueryStatement(PreparedStatement ps, ResultSet rs)
Close a prepared statement opened with prepareQueryStatement()
 void closeStatement(PreparedStatement ps)
Close a prepared or callable statement opened using prepareStatement() or prepareCallableStatement()
 void closeStatements()
Close any query statements that were left lying around
 void executeBatch()
Execute the batch
 ResultSet getResultSet(CallableStatement ps, Dialect dialect)
Execute the statement and return the result set from a callable statement
 ResultSet getResultSet(PreparedStatement ps)
Execute the statement and return the result set
 boolean hasOpenResources()
 Connection openConnection()
Obtain a JDBC connection
 String openResourceStatsAsString()
 CallableStatement prepareBatchCallableStatement(String sql)
Get a batchable callable statement to use for inserting / deleting / updating (might be called many times before a single call to executeBatch()).
 PreparedStatement prepareBatchStatement(String sql)
Get a batchable prepared statement to use for inserting / deleting / updating (might be called many times before a single call to executeBatch()).
 CallableStatement prepareCallableQueryStatement(String sql, boolean scrollable, ScrollMode scrollMode)
Get a prepared statement for use in loading / querying.
 CallableStatement prepareCallableStatement(String sql)
Get a non-batchable callable statement to use for inserting / deleting / updating.
 PreparedStatement prepareQueryStatement(String sql, boolean scrollable, ScrollMode scrollMode)
Get a prepared statement for use in loading / querying.
 PreparedStatement prepareSelectStatement(String sql)
Get a non-batchable prepared statement to use for selecting.
 PreparedStatement prepareStatement(String sql)
Get a non-batchable prepared statement to use for inserting / deleting / updating.
 PreparedStatement prepareStatement(String sql, boolean useGetGeneratedKeys)
Get a non-batchable prepared statement to use for inserting / deleting / updating, using JDBC3 getGeneratedKeys (Connection.prepareStatement(String, int)).
 PreparedStatement prepareStatement(String sql, String[] columnNames)
Get a non-batchable prepared statement to use for inserting / deleting / updating.
 void setTransactionTimeout(int seconds)
Set the transaction timeout to seconds later than the current system time.
 void unsetTransactionTimeout()
Unset the transaction timeout, called after the end of a transaction.

Method Detail

prepareQueryStatement

public PreparedStatement prepareQueryStatement(String sql,
                                               boolean scrollable,
                                               ScrollMode scrollMode)
                                        throws SQLException,
                                               HibernateException
Get a prepared statement for use in loading / querying. If not explicitly released by closeQueryStatement(), it will be released when the session is closed or disconnected.

Throws:
SQLException
HibernateException

closeQueryStatement

public void closeQueryStatement(PreparedStatement ps,
                                ResultSet rs)
                         throws SQLException
Close a prepared statement opened with prepareQueryStatement()

Throws:
SQLException

prepareCallableQueryStatement

public CallableStatement prepareCallableQueryStatement(String sql,
                                                       boolean scrollable,
                                                       ScrollMode scrollMode)
                                                throws SQLException,
                                                       HibernateException
Get a prepared statement for use in loading / querying. If not explicitly released by closeQueryStatement(), it will be released when the session is closed or disconnected.

Throws:
SQLException
HibernateException

prepareSelectStatement

public PreparedStatement prepareSelectStatement(String sql)
                                         throws SQLException,
                                                HibernateException
Get a non-batchable prepared statement to use for selecting. Does not result in execution of the current batch.

Throws:
SQLException
HibernateException

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          boolean useGetGeneratedKeys)
                                   throws SQLException,
                                          HibernateException
Get a non-batchable prepared statement to use for inserting / deleting / updating, using JDBC3 getGeneratedKeys (Connection.prepareStatement(String, int)).

Must be explicitly released by closeStatement(java.sql.PreparedStatement) after use.

Throws:
SQLException
HibernateException

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          String[] columnNames)
                                   throws SQLException,
                                          HibernateException
Get a non-batchable prepared statement to use for inserting / deleting / updating. using JDBC3 getGeneratedKeys (Connection.prepareStatement(String, String[])).

Must be explicitly released by closeStatement(java.sql.PreparedStatement) after use.

Throws:
SQLException
HibernateException

prepareStatement

public PreparedStatement prepareStatement(String sql)
                                   throws SQLException,
                                          HibernateException
Get a non-batchable prepared statement to use for inserting / deleting / updating.

Must be explicitly released by closeStatement(java.sql.PreparedStatement) after use.

Throws:
SQLException
HibernateException

prepareCallableStatement

public CallableStatement prepareCallableStatement(String sql)
                                           throws SQLException,
                                                  HibernateException
Get a non-batchable callable statement to use for inserting / deleting / updating.

Must be explicitly released by closeStatement(java.sql.PreparedStatement) after use.

Throws:
SQLException
HibernateException

closeStatement

public void closeStatement(PreparedStatement ps)
                    throws SQLException
Close a prepared or callable statement opened using prepareStatement() or prepareCallableStatement()

Throws:
SQLException

prepareBatchStatement

public PreparedStatement prepareBatchStatement(String sql)
                                        throws SQLException,
                                               HibernateException
Get a batchable prepared statement to use for inserting / deleting / updating (might be called many times before a single call to executeBatch()). After setting parameters, call addToBatch - do not execute the statement explicitly.

Throws:
SQLException
HibernateException
See Also:
addToBatch(org.hibernate.jdbc.Expectation)

prepareBatchCallableStatement

public CallableStatement prepareBatchCallableStatement(String sql)
                                                throws SQLException,
                                                       HibernateException
Get a batchable callable statement to use for inserting / deleting / updating (might be called many times before a single call to executeBatch()). After setting parameters, call addToBatch - do not execute the statement explicitly.

Throws:
SQLException
HibernateException
See Also:
addToBatch(org.hibernate.jdbc.Expectation)

addToBatch

public void addToBatch(Expectation expectation)
                throws SQLException,
                       HibernateException
Add an insert / delete / update to the current batch (might be called multiple times for single prepareBatchStatement())

Throws:
SQLException
HibernateException

executeBatch

public void executeBatch()
                  throws HibernateException
Execute the batch

Throws:
HibernateException

closeStatements

public void closeStatements()
Close any query statements that were left lying around

getResultSet

public ResultSet getResultSet(PreparedStatement ps)
                       throws SQLException
Execute the statement and return the result set

Throws:
SQLException

getResultSet

public ResultSet getResultSet(CallableStatement ps,
                              Dialect dialect)
                       throws SQLException
Execute the statement and return the result set from a callable statement

Throws:
SQLException

abortBatch

public void abortBatch(SQLException sqle)
Must be called when an exception occurs

Parameters:
sqle - the (not null) exception that is the reason for aborting

cancelLastQuery

public void cancelLastQuery()
                     throws HibernateException
Cancel the current query statement

Throws:
HibernateException

hasOpenResources

public boolean hasOpenResources()

openResourceStatsAsString

public String openResourceStatsAsString()

openConnection

public Connection openConnection()
                          throws HibernateException
Obtain a JDBC connection

Throws:
HibernateException

closeConnection

public void closeConnection(Connection conn)
                     throws HibernateException
Dispose of the JDBC connection

Throws:
HibernateException

setTransactionTimeout

public void setTransactionTimeout(int seconds)
Set the transaction timeout to seconds later than the current system time.

unsetTransactionTimeout

public void unsetTransactionTimeout()
Unset the transaction timeout, called after the end of a transaction.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BatcherFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Interface BatcherFactory

All Known Implementing Classes:
BatchingBatcherFactory, NonBatchingBatcherFactory
public interface BatcherFactory

Factory for Batcher instances.

Author:
Gavin King

Method Summary
 Batcher createBatcher(ConnectionManager connectionManager, Interceptor interceptor)

Method Detail

createBatcher

public Batcher createBatcher(ConnectionManager connectionManager,
                             Interceptor interceptor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Expectation (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Interface Expectation

All Known Implementing Classes:
Expectations.BasicExpectation
public interface Expectation

Defines an expected DML operation outcome.

Author:
Steve Ebersole

Method Summary
boolean | canBeBatched()
int | prepare(PreparedStatement statement)
void | verifyOutcome(int rowCount, PreparedStatement statement, int batchPosition)

Method Detail

verifyOutcome

public void verifyOutcome(int rowCount,
                          PreparedStatement statement,
                          int batchPosition)
                   throws SQLException,
                          HibernateException
Throws:
SQLException
HibernateException

prepare

public int prepare(PreparedStatement statement)
            throws SQLException,
                   HibernateException
Throws:
SQLException
HibernateException

canBeBatched

public boolean canBeBatched()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractBatcher (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class AbstractBatcher

java.lang.Object
    extended by org.hibernate.jdbc.AbstractBatcher
All Implemented Interfaces:
Batcher
Direct Known Subclasses:
BatchingBatcher, NonBatchingBatcher
public abstract class AbstractBatcher
extends Object
implements Batcher

Manages prepared statements and batching.

Author:
Gavin King

Field Summary
protected static org.apache.commons.logging.Log | log
protected static org.apache.commons.logging.Log | SQL_LOG
Constructor Summary
AbstractBatcher(ConnectionManager connectionManager, Interceptor interceptor)
Method Summary
 void abortBatch(SQLException sqle)
Must be called when an exception occurs
 void cancelLastQuery()
Cancel the current query statement
 void closeConnection(Connection conn)
Dispose of the JDBC connection
 void closeQueryStatement(PreparedStatement ps, ResultSet rs)
Close a prepared statement opened with prepareQueryStatement()
 void closeStatement(PreparedStatement ps)
Close a prepared or callable statement opened using prepareStatement() or prepareCallableStatement()
 void closeStatements()
Actually releases the batcher, allowing it to cleanup internally held resources.
protected abstract  void doExecuteBatch(PreparedStatement ps)
 void executeBatch()
Execute the batch
protected  SessionFactoryImplementor getFactory()
 ResultSet getResultSet(CallableStatement ps, Dialect dialect)
Execute the statement and return the result set from a callable statement
 ResultSet getResultSet(PreparedStatement ps)
Execute the statement and return the result set
protected  PreparedStatement getStatement()
 boolean hasOpenResources()
 Connection openConnection()
Obtain a JDBC connection
 String openResourceStatsAsString()
 CallableStatement prepareBatchCallableStatement(String sql)
Get a batchable callable statement to use for inserting / deleting / updating (might be called many times before a single call to executeBatch()).
 PreparedStatement prepareBatchStatement(String sql)
Get a batchable prepared statement to use for inserting / deleting / updating (might be called many times before a single call to executeBatch()).
 CallableStatement prepareCallableQueryStatement(String sql, boolean scrollable, ScrollMode scrollMode)
Get a prepared statement for use in loading / querying.
 CallableStatement prepareCallableStatement(String sql)
Get a non-batchable callable statement to use for inserting / deleting / updating.
 PreparedStatement prepareQueryStatement(String sql, boolean scrollable, ScrollMode scrollMode)
Get a prepared statement for use in loading / querying.
 PreparedStatement prepareSelectStatement(String sql)
Get a non-batchable prepared statement to use for selecting.
 PreparedStatement prepareStatement(String sql)
Get a non-batchable prepared statement to use for inserting / deleting / updating.
 PreparedStatement prepareStatement(String sql, boolean getGeneratedKeys)
Get a non-batchable prepared statement to use for inserting / deleting / updating, using JDBC3 getGeneratedKeys (Connection.prepareStatement(String, int)).
 PreparedStatement prepareStatement(String sql, String[] columnNames)
Get a non-batchable prepared statement to use for inserting / deleting / updating.
 void setTransactionTimeout(int seconds)
Set the transaction timeout to seconds later than the current system time.
 void unsetTransactionTimeout()
Unset the transaction timeout, called after the end of a transaction.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.jdbc.Batcher
addToBatch

Field Detail

log

protected static final org.apache.commons.logging.Log log

SQL_LOG

protected static final org.apache.commons.logging.Log SQL_LOG
Constructor Detail

AbstractBatcher

public AbstractBatcher(ConnectionManager connectionManager,
                       Interceptor interceptor)
Method Detail

setTransactionTimeout

public void setTransactionTimeout(int seconds)
Description copied from interface: Batcher
Set the transaction timeout to seconds later than the current system time.

Specified by:
setTransactionTimeout in interface Batcher

unsetTransactionTimeout

public void unsetTransactionTimeout()
Description copied from interface: Batcher
Unset the transaction timeout, called after the end of a transaction.

Specified by:
unsetTransactionTimeout in interface Batcher

getStatement

protected PreparedStatement getStatement()

prepareCallableStatement

public CallableStatement prepareCallableStatement(String sql)
                                           throws SQLException,
                                                  HibernateException
Description copied from interface: Batcher
Get a non-batchable callable statement to use for inserting / deleting / updating.

Must be explicitly released by Batcher.closeStatement(java.sql.PreparedStatement) after use.

Specified by:
prepareCallableStatement in interface Batcher
Throws:
SQLException
HibernateException

prepareStatement

public PreparedStatement prepareStatement(String sql)
                                   throws SQLException,
                                          HibernateException
Description copied from interface: Batcher
Get a non-batchable prepared statement to use for inserting / deleting / updating.

Must be explicitly released by Batcher.closeStatement(java.sql.PreparedStatement) after use.

Specified by:
prepareStatement in interface Batcher
Throws:
SQLException
HibernateException

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          boolean getGeneratedKeys)
                                   throws SQLException,
                                          HibernateException
Description copied from interface: Batcher
Get a non-batchable prepared statement to use for inserting / deleting / updating, using JDBC3 getGeneratedKeys (Connection.prepareStatement(String, int)).

Must be explicitly released by Batcher.closeStatement(java.sql.PreparedStatement) after use.

Specified by:
prepareStatement in interface Batcher
Throws:
SQLException
HibernateException

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          String[] columnNames)
                                   throws SQLException,
                                          HibernateException
Description copied from interface: Batcher
Get a non-batchable prepared statement to use for inserting / deleting / updating. using JDBC3 getGeneratedKeys (Connection.prepareStatement(String, String[])).

Must be explicitly released by Batcher.closeStatement(java.sql.PreparedStatement) after use.

Specified by:
prepareStatement in interface Batcher
Throws:
SQLException
HibernateException

prepareSelectStatement

public PreparedStatement prepareSelectStatement(String sql)
                                         throws SQLException,
                                                HibernateException
Description copied from interface: Batcher
Get a non-batchable prepared statement to use for selecting. Does not result in execution of the current batch.

Specified by:
prepareSelectStatement in interface Batcher
Throws:
SQLException
HibernateException

prepareQueryStatement

public PreparedStatement prepareQueryStatement(String sql,
                                               boolean scrollable,
                                               ScrollMode scrollMode)
                                        throws SQLException,
                                               HibernateException
Description copied from interface: Batcher
Get a prepared statement for use in loading / querying. If not explicitly released by closeQueryStatement(), it will be released when the session is closed or disconnected.

Specified by:
prepareQueryStatement in interface Batcher
Throws:
SQLException
HibernateException

prepareCallableQueryStatement

public CallableStatement prepareCallableQueryStatement(String sql,
                                                       boolean scrollable,
                                                       ScrollMode scrollMode)
                                                throws SQLException,
                                                       HibernateException
Description copied from interface: Batcher
Get a prepared statement for use in loading / querying. If not explicitly released by closeQueryStatement(), it will be released when the session is closed or disconnected.

Specified by:
prepareCallableQueryStatement in interface Batcher
Throws:
SQLException
HibernateException

abortBatch

public void abortBatch(SQLException sqle)
Description copied from interface: Batcher
Must be called when an exception occurs

Specified by:
abortBatch in interface Batcher
Parameters:
sqle - the (not null) exception that is the reason for aborting

getResultSet

public ResultSet getResultSet(PreparedStatement ps)
                       throws SQLException
Description copied from interface: Batcher
Execute the statement and return the result set

Specified by:
getResultSet in interface Batcher
Throws:
SQLException

getResultSet

public ResultSet getResultSet(CallableStatement ps,
                              Dialect dialect)
                       throws SQLException
Description copied from interface: Batcher
Execute the statement and return the result set from a callable statement

Specified by:
getResultSet in interface Batcher
Throws:
SQLException

closeQueryStatement

public void closeQueryStatement(PreparedStatement ps,
                                ResultSet rs)
                         throws SQLException
Description copied from interface: Batcher
Close a prepared statement opened with prepareQueryStatement()

Specified by:
closeQueryStatement in interface Batcher
Throws:
SQLException

prepareBatchStatement

public PreparedStatement prepareBatchStatement(String sql)
                                        throws SQLException,
                                               HibernateException
Description copied from interface: Batcher
Get a batchable prepared statement to use for inserting / deleting / updating (might be called many times before a single call to executeBatch()). After setting parameters, call addToBatch - do not execute the statement explicitly.

Specified by:
prepareBatchStatement in interface Batcher
Throws:
SQLException
HibernateException
See Also:
Batcher.addToBatch(org.hibernate.jdbc.Expectation)

prepareBatchCallableStatement

public CallableStatement prepareBatchCallableStatement(String sql)
                                                throws SQLException,
                                                       HibernateException
Description copied from interface: Batcher
Get a batchable callable statement to use for inserting / deleting / updating (might be called many times before a single call to executeBatch()). After setting parameters, call addToBatch - do not execute the statement explicitly.

Specified by:
prepareBatchCallableStatement in interface Batcher
Throws:
SQLException
HibernateException
See Also:
Batcher.addToBatch(org.hibernate.jdbc.Expectation)

executeBatch

public void executeBatch()
                  throws HibernateException
Description copied from interface: Batcher
Execute the batch

Specified by:
executeBatch in interface Batcher
Throws:
HibernateException

closeStatement

public void closeStatement(PreparedStatement ps)
                    throws SQLException
Description copied from interface: Batcher
Close a prepared or callable statement opened using prepareStatement() or prepareCallableStatement()

Specified by:
closeStatement in interface Batcher
Throws:
SQLException

closeStatements

public void closeStatements()
Actually releases the batcher, allowing it to cleanup internally held resources.

Specified by:
closeStatements in interface Batcher

doExecuteBatch

protected abstract void doExecuteBatch(PreparedStatement ps)
                                throws SQLException,
                                       HibernateException
Throws:
SQLException
HibernateException

getFactory

protected SessionFactoryImplementor getFactory()

openConnection

public Connection openConnection()
                          throws HibernateException
Description copied from interface: Batcher
Obtain a JDBC connection

Specified by:
openConnection in interface Batcher
Throws:
HibernateException

closeConnection

public void closeConnection(Connection conn)
                     throws HibernateException
Description copied from interface: Batcher
Dispose of the JDBC connection

Specified by:
closeConnection in interface Batcher
Throws:
HibernateException

cancelLastQuery

public void cancelLastQuery()
                     throws HibernateException
Description copied from interface: Batcher
Cancel the current query statement

Specified by:
cancelLastQuery in interface Batcher
Throws:
HibernateException

hasOpenResources

public boolean hasOpenResources()
Specified by:
hasOpenResources in interface Batcher

openResourceStatsAsString

public String openResourceStatsAsString()
Specified by:
openResourceStatsAsString in interface Batcher
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BatchingBatcher (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class BatchingBatcher

java.lang.Object
    extended by org.hibernate.jdbc.AbstractBatcher
        extended by org.hibernate.jdbc.BatchingBatcher
All Implemented Interfaces:
Batcher
public class BatchingBatcher
extends AbstractBatcher

An implementation of the Batcher interface that actually uses batching

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.jdbc.AbstractBatcher
log, SQL_LOG
Constructor Summary
BatchingBatcher(ConnectionManager connectionManager, Interceptor interceptor)
Method Summary
void | addToBatch(Expectation expectation) Add an insert / delete / update to the current batch (might be called multiple times for single prepareBatchStatement())
protected void | doExecuteBatch(PreparedStatement ps)
Methods inherited from class org.hibernate.jdbc.AbstractBatcher
abortBatch, cancelLastQuery, closeConnection, closeQueryStatement, closeStatement, closeStatements, executeBatch, getFactory, getResultSet, getResultSet, getStatement, hasOpenResources, openConnection, openResourceStatsAsString, prepareBatchCallableStatement, prepareBatchStatement, prepareCallableQueryStatement, prepareCallableStatement, prepareQueryStatement, prepareSelectStatement, prepareStatement, prepareStatement, prepareStatement, setTransactionTimeout, unsetTransactionTimeout
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BatchingBatcher

public BatchingBatcher(ConnectionManager connectionManager,
                       Interceptor interceptor)
Method Detail

addToBatch

public void addToBatch(Expectation expectation)
                throws SQLException,
                       HibernateException
Description copied from interface: Batcher
Add an insert / delete / update to the current batch (might be called multiple times for single prepareBatchStatement())

Throws:
SQLException
HibernateException

doExecuteBatch

protected void doExecuteBatch(PreparedStatement ps)
                       throws SQLException,
                              HibernateException
Specified by:
doExecuteBatch in class AbstractBatcher
Throws:
SQLException
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BatchingBatcherFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class BatchingBatcherFactory

java.lang.Object
    extended by org.hibernate.jdbc.BatchingBatcherFactory
All Implemented Interfaces:
BatcherFactory
public class BatchingBatcherFactory
extends Object
implements BatcherFactory

A BatcherFactory implementation which constructs Batcher instances capable of actually performing batch operations.

Author:
Gavin King

Constructor Summary
BatchingBatcherFactory()
Method Summary
 Batcher createBatcher(ConnectionManager connectionManager, Interceptor interceptor)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BatchingBatcherFactory

public BatchingBatcherFactory()
Method Detail

createBatcher

public Batcher createBatcher(ConnectionManager connectionManager,
                             Interceptor interceptor)
Specified by:
createBatcher in interface BatcherFactory
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BorrowedConnectionProxy (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class BorrowedConnectionProxy

java.lang.Object
    extended by org.hibernate.jdbc.BorrowedConnectionProxy
All Implemented Interfaces:
InvocationHandler
public class BorrowedConnectionProxy
extends Object
implements InvocationHandler

A proxy for borrowed connections which funnels all requests back into the ConnectionManager from which it was borrowed to be properly handled (in terms of connection release modes).

Note: the term borrowed here refers to connection references obtained via Session.connection() for application usage.

Author:
Steve Ebersole

Constructor Summary
BorrowedConnectionProxy(ConnectionManager connectionManager)
Method Summary
static Connection | generateProxy(ConnectionManager connectionManager)
Object | invoke(Object proxy, Method method, Object[] args)
static void | renderUnuseable(Connection connection)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BorrowedConnectionProxy

public BorrowedConnectionProxy(ConnectionManager connectionManager)
Method Detail

invoke

public Object invoke(Object proxy,
                     Method method,
                     Object[] args)
              throws Throwable
Specified by:
invoke in interface InvocationHandler
Throws:
Throwable

generateProxy

public static Connection generateProxy(ConnectionManager connectionManager)

renderUnuseable

public static void renderUnuseable(Connection connection)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ColumnNameCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class ColumnNameCache

java.lang.Object
    extended by org.hibernate.jdbc.ColumnNameCache
public class ColumnNameCache
extends Object

Implementation of ColumnNameCache.

Author:
Steve Ebersole

Constructor Summary
ColumnNameCache(int columnCount)
Method Summary
 int getIndexForColumnName(String columnName, ResultSetWrapper rs)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ColumnNameCache

public ColumnNameCache(int columnCount)
Method Detail

getIndexForColumnName

public int getIndexForColumnName(String columnName,
                                 ResultSetWrapper rs)
                          throws SQLException
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConnectionManager (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class ConnectionManager

java.lang.Object
    extended by org.hibernate.jdbc.ConnectionManager
All Implemented Interfaces:
Serializable
public class ConnectionManager
extends Object
implements Serializable

Encapsulates JDBC Connection management logic needed by Hibernate.

The lifecycle is intended to span a logical series of interactions with the database. Internally, this means the the lifecycle of the Session.

Author:
Steve Ebersole
See Also:
Serialized Form

Nested Class Summary
static interface ConnectionManager.Callback
Constructor Summary
ConnectionManager(SessionFactoryImplementor factory, ConnectionManager.Callback callback, ConnectionReleaseMode releaseMode, Connection connection, Interceptor interceptor)
Constructs a ConnectionManager.
Method Summary
void | afterStatement() To be called after execution of each JDBC statement.
void | afterTransaction() To be called after local transaction completion.
Connection | borrowConnection()
Connection | close() To be called after Session completion.
static ConnectionManager | deserialize(ObjectInputStream ois, SessionFactoryImplementor factory, Interceptor interceptor, ConnectionReleaseMode connectionReleaseMode, JDBCContext jdbcContext)
void | flushBeginning() Callback to let us know that a flush is beginning.
void | flushEnding() Callback to let us know that a flush is ending.
Batcher | getBatcher() The batcher managed by this ConnectionManager.
Connection | getConnection() Retrieves the connection currently managed by this ConnectionManager.
SessionFactoryImplementor | getFactory() The session factory.
boolean | hasBorrowedConnection()
boolean | isAggressiveRelease() Will connections be released after each statement execution? Connections will be released after each statement if either: the defined release-mode is ConnectionReleaseMode.AFTER_STATEMENT; or the defined release-mode is ConnectionReleaseMode.AFTER_TRANSACTION but we are in auto-commit mode.
boolean | isAutoCommit() Is the connection considered "auto-commit"?
boolean | isCurrentlyConnected() Is this ConnectionManager instance "logically" connected.
boolean | isReadyForSerialization()
boolean | isSuppliedConnection() Was the connection being used here supplied by the user?
Connection | manualDisconnect() Manually disconnect the underlying JDBC Connection.
void | manualReconnect() Manually reconnect the underlying JDBC Connection.
void | manualReconnect(Connection suppliedConnection) Manually reconnect the underlying JDBC Connection.
void | releaseBorrowedConnection()
void | serialize(ObjectOutputStream oos)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConnectionManager

public ConnectionManager(SessionFactoryImplementor factory,
                         ConnectionManager.Callback callback,
                         ConnectionReleaseMode releaseMode,
                         Connection connection,
                         Interceptor interceptor)
Constructs a ConnectionManager.

This is the form used internally.

Parameters:
factory - The SessionFactory.
callback - An observer for internal state change.
releaseMode - The mode by which to release JDBC connections.
connection - An externally supplied connection.
Method Detail

getFactory

public SessionFactoryImplementor getFactory()
The session factory.

Returns:
the session factory.

getBatcher

public Batcher getBatcher()
The batcher managed by this ConnectionManager.

Returns:
The batcher.

isSuppliedConnection

public boolean isSuppliedConnection()
Was the connection being used here supplied by the user?

Returns:
True if the user supplied the JDBC connection; false otherwise

getConnection

public Connection getConnection()
                         throws HibernateException
Retrieves the connection currently managed by this ConnectionManager.

Note, that we may need to obtain a connection to return here if a connection has either not yet been obtained (non-UserSuppliedConnectionProvider) or has previously been aggressively released (if supported in this environment).

Returns:
The current Connection.
Throws:
HibernateException - Indicates a connection is currently not available (we are currently manually disconnected).

hasBorrowedConnection

public boolean hasBorrowedConnection()

borrowConnection

public Connection borrowConnection()

releaseBorrowedConnection

public void releaseBorrowedConnection()

isAutoCommit

public boolean isAutoCommit()
                     throws SQLException
Is the connection considered "auto-commit"?

Returns:
True if we either do not have a connection, or the connection really is in auto-commit mode.
Throws:
SQLException - Can be thrown by the Connection.isAutoCommit() check.

isAggressiveRelease

public boolean isAggressiveRelease()
Will connections be released after each statement execution?

Connections will be released after each statement if either:

  • the defined release-mode is ConnectionReleaseMode.AFTER_STATEMENT; or
  • the defined release-mode is ConnectionReleaseMode.AFTER_TRANSACTION but we are in auto-commit mode.

    release-mode = ConnectionReleaseMode.ON_CLOSE should [b]never[/b] release a connection.

    Returns:
    True if the connections will be released after each statement; false otherwise.

isCurrentlyConnected

public boolean isCurrentlyConnected()
Is this ConnectionManager instance "logically" connected. Meaning do we either have a cached connection available or do we have the ability to obtain a connection on demand.

Returns:
True if logically connected; false otherwise.

afterStatement

public void afterStatement()
To be called after execution of each JDBC statement. Used to conditionally release the JDBC connection aggressively if the configured release mode indicates.

afterTransaction

public void afterTransaction()
To be called after local transaction completion. Used to conditionally release the JDBC connection aggressively if the configured release mode indicates.

close

public Connection close()
To be called after Session completion. Used to release the JDBC connection.

Returns:
The connection mantained here at time of close. Null if there was no connection cached internally.

manualDisconnect

public Connection manualDisconnect()
Manually disconnect the underlying JDBC Connection. The assumption here is that the manager will be reconnected at a later point in time.

Returns:
The connection mantained here at time of disconnect. Null if there was no connection cached internally.

manualReconnect

public void manualReconnect()
Manually reconnect the underlying JDBC Connection. Should be called at some point after manualDisconnect().

This form is used for ConnectionProvider-supplied connections.

manualReconnect

public void manualReconnect(Connection suppliedConnection)
Manually reconnect the underlying JDBC Connection. Should be called at some point after manualDisconnect().

This form is used for user-supplied connections.

flushBeginning

public void flushBeginning()
Callback to let us know that a flush is beginning. We use this fact to temporarily circumvent aggressive connection releasing until after the flush cycle is complete flushEnding()

flushEnding

public void flushEnding()
Callback to let us know that a flush is ending. We use this fact to stop circumventing aggressive releasing connections.

isReadyForSerialization

public boolean isReadyForSerialization()

serialize

public void serialize(ObjectOutputStream oos)
               throws IOException
Throws:
IOException

deserialize

public static ConnectionManager deserialize(ObjectInputStream ois,
                                            SessionFactoryImplementor factory,
                                            Interceptor interceptor,
                                            ConnectionReleaseMode connectionReleaseMode,
                                            JDBCContext jdbcContext)
                                     throws IOException
Throws:
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConnectionManager.Callback (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Interface ConnectionManager.Callback

All Known Implementing Classes:
JDBCContext
Enclosing interface:
ConnectionManager
public static interface ConnectionManager.Callback

Method Summary
void | connectionCleanedUp()
void | connectionOpened()
boolean | isTransactionInProgress()

Method Detail

connectionOpened

public void connectionOpened()

connectionCleanedUp

public void connectionCleanedUp()

isTransactionInProgress

public boolean isTransactionInProgress()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Expectations (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class Expectations

java.lang.Object
    extended by org.hibernate.jdbc.Expectations
public class Expectations
extends Object

Holds various often used Expectations.BasicExpectation definitions.

Author:
Steve Ebersole

Nested Class Summary
static class | Expectations.BasicExpectation
static class | Expectations.BasicParamExpectation
Field Summary
static Expectation | BASIC
static Expectation | NONE
static Expectation | PARAM
static int | USUAL_EXPECTED_COUNT
static int | USUAL_PARAM_POSITION
Method Summary
static Expectation appropriateExpectation(ExecuteUpdateResultCheckStyle style)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

USUAL_EXPECTED_COUNT

public static final int USUAL_EXPECTED_COUNT
See Also:
Constant Field Values

USUAL_PARAM_POSITION

public static final int USUAL_PARAM_POSITION
See Also:
Constant Field Values

NONE

public static final Expectation NONE

BASIC

public static final Expectation BASIC

PARAM

public static final Expectation PARAM
Method Detail

appropriateExpectation

public static Expectation appropriateExpectation(ExecuteUpdateResultCheckStyle style)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Expectations.BasicExpectation (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class Expectations.BasicExpectation

java.lang.Object
    extended by org.hibernate.jdbc.Expectations.BasicExpectation
All Implemented Interfaces:
Expectation
Direct Known Subclasses:
Expectations.BasicParamExpectation
Enclosing class:
Expectations
public static class Expectations.BasicExpectation
extends Object
implements Expectation

Constructor Summary
protected Expectations.BasicExpectation(int expectedRowCount)
Method Summary
boolean | canBeBatched()
protected int | determineRowCount(int reportedRowCount, PreparedStatement statement)
int | prepare(PreparedStatement statement)
void | verifyOutcome(int rowCount, PreparedStatement statement, int batchPosition)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Expectations.BasicExpectation

protected Expectations.BasicExpectation(int expectedRowCount)
Method Detail

verifyOutcome

public final void verifyOutcome(int rowCount,
                                PreparedStatement statement,
                                int batchPosition)
Specified by:
verifyOutcome in interface Expectation

prepare

public int prepare(PreparedStatement statement)
            throws SQLException,
                   HibernateException
Specified by:
prepare in interface Expectation
Throws:
SQLException
HibernateException

canBeBatched

public boolean canBeBatched()
Specified by:
canBeBatched in interface Expectation

determineRowCount

protected int determineRowCount(int reportedRowCount,
                                PreparedStatement statement)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Expectations.BasicParamExpectation (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class Expectations.BasicParamExpectation

java.lang.Object
    extended by org.hibernate.jdbc.Expectations.BasicExpectation
        extended by org.hibernate.jdbc.Expectations.BasicParamExpectation
All Implemented Interfaces:
Expectation
Enclosing class:
Expectations
public static class Expectations.BasicParamExpectation
extends Expectations.BasicExpectation

Constructor Summary
protected Expectations.BasicParamExpectation(int expectedRowCount, int parameterPosition)
Method Summary
boolean | canBeBatched()
protected int | determineRowCount(int reportedRowCount, PreparedStatement statement)
int | prepare(PreparedStatement statement)
Methods inherited from class org.hibernate.jdbc.Expectations.BasicExpectation
verifyOutcome
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Expectations.BasicParamExpectation

protected Expectations.BasicParamExpectation(int expectedRowCount,
                                             int parameterPosition)
Method Detail

prepare

public int prepare(PreparedStatement statement)
            throws SQLException,
                   HibernateException
Specified by:
prepare in interface Expectation
Overrides:
prepare in class Expectations.BasicExpectation
Throws:
SQLException
HibernateException

canBeBatched

public boolean canBeBatched()
Specified by:
canBeBatched in interface Expectation
Overrides:
canBeBatched in class Expectations.BasicExpectation

determineRowCount

protected int determineRowCount(int reportedRowCount,
                                PreparedStatement statement)
Overrides:
determineRowCount in class Expectations.BasicExpectation
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JDBCContext (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class JDBCContext

java.lang.Object
    extended by org.hibernate.jdbc.JDBCContext
All Implemented Interfaces:
ConnectionManager.Callback, Serializable
public class JDBCContext
extends Object
implements Serializable, ConnectionManager.Callback

Acts as the mediary between "entity-mode related" sessions in terms of their interaction with the JDBC data store.

Author:
Steve Ebersole
See Also:
Serialized Form

Nested Class Summary
static interface JDBCContext.Context
Constructor Summary
JDBCContext(JDBCContext.Context owner, Connection connection, Interceptor interceptor)
Method Summary
void | afterNontransactionalQuery(boolean success) Called after executing a query outside the scope of a Hibernate or JTA transaction
void | afterTransactionBegin(Transaction tx) We cannot rely upon this method being called! It is only called if we are using Hibernate Transaction API.
void | afterTransactionCompletion(boolean success, Transaction tx)
void | beforeTransactionCompletion(Transaction tx)
Connection | borrowConnection()
Connection | connection()
void | connectionCleanedUp()
void | connectionOpened()
static JDBCContext | deserialize(ObjectInputStream ois, JDBCContext.Context context, Interceptor interceptor) Custom deserialization routine used during deserialization of a Session/PersistenceContext for increased performance.
ConnectionManager | getConnectionManager()
SessionFactoryImplementor | getFactory()
Transaction | getTransaction()
boolean | isTransactionInProgress()
boolean | registerCallbackIfNecessary()
boolean | registerSynchronizationIfPossible()
void | serialize(ObjectOutputStream oos) Custom serialization routine used during serialization of a Session/PersistenceContext for increased performance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JDBCContext

public JDBCContext(JDBCContext.Context owner,
                   Connection connection,
                   Interceptor interceptor)
Method Detail

connectionOpened

public void connectionOpened()
Specified by:
connectionOpened in interface ConnectionManager.Callback

connectionCleanedUp

public void connectionCleanedUp()
Specified by:
connectionCleanedUp in interface ConnectionManager.Callback

getFactory

public SessionFactoryImplementor getFactory()

getConnectionManager

public ConnectionManager getConnectionManager()

borrowConnection

public Connection borrowConnection()

connection

public Connection connection()
                      throws HibernateException
Throws:
HibernateException

registerCallbackIfNecessary

public boolean registerCallbackIfNecessary()

registerSynchronizationIfPossible

public boolean registerSynchronizationIfPossible()

isTransactionInProgress

public boolean isTransactionInProgress()
Specified by:
isTransactionInProgress in interface ConnectionManager.Callback

getTransaction

public Transaction getTransaction()
                           throws HibernateException
Throws:
HibernateException

beforeTransactionCompletion

public void beforeTransactionCompletion(Transaction tx)

afterTransactionBegin

public void afterTransactionBegin(Transaction tx)
We cannot rely upon this method being called! It is only called if we are using Hibernate Transaction API.

afterTransactionCompletion

public void afterTransactionCompletion(boolean success,
                                       Transaction tx)

afterNontransactionalQuery

public void afterNontransactionalQuery(boolean success)
Called after executing a query outside the scope of a Hibernate or JTA transaction

serialize

public void serialize(ObjectOutputStream oos)
               throws IOException
Custom serialization routine used during serialization of a Session/PersistenceContext for increased performance.

Parameters:
oos - The stream to which we should write the serial data.
Throws:
IOException

deserialize

public static JDBCContext deserialize(ObjectInputStream ois,
                                      JDBCContext.Context context,
                                      Interceptor interceptor)
                               throws IOException
Custom deserialization routine used during deserialization of a Session/PersistenceContext for increased performance.

Parameters:
ois - The stream from which to read the entry.
Throws:
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JDBCContext.Context (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Interface JDBCContext.Context

All Superinterfaces:
TransactionFactory.Context
All Known Implementing Classes:
SessionImpl, StatelessSessionImpl
Enclosing interface:
JDBCContext
public static interface JDBCContext.Context
extends TransactionFactory.Context

Method Summary
void | afterTransactionBegin(Transaction tx) We cannot rely upon this method being called! It is only called if we are using Hibernate Transaction API.
void | afterTransactionCompletion(boolean success, Transaction tx)
void | beforeTransactionCompletion(Transaction tx)
ConnectionReleaseMode | getConnectionReleaseMode()
boolean | isAutoCloseSessionEnabled()
Methods inherited from interface org.hibernate.transaction.TransactionFactory.Context
getFactory, isClosed, isFlushBeforeCompletionEnabled, isFlushModeNever, managedClose, managedFlush, shouldAutoClose

Method Detail

afterTransactionBegin

public void afterTransactionBegin(Transaction tx)
We cannot rely upon this method being called! It is only called if we are using Hibernate Transaction API.

beforeTransactionCompletion

public void beforeTransactionCompletion(Transaction tx)

afterTransactionCompletion

public void afterTransactionCompletion(boolean success,
                                       Transaction tx)

getConnectionReleaseMode

public ConnectionReleaseMode getConnectionReleaseMode()

isAutoCloseSessionEnabled

public boolean isAutoCloseSessionEnabled()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


NonBatchingBatcher (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class NonBatchingBatcher

java.lang.Object
    extended by org.hibernate.jdbc.AbstractBatcher
        extended by org.hibernate.jdbc.NonBatchingBatcher
All Implemented Interfaces:
Batcher
public class NonBatchingBatcher
extends AbstractBatcher

An implementation of the Batcher interface that does no batching

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.jdbc.AbstractBatcher
log, SQL_LOG
Constructor Summary
NonBatchingBatcher(ConnectionManager connectionManager, Interceptor interceptor)
Method Summary
void | addToBatch(Expectation expectation) Add an insert / delete / update to the current batch (might be called multiple times for single prepareBatchStatement())
protected void | doExecuteBatch(PreparedStatement ps)
Methods inherited from class org.hibernate.jdbc.AbstractBatcher
abortBatch, cancelLastQuery, closeConnection, closeQueryStatement, closeStatement, closeStatements, executeBatch, getFactory, getResultSet, getResultSet, getStatement, hasOpenResources, openConnection, openResourceStatsAsString, prepareBatchCallableStatement, prepareBatchStatement, prepareCallableQueryStatement, prepareCallableStatement, prepareQueryStatement, prepareSelectStatement, prepareStatement, prepareStatement, prepareStatement, setTransactionTimeout, unsetTransactionTimeout
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NonBatchingBatcher

public NonBatchingBatcher(ConnectionManager connectionManager,
                          Interceptor interceptor)
Method Detail

addToBatch

public void addToBatch(Expectation expectation)
                throws SQLException,
                       HibernateException
Description copied from interface: Batcher
Add an insert / delete / update to the current batch (might be called multiple times for single prepareBatchStatement())

Throws:
SQLException
HibernateException

doExecuteBatch

protected void doExecuteBatch(PreparedStatement ps)
                       throws SQLException,
                              HibernateException
Specified by:
doExecuteBatch in class AbstractBatcher
Throws:
SQLException
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonBatchingBatcherFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class NonBatchingBatcherFactory

java.lang.Object
    extended by org.hibernate.jdbc.NonBatchingBatcherFactory
All Implemented Interfaces:
BatcherFactory
public class NonBatchingBatcherFactory
extends Object
implements BatcherFactory

A BatcherFactory implementation which constructs Batcher instances that do not perform batch operations.

Author:
Gavin King

Constructor Summary
NonBatchingBatcherFactory()
Method Summary
 Batcher createBatcher(ConnectionManager connectionManager, Interceptor interceptor)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NonBatchingBatcherFactory

public NonBatchingBatcherFactory()
Method Detail

createBatcher

public Batcher createBatcher(ConnectionManager connectionManager,
                             Interceptor interceptor)
Specified by:
createBatcher in interface BatcherFactory
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResultSetWrapper (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class ResultSetWrapper

java.lang.Object
    extended by org.hibernate.jdbc.ResultSetWrapper
All Implemented Interfaces:
ResultSet
public class ResultSetWrapper
extends Object
implements ResultSet

A ResultSet delegate, responsible for locally caching the columnName-to-columnIndex resolution that has been found to be inefficient in a few vendor's drivers (i.e., Oracle and Postgres).

Author:
Steve Ebersole

Field Summary
Fields inherited from interface java.sql.ResultSet
CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE
Constructor Summary
ResultSetWrapper(ResultSet resultSet, ColumnNameCache columnNameCache)
Method Summary
boolean | absolute(int row)
void | afterLast()
void | beforeFirst()
void | cancelRowUpdates()
void | clearWarnings()
void | close()
void | deleteRow()
int | findColumn(String columnName) Overridden version to utilize local caching of the column indexes by name to improve performance for those drivers which are known to not support such caching by themselves.
boolean | first()
Array | getArray(int columnIndex)
Array | getArray(String colName)
InputStream | getAsciiStream(int columnIndex)
InputStream | getAsciiStream(String columnName)
BigDecimal | getBigDecimal(int columnIndex)
BigDecimal | getBigDecimal(int columnIndex, int scale)
BigDecimal | getBigDecimal(String columnName)
BigDecimal | getBigDecimal(String columnName, int scale)
InputStream | getBinaryStream(int columnIndex)
InputStream | getBinaryStream(String columnName)
Blob | getBlob(int columnIndex)
Blob | getBlob(String columnName)
boolean | getBoolean(int columnIndex)
boolean | getBoolean(String columnName)
byte | getByte(int columnIndex)
byte | getByte(String columnName)
byte[] | getBytes(int columnIndex)
byte[] | getBytes(String columnName)
Reader | getCharacterStream(int columnIndex)
Reader | getCharacterStream(String columnName)
Clob | getClob(int columnIndex)
Clob | getClob(String columnName)
int | getConcurrency()
String | getCursorName()
Date | getDate(int columnIndex)
Date | getDate(int columnIndex, Calendar cal)
Date | getDate(String columnName)
Date | getDate(String columnName, Calendar cal)
double | getDouble(int columnIndex)
double | getDouble(String columnName)
int | getFetchDirection()
int | getFetchSize()
float | getFloat(int columnIndex)
float | getFloat(String columnName)
int | getInt(int columnIndex)
int | getInt(String columnName)
long | getLong(int columnIndex)
long | getLong(String columnName)
ResultSetMetaData | getMetaData()
Object | getObject(int columnIndex)
Object | getObject(int columnIndex, Map map)
Object | getObject(String columnName)
Object | getObject(String columnName, Map map)
Ref | getRef(int columnIndex)
Ref | getRef(String columnName)
int | getRow()
short | getShort(int columnIndex)
short | getShort(String columnName)
Statement | getStatement()
String | getString(int columnIndex)
String | getString(String columnName)
Time | getTime(int columnIndex)
Time | getTime(int columnIndex, Calendar cal)
Time | getTime(String columnName)
Time | getTime(String columnName, Calendar cal)
Timestamp | getTimestamp(int columnIndex)
Timestamp | getTimestamp(int columnIndex, Calendar cal)
Timestamp | getTimestamp(String columnName)
Timestamp | getTimestamp(String columnName, Calendar cal)
int | getType()
InputStream | getUnicodeStream(int columnIndex)
InputStream | getUnicodeStream(String columnName)
URL | getURL(int columnIndex)
URL | getURL(String columnName)
SQLWarning | getWarnings()
void | insertRow()
boolean | isAfterLast()
boolean | isBeforeFirst()
boolean | isFirst()
boolean | isLast()
boolean | last()
void | moveToCurrentRow()
void | moveToInsertRow()
boolean | next()
boolean | previous()
void | refreshRow()
boolean | relative(int rows)
boolean | rowDeleted()
boolean | rowInserted()
boolean | rowUpdated()
void | setFetchDirection(int direction)
void | setFetchSize(int rows)
void | updateArray(int columnIndex, Array x)
void | updateArray(String columnName, Array x)
void | updateAsciiStream(int columnIndex, InputStream x, int length)
void | updateAsciiStream(String columnName, InputStream x, int length)
void | updateBigDecimal(int columnIndex, BigDecimal x)
void | updateBigDecimal(String columnName, BigDecimal x)
void | updateBinaryStream(int columnIndex, InputStream x, int length)
void | updateBinaryStream(String columnName, InputStream x, int length)
void | updateBlob(int columnIndex, Blob x)
void | updateBlob(String columnName, Blob x)
void | updateBoolean(int columnIndex, boolean x)
void | updateBoolean(String columnName, boolean x)
void | updateByte(int columnIndex, byte x)
void | updateByte(String columnName, byte x)
void | updateBytes(int columnIndex, byte[] x)
void | updateBytes(String columnName, byte[] x)
void | updateCharacterStream(int columnIndex, Reader x, int length)
void | updateCharacterStream(String columnName, Reader x, int length)
void | updateClob(int columnIndex, Clob x)
void | updateClob(String columnName, Clob x)
void | updateDate(int columnIndex, Date x)
void | updateDate(String columnName, Date x)
void | updateDouble(int columnIndex, double x)
void | updateDouble(String columnName, double x)
void | updateFloat(int columnIndex, float x)
void | updateFloat(String columnName, float x)
void | updateInt(int columnIndex, int x)
void | updateInt(String columnName, int x)
void | updateLong(int columnIndex, long x)
void | updateLong(String columnName, long x)
void | updateNull(int columnIndex)
void | updateNull(String columnName)
void | updateObject(int columnIndex, Object x)
void | updateObject(int columnIndex, Object x, int scale)
void | updateObject(String columnName, Object x)
void | updateObject(String columnName, Object x, int scale)
void | updateRef(int columnIndex, Ref x)
void | updateRef(String columnName, Ref x)
void | updateRow()
void | updateShort(int columnIndex, short x)
void | updateShort(String columnName, short x)
void | updateString(int columnIndex, String x)
void | updateString(String columnName, String x)
void | updateTime(int columnIndex, Time x)
void | updateTime(String columnName, Time x)
void | updateTimestamp(int columnIndex, Timestamp x)
void | updateTimestamp(String columnName, Timestamp x)
boolean | wasNull()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResultSetWrapper

public ResultSetWrapper(ResultSet resultSet,
                        ColumnNameCache columnNameCache)
Method Detail

findColumn

public int findColumn(String columnName)
               throws SQLException
Overridden version to utilize local caching of the column indexes by name to improve performance for those drivers which are known to not support such caching by themselves.

This implementation performs the caching based on the upper case version of the given column name.

Specified by:
findColumn in interface ResultSet
Parameters:
columnName - The column name to resolve into an index.
Returns:
The column index corresponding to the given column name.
Throws:
SQLException - - if the ResultSet object does not contain columnName or a database access error occurs

getArray

public Array getArray(String colName)
               throws SQLException
Specified by:
getArray in interface ResultSet
Throws:
SQLException

updateArray

public void updateArray(String columnName,
                        Array x)
                 throws SQLException
Specified by:
updateArray in interface ResultSet
Throws:
SQLException

getAsciiStream

public InputStream getAsciiStream(String columnName)
                           throws SQLException
Specified by:
getAsciiStream in interface ResultSet
Throws:
SQLException

updateAsciiStream

public void updateAsciiStream(String columnName,
                              InputStream x,
                              int length)
                       throws SQLException
Specified by:
updateAsciiStream in interface ResultSet
Throws:
SQLException

getBigDecimal

public BigDecimal getBigDecimal(String columnName)
                         throws SQLException
Specified by:
getBigDecimal in interface ResultSet
Throws:
SQLException

getBigDecimal

public BigDecimal getBigDecimal(String columnName,
                                int scale)
                         throws SQLException
Specified by:
getBigDecimal in interface ResultSet
Throws:
SQLException

updateBigDecimal

public void updateBigDecimal(String columnName,
                             BigDecimal x)
                      throws SQLException
Specified by:
updateBigDecimal in interface ResultSet
Throws:
SQLException

getBinaryStream

public InputStream getBinaryStream(String columnName)
                            throws SQLException
Specified by:
getBinaryStream in interface ResultSet
Throws:
SQLException

updateBinaryStream

public void updateBinaryStream(String columnName,
                               InputStream x,
                               int length)
                        throws SQLException
Specified by:
updateBinaryStream in interface ResultSet
Throws:
SQLException

getBlob

public Blob getBlob(String columnName)
             throws SQLException
Specified by:
getBlob in interface ResultSet
Throws:
SQLException

updateBlob

public void updateBlob(String columnName,
                       Blob x)
                throws SQLException
Specified by:
updateBlob in interface ResultSet
Throws:
SQLException

getBoolean

public boolean getBoolean(String columnName)
                   throws SQLException
Specified by:
getBoolean in interface ResultSet
Throws:
SQLException

updateBoolean

public void updateBoolean(String columnName,
                          boolean x)
                   throws SQLException
Specified by:
updateBoolean in interface ResultSet
Throws:
SQLException

getByte

public byte getByte(String columnName)
             throws SQLException
Specified by:
getByte in interface ResultSet
Throws:
SQLException

updateByte

public void updateByte(String columnName,
                       byte x)
                throws SQLException
Specified by:
updateByte in interface ResultSet
Throws:
SQLException

getBytes

public byte[] getBytes(String columnName)
                throws SQLException
Specified by:
getBytes in interface ResultSet
Throws:
SQLException

updateBytes

public void updateBytes(String columnName,
                        byte[] x)
                 throws SQLException
Specified by:
updateBytes in interface ResultSet
Throws:
SQLException

getCharacterStream

public Reader getCharacterStream(String columnName)
                          throws SQLException
Specified by:
getCharacterStream in interface ResultSet
Throws:
SQLException

updateCharacterStream

public void updateCharacterStream(String columnName,
                                  Reader x,
                                  int length)
                           throws SQLException
Specified by:
updateCharacterStream in interface ResultSet
Throws:
SQLException

getClob

public Clob getClob(String columnName)
             throws SQLException
Specified by:
getClob in interface ResultSet
Throws:
SQLException

updateClob

public void updateClob(String columnName,
                       Clob x)
                throws SQLException
Specified by:
updateClob in interface ResultSet
Throws:
SQLException

getDate

public Date getDate(String columnName)
             throws SQLException
Specified by:
getDate in interface ResultSet
Throws:
SQLException

getDate

public Date getDate(String columnName,
                    Calendar cal)
             throws SQLException
Specified by:
getDate in interface ResultSet
Throws:
SQLException

updateDate

public void updateDate(String columnName,
                       Date x)
                throws SQLException
Specified by:
updateDate in interface ResultSet
Throws:
SQLException

getDouble

public double getDouble(String columnName)
                 throws SQLException
Specified by:
getDouble in interface ResultSet
Throws:
SQLException

updateDouble

public void updateDouble(String columnName,
                         double x)
                  throws SQLException
Specified by:
updateDouble in interface ResultSet
Throws:
SQLException

getFloat

public float getFloat(String columnName)
               throws SQLException
Specified by:
getFloat in interface ResultSet
Throws:
SQLException

updateFloat

public void updateFloat(String columnName,
                        float x)
                 throws SQLException
Specified by:
updateFloat in interface ResultSet
Throws:
SQLException

getInt

public int getInt(String columnName)
           throws SQLException
Specified by:
getInt in interface ResultSet
Throws:
SQLException

updateInt

public void updateInt(String columnName,
                      int x)
               throws SQLException
Specified by:
updateInt in interface ResultSet
Throws:
SQLException

getLong

public long getLong(String columnName)
             throws SQLException
Specified by:
getLong in interface ResultSet
Throws:
SQLException

updateLong

public void updateLong(String columnName,
                       long x)
                throws SQLException
Specified by:
updateLong in interface ResultSet
Throws:
SQLException

getObject

public Object getObject(String columnName)
                 throws SQLException
Specified by:
getObject in interface ResultSet
Throws:
SQLException

getObject

public Object getObject(String columnName,
                        Map map)
                 throws SQLException
Specified by:
getObject in interface ResultSet
Throws:
SQLException

updateObject

public void updateObject(String columnName,
                         Object x)
                  throws SQLException
Specified by:
updateObject in interface ResultSet
Throws:
SQLException

updateObject

public void updateObject(String columnName,
                         Object x,
                         int scale)
                  throws SQLException
Specified by:
updateObject in interface ResultSet
Throws:
SQLException

getRef

public Ref getRef(String columnName)
           throws SQLException
Specified by:
getRef in interface ResultSet
Throws:
SQLException

updateRef

public void updateRef(String columnName,
                      Ref x)
               throws SQLException
Specified by:
updateRef in interface ResultSet
Throws:
SQLException

getShort

public short getShort(String columnName)
               throws SQLException
Specified by:
getShort in interface ResultSet
Throws:
SQLException

updateShort

public void updateShort(String columnName,
                        short x)
                 throws SQLException
Specified by:
updateShort in interface ResultSet
Throws:
SQLException

getString

public String getString(String columnName)
                 throws SQLException
Specified by:
getString in interface ResultSet
Throws:
SQLException

updateString

public void updateString(String columnName,
                         String x)
                  throws SQLException
Specified by:
updateString in interface ResultSet
Throws:
SQLException

getTime

public Time getTime(String columnName)
             throws SQLException
Specified by:
getTime in interface ResultSet
Throws:
SQLException

getTime

public Time getTime(String columnName,
                    Calendar cal)
             throws SQLException
Specified by:
getTime in interface ResultSet
Throws:
SQLException

updateTime

public void updateTime(String columnName,
                       Time x)
                throws SQLException
Specified by:
updateTime in interface ResultSet
Throws:
SQLException

getTimestamp

public Timestamp getTimestamp(String columnName)
                       throws SQLException
Specified by:
getTimestamp in interface ResultSet
Throws:
SQLException

updateTimestamp

public void updateTimestamp(String columnName,
                            Timestamp x)
                     throws SQLException
Specified by:
updateTimestamp in interface ResultSet
Throws:
SQLException

getTimestamp

public Timestamp getTimestamp(String columnName,
                              Calendar cal)
                       throws SQLException
Specified by:
getTimestamp in interface ResultSet
Throws:
SQLException

getUnicodeStream

public InputStream getUnicodeStream(String columnName)
                             throws SQLException
Specified by:
getUnicodeStream in interface ResultSet
Throws:
SQLException

getURL

public URL getURL(String columnName)
           throws SQLException
Specified by:
getURL in interface ResultSet
Throws:
SQLException

updateNull

public void updateNull(String columnName)
                throws SQLException
Specified by:
updateNull in interface ResultSet
Throws:
SQLException

getConcurrency

public int getConcurrency()
                   throws SQLException
Specified by:
getConcurrency in interface ResultSet
Throws:
SQLException

getFetchDirection

public int getFetchDirection()
                      throws SQLException
Specified by:
getFetchDirection in interface ResultSet
Throws:
SQLException

getFetchSize

public int getFetchSize()
                 throws SQLException
Specified by:
getFetchSize in interface ResultSet
Throws:
SQLException

getRow

public int getRow()
           throws SQLException
Specified by:
getRow in interface ResultSet
Throws:
SQLException

getType

public int getType()
            throws SQLException
Specified by:
getType in interface ResultSet
Throws:
SQLException

afterLast

public void afterLast()
               throws SQLException
Specified by:
afterLast in interface ResultSet
Throws:
SQLException

beforeFirst

public void beforeFirst()
                 throws SQLException
Specified by:
beforeFirst in interface ResultSet
Throws:
SQLException

cancelRowUpdates

public void cancelRowUpdates()
                      throws SQLException
Specified by:
cancelRowUpdates in interface ResultSet
Throws:
SQLException

clearWarnings

public void clearWarnings()
                   throws SQLException
Specified by:
clearWarnings in interface ResultSet
Throws:
SQLException

close

public void close()
           throws SQLException
Specified by:
close in interface ResultSet
Throws:
SQLException

deleteRow

public void deleteRow()
               throws SQLException
Specified by:
deleteRow in interface ResultSet
Throws:
SQLException

insertRow

public void insertRow()
               throws SQLException
Specified by:
insertRow in interface ResultSet
Throws:
SQLException

moveToCurrentRow

public void moveToCurrentRow()
                      throws SQLException
Specified by:
moveToCurrentRow in interface ResultSet
Throws:
SQLException

moveToInsertRow

public void moveToInsertRow()
                     throws SQLException
Specified by:
moveToInsertRow in interface ResultSet
Throws:
SQLException

refreshRow

public void refreshRow()
                throws SQLException
Specified by:
refreshRow in interface ResultSet
Throws:
SQLException

updateRow

public void updateRow()
               throws SQLException
Specified by:
updateRow in interface ResultSet
Throws:
SQLException

first

public boolean first()
              throws SQLException
Specified by:
first in interface ResultSet
Throws:
SQLException

isAfterLast

public boolean isAfterLast()
                    throws SQLException
Specified by:
isAfterLast in interface ResultSet
Throws:
SQLException

isBeforeFirst

public boolean isBeforeFirst()
                      throws SQLException
Specified by:
isBeforeFirst in interface ResultSet
Throws:
SQLException

isFirst

public boolean isFirst()
                throws SQLException
Specified by:
isFirst in interface ResultSet
Throws:
SQLException

isLast

public boolean isLast()
               throws SQLException
Specified by:
isLast in interface ResultSet
Throws:
SQLException

last

public boolean last()
             throws SQLException
Specified by:
last in interface ResultSet
Throws:
SQLException

next

public boolean next()
             throws SQLException
Specified by:
next in interface ResultSet
Throws:
SQLException

previous

public boolean previous()
                 throws SQLException
Specified by:
previous in interface ResultSet
Throws:
SQLException

rowDeleted

public boolean rowDeleted()
                   throws SQLException
Specified by:
rowDeleted in interface ResultSet
Throws:
SQLException

rowInserted

public boolean rowInserted()
                    throws SQLException
Specified by:
rowInserted in interface ResultSet
Throws:
SQLException

rowUpdated

public boolean rowUpdated()
                   throws SQLException
Specified by:
rowUpdated in interface ResultSet
Throws:
SQLException

wasNull

public boolean wasNull()
                throws SQLException
Specified by:
wasNull in interface ResultSet
Throws:
SQLException

getByte

public byte getByte(int columnIndex)
             throws SQLException
Specified by:
getByte in interface ResultSet
Throws:
SQLException

getDouble

public double getDouble(int columnIndex)
                 throws SQLException
Specified by:
getDouble in interface ResultSet
Throws:
SQLException

getFloat

public float getFloat(int columnIndex)
               throws SQLException
Specified by:
getFloat in interface ResultSet
Throws:
SQLException

getInt

public int getInt(int columnIndex)
           throws SQLException
Specified by:
getInt in interface ResultSet
Throws:
SQLException

getLong

public long getLong(int columnIndex)
             throws SQLException
Specified by:
getLong in interface ResultSet
Throws:
SQLException

getShort

public short getShort(int columnIndex)
               throws SQLException
Specified by:
getShort in interface ResultSet
Throws:
SQLException

setFetchDirection

public void setFetchDirection(int direction)
                       throws SQLException
Specified by:
setFetchDirection in interface ResultSet
Throws:
SQLException

setFetchSize

public void setFetchSize(int rows)
                  throws SQLException
Specified by:
setFetchSize in interface ResultSet
Throws:
SQLException

updateNull

public void updateNull(int columnIndex)
                throws SQLException
Specified by:
updateNull in interface ResultSet
Throws:
SQLException

absolute

public boolean absolute(int row)
                 throws SQLException
Specified by:
absolute in interface ResultSet
Throws:
SQLException

getBoolean

public boolean getBoolean(int columnIndex)
                   throws SQLException
Specified by:
getBoolean in interface ResultSet
Throws:
SQLException

relative

public boolean relative(int rows)
                 throws SQLException
Specified by:
relative in interface ResultSet
Throws:
SQLException

getBytes

public byte[] getBytes(int columnIndex)
                throws SQLException
Specified by:
getBytes in interface ResultSet
Throws:
SQLException

updateByte

public void updateByte(int columnIndex,
                       byte x)
                throws SQLException
Specified by:
updateByte in interface ResultSet
Throws:
SQLException

updateDouble

public void updateDouble(int columnIndex,
                         double x)
                  throws SQLException
Specified by:
updateDouble in interface ResultSet
Throws:
SQLException

updateFloat

public void updateFloat(int columnIndex,
                        float x)
                 throws SQLException
Specified by:
updateFloat in interface ResultSet
Throws:
SQLException

updateInt

public void updateInt(int columnIndex,
                      int x)
               throws SQLException
Specified by:
updateInt in interface ResultSet
Throws:
SQLException

updateLong

public void updateLong(int columnIndex,
                       long x)
                throws SQLException
Specified by:
updateLong in interface ResultSet
Throws:
SQLException

updateShort

public void updateShort(int columnIndex,
                        short x)
                 throws SQLException
Specified by:
updateShort in interface ResultSet
Throws:
SQLException

updateBoolean

public void updateBoolean(int columnIndex,
                          boolean x)
                   throws SQLException
Specified by:
updateBoolean in interface ResultSet
Throws:
SQLException

updateBytes

public void updateBytes(int columnIndex,
                        byte[] x)
                 throws SQLException
Specified by:
updateBytes in interface ResultSet
Throws:
SQLException

getAsciiStream

public InputStream getAsciiStream(int columnIndex)
                           throws SQLException
Specified by:
getAsciiStream in interface ResultSet
Throws:
SQLException

getBinaryStream

public InputStream getBinaryStream(int columnIndex)
                            throws SQLException
Specified by:
getBinaryStream in interface ResultSet
Throws:
SQLException

getUnicodeStream

public InputStream getUnicodeStream(int columnIndex)
                             throws SQLException
Specified by:
getUnicodeStream in interface ResultSet
Throws:
SQLException

updateAsciiStream

public void updateAsciiStream(int columnIndex,
                              InputStream x,
                              int length)
                       throws SQLException
Specified by:
updateAsciiStream in interface ResultSet
Throws:
SQLException

updateBinaryStream

public void updateBinaryStream(int columnIndex,
                               InputStream x,
                               int length)
                        throws SQLException
Specified by:
updateBinaryStream in interface ResultSet
Throws:
SQLException

getCharacterStream

public Reader getCharacterStream(int columnIndex)
                          throws SQLException
Specified by:
getCharacterStream in interface ResultSet
Throws:
SQLException

updateCharacterStream

public void updateCharacterStream(int columnIndex,
                                  Reader x,
                                  int length)
                           throws SQLException
Specified by:
updateCharacterStream in interface ResultSet
Throws:
SQLException

getObject

public Object getObject(int columnIndex)
                 throws SQLException
Specified by:
getObject in interface ResultSet
Throws:
SQLException

updateObject

public void updateObject(int columnIndex,
                         Object x)
                  throws SQLException
Specified by:
updateObject in interface ResultSet
Throws:
SQLException

updateObject

public void updateObject(int columnIndex,
                         Object x,
                         int scale)
                  throws SQLException
Specified by:
updateObject in interface ResultSet
Throws:
SQLException

getCursorName

public String getCursorName()
                     throws SQLException
Specified by:
getCursorName in interface ResultSet
Throws:
SQLException

getString

public String getString(int columnIndex)
                 throws SQLException
Specified by:
getString in interface ResultSet
Throws:
SQLException

updateString

public void updateString(int columnIndex,
                         String x)
                  throws SQLException
Specified by:
updateString in interface ResultSet
Throws:
SQLException

getBigDecimal

public BigDecimal getBigDecimal(int columnIndex)
                         throws SQLException
Specified by:
getBigDecimal in interface ResultSet
Throws:
SQLException

getBigDecimal

public BigDecimal getBigDecimal(int columnIndex,
                                int scale)
                         throws SQLException
Specified by:
getBigDecimal in interface ResultSet
Throws:
SQLException

updateBigDecimal

public void updateBigDecimal(int columnIndex,
                             BigDecimal x)
                      throws SQLException
Specified by:
updateBigDecimal in interface ResultSet
Throws:
SQLException

getURL

public URL getURL(int columnIndex)
           throws SQLException
Specified by:
getURL in interface ResultSet
Throws:
SQLException

getArray

public Array getArray(int columnIndex)
               throws SQLException
Specified by:
getArray in interface ResultSet
Throws:
SQLException

updateArray

public void updateArray(int columnIndex,
                        Array x)
                 throws SQLException
Specified by:
updateArray in interface ResultSet
Throws:
SQLException

getBlob

public Blob getBlob(int columnIndex)
             throws SQLException
Specified by:
getBlob in interface ResultSet
Throws:
SQLException

updateBlob

public void updateBlob(int columnIndex,
                       Blob x)
                throws SQLException
Specified by:
updateBlob in interface ResultSet
Throws:
SQLException

getClob

public Clob getClob(int columnIndex)
             throws SQLException
Specified by:
getClob in interface ResultSet
Throws:
SQLException

updateClob

public void updateClob(int columnIndex,
                       Clob x)
                throws SQLException
Specified by:
updateClob in interface ResultSet
Throws:
SQLException

getDate

public Date getDate(int columnIndex)
             throws SQLException
Specified by:
getDate in interface ResultSet
Throws:
SQLException

updateDate

public void updateDate(int columnIndex,
                       Date x)
                throws SQLException
Specified by:
updateDate in interface ResultSet
Throws:
SQLException

getRef

public Ref getRef(int columnIndex)
           throws SQLException
Specified by:
getRef in interface ResultSet
Throws:
SQLException

updateRef

public void updateRef(int columnIndex,
                      Ref x)
               throws SQLException
Specified by:
updateRef in interface ResultSet
Throws:
SQLException

getMetaData

public ResultSetMetaData getMetaData()
                              throws SQLException
Specified by:
getMetaData in interface ResultSet
Throws:
SQLException

getWarnings

public SQLWarning getWarnings()
                       throws SQLException
Specified by:
getWarnings in interface ResultSet
Throws:
SQLException

getStatement

public Statement getStatement()
                       throws SQLException
Specified by:
getStatement in interface ResultSet
Throws:
SQLException

getTime

public Time getTime(int columnIndex)
             throws SQLException
Specified by:
getTime in interface ResultSet
Throws:
SQLException

updateTime

public void updateTime(int columnIndex,
                       Time x)
                throws SQLException
Specified by:
updateTime in interface ResultSet
Throws:
SQLException

getTimestamp

public Timestamp getTimestamp(int columnIndex)
                       throws SQLException
Specified by:
getTimestamp in interface ResultSet
Throws:
SQLException

updateTimestamp

public void updateTimestamp(int columnIndex,
                            Timestamp x)
                     throws SQLException
Specified by:
updateTimestamp in interface ResultSet
Throws:
SQLException

getObject

public Object getObject(int columnIndex,
                        Map map)
                 throws SQLException
Specified by:
getObject in interface ResultSet
Throws:
SQLException

getDate

public Date getDate(int columnIndex,
                    Calendar cal)
             throws SQLException
Specified by:
getDate in interface ResultSet
Throws:
SQLException

getTime

public Time getTime(int columnIndex,
                    Calendar cal)
             throws SQLException
Specified by:
getTime in interface ResultSet
Throws:
SQLException

getTimestamp

public Timestamp getTimestamp(int columnIndex,
                              Calendar cal)
                       throws SQLException
Specified by:
getTimestamp in interface ResultSet
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BatchedTooManyRowsAffectedException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class BatchedTooManyRowsAffectedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.jdbc.TooManyRowsAffectedException
                            extended by org.hibernate.jdbc.BatchedTooManyRowsAffectedException
All Implemented Interfaces:
Nestable, Serializable
public class BatchedTooManyRowsAffectedException
extends TooManyRowsAffectedException

Much like TooManyRowsAffectedException, indicates that more rows than what we were expcecting were affected. Additionally, this form occurs from a batch and carries along the batch positon that failed.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
BatchedTooManyRowsAffectedException(String message, int expectedRowCount, int actualRowCount, int batchPosition)
Method Summary
 int getBatchPosition()
Methods inherited from class org.hibernate.jdbc.TooManyRowsAffectedException
getActualRowCount, getExpectedRowCount
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BatchedTooManyRowsAffectedException

public BatchedTooManyRowsAffectedException(String message,
                                           int expectedRowCount,
                                           int actualRowCount,
                                           int batchPosition)
Method Detail

getBatchPosition

public int getBatchPosition()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BatchFailedException (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class BatchFailedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.jdbc.BatchFailedException
All Implemented Interfaces:
Nestable, Serializable
public class BatchFailedException
extends HibernateException

Indicates a failed batch entry (-3 return).

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
BatchFailedException(String s)
BatchFailedException(String string, Throwable root)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BatchFailedException

public BatchFailedException(String s)

BatchFailedException

public BatchFailedException(String string,
                            Throwable root)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TooManyRowsAffectedException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jdbc
Class TooManyRowsAffectedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.jdbc.TooManyRowsAffectedException
All Implemented Interfaces:
Nestable, Serializable
Direct Known Subclasses:
BatchedTooManyRowsAffectedException
public class TooManyRowsAffectedException
extends HibernateException

Indicates that more rows were affected then we were expecting to be. Typically indicates presence of duplicate "PK" values in the given table.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
TooManyRowsAffectedException(String message, int expectedRowCount, int actualRowCount)
Method Summary
int | getActualRowCount()
int | getExpectedRowCount()
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TooManyRowsAffectedException

public TooManyRowsAffectedException(String message,
                                    int expectedRowCount,
                                    int actualRowCount)
Method Detail

getExpectedRowCount

public int getExpectedRowCount()

getActualRowCount

public int getActualRowCount()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.jmx (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.jmx

This package exposes a Hibernate instance via JMX.

See:
Description

Interface Summary
HibernateServiceMBean | Hibernate JMX Management API
StatisticsServiceMBean | MBean exposing Session Factory statistics

Class Summary
HibernateService | Implementation of HibernateServiceMBean.
SessionFactoryStub | A flyweight for SessionFactory.
StatisticsService | JMX service for Hibernate statistics Register this MBean in your JMX server for a specific session factory

Package org.hibernate.jmx Description

This package exposes a Hibernate instance via JMX.

HibernateService allows configuration and management of the Hibernate runtime. StatisticsService reports information that might be useful for performance tuning.


org.hibernate.jmx Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.jmx

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.util.ExternalSessionFactoryConfig
      • class org.hibernate.jmx.HibernateService (implements org.hibernate.jmx.HibernateServiceMBean)
    • class org.hibernate.jmx.SessionFactoryStub (implements org.hibernate.SessionFactory)
    • class org.hibernate.jmx.StatisticsService (implements org.hibernate.jmx.StatisticsServiceMBean)

Interface Hierarchy

  • interface org.hibernate.jmx.HibernateServiceMBean
  • interface org.hibernate.stat.Statistics
    • interface org.hibernate.jmx.StatisticsServiceMBean


Uses of Package org.hibernate.jmx (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.jmx

Packages that use org.hibernate.jmx
org.hibernate.jmx This package exposes a Hibernate instance via JMX.

Classes in org.hibernate.jmx used by org.hibernate.jmx
HibernateServiceMBean
Hibernate JMX Management API
StatisticsServiceMBean
MBean exposing Session Factory statistics

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HibernateServiceMBean (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jmx
Interface HibernateServiceMBean

All Known Implementing Classes:
HibernateService
public interface HibernateServiceMBean

Hibernate JMX Management API

Author:
John Urberg, Gavin King
See Also:
HibernateService

Method Summary
 void addMapResource(String mapResource)
Add a mapping file
 void createSchema()
Export the CREATE DDL to the database
 void dropSchema()
Export the DROP DDL to the database
 String getAutoCloseSessionEnabled()
Is automatic Session closing enabled?
 String getBatchVersionedDataEnabled()
Is JDBC batch update for versioned entities enabled?
 String getCacheProviderClass()
Get the second-level cache provider class name
 String getCacheRegionPrefix()
Get the cache region prefix
 String getCommentsEnabled()
Are SQL comments enabled?
 String getDatasource()
The JNDI name of the datasource to use in this SessionFactory
 String getDefaultCatalog()
Get the default catalog
 String getDefaultSchema()
Get the default schema
 String getDialect()
The JNDI name of the dialect class to use in this SessionFactory
 String getFlushBeforeCompletionEnabled()
Is automatic Session flusing enabled?
 String getGetGeneratedKeysEnabled()
Is use of JDBC3 getGeneratedKeys() enabled?
 String getJdbcBatchSize()
Get the maximum JDBC batch size
 String getJdbcFetchSize()
Get the JDBC fetch size
 String getJdbcScrollableResultSetEnabled()
Is use of scrollable resultsets enabled?
 String getJndiName()
The JNDI name to bind to the SessionFactory
 String getMapResources()
The Hibernate mapping files (might be overridden by subclasses that want to specify the mapping files by some other mechanism)
 String getMaximumFetchDepth()
Get the maximum outer join fetch depth
 String getMinimalPutsEnabled()
Is the second-level cache optimized for miminal puts?
 String getPassword()
Log into the database with this password
 String getProperty(String property)
Get a property
 String getPropertyList()
Display the properties
 String getQueryCacheEnabled()
Is the query cache enabled?
 String getQuerySubstitutions()
Get the query language substitutions
 String getSecondLevelCacheEnabled()
Is the second-level cache enabled?
 String getShowSqlEnabled()
Is SQL logging enabled?
 String getTransactionManagerLookupStrategy()
Get the strategy for obtaining the JTA TransactionManager
 String getTransactionStrategy()
The fully qualified class name of the Hibernate TransactionFactory implementation
 String getUserName()
Log into the database with this name
 String getUserTransactionName()
The JNDI name of the JTA UserTransaction object (used only be JTATransaction).
 void setAutoCloseSessionEnabled(String enabled)
Enable automatic closing of Session when JTA transaction ends.
 void setBatchVersionedDataEnabled(String enabled)
Enable or disable the use of batch updates for versioned entities
 void setCacheProviderClass(String providerClassName)
Set the second-level cache provider class name
 void setCacheRegionPrefix(String prefix)
Set the cache region prefix
 void setCommentsEnabled(String enabled)
Enable or disable the inclusion of comments in generated SQL
 void setDatasource(String datasource)
Set the JNDI name of the datasource to use in this SessionFactory
 void setDefaultCatalog(String catalog)
Set the default catalog
 void setDefaultSchema(String schema)
Set the default schema
 void setDialect(String dialect)
The name of the dialect class to use in this SessionFactory
 void setFlushBeforeCompletionEnabled(String enabled)
Enable automatic flushing of the Session when JTA transaction ends.
 void setGetGeneratedKeysEnabled(String enabled)
Enable or disable the use getGeneratedKeys()
 void setJdbcBatchSize(String batchSize)
Set the maximum JDBC batch size
 void setJdbcFetchSize(String fetchSize)
Set the JDBC fetch size
 void setJdbcScrollableResultSetEnabled(String enabled)
Enable or disable the use of scrollable resultsets
 void setJndiName(String jndiName)
The JNDI name to bind to the SessionFactory
 void setMapResources(String mappingFiles)
Specify the Hibernate mapping files
 void setMaximumFetchDepth(String fetchDepth)
Set the maximum outer join fetch depth
 void setMinimalPutsEnabled(String enabled)
Enable or disable optimization of second-level cache for minimal puts
 void setPassword(String password)
Log into the database with this password
 void setProperty(String property, String value)
Set a property
 void setQueryCacheEnabled(String enabled)
Enable or disable the query cache
 void setQuerySubstitutions(String querySubstitutions)
Set the query language substitutions
 void setSecondLevelCacheEnabled(String enabled)
Enable or disable the second-level cache
 void setShowSqlEnabled(String showSql)
Enable logging of SQL to console
 void setTransactionManagerLookupStrategy(String lkpStrategy)
Set the strategy for obtaining the JTA TransactionManager
 void setTransactionStrategy(String txnStrategy)
Set the fully qualified class name of the Hibernate TransactionFactory implementation
 void setUserName(String userName)
Log into the database with this name
 void setUserTransactionName(String utName)
Set the JNDI name of the JTA UserTransaction object (used only by JTATransaction).
 void start()
Create the SessionFactory and bind to the jndi name on startup
 void stop()
Unbind the SessionFactory or stub from JNDI

Method Detail

getMapResources

public String getMapResources()
The Hibernate mapping files (might be overridden by subclasses that want to specify the mapping files by some other mechanism)

Returns:
String

setMapResources

public void setMapResources(String mappingFiles)
Specify the Hibernate mapping files

Parameters:
mappingFiles -

addMapResource

public void addMapResource(String mapResource)
Add a mapping file

Parameters:
mapResource -

setProperty

public void setProperty(String property,
                        String value)
Set a property

Parameters:
property - the property name
value - the property value

getProperty

public String getProperty(String property)
Get a property

Parameters:
property - the property name
Returns:
the property value

getPropertyList

public String getPropertyList()
Display the properties

Returns:
a list of property names and values

getDatasource

public String getDatasource()
The JNDI name of the datasource to use in this SessionFactory

Returns:
String

setDatasource

public void setDatasource(String datasource)
Set the JNDI name of the datasource to use in this SessionFactory

Parameters:
datasource -

getUserName

public String getUserName()
Log into the database with this name

Returns:
String

setUserName

public void setUserName(String userName)
Log into the database with this name

Parameters:
userName -

getPassword

public String getPassword()
Log into the database with this password

Returns:
String

setPassword

public void setPassword(String password)
Log into the database with this password

Parameters:
password -

getDialect

public String getDialect()
The JNDI name of the dialect class to use in this SessionFactory

Returns:
String

setDialect

public void setDialect(String dialect)
The name of the dialect class to use in this SessionFactory

Parameters:
dialect - fully qualified class name of Dialect subclass
See Also:
Dialect

getJndiName

public String getJndiName()
The JNDI name to bind to the SessionFactory

Returns:
String

setJndiName

public void setJndiName(String jndiName)
The JNDI name to bind to the SessionFactory

Parameters:
jndiName -

getTransactionStrategy

public String getTransactionStrategy()
The fully qualified class name of the Hibernate TransactionFactory implementation

Returns:
the class name
See Also:
TransactionFactory

setTransactionStrategy

public void setTransactionStrategy(String txnStrategy)
Set the fully qualified class name of the Hibernate TransactionFactory implementation

Parameters:
txnStrategy - the class name
See Also:
TransactionFactory

getUserTransactionName

public String getUserTransactionName()
The JNDI name of the JTA UserTransaction object (used only be JTATransaction).

Returns:
the JNDI name
See Also:
JTATransaction

setUserTransactionName

public void setUserTransactionName(String utName)
Set the JNDI name of the JTA UserTransaction object (used only by JTATransaction).

Parameters:
utName - the JNDI name
See Also:
JTATransaction

getTransactionManagerLookupStrategy

public String getTransactionManagerLookupStrategy()
Get the strategy for obtaining the JTA TransactionManager

Returns:
the class name
See Also:
TransactionManagerLookup

setTransactionManagerLookupStrategy

public void setTransactionManagerLookupStrategy(String lkpStrategy)
Set the strategy for obtaining the JTA TransactionManager

Parameters:
lkpStrategy - the class name
See Also:
TransactionManagerLookup

getShowSqlEnabled

public String getShowSqlEnabled()
Is SQL logging enabled?

setShowSqlEnabled

public void setShowSqlEnabled(String showSql)
Enable logging of SQL to console

getMaximumFetchDepth

public String getMaximumFetchDepth()
Get the maximum outer join fetch depth

setMaximumFetchDepth

public void setMaximumFetchDepth(String fetchDepth)
Set the maximum outer join fetch depth

getJdbcBatchSize

public String getJdbcBatchSize()
Get the maximum JDBC batch size

setJdbcBatchSize

public void setJdbcBatchSize(String batchSize)
Set the maximum JDBC batch size

getJdbcFetchSize

public String getJdbcFetchSize()
Get the JDBC fetch size

setJdbcFetchSize

public void setJdbcFetchSize(String fetchSize)
Set the JDBC fetch size

getQuerySubstitutions

public String getQuerySubstitutions()
Get the query language substitutions

setQuerySubstitutions

public void setQuerySubstitutions(String querySubstitutions)
Set the query language substitutions

getDefaultSchema

public String getDefaultSchema()
Get the default schema

setDefaultSchema

public void setDefaultSchema(String schema)
Set the default schema

getDefaultCatalog

public String getDefaultCatalog()
Get the default catalog

setDefaultCatalog

public void setDefaultCatalog(String catalog)
Set the default catalog

getJdbcScrollableResultSetEnabled

public String getJdbcScrollableResultSetEnabled()
Is use of scrollable resultsets enabled?

setJdbcScrollableResultSetEnabled

public void setJdbcScrollableResultSetEnabled(String enabled)
Enable or disable the use of scrollable resultsets

getGetGeneratedKeysEnabled

public String getGetGeneratedKeysEnabled()
Is use of JDBC3 getGeneratedKeys() enabled?

setGetGeneratedKeysEnabled

public void setGetGeneratedKeysEnabled(String enabled)
Enable or disable the use getGeneratedKeys()

getCacheProviderClass

public String getCacheProviderClass()
Get the second-level cache provider class name

setCacheProviderClass

public void setCacheProviderClass(String providerClassName)
Set the second-level cache provider class name

getQueryCacheEnabled

public String getQueryCacheEnabled()
Is the query cache enabled?

setQueryCacheEnabled

public void setQueryCacheEnabled(String enabled)
Enable or disable the query cache

getSecondLevelCacheEnabled

public String getSecondLevelCacheEnabled()
Is the second-level cache enabled?

setSecondLevelCacheEnabled

public void setSecondLevelCacheEnabled(String enabled)
Enable or disable the second-level cache

getCacheRegionPrefix

public String getCacheRegionPrefix()
Get the cache region prefix

setCacheRegionPrefix

public void setCacheRegionPrefix(String prefix)
Set the cache region prefix

getMinimalPutsEnabled

public String getMinimalPutsEnabled()
Is the second-level cache optimized for miminal puts?

setMinimalPutsEnabled

public void setMinimalPutsEnabled(String enabled)
Enable or disable optimization of second-level cache for minimal puts

getCommentsEnabled

public String getCommentsEnabled()
Are SQL comments enabled?

setCommentsEnabled

public void setCommentsEnabled(String enabled)
Enable or disable the inclusion of comments in generated SQL

getBatchVersionedDataEnabled

public String getBatchVersionedDataEnabled()
Is JDBC batch update for versioned entities enabled?

setBatchVersionedDataEnabled

public void setBatchVersionedDataEnabled(String enabled)
Enable or disable the use of batch updates for versioned entities

setFlushBeforeCompletionEnabled

public void setFlushBeforeCompletionEnabled(String enabled)
Enable automatic flushing of the Session when JTA transaction ends.

getFlushBeforeCompletionEnabled

public String getFlushBeforeCompletionEnabled()
Is automatic Session flusing enabled?

setAutoCloseSessionEnabled

public void setAutoCloseSessionEnabled(String enabled)
Enable automatic closing of Session when JTA transaction ends.

getAutoCloseSessionEnabled

public String getAutoCloseSessionEnabled()
Is automatic Session closing enabled?

createSchema

public void createSchema()
                  throws HibernateException
Export the CREATE DDL to the database

Throws:
HibernateException

dropSchema

public void dropSchema()
                throws HibernateException
Export the DROP DDL to the database

Throws:
HibernateException

start

public void start()
           throws HibernateException
Create the SessionFactory and bind to the jndi name on startup

Throws:
HibernateException

stop

public void stop()
Unbind the SessionFactory or stub from JNDI

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


StatisticsServiceMBean (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jmx
Interface StatisticsServiceMBean

All Superinterfaces:
Statistics
All Known Implementing Classes:
StatisticsService
public interface StatisticsServiceMBean
extends Statistics

MBean exposing Session Factory statistics

Author:
Emmanuel Bernard
See Also:
Statistics

Method Summary
 void setSessionFactoryJNDIName(String sfJNDIName)
Publish the statistics of a session factory bound to the default JNDI context
Methods inherited from interface org.hibernate.stat.Statistics
clear, getCloseStatementCount, getCollectionFetchCount, getCollectionLoadCount, getCollectionRecreateCount, getCollectionRemoveCount, getCollectionRoleNames, getCollectionStatistics, getCollectionUpdateCount, getConnectCount, getEntityDeleteCount, getEntityFetchCount, getEntityInsertCount, getEntityLoadCount, getEntityNames, getEntityStatistics, getEntityUpdateCount, getFlushCount, getOptimisticFailureCount, getPrepareStatementCount, getQueries, getQueryCacheHitCount, getQueryCacheMissCount, getQueryCachePutCount, getQueryExecutionCount, getQueryExecutionMaxTime, getQueryExecutionMaxTimeQueryString, getQueryStatistics, getSecondLevelCacheHitCount, getSecondLevelCacheMissCount, getSecondLevelCachePutCount, getSecondLevelCacheRegionNames, getSecondLevelCacheStatistics, getSessionCloseCount, getSessionOpenCount, getStartTime, getSuccessfulTransactionCount, getTransactionCount, isStatisticsEnabled, logSummary, setStatisticsEnabled

Method Detail

setSessionFactoryJNDIName

public void setSessionFactoryJNDIName(String sfJNDIName)
Publish the statistics of a session factory bound to the default JNDI context

Parameters:
sfJNDIName - session factory jndi name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HibernateService (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jmx
Class HibernateService

java.lang.Object
    extended by org.hibernate.util.ExternalSessionFactoryConfig
        extended by org.hibernate.jmx.HibernateService
All Implemented Interfaces:
HibernateServiceMBean
public class HibernateService
extends ExternalSessionFactoryConfig
implements HibernateServiceMBean

Implementation of HibernateServiceMBean. Creates a SessionFactory and binds it to the specified JNDI name.

All mapping documents are loaded as resources by the MBean.

Author:
John Urberg, Gavin King
See Also:
HibernateServiceMBean, SessionFactory

Constructor Summary
HibernateService()
Method Summary
void | createSchema() Export the CREATE DDL to the database
void | dropSchema() Export the DROP DDL to the database
String | getAutoCloseSessionEnabled() Is automatic Session closing enabled?
String | getDatasource() The JNDI name of the datasource to use in this SessionFactory
protected Map | getExtraProperties()
String | getFlushBeforeCompletionEnabled() Is automatic Session flusing enabled?
String | getJndiName() The JNDI name to bind to the SessionFactory
String | getName()
String | getPassword() Log into the database with this password
Properties | getProperties()
String | getProperty(String property) Get a property
String | getPropertyList() Display the properties
String | getTransactionManagerLookupStrategy() Get the strategy for obtaining the JTA TransactionManager
String | getTransactionStrategy() The fully qualified class name of the Hibernate TransactionFactory implementation
String | getUserName() Log into the database with this name
String | getUserTransactionName() The JNDI name of the JTA UserTransaction object (used only be JTATransaction).
void | setAutoCloseSessionEnabled(String enabled) Enable automatic closing of Session when JTA transaction ends.
void | setDatasource(String datasource) Set the JNDI name of the datasource to use in this SessionFactory
void | setFlushBeforeCompletionEnabled(String enabled) Enable automatic flushing of the Session when JTA transaction ends.
void | setJndiName(String jndiName) The JNDI name to bind to the SessionFactory
void | setPassword(String password) Log into the database with this password
void | setProperty(String property, String value) Set a property
void | setTransactionManagerLookupStrategy(String lkpStrategy) Set the strategy for obtaining the JTA TransactionManager
void | setTransactionStrategy(String txnStrategy) Set the fully qualified class name of the Hibernate TransactionFactory implementation
void | setUserName(String userName) Log into the database with this name
void | setUserTransactionName(String utName) Set the JNDI name of the JTA UserTransaction object (used only by JTATransaction).
void | start() Create the SessionFactory and bind to the jndi name on startup
void | stop() Unbind the SessionFactory or stub from JNDI
Methods inherited from class org.hibernate.util.ExternalSessionFactoryConfig
addAdditionalProperty, addAll, addMapResource, buildConfiguration, buildProperties, getBatchVersionedDataEnabled, getCacheProviderClass, getCacheRegionPrefix, getCommentsEnabled, getCustomListeners, getDefaultCatalog, getDefaultSchema, getDialect, getExcludedPropertyNames, getGetGeneratedKeysEnabled, getJdbcBatchSize, getJdbcFetchSize, getJdbcScrollableResultSetEnabled, getMapResources, getMaximumFetchDepth, getMinimalPutsEnabled, getQueryCacheEnabled, getQuerySubstitutions, getReflectionOptimizationEnabled, getSecondLevelCacheEnabled, getShowSqlEnabled, getStreamsForBinaryEnabled, setBatchVersionedDataEnabled, setCacheProviderClass, setCacheRegionPrefix, setCommentsEnabled, setCustomListener, setCustomListeners, setCustomListenersAsString, setDefaultCatalog, setDefaultSchema, setDialect, setGetGeneratedKeysEnabled, setJdbcBatchSize, setJdbcFetchSize, setJdbcScrollableResultSetEnabled, setMapResources, setMaximumFetchDepth, setMinimalPutsEnabled, setQueryCacheEnabled, setQuerySubstitutions, setReflectionOptimizationEnabled, setSecondLevelCacheEnabled, setShowSqlEnabled, setStreamsForBinaryEnabled
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.jmx.HibernateServiceMBean
addMapResource, getBatchVersionedDataEnabled, getCacheProviderClass, getCacheRegionPrefix, getCommentsEnabled, getDefaultCatalog, getDefaultSchema, getDialect, getGetGeneratedKeysEnabled, getJdbcBatchSize, getJdbcFetchSize, getJdbcScrollableResultSetEnabled, getMapResources, getMaximumFetchDepth, getMinimalPutsEnabled, getQueryCacheEnabled, getQuerySubstitutions, getSecondLevelCacheEnabled, getShowSqlEnabled, setBatchVersionedDataEnabled, setCacheProviderClass, setCacheRegionPrefix, setCommentsEnabled, setDefaultCatalog, setDefaultSchema, setDialect, setGetGeneratedKeysEnabled, setJdbcBatchSize, setJdbcFetchSize, setJdbcScrollableResultSetEnabled, setMapResources, setMaximumFetchDepth, setMinimalPutsEnabled, setQueryCacheEnabled, setQuerySubstitutions, setSecondLevelCacheEnabled, setShowSqlEnabled

Constructor Detail

HibernateService

public HibernateService()
Method Detail

start

public void start()
           throws HibernateException
Description copied from interface: HibernateServiceMBean
Create the SessionFactory and bind to the jndi name on startup

Specified by:
start in interface HibernateServiceMBean
Throws:
HibernateException

stop

public void stop()
Description copied from interface: HibernateServiceMBean
Unbind the SessionFactory or stub from JNDI

Specified by:
stop in interface HibernateServiceMBean

getExtraProperties

protected Map getExtraProperties()
Overrides:
getExtraProperties in class ExternalSessionFactoryConfig

getTransactionStrategy

public String getTransactionStrategy()
Description copied from interface: HibernateServiceMBean
The fully qualified class name of the Hibernate TransactionFactory implementation

Specified by:
getTransactionStrategy in interface HibernateServiceMBean
Returns:
the class name
See Also:
TransactionFactory

setTransactionStrategy

public void setTransactionStrategy(String txnStrategy)
Description copied from interface: HibernateServiceMBean
Set the fully qualified class name of the Hibernate TransactionFactory implementation

Specified by:
setTransactionStrategy in interface HibernateServiceMBean
Parameters:
txnStrategy - the class name
See Also:
TransactionFactory

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: HibernateServiceMBean
The JNDI name of the JTA UserTransaction object (used only be JTATransaction).

Specified by:
getUserTransactionName in interface HibernateServiceMBean
Returns:
the JNDI name
See Also:
JTATransaction

setUserTransactionName

public void setUserTransactionName(String utName)
Description copied from interface: HibernateServiceMBean
Set the JNDI name of the JTA UserTransaction object (used only by JTATransaction).

Specified by:
setUserTransactionName in interface HibernateServiceMBean
Parameters:
utName - the JNDI name
See Also:
JTATransaction

getTransactionManagerLookupStrategy

public String getTransactionManagerLookupStrategy()
Description copied from interface: HibernateServiceMBean
Get the strategy for obtaining the JTA TransactionManager

Specified by:
getTransactionManagerLookupStrategy in interface HibernateServiceMBean
Returns:
the class name
See Also:
TransactionManagerLookup

setTransactionManagerLookupStrategy

public void setTransactionManagerLookupStrategy(String lkpStrategy)
Description copied from interface: HibernateServiceMBean
Set the strategy for obtaining the JTA TransactionManager

Specified by:
setTransactionManagerLookupStrategy in interface HibernateServiceMBean
Parameters:
lkpStrategy - the class name
See Also:
TransactionManagerLookup

getPropertyList

public String getPropertyList()
Description copied from interface: HibernateServiceMBean
Display the properties

Specified by:
getPropertyList in interface HibernateServiceMBean
Returns:
a list of property names and values

getProperty

public String getProperty(String property)
Description copied from interface: HibernateServiceMBean
Get a property

Specified by:
getProperty in interface HibernateServiceMBean
Parameters:
property - the property name
Returns:
the property value

setProperty

public void setProperty(String property,
                        String value)
Description copied from interface: HibernateServiceMBean
Set a property

Specified by:
setProperty in interface HibernateServiceMBean
Parameters:
property - the property name
value - the property value

dropSchema

public void dropSchema()
Description copied from interface: HibernateServiceMBean
Export the DROP DDL to the database

Specified by:
dropSchema in interface HibernateServiceMBean

createSchema

public void createSchema()
Description copied from interface: HibernateServiceMBean
Export the CREATE DDL to the database

Specified by:
createSchema in interface HibernateServiceMBean

getName

public String getName()

getDatasource

public String getDatasource()
Description copied from interface: HibernateServiceMBean
The JNDI name of the datasource to use in this SessionFactory

Specified by:
getDatasource in interface HibernateServiceMBean
Returns:
String

setDatasource

public void setDatasource(String datasource)
Description copied from interface: HibernateServiceMBean
Set the JNDI name of the datasource to use in this SessionFactory

Specified by:
setDatasource in interface HibernateServiceMBean
Parameters:
datasource -

getJndiName

public String getJndiName()
Description copied from interface: HibernateServiceMBean
The JNDI name to bind to the SessionFactory

Specified by:
getJndiName in interface HibernateServiceMBean
Returns:
String

setJndiName

public void setJndiName(String jndiName)
Description copied from interface: HibernateServiceMBean
The JNDI name to bind to the SessionFactory

Specified by:
setJndiName in interface HibernateServiceMBean
Parameters:
jndiName -

getUserName

public String getUserName()
Description copied from interface: HibernateServiceMBean
Log into the database with this name

Specified by:
getUserName in interface HibernateServiceMBean
Returns:
String

setUserName

public void setUserName(String userName)
Description copied from interface: HibernateServiceMBean
Log into the database with this name

Specified by:
setUserName in interface HibernateServiceMBean
Parameters:
userName -

getPassword

public String getPassword()
Description copied from interface: HibernateServiceMBean
Log into the database with this password

Specified by:
getPassword in interface HibernateServiceMBean
Returns:
String

setPassword

public void setPassword(String password)
Description copied from interface: HibernateServiceMBean
Log into the database with this password

Specified by:
setPassword in interface HibernateServiceMBean
Parameters:
password -

setFlushBeforeCompletionEnabled

public void setFlushBeforeCompletionEnabled(String enabled)
Description copied from interface: HibernateServiceMBean
Enable automatic flushing of the Session when JTA transaction ends.

Specified by:
setFlushBeforeCompletionEnabled in interface HibernateServiceMBean

getFlushBeforeCompletionEnabled

public String getFlushBeforeCompletionEnabled()
Description copied from interface: HibernateServiceMBean
Is automatic Session flusing enabled?

Specified by:
getFlushBeforeCompletionEnabled in interface HibernateServiceMBean

setAutoCloseSessionEnabled

public void setAutoCloseSessionEnabled(String enabled)
Description copied from interface: HibernateServiceMBean
Enable automatic closing of Session when JTA transaction ends.

Specified by:
setAutoCloseSessionEnabled in interface HibernateServiceMBean

getAutoCloseSessionEnabled

public String getAutoCloseSessionEnabled()
Description copied from interface: HibernateServiceMBean
Is automatic Session closing enabled?

Specified by:
getAutoCloseSessionEnabled in interface HibernateServiceMBean

getProperties

public Properties getProperties()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


SessionFactoryStub (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jmx
Class SessionFactoryStub

java.lang.Object
    extended by org.hibernate.jmx.SessionFactoryStub
All Implemented Interfaces:
Referenceable, Serializable, SessionFactory
public class SessionFactoryStub
extends Object
implements SessionFactory

A flyweight for SessionFactory. If the MBean itself does not have classpath to the persistent classes, then a stub will be registered with JNDI and the actual SessionFactoryImpl built upon first access.

Author:
Gavin King
See Also:
Serialized Form

Method Summary
void | close() Destroy this SessionFactory and release all resources (caches, connection pools, etc).
void | evict(Class persistentClass) Evict all entries from the second-level cache.
void | evict(Class persistentClass, Serializable id) Evict an entry from the second-level cache.
void | evictCollection(String roleName) Evict all entries from the second-level cache.
void | evictCollection(String roleName, Serializable id) Evict an entry from the second-level cache.
void | evictEntity(String entityName) Evict all entries from the second-level cache.
void | evictEntity(String entityName, Serializable id) Evict an entry from the second-level cache.
void | evictQueries() Evict any query result sets cached in the default query cache region.
void | evictQueries(String cacheRegion) Evict any query result sets cached in the named query cache region.
Map | getAllClassMetadata() Get all ClassMetadata as a Map from entityname String to metadata object
Map | getAllCollectionMetadata() Get all CollectionMetadata as a Map from role name to metadata object
ClassMetadata | getClassMetadata(Class persistentClass) Get the ClassMetadata associated with the given entity class
ClassMetadata | getClassMetadata(String entityName) Get the ClassMetadata associated with the given entity name
CollectionMetadata | getCollectionMetadata(String roleName) Get the CollectionMetadata associated with the named collection role
Session | getCurrentSession() Obtains the current session.
Set | getDefinedFilterNames() Obtain a set of the names of all filters defined on this SessionFactory.
FilterDefinition | getFilterDefinition(String filterName) Obtain the definition of a filter by name.
Reference | getReference()
Statistics | getStatistics() Get the statistics for this session factory
boolean | isClosed() Was this SessionFactory already closed?
Session | openSession() Create database connection and open a Session on it.
Session | openSession(Connection conn) Open a Session on the given connection.
Session | openSession(Connection connection, Interceptor interceptor) Open a Session on the given connection, specifying an interceptor.
Session | openSession(Interceptor interceptor) Create database connection and open a Session on it, specifying an interceptor.
StatelessSession | openStatelessSession() Get a new stateless session.
StatelessSession | openStatelessSession(Connection conn) Get a new stateless session for the given JDBC connection.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

openSession

public Session openSession(Connection connection,
                           Interceptor interceptor)
Description copied from interface: SessionFactory
Open a Session on the given connection, specifying an interceptor.

Note that the second-level cache will be disabled if you supply a JDBC connection. Hibernate will not be able to track any statements you might have executed in the same transaction. Consider implementing your own ConnectionProvider.

Specified by:
openSession in interface SessionFactory
Parameters:
connection - a connection provided by the application.
interceptor - a session-scoped interceptor
Returns:
Session

openSession

public Session openSession(Interceptor interceptor)
                    throws HibernateException
Description copied from interface: SessionFactory
Create database connection and open a Session on it, specifying an interceptor.

Specified by:
openSession in interface SessionFactory
Parameters:
interceptor - a session-scoped interceptor
Returns:
Session
Throws:
HibernateException

openSession

public Session openSession()
                    throws HibernateException
Description copied from interface: SessionFactory
Create database connection and open a Session on it.

Specified by:
openSession in interface SessionFactory
Returns:
Session
Throws:
HibernateException

openSession

public Session openSession(Connection conn)
Description copied from interface: SessionFactory
Open a Session on the given connection.

Note that the second-level cache will be disabled if you supply a JDBC connection. Hibernate will not be able to track any statements you might have executed in the same transaction. Consider implementing your own ConnectionProvider.

Specified by:
openSession in interface SessionFactory
Parameters:
conn - a connection provided by the application.
Returns:
Session

getCurrentSession

public Session getCurrentSession()
Description copied from interface: SessionFactory
Obtains the current session. The definition of what exactly "current" means controlled by the CurrentSessionContext impl configured for use.

Note that for backwards compatibility, if a CurrentSessionContext is not configured but a JTA TransactionManagerLookup is configured this will default to the JTASessionContext impl.

Specified by:
getCurrentSession in interface SessionFactory
Returns:
The current session.

getReference

public Reference getReference()
                       throws NamingException
Specified by:
getReference in interface Referenceable
Throws:
NamingException
See Also:
Referenceable.getReference()

getClassMetadata

public ClassMetadata getClassMetadata(Class persistentClass)
                               throws HibernateException
Description copied from interface: SessionFactory
Get the ClassMetadata associated with the given entity class

Specified by:
getClassMetadata in interface SessionFactory
Throws:
HibernateException
See Also:
ClassMetadata

getClassMetadata

public ClassMetadata getClassMetadata(String entityName)
                               throws HibernateException
Description copied from interface: SessionFactory
Get the ClassMetadata associated with the given entity name

Specified by:
getClassMetadata in interface SessionFactory
Throws:
HibernateException
See Also:
ClassMetadata

getCollectionMetadata

public CollectionMetadata getCollectionMetadata(String roleName)
                                         throws HibernateException
Description copied from interface: SessionFactory
Get the CollectionMetadata associated with the named collection role

Specified by:
getCollectionMetadata in interface SessionFactory
Throws:
HibernateException
See Also:
CollectionMetadata

getAllClassMetadata

public Map getAllClassMetadata()
                        throws HibernateException
Description copied from interface: SessionFactory
Get all ClassMetadata as a Map from entityname String to metadata object

Specified by:
getAllClassMetadata in interface SessionFactory
Returns:
a map from String an entity name to ClassMetaData
Throws:
HibernateException
See Also:
ClassMetadata

getAllCollectionMetadata

public Map getAllCollectionMetadata()
                             throws HibernateException
Description copied from interface: SessionFactory
Get all CollectionMetadata as a Map from role name to metadata object

Specified by:
getAllCollectionMetadata in interface SessionFactory
Returns:
a map from String to CollectionMetadata
Throws:
HibernateException
See Also:
CollectionMetadata

close

public void close()
           throws HibernateException
Description copied from interface: SessionFactory
Destroy this SessionFactory and release all resources (caches, connection pools, etc). It is the responsibility of the application to ensure that there are no open Sessions before calling close().

Specified by:
close in interface SessionFactory
Throws:
HibernateException

isClosed

public boolean isClosed()
Description copied from interface: SessionFactory
Was this SessionFactory already closed?

Specified by:
isClosed in interface SessionFactory

evict

public void evict(Class persistentClass,
                  Serializable id)
           throws HibernateException
Description copied from interface: SessionFactory
Evict an entry from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Specified by:
evict in interface SessionFactory
Throws:
HibernateException

evict

public void evict(Class persistentClass)
           throws HibernateException
Description copied from interface: SessionFactory
Evict all entries from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Specified by:
evict in interface SessionFactory
Throws:
HibernateException

evictEntity

public void evictEntity(String entityName,
                        Serializable id)
                 throws HibernateException
Description copied from interface: SessionFactory
Evict an entry from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Specified by:
evictEntity in interface SessionFactory
Throws:
HibernateException

evictEntity

public void evictEntity(String entityName)
                 throws HibernateException
Description copied from interface: SessionFactory
Evict all entries from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Specified by:
evictEntity in interface SessionFactory
Throws:
HibernateException

evictCollection

public void evictCollection(String roleName,
                            Serializable id)
                     throws HibernateException
Description copied from interface: SessionFactory
Evict an entry from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Specified by:
evictCollection in interface SessionFactory
Throws:
HibernateException

evictCollection

public void evictCollection(String roleName)
                     throws HibernateException
Description copied from interface: SessionFactory
Evict all entries from the second-level cache. This method occurs outside of any transaction; it performs an immediate "hard" remove, so does not respect any transaction isolation semantics of the usage strategy. Use with care.

Specified by:
evictCollection in interface SessionFactory
Throws:
HibernateException

evictQueries

public void evictQueries()
                  throws HibernateException
Description copied from interface: SessionFactory
Evict any query result sets cached in the default query cache region.

Specified by:
evictQueries in interface SessionFactory
Throws:
HibernateException

evictQueries

public void evictQueries(String cacheRegion)
                  throws HibernateException
Description copied from interface: SessionFactory
Evict any query result sets cached in the named query cache region.

Specified by:
evictQueries in interface SessionFactory
Throws:
HibernateException

getStatistics

public Statistics getStatistics()
Description copied from interface: SessionFactory
Get the statistics for this session factory

Specified by:
getStatistics in interface SessionFactory

openStatelessSession

public StatelessSession openStatelessSession()
Description copied from interface: SessionFactory
Get a new stateless session.

Specified by:
openStatelessSession in interface SessionFactory

openStatelessSession

public StatelessSession openStatelessSession(Connection conn)
Description copied from interface: SessionFactory
Get a new stateless session for the given JDBC connection.

Specified by:
openStatelessSession in interface SessionFactory

getDefinedFilterNames

public Set getDefinedFilterNames()
Description copied from interface: SessionFactory
Obtain a set of the names of all filters defined on this SessionFactory.

Specified by:
getDefinedFilterNames in interface SessionFactory
Returns:
The set of filter names.

getFilterDefinition

public FilterDefinition getFilterDefinition(String filterName)
                                     throws HibernateException
Description copied from interface: SessionFactory
Obtain the definition of a filter by name.

Specified by:
getFilterDefinition in interface SessionFactory
Parameters:
filterName - The name of the filter for which to obtain the definition.
Returns:
The filter definition.
Throws:
HibernateException - If no filter defined with the given name.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StatisticsService (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.jmx
Class StatisticsService

java.lang.Object
    extended by org.hibernate.jmx.StatisticsService
All Implemented Interfaces:
Statistics, StatisticsServiceMBean
public class StatisticsService
extends Object
implements StatisticsServiceMBean

JMX service for Hibernate statistics

Register this MBean in your JMX server for a specific session factory

 //build the ObjectName you want
 Hashtable tb = new Hashtable();
 tb.put("type", "statistics");
 tb.put("sessionFactory", "myFinancialApp");
 ObjectName on = new ObjectName("hibernate", tb);
 StatisticsService stats = new StatisticsService();
 stats.setSessionFactory(sessionFactory);
 server.registerMBean(stats, on);
And call the MBean the way you want

Register this MBean in your JMX server with no specific session factory
 //build the ObjectName you want
 Hashtable tb = new Hashtable();
 tb.put("type", "statistics");
 tb.put("sessionFactory", "myFinancialApp");
 ObjectName on = new ObjectName("hibernate", tb);
 StatisticsService stats = new StatisticsService();
 server.registerMBean(stats, on);
And call the MBean by providing the SessionFactoryJNDIName first. Then the session factory will be retrieved from JNDI and the statistics loaded.

Author:
Emmanuel Bernard

Constructor Summary
StatisticsService()
Method Summary
void | clear() reset all statistics
long | getCloseStatementCount() The number of prepared statements that were released
long | getCollectionFetchCount() Global number of collections fetched
long | getCollectionLoadCount() Global number of collections loaded
long | getCollectionRecreateCount() Global number of collections recreated
long | getCollectionRemoveCount() Global number of collections removed
String[] | getCollectionRoleNames() Get the names of all collection roles
CollectionStatistics | getCollectionStatistics(String role) Get collection statistics per role
long | getCollectionUpdateCount() Global number of collections updated
long | getConnectCount() Get the global number of connections asked by the sessions (the actual number of connections used may be much smaller depending whether you use a connection pool or not)
long | getEntityDeleteCount() Get global number of entity deletes
long | getEntityFetchCount() Get global number of entity fetchs
long | getEntityInsertCount() Get global number of entity inserts
long | getEntityLoadCount() Get global number of entity loads
String[] | getEntityNames() Get the names of all entities
EntityStatistics | getEntityStatistics(String entityName) find entity statistics per name
long | getEntityUpdateCount() Get global number of entity updates
long | getFlushCount() Get the global number of flush executed by sessions (either implicit or explicit)
long | getOptimisticFailureCount() The number of StaleObjectStateExceptions that occurred
long | getPrepareStatementCount() The number of prepared statements that were acquired
String[] | getQueries() Get all executed query strings
long | getQueryCacheHitCount() Get the global number of cached queries successfully retrieved from cache
long | getQueryCacheMissCount() Get the global number of cached queries *not* found in cache
long | getQueryCachePutCount() Get the global number of cacheable queries put in cache
long | getQueryExecutionCount() Get global number of executed queries
long | getQueryExecutionMaxTime() Get the time in milliseconds of the slowest query.
String | getQueryExecutionMaxTimeQueryString() Get the query string for the slowest query.
QueryStatistics | getQueryStatistics(String hql) Query statistics from query string (HQL or SQL)
long | getSecondLevelCacheHitCount() Global number of cacheable entities/collections successfully retrieved from the cache
long | getSecondLevelCacheMissCount() Global number of cacheable entities/collections not found in the cache and loaded from the database.
long | getSecondLevelCachePutCount() Global number of cacheable entities/collections put in the cache
String[] | getSecondLevelCacheRegionNames() Get all second-level cache region names
SecondLevelCacheStatistics | getSecondLevelCacheStatistics(String regionName) Second level cache statistics per region
long | getSessionCloseCount() Global number of sessions closed
long | getSessionOpenCount() Global number of sessions opened
long | getStartTime()
long | getSuccessfulTransactionCount() The number of transactions we know to have been successful
long | getTransactionCount() The number of transactions we know to have completed
boolean | isStatisticsEnabled() Are statistics logged
void | logSummary() log in info level the main statistics
void | setSessionFactory(SessionFactory sf) Useful to init this MBean wo a JNDI session factory name
void | setSessionFactoryJNDIName(String sfJNDIName) Publish the statistics of a session factory bound to the default JNDI context
void | setStatisticsEnabled(boolean enable) Enable statistics logs (this is a dynamic parameter)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StatisticsService

public StatisticsService()
Method Detail

setSessionFactoryJNDIName

public void setSessionFactoryJNDIName(String sfJNDIName)
Description copied from interface: StatisticsServiceMBean
Publish the statistics of a session factory bound to the default JNDI context

Specified by:
setSessionFactoryJNDIName in interface StatisticsServiceMBean
Parameters:
sfJNDIName - session factory jndi name
See Also:
StatisticsServiceMBean.setSessionFactoryJNDIName(java.lang.String)

setSessionFactory

public void setSessionFactory(SessionFactory sf)
Useful to init this MBean wo a JNDI session factory name

Parameters:
sf - session factory to register

clear

public void clear()
Description copied from interface: Statistics
reset all statistics

Specified by:
clear in interface Statistics
See Also:
Statistics.clear()

getEntityStatistics

public EntityStatistics getEntityStatistics(String entityName)
Description copied from interface: Statistics
find entity statistics per name

Specified by:
getEntityStatistics in interface Statistics
Parameters:
entityName - entity name
Returns:
EntityStatistics object
See Also:
Statistics.getEntityStatistics(java.lang.String)

getCollectionStatistics

public CollectionStatistics getCollectionStatistics(String role)
Description copied from interface: Statistics
Get collection statistics per role

Specified by:
getCollectionStatistics in interface Statistics
Parameters:
role - collection role
Returns:
CollectionStatistics
See Also:
Statistics.getCollectionStatistics(java.lang.String)

getSecondLevelCacheStatistics

public SecondLevelCacheStatistics getSecondLevelCacheStatistics(String regionName)
Description copied from interface: Statistics
Second level cache statistics per region

Specified by:
getSecondLevelCacheStatistics in interface Statistics
Parameters:
regionName - region name
Returns:
SecondLevelCacheStatistics
See Also:
Statistics.getSecondLevelCacheStatistics(java.lang.String)

getQueryStatistics

public QueryStatistics getQueryStatistics(String hql)
Description copied from interface: Statistics
Query statistics from query string (HQL or SQL)

Specified by:
getQueryStatistics in interface Statistics
Parameters:
hql - query string
Returns:
QueryStatistics
See Also:
Statistics.getQueryStatistics(java.lang.String)

getEntityDeleteCount

public long getEntityDeleteCount()
Description copied from interface: Statistics
Get global number of entity deletes

Specified by:
getEntityDeleteCount in interface Statistics
Returns:
entity deletion count
See Also:
Statistics.getEntityDeleteCount()

getEntityInsertCount

public long getEntityInsertCount()
Description copied from interface: Statistics
Get global number of entity inserts

Specified by:
getEntityInsertCount in interface Statistics
Returns:
entity insertion count
See Also:
Statistics.getEntityInsertCount()

getEntityLoadCount

public long getEntityLoadCount()
Description copied from interface: Statistics
Get global number of entity loads

Specified by:
getEntityLoadCount in interface Statistics
Returns:
entity load (from DB)
See Also:
Statistics.getEntityLoadCount()

getEntityFetchCount

public long getEntityFetchCount()
Description copied from interface: Statistics
Get global number of entity fetchs

Specified by:
getEntityFetchCount in interface Statistics
Returns:
entity fetch (from DB)
See Also:
Statistics.getEntityFetchCount()

getEntityUpdateCount

public long getEntityUpdateCount()
Description copied from interface: Statistics
Get global number of entity updates

Specified by:
getEntityUpdateCount in interface Statistics
Returns:
entity update
See Also:
Statistics.getEntityUpdateCount()

getQueryExecutionCount

public long getQueryExecutionCount()
Description copied from interface: Statistics
Get global number of executed queries

Specified by:
getQueryExecutionCount in interface Statistics
Returns:
query execution count
See Also:
Statistics.getQueryExecutionCount()

getQueryCacheHitCount

public long getQueryCacheHitCount()
Description copied from interface: Statistics
Get the global number of cached queries successfully retrieved from cache

Specified by:
getQueryCacheHitCount in interface Statistics

getQueryExecutionMaxTime

public long getQueryExecutionMaxTime()
Description copied from interface: Statistics
Get the time in milliseconds of the slowest query.

Specified by:
getQueryExecutionMaxTime in interface Statistics

getQueryCacheMissCount

public long getQueryCacheMissCount()
Description copied from interface: Statistics
Get the global number of cached queries *not* found in cache

Specified by:
getQueryCacheMissCount in interface Statistics

getQueryCachePutCount

public long getQueryCachePutCount()
Description copied from interface: Statistics
Get the global number of cacheable queries put in cache

Specified by:
getQueryCachePutCount in interface Statistics

getFlushCount

public long getFlushCount()
Description copied from interface: Statistics
Get the global number of flush executed by sessions (either implicit or explicit)

Specified by:
getFlushCount in interface Statistics
See Also:
Statistics.getFlushCount()

getConnectCount

public long getConnectCount()
Description copied from interface: Statistics
Get the global number of connections asked by the sessions (the actual number of connections used may be much smaller depending whether you use a connection pool or not)

Specified by:
getConnectCount in interface Statistics
See Also:
Statistics.getConnectCount()

getSecondLevelCacheHitCount

public long getSecondLevelCacheHitCount()
Description copied from interface: Statistics
Global number of cacheable entities/collections successfully retrieved from the cache

Specified by:
getSecondLevelCacheHitCount in interface Statistics
See Also:
Statistics.getSecondLevelCacheHitCount()

getSecondLevelCacheMissCount

public long getSecondLevelCacheMissCount()
Description copied from interface: Statistics
Global number of cacheable entities/collections not found in the cache and loaded from the database.

Specified by:
getSecondLevelCacheMissCount in interface Statistics
See Also:
Statistics.getSecondLevelCacheMissCount()

getSecondLevelCachePutCount

public long getSecondLevelCachePutCount()
Description copied from interface: Statistics
Global number of cacheable entities/collections put in the cache

Specified by:
getSecondLevelCachePutCount in interface Statistics
See Also:
Statistics.getSecondLevelCachePutCount()

getSessionCloseCount

public long getSessionCloseCount()
Description copied from interface: Statistics
Global number of sessions closed

Specified by:
getSessionCloseCount in interface Statistics
See Also:
Statistics.getSessionCloseCount()

getSessionOpenCount

public long getSessionOpenCount()
Description copied from interface: Statistics
Global number of sessions opened

Specified by:
getSessionOpenCount in interface Statistics
See Also:
Statistics.getSessionOpenCount()

getCollectionLoadCount

public long getCollectionLoadCount()
Description copied from interface: Statistics
Global number of collections loaded

Specified by:
getCollectionLoadCount in interface Statistics
See Also:
Statistics.getCollectionLoadCount()

getCollectionFetchCount

public long getCollectionFetchCount()
Description copied from interface: Statistics
Global number of collections fetched

Specified by:
getCollectionFetchCount in interface Statistics
See Also:
Statistics.getCollectionFetchCount()

getCollectionUpdateCount

public long getCollectionUpdateCount()
Description copied from interface: Statistics
Global number of collections updated

Specified by:
getCollectionUpdateCount in interface Statistics
See Also:
Statistics.getCollectionUpdateCount()

getCollectionRemoveCount

public long getCollectionRemoveCount()
Description copied from interface: Statistics
Global number of collections removed

Specified by:
getCollectionRemoveCount in interface Statistics
See Also:
Statistics.getCollectionRemoveCount()

getCollectionRecreateCount

public long getCollectionRecreateCount()
Description copied from interface: Statistics
Global number of collections recreated

Specified by:
getCollectionRecreateCount in interface Statistics
See Also:
Statistics.getCollectionRecreateCount()

getStartTime

public long getStartTime()
Specified by:
getStartTime in interface Statistics
Returns:
start time in ms (JVM standards System.currentTimeMillis())
See Also:
Statistics.getStartTime()

isStatisticsEnabled

public boolean isStatisticsEnabled()
Description copied from interface: Statistics
Are statistics logged

Specified by:
isStatisticsEnabled in interface Statistics
See Also:
Statistics.isStatisticsEnabled()

setStatisticsEnabled

public void setStatisticsEnabled(boolean enable)
Description copied from interface: Statistics
Enable statistics logs (this is a dynamic parameter)

Specified by:
setStatisticsEnabled in interface Statistics
See Also:
Statistics.setStatisticsEnabled(boolean)

logSummary

public void logSummary()
Description copied from interface: Statistics
log in info level the main statistics

Specified by:
logSummary in interface Statistics

getCollectionRoleNames

public String[] getCollectionRoleNames()
Description copied from interface: Statistics
Get the names of all collection roles

Specified by:
getCollectionRoleNames in interface Statistics

getEntityNames

public String[] getEntityNames()
Description copied from interface: Statistics
Get the names of all entities

Specified by:
getEntityNames in interface Statistics

getQueries

public String[] getQueries()
Description copied from interface: Statistics
Get all executed query strings

Specified by:
getQueries in interface Statistics

getSecondLevelCacheRegionNames

public String[] getSecondLevelCacheRegionNames()
Description copied from interface: Statistics
Get all second-level cache region names

Specified by:
getSecondLevelCacheRegionNames in interface Statistics

getSuccessfulTransactionCount

public long getSuccessfulTransactionCount()
Description copied from interface: Statistics
The number of transactions we know to have been successful

Specified by:
getSuccessfulTransactionCount in interface Statistics

getTransactionCount

public long getTransactionCount()
Description copied from interface: Statistics
The number of transactions we know to have completed

Specified by:
getTransactionCount in interface Statistics

getCloseStatementCount

public long getCloseStatementCount()
Description copied from interface: Statistics
The number of prepared statements that were released

Specified by:
getCloseStatementCount in interface Statistics

getPrepareStatementCount

public long getPrepareStatementCount()
Description copied from interface: Statistics
The number of prepared statements that were acquired

Specified by:
getPrepareStatementCount in interface Statistics

getOptimisticFailureCount

public long getOptimisticFailureCount()
Description copied from interface: Statistics
The number of StaleObjectStateExceptions that occurred

Specified by:
getOptimisticFailureCount in interface Statistics

getQueryExecutionMaxTimeQueryString

public String getQueryExecutionMaxTimeQueryString()
Description copied from interface: Statistics
Get the query string for the slowest query.

Specified by:
getQueryExecutionMaxTimeQueryString in interface Statistics
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.loader (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.loader

This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.

See:
Description

Interface Summary
CollectionAliases | Type definition of CollectionAliases.
EntityAliases | Metadata describing the SQL result set column aliases for a particular entity.

Class Summary
AbstractEntityJoinWalker | Abstract walker for walkers which begin at an entity (criteria queries and entity loaders).
BasicLoader | Uses the default mapping from property to result set column alias defined by the entities' persisters.
ColumnEntityAliases | EntityAliases that chooses the column names over the alias names.
DefaultEntityAliases | EntityAliases which handles the logic of selecting user provided aliases (via return-property), before using the default aliases.
GeneratedCollectionAliases | CollectionAliases which handles the logic of selecting user provided aliases (via return-property), before using the default aliases.
JoinWalker | Walks the metamodel, searching for joins, and collecting together information needed by OuterJoinLoader.
Loader | Abstract superclass of object loading (and querying) strategies.
OuterJoinableAssociation |
OuterJoinLoader | Implements logic for walking a tree of associated classes.

Package org.hibernate.loader Description

This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.

Subclasses of Loader define a particular query mechanism.


org.hibernate.loader Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.loader

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.loader.DefaultEntityAliases (implements org.hibernate.loader.EntityAliases)
      • class org.hibernate.loader.ColumnEntityAliases
    • class org.hibernate.loader.GeneratedCollectionAliases (implements org.hibernate.loader.CollectionAliases)
    • class org.hibernate.loader.JoinWalker
      • class org.hibernate.loader.AbstractEntityJoinWalker
    • class org.hibernate.loader.Loader
      • class org.hibernate.loader.BasicLoader
        • class org.hibernate.loader.OuterJoinLoader
    • class org.hibernate.loader.OuterJoinableAssociation

Interface Hierarchy

  • interface org.hibernate.loader.CollectionAliases
  • interface org.hibernate.loader.EntityAliases


Uses of Package org.hibernate.loader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.loader

Packages that use org.hibernate.loader
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser

Classes in org.hibernate.loader used by org.hibernate.collection
CollectionAliases
Type definition of CollectionAliases.

Classes in org.hibernate.loader used by org.hibernate.hql.classic
BasicLoader
Uses the default mapping from property to result set column alias defined by the entities' persisters.
Loader
Abstract superclass of object loading (and querying) strategies.

Classes in org.hibernate.loader used by org.hibernate.impl
Loader
Abstract superclass of object loading (and querying) strategies.

Classes in org.hibernate.loader used by org.hibernate.loader
BasicLoader
Uses the default mapping from property to result set column alias defined by the entities' persisters.
CollectionAliases
Type definition of CollectionAliases.
DefaultEntityAliases
EntityAliases which handles the logic of selecting user provided aliases (via return-property), before using the default aliases.
EntityAliases
Metadata describing the SQL result set column aliases for a particular entity.
JoinWalker
Walks the metamodel, searching for joins, and collecting together information needed by OuterJoinLoader.
Loader
Abstract superclass of object loading (and querying) strategies.
OuterJoinableAssociation

Classes in org.hibernate.loader used by org.hibernate.loader.collection
BasicLoader
Uses the default mapping from property to result set column alias defined by the entities' persisters.
JoinWalker
Walks the metamodel, searching for joins, and collecting together information needed by OuterJoinLoader.
Loader
Abstract superclass of object loading (and querying) strategies.
OuterJoinLoader
Implements logic for walking a tree of associated classes.

Classes in org.hibernate.loader used by org.hibernate.loader.criteria
AbstractEntityJoinWalker
Abstract walker for walkers which begin at an entity (criteria queries and entity loaders).
BasicLoader
Uses the default mapping from property to result set column alias defined by the entities' persisters.
JoinWalker
Walks the metamodel, searching for joins, and collecting together information needed by OuterJoinLoader.
Loader
Abstract superclass of object loading (and querying) strategies.
OuterJoinLoader
Implements logic for walking a tree of associated classes.

Classes in org.hibernate.loader used by org.hibernate.loader.custom
CollectionAliases
Type definition of CollectionAliases.
EntityAliases
Metadata describing the SQL result set column aliases for a particular entity.
Loader
Abstract superclass of object loading (and querying) strategies.

Classes in org.hibernate.loader used by org.hibernate.loader.entity
AbstractEntityJoinWalker
Abstract walker for walkers which begin at an entity (criteria queries and entity loaders).
BasicLoader
Uses the default mapping from property to result set column alias defined by the entities' persisters.
JoinWalker
Walks the metamodel, searching for joins, and collecting together information needed by OuterJoinLoader.
Loader
Abstract superclass of object loading (and querying) strategies.
OuterJoinLoader
Implements logic for walking a tree of associated classes.

Classes in org.hibernate.loader used by org.hibernate.loader.hql
BasicLoader
Uses the default mapping from property to result set column alias defined by the entities' persisters.
Loader
Abstract superclass of object loading (and querying) strategies.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CollectionAliases (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader
Interface CollectionAliases

All Known Implementing Classes:
ColumnCollectionAliases, GeneratedCollectionAliases
public interface CollectionAliases

Type definition of CollectionAliases.

Author:
Steve Ebersole

Method Summary
String | getSuffix() Returns the suffix used to unique the column aliases for this particular alias set.
String[] | getSuffixedElementAliases() Returns the suffixed result-set column-aliases for the columns making up the collection's elements.
String | getSuffixedIdentifierAlias() Returns the suffixed result-set column-aliases for the column defining the collection's identifier (if any).
String[] | getSuffixedIndexAliases() Returns the suffixed result-set column-aliases for the collumns making up the collection's index (map or list).
String[] | getSuffixedKeyAliases() Returns the suffixed result-set column-aliases for columns making up the key for this collection (i.e., its FK to its owner).

Method Detail

getSuffixedKeyAliases

public String[] getSuffixedKeyAliases()
Returns the suffixed result-set column-aliases for columns making up the key for this collection (i.e., its FK to its owner).

Returns:
The key result-set column aliases.

getSuffixedIndexAliases

public String[] getSuffixedIndexAliases()
Returns the suffixed result-set column-aliases for the collumns making up the collection's index (map or list).

Returns:
The index result-set column aliases.

getSuffixedElementAliases

public String[] getSuffixedElementAliases()
Returns the suffixed result-set column-aliases for the columns making up the collection's elements.

Returns:
The element result-set column aliases.

getSuffixedIdentifierAlias

public String getSuffixedIdentifierAlias()
Returns the suffixed result-set column-aliases for the column defining the collection's identifier (if any).

Returns:
The identifier result-set column aliases.

getSuffix

public String getSuffix()
Returns the suffix used to unique the column aliases for this particular alias set.

Returns:
The uniqued column alias suffix.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


EntityAliases (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader
Interface EntityAliases

All Known Implementing Classes:
DefaultEntityAliases
public interface EntityAliases

Metadata describing the SQL result set column aliases for a particular entity.

Author:
Gavin King

Method Summary
String | getRowIdAlias() The result set column alias for the Oracle row id
String | getSuffixedDiscriminatorAlias() The result set column aliases for the discriminator columns
String[] | getSuffixedKeyAliases() The result set column aliases for the primary key columns
String[][] | getSuffixedPropertyAliases() The result set column aliases for the property columns
String[][] | getSuffixedPropertyAliases(Loadable persister) The result set column aliases for the property columns of a subclass
String[] | getSuffixedVersionAliases() The result set column aliases for the version columns

Method Detail

getSuffixedKeyAliases

public String[] getSuffixedKeyAliases()
The result set column aliases for the primary key columns

getSuffixedDiscriminatorAlias

public String getSuffixedDiscriminatorAlias()
The result set column aliases for the discriminator columns

getSuffixedVersionAliases

public String[] getSuffixedVersionAliases()
The result set column aliases for the version columns

getSuffixedPropertyAliases

public String[][] getSuffixedPropertyAliases()
The result set column aliases for the property columns

getSuffixedPropertyAliases

public String[][] getSuffixedPropertyAliases(Loadable persister)
The result set column aliases for the property columns of a subclass

getRowIdAlias

public String getRowIdAlias()
The result set column alias for the Oracle row id

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractEntityJoinWalker (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader
Class AbstractEntityJoinWalker

java.lang.Object
    extended by org.hibernate.loader.JoinWalker
        extended by org.hibernate.loader.AbstractEntityJoinWalker
Direct Known Subclasses:
CascadeEntityJoinWalker, CriteriaJoinWalker, EntityJoinWalker
public abstract class AbstractEntityJoinWalker
extends JoinWalker

Abstract walker for walkers which begin at an entity (criteria queries and entity loaders).

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.loader.JoinWalker
aliases, associations, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Constructor Summary
AbstractEntityJoinWalker(OuterJoinLoadable persister, SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
protected String | getAlias()
abstract String | getComment()
protected Loadable | getPersister()
protected String | getWhereFragment() Don't bother with the discriminator, unless overridded by subclass
protected void | initAll(String whereString, String orderByString, LockMode lockMode)
protected void | initProjection(String projectionString, String whereString, String orderByString, String groupByString, LockMode lockMode)
protected boolean | isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) The superclass deliberately excludes collections
String | toString()
Methods inherited from class org.hibernate.loader.JoinWalker
countCollectionPersisters, countEntityPersisters, generateRootAlias, generateTableAlias, getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getFactory, getJoinType, getJoinType, getLockModeArray, getOwnerAssociationTypes, getOwners, getPersisters, getSQLString, getSuffixes, initPersisters, isDuplicateAssociation, isDuplicateAssociation, isJoinable, isJoinedFetchEnabledInMapping, isTooDeep, isTooManyCollections, mergeOrderings, mergeOuterJoins, orderBy, orderBy, selectString, setAliases, setCollectionOwners, setCollectionPersisters, setCollectionSuffixes, setLockModeArray, setOwnerAssociationTypes, setOwners, setPersisters, setSql, setSuffixes, walkCollectionTree, walkEntityTree, whereString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AbstractEntityJoinWalker

public AbstractEntityJoinWalker(OuterJoinLoadable persister,
                                SessionFactoryImplementor factory,
                                Map enabledFilters)
Method Detail

initAll

protected final void initAll(String whereString,
                             String orderByString,
                             LockMode lockMode)
                      throws MappingException
Throws:
MappingException

initProjection

protected final void initProjection(String projectionString,
                                    String whereString,
                                    String orderByString,
                                    String groupByString,
                                    LockMode lockMode)
                             throws MappingException
Throws:
MappingException

getWhereFragment

protected String getWhereFragment()
                           throws MappingException
Don't bother with the discriminator, unless overridded by subclass

Throws:
MappingException

isJoinedFetchEnabled

protected boolean isJoinedFetchEnabled(AssociationType type,
                                       FetchMode config,
                                       CascadeStyle cascadeStyle)
The superclass deliberately excludes collections

Overrides:
isJoinedFetchEnabled in class JoinWalker

getComment

public abstract String getComment()

getPersister

protected final Loadable getPersister()

getAlias

protected final String getAlias()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BasicLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader
Class BasicLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
Direct Known Subclasses:
OuterJoinLoader, QueryLoader, QueryTranslatorImpl
public abstract class BasicLoader
extends Loader

Uses the default mapping from property to result set column alias defined by the entities' persisters. Used when Hibernate is generating result set column aliases.

Author:
Gavin King

Field Summary
protected static String[] NO_SUFFIX
Constructor Summary
BasicLoader(SessionFactoryImplementor factory)
Method Summary
static String[] | generateSuffixes(int length) Utility method that generates 0_, 1_ suffixes.
static String[] | generateSuffixes(int seed, int length)
protected CollectionAliases[] | getCollectionAliases()
protected abstract String[] | getCollectionSuffixes()
protected EntityAliases[] | getEntityAliases() Get the result set descriptor
protected abstract String[] | getSuffixes()
protected void | postInstantiate() Calculate and cache select-clause suffixes.
Methods inherited from class org.hibernate.loader.Loader
applyLocks, autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getAliases, getCollectionOwners, getCollectionPersisters, getEntityEagerPropertyFetches, getEntityPersisters, getFactory, getLockModes, getNamedParameterLocs, getOwnerAssociationTypes, getOwners, getQueryIdentifier, getResultColumnOrRow, getResultList, getResultSet, getSQLString, hasSubselectLoadableCollections, isSingleRowLoader, isSubselectLoadingEnabled, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll, toString, upgradeLocks
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NO_SUFFIX

protected static final String[] NO_SUFFIX
Constructor Detail

BasicLoader

public BasicLoader(SessionFactoryImplementor factory)
Method Detail

getEntityAliases

protected final EntityAliases[] getEntityAliases()
Description copied from class: Loader
Get the result set descriptor

Specified by:
getEntityAliases in class Loader

getCollectionAliases

protected final CollectionAliases[] getCollectionAliases()
Specified by:
getCollectionAliases in class Loader

getSuffixes

protected abstract String[] getSuffixes()

getCollectionSuffixes

protected abstract String[] getCollectionSuffixes()

postInstantiate

protected void postInstantiate()
Description copied from class: Loader
Calculate and cache select-clause suffixes. Must be called by subclasses after instantiation.

Overrides:
postInstantiate in class Loader

generateSuffixes

public static String[] generateSuffixes(int length)
Utility method that generates 0_, 1_ suffixes. Subclasses don't necessarily need to use this algorithm, but it is intended that they will in most cases.

generateSuffixes

public static String[] generateSuffixes(int seed,
                                        int length)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ColumnEntityAliases (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader
Class ColumnEntityAliases

java.lang.Object
    extended by org.hibernate.loader.DefaultEntityAliases
        extended by org.hibernate.loader.ColumnEntityAliases
All Implemented Interfaces:
EntityAliases
public class ColumnEntityAliases
extends DefaultEntityAliases

EntityAliases that chooses the column names over the alias names.

Author:
max

Constructor Summary
ColumnEntityAliases(Map returnProperties, Loadable persister, String suffix)
Method Summary
protected String | getDiscriminatorAlias(Loadable persister, String suffix)
protected String[] | getIdentifierAliases(Loadable persister, String suffix)
protected String[] | getPropertyAliases(Loadable persister, int j)
Methods inherited from class org.hibernate.loader.DefaultEntityAliases
getRowIdAlias, getSuffixedDiscriminatorAlias, getSuffixedKeyAliases, getSuffixedPropertyAliases, getSuffixedPropertyAliases, getSuffixedVersionAliases
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ColumnEntityAliases

public ColumnEntityAliases(Map returnProperties,
                           Loadable persister,
                           String suffix)
Method Detail

getIdentifierAliases

protected String[] getIdentifierAliases(Loadable persister,
                                        String suffix)
Overrides:
getIdentifierAliases in class DefaultEntityAliases

getDiscriminatorAlias

protected String getDiscriminatorAlias(Loadable persister,
                                       String suffix)
Overrides:
getDiscriminatorAlias in class DefaultEntityAliases

getPropertyAliases

protected String[] getPropertyAliases(Loadable persister,
                                      int j)
Overrides:
getPropertyAliases in class DefaultEntityAliases
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultEntityAliases (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader
Class DefaultEntityAliases

java.lang.Object
    extended by org.hibernate.loader.DefaultEntityAliases
All Implemented Interfaces:
EntityAliases
Direct Known Subclasses:
ColumnEntityAliases
public class DefaultEntityAliases
extends Object
implements EntityAliases

EntityAliases which handles the logic of selecting user provided aliases (via return-property), before using the default aliases.

Author:
max

Constructor Summary
DefaultEntityAliases(Loadable persister, String suffix)
DefaultEntityAliases(Map userProvidedAliases, Loadable persister, String suffix)
Calculate and cache select-clause suffixes.
Method Summary
protected String | getDiscriminatorAlias(Loadable persister, String suffix)
protected String[] | getIdentifierAliases(Loadable persister, String suffix)
protected String[] | getPropertyAliases(Loadable persister, int j)
String | getRowIdAlias() The result set column alias for the Oracle row id
String | getSuffixedDiscriminatorAlias() The result set column aliases for the discriminator columns
String[] | getSuffixedKeyAliases() The result set column aliases for the primary key columns
String[][] | getSuffixedPropertyAliases() The result set column aliases for the property columns
String[][] | getSuffixedPropertyAliases(Loadable persister) The result set column aliases for the property columns of a subclass
String[] | getSuffixedVersionAliases() The result set column aliases for the version columns
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultEntityAliases

public DefaultEntityAliases(Loadable persister,
                            String suffix)

DefaultEntityAliases

public DefaultEntityAliases(Map userProvidedAliases,
                            Loadable persister,
                            String suffix)
Calculate and cache select-clause suffixes.

Method Detail

getDiscriminatorAlias

protected String getDiscriminatorAlias(Loadable persister,
                                       String suffix)

getIdentifierAliases

protected String[] getIdentifierAliases(Loadable persister,
                                        String suffix)

getPropertyAliases

protected String[] getPropertyAliases(Loadable persister,
                                      int j)

getSuffixedPropertyAliases

public String[][] getSuffixedPropertyAliases(Loadable persister)
Description copied from interface: EntityAliases
The result set column aliases for the property columns of a subclass

Specified by:
getSuffixedPropertyAliases in interface EntityAliases

getSuffixedVersionAliases

public String[] getSuffixedVersionAliases()
Description copied from interface: EntityAliases
The result set column aliases for the version columns

Specified by:
getSuffixedVersionAliases in interface EntityAliases

getSuffixedPropertyAliases

public String[][] getSuffixedPropertyAliases()
Description copied from interface: EntityAliases
The result set column aliases for the property columns

Specified by:
getSuffixedPropertyAliases in interface EntityAliases

getSuffixedDiscriminatorAlias

public String getSuffixedDiscriminatorAlias()
Description copied from interface: EntityAliases
The result set column aliases for the discriminator columns

Specified by:
getSuffixedDiscriminatorAlias in interface EntityAliases

getSuffixedKeyAliases

public String[] getSuffixedKeyAliases()
Description copied from interface: EntityAliases
The result set column aliases for the primary key columns

Specified by:
getSuffixedKeyAliases in interface EntityAliases

getRowIdAlias

public String getRowIdAlias()
Description copied from interface: EntityAliases
The result set column alias for the Oracle row id

Specified by:
getRowIdAlias in interface EntityAliases
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GeneratedCollectionAliases (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader
Class GeneratedCollectionAliases

java.lang.Object
    extended by org.hibernate.loader.GeneratedCollectionAliases
All Implemented Interfaces:
CollectionAliases
public class GeneratedCollectionAliases
extends Object
implements CollectionAliases

CollectionAliases which handles the logic of selecting user provided aliases (via return-property), before using the default aliases.

Author:
Steve Ebersole and Max Rydahl Andersen

Constructor Summary
GeneratedCollectionAliases(CollectionPersister persister, String string)
GeneratedCollectionAliases(Map userProvidedAliases, CollectionPersister persister, String suffix)
Method Summary
String | getSuffix() Returns the suffix used to unique the column aliases for this particular alias set.
String[] | getSuffixedElementAliases() Returns the suffixed result-set column-aliases for the columns making up the collection's elements.
String | getSuffixedIdentifierAlias() Returns the suffixed result-set column-aliases for the column defining the collection's identifier (if any).
String[] | getSuffixedIndexAliases() Returns the suffixed result-set column-aliases for the collumns making up the collection's index (map or list).
String[] | getSuffixedKeyAliases() Returns the suffixed result-set column-aliases for columns making up the key for this collection (i.e., its FK to its owner).
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

GeneratedCollectionAliases

public GeneratedCollectionAliases(Map userProvidedAliases,
                                  CollectionPersister persister,
                                  String suffix)

GeneratedCollectionAliases

public GeneratedCollectionAliases(CollectionPersister persister,
                                  String string)
Method Detail

getSuffixedKeyAliases

public String[] getSuffixedKeyAliases()
Returns the suffixed result-set column-aliases for columns making up the key for this collection (i.e., its FK to its owner).

Specified by:
getSuffixedKeyAliases in interface CollectionAliases
Returns:
The key result-set column aliases.

getSuffixedIndexAliases

public String[] getSuffixedIndexAliases()
Returns the suffixed result-set column-aliases for the collumns making up the collection's index (map or list).

Specified by:
getSuffixedIndexAliases in interface CollectionAliases
Returns:
The index result-set column aliases.

getSuffixedElementAliases

public String[] getSuffixedElementAliases()
Returns the suffixed result-set column-aliases for the columns making up the collection's elements.

Specified by:
getSuffixedElementAliases in interface CollectionAliases
Returns:
The element result-set column aliases.

getSuffixedIdentifierAlias

public String getSuffixedIdentifierAlias()
Returns the suffixed result-set column-aliases for the column defining the collection's identifier (if any).

Specified by:
getSuffixedIdentifierAlias in interface CollectionAliases
Returns:
The identifier result-set column aliases.

getSuffix

public String getSuffix()
Returns the suffix used to unique the column aliases for this particular alias set.

Specified by:
getSuffix in interface CollectionAliases
Returns:
The uniqued column alias suffix.

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JoinWalker (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader
Class JoinWalker

java.lang.Object
    extended by org.hibernate.loader.JoinWalker
Direct Known Subclasses:
AbstractEntityJoinWalker, CollectionJoinWalker
public class JoinWalker
extends Object

Walks the metamodel, searching for joins, and collecting together information needed by OuterJoinLoader.

Author:
Gavin King, Jon Lipsky
See Also:
OuterJoinLoader

Field Summary
protected String[] | aliases
protected List | associations
protected int[] | collectionOwners
protected CollectionPersister[] | collectionPersisters
protected String[] | collectionSuffixes
protected LockMode[] | lockModeArray
protected EntityType[] | ownerAssociationTypes
protected int[] | owners
protected Loadable[] | persisters
protected String | sql
protected String[] | suffixes
Constructor Summary
protected JoinWalker(SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
protected static int | countCollectionPersisters(List associations) Count the number of instances of Joinable which are actually also instances of PersistentCollection which are being fetched by outer join
protected static int | countEntityPersisters(List associations) Count the number of instances of Joinable which are actually also instances of Loadable, or are one-to-many associations
protected String | generateRootAlias(String description)
protected String | generateTableAlias(int n, String path, Joinable joinable)
String[] | getAliases()
int[] | getCollectionOwners()
CollectionPersister[] | getCollectionPersisters()
String[] | getCollectionSuffixes()
protected Dialect | getDialect()
protected Map | getEnabledFilters()
protected SessionFactoryImplementor | getFactory()
protected int | getJoinType(AssociationType type, FetchMode config, String path, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth, CascadeStyle cascadeStyle) Get the join type (inner, outer, etc) or -1 if the association should not be joined.
protected int | getJoinType(boolean nullable, int currentDepth) Use an inner join if it is a non-null association and this is the "first" join in a series
LockMode[] | getLockModeArray()
EntityType[] | getOwnerAssociationTypes()
int[] | getOwners()
Loadable[] | getPersisters()
String | getSQLString()
String[] | getSuffixes()
protected void | initPersisters(List associations, LockMode lockMode)
protected boolean | isDuplicateAssociation(String foreignKeyTable, String[] foreignKeyColumns) Used to detect circularities in the joined graph, note that this method is side-effecty
protected boolean | isDuplicateAssociation(String lhsTable, String[] lhsColumnNames, AssociationType type) Used to detect circularities in the joined graph, note that this method is side-effecty
protected boolean | isJoinable(int joinType, Set visitedAssociationKeys, String lhsTable, String[] lhsColumnNames, AssociationType type, int depth) Should we join this association?
protected boolean | isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) Override on subclasses to enable or suppress joining of certain association types
protected boolean | isJoinedFetchEnabledInMapping(FetchMode config, AssociationType type) Does the mapping, and Hibernate default semantics, specify that this association should be fetched by outer joining
protected boolean | isTooDeep(int currentDepth)
protected boolean | isTooManyCollections()
protected static String | mergeOrderings(String ordering1, String ordering2)
protected JoinFragment | mergeOuterJoins(List associations) Generate a sequence of LEFT OUTER JOIN clauses for the given associations.
protected static String | orderBy(List associations) Get the order by string required for collection fetching
protected String | orderBy(List associations, String orderBy)
protected String | selectString(List associations) Generate a select list of columns containing all properties of the entity classes
void | setAliases(String[] aliases)
void | setCollectionOwners(int[] collectionOwners)
void | setCollectionPersisters(CollectionPersister[] collectionPersisters)
void | setCollectionSuffixes(String[] collectionSuffixes)
void | setLockModeArray(LockMode[] lockModeArray)
void | setOwnerAssociationTypes(EntityType[] ownerAssociationType)
void | setOwners(int[] owners)
void | setPersisters(Loadable[] persisters)
void | setSql(String sql)
void | setSuffixes(String[] suffixes)
protected void | walkCollectionTree(QueryableCollection persister, String alias) For a collection role, return a list of associations to be fetched by outerjoin
protected void | walkEntityTree(OuterJoinLoadable persister, String alias) For an entity class, return a list of associations to be fetched by outerjoin
protected StringBuffer | whereString(String alias, String[] columnNames, int batchSize) Render the where condition for a (batch) load by identifier / collection key
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

associations

protected final List associations

suffixes

protected String[] suffixes

collectionSuffixes

protected String[] collectionSuffixes

persisters

protected Loadable[] persisters

owners

protected int[] owners

ownerAssociationTypes

protected EntityType[] ownerAssociationTypes

collectionPersisters

protected CollectionPersister[] collectionPersisters

collectionOwners

protected int[] collectionOwners

aliases

protected String[] aliases

lockModeArray

protected LockMode[] lockModeArray

sql

protected String sql
Constructor Detail

JoinWalker

protected JoinWalker(SessionFactoryImplementor factory,
                     Map enabledFilters)
Method Detail

getCollectionSuffixes

public String[] getCollectionSuffixes()

setCollectionSuffixes

public void setCollectionSuffixes(String[] collectionSuffixes)

getLockModeArray

public LockMode[] getLockModeArray()

setLockModeArray

public void setLockModeArray(LockMode[] lockModeArray)

getSuffixes

public String[] getSuffixes()

setSuffixes

public void setSuffixes(String[] suffixes)

getAliases

public String[] getAliases()

setAliases

public void setAliases(String[] aliases)

getCollectionOwners

public int[] getCollectionOwners()

setCollectionOwners

public void setCollectionOwners(int[] collectionOwners)

getCollectionPersisters

public CollectionPersister[] getCollectionPersisters()

setCollectionPersisters

public void setCollectionPersisters(CollectionPersister[] collectionPersisters)

getOwnerAssociationTypes

public EntityType[] getOwnerAssociationTypes()

setOwnerAssociationTypes

public void setOwnerAssociationTypes(EntityType[] ownerAssociationType)

getOwners

public int[] getOwners()

setOwners

public void setOwners(int[] owners)

getPersisters

public Loadable[] getPersisters()

setPersisters

public void setPersisters(Loadable[] persisters)

getSQLString

public String getSQLString()

setSql

public void setSql(String sql)

getFactory

protected SessionFactoryImplementor getFactory()

getDialect

protected Dialect getDialect()

getEnabledFilters

protected Map getEnabledFilters()

walkEntityTree

protected final void walkEntityTree(OuterJoinLoadable persister,
                                    String alias)
                             throws MappingException
For an entity class, return a list of associations to be fetched by outerjoin

Throws:
MappingException

walkCollectionTree

protected final void walkCollectionTree(QueryableCollection persister,
                                        String alias)
                                 throws MappingException
For a collection role, return a list of associations to be fetched by outerjoin

Throws:
MappingException

getJoinType

protected int getJoinType(AssociationType type,
                          FetchMode config,
                          String path,
                          String lhsTable,
                          String[] lhsColumns,
                          boolean nullable,
                          int currentDepth,
                          CascadeStyle cascadeStyle)
                   throws MappingException
Get the join type (inner, outer, etc) or -1 if the association should not be joined. Override on subclasses.

Throws:
MappingException

getJoinType

protected int getJoinType(boolean nullable,
                          int currentDepth)
Use an inner join if it is a non-null association and this is the "first" join in a series

isTooDeep

protected boolean isTooDeep(int currentDepth)

isTooManyCollections

protected boolean isTooManyCollections()

isJoinedFetchEnabledInMapping

protected boolean isJoinedFetchEnabledInMapping(FetchMode config,
                                                AssociationType type)
                                         throws MappingException
Does the mapping, and Hibernate default semantics, specify that this association should be fetched by outer joining

Throws:
MappingException

isJoinedFetchEnabled

protected boolean isJoinedFetchEnabled(AssociationType type,
                                       FetchMode config,
                                       CascadeStyle cascadeStyle)
Override on subclasses to enable or suppress joining of certain association types

generateTableAlias

protected String generateTableAlias(int n,
                                    String path,
                                    Joinable joinable)

generateRootAlias

protected String generateRootAlias(String description)

isDuplicateAssociation

protected boolean isDuplicateAssociation(String foreignKeyTable,
                                         String[] foreignKeyColumns)
Used to detect circularities in the joined graph, note that this method is side-effecty

isDuplicateAssociation

protected boolean isDuplicateAssociation(String lhsTable,
                                         String[] lhsColumnNames,
                                         AssociationType type)
Used to detect circularities in the joined graph, note that this method is side-effecty

isJoinable

protected boolean isJoinable(int joinType,
                             Set visitedAssociationKeys,
                             String lhsTable,
                             String[] lhsColumnNames,
                             AssociationType type,
                             int depth)
Should we join this association?

orderBy

protected String orderBy(List associations,
                         String orderBy)

mergeOrderings

protected static String mergeOrderings(String ordering1,
                                       String ordering2)

mergeOuterJoins

protected final JoinFragment mergeOuterJoins(List associations)
                                      throws MappingException
Generate a sequence of LEFT OUTER JOIN clauses for the given associations.

Throws:
MappingException

countEntityPersisters

protected static final int countEntityPersisters(List associations)
                                          throws MappingException
Count the number of instances of Joinable which are actually also instances of Loadable, or are one-to-many associations

Throws:
MappingException

countCollectionPersisters

protected static final int countCollectionPersisters(List associations)
                                              throws MappingException
Count the number of instances of Joinable which are actually also instances of PersistentCollection which are being fetched by outer join

Throws:
MappingException

orderBy

protected static final String orderBy(List associations)
                               throws MappingException
Get the order by string required for collection fetching

Throws:
MappingException

whereString

protected StringBuffer whereString(String alias,
                                   String[] columnNames,
                                   int batchSize)
Render the where condition for a (batch) load by identifier / collection key

initPersisters

protected void initPersisters(List associations,
                              LockMode lockMode)
                       throws MappingException
Throws:
MappingException

selectString

protected final String selectString(List associations)
                             throws MappingException
Generate a select list of columns containing all properties of the entity classes

Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Loader (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader
Class Loader

java.lang.Object
    extended by org.hibernate.loader.Loader
Direct Known Subclasses:
BasicLoader, CustomLoader
public abstract class Loader
extends Object

Abstract superclass of object loading (and querying) strategies. This class implements useful common functionality that concrete loaders delegate to. It is not intended that this functionality would be directly accessed by client code. (Hence, all methods of this class are declared protected or private.) This class relies heavily upon the Loadable interface, which is the contract between this class and EntityPersisters that may be loaded by it.

The present implementation is able to load any number of columns of entities and at most one collection role per query.

Author:
Gavin King
See Also:
Loadable

Constructor Summary
Loader(SessionFactoryImplementor factory)
Method Summary
protected String | applyLocks(String sql, Map lockModes, Dialect dialect) Append FOR UPDATE OF clause, if necessary.
protected void | autoDiscoverTypes(ResultSet rs)
protected int | bindNamedParameters(PreparedStatement ps, Map namedParams, int start, SessionImplementor session) Bind named parameters to the PreparedStatement.
protected int | bindPositionalParameters(PreparedStatement st, QueryParameters queryParameters, int start, SessionImplementor session) Bind positional parameter values to the PreparedStatement (these are parameters specified by a JDBC-style ?).
protected void | checkScrollability() Check whether the current loader can support returning ScrollableResults.
protected List | doList(SessionImplementor session, QueryParameters queryParameters) Actually execute a query, ignoring the query cache
protected String[] | getAliases() Get the SQL table aliases of entities whose associations are subselect-loadable, returning null if this loader does not support subselect loading
protected abstract CollectionAliases[] | getCollectionAliases()
protected int[] | getCollectionOwners() Get the index of the entity that owns the collection, or -1 if there is no owner in the query results (ie.
protected CollectionPersister[] | getCollectionPersisters() An (optional) persister for a collection to be initialized; only collection loaders return a non-null value
protected abstract EntityAliases[] | getEntityAliases() Get the result set descriptor
protected boolean[] | getEntityEagerPropertyFetches() An array indicating whether the entities have eager property fetching enabled
protected abstract Loadable[] | getEntityPersisters() An array of persisters of entity classes contained in each row of results; implemented by all subclasses
SessionFactoryImplementor | getFactory()
protected abstract LockMode[] | getLockModes(Map lockModes) What lock mode does this load entities with?
int[] | getNamedParameterLocs(String name)
protected EntityType[] | getOwnerAssociationTypes() An array of unique key property names by which the corresponding entities are referenced by other entities in the result set
protected int[] | getOwners() An array of indexes of the entity that owns a one-to-one association to the entity at the given index (-1 if there is no "owner")
protected String | getQueryIdentifier() Identifies the query for statistics reporting, if null, no statistics will be reported
protected Object | getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session) Get the actual object that is returned in the user-visible result list.
protected List | getResultList(List results, ResultTransformer resultTransformer)
protected ResultSet | getResultSet(PreparedStatement st, boolean autodiscovertypes, boolean callable, RowSelection selection, SessionImplementor session) Fetch a PreparedStatement, call setMaxRows and then execute it, advance to the first result and return an SQL ResultSet
protected abstract String | getSQLString() The SQL query string to be called; implemented by all subclasses
protected boolean | hasSubselectLoadableCollections()
protected boolean | isSingleRowLoader() Return false is this loader is a batch entity loader
protected boolean | isSubselectLoadingEnabled()
protected List | list(SessionImplementor session, QueryParameters queryParameters, Set querySpaces, Type[] resultTypes) Return the query results, using the query cache, called by subclasses that implement cacheable queries
void | loadCollection(SessionImplementor session, Serializable id, Type type) Called by subclasses that initialize collections
void | loadCollectionBatch(SessionImplementor session, Serializable[] ids, Type type) Called by wrappers that batch initialize collections
protected void | loadCollectionSubselect(SessionImplementor session, Serializable[] ids, Object[] parameterValues, Type[] parameterTypes, Map namedParameters, Type type) Called by subclasses that batch initialize collections
protected List | loadEntity(SessionImplementor session, Object key, Object index, Type keyType, Type indexType, EntityPersister persister) Called by subclasses that load entities
protected List | loadEntity(SessionImplementor session, Object id, Type identifierType, Object optionalObject, String optionalEntityName, Serializable optionalIdentifier, EntityPersister persister) Called by subclasses that load entities
List | loadEntityBatch(SessionImplementor session, Serializable[] ids, Type idType, Object optionalObject, String optionalEntityName, Serializable optionalId, EntityPersister persister) Called by wrappers that batch load entities
Object | loadSequentialRowsForward(ResultSet resultSet, SessionImplementor session, QueryParameters queryParameters, boolean returnProxies) Loads a single logical row from the result set moving forward.
Object | loadSequentialRowsReverse(ResultSet resultSet, SessionImplementor session, QueryParameters queryParameters, boolean returnProxies, boolean isLogicallyAfterLast) Loads a single logical row from the result set moving forward.
Object | loadSingleRow(ResultSet resultSet, SessionImplementor session, QueryParameters queryParameters, boolean returnProxies) Loads a single row from the result set.
protected boolean | needsFetchingScroll() Does the result set to be scrolled contain collection fetches?
protected void | postInstantiate() Calculate and cache select-clause suffixes.
protected PreparedStatement | prepareQueryStatement(QueryParameters queryParameters, boolean scroll, SessionImplementor session) Obtain a PreparedStatement with all parameters pre-bound.
protected String | preprocessSQL(String sql, QueryParameters parameters, Dialect dialect) Modify the SQL, adding lock hints and comments, if necessary
protected ScrollableResults | scroll(QueryParameters queryParameters, Type[] returnTypes, HolderInstantiator holderInstantiator, SessionImplementor session) Return the query results, as an instance of ScrollableResults
String | toString()
protected boolean | upgradeLocks() Does this query return objects that might be already cached by the session, whose lock mode may need upgrading
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Loader

public Loader(SessionFactoryImplementor factory)
Method Detail

getSQLString

protected abstract String getSQLString()
The SQL query string to be called; implemented by all subclasses

getEntityPersisters

protected abstract Loadable[] getEntityPersisters()
An array of persisters of entity classes contained in each row of results; implemented by all subclasses

getEntityEagerPropertyFetches

protected boolean[] getEntityEagerPropertyFetches()
An array indicating whether the entities have eager property fetching enabled

getOwners

protected int[] getOwners()
An array of indexes of the entity that owns a one-to-one association to the entity at the given index (-1 if there is no "owner")

getOwnerAssociationTypes

protected EntityType[] getOwnerAssociationTypes()
An array of unique key property names by which the corresponding entities are referenced by other entities in the result set

getCollectionPersisters

protected CollectionPersister[] getCollectionPersisters()
An (optional) persister for a collection to be initialized; only collection loaders return a non-null value

getCollectionOwners

protected int[] getCollectionOwners()
Get the index of the entity that owns the collection, or -1 if there is no owner in the query results (ie. in the case of a collection initializer) or no collection.

getLockModes

protected abstract LockMode[] getLockModes(Map lockModes)
What lock mode does this load entities with?

Parameters:
lockModes - a collection of lock modes specified dynamically via the Query interface

applyLocks

protected String applyLocks(String sql,
                            Map lockModes,
                            Dialect dialect)
                     throws HibernateException
Append FOR UPDATE OF clause, if necessary. This empty superclass implementation merely returns its first argument.

Throws:
HibernateException

upgradeLocks

protected boolean upgradeLocks()
Does this query return objects that might be already cached by the session, whose lock mode may need upgrading

isSingleRowLoader

protected boolean isSingleRowLoader()
Return false is this loader is a batch entity loader

getAliases

protected String[] getAliases()
Get the SQL table aliases of entities whose associations are subselect-loadable, returning null if this loader does not support subselect loading

preprocessSQL

protected String preprocessSQL(String sql,
                               QueryParameters parameters,
                               Dialect dialect)
                        throws HibernateException
Modify the SQL, adding lock hints and comments, if necessary

Throws:
HibernateException

loadSingleRow

public Object loadSingleRow(ResultSet resultSet,
                            SessionImplementor session,
                            QueryParameters queryParameters,
                            boolean returnProxies)
                     throws HibernateException
Loads a single row from the result set. This is the processing used from the ScrollableResults where no collection fetches were encountered.

Parameters:
resultSet - The result set from which to do the load.
session - The session from which the request originated.
queryParameters - The query parameters specified by the user.
returnProxies - Should proxies be generated
Returns:
The loaded "row".
Throws:
HibernateException

loadSequentialRowsForward

public Object loadSequentialRowsForward(ResultSet resultSet,
                                        SessionImplementor session,
                                        QueryParameters queryParameters,
                                        boolean returnProxies)
                                 throws HibernateException
Loads a single logical row from the result set moving forward. This is the processing used from the ScrollableResults where there were collection fetches encountered; thus a single logical row may have multiple rows in the underlying result set.

Parameters:
resultSet - The result set from which to do the load.
session - The session from which the request originated.
queryParameters - The query parameters specified by the user.
returnProxies - Should proxies be generated
Returns:
The loaded "row".
Throws:
HibernateException

loadSequentialRowsReverse

public Object loadSequentialRowsReverse(ResultSet resultSet,
                                        SessionImplementor session,
                                        QueryParameters queryParameters,
                                        boolean returnProxies,
                                        boolean isLogicallyAfterLast)
                                 throws HibernateException
Loads a single logical row from the result set moving forward. This is the processing used from the ScrollableResults where there were collection fetches encountered; thus a single logical row may have multiple rows in the underlying result set.

Parameters:
resultSet - The result set from which to do the load.
session - The session from which the request originated.
queryParameters - The query parameters specified by the user.
returnProxies - Should proxies be generated
Returns:
The loaded "row".
Throws:
HibernateException

isSubselectLoadingEnabled

protected boolean isSubselectLoadingEnabled()

hasSubselectLoadableCollections

protected boolean hasSubselectLoadableCollections()

getResultList

protected List getResultList(List results,
                             ResultTransformer resultTransformer)
                      throws QueryException
Throws:
QueryException

getResultColumnOrRow

protected Object getResultColumnOrRow(Object[] row,
                                      ResultTransformer transformer,
                                      ResultSet rs,
                                      SessionImplementor session)
                               throws SQLException,
                                      HibernateException
Get the actual object that is returned in the user-visible result list. This empty implementation merely returns its first argument. This is overridden by some subclasses.

Throws:
SQLException
HibernateException

bindPositionalParameters

protected int bindPositionalParameters(PreparedStatement st,
                                       QueryParameters queryParameters,
                                       int start,
                                       SessionImplementor session)
                                throws SQLException,
                                       HibernateException
Bind positional parameter values to the PreparedStatement (these are parameters specified by a JDBC-style ?).

Throws:
SQLException
HibernateException

prepareQueryStatement

protected final PreparedStatement prepareQueryStatement(QueryParameters queryParameters,
                                                        boolean scroll,
                                                        SessionImplementor session)
                                                 throws SQLException,
                                                        HibernateException
Obtain a PreparedStatement with all parameters pre-bound. Bind JDBC-style ? parameters, named parameters, and limit parameters.

Throws:
SQLException
HibernateException

getResultSet

protected final ResultSet getResultSet(PreparedStatement st,
                                       boolean autodiscovertypes,
                                       boolean callable,
                                       RowSelection selection,
                                       SessionImplementor session)
                                throws SQLException,
                                       HibernateException
Fetch a PreparedStatement, call setMaxRows and then execute it, advance to the first result and return an SQL ResultSet

Throws:
SQLException
HibernateException

autoDiscoverTypes

protected void autoDiscoverTypes(ResultSet rs)

bindNamedParameters

protected int bindNamedParameters(PreparedStatement ps,
                                  Map namedParams,
                                  int start,
                                  SessionImplementor session)
                           throws SQLException,
                                  HibernateException
Bind named parameters to the PreparedStatement. This has an empty implementation on this superclass and should be implemented by subclasses (queries) which allow named parameters.

Throws:
SQLException
HibernateException

getNamedParameterLocs

public int[] getNamedParameterLocs(String name)

loadEntity

protected final List loadEntity(SessionImplementor session,
                                Object id,
                                Type identifierType,
                                Object optionalObject,
                                String optionalEntityName,
                                Serializable optionalIdentifier,
                                EntityPersister persister)
                         throws HibernateException
Called by subclasses that load entities

Parameters:
persister - only needed for logging
Throws:
HibernateException

loadEntity

protected final List loadEntity(SessionImplementor session,
                                Object key,
                                Object index,
                                Type keyType,
                                Type indexType,
                                EntityPersister persister)
                         throws HibernateException
Called by subclasses that load entities

Parameters:
persister - only needed for logging
Throws:
HibernateException

loadEntityBatch

public final List loadEntityBatch(SessionImplementor session,
                                  Serializable[] ids,
                                  Type idType,
                                  Object optionalObject,
                                  String optionalEntityName,
                                  Serializable optionalId,
                                  EntityPersister persister)
                           throws HibernateException
Called by wrappers that batch load entities

Parameters:
persister - only needed for logging
Throws:
HibernateException

loadCollection

public final void loadCollection(SessionImplementor session,
                                 Serializable id,
                                 Type type)
                          throws HibernateException
Called by subclasses that initialize collections

Throws:
HibernateException

loadCollectionBatch

public final void loadCollectionBatch(SessionImplementor session,
                                      Serializable[] ids,
                                      Type type)
                               throws HibernateException
Called by wrappers that batch initialize collections

Throws:
HibernateException

loadCollectionSubselect

protected final void loadCollectionSubselect(SessionImplementor session,
                                             Serializable[] ids,
                                             Object[] parameterValues,
                                             Type[] parameterTypes,
                                             Map namedParameters,
                                             Type type)
                                      throws HibernateException
Called by subclasses that batch initialize collections

Throws:
HibernateException

list

protected List list(SessionImplementor session,
                    QueryParameters queryParameters,
                    Set querySpaces,
                    Type[] resultTypes)
             throws HibernateException
Return the query results, using the query cache, called by subclasses that implement cacheable queries

Throws:
HibernateException

doList

protected List doList(SessionImplementor session,
                      QueryParameters queryParameters)
               throws HibernateException
Actually execute a query, ignoring the query cache

Throws:
HibernateException

checkScrollability

protected void checkScrollability()
                           throws HibernateException
Check whether the current loader can support returning ScrollableResults.

Throws:
HibernateException

needsFetchingScroll

protected boolean needsFetchingScroll()
Does the result set to be scrolled contain collection fetches?

Returns:
True if it does, and thus needs the special fetching scroll functionality; false otherwise.

scroll

protected ScrollableResults scroll(QueryParameters queryParameters,
                                   Type[] returnTypes,
                                   HolderInstantiator holderInstantiator,
                                   SessionImplementor session)
                            throws HibernateException
Return the query results, as an instance of ScrollableResults

Parameters:
queryParameters - The parameters with which the query should be executed.
returnTypes - The expected return types of the query
holderInstantiator - If the return values are expected to be wrapped in a holder, this is the thing that knows how to wrap them.
session - The session from which the scroll request originated.
Returns:
The ScrollableResults instance.
Throws:
HibernateException - Indicates an error executing the query, or constructing the ScrollableResults.

postInstantiate

protected void postInstantiate()
Calculate and cache select-clause suffixes. Must be called by subclasses after instantiation.

getEntityAliases

protected abstract EntityAliases[] getEntityAliases()
Get the result set descriptor

getCollectionAliases

protected abstract CollectionAliases[] getCollectionAliases()

getQueryIdentifier

protected String getQueryIdentifier()
Identifies the query for statistics reporting, if null, no statistics will be reported

getFactory

public final SessionFactoryImplementor getFactory()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OuterJoinableAssociation (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader
Class OuterJoinableAssociation

java.lang.Object
    extended by org.hibernate.loader.OuterJoinableAssociation
public final class OuterJoinableAssociation
extends Object

Constructor Summary
OuterJoinableAssociation(AssociationType joinableType, String lhsAlias, String[] lhsColumns, String rhsAlias, int joinType, SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
void | addJoins(JoinFragment outerjoin)
void | addManyToManyJoin(JoinFragment outerjoin, QueryableCollection collection)
Joinable | getJoinable()
AssociationType | getJoinableType()
int | getJoinType()
int | getOwner(List associations)
String | getRHSAlias()
String | getRHSUniqueKeyName()
boolean | isCollection()
boolean | isManyToManyWith(OuterJoinableAssociation other)
void | validateJoin(String path)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OuterJoinableAssociation

public OuterJoinableAssociation(AssociationType joinableType,
                                String lhsAlias,
                                String[] lhsColumns,
                                String rhsAlias,
                                int joinType,
                                SessionFactoryImplementor factory,
                                Map enabledFilters)
                         throws MappingException
Method Detail

getJoinType

public int getJoinType()

getRHSAlias

public String getRHSAlias()

getJoinableType

public AssociationType getJoinableType()

getRHSUniqueKeyName

public String getRHSUniqueKeyName()

isCollection

public boolean isCollection()

getJoinable

public Joinable getJoinable()

getOwner

public int getOwner(List associations)

addJoins

public void addJoins(JoinFragment outerjoin)
              throws MappingException
Throws:
MappingException

validateJoin

public void validateJoin(String path)
                  throws MappingException
Throws:
MappingException

isManyToManyWith

public boolean isManyToManyWith(OuterJoinableAssociation other)

addManyToManyJoin

public void addManyToManyJoin(JoinFragment outerjoin,
                              QueryableCollection collection)
                       throws MappingException
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OuterJoinLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader
Class OuterJoinLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.loader.OuterJoinLoader
Direct Known Subclasses:
AbstractEntityLoader, CollectionElementLoader, CollectionLoader, CriteriaLoader
public abstract class OuterJoinLoader
extends BasicLoader

Implements logic for walking a tree of associated classes. Generates an SQL select string containing all properties of those classes. Tables are joined using an ANSI-style left outer join.

Author:
Gavin King

Field Summary
protected String[] | aliases
protected int[] | collectionOwners
protected CollectionPersister[] | collectionPersisters
protected String[] | collectionSuffixes
protected LockMode[] | lockModeArray
protected EntityType[] | ownerAssociationTypes
protected int[] | owners
protected Loadable[] | persisters
protected String | sql
protected String[] | suffixes
Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX
Constructor Summary
OuterJoinLoader(SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
protected String[] | getAliases() Get the SQL table aliases of entities whose associations are subselect-loadable, returning null if this loader does not support subselect loading
protected int[] | getCollectionOwners() Get the index of the entity that owns the collection, or -1 if there is no owner in the query results (ie.
protected CollectionPersister[] | getCollectionPersisters() An (optional) persister for a collection to be initialized; only collection loaders return a non-null value
protected String[] | getCollectionSuffixes()
protected Dialect | getDialect()
Map | getEnabledFilters()
protected Loadable[] | getEntityPersisters() An array of persisters of entity classes contained in each row of results; implemented by all subclasses
protected LockMode[] | getLockModes(Map lockModes) What lock mode does this load entities with?
protected EntityType[] | getOwnerAssociationTypes() An array of unique key property names by which the corresponding entities are referenced by other entities in the result set
protected int[] | getOwners() An array of indexes of the entity that owns a one-to-one association to the entity at the given index (-1 if there is no "owner")
protected String | getSQLString() The SQL query string to be called; implemented by all subclasses
protected String[] | getSuffixes()
protected void | initFromWalker(JoinWalker walker)
Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate
Methods inherited from class org.hibernate.loader.Loader
applyLocks, autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getEntityEagerPropertyFetches, getFactory, getNamedParameterLocs, getQueryIdentifier, getResultColumnOrRow, getResultList, getResultSet, hasSubselectLoadableCollections, isSingleRowLoader, isSubselectLoadingEnabled, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll, toString, upgradeLocks
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

persisters

protected Loadable[] persisters

collectionPersisters

protected CollectionPersister[] collectionPersisters

collectionOwners

protected int[] collectionOwners

aliases

protected String[] aliases

lockModeArray

protected LockMode[] lockModeArray

owners

protected int[] owners

ownerAssociationTypes

protected EntityType[] ownerAssociationTypes

sql

protected String sql

suffixes

protected String[] suffixes

collectionSuffixes

protected String[] collectionSuffixes
Constructor Detail

OuterJoinLoader

public OuterJoinLoader(SessionFactoryImplementor factory,
                       Map enabledFilters)
Method Detail

getDialect

protected final Dialect getDialect()

getSuffixes

protected String[] getSuffixes()
Specified by:
getSuffixes in class BasicLoader

getCollectionSuffixes

protected String[] getCollectionSuffixes()
Specified by:
getCollectionSuffixes in class BasicLoader

getSQLString

protected final String getSQLString()
Description copied from class: Loader
The SQL query string to be called; implemented by all subclasses

Specified by:
getSQLString in class Loader

getEntityPersisters

protected final Loadable[] getEntityPersisters()
Description copied from class: Loader
An array of persisters of entity classes contained in each row of results; implemented by all subclasses

Specified by:
getEntityPersisters in class Loader

getOwners

protected int[] getOwners()
Description copied from class: Loader
An array of indexes of the entity that owns a one-to-one association to the entity at the given index (-1 if there is no "owner")

Overrides:
getOwners in class Loader

getOwnerAssociationTypes

protected EntityType[] getOwnerAssociationTypes()
Description copied from class: Loader
An array of unique key property names by which the corresponding entities are referenced by other entities in the result set

Overrides:
getOwnerAssociationTypes in class Loader

getLockModes

protected LockMode[] getLockModes(Map lockModes)
Description copied from class: Loader
What lock mode does this load entities with?

Specified by:
getLockModes in class Loader
Parameters:
lockModes - a collection of lock modes specified dynamically via the Query interface

getEnabledFilters

public Map getEnabledFilters()

getAliases

protected final String[] getAliases()
Description copied from class: Loader
Get the SQL table aliases of entities whose associations are subselect-loadable, returning null if this loader does not support subselect loading

Overrides:
getAliases in class Loader

getCollectionPersisters

protected final CollectionPersister[] getCollectionPersisters()
Description copied from class: Loader
An (optional) persister for a collection to be initialized; only collection loaders return a non-null value

Overrides:
getCollectionPersisters in class Loader

getCollectionOwners

protected final int[] getCollectionOwners()
Description copied from class: Loader
Get the index of the entity that owns the collection, or -1 if there is no owner in the query results (ie. in the case of a collection initializer) or no collection.

Overrides:
getCollectionOwners in class Loader

initFromWalker

protected void initFromWalker(JoinWalker walker)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.loader.collection (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.loader.collection

This package defines collection initializers

See:
Description

Interface Summary
CollectionInitializer An interface for collection loaders

Class Summary
BasicCollectionJoinWalker | Walker for collections of values and many-to-many associations
BasicCollectionLoader | Loads a collection of values or a many-to-many association.
BatchingCollectionInitializer | "Batch" loads collections, using multiple foreign key values in the SQL where clause.
CollectionJoinWalker | Superclass of walkers for collection initializers
CollectionLoader | Superclass for loaders that initialize collections
OneToManyJoinWalker | Walker for one-to-many associations
OneToManyLoader | Loads one-to-many associations The collection persister must implement QueryableCOllection.
SubselectCollectionLoader | Implements subselect fetching for a collection
SubselectOneToManyLoader | Implements subselect fetching for a one to many association

Package org.hibernate.loader.collection Description

This package defines collection initializers


org.hibernate.loader.collection Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.loader.collection

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.loader.collection.BatchingCollectionInitializer (implements org.hibernate.loader.collection.CollectionInitializer)
    • class org.hibernate.loader.JoinWalker
      • class org.hibernate.loader.collection.CollectionJoinWalker
        • class org.hibernate.loader.collection.BasicCollectionJoinWalker
        • class org.hibernate.loader.collection.OneToManyJoinWalker
    • class org.hibernate.loader.Loader
      • class org.hibernate.loader.BasicLoader
        • class org.hibernate.loader.OuterJoinLoader
          • class org.hibernate.loader.collection.CollectionLoader (implements org.hibernate.loader.collection.CollectionInitializer)
            • class org.hibernate.loader.collection.BasicCollectionLoader
              • class org.hibernate.loader.collection.SubselectCollectionLoader
            • class org.hibernate.loader.collection.OneToManyLoader
              • class org.hibernate.loader.collection.SubselectOneToManyLoader

Interface Hierarchy

  • interface org.hibernate.loader.collection.CollectionInitializer


Uses of Package org.hibernate.loader.collection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.loader.collection

Packages that use org.hibernate.loader.collection
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.

Classes in org.hibernate.loader.collection used by org.hibernate.loader.collection
BasicCollectionLoader
Loads a collection of values or a many-to-many association.
CollectionInitializer
An interface for collection loaders
CollectionJoinWalker
Superclass of walkers for collection initializers
CollectionLoader
Superclass for loaders that initialize collections
OneToManyLoader
Loads one-to-many associations

The collection persister must implement QueryableCOllection.

Classes in org.hibernate.loader.collection used by org.hibernate.persister.collection
CollectionInitializer
An interface for collection loaders

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CollectionInitializer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.collection
Interface CollectionInitializer

All Known Implementing Classes:
BatchingCollectionInitializer, CollectionLoader, NamedQueryCollectionInitializer
public interface CollectionInitializer

An interface for collection loaders

Author:
Gavin King
See Also:
BasicCollectionLoader, OneToManyLoader

Method Summary
 void initialize(Serializable id, SessionImplementor session)
Initialize the given collection

Method Detail

initialize

public void initialize(Serializable id,
                       SessionImplementor session)
                throws HibernateException
Initialize the given collection

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BasicCollectionJoinWalker (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.collection
Class BasicCollectionJoinWalker

java.lang.Object
    extended by org.hibernate.loader.JoinWalker
        extended by org.hibernate.loader.collection.CollectionJoinWalker
            extended by org.hibernate.loader.collection.BasicCollectionJoinWalker
public class BasicCollectionJoinWalker
extends CollectionJoinWalker

Walker for collections of values and many-to-many associations

Author:
Gavin King
See Also:
BasicCollectionLoader

Field Summary
Fields inherited from class org.hibernate.loader.JoinWalker
aliases, associations, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Constructor Summary
BasicCollectionJoinWalker(QueryableCollection collectionPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
protected int | getJoinType(AssociationType type, FetchMode config, String path, Set visitedAssociations, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth) We can use an inner join for first many-to-many association
String | toString()
Methods inherited from class org.hibernate.loader.collection.CollectionJoinWalker
whereString
Methods inherited from class org.hibernate.loader.JoinWalker
countCollectionPersisters, countEntityPersisters, generateRootAlias, generateTableAlias, getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getFactory, getJoinType, getJoinType, getLockModeArray, getOwnerAssociationTypes, getOwners, getPersisters, getSQLString, getSuffixes, initPersisters, isDuplicateAssociation, isDuplicateAssociation, isJoinable, isJoinedFetchEnabled, isJoinedFetchEnabledInMapping, isTooDeep, isTooManyCollections, mergeOrderings, mergeOuterJoins, orderBy, orderBy, selectString, setAliases, setCollectionOwners, setCollectionPersisters, setCollectionSuffixes, setLockModeArray, setOwnerAssociationTypes, setOwners, setPersisters, setSql, setSuffixes, walkCollectionTree, walkEntityTree, whereString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BasicCollectionJoinWalker

public BasicCollectionJoinWalker(QueryableCollection collectionPersister,
                                 int batchSize,
                                 String subquery,
                                 SessionFactoryImplementor factory,
                                 Map enabledFilters)
                          throws MappingException
Method Detail

getJoinType

protected int getJoinType(AssociationType type,
                          FetchMode config,
                          String path,
                          Set visitedAssociations,
                          String lhsTable,
                          String[] lhsColumns,
                          boolean nullable,
                          int currentDepth)
                   throws MappingException
We can use an inner join for first many-to-many association

Throws:
MappingException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BasicCollectionLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.collection
Class BasicCollectionLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.loader.OuterJoinLoader
                extended by org.hibernate.loader.collection.CollectionLoader
                    extended by org.hibernate.loader.collection.BasicCollectionLoader
All Implemented Interfaces:
CollectionInitializer
Direct Known Subclasses:
SubselectCollectionLoader
public class BasicCollectionLoader
extends CollectionLoader

Loads a collection of values or a many-to-many association.
The collection persister must implement QueryableCOllection. For other collections, create a customized subclass of Loader.

Author:
Gavin King
See Also:
OneToManyLoader

Field Summary

Fields inherited from class org.hibernate.loader.OuterJoinLoader
aliases, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes

Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX

Constructor Summary
 | BasicCollectionLoader(QueryableCollection collectionPersister, int batchSize, SessionFactoryImplementor factory, Map enabledFilters)
protected | BasicCollectionLoader(QueryableCollection collectionPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)
 | BasicCollectionLoader(QueryableCollection collectionPersister, SessionFactoryImplementor session, Map enabledFilters)

Methods inherited from class org.hibernate.loader.collection.CollectionLoader
getKeyType, initialize, isSubselectLoadingEnabled, toString

Methods inherited from class org.hibernate.loader.OuterJoinLoader
getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getEntityPersisters, getLockModes, getOwnerAssociationTypes, getOwners, getSQLString, getSuffixes, initFromWalker

Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate

Methods inherited from class org.hibernate.loader.Loader
applyLocks, autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getEntityEagerPropertyFetches, getFactory, getNamedParameterLocs, getQueryIdentifier, getResultColumnOrRow, getResultList, getResultSet, hasSubselectLoadableCollections, isSingleRowLoader, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll, upgradeLocks

Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BasicCollectionLoader

public BasicCollectionLoader(QueryableCollection collectionPersister,
                             SessionFactoryImplementor session,
                             Map enabledFilters)
                      throws MappingException

BasicCollectionLoader

public BasicCollectionLoader(QueryableCollection collectionPersister,
                             int batchSize,
                             SessionFactoryImplementor factory,
                             Map enabledFilters)
                      throws MappingException

BasicCollectionLoader

protected BasicCollectionLoader(QueryableCollection collectionPersister,
                                int batchSize,
                                String subquery,
                                SessionFactoryImplementor factory,
                                Map enabledFilters)
                         throws MappingException
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BatchingCollectionInitializer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.collection
Class BatchingCollectionInitializer

java.lang.Object
    extended by org.hibernate.loader.collection.BatchingCollectionInitializer
All Implemented Interfaces:
CollectionInitializer
public class BatchingCollectionInitializer
extends Object
implements CollectionInitializer

"Batch" loads collections, using multiple foreign key values in the SQL where clause.

Author:
Gavin King
See Also:
BasicCollectionLoader, OneToManyLoader

Constructor Summary
BatchingCollectionInitializer(CollectionPersister collPersister, int[] batchSizes, Loader[] loaders)
Method Summary
static CollectionInitializer | createBatchingCollectionInitializer(QueryableCollection persister, int maxBatchSize, SessionFactoryImplementor factory, Map enabledFilters)
static CollectionInitializer | createBatchingOneToManyInitializer(QueryableCollection persister, int maxBatchSize, SessionFactoryImplementor factory, Map enabledFilters)
void | initialize(Serializable id, SessionImplementor session) Initialize the given collection
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BatchingCollectionInitializer

public BatchingCollectionInitializer(CollectionPersister collPersister,
                                     int[] batchSizes,
                                     Loader[] loaders)
Method Detail

initialize

public void initialize(Serializable id,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: CollectionInitializer
Initialize the given collection

Specified by:
initialize in interface CollectionInitializer
Throws:
HibernateException

createBatchingOneToManyInitializer

public static CollectionInitializer createBatchingOneToManyInitializer(QueryableCollection persister,
                                                                       int maxBatchSize,
                                                                       SessionFactoryImplementor factory,
                                                                       Map enabledFilters)
                                                                throws MappingException
Throws:
MappingException

createBatchingCollectionInitializer

public static CollectionInitializer createBatchingCollectionInitializer(QueryableCollection persister,
                                                                        int maxBatchSize,
                                                                        SessionFactoryImplementor factory,
                                                                        Map enabledFilters)
                                                                 throws MappingException
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionJoinWalker (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.collection
Class CollectionJoinWalker

java.lang.Object
    extended by org.hibernate.loader.JoinWalker
        extended by org.hibernate.loader.collection.CollectionJoinWalker
Direct Known Subclasses:
BasicCollectionJoinWalker, OneToManyJoinWalker
public abstract class CollectionJoinWalker
extends JoinWalker

Superclass of walkers for collection initializers

Author:
Gavin King
See Also:
CollectionLoader, OneToManyJoinWalker, BasicCollectionJoinWalker

Field Summary
Fields inherited from class org.hibernate.loader.JoinWalker
aliases, associations, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Constructor Summary
CollectionJoinWalker(SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
protected  StringBuffer whereString(String alias, String[] columnNames, String subselect, int batchSize)
Methods inherited from class org.hibernate.loader.JoinWalker
countCollectionPersisters, countEntityPersisters, generateRootAlias, generateTableAlias, getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getFactory, getJoinType, getJoinType, getLockModeArray, getOwnerAssociationTypes, getOwners, getPersisters, getSQLString, getSuffixes, initPersisters, isDuplicateAssociation, isDuplicateAssociation, isJoinable, isJoinedFetchEnabled, isJoinedFetchEnabledInMapping, isTooDeep, isTooManyCollections, mergeOrderings, mergeOuterJoins, orderBy, orderBy, selectString, setAliases, setCollectionOwners, setCollectionPersisters, setCollectionSuffixes, setLockModeArray, setOwnerAssociationTypes, setOwners, setPersisters, setSql, setSuffixes, walkCollectionTree, walkEntityTree, whereString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CollectionJoinWalker

public CollectionJoinWalker(SessionFactoryImplementor factory,
                            Map enabledFilters)
Method Detail

whereString

protected StringBuffer whereString(String alias,
                                   String[] columnNames,
                                   String subselect,
                                   int batchSize)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.collection
Class CollectionLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.loader.OuterJoinLoader
                extended by org.hibernate.loader.collection.CollectionLoader
All Implemented Interfaces:
CollectionInitializer
Direct Known Subclasses:
BasicCollectionLoader, OneToManyLoader
public class CollectionLoader
extends OuterJoinLoader
implements CollectionInitializer

Superclass for loaders that initialize collections

Author:
Gavin King
See Also:
OneToManyLoader, BasicCollectionLoader

Field Summary
Fields inherited from class org.hibernate.loader.OuterJoinLoader
aliases, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX
Constructor Summary
CollectionLoader(QueryableCollection collectionPersister, SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
protected Type | getKeyType()
void | initialize(Serializable id, SessionImplementor session) Initialize the given collection
protected boolean | isSubselectLoadingEnabled()
String | toString()
Methods inherited from class org.hibernate.loader.OuterJoinLoader
getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getEntityPersisters, getLockModes, getOwnerAssociationTypes, getOwners, getSQLString, getSuffixes, initFromWalker
Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate
Methods inherited from class org.hibernate.loader.Loader
applyLocks, autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getEntityEagerPropertyFetches, getFactory, getNamedParameterLocs, getQueryIdentifier, getResultColumnOrRow, getResultList, getResultSet, hasSubselectLoadableCollections, isSingleRowLoader, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll, upgradeLocks
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CollectionLoader

public CollectionLoader(QueryableCollection collectionPersister,
                        SessionFactoryImplementor factory,
                        Map enabledFilters)
Method Detail

isSubselectLoadingEnabled

protected boolean isSubselectLoadingEnabled()
Overrides:
isSubselectLoadingEnabled in class Loader

initialize

public void initialize(Serializable id,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: CollectionInitializer
Initialize the given collection

Specified by:
initialize in interface CollectionInitializer
Throws:
HibernateException

getKeyType

protected Type getKeyType()

toString

public String toString()
Overrides:
toString in class Loader
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OneToManyJoinWalker (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.collection
Class OneToManyJoinWalker

java.lang.Object
    extended by org.hibernate.loader.JoinWalker
        extended by org.hibernate.loader.collection.CollectionJoinWalker
            extended by org.hibernate.loader.collection.OneToManyJoinWalker
public class OneToManyJoinWalker
extends CollectionJoinWalker

Walker for one-to-many associations

Author:
Gavin King
See Also:
OneToManyLoader

Field Summary
Fields inherited from class org.hibernate.loader.JoinWalker
aliases, associations, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Constructor Summary
OneToManyJoinWalker(QueryableCollection oneToManyPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
protected boolean | isDuplicateAssociation(String foreignKeyTable, String[] foreignKeyColumns) Used to detect circularities in the joined graph, note that this method is side-effecty
String | toString()
Methods inherited from class org.hibernate.loader.collection.CollectionJoinWalker
whereString
Methods inherited from class org.hibernate.loader.JoinWalker
countCollectionPersisters, countEntityPersisters, generateRootAlias, generateTableAlias, getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getFactory, getJoinType, getJoinType, getLockModeArray, getOwnerAssociationTypes, getOwners, getPersisters, getSQLString, getSuffixes, initPersisters, isDuplicateAssociation, isJoinable, isJoinedFetchEnabled, isJoinedFetchEnabledInMapping, isTooDeep, isTooManyCollections, mergeOrderings, mergeOuterJoins, orderBy, orderBy, selectString, setAliases, setCollectionOwners, setCollectionPersisters, setCollectionSuffixes, setLockModeArray, setOwnerAssociationTypes, setOwners, setPersisters, setSql, setSuffixes, walkCollectionTree, walkEntityTree, whereString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OneToManyJoinWalker

public OneToManyJoinWalker(QueryableCollection oneToManyPersister,
                           int batchSize,
                           String subquery,
                           SessionFactoryImplementor factory,
                           Map enabledFilters)
                    throws MappingException
Method Detail

isDuplicateAssociation

protected boolean isDuplicateAssociation(String foreignKeyTable,
                                         String[] foreignKeyColumns)
Description copied from class: JoinWalker
Used to detect circularities in the joined graph, note that this method is side-effecty

Overrides:
isDuplicateAssociation in class JoinWalker

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OneToManyLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.collection
Class OneToManyLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.loader.OuterJoinLoader
                extended by org.hibernate.loader.collection.CollectionLoader
                    extended by org.hibernate.loader.collection.OneToManyLoader
All Implemented Interfaces:
CollectionInitializer
Direct Known Subclasses:
SubselectOneToManyLoader
public class OneToManyLoader
extends CollectionLoader

Loads one-to-many associations

The collection persister must implement QueryableCOllection. For other collections, create a customized subclass of Loader.

Author:
Gavin King
See Also:
BasicCollectionLoader

Field Summary

Fields inherited from class org.hibernate.loader.OuterJoinLoader
aliases, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes

Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX

Constructor Summary
OneToManyLoader(QueryableCollection oneToManyPersister, int batchSize, SessionFactoryImplementor factory, Map enabledFilters)

OneToManyLoader(QueryableCollection oneToManyPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)

OneToManyLoader(QueryableCollection oneToManyPersister, SessionFactoryImplementor session, Map enabledFilters)

Methods inherited from class org.hibernate.loader.collection.CollectionLoader
getKeyType, initialize, isSubselectLoadingEnabled, toString

Methods inherited from class org.hibernate.loader.OuterJoinLoader
getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getEntityPersisters, getLockModes, getOwnerAssociationTypes, getOwners, getSQLString, getSuffixes, initFromWalker

Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate

Methods inherited from class org.hibernate.loader.Loader
applyLocks, autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getEntityEagerPropertyFetches, getFactory, getNamedParameterLocs, getQueryIdentifier, getResultColumnOrRow, getResultList, getResultSet, hasSubselectLoadableCollections, isSingleRowLoader, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll, upgradeLocks

Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OneToManyLoader

public OneToManyLoader(QueryableCollection oneToManyPersister,
                       SessionFactoryImplementor session,
                       Map enabledFilters)
                throws MappingException

OneToManyLoader

public OneToManyLoader(QueryableCollection oneToManyPersister,
                       int batchSize,
                       SessionFactoryImplementor factory,
                       Map enabledFilters)
                throws MappingException

OneToManyLoader

public OneToManyLoader(QueryableCollection oneToManyPersister,
                       int batchSize,
                       String subquery,
                       SessionFactoryImplementor factory,
                       Map enabledFilters)
                throws MappingException
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubselectCollectionLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.collection
Class SubselectCollectionLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.loader.OuterJoinLoader
                extended by org.hibernate.loader.collection.CollectionLoader
                    extended by org.hibernate.loader.collection.BasicCollectionLoader
                        extended by org.hibernate.loader.collection.SubselectCollectionLoader
All Implemented Interfaces:
CollectionInitializer
public class SubselectCollectionLoader
extends BasicCollectionLoader

Implements subselect fetching for a collection

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.loader.OuterJoinLoader
aliases, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX
Constructor Summary
SubselectCollectionLoader(QueryableCollection persister, String subquery, Collection entityKeys, QueryParameters queryParameters, Map namedParameterLocMap, SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
int[] | getNamedParameterLocs(String name)
void | initialize(Serializable id, SessionImplementor session) Initialize the given collection
Methods inherited from class org.hibernate.loader.collection.CollectionLoader
getKeyType, isSubselectLoadingEnabled, toString
Methods inherited from class org.hibernate.loader.OuterJoinLoader
getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getEntityPersisters, getLockModes, getOwnerAssociationTypes, getOwners, getSQLString, getSuffixes, initFromWalker
Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate
Methods inherited from class org.hibernate.loader.Loader
applyLocks, autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getEntityEagerPropertyFetches, getFactory, getQueryIdentifier, getResultColumnOrRow, getResultList, getResultSet, hasSubselectLoadableCollections, isSingleRowLoader, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll, upgradeLocks
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SubselectCollectionLoader

public SubselectCollectionLoader(QueryableCollection persister,
                                 String subquery,
                                 Collection entityKeys,
                                 QueryParameters queryParameters,
                                 Map namedParameterLocMap,
                                 SessionFactoryImplementor factory,
                                 Map enabledFilters)
                          throws MappingException
Method Detail

initialize

public void initialize(Serializable id,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: CollectionInitializer
Initialize the given collection

Specified by:
initialize in interface CollectionInitializer
Overrides:
initialize in class CollectionLoader
Throws:
HibernateException

getNamedParameterLocs

public int[] getNamedParameterLocs(String name)
Overrides:
getNamedParameterLocs in class Loader
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubselectOneToManyLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.collection
Class SubselectOneToManyLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.loader.OuterJoinLoader
                extended by org.hibernate.loader.collection.CollectionLoader
                    extended by org.hibernate.loader.collection.OneToManyLoader
                        extended by org.hibernate.loader.collection.SubselectOneToManyLoader
All Implemented Interfaces:
CollectionInitializer
public class SubselectOneToManyLoader
extends OneToManyLoader

Implements subselect fetching for a one to many association

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.loader.OuterJoinLoader
aliases, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX
Constructor Summary
SubselectOneToManyLoader(QueryableCollection persister, String subquery, Collection entityKeys, QueryParameters queryParameters, Map namedParameterLocMap, SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
int[] | getNamedParameterLocs(String name)
void | initialize(Serializable id, SessionImplementor session) Initialize the given collection
Methods inherited from class org.hibernate.loader.collection.CollectionLoader
getKeyType, isSubselectLoadingEnabled, toString
Methods inherited from class org.hibernate.loader.OuterJoinLoader
getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getEntityPersisters, getLockModes, getOwnerAssociationTypes, getOwners, getSQLString, getSuffixes, initFromWalker
Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate
Methods inherited from class org.hibernate.loader.Loader
applyLocks, autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getEntityEagerPropertyFetches, getFactory, getQueryIdentifier, getResultColumnOrRow, getResultList, getResultSet, hasSubselectLoadableCollections, isSingleRowLoader, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll, upgradeLocks
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SubselectOneToManyLoader

public SubselectOneToManyLoader(QueryableCollection persister,
                                String subquery,
                                Collection entityKeys,
                                QueryParameters queryParameters,
                                Map namedParameterLocMap,
                                SessionFactoryImplementor factory,
                                Map enabledFilters)
                         throws MappingException
Method Detail

initialize

public void initialize(Serializable id,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: CollectionInitializer
Initialize the given collection

Specified by:
initialize in interface CollectionInitializer
Overrides:
initialize in class CollectionLoader
Throws:
HibernateException

getNamedParameterLocs

public int[] getNamedParameterLocs(String name)
Overrides:
getNamedParameterLocs in class Loader
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.loader.criteria (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.loader.criteria

This package defines the criteria query compiler and loader

See:
Description

Class Summary
CriteriaJoinWalker | A JoinWalker for Criteria queries.
CriteriaLoader | A Loader for Criteria queries.
CriteriaQueryTranslator |

Package org.hibernate.loader.criteria Description

This package defines the criteria query compiler and loader


org.hibernate.loader.criteria Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.loader.criteria

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.loader.criteria.CriteriaQueryTranslator (implements org.hibernate.criterion.CriteriaQuery)
    • class org.hibernate.loader.JoinWalker
      • class org.hibernate.loader.AbstractEntityJoinWalker
        • class org.hibernate.loader.criteria.CriteriaJoinWalker
    • class org.hibernate.loader.Loader
      • class org.hibernate.loader.BasicLoader
        • class org.hibernate.loader.OuterJoinLoader
          • class org.hibernate.loader.criteria.CriteriaLoader


Uses of Package org.hibernate.loader.criteria (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.loader.criteria

Packages that use org.hibernate.loader.criteria
org.hibernate.loader.criteria This package defines the criteria query compiler and loader

Classes in org.hibernate.loader.criteria used by org.hibernate.loader.criteria
CriteriaQueryTranslator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CriteriaJoinWalker (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.criteria
Class CriteriaJoinWalker

java.lang.Object
    extended by org.hibernate.loader.JoinWalker
        extended by org.hibernate.loader.AbstractEntityJoinWalker
            extended by org.hibernate.loader.criteria.CriteriaJoinWalker
public class CriteriaJoinWalker
extends AbstractEntityJoinWalker

A JoinWalker for Criteria queries.

Author:
Gavin King
See Also:
CriteriaLoader

Field Summary
Fields inherited from class org.hibernate.loader.JoinWalker
aliases, associations, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Constructor Summary
CriteriaJoinWalker(OuterJoinLoadable persister, CriteriaQueryTranslator translator, SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, Map enabledFilters)
Method Summary
protected String | generateRootAlias(String tableName)
protected String | generateTableAlias(int n, String path, Joinable joinable)
String | getComment()
protected int | getJoinType(AssociationType type, FetchMode config, String path, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth, CascadeStyle cascadeStyle) Get the join type (inner, outer, etc) or -1 if the association should not be joined.
Set | getQuerySpaces()
Type[] | getResultTypes()
String[] | getUserAliases()
protected String | getWhereFragment() Use the discriminator, to narrow the select to instances of the queried subclass, also applying any filters.
Methods inherited from class org.hibernate.loader.AbstractEntityJoinWalker
getAlias, getPersister, initAll, initProjection, isJoinedFetchEnabled, toString
Methods inherited from class org.hibernate.loader.JoinWalker
countCollectionPersisters, countEntityPersisters, getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getFactory, getJoinType, getLockModeArray, getOwnerAssociationTypes, getOwners, getPersisters, getSQLString, getSuffixes, initPersisters, isDuplicateAssociation, isDuplicateAssociation, isJoinable, isJoinedFetchEnabledInMapping, isTooDeep, isTooManyCollections, mergeOrderings, mergeOuterJoins, orderBy, orderBy, selectString, setAliases, setCollectionOwners, setCollectionPersisters, setCollectionSuffixes, setLockModeArray, setOwnerAssociationTypes, setOwners, setPersisters, setSql, setSuffixes, walkCollectionTree, walkEntityTree, whereString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CriteriaJoinWalker

public CriteriaJoinWalker(OuterJoinLoadable persister,
                          CriteriaQueryTranslator translator,
                          SessionFactoryImplementor factory,
                          CriteriaImpl criteria,
                          String rootEntityName,
                          Map enabledFilters)
                   throws HibernateException
Method Detail

getResultTypes

public Type[] getResultTypes()

getUserAliases

public String[] getUserAliases()

getJoinType

protected int getJoinType(AssociationType type,
                          FetchMode config,
                          String path,
                          String lhsTable,
                          String[] lhsColumns,
                          boolean nullable,
                          int currentDepth,
                          CascadeStyle cascadeStyle)
                   throws MappingException
Description copied from class: JoinWalker
Get the join type (inner, outer, etc) or -1 if the association should not be joined. Override on subclasses.

Overrides:
getJoinType in class JoinWalker
Throws:
MappingException

getWhereFragment

protected String getWhereFragment()
                           throws MappingException
Use the discriminator, to narrow the select to instances of the queried subclass, also applying any filters.

Overrides:
getWhereFragment in class AbstractEntityJoinWalker
Throws:
MappingException

generateTableAlias

protected String generateTableAlias(int n,
                                    String path,
                                    Joinable joinable)
Overrides:
generateTableAlias in class JoinWalker

generateRootAlias

protected String generateRootAlias(String tableName)
Overrides:
generateRootAlias in class JoinWalker

getQuerySpaces

public Set getQuerySpaces()

getComment

public String getComment()
Specified by:
getComment in class AbstractEntityJoinWalker
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CriteriaLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.criteria
Class CriteriaLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.loader.OuterJoinLoader
                extended by org.hibernate.loader.criteria.CriteriaLoader
public class CriteriaLoader
extends OuterJoinLoader

A Loader for Criteria queries. Note that criteria queries are more like multi-object load()s than like HQL queries.

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.loader.OuterJoinLoader
aliases, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX
Constructor Summary
CriteriaLoader(OuterJoinLoadable persister, SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, Map enabledFilters)
Method Summary
protected String | applyLocks(String sqlSelectString, Map lockModes, Dialect dialect) Append FOR UPDATE OF clause, if necessary.
protected LockMode[] | getLockModes(Map lockModes) What lock mode does this load entities with?
Set | getQuerySpaces()
protected Object | getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session) Get the actual object that is returned in the user-visible result list.
protected List | getResultList(List results, ResultTransformer resultTransformer)
protected boolean | isSubselectLoadingEnabled()
List | list(SessionImplementor session)
ScrollableResults | scroll(SessionImplementor session, ScrollMode scrollMode)
Methods inherited from class org.hibernate.loader.OuterJoinLoader
getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getEntityPersisters, getOwnerAssociationTypes, getOwners, getSQLString, getSuffixes, initFromWalker
Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate
Methods inherited from class org.hibernate.loader.Loader
autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getEntityEagerPropertyFetches, getFactory, getNamedParameterLocs, getQueryIdentifier, getResultSet, hasSubselectLoadableCollections, isSingleRowLoader, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll, toString, upgradeLocks
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CriteriaLoader

public CriteriaLoader(OuterJoinLoadable persister,
                      SessionFactoryImplementor factory,
                      CriteriaImpl criteria,
                      String rootEntityName,
                      Map enabledFilters)
               throws HibernateException
Method Detail

scroll

public ScrollableResults scroll(SessionImplementor session,
                                ScrollMode scrollMode)
                         throws HibernateException
Throws:
HibernateException

list

public List list(SessionImplementor session)
          throws HibernateException
Throws:
HibernateException

getResultColumnOrRow

protected Object getResultColumnOrRow(Object[] row,
                                      ResultTransformer transformer,
                                      ResultSet rs,
                                      SessionImplementor session)
                               throws SQLException,
                                      HibernateException
Description copied from class: Loader
Get the actual object that is returned in the user-visible result list. This empty implementation merely returns its first argument. This is overridden by some subclasses.

Overrides:
getResultColumnOrRow in class Loader
Throws:
SQLException
HibernateException

getQuerySpaces

public Set getQuerySpaces()

applyLocks

protected String applyLocks(String sqlSelectString,
                            Map lockModes,
                            Dialect dialect)
                     throws QueryException
Description copied from class: Loader
Append FOR UPDATE OF clause, if necessary. This empty superclass implementation merely returns its first argument.

Overrides:
applyLocks in class Loader
Throws:
QueryException

getLockModes

protected LockMode[] getLockModes(Map lockModes)
Description copied from class: Loader
What lock mode does this load entities with?

Overrides:
getLockModes in class OuterJoinLoader

isSubselectLoadingEnabled

protected boolean isSubselectLoadingEnabled()
Overrides:
isSubselectLoadingEnabled in class Loader

getResultList

protected List getResultList(List results,
                             ResultTransformer resultTransformer)
Overrides:
getResultList in class Loader
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CriteriaQueryTranslator (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.criteria
Class CriteriaQueryTranslator

java.lang.Object
    extended by org.hibernate.loader.criteria.CriteriaQueryTranslator
All Implemented Interfaces:
CriteriaQuery
public class CriteriaQueryTranslator
extends Object
implements CriteriaQuery

Author:
Gavin King

Field Summary
static String ROOT_SQL_ALIAS
Constructor Summary
CriteriaQueryTranslator(SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, String rootSQLAlias)
CriteriaQueryTranslator(SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, String rootSQLAlias, CriteriaQuery outerQuery)
Method Summary
String | generateSQLAlias()
String | getColumn(Criteria criteria, String propertyName) Get the names of the columns mapped by a property path, ignoring projection aliases
String[] | getColumnsUsingProjection(Criteria subcriteria, String propertyName) Get the names of the columns constrained by this criterion.
Criteria | getCriteria(String path)
String | getEntityName(Criteria criteria) Get the entity name of an entity
String | getEntityName(Criteria subcriteria, String propertyName) Get the entity name of an entity, taking into account the qualifier of the property path
SessionFactoryImplementor | getFactory()
String | getGroupBy()
String[] | getIdentifierColumns(Criteria subcriteria) Get the identifier column names of this entity
Type | getIdentifierType(Criteria subcriteria) Get the identifier type of this entity
int | getJoinType(String path)
String | getOrderBy()
String[] | getProjectedAliases()
String[] | getProjectedColumnAliases()
Type[] | getProjectedTypes()
String | getPropertyName(String propertyName) Get the property name, given a possibly qualified property name
QueryParameters | getQueryParameters()
Set | getQuerySpaces()
CriteriaImpl | getRootCriteria()
String | getRootSQLALias()
String | getSelect()
String | getSQLAlias(Criteria criteria) Get the root table alias of an entity
String | getSQLAlias(Criteria criteria, String propertyName) Get the root table alias of an entity, taking into account the qualifier of the property path
int | getSQLAliasCount()
Type | getType(Criteria subcriteria, String propertyName) Get the type of a property path, ignoring projection aliases
TypedValue | getTypedIdentifierValue(Criteria subcriteria, Object value)
TypedValue | getTypedValue(Criteria subcriteria, String propertyName, Object value) Get the a typed value for the given property value.
Type | getTypeUsingProjection(Criteria subcriteria, String propertyName) Get the type of a property path
String | getWhereCondition()
boolean | hasProjection()
boolean | isJoin(String path)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ROOT_SQL_ALIAS

public static final String ROOT_SQL_ALIAS
See Also:
Constant Field Values
Constructor Detail

CriteriaQueryTranslator

public CriteriaQueryTranslator(SessionFactoryImplementor factory,
                               CriteriaImpl criteria,
                               String rootEntityName,
                               String rootSQLAlias,
                               CriteriaQuery outerQuery)
                        throws HibernateException

CriteriaQueryTranslator

public CriteriaQueryTranslator(SessionFactoryImplementor factory,
                               CriteriaImpl criteria,
                               String rootEntityName,
                               String rootSQLAlias)
                        throws HibernateException
Method Detail

generateSQLAlias

public String generateSQLAlias()
Specified by:
generateSQLAlias in interface CriteriaQuery

getRootSQLALias

public String getRootSQLALias()

isJoin

public boolean isJoin(String path)

getJoinType

public int getJoinType(String path)

getCriteria

public Criteria getCriteria(String path)

getQuerySpaces

public Set getQuerySpaces()

getSQLAliasCount

public int getSQLAliasCount()

getRootCriteria

public CriteriaImpl getRootCriteria()

getQueryParameters

public QueryParameters getQueryParameters()

hasProjection

public boolean hasProjection()

getGroupBy

public String getGroupBy()

getSelect

public String getSelect()

getProjectedTypes

public Type[] getProjectedTypes()

getProjectedColumnAliases

public String[] getProjectedColumnAliases()

getProjectedAliases

public String[] getProjectedAliases()

getWhereCondition

public String getWhereCondition()

getOrderBy

public String getOrderBy()

getFactory

public SessionFactoryImplementor getFactory()
Specified by:
getFactory in interface CriteriaQuery

getSQLAlias

public String getSQLAlias(Criteria criteria)
Description copied from interface: CriteriaQuery
Get the root table alias of an entity

Specified by:
getSQLAlias in interface CriteriaQuery

getEntityName

public String getEntityName(Criteria criteria)
Description copied from interface: CriteriaQuery
Get the entity name of an entity

Specified by:
getEntityName in interface CriteriaQuery

getColumn

public String getColumn(Criteria criteria,
                        String propertyName)
Description copied from interface: CriteriaQuery
Get the names of the columns mapped by a property path, ignoring projection aliases

Specified by:
getColumn in interface CriteriaQuery

getColumnsUsingProjection

public String[] getColumnsUsingProjection(Criteria subcriteria,
                                          String propertyName)
                                   throws HibernateException
Get the names of the columns constrained by this criterion.

Specified by:
getColumnsUsingProjection in interface CriteriaQuery
Throws:
HibernateException

getIdentifierColumns

public String[] getIdentifierColumns(Criteria subcriteria)
Description copied from interface: CriteriaQuery
Get the identifier column names of this entity

Specified by:
getIdentifierColumns in interface CriteriaQuery

getIdentifierType

public Type getIdentifierType(Criteria subcriteria)
Description copied from interface: CriteriaQuery
Get the identifier type of this entity

Specified by:
getIdentifierType in interface CriteriaQuery

getTypedIdentifierValue

public TypedValue getTypedIdentifierValue(Criteria subcriteria,
                                          Object value)
Specified by:
getTypedIdentifierValue in interface CriteriaQuery

getTypeUsingProjection

public Type getTypeUsingProjection(Criteria subcriteria,
                                   String propertyName)
                            throws HibernateException
Description copied from interface: CriteriaQuery
Get the type of a property path

Specified by:
getTypeUsingProjection in interface CriteriaQuery
Throws:
HibernateException

getType

public Type getType(Criteria subcriteria,
                    String propertyName)
             throws HibernateException
Description copied from interface: CriteriaQuery
Get the type of a property path, ignoring projection aliases

Specified by:
getType in interface CriteriaQuery
Throws:
HibernateException

getTypedValue

public TypedValue getTypedValue(Criteria subcriteria,
                                String propertyName,
                                Object value)
                         throws HibernateException
Get the a typed value for the given property value.

Specified by:
getTypedValue in interface CriteriaQuery
Throws:
HibernateException

getEntityName

public String getEntityName(Criteria subcriteria,
                            String propertyName)
Description copied from interface: CriteriaQuery
Get the entity name of an entity, taking into account the qualifier of the property path

Specified by:
getEntityName in interface CriteriaQuery

getSQLAlias

public String getSQLAlias(Criteria criteria,
                          String propertyName)
Description copied from interface: CriteriaQuery
Get the root table alias of an entity, taking into account the qualifier of the property path

Specified by:
getSQLAlias in interface CriteriaQuery

getPropertyName

public String getPropertyName(String propertyName)
Description copied from interface: CriteriaQuery
Get the property name, given a possibly qualified property name

Specified by:
getPropertyName in interface CriteriaQuery
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.loader.custom (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.loader.custom

This package defines a framework for custom loaders that accept handwritten SQL

See:
Description

Interface Summary
CustomQuery | Extension point allowing any SQL query with named and positional parameters to be executed by Hibernate, returning managed entities, collections and simple scalar values.
Return | Represents a return in a custom query.

Class Summary
CollectionFetchReturn | Spefically a fetch return that refers to a collection association.
CollectionReturn | Represents a return which names a collection role; it is used in defining a custom query for loading an entity's collection in non-fetching scenarios (i.e., loading the collection itself as the "root" of the result).
ColumnCollectionAliases | CollectionAliases that uses columnnames instead of generated aliases.
CustomLoader | Extension point for loaders which use a SQL result set with "unexpected" column aliases.
EntityFetchReturn | Spefically a fetch return that refers to an entity association.
FetchReturn | Represents a return which names a fetched association.
NonScalarReturn | Represents some non-scalar (entity/collection) return within the query result.
RootReturn | Represents a return which names a "root" entity.
ScalarReturn | Represent a scalar (aka simple value) return within a query result.

Package org.hibernate.loader.custom Description

This package defines a framework for custom loaders that accept handwritten SQL


org.hibernate.loader.custom Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.loader.custom

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.loader.custom.ColumnCollectionAliases (implements org.hibernate.loader.CollectionAliases)
    • class org.hibernate.loader.custom.CustomLoader.NonScalarResultColumnProcessor (implements org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor)
    • class org.hibernate.loader.custom.CustomLoader.ResultRowProcessor
    • class org.hibernate.loader.custom.CustomLoader.ScalarResultColumnProcessor (implements org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor)
    • class org.hibernate.loader.Loader
      • class org.hibernate.loader.custom.CustomLoader
    • class org.hibernate.loader.custom.NonScalarReturn (implements org.hibernate.loader.custom.Return)
      • class org.hibernate.loader.custom.CollectionReturn
      • class org.hibernate.loader.custom.FetchReturn
        • class org.hibernate.loader.custom.CollectionFetchReturn
        • class org.hibernate.loader.custom.EntityFetchReturn
      • class org.hibernate.loader.custom.RootReturn
    • class org.hibernate.loader.custom.ScalarReturn (implements org.hibernate.loader.custom.Return)

Interface Hierarchy

  • interface org.hibernate.loader.custom.CustomQuery
  • interface org.hibernate.loader.custom.Return


Uses of Package org.hibernate.loader.custom (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.loader.custom

Packages that use org.hibernate.loader.custom
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.custom.sql |

Classes in org.hibernate.loader.custom used by org.hibernate.engine
CustomQuery
Extension point allowing any SQL query with named and positional parameters to be executed by Hibernate, returning managed entities, collections and simple scalar values.

Classes in org.hibernate.loader.custom used by org.hibernate.impl
CustomQuery
Extension point allowing any SQL query with named and positional parameters to be executed by Hibernate, returning managed entities, collections and simple scalar values.

Classes in org.hibernate.loader.custom used by org.hibernate.loader.custom
CustomQuery
Extension point allowing any SQL query with named and positional parameters to be executed by Hibernate, returning managed entities, collections and simple scalar values.
FetchReturn
Represents a return which names a fetched association.
NonScalarReturn
Represents some non-scalar (entity/collection) return within the query result.
Return
Represents a return in a custom query.

Classes in org.hibernate.loader.custom used by org.hibernate.loader.custom.sql
CustomQuery
Extension point allowing any SQL query with named and positional parameters to be executed by Hibernate, returning managed entities, collections and simple scalar values.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CustomQuery (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Interface CustomQuery

All Known Implementing Classes:
SQLCustomQuery
public interface CustomQuery

Extension point allowing any SQL query with named and positional parameters to be executed by Hibernate, returning managed entities, collections and simple scalar values.

Author:
Gavin King, Steve Ebersole

Method Summary
List | getCustomQueryReturns() A collection of descriptors describing the JDBC result set to be expected and how to map this result set.
Map | getNamedParameterBindPoints() A map representing positions within the supplied query to which we need to bind named parameters.
Set | getQuerySpaces() Any query spaces to apply to the query execution.
String | getSQL() The SQL query string to be performed.

Method Detail

getSQL

public String getSQL()
The SQL query string to be performed.

Returns:
The SQL statement string.

getQuerySpaces

public Set getQuerySpaces()
Any query spaces to apply to the query execution. Query spaces are used in Hibernate's auto-flushing mechanism to determine which entities need to be checked for pending changes.

Returns:
The query spaces

getNamedParameterBindPoints

public Map getNamedParameterBindPoints()
A map representing positions within the supplied query to which we need to bind named parameters.

Optional, may return null if no named parameters.

The structure of the returned map (if one) as follows:

  1. The keys into the map are the named parameter names
  2. The corresponding value is either an Integer if the parameter occurs only once in the query; or a List of Integers if the parameter occurs more than once

getCustomQueryReturns

public List getCustomQueryReturns()
A collection of descriptors describing the JDBC result set to be expected and how to map this result set.

Returns:
List of return descriptors.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Return (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Interface Return

All Known Implementing Classes:
NonScalarReturn, ScalarReturn
public interface Return

Represents a return in a custom query.

Author:
Steve Ebersole

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CollectionFetchReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Class CollectionFetchReturn

java.lang.Object
    extended by org.hibernate.loader.custom.NonScalarReturn
        extended by org.hibernate.loader.custom.FetchReturn
            extended by org.hibernate.loader.custom.CollectionFetchReturn
All Implemented Interfaces:
Return
public class CollectionFetchReturn
extends FetchReturn

Spefically a fetch return that refers to a collection association.

Author:
Steve Ebersole

Constructor Summary
CollectionFetchReturn(String alias, NonScalarReturn owner, String ownerProperty, CollectionAliases collectionAliases, EntityAliases elementEntityAliases, LockMode lockMode)
Method Summary
CollectionAliases | getCollectionAliases()
EntityAliases | getElementEntityAliases()
Methods inherited from class org.hibernate.loader.custom.FetchReturn
getOwner, getOwnerProperty
Methods inherited from class org.hibernate.loader.custom.NonScalarReturn
getAlias, getLockMode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CollectionFetchReturn

public CollectionFetchReturn(String alias,
                             NonScalarReturn owner,
                             String ownerProperty,
                             CollectionAliases collectionAliases,
                             EntityAliases elementEntityAliases,
                             LockMode lockMode)
Method Detail

getCollectionAliases

public CollectionAliases getCollectionAliases()

getElementEntityAliases

public EntityAliases getElementEntityAliases()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CollectionReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Class CollectionReturn

java.lang.Object
    extended by org.hibernate.loader.custom.NonScalarReturn
        extended by org.hibernate.loader.custom.CollectionReturn
All Implemented Interfaces:
Return
public class CollectionReturn
extends NonScalarReturn

Represents a return which names a collection role; it is used in defining a custom query for loading an entity's collection in non-fetching scenarios (i.e., loading the collection itself as the "root" of the result).

Author:
Steve Ebersole

Constructor Summary
CollectionReturn(String alias, String ownerEntityName, String ownerProperty, CollectionAliases collectionAliases, EntityAliases elementEntityAliases, LockMode lockMode)
Method Summary
 CollectionAliases getCollectionAliases()
 EntityAliases getElementEntityAliases()
 String getOwnerEntityName()
Returns the class owning the collection.
 String getOwnerProperty()
Returns the name of the property representing the collection from the getOwnerEntityName().
Methods inherited from class org.hibernate.loader.custom.NonScalarReturn
getAlias, getLockMode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CollectionReturn

public CollectionReturn(String alias,
                        String ownerEntityName,
                        String ownerProperty,
                        CollectionAliases collectionAliases,
                        EntityAliases elementEntityAliases,
                        LockMode lockMode)
Method Detail

getOwnerEntityName

public String getOwnerEntityName()
Returns the class owning the collection.

Returns:
The class owning the collection.

getOwnerProperty

public String getOwnerProperty()
Returns the name of the property representing the collection from the getOwnerEntityName().

Returns:
The name of the property representing the collection on the owner class.

getCollectionAliases

public CollectionAliases getCollectionAliases()

getElementEntityAliases

public EntityAliases getElementEntityAliases()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ColumnCollectionAliases (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Class ColumnCollectionAliases

java.lang.Object
    extended by org.hibernate.loader.custom.ColumnCollectionAliases
All Implemented Interfaces:
CollectionAliases
public class ColumnCollectionAliases
extends Object
implements CollectionAliases

CollectionAliases that uses columnnames instead of generated aliases. Aliases can still be overwritten via

Author:
Max Rydahl Andersen

Constructor Summary
ColumnCollectionAliases(Map userProvidedAliases, SQLLoadableCollection persister)
Method Summary
String | getSuffix() Returns the suffix used to unique the column aliases for this particular alias set.
String[] | getSuffixedElementAliases() Returns the suffixed result-set column-aliases for the columns making up the collection's elements.
String | getSuffixedIdentifierAlias() Returns the suffixed result-set column-aliases for the column defining the collection's identifier (if any).
String[] | getSuffixedIndexAliases() Returns the suffixed result-set column-aliases for the collumns making up the collection's index (map or list).
String[] | getSuffixedKeyAliases() Returns the suffixed result-set column-aliases for columns making up the key for this collection (i.e., its FK to its owner).
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ColumnCollectionAliases

public ColumnCollectionAliases(Map userProvidedAliases,
                               SQLLoadableCollection persister)
Method Detail

getSuffixedKeyAliases

public String[] getSuffixedKeyAliases()
Returns the suffixed result-set column-aliases for columns making up the key for this collection (i.e., its FK to its owner).

Specified by:
getSuffixedKeyAliases in interface CollectionAliases
Returns:
The key result-set column aliases.

getSuffixedIndexAliases

public String[] getSuffixedIndexAliases()
Returns the suffixed result-set column-aliases for the collumns making up the collection's index (map or list).

Specified by:
getSuffixedIndexAliases in interface CollectionAliases
Returns:
The index result-set column aliases.

getSuffixedElementAliases

public String[] getSuffixedElementAliases()
Returns the suffixed result-set column-aliases for the columns making up the collection's elements.

Specified by:
getSuffixedElementAliases in interface CollectionAliases
Returns:
The element result-set column aliases.

getSuffixedIdentifierAlias

public String getSuffixedIdentifierAlias()
Returns the suffixed result-set column-aliases for the column defining the collection's identifier (if any).

Specified by:
getSuffixedIdentifierAlias in interface CollectionAliases
Returns:
The identifier result-set column aliases.

getSuffix

public String getSuffix()
Returns the suffix used to unique the column aliases for this particular alias set.

Specified by:
getSuffix in interface CollectionAliases
Returns:
The uniqued column alias suffix.

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Class CustomLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.custom.CustomLoader
public class CustomLoader
extends Loader

Extension point for loaders which use a SQL result set with "unexpected" column aliases.

Author:
Gavin King, Steve Ebersole

Nested Class Summary
class | CustomLoader.NonScalarResultColumnProcessor
class | CustomLoader.ResultRowProcessor
class | CustomLoader.ScalarResultColumnProcessor
Constructor Summary
CustomLoader(CustomQuery customQuery, SessionFactoryImplementor factory)
Method Summary
protected void | autoDiscoverTypes(ResultSet rs)
protected CollectionAliases[] | getCollectionAliases()
protected int[] | getCollectionOwners() Get the index of the entity that owns the collection, or -1 if there is no owner in the query results (ie.
protected CollectionPersister[] | getCollectionPersisters() An (optional) persister for a collection to be initialized; only collection loaders return a non-null value
protected EntityAliases[] | getEntityAliases() Get the result set descriptor
protected Loadable[] | getEntityPersisters() An array of persisters of entity classes contained in each row of results; implemented by all subclasses
protected LockMode[] | getLockModes(Map lockModesMap) What lock mode does this load entities with?
int[] | getNamedParameterLocs(String name)
protected int[] | getOwners() An array of indexes of the entity that owns a one-to-one association to the entity at the given index (-1 if there is no "owner")
protected String | getQueryIdentifier() Identifies the query for statistics reporting, if null, no statistics will be reported
Set | getQuerySpaces()
protected Object | getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session) Get the actual object that is returned in the user-visible result list.
protected List | getResultList(List results, ResultTransformer resultTransformer)
protected String | getSQLString() The SQL query string to be called; implemented by all subclasses
List | list(SessionImplementor session, QueryParameters queryParameters)
ScrollableResults | scroll(QueryParameters queryParameters, SessionImplementor session)
Methods inherited from class org.hibernate.loader.Loader
applyLocks, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getAliases, getEntityEagerPropertyFetches, getFactory, getOwnerAssociationTypes, getResultSet, hasSubselectLoadableCollections, isSingleRowLoader, isSubselectLoadingEnabled, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, postInstantiate, prepareQueryStatement, preprocessSQL, scroll, toString, upgradeLocks
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CustomLoader

public CustomLoader(CustomQuery customQuery,
                    SessionFactoryImplementor factory)
Method Detail

getQueryIdentifier

protected String getQueryIdentifier()
Description copied from class: Loader
Identifies the query for statistics reporting, if null, no statistics will be reported

Overrides:
getQueryIdentifier in class Loader

getSQLString

protected String getSQLString()
Description copied from class: Loader
The SQL query string to be called; implemented by all subclasses

Specified by:
getSQLString in class Loader

getQuerySpaces

public Set getQuerySpaces()

getLockModes

protected LockMode[] getLockModes(Map lockModesMap)
Description copied from class: Loader
What lock mode does this load entities with?

Specified by:
getLockModes in class Loader
Parameters:
lockModesMap - a collection of lock modes specified dynamically via the Query interface

getEntityPersisters

protected Loadable[] getEntityPersisters()
Description copied from class: Loader
An array of persisters of entity classes contained in each row of results; implemented by all subclasses

Specified by:
getEntityPersisters in class Loader

getCollectionPersisters

protected CollectionPersister[] getCollectionPersisters()
Description copied from class: Loader
An (optional) persister for a collection to be initialized; only collection loaders return a non-null value

Overrides:
getCollectionPersisters in class Loader

getCollectionOwners

protected int[] getCollectionOwners()
Description copied from class: Loader
Get the index of the entity that owns the collection, or -1 if there is no owner in the query results (ie. in the case of a collection initializer) or no collection.

Overrides:
getCollectionOwners in class Loader

getOwners

protected int[] getOwners()
Description copied from class: Loader
An array of indexes of the entity that owns a one-to-one association to the entity at the given index (-1 if there is no "owner")

Overrides:
getOwners in class Loader

list

public List list(SessionImplementor session,
                 QueryParameters queryParameters)
          throws HibernateException
Throws:
HibernateException

scroll

public ScrollableResults scroll(QueryParameters queryParameters,
                                SessionImplementor session)
                         throws HibernateException
Throws:
HibernateException

getResultColumnOrRow

protected Object getResultColumnOrRow(Object[] row,
                                      ResultTransformer transformer,
                                      ResultSet rs,
                                      SessionImplementor session)
                               throws SQLException,
                                      HibernateException
Description copied from class: Loader
Get the actual object that is returned in the user-visible result list. This empty implementation merely returns its first argument. This is overridden by some subclasses.

Overrides:
getResultColumnOrRow in class Loader
Throws:
SQLException
HibernateException

getResultList

protected List getResultList(List results,
                             ResultTransformer resultTransformer)
                      throws QueryException
Overrides:
getResultList in class Loader
Throws:
QueryException

getEntityAliases

protected EntityAliases[] getEntityAliases()
Description copied from class: Loader
Get the result set descriptor

Specified by:
getEntityAliases in class Loader

getCollectionAliases

protected CollectionAliases[] getCollectionAliases()
Specified by:
getCollectionAliases in class Loader

getNamedParameterLocs

public int[] getNamedParameterLocs(String name)
                            throws QueryException
Overrides:
getNamedParameterLocs in class Loader
Throws:
QueryException

autoDiscoverTypes

protected void autoDiscoverTypes(ResultSet rs)
Overrides:
autoDiscoverTypes in class Loader
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomLoader.NonScalarResultColumnProcessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Class CustomLoader.NonScalarResultColumnProcessor

java.lang.Object
    extended by org.hibernate.loader.custom.CustomLoader.NonScalarResultColumnProcessor
All Implemented Interfaces:
org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor
Enclosing class:
CustomLoader
public class CustomLoader.NonScalarResultColumnProcessor
extends Object
implements org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor

Constructor Summary
CustomLoader.NonScalarResultColumnProcessor(int position)
Method Summary
Object | extract(Object[] data, ResultSet resultSet, SessionImplementor session)
void | performDiscovery(org.hibernate.loader.custom.CustomLoader.Metadata metadata, List types, List aliases)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomLoader.NonScalarResultColumnProcessor

public CustomLoader.NonScalarResultColumnProcessor(int position)
Method Detail

extract

public Object extract(Object[] data,
                      ResultSet resultSet,
                      SessionImplementor session)
               throws SQLException,
                      HibernateException
Specified by:
extract in interface org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor
Throws:
SQLException
HibernateException

performDiscovery

public void performDiscovery(org.hibernate.loader.custom.CustomLoader.Metadata metadata,
                             List types,
                             List aliases)
Specified by:
performDiscovery in interface org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomLoader.ResultRowProcessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Class CustomLoader.ResultRowProcessor

java.lang.Object
    extended by org.hibernate.loader.custom.CustomLoader.ResultRowProcessor
Enclosing class:
CustomLoader
public class CustomLoader.ResultRowProcessor
extends Object

Constructor Summary
CustomLoader.ResultRowProcessor(boolean hasScalars, org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor[] columnProcessors)
Method Summary
Object | buildResultRow(Object[] data, ResultSet resultSet, boolean hasTransformer, SessionImplementor session) Build a logical result row.
void | prepareForAutoDiscovery(org.hibernate.loader.custom.CustomLoader.Metadata metadata)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomLoader.ResultRowProcessor

public CustomLoader.ResultRowProcessor(boolean hasScalars,
                                       org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor[] columnProcessors)
Method Detail

prepareForAutoDiscovery

public void prepareForAutoDiscovery(org.hibernate.loader.custom.CustomLoader.Metadata metadata)
                             throws SQLException
Throws:
SQLException

buildResultRow

public Object buildResultRow(Object[] data,
                             ResultSet resultSet,
                             boolean hasTransformer,
                             SessionImplementor session)
                      throws SQLException,
                             HibernateException
Build a logical result row.

At this point, Loader has already processed all non-scalar result data. We just need to account for scalar result data here...

Parameters:
data - Entity data defined as "root returns" and already handled by the normal Loader mechanism.
resultSet - The JDBC result set (positioned at the row currently being processed).
hasTransformer - Does this query have an associated ResultTransformer
session - The session from which the query request originated.
Returns:
The logical result row
Throws:
SQLException
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomLoader.ScalarResultColumnProcessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Class CustomLoader.ScalarResultColumnProcessor

java.lang.Object
    extended by org.hibernate.loader.custom.CustomLoader.ScalarResultColumnProcessor
All Implemented Interfaces:
org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor
Enclosing class:
CustomLoader
public class CustomLoader.ScalarResultColumnProcessor
extends Object
implements org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor

Constructor Summary
CustomLoader.ScalarResultColumnProcessor(int position)
CustomLoader.ScalarResultColumnProcessor(String alias, Type type)
Method Summary
Object | extract(Object[] data, ResultSet resultSet, SessionImplementor session)
void | performDiscovery(org.hibernate.loader.custom.CustomLoader.Metadata metadata, List types, List aliases)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomLoader.ScalarResultColumnProcessor

public CustomLoader.ScalarResultColumnProcessor(int position)

CustomLoader.ScalarResultColumnProcessor

public CustomLoader.ScalarResultColumnProcessor(String alias,
                                                Type type)
Method Detail

extract

public Object extract(Object[] data,
                      ResultSet resultSet,
                      SessionImplementor session)
               throws SQLException,
                      HibernateException
Specified by:
extract in interface org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor
Throws:
SQLException
HibernateException

performDiscovery

public void performDiscovery(org.hibernate.loader.custom.CustomLoader.Metadata metadata,
                             List types,
                             List aliases)
                      throws SQLException
Specified by:
performDiscovery in interface org.hibernate.loader.custom.CustomLoader.ResultColumnProcessor
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityFetchReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Class EntityFetchReturn

java.lang.Object
    extended by org.hibernate.loader.custom.NonScalarReturn
        extended by org.hibernate.loader.custom.FetchReturn
            extended by org.hibernate.loader.custom.EntityFetchReturn
All Implemented Interfaces:
Return
public class EntityFetchReturn
extends FetchReturn

Spefically a fetch return that refers to an entity association.

Author:
Steve Ebersole

Constructor Summary
EntityFetchReturn(String alias, EntityAliases entityAliases, NonScalarReturn owner, String ownerProperty, LockMode lockMode)
Method Summary
 EntityAliases getEntityAliases()
Methods inherited from class org.hibernate.loader.custom.FetchReturn
getOwner, getOwnerProperty
Methods inherited from class org.hibernate.loader.custom.NonScalarReturn
getAlias, getLockMode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EntityFetchReturn

public EntityFetchReturn(String alias,
                         EntityAliases entityAliases,
                         NonScalarReturn owner,
                         String ownerProperty,
                         LockMode lockMode)
Method Detail

getEntityAliases

public EntityAliases getEntityAliases()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FetchReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Class FetchReturn

java.lang.Object
    extended by org.hibernate.loader.custom.NonScalarReturn
        extended by org.hibernate.loader.custom.FetchReturn
All Implemented Interfaces:
Return
Direct Known Subclasses:
CollectionFetchReturn, EntityFetchReturn
public abstract class FetchReturn
extends NonScalarReturn

Represents a return which names a fetched association.

Author:
Steve Ebersole

Constructor Summary
FetchReturn(NonScalarReturn owner, String ownerProperty, String alias, LockMode lockMode)
Creates a return descriptor for an association fetch.
Method Summary
NonScalarReturn | getOwner() Retrieves the return descriptor for the owner of this fetch.
String | getOwnerProperty() The name of the property on the owner which represents this association.
Methods inherited from class org.hibernate.loader.custom.NonScalarReturn
getAlias, getLockMode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FetchReturn

public FetchReturn(NonScalarReturn owner,
                   String ownerProperty,
                   String alias,
                   LockMode lockMode)
Creates a return descriptor for an association fetch.

Parameters:
owner - The return descriptor for the owner of the fetch
ownerProperty - The name of the property represernting the association being fetched
alias - The alias for the fetch
lockMode - The lock mode to apply to the fetched association.
Method Detail

getOwner

public NonScalarReturn getOwner()
Retrieves the return descriptor for the owner of this fetch.

Returns:
The owner

getOwnerProperty

public String getOwnerProperty()
The name of the property on the owner which represents this association.

Returns:
The property name.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonScalarReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Class NonScalarReturn

java.lang.Object
    extended by org.hibernate.loader.custom.NonScalarReturn
All Implemented Interfaces:
Return
Direct Known Subclasses:
CollectionReturn, FetchReturn, RootReturn
public abstract class NonScalarReturn
extends Object
implements Return

Represents some non-scalar (entity/collection) return within the query result.

Author:
Steve Ebersole

Constructor Summary
NonScalarReturn(String alias, LockMode lockMode)
Method Summary
String | getAlias()
LockMode | getLockMode()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NonScalarReturn

public NonScalarReturn(String alias,
                       LockMode lockMode)
Method Detail

getAlias

public String getAlias()

getLockMode

public LockMode getLockMode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RootReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Class RootReturn

java.lang.Object
    extended by org.hibernate.loader.custom.NonScalarReturn
        extended by org.hibernate.loader.custom.RootReturn
All Implemented Interfaces:
Return
public class RootReturn
extends NonScalarReturn

Represents a return which names a "root" entity.

A root entity means it is explicitly a "column" in the result, as opposed to a fetched association.

Author:
Steve Ebersole

Constructor Summary
RootReturn(String alias, String entityName, EntityAliases entityAliases, LockMode lockMode)
Method Summary
EntityAliases | getEntityAliases()
String | getEntityName()
Methods inherited from class org.hibernate.loader.custom.NonScalarReturn
getAlias, getLockMode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RootReturn

public RootReturn(String alias,
                  String entityName,
                  EntityAliases entityAliases,
                  LockMode lockMode)
Method Detail

getEntityName

public String getEntityName()

getEntityAliases

public EntityAliases getEntityAliases()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScalarReturn (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom
Class ScalarReturn

java.lang.Object
    extended by org.hibernate.loader.custom.ScalarReturn
All Implemented Interfaces:
Return
public class ScalarReturn
extends Object
implements Return

Represent a scalar (aka simple value) return within a query result.

Author:
Steve Ebersole

Constructor Summary
ScalarReturn(Type type, String columnAlias)
Method Summary
String | getColumnAlias()
Type | getType()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ScalarReturn

public ScalarReturn(Type type,
                    String columnAlias)
Method Detail

getType

public Type getType()

getColumnAlias

public String getColumnAlias()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.loader.custom.sql (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.loader.custom.sql

Class Summary
SQLCustomQuery | Implements Hibernate's built-in support for native SQL queries.
SQLQueryParser |
SQLQueryParser.ParameterSubstitutionRecognizer |
SQLQueryReturnProcessor | Responsible for processing the series of returns defined by a NativeSQLQuerySpecification and breaking them down into a series of returns for use within the CustomLoader.


org.hibernate.loader.custom.sql Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.loader.custom.sql

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.loader.custom.sql.SQLCustomQuery (implements org.hibernate.loader.custom.CustomQuery)
    • class org.hibernate.loader.custom.sql.SQLQueryParser
    • class org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer (implements org.hibernate.engine.query.ParameterParser.Recognizer)
    • class org.hibernate.loader.custom.sql.SQLQueryReturnProcessor


Uses of Package org.hibernate.loader.custom.sql (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.loader.custom.sql

Packages that use org.hibernate.loader.custom.sql
org.hibernate.engine.query

Classes in org.hibernate.loader.custom.sql used by org.hibernate.engine.query
SQLCustomQuery
Implements Hibernate's built-in support for native SQL queries.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SQLCustomQuery (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom.sql
Class SQLCustomQuery

java.lang.Object
    extended by org.hibernate.loader.custom.sql.SQLCustomQuery
All Implemented Interfaces:
CustomQuery
public class SQLCustomQuery
extends Object
implements CustomQuery

Implements Hibernate's built-in support for native SQL queries.

This support is built on top of the notion of "custom queries"...

Author:
Gavin King, Max Andersen, Steve Ebersole

Field Summary
static org.apache.commons.logging.Log log
Constructor Summary
SQLCustomQuery(String sqlQuery, NativeSQLQueryReturn[] queryReturns, Collection additionalQuerySpaces, SessionFactoryImplementor factory)
Method Summary
List | getCustomQueryReturns() A collection of descriptors describing the JDBC result set to be expected and how to map this result set.
Map | getNamedParameterBindPoints() A map representing positions within the supplied query to which we need to bind named parameters.
Set | getQuerySpaces() Any query spaces to apply to the query execution.
String | getSQL() The SQL query string to be performed.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

public static final org.apache.commons.logging.Log log
Constructor Detail

SQLCustomQuery

public SQLCustomQuery(String sqlQuery,
                      NativeSQLQueryReturn[] queryReturns,
                      Collection additionalQuerySpaces,
                      SessionFactoryImplementor factory)
               throws HibernateException
Method Detail

getSQL

public String getSQL()
Description copied from interface: CustomQuery
The SQL query string to be performed.

Specified by:
getSQL in interface CustomQuery
Returns:
The SQL statement string.

getQuerySpaces

public Set getQuerySpaces()
Description copied from interface: CustomQuery
Any query spaces to apply to the query execution. Query spaces are used in Hibernate's auto-flushing mechanism to determine which entities need to be checked for pending changes.

Specified by:
getQuerySpaces in interface CustomQuery
Returns:
The query spaces

getNamedParameterBindPoints

public Map getNamedParameterBindPoints()
Description copied from interface: CustomQuery
A map representing positions within the supplied query to which we need to bind named parameters.

Optional, may return null if no named parameters.

The structure of the returned map (if one) as follows:

  1. The keys into the map are the named parameter names
  2. The corresponding value is either an Integer if the parameter occurs only once in the query; or a List of Integers if the parameter occurs more than once

Specified by:
getNamedParameterBindPoints in interface CustomQuery

getCustomQueryReturns

public List getCustomQueryReturns()
Description copied from interface: CustomQuery
A collection of descriptors describing the JDBC result set to be expected and how to map this result set.

Specified by:
getCustomQueryReturns in interface CustomQuery
Returns:
List of return descriptors.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


SQLQueryParser (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom.sql
Class SQLQueryParser

java.lang.Object
    extended by org.hibernate.loader.custom.sql.SQLQueryParser
public class SQLQueryParser
extends Object

Author:
Gavin King, Max Andersen, Steve Ebersole

Nested Class Summary
static class SQLQueryParser.ParameterSubstitutionRecognizer
Constructor Summary
SQLQueryParser(String queryString, org.hibernate.loader.custom.sql.SQLQueryParser.ParserContext context)
Method Summary
Map | getNamedParameters()
String | process()
boolean | queryHasAliases()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SQLQueryParser

public SQLQueryParser(String queryString,
                      org.hibernate.loader.custom.sql.SQLQueryParser.ParserContext context)
Method Detail

getNamedParameters

public Map getNamedParameters()

queryHasAliases

public boolean queryHasAliases()

process

public String process()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLQueryParser.ParameterSubstitutionRecognizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom.sql
Class SQLQueryParser.ParameterSubstitutionRecognizer

java.lang.Object
    extended by org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer
All Implemented Interfaces:
ParameterParser.Recognizer
Enclosing class:
SQLQueryParser
public static class SQLQueryParser.ParameterSubstitutionRecognizer
extends Object
implements ParameterParser.Recognizer

Constructor Summary
SQLQueryParser.ParameterSubstitutionRecognizer()
Method Summary
void | jpaPositionalParameter(String name, int position)
void | namedParameter(String name, int position)
void | ordinalParameter(int position)
void | other(char character)
void | outParameter(int position)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SQLQueryParser.ParameterSubstitutionRecognizer

public SQLQueryParser.ParameterSubstitutionRecognizer()
Method Detail

outParameter

public void outParameter(int position)
Specified by:
outParameter in interface ParameterParser.Recognizer

ordinalParameter

public void ordinalParameter(int position)
Specified by:
ordinalParameter in interface ParameterParser.Recognizer

namedParameter

public void namedParameter(String name,
                           int position)
Specified by:
namedParameter in interface ParameterParser.Recognizer

jpaPositionalParameter

public void jpaPositionalParameter(String name,
                                   int position)
Specified by:
jpaPositionalParameter in interface ParameterParser.Recognizer

other

public void other(char character)
Specified by:
other in interface ParameterParser.Recognizer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLQueryReturnProcessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.custom.sql
Class SQLQueryReturnProcessor

java.lang.Object
    extended by org.hibernate.loader.custom.sql.SQLQueryReturnProcessor
public class SQLQueryReturnProcessor
extends Object

Responsible for processing the series of returns defined by a NativeSQLQuerySpecification and breaking them down into a series of returns for use within the CustomLoader.

Author:
Gavin King, Max Andersen, Steve Ebersole

Field Summary
static org.apache.commons.logging.Log log
Constructor Summary
SQLQueryReturnProcessor(NativeSQLQueryReturn[] queryReturns, SessionFactoryImplementor factory)
Method Summary
List | generateCustomReturns(boolean queryHadAliases)
org.hibernate.loader.custom.sql.SQLQueryReturnProcessor.ResultAliasContext | process()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

public static final org.apache.commons.logging.Log log
Constructor Detail

SQLQueryReturnProcessor

public SQLQueryReturnProcessor(NativeSQLQueryReturn[] queryReturns,
                               SessionFactoryImplementor factory)
Method Detail

process

public org.hibernate.loader.custom.sql.SQLQueryReturnProcessor.ResultAliasContext process()

generateCustomReturns

public List generateCustomReturns(boolean queryHadAliases)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.loader.entity (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.loader.entity

This package defines entity loaders

See:
Description

Interface Summary
UniqueEntityLoader Loads entities for a EntityPersister

Class Summary
AbstractEntityLoader |
BatchingEntityLoader | "Batch" loads entities, using multiple primary key values in the SQL where clause.
CascadeEntityJoinWalker |
CascadeEntityLoader |
CollectionElementLoader |
EntityJoinWalker | A walker for loaders that fetch entities
EntityLoader | Loads an entity instance using outerjoin fetching to fetch associated entities.

Package org.hibernate.loader.entity Description

This package defines entity loaders


org.hibernate.loader.entity Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.loader.entity

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.loader.entity.BatchingEntityLoader (implements org.hibernate.loader.entity.UniqueEntityLoader)
    • class org.hibernate.loader.JoinWalker
      • class org.hibernate.loader.AbstractEntityJoinWalker
        • class org.hibernate.loader.entity.CascadeEntityJoinWalker
        • class org.hibernate.loader.entity.EntityJoinWalker
    • class org.hibernate.loader.Loader
      • class org.hibernate.loader.BasicLoader
        • class org.hibernate.loader.OuterJoinLoader
          • class org.hibernate.loader.entity.AbstractEntityLoader (implements org.hibernate.loader.entity.UniqueEntityLoader)
            • class org.hibernate.loader.entity.CascadeEntityLoader
            • class org.hibernate.loader.entity.EntityLoader
          • class org.hibernate.loader.entity.CollectionElementLoader

Interface Hierarchy

  • interface org.hibernate.loader.entity.UniqueEntityLoader


Uses of Package org.hibernate.loader.entity (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.loader.entity

Packages that use org.hibernate.loader.entity
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Classes in org.hibernate.loader.entity used by org.hibernate.loader.entity
AbstractEntityLoader
UniqueEntityLoader
Loads entities for a EntityPersister

Classes in org.hibernate.loader.entity used by org.hibernate.persister.entity
UniqueEntityLoader
Loads entities for a EntityPersister

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


UniqueEntityLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.entity
Interface UniqueEntityLoader

All Known Implementing Classes:
AbstractEntityLoader, BatchingEntityLoader, NamedQueryLoader
public interface UniqueEntityLoader

Loads entities for a EntityPersister

Author:
Gavin King

Method Summary
 Object load(Serializable id, Object optionalObject, SessionImplementor session)
Load an entity instance.

Method Detail

load

public Object load(Serializable id,
                   Object optionalObject,
                   SessionImplementor session)
            throws HibernateException
Load an entity instance. If optionalObject is supplied, load the entity state into the given (uninitialized) object.

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractEntityLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.entity
Class AbstractEntityLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.loader.OuterJoinLoader
                extended by org.hibernate.loader.entity.AbstractEntityLoader
All Implemented Interfaces:
UniqueEntityLoader
Direct Known Subclasses:
CascadeEntityLoader, EntityLoader
public abstract class AbstractEntityLoader
extends OuterJoinLoader
implements UniqueEntityLoader

Field Summary
protected String | entityName
protected static org.apache.commons.logging.Log | log
protected OuterJoinLoadable | persister
protected Type | uniqueKeyType
Fields inherited from class org.hibernate.loader.OuterJoinLoader
aliases, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX
Constructor Summary
AbstractEntityLoader(OuterJoinLoadable persister, Type uniqueKeyType, SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
protected Object | getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session) Get the actual object that is returned in the user-visible result list.
protected boolean | isSingleRowLoader() Return false is this loader is a batch entity loader
Object | load(Serializable id, Object optionalObject, SessionImplementor session) Load an entity instance.
protected Object | load(SessionImplementor session, Object id, Object optionalObject, Serializable optionalId)
Methods inherited from class org.hibernate.loader.OuterJoinLoader
getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getEntityPersisters, getLockModes, getOwnerAssociationTypes, getOwners, getSQLString, getSuffixes, initFromWalker
Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate
Methods inherited from class org.hibernate.loader.Loader
applyLocks, autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getEntityEagerPropertyFetches, getFactory, getNamedParameterLocs, getQueryIdentifier, getResultList, getResultSet, hasSubselectLoadableCollections, isSubselectLoadingEnabled, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll, toString, upgradeLocks
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

log

protected static final org.apache.commons.logging.Log log

persister

protected final OuterJoinLoadable persister

uniqueKeyType

protected final Type uniqueKeyType

entityName

protected final String entityName
Constructor Detail

AbstractEntityLoader

public AbstractEntityLoader(OuterJoinLoadable persister,
                            Type uniqueKeyType,
                            SessionFactoryImplementor factory,
                            Map enabledFilters)
Method Detail

load

public Object load(Serializable id,
                   Object optionalObject,
                   SessionImplementor session)
            throws HibernateException
Description copied from interface: UniqueEntityLoader
Load an entity instance. If optionalObject is supplied, load the entity state into the given (uninitialized) object.

Specified by:
load in interface UniqueEntityLoader
Throws:
HibernateException

load

protected Object load(SessionImplementor session,
                      Object id,
                      Object optionalObject,
                      Serializable optionalId)
               throws HibernateException
Throws:
HibernateException

getResultColumnOrRow

protected Object getResultColumnOrRow(Object[] row,
                                      ResultTransformer transformer,
                                      ResultSet rs,
                                      SessionImplementor session)
                               throws SQLException,
                                      HibernateException
Description copied from class: Loader
Get the actual object that is returned in the user-visible result list. This empty implementation merely returns its first argument. This is overridden by some subclasses.

Overrides:
getResultColumnOrRow in class Loader
Throws:
SQLException
HibernateException

isSingleRowLoader

protected boolean isSingleRowLoader()
Description copied from class: Loader
Return false is this loader is a batch entity loader

Overrides:
isSingleRowLoader in class Loader
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BatchingEntityLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.entity
Class BatchingEntityLoader

java.lang.Object
    extended by org.hibernate.loader.entity.BatchingEntityLoader
All Implemented Interfaces:
UniqueEntityLoader
public class BatchingEntityLoader
extends Object
implements UniqueEntityLoader

"Batch" loads entities, using multiple primary key values in the SQL where clause.

Author:
Gavin King
See Also:
EntityLoader

Constructor Summary
BatchingEntityLoader(EntityPersister persister, int[] batchSizes, Loader[] loaders)
Method Summary
static UniqueEntityLoader | createBatchingEntityLoader(OuterJoinLoadable persister, int maxBatchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
Object | load(Serializable id, Object optionalObject, SessionImplementor session) Load an entity instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BatchingEntityLoader

public BatchingEntityLoader(EntityPersister persister,
                            int[] batchSizes,
                            Loader[] loaders)
Method Detail

load

public Object load(Serializable id,
                   Object optionalObject,
                   SessionImplementor session)
            throws HibernateException
Description copied from interface: UniqueEntityLoader
Load an entity instance. If optionalObject is supplied, load the entity state into the given (uninitialized) object.

Specified by:
load in interface UniqueEntityLoader
Throws:
HibernateException

createBatchingEntityLoader

public static UniqueEntityLoader createBatchingEntityLoader(OuterJoinLoadable persister,
                                                            int maxBatchSize,
                                                            LockMode lockMode,
                                                            SessionFactoryImplementor factory,
                                                            Map enabledFilters)
                                                     throws MappingException
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CascadeEntityJoinWalker (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.entity
Class CascadeEntityJoinWalker

java.lang.Object
    extended by org.hibernate.loader.JoinWalker
        extended by org.hibernate.loader.AbstractEntityJoinWalker
            extended by org.hibernate.loader.entity.CascadeEntityJoinWalker
public class CascadeEntityJoinWalker
extends AbstractEntityJoinWalker

Field Summary
Fields inherited from class org.hibernate.loader.JoinWalker
aliases, associations, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Constructor Summary
CascadeEntityJoinWalker(OuterJoinLoadable persister, CascadingAction action, SessionFactoryImplementor factory)
Method Summary
String | getComment()
protected boolean | isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) The superclass deliberately excludes collections
protected boolean | isTooManyCollections()
Methods inherited from class org.hibernate.loader.AbstractEntityJoinWalker
getAlias, getPersister, getWhereFragment, initAll, initProjection, toString
Methods inherited from class org.hibernate.loader.JoinWalker
countCollectionPersisters, countEntityPersisters, generateRootAlias, generateTableAlias, getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getFactory, getJoinType, getJoinType, getLockModeArray, getOwnerAssociationTypes, getOwners, getPersisters, getSQLString, getSuffixes, initPersisters, isDuplicateAssociation, isDuplicateAssociation, isJoinable, isJoinedFetchEnabledInMapping, isTooDeep, mergeOrderings, mergeOuterJoins, orderBy, orderBy, selectString, setAliases, setCollectionOwners, setCollectionPersisters, setCollectionSuffixes, setLockModeArray, setOwnerAssociationTypes, setOwners, setPersisters, setSql, setSuffixes, walkCollectionTree, walkEntityTree, whereString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CascadeEntityJoinWalker

public CascadeEntityJoinWalker(OuterJoinLoadable persister,
                               CascadingAction action,
                               SessionFactoryImplementor factory)
                        throws MappingException
Method Detail

isJoinedFetchEnabled

protected boolean isJoinedFetchEnabled(AssociationType type,
                                       FetchMode config,
                                       CascadeStyle cascadeStyle)
Description copied from class: AbstractEntityJoinWalker
The superclass deliberately excludes collections

Overrides:
isJoinedFetchEnabled in class AbstractEntityJoinWalker

isTooManyCollections

protected boolean isTooManyCollections()
Overrides:
isTooManyCollections in class JoinWalker

getComment

public String getComment()
Specified by:
getComment in class AbstractEntityJoinWalker
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CascadeEntityLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.entity
Class CascadeEntityLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.loader.OuterJoinLoader
                extended by org.hibernate.loader.entity.AbstractEntityLoader
                    extended by org.hibernate.loader.entity.CascadeEntityLoader
All Implemented Interfaces:
UniqueEntityLoader
public class CascadeEntityLoader
extends AbstractEntityLoader

Field Summary
Fields inherited from class org.hibernate.loader.entity.AbstractEntityLoader
entityName, log, persister, uniqueKeyType
Fields inherited from class org.hibernate.loader.OuterJoinLoader
aliases, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX
Constructor Summary
CascadeEntityLoader(OuterJoinLoadable persister, CascadingAction action, SessionFactoryImplementor factory)
Methods inherited from class org.hibernate.loader.entity.AbstractEntityLoader
getResultColumnOrRow, isSingleRowLoader, load, load
Methods inherited from class org.hibernate.loader.OuterJoinLoader
getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getEntityPersisters, getLockModes, getOwnerAssociationTypes, getOwners, getSQLString, getSuffixes, initFromWalker
Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate
Methods inherited from class org.hibernate.loader.Loader
applyLocks, autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getEntityEagerPropertyFetches, getFactory, getNamedParameterLocs, getQueryIdentifier, getResultList, getResultSet, hasSubselectLoadableCollections, isSubselectLoadingEnabled, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll, toString, upgradeLocks
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CascadeEntityLoader

public CascadeEntityLoader(OuterJoinLoadable persister,
                           CascadingAction action,
                           SessionFactoryImplementor factory)
                    throws MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionElementLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.entity
Class CollectionElementLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.loader.OuterJoinLoader
                extended by org.hibernate.loader.entity.CollectionElementLoader
public class CollectionElementLoader
extends OuterJoinLoader

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.loader.OuterJoinLoader
aliases, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX
Constructor Summary
CollectionElementLoader(QueryableCollection collectionPersister, SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
protected Object | getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session) Get the actual object that is returned in the user-visible result list.
protected boolean | isSingleRowLoader() Return false is this loader is a batch entity loader
Object | loadElement(SessionImplementor session, Object key, Object index)
Methods inherited from class org.hibernate.loader.OuterJoinLoader
getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getEntityPersisters, getLockModes, getOwnerAssociationTypes, getOwners, getSQLString, getSuffixes, initFromWalker
Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate
Methods inherited from class org.hibernate.loader.Loader
applyLocks, autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getEntityEagerPropertyFetches, getFactory, getNamedParameterLocs, getQueryIdentifier, getResultList, getResultSet, hasSubselectLoadableCollections, isSubselectLoadingEnabled, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll, toString, upgradeLocks
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CollectionElementLoader

public CollectionElementLoader(QueryableCollection collectionPersister,
                               SessionFactoryImplementor factory,
                               Map enabledFilters)
                        throws MappingException
Method Detail

loadElement

public Object loadElement(SessionImplementor session,
                          Object key,
                          Object index)
                   throws HibernateException
Throws:
HibernateException

getResultColumnOrRow

protected Object getResultColumnOrRow(Object[] row,
                                      ResultTransformer transformer,
                                      ResultSet rs,
                                      SessionImplementor session)
                               throws SQLException,
                                      HibernateException
Description copied from class: Loader
Get the actual object that is returned in the user-visible result list. This empty implementation merely returns its first argument. This is overridden by some subclasses.

Overrides:
getResultColumnOrRow in class Loader
Throws:
SQLException
HibernateException

isSingleRowLoader

protected boolean isSingleRowLoader()
Description copied from class: Loader
Return false is this loader is a batch entity loader

Overrides:
isSingleRowLoader in class Loader
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityJoinWalker (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.entity
Class EntityJoinWalker

java.lang.Object
    extended by org.hibernate.loader.JoinWalker
        extended by org.hibernate.loader.AbstractEntityJoinWalker
            extended by org.hibernate.loader.entity.EntityJoinWalker
public class EntityJoinWalker
extends AbstractEntityJoinWalker

A walker for loaders that fetch entities

Author:
Gavin King
See Also:
EntityLoader

Field Summary
Fields inherited from class org.hibernate.loader.JoinWalker
aliases, associations, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Constructor Summary
EntityJoinWalker(OuterJoinLoadable persister, String[] uniqueKey, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
String | getComment()
protected boolean | isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) Disable outer join fetching if this loader obtains an upgrade lock mode
Methods inherited from class org.hibernate.loader.AbstractEntityJoinWalker
getAlias, getPersister, getWhereFragment, initAll, initProjection, toString
Methods inherited from class org.hibernate.loader.JoinWalker
countCollectionPersisters, countEntityPersisters, generateRootAlias, generateTableAlias, getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getFactory, getJoinType, getJoinType, getLockModeArray, getOwnerAssociationTypes, getOwners, getPersisters, getSQLString, getSuffixes, initPersisters, isDuplicateAssociation, isDuplicateAssociation, isJoinable, isJoinedFetchEnabledInMapping, isTooDeep, isTooManyCollections, mergeOrderings, mergeOuterJoins, orderBy, orderBy, selectString, setAliases, setCollectionOwners, setCollectionPersisters, setCollectionSuffixes, setLockModeArray, setOwnerAssociationTypes, setOwners, setPersisters, setSql, setSuffixes, walkCollectionTree, walkEntityTree, whereString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EntityJoinWalker

public EntityJoinWalker(OuterJoinLoadable persister,
                        String[] uniqueKey,
                        int batchSize,
                        LockMode lockMode,
                        SessionFactoryImplementor factory,
                        Map enabledFilters)
                 throws MappingException
Method Detail

isJoinedFetchEnabled

protected boolean isJoinedFetchEnabled(AssociationType type,
                                       FetchMode config,
                                       CascadeStyle cascadeStyle)
Disable outer join fetching if this loader obtains an upgrade lock mode

Overrides:
isJoinedFetchEnabled in class AbstractEntityJoinWalker

getComment

public String getComment()
Specified by:
getComment in class AbstractEntityJoinWalker
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.entity
Class EntityLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.loader.OuterJoinLoader
                extended by org.hibernate.loader.entity.AbstractEntityLoader
                    extended by org.hibernate.loader.entity.EntityLoader
All Implemented Interfaces:
UniqueEntityLoader
public class EntityLoader
extends AbstractEntityLoader

Loads an entity instance using outerjoin fetching to fetch associated entities.
The EntityPersister must implement Loadable. For other entities, create a customized subclass of Loader.

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.loader.entity.AbstractEntityLoader
entityName, log, persister, uniqueKeyType
Fields inherited from class org.hibernate.loader.OuterJoinLoader
aliases, collectionOwners, collectionPersisters, collectionSuffixes, lockModeArray, ownerAssociationTypes, owners, persisters, sql, suffixes
Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX
Constructor Summary
EntityLoader(OuterJoinLoadable persister, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityLoader(OuterJoinLoadable persister, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityLoader(OuterJoinLoadable persister, String[] uniqueKey, Type uniqueKeyType, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
Method Summary
protected boolean | isSingleRowLoader() Return false is this loader is a batch entity loader
Object | loadByUniqueKey(SessionImplementor session, Object key)
Methods inherited from class org.hibernate.loader.entity.AbstractEntityLoader
getResultColumnOrRow, load, load
Methods inherited from class org.hibernate.loader.OuterJoinLoader
getAliases, getCollectionOwners, getCollectionPersisters, getCollectionSuffixes, getDialect, getEnabledFilters, getEntityPersisters, getLockModes, getOwnerAssociationTypes, getOwners, getSQLString, getSuffixes, initFromWalker
Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate
Methods inherited from class org.hibernate.loader.Loader
applyLocks, autoDiscoverTypes, bindNamedParameters, bindPositionalParameters, checkScrollability, doList, getEntityEagerPropertyFetches, getFactory, getNamedParameterLocs, getQueryIdentifier, getResultList, getResultSet, hasSubselectLoadableCollections, isSubselectLoadingEnabled, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, needsFetchingScroll, prepareQueryStatement, preprocessSQL, scroll, toString, upgradeLocks
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EntityLoader

public EntityLoader(OuterJoinLoadable persister,
                    LockMode lockMode,
                    SessionFactoryImplementor factory,
                    Map enabledFilters)
             throws MappingException

EntityLoader

public EntityLoader(OuterJoinLoadable persister,
                    int batchSize,
                    LockMode lockMode,
                    SessionFactoryImplementor factory,
                    Map enabledFilters)
             throws MappingException

EntityLoader

public EntityLoader(OuterJoinLoadable persister,
                    String[] uniqueKey,
                    Type uniqueKeyType,
                    int batchSize,
                    LockMode lockMode,
                    SessionFactoryImplementor factory,
                    Map enabledFilters)
             throws MappingException
Method Detail

loadByUniqueKey

public Object loadByUniqueKey(SessionImplementor session,
                              Object key)
                       throws HibernateException
Throws:
HibernateException

isSingleRowLoader

protected boolean isSingleRowLoader()
Description copied from class: Loader
Return false is this loader is a batch entity loader

Overrides:
isSingleRowLoader in class AbstractEntityLoader
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.loader.hql (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.loader.hql

This package defines a loader for the AST-based query parser

See:
Description

Class Summary
QueryLoader A delegate that implements the Loader part of QueryTranslator.

Package org.hibernate.loader.hql Description

This package defines a loader for the AST-based query parser


org.hibernate.loader.hql Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.loader.hql

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.loader.Loader
      • class org.hibernate.loader.BasicLoader
        • class org.hibernate.loader.hql.QueryLoader


Uses of Package org.hibernate.loader.hql (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.loader.hql

No usage of org.hibernate.loader.hql

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


QueryLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.loader.hql
Class QueryLoader

java.lang.Object
    extended by org.hibernate.loader.Loader
        extended by org.hibernate.loader.BasicLoader
            extended by org.hibernate.loader.hql.QueryLoader
public class QueryLoader
extends BasicLoader

A delegate that implements the Loader part of QueryTranslator.

Author:
josh

Field Summary
Fields inherited from class org.hibernate.loader.BasicLoader
NO_SUFFIX
Constructor Summary
QueryLoader(QueryTranslator queryTranslator, SessionFactoryImplementor factory, SelectClause selectClause)
Creates a new Loader implementation.
Method Summary
protected String | applyLocks(String sql, Map lockModes, Dialect dialect) Append FOR UPDATE OF clause, if necessary.
protected int | bindNamedParameters(PreparedStatement ps, Map namedParams, int start, SessionImplementor session) Bind named parameters to the PreparedStatement.
String[] | getAliases() Get the SQL table aliases of entities whose associations are subselect-loadable, returning null if this loader does not support subselect loading
protected int[] | getCollectionOwners() Get the index of the entity that owns the collection, or -1 if there is no owner in the query results (ie.
protected CollectionPersister[] | getCollectionPersisters() An (optional) persister for a collection to be initialized; only collection loaders return a non-null value
String[] | getCollectionSuffixes()
protected boolean[] | getEntityEagerPropertyFetches() An array indicating whether the entities have eager property fetching enabled
Loadable[] | getEntityPersisters() An array of persisters of entity classes contained in each row of results; implemented by all subclasses
protected LockMode[] | getLockModes(Map lockModes) What lock mode does this load entities with?
int[] | getNamedParameterLocs(String name) Returns the locations of all occurrences of the named parameter.
protected EntityType[] | getOwnerAssociationTypes() An array of unique key property names by which the corresponding entities are referenced by other entities in the result set
protected int[] | getOwners() An array of indexes of the entity that owns a one-to-one association to the entity at the given index (-1 if there is no "owner")
protected String | getQueryIdentifier() Identifies the query for statistics reporting, if null, no statistics will be reported
protected Object | getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session) Get the actual object that is returned in the user-visible result list.
protected List | getResultList(List results, ResultTransformer resultTransformer)
String[] | getSqlAliasSuffixes()
protected String | getSQLString() The SQL query string to be called.
String[] | getSuffixes()
protected boolean | isSubselectLoadingEnabled()
Iterator | iterate(QueryParameters queryParameters, EventSource session) Return the query results as an iterator
List | list(SessionImplementor session, QueryParameters queryParameters) Delegats
protected boolean | needsFetchingScroll() Does the result set to be scrolled contain collection fetches?
ScrollableResults | scroll(QueryParameters queryParameters, SessionImplementor session)
protected boolean | upgradeLocks() Does this query return objects that might be already cached by the session, whose lock mode may need upgrading
void | validateScrollability()
Methods inherited from class org.hibernate.loader.BasicLoader
generateSuffixes, generateSuffixes, getCollectionAliases, getEntityAliases, postInstantiate
Methods inherited from class org.hibernate.loader.Loader
autoDiscoverTypes, bindPositionalParameters, checkScrollability, doList, getFactory, getResultSet, hasSubselectLoadableCollections, isSingleRowLoader, list, loadCollection, loadCollectionBatch, loadCollectionSubselect, loadEntity, loadEntity, loadEntityBatch, loadSequentialRowsForward, loadSequentialRowsReverse, loadSingleRow, prepareQueryStatement, preprocessSQL, scroll, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

QueryLoader

public QueryLoader(QueryTranslator queryTranslator,
                   SessionFactoryImplementor factory,
                   SelectClause selectClause)
Creates a new Loader implementation.

Parameters:
queryTranslator - The query translator that is the delegator.
factory - The factory from which this loader is being created.
Method Detail

validateScrollability

public final void validateScrollability()
                                 throws HibernateException
Throws:
HibernateException

needsFetchingScroll

protected boolean needsFetchingScroll()
Description copied from class: Loader
Does the result set to be scrolled contain collection fetches?

Overrides:
needsFetchingScroll in class Loader
Returns:
True if it does, and thus needs the special fetching scroll functionality; false otherwise.

getEntityPersisters

public Loadable[] getEntityPersisters()
Description copied from class: Loader
An array of persisters of entity classes contained in each row of results; implemented by all subclasses

Specified by:
getEntityPersisters in class Loader

getAliases

public String[] getAliases()
Description copied from class: Loader
Get the SQL table aliases of entities whose associations are subselect-loadable, returning null if this loader does not support subselect loading

Overrides:
getAliases in class Loader

getSqlAliasSuffixes

public String[] getSqlAliasSuffixes()

getSuffixes

public String[] getSuffixes()
Specified by:
getSuffixes in class BasicLoader

getCollectionSuffixes

public String[] getCollectionSuffixes()
Specified by:
getCollectionSuffixes in class BasicLoader

getQueryIdentifier

protected String getQueryIdentifier()
Description copied from class: Loader
Identifies the query for statistics reporting, if null, no statistics will be reported

Overrides:
getQueryIdentifier in class Loader

getSQLString

protected String getSQLString()
The SQL query string to be called.

Specified by:
getSQLString in class Loader

getCollectionPersisters

protected CollectionPersister[] getCollectionPersisters()
An (optional) persister for a collection to be initialized; only collection loaders return a non-null value

Overrides:
getCollectionPersisters in class Loader

getCollectionOwners

protected int[] getCollectionOwners()
Description copied from class: Loader
Get the index of the entity that owns the collection, or -1 if there is no owner in the query results (ie. in the case of a collection initializer) or no collection.

Overrides:
getCollectionOwners in class Loader

getEntityEagerPropertyFetches

protected boolean[] getEntityEagerPropertyFetches()
Description copied from class: Loader
An array indicating whether the entities have eager property fetching enabled

Overrides:
getEntityEagerPropertyFetches in class Loader

getOwners

protected int[] getOwners()
An array of indexes of the entity that owns a one-to-one association to the entity at the given index (-1 if there is no "owner")

Overrides:
getOwners in class Loader

getOwnerAssociationTypes

protected EntityType[] getOwnerAssociationTypes()
Description copied from class: Loader
An array of unique key property names by which the corresponding entities are referenced by other entities in the result set

Overrides:
getOwnerAssociationTypes in class Loader

isSubselectLoadingEnabled

protected boolean isSubselectLoadingEnabled()
Overrides:
isSubselectLoadingEnabled in class Loader

getLockModes

protected LockMode[] getLockModes(Map lockModes)
Description copied from class: Loader
What lock mode does this load entities with?

Specified by:
getLockModes in class Loader
Parameters:
lockModes - a collection of lock modes specified dynamically via the Query interface

applyLocks

protected String applyLocks(String sql,
                            Map lockModes,
                            Dialect dialect)
                     throws QueryException
Description copied from class: Loader
Append FOR UPDATE OF clause, if necessary. This empty superclass implementation merely returns its first argument.

Overrides:
applyLocks in class Loader
Throws:
QueryException

upgradeLocks

protected boolean upgradeLocks()
Description copied from class: Loader
Does this query return objects that might be already cached by the session, whose lock mode may need upgrading

Overrides:
upgradeLocks in class Loader

getResultColumnOrRow

protected Object getResultColumnOrRow(Object[] row,
                                      ResultTransformer transformer,
                                      ResultSet rs,
                                      SessionImplementor session)
                               throws SQLException,
                                      HibernateException
Description copied from class: Loader
Get the actual object that is returned in the user-visible result list. This empty implementation merely returns its first argument. This is overridden by some subclasses.

Overrides:
getResultColumnOrRow in class Loader
Throws:
SQLException
HibernateException

getResultList

protected List getResultList(List results,
                             ResultTransformer resultTransformer)
                      throws QueryException
Overrides:
getResultList in class Loader
Throws:
QueryException

list

public List list(SessionImplementor session,
                 QueryParameters queryParameters)
          throws HibernateException
Delegats

Parameters:
session -
queryParameters -
Returns:
Throws:
HibernateException

iterate

public Iterator iterate(QueryParameters queryParameters,
                        EventSource session)
                 throws HibernateException
Return the query results as an iterator

Throws:
HibernateException

scroll

public ScrollableResults scroll(QueryParameters queryParameters,
                                SessionImplementor session)
                         throws HibernateException
Throws:
HibernateException

getNamedParameterLocs

public int[] getNamedParameterLocs(String name)
                            throws QueryException
Returns the locations of all occurrences of the named parameter.

Overrides:
getNamedParameterLocs in class Loader
Throws:
QueryException

bindNamedParameters

protected int bindNamedParameters(PreparedStatement ps,
                                  Map namedParams,
                                  int start,
                                  SessionImplementor session)
                           throws SQLException,
                                  HibernateException
Description copied from class: Loader
Bind named parameters to the PreparedStatement. This has an empty implementation on this superclass and should be implemented by subclasses (queries) which allow named parameters.

Overrides:
bindNamedParameters in class Loader
Throws:
SQLException
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.lob (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.lob

This package defines dummy and wrapper implementations of java.sql.Clob and java.sql.Blob.

See:
Description

Class Summary
BlobImpl | A dummy implementation of java.sql.Blob that may be used to insert new data into a BLOB.
ClobImpl | A dummy implementation of java.sql.Clob that may be used to insert new data into a CLOB.
ReaderInputStream | Exposes a Reader as an InputStream
SerializableBlob |
SerializableClob |

Package org.hibernate.lob Description

This package defines dummy and wrapper implementations of java.sql.Clob and java.sql.Blob.


org.hibernate.lob Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.lob

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.lob.BlobImpl (implements java.sql.Blob)
    • class org.hibernate.lob.ClobImpl (implements java.sql.Clob)
    • class java.io.InputStream
      • class org.hibernate.lob.ReaderInputStream
    • class org.hibernate.lob.SerializableBlob (implements java.sql.Blob, java.io.Serializable)
    • class org.hibernate.lob.SerializableClob (implements java.sql.Clob, java.io.Serializable)


Uses of Package org.hibernate.lob (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.lob

No usage of org.hibernate.lob

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BlobImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.lob
Class BlobImpl

java.lang.Object
    extended by org.hibernate.lob.BlobImpl
All Implemented Interfaces:
Blob
public class BlobImpl
extends Object
implements Blob

A dummy implementation of java.sql.Blob that may be used to insert new data into a BLOB.

Author:
Gavin King

Constructor Summary
BlobImpl(byte[] bytes)
BlobImpl(InputStream stream, int length)
Method Summary
InputStream | getBinaryStream()
byte[] | getBytes(long pos, int len)
long | length()
long | position(Blob blob, long pos)
long | position(byte[] bytes, long pos)
OutputStream | setBinaryStream(long pos)
int | setBytes(long pos, byte[] bytes)
int | setBytes(long pos, byte[] bytes, int i, int j)
void | truncate(long pos)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BlobImpl

public BlobImpl(byte[] bytes)

BlobImpl

public BlobImpl(InputStream stream,
                int length)
Method Detail

length

public long length()
            throws SQLException
Specified by:
length in interface Blob
Throws:
SQLException
See Also:
Blob.length()

truncate

public void truncate(long pos)
              throws SQLException
Specified by:
truncate in interface Blob
Throws:
SQLException
See Also:
Blob.truncate(long)

getBytes

public byte[] getBytes(long pos,
                       int len)
                throws SQLException
Specified by:
getBytes in interface Blob
Throws:
SQLException
See Also:
Blob.getBytes(long, int)

setBytes

public int setBytes(long pos,
                    byte[] bytes)
             throws SQLException
Specified by:
setBytes in interface Blob
Throws:
SQLException
See Also:
Blob.setBytes(long, byte[])

setBytes

public int setBytes(long pos,
                    byte[] bytes,
                    int i,
                    int j)
             throws SQLException
Specified by:
setBytes in interface Blob
Throws:
SQLException
See Also:
Blob.setBytes(long, byte[], int, int)

position

public long position(byte[] bytes,
                     long pos)
              throws SQLException
Specified by:
position in interface Blob
Throws:
SQLException
See Also:
Blob.position(byte[], long)

getBinaryStream

public InputStream getBinaryStream()
                            throws SQLException
Specified by:
getBinaryStream in interface Blob
Throws:
SQLException
See Also:
Blob.getBinaryStream()

setBinaryStream

public OutputStream setBinaryStream(long pos)
                             throws SQLException
Specified by:
setBinaryStream in interface Blob
Throws:
SQLException
See Also:
Blob.setBinaryStream(long)

position

public long position(Blob blob,
                     long pos)
              throws SQLException
Specified by:
position in interface Blob
Throws:
SQLException
See Also:
Blob.position(Blob, long)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ClobImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.lob
Class ClobImpl

java.lang.Object
    extended by org.hibernate.lob.ClobImpl
All Implemented Interfaces:
Clob
public class ClobImpl
extends Object
implements Clob

A dummy implementation of java.sql.Clob that may be used to insert new data into a CLOB.

Author:
Gavin King

Constructor Summary
ClobImpl(Reader reader, int length)
ClobImpl(String string)
Method Summary
InputStream | getAsciiStream()
Reader | getCharacterStream()
String | getSubString(long pos, int len)
long | length()
long | position(Clob colb, long pos)
long | position(String string, long pos)
OutputStream | setAsciiStream(long pos)
Writer | setCharacterStream(long pos)
int | setString(long pos, String string)
int | setString(long pos, String string, int i, int j)
void | truncate(long pos)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClobImpl

public ClobImpl(String string)

ClobImpl

public ClobImpl(Reader reader,
                int length)
Method Detail

length

public long length()
            throws SQLException
Specified by:
length in interface Clob
Throws:
SQLException
See Also:
Clob.length()

truncate

public void truncate(long pos)
              throws SQLException
Specified by:
truncate in interface Clob
Throws:
SQLException
See Also:
Clob.truncate(long)

getAsciiStream

public InputStream getAsciiStream()
                           throws SQLException
Specified by:
getAsciiStream in interface Clob
Throws:
SQLException
See Also:
Clob.getAsciiStream()

setAsciiStream

public OutputStream setAsciiStream(long pos)
                            throws SQLException
Specified by:
setAsciiStream in interface Clob
Throws:
SQLException
See Also:
Clob.setAsciiStream(long)

getCharacterStream

public Reader getCharacterStream()
                          throws SQLException
Specified by:
getCharacterStream in interface Clob
Throws:
SQLException
See Also:
Clob.getCharacterStream()

setCharacterStream

public Writer setCharacterStream(long pos)
                          throws SQLException
Specified by:
setCharacterStream in interface Clob
Throws:
SQLException
See Also:
Clob.setCharacterStream(long)

getSubString

public String getSubString(long pos,
                           int len)
                    throws SQLException
Specified by:
getSubString in interface Clob
Throws:
SQLException
See Also:
Clob.getSubString(long, int)

setString

public int setString(long pos,
                     String string)
              throws SQLException
Specified by:
setString in interface Clob
Throws:
SQLException
See Also:
Clob.setString(long, String)

setString

public int setString(long pos,
                     String string,
                     int i,
                     int j)
              throws SQLException
Specified by:
setString in interface Clob
Throws:
SQLException
See Also:
Clob.setString(long, String, int, int)

position

public long position(String string,
                     long pos)
              throws SQLException
Specified by:
position in interface Clob
Throws:
SQLException
See Also:
Clob.position(String, long)

position

public long position(Clob colb,
                     long pos)
              throws SQLException
Specified by:
position in interface Clob
Throws:
SQLException
See Also:
Clob.position(Clob, long)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReaderInputStream (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.lob
Class ReaderInputStream

java.lang.Object
    extended by java.io.InputStream
        extended by org.hibernate.lob.ReaderInputStream
public class ReaderInputStream
extends InputStream

Exposes a Reader as an InputStream

Author:
Gavin King

Constructor Summary
ReaderInputStream(Reader reader)
Method Summary
 int read()
Methods inherited from class java.io.InputStream
available, close, mark, markSupported, read, read, reset, skip
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReaderInputStream

public ReaderInputStream(Reader reader)
Method Detail

read

public int read()
         throws IOException
Throws:
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SerializableBlob (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.lob
Class SerializableBlob

java.lang.Object
    extended by org.hibernate.lob.SerializableBlob
All Implemented Interfaces:
Blob, Serializable
public class SerializableBlob
extends Object
implements Serializable, Blob

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
SerializableBlob(Blob blob)
Method Summary
InputStream | getBinaryStream()
byte[] | getBytes(long pos, int length)
Blob | getWrappedBlob()
long | length()
long | position(Blob pattern, long start)
long | position(byte[] pattern, long start)
OutputStream | setBinaryStream(long pos)
int | setBytes(long pos, byte[] bytes)
int | setBytes(long pos, byte[] bytes, int offset, int len)
void | truncate(long len)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SerializableBlob

public SerializableBlob(Blob blob)
Method Detail

getWrappedBlob

public Blob getWrappedBlob()

length

public long length()
            throws SQLException
Specified by:
length in interface Blob
Throws:
SQLException

getBytes

public byte[] getBytes(long pos,
                       int length)
                throws SQLException
Specified by:
getBytes in interface Blob
Throws:
SQLException

getBinaryStream

public InputStream getBinaryStream()
                            throws SQLException
Specified by:
getBinaryStream in interface Blob
Throws:
SQLException

position

public long position(byte[] pattern,
                     long start)
              throws SQLException
Specified by:
position in interface Blob
Throws:
SQLException

position

public long position(Blob pattern,
                     long start)
              throws SQLException
Specified by:
position in interface Blob
Throws:
SQLException

setBytes

public int setBytes(long pos,
                    byte[] bytes)
             throws SQLException
Specified by:
setBytes in interface Blob
Throws:
SQLException

setBytes

public int setBytes(long pos,
                    byte[] bytes,
                    int offset,
                    int len)
             throws SQLException
Specified by:
setBytes in interface Blob
Throws:
SQLException

setBinaryStream

public OutputStream setBinaryStream(long pos)
                             throws SQLException
Specified by:
setBinaryStream in interface Blob
Throws:
SQLException

truncate

public void truncate(long len)
              throws SQLException
Specified by:
truncate in interface Blob
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SerializableClob (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.lob
Class SerializableClob

java.lang.Object
    extended by org.hibernate.lob.SerializableClob
All Implemented Interfaces:
Clob, Serializable
public class SerializableClob
extends Object
implements Serializable, Clob

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
SerializableClob(Clob blob)
Method Summary
InputStream | getAsciiStream()
Reader | getCharacterStream()
String | getSubString(long pos, int length)
Clob | getWrappedClob()
long | length()
long | position(Clob searchstr, long start)
long | position(String searchstr, long start)
OutputStream | setAsciiStream(long pos)
Writer | setCharacterStream(long pos)
int | setString(long pos, String str)
int | setString(long pos, String str, int offset, int len)
void | truncate(long len)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SerializableClob

public SerializableClob(Clob blob)
Method Detail

getWrappedClob

public Clob getWrappedClob()

length

public long length()
            throws SQLException
Specified by:
length in interface Clob
Throws:
SQLException

getSubString

public String getSubString(long pos,
                           int length)
                    throws SQLException
Specified by:
getSubString in interface Clob
Throws:
SQLException

getCharacterStream

public Reader getCharacterStream()
                          throws SQLException
Specified by:
getCharacterStream in interface Clob
Throws:
SQLException

getAsciiStream

public InputStream getAsciiStream()
                           throws SQLException
Specified by:
getAsciiStream in interface Clob
Throws:
SQLException

position

public long position(String searchstr,
                     long start)
              throws SQLException
Specified by:
position in interface Clob
Throws:
SQLException

position

public long position(Clob searchstr,
                     long start)
              throws SQLException
Specified by:
position in interface Clob
Throws:
SQLException

setString

public int setString(long pos,
                     String str)
              throws SQLException
Specified by:
setString in interface Clob
Throws:
SQLException

setString

public int setString(long pos,
                     String str,
                     int offset,
                     int len)
              throws SQLException
Specified by:
setString in interface Clob
Throws:
SQLException

setAsciiStream

public OutputStream setAsciiStream(long pos)
                            throws SQLException
Specified by:
setAsciiStream in interface Clob
Throws:
SQLException

setCharacterStream

public Writer setCharacterStream(long pos)
                          throws SQLException
Specified by:
setCharacterStream in interface Clob
Throws:
SQLException

truncate

public void truncate(long len)
              throws SQLException
Specified by:
truncate in interface Clob
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.mapping (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.mapping

This package defines the Hibernate configuration-time metamodel.

See:
Description

Interface Summary
AuxiliaryDatabaseObject | Auxiliary database objects (i.e., triggers, stored procedures, etc) defined in the mappings.
Fetchable | Any mapping with an outer-join attribute
Filterable | Defines mapping elements to which filters may be applied.
KeyValue | Represents an identifying key of a table: the value for primary key of an entity, or a foreign key of a collection or join table or joined subclass table.
MetaAttributable | Common interface for things that can handle meta attributes.
PersistentClassVisitor |
RelationalModel | A relational object which may be created using DDL
Selectable |
TableOwner | Interface allowing to differenciate SubClasses from Classes, JoinedSubClasses and UnionSubClasses The first one has not its own table while the others have
Value | A value is anything that is persisted by value, instead of by reference.
ValueVisitor |

Class Summary
AbstractAuxiliaryDatabaseObject | Convenience base class for AuxiliaryDatabaseObjects.
Any | A Hibernate "any" type (ie.
Array | An array mapping has a primary key consisting of the key columns + index column.
Backref |
Bag | A bag permits duplicates, so it has no primary key
Collection | Mapping for a collection.
Column | A column of a relational database table
Component | The mapping for a component, composite element, composite identifier, etc.
Constraint | A relational constraint.
DenormalizedTable |
DependantValue | A value which is "typed" by reference to some other value (for example, a foreign key is typed by the referenced primary key).
ForeignKey | A foreign key constraint
Formula | A formula is a derived column value
IdentifierBag | An IdentifierBag has a primary key consisting of just the identifier column
IdentifierCollection | A collection with a synthetic "identifier" column
Index | A relational table index
IndexBackref |
IndexedCollection | Indexed collections include Lists, Maps, arrays and primitive arrays.
Join |
JoinedSubclass | A subclass in a table-per-subclass mapping
List | A list mapping has a primary key consisting of the key columns + index column.
ManyToOne | A many-to-one association mapping
Map | A map has a primary key consisting of the key columns + index columns.
MetaAttribute | A meta attribute is a named value or values.
OneToMany | A mapping for a one-to-many association
OneToOne | A one-to-one association mapping
PersistentClass | Mapping for an entity.
PrimaryKey | A primary key constraint
PrimitiveArray | A primitive array has a primary key consisting of the key columns + index column.
Property | Represents a property as part of an entity or a component.
PropertyGeneration | Indicates whether given properties are generated by the database and, if so, at what time(s) they are generated.
RootClass | The root class of an inheritance hierarchy
Set | A set with no nullable element columns.
SimpleAuxiliaryDatabaseObject | A simple implementation of AbstractAuxiliaryDatabaseObject in which the CREATE and DROP strings are provided up front.
SimpleValue | Any value that maps to columns.
SingleTableSubclass |
Subclass | A sublass in a table-per-class-hierarchy mapping
Table | A relational table
ToOne | A simple-point association (ie.
TypeDef | Placeholder for typedef information
UnionSubclass | A subclass in a table-per-concrete-class mapping
UniqueKey | A relational unique key constraint

Package org.hibernate.mapping Description

This package defines the Hibernate configuration-time metamodel.


org.hibernate.mapping Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.mapping

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.mapping.AbstractAuxiliaryDatabaseObject (implements org.hibernate.mapping.AuxiliaryDatabaseObject)
      • class org.hibernate.mapping.SimpleAuxiliaryDatabaseObject
    • class org.hibernate.mapping.Collection (implements org.hibernate.mapping.Fetchable, org.hibernate.mapping.Filterable, org.hibernate.mapping.Value)
      • class org.hibernate.mapping.Bag
      • class org.hibernate.mapping.IdentifierCollection
        • class org.hibernate.mapping.IdentifierBag
      • class org.hibernate.mapping.IndexedCollection
        • class org.hibernate.mapping.List
          • class org.hibernate.mapping.Array
            • class org.hibernate.mapping.PrimitiveArray
        • class org.hibernate.mapping.Map
      • class org.hibernate.mapping.Set
    • class org.hibernate.mapping.Column (implements java.lang.Cloneable, org.hibernate.mapping.Selectable, java.io.Serializable)
    • class org.hibernate.mapping.Constraint (implements org.hibernate.mapping.RelationalModel, java.io.Serializable)
      • class org.hibernate.mapping.ForeignKey
      • class org.hibernate.mapping.PrimaryKey
      • class org.hibernate.mapping.UniqueKey
    • class org.hibernate.mapping.Formula (implements org.hibernate.mapping.Selectable, java.io.Serializable)
    • class org.hibernate.mapping.Index (implements org.hibernate.mapping.RelationalModel, java.io.Serializable)
    • class org.hibernate.mapping.Join (implements java.io.Serializable)
    • class org.hibernate.mapping.MetaAttribute (implements java.io.Serializable)
    • class org.hibernate.mapping.OneToMany (implements org.hibernate.mapping.Value)
    • class org.hibernate.mapping.PersistentClass (implements org.hibernate.mapping.Filterable, org.hibernate.mapping.MetaAttributable, java.io.Serializable)
      • class org.hibernate.mapping.RootClass (implements org.hibernate.mapping.TableOwner)
      • class org.hibernate.mapping.Subclass
        • class org.hibernate.mapping.JoinedSubclass (implements org.hibernate.mapping.TableOwner)
        • class org.hibernate.mapping.SingleTableSubclass
        • class org.hibernate.mapping.UnionSubclass (implements org.hibernate.mapping.TableOwner)
    • class org.hibernate.mapping.Property (implements org.hibernate.mapping.MetaAttributable, java.io.Serializable)
      • class org.hibernate.mapping.Backref
      • class org.hibernate.mapping.IndexBackref
    • class org.hibernate.mapping.PropertyGeneration (implements java.io.Serializable)
    • class org.hibernate.mapping.SimpleValue (implements org.hibernate.mapping.KeyValue)
      • class org.hibernate.mapping.Any
      • class org.hibernate.mapping.Component (implements org.hibernate.mapping.MetaAttributable)
      • class org.hibernate.mapping.DependantValue
      • class org.hibernate.mapping.ToOne (implements org.hibernate.mapping.Fetchable)
        • class org.hibernate.mapping.ManyToOne
        • class org.hibernate.mapping.OneToOne
    • class org.hibernate.mapping.Table (implements org.hibernate.mapping.RelationalModel, java.io.Serializable)
      • class org.hibernate.mapping.DenormalizedTable
    • class org.hibernate.mapping.TypeDef (implements java.io.Serializable)

Interface Hierarchy

  • interface org.hibernate.mapping.Fetchable
  • interface org.hibernate.mapping.Filterable
  • interface org.hibernate.mapping.MetaAttributable
  • interface org.hibernate.mapping.PersistentClassVisitor
  • interface org.hibernate.mapping.RelationalModel
    • interface org.hibernate.mapping.AuxiliaryDatabaseObject (also extends java.io.Serializable)
  • interface org.hibernate.mapping.Selectable
  • interface java.io.Serializable
    • interface org.hibernate.mapping.AuxiliaryDatabaseObject (also extends org.hibernate.mapping.RelationalModel)
    • interface org.hibernate.mapping.Value
      • interface org.hibernate.mapping.KeyValue
  • interface org.hibernate.mapping.TableOwner
  • interface org.hibernate.mapping.ValueVisitor


Uses of Package org.hibernate.mapping (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.mapping

Packages that use org.hibernate.mapping
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |

Classes in org.hibernate.mapping used by org.hibernate.cfg
Any
A Hibernate "any" type (ie.
Array
An array mapping has a primary key consisting of the key columns + index column.
AuxiliaryDatabaseObject
Auxiliary database objects (i.e., triggers, stored procedures, etc) defined in the mappings.
Collection
Mapping for a collection.
Column
A column of a relational database table
Component
The mapping for a component, composite element, composite identifier, etc.
IdentifierCollection
A collection with a synthetic "identifier" column
JoinedSubclass
A subclass in a table-per-subclass mapping
List
A list mapping has a primary key consisting of the key columns + index column.
ManyToOne
A many-to-one association mapping
Map
A map has a primary key consisting of the key columns + index columns.
OneToMany
A mapping for a one-to-many association
OneToOne
A one-to-one association mapping
PersistentClass
Mapping for an entity.
Property
Represents a property as part of an entity or a component.
RootClass
The root class of an inheritance hierarchy
SimpleValue
Any value that maps to columns.
Subclass
A sublass in a table-per-class-hierarchy mapping
Table
A relational table
TypeDef
Placeholder for typedef information
UnionSubclass
A subclass in a table-per-concrete-class mapping
UniqueKey
A relational unique key constraint

Classes in org.hibernate.mapping used by org.hibernate.mapping
AbstractAuxiliaryDatabaseObject
Convenience base class for AuxiliaryDatabaseObjects.
Any
A Hibernate "any" type (ie.
Array
An array mapping has a primary key consisting of the key columns + index column.
AuxiliaryDatabaseObject
Auxiliary database objects (i.e., triggers, stored procedures, etc) defined in the mappings.
Bag
A bag permits duplicates, so it has no primary key
Collection
Mapping for a collection.
Column
A column of a relational database table
Component
The mapping for a component, composite element, composite identifier, etc.
Constraint
A relational constraint.
DependantValue
A value which is "typed" by reference to some other value (for example, a foreign key is typed by the referenced primary key).
Fetchable
Any mapping with an outer-join attribute
Filterable
Defines mapping elements to which filters may be applied.
ForeignKey
A foreign key constraint
Formula
A formula is a derived column value
IdentifierBag
An IdentifierBag has a primary key consisting of just the identifier column
IdentifierCollection
A collection with a synthetic "identifier" column
Index
A relational table index
IndexedCollection
Indexed collections include Lists, Maps, arrays and primitive arrays.
Join
JoinedSubclass
A subclass in a table-per-subclass mapping
KeyValue
Represents an identifying key of a table: the value for primary key of an entity, or a foreign key of a collection or join table or joined subclass table.
List
A list mapping has a primary key consisting of the key columns + index column.
ManyToOne
A many-to-one association mapping
Map
A map has a primary key consisting of the key columns + index columns.
MetaAttributable
Common interface for things that can handle meta attributes.
MetaAttribute
A meta attribute is a named value or values.
OneToMany
A mapping for a one-to-many association
OneToOne
A one-to-one association mapping
PersistentClass
Mapping for an entity.
PersistentClassVisitor
PrimaryKey
A primary key constraint
PrimitiveArray
A primitive array has a primary key consisting of the key columns + index column.
Property
Represents a property as part of an entity or a component.
PropertyGeneration
Indicates whether given properties are generated by the database and, if so, at what time(s) they are generated.
RelationalModel
A relational object which may be created using DDL
RootClass
The root class of an inheritance hierarchy
Selectable
Set
A set with no nullable element columns.
SimpleValue
Any value that maps to columns.
SingleTableSubclass
Subclass
A sublass in a table-per-class-hierarchy mapping
Table
A relational table
TableOwner
Interface allowing to differenciate SubClasses from Classes, JoinedSubClasses and UnionSubClasses The first one has not its own table while the others have
ToOne
A simple-point association (ie.
UnionSubclass
A subclass in a table-per-concrete-class mapping
UniqueKey
A relational unique key constraint
Value
A value is anything that is persisted by value, instead of by reference.
ValueVisitor

Classes in org.hibernate.mapping used by org.hibernate.persister
Collection
Mapping for a collection.
PersistentClass
Mapping for an entity.

Classes in org.hibernate.mapping used by org.hibernate.persister.collection
Collection
Mapping for a collection.

Classes in org.hibernate.mapping used by org.hibernate.persister.entity
PersistentClass
Mapping for an entity.

Classes in org.hibernate.mapping used by org.hibernate.property
Property
Represents a property as part of an entity or a component.

Classes in org.hibernate.mapping used by org.hibernate.tuple
Component
The mapping for a component, composite element, composite identifier, etc.
PersistentClass
Mapping for an entity.
Property
Represents a property as part of an entity or a component.

Classes in org.hibernate.mapping used by org.hibernate.tuple.component
Component
The mapping for a component, composite element, composite identifier, etc.
Property
Represents a property as part of an entity or a component.

Classes in org.hibernate.mapping used by org.hibernate.tuple.entity
PersistentClass
Mapping for an entity.
Property
Represents a property as part of an entity or a component.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AuxiliaryDatabaseObject (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Interface AuxiliaryDatabaseObject

All Superinterfaces:
RelationalModel, Serializable
All Known Implementing Classes:
AbstractAuxiliaryDatabaseObject
public interface AuxiliaryDatabaseObject
extends RelationalModel, Serializable

Auxiliary database objects (i.e., triggers, stored procedures, etc) defined in the mappings. Allows Hibernate to manage their lifecycle as part of creating/dropping the schema.

Author:
Steve Ebersole

Method Summary
void | addDialectScope(String dialectName) Add the given dialect name to the scope of dialects to which this database object applies.
boolean | appliesToDialect(Dialect dialect) Does this database object apply to the given dialect?
Methods inherited from interface org.hibernate.mapping.RelationalModel
sqlCreateString, sqlDropString

Method Detail

addDialectScope

public void addDialectScope(String dialectName)
Add the given dialect name to the scope of dialects to which this database object applies.

Parameters:
dialectName - The name of a dialect.

appliesToDialect

public boolean appliesToDialect(Dialect dialect)
Does this database object apply to the given dialect?

Parameters:
dialect - The dialect to check against.
Returns:
True if this database object does apply to the given dialect.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Fetchable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Interface Fetchable

All Known Implementing Classes:
Collection, ToOne
public interface Fetchable

Any mapping with an outer-join attribute

Author:
Gavin King

Method Summary
FetchMode | getFetchMode()
boolean | isLazy()
void | setFetchMode(FetchMode joinedFetch)
void | setLazy(boolean lazy)

Method Detail

getFetchMode

public FetchMode getFetchMode()

setFetchMode

public void setFetchMode(FetchMode joinedFetch)

isLazy

public boolean isLazy()

setLazy

public void setLazy(boolean lazy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Filterable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Interface Filterable

All Known Implementing Classes:
Collection, PersistentClass
public interface Filterable

Defines mapping elements to which filters may be applied.

Author:
Steve Ebersole

Method Summary
void | addFilter(String name, String condition)
Map | getFilterMap()

Method Detail

addFilter

public void addFilter(String name,
                      String condition)

getFilterMap

public Map getFilterMap()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


KeyValue (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Interface KeyValue

All Superinterfaces:
Serializable, Value
All Known Implementing Classes:
SimpleValue
public interface KeyValue
extends Value

Represents an identifying key of a table: the value for primary key of an entity, or a foreign key of a collection or join table or joined subclass table.

Author:
Gavin King

Method Summary
void | createForeignKeyOfEntity(String entityName)
IdentifierGenerator | createIdentifierGenerator(Dialect dialect, String defaultCatalog, String defaultSchema, RootClass rootClass)
String | getNullValue()
boolean | isCascadeDeleteEnabled()
boolean | isIdentityColumn(Dialect dialect)
boolean | isUpdateable()
Methods inherited from interface org.hibernate.mapping.Value
accept, createForeignKey, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getFetchMode, getTable, getType, hasFormula, isAlternateUniqueKey, isNullable, isSimpleValue, isValid, setTypeUsingReflection

Method Detail

createForeignKeyOfEntity

public void createForeignKeyOfEntity(String entityName)

isCascadeDeleteEnabled

public boolean isCascadeDeleteEnabled()

isIdentityColumn

public boolean isIdentityColumn(Dialect dialect)

getNullValue

public String getNullValue()

isUpdateable

public boolean isUpdateable()

createIdentifierGenerator

public IdentifierGenerator createIdentifierGenerator(Dialect dialect,
                                                     String defaultCatalog,
                                                     String defaultSchema,
                                                     RootClass rootClass)
                                              throws MappingException
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MetaAttributable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Interface MetaAttributable

All Known Implementing Classes:
Component, PersistentClass, Property
public interface MetaAttributable

Common interface for things that can handle meta attributes.

Since:
3.0.1

Method Summary
MetaAttribute | getMetaAttribute(String name)
Map | getMetaAttributes()
void | setMetaAttributes(Map metas)

Method Detail

getMetaAttributes

public Map getMetaAttributes()

setMetaAttributes

public void setMetaAttributes(Map metas)

getMetaAttribute

public MetaAttribute getMetaAttribute(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentClassVisitor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Interface PersistentClassVisitor

public interface PersistentClassVisitor

Author:
max

Method Summary
Object | accept(JoinedSubclass subclass)
Object | accept(RootClass class1)
Object | accept(SingleTableSubclass subclass)
Object | accept(Subclass subclass)
Object | accept(UnionSubclass subclass)

Method Detail

accept

public Object accept(RootClass class1)
Parameters:
class1 -
Returns:

accept

public Object accept(UnionSubclass subclass)
Parameters:
subclass -
Returns:

accept

public Object accept(SingleTableSubclass subclass)
Parameters:
subclass -
Returns:

accept

public Object accept(JoinedSubclass subclass)
Parameters:
subclass -
Returns:

accept

public Object accept(Subclass subclass)
Parameters:
subclass -
Returns:
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RelationalModel (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Interface RelationalModel

All Known Subinterfaces:
AuxiliaryDatabaseObject
All Known Implementing Classes:
AbstractAuxiliaryDatabaseObject, Constraint, Index, Table
public interface RelationalModel

A relational object which may be created using DDL

Author:
Gavin King

Method Summary
String | sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
String | sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)

Method Detail

sqlCreateString

public String sqlCreateString(Dialect dialect,
                              Mapping p,
                              String defaultCatalog,
                              String defaultSchema)
                       throws HibernateException
Throws:
HibernateException

sqlDropString

public String sqlDropString(Dialect dialect,
                            String defaultCatalog,
                            String defaultSchema)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Selectable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Interface Selectable

All Known Implementing Classes:
Column, Formula
public interface Selectable

Method Summary
String | getAlias(Dialect dialect)
String | getAlias(Dialect dialect, Table table)
String | getTemplate(Dialect dialect, SQLFunctionRegistry functionRegistry)
String | getText()
String | getText(Dialect dialect)
boolean | isFormula()

Method Detail

getAlias

public String getAlias(Dialect dialect)

getAlias

public String getAlias(Dialect dialect,
                       Table table)

isFormula

public boolean isFormula()

getTemplate

public String getTemplate(Dialect dialect,
                          SQLFunctionRegistry functionRegistry)

getText

public String getText(Dialect dialect)

getText

public String getText()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableOwner (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Interface TableOwner

All Known Implementing Classes:
JoinedSubclass, RootClass, UnionSubclass
public interface TableOwner

Interface allowing to differenciate SubClasses from Classes, JoinedSubClasses and UnionSubClasses The first one has not its own table while the others have

Author:
Emmanuel Bernard

Method Summary
 void setTable(Table table)

Method Detail

setTable

public void setTable(Table table)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Value (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Interface Value

All Superinterfaces:
Serializable
All Known Subinterfaces:
KeyValue
All Known Implementing Classes:
Collection, OneToMany, SimpleValue
public interface Value
extends Serializable

A value is anything that is persisted by value, instead of by reference. It is essentially a Hibernate Type, together with zero or more columns. Values are wrapped by things with higher level semantics, for example properties, collections, classes.

Author:
Gavin King

Method Summary
Object | accept(ValueVisitor visitor)
void | createForeignKey()
boolean[] | getColumnInsertability()
Iterator | getColumnIterator()
int | getColumnSpan()
boolean[] | getColumnUpdateability()
FetchMode | getFetchMode()
Table | getTable()
Type | getType()
boolean | hasFormula()
boolean | isAlternateUniqueKey()
boolean | isNullable()
boolean | isSimpleValue()
boolean | isValid(Mapping mapping)
void | setTypeUsingReflection(String className, String propertyName)

Method Detail

getColumnSpan

public int getColumnSpan()

getColumnIterator

public Iterator getColumnIterator()

getType

public Type getType()
             throws MappingException
Throws:
MappingException

getFetchMode

public FetchMode getFetchMode()

getTable

public Table getTable()

hasFormula

public boolean hasFormula()

isAlternateUniqueKey

public boolean isAlternateUniqueKey()

isNullable

public boolean isNullable()

getColumnUpdateability

public boolean[] getColumnUpdateability()

getColumnInsertability

public boolean[] getColumnInsertability()

createForeignKey

public void createForeignKey()
                      throws MappingException
Throws:
MappingException

isSimpleValue

public boolean isSimpleValue()

isValid

public boolean isValid(Mapping mapping)
                throws MappingException
Throws:
MappingException

setTypeUsingReflection

public void setTypeUsingReflection(String className,
                                   String propertyName)
                            throws MappingException
Throws:
MappingException

accept

public Object accept(ValueVisitor visitor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValueVisitor (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Interface ValueVisitor

public interface ValueVisitor

Author:
max

Method Summary
Object | accept(Any any)
Object | accept(Array list)
Object | accept(Bag bag)
Object | accept(Component component)
Object | accept(DependantValue value)
Object | accept(IdentifierBag bag)
Object | accept(List list)
Object | accept(ManyToOne mto)
Object | accept(Map map)
Object | accept(OneToMany many)
Object | accept(OneToOne oto)
Object | accept(PrimitiveArray primitiveArray)
Object | accept(Set set)
Object | accept(SimpleValue value)

Method Detail

accept

public Object accept(Bag bag)
Parameters:
bag -

accept

public Object accept(IdentifierBag bag)
Parameters:
bag -

accept

public Object accept(List list)
Parameters:
list -

accept

public Object accept(PrimitiveArray primitiveArray)

accept

public Object accept(Array list)

accept

public Object accept(Map map)
Parameters:
map -

accept

public Object accept(OneToMany many)
Parameters:
many -

accept

public Object accept(Set set)
Parameters:
set -

accept

public Object accept(Any any)
Parameters:
any -

accept

public Object accept(SimpleValue value)
Parameters:
value -

accept

public Object accept(DependantValue value)

accept

public Object accept(Component component)

accept

public Object accept(ManyToOne mto)

accept

public Object accept(OneToOne oto)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractAuxiliaryDatabaseObject (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class AbstractAuxiliaryDatabaseObject

java.lang.Object
    extended by org.hibernate.mapping.AbstractAuxiliaryDatabaseObject
All Implemented Interfaces:
AuxiliaryDatabaseObject, RelationalModel, Serializable
Direct Known Subclasses:
SimpleAuxiliaryDatabaseObject
public abstract class AbstractAuxiliaryDatabaseObject
extends Object
implements AuxiliaryDatabaseObject

Convenience base class for AuxiliaryDatabaseObjects.

This implementation performs dialect scoping checks strictly based on dialect name comparisons. Custom implementations might want to do instanceof-type checks.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
protected | AbstractAuxiliaryDatabaseObject()
protected | AbstractAuxiliaryDatabaseObject(HashSet dialectScopes)
Method Summary
void | addDialectScope(String dialectName) Add the given dialect name to the scope of dialects to which this database object applies.
boolean | appliesToDialect(Dialect dialect) Does this database object apply to the given dialect?
HashSet | getDialectScopes()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.mapping.RelationalModel
sqlCreateString, sqlDropString

Constructor Detail

AbstractAuxiliaryDatabaseObject

protected AbstractAuxiliaryDatabaseObject()

AbstractAuxiliaryDatabaseObject

protected AbstractAuxiliaryDatabaseObject(HashSet dialectScopes)
Method Detail

addDialectScope

public void addDialectScope(String dialectName)
Description copied from interface: AuxiliaryDatabaseObject
Add the given dialect name to the scope of dialects to which this database object applies.

Specified by:
addDialectScope in interface AuxiliaryDatabaseObject
Parameters:
dialectName - The name of a dialect.

getDialectScopes

public HashSet getDialectScopes()

appliesToDialect

public boolean appliesToDialect(Dialect dialect)
Description copied from interface: AuxiliaryDatabaseObject
Does this database object apply to the given dialect?

Specified by:
appliesToDialect in interface AuxiliaryDatabaseObject
Parameters:
dialect - The dialect to check against.
Returns:
True if this database object does apply to the given dialect.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Any (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Any

java.lang.Object
    extended by org.hibernate.mapping.SimpleValue
        extended by org.hibernate.mapping.Any
All Implemented Interfaces:
KeyValue, Serializable, Value
public class Any
extends SimpleValue

A Hibernate "any" type (ie. polymorphic association to one-of-several tables).

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
Any(Table table)
Method Summary
Object | accept(ValueVisitor visitor)
String | getIdentifierType()
String | getMetaType()
Map | getMetaValues()
Type | getType()
void | setIdentifierType(String identifierType)
void | setMetaType(String type)
void | setMetaValues(Map metaValues)
void | setTypeByReflection(String propertyClass, String propertyName)
void | setTypeUsingReflection(String className, String propertyName)
Methods inherited from class org.hibernate.mapping.SimpleValue
addColumn, addFormula, createForeignKey, createForeignKeyOfEntity, createIdentifierGenerator, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getConstraintColumns, getFetchMode, getForeignKeyName, getIdentifierGeneratorProperties, getIdentifierGeneratorStrategy, getNullValue, getTable, getTypeName, getTypeParameters, hasFormula, isAlternateUniqueKey, isCascadeDeleteEnabled, isIdentityColumn, isNullable, isSimpleValue, isTypeSpecified, isUpdateable, isValid, setAlternateUniqueKey, setCascadeDeleteEnabled, setForeignKeyName, setIdentifierGeneratorProperties, setIdentifierGeneratorStrategy, setNullValue, setTable, setTypeName, setTypeParameters, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Any

public Any(Table table)
Method Detail

getIdentifierType

public String getIdentifierType()

setIdentifierType

public void setIdentifierType(String identifierType)

getType

public Type getType()
             throws MappingException
Specified by:
getType in interface Value
Overrides:
getType in class SimpleValue
Throws:
MappingException

setTypeByReflection

public void setTypeByReflection(String propertyClass,
                                String propertyName)

getMetaType

public String getMetaType()

setMetaType

public void setMetaType(String type)

getMetaValues

public Map getMetaValues()

setMetaValues

public void setMetaValues(Map metaValues)

setTypeUsingReflection

public void setTypeUsingReflection(String className,
                                   String propertyName)
                            throws MappingException
Specified by:
setTypeUsingReflection in interface Value
Overrides:
setTypeUsingReflection in class SimpleValue
Throws:
MappingException

accept

public Object accept(ValueVisitor visitor)
Specified by:
accept in interface Value
Overrides:
accept in class SimpleValue
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Array (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Array

java.lang.Object
    extended by org.hibernate.mapping.Collection
        extended by org.hibernate.mapping.IndexedCollection
            extended by org.hibernate.mapping.List
                extended by org.hibernate.mapping.Array
All Implemented Interfaces:
Fetchable, Filterable, Serializable, Value
Direct Known Subclasses:
PrimitiveArray
public class Array
extends List

An array mapping has a primary key consisting of the key columns + index column.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.IndexedCollection
DEFAULT_INDEX_COLUMN_NAME
Fields inherited from class org.hibernate.mapping.Collection
DEFAULT_ELEMENT_COLUMN_NAME, DEFAULT_KEY_COLUMN_NAME
Constructor Summary
Array(PersistentClass owner)
Constructor for Array.
Method Summary
Object | accept(ValueVisitor visitor)
CollectionType | getDefaultCollectionType()
Class | getElementClass()
String | getElementClassName()
boolean | isArray()
void | setElementClassName(String elementClassName)
Methods inherited from class org.hibernate.mapping.List
getBaseIndex, isList, setBaseIndex
Methods inherited from class org.hibernate.mapping.IndexedCollection
getIndex, getIndexNodeName, isIndexed, setIndex, setIndexNodeName, validate
Methods inherited from class org.hibernate.mapping.Collection
addFilter, addManyToManyFilter, createAllKeys, createForeignKey, getBatchSize, getCacheConcurrencyStrategy, getCacheRegionName, getCollectionPersisterClass, getCollectionTable, getCollectionType, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getComparator, getComparatorClassName, getCustomSQLDelete, getCustomSQLDeleteAll, getCustomSQLDeleteAllCheckStyle, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getElement, getElementNodeName, getFetchMode, getFilterMap, getKey, getLoaderName, getManyToManyFilterMap, getManyToManyOrdering, getManyToManyWhere, getNodeName, getOrderBy, getOwner, getOwnerEntityName, getReferencedPropertyName, getRole, getSynchronizedTables, getTable, getType, getTypeName, getWhere, hasFormula, hasOrder, hasOrphanDelete, isAlternateUniqueKey, isCustomDeleteAllCallable, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isEmbedded, isExtraLazy, isIdentified, isInverse, isLazy, isMap, isMutable, isNullable, isOneToMany, isOptimisticLocked, isPrimitiveArray, isSet, isSimpleValue, isSorted, isSubselectLoadable, isValid, setBatchSize, setCacheConcurrencyStrategy, setCacheRegionName, setCollectionPersisterClass, setCollectionTable, setComparator, setComparatorClassName, setCustomSQLDelete, setCustomSQLDeleteAll, setCustomSQLInsert, setCustomSQLUpdate, setElement, setElementNodeName, setEmbedded, setExtraLazy, setFetchMode, setInverse, setKey, setLazy, setLoaderName, setManyToManyOrdering, setManyToManyWhere, setMutable, setNodeName, setOptimisticLocked, setOrderBy, setOrphanDelete, setOwner, setReferencedPropertyName, setRole, setSorted, setSubselectLoadable, setTypeName, setTypeUsingReflection, setWhere, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Array

public Array(PersistentClass owner)
Constructor for Array.

Parameters:
owner -
Method Detail

getElementClass

public Class getElementClass()
                      throws MappingException
Throws:
MappingException

getDefaultCollectionType

public CollectionType getDefaultCollectionType()
                                        throws MappingException
Overrides:
getDefaultCollectionType in class List
Throws:
MappingException

isArray

public boolean isArray()
Overrides:
isArray in class Collection

getElementClassName

public String getElementClassName()
Returns:
Returns the elementClassName.

setElementClassName

public void setElementClassName(String elementClassName)
Parameters:
elementClassName - The elementClassName to set.

accept

public Object accept(ValueVisitor visitor)
Specified by:
accept in interface Value
Overrides:
accept in class List
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Backref (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Backref

java.lang.Object
    extended by org.hibernate.mapping.Property
        extended by org.hibernate.mapping.Backref
All Implemented Interfaces:
MetaAttributable, Serializable
public class Backref
extends Property

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
Backref()
Method Summary
String | getCollectionRole()
String | getEntityName()
PropertyAccessor | getPropertyAccessor(Class clazz)
boolean | isBackRef()
boolean | isBasicPropertyAccessor()
void | setCollectionRole(String collectionRole)
void | setEntityName(String entityName)
Methods inherited from class org.hibernate.mapping.Property
getAccessorPropertyName, getCascade, getCascadeStyle, getColumnIterator, getColumnSpan, getGeneration, getGetter, getMetaAttribute, getMetaAttributes, getName, getNodeName, getPersistentClass, getPropertyAccessorName, getSetter, getType, getValue, isComposite, isInsertable, isLazy, isNaturalIdentifier, isOptimisticLocked, isOptional, isPrimitive, isSelectable, isUpdateable, isValid, setCascade, setGeneration, setInsertable, setLazy, setMetaAttributes, setName, setNaturalIdentifier, setNodeName, setOptimisticLocked, setOptional, setPersistentClass, setPropertyAccessorName, setSelectable, setUpdateable, setValue, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Backref

public Backref()
Method Detail

isBackRef

public boolean isBackRef()
Overrides:
isBackRef in class Property

getCollectionRole

public String getCollectionRole()

setCollectionRole

public void setCollectionRole(String collectionRole)

isBasicPropertyAccessor

public boolean isBasicPropertyAccessor()
Overrides:
isBasicPropertyAccessor in class Property

getPropertyAccessor

public PropertyAccessor getPropertyAccessor(Class clazz)
Overrides:
getPropertyAccessor in class Property

getEntityName

public String getEntityName()

setEntityName

public void setEntityName(String entityName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Bag (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Bag

java.lang.Object
    extended by org.hibernate.mapping.Collection
        extended by org.hibernate.mapping.Bag
All Implemented Interfaces:
Fetchable, Filterable, Serializable, Value
public class Bag
extends Collection

A bag permits duplicates, so it has no primary key

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.Collection
DEFAULT_ELEMENT_COLUMN_NAME, DEFAULT_KEY_COLUMN_NAME
Constructor Summary
Bag(PersistentClass owner)
Method Summary
Object | accept(ValueVisitor visitor)
CollectionType | getDefaultCollectionType()
Methods inherited from class org.hibernate.mapping.Collection
addFilter, addManyToManyFilter, createAllKeys, createForeignKey, getBatchSize, getCacheConcurrencyStrategy, getCacheRegionName, getCollectionPersisterClass, getCollectionTable, getCollectionType, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getComparator, getComparatorClassName, getCustomSQLDelete, getCustomSQLDeleteAll, getCustomSQLDeleteAllCheckStyle, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getElement, getElementNodeName, getFetchMode, getFilterMap, getKey, getLoaderName, getManyToManyFilterMap, getManyToManyOrdering, getManyToManyWhere, getNodeName, getOrderBy, getOwner, getOwnerEntityName, getReferencedPropertyName, getRole, getSynchronizedTables, getTable, getType, getTypeName, getWhere, hasFormula, hasOrder, hasOrphanDelete, isAlternateUniqueKey, isArray, isCustomDeleteAllCallable, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isEmbedded, isExtraLazy, isIdentified, isIndexed, isInverse, isLazy, isMap, isMutable, isNullable, isOneToMany, isOptimisticLocked, isPrimitiveArray, isSet, isSimpleValue, isSorted, isSubselectLoadable, isValid, setBatchSize, setCacheConcurrencyStrategy, setCacheRegionName, setCollectionPersisterClass, setCollectionTable, setComparator, setComparatorClassName, setCustomSQLDelete, setCustomSQLDeleteAll, setCustomSQLInsert, setCustomSQLUpdate, setElement, setElementNodeName, setEmbedded, setExtraLazy, setFetchMode, setInverse, setKey, setLazy, setLoaderName, setManyToManyOrdering, setManyToManyWhere, setMutable, setNodeName, setOptimisticLocked, setOrderBy, setOrphanDelete, setOwner, setReferencedPropertyName, setRole, setSorted, setSubselectLoadable, setTypeName, setTypeUsingReflection, setWhere, toString, validate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Bag

public Bag(PersistentClass owner)
Method Detail

getDefaultCollectionType

public CollectionType getDefaultCollectionType()
Specified by:
getDefaultCollectionType in class Collection

accept

public Object accept(ValueVisitor visitor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Collection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Collection

java.lang.Object
    extended by org.hibernate.mapping.Collection
All Implemented Interfaces:
Fetchable, Filterable, Serializable, Value
Direct Known Subclasses:
Bag, IdentifierCollection, IndexedCollection, Set
public abstract class Collection
extends Object
implements Fetchable, Value, Filterable

Mapping for a collection. Subclasses specialize to particular collection styles.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
static String | DEFAULT_ELEMENT_COLUMN_NAME
static String | DEFAULT_KEY_COLUMN_NAME
Constructor Summary
protected Collection(PersistentClass owner)
Method Summary
void | addFilter(String name, String condition)
void | addManyToManyFilter(String name, String condition)
void | createAllKeys()
void | createForeignKey()
int | getBatchSize()
String | getCacheConcurrencyStrategy()
String | getCacheRegionName()
Class | getCollectionPersisterClass()
Table | getCollectionTable()
CollectionType | getCollectionType()
boolean[] | getColumnInsertability()
Iterator | getColumnIterator()
int | getColumnSpan()
boolean[] | getColumnUpdateability()
Comparator | getComparator()
String | getComparatorClassName()
String | getCustomSQLDelete()
String | getCustomSQLDeleteAll()
ExecuteUpdateResultCheckStyle | getCustomSQLDeleteAllCheckStyle()
ExecuteUpdateResultCheckStyle | getCustomSQLDeleteCheckStyle()
String | getCustomSQLInsert()
ExecuteUpdateResultCheckStyle | getCustomSQLInsertCheckStyle()
String | getCustomSQLUpdate()
ExecuteUpdateResultCheckStyle | getCustomSQLUpdateCheckStyle()
abstract CollectionType | getDefaultCollectionType()
Value | getElement()
String | getElementNodeName()
FetchMode | getFetchMode()
Map | getFilterMap()
KeyValue | getKey()
String | getLoaderName()
Map | getManyToManyFilterMap()
String | getManyToManyOrdering()
String | getManyToManyWhere()
String | getNodeName()
String | getOrderBy()
PersistentClass | getOwner()
String | getOwnerEntityName()
String | getReferencedPropertyName()
String | getRole()
Set | getSynchronizedTables()
Table | getTable()
Type | getType()
String | getTypeName()
String | getWhere()
boolean | hasFormula()
boolean | hasOrder()
boolean | hasOrphanDelete()
boolean | isAlternateUniqueKey()
boolean | isArray()
boolean | isCustomDeleteAllCallable()
boolean | isCustomDeleteCallable()
boolean | isCustomInsertCallable()
boolean | isCustomUpdateCallable()
boolean | isEmbedded()
boolean | isExtraLazy()
boolean | isIdentified()
boolean | isIndexed()
boolean | isInverse()
boolean | isLazy()
boolean | isMap()
boolean | isMutable()
boolean | isNullable()
boolean | isOneToMany()
boolean | isOptimisticLocked()
boolean | isPrimitiveArray()
boolean | isSet()
boolean | isSimpleValue()
boolean | isSorted()
boolean | isSubselectLoadable()
boolean | isValid(Mapping mapping)
void | setBatchSize(int i)
void | setCacheConcurrencyStrategy(String cacheConcurrencyStrategy)
void | setCacheRegionName(String cacheRegionName)
void | setCollectionPersisterClass(Class persister)
void | setCollectionTable(Table table)
void | setComparator(Comparator comparator)
void | setComparatorClassName(String comparatorClassName)
void | setCustomSQLDelete(String customSQLDelete, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | setCustomSQLDeleteAll(String customSQLDeleteAll, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | setCustomSQLInsert(String customSQLInsert, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | setCustomSQLUpdate(String customSQLUpdate, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | setElement(Value element)
void | setElementNodeName(String elementNodeName)
void | setEmbedded(boolean embedded)
void | setExtraLazy(boolean extraLazy)
void | setFetchMode(FetchMode fetchMode)
void | setInverse(boolean inverse)
void | setKey(KeyValue key)
void | setLazy(boolean lazy)
void | setLoaderName(String name)
void | setManyToManyOrdering(String orderFragment)
void | setManyToManyWhere(String manyToManyWhere)
void | setMutable(boolean mutable)
void | setNodeName(String nodeName)
void | setOptimisticLocked(boolean optimisticLocked)
void | setOrderBy(String orderBy)
void | setOrphanDelete(boolean orphanDelete)
void | setOwner(PersistentClass owner)
void | setReferencedPropertyName(String propertyRef)
void | setRole(String role)
void | setSorted(boolean sorted)
void | setSubselectLoadable(boolean subqueryLoadable)
void | setTypeName(String typeName)
void | setTypeUsingReflection(String className, String propertyName)
void | setWhere(String where)
String | toString()
void | validate(Mapping mapping)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.mapping.Value
accept

Field Detail

DEFAULT_ELEMENT_COLUMN_NAME

public static final String DEFAULT_ELEMENT_COLUMN_NAME
See Also:
Constant Field Values

DEFAULT_KEY_COLUMN_NAME

public static final String DEFAULT_KEY_COLUMN_NAME
See Also:
Constant Field Values
Constructor Detail

Collection

protected Collection(PersistentClass owner)
Method Detail

isSet

public boolean isSet()

getKey

public KeyValue getKey()

getElement

public Value getElement()

isIndexed

public boolean isIndexed()

getCollectionTable

public Table getCollectionTable()

setCollectionTable

public void setCollectionTable(Table table)

isSorted

public boolean isSorted()

getComparator

public Comparator getComparator()

isLazy

public boolean isLazy()
Specified by:
isLazy in interface Fetchable

setLazy

public void setLazy(boolean lazy)
Specified by:
setLazy in interface Fetchable

getRole

public String getRole()

getDefaultCollectionType

public abstract CollectionType getDefaultCollectionType()
                                                 throws MappingException
Throws:
MappingException

isPrimitiveArray

public boolean isPrimitiveArray()

isArray

public boolean isArray()

hasFormula

public boolean hasFormula()
Specified by:
hasFormula in interface Value

isOneToMany

public boolean isOneToMany()

isInverse

public boolean isInverse()

getOwnerEntityName

public String getOwnerEntityName()

getOrderBy

public String getOrderBy()

setComparator

public void setComparator(Comparator comparator)

setElement

public void setElement(Value element)

setKey

public void setKey(KeyValue key)

setOrderBy

public void setOrderBy(String orderBy)

setRole

public void setRole(String role)

setSorted

public void setSorted(boolean sorted)

setInverse

public void setInverse(boolean inverse)

getOwner

public PersistentClass getOwner()

setOwner

public void setOwner(PersistentClass owner)

getWhere

public String getWhere()

setWhere

public void setWhere(String where)

getManyToManyWhere

public String getManyToManyWhere()

setManyToManyWhere

public void setManyToManyWhere(String manyToManyWhere)

getManyToManyOrdering

public String getManyToManyOrdering()

setManyToManyOrdering

public void setManyToManyOrdering(String orderFragment)

isIdentified

public boolean isIdentified()

hasOrphanDelete

public boolean hasOrphanDelete()

setOrphanDelete

public void setOrphanDelete(boolean orphanDelete)

getBatchSize

public int getBatchSize()

setBatchSize

public void setBatchSize(int i)

getFetchMode

public FetchMode getFetchMode()
Specified by:
getFetchMode in interface Fetchable

setFetchMode

public void setFetchMode(FetchMode fetchMode)
Specified by:
setFetchMode in interface Fetchable

setCollectionPersisterClass

public void setCollectionPersisterClass(Class persister)

getCollectionPersisterClass

public Class getCollectionPersisterClass()

validate

public void validate(Mapping mapping)
              throws MappingException
Throws:
MappingException

getColumnIterator

public Iterator getColumnIterator()
Specified by:
getColumnIterator in interface Value

getColumnSpan

public int getColumnSpan()
Specified by:
getColumnSpan in interface Value

getType

public Type getType()
             throws MappingException
Specified by:
getType in interface Value
Throws:
MappingException

getCollectionType

public CollectionType getCollectionType()

isNullable

public boolean isNullable()
Specified by:
isNullable in interface Value

isAlternateUniqueKey

public boolean isAlternateUniqueKey()
Specified by:
isAlternateUniqueKey in interface Value

getTable

public Table getTable()
Specified by:
getTable in interface Value

createForeignKey

public void createForeignKey()
Specified by:
createForeignKey in interface Value

isSimpleValue

public boolean isSimpleValue()
Specified by:
isSimpleValue in interface Value

isValid

public boolean isValid(Mapping mapping)
                throws MappingException
Specified by:
isValid in interface Value
Throws:
MappingException

createAllKeys

public void createAllKeys()
                   throws MappingException
Throws:
MappingException

getCacheConcurrencyStrategy

public String getCacheConcurrencyStrategy()

setCacheConcurrencyStrategy

public void setCacheConcurrencyStrategy(String cacheConcurrencyStrategy)

setTypeUsingReflection

public void setTypeUsingReflection(String className,
                                   String propertyName)
Specified by:
setTypeUsingReflection in interface Value

getCacheRegionName

public String getCacheRegionName()

setCacheRegionName

public void setCacheRegionName(String cacheRegionName)

setCustomSQLInsert

public void setCustomSQLInsert(String customSQLInsert,
                               boolean callable,
                               ExecuteUpdateResultCheckStyle checkStyle)

getCustomSQLInsert

public String getCustomSQLInsert()

isCustomInsertCallable

public boolean isCustomInsertCallable()

getCustomSQLInsertCheckStyle

public ExecuteUpdateResultCheckStyle getCustomSQLInsertCheckStyle()

setCustomSQLUpdate

public void setCustomSQLUpdate(String customSQLUpdate,
                               boolean callable,
                               ExecuteUpdateResultCheckStyle checkStyle)

getCustomSQLUpdate

public String getCustomSQLUpdate()

isCustomUpdateCallable

public boolean isCustomUpdateCallable()

getCustomSQLUpdateCheckStyle

public ExecuteUpdateResultCheckStyle getCustomSQLUpdateCheckStyle()

setCustomSQLDelete

public void setCustomSQLDelete(String customSQLDelete,
                               boolean callable,
                               ExecuteUpdateResultCheckStyle checkStyle)

getCustomSQLDelete

public String getCustomSQLDelete()

isCustomDeleteCallable

public boolean isCustomDeleteCallable()

getCustomSQLDeleteCheckStyle

public ExecuteUpdateResultCheckStyle getCustomSQLDeleteCheckStyle()

setCustomSQLDeleteAll

public void setCustomSQLDeleteAll(String customSQLDeleteAll,
                                  boolean callable,
                                  ExecuteUpdateResultCheckStyle checkStyle)

getCustomSQLDeleteAll

public String getCustomSQLDeleteAll()

isCustomDeleteAllCallable

public boolean isCustomDeleteAllCallable()

getCustomSQLDeleteAllCheckStyle

public ExecuteUpdateResultCheckStyle getCustomSQLDeleteAllCheckStyle()

addFilter

public void addFilter(String name,
                      String condition)
Specified by:
addFilter in interface Filterable

getFilterMap

public Map getFilterMap()
Specified by:
getFilterMap in interface Filterable

addManyToManyFilter

public void addManyToManyFilter(String name,
                                String condition)

getManyToManyFilterMap

public Map getManyToManyFilterMap()

toString

public String toString()

getSynchronizedTables

public Set getSynchronizedTables()

getLoaderName

public String getLoaderName()

setLoaderName

public void setLoaderName(String name)

getReferencedPropertyName

public String getReferencedPropertyName()

setReferencedPropertyName

public void setReferencedPropertyName(String propertyRef)

isOptimisticLocked

public boolean isOptimisticLocked()

setOptimisticLocked

public void setOptimisticLocked(boolean optimisticLocked)

isMap

public boolean isMap()

getTypeName

public String getTypeName()

setTypeName

public void setTypeName(String typeName)

getColumnInsertability

public boolean[] getColumnInsertability()
Specified by:
getColumnInsertability in interface Value

getColumnUpdateability

public boolean[] getColumnUpdateability()
Specified by:
getColumnUpdateability in interface Value

getNodeName

public String getNodeName()

setNodeName

public void setNodeName(String nodeName)

getElementNodeName

public String getElementNodeName()

setElementNodeName

public void setElementNodeName(String elementNodeName)

isEmbedded

public boolean isEmbedded()

setEmbedded

public void setEmbedded(boolean embedded)

isSubselectLoadable

public boolean isSubselectLoadable()

setSubselectLoadable

public void setSubselectLoadable(boolean subqueryLoadable)

isMutable

public boolean isMutable()

setMutable

public void setMutable(boolean mutable)

isExtraLazy

public boolean isExtraLazy()

setExtraLazy

public void setExtraLazy(boolean extraLazy)

hasOrder

public boolean hasOrder()

setComparatorClassName

public void setComparatorClassName(String comparatorClassName)

getComparatorClassName

public String getComparatorClassName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Column (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Column

java.lang.Object
    extended by org.hibernate.mapping.Column
All Implemented Interfaces:
Cloneable, Selectable, Serializable
public class Column
extends Object
implements Selectable, Serializable, Cloneable

A column of a relational database table

Author:
Gavin King
See Also:
Serialized Form

Field Summary
static int | DEFAULT_LENGTH
static int | DEFAULT_PRECISION
static int | DEFAULT_SCALE
Constructor Summary
Column()
Column(String columnName)
Method Summary
protected Object | clone() Shallow copy, the value is not copied
boolean | equals(Column column)
boolean | equals(Object object)
String | getAlias(Dialect dialect) For any column name, generate an alias that is unique to that column name, and also 10 characters or less in length.
String | getAlias(Dialect dialect, Table table) Generate a column alias that is unique across multiple tables
String | getCanonicalName()
String | getCheckConstraint()
String | getComment()
String | getDefaultValue()
int | getLength()
String | getName()
int | getPrecision()
String | getQuotedName() returns quoted name as it would be in the mapping file.
String | getQuotedName(Dialect d)
int | getScale()
String | getSqlType()
String | getSqlType(Dialect dialect, Mapping mapping)
Integer | getSqlTypeCode() Returns the underlying columns sqltypecode.
int | getSqlTypeCode(Mapping mapping)
String | getTemplate(Dialect dialect, SQLFunctionRegistry functionRegistry)
String | getText()
String | getText(Dialect d)
int | getTypeIndex()
Value | getValue()
boolean | hasCheckConstraint()
int | hashCode()
boolean | isFormula()
boolean | isNullable()
boolean | isQuoted()
boolean | isUnique()
void | setCheckConstraint(String checkConstraint)
void | setComment(String comment)
void | setDefaultValue(String defaultValue)
void | setLength(int length)
void | setName(String name)
void | setNullable(boolean nullable)
void | setPrecision(int scale)
void | setScale(int scale)
void | setSqlType(String sqlType)
void | setSqlTypeCode(Integer typecode)
void | setTypeIndex(int typeIndex)
void | setUnique(boolean unique)
void | setValue(Value value)
String | toString()
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

DEFAULT_LENGTH

public static final int DEFAULT_LENGTH
See Also:
Constant Field Values

DEFAULT_PRECISION

public static final int DEFAULT_PRECISION
See Also:
Constant Field Values

DEFAULT_SCALE

public static final int DEFAULT_SCALE
See Also:
Constant Field Values
Constructor Detail

Column

public Column()

Column

public Column(String columnName)
Method Detail

getLength

public int getLength()

setLength

public void setLength(int length)

getValue

public Value getValue()

setValue

public void setValue(Value value)

getName

public String getName()

setName

public void setName(String name)

getQuotedName

public String getQuotedName()
returns quoted name as it would be in the mapping file.

getQuotedName

public String getQuotedName(Dialect d)

getAlias

public String getAlias(Dialect dialect)
For any column name, generate an alias that is unique to that column name, and also 10 characters or less in length.

Specified by:
getAlias in interface Selectable

getAlias

public String getAlias(Dialect dialect,
                       Table table)
Generate a column alias that is unique across multiple tables

Specified by:
getAlias in interface Selectable

isNullable

public boolean isNullable()

setNullable

public void setNullable(boolean nullable)

getTypeIndex

public int getTypeIndex()

setTypeIndex

public void setTypeIndex(int typeIndex)

getSqlTypeCode

public int getSqlTypeCode(Mapping mapping)
                   throws MappingException
Throws:
MappingException

getSqlTypeCode

public Integer getSqlTypeCode()
Returns the underlying columns sqltypecode. If null, it is because the sqltype code is unknown. Use #getSqlTypeCode(Mapping) to retreive the sqltypecode used for the columns associated Value/Type.

Returns:
sqltypecode if it is set, otherwise null.

setSqlTypeCode

public void setSqlTypeCode(Integer typecode)

isUnique

public boolean isUnique()

getSqlType

public String getSqlType(Dialect dialect,
                         Mapping mapping)
                  throws HibernateException
Throws:
HibernateException

equals

public boolean equals(Object object)

equals

public boolean equals(Column column)

hashCode

public int hashCode()

getSqlType

public String getSqlType()

setSqlType

public void setSqlType(String sqlType)

setUnique

public void setUnique(boolean unique)

isQuoted

public boolean isQuoted()

toString

public String toString()

getCheckConstraint

public String getCheckConstraint()

setCheckConstraint

public void setCheckConstraint(String checkConstraint)

hasCheckConstraint

public boolean hasCheckConstraint()

getTemplate

public String getTemplate(Dialect dialect,
                          SQLFunctionRegistry functionRegistry)
Specified by:
getTemplate in interface Selectable

isFormula

public boolean isFormula()
Specified by:
isFormula in interface Selectable

getText

public String getText(Dialect d)
Specified by:
getText in interface Selectable

getText

public String getText()
Specified by:
getText in interface Selectable

getPrecision

public int getPrecision()

setPrecision

public void setPrecision(int scale)

getScale

public int getScale()

setScale

public void setScale(int scale)

getComment

public String getComment()

setComment

public void setComment(String comment)

getDefaultValue

public String getDefaultValue()

setDefaultValue

public void setDefaultValue(String defaultValue)

getCanonicalName

public String getCanonicalName()

clone

protected Object clone()
Shallow copy, the value is not copied

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Component (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Component

java.lang.Object
    extended by org.hibernate.mapping.SimpleValue
        extended by org.hibernate.mapping.Component
All Implemented Interfaces:
KeyValue, MetaAttributable, Serializable, Value
public class Component
extends SimpleValue
implements MetaAttributable

The mapping for a component, composite element, composite identifier, etc.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
Component(Collection collection)
Component(Component component)
Component(Join join)
Component(PersistentClass owner)
Method Summary
Object | accept(ValueVisitor visitor)
void | addColumn(Column column)
void | addProperty(Property p)
void | addTuplizer(EntityMode entityMode, String implClassName)
boolean[] | getColumnInsertability()
Iterator | getColumnIterator()
int | getColumnSpan()
boolean[] | getColumnUpdateability()
Class | getComponentClass()
String | getComponentClassName()
MetaAttribute | getMetaAttribute(String attributeName)
Map | getMetaAttributes()
String | getNodeName()
PersistentClass | getOwner()
String | getParentProperty()
Property | getProperty(String propertyName)
Iterator | getPropertyIterator()
int | getPropertySpan()
String | getRoleName()
String | getTuplizerImplClassName(EntityMode mode)
Map | getTuplizerMap()
Type | getType()
boolean | hasPojoRepresentation()
boolean | isDynamic()
boolean | isEmbedded()
boolean | isKey()
void | setComponentClassName(String componentClass)
void | setDynamic(boolean dynamic)
void | setEmbedded(boolean embedded)
void | setKey(boolean isKey)
void | setMetaAttributes(Map metas)
void | setNodeName(String nodeName)
void | setOwner(PersistentClass owner)
void | setParentProperty(String parentProperty)
void | setRoleName(String roleName)
void | setTypeByReflection(String propertyClass, String propertyName)
void | setTypeUsingReflection(String className, String propertyName)
String | toString()
Methods inherited from class org.hibernate.mapping.SimpleValue
addFormula, createForeignKey, createForeignKeyOfEntity, createIdentifierGenerator, getConstraintColumns, getFetchMode, getForeignKeyName, getIdentifierGeneratorProperties, getIdentifierGeneratorStrategy, getNullValue, getTable, getTypeName, getTypeParameters, hasFormula, isAlternateUniqueKey, isCascadeDeleteEnabled, isIdentityColumn, isNullable, isSimpleValue, isTypeSpecified, isUpdateable, isValid, setAlternateUniqueKey, setCascadeDeleteEnabled, setForeignKeyName, setIdentifierGeneratorProperties, setIdentifierGeneratorStrategy, setNullValue, setTable, setTypeName, setTypeParameters
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Component

public Component(PersistentClass owner)
          throws MappingException

Component

public Component(Component component)
          throws MappingException

Component

public Component(Join join)
          throws MappingException

Component

public Component(Collection collection)
          throws MappingException
Method Detail

getPropertySpan

public int getPropertySpan()

getPropertyIterator

public Iterator getPropertyIterator()

addProperty

public void addProperty(Property p)

addColumn

public void addColumn(Column column)
Overrides:
addColumn in class SimpleValue

getColumnSpan

public int getColumnSpan()
Specified by:
getColumnSpan in interface Value
Overrides:
getColumnSpan in class SimpleValue

getColumnIterator

public Iterator getColumnIterator()
Specified by:
getColumnIterator in interface Value
Overrides:
getColumnIterator in class SimpleValue

setTypeByReflection

public void setTypeByReflection(String propertyClass,
                                String propertyName)

isEmbedded

public boolean isEmbedded()

getComponentClassName

public String getComponentClassName()

getComponentClass

public Class getComponentClass()
                        throws MappingException
Throws:
MappingException

getOwner

public PersistentClass getOwner()

getParentProperty

public String getParentProperty()

setComponentClassName

public void setComponentClassName(String componentClass)

setEmbedded

public void setEmbedded(boolean embedded)

setOwner

public void setOwner(PersistentClass owner)

setParentProperty

public void setParentProperty(String parentProperty)

isDynamic

public boolean isDynamic()

setDynamic

public void setDynamic(boolean dynamic)

getType

public Type getType()
             throws MappingException
Specified by:
getType in interface Value
Overrides:
getType in class SimpleValue
Throws:
MappingException

setTypeUsingReflection

public void setTypeUsingReflection(String className,
                                   String propertyName)
                            throws MappingException
Specified by:
setTypeUsingReflection in interface Value
Overrides:
setTypeUsingReflection in class SimpleValue
Throws:
MappingException

getMetaAttributes

public Map getMetaAttributes()
Specified by:
getMetaAttributes in interface MetaAttributable

getMetaAttribute

public MetaAttribute getMetaAttribute(String attributeName)
Specified by:
getMetaAttribute in interface MetaAttributable

setMetaAttributes

public void setMetaAttributes(Map metas)
Specified by:
setMetaAttributes in interface MetaAttributable

accept

public Object accept(ValueVisitor visitor)
Specified by:
accept in interface Value
Overrides:
accept in class SimpleValue

getColumnInsertability

public boolean[] getColumnInsertability()
Specified by:
getColumnInsertability in interface Value
Overrides:
getColumnInsertability in class SimpleValue

getColumnUpdateability

public boolean[] getColumnUpdateability()
Specified by:
getColumnUpdateability in interface Value
Overrides:
getColumnUpdateability in class SimpleValue

getNodeName

public String getNodeName()

setNodeName

public void setNodeName(String nodeName)

isKey

public boolean isKey()

setKey

public void setKey(boolean isKey)

hasPojoRepresentation

public boolean hasPojoRepresentation()

addTuplizer

public void addTuplizer(EntityMode entityMode,
                        String implClassName)

getTuplizerImplClassName

public String getTuplizerImplClassName(EntityMode mode)

getTuplizerMap

public Map getTuplizerMap()

getProperty

public Property getProperty(String propertyName)
                     throws MappingException
Throws:
MappingException

getRoleName

public String getRoleName()

setRoleName

public void setRoleName(String roleName)

toString

public String toString()
Overrides:
toString in class SimpleValue
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constraint (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Constraint

java.lang.Object
    extended by org.hibernate.mapping.Constraint
All Implemented Interfaces:
RelationalModel, Serializable
Direct Known Subclasses:
ForeignKey, PrimaryKey, UniqueKey
public abstract class Constraint
extends Object
implements RelationalModel, Serializable

A relational constraint.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
Constraint()
Method Summary
void | addColumn(Column column)
void | addColumns(Iterator columnIterator)
Iterator | columnIterator()
boolean | containsColumn(Column column)
Column | getColumn(int i)
Iterator | getColumnIterator()
List | getColumns()
int | getColumnSpan()
String | getName()
Table | getTable()
void | setName(String name)
void | setTable(Table table)
abstract String | sqlConstraintString(Dialect d, String constraintName, String defaultCatalog, String defaultSchema)
String | sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
String | sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Constraint

public Constraint()
Method Detail

getName

public String getName()

setName

public void setName(String name)

getColumnIterator

public Iterator getColumnIterator()

addColumn

public void addColumn(Column column)

addColumns

public void addColumns(Iterator columnIterator)

containsColumn

public boolean containsColumn(Column column)
Parameters:
column -
Returns:
true if this constraint already contains a column with same name.

getColumnSpan

public int getColumnSpan()

getColumn

public Column getColumn(int i)

columnIterator

public Iterator columnIterator()

getTable

public Table getTable()

setTable

public void setTable(Table table)

sqlDropString

public String sqlDropString(Dialect dialect,
                            String defaultCatalog,
                            String defaultSchema)
Specified by:
sqlDropString in interface RelationalModel

sqlCreateString

public String sqlCreateString(Dialect dialect,
                              Mapping p,
                              String defaultCatalog,
                              String defaultSchema)
Specified by:
sqlCreateString in interface RelationalModel

getColumns

public List getColumns()

sqlConstraintString

public abstract String sqlConstraintString(Dialect d,
                                           String constraintName,
                                           String defaultCatalog,
                                           String defaultSchema)

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DenormalizedTable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class DenormalizedTable

java.lang.Object
    extended by org.hibernate.mapping.Table
        extended by org.hibernate.mapping.DenormalizedTable
All Implemented Interfaces:
RelationalModel, Serializable
public class DenormalizedTable
extends Table

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
DenormalizedTable(Table includedTable)
Method Summary
boolean | containsColumn(Column column)
void | createForeignKeys()
Iterator | getColumnIterator()
Iterator | getIndexIterator()
PrimaryKey | getPrimaryKey()
Iterator | getUniqueKeyIterator()
Methods inherited from class org.hibernate.mapping.Table
addCheckConstraint, addColumn, addIndex, addUniqueKey, createForeignKey, createForeignKey, createUniqueKey, getCatalog, getCheckConstraintsIterator, getColumn, getColumn, getColumnSpan, getComment, getForeignKeyIterator, getIdentifierValue, getIndex, getName, getOrCreateIndex, getOrCreateUniqueKey, getQualifiedName, getQuotedName, getQuotedName, getQuotedSchema, getQuotedSchema, getRowId, getSchema, getSubselect, getUniqueInteger, getUniqueKey, hasDenormalizedTables, hasPrimaryKey, isAbstract, isAbstractUnionTable, isPhysicalTable, isQuoted, isSchemaQuoted, isSubselect, qualify, setAbstract, setCatalog, setComment, setIdentifierValue, setName, setPrimaryKey, setQuoted, setRowId, setSchema, setSubselect, sqlAlterStrings, sqlCommentStrings, sqlCreateString, sqlDropString, sqlTemporaryTableCreateString, toString, uniqueColumnString, uniqueColumnString, validateColumns
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DenormalizedTable

public DenormalizedTable(Table includedTable)
Method Detail

createForeignKeys

public void createForeignKeys()
Overrides:
createForeignKeys in class Table

getColumnIterator

public Iterator getColumnIterator()
Overrides:
getColumnIterator in class Table

containsColumn

public boolean containsColumn(Column column)
Overrides:
containsColumn in class Table

getPrimaryKey

public PrimaryKey getPrimaryKey()
Overrides:
getPrimaryKey in class Table

getUniqueKeyIterator

public Iterator getUniqueKeyIterator()
Overrides:
getUniqueKeyIterator in class Table

getIndexIterator

public Iterator getIndexIterator()
Overrides:
getIndexIterator in class Table
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DependantValue (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class DependantValue

java.lang.Object
    extended by org.hibernate.mapping.SimpleValue
        extended by org.hibernate.mapping.DependantValue
All Implemented Interfaces:
KeyValue, Serializable, Value
public class DependantValue
extends SimpleValue

A value which is "typed" by reference to some other value (for example, a foreign key is typed by the referenced primary key).

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
DependantValue(Table table, KeyValue prototype)
Method Summary
Object | accept(ValueVisitor visitor)
Type | getType()
boolean | isNullable()
boolean | isUpdateable()
void | setNullable(boolean nullable)
void | setTypeUsingReflection(String className, String propertyName)
void | setUpdateable(boolean updateable)
Methods inherited from class org.hibernate.mapping.SimpleValue
addColumn, addFormula, createForeignKey, createForeignKeyOfEntity, createIdentifierGenerator, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getConstraintColumns, getFetchMode, getForeignKeyName, getIdentifierGeneratorProperties, getIdentifierGeneratorStrategy, getNullValue, getTable, getTypeName, getTypeParameters, hasFormula, isAlternateUniqueKey, isCascadeDeleteEnabled, isIdentityColumn, isSimpleValue, isTypeSpecified, isValid, setAlternateUniqueKey, setCascadeDeleteEnabled, setForeignKeyName, setIdentifierGeneratorProperties, setIdentifierGeneratorStrategy, setNullValue, setTable, setTypeName, setTypeParameters, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DependantValue

public DependantValue(Table table,
                      KeyValue prototype)
Method Detail

getType

public Type getType()
             throws MappingException
Specified by:
getType in interface Value
Overrides:
getType in class SimpleValue
Throws:
MappingException

setTypeUsingReflection

public void setTypeUsingReflection(String className,
                                   String propertyName)
Specified by:
setTypeUsingReflection in interface Value
Overrides:
setTypeUsingReflection in class SimpleValue

accept

public Object accept(ValueVisitor visitor)
Specified by:
accept in interface Value
Overrides:
accept in class SimpleValue

isNullable

public boolean isNullable()
Specified by:
isNullable in interface Value
Overrides:
isNullable in class SimpleValue

setNullable

public void setNullable(boolean nullable)

isUpdateable

public boolean isUpdateable()
Specified by:
isUpdateable in interface KeyValue
Overrides:
isUpdateable in class SimpleValue

setUpdateable

public void setUpdateable(boolean updateable)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ForeignKey (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class ForeignKey

java.lang.Object
    extended by org.hibernate.mapping.Constraint
        extended by org.hibernate.mapping.ForeignKey
All Implemented Interfaces:
RelationalModel, Serializable
public class ForeignKey
extends Constraint

A foreign key constraint

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
ForeignKey()
Method Summary
void | addReferencedColumns(Iterator referencedColumnsIterator)
void | alignColumns() Validates that columnspan of the foreignkey and the primarykey is the same.
List | getReferencedColumns() Returns the referenced columns if the foreignkey does not refer to the primary key
String | getReferencedEntityName()
Table | getReferencedTable()
boolean | isCascadeDeleteEnabled()
boolean | isPhysicalConstraint()
boolean | isReferenceToPrimaryKey() Does this foreignkey reference the primary key of the reference table
void | setCascadeDeleteEnabled(boolean cascadeDeleteEnabled)
void | setReferencedEntityName(String referencedEntityName)
void | setReferencedTable(Table referencedTable)
String | sqlConstraintString(Dialect dialect, String constraintName, String defaultCatalog, String defaultSchema)
String | sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
String | toString()
Methods inherited from class org.hibernate.mapping.Constraint
addColumn, addColumns, columnIterator, containsColumn, getColumn, getColumnIterator, getColumns, getColumnSpan, getName, getTable, setName, setTable, sqlCreateString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ForeignKey

public ForeignKey()
Method Detail

sqlConstraintString

public String sqlConstraintString(Dialect dialect,
                                  String constraintName,
                                  String defaultCatalog,
                                  String defaultSchema)
Specified by:
sqlConstraintString in class Constraint

getReferencedTable

public Table getReferencedTable()

setReferencedTable

public void setReferencedTable(Table referencedTable)
                        throws MappingException
Throws:
MappingException

alignColumns

public void alignColumns()
Validates that columnspan of the foreignkey and the primarykey is the same. Furthermore it aligns the length of the underlying tables columns.

getReferencedEntityName

public String getReferencedEntityName()

setReferencedEntityName

public void setReferencedEntityName(String referencedEntityName)

sqlDropString

public String sqlDropString(Dialect dialect,
                            String defaultCatalog,
                            String defaultSchema)
Specified by:
sqlDropString in interface RelationalModel
Overrides:
sqlDropString in class Constraint

isCascadeDeleteEnabled

public boolean isCascadeDeleteEnabled()

setCascadeDeleteEnabled

public void setCascadeDeleteEnabled(boolean cascadeDeleteEnabled)

isPhysicalConstraint

public boolean isPhysicalConstraint()

getReferencedColumns

public List getReferencedColumns()
Returns the referenced columns if the foreignkey does not refer to the primary key

isReferenceToPrimaryKey

public boolean isReferenceToPrimaryKey()
Does this foreignkey reference the primary key of the reference table

addReferencedColumns

public void addReferencedColumns(Iterator referencedColumnsIterator)

toString

public String toString()
Overrides:
toString in class Constraint
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Formula (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Formula

java.lang.Object
    extended by org.hibernate.mapping.Formula
All Implemented Interfaces:
Selectable, Serializable
public class Formula
extends Object
implements Selectable, Serializable

A formula is a derived column value

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
Formula()
Method Summary
String | getAlias(Dialect dialect)
String | getAlias(Dialect dialect, Table table)
String | getFormula()
String | getTemplate(Dialect dialect, SQLFunctionRegistry functionRegistry)
String | getText()
String | getText(Dialect dialect)
boolean | isFormula()
void | setFormula(String string)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Formula

public Formula()
Method Detail

getTemplate

public String getTemplate(Dialect dialect,
                          SQLFunctionRegistry functionRegistry)
Specified by:
getTemplate in interface Selectable

getText

public String getText(Dialect dialect)
Specified by:
getText in interface Selectable

getText

public String getText()
Specified by:
getText in interface Selectable

getAlias

public String getAlias(Dialect dialect)
Specified by:
getAlias in interface Selectable

getAlias

public String getAlias(Dialect dialect,
                       Table table)
Specified by:
getAlias in interface Selectable

getFormula

public String getFormula()

setFormula

public void setFormula(String string)

isFormula

public boolean isFormula()
Specified by:
isFormula in interface Selectable

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentifierBag (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class IdentifierBag

java.lang.Object
    extended by org.hibernate.mapping.Collection
        extended by org.hibernate.mapping.IdentifierCollection
            extended by org.hibernate.mapping.IdentifierBag
All Implemented Interfaces:
Fetchable, Filterable, Serializable, Value
public class IdentifierBag
extends IdentifierCollection

An IdentifierBag has a primary key consisting of just the identifier column

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.IdentifierCollection
DEFAULT_IDENTIFIER_COLUMN_NAME
Fields inherited from class org.hibernate.mapping.Collection
DEFAULT_ELEMENT_COLUMN_NAME, DEFAULT_KEY_COLUMN_NAME
Constructor Summary
IdentifierBag(PersistentClass owner)
Method Summary
Object | accept(ValueVisitor visitor)
CollectionType | getDefaultCollectionType()
Methods inherited from class org.hibernate.mapping.IdentifierCollection
getIdentifier, isIdentified, setIdentifier, validate
Methods inherited from class org.hibernate.mapping.Collection
addFilter, addManyToManyFilter, createAllKeys, createForeignKey, getBatchSize, getCacheConcurrencyStrategy, getCacheRegionName, getCollectionPersisterClass, getCollectionTable, getCollectionType, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getComparator, getComparatorClassName, getCustomSQLDelete, getCustomSQLDeleteAll, getCustomSQLDeleteAllCheckStyle, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getElement, getElementNodeName, getFetchMode, getFilterMap, getKey, getLoaderName, getManyToManyFilterMap, getManyToManyOrdering, getManyToManyWhere, getNodeName, getOrderBy, getOwner, getOwnerEntityName, getReferencedPropertyName, getRole, getSynchronizedTables, getTable, getType, getTypeName, getWhere, hasFormula, hasOrder, hasOrphanDelete, isAlternateUniqueKey, isArray, isCustomDeleteAllCallable, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isEmbedded, isExtraLazy, isIndexed, isInverse, isLazy, isMap, isMutable, isNullable, isOneToMany, isOptimisticLocked, isPrimitiveArray, isSet, isSimpleValue, isSorted, isSubselectLoadable, isValid, setBatchSize, setCacheConcurrencyStrategy, setCacheRegionName, setCollectionPersisterClass, setCollectionTable, setComparator, setComparatorClassName, setCustomSQLDelete, setCustomSQLDeleteAll, setCustomSQLInsert, setCustomSQLUpdate, setElement, setElementNodeName, setEmbedded, setExtraLazy, setFetchMode, setInverse, setKey, setLazy, setLoaderName, setManyToManyOrdering, setManyToManyWhere, setMutable, setNodeName, setOptimisticLocked, setOrderBy, setOrphanDelete, setOwner, setReferencedPropertyName, setRole, setSorted, setSubselectLoadable, setTypeName, setTypeUsingReflection, setWhere, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IdentifierBag

public IdentifierBag(PersistentClass owner)
Method Detail

getDefaultCollectionType

public CollectionType getDefaultCollectionType()
Specified by:
getDefaultCollectionType in class Collection

accept

public Object accept(ValueVisitor visitor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentifierCollection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class IdentifierCollection

java.lang.Object
    extended by org.hibernate.mapping.Collection
        extended by org.hibernate.mapping.IdentifierCollection
All Implemented Interfaces:
Fetchable, Filterable, Serializable, Value
Direct Known Subclasses:
IdentifierBag
public abstract class IdentifierCollection
extends Collection

A collection with a synthetic "identifier" column

See Also:
Serialized Form

Field Summary
static String DEFAULT_IDENTIFIER_COLUMN_NAME
Fields inherited from class org.hibernate.mapping.Collection
DEFAULT_ELEMENT_COLUMN_NAME, DEFAULT_KEY_COLUMN_NAME
Constructor Summary
IdentifierCollection(PersistentClass owner)
Method Summary
KeyValue | getIdentifier()
boolean | isIdentified()
void | setIdentifier(KeyValue identifier)
void | validate(Mapping mapping)
Methods inherited from class org.hibernate.mapping.Collection
addFilter, addManyToManyFilter, createAllKeys, createForeignKey, getBatchSize, getCacheConcurrencyStrategy, getCacheRegionName, getCollectionPersisterClass, getCollectionTable, getCollectionType, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getComparator, getComparatorClassName, getCustomSQLDelete, getCustomSQLDeleteAll, getCustomSQLDeleteAllCheckStyle, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getDefaultCollectionType, getElement, getElementNodeName, getFetchMode, getFilterMap, getKey, getLoaderName, getManyToManyFilterMap, getManyToManyOrdering, getManyToManyWhere, getNodeName, getOrderBy, getOwner, getOwnerEntityName, getReferencedPropertyName, getRole, getSynchronizedTables, getTable, getType, getTypeName, getWhere, hasFormula, hasOrder, hasOrphanDelete, isAlternateUniqueKey, isArray, isCustomDeleteAllCallable, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isEmbedded, isExtraLazy, isIndexed, isInverse, isLazy, isMap, isMutable, isNullable, isOneToMany, isOptimisticLocked, isPrimitiveArray, isSet, isSimpleValue, isSorted, isSubselectLoadable, isValid, setBatchSize, setCacheConcurrencyStrategy, setCacheRegionName, setCollectionPersisterClass, setCollectionTable, setComparator, setComparatorClassName, setCustomSQLDelete, setCustomSQLDeleteAll, setCustomSQLInsert, setCustomSQLUpdate, setElement, setElementNodeName, setEmbedded, setExtraLazy, setFetchMode, setInverse, setKey, setLazy, setLoaderName, setManyToManyOrdering, setManyToManyWhere, setMutable, setNodeName, setOptimisticLocked, setOrderBy, setOrphanDelete, setOwner, setReferencedPropertyName, setRole, setSorted, setSubselectLoadable, setTypeName, setTypeUsingReflection, setWhere, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.mapping.Value
accept

Field Detail

DEFAULT_IDENTIFIER_COLUMN_NAME

public static final String DEFAULT_IDENTIFIER_COLUMN_NAME
See Also:
Constant Field Values
Constructor Detail

IdentifierCollection

public IdentifierCollection(PersistentClass owner)
Method Detail

getIdentifier

public KeyValue getIdentifier()

setIdentifier

public void setIdentifier(KeyValue identifier)

isIdentified

public final boolean isIdentified()
Overrides:
isIdentified in class Collection

validate

public void validate(Mapping mapping)
              throws MappingException
Overrides:
validate in class Collection
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Index (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Index

java.lang.Object
    extended by org.hibernate.mapping.Index
All Implemented Interfaces:
RelationalModel, Serializable
public class Index
extends Object
implements RelationalModel, Serializable

A relational table index

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
Index()
Method Summary
void | addColumn(Column column)
void | addColumns(Iterator extraColumns)
static String | buildSqlCreateIndexString(Dialect dialect, String name, Table table, Iterator columns, boolean unique, String defaultCatalog, String defaultSchema)
static String | buildSqlDropIndexString(Dialect dialect, Table table, String name, String defaultCatalog, String defaultSchema)
boolean | containsColumn(Column column)
Iterator | getColumnIterator()
int | getColumnSpan()
String | getName()
Table | getTable()
void | setName(String name)
void | setTable(Table table)
String | sqlConstraintString(Dialect dialect)
String | sqlCreateString(Dialect dialect, Mapping mapping, String defaultCatalog, String defaultSchema)
String | sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Index

public Index()
Method Detail

sqlCreateString

public String sqlCreateString(Dialect dialect,
                              Mapping mapping,
                              String defaultCatalog,
                              String defaultSchema)
                       throws HibernateException
Specified by:
sqlCreateString in interface RelationalModel
Throws:
HibernateException

buildSqlDropIndexString

public static String buildSqlDropIndexString(Dialect dialect,
                                             Table table,
                                             String name,
                                             String defaultCatalog,
                                             String defaultSchema)

buildSqlCreateIndexString

public static String buildSqlCreateIndexString(Dialect dialect,
                                               String name,
                                               Table table,
                                               Iterator columns,
                                               boolean unique,
                                               String defaultCatalog,
                                               String defaultSchema)

sqlConstraintString

public String sqlConstraintString(Dialect dialect)

sqlDropString

public String sqlDropString(Dialect dialect,
                            String defaultCatalog,
                            String defaultSchema)
Specified by:
sqlDropString in interface RelationalModel

getTable

public Table getTable()

setTable

public void setTable(Table table)

getColumnSpan

public int getColumnSpan()

getColumnIterator

public Iterator getColumnIterator()

addColumn

public void addColumn(Column column)

addColumns

public void addColumns(Iterator extraColumns)

containsColumn

public boolean containsColumn(Column column)
Parameters:
column -
Returns:
true if this constraint already contains a column with same name.

getName

public String getName()

setName

public void setName(String name)

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IndexBackref (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class IndexBackref

java.lang.Object
    extended by org.hibernate.mapping.Property
        extended by org.hibernate.mapping.IndexBackref
All Implemented Interfaces:
MetaAttributable, Serializable
public class IndexBackref
extends Property

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
IndexBackref()
Method Summary
String | getCollectionRole()
String | getEntityName()
PropertyAccessor | getPropertyAccessor(Class clazz)
boolean | isBackRef()
boolean | isBasicPropertyAccessor()
void | setCollectionRole(String collectionRole)
void | setEntityName(String entityName)
Methods inherited from class org.hibernate.mapping.Property
getAccessorPropertyName, getCascade, getCascadeStyle, getColumnIterator, getColumnSpan, getGeneration, getGetter, getMetaAttribute, getMetaAttributes, getName, getNodeName, getPersistentClass, getPropertyAccessorName, getSetter, getType, getValue, isComposite, isInsertable, isLazy, isNaturalIdentifier, isOptimisticLocked, isOptional, isPrimitive, isSelectable, isUpdateable, isValid, setCascade, setGeneration, setInsertable, setLazy, setMetaAttributes, setName, setNaturalIdentifier, setNodeName, setOptimisticLocked, setOptional, setPersistentClass, setPropertyAccessorName, setSelectable, setUpdateable, setValue, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IndexBackref

public IndexBackref()
Method Detail

isBackRef

public boolean isBackRef()
Overrides:
isBackRef in class Property

getCollectionRole

public String getCollectionRole()

setCollectionRole

public void setCollectionRole(String collectionRole)

isBasicPropertyAccessor

public boolean isBasicPropertyAccessor()
Overrides:
isBasicPropertyAccessor in class Property

getPropertyAccessor

public PropertyAccessor getPropertyAccessor(Class clazz)
Overrides:
getPropertyAccessor in class Property

getEntityName

public String getEntityName()

setEntityName

public void setEntityName(String entityName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IndexedCollection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class IndexedCollection

java.lang.Object
    extended by org.hibernate.mapping.Collection
        extended by org.hibernate.mapping.IndexedCollection
All Implemented Interfaces:
Fetchable, Filterable, Serializable, Value
Direct Known Subclasses:
List, Map
public abstract class IndexedCollection
extends Collection

Indexed collections include Lists, Maps, arrays and primitive arrays.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
static String DEFAULT_INDEX_COLUMN_NAME
Fields inherited from class org.hibernate.mapping.Collection
DEFAULT_ELEMENT_COLUMN_NAME, DEFAULT_KEY_COLUMN_NAME
Constructor Summary
IndexedCollection(PersistentClass owner)
Method Summary
Value | getIndex()
String | getIndexNodeName()
boolean | isIndexed()
boolean | isList()
void | setIndex(Value index)
void | setIndexNodeName(String indexNodeName)
void | validate(Mapping mapping)
Methods inherited from class org.hibernate.mapping.Collection
addFilter, addManyToManyFilter, createAllKeys, createForeignKey, getBatchSize, getCacheConcurrencyStrategy, getCacheRegionName, getCollectionPersisterClass, getCollectionTable, getCollectionType, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getComparator, getComparatorClassName, getCustomSQLDelete, getCustomSQLDeleteAll, getCustomSQLDeleteAllCheckStyle, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getDefaultCollectionType, getElement, getElementNodeName, getFetchMode, getFilterMap, getKey, getLoaderName, getManyToManyFilterMap, getManyToManyOrdering, getManyToManyWhere, getNodeName, getOrderBy, getOwner, getOwnerEntityName, getReferencedPropertyName, getRole, getSynchronizedTables, getTable, getType, getTypeName, getWhere, hasFormula, hasOrder, hasOrphanDelete, isAlternateUniqueKey, isArray, isCustomDeleteAllCallable, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isEmbedded, isExtraLazy, isIdentified, isInverse, isLazy, isMap, isMutable, isNullable, isOneToMany, isOptimisticLocked, isPrimitiveArray, isSet, isSimpleValue, isSorted, isSubselectLoadable, isValid, setBatchSize, setCacheConcurrencyStrategy, setCacheRegionName, setCollectionPersisterClass, setCollectionTable, setComparator, setComparatorClassName, setCustomSQLDelete, setCustomSQLDeleteAll, setCustomSQLInsert, setCustomSQLUpdate, setElement, setElementNodeName, setEmbedded, setExtraLazy, setFetchMode, setInverse, setKey, setLazy, setLoaderName, setManyToManyOrdering, setManyToManyWhere, setMutable, setNodeName, setOptimisticLocked, setOrderBy, setOrphanDelete, setOwner, setReferencedPropertyName, setRole, setSorted, setSubselectLoadable, setTypeName, setTypeUsingReflection, setWhere, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.mapping.Value
accept

Field Detail

DEFAULT_INDEX_COLUMN_NAME

public static final String DEFAULT_INDEX_COLUMN_NAME
See Also:
Constant Field Values
Constructor Detail

IndexedCollection

public IndexedCollection(PersistentClass owner)
Method Detail

getIndex

public Value getIndex()

setIndex

public void setIndex(Value index)

isIndexed

public final boolean isIndexed()
Overrides:
isIndexed in class Collection

validate

public void validate(Mapping mapping)
              throws MappingException
Overrides:
validate in class Collection
Throws:
MappingException

isList

public boolean isList()

getIndexNodeName

public String getIndexNodeName()

setIndexNodeName

public void setIndexNodeName(String indexNodeName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Join (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Join

java.lang.Object
    extended by org.hibernate.mapping.Join
All Implemented Interfaces:
Serializable
public class Join
extends Object
implements Serializable

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
Join()
Method Summary
void | addProperty(Property prop)
boolean | containsProperty(Property prop)
void | createForeignKey()
void | createPrimaryKey()
String | getCustomSQLDelete()
ExecuteUpdateResultCheckStyle | getCustomSQLDeleteCheckStyle()
String | getCustomSQLInsert()
ExecuteUpdateResultCheckStyle | getCustomSQLInsertCheckStyle()
String | getCustomSQLUpdate()
ExecuteUpdateResultCheckStyle | getCustomSQLUpdateCheckStyle()
KeyValue | getKey()
PersistentClass | getPersistentClass()
Iterator | getPropertyIterator()
int | getPropertySpan()
Table | getTable()
boolean | isCustomDeleteCallable()
boolean | isCustomInsertCallable()
boolean | isCustomUpdateCallable()
boolean | isInverse()
boolean | isLazy()
boolean | isOptional()
boolean | isSequentialSelect()
void | setCustomSQLDelete(String customSQLDelete, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | setCustomSQLInsert(String customSQLInsert, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | setCustomSQLUpdate(String customSQLUpdate, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | setInverse(boolean leftJoin)
void | setKey(KeyValue key)
void | setOptional(boolean nullable)
void | setPersistentClass(PersistentClass persistentClass)
void | setSequentialSelect(boolean deferred)
void | setTable(Table table)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Join

public Join()
Method Detail

addProperty

public void addProperty(Property prop)

containsProperty

public boolean containsProperty(Property prop)

getPropertyIterator

public Iterator getPropertyIterator()

getTable

public Table getTable()

setTable

public void setTable(Table table)

getKey

public KeyValue getKey()

setKey

public void setKey(KeyValue key)

getPersistentClass

public PersistentClass getPersistentClass()

setPersistentClass

public void setPersistentClass(PersistentClass persistentClass)

createForeignKey

public void createForeignKey()

createPrimaryKey

public void createPrimaryKey()

getPropertySpan

public int getPropertySpan()

setCustomSQLInsert

public void setCustomSQLInsert(String customSQLInsert,
                               boolean callable,
                               ExecuteUpdateResultCheckStyle checkStyle)

getCustomSQLInsert

public String getCustomSQLInsert()

isCustomInsertCallable

public boolean isCustomInsertCallable()

getCustomSQLInsertCheckStyle

public ExecuteUpdateResultCheckStyle getCustomSQLInsertCheckStyle()

setCustomSQLUpdate

public void setCustomSQLUpdate(String customSQLUpdate,
                               boolean callable,
                               ExecuteUpdateResultCheckStyle checkStyle)

getCustomSQLUpdate

public String getCustomSQLUpdate()

isCustomUpdateCallable

public boolean isCustomUpdateCallable()

getCustomSQLUpdateCheckStyle

public ExecuteUpdateResultCheckStyle getCustomSQLUpdateCheckStyle()

setCustomSQLDelete

public void setCustomSQLDelete(String customSQLDelete,
                               boolean callable,
                               ExecuteUpdateResultCheckStyle checkStyle)

getCustomSQLDelete

public String getCustomSQLDelete()

isCustomDeleteCallable

public boolean isCustomDeleteCallable()

getCustomSQLDeleteCheckStyle

public ExecuteUpdateResultCheckStyle getCustomSQLDeleteCheckStyle()

isSequentialSelect

public boolean isSequentialSelect()

setSequentialSelect

public void setSequentialSelect(boolean deferred)

isInverse

public boolean isInverse()

setInverse

public void setInverse(boolean leftJoin)

toString

public String toString()

isLazy

public boolean isLazy()

isOptional

public boolean isOptional()

setOptional

public void setOptional(boolean nullable)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JoinedSubclass (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class JoinedSubclass

java.lang.Object
    extended by org.hibernate.mapping.PersistentClass
        extended by org.hibernate.mapping.Subclass
            extended by org.hibernate.mapping.JoinedSubclass
All Implemented Interfaces:
Filterable, MetaAttributable, Serializable, TableOwner
public class JoinedSubclass
extends Subclass
implements TableOwner

A subclass in a table-per-subclass mapping

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.PersistentClass
NOT_NULL_DISCRIMINATOR_MAPPING, NULL_DISCRIMINATOR_MAPPING, optimisticLockMode, synchronizedTables
Constructor Summary
JoinedSubclass(PersistentClass superclass)
Method Summary
Object | accept(PersistentClassVisitor mv)
KeyValue | getKey()
Iterator | getReferenceablePropertyIterator()
Table | getTable()
void | setKey(KeyValue key)
void | setTable(Table table)
void | validate(Mapping mapping)
Methods inherited from class org.hibernate.mapping.Subclass
addJoin, addProperty, addSubclassJoin, addSubclassProperty, addSubclassTable, createForeignKey, getCacheConcurrencyStrategy, getDiscriminator, getEntityPersisterClass, getFilterMap, getIdentifier, getIdentifierMapper, getIdentifierProperty, getJoinClosureIterator, getJoinClosureSpan, getKeyClosureIterator, getOptimisticLockMode, getPropertyClosureIterator, getPropertyClosureSpan, getRootClass, getRootTable, getSubclassId, getSuperclass, getSynchronizedTables, getTableClosureIterator, getTuplizerImplClassName, getTuplizerMap, getVersion, getWhere, hasEmbeddedIdentifier, hasIdentifierProperty, hasSubselectLoadableCollections, isClassOrSuperclassJoin, isClassOrSuperclassTable, isDiscriminatorInsertable, isExplicitPolymorphism, isForceDiscriminator, isInherited, isJoinedSubclass, isLazyPropertiesCacheable, isMutable, isPolymorphic, isVersioned, setEntityPersisterClass, setSuperclass
Methods inherited from class org.hibernate.mapping.PersistentClass
addFilter, addSubclass, addSynchronizedTable, addTuplizer, checkColumnDuplication, checkColumnDuplication, checkPropertyColumnDuplication, createPrimaryKey, getBatchSize, getClassName, getCustomSQLDelete, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getDirectSubclasses, getDiscriminatorColumnIterator, getDiscriminatorValue, getEntityName, getIdentityTable, getJoinIterator, getJoinNumber, getLoaderName, getMappedClass, getMetaAttribute, getMetaAttributes, getNodeName, getNonDuplicatedPropertyIterator, getProperty, getPropertyIterator, getProxyInterface, getProxyInterfaceName, getRecursiveProperty, getReferencedProperty, getSubclassClosureIterator, getSubclassIterator, getSubclassJoinClosureIterator, getSubclassPropertyClosureIterator, getSubclassSpan, getSubclassTableClosureIterator, getTemporaryIdTableDDL, getTemporaryIdTableName, getUnjoinedPropertyIterator, hasDom4jRepresentation, hasIdentifierMapper, hasNaturalId, hasPojoRepresentation, hasSelectBeforeUpdate, hasSubclasses, isAbstract, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isDiscriminatorValueNotNull, isDiscriminatorValueNull, isLazy, prepareTemporaryTables, setAbstract, setBatchSize, setClassName, setCustomSQLDelete, setCustomSQLInsert, setCustomSQLUpdate, setDiscriminatorValue, setDynamicInsert, setDynamicUpdate, setEntityName, setIdentifierMapper, setLazy, setLoaderName, setMetaAttributes, setNodeName, setOptimisticLockMode, setProxyInterfaceName, setSelectBeforeUpdate, setSubselectLoadableCollections, toString, useDynamicInsert, useDynamicUpdate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JoinedSubclass

public JoinedSubclass(PersistentClass superclass)
Method Detail

getTable

public Table getTable()
Overrides:
getTable in class Subclass

setTable

public void setTable(Table table)
Specified by:
setTable in interface TableOwner

getKey

public KeyValue getKey()
Overrides:
getKey in class Subclass

setKey

public void setKey(KeyValue key)

validate

public void validate(Mapping mapping)
              throws MappingException
Overrides:
validate in class PersistentClass
Throws:
MappingException

getReferenceablePropertyIterator

public Iterator getReferenceablePropertyIterator()
Overrides:
getReferenceablePropertyIterator in class PersistentClass

accept

public Object accept(PersistentClassVisitor mv)
Overrides:
accept in class Subclass
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


List (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class List

java.lang.Object
    extended by org.hibernate.mapping.Collection
        extended by org.hibernate.mapping.IndexedCollection
            extended by org.hibernate.mapping.List
All Implemented Interfaces:
Fetchable, Filterable, Serializable, Value
Direct Known Subclasses:
Array
public class List
extends IndexedCollection

A list mapping has a primary key consisting of the key columns + index column.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.IndexedCollection
DEFAULT_INDEX_COLUMN_NAME
Fields inherited from class org.hibernate.mapping.Collection
DEFAULT_ELEMENT_COLUMN_NAME, DEFAULT_KEY_COLUMN_NAME
Constructor Summary
List(PersistentClass owner)
Method Summary
Object | accept(ValueVisitor visitor)
int | getBaseIndex()
CollectionType | getDefaultCollectionType()
boolean | isList()
void | setBaseIndex(int baseIndex)
Methods inherited from class org.hibernate.mapping.IndexedCollection
getIndex, getIndexNodeName, isIndexed, setIndex, setIndexNodeName, validate
Methods inherited from class org.hibernate.mapping.Collection
addFilter, addManyToManyFilter, createAllKeys, createForeignKey, getBatchSize, getCacheConcurrencyStrategy, getCacheRegionName, getCollectionPersisterClass, getCollectionTable, getCollectionType, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getComparator, getComparatorClassName, getCustomSQLDelete, getCustomSQLDeleteAll, getCustomSQLDeleteAllCheckStyle, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getElement, getElementNodeName, getFetchMode, getFilterMap, getKey, getLoaderName, getManyToManyFilterMap, getManyToManyOrdering, getManyToManyWhere, getNodeName, getOrderBy, getOwner, getOwnerEntityName, getReferencedPropertyName, getRole, getSynchronizedTables, getTable, getType, getTypeName, getWhere, hasFormula, hasOrder, hasOrphanDelete, isAlternateUniqueKey, isArray, isCustomDeleteAllCallable, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isEmbedded, isExtraLazy, isIdentified, isInverse, isLazy, isMap, isMutable, isNullable, isOneToMany, isOptimisticLocked, isPrimitiveArray, isSet, isSimpleValue, isSorted, isSubselectLoadable, isValid, setBatchSize, setCacheConcurrencyStrategy, setCacheRegionName, setCollectionPersisterClass, setCollectionTable, setComparator, setComparatorClassName, setCustomSQLDelete, setCustomSQLDeleteAll, setCustomSQLInsert, setCustomSQLUpdate, setElement, setElementNodeName, setEmbedded, setExtraLazy, setFetchMode, setInverse, setKey, setLazy, setLoaderName, setManyToManyOrdering, setManyToManyWhere, setMutable, setNodeName, setOptimisticLocked, setOrderBy, setOrphanDelete, setOwner, setReferencedPropertyName, setRole, setSorted, setSubselectLoadable, setTypeName, setTypeUsingReflection, setWhere, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

List

public List(PersistentClass owner)
Method Detail

isList

public boolean isList()
Overrides:
isList in class IndexedCollection

getDefaultCollectionType

public CollectionType getDefaultCollectionType()
                                        throws MappingException
Specified by:
getDefaultCollectionType in class Collection
Throws:
MappingException

accept

public Object accept(ValueVisitor visitor)

getBaseIndex

public int getBaseIndex()

setBaseIndex

public void setBaseIndex(int baseIndex)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManyToOne (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class ManyToOne

java.lang.Object
    extended by org.hibernate.mapping.SimpleValue
        extended by org.hibernate.mapping.ToOne
            extended by org.hibernate.mapping.ManyToOne
All Implemented Interfaces:
Fetchable, KeyValue, Serializable, Value
public class ManyToOne
extends ToOne

A many-to-one association mapping

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.ToOne
referencedPropertyName, unwrapProxy
Constructor Summary
ManyToOne(Table table)
Method Summary
Object | accept(ValueVisitor visitor)
void | createForeignKey()
void | createPropertyRefConstraints(Map persistentClasses)
Type | getType()
boolean | isIgnoreNotFound()
void | setIgnoreNotFound(boolean ignoreNotFound)
Methods inherited from class org.hibernate.mapping.ToOne
getFetchMode, getReferencedEntityName, getReferencedPropertyName, isEmbedded, isLazy, isTypeSpecified, isUnwrapProxy, isValid, setEmbedded, setFetchMode, setLazy, setReferencedEntityName, setReferencedPropertyName, setTypeUsingReflection, setUnwrapProxy
Methods inherited from class org.hibernate.mapping.SimpleValue
addColumn, addFormula, createForeignKeyOfEntity, createIdentifierGenerator, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getConstraintColumns, getForeignKeyName, getIdentifierGeneratorProperties, getIdentifierGeneratorStrategy, getNullValue, getTable, getTypeName, getTypeParameters, hasFormula, isAlternateUniqueKey, isCascadeDeleteEnabled, isIdentityColumn, isNullable, isSimpleValue, isUpdateable, setAlternateUniqueKey, setCascadeDeleteEnabled, setForeignKeyName, setIdentifierGeneratorProperties, setIdentifierGeneratorStrategy, setNullValue, setTable, setTypeName, setTypeParameters, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ManyToOne

public ManyToOne(Table table)
Method Detail

getType

public Type getType()
             throws MappingException
Specified by:
getType in interface Value
Specified by:
getType in class ToOne
Throws:
MappingException

createForeignKey

public void createForeignKey()
                      throws MappingException
Specified by:
createForeignKey in interface Value
Specified by:
createForeignKey in class ToOne
Throws:
MappingException

createPropertyRefConstraints

public void createPropertyRefConstraints(Map persistentClasses)

accept

public Object accept(ValueVisitor visitor)
Specified by:
accept in interface Value
Overrides:
accept in class ToOne

isIgnoreNotFound

public boolean isIgnoreNotFound()

setIgnoreNotFound

public void setIgnoreNotFound(boolean ignoreNotFound)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Map (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Map

java.lang.Object
    extended by org.hibernate.mapping.Collection
        extended by org.hibernate.mapping.IndexedCollection
            extended by org.hibernate.mapping.Map
All Implemented Interfaces:
Fetchable, Filterable, Serializable, Value
public class Map
extends IndexedCollection

A map has a primary key consisting of the key columns + index columns.

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.IndexedCollection
DEFAULT_INDEX_COLUMN_NAME
Fields inherited from class org.hibernate.mapping.Collection
DEFAULT_ELEMENT_COLUMN_NAME, DEFAULT_KEY_COLUMN_NAME
Constructor Summary
Map(PersistentClass owner)
Method Summary
Object | accept(ValueVisitor visitor)
void | createAllKeys()
CollectionType | getDefaultCollectionType()
boolean | isMap()
Methods inherited from class org.hibernate.mapping.IndexedCollection
getIndex, getIndexNodeName, isIndexed, isList, setIndex, setIndexNodeName, validate
Methods inherited from class org.hibernate.mapping.Collection
addFilter, addManyToManyFilter, createForeignKey, getBatchSize, getCacheConcurrencyStrategy, getCacheRegionName, getCollectionPersisterClass, getCollectionTable, getCollectionType, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getComparator, getComparatorClassName, getCustomSQLDelete, getCustomSQLDeleteAll, getCustomSQLDeleteAllCheckStyle, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getElement, getElementNodeName, getFetchMode, getFilterMap, getKey, getLoaderName, getManyToManyFilterMap, getManyToManyOrdering, getManyToManyWhere, getNodeName, getOrderBy, getOwner, getOwnerEntityName, getReferencedPropertyName, getRole, getSynchronizedTables, getTable, getType, getTypeName, getWhere, hasFormula, hasOrder, hasOrphanDelete, isAlternateUniqueKey, isArray, isCustomDeleteAllCallable, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isEmbedded, isExtraLazy, isIdentified, isInverse, isLazy, isMutable, isNullable, isOneToMany, isOptimisticLocked, isPrimitiveArray, isSet, isSimpleValue, isSorted, isSubselectLoadable, isValid, setBatchSize, setCacheConcurrencyStrategy, setCacheRegionName, setCollectionPersisterClass, setCollectionTable, setComparator, setComparatorClassName, setCustomSQLDelete, setCustomSQLDeleteAll, setCustomSQLInsert, setCustomSQLUpdate, setElement, setElementNodeName, setEmbedded, setExtraLazy, setFetchMode, setInverse, setKey, setLazy, setLoaderName, setManyToManyOrdering, setManyToManyWhere, setMutable, setNodeName, setOptimisticLocked, setOrderBy, setOrphanDelete, setOwner, setReferencedPropertyName, setRole, setSorted, setSubselectLoadable, setTypeName, setTypeUsingReflection, setWhere, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Map

public Map(PersistentClass owner)
Method Detail

isMap

public boolean isMap()
Overrides:
isMap in class Collection

getDefaultCollectionType

public CollectionType getDefaultCollectionType()
Specified by:
getDefaultCollectionType in class Collection

createAllKeys

public void createAllKeys()
                   throws MappingException
Overrides:
createAllKeys in class Collection
Throws:
MappingException

accept

public Object accept(ValueVisitor visitor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MetaAttribute (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class MetaAttribute

java.lang.Object
    extended by org.hibernate.mapping.MetaAttribute
All Implemented Interfaces:
Serializable
public class MetaAttribute
extends Object
implements Serializable

A meta attribute is a named value or values.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
MetaAttribute(String name)
Method Summary
void | addValue(String value)
String | getName()
String | getValue()
List | getValues()
boolean | isMultiValued()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MetaAttribute

public MetaAttribute(String name)
Method Detail

getName

public String getName()

getValues

public List getValues()

addValue

public void addValue(String value)

getValue

public String getValue()

isMultiValued

public boolean isMultiValued()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OneToMany (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class OneToMany

java.lang.Object
    extended by org.hibernate.mapping.OneToMany
All Implemented Interfaces:
Serializable, Value
public class OneToMany
extends Object
implements Value

A mapping for a one-to-many association

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
OneToMany(PersistentClass owner)
Method Summary
Object | accept(ValueVisitor visitor)
void | createForeignKey()
PersistentClass | getAssociatedClass()
boolean[] | getColumnInsertability()
Iterator | getColumnIterator()
int | getColumnSpan()
boolean[] | getColumnUpdateability()
FetchMode | getFetchMode()
String | getReferencedEntityName()
Table | getTable() Table of the owner entity (the "one" side)
Type | getType()
boolean | hasFormula()
boolean | isAlternateUniqueKey()
boolean | isEmbedded()
boolean | isIgnoreNotFound()
boolean | isNullable()
boolean | isSimpleValue()
boolean | isValid(Mapping mapping)
void | setAssociatedClass(PersistentClass associatedClass) Associated entity on the many side
void | setEmbedded(boolean embedded)
void | setIgnoreNotFound(boolean ignoreNotFound)
void | setReferencedEntityName(String referencedEntityName) Associated entity on the "many" side
void | setTypeUsingReflection(String className, String propertyName)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OneToMany

public OneToMany(PersistentClass owner)
          throws MappingException
Method Detail

getAssociatedClass

public PersistentClass getAssociatedClass()

setAssociatedClass

public void setAssociatedClass(PersistentClass associatedClass)
Associated entity on the many side

createForeignKey

public void createForeignKey()
Specified by:
createForeignKey in interface Value

getColumnIterator

public Iterator getColumnIterator()
Specified by:
getColumnIterator in interface Value

getColumnSpan

public int getColumnSpan()
Specified by:
getColumnSpan in interface Value

getFetchMode

public FetchMode getFetchMode()
Specified by:
getFetchMode in interface Value

getTable

public Table getTable()
Table of the owner entity (the "one" side)

Specified by:
getTable in interface Value

getType

public Type getType()
Specified by:
getType in interface Value

isNullable

public boolean isNullable()
Specified by:
isNullable in interface Value

isSimpleValue

public boolean isSimpleValue()
Specified by:
isSimpleValue in interface Value

isAlternateUniqueKey

public boolean isAlternateUniqueKey()
Specified by:
isAlternateUniqueKey in interface Value

hasFormula

public boolean hasFormula()
Specified by:
hasFormula in interface Value

isValid

public boolean isValid(Mapping mapping)
                throws MappingException
Specified by:
isValid in interface Value
Throws:
MappingException

getReferencedEntityName

public String getReferencedEntityName()

setReferencedEntityName

public void setReferencedEntityName(String referencedEntityName)
Associated entity on the "many" side

setTypeUsingReflection

public void setTypeUsingReflection(String className,
                                   String propertyName)
Specified by:
setTypeUsingReflection in interface Value

accept

public Object accept(ValueVisitor visitor)
Specified by:
accept in interface Value

getColumnInsertability

public boolean[] getColumnInsertability()
Specified by:
getColumnInsertability in interface Value

getColumnUpdateability

public boolean[] getColumnUpdateability()
Specified by:
getColumnUpdateability in interface Value

isEmbedded

public boolean isEmbedded()

setEmbedded

public void setEmbedded(boolean embedded)

isIgnoreNotFound

public boolean isIgnoreNotFound()

setIgnoreNotFound

public void setIgnoreNotFound(boolean ignoreNotFound)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OneToOne (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class OneToOne

java.lang.Object
    extended by org.hibernate.mapping.SimpleValue
        extended by org.hibernate.mapping.ToOne
            extended by org.hibernate.mapping.OneToOne
All Implemented Interfaces:
Fetchable, KeyValue, Serializable, Value
public class OneToOne
extends ToOne

A one-to-one association mapping

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.ToOne
referencedPropertyName, unwrapProxy
Constructor Summary
OneToOne(Table table, PersistentClass owner)
Method Summary
Object | accept(ValueVisitor visitor)
void | createForeignKey()
List | getConstraintColumns()
String | getEntityName()
ForeignKeyDirection | getForeignKeyType() Returns the foreignKeyType.
KeyValue | getIdentifier() Returns the identifier.
String | getPropertyName()
Type | getType()
boolean | isConstrained() Returns the constrained.
boolean | isNullable()
void | setConstrained(boolean constrained) Sets the constrained.
void | setEntityName(String propertyName)
void | setForeignKeyType(ForeignKeyDirection foreignKeyType) Sets the foreignKeyType.
void | setIdentifier(KeyValue identifier) Sets the identifier.
void | setPropertyName(String propertyName)
Methods inherited from class org.hibernate.mapping.ToOne
getFetchMode, getReferencedEntityName, getReferencedPropertyName, isEmbedded, isLazy, isTypeSpecified, isUnwrapProxy, isValid, setEmbedded, setFetchMode, setLazy, setReferencedEntityName, setReferencedPropertyName, setTypeUsingReflection, setUnwrapProxy
Methods inherited from class org.hibernate.mapping.SimpleValue
addColumn, addFormula, createForeignKeyOfEntity, createIdentifierGenerator, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getForeignKeyName, getIdentifierGeneratorProperties, getIdentifierGeneratorStrategy, getNullValue, getTable, getTypeName, getTypeParameters, hasFormula, isAlternateUniqueKey, isCascadeDeleteEnabled, isIdentityColumn, isSimpleValue, isUpdateable, setAlternateUniqueKey, setCascadeDeleteEnabled, setForeignKeyName, setIdentifierGeneratorProperties, setIdentifierGeneratorStrategy, setNullValue, setTable, setTypeName, setTypeParameters, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OneToOne

public OneToOne(Table table,
                PersistentClass owner)
         throws MappingException
Method Detail

getPropertyName

public String getPropertyName()

setPropertyName

public void setPropertyName(String propertyName)

getEntityName

public String getEntityName()

setEntityName

public void setEntityName(String propertyName)

getType

public Type getType()
             throws MappingException
Specified by:
getType in interface Value
Specified by:
getType in class ToOne
Throws:
MappingException

createForeignKey

public void createForeignKey()
                      throws MappingException
Specified by:
createForeignKey in interface Value
Specified by:
createForeignKey in class ToOne
Throws:
MappingException

getConstraintColumns

public List getConstraintColumns()
Overrides:
getConstraintColumns in class SimpleValue

isConstrained

public boolean isConstrained()
Returns the constrained.

Returns:
boolean

getForeignKeyType

public ForeignKeyDirection getForeignKeyType()
Returns the foreignKeyType.

Returns:
AssociationType.ForeignKeyType

getIdentifier

public KeyValue getIdentifier()
Returns the identifier.

Returns:
Value

setConstrained

public void setConstrained(boolean constrained)
Sets the constrained.

Parameters:
constrained - The constrained to set

setForeignKeyType

public void setForeignKeyType(ForeignKeyDirection foreignKeyType)
Sets the foreignKeyType.

Parameters:
foreignKeyType - The foreignKeyType to set

setIdentifier

public void setIdentifier(KeyValue identifier)
Sets the identifier.

Parameters:
identifier - The identifier to set

isNullable

public boolean isNullable()
Specified by:
isNullable in interface Value
Overrides:
isNullable in class SimpleValue

accept

public Object accept(ValueVisitor visitor)
Specified by:
accept in interface Value
Overrides:
accept in class ToOne
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PersistentClass (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class PersistentClass

java.lang.Object
    extended by org.hibernate.mapping.PersistentClass
All Implemented Interfaces:
Filterable, MetaAttributable, Serializable
Direct Known Subclasses:
RootClass, Subclass
public abstract class PersistentClass
extends Object
implements Serializable, Filterable, MetaAttributable

Mapping for an entity.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
static String | NOT_NULL_DISCRIMINATOR_MAPPING
static String | NULL_DISCRIMINATOR_MAPPING
protected int | optimisticLockMode
protected Set | synchronizedTables
Constructor Summary
PersistentClass()
Method Summary
abstract Object | accept(PersistentClassVisitor mv)
void | addFilter(String name, String condition)
void | addJoin(Join join)
void | addProperty(Property p)
void | addSubclass(Subclass subclass)
protected void | addSubclassJoin(Join join)
protected void | addSubclassProperty(Property prop)
protected void | addSubclassTable(Table subclassTable)
void | addSynchronizedTable(String table)
void | addTuplizer(EntityMode entityMode, String implClassName)
protected void | checkColumnDuplication()
protected void | checkColumnDuplication(Set distinctColumns, Iterator columns)
protected void | checkPropertyColumnDuplication(Set distinctColumns, Iterator properties)
void | createPrimaryKey()
int | getBatchSize()
abstract String | getCacheConcurrencyStrategy()
String | getClassName()
String | getCustomSQLDelete()
ExecuteUpdateResultCheckStyle | getCustomSQLDeleteCheckStyle()
String | getCustomSQLInsert()
ExecuteUpdateResultCheckStyle | getCustomSQLInsertCheckStyle()
String | getCustomSQLUpdate()
ExecuteUpdateResultCheckStyle | getCustomSQLUpdateCheckStyle()
Iterator | getDirectSubclasses()
abstract Value | getDiscriminator()
protected Iterator | getDiscriminatorColumnIterator()
String | getDiscriminatorValue()
String | getEntityName()
abstract Class | getEntityPersisterClass()
Map | getFilterMap()
abstract KeyValue | getIdentifier()
Component | getIdentifierMapper()
abstract Property | getIdentifierProperty()
Table | getIdentityTable()
Iterator | getJoinClosureIterator()
int | getJoinClosureSpan()
Iterator | getJoinIterator()
int | getJoinNumber(Property prop)
abstract KeyValue | getKey()
abstract Iterator | getKeyClosureIterator()
String | getLoaderName()
Class | getMappedClass()
MetaAttribute | getMetaAttribute(String name)
Map | getMetaAttributes()
String | getNodeName()
protected Iterator | getNonDuplicatedPropertyIterator()
abstract int | getOptimisticLockMode()
Property | getProperty(String propertyName)
abstract Iterator | getPropertyClosureIterator()
int | getPropertyClosureSpan()
Iterator | getPropertyIterator()
Class | getProxyInterface()
String | getProxyInterfaceName()
Property | getRecursiveProperty(String propertyPath)
Iterator | getReferenceablePropertyIterator()
Property | getReferencedProperty(String propertyPath)
abstract RootClass | getRootClass()
abstract Table | getRootTable()
Iterator | getSubclassClosureIterator()
abstract int | getSubclassId()
Iterator | getSubclassIterator() Iterate over subclasses in a special 'order', most derived subclasses first.
Iterator | getSubclassJoinClosureIterator()
Iterator | getSubclassPropertyClosureIterator()
int | getSubclassSpan()
Iterator | getSubclassTableClosureIterator()
abstract PersistentClass | getSuperclass()
abstract Set | getSynchronizedTables()
abstract Table | getTable()
abstract Iterator | getTableClosureIterator()
String | getTemporaryIdTableDDL()
String | getTemporaryIdTableName()
String | getTuplizerImplClassName(EntityMode mode)
Map | getTuplizerMap()
Iterator | getUnjoinedPropertyIterator()
abstract Property | getVersion()
abstract String | getWhere()
boolean | hasDom4jRepresentation()
abstract boolean | hasEmbeddedIdentifier()
boolean | hasIdentifierMapper()
abstract boolean | hasIdentifierProperty()
boolean | hasNaturalId()
boolean | hasPojoRepresentation()
boolean | hasSelectBeforeUpdate()
boolean | hasSubclasses()
boolean | hasSubselectLoadableCollections()
Boolean | isAbstract()
boolean | isClassOrSuperclassJoin(Join join)
boolean | isClassOrSuperclassTable(Table closureTable)
boolean | isCustomDeleteCallable()
boolean | isCustomInsertCallable()
boolean | isCustomUpdateCallable()
abstract boolean | isDiscriminatorInsertable()
boolean | isDiscriminatorValueNotNull()
boolean | isDiscriminatorValueNull()
abstract boolean | isExplicitPolymorphism()
boolean | isForceDiscriminator()
abstract boolean | isInherited()
abstract boolean | isJoinedSubclass()
boolean | isLazy()
abstract boolean | isLazyPropertiesCacheable()
abstract boolean | isMutable()
abstract boolean | isPolymorphic()
abstract boolean | isVersioned()
void | prepareTemporaryTables(Mapping mapping, Dialect dialect)
void | setAbstract(Boolean isAbstract)
void | setBatchSize(int batchSize)
void | setClassName(String className)
void | setCustomSQLDelete(String customSQLDelete, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | setCustomSQLInsert(String customSQLInsert, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | setCustomSQLUpdate(String customSQLUpdate, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | setDiscriminatorValue(String discriminatorValue)
void | setDynamicInsert(boolean dynamicInsert)
void | setDynamicUpdate(boolean dynamicUpdate)
void | setEntityName(String entityName)
abstract void | setEntityPersisterClass(Class classPersisterClass)
void | setIdentifierMapper(Component handle)
void | setLazy(boolean lazy)
void | setLoaderName(String loaderName)
void | setMetaAttributes(Map metas)
void | setNodeName(String nodeName)
void | setOptimisticLockMode(int optimisticLockMode)
void | setProxyInterfaceName(String proxyInterfaceName)
void | setSelectBeforeUpdate(boolean selectBeforeUpdate)
void | setSubselectLoadableCollections(boolean hasSubselectCollections)
String | toString()
boolean | useDynamicInsert()
boolean | useDynamicUpdate()
void | validate(Mapping mapping)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NULL_DISCRIMINATOR_MAPPING

public static final String NULL_DISCRIMINATOR_MAPPING
See Also:
Constant Field Values

NOT_NULL_DISCRIMINATOR_MAPPING

public static final String NOT_NULL_DISCRIMINATOR_MAPPING
See Also:
Constant Field Values

synchronizedTables

protected final Set synchronizedTables

optimisticLockMode

protected int optimisticLockMode
Constructor Detail

PersistentClass

public PersistentClass()
Method Detail

getClassName

public String getClassName()

setClassName

public void setClassName(String className)

getProxyInterfaceName

public String getProxyInterfaceName()

setProxyInterfaceName

public void setProxyInterfaceName(String proxyInterfaceName)

getMappedClass

public Class getMappedClass()
                     throws MappingException
Throws:
MappingException

getProxyInterface

public Class getProxyInterface()

useDynamicInsert

public boolean useDynamicInsert()

getSubclassId

public abstract int getSubclassId()

useDynamicUpdate

public boolean useDynamicUpdate()

setDynamicInsert

public void setDynamicInsert(boolean dynamicInsert)

setDynamicUpdate

public void setDynamicUpdate(boolean dynamicUpdate)

getDiscriminatorValue

public String getDiscriminatorValue()

addSubclass

public void addSubclass(Subclass subclass)
                 throws MappingException
Throws:
MappingException

hasSubclasses

public boolean hasSubclasses()

getSubclassSpan

public int getSubclassSpan()

getSubclassIterator

public Iterator getSubclassIterator()
Iterate over subclasses in a special 'order', most derived subclasses first.

getSubclassClosureIterator

public Iterator getSubclassClosureIterator()

getIdentityTable

public Table getIdentityTable()

getDirectSubclasses

public Iterator getDirectSubclasses()

addProperty

public void addProperty(Property p)

getTable

public abstract Table getTable()

getEntityName

public String getEntityName()

isMutable

public abstract boolean isMutable()

hasIdentifierProperty

public abstract boolean hasIdentifierProperty()

getIdentifierProperty

public abstract Property getIdentifierProperty()

getIdentifier

public abstract KeyValue getIdentifier()

getVersion

public abstract Property getVersion()

getDiscriminator

public abstract Value getDiscriminator()

isInherited

public abstract boolean isInherited()

isPolymorphic

public abstract boolean isPolymorphic()

isVersioned

public abstract boolean isVersioned()

getCacheConcurrencyStrategy

public abstract String getCacheConcurrencyStrategy()

getSuperclass

public abstract PersistentClass getSuperclass()

isExplicitPolymorphism

public abstract boolean isExplicitPolymorphism()

isDiscriminatorInsertable

public abstract boolean isDiscriminatorInsertable()

getPropertyClosureIterator

public abstract Iterator getPropertyClosureIterator()

getTableClosureIterator

public abstract Iterator getTableClosureIterator()

getKeyClosureIterator

public abstract Iterator getKeyClosureIterator()

addSubclassProperty

protected void addSubclassProperty(Property prop)

addSubclassJoin

protected void addSubclassJoin(Join join)

addSubclassTable

protected void addSubclassTable(Table subclassTable)

getSubclassPropertyClosureIterator

public Iterator getSubclassPropertyClosureIterator()

getSubclassJoinClosureIterator

public Iterator getSubclassJoinClosureIterator()

getSubclassTableClosureIterator

public Iterator getSubclassTableClosureIterator()

isClassOrSuperclassJoin

public boolean isClassOrSuperclassJoin(Join join)

isClassOrSuperclassTable

public boolean isClassOrSuperclassTable(Table closureTable)

isLazy

public boolean isLazy()

setLazy

public void setLazy(boolean lazy)

hasEmbeddedIdentifier

public abstract boolean hasEmbeddedIdentifier()

getEntityPersisterClass

public abstract Class getEntityPersisterClass()

setEntityPersisterClass

public abstract void setEntityPersisterClass(Class classPersisterClass)

getRootTable

public abstract Table getRootTable()

getRootClass

public abstract RootClass getRootClass()

getKey

public abstract KeyValue getKey()

setDiscriminatorValue

public void setDiscriminatorValue(String discriminatorValue)

setEntityName

public void setEntityName(String entityName)

createPrimaryKey

public void createPrimaryKey()

getWhere

public abstract String getWhere()

getBatchSize

public int getBatchSize()

setBatchSize

public void setBatchSize(int batchSize)

hasSelectBeforeUpdate

public boolean hasSelectBeforeUpdate()

setSelectBeforeUpdate

public void setSelectBeforeUpdate(boolean selectBeforeUpdate)

getReferenceablePropertyIterator

public Iterator getReferenceablePropertyIterator()

getReferencedProperty

public Property getReferencedProperty(String propertyPath)
                               throws MappingException
Throws:
MappingException

getRecursiveProperty

public Property getRecursiveProperty(String propertyPath)
                              throws MappingException
Throws:
MappingException

getProperty

public Property getProperty(String propertyName)
                     throws MappingException
Throws:
MappingException

getOptimisticLockMode

public abstract int getOptimisticLockMode()

setOptimisticLockMode

public void setOptimisticLockMode(int optimisticLockMode)

validate

public void validate(Mapping mapping)
              throws MappingException
Throws:
MappingException

isDiscriminatorValueNotNull

public boolean isDiscriminatorValueNotNull()

isDiscriminatorValueNull

public boolean isDiscriminatorValueNull()

getMetaAttributes

public Map getMetaAttributes()
Specified by:
getMetaAttributes in interface MetaAttributable

setMetaAttributes

public void setMetaAttributes(Map metas)
Specified by:
setMetaAttributes in interface MetaAttributable

getMetaAttribute

public MetaAttribute getMetaAttribute(String name)
Specified by:
getMetaAttribute in interface MetaAttributable

toString

public String toString()

getJoinIterator

public Iterator getJoinIterator()

getJoinClosureIterator

public Iterator getJoinClosureIterator()

addJoin

public void addJoin(Join join)

getJoinClosureSpan

public int getJoinClosureSpan()

getPropertyClosureSpan

public int getPropertyClosureSpan()

getJoinNumber

public int getJoinNumber(Property prop)

getPropertyIterator

public Iterator getPropertyIterator()

getUnjoinedPropertyIterator

public Iterator getUnjoinedPropertyIterator()

setCustomSQLInsert

public void setCustomSQLInsert(String customSQLInsert,
                               boolean callable,
                               ExecuteUpdateResultCheckStyle checkStyle)

getCustomSQLInsert

public String getCustomSQLInsert()

isCustomInsertCallable

public boolean isCustomInsertCallable()

getCustomSQLInsertCheckStyle

public ExecuteUpdateResultCheckStyle getCustomSQLInsertCheckStyle()

setCustomSQLUpdate

public void setCustomSQLUpdate(String customSQLUpdate,
                               boolean callable,
                               ExecuteUpdateResultCheckStyle checkStyle)

getCustomSQLUpdate

public String getCustomSQLUpdate()

isCustomUpdateCallable

public boolean isCustomUpdateCallable()

getCustomSQLUpdateCheckStyle

public ExecuteUpdateResultCheckStyle getCustomSQLUpdateCheckStyle()

setCustomSQLDelete

public void setCustomSQLDelete(String customSQLDelete,
                               boolean callable,
                               ExecuteUpdateResultCheckStyle checkStyle)

getCustomSQLDelete

public String getCustomSQLDelete()

isCustomDeleteCallable

public boolean isCustomDeleteCallable()

getCustomSQLDeleteCheckStyle

public ExecuteUpdateResultCheckStyle getCustomSQLDeleteCheckStyle()

addFilter

public void addFilter(String name,
                      String condition)
Specified by:
addFilter in interface Filterable

getFilterMap

public Map getFilterMap()
Specified by:
getFilterMap in interface Filterable

isForceDiscriminator

public boolean isForceDiscriminator()

isJoinedSubclass

public abstract boolean isJoinedSubclass()

getLoaderName

public String getLoaderName()

setLoaderName

public void setLoaderName(String loaderName)

getSynchronizedTables

public abstract Set getSynchronizedTables()

addSynchronizedTable

public void addSynchronizedTable(String table)

isAbstract

public Boolean isAbstract()

setAbstract

public void setAbstract(Boolean isAbstract)

checkColumnDuplication

protected void checkColumnDuplication(Set distinctColumns,
                                      Iterator columns)
                               throws MappingException
Throws:
MappingException

checkPropertyColumnDuplication

protected void checkPropertyColumnDuplication(Set distinctColumns,
                                              Iterator properties)
                                       throws MappingException
Throws:
MappingException

getNonDuplicatedPropertyIterator

protected Iterator getNonDuplicatedPropertyIterator()

getDiscriminatorColumnIterator

protected Iterator getDiscriminatorColumnIterator()

checkColumnDuplication

protected void checkColumnDuplication()

accept

public abstract Object accept(PersistentClassVisitor mv)

getNodeName

public String getNodeName()

setNodeName

public void setNodeName(String nodeName)

hasPojoRepresentation

public boolean hasPojoRepresentation()

hasDom4jRepresentation

public boolean hasDom4jRepresentation()

hasSubselectLoadableCollections

public boolean hasSubselectLoadableCollections()

setSubselectLoadableCollections

public void setSubselectLoadableCollections(boolean hasSubselectCollections)

prepareTemporaryTables

public void prepareTemporaryTables(Mapping mapping,
                                   Dialect dialect)

getTemporaryIdTableName

public String getTemporaryIdTableName()

getTemporaryIdTableDDL

public String getTemporaryIdTableDDL()

getIdentifierMapper

public Component getIdentifierMapper()

hasIdentifierMapper

public boolean hasIdentifierMapper()

setIdentifierMapper

public void setIdentifierMapper(Component handle)

addTuplizer

public void addTuplizer(EntityMode entityMode,
                        String implClassName)

getTuplizerImplClassName

public String getTuplizerImplClassName(EntityMode mode)

getTuplizerMap

public Map getTuplizerMap()

hasNaturalId

public boolean hasNaturalId()

isLazyPropertiesCacheable

public abstract boolean isLazyPropertiesCacheable()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrimaryKey (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class PrimaryKey

java.lang.Object
    extended by org.hibernate.mapping.Constraint
        extended by org.hibernate.mapping.PrimaryKey
All Implemented Interfaces:
RelationalModel, Serializable
public class PrimaryKey
extends Constraint

A primary key constraint

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
PrimaryKey()
Method Summary
String | sqlConstraintString(Dialect dialect)
String | sqlConstraintString(Dialect dialect, String constraintName, String defaultCatalog, String defaultSchema)
Methods inherited from class org.hibernate.mapping.Constraint
addColumn, addColumns, columnIterator, containsColumn, getColumn, getColumnIterator, getColumns, getColumnSpan, getName, getTable, setName, setTable, sqlCreateString, sqlDropString, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PrimaryKey

public PrimaryKey()
Method Detail

sqlConstraintString

public String sqlConstraintString(Dialect dialect)

sqlConstraintString

public String sqlConstraintString(Dialect dialect,
                                  String constraintName,
                                  String defaultCatalog,
                                  String defaultSchema)
Specified by:
sqlConstraintString in class Constraint
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrimitiveArray (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class PrimitiveArray

java.lang.Object
    extended by org.hibernate.mapping.Collection
        extended by org.hibernate.mapping.IndexedCollection
            extended by org.hibernate.mapping.List
                extended by org.hibernate.mapping.Array
                    extended by org.hibernate.mapping.PrimitiveArray
All Implemented Interfaces:
Fetchable, Filterable, Serializable, Value
public class PrimitiveArray
extends Array

A primitive array has a primary key consisting of the key columns + index column.

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.IndexedCollection
DEFAULT_INDEX_COLUMN_NAME
Fields inherited from class org.hibernate.mapping.Collection
DEFAULT_ELEMENT_COLUMN_NAME, DEFAULT_KEY_COLUMN_NAME
Constructor Summary
PrimitiveArray(PersistentClass owner)
Method Summary
Object | accept(ValueVisitor visitor)
boolean | isPrimitiveArray()
Methods inherited from class org.hibernate.mapping.Array
getDefaultCollectionType, getElementClass, getElementClassName, isArray, setElementClassName
Methods inherited from class org.hibernate.mapping.List
getBaseIndex, isList, setBaseIndex
Methods inherited from class org.hibernate.mapping.IndexedCollection
getIndex, getIndexNodeName, isIndexed, setIndex, setIndexNodeName, validate
Methods inherited from class org.hibernate.mapping.Collection
addFilter, addManyToManyFilter, createAllKeys, createForeignKey, getBatchSize, getCacheConcurrencyStrategy, getCacheRegionName, getCollectionPersisterClass, getCollectionTable, getCollectionType, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getComparator, getComparatorClassName, getCustomSQLDelete, getCustomSQLDeleteAll, getCustomSQLDeleteAllCheckStyle, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getElement, getElementNodeName, getFetchMode, getFilterMap, getKey, getLoaderName, getManyToManyFilterMap, getManyToManyOrdering, getManyToManyWhere, getNodeName, getOrderBy, getOwner, getOwnerEntityName, getReferencedPropertyName, getRole, getSynchronizedTables, getTable, getType, getTypeName, getWhere, hasFormula, hasOrder, hasOrphanDelete, isAlternateUniqueKey, isCustomDeleteAllCallable, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isEmbedded, isExtraLazy, isIdentified, isInverse, isLazy, isMap, isMutable, isNullable, isOneToMany, isOptimisticLocked, isSet, isSimpleValue, isSorted, isSubselectLoadable, isValid, setBatchSize, setCacheConcurrencyStrategy, setCacheRegionName, setCollectionPersisterClass, setCollectionTable, setComparator, setComparatorClassName, setCustomSQLDelete, setCustomSQLDeleteAll, setCustomSQLInsert, setCustomSQLUpdate, setElement, setElementNodeName, setEmbedded, setExtraLazy, setFetchMode, setInverse, setKey, setLazy, setLoaderName, setManyToManyOrdering, setManyToManyWhere, setMutable, setNodeName, setOptimisticLocked, setOrderBy, setOrphanDelete, setOwner, setReferencedPropertyName, setRole, setSorted, setSubselectLoadable, setTypeName, setTypeUsingReflection, setWhere, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PrimitiveArray

public PrimitiveArray(PersistentClass owner)
Method Detail

isPrimitiveArray

public boolean isPrimitiveArray()
Overrides:
isPrimitiveArray in class Collection

accept

public Object accept(ValueVisitor visitor)
Specified by:
accept in interface Value
Overrides:
accept in class Array
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Property (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Property

java.lang.Object
    extended by org.hibernate.mapping.Property
All Implemented Interfaces:
MetaAttributable, Serializable
Direct Known Subclasses:
Backref, IndexBackref
public class Property
extends Object
implements Serializable, MetaAttributable

Represents a property as part of an entity or a component.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
Property()
Method Summary
String | getAccessorPropertyName(EntityMode mode)
String | getCascade()
CascadeStyle | getCascadeStyle()
Iterator | getColumnIterator()
int | getColumnSpan()
PropertyGeneration | getGeneration()
Getter | getGetter(Class clazz)
MetaAttribute | getMetaAttribute(String attributeName)
Map | getMetaAttributes()
String | getName()
String | getNodeName()
PersistentClass | getPersistentClass()
PropertyAccessor | getPropertyAccessor(Class clazz)
String | getPropertyAccessorName()
Setter | getSetter(Class clazz)
Type | getType()
Value | getValue()
boolean | isBackRef()
boolean | isBasicPropertyAccessor()
boolean | isComposite()
boolean | isInsertable()
boolean | isLazy()
boolean | isNaturalIdentifier()
boolean | isOptimisticLocked()
boolean | isOptional()
boolean | isPrimitive(Class clazz)
boolean | isSelectable()
boolean | isUpdateable()
boolean | isValid(Mapping mapping)
void | setCascade(String cascade)
void | setGeneration(PropertyGeneration generation)
void | setInsertable(boolean insertable)
void | setLazy(boolean lazy)
void | setMetaAttributes(Map metas)
void | setName(String name)
void | setNaturalIdentifier(boolean naturalIdentifier)
void | setNodeName(String nodeName)
void | setOptimisticLocked(boolean optimisticLocked)
void | setOptional(boolean optional)
void | setPersistentClass(PersistentClass persistentClass)
void | setPropertyAccessorName(String string)
void | setSelectable(boolean selectable)
void | setUpdateable(boolean mutable)
void | setValue(Value value)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Property

public Property()
Method Detail

isBackRef

public boolean isBackRef()

getType

public Type getType()
             throws MappingException
Throws:
MappingException

getColumnSpan

public int getColumnSpan()

getColumnIterator

public Iterator getColumnIterator()

getName

public String getName()

isComposite

public boolean isComposite()

getValue

public Value getValue()

isPrimitive

public boolean isPrimitive(Class clazz)

getCascadeStyle

public CascadeStyle getCascadeStyle()
                             throws MappingException
Throws:
MappingException

getCascade

public String getCascade()

setCascade

public void setCascade(String cascade)

setName

public void setName(String name)

setValue

public void setValue(Value value)

isUpdateable

public boolean isUpdateable()

isInsertable

public boolean isInsertable()

getGeneration

public PropertyGeneration getGeneration()

setGeneration

public void setGeneration(PropertyGeneration generation)

setUpdateable

public void setUpdateable(boolean mutable)

setInsertable

public void setInsertable(boolean insertable)

getPropertyAccessorName

public String getPropertyAccessorName()

setPropertyAccessorName

public void setPropertyAccessorName(String string)

isBasicPropertyAccessor

public boolean isBasicPropertyAccessor()

getMetaAttributes

public Map getMetaAttributes()
Specified by:
getMetaAttributes in interface MetaAttributable

getMetaAttribute

public MetaAttribute getMetaAttribute(String attributeName)
Specified by:
getMetaAttribute in interface MetaAttributable

setMetaAttributes

public void setMetaAttributes(Map metas)
Specified by:
setMetaAttributes in interface MetaAttributable

isValid

public boolean isValid(Mapping mapping)
                throws MappingException
Throws:
MappingException

toString

public String toString()

setLazy

public void setLazy(boolean lazy)

isLazy

public boolean isLazy()

isOptimisticLocked

public boolean isOptimisticLocked()

setOptimisticLocked

public void setOptimisticLocked(boolean optimisticLocked)

isOptional

public boolean isOptional()

setOptional

public void setOptional(boolean optional)

getPersistentClass

public PersistentClass getPersistentClass()

setPersistentClass

public void setPersistentClass(PersistentClass persistentClass)

isSelectable

public boolean isSelectable()

setSelectable

public void setSelectable(boolean selectable)

getNodeName

public String getNodeName()

setNodeName

public void setNodeName(String nodeName)

getAccessorPropertyName

public String getAccessorPropertyName(EntityMode mode)

getGetter

public Getter getGetter(Class clazz)
                 throws PropertyNotFoundException,
                        MappingException
Throws:
PropertyNotFoundException
MappingException

getSetter

public Setter getSetter(Class clazz)
                 throws PropertyNotFoundException,
                        MappingException
Throws:
PropertyNotFoundException
MappingException

getPropertyAccessor

public PropertyAccessor getPropertyAccessor(Class clazz)
                                     throws MappingException
Throws:
MappingException

isNaturalIdentifier

public boolean isNaturalIdentifier()

setNaturalIdentifier

public void setNaturalIdentifier(boolean naturalIdentifier)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyGeneration (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class PropertyGeneration

java.lang.Object
    extended by org.hibernate.mapping.PropertyGeneration
All Implemented Interfaces:
Serializable
public class PropertyGeneration
extends Object
implements Serializable

Indicates whether given properties are generated by the database and, if so, at what time(s) they are generated.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
static PropertyGeneration | ALWAYS Values for this property are generated by the database on both insert and update.
static PropertyGeneration | INSERT Values for this property are generated by the database on insert.
static PropertyGeneration | NEVER Values for this property are never generated by the database.
Method Summary
String | getName()
static PropertyGeneration | parse(String name)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

NEVER

public static final PropertyGeneration NEVER
Values for this property are never generated by the database.

INSERT

public static final PropertyGeneration INSERT
Values for this property are generated by the database on insert.

ALWAYS

public static final PropertyGeneration ALWAYS
Values for this property are generated by the database on both insert and update.

Method Detail

getName

public String getName()

parse

public static PropertyGeneration parse(String name)

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RootClass (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class RootClass

java.lang.Object
    extended by org.hibernate.mapping.PersistentClass
        extended by org.hibernate.mapping.RootClass
All Implemented Interfaces:
Filterable, MetaAttributable, Serializable, TableOwner
public class RootClass
extends PersistentClass
implements TableOwner

The root class of an inheritance hierarchy

Author:
Gavin King
See Also:
Serialized Form

Field Summary
static String | DEFAULT_DISCRIMINATOR_COLUMN_NAME
static String | DEFAULT_IDENTIFIER_COLUMN_NAME
Fields inherited from class org.hibernate.mapping.PersistentClass
NOT_NULL_DISCRIMINATOR_MAPPING, NULL_DISCRIMINATOR_MAPPING, optimisticLockMode, synchronizedTables
Constructor Summary
RootClass()
Method Summary
Object | accept(PersistentClassVisitor mv)
void | addSubclass(Subclass subclass)
String | getCacheConcurrencyStrategy()
String | getCacheRegionName()
Value | getDiscriminator()
Class | getEntityPersisterClass()
KeyValue | getIdentifier()
Property | getIdentifierProperty()
Set | getIdentityTables()
KeyValue | getKey()
Iterator | getKeyClosureIterator()
int | getOptimisticLockMode()
Iterator | getPropertyClosureIterator()
RootClass | getRootClass()
Table | getRootTable()
int | getSubclassId()
PersistentClass | getSuperclass()
Set | getSynchronizedTables()
Table | getTable()
Iterator | getTableClosureIterator()
Property | getVersion()
String | getWhere()
boolean | hasEmbeddedIdentifier()
boolean | hasIdentifierProperty()
boolean | isDiscriminatorInsertable()
boolean | isExplicitPolymorphism()
boolean | isForceDiscriminator()
boolean | isInherited()
boolean | isJoinedSubclass()
boolean | isLazyPropertiesCacheable()
boolean | isMutable()
boolean | isPolymorphic()
boolean | isVersioned()
void | setCacheConcurrencyStrategy(String cacheConcurrencyStrategy)
void | setCacheRegionName(String cacheRegionName)
void | setDiscriminator(Value discriminator)
void | setDiscriminatorInsertable(boolean insertable)
void | setEmbeddedIdentifier(boolean embeddedIdentifier)
void | setEntityPersisterClass(Class persister)
void | setExplicitPolymorphism(boolean explicitPolymorphism)
void | setForceDiscriminator(boolean forceDiscriminator)
void | setIdentifier(KeyValue identifier)
void | setIdentifierProperty(Property identifierProperty)
void | setLazyPropertiesCacheable(boolean lazyPropertiesCacheable)
void | setMutable(boolean mutable)
void | setPolymorphic(boolean polymorphic)
void | setTable(Table table)
void | setVersion(Property version)
void | setWhere(String string)
void | validate(Mapping mapping)
Methods inherited from class org.hibernate.mapping.PersistentClass
addFilter, addJoin, addProperty, addSubclassJoin, addSubclassProperty, addSubclassTable, addSynchronizedTable, addTuplizer, checkColumnDuplication, checkColumnDuplication, checkPropertyColumnDuplication, createPrimaryKey, getBatchSize, getClassName, getCustomSQLDelete, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getDirectSubclasses, getDiscriminatorColumnIterator, getDiscriminatorValue, getEntityName, getFilterMap, getIdentifierMapper, getIdentityTable, getJoinClosureIterator, getJoinClosureSpan, getJoinIterator, getJoinNumber, getLoaderName, getMappedClass, getMetaAttribute, getMetaAttributes, getNodeName, getNonDuplicatedPropertyIterator, getProperty, getPropertyClosureSpan, getPropertyIterator, getProxyInterface, getProxyInterfaceName, getRecursiveProperty, getReferenceablePropertyIterator, getReferencedProperty, getSubclassClosureIterator, getSubclassIterator, getSubclassJoinClosureIterator, getSubclassPropertyClosureIterator, getSubclassSpan, getSubclassTableClosureIterator, getTemporaryIdTableDDL, getTemporaryIdTableName, getTuplizerImplClassName, getTuplizerMap, getUnjoinedPropertyIterator, hasDom4jRepresentation, hasIdentifierMapper, hasNaturalId, hasPojoRepresentation, hasSelectBeforeUpdate, hasSubclasses, hasSubselectLoadableCollections, isAbstract, isClassOrSuperclassJoin, isClassOrSuperclassTable, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isDiscriminatorValueNotNull, isDiscriminatorValueNull, isLazy, prepareTemporaryTables, setAbstract, setBatchSize, setClassName, setCustomSQLDelete, setCustomSQLInsert, setCustomSQLUpdate, setDiscriminatorValue, setDynamicInsert, setDynamicUpdate, setEntityName, setIdentifierMapper, setLazy, setLoaderName, setMetaAttributes, setNodeName, setOptimisticLockMode, setProxyInterfaceName, setSelectBeforeUpdate, setSubselectLoadableCollections, toString, useDynamicInsert, useDynamicUpdate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

DEFAULT_IDENTIFIER_COLUMN_NAME

public static final String DEFAULT_IDENTIFIER_COLUMN_NAME
See Also:
Constant Field Values

DEFAULT_DISCRIMINATOR_COLUMN_NAME

public static final String DEFAULT_DISCRIMINATOR_COLUMN_NAME
See Also:
Constant Field Values
Constructor Detail

RootClass

public RootClass()
Method Detail

getSubclassId

public int getSubclassId()
Specified by:
getSubclassId in class PersistentClass

setTable

public void setTable(Table table)
Specified by:
setTable in interface TableOwner

getTable

public Table getTable()
Specified by:
getTable in class PersistentClass

getIdentifierProperty

public Property getIdentifierProperty()
Specified by:
getIdentifierProperty in class PersistentClass

getIdentifier

public KeyValue getIdentifier()
Specified by:
getIdentifier in class PersistentClass

hasIdentifierProperty

public boolean hasIdentifierProperty()
Specified by:
hasIdentifierProperty in class PersistentClass

getDiscriminator

public Value getDiscriminator()
Specified by:
getDiscriminator in class PersistentClass

isInherited

public boolean isInherited()
Specified by:
isInherited in class PersistentClass

isPolymorphic

public boolean isPolymorphic()
Specified by:
isPolymorphic in class PersistentClass

setPolymorphic

public void setPolymorphic(boolean polymorphic)

getRootClass

public RootClass getRootClass()
Specified by:
getRootClass in class PersistentClass

getPropertyClosureIterator

public Iterator getPropertyClosureIterator()
Specified by:
getPropertyClosureIterator in class PersistentClass

getTableClosureIterator

public Iterator getTableClosureIterator()
Specified by:
getTableClosureIterator in class PersistentClass

getKeyClosureIterator

public Iterator getKeyClosureIterator()
Specified by:
getKeyClosureIterator in class PersistentClass

addSubclass

public void addSubclass(Subclass subclass)
                 throws MappingException
Overrides:
addSubclass in class PersistentClass
Throws:
MappingException

isExplicitPolymorphism

public boolean isExplicitPolymorphism()
Specified by:
isExplicitPolymorphism in class PersistentClass

getVersion

public Property getVersion()
Specified by:
getVersion in class PersistentClass

setVersion

public void setVersion(Property version)

isVersioned

public boolean isVersioned()
Specified by:
isVersioned in class PersistentClass

isMutable

public boolean isMutable()
Specified by:
isMutable in class PersistentClass

hasEmbeddedIdentifier

public boolean hasEmbeddedIdentifier()
Specified by:
hasEmbeddedIdentifier in class PersistentClass

getEntityPersisterClass

public Class getEntityPersisterClass()
Specified by:
getEntityPersisterClass in class PersistentClass

getRootTable

public Table getRootTable()
Specified by:
getRootTable in class PersistentClass

setEntityPersisterClass

public void setEntityPersisterClass(Class persister)
Specified by:
setEntityPersisterClass in class PersistentClass

getSuperclass

public PersistentClass getSuperclass()
Specified by:
getSuperclass in class PersistentClass

getKey

public KeyValue getKey()
Specified by:
getKey in class PersistentClass

setDiscriminator

public void setDiscriminator(Value discriminator)

setEmbeddedIdentifier

public void setEmbeddedIdentifier(boolean embeddedIdentifier)

setExplicitPolymorphism

public void setExplicitPolymorphism(boolean explicitPolymorphism)

setIdentifier

public void setIdentifier(KeyValue identifier)

setIdentifierProperty

public void setIdentifierProperty(Property identifierProperty)

setMutable

public void setMutable(boolean mutable)

isDiscriminatorInsertable

public boolean isDiscriminatorInsertable()
Specified by:
isDiscriminatorInsertable in class PersistentClass

setDiscriminatorInsertable

public void setDiscriminatorInsertable(boolean insertable)

isForceDiscriminator

public boolean isForceDiscriminator()
Overrides:
isForceDiscriminator in class PersistentClass

setForceDiscriminator

public void setForceDiscriminator(boolean forceDiscriminator)

getWhere

public String getWhere()
Specified by:
getWhere in class PersistentClass

setWhere

public void setWhere(String string)

validate

public void validate(Mapping mapping)
              throws MappingException
Overrides:
validate in class PersistentClass
Throws:
MappingException

getCacheConcurrencyStrategy

public String getCacheConcurrencyStrategy()
Specified by:
getCacheConcurrencyStrategy in class PersistentClass

setCacheConcurrencyStrategy

public void setCacheConcurrencyStrategy(String cacheConcurrencyStrategy)

getCacheRegionName

public String getCacheRegionName()

setCacheRegionName

public void setCacheRegionName(String cacheRegionName)

isLazyPropertiesCacheable

public boolean isLazyPropertiesCacheable()
Specified by:
isLazyPropertiesCacheable in class PersistentClass

setLazyPropertiesCacheable

public void setLazyPropertiesCacheable(boolean lazyPropertiesCacheable)

isJoinedSubclass

public boolean isJoinedSubclass()
Specified by:
isJoinedSubclass in class PersistentClass

getSynchronizedTables

public Set getSynchronizedTables()
Specified by:
getSynchronizedTables in class PersistentClass

getIdentityTables

public Set getIdentityTables()

accept

public Object accept(PersistentClassVisitor mv)
Specified by:
accept in class PersistentClass

getOptimisticLockMode

public int getOptimisticLockMode()
Specified by:
getOptimisticLockMode in class PersistentClass
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Set (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Set

java.lang.Object
    extended by org.hibernate.mapping.Collection
        extended by org.hibernate.mapping.Set
All Implemented Interfaces:
Fetchable, Filterable, Serializable, Value
public class Set
extends Collection

A set with no nullable element columns. It will have a primary key consisting of all table columns (ie. key columns + element columns).

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.Collection
DEFAULT_ELEMENT_COLUMN_NAME, DEFAULT_KEY_COLUMN_NAME
Constructor Summary
Set(PersistentClass owner)
Constructor for Set.
Method Summary
Object | accept(ValueVisitor visitor)
CollectionType | getDefaultCollectionType()
boolean | isSet()
void | validate(Mapping mapping)
Methods inherited from class org.hibernate.mapping.Collection
addFilter, addManyToManyFilter, createAllKeys, createForeignKey, getBatchSize, getCacheConcurrencyStrategy, getCacheRegionName, getCollectionPersisterClass, getCollectionTable, getCollectionType, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getComparator, getComparatorClassName, getCustomSQLDelete, getCustomSQLDeleteAll, getCustomSQLDeleteAllCheckStyle, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getElement, getElementNodeName, getFetchMode, getFilterMap, getKey, getLoaderName, getManyToManyFilterMap, getManyToManyOrdering, getManyToManyWhere, getNodeName, getOrderBy, getOwner, getOwnerEntityName, getReferencedPropertyName, getRole, getSynchronizedTables, getTable, getType, getTypeName, getWhere, hasFormula, hasOrder, hasOrphanDelete, isAlternateUniqueKey, isArray, isCustomDeleteAllCallable, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isEmbedded, isExtraLazy, isIdentified, isIndexed, isInverse, isLazy, isMap, isMutable, isNullable, isOneToMany, isOptimisticLocked, isPrimitiveArray, isSimpleValue, isSorted, isSubselectLoadable, isValid, setBatchSize, setCacheConcurrencyStrategy, setCacheRegionName, setCollectionPersisterClass, setCollectionTable, setComparator, setComparatorClassName, setCustomSQLDelete, setCustomSQLDeleteAll, setCustomSQLInsert, setCustomSQLUpdate, setElement, setElementNodeName, setEmbedded, setExtraLazy, setFetchMode, setInverse, setKey, setLazy, setLoaderName, setManyToManyOrdering, setManyToManyWhere, setMutable, setNodeName, setOptimisticLocked, setOrderBy, setOrphanDelete, setOwner, setReferencedPropertyName, setRole, setSorted, setSubselectLoadable, setTypeName, setTypeUsingReflection, setWhere, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Set

public Set(PersistentClass owner)
Constructor for Set.

Parameters:
owner -
Method Detail

validate

public void validate(Mapping mapping)
              throws MappingException
Overrides:
validate in class Collection
Throws:
MappingException

isSet

public boolean isSet()
Overrides:
isSet in class Collection

getDefaultCollectionType

public CollectionType getDefaultCollectionType()
Specified by:
getDefaultCollectionType in class Collection

accept

public Object accept(ValueVisitor visitor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleAuxiliaryDatabaseObject (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class SimpleAuxiliaryDatabaseObject

java.lang.Object
    extended by org.hibernate.mapping.AbstractAuxiliaryDatabaseObject
        extended by org.hibernate.mapping.SimpleAuxiliaryDatabaseObject
All Implemented Interfaces:
AuxiliaryDatabaseObject, RelationalModel, Serializable
public class SimpleAuxiliaryDatabaseObject
extends AbstractAuxiliaryDatabaseObject

A simple implementation of AbstractAuxiliaryDatabaseObject in which the CREATE and DROP strings are provided up front. Contains simple facilities for templating the catalog and schema names into the provided strings.

This is the form created when the mapping documents use <create/> and <drop/>.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
SimpleAuxiliaryDatabaseObject(String sqlCreateString, String sqlDropString)
SimpleAuxiliaryDatabaseObject(String sqlCreateString, String sqlDropString, HashSet dialectScopes)
Method Summary
String | sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
String | sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
Methods inherited from class org.hibernate.mapping.AbstractAuxiliaryDatabaseObject
addDialectScope, appliesToDialect, getDialectScopes
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SimpleAuxiliaryDatabaseObject

public SimpleAuxiliaryDatabaseObject(String sqlCreateString,
                                     String sqlDropString)

SimpleAuxiliaryDatabaseObject

public SimpleAuxiliaryDatabaseObject(String sqlCreateString,
                                     String sqlDropString,
                                     HashSet dialectScopes)
Method Detail

sqlCreateString

public String sqlCreateString(Dialect dialect,
                              Mapping p,
                              String defaultCatalog,
                              String defaultSchema)
                       throws HibernateException
Throws:
HibernateException

sqlDropString

public String sqlDropString(Dialect dialect,
                            String defaultCatalog,
                            String defaultSchema)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleValue (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class SimpleValue

java.lang.Object
    extended by org.hibernate.mapping.SimpleValue
All Implemented Interfaces:
KeyValue, Serializable, Value
Direct Known Subclasses:
Any, Component, DependantValue, ToOne
public class SimpleValue
extends Object
implements KeyValue

Any value that maps to columns.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
SimpleValue()
SimpleValue(Table table)
Method Summary
Object | accept(ValueVisitor visitor)
void | addColumn(Column column)
void | addFormula(Formula formula)
void | createForeignKey()
void | createForeignKeyOfEntity(String entityName)
IdentifierGenerator | createIdentifierGenerator(Dialect dialect, String defaultCatalog, String defaultSchema, RootClass rootClass)
boolean[] | getColumnInsertability()
Iterator | getColumnIterator()
int | getColumnSpan()
boolean[] | getColumnUpdateability()
List | getConstraintColumns()
FetchMode | getFetchMode()
String | getForeignKeyName()
Properties | getIdentifierGeneratorProperties()
String | getIdentifierGeneratorStrategy() Returns the identifierGeneratorStrategy.
String | getNullValue()
Table | getTable()
Type | getType()
String | getTypeName()
Properties | getTypeParameters()
boolean | hasFormula()
boolean | isAlternateUniqueKey()
boolean | isCascadeDeleteEnabled()
boolean | isIdentityColumn(Dialect dialect)
boolean | isNullable()
boolean | isSimpleValue()
boolean | isTypeSpecified()
boolean | isUpdateable()
boolean | isValid(Mapping mapping)
void | setAlternateUniqueKey(boolean unique)
void | setCascadeDeleteEnabled(boolean cascadeDeleteEnabled)
void | setForeignKeyName(String foreignKeyName)
void | setIdentifierGeneratorProperties(Properties identifierGeneratorProperties) Sets the identifierGeneratorProperties.
void | setIdentifierGeneratorStrategy(String identifierGeneratorStrategy) Sets the identifierGeneratorStrategy.
void | setNullValue(String nullValue) Sets the nullValue.
void | setTable(Table table)
void | setTypeName(String type)
void | setTypeParameters(Properties parameterMap)
void | setTypeUsingReflection(String className, String propertyName)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SimpleValue

public SimpleValue(Table table)

SimpleValue

public SimpleValue()
Method Detail

isCascadeDeleteEnabled

public boolean isCascadeDeleteEnabled()
Specified by:
isCascadeDeleteEnabled in interface KeyValue

setCascadeDeleteEnabled

public void setCascadeDeleteEnabled(boolean cascadeDeleteEnabled)

addColumn

public void addColumn(Column column)

addFormula

public void addFormula(Formula formula)

hasFormula

public boolean hasFormula()
Specified by:
hasFormula in interface Value

getColumnSpan

public int getColumnSpan()
Specified by:
getColumnSpan in interface Value

getColumnIterator

public Iterator getColumnIterator()
Specified by:
getColumnIterator in interface Value

getConstraintColumns

public List getConstraintColumns()

getTypeName

public String getTypeName()

setTypeName

public void setTypeName(String type)

setTable

public void setTable(Table table)

createForeignKey

public void createForeignKey()
                      throws MappingException
Specified by:
createForeignKey in interface Value
Throws:
MappingException

createForeignKeyOfEntity

public void createForeignKeyOfEntity(String entityName)
Specified by:
createForeignKeyOfEntity in interface KeyValue

createIdentifierGenerator

public IdentifierGenerator createIdentifierGenerator(Dialect dialect,
                                                     String defaultCatalog,
                                                     String defaultSchema,
                                                     RootClass rootClass)
                                              throws MappingException
Specified by:
createIdentifierGenerator in interface KeyValue
Throws:
MappingException

isUpdateable

public boolean isUpdateable()
Specified by:
isUpdateable in interface KeyValue

getFetchMode

public FetchMode getFetchMode()
Specified by:
getFetchMode in interface Value

getIdentifierGeneratorProperties

public Properties getIdentifierGeneratorProperties()

getNullValue

public String getNullValue()
Specified by:
getNullValue in interface KeyValue

getTable

public Table getTable()
Specified by:
getTable in interface Value

getIdentifierGeneratorStrategy

public String getIdentifierGeneratorStrategy()
Returns the identifierGeneratorStrategy.

Returns:
String

isIdentityColumn

public boolean isIdentityColumn(Dialect dialect)
Specified by:
isIdentityColumn in interface KeyValue

setIdentifierGeneratorProperties

public void setIdentifierGeneratorProperties(Properties identifierGeneratorProperties)
Sets the identifierGeneratorProperties.

Parameters:
identifierGeneratorProperties - The identifierGeneratorProperties to set

setIdentifierGeneratorStrategy

public void setIdentifierGeneratorStrategy(String identifierGeneratorStrategy)
Sets the identifierGeneratorStrategy.

Parameters:
identifierGeneratorStrategy - The identifierGeneratorStrategy to set

setNullValue

public void setNullValue(String nullValue)
Sets the nullValue.

Parameters:
nullValue - The nullValue to set

getForeignKeyName

public String getForeignKeyName()

setForeignKeyName

public void setForeignKeyName(String foreignKeyName)

isAlternateUniqueKey

public boolean isAlternateUniqueKey()
Specified by:
isAlternateUniqueKey in interface Value

setAlternateUniqueKey

public void setAlternateUniqueKey(boolean unique)

isNullable

public boolean isNullable()
Specified by:
isNullable in interface Value

isSimpleValue

public boolean isSimpleValue()
Specified by:
isSimpleValue in interface Value

isValid

public boolean isValid(Mapping mapping)
                throws MappingException
Specified by:
isValid in interface Value
Throws:
MappingException

getType

public Type getType()
             throws MappingException
Specified by:
getType in interface Value
Throws:
MappingException

setTypeUsingReflection

public void setTypeUsingReflection(String className,
                                   String propertyName)
                            throws MappingException
Specified by:
setTypeUsingReflection in interface Value
Throws:
MappingException

isTypeSpecified

public boolean isTypeSpecified()

setTypeParameters

public void setTypeParameters(Properties parameterMap)

getTypeParameters

public Properties getTypeParameters()

toString

public String toString()

accept

public Object accept(ValueVisitor visitor)
Specified by:
accept in interface Value

getColumnInsertability

public boolean[] getColumnInsertability()
Specified by:
getColumnInsertability in interface Value

getColumnUpdateability

public boolean[] getColumnUpdateability()
Specified by:
getColumnUpdateability in interface Value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SingleTableSubclass (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class SingleTableSubclass

java.lang.Object
    extended by org.hibernate.mapping.PersistentClass
        extended by org.hibernate.mapping.Subclass
            extended by org.hibernate.mapping.SingleTableSubclass
All Implemented Interfaces:
Filterable, MetaAttributable, Serializable
public class SingleTableSubclass
extends Subclass

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.PersistentClass
NOT_NULL_DISCRIMINATOR_MAPPING, NULL_DISCRIMINATOR_MAPPING, optimisticLockMode, synchronizedTables
Constructor Summary
SingleTableSubclass(PersistentClass superclass)
Method Summary
Object | accept(PersistentClassVisitor mv)
protected Iterator | getDiscriminatorColumnIterator()
protected Iterator | getNonDuplicatedPropertyIterator()
void | validate(Mapping mapping)
Methods inherited from class org.hibernate.mapping.Subclass
addJoin, addProperty, addSubclassJoin, addSubclassProperty, addSubclassTable, createForeignKey, getCacheConcurrencyStrategy, getDiscriminator, getEntityPersisterClass, getFilterMap, getIdentifier, getIdentifierMapper, getIdentifierProperty, getJoinClosureIterator, getJoinClosureSpan, getKey, getKeyClosureIterator, getOptimisticLockMode, getPropertyClosureIterator, getPropertyClosureSpan, getRootClass, getRootTable, getSubclassId, getSuperclass, getSynchronizedTables, getTable, getTableClosureIterator, getTuplizerImplClassName, getTuplizerMap, getVersion, getWhere, hasEmbeddedIdentifier, hasIdentifierProperty, hasSubselectLoadableCollections, isClassOrSuperclassJoin, isClassOrSuperclassTable, isDiscriminatorInsertable, isExplicitPolymorphism, isForceDiscriminator, isInherited, isJoinedSubclass, isLazyPropertiesCacheable, isMutable, isPolymorphic, isVersioned, setEntityPersisterClass, setSuperclass
Methods inherited from class org.hibernate.mapping.PersistentClass
addFilter, addSubclass, addSynchronizedTable, addTuplizer, checkColumnDuplication, checkColumnDuplication, checkPropertyColumnDuplication, createPrimaryKey, getBatchSize, getClassName, getCustomSQLDelete, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getDirectSubclasses, getDiscriminatorValue, getEntityName, getIdentityTable, getJoinIterator, getJoinNumber, getLoaderName, getMappedClass, getMetaAttribute, getMetaAttributes, getNodeName, getProperty, getPropertyIterator, getProxyInterface, getProxyInterfaceName, getRecursiveProperty, getReferenceablePropertyIterator, getReferencedProperty, getSubclassClosureIterator, getSubclassIterator, getSubclassJoinClosureIterator, getSubclassPropertyClosureIterator, getSubclassSpan, getSubclassTableClosureIterator, getTemporaryIdTableDDL, getTemporaryIdTableName, getUnjoinedPropertyIterator, hasDom4jRepresentation, hasIdentifierMapper, hasNaturalId, hasPojoRepresentation, hasSelectBeforeUpdate, hasSubclasses, isAbstract, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isDiscriminatorValueNotNull, isDiscriminatorValueNull, isLazy, prepareTemporaryTables, setAbstract, setBatchSize, setClassName, setCustomSQLDelete, setCustomSQLInsert, setCustomSQLUpdate, setDiscriminatorValue, setDynamicInsert, setDynamicUpdate, setEntityName, setIdentifierMapper, setLazy, setLoaderName, setMetaAttributes, setNodeName, setOptimisticLockMode, setProxyInterfaceName, setSelectBeforeUpdate, setSubselectLoadableCollections, toString, useDynamicInsert, useDynamicUpdate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SingleTableSubclass

public SingleTableSubclass(PersistentClass superclass)
Method Detail

getNonDuplicatedPropertyIterator

protected Iterator getNonDuplicatedPropertyIterator()
Overrides:
getNonDuplicatedPropertyIterator in class PersistentClass

getDiscriminatorColumnIterator

protected Iterator getDiscriminatorColumnIterator()
Overrides:
getDiscriminatorColumnIterator in class PersistentClass

accept

public Object accept(PersistentClassVisitor mv)
Overrides:
accept in class Subclass

validate

public void validate(Mapping mapping)
              throws MappingException
Overrides:
validate in class PersistentClass
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Subclass (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Subclass

java.lang.Object
    extended by org.hibernate.mapping.PersistentClass
        extended by org.hibernate.mapping.Subclass
All Implemented Interfaces:
Filterable, MetaAttributable, Serializable
Direct Known Subclasses:
JoinedSubclass, SingleTableSubclass, UnionSubclass
public class Subclass
extends PersistentClass

A sublass in a table-per-class-hierarchy mapping

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.PersistentClass
NOT_NULL_DISCRIMINATOR_MAPPING, NULL_DISCRIMINATOR_MAPPING, optimisticLockMode, synchronizedTables
Constructor Summary
Subclass(PersistentClass superclass)
Method Summary
Object | accept(PersistentClassVisitor mv)
void | addJoin(Join j)
void | addProperty(Property p)
protected void | addSubclassJoin(Join j)
protected void | addSubclassProperty(Property p)
protected void | addSubclassTable(Table table)
void | createForeignKey()
String | getCacheConcurrencyStrategy()
Value | getDiscriminator()
Class | getEntityPersisterClass()
Map | getFilterMap()
KeyValue | getIdentifier()
Component | getIdentifierMapper()
Property | getIdentifierProperty()
Iterator | getJoinClosureIterator()
int | getJoinClosureSpan()
KeyValue | getKey()
Iterator | getKeyClosureIterator()
int | getOptimisticLockMode()
Iterator | getPropertyClosureIterator()
int | getPropertyClosureSpan()
RootClass | getRootClass()
Table | getRootTable()
int | getSubclassId()
PersistentClass | getSuperclass()
Set | getSynchronizedTables()
Table | getTable()
Iterator | getTableClosureIterator()
String | getTuplizerImplClassName(EntityMode mode)
Map | getTuplizerMap()
Property | getVersion()
String | getWhere()
boolean | hasEmbeddedIdentifier()
boolean | hasIdentifierProperty()
boolean | hasSubselectLoadableCollections()
boolean | isClassOrSuperclassJoin(Join join)
boolean | isClassOrSuperclassTable(Table table)
boolean | isDiscriminatorInsertable()
boolean | isExplicitPolymorphism()
boolean | isForceDiscriminator()
boolean | isInherited()
boolean | isJoinedSubclass()
boolean | isLazyPropertiesCacheable()
boolean | isMutable()
boolean | isPolymorphic()
boolean | isVersioned()
void | setEntityPersisterClass(Class classPersisterClass)
void | setSuperclass(PersistentClass superclass)
Methods inherited from class org.hibernate.mapping.PersistentClass
addFilter, addSubclass, addSynchronizedTable, addTuplizer, checkColumnDuplication, checkColumnDuplication, checkPropertyColumnDuplication, createPrimaryKey, getBatchSize, getClassName, getCustomSQLDelete, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getDirectSubclasses, getDiscriminatorColumnIterator, getDiscriminatorValue, getEntityName, getIdentityTable, getJoinIterator, getJoinNumber, getLoaderName, getMappedClass, getMetaAttribute, getMetaAttributes, getNodeName, getNonDuplicatedPropertyIterator, getProperty, getPropertyIterator, getProxyInterface, getProxyInterfaceName, getRecursiveProperty, getReferenceablePropertyIterator, getReferencedProperty, getSubclassClosureIterator, getSubclassIterator, getSubclassJoinClosureIterator, getSubclassPropertyClosureIterator, getSubclassSpan, getSubclassTableClosureIterator, getTemporaryIdTableDDL, getTemporaryIdTableName, getUnjoinedPropertyIterator, hasDom4jRepresentation, hasIdentifierMapper, hasNaturalId, hasPojoRepresentation, hasSelectBeforeUpdate, hasSubclasses, isAbstract, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isDiscriminatorValueNotNull, isDiscriminatorValueNull, isLazy, prepareTemporaryTables, setAbstract, setBatchSize, setClassName, setCustomSQLDelete, setCustomSQLInsert, setCustomSQLUpdate, setDiscriminatorValue, setDynamicInsert, setDynamicUpdate, setEntityName, setIdentifierMapper, setLazy, setLoaderName, setMetaAttributes, setNodeName, setOptimisticLockMode, setProxyInterfaceName, setSelectBeforeUpdate, setSubselectLoadableCollections, toString, useDynamicInsert, useDynamicUpdate, validate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Subclass

public Subclass(PersistentClass superclass)
Method Detail

getSubclassId

public int getSubclassId()
Specified by:
getSubclassId in class PersistentClass

getCacheConcurrencyStrategy

public String getCacheConcurrencyStrategy()
Specified by:
getCacheConcurrencyStrategy in class PersistentClass

getRootClass

public RootClass getRootClass()
Specified by:
getRootClass in class PersistentClass

getSuperclass

public PersistentClass getSuperclass()
Specified by:
getSuperclass in class PersistentClass

getIdentifierProperty

public Property getIdentifierProperty()
Specified by:
getIdentifierProperty in class PersistentClass

getIdentifier

public KeyValue getIdentifier()
Specified by:
getIdentifier in class PersistentClass

hasIdentifierProperty

public boolean hasIdentifierProperty()
Specified by:
hasIdentifierProperty in class PersistentClass

getDiscriminator

public Value getDiscriminator()
Specified by:
getDiscriminator in class PersistentClass

isMutable

public boolean isMutable()
Specified by:
isMutable in class PersistentClass

isInherited

public boolean isInherited()
Specified by:
isInherited in class PersistentClass

isPolymorphic

public boolean isPolymorphic()
Specified by:
isPolymorphic in class PersistentClass

addProperty

public void addProperty(Property p)
Overrides:
addProperty in class PersistentClass

addJoin

public void addJoin(Join j)
Overrides:
addJoin in class PersistentClass

getPropertyClosureIterator

public Iterator getPropertyClosureIterator()
Specified by:
getPropertyClosureIterator in class PersistentClass

getTableClosureIterator

public Iterator getTableClosureIterator()
Specified by:
getTableClosureIterator in class PersistentClass

getKeyClosureIterator

public Iterator getKeyClosureIterator()
Specified by:
getKeyClosureIterator in class PersistentClass

addSubclassProperty

protected void addSubclassProperty(Property p)
Overrides:
addSubclassProperty in class PersistentClass

addSubclassJoin

protected void addSubclassJoin(Join j)
Overrides:
addSubclassJoin in class PersistentClass

addSubclassTable

protected void addSubclassTable(Table table)
Overrides:
addSubclassTable in class PersistentClass

isVersioned

public boolean isVersioned()
Specified by:
isVersioned in class PersistentClass

getVersion

public Property getVersion()
Specified by:
getVersion in class PersistentClass

hasEmbeddedIdentifier

public boolean hasEmbeddedIdentifier()
Specified by:
hasEmbeddedIdentifier in class PersistentClass

getEntityPersisterClass

public Class getEntityPersisterClass()
Specified by:
getEntityPersisterClass in class PersistentClass

getRootTable

public Table getRootTable()
Specified by:
getRootTable in class PersistentClass

getKey

public KeyValue getKey()
Specified by:
getKey in class PersistentClass

isExplicitPolymorphism

public boolean isExplicitPolymorphism()
Specified by:
isExplicitPolymorphism in class PersistentClass

setSuperclass

public void setSuperclass(PersistentClass superclass)

getWhere

public String getWhere()
Specified by:
getWhere in class PersistentClass

isJoinedSubclass

public boolean isJoinedSubclass()
Specified by:
isJoinedSubclass in class PersistentClass

createForeignKey

public void createForeignKey()

setEntityPersisterClass

public void setEntityPersisterClass(Class classPersisterClass)
Specified by:
setEntityPersisterClass in class PersistentClass

isLazyPropertiesCacheable

public boolean isLazyPropertiesCacheable()
Specified by:
isLazyPropertiesCacheable in class PersistentClass

getJoinClosureSpan

public int getJoinClosureSpan()
Overrides:
getJoinClosureSpan in class PersistentClass

getPropertyClosureSpan

public int getPropertyClosureSpan()
Overrides:
getPropertyClosureSpan in class PersistentClass

getJoinClosureIterator

public Iterator getJoinClosureIterator()
Overrides:
getJoinClosureIterator in class PersistentClass

isClassOrSuperclassJoin

public boolean isClassOrSuperclassJoin(Join join)
Overrides:
isClassOrSuperclassJoin in class PersistentClass

isClassOrSuperclassTable

public boolean isClassOrSuperclassTable(Table table)
Overrides:
isClassOrSuperclassTable in class PersistentClass

getTable

public Table getTable()
Specified by:
getTable in class PersistentClass

isForceDiscriminator

public boolean isForceDiscriminator()
Overrides:
isForceDiscriminator in class PersistentClass

isDiscriminatorInsertable

public boolean isDiscriminatorInsertable()
Specified by:
isDiscriminatorInsertable in class PersistentClass

getSynchronizedTables

public Set getSynchronizedTables()
Specified by:
getSynchronizedTables in class PersistentClass

accept

public Object accept(PersistentClassVisitor mv)
Specified by:
accept in class PersistentClass

getFilterMap

public Map getFilterMap()
Specified by:
getFilterMap in interface Filterable
Overrides:
getFilterMap in class PersistentClass

hasSubselectLoadableCollections

public boolean hasSubselectLoadableCollections()
Overrides:
hasSubselectLoadableCollections in class PersistentClass

getTuplizerImplClassName

public String getTuplizerImplClassName(EntityMode mode)
Overrides:
getTuplizerImplClassName in class PersistentClass

getTuplizerMap

public Map getTuplizerMap()
Overrides:
getTuplizerMap in class PersistentClass

getIdentifierMapper

public Component getIdentifierMapper()
Overrides:
getIdentifierMapper in class PersistentClass

getOptimisticLockMode

public int getOptimisticLockMode()
Specified by:
getOptimisticLockMode in class PersistentClass
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Table (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class Table

java.lang.Object
    extended by org.hibernate.mapping.Table
All Implemented Interfaces:
RelationalModel, Serializable
Direct Known Subclasses:
DenormalizedTable
public class Table
extends Object
implements RelationalModel, Serializable

A relational table

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
Table()
Table(String name)
Method Summary
void | addCheckConstraint(String constraint)
void | addColumn(Column column)
Index | addIndex(Index index)
UniqueKey | addUniqueKey(UniqueKey uniqueKey)
boolean | containsColumn(Column column)
ForeignKey | createForeignKey(String keyName, List keyColumns, String referencedEntityName)
ForeignKey | createForeignKey(String keyName, List keyColumns, String referencedEntityName, List referencedColumns)
void | createForeignKeys()
UniqueKey | createUniqueKey(List keyColumns)
String | getCatalog()
Iterator | getCheckConstraintsIterator()
Column | getColumn(Column column) Return the column which is identified by column provided as argument.
Column | getColumn(int n)
Iterator | getColumnIterator()
int | getColumnSpan()
String | getComment()
Iterator | getForeignKeyIterator()
KeyValue | getIdentifierValue()
Index | getIndex(String indexName)
Iterator | getIndexIterator()
String | getName()
Index | getOrCreateIndex(String indexName)
UniqueKey | getOrCreateUniqueKey(String keyName)
PrimaryKey | getPrimaryKey()
String | getQualifiedName(Dialect dialect, String defaultCatalog, String defaultSchema)
String | getQuotedName() returns quoted name as it would be in the mapping file.
String | getQuotedName(Dialect dialect)
String | getQuotedSchema() returns quoted name as it is in the mapping file.
String | getQuotedSchema(Dialect dialect)
String | getRowId()
String | getSchema()
String | getSubselect()
int | getUniqueInteger()
UniqueKey | getUniqueKey(String keyName)
Iterator | getUniqueKeyIterator()
boolean | hasDenormalizedTables()
boolean | hasPrimaryKey()
boolean | isAbstract()
boolean | isAbstractUnionTable()
boolean | isPhysicalTable()
boolean | isQuoted()
boolean | isSchemaQuoted()
boolean | isSubselect()
static String | qualify(String catalog, String schema, String table)
void | setAbstract(boolean isAbstract)
void | setCatalog(String catalog)
void | setComment(String comment)
void | setIdentifierValue(KeyValue idValue)
void | setName(String name)
void | setPrimaryKey(PrimaryKey primaryKey)
void | setQuoted(boolean quoted)
void | setRowId(String rowId)
void | setSchema(String schema)
void | setSubselect(String subselect)
Iterator | sqlAlterStrings(Dialect dialect, Mapping p, TableMetadata tableInfo, String defaultCatalog, String defaultSchema)
Iterator | sqlCommentStrings(Dialect dialect, String defaultCatalog, String defaultSchema)
String | sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
String | sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
String | sqlTemporaryTableCreateString(Dialect dialect, Mapping mapping)
String | toString()
String | uniqueColumnString(Iterator iterator)
String | uniqueColumnString(Iterator iterator, String referencedEntityName)
void | validateColumns(Dialect dialect, Mapping mapping, TableMetadata tableInfo)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Table

public Table()

Table

public Table(String name)
Method Detail

getQualifiedName

public String getQualifiedName(Dialect dialect,
                               String defaultCatalog,
                               String defaultSchema)

qualify

public static String qualify(String catalog,
                             String schema,
                             String table)

getName

public String getName()

getQuotedName

public String getQuotedName()
returns quoted name as it would be in the mapping file.

getQuotedName

public String getQuotedName(Dialect dialect)

getQuotedSchema

public String getQuotedSchema()
returns quoted name as it is in the mapping file.

getQuotedSchema

public String getQuotedSchema(Dialect dialect)

setName

public void setName(String name)

getColumn

public Column getColumn(Column column)
Return the column which is identified by column provided as argument.

Parameters:
column - column with atleast a name.
Returns:
the underlying column or null if not inside this table. Note: the instance *can* be different than the input parameter, but the name will be the same.

getColumn

public Column getColumn(int n)

addColumn

public void addColumn(Column column)

getColumnSpan

public int getColumnSpan()

getColumnIterator

public Iterator getColumnIterator()

getIndexIterator

public Iterator getIndexIterator()

getForeignKeyIterator

public Iterator getForeignKeyIterator()

getUniqueKeyIterator

public Iterator getUniqueKeyIterator()

validateColumns

public void validateColumns(Dialect dialect,
                            Mapping mapping,
                            TableMetadata tableInfo)

sqlAlterStrings

public Iterator sqlAlterStrings(Dialect dialect,
                                Mapping p,
                                TableMetadata tableInfo,
                                String defaultCatalog,
                                String defaultSchema)
                         throws HibernateException
Throws:
HibernateException

hasPrimaryKey

public boolean hasPrimaryKey()

sqlTemporaryTableCreateString

public String sqlTemporaryTableCreateString(Dialect dialect,
                                            Mapping mapping)
                                     throws HibernateException
Throws:
HibernateException

sqlCreateString

public String sqlCreateString(Dialect dialect,
                              Mapping p,
                              String defaultCatalog,
                              String defaultSchema)
                       throws HibernateException
Specified by:
sqlCreateString in interface RelationalModel
Throws:
HibernateException

sqlDropString

public String sqlDropString(Dialect dialect,
                            String defaultCatalog,
                            String defaultSchema)
Specified by:
sqlDropString in interface RelationalModel

getPrimaryKey

public PrimaryKey getPrimaryKey()

setPrimaryKey

public void setPrimaryKey(PrimaryKey primaryKey)

getOrCreateIndex

public Index getOrCreateIndex(String indexName)

getIndex

public Index getIndex(String indexName)

addIndex

public Index addIndex(Index index)

addUniqueKey

public UniqueKey addUniqueKey(UniqueKey uniqueKey)

createUniqueKey

public UniqueKey createUniqueKey(List keyColumns)

getUniqueKey

public UniqueKey getUniqueKey(String keyName)

getOrCreateUniqueKey

public UniqueKey getOrCreateUniqueKey(String keyName)

createForeignKeys

public void createForeignKeys()

createForeignKey

public ForeignKey createForeignKey(String keyName,
                                   List keyColumns,
                                   String referencedEntityName)

createForeignKey

public ForeignKey createForeignKey(String keyName,
                                   List keyColumns,
                                   String referencedEntityName,
                                   List referencedColumns)

uniqueColumnString

public String uniqueColumnString(Iterator iterator)

uniqueColumnString

public String uniqueColumnString(Iterator iterator,
                                 String referencedEntityName)

getSchema

public String getSchema()

setSchema

public void setSchema(String schema)

getCatalog

public String getCatalog()

setCatalog

public void setCatalog(String catalog)

getUniqueInteger

public int getUniqueInteger()

setIdentifierValue

public void setIdentifierValue(KeyValue idValue)

getIdentifierValue

public KeyValue getIdentifierValue()

isSchemaQuoted

public boolean isSchemaQuoted()

isQuoted

public boolean isQuoted()

setQuoted

public void setQuoted(boolean quoted)

addCheckConstraint

public void addCheckConstraint(String constraint)

containsColumn

public boolean containsColumn(Column column)

getRowId

public String getRowId()

setRowId

public void setRowId(String rowId)

toString

public String toString()

getSubselect

public String getSubselect()

setSubselect

public void setSubselect(String subselect)

isSubselect

public boolean isSubselect()

isAbstractUnionTable

public boolean isAbstractUnionTable()

hasDenormalizedTables

public boolean hasDenormalizedTables()

setAbstract

public void setAbstract(boolean isAbstract)

isAbstract

public boolean isAbstract()

isPhysicalTable

public boolean isPhysicalTable()

getComment

public String getComment()

setComment

public void setComment(String comment)

getCheckConstraintsIterator

public Iterator getCheckConstraintsIterator()

sqlCommentStrings

public Iterator sqlCommentStrings(Dialect dialect,
                                  String defaultCatalog,
                                  String defaultSchema)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToOne (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class ToOne

java.lang.Object
    extended by org.hibernate.mapping.SimpleValue
        extended by org.hibernate.mapping.ToOne
All Implemented Interfaces:
Fetchable, KeyValue, Serializable, Value
Direct Known Subclasses:
ManyToOne, OneToOne
public abstract class ToOne
extends SimpleValue
implements Fetchable

A simple-point association (ie. a reference to another entity).

Author:
Gavin King
See Also:
Serialized Form

Field Summary
protected String | referencedPropertyName
protected boolean | unwrapProxy
Constructor Summary
protected ToOne(Table table)
Method Summary
Object | accept(ValueVisitor visitor)
abstract void | createForeignKey()
FetchMode | getFetchMode()
String | getReferencedEntityName()
String | getReferencedPropertyName()
abstract Type | getType()
boolean | isEmbedded()
boolean | isLazy()
boolean | isTypeSpecified()
boolean | isUnwrapProxy()
boolean | isValid(Mapping mapping)
void | setEmbedded(boolean embedded)
void | setFetchMode(FetchMode fetchMode)
void | setLazy(boolean lazy)
void | setReferencedEntityName(String referencedEntityName)
void | setReferencedPropertyName(String name)
void | setTypeUsingReflection(String className, String propertyName)
void | setUnwrapProxy(boolean unwrapProxy)
Methods inherited from class org.hibernate.mapping.SimpleValue
addColumn, addFormula, createForeignKeyOfEntity, createIdentifierGenerator, getColumnInsertability, getColumnIterator, getColumnSpan, getColumnUpdateability, getConstraintColumns, getForeignKeyName, getIdentifierGeneratorProperties, getIdentifierGeneratorStrategy, getNullValue, getTable, getTypeName, getTypeParameters, hasFormula, isAlternateUniqueKey, isCascadeDeleteEnabled, isIdentityColumn, isNullable, isSimpleValue, isUpdateable, setAlternateUniqueKey, setCascadeDeleteEnabled, setForeignKeyName, setIdentifierGeneratorProperties, setIdentifierGeneratorStrategy, setNullValue, setTable, setTypeName, setTypeParameters, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

referencedPropertyName

protected String referencedPropertyName

unwrapProxy

protected boolean unwrapProxy
Constructor Detail

ToOne

protected ToOne(Table table)
Method Detail

getFetchMode

public FetchMode getFetchMode()
Specified by:
getFetchMode in interface Fetchable
Overrides:
getFetchMode in class SimpleValue

setFetchMode

public void setFetchMode(FetchMode fetchMode)
Specified by:
setFetchMode in interface Fetchable

createForeignKey

public abstract void createForeignKey()
                               throws MappingException
Specified by:
createForeignKey in interface Value
Overrides:
createForeignKey in class SimpleValue
Throws:
MappingException

getType

public abstract Type getType()
                      throws MappingException
Specified by:
getType in interface Value
Overrides:
getType in class SimpleValue
Throws:
MappingException

getReferencedPropertyName

public String getReferencedPropertyName()

setReferencedPropertyName

public void setReferencedPropertyName(String name)

getReferencedEntityName

public String getReferencedEntityName()

setReferencedEntityName

public void setReferencedEntityName(String referencedEntityName)

setTypeUsingReflection

public void setTypeUsingReflection(String className,
                                   String propertyName)
                            throws MappingException
Specified by:
setTypeUsingReflection in interface Value
Overrides:
setTypeUsingReflection in class SimpleValue
Throws:
MappingException

isTypeSpecified

public boolean isTypeSpecified()
Overrides:
isTypeSpecified in class SimpleValue

accept

public Object accept(ValueVisitor visitor)
Specified by:
accept in interface Value
Overrides:
accept in class SimpleValue

isEmbedded

public boolean isEmbedded()

setEmbedded

public void setEmbedded(boolean embedded)

isValid

public boolean isValid(Mapping mapping)
                throws MappingException
Specified by:
isValid in interface Value
Overrides:
isValid in class SimpleValue
Throws:
MappingException

isLazy

public boolean isLazy()
Specified by:
isLazy in interface Fetchable

setLazy

public void setLazy(boolean lazy)
Specified by:
setLazy in interface Fetchable

isUnwrapProxy

public boolean isUnwrapProxy()

setUnwrapProxy

public void setUnwrapProxy(boolean unwrapProxy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TypeDef (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class TypeDef

java.lang.Object
    extended by org.hibernate.mapping.TypeDef
All Implemented Interfaces:
Serializable
public class TypeDef
extends Object
implements Serializable

Placeholder for typedef information

See Also:
Serialized Form

Constructor Summary
TypeDef(String typeClass, Properties parameters)
Method Summary
Properties | getParameters()
String | getTypeClass()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TypeDef

public TypeDef(String typeClass,
               Properties parameters)
Method Detail

getParameters

public Properties getParameters()

getTypeClass

public String getTypeClass()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnionSubclass (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class UnionSubclass

java.lang.Object
    extended by org.hibernate.mapping.PersistentClass
        extended by org.hibernate.mapping.Subclass
            extended by org.hibernate.mapping.UnionSubclass
All Implemented Interfaces:
Filterable, MetaAttributable, Serializable, TableOwner
public class UnionSubclass
extends Subclass
implements TableOwner

A subclass in a table-per-concrete-class mapping

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.mapping.PersistentClass
NOT_NULL_DISCRIMINATOR_MAPPING, NULL_DISCRIMINATOR_MAPPING, optimisticLockMode, synchronizedTables
Constructor Summary
UnionSubclass(PersistentClass superclass)
Method Summary
Object | accept(PersistentClassVisitor mv)
Table | getIdentityTable()
protected Iterator | getNonDuplicatedPropertyIterator()
Set | getSynchronizedTables()
Table | getTable()
void | setTable(Table table)
void | validate(Mapping mapping)
Methods inherited from class org.hibernate.mapping.Subclass
addJoin, addProperty, addSubclassJoin, addSubclassProperty, addSubclassTable, createForeignKey, getCacheConcurrencyStrategy, getDiscriminator, getEntityPersisterClass, getFilterMap, getIdentifier, getIdentifierMapper, getIdentifierProperty, getJoinClosureIterator, getJoinClosureSpan, getKey, getKeyClosureIterator, getOptimisticLockMode, getPropertyClosureIterator, getPropertyClosureSpan, getRootClass, getRootTable, getSubclassId, getSuperclass, getTableClosureIterator, getTuplizerImplClassName, getTuplizerMap, getVersion, getWhere, hasEmbeddedIdentifier, hasIdentifierProperty, hasSubselectLoadableCollections, isClassOrSuperclassJoin, isClassOrSuperclassTable, isDiscriminatorInsertable, isExplicitPolymorphism, isForceDiscriminator, isInherited, isJoinedSubclass, isLazyPropertiesCacheable, isMutable, isPolymorphic, isVersioned, setEntityPersisterClass, setSuperclass
Methods inherited from class org.hibernate.mapping.PersistentClass
addFilter, addSubclass, addSynchronizedTable, addTuplizer, checkColumnDuplication, checkColumnDuplication, checkPropertyColumnDuplication, createPrimaryKey, getBatchSize, getClassName, getCustomSQLDelete, getCustomSQLDeleteCheckStyle, getCustomSQLInsert, getCustomSQLInsertCheckStyle, getCustomSQLUpdate, getCustomSQLUpdateCheckStyle, getDirectSubclasses, getDiscriminatorColumnIterator, getDiscriminatorValue, getEntityName, getJoinIterator, getJoinNumber, getLoaderName, getMappedClass, getMetaAttribute, getMetaAttributes, getNodeName, getProperty, getPropertyIterator, getProxyInterface, getProxyInterfaceName, getRecursiveProperty, getReferenceablePropertyIterator, getReferencedProperty, getSubclassClosureIterator, getSubclassIterator, getSubclassJoinClosureIterator, getSubclassPropertyClosureIterator, getSubclassSpan, getSubclassTableClosureIterator, getTemporaryIdTableDDL, getTemporaryIdTableName, getUnjoinedPropertyIterator, hasDom4jRepresentation, hasIdentifierMapper, hasNaturalId, hasPojoRepresentation, hasSelectBeforeUpdate, hasSubclasses, isAbstract, isCustomDeleteCallable, isCustomInsertCallable, isCustomUpdateCallable, isDiscriminatorValueNotNull, isDiscriminatorValueNull, isLazy, prepareTemporaryTables, setAbstract, setBatchSize, setClassName, setCustomSQLDelete, setCustomSQLInsert, setCustomSQLUpdate, setDiscriminatorValue, setDynamicInsert, setDynamicUpdate, setEntityName, setIdentifierMapper, setLazy, setLoaderName, setMetaAttributes, setNodeName, setOptimisticLockMode, setProxyInterfaceName, setSelectBeforeUpdate, setSubselectLoadableCollections, toString, useDynamicInsert, useDynamicUpdate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnionSubclass

public UnionSubclass(PersistentClass superclass)
Method Detail

getTable

public Table getTable()
Overrides:
getTable in class Subclass

setTable

public void setTable(Table table)
Specified by:
setTable in interface TableOwner

getSynchronizedTables

public Set getSynchronizedTables()
Overrides:
getSynchronizedTables in class Subclass

getNonDuplicatedPropertyIterator

protected Iterator getNonDuplicatedPropertyIterator()
Overrides:
getNonDuplicatedPropertyIterator in class PersistentClass

validate

public void validate(Mapping mapping)
              throws MappingException
Overrides:
validate in class PersistentClass
Throws:
MappingException

getIdentityTable

public Table getIdentityTable()
Overrides:
getIdentityTable in class PersistentClass

accept

public Object accept(PersistentClassVisitor mv)
Overrides:
accept in class Subclass
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UniqueKey (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.mapping
Class UniqueKey

java.lang.Object
    extended by org.hibernate.mapping.Constraint
        extended by org.hibernate.mapping.UniqueKey
All Implemented Interfaces:
RelationalModel, Serializable
public class UniqueKey
extends Constraint

A relational unique key constraint

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
UniqueKey()
Method Summary
String | sqlConstraintString(Dialect dialect)
String | sqlConstraintString(Dialect dialect, String constraintName, String defaultCatalog, String defaultSchema)
String | sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
String | sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
Methods inherited from class org.hibernate.mapping.Constraint
addColumn, addColumns, columnIterator, containsColumn, getColumn, getColumnIterator, getColumns, getColumnSpan, getName, getTable, setName, setTable, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UniqueKey

public UniqueKey()
Method Detail

sqlConstraintString

public String sqlConstraintString(Dialect dialect)

sqlConstraintString

public String sqlConstraintString(Dialect dialect,
                                  String constraintName,
                                  String defaultCatalog,
                                  String defaultSchema)
Specified by:
sqlConstraintString in class Constraint

sqlCreateString

public String sqlCreateString(Dialect dialect,
                              Mapping p,
                              String defaultCatalog,
                              String defaultSchema)
Specified by:
sqlCreateString in interface RelationalModel
Overrides:
sqlCreateString in class Constraint

sqlDropString

public String sqlDropString(Dialect dialect,
                            String defaultCatalog,
                            String defaultSchema)
Specified by:
sqlDropString in interface RelationalModel
Overrides:
sqlDropString in class Constraint
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.metadata (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.metadata

This package defines an API for accessing the Hibernate runtime metamodel.

See:
Description

Interface Summary
ClassMetadata | Exposes entity class metadata to the application
CollectionMetadata | Exposes collection metadata to the application

Package org.hibernate.metadata Description

This package defines an API for accessing the Hibernate runtime metamodel.


org.hibernate.metadata Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.metadata

Package Hierarchies:
All Packages

Interface Hierarchy

  • interface org.hibernate.metadata.ClassMetadata
  • interface org.hibernate.metadata.CollectionMetadata


Uses of Package org.hibernate.metadata (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.metadata

Packages that use org.hibernate.metadata
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Classes in org.hibernate.metadata used by org.hibernate
ClassMetadata
Exposes entity class metadata to the application
CollectionMetadata
Exposes collection metadata to the application

Classes in org.hibernate.metadata used by org.hibernate.impl
ClassMetadata
Exposes entity class metadata to the application
CollectionMetadata
Exposes collection metadata to the application

Classes in org.hibernate.metadata used by org.hibernate.jmx
ClassMetadata
Exposes entity class metadata to the application
CollectionMetadata
Exposes collection metadata to the application

Classes in org.hibernate.metadata used by org.hibernate.persister.collection
CollectionMetadata
Exposes collection metadata to the application

Classes in org.hibernate.metadata used by org.hibernate.persister.entity
ClassMetadata
Exposes entity class metadata to the application

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ClassMetadata (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.metadata
Interface ClassMetadata

All Known Implementing Classes:
AbstractEntityPersister
public interface ClassMetadata

Exposes entity class metadata to the application

Author:
Gavin King
See Also:
SessionFactory.getClassMetadata(Class)

Method Summary
String | getEntityName() The name of the entity
Serializable | getIdentifier(Object entity, EntityMode entityMode) Get the identifier of an instance (throw an exception if no identifier property)
String | getIdentifierPropertyName() Get the name of the identifier property (or return null)
Type | getIdentifierType() Get the identifier Hibernate type
Class | getMappedClass(EntityMode entityMode) The persistent class, or null
int[] | getNaturalIdentifierProperties() Which properties hold the natural id?
boolean[] | getPropertyLaziness() Get the "laziness" of the properties of this class
String[] | getPropertyNames() Get the names of the class' persistent properties
boolean[] | getPropertyNullability() Get the nullability of the class' persistent properties
Type | getPropertyType(String propertyName) Get the type of a particular (named) property
Type[] | getPropertyTypes() Get the Hibernate types of the class properties
Object | getPropertyValue(Object object, String propertyName, EntityMode entityMode) Get the value of a particular (named) property
Object[] | getPropertyValues(Object entity, EntityMode entityMode) Extract the property values from the given entity.
Object[] | getPropertyValuesToInsert(Object entity, Map mergeMap, SessionImplementor session) Return the values of the mapped properties of the object
Object | getVersion(Object object, EntityMode entityMode) Get the version number (or timestamp) from the object's version property (or return null if not versioned)
int | getVersionProperty() Get the index of the version property
boolean | hasIdentifierProperty() Does this class have an identifier property?
boolean | hasNaturalIdentifier() Does this entity declare a natural id?
boolean | hasProxy() Does this class support dynamic proxies?
boolean | hasSubclasses() Does this entity have mapped subclasses?
boolean | implementsLifecycle(EntityMode entityMode) Does the class implement the Lifecycle interface?
boolean | implementsValidatable(EntityMode entityMode) Does the class implement the Validatable interface?
Object | instantiate(Serializable id, EntityMode entityMode) Create a class instance initialized with the given identifier
boolean | isInherited() Does this entity extend a mapped superclass?
boolean | isMutable() Are instances of this class mutable?
boolean | isVersioned() Are instances of this class versioned by a timestamp or version number column?
void | setIdentifier(Object object, Serializable id, EntityMode entityMode) Set the identifier of an instance (or do nothing if no identifier property)
void | setPropertyValue(Object object, String propertyName, Object value, EntityMode entityMode) Set the value of a particular (named) property
void | setPropertyValues(Object object, Object[] values, EntityMode entityMode) Set the given values to the mapped properties of the given object

Method Detail

getEntityName

public String getEntityName()
The name of the entity

getIdentifierPropertyName

public String getIdentifierPropertyName()
Get the name of the identifier property (or return null)

getPropertyNames

public String[] getPropertyNames()
Get the names of the class' persistent properties

getIdentifierType

public Type getIdentifierType()
Get the identifier Hibernate type

getPropertyTypes

public Type[] getPropertyTypes()
Get the Hibernate types of the class properties

getPropertyType

public Type getPropertyType(String propertyName)
                     throws HibernateException
Get the type of a particular (named) property

Throws:
HibernateException

hasProxy

public boolean hasProxy()
Does this class support dynamic proxies?

isMutable

public boolean isMutable()
Are instances of this class mutable?

isVersioned

public boolean isVersioned()
Are instances of this class versioned by a timestamp or version number column?

getVersionProperty

public int getVersionProperty()
Get the index of the version property

getPropertyNullability

public boolean[] getPropertyNullability()
Get the nullability of the class' persistent properties

getPropertyLaziness

public boolean[] getPropertyLaziness()
Get the "laziness" of the properties of this class

hasIdentifierProperty

public boolean hasIdentifierProperty()
Does this class have an identifier property?

hasNaturalIdentifier

public boolean hasNaturalIdentifier()
Does this entity declare a natural id?

getNaturalIdentifierProperties

public int[] getNaturalIdentifierProperties()
Which properties hold the natural id?

hasSubclasses

public boolean hasSubclasses()
Does this entity have mapped subclasses?

isInherited

public boolean isInherited()
Does this entity extend a mapped superclass?

getPropertyValuesToInsert

public Object[] getPropertyValuesToInsert(Object entity,
                                          Map mergeMap,
                                          SessionImplementor session)
                                   throws HibernateException
Return the values of the mapped properties of the object

Throws:
HibernateException

getMappedClass

public Class getMappedClass(EntityMode entityMode)
The persistent class, or null

instantiate

public Object instantiate(Serializable id,
                          EntityMode entityMode)
                   throws HibernateException
Create a class instance initialized with the given identifier

Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object object,
                               String propertyName,
                               EntityMode entityMode)
                        throws HibernateException
Get the value of a particular (named) property

Throws:
HibernateException

getPropertyValues

public Object[] getPropertyValues(Object entity,
                                  EntityMode entityMode)
                           throws HibernateException
Extract the property values from the given entity.

Parameters:
entity - The entity from which to extract the property values.
entityMode - The entity-mode of the given entity
Returns:
The property values.
Throws:
HibernateException

setPropertyValue

public void setPropertyValue(Object object,
                             String propertyName,
                             Object value,
                             EntityMode entityMode)
                      throws HibernateException
Set the value of a particular (named) property

Throws:
HibernateException

setPropertyValues

public void setPropertyValues(Object object,
                              Object[] values,
                              EntityMode entityMode)
                       throws HibernateException
Set the given values to the mapped properties of the given object

Throws:
HibernateException

getIdentifier

public Serializable getIdentifier(Object entity,
                                  EntityMode entityMode)
                           throws HibernateException
Get the identifier of an instance (throw an exception if no identifier property)

Throws:
HibernateException

setIdentifier

public void setIdentifier(Object object,
                          Serializable id,
                          EntityMode entityMode)
                   throws HibernateException
Set the identifier of an instance (or do nothing if no identifier property)

Throws:
HibernateException

implementsLifecycle

public boolean implementsLifecycle(EntityMode entityMode)
Does the class implement the Lifecycle interface?

implementsValidatable

public boolean implementsValidatable(EntityMode entityMode)
Does the class implement the Validatable interface?

getVersion

public Object getVersion(Object object,
                         EntityMode entityMode)
                  throws HibernateException
Get the version number (or timestamp) from the object's version property (or return null if not versioned)

Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CollectionMetadata (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.metadata
Interface CollectionMetadata

All Known Implementing Classes:
AbstractCollectionPersister
public interface CollectionMetadata

Exposes collection metadata to the application

Author:
Gavin King

Method Summary
Type | getElementType() The collection element type
Type | getIndexType() The collection index type (or null if the collection has no index)
Type | getKeyType() The collection key type
String | getRole() The name of this collection role
boolean | hasIndex() Is this collection indexed?
boolean | isArray() Is the collection an array?
boolean | isLazy() Is the collection lazily initialized?
boolean | isPrimitiveArray() Is the collection a primitive array?

Method Detail

getKeyType

public Type getKeyType()
The collection key type

getElementType

public Type getElementType()
The collection element type

getIndexType

public Type getIndexType()
The collection index type (or null if the collection has no index)

hasIndex

public boolean hasIndex()
Is this collection indexed?

getRole

public String getRole()
The name of this collection role

isArray

public boolean isArray()
Is the collection an array?

isPrimitiveArray

public boolean isPrimitiveArray()
Is the collection a primitive array?

isLazy

public boolean isLazy()
Is the collection lazily initialized?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.param (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.param

Interface Summary
ExplicitParameterSpecification | An additional contract for parameters which originate from parameters explicitly encountered in the source statement (HQL or native-SQL).
ParameterSpecification | Maintains information relating to parameters which need to get bound into a JDBC PreparedStatement.

Class Summary
AbstractExplicitParameterSpecification | Convenience base class for explicitly defined query parameters.
NamedParameterSpecification | Relates to an explicit query named-parameter.
PositionalParameterSpecification | Relates to an explicit query positional (or ordinal) parameter.
VersionTypeSeedParameterSpecification | Implementation of VersionTypeSeedParameterSpecification.


org.hibernate.param Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.param

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.param.AbstractExplicitParameterSpecification (implements org.hibernate.param.ExplicitParameterSpecification)
      • class org.hibernate.param.NamedParameterSpecification (implements org.hibernate.param.ParameterSpecification)
      • class org.hibernate.param.PositionalParameterSpecification (implements org.hibernate.param.ParameterSpecification)
    • class org.hibernate.param.VersionTypeSeedParameterSpecification (implements org.hibernate.param.ParameterSpecification)

Interface Hierarchy

  • interface org.hibernate.param.ParameterSpecification
    • interface org.hibernate.param.ExplicitParameterSpecification


Uses of Package org.hibernate.param (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.param

Packages that use org.hibernate.param
org.hibernate.hql.ast.tree
org.hibernate.param

Classes in org.hibernate.param used by org.hibernate.hql.ast.tree
ParameterSpecification
Maintains information relating to parameters which need to get bound into a JDBC PreparedStatement.

Classes in org.hibernate.param used by org.hibernate.param
AbstractExplicitParameterSpecification
Convenience base class for explicitly defined query parameters.
ExplicitParameterSpecification
An additional contract for parameters which originate from parameters explicitly encountered in the source statement (HQL or native-SQL).
ParameterSpecification
Maintains information relating to parameters which need to get bound into a JDBC PreparedStatement.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ExplicitParameterSpecification (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.param
Interface ExplicitParameterSpecification

All Superinterfaces:
ParameterSpecification
All Known Implementing Classes:
AbstractExplicitParameterSpecification
public interface ExplicitParameterSpecification
extends ParameterSpecification

An additional contract for parameters which originate from parameters explicitly encountered in the source statement (HQL or native-SQL).

Author:
Steve Ebersole

Method Summary
int | getSourceColumn()
int | getSourceLine()
Methods inherited from interface org.hibernate.param.ParameterSpecification
bind, getExpectedType, renderDisplayInfo, setExpectedType

Method Detail

getSourceLine

public int getSourceLine()

getSourceColumn

public int getSourceColumn()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ParameterSpecification (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.param
Interface ParameterSpecification

All Known Subinterfaces:
ExplicitParameterSpecification
All Known Implementing Classes:
AbstractExplicitParameterSpecification, NamedParameterSpecification, PositionalParameterSpecification, VersionTypeSeedParameterSpecification
public interface ParameterSpecification

Maintains information relating to parameters which need to get bound into a JDBC PreparedStatement.

Author:
Steve Ebersole

Method Summary
int | bind(PreparedStatement statement, QueryParameters qp, SessionImplementor session, int position) Bind the appropriate value into the given statement at the specified position.
Type | getExpectedType()
String | renderDisplayInfo()
void | setExpectedType(Type expectedType)

Method Detail

bind

public int bind(PreparedStatement statement,
                QueryParameters qp,
                SessionImplementor session,
                int position)
         throws SQLException
Bind the appropriate value into the given statement at the specified position.

Parameters:
statement - The statement into which the value should be bound.
qp - The defined values for the current query execution.
session - The session against which the current execution is occuring.
position - The position from which to start binding value(s).
Returns:
The number of sql bind positions "eaten" by this bind operation.
Throws:
SQLException

getExpectedType

public Type getExpectedType()

setExpectedType

public void setExpectedType(Type expectedType)

renderDisplayInfo

public String renderDisplayInfo()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractExplicitParameterSpecification (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.param
Class AbstractExplicitParameterSpecification

java.lang.Object
    extended by org.hibernate.param.AbstractExplicitParameterSpecification
All Implemented Interfaces:
ExplicitParameterSpecification, ParameterSpecification
Direct Known Subclasses:
NamedParameterSpecification, PositionalParameterSpecification
public abstract class AbstractExplicitParameterSpecification
extends Object
implements ExplicitParameterSpecification

Convenience base class for explicitly defined query parameters.

Author:
Steve Ebersole

Constructor Summary
protected AbstractExplicitParameterSpecification(int sourceLine, int sourceColumn)
Method Summary
Type | getExpectedType()
int | getSourceColumn()
int | getSourceLine()
void | setExpectedType(Type expectedType)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.param.ParameterSpecification
bind, renderDisplayInfo

Constructor Detail

AbstractExplicitParameterSpecification

protected AbstractExplicitParameterSpecification(int sourceLine,
                                                 int sourceColumn)
Method Detail

getSourceLine

public int getSourceLine()
Specified by:
getSourceLine in interface ExplicitParameterSpecification

getSourceColumn

public int getSourceColumn()
Specified by:
getSourceColumn in interface ExplicitParameterSpecification

getExpectedType

public Type getExpectedType()
Specified by:
getExpectedType in interface ParameterSpecification

setExpectedType

public void setExpectedType(Type expectedType)
Specified by:
setExpectedType in interface ParameterSpecification
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


NamedParameterSpecification (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.param
Class NamedParameterSpecification

java.lang.Object
    extended by org.hibernate.param.AbstractExplicitParameterSpecification
        extended by org.hibernate.param.NamedParameterSpecification
All Implemented Interfaces:
ExplicitParameterSpecification, ParameterSpecification
public class NamedParameterSpecification
extends AbstractExplicitParameterSpecification
implements ParameterSpecification

Relates to an explicit query named-parameter.

Author:
Steve Ebersole

Constructor Summary
NamedParameterSpecification(int sourceLine, int sourceColumn, String name)
Method Summary
int | bind(PreparedStatement statement, QueryParameters qp, SessionImplementor session, int position) Bind the appropriate value into the given statement at the specified position.
String | getName()
String | renderDisplayInfo()
Methods inherited from class org.hibernate.param.AbstractExplicitParameterSpecification
getExpectedType, getSourceColumn, getSourceLine, setExpectedType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.param.ParameterSpecification
getExpectedType, setExpectedType

Constructor Detail

NamedParameterSpecification

public NamedParameterSpecification(int sourceLine,
                                   int sourceColumn,
                                   String name)
Method Detail

bind

public int bind(PreparedStatement statement,
                QueryParameters qp,
                SessionImplementor session,
                int position)
         throws SQLException
Bind the appropriate value into the given statement at the specified position.

Specified by:
bind in interface ParameterSpecification
Parameters:
statement - The statement into which the value should be bound.
qp - The defined values for the current query execution.
session - The session against which the current execution is occuring.
position - The position from which to start binding value(s).
Returns:
The number of sql bind positions "eaten" by this bind operation.
Throws:
SQLException

renderDisplayInfo

public String renderDisplayInfo()
Specified by:
renderDisplayInfo in interface ParameterSpecification

getName

public String getName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PositionalParameterSpecification (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.param
Class PositionalParameterSpecification

java.lang.Object
    extended by org.hibernate.param.AbstractExplicitParameterSpecification
        extended by org.hibernate.param.PositionalParameterSpecification
All Implemented Interfaces:
ExplicitParameterSpecification, ParameterSpecification
public class PositionalParameterSpecification
extends AbstractExplicitParameterSpecification
implements ParameterSpecification

Relates to an explicit query positional (or ordinal) parameter.

Author:
Steve Ebersole

Constructor Summary
PositionalParameterSpecification(int sourceLine, int sourceColumn, int hqlPosition)
Method Summary
int | bind(PreparedStatement statement, QueryParameters qp, SessionImplementor session, int position) Bind the appropriate value into the given statement at the specified position.
int | getHqlPosition()
String | renderDisplayInfo()
Methods inherited from class org.hibernate.param.AbstractExplicitParameterSpecification
getExpectedType, getSourceColumn, getSourceLine, setExpectedType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.param.ParameterSpecification
getExpectedType, setExpectedType

Constructor Detail

PositionalParameterSpecification

public PositionalParameterSpecification(int sourceLine,
                                        int sourceColumn,
                                        int hqlPosition)
Method Detail

bind

public int bind(PreparedStatement statement,
                QueryParameters qp,
                SessionImplementor session,
                int position)
         throws SQLException
Bind the appropriate value into the given statement at the specified position.

Specified by:
bind in interface ParameterSpecification
Parameters:
statement - The statement into which the value should be bound.
qp - The defined values for the current query execution.
session - The session against which the current execution is occuring.
position - The position from which to start binding value(s).
Returns:
The number of sql bind positions "eaten" by this bind operation.
Throws:
SQLException

renderDisplayInfo

public String renderDisplayInfo()
Specified by:
renderDisplayInfo in interface ParameterSpecification

getHqlPosition

public int getHqlPosition()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VersionTypeSeedParameterSpecification (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.param
Class VersionTypeSeedParameterSpecification

java.lang.Object
    extended by org.hibernate.param.VersionTypeSeedParameterSpecification
All Implemented Interfaces:
ParameterSpecification
public class VersionTypeSeedParameterSpecification
extends Object
implements ParameterSpecification

Implementation of VersionTypeSeedParameterSpecification.

Author:
Steve Ebersole

Constructor Summary
VersionTypeSeedParameterSpecification(VersionType type)
Method Summary
int | bind(PreparedStatement statement, QueryParameters qp, SessionImplementor session, int position) Bind the appropriate value into the given statement at the specified position.
Type | getExpectedType()
String | renderDisplayInfo()
void | setExpectedType(Type expectedType)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VersionTypeSeedParameterSpecification

public VersionTypeSeedParameterSpecification(VersionType type)
Method Detail

bind

public int bind(PreparedStatement statement,
                QueryParameters qp,
                SessionImplementor session,
                int position)
         throws SQLException
Description copied from interface: ParameterSpecification
Bind the appropriate value into the given statement at the specified position.

Specified by:
bind in interface ParameterSpecification
Parameters:
statement - The statement into which the value should be bound.
qp - The defined values for the current query execution.
session - The session against which the current execution is occuring.
position - The position from which to start binding value(s).
Returns:
The number of sql bind positions "eaten" by this bind operation.
Throws:
SQLException
See Also:
ParameterSpecification.bind(java.sql.PreparedStatement, org.hibernate.engine.QueryParameters, org.hibernate.engine.SessionImplementor, int)

getExpectedType

public Type getExpectedType()
Specified by:
getExpectedType in interface ParameterSpecification

setExpectedType

public void setExpectedType(Type expectedType)
Specified by:
setExpectedType in interface ParameterSpecification

renderDisplayInfo

public String renderDisplayInfo()
Specified by:
renderDisplayInfo in interface ParameterSpecification
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.persister (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.persister

A persister defines a mapping strategy for a collection or entity.

See:
Description

Class Summary
PersisterFactory Factory for EntityPersister and CollectionPersister instances

Package org.hibernate.persister Description

A persister defines a mapping strategy for a collection or entity.


org.hibernate.persister Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.persister

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.persister.PersisterFactory


Uses of Package org.hibernate.persister (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.persister

No usage of org.hibernate.persister

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PersisterFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister
Class PersisterFactory

java.lang.Object
    extended by org.hibernate.persister.PersisterFactory
public final class PersisterFactory
extends Object

Factory for EntityPersister and CollectionPersister instances

Author:
Gavin King

Method Summary
static EntityPersister | createClassPersister(PersistentClass model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping cfg)
static CollectionPersister | createCollectionPersister(Configuration cfg, Collection model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createClassPersister

public static EntityPersister createClassPersister(PersistentClass model,
                                                   CacheConcurrencyStrategy cache,
                                                   SessionFactoryImplementor factory,
                                                   Mapping cfg)
                                            throws HibernateException
Throws:
HibernateException

createCollectionPersister

public static CollectionPersister createCollectionPersister(Configuration cfg,
                                                            Collection model,
                                                            CacheConcurrencyStrategy cache,
                                                            SessionFactoryImplementor factory)
                                                     throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.persister.collection (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.persister.collection

This package abstracts the persistence mechanism for collections.

See:
Description

Interface Summary
CollectionPersister | A strategy for persisting a collection role.
QueryableCollection | A collection role that may be queried or loaded by outer join.
SQLLoadableCollection |

Class Summary
AbstractCollectionPersister | Base implementation of the QueryableCollection interface.
BasicCollectionPersister | Collection persister for collections of values and many-to-many associations.
CollectionPropertyMapping |
CollectionPropertyNames | The names of all the collection properties.
CompositeElementPropertyMapping |
ElementPropertyMapping |
NamedQueryCollectionInitializer | A wrapper around a named query.
OneToManyPersister | Collection persister for one-to-many associations.

Package org.hibernate.persister.collection Description

This package abstracts the persistence mechanism for collections.

Concrete implementations of CollectionPersister define strategies for persistence of particular collection roles. Collection persisters may optionally implement QueryableCollection if they should be queryable using HQL or loaded using OuterJoinLoader.


org.hibernate.persister.collection Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.persister.collection

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.persister.collection.AbstractCollectionPersister (implements org.hibernate.metadata.CollectionMetadata, org.hibernate.persister.collection.SQLLoadableCollection)
      • class org.hibernate.persister.collection.BasicCollectionPersister
      • class org.hibernate.persister.collection.OneToManyPersister
    • class org.hibernate.persister.entity.AbstractPropertyMapping (implements org.hibernate.persister.entity.PropertyMapping)
      • class org.hibernate.persister.collection.CompositeElementPropertyMapping
    • class org.hibernate.persister.collection.CollectionPropertyMapping (implements org.hibernate.persister.entity.PropertyMapping)
    • class org.hibernate.persister.collection.CollectionPropertyNames
    • class org.hibernate.persister.collection.ElementPropertyMapping (implements org.hibernate.persister.entity.PropertyMapping)
    • class org.hibernate.persister.collection.NamedQueryCollectionInitializer (implements org.hibernate.loader.collection.CollectionInitializer)

Interface Hierarchy

  • interface org.hibernate.persister.collection.CollectionPersister
    • interface org.hibernate.persister.collection.QueryableCollection (also extends org.hibernate.persister.entity.Joinable, org.hibernate.persister.entity.PropertyMapping)
      • interface org.hibernate.persister.collection.SQLLoadableCollection
  • interface org.hibernate.persister.entity.Joinable
    • interface org.hibernate.persister.collection.QueryableCollection (also extends org.hibernate.persister.collection.CollectionPersister, org.hibernate.persister.entity.PropertyMapping)
      • interface org.hibernate.persister.collection.SQLLoadableCollection
  • interface org.hibernate.persister.entity.PropertyMapping
    • interface org.hibernate.persister.collection.QueryableCollection (also extends org.hibernate.persister.collection.CollectionPersister, org.hibernate.persister.entity.Joinable)
      • interface org.hibernate.persister.collection.SQLLoadableCollection


Uses of Package org.hibernate.persister.collection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.persister.collection

Packages that use org.hibernate.persister.collection
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.pretty | Classes for pretty printing things for exception and log messages.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.usertype | Interfaces for user-defined custom types.

Classes in org.hibernate.persister.collection used by org.hibernate.action
CollectionPersister
A strategy for persisting a collection role.

Classes in org.hibernate.persister.collection used by org.hibernate.cache.entry
CollectionPersister
A strategy for persisting a collection role.

Classes in org.hibernate.persister.collection used by org.hibernate.collection
BasicCollectionPersister
Collection persister for collections of values and many-to-many associations.
CollectionPersister
A strategy for persisting a collection role.

Classes in org.hibernate.persister.collection used by org.hibernate.criterion
QueryableCollection
A collection role that may be queried or loaded by outer join.

Classes in org.hibernate.persister.collection used by org.hibernate.engine
CollectionPersister
A strategy for persisting a collection role.

Classes in org.hibernate.persister.collection used by org.hibernate.event.def
CollectionPersister
A strategy for persisting a collection role.

Classes in org.hibernate.persister.collection used by org.hibernate.hql.ast.tree
QueryableCollection
A collection role that may be queried or loaded by outer join.

Classes in org.hibernate.persister.collection used by org.hibernate.hql.ast.util
QueryableCollection
A collection role that may be queried or loaded by outer join.

Classes in org.hibernate.persister.collection used by org.hibernate.hql.classic
CollectionPersister
A strategy for persisting a collection role.

Classes in org.hibernate.persister.collection used by org.hibernate.impl
CollectionPersister
A strategy for persisting a collection role.

Classes in org.hibernate.persister.collection used by org.hibernate.loader
CollectionPersister
A strategy for persisting a collection role.
QueryableCollection
A collection role that may be queried or loaded by outer join.

Classes in org.hibernate.persister.collection used by org.hibernate.loader.collection
CollectionPersister
A strategy for persisting a collection role.
QueryableCollection
A collection role that may be queried or loaded by outer join.

Classes in org.hibernate.persister.collection used by org.hibernate.loader.custom
CollectionPersister
A strategy for persisting a collection role.
SQLLoadableCollection

Classes in org.hibernate.persister.collection used by org.hibernate.loader.entity
QueryableCollection
A collection role that may be queried or loaded by outer join.

Classes in org.hibernate.persister.collection used by org.hibernate.loader.hql
CollectionPersister
A strategy for persisting a collection role.

Classes in org.hibernate.persister.collection used by org.hibernate.persister
CollectionPersister
A strategy for persisting a collection role.

Classes in org.hibernate.persister.collection used by org.hibernate.persister.collection
AbstractCollectionPersister
Base implementation of the QueryableCollection interface.
CollectionPersister
A strategy for persisting a collection role.
QueryableCollection
A collection role that may be queried or loaded by outer join.
SQLLoadableCollection

Classes in org.hibernate.persister.collection used by org.hibernate.pretty
CollectionPersister
A strategy for persisting a collection role.

Classes in org.hibernate.persister.collection used by org.hibernate.type
CollectionPersister
A strategy for persisting a collection role.

Classes in org.hibernate.persister.collection used by org.hibernate.usertype
CollectionPersister
A strategy for persisting a collection role.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CollectionPersister (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.collection
Interface CollectionPersister

All Known Subinterfaces:
QueryableCollection, SQLLoadableCollection
All Known Implementing Classes:
AbstractCollectionPersister
public interface CollectionPersister

A strategy for persisting a collection role. Defines a contract between the persistence strategy and the actual persistent collection framework and session. Does not define operations that are required for querying collections, or loading by outer join.

Implements persistence of a collection instance while the instance is referenced in a particular role.

This class is highly coupled to the PersistentCollection hierarchy, since double dispatch is used to load and update collection elements.

May be considered an immutable view of the mapping object

Author:
Gavin King
See Also:
QueryableCollection, PersistentCollection

Method Summary
void | deleteRows(PersistentCollection collection, Serializable key, SessionImplementor session) Delete the persistent state of any elements that were removed from the collection
boolean | elementExists(Serializable key, Object element, SessionImplementor session)
CacheConcurrencyStrategy | getCache() Get the cache
CacheEntryStructure | getCacheEntryStructure() Get the cache structure
CollectionMetadata | getCollectionMetadata()
Serializable[] | getCollectionSpaces() Get the "space" that holds the persistent state
CollectionType | getCollectionType() Get the associated Type
Object | getElementByIndex(Serializable key, Object index, SessionImplementor session, Object owner)
Class | getElementClass() Return the element class of an array, or null otherwise
String[] | getElementColumnAliases(String suffix) Generates the collection's element column aliases, based on the given suffix.
String | getElementNodeName()
Type | getElementType() Get the "element" type
SessionFactoryImplementor | getFactory()
String | getIdentifierColumnAlias(String suffix) Generates the collection's identifier column aliases, based on the given suffix.
IdentifierGenerator | getIdentifierGenerator() Get the surrogate key generation strategy (optional operation)
Type | getIdentifierType() Get the type of the surrogate key
String[] | getIndexColumnAliases(String suffix) Generates the collection's index column aliases, based on the given suffix.
String | getIndexNodeName()
Type | getIndexType() Get the "index" type for a list or map (optional operation)
String[] | getKeyColumnAliases(String suffix) Generates the collection's key column aliases, based on the given suffix.
Type | getKeyType() Get the "key" type (the type of the foreign key)
String | getManyToManyFilterFragment(String alias, Map enabledFilters)
String | getNodeName()
EntityPersister | getOwnerEntityPersister() Get the persister of the entity that "owns" this collection
String | getRole() Get the name of this collection role (the fully qualified class name, extended by a "property path")
int | getSize(Serializable key, SessionImplementor session)
boolean | hasCache() Is this collection role cacheable
boolean | hasIndex() Is this an "indexed" collection? (list or map)
boolean | hasManyToManyOrdering()
boolean | hasOrdering() Is this an ordered collection? (An ordered collection is ordered by the initialization operation, not by sorting that happens in memory, as in the case of a sorted collection.)
boolean | hasOrphanDelete() Does this collection implement "orphan delete"?
boolean | indexExists(Serializable key, Object index, SessionImplementor session)
void | initialize(Serializable key, SessionImplementor session) Initialize the given collection with the given key
void | insertRows(PersistentCollection collection, Serializable key, SessionImplementor session) Insert the persistent state of any new collection elements
boolean | isAffectedByEnabledFilters(SessionImplementor session)
boolean | isArray() Is this an array?
boolean | isCascadeDeleteEnabled() Is cascade delete handled by the database-level foreign key constraint definition?
boolean | isExtraLazy()
boolean | isInverse() Is this collection "inverse", so state changes are not propogated to the database.
boolean | isLazy() Is this collection lazyily initialized?
boolean | isManyToMany() Is this a many-to-many association? Note that this is mainly a convenience feature as the single persister does not conatin all the information needed to handle a many-to-many itself, as internally it is looked at as two many-to-ones.
boolean | isMutable() Can the elements of this collection change?
boolean | isOneToMany() Is this a one-to-many association?
boolean | isPrimitiveArray() Is this an array or primitive values?
boolean | isVersioned() Does this collection cause version increment of the owning entity?
void | postInstantiate()
Object | readElement(ResultSet rs, Object owner, String[] columnAliases, SessionImplementor session) Read the element from a row of the JDBC ResultSet
Object | readIdentifier(ResultSet rs, String columnAlias, SessionImplementor session) Read the identifier from a row of the JDBC ResultSet
Object | readIndex(ResultSet rs, String[] columnAliases, SessionImplementor session) Read the index from a row of the JDBC ResultSet
Object | readKey(ResultSet rs, String[] keyAliases, SessionImplementor session) Read the key from a row of the JDBC ResultSet
void | recreate(PersistentCollection collection, Serializable key, SessionImplementor session) (Re)create the collection's persistent state
void | remove(Serializable id, SessionImplementor session) Completely remove the persistent state of the collection
void | updateRows(PersistentCollection collection, Serializable key, SessionImplementor session) Update the persistent state of any elements that were modified

Method Detail

initialize

public void initialize(Serializable key,
                       SessionImplementor session)
                throws HibernateException
Initialize the given collection with the given key

Throws:
HibernateException

getCache

public CacheConcurrencyStrategy getCache()
Get the cache

hasCache

public boolean hasCache()
Is this collection role cacheable

getCacheEntryStructure

public CacheEntryStructure getCacheEntryStructure()
Get the cache structure

getCollectionType

public CollectionType getCollectionType()
Get the associated Type

getKeyType

public Type getKeyType()
Get the "key" type (the type of the foreign key)

getIndexType

public Type getIndexType()
Get the "index" type for a list or map (optional operation)

getElementType

public Type getElementType()
Get the "element" type

getElementClass

public Class getElementClass()
Return the element class of an array, or null otherwise

readKey

public Object readKey(ResultSet rs,
                      String[] keyAliases,
                      SessionImplementor session)
               throws HibernateException,
                      SQLException
Read the key from a row of the JDBC ResultSet

Throws:
HibernateException
SQLException

readElement

public Object readElement(ResultSet rs,
                          Object owner,
                          String[] columnAliases,
                          SessionImplementor session)
                   throws HibernateException,
                          SQLException
Read the element from a row of the JDBC ResultSet

Throws:
HibernateException
SQLException

readIndex

public Object readIndex(ResultSet rs,
                        String[] columnAliases,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Read the index from a row of the JDBC ResultSet

Throws:
HibernateException
SQLException

readIdentifier

public Object readIdentifier(ResultSet rs,
                             String columnAlias,
                             SessionImplementor session)
                      throws HibernateException,
                             SQLException
Read the identifier from a row of the JDBC ResultSet

Throws:
HibernateException
SQLException

isPrimitiveArray

public boolean isPrimitiveArray()
Is this an array or primitive values?

isArray

public boolean isArray()
Is this an array?

isOneToMany

public boolean isOneToMany()
Is this a one-to-many association?

isManyToMany

public boolean isManyToMany()
Is this a many-to-many association? Note that this is mainly a convenience feature as the single persister does not conatin all the information needed to handle a many-to-many itself, as internally it is looked at as two many-to-ones.

getManyToManyFilterFragment

public String getManyToManyFilterFragment(String alias,
                                          Map enabledFilters)

hasIndex

public boolean hasIndex()
Is this an "indexed" collection? (list or map)

isLazy

public boolean isLazy()
Is this collection lazyily initialized?

isInverse

public boolean isInverse()
Is this collection "inverse", so state changes are not propogated to the database.

remove

public void remove(Serializable id,
                   SessionImplementor session)
            throws HibernateException
Completely remove the persistent state of the collection

Throws:
HibernateException

recreate

public void recreate(PersistentCollection collection,
                     Serializable key,
                     SessionImplementor session)
              throws HibernateException
(Re)create the collection's persistent state

Throws:
HibernateException

deleteRows

public void deleteRows(PersistentCollection collection,
                       Serializable key,
                       SessionImplementor session)
                throws HibernateException
Delete the persistent state of any elements that were removed from the collection

Throws:
HibernateException

updateRows

public void updateRows(PersistentCollection collection,
                       Serializable key,
                       SessionImplementor session)
                throws HibernateException
Update the persistent state of any elements that were modified

Throws:
HibernateException

insertRows

public void insertRows(PersistentCollection collection,
                       Serializable key,
                       SessionImplementor session)
                throws HibernateException
Insert the persistent state of any new collection elements

Throws:
HibernateException

getRole

public String getRole()
Get the name of this collection role (the fully qualified class name, extended by a "property path")

getOwnerEntityPersister

public EntityPersister getOwnerEntityPersister()
Get the persister of the entity that "owns" this collection

getIdentifierGenerator

public IdentifierGenerator getIdentifierGenerator()
Get the surrogate key generation strategy (optional operation)

getIdentifierType

public Type getIdentifierType()
Get the type of the surrogate key

hasOrphanDelete

public boolean hasOrphanDelete()
Does this collection implement "orphan delete"?

hasOrdering

public boolean hasOrdering()
Is this an ordered collection? (An ordered collection is ordered by the initialization operation, not by sorting that happens in memory, as in the case of a sorted collection.)

hasManyToManyOrdering

public boolean hasManyToManyOrdering()

getCollectionSpaces

public Serializable[] getCollectionSpaces()
Get the "space" that holds the persistent state

getCollectionMetadata

public CollectionMetadata getCollectionMetadata()

isCascadeDeleteEnabled

public boolean isCascadeDeleteEnabled()
Is cascade delete handled by the database-level foreign key constraint definition?

isVersioned

public boolean isVersioned()
Does this collection cause version increment of the owning entity?

isMutable

public boolean isMutable()
Can the elements of this collection change?

getNodeName

public String getNodeName()

getElementNodeName

public String getElementNodeName()

getIndexNodeName

public String getIndexNodeName()

postInstantiate

public void postInstantiate()
                     throws MappingException
Throws:
MappingException

getFactory

public SessionFactoryImplementor getFactory()

isAffectedByEnabledFilters

public boolean isAffectedByEnabledFilters(SessionImplementor session)

getKeyColumnAliases

public String[] getKeyColumnAliases(String suffix)
Generates the collection's key column aliases, based on the given suffix.

Parameters:
suffix - The suffix to use in the key column alias generation.
Returns:
The key column aliases.

getIndexColumnAliases

public String[] getIndexColumnAliases(String suffix)
Generates the collection's index column aliases, based on the given suffix.

Parameters:
suffix - The suffix to use in the index column alias generation.
Returns:
The key column aliases, or null if not indexed.

getElementColumnAliases

public String[] getElementColumnAliases(String suffix)
Generates the collection's element column aliases, based on the given suffix.

Parameters:
suffix - The suffix to use in the element column alias generation.
Returns:
The key column aliases.

getIdentifierColumnAlias

public String getIdentifierColumnAlias(String suffix)
Generates the collection's identifier column aliases, based on the given suffix.

Parameters:
suffix - The suffix to use in the key column alias generation.
Returns:
The key column aliases.

isExtraLazy

public boolean isExtraLazy()

getSize

public int getSize(Serializable key,
                   SessionImplementor session)

indexExists

public boolean indexExists(Serializable key,
                           Object index,
                           SessionImplementor session)

elementExists

public boolean elementExists(Serializable key,
                             Object element,
                             SessionImplementor session)

getElementByIndex

public Object getElementByIndex(Serializable key,
                                Object index,
                                SessionImplementor session,
                                Object owner)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


QueryableCollection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.collection
Interface QueryableCollection

All Superinterfaces:
CollectionPersister, Joinable, PropertyMapping
All Known Subinterfaces:
SQLLoadableCollection
All Known Implementing Classes:
AbstractCollectionPersister
public interface QueryableCollection
extends PropertyMapping, Joinable, CollectionPersister

A collection role that may be queried or loaded by outer join.

Author:
Gavin King

Method Summary
String[] | getElementColumnNames() Get the names of the collection element columns (or the primary key columns in the case of a one-to-many association)
String[] | getElementColumnNames(String alias) Get the names of the collection element columns (or the primary key columns in the case of a one-to-many association), aliased by the given table alias
EntityPersister | getElementPersister() Get the persister of the element class, if this is a collection of entities (optional operation).
FetchMode | getFetchMode() Should we load this collection role by outerjoining?
String[] | getIndexColumnNames() Get the names of the collection index columns if this is an indexed collection (optional operation)
String[] | getIndexColumnNames(String alias) Get the names of the collection index columns if this is an indexed collection (optional operation), aliased by the given table alias
String[] | getIndexFormulas() Get the index formulas if this is an indexed collection (optional operation)
String | getManyToManyOrderByString(String alias) Get the order-by to be applied at the target table of a many to many
String | getSQLOrderByString(String alias) Get the order by SQL
boolean | hasWhere() Does this collection role have a where clause filter?
String | selectFragment(String alias, String columnSuffix) Generate a list of collection index and element columns
Methods inherited from interface org.hibernate.persister.entity.PropertyMapping
getType, toColumns, toColumns, toType
Methods inherited from interface org.hibernate.persister.entity.Joinable
consumesCollectionAlias, consumesEntityAlias, filterFragment, fromJoinFragment, getKeyColumnNames, getName, getTableName, isCollection, oneToManyFilterFragment, selectFragment, whereJoinFragment
Methods inherited from interface org.hibernate.persister.collection.CollectionPersister
deleteRows, elementExists, getCache, getCacheEntryStructure, getCollectionMetadata, getCollectionSpaces, getCollectionType, getElementByIndex, getElementClass, getElementColumnAliases, getElementNodeName, getElementType, getFactory, getIdentifierColumnAlias, getIdentifierGenerator, getIdentifierType, getIndexColumnAliases, getIndexNodeName, getIndexType, getKeyColumnAliases, getKeyType, getManyToManyFilterFragment, getNodeName, getOwnerEntityPersister, getRole, getSize, hasCache, hasIndex, hasManyToManyOrdering, hasOrdering, hasOrphanDelete, indexExists, initialize, insertRows, isAffectedByEnabledFilters, isArray, isCascadeDeleteEnabled, isExtraLazy, isInverse, isLazy, isManyToMany, isMutable, isOneToMany, isPrimitiveArray, isVersioned, postInstantiate, readElement, readIdentifier, readIndex, readKey, recreate, remove, updateRows

Method Detail

selectFragment

public String selectFragment(String alias,
                             String columnSuffix)
Generate a list of collection index and element columns

getIndexColumnNames

public String[] getIndexColumnNames()
Get the names of the collection index columns if this is an indexed collection (optional operation)

getIndexFormulas

public String[] getIndexFormulas()
Get the index formulas if this is an indexed collection (optional operation)

getIndexColumnNames

public String[] getIndexColumnNames(String alias)
Get the names of the collection index columns if this is an indexed collection (optional operation), aliased by the given table alias

getElementColumnNames

public String[] getElementColumnNames(String alias)
Get the names of the collection element columns (or the primary key columns in the case of a one-to-many association), aliased by the given table alias

getElementColumnNames

public String[] getElementColumnNames()
Get the names of the collection element columns (or the primary key columns in the case of a one-to-many association)

getSQLOrderByString

public String getSQLOrderByString(String alias)
Get the order by SQL

getManyToManyOrderByString

public String getManyToManyOrderByString(String alias)
Get the order-by to be applied at the target table of a many to many

Parameters:
alias - The alias for the many-to-many target table
Returns:
appropriate order-by fragment or empty string.

hasWhere

public boolean hasWhere()
Does this collection role have a where clause filter?

getElementPersister

public EntityPersister getElementPersister()
Get the persister of the element class, if this is a collection of entities (optional operation). Note that for a one-to-many association, the returned persister must be OuterJoinLoadable.

getFetchMode

public FetchMode getFetchMode()
Should we load this collection role by outerjoining?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLLoadableCollection (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.collection
Interface SQLLoadableCollection

All Superinterfaces:
CollectionPersister, Joinable, PropertyMapping, QueryableCollection
All Known Implementing Classes:
AbstractCollectionPersister
public interface SQLLoadableCollection
extends QueryableCollection

Method Summary
String[] | getCollectionPropertyColumnAliases(String propertyName, String string)
String | getIdentifierColumnName()
Methods inherited from interface org.hibernate.persister.collection.QueryableCollection
getElementColumnNames, getElementColumnNames, getElementPersister, getFetchMode, getIndexColumnNames, getIndexColumnNames, getIndexFormulas, getManyToManyOrderByString, getSQLOrderByString, hasWhere, selectFragment
Methods inherited from interface org.hibernate.persister.entity.PropertyMapping
getType, toColumns, toColumns, toType
Methods inherited from interface org.hibernate.persister.entity.Joinable
consumesCollectionAlias, consumesEntityAlias, filterFragment, fromJoinFragment, getKeyColumnNames, getName, getTableName, isCollection, oneToManyFilterFragment, selectFragment, whereJoinFragment
Methods inherited from interface org.hibernate.persister.collection.CollectionPersister
deleteRows, elementExists, getCache, getCacheEntryStructure, getCollectionMetadata, getCollectionSpaces, getCollectionType, getElementByIndex, getElementClass, getElementColumnAliases, getElementNodeName, getElementType, getFactory, getIdentifierColumnAlias, getIdentifierGenerator, getIdentifierType, getIndexColumnAliases, getIndexNodeName, getIndexType, getKeyColumnAliases, getKeyType, getManyToManyFilterFragment, getNodeName, getOwnerEntityPersister, getRole, getSize, hasCache, hasIndex, hasManyToManyOrdering, hasOrdering, hasOrphanDelete, indexExists, initialize, insertRows, isAffectedByEnabledFilters, isArray, isCascadeDeleteEnabled, isExtraLazy, isInverse, isLazy, isManyToMany, isMutable, isOneToMany, isPrimitiveArray, isVersioned, postInstantiate, readElement, readIdentifier, readIndex, readKey, recreate, remove, updateRows

Method Detail

getCollectionPropertyColumnAliases

public String[] getCollectionPropertyColumnAliases(String propertyName,
                                                   String string)

getIdentifierColumnName

public String getIdentifierColumnName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractCollectionPersister (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.collection
Class AbstractCollectionPersister

java.lang.Object
    extended by org.hibernate.persister.collection.AbstractCollectionPersister
All Implemented Interfaces:
CollectionMetadata, CollectionPersister, Joinable, PropertyMapping, QueryableCollection, SQLLoadableCollection
Direct Known Subclasses:
BasicCollectionPersister, OneToManyPersister
public abstract class AbstractCollectionPersister
extends Object
implements CollectionMetadata, SQLLoadableCollection

Base implementation of the QueryableCollection interface.

Author:
Gavin King
See Also:
BasicCollectionPersister, OneToManyPersister

Field Summary
protected int | batchSize
protected String[] | elementColumnAliases
protected boolean[] | elementColumnIsInPrimaryKey
protected boolean[] | elementColumnIsSettable
protected String[] | elementColumnNames
protected String[] | elementFormulas
protected String[] | elementFormulaTemplates
protected boolean | elementIsPureFormula
protected Type | elementType
protected boolean | hasIdentifier
protected boolean | hasIndex
protected boolean | hasWhere
protected String | identifierColumnName
protected String[] | indexColumnAliases
protected boolean[] | indexColumnIsSettable
protected String[] | indexColumnNames
protected boolean | indexContainsFormula
protected String[] | indexFormulas
protected String[] | indexFormulaTemplates
protected String[] | keyColumnAliases
protected String[] | keyColumnNames
protected String | qualifiedTableName
protected String | sqlWhereString
Constructor Summary
AbstractCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
Method Summary
protected void | appendElementColumns(SelectFragment frag, String elemAlias)
protected void | appendIdentifierColumns(SelectFragment frag, String alias)
protected void | appendIndexColumns(SelectFragment frag, String alias)
protected abstract CollectionInitializer | createCollectionInitializer(Map enabledFilters)
protected abstract CollectionInitializer | createSubselectInitializer(SubselectFetch subselect, SessionImplementor session)
protected Object | decrementIndexByBase(Object index)
void | deleteRows(PersistentCollection collection, Serializable id, SessionImplementor session) Delete the persistent state of any elements that were removed from the collection
protected abstract int | doUpdateRows(Serializable key, PersistentCollection collection, SessionImplementor session)
boolean | elementExists(Serializable key, Object element, SessionImplementor session)
protected String | filterFragment(String alias)
String | filterFragment(String alias, Map enabledFilters) Get the where clause filter, given a query alias and considering enabled session filters
protected abstract String | generateDeleteRowString()
protected abstract String | generateDeleteString()
protected String | generateDetectRowByElementString()
protected String | generateDetectRowByIndexString()
protected abstract String | generateInsertRowString()
protected SelectFragment | generateSelectFragment(String alias, String columnSuffix)
protected String | generateSelectRowByIndexString()
protected String | generateSelectSizeString(boolean isIntegerIndexed)
protected abstract String | generateUpdateRowString()
protected CollectionInitializer | getAppropriateInitializer(Serializable key, SessionImplementor session)
CacheConcurrencyStrategy | getCache() Get the cache
CacheEntryStructure | getCacheEntryStructure() Get the cache structure
CollectionMetadata | getCollectionMetadata()
String[] | getCollectionPropertyColumnAliases(String propertyName, String suffix)
Serializable[] | getCollectionSpaces() Get the "space" that holds the persistent state
CollectionType | getCollectionType() Get the associated Type
protected ExecuteUpdateResultCheckStyle | getDeleteAllCheckStyle()
protected ExecuteUpdateResultCheckStyle | getDeleteCheckStyle()
protected Dialect | getDialect()
Object | getElementByIndex(Serializable key, Object index, SessionImplementor session, Object owner)
Class | getElementClass() Return the element class of an array, or null otherwise
String[] | getElementColumnAliases(String suffix) Generates the collection's element column aliases, based on the given suffix.
String[] | getElementColumnNames() Get the names of the collection element columns (or the primary key columns in the case of a one-to-many association)
String[] | getElementColumnNames(String alias) Get the names of the collection element columns (or the primary key columns in the case of a one-to-many association), aliased by the given table alias
String | getElementNodeName()
EntityPersister | getElementPersister() Get the persister of the element class, if this is a collection of entities (optional operation).
Type | getElementType() The collection element type
SessionFactoryImplementor | getFactory()
FetchMode | getFetchMode() Should we load this collection role by outerjoining?
String | getIdentifierColumnAlias(String suffix) Generates the collection's identifier column aliases, based on the given suffix.
String | getIdentifierColumnName()
IdentifierGenerator | getIdentifierGenerator() Get the surrogate key generation strategy (optional operation)
Type | getIdentifierType() Get the type of the surrogate key
String[] | getIndexColumnAliases(String suffix) Generates the collection's index column aliases, based on the given suffix.
String[] | getIndexColumnNames() Get the names of the collection index columns if this is an indexed collection (optional operation)
String[] | getIndexColumnNames(String alias) Get the names of the collection index columns if this is an indexed collection (optional operation), aliased by the given table alias
String[] | getIndexFormulas() Get the index formulas if this is an indexed collection (optional operation)
String | getIndexNodeName()
Type | getIndexType() The collection index type (or null if the collection has no index)
protected ExecuteUpdateResultCheckStyle | getInsertCheckStyle()
String[] | getKeyColumnAliases(String suffix) Generates the collection's key column aliases, based on the given suffix.
String[] | getKeyColumnNames() The columns to join on
Type | getKeyType() The collection key type
String | getManyToManyFilterFragment(String alias, Map enabledFilters)
String | getManyToManyOrderByString(String alias) Get the order-by to be applied at the target table of a many to many
String | getName() An identifying name; a class name or collection role name.
String | getNodeName()
String | getOwnerEntityName()
EntityPersister | getOwnerEntityPersister() Get the persister of the entity that "owns" this collection
String | getRole() The name of this collection role
int | getSize(Serializable key, SessionImplementor session)
protected String | getSQLDeleteRowString()
protected String | getSQLDeleteString()
protected SQLExceptionConverter | getSQLExceptionConverter()
protected String | getSQLInsertRowString()
String | getSQLOrderByString(String alias) Get the order by SQL
protected String | getSQLUpdateRowString()
protected String | getSQLWhereString(String alias)
String | getTableName() The table to join to.
Type | getType() Get the type of the thing containing the properties
protected ExecuteUpdateResultCheckStyle | getUpdateCheckStyle()
boolean | hasCache() Is this collection role cacheable
boolean | hasIndex() Is this collection indexed?
boolean | hasManyToManyOrdering()
boolean | hasOrdering() Is this an ordered collection? (An ordered collection is ordered by the initialization operation, not by sorting that happens in memory, as in the case of a sorted collection.)
boolean | hasOrphanDelete() Does this collection implement "orphan delete"?
boolean | hasWhere() Does this collection role have a where clause filter?
protected Object | incrementIndexByBase(Object index)
boolean | indexExists(Serializable key, Object index, SessionImplementor session)
void | initCollectionPropertyMap()
void | initialize(Serializable key, SessionImplementor session) Initialize the given collection with the given key
void | insertRows(PersistentCollection collection, Serializable id, SessionImplementor session) Insert the persistent state of any new collection elements
boolean | isAffectedByEnabledFilters(SessionImplementor session)
boolean | isArray() Is the collection an array?
boolean | isCollection() Is this instance actually a CollectionPersister?
protected boolean | isDeleteAllCallable()
protected boolean | isDeleteCallable()
boolean | isExtraLazy()
protected boolean | isInsertCallable()
boolean | isInverse() Is this collection "inverse", so state changes are not propogated to the database.
boolean | isLazy() Is the collection lazily initialized?
abstract boolean | isManyToMany() Is this a many-to-many association? Note that this is mainly a convenience feature as the single persister does not conatin all the information needed to handle a many-to-many itself, as internally it is looked at as two many-to-ones.
boolean | isMutable() Can the elements of this collection change?
boolean | isPrimitiveArray() Is the collection a primitive array?
protected boolean | isRowDeleteEnabled()
protected boolean | isRowInsertEnabled()
boolean | isSubselectLoadable()
protected boolean | isUpdateCallable()
boolean | isVersioned() Does this collection cause version increment of the owning entity?
protected void | logStaticSQL()
String | oneToManyFilterFragment(String alias)
void | postInstantiate()
Object | readElement(ResultSet rs, Object owner, String[] aliases, SessionImplementor session) Read the element from a row of the JDBC ResultSet
Object | readIdentifier(ResultSet rs, String alias, SessionImplementor session) Read the identifier from a row of the JDBC ResultSet
Object | readIndex(ResultSet rs, String[] aliases, SessionImplementor session) Read the index from a row of the JDBC ResultSet
Object | readKey(ResultSet rs, String[] aliases, SessionImplementor session) Read the key from a row of the JDBC ResultSet
void | recreate(PersistentCollection collection, Serializable id, SessionImplementor session) (Re)create the collection's persistent state
void | remove(Serializable id, SessionImplementor session) Completely remove the persistent state of the collection
String | selectFragment(String alias, String columnSuffix) Generate a list of collection index, key and element columns
String[] | toColumns(String propertyName) Given a property path, return the corresponding column name(s).
String[] | toColumns(String alias, String propertyName) Given a query alias and a property path, return the qualified column name
String | toString()
Type | toType(String propertyName) Given a component path expression, get the type of the property
void | updateRows(PersistentCollection collection, Serializable id, SessionImplementor session) Update the persistent state of any elements that were modified
protected int | writeElement(PreparedStatement st, Object elt, int i, SessionImplementor session) Write the element to a JDBC PreparedStatement
protected int | writeElementToWhere(PreparedStatement st, Object elt, int i, SessionImplementor session) Write the element to a JDBC PreparedStatement
int | writeIdentifier(PreparedStatement st, Object id, int i, SessionImplementor session) Write the identifier to a JDBC PreparedStatement
protected int | writeIndex(PreparedStatement st, Object index, int i, SessionImplementor session) Write the index to a JDBC PreparedStatement
protected int | writeIndexToWhere(PreparedStatement st, Object index, int i, SessionImplementor session) Write the index to a JDBC PreparedStatement
protected int | writeKey(PreparedStatement st, Serializable key, int i, SessionImplementor session) Write the key to a JDBC PreparedStatement
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.persister.entity.Joinable
consumesCollectionAlias, consumesEntityAlias, fromJoinFragment, selectFragment, whereJoinFragment
Methods inherited from interface org.hibernate.persister.collection.CollectionPersister
isCascadeDeleteEnabled, isOneToMany

Field Detail

sqlWhereString

protected final String sqlWhereString

hasWhere

protected final boolean hasWhere

indexContainsFormula

protected final boolean indexContainsFormula

elementIsPureFormula

protected final boolean elementIsPureFormula

elementType

protected final Type elementType

keyColumnNames

protected final String[] keyColumnNames

indexColumnNames

protected final String[] indexColumnNames

indexFormulaTemplates

protected final String[] indexFormulaTemplates

indexFormulas

protected final String[] indexFormulas

indexColumnIsSettable

protected final boolean[] indexColumnIsSettable

elementColumnNames

protected final String[] elementColumnNames

elementFormulaTemplates

protected final String[] elementFormulaTemplates

elementFormulas

protected final String[] elementFormulas

elementColumnIsSettable

protected final boolean[] elementColumnIsSettable

elementColumnIsInPrimaryKey

protected final boolean[] elementColumnIsInPrimaryKey

indexColumnAliases

protected final String[] indexColumnAliases

elementColumnAliases

protected final String[] elementColumnAliases

keyColumnAliases

protected final String[] keyColumnAliases

identifierColumnName

protected final String identifierColumnName

qualifiedTableName

protected final String qualifiedTableName

hasIndex

protected final boolean hasIndex

hasIdentifier

protected final boolean hasIdentifier

batchSize

protected final int batchSize
Constructor Detail

AbstractCollectionPersister

public AbstractCollectionPersister(Collection collection,
                                   CacheConcurrencyStrategy cache,
                                   Configuration cfg,
                                   SessionFactoryImplementor factory)
                            throws MappingException,
                                   CacheException
Method Detail

postInstantiate

public void postInstantiate()
                     throws MappingException
Specified by:
postInstantiate in interface CollectionPersister
Throws:
MappingException

logStaticSQL

protected void logStaticSQL()

initialize

public void initialize(Serializable key,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: CollectionPersister
Initialize the given collection with the given key

Specified by:
initialize in interface CollectionPersister
Throws:
HibernateException

getAppropriateInitializer

protected CollectionInitializer getAppropriateInitializer(Serializable key,
                                                          SessionImplementor session)

createSubselectInitializer

protected abstract CollectionInitializer createSubselectInitializer(SubselectFetch subselect,
                                                                    SessionImplementor session)

createCollectionInitializer

protected abstract CollectionInitializer createCollectionInitializer(Map enabledFilters)
                                                              throws MappingException
Throws:
MappingException

getCache

public CacheConcurrencyStrategy getCache()
Description copied from interface: CollectionPersister
Get the cache

Specified by:
getCache in interface CollectionPersister

hasCache

public boolean hasCache()
Description copied from interface: CollectionPersister
Is this collection role cacheable

Specified by:
hasCache in interface CollectionPersister

getCollectionType

public CollectionType getCollectionType()
Description copied from interface: CollectionPersister
Get the associated Type

Specified by:
getCollectionType in interface CollectionPersister

getSQLWhereString

protected String getSQLWhereString(String alias)

getSQLOrderByString

public String getSQLOrderByString(String alias)
Description copied from interface: QueryableCollection
Get the order by SQL

Specified by:
getSQLOrderByString in interface QueryableCollection

getManyToManyOrderByString

public String getManyToManyOrderByString(String alias)
Description copied from interface: QueryableCollection
Get the order-by to be applied at the target table of a many to many

Specified by:
getManyToManyOrderByString in interface QueryableCollection
Parameters:
alias - The alias for the many-to-many target table
Returns:
appropriate order-by fragment or empty string.

getFetchMode

public FetchMode getFetchMode()
Description copied from interface: QueryableCollection
Should we load this collection role by outerjoining?

Specified by:
getFetchMode in interface QueryableCollection

hasOrdering

public boolean hasOrdering()
Description copied from interface: CollectionPersister
Is this an ordered collection? (An ordered collection is ordered by the initialization operation, not by sorting that happens in memory, as in the case of a sorted collection.)

Specified by:
hasOrdering in interface CollectionPersister

hasManyToManyOrdering

public boolean hasManyToManyOrdering()
Specified by:
hasManyToManyOrdering in interface CollectionPersister

hasWhere

public boolean hasWhere()
Description copied from interface: QueryableCollection
Does this collection role have a where clause filter?

Specified by:
hasWhere in interface QueryableCollection

getSQLDeleteString

protected String getSQLDeleteString()

getSQLInsertRowString

protected String getSQLInsertRowString()

getSQLUpdateRowString

protected String getSQLUpdateRowString()

getSQLDeleteRowString

protected String getSQLDeleteRowString()

getKeyType

public Type getKeyType()
Description copied from interface: CollectionMetadata
The collection key type

Specified by:
getKeyType in interface CollectionMetadata

getIndexType

public Type getIndexType()
Description copied from interface: CollectionMetadata
The collection index type (or null if the collection has no index)

Specified by:
getIndexType in interface CollectionMetadata

getElementType

public Type getElementType()
Description copied from interface: CollectionMetadata
The collection element type

Specified by:
getElementType in interface CollectionMetadata

getElementClass

public Class getElementClass()
Return the element class of an array, or null otherwise

Specified by:
getElementClass in interface CollectionPersister

readElement

public Object readElement(ResultSet rs,
                          Object owner,
                          String[] aliases,
                          SessionImplementor session)
                   throws HibernateException,
                          SQLException
Description copied from interface: CollectionPersister
Read the element from a row of the JDBC ResultSet

Specified by:
readElement in interface CollectionPersister
Throws:
HibernateException
SQLException

readIndex

public Object readIndex(ResultSet rs,
                        String[] aliases,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: CollectionPersister
Read the index from a row of the JDBC ResultSet

Specified by:
readIndex in interface CollectionPersister
Throws:
HibernateException
SQLException

decrementIndexByBase

protected Object decrementIndexByBase(Object index)

readIdentifier

public Object readIdentifier(ResultSet rs,
                             String alias,
                             SessionImplementor session)
                      throws HibernateException,
                             SQLException
Description copied from interface: CollectionPersister
Read the identifier from a row of the JDBC ResultSet

Specified by:
readIdentifier in interface CollectionPersister
Throws:
HibernateException
SQLException

readKey

public Object readKey(ResultSet rs,
                      String[] aliases,
                      SessionImplementor session)
               throws HibernateException,
                      SQLException
Description copied from interface: CollectionPersister
Read the key from a row of the JDBC ResultSet

Specified by:
readKey in interface CollectionPersister
Throws:
HibernateException
SQLException

writeKey

protected int writeKey(PreparedStatement st,
                       Serializable key,
                       int i,
                       SessionImplementor session)
                throws HibernateException,
                       SQLException
Write the key to a JDBC PreparedStatement

Throws:
HibernateException
SQLException

writeElement

protected int writeElement(PreparedStatement st,
                           Object elt,
                           int i,
                           SessionImplementor session)
                    throws HibernateException,
                           SQLException
Write the element to a JDBC PreparedStatement

Throws:
HibernateException
SQLException

writeIndex

protected int writeIndex(PreparedStatement st,
                         Object index,
                         int i,
                         SessionImplementor session)
                  throws HibernateException,
                         SQLException
Write the index to a JDBC PreparedStatement

Throws:
HibernateException
SQLException

incrementIndexByBase

protected Object incrementIndexByBase(Object index)

writeElementToWhere

protected int writeElementToWhere(PreparedStatement st,
                                  Object elt,
                                  int i,
                                  SessionImplementor session)
                           throws HibernateException,
                                  SQLException
Write the element to a JDBC PreparedStatement

Throws:
HibernateException
SQLException

writeIndexToWhere

protected int writeIndexToWhere(PreparedStatement st,
                                Object index,
                                int i,
                                SessionImplementor session)
                         throws HibernateException,
                                SQLException
Write the index to a JDBC PreparedStatement

Throws:
HibernateException
SQLException

writeIdentifier

public int writeIdentifier(PreparedStatement st,
                           Object id,
                           int i,
                           SessionImplementor session)
                    throws HibernateException,
                           SQLException
Write the identifier to a JDBC PreparedStatement

Throws:
HibernateException
SQLException

isPrimitiveArray

public boolean isPrimitiveArray()
Description copied from interface: CollectionMetadata
Is the collection a primitive array?

Specified by:
isPrimitiveArray in interface CollectionMetadata

isArray

public boolean isArray()
Description copied from interface: CollectionMetadata
Is the collection an array?

Specified by:
isArray in interface CollectionMetadata

getKeyColumnAliases

public String[] getKeyColumnAliases(String suffix)
Description copied from interface: CollectionPersister
Generates the collection's key column aliases, based on the given suffix.

Specified by:
getKeyColumnAliases in interface CollectionPersister
Parameters:
suffix - The suffix to use in the key column alias generation.
Returns:
The key column aliases.

getElementColumnAliases

public String[] getElementColumnAliases(String suffix)
Description copied from interface: CollectionPersister
Generates the collection's element column aliases, based on the given suffix.

Specified by:
getElementColumnAliases in interface CollectionPersister
Parameters:
suffix - The suffix to use in the element column alias generation.
Returns:
The key column aliases.

getIndexColumnAliases

public String[] getIndexColumnAliases(String suffix)
Description copied from interface: CollectionPersister
Generates the collection's index column aliases, based on the given suffix.

Specified by:
getIndexColumnAliases in interface CollectionPersister
Parameters:
suffix - The suffix to use in the index column alias generation.
Returns:
The key column aliases, or null if not indexed.

getIdentifierColumnAlias

public String getIdentifierColumnAlias(String suffix)
Description copied from interface: CollectionPersister
Generates the collection's identifier column aliases, based on the given suffix.

Specified by:
getIdentifierColumnAlias in interface CollectionPersister
Parameters:
suffix - The suffix to use in the key column alias generation.
Returns:
The key column aliases.

getIdentifierColumnName

public String getIdentifierColumnName()
Specified by:
getIdentifierColumnName in interface SQLLoadableCollection

selectFragment

public String selectFragment(String alias,
                             String columnSuffix)
Generate a list of collection index, key and element columns

Specified by:
selectFragment in interface QueryableCollection

generateSelectSizeString

protected String generateSelectSizeString(boolean isIntegerIndexed)

generateDetectRowByIndexString

protected String generateDetectRowByIndexString()

generateSelectRowByIndexString

protected String generateSelectRowByIndexString()

generateDetectRowByElementString

protected String generateDetectRowByElementString()

generateSelectFragment

protected SelectFragment generateSelectFragment(String alias,
                                                String columnSuffix)

appendElementColumns

protected void appendElementColumns(SelectFragment frag,
                                    String elemAlias)

appendIndexColumns

protected void appendIndexColumns(SelectFragment frag,
                                  String alias)

appendIdentifierColumns

protected void appendIdentifierColumns(SelectFragment frag,
                                       String alias)

getIndexColumnNames

public String[] getIndexColumnNames()
Description copied from interface: QueryableCollection
Get the names of the collection index columns if this is an indexed collection (optional operation)

Specified by:
getIndexColumnNames in interface QueryableCollection

getIndexFormulas

public String[] getIndexFormulas()
Description copied from interface: QueryableCollection
Get the index formulas if this is an indexed collection (optional operation)

Specified by:
getIndexFormulas in interface QueryableCollection

getIndexColumnNames

public String[] getIndexColumnNames(String alias)
Description copied from interface: QueryableCollection
Get the names of the collection index columns if this is an indexed collection (optional operation), aliased by the given table alias

Specified by:
getIndexColumnNames in interface QueryableCollection

getElementColumnNames

public String[] getElementColumnNames(String alias)
Description copied from interface: QueryableCollection
Get the names of the collection element columns (or the primary key columns in the case of a one-to-many association), aliased by the given table alias

Specified by:
getElementColumnNames in interface QueryableCollection

getElementColumnNames

public String[] getElementColumnNames()
Description copied from interface: QueryableCollection
Get the names of the collection element columns (or the primary key columns in the case of a one-to-many association)

Specified by:
getElementColumnNames in interface QueryableCollection

getKeyColumnNames

public String[] getKeyColumnNames()
Description copied from interface: Joinable
The columns to join on

Specified by:
getKeyColumnNames in interface Joinable

hasIndex

public boolean hasIndex()
Description copied from interface: CollectionMetadata
Is this collection indexed?

Specified by:
hasIndex in interface CollectionMetadata

isLazy

public boolean isLazy()
Description copied from interface: CollectionMetadata
Is the collection lazily initialized?

Specified by:
isLazy in interface CollectionMetadata

isInverse

public boolean isInverse()
Description copied from interface: CollectionPersister
Is this collection "inverse", so state changes are not propogated to the database.

Specified by:
isInverse in interface CollectionPersister

getTableName

public String getTableName()
Description copied from interface: Joinable
The table to join to.

Specified by:
getTableName in interface Joinable

remove

public void remove(Serializable id,
                   SessionImplementor session)
            throws HibernateException
Description copied from interface: CollectionPersister
Completely remove the persistent state of the collection

Specified by:
remove in interface CollectionPersister
Throws:
HibernateException

recreate

public void recreate(PersistentCollection collection,
                     Serializable id,
                     SessionImplementor session)
              throws HibernateException
Description copied from interface: CollectionPersister
(Re)create the collection's persistent state

Specified by:
recreate in interface CollectionPersister
Throws:
HibernateException

isRowDeleteEnabled

protected boolean isRowDeleteEnabled()

deleteRows

public void deleteRows(PersistentCollection collection,
                       Serializable id,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: CollectionPersister
Delete the persistent state of any elements that were removed from the collection

Specified by:
deleteRows in interface CollectionPersister
Throws:
HibernateException

isRowInsertEnabled

protected boolean isRowInsertEnabled()

insertRows

public void insertRows(PersistentCollection collection,
                       Serializable id,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: CollectionPersister
Insert the persistent state of any new collection elements

Specified by:
insertRows in interface CollectionPersister
Throws:
HibernateException

getRole

public String getRole()
Description copied from interface: CollectionMetadata
The name of this collection role

Specified by:
getRole in interface CollectionMetadata

getOwnerEntityName

public String getOwnerEntityName()

getOwnerEntityPersister

public EntityPersister getOwnerEntityPersister()
Description copied from interface: CollectionPersister
Get the persister of the entity that "owns" this collection

Specified by:
getOwnerEntityPersister in interface CollectionPersister

getIdentifierGenerator

public IdentifierGenerator getIdentifierGenerator()
Description copied from interface: CollectionPersister
Get the surrogate key generation strategy (optional operation)

Specified by:
getIdentifierGenerator in interface CollectionPersister

getIdentifierType

public Type getIdentifierType()
Description copied from interface: CollectionPersister
Get the type of the surrogate key

Specified by:
getIdentifierType in interface CollectionPersister

hasOrphanDelete

public boolean hasOrphanDelete()
Description copied from interface: CollectionPersister
Does this collection implement "orphan delete"?

Specified by:
hasOrphanDelete in interface CollectionPersister

toType

public Type toType(String propertyName)
            throws QueryException
Description copied from interface: PropertyMapping
Given a component path expression, get the type of the property

Specified by:
toType in interface PropertyMapping
Throws:
QueryException

isManyToMany

public abstract boolean isManyToMany()
Description copied from interface: CollectionPersister
Is this a many-to-many association? Note that this is mainly a convenience feature as the single persister does not conatin all the information needed to handle a many-to-many itself, as internally it is looked at as two many-to-ones.

Specified by:
isManyToMany in interface CollectionPersister

getManyToManyFilterFragment

public String getManyToManyFilterFragment(String alias,
                                          Map enabledFilters)
Specified by:
getManyToManyFilterFragment in interface CollectionPersister

toColumns

public String[] toColumns(String alias,
                          String propertyName)
                   throws QueryException
Description copied from interface: PropertyMapping
Given a query alias and a property path, return the qualified column name

Specified by:
toColumns in interface PropertyMapping
Throws:
QueryException

toColumns

public String[] toColumns(String propertyName)
                   throws QueryException
Description copied from interface: PropertyMapping
Given a property path, return the corresponding column name(s).

Specified by:
toColumns in interface PropertyMapping
Throws:
QueryException

getType

public Type getType()
Description copied from interface: PropertyMapping
Get the type of the thing containing the properties

Specified by:
getType in interface PropertyMapping

getName

public String getName()
Description copied from interface: Joinable
An identifying name; a class name or collection role name.

Specified by:
getName in interface Joinable

getElementPersister

public EntityPersister getElementPersister()
Description copied from interface: QueryableCollection
Get the persister of the element class, if this is a collection of entities (optional operation). Note that for a one-to-many association, the returned persister must be OuterJoinLoadable.

Specified by:
getElementPersister in interface QueryableCollection

isCollection

public boolean isCollection()
Description copied from interface: Joinable
Is this instance actually a CollectionPersister?

Specified by:
isCollection in interface Joinable

getCollectionSpaces

public Serializable[] getCollectionSpaces()
Description copied from interface: CollectionPersister
Get the "space" that holds the persistent state

Specified by:
getCollectionSpaces in interface CollectionPersister

generateDeleteString

protected abstract String generateDeleteString()

generateDeleteRowString

protected abstract String generateDeleteRowString()

generateUpdateRowString

protected abstract String generateUpdateRowString()

generateInsertRowString

protected abstract String generateInsertRowString()

updateRows

public void updateRows(PersistentCollection collection,
                       Serializable id,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: CollectionPersister
Update the persistent state of any elements that were modified

Specified by:
updateRows in interface CollectionPersister
Throws:
HibernateException

doUpdateRows

protected abstract int doUpdateRows(Serializable key,
                                    PersistentCollection collection,
                                    SessionImplementor session)
                             throws HibernateException
Throws:
HibernateException

getCollectionMetadata

public CollectionMetadata getCollectionMetadata()
Specified by:
getCollectionMetadata in interface CollectionPersister

getFactory

public SessionFactoryImplementor getFactory()
Specified by:
getFactory in interface CollectionPersister

filterFragment

protected String filterFragment(String alias)
                         throws MappingException
Throws:
MappingException

filterFragment

public String filterFragment(String alias,
                             Map enabledFilters)
                      throws MappingException
Description copied from interface: Joinable
Get the where clause filter, given a query alias and considering enabled session filters

Specified by:
filterFragment in interface Joinable
Throws:
MappingException

oneToManyFilterFragment

public String oneToManyFilterFragment(String alias)
                               throws MappingException
Specified by:
oneToManyFilterFragment in interface Joinable
Throws:
MappingException

isInsertCallable

protected boolean isInsertCallable()

getInsertCheckStyle

protected ExecuteUpdateResultCheckStyle getInsertCheckStyle()

isUpdateCallable

protected boolean isUpdateCallable()

getUpdateCheckStyle

protected ExecuteUpdateResultCheckStyle getUpdateCheckStyle()

isDeleteCallable

protected boolean isDeleteCallable()

getDeleteCheckStyle

protected ExecuteUpdateResultCheckStyle getDeleteCheckStyle()

isDeleteAllCallable

protected boolean isDeleteAllCallable()

getDeleteAllCheckStyle

protected ExecuteUpdateResultCheckStyle getDeleteAllCheckStyle()

toString

public String toString()

isVersioned

public boolean isVersioned()
Description copied from interface: CollectionPersister
Does this collection cause version increment of the owning entity?

Specified by:
isVersioned in interface CollectionPersister

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface CollectionPersister

getElementNodeName

public String getElementNodeName()
Specified by:
getElementNodeName in interface CollectionPersister

getIndexNodeName

public String getIndexNodeName()
Specified by:
getIndexNodeName in interface CollectionPersister

getSQLExceptionConverter

protected SQLExceptionConverter getSQLExceptionConverter()

getCacheEntryStructure

public CacheEntryStructure getCacheEntryStructure()
Description copied from interface: CollectionPersister
Get the cache structure

Specified by:
getCacheEntryStructure in interface CollectionPersister

isAffectedByEnabledFilters

public boolean isAffectedByEnabledFilters(SessionImplementor session)
Specified by:
isAffectedByEnabledFilters in interface CollectionPersister

isSubselectLoadable

public boolean isSubselectLoadable()

isMutable

public boolean isMutable()
Description copied from interface: CollectionPersister
Can the elements of this collection change?

Specified by:
isMutable in interface CollectionPersister

getCollectionPropertyColumnAliases

public String[] getCollectionPropertyColumnAliases(String propertyName,
                                                   String suffix)
Specified by:
getCollectionPropertyColumnAliases in interface SQLLoadableCollection

initCollectionPropertyMap

public void initCollectionPropertyMap()

getSize

public int getSize(Serializable key,
                   SessionImplementor session)
Specified by:
getSize in interface CollectionPersister

indexExists

public boolean indexExists(Serializable key,
                           Object index,
                           SessionImplementor session)
Specified by:
indexExists in interface CollectionPersister

elementExists

public boolean elementExists(Serializable key,
                             Object element,
                             SessionImplementor session)
Specified by:
elementExists in interface CollectionPersister

getElementByIndex

public Object getElementByIndex(Serializable key,
                                Object index,
                                SessionImplementor session,
                                Object owner)
Specified by:
getElementByIndex in interface CollectionPersister

isExtraLazy

public boolean isExtraLazy()
Specified by:
isExtraLazy in interface CollectionPersister

getDialect

protected Dialect getDialect()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BasicCollectionPersister (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.collection
Class BasicCollectionPersister

java.lang.Object
    extended by org.hibernate.persister.collection.AbstractCollectionPersister
        extended by org.hibernate.persister.collection.BasicCollectionPersister
All Implemented Interfaces:
CollectionMetadata, CollectionPersister, Joinable, PropertyMapping, QueryableCollection, SQLLoadableCollection
public class BasicCollectionPersister
extends AbstractCollectionPersister

Collection persister for collections of values and many-to-many associations.

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.persister.collection.AbstractCollectionPersister
batchSize, elementColumnAliases, elementColumnIsInPrimaryKey, elementColumnIsSettable, elementColumnNames, elementFormulas, elementFormulaTemplates, elementIsPureFormula, elementType, hasIdentifier, hasIndex, hasWhere, identifierColumnName, indexColumnAliases, indexColumnIsSettable, indexColumnNames, indexContainsFormula, indexFormulas, indexFormulaTemplates, keyColumnAliases, keyColumnNames, qualifiedTableName, sqlWhereString
Constructor Summary
BasicCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
Method Summary
boolean | consumesCollectionAlias() Very, very, very ugly...
boolean | consumesEntityAlias() Very, very, very ugly...
protected CollectionInitializer | createCollectionInitializer(Map enabledFilters) Create the CollectionLoader
protected CollectionInitializer | createSubselectInitializer(SubselectFetch subselect, SessionImplementor session)
protected int | doUpdateRows(Serializable id, PersistentCollection collection, SessionImplementor session)
String | fromJoinFragment(String alias, boolean innerJoin, boolean includeSubclasses) Get the from clause part of any joins (optional operation)
protected String | generateDeleteRowString() Generate the SQL DELETE that deletes a particular row
protected String | generateDeleteString() Generate the SQL DELETE that deletes all rows
protected String | generateInsertRowString() Generate the SQL INSERT that creates a new row
protected String | generateUpdateRowString() Generate the SQL UPDATE that updates a row
boolean | isCascadeDeleteEnabled() Is cascade delete handled by the database-level foreign key constraint definition?
boolean | isManyToMany() Is this a many-to-many association? Note that this is mainly a convenience feature as the single persister does not conatin all the information needed to handle a many-to-many itself, as internally it is looked at as two many-to-ones.
boolean | isOneToMany() Is this a one-to-many association?
String | selectFragment(Joinable rhs, String rhsAlias, String lhsAlias, String entitySuffix, String collectionSuffix, boolean includeCollectionColumns) All columns to select, when loading.
String | whereJoinFragment(String alias, boolean innerJoin, boolean includeSubclasses) Get the where clause part of any joins (optional operation)
Methods inherited from class org.hibernate.persister.collection.AbstractCollectionPersister
appendElementColumns, appendIdentifierColumns, appendIndexColumns, decrementIndexByBase, deleteRows, elementExists, filterFragment, filterFragment, generateDetectRowByElementString, generateDetectRowByIndexString, generateSelectFragment, generateSelectRowByIndexString, generateSelectSizeString, getAppropriateInitializer, getCache, getCacheEntryStructure, getCollectionMetadata, getCollectionPropertyColumnAliases, getCollectionSpaces, getCollectionType, getDeleteAllCheckStyle, getDeleteCheckStyle, getDialect, getElementByIndex, getElementClass, getElementColumnAliases, getElementColumnNames, getElementColumnNames, getElementNodeName, getElementPersister, getElementType, getFactory, getFetchMode, getIdentifierColumnAlias, getIdentifierColumnName, getIdentifierGenerator, getIdentifierType, getIndexColumnAliases, getIndexColumnNames, getIndexColumnNames, getIndexFormulas, getIndexNodeName, getIndexType, getInsertCheckStyle, getKeyColumnAliases, getKeyColumnNames, getKeyType, getManyToManyFilterFragment, getManyToManyOrderByString, getName, getNodeName, getOwnerEntityName, getOwnerEntityPersister, getRole, getSize, getSQLDeleteRowString, getSQLDeleteString, getSQLExceptionConverter, getSQLInsertRowString, getSQLOrderByString, getSQLUpdateRowString, getSQLWhereString, getTableName, getType, getUpdateCheckStyle, hasCache, hasIndex, hasManyToManyOrdering, hasOrdering, hasOrphanDelete, hasWhere, incrementIndexByBase, indexExists, initCollectionPropertyMap, initialize, insertRows, isAffectedByEnabledFilters, isArray, isCollection, isDeleteAllCallable, isDeleteCallable, isExtraLazy, isInsertCallable, isInverse, isLazy, isMutable, isPrimitiveArray, isRowDeleteEnabled, isRowInsertEnabled, isSubselectLoadable, isUpdateCallable, isVersioned, logStaticSQL, oneToManyFilterFragment, postInstantiate, readElement, readIdentifier, readIndex, readKey, recreate, remove, selectFragment, toColumns, toColumns, toString, toType, updateRows, writeElement, writeElementToWhere, writeIdentifier, writeIndex, writeIndexToWhere, writeKey
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

BasicCollectionPersister

public BasicCollectionPersister(Collection collection,
                                CacheConcurrencyStrategy cache,
                                Configuration cfg,
                                SessionFactoryImplementor factory)
                         throws MappingException,
                                CacheException
Method Detail

isCascadeDeleteEnabled

public boolean isCascadeDeleteEnabled()
Description copied from interface: CollectionPersister
Is cascade delete handled by the database-level foreign key constraint definition?

generateDeleteString

protected String generateDeleteString()
Generate the SQL DELETE that deletes all rows

Specified by:
generateDeleteString in class AbstractCollectionPersister

generateInsertRowString

protected String generateInsertRowString()
Generate the SQL INSERT that creates a new row

Specified by:
generateInsertRowString in class AbstractCollectionPersister

generateUpdateRowString

protected String generateUpdateRowString()
Generate the SQL UPDATE that updates a row

Specified by:
generateUpdateRowString in class AbstractCollectionPersister

generateDeleteRowString

protected String generateDeleteRowString()
Generate the SQL DELETE that deletes a particular row

Specified by:
generateDeleteRowString in class AbstractCollectionPersister

consumesEntityAlias

public boolean consumesEntityAlias()
Description copied from interface: Joinable
Very, very, very ugly...

Returns:
Does this persister "consume" entity column aliases in the result set?

consumesCollectionAlias

public boolean consumesCollectionAlias()
Description copied from interface: Joinable
Very, very, very ugly...

Returns:
Does this persister "consume" collection column aliases in the result set?

isOneToMany

public boolean isOneToMany()
Description copied from interface: CollectionPersister
Is this a one-to-many association?

isManyToMany

public boolean isManyToMany()
Description copied from interface: CollectionPersister
Is this a many-to-many association? Note that this is mainly a convenience feature as the single persister does not conatin all the information needed to handle a many-to-many itself, as internally it is looked at as two many-to-ones.

Specified by:
isManyToMany in interface CollectionPersister
Specified by:
isManyToMany in class AbstractCollectionPersister

doUpdateRows

protected int doUpdateRows(Serializable id,
                           PersistentCollection collection,
                           SessionImplementor session)
                    throws HibernateException
Specified by:
doUpdateRows in class AbstractCollectionPersister
Throws:
HibernateException

selectFragment

public String selectFragment(Joinable rhs,
                             String rhsAlias,
                             String lhsAlias,
                             String entitySuffix,
                             String collectionSuffix,
                             boolean includeCollectionColumns)
Description copied from interface: Joinable
All columns to select, when loading.

createCollectionInitializer

protected CollectionInitializer createCollectionInitializer(Map enabledFilters)
                                                     throws MappingException
Create the CollectionLoader

Specified by:
createCollectionInitializer in class AbstractCollectionPersister
Throws:
MappingException
See Also:
BasicCollectionLoader

fromJoinFragment

public String fromJoinFragment(String alias,
                               boolean innerJoin,
                               boolean includeSubclasses)
Description copied from interface: Joinable
Get the from clause part of any joins (optional operation)

whereJoinFragment

public String whereJoinFragment(String alias,
                                boolean innerJoin,
                                boolean includeSubclasses)
Description copied from interface: Joinable
Get the where clause part of any joins (optional operation)

createSubselectInitializer

protected CollectionInitializer createSubselectInitializer(SubselectFetch subselect,
                                                           SessionImplementor session)
Specified by:
createSubselectInitializer in class AbstractCollectionPersister
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionPropertyMapping (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.collection
Class CollectionPropertyMapping

java.lang.Object
    extended by org.hibernate.persister.collection.CollectionPropertyMapping
All Implemented Interfaces:
PropertyMapping
public class CollectionPropertyMapping
extends Object
implements PropertyMapping

Author:
Gavin King

Constructor Summary
CollectionPropertyMapping(QueryableCollection memberPersister)
Method Summary
Type | getType() Get the type of the thing containing the properties
String[] | toColumns(String propertyName) Given a property path, return the corresponding column name(s).
String[] | toColumns(String alias, String propertyName) Given a query alias and a property path, return the qualified column name
Type | toType(String propertyName) Given a component path expression, get the type of the property
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CollectionPropertyMapping

public CollectionPropertyMapping(QueryableCollection memberPersister)
Method Detail

toType

public Type toType(String propertyName)
            throws QueryException
Description copied from interface: PropertyMapping
Given a component path expression, get the type of the property

Specified by:
toType in interface PropertyMapping
Throws:
QueryException

toColumns

public String[] toColumns(String alias,
                          String propertyName)
                   throws QueryException
Description copied from interface: PropertyMapping
Given a query alias and a property path, return the qualified column name

Specified by:
toColumns in interface PropertyMapping
Throws:
QueryException

toColumns

public String[] toColumns(String propertyName)
                   throws QueryException,
                          UnsupportedOperationException
Given a property path, return the corresponding column name(s).

Specified by:
toColumns in interface PropertyMapping
Throws:
QueryException
UnsupportedOperationException

getType

public Type getType()
Description copied from interface: PropertyMapping
Get the type of the thing containing the properties

Specified by:
getType in interface PropertyMapping
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionPropertyNames (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.collection
Class CollectionPropertyNames

java.lang.Object
    extended by org.hibernate.persister.collection.CollectionPropertyNames
public class CollectionPropertyNames
extends Object

The names of all the collection properties.

Author:
josh Dec 23, 2004 7:35:02 AM

Field Summary
static String | COLLECTION_ELEMENTS
static String | COLLECTION_INDEX
static String | COLLECTION_INDICES
static String | COLLECTION_MAX_ELEMENT
static String | COLLECTION_MAX_INDEX
static String | COLLECTION_MIN_ELEMENT
static String | COLLECTION_MIN_INDEX
static String | COLLECTION_SIZE
Constructor Summary
CollectionPropertyNames()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COLLECTION_SIZE

public static final String COLLECTION_SIZE
See Also:
Constant Field Values

COLLECTION_ELEMENTS

public static final String COLLECTION_ELEMENTS
See Also:
Constant Field Values

COLLECTION_INDICES

public static final String COLLECTION_INDICES
See Also:
Constant Field Values

COLLECTION_MAX_INDEX

public static final String COLLECTION_MAX_INDEX
See Also:
Constant Field Values

COLLECTION_MIN_INDEX

public static final String COLLECTION_MIN_INDEX
See Also:
Constant Field Values

COLLECTION_MAX_ELEMENT

public static final String COLLECTION_MAX_ELEMENT
See Also:
Constant Field Values

COLLECTION_MIN_ELEMENT

public static final String COLLECTION_MIN_ELEMENT
See Also:
Constant Field Values

COLLECTION_INDEX

public static final String COLLECTION_INDEX
See Also:
Constant Field Values
Constructor Detail

CollectionPropertyNames

public CollectionPropertyNames()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompositeElementPropertyMapping (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.collection
Class CompositeElementPropertyMapping

java.lang.Object
    extended by org.hibernate.persister.entity.AbstractPropertyMapping
        extended by org.hibernate.persister.collection.CompositeElementPropertyMapping
All Implemented Interfaces:
PropertyMapping
public class CompositeElementPropertyMapping
extends AbstractPropertyMapping

Author:
Gavin King

Constructor Summary
CompositeElementPropertyMapping(String[] elementColumns, String[] elementFormulaTemplates, AbstractComponentType compositeType, Mapping factory)
Method Summary
protected String | getEntityName()
Type | getType() Get the type of the thing containing the properties
Methods inherited from class org.hibernate.persister.entity.AbstractPropertyMapping
addPropertyPath, getColumnNames, getIdentifierColumnNames, initComponentPropertyPaths, initIdentifierPropertyPaths, initPropertyPaths, throwPropertyException, toColumns, toColumns, toType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CompositeElementPropertyMapping

public CompositeElementPropertyMapping(String[] elementColumns,
                                       String[] elementFormulaTemplates,
                                       AbstractComponentType compositeType,
                                       Mapping factory)
                                throws MappingException
Method Detail

getType

public Type getType()
Description copied from interface: PropertyMapping
Get the type of the thing containing the properties

getEntityName

protected String getEntityName()
Specified by:
getEntityName in class AbstractPropertyMapping
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ElementPropertyMapping (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.collection
Class ElementPropertyMapping

java.lang.Object
    extended by org.hibernate.persister.collection.ElementPropertyMapping
All Implemented Interfaces:
PropertyMapping
public class ElementPropertyMapping
extends Object
implements PropertyMapping

Author:
Gavin King

Constructor Summary
ElementPropertyMapping(String[] elementColumns, Type type)
Method Summary
Type | getType() Get the type of the thing containing the properties
String[] | toColumns(String propertyName) Given a property path, return the corresponding column name(s).
String[] | toColumns(String alias, String propertyName) Given a query alias and a property path, return the qualified column name
Type | toType(String propertyName) Given a component path expression, get the type of the property
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ElementPropertyMapping

public ElementPropertyMapping(String[] elementColumns,
                              Type type)
                       throws MappingException
Method Detail

toType

public Type toType(String propertyName)
            throws QueryException
Description copied from interface: PropertyMapping
Given a component path expression, get the type of the property

Specified by:
toType in interface PropertyMapping
Throws:
QueryException

toColumns

public String[] toColumns(String alias,
                          String propertyName)
                   throws QueryException
Description copied from interface: PropertyMapping
Given a query alias and a property path, return the qualified column name

Specified by:
toColumns in interface PropertyMapping
Throws:
QueryException

toColumns

public String[] toColumns(String propertyName)
                   throws QueryException,
                          UnsupportedOperationException
Given a property path, return the corresponding column name(s).

Specified by:
toColumns in interface PropertyMapping
Throws:
QueryException
UnsupportedOperationException

getType

public Type getType()
Description copied from interface: PropertyMapping
Get the type of the thing containing the properties

Specified by:
getType in interface PropertyMapping
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamedQueryCollectionInitializer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.collection
Class NamedQueryCollectionInitializer

java.lang.Object
    extended by org.hibernate.persister.collection.NamedQueryCollectionInitializer
All Implemented Interfaces:
CollectionInitializer
public final class NamedQueryCollectionInitializer
extends Object
implements CollectionInitializer

A wrapper around a named query.

Author:
Gavin King

Constructor Summary
NamedQueryCollectionInitializer(String queryName, CollectionPersister persister)
Method Summary
 void initialize(Serializable key, SessionImplementor session)
Initialize the given collection
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NamedQueryCollectionInitializer

public NamedQueryCollectionInitializer(String queryName,
                                       CollectionPersister persister)
Method Detail

initialize

public void initialize(Serializable key,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: CollectionInitializer
Initialize the given collection

Specified by:
initialize in interface CollectionInitializer
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OneToManyPersister (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.collection
Class OneToManyPersister

java.lang.Object
    extended by org.hibernate.persister.collection.AbstractCollectionPersister
        extended by org.hibernate.persister.collection.OneToManyPersister
All Implemented Interfaces:
CollectionMetadata, CollectionPersister, Joinable, PropertyMapping, QueryableCollection, SQLLoadableCollection
public class OneToManyPersister
extends AbstractCollectionPersister

Collection persister for one-to-many associations.

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.persister.collection.AbstractCollectionPersister
batchSize, elementColumnAliases, elementColumnIsInPrimaryKey, elementColumnIsSettable, elementColumnNames, elementFormulas, elementFormulaTemplates, elementIsPureFormula, elementType, hasIdentifier, hasIndex, hasWhere, identifierColumnName, indexColumnAliases, indexColumnIsSettable, indexColumnNames, indexContainsFormula, indexFormulas, indexFormulaTemplates, keyColumnAliases, keyColumnNames, qualifiedTableName, sqlWhereString
Constructor Summary
OneToManyPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
Method Summary
boolean | consumesCollectionAlias() Very, very, very ugly...
boolean | consumesEntityAlias() Very, very, very ugly...
protected CollectionInitializer | createCollectionInitializer(Map enabledFilters) Create the OneToManyLoader
protected CollectionInitializer | createSubselectInitializer(SubselectFetch subselect, SessionImplementor session)
protected int | doUpdateRows(Serializable id, PersistentCollection collection, SessionImplementor session)
String | filterFragment(String alias)
String | fromJoinFragment(String alias, boolean innerJoin, boolean includeSubclasses) Get the from clause part of any joins (optional operation)
protected String | generateDeleteRowString() Generate the SQL UPDATE that updates a particular row's foreign key to null
protected String | generateDeleteString() Generate the SQL UPDATE that updates all the foreign keys to null
protected String | generateInsertRowString() Generate the SQL UPDATE that updates a foreign key to a value
protected String | generateUpdateRowString() Not needed for one-to-many association
Object | getElementByIndex(Serializable key, Object index, SessionImplementor session, Object owner)
String | getTableName() The table to join to.
boolean | isCascadeDeleteEnabled() Is cascade delete handled by the database-level foreign key constraint definition?
boolean | isManyToMany() Is this a many-to-many association? Note that this is mainly a convenience feature as the single persister does not conatin all the information needed to handle a many-to-many itself, as internally it is looked at as two many-to-ones.
boolean | isOneToMany() Is this a one-to-many association?
protected boolean | isRowDeleteEnabled()
protected boolean | isRowInsertEnabled()
String | selectFragment(Joinable rhs, String rhsAlias, String lhsAlias, String entitySuffix, String collectionSuffix, boolean includeCollectionColumns) All columns to select, when loading.
String | whereJoinFragment(String alias, boolean innerJoin, boolean includeSubclasses) Get the where clause part of any joins (optional operation)
Methods inherited from class org.hibernate.persister.collection.AbstractCollectionPersister
appendElementColumns, appendIdentifierColumns, appendIndexColumns, decrementIndexByBase, deleteRows, elementExists, filterFragment, generateDetectRowByElementString, generateDetectRowByIndexString, generateSelectFragment, generateSelectRowByIndexString, generateSelectSizeString, getAppropriateInitializer, getCache, getCacheEntryStructure, getCollectionMetadata, getCollectionPropertyColumnAliases, getCollectionSpaces, getCollectionType, getDeleteAllCheckStyle, getDeleteCheckStyle, getDialect, getElementClass, getElementColumnAliases, getElementColumnNames, getElementColumnNames, getElementNodeName, getElementPersister, getElementType, getFactory, getFetchMode, getIdentifierColumnAlias, getIdentifierColumnName, getIdentifierGenerator, getIdentifierType, getIndexColumnAliases, getIndexColumnNames, getIndexColumnNames, getIndexFormulas, getIndexNodeName, getIndexType, getInsertCheckStyle, getKeyColumnAliases, getKeyColumnNames, getKeyType, getManyToManyFilterFragment, getManyToManyOrderByString, getName, getNodeName, getOwnerEntityName, getOwnerEntityPersister, getRole, getSize, getSQLDeleteRowString, getSQLDeleteString, getSQLExceptionConverter, getSQLInsertRowString, getSQLOrderByString, getSQLUpdateRowString, getSQLWhereString, getType, getUpdateCheckStyle, hasCache, hasIndex, hasManyToManyOrdering, hasOrdering, hasOrphanDelete, hasWhere, incrementIndexByBase, indexExists, initCollectionPropertyMap, initialize, insertRows, isAffectedByEnabledFilters, isArray, isCollection, isDeleteAllCallable, isDeleteCallable, isExtraLazy, isInsertCallable, isInverse, isLazy, isMutable, isPrimitiveArray, isSubselectLoadable, isUpdateCallable, isVersioned, logStaticSQL, oneToManyFilterFragment, postInstantiate, readElement, readIdentifier, readIndex, readKey, recreate, remove, selectFragment, toColumns, toColumns, toString, toType, updateRows, writeElement, writeElementToWhere, writeIdentifier, writeIndex, writeIndexToWhere, writeKey
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

OneToManyPersister

public OneToManyPersister(Collection collection,
                          CacheConcurrencyStrategy cache,
                          Configuration cfg,
                          SessionFactoryImplementor factory)
                   throws MappingException,
                          CacheException
Method Detail

isRowDeleteEnabled

protected boolean isRowDeleteEnabled()
Overrides:
isRowDeleteEnabled in class AbstractCollectionPersister

isRowInsertEnabled

protected boolean isRowInsertEnabled()
Overrides:
isRowInsertEnabled in class AbstractCollectionPersister

isCascadeDeleteEnabled

public boolean isCascadeDeleteEnabled()
Description copied from interface: CollectionPersister
Is cascade delete handled by the database-level foreign key constraint definition?

generateDeleteString

protected String generateDeleteString()
Generate the SQL UPDATE that updates all the foreign keys to null

Specified by:
generateDeleteString in class AbstractCollectionPersister

generateInsertRowString

protected String generateInsertRowString()
Generate the SQL UPDATE that updates a foreign key to a value

Specified by:
generateInsertRowString in class AbstractCollectionPersister

generateUpdateRowString

protected String generateUpdateRowString()
Not needed for one-to-many association

Specified by:
generateUpdateRowString in class AbstractCollectionPersister

generateDeleteRowString

protected String generateDeleteRowString()
Generate the SQL UPDATE that updates a particular row's foreign key to null

Specified by:
generateDeleteRowString in class AbstractCollectionPersister

consumesEntityAlias

public boolean consumesEntityAlias()
Description copied from interface: Joinable
Very, very, very ugly...

Returns:
Does this persister "consume" entity column aliases in the result set?

consumesCollectionAlias

public boolean consumesCollectionAlias()
Description copied from interface: Joinable
Very, very, very ugly...

Returns:
Does this persister "consume" collection column aliases in the result set?

isOneToMany

public boolean isOneToMany()
Description copied from interface: CollectionPersister
Is this a one-to-many association?

isManyToMany

public boolean isManyToMany()
Description copied from interface: CollectionPersister
Is this a many-to-many association? Note that this is mainly a convenience feature as the single persister does not conatin all the information needed to handle a many-to-many itself, as internally it is looked at as two many-to-ones.

Specified by:
isManyToMany in interface CollectionPersister
Specified by:
isManyToMany in class AbstractCollectionPersister

doUpdateRows

protected int doUpdateRows(Serializable id,
                           PersistentCollection collection,
                           SessionImplementor session)
                    throws HibernateException
Specified by:
doUpdateRows in class AbstractCollectionPersister
Throws:
HibernateException

selectFragment

public String selectFragment(Joinable rhs,
                             String rhsAlias,
                             String lhsAlias,
                             String entitySuffix,
                             String collectionSuffix,
                             boolean includeCollectionColumns)
Description copied from interface: Joinable
All columns to select, when loading.

createCollectionInitializer

protected CollectionInitializer createCollectionInitializer(Map enabledFilters)
                                                     throws MappingException
Create the OneToManyLoader

Specified by:
createCollectionInitializer in class AbstractCollectionPersister
Throws:
MappingException
See Also:
OneToManyLoader

fromJoinFragment

public String fromJoinFragment(String alias,
                               boolean innerJoin,
                               boolean includeSubclasses)
Description copied from interface: Joinable
Get the from clause part of any joins (optional operation)

whereJoinFragment

public String whereJoinFragment(String alias,
                                boolean innerJoin,
                                boolean includeSubclasses)
Description copied from interface: Joinable
Get the where clause part of any joins (optional operation)

getTableName

public String getTableName()
Description copied from interface: Joinable
The table to join to.

Specified by:
getTableName in interface Joinable
Overrides:
getTableName in class AbstractCollectionPersister

filterFragment

public String filterFragment(String alias)
                      throws MappingException
Overrides:
filterFragment in class AbstractCollectionPersister
Throws:
MappingException

createSubselectInitializer

protected CollectionInitializer createSubselectInitializer(SubselectFetch subselect,
                                                           SessionImplementor session)
Specified by:
createSubselectInitializer in class AbstractCollectionPersister

getElementByIndex

public Object getElementByIndex(Serializable key,
                                Object index,
                                SessionImplementor session,
                                Object owner)
Specified by:
getElementByIndex in interface CollectionPersister
Overrides:
getElementByIndex in class AbstractCollectionPersister
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.persister.entity (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.persister.entity

This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

See:
Description

Interface Summary
EntityPersister | Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.
Joinable | Anything that can be loaded by outer join - namely persisters for classes or collections.
Loadable | Implemented by a EntityPersister that may be loaded using Loader.
Lockable | Contract for things that can be locked via a LockingStrategy
OuterJoinLoadable | A EntityPersister that may be loaded by outer join using the OuterJoinLoader hierarchy and may be an element of a one-to-many association.
PropertyMapping | Abstraction of all mappings that define properties: entities, collection elements.
Queryable | Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language
SQLLoadable | A class persister that supports queries expressed in the platform native SQL dialect
UniqueKeyLoadable |

Class Summary
AbstractEntityPersister | Basic functionality for persisting an entity via JDBC through either generated or custom SQL
AbstractPropertyMapping | Base implementation of a PropertyMapping
BasicEntityPropertyMapping |
JoinedSubclassEntityPersister | An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
NamedQueryLoader | Not really a Loader, just a wrapper around a named query.
SingleTableEntityPersister | The default implementation of the EntityPersister interface.
UnionSubclassEntityPersister | Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Package org.hibernate.persister.entity Description

This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Strategies for persisting entities implement the EntityPersister interface. Optionally, they may implement certain additional interfaces that define contracts with various loaders. Concrete implementations in this package define the built-in inheritance mapping strategies.


org.hibernate.persister.entity Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.persister.entity

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.persister.entity.AbstractEntityPersister (implements org.hibernate.metadata.ClassMetadata, org.hibernate.intercept.LazyPropertyInitializer, org.hibernate.persister.entity.Lockable, org.hibernate.persister.entity.OuterJoinLoadable, org.hibernate.id.PostInsertIdentityPersister, org.hibernate.persister.entity.Queryable, org.hibernate.persister.entity.SQLLoadable, org.hibernate.persister.entity.UniqueKeyLoadable)
      • class org.hibernate.persister.entity.JoinedSubclassEntityPersister
      • class org.hibernate.persister.entity.SingleTableEntityPersister
      • class org.hibernate.persister.entity.UnionSubclassEntityPersister
    • class org.hibernate.persister.entity.AbstractPropertyMapping (implements org.hibernate.persister.entity.PropertyMapping)
      • class org.hibernate.persister.entity.BasicEntityPropertyMapping
    • class org.hibernate.persister.entity.NamedQueryLoader (implements org.hibernate.loader.entity.UniqueEntityLoader)

Interface Hierarchy

  • interface org.hibernate.persister.entity.Joinable
    • interface org.hibernate.persister.entity.OuterJoinLoadable (also extends org.hibernate.persister.entity.Loadable)
    • interface org.hibernate.persister.entity.Queryable (also extends org.hibernate.persister.entity.Loadable, org.hibernate.persister.entity.PropertyMapping)
  • interface org.hibernate.cache.OptimisticCacheSource
    • interface org.hibernate.persister.entity.EntityPersister
      • interface org.hibernate.persister.entity.Loadable
        • interface org.hibernate.persister.entity.OuterJoinLoadable (also extends org.hibernate.persister.entity.Joinable)
        • interface org.hibernate.persister.entity.Queryable (also extends org.hibernate.persister.entity.Joinable, org.hibernate.persister.entity.PropertyMapping)
        • interface org.hibernate.persister.entity.SQLLoadable
        • interface org.hibernate.persister.entity.UniqueKeyLoadable
      • interface org.hibernate.persister.entity.Lockable
  • interface org.hibernate.persister.entity.PropertyMapping
    • interface org.hibernate.persister.entity.Queryable (also extends org.hibernate.persister.entity.Joinable, org.hibernate.persister.entity.Loadable)


Uses of Package org.hibernate.persister.entity (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.persister.entity

Packages that use org.hibernate.persister.entity
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.lock |
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.hql.ast.exec |
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.pretty | Classes for pretty printing things for exception and log messages.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Classes in org.hibernate.persister.entity used by org.hibernate.action
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.
Queryable
Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language

Classes in org.hibernate.persister.entity used by org.hibernate.cache.entry
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.

Classes in org.hibernate.persister.entity used by org.hibernate.dialect
Lockable
Contract for things that can be locked via a LockingStrategy

Classes in org.hibernate.persister.entity used by org.hibernate.dialect.lock
Lockable
Contract for things that can be locked via a LockingStrategy

Classes in org.hibernate.persister.entity used by org.hibernate.engine
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.
Joinable
Anything that can be loaded by outer join - namely persisters for classes or collections.
Loadable
Implemented by a EntityPersister that may be loaded using Loader.
OuterJoinLoadable
A EntityPersister that may be loaded by outer join using the OuterJoinLoader hierarchy and may be an element of a one-to-many association.

Classes in org.hibernate.persister.entity used by org.hibernate.event
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.

Classes in org.hibernate.persister.entity used by org.hibernate.event.def
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.

Classes in org.hibernate.persister.entity used by org.hibernate.hql.ast.exec
Queryable
Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language

Classes in org.hibernate.persister.entity used by org.hibernate.hql.ast.tree
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.
PropertyMapping
Abstraction of all mappings that define properties: entities, collection elements.
Queryable
Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language

Classes in org.hibernate.persister.entity used by org.hibernate.hql.ast.util
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.
Queryable
Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language

Classes in org.hibernate.persister.entity used by org.hibernate.hql.classic
Loadable
Implemented by a EntityPersister that may be loaded using Loader.

Classes in org.hibernate.persister.entity used by org.hibernate.id
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.

Classes in org.hibernate.persister.entity used by org.hibernate.impl
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.

Classes in org.hibernate.persister.entity used by org.hibernate.loader
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.
Joinable
Anything that can be loaded by outer join - namely persisters for classes or collections.
Loadable
Implemented by a EntityPersister that may be loaded using Loader.
OuterJoinLoadable
A EntityPersister that may be loaded by outer join using the OuterJoinLoader hierarchy and may be an element of a one-to-many association.

Classes in org.hibernate.persister.entity used by org.hibernate.loader.criteria
Joinable
Anything that can be loaded by outer join - namely persisters for classes or collections.
OuterJoinLoadable
A EntityPersister that may be loaded by outer join using the OuterJoinLoader hierarchy and may be an element of a one-to-many association.

Classes in org.hibernate.persister.entity used by org.hibernate.loader.custom
Loadable
Implemented by a EntityPersister that may be loaded using Loader.

Classes in org.hibernate.persister.entity used by org.hibernate.loader.entity
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.
OuterJoinLoadable
A EntityPersister that may be loaded by outer join using the OuterJoinLoader hierarchy and may be an element of a one-to-many association.

Classes in org.hibernate.persister.entity used by org.hibernate.loader.hql
Loadable
Implemented by a EntityPersister that may be loaded using Loader.

Classes in org.hibernate.persister.entity used by org.hibernate.persister
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.

Classes in org.hibernate.persister.entity used by org.hibernate.persister.collection
AbstractPropertyMapping
Base implementation of a PropertyMapping
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.
Joinable
Anything that can be loaded by outer join - namely persisters for classes or collections.
PropertyMapping
Abstraction of all mappings that define properties: entities, collection elements.

Classes in org.hibernate.persister.entity used by org.hibernate.persister.entity
AbstractEntityPersister
Basic functionality for persisting an entity via JDBC through either generated or custom SQL
AbstractPropertyMapping
Base implementation of a PropertyMapping
BasicEntityPropertyMapping
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.
Joinable
Anything that can be loaded by outer join - namely persisters for classes or collections.
Loadable
Implemented by a EntityPersister that may be loaded using Loader.
Lockable
Contract for things that can be locked via a LockingStrategy
OuterJoinLoadable
A EntityPersister that may be loaded by outer join using the OuterJoinLoader hierarchy and may be an element of a one-to-many association.
PropertyMapping
Abstraction of all mappings that define properties: entities, collection elements.
Queryable
Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language
SQLLoadable
A class persister that supports queries expressed in the platform native SQL dialect
UniqueKeyLoadable

Classes in org.hibernate.persister.entity used by org.hibernate.pretty
EntityPersister
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.

Classes in org.hibernate.persister.entity used by org.hibernate.type
Joinable
Anything that can be loaded by outer join - namely persisters for classes or collections.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


EntityPersister (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Interface EntityPersister

All Superinterfaces:
OptimisticCacheSource
All Known Subinterfaces:
Loadable, Lockable, OuterJoinLoadable, PostInsertIdentityPersister, Queryable, SQLLoadable, UniqueKeyLoadable
All Known Implementing Classes:
AbstractEntityPersister
public interface EntityPersister
extends OptimisticCacheSource

Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.

Implementors must be threadsafe (preferrably immutable) and must provide a constructor of type (org.hibernate.map.PersistentClass, org.hibernate.impl.SessionFactoryImplementor).

Author:
Gavin King

Field Summary
static String ENTITY_ID
The property name of the "special" identifier property in HQL
Method Summary
void | afterInitialize(Object entity, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Called just after the entities properties have been initialized
void | afterReassociate(Object entity, SessionImplementor session) Called just after the entity has been reassociated with the session
boolean | canExtractIdOutOfEntity() Do detached instances of this class carry their own identifier value?
Object | createProxy(Serializable id, SessionImplementor session) Create a new proxy instance
void | delete(Serializable id, Object version, Object object, SessionImplementor session) Delete a persistent instance
int[] | findDirty(Object[] x, Object[] y, Object owner, SessionImplementor session) Compare two snapshots of the state of an instance to determine if the persistent state was modified
int[] | findModified(Object[] old, Object[] current, Object object, SessionImplementor session) Compare the state of an instance to the current database state
Object | forceVersionIncrement(Serializable id, Object currentVersion, SessionImplementor session)
CacheConcurrencyStrategy | getCache() Get the cache (optional operation)
CacheEntryStructure | getCacheEntryStructure() Get the cache structure
ClassMetadata | getClassMetadata() Get the user-visible metadata for the class (optional operation)
Class | getConcreteProxyClass(EntityMode entityMode) Get the proxy interface that instances of this concrete class will be cast to (optional operation).
Object | getCurrentVersion(Serializable id, SessionImplementor session) Get the current version of the object, or return null if there is no row for the given identifier.
Object[] | getDatabaseSnapshot(Serializable id, SessionImplementor session) Get the current database state of the object, in a "hydrated" form, without resolving identifiers
String | getEntityName() The classname of the persistent class (used only for messages)
SessionFactoryImplementor | getFactory() Return the SessionFactory to which this persister "belongs".
Serializable | getIdentifier(Object object, EntityMode entityMode) Get the identifier of an instance (throw an exception if no identifier property)
IdentifierGenerator | getIdentifierGenerator() Return the IdentifierGenerator for the class
String | getIdentifierPropertyName() Get the name of the identifier property (or return null) - need not return the name of an actual Java property
Type | getIdentifierType() Get the identifier type
Class | getMappedClass(EntityMode entityMode) The persistent class, or null
int[] | getNaturalIdentifierProperties() Which properties hold the natural id?
Object[] | getNaturalIdentifierSnapshot(Serializable id, SessionImplementor session) Retrieve the current state of the natural-id properties from the database.
CascadeStyle[] | getPropertyCascadeStyles() Get the cascade styles of the propertes (optional operation)
boolean[] | getPropertyCheckability() Get the "checkability" of the properties of this class (is the property dirty checked, does the cache need to be updated)
boolean[] | getPropertyInsertability() Get the "insertability" of the properties of this class (does the property appear in an SQL INSERT)
boolean[] | getPropertyInsertGeneration() Which of the properties of this class are database generated values on insert?
boolean[] | getPropertyLaziness()
String[] | getPropertyNames() Get the names of the class properties - doesn't have to be the names of the actual Java properties (used for XML generation only)
boolean[] | getPropertyNullability() Get the nullability of the properties of this class
Serializable[] | getPropertySpaces() Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class only.
Type | getPropertyType(String propertyName) Get the type of a particular property
Type[] | getPropertyTypes() Get the Hibernate types of the class properties
boolean[] | getPropertyUpdateability() Get the "updateability" of the properties of this class (does the property appear in an SQL UPDATE)
boolean[] | getPropertyUpdateGeneration() Which of the properties of this class are database generated values on update?
Object | getPropertyValue(Object object, int i, EntityMode entityMode) Get the value of a particular property
Object | getPropertyValue(Object object, String propertyName, EntityMode entityMode) Get the value of a particular property
Object[] | getPropertyValues(Object object, EntityMode entityMode) Return the (loaded) values of the mapped properties of the object (not including backrefs)
Object[] | getPropertyValuesToInsert(Object object, Map mergeMap, SessionImplementor session) Return the values of the insertable properties of the object (including backrefs)
boolean[] | getPropertyVersionability() Get the "versionability" of the properties of this class (is the property optimistic-locked)
Serializable[] | getQuerySpaces() Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class and its subclasses.
String | getRootEntityName() Returns an object that identifies the space in which identifiers of this class hierarchy are unique.
EntityPersister | getSubclassEntityPersister(Object instance, SessionFactoryImplementor factory, EntityMode entityMode) Get the persister for an instance of this class or a subclass
Object | getVersion(Object object, EntityMode entityMode) Get the version number (or timestamp) from the object's version property (or return null if not versioned)
int | getVersionProperty() Which property holds the version number (optional operation).
VersionType | getVersionType() Get the type of versioning (optional operation)
EntityMode | guessEntityMode(Object object) Try to discover the entity mode from the entity instance
boolean | hasCache() Does this class have a cache.
boolean | hasCascades() Does this class declare any cascading save/update/deletes.
boolean | hasCollections() Do instances of this class contain collections.
boolean | hasIdentifierProperty() Does the class have a property holding the identifier value?
boolean | hasInsertGeneratedProperties() Does this entity define any properties as being database generated on insert?
boolean | hasLazyProperties() Does this entity define some lazy attributes?
boolean | hasMutableProperties() Does this entity declare any properties of mutable type?
boolean | hasNaturalIdentifier() Does this entity declare a natural id?
boolean | hasProxy() Does this class support dynamic proxies.
boolean | hasSubselectLoadableCollections() Does this entity own any collections which are fetchable by subselect?
boolean | hasUninitializedLazyProperties(Object object, EntityMode entityMode) Does the given instance have any uninitialized lazy properties?
boolean | hasUpdateGeneratedProperties() Does this entity define any properties as being database generated on update?
boolean | implementsLifecycle(EntityMode entityMode) Does the class implement the Lifecycle interface.
boolean | implementsValidatable(EntityMode entityMode) Does the class implement the Validatable interface.
Serializable | insert(Object[] fields, Object object, SessionImplementor session) Persist an instance, using a natively generated identifier (optional operation)
void | insert(Serializable id, Object[] fields, Object object, SessionImplementor session) Persist an instance
Object | instantiate(Serializable id, EntityMode entityMode) Create a class instance initialized with the given identifier
boolean | isBatchLoadable() Is batch loading enabled?
boolean | isCacheInvalidationRequired() Should we always invalidate the cache instead of recaching updated state
boolean | isIdentifierAssignedByInsert() Is the identifier assigned before the insert by an IDGenerator.
boolean | isInherited() Is this class mapped as a subclass of another class?
boolean | isInstance(Object object, EntityMode entityMode) Is the given object an instance of this entity?
boolean | isInstrumented(EntityMode entityMode) Has the class actually been bytecode instrumented?
boolean | isLazyPropertiesCacheable() Should lazy properties of this entity be cached?
boolean | isMutable() Are instances of this class mutable.
boolean | isSelectBeforeUpdateRequired() Is select snapshot before update enabled?
boolean | isSubclassEntityName(String entityName) Is the given entity name the name of a subclass, or this class?
Boolean | isTransient(Object object, SessionImplementor session) Is this a new transient instance?
boolean | isVersioned() Are instances of this class versioned by a timestamp or version number column.
boolean | isVersionPropertyGenerated() Does this entity contain a version property that is defined to be database generated?
Object | load(Serializable id, Object optionalObject, LockMode lockMode, SessionImplementor session) Load an instance of the persistent class.
void | lock(Serializable id, Object version, Object object, LockMode lockMode, SessionImplementor session) Do a version check (optional operation)
void | postInstantiate() Finish the initialization of this object, once all ClassPersisters have been instantiated.
void | processInsertGeneratedProperties(Serializable id, Object entity, Object[] state, SessionImplementor session) Perform a select to retrieve the values of any generated properties back from the database, injecting these generated values into the given entity as well as writing this state to the PersistenceContext.
void | processUpdateGeneratedProperties(Serializable id, Object entity, Object[] state, SessionImplementor session) Perform a select to retrieve the values of any generated properties back from the database, injecting these generated values into the given entity as well as writing this state to the PersistenceContext.
void | resetIdentifier(Object entity, Serializable currentId, Object currentVersion, EntityMode entityMode) Set the identifier and version of the given instance back to its "unsaved" value, returning the id
void | setIdentifier(Object object, Serializable id, EntityMode entityMode) Set the identifier of an instance (or do nothing if no identifier property)
void | setPropertyValue(Object object, int i, Object value, EntityMode entityMode) Set the value of a particular property
void | setPropertyValues(Object object, Object[] values, EntityMode entityMode) Set the given values to the mapped properties of the given object
void | update(Serializable id, Object[] fields, int[] dirtyFields, boolean hasDirtyCollection, Object[] oldFields, Object oldVersion, Object object, Object rowId, SessionImplementor session) Update a persistent instance
Methods inherited from interface org.hibernate.cache.OptimisticCacheSource
getVersionComparator

Field Detail

ENTITY_ID

public static final String ENTITY_ID
The property name of the "special" identifier property in HQL

See Also:
Constant Field Values
Method Detail

postInstantiate

public void postInstantiate()
                     throws MappingException
Finish the initialization of this object, once all ClassPersisters have been instantiated. Called only once, before any other method.

Throws:
MappingException

getFactory

public SessionFactoryImplementor getFactory()
Return the SessionFactory to which this persister "belongs".

Returns:
The owning SessionFactory.

getRootEntityName

public String getRootEntityName()
Returns an object that identifies the space in which identifiers of this class hierarchy are unique. A table name, a JNDI URL, etc.

getEntityName

public String getEntityName()
The classname of the persistent class (used only for messages)

isSubclassEntityName

public boolean isSubclassEntityName(String entityName)
Is the given entity name the name of a subclass, or this class?

getPropertySpaces

public Serializable[] getPropertySpaces()
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class only.

getQuerySpaces

public Serializable[] getQuerySpaces()
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class and its subclasses.

hasProxy

public boolean hasProxy()
Does this class support dynamic proxies.

hasCollections

public boolean hasCollections()
Do instances of this class contain collections.

hasMutableProperties

public boolean hasMutableProperties()
Does this entity declare any properties of mutable type?

hasSubselectLoadableCollections

public boolean hasSubselectLoadableCollections()
Does this entity own any collections which are fetchable by subselect?

hasCascades

public boolean hasCascades()
Does this class declare any cascading save/update/deletes.

isMutable

public boolean isMutable()
Are instances of this class mutable.

isInherited

public boolean isInherited()
Is this class mapped as a subclass of another class?

isIdentifierAssignedByInsert

public boolean isIdentifierAssignedByInsert()
Is the identifier assigned before the insert by an IDGenerator. Or is it returned by the insert() method? This determines which form of insert() will be called.

getPropertyType

public Type getPropertyType(String propertyName)
                     throws MappingException
Get the type of a particular property

Throws:
MappingException

findDirty

public int[] findDirty(Object[] x,
                       Object[] y,
                       Object owner,
                       SessionImplementor session)
                throws HibernateException
Compare two snapshots of the state of an instance to determine if the persistent state was modified

Returns:
null or the indices of the dirty properties
Throws:
HibernateException

findModified

public int[] findModified(Object[] old,
                          Object[] current,
                          Object object,
                          SessionImplementor session)
                   throws HibernateException
Compare the state of an instance to the current database state

Returns:
null or the indices of the dirty properties
Throws:
HibernateException

hasIdentifierProperty

public boolean hasIdentifierProperty()
Does the class have a property holding the identifier value?

canExtractIdOutOfEntity

public boolean canExtractIdOutOfEntity()
Do detached instances of this class carry their own identifier value?

isVersioned

public boolean isVersioned()
Are instances of this class versioned by a timestamp or version number column.

Specified by:
isVersioned in interface OptimisticCacheSource
Returns:
True if this source represents versioned data; false otherwise.

getVersionType

public VersionType getVersionType()
Get the type of versioning (optional operation)

getVersionProperty

public int getVersionProperty()
Which property holds the version number (optional operation).

hasNaturalIdentifier

public boolean hasNaturalIdentifier()
Does this entity declare a natural id?

getNaturalIdentifierProperties

public int[] getNaturalIdentifierProperties()
Which properties hold the natural id?

getNaturalIdentifierSnapshot

public Object[] getNaturalIdentifierSnapshot(Serializable id,
                                             SessionImplementor session)
                                      throws HibernateException
Retrieve the current state of the natural-id properties from the database.

Parameters:
id - The identifier of the entity for which to retrieve the naturak-id values.
session - The session from which the request originated.
Returns:
The natural-id snapshot.
Throws:
HibernateException

getIdentifierGenerator

public IdentifierGenerator getIdentifierGenerator()
                                           throws HibernateException
Return the IdentifierGenerator for the class

Throws:
HibernateException

hasLazyProperties

public boolean hasLazyProperties()
Does this entity define some lazy attributes?

load

public Object load(Serializable id,
                   Object optionalObject,
                   LockMode lockMode,
                   SessionImplementor session)
            throws HibernateException
Load an instance of the persistent class.

Throws:
HibernateException

lock

public void lock(Serializable id,
                 Object version,
                 Object object,
                 LockMode lockMode,
                 SessionImplementor session)
          throws HibernateException
Do a version check (optional operation)

Throws:
HibernateException

insert

public void insert(Serializable id,
                   Object[] fields,
                   Object object,
                   SessionImplementor session)
            throws HibernateException
Persist an instance

Throws:
HibernateException

insert

public Serializable insert(Object[] fields,
                           Object object,
                           SessionImplementor session)
                    throws HibernateException
Persist an instance, using a natively generated identifier (optional operation)

Throws:
HibernateException

delete

public void delete(Serializable id,
                   Object version,
                   Object object,
                   SessionImplementor session)
            throws HibernateException
Delete a persistent instance

Throws:
HibernateException

update

public void update(Serializable id,
                   Object[] fields,
                   int[] dirtyFields,
                   boolean hasDirtyCollection,
                   Object[] oldFields,
                   Object oldVersion,
                   Object object,
                   Object rowId,
                   SessionImplementor session)
            throws HibernateException
Update a persistent instance

Throws:
HibernateException

getPropertyTypes

public Type[] getPropertyTypes()
Get the Hibernate types of the class properties

getPropertyNames

public String[] getPropertyNames()
Get the names of the class properties - doesn't have to be the names of the actual Java properties (used for XML generation only)

getPropertyInsertability

public boolean[] getPropertyInsertability()
Get the "insertability" of the properties of this class (does the property appear in an SQL INSERT)

getPropertyInsertGeneration

public boolean[] getPropertyInsertGeneration()
Which of the properties of this class are database generated values on insert?

getPropertyUpdateGeneration

public boolean[] getPropertyUpdateGeneration()
Which of the properties of this class are database generated values on update?

getPropertyUpdateability

public boolean[] getPropertyUpdateability()
Get the "updateability" of the properties of this class (does the property appear in an SQL UPDATE)

getPropertyCheckability

public boolean[] getPropertyCheckability()
Get the "checkability" of the properties of this class (is the property dirty checked, does the cache need to be updated)

getPropertyNullability

public boolean[] getPropertyNullability()
Get the nullability of the properties of this class

getPropertyVersionability

public boolean[] getPropertyVersionability()
Get the "versionability" of the properties of this class (is the property optimistic-locked)

getPropertyLaziness

public boolean[] getPropertyLaziness()

getPropertyCascadeStyles

public CascadeStyle[] getPropertyCascadeStyles()
Get the cascade styles of the propertes (optional operation)

getIdentifierType

public Type getIdentifierType()
Get the identifier type

getIdentifierPropertyName

public String getIdentifierPropertyName()
Get the name of the identifier property (or return null) - need not return the name of an actual Java property

isCacheInvalidationRequired

public boolean isCacheInvalidationRequired()
Should we always invalidate the cache instead of recaching updated state

isLazyPropertiesCacheable

public boolean isLazyPropertiesCacheable()
Should lazy properties of this entity be cached?

hasCache

public boolean hasCache()
Does this class have a cache.

getCache

public CacheConcurrencyStrategy getCache()
Get the cache (optional operation)

getCacheEntryStructure

public CacheEntryStructure getCacheEntryStructure()
Get the cache structure

getClassMetadata

public ClassMetadata getClassMetadata()
Get the user-visible metadata for the class (optional operation)

isBatchLoadable

public boolean isBatchLoadable()
Is batch loading enabled?

isSelectBeforeUpdateRequired

public boolean isSelectBeforeUpdateRequired()
Is select snapshot before update enabled?

getDatabaseSnapshot

public Object[] getDatabaseSnapshot(Serializable id,
                                    SessionImplementor session)
                             throws HibernateException
Get the current database state of the object, in a "hydrated" form, without resolving identifiers

Returns:
null if there is no row in the database
Throws:
HibernateException

getCurrentVersion

public Object getCurrentVersion(Serializable id,
                                SessionImplementor session)
                         throws HibernateException
Get the current version of the object, or return null if there is no row for the given identifier. In the case of unversioned data, return any object if the row exists.

Throws:
HibernateException

forceVersionIncrement

public Object forceVersionIncrement(Serializable id,
                                    Object currentVersion,
                                    SessionImplementor session)
                             throws HibernateException
Throws:
HibernateException

guessEntityMode

public EntityMode guessEntityMode(Object object)
Try to discover the entity mode from the entity instance

isInstrumented

public boolean isInstrumented(EntityMode entityMode)
Has the class actually been bytecode instrumented?

hasInsertGeneratedProperties

public boolean hasInsertGeneratedProperties()
Does this entity define any properties as being database generated on insert?

Returns:
True if this entity contains at least one property defined as generated (including version property, but not identifier).

hasUpdateGeneratedProperties

public boolean hasUpdateGeneratedProperties()
Does this entity define any properties as being database generated on update?

Returns:
True if this entity contains at least one property defined as generated (including version property, but not identifier).

isVersionPropertyGenerated

public boolean isVersionPropertyGenerated()
Does this entity contain a version property that is defined to be database generated?

Returns:
true if this entity contains a version property and that property has been marked as generated.

afterInitialize

public void afterInitialize(Object entity,
                            boolean lazyPropertiesAreUnfetched,
                            SessionImplementor session)
Called just after the entities properties have been initialized

afterReassociate

public void afterReassociate(Object entity,
                             SessionImplementor session)
Called just after the entity has been reassociated with the session

createProxy

public Object createProxy(Serializable id,
                          SessionImplementor session)
                   throws HibernateException
Create a new proxy instance

Throws:
HibernateException

isTransient

public Boolean isTransient(Object object,
                           SessionImplementor session)
                    throws HibernateException
Is this a new transient instance?

Throws:
HibernateException

getPropertyValuesToInsert

public Object[] getPropertyValuesToInsert(Object object,
                                          Map mergeMap,
                                          SessionImplementor session)
                                   throws HibernateException
Return the values of the insertable properties of the object (including backrefs)

Throws:
HibernateException

processInsertGeneratedProperties

public void processInsertGeneratedProperties(Serializable id,
                                             Object entity,
                                             Object[] state,
                                             SessionImplementor session)
Perform a select to retrieve the values of any generated properties back from the database, injecting these generated values into the given entity as well as writing this state to the PersistenceContext.

Note, that because we update the PersistenceContext here, callers need to take care that they have already written the initial snapshot to the PersistenceContext before calling this method.

Parameters:
id - The entity's id value.
entity - The entity for which to get the state.
state -
session - The session

processUpdateGeneratedProperties

public void processUpdateGeneratedProperties(Serializable id,
                                             Object entity,
                                             Object[] state,
                                             SessionImplementor session)
Perform a select to retrieve the values of any generated properties back from the database, injecting these generated values into the given entity as well as writing this state to the PersistenceContext.

Note, that because we update the PersistenceContext here, callers need to take care that they have already written the initial snapshot to the PersistenceContext before calling this method.

Parameters:
id - The entity's id value.
entity - The entity for which to get the state.
state -
session - The session

getMappedClass

public Class getMappedClass(EntityMode entityMode)
The persistent class, or null

implementsLifecycle

public boolean implementsLifecycle(EntityMode entityMode)
Does the class implement the Lifecycle interface.

implementsValidatable

public boolean implementsValidatable(EntityMode entityMode)
Does the class implement the Validatable interface.

getConcreteProxyClass

public Class getConcreteProxyClass(EntityMode entityMode)
Get the proxy interface that instances of this concrete class will be cast to (optional operation).

setPropertyValues

public void setPropertyValues(Object object,
                              Object[] values,
                              EntityMode entityMode)
                       throws HibernateException
Set the given values to the mapped properties of the given object

Throws:
HibernateException

setPropertyValue

public void setPropertyValue(Object object,
                             int i,
                             Object value,
                             EntityMode entityMode)
                      throws HibernateException
Set the value of a particular property

Throws:
HibernateException

getPropertyValues

public Object[] getPropertyValues(Object object,
                                  EntityMode entityMode)
                           throws HibernateException
Return the (loaded) values of the mapped properties of the object (not including backrefs)

Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object object,
                               int i,
                               EntityMode entityMode)
                        throws HibernateException
Get the value of a particular property

Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object object,
                               String propertyName,
                               EntityMode entityMode)
                        throws HibernateException
Get the value of a particular property

Throws:
HibernateException

getIdentifier

public Serializable getIdentifier(Object object,
                                  EntityMode entityMode)
                           throws HibernateException
Get the identifier of an instance (throw an exception if no identifier property)

Throws:
HibernateException

setIdentifier

public void setIdentifier(Object object,
                          Serializable id,
                          EntityMode entityMode)
                   throws HibernateException
Set the identifier of an instance (or do nothing if no identifier property)

Throws:
HibernateException

getVersion

public Object getVersion(Object object,
                         EntityMode entityMode)
                  throws HibernateException
Get the version number (or timestamp) from the object's version property (or return null if not versioned)

Throws:
HibernateException

instantiate

public Object instantiate(Serializable id,
                          EntityMode entityMode)
                   throws HibernateException
Create a class instance initialized with the given identifier

Throws:
HibernateException

isInstance

public boolean isInstance(Object object,
                          EntityMode entityMode)
Is the given object an instance of this entity?

hasUninitializedLazyProperties

public boolean hasUninitializedLazyProperties(Object object,
                                              EntityMode entityMode)
Does the given instance have any uninitialized lazy properties?

resetIdentifier

public void resetIdentifier(Object entity,
                            Serializable currentId,
                            Object currentVersion,
                            EntityMode entityMode)
Set the identifier and version of the given instance back to its "unsaved" value, returning the id

Parameters:
currentId - TODO
currentVersion - TODO

getSubclassEntityPersister

public EntityPersister getSubclassEntityPersister(Object instance,
                                                  SessionFactoryImplementor factory,
                                                  EntityMode entityMode)
Get the persister for an instance of this class or a subclass

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Joinable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Interface Joinable

All Known Subinterfaces:
OuterJoinLoadable, Queryable, QueryableCollection, SQLLoadableCollection
All Known Implementing Classes:
AbstractCollectionPersister, AbstractEntityPersister
public interface Joinable

Anything that can be loaded by outer join - namely persisters for classes or collections.

Author:
Gavin King

Method Summary
boolean | consumesCollectionAlias() Very, very, very ugly...
boolean | consumesEntityAlias() Very, very, very ugly...
String | filterFragment(String alias, Map enabledFilters) Get the where clause filter, given a query alias and considering enabled session filters
String | fromJoinFragment(String alias, boolean innerJoin, boolean includeSubclasses) Get the from clause part of any joins (optional operation)
String[] | getKeyColumnNames() The columns to join on
String | getName() An identifying name; a class name or collection role name.
String | getTableName() The table to join to.
boolean | isCollection() Is this instance actually a CollectionPersister?
String | oneToManyFilterFragment(String alias)
String | selectFragment(Joinable rhs, String rhsAlias, String lhsAlias, String currentEntitySuffix, String currentCollectionSuffix, boolean includeCollectionColumns) All columns to select, when loading.
String | whereJoinFragment(String alias, boolean innerJoin, boolean includeSubclasses) Get the where clause part of any joins (optional operation)

Method Detail

getName

public String getName()
An identifying name; a class name or collection role name.

getTableName

public String getTableName()
The table to join to.

selectFragment

public String selectFragment(Joinable rhs,
                             String rhsAlias,
                             String lhsAlias,
                             String currentEntitySuffix,
                             String currentCollectionSuffix,
                             boolean includeCollectionColumns)
All columns to select, when loading.

whereJoinFragment

public String whereJoinFragment(String alias,
                                boolean innerJoin,
                                boolean includeSubclasses)
Get the where clause part of any joins (optional operation)

fromJoinFragment

public String fromJoinFragment(String alias,
                               boolean innerJoin,
                               boolean includeSubclasses)
Get the from clause part of any joins (optional operation)

getKeyColumnNames

public String[] getKeyColumnNames()
The columns to join on

filterFragment

public String filterFragment(String alias,
                             Map enabledFilters)
                      throws MappingException
Get the where clause filter, given a query alias and considering enabled session filters

Throws:
MappingException

oneToManyFilterFragment

public String oneToManyFilterFragment(String alias)
                               throws MappingException
Throws:
MappingException

isCollection

public boolean isCollection()
Is this instance actually a CollectionPersister?

consumesEntityAlias

public boolean consumesEntityAlias()
Very, very, very ugly...

Returns:
Does this persister "consume" entity column aliases in the result set?

consumesCollectionAlias

public boolean consumesCollectionAlias()
Very, very, very ugly...

Returns:
Does this persister "consume" collection column aliases in the result set?
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Loadable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Interface Loadable

All Superinterfaces:
EntityPersister, OptimisticCacheSource
All Known Subinterfaces:
OuterJoinLoadable, Queryable, SQLLoadable, UniqueKeyLoadable
All Known Implementing Classes:
AbstractEntityPersister
public interface Loadable
extends EntityPersister

Implemented by a EntityPersister that may be loaded using Loader.

Author:
Gavin King
See Also:
Loader

Field Summary
static String ROWID_ALIAS
Fields inherited from interface org.hibernate.persister.entity.EntityPersister
ENTITY_ID
Method Summary
String | getDiscriminatorAlias(String suffix) Get the result set aliases used for the identifier columns, given a suffix
String | getDiscriminatorColumnName()
Type | getDiscriminatorType() Get the discriminator type
String[] | getIdentifierAliases(String suffix) Get the result set aliases used for the identifier columns, given a suffix
String[] | getIdentifierColumnNames() Get the names of columns used to persist the identifier
String[] | getPropertyAliases(String suffix, int i) Get the result set aliases used for the property columns, given a suffix (properties of this class, only).
String[] | getPropertyColumnNames(int i) Get the result set column names mapped for this property (properties of this class, only).
String | getSubclassForDiscriminatorValue(Object value) Get the concrete subclass corresponding to the given discriminator value
boolean | hasRowId() Does the result set contain rowids?
boolean | hasSubclasses() Does this persistent class have subclasses?
Object[] | hydrate(ResultSet rs, Serializable id, Object object, Loadable rootLoadable, String[][] suffixedPropertyColumns, boolean allProperties, SessionImplementor session) Retrieve property values from one row of a result set
boolean | isAbstract()
Methods inherited from interface org.hibernate.persister.entity.EntityPersister
afterInitialize, afterReassociate, canExtractIdOutOfEntity, createProxy, delete, findDirty, findModified, forceVersionIncrement, getCache, getCacheEntryStructure, getClassMetadata, getConcreteProxyClass, getCurrentVersion, getDatabaseSnapshot, getEntityName, getFactory, getIdentifier, getIdentifierGenerator, getIdentifierPropertyName, getIdentifierType, getMappedClass, getNaturalIdentifierProperties, getNaturalIdentifierSnapshot, getPropertyCascadeStyles, getPropertyCheckability, getPropertyInsertability, getPropertyInsertGeneration, getPropertyLaziness, getPropertyNames, getPropertyNullability, getPropertySpaces, getPropertyType, getPropertyTypes, getPropertyUpdateability, getPropertyUpdateGeneration, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValuesToInsert, getPropertyVersionability, getQuerySpaces, getRootEntityName, getSubclassEntityPersister, getVersion, getVersionProperty, getVersionType, guessEntityMode, hasCache, hasCascades, hasCollections, hasIdentifierProperty, hasInsertGeneratedProperties, hasLazyProperties, hasMutableProperties, hasNaturalIdentifier, hasProxy, hasSubselectLoadableCollections, hasUninitializedLazyProperties, hasUpdateGeneratedProperties, implementsLifecycle, implementsValidatable, insert, insert, instantiate, isBatchLoadable, isCacheInvalidationRequired, isIdentifierAssignedByInsert, isInherited, isInstance, isInstrumented, isLazyPropertiesCacheable, isMutable, isSelectBeforeUpdateRequired, isSubclassEntityName, isTransient, isVersioned, isVersionPropertyGenerated, load, lock, postInstantiate, processInsertGeneratedProperties, processUpdateGeneratedProperties, resetIdentifier, setIdentifier, setPropertyValue, setPropertyValues, update
Methods inherited from interface org.hibernate.cache.OptimisticCacheSource
getVersionComparator

Field Detail

ROWID_ALIAS

public static final String ROWID_ALIAS
See Also:
Constant Field Values
Method Detail

hasSubclasses

public boolean hasSubclasses()
Does this persistent class have subclasses?

getDiscriminatorType

public Type getDiscriminatorType()
Get the discriminator type

getSubclassForDiscriminatorValue

public String getSubclassForDiscriminatorValue(Object value)
Get the concrete subclass corresponding to the given discriminator value

getIdentifierColumnNames

public String[] getIdentifierColumnNames()
Get the names of columns used to persist the identifier

getIdentifierAliases

public String[] getIdentifierAliases(String suffix)
Get the result set aliases used for the identifier columns, given a suffix

getPropertyAliases

public String[] getPropertyAliases(String suffix,
                                   int i)
Get the result set aliases used for the property columns, given a suffix (properties of this class, only).

getPropertyColumnNames

public String[] getPropertyColumnNames(int i)
Get the result set column names mapped for this property (properties of this class, only).

getDiscriminatorAlias

public String getDiscriminatorAlias(String suffix)
Get the result set aliases used for the identifier columns, given a suffix

getDiscriminatorColumnName

public String getDiscriminatorColumnName()
Returns:
the column name for the discriminator as specified in the mapping.

hasRowId

public boolean hasRowId()
Does the result set contain rowids?

hydrate

public Object[] hydrate(ResultSet rs,
                        Serializable id,
                        Object object,
                        Loadable rootLoadable,
                        String[][] suffixedPropertyColumns,
                        boolean allProperties,
                        SessionImplementor session)
                 throws SQLException,
                        HibernateException
Retrieve property values from one row of a result set

Throws:
SQLException
HibernateException

isAbstract

public boolean isAbstract()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Lockable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Interface Lockable

All Superinterfaces:
EntityPersister, OptimisticCacheSource
All Known Implementing Classes:
AbstractEntityPersister
public interface Lockable
extends EntityPersister

Contract for things that can be locked via a LockingStrategy

Since:
3.2
Author:
Steve Ebersole

Field Summary
Fields inherited from interface org.hibernate.persister.entity.EntityPersister
ENTITY_ID
Method Summary
String[] | getRootTableIdentifierColumnNames() Get the names of columns on the root table used to persist the identifier.
String | getRootTableName() Locks are always applied to the "root table".
String | getVersionColumnName() For versioned entities, get the name of the column (again, expected on the root table) used to store the version values.
Methods inherited from interface org.hibernate.persister.entity.EntityPersister
afterInitialize, afterReassociate, canExtractIdOutOfEntity, createProxy, delete, findDirty, findModified, forceVersionIncrement, getCache, getCacheEntryStructure, getClassMetadata, getConcreteProxyClass, getCurrentVersion, getDatabaseSnapshot, getEntityName, getFactory, getIdentifier, getIdentifierGenerator, getIdentifierPropertyName, getIdentifierType, getMappedClass, getNaturalIdentifierProperties, getNaturalIdentifierSnapshot, getPropertyCascadeStyles, getPropertyCheckability, getPropertyInsertability, getPropertyInsertGeneration, getPropertyLaziness, getPropertyNames, getPropertyNullability, getPropertySpaces, getPropertyType, getPropertyTypes, getPropertyUpdateability, getPropertyUpdateGeneration, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValuesToInsert, getPropertyVersionability, getQuerySpaces, getRootEntityName, getSubclassEntityPersister, getVersion, getVersionProperty, getVersionType, guessEntityMode, hasCache, hasCascades, hasCollections, hasIdentifierProperty, hasInsertGeneratedProperties, hasLazyProperties, hasMutableProperties, hasNaturalIdentifier, hasProxy, hasSubselectLoadableCollections, hasUninitializedLazyProperties, hasUpdateGeneratedProperties, implementsLifecycle, implementsValidatable, insert, insert, instantiate, isBatchLoadable, isCacheInvalidationRequired, isIdentifierAssignedByInsert, isInherited, isInstance, isInstrumented, isLazyPropertiesCacheable, isMutable, isSelectBeforeUpdateRequired, isSubclassEntityName, isTransient, isVersioned, isVersionPropertyGenerated, load, lock, postInstantiate, processInsertGeneratedProperties, processUpdateGeneratedProperties, resetIdentifier, setIdentifier, setPropertyValue, setPropertyValues, update
Methods inherited from interface org.hibernate.cache.OptimisticCacheSource
getVersionComparator

Method Detail

getRootTableName

public String getRootTableName()
Locks are always applied to the "root table".

Returns:
The root table name

getRootTableIdentifierColumnNames

public String[] getRootTableIdentifierColumnNames()
Get the names of columns on the root table used to persist the identifier.

Returns:
The root table identifier column names.

getVersionColumnName

public String getVersionColumnName()
For versioned entities, get the name of the column (again, expected on the root table) used to store the version values.

Returns:
The version column name.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OuterJoinLoadable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Interface OuterJoinLoadable

All Superinterfaces:
EntityPersister, Joinable, Loadable, OptimisticCacheSource
All Known Implementing Classes:
AbstractEntityPersister
public interface OuterJoinLoadable
extends Loadable, Joinable

A EntityPersister that may be loaded by outer join using the OuterJoinLoader hierarchy and may be an element of a one-to-many association.

Author:
Gavin King
See Also:
OuterJoinLoader

Field Summary
Fields inherited from interface org.hibernate.persister.entity.Loadable
ROWID_ALIAS
Fields inherited from interface org.hibernate.persister.entity.EntityPersister
ENTITY_ID
Method Summary
int | countSubclassProperties() How many properties are there, for this class and all subclasses?
String | fromTableFragment(String alias) Get the main from table fragment, given a query alias.
CascadeStyle | getCascadeStyle(int i) Get the cascade style of this (subclass closure) property
EntityType | getEntityType()
FetchMode | getFetchMode(int i) May this (subclass closure) property be fetched using an SQL outerjoin?
String[] | getPropertyColumnNames(String propertyPath) Get the column names for the given property path
String | getPropertyTableName(String propertyName) Get the table name for the given property path
String[] | getSubclassPropertyColumnNames(int i) Return the column names used to persist the numbered property of the class or a subclass.
String | getSubclassPropertyName(int i) Get the name of the numbered property of the class or a subclass.
String | getSubclassPropertyTableName(int i) Return the table name used to persist the numbered property of the class or a subclass.
Type | getSubclassPropertyType(int i) Get the type of the numbered property of the class or a subclass.
boolean | isDefinedOnSubclass(int i) Is this property defined on a subclass of the mapped class.
boolean | isSubclassPropertyNullable(int i) Is the numbered property of the class of subclass nullable?
String | selectFragment(String alias, String suffix) Generate a list of collection index, key and element columns
String[] | toColumns(String name, int i) Given the number of a property of a subclass, and a table alias, return the aliased column names.
Methods inherited from interface org.hibernate.persister.entity.Loadable
getDiscriminatorAlias, getDiscriminatorColumnName, getDiscriminatorType, getIdentifierAliases, getIdentifierColumnNames, getPropertyAliases, getPropertyColumnNames, getSubclassForDiscriminatorValue, hasRowId, hasSubclasses, hydrate, isAbstract
Methods inherited from interface org.hibernate.persister.entity.EntityPersister
afterInitialize, afterReassociate, canExtractIdOutOfEntity, createProxy, delete, findDirty, findModified, forceVersionIncrement, getCache, getCacheEntryStructure, getClassMetadata, getConcreteProxyClass, getCurrentVersion, getDatabaseSnapshot, getEntityName, getFactory, getIdentifier, getIdentifierGenerator, getIdentifierPropertyName, getIdentifierType, getMappedClass, getNaturalIdentifierProperties, getNaturalIdentifierSnapshot, getPropertyCascadeStyles, getPropertyCheckability, getPropertyInsertability, getPropertyInsertGeneration, getPropertyLaziness, getPropertyNames, getPropertyNullability, getPropertySpaces, getPropertyType, getPropertyTypes, getPropertyUpdateability, getPropertyUpdateGeneration, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValuesToInsert, getPropertyVersionability, getQuerySpaces, getRootEntityName, getSubclassEntityPersister, getVersion, getVersionProperty, getVersionType, guessEntityMode, hasCache, hasCascades, hasCollections, hasIdentifierProperty, hasInsertGeneratedProperties, hasLazyProperties, hasMutableProperties, hasNaturalIdentifier, hasProxy, hasSubselectLoadableCollections, hasUninitializedLazyProperties, hasUpdateGeneratedProperties, implementsLifecycle, implementsValidatable, insert, insert, instantiate, isBatchLoadable, isCacheInvalidationRequired, isIdentifierAssignedByInsert, isInherited, isInstance, isInstrumented, isLazyPropertiesCacheable, isMutable, isSelectBeforeUpdateRequired, isSubclassEntityName, isTransient, isVersioned, isVersionPropertyGenerated, load, lock, postInstantiate, processInsertGeneratedProperties, processUpdateGeneratedProperties, resetIdentifier, setIdentifier, setPropertyValue, setPropertyValues, update
Methods inherited from interface org.hibernate.cache.OptimisticCacheSource
getVersionComparator
Methods inherited from interface org.hibernate.persister.entity.Joinable
consumesCollectionAlias, consumesEntityAlias, filterFragment, fromJoinFragment, getKeyColumnNames, getName, getTableName, isCollection, oneToManyFilterFragment, selectFragment, whereJoinFragment

Method Detail

selectFragment

public String selectFragment(String alias,
                             String suffix)
Generate a list of collection index, key and element columns

countSubclassProperties

public int countSubclassProperties()
How many properties are there, for this class and all subclasses?

getFetchMode

public FetchMode getFetchMode(int i)
May this (subclass closure) property be fetched using an SQL outerjoin?

getCascadeStyle

public CascadeStyle getCascadeStyle(int i)
Get the cascade style of this (subclass closure) property

isDefinedOnSubclass

public boolean isDefinedOnSubclass(int i)
Is this property defined on a subclass of the mapped class.

getSubclassPropertyType

public Type getSubclassPropertyType(int i)
Get the type of the numbered property of the class or a subclass.

getSubclassPropertyName

public String getSubclassPropertyName(int i)
Get the name of the numbered property of the class or a subclass.

isSubclassPropertyNullable

public boolean isSubclassPropertyNullable(int i)
Is the numbered property of the class of subclass nullable?

getSubclassPropertyColumnNames

public String[] getSubclassPropertyColumnNames(int i)
Return the column names used to persist the numbered property of the class or a subclass.

getSubclassPropertyTableName

public String getSubclassPropertyTableName(int i)
Return the table name used to persist the numbered property of the class or a subclass.

toColumns

public String[] toColumns(String name,
                          int i)
Given the number of a property of a subclass, and a table alias, return the aliased column names.

fromTableFragment

public String fromTableFragment(String alias)
Get the main from table fragment, given a query alias.

getPropertyColumnNames

public String[] getPropertyColumnNames(String propertyPath)
Get the column names for the given property path

getPropertyTableName

public String getPropertyTableName(String propertyName)
Get the table name for the given property path

getEntityType

public EntityType getEntityType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyMapping (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Interface PropertyMapping

All Known Subinterfaces:
Queryable, QueryableCollection, SQLLoadableCollection
All Known Implementing Classes:
AbstractCollectionPersister, AbstractEntityPersister, AbstractPropertyMapping, CollectionPropertyMapping, ElementPropertyMapping
public interface PropertyMapping

Abstraction of all mappings that define properties: entities, collection elements.

Author:
Gavin King

Method Summary
Type | getType() Get the type of the thing containing the properties
String[] | toColumns(String propertyName) Given a property path, return the corresponding column name(s).
String[] | toColumns(String alias, String propertyName) Given a query alias and a property path, return the qualified column name
Type | toType(String propertyName) Given a component path expression, get the type of the property

Method Detail

toType

public Type toType(String propertyName)
            throws QueryException
Given a component path expression, get the type of the property

Throws:
QueryException

toColumns

public String[] toColumns(String alias,
                          String propertyName)
                   throws QueryException
Given a query alias and a property path, return the qualified column name

Throws:
QueryException

toColumns

public String[] toColumns(String propertyName)
                   throws QueryException,
                          UnsupportedOperationException
Given a property path, return the corresponding column name(s).

Throws:
QueryException
UnsupportedOperationException

getType

public Type getType()
Get the type of the thing containing the properties

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Queryable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Interface Queryable

All Superinterfaces:
EntityPersister, Joinable, Loadable, OptimisticCacheSource, PropertyMapping
All Known Implementing Classes:
AbstractEntityPersister
public interface Queryable
extends Loadable, PropertyMapping, Joinable

Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language

Author:
Gavin King

Field Summary
Fields inherited from interface org.hibernate.persister.entity.Loadable
ROWID_ALIAS
Fields inherited from interface org.hibernate.persister.entity.EntityPersister
ENTITY_ID
Method Summary
 String generateFilterConditionAlias(String rootAlias)
The alias used for any filter conditions (mapped where-fragments or enabled-filters).
 String[] getConstraintOrderedTableNameClosure()
Get the names of all tables used in the hierarchy (up and down) ordered such that deletes in the given order would not cause contraint violations.
 String[][] getContraintOrderedTableKeyColumnClosure()
For each table specified in getConstraintOrderedTableNameClosure(), get the columns that define the key between the various hierarchy classes.
 String getDiscriminatorSQLValue()
Get the discriminator value for this particular concrete subclass, as a string that may be embedded in a select statement
 String[] getIdentifierColumnNames()
Get the names of columns used to persist the identifier
 String getMappedSuperclass()
Get the class that this class is mapped as a subclass of - not necessarily the direct superclass
 int getSubclassPropertyTableNumber(String propertyPath)
Given a property name, determine the number of the table which contains the column to which this property is mapped.
 String getSubclassTableName(int number)
Get the name of the table with the given index from the internal array.
 String getTemporaryIdTableDDL()
Get the appropriate DDL command for generating the temporary table to be used to (potentially) store id values when performing bulk update/deletes.
 String getTemporaryIdTableName()
Get the name of the temporary table to be used to (potentially) store id values when performing bulk update/deletes.
 String identifierSelectFragment(String name, String suffix)
Given a query alias and an identifying suffix, render the intentifier select fragment.
 boolean isAbstract()
Is this an abstract class?
 boolean isExplicitPolymorphism()
Is this class explicit polymorphism only?
 boolean isMultiTable()
Is the inheritence hierarchy described by this persister contained across multiple tables?
 boolean isVersionPropertyInsertable()
Is the version property included in insert statements?
 String propertySelectFragment(String alias, String suffix, boolean allProperties)
Given a query alias and an identifying suffix, render the property select fragment.
Methods inherited from interface org.hibernate.persister.entity.Loadable
getDiscriminatorAlias, getDiscriminatorColumnName, getDiscriminatorType, getIdentifierAliases, getPropertyAliases, getPropertyColumnNames, getSubclassForDiscriminatorValue, hasRowId, hasSubclasses, hydrate
Methods inherited from interface org.hibernate.persister.entity.EntityPersister
afterInitialize, afterReassociate, canExtractIdOutOfEntity, createProxy, delete, findDirty, findModified, forceVersionIncrement, getCache, getCacheEntryStructure, getClassMetadata, getConcreteProxyClass, getCurrentVersion, getDatabaseSnapshot, getEntityName, getFactory, getIdentifier, getIdentifierGenerator, getIdentifierPropertyName, getIdentifierType, getMappedClass, getNaturalIdentifierProperties, getNaturalIdentifierSnapshot, getPropertyCascadeStyles, getPropertyCheckability, getPropertyInsertability, getPropertyInsertGeneration, getPropertyLaziness, getPropertyNames, getPropertyNullability, getPropertySpaces, getPropertyType, getPropertyTypes, getPropertyUpdateability, getPropertyUpdateGeneration, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValuesToInsert, getPropertyVersionability, getQuerySpaces, getRootEntityName, getSubclassEntityPersister, getVersion, getVersionProperty, getVersionType, guessEntityMode, hasCache, hasCascades, hasCollections, hasIdentifierProperty, hasInsertGeneratedProperties, hasLazyProperties, hasMutableProperties, hasNaturalIdentifier, hasProxy, hasSubselectLoadableCollections, hasUninitializedLazyProperties, hasUpdateGeneratedProperties, implementsLifecycle, implementsValidatable, insert, insert, instantiate, isBatchLoadable, isCacheInvalidationRequired, isIdentifierAssignedByInsert, isInherited, isInstance, isInstrumented, isLazyPropertiesCacheable, isMutable, isSelectBeforeUpdateRequired, isSubclassEntityName, isTransient, isVersioned, isVersionPropertyGenerated, load, lock, postInstantiate, processInsertGeneratedProperties, processUpdateGeneratedProperties, resetIdentifier, setIdentifier, setPropertyValue, setPropertyValues, update
Methods inherited from interface org.hibernate.cache.OptimisticCacheSource
getVersionComparator
Methods inherited from interface org.hibernate.persister.entity.PropertyMapping
getType, toColumns, toColumns, toType
Methods inherited from interface org.hibernate.persister.entity.Joinable
consumesCollectionAlias, consumesEntityAlias, filterFragment, fromJoinFragment, getKeyColumnNames, getName, getTableName, isCollection, oneToManyFilterFragment, selectFragment, whereJoinFragment

Method Detail

isAbstract

public boolean isAbstract()
Is this an abstract class?

Specified by:
isAbstract in interface Loadable

isExplicitPolymorphism

public boolean isExplicitPolymorphism()
Is this class explicit polymorphism only?

getMappedSuperclass

public String getMappedSuperclass()
Get the class that this class is mapped as a subclass of - not necessarily the direct superclass

getDiscriminatorSQLValue

public String getDiscriminatorSQLValue()
Get the discriminator value for this particular concrete subclass, as a string that may be embedded in a select statement

identifierSelectFragment

public String identifierSelectFragment(String name,
                                       String suffix)
Given a query alias and an identifying suffix, render the intentifier select fragment.

propertySelectFragment

public String propertySelectFragment(String alias,
                                     String suffix,
                                     boolean allProperties)
Given a query alias and an identifying suffix, render the property select fragment.

getIdentifierColumnNames

public String[] getIdentifierColumnNames()
Get the names of columns used to persist the identifier

Specified by:
getIdentifierColumnNames in interface Loadable

isMultiTable

public boolean isMultiTable()
Is the inheritence hierarchy described by this persister contained across multiple tables?

Returns:
True if the inheritence hierarchy is spread across multiple tables; false otherwise.

getConstraintOrderedTableNameClosure

public String[] getConstraintOrderedTableNameClosure()
Get the names of all tables used in the hierarchy (up and down) ordered such that deletes in the given order would not cause contraint violations.

Returns:
The ordered array of table names.

getContraintOrderedTableKeyColumnClosure

public String[][] getContraintOrderedTableKeyColumnClosure()
For each table specified in getConstraintOrderedTableNameClosure(), get the columns that define the key between the various hierarchy classes.

The first dimension here corresponds to the table indexes returned in getConstraintOrderedTableNameClosure().

The second dimension should have the same length across all the elements in the first dimension. If not, that'd be a problem ;)

Returns:

getTemporaryIdTableName

public String getTemporaryIdTableName()
Get the name of the temporary table to be used to (potentially) store id values when performing bulk update/deletes.

Returns:
The appropriate temporary table name.

getTemporaryIdTableDDL

public String getTemporaryIdTableDDL()
Get the appropriate DDL command for generating the temporary table to be used to (potentially) store id values when performing bulk update/deletes.

Returns:
The appropriate temporary table creation command.

getSubclassPropertyTableNumber

public int getSubclassPropertyTableNumber(String propertyPath)
Given a property name, determine the number of the table which contains the column to which this property is mapped.

Note that this is not relative to the results from getConstraintOrderedTableNameClosure(). It is relative to the subclass table name closure maintained internal to the persister (yick!). It is also relative to the indexing used to resolve getSubclassTableName(int)...

Parameters:
propertyPath - The name of the property.
Returns:
The nunber of the table to which the property is mapped.

getSubclassTableName

public String getSubclassTableName(int number)
Get the name of the table with the given index from the internal array.

Parameters:
number - The index into the internal array.
Returns:

isVersionPropertyInsertable

public boolean isVersionPropertyInsertable()
Is the version property included in insert statements?

generateFilterConditionAlias

public String generateFilterConditionAlias(String rootAlias)
The alias used for any filter conditions (mapped where-fragments or enabled-filters).

This may or may not be different from the root alias depending upon the inheritence mapping strategy.

Parameters:
rootAlias - The root alias
Returns:
The alias used for "filter conditions" within the where clause.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLLoadable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Interface SQLLoadable

All Superinterfaces:
EntityPersister, Loadable, OptimisticCacheSource
All Known Implementing Classes:
AbstractEntityPersister
public interface SQLLoadable
extends Loadable

A class persister that supports queries expressed in the platform native SQL dialect

Author:
Gavin King, Max Andersen

Field Summary
Fields inherited from interface org.hibernate.persister.entity.Loadable
ROWID_ALIAS
Fields inherited from interface org.hibernate.persister.entity.EntityPersister
ENTITY_ID
Method Summary
String[] | getSubclassPropertyColumnAliases(String propertyName, String suffix) Return the column alias names used to persist/query the named property of the class or a subclass (optional operation).
String[] | getSubclassPropertyColumnNames(String propertyName) Return the column names used to persist/query the named property of the class or a subclass (optional operation).
Type | getType() Get the type
String | selectFragment(String alias, String suffix) All columns to select, when loading.
Methods inherited from interface org.hibernate.persister.entity.Loadable
getDiscriminatorAlias, getDiscriminatorColumnName, getDiscriminatorType, getIdentifierAliases, getIdentifierColumnNames, getPropertyAliases, getPropertyColumnNames, getSubclassForDiscriminatorValue, hasRowId, hasSubclasses, hydrate, isAbstract
Methods inherited from interface org.hibernate.persister.entity.EntityPersister
afterInitialize, afterReassociate, canExtractIdOutOfEntity, createProxy, delete, findDirty, findModified, forceVersionIncrement, getCache, getCacheEntryStructure, getClassMetadata, getConcreteProxyClass, getCurrentVersion, getDatabaseSnapshot, getEntityName, getFactory, getIdentifier, getIdentifierGenerator, getIdentifierPropertyName, getIdentifierType, getMappedClass, getNaturalIdentifierProperties, getNaturalIdentifierSnapshot, getPropertyCascadeStyles, getPropertyCheckability, getPropertyInsertability, getPropertyInsertGeneration, getPropertyLaziness, getPropertyNames, getPropertyNullability, getPropertySpaces, getPropertyType, getPropertyTypes, getPropertyUpdateability, getPropertyUpdateGeneration, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValuesToInsert, getPropertyVersionability, getQuerySpaces, getRootEntityName, getSubclassEntityPersister, getVersion, getVersionProperty, getVersionType, guessEntityMode, hasCache, hasCascades, hasCollections, hasIdentifierProperty, hasInsertGeneratedProperties, hasLazyProperties, hasMutableProperties, hasNaturalIdentifier, hasProxy, hasSubselectLoadableCollections, hasUninitializedLazyProperties, hasUpdateGeneratedProperties, implementsLifecycle, implementsValidatable, insert, insert, instantiate, isBatchLoadable, isCacheInvalidationRequired, isIdentifierAssignedByInsert, isInherited, isInstance, isInstrumented, isLazyPropertiesCacheable, isMutable, isSelectBeforeUpdateRequired, isSubclassEntityName, isTransient, isVersioned, isVersionPropertyGenerated, load, lock, postInstantiate, processInsertGeneratedProperties, processUpdateGeneratedProperties, resetIdentifier, setIdentifier, setPropertyValue, setPropertyValues, update
Methods inherited from interface org.hibernate.cache.OptimisticCacheSource
getVersionComparator

Method Detail

getSubclassPropertyColumnAliases

public String[] getSubclassPropertyColumnAliases(String propertyName,
                                                 String suffix)
Return the column alias names used to persist/query the named property of the class or a subclass (optional operation).

getSubclassPropertyColumnNames

public String[] getSubclassPropertyColumnNames(String propertyName)
Return the column names used to persist/query the named property of the class or a subclass (optional operation).

selectFragment

public String selectFragment(String alias,
                             String suffix)
All columns to select, when loading.

getType

public Type getType()
Get the type

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UniqueKeyLoadable (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Interface UniqueKeyLoadable

All Superinterfaces:
EntityPersister, Loadable, OptimisticCacheSource
All Known Implementing Classes:
AbstractEntityPersister
public interface UniqueKeyLoadable
extends Loadable

Author:
Gavin King

Field Summary
Fields inherited from interface org.hibernate.persister.entity.Loadable
ROWID_ALIAS
Fields inherited from interface org.hibernate.persister.entity.EntityPersister
ENTITY_ID
Method Summary
int | getPropertyIndex(String propertyName) Get the property number of the unique key property
Object | loadByUniqueKey(String propertyName, Object uniqueKey, SessionImplementor session) Load an instance of the persistent class, by a unique key other than the primary key.
Methods inherited from interface org.hibernate.persister.entity.Loadable
getDiscriminatorAlias, getDiscriminatorColumnName, getDiscriminatorType, getIdentifierAliases, getIdentifierColumnNames, getPropertyAliases, getPropertyColumnNames, getSubclassForDiscriminatorValue, hasRowId, hasSubclasses, hydrate, isAbstract
Methods inherited from interface org.hibernate.persister.entity.EntityPersister
afterInitialize, afterReassociate, canExtractIdOutOfEntity, createProxy, delete, findDirty, findModified, forceVersionIncrement, getCache, getCacheEntryStructure, getClassMetadata, getConcreteProxyClass, getCurrentVersion, getDatabaseSnapshot, getEntityName, getFactory, getIdentifier, getIdentifierGenerator, getIdentifierPropertyName, getIdentifierType, getMappedClass, getNaturalIdentifierProperties, getNaturalIdentifierSnapshot, getPropertyCascadeStyles, getPropertyCheckability, getPropertyInsertability, getPropertyInsertGeneration, getPropertyLaziness, getPropertyNames, getPropertyNullability, getPropertySpaces, getPropertyType, getPropertyTypes, getPropertyUpdateability, getPropertyUpdateGeneration, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValuesToInsert, getPropertyVersionability, getQuerySpaces, getRootEntityName, getSubclassEntityPersister, getVersion, getVersionProperty, getVersionType, guessEntityMode, hasCache, hasCascades, hasCollections, hasIdentifierProperty, hasInsertGeneratedProperties, hasLazyProperties, hasMutableProperties, hasNaturalIdentifier, hasProxy, hasSubselectLoadableCollections, hasUninitializedLazyProperties, hasUpdateGeneratedProperties, implementsLifecycle, implementsValidatable, insert, insert, instantiate, isBatchLoadable, isCacheInvalidationRequired, isIdentifierAssignedByInsert, isInherited, isInstance, isInstrumented, isLazyPropertiesCacheable, isMutable, isSelectBeforeUpdateRequired, isSubclassEntityName, isTransient, isVersioned, isVersionPropertyGenerated, load, lock, postInstantiate, processInsertGeneratedProperties, processUpdateGeneratedProperties, resetIdentifier, setIdentifier, setPropertyValue, setPropertyValues, update
Methods inherited from interface org.hibernate.cache.OptimisticCacheSource
getVersionComparator

Method Detail

loadByUniqueKey

public Object loadByUniqueKey(String propertyName,
                              Object uniqueKey,
                              SessionImplementor session)
                       throws HibernateException
Load an instance of the persistent class, by a unique key other than the primary key.

Throws:
HibernateException

getPropertyIndex

public int getPropertyIndex(String propertyName)
Get the property number of the unique key property

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractEntityPersister (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Class AbstractEntityPersister

java.lang.Object
    extended by org.hibernate.persister.entity.AbstractEntityPersister
All Implemented Interfaces:
ClassMetadata, EntityPersister, Joinable, LazyPropertyInitializer, Loadable, Lockable, OptimisticCacheSource, OuterJoinLoadable, PostInsertIdentityPersister, PropertyMapping, Queryable, SQLLoadable, UniqueKeyLoadable
Direct Known Subclasses:
JoinedSubclassEntityPersister, SingleTableEntityPersister, UnionSubclassEntityPersister
public abstract class AbstractEntityPersister
extends Object
implements OuterJoinLoadable, Queryable, ClassMetadata, UniqueKeyLoadable, SQLLoadable, LazyPropertyInitializer, PostInsertIdentityPersister, Lockable

Basic functionality for persisting an entity via JDBC through either generated or custom SQL

Author:
Gavin King

Field Summary
protected String[] | customSQLDelete
protected String[] | customSQLInsert
protected String[] | customSQLUpdate
protected boolean[] | deleteCallable
protected ExecuteUpdateResultCheckStyle[] | deleteResultCheckStyles
static String | ENTITY_CLASS
protected boolean[] | insertCallable
protected ExecuteUpdateResultCheckStyle[] | insertResultCheckStyles
protected BasicEntityPropertyMapping | propertyMapping
protected String | rowIdName
protected boolean[] | updateCallable
protected ExecuteUpdateResultCheckStyle[] | updateResultCheckStyles
Fields inherited from interface org.hibernate.persister.entity.Loadable
ROWID_ALIAS
Fields inherited from interface org.hibernate.persister.entity.EntityPersister
ENTITY_ID
Fields inherited from interface org.hibernate.intercept.LazyPropertyInitializer
UNFETCHED_PROPERTY
Constructor Summary
AbstractEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory)
Method Summary
protected void | addDiscriminatorToInsert(Insert insert)
protected void | addDiscriminatorToSelect(SelectFragment select, String name, String suffix)
void | afterInitialize(Object entity, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Called just after the entities properties have been initialized
void | afterReassociate(Object entity, SessionImplementor session) Called just after the entity has been reassociated with the session
boolean | canExtractIdOutOfEntity() Do detached instances of this class carry their own identifier value?
protected boolean | check(int rows, Serializable id, int tableNumber, Expectation expectation, PreparedStatement statement)
protected String | concretePropertySelectFragment(String alias, boolean[] includeProperty)
protected String | concretePropertySelectFragmentSansLeadingComma(String alias, boolean[] include)
boolean | consumesCollectionAlias() Very, very, very ugly...
boolean | consumesEntityAlias() Very, very, very ugly...
int | countSubclassProperties() How many properties are there, for this class and all subclasses?
protected UniqueEntityLoader | createEntityLoader(LockMode lockMode)
protected UniqueEntityLoader | createEntityLoader(LockMode lockMode, Map enabledFilters)
protected String | createFrom(int tableNumber, String alias)
protected JoinFragment | createJoin(int[] tableNumbers, String drivingAlias)
protected JoinFragment | createJoin(String name, boolean innerJoin, boolean includeSubclasses)
Object | createProxy(Serializable id, SessionImplementor session) Create a new proxy instance
protected void | createQueryLoader()
protected SelectFragment | createSelect(int[] subclassColumnNumbers, int[] subclassFormulaNumbers)
protected void | createUniqueKeyLoaders()
protected String | createWhereByKey(int tableNumber, String alias)
protected int | dehydrate(Serializable id, Object[] fields, boolean[] includeProperty, boolean[][] includeColumns, int j, PreparedStatement st, SessionImplementor session)
protected int | dehydrate(Serializable id, Object[] fields, Object rowId, boolean[] includeProperty, boolean[][] includeColumns, int j, PreparedStatement ps, SessionImplementor session, int index) Marshall the fields of a persistent instance to a prepared statement
protected void | delete(Serializable id, Object version, int j, Object object, String sql, SessionImplementor session, Object[] loadedState) Perform an SQL DELETE
void | delete(Serializable id, Object version, Object object, SessionImplementor session) Delete an object
protected abstract String | filterFragment(String alias)
String | filterFragment(String alias, Map enabledFilters) Get the where clause filter, given a query alias and considering enabled session filters
int[] | findDirty(Object[] currentState, Object[] previousState, Object entity, SessionImplementor session) Locate the property-indices of all properties considered to be dirty.
int[] | findModified(Object[] old, Object[] current, Object entity, SessionImplementor session) Locate the property-indices of all properties considered to be dirty.
Object | forceVersionIncrement(Serializable id, Object currentVersion, SessionImplementor session)
String | fromJoinFragment(String alias, boolean innerJoin, boolean includeSubclasses) Get the from clause part of any joins (optional operation)
protected String | generateDeleteString(int j) Generate the SQL that deletes a row by id (and version)
String | generateFilterConditionAlias(String rootAlias) The alias used for any filter conditions (mapped where-fragments or enabled-filters).
protected String | generateIdentityInsertString(boolean[] includeProperty) Used to generate an insery statement against the root table in the case of identifier generation strategies where the insert statement executions actually generates the identifier value.
protected String | generateInsertGeneratedValuesSelectString()
protected String | generateInsertString(boolean[] includeProperty, int j)
protected String | generateInsertString(boolean identityInsert, boolean[] includeProperty)
protected String | generateInsertString(boolean identityInsert, boolean[] includeProperty, int j) Generate the SQL that inserts a row
protected String | generateLazySelectString()
protected LockingStrategy | generateLocker(LockMode lockMode)
protected String | generateSelectVersionString() Generate the SQL that selects the version number by id
protected String | generateSnapshotSelectString()
protected String | generateTableAlias(String rootAlias, int tableNumber)
protected String | generateUpdateGeneratedValuesSelectString()
protected String | generateUpdateString(boolean[] includeProperty, int j, boolean useRowId)
protected String | generateUpdateString(boolean[] includeProperty, int j, Object[] oldFields, boolean useRowId) Generate the SQL that updates a row by id (and version)
CacheConcurrencyStrategy | getCache() Get the cache (optional operation)
CacheEntryStructure | getCacheEntryStructure() Get the cache structure
CascadeStyle | getCascadeStyle(int i) Get the cascade style of this (subclass closure) property
ClassMetadata | getClassMetadata() Get the user-visible metadata for the class (optional operation)
Class | getConcreteProxyClass(EntityMode entityMode) Get the proxy interface that instances of this concrete class will be cast to (optional operation).
Object | getCurrentVersion(Serializable id, SessionImplementor session) Retrieve the version number
Object[] | getDatabaseSnapshot(Serializable id, SessionImplementor session) Get the current database state of the object, in a "hydrated" form, without resolving identifiers
protected String | getDiscriminatorAlias()
String | getDiscriminatorAlias(String suffix) Get the result set aliases used for the identifier columns, given a suffix
String | getDiscriminatorColumnName()
protected String | getDiscriminatorFormulaTemplate()
protected EntityMetamodel | getEntityMetamodel()
String | getEntityName() The name of the entity
EntityType | getEntityType()
SessionFactoryImplementor | getFactory() Return the SessionFactory to which this persister "belongs".
FetchMode | getFetchMode(int i) May this (subclass closure) property be fetched using an SQL outerjoin?
Serializable | getIdentifier(Object object, EntityMode entityMode) Get the identifier of an instance (throw an exception if no identifier property)
protected String[] | getIdentifierAliases()
String[] | getIdentifierAliases(String suffix) Get the result set aliases used for the identifier columns, given a suffix
String[] | getIdentifierColumnNames() Get the names of columns used to persist the identifier
protected int | getIdentifierColumnSpan()
IdentifierGenerator | getIdentifierGenerator() Return the IdentifierGenerator for the class
String | getIdentifierPropertyName() Get the name of the identifier property (or return null)
Type | getIdentifierType() Get the identifier Hibernate type
String | getIdentitySelectString() Get the database-specific SQL command to retrieve the last generated IDENTITY value.
String[] | getKeyColumnNames() The columns to join on
protected abstract String[] | getKeyColumns(int j)
protected Set | getLazyProperties()
Class | getMappedClass(EntityMode entityMode) The persistent class, or null
String | getMappedSuperclass() Get the class that this class is mapped as a subclass of - not necessarily the direct superclass
String | getName() An identifying name; a class name or collection role name.
int[] | getNaturalIdentifierProperties() Which properties hold the natural id?
Object[] | getNaturalIdentifierSnapshot(Serializable id, SessionImplementor session) Retrieve the current state of the natural-id properties from the database.
boolean[] | getNonLazyPropertyUpdateability()
protected boolean[] | getPropertiesToInsert(Object[] fields) Transform the array of property indexes to an array of booleans, true when the property is insertable and non-null
protected boolean[] | getPropertiesToUpdate(int[] dirtyProperties, boolean hasDirtyCollection) Transform the array of property indexes to an array of booleans, true when the property is dirty
String[] | getPropertyAliases(String suffix, int i) Get the result set aliases used for the property columns, given a suffix (properties of this class, only).
CascadeStyle[] | getPropertyCascadeStyles() Get the cascade styles of the propertes (optional operation)
boolean[] | getPropertyCheckability() Get the "checkability" of the properties of this class (is the property dirty checked, does the cache need to be updated)
String[] | getPropertyColumnNames(int i) Get the result set column names mapped for this property (properties of this class, only).
String[] | getPropertyColumnNames(String propertyName) Get the column names for the given property path
protected int | getPropertyColumnSpan(int i)
int | getPropertyIndex(String propertyName) Get the property number of the unique key property
boolean[] | getPropertyInsertability() Get the "insertability" of the properties of this class (does the property appear in an SQL INSERT)
boolean[] | getPropertyInsertGeneration() Which of the properties of this class are database generated values on insert?
boolean[] | getPropertyLaziness() Get the "laziness" of the properties of this class
String[] | getPropertyNames() Get the names of the class' persistent properties
boolean[] | getPropertyNullability() Get the nullability of the class' persistent properties
protected int | getPropertySpan()
protected String[] | getPropertySubclassNames()
protected abstract int[] | getPropertyTableNumbers()
protected abstract int[] | getPropertyTableNumbersInSelect()
Type | getPropertyType(String propertyName) Get the type of a particular (named) property
Type[] | getPropertyTypes() Get the Hibernate types of the class properties
boolean[] | getPropertyUpdateability() Get the "updateability" of the properties of this class (does the property appear in an SQL UPDATE)
protected boolean[] | getPropertyUpdateability(Object entity, EntityMode entityMode) Which properties appear in the SQL update? (Initialized, updateable ones!)
boolean[] | getPropertyUpdateGeneration() Which of the properties of this class are database generated values on update?
Object | getPropertyValue(Object object, int i, EntityMode entityMode) Get the value of a particular property
Object | getPropertyValue(Object object, String propertyName, EntityMode entityMode) Get the value of a particular (named) property
Object[] | getPropertyValues(Object object, EntityMode entityMode) Extract the property values from the given entity.
Object[] | getPropertyValuesToInsert(Object object, Map mergeMap, SessionImplementor session) Return the values of the mapped properties of the object
boolean[] | getPropertyVersionability() Get the "versionability" of the properties of this class (is the property optimistic-locked)
Serializable[] | getQuerySpaces() Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class and its subclasses.
String | getRootEntityName() Returns an object that identifies the space in which identifiers of this class hierarchy are unique.
String[] | getRootTableIdentifierColumnNames() Get the names of columns on the root table used to persist the identifier.
String[] | getRootTableKeyColumnNames() The names of the primary key columns in the root table.
String | getRootTableName() Locks are always applied to the "root table".
String | getSelectByUniqueKeyString(String propertyName) Get a SQL select string that performs a select based on a unique key determined by the given property name).
protected String | getSequentialSelect(String entityName)
protected String[] | getSQLDeleteStrings()
protected String | getSQLIdentityInsertString() The query that inserts a row, letting the database generate an id
protected String[] | getSQLInsertStrings()
protected String | getSQLLazySelectString()
protected String[] | getSQLLazyUpdateByRowIdStrings()
protected String[] | getSQLLazyUpdateStrings()
protected String | getSQLSnapshotSelectString()
protected String[] | getSQLUpdateByRowIdStrings()
protected String[] | getSQLUpdateStrings()
protected String | getSQLWhereString(String alias)
protected String[] | getSubclassColumnAliasClosure()
protected String[] | getSubclassColumnClosure()
protected boolean[] | getSubclassColumnLazyiness()
protected abstract int[] | getSubclassColumnTableNumberClosure()
EntityPersister | getSubclassEntityPersister(Object instance, SessionFactoryImplementor factory, EntityMode entityMode) Get the persister for an instance of this class or a subclass
protected String[] | getSubclassFormulaAliasClosure()
protected String[] | getSubclassFormulaClosure()
protected boolean[] | getSubclassFormulaLazyiness()
protected abstract int[] | getSubclassFormulaTableNumberClosure()
protected String[] | getSubclassFormulaTemplateClosure()
String[] | getSubclassPropertyColumnAliases(String propertyName, String suffix) Return the column alias names used to persist/query the named property of the class or a subclass (optional operation).
protected String[][] | getSubclassPropertyColumnNameClosure()
String[] | getSubclassPropertyColumnNames(int i) Return the column names used to persist the numbered property of the class or a subclass.
String[] | getSubclassPropertyColumnNames(String propertyName) Return the column names used to persist/query the named property of the class or a subclass (optional operation).
protected String[][] | getSubclassPropertyFormulaTemplateClosure()
String | getSubclassPropertyName(int i) Get the name of the numbered property of the class or a subclass.
protected String[] | getSubclassPropertyNameClosure()
protected String[] | getSubclassPropertySubclassNameClosure()
protected abstract int | getSubclassPropertyTableNumber(int i)
int | getSubclassPropertyTableNumber(String propertyPath) Warning: When there are duplicated property names in the subclasses of the class, this method may return the wrong table number for the duplicated subclass property (note that SingleTableEntityPersister defines an overloaded form which takes the entity name.
Type | getSubclassPropertyType(int i) Get the type of the numbered property of the class or a subclass.
protected Type[] | getSubclassPropertyTypeClosure()
protected abstract String[] | getSubclassTableKeyColumns(int j)
abstract String | getSubclassTableName(int j) Get the name of the table with the given index from the internal array.
protected abstract int | getSubclassTableSpan()
protected abstract String | getTableName(int j)
protected abstract int | getTableSpan()
protected boolean[] | getTableUpdateNeeded(int[] dirtyProperties, boolean hasDirtyCollection) Decide which tables need to be updated
String | getTemporaryIdTableDDL() Get the appropriate DDL command for generating the temporary table to be used to (potentially) store id values when performing bulk update/deletes.
String | getTemporaryIdTableName() Get the name of the temporary table to be used to (potentially) store id values when performing bulk update/deletes.
protected EntityTuplizer | getTuplizer(EntityMode entityMode)
protected EntityTuplizer | getTuplizer(SessionImplementor session)
Type | getType() Get the type
Object | getVersion(Object object, EntityMode entityMode) Get the version number (or timestamp) from the object's version property (or return null if not versioned)
String | getVersionColumnName() For versioned entities, get the name of the column (again, expected on the root table) used to store the version values.
Comparator | getVersionComparator() Get the comparator used to compare two different version values together.
protected String | getVersionedTableName()
int | getVersionProperty() Get the index of the version property
protected String | getVersionSelectString()
VersionType | getVersionType() Get the type of versioning (optional operation)
EntityMode | guessEntityMode(Object object) Try to discover the entity mode from the entity instance
boolean | hasCache() Does this class have a cache.
boolean | hasCascades() Does this class declare any cascading save/update/deletes.
boolean | hasCollections() Do instances of this class contain collections.
protected boolean | hasEmbeddedCompositeIdentifier()
protected boolean | hasFormulaProperties()
boolean | hasIdentifierProperty() Does this class have an identifier property?
boolean | hasInsertGeneratedProperties() Does this entity define any properties as being database generated on insert?
boolean | hasLazyProperties() Does this entity define some lazy attributes?
boolean | hasMutableProperties() Does this entity declare any properties of mutable type?
boolean | hasNaturalIdentifier() Does this entity declare a natural id?
boolean | hasProxy() Does this class support dynamic proxies?
boolean | hasRowId() Does the result set contain rowids?
boolean | hasSequentialSelect()
boolean | hasSubclasses() Does this entity have mapped subclasses?
boolean | hasSubselectLoadableCollections() Does this entity own any collections which are fetchable by subselect?
boolean | hasUninitializedLazyProperties(Object object, EntityMode entityMode) Does the given instance have any uninitialized lazy properties?
boolean | hasUpdateGeneratedProperties() Does this entity define any properties as being database generated on update?
protected boolean | hasWhere()
Object[] | hydrate(ResultSet rs, Serializable id, Object object, Loadable rootLoadable, String[][] suffixedPropertyColumns, boolean allProperties, SessionImplementor session) Unmarshall the fields of a persistent instance from a result set, without resolving associations or collections.
String | identifierSelectFragment(String name, String suffix) Given a query alias and an identifying suffix, render the intentifier select fragment.
boolean | implementsLifecycle(EntityMode entityMode) Does the class implement the Lifecycle interface?
boolean | implementsValidatable(EntityMode entityMode) Does the class implement the Validatable interface?
Object | initializeLazyProperty(String fieldName, Object entity, SessionImplementor session) Initialize the property, and return its new value
protected void | initLockers()
protected void | initPropertyPaths(Mapping mapping)
protected void | initSubclassPropertyAliasesMap(PersistentClass model) Must be called by subclasses, at the end of their constructors
protected Serializable | insert(Object[] fields, boolean[] notNull, String sql, Object object, SessionImplementor session) Perform an SQL INSERT, and then retrieve a generated identifier.
Serializable | insert(Object[] fields, Object object, SessionImplementor session) Persist an instance, using a natively generated identifier (optional operation)
protected void | insert(Serializable id, Object[] fields, boolean[] notNull, int j, String sql, Object object, SessionImplementor session) Perform an SQL INSERT.
void | insert(Serializable id, Object[] fields, Object object, SessionImplementor session) Persist an instance
Object | instantiate(Serializable id, EntityMode entityMode) Create a class instance initialized with the given identifier
boolean | isAbstract() Is this an abstract class?
boolean | isBatchable()
boolean | isBatchLoadable() Is batch loading enabled?
boolean | isCacheInvalidationRequired() We can't immediately add to the cache if we have formulas which must be evaluated, or if we have the possibility of two concurrent updates to the same item being merged on the database.
protected abstract boolean | isClassOrSuperclassTable(int j)
boolean | isCollection() Is this instance actually a CollectionPersister?
boolean | isDefinedOnSubclass(int i) Is this property defined on a subclass of the mapped class.
protected boolean | isDeleteCallable(int j)
boolean | isExplicitPolymorphism() Is this class explicit polymorphism only?
boolean | isIdentifierAssignedByInsert() Is the identifier assigned before the insert by an IDGenerator.
boolean | isInherited() Does this entity extend a mapped superclass?
protected boolean | isInsertCallable(int j)
boolean | isInstance(Object object, EntityMode entityMode) Is the given object an instance of this entity?
boolean | isInstrumented(EntityMode entityMode) Has the class actually been bytecode instrumented?
protected boolean | isInverseSubclassTable(int j)
protected boolean | isInverseTable(int j)
boolean | isLazyPropertiesCacheable() Should lazy properties of this entity be cached?
boolean | isMultiTable() Is the inheritence hierarchy described by this persister contained across multiple tables?
boolean | isMutable() Are instances of this class mutable?
protected boolean | isNullableSubclassTable(int j)
protected boolean | isNullableTable(int j)
boolean | isPolymorphic()
protected abstract boolean | isPropertyOfTable(int property, int j)
boolean | isSelectBeforeUpdateRequired() Is select snapshot before update enabled?
boolean | isSubclassEntityName(String entityName) Is the given entity name the name of a subclass, or this class?
protected boolean | isSubclassPropertyDeferred(String propertyName, String entityName)
boolean | isSubclassPropertyNullable(int i) Is the numbered property of the class of subclass nullable?
protected boolean | isSubclassTableLazy(int j)
protected boolean | isSubclassTableSequentialSelect(int j)
protected abstract boolean | isTableCascadeDeleteEnabled(int j)
Boolean | isTransient(Object entity, SessionImplementor session) Is this a new transient instance?
protected boolean | isUpdateCallable(int j)
boolean | isVersioned() Are instances of this class versioned by a timestamp or version number column?
boolean | isVersionPropertyGenerated() Does this entity contain a version property that is defined to be database generated?
boolean | isVersionPropertyInsertable() Is the version property included in insert statements?
Object | load(Serializable id, Object optionalObject, LockMode lockMode, SessionImplementor session) Load an instance using either the forUpdateLoader or the outer joining loader, depending upon the value of the lock parameter
Object | loadByUniqueKey(String propertyName, Object uniqueKey, SessionImplementor session) Load an instance of the persistent class, by a unique key other than the primary key.
void | lock(Serializable id, Object version, Object object, LockMode lockMode, SessionImplementor session) Do a version check (optional operation)
protected void | logStaticSQL()
String | oneToManyFilterFragment(String alias)
protected int | optimisticLockMode()
protected void | postConstruct(Mapping mapping)
void | postInstantiate() Finish the initialization of this object, once all ClassPersisters have been instantiated.
void | processInsertGeneratedProperties(Serializable id, Object entity, Object[] state, SessionImplementor session) Perform a select to retrieve the values of any generated properties back from the database, injecting these generated values into the given entity as well as writing this state to the PersistenceContext.
void | processUpdateGeneratedProperties(Serializable id, Object entity, Object[] state, SessionImplementor session) Perform a select to retrieve the values of any generated properties back from the database, injecting these generated values into the given entity as well as writing this state to the PersistenceContext.
String | propertySelectFragment(String name, String suffix, boolean allProperties) Given a query alias and an identifying suffix, render the property select fragment.
protected String | renderSelect(int[] tableNumbers, int[] columnNumbers, int[] formulaNumbers)
void | resetIdentifier(Object entity, Serializable currentId, Object currentVersion, EntityMode entityMode) Set the identifier and version of the given instance back to its "unsaved" value, returning the id
String | selectFragment(Joinable rhs, String rhsAlias, String lhsAlias, String entitySuffix, String collectionSuffix, boolean includeCollectionColumns) All columns to select, when loading.
String | selectFragment(String alias, String suffix) Generate a list of collection index, key and element columns
void | setIdentifier(Object object, Serializable id, EntityMode entityMode) Set the identifier of an instance (or do nothing if no identifier property)
void | setPropertyValue(Object object, int i, Object value, EntityMode entityMode) Set the value of a particular property
void | setPropertyValue(Object object, String propertyName, Object value, EntityMode entityMode) Set the value of a particular (named) property
void | setPropertyValues(Object object, Object[] values, EntityMode entityMode) Set the given values to the mapped properties of the given object
String[] | toColumns(String propertyName) Given a property path, return the corresponding column name(s).
String[] | toColumns(String name, int i) Given the number of a property of a subclass, and a table alias, return the aliased column names.
String[] | toColumns(String alias, String propertyName) Given a query alias and a property path, return the qualified column name
String | toString()
Type | toType(String propertyName) Given a component path expression, get the type of the property
void | update(Serializable id, Object[] fields, int[] dirtyFields, boolean hasDirtyCollection, Object[] oldFields, Object oldVersion, Object object, Object rowId, SessionImplementor session) Update an object
protected boolean | update(Serializable id, Object[] fields, Object[] oldFields, Object rowId, boolean[] includeProperty, int j, Object oldVersion, Object object, String sql, SessionImplementor session)
protected void | updateOrInsert(Serializable id, Object[] fields, Object[] oldFields, Object rowId, boolean[] includeProperty, int j, Object oldVersion, Object object, String sql, SessionImplementor session) Perform an SQL UPDATE or SQL INSERT
protected boolean | useDynamicInsert()
protected boolean | useDynamicUpdate()
protected boolean | useGetGeneratedKeys()
protected boolean | useInsertSelectIdentity()
String | whereJoinFragment(String alias, boolean innerJoin, boolean includeSubclasses) Get the where clause part of any joins (optional operation)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.persister.entity.OuterJoinLoadable
fromTableFragment, getPropertyTableName, getSubclassPropertyTableName
Methods inherited from interface org.hibernate.persister.entity.Loadable
getDiscriminatorType, getSubclassForDiscriminatorValue
Methods inherited from interface org.hibernate.persister.entity.EntityPersister
getPropertySpaces
Methods inherited from interface org.hibernate.persister.entity.Joinable
getTableName
Methods inherited from interface org.hibernate.persister.entity.Queryable
getConstraintOrderedTableNameClosure, getContraintOrderedTableKeyColumnClosure, getDiscriminatorSQLValue

Field Detail

ENTITY_CLASS

public static final String ENTITY_CLASS
See Also:
Constant Field Values

rowIdName

protected final String rowIdName

insertCallable

protected boolean[] insertCallable

updateCallable

protected boolean[] updateCallable

deleteCallable

protected boolean[] deleteCallable

customSQLInsert

protected String[] customSQLInsert

customSQLUpdate

protected String[] customSQLUpdate

customSQLDelete

protected String[] customSQLDelete

insertResultCheckStyles

protected ExecuteUpdateResultCheckStyle[] insertResultCheckStyles

updateResultCheckStyles

protected ExecuteUpdateResultCheckStyle[] updateResultCheckStyles

deleteResultCheckStyles

protected ExecuteUpdateResultCheckStyle[] deleteResultCheckStyles

propertyMapping

protected final BasicEntityPropertyMapping propertyMapping
Constructor Detail

AbstractEntityPersister

public AbstractEntityPersister(PersistentClass persistentClass,
                               CacheConcurrencyStrategy cache,
                               SessionFactoryImplementor factory)
                        throws HibernateException
Method Detail

addDiscriminatorToInsert

protected void addDiscriminatorToInsert(Insert insert)

addDiscriminatorToSelect

protected void addDiscriminatorToSelect(SelectFragment select,
                                        String name,
                                        String suffix)

getSubclassColumnTableNumberClosure

protected abstract int[] getSubclassColumnTableNumberClosure()

getSubclassFormulaTableNumberClosure

protected abstract int[] getSubclassFormulaTableNumberClosure()

getSubclassTableName

public abstract String getSubclassTableName(int j)
Description copied from interface: Queryable
Get the name of the table with the given index from the internal array.

Specified by:
getSubclassTableName in interface Queryable
Parameters:
j - The index into the internal array.
Returns:

getSubclassTableKeyColumns

protected abstract String[] getSubclassTableKeyColumns(int j)

isClassOrSuperclassTable

protected abstract boolean isClassOrSuperclassTable(int j)

getSubclassTableSpan

protected abstract int getSubclassTableSpan()

getTableSpan

protected abstract int getTableSpan()

isTableCascadeDeleteEnabled

protected abstract boolean isTableCascadeDeleteEnabled(int j)

getTableName

protected abstract String getTableName(int j)

getKeyColumns

protected abstract String[] getKeyColumns(int j)

isPropertyOfTable

protected abstract boolean isPropertyOfTable(int property,
                                             int j)

getPropertyTableNumbersInSelect

protected abstract int[] getPropertyTableNumbersInSelect()

getPropertyTableNumbers

protected abstract int[] getPropertyTableNumbers()

getSubclassPropertyTableNumber

protected abstract int getSubclassPropertyTableNumber(int i)

filterFragment

protected abstract String filterFragment(String alias)
                                  throws MappingException
Throws:
MappingException

getDiscriminatorColumnName

public String getDiscriminatorColumnName()
Specified by:
getDiscriminatorColumnName in interface Loadable
Returns:
the column name for the discriminator as specified in the mapping.

getDiscriminatorAlias

protected String getDiscriminatorAlias()

getDiscriminatorFormulaTemplate

protected String getDiscriminatorFormulaTemplate()

isInverseTable

protected boolean isInverseTable(int j)

isNullableTable

protected boolean isNullableTable(int j)

isNullableSubclassTable

protected boolean isNullableSubclassTable(int j)

isInverseSubclassTable

protected boolean isInverseSubclassTable(int j)

isSubclassEntityName

public boolean isSubclassEntityName(String entityName)
Description copied from interface: EntityPersister
Is the given entity name the name of a subclass, or this class?

Specified by:
isSubclassEntityName in interface EntityPersister

getRootTableKeyColumnNames

public String[] getRootTableKeyColumnNames()
Description copied from interface: PostInsertIdentityPersister
The names of the primary key columns in the root table.

Specified by:
getRootTableKeyColumnNames in interface PostInsertIdentityPersister
Returns:
The primary key column names.

getSQLUpdateByRowIdStrings

protected String[] getSQLUpdateByRowIdStrings()

getSQLLazyUpdateByRowIdStrings

protected String[] getSQLLazyUpdateByRowIdStrings()

getSQLSnapshotSelectString

protected String getSQLSnapshotSelectString()

getSQLLazySelectString

protected String getSQLLazySelectString()

getSQLDeleteStrings

protected String[] getSQLDeleteStrings()

getSQLInsertStrings

protected String[] getSQLInsertStrings()

getSQLUpdateStrings

protected String[] getSQLUpdateStrings()

getSQLLazyUpdateStrings

protected String[] getSQLLazyUpdateStrings()

getSQLIdentityInsertString

protected String getSQLIdentityInsertString()
The query that inserts a row, letting the database generate an id

getVersionSelectString

protected String getVersionSelectString()

isInsertCallable

protected boolean isInsertCallable(int j)

isUpdateCallable

protected boolean isUpdateCallable(int j)

isDeleteCallable

protected boolean isDeleteCallable(int j)

isSubclassPropertyDeferred

protected boolean isSubclassPropertyDeferred(String propertyName,
                                             String entityName)

isSubclassTableSequentialSelect

protected boolean isSubclassTableSequentialSelect(int j)

hasSequentialSelect

public boolean hasSequentialSelect()

getTableUpdateNeeded

protected boolean[] getTableUpdateNeeded(int[] dirtyProperties,
                                         boolean hasDirtyCollection)
Decide which tables need to be updated

hasRowId

public boolean hasRowId()
Description copied from interface: Loadable
Does the result set contain rowids?

Specified by:
hasRowId in interface Loadable

generateLazySelectString

protected String generateLazySelectString()

initializeLazyProperty

public Object initializeLazyProperty(String fieldName,
                                     Object entity,
                                     SessionImplementor session)
                              throws HibernateException
Description copied from interface: LazyPropertyInitializer
Initialize the property, and return its new value

Specified by:
initializeLazyProperty in interface LazyPropertyInitializer
Throws:
HibernateException

isBatchable

public boolean isBatchable()

getQuerySpaces

public Serializable[] getQuerySpaces()
Description copied from interface: EntityPersister
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class and its subclasses.

Specified by:
getQuerySpaces in interface EntityPersister

getLazyProperties

protected Set getLazyProperties()

isBatchLoadable

public boolean isBatchLoadable()
Description copied from interface: EntityPersister
Is batch loading enabled?

Specified by:
isBatchLoadable in interface EntityPersister

getIdentifierColumnNames

public String[] getIdentifierColumnNames()
Description copied from interface: Queryable
Get the names of columns used to persist the identifier

Specified by:
getIdentifierColumnNames in interface Loadable

getIdentifierColumnSpan

protected int getIdentifierColumnSpan()

getIdentifierAliases

protected String[] getIdentifierAliases()

getVersionColumnName

public String getVersionColumnName()
Description copied from interface: Lockable
For versioned entities, get the name of the column (again, expected on the root table) used to store the version values.

Specified by:
getVersionColumnName in interface Lockable
Returns:
The version column name.

getVersionedTableName

protected String getVersionedTableName()

getSubclassColumnLazyiness

protected boolean[] getSubclassColumnLazyiness()

getSubclassFormulaLazyiness

protected boolean[] getSubclassFormulaLazyiness()

isCacheInvalidationRequired

public boolean isCacheInvalidationRequired()
We can't immediately add to the cache if we have formulas which must be evaluated, or if we have the possibility of two concurrent updates to the same item being merged on the database. This can happen if (a) the item is not versioned and either (b) we have dynamic update enabled or (c) we have multiple tables holding the state of the item.

Specified by:
isCacheInvalidationRequired in interface EntityPersister

isLazyPropertiesCacheable

public boolean isLazyPropertiesCacheable()
Description copied from interface: EntityPersister
Should lazy properties of this entity be cached?

Specified by:
isLazyPropertiesCacheable in interface EntityPersister

selectFragment

public String selectFragment(String alias,
                             String suffix)
Description copied from interface: OuterJoinLoadable
Generate a list of collection index, key and element columns

Specified by:
selectFragment in interface OuterJoinLoadable

getIdentifierAliases

public String[] getIdentifierAliases(String suffix)
Description copied from interface: Loadable
Get the result set aliases used for the identifier columns, given a suffix

Specified by:
getIdentifierAliases in interface Loadable

getPropertyAliases

public String[] getPropertyAliases(String suffix,
                                   int i)
Description copied from interface: Loadable
Get the result set aliases used for the property columns, given a suffix (properties of this class, only).

Specified by:
getPropertyAliases in interface Loadable

getDiscriminatorAlias

public String getDiscriminatorAlias(String suffix)
Description copied from interface: Loadable
Get the result set aliases used for the identifier columns, given a suffix

Specified by:
getDiscriminatorAlias in interface Loadable

identifierSelectFragment

public String identifierSelectFragment(String name,
                                       String suffix)
Description copied from interface: Queryable
Given a query alias and an identifying suffix, render the intentifier select fragment.

Specified by:
identifierSelectFragment in interface Queryable

propertySelectFragment

public String propertySelectFragment(String name,
                                     String suffix,
                                     boolean allProperties)
Description copied from interface: Queryable
Given a query alias and an identifying suffix, render the property select fragment.

Specified by:
propertySelectFragment in interface Queryable

getDatabaseSnapshot

public Object[] getDatabaseSnapshot(Serializable id,
                                    SessionImplementor session)
                             throws HibernateException
Description copied from interface: EntityPersister
Get the current database state of the object, in a "hydrated" form, without resolving identifiers

Specified by:
getDatabaseSnapshot in interface EntityPersister
Returns:
null if there is no row in the database
Throws:
HibernateException

generateSelectVersionString

protected String generateSelectVersionString()
Generate the SQL that selects the version number by id

generateInsertGeneratedValuesSelectString

protected String generateInsertGeneratedValuesSelectString()

generateUpdateGeneratedValuesSelectString

protected String generateUpdateGeneratedValuesSelectString()

concretePropertySelectFragment

protected String concretePropertySelectFragment(String alias,
                                                boolean[] includeProperty)

generateSnapshotSelectString

protected String generateSnapshotSelectString()

forceVersionIncrement

public Object forceVersionIncrement(Serializable id,
                                    Object currentVersion,
                                    SessionImplementor session)
Specified by:
forceVersionIncrement in interface EntityPersister

getCurrentVersion

public Object getCurrentVersion(Serializable id,
                                SessionImplementor session)
                         throws HibernateException
Retrieve the version number

Specified by:
getCurrentVersion in interface EntityPersister
Throws:
HibernateException

initLockers

protected void initLockers()

generateLocker

protected LockingStrategy generateLocker(LockMode lockMode)

lock

public void lock(Serializable id,
                 Object version,
                 Object object,
                 LockMode lockMode,
                 SessionImplementor session)
          throws HibernateException
Description copied from interface: EntityPersister
Do a version check (optional operation)

Specified by:
lock in interface EntityPersister
Throws:
HibernateException

getRootTableName

public String getRootTableName()
Description copied from interface: Lockable
Locks are always applied to the "root table".

Specified by:
getRootTableName in interface Lockable
Returns:
The root table name

getRootTableIdentifierColumnNames

public String[] getRootTableIdentifierColumnNames()
Description copied from interface: Lockable
Get the names of columns on the root table used to persist the identifier.

Specified by:
getRootTableIdentifierColumnNames in interface Lockable
Returns:
The root table identifier column names.

toColumns

public String[] toColumns(String alias,
                          String propertyName)
                   throws QueryException
Description copied from interface: PropertyMapping
Given a query alias and a property path, return the qualified column name

Specified by:
toColumns in interface PropertyMapping
Throws:
QueryException

toColumns

public String[] toColumns(String propertyName)
                   throws QueryException
Description copied from interface: PropertyMapping
Given a property path, return the corresponding column name(s).

Specified by:
toColumns in interface PropertyMapping
Throws:
QueryException

toType

public Type toType(String propertyName)
            throws QueryException
Description copied from interface: PropertyMapping
Given a component path expression, get the type of the property

Specified by:
toType in interface PropertyMapping
Throws:
QueryException

getPropertyColumnNames

public String[] getPropertyColumnNames(String propertyName)
Description copied from interface: OuterJoinLoadable
Get the column names for the given property path

Specified by:
getPropertyColumnNames in interface OuterJoinLoadable

getSubclassPropertyTableNumber

public int getSubclassPropertyTableNumber(String propertyPath)
Warning: When there are duplicated property names in the subclasses of the class, this method may return the wrong table number for the duplicated subclass property (note that SingleTableEntityPersister defines an overloaded form which takes the entity name.

Specified by:
getSubclassPropertyTableNumber in interface Queryable
Parameters:
propertyPath - The name of the property.
Returns:
The nunber of the table to which the property is mapped.

generateTableAlias

protected String generateTableAlias(String rootAlias,
                                    int tableNumber)

toColumns

public String[] toColumns(String name,
                          int i)
Description copied from interface: OuterJoinLoadable
Given the number of a property of a subclass, and a table alias, return the aliased column names.

Specified by:
toColumns in interface OuterJoinLoadable

getPropertySubclassNames

protected String[] getPropertySubclassNames()

getPropertyColumnNames

public String[] getPropertyColumnNames(int i)
Description copied from interface: Loadable
Get the result set column names mapped for this property (properties of this class, only).

Specified by:
getPropertyColumnNames in interface Loadable

getPropertyColumnSpan

protected int getPropertyColumnSpan(int i)

hasFormulaProperties

protected boolean hasFormulaProperties()

getFetchMode

public FetchMode getFetchMode(int i)
Description copied from interface: OuterJoinLoadable
May this (subclass closure) property be fetched using an SQL outerjoin?

Specified by:
getFetchMode in interface OuterJoinLoadable

getCascadeStyle

public CascadeStyle getCascadeStyle(int i)
Description copied from interface: OuterJoinLoadable
Get the cascade style of this (subclass closure) property

Specified by:
getCascadeStyle in interface OuterJoinLoadable

getSubclassPropertyType

public Type getSubclassPropertyType(int i)
Description copied from interface: OuterJoinLoadable
Get the type of the numbered property of the class or a subclass.

Specified by:
getSubclassPropertyType in interface OuterJoinLoadable

getSubclassPropertyName

public String getSubclassPropertyName(int i)
Description copied from interface: OuterJoinLoadable
Get the name of the numbered property of the class or a subclass.

Specified by:
getSubclassPropertyName in interface OuterJoinLoadable

countSubclassProperties

public int countSubclassProperties()
Description copied from interface: OuterJoinLoadable
How many properties are there, for this class and all subclasses?

Specified by:
countSubclassProperties in interface OuterJoinLoadable

getSubclassPropertyColumnNames

public String[] getSubclassPropertyColumnNames(int i)
Description copied from interface: OuterJoinLoadable
Return the column names used to persist the numbered property of the class or a subclass.

Specified by:
getSubclassPropertyColumnNames in interface OuterJoinLoadable

isDefinedOnSubclass

public boolean isDefinedOnSubclass(int i)
Description copied from interface: OuterJoinLoadable
Is this property defined on a subclass of the mapped class.

Specified by:
isDefinedOnSubclass in interface OuterJoinLoadable

getSubclassPropertyFormulaTemplateClosure

protected String[][] getSubclassPropertyFormulaTemplateClosure()

getSubclassPropertyTypeClosure

protected Type[] getSubclassPropertyTypeClosure()

getSubclassPropertyColumnNameClosure

protected String[][] getSubclassPropertyColumnNameClosure()

getSubclassPropertyNameClosure

protected String[] getSubclassPropertyNameClosure()

getSubclassPropertySubclassNameClosure

protected String[] getSubclassPropertySubclassNameClosure()

getSubclassColumnClosure

protected String[] getSubclassColumnClosure()

getSubclassColumnAliasClosure

protected String[] getSubclassColumnAliasClosure()

getSubclassFormulaClosure

protected String[] getSubclassFormulaClosure()

getSubclassFormulaTemplateClosure

protected String[] getSubclassFormulaTemplateClosure()

getSubclassFormulaAliasClosure

protected String[] getSubclassFormulaAliasClosure()

getSubclassPropertyColumnAliases

public String[] getSubclassPropertyColumnAliases(String propertyName,
                                                 String suffix)
Description copied from interface: SQLLoadable
Return the column alias names used to persist/query the named property of the class or a subclass (optional operation).

Specified by:
getSubclassPropertyColumnAliases in interface SQLLoadable

getSubclassPropertyColumnNames

public String[] getSubclassPropertyColumnNames(String propertyName)
Description copied from interface: SQLLoadable
Return the column names used to persist/query the named property of the class or a subclass (optional operation).

Specified by:
getSubclassPropertyColumnNames in interface SQLLoadable

initSubclassPropertyAliasesMap

protected void initSubclassPropertyAliasesMap(PersistentClass model)
                                       throws MappingException
Must be called by subclasses, at the end of their constructors

Throws:
MappingException

loadByUniqueKey

public Object loadByUniqueKey(String propertyName,
                              Object uniqueKey,
                              SessionImplementor session)
                       throws HibernateException
Description copied from interface: UniqueKeyLoadable
Load an instance of the persistent class, by a unique key other than the primary key.

Specified by:
loadByUniqueKey in interface UniqueKeyLoadable
Throws:
HibernateException

getPropertyIndex

public int getPropertyIndex(String propertyName)
Description copied from interface: UniqueKeyLoadable
Get the property number of the unique key property

Specified by:
getPropertyIndex in interface UniqueKeyLoadable

createUniqueKeyLoaders

protected void createUniqueKeyLoaders()
                               throws MappingException
Throws:
MappingException

getSQLWhereString

protected String getSQLWhereString(String alias)

hasWhere

protected boolean hasWhere()

initPropertyPaths

protected void initPropertyPaths(Mapping mapping)
                          throws MappingException
Throws:
MappingException

createEntityLoader

protected UniqueEntityLoader createEntityLoader(LockMode lockMode,
                                                Map enabledFilters)
                                         throws MappingException
Throws:
MappingException

createEntityLoader

protected UniqueEntityLoader createEntityLoader(LockMode lockMode)
                                         throws MappingException
Throws:
MappingException

check

protected boolean check(int rows,
                        Serializable id,
                        int tableNumber,
                        Expectation expectation,
                        PreparedStatement statement)
                 throws HibernateException
Throws:
HibernateException

generateUpdateString

protected String generateUpdateString(boolean[] includeProperty,
                                      int j,
                                      boolean useRowId)

generateUpdateString

protected String generateUpdateString(boolean[] includeProperty,
                                      int j,
                                      Object[] oldFields,
                                      boolean useRowId)
Generate the SQL that updates a row by id (and version)

generateInsertString

protected String generateInsertString(boolean[] includeProperty,
                                      int j)

generateInsertString

protected String generateInsertString(boolean identityInsert,
                                      boolean[] includeProperty)

generateInsertString

protected String generateInsertString(boolean identityInsert,
                                      boolean[] includeProperty,
                                      int j)
Generate the SQL that inserts a row

generateIdentityInsertString

protected String generateIdentityInsertString(boolean[] includeProperty)
Used to generate an insery statement against the root table in the case of identifier generation strategies where the insert statement executions actually generates the identifier value.

Parameters:
includeProperty - indices of the properties to include in the insert statement.
Returns:
The insert SQL statement string

generateDeleteString

protected String generateDeleteString(int j)
Generate the SQL that deletes a row by id (and version)

dehydrate

protected int dehydrate(Serializable id,
                        Object[] fields,
                        boolean[] includeProperty,
                        boolean[][] includeColumns,
                        int j,
                        PreparedStatement st,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Throws:
HibernateException
SQLException

dehydrate

protected int dehydrate(Serializable id,
                        Object[] fields,
                        Object rowId,
                        boolean[] includeProperty,
                        boolean[][] includeColumns,
                        int j,
                        PreparedStatement ps,
                        SessionImplementor session,
                        int index)
                 throws SQLException,
                        HibernateException
Marshall the fields of a persistent instance to a prepared statement

Throws:
SQLException
HibernateException

hydrate

public Object[] hydrate(ResultSet rs,
                        Serializable id,
                        Object object,
                        Loadable rootLoadable,
                        String[][] suffixedPropertyColumns,
                        boolean allProperties,
                        SessionImplementor session)
                 throws SQLException,
                        HibernateException
Unmarshall the fields of a persistent instance from a result set, without resolving associations or collections. Question: should this really be here, or should it be sent back to Loader?

Specified by:
hydrate in interface Loadable
Throws:
SQLException
HibernateException

useInsertSelectIdentity

protected boolean useInsertSelectIdentity()

useGetGeneratedKeys

protected boolean useGetGeneratedKeys()

getSequentialSelect

protected String getSequentialSelect(String entityName)

insert

protected Serializable insert(Object[] fields,
                              boolean[] notNull,
                              String sql,
                              Object object,
                              SessionImplementor session)
                       throws HibernateException
Perform an SQL INSERT, and then retrieve a generated identifier.

This form is used for PostInsertIdentifierGenerator-style ids (IDENTITY, select, etc).

Throws:
HibernateException

getIdentitySelectString

public String getIdentitySelectString()
Description copied from interface: PostInsertIdentityPersister
Get the database-specific SQL command to retrieve the last generated IDENTITY value.

Specified by:
getIdentitySelectString in interface PostInsertIdentityPersister
Returns:
The SQL command string

getSelectByUniqueKeyString

public String getSelectByUniqueKeyString(String propertyName)
Description copied from interface: PostInsertIdentityPersister
Get a SQL select string that performs a select based on a unique key determined by the given property name).

Specified by:
getSelectByUniqueKeyString in interface PostInsertIdentityPersister
Parameters:
propertyName - The name of the property which maps to the column(s) to use in the select statement restriction.
Returns:
The SQL select string

insert

protected void insert(Serializable id,
                      Object[] fields,
                      boolean[] notNull,
                      int j,
                      String sql,
                      Object object,
                      SessionImplementor session)
               throws HibernateException
Perform an SQL INSERT.

This for is used for all non-root tables as well as the root table in cases where the identifier value is known before the insert occurs.

Throws:
HibernateException

updateOrInsert

protected void updateOrInsert(Serializable id,
                              Object[] fields,
                              Object[] oldFields,
                              Object rowId,
                              boolean[] includeProperty,
                              int j,
                              Object oldVersion,
                              Object object,
                              String sql,
                              SessionImplementor session)
                       throws HibernateException
Perform an SQL UPDATE or SQL INSERT

Throws:
HibernateException

update

protected boolean update(Serializable id,
                         Object[] fields,
                         Object[] oldFields,
                         Object rowId,
                         boolean[] includeProperty,
                         int j,
                         Object oldVersion,
                         Object object,
                         String sql,
                         SessionImplementor session)
                  throws HibernateException
Throws:
HibernateException

delete

protected void delete(Serializable id,
                      Object version,
                      int j,
                      Object object,
                      String sql,
                      SessionImplementor session,
                      Object[] loadedState)
               throws HibernateException
Perform an SQL DELETE

Throws:
HibernateException

update

public void update(Serializable id,
                   Object[] fields,
                   int[] dirtyFields,
                   boolean hasDirtyCollection,
                   Object[] oldFields,
                   Object oldVersion,
                   Object object,
                   Object rowId,
                   SessionImplementor session)
            throws HibernateException
Update an object

Specified by:
update in interface EntityPersister
Throws:
HibernateException

insert

public Serializable insert(Object[] fields,
                           Object object,
                           SessionImplementor session)
                    throws HibernateException
Description copied from interface: EntityPersister
Persist an instance, using a natively generated identifier (optional operation)

Specified by:
insert in interface EntityPersister
Throws:
HibernateException

insert

public void insert(Serializable id,
                   Object[] fields,
                   Object object,
                   SessionImplementor session)
            throws HibernateException
Description copied from interface: EntityPersister
Persist an instance

Specified by:
insert in interface EntityPersister
Throws:
HibernateException

delete

public void delete(Serializable id,
                   Object version,
                   Object object,
                   SessionImplementor session)
            throws HibernateException
Delete an object

Specified by:
delete in interface EntityPersister
Throws:
HibernateException

logStaticSQL

protected void logStaticSQL()

filterFragment

public String filterFragment(String alias,
                             Map enabledFilters)
                      throws MappingException
Description copied from interface: Joinable
Get the where clause filter, given a query alias and considering enabled session filters

Specified by:
filterFragment in interface Joinable
Throws:
MappingException

generateFilterConditionAlias

public String generateFilterConditionAlias(String rootAlias)
Description copied from interface: Queryable
The alias used for any filter conditions (mapped where-fragments or enabled-filters).

This may or may not be different from the root alias depending upon the inheritence mapping strategy.

Specified by:
generateFilterConditionAlias in interface Queryable
Parameters:
rootAlias - The root alias
Returns:
The alias used for "filter conditions" within the where clause.

oneToManyFilterFragment

public String oneToManyFilterFragment(String alias)
                               throws MappingException
Specified by:
oneToManyFilterFragment in interface Joinable
Throws:
MappingException

fromJoinFragment

public String fromJoinFragment(String alias,
                               boolean innerJoin,
                               boolean includeSubclasses)
Description copied from interface: Joinable
Get the from clause part of any joins (optional operation)

Specified by:
fromJoinFragment in interface Joinable

whereJoinFragment

public String whereJoinFragment(String alias,
                                boolean innerJoin,
                                boolean includeSubclasses)
Description copied from interface: Joinable
Get the where clause part of any joins (optional operation)

Specified by:
whereJoinFragment in interface Joinable

isSubclassTableLazy

protected boolean isSubclassTableLazy(int j)

createJoin

protected JoinFragment createJoin(String name,
                                  boolean innerJoin,
                                  boolean includeSubclasses)

createJoin

protected JoinFragment createJoin(int[] tableNumbers,
                                  String drivingAlias)

createSelect

protected SelectFragment createSelect(int[] subclassColumnNumbers,
                                      int[] subclassFormulaNumbers)

createFrom

protected String createFrom(int tableNumber,
                            String alias)

createWhereByKey

protected String createWhereByKey(int tableNumber,
                                  String alias)

renderSelect

protected String renderSelect(int[] tableNumbers,
                              int[] columnNumbers,
                              int[] formulaNumbers)

postConstruct

protected void postConstruct(Mapping mapping)
                      throws MappingException
Throws:
MappingException

postInstantiate

public void postInstantiate()
                     throws MappingException
Description copied from interface: EntityPersister
Finish the initialization of this object, once all ClassPersisters have been instantiated. Called only once, before any other method.

Specified by:
postInstantiate in interface EntityPersister
Throws:
MappingException

createQueryLoader

protected void createQueryLoader()

load

public Object load(Serializable id,
                   Object optionalObject,
                   LockMode lockMode,
                   SessionImplementor session)
            throws HibernateException
Load an instance using either the forUpdateLoader or the outer joining loader, depending upon the value of the lock parameter

Specified by:
load in interface EntityPersister
Throws:
HibernateException

isSubclassPropertyNullable

public boolean isSubclassPropertyNullable(int i)
Description copied from interface: OuterJoinLoadable
Is the numbered property of the class of subclass nullable?

Specified by:
isSubclassPropertyNullable in interface OuterJoinLoadable

getPropertiesToUpdate

protected final boolean[] getPropertiesToUpdate(int[] dirtyProperties,
                                                boolean hasDirtyCollection)
Transform the array of property indexes to an array of booleans, true when the property is dirty

getPropertiesToInsert

protected boolean[] getPropertiesToInsert(Object[] fields)
Transform the array of property indexes to an array of booleans, true when the property is insertable and non-null

findDirty

public int[] findDirty(Object[] currentState,
                       Object[] previousState,
                       Object entity,
                       SessionImplementor session)
                throws HibernateException
Locate the property-indices of all properties considered to be dirty.

Specified by:
findDirty in interface EntityPersister
Parameters:
currentState - The current state of the entity (the state to be checked).
previousState - The previous state of the entity (the state to be checked against).
entity - The entity for which we are checking state dirtiness.
session - The session in which the check is ccurring.
Returns:
null or the indices of the dirty properties
Throws:
HibernateException

findModified

public int[] findModified(Object[] old,
                          Object[] current,
                          Object entity,
                          SessionImplementor session)
                   throws HibernateException
Locate the property-indices of all properties considered to be dirty.

Specified by:
findModified in interface EntityPersister
Parameters:
old - The old state of the entity.
current - The current state of the entity.
entity - The entity for which we are checking state modification.
session - The session in which the check is ccurring.
Returns:
null or the indices of the modified properties
Throws:
HibernateException

getPropertyUpdateability

protected boolean[] getPropertyUpdateability(Object entity,
                                             EntityMode entityMode)
Which properties appear in the SQL update? (Initialized, updateable ones!)

getTuplizer

protected EntityTuplizer getTuplizer(SessionImplementor session)

getTuplizer

protected EntityTuplizer getTuplizer(EntityMode entityMode)

getFactory

public SessionFactoryImplementor getFactory()
Description copied from interface: EntityPersister
Return the SessionFactory to which this persister "belongs".

Specified by:
getFactory in interface EntityPersister
Returns:
The owning SessionFactory.

getEntityMetamodel

protected EntityMetamodel getEntityMetamodel()

hasCache

public boolean hasCache()
Description copied from interface: EntityPersister
Does this class have a cache.

Specified by:
hasCache in interface EntityPersister

getCache

public CacheConcurrencyStrategy getCache()
Description copied from interface: EntityPersister
Get the cache (optional operation)

Specified by:
getCache in interface EntityPersister

getCacheEntryStructure

public CacheEntryStructure getCacheEntryStructure()
Description copied from interface: EntityPersister
Get the cache structure

Specified by:
getCacheEntryStructure in interface EntityPersister

getVersionComparator

public Comparator getVersionComparator()
Description copied from interface: OptimisticCacheSource
Get the comparator used to compare two different version values together.

Specified by:
getVersionComparator in interface OptimisticCacheSource
Returns:
An appropriate comparator.

getEntityName

public final String getEntityName()
Description copied from interface: ClassMetadata
The name of the entity

Specified by:
getEntityName in interface EntityPersister

getEntityType

public EntityType getEntityType()
Specified by:
getEntityType in interface OuterJoinLoadable

isPolymorphic

public boolean isPolymorphic()

isInherited

public boolean isInherited()
Description copied from interface: ClassMetadata
Does this entity extend a mapped superclass?

Specified by:
isInherited in interface EntityPersister

hasCascades

public boolean hasCascades()
Description copied from interface: EntityPersister
Does this class declare any cascading save/update/deletes.

Specified by:
hasCascades in interface EntityPersister

hasIdentifierProperty

public boolean hasIdentifierProperty()
Description copied from interface: ClassMetadata
Does this class have an identifier property?

Specified by:
hasIdentifierProperty in interface EntityPersister

getVersionType

public VersionType getVersionType()
Description copied from interface: EntityPersister
Get the type of versioning (optional operation)

Specified by:
getVersionType in interface EntityPersister

getVersionProperty

public int getVersionProperty()
Description copied from interface: ClassMetadata
Get the index of the version property

Specified by:
getVersionProperty in interface EntityPersister

isVersioned

public boolean isVersioned()
Description copied from interface: ClassMetadata
Are instances of this class versioned by a timestamp or version number column?

Specified by:
isVersioned in interface EntityPersister

isIdentifierAssignedByInsert

public boolean isIdentifierAssignedByInsert()
Description copied from interface: EntityPersister
Is the identifier assigned before the insert by an IDGenerator. Or is it returned by the insert() method? This determines which form of insert() will be called.

Specified by:
isIdentifierAssignedByInsert in interface EntityPersister

hasLazyProperties

public boolean hasLazyProperties()
Description copied from interface: EntityPersister
Does this entity define some lazy attributes?

Specified by:
hasLazyProperties in interface EntityPersister

afterReassociate

public void afterReassociate(Object entity,
                             SessionImplementor session)
Description copied from interface: EntityPersister
Called just after the entity has been reassociated with the session

Specified by:
afterReassociate in interface EntityPersister

isTransient

public Boolean isTransient(Object entity,
                           SessionImplementor session)
                    throws HibernateException
Description copied from interface: EntityPersister
Is this a new transient instance?

Specified by:
isTransient in interface EntityPersister
Throws:
HibernateException

hasCollections

public boolean hasCollections()
Description copied from interface: EntityPersister
Do instances of this class contain collections.

Specified by:
hasCollections in interface EntityPersister

hasMutableProperties

public boolean hasMutableProperties()
Description copied from interface: EntityPersister
Does this entity declare any properties of mutable type?

Specified by:
hasMutableProperties in interface EntityPersister

isMutable

public boolean isMutable()
Description copied from interface: ClassMetadata
Are instances of this class mutable?

Specified by:
isMutable in interface EntityPersister

isAbstract

public boolean isAbstract()
Description copied from interface: Queryable
Is this an abstract class?

Specified by:
isAbstract in interface Loadable

hasSubclasses

public boolean hasSubclasses()
Description copied from interface: ClassMetadata
Does this entity have mapped subclasses?

Specified by:
hasSubclasses in interface Loadable

hasProxy

public boolean hasProxy()
Description copied from interface: ClassMetadata
Does this class support dynamic proxies?

Specified by:
hasProxy in interface EntityPersister

getIdentifierGenerator

public IdentifierGenerator getIdentifierGenerator()
                                           throws HibernateException
Description copied from interface: EntityPersister
Return the IdentifierGenerator for the class

Specified by:
getIdentifierGenerator in interface EntityPersister
Throws:
HibernateException

getRootEntityName

public String getRootEntityName()
Description copied from interface: EntityPersister
Returns an object that identifies the space in which identifiers of this class hierarchy are unique. A table name, a JNDI URL, etc.

Specified by:
getRootEntityName in interface EntityPersister

getClassMetadata

public ClassMetadata getClassMetadata()
Description copied from interface: EntityPersister
Get the user-visible metadata for the class (optional operation)

Specified by:
getClassMetadata in interface EntityPersister

getMappedSuperclass

public String getMappedSuperclass()
Description copied from interface: Queryable
Get the class that this class is mapped as a subclass of - not necessarily the direct superclass

Specified by:
getMappedSuperclass in interface Queryable

isExplicitPolymorphism

public boolean isExplicitPolymorphism()
Description copied from interface: Queryable
Is this class explicit polymorphism only?

Specified by:
isExplicitPolymorphism in interface Queryable

useDynamicUpdate

protected boolean useDynamicUpdate()

useDynamicInsert

protected boolean useDynamicInsert()

hasEmbeddedCompositeIdentifier

protected boolean hasEmbeddedCompositeIdentifier()

canExtractIdOutOfEntity

public boolean canExtractIdOutOfEntity()
Description copied from interface: EntityPersister
Do detached instances of this class carry their own identifier value?

Specified by:
canExtractIdOutOfEntity in interface EntityPersister

getKeyColumnNames

public String[] getKeyColumnNames()
Description copied from interface: Joinable
The columns to join on

Specified by:
getKeyColumnNames in interface Joinable

getName

public String getName()
Description copied from interface: Joinable
An identifying name; a class name or collection role name.

Specified by:
getName in interface Joinable

isCollection

public boolean isCollection()
Description copied from interface: Joinable
Is this instance actually a CollectionPersister?

Specified by:
isCollection in interface Joinable

consumesEntityAlias

public boolean consumesEntityAlias()
Description copied from interface: Joinable
Very, very, very ugly...

Specified by:
consumesEntityAlias in interface Joinable
Returns:
Does this persister "consume" entity column aliases in the result set?

consumesCollectionAlias

public boolean consumesCollectionAlias()
Description copied from interface: Joinable
Very, very, very ugly...

Specified by:
consumesCollectionAlias in interface Joinable
Returns:
Does this persister "consume" collection column aliases in the result set?

getPropertyType

public Type getPropertyType(String propertyName)
                     throws MappingException
Description copied from interface: ClassMetadata
Get the type of a particular (named) property

Specified by:
getPropertyType in interface EntityPersister
Throws:
MappingException

getType

public Type getType()
Description copied from interface: SQLLoadable
Get the type

Specified by:
getType in interface PropertyMapping

isSelectBeforeUpdateRequired

public boolean isSelectBeforeUpdateRequired()
Description copied from interface: EntityPersister
Is select snapshot before update enabled?

Specified by:
isSelectBeforeUpdateRequired in interface EntityPersister

optimisticLockMode

protected final int optimisticLockMode()

createProxy

public Object createProxy(Serializable id,
                          SessionImplementor session)
                   throws HibernateException
Description copied from interface: EntityPersister
Create a new proxy instance

Specified by:
createProxy in interface EntityPersister
Throws:
HibernateException

toString

public String toString()

selectFragment

public final String selectFragment(Joinable rhs,
                                   String rhsAlias,
                                   String lhsAlias,
                                   String entitySuffix,
                                   String collectionSuffix,
                                   boolean includeCollectionColumns)
Description copied from interface: Joinable
All columns to select, when loading.

Specified by:
selectFragment in interface Joinable

isInstrumented

public boolean isInstrumented(EntityMode entityMode)
Description copied from interface: EntityPersister
Has the class actually been bytecode instrumented?

Specified by:
isInstrumented in interface EntityPersister

hasInsertGeneratedProperties

public boolean hasInsertGeneratedProperties()
Description copied from interface: EntityPersister
Does this entity define any properties as being database generated on insert?

Specified by:
hasInsertGeneratedProperties in interface EntityPersister
Returns:
True if this entity contains at least one property defined as generated (including version property, but not identifier).

hasUpdateGeneratedProperties

public boolean hasUpdateGeneratedProperties()
Description copied from interface: EntityPersister
Does this entity define any properties as being database generated on update?

Specified by:
hasUpdateGeneratedProperties in interface EntityPersister
Returns:
True if this entity contains at least one property defined as generated (including version property, but not identifier).

isVersionPropertyGenerated

public boolean isVersionPropertyGenerated()
Description copied from interface: EntityPersister
Does this entity contain a version property that is defined to be database generated?

Specified by:
isVersionPropertyGenerated in interface EntityPersister
Returns:
true if this entity contains a version property and that property has been marked as generated.

isVersionPropertyInsertable

public boolean isVersionPropertyInsertable()
Description copied from interface: Queryable
Is the version property included in insert statements?

Specified by:
isVersionPropertyInsertable in interface Queryable

afterInitialize

public void afterInitialize(Object entity,
                            boolean lazyPropertiesAreUnfetched,
                            SessionImplementor session)
Description copied from interface: EntityPersister
Called just after the entities properties have been initialized

Specified by:
afterInitialize in interface EntityPersister

getPropertyNames

public String[] getPropertyNames()
Description copied from interface: ClassMetadata
Get the names of the class' persistent properties

Specified by:
getPropertyNames in interface EntityPersister

getPropertyTypes

public Type[] getPropertyTypes()
Description copied from interface: ClassMetadata
Get the Hibernate types of the class properties

Specified by:
getPropertyTypes in interface EntityPersister

getPropertyLaziness

public boolean[] getPropertyLaziness()
Description copied from interface: ClassMetadata
Get the "laziness" of the properties of this class

Specified by:
getPropertyLaziness in interface EntityPersister

getPropertyUpdateability

public boolean[] getPropertyUpdateability()
Description copied from interface: EntityPersister
Get the "updateability" of the properties of this class (does the property appear in an SQL UPDATE)

Specified by:
getPropertyUpdateability in interface EntityPersister

getPropertyCheckability

public boolean[] getPropertyCheckability()
Description copied from interface: EntityPersister
Get the "checkability" of the properties of this class (is the property dirty checked, does the cache need to be updated)

Specified by:
getPropertyCheckability in interface EntityPersister

getNonLazyPropertyUpdateability

public boolean[] getNonLazyPropertyUpdateability()

getPropertyInsertability

public boolean[] getPropertyInsertability()
Description copied from interface: EntityPersister
Get the "insertability" of the properties of this class (does the property appear in an SQL INSERT)

Specified by:
getPropertyInsertability in interface EntityPersister

getPropertyInsertGeneration

public boolean[] getPropertyInsertGeneration()
Description copied from interface: EntityPersister
Which of the properties of this class are database generated values on insert?

Specified by:
getPropertyInsertGeneration in interface EntityPersister

getPropertyUpdateGeneration

public boolean[] getPropertyUpdateGeneration()
Description copied from interface: EntityPersister
Which of the properties of this class are database generated values on update?

Specified by:
getPropertyUpdateGeneration in interface EntityPersister

getPropertyNullability

public boolean[] getPropertyNullability()
Description copied from interface: ClassMetadata
Get the nullability of the class' persistent properties

Specified by:
getPropertyNullability in interface EntityPersister

getPropertyVersionability

public boolean[] getPropertyVersionability()
Description copied from interface: EntityPersister
Get the "versionability" of the properties of this class (is the property optimistic-locked)

Specified by:
getPropertyVersionability in interface EntityPersister

getPropertyCascadeStyles

public CascadeStyle[] getPropertyCascadeStyles()
Description copied from interface: EntityPersister
Get the cascade styles of the propertes (optional operation)

Specified by:
getPropertyCascadeStyles in interface EntityPersister

getMappedClass

public final Class getMappedClass(EntityMode entityMode)
Description copied from interface: ClassMetadata
The persistent class, or null

Specified by:
getMappedClass in interface EntityPersister

implementsLifecycle

public boolean implementsLifecycle(EntityMode entityMode)
Description copied from interface: ClassMetadata
Does the class implement the Lifecycle interface?

Specified by:
implementsLifecycle in interface EntityPersister

implementsValidatable

public boolean implementsValidatable(EntityMode entityMode)
Description copied from interface: ClassMetadata
Does the class implement the Validatable interface?

Specified by:
implementsValidatable in interface EntityPersister

getConcreteProxyClass

public Class getConcreteProxyClass(EntityMode entityMode)
Description copied from interface: EntityPersister
Get the proxy interface that instances of this concrete class will be cast to (optional operation).

Specified by:
getConcreteProxyClass in interface EntityPersister

setPropertyValues

public void setPropertyValues(Object object,
                              Object[] values,
                              EntityMode entityMode)
                       throws HibernateException
Description copied from interface: ClassMetadata
Set the given values to the mapped properties of the given object

Specified by:
setPropertyValues in interface EntityPersister
Throws:
HibernateException

setPropertyValue

public void setPropertyValue(Object object,
                             int i,
                             Object value,
                             EntityMode entityMode)
                      throws HibernateException
Description copied from interface: EntityPersister
Set the value of a particular property

Specified by:
setPropertyValue in interface EntityPersister
Throws:
HibernateException

getPropertyValues

public Object[] getPropertyValues(Object object,
                                  EntityMode entityMode)
                           throws HibernateException
Description copied from interface: ClassMetadata
Extract the property values from the given entity.

Specified by:
getPropertyValues in interface EntityPersister
Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object object,
                               int i,
                               EntityMode entityMode)
                        throws HibernateException
Description copied from interface: EntityPersister
Get the value of a particular property

Specified by:
getPropertyValue in interface EntityPersister
Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object object,
                               String propertyName,
                               EntityMode entityMode)
                        throws HibernateException
Description copied from interface: ClassMetadata
Get the value of a particular (named) property

Specified by:
getPropertyValue in interface EntityPersister
Throws:
HibernateException

getIdentifier

public Serializable getIdentifier(Object object,
                                  EntityMode entityMode)
                           throws HibernateException
Description copied from interface: ClassMetadata
Get the identifier of an instance (throw an exception if no identifier property)

Specified by:
getIdentifier in interface EntityPersister
Throws:
HibernateException

setIdentifier

public void setIdentifier(Object object,
                          Serializable id,
                          EntityMode entityMode)
                   throws HibernateException
Description copied from interface: ClassMetadata
Set the identifier of an instance (or do nothing if no identifier property)

Specified by:
setIdentifier in interface EntityPersister
Throws:
HibernateException

getVersion

public Object getVersion(Object object,
                         EntityMode entityMode)
                  throws HibernateException
Description copied from interface: ClassMetadata
Get the version number (or timestamp) from the object's version property (or return null if not versioned)

Specified by:
getVersion in interface EntityPersister
Throws:
HibernateException

instantiate

public Object instantiate(Serializable id,
                          EntityMode entityMode)
                   throws HibernateException
Description copied from interface: ClassMetadata
Create a class instance initialized with the given identifier

Specified by:
instantiate in interface EntityPersister
Throws:
HibernateException

isInstance

public boolean isInstance(Object object,
                          EntityMode entityMode)
Description copied from interface: EntityPersister
Is the given object an instance of this entity?

Specified by:
isInstance in interface EntityPersister

hasUninitializedLazyProperties

public boolean hasUninitializedLazyProperties(Object object,
                                              EntityMode entityMode)
Description copied from interface: EntityPersister
Does the given instance have any uninitialized lazy properties?

Specified by:
hasUninitializedLazyProperties in interface EntityPersister

resetIdentifier

public void resetIdentifier(Object entity,
                            Serializable currentId,
                            Object currentVersion,
                            EntityMode entityMode)
Description copied from interface: EntityPersister
Set the identifier and version of the given instance back to its "unsaved" value, returning the id

Specified by:
resetIdentifier in interface EntityPersister
Parameters:
currentId - TODO
currentVersion - TODO

getSubclassEntityPersister

public EntityPersister getSubclassEntityPersister(Object instance,
                                                  SessionFactoryImplementor factory,
                                                  EntityMode entityMode)
Description copied from interface: EntityPersister
Get the persister for an instance of this class or a subclass

Specified by:
getSubclassEntityPersister in interface EntityPersister

guessEntityMode

public EntityMode guessEntityMode(Object object)
Description copied from interface: EntityPersister
Try to discover the entity mode from the entity instance

Specified by:
guessEntityMode in interface EntityPersister

isMultiTable

public boolean isMultiTable()
Description copied from interface: Queryable
Is the inheritence hierarchy described by this persister contained across multiple tables?

Specified by:
isMultiTable in interface Queryable
Returns:
True if the inheritence hierarchy is spread across multiple tables; false otherwise.

getTemporaryIdTableName

public String getTemporaryIdTableName()
Description copied from interface: Queryable
Get the name of the temporary table to be used to (potentially) store id values when performing bulk update/deletes.

Specified by:
getTemporaryIdTableName in interface Queryable
Returns:
The appropriate temporary table name.

getTemporaryIdTableDDL

public String getTemporaryIdTableDDL()
Description copied from interface: Queryable
Get the appropriate DDL command for generating the temporary table to be used to (potentially) store id values when performing bulk update/deletes.

Specified by:
getTemporaryIdTableDDL in interface Queryable
Returns:
The appropriate temporary table creation command.

getPropertySpan

protected int getPropertySpan()

getPropertyValuesToInsert

public Object[] getPropertyValuesToInsert(Object object,
                                          Map mergeMap,
                                          SessionImplementor session)
                                   throws HibernateException
Description copied from interface: ClassMetadata
Return the values of the mapped properties of the object

Specified by:
getPropertyValuesToInsert in interface EntityPersister
Throws:
HibernateException

processInsertGeneratedProperties

public void processInsertGeneratedProperties(Serializable id,
                                             Object entity,
                                             Object[] state,
                                             SessionImplementor session)
Description copied from interface: EntityPersister
Perform a select to retrieve the values of any generated properties back from the database, injecting these generated values into the given entity as well as writing this state to the PersistenceContext.

Note, that because we update the PersistenceContext here, callers need to take care that they have already written the initial snapshot to the PersistenceContext before calling this method.

Specified by:
processInsertGeneratedProperties in interface EntityPersister
Parameters:
id - The entity's id value.
entity - The entity for which to get the state.
state -
session - The session

processUpdateGeneratedProperties

public void processUpdateGeneratedProperties(Serializable id,
                                             Object entity,
                                             Object[] state,
                                             SessionImplementor session)
Description copied from interface: EntityPersister
Perform a select to retrieve the values of any generated properties back from the database, injecting these generated values into the given entity as well as writing this state to the PersistenceContext.

Note, that because we update the PersistenceContext here, callers need to take care that they have already written the initial snapshot to the PersistenceContext before calling this method.

Specified by:
processUpdateGeneratedProperties in interface EntityPersister
Parameters:
id - The entity's id value.
entity - The entity for which to get the state.
state -
session - The session

getIdentifierPropertyName

public String getIdentifierPropertyName()
Description copied from interface: ClassMetadata
Get the name of the identifier property (or return null)

Specified by:
getIdentifierPropertyName in interface EntityPersister

getIdentifierType

public Type getIdentifierType()
Description copied from interface: ClassMetadata
Get the identifier Hibernate type

Specified by:
getIdentifierType in interface EntityPersister

hasSubselectLoadableCollections

public boolean hasSubselectLoadableCollections()
Description copied from interface: EntityPersister
Does this entity own any collections which are fetchable by subselect?

Specified by:
hasSubselectLoadableCollections in interface EntityPersister

getNaturalIdentifierProperties

public int[] getNaturalIdentifierProperties()
Description copied from interface: ClassMetadata
Which properties hold the natural id?

Specified by:
getNaturalIdentifierProperties in interface EntityPersister

getNaturalIdentifierSnapshot

public Object[] getNaturalIdentifierSnapshot(Serializable id,
                                             SessionImplementor session)
                                      throws HibernateException
Description copied from interface: EntityPersister
Retrieve the current state of the natural-id properties from the database.

Specified by:
getNaturalIdentifierSnapshot in interface EntityPersister
Parameters:
id - The identifier of the entity for which to retrieve the naturak-id values.
session - The session from which the request originated.
Returns:
The natural-id snapshot.
Throws:
HibernateException

concretePropertySelectFragmentSansLeadingComma

protected String concretePropertySelectFragmentSansLeadingComma(String alias,
                                                                boolean[] include)

hasNaturalIdentifier

public boolean hasNaturalIdentifier()
Description copied from interface: ClassMetadata
Does this entity declare a natural id?

Specified by:
hasNaturalIdentifier in interface EntityPersister

setPropertyValue

public void setPropertyValue(Object object,
                             String propertyName,
                             Object value,
                             EntityMode entityMode)
                      throws HibernateException
Description copied from interface: ClassMetadata
Set the value of a particular (named) property

Specified by:
setPropertyValue in interface ClassMetadata
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractPropertyMapping (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Class AbstractPropertyMapping

java.lang.Object
    extended by org.hibernate.persister.entity.AbstractPropertyMapping
All Implemented Interfaces:
PropertyMapping
Direct Known Subclasses:
BasicEntityPropertyMapping, CompositeElementPropertyMapping
public abstract class AbstractPropertyMapping
extends Object
implements PropertyMapping

Base implementation of a PropertyMapping

Author:
Gavin King

Constructor Summary
AbstractPropertyMapping()
Method Summary
protected void | addPropertyPath(String path, Type type, String[] columns, String[] formulaTemplates)
String[] | getColumnNames(String propertyName)
protected abstract String | getEntityName()
String[] | getIdentifierColumnNames()
protected void | initComponentPropertyPaths(String path, AbstractComponentType type, String[] columns, String[] formulaTemplates, Mapping factory)
protected void | initIdentifierPropertyPaths(String path, EntityType etype, String[] columns, Mapping factory)
protected void | initPropertyPaths(String path, Type type, String[] columns, String[] formulaTemplates, Mapping factory)
protected void | throwPropertyException(String propertyName)
String[] | toColumns(String propertyName) Given a property path, return the corresponding column name(s).
String[] | toColumns(String alias, String propertyName) Given a query alias and a property path, return the qualified column name
Type | toType(String propertyName) Given a component path expression, get the type of the property
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.persister.entity.PropertyMapping
getType

Constructor Detail

AbstractPropertyMapping

public AbstractPropertyMapping()
Method Detail

getIdentifierColumnNames

public String[] getIdentifierColumnNames()

getEntityName

protected abstract String getEntityName()

toType

public Type toType(String propertyName)
            throws QueryException
Description copied from interface: PropertyMapping
Given a component path expression, get the type of the property

Specified by:
toType in interface PropertyMapping
Throws:
QueryException

throwPropertyException

protected final void throwPropertyException(String propertyName)
                                     throws QueryException
Throws:
QueryException

getColumnNames

public String[] getColumnNames(String propertyName)

toColumns

public String[] toColumns(String alias,
                          String propertyName)
                   throws QueryException
Description copied from interface: PropertyMapping
Given a query alias and a property path, return the qualified column name

Specified by:
toColumns in interface PropertyMapping
Throws:
QueryException

toColumns

public String[] toColumns(String propertyName)
                   throws QueryException
Description copied from interface: PropertyMapping
Given a property path, return the corresponding column name(s).

Specified by:
toColumns in interface PropertyMapping
Throws:
QueryException

addPropertyPath

protected void addPropertyPath(String path,
                               Type type,
                               String[] columns,
                               String[] formulaTemplates)

initPropertyPaths

protected void initPropertyPaths(String path,
                                 Type type,
                                 String[] columns,
                                 String[] formulaTemplates,
                                 Mapping factory)
                          throws MappingException
Throws:
MappingException

initIdentifierPropertyPaths

protected void initIdentifierPropertyPaths(String path,
                                           EntityType etype,
                                           String[] columns,
                                           Mapping factory)
                                    throws MappingException
Throws:
MappingException

initComponentPropertyPaths

protected void initComponentPropertyPaths(String path,
                                          AbstractComponentType type,
                                          String[] columns,
                                          String[] formulaTemplates,
                                          Mapping factory)
                                   throws MappingException
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BasicEntityPropertyMapping (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Class BasicEntityPropertyMapping

java.lang.Object
    extended by org.hibernate.persister.entity.AbstractPropertyMapping
        extended by org.hibernate.persister.entity.BasicEntityPropertyMapping
All Implemented Interfaces:
PropertyMapping
public class BasicEntityPropertyMapping
extends AbstractPropertyMapping

Author:
Gavin King

Constructor Summary
BasicEntityPropertyMapping(AbstractEntityPersister persister)
Method Summary
protected String | getEntityName()
String[] | getIdentifierColumnNames()
Type | getType() Get the type of the thing containing the properties
String[] | toColumns(String alias, String propertyName) Given a query alias and a property path, return the qualified column name
Methods inherited from class org.hibernate.persister.entity.AbstractPropertyMapping
addPropertyPath, getColumnNames, initComponentPropertyPaths, initIdentifierPropertyPaths, initPropertyPaths, throwPropertyException, toColumns, toType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BasicEntityPropertyMapping

public BasicEntityPropertyMapping(AbstractEntityPersister persister)
Method Detail

getIdentifierColumnNames

public String[] getIdentifierColumnNames()
Overrides:
getIdentifierColumnNames in class AbstractPropertyMapping

getEntityName

protected String getEntityName()
Specified by:
getEntityName in class AbstractPropertyMapping

getType

public Type getType()
Description copied from interface: PropertyMapping
Get the type of the thing containing the properties

toColumns

public String[] toColumns(String alias,
                          String propertyName)
                   throws QueryException
Description copied from interface: PropertyMapping
Given a query alias and a property path, return the qualified column name

Specified by:
toColumns in interface PropertyMapping
Overrides:
toColumns in class AbstractPropertyMapping
Throws:
QueryException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JoinedSubclassEntityPersister (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Class JoinedSubclassEntityPersister

java.lang.Object
    extended by org.hibernate.persister.entity.AbstractEntityPersister
        extended by org.hibernate.persister.entity.JoinedSubclassEntityPersister
All Implemented Interfaces:
ClassMetadata, EntityPersister, Joinable, LazyPropertyInitializer, Loadable, Lockable, OptimisticCacheSource, OuterJoinLoadable, PostInsertIdentityPersister, PropertyMapping, Queryable, SQLLoadable, UniqueKeyLoadable
public class JoinedSubclassEntityPersister
extends AbstractEntityPersister

An EntityPersister implementing the normalized "table-per-subclass" mapping strategy

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.persister.entity.AbstractEntityPersister
customSQLDelete, customSQLInsert, customSQLUpdate, deleteCallable, deleteResultCheckStyles, ENTITY_CLASS, insertCallable, insertResultCheckStyles, propertyMapping, rowIdName, updateCallable, updateResultCheckStyles
Fields inherited from interface org.hibernate.persister.entity.Loadable
ROWID_ALIAS
Fields inherited from interface org.hibernate.persister.entity.EntityPersister
ENTITY_ID
Fields inherited from interface org.hibernate.intercept.LazyPropertyInitializer
UNFETCHED_PROPERTY
Constructor Summary
JoinedSubclassEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
Method Summary
 void addDiscriminatorToSelect(SelectFragment select, String name, String suffix)
 String filterFragment(String alias)
 String fromTableFragment(String alias)
Get the main from table fragment, given a query alias.
 String generateFilterConditionAlias(String rootAlias)
The alias used for any filter conditions (mapped where-fragments or enabled-filters).
 String[] getConstraintOrderedTableNameClosure()
Get the names of all tables used in the hierarchy (up and down) ordered such that deletes in the given order would not cause contraint violations.
 String[][] getContraintOrderedTableKeyColumnClosure()
For each table specified in getConstraintOrderedTableNameClosure(), get the columns that define the key between the various hierarchy classes.
 String getDiscriminatorSQLValue()
Get the discriminator value for this particular concrete subclass, as a string that may be embedded in a select statement
 Type getDiscriminatorType()
Get the discriminator type
 String[] getIdentifierColumnNames()
Get the names of columns used to persist the identifier
protected  String[] getKeyColumns(int j)
 Serializable[] getPropertySpaces()
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class only.
 String getPropertyTableName(String propertyName)
Get the table name for the given property path
protected  int[] getPropertyTableNumbers()
protected  int[] getPropertyTableNumbersInSelect()
 String getRootTableName()
Locks are always applied to the "root table".
protected  int[] getSubclassColumnTableNumberClosure()
 String getSubclassForDiscriminatorValue(Object value)
Get the concrete subclass corresponding to the given discriminator value
protected  int[] getSubclassFormulaTableNumberClosure()
 String getSubclassPropertyTableName(int i)
Return the table name used to persist the numbered property of the class or a subclass.
protected  int getSubclassPropertyTableNumber(int i)
protected  String[] getSubclassTableKeyColumns(int j)
 String getSubclassTableName(int j)
Get the name of the table with the given index from the internal array.
 int getSubclassTableSpan()
 String getTableName()
The table to join to.
protected  String getTableName(int j)
 int getTableSpan()
protected  boolean isClassOrSuperclassTable(int j)
 boolean isMultiTable()
Is the inheritence hierarchy described by this persister contained across multiple tables?
protected  boolean isPropertyOfTable(int property, int j)
protected  boolean isTableCascadeDeleteEnabled(int j)
 String[] toColumns(String alias, String propertyName)
Given a query alias and a property path, return the qualified column name
Methods inherited from class org.hibernate.persister.entity.AbstractEntityPersister
addDiscriminatorToInsert, afterInitialize, afterReassociate, canExtractIdOutOfEntity, check, concretePropertySelectFragment, concretePropertySelectFragmentSansLeadingComma, consumesCollectionAlias, consumesEntityAlias, countSubclassProperties, createEntityLoader, createEntityLoader, createFrom, createJoin, createJoin, createProxy, createQueryLoader, createSelect, createUniqueKeyLoaders, createWhereByKey, dehydrate, dehydrate, delete, delete, filterFragment, findDirty, findModified, forceVersionIncrement, fromJoinFragment, generateDeleteString, generateIdentityInsertString, generateInsertGeneratedValuesSelectString, generateInsertString, generateInsertString, generateInsertString, generateLazySelectString, generateLocker, generateSelectVersionString, generateSnapshotSelectString, generateTableAlias, generateUpdateGeneratedValuesSelectString, generateUpdateString, generateUpdateString, getCache, getCacheEntryStructure, getCascadeStyle, getClassMetadata, getConcreteProxyClass, getCurrentVersion, getDatabaseSnapshot, getDiscriminatorAlias, getDiscriminatorAlias, getDiscriminatorColumnName, getDiscriminatorFormulaTemplate, getEntityMetamodel, getEntityName, getEntityType, getFactory, getFetchMode, getIdentifier, getIdentifierAliases, getIdentifierAliases, getIdentifierColumnSpan, getIdentifierGenerator, getIdentifierPropertyName, getIdentifierType, getIdentitySelectString, getKeyColumnNames, getLazyProperties, getMappedClass, getMappedSuperclass, getName, getNaturalIdentifierProperties, getNaturalIdentifierSnapshot, getNonLazyPropertyUpdateability, getPropertiesToInsert, getPropertiesToUpdate, getPropertyAliases, getPropertyCascadeStyles, getPropertyCheckability, getPropertyColumnNames, getPropertyColumnNames, getPropertyColumnSpan, getPropertyIndex, getPropertyInsertability, getPropertyInsertGeneration, getPropertyLaziness, getPropertyNames, getPropertyNullability, getPropertySpan, getPropertySubclassNames, getPropertyType, getPropertyTypes, getPropertyUpdateability, getPropertyUpdateability, getPropertyUpdateGeneration, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValuesToInsert, getPropertyVersionability, getQuerySpaces, getRootEntityName, getRootTableIdentifierColumnNames, getRootTableKeyColumnNames, getSelectByUniqueKeyString, getSequentialSelect, getSQLDeleteStrings, getSQLIdentityInsertString, getSQLInsertStrings, getSQLLazySelectString, getSQLLazyUpdateByRowIdStrings, getSQLLazyUpdateStrings, getSQLSnapshotSelectString, getSQLUpdateByRowIdStrings, getSQLUpdateStrings, getSQLWhereString, getSubclassColumnAliasClosure, getSubclassColumnClosure, getSubclassColumnLazyiness, getSubclassEntityPersister, getSubclassFormulaAliasClosure, getSubclassFormulaClosure, getSubclassFormulaLazyiness, getSubclassFormulaTemplateClosure, getSubclassPropertyColumnAliases, getSubclassPropertyColumnNameClosure, getSubclassPropertyColumnNames, getSubclassPropertyColumnNames, getSubclassPropertyFormulaTemplateClosure, getSubclassPropertyName, getSubclassPropertyNameClosure, getSubclassPropertySubclassNameClosure, getSubclassPropertyTableNumber, getSubclassPropertyType, getSubclassPropertyTypeClosure, getTableUpdateNeeded, getTemporaryIdTableDDL, getTemporaryIdTableName, getTuplizer, getTuplizer, getType, getVersion, getVersionColumnName, getVersionComparator, getVersionedTableName, getVersionProperty, getVersionSelectString, getVersionType, guessEntityMode, hasCache, hasCascades, hasCollections, hasEmbeddedCompositeIdentifier, hasFormulaProperties, hasIdentifierProperty, hasInsertGeneratedProperties, hasLazyProperties, hasMutableProperties, hasNaturalIdentifier, hasProxy, hasRowId, hasSequentialSelect, hasSubclasses, hasSubselectLoadableCollections, hasUninitializedLazyProperties, hasUpdateGeneratedProperties, hasWhere, hydrate, identifierSelectFragment, implementsLifecycle, implementsValidatable, initializeLazyProperty, initLockers, initPropertyPaths, initSubclassPropertyAliasesMap, insert, insert, insert, insert, instantiate, isAbstract, isBatchable, isBatchLoadable, isCacheInvalidationRequired, isCollection, isDefinedOnSubclass, isDeleteCallable, isExplicitPolymorphism, isIdentifierAssignedByInsert, isInherited, isInsertCallable, isInstance, isInstrumented, isInverseSubclassTable, isInverseTable, isLazyPropertiesCacheable, isMutable, isNullableSubclassTable, isNullableTable, isPolymorphic, isSelectBeforeUpdateRequired, isSubclassEntityName, isSubclassPropertyDeferred, isSubclassPropertyNullable, isSubclassTableLazy, isSubclassTableSequentialSelect, isTransient, isUpdateCallable, isVersioned, isVersionPropertyGenerated, isVersionPropertyInsertable, load, loadByUniqueKey, lock, logStaticSQL, oneToManyFilterFragment, optimisticLockMode, postConstruct, postInstantiate, processInsertGeneratedProperties, processUpdateGeneratedProperties, propertySelectFragment, renderSelect, resetIdentifier, selectFragment, selectFragment, setIdentifier, setPropertyValue, setPropertyValue, setPropertyValues, toColumns, toColumns, toString, toType, update, update, updateOrInsert, useDynamicInsert, useDynamicUpdate, useGetGeneratedKeys, useInsertSelectIdentity, whereJoinFragment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JoinedSubclassEntityPersister

public JoinedSubclassEntityPersister(PersistentClass persistentClass,
                                     CacheConcurrencyStrategy cache,
                                     SessionFactoryImplementor factory,
                                     Mapping mapping)
                              throws HibernateException
Method Detail

getSubclassPropertyTableName

public String getSubclassPropertyTableName(int i)
Description copied from interface: OuterJoinLoadable
Return the table name used to persist the numbered property of the class or a subclass.

getDiscriminatorType

public Type getDiscriminatorType()
Description copied from interface: Loadable
Get the discriminator type

getDiscriminatorSQLValue

public String getDiscriminatorSQLValue()
Description copied from interface: Queryable
Get the discriminator value for this particular concrete subclass, as a string that may be embedded in a select statement

getSubclassForDiscriminatorValue

public String getSubclassForDiscriminatorValue(Object value)
Description copied from interface: Loadable
Get the concrete subclass corresponding to the given discriminator value

getPropertySpaces

public Serializable[] getPropertySpaces()
Description copied from interface: EntityPersister
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class only.

getTableName

protected String getTableName(int j)
Specified by:
getTableName in class AbstractEntityPersister

getKeyColumns

protected String[] getKeyColumns(int j)
Specified by:
getKeyColumns in class AbstractEntityPersister

isTableCascadeDeleteEnabled

protected boolean isTableCascadeDeleteEnabled(int j)
Specified by:
isTableCascadeDeleteEnabled in class AbstractEntityPersister

isPropertyOfTable

protected boolean isPropertyOfTable(int property,
                                    int j)
Specified by:
isPropertyOfTable in class AbstractEntityPersister

fromTableFragment

public String fromTableFragment(String alias)
Description copied from interface: OuterJoinLoadable
Get the main from table fragment, given a query alias.

getTableName

public String getTableName()
Description copied from interface: Joinable
The table to join to.

addDiscriminatorToSelect

public void addDiscriminatorToSelect(SelectFragment select,
                                     String name,
                                     String suffix)
Overrides:
addDiscriminatorToSelect in class AbstractEntityPersister

filterFragment

public String filterFragment(String alias)
Specified by:
filterFragment in class AbstractEntityPersister

generateFilterConditionAlias

public String generateFilterConditionAlias(String rootAlias)
Description copied from interface: Queryable
The alias used for any filter conditions (mapped where-fragments or enabled-filters).

This may or may not be different from the root alias depending upon the inheritence mapping strategy.

Specified by:
generateFilterConditionAlias in interface Queryable
Overrides:
generateFilterConditionAlias in class AbstractEntityPersister

getIdentifierColumnNames

public String[] getIdentifierColumnNames()
Description copied from interface: Queryable
Get the names of columns used to persist the identifier

Specified by:
getIdentifierColumnNames in interface Loadable
Overrides:
getIdentifierColumnNames in class AbstractEntityPersister

toColumns

public String[] toColumns(String alias,
                          String propertyName)
                   throws QueryException
Description copied from interface: PropertyMapping
Given a query alias and a property path, return the qualified column name

Specified by:
toColumns in interface PropertyMapping
Overrides:
toColumns in class AbstractEntityPersister
Throws:
QueryException

getPropertyTableNumbersInSelect

protected int[] getPropertyTableNumbersInSelect()
Specified by:
getPropertyTableNumbersInSelect in class AbstractEntityPersister

getSubclassPropertyTableNumber

protected int getSubclassPropertyTableNumber(int i)
Specified by:
getSubclassPropertyTableNumber in class AbstractEntityPersister

getTableSpan

public int getTableSpan()
Specified by:
getTableSpan in class AbstractEntityPersister

isMultiTable

public boolean isMultiTable()
Description copied from interface: Queryable
Is the inheritence hierarchy described by this persister contained across multiple tables?

Specified by:
isMultiTable in interface Queryable
Overrides:
isMultiTable in class AbstractEntityPersister

getSubclassColumnTableNumberClosure

protected int[] getSubclassColumnTableNumberClosure()
Specified by:
getSubclassColumnTableNumberClosure in class AbstractEntityPersister

getSubclassFormulaTableNumberClosure

protected int[] getSubclassFormulaTableNumberClosure()
Specified by:
getSubclassFormulaTableNumberClosure in class AbstractEntityPersister

getPropertyTableNumbers

protected int[] getPropertyTableNumbers()
Specified by:
getPropertyTableNumbers in class AbstractEntityPersister

getSubclassTableKeyColumns

protected String[] getSubclassTableKeyColumns(int j)
Specified by:
getSubclassTableKeyColumns in class AbstractEntityPersister

getSubclassTableName

public String getSubclassTableName(int j)
Description copied from interface: Queryable
Get the name of the table with the given index from the internal array.

Specified by:
getSubclassTableName in interface Queryable
Specified by:
getSubclassTableName in class AbstractEntityPersister

getSubclassTableSpan

public int getSubclassTableSpan()
Specified by:
getSubclassTableSpan in class AbstractEntityPersister

isClassOrSuperclassTable

protected boolean isClassOrSuperclassTable(int j)
Specified by:
isClassOrSuperclassTable in class AbstractEntityPersister

getPropertyTableName

public String getPropertyTableName(String propertyName)
Description copied from interface: OuterJoinLoadable
Get the table name for the given property path

getConstraintOrderedTableNameClosure

public String[] getConstraintOrderedTableNameClosure()
Description copied from interface: Queryable
Get the names of all tables used in the hierarchy (up and down) ordered such that deletes in the given order would not cause contraint violations.

Returns:
The ordered array of table names.

getContraintOrderedTableKeyColumnClosure

public String[][] getContraintOrderedTableKeyColumnClosure()
Description copied from interface: Queryable
For each table specified in Queryable.getConstraintOrderedTableNameClosure(), get the columns that define the key between the various hierarchy classes.

The first dimension here corresponds to the table indexes returned in Queryable.getConstraintOrderedTableNameClosure().

The second dimension should have the same length across all the elements in the first dimension. If not, that'd be a problem ;)

Returns:

getRootTableName

public String getRootTableName()
Description copied from interface: Lockable
Locks are always applied to the "root table".

Specified by:
getRootTableName in interface Lockable
Overrides:
getRootTableName in class AbstractEntityPersister
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamedQueryLoader (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Class NamedQueryLoader

java.lang.Object
    extended by org.hibernate.persister.entity.NamedQueryLoader
All Implemented Interfaces:
UniqueEntityLoader
public final class NamedQueryLoader
extends Object
implements UniqueEntityLoader

Not really a Loader, just a wrapper around a named query.

Author:
Gavin King

Constructor Summary
NamedQueryLoader(String queryName, EntityPersister persister)
Method Summary
 Object load(Serializable id, Object optionalObject, SessionImplementor session)
Load an entity instance.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NamedQueryLoader

public NamedQueryLoader(String queryName,
                        EntityPersister persister)
Method Detail

load

public Object load(Serializable id,
                   Object optionalObject,
                   SessionImplementor session)
            throws HibernateException
Description copied from interface: UniqueEntityLoader
Load an entity instance. If optionalObject is supplied, load the entity state into the given (uninitialized) object.

Specified by:
load in interface UniqueEntityLoader
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SingleTableEntityPersister (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Class SingleTableEntityPersister

java.lang.Object
    extended by org.hibernate.persister.entity.AbstractEntityPersister
        extended by org.hibernate.persister.entity.SingleTableEntityPersister
All Implemented Interfaces:
ClassMetadata, EntityPersister, Joinable, LazyPropertyInitializer, Loadable, Lockable, OptimisticCacheSource, OuterJoinLoadable, PostInsertIdentityPersister, PropertyMapping, Queryable, SQLLoadable, UniqueKeyLoadable
public class SingleTableEntityPersister
extends AbstractEntityPersister

The default implementation of the EntityPersister interface. Implements the "table-per-class-hierarchy" or "roll-up" mapping strategy for an entity class and its inheritence hierarchy. This is implemented as a single table holding all classes in the hierarchy with a discrimator column used to determine which concrete class is referenced.

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.persister.entity.AbstractEntityPersister
customSQLDelete, customSQLInsert, customSQLUpdate, deleteCallable, deleteResultCheckStyles, ENTITY_CLASS, insertCallable, insertResultCheckStyles, propertyMapping, rowIdName, updateCallable, updateResultCheckStyles
Fields inherited from interface org.hibernate.persister.entity.Loadable
ROWID_ALIAS
Fields inherited from interface org.hibernate.persister.entity.EntityPersister
ENTITY_ID
Fields inherited from interface org.hibernate.intercept.LazyPropertyInitializer
UNFETCHED_PROPERTY
Constructor Summary
SingleTableEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
Method Summary
protected  void addDiscriminatorToInsert(Insert insert)
protected  void addDiscriminatorToSelect(SelectFragment select, String name, String suffix)
 String filterFragment(String alias)
 String fromTableFragment(String name)
Get the main from table fragment, given a query alias.
 String[] getConstraintOrderedTableNameClosure()
Get the names of all tables used in the hierarchy (up and down) ordered such that deletes in the given order would not cause contraint violations.
 String[][] getContraintOrderedTableKeyColumnClosure()
For each table specified in getConstraintOrderedTableNameClosure(), get the columns that define the key between the various hierarchy classes.
protected  String getDiscriminatorAlias()
 String getDiscriminatorColumnName()
protected  String getDiscriminatorFormula()
protected  String getDiscriminatorFormulaTemplate()
 String getDiscriminatorSQLValue()
Get the discriminator value for this particular concrete subclass, as a string that may be embedded in a select statement
 Type getDiscriminatorType()
Get the discriminator type
protected  String[] getKeyColumns(int j)
 Serializable[] getPropertySpaces()
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class only.
 String getPropertyTableName(String propertyName)
Get the table name for the given property path
protected  int[] getPropertyTableNumbers()
protected  int[] getPropertyTableNumbersInSelect()
protected  String getSequentialSelect(String entityName)
 String[] getSubclassClosure()
protected  int[] getSubclassColumnTableNumberClosure()
 String getSubclassForDiscriminatorValue(Object value)
Get the concrete subclass corresponding to the given discriminator value
protected  int[] getSubclassFormulaTableNumberClosure()
 String getSubclassPropertyTableName(int i)
Return the table name used to persist the numbered property of the class or a subclass.
protected  int getSubclassPropertyTableNumber(int i)
protected  String[] getSubclassTableKeyColumns(int j)
 String getSubclassTableName(int j)
Get the name of the table with the given index from the internal array.
 int getSubclassTableSpan()
 String getTableName()
The table to join to.
protected  String getTableName(int j)
 int getTableSpan()
 boolean hasSequentialSelect()
protected  boolean isClassOrSuperclassTable(int j)
protected  boolean isDiscriminatorFormula()
protected  boolean isInverseSubclassTable(int j)
protected  boolean isInverseTable(int j)
 boolean isMultiTable()
Is the inheritence hierarchy described by this persister contained across multiple tables?
protected  boolean isNullableSubclassTable(int j)
protected  boolean isNullableTable(int j)
protected  boolean isPropertyOfTable(int property, int j)
protected  boolean isSubclassPropertyDeferred(String propertyName, String entityName)
protected  boolean isSubclassTableLazy(int j)
protected  boolean isSubclassTableSequentialSelect(int j)
protected  boolean isTableCascadeDeleteEnabled(int j)
 String oneToManyFilterFragment(String alias)
 void postInstantiate()
Finish the initialization of this object, once all ClassPersisters have been instantiated.
Methods inherited from class org.hibernate.persister.entity.AbstractEntityPersister
afterInitialize, afterReassociate, canExtractIdOutOfEntity, check, concretePropertySelectFragment, concretePropertySelectFragmentSansLeadingComma, consumesCollectionAlias, consumesEntityAlias, countSubclassProperties, createEntityLoader, createEntityLoader, createFrom, createJoin, createJoin, createProxy, createQueryLoader, createSelect, createUniqueKeyLoaders, createWhereByKey, dehydrate, dehydrate, delete, delete, filterFragment, findDirty, findModified, forceVersionIncrement, fromJoinFragment, generateDeleteString, generateFilterConditionAlias, generateIdentityInsertString, generateInsertGeneratedValuesSelectString, generateInsertString, generateInsertString, generateInsertString, generateLazySelectString, generateLocker, generateSelectVersionString, generateSnapshotSelectString, generateTableAlias, generateUpdateGeneratedValuesSelectString, generateUpdateString, generateUpdateString, getCache, getCacheEntryStructure, getCascadeStyle, getClassMetadata, getConcreteProxyClass, getCurrentVersion, getDatabaseSnapshot, getDiscriminatorAlias, getEntityMetamodel, getEntityName, getEntityType, getFactory, getFetchMode, getIdentifier, getIdentifierAliases, getIdentifierAliases, getIdentifierColumnNames, getIdentifierColumnSpan, getIdentifierGenerator, getIdentifierPropertyName, getIdentifierType, getIdentitySelectString, getKeyColumnNames, getLazyProperties, getMappedClass, getMappedSuperclass, getName, getNaturalIdentifierProperties, getNaturalIdentifierSnapshot, getNonLazyPropertyUpdateability, getPropertiesToInsert, getPropertiesToUpdate, getPropertyAliases, getPropertyCascadeStyles, getPropertyCheckability, getPropertyColumnNames, getPropertyColumnNames, getPropertyColumnSpan, getPropertyIndex, getPropertyInsertability, getPropertyInsertGeneration, getPropertyLaziness, getPropertyNames, getPropertyNullability, getPropertySpan, getPropertySubclassNames, getPropertyType, getPropertyTypes, getPropertyUpdateability, getPropertyUpdateability, getPropertyUpdateGeneration, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValuesToInsert, getPropertyVersionability, getQuerySpaces, getRootEntityName, getRootTableIdentifierColumnNames, getRootTableKeyColumnNames, getRootTableName, getSelectByUniqueKeyString, getSQLDeleteStrings, getSQLIdentityInsertString, getSQLInsertStrings, getSQLLazySelectString, getSQLLazyUpdateByRowIdStrings, getSQLLazyUpdateStrings, getSQLSnapshotSelectString, getSQLUpdateByRowIdStrings, getSQLUpdateStrings, getSQLWhereString, getSubclassColumnAliasClosure, getSubclassColumnClosure, getSubclassColumnLazyiness, getSubclassEntityPersister, getSubclassFormulaAliasClosure, getSubclassFormulaClosure, getSubclassFormulaLazyiness, getSubclassFormulaTemplateClosure, getSubclassPropertyColumnAliases, getSubclassPropertyColumnNameClosure, getSubclassPropertyColumnNames, getSubclassPropertyColumnNames, getSubclassPropertyFormulaTemplateClosure, getSubclassPropertyName, getSubclassPropertyNameClosure, getSubclassPropertySubclassNameClosure, getSubclassPropertyTableNumber, getSubclassPropertyType, getSubclassPropertyTypeClosure, getTableUpdateNeeded, getTemporaryIdTableDDL, getTemporaryIdTableName, getTuplizer, getTuplizer, getType, getVersion, getVersionColumnName, getVersionComparator, getVersionedTableName, getVersionProperty, getVersionSelectString, getVersionType, guessEntityMode, hasCache, hasCascades, hasCollections, hasEmbeddedCompositeIdentifier, hasFormulaProperties, hasIdentifierProperty, hasInsertGeneratedProperties, hasLazyProperties, hasMutableProperties, hasNaturalIdentifier, hasProxy, hasRowId, hasSubclasses, hasSubselectLoadableCollections, hasUninitializedLazyProperties, hasUpdateGeneratedProperties, hasWhere, hydrate, identifierSelectFragment, implementsLifecycle, implementsValidatable, initializeLazyProperty, initLockers, initPropertyPaths, initSubclassPropertyAliasesMap, insert, insert, insert, insert, instantiate, isAbstract, isBatchable, isBatchLoadable, isCacheInvalidationRequired, isCollection, isDefinedOnSubclass, isDeleteCallable, isExplicitPolymorphism, isIdentifierAssignedByInsert, isInherited, isInsertCallable, isInstance, isInstrumented, isLazyPropertiesCacheable, isMutable, isPolymorphic, isSelectBeforeUpdateRequired, isSubclassEntityName, isSubclassPropertyNullable, isTransient, isUpdateCallable, isVersioned, isVersionPropertyGenerated, isVersionPropertyInsertable, load, loadByUniqueKey, lock, logStaticSQL, optimisticLockMode, postConstruct, processInsertGeneratedProperties, processUpdateGeneratedProperties, propertySelectFragment, renderSelect, resetIdentifier, selectFragment, selectFragment, setIdentifier, setPropertyValue, setPropertyValue, setPropertyValues, toColumns, toColumns, toColumns, toString, toType, update, update, updateOrInsert, useDynamicInsert, useDynamicUpdate, useGetGeneratedKeys, useInsertSelectIdentity, whereJoinFragment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SingleTableEntityPersister

public SingleTableEntityPersister(PersistentClass persistentClass,
                                  CacheConcurrencyStrategy cache,
                                  SessionFactoryImplementor factory,
                                  Mapping mapping)
                           throws HibernateException
Method Detail

isInverseTable

protected boolean isInverseTable(int j)
Overrides:
isInverseTable in class AbstractEntityPersister

isInverseSubclassTable

protected boolean isInverseSubclassTable(int j)
Overrides:
isInverseSubclassTable in class AbstractEntityPersister

getDiscriminatorColumnName

public String getDiscriminatorColumnName()
Specified by:
getDiscriminatorColumnName in interface Loadable
Overrides:
getDiscriminatorColumnName in class AbstractEntityPersister

getDiscriminatorAlias

protected String getDiscriminatorAlias()
Overrides:
getDiscriminatorAlias in class AbstractEntityPersister

getDiscriminatorFormulaTemplate

protected String getDiscriminatorFormulaTemplate()
Overrides:
getDiscriminatorFormulaTemplate in class AbstractEntityPersister

getTableName

public String getTableName()
Description copied from interface: Joinable
The table to join to.

getDiscriminatorType

public Type getDiscriminatorType()
Description copied from interface: Loadable
Get the discriminator type

getDiscriminatorSQLValue

public String getDiscriminatorSQLValue()
Description copied from interface: Queryable
Get the discriminator value for this particular concrete subclass, as a string that may be embedded in a select statement

getSubclassClosure

public String[] getSubclassClosure()

getSubclassForDiscriminatorValue

public String getSubclassForDiscriminatorValue(Object value)
Description copied from interface: Loadable
Get the concrete subclass corresponding to the given discriminator value

getPropertySpaces

public Serializable[] getPropertySpaces()
Description copied from interface: EntityPersister
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class only.

isDiscriminatorFormula

protected boolean isDiscriminatorFormula()

getDiscriminatorFormula

protected String getDiscriminatorFormula()

getTableName

protected String getTableName(int j)
Specified by:
getTableName in class AbstractEntityPersister

getKeyColumns

protected String[] getKeyColumns(int j)
Specified by:
getKeyColumns in class AbstractEntityPersister

isTableCascadeDeleteEnabled

protected boolean isTableCascadeDeleteEnabled(int j)
Specified by:
isTableCascadeDeleteEnabled in class AbstractEntityPersister

isPropertyOfTable

protected boolean isPropertyOfTable(int property,
                                    int j)
Specified by:
isPropertyOfTable in class AbstractEntityPersister

isSubclassTableSequentialSelect

protected boolean isSubclassTableSequentialSelect(int j)
Overrides:
isSubclassTableSequentialSelect in class AbstractEntityPersister

fromTableFragment

public String fromTableFragment(String name)
Description copied from interface: OuterJoinLoadable
Get the main from table fragment, given a query alias.

filterFragment

public String filterFragment(String alias)
                      throws MappingException
Specified by:
filterFragment in class AbstractEntityPersister
Throws:
MappingException

oneToManyFilterFragment

public String oneToManyFilterFragment(String alias)
                               throws MappingException
Specified by:
oneToManyFilterFragment in interface Joinable
Overrides:
oneToManyFilterFragment in class AbstractEntityPersister
Throws:
MappingException

getSubclassPropertyTableName

public String getSubclassPropertyTableName(int i)
Description copied from interface: OuterJoinLoadable
Return the table name used to persist the numbered property of the class or a subclass.

addDiscriminatorToSelect

protected void addDiscriminatorToSelect(SelectFragment select,
                                        String name,
                                        String suffix)
Overrides:
addDiscriminatorToSelect in class AbstractEntityPersister

getPropertyTableNumbersInSelect

protected int[] getPropertyTableNumbersInSelect()
Specified by:
getPropertyTableNumbersInSelect in class AbstractEntityPersister

getSubclassPropertyTableNumber

protected int getSubclassPropertyTableNumber(int i)
Specified by:
getSubclassPropertyTableNumber in class AbstractEntityPersister

getTableSpan

public int getTableSpan()
Specified by:
getTableSpan in class AbstractEntityPersister

addDiscriminatorToInsert

protected void addDiscriminatorToInsert(Insert insert)
Overrides:
addDiscriminatorToInsert in class AbstractEntityPersister

getSubclassColumnTableNumberClosure

protected int[] getSubclassColumnTableNumberClosure()
Specified by:
getSubclassColumnTableNumberClosure in class AbstractEntityPersister

getSubclassFormulaTableNumberClosure

protected int[] getSubclassFormulaTableNumberClosure()
Specified by:
getSubclassFormulaTableNumberClosure in class AbstractEntityPersister

getPropertyTableNumbers

protected int[] getPropertyTableNumbers()
Specified by:
getPropertyTableNumbers in class AbstractEntityPersister

isSubclassPropertyDeferred

protected boolean isSubclassPropertyDeferred(String propertyName,
                                             String entityName)
Overrides:
isSubclassPropertyDeferred in class AbstractEntityPersister

hasSequentialSelect

public boolean hasSequentialSelect()
Overrides:
hasSequentialSelect in class AbstractEntityPersister

getSequentialSelect

protected String getSequentialSelect(String entityName)
Overrides:
getSequentialSelect in class AbstractEntityPersister

getSubclassTableKeyColumns

protected String[] getSubclassTableKeyColumns(int j)
Specified by:
getSubclassTableKeyColumns in class AbstractEntityPersister

getSubclassTableName

public String getSubclassTableName(int j)
Description copied from interface: Queryable
Get the name of the table with the given index from the internal array.

Specified by:
getSubclassTableName in interface Queryable
Specified by:
getSubclassTableName in class AbstractEntityPersister

getSubclassTableSpan

public int getSubclassTableSpan()
Specified by:
getSubclassTableSpan in class AbstractEntityPersister

isClassOrSuperclassTable

protected boolean isClassOrSuperclassTable(int j)
Specified by:
isClassOrSuperclassTable in class AbstractEntityPersister

isSubclassTableLazy

protected boolean isSubclassTableLazy(int j)
Overrides:
isSubclassTableLazy in class AbstractEntityPersister

isNullableTable

protected boolean isNullableTable(int j)
Overrides:
isNullableTable in class AbstractEntityPersister

isNullableSubclassTable

protected boolean isNullableSubclassTable(int j)
Overrides:
isNullableSubclassTable in class AbstractEntityPersister

getPropertyTableName

public String getPropertyTableName(String propertyName)
Description copied from interface: OuterJoinLoadable
Get the table name for the given property path

postInstantiate

public void postInstantiate()
Description copied from interface: EntityPersister
Finish the initialization of this object, once all ClassPersisters have been instantiated. Called only once, before any other method.

Specified by:
postInstantiate in interface EntityPersister
Overrides:
postInstantiate in class AbstractEntityPersister

isMultiTable

public boolean isMultiTable()
Description copied from interface: Queryable
Is the inheritence hierarchy described by this persister contained across multiple tables?

Specified by:
isMultiTable in interface Queryable
Overrides:
isMultiTable in class AbstractEntityPersister

getConstraintOrderedTableNameClosure

public String[] getConstraintOrderedTableNameClosure()
Description copied from interface: Queryable
Get the names of all tables used in the hierarchy (up and down) ordered such that deletes in the given order would not cause contraint violations.

Returns:
The ordered array of table names.

getContraintOrderedTableKeyColumnClosure

public String[][] getContraintOrderedTableKeyColumnClosure()
Description copied from interface: Queryable
For each table specified in Queryable.getConstraintOrderedTableNameClosure(), get the columns that define the key between the various hierarchy classes.

The first dimension here corresponds to the table indexes returned in Queryable.getConstraintOrderedTableNameClosure().

The second dimension should have the same length across all the elements in the first dimension. If not, that'd be a problem ;)

Returns:
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnionSubclassEntityPersister (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.persister.entity
Class UnionSubclassEntityPersister

java.lang.Object
    extended by org.hibernate.persister.entity.AbstractEntityPersister
        extended by org.hibernate.persister.entity.UnionSubclassEntityPersister
All Implemented Interfaces:
ClassMetadata, EntityPersister, Joinable, LazyPropertyInitializer, Loadable, Lockable, OptimisticCacheSource, OuterJoinLoadable, PostInsertIdentityPersister, PropertyMapping, Queryable, SQLLoadable, UniqueKeyLoadable
public class UnionSubclassEntityPersister
extends AbstractEntityPersister

Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.persister.entity.AbstractEntityPersister
customSQLDelete, customSQLInsert, customSQLUpdate, deleteCallable, deleteResultCheckStyles, ENTITY_CLASS, insertCallable, insertResultCheckStyles, propertyMapping, rowIdName, updateCallable, updateResultCheckStyles
Fields inherited from interface org.hibernate.persister.entity.Loadable
ROWID_ALIAS
Fields inherited from interface org.hibernate.persister.entity.EntityPersister
ENTITY_ID
Fields inherited from interface org.hibernate.intercept.LazyPropertyInitializer
UNFETCHED_PROPERTY
Constructor Summary
UnionSubclassEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
Method Summary
protected  void addDiscriminatorToSelect(SelectFragment select, String name, String suffix)
 String filterFragment(String name)
 String fromTableFragment(String name)
Get the main from table fragment, given a query alias.
protected  String generateSelectString(LockMode lockMode)
Generate the SQL that selects a row by id
protected  String generateSubquery(PersistentClass model, Mapping mapping)
 String[] getConstraintOrderedTableNameClosure()
Get the names of all tables used in the hierarchy (up and down) ordered such that deletes in the given order would not cause contraint violations.
 String[][] getContraintOrderedTableKeyColumnClosure()
For each table specified in getConstraintOrderedTableNameClosure(), get the columns that define the key between the various hierarchy classes.
protected  String getDiscriminatorFormula()
 String getDiscriminatorSQLValue()
Get the discriminator value for this particular concrete subclass, as a string that may be embedded in a select statement
 Type getDiscriminatorType()
Get the discriminator type
protected  String[] getKeyColumns(int j)
 Serializable[] getPropertySpaces()
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class only.
 String getPropertyTableName(String propertyName)
Get the table name for the given property path
protected  int[] getPropertyTableNumbers()
protected  int[] getPropertyTableNumbersInSelect()
 Serializable[] getQuerySpaces()
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class and its subclasses.
 String[] getSubclassClosure()
protected  int[] getSubclassColumnTableNumberClosure()
 String getSubclassForDiscriminatorValue(Object value)
Get the concrete subclass corresponding to the given discriminator value
protected  int[] getSubclassFormulaTableNumberClosure()
 String getSubclassPropertyTableName(int i)
Return the table name used to persist the numbered property of the class or a subclass.
protected  int getSubclassPropertyTableNumber(int i)
 int getSubclassPropertyTableNumber(String propertyName)
Warning: When there are duplicated property names in the subclasses of the class, this method may return the wrong table number for the duplicated subclass property (note that SingleTableEntityPersister defines an overloaded form which takes the entity name.
protected  String[] getSubclassTableKeyColumns(int j)
 String getSubclassTableName(int j)
Get the name of the table with the given index from the internal array.
 int getSubclassTableSpan()
protected  boolean[] getTableHasColumns()
 String getTableName()
The table to join to.
protected  String getTableName(int j)
 int getTableSpan()
protected  boolean isClassOrSuperclassTable(int j)
protected  boolean isDiscriminatorFormula()
 boolean isMultiTable()
Is the inheritence hierarchy described by this persister contained across multiple tables?
protected  boolean isPropertyOfTable(int property, int j)
protected  boolean isTableCascadeDeleteEnabled(int j)
Methods inherited from class org.hibernate.persister.entity.AbstractEntityPersister
addDiscriminatorToInsert, afterInitialize, afterReassociate, canExtractIdOutOfEntity, check, concretePropertySelectFragment, concretePropertySelectFragmentSansLeadingComma, consumesCollectionAlias, consumesEntityAlias, countSubclassProperties, createEntityLoader, createEntityLoader, createFrom, createJoin, createJoin, createProxy, createQueryLoader, createSelect, createUniqueKeyLoaders, createWhereByKey, dehydrate, dehydrate, delete, delete, filterFragment, findDirty, findModified, forceVersionIncrement, fromJoinFragment, generateDeleteString, generateFilterConditionAlias, generateIdentityInsertString, generateInsertGeneratedValuesSelectString, generateInsertString, generateInsertString, generateInsertString, generateLazySelectString, generateLocker, generateSelectVersionString, generateSnapshotSelectString, generateTableAlias, generateUpdateGeneratedValuesSelectString, generateUpdateString, generateUpdateString, getCache, getCacheEntryStructure, getCascadeStyle, getClassMetadata, getConcreteProxyClass, getCurrentVersion, getDatabaseSnapshot, getDiscriminatorAlias, getDiscriminatorAlias, getDiscriminatorColumnName, getDiscriminatorFormulaTemplate, getEntityMetamodel, getEntityName, getEntityType, getFactory, getFetchMode, getIdentifier, getIdentifierAliases, getIdentifierAliases, getIdentifierColumnNames, getIdentifierColumnSpan, getIdentifierGenerator, getIdentifierPropertyName, getIdentifierType, getIdentitySelectString, getKeyColumnNames, getLazyProperties, getMappedClass, getMappedSuperclass, getName, getNaturalIdentifierProperties, getNaturalIdentifierSnapshot, getNonLazyPropertyUpdateability, getPropertiesToInsert, getPropertiesToUpdate, getPropertyAliases, getPropertyCascadeStyles, getPropertyCheckability, getPropertyColumnNames, getPropertyColumnNames, getPropertyColumnSpan, getPropertyIndex, getPropertyInsertability, getPropertyInsertGeneration, getPropertyLaziness, getPropertyNames, getPropertyNullability, getPropertySpan, getPropertySubclassNames, getPropertyType, getPropertyTypes, getPropertyUpdateability, getPropertyUpdateability, getPropertyUpdateGeneration, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValuesToInsert, getPropertyVersionability, getRootEntityName, getRootTableIdentifierColumnNames, getRootTableKeyColumnNames, getRootTableName, getSelectByUniqueKeyString, getSequentialSelect, getSQLDeleteStrings, getSQLIdentityInsertString, getSQLInsertStrings, getSQLLazySelectString, getSQLLazyUpdateByRowIdStrings, getSQLLazyUpdateStrings, getSQLSnapshotSelectString, getSQLUpdateByRowIdStrings, getSQLUpdateStrings, getSQLWhereString, getSubclassColumnAliasClosure, getSubclassColumnClosure, getSubclassColumnLazyiness, getSubclassEntityPersister, getSubclassFormulaAliasClosure, getSubclassFormulaClosure, getSubclassFormulaLazyiness, getSubclassFormulaTemplateClosure, getSubclassPropertyColumnAliases, getSubclassPropertyColumnNameClosure, getSubclassPropertyColumnNames, getSubclassPropertyColumnNames, getSubclassPropertyFormulaTemplateClosure, getSubclassPropertyName, getSubclassPropertyNameClosure, getSubclassPropertySubclassNameClosure, getSubclassPropertyType, getSubclassPropertyTypeClosure, getTableUpdateNeeded, getTemporaryIdTableDDL, getTemporaryIdTableName, getTuplizer, getTuplizer, getType, getVersion, getVersionColumnName, getVersionComparator, getVersionedTableName, getVersionProperty, getVersionSelectString, getVersionType, guessEntityMode, hasCache, hasCascades, hasCollections, hasEmbeddedCompositeIdentifier, hasFormulaProperties, hasIdentifierProperty, hasInsertGeneratedProperties, hasLazyProperties, hasMutableProperties, hasNaturalIdentifier, hasProxy, hasRowId, hasSequentialSelect, hasSubclasses, hasSubselectLoadableCollections, hasUninitializedLazyProperties, hasUpdateGeneratedProperties, hasWhere, hydrate, identifierSelectFragment, implementsLifecycle, implementsValidatable, initializeLazyProperty, initLockers, initPropertyPaths, initSubclassPropertyAliasesMap, insert, insert, insert, insert, instantiate, isAbstract, isBatchable, isBatchLoadable, isCacheInvalidationRequired, isCollection, isDefinedOnSubclass, isDeleteCallable, isExplicitPolymorphism, isIdentifierAssignedByInsert, isInherited, isInsertCallable, isInstance, isInstrumented, isInverseSubclassTable, isInverseTable, isLazyPropertiesCacheable, isMutable, isNullableSubclassTable, isNullableTable, isPolymorphic, isSelectBeforeUpdateRequired, isSubclassEntityName, isSubclassPropertyDeferred, isSubclassPropertyNullable, isSubclassTableLazy, isSubclassTableSequentialSelect, isTransient, isUpdateCallable, isVersioned, isVersionPropertyGenerated, isVersionPropertyInsertable, load, loadByUniqueKey, lock, logStaticSQL, oneToManyFilterFragment, optimisticLockMode, postConstruct, postInstantiate, processInsertGeneratedProperties, processUpdateGeneratedProperties, propertySelectFragment, renderSelect, resetIdentifier, selectFragment, selectFragment, setIdentifier, setPropertyValue, setPropertyValue, setPropertyValues, toColumns, toColumns, toColumns, toString, toType, update, update, updateOrInsert, useDynamicInsert, useDynamicUpdate, useGetGeneratedKeys, useInsertSelectIdentity, whereJoinFragment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UnionSubclassEntityPersister

public UnionSubclassEntityPersister(PersistentClass persistentClass,
                                    CacheConcurrencyStrategy cache,
                                    SessionFactoryImplementor factory,
                                    Mapping mapping)
                             throws HibernateException
Method Detail

getQuerySpaces

public Serializable[] getQuerySpaces()
Description copied from interface: EntityPersister
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class and its subclasses.

Specified by:
getQuerySpaces in interface EntityPersister
Overrides:
getQuerySpaces in class AbstractEntityPersister

getTableName

public String getTableName()
Description copied from interface: Joinable
The table to join to.

getDiscriminatorType

public Type getDiscriminatorType()
Description copied from interface: Loadable
Get the discriminator type

getDiscriminatorSQLValue

public String getDiscriminatorSQLValue()
Description copied from interface: Queryable
Get the discriminator value for this particular concrete subclass, as a string that may be embedded in a select statement

getSubclassClosure

public String[] getSubclassClosure()

getSubclassForDiscriminatorValue

public String getSubclassForDiscriminatorValue(Object value)
Description copied from interface: Loadable
Get the concrete subclass corresponding to the given discriminator value

getPropertySpaces

public Serializable[] getPropertySpaces()
Description copied from interface: EntityPersister
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class only.

isDiscriminatorFormula

protected boolean isDiscriminatorFormula()

generateSelectString

protected String generateSelectString(LockMode lockMode)
Generate the SQL that selects a row by id

getDiscriminatorFormula

protected String getDiscriminatorFormula()

getTableName

protected String getTableName(int j)
Specified by:
getTableName in class AbstractEntityPersister

getKeyColumns

protected String[] getKeyColumns(int j)
Specified by:
getKeyColumns in class AbstractEntityPersister

isTableCascadeDeleteEnabled

protected boolean isTableCascadeDeleteEnabled(int j)
Specified by:
isTableCascadeDeleteEnabled in class AbstractEntityPersister

isPropertyOfTable

protected boolean isPropertyOfTable(int property,
                                    int j)
Specified by:
isPropertyOfTable in class AbstractEntityPersister

fromTableFragment

public String fromTableFragment(String name)
Description copied from interface: OuterJoinLoadable
Get the main from table fragment, given a query alias.

filterFragment

public String filterFragment(String name)
Specified by:
filterFragment in class AbstractEntityPersister

getSubclassPropertyTableName

public String getSubclassPropertyTableName(int i)
Description copied from interface: OuterJoinLoadable
Return the table name used to persist the numbered property of the class or a subclass.

addDiscriminatorToSelect

protected void addDiscriminatorToSelect(SelectFragment select,
                                        String name,
                                        String suffix)
Overrides:
addDiscriminatorToSelect in class AbstractEntityPersister

getPropertyTableNumbersInSelect

protected int[] getPropertyTableNumbersInSelect()
Specified by:
getPropertyTableNumbersInSelect in class AbstractEntityPersister

getSubclassPropertyTableNumber

protected int getSubclassPropertyTableNumber(int i)
Specified by:
getSubclassPropertyTableNumber in class AbstractEntityPersister

getSubclassPropertyTableNumber

public int getSubclassPropertyTableNumber(String propertyName)
Description copied from class: AbstractEntityPersister
Warning: When there are duplicated property names in the subclasses of the class, this method may return the wrong table number for the duplicated subclass property (note that SingleTableEntityPersister defines an overloaded form which takes the entity name.

Specified by:
getSubclassPropertyTableNumber in interface Queryable
Overrides:
getSubclassPropertyTableNumber in class AbstractEntityPersister

isMultiTable

public boolean isMultiTable()
Description copied from interface: Queryable
Is the inheritence hierarchy described by this persister contained across multiple tables?

Specified by:
isMultiTable in interface Queryable
Overrides:
isMultiTable in class AbstractEntityPersister

getTableSpan

public int getTableSpan()
Specified by:
getTableSpan in class AbstractEntityPersister

getSubclassColumnTableNumberClosure

protected int[] getSubclassColumnTableNumberClosure()
Specified by:
getSubclassColumnTableNumberClosure in class AbstractEntityPersister

getSubclassFormulaTableNumberClosure

protected int[] getSubclassFormulaTableNumberClosure()
Specified by:
getSubclassFormulaTableNumberClosure in class AbstractEntityPersister

getTableHasColumns

protected boolean[] getTableHasColumns()

getPropertyTableNumbers

protected int[] getPropertyTableNumbers()
Specified by:
getPropertyTableNumbers in class AbstractEntityPersister

generateSubquery

protected String generateSubquery(PersistentClass model,
                                  Mapping mapping)

getSubclassTableKeyColumns

protected String[] getSubclassTableKeyColumns(int j)
Specified by:
getSubclassTableKeyColumns in class AbstractEntityPersister

getSubclassTableName

public String getSubclassTableName(int j)
Description copied from interface: Queryable
Get the name of the table with the given index from the internal array.

Specified by:
getSubclassTableName in interface Queryable
Specified by:
getSubclassTableName in class AbstractEntityPersister

getSubclassTableSpan

public int getSubclassTableSpan()
Specified by:
getSubclassTableSpan in class AbstractEntityPersister

isClassOrSuperclassTable

protected boolean isClassOrSuperclassTable(int j)
Specified by:
isClassOrSuperclassTable in class AbstractEntityPersister

getPropertyTableName

public String getPropertyTableName(String propertyName)
Description copied from interface: OuterJoinLoadable
Get the table name for the given property path

getConstraintOrderedTableNameClosure

public String[] getConstraintOrderedTableNameClosure()
Description copied from interface: Queryable
Get the names of all tables used in the hierarchy (up and down) ordered such that deletes in the given order would not cause contraint violations.

Returns:
The ordered array of table names.

getContraintOrderedTableKeyColumnClosure

public String[][] getContraintOrderedTableKeyColumnClosure()
Description copied from interface: Queryable
For each table specified in Queryable.getConstraintOrderedTableNameClosure(), get the columns that define the key between the various hierarchy classes.

The first dimension here corresponds to the table indexes returned in Queryable.getConstraintOrderedTableNameClosure().

The second dimension should have the same length across all the elements in the first dimension. If not, that'd be a problem ;)

Returns:
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.pretty (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.pretty

Classes for pretty printing things for exception and log messages.

See:
Description

Class Summary
DDLFormatter |
Formatter |
MessageHelper | MessageHelper methods for rendering log messages relating to managed entities and collections typically used in log statements and exception messages.
Printer | Renders entities to a nicely readable string.

Package org.hibernate.pretty Description

Classes for pretty printing things for exception and log messages.


org.hibernate.pretty Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.pretty

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.pretty.DDLFormatter
    • class org.hibernate.pretty.Formatter
    • class org.hibernate.pretty.MessageHelper
    • class org.hibernate.pretty.Printer


Uses of Package org.hibernate.pretty (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.pretty

Packages that use org.hibernate.pretty
org.hibernate.pretty Classes for pretty printing things for exception and log messages.

Classes in org.hibernate.pretty used by org.hibernate.pretty
Formatter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DDLFormatter (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.pretty
Class DDLFormatter

java.lang.Object
    extended by org.hibernate.pretty.DDLFormatter
public class DDLFormatter
extends Object

Constructor Summary
DDLFormatter(String sql)
Method Summary
 String format()
Format an SQL statement using simple rules: a) Insert newline after each comma; b) Indent three spaces after each inserted newline; If the statement contains single/double quotes return unchanged, it is too complex and could be broken by simple formatting.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DDLFormatter

public DDLFormatter(String sql)
Method Detail

format

public String format()
Format an SQL statement using simple rules: a) Insert newline after each comma; b) Indent three spaces after each inserted newline; If the statement contains single/double quotes return unchanged, it is too complex and could be broken by simple formatting.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Formatter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.pretty
Class Formatter

java.lang.Object
    extended by org.hibernate.pretty.Formatter
public class Formatter
extends Object

Constructor Summary
Formatter(String sql)
Method Summary
String | format()
static void | main(String[] args)
Formatter | setIndentString(String indent)
Formatter | setInitialString(String initial)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Formatter

public Formatter(String sql)
Method Detail

setInitialString

public Formatter setInitialString(String initial)

setIndentString

public Formatter setIndentString(String indent)

format

public String format()

main

public static void main(String[] args)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MessageHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.pretty
Class MessageHelper

java.lang.Object
    extended by org.hibernate.pretty.MessageHelper
public final class MessageHelper
extends Object

MessageHelper methods for rendering log messages relating to managed entities and collections typically used in log statements and exception messages.

Author:
Max Andersen, Gavin King

Method Summary
static String | collectionInfoString(CollectionPersister persister, Serializable[] ids, SessionFactoryImplementor factory) Generate an info message string relating to a series of managed collections.
static String | collectionInfoString(CollectionPersister persister, Serializable id, SessionFactoryImplementor factory) Generate an info message string relating to a particular managed collection.
static String | collectionInfoString(String role, Serializable id) Generate an info message string relating to a particular managed collection.
static String | infoString(EntityPersister persister) Generate an info message string relating to given entity persister.
static String | infoString(EntityPersister persister, Object id, SessionFactoryImplementor factory) Generate an info message string relating to a particular entity.
static String | infoString(EntityPersister persister, Object id, Type identifierType, SessionFactoryImplementor factory) Generate an info message string relating to a particular entity,.
static String | infoString(EntityPersister persister, Serializable[] ids, SessionFactoryImplementor factory) Generate an info message string relating to a series of entities.
static String | infoString(String entityName, Serializable id) Generate an info message string relating to a particular entity, based on the given entityName and id.
static String | infoString(String entityName, String propertyName, Object key) Generate an info message string relating to a given property value for an entity.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

infoString

public static String infoString(String entityName,
                                Serializable id)
Generate an info message string relating to a particular entity, based on the given entityName and id.

Parameters:
entityName - The defined entity name.
id - The entity id value.
Returns:
An info string, in the form [FooBar#1].

infoString

public static String infoString(EntityPersister persister,
                                Object id,
                                SessionFactoryImplementor factory)
Generate an info message string relating to a particular entity.

Parameters:
persister - The persister for the entity
id - The entity id value
factory - The session factory
Returns:
An info string, in the form [FooBar#1]

infoString

public static String infoString(EntityPersister persister,
                                Object id,
                                Type identifierType,
                                SessionFactoryImplementor factory)
Generate an info message string relating to a particular entity,.

Parameters:
persister - The persister for the entity
id - The entity id value
identifierType - The entity identifier type mapping
factory - The session factory
Returns:
An info string, in the form [FooBar#1]

infoString

public static String infoString(EntityPersister persister,
                                Serializable[] ids,
                                SessionFactoryImplementor factory)
Generate an info message string relating to a series of entities.

Parameters:
persister - The persister for the entities
ids - The entity id values
factory - The session factory
Returns:
An info string, in the form [FooBar#<1,2,3>]

infoString

public static String infoString(EntityPersister persister)
Generate an info message string relating to given entity persister.

Parameters:
persister - The persister.
Returns:
An info string, in the form [FooBar]

infoString

public static String infoString(String entityName,
                                String propertyName,
                                Object key)
Generate an info message string relating to a given property value for an entity.

Parameters:
entityName - The entity name
propertyName - The name of the property
key - The property value.
Returns:
An info string, in the form [Foo.bars#1]

collectionInfoString

public static String collectionInfoString(CollectionPersister persister,
                                          Serializable[] ids,
                                          SessionFactoryImplementor factory)
Generate an info message string relating to a series of managed collections.

Parameters:
persister - The persister for the collections
ids - The id values of the owners
factory - The session factory
Returns:
An info string, in the form [Foo.bars#<1,2,3>]

collectionInfoString

public static String collectionInfoString(CollectionPersister persister,
                                          Serializable id,
                                          SessionFactoryImplementor factory)
Generate an info message string relating to a particular managed collection.

Parameters:
persister - The persister for the collection
id - The id value of the owner
factory - The session factory
Returns:
An info string, in the form [Foo.bars#1]

collectionInfoString

public static String collectionInfoString(String role,
                                          Serializable id)
Generate an info message string relating to a particular managed collection.

Parameters:
role - The role-name of the collection
id - The id value of the owner
Returns:
An info string, in the form [Foo.bars#1]
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Printer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.pretty
Class Printer

java.lang.Object
    extended by org.hibernate.pretty.Printer
public final class Printer
extends Object

Renders entities to a nicely readable string.

Author:
Gavin King

Constructor Summary
Printer(SessionFactoryImplementor factory)
Method Summary
void | toString(Iterator iter, EntityMode entityMode)
String | toString(Map namedTypedValues)
String | toString(Object entity, EntityMode entityMode)
String | toString(Type[] types, Object[] values)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Printer

public Printer(SessionFactoryImplementor factory)
Method Detail

toString

public String toString(Object entity,
                       EntityMode entityMode)
                throws HibernateException
Parameters:
entity - an actual entity object, not a proxy!
Throws:
HibernateException

toString

public String toString(Type[] types,
                       Object[] values)
                throws HibernateException
Throws:
HibernateException

toString

public String toString(Map namedTypedValues)
                throws HibernateException
Throws:
HibernateException

toString

public void toString(Iterator iter,
                     EntityMode entityMode)
              throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.property (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.property

This package abstracts the notion of a "property" of an entity.

See:
Description

Interface Summary
Getter | Gets values of a particular property
PropertyAccessor | Abstracts the notion of a "property".
Setter | Sets values to a particular property.

Class Summary
BackrefPropertyAccessor | Represents a "back-reference" to the id of a collection owner.
BackrefPropertyAccessor.BackrefSetter | The Setter implementation for id backrefs.
BasicPropertyAccessor | Accesses property values via a get/set pair, which may be nonpublic.
BasicPropertyAccessor.BasicGetter |
BasicPropertyAccessor.BasicSetter |
ChainedPropertyAccessor |
DirectPropertyAccessor | Accesses fields directly.
DirectPropertyAccessor.DirectGetter |
DirectPropertyAccessor.DirectSetter |
Dom4jAccessor | Responsible for accessing property values represented as a dom4j Element or Attribute.
Dom4jAccessor.AttributeGetter | For nodes like "@bar"
Dom4jAccessor.AttributeSetter | For nodes like "@bar"
Dom4jAccessor.Dom4jGetter | Defines the strategy for getting property values out of a dom4j Node.
Dom4jAccessor.Dom4jSetter |
Dom4jAccessor.ElementAttributeGetter | For nodes like "foo/@bar"
Dom4jAccessor.ElementAttributeSetter | For nodes like "foo/@bar"
Dom4jAccessor.ElementGetter | For nodes like "foo"
Dom4jAccessor.ElementSetter | For nodes like "foo"
Dom4jAccessor.TextGetter | For nodes like "."
Dom4jAccessor.TextSetter | For nodes like "."
EmbeddedPropertyAccessor |
EmbeddedPropertyAccessor.EmbeddedGetter |
EmbeddedPropertyAccessor.EmbeddedSetter |
IndexPropertyAccessor | Represents a "back-reference" to the index of a collection.
IndexPropertyAccessor.IndexSetter | The Setter implementation for index backrefs.
MapAccessor |
MapAccessor.MapGetter |
MapAccessor.MapSetter |
NoopAccessor | Used to declare properties not represented at the pojo level
PropertyAccessorFactory | A factory for building/retrieving PropertyAccessor instances.

Package org.hibernate.property Description

This package abstracts the notion of a "property" of an entity. Support for JavaBean properties and Map elements is included.


org.hibernate.property Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.property

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.property.BackrefPropertyAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.BackrefPropertyAccessor.BackrefGetter (implements org.hibernate.property.Getter)
    • class org.hibernate.property.BackrefPropertyAccessor.BackrefSetter (implements org.hibernate.property.Setter)
    • class org.hibernate.property.BasicPropertyAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.BasicPropertyAccessor.BasicGetter (implements org.hibernate.property.Getter)
    • class org.hibernate.property.BasicPropertyAccessor.BasicSetter (implements org.hibernate.property.Setter)
    • class org.hibernate.property.ChainedPropertyAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.DirectPropertyAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.DirectPropertyAccessor.DirectGetter (implements org.hibernate.property.Getter)
    • class org.hibernate.property.DirectPropertyAccessor.DirectSetter (implements org.hibernate.property.Setter)
    • class org.hibernate.property.Dom4jAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.Dom4jAccessor.Dom4jGetter (implements org.hibernate.property.Getter)
      • class org.hibernate.property.Dom4jAccessor.AttributeGetter
      • class org.hibernate.property.Dom4jAccessor.ElementAttributeGetter
      • class org.hibernate.property.Dom4jAccessor.ElementGetter
      • class org.hibernate.property.Dom4jAccessor.TextGetter
    • class org.hibernate.property.Dom4jAccessor.Dom4jSetter (implements org.hibernate.property.Setter)
      • class org.hibernate.property.Dom4jAccessor.AttributeSetter
      • class org.hibernate.property.Dom4jAccessor.ElementAttributeSetter
      • class org.hibernate.property.Dom4jAccessor.ElementSetter
      • class org.hibernate.property.Dom4jAccessor.TextSetter
    • class org.hibernate.property.EmbeddedPropertyAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter (implements org.hibernate.property.Getter)
    • class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedSetter (implements org.hibernate.property.Setter)
    • class org.hibernate.property.IndexPropertyAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.IndexPropertyAccessor.IndexGetter (implements org.hibernate.property.Getter)
    • class org.hibernate.property.IndexPropertyAccessor.IndexSetter (implements org.hibernate.property.Setter)
    • class org.hibernate.property.MapAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.MapAccessor.MapGetter (implements org.hibernate.property.Getter)
    • class org.hibernate.property.MapAccessor.MapSetter (implements org.hibernate.property.Setter)
    • class org.hibernate.property.NoopAccessor (implements org.hibernate.property.PropertyAccessor)
    • class org.hibernate.property.PropertyAccessorFactory

Interface Hierarchy

  • interface org.hibernate.property.PropertyAccessor
  • interface java.io.Serializable
    • interface org.hibernate.property.Getter
    • interface org.hibernate.property.Setter


Uses of Package org.hibernate.property (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.property

Packages that use org.hibernate.property
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |
org.hibernate.util | Utility classes.

Classes in org.hibernate.property used by org.hibernate.engine
Getter
Gets values of a particular property

Classes in org.hibernate.property used by org.hibernate.mapping
Getter
Gets values of a particular property
PropertyAccessor
Abstracts the notion of a "property".
Setter
Sets values to a particular property.

Classes in org.hibernate.property used by org.hibernate.property
Dom4jAccessor.Dom4jGetter
Defines the strategy for getting property values out of a dom4j Node.
Dom4jAccessor.Dom4jSetter
Getter
Gets values of a particular property
PropertyAccessor
Abstracts the notion of a "property".
Setter
Sets values to a particular property.

Classes in org.hibernate.property used by org.hibernate.tuple.component
Getter
Gets values of a particular property
Setter
Sets values to a particular property.

Classes in org.hibernate.property used by org.hibernate.tuple.entity
Getter
Gets values of a particular property
Setter
Sets values to a particular property.

Classes in org.hibernate.property used by org.hibernate.util
Getter
Gets values of a particular property

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Getter (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Interface Getter

All Superinterfaces:
Serializable
All Known Implementing Classes:
BackrefPropertyAccessor.BackrefGetter, BasicPropertyAccessor.BasicGetter, DirectPropertyAccessor.DirectGetter, Dom4jAccessor.Dom4jGetter, EmbeddedPropertyAccessor.EmbeddedGetter, IndexPropertyAccessor.IndexGetter, MapAccessor.MapGetter
public interface Getter
extends Serializable

Gets values of a particular property

Author:
Gavin King

Method Summary
Object | get(Object owner) Get the property value from the given instance .
Object | getForInsert(Object owner, Map mergeMap, SessionImplementor session) Get the property value from the given owner instance.
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
Class | getReturnType() Get the declared Java type

Method Detail

get

public Object get(Object owner)
           throws HibernateException
Get the property value from the given instance .

Parameters:
owner - The instance containing the value to be retreived.
Returns:
The extracted value.
Throws:
HibernateException

getForInsert

public Object getForInsert(Object owner,
                           Map mergeMap,
                           SessionImplementor session)
                    throws HibernateException
Get the property value from the given owner instance.

Parameters:
owner - The instance containing the value to be retreived.
mergeMap - a map of merged persistent instances to detached instances
session - The session from which this request originated.
Returns:
The extracted value.
Throws:
HibernateException

getReturnType

public Class getReturnType()
Get the declared Java type

getMethodName

public String getMethodName()
Optional operation (return null)

getMethod

public Method getMethod()
Optional operation (return null)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PropertyAccessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Interface PropertyAccessor

All Known Implementing Classes:
BackrefPropertyAccessor, BasicPropertyAccessor, ChainedPropertyAccessor, DirectPropertyAccessor, Dom4jAccessor, EmbeddedPropertyAccessor, IndexPropertyAccessor, MapAccessor, NoopAccessor
public interface PropertyAccessor

Abstracts the notion of a "property". Defines a strategy for accessing the value of an attribute.

Author:
Gavin King

Method Summary
Getter | getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Setter | getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute

Method Detail

getGetter

public Getter getGetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Create a "getter" for the named attribute

Throws:
PropertyNotFoundException

getSetter

public Setter getSetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Create a "setter" for the named attribute

Throws:
PropertyNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Setter (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Interface Setter

All Superinterfaces:
Serializable
All Known Implementing Classes:
BackrefPropertyAccessor.BackrefSetter, BasicPropertyAccessor.BasicSetter, DirectPropertyAccessor.DirectSetter, Dom4jAccessor.Dom4jSetter, EmbeddedPropertyAccessor.EmbeddedSetter, IndexPropertyAccessor.IndexSetter, MapAccessor.MapSetter
public interface Setter
extends Serializable

Sets values to a particular property.

Author:
Gavin King

Method Summary
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
void | set(Object target, Object value, SessionFactoryImplementor factory) Set the property value from the given instance

Method Detail

set

public void set(Object target,
                Object value,
                SessionFactoryImplementor factory)
         throws HibernateException
Set the property value from the given instance

Parameters:
target - The instance upon which to set the given value.
value - The value to be set on the target.
factory - The session factory from which this request originated.
Throws:
HibernateException

getMethodName

public String getMethodName()
Optional operation (return null)

getMethod

public Method getMethod()
Optional operation (return null)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BackrefPropertyAccessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class BackrefPropertyAccessor

java.lang.Object
    extended by org.hibernate.property.BackrefPropertyAccessor
All Implemented Interfaces:
PropertyAccessor
public class BackrefPropertyAccessor
extends Object
implements PropertyAccessor

Represents a "back-reference" to the id of a collection owner.

Author:
Gavin King

Nested Class Summary
class | BackrefPropertyAccessor.BackrefGetter The Getter implementation for id backrefs.
static class | BackrefPropertyAccessor.BackrefSetter The Setter implementation for id backrefs.
Field Summary
static Serializable UNKNOWN
A placeholder for a property value, indicating that we don't know the value of the back reference
Constructor Summary
BackrefPropertyAccessor(String collectionRole, String entityName)
Constructs a new instance of BackrefPropertyAccessor.
Method Summary
Getter | getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Setter | getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UNKNOWN

public static final Serializable UNKNOWN
A placeholder for a property value, indicating that we don't know the value of the back reference

Constructor Detail

BackrefPropertyAccessor

public BackrefPropertyAccessor(String collectionRole,
                               String entityName)
Constructs a new instance of BackrefPropertyAccessor.

Parameters:
collectionRole - The collection role which this back ref references.
Method Detail

getSetter

public Setter getSetter(Class theClass,
                        String propertyName)
Description copied from interface: PropertyAccessor
Create a "setter" for the named attribute

Specified by:
getSetter in interface PropertyAccessor

getGetter

public Getter getGetter(Class theClass,
                        String propertyName)
Description copied from interface: PropertyAccessor
Create a "getter" for the named attribute

Specified by:
getGetter in interface PropertyAccessor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BackrefPropertyAccessor.BackrefGetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class BackrefPropertyAccessor.BackrefGetter

java.lang.Object
    extended by org.hibernate.property.BackrefPropertyAccessor.BackrefGetter
All Implemented Interfaces:
Getter, Serializable
Enclosing class:
BackrefPropertyAccessor
public class BackrefPropertyAccessor.BackrefGetter
extends Object
implements Getter

The Getter implementation for id backrefs.

See Also:
Serialized Form

Constructor Summary
BackrefPropertyAccessor.BackrefGetter()
Method Summary
Object | get(Object target) Get the property value from the given instance .
Object | getForInsert(Object target, Map mergeMap, SessionImplementor session) Get the property value from the given owner instance.
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
Class | getReturnType() Get the declared Java type
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BackrefPropertyAccessor.BackrefGetter

public BackrefPropertyAccessor.BackrefGetter()
Method Detail

getForInsert

public Object getForInsert(Object target,
                           Map mergeMap,
                           SessionImplementor session)
                    throws HibernateException
Description copied from interface: Getter
Get the property value from the given owner instance.

Specified by:
getForInsert in interface Getter
Parameters:
target - The instance containing the value to be retreived.
mergeMap - a map of merged persistent instances to detached instances
session - The session from which this request originated.
Returns:
The extracted value.
Throws:
HibernateException

get

public Object get(Object target)
Description copied from interface: Getter
Get the property value from the given instance .

Specified by:
get in interface Getter
Parameters:
target - The instance containing the value to be retreived.
Returns:
The extracted value.

getMethod

public Method getMethod()
Description copied from interface: Getter
Optional operation (return null)

Specified by:
getMethod in interface Getter

getMethodName

public String getMethodName()
Description copied from interface: Getter
Optional operation (return null)

Specified by:
getMethodName in interface Getter

getReturnType

public Class getReturnType()
Description copied from interface: Getter
Get the declared Java type

Specified by:
getReturnType in interface Getter
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BackrefPropertyAccessor.BackrefSetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class BackrefPropertyAccessor.BackrefSetter

java.lang.Object
    extended by org.hibernate.property.BackrefPropertyAccessor.BackrefSetter
All Implemented Interfaces:
Serializable, Setter
Enclosing class:
BackrefPropertyAccessor
public static final class BackrefPropertyAccessor.BackrefSetter
extends Object
implements Setter

The Setter implementation for id backrefs.

See Also:
Serialized Form

Constructor Summary
BackrefPropertyAccessor.BackrefSetter()
Method Summary
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
void | set(Object target, Object value, SessionFactoryImplementor factory) Set the property value from the given instance
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BackrefPropertyAccessor.BackrefSetter

public BackrefPropertyAccessor.BackrefSetter()
Method Detail

getMethod

public Method getMethod()
Description copied from interface: Setter
Optional operation (return null)

Specified by:
getMethod in interface Setter

getMethodName

public String getMethodName()
Description copied from interface: Setter
Optional operation (return null)

Specified by:
getMethodName in interface Setter

set

public void set(Object target,
                Object value,
                SessionFactoryImplementor factory)
Description copied from interface: Setter
Set the property value from the given instance

Specified by:
set in interface Setter
Parameters:
target - The instance upon which to set the given value.
value - The value to be set on the target.
factory - The session factory from which this request originated.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BasicPropertyAccessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class BasicPropertyAccessor

java.lang.Object
    extended by org.hibernate.property.BasicPropertyAccessor
All Implemented Interfaces:
PropertyAccessor
public class BasicPropertyAccessor
extends Object
implements PropertyAccessor

Accesses property values via a get/set pair, which may be nonpublic. The default (and recommended strategy).

Author:
Gavin King

Nested Class Summary
static class | BasicPropertyAccessor.BasicGetter
static class | BasicPropertyAccessor.BasicSetter
Constructor Summary
BasicPropertyAccessor()
Method Summary
static Getter | createGetter(Class theClass, String propertyName)
Getter | getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Setter | getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BasicPropertyAccessor

public BasicPropertyAccessor()
Method Detail

getSetter

public Setter getSetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Description copied from interface: PropertyAccessor
Create a "setter" for the named attribute

Specified by:
getSetter in interface PropertyAccessor
Throws:
PropertyNotFoundException

getGetter

public Getter getGetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Description copied from interface: PropertyAccessor
Create a "getter" for the named attribute

Specified by:
getGetter in interface PropertyAccessor
Throws:
PropertyNotFoundException

createGetter

public static Getter createGetter(Class theClass,
                                  String propertyName)
                           throws PropertyNotFoundException
Throws:
PropertyNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BasicPropertyAccessor.BasicGetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class BasicPropertyAccessor.BasicGetter

java.lang.Object
    extended by org.hibernate.property.BasicPropertyAccessor.BasicGetter
All Implemented Interfaces:
Getter, Serializable
Enclosing class:
BasicPropertyAccessor
public static final class BasicPropertyAccessor.BasicGetter
extends Object
implements Getter

See Also:
Serialized Form

Method Summary
Object | get(Object target) Get the property value from the given instance .
Object | getForInsert(Object target, Map mergeMap, SessionImplementor session) Get the property value from the given owner instance.
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
Class | getReturnType() Get the declared Java type
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

get

public Object get(Object target)
           throws HibernateException
Description copied from interface: Getter
Get the property value from the given instance .

Specified by:
get in interface Getter
Parameters:
target - The instance containing the value to be retreived.
Returns:
The extracted value.
Throws:
HibernateException

getForInsert

public Object getForInsert(Object target,
                           Map mergeMap,
                           SessionImplementor session)
Description copied from interface: Getter
Get the property value from the given owner instance.

Specified by:
getForInsert in interface Getter
Parameters:
target - The instance containing the value to be retreived.
mergeMap - a map of merged persistent instances to detached instances
session - The session from which this request originated.
Returns:
The extracted value.

getReturnType

public Class getReturnType()
Description copied from interface: Getter
Get the declared Java type

Specified by:
getReturnType in interface Getter

getMethod

public Method getMethod()
Description copied from interface: Getter
Optional operation (return null)

Specified by:
getMethod in interface Getter

getMethodName

public String getMethodName()
Description copied from interface: Getter
Optional operation (return null)

Specified by:
getMethodName in interface Getter

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BasicPropertyAccessor.BasicSetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class BasicPropertyAccessor.BasicSetter

java.lang.Object
    extended by org.hibernate.property.BasicPropertyAccessor.BasicSetter
All Implemented Interfaces:
Serializable, Setter
Enclosing class:
BasicPropertyAccessor
public static final class BasicPropertyAccessor.BasicSetter
extends Object
implements Setter

See Also:
Serialized Form

Method Summary
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
void | set(Object target, Object value, SessionFactoryImplementor factory) Set the property value from the given instance
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

set

public void set(Object target,
                Object value,
                SessionFactoryImplementor factory)
         throws HibernateException
Description copied from interface: Setter
Set the property value from the given instance

Specified by:
set in interface Setter
Parameters:
target - The instance upon which to set the given value.
value - The value to be set on the target.
factory - The session factory from which this request originated.
Throws:
HibernateException

getMethod

public Method getMethod()
Description copied from interface: Setter
Optional operation (return null)

Specified by:
getMethod in interface Setter

getMethodName

public String getMethodName()
Description copied from interface: Setter
Optional operation (return null)

Specified by:
getMethodName in interface Setter

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChainedPropertyAccessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class ChainedPropertyAccessor

java.lang.Object
    extended by org.hibernate.property.ChainedPropertyAccessor
All Implemented Interfaces:
PropertyAccessor
public class ChainedPropertyAccessor
extends Object
implements PropertyAccessor

Author:
max

Constructor Summary
ChainedPropertyAccessor(PropertyAccessor[] chain)
Method Summary
Getter | getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Setter | getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ChainedPropertyAccessor

public ChainedPropertyAccessor(PropertyAccessor[] chain)
Method Detail

getGetter

public Getter getGetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Description copied from interface: PropertyAccessor
Create a "getter" for the named attribute

Specified by:
getGetter in interface PropertyAccessor
Throws:
PropertyNotFoundException

getSetter

public Setter getSetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Description copied from interface: PropertyAccessor
Create a "setter" for the named attribute

Specified by:
getSetter in interface PropertyAccessor
Throws:
PropertyNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DirectPropertyAccessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class DirectPropertyAccessor

java.lang.Object
    extended by org.hibernate.property.DirectPropertyAccessor
All Implemented Interfaces:
PropertyAccessor
public class DirectPropertyAccessor
extends Object
implements PropertyAccessor

Accesses fields directly.

Author:
Gavin King

Nested Class Summary
static class | DirectPropertyAccessor.DirectGetter
static class | DirectPropertyAccessor.DirectSetter
Constructor Summary
DirectPropertyAccessor()
Method Summary
Getter | getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Setter | getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DirectPropertyAccessor

public DirectPropertyAccessor()
Method Detail

getGetter

public Getter getGetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Description copied from interface: PropertyAccessor
Create a "getter" for the named attribute

Specified by:
getGetter in interface PropertyAccessor
Throws:
PropertyNotFoundException

getSetter

public Setter getSetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Description copied from interface: PropertyAccessor
Create a "setter" for the named attribute

Specified by:
getSetter in interface PropertyAccessor
Throws:
PropertyNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DirectPropertyAccessor.DirectGetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class DirectPropertyAccessor.DirectGetter

java.lang.Object
    extended by org.hibernate.property.DirectPropertyAccessor.DirectGetter
All Implemented Interfaces:
Getter, Serializable
Enclosing class:
DirectPropertyAccessor
public static final class DirectPropertyAccessor.DirectGetter
extends Object
implements Getter

See Also:
Serialized Form

Method Summary
Object | get(Object target) Get the property value from the given instance .
Object | getForInsert(Object target, Map mergeMap, SessionImplementor session) Get the property value from the given owner instance.
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
Class | getReturnType() Get the declared Java type
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

get

public Object get(Object target)
           throws HibernateException
Description copied from interface: Getter
Get the property value from the given instance .

Specified by:
get in interface Getter
Parameters:
target - The instance containing the value to be retreived.
Returns:
The extracted value.
Throws:
HibernateException

getForInsert

public Object getForInsert(Object target,
                           Map mergeMap,
                           SessionImplementor session)
Description copied from interface: Getter
Get the property value from the given owner instance.

Specified by:
getForInsert in interface Getter
Parameters:
target - The instance containing the value to be retreived.
mergeMap - a map of merged persistent instances to detached instances
session - The session from which this request originated.
Returns:
The extracted value.

getMethod

public Method getMethod()
Description copied from interface: Getter
Optional operation (return null)

Specified by:
getMethod in interface Getter

getMethodName

public String getMethodName()
Description copied from interface: Getter
Optional operation (return null)

Specified by:
getMethodName in interface Getter

getReturnType

public Class getReturnType()
Description copied from interface: Getter
Get the declared Java type

Specified by:
getReturnType in interface Getter

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DirectPropertyAccessor.DirectSetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class DirectPropertyAccessor.DirectSetter

java.lang.Object
    extended by org.hibernate.property.DirectPropertyAccessor.DirectSetter
All Implemented Interfaces:
Serializable, Setter
Enclosing class:
DirectPropertyAccessor
public static final class DirectPropertyAccessor.DirectSetter
extends Object
implements Setter

See Also:
Serialized Form

Method Summary
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
void | set(Object target, Object value, SessionFactoryImplementor factory) Set the property value from the given instance
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getMethod

public Method getMethod()
Description copied from interface: Setter
Optional operation (return null)

Specified by:
getMethod in interface Setter

getMethodName

public String getMethodName()
Description copied from interface: Setter
Optional operation (return null)

Specified by:
getMethodName in interface Setter

set

public void set(Object target,
                Object value,
                SessionFactoryImplementor factory)
         throws HibernateException
Description copied from interface: Setter
Set the property value from the given instance

Specified by:
set in interface Setter
Parameters:
target - The instance upon which to set the given value.
value - The value to be set on the target.
factory - The session factory from which this request originated.
Throws:
HibernateException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jAccessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class Dom4jAccessor

java.lang.Object
    extended by org.hibernate.property.Dom4jAccessor
All Implemented Interfaces:
PropertyAccessor
public class Dom4jAccessor
extends Object
implements PropertyAccessor

Responsible for accessing property values represented as a dom4j Element or Attribute.

Author:
Steve Ebersole

Nested Class Summary
static class | Dom4jAccessor.AttributeGetter For nodes like "@bar"
static class | Dom4jAccessor.AttributeSetter For nodes like "@bar"
static class | Dom4jAccessor.Dom4jGetter Defines the strategy for getting property values out of a dom4j Node.
static class | Dom4jAccessor.Dom4jSetter
static class | Dom4jAccessor.ElementAttributeGetter For nodes like "foo/@bar"
static class | Dom4jAccessor.ElementAttributeSetter For nodes like "foo/@bar"
static class | Dom4jAccessor.ElementGetter For nodes like "foo"
static class | Dom4jAccessor.ElementSetter For nodes like "foo"
static class | Dom4jAccessor.TextGetter For nodes like "."
static class | Dom4jAccessor.TextSetter For nodes like "."
Constructor Summary
Dom4jAccessor(String nodeName, Type propertyType, SessionFactoryImplementor factory)
Method Summary
Getter | getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Setter | getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Dom4jAccessor

public Dom4jAccessor(String nodeName,
                     Type propertyType,
                     SessionFactoryImplementor factory)
Method Detail

getGetter

public Getter getGetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Create a "getter" for the named attribute

Specified by:
getGetter in interface PropertyAccessor
Throws:
PropertyNotFoundException

getSetter

public Setter getSetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Create a "setter" for the named attribute

Specified by:
getSetter in interface PropertyAccessor
Throws:
PropertyNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jAccessor.AttributeGetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class Dom4jAccessor.AttributeGetter

java.lang.Object
    extended by org.hibernate.property.Dom4jAccessor.Dom4jGetter
        extended by org.hibernate.property.Dom4jAccessor.AttributeGetter
All Implemented Interfaces:
Getter, Serializable
Enclosing class:
Dom4jAccessor
public static class Dom4jAccessor.AttributeGetter
extends Dom4jAccessor.Dom4jGetter

For nodes like "@bar"

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.property.Dom4jAccessor.Dom4jGetter
factory, propertyType
Method Summary
 Object get(Object owner)
Get the property value from the given instance .
Methods inherited from class org.hibernate.property.Dom4jAccessor.Dom4jGetter
getForInsert, getMethod, getMethodName, getReturnType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

get

public Object get(Object owner)
           throws HibernateException
Description copied from interface: Getter
Get the property value from the given instance .

Parameters:
owner - The instance containing the value to be retreived.
Returns:
The extracted value.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jAccessor.AttributeSetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class Dom4jAccessor.AttributeSetter

java.lang.Object
    extended by org.hibernate.property.Dom4jAccessor.Dom4jSetter
        extended by org.hibernate.property.Dom4jAccessor.AttributeSetter
All Implemented Interfaces:
Serializable, Setter
Enclosing class:
Dom4jAccessor
public static class Dom4jAccessor.AttributeSetter
extends Dom4jAccessor.Dom4jSetter

For nodes like "@bar"

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.property.Dom4jAccessor.Dom4jSetter
propertyType
Method Summary
 void set(Object target, Object value, SessionFactoryImplementor factory)
Set the property value from the given instance
Methods inherited from class org.hibernate.property.Dom4jAccessor.Dom4jSetter
getMethod, getMethodName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

set

public void set(Object target,
                Object value,
                SessionFactoryImplementor factory)
         throws HibernateException
Description copied from interface: Setter
Set the property value from the given instance

Parameters:
target - The instance upon which to set the given value.
value - The value to be set on the target.
factory - The session factory from which this request originated.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jAccessor.Dom4jGetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class Dom4jAccessor.Dom4jGetter

java.lang.Object
    extended by org.hibernate.property.Dom4jAccessor.Dom4jGetter
All Implemented Interfaces:
Getter, Serializable
Direct Known Subclasses:
Dom4jAccessor.AttributeGetter, Dom4jAccessor.ElementAttributeGetter, Dom4jAccessor.ElementGetter, Dom4jAccessor.TextGetter
Enclosing class:
Dom4jAccessor
public abstract static class Dom4jAccessor.Dom4jGetter
extends Object
implements Getter

Defines the strategy for getting property values out of a dom4j Node.

See Also:
Serialized Form

Field Summary
protected SessionFactoryImplementor | factory
protected Type | propertyType
Method Summary
Object | getForInsert(Object owner, Map mergeMap, SessionImplementor session) Get the property value from the given owner instance.
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
Class | getReturnType() Get the declared Java type
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.property.Getter
get

Field Detail

propertyType

protected final Type propertyType

factory

protected final SessionFactoryImplementor factory
Method Detail

getForInsert

public Object getForInsert(Object owner,
                           Map mergeMap,
                           SessionImplementor session)
                    throws HibernateException
Description copied from interface: Getter
Get the property value from the given owner instance.

Specified by:
getForInsert in interface Getter
Parameters:
owner - The instance containing the value to be retreived.
mergeMap - a map of merged persistent instances to detached instances
session - The session from which this request originated.
Returns:
The extracted value.
Throws:
HibernateException

getReturnType

public Class getReturnType()
Get the declared Java type

Specified by:
getReturnType in interface Getter

getMethodName

public String getMethodName()
Optional operation (return null)

Specified by:
getMethodName in interface Getter

getMethod

public Method getMethod()
Optional operation (return null)

Specified by:
getMethod in interface Getter
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jAccessor.Dom4jSetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class Dom4jAccessor.Dom4jSetter

java.lang.Object
    extended by org.hibernate.property.Dom4jAccessor.Dom4jSetter
All Implemented Interfaces:
Serializable, Setter
Direct Known Subclasses:
Dom4jAccessor.AttributeSetter, Dom4jAccessor.ElementAttributeSetter, Dom4jAccessor.ElementSetter, Dom4jAccessor.TextSetter
Enclosing class:
Dom4jAccessor
public abstract static class Dom4jAccessor.Dom4jSetter
extends Object
implements Setter

See Also:
Serialized Form

Field Summary
protected  Type propertyType
Method Summary
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.property.Setter
set

Field Detail

propertyType

protected final Type propertyType
Method Detail

getMethodName

public String getMethodName()
Optional operation (return null)

Specified by:
getMethodName in interface Setter

getMethod

public Method getMethod()
Optional operation (return null)

Specified by:
getMethod in interface Setter
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jAccessor.ElementAttributeGetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class Dom4jAccessor.ElementAttributeGetter

java.lang.Object
    extended by org.hibernate.property.Dom4jAccessor.Dom4jGetter
        extended by org.hibernate.property.Dom4jAccessor.ElementAttributeGetter
All Implemented Interfaces:
Getter, Serializable
Enclosing class:
Dom4jAccessor
public static class Dom4jAccessor.ElementAttributeGetter
extends Dom4jAccessor.Dom4jGetter

For nodes like "foo/@bar"

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.property.Dom4jAccessor.Dom4jGetter
factory, propertyType
Method Summary
 Object get(Object owner)
Get the property value from the given instance .
Methods inherited from class org.hibernate.property.Dom4jAccessor.Dom4jGetter
getForInsert, getMethod, getMethodName, getReturnType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

get

public Object get(Object owner)
           throws HibernateException
Description copied from interface: Getter
Get the property value from the given instance .

Parameters:
owner - The instance containing the value to be retreived.
Returns:
The extracted value.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jAccessor.ElementAttributeSetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class Dom4jAccessor.ElementAttributeSetter

java.lang.Object
    extended by org.hibernate.property.Dom4jAccessor.Dom4jSetter
        extended by org.hibernate.property.Dom4jAccessor.ElementAttributeSetter
All Implemented Interfaces:
Serializable, Setter
Enclosing class:
Dom4jAccessor
public static class Dom4jAccessor.ElementAttributeSetter
extends Dom4jAccessor.Dom4jSetter

For nodes like "foo/@bar"

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.property.Dom4jAccessor.Dom4jSetter
propertyType
Method Summary
 void set(Object target, Object value, SessionFactoryImplementor factory)
Set the property value from the given instance
Methods inherited from class org.hibernate.property.Dom4jAccessor.Dom4jSetter
getMethod, getMethodName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

set

public void set(Object target,
                Object value,
                SessionFactoryImplementor factory)
         throws HibernateException
Description copied from interface: Setter
Set the property value from the given instance

Parameters:
target - The instance upon which to set the given value.
value - The value to be set on the target.
factory - The session factory from which this request originated.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jAccessor.ElementGetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class Dom4jAccessor.ElementGetter

java.lang.Object
    extended by org.hibernate.property.Dom4jAccessor.Dom4jGetter
        extended by org.hibernate.property.Dom4jAccessor.ElementGetter
All Implemented Interfaces:
Getter, Serializable
Enclosing class:
Dom4jAccessor
public static class Dom4jAccessor.ElementGetter
extends Dom4jAccessor.Dom4jGetter

For nodes like "foo"

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.property.Dom4jAccessor.Dom4jGetter
factory, propertyType
Method Summary
 Object get(Object owner)
Get the property value from the given instance .
Methods inherited from class org.hibernate.property.Dom4jAccessor.Dom4jGetter
getForInsert, getMethod, getMethodName, getReturnType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

get

public Object get(Object owner)
           throws HibernateException
Description copied from interface: Getter
Get the property value from the given instance .

Parameters:
owner - The instance containing the value to be retreived.
Returns:
The extracted value.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jAccessor.ElementSetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class Dom4jAccessor.ElementSetter

java.lang.Object
    extended by org.hibernate.property.Dom4jAccessor.Dom4jSetter
        extended by org.hibernate.property.Dom4jAccessor.ElementSetter
All Implemented Interfaces:
Serializable, Setter
Enclosing class:
Dom4jAccessor
public static class Dom4jAccessor.ElementSetter
extends Dom4jAccessor.Dom4jSetter

For nodes like "foo"

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.property.Dom4jAccessor.Dom4jSetter
propertyType
Method Summary
 void set(Object target, Object value, SessionFactoryImplementor factory)
Set the property value from the given instance
Methods inherited from class org.hibernate.property.Dom4jAccessor.Dom4jSetter
getMethod, getMethodName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

set

public void set(Object target,
                Object value,
                SessionFactoryImplementor factory)
         throws HibernateException
Description copied from interface: Setter
Set the property value from the given instance

Parameters:
target - The instance upon which to set the given value.
value - The value to be set on the target.
factory - The session factory from which this request originated.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jAccessor.TextGetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class Dom4jAccessor.TextGetter

java.lang.Object
    extended by org.hibernate.property.Dom4jAccessor.Dom4jGetter
        extended by org.hibernate.property.Dom4jAccessor.TextGetter
All Implemented Interfaces:
Getter, Serializable
Enclosing class:
Dom4jAccessor
public static class Dom4jAccessor.TextGetter
extends Dom4jAccessor.Dom4jGetter

For nodes like "."

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.property.Dom4jAccessor.Dom4jGetter
factory, propertyType
Method Summary
 Object get(Object owner)
Get the property value from the given instance .
Methods inherited from class org.hibernate.property.Dom4jAccessor.Dom4jGetter
getForInsert, getMethod, getMethodName, getReturnType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

get

public Object get(Object owner)
           throws HibernateException
Description copied from interface: Getter
Get the property value from the given instance .

Parameters:
owner - The instance containing the value to be retreived.
Returns:
The extracted value.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jAccessor.TextSetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class Dom4jAccessor.TextSetter

java.lang.Object
    extended by org.hibernate.property.Dom4jAccessor.Dom4jSetter
        extended by org.hibernate.property.Dom4jAccessor.TextSetter
All Implemented Interfaces:
Serializable, Setter
Enclosing class:
Dom4jAccessor
public static class Dom4jAccessor.TextSetter
extends Dom4jAccessor.Dom4jSetter

For nodes like "."

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.property.Dom4jAccessor.Dom4jSetter
propertyType
Method Summary
 void set(Object target, Object value, SessionFactoryImplementor factory)
Set the property value from the given instance
Methods inherited from class org.hibernate.property.Dom4jAccessor.Dom4jSetter
getMethod, getMethodName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

set

public void set(Object target,
                Object value,
                SessionFactoryImplementor factory)
         throws HibernateException
Description copied from interface: Setter
Set the property value from the given instance

Parameters:
target - The instance upon which to set the given value.
value - The value to be set on the target.
factory - The session factory from which this request originated.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmbeddedPropertyAccessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class EmbeddedPropertyAccessor

java.lang.Object
    extended by org.hibernate.property.EmbeddedPropertyAccessor
All Implemented Interfaces:
PropertyAccessor
public class EmbeddedPropertyAccessor
extends Object
implements PropertyAccessor

Author:
Gavin King

Nested Class Summary
static class | EmbeddedPropertyAccessor.EmbeddedGetter
static class | EmbeddedPropertyAccessor.EmbeddedSetter
Constructor Summary
EmbeddedPropertyAccessor()
Method Summary
Getter | getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Setter | getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EmbeddedPropertyAccessor

public EmbeddedPropertyAccessor()
Method Detail

getGetter

public Getter getGetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Description copied from interface: PropertyAccessor
Create a "getter" for the named attribute

Specified by:
getGetter in interface PropertyAccessor
Throws:
PropertyNotFoundException

getSetter

public Setter getSetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Description copied from interface: PropertyAccessor
Create a "setter" for the named attribute

Specified by:
getSetter in interface PropertyAccessor
Throws:
PropertyNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmbeddedPropertyAccessor.EmbeddedGetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class EmbeddedPropertyAccessor.EmbeddedGetter

java.lang.Object
    extended by org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter
All Implemented Interfaces:
Getter, Serializable
Enclosing class:
EmbeddedPropertyAccessor
public static final class EmbeddedPropertyAccessor.EmbeddedGetter
extends Object
implements Getter

See Also:
Serialized Form

Method Summary
Object | get(Object target) Get the property value from the given instance .
Object | getForInsert(Object target, Map mergeMap, SessionImplementor session) Get the property value from the given owner instance.
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
Class | getReturnType() Get the declared Java type
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

get

public Object get(Object target)
           throws HibernateException
Description copied from interface: Getter
Get the property value from the given instance .

Specified by:
get in interface Getter
Parameters:
target - The instance containing the value to be retreived.
Returns:
The extracted value.
Throws:
HibernateException

getForInsert

public Object getForInsert(Object target,
                           Map mergeMap,
                           SessionImplementor session)
Description copied from interface: Getter
Get the property value from the given owner instance.

Specified by:
getForInsert in interface Getter
Parameters:
target - The instance containing the value to be retreived.
mergeMap - a map of merged persistent instances to detached instances
session - The session from which this request originated.
Returns:
The extracted value.

getMethod

public Method getMethod()
Description copied from interface: Getter
Optional operation (return null)

Specified by:
getMethod in interface Getter

getMethodName

public String getMethodName()
Description copied from interface: Getter
Optional operation (return null)

Specified by:
getMethodName in interface Getter

getReturnType

public Class getReturnType()
Description copied from interface: Getter
Get the declared Java type

Specified by:
getReturnType in interface Getter

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmbeddedPropertyAccessor.EmbeddedSetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class EmbeddedPropertyAccessor.EmbeddedSetter

java.lang.Object
    extended by org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedSetter
All Implemented Interfaces:
Serializable, Setter
Enclosing class:
EmbeddedPropertyAccessor
public static final class EmbeddedPropertyAccessor.EmbeddedSetter
extends Object
implements Setter

See Also:
Serialized Form

Method Summary
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
void | set(Object target, Object value, SessionFactoryImplementor factory) Set the property value from the given instance
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getMethod

public Method getMethod()
Description copied from interface: Setter
Optional operation (return null)

Specified by:
getMethod in interface Setter

getMethodName

public String getMethodName()
Description copied from interface: Setter
Optional operation (return null)

Specified by:
getMethodName in interface Setter

set

public void set(Object target,
                Object value,
                SessionFactoryImplementor factory)
         throws HibernateException
Description copied from interface: Setter
Set the property value from the given instance

Specified by:
set in interface Setter
Parameters:
target - The instance upon which to set the given value.
value - The value to be set on the target.
factory - The session factory from which this request originated.
Throws:
HibernateException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IndexPropertyAccessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class IndexPropertyAccessor

java.lang.Object
    extended by org.hibernate.property.IndexPropertyAccessor
All Implemented Interfaces:
PropertyAccessor
public class IndexPropertyAccessor
extends Object
implements PropertyAccessor

Represents a "back-reference" to the index of a collection.

Author:
Gavin King

Nested Class Summary
class | IndexPropertyAccessor.IndexGetter The Getter implementation for index backrefs.
static class | IndexPropertyAccessor.IndexSetter The Setter implementation for index backrefs.
Constructor Summary
IndexPropertyAccessor(String collectionRole, String entityName)
Constructs a new instance of IndexPropertyAccessor.
Method Summary
Getter | getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Setter | getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IndexPropertyAccessor

public IndexPropertyAccessor(String collectionRole,
                             String entityName)
Constructs a new instance of IndexPropertyAccessor.

Parameters:
collectionRole - The collection role which this back ref references.
Method Detail

getSetter

public Setter getSetter(Class theClass,
                        String propertyName)
Description copied from interface: PropertyAccessor
Create a "setter" for the named attribute

Specified by:
getSetter in interface PropertyAccessor

getGetter

public Getter getGetter(Class theClass,
                        String propertyName)
Description copied from interface: PropertyAccessor
Create a "getter" for the named attribute

Specified by:
getGetter in interface PropertyAccessor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IndexPropertyAccessor.IndexGetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class IndexPropertyAccessor.IndexGetter

java.lang.Object
    extended by org.hibernate.property.IndexPropertyAccessor.IndexGetter
All Implemented Interfaces:
Getter, Serializable
Enclosing class:
IndexPropertyAccessor
public class IndexPropertyAccessor.IndexGetter
extends Object
implements Getter

The Getter implementation for index backrefs.

See Also:
Serialized Form

Constructor Summary
IndexPropertyAccessor.IndexGetter()
Method Summary
Object | get(Object target) Get the property value from the given instance .
Object | getForInsert(Object target, Map mergeMap, SessionImplementor session) Get the property value from the given owner instance.
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
Class | getReturnType() Get the declared Java type
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IndexPropertyAccessor.IndexGetter

public IndexPropertyAccessor.IndexGetter()
Method Detail

getForInsert

public Object getForInsert(Object target,
                           Map mergeMap,
                           SessionImplementor session)
                    throws HibernateException
Description copied from interface: Getter
Get the property value from the given owner instance.

Specified by:
getForInsert in interface Getter
Parameters:
target - The instance containing the value to be retreived.
mergeMap - a map of merged persistent instances to detached instances
session - The session from which this request originated.
Returns:
The extracted value.
Throws:
HibernateException

get

public Object get(Object target)
Description copied from interface: Getter
Get the property value from the given instance .

Specified by:
get in interface Getter
Parameters:
target - The instance containing the value to be retreived.
Returns:
The extracted value.

getMethod

public Method getMethod()
Description copied from interface: Getter
Optional operation (return null)

Specified by:
getMethod in interface Getter

getMethodName

public String getMethodName()
Description copied from interface: Getter
Optional operation (return null)

Specified by:
getMethodName in interface Getter

getReturnType

public Class getReturnType()
Description copied from interface: Getter
Get the declared Java type

Specified by:
getReturnType in interface Getter
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IndexPropertyAccessor.IndexSetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class IndexPropertyAccessor.IndexSetter

java.lang.Object
    extended by org.hibernate.property.IndexPropertyAccessor.IndexSetter
All Implemented Interfaces:
Serializable, Setter
Enclosing class:
IndexPropertyAccessor
public static final class IndexPropertyAccessor.IndexSetter
extends Object
implements Setter

The Setter implementation for index backrefs.

See Also:
Serialized Form

Constructor Summary
IndexPropertyAccessor.IndexSetter()
Method Summary
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
void | set(Object target, Object value)
void | set(Object target, Object value, SessionFactoryImplementor factory) Set the property value from the given instance
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IndexPropertyAccessor.IndexSetter

public IndexPropertyAccessor.IndexSetter()
Method Detail

getMethod

public Method getMethod()
Description copied from interface: Setter
Optional operation (return null)

Specified by:
getMethod in interface Setter

getMethodName

public String getMethodName()
Description copied from interface: Setter
Optional operation (return null)

Specified by:
getMethodName in interface Setter

set

public void set(Object target,
                Object value)

set

public void set(Object target,
                Object value,
                SessionFactoryImplementor factory)
         throws HibernateException
Description copied from interface: Setter
Set the property value from the given instance

Specified by:
set in interface Setter
Parameters:
target - The instance upon which to set the given value.
value - The value to be set on the target.
factory - The session factory from which this request originated.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MapAccessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class MapAccessor

java.lang.Object
    extended by org.hibernate.property.MapAccessor
All Implemented Interfaces:
PropertyAccessor
public class MapAccessor
extends Object
implements PropertyAccessor

Author:
Gavin King

Nested Class Summary
static class | MapAccessor.MapGetter
static class | MapAccessor.MapSetter
Constructor Summary
MapAccessor()
Method Summary
Getter | getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Setter | getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MapAccessor

public MapAccessor()
Method Detail

getGetter

public Getter getGetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Description copied from interface: PropertyAccessor
Create a "getter" for the named attribute

Specified by:
getGetter in interface PropertyAccessor
Throws:
PropertyNotFoundException

getSetter

public Setter getSetter(Class theClass,
                        String propertyName)
                 throws PropertyNotFoundException
Description copied from interface: PropertyAccessor
Create a "setter" for the named attribute

Specified by:
getSetter in interface PropertyAccessor
Throws:
PropertyNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MapAccessor.MapGetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class MapAccessor.MapGetter

java.lang.Object
    extended by org.hibernate.property.MapAccessor.MapGetter
All Implemented Interfaces:
Getter, Serializable
Enclosing class:
MapAccessor
public static final class MapAccessor.MapGetter
extends Object
implements Getter

See Also:
Serialized Form

Method Summary
Object | get(Object target) Get the property value from the given instance .
Object | getForInsert(Object target, Map mergeMap, SessionImplementor session) Get the property value from the given owner instance.
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
Class | getReturnType() Get the declared Java type
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getMethod

public Method getMethod()
Description copied from interface: Getter
Optional operation (return null)

Specified by:
getMethod in interface Getter

getMethodName

public String getMethodName()
Description copied from interface: Getter
Optional operation (return null)

Specified by:
getMethodName in interface Getter

get

public Object get(Object target)
           throws HibernateException
Description copied from interface: Getter
Get the property value from the given instance .

Specified by:
get in interface Getter
Parameters:
target - The instance containing the value to be retreived.
Returns:
The extracted value.
Throws:
HibernateException

getForInsert

public Object getForInsert(Object target,
                           Map mergeMap,
                           SessionImplementor session)
Description copied from interface: Getter
Get the property value from the given owner instance.

Specified by:
getForInsert in interface Getter
Parameters:
target - The instance containing the value to be retreived.
mergeMap - a map of merged persistent instances to detached instances
session - The session from which this request originated.
Returns:
The extracted value.

getReturnType

public Class getReturnType()
Description copied from interface: Getter
Get the declared Java type

Specified by:
getReturnType in interface Getter
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MapAccessor.MapSetter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class MapAccessor.MapSetter

java.lang.Object
    extended by org.hibernate.property.MapAccessor.MapSetter
All Implemented Interfaces:
Serializable, Setter
Enclosing class:
MapAccessor
public static final class MapAccessor.MapSetter
extends Object
implements Setter

See Also:
Serialized Form

Method Summary
Method | getMethod() Optional operation (return null)
String | getMethodName() Optional operation (return null)
void | set(Object target, Object value, SessionFactoryImplementor factory) Set the property value from the given instance
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getMethod

public Method getMethod()
Description copied from interface: Setter
Optional operation (return null)

Specified by:
getMethod in interface Setter

getMethodName

public String getMethodName()
Description copied from interface: Setter
Optional operation (return null)

Specified by:
getMethodName in interface Setter

set

public void set(Object target,
                Object value,
                SessionFactoryImplementor factory)
         throws HibernateException
Description copied from interface: Setter
Set the property value from the given instance

Specified by:
set in interface Setter
Parameters:
target - The instance upon which to set the given value.
value - The value to be set on the target.
factory - The session factory from which this request originated.
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoopAccessor (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class NoopAccessor

java.lang.Object
    extended by org.hibernate.property.NoopAccessor
All Implemented Interfaces:
PropertyAccessor
public class NoopAccessor
extends Object
implements PropertyAccessor

Used to declare properties not represented at the pojo level

Author:
Michael Bartmann

Constructor Summary
NoopAccessor()
Method Summary
Getter | getGetter(Class arg0, String arg1) Create a "getter" for the named attribute
Setter | getSetter(Class arg0, String arg1) Create a "setter" for the named attribute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NoopAccessor

public NoopAccessor()
Method Detail

getGetter

public Getter getGetter(Class arg0,
                        String arg1)
                 throws PropertyNotFoundException
Description copied from interface: PropertyAccessor
Create a "getter" for the named attribute

Specified by:
getGetter in interface PropertyAccessor
Throws:
PropertyNotFoundException

getSetter

public Setter getSetter(Class arg0,
                        String arg1)
                 throws PropertyNotFoundException
Description copied from interface: PropertyAccessor
Create a "setter" for the named attribute

Specified by:
getSetter in interface PropertyAccessor
Throws:
PropertyNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyAccessorFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.property
Class PropertyAccessorFactory

java.lang.Object
    extended by org.hibernate.property.PropertyAccessorFactory
public final class PropertyAccessorFactory
extends Object

A factory for building/retrieving PropertyAccessor instances.

Author:
Gavin King, Steve Ebersole

Method Summary
static PropertyAccessor | getDom4jPropertyAccessor(String nodeName, Type type, SessionFactoryImplementor factory)
static PropertyAccessor | getDynamicMapPropertyAccessor()
static PropertyAccessor | getPropertyAccessor(Class optionalClass, String type)
static PropertyAccessor | getPropertyAccessor(Property property, EntityMode mode) Retrieves a PropertyAccessor instance based on the given property definition and entity mode.
static PropertyAccessor | getPropertyAccessor(String type)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getPropertyAccessor

public static PropertyAccessor getPropertyAccessor(Property property,
                                                   EntityMode mode)
                                            throws MappingException
Retrieves a PropertyAccessor instance based on the given property definition and entity mode.

Parameters:
property - The property for which to retrieve an accessor.
mode - The mode for the resulting entity.
Returns:
An appropriate accessor.
Throws:
MappingException

getDynamicMapPropertyAccessor

public static PropertyAccessor getDynamicMapPropertyAccessor()
                                                      throws MappingException
Throws:
MappingException

getDom4jPropertyAccessor

public static PropertyAccessor getDom4jPropertyAccessor(String nodeName,
                                                        Type type,
                                                        SessionFactoryImplementor factory)
                                                 throws MappingException
Throws:
MappingException

getPropertyAccessor

public static PropertyAccessor getPropertyAccessor(Class optionalClass,
                                                   String type)
                                            throws MappingException
Throws:
MappingException

getPropertyAccessor

public static PropertyAccessor getPropertyAccessor(String type)
                                            throws MappingException
Throws:
MappingException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.proxy (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.proxy

This package defines a framework for lazy-initializing entity proxies.

See:
Description

Interface Summary
EntityNotFoundDelegate | Delegate to handle the scenario of an entity not found by a specified id.
HibernateProxy | Marker interface for entity proxies
LazyInitializer | Handles fetching of the underlying entity for a proxy
ProxyFactory | Contract for run-time, proxy-based lazy initialization proxies.

Class Summary
AbstractLazyInitializer | Convenience base class for lazy initialization handlers.
HibernateProxyHelper | Utility methods for working with proxies.

Package org.hibernate.proxy Description

This package defines a framework for lazy-initializing entity proxies.


org.hibernate.proxy Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.proxy

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.proxy.AbstractLazyInitializer (implements org.hibernate.proxy.LazyInitializer)
    • class org.hibernate.proxy.HibernateProxyHelper

Interface Hierarchy

  • interface org.hibernate.proxy.EntityNotFoundDelegate
  • interface org.hibernate.proxy.LazyInitializer
  • interface org.hibernate.proxy.ProxyFactory
  • interface java.io.Serializable
    • interface org.hibernate.proxy.HibernateProxy


Uses of Package org.hibernate.proxy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.proxy

Packages that use org.hibernate.proxy
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.proxy | This package defines a framework for lazy-initializing entity proxies.
org.hibernate.proxy.dom4j |
org.hibernate.proxy.map |
org.hibernate.proxy.pojo |
org.hibernate.proxy.pojo.cglib |
org.hibernate.proxy.pojo.javassist |
org.hibernate.tuple.entity |

Classes in org.hibernate.proxy used by org.hibernate.bytecode
ProxyFactory
Contract for run-time, proxy-based lazy initialization proxies.

Classes in org.hibernate.proxy used by org.hibernate.bytecode.cglib
ProxyFactory
Contract for run-time, proxy-based lazy initialization proxies.

Classes in org.hibernate.proxy used by org.hibernate.cfg
EntityNotFoundDelegate
Delegate to handle the scenario of an entity not found by a specified id.

Classes in org.hibernate.proxy used by org.hibernate.engine
EntityNotFoundDelegate
Delegate to handle the scenario of an entity not found by a specified id.

Classes in org.hibernate.proxy used by org.hibernate.impl
EntityNotFoundDelegate
Delegate to handle the scenario of an entity not found by a specified id.

Classes in org.hibernate.proxy used by org.hibernate.proxy
HibernateProxy
Marker interface for entity proxies
LazyInitializer
Handles fetching of the underlying entity for a proxy

Classes in org.hibernate.proxy used by org.hibernate.proxy.dom4j
AbstractLazyInitializer
Convenience base class for lazy initialization handlers.
HibernateProxy
Marker interface for entity proxies
LazyInitializer
Handles fetching of the underlying entity for a proxy
ProxyFactory
Contract for run-time, proxy-based lazy initialization proxies.

Classes in org.hibernate.proxy used by org.hibernate.proxy.map
AbstractLazyInitializer
Convenience base class for lazy initialization handlers.
HibernateProxy
Marker interface for entity proxies
LazyInitializer
Handles fetching of the underlying entity for a proxy
ProxyFactory
Contract for run-time, proxy-based lazy initialization proxies.

Classes in org.hibernate.proxy used by org.hibernate.proxy.pojo
AbstractLazyInitializer
Convenience base class for lazy initialization handlers.
LazyInitializer
Handles fetching of the underlying entity for a proxy

Classes in org.hibernate.proxy used by org.hibernate.proxy.pojo.cglib
AbstractLazyInitializer
Convenience base class for lazy initialization handlers.
HibernateProxy
Marker interface for entity proxies
LazyInitializer
Handles fetching of the underlying entity for a proxy
ProxyFactory
Contract for run-time, proxy-based lazy initialization proxies.

Classes in org.hibernate.proxy used by org.hibernate.proxy.pojo.javassist
AbstractLazyInitializer
Convenience base class for lazy initialization handlers.
HibernateProxy
Marker interface for entity proxies
LazyInitializer
Handles fetching of the underlying entity for a proxy
ProxyFactory
Contract for run-time, proxy-based lazy initialization proxies.

Classes in org.hibernate.proxy used by org.hibernate.tuple.entity
ProxyFactory
Contract for run-time, proxy-based lazy initialization proxies.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


EntityNotFoundDelegate (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy
Interface EntityNotFoundDelegate

public interface EntityNotFoundDelegate

Delegate to handle the scenario of an entity not found by a specified id.

Author:
Steve Ebersole

Method Summary
 void handleEntityNotFound(String entityName, Serializable id)

Method Detail

handleEntityNotFound

public void handleEntityNotFound(String entityName,
                                 Serializable id)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HibernateProxy (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy
Interface HibernateProxy

All Superinterfaces:
Serializable
All Known Implementing Classes:
Dom4jProxy, MapProxy
public interface HibernateProxy
extends Serializable

Marker interface for entity proxies

Author:
Gavin King

Method Summary
LazyInitializer | getHibernateLazyInitializer() Get the underlying lazy initialization handler.
Object | writeReplace() Perform serialization-time write-replacement of this proxy.

Method Detail

writeReplace

public Object writeReplace()
Perform serialization-time write-replacement of this proxy.

Returns:
The serializable proxy replacement.

getHibernateLazyInitializer

public LazyInitializer getHibernateLazyInitializer()
Get the underlying lazy initialization handler.

Returns:
The lazy initializer.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LazyInitializer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy
Interface LazyInitializer

All Known Implementing Classes:
AbstractLazyInitializer
public interface LazyInitializer

Handles fetching of the underlying entity for a proxy

Author:
Gavin King

Method Summary
String | getEntityName() Get the entity name
Serializable | getIdentifier() Get the identifier held by the proxy
Object | getImplementation() Return the underlying persistent object, initializing if necessary
Object | getImplementation(SessionImplementor s) Return the underlying persistent object in the given Session, or null
Class | getPersistentClass() Get the actual class of the entity (don't use this, use the entityName)
SessionImplementor | getSession() Get the session, if this proxy is attached
void | initialize() Initialize the proxy, fetching the target entity if necessary
boolean | isUninitialized() Is the proxy uninitialzed?
boolean | isUnwrap()
void | setIdentifier(Serializable id) Set the identifier property of the proxy
void | setImplementation(Object target) Initialize the proxy manually
void | setSession(SessionImplementor s) Attach the proxy to a session
void | setUnwrap(boolean unwrap)

Method Detail

initialize

public void initialize()
                throws HibernateException
Initialize the proxy, fetching the target entity if necessary

Throws:
HibernateException

getIdentifier

public Serializable getIdentifier()
Get the identifier held by the proxy

setIdentifier

public void setIdentifier(Serializable id)
Set the identifier property of the proxy

getEntityName

public String getEntityName()
Get the entity name

getPersistentClass

public Class getPersistentClass()
Get the actual class of the entity (don't use this, use the entityName)

isUninitialized

public boolean isUninitialized()
Is the proxy uninitialzed?

setImplementation

public void setImplementation(Object target)
Initialize the proxy manually

getSession

public SessionImplementor getSession()
Get the session, if this proxy is attached

setSession

public void setSession(SessionImplementor s)
                throws HibernateException
Attach the proxy to a session

Throws:
HibernateException

getImplementation

public Object getImplementation()
Return the underlying persistent object, initializing if necessary

getImplementation

public Object getImplementation(SessionImplementor s)
                         throws HibernateException
Return the underlying persistent object in the given Session, or null

Throws:
HibernateException

setUnwrap

public void setUnwrap(boolean unwrap)

isUnwrap

public boolean isUnwrap()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy
Interface ProxyFactory

All Known Implementing Classes:
CGLIBProxyFactory, Dom4jProxyFactory, JavassistProxyFactory, MapProxyFactory
public interface ProxyFactory

Contract for run-time, proxy-based lazy initialization proxies.

Author:
Gavin King

Method Summary
HibernateProxy | getProxy(Serializable id, SessionImplementor session) Create a new proxy instance
void | postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType) Called immediately after instantiation of this factory.

Method Detail

postInstantiate

public void postInstantiate(String entityName,
                            Class persistentClass,
                            Set interfaces,
                            Method getIdentifierMethod,
                            Method setIdentifierMethod,
                            AbstractComponentType componentIdType)
                     throws HibernateException
Called immediately after instantiation of this factory.

Essentially equivalent to contructor injection, but contracted here via interface.

Parameters:
entityName - The name of the entity for which this factory should generate proxies.
persistentClass - The entity class for which to generate proxies; not always the same as the entityName.
interfaces - The interfaces to expose in the generated proxy; HibernateProxy is already included in this collection.
getIdentifierMethod - Reference to the identifier getter method; invocation on this method should not force initialization
setIdentifierMethod - Reference to the identifier setter method; invocation on this method should not force initialization
componentIdType - For composite identifier types, a reference to the type of the identifier property; again accessing the id should generally not cause initialization - but need to bear in mind mappings.
Throws:
HibernateException - Indicates a problem completing post instantiation initialization.

getProxy

public HibernateProxy getProxy(Serializable id,
                               SessionImplementor session)
                        throws HibernateException
Create a new proxy instance

Parameters:
id - The id value for the proxy to be generated.
session - The session to which the generated proxy will be associated.
Returns:
The generated proxy.
Throws:
HibernateException - Indicates problems generating the requested proxy.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractLazyInitializer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy
Class AbstractLazyInitializer

java.lang.Object
    extended by org.hibernate.proxy.AbstractLazyInitializer
All Implemented Interfaces:
LazyInitializer
Direct Known Subclasses:
BasicLazyInitializer, Dom4jLazyInitializer, MapLazyInitializer
public abstract class AbstractLazyInitializer
extends Object
implements LazyInitializer

Convenience base class for lazy initialization handlers. Centralizes the basic plumbing of doing lazy initialization freeing subclasses to acts as essentially adapters to their intended entity mode and/or proxy generation strategy.

Author:
Gavin King

Constructor Summary
protected AbstractLazyInitializer(String entityName, Serializable id, SessionImplementor session)
Method Summary
String | getEntityName() Get the entity name
Serializable | getIdentifier() Get the identifier held by the proxy
Object | getImplementation() Return the underlying persistent object, initializing if necessary
Object | getImplementation(SessionImplementor s) Return the underlying persistent object in the given Session, or null, do not initialize the proxy
SessionImplementor | getSession() Get the session, if this proxy is attached
protected Object | getTarget()
void | initialize() Initialize the proxy, fetching the target entity if necessary
protected boolean | isConnectedToSession()
boolean | isUninitialized() Is the proxy uninitialzed?
boolean | isUnwrap()
void | setIdentifier(Serializable id) Set the identifier property of the proxy
void | setImplementation(Object target) Initialize the proxy manually
void | setSession(SessionImplementor s) Attach the proxy to a session
void | setUnwrap(boolean unwrap)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.proxy.LazyInitializer
getPersistentClass

Constructor Detail

AbstractLazyInitializer

protected AbstractLazyInitializer(String entityName,
                                  Serializable id,
                                  SessionImplementor session)
Method Detail

getIdentifier

public final Serializable getIdentifier()
Description copied from interface: LazyInitializer
Get the identifier held by the proxy

Specified by:
getIdentifier in interface LazyInitializer

setIdentifier

public final void setIdentifier(Serializable id)
Description copied from interface: LazyInitializer
Set the identifier property of the proxy

Specified by:
setIdentifier in interface LazyInitializer

getEntityName

public final String getEntityName()
Description copied from interface: LazyInitializer
Get the entity name

Specified by:
getEntityName in interface LazyInitializer

isUninitialized

public final boolean isUninitialized()
Description copied from interface: LazyInitializer
Is the proxy uninitialzed?

Specified by:
isUninitialized in interface LazyInitializer

getSession

public final SessionImplementor getSession()
Description copied from interface: LazyInitializer
Get the session, if this proxy is attached

Specified by:
getSession in interface LazyInitializer

initialize

public final void initialize()
                      throws HibernateException
Description copied from interface: LazyInitializer
Initialize the proxy, fetching the target entity if necessary

Specified by:
initialize in interface LazyInitializer
Throws:
HibernateException

setSession

public final void setSession(SessionImplementor s)
                      throws HibernateException
Description copied from interface: LazyInitializer
Attach the proxy to a session

Specified by:
setSession in interface LazyInitializer
Throws:
HibernateException

isConnectedToSession

protected final boolean isConnectedToSession()

setImplementation

public final void setImplementation(Object target)
Description copied from interface: LazyInitializer
Initialize the proxy manually

Specified by:
setImplementation in interface LazyInitializer

getImplementation

public final Object getImplementation()
Return the underlying persistent object, initializing if necessary

Specified by:
getImplementation in interface LazyInitializer

getImplementation

public final Object getImplementation(SessionImplementor s)
                               throws HibernateException
Return the underlying persistent object in the given Session, or null, do not initialize the proxy

Specified by:
getImplementation in interface LazyInitializer
Throws:
HibernateException

getTarget

protected final Object getTarget()

isUnwrap

public boolean isUnwrap()
Specified by:
isUnwrap in interface LazyInitializer

setUnwrap

public void setUnwrap(boolean unwrap)
Specified by:
setUnwrap in interface LazyInitializer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HibernateProxyHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy
Class HibernateProxyHelper

java.lang.Object
    extended by org.hibernate.proxy.HibernateProxyHelper
public final class HibernateProxyHelper
extends Object

Utility methods for working with proxies. (this class is being phased out)

Author:
Gavin King

Method Summary
static Class getClassWithoutInitializingProxy(Object object)
Get the class of an instance or the underlying class of a proxy (without initializing the proxy!).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getClassWithoutInitializingProxy

public static Class getClassWithoutInitializingProxy(Object object)
Get the class of an instance or the underlying class of a proxy (without initializing the proxy!). It is almost always better to use the entity name!

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.proxy.dom4j (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.proxy.dom4j

Class Summary
Dom4jLazyInitializer | Lazy initializer for "dom4j" entity representations.
Dom4jProxy | Proxy for "dom4j" entity representations.
Dom4jProxyFactory | Builds proxies for "dom4j" entity representations.


org.hibernate.proxy.dom4j Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.proxy.dom4j

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.proxy.AbstractLazyInitializer (implements org.hibernate.proxy.LazyInitializer)
      • class org.hibernate.proxy.dom4j.Dom4jLazyInitializer (implements java.io.Serializable)
    • class org.hibernate.proxy.dom4j.Dom4jProxy (implements org.dom4j.Element, org.hibernate.proxy.HibernateProxy, java.io.Serializable)
    • class org.hibernate.proxy.dom4j.Dom4jProxyFactory (implements org.hibernate.proxy.ProxyFactory)


Uses of Package org.hibernate.proxy.dom4j (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.proxy.dom4j

Packages that use org.hibernate.proxy.dom4j
org.hibernate.proxy.dom4j

Classes in org.hibernate.proxy.dom4j used by org.hibernate.proxy.dom4j
Dom4jLazyInitializer
Lazy initializer for "dom4j" entity representations.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Dom4jLazyInitializer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.dom4j
Class Dom4jLazyInitializer

java.lang.Object
    extended by org.hibernate.proxy.AbstractLazyInitializer
        extended by org.hibernate.proxy.dom4j.Dom4jLazyInitializer
All Implemented Interfaces:
LazyInitializer, Serializable
public class Dom4jLazyInitializer
extends AbstractLazyInitializer
implements Serializable

Lazy initializer for "dom4j" entity representations.

Author:
Steve Ebersole
See Also:
Serialized Form

Method Summary
org.dom4j.Element | getElement()
Class | getPersistentClass() Get the actual class of the entity (don't use this, use the entityName)
Methods inherited from class org.hibernate.proxy.AbstractLazyInitializer
getEntityName, getIdentifier, getImplementation, getImplementation, getSession, getTarget, initialize, isConnectedToSession, isUninitialized, isUnwrap, setIdentifier, setImplementation, setSession, setUnwrap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getElement

public org.dom4j.Element getElement()

getPersistentClass

public Class getPersistentClass()
Description copied from interface: LazyInitializer
Get the actual class of the entity (don't use this, use the entityName)

Specified by:
getPersistentClass in interface LazyInitializer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Dom4jProxy (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.dom4j
Class Dom4jProxy

java.lang.Object
    extended by org.hibernate.proxy.dom4j.Dom4jProxy
All Implemented Interfaces:
org.dom4j.Branch, Cloneable, org.dom4j.Element, HibernateProxy, org.dom4j.Node, Serializable
public class Dom4jProxy
extends Object
implements HibernateProxy, org.dom4j.Element, Serializable

Proxy for "dom4j" entity representations.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
Dom4jProxy(Dom4jLazyInitializer li)
Method Summary
void | accept(org.dom4j.Visitor visitor)
void | add(org.dom4j.Attribute attribute)
void | add(org.dom4j.CDATA cdata)
void | add(org.dom4j.Comment comment)
void | add(org.dom4j.Element element)
void | add(org.dom4j.Entity entity)
void | add(org.dom4j.Namespace namespace)
void | add(org.dom4j.Node node)
void | add(org.dom4j.ProcessingInstruction processingInstruction)
void | add(org.dom4j.Text text)
org.dom4j.Element | addAttribute(org.dom4j.QName attrName, String text)
org.dom4j.Element | addAttribute(String attrName, String text)
org.dom4j.Element | addCDATA(String text)
org.dom4j.Element | addComment(String text)
org.dom4j.Element | addElement(org.dom4j.QName qName)
org.dom4j.Element | addElement(String name)
org.dom4j.Element | addElement(String name, String text)
org.dom4j.Element | addEntity(String name, String text)
List | additionalNamespaces()
org.dom4j.Element | addNamespace(String prefix, String uri)
org.dom4j.Element | addProcessingInstruction(String target, Map data)
org.dom4j.Element | addProcessingInstruction(String target, String text)
org.dom4j.Element | addText(String text)
void | appendAttributes(org.dom4j.Element element)
void | appendContent(org.dom4j.Branch branch)
String | asXML()
org.dom4j.Node | asXPathResult(org.dom4j.Element element)
org.dom4j.Attribute | attribute(int i)
org.dom4j.Attribute | attribute(org.dom4j.QName qName)
org.dom4j.Attribute | attribute(String name)
int | attributeCount()
Iterator | attributeIterator()
List | attributes()
String | attributeValue(org.dom4j.QName qName)
String | attributeValue(org.dom4j.QName qName, String defaultValue)
String | attributeValue(String name)
String | attributeValue(String name, String defaultValue)
void | clearContent()
Object | clone()
List | content()
org.dom4j.Element | createCopy()
org.dom4j.Element | createCopy(org.dom4j.QName qName)
org.dom4j.Element | createCopy(String name)
org.dom4j.XPath | createXPath(String xpath)
List | declaredNamespaces()
org.dom4j.Node | detach()
org.dom4j.Element | element(org.dom4j.QName qName)
org.dom4j.Element | element(String name)
org.dom4j.Element | elementByID(String id)
Iterator | elementIterator()
Iterator | elementIterator(org.dom4j.QName qName)
Iterator | elementIterator(String name)
List | elements()
List | elements(org.dom4j.QName qName)
List | elements(String name)
String | elementText(org.dom4j.QName qName)
String | elementText(String name)
String | elementTextTrim(org.dom4j.QName qName)
String | elementTextTrim(String name)
Object | getData()
org.dom4j.Document | getDocument()
LazyInitializer | getHibernateLazyInitializer() Get the underlying lazy initialization handler.
String | getName()
org.dom4j.Namespace | getNamespace()
org.dom4j.Namespace | getNamespaceForPrefix(String s)
org.dom4j.Namespace | getNamespaceForURI(String s)
String | getNamespacePrefix()
List | getNamespacesForURI(String s)
String | getNamespaceURI()
short | getNodeType()
String | getNodeTypeName()
org.dom4j.Element | getParent()
String | getPath()
String | getPath(org.dom4j.Element element)
org.dom4j.QName | getQName()
org.dom4j.QName | getQName(String s)
String | getQualifiedName()
String | getStringValue()
String | getText()
String | getTextTrim()
String | getUniquePath()
String | getUniquePath(org.dom4j.Element element)
org.dom4j.Node | getXPathResult(int i)
boolean | hasContent()
boolean | hasMixedContent()
int | indexOf(org.dom4j.Node node)
boolean | isReadOnly()
boolean | isRootElement()
boolean | isTextOnly()
boolean | matches(String xpath)
org.dom4j.Node | node(int i)
int | nodeCount()
Iterator | nodeIterator()
void | normalize()
Number | numberValueOf(String xpath)
org.dom4j.ProcessingInstruction | processingInstruction(String name)
List | processingInstructions()
List | processingInstructions(String name)
boolean | remove(org.dom4j.Attribute attribute)
boolean | remove(org.dom4j.CDATA cdata)
boolean | remove(org.dom4j.Comment comment)
boolean | remove(org.dom4j.Element element)
boolean | remove(org.dom4j.Entity entity)
boolean | remove(org.dom4j.Namespace namespace)
boolean | remove(org.dom4j.Node node)
boolean | remove(org.dom4j.ProcessingInstruction processingInstruction)
boolean | remove(org.dom4j.Text text)
boolean | removeProcessingInstruction(String name)
List | selectNodes(String xpath)
List | selectNodes(String xpath, String comparison)
List | selectNodes(String xpath, String comparison, boolean removeDups)
Object | selectObject(String xpath)
org.dom4j.Node | selectSingleNode(String xpath)
void | setAttributes(List list)
void | setAttributeValue(org.dom4j.QName qName, String value) Deprecated.
void | setAttributeValue(String name, String value) Deprecated.
void | setContent(List list)
void | setData(Object data)
void | setDocument(org.dom4j.Document document)
void | setName(String name)
void | setParent(org.dom4j.Element element)
void | setProcessingInstructions(List list)
void | setQName(org.dom4j.QName qName)
void | setText(String text)
boolean | supportsParent()
String | valueOf(String xpath)
void | write(Writer writer)
Object | writeReplace() Perform serialization-time write-replacement of this proxy.
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Dom4jProxy

public Dom4jProxy(Dom4jLazyInitializer li)
Method Detail

writeReplace

public Object writeReplace()
Description copied from interface: HibernateProxy
Perform serialization-time write-replacement of this proxy.

Specified by:
writeReplace in interface HibernateProxy
Returns:
The serializable proxy replacement.

getHibernateLazyInitializer

public LazyInitializer getHibernateLazyInitializer()
Description copied from interface: HibernateProxy
Get the underlying lazy initialization handler.

Specified by:
getHibernateLazyInitializer in interface HibernateProxy
Returns:
The lazy initializer.

getQName

public org.dom4j.QName getQName()
Specified by:
getQName in interface org.dom4j.Element

getQName

public org.dom4j.QName getQName(String s)
Specified by:
getQName in interface org.dom4j.Element

setQName

public void setQName(org.dom4j.QName qName)
Specified by:
setQName in interface org.dom4j.Element

getNamespace

public org.dom4j.Namespace getNamespace()
Specified by:
getNamespace in interface org.dom4j.Element

getNamespaceForPrefix

public org.dom4j.Namespace getNamespaceForPrefix(String s)
Specified by:
getNamespaceForPrefix in interface org.dom4j.Element

getNamespaceForURI

public org.dom4j.Namespace getNamespaceForURI(String s)
Specified by:
getNamespaceForURI in interface org.dom4j.Element

getNamespacesForURI

public List getNamespacesForURI(String s)
Specified by:
getNamespacesForURI in interface org.dom4j.Element

getNamespacePrefix

public String getNamespacePrefix()
Specified by:
getNamespacePrefix in interface org.dom4j.Element

getNamespaceURI

public String getNamespaceURI()
Specified by:
getNamespaceURI in interface org.dom4j.Element

getQualifiedName

public String getQualifiedName()
Specified by:
getQualifiedName in interface org.dom4j.Element

additionalNamespaces

public List additionalNamespaces()
Specified by:
additionalNamespaces in interface org.dom4j.Element

declaredNamespaces

public List declaredNamespaces()
Specified by:
declaredNamespaces in interface org.dom4j.Element

addAttribute

public org.dom4j.Element addAttribute(String attrName,
                                      String text)
Specified by:
addAttribute in interface org.dom4j.Element

addAttribute

public org.dom4j.Element addAttribute(org.dom4j.QName attrName,
                                      String text)
Specified by:
addAttribute in interface org.dom4j.Element

addComment

public org.dom4j.Element addComment(String text)
Specified by:
addComment in interface org.dom4j.Element

addCDATA

public org.dom4j.Element addCDATA(String text)
Specified by:
addCDATA in interface org.dom4j.Element

addEntity

public org.dom4j.Element addEntity(String name,
                                   String text)
Specified by:
addEntity in interface org.dom4j.Element

addNamespace

public org.dom4j.Element addNamespace(String prefix,
                                      String uri)
Specified by:
addNamespace in interface org.dom4j.Element

addProcessingInstruction

public org.dom4j.Element addProcessingInstruction(String target,
                                                  String text)
Specified by:
addProcessingInstruction in interface org.dom4j.Element

addProcessingInstruction

public org.dom4j.Element addProcessingInstruction(String target,
                                                  Map data)
Specified by:
addProcessingInstruction in interface org.dom4j.Element

addText

public org.dom4j.Element addText(String text)
Specified by:
addText in interface org.dom4j.Element

add

public void add(org.dom4j.Attribute attribute)
Specified by:
add in interface org.dom4j.Element

add

public void add(org.dom4j.CDATA cdata)
Specified by:
add in interface org.dom4j.Element

add

public void add(org.dom4j.Entity entity)
Specified by:
add in interface org.dom4j.Element

add

public void add(org.dom4j.Text text)
Specified by:
add in interface org.dom4j.Element

add

public void add(org.dom4j.Namespace namespace)
Specified by:
add in interface org.dom4j.Element

remove

public boolean remove(org.dom4j.Attribute attribute)
Specified by:
remove in interface org.dom4j.Element

remove

public boolean remove(org.dom4j.CDATA cdata)
Specified by:
remove in interface org.dom4j.Element

remove

public boolean remove(org.dom4j.Entity entity)
Specified by:
remove in interface org.dom4j.Element

remove

public boolean remove(org.dom4j.Namespace namespace)
Specified by:
remove in interface org.dom4j.Element

remove

public boolean remove(org.dom4j.Text text)
Specified by:
remove in interface org.dom4j.Element

supportsParent

public boolean supportsParent()
Specified by:
supportsParent in interface org.dom4j.Node

getParent

public org.dom4j.Element getParent()
Specified by:
getParent in interface org.dom4j.Node

setParent

public void setParent(org.dom4j.Element element)
Specified by:
setParent in interface org.dom4j.Node

getDocument

public org.dom4j.Document getDocument()
Specified by:
getDocument in interface org.dom4j.Node

setDocument

public void setDocument(org.dom4j.Document document)
Specified by:
setDocument in interface org.dom4j.Node

isReadOnly

public boolean isReadOnly()
Specified by:
isReadOnly in interface org.dom4j.Node

hasContent

public boolean hasContent()
Specified by:
hasContent in interface org.dom4j.Node

getName

public String getName()
Specified by:
getName in interface org.dom4j.Node

setName

public void setName(String name)
Specified by:
setName in interface org.dom4j.Node

getText

public String getText()
Specified by:
getText in interface org.dom4j.Element

setText

public void setText(String text)
Specified by:
setText in interface org.dom4j.Node

getTextTrim

public String getTextTrim()
Specified by:
getTextTrim in interface org.dom4j.Element

getStringValue

public String getStringValue()
Specified by:
getStringValue in interface org.dom4j.Element

getPath

public String getPath()
Specified by:
getPath in interface org.dom4j.Node

getPath

public String getPath(org.dom4j.Element element)
Specified by:
getPath in interface org.dom4j.Node

getUniquePath

public String getUniquePath()
Specified by:
getUniquePath in interface org.dom4j.Node

getUniquePath

public String getUniquePath(org.dom4j.Element element)
Specified by:
getUniquePath in interface org.dom4j.Node

asXML

public String asXML()
Specified by:
asXML in interface org.dom4j.Node

write

public void write(Writer writer)
           throws IOException
Specified by:
write in interface org.dom4j.Node
Throws:
IOException

getNodeType

public short getNodeType()
Specified by:
getNodeType in interface org.dom4j.Node

getNodeTypeName

public String getNodeTypeName()
Specified by:
getNodeTypeName in interface org.dom4j.Node

detach

public org.dom4j.Node detach()
Specified by:
detach in interface org.dom4j.Node

selectNodes

public List selectNodes(String xpath)
Specified by:
selectNodes in interface org.dom4j.Node

selectObject

public Object selectObject(String xpath)
Specified by:
selectObject in interface org.dom4j.Node

selectNodes

public List selectNodes(String xpath,
                        String comparison)
Specified by:
selectNodes in interface org.dom4j.Node

selectNodes

public List selectNodes(String xpath,
                        String comparison,
                        boolean removeDups)
Specified by:
selectNodes in interface org.dom4j.Node

selectSingleNode

public org.dom4j.Node selectSingleNode(String xpath)
Specified by:
selectSingleNode in interface org.dom4j.Node

valueOf

public String valueOf(String xpath)
Specified by:
valueOf in interface org.dom4j.Node

numberValueOf

public Number numberValueOf(String xpath)
Specified by:
numberValueOf in interface org.dom4j.Node

matches

public boolean matches(String xpath)
Specified by:
matches in interface org.dom4j.Node

createXPath

public org.dom4j.XPath createXPath(String xpath)
                            throws org.dom4j.InvalidXPathException
Specified by:
createXPath in interface org.dom4j.Node
Throws:
org.dom4j.InvalidXPathException

asXPathResult

public org.dom4j.Node asXPathResult(org.dom4j.Element element)
Specified by:
asXPathResult in interface org.dom4j.Node

accept

public void accept(org.dom4j.Visitor visitor)
Specified by:
accept in interface org.dom4j.Node

clone

public Object clone()
Specified by:
clone in interface org.dom4j.Node

getData

public Object getData()
Specified by:
getData in interface org.dom4j.Element

setData

public void setData(Object data)
Specified by:
setData in interface org.dom4j.Element

attributes

public List attributes()
Specified by:
attributes in interface org.dom4j.Element

setAttributes

public void setAttributes(List list)
Specified by:
setAttributes in interface org.dom4j.Element

attributeCount

public int attributeCount()
Specified by:
attributeCount in interface org.dom4j.Element

attributeIterator

public Iterator attributeIterator()
Specified by:
attributeIterator in interface org.dom4j.Element

attribute

public org.dom4j.Attribute attribute(int i)
Specified by:
attribute in interface org.dom4j.Element

attribute

public org.dom4j.Attribute attribute(String name)
Specified by:
attribute in interface org.dom4j.Element

attribute

public org.dom4j.Attribute attribute(org.dom4j.QName qName)
Specified by:
attribute in interface org.dom4j.Element

attributeValue

public String attributeValue(String name)
Specified by:
attributeValue in interface org.dom4j.Element

attributeValue

public String attributeValue(String name,
                             String defaultValue)
Specified by:
attributeValue in interface org.dom4j.Element

attributeValue

public String attributeValue(org.dom4j.QName qName)
Specified by:
attributeValue in interface org.dom4j.Element

attributeValue

public String attributeValue(org.dom4j.QName qName,
                             String defaultValue)
Specified by:
attributeValue in interface org.dom4j.Element

setAttributeValue

public void setAttributeValue(String name,
                              String value)
Deprecated.

Specified by:
setAttributeValue in interface org.dom4j.Element

setAttributeValue

public void setAttributeValue(org.dom4j.QName qName,
                              String value)
Deprecated.

Specified by:
setAttributeValue in interface org.dom4j.Element

element

public org.dom4j.Element element(String name)
Specified by:
element in interface org.dom4j.Element

element

public org.dom4j.Element element(org.dom4j.QName qName)
Specified by:
element in interface org.dom4j.Element

elements

public List elements()
Specified by:
elements in interface org.dom4j.Element

elements

public List elements(String name)
Specified by:
elements in interface org.dom4j.Element

elements

public List elements(org.dom4j.QName qName)
Specified by:
elements in interface org.dom4j.Element

elementIterator

public Iterator elementIterator()
Specified by:
elementIterator in interface org.dom4j.Element

elementIterator

public Iterator elementIterator(String name)
Specified by:
elementIterator in interface org.dom4j.Element

elementIterator

public Iterator elementIterator(org.dom4j.QName qName)
Specified by:
elementIterator in interface org.dom4j.Element

isRootElement

public boolean isRootElement()
Specified by:
isRootElement in interface org.dom4j.Element

hasMixedContent

public boolean hasMixedContent()
Specified by:
hasMixedContent in interface org.dom4j.Element

isTextOnly

public boolean isTextOnly()
Specified by:
isTextOnly in interface org.dom4j.Element

appendAttributes

public void appendAttributes(org.dom4j.Element element)
Specified by:
appendAttributes in interface org.dom4j.Element

createCopy

public org.dom4j.Element createCopy()
Specified by:
createCopy in interface org.dom4j.Element

createCopy

public org.dom4j.Element createCopy(String name)
Specified by:
createCopy in interface org.dom4j.Element

createCopy

public org.dom4j.Element createCopy(org.dom4j.QName qName)
Specified by:
createCopy in interface org.dom4j.Element

elementText

public String elementText(String name)
Specified by:
elementText in interface org.dom4j.Element

elementText

public String elementText(org.dom4j.QName qName)
Specified by:
elementText in interface org.dom4j.Element

elementTextTrim

public String elementTextTrim(String name)
Specified by:
elementTextTrim in interface org.dom4j.Element

elementTextTrim

public String elementTextTrim(org.dom4j.QName qName)
Specified by:
elementTextTrim in interface org.dom4j.Element

getXPathResult

public org.dom4j.Node getXPathResult(int i)
Specified by:
getXPathResult in interface org.dom4j.Element

node

public org.dom4j.Node node(int i)
Specified by:
node in interface org.dom4j.Branch

indexOf

public int indexOf(org.dom4j.Node node)
Specified by:
indexOf in interface org.dom4j.Branch

nodeCount

public int nodeCount()
Specified by:
nodeCount in interface org.dom4j.Branch

elementByID

public org.dom4j.Element elementByID(String id)
Specified by:
elementByID in interface org.dom4j.Branch

content

public List content()
Specified by:
content in interface org.dom4j.Branch

nodeIterator

public Iterator nodeIterator()
Specified by:
nodeIterator in interface org.dom4j.Branch

setContent

public void setContent(List list)
Specified by:
setContent in interface org.dom4j.Branch

appendContent

public void appendContent(org.dom4j.Branch branch)
Specified by:
appendContent in interface org.dom4j.Branch

clearContent

public void clearContent()
Specified by:
clearContent in interface org.dom4j.Branch

processingInstructions

public List processingInstructions()
Specified by:
processingInstructions in interface org.dom4j.Branch

processingInstructions

public List processingInstructions(String name)
Specified by:
processingInstructions in interface org.dom4j.Branch

processingInstruction

public org.dom4j.ProcessingInstruction processingInstruction(String name)
Specified by:
processingInstruction in interface org.dom4j.Branch

setProcessingInstructions

public void setProcessingInstructions(List list)
Specified by:
setProcessingInstructions in interface org.dom4j.Branch

addElement

public org.dom4j.Element addElement(String name)
Specified by:
addElement in interface org.dom4j.Branch

addElement

public org.dom4j.Element addElement(org.dom4j.QName qName)
Specified by:
addElement in interface org.dom4j.Branch

addElement

public org.dom4j.Element addElement(String name,
                                    String text)
Specified by:
addElement in interface org.dom4j.Branch

removeProcessingInstruction

public boolean removeProcessingInstruction(String name)
Specified by:
removeProcessingInstruction in interface org.dom4j.Branch

add

public void add(org.dom4j.Node node)
Specified by:
add in interface org.dom4j.Branch

add

public void add(org.dom4j.Comment comment)
Specified by:
add in interface org.dom4j.Branch

add

public void add(org.dom4j.Element element)
Specified by:
add in interface org.dom4j.Branch

add

public void add(org.dom4j.ProcessingInstruction processingInstruction)
Specified by:
add in interface org.dom4j.Branch

remove

public boolean remove(org.dom4j.Node node)
Specified by:
remove in interface org.dom4j.Branch

remove

public boolean remove(org.dom4j.Comment comment)
Specified by:
remove in interface org.dom4j.Branch

remove

public boolean remove(org.dom4j.Element element)
Specified by:
remove in interface org.dom4j.Branch

remove

public boolean remove(org.dom4j.ProcessingInstruction processingInstruction)
Specified by:
remove in interface org.dom4j.Branch

normalize

public void normalize()
Specified by:
normalize in interface org.dom4j.Branch
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jProxyFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.dom4j
Class Dom4jProxyFactory

java.lang.Object
    extended by org.hibernate.proxy.dom4j.Dom4jProxyFactory
All Implemented Interfaces:
ProxyFactory
public class Dom4jProxyFactory
extends Object
implements ProxyFactory

Builds proxies for "dom4j" entity representations.

Author:
Steve Ebersole

Constructor Summary
Dom4jProxyFactory()
Method Summary
HibernateProxy | getProxy(Serializable id, SessionImplementor session) Create a new proxy
void | postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType) Called immediately after instantiation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Dom4jProxyFactory

public Dom4jProxyFactory()
Method Detail

postInstantiate

public void postInstantiate(String entityName,
                            Class persistentClass,
                            Set interfaces,
                            Method getIdentifierMethod,
                            Method setIdentifierMethod,
                            AbstractComponentType componentIdType)
                     throws HibernateException
Called immediately after instantiation

Specified by:
postInstantiate in interface ProxyFactory
Parameters:
entityName - The name of the entity for which this factory should generate proxies.
persistentClass - The entity class for which to generate proxies; not always the same as the entityName.
interfaces - The interfaces to expose in the generated proxy; HibernateProxy is already included in this collection.
getIdentifierMethod - Reference to the identifier getter method; invocation on this method should not force initialization
setIdentifierMethod - Reference to the identifier setter method; invocation on this method should not force initialization
componentIdType - For composite identifier types, a reference to the type of the identifier property; again accessing the id should generally not cause initialization - but need to bear in mind mappings.
Throws:
HibernateException - Indicates a problem completing post instantiation initialization.

getProxy

public HibernateProxy getProxy(Serializable id,
                               SessionImplementor session)
                        throws HibernateException
Create a new proxy

Specified by:
getProxy in interface ProxyFactory
Parameters:
id - The id value for the proxy to be generated.
session - The session to which the generated proxy will be associated.
Returns:
The generated proxy.
Throws:
HibernateException - Indicates problems generating the requested proxy.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.proxy.map (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.proxy.map

Class Summary
MapLazyInitializer | Lazy initializer for "dynamic-map" entity representations.
MapProxy | Proxy for "dynamic-map" entity representations.
MapProxyFactory |


org.hibernate.proxy.map Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.proxy.map

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.proxy.AbstractLazyInitializer (implements org.hibernate.proxy.LazyInitializer)
      • class org.hibernate.proxy.map.MapLazyInitializer (implements java.io.Serializable)
    • class org.hibernate.proxy.map.MapProxy (implements org.hibernate.proxy.HibernateProxy, java.util.Map, java.io.Serializable)
    • class org.hibernate.proxy.map.MapProxyFactory (implements org.hibernate.proxy.ProxyFactory)


Uses of Package org.hibernate.proxy.map (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.proxy.map

No usage of org.hibernate.proxy.map

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


MapLazyInitializer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.map
Class MapLazyInitializer

java.lang.Object
    extended by org.hibernate.proxy.AbstractLazyInitializer
        extended by org.hibernate.proxy.map.MapLazyInitializer
All Implemented Interfaces:
LazyInitializer, Serializable
public class MapLazyInitializer
extends AbstractLazyInitializer
implements Serializable

Lazy initializer for "dynamic-map" entity representations.

Author:
Gavin King
See Also:
Serialized Form

Method Summary
Map | getMap()
Class | getPersistentClass() Get the actual class of the entity (don't use this, use the entityName)
Methods inherited from class org.hibernate.proxy.AbstractLazyInitializer
getEntityName, getIdentifier, getImplementation, getImplementation, getSession, getTarget, initialize, isConnectedToSession, isUninitialized, isUnwrap, setIdentifier, setImplementation, setSession, setUnwrap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getMap

public Map getMap()

getPersistentClass

public Class getPersistentClass()
Description copied from interface: LazyInitializer
Get the actual class of the entity (don't use this, use the entityName)

Specified by:
getPersistentClass in interface LazyInitializer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


MapProxy (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.map
Class MapProxy

java.lang.Object
    extended by org.hibernate.proxy.map.MapProxy
All Implemented Interfaces:
HibernateProxy, Map, Serializable
public class MapProxy
extends Object
implements HibernateProxy, Map, Serializable

Proxy for "dynamic-map" entity representations.

Author:
Gavin King
See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class java.util.Map
Map.Entry
Method Summary
void | clear()
boolean | containsKey(Object key)
boolean | containsValue(Object value)
Set | entrySet()
Object | get(Object key)
LazyInitializer | getHibernateLazyInitializer() Get the underlying lazy initialization handler.
boolean | isEmpty()
Set | keySet()
Object | put(Object key, Object value)
void | putAll(Map t)
Object | remove(Object key)
int | size()
Collection | values()
Object | writeReplace() Perform serialization-time write-replacement of this proxy.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode

Method Detail

writeReplace

public Object writeReplace()
Description copied from interface: HibernateProxy
Perform serialization-time write-replacement of this proxy.

Specified by:
writeReplace in interface HibernateProxy
Returns:
The serializable proxy replacement.

getHibernateLazyInitializer

public LazyInitializer getHibernateLazyInitializer()
Description copied from interface: HibernateProxy
Get the underlying lazy initialization handler.

Specified by:
getHibernateLazyInitializer in interface HibernateProxy
Returns:
The lazy initializer.

size

public int size()
Specified by:
size in interface Map

clear

public void clear()
Specified by:
clear in interface Map

isEmpty

public boolean isEmpty()
Specified by:
isEmpty in interface Map

containsKey

public boolean containsKey(Object key)
Specified by:
containsKey in interface Map

containsValue

public boolean containsValue(Object value)
Specified by:
containsValue in interface Map

values

public Collection values()
Specified by:
values in interface Map

putAll

public void putAll(Map t)
Specified by:
putAll in interface Map

entrySet

public Set entrySet()
Specified by:
entrySet in interface Map

keySet

public Set keySet()
Specified by:
keySet in interface Map

get

public Object get(Object key)
Specified by:
get in interface Map

remove

public Object remove(Object key)
Specified by:
remove in interface Map

put

public Object put(Object key,
                  Object value)
Specified by:
put in interface Map
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MapProxyFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.map
Class MapProxyFactory

java.lang.Object
    extended by org.hibernate.proxy.map.MapProxyFactory
All Implemented Interfaces:
ProxyFactory
public class MapProxyFactory
extends Object
implements ProxyFactory

Author:
Gavin King

Constructor Summary
MapProxyFactory()
Method Summary
HibernateProxy | getProxy(Serializable id, SessionImplementor session) Create a new proxy instance
void | postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType) Called immediately after instantiation of this factory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MapProxyFactory

public MapProxyFactory()
Method Detail

postInstantiate

public void postInstantiate(String entityName,
                            Class persistentClass,
                            Set interfaces,
                            Method getIdentifierMethod,
                            Method setIdentifierMethod,
                            AbstractComponentType componentIdType)
                     throws HibernateException
Description copied from interface: ProxyFactory
Called immediately after instantiation of this factory.

Essentially equivalent to contructor injection, but contracted here via interface.

Specified by:
postInstantiate in interface ProxyFactory
Parameters:
entityName - The name of the entity for which this factory should generate proxies.
persistentClass - The entity class for which to generate proxies; not always the same as the entityName.
interfaces - The interfaces to expose in the generated proxy; HibernateProxy is already included in this collection.
getIdentifierMethod - Reference to the identifier getter method; invocation on this method should not force initialization
setIdentifierMethod - Reference to the identifier setter method; invocation on this method should not force initialization
componentIdType - For composite identifier types, a reference to the type of the identifier property; again accessing the id should generally not cause initialization - but need to bear in mind mappings.
Throws:
HibernateException - Indicates a problem completing post instantiation initialization.

getProxy

public HibernateProxy getProxy(Serializable id,
                               SessionImplementor session)
                        throws HibernateException
Description copied from interface: ProxyFactory
Create a new proxy instance

Specified by:
getProxy in interface ProxyFactory
Parameters:
id - The id value for the proxy to be generated.
session - The session to which the generated proxy will be associated.
Returns:
The generated proxy.
Throws:
HibernateException - Indicates problems generating the requested proxy.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.proxy.pojo (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.proxy.pojo

Class Summary
BasicLazyInitializer Lazy initializer for POJOs


org.hibernate.proxy.pojo Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.proxy.pojo

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.proxy.AbstractLazyInitializer (implements org.hibernate.proxy.LazyInitializer)
      • class org.hibernate.proxy.pojo.BasicLazyInitializer


Uses of Package org.hibernate.proxy.pojo (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.proxy.pojo

Packages that use org.hibernate.proxy.pojo
org.hibernate.proxy.pojo.cglib
org.hibernate.proxy.pojo.javassist

Classes in org.hibernate.proxy.pojo used by org.hibernate.proxy.pojo.cglib
BasicLazyInitializer
Lazy initializer for POJOs

Classes in org.hibernate.proxy.pojo used by org.hibernate.proxy.pojo.javassist
BasicLazyInitializer
Lazy initializer for POJOs

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BasicLazyInitializer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.pojo
Class BasicLazyInitializer

java.lang.Object
    extended by org.hibernate.proxy.AbstractLazyInitializer
        extended by org.hibernate.proxy.pojo.BasicLazyInitializer
All Implemented Interfaces:
LazyInitializer
Direct Known Subclasses:
CGLIBLazyInitializer, JavassistLazyInitializer
public abstract class BasicLazyInitializer
extends AbstractLazyInitializer

Lazy initializer for POJOs

Author:
Gavin King

Field Summary
protected AbstractComponentType | componentIdType
protected Method | getIdentifierMethod
protected static Object | INVOKE_IMPLEMENTATION
protected boolean | overridesEquals
protected Class | persistentClass
protected Method | setIdentifierMethod
Constructor Summary
protected BasicLazyInitializer(String entityName, Class persistentClass, Serializable id, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, SessionImplementor session)
Method Summary
Class | getPersistentClass() Get the actual class of the entity (don't use this, use the entityName)
protected Object | invoke(Method method, Object[] args, Object proxy)
protected abstract Object | serializableProxy()
Methods inherited from class org.hibernate.proxy.AbstractLazyInitializer
getEntityName, getIdentifier, getImplementation, getImplementation, getSession, getTarget, initialize, isConnectedToSession, isUninitialized, isUnwrap, setIdentifier, setImplementation, setSession, setUnwrap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INVOKE_IMPLEMENTATION

protected static final Object INVOKE_IMPLEMENTATION

persistentClass

protected Class persistentClass

getIdentifierMethod

protected Method getIdentifierMethod

setIdentifierMethod

protected Method setIdentifierMethod

overridesEquals

protected boolean overridesEquals

componentIdType

protected AbstractComponentType componentIdType
Constructor Detail

BasicLazyInitializer

protected BasicLazyInitializer(String entityName,
                               Class persistentClass,
                               Serializable id,
                               Method getIdentifierMethod,
                               Method setIdentifierMethod,
                               AbstractComponentType componentIdType,
                               SessionImplementor session)
Method Detail

serializableProxy

protected abstract Object serializableProxy()

invoke

protected final Object invoke(Method method,
                              Object[] args,
                              Object proxy)
                       throws Throwable
Throws:
Throwable

getPersistentClass

public final Class getPersistentClass()
Description copied from interface: LazyInitializer
Get the actual class of the entity (don't use this, use the entityName)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.proxy.pojo.cglib (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.proxy.pojo.cglib

Class Summary
CGLIBLazyInitializer | A LazyInitializer implemented using the CGLIB bytecode generation library
CGLIBProxyFactory |
SerializableProxy | Serializable placeholder for CGLIB proxies


org.hibernate.proxy.pojo.cglib Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.proxy.pojo.cglib

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.proxy.AbstractLazyInitializer (implements org.hibernate.proxy.LazyInitializer)
      • class org.hibernate.proxy.pojo.BasicLazyInitializer
        • class org.hibernate.proxy.pojo.cglib.CGLIBLazyInitializer (implements net.sf.cglib.proxy.InvocationHandler)
    • class org.hibernate.proxy.pojo.cglib.CGLIBProxyFactory (implements org.hibernate.proxy.ProxyFactory)
    • class org.hibernate.proxy.pojo.cglib.SerializableProxy (implements java.io.Serializable)


Uses of Package org.hibernate.proxy.pojo.cglib (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.proxy.pojo.cglib

No usage of org.hibernate.proxy.pojo.cglib

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CGLIBLazyInitializer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.pojo.cglib
Class CGLIBLazyInitializer

java.lang.Object
    extended by org.hibernate.proxy.AbstractLazyInitializer
        extended by org.hibernate.proxy.pojo.BasicLazyInitializer
            extended by org.hibernate.proxy.pojo.cglib.CGLIBLazyInitializer
All Implemented Interfaces:
net.sf.cglib.proxy.Callback, net.sf.cglib.proxy.InvocationHandler, LazyInitializer
public final class CGLIBLazyInitializer
extends BasicLazyInitializer
implements net.sf.cglib.proxy.InvocationHandler

A LazyInitializer implemented using the CGLIB bytecode generation library

Field Summary
Fields inherited from class org.hibernate.proxy.pojo.BasicLazyInitializer
componentIdType, getIdentifierMethod, INVOKE_IMPLEMENTATION, overridesEquals, persistentClass, setIdentifierMethod
Method Summary
static HibernateProxy | getProxy(Class factory, String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)
static Class | getProxyFactory(Class persistentClass, Class[] interfaces)
Object | invoke(Object proxy, Method method, Object[] args)
protected Object | serializableProxy()
Methods inherited from class org.hibernate.proxy.pojo.BasicLazyInitializer
getPersistentClass, invoke
Methods inherited from class org.hibernate.proxy.AbstractLazyInitializer
getEntityName, getIdentifier, getImplementation, getImplementation, getSession, getTarget, initialize, isConnectedToSession, isUninitialized, isUnwrap, setIdentifier, setImplementation, setSession, setUnwrap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getProxy

public static HibernateProxy getProxy(Class factory,
                                      String entityName,
                                      Class persistentClass,
                                      Class[] interfaces,
                                      Method getIdentifierMethod,
                                      Method setIdentifierMethod,
                                      AbstractComponentType componentIdType,
                                      Serializable id,
                                      SessionImplementor session)
                               throws HibernateException
Throws:
HibernateException

getProxyFactory

public static Class getProxyFactory(Class persistentClass,
                                    Class[] interfaces)
                             throws HibernateException
Throws:
HibernateException

invoke

public Object invoke(Object proxy,
                     Method method,
                     Object[] args)
              throws Throwable
Specified by:
invoke in interface net.sf.cglib.proxy.InvocationHandler
Throws:
Throwable

serializableProxy

protected Object serializableProxy()
Specified by:
serializableProxy in class BasicLazyInitializer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CGLIBProxyFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.pojo.cglib
Class CGLIBProxyFactory

java.lang.Object
    extended by org.hibernate.proxy.pojo.cglib.CGLIBProxyFactory
All Implemented Interfaces:
ProxyFactory
public class CGLIBProxyFactory
extends Object
implements ProxyFactory

Author:
Gavin King

Field Summary
protected static Class[] NO_CLASSES
Constructor Summary
CGLIBProxyFactory()
Method Summary
HibernateProxy | getProxy(Serializable id, SessionImplementor session) Create a new proxy instance
void | postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType) Called immediately after instantiation of this factory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NO_CLASSES

protected static final Class[] NO_CLASSES
Constructor Detail

CGLIBProxyFactory

public CGLIBProxyFactory()
Method Detail

postInstantiate

public void postInstantiate(String entityName,
                            Class persistentClass,
                            Set interfaces,
                            Method getIdentifierMethod,
                            Method setIdentifierMethod,
                            AbstractComponentType componentIdType)
                     throws HibernateException
Description copied from interface: ProxyFactory
Called immediately after instantiation of this factory.

Essentially equivalent to contructor injection, but contracted here via interface.

Specified by:
postInstantiate in interface ProxyFactory
Parameters:
entityName - The name of the entity for which this factory should generate proxies.
persistentClass - The entity class for which to generate proxies; not always the same as the entityName.
interfaces - The interfaces to expose in the generated proxy; HibernateProxy is already included in this collection.
getIdentifierMethod - Reference to the identifier getter method; invocation on this method should not force initialization
setIdentifierMethod - Reference to the identifier setter method; invocation on this method should not force initialization
componentIdType - For composite identifier types, a reference to the type of the identifier property; again accessing the id should generally not cause initialization - but need to bear in mind mappings.
Throws:
HibernateException - Indicates a problem completing post instantiation initialization.

getProxy

public HibernateProxy getProxy(Serializable id,
                               SessionImplementor session)
                        throws HibernateException
Description copied from interface: ProxyFactory
Create a new proxy instance

Specified by:
getProxy in interface ProxyFactory
Parameters:
id - The id value for the proxy to be generated.
session - The session to which the generated proxy will be associated.
Returns:
The generated proxy.
Throws:
HibernateException - Indicates problems generating the requested proxy.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SerializableProxy (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.pojo.cglib
Class SerializableProxy

java.lang.Object
    extended by org.hibernate.proxy.pojo.cglib.SerializableProxy
All Implemented Interfaces:
Serializable
public final class SerializableProxy
extends Object
implements Serializable

Serializable placeholder for CGLIB proxies

See Also:
Serialized Form

Constructor Summary
SerializableProxy()
SerializableProxy(String entityName, Class persistentClass, Class[] interfaces, Serializable id, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SerializableProxy

public SerializableProxy()

SerializableProxy

public SerializableProxy(String entityName,
                         Class persistentClass,
                         Class[] interfaces,
                         Serializable id,
                         Method getIdentifierMethod,
                         Method setIdentifierMethod,
                         AbstractComponentType componentIdType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.proxy.pojo.javassist (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.proxy.pojo.javassist

Class Summary
JavassistLazyInitializer | A Javassist-based lazy initializer proxy.
JavassistProxyFactory | A ProxyFactory implementation for producing Javassist-based proxies.
SerializableProxy | Serializable placeholder for Javassist proxies


org.hibernate.proxy.pojo.javassist Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.proxy.pojo.javassist

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.proxy.AbstractLazyInitializer (implements org.hibernate.proxy.LazyInitializer)
      • class org.hibernate.proxy.pojo.BasicLazyInitializer
        • class org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer (implements javassist.util.proxy.MethodHandler)
    • class org.hibernate.proxy.pojo.javassist.JavassistProxyFactory (implements org.hibernate.proxy.ProxyFactory, java.io.Serializable)
    • class org.hibernate.proxy.pojo.javassist.SerializableProxy (implements java.io.Serializable)


Uses of Package org.hibernate.proxy.pojo.javassist (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.proxy.pojo.javassist

No usage of org.hibernate.proxy.pojo.javassist

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


JavassistLazyInitializer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.pojo.javassist
Class JavassistLazyInitializer

java.lang.Object
    extended by org.hibernate.proxy.AbstractLazyInitializer
        extended by org.hibernate.proxy.pojo.BasicLazyInitializer
            extended by org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer
All Implemented Interfaces:
LazyInitializer, javassist.util.proxy.MethodHandler
public class JavassistLazyInitializer
extends BasicLazyInitializer
implements javassist.util.proxy.MethodHandler

A Javassist-based lazy initializer proxy.

Author:
Muga Nishizawa

Field Summary
Fields inherited from class org.hibernate.proxy.pojo.BasicLazyInitializer
componentIdType, getIdentifierMethod, INVOKE_IMPLEMENTATION, overridesEquals, persistentClass, setIdentifierMethod
Method Summary
static HibernateProxy | getProxy(Class factory, String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)
static HibernateProxy | getProxy(String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)
static Class | getProxyFactory(Class persistentClass, Class[] interfaces)
Object | invoke(Object proxy, Method thisMethod, Method proceed, Object[] args)
protected Object | serializableProxy()
Methods inherited from class org.hibernate.proxy.pojo.BasicLazyInitializer
getPersistentClass, invoke
Methods inherited from class org.hibernate.proxy.AbstractLazyInitializer
getEntityName, getIdentifier, getImplementation, getImplementation, getSession, getTarget, initialize, isConnectedToSession, isUninitialized, isUnwrap, setIdentifier, setImplementation, setSession, setUnwrap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getProxy

public static HibernateProxy getProxy(String entityName,
                                      Class persistentClass,
                                      Class[] interfaces,
                                      Method getIdentifierMethod,
                                      Method setIdentifierMethod,
                                      AbstractComponentType componentIdType,
                                      Serializable id,
                                      SessionImplementor session)
                               throws HibernateException
Throws:
HibernateException

getProxy

public static HibernateProxy getProxy(Class factory,
                                      String entityName,
                                      Class persistentClass,
                                      Class[] interfaces,
                                      Method getIdentifierMethod,
                                      Method setIdentifierMethod,
                                      AbstractComponentType componentIdType,
                                      Serializable id,
                                      SessionImplementor session)
                               throws HibernateException
Throws:
HibernateException

getProxyFactory

public static Class getProxyFactory(Class persistentClass,
                                    Class[] interfaces)
                             throws HibernateException
Throws:
HibernateException

invoke

public Object invoke(Object proxy,
                     Method thisMethod,
                     Method proceed,
                     Object[] args)
              throws Throwable
Specified by:
invoke in interface javassist.util.proxy.MethodHandler
Throws:
Throwable

serializableProxy

protected Object serializableProxy()
Specified by:
serializableProxy in class BasicLazyInitializer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JavassistProxyFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.pojo.javassist
Class JavassistProxyFactory

java.lang.Object
    extended by org.hibernate.proxy.pojo.javassist.JavassistProxyFactory
All Implemented Interfaces:
ProxyFactory, Serializable
public class JavassistProxyFactory
extends Object
implements ProxyFactory, Serializable

A ProxyFactory implementation for producing Javassist-based proxies.

Author:
Muga Nishizawa
See Also:
Serialized Form

Field Summary
protected static Class[] NO_CLASSES
Constructor Summary
JavassistProxyFactory()
Method Summary
HibernateProxy | getProxy(Serializable id, SessionImplementor session) Create a new proxy instance
void | postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType) Called immediately after instantiation of this factory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NO_CLASSES

protected static final Class[] NO_CLASSES
Constructor Detail

JavassistProxyFactory

public JavassistProxyFactory()
Method Detail

postInstantiate

public void postInstantiate(String entityName,
                            Class persistentClass,
                            Set interfaces,
                            Method getIdentifierMethod,
                            Method setIdentifierMethod,
                            AbstractComponentType componentIdType)
                     throws HibernateException
Description copied from interface: ProxyFactory
Called immediately after instantiation of this factory.

Essentially equivalent to contructor injection, but contracted here via interface.

Specified by:
postInstantiate in interface ProxyFactory
Parameters:
entityName - The name of the entity for which this factory should generate proxies.
persistentClass - The entity class for which to generate proxies; not always the same as the entityName.
interfaces - The interfaces to expose in the generated proxy; HibernateProxy is already included in this collection.
getIdentifierMethod - Reference to the identifier getter method; invocation on this method should not force initialization
setIdentifierMethod - Reference to the identifier setter method; invocation on this method should not force initialization
componentIdType - For composite identifier types, a reference to the type of the identifier property; again accessing the id should generally not cause initialization - but need to bear in mind mappings.
Throws:
HibernateException - Indicates a problem completing post instantiation initialization.

getProxy

public HibernateProxy getProxy(Serializable id,
                               SessionImplementor session)
                        throws HibernateException
Description copied from interface: ProxyFactory
Create a new proxy instance

Specified by:
getProxy in interface ProxyFactory
Parameters:
id - The id value for the proxy to be generated.
session - The session to which the generated proxy will be associated.
Returns:
The generated proxy.
Throws:
HibernateException - Indicates problems generating the requested proxy.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SerializableProxy (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.proxy.pojo.javassist
Class SerializableProxy

java.lang.Object
    extended by org.hibernate.proxy.pojo.javassist.SerializableProxy
All Implemented Interfaces:
Serializable
public final class SerializableProxy
extends Object
implements Serializable

Serializable placeholder for Javassist proxies

See Also:
Serialized Form

Constructor Summary
SerializableProxy()
SerializableProxy(String entityName, Class persistentClass, Class[] interfaces, Serializable id, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SerializableProxy

public SerializableProxy()

SerializableProxy

public SerializableProxy(String entityName,
                         Class persistentClass,
                         Class[] interfaces,
                         Serializable id,
                         Method getIdentifierMethod,
                         Method setIdentifierMethod,
                         AbstractComponentType componentIdType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.secure (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.secure

Declarative security for CRUD operations on entities.

See:
Description

Interface Summary
JACCSecurityListener Marker interface for JACC event listeners

Class Summary
HibernatePermission |
JACCConfiguration | Adds Hibernate permissions to roles via JACC
JACCPermissions | Copied from JBoss org.jboss.ejb3.security.JaccHelper and org.jboss.ejb3.security.SecurityActions
JACCPreDeleteEventListener | Check security before any deletion
JACCPreInsertEventListener | Check security before an insertion
JACCPreLoadEventListener | Check security before any load
JACCPreUpdateEventListener | Check security before any update

Package org.hibernate.secure Description

Declarative security for CRUD operations on entities.


org.hibernate.secure Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.secure

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.secure.JACCConfiguration
    • class org.hibernate.secure.JACCPermissions
    • class org.hibernate.secure.JACCPreDeleteEventListener (implements org.hibernate.event.Initializable, org.hibernate.secure.JACCSecurityListener, org.hibernate.event.PreDeleteEventListener)
    • class org.hibernate.secure.JACCPreInsertEventListener (implements org.hibernate.event.Initializable, org.hibernate.secure.JACCSecurityListener, org.hibernate.event.PreInsertEventListener)
    • class org.hibernate.secure.JACCPreLoadEventListener (implements org.hibernate.event.Initializable, org.hibernate.secure.JACCSecurityListener, org.hibernate.event.PreLoadEventListener)
    • class org.hibernate.secure.JACCPreUpdateEventListener (implements org.hibernate.event.Initializable, org.hibernate.secure.JACCSecurityListener, org.hibernate.event.PreUpdateEventListener)
    • class java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • class org.hibernate.secure.HibernatePermission

Interface Hierarchy

  • interface org.hibernate.secure.JACCSecurityListener


Uses of Package org.hibernate.secure (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.secure

Packages that use org.hibernate.secure
org.hibernate.secure Declarative security for CRUD operations on entities.

Classes in org.hibernate.secure used by org.hibernate.secure
JACCSecurityListener
Marker interface for JACC event listeners

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


JACCSecurityListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.secure
Interface JACCSecurityListener

All Known Implementing Classes:
JACCPreDeleteEventListener, JACCPreInsertEventListener, JACCPreLoadEventListener, JACCPreUpdateEventListener
public interface JACCSecurityListener

Marker interface for JACC event listeners

Version:
$Revision: 8702 $
Author:
Kabir Khan

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HibernatePermission (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.secure
Class HibernatePermission

java.lang.Object
    extended by java.security.Permission
        extended by org.hibernate.secure.HibernatePermission
All Implemented Interfaces:
Guard, Serializable
public class HibernatePermission
extends Permission

Author:
Gavin King
See Also:
Serialized Form

Field Summary
static String | ANY
static String | DELETE
static String | INSERT
static String | READ
static String | UPDATE
Constructor Summary
HibernatePermission(String entityName, String actions)
Method Summary
boolean | equals(Object obj)
String | getActions()
int | hashCode()
boolean | implies(Permission permission)
String | toString()
Methods inherited from class java.security.Permission
checkGuard, getName, newPermissionCollection
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

INSERT

public static final String INSERT
See Also:
Constant Field Values

UPDATE

public static final String UPDATE
See Also:
Constant Field Values

DELETE

public static final String DELETE
See Also:
Constant Field Values

READ

public static final String READ
See Also:
Constant Field Values

ANY

public static final String ANY
See Also:
Constant Field Values
Constructor Detail

HibernatePermission

public HibernatePermission(String entityName,
                           String actions)
Method Detail

implies

public boolean implies(Permission permission)

equals

public boolean equals(Object obj)

hashCode

public int hashCode()

getActions

public String getActions()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JACCConfiguration (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.secure
Class JACCConfiguration

java.lang.Object
    extended by org.hibernate.secure.JACCConfiguration
public class JACCConfiguration
extends Object

Adds Hibernate permissions to roles via JACC

Author:
Gavin King

Constructor Summary
JACCConfiguration(String contextId)
Method Summary
 void addPermission(String role, String entityName, String action)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JACCConfiguration

public JACCConfiguration(String contextId)
                  throws HibernateException
Method Detail

addPermission

public void addPermission(String role,
                          String entityName,
                          String action)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JACCPermissions (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.secure
Class JACCPermissions

java.lang.Object
    extended by org.hibernate.secure.JACCPermissions
public class JACCPermissions
extends Object

Copied from JBoss org.jboss.ejb3.security.JaccHelper and org.jboss.ejb3.security.SecurityActions

Author:
Kabir Khan

Constructor Summary
JACCPermissions()
Method Summary
static void checkPermission(Class clazz, String contextID, javax.security.jacc.EJBMethodPermission methodPerm)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JACCPermissions

public JACCPermissions()
Method Detail

checkPermission

public static void checkPermission(Class clazz,
                                   String contextID,
                                   javax.security.jacc.EJBMethodPermission methodPerm)
                            throws SecurityException
Throws:
SecurityException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JACCPreDeleteEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.secure
Class JACCPreDeleteEventListener

java.lang.Object
    extended by org.hibernate.secure.JACCPreDeleteEventListener
All Implemented Interfaces:
Initializable, JACCSecurityListener, PreDeleteEventListener, Serializable
public class JACCPreDeleteEventListener
extends Object
implements PreDeleteEventListener, Initializable, JACCSecurityListener

Check security before any deletion

Author:
Kabir Khan
See Also:
Serialized Form

Constructor Summary
JACCPreDeleteEventListener()
Method Summary
void | initialize(Configuration cfg)
boolean | onPreDelete(PreDeleteEvent event)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JACCPreDeleteEventListener

public JACCPreDeleteEventListener()
Method Detail

onPreDelete

public boolean onPreDelete(PreDeleteEvent event)
Specified by:
onPreDelete in interface PreDeleteEventListener

initialize

public void initialize(Configuration cfg)
Specified by:
initialize in interface Initializable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JACCPreInsertEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.secure
Class JACCPreInsertEventListener

java.lang.Object
    extended by org.hibernate.secure.JACCPreInsertEventListener
All Implemented Interfaces:
Initializable, JACCSecurityListener, PreInsertEventListener, Serializable
public class JACCPreInsertEventListener
extends Object
implements PreInsertEventListener, Initializable, JACCSecurityListener

Check security before an insertion

Author:
Kabir Khan
See Also:
Serialized Form

Constructor Summary
JACCPreInsertEventListener()
Method Summary
void | initialize(Configuration cfg)
boolean | onPreInsert(PreInsertEvent event)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JACCPreInsertEventListener

public JACCPreInsertEventListener()
Method Detail

onPreInsert

public boolean onPreInsert(PreInsertEvent event)
Specified by:
onPreInsert in interface PreInsertEventListener

initialize

public void initialize(Configuration cfg)
Specified by:
initialize in interface Initializable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JACCPreLoadEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.secure
Class JACCPreLoadEventListener

java.lang.Object
    extended by org.hibernate.secure.JACCPreLoadEventListener
All Implemented Interfaces:
Initializable, JACCSecurityListener, PreLoadEventListener, Serializable
public class JACCPreLoadEventListener
extends Object
implements PreLoadEventListener, Initializable, JACCSecurityListener

Check security before any load

Version:
$Revision: 8702 $
Author:
Kabir Khan
See Also:
Serialized Form

Constructor Summary
JACCPreLoadEventListener()
Method Summary
void | initialize(Configuration cfg)
void | onPreLoad(PreLoadEvent event)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JACCPreLoadEventListener

public JACCPreLoadEventListener()
Method Detail

onPreLoad

public void onPreLoad(PreLoadEvent event)
Specified by:
onPreLoad in interface PreLoadEventListener

initialize

public void initialize(Configuration cfg)
Specified by:
initialize in interface Initializable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JACCPreUpdateEventListener (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.secure
Class JACCPreUpdateEventListener

java.lang.Object
    extended by org.hibernate.secure.JACCPreUpdateEventListener
All Implemented Interfaces:
Initializable, JACCSecurityListener, PreUpdateEventListener, Serializable
public class JACCPreUpdateEventListener
extends Object
implements PreUpdateEventListener, Initializable, JACCSecurityListener

Check security before any update

Version:
$Revision: 8702 $
Author:
Kabir Khan
See Also:
Serialized Form

Constructor Summary
JACCPreUpdateEventListener()
Method Summary
void | initialize(Configuration cfg)
boolean | onPreUpdate(PreUpdateEvent event)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JACCPreUpdateEventListener

public JACCPreUpdateEventListener()
Method Detail

onPreUpdate

public boolean onPreUpdate(PreUpdateEvent event)
Specified by:
onPreUpdate in interface PreUpdateEventListener

initialize

public void initialize(Configuration cfg)
Specified by:
initialize in interface Initializable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.sql (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.sql

This package defines helper classes for rendering SQL fragments and SQL statements.

See:
Description

Class Summary
Alias | An alias generator for SQL identifiers
ANSICaseFragment | An ANSI SQL CASE expression.
ANSIJoinFragment | An ANSI-style join
CaseFragment | Abstract SQL case fragment renderer
ConditionFragment |
DecodeCaseFragment | An Oracle-style DECODE function.
Delete | An SQL DELETE statement
DerbyCaseFragment |
DisjunctionFragment | A disjunctive string of conditions
ForUpdateFragment |
HSQLCaseFragment | The HSQL CASEWHEN function.
InFragment | An SQL IN expression.
Insert | An SQL INSERT statement
InsertSelect | Implementation of InsertSelect.
JoinFragment | An abstract SQL join fragment renderer
MckoiCaseFragment | A Mckoi IF function.
OracleJoinFragment | An Oracle-style (theta) join
QueryJoinFragment | A join that appears in a translated HQL query
QuerySelect | A translated HQL query
Select | A simple SQL SELECT statement
SelectFragment | A fragment of an SQL SELECT clause
SimpleSelect | An SQL SELECT statement with no table joins
Sybase11JoinFragment | An old Sybase-style join (before Sybase supported the ANSI style "inner join" etc syntax) This is needed for Sybase 11.9.2 and earlier, using the HQL 2.* syntax with Collections.
Template | Parses SQL fragments specified in mapping documents
Update | An SQL UPDATE statement

Package org.hibernate.sql Description

This package defines helper classes for rendering SQL fragments and SQL statements.


org.hibernate.sql Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.sql

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.sql.Alias
    • class org.hibernate.sql.CaseFragment
      • class org.hibernate.sql.ANSICaseFragment
      • class org.hibernate.sql.DecodeCaseFragment
      • class org.hibernate.sql.DerbyCaseFragment
      • class org.hibernate.sql.HSQLCaseFragment
      • class org.hibernate.sql.MckoiCaseFragment
    • class org.hibernate.sql.ConditionFragment
    • class org.hibernate.sql.Delete
    • class org.hibernate.sql.DisjunctionFragment
    • class org.hibernate.sql.ForUpdateFragment
    • class org.hibernate.sql.InFragment
    • class org.hibernate.sql.Insert
    • class org.hibernate.sql.InsertSelect
    • class org.hibernate.sql.JoinFragment
      • class org.hibernate.sql.ANSIJoinFragment
      • class org.hibernate.sql.OracleJoinFragment
      • class org.hibernate.sql.QueryJoinFragment
      • class org.hibernate.sql.Sybase11JoinFragment
    • class org.hibernate.sql.QuerySelect
    • class org.hibernate.sql.Select
    • class org.hibernate.sql.SelectFragment
    • class org.hibernate.sql.SimpleSelect
    • class org.hibernate.sql.Template
    • class org.hibernate.sql.Update


Uses of Package org.hibernate.sql (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.sql

Packages that use org.hibernate.sql
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.id.insert |
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.

Classes in org.hibernate.sql used by org.hibernate.dialect
CaseFragment
Abstract SQL case fragment renderer
JoinFragment
An abstract SQL join fragment renderer

Classes in org.hibernate.sql used by org.hibernate.engine
JoinFragment
An abstract SQL join fragment renderer

Classes in org.hibernate.sql used by org.hibernate.hql.ast.tree
JoinFragment
An abstract SQL join fragment renderer

Classes in org.hibernate.sql used by org.hibernate.hql.ast.util
JoinFragment
An abstract SQL join fragment renderer

Classes in org.hibernate.sql used by org.hibernate.id
Insert
An SQL INSERT statement

Classes in org.hibernate.sql used by org.hibernate.id.insert
Insert
An SQL INSERT statement

Classes in org.hibernate.sql used by org.hibernate.loader
JoinFragment
An abstract SQL join fragment renderer

Classes in org.hibernate.sql used by org.hibernate.persister.collection
SelectFragment
A fragment of an SQL SELECT clause

Classes in org.hibernate.sql used by org.hibernate.persister.entity
Insert
An SQL INSERT statement
JoinFragment
An abstract SQL join fragment renderer
SelectFragment
A fragment of an SQL SELECT clause

Classes in org.hibernate.sql used by org.hibernate.sql
CaseFragment
Abstract SQL case fragment renderer
ConditionFragment
Delete
An SQL DELETE statement
DisjunctionFragment
A disjunctive string of conditions
ForUpdateFragment
InFragment
An SQL IN expression.
Insert
An SQL INSERT statement
InsertSelect
Implementation of InsertSelect.
JoinFragment
An abstract SQL join fragment renderer
QuerySelect
A translated HQL query
Select
A simple SQL SELECT statement
SelectFragment
A fragment of an SQL SELECT clause
SimpleSelect
An SQL SELECT statement with no table joins
Update
An SQL UPDATE statement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Alias (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class Alias

java.lang.Object
    extended by org.hibernate.sql.Alias
public final class Alias
extends Object

An alias generator for SQL identifiers

Author:
Gavin King

Constructor Summary
Alias(int length, String suffix)
Constructor for Alias.
Alias(String suffix)
Constructor for Alias.
Method Summary
String | toAliasString(String sqlIdentifier)
String[] | toAliasStrings(String[] sqlIdentifiers)
String | toUnquotedAliasString(String sqlIdentifier)
String[] | toUnquotedAliasStrings(String[] sqlIdentifiers)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Alias

public Alias(int length,
             String suffix)
Constructor for Alias.

Alias

public Alias(String suffix)
Constructor for Alias.

Method Detail

toAliasString

public String toAliasString(String sqlIdentifier)

toUnquotedAliasString

public String toUnquotedAliasString(String sqlIdentifier)

toUnquotedAliasStrings

public String[] toUnquotedAliasStrings(String[] sqlIdentifiers)

toAliasStrings

public String[] toAliasStrings(String[] sqlIdentifiers)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ANSICaseFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class ANSICaseFragment

java.lang.Object
    extended by org.hibernate.sql.CaseFragment
        extended by org.hibernate.sql.ANSICaseFragment
public class ANSICaseFragment
extends CaseFragment

An ANSI SQL CASE expression.
case when ... then ... end as ...

Author:
Gavin King, Simon Harris

Field Summary
Fields inherited from class org.hibernate.sql.CaseFragment
cases, returnColumnName
Constructor Summary
ANSICaseFragment()
Method Summary
 String toFragmentString()
Methods inherited from class org.hibernate.sql.CaseFragment
addWhenColumnNotNull, setReturnColumnName, setReturnColumnName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ANSICaseFragment

public ANSICaseFragment()
Method Detail

toFragmentString

public String toFragmentString()
Specified by:
toFragmentString in class CaseFragment
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ANSIJoinFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class ANSIJoinFragment

java.lang.Object
    extended by org.hibernate.sql.JoinFragment
        extended by org.hibernate.sql.ANSIJoinFragment
public class ANSIJoinFragment
extends JoinFragment

An ANSI-style join

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.sql.JoinFragment
FULL_JOIN, INNER_JOIN, LEFT_OUTER_JOIN, RIGHT_OUTER_JOIN
Constructor Summary
ANSIJoinFragment()
Method Summary
boolean | addCondition(String condition)
void | addCondition(String alias, String[] columns, String condition)
void | addCondition(String alias, String[] fkColumns, String[] pkColumns)
void | addCrossJoin(String tableName, String alias)
void | addFromFragmentString(String fromFragmentString)
void | addJoin(String tableName, String alias, String[] fkColumns, String[] pkColumns, int joinType)
void | addJoin(String tableName, String alias, String[] fkColumns, String[] pkColumns, int joinType, String on)
void | addJoins(String fromFragment, String whereFragment)
JoinFragment | copy()
String | toFromFragmentString()
String | toWhereFragmentString()
Methods inherited from class org.hibernate.sql.JoinFragment
addCondition, addFragment, hasFilterCondition, hasThetaJoins, setHasFilterCondition, setHasThetaJoins
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ANSIJoinFragment

public ANSIJoinFragment()
Method Detail

addJoin

public void addJoin(String tableName,
                    String alias,
                    String[] fkColumns,
                    String[] pkColumns,
                    int joinType)
Specified by:
addJoin in class JoinFragment

addJoin

public void addJoin(String tableName,
                    String alias,
                    String[] fkColumns,
                    String[] pkColumns,
                    int joinType,
                    String on)
Specified by:
addJoin in class JoinFragment

toFromFragmentString

public String toFromFragmentString()
Specified by:
toFromFragmentString in class JoinFragment

toWhereFragmentString

public String toWhereFragmentString()
Specified by:
toWhereFragmentString in class JoinFragment

addJoins

public void addJoins(String fromFragment,
                     String whereFragment)
Specified by:
addJoins in class JoinFragment

copy

public JoinFragment copy()
Specified by:
copy in class JoinFragment

addCondition

public void addCondition(String alias,
                         String[] columns,
                         String condition)

addCrossJoin

public void addCrossJoin(String tableName,
                         String alias)
Specified by:
addCrossJoin in class JoinFragment

addCondition

public void addCondition(String alias,
                         String[] fkColumns,
                         String[] pkColumns)
Specified by:
addCondition in class JoinFragment

addCondition

public boolean addCondition(String condition)
Specified by:
addCondition in class JoinFragment

addFromFragmentString

public void addFromFragmentString(String fromFragmentString)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CaseFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class CaseFragment

java.lang.Object
    extended by org.hibernate.sql.CaseFragment
Direct Known Subclasses:
ANSICaseFragment, DecodeCaseFragment, DerbyCaseFragment, HSQLCaseFragment, MckoiCaseFragment
public abstract class CaseFragment
extends Object

Abstract SQL case fragment renderer

Author:
Gavin King, Simon Harris

Field Summary
protected Map | cases
protected String | returnColumnName
Constructor Summary
CaseFragment()
Method Summary
CaseFragment | addWhenColumnNotNull(String alias, String columnName, String value)
CaseFragment | setReturnColumnName(String returnColumnName)
CaseFragment | setReturnColumnName(String returnColumnName, String suffix)
abstract String | toFragmentString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

returnColumnName

protected String returnColumnName

cases

protected Map cases
Constructor Detail

CaseFragment

public CaseFragment()
Method Detail

toFragmentString

public abstract String toFragmentString()

setReturnColumnName

public CaseFragment setReturnColumnName(String returnColumnName)

setReturnColumnName

public CaseFragment setReturnColumnName(String returnColumnName,
                                        String suffix)

addWhenColumnNotNull

public CaseFragment addWhenColumnNotNull(String alias,
                                         String columnName,
                                         String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConditionFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class ConditionFragment

java.lang.Object
    extended by org.hibernate.sql.ConditionFragment
public class ConditionFragment
extends Object

Author:
Gavin King

Constructor Summary
ConditionFragment()
Method Summary
ConditionFragment | setCondition(String[] lhs, String rhs)
ConditionFragment | setCondition(String[] lhs, String[] rhs)
ConditionFragment | setOp(String op) Sets the op.
ConditionFragment | setTableAlias(String tableAlias) Sets the tableAlias.
String | toFragmentString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConditionFragment

public ConditionFragment()
Method Detail

setOp

public ConditionFragment setOp(String op)
Sets the op.

Parameters:
op - The op to set

setTableAlias

public ConditionFragment setTableAlias(String tableAlias)
Sets the tableAlias.

Parameters:
tableAlias - The tableAlias to set

setCondition

public ConditionFragment setCondition(String[] lhs,
                                      String[] rhs)

setCondition

public ConditionFragment setCondition(String[] lhs,
                                      String rhs)

toFragmentString

public String toFragmentString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DecodeCaseFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class DecodeCaseFragment

java.lang.Object
    extended by org.hibernate.sql.CaseFragment
        extended by org.hibernate.sql.DecodeCaseFragment
public class DecodeCaseFragment
extends CaseFragment

An Oracle-style DECODE function.
decode(pkvalue, key1, 1, key2, 2, ..., 0)

Author:
Simon Harris

Field Summary
Fields inherited from class org.hibernate.sql.CaseFragment
cases, returnColumnName
Constructor Summary
DecodeCaseFragment()
Method Summary
 String toFragmentString()
Methods inherited from class org.hibernate.sql.CaseFragment
addWhenColumnNotNull, setReturnColumnName, setReturnColumnName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DecodeCaseFragment

public DecodeCaseFragment()
Method Detail

toFragmentString

public String toFragmentString()
Specified by:
toFragmentString in class CaseFragment
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Delete (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class Delete

java.lang.Object
    extended by org.hibernate.sql.Delete
public class Delete
extends Object

An SQL DELETE statement

Author:
Gavin King

Constructor Summary
Delete()
Method Summary
Delete | addWhereFragment(String fragment)
Delete | setComment(String comment)
Delete | setPrimaryKeyColumnNames(String[] primaryKeyColumnNames)
Delete | setTableName(String tableName)
Delete | setVersionColumnName(String versionColumnName)
Delete | setWhere(String where)
String | toStatementString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Delete

public Delete()
Method Detail

setComment

public Delete setComment(String comment)

setTableName

public Delete setTableName(String tableName)

toStatementString

public String toStatementString()

setWhere

public Delete setWhere(String where)

addWhereFragment

public Delete addWhereFragment(String fragment)

setPrimaryKeyColumnNames

public Delete setPrimaryKeyColumnNames(String[] primaryKeyColumnNames)

setVersionColumnName

public Delete setVersionColumnName(String versionColumnName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DerbyCaseFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class DerbyCaseFragment

java.lang.Object
    extended by org.hibernate.sql.CaseFragment
        extended by org.hibernate.sql.DerbyCaseFragment
public class DerbyCaseFragment
extends CaseFragment

Author:
Simon Johnston
See Also:
DerbyDialect

Field Summary
Fields inherited from class org.hibernate.sql.CaseFragment
cases, returnColumnName
Constructor Summary
DerbyCaseFragment()
Method Summary
 String toFragmentString()
From http://www.jroller.com/comments/kenlars99/Weblog/cloudscape_soon_to_be_derby

The problem we had, was when Hibernate does a select with a case statement, for joined subclasses.

Methods inherited from class org.hibernate.sql.CaseFragment
addWhenColumnNotNull, setReturnColumnName, setReturnColumnName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DerbyCaseFragment

public DerbyCaseFragment()
Method Detail

toFragmentString

public String toFragmentString()
From http://www.jroller.com/comments/kenlars99/Weblog/cloudscape_soon_to_be_derby

The problem we had, was when Hibernate does a select with a case statement, for joined subclasses. This seems to be because there was no else at the end of the case statement (other dbs seem to not mind).

Specified by:
toFragmentString in class CaseFragment
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DisjunctionFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class DisjunctionFragment

java.lang.Object
    extended by org.hibernate.sql.DisjunctionFragment
public class DisjunctionFragment
extends Object

A disjunctive string of conditions

Author:
Gavin King

Constructor Summary
DisjunctionFragment()
Method Summary
DisjunctionFragment | addCondition(ConditionFragment fragment)
String | toFragmentString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DisjunctionFragment

public DisjunctionFragment()
Method Detail

addCondition

public DisjunctionFragment addCondition(ConditionFragment fragment)

toFragmentString

public String toFragmentString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ForUpdateFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class ForUpdateFragment

java.lang.Object
    extended by org.hibernate.sql.ForUpdateFragment
public class ForUpdateFragment
extends Object

Author:
Gavin King

Constructor Summary
ForUpdateFragment(Dialect dialect)
ForUpdateFragment(Dialect dialect, Map lockModes, Map keyColumnNames)
Method Summary
ForUpdateFragment | addTableAlias(String alias)
ForUpdateFragment | setNowaitEnabled(boolean nowait)
String | toFragmentString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ForUpdateFragment

public ForUpdateFragment(Dialect dialect)

ForUpdateFragment

public ForUpdateFragment(Dialect dialect,
                         Map lockModes,
                         Map keyColumnNames)
                  throws QueryException
Method Detail

addTableAlias

public ForUpdateFragment addTableAlias(String alias)

toFragmentString

public String toFragmentString()

setNowaitEnabled

public ForUpdateFragment setNowaitEnabled(boolean nowait)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HSQLCaseFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class HSQLCaseFragment

java.lang.Object
    extended by org.hibernate.sql.CaseFragment
        extended by org.hibernate.sql.HSQLCaseFragment
public class HSQLCaseFragment
extends CaseFragment

The HSQL CASEWHEN function.
casewhen(..., ..., ...) as ...

Author:
Wolfgang Jung

Field Summary
Fields inherited from class org.hibernate.sql.CaseFragment
cases, returnColumnName
Constructor Summary
HSQLCaseFragment()
Method Summary
 String toFragmentString()
Methods inherited from class org.hibernate.sql.CaseFragment
addWhenColumnNotNull, setReturnColumnName, setReturnColumnName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HSQLCaseFragment

public HSQLCaseFragment()
Method Detail

toFragmentString

public String toFragmentString()
Specified by:
toFragmentString in class CaseFragment
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class InFragment

java.lang.Object
    extended by org.hibernate.sql.InFragment
public class InFragment
extends Object

An SQL IN expression.
... in(...)

Author:
Gavin King

Field Summary
static String | NOT_NULL
static String | NULL
Constructor Summary
InFragment()
Method Summary
InFragment | addValue(Object value)
InFragment | setColumn(String columnName)
InFragment | setColumn(String alias, String columnName)
InFragment | setFormula(String alias, String formulaTemplate)
String | toFragmentString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NULL

public static final String NULL
See Also:
Constant Field Values

NOT_NULL

public static final String NOT_NULL
See Also:
Constant Field Values
Constructor Detail

InFragment

public InFragment()
Method Detail

addValue

public InFragment addValue(Object value)

setColumn

public InFragment setColumn(String columnName)

setColumn

public InFragment setColumn(String alias,
                            String columnName)

setFormula

public InFragment setFormula(String alias,
                             String formulaTemplate)

toFragmentString

public String toFragmentString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Insert (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class Insert

java.lang.Object
    extended by org.hibernate.sql.Insert
Direct Known Subclasses:
IdentifierGeneratingInsert
public class Insert
extends Object

An SQL INSERT statement

Author:
Gavin King

Constructor Summary
Insert(Dialect dialect)
Method Summary
Insert | addColumn(String columnName)
Insert | addColumn(String columnName, Object value, LiteralType type)
Insert | addColumn(String columnName, String value)
Insert | addColumns(String[] columnNames)
Insert | addColumns(String[] columnNames, boolean[] insertable)
Insert | addIdentityColumn(String columnName)
protected Dialect | getDialect()
Insert | setComment(String comment)
Insert | setTableName(String tableName)
String | toStatementString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Insert

public Insert(Dialect dialect)
Method Detail

getDialect

protected Dialect getDialect()

setComment

public Insert setComment(String comment)

addColumn

public Insert addColumn(String columnName)

addColumns

public Insert addColumns(String[] columnNames)

addColumns

public Insert addColumns(String[] columnNames,
                         boolean[] insertable)

addColumn

public Insert addColumn(String columnName,
                        String value)

addColumn

public Insert addColumn(String columnName,
                        Object value,
                        LiteralType type)
                 throws Exception
Throws:
Exception

addIdentityColumn

public Insert addIdentityColumn(String columnName)

setTableName

public Insert setTableName(String tableName)

toStatementString

public String toStatementString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InsertSelect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class InsertSelect

java.lang.Object
    extended by org.hibernate.sql.InsertSelect
public class InsertSelect
extends Object

Implementation of InsertSelect.

Author:
Steve Ebersole

Constructor Summary
InsertSelect(Dialect dialect)
Method Summary
InsertSelect | addColumn(String columnName)
InsertSelect | addColumns(String[] columnNames)
InsertSelect | setComment(String comment)
InsertSelect | setSelect(Select select)
InsertSelect | setTableName(String tableName)
String | toStatementString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InsertSelect

public InsertSelect(Dialect dialect)
Method Detail

setTableName

public InsertSelect setTableName(String tableName)

setComment

public InsertSelect setComment(String comment)

addColumn

public InsertSelect addColumn(String columnName)

addColumns

public InsertSelect addColumns(String[] columnNames)

setSelect

public InsertSelect setSelect(Select select)

toStatementString

public String toStatementString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JoinFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class JoinFragment

java.lang.Object
    extended by org.hibernate.sql.JoinFragment
Direct Known Subclasses:
ANSIJoinFragment, OracleJoinFragment, QueryJoinFragment, Sybase11JoinFragment
public abstract class JoinFragment
extends Object

An abstract SQL join fragment renderer

Author:
Gavin King

Field Summary
static int | FULL_JOIN
static int | INNER_JOIN
static int | LEFT_OUTER_JOIN
static int | RIGHT_OUTER_JOIN
Constructor Summary
JoinFragment()
Method Summary
abstract boolean | addCondition(String condition)
protected boolean | addCondition(StringBuffer buffer, String on) Appends the 'on' condition to the buffer, returning true if the condition was added.
abstract void | addCondition(String alias, String[] fkColumns, String[] pkColumns)
abstract void | addCrossJoin(String tableName, String alias)
void | addFragment(JoinFragment ojf)
abstract void | addJoin(String tableName, String alias, String[] fkColumns, String[] pkColumns, int joinType)
abstract void | addJoin(String tableName, String alias, String[] fkColumns, String[] pkColumns, int joinType, String on)
abstract void | addJoins(String fromFragment, String whereFragment)
abstract JoinFragment | copy()
boolean | hasFilterCondition() True if the where fragment is from a filter condition.
boolean | hasThetaJoins()
void | setHasFilterCondition(boolean b)
void | setHasThetaJoins(boolean hasThetaJoins)
abstract String | toFromFragmentString()
abstract String | toWhereFragmentString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INNER_JOIN

public static final int INNER_JOIN
See Also:
Constant Field Values

FULL_JOIN

public static final int FULL_JOIN
See Also:
Constant Field Values

LEFT_OUTER_JOIN

public static final int LEFT_OUTER_JOIN
See Also:
Constant Field Values

RIGHT_OUTER_JOIN

public static final int RIGHT_OUTER_JOIN
See Also:
Constant Field Values
Constructor Detail

JoinFragment

public JoinFragment()
Method Detail

addJoin

public abstract void addJoin(String tableName,
                             String alias,
                             String[] fkColumns,
                             String[] pkColumns,
                             int joinType)

addJoin

public abstract void addJoin(String tableName,
                             String alias,
                             String[] fkColumns,
                             String[] pkColumns,
                             int joinType,
                             String on)

addCrossJoin

public abstract void addCrossJoin(String tableName,
                                  String alias)

addJoins

public abstract void addJoins(String fromFragment,
                              String whereFragment)

toFromFragmentString

public abstract String toFromFragmentString()

toWhereFragmentString

public abstract String toWhereFragmentString()

addCondition

public abstract void addCondition(String alias,
                                  String[] fkColumns,
                                  String[] pkColumns)

addCondition

public abstract boolean addCondition(String condition)

copy

public abstract JoinFragment copy()

addFragment

public void addFragment(JoinFragment ojf)

addCondition

protected boolean addCondition(StringBuffer buffer,
                               String on)
Appends the 'on' condition to the buffer, returning true if the condition was added. Returns false if the 'on' condition was empty.

Parameters:
buffer - The buffer to append the 'on' condition to.
on - The 'on' condition.
Returns:
Returns true if the condition was added, false if the condition was already in 'on' string.

hasFilterCondition

public boolean hasFilterCondition()
True if the where fragment is from a filter condition.

Returns:
True if the where fragment is from a filter condition.

setHasFilterCondition

public void setHasFilterCondition(boolean b)

hasThetaJoins

public boolean hasThetaJoins()

setHasThetaJoins

public void setHasThetaJoins(boolean hasThetaJoins)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MckoiCaseFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class MckoiCaseFragment

java.lang.Object
    extended by org.hibernate.sql.CaseFragment
        extended by org.hibernate.sql.MckoiCaseFragment
public class MckoiCaseFragment
extends CaseFragment

A Mckoi IF function.
if(..., ..., ...) as ...

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.sql.CaseFragment
cases, returnColumnName
Constructor Summary
MckoiCaseFragment()
Method Summary
 String toFragmentString()
Methods inherited from class org.hibernate.sql.CaseFragment
addWhenColumnNotNull, setReturnColumnName, setReturnColumnName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MckoiCaseFragment

public MckoiCaseFragment()
Method Detail

toFragmentString

public String toFragmentString()
Specified by:
toFragmentString in class CaseFragment
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OracleJoinFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class OracleJoinFragment

java.lang.Object
    extended by org.hibernate.sql.JoinFragment
        extended by org.hibernate.sql.OracleJoinFragment
public class OracleJoinFragment
extends JoinFragment

An Oracle-style (theta) join

Author:
Jon Lipsky, Gavin King

Field Summary
Fields inherited from class org.hibernate.sql.JoinFragment
FULL_JOIN, INNER_JOIN, LEFT_OUTER_JOIN, RIGHT_OUTER_JOIN
Constructor Summary
OracleJoinFragment()
Method Summary
boolean | addCondition(String condition)
void | addCondition(String alias, String[] columns, String condition)
void | addCondition(String alias, String[] fkColumns, String[] pkColumns)
void | addCrossJoin(String tableName, String alias)
void | addFromFragmentString(String fromFragmentString)
void | addJoin(String tableName, String alias, String[] fkColumns, String[] pkColumns, int joinType)
void | addJoin(String tableName, String alias, String[] fkColumns, String[] pkColumns, int joinType, String on)
void | addJoins(String fromFragment, String whereFragment)
JoinFragment | copy()
String | toFromFragmentString()
String | toWhereFragmentString()
Methods inherited from class org.hibernate.sql.JoinFragment
addCondition, addFragment, hasFilterCondition, hasThetaJoins, setHasFilterCondition, setHasThetaJoins
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OracleJoinFragment

public OracleJoinFragment()
Method Detail

addJoin

public void addJoin(String tableName,
                    String alias,
                    String[] fkColumns,
                    String[] pkColumns,
                    int joinType)
Specified by:
addJoin in class JoinFragment

toFromFragmentString

public String toFromFragmentString()
Specified by:
toFromFragmentString in class JoinFragment

toWhereFragmentString

public String toWhereFragmentString()
Specified by:
toWhereFragmentString in class JoinFragment

addJoins

public void addJoins(String fromFragment,
                     String whereFragment)
Specified by:
addJoins in class JoinFragment

copy

public JoinFragment copy()
Specified by:
copy in class JoinFragment

addCondition

public void addCondition(String alias,
                         String[] columns,
                         String condition)

addCrossJoin

public void addCrossJoin(String tableName,
                         String alias)
Specified by:
addCrossJoin in class JoinFragment

addCondition

public void addCondition(String alias,
                         String[] fkColumns,
                         String[] pkColumns)
Specified by:
addCondition in class JoinFragment

addCondition

public boolean addCondition(String condition)
Specified by:
addCondition in class JoinFragment

addFromFragmentString

public void addFromFragmentString(String fromFragmentString)

addJoin

public void addJoin(String tableName,
                    String alias,
                    String[] fkColumns,
                    String[] pkColumns,
                    int joinType,
                    String on)
Specified by:
addJoin in class JoinFragment
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryJoinFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class QueryJoinFragment

java.lang.Object
    extended by org.hibernate.sql.JoinFragment
        extended by org.hibernate.sql.QueryJoinFragment
public class QueryJoinFragment
extends JoinFragment

A join that appears in a translated HQL query

Author:
Gavin King

Field Summary
Fields inherited from class org.hibernate.sql.JoinFragment
FULL_JOIN, INNER_JOIN, LEFT_OUTER_JOIN, RIGHT_OUTER_JOIN
Constructor Summary
QueryJoinFragment(Dialect dialect, boolean useThetaStyleInnerJoins)
Method Summary
boolean | addCondition(String condition) Add the condition string to the join fragment.
void | addCondition(String alias, String[] columns, String condition)
void | addCondition(String alias, String[] fkColumns, String[] pkColumns)
void | addCrossJoin(String tableName, String alias)
void | addFromFragmentString(String fromFragmentString)
void | addJoin(String tableName, String alias, String[] fkColumns, String[] pkColumns, int joinType)
void | addJoin(String tableName, String alias, String[] fkColumns, String[] pkColumns, int joinType, String on)
void | addJoins(String fromFragment, String whereFragment)
void | clearWherePart()
JoinFragment | copy()
String | toFromFragmentString()
String | toWhereFragmentString()
Methods inherited from class org.hibernate.sql.JoinFragment
addCondition, addFragment, hasFilterCondition, hasThetaJoins, setHasFilterCondition, setHasThetaJoins
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryJoinFragment

public QueryJoinFragment(Dialect dialect,
                         boolean useThetaStyleInnerJoins)
Method Detail

addJoin

public void addJoin(String tableName,
                    String alias,
                    String[] fkColumns,
                    String[] pkColumns,
                    int joinType)
Specified by:
addJoin in class JoinFragment

addJoin

public void addJoin(String tableName,
                    String alias,
                    String[] fkColumns,
                    String[] pkColumns,
                    int joinType,
                    String on)
Specified by:
addJoin in class JoinFragment

toFromFragmentString

public String toFromFragmentString()
Specified by:
toFromFragmentString in class JoinFragment

toWhereFragmentString

public String toWhereFragmentString()
Specified by:
toWhereFragmentString in class JoinFragment

addJoins

public void addJoins(String fromFragment,
                     String whereFragment)
Specified by:
addJoins in class JoinFragment

copy

public JoinFragment copy()
Specified by:
copy in class JoinFragment

addCondition

public void addCondition(String alias,
                         String[] columns,
                         String condition)

addCrossJoin

public void addCrossJoin(String tableName,
                         String alias)
Specified by:
addCrossJoin in class JoinFragment

addCondition

public void addCondition(String alias,
                         String[] fkColumns,
                         String[] pkColumns)
Specified by:
addCondition in class JoinFragment

addCondition

public boolean addCondition(String condition)
Add the condition string to the join fragment.

Specified by:
addCondition in class JoinFragment
Parameters:
condition -
Returns:
true if the condition was added, false if it was already in the fragment.

addFromFragmentString

public void addFromFragmentString(String fromFragmentString)

clearWherePart

public void clearWherePart()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuerySelect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class QuerySelect

java.lang.Object
    extended by org.hibernate.sql.QuerySelect
public class QuerySelect
extends Object

A translated HQL query

Author:
Gavin King

Constructor Summary
QuerySelect(Dialect dialect)
Method Summary
void | addOrderBy(String orderByString)
void | addSelectColumn(String columnName, String alias)
void | addSelectFragmentString(String fragment)
QuerySelect | copy()
JoinFragment | getJoinFragment()
void | prependWhereConditions(String conditions)
void | setComment(String comment)
void | setDistinct(boolean distinct)
void | setGroupByTokens(Iterator tokens)
void | setHavingTokens(Iterator tokens)
void | setOrderByTokens(Iterator tokens)
void | setWhereTokens(Iterator tokens)
String | toQueryString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QuerySelect

public QuerySelect(Dialect dialect)
Method Detail

getJoinFragment

public JoinFragment getJoinFragment()

addSelectFragmentString

public void addSelectFragmentString(String fragment)

addSelectColumn

public void addSelectColumn(String columnName,
                            String alias)

setDistinct

public void setDistinct(boolean distinct)

setWhereTokens

public void setWhereTokens(Iterator tokens)

prependWhereConditions

public void prependWhereConditions(String conditions)

setGroupByTokens

public void setGroupByTokens(Iterator tokens)

setOrderByTokens

public void setOrderByTokens(Iterator tokens)

setHavingTokens

public void setHavingTokens(Iterator tokens)

addOrderBy

public void addOrderBy(String orderByString)

toQueryString

public String toQueryString()

setComment

public void setComment(String comment)

copy

public QuerySelect copy()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Select (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class Select

java.lang.Object
    extended by org.hibernate.sql.Select
public class Select
extends Object

A simple SQL SELECT statement

Author:
Gavin King

Field Summary
 Dialect dialect
Constructor Summary
Select(Dialect dialect)
Method Summary
LockMode | getLockMode()
Select | setComment(String comment)
Select | setFromClause(String fromClause) Sets the fromClause.
Select | setFromClause(String tableName, String alias)
Select | setGroupByClause(String groupByClause)
Select | setLockMode(LockMode lockMode)
Select | setOrderByClause(String orderByClause)
Select | setOuterJoins(String outerJoinsAfterFrom, String outerJoinsAfterWhere)
Select | setSelectClause(String selectClause) Sets the selectClause.
Select | setWhereClause(String whereClause) Sets the whereClause.
String | toStatementString() Construct an SQL SELECT statement from the given clauses
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

dialect

public final Dialect dialect
Constructor Detail

Select

public Select(Dialect dialect)
Method Detail

toStatementString

public String toStatementString()
Construct an SQL SELECT statement from the given clauses

setFromClause

public Select setFromClause(String fromClause)
Sets the fromClause.

Parameters:
fromClause - The fromClause to set

setFromClause

public Select setFromClause(String tableName,
                            String alias)

setOrderByClause

public Select setOrderByClause(String orderByClause)

setGroupByClause

public Select setGroupByClause(String groupByClause)

setOuterJoins

public Select setOuterJoins(String outerJoinsAfterFrom,
                            String outerJoinsAfterWhere)

setSelectClause

public Select setSelectClause(String selectClause)
Sets the selectClause.

Parameters:
selectClause - The selectClause to set

setWhereClause

public Select setWhereClause(String whereClause)
Sets the whereClause.

Parameters:
whereClause - The whereClause to set

setComment

public Select setComment(String comment)

getLockMode

public LockMode getLockMode()

setLockMode

public Select setLockMode(LockMode lockMode)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class SelectFragment

java.lang.Object
    extended by org.hibernate.sql.SelectFragment
public class SelectFragment
extends Object

A fragment of an SQL SELECT clause

Author:
Gavin King

Constructor Summary
SelectFragment()
Method Summary
SelectFragment | addColumn(String columnName)
SelectFragment | addColumn(String tableAlias, String columnName)
SelectFragment | addColumn(String tableAlias, String columnName, String columnAlias)
SelectFragment | addColumns(String[] columnNames)
SelectFragment | addColumns(String tableAlias, String[] columnNames)
SelectFragment | addColumns(String tableAlias, String[] columnNames, String[] columnAliases)
SelectFragment | addFormula(String tableAlias, String formula, String formulaAlias)
SelectFragment | addFormulas(String tableAlias, String[] formulas, String[] formulaAliases)
SelectFragment | setExtraSelectList(CaseFragment caseFragment, String fragmentAlias)
SelectFragment | setExtraSelectList(String extraSelectList)
SelectFragment | setSuffix(String suffix)
SelectFragment | setUsedAliases(String[] aliases)
String | toFragmentString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SelectFragment

public SelectFragment()
Method Detail

setUsedAliases

public SelectFragment setUsedAliases(String[] aliases)

setExtraSelectList

public SelectFragment setExtraSelectList(String extraSelectList)

setExtraSelectList

public SelectFragment setExtraSelectList(CaseFragment caseFragment,
                                         String fragmentAlias)

setSuffix

public SelectFragment setSuffix(String suffix)

addColumn

public SelectFragment addColumn(String columnName)

addColumns

public SelectFragment addColumns(String[] columnNames)

addColumn

public SelectFragment addColumn(String tableAlias,
                                String columnName)

addColumn

public SelectFragment addColumn(String tableAlias,
                                String columnName,
                                String columnAlias)

addColumns

public SelectFragment addColumns(String tableAlias,
                                 String[] columnNames)

addColumns

public SelectFragment addColumns(String tableAlias,
                                 String[] columnNames,
                                 String[] columnAliases)

addFormulas

public SelectFragment addFormulas(String tableAlias,
                                  String[] formulas,
                                  String[] formulaAliases)

addFormula

public SelectFragment addFormula(String tableAlias,
                                 String formula,
                                 String formulaAlias)

toFragmentString

public String toFragmentString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleSelect (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class SimpleSelect

java.lang.Object
    extended by org.hibernate.sql.SimpleSelect
public class SimpleSelect
extends Object

An SQL SELECT statement with no table joins

Author:
Gavin King

Constructor Summary
SimpleSelect(Dialect dialect)
Method Summary
SimpleSelect | addColumn(String columnName)
SimpleSelect | addColumn(String columnName, String alias)
SimpleSelect | addColumns(String[] columnNames)
SimpleSelect | addColumns(String[] columnNames, String[] columnAliases)
SimpleSelect | addColumns(String[] columns, String[] aliases, boolean[] ignore)
SimpleSelect | addCondition(String[] lhs, String condition)
SimpleSelect | addCondition(String[] lhs, String op, String[] rhs)
SimpleSelect | addCondition(String lhs, String condition)
SimpleSelect | addCondition(String lhs, String op, String rhs)
SimpleSelect | addWhereToken(String token)
SimpleSelect | setComment(String comment)
SimpleSelect | setLockMode(LockMode lockMode)
SimpleSelect | setOrderBy(String orderBy)
SimpleSelect | setTableName(String tableName)
String | toStatementString()
String | toWhereClause()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SimpleSelect

public SimpleSelect(Dialect dialect)
Method Detail

addColumns

public SimpleSelect addColumns(String[] columnNames,
                               String[] columnAliases)

addColumns

public SimpleSelect addColumns(String[] columns,
                               String[] aliases,
                               boolean[] ignore)

addColumns

public SimpleSelect addColumns(String[] columnNames)

addColumn

public SimpleSelect addColumn(String columnName)

addColumn

public SimpleSelect addColumn(String columnName,
                              String alias)

setTableName

public SimpleSelect setTableName(String tableName)

setLockMode

public SimpleSelect setLockMode(LockMode lockMode)

addWhereToken

public SimpleSelect addWhereToken(String token)

addCondition

public SimpleSelect addCondition(String lhs,
                                 String op,
                                 String rhs)

addCondition

public SimpleSelect addCondition(String lhs,
                                 String condition)

addCondition

public SimpleSelect addCondition(String[] lhs,
                                 String op,
                                 String[] rhs)

addCondition

public SimpleSelect addCondition(String[] lhs,
                                 String condition)

toStatementString

public String toStatementString()

toWhereClause

public String toWhereClause()

setOrderBy

public SimpleSelect setOrderBy(String orderBy)

setComment

public SimpleSelect setComment(String comment)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sybase11JoinFragment (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class Sybase11JoinFragment

java.lang.Object
    extended by org.hibernate.sql.JoinFragment
        extended by org.hibernate.sql.Sybase11JoinFragment
public class Sybase11JoinFragment
extends JoinFragment

An old Sybase-style join (before Sybase supported the ANSI style "inner join" etc syntax) This is needed for Sybase 11.9.2 and earlier, using the HQL 2.* syntax with Collections.

Author:
Colm O' Flaherty

Field Summary
Fields inherited from class org.hibernate.sql.JoinFragment
FULL_JOIN, INNER_JOIN, LEFT_OUTER_JOIN, RIGHT_OUTER_JOIN
Constructor Summary
Sybase11JoinFragment()
Method Summary
boolean | addCondition(String condition)
void | addCondition(String alias, String[] columns, String condition)
void | addCondition(String alias, String[] fkColumns, String[] pkColumns)
void | addCrossJoin(String tableName, String alias)
void | addFromFragmentString(String fromFragmentString)
void | addJoin(String tableName, String alias, String[] fkColumns, String[] pkColumns, int joinType)
void | addJoin(String tableName, String alias, String[] fkColumns, String[] pkColumns, int joinType, String on)
void | addJoins(String fromFragment, String whereFragment)
JoinFragment | copy()
String | toFromFragmentString()
String | toWhereFragmentString()
Methods inherited from class org.hibernate.sql.JoinFragment
addCondition, addFragment, hasFilterCondition, hasThetaJoins, setHasFilterCondition, setHasThetaJoins
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Sybase11JoinFragment

public Sybase11JoinFragment()
Method Detail

addJoin

public void addJoin(String tableName,
                    String alias,
                    String[] fkColumns,
                    String[] pkColumns,
                    int joinType)
Specified by:
addJoin in class JoinFragment

toFromFragmentString

public String toFromFragmentString()
Specified by:
toFromFragmentString in class JoinFragment

toWhereFragmentString

public String toWhereFragmentString()
Specified by:
toWhereFragmentString in class JoinFragment

addJoins

public void addJoins(String fromFragment,
                     String whereFragment)
Specified by:
addJoins in class JoinFragment

copy

public JoinFragment copy()
Specified by:
copy in class JoinFragment

addCondition

public void addCondition(String alias,
                         String[] columns,
                         String condition)

addCrossJoin

public void addCrossJoin(String tableName,
                         String alias)
Specified by:
addCrossJoin in class JoinFragment

addCondition

public void addCondition(String alias,
                         String[] fkColumns,
                         String[] pkColumns)
Specified by:
addCondition in class JoinFragment

addCondition

public boolean addCondition(String condition)
Specified by:
addCondition in class JoinFragment

addFromFragmentString

public void addFromFragmentString(String fromFragmentString)

addJoin

public void addJoin(String tableName,
                    String alias,
                    String[] fkColumns,
                    String[] pkColumns,
                    int joinType,
                    String on)
Specified by:
addJoin in class JoinFragment
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Template (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class Template

java.lang.Object
    extended by org.hibernate.sql.Template
public final class Template
extends Object

Parses SQL fragments specified in mapping documents

Author:
Gavin King

Field Summary
static String TEMPLATE
Method Summary
static String renderOrderByStringTemplate(String sqlOrderByString, Dialect dialect, SQLFunctionRegistry functionRegistry)
Takes order by clause provided in the mapping attribute and interpolates the alias.
static String renderWhereStringTemplate(String sqlWhereString, Dialect dialect, SQLFunctionRegistry functionRegistry)
static String renderWhereStringTemplate(String sqlWhereString, String placeholder, Dialect dialect)
Deprecated. Only intended for annotations usage; use renderWhereStringTemplate(String, String, Dialect, SQLFunctionRegistry) instead
static String renderWhereStringTemplate(String sqlWhereString, String placeholder, Dialect dialect, SQLFunctionRegistry functionRegistry)
Takes the where condition provided in the mapping attribute and interpolates the alias.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values
Method Detail

renderWhereStringTemplate

public static String renderWhereStringTemplate(String sqlWhereString,
                                               Dialect dialect,
                                               SQLFunctionRegistry functionRegistry)

renderWhereStringTemplate

public static String renderWhereStringTemplate(String sqlWhereString,
                                               String placeholder,
                                               Dialect dialect)
Deprecated. Only intended for annotations usage; use renderWhereStringTemplate(String, String, Dialect, SQLFunctionRegistry) instead

Same functionality as renderWhereStringTemplate(String, String, Dialect, SQLFunctionRegistry), except that a SQLFunctionRegistry is not provided (i.e., only the dialect-defined functions are considered). This is only intended for use by the annotations project until the many-to-many/map-key-from-target-table feature is pulled into core.

renderWhereStringTemplate

public static String renderWhereStringTemplate(String sqlWhereString,
                                               String placeholder,
                                               Dialect dialect,
                                               SQLFunctionRegistry functionRegistry)
Takes the where condition provided in the mapping attribute and interpolates the alias. Handles subselects, quoted identifiers, quoted strings, expressions, SQL functions, named parameters.

Parameters:
sqlWhereString - The string into which to interpolate the placeholder value
placeholder - The value to be interpolated into the the sqlWhereString
dialect - The dialect to apply
functionRegistry - The registry of all sql functions
Returns:
The rendered sql fragment

renderOrderByStringTemplate

public static String renderOrderByStringTemplate(String sqlOrderByString,
                                                 Dialect dialect,
                                                 SQLFunctionRegistry functionRegistry)
Takes order by clause provided in the mapping attribute and interpolates the alias. Handles asc, desc, SQL functions, quoted identifiers.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Update (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.sql
Class Update

java.lang.Object
    extended by org.hibernate.sql.Update
public class Update
extends Object

An SQL UPDATE statement

Author:
Gavin King

Constructor Summary
Update(Dialect dialect)
Method Summary
Update | addColumn(String columnName)
Update | addColumn(String columnName, Object value, LiteralType type)
Update | addColumn(String columnName, String value)
Update | addColumns(String[] columnNames)
Update | addColumns(String[] columnNames, boolean[] updateable)
Update | addColumns(String[] columnNames, String value)
Update | addWhereColumn(String columnName)
Update | addWhereColumn(String columnName, String value)
Update | addWhereColumns(String[] columnNames)
Update | addWhereColumns(String[] columnNames, String value)
Update | appendAssignmentFragment(String fragment)
String | getTableName()
Update | setComment(String comment)
Update | setPrimaryKeyColumnNames(String[] primaryKeyColumnNames)
Update | setTableName(String tableName)
Update | setVersionColumnName(String versionColumnName)
Update | setWhere(String where)
String | toStatementString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Update

public Update(Dialect dialect)
Method Detail

getTableName

public String getTableName()

appendAssignmentFragment

public Update appendAssignmentFragment(String fragment)

setTableName

public Update setTableName(String tableName)

setPrimaryKeyColumnNames

public Update setPrimaryKeyColumnNames(String[] primaryKeyColumnNames)

setVersionColumnName

public Update setVersionColumnName(String versionColumnName)

setComment

public Update setComment(String comment)

addColumns

public Update addColumns(String[] columnNames)

addColumns

public Update addColumns(String[] columnNames,
                         boolean[] updateable)

addColumns

public Update addColumns(String[] columnNames,
                         String value)

addColumn

public Update addColumn(String columnName)

addColumn

public Update addColumn(String columnName,
                        String value)

addColumn

public Update addColumn(String columnName,
                        Object value,
                        LiteralType type)
                 throws Exception
Throws:
Exception

addWhereColumns

public Update addWhereColumns(String[] columnNames)

addWhereColumns

public Update addWhereColumns(String[] columnNames,
                              String value)

addWhereColumn

public Update addWhereColumn(String columnName)

addWhereColumn

public Update addWhereColumn(String columnName,
                             String value)

setWhere

public Update setWhere(String where)

toStatementString

public String toStatementString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.stat (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.stat

This package exposes statistics about a running Hibernate instance to the application.

See:
Description

Interface Summary
SessionStatistics | Information about the first-level (session) cache for a particular session instance
Statistics | Statistics for a particular SessionFactory.
StatisticsImplementor | Statistics SPI for the Hibernate core

Class Summary
CategorizedStatistics | Statistics for a particular "category" (a named entity, collection role, second level cache region or query).
CollectionStatistics | Collection related statistics
EntityStatistics | Entity related statistics
QueryStatistics | Query statistics (HQL and SQL) Note that for a cached query, the cache miss is equals to the db count
SecondLevelCacheStatistics | Second level cache statistics of a specific region
SessionStatisticsImpl |
StatisticsImpl |

Package org.hibernate.stat Description

This package exposes statistics about a running Hibernate instance to the application.


org.hibernate.stat Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.stat

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.stat.CategorizedStatistics (implements java.io.Serializable)
      • class org.hibernate.stat.CollectionStatistics
      • class org.hibernate.stat.EntityStatistics
      • class org.hibernate.stat.QueryStatistics
      • class org.hibernate.stat.SecondLevelCacheStatistics
    • class org.hibernate.stat.SessionStatisticsImpl (implements org.hibernate.stat.SessionStatistics)
    • class org.hibernate.stat.StatisticsImpl (implements org.hibernate.stat.Statistics, org.hibernate.stat.StatisticsImplementor)

Interface Hierarchy

  • interface org.hibernate.stat.SessionStatistics
  • interface org.hibernate.stat.Statistics
  • interface org.hibernate.stat.StatisticsImplementor


Uses of Package org.hibernate.stat (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.stat

Packages that use org.hibernate.stat
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.stat | This package exposes statistics about a running Hibernate instance to the application.

Classes in org.hibernate.stat used by org.hibernate
SessionStatistics
Information about the first-level (session) cache for a particular session instance
Statistics
Statistics for a particular SessionFactory.

Classes in org.hibernate.stat used by org.hibernate.engine
StatisticsImplementor
Statistics SPI for the Hibernate core

Classes in org.hibernate.stat used by org.hibernate.impl
SessionStatistics
Information about the first-level (session) cache for a particular session instance
Statistics
Statistics for a particular SessionFactory.
StatisticsImplementor
Statistics SPI for the Hibernate core

Classes in org.hibernate.stat used by org.hibernate.jmx
CollectionStatistics
Collection related statistics
EntityStatistics
Entity related statistics
QueryStatistics
Query statistics (HQL and SQL) Note that for a cached query, the cache miss is equals to the db count
SecondLevelCacheStatistics
Second level cache statistics of a specific region
Statistics
Statistics for a particular SessionFactory.

Classes in org.hibernate.stat used by org.hibernate.stat
CategorizedStatistics
Statistics for a particular "category" (a named entity, collection role, second level cache region or query).
CollectionStatistics
Collection related statistics
EntityStatistics
Entity related statistics
QueryStatistics
Query statistics (HQL and SQL) Note that for a cached query, the cache miss is equals to the db count
SecondLevelCacheStatistics
Second level cache statistics of a specific region
SessionStatistics
Information about the first-level (session) cache for a particular session instance
Statistics
Statistics for a particular SessionFactory.
StatisticsImplementor
Statistics SPI for the Hibernate core

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SessionStatistics (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.stat
Interface SessionStatistics

All Known Implementing Classes:
SessionStatisticsImpl
public interface SessionStatistics

Information about the first-level (session) cache for a particular session instance

Author:
Gavin King

Method Summary
int | getCollectionCount() Get the number of collection instances associated with the session
Set | getCollectionKeys() Get the set of all CollectionKeys
int | getEntityCount() Get the number of entity instances associated with the session
Set | getEntityKeys() Get the set of all EntityKeys

Method Detail

getEntityCount

public int getEntityCount()
Get the number of entity instances associated with the session

getCollectionCount

public int getCollectionCount()
Get the number of collection instances associated with the session

getEntityKeys

public Set getEntityKeys()
Get the set of all EntityKeys

See Also:
EntityKey

getCollectionKeys

public Set getCollectionKeys()
Get the set of all CollectionKeys

See Also:
CollectionKey
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Statistics (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.stat
Interface Statistics

All Known Subinterfaces:
StatisticsServiceMBean
All Known Implementing Classes:
StatisticsImpl, StatisticsService
public interface Statistics

Statistics for a particular SessionFactory. Beware of milliseconds metrics, they are depdendent of the JVM precision: you may then encounter a 10 ms approximation dending on you OS platform. Please refer to the JVM documentation for more information.

Author:
Emmanuel Bernard

Method Summary
void | clear() reset all statistics
long | getCloseStatementCount() The number of prepared statements that were released
long | getCollectionFetchCount() Global number of collections fetched
long | getCollectionLoadCount() Global number of collections loaded
long | getCollectionRecreateCount() Global number of collections recreated
long | getCollectionRemoveCount() Global number of collections removed
String[] | getCollectionRoleNames() Get the names of all collection roles
CollectionStatistics | getCollectionStatistics(String role) Get collection statistics per role
long | getCollectionUpdateCount() Global number of collections updated
long | getConnectCount() Get the global number of connections asked by the sessions (the actual number of connections used may be much smaller depending whether you use a connection pool or not)
long | getEntityDeleteCount() Get global number of entity deletes
long | getEntityFetchCount() Get global number of entity fetchs
long | getEntityInsertCount() Get global number of entity inserts
long | getEntityLoadCount() Get global number of entity loads
String[] | getEntityNames() Get the names of all entities
EntityStatistics | getEntityStatistics(String entityName) find entity statistics per name
long | getEntityUpdateCount() Get global number of entity updates
long | getFlushCount() Get the global number of flush executed by sessions (either implicit or explicit)
long | getOptimisticFailureCount() The number of StaleObjectStateExceptions that occurred
long | getPrepareStatementCount() The number of prepared statements that were acquired
String[] | getQueries() Get all executed query strings
long | getQueryCacheHitCount() Get the global number of cached queries successfully retrieved from cache
long | getQueryCacheMissCount() Get the global number of cached queries *not* found in cache
long | getQueryCachePutCount() Get the global number of cacheable queries put in cache
long | getQueryExecutionCount() Get global number of executed queries
long | getQueryExecutionMaxTime() Get the time in milliseconds of the slowest query.
String | getQueryExecutionMaxTimeQueryString() Get the query string for the slowest query.
QueryStatistics | getQueryStatistics(String queryString) Query statistics from query string (HQL or SQL)
long | getSecondLevelCacheHitCount() Global number of cacheable entities/collections successfully retrieved from the cache
long | getSecondLevelCacheMissCount() Global number of cacheable entities/collections not found in the cache and loaded from the database.
long | getSecondLevelCachePutCount() Global number of cacheable entities/collections put in the cache
String[] | getSecondLevelCacheRegionNames() Get all second-level cache region names
SecondLevelCacheStatistics | getSecondLevelCacheStatistics(String regionName) Second level cache statistics per region
long | getSessionCloseCount() Global number of sessions closed
long | getSessionOpenCount() Global number of sessions opened
long | getStartTime()
long | getSuccessfulTransactionCount() The number of transactions we know to have been successful
long | getTransactionCount() The number of transactions we know to have completed
boolean | isStatisticsEnabled() Are statistics logged
void | logSummary() log in info level the main statistics
void | setStatisticsEnabled(boolean b) Enable statistics logs (this is a dynamic parameter)

Method Detail

clear

public void clear()
reset all statistics

getEntityStatistics

public EntityStatistics getEntityStatistics(String entityName)
find entity statistics per name

Parameters:
entityName - entity name
Returns:
EntityStatistics object

getCollectionStatistics

public CollectionStatistics getCollectionStatistics(String role)
Get collection statistics per role

Parameters:
role - collection role
Returns:
CollectionStatistics

getSecondLevelCacheStatistics

public SecondLevelCacheStatistics getSecondLevelCacheStatistics(String regionName)
Second level cache statistics per region

Parameters:
regionName - region name
Returns:
SecondLevelCacheStatistics

getQueryStatistics

public QueryStatistics getQueryStatistics(String queryString)
Query statistics from query string (HQL or SQL)

Parameters:
queryString - query string
Returns:
QueryStatistics

getEntityDeleteCount

public long getEntityDeleteCount()
Get global number of entity deletes

Returns:
entity deletion count

getEntityInsertCount

public long getEntityInsertCount()
Get global number of entity inserts

Returns:
entity insertion count

getEntityLoadCount

public long getEntityLoadCount()
Get global number of entity loads

Returns:
entity load (from DB)

getEntityFetchCount

public long getEntityFetchCount()
Get global number of entity fetchs

Returns:
entity fetch (from DB)

getEntityUpdateCount

public long getEntityUpdateCount()
Get global number of entity updates

Returns:
entity update

getQueryExecutionCount

public long getQueryExecutionCount()
Get global number of executed queries

Returns:
query execution count

getQueryExecutionMaxTime

public long getQueryExecutionMaxTime()
Get the time in milliseconds of the slowest query.

getQueryExecutionMaxTimeQueryString

public String getQueryExecutionMaxTimeQueryString()
Get the query string for the slowest query.

getQueryCacheHitCount

public long getQueryCacheHitCount()
Get the global number of cached queries successfully retrieved from cache

getQueryCacheMissCount

public long getQueryCacheMissCount()
Get the global number of cached queries *not* found in cache

getQueryCachePutCount

public long getQueryCachePutCount()
Get the global number of cacheable queries put in cache

getFlushCount

public long getFlushCount()
Get the global number of flush executed by sessions (either implicit or explicit)

getConnectCount

public long getConnectCount()
Get the global number of connections asked by the sessions (the actual number of connections used may be much smaller depending whether you use a connection pool or not)

getSecondLevelCacheHitCount

public long getSecondLevelCacheHitCount()
Global number of cacheable entities/collections successfully retrieved from the cache

getSecondLevelCacheMissCount

public long getSecondLevelCacheMissCount()
Global number of cacheable entities/collections not found in the cache and loaded from the database.

getSecondLevelCachePutCount

public long getSecondLevelCachePutCount()
Global number of cacheable entities/collections put in the cache

getSessionCloseCount

public long getSessionCloseCount()
Global number of sessions closed

getSessionOpenCount

public long getSessionOpenCount()
Global number of sessions opened

getCollectionLoadCount

public long getCollectionLoadCount()
Global number of collections loaded

getCollectionFetchCount

public long getCollectionFetchCount()
Global number of collections fetched

getCollectionUpdateCount

public long getCollectionUpdateCount()
Global number of collections updated

getCollectionRemoveCount

public long getCollectionRemoveCount()
Global number of collections removed

getCollectionRecreateCount

public long getCollectionRecreateCount()
Global number of collections recreated

getStartTime

public long getStartTime()
Returns:
start time in ms (JVM standards System.currentTimeMillis())

logSummary

public void logSummary()
log in info level the main statistics

isStatisticsEnabled

public boolean isStatisticsEnabled()
Are statistics logged

setStatisticsEnabled

public void setStatisticsEnabled(boolean b)
Enable statistics logs (this is a dynamic parameter)

getQueries

public String[] getQueries()
Get all executed query strings

getEntityNames

public String[] getEntityNames()
Get the names of all entities

getCollectionRoleNames

public String[] getCollectionRoleNames()
Get the names of all collection roles

getSecondLevelCacheRegionNames

public String[] getSecondLevelCacheRegionNames()
Get all second-level cache region names

getSuccessfulTransactionCount

public long getSuccessfulTransactionCount()
The number of transactions we know to have been successful

getTransactionCount

public long getTransactionCount()
The number of transactions we know to have completed

getPrepareStatementCount

public long getPrepareStatementCount()
The number of prepared statements that were acquired

getCloseStatementCount

public long getCloseStatementCount()
The number of prepared statements that were released

getOptimisticFailureCount

public long getOptimisticFailureCount()
The number of StaleObjectStateExceptions that occurred

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StatisticsImplementor (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.stat
Interface StatisticsImplementor

All Known Implementing Classes:
StatisticsImpl
public interface StatisticsImplementor

Statistics SPI for the Hibernate core

Author:
Emmanuel Bernard

Method Summary
void | closeSession()
void | closeStatement()
void | connect()
void | deleteEntity(String entityName)
void | endTransaction(boolean success)
void | fetchCollection(String role)
void | fetchEntity(String entityName)
void | flush()
void | insertEntity(String entityName)
void | loadCollection(String role)
void | loadEntity(String entityName)
void | openSession()
void | optimisticFailure(String entityName)
void | prepareStatement()
void | queryCacheHit(String hql, String regionName)
void | queryCacheMiss(String hql, String regionName)
void | queryCachePut(String hql, String regionName)
void | queryExecuted(String hql, int rows, long time)
void | recreateCollection(String role)
void | removeCollection(String role)
void | secondLevelCacheHit(String regionName)
void | secondLevelCacheMiss(String regionName)
void | secondLevelCachePut(String regionName)
void | updateCollection(String role)
void | updateEntity(String entityName)

Method Detail

openSession

public void openSession()

closeSession

public void closeSession()

flush

public void flush()

connect

public void connect()

loadEntity

public void loadEntity(String entityName)

fetchEntity

public void fetchEntity(String entityName)

updateEntity

public void updateEntity(String entityName)

insertEntity

public void insertEntity(String entityName)

deleteEntity

public void deleteEntity(String entityName)

loadCollection

public void loadCollection(String role)

fetchCollection

public void fetchCollection(String role)

updateCollection

public void updateCollection(String role)

recreateCollection

public void recreateCollection(String role)

removeCollection

public void removeCollection(String role)

secondLevelCachePut

public void secondLevelCachePut(String regionName)

secondLevelCacheHit

public void secondLevelCacheHit(String regionName)

secondLevelCacheMiss

public void secondLevelCacheMiss(String regionName)

queryExecuted

public void queryExecuted(String hql,
                          int rows,
                          long time)

queryCacheHit

public void queryCacheHit(String hql,
                          String regionName)

queryCacheMiss

public void queryCacheMiss(String hql,
                           String regionName)

queryCachePut

public void queryCachePut(String hql,
                          String regionName)

endTransaction

public void endTransaction(boolean success)

closeStatement

public void closeStatement()

prepareStatement

public void prepareStatement()

optimisticFailure

public void optimisticFailure(String entityName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CategorizedStatistics (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.stat
Class CategorizedStatistics

java.lang.Object
    extended by org.hibernate.stat.CategorizedStatistics
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
CollectionStatistics, EntityStatistics, QueryStatistics, SecondLevelCacheStatistics
public class CategorizedStatistics
extends Object
implements Serializable

Statistics for a particular "category" (a named entity, collection role, second level cache region or query).

Author:
Gavin King
See Also:
Serialized Form

Method Summary
 String getCategoryName()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getCategoryName

public String getCategoryName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CollectionStatistics (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.stat
Class CollectionStatistics

java.lang.Object
    extended by org.hibernate.stat.CategorizedStatistics
        extended by org.hibernate.stat.CollectionStatistics
All Implemented Interfaces:
Serializable
public class CollectionStatistics
extends CategorizedStatistics

Collection related statistics

Author:
Gavin King
See Also:
Serialized Form

Method Summary
long | getFetchCount()
long | getLoadCount()
long | getRecreateCount()
long | getRemoveCount()
long | getUpdateCount()
String | toString()
Methods inherited from class org.hibernate.stat.CategorizedStatistics
getCategoryName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getLoadCount

public long getLoadCount()

getFetchCount

public long getFetchCount()

getRecreateCount

public long getRecreateCount()

getRemoveCount

public long getRemoveCount()

getUpdateCount

public long getUpdateCount()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityStatistics (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.stat
Class EntityStatistics

java.lang.Object
    extended by org.hibernate.stat.CategorizedStatistics
        extended by org.hibernate.stat.EntityStatistics
All Implemented Interfaces:
Serializable
public class EntityStatistics
extends CategorizedStatistics

Entity related statistics

Author:
Gavin King
See Also:
Serialized Form

Method Summary
long | getDeleteCount()
long | getFetchCount()
long | getInsertCount()
long | getLoadCount()
long | getOptimisticFailureCount()
long | getUpdateCount()
String | toString()
Methods inherited from class org.hibernate.stat.CategorizedStatistics
getCategoryName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getDeleteCount

public long getDeleteCount()

getInsertCount

public long getInsertCount()

getLoadCount

public long getLoadCount()

getUpdateCount

public long getUpdateCount()

getFetchCount

public long getFetchCount()

getOptimisticFailureCount

public long getOptimisticFailureCount()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryStatistics (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.stat
Class QueryStatistics

java.lang.Object
    extended by org.hibernate.stat.CategorizedStatistics
        extended by org.hibernate.stat.QueryStatistics
All Implemented Interfaces:
Serializable
public class QueryStatistics
extends CategorizedStatistics

Query statistics (HQL and SQL) Note that for a cached query, the cache miss is equals to the db count

Author:
Gavin King
See Also:
Serialized Form

Method Summary
 long getCacheHitCount()
Queries retrieved successfully from the cache
 long getCacheMissCount()
 long getCachePutCount()
 long getExecutionAvgTime()
average time in ms taken by the excution of this query onto the DB
 long getExecutionCount()
queries executed to the DB
 long getExecutionMaxTime()
max time in ms taken by the excution of this query onto the DB
 long getExecutionMinTime()
min time in ms taken by the excution of this query onto the DB
 long getExecutionRowCount()
Number of lines returned by all the executions of this query (from DB) For now, Query.iterate() and Query.scroll()() do not fill this statistic
 String toString()
Methods inherited from class org.hibernate.stat.CategorizedStatistics
getCategoryName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getExecutionCount

public long getExecutionCount()
queries executed to the DB

getCacheHitCount

public long getCacheHitCount()
Queries retrieved successfully from the cache

getCachePutCount

public long getCachePutCount()

getCacheMissCount

public long getCacheMissCount()

getExecutionRowCount

public long getExecutionRowCount()
Number of lines returned by all the executions of this query (from DB) For now, Query.iterate() and Query.scroll()() do not fill this statistic

Returns:
The number of rows cumulatively returned by the given query; iterate and scroll queries do not effect this total as their number of returned rows is not known at execution time.

getExecutionAvgTime

public long getExecutionAvgTime()
average time in ms taken by the excution of this query onto the DB

getExecutionMaxTime

public long getExecutionMaxTime()
max time in ms taken by the excution of this query onto the DB

getExecutionMinTime

public long getExecutionMinTime()
min time in ms taken by the excution of this query onto the DB

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SecondLevelCacheStatistics (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.stat
Class SecondLevelCacheStatistics

java.lang.Object
    extended by org.hibernate.stat.CategorizedStatistics
        extended by org.hibernate.stat.SecondLevelCacheStatistics
All Implemented Interfaces:
Serializable
public class SecondLevelCacheStatistics
extends CategorizedStatistics

Second level cache statistics of a specific region

Author:
Gavin King
See Also:
Serialized Form

Method Summary
long | getElementCountInMemory()
long | getElementCountOnDisk()
Map | getEntries()
long | getHitCount()
long | getMissCount()
long | getPutCount()
long | getSizeInMemory()
String | toString()
Methods inherited from class org.hibernate.stat.CategorizedStatistics
getCategoryName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getHitCount

public long getHitCount()

getMissCount

public long getMissCount()

getPutCount

public long getPutCount()

getElementCountInMemory

public long getElementCountInMemory()

getElementCountOnDisk

public long getElementCountOnDisk()

getSizeInMemory

public long getSizeInMemory()

getEntries

public Map getEntries()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SessionStatisticsImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.stat
Class SessionStatisticsImpl

java.lang.Object
    extended by org.hibernate.stat.SessionStatisticsImpl
All Implemented Interfaces:
SessionStatistics
public class SessionStatisticsImpl
extends Object
implements SessionStatistics

Author:
Gavin King

Constructor Summary
SessionStatisticsImpl(SessionImplementor session)
Method Summary
int | getCollectionCount() Get the number of collection instances associated with the session
Set | getCollectionKeys() Get the set of all CollectionKeys
int | getEntityCount() Get the number of entity instances associated with the session
Set | getEntityKeys() Get the set of all EntityKeys
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SessionStatisticsImpl

public SessionStatisticsImpl(SessionImplementor session)
Method Detail

getEntityCount

public int getEntityCount()
Description copied from interface: SessionStatistics
Get the number of entity instances associated with the session

Specified by:
getEntityCount in interface SessionStatistics

getCollectionCount

public int getCollectionCount()
Description copied from interface: SessionStatistics
Get the number of collection instances associated with the session

Specified by:
getCollectionCount in interface SessionStatistics

getEntityKeys

public Set getEntityKeys()
Description copied from interface: SessionStatistics
Get the set of all EntityKeys

Specified by:
getEntityKeys in interface SessionStatistics
See Also:
EntityKey

getCollectionKeys

public Set getCollectionKeys()
Description copied from interface: SessionStatistics
Get the set of all CollectionKeys

Specified by:
getCollectionKeys in interface SessionStatistics
See Also:
CollectionKey

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StatisticsImpl (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.stat
Class StatisticsImpl

java.lang.Object
    extended by org.hibernate.stat.StatisticsImpl
All Implemented Interfaces:
Statistics, StatisticsImplementor
public class StatisticsImpl
extends Object
implements Statistics, StatisticsImplementor

Author:
Gavin King
See Also:
Statistics

Constructor Summary
StatisticsImpl()
StatisticsImpl(SessionFactoryImplementor sessionFactory)
Method Summary
void | clear() reset all statistics
void | closeSession()
void | closeStatement()
void | connect()
void | deleteEntity(String entityName)
void | endTransaction(boolean success)
void | fetchCollection(String role)
void | fetchEntity(String entityName)
void | flush()
long | getCloseStatementCount() The number of prepared statements that were released
long | getCollectionFetchCount() Global number of collections fetched
long | getCollectionLoadCount() Global number of collections loaded
long | getCollectionRecreateCount() Global number of collections recreated
long | getCollectionRemoveCount() Global number of collections removed
String[] | getCollectionRoleNames() Get the names of all collection roles
CollectionStatistics | getCollectionStatistics(String role) Get collection statistics per role
long | getCollectionUpdateCount() Global number of collections updated
long | getConnectCount() Get the global number of connections asked by the sessions (the actual number of connections used may be much smaller depending whether you use a connection pool or not)
long | getEntityDeleteCount() Get global number of entity deletes
long | getEntityFetchCount() Get global number of entity fetchs
long | getEntityInsertCount() Get global number of entity inserts
long | getEntityLoadCount() Get global number of entity loads
String[] | getEntityNames() Get the names of all entities
EntityStatistics | getEntityStatistics(String entityName) find entity statistics per name
long | getEntityUpdateCount() Get global number of entity updates
long | getFlushCount() Get the global number of flush executed by sessions (either implicit or explicit)
long | getOptimisticFailureCount() The number of StaleObjectStateExceptions that occurred
long | getPrepareStatementCount() The number of prepared statements that were acquired
String[] | getQueries() Get all executed query strings
long | getQueryCacheHitCount() Get the global number of cached queries successfully retrieved from cache
long | getQueryCacheMissCount() Get the global number of cached queries *not* found in cache
long | getQueryCachePutCount() Get the global number of cacheable queries put in cache
long | getQueryExecutionCount() Get global number of executed queries
long | getQueryExecutionMaxTime() Get the time in milliseconds of the slowest query.
String | getQueryExecutionMaxTimeQueryString() Get the query string for the slowest query.
QueryStatistics | getQueryStatistics(String queryString) Query statistics from query string (HQL or SQL)
long | getSecondLevelCacheHitCount() Global number of cacheable entities/collections successfully retrieved from the cache
long | getSecondLevelCacheMissCount() Global number of cacheable entities/collections not found in the cache and loaded from the database.
long | getSecondLevelCachePutCount() Global number of cacheable entities/collections put in the cache
String[] | getSecondLevelCacheRegionNames() Get all second-level cache region names
SecondLevelCacheStatistics | getSecondLevelCacheStatistics(String regionName) Second level cache statistics per region
long | getSessionCloseCount() Global number of sessions closed
long | getSessionOpenCount() Global number of sessions opened
long | getStartTime()
long | getSuccessfulTransactionCount() The number of transactions we know to have been successful
long | getTransactionCount() The number of transactions we know to have completed
void | insertEntity(String entityName)
boolean | isStatisticsEnabled() Are statistics logged
void | loadCollection(String role)
void | loadEntity(String entityName)
void | logSummary() log in info level the main statistics
void | openSession()
void | optimisticFailure(String entityName)
void | prepareStatement()
void | queryCacheHit(String hql, String regionName)
void | queryCacheMiss(String hql, String regionName)
void | queryCachePut(String hql, String regionName)
void | queryExecuted(String hql, int rows, long time)
void | recreateCollection(String role)
void | removeCollection(String role)
void | secondLevelCacheHit(String regionName)
void | secondLevelCacheMiss(String regionName)
void | secondLevelCachePut(String regionName)
void | setStatisticsEnabled(boolean b) Enable statistics logs (this is a dynamic parameter)
String | toString()
void | updateCollection(String role)
void | updateEntity(String entityName)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

StatisticsImpl

public StatisticsImpl()

StatisticsImpl

public StatisticsImpl(SessionFactoryImplementor sessionFactory)
Method Detail

clear

public void clear()
reset all statistics

Specified by:
clear in interface Statistics

openSession

public void openSession()
Specified by:
openSession in interface StatisticsImplementor

closeSession

public void closeSession()
Specified by:
closeSession in interface StatisticsImplementor

flush

public void flush()
Specified by:
flush in interface StatisticsImplementor

connect

public void connect()
Specified by:
connect in interface StatisticsImplementor

loadEntity

public void loadEntity(String entityName)
Specified by:
loadEntity in interface StatisticsImplementor

fetchEntity

public void fetchEntity(String entityName)
Specified by:
fetchEntity in interface StatisticsImplementor

getEntityStatistics

public EntityStatistics getEntityStatistics(String entityName)
find entity statistics per name

Specified by:
getEntityStatistics in interface Statistics
Parameters:
entityName - entity name
Returns:
EntityStatistics object

updateEntity

public void updateEntity(String entityName)
Specified by:
updateEntity in interface StatisticsImplementor

insertEntity

public void insertEntity(String entityName)
Specified by:
insertEntity in interface StatisticsImplementor

deleteEntity

public void deleteEntity(String entityName)
Specified by:
deleteEntity in interface StatisticsImplementor

getCollectionStatistics

public CollectionStatistics getCollectionStatistics(String role)
Get collection statistics per role

Specified by:
getCollectionStatistics in interface Statistics
Parameters:
role - collection role
Returns:
CollectionStatistics

loadCollection

public void loadCollection(String role)
Specified by:
loadCollection in interface StatisticsImplementor

fetchCollection

public void fetchCollection(String role)
Specified by:
fetchCollection in interface StatisticsImplementor

updateCollection

public void updateCollection(String role)
Specified by:
updateCollection in interface StatisticsImplementor

recreateCollection

public void recreateCollection(String role)
Specified by:
recreateCollection in interface StatisticsImplementor

removeCollection

public void removeCollection(String role)
Specified by:
removeCollection in interface StatisticsImplementor

getSecondLevelCacheStatistics

public SecondLevelCacheStatistics getSecondLevelCacheStatistics(String regionName)
Second level cache statistics per region

Specified by:
getSecondLevelCacheStatistics in interface Statistics
Parameters:
regionName - region name
Returns:
SecondLevelCacheStatistics

secondLevelCachePut

public void secondLevelCachePut(String regionName)
Specified by:
secondLevelCachePut in interface StatisticsImplementor

secondLevelCacheHit

public void secondLevelCacheHit(String regionName)
Specified by:
secondLevelCacheHit in interface StatisticsImplementor

secondLevelCacheMiss

public void secondLevelCacheMiss(String regionName)
Specified by:
secondLevelCacheMiss in interface StatisticsImplementor

queryExecuted

public void queryExecuted(String hql,
                          int rows,
                          long time)
Specified by:
queryExecuted in interface StatisticsImplementor

queryCacheHit

public void queryCacheHit(String hql,
                          String regionName)
Specified by:
queryCacheHit in interface StatisticsImplementor

queryCacheMiss

public void queryCacheMiss(String hql,
                           String regionName)
Specified by:
queryCacheMiss in interface StatisticsImplementor

queryCachePut

public void queryCachePut(String hql,
                          String regionName)
Specified by:
queryCachePut in interface StatisticsImplementor

getQueryStatistics

public QueryStatistics getQueryStatistics(String queryString)
Query statistics from query string (HQL or SQL)

Specified by:
getQueryStatistics in interface Statistics
Parameters:
queryString - query string
Returns:
QueryStatistics

getEntityDeleteCount

public long getEntityDeleteCount()
Description copied from interface: Statistics
Get global number of entity deletes

Specified by:
getEntityDeleteCount in interface Statistics
Returns:
entity deletion count

getEntityInsertCount

public long getEntityInsertCount()
Description copied from interface: Statistics
Get global number of entity inserts

Specified by:
getEntityInsertCount in interface Statistics
Returns:
entity insertion count

getEntityLoadCount

public long getEntityLoadCount()
Description copied from interface: Statistics
Get global number of entity loads

Specified by:
getEntityLoadCount in interface Statistics
Returns:
entity load (from DB)

getEntityFetchCount

public long getEntityFetchCount()
Description copied from interface: Statistics
Get global number of entity fetchs

Specified by:
getEntityFetchCount in interface Statistics
Returns:
entity fetch (from DB)

getEntityUpdateCount

public long getEntityUpdateCount()
Description copied from interface: Statistics
Get global number of entity updates

Specified by:
getEntityUpdateCount in interface Statistics
Returns:
entity update

getQueryExecutionCount

public long getQueryExecutionCount()
Description copied from interface: Statistics
Get global number of executed queries

Specified by:
getQueryExecutionCount in interface Statistics
Returns:
query execution count

getQueryCacheHitCount

public long getQueryCacheHitCount()
Description copied from interface: Statistics
Get the global number of cached queries successfully retrieved from cache

Specified by:
getQueryCacheHitCount in interface Statistics

getQueryCacheMissCount

public long getQueryCacheMissCount()
Description copied from interface: Statistics
Get the global number of cached queries *not* found in cache

Specified by:
getQueryCacheMissCount in interface Statistics

getQueryCachePutCount

public long getQueryCachePutCount()
Description copied from interface: Statistics
Get the global number of cacheable queries put in cache

Specified by:
getQueryCachePutCount in interface Statistics

getFlushCount

public long getFlushCount()
Description copied from interface: Statistics
Get the global number of flush executed by sessions (either implicit or explicit)

Specified by:
getFlushCount in interface Statistics
Returns:
flush

getConnectCount

public long getConnectCount()
Description copied from interface: Statistics
Get the global number of connections asked by the sessions (the actual number of connections used may be much smaller depending whether you use a connection pool or not)

Specified by:
getConnectCount in interface Statistics
Returns:
session connect

getSecondLevelCacheHitCount

public long getSecondLevelCacheHitCount()
Description copied from interface: Statistics
Global number of cacheable entities/collections successfully retrieved from the cache

Specified by:
getSecondLevelCacheHitCount in interface Statistics
Returns:
second level cache hit

getSecondLevelCacheMissCount

public long getSecondLevelCacheMissCount()
Description copied from interface: Statistics
Global number of cacheable entities/collections not found in the cache and loaded from the database.

Specified by:
getSecondLevelCacheMissCount in interface Statistics
Returns:
second level cache miss

getSecondLevelCachePutCount

public long getSecondLevelCachePutCount()
Description copied from interface: Statistics
Global number of cacheable entities/collections put in the cache

Specified by:
getSecondLevelCachePutCount in interface Statistics
Returns:
second level cache put

getSessionCloseCount

public long getSessionCloseCount()
Description copied from interface: Statistics
Global number of sessions closed

Specified by:
getSessionCloseCount in interface Statistics
Returns:
session closing

getSessionOpenCount

public long getSessionOpenCount()
Description copied from interface: Statistics
Global number of sessions opened

Specified by:
getSessionOpenCount in interface Statistics
Returns:
session opening

getCollectionLoadCount

public long getCollectionLoadCount()
Description copied from interface: Statistics
Global number of collections loaded

Specified by:
getCollectionLoadCount in interface Statistics
Returns:
collection loading (from DB)

getCollectionFetchCount

public long getCollectionFetchCount()
Description copied from interface: Statistics
Global number of collections fetched

Specified by:
getCollectionFetchCount in interface Statistics
Returns:
collection fetching (from DB)

getCollectionUpdateCount

public long getCollectionUpdateCount()
Description copied from interface: Statistics
Global number of collections updated

Specified by:
getCollectionUpdateCount in interface Statistics
Returns:
collection update

getCollectionRemoveCount

public long getCollectionRemoveCount()
Description copied from interface: Statistics
Global number of collections removed

Specified by:
getCollectionRemoveCount in interface Statistics
Returns:
collection removal FIXME: even if isInverse="true"?

getCollectionRecreateCount

public long getCollectionRecreateCount()
Description copied from interface: Statistics
Global number of collections recreated

Specified by:
getCollectionRecreateCount in interface Statistics
Returns:
collection recreation

getStartTime

public long getStartTime()
Specified by:
getStartTime in interface Statistics
Returns:
start time in ms (JVM standards System.currentTimeMillis())

logSummary

public void logSummary()
log in info level the main statistics

Specified by:
logSummary in interface Statistics

isStatisticsEnabled

public boolean isStatisticsEnabled()
Are statistics logged

Specified by:
isStatisticsEnabled in interface Statistics

setStatisticsEnabled

public void setStatisticsEnabled(boolean b)
Enable statistics logs (this is a dynamic parameter)

Specified by:
setStatisticsEnabled in interface Statistics

getQueryExecutionMaxTime

public long getQueryExecutionMaxTime()
Description copied from interface: Statistics
Get the time in milliseconds of the slowest query.

Specified by:
getQueryExecutionMaxTime in interface Statistics
Returns:
Returns the max query execution time, for all queries

getQueries

public String[] getQueries()
Get all executed query strings

Specified by:
getQueries in interface Statistics

getEntityNames

public String[] getEntityNames()
Get the names of all entities

Specified by:
getEntityNames in interface Statistics

getCollectionRoleNames

public String[] getCollectionRoleNames()
Get the names of all collection roles

Specified by:
getCollectionRoleNames in interface Statistics

getSecondLevelCacheRegionNames

public String[] getSecondLevelCacheRegionNames()
Get all second-level cache region names

Specified by:
getSecondLevelCacheRegionNames in interface Statistics

endTransaction

public void endTransaction(boolean success)
Specified by:
endTransaction in interface StatisticsImplementor

getSuccessfulTransactionCount

public long getSuccessfulTransactionCount()
Description copied from interface: Statistics
The number of transactions we know to have been successful

Specified by:
getSuccessfulTransactionCount in interface Statistics

getTransactionCount

public long getTransactionCount()
Description copied from interface: Statistics
The number of transactions we know to have completed

Specified by:
getTransactionCount in interface Statistics

closeStatement

public void closeStatement()
Specified by:
closeStatement in interface StatisticsImplementor

prepareStatement

public void prepareStatement()
Specified by:
prepareStatement in interface StatisticsImplementor

getCloseStatementCount

public long getCloseStatementCount()
Description copied from interface: Statistics
The number of prepared statements that were released

Specified by:
getCloseStatementCount in interface Statistics

getPrepareStatementCount

public long getPrepareStatementCount()
Description copied from interface: Statistics
The number of prepared statements that were acquired

Specified by:
getPrepareStatementCount in interface Statistics

optimisticFailure

public void optimisticFailure(String entityName)
Specified by:
optimisticFailure in interface StatisticsImplementor

getOptimisticFailureCount

public long getOptimisticFailureCount()
Description copied from interface: Statistics
The number of StaleObjectStateExceptions that occurred

Specified by:
getOptimisticFailureCount in interface Statistics

toString

public String toString()

getQueryExecutionMaxTimeQueryString

public String getQueryExecutionMaxTimeQueryString()
Description copied from interface: Statistics
Get the query string for the slowest query.

Specified by:
getQueryExecutionMaxTimeQueryString in interface Statistics
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.tool.hbm2ddl (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.tool.hbm2ddl

The hbm2ddl tool.

See:
Description

Class Summary
ColumnMetadata | JDBC column metadata
DatabaseMetadata | JDBC database metadata
ForeignKeyMetadata | JDBC foreign key metadata
IndexMetadata | JDBC index metadata
SchemaExport | Commandline tool to export table schema to the database.
SchemaExportTask | An Ant task for SchemaExport.
SchemaUpdate | A commandline tool to update a database schema.
SchemaUpdateTask | An Ant task for SchemaUpdate.
SchemaValidator | A commandline tool to update a database schema.
SchemaValidatorTask | An Ant task for SchemaUpdate.
TableMetadata | JDBC table metadata

Package org.hibernate.tool.hbm2ddl Description

The hbm2ddl tool.


org.hibernate.tool.hbm2ddl Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.tool.hbm2ddl

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.tool.hbm2ddl.ColumnMetadata
    • class org.hibernate.tool.hbm2ddl.DatabaseMetadata
    • class org.hibernate.tool.hbm2ddl.ForeignKeyMetadata
    • class org.hibernate.tool.hbm2ddl.IndexMetadata
    • class org.apache.tools.ant.ProjectComponent
      • class org.apache.tools.ant.Task
        • class org.apache.tools.ant.taskdefs.MatchingTask (implements org.apache.tools.ant.types.selectors.SelectorContainer)
          • class org.hibernate.tool.hbm2ddl.SchemaExportTask
          • class org.hibernate.tool.hbm2ddl.SchemaUpdateTask
          • class org.hibernate.tool.hbm2ddl.SchemaValidatorTask
    • class org.hibernate.tool.hbm2ddl.SchemaExport
    • class org.hibernate.tool.hbm2ddl.SchemaUpdate
    • class org.hibernate.tool.hbm2ddl.SchemaValidator
    • class org.hibernate.tool.hbm2ddl.TableMetadata


Uses of Package org.hibernate.tool.hbm2ddl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.tool.hbm2ddl

Packages that use org.hibernate.tool.hbm2ddl
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.tool.hbm2ddl | The hbm2ddl tool.

Classes in org.hibernate.tool.hbm2ddl used by org.hibernate.cfg
DatabaseMetadata
JDBC database metadata

Classes in org.hibernate.tool.hbm2ddl used by org.hibernate.mapping
TableMetadata
JDBC table metadata

Classes in org.hibernate.tool.hbm2ddl used by org.hibernate.tool.hbm2ddl
ColumnMetadata
JDBC column metadata
ForeignKeyMetadata
JDBC foreign key metadata
IndexMetadata
JDBC index metadata
SchemaExport
Commandline tool to export table schema to the database.
TableMetadata
JDBC table metadata

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ColumnMetadata (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.hbm2ddl
Class ColumnMetadata

java.lang.Object
    extended by org.hibernate.tool.hbm2ddl.ColumnMetadata
public class ColumnMetadata
extends Object

JDBC column metadata

Author:
Christoph Sturm

Method Summary
int | getColumnSize()
int | getDecimalDigits()
String | getName()
String | getNullable()
int | getTypeCode()
String | getTypeName()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getName

public String getName()

getTypeName

public String getTypeName()

getColumnSize

public int getColumnSize()

getDecimalDigits

public int getDecimalDigits()

getNullable

public String getNullable()

toString

public String toString()

getTypeCode

public int getTypeCode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DatabaseMetadata (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.hbm2ddl
Class DatabaseMetadata

java.lang.Object
    extended by org.hibernate.tool.hbm2ddl.DatabaseMetadata
public class DatabaseMetadata
extends Object

JDBC database metadata

Author:
Christoph Sturm, Teodor Danciu

Constructor Summary
DatabaseMetadata(Connection connection, Dialect dialect)
DatabaseMetadata(Connection connection, Dialect dialect, boolean extras)
Method Summary
TableMetadata | getTableMetadata(String name, String schema, String catalog)
boolean | isSequence(Object key)
boolean | isTable(Object key)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DatabaseMetadata

public DatabaseMetadata(Connection connection,
                        Dialect dialect)
                 throws SQLException

DatabaseMetadata

public DatabaseMetadata(Connection connection,
                        Dialect dialect,
                        boolean extras)
                 throws SQLException
Method Detail

getTableMetadata

public TableMetadata getTableMetadata(String name,
                                      String schema,
                                      String catalog)
                               throws HibernateException
Throws:
HibernateException

isSequence

public boolean isSequence(Object key)

isTable

public boolean isTable(Object key)
                throws HibernateException
Throws:
HibernateException

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ForeignKeyMetadata (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.hbm2ddl
Class ForeignKeyMetadata

java.lang.Object
    extended by org.hibernate.tool.hbm2ddl.ForeignKeyMetadata
public class ForeignKeyMetadata
extends Object

JDBC foreign key metadata

Author:
Christoph Sturm

Method Summary
ColumnMetadata[] | getColumns()
String | getName()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getName

public String getName()

getColumns

public ColumnMetadata[] getColumns()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IndexMetadata (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.hbm2ddl
Class IndexMetadata

java.lang.Object
    extended by org.hibernate.tool.hbm2ddl.IndexMetadata
public class IndexMetadata
extends Object

JDBC index metadata

Author:
Christoph Sturm

Method Summary
ColumnMetadata[] | getColumns()
String | getName()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getName

public String getName()

getColumns

public ColumnMetadata[] getColumns()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SchemaExport (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.hbm2ddl
Class SchemaExport

java.lang.Object
    extended by org.hibernate.tool.hbm2ddl.SchemaExport
public class SchemaExport
extends Object

Commandline tool to export table schema to the database. This class may also be called from inside an application.

Author:
Daniel Bradby, Gavin King

Constructor Summary
SchemaExport(Configuration cfg)
Create a schema exporter for the given Configuration
SchemaExport(Configuration cfg, Connection connection)
SchemaExport(Configuration cfg, Properties properties)
Deprecated. properties may be specified via the Configuration object
SchemaExport(Configuration cfg, Settings settings)
Create a schema exporter for the given Configuration and given settings
Method Summary
void | create(boolean script, boolean export) Run the schema creation script.
void | drop(boolean script, boolean export) Run the drop schema script.
void | execute(boolean script, boolean export, boolean justDrop, boolean justCreate)
List | getExceptions() Returns a List of all Exceptions which occured during the export.
static void | main(String[] args)
SchemaExport | setDelimiter(String delimiter) Set the end of statement delimiter
SchemaExport | setFormat(boolean format)
SchemaExport | setHaltOnError(boolean haltOnError)
SchemaExport | setImportFile(String filename)
SchemaExport | setOutputFile(String filename) Set an output filename.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SchemaExport

public SchemaExport(Configuration cfg)
             throws HibernateException
Create a schema exporter for the given Configuration

SchemaExport

public SchemaExport(Configuration cfg,
                    Settings settings)
             throws HibernateException
Create a schema exporter for the given Configuration and given settings

SchemaExport

public SchemaExport(Configuration cfg,
                    Properties properties)
             throws HibernateException
Deprecated. properties may be specified via the Configuration object

Create a schema exporter for the given Configuration, with the given database connection properties.

SchemaExport

public SchemaExport(Configuration cfg,
                    Connection connection)
Method Detail

setOutputFile

public SchemaExport setOutputFile(String filename)
Set an output filename. The generated script will be written to this file.

setImportFile

public SchemaExport setImportFile(String filename)

setDelimiter

public SchemaExport setDelimiter(String delimiter)
Set the end of statement delimiter

create

public void create(boolean script,
                   boolean export)
Run the schema creation script.

Parameters:
script - print the DDL to the console
export - export the script to the database

drop

public void drop(boolean script,
                 boolean export)
Run the drop schema script.

Parameters:
script - print the DDL to the console
export - export the script to the database

execute

public void execute(boolean script,
                    boolean export,
                    boolean justDrop,
                    boolean justCreate)

main

public static void main(String[] args)

getExceptions

public List getExceptions()
Returns a List of all Exceptions which occured during the export.

Returns:
A List containig the Exceptions occured during the export

setFormat

public SchemaExport setFormat(boolean format)

setHaltOnError

public SchemaExport setHaltOnError(boolean haltOnError)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SchemaExportTask (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.hbm2ddl
Class SchemaExportTask

java.lang.Object
    extended by org.apache.tools.ant.ProjectComponent
        extended by org.apache.tools.ant.Task
            extended by org.apache.tools.ant.taskdefs.MatchingTask
                extended by org.hibernate.tool.hbm2ddl.SchemaExportTask
All Implemented Interfaces:
org.apache.tools.ant.types.selectors.SelectorContainer
public class SchemaExportTask
extends org.apache.tools.ant.taskdefs.MatchingTask

An Ant task for SchemaExport.

 <taskdef name="schemaexport"
     classname="org.hibernate.tool.hbm2ddl.SchemaExportTask"
     classpathref="class.path"/>

 <schemaexport
     properties="${build.classes.dir}/hibernate.properties"
     quiet="no"
     text="no"
     drop="no"
     delimiter=";"
     output="${build.dir}/schema-export.sql">
     <fileset dir="${build.classes.dir}">
         <include name="*.hbm.xml"/>
     </fileset>
 </schemaexport>

Author:
Rong C Ou
See Also:
SchemaExport

Field Summary
Fields inherited from class org.apache.tools.ant.taskdefs.MatchingTask
fileset
Fields inherited from class org.apache.tools.ant.Task
description, location, target, taskName, taskType, wrapper
Fields inherited from class org.apache.tools.ant.ProjectComponent
project
Constructor Summary
SchemaExportTask()
Method Summary
void | addFileset(org.apache.tools.ant.types.FileSet set)
void | execute() Execute the task
void | setConfig(File configurationFile) Set a .cfg.xml file, which will be loaded as a resource, from the classpath
void | setCreate(boolean create) Enable "create" mode.
void | setDelimiter(String delimiter) Set the end of statement delimiter for the generated script
void | setDrop(boolean drop) Enable "drop" mode.
void | setHaltonerror(boolean haltOnError)
void | setNamingStrategy(String namingStrategy)
void | setOutput(File outputFile) Set the script output file
void | setProperties(File propertiesFile) Set a properties file
void | setQuiet(boolean quiet) Enable "quiet" mode.
void | setText(boolean text) Enable "text-only" mode.
Methods inherited from class org.apache.tools.ant.taskdefs.MatchingTask
add, addAnd, addContains, addContainsRegexp, addCustom, addDate, addDepend, addDepth, addDifferent, addFilename, addMajority, addModified, addNone, addNot, addOr, addPresent, addSelector, addSize, addType, appendSelector, createExclude, createExcludesFile, createInclude, createIncludesFile, createPatternSet, getDirectoryScanner, getImplicitFileSet, getSelectors, hasSelectors, selectorCount, selectorElements, setCaseSensitive, setDefaultexcludes, setExcludes, setExcludesfile, setFollowSymlinks, setIncludes, setIncludesfile, setProject, XsetIgnore, XsetItems
Methods inherited from class org.apache.tools.ant.Task
getDescription, getLocation, getOwningTarget, getRuntimeConfigurableWrapper, getTaskName, getTaskType, getWrapper, handleErrorFlush, handleErrorOutput, handleFlush, handleInput, handleOutput, init, isInvalid, log, log, maybeConfigure, perform, reconfigure, setDescription, setLocation, setOwningTarget, setRuntimeConfigurableWrapper, setTaskName, setTaskType
Methods inherited from class org.apache.tools.ant.ProjectComponent
getProject
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SchemaExportTask

public SchemaExportTask()
Method Detail

addFileset

public void addFileset(org.apache.tools.ant.types.FileSet set)

setProperties

public void setProperties(File propertiesFile)
Set a properties file

Parameters:
propertiesFile - the properties file name

setConfig

public void setConfig(File configurationFile)
Set a .cfg.xml file, which will be loaded as a resource, from the classpath

Parameters:
configurationFile - the path to the resource

setQuiet

public void setQuiet(boolean quiet)
Enable "quiet" mode. The schema will not be written to standard out.

Parameters:
quiet - true to enable quiet mode

setText

public void setText(boolean text)
Enable "text-only" mode. The schema will not be exported to the database.

Parameters:
text - true to enable text-only mode

setDrop

public void setDrop(boolean drop)
Enable "drop" mode. Database objects will be dropped but not recreated.

Parameters:
drop - true to enable drop mode

setCreate

public void setCreate(boolean create)
Enable "create" mode. Database objects will be created but not first dropped.

Parameters:
create - true to enable create mode

setDelimiter

public void setDelimiter(String delimiter)
Set the end of statement delimiter for the generated script

Parameters:
delimiter - the delimiter

setOutput

public void setOutput(File outputFile)
Set the script output file

Parameters:
outputFile - the file name

execute

public void execute()
             throws org.apache.tools.ant.BuildException
Execute the task

Throws:
org.apache.tools.ant.BuildException

setNamingStrategy

public void setNamingStrategy(String namingStrategy)

setHaltonerror

public void setHaltonerror(boolean haltOnError)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SchemaUpdate (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.hbm2ddl
Class SchemaUpdate

java.lang.Object
    extended by org.hibernate.tool.hbm2ddl.SchemaUpdate
public class SchemaUpdate
extends Object

A commandline tool to update a database schema. May also be called from inside an application.

Author:
Christoph Sturm

Constructor Summary
SchemaUpdate(Configuration cfg)
SchemaUpdate(Configuration cfg, Properties connectionProperties)
SchemaUpdate(Configuration cfg, Settings settings)
Method Summary
void | execute(boolean script, boolean doUpdate) Execute the schema updates
List | getExceptions() Returns a List of all Exceptions which occured during the export.
static void | main(String[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SchemaUpdate

public SchemaUpdate(Configuration cfg)
             throws HibernateException

SchemaUpdate

public SchemaUpdate(Configuration cfg,
                    Properties connectionProperties)
             throws HibernateException

SchemaUpdate

public SchemaUpdate(Configuration cfg,
                    Settings settings)
             throws HibernateException
Method Detail

main

public static void main(String[] args)

execute

public void execute(boolean script,
                    boolean doUpdate)
Execute the schema updates

Parameters:
script - print all DDL to the console

getExceptions

public List getExceptions()
Returns a List of all Exceptions which occured during the export.

Returns:
A List containig the Exceptions occured during the export
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SchemaUpdateTask (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.hbm2ddl
Class SchemaUpdateTask

java.lang.Object
    extended by org.apache.tools.ant.ProjectComponent
        extended by org.apache.tools.ant.Task
            extended by org.apache.tools.ant.taskdefs.MatchingTask
                extended by org.hibernate.tool.hbm2ddl.SchemaUpdateTask
All Implemented Interfaces:
org.apache.tools.ant.types.selectors.SelectorContainer
public class SchemaUpdateTask
extends org.apache.tools.ant.taskdefs.MatchingTask

An Ant task for SchemaUpdate.

 <taskdef name="schemaupdate"
     classname="org.hibernate.tool.hbm2ddl.SchemaUpdateTask"
     classpathref="class.path"/>

 <schemaupdate
     properties="${build.classes.dir}/hibernate.properties"
     quiet="no"
     <fileset dir="${build.classes.dir}">
         <include name="*.hbm.xml"/>
     </fileset>
 </schemaupdate>

Author:
Rong C Ou, Gavin King
See Also:
SchemaUpdate

Field Summary
Fields inherited from class org.apache.tools.ant.taskdefs.MatchingTask
fileset
Fields inherited from class org.apache.tools.ant.Task
description, location, target, taskName, taskType, wrapper
Fields inherited from class org.apache.tools.ant.ProjectComponent
project
Constructor Summary
SchemaUpdateTask()
Method Summary
void | addFileset(org.apache.tools.ant.types.FileSet set)
void | execute() Execute the task
void | setConfig(File configurationFile) Set a .cfg.xml file
void | setNamingStrategy(String namingStrategy)
void | setProperties(File propertiesFile) Set a properties file
void | setQuiet(boolean quiet) Enable "quiet" mode.
void | setText(boolean text) Enable "text-only" mode.
Methods inherited from class org.apache.tools.ant.taskdefs.MatchingTask
add, addAnd, addContains, addContainsRegexp, addCustom, addDate, addDepend, addDepth, addDifferent, addFilename, addMajority, addModified, addNone, addNot, addOr, addPresent, addSelector, addSize, addType, appendSelector, createExclude, createExcludesFile, createInclude, createIncludesFile, createPatternSet, getDirectoryScanner, getImplicitFileSet, getSelectors, hasSelectors, selectorCount, selectorElements, setCaseSensitive, setDefaultexcludes, setExcludes, setExcludesfile, setFollowSymlinks, setIncludes, setIncludesfile, setProject, XsetIgnore, XsetItems
Methods inherited from class org.apache.tools.ant.Task
getDescription, getLocation, getOwningTarget, getRuntimeConfigurableWrapper, getTaskName, getTaskType, getWrapper, handleErrorFlush, handleErrorOutput, handleFlush, handleInput, handleOutput, init, isInvalid, log, log, maybeConfigure, perform, reconfigure, setDescription, setLocation, setOwningTarget, setRuntimeConfigurableWrapper, setTaskName, setTaskType
Methods inherited from class org.apache.tools.ant.ProjectComponent
getProject
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SchemaUpdateTask

public SchemaUpdateTask()
Method Detail

addFileset

public void addFileset(org.apache.tools.ant.types.FileSet set)

setProperties

public void setProperties(File propertiesFile)
Set a properties file

Parameters:
propertiesFile - the properties file name

setConfig

public void setConfig(File configurationFile)
Set a .cfg.xml file

Parameters:
configurationFile - the file name

setText

public void setText(boolean text)
Enable "text-only" mode. The schema will not be updated in the database.

Parameters:
text - true to enable text-only mode

setQuiet

public void setQuiet(boolean quiet)
Enable "quiet" mode. The schema will not be written to standard out.

Parameters:
quiet - true to enable quiet mode

execute

public void execute()
             throws org.apache.tools.ant.BuildException
Execute the task

Throws:
org.apache.tools.ant.BuildException

setNamingStrategy

public void setNamingStrategy(String namingStrategy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SchemaValidator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.hbm2ddl
Class SchemaValidator

java.lang.Object
    extended by org.hibernate.tool.hbm2ddl.SchemaValidator
public class SchemaValidator
extends Object

A commandline tool to update a database schema. May also be called from inside an application.

Author:
Christoph Sturm

Constructor Summary
SchemaValidator(Configuration cfg)
SchemaValidator(Configuration cfg, Properties connectionProperties)
SchemaValidator(Configuration cfg, Settings settings)
Method Summary
static void | main(String[] args)
void | validate() Perform the validations.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SchemaValidator

public SchemaValidator(Configuration cfg)
                throws HibernateException

SchemaValidator

public SchemaValidator(Configuration cfg,
                       Properties connectionProperties)
                throws HibernateException

SchemaValidator

public SchemaValidator(Configuration cfg,
                       Settings settings)
                throws HibernateException
Method Detail

main

public static void main(String[] args)

validate

public void validate()
Perform the validations.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SchemaValidatorTask (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.hbm2ddl
Class SchemaValidatorTask

java.lang.Object
    extended by org.apache.tools.ant.ProjectComponent
        extended by org.apache.tools.ant.Task
            extended by org.apache.tools.ant.taskdefs.MatchingTask
                extended by org.hibernate.tool.hbm2ddl.SchemaValidatorTask
All Implemented Interfaces:
org.apache.tools.ant.types.selectors.SelectorContainer
public class SchemaValidatorTask
extends org.apache.tools.ant.taskdefs.MatchingTask

An Ant task for SchemaUpdate.

 <taskdef name="schemavalidator"
     classname="org.hibernate.tool.hbm2ddl.SchemaValidatorTask"
     classpathref="class.path"/>

 <schemaupdate
     properties="${build.classes.dir}/hibernate.properties"
     <fileset dir="${build.classes.dir}">
         <include name="*.hbm.xml"/>
     </fileset>
 </schemaupdate>

Author:
Gavin King
See Also:
SchemaValidator

Field Summary
Fields inherited from class org.apache.tools.ant.taskdefs.MatchingTask
fileset
Fields inherited from class org.apache.tools.ant.Task
description, location, target, taskName, taskType, wrapper
Fields inherited from class org.apache.tools.ant.ProjectComponent
project
Constructor Summary
SchemaValidatorTask()
Method Summary
void | addFileset(org.apache.tools.ant.types.FileSet set)
void | execute() Execute the task
void | setConfig(File configurationFile) Set a .cfg.xml file
void | setNamingStrategy(String namingStrategy)
void | setProperties(File propertiesFile) Set a properties file
Methods inherited from class org.apache.tools.ant.taskdefs.MatchingTask
add, addAnd, addContains, addContainsRegexp, addCustom, addDate, addDepend, addDepth, addDifferent, addFilename, addMajority, addModified, addNone, addNot, addOr, addPresent, addSelector, addSize, addType, appendSelector, createExclude, createExcludesFile, createInclude, createIncludesFile, createPatternSet, getDirectoryScanner, getImplicitFileSet, getSelectors, hasSelectors, selectorCount, selectorElements, setCaseSensitive, setDefaultexcludes, setExcludes, setExcludesfile, setFollowSymlinks, setIncludes, setIncludesfile, setProject, XsetIgnore, XsetItems
Methods inherited from class org.apache.tools.ant.Task
getDescription, getLocation, getOwningTarget, getRuntimeConfigurableWrapper, getTaskName, getTaskType, getWrapper, handleErrorFlush, handleErrorOutput, handleFlush, handleInput, handleOutput, init, isInvalid, log, log, maybeConfigure, perform, reconfigure, setDescription, setLocation, setOwningTarget, setRuntimeConfigurableWrapper, setTaskName, setTaskType
Methods inherited from class org.apache.tools.ant.ProjectComponent
getProject
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SchemaValidatorTask

public SchemaValidatorTask()
Method Detail

addFileset

public void addFileset(org.apache.tools.ant.types.FileSet set)

setProperties

public void setProperties(File propertiesFile)
Set a properties file

Parameters:
propertiesFile - the properties file name

setConfig

public void setConfig(File configurationFile)
Set a .cfg.xml file

Parameters:
configurationFile - the file name

execute

public void execute()
             throws org.apache.tools.ant.BuildException
Execute the task

Throws:
org.apache.tools.ant.BuildException

setNamingStrategy

public void setNamingStrategy(String namingStrategy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TableMetadata (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.hbm2ddl
Class TableMetadata

java.lang.Object
    extended by org.hibernate.tool.hbm2ddl.TableMetadata
public class TableMetadata
extends Object

JDBC table metadata

Author:
Christoph Sturm

Method Summary
void | addColumn(ResultSet rs)
ColumnMetadata | getColumnMetadata(String columnName)
ForeignKeyMetadata | getForeignKeyMetadata(String keyName)
IndexMetadata | getIndexMetadata(String indexName)
String | getName()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getName

public String getName()

toString

public String toString()

getColumnMetadata

public ColumnMetadata getColumnMetadata(String columnName)

getForeignKeyMetadata

public ForeignKeyMetadata getForeignKeyMetadata(String keyName)

getIndexMetadata

public IndexMetadata getIndexMetadata(String indexName)

addColumn

public void addColumn(ResultSet rs)
               throws SQLException
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.tool.instrument (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.tool.instrument

The instrument tool for adding field-interception hooks to persistent classes using built-time bytecode processing.

See:
Description

Class Summary
BasicInstrumentationTask Super class for all Hibernate instrumentation tasks.

Package org.hibernate.tool.instrument Description

The instrument tool for adding field-interception hooks to persistent classes using built-time bytecode processing. Use this tool only if you wish to take advantage of lazy property fetching (the <lazy> mapping element).


org.hibernate.tool.instrument Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.tool.instrument

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.tool.instrument.BasicInstrumentationTask.CustomFieldFilter (implements org.hibernate.bytecode.util.FieldFilter)
    • class org.hibernate.tool.instrument.BasicInstrumentationTask.Logger
    • class org.apache.tools.ant.ProjectComponent
      • class org.apache.tools.ant.Task
        • class org.hibernate.tool.instrument.BasicInstrumentationTask


Uses of Package org.hibernate.tool.instrument (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.tool.instrument

Packages that use org.hibernate.tool.instrument
org.hibernate.tool.instrument | The instrument tool for adding field-interception hooks to persistent classes using built-time bytecode processing.
org.hibernate.tool.instrument.cglib |

Classes in org.hibernate.tool.instrument used by org.hibernate.tool.instrument
BasicInstrumentationTask.Logger

Classes in org.hibernate.tool.instrument used by org.hibernate.tool.instrument.cglib
BasicInstrumentationTask
Super class for all Hibernate instrumentation tasks.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BasicInstrumentationTask (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.instrument
Class BasicInstrumentationTask

java.lang.Object
    extended by org.apache.tools.ant.ProjectComponent
        extended by org.apache.tools.ant.Task
            extended by org.hibernate.tool.instrument.BasicInstrumentationTask
Direct Known Subclasses:
InstrumentTask, InstrumentTask
public abstract class BasicInstrumentationTask
extends org.apache.tools.ant.Task

Super class for all Hibernate instrumentation tasks. Provides the basic templating of how instrumentation should occur.

Author:
Steve Ebersole

Nested Class Summary
protected class | BasicInstrumentationTask.CustomFieldFilter
protected class | BasicInstrumentationTask.Logger
Field Summary
protected  BasicInstrumentationTask.Logger logger
Fields inherited from class org.apache.tools.ant.Task
description, location, target, taskName, taskType, wrapper
Fields inherited from class org.apache.tools.ant.ProjectComponent
project
Constructor Summary
BasicInstrumentationTask()
Method Summary
void | addFileset(org.apache.tools.ant.types.FileSet set)
protected boolean | checkMagic(File file, long magic)
void | execute()
protected Iterator | filesets()
protected abstract ClassDescriptor | getClassDescriptor(byte[] byecode)
protected abstract ClassTransformer | getClassTransformer(ClassDescriptor descriptor)
protected boolean | isBeingIntrumented(String className)
protected boolean | isClassFile(File file)
boolean | isExtended()
protected boolean | isJarFile(File file)
boolean | isVerbose()
protected void | processClassFile(File file)
protected void | processFile(File file)
protected void | processJarFile(File file)
void | setExtended(boolean extended)
void | setVerbose(boolean verbose)
Methods inherited from class org.apache.tools.ant.Task
getDescription, getLocation, getOwningTarget, getRuntimeConfigurableWrapper, getTaskName, getTaskType, getWrapper, handleErrorFlush, handleErrorOutput, handleFlush, handleInput, handleOutput, init, isInvalid, log, log, maybeConfigure, perform, reconfigure, setDescription, setLocation, setOwningTarget, setRuntimeConfigurableWrapper, setTaskName, setTaskType
Methods inherited from class org.apache.tools.ant.ProjectComponent
getProject, setProject
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logger

protected final BasicInstrumentationTask.Logger logger
Constructor Detail

BasicInstrumentationTask

public BasicInstrumentationTask()
Method Detail

addFileset

public void addFileset(org.apache.tools.ant.types.FileSet set)

filesets

protected final Iterator filesets()

isExtended

public boolean isExtended()

setExtended

public void setExtended(boolean extended)

isVerbose

public boolean isVerbose()

setVerbose

public void setVerbose(boolean verbose)

execute

public void execute()
             throws org.apache.tools.ant.BuildException
Throws:
org.apache.tools.ant.BuildException

processFile

protected void processFile(File file)
                    throws Exception
Throws:
Exception

isClassFile

protected final boolean isClassFile(File file)
                             throws IOException
Throws:
IOException

isJarFile

protected final boolean isJarFile(File file)
                           throws IOException
Throws:
IOException

checkMagic

protected final boolean checkMagic(File file,
                                   long magic)
                            throws IOException
Throws:
IOException

processClassFile

protected void processClassFile(File file)
                         throws Exception
Throws:
Exception

processJarFile

protected void processJarFile(File file)
                       throws Exception
Throws:
Exception

isBeingIntrumented

protected boolean isBeingIntrumented(String className)

getClassDescriptor

protected abstract ClassDescriptor getClassDescriptor(byte[] byecode)
                                               throws Exception
Throws:
Exception

getClassTransformer

protected abstract ClassTransformer getClassTransformer(ClassDescriptor descriptor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BasicInstrumentationTask.CustomFieldFilter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.instrument
Class BasicInstrumentationTask.CustomFieldFilter

java.lang.Object
    extended by org.hibernate.tool.instrument.BasicInstrumentationTask.CustomFieldFilter
All Implemented Interfaces:
FieldFilter
Enclosing class:
BasicInstrumentationTask
protected class BasicInstrumentationTask.CustomFieldFilter
extends Object
implements FieldFilter

Constructor Summary
BasicInstrumentationTask.CustomFieldFilter(ClassDescriptor descriptor)
Method Summary
boolean | shouldInstrumentField(String className, String fieldName) Should this field definition be instrumented?
boolean | shouldTransformFieldAccess(String transformingClassName, String fieldOwnerClassName, String fieldName) Should we instrument *access to* the given field.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BasicInstrumentationTask.CustomFieldFilter

public BasicInstrumentationTask.CustomFieldFilter(ClassDescriptor descriptor)
Method Detail

shouldInstrumentField

public boolean shouldInstrumentField(String className,
                                     String fieldName)
Description copied from interface: FieldFilter
Should this field definition be instrumented?

Specified by:
shouldInstrumentField in interface FieldFilter
Parameters:
className - The name of the class currently being processed
fieldName - The name of the field being checked.
Returns:
True if we should instrument this field.

shouldTransformFieldAccess

public boolean shouldTransformFieldAccess(String transformingClassName,
                                          String fieldOwnerClassName,
                                          String fieldName)
Description copied from interface: FieldFilter
Should we instrument *access to* the given field. This differs from FieldFilter.shouldInstrumentField(java.lang.String, java.lang.String) in that here we are talking about a particular usage of a field.

Specified by:
shouldTransformFieldAccess in interface FieldFilter
Parameters:
transformingClassName - The class currently being transformed.
fieldOwnerClassName - The name of the class owning this field being checked.
fieldName - The name of the field being checked.
Returns:
True if this access should be transformed.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BasicInstrumentationTask.Logger (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.instrument
Class BasicInstrumentationTask.Logger

java.lang.Object
    extended by org.hibernate.tool.instrument.BasicInstrumentationTask.Logger
Enclosing class:
BasicInstrumentationTask
protected class BasicInstrumentationTask.Logger
extends Object

Constructor Summary
protected BasicInstrumentationTask.Logger()
Method Summary
void | debug(String message)
void | info(String message)
void | verbose(String message)
void | warn(String message)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BasicInstrumentationTask.Logger

protected BasicInstrumentationTask.Logger()
Method Detail

verbose

public void verbose(String message)

debug

public void debug(String message)

info

public void info(String message)

warn

public void warn(String message)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.tool.instrument.cglib (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.tool.instrument.cglib

Class Summary
InstrumentTask An Ant task for instrumenting persistent classes in order to enable field-level interception using CGLIB.


org.hibernate.tool.instrument.cglib Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.tool.instrument.cglib

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.apache.tools.ant.ProjectComponent
      • class org.apache.tools.ant.Task
        • class org.hibernate.tool.instrument.BasicInstrumentationTask
          • class org.hibernate.tool.instrument.cglib.InstrumentTask


Uses of Package org.hibernate.tool.instrument.cglib (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.tool.instrument.cglib

No usage of org.hibernate.tool.instrument.cglib

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


InstrumentTask (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.instrument.cglib
Class InstrumentTask

java.lang.Object
    extended by org.apache.tools.ant.ProjectComponent
        extended by org.apache.tools.ant.Task
            extended by org.hibernate.tool.instrument.BasicInstrumentationTask
                extended by org.hibernate.tool.instrument.cglib.InstrumentTask
public class InstrumentTask
extends BasicInstrumentationTask

An Ant task for instrumenting persistent classes in order to enable field-level interception using CGLIB.

In order to use this task, typically you would define a a taskdef similiar to:
where lib.class.path is an ANT path reference containing all the required Hibernate and CGLIB libraries.

And then use it like:

         ...
where the nested ANT fileset includes the class you would like to have instrumented.

Optionally you can chose to enable "Extended Instrumentation" if desired by specifying the extended attriubute on the task:

     ...
See the Hibernate manual regarding this option.

Author:
Gavin King, Steve Ebersole

Nested Class Summary
Nested classes inherited from class org.hibernate.tool.instrument.BasicInstrumentationTask
BasicInstrumentationTask.CustomFieldFilter, BasicInstrumentationTask.Logger
Field Summary
Fields inherited from class org.hibernate.tool.instrument.BasicInstrumentationTask
logger
Fields inherited from class org.apache.tools.ant.Task
description, location, target, taskName, taskType, wrapper
Fields inherited from class org.apache.tools.ant.ProjectComponent
project
Constructor Summary
InstrumentTask()
Method Summary
protected ClassDescriptor | getClassDescriptor(byte[] byecode)
protected ClassTransformer | getClassTransformer(ClassDescriptor descriptor)
Methods inherited from class org.hibernate.tool.instrument.BasicInstrumentationTask
addFileset, checkMagic, execute, filesets, isBeingIntrumented, isClassFile, isExtended, isJarFile, isVerbose, processClassFile, processFile, processJarFile, setExtended, setVerbose
Methods inherited from class org.apache.tools.ant.Task
getDescription, getLocation, getOwningTarget, getRuntimeConfigurableWrapper, getTaskName, getTaskType, getWrapper, handleErrorFlush, handleErrorOutput, handleFlush, handleInput, handleOutput, init, isInvalid, log, log, maybeConfigure, perform, reconfigure, setDescription, setLocation, setOwningTarget, setRuntimeConfigurableWrapper, setTaskName, setTaskType
Methods inherited from class org.apache.tools.ant.ProjectComponent
getProject, setProject
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InstrumentTask

public InstrumentTask()
Method Detail

getClassDescriptor

protected ClassDescriptor getClassDescriptor(byte[] byecode)
                                      throws Exception
Specified by:
getClassDescriptor in class BasicInstrumentationTask
Throws:
Exception

getClassTransformer

protected ClassTransformer getClassTransformer(ClassDescriptor descriptor)
Specified by:
getClassTransformer in class BasicInstrumentationTask
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.tool.instrument.javassist (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.tool.instrument.javassist

Class Summary
InstrumentTask An Ant task for instrumenting persistent classes in order to enable field-level interception using Javassist.


org.hibernate.tool.instrument.javassist Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.tool.instrument.javassist

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.apache.tools.ant.ProjectComponent
      • class org.apache.tools.ant.Task
        • class org.hibernate.tool.instrument.BasicInstrumentationTask
          • class org.hibernate.tool.instrument.javassist.InstrumentTask


Uses of Package org.hibernate.tool.instrument.javassist (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.tool.instrument.javassist

No usage of org.hibernate.tool.instrument.javassist

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


InstrumentTask (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tool.instrument.javassist
Class InstrumentTask

java.lang.Object
    extended by org.apache.tools.ant.ProjectComponent
        extended by org.apache.tools.ant.Task
            extended by org.hibernate.tool.instrument.BasicInstrumentationTask
                extended by org.hibernate.tool.instrument.javassist.InstrumentTask
public class InstrumentTask
extends BasicInstrumentationTask

An Ant task for instrumenting persistent classes in order to enable field-level interception using Javassist.

In order to use this task, typically you would define a a taskdef similiar to:
where lib.class.path is an ANT path reference containing all the required Hibernate and Javassist libraries.

And then use it like:

         ...
where the nested ANT fileset includes the class you would like to have instrumented.

Optionally you can chose to enable "Extended Instrumentation" if desired by specifying the extended attriubute on the task:

     ...
See the Hibernate manual regarding this option.

Author:
Muga Nishizawa, Steve Ebersole

Nested Class Summary
Nested classes inherited from class org.hibernate.tool.instrument.BasicInstrumentationTask
BasicInstrumentationTask.CustomFieldFilter, BasicInstrumentationTask.Logger
Field Summary
Fields inherited from class org.hibernate.tool.instrument.BasicInstrumentationTask
logger
Fields inherited from class org.apache.tools.ant.Task
description, location, target, taskName, taskType, wrapper
Fields inherited from class org.apache.tools.ant.ProjectComponent
project
Constructor Summary
InstrumentTask()
Method Summary
protected ClassDescriptor | getClassDescriptor(byte[] bytecode)
protected ClassTransformer | getClassTransformer(ClassDescriptor descriptor)
Methods inherited from class org.hibernate.tool.instrument.BasicInstrumentationTask
addFileset, checkMagic, execute, filesets, isBeingIntrumented, isClassFile, isExtended, isJarFile, isVerbose, processClassFile, processFile, processJarFile, setExtended, setVerbose
Methods inherited from class org.apache.tools.ant.Task
getDescription, getLocation, getOwningTarget, getRuntimeConfigurableWrapper, getTaskName, getTaskType, getWrapper, handleErrorFlush, handleErrorOutput, handleFlush, handleInput, handleOutput, init, isInvalid, log, log, maybeConfigure, perform, reconfigure, setDescription, setLocation, setOwningTarget, setRuntimeConfigurableWrapper, setTaskName, setTaskType
Methods inherited from class org.apache.tools.ant.ProjectComponent
getProject, setProject
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InstrumentTask

public InstrumentTask()
Method Detail

getClassDescriptor

protected ClassDescriptor getClassDescriptor(byte[] bytecode)
                                      throws IOException
Specified by:
getClassDescriptor in class BasicInstrumentationTask
Throws:
IOException

getClassTransformer

protected ClassTransformer getClassTransformer(ClassDescriptor descriptor)
Specified by:
getClassTransformer in class BasicInstrumentationTask
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.transaction (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.transaction

This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.

See:
Description

Interface Summary
TransactionFactory | An abstract factory for Transaction instances.
TransactionFactory.Context |
TransactionManagerLookup | Concrete implementations locate and return the JTA TransactionManager.

Class Summary
BESTransactionManagerLookup | A TransactionManager lookup strategy for Borland ES.
CacheSynchronization |
CMTTransaction | Implements a basic transaction strategy for CMT transactions.
CMTTransactionFactory | Factory for CMTTransaction.
JBossTransactionManagerLookup | A TransactionManager lookup strategy for JBoss
JDBCTransaction | Implements a basic transaction strategy for JDBC connections.This is the default Transaction implementation used if none is explicitly specified.
JDBCTransactionFactory | Factory for JDBCTransaction.
JNDITransactionManagerLookup | Locates a TransactionManager in JNDI.
JOnASTransactionManagerLookup | TransactionManager lookup strategy for JOnAS
JOTMTransactionManagerLookup | TransactionManager lookup strategy for JOTM
JRun4TransactionManagerLookup | TransactionManager lookup strategy for JRun4
JTATransaction | Implements a basic transaction strategy for JTA transactions.
JTATransactionFactory | Factory for JTATransaction.
OC4JTransactionManagerLookup | TransactionManagerLookup for the OC4J (Oracle) app-server.
OrionTransactionManagerLookup | TransactionManager lookup strategy for Orion
ResinTransactionManagerLookup | TransactionManager lookup strategy for Resin
SunONETransactionManagerLookup | TransactionManager lookup strategy for Sun ONE Application Server 7
TransactionFactoryFactory |
TransactionManagerLookupFactory |
WeblogicTransactionManagerLookup | TransactionManager lookup strategy for WebLogic
WebSphereExtendedJTATransactionLookup | Support for proprietary interfaces for registering synchronizations in WebSphere 6.
WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter |
WebSphereTransactionManagerLookup | TransactionManager lookup strategy for WebSphere (versions 4, 5.0 and 5.1)

Package org.hibernate.transaction Description

This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.


org.hibernate.transaction Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.transaction

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.transaction.CacheSynchronization (implements javax.transaction.Synchronization)
    • class org.hibernate.transaction.CMTTransaction (implements org.hibernate.Transaction)
    • class org.hibernate.transaction.CMTTransactionFactory (implements org.hibernate.transaction.TransactionFactory)
    • class org.hibernate.transaction.JDBCTransaction (implements org.hibernate.Transaction)
    • class org.hibernate.transaction.JDBCTransactionFactory (implements org.hibernate.transaction.TransactionFactory)
    • class org.hibernate.transaction.JNDITransactionManagerLookup (implements org.hibernate.transaction.TransactionManagerLookup)
      • class org.hibernate.transaction.BESTransactionManagerLookup
      • class org.hibernate.transaction.JBossTransactionManagerLookup
      • class org.hibernate.transaction.JRun4TransactionManagerLookup
      • class org.hibernate.transaction.OC4JTransactionManagerLookup
      • class org.hibernate.transaction.OrionTransactionManagerLookup
      • class org.hibernate.transaction.ResinTransactionManagerLookup
      • class org.hibernate.transaction.SunONETransactionManagerLookup
      • class org.hibernate.transaction.WeblogicTransactionManagerLookup
    • class org.hibernate.transaction.JOnASTransactionManagerLookup (implements org.hibernate.transaction.TransactionManagerLookup)
    • class org.hibernate.transaction.JOTMTransactionManagerLookup (implements org.hibernate.transaction.TransactionManagerLookup)
    • class org.hibernate.transaction.JTATransaction (implements org.hibernate.Transaction)
    • class org.hibernate.transaction.JTATransactionFactory (implements org.hibernate.transaction.TransactionFactory)
    • class org.hibernate.transaction.TransactionFactoryFactory
    • class org.hibernate.transaction.TransactionManagerLookupFactory
    • class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup (implements org.hibernate.transaction.TransactionManagerLookup)
    • class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter (implements javax.transaction.TransactionManager)
    • class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter (implements javax.transaction.Transaction)
    • class org.hibernate.transaction.WebSphereTransactionManagerLookup (implements org.hibernate.transaction.TransactionManagerLookup)

Interface Hierarchy

  • interface org.hibernate.transaction.TransactionFactory
  • interface org.hibernate.transaction.TransactionFactory.Context
  • interface org.hibernate.transaction.TransactionManagerLookup


Uses of Package org.hibernate.transaction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.transaction

Packages that use org.hibernate.transaction
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.

Classes in org.hibernate.transaction used by org.hibernate.cfg
TransactionFactory
An abstract factory for Transaction instances.
TransactionManagerLookup
Concrete implementations locate and return the JTA TransactionManager.

Classes in org.hibernate.transaction used by org.hibernate.impl
TransactionFactory
An abstract factory for Transaction instances.
TransactionFactory.Context

Classes in org.hibernate.transaction used by org.hibernate.jdbc
TransactionFactory.Context

Classes in org.hibernate.transaction used by org.hibernate.transaction
JNDITransactionManagerLookup
Locates a TransactionManager in JNDI.
TransactionFactory
An abstract factory for Transaction instances.
TransactionFactory.Context
TransactionManagerLookup
Concrete implementations locate and return the JTA TransactionManager.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


TransactionFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Interface TransactionFactory

All Known Implementing Classes:
CMTTransactionFactory, JDBCTransactionFactory, JTATransactionFactory
public interface TransactionFactory

An abstract factory for Transaction instances. Concrete implementations are specified by hibernate.transaction.factory_class.

Implementors must be threadsafe and should declare a public default constructor.

Author:
Anton van Straaten, Gavin King
See Also:
Transaction

Nested Class Summary
static interface TransactionFactory.Context
Method Summary
boolean | areCallbacksLocalToHibernateTransactions() Are all transaction callbacks local to Hibernate Transactions? Or can the callbacks originate from some other source (e.g.
void | configure(Properties props) Configure from the given properties.
Transaction | createTransaction(JDBCContext jdbcContext, TransactionFactory.Context context) Begin a transaction and return the associated Transaction instance.
ConnectionReleaseMode | getDefaultReleaseMode() Get the default connection release mode
boolean | isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction) Determine whether an underlying transaction is in progress.
boolean | isTransactionManagerRequired() Do we require access to the JTA TransactionManager for this strategy?

Method Detail

createTransaction

public Transaction createTransaction(JDBCContext jdbcContext,
                                     TransactionFactory.Context context)
                              throws HibernateException
Begin a transaction and return the associated Transaction instance.

Parameters:
jdbcContext - The jdbc context to which the transaction belongs
context - The contract regarding the context in which this transaction will operate.
Returns:
Transaction
Throws:
HibernateException

configure

public void configure(Properties props)
               throws HibernateException
Configure from the given properties.

Parameters:
props -
Throws:
HibernateException

getDefaultReleaseMode

public ConnectionReleaseMode getDefaultReleaseMode()
Get the default connection release mode

isTransactionManagerRequired

public boolean isTransactionManagerRequired()
Do we require access to the JTA TransactionManager for this strategy?

areCallbacksLocalToHibernateTransactions

public boolean areCallbacksLocalToHibernateTransactions()
Are all transaction callbacks local to Hibernate Transactions? Or can the callbacks originate from some other source (e.g. a JTA Synchronization).

Returns:
true if callbacks only ever originate from the Hibernate Transaction; false otherwise.

isTransactionInProgress

public boolean isTransactionInProgress(JDBCContext jdbcContext,
                                       TransactionFactory.Context transactionContext,
                                       Transaction transaction)
Determine whether an underlying transaction is in progress.

Mainly this is used in determining whether to register a synchronization as well as whether or not to circumvent auto flushing outside transactions.

Parameters:
jdbcContext -
transactionContext -
transaction -
Returns:
true if an underlying transaction is know to be in effect.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


TransactionFactory.Context (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Interface TransactionFactory.Context

All Known Subinterfaces:
JDBCContext.Context
All Known Implementing Classes:
SessionImpl, StatelessSessionImpl
Enclosing interface:
TransactionFactory
public static interface TransactionFactory.Context

Method Summary
SessionFactoryImplementor | getFactory()
boolean | isClosed()
boolean | isFlushBeforeCompletionEnabled()
boolean | isFlushModeNever()
void | managedClose()
void | managedFlush()
boolean | shouldAutoClose()

Method Detail

getFactory

public SessionFactoryImplementor getFactory()

isClosed

public boolean isClosed()

isFlushModeNever

public boolean isFlushModeNever()

isFlushBeforeCompletionEnabled

public boolean isFlushBeforeCompletionEnabled()

managedFlush

public void managedFlush()

shouldAutoClose

public boolean shouldAutoClose()

managedClose

public void managedClose()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Interface TransactionManagerLookup

All Known Implementing Classes:
JNDITransactionManagerLookup, JOnASTransactionManagerLookup, JOTMTransactionManagerLookup, WebSphereExtendedJTATransactionLookup, WebSphereTransactionManagerLookup
public interface TransactionManagerLookup

Concrete implementations locate and return the JTA TransactionManager.

Author:
Gavin King

Method Summary
TransactionManager | getTransactionManager(Properties props) Obtain the JTA TransactionManager
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).

Method Detail

getTransactionManager

public TransactionManager getTransactionManager(Properties props)
                                         throws HibernateException
Obtain the JTA TransactionManager

Throws:
HibernateException

getUserTransactionName

public String getUserTransactionName()
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BESTransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class BESTransactionManagerLookup

java.lang.Object
    extended by org.hibernate.transaction.JNDITransactionManagerLookup
        extended by org.hibernate.transaction.BESTransactionManagerLookup
All Implemented Interfaces:
TransactionManagerLookup
public final class BESTransactionManagerLookup
extends JNDITransactionManagerLookup

A TransactionManager lookup strategy for Borland ES.

Author:
Etienne Hardy

Constructor Summary
BESTransactionManagerLookup()
Method Summary
protected String | getName()
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).
Methods inherited from class org.hibernate.transaction.JNDITransactionManagerLookup
getTransactionManager
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BESTransactionManagerLookup

public BESTransactionManagerLookup()
Method Detail

getName

protected String getName()
Specified by:
getName in class JNDITransactionManagerLookup

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CacheSynchronization (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class CacheSynchronization

java.lang.Object
    extended by org.hibernate.transaction.CacheSynchronization
All Implemented Interfaces:
Synchronization
public final class CacheSynchronization
extends Object
implements Synchronization

Author:
Gavin King

Constructor Summary
CacheSynchronization(TransactionFactory.Context ctx, JDBCContext jdbcContext, Transaction transaction, Transaction tx)
Method Summary
void | afterCompletion(int status)
void | beforeCompletion()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

CacheSynchronization

public CacheSynchronization(TransactionFactory.Context ctx,
                            JDBCContext jdbcContext,
                            Transaction transaction,
                            Transaction tx)
Method Detail

beforeCompletion

public void beforeCompletion()
Specified by:
beforeCompletion in interface Synchronization

afterCompletion

public void afterCompletion(int status)
Specified by:
afterCompletion in interface Synchronization

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CMTTransaction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class CMTTransaction

java.lang.Object
    extended by org.hibernate.transaction.CMTTransaction
All Implemented Interfaces:
Transaction
public class CMTTransaction
extends Object
implements Transaction

Implements a basic transaction strategy for CMT transactions. All work is done in the context of the container managed transaction.

Author:
Gavin King

Field Summary
protected JDBCContext | jdbcContext
protected TransactionFactory.Context | transactionContext
Constructor Summary
CMTTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
Method Summary
void | begin() Begin a new transaction.
void | commit() Flush the associated Session and end the unit of work (unless we are in FlushMode#NEVER.
Transaction | getTransaction()
boolean | isActive() Is this transaction still active? Again, this only returns information in relation to the local transaction, not the actual underlying transaction.
void | registerSynchronization(Synchronization sync) Register a user synchronization callback for this transaction.
void | rollback() Force the underlying transaction to roll back.
void | setTimeout(int seconds) Set the transaction timeout for any transaction started by a subsequent call to begin() on this instance.
boolean | wasCommitted() Check if this transaction was successfully committed.
boolean | wasRolledBack() Was this transaction rolled back or set to rollback only? This only accounts for actions initiated from this local transaction.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

jdbcContext

protected final JDBCContext jdbcContext

transactionContext

protected final TransactionFactory.Context transactionContext
Constructor Detail

CMTTransaction

public CMTTransaction(JDBCContext jdbcContext,
                      TransactionFactory.Context transactionContext)
Method Detail

begin

public void begin()
           throws HibernateException
Description copied from interface: Transaction
Begin a new transaction.

Specified by:
begin in interface Transaction
Throws:
HibernateException

commit

public void commit()
            throws HibernateException
Description copied from interface: Transaction
Flush the associated Session and end the unit of work (unless we are in FlushMode.NEVER.

This method will commit the underlying transaction if and only if the underlying transaction was initiated by this object.

Specified by:
commit in interface Transaction
Throws:
HibernateException

rollback

public void rollback()
              throws HibernateException
Description copied from interface: Transaction
Force the underlying transaction to roll back.

Specified by:
rollback in interface Transaction
Throws:
HibernateException

getTransaction

public Transaction getTransaction()
                           throws SystemException
Throws:
SystemException

isActive

public boolean isActive()
                 throws TransactionException
Description copied from interface: Transaction
Is this transaction still active?

Again, this only returns information in relation to the local transaction, not the actual underlying transaction.

Specified by:
isActive in interface Transaction
Returns:
boolean Treu if this local transaction is still active.
Throws:
TransactionException

wasRolledBack

public boolean wasRolledBack()
                      throws TransactionException
Description copied from interface: Transaction
Was this transaction rolled back or set to rollback only?

This only accounts for actions initiated from this local transaction. If, for example, the underlying transaction is forced to rollback via some other means, this method still reports false because the rollback was not initiated from here.

Specified by:
wasRolledBack in interface Transaction
Returns:
boolean True if the transaction was rolled back via this local transaction; false otherwise.
Throws:
TransactionException

wasCommitted

public boolean wasCommitted()
                     throws TransactionException
Description copied from interface: Transaction
Check if this transaction was successfully committed.

This method could return false even after successful invocation of Transaction.commit(). As an example, JTA based strategies no-op on Transaction.commit() calls if they did not start the transaction; in that case, they also report Transaction.wasCommitted() as false.

Specified by:
wasCommitted in interface Transaction
Returns:
boolean True if the transaction was (unequivocally) committed via this local transaction; false otherwise.
Throws:
TransactionException

registerSynchronization

public void registerSynchronization(Synchronization sync)
                             throws HibernateException
Description copied from interface: Transaction
Register a user synchronization callback for this transaction.

Specified by:
registerSynchronization in interface Transaction
Parameters:
sync - The Synchronization callback to register.
Throws:
HibernateException

setTimeout

public void setTimeout(int seconds)
Description copied from interface: Transaction
Set the transaction timeout for any transaction started by a subsequent call to begin() on this instance.

Specified by:
setTimeout in interface Transaction
Parameters:
seconds - The number of seconds before a timeout.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CMTTransactionFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class CMTTransactionFactory

java.lang.Object
    extended by org.hibernate.transaction.CMTTransactionFactory
All Implemented Interfaces:
TransactionFactory
public class CMTTransactionFactory
extends Object
implements TransactionFactory

Factory for CMTTransaction.

Author:
Gavin King
See Also:
CMTTransaction

Nested Class Summary
Nested classes inherited from class org.hibernate.transaction.TransactionFactory
TransactionFactory.Context
Constructor Summary
CMTTransactionFactory()
Method Summary
boolean | areCallbacksLocalToHibernateTransactions() Are all transaction callbacks local to Hibernate Transactions? Or can the callbacks originate from some other source (e.g.
void | configure(Properties props) Configure from the given properties.
Transaction | createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext) Begin a transaction and return the associated Transaction instance.
ConnectionReleaseMode | getDefaultReleaseMode() Get the default connection release mode
boolean | isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction) Determine whether an underlying transaction is in progress.
boolean | isTransactionManagerRequired() Do we require access to the JTA TransactionManager for this strategy?
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CMTTransactionFactory

public CMTTransactionFactory()
Method Detail

getDefaultReleaseMode

public ConnectionReleaseMode getDefaultReleaseMode()
Description copied from interface: TransactionFactory
Get the default connection release mode

Specified by:
getDefaultReleaseMode in interface TransactionFactory

configure

public void configure(Properties props)
               throws HibernateException
Description copied from interface: TransactionFactory
Configure from the given properties.

Specified by:
configure in interface TransactionFactory
Parameters:
props -
Throws:
HibernateException

createTransaction

public Transaction createTransaction(JDBCContext jdbcContext,
                                     TransactionFactory.Context transactionContext)
                              throws HibernateException
Description copied from interface: TransactionFactory
Begin a transaction and return the associated Transaction instance.

Specified by:
createTransaction in interface TransactionFactory
Parameters:
jdbcContext - The jdbc context to which the transaction belongs
transactionContext - The contract regarding the context in which this transaction will operate.
Returns:
Transaction
Throws:
HibernateException

isTransactionManagerRequired

public boolean isTransactionManagerRequired()
Description copied from interface: TransactionFactory
Do we require access to the JTA TransactionManager for this strategy?

Specified by:
isTransactionManagerRequired in interface TransactionFactory

areCallbacksLocalToHibernateTransactions

public boolean areCallbacksLocalToHibernateTransactions()
Description copied from interface: TransactionFactory
Are all transaction callbacks local to Hibernate Transactions? Or can the callbacks originate from some other source (e.g. a JTA Synchronization).

Specified by:
areCallbacksLocalToHibernateTransactions in interface TransactionFactory
Returns:
true if callbacks only ever originate from the Hibernate Transaction; false otherwise.

isTransactionInProgress

public boolean isTransactionInProgress(JDBCContext jdbcContext,
                                       TransactionFactory.Context transactionContext,
                                       Transaction transaction)
Description copied from interface: TransactionFactory
Determine whether an underlying transaction is in progress.

Mainly this is used in determining whether to register a synchronization as well as whether or not to circumvent auto flushing outside transactions.

Specified by:
isTransactionInProgress in interface TransactionFactory
Parameters:
jdbcContext -
transactionContext -
transaction -
Returns:
true if an underlying transaction is know to be in effect.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JBossTransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class JBossTransactionManagerLookup

java.lang.Object
    extended by org.hibernate.transaction.JNDITransactionManagerLookup
        extended by org.hibernate.transaction.JBossTransactionManagerLookup
All Implemented Interfaces:
TransactionManagerLookup
public final class JBossTransactionManagerLookup
extends JNDITransactionManagerLookup

A TransactionManager lookup strategy for JBoss

Author:
Gavin King

Constructor Summary
JBossTransactionManagerLookup()
Method Summary
protected String | getName()
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).
Methods inherited from class org.hibernate.transaction.JNDITransactionManagerLookup
getTransactionManager
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JBossTransactionManagerLookup

public JBossTransactionManagerLookup()
Method Detail

getName

protected String getName()
Specified by:
getName in class JNDITransactionManagerLookup

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JDBCTransaction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class JDBCTransaction

java.lang.Object
    extended by org.hibernate.transaction.JDBCTransaction
All Implemented Interfaces:
Transaction
public class JDBCTransaction
extends Object
implements Transaction

Implements a basic transaction strategy for JDBC connections.This is the default Transaction implementation used if none is explicitly specified.

Author:
Anton van Straaten, Gavin King

Constructor Summary
JDBCTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
Method Summary
void | begin() Begin a new transaction.
void | commit() Flush the associated Session and end the unit of work (unless we are in FlushMode#NEVER.
boolean | isActive() Is this transaction still active? Again, this only returns information in relation to the local transaction, not the actual underlying transaction.
void | registerSynchronization(Synchronization sync) Register a user synchronization callback for this transaction.
void | rollback() Force the underlying transaction to roll back.
void | setTimeout(int seconds) Set the transaction timeout for any transaction started by a subsequent call to begin() on this instance.
boolean | wasCommitted() Check if this transaction was successfully committed.
boolean | wasRolledBack() Was this transaction rolled back or set to rollback only? This only accounts for actions initiated from this local transaction.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JDBCTransaction

public JDBCTransaction(JDBCContext jdbcContext,
                       TransactionFactory.Context transactionContext)
Method Detail

begin

public void begin()
           throws HibernateException
Description copied from interface: Transaction
Begin a new transaction.

Specified by:
begin in interface Transaction
Throws:
HibernateException

commit

public void commit()
            throws HibernateException
Description copied from interface: Transaction
Flush the associated Session and end the unit of work (unless we are in FlushMode.NEVER.

This method will commit the underlying transaction if and only if the underlying transaction was initiated by this object.

Specified by:
commit in interface Transaction
Throws:
HibernateException

rollback

public void rollback()
              throws HibernateException
Description copied from interface: Transaction
Force the underlying transaction to roll back.

Specified by:
rollback in interface Transaction
Throws:
HibernateException

wasRolledBack

public boolean wasRolledBack()
Description copied from interface: Transaction
Was this transaction rolled back or set to rollback only?

This only accounts for actions initiated from this local transaction. If, for example, the underlying transaction is forced to rollback via some other means, this method still reports false because the rollback was not initiated from here.

Specified by:
wasRolledBack in interface Transaction
Returns:
boolean True if the transaction was rolled back via this local transaction; false otherwise.

wasCommitted

public boolean wasCommitted()
Description copied from interface: Transaction
Check if this transaction was successfully committed.

This method could return false even after successful invocation of Transaction.commit(). As an example, JTA based strategies no-op on Transaction.commit() calls if they did not start the transaction; in that case, they also report Transaction.wasCommitted() as false.

Specified by:
wasCommitted in interface Transaction
Returns:
boolean True if the transaction was (unequivocally) committed via this local transaction; false otherwise.

isActive

public boolean isActive()
Description copied from interface: Transaction
Is this transaction still active?

Again, this only returns information in relation to the local transaction, not the actual underlying transaction.

Specified by:
isActive in interface Transaction
Returns:
boolean Treu if this local transaction is still active.

registerSynchronization

public void registerSynchronization(Synchronization sync)
                             throws HibernateException
Description copied from interface: Transaction
Register a user synchronization callback for this transaction.

Specified by:
registerSynchronization in interface Transaction
Parameters:
sync - The Synchronization callback to register.
Throws:
HibernateException

setTimeout

public void setTimeout(int seconds)
Description copied from interface: Transaction
Set the transaction timeout for any transaction started by a subsequent call to begin() on this instance.

Specified by:
setTimeout in interface Transaction
Parameters:
seconds - The number of seconds before a timeout.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JDBCTransactionFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class JDBCTransactionFactory

java.lang.Object
    extended by org.hibernate.transaction.JDBCTransactionFactory
All Implemented Interfaces:
TransactionFactory
public final class JDBCTransactionFactory
extends Object
implements TransactionFactory

Factory for JDBCTransaction.

Author:
Anton van Straaten
See Also:
JDBCTransaction

Nested Class Summary
Nested classes inherited from class org.hibernate.transaction.TransactionFactory
TransactionFactory.Context
Constructor Summary
JDBCTransactionFactory()
Method Summary
boolean | areCallbacksLocalToHibernateTransactions() Are all transaction callbacks local to Hibernate Transactions? Or can the callbacks originate from some other source (e.g.
void | configure(Properties props) Configure from the given properties.
Transaction | createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext) Begin a transaction and return the associated Transaction instance.
ConnectionReleaseMode | getDefaultReleaseMode() Get the default connection release mode
boolean | isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction) Determine whether an underlying transaction is in progress.
boolean | isTransactionManagerRequired() Do we require access to the JTA TransactionManager for this strategy?
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JDBCTransactionFactory

public JDBCTransactionFactory()
Method Detail

getDefaultReleaseMode

public ConnectionReleaseMode getDefaultReleaseMode()
Description copied from interface: TransactionFactory
Get the default connection release mode

Specified by:
getDefaultReleaseMode in interface TransactionFactory

createTransaction

public Transaction createTransaction(JDBCContext jdbcContext,
                                     TransactionFactory.Context transactionContext)
                              throws HibernateException
Description copied from interface: TransactionFactory
Begin a transaction and return the associated Transaction instance.

Specified by:
createTransaction in interface TransactionFactory
Parameters:
jdbcContext - The jdbc context to which the transaction belongs
transactionContext - The contract regarding the context in which this transaction will operate.
Returns:
Transaction
Throws:
HibernateException

configure

public void configure(Properties props)
               throws HibernateException
Description copied from interface: TransactionFactory
Configure from the given properties.

Specified by:
configure in interface TransactionFactory
Parameters:
props -
Throws:
HibernateException

isTransactionManagerRequired

public boolean isTransactionManagerRequired()
Description copied from interface: TransactionFactory
Do we require access to the JTA TransactionManager for this strategy?

Specified by:
isTransactionManagerRequired in interface TransactionFactory

areCallbacksLocalToHibernateTransactions

public boolean areCallbacksLocalToHibernateTransactions()
Description copied from interface: TransactionFactory
Are all transaction callbacks local to Hibernate Transactions? Or can the callbacks originate from some other source (e.g. a JTA Synchronization).

Specified by:
areCallbacksLocalToHibernateTransactions in interface TransactionFactory
Returns:
true if callbacks only ever originate from the Hibernate Transaction; false otherwise.

isTransactionInProgress

public boolean isTransactionInProgress(JDBCContext jdbcContext,
                                       TransactionFactory.Context transactionContext,
                                       Transaction transaction)
Description copied from interface: TransactionFactory
Determine whether an underlying transaction is in progress.

Mainly this is used in determining whether to register a synchronization as well as whether or not to circumvent auto flushing outside transactions.

Specified by:
isTransactionInProgress in interface TransactionFactory
Parameters:
jdbcContext -
transactionContext -
transaction -
Returns:
true if an underlying transaction is know to be in effect.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JNDITransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class JNDITransactionManagerLookup

java.lang.Object
    extended by org.hibernate.transaction.JNDITransactionManagerLookup
All Implemented Interfaces:
TransactionManagerLookup
Direct Known Subclasses:
BESTransactionManagerLookup, JBossTransactionManagerLookup, JRun4TransactionManagerLookup, OC4JTransactionManagerLookup, OrionTransactionManagerLookup, ResinTransactionManagerLookup, SunONETransactionManagerLookup, WeblogicTransactionManagerLookup
public abstract class JNDITransactionManagerLookup
extends Object
implements TransactionManagerLookup

Locates a TransactionManager in JNDI.

Author:
Gavin King

Constructor Summary
JNDITransactionManagerLookup()
Method Summary
protected abstract String | getName()
TransactionManager | getTransactionManager(Properties props) Obtain the JTA TransactionManager
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.transaction.TransactionManagerLookup
getUserTransactionName

Constructor Detail

JNDITransactionManagerLookup

public JNDITransactionManagerLookup()
Method Detail

getTransactionManager

public TransactionManager getTransactionManager(Properties props)
                                         throws HibernateException
Description copied from interface: TransactionManagerLookup
Obtain the JTA TransactionManager

Specified by:
getTransactionManager in interface TransactionManagerLookup
Throws:
HibernateException
See Also:
TransactionManagerLookup.getTransactionManager(java.util.Properties)

getName

protected abstract String getName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JOnASTransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class JOnASTransactionManagerLookup

java.lang.Object
    extended by org.hibernate.transaction.JOnASTransactionManagerLookup
All Implemented Interfaces:
TransactionManagerLookup
public class JOnASTransactionManagerLookup
extends Object
implements TransactionManagerLookup

TransactionManager lookup strategy for JOnAS

Author:
?

Constructor Summary
JOnASTransactionManagerLookup()
Method Summary
TransactionManager | getTransactionManager(Properties props) Obtain the JTA TransactionManager
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JOnASTransactionManagerLookup

public JOnASTransactionManagerLookup()
Method Detail

getTransactionManager

public TransactionManager getTransactionManager(Properties props)
                                         throws HibernateException
Description copied from interface: TransactionManagerLookup
Obtain the JTA TransactionManager

Specified by:
getTransactionManager in interface TransactionManagerLookup
Throws:
HibernateException
See Also:
TransactionManagerLookup.getTransactionManager(Properties)

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Specified by:
getUserTransactionName in interface TransactionManagerLookup
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JOTMTransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class JOTMTransactionManagerLookup

java.lang.Object
    extended by org.hibernate.transaction.JOTMTransactionManagerLookup
All Implemented Interfaces:
TransactionManagerLookup
public class JOTMTransactionManagerLookup
extends Object
implements TransactionManagerLookup

TransactionManager lookup strategy for JOTM

Author:
Low Heng Sin

Constructor Summary
JOTMTransactionManagerLookup()
Method Summary
TransactionManager | getTransactionManager(Properties props) Obtain the JTA TransactionManager
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JOTMTransactionManagerLookup

public JOTMTransactionManagerLookup()
Method Detail

getTransactionManager

public TransactionManager getTransactionManager(Properties props)
                                         throws HibernateException
Description copied from interface: TransactionManagerLookup
Obtain the JTA TransactionManager

Specified by:
getTransactionManager in interface TransactionManagerLookup
Throws:
HibernateException
See Also:
TransactionManagerLookup.getTransactionManager(Properties)

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Specified by:
getUserTransactionName in interface TransactionManagerLookup
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JRun4TransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class JRun4TransactionManagerLookup

java.lang.Object
    extended by org.hibernate.transaction.JNDITransactionManagerLookup
        extended by org.hibernate.transaction.JRun4TransactionManagerLookup
All Implemented Interfaces:
TransactionManagerLookup
public class JRun4TransactionManagerLookup
extends JNDITransactionManagerLookup

TransactionManager lookup strategy for JRun4

Author:
Joseph Bissen

Constructor Summary
JRun4TransactionManagerLookup()
Method Summary
protected String | getName()
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).
Methods inherited from class org.hibernate.transaction.JNDITransactionManagerLookup
getTransactionManager
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JRun4TransactionManagerLookup

public JRun4TransactionManagerLookup()
Method Detail

getName

protected String getName()
Specified by:
getName in class JNDITransactionManagerLookup

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JTATransaction (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class JTATransaction

java.lang.Object
    extended by org.hibernate.transaction.JTATransaction
All Implemented Interfaces:
Transaction
public class JTATransaction
extends Object
implements Transaction

Implements a basic transaction strategy for JTA transactions. Instances check to see if there is an existing JTA transaction. If none exists, a new transaction is started. If one exists, all work is done in the existing context. The following properties are used to locate the underlying UserTransaction:

hibernate.jndi.url | JNDI initial context URL
hibernate.jndi.class | JNDI provider class
jta.UserTransaction | JNDI name

Author:
Gavin King

Constructor Summary
JTATransaction(InitialContext context, String utName, JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
Method Summary
void | begin() Begin a new transaction.
void | commit() Flush the associated Session and end the unit of work (unless we are in FlushMode#NEVER.
protected UserTransaction | getUserTransaction()
boolean | isActive() Is this transaction still active? Again, this only returns information in relation to the local transaction, not the actual underlying transaction.
void | registerSynchronization(Synchronization sync) Register a user synchronization callback for this transaction.
void | rollback() Force the underlying transaction to roll back.
void | setTimeout(int seconds) Set the transaction timeout for any transaction started by a subsequent call to begin() on this instance.
boolean | wasCommitted() Check if this transaction was successfully committed.
boolean | wasRolledBack() Was this transaction rolled back or set to rollback only? This only accounts for actions initiated from this local transaction.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JTATransaction

public JTATransaction(InitialContext context,
                      String utName,
                      JDBCContext jdbcContext,
                      TransactionFactory.Context transactionContext)
Method Detail

begin

public void begin()
           throws HibernateException
Description copied from interface: Transaction
Begin a new transaction.

Specified by:
begin in interface Transaction
Throws:
HibernateException

commit

public void commit()
            throws HibernateException
Description copied from interface: Transaction
Flush the associated Session and end the unit of work (unless we are in FlushMode.NEVER.

This method will commit the underlying transaction if and only if the underlying transaction was initiated by this object.

Specified by:
commit in interface Transaction
Throws:
HibernateException

rollback

public void rollback()
              throws HibernateException
Description copied from interface: Transaction
Force the underlying transaction to roll back.

Specified by:
rollback in interface Transaction
Throws:
HibernateException

wasRolledBack

public boolean wasRolledBack()
                      throws TransactionException
Description copied from interface: Transaction
Was this transaction rolled back or set to rollback only?

This only accounts for actions initiated from this local transaction. If, for example, the underlying transaction is forced to rollback via some other means, this method still reports false because the rollback was not initiated from here.

Specified by:
wasRolledBack in interface Transaction
Returns:
boolean True if the transaction was rolled back via this local transaction; false otherwise.
Throws:
TransactionException

wasCommitted

public boolean wasCommitted()
                     throws TransactionException
Description copied from interface: Transaction
Check if this transaction was successfully committed.

This method could return false even after successful invocation of Transaction.commit(). As an example, JTA based strategies no-op on Transaction.commit() calls if they did not start the transaction; in that case, they also report Transaction.wasCommitted() as false.

Specified by:
wasCommitted in interface Transaction
Returns:
boolean True if the transaction was (unequivocally) committed via this local transaction; false otherwise.
Throws:
TransactionException

isActive

public boolean isActive()
                 throws TransactionException
Description copied from interface: Transaction
Is this transaction still active?

Again, this only returns information in relation to the local transaction, not the actual underlying transaction.

Specified by:
isActive in interface Transaction
Returns:
boolean Treu if this local transaction is still active.
Throws:
TransactionException

registerSynchronization

public void registerSynchronization(Synchronization sync)
                             throws HibernateException
Description copied from interface: Transaction
Register a user synchronization callback for this transaction.

Specified by:
registerSynchronization in interface Transaction
Parameters:
sync - The Synchronization callback to register.
Throws:
HibernateException

setTimeout

public void setTimeout(int seconds)
Description copied from interface: Transaction
Set the transaction timeout for any transaction started by a subsequent call to begin() on this instance.

Specified by:
setTimeout in interface Transaction
Parameters:
seconds - The number of seconds before a timeout.

getUserTransaction

protected UserTransaction getUserTransaction()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JTATransactionFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class JTATransactionFactory

java.lang.Object
    extended by org.hibernate.transaction.JTATransactionFactory
All Implemented Interfaces:
TransactionFactory
public class JTATransactionFactory
extends Object
implements TransactionFactory

Factory for JTATransaction.

Author:
Gavin King
See Also:
JTATransaction

Nested Class Summary
Nested classes inherited from class org.hibernate.transaction.TransactionFactory
TransactionFactory.Context
Field Summary
protected InitialContext | context
protected String | utName
Constructor Summary
JTATransactionFactory()
Method Summary
boolean | areCallbacksLocalToHibernateTransactions() Are all transaction callbacks local to Hibernate Transactions? Or can the callbacks originate from some other source (e.g.
void | configure(Properties props) Configure from the given properties.
Transaction | createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext) Begin a transaction and return the associated Transaction instance.
ConnectionReleaseMode | getDefaultReleaseMode() Get the default connection release mode
boolean | isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction) Determine whether an underlying transaction is in progress.
boolean | isTransactionManagerRequired() Do we require access to the JTA TransactionManager for this strategy?
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

context

protected InitialContext context

utName

protected String utName
Constructor Detail

JTATransactionFactory

public JTATransactionFactory()
Method Detail

configure

public void configure(Properties props)
               throws HibernateException
Description copied from interface: TransactionFactory
Configure from the given properties.

Specified by:
configure in interface TransactionFactory
Parameters:
props -
Throws:
HibernateException

createTransaction

public Transaction createTransaction(JDBCContext jdbcContext,
                                     TransactionFactory.Context transactionContext)
                              throws HibernateException
Description copied from interface: TransactionFactory
Begin a transaction and return the associated Transaction instance.

Specified by:
createTransaction in interface TransactionFactory
Parameters:
jdbcContext - The jdbc context to which the transaction belongs
transactionContext - The contract regarding the context in which this transaction will operate.
Returns:
Transaction
Throws:
HibernateException

getDefaultReleaseMode

public ConnectionReleaseMode getDefaultReleaseMode()
Description copied from interface: TransactionFactory
Get the default connection release mode

Specified by:
getDefaultReleaseMode in interface TransactionFactory

isTransactionManagerRequired

public boolean isTransactionManagerRequired()
Description copied from interface: TransactionFactory
Do we require access to the JTA TransactionManager for this strategy?

Specified by:
isTransactionManagerRequired in interface TransactionFactory

areCallbacksLocalToHibernateTransactions

public boolean areCallbacksLocalToHibernateTransactions()
Description copied from interface: TransactionFactory
Are all transaction callbacks local to Hibernate Transactions? Or can the callbacks originate from some other source (e.g. a JTA Synchronization).

Specified by:
areCallbacksLocalToHibernateTransactions in interface TransactionFactory
Returns:
true if callbacks only ever originate from the Hibernate Transaction; false otherwise.

isTransactionInProgress

public boolean isTransactionInProgress(JDBCContext jdbcContext,
                                       TransactionFactory.Context transactionContext,
                                       Transaction transaction)
Description copied from interface: TransactionFactory
Determine whether an underlying transaction is in progress.

Mainly this is used in determining whether to register a synchronization as well as whether or not to circumvent auto flushing outside transactions.

Specified by:
isTransactionInProgress in interface TransactionFactory
Parameters:
jdbcContext -
transactionContext -
transaction -
Returns:
true if an underlying transaction is know to be in effect.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OC4JTransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class OC4JTransactionManagerLookup

java.lang.Object
    extended by org.hibernate.transaction.JNDITransactionManagerLookup
        extended by org.hibernate.transaction.OC4JTransactionManagerLookup
All Implemented Interfaces:
TransactionManagerLookup
public class OC4JTransactionManagerLookup
extends JNDITransactionManagerLookup

TransactionManagerLookup for the OC4J (Oracle) app-server.

Author:
Stijn Janssens

Constructor Summary
OC4JTransactionManagerLookup()
Method Summary
protected String | getName()
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).
Methods inherited from class org.hibernate.transaction.JNDITransactionManagerLookup
getTransactionManager
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OC4JTransactionManagerLookup

public OC4JTransactionManagerLookup()
Method Detail

getName

protected String getName()
Specified by:
getName in class JNDITransactionManagerLookup

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrionTransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class OrionTransactionManagerLookup

java.lang.Object
    extended by org.hibernate.transaction.JNDITransactionManagerLookup
        extended by org.hibernate.transaction.OrionTransactionManagerLookup
All Implemented Interfaces:
TransactionManagerLookup
public class OrionTransactionManagerLookup
extends JNDITransactionManagerLookup

TransactionManager lookup strategy for Orion

Author:
Gavin King

Constructor Summary
OrionTransactionManagerLookup()
Method Summary
protected String | getName()
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).
Methods inherited from class org.hibernate.transaction.JNDITransactionManagerLookup
getTransactionManager
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OrionTransactionManagerLookup

public OrionTransactionManagerLookup()
Method Detail

getName

protected String getName()
Specified by:
getName in class JNDITransactionManagerLookup
See Also:
JNDITransactionManagerLookup.getName()

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResinTransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class ResinTransactionManagerLookup

java.lang.Object
    extended by org.hibernate.transaction.JNDITransactionManagerLookup
        extended by org.hibernate.transaction.ResinTransactionManagerLookup
All Implemented Interfaces:
TransactionManagerLookup
public class ResinTransactionManagerLookup
extends JNDITransactionManagerLookup

TransactionManager lookup strategy for Resin

Author:
Aapo Laakkonen

Constructor Summary
ResinTransactionManagerLookup()
Method Summary
protected String | getName()
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).
Methods inherited from class org.hibernate.transaction.JNDITransactionManagerLookup
getTransactionManager
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResinTransactionManagerLookup

public ResinTransactionManagerLookup()
Method Detail

getName

protected String getName()
Specified by:
getName in class JNDITransactionManagerLookup
See Also:
JNDITransactionManagerLookup.getName()

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SunONETransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class SunONETransactionManagerLookup

java.lang.Object
    extended by org.hibernate.transaction.JNDITransactionManagerLookup
        extended by org.hibernate.transaction.SunONETransactionManagerLookup
All Implemented Interfaces:
TransactionManagerLookup
public class SunONETransactionManagerLookup
extends JNDITransactionManagerLookup

TransactionManager lookup strategy for Sun ONE Application Server 7

Author:
Robert Davidson, Sanjeev Krishnan, Emmanuel Bernard

Constructor Summary
SunONETransactionManagerLookup()
Method Summary
protected String | getName()
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).
Methods inherited from class org.hibernate.transaction.JNDITransactionManagerLookup
getTransactionManager
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SunONETransactionManagerLookup

public SunONETransactionManagerLookup()
Method Detail

getName

protected String getName()
Specified by:
getName in class JNDITransactionManagerLookup

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransactionFactoryFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class TransactionFactoryFactory

java.lang.Object
    extended by org.hibernate.transaction.TransactionFactoryFactory
public final class TransactionFactoryFactory
extends Object

Author:
Gavin King

Method Summary
static TransactionFactory buildTransactionFactory(Properties transactionProps)
Obtain a TransactionFactory with the transaction handling strategy specified by the given Properties.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

buildTransactionFactory

public static TransactionFactory buildTransactionFactory(Properties transactionProps)
                                                  throws HibernateException
Obtain a TransactionFactory with the transaction handling strategy specified by the given Properties.

Parameters:
transactionProps - transaction properties
Returns:
TransactionFactory
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransactionManagerLookupFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class TransactionManagerLookupFactory

java.lang.Object
    extended by org.hibernate.transaction.TransactionManagerLookupFactory
public final class TransactionManagerLookupFactory
extends Object

Author:
Gavin King

Method Summary
static TransactionManager | getTransactionManager(Properties props)
static TransactionManagerLookup | getTransactionManagerLookup(Properties props)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getTransactionManager

public static final TransactionManager getTransactionManager(Properties props)
                                                      throws HibernateException
Throws:
HibernateException

getTransactionManagerLookup

public static final TransactionManagerLookup getTransactionManagerLookup(Properties props)
                                                                  throws HibernateException
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WeblogicTransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class WeblogicTransactionManagerLookup

java.lang.Object
    extended by org.hibernate.transaction.JNDITransactionManagerLookup
        extended by org.hibernate.transaction.WeblogicTransactionManagerLookup
All Implemented Interfaces:
TransactionManagerLookup
public final class WeblogicTransactionManagerLookup
extends JNDITransactionManagerLookup

TransactionManager lookup strategy for WebLogic

Author:
Gavin King

Constructor Summary
WeblogicTransactionManagerLookup()
Method Summary
protected String | getName()
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).
Methods inherited from class org.hibernate.transaction.JNDITransactionManagerLookup
getTransactionManager
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WeblogicTransactionManagerLookup

public WeblogicTransactionManagerLookup()
Method Detail

getName

protected String getName()
Specified by:
getName in class JNDITransactionManagerLookup
See Also:
JNDITransactionManagerLookup.getName()

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WebSphereExtendedJTATransactionLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class WebSphereExtendedJTATransactionLookup

java.lang.Object
    extended by org.hibernate.transaction.WebSphereExtendedJTATransactionLookup
All Implemented Interfaces:
TransactionManagerLookup
public class WebSphereExtendedJTATransactionLookup
extends Object
implements TransactionManagerLookup

Support for proprietary interfaces for registering synchronizations in WebSphere 6.

Author:
Gavin King

Nested Class Summary
static class WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter
Constructor Summary
WebSphereExtendedJTATransactionLookup()
Method Summary
TransactionManager | getTransactionManager(Properties props) Obtain the JTA TransactionManager
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WebSphereExtendedJTATransactionLookup

public WebSphereExtendedJTATransactionLookup()
Method Detail

getTransactionManager

public TransactionManager getTransactionManager(Properties props)
                                         throws HibernateException
Description copied from interface: TransactionManagerLookup
Obtain the JTA TransactionManager

Specified by:
getTransactionManager in interface TransactionManagerLookup
Throws:
HibernateException

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Specified by:
getUserTransactionName in interface TransactionManagerLookup
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter

java.lang.Object
    extended by org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter
All Implemented Interfaces:
TransactionManager
Enclosing class:
WebSphereExtendedJTATransactionLookup
public static class WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter
extends Object
implements TransactionManager

Nested Class Summary
 class WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter
Method Summary
void | begin()
void | commit()
int | getStatus()
Transaction | getTransaction()
void | resume(Transaction txn)
void | rollback()
void | setRollbackOnly()
void | setTransactionTimeout(int i)
Transaction | suspend()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

begin

public void begin()
           throws NotSupportedException,
                  SystemException
Specified by:
begin in interface TransactionManager
Throws:
NotSupportedException
SystemException

commit

public void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
Specified by:
commit in interface TransactionManager
Throws:
RollbackException
HeuristicMixedException
HeuristicRollbackException
SecurityException
IllegalStateException
SystemException

getStatus

public int getStatus()
              throws SystemException
Specified by:
getStatus in interface TransactionManager
Throws:
SystemException

getTransaction

public Transaction getTransaction()
                           throws SystemException
Specified by:
getTransaction in interface TransactionManager
Throws:
SystemException

resume

public void resume(Transaction txn)
            throws InvalidTransactionException,
                   IllegalStateException,
                   SystemException
Specified by:
resume in interface TransactionManager
Throws:
InvalidTransactionException
IllegalStateException
SystemException

rollback

public void rollback()
              throws IllegalStateException,
                     SecurityException,
                     SystemException
Specified by:
rollback in interface TransactionManager
Throws:
IllegalStateException
SecurityException
SystemException

setRollbackOnly

public void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
Specified by:
setRollbackOnly in interface TransactionManager
Throws:
IllegalStateException
SystemException

setTransactionTimeout

public void setTransactionTimeout(int i)
                           throws SystemException
Specified by:
setTransactionTimeout in interface TransactionManager
Throws:
SystemException

suspend

public Transaction suspend()
                    throws SystemException
Specified by:
suspend in interface TransactionManager
Throws:
SystemException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WebSphereTransactionManagerLookup (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class WebSphereTransactionManagerLookup

java.lang.Object
    extended by org.hibernate.transaction.WebSphereTransactionManagerLookup
All Implemented Interfaces:
TransactionManagerLookup
public class WebSphereTransactionManagerLookup
extends Object
implements TransactionManagerLookup

TransactionManager lookup strategy for WebSphere (versions 4, 5.0 and 5.1)

Author:
Gavin King

Constructor Summary
WebSphereTransactionManagerLookup()
Method Summary
TransactionManager | getTransactionManager(Properties props) Obtain the JTA TransactionManager
String | getUserTransactionName() Return the JNDI name of the JTA UserTransaction or null (optional operation).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WebSphereTransactionManagerLookup

public WebSphereTransactionManagerLookup()
Method Detail

getTransactionManager

public TransactionManager getTransactionManager(Properties props)
                                         throws HibernateException
Description copied from interface: TransactionManagerLookup
Obtain the JTA TransactionManager

Specified by:
getTransactionManager in interface TransactionManagerLookup
Throws:
HibernateException

getUserTransactionName

public String getUserTransactionName()
Description copied from interface: TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).

Specified by:
getUserTransactionName in interface TransactionManagerLookup
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.transform (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.transform

Defines strategies for post-processing criteria query result sets into a form convenient to the application.

See:
Description

Interface Summary
ResultTransformer Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Class Summary
AliasToBeanConstructorResultTransformer |
AliasToBeanResultTransformer | Result transformer that allows to transform a result to a user specified class which will be populated via setter methods or fields matching the alias names.
AliasToEntityMapResultTransformer |
DistinctRootEntityResultTransformer |
PassThroughResultTransformer |
RootEntityResultTransformer |
ToListResultTransformer |
Transformers |

Package org.hibernate.transform Description

Defines strategies for post-processing criteria query result sets into a form convenient to the application.


org.hibernate.transform Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.transform

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.transform.AliasToBeanConstructorResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.transform.AliasToBeanResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.transform.AliasToEntityMapResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.transform.DistinctRootEntityResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.transform.PassThroughResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.transform.RootEntityResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.transform.ToListResultTransformer (implements org.hibernate.transform.ResultTransformer)
    • class org.hibernate.transform.Transformers

Interface Hierarchy

  • interface java.io.Serializable
    • interface org.hibernate.transform.ResultTransformer


Uses of Package org.hibernate.transform (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.transform

Packages that use org.hibernate.transform
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.transform | Defines strategies for post-processing criteria query result sets into a form convenient to the application.

Classes in org.hibernate.transform used by org.hibernate
ResultTransformer
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Classes in org.hibernate.transform used by org.hibernate.criterion
ResultTransformer
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Classes in org.hibernate.transform used by org.hibernate.engine
ResultTransformer
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Classes in org.hibernate.transform used by org.hibernate.hql
ResultTransformer
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Classes in org.hibernate.transform used by org.hibernate.hql.classic
ResultTransformer
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Classes in org.hibernate.transform used by org.hibernate.impl
ResultTransformer
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Classes in org.hibernate.transform used by org.hibernate.loader
ResultTransformer
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Classes in org.hibernate.transform used by org.hibernate.loader.criteria
ResultTransformer
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Classes in org.hibernate.transform used by org.hibernate.loader.custom
ResultTransformer
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Classes in org.hibernate.transform used by org.hibernate.loader.entity
ResultTransformer
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Classes in org.hibernate.transform used by org.hibernate.loader.hql
ResultTransformer
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Classes in org.hibernate.transform used by org.hibernate.transform
ResultTransformer
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ResultTransformer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transform
Interface ResultTransformer

All Superinterfaces:
Serializable
All Known Implementing Classes:
AliasToBeanConstructorResultTransformer, AliasToBeanResultTransformer, AliasToEntityMapResultTransformer, DistinctRootEntityResultTransformer, PassThroughResultTransformer, RootEntityResultTransformer, ToListResultTransformer
public interface ResultTransformer
extends Serializable

Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.

Author:
Gavin King
See Also:
Criteria.setResultTransformer(ResultTransformer)

Method Summary
List | transformList(List collection)
Object | transformTuple(Object[] tuple, String[] aliases)

Method Detail

transformTuple

public Object transformTuple(Object[] tuple,
                             String[] aliases)

transformList

public List transformList(List collection)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AliasToBeanConstructorResultTransformer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transform
Class AliasToBeanConstructorResultTransformer

java.lang.Object
    extended by org.hibernate.transform.AliasToBeanConstructorResultTransformer
All Implemented Interfaces:
ResultTransformer, Serializable
public class AliasToBeanConstructorResultTransformer
extends Object
implements ResultTransformer

See Also:
Serialized Form

Constructor Summary
AliasToBeanConstructorResultTransformer(Constructor constructor)
Method Summary
List | transformList(List collection)
Object | transformTuple(Object[] tuple, String[] aliases)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AliasToBeanConstructorResultTransformer

public AliasToBeanConstructorResultTransformer(Constructor constructor)
Method Detail

transformTuple

public Object transformTuple(Object[] tuple,
                             String[] aliases)
Specified by:
transformTuple in interface ResultTransformer

transformList

public List transformList(List collection)
Specified by:
transformList in interface ResultTransformer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AliasToBeanResultTransformer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transform
Class AliasToBeanResultTransformer

java.lang.Object
    extended by org.hibernate.transform.AliasToBeanResultTransformer
All Implemented Interfaces:
ResultTransformer, Serializable
public class AliasToBeanResultTransformer
extends Object
implements ResultTransformer

Result transformer that allows to transform a result to a user specified class which will be populated via setter methods or fields matching the alias names.

 List resultWithAliasedBean = s.createCriteria(Enrolment.class)
            .createAlias("student", "st")
            .createAlias("course", "co")
            .setProjection( Projections.projectionList()
                    .add( Projections.property("co.description"), "courseDescription" )
            )
            .setResultTransformer( new AliasToBeanResultTransformer(StudentDTO.class) )
            .list();

  StudentDTO dto = (StudentDTO)resultWithAliasedBean.get(0);

Author:
max
See Also:
Serialized Form

Constructor Summary
AliasToBeanResultTransformer(Class resultClass)
Method Summary
List | transformList(List collection)
Object | transformTuple(Object[] tuple, String[] aliases)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AliasToBeanResultTransformer

public AliasToBeanResultTransformer(Class resultClass)
Method Detail

transformTuple

public Object transformTuple(Object[] tuple,
                             String[] aliases)
Specified by:
transformTuple in interface ResultTransformer

transformList

public List transformList(List collection)
Specified by:
transformList in interface ResultTransformer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AliasToEntityMapResultTransformer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transform
Class AliasToEntityMapResultTransformer

java.lang.Object
    extended by org.hibernate.transform.AliasToEntityMapResultTransformer
All Implemented Interfaces:
ResultTransformer, Serializable
public class AliasToEntityMapResultTransformer
extends Object
implements ResultTransformer

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
AliasToEntityMapResultTransformer()
Method Summary
List | transformList(List collection)
Object | transformTuple(Object[] tuple, String[] aliases)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AliasToEntityMapResultTransformer

public AliasToEntityMapResultTransformer()
Method Detail

transformTuple

public Object transformTuple(Object[] tuple,
                             String[] aliases)
Specified by:
transformTuple in interface ResultTransformer

transformList

public List transformList(List collection)
Specified by:
transformList in interface ResultTransformer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DistinctRootEntityResultTransformer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transform
Class DistinctRootEntityResultTransformer

java.lang.Object
    extended by org.hibernate.transform.DistinctRootEntityResultTransformer
All Implemented Interfaces:
ResultTransformer, Serializable
public class DistinctRootEntityResultTransformer
extends Object
implements ResultTransformer

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
DistinctRootEntityResultTransformer()
Method Summary
List | transformList(List list)
Object | transformTuple(Object[] tuple, String[] aliases)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DistinctRootEntityResultTransformer

public DistinctRootEntityResultTransformer()
Method Detail

transformTuple

public Object transformTuple(Object[] tuple,
                             String[] aliases)
Specified by:
transformTuple in interface ResultTransformer

transformList

public List transformList(List list)
Specified by:
transformList in interface ResultTransformer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PassThroughResultTransformer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transform
Class PassThroughResultTransformer

java.lang.Object
    extended by org.hibernate.transform.PassThroughResultTransformer
All Implemented Interfaces:
ResultTransformer, Serializable
public class PassThroughResultTransformer
extends Object
implements ResultTransformer

Author:
max
See Also:
Serialized Form

Constructor Summary
PassThroughResultTransformer()
Method Summary
List | transformList(List collection)
Object | transformTuple(Object[] tuple, String[] aliases)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PassThroughResultTransformer

public PassThroughResultTransformer()
Method Detail

transformTuple

public Object transformTuple(Object[] tuple,
                             String[] aliases)
Specified by:
transformTuple in interface ResultTransformer

transformList

public List transformList(List collection)
Specified by:
transformList in interface ResultTransformer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RootEntityResultTransformer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transform
Class RootEntityResultTransformer

java.lang.Object
    extended by org.hibernate.transform.RootEntityResultTransformer
All Implemented Interfaces:
ResultTransformer, Serializable
public class RootEntityResultTransformer
extends Object
implements ResultTransformer

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
RootEntityResultTransformer()
Method Summary
List | transformList(List collection)
Object | transformTuple(Object[] tuple, String[] aliases)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RootEntityResultTransformer

public RootEntityResultTransformer()
Method Detail

transformTuple

public Object transformTuple(Object[] tuple,
                             String[] aliases)
Specified by:
transformTuple in interface ResultTransformer

transformList

public List transformList(List collection)
Specified by:
transformList in interface ResultTransformer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ToListResultTransformer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transform
Class ToListResultTransformer

java.lang.Object
    extended by org.hibernate.transform.ToListResultTransformer
All Implemented Interfaces:
ResultTransformer, Serializable
public class ToListResultTransformer
extends Object
implements ResultTransformer

See Also:
Serialized Form

Field Summary
static ResultTransformer INSTANCE
Method Summary
List | transformList(List collection)
Object | transformTuple(Object[] tuple, String[] aliases)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INSTANCE

public static final ResultTransformer INSTANCE
Method Detail

transformTuple

public Object transformTuple(Object[] tuple,
                             String[] aliases)
Specified by:
transformTuple in interface ResultTransformer

transformList

public List transformList(List collection)
Specified by:
transformList in interface ResultTransformer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Transformers (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transform
Class Transformers

java.lang.Object
    extended by org.hibernate.transform.Transformers
public final class Transformers
extends Object

Field Summary
static ResultTransformer | ALIAS_TO_ENTITY_MAP Each row of results is a Map from alias to values/entities
static ResultTransformer | TO_LIST Each row of results is a List
Method Summary
static ResultTransformer aliasToBean(Class target)
Creates a resulttransformer that will inject aliased values into instances of Class via property methods or fields.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ALIAS_TO_ENTITY_MAP

public static final ResultTransformer ALIAS_TO_ENTITY_MAP
Each row of results is a Map from alias to values/entities

TO_LIST

public static final ResultTransformer TO_LIST
Each row of results is a List

Method Detail

aliasToBean

public static ResultTransformer aliasToBean(Class target)
Creates a resulttransformer that will inject aliased values into instances of Class via property methods or fields.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.tuple (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.tuple

This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.

See:
Description

Interface Summary
Instantiator | Contract for implementors responsible for instantiating entity/component instances.
Tuplizer | A tuplizer defines the contract for things which know how to manage a particular representation of a piece of data, given that representation's EntityMode (the entity-mode essentially defining which representation).

Class Summary
Dom4jInstantiator | Performs "instantiation" based on DOM4J elements.
DynamicMapInstantiator |
ElementWrapper | Wraps dom4j elements, allowing them to exist in a non-hierarchical structure.
EntityModeToTuplizerMapping | Centralizes handling of EntityMode to Tuplizer mappings.
IdentifierProperty | Represents a defined entity identifier property within the Hibernate runtime-metamodel.
PojoInstantiator | Defines a POJO-based instantiator for use from the tuplizers.
Property | Defines the basic contract of a Property within the runtime metamodel.
PropertyFactory | Responsible for generation of runtime metamodel Property representations.
StandardProperty | Represents a basic property within the Hibernate runtime-metamodel.
VersionProperty | Represents a version property within the Hibernate runtime-metamodel.

Package org.hibernate.tuple Description

This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes. It is unaware of mappings to the database.

(This package is still undergoing maturation and will change over the next few months.)


org.hibernate.tuple Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.tuple

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.tuple.Dom4jInstantiator (implements org.hibernate.tuple.Instantiator)
    • class org.hibernate.tuple.DynamicMapInstantiator (implements org.hibernate.tuple.Instantiator)
    • class org.hibernate.tuple.ElementWrapper (implements org.dom4j.Element, java.io.Serializable)
    • class org.hibernate.tuple.EntityModeToTuplizerMapping (implements java.io.Serializable)
    • class org.hibernate.tuple.PojoInstantiator (implements org.hibernate.tuple.Instantiator, java.io.Serializable)
    • class org.hibernate.tuple.Property (implements java.io.Serializable)
      • class org.hibernate.tuple.IdentifierProperty
      • class org.hibernate.tuple.StandardProperty
        • class org.hibernate.tuple.VersionProperty
    • class org.hibernate.tuple.PropertyFactory

Interface Hierarchy

  • interface java.io.Serializable
    • interface org.hibernate.tuple.Instantiator
  • interface org.hibernate.tuple.Tuplizer


Uses of Package org.hibernate.tuple (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.tuple

Packages that use org.hibernate.tuple
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Classes in org.hibernate.tuple used by org.hibernate.tuple
IdentifierProperty
Represents a defined entity identifier property within the Hibernate runtime-metamodel.
Instantiator
Contract for implementors responsible for instantiating entity/component instances.
Property
Defines the basic contract of a Property within the runtime metamodel.
StandardProperty
Represents a basic property within the Hibernate runtime-metamodel.
Tuplizer
A tuplizer defines the contract for things which know how to manage a particular representation of a piece of data, given that representation's EntityMode (the entity-mode essentially defining which representation).
VersionProperty
Represents a version property within the Hibernate runtime-metamodel.

Classes in org.hibernate.tuple used by org.hibernate.tuple.component
Instantiator
Contract for implementors responsible for instantiating entity/component instances.
StandardProperty
Represents a basic property within the Hibernate runtime-metamodel.
Tuplizer
A tuplizer defines the contract for things which know how to manage a particular representation of a piece of data, given that representation's EntityMode (the entity-mode essentially defining which representation).

Classes in org.hibernate.tuple used by org.hibernate.tuple.entity
EntityModeToTuplizerMapping
Centralizes handling of EntityMode to Tuplizer mappings.
IdentifierProperty
Represents a defined entity identifier property within the Hibernate runtime-metamodel.
Instantiator
Contract for implementors responsible for instantiating entity/component instances.
StandardProperty
Represents a basic property within the Hibernate runtime-metamodel.
Tuplizer
A tuplizer defines the contract for things which know how to manage a particular representation of a piece of data, given that representation's EntityMode (the entity-mode essentially defining which representation).
VersionProperty
Represents a version property within the Hibernate runtime-metamodel.

Classes in org.hibernate.tuple used by org.hibernate.type
EntityModeToTuplizerMapping
Centralizes handling of EntityMode to Tuplizer mappings.
StandardProperty
Represents a basic property within the Hibernate runtime-metamodel.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Instantiator (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple
Interface Instantiator

All Superinterfaces:
Serializable
All Known Implementing Classes:
Dom4jInstantiator, DynamicMapInstantiator, PojoInstantiator
public interface Instantiator
extends Serializable

Contract for implementors responsible for instantiating entity/component instances.

Author:
Steve Ebersole

Method Summary
Object | instantiate() Perform the requested instantiation.
Object | instantiate(Serializable id) Perform the requested entity instantiation.
boolean | isInstance(Object object) Performs check to see if the given object is an instance of the entity or component which this Instantiator instantiates.

Method Detail

instantiate

public Object instantiate(Serializable id)
Perform the requested entity instantiation.

This form is never called for component instantiation, only entity instantiation.

Parameters:
id - The id of the entity to be instantiated.
Returns:
An appropriately instantiated entity.

instantiate

public Object instantiate()
Perform the requested instantiation.

Returns:
The instantiated data structure.

isInstance

public boolean isInstance(Object object)
Performs check to see if the given object is an instance of the entity or component which this Instantiator instantiates.

Parameters:
object - The object to be checked.
Returns:
True is the object does respresent an instance of the underlying entity/component.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Tuplizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple
Interface Tuplizer

All Known Subinterfaces:
ComponentTuplizer, EntityTuplizer
All Known Implementing Classes:
AbstractComponentTuplizer, AbstractEntityTuplizer
public interface Tuplizer

A tuplizer defines the contract for things which know how to manage a particular representation of a piece of data, given that representation's EntityMode (the entity-mode essentially defining which representation).

If that given piece of data is thought of as a data structure, then a tuplizer is the thing which knows how to
  • create such a data structure appropriately
  • extract values from and inject values into such a data structure

For example, a given piece of data might be represented as a POJO class. Here, it's representation and entity-mode is POJO. Well a tuplizer for POJO entity-modes would know how to
  • create the data structure by calling the POJO's constructor
  • extract and inject values through getters/setter, or by direct field access, etc

That same piece of data might also be represented as a DOM structure, using the tuplizer associated with the DOM4J entity-mode, which would generate instances of Element as the data structure and know how to access the values as either nested Elements or as Attributes.

Author:
Steve Ebersole
See Also:
EntityTuplizer, ComponentTuplizer

Method Summary
Class | getMappedClass() Return the pojo class managed by this tuplizer.
Object | getPropertyValue(Object entity, int i) Extract the value of a particular property from the given entity.
Object[] | getPropertyValues(Object entity) Extract the current values contained on the given entity.
Object | instantiate() Generate a new, empty entity.
boolean | isInstance(Object object) Is the given object considered an instance of the the entity (acconting for entity-mode) managed by this tuplizer.
void | setPropertyValues(Object entity, Object[] values) Inject the given values into the given entity.

Method Detail

getPropertyValues

public Object[] getPropertyValues(Object entity)
                           throws HibernateException
Extract the current values contained on the given entity.

Parameters:
entity - The entity from which to extract values.
Returns:
The current property values.
Throws:
HibernateException

setPropertyValues

public void setPropertyValues(Object entity,
                              Object[] values)
                       throws HibernateException
Inject the given values into the given entity.

Parameters:
entity - The entity.
values - The values to be injected.
Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object entity,
                               int i)
                        throws HibernateException
Extract the value of a particular property from the given entity.

Parameters:
entity - The entity from which to extract the property value.
i - The index of the property for which to extract the value.
Returns:
The current value of the given property on the given entity.
Throws:
HibernateException

instantiate

public Object instantiate()
                   throws HibernateException
Generate a new, empty entity.

Returns:
The new, empty entity instance.
Throws:
HibernateException

isInstance

public boolean isInstance(Object object)
Is the given object considered an instance of the the entity (acconting for entity-mode) managed by this tuplizer.

Parameters:
object - The object to be checked.
Returns:
True if the object is considered as an instance of this entity within the given mode.

getMappedClass

public Class getMappedClass()
Return the pojo class managed by this tuplizer.

Need to determine how to best handle this for the Tuplizers for EntityModes other than POJO.

todo : be really nice to not have this here since it is essentially pojo specific...

Returns:
The persistent class.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Dom4jInstantiator (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple
Class Dom4jInstantiator

java.lang.Object
    extended by org.hibernate.tuple.Dom4jInstantiator
All Implemented Interfaces:
Instantiator, Serializable
public class Dom4jInstantiator
extends Object
implements Instantiator

Performs "instantiation" based on DOM4J elements.

See Also:
Serialized Form

Constructor Summary
Dom4jInstantiator(Component component)
Dom4jInstantiator(PersistentClass mappingInfo)
Method Summary
Object | instantiate() Perform the requested instantiation.
Object | instantiate(Serializable id) Perform the requested entity instantiation.
boolean | isInstance(Object object) Performs check to see if the given object is an instance of the entity or component which this Instantiator instantiates.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Dom4jInstantiator

public Dom4jInstantiator(Component component)

Dom4jInstantiator

public Dom4jInstantiator(PersistentClass mappingInfo)
Method Detail

instantiate

public Object instantiate(Serializable id)
Description copied from interface: Instantiator
Perform the requested entity instantiation.

This form is never called for component instantiation, only entity instantiation.

Specified by:
instantiate in interface Instantiator
Parameters:
id - The id of the entity to be instantiated.
Returns:
An appropriately instantiated entity.

instantiate

public Object instantiate()
Description copied from interface: Instantiator
Perform the requested instantiation.

Specified by:
instantiate in interface Instantiator
Returns:
The instantiated data structure.

isInstance

public boolean isInstance(Object object)
Description copied from interface: Instantiator
Performs check to see if the given object is an instance of the entity or component which this Instantiator instantiates.

Specified by:
isInstance in interface Instantiator
Parameters:
object - The object to be checked.
Returns:
True is the object does respresent an instance of the underlying entity/component.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DynamicMapInstantiator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple
Class DynamicMapInstantiator

java.lang.Object
    extended by org.hibernate.tuple.DynamicMapInstantiator
All Implemented Interfaces:
Instantiator, Serializable
public class DynamicMapInstantiator
extends Object
implements Instantiator

See Also:
Serialized Form

Field Summary
static String KEY
Constructor Summary
DynamicMapInstantiator()
DynamicMapInstantiator(PersistentClass mappingInfo)
Method Summary
protected Map | generateMap()
Object | instantiate() Perform the requested instantiation.
Object | instantiate(Serializable id) Perform the requested entity instantiation.
boolean | isInstance(Object object) Performs check to see if the given object is an instance of the entity or component which this Instantiator instantiates.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

KEY

public static final String KEY
See Also:
Constant Field Values
Constructor Detail

DynamicMapInstantiator

public DynamicMapInstantiator()

DynamicMapInstantiator

public DynamicMapInstantiator(PersistentClass mappingInfo)
Method Detail

instantiate

public final Object instantiate(Serializable id)
Description copied from interface: Instantiator
Perform the requested entity instantiation.

This form is never called for component instantiation, only entity instantiation.

Specified by:
instantiate in interface Instantiator
Parameters:
id - The id of the entity to be instantiated.
Returns:
An appropriately instantiated entity.

instantiate

public final Object instantiate()
Description copied from interface: Instantiator
Perform the requested instantiation.

Specified by:
instantiate in interface Instantiator
Returns:
The instantiated data structure.

isInstance

public final boolean isInstance(Object object)
Description copied from interface: Instantiator
Performs check to see if the given object is an instance of the entity or component which this Instantiator instantiates.

Specified by:
isInstance in interface Instantiator
Parameters:
object - The object to be checked.
Returns:
True is the object does respresent an instance of the underlying entity/component.

generateMap

protected Map generateMap()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ElementWrapper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple
Class ElementWrapper

java.lang.Object
    extended by org.hibernate.tuple.ElementWrapper
All Implemented Interfaces:
org.dom4j.Branch, Cloneable, org.dom4j.Element, org.dom4j.Node, Serializable
public class ElementWrapper
extends Object
implements org.dom4j.Element, Serializable

Wraps dom4j elements, allowing them to exist in a non-hierarchical structure.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
ElementWrapper(org.dom4j.Element element)
Method Summary
void | accept(org.dom4j.Visitor visitor)
void | add(org.dom4j.Attribute attribute)
void | add(org.dom4j.CDATA cdata)
void | add(org.dom4j.Comment comment)
void | add(org.dom4j.Element element)
void | add(org.dom4j.Entity entity)
void | add(org.dom4j.Namespace namespace)
void | add(org.dom4j.Node node)
void | add(org.dom4j.ProcessingInstruction processingInstruction)
void | add(org.dom4j.Text text)
org.dom4j.Element | addAttribute(org.dom4j.QName attrName, String text)
org.dom4j.Element | addAttribute(String attrName, String text)
org.dom4j.Element | addCDATA(String text)
org.dom4j.Element | addComment(String text)
org.dom4j.Element | addElement(org.dom4j.QName qName)
org.dom4j.Element | addElement(String name)
org.dom4j.Element | addElement(String name, String text)
org.dom4j.Element | addEntity(String name, String text)
List | additionalNamespaces()
org.dom4j.Element | addNamespace(String prefix, String uri)
org.dom4j.Element | addProcessingInstruction(String target, Map data)
org.dom4j.Element | addProcessingInstruction(String target, String text)
org.dom4j.Element | addText(String text)
void | appendAttributes(org.dom4j.Element element)
void | appendContent(org.dom4j.Branch branch)
String | asXML()
org.dom4j.Node | asXPathResult(org.dom4j.Element element)
org.dom4j.Attribute | attribute(int i)
org.dom4j.Attribute | attribute(org.dom4j.QName qName)
org.dom4j.Attribute | attribute(String name)
int | attributeCount()
Iterator | attributeIterator()
List | attributes()
String | attributeValue(org.dom4j.QName qName)
String | attributeValue(org.dom4j.QName qName, String defaultValue)
String | attributeValue(String name)
String | attributeValue(String name, String defaultValue)
void | clearContent()
Object | clone()
List | content()
org.dom4j.Element | createCopy()
org.dom4j.Element | createCopy(org.dom4j.QName qName)
org.dom4j.Element | createCopy(String name)
org.dom4j.XPath | createXPath(String xpath)
List | declaredNamespaces()
org.dom4j.Node | detach()
org.dom4j.Element | element(org.dom4j.QName qName)
org.dom4j.Element | element(String name)
org.dom4j.Element | elementByID(String id)
Iterator | elementIterator()
Iterator | elementIterator(org.dom4j.QName qName)
Iterator | elementIterator(String name)
List | elements()
List | elements(org.dom4j.QName qName)
List | elements(String name)
String | elementText(org.dom4j.QName qName)
String | elementText(String name)
String | elementTextTrim(org.dom4j.QName qName)
String | elementTextTrim(String name)
boolean | equals(Object other)
Object | getData()
org.dom4j.Document | getDocument()
org.dom4j.Element | getElement()
String | getName()
org.dom4j.Namespace | getNamespace()
org.dom4j.Namespace | getNamespaceForPrefix(String s)
org.dom4j.Namespace | getNamespaceForURI(String s)
String | getNamespacePrefix()
List | getNamespacesForURI(String s)
String | getNamespaceURI()
short | getNodeType()
String | getNodeTypeName()
org.dom4j.Element | getParent()
String | getPath()
String | getPath(org.dom4j.Element element)
org.dom4j.QName | getQName()
org.dom4j.QName | getQName(String s)
String | getQualifiedName()
String | getStringValue()
String | getText()
String | getTextTrim()
String | getUniquePath()
String | getUniquePath(org.dom4j.Element element)
org.dom4j.Node | getXPathResult(int i)
boolean | hasContent()
int | hashCode()
boolean | hasMixedContent()
int | indexOf(org.dom4j.Node node)
boolean | isReadOnly()
boolean | isRootElement()
boolean | isTextOnly()
boolean | matches(String xpath)
org.dom4j.Node | node(int i)
int | nodeCount()
Iterator | nodeIterator()
void | normalize()
Number | numberValueOf(String xpath)
org.dom4j.ProcessingInstruction | processingInstruction(String name)
List | processingInstructions()
List | processingInstructions(String name)
boolean | remove(org.dom4j.Attribute attribute)
boolean | remove(org.dom4j.CDATA cdata)
boolean | remove(org.dom4j.Comment comment)
boolean | remove(org.dom4j.Element element)
boolean | remove(org.dom4j.Entity entity)
boolean | remove(org.dom4j.Namespace namespace)
boolean | remove(org.dom4j.Node node)
boolean | remove(org.dom4j.ProcessingInstruction processingInstruction)
boolean | remove(org.dom4j.Text text)
boolean | removeProcessingInstruction(String name)
List | selectNodes(String xpath)
List | selectNodes(String xpath, String comparison)
List | selectNodes(String xpath, String comparison, boolean removeDups)
Object | selectObject(String xpath)
org.dom4j.Node | selectSingleNode(String xpath)
void | setAttributes(List list)
void | setAttributeValue(org.dom4j.QName qName, String value) Deprecated.
void | setAttributeValue(String name, String value) Deprecated.
void | setContent(List list)
void | setData(Object data)
void | setDocument(org.dom4j.Document document)
void | setName(String name)
void | setParent(org.dom4j.Element parent)
void | setProcessingInstructions(List list)
void | setQName(org.dom4j.QName qName)
void | setText(String text)
boolean | supportsParent()
String | toString()
String | valueOf(String xpath)
void | write(Writer writer)
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

ElementWrapper

public ElementWrapper(org.dom4j.Element element)
Method Detail

getElement

public org.dom4j.Element getElement()

getQName

public org.dom4j.QName getQName()
Specified by:
getQName in interface org.dom4j.Element

getQName

public org.dom4j.QName getQName(String s)
Specified by:
getQName in interface org.dom4j.Element

setQName

public void setQName(org.dom4j.QName qName)
Specified by:
setQName in interface org.dom4j.Element

getNamespace

public org.dom4j.Namespace getNamespace()
Specified by:
getNamespace in interface org.dom4j.Element

getNamespaceForPrefix

public org.dom4j.Namespace getNamespaceForPrefix(String s)
Specified by:
getNamespaceForPrefix in interface org.dom4j.Element

getNamespaceForURI

public org.dom4j.Namespace getNamespaceForURI(String s)
Specified by:
getNamespaceForURI in interface org.dom4j.Element

getNamespacesForURI

public List getNamespacesForURI(String s)
Specified by:
getNamespacesForURI in interface org.dom4j.Element

getNamespacePrefix

public String getNamespacePrefix()
Specified by:
getNamespacePrefix in interface org.dom4j.Element

getNamespaceURI

public String getNamespaceURI()
Specified by:
getNamespaceURI in interface org.dom4j.Element

getQualifiedName

public String getQualifiedName()
Specified by:
getQualifiedName in interface org.dom4j.Element

additionalNamespaces

public List additionalNamespaces()
Specified by:
additionalNamespaces in interface org.dom4j.Element

declaredNamespaces

public List declaredNamespaces()
Specified by:
declaredNamespaces in interface org.dom4j.Element

addAttribute

public org.dom4j.Element addAttribute(String attrName,
                                      String text)
Specified by:
addAttribute in interface org.dom4j.Element

addAttribute

public org.dom4j.Element addAttribute(org.dom4j.QName attrName,
                                      String text)
Specified by:
addAttribute in interface org.dom4j.Element

addComment

public org.dom4j.Element addComment(String text)
Specified by:
addComment in interface org.dom4j.Element

addCDATA

public org.dom4j.Element addCDATA(String text)
Specified by:
addCDATA in interface org.dom4j.Element

addEntity

public org.dom4j.Element addEntity(String name,
                                   String text)
Specified by:
addEntity in interface org.dom4j.Element

addNamespace

public org.dom4j.Element addNamespace(String prefix,
                                      String uri)
Specified by:
addNamespace in interface org.dom4j.Element

addProcessingInstruction

public org.dom4j.Element addProcessingInstruction(String target,
                                                  String text)
Specified by:
addProcessingInstruction in interface org.dom4j.Element

addProcessingInstruction

public org.dom4j.Element addProcessingInstruction(String target,
                                                  Map data)
Specified by:
addProcessingInstruction in interface org.dom4j.Element

addText

public org.dom4j.Element addText(String text)
Specified by:
addText in interface org.dom4j.Element

add

public void add(org.dom4j.Attribute attribute)
Specified by:
add in interface org.dom4j.Element

add

public void add(org.dom4j.CDATA cdata)
Specified by:
add in interface org.dom4j.Element

add

public void add(org.dom4j.Entity entity)
Specified by:
add in interface org.dom4j.Element

add

public void add(org.dom4j.Text text)
Specified by:
add in interface org.dom4j.Element

add

public void add(org.dom4j.Namespace namespace)
Specified by:
add in interface org.dom4j.Element

remove

public boolean remove(org.dom4j.Attribute attribute)
Specified by:
remove in interface org.dom4j.Element

remove

public boolean remove(org.dom4j.CDATA cdata)
Specified by:
remove in interface org.dom4j.Element

remove

public boolean remove(org.dom4j.Entity entity)
Specified by:
remove in interface org.dom4j.Element

remove

public boolean remove(org.dom4j.Namespace namespace)
Specified by:
remove in interface org.dom4j.Element

remove

public boolean remove(org.dom4j.Text text)
Specified by:
remove in interface org.dom4j.Element

supportsParent

public boolean supportsParent()
Specified by:
supportsParent in interface org.dom4j.Node

getParent

public org.dom4j.Element getParent()
Specified by:
getParent in interface org.dom4j.Node

setParent

public void setParent(org.dom4j.Element parent)
Specified by:
setParent in interface org.dom4j.Node

getDocument

public org.dom4j.Document getDocument()
Specified by:
getDocument in interface org.dom4j.Node

setDocument

public void setDocument(org.dom4j.Document document)
Specified by:
setDocument in interface org.dom4j.Node

isReadOnly

public boolean isReadOnly()
Specified by:
isReadOnly in interface org.dom4j.Node

hasContent

public boolean hasContent()
Specified by:
hasContent in interface org.dom4j.Node

getName

public String getName()
Specified by:
getName in interface org.dom4j.Node

setName

public void setName(String name)
Specified by:
setName in interface org.dom4j.Node

getText

public String getText()
Specified by:
getText in interface org.dom4j.Element

setText

public void setText(String text)
Specified by:
setText in interface org.dom4j.Node

getTextTrim

public String getTextTrim()
Specified by:
getTextTrim in interface org.dom4j.Element

getStringValue

public String getStringValue()
Specified by:
getStringValue in interface org.dom4j.Element

getPath

public String getPath()
Specified by:
getPath in interface org.dom4j.Node

getPath

public String getPath(org.dom4j.Element element)
Specified by:
getPath in interface org.dom4j.Node

getUniquePath

public String getUniquePath()
Specified by:
getUniquePath in interface org.dom4j.Node

getUniquePath

public String getUniquePath(org.dom4j.Element element)
Specified by:
getUniquePath in interface org.dom4j.Node

asXML

public String asXML()
Specified by:
asXML in interface org.dom4j.Node

write

public void write(Writer writer)
           throws IOException
Specified by:
write in interface org.dom4j.Node
Throws:
IOException

getNodeType

public short getNodeType()
Specified by:
getNodeType in interface org.dom4j.Node

getNodeTypeName

public String getNodeTypeName()
Specified by:
getNodeTypeName in interface org.dom4j.Node

detach

public org.dom4j.Node detach()
Specified by:
detach in interface org.dom4j.Node

selectNodes

public List selectNodes(String xpath)
Specified by:
selectNodes in interface org.dom4j.Node

selectObject

public Object selectObject(String xpath)
Specified by:
selectObject in interface org.dom4j.Node

selectNodes

public List selectNodes(String xpath,
                        String comparison)
Specified by:
selectNodes in interface org.dom4j.Node

selectNodes

public List selectNodes(String xpath,
                        String comparison,
                        boolean removeDups)
Specified by:
selectNodes in interface org.dom4j.Node

selectSingleNode

public org.dom4j.Node selectSingleNode(String xpath)
Specified by:
selectSingleNode in interface org.dom4j.Node

valueOf

public String valueOf(String xpath)
Specified by:
valueOf in interface org.dom4j.Node

numberValueOf

public Number numberValueOf(String xpath)
Specified by:
numberValueOf in interface org.dom4j.Node

matches

public boolean matches(String xpath)
Specified by:
matches in interface org.dom4j.Node

createXPath

public org.dom4j.XPath createXPath(String xpath)
                            throws org.dom4j.InvalidXPathException
Specified by:
createXPath in interface org.dom4j.Node
Throws:
org.dom4j.InvalidXPathException

asXPathResult

public org.dom4j.Node asXPathResult(org.dom4j.Element element)
Specified by:
asXPathResult in interface org.dom4j.Node

accept

public void accept(org.dom4j.Visitor visitor)
Specified by:
accept in interface org.dom4j.Node

clone

public Object clone()
Specified by:
clone in interface org.dom4j.Node

getData

public Object getData()
Specified by:
getData in interface org.dom4j.Element

setData

public void setData(Object data)
Specified by:
setData in interface org.dom4j.Element

attributes

public List attributes()
Specified by:
attributes in interface org.dom4j.Element

setAttributes

public void setAttributes(List list)
Specified by:
setAttributes in interface org.dom4j.Element

attributeCount

public int attributeCount()
Specified by:
attributeCount in interface org.dom4j.Element

attributeIterator

public Iterator attributeIterator()
Specified by:
attributeIterator in interface org.dom4j.Element

attribute

public org.dom4j.Attribute attribute(int i)
Specified by:
attribute in interface org.dom4j.Element

attribute

public org.dom4j.Attribute attribute(String name)
Specified by:
attribute in interface org.dom4j.Element

attribute

public org.dom4j.Attribute attribute(org.dom4j.QName qName)
Specified by:
attribute in interface org.dom4j.Element

attributeValue

public String attributeValue(String name)
Specified by:
attributeValue in interface org.dom4j.Element

attributeValue

public String attributeValue(String name,
                             String defaultValue)
Specified by:
attributeValue in interface org.dom4j.Element

attributeValue

public String attributeValue(org.dom4j.QName qName)
Specified by:
attributeValue in interface org.dom4j.Element

attributeValue

public String attributeValue(org.dom4j.QName qName,
                             String defaultValue)
Specified by:
attributeValue in interface org.dom4j.Element

setAttributeValue

public void setAttributeValue(String name,
                              String value)
Deprecated.

Specified by:
setAttributeValue in interface org.dom4j.Element

setAttributeValue

public void setAttributeValue(org.dom4j.QName qName,
                              String value)
Deprecated.

Specified by:
setAttributeValue in interface org.dom4j.Element

element

public org.dom4j.Element element(String name)
Specified by:
element in interface org.dom4j.Element

element

public org.dom4j.Element element(org.dom4j.QName qName)
Specified by:
element in interface org.dom4j.Element

elements

public List elements()
Specified by:
elements in interface org.dom4j.Element

elements

public List elements(String name)
Specified by:
elements in interface org.dom4j.Element

elements

public List elements(org.dom4j.QName qName)
Specified by:
elements in interface org.dom4j.Element

elementIterator

public Iterator elementIterator()
Specified by:
elementIterator in interface org.dom4j.Element

elementIterator

public Iterator elementIterator(String name)
Specified by:
elementIterator in interface org.dom4j.Element

elementIterator

public Iterator elementIterator(org.dom4j.QName qName)
Specified by:
elementIterator in interface org.dom4j.Element

isRootElement

public boolean isRootElement()
Specified by:
isRootElement in interface org.dom4j.Element

hasMixedContent

public boolean hasMixedContent()
Specified by:
hasMixedContent in interface org.dom4j.Element

isTextOnly

public boolean isTextOnly()
Specified by:
isTextOnly in interface org.dom4j.Element

appendAttributes

public void appendAttributes(org.dom4j.Element element)
Specified by:
appendAttributes in interface org.dom4j.Element

createCopy

public org.dom4j.Element createCopy()
Specified by:
createCopy in interface org.dom4j.Element

createCopy

public org.dom4j.Element createCopy(String name)
Specified by:
createCopy in interface org.dom4j.Element

createCopy

public org.dom4j.Element createCopy(org.dom4j.QName qName)
Specified by:
createCopy in interface org.dom4j.Element

elementText

public String elementText(String name)
Specified by:
elementText in interface org.dom4j.Element

elementText

public String elementText(org.dom4j.QName qName)
Specified by:
elementText in interface org.dom4j.Element

elementTextTrim

public String elementTextTrim(String name)
Specified by:
elementTextTrim in interface org.dom4j.Element

elementTextTrim

public String elementTextTrim(org.dom4j.QName qName)
Specified by:
elementTextTrim in interface org.dom4j.Element

getXPathResult

public org.dom4j.Node getXPathResult(int i)
Specified by:
getXPathResult in interface org.dom4j.Element

node

public org.dom4j.Node node(int i)
Specified by:
node in interface org.dom4j.Branch

indexOf

public int indexOf(org.dom4j.Node node)
Specified by:
indexOf in interface org.dom4j.Branch

nodeCount

public int nodeCount()
Specified by:
nodeCount in interface org.dom4j.Branch

elementByID

public org.dom4j.Element elementByID(String id)
Specified by:
elementByID in interface org.dom4j.Branch

content

public List content()
Specified by:
content in interface org.dom4j.Branch

nodeIterator

public Iterator nodeIterator()
Specified by:
nodeIterator in interface org.dom4j.Branch

setContent

public void setContent(List list)
Specified by:
setContent in interface org.dom4j.Branch

appendContent

public void appendContent(org.dom4j.Branch branch)
Specified by:
appendContent in interface org.dom4j.Branch

clearContent

public void clearContent()
Specified by:
clearContent in interface org.dom4j.Branch

processingInstructions

public List processingInstructions()
Specified by:
processingInstructions in interface org.dom4j.Branch

processingInstructions

public List processingInstructions(String name)
Specified by:
processingInstructions in interface org.dom4j.Branch

processingInstruction

public org.dom4j.ProcessingInstruction processingInstruction(String name)
Specified by:
processingInstruction in interface org.dom4j.Branch

setProcessingInstructions

public void setProcessingInstructions(List list)
Specified by:
setProcessingInstructions in interface org.dom4j.Branch

addElement

public org.dom4j.Element addElement(String name)
Specified by:
addElement in interface org.dom4j.Branch

addElement

public org.dom4j.Element addElement(org.dom4j.QName qName)
Specified by:
addElement in interface org.dom4j.Branch

addElement

public org.dom4j.Element addElement(String name,
                                    String text)
Specified by:
addElement in interface org.dom4j.Branch

removeProcessingInstruction

public boolean removeProcessingInstruction(String name)
Specified by:
removeProcessingInstruction in interface org.dom4j.Branch

add

public void add(org.dom4j.Node node)
Specified by:
add in interface org.dom4j.Branch

add

public void add(org.dom4j.Comment comment)
Specified by:
add in interface org.dom4j.Branch

add

public void add(org.dom4j.Element element)
Specified by:
add in interface org.dom4j.Branch

add

public void add(org.dom4j.ProcessingInstruction processingInstruction)
Specified by:
add in interface org.dom4j.Branch

remove

public boolean remove(org.dom4j.Node node)
Specified by:
remove in interface org.dom4j.Branch

remove

public boolean remove(org.dom4j.Comment comment)
Specified by:
remove in interface org.dom4j.Branch

remove

public boolean remove(org.dom4j.Element element)
Specified by:
remove in interface org.dom4j.Branch

remove

public boolean remove(org.dom4j.ProcessingInstruction processingInstruction)
Specified by:
remove in interface org.dom4j.Branch

normalize

public void normalize()
Specified by:
normalize in interface org.dom4j.Branch

equals

public boolean equals(Object other)

hashCode

public int hashCode()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityModeToTuplizerMapping (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple
Class EntityModeToTuplizerMapping

java.lang.Object
    extended by org.hibernate.tuple.EntityModeToTuplizerMapping
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
EntityEntityModeToTuplizerMapping
public abstract class EntityModeToTuplizerMapping
extends Object
implements Serializable

Centralizes handling of EntityMode to Tuplizer mappings.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
EntityModeToTuplizerMapping()
Method Summary
protected void | addTuplizer(EntityMode entityMode, Tuplizer tuplizer)
Tuplizer | getTuplizer(EntityMode entityMode) Locate the tuplizer contained within this mapping which is responsible for the given entity-mode.
Tuplizer | getTuplizerOrNull(EntityMode entityMode) Locate the contained tuplizer responsible for the given entity-mode.
EntityMode | guessEntityMode(Object object) Given a supposed instance of an entity/component, guess its entity mode.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EntityModeToTuplizerMapping

public EntityModeToTuplizerMapping()
Method Detail

addTuplizer

protected void addTuplizer(EntityMode entityMode,
                           Tuplizer tuplizer)

guessEntityMode

public EntityMode guessEntityMode(Object object)
Given a supposed instance of an entity/component, guess its entity mode.

Parameters:
object - The supposed instance of the entity/component.
Returns:
The guessed entity mode.

getTuplizerOrNull

public Tuplizer getTuplizerOrNull(EntityMode entityMode)
Locate the contained tuplizer responsible for the given entity-mode. If no such tuplizer is defined on this mapping, then return null.

Parameters:
entityMode - The entity-mode for which the caller wants a tuplizer.
Returns:
The tuplizer, or null if not found.

getTuplizer

public Tuplizer getTuplizer(EntityMode entityMode)
Locate the tuplizer contained within this mapping which is responsible for the given entity-mode. If no such tuplizer is defined on this mapping, then an exception is thrown.

Parameters:
entityMode - The entity-mode for which the caller wants a tuplizer.
Returns:
The tuplizer.
Throws:
HibernateException - Unable to locate the requested tuplizer.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentifierProperty (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple
Class IdentifierProperty

java.lang.Object
    extended by org.hibernate.tuple.Property
        extended by org.hibernate.tuple.IdentifierProperty
All Implemented Interfaces:
Serializable
public class IdentifierProperty
extends Property

Represents a defined entity identifier property within the Hibernate runtime-metamodel.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
IdentifierProperty(String name, String node, Type type, boolean embedded, IdentifierValue unsavedValue, IdentifierGenerator identifierGenerator)
Construct a non-virtual identifier property.
IdentifierProperty(Type type, boolean embedded, boolean hasIdentifierMapper, IdentifierValue unsavedValue, IdentifierGenerator identifierGenerator)
Construct a virtual IdentifierProperty.
Method Summary
IdentifierGenerator | getIdentifierGenerator()
IdentifierValue | getUnsavedValue()
boolean | hasIdentifierMapper()
boolean | isEmbedded()
boolean | isIdentifierAssignedByInsert()
boolean | isVirtual()
Methods inherited from class org.hibernate.tuple.Property
getName, getNode, getType, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IdentifierProperty

public IdentifierProperty(String name,
                          String node,
                          Type type,
                          boolean embedded,
                          IdentifierValue unsavedValue,
                          IdentifierGenerator identifierGenerator)
Construct a non-virtual identifier property.

Parameters:
name - The name of the property representing the identifier within its owning entity.
node - The node name to use for XML-based representation of this property.
type - The Hibernate Type for the identifier property.
embedded - Is this an embedded identifier.
unsavedValue - The value which, if found as the value on the identifier property, represents new (i.e., un-saved) instances of the owning entity.
identifierGenerator - The generator to use for id value generation.

IdentifierProperty

public IdentifierProperty(Type type,
                          boolean embedded,
                          boolean hasIdentifierMapper,
                          IdentifierValue unsavedValue,
                          IdentifierGenerator identifierGenerator)
Construct a virtual IdentifierProperty.

Parameters:
type - The Hibernate Type for the identifier property.
embedded - Is this an embedded identifier.
unsavedValue - The value which, if found as the value on the identifier property, represents new (i.e., un-saved) instances of the owning entity.
identifierGenerator - The generator to use for id value generation.
Method Detail

isVirtual

public boolean isVirtual()

isEmbedded

public boolean isEmbedded()

getUnsavedValue

public IdentifierValue getUnsavedValue()

getIdentifierGenerator

public IdentifierGenerator getIdentifierGenerator()

isIdentifierAssignedByInsert

public boolean isIdentifierAssignedByInsert()

hasIdentifierMapper

public boolean hasIdentifierMapper()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PojoInstantiator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple
Class PojoInstantiator

java.lang.Object
    extended by org.hibernate.tuple.PojoInstantiator
All Implemented Interfaces:
Instantiator, Serializable
public class PojoInstantiator
extends Object
implements Instantiator, Serializable

Defines a POJO-based instantiator for use from the tuplizers.

See Also:
Serialized Form

Constructor Summary
PojoInstantiator(Component component, ReflectionOptimizer.InstantiationOptimizer optimizer)
PojoInstantiator(PersistentClass persistentClass, ReflectionOptimizer.InstantiationOptimizer optimizer)
Method Summary
Object | instantiate() Perform the requested instantiation.
Object | instantiate(Serializable id) Perform the requested entity instantiation.
boolean | isInstance(Object object) Performs check to see if the given object is an instance of the entity or component which this Instantiator instantiates.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PojoInstantiator

public PojoInstantiator(Component component,
                        ReflectionOptimizer.InstantiationOptimizer optimizer)

PojoInstantiator

public PojoInstantiator(PersistentClass persistentClass,
                        ReflectionOptimizer.InstantiationOptimizer optimizer)
Method Detail

instantiate

public Object instantiate()
Description copied from interface: Instantiator
Perform the requested instantiation.

Specified by:
instantiate in interface Instantiator
Returns:
The instantiated data structure.

instantiate

public Object instantiate(Serializable id)
Description copied from interface: Instantiator
Perform the requested entity instantiation.

This form is never called for component instantiation, only entity instantiation.

Specified by:
instantiate in interface Instantiator
Parameters:
id - The id of the entity to be instantiated.
Returns:
An appropriately instantiated entity.

isInstance

public boolean isInstance(Object object)
Description copied from interface: Instantiator
Performs check to see if the given object is an instance of the entity or component which this Instantiator instantiates.

Specified by:
isInstance in interface Instantiator
Parameters:
object - The object to be checked.
Returns:
True is the object does respresent an instance of the underlying entity/component.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Property (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple
Class Property

java.lang.Object
    extended by org.hibernate.tuple.Property
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
IdentifierProperty, StandardProperty
public abstract class Property
extends Object
implements Serializable

Defines the basic contract of a Property within the runtime metamodel.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
protected Property(String name, String node, Type type)
Constructor for Property instances.
Method Summary
String | getName()
String | getNode()
Type | getType()
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

Property

protected Property(String name,
                   String node,
                   Type type)
Constructor for Property instances.

Parameters:
name - The name by which the property can be referenced within its owner.
node - The node name to use for XML-based representation of this property.
type - The Hibernate Type of this property.
Method Detail

getName

public String getName()

getNode

public String getNode()

getType

public Type getType()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple
Class PropertyFactory

java.lang.Object
    extended by org.hibernate.tuple.PropertyFactory
public class PropertyFactory
extends Object

Responsible for generation of runtime metamodel Property representations. Makes distinction between identifier, version, and other (standard) properties.

Author:
Steve Ebersole

Constructor Summary
PropertyFactory()
Method Summary
static IdentifierProperty | buildIdentifierProperty(PersistentClass mappedEntity, IdentifierGenerator generator) Generates an IdentifierProperty representation of the for a given entity mapping.
static StandardProperty | buildStandardProperty(Property property, boolean lazyAvailable) Generate a "standard" (i.e., non-identifier and non-version) based on the given mapped property.
static VersionProperty | buildVersionProperty(Property property, boolean lazyAvailable) Generates a VersionProperty representation for an entity mapping given its version mapping Property.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PropertyFactory

public PropertyFactory()
Method Detail

buildIdentifierProperty

public static IdentifierProperty buildIdentifierProperty(PersistentClass mappedEntity,
                                                         IdentifierGenerator generator)
Generates an IdentifierProperty representation of the for a given entity mapping.

Parameters:
mappedEntity - The mapping definition of the entity.
generator - The identifier value generator to use for this identifier.
Returns:
The appropriate IdentifierProperty definition.

buildVersionProperty

public static VersionProperty buildVersionProperty(Property property,
                                                   boolean lazyAvailable)
Generates a VersionProperty representation for an entity mapping given its version mapping Property.

Parameters:
property - The version mapping Property.
lazyAvailable - Is property lazy loading currently available.
Returns:
The appropriate VersionProperty definition.

buildStandardProperty

public static StandardProperty buildStandardProperty(Property property,
                                                     boolean lazyAvailable)
Generate a "standard" (i.e., non-identifier and non-version) based on the given mapped property.

Parameters:
property - The mapped property.
lazyAvailable - Is property lazy loading currently available.
Returns:
The appropriate StandardProperty definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StandardProperty (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple
Class StandardProperty

java.lang.Object
    extended by org.hibernate.tuple.Property
        extended by org.hibernate.tuple.StandardProperty
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
VersionProperty
public class StandardProperty
extends Property

Represents a basic property within the Hibernate runtime-metamodel.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
StandardProperty(String name, String node, Type type, boolean lazy, boolean insertable, boolean updateable, boolean insertGenerated, boolean updateGenerated, boolean nullable, boolean checkable, boolean versionable, CascadeStyle cascadeStyle, FetchMode fetchMode)
Constructs StandardProperty instances.
Method Summary
CascadeStyle | getCascadeStyle()
FetchMode | getFetchMode()
boolean | isDirtyCheckable()
boolean | isDirtyCheckable(boolean hasUninitializedProperties)
boolean | isInsertable()
boolean | isInsertGenerated()
boolean | isLazy()
boolean | isNullable()
boolean | isUpdateable()
boolean | isUpdateGenerated()
boolean | isVersionable()
Methods inherited from class org.hibernate.tuple.Property
getName, getNode, getType, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

StandardProperty

public StandardProperty(String name,
                        String node,
                        Type type,
                        boolean lazy,
                        boolean insertable,
                        boolean updateable,
                        boolean insertGenerated,
                        boolean updateGenerated,
                        boolean nullable,
                        boolean checkable,
                        boolean versionable,
                        CascadeStyle cascadeStyle,
                        FetchMode fetchMode)
Constructs StandardProperty instances.

Parameters:
name - The name by which the property can be referenced within its owner.
node - The node name to use for XML-based representation of this property.
type - The Hibernate Type of this property.
lazy - Should this property be handled lazily?
insertable - Is this property an insertable value?
updateable - Is this property an updateable value?
insertGenerated - Is this property generated in the database on insert?
updateGenerated - Is this property generated in the database on update?
nullable - Is this property a nullable value?
checkable - Is this property a checkable value?
versionable - Is this property a versionable value?
cascadeStyle - The cascade style for this property's value.
fetchMode - Any fetch mode defined for this property
Method Detail

isLazy

public boolean isLazy()

isInsertable

public boolean isInsertable()

isUpdateable

public boolean isUpdateable()

isInsertGenerated

public boolean isInsertGenerated()

isUpdateGenerated

public boolean isUpdateGenerated()

isNullable

public boolean isNullable()

isDirtyCheckable

public boolean isDirtyCheckable(boolean hasUninitializedProperties)

isDirtyCheckable

public boolean isDirtyCheckable()

isVersionable

public boolean isVersionable()

getCascadeStyle

public CascadeStyle getCascadeStyle()

getFetchMode

public FetchMode getFetchMode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VersionProperty (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple
Class VersionProperty

java.lang.Object
    extended by org.hibernate.tuple.Property
        extended by org.hibernate.tuple.StandardProperty
            extended by org.hibernate.tuple.VersionProperty
All Implemented Interfaces:
Serializable
public class VersionProperty
extends StandardProperty

Represents a version property within the Hibernate runtime-metamodel.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
VersionProperty(String name, String node, Type type, boolean lazy, boolean insertable, boolean updateable, boolean insertGenerated, boolean updateGenerated, boolean nullable, boolean checkable, boolean versionable, CascadeStyle cascadeStyle, VersionValue unsavedValue)
Constructs VersionProperty instances.
Method Summary
 VersionValue getUnsavedValue()
Methods inherited from class org.hibernate.tuple.StandardProperty
getCascadeStyle, getFetchMode, isDirtyCheckable, isDirtyCheckable, isInsertable, isInsertGenerated, isLazy, isNullable, isUpdateable, isUpdateGenerated, isVersionable
Methods inherited from class org.hibernate.tuple.Property
getName, getNode, getType, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

VersionProperty

public VersionProperty(String name,
                       String node,
                       Type type,
                       boolean lazy,
                       boolean insertable,
                       boolean updateable,
                       boolean insertGenerated,
                       boolean updateGenerated,
                       boolean nullable,
                       boolean checkable,
                       boolean versionable,
                       CascadeStyle cascadeStyle,
                       VersionValue unsavedValue)
Constructs VersionProperty instances.

Parameters:
name - The name by which the property can be referenced within its owner.
node - The node name to use for XML-based representation of this property.
type - The Hibernate Type of this property.
lazy - Should this property be handled lazily?
insertable - Is this property an insertable value?
updateable - Is this property an updateable value?
insertGenerated - Is this property generated in the database on insert?
updateGenerated - Is this property generated in the database on update?
nullable - Is this property a nullable value?
checkable - Is this property a checkable value?
versionable - Is this property a versionable value?
cascadeStyle - The cascade style for this property's value.
unsavedValue - The value which, if found as the value of this (i.e., the version) property, represents new (i.e., un-saved) instances of the owning entity.
Method Detail

getUnsavedValue

public VersionValue getUnsavedValue()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.tuple.component (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.tuple.component

Interface Summary
ComponentTuplizer Defines further responsibilities reagarding tuplization based on a mapped components.

Class Summary
AbstractComponentTuplizer | Support for tuplizers relating to components.
ComponentMetamodel | Centralizes metamodel information about a component.
Dom4jComponentTuplizer | A ComponentTuplizer specific to the dom4j entity mode.
DynamicMapComponentTuplizer | A ComponentTuplizer specific to the dynamic-map entity mode.
PojoComponentTuplizer | A ComponentTuplizer specific to the pojo entity mode.


org.hibernate.tuple.component Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.tuple.component

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.tuple.component.AbstractComponentTuplizer (implements org.hibernate.tuple.component.ComponentTuplizer)
      • class org.hibernate.tuple.component.Dom4jComponentTuplizer
      • class org.hibernate.tuple.component.DynamicMapComponentTuplizer
      • class org.hibernate.tuple.component.PojoComponentTuplizer
    • class org.hibernate.tuple.component.ComponentMetamodel (implements java.io.Serializable)

Interface Hierarchy

  • interface java.io.Serializable
    • interface org.hibernate.tuple.component.ComponentTuplizer (also extends org.hibernate.tuple.Tuplizer)
  • interface org.hibernate.tuple.Tuplizer
    • interface org.hibernate.tuple.component.ComponentTuplizer (also extends java.io.Serializable)


Uses of Package org.hibernate.tuple.component (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.tuple.component

Packages that use org.hibernate.tuple.component
org.hibernate.tuple.component |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Classes in org.hibernate.tuple.component used by org.hibernate.tuple.component
AbstractComponentTuplizer
Support for tuplizers relating to components.
ComponentTuplizer
Defines further responsibilities reagarding tuplization based on a mapped components.

Classes in org.hibernate.tuple.component used by org.hibernate.type
ComponentMetamodel
Centralizes metamodel information about a component.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ComponentTuplizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.component
Interface ComponentTuplizer

All Superinterfaces:
Serializable, Tuplizer
All Known Implementing Classes:
AbstractComponentTuplizer
public interface ComponentTuplizer
extends Tuplizer, Serializable

Defines further responsibilities reagarding tuplization based on a mapped components.

ComponentTuplizer implementations should have the following constructor signature: (org.hibernate.mapping.Component)

Author:
Gavin King, Steve Ebersole

Method Summary
Object | getParent(Object component) Retreive the current value of the parent property.
boolean | hasParentProperty() Does the component managed by this tuuplizer contain a parent property?
boolean | isMethodOf(Method method) Is the given method available via the managed component as a property getter?
void | setParent(Object component, Object parent, SessionFactoryImplementor factory) Set the value of the parent property.
Methods inherited from interface org.hibernate.tuple.Tuplizer
getMappedClass, getPropertyValue, getPropertyValues, instantiate, isInstance, setPropertyValues

Method Detail

getParent

public Object getParent(Object component)
Retreive the current value of the parent property.

Parameters:
component - The component instance from which to extract the parent property value.
Returns:
The current value of the parent property.

setParent

public void setParent(Object component,
                      Object parent,
                      SessionFactoryImplementor factory)
Set the value of the parent property.

Parameters:
component - The component instance on which to set the parent.
parent - The parent to be set on the comonent.
factory - The current session factory.

hasParentProperty

public boolean hasParentProperty()
Does the component managed by this tuuplizer contain a parent property?

Returns:
True if the component does contain a parent property; false otherwise.

isMethodOf

public boolean isMethodOf(Method method)
Is the given method available via the managed component as a property getter?

Parameters:
method - The method which to check against the managed component.
Returns:
True if the managed component is available from the managed component; else false.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractComponentTuplizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.component
Class AbstractComponentTuplizer

java.lang.Object
    extended by org.hibernate.tuple.component.AbstractComponentTuplizer
All Implemented Interfaces:
ComponentTuplizer, Serializable, Tuplizer
Direct Known Subclasses:
Dom4jComponentTuplizer, DynamicMapComponentTuplizer, PojoComponentTuplizer
public abstract class AbstractComponentTuplizer
extends Object
implements ComponentTuplizer

Support for tuplizers relating to components.

Author:
Gavin King, Steve Ebersole
See Also:
Serialized Form

Field Summary
protected Getter[] | getters
protected boolean | hasCustomAccessors
protected Instantiator | instantiator
protected int | propertySpan
protected Setter[] | setters
Constructor Summary
protected AbstractComponentTuplizer(Component component)
Method Summary
protected abstract Getter | buildGetter(Component component, Property prop)
protected abstract Instantiator | buildInstantiator(Component component)
protected abstract Setter | buildSetter(Component component, Property prop)
Object | getParent(Object component) Retreive the current value of the parent property.
Object | getPropertyValue(Object component, int i) Extract the value of a particular property from the given entity.
Object[] | getPropertyValues(Object component) Extract the current values contained on the given entity.
boolean | hasParentProperty() Does the component managed by this tuuplizer contain a parent property?
Object | instantiate() This method does not populate the component parent
boolean | isInstance(Object object) Is the given object considered an instance of the the entity (acconting for entity-mode) managed by this tuplizer.
boolean | isMethodOf(Method method) Is the given method available via the managed component as a property getter?
void | setParent(Object component, Object parent, SessionFactoryImplementor factory) Set the value of the parent property.
void | setPropertyValues(Object component, Object[] values) Inject the given values into the given entity.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.tuple.Tuplizer
getMappedClass

Field Detail

getters

protected final Getter[] getters

setters

protected final Setter[] setters

propertySpan

protected final int propertySpan

instantiator

protected final Instantiator instantiator

hasCustomAccessors

protected final boolean hasCustomAccessors
Constructor Detail

AbstractComponentTuplizer

protected AbstractComponentTuplizer(Component component)
Method Detail

buildInstantiator

protected abstract Instantiator buildInstantiator(Component component)

buildGetter

protected abstract Getter buildGetter(Component component,
                                      Property prop)

buildSetter

protected abstract Setter buildSetter(Component component,
                                      Property prop)

getPropertyValue

public Object getPropertyValue(Object component,
                               int i)
                        throws HibernateException
Description copied from interface: Tuplizer
Extract the value of a particular property from the given entity.

Specified by:
getPropertyValue in interface Tuplizer
Parameters:
component - The entity from which to extract the property value.
i - The index of the property for which to extract the value.
Returns:
The current value of the given property on the given entity.
Throws:
HibernateException

getPropertyValues

public Object[] getPropertyValues(Object component)
                           throws HibernateException
Description copied from interface: Tuplizer
Extract the current values contained on the given entity.

Specified by:
getPropertyValues in interface Tuplizer
Parameters:
component - The entity from which to extract values.
Returns:
The current property values.
Throws:
HibernateException

isInstance

public boolean isInstance(Object object)
Description copied from interface: Tuplizer
Is the given object considered an instance of the the entity (acconting for entity-mode) managed by this tuplizer.

Specified by:
isInstance in interface Tuplizer
Parameters:
object - The object to be checked.
Returns:
True if the object is considered as an instance of this entity within the given mode.

setPropertyValues

public void setPropertyValues(Object component,
                              Object[] values)
                       throws HibernateException
Description copied from interface: Tuplizer
Inject the given values into the given entity.

Specified by:
setPropertyValues in interface Tuplizer
Parameters:
component - The entity.
values - The values to be injected.
Throws:
HibernateException

instantiate

public Object instantiate()
                   throws HibernateException
This method does not populate the component parent

Specified by:
instantiate in interface Tuplizer
Returns:
The new, empty entity instance.
Throws:
HibernateException

getParent

public Object getParent(Object component)
Description copied from interface: ComponentTuplizer
Retreive the current value of the parent property.

Specified by:
getParent in interface ComponentTuplizer
Parameters:
component - The component instance from which to extract the parent property value.
Returns:
The current value of the parent property.

hasParentProperty

public boolean hasParentProperty()
Description copied from interface: ComponentTuplizer
Does the component managed by this tuuplizer contain a parent property?

Specified by:
hasParentProperty in interface ComponentTuplizer
Returns:
True if the component does contain a parent property; false otherwise.

isMethodOf

public boolean isMethodOf(Method method)
Description copied from interface: ComponentTuplizer
Is the given method available via the managed component as a property getter?

Specified by:
isMethodOf in interface ComponentTuplizer
Parameters:
method - The method which to check against the managed component.
Returns:
True if the managed component is available from the managed component; else false.

setParent

public void setParent(Object component,
                      Object parent,
                      SessionFactoryImplementor factory)
Description copied from interface: ComponentTuplizer
Set the value of the parent property.

Specified by:
setParent in interface ComponentTuplizer
Parameters:
component - The component instance on which to set the parent.
parent - The parent to be set on the comonent.
factory - The current session factory.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ComponentMetamodel (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.component
Class ComponentMetamodel

java.lang.Object
    extended by org.hibernate.tuple.component.ComponentMetamodel
All Implemented Interfaces:
Serializable
public class ComponentMetamodel
extends Object
implements Serializable

Centralizes metamodel information about a component.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
ComponentMetamodel(Component component)
Method Summary
StandardProperty[] | getProperties()
StandardProperty | getProperty(int index)
StandardProperty | getProperty(String propertyName)
int | getPropertyIndex(String propertyName)
int | getPropertySpan()
org.hibernate.tuple.component.ComponentEntityModeToTuplizerMapping | getTuplizerMapping()
boolean | isKey()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ComponentMetamodel

public ComponentMetamodel(Component component)
Method Detail

isKey

public boolean isKey()

getPropertySpan

public int getPropertySpan()

getProperties

public StandardProperty[] getProperties()

getProperty

public StandardProperty getProperty(int index)

getPropertyIndex

public int getPropertyIndex(String propertyName)

getProperty

public StandardProperty getProperty(String propertyName)

getTuplizerMapping

public org.hibernate.tuple.component.ComponentEntityModeToTuplizerMapping getTuplizerMapping()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dom4jComponentTuplizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.component
Class Dom4jComponentTuplizer

java.lang.Object
    extended by org.hibernate.tuple.component.AbstractComponentTuplizer
        extended by org.hibernate.tuple.component.Dom4jComponentTuplizer
All Implemented Interfaces:
ComponentTuplizer, Serializable, Tuplizer
public class Dom4jComponentTuplizer
extends AbstractComponentTuplizer

A ComponentTuplizer specific to the dom4j entity mode.

Author:
Gavin King, Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.tuple.component.AbstractComponentTuplizer
getters, hasCustomAccessors, instantiator, propertySpan, setters
Constructor Summary
Dom4jComponentTuplizer(Component component)
Method Summary
protected Getter | buildGetter(Component component, Property prop)
protected Instantiator | buildInstantiator(Component component)
protected Setter | buildSetter(Component component, Property prop)
Class | getMappedClass() Return the pojo class managed by this tuplizer.
Methods inherited from class org.hibernate.tuple.component.AbstractComponentTuplizer
getParent, getPropertyValue, getPropertyValues, hasParentProperty, instantiate, isInstance, isMethodOf, setParent, setPropertyValues
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Dom4jComponentTuplizer

public Dom4jComponentTuplizer(Component component)
Method Detail

getMappedClass

public Class getMappedClass()
Description copied from interface: Tuplizer
Return the pojo class managed by this tuplizer.

Need to determine how to best handle this for the Tuplizers for EntityModes other than POJO.

todo : be really nice to not have this here since it is essentially pojo specific...

Returns:
The persistent class.

buildInstantiator

protected Instantiator buildInstantiator(Component component)
Specified by:
buildInstantiator in class AbstractComponentTuplizer

buildGetter

protected Getter buildGetter(Component component,
                             Property prop)
Specified by:
buildGetter in class AbstractComponentTuplizer

buildSetter

protected Setter buildSetter(Component component,
                             Property prop)
Specified by:
buildSetter in class AbstractComponentTuplizer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DynamicMapComponentTuplizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.component
Class DynamicMapComponentTuplizer

java.lang.Object
    extended by org.hibernate.tuple.component.AbstractComponentTuplizer
        extended by org.hibernate.tuple.component.DynamicMapComponentTuplizer
All Implemented Interfaces:
ComponentTuplizer, Serializable, Tuplizer
public class DynamicMapComponentTuplizer
extends AbstractComponentTuplizer

A ComponentTuplizer specific to the dynamic-map entity mode.

Author:
Gavin King, Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.tuple.component.AbstractComponentTuplizer
getters, hasCustomAccessors, instantiator, propertySpan, setters
Constructor Summary
DynamicMapComponentTuplizer(Component component)
Method Summary
protected Getter | buildGetter(Component component, Property prop)
protected Instantiator | buildInstantiator(Component component)
protected Setter | buildSetter(Component component, Property prop)
Class | getMappedClass() Return the pojo class managed by this tuplizer.
Methods inherited from class org.hibernate.tuple.component.AbstractComponentTuplizer
getParent, getPropertyValue, getPropertyValues, hasParentProperty, instantiate, isInstance, isMethodOf, setParent, setPropertyValues
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynamicMapComponentTuplizer

public DynamicMapComponentTuplizer(Component component)
Method Detail

getMappedClass

public Class getMappedClass()
Description copied from interface: Tuplizer
Return the pojo class managed by this tuplizer.

Need to determine how to best handle this for the Tuplizers for EntityModes other than POJO.

todo : be really nice to not have this here since it is essentially pojo specific...

Returns:
The persistent class.

buildInstantiator

protected Instantiator buildInstantiator(Component component)
Specified by:
buildInstantiator in class AbstractComponentTuplizer

buildGetter

protected Getter buildGetter(Component component,
                             Property prop)
Specified by:
buildGetter in class AbstractComponentTuplizer

buildSetter

protected Setter buildSetter(Component component,
                             Property prop)
Specified by:
buildSetter in class AbstractComponentTuplizer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PojoComponentTuplizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.component
Class PojoComponentTuplizer

java.lang.Object
    extended by org.hibernate.tuple.component.AbstractComponentTuplizer
        extended by org.hibernate.tuple.component.PojoComponentTuplizer
All Implemented Interfaces:
ComponentTuplizer, Serializable, Tuplizer
public class PojoComponentTuplizer
extends AbstractComponentTuplizer

A ComponentTuplizer specific to the pojo entity mode.

Author:
Gavin King, Steve Ebersole
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.tuple.component.AbstractComponentTuplizer
getters, hasCustomAccessors, instantiator, propertySpan, setters
Constructor Summary
PojoComponentTuplizer(Component component)
Method Summary
protected Getter | buildGetter(Component component, Property prop)
protected Instantiator | buildInstantiator(Component component)
protected Setter | buildSetter(Component component, Property prop)
Class | getMappedClass() Return the pojo class managed by this tuplizer.
Object | getParent(Object component) Retreive the current value of the parent property.
Object[] | getPropertyValues(Object component) Extract the current values contained on the given entity.
boolean | hasParentProperty() Does the component managed by this tuuplizer contain a parent property?
boolean | isMethodOf(Method method) Is the given method available via the managed component as a property getter?
void | setParent(Object component, Object parent, SessionFactoryImplementor factory) Set the value of the parent property.
void | setPropertyValues(Object component, Object[] values) Inject the given values into the given entity.
Methods inherited from class org.hibernate.tuple.component.AbstractComponentTuplizer
getPropertyValue, instantiate, isInstance
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PojoComponentTuplizer

public PojoComponentTuplizer(Component component)
Method Detail

getMappedClass

public Class getMappedClass()
Description copied from interface: Tuplizer
Return the pojo class managed by this tuplizer.

Need to determine how to best handle this for the Tuplizers for EntityModes other than POJO.

todo : be really nice to not have this here since it is essentially pojo specific...

Returns:
The persistent class.

getPropertyValues

public Object[] getPropertyValues(Object component)
                           throws HibernateException
Description copied from interface: Tuplizer
Extract the current values contained on the given entity.

Specified by:
getPropertyValues in interface Tuplizer
Overrides:
getPropertyValues in class AbstractComponentTuplizer
Throws:
HibernateException

setPropertyValues

public void setPropertyValues(Object component,
                              Object[] values)
                       throws HibernateException
Description copied from interface: Tuplizer
Inject the given values into the given entity.

Specified by:
setPropertyValues in interface Tuplizer
Overrides:
setPropertyValues in class AbstractComponentTuplizer
Throws:
HibernateException

getParent

public Object getParent(Object component)
Description copied from interface: ComponentTuplizer
Retreive the current value of the parent property.

Specified by:
getParent in interface ComponentTuplizer
Overrides:
getParent in class AbstractComponentTuplizer

hasParentProperty

public boolean hasParentProperty()
Description copied from interface: ComponentTuplizer
Does the component managed by this tuuplizer contain a parent property?

Specified by:
hasParentProperty in interface ComponentTuplizer
Overrides:
hasParentProperty in class AbstractComponentTuplizer

isMethodOf

public boolean isMethodOf(Method method)
Description copied from interface: ComponentTuplizer
Is the given method available via the managed component as a property getter?

Specified by:
isMethodOf in interface ComponentTuplizer
Overrides:
isMethodOf in class AbstractComponentTuplizer

setParent

public void setParent(Object component,
                      Object parent,
                      SessionFactoryImplementor factory)
Description copied from interface: ComponentTuplizer
Set the value of the parent property.

Specified by:
setParent in interface ComponentTuplizer
Overrides:
setParent in class AbstractComponentTuplizer

buildInstantiator

protected Instantiator buildInstantiator(Component component)
Specified by:
buildInstantiator in class AbstractComponentTuplizer

buildGetter

protected Getter buildGetter(Component component,
                             Property prop)
Specified by:
buildGetter in class AbstractComponentTuplizer

buildSetter

protected Setter buildSetter(Component component,
                             Property prop)
Specified by:
buildSetter in class AbstractComponentTuplizer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.tuple.entity (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.tuple.entity

Interface Summary
EntityTuplizer Defines further responsibilities reagarding tuplization based on a mapped entity.

Class Summary
AbstractEntityTuplizer | Support for tuplizers relating to entities.
Dom4jEntityTuplizer | An EntityTuplizer specific to the dom4j entity mode.
DynamicMapEntityTuplizer | An EntityTuplizer specific to the dynamic-map entity mode.
EntityEntityModeToTuplizerMapping | Handles mapping EntityModes to EntityTuplizers.
EntityMetamodel | Centralizes metamodel information about an entity.
PojoEntityTuplizer | An EntityTuplizer specific to the pojo entity mode.


org.hibernate.tuple.entity Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.tuple.entity

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.tuple.entity.AbstractEntityTuplizer (implements org.hibernate.tuple.entity.EntityTuplizer)
      • class org.hibernate.tuple.entity.Dom4jEntityTuplizer
      • class org.hibernate.tuple.entity.DynamicMapEntityTuplizer
      • class org.hibernate.tuple.entity.PojoEntityTuplizer
    • class org.hibernate.tuple.entity.EntityMetamodel (implements java.io.Serializable)
    • class org.hibernate.tuple.EntityModeToTuplizerMapping (implements java.io.Serializable)
      • class org.hibernate.tuple.entity.EntityEntityModeToTuplizerMapping (implements java.io.Serializable)

Interface Hierarchy

  • interface org.hibernate.tuple.Tuplizer
    • interface org.hibernate.tuple.entity.EntityTuplizer


Uses of Package org.hibernate.tuple.entity (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.tuple.entity

Packages that use org.hibernate.tuple.entity
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.tuple.entity |

Classes in org.hibernate.tuple.entity used by org.hibernate.persister.entity
EntityMetamodel
Centralizes metamodel information about an entity.
EntityTuplizer
Defines further responsibilities reagarding tuplization based on a mapped entity.

Classes in org.hibernate.tuple.entity used by org.hibernate.tuple.entity
AbstractEntityTuplizer
Support for tuplizers relating to entities.
EntityMetamodel
Centralizes metamodel information about an entity.
EntityTuplizer
Defines further responsibilities reagarding tuplization based on a mapped entity.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


EntityTuplizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.entity
Interface EntityTuplizer

All Superinterfaces:
Tuplizer
All Known Implementing Classes:
AbstractEntityTuplizer
public interface EntityTuplizer
extends Tuplizer

Defines further responsibilities reagarding tuplization based on a mapped entity.

EntityTuplizer implementations should have the following constructor signature: (org.hibernate.tuple.entity.EntityMetamodel, org.hibernate.mapping.PersistentClass)

Author:
Gavin King, Steve Ebersole

Method Summary
void | afterInitialize(Object entity, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Called just after the entities properties have been initialized.
Object | createProxy(Serializable id, SessionImplementor session) Generates an appropriate proxy representation of this entity for this entity-mode.
Class | getConcreteProxyClass() Returns the java class to which generated proxies will be typed.
Serializable | getIdentifier(Object entity) Extract the identifier value from the given entity.
Object | getPropertyValue(Object entity, String propertyName) Extract the value of a particular property from the given entity.
Object[] | getPropertyValuesToInsert(Object entity, Map mergeMap, SessionImplementor session) Extract the values of the insertable properties of the entity (including backrefs)
Object | getVersion(Object entity) Extract the value of the version property from the given entity.
boolean | hasProxy() Does this entity, for this mode, present a possibility for proxying?
boolean | hasUninitializedLazyProperties(Object entity) Does the given entity instance have any currently uninitialized lazy properties?
Object | instantiate(Serializable id) Create an entity instance initialized with the given identifier.
boolean | isInstrumented() Is it an instrumented POJO?
boolean | isLifecycleImplementor() Does the class managed by this tuplizer implement the Lifecycle interface.
boolean | isValidatableImplementor() Does the class managed by this tuplizer implement the Validatable interface.
void | resetIdentifier(Object entity, Serializable currentId, Object currentVersion) Inject the given identifier and version into the entity, in order to "roll back" to their original values.
void | setIdentifier(Object entity, Serializable id) Inject the identifier value into the given entity.
void | setPropertyValue(Object entity, int i, Object value) Inject the value of a particular property.
void | setPropertyValue(Object entity, String propertyName, Object value) Inject the value of a particular property.
Methods inherited from interface org.hibernate.tuple.Tuplizer
getMappedClass, getPropertyValue, getPropertyValues, instantiate, isInstance, setPropertyValues

Method Detail

instantiate

public Object instantiate(Serializable id)
                   throws HibernateException
Create an entity instance initialized with the given identifier.

Parameters:
id - The identifier value for the entity to be instantiated.
Returns:
The instantiated entity.
Throws:
HibernateException

getIdentifier

public Serializable getIdentifier(Object entity)
                           throws HibernateException
Extract the identifier value from the given entity.

Parameters:
entity - The entity from which to extract the identifier value.
Returns:
The identifier value.
Throws:
HibernateException - If the entity does not define an identifier property, or an error occurrs accessing its value.

setIdentifier

public void setIdentifier(Object entity,
                          Serializable id)
                   throws HibernateException
Inject the identifier value into the given entity.

Has no effect if the entity does not define an identifier property

Parameters:
entity - The entity to inject with the identifier value.
id - The value to be injected as the identifier.
Throws:
HibernateException

resetIdentifier

public void resetIdentifier(Object entity,
                            Serializable currentId,
                            Object currentVersion)
Inject the given identifier and version into the entity, in order to "roll back" to their original values.

Parameters:
currentId - The identifier value to inject into the entity.
currentVersion - The version value to inject into the entity.

getVersion

public Object getVersion(Object entity)
                  throws HibernateException
Extract the value of the version property from the given entity.

Parameters:
entity - The entity from which to extract the version value.
Returns:
The value of the version property, or null if not versioned.
Throws:
HibernateException

setPropertyValue

public void setPropertyValue(Object entity,
                             int i,
                             Object value)
                      throws HibernateException
Inject the value of a particular property.

Parameters:
entity - The entity into which to inject the value.
i - The property's index.
value - The property value to inject.
Throws:
HibernateException

setPropertyValue

public void setPropertyValue(Object entity,
                             String propertyName,
                             Object value)
                      throws HibernateException
Inject the value of a particular property.

Parameters:
entity - The entity into which to inject the value.
propertyName - The name of the property.
value - The property value to inject.
Throws:
HibernateException

getPropertyValuesToInsert

public Object[] getPropertyValuesToInsert(Object entity,
                                          Map mergeMap,
                                          SessionImplementor session)
                                   throws HibernateException
Extract the values of the insertable properties of the entity (including backrefs)

Parameters:
entity - The entity from which to extract.
mergeMap - a map of instances being merged to merged instances
session - The session in which the resuest is being made.
Returns:
The insertable property values.
Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object entity,
                               String propertyName)
                        throws HibernateException
Extract the value of a particular property from the given entity.

Parameters:
entity - The entity from which to extract the property value.
propertyName - The name of the property for which to extract the value.
Returns:
The current value of the given property on the given entity.
Throws:
HibernateException

afterInitialize

public void afterInitialize(Object entity,
                            boolean lazyPropertiesAreUnfetched,
                            SessionImplementor session)
Called just after the entities properties have been initialized.

Parameters:
entity - The entity being initialized.
lazyPropertiesAreUnfetched - Are defined lazy properties currently unfecthed
session - The session initializing this entity.

hasProxy

public boolean hasProxy()
Does this entity, for this mode, present a possibility for proxying?

Returns:
True if this tuplizer can generate proxies for this entity.

createProxy

public Object createProxy(Serializable id,
                          SessionImplementor session)
                   throws HibernateException
Generates an appropriate proxy representation of this entity for this entity-mode.

Parameters:
id - The id of the instance for which to generate a proxy.
session - The session to which the proxy should be bound.
Returns:
The generate proxies.
Throws:
HibernateException - Indicates an error generating the proxy.

isLifecycleImplementor

public boolean isLifecycleImplementor()
Does the class managed by this tuplizer implement the Lifecycle interface.

Returns:
True if the Lifecycle interface is implemented; false otherwise.

isValidatableImplementor

public boolean isValidatableImplementor()
Does the class managed by this tuplizer implement the Validatable interface.

Returns:
True if the Validatable interface is implemented; false otherwise.

getConcreteProxyClass

public Class getConcreteProxyClass()
Returns the java class to which generated proxies will be typed.

Returns:
The java class to which generated proxies will be typed

hasUninitializedLazyProperties

public boolean hasUninitializedLazyProperties(Object entity)
Does the given entity instance have any currently uninitialized lazy properties?

Parameters:
entity - The entity to be check for uninitialized lazy properties.
Returns:
True if uninitialized lazy properties were found; false otherwise.

isInstrumented

public boolean isInstrumented()
Is it an instrumented POJO?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractEntityTuplizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.entity
Class AbstractEntityTuplizer

java.lang.Object
    extended by org.hibernate.tuple.entity.AbstractEntityTuplizer
All Implemented Interfaces:
EntityTuplizer, Tuplizer
Direct Known Subclasses:
Dom4jEntityTuplizer, DynamicMapEntityTuplizer, PojoEntityTuplizer
public abstract class AbstractEntityTuplizer
extends Object
implements EntityTuplizer

Support for tuplizers relating to entities.

Author:
Steve Ebersole, Gavin King

Field Summary
protected Getter[] | getters
protected boolean | hasCustomAccessors
protected int | propertySpan
protected Setter[] | setters
Constructor Summary
AbstractEntityTuplizer(EntityMetamodel entityMetamodel, PersistentClass mappingInfo)
Constructs a new AbstractEntityTuplizer instance.
Method Summary
void | afterInitialize(Object entity, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Called just after the entities properties have been initialized.
protected abstract Instantiator | buildInstantiator(PersistentClass mappingInfo) Build an appropriate Instantiator for the given mapped entity.
protected abstract Getter | buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Getter for the given property.
protected abstract Setter | buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Setter for the given property.
protected abstract ProxyFactory | buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter) Build an appropriate ProxyFactory for the given mapped entity.
Object | createProxy(Serializable id, SessionImplementor session) Generates an appropriate proxy representation of this entity for this entity-mode.
protected Object | getComponentValue(ComponentType type, Object component, String propertyPath) Extract a component property value.
protected EntityMetamodel | getEntityMetamodel()
protected abstract EntityMode | getEntityMode() Return the entity-mode handled by this tuplizer instance.
protected String | getEntityName() Retreives the defined entity-name for the tuplized entity.
protected SessionFactoryImplementor | getFactory()
Serializable | getIdentifier(Object entity) Extract the identifier value from the given entity.
protected Instantiator | getInstantiator()
Object | getPropertyValue(Object entity, int i) Extract the value of a particular property from the given entity.
Object | getPropertyValue(Object entity, String propertyPath) Extract the value of a particular property from the given entity.
Object[] | getPropertyValues(Object entity) Extract the current values contained on the given entity.
Object[] | getPropertyValuesToInsert(Object entity, Map mergeMap, SessionImplementor session) Extract the values of the insertable properties of the entity (including backrefs)
protected ProxyFactory | getProxyFactory()
protected Set | getSubclassEntityNames() Retreives the defined entity-names for any subclasses defined for this entity.
Object | getVersion(Object entity) Extract the value of the version property from the given entity.
boolean | hasProxy() Does this entity, for this mode, present a possibility for proxying?
boolean | hasUninitializedLazyProperties(Object entity) Does the given entity instance have any currently uninitialized lazy properties?
Object | instantiate() Generate a new, empty entity.
Object | instantiate(Serializable id) Create an entity instance initialized with the given identifier.
boolean | isInstance(Object object) Is the given object considered an instance of the the entity (acconting for entity-mode) managed by this tuplizer.
boolean | isLifecycleImplementor() Does the class managed by this tuplizer implement the Lifecycle interface.
boolean | isValidatableImplementor() Does the class managed by this tuplizer implement the Validatable interface.
void | resetIdentifier(Object entity, Serializable currentId, Object currentVersion) Inject the given identifier and version into the entity, in order to "roll back" to their original values.
void | setIdentifier(Object entity, Serializable id) Inject the identifier value into the given entity.
void | setPropertyValue(Object entity, int i, Object value) Inject the value of a particular property.
void | setPropertyValue(Object entity, String propertyName, Object value) Inject the value of a particular property.
void | setPropertyValues(Object entity, Object[] values) Inject the given values into the given entity.
protected boolean | shouldGetAllProperties(Object entity)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.tuple.entity.EntityTuplizer
getConcreteProxyClass, isInstrumented
Methods inherited from interface org.hibernate.tuple.Tuplizer
getMappedClass

Field Detail

getters

protected final Getter[] getters

setters

protected final Setter[] setters

propertySpan

protected final int propertySpan

hasCustomAccessors

protected final boolean hasCustomAccessors
Constructor Detail

AbstractEntityTuplizer

public AbstractEntityTuplizer(EntityMetamodel entityMetamodel,
                              PersistentClass mappingInfo)
Constructs a new AbstractEntityTuplizer instance.

Parameters:
entityMetamodel - The "interpreted" information relating to the mapped entity.
mappingInfo - The parsed "raw" mapping data relating to the given entity.
Method Detail

getEntityMode

protected abstract EntityMode getEntityMode()
Return the entity-mode handled by this tuplizer instance.

Returns:
The entity-mode

buildPropertyGetter

protected abstract Getter buildPropertyGetter(Property mappedProperty,
                                              PersistentClass mappedEntity)
Build an appropriate Getter for the given property.

Parameters:
mappedProperty - The property to be accessed via the built Getter.
mappedEntity - The entity information regarding the mapped entity owning this property.
Returns:
An appropriate Getter instance.

buildPropertySetter

protected abstract Setter buildPropertySetter(Property mappedProperty,
                                              PersistentClass mappedEntity)
Build an appropriate Setter for the given property.

Parameters:
mappedProperty - The property to be accessed via the built Setter.
mappedEntity - The entity information regarding the mapped entity owning this property.
Returns:
An appropriate Setter instance.

buildInstantiator

protected abstract Instantiator buildInstantiator(PersistentClass mappingInfo)
Build an appropriate Instantiator for the given mapped entity.

Parameters:
mappingInfo - The mapping information regarding the mapped entity.
Returns:
An appropriate Instantiator instance.

buildProxyFactory

protected abstract ProxyFactory buildProxyFactory(PersistentClass mappingInfo,
                                                  Getter idGetter,
                                                  Setter idSetter)
Build an appropriate ProxyFactory for the given mapped entity.

Parameters:
mappingInfo - The mapping information regarding the mapped entity.
idGetter - The constructed Getter relating to the entity's id property.
idSetter - The constructed Setter relating to the entity's id property.
Returns:
An appropriate ProxyFactory instance.

getEntityName

protected String getEntityName()
Retreives the defined entity-name for the tuplized entity.

Returns:
The entity-name.

getSubclassEntityNames

protected Set getSubclassEntityNames()
Retreives the defined entity-names for any subclasses defined for this entity.

Returns:
Any subclass entity-names.

getIdentifier

public Serializable getIdentifier(Object entity)
                           throws HibernateException
Description copied from interface: EntityTuplizer
Extract the identifier value from the given entity.

Specified by:
getIdentifier in interface EntityTuplizer
Parameters:
entity - The entity from which to extract the identifier value.
Returns:
The identifier value.
Throws:
HibernateException - If the entity does not define an identifier property, or an error occurrs accessing its value.

setIdentifier

public void setIdentifier(Object entity,
                          Serializable id)
                   throws HibernateException
Description copied from interface: EntityTuplizer
Inject the identifier value into the given entity.

Has no effect if the entity does not define an identifier property

Specified by:
setIdentifier in interface EntityTuplizer
Parameters:
entity - The entity to inject with the identifier value.
id - The value to be injected as the identifier.
Throws:
HibernateException

resetIdentifier

public void resetIdentifier(Object entity,
                            Serializable currentId,
                            Object currentVersion)
Description copied from interface: EntityTuplizer
Inject the given identifier and version into the entity, in order to "roll back" to their original values.

Specified by:
resetIdentifier in interface EntityTuplizer
Parameters:
currentId - The identifier value to inject into the entity.
currentVersion - The version value to inject into the entity.

getVersion

public Object getVersion(Object entity)
                  throws HibernateException
Description copied from interface: EntityTuplizer
Extract the value of the version property from the given entity.

Specified by:
getVersion in interface EntityTuplizer
Parameters:
entity - The entity from which to extract the version value.
Returns:
The value of the version property, or null if not versioned.
Throws:
HibernateException

shouldGetAllProperties

protected boolean shouldGetAllProperties(Object entity)

getPropertyValues

public Object[] getPropertyValues(Object entity)
                           throws HibernateException
Description copied from interface: Tuplizer
Extract the current values contained on the given entity.

Specified by:
getPropertyValues in interface Tuplizer
Parameters:
entity - The entity from which to extract values.
Returns:
The current property values.
Throws:
HibernateException

getPropertyValuesToInsert

public Object[] getPropertyValuesToInsert(Object entity,
                                          Map mergeMap,
                                          SessionImplementor session)
                                   throws HibernateException
Description copied from interface: EntityTuplizer
Extract the values of the insertable properties of the entity (including backrefs)

Specified by:
getPropertyValuesToInsert in interface EntityTuplizer
Parameters:
entity - The entity from which to extract.
mergeMap - a map of instances being merged to merged instances
session - The session in which the resuest is being made.
Returns:
The insertable property values.
Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object entity,
                               int i)
                        throws HibernateException
Description copied from interface: Tuplizer
Extract the value of a particular property from the given entity.

Specified by:
getPropertyValue in interface Tuplizer
Parameters:
entity - The entity from which to extract the property value.
i - The index of the property for which to extract the value.
Returns:
The current value of the given property on the given entity.
Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object entity,
                               String propertyPath)
                        throws HibernateException
Description copied from interface: EntityTuplizer
Extract the value of a particular property from the given entity.

Specified by:
getPropertyValue in interface EntityTuplizer
Parameters:
entity - The entity from which to extract the property value.
propertyPath - The name of the property for which to extract the value.
Returns:
The current value of the given property on the given entity.
Throws:
HibernateException

getComponentValue

protected Object getComponentValue(ComponentType type,
                                   Object component,
                                   String propertyPath)
Extract a component property value.

Parameters:
type - The component property types.
component - The component instance itself.
propertyPath - The property path for the property to be extracted.
Returns:
The property value extracted.

setPropertyValues

public void setPropertyValues(Object entity,
                              Object[] values)
                       throws HibernateException
Description copied from interface: Tuplizer
Inject the given values into the given entity.

Specified by:
setPropertyValues in interface Tuplizer
Parameters:
entity - The entity.
values - The values to be injected.
Throws:
HibernateException

setPropertyValue

public void setPropertyValue(Object entity,
                             int i,
                             Object value)
                      throws HibernateException
Description copied from interface: EntityTuplizer
Inject the value of a particular property.

Specified by:
setPropertyValue in interface EntityTuplizer
Parameters:
entity - The entity into which to inject the value.
i - The property's index.
value - The property value to inject.
Throws:
HibernateException

setPropertyValue

public void setPropertyValue(Object entity,
                             String propertyName,
                             Object value)
                      throws HibernateException
Description copied from interface: EntityTuplizer
Inject the value of a particular property.

Specified by:
setPropertyValue in interface EntityTuplizer
Parameters:
entity - The entity into which to inject the value.
propertyName - The name of the property.
value - The property value to inject.
Throws:
HibernateException

instantiate

public final Object instantiate(Serializable id)
                         throws HibernateException
Description copied from interface: EntityTuplizer
Create an entity instance initialized with the given identifier.

Specified by:
instantiate in interface EntityTuplizer
Parameters:
id - The identifier value for the entity to be instantiated.
Returns:
The instantiated entity.
Throws:
HibernateException

instantiate

public final Object instantiate()
                         throws HibernateException
Description copied from interface: Tuplizer
Generate a new, empty entity.

Specified by:
instantiate in interface Tuplizer
Returns:
The new, empty entity instance.
Throws:
HibernateException

afterInitialize

public void afterInitialize(Object entity,
                            boolean lazyPropertiesAreUnfetched,
                            SessionImplementor session)
Description copied from interface: EntityTuplizer
Called just after the entities properties have been initialized.

Specified by:
afterInitialize in interface EntityTuplizer
Parameters:
entity - The entity being initialized.
lazyPropertiesAreUnfetched - Are defined lazy properties currently unfecthed
session - The session initializing this entity.

hasUninitializedLazyProperties

public boolean hasUninitializedLazyProperties(Object entity)
Description copied from interface: EntityTuplizer
Does the given entity instance have any currently uninitialized lazy properties?

Specified by:
hasUninitializedLazyProperties in interface EntityTuplizer
Parameters:
entity - The entity to be check for uninitialized lazy properties.
Returns:
True if uninitialized lazy properties were found; false otherwise.

isInstance

public final boolean isInstance(Object object)
Description copied from interface: Tuplizer
Is the given object considered an instance of the the entity (acconting for entity-mode) managed by this tuplizer.

Specified by:
isInstance in interface Tuplizer
Parameters:
object - The object to be checked.
Returns:
True if the object is considered as an instance of this entity within the given mode.

hasProxy

public boolean hasProxy()
Description copied from interface: EntityTuplizer
Does this entity, for this mode, present a possibility for proxying?

Specified by:
hasProxy in interface EntityTuplizer
Returns:
True if this tuplizer can generate proxies for this entity.

createProxy

public final Object createProxy(Serializable id,
                                SessionImplementor session)
                         throws HibernateException
Description copied from interface: EntityTuplizer
Generates an appropriate proxy representation of this entity for this entity-mode.

Specified by:
createProxy in interface EntityTuplizer
Parameters:
id - The id of the instance for which to generate a proxy.
session - The session to which the proxy should be bound.
Returns:
The generate proxies.
Throws:
HibernateException - Indicates an error generating the proxy.

isLifecycleImplementor

public boolean isLifecycleImplementor()
Description copied from interface: EntityTuplizer
Does the class managed by this tuplizer implement the Lifecycle interface.

Specified by:
isLifecycleImplementor in interface EntityTuplizer
Returns:
True if the Lifecycle interface is implemented; false otherwise.

isValidatableImplementor

public boolean isValidatableImplementor()
Description copied from interface: EntityTuplizer
Does the class managed by this tuplizer implement the Validatable interface.

Specified by:
isValidatableImplementor in interface EntityTuplizer
Returns:
True if the Validatable interface is implemented; false otherwise.

getEntityMetamodel

protected final EntityMetamodel getEntityMetamodel()

getFactory

protected final SessionFactoryImplementor getFactory()

getInstantiator

protected final Instantiator getInstantiator()

getProxyFactory

protected final ProxyFactory getProxyFactory()

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Dom4jEntityTuplizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.entity
Class Dom4jEntityTuplizer

java.lang.Object
    extended by org.hibernate.tuple.entity.AbstractEntityTuplizer
        extended by org.hibernate.tuple.entity.Dom4jEntityTuplizer
All Implemented Interfaces:
EntityTuplizer, Tuplizer
public class Dom4jEntityTuplizer
extends AbstractEntityTuplizer

An EntityTuplizer specific to the dom4j entity mode.

Author:
Steve Ebersole, Gavin King

Field Summary
Fields inherited from class org.hibernate.tuple.entity.AbstractEntityTuplizer
getters, hasCustomAccessors, propertySpan, setters
Method Summary
protected Instantiator | buildInstantiator(PersistentClass persistentClass) Build an appropriate Instantiator for the given mapped entity.
protected Getter | buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Getter for the given property.
protected Setter | buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Setter for the given property.
protected ProxyFactory | buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter) Build an appropriate ProxyFactory for the given mapped entity.
Class | getConcreteProxyClass() Returns the java class to which generated proxies will be typed.
EntityMode | getEntityMode() Return the entity-mode handled by this tuplizer instance.
Serializable | getIdentifier(Object entityOrId) Extract the identifier value from the given entity.
Class | getMappedClass() Return the pojo class managed by this tuplizer.
boolean | isInstrumented() Is it an instrumented POJO?
Methods inherited from class org.hibernate.tuple.entity.AbstractEntityTuplizer
afterInitialize, createProxy, getComponentValue, getEntityMetamodel, getEntityName, getFactory, getInstantiator, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValuesToInsert, getProxyFactory, getSubclassEntityNames, getVersion, hasProxy, hasUninitializedLazyProperties, instantiate, instantiate, isInstance, isLifecycleImplementor, isValidatableImplementor, resetIdentifier, setIdentifier, setPropertyValue, setPropertyValue, setPropertyValues, shouldGetAllProperties, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getEntityMode

public EntityMode getEntityMode()
Description copied from class: AbstractEntityTuplizer
Return the entity-mode handled by this tuplizer instance.

Specified by:
getEntityMode in class AbstractEntityTuplizer
Returns:
The entity-mode

buildPropertyGetter

protected Getter buildPropertyGetter(Property mappedProperty,
                                     PersistentClass mappedEntity)
Description copied from class: AbstractEntityTuplizer
Build an appropriate Getter for the given property.

Specified by:
buildPropertyGetter in class AbstractEntityTuplizer
Parameters:
mappedProperty - The property to be accessed via the built Getter.
mappedEntity - The entity information regarding the mapped entity owning this property.
Returns:
An appropriate Getter instance.

buildPropertySetter

protected Setter buildPropertySetter(Property mappedProperty,
                                     PersistentClass mappedEntity)
Description copied from class: AbstractEntityTuplizer
Build an appropriate Setter for the given property.

Specified by:
buildPropertySetter in class AbstractEntityTuplizer
Parameters:
mappedProperty - The property to be accessed via the built Setter.
mappedEntity - The entity information regarding the mapped entity owning this property.
Returns:
An appropriate Setter instance.

buildInstantiator

protected Instantiator buildInstantiator(PersistentClass persistentClass)
Description copied from class: AbstractEntityTuplizer
Build an appropriate Instantiator for the given mapped entity.

Specified by:
buildInstantiator in class AbstractEntityTuplizer
Parameters:
persistentClass - The mapping information regarding the mapped entity.
Returns:
An appropriate Instantiator instance.

getIdentifier

public Serializable getIdentifier(Object entityOrId)
                           throws HibernateException
Description copied from interface: EntityTuplizer
Extract the identifier value from the given entity.

Specified by:
getIdentifier in interface EntityTuplizer
Overrides:
getIdentifier in class AbstractEntityTuplizer
Throws:
HibernateException

buildProxyFactory

protected ProxyFactory buildProxyFactory(PersistentClass mappingInfo,
                                         Getter idGetter,
                                         Setter idSetter)
Description copied from class: AbstractEntityTuplizer
Build an appropriate ProxyFactory for the given mapped entity.

Specified by:
buildProxyFactory in class AbstractEntityTuplizer
Parameters:
mappingInfo - The mapping information regarding the mapped entity.
idGetter - The constructed Getter relating to the entity's id property.
idSetter - The constructed Setter relating to the entity's id property.
Returns:
An appropriate ProxyFactory instance.

getMappedClass

public Class getMappedClass()
Description copied from interface: Tuplizer
Return the pojo class managed by this tuplizer.

Need to determine how to best handle this for the Tuplizers for EntityModes other than POJO.

todo : be really nice to not have this here since it is essentially pojo specific...

Returns:
The persistent class.

getConcreteProxyClass

public Class getConcreteProxyClass()
Description copied from interface: EntityTuplizer
Returns the java class to which generated proxies will be typed.

Returns:
The java class to which generated proxies will be typed

isInstrumented

public boolean isInstrumented()
Description copied from interface: EntityTuplizer
Is it an instrumented POJO?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DynamicMapEntityTuplizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.entity
Class DynamicMapEntityTuplizer

java.lang.Object
    extended by org.hibernate.tuple.entity.AbstractEntityTuplizer
        extended by org.hibernate.tuple.entity.DynamicMapEntityTuplizer
All Implemented Interfaces:
EntityTuplizer, Tuplizer
public class DynamicMapEntityTuplizer
extends AbstractEntityTuplizer

An EntityTuplizer specific to the dynamic-map entity mode.

Author:
Steve Ebersole, Gavin King

Field Summary
Fields inherited from class org.hibernate.tuple.entity.AbstractEntityTuplizer
getters, hasCustomAccessors, propertySpan, setters
Method Summary
protected Instantiator | buildInstantiator(PersistentClass mappingInfo) Build an appropriate Instantiator for the given mapped entity.
protected Getter | buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Getter for the given property.
protected Setter | buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Setter for the given property.
protected ProxyFactory | buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter) Build an appropriate ProxyFactory for the given mapped entity.
Class | getConcreteProxyClass() Returns the java class to which generated proxies will be typed.
EntityMode | getEntityMode() Return the entity-mode handled by this tuplizer instance.
Class | getMappedClass() Return the pojo class managed by this tuplizer.
boolean | isInstrumented() Is it an instrumented POJO?
Methods inherited from class org.hibernate.tuple.entity.AbstractEntityTuplizer
afterInitialize, createProxy, getComponentValue, getEntityMetamodel, getEntityName, getFactory, getIdentifier, getInstantiator, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValuesToInsert, getProxyFactory, getSubclassEntityNames, getVersion, hasProxy, hasUninitializedLazyProperties, instantiate, instantiate, isInstance, isLifecycleImplementor, isValidatableImplementor, resetIdentifier, setIdentifier, setPropertyValue, setPropertyValue, setPropertyValues, shouldGetAllProperties, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Method Detail

getEntityMode

public EntityMode getEntityMode()
Description copied from class: AbstractEntityTuplizer
Return the entity-mode handled by this tuplizer instance.

Specified by:
getEntityMode in class AbstractEntityTuplizer
Returns:
The entity-mode

buildPropertyGetter

protected Getter buildPropertyGetter(Property mappedProperty,
                                     PersistentClass mappedEntity)
Description copied from class: AbstractEntityTuplizer
Build an appropriate Getter for the given property.

Specified by:
buildPropertyGetter in class AbstractEntityTuplizer
Parameters:
mappedProperty - The property to be accessed via the built Getter.
mappedEntity - The entity information regarding the mapped entity owning this property.
Returns:
An appropriate Getter instance.

buildPropertySetter

protected Setter buildPropertySetter(Property mappedProperty,
                                     PersistentClass mappedEntity)
Description copied from class: AbstractEntityTuplizer
Build an appropriate Setter for the given property.

Specified by:
buildPropertySetter in class AbstractEntityTuplizer
Parameters:
mappedProperty - The property to be accessed via the built Setter.
mappedEntity - The entity information regarding the mapped entity owning this property.
Returns:
An appropriate Setter instance.

buildInstantiator

protected Instantiator buildInstantiator(PersistentClass mappingInfo)
Description copied from class: AbstractEntityTuplizer
Build an appropriate Instantiator for the given mapped entity.

Specified by:
buildInstantiator in class AbstractEntityTuplizer
Parameters:
mappingInfo - The mapping information regarding the mapped entity.
Returns:
An appropriate Instantiator instance.

buildProxyFactory

protected ProxyFactory buildProxyFactory(PersistentClass mappingInfo,
                                         Getter idGetter,
                                         Setter idSetter)
Description copied from class: AbstractEntityTuplizer
Build an appropriate ProxyFactory for the given mapped entity.

Specified by:
buildProxyFactory in class AbstractEntityTuplizer
Parameters:
mappingInfo - The mapping information regarding the mapped entity.
idGetter - The constructed Getter relating to the entity's id property.
idSetter - The constructed Setter relating to the entity's id property.
Returns:
An appropriate ProxyFactory instance.

getMappedClass

public Class getMappedClass()
Description copied from interface: Tuplizer
Return the pojo class managed by this tuplizer.

Need to determine how to best handle this for the Tuplizers for EntityModes other than POJO.

todo : be really nice to not have this here since it is essentially pojo specific...

Returns:
The persistent class.

getConcreteProxyClass

public Class getConcreteProxyClass()
Description copied from interface: EntityTuplizer
Returns the java class to which generated proxies will be typed.

Returns:
The java class to which generated proxies will be typed

isInstrumented

public boolean isInstrumented()
Description copied from interface: EntityTuplizer
Is it an instrumented POJO?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityEntityModeToTuplizerMapping (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.entity
Class EntityEntityModeToTuplizerMapping

java.lang.Object
    extended by org.hibernate.tuple.EntityModeToTuplizerMapping
        extended by org.hibernate.tuple.entity.EntityEntityModeToTuplizerMapping
All Implemented Interfaces:
Serializable
public class EntityEntityModeToTuplizerMapping
extends EntityModeToTuplizerMapping
implements Serializable

Handles mapping EntityModes to EntityTuplizers.

Most of the handling is really in the super class; here we just create the tuplizers and add them to the superclass

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
EntityEntityModeToTuplizerMapping(PersistentClass mappedEntity, EntityMetamodel em)
Instantiates a EntityEntityModeToTuplizerMapping based on the given entity mapping and metamodel definitions.
Methods inherited from class org.hibernate.tuple.EntityModeToTuplizerMapping
addTuplizer, getTuplizer, getTuplizerOrNull, guessEntityMode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EntityEntityModeToTuplizerMapping

public EntityEntityModeToTuplizerMapping(PersistentClass mappedEntity,
                                         EntityMetamodel em)
Instantiates a EntityEntityModeToTuplizerMapping based on the given entity mapping and metamodel definitions.

Parameters:
mappedEntity - The entity mapping definition.
em - The entity metamodel definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityMetamodel (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.entity
Class EntityMetamodel

java.lang.Object
    extended by org.hibernate.tuple.entity.EntityMetamodel
All Implemented Interfaces:
Serializable
public class EntityMetamodel
extends Object
implements Serializable

Centralizes metamodel information about an entity.

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
EntityMetamodel(PersistentClass persistentClass, SessionFactoryImplementor sessionFactory)
Method Summary
CascadeStyle[] | getCascadeStyles()
EntityType | getEntityType()
IdentifierProperty | getIdentifierProperty()
String | getName()
int[] | getNaturalIdentifierProperties()
boolean[] | getNonlazyPropertyUpdateability()
int | getOptimisticLockMode()
StandardProperty[] | getProperties()
boolean[] | getPropertyCheckability()
int | getPropertyIndex(String propertyName)
Integer | getPropertyIndexOrNull(String propertyName)
boolean[] | getPropertyInsertability()
boolean[] | getPropertyInsertGeneration()
boolean[] | getPropertyLaziness()
String[] | getPropertyNames()
boolean[] | getPropertyNullability()
int | getPropertySpan()
Type[] | getPropertyTypes()
boolean[] | getPropertyUpdateability()
boolean[] | getPropertyUpdateGeneration()
boolean[] | getPropertyVersionability()
String | getRootName()
SessionFactoryImplementor | getSessionFactory()
Set | getSubclassEntityNames()
String | getSuperclass()
EntityTuplizer | getTuplizer(EntityMode entityMode)
EntityTuplizer | getTuplizerOrNull(EntityMode entityMode)
VersionProperty | getVersionProperty()
int | getVersionPropertyIndex()
EntityMode | guessEntityMode(Object object)
boolean | hasCascades()
boolean | hasCollections()
boolean | hasLazyProperties()
boolean | hasMutableProperties()
boolean | hasNaturalIdentifier()
boolean | hasSubclasses()
boolean | isAbstract()
boolean | isDynamicInsert()
boolean | isDynamicUpdate()
boolean | isExplicitPolymorphism()
boolean | isInherited()
boolean | isLazy()
boolean | isMutable()
boolean | isPolymorphic()
boolean | isSelectBeforeUpdate()
boolean | isVersioned()
void | setLazy(boolean lazy)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

EntityMetamodel

public EntityMetamodel(PersistentClass persistentClass,
                       SessionFactoryImplementor sessionFactory)
Method Detail

getTuplizer

public EntityTuplizer getTuplizer(EntityMode entityMode)

getTuplizerOrNull

public EntityTuplizer getTuplizerOrNull(EntityMode entityMode)

guessEntityMode

public EntityMode guessEntityMode(Object object)

getNaturalIdentifierProperties

public int[] getNaturalIdentifierProperties()

hasNaturalIdentifier

public boolean hasNaturalIdentifier()

getSubclassEntityNames

public Set getSubclassEntityNames()

getSessionFactory

public SessionFactoryImplementor getSessionFactory()

getName

public String getName()

getRootName

public String getRootName()

getEntityType

public EntityType getEntityType()

getIdentifierProperty

public IdentifierProperty getIdentifierProperty()

getPropertySpan

public int getPropertySpan()

getVersionPropertyIndex

public int getVersionPropertyIndex()

getVersionProperty

public VersionProperty getVersionProperty()

getProperties

public StandardProperty[] getProperties()

getPropertyIndex

public int getPropertyIndex(String propertyName)

getPropertyIndexOrNull

public Integer getPropertyIndexOrNull(String propertyName)

hasCollections

public boolean hasCollections()

hasMutableProperties

public boolean hasMutableProperties()

hasLazyProperties

public boolean hasLazyProperties()

hasCascades

public boolean hasCascades()

isMutable

public boolean isMutable()

isSelectBeforeUpdate

public boolean isSelectBeforeUpdate()

isDynamicUpdate

public boolean isDynamicUpdate()

isDynamicInsert

public boolean isDynamicInsert()

getOptimisticLockMode

public int getOptimisticLockMode()

isPolymorphic

public boolean isPolymorphic()

getSuperclass

public String getSuperclass()

isExplicitPolymorphism

public boolean isExplicitPolymorphism()

isInherited

public boolean isInherited()

hasSubclasses

public boolean hasSubclasses()

isLazy

public boolean isLazy()

setLazy

public void setLazy(boolean lazy)

isVersioned

public boolean isVersioned()

isAbstract

public boolean isAbstract()

toString

public String toString()

getPropertyNames

public String[] getPropertyNames()

getPropertyTypes

public Type[] getPropertyTypes()

getPropertyLaziness

public boolean[] getPropertyLaziness()

getPropertyUpdateability

public boolean[] getPropertyUpdateability()

getPropertyCheckability

public boolean[] getPropertyCheckability()

getNonlazyPropertyUpdateability

public boolean[] getNonlazyPropertyUpdateability()

getPropertyInsertability

public boolean[] getPropertyInsertability()

getPropertyInsertGeneration

public boolean[] getPropertyInsertGeneration()

getPropertyUpdateGeneration

public boolean[] getPropertyUpdateGeneration()

getPropertyNullability

public boolean[] getPropertyNullability()

getPropertyVersionability

public boolean[] getPropertyVersionability()

getCascadeStyles

public CascadeStyle[] getCascadeStyles()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PojoEntityTuplizer (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.tuple.entity
Class PojoEntityTuplizer

java.lang.Object
    extended by org.hibernate.tuple.entity.AbstractEntityTuplizer
        extended by org.hibernate.tuple.entity.PojoEntityTuplizer
All Implemented Interfaces:
EntityTuplizer, Tuplizer
public class PojoEntityTuplizer
extends AbstractEntityTuplizer

An EntityTuplizer specific to the pojo entity mode.

Author:
Steve Ebersole, Gavin King

Field Summary
Fields inherited from class org.hibernate.tuple.entity.AbstractEntityTuplizer
getters, hasCustomAccessors, propertySpan, setters
Constructor Summary
PojoEntityTuplizer(EntityMetamodel entityMetamodel, PersistentClass mappedEntity)
Method Summary
void | afterInitialize(Object entity, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Called just after the entities properties have been initialized.
protected Instantiator | buildInstantiator(PersistentClass persistentClass) Build an appropriate Instantiator for the given mapped entity.
protected Getter | buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Getter for the given property.
protected Setter | buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Setter for the given property.
protected ProxyFactory | buildProxyFactory(PersistentClass persistentClass, Getter idGetter, Setter idSetter) Build an appropriate ProxyFactory for the given mapped entity.
protected ProxyFactory | buildProxyFactoryInternal(PersistentClass persistentClass, Getter idGetter, Setter idSetter)
Class | getConcreteProxyClass() Returns the java class to which generated proxies will be typed.
EntityMode | getEntityMode() Return the entity-mode handled by this tuplizer instance.
Class | getMappedClass() Return the pojo class managed by this tuplizer.
Object[] | getPropertyValues(Object entity) Extract the current values contained on the given entity.
Object[] | getPropertyValuesToInsert(Object entity, Map mergeMap, SessionImplementor session) Extract the values of the insertable properties of the entity (including backrefs)
protected Object[] | getPropertyValuesWithOptimizer(Object object)
boolean | hasUninitializedLazyProperties(Object entity) Does the given entity instance have any currently uninitialized lazy properties?
boolean | isInstrumented() Is it an instrumented POJO?
boolean | isLifecycleImplementor() Does the class managed by this tuplizer implement the Lifecycle interface.
boolean | isValidatableImplementor() Does the class managed by this tuplizer implement the Validatable interface.
void | setPropertyValues(Object entity, Object[] values) Inject the given values into the given entity.
protected void | setPropertyValuesWithOptimizer(Object object, Object[] values)
Methods inherited from class org.hibernate.tuple.entity.AbstractEntityTuplizer
createProxy, getComponentValue, getEntityMetamodel, getEntityName, getFactory, getIdentifier, getInstantiator, getPropertyValue, getPropertyValue, getProxyFactory, getSubclassEntityNames, getVersion, hasProxy, instantiate, instantiate, isInstance, resetIdentifier, setIdentifier, setPropertyValue, setPropertyValue, shouldGetAllProperties, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PojoEntityTuplizer

public PojoEntityTuplizer(EntityMetamodel entityMetamodel,
                          PersistentClass mappedEntity)
Method Detail

buildProxyFactory

protected ProxyFactory buildProxyFactory(PersistentClass persistentClass,
                                         Getter idGetter,
                                         Setter idSetter)
Description copied from class: AbstractEntityTuplizer
Build an appropriate ProxyFactory for the given mapped entity.

Specified by:
buildProxyFactory in class AbstractEntityTuplizer
Parameters:
persistentClass - The mapping information regarding the mapped entity.
idGetter - The constructed Getter relating to the entity's id property.
idSetter - The constructed Setter relating to the entity's id property.
Returns:
An appropriate ProxyFactory instance.

buildProxyFactoryInternal

protected ProxyFactory buildProxyFactoryInternal(PersistentClass persistentClass,
                                                 Getter idGetter,
                                                 Setter idSetter)

buildInstantiator

protected Instantiator buildInstantiator(PersistentClass persistentClass)
Description copied from class: AbstractEntityTuplizer
Build an appropriate Instantiator for the given mapped entity.

Specified by:
buildInstantiator in class AbstractEntityTuplizer
Parameters:
persistentClass - The mapping information regarding the mapped entity.
Returns:
An appropriate Instantiator instance.

setPropertyValues

public void setPropertyValues(Object entity,
                              Object[] values)
                       throws HibernateException
Description copied from interface: Tuplizer
Inject the given values into the given entity.

Specified by:
setPropertyValues in interface Tuplizer
Overrides:
setPropertyValues in class AbstractEntityTuplizer
Throws:
HibernateException

getPropertyValues

public Object[] getPropertyValues(Object entity)
                           throws HibernateException
Description copied from interface: Tuplizer
Extract the current values contained on the given entity.

Specified by:
getPropertyValues in interface Tuplizer
Overrides:
getPropertyValues in class AbstractEntityTuplizer
Throws:
HibernateException

getPropertyValuesToInsert

public Object[] getPropertyValuesToInsert(Object entity,
                                          Map mergeMap,
                                          SessionImplementor session)
                                   throws HibernateException
Description copied from interface: EntityTuplizer
Extract the values of the insertable properties of the entity (including backrefs)

Specified by:
getPropertyValuesToInsert in interface EntityTuplizer
Overrides:
getPropertyValuesToInsert in class AbstractEntityTuplizer
Throws:
HibernateException

setPropertyValuesWithOptimizer

protected void setPropertyValuesWithOptimizer(Object object,
                                              Object[] values)

getPropertyValuesWithOptimizer

protected Object[] getPropertyValuesWithOptimizer(Object object)

getEntityMode

public EntityMode getEntityMode()
Description copied from class: AbstractEntityTuplizer
Return the entity-mode handled by this tuplizer instance.

Specified by:
getEntityMode in class AbstractEntityTuplizer
Returns:
The entity-mode

getMappedClass

public Class getMappedClass()
Description copied from interface: Tuplizer
Return the pojo class managed by this tuplizer.

Need to determine how to best handle this for the Tuplizers for EntityModes other than POJO.

todo : be really nice to not have this here since it is essentially pojo specific...

Returns:
The persistent class.

isLifecycleImplementor

public boolean isLifecycleImplementor()
Description copied from interface: EntityTuplizer
Does the class managed by this tuplizer implement the Lifecycle interface.

Specified by:
isLifecycleImplementor in interface EntityTuplizer
Overrides:
isLifecycleImplementor in class AbstractEntityTuplizer

isValidatableImplementor

public boolean isValidatableImplementor()
Description copied from interface: EntityTuplizer
Does the class managed by this tuplizer implement the Validatable interface.

Specified by:
isValidatableImplementor in interface EntityTuplizer
Overrides:
isValidatableImplementor in class AbstractEntityTuplizer

buildPropertyGetter

protected Getter buildPropertyGetter(Property mappedProperty,
                                     PersistentClass mappedEntity)
Description copied from class: AbstractEntityTuplizer
Build an appropriate Getter for the given property.

Specified by:
buildPropertyGetter in class AbstractEntityTuplizer
Parameters:
mappedProperty - The property to be accessed via the built Getter.
mappedEntity - The entity information regarding the mapped entity owning this property.
Returns:
An appropriate Getter instance.

buildPropertySetter

protected Setter buildPropertySetter(Property mappedProperty,
                                     PersistentClass mappedEntity)
Description copied from class: AbstractEntityTuplizer
Build an appropriate Setter for the given property.

Specified by:
buildPropertySetter in class AbstractEntityTuplizer
Parameters:
mappedProperty - The property to be accessed via the built Setter.
mappedEntity - The entity information regarding the mapped entity owning this property.
Returns:
An appropriate Setter instance.

getConcreteProxyClass

public Class getConcreteProxyClass()
Description copied from interface: EntityTuplizer
Returns the java class to which generated proxies will be typed.

Returns:
The java class to which generated proxies will be typed

afterInitialize

public void afterInitialize(Object entity,
                            boolean lazyPropertiesAreUnfetched,
                            SessionImplementor session)
Description copied from interface: EntityTuplizer
Called just after the entities properties have been initialized.

Specified by:
afterInitialize in interface EntityTuplizer
Overrides:
afterInitialize in class AbstractEntityTuplizer

hasUninitializedLazyProperties

public boolean hasUninitializedLazyProperties(Object entity)
Description copied from interface: EntityTuplizer
Does the given entity instance have any currently uninitialized lazy properties?

Specified by:
hasUninitializedLazyProperties in interface EntityTuplizer
Overrides:
hasUninitializedLazyProperties in class AbstractEntityTuplizer

isInstrumented

public boolean isInstrumented()
Description copied from interface: EntityTuplizer
Is it an instrumented POJO?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.type (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.type

A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

See:
Description

Interface Summary
AbstractComponentType | Enables other Component-like types to hold collections and have cascades, etc.
AssociationType | A type that represents some kind of association between entities.
DiscriminatorType | A Type that may be used for a discriminator column.
IdentifierType | A Type that may be used as an identifier.
LiteralType | A type that may appear as an SQL literal
Type | Defines a mapping from a Java type to an JDBC datatype.
VersionType | A Type that may be used to version data.

Class Summary
AbstractBynaryType | Logic to bind stream of byte into a VARBINARY
AbstractCharArrayType | Logic to bind stream of char into a VARCHAR
AbstractType | Abstract superclass of the built in Type hierarchy.
AdaptedImmutableType | Optimize a mutable type, if the user promises not to mutable the instances.
AnyType | Handles "any" mappings and the old deprecated "object" type
AnyType.ObjectTypeCacheEntry |
ArrayType | A type for persistent arrays.
BagType |
BigDecimalType | big_decimal: A type that maps an SQL NUMERIC to a java.math.BigDecimal
BigIntegerType | big_integer: A type that maps an SQL NUMERIC to a java.math.BigInteger
BinaryType | binary: A type that maps an SQL VARBINARY to a Java byte[].
BlobType | blob: A type that maps an SQL BLOB to a java.sql.Blob.
BooleanType | boolean: A type that maps an SQL BIT to a Java Boolean.
ByteType | byte: A type that maps an SQL TINYINT to a Java Byte.
CalendarDateType | calendar_date: A type mapping for a Calendar object that represents a date.
CalendarType | calendar: A type mapping for a Calendar object that represents a datetime.
CharacterArrayType | Bridge Character[] and VARCHAR
CharacterType | character: A type that maps an SQL CHAR(1) to a Java Character.
CharArrayType | put char[] into VARCHAR
CharBooleanType | Superclass for types that map Java boolean to SQL CHAR(1).
ClassType | class: A type that maps an SQL VARCHAR to a Java Class.
ClobType | clob: A type that maps an SQL CLOB to a java.sql.Clob.
CollectionType | A type that handles Hibernate PersistentCollections (including arrays).
ComponentType | Handles "component" mappings
CompositeCustomType | Adapts CompositeUserType to Type interface
CurrencyType | currency: A type that maps an SQL VARCHAR to a java.util.Currency
CustomCollectionType | A custom type for mapping user-written classes that implement PersistentCollection
CustomType | Adapts UserType to the generic Type interface, in order to isolate user code from changes in the internal Type contracts.
DateType | date: A type that maps an SQL DATE to a Java Date.
DbTimestampType | dbtimestamp: An extension of TimestampType which maps to the database's current timestamp, rather than the jvm's current timestamp.
DoubleType | double: A type that maps an SQL DOUBLE to a Java Double.
EmbeddedComponentType |
EntityType | A reference to an entity class
FloatType | float: A type that maps an SQL FLOAT to a Java Float.
ForeignKeyDirection | Represents directionality of the foreign key constraint
IdentifierBagType |
ImmutableType | Superclass of nullable immutable types.
IntegerType | integer: A type that maps an SQL INT to a Java Integer.
ListType |
LocaleType | locale: A type that maps an SQL VARCHAR to a Java Locale.
LongType | long: A type that maps an SQL BIGINT to a Java Long.
ManyToOneType | A many-to-one association to an entity.
MapType |
MetaType |
MutableType | Superclass for mutable nullable types
NullableType | Superclass of single-column nullable types.
OneToOneType | A one-to-one association to an entity
OrderedMapType |
OrderedSetType |
PrimitiveType | Superclass of primitive / primitive wrapper types.
SerializableType | serializable: A type that maps an SQL VARBINARY to a serializable Java object.
SetType |
ShortType | short: A type that maps an SQL SMALLINT to a Java Short.
SortedMapType |
SortedSetType |
SpecialOneToOneType | A one-to-one association that maps to specific formula(s) instead of the primary key column of the owning entity.
StringType | string: A type that maps an SQL VARCHAR to a Java String.
TextType | text: A type that maps an SQL CLOB to a Java String.
TimestampType | timestamp: A type that maps an SQL TIMESTAMP to a Java java.util.Date or java.sql.Timestamp.
TimeType | time: A type that maps an SQL TIME to a Java java.util.Date or java.sql.Time.
TimeZoneType | timezone: A type that maps an SQL VARCHAR to a java.util.TimeZone
TrueFalseType | true_false: A type that maps an SQL CHAR(1) to a Java Boolean.
TypeFactory | Used internally to obtain instances of Type.
WrapperBinaryType |
YesNoType | yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.

Exception Summary
SerializationException Thrown when a property cannot be serializaed/deserialized

Package org.hibernate.type Description

A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.


org.hibernate.type Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.type

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.type.AbstractType (implements org.hibernate.type.Type)
      • class org.hibernate.type.AnyType (implements org.hibernate.type.AbstractComponentType, org.hibernate.type.AssociationType)
      • class org.hibernate.type.BlobType
      • class org.hibernate.type.ClobType
      • class org.hibernate.type.CollectionType (implements org.hibernate.type.AssociationType)
        • class org.hibernate.type.ArrayType
        • class org.hibernate.type.BagType
        • class org.hibernate.type.CustomCollectionType
        • class org.hibernate.type.IdentifierBagType
        • class org.hibernate.type.ListType
        • class org.hibernate.type.MapType
          • class org.hibernate.type.OrderedMapType
          • class org.hibernate.type.SortedMapType
        • class org.hibernate.type.SetType
          • class org.hibernate.type.OrderedSetType
          • class org.hibernate.type.SortedSetType
      • class org.hibernate.type.ComponentType (implements org.hibernate.type.AbstractComponentType)
        • class org.hibernate.type.EmbeddedComponentType
      • class org.hibernate.type.CompositeCustomType (implements org.hibernate.type.AbstractComponentType)
      • class org.hibernate.type.CustomType (implements org.hibernate.type.DiscriminatorType, org.hibernate.type.IdentifierType, org.hibernate.type.VersionType)
      • class org.hibernate.type.EntityType (implements org.hibernate.type.AssociationType)
        • class org.hibernate.type.ManyToOneType
        • class org.hibernate.type.OneToOneType
          • class org.hibernate.type.SpecialOneToOneType
      • class org.hibernate.type.MetaType
      • class org.hibernate.type.NullableType
        • class org.hibernate.type.ImmutableType
          • class org.hibernate.type.AdaptedImmutableType
          • class org.hibernate.type.BigDecimalType
          • class org.hibernate.type.BigIntegerType (implements org.hibernate.type.DiscriminatorType)
          • class org.hibernate.type.ClassType
          • class org.hibernate.type.CurrencyType (implements org.hibernate.type.LiteralType)
          • class org.hibernate.type.LocaleType (implements org.hibernate.type.LiteralType)
          • class org.hibernate.type.PrimitiveType (implements org.hibernate.type.LiteralType)
            • class org.hibernate.type.BooleanType (implements org.hibernate.type.DiscriminatorType)
              • class org.hibernate.type.CharBooleanType
                • class org.hibernate.type.TrueFalseType
                • class org.hibernate.type.YesNoType
            • class org.hibernate.type.ByteType (implements org.hibernate.type.DiscriminatorType, org.hibernate.type.VersionType)
            • class org.hibernate.type.CharacterType (implements org.hibernate.type.DiscriminatorType)
            • class org.hibernate.type.DoubleType
            • class org.hibernate.type.FloatType
            • class org.hibernate.type.IntegerType (implements org.hibernate.type.DiscriminatorType, org.hibernate.type.VersionType)
            • class org.hibernate.type.LongType (implements org.hibernate.type.DiscriminatorType, org.hibernate.type.VersionType)
            • class org.hibernate.type.ShortType (implements org.hibernate.type.DiscriminatorType, org.hibernate.type.VersionType)
          • class org.hibernate.type.StringType (implements org.hibernate.type.DiscriminatorType)
          • class org.hibernate.type.TextType
          • class org.hibernate.type.TimeZoneType (implements org.hibernate.type.LiteralType)
        • class org.hibernate.type.MutableType
          • class org.hibernate.type.AbstractBynaryType (implements java.util.Comparator, org.hibernate.type.VersionType)
            • class org.hibernate.type.BinaryType
            • class org.hibernate.type.WrapperBinaryType
          • class org.hibernate.type.AbstractCharArrayType
            • class org.hibernate.type.CharacterArrayType
            • class org.hibernate.type.CharArrayType
          • class org.hibernate.type.CalendarDateType
          • class org.hibernate.type.CalendarType (implements org.hibernate.type.VersionType)
          • class org.hibernate.type.DateType (implements org.hibernate.type.IdentifierType, org.hibernate.type.LiteralType)
          • class org.hibernate.type.SerializableType
          • class org.hibernate.type.TimestampType (implements org.hibernate.type.LiteralType, org.hibernate.type.VersionType)
            • class org.hibernate.type.DbTimestampType (implements org.hibernate.type.VersionType)
          • class org.hibernate.type.TimeType (implements org.hibernate.type.LiteralType)
    • class org.hibernate.type.AnyType.ObjectTypeCacheEntry (implements java.io.Serializable)
    • class org.hibernate.type.ForeignKeyDirection (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class org.hibernate.exception.NestableRuntimeException (implements org.hibernate.exception.Nestable)
            • class org.hibernate.HibernateException
              • class org.hibernate.type.SerializationException
    • class org.hibernate.type.TypeFactory

Interface Hierarchy

  • interface org.hibernate.type.LiteralType
    • interface org.hibernate.type.DiscriminatorType (also extends org.hibernate.type.IdentifierType)
  • interface java.io.Serializable
    • interface org.hibernate.type.Type
      • interface org.hibernate.type.AbstractComponentType
      • interface org.hibernate.type.AssociationType
      • interface org.hibernate.type.IdentifierType
        • interface org.hibernate.type.DiscriminatorType (also extends org.hibernate.type.LiteralType)
      • interface org.hibernate.type.VersionType


Uses of Package org.hibernate.type (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.type

Packages that use org.hibernate.type
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.classic | This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function | A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.engine.query.sql |
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.metadata | This package defines an API for accessing the Hibernate runtime metamodel.
org.hibernate.param |
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.pretty | Classes for pretty printing things for exception and log messages.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.proxy | This package defines a framework for lazy-initializing entity proxies.
org.hibernate.proxy.dom4j |
org.hibernate.proxy.map |
org.hibernate.proxy.pojo |
org.hibernate.proxy.pojo.cglib |
org.hibernate.proxy.pojo.javassist |
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.usertype | Interfaces for user-defined custom types.
org.hibernate.util | Utility classes.

Classes in org.hibernate.type used by org.hibernate
NullableType
Superclass of single-column nullable types.
Type
Defines a mapping from a Java type to an JDBC datatype.
VersionType
A Type that may be used to version data.

Classes in org.hibernate.type used by org.hibernate.cache
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.classic
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.collection
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.criterion
AbstractComponentType
Enables other Component-like types to hold collections and have cascades, etc.
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.dialect
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.dialect.function
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.engine
AssociationType
A type that represents some kind of association between entities.
CollectionType
A type that handles Hibernate PersistentCollections (including arrays).
Type
Defines a mapping from a Java type to an JDBC datatype.
VersionType
A Type that may be used to version data.

Classes in org.hibernate.type used by org.hibernate.engine.query
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.engine.query.sql
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.event.def
CollectionType
A type that handles Hibernate PersistentCollections (including arrays).
ForeignKeyDirection
Represents directionality of the foreign key constraint
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.hql
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.hql.ast
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.hql.ast.tree
BooleanType
boolean: A type that maps an SQL BIT to a Java Boolean.
EntityType
A reference to an entity class
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.hql.ast.util
AssociationType
A type that represents some kind of association between entities.
CollectionType
A type that handles Hibernate PersistentCollections (including arrays).
EntityType
A reference to an entity class
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.hql.classic
EntityType
A reference to an entity class
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.id
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.impl
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.loader
AssociationType
A type that represents some kind of association between entities.
EntityType
A reference to an entity class
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.loader.collection
AssociationType
A type that represents some kind of association between entities.
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.loader.criteria
AssociationType
A type that represents some kind of association between entities.
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.loader.custom
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.loader.entity
AssociationType
A type that represents some kind of association between entities.
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.loader.hql
EntityType
A reference to an entity class

Classes in org.hibernate.type used by org.hibernate.mapping
CollectionType
A type that handles Hibernate PersistentCollections (including arrays).
ForeignKeyDirection
Represents directionality of the foreign key constraint
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.metadata
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.param
Type
Defines a mapping from a Java type to an JDBC datatype.
VersionType
A Type that may be used to version data.

Classes in org.hibernate.type used by org.hibernate.persister.collection
AbstractComponentType
Enables other Component-like types to hold collections and have cascades, etc.
CollectionType
A type that handles Hibernate PersistentCollections (including arrays).
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.persister.entity
AbstractComponentType
Enables other Component-like types to hold collections and have cascades, etc.
EntityType
A reference to an entity class
Type
Defines a mapping from a Java type to an JDBC datatype.
VersionType
A Type that may be used to version data.

Classes in org.hibernate.type used by org.hibernate.pretty
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.property
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.proxy
AbstractComponentType
Enables other Component-like types to hold collections and have cascades, etc.

Classes in org.hibernate.type used by org.hibernate.proxy.dom4j
AbstractComponentType
Enables other Component-like types to hold collections and have cascades, etc.

Classes in org.hibernate.type used by org.hibernate.proxy.map
AbstractComponentType
Enables other Component-like types to hold collections and have cascades, etc.

Classes in org.hibernate.type used by org.hibernate.proxy.pojo
AbstractComponentType
Enables other Component-like types to hold collections and have cascades, etc.

Classes in org.hibernate.type used by org.hibernate.proxy.pojo.cglib
AbstractComponentType
Enables other Component-like types to hold collections and have cascades, etc.

Classes in org.hibernate.type used by org.hibernate.proxy.pojo.javassist
AbstractComponentType
Enables other Component-like types to hold collections and have cascades, etc.

Classes in org.hibernate.type used by org.hibernate.sql
LiteralType
A type that may appear as an SQL literal

Classes in org.hibernate.type used by org.hibernate.tuple
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.tuple.entity
ComponentType
Handles "component" mappings
EntityType
A reference to an entity class
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.type
AbstractBynaryType
Logic to bind stream of byte into a VARBINARY
AbstractCharArrayType
Logic to bind stream of char into a VARCHAR
AbstractComponentType
Enables other Component-like types to hold collections and have cascades, etc.
AbstractType
Abstract superclass of the built in Type hierarchy.
AssociationType
A type that represents some kind of association between entities.
BooleanType
boolean: A type that maps an SQL BIT to a Java Boolean.
CharBooleanType
Superclass for types that map Java boolean to SQL CHAR(1).
CollectionType
A type that handles Hibernate PersistentCollections (including arrays).
ComponentType
Handles "component" mappings
DiscriminatorType
A Type that may be used for a discriminator column.
EntityType
A reference to an entity class
ForeignKeyDirection
Represents directionality of the foreign key constraint
IdentifierType
A Type that may be used as an identifier.
ImmutableType
Superclass of nullable immutable types.
LiteralType
A type that may appear as an SQL literal
MapType
MutableType
Superclass for mutable nullable types
NullableType
Superclass of single-column nullable types.
OneToOneType
A one-to-one association to an entity
PrimitiveType
Superclass of primitive / primitive wrapper types.
SetType
TimestampType
timestamp: A type that maps an SQL TIMESTAMP to a Java java.util.Date or java.sql.Timestamp.
Type
Defines a mapping from a Java type to an JDBC datatype.
VersionType
A Type that may be used to version data.

Classes in org.hibernate.type used by org.hibernate.usertype
Type
Defines a mapping from a Java type to an JDBC datatype.

Classes in org.hibernate.type used by org.hibernate.util
SerializationException
Thrown when a property cannot be serializaed/deserialized
Type
Defines a mapping from a Java type to an JDBC datatype.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractComponentType (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Interface AbstractComponentType

All Superinterfaces:
Serializable, Type
All Known Implementing Classes:
AnyType, ComponentType, CompositeCustomType
public interface AbstractComponentType
extends Type

Enables other Component-like types to hold collections and have cascades, etc.

Author:
Gavin King
See Also:
ComponentType, AnyType

Method Summary
CascadeStyle | getCascadeStyle(int i)
FetchMode | getFetchMode(int i)
String[] | getPropertyNames() Get the names of the component properties
boolean[] | getPropertyNullability() Optional operation
Object | getPropertyValue(Object component, int i, SessionImplementor session)
Object[] | getPropertyValues(Object component, EntityMode entityMode) Optional operation
Object[] | getPropertyValues(Object component, SessionImplementor session) Get the values of the component properties of a component instance
Type[] | getSubtypes() Get the types of the component properties
boolean | isEmbedded()
boolean | isMethodOf(Method method)
void | setPropertyValues(Object component, Object[] values, EntityMode entityMode) Optional operation
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getName, getReturnedClass, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Method Detail

getSubtypes

public Type[] getSubtypes()
Get the types of the component properties

getPropertyNames

public String[] getPropertyNames()
Get the names of the component properties

getPropertyNullability

public boolean[] getPropertyNullability()
Optional operation

Returns:
nullability of component properties

getPropertyValues

public Object[] getPropertyValues(Object component,
                                  SessionImplementor session)
                           throws HibernateException
Get the values of the component properties of a component instance

Throws:
HibernateException

getPropertyValues

public Object[] getPropertyValues(Object component,
                                  EntityMode entityMode)
                           throws HibernateException
Optional operation

Throws:
HibernateException

setPropertyValues

public void setPropertyValues(Object component,
                              Object[] values,
                              EntityMode entityMode)
                       throws HibernateException
Optional operation

Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object component,
                               int i,
                               SessionImplementor session)
                        throws HibernateException
Throws:
HibernateException

getCascadeStyle

public CascadeStyle getCascadeStyle(int i)

getFetchMode

public FetchMode getFetchMode(int i)

isMethodOf

public boolean isMethodOf(Method method)

isEmbedded

public boolean isEmbedded()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AssociationType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Interface AssociationType

All Superinterfaces:
Serializable, Type
All Known Implementing Classes:
AnyType, CollectionType, EntityType
public interface AssociationType
extends Type

A type that represents some kind of association between entities.

Author:
Gavin King
See Also:
Cascade

Method Summary
String | getAssociatedEntityName(SessionFactoryImplementor factory) Get the entity name of the associated entity
Joinable | getAssociatedJoinable(SessionFactoryImplementor factory) Get the "persister" for this association - a class or collection persister
ForeignKeyDirection | getForeignKeyDirection() Get the foreign key directionality of this association
String | getLHSPropertyName() Get the name of a property in the owning entity that provides the join key (null if the identifier)
String | getOnCondition(String alias, SessionFactoryImplementor factory, Map enabledFilters) Get the "filtering" SQL fragment that is applied in the SQL on clause, in addition to the usual join condition
String | getRHSUniqueKeyPropertyName() The name of a unique property of the associated entity that provides the join key (null if the identifier of an entity, or key of a collection)
boolean | isAlwaysDirtyChecked() Do we dirty check this association, even when there are no columns to be updated?
boolean | isEmbeddedInXML()
boolean | useLHSPrimaryKey() Is the primary key of the owning entity table to be used in the join?
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getName, getReturnedClass, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Method Detail

getForeignKeyDirection

public ForeignKeyDirection getForeignKeyDirection()
Get the foreign key directionality of this association

useLHSPrimaryKey

public boolean useLHSPrimaryKey()
Is the primary key of the owning entity table to be used in the join?

getLHSPropertyName

public String getLHSPropertyName()
Get the name of a property in the owning entity that provides the join key (null if the identifier)

getRHSUniqueKeyPropertyName

public String getRHSUniqueKeyPropertyName()
The name of a unique property of the associated entity that provides the join key (null if the identifier of an entity, or key of a collection)

getAssociatedJoinable

public Joinable getAssociatedJoinable(SessionFactoryImplementor factory)
                               throws MappingException
Get the "persister" for this association - a class or collection persister

Throws:
MappingException

getAssociatedEntityName

public String getAssociatedEntityName(SessionFactoryImplementor factory)
                               throws MappingException
Get the entity name of the associated entity

Throws:
MappingException

getOnCondition

public String getOnCondition(String alias,
                             SessionFactoryImplementor factory,
                             Map enabledFilters)
                      throws MappingException
Get the "filtering" SQL fragment that is applied in the SQL on clause, in addition to the usual join condition

Throws:
MappingException

isAlwaysDirtyChecked

public boolean isAlwaysDirtyChecked()
Do we dirty check this association, even when there are no columns to be updated?

isEmbeddedInXML

public boolean isEmbeddedInXML()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DiscriminatorType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Interface DiscriminatorType

All Superinterfaces:
IdentifierType, LiteralType, Serializable, Type
All Known Implementing Classes:
BigIntegerType, BooleanType, ByteType, CharacterType, CustomType, IntegerType, LongType, ShortType, StringType
public interface DiscriminatorType
extends IdentifierType, LiteralType

A Type that may be used for a discriminator column.

Author:
Gavin King

Methods inherited from interface org.hibernate.type.IdentifierType
stringToObject
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getName, getReturnedClass, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString
Methods inherited from interface org.hibernate.type.LiteralType
objectToSQLString

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentifierType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Interface IdentifierType

All Superinterfaces:
Serializable, Type
All Known Subinterfaces:
DiscriminatorType
All Known Implementing Classes:
BigIntegerType, BooleanType, ByteType, CharacterType, CustomType, DateType, IntegerType, LongType, ShortType, StringType
public interface IdentifierType
extends Type

A Type that may be used as an identifier.

Author:
Gavin King

Method Summary
 Object stringToObject(String xml)
Convert the value from the mapping file to a Java object.
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getName, getReturnedClass, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Method Detail

stringToObject

public Object stringToObject(String xml)
                      throws Exception
Convert the value from the mapping file to a Java object.

Parameters:
xml - the value of discriminator-value or unsaved-value attribute
Returns:
Object
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LiteralType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Interface LiteralType

All Known Subinterfaces:
DiscriminatorType
All Known Implementing Classes:
BigIntegerType, BooleanType, ByteType, CharacterType, CurrencyType, CustomType, DateType, IntegerType, LocaleType, LongType, PrimitiveType, ShortType, StringType, TimestampType, TimeType, TimeZoneType
public interface LiteralType

A type that may appear as an SQL literal

Author:
Gavin King

Method Summary
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.

Method Detail

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
String representation of the value, suitable for embedding in an SQL statement.

Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Type (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Interface Type

All Superinterfaces:
Serializable
All Known Subinterfaces:
AbstractComponentType, AssociationType, DiscriminatorType, IdentifierType, VersionType
All Known Implementing Classes:
AbstractBynaryType, AbstractType, AnyType, BigIntegerType, BooleanType, ByteType, CalendarType, CharacterType, CollectionType, ComponentType, CompositeCustomType, CustomType, DateType, DbTimestampType, EntityType, IntegerType, LongType, ShortType, StringType, TimestampType
public interface Type
extends Serializable

Defines a mapping from a Java type to an JDBC datatype. This interface is intended to be implemented by applications that need custom types.

Implementors should usually be immutable and must certainly be threadsafe.

Author:
Gavin King

Method Summary
 Object assemble(Serializable cached, SessionImplementor session, Object owner)
Reconstruct the object from its cached "disassembled" state.
 void beforeAssemble(Serializable cached, SessionImplementor session)
Called before assembling a query result set from the query cache, to allow batch fetching of entities missing from the second-level cache.
 int compare(Object x, Object y, EntityMode entityMode)
compare two instances of the type
 Object deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Return a deep copy of the persistent state, stopping at entities and at collections.
 Serializable disassemble(Object value, SessionImplementor session, Object owner)
Return a cacheable "disassembled" representation of the object.
 Object fromXMLNode(org.dom4j.Node xml, Mapping factory)
Parse the XML representation of an instance.
 int getColumnSpan(Mapping mapping)
How many columns are used to persist this type.
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 int getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Type getSemiResolvedType(SessionFactoryImplementor factory)
Get the type of a semi-resolved value.
 Object hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset.
 boolean isAnyType()
Is this an "any" type.
 boolean isAssociationType()
Return true if the implementation is castable to AssociationType.
 boolean isCollectionType()
Is this type a collection type.
 boolean isComponentType()
Is this type a component type.
 boolean isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Should the parent be considered dirty, given both the old and current field or element value?
 boolean isDirty(Object old, Object current, SessionImplementor session)
Should the parent be considered dirty, given both the old and current field or element value?
 boolean isEntityType()
Is this type an entity type?
 boolean isEqual(Object x, Object y, EntityMode entityMode)
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
 boolean isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory)
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
 boolean isModified(Object oldHydratedState, Object currentState, boolean[] checkable, SessionImplementor session)
Has the parent object been modified, compared to the current database state?
 boolean isMutable()
Are objects of this type mutable.
 boolean isSame(Object x, Object y, EntityMode entityMode)
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.
 boolean isXMLElement()
 Object nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 Object nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 void nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
Write an instance of the mapped class to a prepared statement, ignoring some columns.
 void nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Write an instance of the mapped class to a prepared statement.
 Object replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
 Object replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
 Object resolve(Object value, SessionImplementor session, Object owner)
Map identifiers to entities or collections.
 Object semiResolve(Object value, SessionImplementor session, Object owner)
Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.
 void setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in an XML element.
 int[] sqlTypes(Mapping mapping)
Return the SQL type codes for the columns mapped by this type.
 boolean[] toColumnNullness(Object value, Mapping mapping)
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
 String toLoggableString(Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in a log file.

Method Detail

isAssociationType

public boolean isAssociationType()
Return true if the implementation is castable to AssociationType. This does not necessarily imply that the type actually represents an association.

Returns:
boolean
See Also:
AssociationType

isCollectionType

public boolean isCollectionType()
Is this type a collection type.

isComponentType

public boolean isComponentType()
Is this type a component type. If so, the implementation must be castable to AbstractComponentType. A component type may own collections or associations and hence must provide certain extra functionality.

Returns:
boolean
See Also:
AbstractComponentType

isEntityType

public boolean isEntityType()
Is this type an entity type?

Returns:
boolean

isAnyType

public boolean isAnyType()
Is this an "any" type. i.e. a reference to a persistent entity that is not modelled as a (foreign key) association.

isXMLElement

public boolean isXMLElement()

sqlTypes

public int[] sqlTypes(Mapping mapping)
               throws MappingException
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Returns:
the typecodes
Throws:
MappingException
See Also:
Types

getColumnSpan

public int getColumnSpan(Mapping mapping)
                  throws MappingException
How many columns are used to persist this type.

Throws:
MappingException

getReturnedClass

public Class getReturnedClass()
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

isSame

public boolean isSame(Object x,
                      Object y,
                      EntityMode entityMode)
               throws HibernateException
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.

Parameters:
x -
y -
entityMode -
Returns:
boolean
Throws:
HibernateException

isEqual

public boolean isEqual(Object x,
                       Object y,
                       EntityMode entityMode)
                throws HibernateException
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Parameters:
x -
y -
entityMode -
Returns:
boolean
Throws:
HibernateException

isEqual

public boolean isEqual(Object x,
                       Object y,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
                throws HibernateException
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Parameters:
x -
y -
entityMode -
Returns:
boolean
Throws:
HibernateException

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
                throws HibernateException
Get a hashcode, consistent with persistence "equality"

Parameters:
x -
entityMode -
Throws:
HibernateException

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
                throws HibernateException
Get a hashcode, consistent with persistence "equality"

Parameters:
x -
entityMode -
factory -
Throws:
HibernateException

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
compare two instances of the type

Parameters:
entityMode -

isDirty

public boolean isDirty(Object old,
                       Object current,
                       SessionImplementor session)
                throws HibernateException
Should the parent be considered dirty, given both the old and current field or element value?

Parameters:
old - the old value
current - the current value
session -
Returns:
true if the field is dirty
Throws:
HibernateException

isDirty

public boolean isDirty(Object old,
                       Object current,
                       boolean[] checkable,
                       SessionImplementor session)
                throws HibernateException
Should the parent be considered dirty, given both the old and current field or element value?

Parameters:
old - the old value
current - the current value
checkable - which columns are actually updatable
session -
Returns:
true if the field is dirty
Throws:
HibernateException

isModified

public boolean isModified(Object oldHydratedState,
                          Object currentState,
                          boolean[] checkable,
                          SessionImplementor session)
                   throws HibernateException
Has the parent object been modified, compared to the current database state?

Parameters:
oldHydratedState - the database state, in a "hydrated" form, with identifiers unresolved
currentState - the current state of the object
checkable - which columns are actually updatable
session -
Returns:
true if the field has been modified
Throws:
HibernateException

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String[] names,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Parameters:
rs -
names - the column names
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException
See Also:
alternative, 2-phase property initialization

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String name,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Retrieve an instance of the mapped class from a JDBC resultset. Implementations should handle possibility of null values. This method might be called if the type is known to be a single-column type.

Parameters:
rs -
name - the column name
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        boolean[] settable,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Write an instance of the mapped class to a prepared statement, ignoring some columns. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
settable - an array indicating which columns to ignore
session -
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
session -
Throws:
HibernateException
SQLException

setToXMLNode

public void setToXMLNode(org.dom4j.Node node,
                         Object value,
                         SessionFactoryImplementor factory)
                  throws HibernateException
A representation of the value to be embedded in an XML element.

Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
                        throws HibernateException
A representation of the value to be embedded in a log file.

Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

fromXMLNode

public Object fromXMLNode(org.dom4j.Node xml,
                          Mapping factory)
                   throws HibernateException
Parse the XML representation of an instance.

Parameters:
xml -
factory -
Returns:
an instance of the type
Throws:
HibernateException

getName

public String getName()
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name

deepCopy

public Object deepCopy(Object value,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
                throws HibernateException
Return a deep copy of the persistent state, stopping at entities and at collections.

Parameters:
value - generally a collection element or entity field
entityMode -
factory -
Returns:
Object a copy
Throws:
HibernateException

isMutable

public boolean isMutable()
Are objects of this type mutable. (With respect to the referencing object ... entities and collections are considered immutable because they manage their own internal state.)

Returns:
boolean

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Return a cacheable "disassembled" representation of the object.

Parameters:
value - the value to cache
session - the session
owner - optional parent entity object (needed for collections)
Returns:
the disassembled, deep cloned state
Throws:
HibernateException

assemble

public Object assemble(Serializable cached,
                       SessionImplementor session,
                       Object owner)
                throws HibernateException
Reconstruct the object from its cached "disassembled" state.

Parameters:
cached - the disassembled state from the cache
session - the session
owner - the parent entity object
Returns:
the the object
Throws:
HibernateException

beforeAssemble

public void beforeAssemble(Serializable cached,
                           SessionImplementor session)
Called before assembling a query result set from the query cache, to allow batch fetching of entities missing from the second-level cache.

hydrate

public Object hydrate(ResultSet rs,
                      String[] names,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException,
                      SQLException
Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset. This is useful for 2-phase property initialization - the second phase is a call to resolveIdentifier().

Parameters:
rs -
names - the column names
session - the session
owner - the parent entity
Returns:
Object an identifier or actual value
Throws:
HibernateException
SQLException
See Also:
resolve(Object, SessionImplementor, Object)

resolve

public Object resolve(Object value,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException
Map identifiers to entities or collections. This is the second phase of 2-phase property initialization.

Parameters:
value - an identifier or value returned by hydrate()
owner - the parent entity
session - the session
Returns:
the given value, or the value associated with the identifier
Throws:
HibernateException
See Also:
hydrate(ResultSet, String[], SessionImplementor, Object)

semiResolve

public Object semiResolve(Object value,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException
Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.

Throws:
HibernateException

getSemiResolvedType

public Type getSemiResolvedType(SessionFactoryImplementor factory)
Get the type of a semi-resolved value.

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache)
               throws HibernateException
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache,
                      ForeignKeyDirection foreignKeyDirection)
               throws HibernateException
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException

toColumnNullness

public boolean[] toColumnNullness(Object value,
                                  Mapping mapping)
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.

Parameters:
value - an instance of the type
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VersionType (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Interface VersionType

All Superinterfaces:
Serializable, Type
All Known Implementing Classes:
AbstractBynaryType, ByteType, CalendarType, CustomType, DbTimestampType, IntegerType, LongType, ShortType, TimestampType
public interface VersionType
extends Type

A Type that may be used to version data.

Author:
Gavin King

Method Summary
Comparator | getComparator() Get a comparator for version values.
boolean | isEqual(Object x, Object y) Are the two version values considered equal?
Object | next(Object current, SessionImplementor session) Increment the version.
Object | seed(SessionImplementor session) Generate an initial version.
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getName, getReturnedClass, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Method Detail

seed

public Object seed(SessionImplementor session)
Generate an initial version.

Parameters:
session - The session from which this request originates.
Returns:
an instance of the type

next

public Object next(Object current,
                   SessionImplementor session)
Increment the version.

Parameters:
session - The session from which this request originates.
current - the current version
Returns:
an instance of the type

getComparator

public Comparator getComparator()
Get a comparator for version values.

Returns:
The comparator to use to compare different version values.

isEqual

public boolean isEqual(Object x,
                       Object y)
Are the two version values considered equal?

Parameters:
x - One value to check.
y - The other value to check.
Returns:
true if the values are equal, false otherwise.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractBynaryType (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class AbstractBynaryType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.AbstractBynaryType
All Implemented Interfaces:
Comparator, Serializable, Type, VersionType
Direct Known Subclasses:
BinaryType, WrapperBinaryType
public abstract class AbstractBynaryType
extends MutableType
implements VersionType, Comparator

Logic to bind stream of byte into a VARBINARY

Author:
Gavin King, Emmanuel Bernard
See Also:
Serialized Form

Constructor Summary
AbstractBynaryType()
Method Summary
int | compare(Object o1, Object o2)
int | compare(Object x, Object y, EntityMode entityMode) compare two instances of the type
Object | deepCopyNotNull(Object value)
Object | fromStringValue(String xml)
Object | get(ResultSet rs, String name) Get a column value from a result set, without worrying about the possibility of null values
Comparator | getComparator() Get a comparator for version values.
int | getHashCode(Object x, EntityMode entityMode) Get a hashcode, consistent with persistence "equality"
abstract String | getName() Returns the abbreviated name of the type.
boolean | isEqual(Object x, Object y) Are the two version values considered equal?
Object | next(Object current, SessionImplementor session) Increment the version.
Object | seed(SessionImplementor session) Generate an initial version.
void | set(PreparedStatement st, Object value, int index) Get a parameter value without worrying about the possibility of null values
int | sqlType()
protected abstract Object | toExternalFormat(byte[] bytes) Convert the byte[] into the expected object type
protected abstract byte[] | toInternalFormat(Object bytes) Convert the object into the internal byte[] representation
String | toString(Object val)
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, disassemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getReturnedClass, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString
Methods inherited from interface java.util.Comparator
equals

Constructor Detail

AbstractBynaryType

public AbstractBynaryType()
Method Detail

toExternalFormat

protected abstract Object toExternalFormat(byte[] bytes)
Convert the byte[] into the expected object type

toInternalFormat

protected abstract byte[] toInternalFormat(Object bytes)
Convert the object into the internal byte[] representation

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws HibernateException,
                SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
HibernateException
SQLException

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
HibernateException
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

seed

public Object seed(SessionImplementor session)
Description copied from interface: VersionType
Generate an initial version.

Specified by:
seed in interface VersionType
Parameters:
session - The session from which this request originates.
Returns:
an instance of the type

next

public Object next(Object current,
                   SessionImplementor session)
Description copied from interface: VersionType
Increment the version.

Specified by:
next in interface VersionType
Parameters:
session - The session from which this request originates.
current - the current version
Returns:
an instance of the type

getComparator

public Comparator getComparator()
Description copied from interface: VersionType
Get a comparator for version values.

Specified by:
getComparator in interface VersionType
Returns:
The comparator to use to compare different version values.

compare

public int compare(Object o1,
                   Object o2)
Specified by:
compare in interface Comparator

isEqual

public boolean isEqual(Object x,
                       Object y)
Description copied from interface: VersionType
Are the two version values considered equal?

Specified by:
isEqual in interface VersionType
Overrides:
isEqual in class NullableType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Overrides:
compare in class AbstractType

getName

public abstract String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

toString

public String toString(Object val)
Specified by:
toString in class NullableType

deepCopyNotNull

public Object deepCopyNotNull(Object value)
Specified by:
deepCopyNotNull in class MutableType

fromStringValue

public Object fromStringValue(String xml)
                       throws HibernateException
Specified by:
fromStringValue in class NullableType
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractCharArrayType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class AbstractCharArrayType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.AbstractCharArrayType
All Implemented Interfaces:
Serializable, Type
Direct Known Subclasses:
CharacterArrayType, CharArrayType
public abstract class AbstractCharArrayType
extends MutableType

Logic to bind stream of char into a VARCHAR

Author:
Emmanuel Bernard
See Also:
Serialized Form

Constructor Summary
AbstractCharArrayType()
Method Summary
protected  Object deepCopyNotNull(Object value)
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
abstract  Class getReturnedClass()
The class returned by nullSafeGet() methods.
 String objectToSQLString(Object value, Dialect dialect)
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 Object stringToObject(String xml)
protected abstract  Object toExternalFormat(char[] chars)
Convert the char[] into the expected object type
protected abstract  char[] toInternalFormat(Object chars)
Convert the object into the internal char[] representation
 String toString(Object value)
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
getName

Constructor Detail

AbstractCharArrayType

public AbstractCharArrayType()
Method Detail

toExternalFormat

protected abstract Object toExternalFormat(char[] chars)
Convert the char[] into the expected object type

toInternalFormat

protected abstract char[] toInternalFormat(Object chars)
Convert the object into the internal char[] representation

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getReturnedClass

public abstract Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Throws:
Exception

stringToObject

public Object stringToObject(String xml)
                      throws Exception
Throws:
Exception

toString

public String toString(Object value)
Specified by:
toString in class NullableType

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType

deepCopyNotNull

protected Object deepCopyNotNull(Object value)
                          throws HibernateException
Specified by:
deepCopyNotNull in class MutableType
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class AbstractType

java.lang.Object
    extended by org.hibernate.type.AbstractType
All Implemented Interfaces:
Serializable, Type
Direct Known Subclasses:
AnyType, BlobType, ClobType, CollectionType, ComponentType, CompositeCustomType, CustomType, EntityType, MetaType, NullableType
public abstract class AbstractType
extends Object
implements Type

Abstract superclass of the built in Type hierarchy.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
AbstractType()
Method Summary
Object | assemble(Serializable cached, SessionImplementor session, Object owner) Reconstruct the object from its cached "disassembled" state.
void | beforeAssemble(Serializable cached, SessionImplementor session) Called before assembling a query result set from the query cache, to allow batch fetching of entities missing from the second-level cache.
int | compare(Object x, Object y, EntityMode entityMode) compare two instances of the type
Serializable | disassemble(Object value, SessionImplementor session, Object owner) Return a cacheable "disassembled" representation of the object.
int | getHashCode(Object x, EntityMode entityMode) Get a hashcode, consistent with persistence "equality"
int | getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory) Get a hashcode, consistent with persistence "equality"
Type | getSemiResolvedType(SessionFactoryImplementor factory) Get the type of a semi-resolved value.
Object | hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner) Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset.
boolean | isAnyType() Is this an "any" type.
boolean | isAssociationType() Return true if the implementation is castable to AssociationType.
boolean | isCollectionType() Is this type a collection type.
boolean | isComponentType() Is this type a component type.
boolean | isDirty(Object old, Object current, SessionImplementor session) Should the parent be considered dirty, given both the old and current field or element value?
boolean | isEntityType() Is this type an entity type?
boolean | isEqual(Object x, Object y, EntityMode entityMode) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
boolean | isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
boolean | isModified(Object old, Object current, boolean[] checkable, SessionImplementor session) Has the parent object been modified, compared to the current database state?
boolean | isSame(Object x, Object y, EntityMode entityMode) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.
boolean | isXMLElement()
Object | replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
protected static void | replaceNode(org.dom4j.Node container, org.dom4j.Element value)
Object | resolve(Object value, SessionImplementor session, Object owner) Map identifiers to entities or collections.
Object | semiResolve(Object value, SessionImplementor session, Object owner) Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
deepCopy, fromXMLNode, getColumnSpan, getName, getReturnedClass, isDirty, isMutable, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Constructor Detail

AbstractType

public AbstractType()
Method Detail

isAssociationType

public boolean isAssociationType()
Description copied from interface: Type
Return true if the implementation is castable to AssociationType. This does not necessarily imply that the type actually represents an association.

Specified by:
isAssociationType in interface Type
Returns:
boolean
See Also:
AssociationType

isCollectionType

public boolean isCollectionType()
Description copied from interface: Type
Is this type a collection type.

Specified by:
isCollectionType in interface Type

isComponentType

public boolean isComponentType()
Description copied from interface: Type
Is this type a component type. If so, the implementation must be castable to AbstractComponentType. A component type may own collections or associations and hence must provide certain extra functionality.

Specified by:
isComponentType in interface Type
Returns:
boolean
See Also:
AbstractComponentType

isEntityType

public boolean isEntityType()
Description copied from interface: Type
Is this type an entity type?

Specified by:
isEntityType in interface Type
Returns:
boolean

isXMLElement

public boolean isXMLElement()
Specified by:
isXMLElement in interface Type

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Parameters:
entityMode -

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Description copied from interface: Type
Return a cacheable "disassembled" representation of the object.

Specified by:
disassemble in interface Type
Parameters:
value - the value to cache
session - the session
owner - optional parent entity object (needed for collections)
Returns:
the disassembled, deep cloned state
Throws:
HibernateException

assemble

public Object assemble(Serializable cached,
                       SessionImplementor session,
                       Object owner)
                throws HibernateException
Description copied from interface: Type
Reconstruct the object from its cached "disassembled" state.

Specified by:
assemble in interface Type
Parameters:
cached - the disassembled state from the cache
session - the session
owner - the parent entity object
Returns:
the the object
Throws:
HibernateException

isDirty

public boolean isDirty(Object old,
                       Object current,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Specified by:
isDirty in interface Type
Parameters:
old - the old value
current - the current value
session -
Returns:
true if the field is dirty
Throws:
HibernateException

hydrate

public Object hydrate(ResultSet rs,
                      String[] names,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException,
                      SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset. This is useful for 2-phase property initialization - the second phase is a call to resolveIdentifier().

Specified by:
hydrate in interface Type
Parameters:
rs -
names - the column names
session - the session
owner - the parent entity
Returns:
Object an identifier or actual value
Throws:
HibernateException
SQLException
See Also:
Type.resolve(Object, SessionImplementor, Object)

resolve

public Object resolve(Object value,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException
Description copied from interface: Type
Map identifiers to entities or collections. This is the second phase of 2-phase property initialization.

Specified by:
resolve in interface Type
Parameters:
value - an identifier or value returned by hydrate()
owner - the parent entity
session - the session
Returns:
the given value, or the value associated with the identifier
Throws:
HibernateException
See Also:
Type.hydrate(ResultSet, String[], SessionImplementor, Object)

semiResolve

public Object semiResolve(Object value,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException
Description copied from interface: Type
Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.

Specified by:
semiResolve in interface Type
Throws:
HibernateException

isAnyType

public boolean isAnyType()
Description copied from interface: Type
Is this an "any" type. i.e. a reference to a persistent entity that is not modelled as a (foreign key) association.

Specified by:
isAnyType in interface Type

isModified

public boolean isModified(Object old,
                          Object current,
                          boolean[] checkable,
                          SessionImplementor session)
                   throws HibernateException
Description copied from interface: Type
Has the parent object been modified, compared to the current database state?

Specified by:
isModified in interface Type
Parameters:
old - the database state, in a "hydrated" form, with identifiers unresolved
current - the current state of the object
checkable - which columns are actually updatable
session -
Returns:
true if the field has been modified
Throws:
HibernateException

isSame

public boolean isSame(Object x,
                      Object y,
                      EntityMode entityMode)
               throws HibernateException
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.

Specified by:
isSame in interface Type
Parameters:
x -
y -
entityMode -
Returns:
boolean
Throws:
HibernateException

isEqual

public boolean isEqual(Object x,
                       Object y,
                       EntityMode entityMode)
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Specified by:
isEqual in interface Type
Parameters:
x -
y -
entityMode -
Returns:
boolean

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Parameters:
x -
entityMode -

isEqual

public boolean isEqual(Object x,
                       Object y,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Specified by:
isEqual in interface Type
Parameters:
x -
y -
entityMode -
Returns:
boolean

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Parameters:
x -
entityMode -
factory -

replaceNode

protected static void replaceNode(org.dom4j.Node container,
                                  org.dom4j.Element value)

getSemiResolvedType

public Type getSemiResolvedType(SessionFactoryImplementor factory)
Description copied from interface: Type
Get the type of a semi-resolved value.

Specified by:
getSemiResolvedType in interface Type

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache,
                      ForeignKeyDirection foreignKeyDirection)
               throws HibernateException
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Specified by:
replace in interface Type
Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException

beforeAssemble

public void beforeAssemble(Serializable cached,
                           SessionImplementor session)
Description copied from interface: Type
Called before assembling a query result set from the query cache, to allow batch fetching of entities missing from the second-level cache.

Specified by:
beforeAssemble in interface Type
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AdaptedImmutableType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class AdaptedImmutableType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.AdaptedImmutableType
All Implemented Interfaces:
Serializable, Type
public class AdaptedImmutableType
extends ImmutableType

Optimize a mutable type, if the user promises not to mutable the instances.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
AdaptedImmutableType(NullableType mutableType)
Method Summary
 int compare(Object x, Object y, EntityMode entityMode)
compare two instances of the type
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isEqual(Object x, Object y)
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 String toString(Object value)
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, disassemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AdaptedImmutableType

public AdaptedImmutableType(NullableType mutableType)
Method Detail

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
HibernateException
SQLException

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws HibernateException,
                SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
HibernateException
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

toString

public String toString(Object value)
                throws HibernateException
Specified by:
toString in class NullableType
Throws:
HibernateException

fromStringValue

public Object fromStringValue(String xml)
                       throws HibernateException
Specified by:
fromStringValue in class NullableType
Throws:
HibernateException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name

isEqual

public boolean isEqual(Object x,
                       Object y)
Overrides:
isEqual in class NullableType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Overrides:
compare in class AbstractType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AnyType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class AnyType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.AnyType
All Implemented Interfaces:
AbstractComponentType, AssociationType, Serializable, Type
public class AnyType
extends AbstractType
implements AbstractComponentType, AssociationType

Handles "any" mappings and the old deprecated "object" type

Author:
Gavin King
See Also:
Serialized Form

Nested Class Summary
static class AnyType.ObjectTypeCacheEntry
Constructor Summary
AnyType()
AnyType(Type metaType, Type identifierType)
Method Summary
 Object assemble(Serializable cached, SessionImplementor session, Object owner)
Reconstruct the object from its cached "disassembled" state.
 int compare(Object x, Object y, EntityMode entityMode)
compare two instances of the type
 Object deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Return a deep copy of the persistent state, stopping at entities and at collections.
 Serializable disassemble(Object value, SessionImplementor session, Object owner)
Return a cacheable "disassembled" representation of the object.
 Object fromXMLNode(org.dom4j.Node xml, Mapping factory)
Parse the XML representation of an instance.
 String getAssociatedEntityName(SessionFactoryImplementor factory)
Get the entity name of the associated entity
 Joinable getAssociatedJoinable(SessionFactoryImplementor factory)
Get the "persister" for this association - a class or collection persister
 CascadeStyle getCascadeStyle(int i)
 int getColumnSpan(Mapping session)
How many columns are used to persist this type.
 FetchMode getFetchMode(int i)
 ForeignKeyDirection getForeignKeyDirection()
Get the foreign key directionality of this association
 String getLHSPropertyName()
Get the name of a property in the owning entity that provides the join key (null if the identifier)
 String getName()
Returns the abbreviated name of the type.
 String getOnCondition(String alias, SessionFactoryImplementor factory, Map enabledFilters)
Get the "filtering" SQL fragment that is applied in the SQL on clause, in addition to the usual join condition
 String[] getPropertyNames()
Get the names of the component properties
 boolean[] getPropertyNullability()
Optional operation
 Object getPropertyValue(Object component, int i, SessionImplementor session)
 Object[] getPropertyValues(Object component, EntityMode entityMode)
Optional operation
 Object[] getPropertyValues(Object component, SessionImplementor session)
Get the values of the component properties of a component instance
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 String getRHSUniqueKeyPropertyName()
The name of a unique property of the associated entity that provides the join key (null if the identifier of an entity, or key of a collection)
 Type[] getSubtypes()
Get the types of the component properties
 Object hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset.
 boolean isAlwaysDirtyChecked()
Do we dirty check this association, even when there are no columns to be updated?
 boolean isAnyType()
Is this an "any" type.
 boolean isAssociationType()
Return true if the implementation is castable to AssociationType.
 boolean isComponentType()
Is this type a component type.
 boolean isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Should the parent be considered dirty, given both the old and current field or element value?
 boolean isEmbedded()
 boolean isEmbeddedInXML()
 boolean isMethodOf(Method method)
 boolean isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
Has the parent object been modified, compared to the current database state?
 boolean isMutable()
Are objects of this type mutable.
 boolean isReferenceToPrimaryKey()
 boolean isSame(Object x, Object y, EntityMode entityMode)
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.
 Object nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 Object nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 void nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
Write an instance of the mapped class to a prepared statement, ignoring some columns.
 void nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Write an instance of the mapped class to a prepared statement.
 Object replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
 Object resolve(Object value, SessionImplementor session, Object owner)
Map identifiers to entities or collections.
 Object semiResolve(Object value, SessionImplementor session, Object owner)
Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.
 void setPropertyValues(Object component, Object[] values, EntityMode entityMode)
Optional operation
 void setToXMLNode(org.dom4j.Node xml, Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in an XML element.
 int[] sqlTypes(Mapping mapping)
Return the SQL type codes for the columns mapped by this type.
 boolean[] toColumnNullness(Object value, Mapping mapping)
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
 String toLoggableString(Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in a log file.
 boolean useLHSPrimaryKey()
Is the primary key of the owning entity table to be used in the join?
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getHashCode, getSemiResolvedType, isCollectionType, isDirty, isEntityType, isEqual, isEqual, isXMLElement, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getHashCode, getSemiResolvedType, isCollectionType, isDirty, isEntityType, isEqual, isEqual, isXMLElement, replace

Constructor Detail

AnyType

public AnyType(Type metaType,
               Type identifierType)

AnyType

public AnyType()
Method Detail

deepCopy

public Object deepCopy(Object value,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
                throws HibernateException
Description copied from interface: Type
Return a deep copy of the persistent state, stopping at entities and at collections.

Specified by:
deepCopy in interface Type
Parameters:
value - generally a collection element or entity field
entityMode -
factory -
Returns:
Object a copy
Throws:
HibernateException

isMethodOf

public boolean isMethodOf(Method method)
Specified by:
isMethodOf in interface AbstractComponentType

isSame

public boolean isSame(Object x,
                      Object y,
                      EntityMode entityMode)
               throws HibernateException
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.

Specified by:
isSame in interface Type
Overrides:
isSame in class AbstractType
Throws:
HibernateException

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Overrides:
compare in class AbstractType

getColumnSpan

public int getColumnSpan(Mapping session)
                  throws MappingException
Description copied from interface: Type
How many columns are used to persist this type.

Specified by:
getColumnSpan in interface Type
Throws:
MappingException

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

isMutable

public boolean isMutable()
Description copied from interface: Type
Are objects of this type mutable. (With respect to the referencing object ... entities and collections are considered immutable because they manage their own internal state.)

Specified by:
isMutable in interface Type
Returns:
boolean

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String name,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementations should handle possibility of null values. This method might be called if the type is known to be a single-column type.

Specified by:
nullSafeGet in interface Type
Parameters:
rs -
name - the column name
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String[] names,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Specified by:
nullSafeGet in interface Type
Parameters:
rs -
names - the column names
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException
See Also:
alternative, 2-phase property initialization

hydrate

public Object hydrate(ResultSet rs,
                      String[] names,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException,
                      SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset. This is useful for 2-phase property initialization - the second phase is a call to resolveIdentifier().

Specified by:
hydrate in interface Type
Overrides:
hydrate in class AbstractType
Throws:
HibernateException
SQLException

resolve

public Object resolve(Object value,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException
Description copied from interface: Type
Map identifiers to entities or collections. This is the second phase of 2-phase property initialization.

Specified by:
resolve in interface Type
Overrides:
resolve in class AbstractType
Throws:
HibernateException

semiResolve

public Object semiResolve(Object value,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException
Description copied from interface: Type
Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.

Specified by:
semiResolve in interface Type
Overrides:
semiResolve in class AbstractType
Throws:
HibernateException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Specified by:
nullSafeSet in interface Type
Parameters:
st -
value - the object to write
index - statement parameter index
session -
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        boolean[] settable,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement, ignoring some columns. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Specified by:
nullSafeSet in interface Type
Parameters:
st -
value - the object to write
index - statement parameter index
settable - an array indicating which columns to ignore
session -
Throws:
HibernateException
SQLException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

sqlTypes

public int[] sqlTypes(Mapping mapping)
               throws MappingException
Description copied from interface: Type
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Specified by:
sqlTypes in interface Type
Returns:
the typecodes
Throws:
MappingException
See Also:
Types

setToXMLNode

public void setToXMLNode(org.dom4j.Node xml,
                         Object value,
                         SessionFactoryImplementor factory)
Description copied from interface: Type
A representation of the value to be embedded in an XML element.

Specified by:
setToXMLNode in interface Type
Parameters:
value -
factory -
Returns:
String

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
                        throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in a log file.

Specified by:
toLoggableString in interface Type
Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

fromXMLNode

public Object fromXMLNode(org.dom4j.Node xml,
                          Mapping factory)
                   throws HibernateException
Description copied from interface: Type
Parse the XML representation of an instance.

Specified by:
fromXMLNode in interface Type
Parameters:
xml -
factory -
Returns:
an instance of the type
Throws:
HibernateException

assemble

public Object assemble(Serializable cached,
                       SessionImplementor session,
                       Object owner)
                throws HibernateException
Description copied from interface: Type
Reconstruct the object from its cached "disassembled" state.

Specified by:
assemble in interface Type
Overrides:
assemble in class AbstractType
Throws:
HibernateException

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Description copied from interface: Type
Return a cacheable "disassembled" representation of the object.

Specified by:
disassemble in interface Type
Overrides:
disassemble in class AbstractType
Throws:
HibernateException

isAnyType

public boolean isAnyType()
Description copied from interface: Type
Is this an "any" type. i.e. a reference to a persistent entity that is not modelled as a (foreign key) association.

Specified by:
isAnyType in interface Type
Overrides:
isAnyType in class AbstractType

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache)
               throws HibernateException
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Specified by:
replace in interface Type
Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException

getCascadeStyle

public CascadeStyle getCascadeStyle(int i)
Specified by:
getCascadeStyle in interface AbstractComponentType

getFetchMode

public FetchMode getFetchMode(int i)
Specified by:
getFetchMode in interface AbstractComponentType

getPropertyNames

public String[] getPropertyNames()
Description copied from interface: AbstractComponentType
Get the names of the component properties

Specified by:
getPropertyNames in interface AbstractComponentType

getPropertyValue

public Object getPropertyValue(Object component,
                               int i,
                               SessionImplementor session)
                        throws HibernateException
Specified by:
getPropertyValue in interface AbstractComponentType
Throws:
HibernateException

getPropertyValues

public Object[] getPropertyValues(Object component,
                                  SessionImplementor session)
                           throws HibernateException
Description copied from interface: AbstractComponentType
Get the values of the component properties of a component instance

Specified by:
getPropertyValues in interface AbstractComponentType
Throws:
HibernateException

getSubtypes

public Type[] getSubtypes()
Description copied from interface: AbstractComponentType
Get the types of the component properties

Specified by:
getSubtypes in interface AbstractComponentType

setPropertyValues

public void setPropertyValues(Object component,
                              Object[] values,
                              EntityMode entityMode)
                       throws HibernateException
Description copied from interface: AbstractComponentType
Optional operation

Specified by:
setPropertyValues in interface AbstractComponentType
Throws:
HibernateException

getPropertyValues

public Object[] getPropertyValues(Object component,
                                  EntityMode entityMode)
Description copied from interface: AbstractComponentType
Optional operation

Specified by:
getPropertyValues in interface AbstractComponentType

isComponentType

public boolean isComponentType()
Description copied from interface: Type
Is this type a component type. If so, the implementation must be castable to AbstractComponentType. A component type may own collections or associations and hence must provide certain extra functionality.

Specified by:
isComponentType in interface Type
Overrides:
isComponentType in class AbstractType

getForeignKeyDirection

public ForeignKeyDirection getForeignKeyDirection()
Description copied from interface: AssociationType
Get the foreign key directionality of this association

Specified by:
getForeignKeyDirection in interface AssociationType

isAssociationType

public boolean isAssociationType()
Description copied from interface: Type
Return true if the implementation is castable to AssociationType. This does not necessarily imply that the type actually represents an association.

Specified by:
isAssociationType in interface Type
Overrides:
isAssociationType in class AbstractType

useLHSPrimaryKey

public boolean useLHSPrimaryKey()
Description copied from interface: AssociationType
Is the primary key of the owning entity table to be used in the join?

Specified by:
useLHSPrimaryKey in interface AssociationType

getAssociatedJoinable

public Joinable getAssociatedJoinable(SessionFactoryImplementor factory)
Description copied from interface: AssociationType
Get the "persister" for this association - a class or collection persister

Specified by:
getAssociatedJoinable in interface AssociationType

isModified

public boolean isModified(Object old,
                          Object current,
                          boolean[] checkable,
                          SessionImplementor session)
                   throws HibernateException
Description copied from interface: Type
Has the parent object been modified, compared to the current database state?

Specified by:
isModified in interface Type
Overrides:
isModified in class AbstractType
Throws:
HibernateException

getAssociatedEntityName

public String getAssociatedEntityName(SessionFactoryImplementor factory)
                               throws MappingException
Description copied from interface: AssociationType
Get the entity name of the associated entity

Specified by:
getAssociatedEntityName in interface AssociationType
Throws:
MappingException

getPropertyNullability

public boolean[] getPropertyNullability()
Description copied from interface: AbstractComponentType
Optional operation

Specified by:
getPropertyNullability in interface AbstractComponentType
Returns:
nullability of component properties

getOnCondition

public String getOnCondition(String alias,
                             SessionFactoryImplementor factory,
                             Map enabledFilters)
                      throws MappingException
Description copied from interface: AssociationType
Get the "filtering" SQL fragment that is applied in the SQL on clause, in addition to the usual join condition

Specified by:
getOnCondition in interface AssociationType
Throws:
MappingException

isReferenceToPrimaryKey

public boolean isReferenceToPrimaryKey()

getRHSUniqueKeyPropertyName

public String getRHSUniqueKeyPropertyName()
Description copied from interface: AssociationType
The name of a unique property of the associated entity that provides the join key (null if the identifier of an entity, or key of a collection)

Specified by:
getRHSUniqueKeyPropertyName in interface AssociationType

getLHSPropertyName

public String getLHSPropertyName()
Description copied from interface: AssociationType
Get the name of a property in the owning entity that provides the join key (null if the identifier)

Specified by:
getLHSPropertyName in interface AssociationType

isAlwaysDirtyChecked

public boolean isAlwaysDirtyChecked()
Description copied from interface: AssociationType
Do we dirty check this association, even when there are no columns to be updated?

Specified by:
isAlwaysDirtyChecked in interface AssociationType

isEmbeddedInXML

public boolean isEmbeddedInXML()
Specified by:
isEmbeddedInXML in interface AssociationType

toColumnNullness

public boolean[] toColumnNullness(Object value,
                                  Mapping mapping)
Description copied from interface: Type
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.

Specified by:
toColumnNullness in interface Type
Parameters:
value - an instance of the type

isDirty

public boolean isDirty(Object old,
                       Object current,
                       boolean[] checkable,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Specified by:
isDirty in interface Type
Parameters:
old - the old value
current - the current value
checkable - which columns are actually updatable
session -
Returns:
true if the field is dirty
Throws:
HibernateException

isEmbedded

public boolean isEmbedded()
Specified by:
isEmbedded in interface AbstractComponentType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AnyType.ObjectTypeCacheEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class AnyType.ObjectTypeCacheEntry

java.lang.Object
    extended by org.hibernate.type.AnyType.ObjectTypeCacheEntry
All Implemented Interfaces:
Serializable
Enclosing class:
AnyType
public static final class AnyType.ObjectTypeCacheEntry
extends Object
implements Serializable

See Also:
Serialized Form

Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArrayType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class ArrayType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CollectionType
            extended by org.hibernate.type.ArrayType
All Implemented Interfaces:
AssociationType, Serializable, Type
public class ArrayType
extends CollectionType

A type for persistent arrays.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.CollectionType
UNFETCHED_COLLECTION
Constructor Summary
ArrayType(String role, String propertyRef, Class elementClass, boolean isEmbeddedInXML)
Method Summary
 Iterator getElementsIterator(Object collection)
Not defined for collections of primitive type
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean hasHolder(EntityMode entityMode)
 Object indexOf(Object array, Object element)
protected  boolean initializeImmediately(EntityMode entityMode)
 Object instantiate(int anticipatedSize)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
 PersistentCollection instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
Instantiate an uninitialized collection wrapper or holder.
 Object instantiateResult(Object original)
Instantiate a new "underlying" collection exhibiting the same capacity charactersitcs and the passed "original".
 boolean isArrayType()
 Object replaceElements(Object original, Object target, Object owner, Map copyCache, SessionImplementor session)
Replace the elements of a collection with the elements of another collection
 String toLoggableString(Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in a log file.
 PersistentCollection wrap(SessionImplementor session, Object array)
Wrap the naked collection instance in a wrapper, or instantiate a holder.
Methods inherited from class org.hibernate.type.CollectionType
assemble, compare, contains, deepCopy, disassemble, fromXMLNode, getAssociatedEntityName, getAssociatedJoinable, getCollection, getColumnSpan, getElementsIterator, getElementType, getForeignKeyDirection, getHashCode, getKeyOfOwner, getLHSPropertyName, getName, getOnCondition, getRHSUniqueKeyPropertyName, getRole, hydrate, isAlwaysDirtyChecked, isAssociationType, isCollectionType, isDirty, isDirty, isEmbeddedInXML, isEqual, isModified, isMutable, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, renderLoggableString, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toString, useLHSPrimaryKey
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace

Constructor Detail

ArrayType

public ArrayType(String role,
                 String propertyRef,
                 Class elementClass,
                 boolean isEmbeddedInXML)
Method Detail

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

instantiate

public PersistentCollection instantiate(SessionImplementor session,
                                        CollectionPersister persister,
                                        Serializable key)
                                 throws HibernateException
Description copied from class: CollectionType
Instantiate an uninitialized collection wrapper or holder. Callers MUST add the holder to the persistence context!

Specified by:
instantiate in class CollectionType
Throws:
HibernateException

getElementsIterator

public Iterator getElementsIterator(Object collection)
Not defined for collections of primitive type

Overrides:
getElementsIterator in class CollectionType

wrap

public PersistentCollection wrap(SessionImplementor session,
                                 Object array)
Description copied from class: CollectionType
Wrap the naked collection instance in a wrapper, or instantiate a holder. Callers MUST add the holder to the persistence context!

Specified by:
wrap in class CollectionType

isArrayType

public boolean isArrayType()
Overrides:
isArrayType in class CollectionType

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
                        throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in a log file.

Specified by:
toLoggableString in interface Type
Overrides:
toLoggableString in class CollectionType
Throws:
HibernateException

instantiateResult

public Object instantiateResult(Object original)
Description copied from class: CollectionType
Instantiate a new "underlying" collection exhibiting the same capacity charactersitcs and the passed "original".

Overrides:
instantiateResult in class CollectionType
Parameters:
original - The original collection.
Returns:
The newly instantiated collection.

replaceElements

public Object replaceElements(Object original,
                              Object target,
                              Object owner,
                              Map copyCache,
                              SessionImplementor session)
                       throws HibernateException
Description copied from class: CollectionType
Replace the elements of a collection with the elements of another collection

Overrides:
replaceElements in class CollectionType
Throws:
HibernateException

instantiate

public Object instantiate(int anticipatedSize)
Description copied from class: CollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial capacity and perhaps load factor).

Specified by:
instantiate in class CollectionType
Parameters:
anticipatedSize - The anticipated size of the instaniated collection after we are done populating it.

indexOf

public Object indexOf(Object array,
                      Object element)
Overrides:
indexOf in class CollectionType

initializeImmediately

protected boolean initializeImmediately(EntityMode entityMode)
Overrides:
initializeImmediately in class CollectionType

hasHolder

public boolean hasHolder(EntityMode entityMode)
Overrides:
hasHolder in class CollectionType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BagType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class BagType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CollectionType
            extended by org.hibernate.type.BagType
All Implemented Interfaces:
AssociationType, Serializable, Type
public class BagType
extends CollectionType

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.CollectionType
UNFETCHED_COLLECTION
Constructor Summary
BagType(String role, String propertyRef, boolean isEmbeddedInXML)
Method Summary
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Object instantiate(int anticipatedSize)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
 PersistentCollection instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
Instantiate an uninitialized collection wrapper or holder.
 PersistentCollection wrap(SessionImplementor session, Object collection)
Wrap the naked collection instance in a wrapper, or instantiate a holder.
Methods inherited from class org.hibernate.type.CollectionType
assemble, compare, contains, deepCopy, disassemble, fromXMLNode, getAssociatedEntityName, getAssociatedJoinable, getCollection, getColumnSpan, getElementsIterator, getElementsIterator, getElementType, getForeignKeyDirection, getHashCode, getKeyOfOwner, getLHSPropertyName, getName, getOnCondition, getRHSUniqueKeyPropertyName, getRole, hasHolder, hydrate, indexOf, initializeImmediately, instantiateResult, isAlwaysDirtyChecked, isArrayType, isAssociationType, isCollectionType, isDirty, isDirty, isEmbeddedInXML, isEqual, isModified, isMutable, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, renderLoggableString, replace, replaceElements, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toString, useLHSPrimaryKey
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace

Constructor Detail

BagType

public BagType(String role,
               String propertyRef,
               boolean isEmbeddedInXML)
Method Detail

instantiate

public PersistentCollection instantiate(SessionImplementor session,
                                        CollectionPersister persister,
                                        Serializable key)
                                 throws HibernateException
Description copied from class: CollectionType
Instantiate an uninitialized collection wrapper or holder. Callers MUST add the holder to the persistence context!

Specified by:
instantiate in class CollectionType
Throws:
HibernateException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

wrap

public PersistentCollection wrap(SessionImplementor session,
                                 Object collection)
Description copied from class: CollectionType
Wrap the naked collection instance in a wrapper, or instantiate a holder. Callers MUST add the holder to the persistence context!

Specified by:
wrap in class CollectionType

instantiate

public Object instantiate(int anticipatedSize)
Description copied from class: CollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial capacity and perhaps load factor).

Specified by:
instantiate in class CollectionType
Parameters:
anticipatedSize - The anticipated size of the instaniated collection after we are done populating it.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BigDecimalType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class BigDecimalType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.BigDecimalType
All Implemented Interfaces:
Serializable, Type
public class BigDecimalType
extends ImmutableType

big_decimal: A type that maps an SQL NUMERIC to a java.math.BigDecimal

Author:
Gavin King
See Also:
BigDecimal, Serialized Form

Constructor Summary
BigDecimalType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isEqual(Object x, Object y)
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 String toString(Object value)
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BigDecimalType

public BigDecimalType()
Method Detail

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
HibernateException
SQLException

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws HibernateException,
                SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
HibernateException
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

toString

public String toString(Object value)
                throws HibernateException
Specified by:
toString in class NullableType
Throws:
HibernateException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

isEqual

public boolean isEqual(Object x,
                       Object y)
Overrides:
isEqual in class NullableType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BigIntegerType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class BigIntegerType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.BigIntegerType
All Implemented Interfaces:
DiscriminatorType, IdentifierType, LiteralType, Serializable, Type
public class BigIntegerType
extends ImmutableType
implements DiscriminatorType

big_integer: A type that maps an SQL NUMERIC to a java.math.BigInteger

Author:
Gavin King
See Also:
BigInteger, Serialized Form

Constructor Summary
BigIntegerType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isEqual(Object x, Object y)
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 Object stringToObject(String xml)
Convert the value from the mapping file to a Java object.
 String toString(Object value)
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Constructor Detail

BigIntegerType

public BigIntegerType()
Method Detail

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

stringToObject

public Object stringToObject(String xml)
                      throws Exception
Description copied from interface: IdentifierType
Convert the value from the mapping file to a Java object.

Specified by:
stringToObject in interface IdentifierType
Parameters:
xml - the value of discriminator-value or unsaved-value attribute
Returns:
Object
Throws:
Exception

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
HibernateException
SQLException

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws HibernateException,
                SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
HibernateException
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

toString

public String toString(Object value)
                throws HibernateException
Specified by:
toString in class NullableType
Throws:
HibernateException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

isEqual

public boolean isEqual(Object x,
                       Object y)
Overrides:
isEqual in class NullableType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BinaryType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class BinaryType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.AbstractBynaryType
                    extended by org.hibernate.type.BinaryType
All Implemented Interfaces:
Comparator, Serializable, Type, VersionType
public class BinaryType
extends AbstractBynaryType

binary: A type that maps an SQL VARBINARY to a Java byte[].

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
BinaryType()
Method Summary
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
protected  Object toExternalFormat(byte[] bytes)
Convert the byte[] into the expected object type
protected  byte[] toInternalFormat(Object bytes)
Convert the object into the internal byte[] representation
Methods inherited from class org.hibernate.type.AbstractBynaryType
compare, compare, deepCopyNotNull, fromStringValue, get, getComparator, getHashCode, isEqual, next, seed, set, sqlType, toString
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, disassemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString
Methods inherited from interface java.util.Comparator
equals

Constructor Detail

BinaryType

public BinaryType()
Method Detail

toExternalFormat

protected Object toExternalFormat(byte[] bytes)
Description copied from class: AbstractBynaryType
Convert the byte[] into the expected object type

Specified by:
toExternalFormat in class AbstractBynaryType

toInternalFormat

protected byte[] toInternalFormat(Object bytes)
Description copied from class: AbstractBynaryType
Convert the object into the internal byte[] representation

Specified by:
toInternalFormat in class AbstractBynaryType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Specified by:
getName in class AbstractBynaryType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BlobType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class BlobType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.BlobType
All Implemented Interfaces:
Serializable, Type
public class BlobType
extends AbstractType

blob: A type that maps an SQL BLOB to a java.sql.Blob.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
BlobType()
Method Summary
 int compare(Object x, Object y, EntityMode entityMode)
compare two instances of the type
 Object deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Return a deep copy of the persistent state, stopping at entities and at collections.
 Serializable disassemble(Object value, SessionImplementor session, Object owner)
Return a cacheable "disassembled" representation of the object.
 Object fromXMLNode(org.dom4j.Node xml, Mapping factory)
Parse the XML representation of an instance.
 Object get(ResultSet rs, String name)
 int getColumnSpan(Mapping mapping)
How many columns are used to persist this type.
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Should the parent be considered dirty, given both the old and current field or element value?
 boolean isEqual(Object x, Object y, EntityMode entityMode)
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
 boolean isMutable()
Are objects of this type mutable.
 Object nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 Object nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 void nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
Write an instance of the mapped class to a prepared statement, ignoring some columns.
 void nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Write an instance of the mapped class to a prepared statement.
 Object replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
 void set(PreparedStatement st, Object value, int index, SessionImplementor session)
 void setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in an XML element.
 int[] sqlTypes(Mapping mapping)
Return the SQL type codes for the columns mapped by this type.
 boolean[] toColumnNullness(Object value, Mapping mapping)
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
 String toLoggableString(Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in a log file.
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BlobType

public BlobType()
Method Detail

set

public void set(PreparedStatement st,
                Object value,
                int index,
                SessionImplementor session)
         throws HibernateException,
                SQLException
Throws:
HibernateException
SQLException

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Throws:
HibernateException
SQLException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

isEqual

public boolean isEqual(Object x,
                       Object y,
                       EntityMode entityMode)
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Specified by:
isEqual in interface Type
Overrides:
isEqual in class AbstractType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Overrides:
compare in class AbstractType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Description copied from interface: Type
Return a cacheable "disassembled" representation of the object.

Specified by:
disassemble in interface Type
Overrides:
disassemble in class AbstractType
Throws:
HibernateException

deepCopy

public Object deepCopy(Object value,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
Description copied from interface: Type
Return a deep copy of the persistent state, stopping at entities and at collections.

Parameters:
value - generally a collection element or entity field
entityMode -
factory -
Returns:
Object a copy

fromXMLNode

public Object fromXMLNode(org.dom4j.Node xml,
                          Mapping factory)
Description copied from interface: Type
Parse the XML representation of an instance.

Parameters:
xml -
factory -
Returns:
an instance of the type

getColumnSpan

public int getColumnSpan(Mapping mapping)
Description copied from interface: Type
How many columns are used to persist this type.

isMutable

public boolean isMutable()
Description copied from interface: Type
Are objects of this type mutable. (With respect to the referencing object ... entities and collections are considered immutable because they manage their own internal state.)

Returns:
boolean

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String name,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementations should handle possibility of null values. This method might be called if the type is known to be a single-column type.

Parameters:
rs -
name - the column name
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String[] names,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Parameters:
rs -
names - the column names
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException
See Also:
alternative, 2-phase property initialization

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        boolean[] settable,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement, ignoring some columns. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
settable - an array indicating which columns to ignore
session -
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
session -
Throws:
HibernateException
SQLException

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache)
               throws HibernateException
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException

sqlTypes

public int[] sqlTypes(Mapping mapping)
               throws MappingException
Description copied from interface: Type
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Returns:
the typecodes
Throws:
MappingException
See Also:
Types

setToXMLNode

public void setToXMLNode(org.dom4j.Node node,
                         Object value,
                         SessionFactoryImplementor factory)
Description copied from interface: Type
A representation of the value to be embedded in an XML element.

Parameters:
value -
factory -
Returns:
String

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
                        throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in a log file.

Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

toColumnNullness

public boolean[] toColumnNullness(Object value,
                                  Mapping mapping)
Description copied from interface: Type
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.

Parameters:
value - an instance of the type

isDirty

public boolean isDirty(Object old,
                       Object current,
                       boolean[] checkable,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Parameters:
old - the old value
current - the current value
checkable - which columns are actually updatable
session -
Returns:
true if the field is dirty
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BooleanType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class BooleanType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.PrimitiveType
                    extended by org.hibernate.type.BooleanType
All Implemented Interfaces:
DiscriminatorType, IdentifierType, LiteralType, Serializable, Type
Direct Known Subclasses:
CharBooleanType
public class BooleanType
extends PrimitiveType
implements DiscriminatorType

boolean: A type that maps an SQL BIT to a Java Boolean.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
BooleanType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 Serializable getDefaultValue()
 String getName()
Returns the abbreviated name of the type.
 Class getPrimitiveClass()
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 Object stringToObject(String xml)
Convert the value from the mapping file to a Java object.
Methods inherited from class org.hibernate.type.PrimitiveType
toString
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Constructor Detail

BooleanType

public BooleanType()
Method Detail

getDefaultValue

public Serializable getDefaultValue()
Specified by:
getDefaultValue in class PrimitiveType

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getPrimitiveClass

public Class getPrimitiveClass()
Specified by:
getPrimitiveClass in class PrimitiveType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

stringToObject

public Object stringToObject(String xml)
                      throws Exception
Description copied from interface: IdentifierType
Convert the value from the mapping file to a Java object.

Specified by:
stringToObject in interface IdentifierType
Parameters:
xml - the value of discriminator-value or unsaved-value attribute
Returns:
Object
Throws:
Exception

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ByteType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class ByteType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.PrimitiveType
                    extended by org.hibernate.type.ByteType
All Implemented Interfaces:
DiscriminatorType, IdentifierType, LiteralType, Serializable, Type, VersionType
public class ByteType
extends PrimitiveType
implements DiscriminatorType, VersionType

byte: A type that maps an SQL TINYINT to a Java Byte.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
ByteType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 Comparator getComparator()
Get a comparator for version values.
 Serializable getDefaultValue()
 String getName()
Returns the abbreviated name of the type.
 Class getPrimitiveClass()
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Object next(Object current, SessionImplementor session)
Increment the version.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 Object seed(SessionImplementor session)
Generate an initial version.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 Object stringToObject(String xml)
Convert the value from the mapping file to a Java object.
Methods inherited from class org.hibernate.type.PrimitiveType
toString
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString
Methods inherited from interface org.hibernate.type.VersionType
isEqual

Constructor Detail

ByteType

public ByteType()
Method Detail

getDefaultValue

public Serializable getDefaultValue()
Specified by:
getDefaultValue in class PrimitiveType

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getPrimitiveClass

public Class getPrimitiveClass()
Specified by:
getPrimitiveClass in class PrimitiveType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

stringToObject

public Object stringToObject(String xml)
                      throws Exception
Description copied from interface: IdentifierType
Convert the value from the mapping file to a Java object.

Specified by:
stringToObject in interface IdentifierType
Parameters:
xml - the value of discriminator-value or unsaved-value attribute
Returns:
Object
Throws:
Exception

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType

next

public Object next(Object current,
                   SessionImplementor session)
Description copied from interface: VersionType
Increment the version.

Specified by:
next in interface VersionType
Parameters:
session - The session from which this request originates.
current - the current version
Returns:
an instance of the type

seed

public Object seed(SessionImplementor session)
Description copied from interface: VersionType
Generate an initial version.

Specified by:
seed in interface VersionType
Parameters:
session - The session from which this request originates.
Returns:
an instance of the type

getComparator

public Comparator getComparator()
Description copied from interface: VersionType
Get a comparator for version values.

Specified by:
getComparator in interface VersionType
Returns:
The comparator to use to compare different version values.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CalendarDateType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class CalendarDateType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.CalendarDateType
All Implemented Interfaces:
Serializable, Type
public class CalendarDateType
extends MutableType

calendar_date: A type mapping for a Calendar object that represents a date.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
CalendarDateType()
Method Summary
 int compare(Object x, Object y, EntityMode entityMode)
compare two instances of the type
 Object deepCopyNotNull(Object value)
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isEqual(Object x, Object y)
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 String toString(Object value)
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, disassemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CalendarDateType

public CalendarDateType()
Method Detail

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
HibernateException
SQLException

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws HibernateException,
                SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
HibernateException
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

toString

public String toString(Object value)
                throws HibernateException
Specified by:
toString in class NullableType
Throws:
HibernateException

fromStringValue

public Object fromStringValue(String xml)
                       throws HibernateException
Specified by:
fromStringValue in class NullableType
Throws:
HibernateException

deepCopyNotNull

public Object deepCopyNotNull(Object value)
Specified by:
deepCopyNotNull in class MutableType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Overrides:
compare in class AbstractType

isEqual

public boolean isEqual(Object x,
                       Object y)
Overrides:
isEqual in class NullableType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CalendarType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class CalendarType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.CalendarType
All Implemented Interfaces:
Serializable, Type, VersionType
public class CalendarType
extends MutableType
implements VersionType

calendar: A type mapping for a Calendar object that represents a datetime.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
CalendarType()
Method Summary
 int compare(Object x, Object y, EntityMode entityMode)
compare two instances of the type
 Object deepCopyNotNull(Object value)
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 Comparator getComparator()
Get a comparator for version values.
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isEqual(Object x, Object y)
Are the two version values considered equal?
 Object next(Object current, SessionImplementor session)
Increment the version.
 Object seed(SessionImplementor session)
Generate an initial version.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 String toString(Object value)
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, disassemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Constructor Detail

CalendarType

public CalendarType()
Method Detail

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
HibernateException
SQLException

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws HibernateException,
                SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
HibernateException
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

toString

public String toString(Object value)
                throws HibernateException
Specified by:
toString in class NullableType
Throws:
HibernateException

fromStringValue

public Object fromStringValue(String xml)
                       throws HibernateException
Specified by:
fromStringValue in class NullableType
Throws:
HibernateException

deepCopyNotNull

public Object deepCopyNotNull(Object value)
                       throws HibernateException
Specified by:
deepCopyNotNull in class MutableType
Throws:
HibernateException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Overrides:
compare in class AbstractType

isEqual

public boolean isEqual(Object x,
                       Object y)
Description copied from interface: VersionType
Are the two version values considered equal?

Specified by:
isEqual in interface VersionType
Overrides:
isEqual in class NullableType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

next

public Object next(Object current,
                   SessionImplementor session)
Description copied from interface: VersionType
Increment the version.

Specified by:
next in interface VersionType
Parameters:
session - The session from which this request originates.
current - the current version
Returns:
an instance of the type

seed

public Object seed(SessionImplementor session)
Description copied from interface: VersionType
Generate an initial version.

Specified by:
seed in interface VersionType
Parameters:
session - The session from which this request originates.
Returns:
an instance of the type

getComparator

public Comparator getComparator()
Description copied from interface: VersionType
Get a comparator for version values.

Specified by:
getComparator in interface VersionType
Returns:
The comparator to use to compare different version values.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CharacterArrayType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class CharacterArrayType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.AbstractCharArrayType
                    extended by org.hibernate.type.CharacterArrayType
All Implemented Interfaces:
Serializable, Type
public class CharacterArrayType
extends AbstractCharArrayType

Bridge Character[] and VARCHAR

Author:
Emmanuel Bernard
See Also:
Serialized Form

Constructor Summary
CharacterArrayType()
Method Summary
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
protected  Object toExternalFormat(char[] chars)
Convert the char[] into the expected object type
protected  char[] toInternalFormat(Object value)
Convert the object into the internal char[] representation
Methods inherited from class org.hibernate.type.AbstractCharArrayType
deepCopyNotNull, fromStringValue, get, objectToSQLString, set, sqlType, stringToObject, toString
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CharacterArrayType

public CharacterArrayType()
Method Detail

toExternalFormat

protected Object toExternalFormat(char[] chars)
Description copied from class: AbstractCharArrayType
Convert the char[] into the expected object type

Specified by:
toExternalFormat in class AbstractCharArrayType

toInternalFormat

protected char[] toInternalFormat(Object value)
Description copied from class: AbstractCharArrayType
Convert the object into the internal char[] representation

Specified by:
toInternalFormat in class AbstractCharArrayType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Specified by:
getReturnedClass in class AbstractCharArrayType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CharacterType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class CharacterType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.PrimitiveType
                    extended by org.hibernate.type.CharacterType
All Implemented Interfaces:
DiscriminatorType, IdentifierType, LiteralType, Serializable, Type
public class CharacterType
extends PrimitiveType
implements DiscriminatorType

character: A type that maps an SQL CHAR(1) to a Java Character.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
CharacterType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 Serializable getDefaultValue()
 String getName()
Returns the abbreviated name of the type.
 Class getPrimitiveClass()
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 Object stringToObject(String xml)
Convert the value from the mapping file to a Java object.
Methods inherited from class org.hibernate.type.PrimitiveType
toString
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Constructor Detail

CharacterType

public CharacterType()
Method Detail

getDefaultValue

public Serializable getDefaultValue()
Specified by:
getDefaultValue in class PrimitiveType

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getPrimitiveClass

public Class getPrimitiveClass()
Specified by:
getPrimitiveClass in class PrimitiveType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

stringToObject

public Object stringToObject(String xml)
                      throws Exception
Description copied from interface: IdentifierType
Convert the value from the mapping file to a Java object.

Specified by:
stringToObject in interface IdentifierType
Parameters:
xml - the value of discriminator-value or unsaved-value attribute
Returns:
Object
Throws:
Exception

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CharArrayType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class CharArrayType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.AbstractCharArrayType
                    extended by org.hibernate.type.CharArrayType
All Implemented Interfaces:
Serializable, Type
public class CharArrayType
extends AbstractCharArrayType

put char[] into VARCHAR

Author:
Emmanuel Bernard
See Also:
Serialized Form

Constructor Summary
CharArrayType()
Method Summary
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
protected  Object toExternalFormat(char[] chars)
Convert the char[] into the expected object type
protected  char[] toInternalFormat(Object chars)
Convert the object into the internal char[] representation
Methods inherited from class org.hibernate.type.AbstractCharArrayType
deepCopyNotNull, fromStringValue, get, objectToSQLString, set, sqlType, stringToObject, toString
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CharArrayType

public CharArrayType()
Method Detail

toExternalFormat

protected Object toExternalFormat(char[] chars)
Description copied from class: AbstractCharArrayType
Convert the char[] into the expected object type

Specified by:
toExternalFormat in class AbstractCharArrayType

toInternalFormat

protected char[] toInternalFormat(Object chars)
Description copied from class: AbstractCharArrayType
Convert the object into the internal char[] representation

Specified by:
toInternalFormat in class AbstractCharArrayType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Specified by:
getReturnedClass in class AbstractCharArrayType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CharBooleanType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class CharBooleanType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.PrimitiveType
                    extended by org.hibernate.type.BooleanType
                        extended by org.hibernate.type.CharBooleanType
All Implemented Interfaces:
DiscriminatorType, IdentifierType, LiteralType, Serializable, Type
Direct Known Subclasses:
TrueFalseType, YesNoType
public abstract class CharBooleanType
extends BooleanType

Superclass for types that map Java boolean to SQL CHAR(1).

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
CharBooleanType()
Method Summary
Object | get(ResultSet rs, String name) Get a column value from a result set, without worrying about the possibility of null values
protected abstract String | getFalseString()
protected abstract String | getTrueString()
String | objectToSQLString(Object value, Dialect dialect) String representation of the value, suitable for embedding in an SQL statement.
void | set(PreparedStatement st, Object value, int index) Get a parameter value without worrying about the possibility of null values
int | sqlType()
Object | stringToObject(String xml) Convert the value from the mapping file to a Java object.
Methods inherited from class org.hibernate.type.BooleanType
fromStringValue, getDefaultValue, getName, getPrimitiveClass, getReturnedClass
Methods inherited from class org.hibernate.type.PrimitiveType
toString
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Constructor Detail

CharBooleanType

public CharBooleanType()
Method Detail

getTrueString

protected abstract String getTrueString()

getFalseString

protected abstract String getFalseString()

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Overrides:
get in class BooleanType
Throws:
SQLException

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Overrides:
set in class BooleanType
Throws:
SQLException

sqlType

public int sqlType()
Overrides:
sqlType in class BooleanType

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Overrides:
objectToSQLString in class BooleanType
Throws:
Exception

stringToObject

public Object stringToObject(String xml)
                      throws Exception
Description copied from interface: IdentifierType
Convert the value from the mapping file to a Java object.

Specified by:
stringToObject in interface IdentifierType
Overrides:
stringToObject in class BooleanType
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class ClassType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.ClassType
All Implemented Interfaces:
Serializable, Type
public class ClassType
extends ImmutableType

class: A type that maps an SQL VARCHAR to a Java Class.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
ClassType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 String toString(Object value)
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClassType

public ClassType()
Method Detail

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
HibernateException
SQLException

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws HibernateException,
                SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
HibernateException
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

toString

public String toString(Object value)
                throws HibernateException
Specified by:
toString in class NullableType
Throws:
HibernateException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name

fromStringValue

public Object fromStringValue(String xml)
                       throws HibernateException
Specified by:
fromStringValue in class NullableType
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClobType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class ClobType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.ClobType
All Implemented Interfaces:
Serializable, Type
public class ClobType
extends AbstractType

clob: A type that maps an SQL CLOB to a java.sql.Clob.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
ClobType()
Method Summary
 int compare(Object x, Object y, EntityMode entityMode)
compare two instances of the type
 Object deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Return a deep copy of the persistent state, stopping at entities and at collections.
 Serializable disassemble(Object value, SessionImplementor session, Object owner)
Return a cacheable "disassembled" representation of the object.
 Object fromXMLNode(org.dom4j.Node xml, Mapping factory)
Parse the XML representation of an instance.
 Object get(ResultSet rs, String name)
 int getColumnSpan(Mapping mapping)
How many columns are used to persist this type.
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Should the parent be considered dirty, given both the old and current field or element value?
 boolean isEqual(Object x, Object y, EntityMode entityMode)
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
 boolean isMutable()
Are objects of this type mutable.
 Object nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 Object nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 void nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
Write an instance of the mapped class to a prepared statement, ignoring some columns.
 void nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Write an instance of the mapped class to a prepared statement.
 Object replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
 void set(PreparedStatement st, Object value, int index, SessionImplementor session)
 void setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in an XML element.
 int[] sqlTypes(Mapping mapping)
Return the SQL type codes for the columns mapped by this type.
 boolean[] toColumnNullness(Object value, Mapping mapping)
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
 String toLoggableString(Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in a log file.
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClobType

public ClobType()
Method Detail

set

public void set(PreparedStatement st,
                Object value,
                int index,
                SessionImplementor session)
         throws HibernateException,
                SQLException
Throws:
HibernateException
SQLException

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Throws:
HibernateException
SQLException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

isEqual

public boolean isEqual(Object x,
                       Object y,
                       EntityMode entityMode)
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Specified by:
isEqual in interface Type
Overrides:
isEqual in class AbstractType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Overrides:
compare in class AbstractType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Description copied from interface: Type
Return a cacheable "disassembled" representation of the object.

Specified by:
disassemble in interface Type
Overrides:
disassemble in class AbstractType
Throws:
HibernateException

deepCopy

public Object deepCopy(Object value,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
Description copied from interface: Type
Return a deep copy of the persistent state, stopping at entities and at collections.

Parameters:
value - generally a collection element or entity field
entityMode -
factory -
Returns:
Object a copy

fromXMLNode

public Object fromXMLNode(org.dom4j.Node xml,
                          Mapping factory)
Description copied from interface: Type
Parse the XML representation of an instance.

Parameters:
xml -
factory -
Returns:
an instance of the type

getColumnSpan

public int getColumnSpan(Mapping mapping)
Description copied from interface: Type
How many columns are used to persist this type.

isMutable

public boolean isMutable()
Description copied from interface: Type
Are objects of this type mutable. (With respect to the referencing object ... entities and collections are considered immutable because they manage their own internal state.)

Returns:
boolean

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String name,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementations should handle possibility of null values. This method might be called if the type is known to be a single-column type.

Parameters:
rs -
name - the column name
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String[] names,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Parameters:
rs -
names - the column names
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException
See Also:
alternative, 2-phase property initialization

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        boolean[] settable,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement, ignoring some columns. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
settable - an array indicating which columns to ignore
session -
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
session -
Throws:
HibernateException
SQLException

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache)
               throws HibernateException
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException

sqlTypes

public int[] sqlTypes(Mapping mapping)
               throws MappingException
Description copied from interface: Type
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Returns:
the typecodes
Throws:
MappingException
See Also:
Types

setToXMLNode

public void setToXMLNode(org.dom4j.Node node,
                         Object value,
                         SessionFactoryImplementor factory)
Description copied from interface: Type
A representation of the value to be embedded in an XML element.

Parameters:
value -
factory -
Returns:
String

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
                        throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in a log file.

Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

toColumnNullness

public boolean[] toColumnNullness(Object value,
                                  Mapping mapping)
Description copied from interface: Type
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.

Parameters:
value - an instance of the type

isDirty

public boolean isDirty(Object old,
                       Object current,
                       boolean[] checkable,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Parameters:
old - the old value
current - the current value
checkable - which columns are actually updatable
session -
Returns:
true if the field is dirty
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class CollectionType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CollectionType
All Implemented Interfaces:
AssociationType, Serializable, Type
Direct Known Subclasses:
ArrayType, BagType, CustomCollectionType, IdentifierBagType, ListType, MapType, SetType
public abstract class CollectionType
extends AbstractType
implements AssociationType

A type that handles Hibernate PersistentCollections (including arrays).

Author:
Gavin King
See Also:
Serialized Form

Field Summary
static Object UNFETCHED_COLLECTION
Constructor Summary
CollectionType(String role, String foreignKeyPropertyName, boolean isEmbeddedInXML)
Method Summary
Object | assemble(Serializable cached, SessionImplementor session, Object owner) Reconstruct the object from its cached "disassembled" state.
int | compare(Object x, Object y, EntityMode entityMode) compare two instances of the type
boolean | contains(Object collection, Object childObject, SessionImplementor session)
Object | deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory) Return a deep copy of the persistent state, stopping at entities and at collections.
Serializable | disassemble(Object value, SessionImplementor session, Object owner) Return a cacheable "disassembled" representation of the object.
Object | fromXMLNode(org.dom4j.Node xml, Mapping factory) Parse the XML representation of an instance.
String | getAssociatedEntityName(SessionFactoryImplementor factory) Get the entity name of the associated entity
Joinable | getAssociatedJoinable(SessionFactoryImplementor factory) Get the "persister" for this association - a class or collection persister
Object | getCollection(Serializable key, SessionImplementor session, Object owner) instantiate a collection wrapper (called when loading an object)
int | getColumnSpan(Mapping session) How many columns are used to persist this type.
protected Iterator | getElementsIterator(Object collection) Get an iterator over the element set of the collection in POJO mode
Iterator | getElementsIterator(Object collection, SessionImplementor session) Get an iterator over the element set of the collection, which may not yet be wrapped
Type | getElementType(SessionFactoryImplementor factory) Get the Hibernate type of the collection elements
ForeignKeyDirection | getForeignKeyDirection() Get the foreign key directionality of this association
int | getHashCode(Object x, EntityMode entityMode) Get a hashcode, consistent with persistence "equality"
Serializable | getKeyOfOwner(Object owner, SessionImplementor session) Get the key value from the owning entity instance, usually the identifier, but might be some other unique key, in the case of property-ref
String | getLHSPropertyName() Get the name of a property in the owning entity that provides the join key (null if the identifier)
String | getName() Returns the abbreviated name of the type.
String | getOnCondition(String alias, SessionFactoryImplementor factory, Map enabledFilters) Get the "filtering" SQL fragment that is applied in the SQL on clause, in addition to the usual join condition
String | getRHSUniqueKeyPropertyName() The name of a unique property of the associated entity that provides the join key (null if the identifier of an entity, or key of a collection)
String | getRole()
boolean | hasHolder(EntityMode entityMode)
Object | hydrate(ResultSet rs, String[] name, SessionImplementor session, Object owner) Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset.
Object | indexOf(Object collection, Object element)
protected boolean | initializeImmediately(EntityMode entityMode)
abstract Object | instantiate(int anticipatedSize) Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
abstract PersistentCollection | instantiate(SessionImplementor session, CollectionPersister persister, Serializable key) Instantiate an uninitialized collection wrapper or holder.
protected Object | instantiateResult(Object original) Instantiate a new "underlying" collection exhibiting the same capacity charactersitcs and the passed "original".
boolean | isAlwaysDirtyChecked() We always need to dirty check the collection because we sometimes need to incremement version number of owner and also because of how assemble/disassemble is implemented for uks
boolean | isArrayType()
boolean | isAssociationType() Note: return true because this type is castable to AssociationType.
boolean | isCollectionType() Is this type a collection type.
boolean | isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session) Should the parent be considered dirty, given both the old and current field or element value?
boolean | isDirty(Object old, Object current, SessionImplementor session) Should the parent be considered dirty, given both the old and current field or element value?
boolean | isEmbeddedInXML()
boolean | isEqual(Object x, Object y, EntityMode entityMode) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
boolean | isModified(Object old, Object current, boolean[] checkable, SessionImplementor session) Has the parent object been modified, compared to the current database state?
boolean | isMutable() Are objects of this type mutable.
boolean | isXMLElement()
Object | nullSafeGet(ResultSet rs, String[] name, SessionImplementor session, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
Object | nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
void | nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session) Write an instance of the mapped class to a prepared statement, ignoring some columns.
void | nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session) Write an instance of the mapped class to a prepared statement.
protected String | renderLoggableString(Object value, SessionFactoryImplementor factory)
Object | replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
Object | replaceElements(Object original, Object target, Object owner, Map copyCache, SessionImplementor session) Replace the elements of a collection with the elements of another collection
Object | resolve(Object value, SessionImplementor session, Object owner) Map identifiers to entities or collections.
Object | semiResolve(Object value, SessionImplementor session, Object owner) Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.
void | setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory) A representation of the value to be embedded in an XML element.
int[] | sqlTypes(Mapping session) Return the SQL type codes for the columns mapped by this type.
boolean[] | toColumnNullness(Object value, Mapping mapping) Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
String | toLoggableString(Object value, SessionFactoryImplementor factory) A representation of the value to be embedded in a log file.
String | toString()
boolean | useLHSPrimaryKey() Is the primary key of the owning entity table to be used in the join?
abstract PersistentCollection | wrap(SessionImplementor session, Object collection) Wrap the naked collection instance in a wrapper, or instantiate a holder.
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getReturnedClass, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace

Field Detail

UNFETCHED_COLLECTION

public static final Object UNFETCHED_COLLECTION
Constructor Detail

CollectionType

public CollectionType(String role,
                      String foreignKeyPropertyName,
                      boolean isEmbeddedInXML)
Method Detail

isEmbeddedInXML

public boolean isEmbeddedInXML()
Specified by:
isEmbeddedInXML in interface AssociationType

getRole

public String getRole()

indexOf

public Object indexOf(Object collection,
                      Object element)

contains

public boolean contains(Object collection,
                        Object childObject,
                        SessionImplementor session)

isCollectionType

public boolean isCollectionType()
Description copied from interface: Type
Is this type a collection type.

Specified by:
isCollectionType in interface Type
Overrides:
isCollectionType in class AbstractType

isEqual

public final boolean isEqual(Object x,
                             Object y,
                             EntityMode entityMode)
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Specified by:
isEqual in interface Type
Overrides:
isEqual in class AbstractType

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Overrides:
compare in class AbstractType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

instantiate

public abstract PersistentCollection instantiate(SessionImplementor session,
                                                 CollectionPersister persister,
                                                 Serializable key)
                                          throws HibernateException
Instantiate an uninitialized collection wrapper or holder. Callers MUST add the holder to the persistence context!

Throws:
HibernateException

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String name,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementations should handle possibility of null values. This method might be called if the type is known to be a single-column type.

Specified by:
nullSafeGet in interface Type
Parameters:
rs -
name - the column name
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String[] name,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Specified by:
nullSafeGet in interface Type
Parameters:
rs -
name - the column names
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException
See Also:
alternative, 2-phase property initialization

nullSafeSet

public final void nullSafeSet(PreparedStatement st,
                              Object value,
                              int index,
                              boolean[] settable,
                              SessionImplementor session)
                       throws HibernateException,
                              SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement, ignoring some columns. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Specified by:
nullSafeSet in interface Type
Parameters:
st -
value - the object to write
index - statement parameter index
settable - an array indicating which columns to ignore
session -
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Specified by:
nullSafeSet in interface Type
Parameters:
st -
value - the object to write
index - statement parameter index
session -
Throws:
HibernateException
SQLException

sqlTypes

public int[] sqlTypes(Mapping session)
               throws MappingException
Description copied from interface: Type
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Specified by:
sqlTypes in interface Type
Returns:
the typecodes
Throws:
MappingException
See Also:
Types

getColumnSpan

public int getColumnSpan(Mapping session)
                  throws MappingException
Description copied from interface: Type
How many columns are used to persist this type.

Specified by:
getColumnSpan in interface Type
Throws:
MappingException

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
                        throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in a log file.

Specified by:
toLoggableString in interface Type
Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

renderLoggableString

protected String renderLoggableString(Object value,
                                      SessionFactoryImplementor factory)
                               throws HibernateException
Throws:
HibernateException

deepCopy

public Object deepCopy(Object value,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
                throws HibernateException
Description copied from interface: Type
Return a deep copy of the persistent state, stopping at entities and at collections.

Specified by:
deepCopy in interface Type
Parameters:
value - generally a collection element or entity field
entityMode -
factory -
Returns:
Object a copy
Throws:
HibernateException

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

getElementsIterator

public Iterator getElementsIterator(Object collection,
                                    SessionImplementor session)
Get an iterator over the element set of the collection, which may not yet be wrapped

getElementsIterator

protected Iterator getElementsIterator(Object collection)
Get an iterator over the element set of the collection in POJO mode

isMutable

public boolean isMutable()
Description copied from interface: Type
Are objects of this type mutable. (With respect to the referencing object ... entities and collections are considered immutable because they manage their own internal state.)

Specified by:
isMutable in interface Type
Returns:
boolean

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Description copied from interface: Type
Return a cacheable "disassembled" representation of the object.

Specified by:
disassemble in interface Type
Overrides:
disassemble in class AbstractType
Throws:
HibernateException

assemble

public Object assemble(Serializable cached,
                       SessionImplementor session,
                       Object owner)
                throws HibernateException
Description copied from interface: Type
Reconstruct the object from its cached "disassembled" state.

Specified by:
assemble in interface Type
Overrides:
assemble in class AbstractType
Throws:
HibernateException

isDirty

public boolean isDirty(Object old,
                       Object current,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Specified by:
isDirty in interface Type
Overrides:
isDirty in class AbstractType
Throws:
HibernateException

isDirty

public boolean isDirty(Object old,
                       Object current,
                       boolean[] checkable,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Specified by:
isDirty in interface Type
Parameters:
old - the old value
current - the current value
checkable - which columns are actually updatable
session -
Returns:
true if the field is dirty
Throws:
HibernateException

wrap

public abstract PersistentCollection wrap(SessionImplementor session,
                                          Object collection)
Wrap the naked collection instance in a wrapper, or instantiate a holder. Callers MUST add the holder to the persistence context!

isAssociationType

public boolean isAssociationType()
Note: return true because this type is castable to AssociationType. Not because all collections are associations.

Specified by:
isAssociationType in interface Type
Overrides:
isAssociationType in class AbstractType

getForeignKeyDirection

public ForeignKeyDirection getForeignKeyDirection()
Description copied from interface: AssociationType
Get the foreign key directionality of this association

Specified by:
getForeignKeyDirection in interface AssociationType

getKeyOfOwner

public Serializable getKeyOfOwner(Object owner,
                                  SessionImplementor session)
Get the key value from the owning entity instance, usually the identifier, but might be some other unique key, in the case of property-ref

hydrate

public Object hydrate(ResultSet rs,
                      String[] name,
                      SessionImplementor session,
                      Object owner)
Description copied from interface: Type
Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset. This is useful for 2-phase property initialization - the second phase is a call to resolveIdentifier().

Specified by:
hydrate in interface Type
Overrides:
hydrate in class AbstractType

resolve

public Object resolve(Object value,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException
Description copied from interface: Type
Map identifiers to entities or collections. This is the second phase of 2-phase property initialization.

Specified by:
resolve in interface Type
Overrides:
resolve in class AbstractType
Throws:
HibernateException

semiResolve

public Object semiResolve(Object value,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException
Description copied from interface: Type
Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.

Specified by:
semiResolve in interface Type
Overrides:
semiResolve in class AbstractType
Throws:
HibernateException

isArrayType

public boolean isArrayType()

useLHSPrimaryKey

public boolean useLHSPrimaryKey()
Description copied from interface: AssociationType
Is the primary key of the owning entity table to be used in the join?

Specified by:
useLHSPrimaryKey in interface AssociationType

getRHSUniqueKeyPropertyName

public String getRHSUniqueKeyPropertyName()
Description copied from interface: AssociationType
The name of a unique property of the associated entity that provides the join key (null if the identifier of an entity, or key of a collection)

Specified by:
getRHSUniqueKeyPropertyName in interface AssociationType

getAssociatedJoinable

public Joinable getAssociatedJoinable(SessionFactoryImplementor factory)
                               throws MappingException
Description copied from interface: AssociationType
Get the "persister" for this association - a class or collection persister

Specified by:
getAssociatedJoinable in interface AssociationType
Throws:
MappingException

isModified

public boolean isModified(Object old,
                          Object current,
                          boolean[] checkable,
                          SessionImplementor session)
                   throws HibernateException
Description copied from interface: Type
Has the parent object been modified, compared to the current database state?

Specified by:
isModified in interface Type
Overrides:
isModified in class AbstractType
Throws:
HibernateException

getAssociatedEntityName

public String getAssociatedEntityName(SessionFactoryImplementor factory)
                               throws MappingException
Description copied from interface: AssociationType
Get the entity name of the associated entity

Specified by:
getAssociatedEntityName in interface AssociationType
Throws:
MappingException

replaceElements

public Object replaceElements(Object original,
                              Object target,
                              Object owner,
                              Map copyCache,
                              SessionImplementor session)
                       throws HibernateException
Replace the elements of a collection with the elements of another collection

Throws:
HibernateException

instantiateResult

protected Object instantiateResult(Object original)
Instantiate a new "underlying" collection exhibiting the same capacity charactersitcs and the passed "original".

Parameters:
original - The original collection.
Returns:
The newly instantiated collection.

instantiate

public abstract Object instantiate(int anticipatedSize)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial capacity and perhaps load factor).

Parameters:
anticipatedSize - The anticipated size of the instaniated collection after we are done populating it.

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache)
               throws HibernateException
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Specified by:
replace in interface Type
Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException

getElementType

public final Type getElementType(SessionFactoryImplementor factory)
                          throws MappingException
Get the Hibernate type of the collection elements

Throws:
MappingException

toString

public String toString()

getOnCondition

public String getOnCondition(String alias,
                             SessionFactoryImplementor factory,
                             Map enabledFilters)
                      throws MappingException
Description copied from interface: AssociationType
Get the "filtering" SQL fragment that is applied in the SQL on clause, in addition to the usual join condition

Specified by:
getOnCondition in interface AssociationType
Throws:
MappingException

getCollection

public Object getCollection(Serializable key,
                            SessionImplementor session,
                            Object owner)
                     throws HibernateException
instantiate a collection wrapper (called when loading an object)

Throws:
HibernateException

hasHolder

public boolean hasHolder(EntityMode entityMode)

initializeImmediately

protected boolean initializeImmediately(EntityMode entityMode)

getLHSPropertyName

public String getLHSPropertyName()
Description copied from interface: AssociationType
Get the name of a property in the owning entity that provides the join key (null if the identifier)

Specified by:
getLHSPropertyName in interface AssociationType

isXMLElement

public boolean isXMLElement()
Specified by:
isXMLElement in interface Type
Overrides:
isXMLElement in class AbstractType

fromXMLNode

public Object fromXMLNode(org.dom4j.Node xml,
                          Mapping factory)
                   throws HibernateException
Description copied from interface: Type
Parse the XML representation of an instance.

Specified by:
fromXMLNode in interface Type
Parameters:
xml -
factory -
Returns:
an instance of the type
Throws:
HibernateException

setToXMLNode

public void setToXMLNode(org.dom4j.Node node,
                         Object value,
                         SessionFactoryImplementor factory)
                  throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in an XML element.

Specified by:
setToXMLNode in interface Type
Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

isAlwaysDirtyChecked

public boolean isAlwaysDirtyChecked()
We always need to dirty check the collection because we sometimes need to incremement version number of owner and also because of how assemble/disassemble is implemented for uks

Specified by:
isAlwaysDirtyChecked in interface AssociationType

toColumnNullness

public boolean[] toColumnNullness(Object value,
                                  Mapping mapping)
Description copied from interface: Type
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.

Specified by:
toColumnNullness in interface Type
Parameters:
value - an instance of the type
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ComponentType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class ComponentType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.ComponentType
All Implemented Interfaces:
AbstractComponentType, Serializable, Type
Direct Known Subclasses:
EmbeddedComponentType
public class ComponentType
extends AbstractType
implements AbstractComponentType

Handles "component" mappings

Author:
Gavin King
See Also:
Serialized Form

Field Summary
protected int | propertySpan
protected EntityModeToTuplizerMapping | tuplizerMapping
Constructor Summary
ComponentType(ComponentMetamodel metamodel)
Method Summary
 Object assemble(Serializable object, SessionImplementor session, Object owner)
Reconstruct the object from its cached "disassembled" state.
 int compare(Object x, Object y, EntityMode entityMode)
compare two instances of the type
 Object deepCopy(Object component, EntityMode entityMode, SessionFactoryImplementor factory)
Return a deep copy of the persistent state, stopping at entities and at collections.
 Serializable disassemble(Object value, SessionImplementor session, Object owner)
Return a cacheable "disassembled" representation of the object.
 Object fromXMLNode(org.dom4j.Node xml, Mapping factory)
Parse the XML representation of an instance.
 CascadeStyle getCascadeStyle(int i)
 int getColumnSpan(Mapping mapping)
How many columns are used to persist this type.
 FetchMode getFetchMode(int i)
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 int getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 String[] getPropertyNames()
Get the names of the component properties
 boolean[] getPropertyNullability()
Optional operation
 Object getPropertyValue(Object component, int i, EntityMode entityMode)
 Object getPropertyValue(Object component, int i, SessionImplementor session)
 Object[] getPropertyValues(Object component, EntityMode entityMode)
Optional operation
 Object[] getPropertyValues(Object component, SessionImplementor session)
Get the values of the component properties of a component instance
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Type[] getSubtypes()
Get the types of the component properties
 Object hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset.
 Object instantiate(EntityMode entityMode)
This method does not populate the component parent
 Object instantiate(Object parent, SessionImplementor session)
 boolean isComponentType()
Is this type a component type.
 boolean isDirty(Object x, Object y, boolean[] checkable, SessionImplementor session)
Should the parent be considered dirty, given both the old and current field or element value?
 boolean isDirty(Object x, Object y, SessionImplementor session)
Should the parent be considered dirty, given both the old and current field or element value?
 boolean isEmbedded()
 boolean isEqual(Object x, Object y, EntityMode entityMode)
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
 boolean isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory)
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
 boolean isMethodOf(Method method)
 boolean isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
Has the parent object been modified, compared to the current database state?
 boolean isMutable()
Are objects of this type mutable.
 boolean isSame(Object x, Object y, EntityMode entityMode)
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.
 boolean isXMLElement()
 Object nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 Object nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 void nullSafeSet(PreparedStatement st, Object value, int begin, boolean[] settable, SessionImplementor session)
Write an instance of the mapped class to a prepared statement, ignoring some columns.
 void nullSafeSet(PreparedStatement st, Object value, int begin, SessionImplementor session)
Write an instance of the mapped class to a prepared statement.
 Object replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
 Object replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
 Object resolve(Object value, SessionImplementor session, Object owner)
Map identifiers to entities or collections.
 Object semiResolve(Object value, SessionImplementor session, Object owner)
Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.
 void setPropertyValues(Object component, Object[] values, EntityMode entityMode)
Optional operation
 void setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in an XML element.
 int[] sqlTypes(Mapping mapping)
Return the SQL type codes for the columns mapped by this type.
 boolean[] toColumnNullness(Object value, Mapping mapping)
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
 String toLoggableString(Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in a log file.
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getSemiResolvedType, isAnyType, isAssociationType, isCollectionType, isEntityType, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getSemiResolvedType, isAnyType, isAssociationType, isCollectionType, isEntityType

Field Detail

propertySpan

protected final int propertySpan

tuplizerMapping

protected final EntityModeToTuplizerMapping tuplizerMapping
Constructor Detail

ComponentType

public ComponentType(ComponentMetamodel metamodel)
Method Detail

sqlTypes

public int[] sqlTypes(Mapping mapping)
               throws MappingException
Description copied from interface: Type
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Specified by:
sqlTypes in interface Type
Returns:
the typecodes
Throws:
MappingException
See Also:
Types

getColumnSpan

public int getColumnSpan(Mapping mapping)
                  throws MappingException
Description copied from interface: Type
How many columns are used to persist this type.

Specified by:
getColumnSpan in interface Type
Throws:
MappingException

isComponentType

public final boolean isComponentType()
Description copied from interface: Type
Is this type a component type. If so, the implementation must be castable to AbstractComponentType. A component type may own collections or associations and hence must provide certain extra functionality.

Specified by:
isComponentType in interface Type
Overrides:
isComponentType in class AbstractType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

isSame

public boolean isSame(Object x,
                      Object y,
                      EntityMode entityMode)
               throws HibernateException
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.

Specified by:
isSame in interface Type
Overrides:
isSame in class AbstractType
Throws:
HibernateException

isEqual

public boolean isEqual(Object x,
                       Object y,
                       EntityMode entityMode)
                throws HibernateException
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Specified by:
isEqual in interface Type
Overrides:
isEqual in class AbstractType
Throws:
HibernateException

isEqual

public boolean isEqual(Object x,
                       Object y,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
                throws HibernateException
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Specified by:
isEqual in interface Type
Overrides:
isEqual in class AbstractType
Throws:
HibernateException

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Overrides:
compare in class AbstractType

isMethodOf

public boolean isMethodOf(Method method)
Specified by:
isMethodOf in interface AbstractComponentType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

isDirty

public boolean isDirty(Object x,
                       Object y,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Specified by:
isDirty in interface Type
Overrides:
isDirty in class AbstractType
Throws:
HibernateException

isDirty

public boolean isDirty(Object x,
                       Object y,
                       boolean[] checkable,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Specified by:
isDirty in interface Type
Parameters:
x - the old value
y - the current value
checkable - which columns are actually updatable
session -
Returns:
true if the field is dirty
Throws:
HibernateException

isModified

public boolean isModified(Object old,
                          Object current,
                          boolean[] checkable,
                          SessionImplementor session)
                   throws HibernateException
Description copied from interface: Type
Has the parent object been modified, compared to the current database state?

Specified by:
isModified in interface Type
Overrides:
isModified in class AbstractType
Throws:
HibernateException

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String[] names,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Specified by:
nullSafeGet in interface Type
Parameters:
rs -
names - the column names
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException
See Also:
alternative, 2-phase property initialization

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int begin,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Specified by:
nullSafeSet in interface Type
Parameters:
st -
value - the object to write
begin - statement parameter index
session -
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int begin,
                        boolean[] settable,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement, ignoring some columns. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Specified by:
nullSafeSet in interface Type
Parameters:
st -
value - the object to write
begin - statement parameter index
settable - an array indicating which columns to ignore
session -
Throws:
HibernateException
SQLException

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String name,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementations should handle possibility of null values. This method might be called if the type is known to be a single-column type.

Specified by:
nullSafeGet in interface Type
Parameters:
rs -
name - the column name
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException

getPropertyValue

public Object getPropertyValue(Object component,
                               int i,
                               SessionImplementor session)
                        throws HibernateException
Specified by:
getPropertyValue in interface AbstractComponentType
Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object component,
                               int i,
                               EntityMode entityMode)
                        throws HibernateException
Throws:
HibernateException

getPropertyValues

public Object[] getPropertyValues(Object component,
                                  SessionImplementor session)
                           throws HibernateException
Description copied from interface: AbstractComponentType
Get the values of the component properties of a component instance

Specified by:
getPropertyValues in interface AbstractComponentType
Throws:
HibernateException

getPropertyValues

public Object[] getPropertyValues(Object component,
                                  EntityMode entityMode)
                           throws HibernateException
Description copied from interface: AbstractComponentType
Optional operation

Specified by:
getPropertyValues in interface AbstractComponentType
Throws:
HibernateException

setPropertyValues

public void setPropertyValues(Object component,
                              Object[] values,
                              EntityMode entityMode)
                       throws HibernateException
Description copied from interface: AbstractComponentType
Optional operation

Specified by:
setPropertyValues in interface AbstractComponentType
Throws:
HibernateException

getSubtypes

public Type[] getSubtypes()
Description copied from interface: AbstractComponentType
Get the types of the component properties

Specified by:
getSubtypes in interface AbstractComponentType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
                        throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in a log file.

Specified by:
toLoggableString in interface Type
Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

getPropertyNames

public String[] getPropertyNames()
Description copied from interface: AbstractComponentType
Get the names of the component properties

Specified by:
getPropertyNames in interface AbstractComponentType

deepCopy

public Object deepCopy(Object component,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
                throws HibernateException
Description copied from interface: Type
Return a deep copy of the persistent state, stopping at entities and at collections.

Specified by:
deepCopy in interface Type
Parameters:
component - generally a collection element or entity field
entityMode -
factory -
Returns:
Object a copy
Throws:
HibernateException

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache)
               throws HibernateException
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Specified by:
replace in interface Type
Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache,
                      ForeignKeyDirection foreignKeyDirection)
               throws HibernateException
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Specified by:
replace in interface Type
Overrides:
replace in class AbstractType
Throws:
HibernateException

instantiate

public Object instantiate(EntityMode entityMode)
                   throws HibernateException
This method does not populate the component parent

Throws:
HibernateException

instantiate

public Object instantiate(Object parent,
                          SessionImplementor session)
                   throws HibernateException
Throws:
HibernateException

getCascadeStyle

public CascadeStyle getCascadeStyle(int i)
Specified by:
getCascadeStyle in interface AbstractComponentType

isMutable

public boolean isMutable()
Description copied from interface: Type
Are objects of this type mutable. (With respect to the referencing object ... entities and collections are considered immutable because they manage their own internal state.)

Specified by:
isMutable in interface Type
Returns:
boolean

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Description copied from interface: Type
Return a cacheable "disassembled" representation of the object.

Specified by:
disassemble in interface Type
Overrides:
disassemble in class AbstractType
Throws:
HibernateException

assemble

public Object assemble(Serializable object,
                       SessionImplementor session,
                       Object owner)
                throws HibernateException
Description copied from interface: Type
Reconstruct the object from its cached "disassembled" state.

Specified by:
assemble in interface Type
Overrides:
assemble in class AbstractType
Throws:
HibernateException

getFetchMode

public FetchMode getFetchMode(int i)
Specified by:
getFetchMode in interface AbstractComponentType

hydrate

public Object hydrate(ResultSet rs,
                      String[] names,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException,
                      SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset. This is useful for 2-phase property initialization - the second phase is a call to resolveIdentifier().

Specified by:
hydrate in interface Type
Overrides:
hydrate in class AbstractType
Throws:
HibernateException
SQLException

resolve

public Object resolve(Object value,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException
Description copied from interface: Type
Map identifiers to entities or collections. This is the second phase of 2-phase property initialization.

Specified by:
resolve in interface Type
Overrides:
resolve in class AbstractType
Throws:
HibernateException

semiResolve

public Object semiResolve(Object value,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException
Description copied from interface: Type
Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.

Specified by:
semiResolve in interface Type
Overrides:
semiResolve in class AbstractType
Throws:
HibernateException

getPropertyNullability

public boolean[] getPropertyNullability()
Description copied from interface: AbstractComponentType
Optional operation

Specified by:
getPropertyNullability in interface AbstractComponentType
Returns:
nullability of component properties

isXMLElement

public boolean isXMLElement()
Specified by:
isXMLElement in interface Type
Overrides:
isXMLElement in class AbstractType

fromXMLNode

public Object fromXMLNode(org.dom4j.Node xml,
                          Mapping factory)
                   throws HibernateException
Description copied from interface: Type
Parse the XML representation of an instance.

Specified by:
fromXMLNode in interface Type
Parameters:
xml -
factory -
Returns:
an instance of the type
Throws:
HibernateException

setToXMLNode

public void setToXMLNode(org.dom4j.Node node,
                         Object value,
                         SessionFactoryImplementor factory)
                  throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in an XML element.

Specified by:
setToXMLNode in interface Type
Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

toColumnNullness

public boolean[] toColumnNullness(Object value,
                                  Mapping mapping)
Description copied from interface: Type
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.

Specified by:
toColumnNullness in interface Type
Parameters:
value - an instance of the type

isEmbedded

public boolean isEmbedded()
Specified by:
isEmbedded in interface AbstractComponentType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompositeCustomType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class CompositeCustomType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CompositeCustomType
All Implemented Interfaces:
AbstractComponentType, Serializable, Type
public class CompositeCustomType
extends AbstractType
implements AbstractComponentType

Adapts CompositeUserType to Type interface

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
CompositeCustomType(Class userTypeClass, Properties parameters)
Method Summary
 Object assemble(Serializable cached, SessionImplementor session, Object owner)
Reconstruct the object from its cached "disassembled" state.
 Object deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Return a deep copy of the persistent state, stopping at entities and at collections.
 Serializable disassemble(Object value, SessionImplementor session, Object owner)
Return a cacheable "disassembled" representation of the object.
 Object fromXMLNode(org.dom4j.Node xml, Mapping factory)
Parse the XML representation of an instance.
 CascadeStyle getCascadeStyle(int i)
 int getColumnSpan(Mapping mapping)
How many columns are used to persist this type.
 FetchMode getFetchMode(int i)
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 String[] getPropertyNames()
Get the names of the component properties
 boolean[] getPropertyNullability()
Optional operation
 Object getPropertyValue(Object component, int i)
 Object getPropertyValue(Object component, int i, SessionImplementor session)
 Object[] getPropertyValues(Object component, EntityMode entityMode)
Optional operation
 Object[] getPropertyValues(Object component, SessionImplementor session)
Get the values of the component properties of a component instance
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Type[] getSubtypes()
Get the types of the component properties
 boolean isComponentType()
Is this type a component type.
 boolean isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Should the parent be considered dirty, given both the old and current field or element value?
 boolean isEmbedded()
 boolean isEqual(Object x, Object y, EntityMode entityMode)
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
 boolean isMethodOf(Method method)
 boolean isMutable()
Are objects of this type mutable.
 Object nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 Object nullSafeGet(ResultSet rs, String columnName, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 void nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
Write an instance of the mapped class to a prepared statement, ignoring some columns.
 void nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Write an instance of the mapped class to a prepared statement.
 Object replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
 void setPropertyValues(Object component, Object[] values, EntityMode entityMode)
Optional operation
 void setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in an XML element.
 int[] sqlTypes(Mapping mapping)
Return the SQL type codes for the columns mapped by this type.
 boolean[] toColumnNullness(Object value, Mapping mapping)
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
 String toLoggableString(Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in a log file.
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, compare, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, compare, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, resolve, semiResolve

Constructor Detail

CompositeCustomType

public CompositeCustomType(Class userTypeClass,
                           Properties parameters)
                    throws MappingException
Method Detail

isMethodOf

public boolean isMethodOf(Method method)
Specified by:
isMethodOf in interface AbstractComponentType

getSubtypes

public Type[] getSubtypes()
Description copied from interface: AbstractComponentType
Get the types of the component properties

Specified by:
getSubtypes in interface AbstractComponentType

getPropertyNames

public String[] getPropertyNames()
Description copied from interface: AbstractComponentType
Get the names of the component properties

Specified by:
getPropertyNames in interface AbstractComponentType

getPropertyValues

public Object[] getPropertyValues(Object component,
                                  SessionImplementor session)
                           throws HibernateException
Description copied from interface: AbstractComponentType
Get the values of the component properties of a component instance

Specified by:
getPropertyValues in interface AbstractComponentType
Throws:
HibernateException

getPropertyValues

public Object[] getPropertyValues(Object component,
                                  EntityMode entityMode)
                           throws HibernateException
Description copied from interface: AbstractComponentType
Optional operation

Specified by:
getPropertyValues in interface AbstractComponentType
Throws:
HibernateException

setPropertyValues

public void setPropertyValues(Object component,
                              Object[] values,
                              EntityMode entityMode)
                       throws HibernateException
Description copied from interface: AbstractComponentType
Optional operation

Specified by:
setPropertyValues in interface AbstractComponentType
Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object component,
                               int i,
                               SessionImplementor session)
                        throws HibernateException
Specified by:
getPropertyValue in interface AbstractComponentType
Throws:
HibernateException

getPropertyValue

public Object getPropertyValue(Object component,
                               int i)
                        throws HibernateException
Throws:
HibernateException

getCascadeStyle

public CascadeStyle getCascadeStyle(int i)
Specified by:
getCascadeStyle in interface AbstractComponentType

getFetchMode

public FetchMode getFetchMode(int i)
Specified by:
getFetchMode in interface AbstractComponentType

isComponentType

public boolean isComponentType()
Description copied from interface: Type
Is this type a component type. If so, the implementation must be castable to AbstractComponentType. A component type may own collections or associations and hence must provide certain extra functionality.

Specified by:
isComponentType in interface Type
Overrides:
isComponentType in class AbstractType

deepCopy

public Object deepCopy(Object value,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
                throws HibernateException
Description copied from interface: Type
Return a deep copy of the persistent state, stopping at entities and at collections.

Specified by:
deepCopy in interface Type
Parameters:
value - generally a collection element or entity field
entityMode -
factory -
Returns:
Object a copy
Throws:
HibernateException

assemble

public Object assemble(Serializable cached,
                       SessionImplementor session,
                       Object owner)
                throws HibernateException
Description copied from interface: Type
Reconstruct the object from its cached "disassembled" state.

Specified by:
assemble in interface Type
Overrides:
assemble in class AbstractType
Throws:
HibernateException

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Description copied from interface: Type
Return a cacheable "disassembled" representation of the object.

Specified by:
disassemble in interface Type
Overrides:
disassemble in class AbstractType
Throws:
HibernateException

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache)
               throws HibernateException
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Specified by:
replace in interface Type
Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException

isEqual

public boolean isEqual(Object x,
                       Object y,
                       EntityMode entityMode)
                throws HibernateException
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Specified by:
isEqual in interface Type
Overrides:
isEqual in class AbstractType
Throws:
HibernateException

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

getColumnSpan

public int getColumnSpan(Mapping mapping)
                  throws MappingException
Description copied from interface: Type
How many columns are used to persist this type.

Specified by:
getColumnSpan in interface Type
Throws:
MappingException

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

isMutable

public boolean isMutable()
Description copied from interface: Type
Are objects of this type mutable. (With respect to the referencing object ... entities and collections are considered immutable because they manage their own internal state.)

Specified by:
isMutable in interface Type
Returns:
boolean

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String columnName,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementations should handle possibility of null values. This method might be called if the type is known to be a single-column type.

Specified by:
nullSafeGet in interface Type
Parameters:
rs -
columnName - the column name
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String[] names,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Specified by:
nullSafeGet in interface Type
Parameters:
rs -
names - the column names
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException
See Also:
alternative, 2-phase property initialization

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Specified by:
nullSafeSet in interface Type
Parameters:
st -
value - the object to write
index - statement parameter index
session -
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        boolean[] settable,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement, ignoring some columns. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Specified by:
nullSafeSet in interface Type
Parameters:
st -
value - the object to write
index - statement parameter index
settable - an array indicating which columns to ignore
session -
Throws:
HibernateException
SQLException

sqlTypes

public int[] sqlTypes(Mapping mapping)
               throws MappingException
Description copied from interface: Type
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Specified by:
sqlTypes in interface Type
Returns:
the typecodes
Throws:
MappingException
See Also:
Types

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
                        throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in a log file.

Specified by:
toLoggableString in interface Type
Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

getPropertyNullability

public boolean[] getPropertyNullability()
Description copied from interface: AbstractComponentType
Optional operation

Specified by:
getPropertyNullability in interface AbstractComponentType
Returns:
nullability of component properties

fromXMLNode

public Object fromXMLNode(org.dom4j.Node xml,
                          Mapping factory)
                   throws HibernateException
Description copied from interface: Type
Parse the XML representation of an instance.

Specified by:
fromXMLNode in interface Type
Parameters:
xml -
factory -
Returns:
an instance of the type
Throws:
HibernateException

setToXMLNode

public void setToXMLNode(org.dom4j.Node node,
                         Object value,
                         SessionFactoryImplementor factory)
                  throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in an XML element.

Specified by:
setToXMLNode in interface Type
Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

toColumnNullness

public boolean[] toColumnNullness(Object value,
                                  Mapping mapping)
Description copied from interface: Type
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.

Specified by:
toColumnNullness in interface Type
Parameters:
value - an instance of the type

isDirty

public boolean isDirty(Object old,
                       Object current,
                       boolean[] checkable,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Specified by:
isDirty in interface Type
Parameters:
old - the old value
current - the current value
checkable - which columns are actually updatable
session -
Returns:
true if the field is dirty
Throws:
HibernateException

isEmbedded

public boolean isEmbedded()
Specified by:
isEmbedded in interface AbstractComponentType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CurrencyType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class CurrencyType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.CurrencyType
All Implemented Interfaces:
LiteralType, Serializable, Type
public class CurrencyType
extends ImmutableType
implements LiteralType

currency: A type that maps an SQL VARCHAR to a java.util.Currency

Author:
Gavin King
See Also:
Currency, Serialized Form

Field Summary
static Class CURRENCY_CLASS
Constructor Summary
CurrencyType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 String toString(Object value)
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CURRENCY_CLASS

public static final Class CURRENCY_CLASS
Constructor Detail

CurrencyType

public CurrencyType()
Method Detail

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
HibernateException
SQLException
See Also:
NullableType.get(ResultSet, String)

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws HibernateException,
                SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
HibernateException
SQLException
See Also:
NullableType.set(PreparedStatement, Object, int)

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType
See Also:
NullableType.sqlType()

toString

public String toString(Object value)
                throws HibernateException
Specified by:
toString in class NullableType
Throws:
HibernateException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class
See Also:
Type.getReturnedClass()

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name
See Also:
Type.getName()

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception
See Also:
LiteralType.objectToSQLString(Object, Dialect)

fromStringValue

public Object fromStringValue(String xml)
                       throws HibernateException
Specified by:
fromStringValue in class NullableType
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomCollectionType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class CustomCollectionType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CollectionType
            extended by org.hibernate.type.CustomCollectionType
All Implemented Interfaces:
AssociationType, Serializable, Type
public class CustomCollectionType
extends CollectionType

A custom type for mapping user-written classes that implement PersistentCollection

Author:
Gavin King
See Also:
PersistentCollection, UserCollectionType, Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.CollectionType
UNFETCHED_COLLECTION
Constructor Summary
CustomCollectionType(Class userTypeClass, String role, String foreignKeyPropertyName, boolean isEmbeddedInXML)
Method Summary
 boolean contains(Object collection, Object entity, SessionImplementor session)
 Iterator getElementsIterator(Object collection)
Get an iterator over the element set of the collection in POJO mode
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Object indexOf(Object collection, Object entity)
 Object instantiate(int anticipatedType)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
 PersistentCollection instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
Instantiate an uninitialized collection wrapper or holder.
protected  String renderLoggableString(Object value, SessionFactoryImplementor factory)
 Object replaceElements(Object original, Object target, Object owner, Map copyCache, SessionImplementor session)
Replace the elements of a collection with the elements of another collection
 PersistentCollection wrap(SessionImplementor session, Object collection)
Wrap the naked collection instance in a wrapper, or instantiate a holder.
Methods inherited from class org.hibernate.type.CollectionType
assemble, compare, deepCopy, disassemble, fromXMLNode, getAssociatedEntityName, getAssociatedJoinable, getCollection, getColumnSpan, getElementsIterator, getElementType, getForeignKeyDirection, getHashCode, getKeyOfOwner, getLHSPropertyName, getName, getOnCondition, getRHSUniqueKeyPropertyName, getRole, hasHolder, hydrate, initializeImmediately, instantiateResult, isAlwaysDirtyChecked, isArrayType, isAssociationType, isCollectionType, isDirty, isDirty, isEmbeddedInXML, isEqual, isModified, isMutable, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toString, useLHSPrimaryKey
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace

Constructor Detail

CustomCollectionType

public CustomCollectionType(Class userTypeClass,
                            String role,
                            String foreignKeyPropertyName,
                            boolean isEmbeddedInXML)
Method Detail

instantiate

public PersistentCollection instantiate(SessionImplementor session,
                                        CollectionPersister persister,
                                        Serializable key)
                                 throws HibernateException
Description copied from class: CollectionType
Instantiate an uninitialized collection wrapper or holder. Callers MUST add the holder to the persistence context!

Specified by:
instantiate in class CollectionType
Throws:
HibernateException

wrap

public PersistentCollection wrap(SessionImplementor session,
                                 Object collection)
Description copied from class: CollectionType
Wrap the naked collection instance in a wrapper, or instantiate a holder. Callers MUST add the holder to the persistence context!

Specified by:
wrap in class CollectionType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

instantiate

public Object instantiate(int anticipatedType)
Description copied from class: CollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial capacity and perhaps load factor).

Specified by:
instantiate in class CollectionType
Parameters:
anticipatedType - The anticipated size of the instaniated collection after we are done populating it.

getElementsIterator

public Iterator getElementsIterator(Object collection)
Description copied from class: CollectionType
Get an iterator over the element set of the collection in POJO mode

Overrides:
getElementsIterator in class CollectionType

contains

public boolean contains(Object collection,
                        Object entity,
                        SessionImplementor session)
Overrides:
contains in class CollectionType

indexOf

public Object indexOf(Object collection,
                      Object entity)
Overrides:
indexOf in class CollectionType

replaceElements

public Object replaceElements(Object original,
                              Object target,
                              Object owner,
                              Map copyCache,
                              SessionImplementor session)
                       throws HibernateException
Description copied from class: CollectionType
Replace the elements of a collection with the elements of another collection

Overrides:
replaceElements in class CollectionType
Throws:
HibernateException

renderLoggableString

protected String renderLoggableString(Object value,
                                      SessionFactoryImplementor factory)
                               throws HibernateException
Overrides:
renderLoggableString in class CollectionType
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class CustomType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CustomType
All Implemented Interfaces:
DiscriminatorType, IdentifierType, LiteralType, Serializable, Type, VersionType
public class CustomType
extends AbstractType
implements IdentifierType, DiscriminatorType, VersionType

Adapts UserType to the generic Type interface, in order to isolate user code from changes in the internal Type contracts.

Author:
Gavin King
See Also:
UserType, Serialized Form

Constructor Summary
CustomType(Class userTypeClass, Properties parameters)
Method Summary
 Object assemble(Serializable cached, SessionImplementor session, Object owner)
Reconstruct the object from its cached "disassembled" state.
 Object deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Return a deep copy of the persistent state, stopping at entities and at collections.
 Serializable disassemble(Object value, SessionImplementor session, Object owner)
Return a cacheable "disassembled" representation of the object.
 Object fromXMLNode(org.dom4j.Node xml, Mapping factory)
Parse the XML representation of an instance.
 Object fromXMLString(String xml, Mapping factory)
 int getColumnSpan(Mapping session)
How many columns are used to persist this type.
 Comparator getComparator()
Get a comparator for version values.
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Should the parent be considered dirty, given both the old and current field or element value?
 boolean isEqual(Object x, Object y)
Are the two version values considered equal?
 boolean isEqual(Object x, Object y, EntityMode entityMode)
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
 boolean isMutable()
Are objects of this type mutable.
 Object next(Object current, SessionImplementor session)
Increment the version.
 Object nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 Object nullSafeGet(ResultSet rs, String columnName, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 void nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
Write an instance of the mapped class to a prepared statement, ignoring some columns.
 void nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Write an instance of the mapped class to a prepared statement.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 Object replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
 Object seed(SessionImplementor session)
Generate an initial version.
 void setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in an XML element.
 int[] sqlTypes(Mapping pi)
Return the SQL type codes for the columns mapped by this type.
 Object stringToObject(String xml)
Convert the value from the mapping file to a Java object.
 boolean[] toColumnNullness(Object value, Mapping mapping)
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
 String toLoggableString(Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in a log file.
 String toXMLString(Object value, SessionFactoryImplementor factory)
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, compare, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, compare, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, resolve, semiResolve

Constructor Detail

CustomType

public CustomType(Class userTypeClass,
                  Properties parameters)
           throws MappingException
Method Detail

sqlTypes

public int[] sqlTypes(Mapping pi)
Description copied from interface: Type
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Specified by:
sqlTypes in interface Type
Returns:
the typecodes
See Also:
Types

getColumnSpan

public int getColumnSpan(Mapping session)
Description copied from interface: Type
How many columns are used to persist this type.

Specified by:
getColumnSpan in interface Type

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

isEqual

public boolean isEqual(Object x,
                       Object y)
                throws HibernateException
Description copied from interface: VersionType
Are the two version values considered equal?

Specified by:
isEqual in interface VersionType
Parameters:
x - One value to check.
y - The other value to check.
Returns:
true if the values are equal, false otherwise.
Throws:
HibernateException

isEqual

public boolean isEqual(Object x,
                       Object y,
                       EntityMode entityMode)
                throws HibernateException
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Specified by:
isEqual in interface Type
Overrides:
isEqual in class AbstractType
Throws:
HibernateException

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String[] names,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Specified by:
nullSafeGet in interface Type
Parameters:
rs -
names - the column names
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException
See Also:
alternative, 2-phase property initialization

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String columnName,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementations should handle possibility of null values. This method might be called if the type is known to be a single-column type.

Specified by:
nullSafeGet in interface Type
Parameters:
rs -
columnName - the column name
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException

assemble

public Object assemble(Serializable cached,
                       SessionImplementor session,
                       Object owner)
                throws HibernateException
Description copied from interface: Type
Reconstruct the object from its cached "disassembled" state.

Specified by:
assemble in interface Type
Overrides:
assemble in class AbstractType
Throws:
HibernateException

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Description copied from interface: Type
Return a cacheable "disassembled" representation of the object.

Specified by:
disassemble in interface Type
Overrides:
disassemble in class AbstractType
Throws:
HibernateException

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache)
               throws HibernateException
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Specified by:
replace in interface Type
Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        boolean[] settable,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement, ignoring some columns. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Specified by:
nullSafeSet in interface Type
Parameters:
st -
value - the object to write
index - statement parameter index
settable - an array indicating which columns to ignore
session -
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Specified by:
nullSafeSet in interface Type
Parameters:
st -
value - the object to write
index - statement parameter index
session -
Throws:
HibernateException
SQLException

toXMLString

public String toXMLString(Object value,
                          SessionFactoryImplementor factory)

fromXMLString

public Object fromXMLString(String xml,
                            Mapping factory)

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

deepCopy

public Object deepCopy(Object value,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
                throws HibernateException
Description copied from interface: Type
Return a deep copy of the persistent state, stopping at entities and at collections.

Specified by:
deepCopy in interface Type
Parameters:
value - generally a collection element or entity field
entityMode -
factory -
Returns:
Object a copy
Throws:
HibernateException

isMutable

public boolean isMutable()
Description copied from interface: Type
Are objects of this type mutable. (With respect to the referencing object ... entities and collections are considered immutable because they manage their own internal state.)

Specified by:
isMutable in interface Type
Returns:
boolean

stringToObject

public Object stringToObject(String xml)
Description copied from interface: IdentifierType
Convert the value from the mapping file to a Java object.

Specified by:
stringToObject in interface IdentifierType
Parameters:
xml - the value of discriminator-value or unsaved-value attribute
Returns:
Object

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

getComparator

public Comparator getComparator()
Description copied from interface: VersionType
Get a comparator for version values.

Specified by:
getComparator in interface VersionType
Returns:
The comparator to use to compare different version values.

next

public Object next(Object current,
                   SessionImplementor session)
Description copied from interface: VersionType
Increment the version.

Specified by:
next in interface VersionType
Parameters:
session - The session from which this request originates.
current - the current version
Returns:
an instance of the type

seed

public Object seed(SessionImplementor session)
Description copied from interface: VersionType
Generate an initial version.

Specified by:
seed in interface VersionType
Parameters:
session - The session from which this request originates.
Returns:
an instance of the type

fromXMLNode

public Object fromXMLNode(org.dom4j.Node xml,
                          Mapping factory)
                   throws HibernateException
Description copied from interface: Type
Parse the XML representation of an instance.

Specified by:
fromXMLNode in interface Type
Parameters:
xml -
factory -
Returns:
an instance of the type
Throws:
HibernateException

setToXMLNode

public void setToXMLNode(org.dom4j.Node node,
                         Object value,
                         SessionFactoryImplementor factory)
                  throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in an XML element.

Specified by:
setToXMLNode in interface Type
Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
                        throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in a log file.

Specified by:
toLoggableString in interface Type
Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

toColumnNullness

public boolean[] toColumnNullness(Object value,
                                  Mapping mapping)
Description copied from interface: Type
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.

Specified by:
toColumnNullness in interface Type
Parameters:
value - an instance of the type

isDirty

public boolean isDirty(Object old,
                       Object current,
                       boolean[] checkable,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Specified by:
isDirty in interface Type
Parameters:
old - the old value
current - the current value
checkable - which columns are actually updatable
session -
Returns:
true if the field is dirty
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class DateType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.DateType
All Implemented Interfaces:
IdentifierType, LiteralType, Serializable, Type
public class DateType
extends MutableType
implements IdentifierType, LiteralType

date: A type that maps an SQL DATE to a Java Date.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
DateType()
Method Summary
 Object deepCopyNotNull(Object value)
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isEqual(Object x, Object y)
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 Object stringToObject(String xml)
Convert the value from the mapping file to a Java object.
 String toString(Object val)
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Constructor Detail

DateType

public DateType()
Method Detail

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

isEqual

public boolean isEqual(Object x,
                       Object y)
Overrides:
isEqual in class NullableType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

toString

public String toString(Object val)
Specified by:
toString in class NullableType

deepCopyNotNull

public Object deepCopyNotNull(Object value)
Specified by:
deepCopyNotNull in class MutableType

stringToObject

public Object stringToObject(String xml)
                      throws Exception
Description copied from interface: IdentifierType
Convert the value from the mapping file to a Java object.

Specified by:
stringToObject in interface IdentifierType
Parameters:
xml - the value of discriminator-value or unsaved-value attribute
Returns:
Object
Throws:
Exception

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

fromStringValue

public Object fromStringValue(String xml)
                       throws HibernateException
Specified by:
fromStringValue in class NullableType
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DbTimestampType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class DbTimestampType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.TimestampType
                    extended by org.hibernate.type.DbTimestampType
All Implemented Interfaces:
LiteralType, Serializable, Type, VersionType
public class DbTimestampType
extends TimestampType
implements VersionType

dbtimestamp: An extension of TimestampType which maps to the database's current timestamp, rather than the jvm's current timestamp.

Note: May/may-not cause issues on dialects which do not properly support a true notion of timestamp (Oracle < 8, for example, where only its DATE datatype is supported). Depends on the frequency of DML operations...

Author:
Steve Ebersole
See Also:
Serialized Form

Constructor Summary
DbTimestampType()
Method Summary
String | getName() Returns the abbreviated name of the type.
Object | seed(SessionImplementor session) Generate an initial version.
Methods inherited from class org.hibernate.type.TimestampType
deepCopyNotNull, fromStringValue, get, getComparator, getHashCode, getReturnedClass, isEqual, next, objectToSQLString, set, sqlType, toString
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.VersionType
getComparator, isEqual, next
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getReturnedClass, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Constructor Detail

DbTimestampType

public DbTimestampType()
Method Detail

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Overrides:
getName in class TimestampType

seed

public Object seed(SessionImplementor session)
Description copied from interface: VersionType
Generate an initial version.

Specified by:
seed in interface VersionType
Overrides:
seed in class TimestampType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DoubleType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class DoubleType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.PrimitiveType
                    extended by org.hibernate.type.DoubleType
All Implemented Interfaces:
LiteralType, Serializable, Type
public class DoubleType
extends PrimitiveType

double: A type that maps an SQL DOUBLE to a Java Double.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
DoubleType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 Serializable getDefaultValue()
 String getName()
Returns the abbreviated name of the type.
 Class getPrimitiveClass()
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
Methods inherited from class org.hibernate.type.PrimitiveType
toString
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DoubleType

public DoubleType()
Method Detail

getDefaultValue

public Serializable getDefaultValue()
Specified by:
getDefaultValue in class PrimitiveType

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getPrimitiveClass

public Class getPrimitiveClass()
Specified by:
getPrimitiveClass in class PrimitiveType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmbeddedComponentType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class EmbeddedComponentType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.ComponentType
            extended by org.hibernate.type.EmbeddedComponentType
All Implemented Interfaces:
AbstractComponentType, Serializable, Type
public class EmbeddedComponentType
extends ComponentType

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.ComponentType
propertySpan, tuplizerMapping
Constructor Summary
EmbeddedComponentType(ComponentMetamodel metamodel)
Method Summary
Object | instantiate(Object parent, SessionImplementor session)
boolean | isEmbedded()
boolean | isMethodOf(Method method)
Methods inherited from class org.hibernate.type.ComponentType
assemble, compare, deepCopy, disassemble, fromXMLNode, getCascadeStyle, getColumnSpan, getFetchMode, getHashCode, getHashCode, getName, getPropertyNames, getPropertyNullability, getPropertyValue, getPropertyValue, getPropertyValues, getPropertyValues, getReturnedClass, getSubtypes, hydrate, instantiate, isComponentType, isDirty, isDirty, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setPropertyValues, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getSemiResolvedType, isAnyType, isAssociationType, isCollectionType, isEntityType, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getSemiResolvedType, isAnyType, isAssociationType, isCollectionType, isEntityType

Constructor Detail

EmbeddedComponentType

public EmbeddedComponentType(ComponentMetamodel metamodel)
Method Detail

isEmbedded

public boolean isEmbedded()
Specified by:
isEmbedded in interface AbstractComponentType
Overrides:
isEmbedded in class ComponentType

isMethodOf

public boolean isMethodOf(Method method)
Specified by:
isMethodOf in interface AbstractComponentType
Overrides:
isMethodOf in class ComponentType

instantiate

public Object instantiate(Object parent,
                          SessionImplementor session)
                   throws HibernateException
Overrides:
instantiate in class ComponentType
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EntityType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class EntityType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.EntityType
All Implemented Interfaces:
AssociationType, Serializable, Type
Direct Known Subclasses:
ManyToOneType, OneToOneType
public abstract class EntityType
extends AbstractType
implements AssociationType

A reference to an entity class

Author:
Gavin King
See Also:
Serialized Form

Field Summary
protected boolean | isEmbeddedInXML
protected String | uniqueKeyPropertyName
Constructor Summary
protected EntityType(String entityName, String uniqueKeyPropertyName, boolean eager, boolean isEmbeddedInXML, boolean unwrapProxy)
Method Summary
int | compare(Object x, Object y, EntityMode entityMode) compare two instances of the type
Object | deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory) Return a deep copy of the persistent state, stopping at entities and at collections.
Object | fromXMLNode(org.dom4j.Node xml, Mapping factory) Parse the XML representation of an instance.
String | getAssociatedEntityName()
String | getAssociatedEntityName(SessionFactoryImplementor factory) Get the entity name of the associated entity
Joinable | getAssociatedJoinable(SessionFactoryImplementor factory) Get the "persister" for this association - a class or collection persister
int | getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory) Get a hashcode, consistent with persistence "equality"
protected Object | getIdentifier(Object value, SessionImplementor session)
String | getIdentifierOrUniqueKeyPropertyName(Mapping factory)
Type | getIdentifierOrUniqueKeyType(Mapping factory)
String | getLHSPropertyName() Get the name of a property in the owning entity that provides the join key (null if the identifier)
String | getName() Returns the abbreviated name of the type.
String | getOnCondition(String alias, SessionFactoryImplementor factory, Map enabledFilters) Get the "filtering" SQL fragment that is applied in the SQL on clause, in addition to the usual join condition
String | getPropertyName()
Class | getReturnedClass() This returns the wrong class for an entity with a proxy, or for a named entity.
String | getRHSUniqueKeyPropertyName() The name of a unique property of the associated entity that provides the join key (null if the identifier of an entity, or key of a collection)
Type | getSemiResolvedType(SessionFactoryImplementor factory) Get the type of a semi-resolved value.
boolean | isAssociationType() Return true if the implementation is castable to AssociationType.
boolean | isEmbeddedInXML()
boolean | isEntityType() Is this type an entity type?
boolean | isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
boolean | isMutable() Are objects of this type mutable.
protected boolean | isNotEmbedded(SessionImplementor session)
protected boolean | isNull(Object owner, SessionImplementor session)
protected abstract boolean | isNullable()
abstract boolean | isOneToOne()
boolean | isReferenceToPrimaryKey() Does this association foreign key reference the primary key of the other table?
boolean | isSame(Object x, Object y, EntityMode entityMode) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.
boolean | isXMLElement()
Object | loadByUniqueKey(String entityName, String uniqueKeyPropertyName, Object key, SessionImplementor session) Load an instance by a unique key that is not the primary key.
Object | nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
Object | nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
Object | replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
Object | resolve(Object value, SessionImplementor session, Object owner) Resolve an identifier or unique key value
protected Object | resolveIdentifier(Serializable id, SessionImplementor session) Resolve an identifier
void | setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory) A representation of the value to be embedded in an XML element.
String | toLoggableString(Object value, SessionFactoryImplementor factory) A representation of the value to be embedded in a log file.
String | toString()
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, disassemble, getHashCode, hydrate, isAnyType, isCollectionType, isComponentType, isDirty, isEqual, isModified, replace, replaceNode, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.AssociationType
getForeignKeyDirection, isAlwaysDirtyChecked, useLHSPrimaryKey
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, disassemble, getColumnSpan, getHashCode, hydrate, isAnyType, isCollectionType, isComponentType, isDirty, isDirty, isEqual, isModified, nullSafeSet, nullSafeSet, replace, semiResolve, sqlTypes, toColumnNullness

Field Detail

uniqueKeyPropertyName

protected final String uniqueKeyPropertyName

isEmbeddedInXML

protected final boolean isEmbeddedInXML
Constructor Detail

EntityType

protected EntityType(String entityName,
                     String uniqueKeyPropertyName,
                     boolean eager,
                     boolean isEmbeddedInXML,
                     boolean unwrapProxy)
Method Detail

isEmbeddedInXML

public boolean isEmbeddedInXML()
Specified by:
isEmbeddedInXML in interface AssociationType

isEntityType

public final boolean isEntityType()
Description copied from interface: Type
Is this type an entity type?

Specified by:
isEntityType in interface Type
Overrides:
isEntityType in class AbstractType

getPropertyName

public String getPropertyName()

getAssociatedEntityName

public final String getAssociatedEntityName()

isSame

public final boolean isSame(Object x,
                            Object y,
                            EntityMode entityMode)
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.

Specified by:
isSame in interface Type
Overrides:
isSame in class AbstractType

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Overrides:
compare in class AbstractType

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String name,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementations should handle possibility of null values. This method might be called if the type is known to be a single-column type.

Specified by:
nullSafeGet in interface Type
Parameters:
rs -
name - the column name
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException

getReturnedClass

public final Class getReturnedClass()
This returns the wrong class for an entity with a proxy, or for a named entity. Theoretically it should return the proxy class, but it doesn't.

Specified by:
getReturnedClass in interface Type
Returns:
Class

getIdentifier

protected final Object getIdentifier(Object value,
                                     SessionImplementor session)
                              throws HibernateException
Throws:
HibernateException

isNotEmbedded

protected boolean isNotEmbedded(SessionImplementor session)

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
                        throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in a log file.

Specified by:
toLoggableString in interface Type
Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

deepCopy

public Object deepCopy(Object value,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
Description copied from interface: Type
Return a deep copy of the persistent state, stopping at entities and at collections.

Specified by:
deepCopy in interface Type
Parameters:
value - generally a collection element or entity field
entityMode -
factory -
Returns:
Object a copy

isMutable

public boolean isMutable()
Description copied from interface: Type
Are objects of this type mutable. (With respect to the referencing object ... entities and collections are considered immutable because they manage their own internal state.)

Specified by:
isMutable in interface Type
Returns:
boolean

isOneToOne

public abstract boolean isOneToOne()

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache)
               throws HibernateException
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Specified by:
replace in interface Type
Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException

isAssociationType

public boolean isAssociationType()
Description copied from interface: Type
Return true if the implementation is castable to AssociationType. This does not necessarily imply that the type actually represents an association.

Specified by:
isAssociationType in interface Type
Overrides:
isAssociationType in class AbstractType

nullSafeGet

public final Object nullSafeGet(ResultSet rs,
                                String[] names,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException,
                                SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Specified by:
nullSafeGet in interface Type
Parameters:
rs -
names - the column names
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException
See Also:
alternative, 2-phase property initialization

getAssociatedJoinable

public Joinable getAssociatedJoinable(SessionFactoryImplementor factory)
                               throws MappingException
Description copied from interface: AssociationType
Get the "persister" for this association - a class or collection persister

Specified by:
getAssociatedJoinable in interface AssociationType
Throws:
MappingException

getIdentifierOrUniqueKeyType

public final Type getIdentifierOrUniqueKeyType(Mapping factory)
                                        throws MappingException
Throws:
MappingException

getIdentifierOrUniqueKeyPropertyName

public final String getIdentifierOrUniqueKeyPropertyName(Mapping factory)
                                                  throws MappingException
Throws:
MappingException

isNullable

protected abstract boolean isNullable()

resolveIdentifier

protected final Object resolveIdentifier(Serializable id,
                                         SessionImplementor session)
                                  throws HibernateException
Resolve an identifier

Throws:
HibernateException

isNull

protected boolean isNull(Object owner,
                         SessionImplementor session)

resolve

public Object resolve(Object value,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException
Resolve an identifier or unique key value

Specified by:
resolve in interface Type
Overrides:
resolve in class AbstractType
Throws:
HibernateException

getAssociatedEntityName

public String getAssociatedEntityName(SessionFactoryImplementor factory)
Description copied from interface: AssociationType
Get the entity name of the associated entity

Specified by:
getAssociatedEntityName in interface AssociationType

isReferenceToPrimaryKey

public boolean isReferenceToPrimaryKey()
Does this association foreign key reference the primary key of the other table?

getRHSUniqueKeyPropertyName

public String getRHSUniqueKeyPropertyName()
Description copied from interface: AssociationType
The name of a unique property of the associated entity that provides the join key (null if the identifier of an entity, or key of a collection)

Specified by:
getRHSUniqueKeyPropertyName in interface AssociationType

toString

public String toString()

loadByUniqueKey

public Object loadByUniqueKey(String entityName,
                              String uniqueKeyPropertyName,
                              Object key,
                              SessionImplementor session)
                       throws HibernateException
Load an instance by a unique key that is not the primary key.

Throws:
HibernateException

getLHSPropertyName

public String getLHSPropertyName()
Description copied from interface: AssociationType
Get the name of a property in the owning entity that provides the join key (null if the identifier)

Specified by:
getLHSPropertyName in interface AssociationType

getOnCondition

public String getOnCondition(String alias,
                             SessionFactoryImplementor factory,
                             Map enabledFilters)
                      throws MappingException
Description copied from interface: AssociationType
Get the "filtering" SQL fragment that is applied in the SQL on clause, in addition to the usual join condition

Specified by:
getOnCondition in interface AssociationType
Throws:
MappingException

getSemiResolvedType

public Type getSemiResolvedType(SessionFactoryImplementor factory)
Description copied from interface: Type
Get the type of a semi-resolved value.

Specified by:
getSemiResolvedType in interface Type
Overrides:
getSemiResolvedType in class AbstractType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

isEqual

public boolean isEqual(Object x,
                       Object y,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Specified by:
isEqual in interface Type
Overrides:
isEqual in class AbstractType

isXMLElement

public boolean isXMLElement()
Specified by:
isXMLElement in interface Type
Overrides:
isXMLElement in class AbstractType

fromXMLNode

public Object fromXMLNode(org.dom4j.Node xml,
                          Mapping factory)
                   throws HibernateException
Description copied from interface: Type
Parse the XML representation of an instance.

Specified by:
fromXMLNode in interface Type
Parameters:
xml -
factory -
Returns:
an instance of the type
Throws:
HibernateException

setToXMLNode

public void setToXMLNode(org.dom4j.Node node,
                         Object value,
                         SessionFactoryImplementor factory)
                  throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in an XML element.

Specified by:
setToXMLNode in interface Type
Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FloatType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class FloatType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.PrimitiveType
                    extended by org.hibernate.type.FloatType
All Implemented Interfaces:
LiteralType, Serializable, Type
public class FloatType
extends PrimitiveType

float: A type that maps an SQL FLOAT to a Java Float.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
FloatType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 Serializable getDefaultValue()
 String getName()
Returns the abbreviated name of the type.
 Class getPrimitiveClass()
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
Methods inherited from class org.hibernate.type.PrimitiveType
toString
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FloatType

public FloatType()
Method Detail

getDefaultValue

public Serializable getDefaultValue()
Specified by:
getDefaultValue in class PrimitiveType

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getPrimitiveClass

public Class getPrimitiveClass()
Specified by:
getPrimitiveClass in class PrimitiveType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ForeignKeyDirection (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class ForeignKeyDirection

java.lang.Object
    extended by org.hibernate.type.ForeignKeyDirection
All Implemented Interfaces:
Serializable
public abstract class ForeignKeyDirection
extends Object
implements Serializable

Represents directionality of the foreign key constraint

Author:
Gavin King
See Also:
Serialized Form

Field Summary
static ForeignKeyDirection | FOREIGN_KEY_FROM_PARENT A foreign key from parent to child
static ForeignKeyDirection | FOREIGN_KEY_TO_PARENT A foreign key from child to parent
Constructor Summary
protected ForeignKeyDirection()
Method Summary
abstract  boolean cascadeNow(int cascadePoint)
Should we cascade at this cascade point?
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FOREIGN_KEY_TO_PARENT

public static final ForeignKeyDirection FOREIGN_KEY_TO_PARENT
A foreign key from child to parent

FOREIGN_KEY_FROM_PARENT

public static final ForeignKeyDirection FOREIGN_KEY_FROM_PARENT
A foreign key from parent to child

Constructor Detail

ForeignKeyDirection

protected ForeignKeyDirection()
Method Detail

cascadeNow

public abstract boolean cascadeNow(int cascadePoint)
Should we cascade at this cascade point?

See Also:
Cascade
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentifierBagType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class IdentifierBagType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CollectionType
            extended by org.hibernate.type.IdentifierBagType
All Implemented Interfaces:
AssociationType, Serializable, Type
public class IdentifierBagType
extends CollectionType

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.CollectionType
UNFETCHED_COLLECTION
Constructor Summary
IdentifierBagType(String role, String propertyRef, boolean isEmbeddedInXML)
Method Summary
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Object instantiate(int anticipatedSize)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
 PersistentCollection instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
Instantiate an uninitialized collection wrapper or holder.
 PersistentCollection wrap(SessionImplementor session, Object collection)
Wrap the naked collection instance in a wrapper, or instantiate a holder.
Methods inherited from class org.hibernate.type.CollectionType
assemble, compare, contains, deepCopy, disassemble, fromXMLNode, getAssociatedEntityName, getAssociatedJoinable, getCollection, getColumnSpan, getElementsIterator, getElementsIterator, getElementType, getForeignKeyDirection, getHashCode, getKeyOfOwner, getLHSPropertyName, getName, getOnCondition, getRHSUniqueKeyPropertyName, getRole, hasHolder, hydrate, indexOf, initializeImmediately, instantiateResult, isAlwaysDirtyChecked, isArrayType, isAssociationType, isCollectionType, isDirty, isDirty, isEmbeddedInXML, isEqual, isModified, isMutable, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, renderLoggableString, replace, replaceElements, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toString, useLHSPrimaryKey
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace

Constructor Detail

IdentifierBagType

public IdentifierBagType(String role,
                         String propertyRef,
                         boolean isEmbeddedInXML)
Method Detail

instantiate

public PersistentCollection instantiate(SessionImplementor session,
                                        CollectionPersister persister,
                                        Serializable key)
                                 throws HibernateException
Description copied from class: CollectionType
Instantiate an uninitialized collection wrapper or holder. Callers MUST add the holder to the persistence context!

Specified by:
instantiate in class CollectionType
Throws:
HibernateException

instantiate

public Object instantiate(int anticipatedSize)
Description copied from class: CollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial capacity and perhaps load factor).

Specified by:
instantiate in class CollectionType
Parameters:
anticipatedSize - The anticipated size of the instaniated collection after we are done populating it.

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

wrap

public PersistentCollection wrap(SessionImplementor session,
                                 Object collection)
Description copied from class: CollectionType
Wrap the naked collection instance in a wrapper, or instantiate a holder. Callers MUST add the holder to the persistence context!

Specified by:
wrap in class CollectionType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ImmutableType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class ImmutableType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
All Implemented Interfaces:
Serializable, Type
Direct Known Subclasses:
AdaptedImmutableType, BigDecimalType, BigIntegerType, ClassType, CurrencyType, LocaleType, PrimitiveType, StringType, TextType, TimeZoneType
public abstract class ImmutableType
extends NullableType

Superclass of nullable immutable types.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
ImmutableType()
Method Summary
Object | deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory) Return a deep copy of the persistent state, stopping at entities and at collections.
boolean | isMutable() Are objects of this type mutable.
Object | replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
Methods inherited from class org.hibernate.type.NullableType
fromStringValue, fromXMLNode, fromXMLString, get, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, set, setToXMLNode, sqlType, sqlTypes, toColumnNullness, toLoggableString, toString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
getName, getReturnedClass

Constructor Detail

ImmutableType

public ImmutableType()
Method Detail

deepCopy

public final Object deepCopy(Object value,
                             EntityMode entityMode,
                             SessionFactoryImplementor factory)
Description copied from interface: Type
Return a deep copy of the persistent state, stopping at entities and at collections.

Parameters:
value - generally a collection element or entity field
entityMode -
factory -
Returns:
Object a copy

isMutable

public final boolean isMutable()
Description copied from interface: Type
Are objects of this type mutable. (With respect to the referencing object ... entities and collections are considered immutable because they manage their own internal state.)

Returns:
boolean

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache)
               throws HibernateException
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IntegerType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class IntegerType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.PrimitiveType
                    extended by org.hibernate.type.IntegerType
All Implemented Interfaces:
DiscriminatorType, IdentifierType, LiteralType, Serializable, Type, VersionType
public class IntegerType
extends PrimitiveType
implements DiscriminatorType, VersionType

integer: A type that maps an SQL INT to a Java Integer.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
IntegerType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 Comparator getComparator()
Get a comparator for version values.
 Serializable getDefaultValue()
 String getName()
Returns the abbreviated name of the type.
 Class getPrimitiveClass()
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Object next(Object current, SessionImplementor session)
Increment the version.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 Object seed(SessionImplementor session)
Generate an initial version.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 Object stringToObject(String xml)
Convert the value from the mapping file to a Java object.
Methods inherited from class org.hibernate.type.PrimitiveType
toString
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString
Methods inherited from interface org.hibernate.type.VersionType
isEqual

Constructor Detail

IntegerType

public IntegerType()
Method Detail

getDefaultValue

public Serializable getDefaultValue()
Specified by:
getDefaultValue in class PrimitiveType

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getPrimitiveClass

public Class getPrimitiveClass()
Specified by:
getPrimitiveClass in class PrimitiveType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

stringToObject

public Object stringToObject(String xml)
                      throws Exception
Description copied from interface: IdentifierType
Convert the value from the mapping file to a Java object.

Specified by:
stringToObject in interface IdentifierType
Parameters:
xml - the value of discriminator-value or unsaved-value attribute
Returns:
Object
Throws:
Exception

next

public Object next(Object current,
                   SessionImplementor session)
Description copied from interface: VersionType
Increment the version.

Specified by:
next in interface VersionType
Parameters:
session - The session from which this request originates.
current - the current version
Returns:
an instance of the type

seed

public Object seed(SessionImplementor session)
Description copied from interface: VersionType
Generate an initial version.

Specified by:
seed in interface VersionType
Parameters:
session - The session from which this request originates.
Returns:
an instance of the type

getComparator

public Comparator getComparator()
Description copied from interface: VersionType
Get a comparator for version values.

Specified by:
getComparator in interface VersionType
Returns:
The comparator to use to compare different version values.

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class ListType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CollectionType
            extended by org.hibernate.type.ListType
All Implemented Interfaces:
AssociationType, Serializable, Type
public class ListType
extends CollectionType

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.CollectionType
UNFETCHED_COLLECTION
Constructor Summary
ListType(String role, String propertyRef, boolean isEmbeddedInXML)
Method Summary
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Object indexOf(Object collection, Object element)
 Object instantiate(int anticipatedSize)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
 PersistentCollection instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
Instantiate an uninitialized collection wrapper or holder.
 PersistentCollection wrap(SessionImplementor session, Object collection)
Wrap the naked collection instance in a wrapper, or instantiate a holder.
Methods inherited from class org.hibernate.type.CollectionType
assemble, compare, contains, deepCopy, disassemble, fromXMLNode, getAssociatedEntityName, getAssociatedJoinable, getCollection, getColumnSpan, getElementsIterator, getElementsIterator, getElementType, getForeignKeyDirection, getHashCode, getKeyOfOwner, getLHSPropertyName, getName, getOnCondition, getRHSUniqueKeyPropertyName, getRole, hasHolder, hydrate, initializeImmediately, instantiateResult, isAlwaysDirtyChecked, isArrayType, isAssociationType, isCollectionType, isDirty, isDirty, isEmbeddedInXML, isEqual, isModified, isMutable, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, renderLoggableString, replace, replaceElements, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toString, useLHSPrimaryKey
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace

Constructor Detail

ListType

public ListType(String role,
                String propertyRef,
                boolean isEmbeddedInXML)
Method Detail

instantiate

public PersistentCollection instantiate(SessionImplementor session,
                                        CollectionPersister persister,
                                        Serializable key)
Description copied from class: CollectionType
Instantiate an uninitialized collection wrapper or holder. Callers MUST add the holder to the persistence context!

Specified by:
instantiate in class CollectionType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

wrap

public PersistentCollection wrap(SessionImplementor session,
                                 Object collection)
Description copied from class: CollectionType
Wrap the naked collection instance in a wrapper, or instantiate a holder. Callers MUST add the holder to the persistence context!

Specified by:
wrap in class CollectionType

instantiate

public Object instantiate(int anticipatedSize)
Description copied from class: CollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial capacity and perhaps load factor).

Specified by:
instantiate in class CollectionType
Parameters:
anticipatedSize - The anticipated size of the instaniated collection after we are done populating it.

indexOf

public Object indexOf(Object collection,
                      Object element)
Overrides:
indexOf in class CollectionType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocaleType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class LocaleType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.LocaleType
All Implemented Interfaces:
LiteralType, Serializable, Type
public class LocaleType
extends ImmutableType
implements LiteralType

locale: A type that maps an SQL VARCHAR to a Java Locale.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
LocaleType()
Method Summary
 int compare(Object x, Object y, EntityMode entityMode)
compare two instances of the type
 Object fromStringValue(String string)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 String toString(Object value)
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LocaleType

public LocaleType()
Method Detail

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
HibernateException
SQLException

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws HibernateException,
                SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
HibernateException
SQLException

fromStringValue

public Object fromStringValue(String string)
Specified by:
fromStringValue in class NullableType

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Overrides:
compare in class AbstractType

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

toString

public String toString(Object value)
                throws HibernateException
Specified by:
toString in class NullableType
Throws:
HibernateException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LongType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class LongType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.PrimitiveType
                    extended by org.hibernate.type.LongType
All Implemented Interfaces:
DiscriminatorType, IdentifierType, LiteralType, Serializable, Type, VersionType
public class LongType
extends PrimitiveType
implements DiscriminatorType, VersionType

long: A type that maps an SQL BIGINT to a Java Long.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
LongType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 Comparator getComparator()
Get a comparator for version values.
 Serializable getDefaultValue()
 String getName()
Returns the abbreviated name of the type.
 Class getPrimitiveClass()
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Object next(Object current, SessionImplementor session)
Increment the version.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 Object seed(SessionImplementor session)
Generate an initial version.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 Object stringToObject(String xml)
Convert the value from the mapping file to a Java object.
Methods inherited from class org.hibernate.type.PrimitiveType
toString
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString
Methods inherited from interface org.hibernate.type.VersionType
isEqual

Constructor Detail

LongType

public LongType()
Method Detail

getDefaultValue

public Serializable getDefaultValue()
Specified by:
getDefaultValue in class PrimitiveType

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getPrimitiveClass

public Class getPrimitiveClass()
Specified by:
getPrimitiveClass in class PrimitiveType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

stringToObject

public Object stringToObject(String xml)
                      throws Exception
Description copied from interface: IdentifierType
Convert the value from the mapping file to a Java object.

Specified by:
stringToObject in interface IdentifierType
Parameters:
xml - the value of discriminator-value or unsaved-value attribute
Returns:
Object
Throws:
Exception

next

public Object next(Object current,
                   SessionImplementor session)
Description copied from interface: VersionType
Increment the version.

Specified by:
next in interface VersionType
Parameters:
session - The session from which this request originates.
current - the current version
Returns:
an instance of the type

seed

public Object seed(SessionImplementor session)
Description copied from interface: VersionType
Generate an initial version.

Specified by:
seed in interface VersionType
Parameters:
session - The session from which this request originates.
Returns:
an instance of the type

getComparator

public Comparator getComparator()
Description copied from interface: VersionType
Get a comparator for version values.

Specified by:
getComparator in interface VersionType
Returns:
The comparator to use to compare different version values.

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManyToOneType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class ManyToOneType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.EntityType
            extended by org.hibernate.type.ManyToOneType
All Implemented Interfaces:
AssociationType, Serializable, Type
public class ManyToOneType
extends EntityType

A many-to-one association to an entity.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.EntityType
isEmbeddedInXML, uniqueKeyPropertyName
Constructor Summary
ManyToOneType(String className)
ManyToOneType(String className, boolean lazy)
ManyToOneType(String entityName, String uniqueKeyPropertyName, boolean lazy, boolean unwrapProxy, boolean isEmbeddedInXML, boolean ignoreNotFound)
Method Summary
Object | assemble(Serializable oid, SessionImplementor session, Object owner) Reconstruct the object from its cached "disassembled" state.
void | beforeAssemble(Serializable oid, SessionImplementor session) Called before assembling a query result set from the query cache, to allow batch fetching of entities missing from the second-level cache.
Serializable | disassemble(Object value, SessionImplementor session, Object owner) Return a cacheable "disassembled" representation of the object.
int | getColumnSpan(Mapping mapping) How many columns are used to persist this type.
ForeignKeyDirection | getForeignKeyDirection() Get the foreign key directionality of this association
Object | hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner) Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset.
boolean | isAlwaysDirtyChecked() Do we dirty check this association, even when there are no columns to be updated?
boolean | isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session) Should the parent be considered dirty, given both the old and current field or element value?
boolean | isDirty(Object old, Object current, SessionImplementor session) Should the parent be considered dirty, given both the old and current field or element value?
boolean | isModified(Object old, Object current, boolean[] checkable, SessionImplementor session) Has the parent object been modified, compared to the current database state?
protected boolean | isNullable()
boolean | isOneToOne()
void | nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session) Write an instance of the mapped class to a prepared statement, ignoring some columns.
void | nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session) Write an instance of the mapped class to a prepared statement.
int[] | sqlTypes(Mapping mapping) Return the SQL type codes for the columns mapped by this type.
boolean[] | toColumnNullness(Object value, Mapping mapping) Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
boolean | useLHSPrimaryKey() Is the primary key of the owning entity table to be used in the join?
Methods inherited from class org.hibernate.type.EntityType
compare, deepCopy, fromXMLNode, getAssociatedEntityName, getAssociatedEntityName, getAssociatedJoinable, getHashCode, getIdentifier, getIdentifierOrUniqueKeyPropertyName, getIdentifierOrUniqueKeyType, getLHSPropertyName, getName, getOnCondition, getPropertyName, getReturnedClass, getRHSUniqueKeyPropertyName, getSemiResolvedType, isAssociationType, isEmbeddedInXML, isEntityType, isEqual, isMutable, isNotEmbedded, isNull, isReferenceToPrimaryKey, isSame, isXMLElement, loadByUniqueKey, nullSafeGet, nullSafeGet, replace, resolve, resolveIdentifier, setToXMLNode, toLoggableString, toString
Methods inherited from class org.hibernate.type.AbstractType
getHashCode, isAnyType, isCollectionType, isComponentType, isEqual, replace, replaceNode, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
getHashCode, isAnyType, isCollectionType, isComponentType, isEqual, replace, semiResolve

Constructor Detail

ManyToOneType

public ManyToOneType(String className)

ManyToOneType

public ManyToOneType(String className,
                     boolean lazy)

ManyToOneType

public ManyToOneType(String entityName,
                     String uniqueKeyPropertyName,
                     boolean lazy,
                     boolean unwrapProxy,
                     boolean isEmbeddedInXML,
                     boolean ignoreNotFound)
Method Detail

isNullable

protected boolean isNullable()
Specified by:
isNullable in class EntityType

isAlwaysDirtyChecked

public boolean isAlwaysDirtyChecked()
Description copied from interface: AssociationType
Do we dirty check this association, even when there are no columns to be updated?

isOneToOne

public boolean isOneToOne()
Specified by:
isOneToOne in class EntityType

getColumnSpan

public int getColumnSpan(Mapping mapping)
                  throws MappingException
Description copied from interface: Type
How many columns are used to persist this type.

Throws:
MappingException

sqlTypes

public int[] sqlTypes(Mapping mapping)
               throws MappingException
Description copied from interface: Type
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Returns:
the typecodes
Throws:
MappingException
See Also:
Types

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        boolean[] settable,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement, ignoring some columns. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
settable - an array indicating which columns to ignore
session -
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
session -
Throws:
HibernateException
SQLException

getForeignKeyDirection

public ForeignKeyDirection getForeignKeyDirection()
Description copied from interface: AssociationType
Get the foreign key directionality of this association

hydrate

public Object hydrate(ResultSet rs,
                      String[] names,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException,
                      SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset. This is useful for 2-phase property initialization - the second phase is a call to resolveIdentifier().

Specified by:
hydrate in interface Type
Overrides:
hydrate in class AbstractType
Throws:
HibernateException
SQLException

useLHSPrimaryKey

public boolean useLHSPrimaryKey()
Description copied from interface: AssociationType
Is the primary key of the owning entity table to be used in the join?

isModified

public boolean isModified(Object old,
                          Object current,
                          boolean[] checkable,
                          SessionImplementor session)
                   throws HibernateException
Description copied from interface: Type
Has the parent object been modified, compared to the current database state?

Specified by:
isModified in interface Type
Overrides:
isModified in class AbstractType
Throws:
HibernateException

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Description copied from interface: Type
Return a cacheable "disassembled" representation of the object.

Specified by:
disassemble in interface Type
Overrides:
disassemble in class AbstractType
Throws:
HibernateException

assemble

public Object assemble(Serializable oid,
                       SessionImplementor session,
                       Object owner)
                throws HibernateException
Description copied from interface: Type
Reconstruct the object from its cached "disassembled" state.

Specified by:
assemble in interface Type
Overrides:
assemble in class AbstractType
Throws:
HibernateException

beforeAssemble

public void beforeAssemble(Serializable oid,
                           SessionImplementor session)
Description copied from interface: Type
Called before assembling a query result set from the query cache, to allow batch fetching of entities missing from the second-level cache.

Specified by:
beforeAssemble in interface Type
Overrides:
beforeAssemble in class AbstractType

toColumnNullness

public boolean[] toColumnNullness(Object value,
                                  Mapping mapping)
Description copied from interface: Type
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.

Parameters:
value - an instance of the type

isDirty

public boolean isDirty(Object old,
                       Object current,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Specified by:
isDirty in interface Type
Overrides:
isDirty in class AbstractType
Throws:
HibernateException

isDirty

public boolean isDirty(Object old,
                       Object current,
                       boolean[] checkable,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Parameters:
old - the old value
current - the current value
checkable - which columns are actually updatable
session -
Returns:
true if the field is dirty
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MapType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class MapType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CollectionType
            extended by org.hibernate.type.MapType
All Implemented Interfaces:
AssociationType, Serializable, Type
Direct Known Subclasses:
OrderedMapType, SortedMapType
public class MapType
extends CollectionType

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.CollectionType
UNFETCHED_COLLECTION
Constructor Summary
MapType(String role, String propertyRef, boolean isEmbeddedInXML)
Method Summary
 Iterator getElementsIterator(Object collection)
Get an iterator over the element set of the collection in POJO mode
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Object indexOf(Object collection, Object element)
 Object instantiate(int anticipatedSize)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
 PersistentCollection instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
Instantiate an uninitialized collection wrapper or holder.
 Object replaceElements(Object original, Object target, Object owner, Map copyCache, SessionImplementor session)
Replace the elements of a collection with the elements of another collection
 PersistentCollection wrap(SessionImplementor session, Object collection)
Wrap the naked collection instance in a wrapper, or instantiate a holder.
Methods inherited from class org.hibernate.type.CollectionType
assemble, compare, contains, deepCopy, disassemble, fromXMLNode, getAssociatedEntityName, getAssociatedJoinable, getCollection, getColumnSpan, getElementsIterator, getElementType, getForeignKeyDirection, getHashCode, getKeyOfOwner, getLHSPropertyName, getName, getOnCondition, getRHSUniqueKeyPropertyName, getRole, hasHolder, hydrate, initializeImmediately, instantiateResult, isAlwaysDirtyChecked, isArrayType, isAssociationType, isCollectionType, isDirty, isDirty, isEmbeddedInXML, isEqual, isModified, isMutable, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, renderLoggableString, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toString, useLHSPrimaryKey
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace

Constructor Detail

MapType

public MapType(String role,
               String propertyRef,
               boolean isEmbeddedInXML)
Method Detail

instantiate

public PersistentCollection instantiate(SessionImplementor session,
                                        CollectionPersister persister,
                                        Serializable key)
Description copied from class: CollectionType
Instantiate an uninitialized collection wrapper or holder. Callers MUST add the holder to the persistence context!

Specified by:
instantiate in class CollectionType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

getElementsIterator

public Iterator getElementsIterator(Object collection)
Description copied from class: CollectionType
Get an iterator over the element set of the collection in POJO mode

Overrides:
getElementsIterator in class CollectionType

wrap

public PersistentCollection wrap(SessionImplementor session,
                                 Object collection)
Description copied from class: CollectionType
Wrap the naked collection instance in a wrapper, or instantiate a holder. Callers MUST add the holder to the persistence context!

Specified by:
wrap in class CollectionType

instantiate

public Object instantiate(int anticipatedSize)
Description copied from class: CollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial capacity and perhaps load factor).

Specified by:
instantiate in class CollectionType
Parameters:
anticipatedSize - The anticipated size of the instaniated collection after we are done populating it.

replaceElements

public Object replaceElements(Object original,
                              Object target,
                              Object owner,
                              Map copyCache,
                              SessionImplementor session)
                       throws HibernateException
Description copied from class: CollectionType
Replace the elements of a collection with the elements of another collection

Overrides:
replaceElements in class CollectionType
Throws:
HibernateException

indexOf

public Object indexOf(Object collection,
                      Object element)
Overrides:
indexOf in class CollectionType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MetaType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class MetaType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.MetaType
All Implemented Interfaces:
Serializable, Type
public class MetaType
extends AbstractType

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
MetaType(Map values, Type baseType)
Method Summary
 Object deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Return a deep copy of the persistent state, stopping at entities and at collections.
 Object fromXMLNode(org.dom4j.Node xml, Mapping factory)
Parse the XML representation of an instance.
 Object fromXMLString(String xml, Mapping factory)
 int getColumnSpan(Mapping mapping)
How many columns are used to persist this type.
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Should the parent be considered dirty, given both the old and current field or element value?
 boolean isMutable()
Are objects of this type mutable.
 Object nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 Object nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 void nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
Write an instance of the mapped class to a prepared statement, ignoring some columns.
 void nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Write an instance of the mapped class to a prepared statement.
 Object replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
 void setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in an XML element.
 int[] sqlTypes(Mapping mapping)
Return the SQL type codes for the columns mapped by this type.
 boolean[] toColumnNullness(Object value, Mapping mapping)
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
 String toLoggableString(Object value, SessionFactoryImplementor factory)
A representation of the value to be embedded in a log file.
 String toXMLString(Object value, SessionFactoryImplementor factory)
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MetaType

public MetaType(Map values,
                Type baseType)
Method Detail

sqlTypes

public int[] sqlTypes(Mapping mapping)
               throws MappingException
Description copied from interface: Type
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Returns:
the typecodes
Throws:
MappingException
See Also:
Types

getColumnSpan

public int getColumnSpan(Mapping mapping)
                  throws MappingException
Description copied from interface: Type
How many columns are used to persist this type.

Throws:
MappingException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String[] names,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Parameters:
rs -
names - the column names
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException
See Also:
alternative, 2-phase property initialization

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String name,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementations should handle possibility of null values. This method might be called if the type is known to be a single-column type.

Parameters:
rs -
name - the column name
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
session -
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        boolean[] settable,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement, ignoring some columns. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
settable - an array indicating which columns to ignore
session -
Throws:
HibernateException
SQLException

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
                        throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in a log file.

Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

toXMLString

public String toXMLString(Object value,
                          SessionFactoryImplementor factory)
                   throws HibernateException
Throws:
HibernateException

fromXMLString

public Object fromXMLString(String xml,
                            Mapping factory)
                     throws HibernateException
Throws:
HibernateException

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name

deepCopy

public Object deepCopy(Object value,
                       EntityMode entityMode,
                       SessionFactoryImplementor factory)
                throws HibernateException
Description copied from interface: Type
Return a deep copy of the persistent state, stopping at entities and at collections.

Parameters:
value - generally a collection element or entity field
entityMode -
factory -
Returns:
Object a copy
Throws:
HibernateException

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache)
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged

isMutable

public boolean isMutable()
Description copied from interface: Type
Are objects of this type mutable. (With respect to the referencing object ... entities and collections are considered immutable because they manage their own internal state.)

Returns:
boolean

fromXMLNode

public Object fromXMLNode(org.dom4j.Node xml,
                          Mapping factory)
                   throws HibernateException
Description copied from interface: Type
Parse the XML representation of an instance.

Parameters:
xml -
factory -
Returns:
an instance of the type
Throws:
HibernateException

setToXMLNode

public void setToXMLNode(org.dom4j.Node node,
                         Object value,
                         SessionFactoryImplementor factory)
                  throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in an XML element.

Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

toColumnNullness

public boolean[] toColumnNullness(Object value,
                                  Mapping mapping)
Description copied from interface: Type
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.

Parameters:
value - an instance of the type

isDirty

public boolean isDirty(Object old,
                       Object current,
                       boolean[] checkable,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Parameters:
old - the old value
current - the current value
checkable - which columns are actually updatable
session -
Returns:
true if the field is dirty
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MutableType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class MutableType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
All Implemented Interfaces:
Serializable, Type
Direct Known Subclasses:
AbstractBynaryType, AbstractCharArrayType, CalendarDateType, CalendarType, DateType, SerializableType, TimestampType, TimeType
public abstract class MutableType
extends NullableType

Superclass for mutable nullable types

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
MutableType()
Method Summary
Object | deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory) Return a deep copy of the persistent state, stopping at entities and at collections.
protected abstract Object | deepCopyNotNull(Object value)
boolean | isMutable() Are objects of this type mutable.
Object | replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
Methods inherited from class org.hibernate.type.NullableType
fromStringValue, fromXMLNode, fromXMLString, get, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, set, setToXMLNode, sqlType, sqlTypes, toColumnNullness, toLoggableString, toString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
getName, getReturnedClass

Constructor Detail

MutableType

public MutableType()
Method Detail

isMutable

public final boolean isMutable()
Description copied from interface: Type
Are objects of this type mutable. (With respect to the referencing object ... entities and collections are considered immutable because they manage their own internal state.)

Returns:
boolean

deepCopyNotNull

protected abstract Object deepCopyNotNull(Object value)
                                   throws HibernateException
Throws:
HibernateException

deepCopy

public final Object deepCopy(Object value,
                             EntityMode entityMode,
                             SessionFactoryImplementor factory)
                      throws HibernateException
Description copied from interface: Type
Return a deep copy of the persistent state, stopping at entities and at collections.

Parameters:
value - generally a collection element or entity field
entityMode -
factory -
Returns:
Object a copy
Throws:
HibernateException

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner,
                      Map copyCache)
               throws HibernateException
Description copied from interface: Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NullableType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class NullableType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
All Implemented Interfaces:
Serializable, Type
Direct Known Subclasses:
ImmutableType, MutableType
public abstract class NullableType
extends AbstractType

Superclass of single-column nullable types.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
NullableType()
Method Summary
abstract Object | fromStringValue(String xml)
Object | fromXMLNode(org.dom4j.Node xml, Mapping factory) Parse the XML representation of an instance.
Object | fromXMLString(String xml, Mapping factory)
abstract Object | get(ResultSet rs, String name) Get a column value from a result set, without worrying about the possibility of null values
int | getColumnSpan(Mapping session) How many columns are used to persist this type.
boolean | isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session) Should the parent be considered dirty, given both the old and current field or element value?
boolean | isEqual(Object x, Object y)
boolean | isEqual(Object x, Object y, EntityMode entityMode) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
Object | nullSafeGet(ResultSet rs, String name)
Object | nullSafeGet(ResultSet rs, String[] names)
Object | nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
Object | nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
void | nullSafeSet(PreparedStatement st, Object value, int index)
void | nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session) Write an instance of the mapped class to a prepared statement, ignoring some columns.
void | nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session) Write an instance of the mapped class to a prepared statement.
abstract void | set(PreparedStatement st, Object value, int index) Get a parameter value without worrying about the possibility of null values
void | setToXMLNode(org.dom4j.Node xml, Object value, SessionFactoryImplementor factory) A representation of the value to be embedded in an XML element.
abstract int | sqlType()
int[] | sqlTypes(Mapping session) Return the SQL type codes for the columns mapped by this type.
boolean[] | toColumnNullness(Object value, Mapping mapping) Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
String | toLoggableString(Object value, SessionFactoryImplementor factory) A representation of the value to be embedded in a log file.
abstract String | toString(Object value)
String | toXMLString(Object value, SessionFactoryImplementor pc)
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
deepCopy, getName, getReturnedClass, isMutable, replace

Constructor Detail

NullableType

public NullableType()
Method Detail

get

public abstract Object get(ResultSet rs,
                           String name)
                    throws HibernateException,
                           SQLException
Get a column value from a result set, without worrying about the possibility of null values

Throws:
HibernateException
SQLException

set

public abstract void set(PreparedStatement st,
                         Object value,
                         int index)
                  throws HibernateException,
                         SQLException
Get a parameter value without worrying about the possibility of null values

Throws:
HibernateException
SQLException

sqlType

public abstract int sqlType()

toString

public abstract String toString(Object value)
                         throws HibernateException
Throws:
HibernateException

fromStringValue

public abstract Object fromStringValue(String xml)
                                throws HibernateException
Throws:
HibernateException

nullSafeSet

public final void nullSafeSet(PreparedStatement st,
                              Object value,
                              int index,
                              boolean[] settable,
                              SessionImplementor session)
                       throws HibernateException,
                              SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement, ignoring some columns. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
settable - an array indicating which columns to ignore
session -
Throws:
HibernateException
SQLException

nullSafeSet

public final void nullSafeSet(PreparedStatement st,
                              Object value,
                              int index,
                              SessionImplementor session)
                       throws HibernateException,
                              SQLException
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
session -
Throws:
HibernateException
SQLException

nullSafeSet

public final void nullSafeSet(PreparedStatement st,
                              Object value,
                              int index)
                       throws HibernateException,
                              SQLException
Throws:
HibernateException
SQLException

nullSafeGet

public final Object nullSafeGet(ResultSet rs,
                                String[] names,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException,
                                SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Parameters:
rs -
names - the column names
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException
See Also:
alternative, 2-phase property initialization

nullSafeGet

public final Object nullSafeGet(ResultSet rs,
                                String[] names)
                         throws HibernateException,
                                SQLException
Throws:
HibernateException
SQLException

nullSafeGet

public final Object nullSafeGet(ResultSet rs,
                                String name)
                         throws HibernateException,
                                SQLException
Throws:
HibernateException
SQLException

nullSafeGet

public final Object nullSafeGet(ResultSet rs,
                                String name,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException,
                                SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class from a JDBC resultset. Implementations should handle possibility of null values. This method might be called if the type is known to be a single-column type.

Parameters:
rs -
name - the column name
session -
owner - the parent entity
Returns:
Object
Throws:
HibernateException
SQLException

toXMLString

public final String toXMLString(Object value,
                                SessionFactoryImplementor pc)
                         throws HibernateException
Throws:
HibernateException

fromXMLString

public final Object fromXMLString(String xml,
                                  Mapping factory)
                           throws HibernateException
Throws:
HibernateException

getColumnSpan

public final int getColumnSpan(Mapping session)
Description copied from interface: Type
How many columns are used to persist this type.

sqlTypes

public final int[] sqlTypes(Mapping session)
Description copied from interface: Type
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Returns:
the typecodes
See Also:
Types

isEqual

public final boolean isEqual(Object x,
                             Object y,
                             EntityMode entityMode)
Description copied from interface: Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.

Specified by:
isEqual in interface Type
Overrides:
isEqual in class AbstractType

isEqual

public boolean isEqual(Object x,
                       Object y)

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
Description copied from interface: Type
A representation of the value to be embedded in a log file.

Parameters:
value -
factory -
Returns:
String

fromXMLNode

public Object fromXMLNode(org.dom4j.Node xml,
                          Mapping factory)
                   throws HibernateException
Description copied from interface: Type
Parse the XML representation of an instance.

Parameters:
xml -
factory -
Returns:
an instance of the type
Throws:
HibernateException

setToXMLNode

public void setToXMLNode(org.dom4j.Node xml,
                         Object value,
                         SessionFactoryImplementor factory)
                  throws HibernateException
Description copied from interface: Type
A representation of the value to be embedded in an XML element.

Parameters:
value -
factory -
Returns:
String
Throws:
HibernateException

toColumnNullness

public boolean[] toColumnNullness(Object value,
                                  Mapping mapping)
Description copied from interface: Type
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.

Parameters:
value - an instance of the type

isDirty

public boolean isDirty(Object old,
                       Object current,
                       boolean[] checkable,
                       SessionImplementor session)
                throws HibernateException
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Parameters:
old - the old value
current - the current value
checkable - which columns are actually updatable
session -
Returns:
true if the field is dirty
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OneToOneType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class OneToOneType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.EntityType
            extended by org.hibernate.type.OneToOneType
All Implemented Interfaces:
AssociationType, Serializable, Type
Direct Known Subclasses:
SpecialOneToOneType
public class OneToOneType
extends EntityType

A one-to-one association to an entity

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.EntityType
isEmbeddedInXML, uniqueKeyPropertyName
Constructor Summary
OneToOneType(String referencedEntityName, ForeignKeyDirection foreignKeyType, String uniqueKeyPropertyName, boolean lazy, boolean unwrapProxy, boolean isEmbeddedInXML, String entityName, String propertyName)
Method Summary
Object | assemble(Serializable oid, SessionImplementor session, Object owner) Reconstruct the object from its cached "disassembled" state.
Serializable | disassemble(Object value, SessionImplementor session, Object owner) Return a cacheable "disassembled" representation of the object.
int | getColumnSpan(Mapping session) How many columns are used to persist this type.
ForeignKeyDirection | getForeignKeyDirection() Get the foreign key directionality of this association
String | getPropertyName()
Object | hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner) Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset.
boolean | isAlwaysDirtyChecked() We don't need to dirty check one-to-one because of how assemble/disassemble is implemented and because a one-to-one association is never dirty
boolean | isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session) Should the parent be considered dirty, given both the old and current field or element value?
boolean | isDirty(Object old, Object current, SessionImplementor session) Should the parent be considered dirty, given both the old and current field or element value?
boolean | isModified(Object old, Object current, boolean[] checkable, SessionImplementor session) Has the parent object been modified, compared to the current database state?
boolean | isNull(Object owner, SessionImplementor session)
protected boolean | isNullable()
boolean | isOneToOne()
void | nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session) Write an instance of the mapped class to a prepared statement, ignoring some columns.
void | nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session) Write an instance of the mapped class to a prepared statement.
int[] | sqlTypes(Mapping session) Return the SQL type codes for the columns mapped by this type.
boolean[] | toColumnNullness(Object value, Mapping mapping) Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
boolean | useLHSPrimaryKey() Is the primary key of the owning entity table to be used in the join?
Methods inherited from class org.hibernate.type.EntityType
compare, deepCopy, fromXMLNode, getAssociatedEntityName, getAssociatedEntityName, getAssociatedJoinable, getHashCode, getIdentifier, getIdentifierOrUniqueKeyPropertyName, getIdentifierOrUniqueKeyType, getLHSPropertyName, getName, getOnCondition, getReturnedClass, getRHSUniqueKeyPropertyName, getSemiResolvedType, isAssociationType, isEmbeddedInXML, isEntityType, isEqual, isMutable, isNotEmbedded, isReferenceToPrimaryKey, isSame, isXMLElement, loadByUniqueKey, nullSafeGet, nullSafeGet, replace, resolve, resolveIdentifier, setToXMLNode, toLoggableString, toString
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, isAnyType, isCollectionType, isComponentType, isEqual, replace, replaceNode, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, isAnyType, isCollectionType, isComponentType, isEqual, replace, semiResolve

Constructor Detail

OneToOneType

public OneToOneType(String referencedEntityName,
                    ForeignKeyDirection foreignKeyType,
                    String uniqueKeyPropertyName,
                    boolean lazy,
                    boolean unwrapProxy,
                    boolean isEmbeddedInXML,
                    String entityName,
                    String propertyName)
Method Detail

getPropertyName

public String getPropertyName()
Overrides:
getPropertyName in class EntityType

isNull

public boolean isNull(Object owner,
                      SessionImplementor session)
Overrides:
isNull in class EntityType

getColumnSpan

public int getColumnSpan(Mapping session)
                  throws MappingException
Description copied from interface: Type
How many columns are used to persist this type.

Throws:
MappingException

sqlTypes

public int[] sqlTypes(Mapping session)
               throws MappingException
Description copied from interface: Type
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Returns:
the typecodes
Throws:
MappingException
See Also:
Types

toColumnNullness

public boolean[] toColumnNullness(Object value,
                                  Mapping mapping)
Description copied from interface: Type
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.

Parameters:
value - an instance of the type

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        boolean[] settable,
                        SessionImplementor session)
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement, ignoring some columns. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
settable - an array indicating which columns to ignore
session -

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        SessionImplementor session)
Description copied from interface: Type
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st -
value - the object to write
index - statement parameter index
session -

isOneToOne

public boolean isOneToOne()
Specified by:
isOneToOne in class EntityType

isDirty

public boolean isDirty(Object old,
                       Object current,
                       SessionImplementor session)
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Specified by:
isDirty in interface Type
Overrides:
isDirty in class AbstractType

isDirty

public boolean isDirty(Object old,
                       Object current,
                       boolean[] checkable,
                       SessionImplementor session)
Description copied from interface: Type
Should the parent be considered dirty, given both the old and current field or element value?

Parameters:
old - the old value
current - the current value
checkable - which columns are actually updatable
session -
Returns:
true if the field is dirty

isModified

public boolean isModified(Object old,
                          Object current,
                          boolean[] checkable,
                          SessionImplementor session)
Description copied from interface: Type
Has the parent object been modified, compared to the current database state?

Specified by:
isModified in interface Type
Overrides:
isModified in class AbstractType

getForeignKeyDirection

public ForeignKeyDirection getForeignKeyDirection()
Description copied from interface: AssociationType
Get the foreign key directionality of this association

hydrate

public Object hydrate(ResultSet rs,
                      String[] names,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException,
                      SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset. This is useful for 2-phase property initialization - the second phase is a call to resolveIdentifier().

Specified by:
hydrate in interface Type
Overrides:
hydrate in class AbstractType
Throws:
HibernateException
SQLException

isNullable

protected boolean isNullable()
Specified by:
isNullable in class EntityType

useLHSPrimaryKey

public boolean useLHSPrimaryKey()
Description copied from interface: AssociationType
Is the primary key of the owning entity table to be used in the join?

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Description copied from interface: Type
Return a cacheable "disassembled" representation of the object.

Specified by:
disassemble in interface Type
Overrides:
disassemble in class AbstractType
Throws:
HibernateException

assemble

public Object assemble(Serializable oid,
                       SessionImplementor session,
                       Object owner)
                throws HibernateException
Description copied from interface: Type
Reconstruct the object from its cached "disassembled" state.

Specified by:
assemble in interface Type
Overrides:
assemble in class AbstractType
Throws:
HibernateException

isAlwaysDirtyChecked

public boolean isAlwaysDirtyChecked()
We don't need to dirty check one-to-one because of how assemble/disassemble is implemented and because a one-to-one association is never dirty

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderedMapType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class OrderedMapType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CollectionType
            extended by org.hibernate.type.MapType
                extended by org.hibernate.type.OrderedMapType
All Implemented Interfaces:
AssociationType, Serializable, Type
public class OrderedMapType
extends MapType

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.CollectionType
UNFETCHED_COLLECTION
Constructor Summary
OrderedMapType(String role, String propertyRef, boolean isEmbeddedInXML)
Method Summary
 Object instantiate(int anticipatedSize)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
Methods inherited from class org.hibernate.type.MapType
getElementsIterator, getReturnedClass, indexOf, instantiate, replaceElements, wrap
Methods inherited from class org.hibernate.type.CollectionType
assemble, compare, contains, deepCopy, disassemble, fromXMLNode, getAssociatedEntityName, getAssociatedJoinable, getCollection, getColumnSpan, getElementsIterator, getElementType, getForeignKeyDirection, getHashCode, getKeyOfOwner, getLHSPropertyName, getName, getOnCondition, getRHSUniqueKeyPropertyName, getRole, hasHolder, hydrate, initializeImmediately, instantiateResult, isAlwaysDirtyChecked, isArrayType, isAssociationType, isCollectionType, isDirty, isDirty, isEmbeddedInXML, isEqual, isModified, isMutable, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, renderLoggableString, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toString, useLHSPrimaryKey
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace

Constructor Detail

OrderedMapType

public OrderedMapType(String role,
                      String propertyRef,
                      boolean isEmbeddedInXML)
Method Detail

instantiate

public Object instantiate(int anticipatedSize)
Description copied from class: CollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial capacity and perhaps load factor).

Overrides:
instantiate in class MapType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OrderedSetType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class OrderedSetType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CollectionType
            extended by org.hibernate.type.SetType
                extended by org.hibernate.type.OrderedSetType
All Implemented Interfaces:
AssociationType, Serializable, Type
public class OrderedSetType
extends SetType

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.CollectionType
UNFETCHED_COLLECTION
Constructor Summary
OrderedSetType(String role, String propertyRef, boolean isEmbeddedInXML)
Method Summary
 Object instantiate(int anticipatedSize)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
Methods inherited from class org.hibernate.type.SetType
getReturnedClass, instantiate, wrap
Methods inherited from class org.hibernate.type.CollectionType
assemble, compare, contains, deepCopy, disassemble, fromXMLNode, getAssociatedEntityName, getAssociatedJoinable, getCollection, getColumnSpan, getElementsIterator, getElementsIterator, getElementType, getForeignKeyDirection, getHashCode, getKeyOfOwner, getLHSPropertyName, getName, getOnCondition, getRHSUniqueKeyPropertyName, getRole, hasHolder, hydrate, indexOf, initializeImmediately, instantiateResult, isAlwaysDirtyChecked, isArrayType, isAssociationType, isCollectionType, isDirty, isDirty, isEmbeddedInXML, isEqual, isModified, isMutable, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, renderLoggableString, replace, replaceElements, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toString, useLHSPrimaryKey
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace

Constructor Detail

OrderedSetType

public OrderedSetType(String role,
                      String propertyRef,
                      boolean isEmbeddedInXML)
Method Detail

instantiate

public Object instantiate(int anticipatedSize)
Description copied from class: CollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial capacity and perhaps load factor).

Overrides:
instantiate in class SetType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrimitiveType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class PrimitiveType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.PrimitiveType
All Implemented Interfaces:
LiteralType, Serializable, Type
Direct Known Subclasses:
BooleanType, ByteType, CharacterType, DoubleType, FloatType, IntegerType, LongType, ShortType
public abstract class PrimitiveType
extends ImmutableType
implements LiteralType

Superclass of primitive / primitive wrapper types.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
PrimitiveType()
Method Summary
abstract Serializable | getDefaultValue()
abstract Class | getPrimitiveClass()
String | toString(Object value)
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromStringValue, fromXMLNode, fromXMLString, get, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, set, setToXMLNode, sqlType, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.LiteralType
objectToSQLString
Methods inherited from interface org.hibernate.type.Type
getName, getReturnedClass

Constructor Detail

PrimitiveType

public PrimitiveType()
Method Detail

getPrimitiveClass

public abstract Class getPrimitiveClass()

toString

public String toString(Object value)
Specified by:
toString in class NullableType

getDefaultValue

public abstract Serializable getDefaultValue()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SerializableType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class SerializableType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.SerializableType
All Implemented Interfaces:
Serializable, Type
public class SerializableType
extends MutableType

serializable: A type that maps an SQL VARBINARY to a serializable Java object.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
SerializableType(Class serializableClass)
Method Summary
 Object assemble(Serializable cached, SessionImplementor session, Object owner)
Reconstruct the object from its cached "disassembled" state.
 Object deepCopyNotNull(Object value)
 Serializable disassemble(Object value, SessionImplementor session, Object owner)
Return a cacheable "disassembled" representation of the object.
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isEqual(Object x, Object y)
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 String toString(Object value)
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, compare, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SerializableType

public SerializableType(Class serializableClass)
Method Detail

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws HibernateException,
                SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
HibernateException
SQLException

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
HibernateException
SQLException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

isEqual

public boolean isEqual(Object x,
                       Object y)
                throws HibernateException
Overrides:
isEqual in class NullableType
Throws:
HibernateException

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

toString

public String toString(Object value)
                throws HibernateException
Specified by:
toString in class NullableType
Throws:
HibernateException

fromStringValue

public Object fromStringValue(String xml)
                       throws HibernateException
Specified by:
fromStringValue in class NullableType
Throws:
HibernateException

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name

deepCopyNotNull

public Object deepCopyNotNull(Object value)
                       throws HibernateException
Specified by:
deepCopyNotNull in class MutableType
Throws:
HibernateException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

assemble

public Object assemble(Serializable cached,
                       SessionImplementor session,
                       Object owner)
                throws HibernateException
Description copied from interface: Type
Reconstruct the object from its cached "disassembled" state.

Specified by:
assemble in interface Type
Overrides:
assemble in class AbstractType
Throws:
HibernateException

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Description copied from interface: Type
Return a cacheable "disassembled" representation of the object.

Specified by:
disassemble in interface Type
Overrides:
disassemble in class AbstractType
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SetType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class SetType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CollectionType
            extended by org.hibernate.type.SetType
All Implemented Interfaces:
AssociationType, Serializable, Type
Direct Known Subclasses:
OrderedSetType, SortedSetType
public class SetType
extends CollectionType

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.CollectionType
UNFETCHED_COLLECTION
Constructor Summary
SetType(String role, String propertyRef, boolean isEmbeddedInXML)
Method Summary
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Object instantiate(int anticipatedSize)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
 PersistentCollection instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
Instantiate an uninitialized collection wrapper or holder.
 PersistentCollection wrap(SessionImplementor session, Object collection)
Wrap the naked collection instance in a wrapper, or instantiate a holder.
Methods inherited from class org.hibernate.type.CollectionType
assemble, compare, contains, deepCopy, disassemble, fromXMLNode, getAssociatedEntityName, getAssociatedJoinable, getCollection, getColumnSpan, getElementsIterator, getElementsIterator, getElementType, getForeignKeyDirection, getHashCode, getKeyOfOwner, getLHSPropertyName, getName, getOnCondition, getRHSUniqueKeyPropertyName, getRole, hasHolder, hydrate, indexOf, initializeImmediately, instantiateResult, isAlwaysDirtyChecked, isArrayType, isAssociationType, isCollectionType, isDirty, isDirty, isEmbeddedInXML, isEqual, isModified, isMutable, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, renderLoggableString, replace, replaceElements, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toString, useLHSPrimaryKey
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace

Constructor Detail

SetType

public SetType(String role,
               String propertyRef,
               boolean isEmbeddedInXML)
Method Detail

instantiate

public PersistentCollection instantiate(SessionImplementor session,
                                        CollectionPersister persister,
                                        Serializable key)
Description copied from class: CollectionType
Instantiate an uninitialized collection wrapper or holder. Callers MUST add the holder to the persistence context!

Specified by:
instantiate in class CollectionType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

wrap

public PersistentCollection wrap(SessionImplementor session,
                                 Object collection)
Description copied from class: CollectionType
Wrap the naked collection instance in a wrapper, or instantiate a holder. Callers MUST add the holder to the persistence context!

Specified by:
wrap in class CollectionType

instantiate

public Object instantiate(int anticipatedSize)
Description copied from class: CollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial capacity and perhaps load factor).

Specified by:
instantiate in class CollectionType
Parameters:
anticipatedSize - The anticipated size of the instaniated collection after we are done populating it.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShortType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class ShortType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.PrimitiveType
                    extended by org.hibernate.type.ShortType
All Implemented Interfaces:
DiscriminatorType, IdentifierType, LiteralType, Serializable, Type, VersionType
public class ShortType
extends PrimitiveType
implements DiscriminatorType, VersionType

short: A type that maps an SQL SMALLINT to a Java Short.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
ShortType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 Comparator getComparator()
Get a comparator for version values.
 Serializable getDefaultValue()
 String getName()
Returns the abbreviated name of the type.
 Class getPrimitiveClass()
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Object next(Object current, SessionImplementor session)
Increment the version.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 Object seed(SessionImplementor session)
Generate an initial version.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 Object stringToObject(String xml)
Convert the value from the mapping file to a Java object.
Methods inherited from class org.hibernate.type.PrimitiveType
toString
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString
Methods inherited from interface org.hibernate.type.VersionType
isEqual

Constructor Detail

ShortType

public ShortType()
Method Detail

getDefaultValue

public Serializable getDefaultValue()
Specified by:
getDefaultValue in class PrimitiveType

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getPrimitiveClass

public Class getPrimitiveClass()
Specified by:
getPrimitiveClass in class PrimitiveType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

stringToObject

public Object stringToObject(String xml)
                      throws Exception
Description copied from interface: IdentifierType
Convert the value from the mapping file to a Java object.

Specified by:
stringToObject in interface IdentifierType
Parameters:
xml - the value of discriminator-value or unsaved-value attribute
Returns:
Object
Throws:
Exception

next

public Object next(Object current,
                   SessionImplementor session)
Description copied from interface: VersionType
Increment the version.

Specified by:
next in interface VersionType
Parameters:
session - The session from which this request originates.
current - the current version
Returns:
an instance of the type

seed

public Object seed(SessionImplementor session)
Description copied from interface: VersionType
Generate an initial version.

Specified by:
seed in interface VersionType
Parameters:
session - The session from which this request originates.
Returns:
an instance of the type

getComparator

public Comparator getComparator()
Description copied from interface: VersionType
Get a comparator for version values.

Specified by:
getComparator in interface VersionType
Returns:
The comparator to use to compare different version values.

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SortedMapType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class SortedMapType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CollectionType
            extended by org.hibernate.type.MapType
                extended by org.hibernate.type.SortedMapType
All Implemented Interfaces:
AssociationType, Serializable, Type
public class SortedMapType
extends MapType

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.CollectionType
UNFETCHED_COLLECTION
Constructor Summary
SortedMapType(String role, String propertyRef, Comparator comparator, boolean isEmbeddedInXML)
Method Summary
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Object instantiate(int anticipatedSize)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
 PersistentCollection instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
Instantiate an uninitialized collection wrapper or holder.
 PersistentCollection wrap(SessionImplementor session, Object collection)
Wrap the naked collection instance in a wrapper, or instantiate a holder.
Methods inherited from class org.hibernate.type.MapType
getElementsIterator, indexOf, replaceElements
Methods inherited from class org.hibernate.type.CollectionType
assemble, compare, contains, deepCopy, disassemble, fromXMLNode, getAssociatedEntityName, getAssociatedJoinable, getCollection, getColumnSpan, getElementsIterator, getElementType, getForeignKeyDirection, getHashCode, getKeyOfOwner, getLHSPropertyName, getName, getOnCondition, getRHSUniqueKeyPropertyName, getRole, hasHolder, hydrate, initializeImmediately, instantiateResult, isAlwaysDirtyChecked, isArrayType, isAssociationType, isCollectionType, isDirty, isDirty, isEmbeddedInXML, isEqual, isModified, isMutable, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, renderLoggableString, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toString, useLHSPrimaryKey
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace

Constructor Detail

SortedMapType

public SortedMapType(String role,
                     String propertyRef,
                     Comparator comparator,
                     boolean isEmbeddedInXML)
Method Detail

instantiate

public PersistentCollection instantiate(SessionImplementor session,
                                        CollectionPersister persister,
                                        Serializable key)
Description copied from class: CollectionType
Instantiate an uninitialized collection wrapper or holder. Callers MUST add the holder to the persistence context!

Overrides:
instantiate in class MapType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Overrides:
getReturnedClass in class MapType

instantiate

public Object instantiate(int anticipatedSize)
Description copied from class: CollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial capacity and perhaps load factor).

Overrides:
instantiate in class MapType

wrap

public PersistentCollection wrap(SessionImplementor session,
                                 Object collection)
Description copied from class: CollectionType
Wrap the naked collection instance in a wrapper, or instantiate a holder. Callers MUST add the holder to the persistence context!

Overrides:
wrap in class MapType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SortedSetType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class SortedSetType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.CollectionType
            extended by org.hibernate.type.SetType
                extended by org.hibernate.type.SortedSetType
All Implemented Interfaces:
AssociationType, Serializable, Type
public class SortedSetType
extends SetType

See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.CollectionType
UNFETCHED_COLLECTION
Constructor Summary
SortedSetType(String role, String propertyRef, Comparator comparator, boolean isEmbeddedInXML)
Method Summary
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 Object instantiate(int anticipatedSize)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
 PersistentCollection instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
Instantiate an uninitialized collection wrapper or holder.
 PersistentCollection wrap(SessionImplementor session, Object collection)
Wrap the naked collection instance in a wrapper, or instantiate a holder.
Methods inherited from class org.hibernate.type.CollectionType
assemble, compare, contains, deepCopy, disassemble, fromXMLNode, getAssociatedEntityName, getAssociatedJoinable, getCollection, getColumnSpan, getElementsIterator, getElementsIterator, getElementType, getForeignKeyDirection, getHashCode, getKeyOfOwner, getLHSPropertyName, getName, getOnCondition, getRHSUniqueKeyPropertyName, getRole, hasHolder, hydrate, indexOf, initializeImmediately, instantiateResult, isAlwaysDirtyChecked, isArrayType, isAssociationType, isCollectionType, isDirty, isDirty, isEmbeddedInXML, isEqual, isModified, isMutable, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, renderLoggableString, replace, replaceElements, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toString, useLHSPrimaryKey
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace, replaceNode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, getSemiResolvedType, isAnyType, isComponentType, isEntityType, isEqual, isSame, replace

Constructor Detail

SortedSetType

public SortedSetType(String role,
                     String propertyRef,
                     Comparator comparator,
                     boolean isEmbeddedInXML)
Method Detail

instantiate

public PersistentCollection instantiate(SessionImplementor session,
                                        CollectionPersister persister,
                                        Serializable key)
Description copied from class: CollectionType
Instantiate an uninitialized collection wrapper or holder. Callers MUST add the holder to the persistence context!

Overrides:
instantiate in class SetType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Overrides:
getReturnedClass in class SetType

instantiate

public Object instantiate(int anticipatedSize)
Description copied from class: CollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial capacity and perhaps load factor).

Overrides:
instantiate in class SetType

wrap

public PersistentCollection wrap(SessionImplementor session,
                                 Object collection)
Description copied from class: CollectionType
Wrap the naked collection instance in a wrapper, or instantiate a holder. Callers MUST add the holder to the persistence context!

Overrides:
wrap in class SetType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SpecialOneToOneType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class SpecialOneToOneType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.EntityType
            extended by org.hibernate.type.OneToOneType
                extended by org.hibernate.type.SpecialOneToOneType
All Implemented Interfaces:
AssociationType, Serializable, Type
public class SpecialOneToOneType
extends OneToOneType

A one-to-one association that maps to specific formula(s) instead of the primary key column of the owning entity.

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.type.EntityType
isEmbeddedInXML, uniqueKeyPropertyName
Constructor Summary
SpecialOneToOneType(String referencedEntityName, ForeignKeyDirection foreignKeyType, String uniqueKeyPropertyName, boolean lazy, boolean unwrapProxy, String entityName, String propertyName)
Method Summary
Object | assemble(Serializable oid, SessionImplementor session, Object owner) Reconstruct the object from its cached "disassembled" state.
Serializable | disassemble(Object value, SessionImplementor session, Object owner) Return a cacheable "disassembled" representation of the object.
int | getColumnSpan(Mapping mapping) How many columns are used to persist this type.
Object | hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner) Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset.
int[] | sqlTypes(Mapping mapping) Return the SQL type codes for the columns mapped by this type.
boolean | useLHSPrimaryKey() Is the primary key of the owning entity table to be used in the join?
Methods inherited from class org.hibernate.type.OneToOneType
getForeignKeyDirection, getPropertyName, isAlwaysDirtyChecked, isDirty, isDirty, isModified, isNull, isNullable, isOneToOne, nullSafeSet, nullSafeSet, toColumnNullness
Methods inherited from class org.hibernate.type.EntityType
compare, deepCopy, fromXMLNode, getAssociatedEntityName, getAssociatedEntityName, getAssociatedJoinable, getHashCode, getIdentifier, getIdentifierOrUniqueKeyPropertyName, getIdentifierOrUniqueKeyType, getLHSPropertyName, getName, getOnCondition, getReturnedClass, getRHSUniqueKeyPropertyName, getSemiResolvedType, isAssociationType, isEmbeddedInXML, isEntityType, isEqual, isMutable, isNotEmbedded, isReferenceToPrimaryKey, isSame, isXMLElement, loadByUniqueKey, nullSafeGet, nullSafeGet, replace, resolve, resolveIdentifier, setToXMLNode, toLoggableString, toString
Methods inherited from class org.hibernate.type.AbstractType
beforeAssemble, getHashCode, isAnyType, isCollectionType, isComponentType, isEqual, replace, replaceNode, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
beforeAssemble, getHashCode, isAnyType, isCollectionType, isComponentType, isEqual, replace, semiResolve

Constructor Detail

SpecialOneToOneType

public SpecialOneToOneType(String referencedEntityName,
                           ForeignKeyDirection foreignKeyType,
                           String uniqueKeyPropertyName,
                           boolean lazy,
                           boolean unwrapProxy,
                           String entityName,
                           String propertyName)
Method Detail

getColumnSpan

public int getColumnSpan(Mapping mapping)
                  throws MappingException
Description copied from interface: Type
How many columns are used to persist this type.

Specified by:
getColumnSpan in interface Type
Overrides:
getColumnSpan in class OneToOneType
Throws:
MappingException

sqlTypes

public int[] sqlTypes(Mapping mapping)
               throws MappingException
Description copied from interface: Type
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Specified by:
sqlTypes in interface Type
Overrides:
sqlTypes in class OneToOneType
Throws:
MappingException

useLHSPrimaryKey

public boolean useLHSPrimaryKey()
Description copied from interface: AssociationType
Is the primary key of the owning entity table to be used in the join?

Specified by:
useLHSPrimaryKey in interface AssociationType
Overrides:
useLHSPrimaryKey in class OneToOneType

hydrate

public Object hydrate(ResultSet rs,
                      String[] names,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException,
                      SQLException
Description copied from interface: Type
Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset. This is useful for 2-phase property initialization - the second phase is a call to resolveIdentifier().

Specified by:
hydrate in interface Type
Overrides:
hydrate in class OneToOneType
Throws:
HibernateException
SQLException

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Description copied from interface: Type
Return a cacheable "disassembled" representation of the object.

Specified by:
disassemble in interface Type
Overrides:
disassemble in class OneToOneType
Throws:
HibernateException

assemble

public Object assemble(Serializable oid,
                       SessionImplementor session,
                       Object owner)
                throws HibernateException
Description copied from interface: Type
Reconstruct the object from its cached "disassembled" state.

Specified by:
assemble in interface Type
Overrides:
assemble in class OneToOneType
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class StringType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.StringType
All Implemented Interfaces:
DiscriminatorType, IdentifierType, LiteralType, Serializable, Type
public class StringType
extends ImmutableType
implements DiscriminatorType

string: A type that maps an SQL VARCHAR to a Java String.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
StringType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 Object stringToObject(String xml)
Convert the value from the mapping file to a Java object.
 String toString(Object value)
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Constructor Detail

StringType

public StringType()
Method Detail

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

stringToObject

public Object stringToObject(String xml)
                      throws Exception
Description copied from interface: IdentifierType
Convert the value from the mapping file to a Java object.

Specified by:
stringToObject in interface IdentifierType
Parameters:
xml - the value of discriminator-value or unsaved-value attribute
Returns:
Object
Throws:
Exception

toString

public String toString(Object value)
Specified by:
toString in class NullableType

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class TextType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.TextType
All Implemented Interfaces:
Serializable, Type
public class TextType
extends ImmutableType

text: A type that maps an SQL CLOB to a Java String.

Author:
Gavin King, Bertrand Renuart
See Also:
Serialized Form

Constructor Summary
TextType()
Method Summary
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 String toString(Object val)
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextType

public TextType()
Method Detail

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws HibernateException,
                SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
HibernateException
SQLException

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
HibernateException
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Returns:
String the Hibernate type name

toString

public String toString(Object val)
Specified by:
toString in class NullableType

fromStringValue

public Object fromStringValue(String xml)
Specified by:
fromStringValue in class NullableType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TimestampType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class TimestampType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.TimestampType
All Implemented Interfaces:
LiteralType, Serializable, Type, VersionType
Direct Known Subclasses:
DbTimestampType
public class TimestampType
extends MutableType
implements VersionType, LiteralType

timestamp: A type that maps an SQL TIMESTAMP to a Java java.util.Date or java.sql.Timestamp.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
TimestampType()
Method Summary
 Object deepCopyNotNull(Object value)
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 Comparator getComparator()
Get a comparator for version values.
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isEqual(Object x, Object y)
Are the two version values considered equal?
 Object next(Object current, SessionImplementor session)
Increment the version.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 Object seed(SessionImplementor session)
Generate an initial version.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 String toString(Object val)
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Constructor Detail

TimestampType

public TimestampType()
Method Detail

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

toString

public String toString(Object val)
Specified by:
toString in class NullableType

deepCopyNotNull

public Object deepCopyNotNull(Object value)
Specified by:
deepCopyNotNull in class MutableType

isEqual

public boolean isEqual(Object x,
                       Object y)
Description copied from interface: VersionType
Are the two version values considered equal?

Specified by:
isEqual in interface VersionType
Overrides:
isEqual in class NullableType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

next

public Object next(Object current,
                   SessionImplementor session)
Description copied from interface: VersionType
Increment the version.

Specified by:
next in interface VersionType
Parameters:
session - The session from which this request originates.
current - the current version
Returns:
an instance of the type

seed

public Object seed(SessionImplementor session)
Description copied from interface: VersionType
Generate an initial version.

Specified by:
seed in interface VersionType
Parameters:
session - The session from which this request originates.
Returns:
an instance of the type

getComparator

public Comparator getComparator()
Description copied from interface: VersionType
Get a comparator for version values.

Specified by:
getComparator in interface VersionType
Returns:
The comparator to use to compare different version values.

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

fromStringValue

public Object fromStringValue(String xml)
                       throws HibernateException
Specified by:
fromStringValue in class NullableType
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TimeType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class TimeType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.TimeType
All Implemented Interfaces:
LiteralType, Serializable, Type
public class TimeType
extends MutableType
implements LiteralType

time: A type that maps an SQL TIME to a Java java.util.Date or java.sql.Time.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
TimeType()
Method Summary
 Object deepCopyNotNull(Object value)
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 int getHashCode(Object x, EntityMode entityMode)
Get a hashcode, consistent with persistence "equality"
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 boolean isEqual(Object x, Object y)
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 String toString(Object val)
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TimeType

public TimeType()
Method Detail

get

public Object get(ResultSet rs,
                  String name)
           throws SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
SQLException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

toString

public String toString(Object val)
Specified by:
toString in class NullableType

isEqual

public boolean isEqual(Object x,
                       Object y)
Overrides:
isEqual in class NullableType

getHashCode

public int getHashCode(Object x,
                       EntityMode entityMode)
Description copied from interface: Type
Get a hashcode, consistent with persistence "equality"

Specified by:
getHashCode in interface Type
Overrides:
getHashCode in class AbstractType

deepCopyNotNull

public Object deepCopyNotNull(Object value)
Specified by:
deepCopyNotNull in class MutableType

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception

fromStringValue

public Object fromStringValue(String xml)
                       throws HibernateException
Specified by:
fromStringValue in class NullableType
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TimeZoneType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class TimeZoneType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.TimeZoneType
All Implemented Interfaces:
LiteralType, Serializable, Type
public class TimeZoneType
extends ImmutableType
implements LiteralType

timezone: A type that maps an SQL VARCHAR to a java.util.TimeZone

Author:
Gavin King
See Also:
TimeZone, Serialized Form

Constructor Summary
TimeZoneType()
Method Summary
 int compare(Object x, Object y, EntityMode entityMode)
compare two instances of the type
 Object fromStringValue(String xml)
 Object get(ResultSet rs, String name)
Get a column value from a result set, without worrying about the possibility of null values
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
 String objectToSQLString(Object value, Dialect dialect)
String representation of the value, suitable for embedding in an SQL statement.
 void set(PreparedStatement st, Object value, int index)
Get a parameter value without worrying about the possibility of null values
 int sqlType()
 String toString(Object value)
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TimeZoneType

public TimeZoneType()
Method Detail

get

public Object get(ResultSet rs,
                  String name)
           throws HibernateException,
                  SQLException
Description copied from class: NullableType
Get a column value from a result set, without worrying about the possibility of null values

Specified by:
get in class NullableType
Throws:
HibernateException
SQLException

set

public void set(PreparedStatement st,
                Object value,
                int index)
         throws HibernateException,
                SQLException
Description copied from class: NullableType
Get a parameter value without worrying about the possibility of null values

Specified by:
set in class NullableType
Throws:
HibernateException
SQLException

sqlType

public int sqlType()
Specified by:
sqlType in class NullableType

toString

public String toString(Object value)
                throws HibernateException
Specified by:
toString in class NullableType
Throws:
HibernateException

compare

public int compare(Object x,
                   Object y,
                   EntityMode entityMode)
Description copied from interface: Type
compare two instances of the type

Specified by:
compare in interface Type
Overrides:
compare in class AbstractType

fromStringValue

public Object fromStringValue(String xml)
                       throws HibernateException
Specified by:
fromStringValue in class NullableType
Throws:
HibernateException

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Specified by:
getReturnedClass in interface Type
Returns:
Class

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Returns:
String the Hibernate type name

objectToSQLString

public String objectToSQLString(Object value,
                                Dialect dialect)
                         throws Exception
Description copied from interface: LiteralType
String representation of the value, suitable for embedding in an SQL statement.

Specified by:
objectToSQLString in interface LiteralType
Parameters:
value -
dialect -
Returns:
String the value, as it appears in a SQL query
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TrueFalseType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class TrueFalseType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.PrimitiveType
                    extended by org.hibernate.type.BooleanType
                        extended by org.hibernate.type.CharBooleanType
                            extended by org.hibernate.type.TrueFalseType
All Implemented Interfaces:
DiscriminatorType, IdentifierType, LiteralType, Serializable, Type
public class TrueFalseType
extends CharBooleanType

true_false: A type that maps an SQL CHAR(1) to a Java Boolean.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
TrueFalseType()
Method Summary
protected String | getFalseString()
String | getName() Returns the abbreviated name of the type.
protected String | getTrueString()
Methods inherited from class org.hibernate.type.CharBooleanType
get, objectToSQLString, set, sqlType, stringToObject
Methods inherited from class org.hibernate.type.BooleanType
fromStringValue, getDefaultValue, getPrimitiveClass, getReturnedClass
Methods inherited from class org.hibernate.type.PrimitiveType
toString
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Constructor Detail

TrueFalseType

public TrueFalseType()
Method Detail

getTrueString

protected final String getTrueString()
Specified by:
getTrueString in class CharBooleanType

getFalseString

protected final String getFalseString()
Specified by:
getFalseString in class CharBooleanType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Overrides:
getName in class BooleanType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TypeFactory (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class TypeFactory

java.lang.Object
    extended by org.hibernate.type.TypeFactory
public final class TypeFactory
extends Object

Used internally to obtain instances of Type. Applications should use static methods and constants on org.hibernate.Hibernate.

Author:
Gavin King
See Also:
Hibernate

Method Summary
static CollectionType | array(String role, String propertyRef, boolean embedded, Class elementClass)
static Object[] | assemble(Serializable[] row, Type[] types, SessionImplementor session, Object owner)
static CollectionType | bag(String role, String propertyRef, boolean embedded)
static Type | basic(String name) Given the name of a Hibernate basic type, return an instance of org.hibernate.type.Type.
static void | beforeAssemble(Serializable[] row, Type[] types, SessionImplementor session) Determine if any of the given field values are modified, returning an array containing indexes of the dirty fields or null if no fields are dirty.
static CollectionType | customCollection(String typeName, String role, String propertyRef, boolean embedded)
static void | deepCopy(Object[] values, Type[] types, boolean[] copy, Object[] target, SessionImplementor session) Deep copy values in the first array into the second
static Serializable[] | disassemble(Object[] row, Type[] types, boolean[] nonCacheable, SessionImplementor session, Object owner)
static int[] | findDirty(StandardProperty[] properties, Object[] x, Object[] y, boolean[][] includeColumns, boolean anyUninitializedProperties, SessionImplementor session) Determine if any of the given field values are dirty, returning an array containing indexes of the dirty fields or null if no fields are dirty.
static int[] | findModified(StandardProperty[] properties, Object[] x, Object[] y, boolean[][] includeColumns, boolean anyUninitializedProperties, SessionImplementor session) Determine if any of the given field values are modified, returning an array containing indexes of the dirty fields or null if no fields are dirty.
static Type | heuristicType(String typeName) Uses heuristics to deduce a Hibernate type given a string naming the type or Java class.
static Type | heuristicType(String typeName, Properties parameters) Uses heuristics to deduce a Hibernate type given a string naming the type or Java class.
static CollectionType | idbag(String role, String propertyRef, boolean embedded)
static void | injectParameters(Object type, Properties parameters)
static CollectionType | list(String role, String propertyRef, boolean embedded)
static EntityType | manyToOne(String persistentClass) A many-to-one association type for the given class
static EntityType | manyToOne(String persistentClass, boolean lazy) A many-to-one association type for the given class
static EntityType | manyToOne(String persistentClass, String uniqueKeyPropertyName, boolean lazy, boolean unwrapProxy, boolean isEmbeddedInXML, boolean ignoreNotFound) A many-to-one association type for the given class
static CollectionType | map(String role, String propertyRef, boolean embedded)
static EntityType | oneToOne(String persistentClass, ForeignKeyDirection foreignKeyType, String uniqueKeyPropertyName, boolean lazy, boolean unwrapProxy, boolean isEmbeddedInXML, String entityName, String propertyName) A one-to-one association type for the given class
static CollectionType | orderedMap(String role, String propertyRef, boolean embedded)
static CollectionType | orderedSet(String role, String propertyRef, boolean embedded)
static Object[] | replace(Object[] original, Object[] target, Type[] types, SessionImplementor session, Object owner, Map copyCache)
static Object[] | replace(Object[] original, Object[] target, Type[] types, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)
static CollectionType | set(String role, String propertyRef, boolean embedded)
static CollectionType | sortedMap(String role, String propertyRef, boolean embedded, Comparator comparator)
static CollectionType | sortedSet(String role, String propertyRef, boolean embedded, Comparator comparator)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

oneToOne

public static EntityType oneToOne(String persistentClass,
                                  ForeignKeyDirection foreignKeyType,
                                  String uniqueKeyPropertyName,
                                  boolean lazy,
                                  boolean unwrapProxy,
                                  boolean isEmbeddedInXML,
                                  String entityName,
                                  String propertyName)
A one-to-one association type for the given class

manyToOne

public static EntityType manyToOne(String persistentClass)
A many-to-one association type for the given class

manyToOne

public static EntityType manyToOne(String persistentClass,
                                   boolean lazy)
A many-to-one association type for the given class

manyToOne

public static EntityType manyToOne(String persistentClass,
                                   String uniqueKeyPropertyName,
                                   boolean lazy,
                                   boolean unwrapProxy,
                                   boolean isEmbeddedInXML,
                                   boolean ignoreNotFound)
A many-to-one association type for the given class

basic

public static Type basic(String name)
Given the name of a Hibernate basic type, return an instance of org.hibernate.type.Type.

heuristicType

public static Type heuristicType(String typeName)
                          throws MappingException
Uses heuristics to deduce a Hibernate type given a string naming the type or Java class. Return an instance of org.hibernate.type.Type.

Throws:
MappingException

heuristicType

public static Type heuristicType(String typeName,
                                 Properties parameters)
                          throws MappingException
Uses heuristics to deduce a Hibernate type given a string naming the type or Java class. Return an instance of org.hibernate.type.Type.

Throws:
MappingException

customCollection

public static CollectionType customCollection(String typeName,
                                              String role,
                                              String propertyRef,
                                              boolean embedded)

array

public static CollectionType array(String role,
                                   String propertyRef,
                                   boolean embedded,
                                   Class elementClass)

list

public static CollectionType list(String role,
                                  String propertyRef,
                                  boolean embedded)

bag

public static CollectionType bag(String role,
                                 String propertyRef,
                                 boolean embedded)

idbag

public static CollectionType idbag(String role,
                                   String propertyRef,
                                   boolean embedded)

map

public static CollectionType map(String role,
                                 String propertyRef,
                                 boolean embedded)

orderedMap

public static CollectionType orderedMap(String role,
                                        String propertyRef,
                                        boolean embedded)

set

public static CollectionType set(String role,
                                 String propertyRef,
                                 boolean embedded)

orderedSet

public static CollectionType orderedSet(String role,
                                        String propertyRef,
                                        boolean embedded)

sortedMap

public static CollectionType sortedMap(String role,
                                       String propertyRef,
                                       boolean embedded,
                                       Comparator comparator)

sortedSet

public static CollectionType sortedSet(String role,
                                       String propertyRef,
                                       boolean embedded,
                                       Comparator comparator)

deepCopy

public static void deepCopy(Object[] values,
                            Type[] types,
                            boolean[] copy,
                            Object[] target,
                            SessionImplementor session)
                     throws HibernateException
Deep copy values in the first array into the second

Throws:
HibernateException

beforeAssemble

public static void beforeAssemble(Serializable[] row,
                                  Type[] types,
                                  SessionImplementor session)
                           throws HibernateException
Determine if any of the given field values are modified, returning an array containing indexes of the dirty fields or null if no fields are dirty.

Throws:
HibernateException

assemble

public static Object[] assemble(Serializable[] row,
                                Type[] types,
                                SessionImplementor session,
                                Object owner)
                         throws HibernateException
Throws:
HibernateException

disassemble

public static Serializable[] disassemble(Object[] row,
                                         Type[] types,
                                         boolean[] nonCacheable,
                                         SessionImplementor session,
                                         Object owner)
                                  throws HibernateException
Throws:
HibernateException

replace

public static Object[] replace(Object[] original,
                               Object[] target,
                               Type[] types,
                               SessionImplementor session,
                               Object owner,
                               Map copyCache)
                        throws HibernateException
Throws:
HibernateException

replace

public static Object[] replace(Object[] original,
                               Object[] target,
                               Type[] types,
                               SessionImplementor session,
                               Object owner,
                               Map copyCache,
                               ForeignKeyDirection foreignKeyDirection)
                        throws HibernateException
Throws:
HibernateException

findDirty

public static int[] findDirty(StandardProperty[] properties,
                              Object[] x,
                              Object[] y,
                              boolean[][] includeColumns,
                              boolean anyUninitializedProperties,
                              SessionImplementor session)
                       throws HibernateException
Determine if any of the given field values are dirty, returning an array containing indexes of the dirty fields or null if no fields are dirty.

Parameters:
x - the current state of the entity
y - the snapshot state from the time the object was loaded
Throws:
HibernateException

findModified

public static int[] findModified(StandardProperty[] properties,
                                 Object[] x,
                                 Object[] y,
                                 boolean[][] includeColumns,
                                 boolean anyUninitializedProperties,
                                 SessionImplementor session)
                          throws HibernateException
Determine if any of the given field values are modified, returning an array containing indexes of the dirty fields or null if no fields are dirty.

Parameters:
x - the current state of the entity
y - the snapshot state just retrieved from the database
Throws:
HibernateException

injectParameters

public static void injectParameters(Object type,
                                    Properties parameters)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WrapperBinaryType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class WrapperBinaryType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.MutableType
                extended by org.hibernate.type.AbstractBynaryType
                    extended by org.hibernate.type.WrapperBinaryType
All Implemented Interfaces:
Comparator, Serializable, Type, VersionType
public class WrapperBinaryType
extends AbstractBynaryType

Author:
Emmanuel Bernard
See Also:
Serialized Form

Constructor Summary
WrapperBinaryType()
Method Summary
 String getName()
Returns the abbreviated name of the type.
 Class getReturnedClass()
The class returned by nullSafeGet() methods.
protected  Object toExternalFormat(byte[] bytes)
Convert the byte[] into the expected object type
protected  byte[] toInternalFormat(Object val)
Convert the object into the internal byte[] representation
Methods inherited from class org.hibernate.type.AbstractBynaryType
compare, compare, deepCopyNotNull, fromStringValue, get, getComparator, getHashCode, isEqual, next, seed, set, sqlType, toString
Methods inherited from class org.hibernate.type.MutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, disassemble, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString
Methods inherited from interface java.util.Comparator
equals

Constructor Detail

WrapperBinaryType

public WrapperBinaryType()
Method Detail

toExternalFormat

protected Object toExternalFormat(byte[] bytes)
Description copied from class: AbstractBynaryType
Convert the byte[] into the expected object type

Specified by:
toExternalFormat in class AbstractBynaryType

toInternalFormat

protected byte[] toInternalFormat(Object val)
Description copied from class: AbstractBynaryType
Convert the object into the internal byte[] representation

Specified by:
toInternalFormat in class AbstractBynaryType

getReturnedClass

public Class getReturnedClass()
Description copied from interface: Type
The class returned by nullSafeGet() methods. This is used to establish the class of an array of this type.

Returns:
Class

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Specified by:
getName in class AbstractBynaryType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


YesNoType (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class YesNoType

java.lang.Object
    extended by org.hibernate.type.AbstractType
        extended by org.hibernate.type.NullableType
            extended by org.hibernate.type.ImmutableType
                extended by org.hibernate.type.PrimitiveType
                    extended by org.hibernate.type.BooleanType
                        extended by org.hibernate.type.CharBooleanType
                            extended by org.hibernate.type.YesNoType
All Implemented Interfaces:
DiscriminatorType, IdentifierType, LiteralType, Serializable, Type
public class YesNoType
extends CharBooleanType

yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.

Author:
Gavin King
See Also:
Serialized Form

Constructor Summary
YesNoType()
Method Summary
protected String | getFalseString()
String | getName() Returns the abbreviated name of the type.
protected String | getTrueString()
Methods inherited from class org.hibernate.type.CharBooleanType
get, objectToSQLString, set, sqlType, stringToObject
Methods inherited from class org.hibernate.type.BooleanType
fromStringValue, getDefaultValue, getPrimitiveClass, getReturnedClass
Methods inherited from class org.hibernate.type.PrimitiveType
toString
Methods inherited from class org.hibernate.type.ImmutableType
deepCopy, isMutable, replace
Methods inherited from class org.hibernate.type.NullableType
fromXMLNode, fromXMLString, getColumnSpan, isDirty, isEqual, isEqual, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, nullSafeSet, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString, toXMLString
Methods inherited from class org.hibernate.type.AbstractType
assemble, beforeAssemble, compare, disassemble, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isEntityType, isEqual, isModified, isSame, isXMLElement, replace, replaceNode, resolve, semiResolve
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.hibernate.type.Type
assemble, beforeAssemble, compare, deepCopy, disassemble, fromXMLNode, getColumnSpan, getHashCode, getHashCode, getSemiResolvedType, hydrate, isAnyType, isAssociationType, isCollectionType, isComponentType, isDirty, isDirty, isEntityType, isEqual, isEqual, isModified, isMutable, isSame, isXMLElement, nullSafeGet, nullSafeGet, nullSafeSet, nullSafeSet, replace, replace, resolve, semiResolve, setToXMLNode, sqlTypes, toColumnNullness, toLoggableString

Constructor Detail

YesNoType

public YesNoType()
Method Detail

getTrueString

protected final String getTrueString()
Specified by:
getTrueString in class CharBooleanType

getFalseString

protected final String getFalseString()
Specified by:
getFalseString in class CharBooleanType

getName

public String getName()
Description copied from interface: Type
Returns the abbreviated name of the type.

Specified by:
getName in interface Type
Overrides:
getName in class BooleanType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


SerializationException (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.type
Class SerializationException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.hibernate.exception.NestableRuntimeException
                    extended by org.hibernate.HibernateException
                        extended by org.hibernate.type.SerializationException
All Implemented Interfaces:
Nestable, Serializable
public class SerializationException
extends HibernateException

Thrown when a property cannot be serializaed/deserialized

Author:
Gavin King
See Also:
Serialized Form

Field Summary
Fields inherited from class org.hibernate.exception.NestableRuntimeException
delegate
Constructor Summary
SerializationException(String message, Exception root)
Methods inherited from class org.hibernate.exception.NestableRuntimeException
getCause, getMessage, getMessage, getMessages, getThrowable, getThrowableCount, getThrowables, indexOfThrowable, indexOfThrowable, printPartialStackTrace, printStackTrace, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SerializationException

public SerializationException(String message,
                              Exception root)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.usertype (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.usertype

Interfaces for user-defined custom types.

See:
Description

Interface Summary
CompositeUserType | A UserType that may be dereferenced in a query.
EnhancedUserType | A custom type that may function as an identifier or discriminator type, or may be marshalled to and from an XML document
LoggableUserType | Marker interface for user types which want to perform custom logging of their corresponding values
ParameterizedType | Support for parameterizable types.
UserCollectionType | A custom type for mapping user-written classes that implement PersistentCollection
UserType | This interface should be implemented by user-defined "types".
UserVersionType | A user type that may be used for a version property

Package org.hibernate.usertype Description

Interfaces for user-defined custom types.


org.hibernate.usertype Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.usertype

Package Hierarchies:
All Packages

Interface Hierarchy

  • interface java.util.Comparator
    • interface org.hibernate.usertype.UserVersionType (also extends org.hibernate.usertype.UserType)
  • interface org.hibernate.usertype.CompositeUserType
  • interface org.hibernate.usertype.LoggableUserType
  • interface org.hibernate.usertype.ParameterizedType
  • interface org.hibernate.usertype.UserCollectionType
  • interface org.hibernate.usertype.UserType
    • interface org.hibernate.usertype.EnhancedUserType
    • interface org.hibernate.usertype.UserVersionType (also extends java.util.Comparator)


Uses of Package org.hibernate.usertype (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.usertype

Packages that use org.hibernate.usertype
org.hibernate.usertype Interfaces for user-defined custom types.

Classes in org.hibernate.usertype used by org.hibernate.usertype
UserType
This interface should be implemented by user-defined "types".

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CompositeUserType (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.usertype
Interface CompositeUserType

public interface CompositeUserType

A UserType that may be dereferenced in a query. This interface allows a custom type to define "properties". These need not necessarily correspond to physical JavaBeans style properties.

A CompositeUserType may be used in almost every way that a component may be used. It may even contain many-to-one associations.

Implementors must be immutable and must declare a public default constructor.

Unlike UserType, cacheability does not depend upon serializability. Instead, assemble() and disassemble provide conversion to/from a cacheable representation.

Author:
Gavin King
See Also:
for more simple cases, Type

Method Summary
 Object assemble(Serializable cached, SessionImplementor session, Object owner)
Reconstruct an object from the cacheable representation.
 Object deepCopy(Object value)
Return a deep copy of the persistent state, stopping at entities and at collections.
 Serializable disassemble(Object value, SessionImplementor session)
Transform the object into its cacheable representation.
 boolean equals(Object x, Object y)
Compare two instances of the class mapped by this type for persistence "equality".
 String[] getPropertyNames()
Get the "property names" that may be used in a query.
 Type[] getPropertyTypes()
Get the corresponding "property types".
 Object getPropertyValue(Object component, int property)
Get the value of a property.
 int hashCode(Object x)
Get a hashcode for the instance, consistent with persistence "equality"
 boolean isMutable()
Check if objects of this type mutable.
 Object nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 void nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Write an instance of the mapped class to a prepared statement.
 Object replace(Object original, Object target, SessionImplementor session, Object owner)
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
 Class returnedClass()
The class returned by nullSafeGet().
 void setPropertyValue(Object component, int property, Object value)
Set the value of a property.

Method Detail

getPropertyNames

public String[] getPropertyNames()
Get the "property names" that may be used in a query.

Returns:
an array of "property names"

getPropertyTypes

public Type[] getPropertyTypes()
Get the corresponding "property types".

Returns:
an array of Hibernate types

getPropertyValue

public Object getPropertyValue(Object component,
                               int property)
                        throws HibernateException
Get the value of a property.

Parameters:
component - an instance of class mapped by this "type"
property -
Returns:
the property value
Throws:
HibernateException

setPropertyValue

public void setPropertyValue(Object component,
                             int property,
                             Object value)
                      throws HibernateException
Set the value of a property.

Parameters:
component - an instance of class mapped by this "type"
property -
value - the value to set
Throws:
HibernateException

returnedClass

public Class returnedClass()
The class returned by nullSafeGet().

Returns:
Class

equals

public boolean equals(Object x,
                      Object y)
               throws HibernateException
Compare two instances of the class mapped by this type for persistence "equality". Equality of the persistent state.

Parameters:
x -
y -
Returns:
boolean
Throws:
HibernateException

hashCode

public int hashCode(Object x)
             throws HibernateException
Get a hashcode for the instance, consistent with persistence "equality"

Throws:
HibernateException

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String[] names,
                          SessionImplementor session,
                          Object owner)
                   throws HibernateException,
                          SQLException
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Parameters:
rs - a JDBC result set
names - the column names
session -
owner - the containing entity
Returns:
Object
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index,
                        SessionImplementor session)
                 throws HibernateException,
                        SQLException
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st - a JDBC prepared statement
value - the object to write
index - statement parameter index
session -
Throws:
HibernateException
SQLException

deepCopy

public Object deepCopy(Object value)
                throws HibernateException
Return a deep copy of the persistent state, stopping at entities and at collections.

Parameters:
value - generally a collection element or entity field
Returns:
Object a copy
Throws:
HibernateException

isMutable

public boolean isMutable()
Check if objects of this type mutable.

Returns:
boolean

disassemble

public Serializable disassemble(Object value,
                                SessionImplementor session)
                         throws HibernateException
Transform the object into its cacheable representation. At the very least this method should perform a deep copy. That may not be enough for some implementations, however; for example, associations must be cached as identifier values. (optional operation)

Parameters:
value - the object to be cached
session -
Returns:
a cachable representation of the object
Throws:
HibernateException

assemble

public Object assemble(Serializable cached,
                       SessionImplementor session,
                       Object owner)
                throws HibernateException
Reconstruct an object from the cacheable representation. At the very least this method should perform a deep copy. (optional operation)

Parameters:
cached - the object to be cached
session -
owner - the owner of the cached object
Returns:
a reconstructed object from the cachable representation
Throws:
HibernateException

replace

public Object replace(Object original,
                      Object target,
                      SessionImplementor session,
                      Object owner)
               throws HibernateException
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. However, since composite user types often define component values, it might make sense to recursively replace component values in the target object.

Parameters:
original -
target -
session -
owner -
Returns:
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


EnhancedUserType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.usertype
Interface EnhancedUserType

All Superinterfaces:
UserType
public interface EnhancedUserType
extends UserType

A custom type that may function as an identifier or discriminator type, or may be marshalled to and from an XML document

Author:
Gavin King

Method Summary
Object | fromXMLString(String xmlValue) Parse a string representation of this value, as it appears in an XML document
String | objectToSQLString(Object value) Return an SQL literal representation of the value
String | toXMLString(Object value) Return a string representation of this value, as it should appear in an XML document
Methods inherited from interface org.hibernate.usertype.UserType
assemble, deepCopy, disassemble, equals, hashCode, isMutable, nullSafeGet, nullSafeSet, replace, returnedClass, sqlTypes

Method Detail

objectToSQLString

public String objectToSQLString(Object value)
Return an SQL literal representation of the value

toXMLString

public String toXMLString(Object value)
Return a string representation of this value, as it should appear in an XML document

fromXMLString

public Object fromXMLString(String xmlValue)
Parse a string representation of this value, as it appears in an XML document

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LoggableUserType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.usertype
Interface LoggableUserType

public interface LoggableUserType

Marker interface for user types which want to perform custom logging of their corresponding values

Author:
Steve Ebersole

Method Summary
 String toLoggableString(Object value, SessionFactoryImplementor factory)
Generate a loggable string representation of the collection (value).

Method Detail

toLoggableString

public String toLoggableString(Object value,
                               SessionFactoryImplementor factory)
Generate a loggable string representation of the collection (value).

Parameters:
value - The collection to be logged; guarenteed to be non-null and initialized.
factory - The factory.
Returns:
The loggable string representation.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterizedType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.usertype
Interface ParameterizedType

public interface ParameterizedType

Support for parameterizable types. A UserType or CustomUserType may be made parameterizable by implementing this interface. Parameters for a type may be set by using a nested type element for the property element in the mapping file, or by defining a typedef.

Author:
Michael Gloegl

Method Summary
 void setParameterValues(Properties parameters)
Gets called by Hibernate to pass the configured type parameters to the implementation.

Method Detail

setParameterValues

public void setParameterValues(Properties parameters)
Gets called by Hibernate to pass the configured type parameters to the implementation.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserCollectionType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.usertype
Interface UserCollectionType

public interface UserCollectionType

A custom type for mapping user-written classes that implement PersistentCollection

Author:
Gavin King
See Also:
PersistentCollection

Method Summary
boolean | contains(Object collection, Object entity) Optional operation.
Iterator | getElementsIterator(Object collection) Return an iterator over the elements of this collection - the passed collection instance may or may not be a wrapper
Object | indexOf(Object collection, Object entity) Optional operation.
Object | instantiate(int anticipatedSize) Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
PersistentCollection | instantiate(SessionImplementor session, CollectionPersister persister) Instantiate an uninitialized instance of the collection wrapper
Object | replaceElements(Object original, Object target, CollectionPersister persister, Object owner, Map copyCache, SessionImplementor session) Replace the elements of a collection with the elements of another collection
PersistentCollection | wrap(SessionImplementor session, Object collection) Wrap an instance of a collection

Method Detail

instantiate

public PersistentCollection instantiate(SessionImplementor session,
                                        CollectionPersister persister)
                                 throws HibernateException
Instantiate an uninitialized instance of the collection wrapper

Throws:
HibernateException

wrap

public PersistentCollection wrap(SessionImplementor session,
                                 Object collection)
Wrap an instance of a collection

getElementsIterator

public Iterator getElementsIterator(Object collection)
Return an iterator over the elements of this collection - the passed collection instance may or may not be a wrapper

contains

public boolean contains(Object collection,
                        Object entity)
Optional operation. Does the collection contain the entity instance?

indexOf

public Object indexOf(Object collection,
                      Object entity)
Optional operation. Return the index of the entity in the collection.

replaceElements

public Object replaceElements(Object original,
                              Object target,
                              CollectionPersister persister,
                              Object owner,
                              Map copyCache,
                              SessionImplementor session)
                       throws HibernateException
Replace the elements of a collection with the elements of another collection

Throws:
HibernateException

instantiate

public Object instantiate(int anticipatedSize)
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e. accounting for initial size and perhaps load factor).

Parameters:
anticipatedSize - The anticipated size of the instaniated collection after we are done populating it. Note, may be negative to indicate that we not yet know anything about the anticipated size (i.e., when initializing from a result set row by row).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserType (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.usertype
Interface UserType

All Known Subinterfaces:
EnhancedUserType, UserVersionType
public interface UserType

This interface should be implemented by user-defined "types". A "type" class is not the actual property type - it is a class that knows how to serialize instances of another class to and from JDBC.

This interface

  • abstracts user code from future changes to the Type interface,
  • simplifies the implementation of custom types and
  • hides certain "internal" interfaces from user code.

Implementors must be immutable and must declare a public default constructor.

The actual class mapped by a UserType may be just about anything.

CompositeUserType provides an extended version of this interface that is useful for more complex cases.

Alternatively, custom types could implement Type directly or extend one of the abstract classes in org.hibernate.type. This approach risks future incompatible changes to classes or interfaces in that package.

Author:
Gavin King
See Also:
for more complex cases, Type

Method Summary
 Object assemble(Serializable cached, Object owner)
Reconstruct an object from the cacheable representation.
 Object deepCopy(Object value)
Return a deep copy of the persistent state, stopping at entities and at collections.
 Serializable disassemble(Object value)
Transform the object into its cacheable representation.
 boolean equals(Object x, Object y)
Compare two instances of the class mapped by this type for persistence "equality".
 int hashCode(Object x)
Get a hashcode for the instance, consistent with persistence "equality"
 boolean isMutable()
Are objects of this type mutable?
 Object nullSafeGet(ResultSet rs, String[] names, Object owner)
Retrieve an instance of the mapped class from a JDBC resultset.
 void nullSafeSet(PreparedStatement st, Object value, int index)
Write an instance of the mapped class to a prepared statement.
 Object replace(Object original, Object target, Object owner)
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
 Class returnedClass()
The class returned by nullSafeGet().
 int[] sqlTypes()
Return the SQL type codes for the columns mapped by this type.

Method Detail

sqlTypes

public int[] sqlTypes()
Return the SQL type codes for the columns mapped by this type. The codes are defined on java.sql.Types.

Returns:
int[] the typecodes
See Also:
Types

returnedClass

public Class returnedClass()
The class returned by nullSafeGet().

Returns:
Class

equals

public boolean equals(Object x,
                      Object y)
               throws HibernateException
Compare two instances of the class mapped by this type for persistence "equality". Equality of the persistent state.

Parameters:
x -
y -
Returns:
boolean
Throws:
HibernateException

hashCode

public int hashCode(Object x)
             throws HibernateException
Get a hashcode for the instance, consistent with persistence "equality"

Throws:
HibernateException

nullSafeGet

public Object nullSafeGet(ResultSet rs,
                          String[] names,
                          Object owner)
                   throws HibernateException,
                          SQLException
Retrieve an instance of the mapped class from a JDBC resultset. Implementors should handle possibility of null values.

Parameters:
rs - a JDBC result set
names - the column names
owner - the containing entity
Returns:
Object
Throws:
HibernateException
SQLException

nullSafeSet

public void nullSafeSet(PreparedStatement st,
                        Object value,
                        int index)
                 throws HibernateException,
                        SQLException
Write an instance of the mapped class to a prepared statement. Implementors should handle possibility of null values. A multi-column type should be written to parameters starting from index.

Parameters:
st - a JDBC prepared statement
value - the object to write
index - statement parameter index
Throws:
HibernateException
SQLException

deepCopy

public Object deepCopy(Object value)
                throws HibernateException
Return a deep copy of the persistent state, stopping at entities and at collections. It is not necessary to copy immutable objects, or null values, in which case it is safe to simply return the argument.

Parameters:
value - the object to be cloned, which may be null
Returns:
Object a copy
Throws:
HibernateException

isMutable

public boolean isMutable()
Are objects of this type mutable?

Returns:
boolean

disassemble

public Serializable disassemble(Object value)
                         throws HibernateException
Transform the object into its cacheable representation. At the very least this method should perform a deep copy if the type is mutable. That may not be enough for some implementations, however; for example, associations must be cached as identifier values. (optional operation)

Parameters:
value - the object to be cached
Returns:
a cachable representation of the object
Throws:
HibernateException

assemble

public Object assemble(Serializable cached,
                       Object owner)
                throws HibernateException
Reconstruct an object from the cacheable representation. At the very least this method should perform a deep copy if the type is mutable. (optional operation)

Parameters:
cached - the object to be cached
owner - the owner of the cached object
Returns:
a reconstructed object from the cachable representation
Throws:
HibernateException

replace

public Object replace(Object original,
                      Object target,
                      Object owner)
               throws HibernateException
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging. For immutable objects, or null values, it is safe to simply return the first parameter. For mutable objects, it is safe to return a copy of the first parameter. For objects with component values, it might make sense to recursively replace component values.

Parameters:
original - the value from the detached entity being merged
target - the value in the managed entity
Returns:
the value to be merged
Throws:
HibernateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserVersionType (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.usertype
Interface UserVersionType

All Superinterfaces:
Comparator, UserType
public interface UserVersionType
extends UserType, Comparator

A user type that may be used for a version property

Author:
Gavin King

Method Summary
Object | next(Object current, SessionImplementor session) Increment the version.
Object | seed(SessionImplementor session) Generate an initial version.
Methods inherited from interface org.hibernate.usertype.UserType
assemble, deepCopy, disassemble, equals, hashCode, isMutable, nullSafeGet, nullSafeSet, replace, returnedClass, sqlTypes
Methods inherited from interface java.util.Comparator
compare, equals

Method Detail

seed

public Object seed(SessionImplementor session)
Generate an initial version.

Parameters:
session - The session from which this request originates. May be null; currently this only happens during startup when trying to determine the "unsaved value" of entities.
Returns:
an instance of the type

next

public Object next(Object current,
                   SessionImplementor session)
Increment the version.

Parameters:
session - The session from which this request originates.
current - the current version
Returns:
an instance of the type
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.hibernate.util (Hibernate API Documentation)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.hibernate.util

Utility classes.

See:
Description

Class Summary
ArrayHelper |
BytesHelper |
CalendarComparator |
Cloneable | An object that is shallow-coneable
CollectionHelper |
ComparableComparator | Delegates to Comparable
ConfigHelper | A simple class to centralize logic needed to locate config files on the system.
DTDEntityResolver | An EntityResolver implementation which attempts to resolve various systemId URLs to local classpath lookups Any systemId URL beginning with http://hibernate.sourceforge.net/ is searched for as a classpath resource in the classloader which loaded the Hibernate classes. Any systemId URL using classpath as the scheme (i.e.
EmptyIterator |
EqualsHelper |
ExternalSessionFactoryConfig | Defines support for various externally configurable SessionFactory(s), for example, JMX or the JCA adapter.
FastHashMap | A customized implementation of java.util.HashMap designed to operate in a multithreaded environment where the large majority of method calls are read-only, instead of structural changes.
FilterHelper | Implementation of FilterHelper.
GetGeneratedKeysHelper |
IdentityMap | A Map where keys are compared by object identity, rather than equals().
IdentityMap.IdentityKey |
IdentityMap.IdentityMapEntry |
IdentitySet | Set implementation that use == instead of equals() as its comparison mechanism that base its implementation of IdentityMap
JDBCExceptionReporter |
JoinedIterator | An JoinedIterator is an Iterator that wraps a number of Iterators.
JTAHelper |
LazyIterator |
LinkedHashCollectionHelper |
MarkerObject |
NamedGeneratedKeysHelper |
NamingHelper |
PropertiesHelper |
Range |
ReflectHelper |
SerializationHelper | Assists with the serialization process and performs additional functionality based on serialization.
SimpleMRUCache | Cache following a "Most Recently Used" (MRU) algorithm for maintaining a bounded in-memory size; the "Least Recently Used" (LRU) entry is the first available for removal from the cache.
SingletonIterator |
SoftLimitMRUCache | Cache following a "Most Recently Used" (MRY) algorithm for maintaining a bounded in-memory size; the "Least Recently Used" (LRU) entry is the first available for removal from the cache.
StringHelper |
XMLHelper | Small helper class that lazy loads DOM and SAX reader and keep them for fast use afterwards.
XMLHelper.ErrorLogger |

Package org.hibernate.util Description

Utility classes.

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


org.hibernate.util Class Hierarchy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.hibernate.util

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.hibernate.util.ArrayHelper
    • class org.hibernate.util.BytesHelper
    • class org.hibernate.util.CalendarComparator (implements java.util.Comparator)
    • class org.hibernate.util.Cloneable
    • class org.hibernate.util.CollectionHelper
    • class org.hibernate.util.ComparableComparator (implements java.util.Comparator)
    • class org.hibernate.util.ConfigHelper
    • class org.hibernate.util.DTDEntityResolver (implements org.xml.sax.EntityResolver, java.io.Serializable)
    • class org.hibernate.util.EmptyIterator (implements java.util.Iterator)
    • class org.hibernate.util.EqualsHelper
    • class org.hibernate.util.ExternalSessionFactoryConfig
    • class org.hibernate.util.FastHashMap (implements java.util.Map, java.io.Serializable)
    • class org.hibernate.util.FilterHelper
    • class org.hibernate.util.GetGeneratedKeysHelper
    • class org.hibernate.util.IdentityMap (implements java.util.Map)
    • class org.hibernate.util.IdentityMap.IdentityKey (implements java.io.Serializable)
    • class org.hibernate.util.IdentityMap.IdentityMapEntry (implements java.util.Map.Entry)
    • class org.hibernate.util.IdentitySet (implements java.util.Set)
    • class org.hibernate.util.JDBCExceptionReporter
    • class org.hibernate.util.JoinedIterator (implements java.util.Iterator)
    • class org.hibernate.util.JTAHelper
    • class org.hibernate.util.LazyIterator (implements java.util.Iterator)
    • class org.hibernate.util.LinkedHashCollectionHelper
    • class org.hibernate.util.MarkerObject
    • class org.hibernate.util.NamedGeneratedKeysHelper
    • class org.hibernate.util.NamingHelper
    • class org.hibernate.util.PropertiesHelper
    • class org.hibernate.util.Range
    • class org.hibernate.util.ReflectHelper
    • class org.hibernate.util.SerializationHelper
    • class org.hibernate.util.SimpleMRUCache (implements java.io.Serializable)
    • class org.hibernate.util.SingletonIterator (implements java.util.Iterator)
    • class org.hibernate.util.SoftLimitMRUCache (implements java.io.Serializable)
    • class org.hibernate.util.StringHelper
    • class org.hibernate.util.XMLHelper
    • class org.hibernate.util.XMLHelper.ErrorLogger (implements org.xml.sax.ErrorHandler)
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package org.hibernate.util (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.hibernate.util

Packages that use org.hibernate.util
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.

Classes in org.hibernate.util used by org.hibernate.cfg
XMLHelper
Small helper class that lazy loads DOM and SAX reader and keep them for fast use afterwards.

Classes in org.hibernate.util used by org.hibernate.event
Cloneable
An object that is shallow-coneable

Classes in org.hibernate.util used by org.hibernate.jmx
ExternalSessionFactoryConfig
Defines support for various externally configurable SessionFactory(s), for example, JMX or the JCA adapter.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ArrayHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class ArrayHelper

java.lang.Object
    extended by org.hibernate.util.ArrayHelper
public final class ArrayHelper
extends Object

Field Summary
static boolean[] | EMPTY_BOOLEAN_ARRAY
static Class[] | EMPTY_CLASS_ARRAY
static int[] | EMPTY_INT_ARRAY
static Object[] | EMPTY_OBJECT_ARRAY
static String[] | EMPTY_STRING_ARRAY
static Type[] | EMPTY_TYPE_ARRAY
static boolean[] | FALSE
static boolean[] | TRUE
Method Summary
static void | addAll(Collection collection, Object[] array)
static int | countTrue(boolean[] array)
static int[] | fillArray(int value, int length)
static LockMode[] | fillArray(LockMode lockMode, int length)
static String[] | fillArray(String value, int length)
static int[] | getBatchSizes(int maxBatchSize)
static int | hash(byte[] bytes) calculate the array hash (only the first level)
static int | hash(char[] array) calculate the array hash (only the first level)
static int | hash(Object[] array) calculate the array hash (only the first level)
static int | indexOf(Object[] array, Object object)
static boolean | isAllFalse(boolean[] array)
static boolean | isAllNegative(int[] array)
static boolean | isAllTrue(boolean[] array)
static boolean | isEquals(byte[] b1, byte[] b2) Compare 2 arrays only at the first level
static boolean | isEquals(char[] o1, char[] o2) Compare 2 arrays only at the first level
static boolean | isEquals(Object[] o1, Object[] o2) Compare 2 arrays only at the first level
static int[] | join(int[] x, int[] y)
static String[] | join(String[] x, String[] y)
static String[] | join(String[] x, String[] y, boolean[] use)
static Object[] | slice(Object[] objects, int begin, int length)
static String[] | slice(String[] strings, int begin, int length)
static int[][] | to2DIntArray(Collection coll)
static String[][] | to2DStringArray(Collection coll)
static boolean[] | toBooleanArray(Collection coll)
static int[] | toIntArray(Collection coll)
static List | toList(Iterator iter)
static List | toList(Object array)
static String | toString(Object[] array)
static String[] | toStringArray(Collection coll)
static String[] | toStringArray(Object[] objects)
static Type[] | toTypeArray(Collection coll)
static Object[] | typecast(Object[] array, Object[] to)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TRUE

public static final boolean[] TRUE

FALSE

public static final boolean[] FALSE

EMPTY_STRING_ARRAY

public static final String[] EMPTY_STRING_ARRAY

EMPTY_INT_ARRAY

public static final int[] EMPTY_INT_ARRAY

EMPTY_BOOLEAN_ARRAY

public static final boolean[] EMPTY_BOOLEAN_ARRAY

EMPTY_CLASS_ARRAY

public static final Class[] EMPTY_CLASS_ARRAY

EMPTY_OBJECT_ARRAY

public static final Object[] EMPTY_OBJECT_ARRAY

EMPTY_TYPE_ARRAY

public static final Type[] EMPTY_TYPE_ARRAY
Method Detail

indexOf

public static int indexOf(Object[] array,
                          Object object)

toStringArray

public static String[] toStringArray(Object[] objects)

fillArray

public static String[] fillArray(String value,
                                 int length)

fillArray

public static int[] fillArray(int value,
                              int length)

fillArray

public static LockMode[] fillArray(LockMode lockMode,
                                   int length)

toStringArray

public static String[] toStringArray(Collection coll)

to2DStringArray

public static String[][] to2DStringArray(Collection coll)

to2DIntArray

public static int[][] to2DIntArray(Collection coll)

toTypeArray

public static Type[] toTypeArray(Collection coll)

toIntArray

public static int[] toIntArray(Collection coll)

toBooleanArray

public static boolean[] toBooleanArray(Collection coll)

typecast

public static Object[] typecast(Object[] array,
                                Object[] to)

toList

public static List toList(Object array)

slice

public static String[] slice(String[] strings,
                             int begin,
                             int length)

slice

public static Object[] slice(Object[] objects,
                             int begin,
                             int length)

toList

public static List toList(Iterator iter)

join

public static String[] join(String[] x,
                            String[] y)

join

public static String[] join(String[] x,
                            String[] y,
                            boolean[] use)

join

public static int[] join(int[] x,
                         int[] y)

toString

public static String toString(Object[] array)

isAllNegative

public static boolean isAllNegative(int[] array)

isAllTrue

public static boolean isAllTrue(boolean[] array)

countTrue

public static int countTrue(boolean[] array)

isAllFalse

public static boolean isAllFalse(boolean[] array)

addAll

public static void addAll(Collection collection,
                          Object[] array)

getBatchSizes

public static int[] getBatchSizes(int maxBatchSize)

hash

public static int hash(Object[] array)
calculate the array hash (only the first level)

hash

public static int hash(char[] array)
calculate the array hash (only the first level)

hash

public static int hash(byte[] bytes)
calculate the array hash (only the first level)

isEquals

public static boolean isEquals(Object[] o1,
                               Object[] o2)
Compare 2 arrays only at the first level

isEquals

public static boolean isEquals(char[] o1,
                               char[] o2)
Compare 2 arrays only at the first level

isEquals

public static boolean isEquals(byte[] b1,
                               byte[] b2)
Compare 2 arrays only at the first level

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BytesHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class BytesHelper

java.lang.Object
    extended by org.hibernate.util.BytesHelper
public final class BytesHelper
extends Object

Method Summary
static int toInt(byte[] bytes)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

toInt

public static int toInt(byte[] bytes)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CalendarComparator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class CalendarComparator

java.lang.Object
    extended by org.hibernate.util.CalendarComparator
All Implemented Interfaces:
Comparator
public class CalendarComparator
extends Object
implements Comparator

Author:
Gavin King

Field Summary
static Comparator INSTANCE
Constructor Summary
CalendarComparator()
Method Summary
 int compare(Object x, Object y)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Comparator
equals

Field Detail

INSTANCE

public static final Comparator INSTANCE
Constructor Detail

CalendarComparator

public CalendarComparator()
Method Detail

compare

public int compare(Object x,
                   Object y)
Specified by:
compare in interface Comparator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Cloneable (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class Cloneable

java.lang.Object
    extended by org.hibernate.util.Cloneable
Direct Known Subclasses:
EventListeners
public class Cloneable
extends Object

An object that is shallow-coneable

Author:
Steve Ebersole

Constructor Summary
Cloneable()
Method Summary
Object | shallowCopy() Essentially performs a shallow copy of this SessionEventListenerConfig instance; meaning the SessionEventListenerConfig itself is cloned, but the individual listeners are not cloned.
void | validate() Checks to ensure the SessionEventListenerConfig is fully configured (basically, that none of the listeners is null).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Cloneable

public Cloneable()
Method Detail

shallowCopy

public Object shallowCopy()
Essentially performs a shallow copy of this SessionEventListenerConfig instance; meaning the SessionEventListenerConfig itself is cloned, but the individual listeners are not cloned.

Returns:
The SessionEventListenerConfig shallow copy.

validate

public void validate()
              throws HibernateException
Checks to ensure the SessionEventListenerConfig is fully configured (basically, that none of the listeners is null).

Throws:
HibernateException - If the SessionEventListenerConfig is not fully configured.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class CollectionHelper

java.lang.Object
    extended by org.hibernate.util.CollectionHelper
public final class CollectionHelper
extends Object

Author:
Gavin King

Field Summary
static Collection | EMPTY_COLLECTION
static List | EMPTY_LIST
static Map | EMPTY_MAP
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EMPTY_LIST

public static final List EMPTY_LIST

EMPTY_COLLECTION

public static final Collection EMPTY_COLLECTION

EMPTY_MAP

public static final Map EMPTY_MAP
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ComparableComparator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class ComparableComparator

java.lang.Object
    extended by org.hibernate.util.ComparableComparator
All Implemented Interfaces:
Comparator
public class ComparableComparator
extends Object
implements Comparator

Delegates to Comparable

Author:
Gavin King

Field Summary
static Comparator INSTANCE
Constructor Summary
ComparableComparator()
Method Summary
 int compare(Object x, Object y)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Comparator
equals

Field Detail

INSTANCE

public static final Comparator INSTANCE
Constructor Detail

ComparableComparator

public ComparableComparator()
Method Detail

compare

public int compare(Object x,
                   Object y)
Specified by:
compare in interface Comparator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConfigHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class ConfigHelper

java.lang.Object
    extended by org.hibernate.util.ConfigHelper
public final class ConfigHelper
extends Object

A simple class to centralize logic needed to locate config files on the system.

Author:
Steve

Method Summary
static URL | findAsResource(String path) Try to locate a local URL representing the incoming path.
static Properties | getConfigProperties(String path) Loads a properties instance based on the data at the incoming config location.
static InputStream | getConfigStream(String path) Open an InputStream to the URL represented by the incoming path.
static Reader | getConfigStreamReader(String path) Open an Reader to the URL represented by the incoming path.
static InputStream | getResourceAsStream(String resource)
static InputStream | getUserResourceAsStream(String resource)
static URL | locateConfig(String path) Try to locate a local URL representing the incoming path.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

locateConfig

public static final URL locateConfig(String path)
Try to locate a local URL representing the incoming path. The first attempt assumes that the incoming path is an actual URL string (file://, etc). If this does not work, then the next attempts try to locate this UURL as a java system resource.

Parameters:
path - The path representing the config location.
Returns:
An appropriate URL or null.

findAsResource

public static final URL findAsResource(String path)
Try to locate a local URL representing the incoming path. This method only attempts to locate this URL as a java system resource.

Parameters:
path - The path representing the config location.
Returns:
An appropriate URL or null.

getConfigStream

public static final InputStream getConfigStream(String path)
                                         throws HibernateException
Open an InputStream to the URL represented by the incoming path. First makes a call to locateConfig(java.lang.String) in order to find an appropriate URL. URL.openStream() is then called to obtain the stream.

Parameters:
path - The path representing the config location.
Returns:
An input stream to the requested config resource.
Throws:
HibernateException - Unable to open stream to that resource.

getConfigStreamReader

public static final Reader getConfigStreamReader(String path)
                                          throws HibernateException
Open an Reader to the URL represented by the incoming path. First makes a call to locateConfig(java.lang.String) in order to find an appropriate URL. URL.openStream() is then called to obtain a stream, which is then wrapped in a Reader.

Parameters:
path - The path representing the config location.
Returns:
An input stream to the requested config resource.
Throws:
HibernateException - Unable to open reader to that resource.

getConfigProperties

public static final Properties getConfigProperties(String path)
                                            throws HibernateException
Loads a properties instance based on the data at the incoming config location.

Parameters:
path - The path representing the config location.
Returns:
The loaded properties instance.
Throws:
HibernateException - Unable to load properties from that resource.

getResourceAsStream

public static InputStream getResourceAsStream(String resource)

getUserResourceAsStream

public static InputStream getUserResourceAsStream(String resource)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DTDEntityResolver (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class DTDEntityResolver

java.lang.Object
    extended by org.hibernate.util.DTDEntityResolver
All Implemented Interfaces:
org.xml.sax.EntityResolver, Serializable
public class DTDEntityResolver
extends Object
implements org.xml.sax.EntityResolver, Serializable

An EntityResolver implementation which attempts to resolve various systemId URLs to local classpath lookups

  1. Any systemId URL beginning with http://hibernate.sourceforge.net/ is searched for as a classpath resource in the classloader which loaded the Hibernate classes.
  2. Any systemId URL using classpath as the scheme (i.e. starting with classpath:// is searched for as a classpath resource using first the current thread context classloader and then the classloader which loaded the Hibernate classes.

Any entity references which cannot be resolved in relation to the above rules result in returning null, which should force the SAX reader to handle the entity reference in its default manner.

See Also:
Serialized Form

Constructor Summary
DTDEntityResolver()
Method Summary
org.xml.sax.InputSource | resolveEntity(String publicId, String systemId)
protected InputStream | resolveInHibernateNamespace(String path)
protected InputStream | resolveInLocalNamespace(String path)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DTDEntityResolver

public DTDEntityResolver()
Method Detail

resolveEntity

public org.xml.sax.InputSource resolveEntity(String publicId,
                                             String systemId)
Specified by:
resolveEntity in interface org.xml.sax.EntityResolver

resolveInHibernateNamespace

protected InputStream resolveInHibernateNamespace(String path)

resolveInLocalNamespace

protected InputStream resolveInLocalNamespace(String path)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmptyIterator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class EmptyIterator

java.lang.Object
    extended by org.hibernate.util.EmptyIterator
All Implemented Interfaces:
Iterator
public final class EmptyIterator
extends Object
implements Iterator

Author:
Gavin King

Field Summary
static Iterator INSTANCE
Method Summary
boolean | hasNext()
Object | next()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INSTANCE

public static final Iterator INSTANCE
Method Detail

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EqualsHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class EqualsHelper

java.lang.Object
    extended by org.hibernate.util.EqualsHelper
public final class EqualsHelper
extends Object

Author:
Gavin King

Method Summary
static boolean equals(Object x, Object y)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

equals

public static boolean equals(Object x,
                             Object y)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExternalSessionFactoryConfig (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class ExternalSessionFactoryConfig

java.lang.Object
    extended by org.hibernate.util.ExternalSessionFactoryConfig
Direct Known Subclasses:
HibernateService
public abstract class ExternalSessionFactoryConfig
extends Object

Defines support for various externally configurable SessionFactory(s), for example, JMX or the JCA adapter.

Author:
Steve Ebersole

Constructor Summary
ExternalSessionFactoryConfig()
Method Summary
void | addAdditionalProperty(String name, String value)
protected void | addAll(Properties target, Map source)
void | addMapResource(String mapResource)
protected Configuration | buildConfiguration()
protected Properties | buildProperties()
String | getBatchVersionedDataEnabled()
String | getCacheProviderClass()
String | getCacheRegionPrefix()
String | getCommentsEnabled()
Map | getCustomListeners()
String | getDefaultCatalog()
String | getDefaultSchema()
String | getDialect()
protected Set | getExcludedPropertyNames()
protected Map | getExtraProperties()
String | getGetGeneratedKeysEnabled()
String | getJdbcBatchSize()
String | getJdbcFetchSize()
String | getJdbcScrollableResultSetEnabled()
String | getMapResources()
String | getMaximumFetchDepth()
String | getMinimalPutsEnabled()
String | getQueryCacheEnabled()
String | getQuerySubstitutions()
String | getReflectionOptimizationEnabled()
String | getSecondLevelCacheEnabled()
String | getShowSqlEnabled()
String | getStreamsForBinaryEnabled()
void | setBatchVersionedDataEnabled(String batchVersionedDataEnabled)
void | setCacheProviderClass(String cacheProviderClass)
void | setCacheRegionPrefix(String cacheRegionPrefix)
void | setCommentsEnabled(String commentsEnabled)
void | setCustomListener(String type, String listenerClass)
void | setCustomListeners(Map customListeners)
void | setCustomListenersAsString(String customListenersString)
void | setDefaultCatalog(String defaultCatalog)
void | setDefaultSchema(String defaultSchema)
void | setDialect(String dialect)
void | setGetGeneratedKeysEnabled(String getGeneratedKeysEnabled)
void | setJdbcBatchSize(String jdbcBatchSize)
void | setJdbcFetchSize(String jdbcFetchSize)
void | setJdbcScrollableResultSetEnabled(String jdbcScrollableResultSetEnabled)
void | setMapResources(String mapResources)
void | setMaximumFetchDepth(String maximumFetchDepth)
void | setMinimalPutsEnabled(String minimalPutsEnabled)
void | setQueryCacheEnabled(String queryCacheEnabled)
void | setQuerySubstitutions(String querySubstitutions)
void | setReflectionOptimizationEnabled(String reflectionOptimizationEnabled)
void | setSecondLevelCacheEnabled(String secondLevelCacheEnabled)
void | setShowSqlEnabled(String showSqlEnabled)
void | setStreamsForBinaryEnabled(String streamsForBinaryEnabled)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExternalSessionFactoryConfig

public ExternalSessionFactoryConfig()
Method Detail

getExcludedPropertyNames

protected Set getExcludedPropertyNames()

getMapResources

public final String getMapResources()

setMapResources

public final void setMapResources(String mapResources)

addMapResource

public void addMapResource(String mapResource)

getDialect

public final String getDialect()

setDialect

public final void setDialect(String dialect)

getDefaultSchema

public final String getDefaultSchema()

setDefaultSchema

public final void setDefaultSchema(String defaultSchema)

getDefaultCatalog

public final String getDefaultCatalog()

setDefaultCatalog

public final void setDefaultCatalog(String defaultCatalog)

getMaximumFetchDepth

public final String getMaximumFetchDepth()

setMaximumFetchDepth

public final void setMaximumFetchDepth(String maximumFetchDepth)

getJdbcFetchSize

public final String getJdbcFetchSize()

setJdbcFetchSize

public final void setJdbcFetchSize(String jdbcFetchSize)

getJdbcBatchSize

public final String getJdbcBatchSize()

setJdbcBatchSize

public final void setJdbcBatchSize(String jdbcBatchSize)

getBatchVersionedDataEnabled

public final String getBatchVersionedDataEnabled()

setBatchVersionedDataEnabled

public final void setBatchVersionedDataEnabled(String batchVersionedDataEnabled)

getJdbcScrollableResultSetEnabled

public final String getJdbcScrollableResultSetEnabled()

setJdbcScrollableResultSetEnabled

public final void setJdbcScrollableResultSetEnabled(String jdbcScrollableResultSetEnabled)

getGetGeneratedKeysEnabled

public final String getGetGeneratedKeysEnabled()

setGetGeneratedKeysEnabled

public final void setGetGeneratedKeysEnabled(String getGeneratedKeysEnabled)

getStreamsForBinaryEnabled

public final String getStreamsForBinaryEnabled()

setStreamsForBinaryEnabled

public final void setStreamsForBinaryEnabled(String streamsForBinaryEnabled)

getReflectionOptimizationEnabled

public final String getReflectionOptimizationEnabled()

setReflectionOptimizationEnabled

public final void setReflectionOptimizationEnabled(String reflectionOptimizationEnabled)

getQuerySubstitutions

public final String getQuerySubstitutions()

setQuerySubstitutions

public final void setQuerySubstitutions(String querySubstitutions)

getShowSqlEnabled

public final String getShowSqlEnabled()

setShowSqlEnabled

public final void setShowSqlEnabled(String showSqlEnabled)

getCommentsEnabled

public final String getCommentsEnabled()

setCommentsEnabled

public final void setCommentsEnabled(String commentsEnabled)

getSecondLevelCacheEnabled

public final String getSecondLevelCacheEnabled()

setSecondLevelCacheEnabled

public final void setSecondLevelCacheEnabled(String secondLevelCacheEnabled)

getCacheProviderClass

public final String getCacheProviderClass()

setCacheProviderClass

public final void setCacheProviderClass(String cacheProviderClass)

getCacheRegionPrefix

public final String getCacheRegionPrefix()

setCacheRegionPrefix

public final void setCacheRegionPrefix(String cacheRegionPrefix)

getMinimalPutsEnabled

public final String getMinimalPutsEnabled()

setMinimalPutsEnabled

public final void setMinimalPutsEnabled(String minimalPutsEnabled)

getQueryCacheEnabled

public final String getQueryCacheEnabled()

setQueryCacheEnabled

public final void setQueryCacheEnabled(String queryCacheEnabled)

getCustomListeners

public final Map getCustomListeners()

setCustomListeners

public void setCustomListeners(Map customListeners)

setCustomListenersAsString

public void setCustomListenersAsString(String customListenersString)

setCustomListener

public void setCustomListener(String type,
                              String listenerClass)

addAdditionalProperty

public final void addAdditionalProperty(String name,
                                        String value)

buildConfiguration

protected final Configuration buildConfiguration()

buildProperties

protected final Properties buildProperties()

addAll

protected void addAll(Properties target,
                      Map source)

getExtraProperties

protected Map getExtraProperties()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FastHashMap (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class FastHashMap

java.lang.Object
    extended by org.hibernate.util.FastHashMap
All Implemented Interfaces:
Map, Serializable
public final class FastHashMap
extends Object
implements Map, Serializable

A customized implementation of java.util.HashMap designed to operate in a multithreaded environment where the large majority of method calls are read-only, instead of structural changes. Read calls are non-synchronized and write calls perform the following steps:

  • Clone the existing collection
  • Perform the modification on the clone
  • Replace the existing collection with the (modified) clone

NOTE: If you are creating and accessing a HashMap only within a single thread, you should use java.util.HashMap directly (with no synchronization), for maximum performance.

See Also:
Serialized Form

Nested Class Summary
Nested classes inherited from class java.util.Map
Map.Entry
Constructor Summary
FastHashMap()
Construct a an empty map.
FastHashMap(int capacity)
Construct an empty map with the specified capacity.
FastHashMap(int capacity, float factor)
Construct an empty map with the specified capacity and load factor.
FastHashMap(Map map)
Construct a new map with the same mappings as the specified map.
Method Summary
void | clear() Remove all mappings from this map.
Object | clone() Return a shallow copy of this FastHashMap instance.
boolean | containsKey(Object key) Return true if this map contains a mapping for the specified key.
boolean | containsValue(Object value) Return true if this map contains one or more keys mapping to the specified value.
Set | entrySet() Return a collection view of the mappings contained in this map.
boolean | equals(Object o) Compare the specified object with this list for equality.
Object | get(Object key) Return the value to which this map maps the specified key.
int | hashCode() Return the hash code value for this map.
boolean | isEmpty() Return true if this map contains no mappings.
Set | keySet() Return a set view of the keys contained in this map.
Object | put(Object key, Object value) Associate the specified value with the specified key in this map.
void | putAll(Map in) Copy all of the mappings from the specified map to this one, replacing any mappings with the same keys.
Object | remove(Object key) Remove any mapping for this key, and return any previously mapped value.
int | size() Return the number of key-value mappings in this map.
String | toString()
Collection | values() Return a collection view of the values contained in this map.
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

FastHashMap

public FastHashMap()
Construct a an empty map.

FastHashMap

public FastHashMap(int capacity)
Construct an empty map with the specified capacity.

Parameters:
capacity - The initial capacity of the empty map

FastHashMap

public FastHashMap(int capacity,
                   float factor)
Construct an empty map with the specified capacity and load factor.

Parameters:
capacity - The initial capacity of the empty map
factor - The load factor of the new map

FastHashMap

public FastHashMap(Map map)
Construct a new map with the same mappings as the specified map.

Parameters:
map - The map whose mappings are to be copied
Method Detail

clear

public void clear()
Remove all mappings from this map.

Specified by:
clear in interface Map

clone

public Object clone()
Return a shallow copy of this FastHashMap instance. The keys and values themselves are not copied.

containsKey

public boolean containsKey(Object key)
Return true if this map contains a mapping for the specified key.

Specified by:
containsKey in interface Map
Parameters:
key - Key to be searched for

containsValue

public boolean containsValue(Object value)
Return true if this map contains one or more keys mapping to the specified value.

Specified by:
containsValue in interface Map
Parameters:
value - Value to be searched for

entrySet

public Set entrySet()
Return a collection view of the mappings contained in this map. Each element in the returned collection is a Map.Entry.

Specified by:
entrySet in interface Map

equals

public boolean equals(Object o)
Compare the specified object with this list for equality. This implementation uses exactly the code that is used to define the list equals function in the documentation for the Map.equals method.

Specified by:
equals in interface Map
Parameters:
o - Object to be compared to this list

get

public Object get(Object key)
Return the value to which this map maps the specified key. Returns null if the map contains no mapping for this key, or if there is a mapping with a value of null. Use the containsKey() method to disambiguate these cases.

Specified by:
get in interface Map
Parameters:
key - Key whose value is to be returned

hashCode

public int hashCode()
Return the hash code value for this map. This implementation uses exactly the code that is used to define the list hash function in the documentation for the Map.hashCode method.

Specified by:
hashCode in interface Map

isEmpty

public boolean isEmpty()
Return true if this map contains no mappings.

Specified by:
isEmpty in interface Map

keySet

public Set keySet()
Return a set view of the keys contained in this map.

Specified by:
keySet in interface Map

put

public Object put(Object key,
                  Object value)
Associate the specified value with the specified key in this map. If the map previously contained a mapping for this key, the old value is replaced and returned.

Specified by:
put in interface Map
Parameters:
key - The key with which the value is to be associated
value - The value to be associated with this key

putAll

public void putAll(Map in)
Copy all of the mappings from the specified map to this one, replacing any mappings with the same keys.

Specified by:
putAll in interface Map
Parameters:
in - Map whose mappings are to be copied

remove

public Object remove(Object key)
Remove any mapping for this key, and return any previously mapped value.

Specified by:
remove in interface Map
Parameters:
key - Key whose mapping is to be removed

size

public int size()
Return the number of key-value mappings in this map.

Specified by:
size in interface Map

values

public Collection values()
Return a collection view of the values contained in this map.

Specified by:
values in interface Map

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FilterHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class FilterHelper

java.lang.Object
    extended by org.hibernate.util.FilterHelper
public class FilterHelper
extends Object

Implementation of FilterHelper.

Author:
Steve Ebersole

Constructor Summary
FilterHelper(Map filters, Dialect dialect, SQLFunctionRegistry functionRegistry)
The map of defined filters.
Method Summary
boolean | isAffectedBy(Map enabledFilters)
void | render(StringBuffer buffer, String alias, Map enabledFilters)
String | render(String alias, Map enabledFilters)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FilterHelper

public FilterHelper(Map filters,
                    Dialect dialect,
                    SQLFunctionRegistry functionRegistry)
The map of defined filters. This is expected to be in format where the filter names are the map keys, and the defined conditions are the values.

Parameters:
filters - The map of defined filters.
dialect - The sql dialect
functionRegistry - The SQL function registry
Method Detail

isAffectedBy

public boolean isAffectedBy(Map enabledFilters)

render

public String render(String alias,
                     Map enabledFilters)

render

public void render(StringBuffer buffer,
                   String alias,
                   Map enabledFilters)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GetGeneratedKeysHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class GetGeneratedKeysHelper

java.lang.Object
    extended by org.hibernate.util.GetGeneratedKeysHelper
public final class GetGeneratedKeysHelper
extends Object

Author:
Gavin King

Method Summary
static ResultSet | getGeneratedKey(PreparedStatement ps)
static PreparedStatement | prepareStatement(Connection conn, String sql)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

prepareStatement

public static PreparedStatement prepareStatement(Connection conn,
                                                 String sql)
                                          throws SQLException
Throws:
SQLException

getGeneratedKey

public static ResultSet getGeneratedKey(PreparedStatement ps)
                                 throws SQLException
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentityMap (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class IdentityMap

java.lang.Object
    extended by org.hibernate.util.IdentityMap
All Implemented Interfaces:
Map
public final class IdentityMap
extends Object
implements Map

A Map where keys are compared by object identity, rather than equals().

Nested Class Summary
static class | IdentityMap.IdentityKey
static class | IdentityMap.IdentityMapEntry
Nested classes inherited from class java.util.Map
Map.Entry
Method Summary
void | clear()
static Map.Entry[] | concurrentEntries(Map map) Return the map entries (as instances of Map.Entry in a collection that is safe from concurrent modification).
boolean | containsKey(Object key)
boolean | containsValue(Object val)
static Map | deserialize(Object o) Workaround for a JDK 1.4.1 bug where IdentityHashMaps are not correctly deserialized.
static List | entries(Map map)
Map.Entry[] | entryArray()
List | entryList()
Set | entrySet()
Object | get(Object key)
static Map | instantiate(int size) Return a new instance of this class, with an undefined iteration order
static Map | instantiateSequenced(int size) Return a new instance of this class, with iteration order defined by the order that entries were added
static Map | invert(Map map)
boolean | isEmpty()
Iterator | keyIterator()
static Iterator | keyIterator(Map map)
Set | keySet()
Object | put(Object key, Object value)
void | putAll(Map otherMap)
Object | remove(Object key)
static Object | serialize(Map map) Workaround for a JDK 1.4.1 bug where IdentityHashMaps are not correctly deserialized.
int | size()
String | toString()
Collection | values()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode

Method Detail

instantiate

public static Map instantiate(int size)
Return a new instance of this class, with an undefined iteration order

Returns:
Map

instantiateSequenced

public static Map instantiateSequenced(int size)
Return a new instance of this class, with iteration order defined by the order that entries were added

concurrentEntries

public static Map.Entry[] concurrentEntries(Map map)
Return the map entries (as instances of Map.Entry in a collection that is safe from concurrent modification). ie. we may safely add new instances to the underlying Map during iteration of the entries().

Parameters:
map -
Returns:
Collection

entries

public static List entries(Map map)

keyIterator

public static Iterator keyIterator(Map map)

keyIterator

public Iterator keyIterator()

size

public int size()
Specified by:
size in interface Map

isEmpty

public boolean isEmpty()
Specified by:
isEmpty in interface Map

containsKey

public boolean containsKey(Object key)
Specified by:
containsKey in interface Map

containsValue

public boolean containsValue(Object val)
Specified by:
containsValue in interface Map

get

public Object get(Object key)
Specified by:
get in interface Map

put

public Object put(Object key,
                  Object value)
Specified by:
put in interface Map

remove

public Object remove(Object key)
Specified by:
remove in interface Map

putAll

public void putAll(Map otherMap)
Specified by:
putAll in interface Map

clear

public void clear()
Specified by:
clear in interface Map

keySet

public Set keySet()
Specified by:
keySet in interface Map

values

public Collection values()
Specified by:
values in interface Map

entrySet

public Set entrySet()
Specified by:
entrySet in interface Map

entryList

public List entryList()

entryArray

public Map.Entry[] entryArray()

serialize

public static Object serialize(Map map)
Workaround for a JDK 1.4.1 bug where IdentityHashMaps are not correctly deserialized.

Parameters:
map -
Returns:
Object

deserialize

public static Map deserialize(Object o)
Workaround for a JDK 1.4.1 bug where IdentityHashMaps are not correctly deserialized.

Parameters:
o -
Returns:
Map

toString

public String toString()

invert

public static Map invert(Map map)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentityMap.IdentityKey (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class IdentityMap.IdentityKey

java.lang.Object
    extended by org.hibernate.util.IdentityMap.IdentityKey
All Implemented Interfaces:
Serializable
Enclosing class:
IdentityMap
public static final class IdentityMap.IdentityKey
extends Object
implements Serializable

See Also:
Serialized Form

Method Summary
boolean | equals(Object other)
Object | getRealKey()
int | hashCode()
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Method Detail

equals

public boolean equals(Object other)

hashCode

public int hashCode()

toString

public String toString()

getRealKey

public Object getRealKey()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentityMap.IdentityMapEntry (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class IdentityMap.IdentityMapEntry

java.lang.Object
    extended by org.hibernate.util.IdentityMap.IdentityMapEntry
All Implemented Interfaces:
Map.Entry
Enclosing class:
IdentityMap
public static final class IdentityMap.IdentityMapEntry
extends Object
implements Map.Entry

Method Summary
Object | getKey()
Object | getValue()
Object | setValue(Object value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Map.Entry
equals, hashCode

Method Detail

getKey

public Object getKey()
Specified by:
getKey in interface Map.Entry

getValue

public Object getValue()
Specified by:
getValue in interface Map.Entry

setValue

public Object setValue(Object value)
Specified by:
setValue in interface Map.Entry
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentitySet (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class IdentitySet

java.lang.Object
    extended by org.hibernate.util.IdentitySet
All Implemented Interfaces:
Collection, Set
public class IdentitySet
extends Object
implements Set

Set implementation that use == instead of equals() as its comparison mechanism that base its implementation of IdentityMap

Author:
Emmanuel Bernard

Constructor Summary
IdentitySet()
Method Summary
boolean | add(Object o)
boolean | addAll(Collection c)
void | clear()
boolean | contains(Object o)
boolean | containsAll(Collection c)
boolean | isEmpty()
Iterator | iterator()
boolean | remove(Object o)
boolean | removeAll(Collection c)
boolean | retainAll(Collection c)
int | size()
Object[] | toArray()
Object[] | toArray(Object[] a)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Set
equals, hashCode

Constructor Detail

IdentitySet

public IdentitySet()
Method Detail

size

public int size()
Specified by:
size in interface Set

isEmpty

public boolean isEmpty()
Specified by:
isEmpty in interface Set

contains

public boolean contains(Object o)
Specified by:
contains in interface Set

iterator

public Iterator iterator()
Specified by:
iterator in interface Set

toArray

public Object[] toArray()
Specified by:
toArray in interface Set

toArray

public Object[] toArray(Object[] a)
Specified by:
toArray in interface Set

add

public boolean add(Object o)
Specified by:
add in interface Set

remove

public boolean remove(Object o)
Specified by:
remove in interface Set

containsAll

public boolean containsAll(Collection c)
Specified by:
containsAll in interface Set

addAll

public boolean addAll(Collection c)
Specified by:
addAll in interface Set

retainAll

public boolean retainAll(Collection c)
Specified by:
retainAll in interface Set

removeAll

public boolean removeAll(Collection c)
Specified by:
removeAll in interface Set

clear

public void clear()
Specified by:
clear in interface Set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JDBCExceptionReporter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class JDBCExceptionReporter

java.lang.Object
    extended by org.hibernate.util.JDBCExceptionReporter
public final class JDBCExceptionReporter
extends Object

Field Summary
static String | DEFAULT_EXCEPTION_MSG
static String | DEFAULT_WARNING_MSG
static org.apache.commons.logging.Log | log
Method Summary
static void | logAndClearWarnings(Connection connection)
static void | logExceptions(SQLException ex)
static void | logExceptions(SQLException ex, String message)
static void | logWarnings(SQLWarning warning)
static void | logWarnings(SQLWarning warning, String message)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

public static final org.apache.commons.logging.Log log

DEFAULT_EXCEPTION_MSG

public static final String DEFAULT_EXCEPTION_MSG
See Also:
Constant Field Values

DEFAULT_WARNING_MSG

public static final String DEFAULT_WARNING_MSG
See Also:
Constant Field Values
Method Detail

logAndClearWarnings

public static void logAndClearWarnings(Connection connection)

logWarnings

public static void logWarnings(SQLWarning warning)

logWarnings

public static void logWarnings(SQLWarning warning,
                               String message)

logExceptions

public static void logExceptions(SQLException ex)

logExceptions

public static void logExceptions(SQLException ex,
                                 String message)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JoinedIterator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class JoinedIterator

java.lang.Object
    extended by org.hibernate.util.JoinedIterator
All Implemented Interfaces:
Iterator
public class JoinedIterator
extends Object
implements Iterator

An JoinedIterator is an Iterator that wraps a number of Iterators. This class makes multiple iterators look like one to the caller. When any method from the Iterator interface is called, the JoinedIterator will delegate to a single underlying Iterator. The JoinedIterator will invoke the Iterators in sequence until all Iterators are exhausted.

Constructor Summary
JoinedIterator(Iterator[] iterators)
JoinedIterator(Iterator first, Iterator second)
JoinedIterator(List iterators)
Method Summary
boolean | hasNext()
Object | next()
void | remove()
protected void | updateCurrentIterator()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JoinedIterator

public JoinedIterator(List iterators)

JoinedIterator

public JoinedIterator(Iterator[] iterators)

JoinedIterator

public JoinedIterator(Iterator first,
                      Iterator second)
Method Detail

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator

updateCurrentIterator

protected void updateCurrentIterator()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JTAHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class JTAHelper

java.lang.Object
    extended by org.hibernate.util.JTAHelper
public final class JTAHelper
extends Object

Author:
Gavin King

Method Summary
static boolean | isInProgress(int status)
static boolean | isMarkedForRollback(int status)
static boolean | isMarkedForRollback(Transaction tx)
static boolean | isRollback(int status)
static boolean | isTransactionInProgress(SessionFactoryImplementor factory) Return true if a JTA transaction is in progress and false in *every* other cases (including in a JDBC transaction).
static boolean | isTransactionInProgress(Transaction tx)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

isRollback

public static boolean isRollback(int status)

isInProgress

public static boolean isInProgress(int status)

isTransactionInProgress

public static boolean isTransactionInProgress(SessionFactoryImplementor factory)
Return true if a JTA transaction is in progress and false in *every* other cases (including in a JDBC transaction).

isTransactionInProgress

public static boolean isTransactionInProgress(Transaction tx)
                                       throws SystemException
Throws:
SystemException

isMarkedForRollback

public static boolean isMarkedForRollback(int status)

isMarkedForRollback

public static boolean isMarkedForRollback(Transaction tx)
                                   throws SystemException
Throws:
SystemException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LazyIterator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class LazyIterator

java.lang.Object
    extended by org.hibernate.util.LazyIterator
All Implemented Interfaces:
Iterator
public final class LazyIterator
extends Object
implements Iterator

Constructor Summary
LazyIterator(Map map)
Method Summary
boolean | hasNext()
Object | next()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LazyIterator

public LazyIterator(Map map)
Method Detail

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LinkedHashCollectionHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class LinkedHashCollectionHelper

java.lang.Object
    extended by org.hibernate.util.LinkedHashCollectionHelper
public final class LinkedHashCollectionHelper
extends Object

Method Summary
static Map | createLinkedHashMap()
static Map | createLinkedHashMap(int anticipatedSize)
static Set | createLinkedHashSet()
static Set | createLinkedHashSet(int anticipatedSize)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createLinkedHashSet

public static Set createLinkedHashSet()

createLinkedHashSet

public static Set createLinkedHashSet(int anticipatedSize)

createLinkedHashMap

public static Map createLinkedHashMap()

createLinkedHashMap

public static Map createLinkedHashMap(int anticipatedSize)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MarkerObject (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class MarkerObject

java.lang.Object
    extended by org.hibernate.util.MarkerObject
public class MarkerObject
extends Object

Author:
Gavin King

Constructor Summary
MarkerObject(String name)
Method Summary
 String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MarkerObject

public MarkerObject(String name)
Method Detail

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamedGeneratedKeysHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class NamedGeneratedKeysHelper

java.lang.Object
    extended by org.hibernate.util.NamedGeneratedKeysHelper
public class NamedGeneratedKeysHelper
extends Object

Author:
Steve Ebersole

Method Summary
static ResultSet | getGeneratedKey(PreparedStatement ps)
static PreparedStatement | prepareStatement(Connection conn, String sql, String[] columnNames)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

prepareStatement

public static PreparedStatement prepareStatement(Connection conn,
                                                 String sql,
                                                 String[] columnNames)
                                          throws SQLException
Throws:
SQLException

getGeneratedKey

public static ResultSet getGeneratedKey(PreparedStatement ps)
                                 throws SQLException
Throws:
SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamingHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class NamingHelper

java.lang.Object
    extended by org.hibernate.util.NamingHelper
public final class NamingHelper
extends Object

Method Summary
static void | bind(Context ctx, String name, Object val) Bind val to name in ctx, and make sure that all intermediate contexts exist.
static InitialContext | getInitialContext(Properties props)
static Properties | getJndiProperties(Properties properties) Transform JNDI properties passed in the form hibernate.jndi.* to the format accepted by InitialContext by triming the leading "hibernate.jndi".
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getInitialContext

public static InitialContext getInitialContext(Properties props)
                                        throws NamingException
Throws:
NamingException

bind

public static void bind(Context ctx,
                        String name,
                        Object val)
                 throws NamingException
Bind val to name in ctx, and make sure that all intermediate contexts exist.

Parameters:
ctx - the root context
name - the name as a string
val - the object to be bound
Throws:
NamingException

getJndiProperties

public static Properties getJndiProperties(Properties properties)
Transform JNDI properties passed in the form hibernate.jndi.* to the format accepted by InitialContext by triming the leading "hibernate.jndi".

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertiesHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class PropertiesHelper

java.lang.Object
    extended by org.hibernate.util.PropertiesHelper
public final class PropertiesHelper
extends Object

Method Summary
static boolean | getBoolean(String property, Properties properties)
static boolean | getBoolean(String property, Properties properties, boolean defaultValue)
static int | getInt(String property, Properties properties, int defaultValue)
static Integer | getInteger(String property, Properties properties)
static String | getString(String property, Properties properties, String defaultValue)
static Properties | maskOut(Properties props, String key) replace a property by a starred version
static String | resolvePlaceHolder(String property)
static void | resolvePlaceHolders(Properties properties)
static Map | toMap(String property, String delim, Properties properties)
static String[] | toStringArray(String propValue, String delim)
static String[] | toStringArray(String property, String delim, Properties properties)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getBoolean

public static boolean getBoolean(String property,
                                 Properties properties)

getBoolean

public static boolean getBoolean(String property,
                                 Properties properties,
                                 boolean defaultValue)

getInt

public static int getInt(String property,
                         Properties properties,
                         int defaultValue)

getString

public static String getString(String property,
                               Properties properties,
                               String defaultValue)

getInteger

public static Integer getInteger(String property,
                                 Properties properties)

toMap

public static Map toMap(String property,
                        String delim,
                        Properties properties)

toStringArray

public static String[] toStringArray(String property,
                                     String delim,
                                     Properties properties)

toStringArray

public static String[] toStringArray(String propValue,
                                     String delim)

maskOut

public static Properties maskOut(Properties props,
                                 String key)
replace a property by a starred version

Parameters:
props - properties to check
key - proeprty to mask
Returns:
cloned and masked properties

resolvePlaceHolders

public static void resolvePlaceHolders(Properties properties)

resolvePlaceHolder

public static String resolvePlaceHolder(String property)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Range (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class Range

java.lang.Object
    extended by org.hibernate.util.Range
public final class Range
extends Object

Method Summary
static int[] range(int begin, int length)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

range

public static int[] range(int begin,
                          int length)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReflectHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class ReflectHelper

java.lang.Object
    extended by org.hibernate.util.ReflectHelper
public final class ReflectHelper
extends Object

Method Summary
static Class | classForName(String name)
static Class | classForName(String name, Class caller)
static Object | getConstantValue(String name)
static Constructor | getConstructor(Class clazz, Type[] types)
static Constructor | getDefaultConstructor(Class clazz)
static Getter | getGetter(Class theClass, String name)
static Method | getMethod(Class clazz, Method method)
static boolean | isAbstractClass(Class clazz)
static boolean | isFinalClass(Class clazz)
static boolean | isPublic(Class clazz, Member member)
static boolean | overridesEquals(Class clazz)
static boolean | overridesHashCode(Class clazz)
static Class | reflectedPropertyClass(String className, String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

overridesEquals

public static boolean overridesEquals(Class clazz)

overridesHashCode

public static boolean overridesHashCode(Class clazz)

reflectedPropertyClass

public static Class reflectedPropertyClass(String className,
                                           String name)
                                    throws MappingException
Throws:
MappingException

getGetter

public static Getter getGetter(Class theClass,
                               String name)
                        throws MappingException
Throws:
MappingException

classForName

public static Class classForName(String name)
                          throws ClassNotFoundException
Throws:
ClassNotFoundException

classForName

public static Class classForName(String name,
                                 Class caller)
                          throws ClassNotFoundException
Throws:
ClassNotFoundException

isPublic

public static boolean isPublic(Class clazz,
                               Member member)

getConstantValue

public static Object getConstantValue(String name)

getDefaultConstructor

public static Constructor getDefaultConstructor(Class clazz)
                                         throws PropertyNotFoundException
Throws:
PropertyNotFoundException

isAbstractClass

public static boolean isAbstractClass(Class clazz)

isFinalClass

public static boolean isFinalClass(Class clazz)

getConstructor

public static Constructor getConstructor(Class clazz,
                                         Type[] types)
                                  throws PropertyNotFoundException
Throws:
PropertyNotFoundException

getMethod

public static Method getMethod(Class clazz,
                               Method method)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SerializationHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class SerializationHelper

java.lang.Object
    extended by org.hibernate.util.SerializationHelper
public final class SerializationHelper
extends Object

Assists with the serialization process and performs additional functionality based on serialization.

  • Deep clone using serialization
  • Serialize managing finally and IOException
  • Deserialize managing finally and IOException

This class throws exceptions for invalid null inputs. Each method documents its behaviour in more detail.

Since:
1.0
Version:
$Id: SerializationHelper.java 9180 2006-01-30 23:51:27Z steveebersole $
Author:
Nissim Karpenstein, Janek Bogucki, Daniel Rall, Stephen Colebourne, Jeff Varszegi, Gary Gregory

Method Summary
static Object | clone(Serializable object) Deep clone an Object using serialization.
static Object | deserialize(byte[] objectData) Deserializes a single Object from an array of bytes.
static Object | deserialize(InputStream inputStream) Deserializes an Object from the specified stream.
static byte[] | serialize(Serializable obj) Serializes an Object to a byte array for storage/serialization.
static void | serialize(Serializable obj, OutputStream outputStream) Serializes an Object to the specified stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

clone

public static Object clone(Serializable object)
                    throws SerializationException

Deep clone an Object using serialization.

This is many times slower than writing clone methods by hand on all objects in your object graph. However, for complex object graphs, or for those that don't support deep cloning this can be a simple alternative implementation. Of course all the objects must be Serializable.

Parameters:
object - the Serializable object to clone
Returns:
the cloned object
Throws:
SerializationException - (runtime) if the serialization fails

serialize

public static void serialize(Serializable obj,
                             OutputStream outputStream)
                      throws SerializationException

Serializes an Object to the specified stream.

The stream will be closed once the object is written. This avoids the need for a finally clause, and maybe also exception handling, in the application code.

The stream passed in is not buffered internally within this method. This is the responsibility of your application if desired.

Parameters:
obj - the object to serialize to bytes, may be null
outputStream - the stream to write to, must not be null
Throws:
IllegalArgumentException - if outputStream is null
SerializationException - (runtime) if the serialization fails

serialize

public static byte[] serialize(Serializable obj)
                        throws SerializationException

Serializes an Object to a byte array for storage/serialization.

Parameters:
obj - the object to serialize to bytes
Returns:
a byte[] with the converted Serializable
Throws:
SerializationException - (runtime) if the serialization fails

deserialize

public static Object deserialize(InputStream inputStream)
                          throws SerializationException

Deserializes an Object from the specified stream.

The stream will be closed once the object is written. This avoids the need for a finally clause, and maybe also exception handling, in the application code.

The stream passed in is not buffered internally within this method. This is the responsibility of your application if desired.

Parameters:
inputStream - the serialized object input stream, must not be null
Returns:
the deserialized object
Throws:
IllegalArgumentException - if inputStream is null
SerializationException - (runtime) if the serialization fails

deserialize

public static Object deserialize(byte[] objectData)
                          throws SerializationException

Deserializes a single Object from an array of bytes.

Parameters:
objectData - the serialized object, must not be null
Returns:
the deserialized object
Throws:
IllegalArgumentException - if objectData is null
SerializationException - (runtime) if the serialization fails
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleMRUCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class SimpleMRUCache

java.lang.Object
    extended by org.hibernate.util.SimpleMRUCache
All Implemented Interfaces:
Serializable
public class SimpleMRUCache
extends Object
implements Serializable

Cache following a "Most Recently Used" (MRU) algorithm for maintaining a bounded in-memory size; the "Least Recently Used" (LRU) entry is the first available for removal from the cache.

This implementation uses a bounded MRU Map to limit the in-memory size of the cache. Thus the size of this cache never grows beyond the stated size.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
static int DEFAULT_STRONG_REF_COUNT
Constructor Summary
SimpleMRUCache()
SimpleMRUCache(int strongReferenceCount)
Method Summary
void | clear()
Object | get(Object key)
Object | put(Object key, Object value)
int | size()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_STRONG_REF_COUNT

public static final int DEFAULT_STRONG_REF_COUNT
See Also:
Constant Field Values
Constructor Detail

SimpleMRUCache

public SimpleMRUCache()

SimpleMRUCache

public SimpleMRUCache(int strongReferenceCount)
Method Detail

get

public Object get(Object key)

put

public Object put(Object key,
                  Object value)

size

public int size()

clear

public void clear()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SingletonIterator (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class SingletonIterator

java.lang.Object
    extended by org.hibernate.util.SingletonIterator
All Implemented Interfaces:
Iterator
public final class SingletonIterator
extends Object
implements Iterator

Author:
Gavin King

Constructor Summary
SingletonIterator(Object value)
Method Summary
boolean | hasNext()
Object | next()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SingletonIterator

public SingletonIterator(Object value)
Method Detail

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SoftLimitMRUCache (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class SoftLimitMRUCache

java.lang.Object
    extended by org.hibernate.util.SoftLimitMRUCache
All Implemented Interfaces:
Serializable
public class SoftLimitMRUCache
extends Object
implements Serializable

Cache following a "Most Recently Used" (MRY) algorithm for maintaining a bounded in-memory size; the "Least Recently Used" (LRU) entry is the first available for removal from the cache.

This implementation uses a "soft limit" to the in-memory size of the cache, meaning that all cache entries are kept within a completely SoftReference-based map with the most recently utilized entries additionally kept in a hard-reference manner to prevent those cache entries soft references from becoming enqueued by the garbage collector. Thus the actual size of this cache impl can actually grow beyond the stated max size bound as long as GC is not actively seeking soft references for enqueuement.

Author:
Steve Ebersole
See Also:
Serialized Form

Field Summary
static int DEFAULT_STRONG_REF_COUNT
Constructor Summary
SoftLimitMRUCache()
SoftLimitMRUCache(int strongRefCount)
Method Summary
void | clear()
Object | get(Object key)
Object | put(Object key, Object value)
int | size()
int | softSize()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_STRONG_REF_COUNT

public static final int DEFAULT_STRONG_REF_COUNT
See Also:
Constant Field Values
Constructor Detail

SoftLimitMRUCache

public SoftLimitMRUCache()

SoftLimitMRUCache

public SoftLimitMRUCache(int strongRefCount)
Method Detail

get

public Object get(Object key)

put

public Object put(Object key,
                  Object value)

size

public int size()

softSize

public int softSize()

clear

public void clear()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class StringHelper

java.lang.Object
    extended by org.hibernate.util.StringHelper
public final class StringHelper
extends Object

Field Summary
static String WHITESPACE
Method Summary
static String[] | add(String[] x, String sep, String[] y)
static boolean | booleanValue(String tfString)
static int | countUnquoted(String string, char character)
static int | firstIndexOfChar(String sqlString, String string, int startindex)
static String | generateAlias(String description)
static String | generateAlias(String description, int unique) Generate a nice alias for the given class name or collection role name and unique integer.
static boolean | isEmpty(String string)
static boolean | isNotEmpty(String string)
static String | join(String seperator, Iterator objects)
static String | join(String seperator, String[] strings)
static int | lastIndexOfLetter(String string)
static int[] | locateUnquoted(String string, char character)
static String | moveAndToBeginning(String filter)
static String[] | multiply(String string, Iterator placeholders, Iterator replacements)
static String | qualifier(String qualifiedName)
static String | qualify(String prefix, String name)
static String[] | qualify(String prefix, String[] names)
static String | repeat(String string, int times)
static String[] | replace(String[] templates, String placeholder, String replacement)
static String | replace(String template, String placeholder, String replacement)
static String | replace(String template, String placeholder, String replacement, boolean wholeWords)
static String | replaceOnce(String template, String placeholder, String replacement)
static String | root(String qualifiedName)
static String[] | split(String seperators, String list)
static String[] | split(String seperators, String list, boolean include)
static String[] | suffix(String[] columns, String suffix)
static String | toLowerCase(String str)
static String | toString(Object[] array)
static String | toUpperCase(String str)
static String | truncate(String string, int length)
static String | unqualify(String qualifiedName)
static String | unqualifyEntityName(String entityName)
static String | unroot(String qualifiedName)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

WHITESPACE

public static final String WHITESPACE
See Also:
Constant Field Values
Method Detail

lastIndexOfLetter

public static int lastIndexOfLetter(String string)

join

public static String join(String seperator,
                          String[] strings)

join

public static String join(String seperator,
                          Iterator objects)

add

public static String[] add(String[] x,
                           String sep,
                           String[] y)

repeat

public static String repeat(String string,
                            int times)

replace

public static String replace(String template,
                             String placeholder,
                             String replacement)

replace

public static String[] replace(String[] templates,
                               String placeholder,
                               String replacement)

replace

public static String replace(String template,
                             String placeholder,
                             String replacement,
                             boolean wholeWords)

replaceOnce

public static String replaceOnce(String template,
                                 String placeholder,
                                 String replacement)

split

public static String[] split(String seperators,
                             String list)

split

public static String[] split(String seperators,
                             String list,
                             boolean include)

unqualify

public static String unqualify(String qualifiedName)

qualifier

public static String qualifier(String qualifiedName)

suffix

public static String[] suffix(String[] columns,
                              String suffix)

root

public static String root(String qualifiedName)

unroot

public static String unroot(String qualifiedName)

booleanValue

public static boolean booleanValue(String tfString)

toString

public static String toString(Object[] array)

multiply

public static String[] multiply(String string,
                                Iterator placeholders,
                                Iterator replacements)

countUnquoted

public static int countUnquoted(String string,
                                char character)

locateUnquoted

public static int[] locateUnquoted(String string,
                                   char character)

isNotEmpty

public static boolean isNotEmpty(String string)

isEmpty

public static boolean isEmpty(String string)

qualify

public static String qualify(String prefix,
                             String name)

qualify

public static String[] qualify(String prefix,
                               String[] names)

firstIndexOfChar

public static int firstIndexOfChar(String sqlString,
                                   String string,
                                   int startindex)

truncate

public static String truncate(String string,
                              int length)

generateAlias

public static String generateAlias(String description)

generateAlias

public static String generateAlias(String description,
                                   int unique)
Generate a nice alias for the given class name or collection role name and unique integer. Subclasses of Loader do not have to use aliases of this form.

Returns:
an alias of the form foo1_

unqualifyEntityName

public static String unqualifyEntityName(String entityName)

toUpperCase

public static String toUpperCase(String str)

toLowerCase

public static String toLowerCase(String str)

moveAndToBeginning

public static String moveAndToBeginning(String filter)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XMLHelper (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class XMLHelper

java.lang.Object
    extended by org.hibernate.util.XMLHelper
public final class XMLHelper
extends Object

Small helper class that lazy loads DOM and SAX reader and keep them for fast use afterwards.

Nested Class Summary
static class XMLHelper.ErrorLogger
Field Summary
static org.xml.sax.EntityResolver DEFAULT_DTD_RESOLVER
Constructor Summary
XMLHelper()
Method Summary
org.dom4j.io.DOMReader | createDOMReader() Create a dom4j DOMReader
org.dom4j.io.SAXReader | createSAXReader(String file, List errorsList, org.xml.sax.EntityResolver entityResolver) Create a dom4j SAXReader which will append all validation errors to errorList
static void | dump(org.dom4j.Element element)
static org.dom4j.Element | generateDom4jElement(String elementName)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_DTD_RESOLVER

public static final org.xml.sax.EntityResolver DEFAULT_DTD_RESOLVER
Constructor Detail

XMLHelper

public XMLHelper()
Method Detail

createSAXReader

public org.dom4j.io.SAXReader createSAXReader(String file,
                                              List errorsList,
                                              org.xml.sax.EntityResolver entityResolver)
Create a dom4j SAXReader which will append all validation errors to errorList

createDOMReader

public org.dom4j.io.DOMReader createDOMReader()
Create a dom4j DOMReader

generateDom4jElement

public static org.dom4j.Element generateDom4jElement(String elementName)

dump

public static void dump(org.dom4j.Element element)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XMLHelper.ErrorLogger (Hibernate API Documentation)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.hibernate.util
Class XMLHelper.ErrorLogger

java.lang.Object
    extended by org.hibernate.util.XMLHelper.ErrorLogger
All Implemented Interfaces:
org.xml.sax.ErrorHandler
Enclosing class:
XMLHelper
public static class XMLHelper.ErrorLogger
extends Object
implements org.xml.sax.ErrorHandler

Method Summary
void | error(org.xml.sax.SAXParseException error)
void | fatalError(org.xml.sax.SAXParseException error)
void | warning(org.xml.sax.SAXParseException warn)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

error

public void error(org.xml.sax.SAXParseException error)
Specified by:
error in interface org.xml.sax.ErrorHandler

fatalError

public void fatalError(org.xml.sax.SAXParseException error)
Specified by:
fatalError in interface org.xml.sax.ErrorHandler

warning

public void warning(org.xml.sax.SAXParseException warn)
Specified by:
warning in interface org.xml.sax.ErrorHandler
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


All Classes (Hibernate API Documentation)

 All Classes
ANSICaseFragment
ANSIJoinFragment
ASTAppender
ASTIterator
ASTParentsFirstIterator
ASTPrinter
ASTQueryTranslatorFactory
ASTUtil
ASTUtil.FilterPredicate
ASTUtil.IncludePredicate
AbstractAuxiliaryDatabaseObject
AbstractBatcher
AbstractBynaryType
AbstractCharArrayType
AbstractClassTransformerImpl
AbstractCollectionPersister
AbstractComponentTuplizer
AbstractComponentType
AbstractEmptinessExpression
AbstractEntityJoinWalker
AbstractEntityLoader
AbstractEntityPersister
AbstractEntityTuplizer
AbstractEvent
AbstractExplicitParameterSpecification
AbstractFieldInterceptor
AbstractFlushingEventListener
AbstractJndiBoundCacheProvider
AbstractLazyInitializer
AbstractLockUpgradeEventListener
AbstractPersistentCollection
AbstractPersistentCollection.DelayedOperation
AbstractPostInsertGenerator
AbstractPropertyMapping
AbstractQueryImpl
AbstractReassociateEventListener
AbstractRestrictableStatement
AbstractReturningDelegate
AbstractSaveEventListener
AbstractScrollableResults
AbstractSelectExpression
AbstractSelectingDelegate
AbstractSessionImpl
AbstractStatement
AbstractStatementExecutor
AbstractType
AbstractUUIDGenerator
AbstractVisitor
AccessOptimizerAdapter
AccessOptimizerAdapter
ActionQueue
AdaptedImmutableType
AggregateNode
AggregateProjection
Alias
AliasGenerator
AliasToBeanConstructorResultTransformer
AliasToBeanResultTransformer
AliasToEntityMapResultTransformer
AliasedProjection
AnsiTrimEmulationFunction
Any
AnyType
AnyType.ObjectTypeCacheEntry
Array
ArrayHelper
ArrayType
AssertionFailure
Assigned
AssignmentSpecification
AssociationType
AutoFlushEvent
AutoFlushEventListener
AuxiliaryDatabaseObject
AvgProjection
BESTransactionManagerLookup
Backref
BackrefPropertyAccessor
BackrefPropertyAccessor.BackrefSetter
Bag
BagType
BasicClassFilter
BasicCollectionJoinWalker
BasicCollectionLoader
BasicCollectionPersister
BasicEntityPropertyMapping
BasicExecutor
BasicInstrumentationTask
BasicLazyInitializer
BasicLoader
BasicPropertyAccessor
BasicPropertyAccessor.BasicGetter
BasicPropertyAccessor.BasicSetter
BasicProxyFactory
BatchFailedException
BatchFetchQueue
BatchedTooManyRowsAffectedException
Batcher
BatcherFactory
BatchingBatcher
BatchingBatcherFactory
BatchingCollectionInitializer
BatchingEntityLoader
BetweenExpression
BetweenOperatorNode
BigDecimalType
BigIntegerType
BinaryArithmeticOperatorNode
BinaryLogicOperatorNode
BinaryOperatorNode
BinaryType
Binder
BlobImpl
BlobType
BooleanLiteralNode
BooleanType
BorrowedConnectionProxy
BulkAccessor
BulkAccessorException
BulkOperationCleanupAction
ByteCodeHelper
ByteType
BytecodeProvider
BytecodeProviderImpl
BytecodeProviderImpl
BytesHelper
C3P0ConnectionProvider
CGLIBHelper
CGLIBLazyInitializer
CGLIBProxyFactory
CMTTransaction
CMTTransactionFactory
Cache
CacheConcurrencyStrategy
CacheConcurrencyStrategy.SoftLock
CacheEntry
CacheEntryStructure
CacheException
CacheFactory
CacheKey
CacheMode
CacheProvider
CacheSynchronization
CalendarComparator
CalendarDateType
CalendarType
CallbackException
Cascade
CascadeEntityJoinWalker
CascadeEntityLoader
CascadeStyle
CascadeStyle.MultipleCascadeStyle
CascadingAction
Case2Node
CaseFragment
CaseNode
CastFunction
CategorizedStatistics
CglibClassTransformer
ChainedPropertyAccessor
CharArrayType
CharBooleanType
CharIndexFunction
CharacterArrayType
CharacterType
ClassDescriptor
ClassFilter
ClassMetadata
ClassTransformer
ClassType
ClassicAvgFunction
ClassicCountFunction
ClassicQueryTranslatorFactory
ClassicSumFunction
ClauseParser
ClobImpl
ClobType
Cloneable
Collection
CollectionAction
CollectionAliases
CollectionCacheEntry
CollectionElementLoader
CollectionEntry
CollectionFetchReturn
CollectionFilterImpl
CollectionFunction
CollectionHelper
CollectionInitializer
CollectionJoinWalker
CollectionKey
CollectionLoadContext
CollectionLoader
CollectionMetadata
CollectionPersister
CollectionProperties
CollectionPropertyMapping
CollectionPropertyNames
CollectionRecreateAction
CollectionRemoveAction
CollectionReturn
CollectionSecondPass
CollectionStatistics
CollectionSubqueryFactory
CollectionType
CollectionUpdateAction
Collections
Column
ColumnCollectionAliases
ColumnEntityAliases
ColumnHelper
ColumnMetadata
ColumnNameCache
ComparableComparator
Component
ComponentMetamodel
ComponentTuplizer
ComponentType
CompositeCustomType
CompositeElementPropertyMapping
CompositeUserType
ConditionFragment
ConfigHelper
Configurable
Configurable
Configuration
Conjunction
ConnectionManager
ConnectionManager.Callback
ConnectionProvider
ConnectionProviderFactory
ConnectionReleaseMode
Constraint
ConstraintViolationException
ConstructorNode
CountNode
CountProjection
Criteria
CriteriaImpl
CriteriaImpl.CriterionEntry
CriteriaImpl.OrderEntry
CriteriaJoinWalker
CriteriaLoader
CriteriaQuery
CriteriaQueryTranslator
CriteriaSpecification
Criterion
CurrencyType
CurrentSessionContext
CustomCollectionType
CustomLoader
CustomQuery
CustomType
DB2390Dialect
DB2400Dialect
DB2Dialect
DDLFormatter
DTDEntityResolver
DataDirectOracle9Dialect
DataException
DatabaseMetadata
DatasourceConnectionProvider
DateType
DbTimestampType
DecodeCaseFragment
DefaultAutoFlushEventListener
DefaultDeleteEventListener
DefaultDirtyCheckEventListener
DefaultEntityAliases
DefaultEvictEventListener
DefaultFlushEntityEventListener
DefaultFlushEventListener
DefaultInitializeCollectionEventListener
DefaultLoadEventListener
DefaultLockEventListener
DefaultMergeEventListener
DefaultNamingStrategy
DefaultPersistEventListener
DefaultPersistOnFlushEventListener
DefaultPostLoadEventListener
DefaultPreLoadEventListener
DefaultRefreshEventListener
DefaultReplicateEventListener
DefaultSaveEventListener
DefaultSaveOrUpdateCopyEventListener
DefaultSaveOrUpdateEventListener
DefaultUpdateEventListener
DelayedPostInsertIdentifier
Delete
DeleteEvent
DeleteEventListener
DeleteStatement
DenormalizedTable
DependantValue
DerbyCaseFragment
DerbyDialect
DerbyDialect.DerbyTrimFunctionEmulation
DetachedCriteria
DetailedSemanticException
Dialect
DialectFactory
DialectFactory.DatabaseDialectMapper
DialectFactory.VersionInsensitiveMapper
DirectPropertyAccessor
DirectPropertyAccessor.DirectGetter
DirectPropertyAccessor.DirectSetter
DirtyCheckEvent
DirtyCheckEventListener
DirtyCollectionSearchVisitor
DiscriminatorType
Disjunction
DisjunctionFragment
DisplayableNode
Distinct
DistinctRootEntityResultTransformer
Dom4jAccessor
Dom4jAccessor.AttributeGetter
Dom4jAccessor.AttributeSetter
Dom4jAccessor.Dom4jGetter
Dom4jAccessor.Dom4jSetter
Dom4jAccessor.ElementAttributeGetter
Dom4jAccessor.ElementAttributeSetter
Dom4jAccessor.ElementGetter
Dom4jAccessor.ElementSetter
Dom4jAccessor.TextGetter
Dom4jAccessor.TextSetter
Dom4jComponentTuplizer
Dom4jEntityTuplizer
Dom4jInstantiator
Dom4jLazyInitializer
Dom4jProxy
Dom4jProxyFactory
DotNode
DoubleType
DriverManagerConnectionProvider
DuplicateMappingException
DynamicMapComponentTuplizer
DynamicMapEntityTuplizer
DynamicMapInstantiator
EhCache
EhCacheProvider
ElementPropertyMapping
ElementWrapper
EmbeddedComponentType
EmbeddedPropertyAccessor
EmbeddedPropertyAccessor.EmbeddedGetter
EmbeddedPropertyAccessor.EmbeddedSetter
EmptyExpression
EmptyInterceptor
EmptyIterator
EnhancedUserType
EntityAction
EntityAliases
EntityDeleteAction
EntityEntityModeToTuplizerMapping
EntityEntry
EntityFetchReturn
EntityIdentityInsertAction
EntityInsertAction
EntityJoinWalker
EntityKey
EntityLoader
EntityMetamodel
EntityMode
EntityModeToTuplizerMapping
EntityNotFoundDelegate
EntityPersister
EntityStatistics
EntityTuplizer
EntityType
EntityUniqueKey
EntityUpdateAction
Environment
EqualsHelper
ErrorCounter
ErrorReporter
EventListeners
EventSource
EvictEvent
EvictEventListener
EvictVisitor
Example
Example.PropertySelector
ExceptionUtils
Executable
ExecuteUpdateResultCheckStyle
ExistsSubqueryExpression
Expectation
Expectations
Expectations.BasicExpectation
Expectations.BasicParamExpectation
ExpectedTypeAwareNode
ExplicitParameterSpecification
Expression
ExtendsQueueEntry
ExternalSessionFactoryConfig
FastClass
FastHashMap
FetchMode
FetchReturn
Fetchable
FetchingScrollableResultsImpl
FieldFilter
FieldFilter
FieldHandled
FieldHandler
FieldInterceptionHelper
FieldInterceptor
FieldInterceptorImpl
FieldInterceptorImpl
FieldTransformer
Filter
FilterDefinition
FilterHelper
FilterImpl
FilterKey
FilterQueryPlan
FilterTranslator
Filterable
FirebirdDialect
FloatType
FlushEntityEvent
FlushEntityEventListener
FlushEvent
FlushEventListener
FlushMode
FlushVisitor
ForUpdateFragment
ForeignGenerator
ForeignKey
ForeignKeyDirection
ForeignKeyMetadata
ForeignKeys
ForeignKeys.Nullifier
Formatter
Formula
FromClause
FromElement
FromParser
FromPathExpressionParser
FromReferenceNode
FrontBaseDialect
GUIDGenerator
GeneratedCollectionAliases
GenericJDBCException
GetGeneratedKeysHelper
Getter
GroupByParser
H2Dialect
HQLQueryPlan
HSQLCaseFragment
HSQLDialect
HSQLDialect.ReadUncommittedLockingStrategy
HashtableCache
HashtableCacheProvider
HavingParser
HbmBinder
Hibernate
HibernateException
HibernateIterator
HibernatePermission
HibernateProxy
HibernateProxyHelper
HibernateService
HibernateServiceMBean
HolderInstantiator
HqlASTFactory
HqlBaseLexer
HqlBaseParser
HqlParser
HqlSqlBaseWalker
HqlSqlTokenTypes
HqlSqlWalker
HqlSqlWalkerNode
HqlToken
HqlTokenTypes
IdentNode
IdentifierBag
IdentifierBagType
IdentifierCollection
IdentifierEqExpression
IdentifierGeneratingInsert
IdentifierGenerationException
IdentifierGenerator
IdentifierGeneratorFactory
IdentifierProjection
IdentifierProperty
IdentifierType
IdentifierValue
IdentityGenerator
IdentityGenerator.BasicDelegate
IdentityGenerator.GetGeneratedKeysDelegate
IdentityGenerator.InsertSelectDelegate
IdentityMap
IdentityMap.IdentityKey
IdentityMap.IdentityMapEntry
IdentitySet
IlikeExpression
ImmutableType
ImpliedFromElement
ImprovedNamingStrategy
InExpression
InFragment
InLogicOperatorNode
IncrementGenerator
Index
IndexBackref
IndexMetadata
IndexNode
IndexPropertyAccessor
IndexPropertyAccessor.IndexSetter
IndexedCollection
InformixDialect
IngresDialect
Initializable
InitializeCollectionEvent
InitializeCollectionEventListener
InitializeableNode
Insert
InsertGeneratedIdentifierDelegate
InsertSelect
InsertSelectIdentityInsert
InsertStatement
InstantiationException
InstantiationOptimizerAdapter
InstantiationOptimizerAdapter
Instantiator
InstrumentTask
InstrumentTask
InstrumentedClassLoader
IntegerType
InterbaseDialect
Interceptor
IntoClause
InvalidMappingException
InvalidPathException
IsolatedWork
Isolater
Isolater.JdbcDelegate
Isolater.JtaDelegate
IteratorImpl
JACCConfiguration
JACCPermissions
JACCPreDeleteEventListener
JACCPreInsertEventListener
JACCPreLoadEventListener
JACCPreUpdateEventListener
JACCSecurityListener
JBossTransactionManagerLookup
JDBCConnectionException
JDBCContext
JDBCContext.Context
JDBCException
JDBCExceptionHelper
JDBCExceptionReporter
JDBCTransaction
JDBCTransactionFactory
JDataStoreDialect
JNDITransactionManagerLookup
JOTMTransactionManagerLookup
JOnASTransactionManagerLookup
JRun4TransactionManagerLookup
JTAHelper
JTASessionContext
JTASessionContext.CleanupSynch
JTATransaction
JTATransactionFactory
JavaConstantNode
JavassistClassTransformer
JavassistHelper
JavassistLazyInitializer
JavassistProxyFactory
JndiBoundTreeCacheProvider
Join
JoinFragment
JoinHelper
JoinProcessor
JoinSequence
JoinSequence.Selector
JoinWalker
Joinable
JoinedIterator
JoinedSubclass
JoinedSubclassEntityPersister
Junction
KeyValue
LazyInitializationException
LazyInitializer
LazyIterator
LazyPropertyInitializer
Lifecycle
LikeExpression
LinkedHashCollectionHelper
List
ListType
LiteralNode
LiteralProcessor
LiteralType
LoadEvent
LoadEventListener
LoadEventListener.LoadType
Loadable
Loader
LocaleType
LockAcquisitionException
LockEvent
LockEventListener
LockMode
Lockable
LockingStrategy
LoggableUserType
LogicalExpression
LongType
ManagedSessionContext
ManyToOne
ManyToOneType
Map
MapAccessor
MapAccessor.MapGetter
MapAccessor.MapSetter
MapLazyInitializer
MapProxy
MapProxyFactory
MapType
Mapping
MappingException
MappingNotFoundException
Mappings
Mappings.ColumnNames
Mappings.TableDescription
MarkerObject
MatchMode
MckoiCaseFragment
MckoiDialect
MergeEvent
MergeEventListener
MessageHelper
MetaAttributable
MetaAttribute
MetaType
MethodNode
MimerSQLDialect
MultiTableDeleteExecutor
MultiTableUpdateExecutor
MultipleHiLoPerTableGenerator
MutableType
MySQL5Dialect
MySQL5InnoDBDialect
MySQLDialect
MySQLInnoDBDialect
MySQLMyISAMDialect
NameGenerator
NamedGeneratedKeysHelper
NamedParameterDescriptor
NamedParameterSpecification
NamedQueryCollectionInitializer
NamedQueryDefinition
NamedQueryLoader
NamedSQLQueryDefinition
NamedSQLQuerySecondPass
NamingHelper
NamingStrategy
NativeSQLQueryCollectionReturn
NativeSQLQueryJoinReturn
NativeSQLQueryNonScalarReturn
NativeSQLQueryPlan
NativeSQLQueryReturn
NativeSQLQueryRootReturn
NativeSQLQueryScalarReturn
NativeSQLQuerySpecification
NaturalIdentifier
Nestable
NestableDelegate
NestableException
NestableRuntimeException
NoArgSQLFunction
NoCacheProvider
NoCachingEnabledException
Node
NodeTraverser
NodeTraverser.VisitationStrategy
NonBatchingBatcher
NonBatchingBatcherFactory
NonScalarReturn
NonUniqueObjectException
NonUniqueResultException
NonstrictReadWriteCache
NoopAccessor
NotEmptyExpression
NotExpression
NotNullExpression
NullExpression
Nullability
NullableType
NvlFunction
OC4JTransactionManagerLookup
OSCache
OSCacheProvider
ObjectDeletedException
ObjectNotFoundException
OnLockVisitor
OnReplicateVisitor
OnUpdateVisitor
OneToMany
OneToManyJoinWalker
OneToManyLoader
OneToManyPersister
OneToOne
OneToOneType
OperatorNode
OptimisticCache
OptimisticCacheSource
OptimisticTreeCache
OptimisticTreeCache.CircumventChecksDataVersion
OptimisticTreeCache.DataVersionAdapter
OptimisticTreeCache.NonLockingDataVersion
OptimisticTreeCacheProvider
Oracle9Dialect
OracleDialect
OracleJoinFragment
Order
OrderByClause
OrderByParser
OrderedMapType
OrderedSetType
OrdinalParameterDescriptor
OrionTransactionManagerLookup
OuterJoinLoadable
OuterJoinLoader
OuterJoinableAssociation
ParamLocationRecognizer
ParamLocationRecognizer.NamedParameterDescription
ParameterBinder
ParameterBinder.NamedParameterSource
ParameterMetadata
ParameterNode
ParameterParser
ParameterParser.Recognizer
ParameterSpecification
ParameterTranslations
ParameterTranslationsImpl
ParameterTranslationsImpl.ParameterInfo
ParameterizedType
ParseErrorHandler
Parser
ParserHelper
PassThroughResultTransformer
PathExpressionParser
PathHelper
PathNode
PersistEvent
PersistEventListener
PersistenceContext
PersistentArrayHolder
PersistentBag
PersistentClass
PersistentClassVisitor
PersistentCollection
PersistentElementHolder
PersistentIdentifierBag
PersistentIdentifierGenerator
PersistentIndexedElementHolder
PersistentIndexedElementHolder.IndexedValue
PersistentList
PersistentListElementHolder
PersistentMap
PersistentMapElementHolder
PersistentObjectException
PersistentSet
PersistentSortedMap
PersistentSortedSet
PersisterFactory
PointbaseDialect
PojoComponentTuplizer
PojoEntityTuplizer
PojoInstantiator
PositionSubstringFunction
PositionalParameterSpecification
PostDeleteEvent
PostDeleteEventListener
PostInsertEvent
PostInsertEventListener
PostInsertIdentifierGenerator
PostInsertIdentityPersister
PostLoadEvent
PostLoadEventListener
PostUpdateEvent
PostUpdateEventListener
PostgreSQLDialect
PreDeleteEvent
PreDeleteEventListener
PreInsertEvent
PreInsertEventListener
PreLoadEvent
PreLoadEventListener
PreUpdateEvent
PreUpdateEventListener
PreprocessingParser
PrimaryKey
PrimitiveArray
PrimitiveType
Printer
ProgressDialect
Projection
ProjectionList
Projections
PropertiesHelper
Property
Property
Property
PropertyAccessException
PropertyAccessor
PropertyAccessorFactory
PropertyExpression
PropertyFactory
PropertyGeneration
PropertyMapping
PropertyNotFoundException
PropertyProjection
PropertySubqueryExpression
PropertyValueException
ProxoolConnectionProvider
ProxyFactory
ProxyFactoryFactory
ProxyFactoryFactoryImpl
ProxyFactoryFactoryImpl
ProxyFactoryFactoryImpl.BasicProxyFactoryImpl
ProxyVisitor
Query
QueryCache
QueryCacheFactory
QueryException
QueryExecutionRequestException
QueryImpl
QueryJoinFragment
QueryKey
QueryLoader
QueryMetadata
QueryNode
QueryParameterException
QueryParameters
QueryPlanCache
QuerySecondPass
QuerySelect
QuerySplitter
QueryStatistics
QuerySyntaxException
QueryTranslator
QueryTranslatorFactory
QueryTranslatorImpl
QueryTranslatorImpl
QueryTranslatorImpl.JavaConstantConverter
Queryable
QueryableCollection
RDMSOS2200Dialect
Range
ReadOnlyCache
ReadWriteCache
ReadWriteCache.Item
ReadWriteCache.Lock
ReadWriteCache.Lockable
ReaderInputStream
ReattachVisitor
ReflectHelper
ReflectionOptimizer
ReflectionOptimizer.AccessOptimizer
ReflectionOptimizer.InstantiationOptimizer
ReflectionOptimizerImpl
ReflectionOptimizerImpl
RefreshEvent
RefreshEventListener
RelationalModel
ReplicateEvent
ReplicateEventListener
ReplicationMode
ResinTransactionManagerLookup
ResolvableNode
RestrictableStatement
Restrictions
ResultSetMappingBinder
ResultSetMappingDefinition
ResultSetMappingSecondPass
ResultSetWrapper
ResultTransformer
Return
ReturnMetadata
RootClass
RootEntityResultTransformer
RootReturn
RowCountProjection
RowSelection
SAPDBDialect
SQLCriterion
SQLCustomQuery
SQLExceptionConverter
SQLExceptionConverterFactory
SQLFunction
SQLFunctionRegistry
SQLFunctionTemplate
SQLGrammarException
SQLLoadable
SQLLoadableCollection
SQLProjection
SQLQuery
SQLQueryImpl
SQLQueryParser
SQLQueryParser.ParameterSubstitutionRecognizer
SQLQueryReturnProcessor
SQLServerDialect
SQLStateConverter
SaveOrUpdateEvent
SaveOrUpdateEventListener
ScalarReturn
SchemaExport
SchemaExportTask
SchemaUpdate
SchemaUpdateTask
SchemaValidator
SchemaValidatorTask
ScrollMode
ScrollableResults
ScrollableResultsImpl
SecondLevelCacheStatistics
SecondPass
Select
SelectClause
SelectExpression
SelectExpressionImpl
SelectExpressionList
SelectFragment
SelectGenerator
SelectGenerator.SelectGeneratorDelegate
SelectLockingStrategy
SelectParser
SelectPathExpressionParser
Selectable
SequenceGenerator
SequenceHiLoGenerator
SequenceIdentityGenerator
SequenceIdentityGenerator.Delegate
SequenceIdentityGenerator.NoCommentsInsert
SerializableBlob
SerializableClob
SerializableProxy
SerializableProxy
SerializableType
SerializationException
SerializationHelper
Session
Session
SessionException
SessionFactory
SessionFactoryAwareNode
SessionFactoryHelper
SessionFactoryImpl
SessionFactoryImplementor
SessionFactoryObjectFactory
SessionFactoryStub
SessionImpl
SessionImplementor
SessionStatistics
SessionStatisticsImpl
Set
SetType
Setter
Settings
SettingsFactory
ShortType
SimpleAuxiliaryDatabaseObject
SimpleExpression
SimpleMRUCache
SimpleProjection
SimpleSelect
SimpleSubqueryExpression
SimpleValue
SingleTableEntityPersister
SingleTableSubclass
SingletonIterator
SizeExpression
SoftLimitMRUCache
SortedMapType
SortedSetType
SpecialOneToOneType
SqlASTFactory
SqlFragment
SqlGenerator
SqlGeneratorBase
SqlNode
SqlTokenTypes
StaleObjectStateException
StaleStateException
StandardProperty
StandardQueryCache
StandardQueryCacheFactory
StandardSQLFunction
StatefulPersistenceContext
StatelessSession
StatelessSessionImpl
Statement
StatementExecutor
Statistics
StatisticsImpl
StatisticsImplementor
StatisticsService
StatisticsServiceMBean
Status
StringHelper
StringType
StructuredCacheEntry
StructuredCollectionCacheEntry
StructuredMapCacheEntry
Subclass
Subqueries
SubqueryExpression
SubselectCollectionLoader
SubselectFetch
SubselectOneToManyLoader
SunONETransactionManagerLookup
SwarmCache
SwarmCacheProvider
Sybase11Dialect
Sybase11JoinFragment
SybaseAnywhereDialect
SybaseDialect
SyntheticAndFactory
Table
TableGenerator
TableHiLoGenerator
TableMetadata
TableOwner
Template
TemplatedViolatedConstraintNameExtracter
TextType
ThreadLocalSessionContext
ThreadLocalSessionContext.CleanupSynch
TimeType
TimeZoneType
TimesTenDialect
TimestampType
Timestamper
ToListResultTransformer
ToOne
TooManyRowsAffectedException
Transaction
TransactionException
TransactionFactory
TransactionFactory.Context
TransactionFactoryFactory
TransactionHelper
TransactionManagerLookup
TransactionManagerLookupFactory
TransactionalCache
Transformers
TransformingClassLoader
TransientObjectException
TreeCache
TreeCacheProvider
TrueFalseType
Tuplizer
TwoPhaseLoad
Type
TypeDef
TypeFactory
TypeMismatchException
TypeNames
TypedValue
UUIDHexGenerator
UnaryArithmeticNode
UnaryLogicOperatorNode
UnaryOperatorNode
UnionSubclass
UnionSubclassEntityPersister
UniqueEntityLoader
UniqueKey
UniqueKeyLoadable
UnresolvableObjectException
UnsavedValueFactory
UnstructuredCacheEntry
Update
UpdateLockingStrategy
UpdateStatement
UpdateTimestampsCache
UserCollectionType
UserSuppliedConnectionProvider
UserType
UserVersionType
Validatable
ValidationFailure
Value
ValueVisitor
VarArgsSQLFunction
VersionProperty
VersionType
VersionTypeSeedParameterSpecification
VersionValue
Versioning
ViolatedConstraintNameExtracter
WebSphereExtendedJTATransactionLookup
WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter
WebSphereTransactionManagerLookup
WeblogicTransactionManagerLookup
WhereParser
WrapVisitor
WrapperBinaryType
WrongClassException
XMLHelper
XMLHelper.ErrorLogger
YesNoType


Constant Field Values (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Constant Field Values

Contents
  • org.hibernate.*
org.hibernate.*

org.hibernate.bytecode.cglib.AccessOptimizerAdapter
public static final String | PROPERTY_GET_EXCEPTION | "exception getting property value with CGLIB (set hibernate.bytecode.use_reflection_optimizer=false for more info)"
public static final String | PROPERTY_SET_EXCEPTION | "exception setting property value with CGLIB (set hibernate.bytecode.use_reflection_optimizer=false for more info)"

org.hibernate.bytecode.javassist.AccessOptimizerAdapter
public static final String | PROPERTY_GET_EXCEPTION | "exception getting property value with Javassist (set hibernate.bytecode.use_reflection_optimizer=false for more info)"
public static final String | PROPERTY_SET_EXCEPTION | "exception setting property value with Javassist (set hibernate.bytecode.use_reflection_optimizer=false for more info)"

org.hibernate.cache.CacheFactory
public static final String | NONSTRICT_READ_WRITE | "nonstrict-read-write"
public static final String | READ_ONLY | "read-only"
public static final String | READ_WRITE | "read-write"
public static final String | TRANSACTIONAL | "transactional"

org.hibernate.cache.OptimisticTreeCacheProvider
public static final String | CONFIG_RESOURCE | "hibernate.cache.opt_tree_cache.config"
public static final String | DEFAULT_CONFIG | "treecache.xml"

org.hibernate.cache.OSCacheProvider
public static final String | OSCACHE_CAPACITY | "capacity"
public static final String | OSCACHE_CRON | "cron"
public static final String | OSCACHE_REFRESH_PERIOD | "refresh.period"

org.hibernate.cache.Timestamper
public static final short ONE_MS 4096

org.hibernate.cache.TreeCacheProvider
public static final String | CONFIG_RESOURCE | "hibernate.cache.tree_cache.config"
public static final String | DEFAULT_CONFIG | "treecache.xml"

org.hibernate.cfg.Environment
public static final String | AUTO_CLOSE_SESSION | "hibernate.transaction.auto_close_session"
public static final String | AUTOCOMMIT | "hibernate.connection.autocommit"
public static final String | BATCH_STRATEGY | "hibernate.jdbc.factory_class"
public static final String | BATCH_VERSIONED_DATA | "hibernate.jdbc.batch_versioned_data"
public static final String | BYTECODE_PROVIDER | "hibernate.bytecode.provider"
public static final String | C3P0_ACQUIRE_INCREMENT | "hibernate.c3p0.acquire_increment"
public static final String | C3P0_IDLE_TEST_PERIOD | "hibernate.c3p0.idle_test_period"
public static final String | C3P0_MAX_SIZE | "hibernate.c3p0.max_size"
public static final String | C3P0_MAX_STATEMENTS | "hibernate.c3p0.max_statements"
public static final String | C3P0_MIN_SIZE | "hibernate.c3p0.min_size"
public static final String | C3P0_TIMEOUT | "hibernate.c3p0.timeout"
public static final String | CACHE_NAMESPACE | "hibernate.cache.jndi"
public static final String | CACHE_PROVIDER | "hibernate.cache.provider_class"
public static final String | CACHE_PROVIDER_CONFIG | "hibernate.cache.provider_configuration_file_resource_path"
public static final String | CACHE_REGION_PREFIX | "hibernate.cache.region_prefix"
public static final String | CONNECTION_PREFIX | "hibernate.connection"
public static final String | CONNECTION_PROVIDER | "hibernate.connection.provider_class"
public static final String | CURRENT_SESSION_CONTEXT_CLASS | "hibernate.current_session_context_class"
public static final String | DATASOURCE | "hibernate.connection.datasource"
public static final String | DEFAULT_BATCH_FETCH_SIZE | "hibernate.default_batch_fetch_size"
public static final String | DEFAULT_CATALOG | "hibernate.default_catalog"
public static final String | DEFAULT_ENTITY_MODE | "hibernate.default_entity_mode"
public static final String | DEFAULT_SCHEMA | "hibernate.default_schema"
public static final String | DIALECT | "hibernate.dialect"
public static final String | DRIVER | "hibernate.connection.driver_class"
public static final String | FLUSH_BEFORE_COMPLETION | "hibernate.transaction.flush_before_completion"
public static final String | FORMAT_SQL | "hibernate.format_sql"
public static final String | GENERATE_STATISTICS | "hibernate.generate_statistics"
public static final String | HBM2DDL_AUTO | "hibernate.hbm2ddl.auto"
public static final String | ISOLATION | "hibernate.connection.isolation"
public static final String | JACC_CONTEXTID | "hibernate.jacc_context_id"
public static final String | JNDI_CLASS | "hibernate.jndi.class"
public static final String | JNDI_PREFIX | "hibernate.jndi"
public static final String | JNDI_URL | "hibernate.jndi.url"
public static final String | JPAQL_STRICT_COMPLIANCE | "hibernate.query.jpaql_strict_compliance"
public static final String | MAX_FETCH_DEPTH | "hibernate.max_fetch_depth"
public static final String | ORDER_UPDATES | "hibernate.order_updates"
public static final String | OUTPUT_STYLESHEET | "hibernate.xml.output_stylesheet"
public static final String | PASS | "hibernate.connection.password"
public static final String | POOL_SIZE | "hibernate.connection.pool_size"
public static final String | PROXOOL_EXISTING_POOL | "hibernate.proxool.existing_pool"
public static final String | PROXOOL_POOL_ALIAS | "hibernate.proxool.pool_alias"
public static final String | PROXOOL_PREFIX | "hibernate.proxool"
public static final String | PROXOOL_PROPERTIES | "hibernate.proxool.properties"
public static final String | PROXOOL_XML | "hibernate.proxool.xml"
public static final String | QUERY_CACHE_FACTORY | "hibernate.cache.query_cache_factory"
public static final String | QUERY_SUBSTITUTIONS | "hibernate.query.substitutions"
public static final String | QUERY_TRANSLATOR | "hibernate.query.factory_class"
public static final String | RELEASE_CONNECTIONS | "hibernate.connection.release_mode"
public static final String | SESSION_FACTORY_NAME | "hibernate.session_factory_name"
public static final String | SHOW_SQL | "hibernate.show_sql"
public static final String | SQL_EXCEPTION_CONVERTER | "hibernate.jdbc.sql_exception_converter"
public static final String | STATEMENT_BATCH_SIZE | "hibernate.jdbc.batch_size"
public static final String | STATEMENT_FETCH_SIZE | "hibernate.jdbc.fetch_size"
public static final String | TRANSACTION_MANAGER_STRATEGY | "hibernate.transaction.manager_lookup_class"
public static final String | TRANSACTION_STRATEGY | "hibernate.transaction.factory_class"
public static final String | URL | "hibernate.connection.url"
public static final String | USE_GET_GENERATED_KEYS | "hibernate.jdbc.use_get_generated_keys"
public static final String | USE_IDENTIFIER_ROLLBACK | "hibernate.use_identifier_rollback"
public static final String | USE_MINIMAL_PUTS | "hibernate.cache.use_minimal_puts"
public static final String | USE_QUERY_CACHE | "hibernate.cache.use_query_cache"
public static final String | USE_REFLECTION_OPTIMIZER | "hibernate.bytecode.use_reflection_optimizer"
public static final String | USE_SCROLLABLE_RESULTSET | "hibernate.jdbc.use_scrollable_resultset"
public static final String | USE_SECOND_LEVEL_CACHE | "hibernate.cache.use_second_level_cache"
public static final String | USE_SQL_COMMENTS | "hibernate.use_sql_comments"
public static final String | USE_STREAMS_FOR_BINARY | "hibernate.jdbc.use_streams_for_binary"
public static final String | USE_STRUCTURED_CACHE | "hibernate.cache.use_structured_entries"
public static final String | USER | "hibernate.connection.username"
public static final String | USER_TRANSACTION | "jta.UserTransaction"
public static final String | VERSION | "3.2.0"
public static final String | WRAP_RESULT_SETS | "hibernate.jdbc.wrap_result_sets"

org.hibernate.classic.Lifecycle
public static final boolean | NO_VETO | false
public static final boolean | VETO | true

org.hibernate.criterion.CriteriaSpecification
public static final int | FULL_JOIN | 4
public static final int | INNER_JOIN | 0
public static final int | LEFT_JOIN | 1
public static final String | ROOT_ALIAS | "this"

org.hibernate.dialect.Dialect
public static final String | CLOSED_QUOTE | "`\"]"
public static final String | QUOTE | "`\"["

org.hibernate.engine.Cascade
public static final int | AFTER_EVICT | 0
public static final int | AFTER_INSERT_BEFORE_DELETE | 1
public static final int | AFTER_INSERT_BEFORE_DELETE_VIA_COLLECTION | 3
public static final int | AFTER_LOCK | 0
public static final int | AFTER_UPDATE | 0
public static final int | BEFORE_FLUSH | 0
public static final int | BEFORE_INSERT_AFTER_DELETE | 2
public static final int | BEFORE_MERGE | 0
public static final int | BEFORE_REFRESH | 0

org.hibernate.engine.Versioning
public static final int | OPTIMISTIC_LOCK_ALL | 2
public static final int | OPTIMISTIC_LOCK_DIRTY | 1
public static final int | OPTIMISTIC_LOCK_NONE | -1
public static final int | OPTIMISTIC_LOCK_VERSION | 0

org.hibernate.event.def.AbstractSaveEventListener
protected static final int | DELETED | 3
protected static final int | DETACHED | 2
protected static final int | PERSISTENT | 0
protected static final int | TRANSIENT | 1

org.hibernate.hql.QueryTranslator
public static final String | ERROR_CANNOT_DETERMINE_TYPE | "Could not determine type of: "
public static final String | ERROR_CANNOT_FETCH_WITH_ITERATE | "fetch may not be used with scroll() or iterate()"
public static final String | ERROR_CANNOT_FORMAT_LITERAL | "Could not format constant value to SQL literal: "
public static final String | ERROR_NAMED_PARAMETER_DOES_NOT_APPEAR | "Named parameter does not appear in Query: "

org.hibernate.hql.antlr.HqlSqlTokenTypes
public static final int | AGGREGATE | 68
public static final int | ALIAS | 69
public static final int | ALIAS_REF | 134
public static final int | ALL | 4
public static final int | AND | 6
public static final int | ANY | 5
public static final int | AS | 7
public static final int | ASCENDING | 8
public static final int | AVG | 9
public static final int | BETWEEN | 10
public static final int | BOGUS | 143
public static final int | BOTH | 61
public static final int | CASE | 54
public static final int | CASE2 | 71
public static final int | CLASS | 11
public static final int | CLOSE | 99
public static final int | CLOSE_BRACKET | 115
public static final int | COLON | 116
public static final int | COMMA | 96
public static final int | CONCAT | 109
public static final int | CONSTANT | 91
public static final int | CONSTRUCTOR | 70
public static final int | COUNT | 12
public static final int | DELETE | 13
public static final int | DESCENDING | 14
public static final int | DISTINCT | 16
public static final int | DIV | 113
public static final int | DOT | 15
public static final int | ELEMENTS | 17
public static final int | ELSE | 56
public static final int | EMPTY | 62
public static final int | END | 55
public static final int | EOF | 1
public static final int | EQ | 97
public static final int | ESCAPE | 18
public static final int | ESCqs | 123
public static final int | EXISTS | 19
public static final int | EXPONENT | 126
public static final int | EXPR_LIST | 72
public static final int | FALSE | 20
public static final int | FETCH | 21
public static final int | FILTER_ENTITY | 73
public static final int | FILTERS | 140
public static final int | FLOAT_SUFFIX | 127
public static final int | FROM | 22
public static final int | FROM_FRAGMENT | 128
public static final int | FULL | 23
public static final int | GE | 108
public static final int | GROUP | 24
public static final int | GT | 106
public static final int | HAVING | 25
public static final int | HEX_DIGIT | 125
public static final int | ID_LETTER | 122
public static final int | ID_START_LETTER | 121
public static final int | IDENT | 120
public static final int | IMPLIED_FROM | 129
public static final int | IN | 26
public static final int | IN_LIST | 74
public static final int | INDEX_OP | 75
public static final int | INDICES | 27
public static final int | INNER | 28
public static final int | INSERT | 29
public static final int | INTO | 30
public static final int | IS | 31
public static final int | IS_NOT_NULL | 76
public static final int | IS_NULL | 77
public static final int | JAVA_CONSTANT | 95
public static final int | JOIN | 32
public static final int | JOIN_FRAGMENT | 130
public static final int | LE | 107
public static final int | LEADING | 63
public static final int | LEFT | 33
public static final int | LEFT_OUTER | 132
public static final int | LIKE | 34
public static final int | LITERAL_ascending | 101
public static final int | LITERAL_by | 100
public static final int | LITERAL_descending | 102
public static final int | LT | 105
public static final int | MAX | 35
public static final int | MEMBER | 64
public static final int | METHOD_CALL | 78
public static final int | METHOD_NAME | 141
public static final int | MIN | 36
public static final int | MINUS | 111
public static final int | NAMED_PARAM | 142
public static final int | NE | 103
public static final int | NEW | 37
public static final int | NOT | 38
public static final int | NOT_BETWEEN | 79
public static final int | NOT_IN | 80
public static final int | NOT_LIKE | 81
public static final int | NULL | 39
public static final int | NULL_TREE_LOOKAHEAD | 3
public static final int | NUM_DOUBLE | 92
public static final int | NUM_FLOAT | 93
public static final int | NUM_INT | 118
public static final int | NUM_LONG | 94
public static final int | OBJECT | 65
public static final int | OF | 66
public static final int | ON | 59
public static final int | OPEN | 98
public static final int | OPEN_BRACKET | 114
public static final int | OR | 40
public static final int | ORDER | 41
public static final int | ORDER_ELEMENT | 82
public static final int | OUTER | 42
public static final int | PARAM | 117
public static final int | PLUS | 110
public static final int | PROPERTIES | 43
public static final int | PROPERTY_REF | 135
public static final int | QUERY | 83
public static final int | QUOTED_STRING | 119
public static final int | RANGE | 84
public static final int | RIGHT | 44
public static final int | RIGHT_OUTER | 133
public static final int | ROW_STAR | 85
public static final int | SELECT | 45
public static final int | SELECT_CLAUSE | 131
public static final int | SELECT_COLUMNS | 137
public static final int | SELECT_EXPR | 138
public static final int | SELECT_FROM | 86
public static final int | SET | 46
public static final int | SOME | 47
public static final int | SQL_NE | 104
public static final int | SQL_TOKEN | 136
public static final int | STAR | 112
public static final int | SUM | 48
public static final int | THEN | 57
public static final int | THETA_JOINS | 139
public static final int | TRAILING | 67
public static final int | TRUE | 49
public static final int | UNARY_MINUS | 87
public static final int | UNARY_PLUS | 88
public static final int | UNION | 50
public static final int | UPDATE | 51
public static final int | VECTOR_EXPR | 89
public static final int | VERSIONED | 52
public static final int | WEIRD_IDENT | 90
public static final int | WHEN | 58
public static final int | WHERE | 53
public static final int | WITH | 60
public static final int | WS | 124

org.hibernate.hql.antlr.HqlTokenTypes
public static final int | AGGREGATE | 68
public static final int | ALIAS | 69
public static final int | ALL | 4
public static final int | AND | 6
public static final int | ANY | 5
public static final int | AS | 7
public static final int | ASCENDING | 8
public static final int | AVG | 9
public static final int | BETWEEN | 10
public static final int | BOTH | 61
public static final int | CASE | 54
public static final int | CASE2 | 71
public static final int | CLASS | 11
public static final int | CLOSE | 99
public static final int | CLOSE_BRACKET | 115
public static final int | COLON | 116
public static final int | COMMA | 96
public static final int | CONCAT | 109
public static final int | CONSTANT | 91
public static final int | CONSTRUCTOR | 70
public static final int | COUNT | 12
public static final int | DELETE | 13
public static final int | DESCENDING | 14
public static final int | DISTINCT | 16
public static final int | DIV | 113
public static final int | DOT | 15
public static final int | ELEMENTS | 17
public static final int | ELSE | 56
public static final int | EMPTY | 62
public static final int | END | 55
public static final int | EOF | 1
public static final int | EQ | 97
public static final int | ESCAPE | 18
public static final int | ESCqs | 123
public static final int | EXISTS | 19
public static final int | EXPONENT | 126
public static final int | EXPR_LIST | 72
public static final int | FALSE | 20
public static final int | FETCH | 21
public static final int | FILTER_ENTITY | 73
public static final int | FLOAT_SUFFIX | 127
public static final int | FROM | 22
public static final int | FULL | 23
public static final int | GE | 108
public static final int | GROUP | 24
public static final int | GT | 106
public static final int | HAVING | 25
public static final int | HEX_DIGIT | 125
public static final int | ID_LETTER | 122
public static final int | ID_START_LETTER | 121
public static final int | IDENT | 120
public static final int | IN | 26
public static final int | IN_LIST | 74
public static final int | INDEX_OP | 75
public static final int | INDICES | 27
public static final int | INNER | 28
public static final int | INSERT | 29
public static final int | INTO | 30
public static final int | IS | 31
public static final int | IS_NOT_NULL | 76
public static final int | IS_NULL | 77
public static final int | JAVA_CONSTANT | 95
public static final int | JOIN | 32
public static final int | LE | 107
public static final int | LEADING | 63
public static final int | LEFT | 33
public static final int | LIKE | 34
public static final int | LITERAL_ascending | 101
public static final int | LITERAL_by | 100
public static final int | LITERAL_descending | 102
public static final int | LT | 105
public static final int | MAX | 35
public static final int | MEMBER | 64
public static final int | METHOD_CALL | 78
public static final int | MIN | 36
public static final int | MINUS | 111
public static final int | NE | 103
public static final int | NEW | 37
public static final int | NOT | 38
public static final int | NOT_BETWEEN | 79
public static final int | NOT_IN | 80
public static final int | NOT_LIKE | 81
public static final int | NULL | 39
public static final int | NULL_TREE_LOOKAHEAD | 3
public static final int | NUM_DOUBLE | 92
public static final int | NUM_FLOAT | 93
public static final int | NUM_INT | 118
public static final int | NUM_LONG | 94
public static final int | OBJECT | 65
public static final int | OF | 66
public static final int | ON | 59
public static final int | OPEN | 98
public static final int | OPEN_BRACKET | 114
public static final int | OR | 40
public static final int | ORDER | 41
public static final int | ORDER_ELEMENT | 82
public static final int | OUTER | 42
public static final int | PARAM | 117
public static final int | PLUS | 110
public static final int | PROPERTIES | 43
public static final int | QUERY | 83
public static final int | QUOTED_STRING | 119
public static final int | RANGE | 84
public static final int | RIGHT | 44
public static final int | ROW_STAR | 85
public static final int | SELECT | 45
public static final int | SELECT_FROM | 86
public static final int | SET | 46
public static final int | SOME | 47
public static final int | SQL_NE | 104
public static final int | STAR | 112
public static final int | SUM | 48
public static final int | THEN | 57
public static final int | TRAILING | 67
public static final int | TRUE | 49
public static final int | UNARY_MINUS | 87
public static final int | UNARY_PLUS | 88
public static final int | UNION | 50
public static final int | UPDATE | 51
public static final int | VECTOR_EXPR | 89
public static final int | VERSIONED | 52
public static final int | WEIRD_IDENT | 90
public static final int | WHEN | 58
public static final int | WHERE | 53
public static final int | WITH | 60
public static final int | WS | 124

org.hibernate.hql.antlr.SqlTokenTypes
public static final int | AGGREGATE | 68
public static final int | ALIAS | 69
public static final int | ALIAS_REF | 134
public static final int | ALL | 4
public static final int | AND | 6
public static final int | ANY | 5
public static final int | AS | 7
public static final int | ASCENDING | 8
public static final int | AVG | 9
public static final int | BETWEEN | 10
public static final int | BOGUS | 143
public static final int | BOTH | 61
public static final int | CASE | 54
public static final int | CASE2 | 71
public static final int | CLASS | 11
public static final int | CLOSE | 99
public static final int | CLOSE_BRACKET | 115
public static final int | COLON | 116
public static final int | COMMA | 96
public static final int | CONCAT | 109
public static final int | CONSTANT | 91
public static final int | CONSTRUCTOR | 70
public static final int | COUNT | 12
public static final int | DELETE | 13
public static final int | DESCENDING | 14
public static final int | DISTINCT | 16
public static final int | DIV | 113
public static final int | DOT | 15
public static final int | ELEMENTS | 17
public static final int | ELSE | 56
public static final int | EMPTY | 62
public static final int | END | 55
public static final int | EOF | 1
public static final int | EQ | 97
public static final int | ESCAPE | 18
public static final int | ESCqs | 123
public static final int | EXISTS | 19
public static final int | EXPONENT | 126
public static final int | EXPR_LIST | 72
public static final int | FALSE | 20
public static final int | FETCH | 21
public static final int | FILTER_ENTITY | 73
public static final int | FILTERS | 140
public static final int | FLOAT_SUFFIX | 127
public static final int | FROM | 22
public static final int | FROM_FRAGMENT | 128
public static final int | FULL | 23
public static final int | GE | 108
public static final int | GROUP | 24
public static final int | GT | 106
public static final int | HAVING | 25
public static final int | HEX_DIGIT | 125
public static final int | ID_LETTER | 122
public static final int | ID_START_LETTER | 121
public static final int | IDENT | 120
public static final int | IMPLIED_FROM | 129
public static final int | IN | 26
public static final int | IN_LIST | 74
public static final int | INDEX_OP | 75
public static final int | INDICES | 27
public static final int | INNER | 28
public static final int | INSERT | 29
public static final int | INTO | 30
public static final int | IS | 31
public static final int | IS_NOT_NULL | 76
public static final int | IS_NULL | 77
public static final int | JAVA_CONSTANT | 95
public static final int | JOIN | 32
public static final int | JOIN_FRAGMENT | 130
public static final int | LE | 107
public static final int | LEADING | 63
public static final int | LEFT | 33
public static final int | LEFT_OUTER | 132
public static final int | LIKE | 34
public static final int | LITERAL_ascending | 101
public static final int | LITERAL_by | 100
public static final int | LITERAL_descending | 102
public static final int | LT | 105
public static final int | MAX | 35
public static final int | MEMBER | 64
public static final int | METHOD_CALL | 78
public static final int | METHOD_NAME | 141
public static final int | MIN | 36
public static final int | MINUS | 111
public static final int | NAMED_PARAM | 142
public static final int | NE | 103
public static final int | NEW | 37
public static final int | NOT | 38
public static final int | NOT_BETWEEN | 79
public static final int | NOT_IN | 80
public static final int | NOT_LIKE | 81
public static final int | NULL | 39
public static final int | NULL_TREE_LOOKAHEAD | 3
public static final int | NUM_DOUBLE | 92
public static final int | NUM_FLOAT | 93
public static final int | NUM_INT | 118
public static final int | NUM_LONG | 94
public static final int | OBJECT | 65
public static final int | OF | 66
public static final int | ON | 59
public static final int | OPEN | 98
public static final int | OPEN_BRACKET | 114
public static final int | OR | 40
public static final int | ORDER | 41
public static final int | ORDER_ELEMENT | 82
public static final int | OUTER | 42
public static final int | PARAM | 117
public static final int | PLUS | 110
public static final int | PROPERTIES | 43
public static final int | PROPERTY_REF | 135
public static final int | QUERY | 83
public static final int | QUOTED_STRING | 119
public static final int | RANGE | 84
public static final int | RIGHT | 44
public static final int | RIGHT_OUTER | 133
public static final int | ROW_STAR | 85
public static final int | SELECT | 45
public static final int | SELECT_CLAUSE | 131
public static final int | SELECT_COLUMNS | 137
public static final int | SELECT_EXPR | 138
public static final int | SELECT_FROM | 86
public static final int | SET | 46
public static final int | SOME | 47
public static final int | SQL_NE | 104
public static final int | SQL_NODE | 144
public static final int | SQL_TOKEN | 136
public static final int | STAR | 112
public static final int | SUM | 48
public static final int | THEN | 57
public static final int | THETA_JOINS | 139
public static final int | TRAILING | 67
public static final int | TRUE | 49
public static final int | UNARY_MINUS | 87
public static final int | UNARY_PLUS | 88
public static final int | UNION | 50
public static final int | UPDATE | 51
public static final int | VECTOR_EXPR | 89
public static final int | VERSIONED | 52
public static final int | WEIRD_IDENT | 90
public static final int | WHEN | 58
public static final int | WHERE | 53
public static final int | WITH | 60
public static final int | WS | 124

org.hibernate.hql.ast.tree.FromClause
public static final int ROOT_LEVEL 1

org.hibernate.hql.ast.tree.FromReferenceNode
public static final int ROOT_LEVEL 0

org.hibernate.hql.ast.util.LiteralProcessor
public static final int | APPROXIMATE | 1
public static final int | EXACT | 0

org.hibernate.hql.classic.ParserHelper
public static final String | HQL_SEPARATORS | " \n\r\f\t,()=<>&|+-=/*\'^![]#~\\"
public static final String | HQL_VARIABLE_PREFIX | ":"
public static final String | PATH_SEPARATORS | "."

org.hibernate.id.IdentifierGenerator
public static final String ENTITY_NAME "entity_name"

org.hibernate.id.MultipleHiLoPerTableGenerator
public static final String | DEFAULT_TABLE | "hibernate_sequences"
public static final String | ID_TABLE | "table"
public static final String | MAX_LO | "max_lo"
public static final String | PK_COLUMN_NAME | "primary_key_column"
public static final String | PK_LENGTH_NAME | "primary_key_length"
public static final String | PK_VALUE_NAME | "primary_key_value"
public static final String | VALUE_COLUMN_NAME | "value_column"

org.hibernate.id.PersistentIdentifierGenerator
public static final String | CATALOG | "catalog"
public static final String | PK | "target_column"
public static final String | SCHEMA | "schema"
public static final String | TABLE | "target_table"
public static final String | TABLES | "identity_tables"

org.hibernate.id.SequenceGenerator
public static final String | PARAMETERS | "parameters"
public static final String | SEQUENCE | "sequence"

org.hibernate.id.SequenceHiLoGenerator
public static final String MAX_LO "max_lo"

org.hibernate.id.TableGenerator
public static final String | COLUMN | "column"
public static final String | DEFAULT_COLUMN_NAME | "next_hi"
public static final String | DEFAULT_TABLE_NAME | "hibernate_unique_key"
public static final String | TABLE | "table"

org.hibernate.id.TableHiLoGenerator
public static final String MAX_LO "max_lo"

org.hibernate.impl.FilterImpl
public static final String MARKER "$FILTER_PLACEHOLDER$"

org.hibernate.jdbc.Expectations
public static final int | USUAL_EXPECTED_COUNT | 1
public static final int | USUAL_PARAM_POSITION | 1

org.hibernate.loader.criteria.CriteriaQueryTranslator
public static final String ROOT_SQL_ALIAS "this_"

org.hibernate.mapping.Collection
public static final String | DEFAULT_ELEMENT_COLUMN_NAME | "elt"
public static final String | DEFAULT_KEY_COLUMN_NAME | "id"

org.hibernate.mapping.Column
public static final int | DEFAULT_LENGTH | 255
public static final int | DEFAULT_PRECISION | 19
public static final int | DEFAULT_SCALE | 2

org.hibernate.mapping.IdentifierCollection
public static final String DEFAULT_IDENTIFIER_COLUMN_NAME "id"

org.hibernate.mapping.IndexedCollection
public static final String DEFAULT_INDEX_COLUMN_NAME "idx"

org.hibernate.mapping.PersistentClass
public static final String | NOT_NULL_DISCRIMINATOR_MAPPING | "not null"
public static final String | NULL_DISCRIMINATOR_MAPPING | "null"

org.hibernate.mapping.RootClass
public static final String | DEFAULT_DISCRIMINATOR_COLUMN_NAME | "class"
public static final String | DEFAULT_IDENTIFIER_COLUMN_NAME | "id"

org.hibernate.persister.collection.CollectionPropertyNames
public static final String | COLLECTION_ELEMENTS | "elements"
public static final String | COLLECTION_INDEX | "index"
public static final String | COLLECTION_INDICES | "indices"
public static final String | COLLECTION_MAX_ELEMENT | "maxElement"
public static final String | COLLECTION_MAX_INDEX | "maxIndex"
public static final String | COLLECTION_MIN_ELEMENT | "minElement"
public static final String | COLLECTION_MIN_INDEX | "minIndex"
public static final String | COLLECTION_SIZE | "size"

org.hibernate.persister.entity.AbstractEntityPersister
public static final String ENTITY_CLASS "class"

org.hibernate.persister.entity.EntityPersister
public static final String ENTITY_ID "id"

org.hibernate.persister.entity.Loadable
public static final String ROWID_ALIAS "rowid_"

org.hibernate.secure.HibernatePermission
public static final String | ANY | "*"
public static final String | DELETE | "delete"
public static final String | INSERT | "insert"
public static final String | READ | "read"
public static final String | UPDATE | "update"

org.hibernate.sql.InFragment
public static final String | NOT_NULL | "not null"
public static final String | NULL | "null"

org.hibernate.sql.JoinFragment
public static final int | FULL_JOIN | 4
public static final int | INNER_JOIN | 0
public static final int | LEFT_OUTER_JOIN | 1
public static final int | RIGHT_OUTER_JOIN | 2

org.hibernate.sql.Template
public static final String TEMPLATE "$PlaceHolder$"

org.hibernate.tuple.DynamicMapInstantiator
public static final String KEY "$type$"

org.hibernate.util.JDBCExceptionReporter
public static final String | DEFAULT_EXCEPTION_MSG | "SQL Exception"
public static final String | DEFAULT_WARNING_MSG | "SQL Warning"

org.hibernate.util.SimpleMRUCache
public static final int DEFAULT_STRONG_REF_COUNT 128

org.hibernate.util.SoftLimitMRUCache
public static final int DEFAULT_STRONG_REF_COUNT 128

org.hibernate.util.StringHelper
public static final String WHITESPACE " \n\r\f\t"

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Deprecated List (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Deprecated API

Deprecated Fields
org.hibernate.cache.TreeCacheProvider.CONFIG_RESOURCE
use org.hibernate.cfg.Environment.CACHE_PROVIDER_CONFIG
org.hibernate.cache.OptimisticTreeCacheProvider.CONFIG_RESOURCE
use Environment.CACHE_PROVIDER_CONFIG
org.hibernate.FetchMode.EAGER
use FetchMode.JOIN
org.hibernate.FetchMode.LAZY
use FetchMode.SELECT
org.hibernate.FlushMode.NEVER
use FlushMode.MANUAL instead.

Deprecated Methods
org.hibernate.classic.Session.createSQLQuery(String, String[], Class[])
will be replaced with a more Query like interface in later release
org.hibernate.classic.Session.createSQLQuery(String, String, Class)
will be replaced with a more Query like interface in later release
org.hibernate.classic.Session.delete(String)
consider using HQL delete statements
org.hibernate.classic.Session.delete(String, Object[], Type[])
consider using HQL delete statements
org.hibernate.classic.Session.delete(String, Object, Type)
consider using HQL delete statements
org.hibernate.classic.Session.filter(Object, String)
use Session.createFilter(Object, String).Query.list()
org.hibernate.classic.Session.filter(Object, String, Object[], Type[])
use Session.createFilter(Object, String).setXYZ.Query.list()
org.hibernate.classic.Session.filter(Object, String, Object, Type)
use Session.createFilter(Object, String).setXYZ.Query.list()
org.hibernate.classic.Session.find(String)
use Session.createQuery(java.lang.String).Query.list()
org.hibernate.classic.Session.find(String, Object[], Type[])
use Session.createQuery(java.lang.String).setXYZ.Query.list()
org.hibernate.classic.Session.find(String, Object, Type)
use Session.createQuery(java.lang.String).setXYZ.Query.list()
org.hibernate.hql.ast.tree.ConstructorNode.getDataType()
(tell clover to ignore this method)
org.hibernate.classic.Session.iterate(String)
use Session.createQuery(java.lang.String).Query.iterate()
org.hibernate.classic.Session.iterate(String, Object[], Type[])
use Session.createQuery(java.lang.String).setXYZ.Query.iterate()
org.hibernate.classic.Session.iterate(String, Object, Type)
use Session.createQuery(java.lang.String).setXYZ.Query.iterate()
org.hibernate.Session.reconnect()
Manual reconnection is only needed in the case of application-supplied connections, in which case the Session.reconnect(java.sql.Connection) for should be used.
org.hibernate.sql.Template.renderWhereStringTemplate(String, String, Dialect)
Only intended for annotations usage; use Template.renderWhereStringTemplate(String, String, Dialect, SQLFunctionRegistry) instead
org.hibernate.classic.Session.save(Object, Serializable)
declare identifier properties for all classes
org.hibernate.classic.Session.save(String, Object, Serializable)
declare identifier properties for all classes
org.hibernate.classic.Session.saveOrUpdateCopy(Object)
use Session.merge(Object)
org.hibernate.classic.Session.saveOrUpdateCopy(Object, Serializable)
with no replacement
org.hibernate.classic.Session.saveOrUpdateCopy(String, Object)
use Session.merge(String, Object)
org.hibernate.classic.Session.saveOrUpdateCopy(String, Object, Serializable)
with no replacement
org.hibernate.proxy.dom4j.Dom4jProxy.setAttributeValue(QName, String)
org.hibernate.tuple.ElementWrapper.setAttributeValue(QName, String)
org.hibernate.proxy.dom4j.Dom4jProxy.setAttributeValue(String, String)
org.hibernate.tuple.ElementWrapper.setAttributeValue(String, String)
org.hibernate.classic.Session.update(Object, Serializable)
declare identifier properties for all classes
org.hibernate.classic.Session.update(String, Object, Serializable)
declare identifier properties for all classes

Deprecated Constructors
org.hibernate.tool.hbm2ddl.SchemaExport(Configuration, Properties)
properties may be specified via the Configuration object

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


API Help (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Exceptions
  • Errors

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Hibernate API Documentation

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Index (Hibernate API Documentation)

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

PREV NEXT

FRAMES NO FRAMES

A B C D E F G H I J K L M N O P Q R S T U V W X Y _

A

AFTER_EVICT - Static variable in class org.hibernate.engine.Cascade
A cascade point that occurs just after eviction of the parent entity from the session cache
AFTER_INSERT_BEFORE_DELETE - Static variable in class org.hibernate.engine.Cascade
A cascade point that occurs just after the insertion of the parent entity and just before deletion
AFTER_INSERT_BEFORE_DELETE_VIA_COLLECTION - Static variable in class org.hibernate.engine.Cascade
A cascade point that occurs just after the insertion of the parent entity and just before deletion, inside a collection
AFTER_LOCK - Static variable in class org.hibernate.engine.Cascade
A cascade point that occurs just after refreshing a parent entity
AFTER_STATEMENT - Static variable in class org.hibernate.ConnectionReleaseMode
Indicates that JDBC connection should be aggressively released after each SQL statement is executed.
AFTER_TRANSACTION - Static variable in class org.hibernate.ConnectionReleaseMode
Indicates that JDBC connections should be released after each transaction ends (works with both JTA-registered synch and HibernateTransaction API).
AFTER_UPDATE - Static variable in class org.hibernate.engine.Cascade
A cascade point that occurs just after update of the parent entity
AGGREGATE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

AGGREGATE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

AGGREGATE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ALIAS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ALIAS - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ALIAS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ALIAS_REF - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ALIAS_REF - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ALIAS_TO_ENTITY_MAP - Static variable in interface org.hibernate.criterion.CriteriaSpecification
Each row of results is a Map from alias to entity instance
ALIAS_TO_ENTITY_MAP - Static variable in class org.hibernate.transform.Transformers
Each row of results is a Map from alias to values/entities
ALL - Static variable in class org.hibernate.engine.CascadeStyle
save / delete / update / evict / lock / replicate / merge / persist
ALL - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ALL - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ALL - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ALL_DELETE_ORPHAN - Static variable in class org.hibernate.engine.CascadeStyle
save / delete / update / evict / lock / replicate / merge / persist + delete orphans
ALWAYS - Static variable in class org.hibernate.FlushMode
The Session is flushed before every query.
ALWAYS - Static variable in class org.hibernate.mapping.PropertyGeneration
Values for this property are generated by the database on both insert and update.
AND - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

AND - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

AND - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ANSICaseFragment - class org.hibernate.sql.ANSICaseFragment.
An ANSI SQL CASE expression.
ANSICaseFragment() - Constructor for class org.hibernate.sql.ANSICaseFragment

ANSIJoinFragment - class org.hibernate.sql.ANSIJoinFragment.
An ANSI-style join
ANSIJoinFragment() - Constructor for class org.hibernate.sql.ANSIJoinFragment

ANY - Static variable in class org.hibernate.engine.IdentifierValue
Always assume the transient instance is newly instantiated
ANY - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ANY - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ANY - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ANY - Static variable in class org.hibernate.secure.HibernatePermission

ANYWHERE - Static variable in class org.hibernate.criterion.MatchMode
Match the pattern anywhere in the string
APPROXIMATE - Static variable in class org.hibernate.hql.ast.util.LiteralProcessor
Indicates that Float and Double literal values should be treated using the SQL "approximate" format (i.e., '1E-3')
AS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

AS - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

AS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ASCENDING - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ASCENDING - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ASCENDING - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ASTAppender - class org.hibernate.hql.ast.util.ASTAppender.
Appends child nodes to a parent efficiently.
ASTAppender(ASTFactory, AST) - Constructor for class org.hibernate.hql.ast.util.ASTAppender

ASTAppender(AST) - Constructor for class org.hibernate.hql.ast.util.ASTAppender

ASTIterator - class org.hibernate.hql.ast.util.ASTIterator.
Depth first iteration of an ANTLR AST.
ASTIterator(AST) - Constructor for class org.hibernate.hql.ast.util.ASTIterator

ASTParentsFirstIterator - class org.hibernate.hql.ast.util.ASTParentsFirstIterator.
Depth first iteration of an ANTLR AST.
ASTParentsFirstIterator(AST) - Constructor for class org.hibernate.hql.ast.util.ASTParentsFirstIterator

ASTPrinter - class org.hibernate.hql.ast.util.ASTPrinter.
An 'ASCII art' AST printer for debugging ANTLR grammars.
ASTPrinter(Class) - Constructor for class org.hibernate.hql.ast.util.ASTPrinter
Constructs an org.hibernate.hql.antlr.ASTPrinter, given the class that contains the token type constants (typically the '{grammar}TokenTypes' interface generated by ANTLR).
ASTQueryTranslatorFactory - class org.hibernate.hql.ast.ASTQueryTranslatorFactory.
Generates translators which uses the Antlr-based parser to perform the translation.
ASTQueryTranslatorFactory() - Constructor for class org.hibernate.hql.ast.ASTQueryTranslatorFactory

ASTUtil - class org.hibernate.hql.ast.util.ASTUtil.
Provides utility methods for AST traversal and manipulation.
ASTUtil.FilterPredicate - interface org.hibernate.hql.ast.util.ASTUtil.FilterPredicate.
Filters nodes out of a tree.
ASTUtil.IncludePredicate - class org.hibernate.hql.ast.util.ASTUtil.IncludePredicate.
A predicate that uses inclusion, rather than exclusion semantics.
ASTUtil.IncludePredicate() - Constructor for class org.hibernate.hql.ast.util.ASTUtil.IncludePredicate

AUTO - Static variable in class org.hibernate.FlushMode
The Session is sometimes flushed before query execution in order to ensure that queries never return stale state.
AUTOCOMMIT - Static variable in class org.hibernate.cfg.Environment
JDBC autocommit mode
AUTO_CLOSE_SESSION - Static variable in class org.hibernate.cfg.Environment
Enable automatic session close at end of transaction
AVG - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

AVG - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

AVG - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

AbstractAuxiliaryDatabaseObject - class org.hibernate.mapping.AbstractAuxiliaryDatabaseObject.
Convenience base class for AuxiliaryDatabaseObjects.
AbstractAuxiliaryDatabaseObject() - Constructor for class org.hibernate.mapping.AbstractAuxiliaryDatabaseObject

AbstractAuxiliaryDatabaseObject(HashSet) - Constructor for class org.hibernate.mapping.AbstractAuxiliaryDatabaseObject

AbstractBatcher - class org.hibernate.jdbc.AbstractBatcher.
Manages prepared statements and batching.
AbstractBatcher(ConnectionManager, Interceptor) - Constructor for class org.hibernate.jdbc.AbstractBatcher

AbstractBynaryType - class org.hibernate.type.AbstractBynaryType.
Logic to bind stream of byte into a VARBINARY
AbstractBynaryType() - Constructor for class org.hibernate.type.AbstractBynaryType

AbstractCharArrayType - class org.hibernate.type.AbstractCharArrayType.
Logic to bind stream of char into a VARCHAR
AbstractCharArrayType() - Constructor for class org.hibernate.type.AbstractCharArrayType

AbstractClassTransformerImpl - class org.hibernate.bytecode.AbstractClassTransformerImpl.

AbstractClassTransformerImpl(ClassFilter, FieldFilter) - Constructor for class org.hibernate.bytecode.AbstractClassTransformerImpl

AbstractCollectionPersister - class org.hibernate.persister.collection.AbstractCollectionPersister.
Base implementation of the QueryableCollection interface.
AbstractCollectionPersister(Collection, CacheConcurrencyStrategy, Configuration, SessionFactoryImplementor) - Constructor for class org.hibernate.persister.collection.AbstractCollectionPersister

AbstractComponentTuplizer - class org.hibernate.tuple.component.AbstractComponentTuplizer.
Support for tuplizers relating to components.
AbstractComponentTuplizer(Component) - Constructor for class org.hibernate.tuple.component.AbstractComponentTuplizer

AbstractComponentType - interface org.hibernate.type.AbstractComponentType.
Enables other Component-like types to hold collections and have cascades, etc.
AbstractEmptinessExpression - class org.hibernate.criterion.AbstractEmptinessExpression.
Implementation of AbstractEmptinessExpression.
AbstractEmptinessExpression(String) - Constructor for class org.hibernate.criterion.AbstractEmptinessExpression

AbstractEntityJoinWalker - class org.hibernate.loader.AbstractEntityJoinWalker.
Abstract walker for walkers which begin at an entity (criteria queries and entity loaders).
AbstractEntityJoinWalker(OuterJoinLoadable, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.AbstractEntityJoinWalker

AbstractEntityLoader - class org.hibernate.loader.entity.AbstractEntityLoader.

AbstractEntityLoader(OuterJoinLoadable, Type, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.entity.AbstractEntityLoader

AbstractEntityPersister - class org.hibernate.persister.entity.AbstractEntityPersister.
Basic functionality for persisting an entity via JDBC through either generated or custom SQL
AbstractEntityPersister(PersistentClass, CacheConcurrencyStrategy, SessionFactoryImplementor) - Constructor for class org.hibernate.persister.entity.AbstractEntityPersister

AbstractEntityTuplizer - class org.hibernate.tuple.entity.AbstractEntityTuplizer.
Support for tuplizers relating to entities.
AbstractEntityTuplizer(EntityMetamodel, PersistentClass) - Constructor for class org.hibernate.tuple.entity.AbstractEntityTuplizer
Constructs a new AbstractEntityTuplizer instance.
AbstractEvent - class org.hibernate.event.AbstractEvent.
Defines a base class for Session generated events.
AbstractEvent(EventSource) - Constructor for class org.hibernate.event.AbstractEvent
Constructs an event from the given event session.
AbstractExplicitParameterSpecification - class org.hibernate.param.AbstractExplicitParameterSpecification.
Convenience base class for explicitly defined query parameters.
AbstractExplicitParameterSpecification(int, int) - Constructor for class org.hibernate.param.AbstractExplicitParameterSpecification

AbstractFieldInterceptor - class org.hibernate.intercept.AbstractFieldInterceptor.

AbstractFieldInterceptor(SessionImplementor, Set, String) - Constructor for class org.hibernate.intercept.AbstractFieldInterceptor

AbstractFlushingEventListener - class org.hibernate.event.def.AbstractFlushingEventListener.
A convenience base class for listeners whose functionality results in flushing.
AbstractFlushingEventListener() - Constructor for class org.hibernate.event.def.AbstractFlushingEventListener

AbstractJndiBoundCacheProvider - class org.hibernate.cache.AbstractJndiBoundCacheProvider.
Support for CacheProvider implementations which are backed by caches bound into JNDI namespace.
AbstractJndiBoundCacheProvider() - Constructor for class org.hibernate.cache.AbstractJndiBoundCacheProvider

AbstractLazyInitializer - class org.hibernate.proxy.AbstractLazyInitializer.
Convenience base class for lazy initialization handlers.
AbstractLazyInitializer(String, Serializable, SessionImplementor) - Constructor for class org.hibernate.proxy.AbstractLazyInitializer

AbstractLockUpgradeEventListener - class org.hibernate.event.def.AbstractLockUpgradeEventListener.
A convenience base class for listeners that respond to requests to perform a pessimistic lock upgrade on an entity.
AbstractLockUpgradeEventListener() - Constructor for class org.hibernate.event.def.AbstractLockUpgradeEventListener

AbstractPersistentCollection - class org.hibernate.collection.AbstractPersistentCollection.
Base class implementing PersistentCollection
AbstractPersistentCollection() - Constructor for class org.hibernate.collection.AbstractPersistentCollection
Not called by Hibernate, but used by non-JDK serialization, eg.
AbstractPersistentCollection(SessionImplementor) - Constructor for class org.hibernate.collection.AbstractPersistentCollection

AbstractPersistentCollection.DelayedOperation - interface org.hibernate.collection.AbstractPersistentCollection.DelayedOperation.

AbstractPostInsertGenerator - class org.hibernate.id.AbstractPostInsertGenerator.

AbstractPostInsertGenerator() - Constructor for class org.hibernate.id.AbstractPostInsertGenerator

AbstractPropertyMapping - class org.hibernate.persister.entity.AbstractPropertyMapping.
Base implementation of a PropertyMapping
AbstractPropertyMapping() - Constructor for class org.hibernate.persister.entity.AbstractPropertyMapping

AbstractQueryImpl - class org.hibernate.impl.AbstractQueryImpl.
Abstract implementation of the Query interface.
AbstractQueryImpl(String, FlushMode, SessionImplementor, ParameterMetadata) - Constructor for class org.hibernate.impl.AbstractQueryImpl

AbstractReassociateEventListener - class org.hibernate.event.def.AbstractReassociateEventListener.
A convenience base class for listeners that respond to requests to reassociate an entity to a session ( such as through lock() or update() ).
AbstractReassociateEventListener() - Constructor for class org.hibernate.event.def.AbstractReassociateEventListener

AbstractRestrictableStatement - class org.hibernate.hql.ast.tree.AbstractRestrictableStatement.
Convenience implementation of RestrictableStatement to centralize common functionality.
AbstractRestrictableStatement() - Constructor for class org.hibernate.hql.ast.tree.AbstractRestrictableStatement

AbstractReturningDelegate - class org.hibernate.id.insert.AbstractReturningDelegate.
Abstract InsertGeneratedIdentifierDelegate implementation where the underlying strategy causes the enerated identitifer to be returned as an effect of performing the insert statement.
AbstractReturningDelegate(PostInsertIdentityPersister) - Constructor for class org.hibernate.id.insert.AbstractReturningDelegate

AbstractSaveEventListener - class org.hibernate.event.def.AbstractSaveEventListener.
A convenience bas class for listeners responding to save events.
AbstractSaveEventListener() - Constructor for class org.hibernate.event.def.AbstractSaveEventListener

AbstractScrollableResults - class org.hibernate.impl.AbstractScrollableResults.
Implementation of the ScrollableResults interface
AbstractScrollableResults(ResultSet, PreparedStatement, SessionImplementor, Loader, QueryParameters, Type[], HolderInstantiator) - Constructor for class org.hibernate.impl.AbstractScrollableResults

AbstractSelectExpression - class org.hibernate.hql.ast.tree.AbstractSelectExpression.
Partial implementation of SelectExpression for all the nodes that aren't constructors.
AbstractSelectExpression() - Constructor for class org.hibernate.hql.ast.tree.AbstractSelectExpression

AbstractSelectingDelegate - class org.hibernate.id.insert.AbstractSelectingDelegate.
Abstract InsertGeneratedIdentifierDelegate implementation where the underlying strategy requires an subsequent select after the insert to determine the generated identifier.
AbstractSelectingDelegate(PostInsertIdentityPersister) - Constructor for class org.hibernate.id.insert.AbstractSelectingDelegate

AbstractSessionImpl - class org.hibernate.impl.AbstractSessionImpl.
Functionality common to stateless and stateful sessions
AbstractSessionImpl(SessionFactoryImpl) - Constructor for class org.hibernate.impl.AbstractSessionImpl

AbstractStatement - class org.hibernate.hql.ast.tree.AbstractStatement.
Convenience implementation of Statement to centralize common functionality.
AbstractStatement() - Constructor for class org.hibernate.hql.ast.tree.AbstractStatement

AbstractStatementExecutor - class org.hibernate.hql.ast.exec.AbstractStatementExecutor.
Implementation of AbstractStatementExecutor.
AbstractStatementExecutor(HqlSqlWalker, Log) - Constructor for class org.hibernate.hql.ast.exec.AbstractStatementExecutor

AbstractType - class org.hibernate.type.AbstractType.
Abstract superclass of the built in Type hierarchy.
AbstractType() - Constructor for class org.hibernate.type.AbstractType

AbstractUUIDGenerator - class org.hibernate.id.AbstractUUIDGenerator.
The base class for identifier generators that use a UUID algorithm.
AbstractUUIDGenerator() - Constructor for class org.hibernate.id.AbstractUUIDGenerator

AbstractVisitor - class org.hibernate.event.def.AbstractVisitor.
Abstract superclass of algorithms that walk a tree of property values of an entity, and perform specific functionality for collections, components and associated entities.
AccessOptimizerAdapter - class org.hibernate.bytecode.cglib.AccessOptimizerAdapter.
The ReflectionOptimizer.AccessOptimizer implementation for CGLIB which simply acts as an adpater to the BulkBean class.
AccessOptimizerAdapter(BulkBean, Class) - Constructor for class org.hibernate.bytecode.cglib.AccessOptimizerAdapter

AccessOptimizerAdapter - class org.hibernate.bytecode.javassist.AccessOptimizerAdapter.
The ReflectionOptimizer.AccessOptimizer implementation for Javassist which simply acts as an adpater to the BulkAccessor class.
AccessOptimizerAdapter(BulkAccessor, Class) - Constructor for class org.hibernate.bytecode.javassist.AccessOptimizerAdapter

ActionQueue - class org.hibernate.engine.ActionQueue.
Responsible for maintaining the queue of actions related to events.
ActionQueue(SessionImplementor) - Constructor for class org.hibernate.engine.ActionQueue
Constructs an action queue bound to the given session.
AdaptedImmutableType - class org.hibernate.type.AdaptedImmutableType.
Optimize a mutable type, if the user promises not to mutable the instances.
AdaptedImmutableType(NullableType) - Constructor for class org.hibernate.type.AdaptedImmutableType

AggregateNode - class org.hibernate.hql.ast.tree.AggregateNode.
Represents an aggregate function i.e.
AggregateNode() - Constructor for class org.hibernate.hql.ast.tree.AggregateNode

AggregateProjection - class org.hibernate.criterion.AggregateProjection.
An aggregation
AggregateProjection(String, String) - Constructor for class org.hibernate.criterion.AggregateProjection

Alias - class org.hibernate.sql.Alias.
An alias generator for SQL identifiers
Alias(int, String) - Constructor for class org.hibernate.sql.Alias
Constructor for Alias.
Alias(String) - Constructor for class org.hibernate.sql.Alias
Constructor for Alias.
AliasGenerator - class org.hibernate.hql.ast.util.AliasGenerator.
Generates class/table/column aliases during semantic analysis and SQL rendering.
AliasGenerator() - Constructor for class org.hibernate.hql.ast.util.AliasGenerator

AliasToBeanConstructorResultTransformer - class org.hibernate.transform.AliasToBeanConstructorResultTransformer.

AliasToBeanConstructorResultTransformer(Constructor) - Constructor for class org.hibernate.transform.AliasToBeanConstructorResultTransformer

AliasToBeanResultTransformer - class org.hibernate.transform.AliasToBeanResultTransformer.
Result transformer that allows to transform a result to a user specified class which will be populated via setter methods or fields matching the alias names.
AliasToBeanResultTransformer(Class) - Constructor for class org.hibernate.transform.AliasToBeanResultTransformer

AliasToEntityMapResultTransformer - class org.hibernate.transform.AliasToEntityMapResultTransformer.

AliasToEntityMapResultTransformer() - Constructor for class org.hibernate.transform.AliasToEntityMapResultTransformer

AliasedProjection - class org.hibernate.criterion.AliasedProjection.

AliasedProjection(Projection, String) - Constructor for class org.hibernate.criterion.AliasedProjection

AnsiTrimEmulationFunction - class org.hibernate.dialect.function.AnsiTrimEmulationFunction.
A SQLFunction implementation that emulates the ANSI SQL trim function on dialects which do not support the full definition.
AnsiTrimEmulationFunction() - Constructor for class org.hibernate.dialect.function.AnsiTrimEmulationFunction

Any - class org.hibernate.mapping.Any.
A Hibernate "any" type (ie.
Any(Table) - Constructor for class org.hibernate.mapping.Any

AnyType - class org.hibernate.type.AnyType.
Handles "any" mappings and the old deprecated "object" type
AnyType(Type, Type) - Constructor for class org.hibernate.type.AnyType

AnyType() - Constructor for class org.hibernate.type.AnyType

AnyType.ObjectTypeCacheEntry - class org.hibernate.type.AnyType.ObjectTypeCacheEntry.

Array - class org.hibernate.mapping.Array.
An array mapping has a primary key consisting of the key columns + index column.
Array(PersistentClass) - Constructor for class org.hibernate.mapping.Array
Constructor for Array.
ArrayHelper - class org.hibernate.util.ArrayHelper.

ArrayType - class org.hibernate.type.ArrayType.
A type for persistent arrays.
ArrayType(String, String, Class, boolean) - Constructor for class org.hibernate.type.ArrayType

AssertionFailure - exception org.hibernate.AssertionFailure.
Indicates failure of an assertion: a possible bug in Hibernate.
AssertionFailure(String) - Constructor for class org.hibernate.AssertionFailure

AssertionFailure(String, Throwable) - Constructor for class org.hibernate.AssertionFailure

Assigned - class org.hibernate.id.Assigned.
assigned

An IdentifierGenerator that returns the current identifier assigned to an instance.
Assigned() - Constructor for class org.hibernate.id.Assigned

AssignmentSpecification - class org.hibernate.hql.ast.tree.AssignmentSpecification.
Encapsulates the information relating to an individual assignment within the set clause of an HQL update statement.
AssignmentSpecification(AST, Queryable) - Constructor for class org.hibernate.hql.ast.tree.AssignmentSpecification

AssociationType - interface org.hibernate.type.AssociationType.
A type that represents some kind of association between entities.
AutoFlushEvent - class org.hibernate.event.AutoFlushEvent.
Defines an event class for the auto-flushing of a session.
AutoFlushEvent(Set, EventSource) - Constructor for class org.hibernate.event.AutoFlushEvent

AutoFlushEventListener - interface org.hibernate.event.AutoFlushEventListener.
Defines the contract for handling of session auto-flush events.
AuxiliaryDatabaseObject - interface org.hibernate.mapping.AuxiliaryDatabaseObject.
Auxiliary database objects (i.e., triggers, stored procedures, etc) defined in the mappings.
AvgProjection - class org.hibernate.criterion.AvgProjection.

AvgProjection(String) - Constructor for class org.hibernate.criterion.AvgProjection

abortBatch(SQLException) - Method in class org.hibernate.jdbc.AbstractBatcher

abortBatch(SQLException) - Method in interface org.hibernate.jdbc.Batcher
Must be called when an exception occurs
absolute(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

accept(ValueVisitor) - Method in class org.hibernate.mapping.Any

accept(ValueVisitor) - Method in class org.hibernate.mapping.Array

accept(ValueVisitor) - Method in class org.hibernate.mapping.Bag

accept(ValueVisitor) - Method in class org.hibernate.mapping.Component

accept(ValueVisitor) - Method in class org.hibernate.mapping.DependantValue

accept(ValueVisitor) - Method in class org.hibernate.mapping.IdentifierBag

accept(PersistentClassVisitor) - Method in class org.hibernate.mapping.JoinedSubclass

accept(ValueVisitor) - Method in class org.hibernate.mapping.List

accept(ValueVisitor) - Method in class org.hibernate.mapping.ManyToOne

accept(ValueVisitor) - Method in class org.hibernate.mapping.Map

accept(ValueVisitor) - Method in class org.hibernate.mapping.OneToMany

accept(ValueVisitor) - Method in class org.hibernate.mapping.OneToOne

accept(PersistentClassVisitor) - Method in class org.hibernate.mapping.PersistentClass

accept(RootClass) - Method in interface org.hibernate.mapping.PersistentClassVisitor

accept(UnionSubclass) - Method in interface org.hibernate.mapping.PersistentClassVisitor

accept(SingleTableSubclass) - Method in interface org.hibernate.mapping.PersistentClassVisitor

accept(JoinedSubclass) - Method in interface org.hibernate.mapping.PersistentClassVisitor

accept(Subclass) - Method in interface org.hibernate.mapping.PersistentClassVisitor

accept(ValueVisitor) - Method in class org.hibernate.mapping.PrimitiveArray

accept(PersistentClassVisitor) - Method in class org.hibernate.mapping.RootClass

accept(ValueVisitor) - Method in class org.hibernate.mapping.Set

accept(ValueVisitor) - Method in class org.hibernate.mapping.SimpleValue

accept(PersistentClassVisitor) - Method in class org.hibernate.mapping.SingleTableSubclass

accept(PersistentClassVisitor) - Method in class org.hibernate.mapping.Subclass

accept(ValueVisitor) - Method in class org.hibernate.mapping.ToOne

accept(PersistentClassVisitor) - Method in class org.hibernate.mapping.UnionSubclass

accept(ValueVisitor) - Method in interface org.hibernate.mapping.Value

accept(Bag) - Method in interface org.hibernate.mapping.ValueVisitor

accept(IdentifierBag) - Method in interface org.hibernate.mapping.ValueVisitor

accept(List) - Method in interface org.hibernate.mapping.ValueVisitor

accept(PrimitiveArray) - Method in interface org.hibernate.mapping.ValueVisitor

accept(Array) - Method in interface org.hibernate.mapping.ValueVisitor

accept(Map) - Method in interface org.hibernate.mapping.ValueVisitor

accept(OneToMany) - Method in interface org.hibernate.mapping.ValueVisitor

accept(Set) - Method in interface org.hibernate.mapping.ValueVisitor

accept(Any) - Method in interface org.hibernate.mapping.ValueVisitor

accept(SimpleValue) - Method in interface org.hibernate.mapping.ValueVisitor

accept(DependantValue) - Method in interface org.hibernate.mapping.ValueVisitor

accept(Component) - Method in interface org.hibernate.mapping.ValueVisitor

accept(ManyToOne) - Method in interface org.hibernate.mapping.ValueVisitor

accept(OneToOne) - Method in interface org.hibernate.mapping.ValueVisitor

accept(Visitor) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

accept(Visitor) - Method in class org.hibernate.tuple.ElementWrapper

add(Criterion) - Method in interface org.hibernate.Criteria
Add a restriction to constrain the results to be retrieved.
add(Document) - Method in class org.hibernate.cfg.Configuration

add(Object) - Method in class org.hibernate.collection.PersistentBag

add(int, Object) - Method in class org.hibernate.collection.PersistentBag

add(Object) - Method in class org.hibernate.collection.PersistentIdentifierBag

add(int, Object) - Method in class org.hibernate.collection.PersistentIdentifierBag

add(Object) - Method in class org.hibernate.collection.PersistentList

add(int, Object) - Method in class org.hibernate.collection.PersistentList

add(Object) - Method in class org.hibernate.collection.PersistentSet

add(Criterion) - Method in class org.hibernate.criterion.DetachedCriteria

add(Criterion) - Method in class org.hibernate.criterion.Junction

add(Projection) - Method in class org.hibernate.criterion.ProjectionList

add(Projection, String) - Method in class org.hibernate.criterion.ProjectionList

add(Criterion) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

add(Criteria, Criterion) - Method in class org.hibernate.impl.CriteriaImpl

add(Criterion) - Method in class org.hibernate.impl.CriteriaImpl

add(Attribute) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

add(CDATA) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

add(Entity) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

add(Text) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

add(Namespace) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

add(Node) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

add(Comment) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

add(Element) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

add(ProcessingInstruction) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

add(Attribute) - Method in class org.hibernate.tuple.ElementWrapper

add(CDATA) - Method in class org.hibernate.tuple.ElementWrapper

add(Entity) - Method in class org.hibernate.tuple.ElementWrapper

add(Text) - Method in class org.hibernate.tuple.ElementWrapper

add(Namespace) - Method in class org.hibernate.tuple.ElementWrapper

add(Node) - Method in class org.hibernate.tuple.ElementWrapper

add(Comment) - Method in class org.hibernate.tuple.ElementWrapper

add(Element) - Method in class org.hibernate.tuple.ElementWrapper

add(ProcessingInstruction) - Method in class org.hibernate.tuple.ElementWrapper

add(Object) - Method in class org.hibernate.util.IdentitySet

add(String[], String, String[]) - Static method in class org.hibernate.util.StringHelper

addAction(EntityInsertAction) - Method in class org.hibernate.engine.ActionQueue

addAction(EntityDeleteAction) - Method in class org.hibernate.engine.ActionQueue

addAction(EntityUpdateAction) - Method in class org.hibernate.engine.ActionQueue

addAction(CollectionRecreateAction) - Method in class org.hibernate.engine.ActionQueue

addAction(CollectionRemoveAction) - Method in class org.hibernate.engine.ActionQueue

addAction(CollectionUpdateAction) - Method in class org.hibernate.engine.ActionQueue

addAction(EntityIdentityInsertAction) - Method in class org.hibernate.engine.ActionQueue

addAction(BulkOperationCleanupAction) - Method in class org.hibernate.engine.ActionQueue

addAdditionalProperty(String, String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

addAll(Collection) - Method in class org.hibernate.collection.PersistentBag

addAll(int, Collection) - Method in class org.hibernate.collection.PersistentBag

addAll(int, Collection) - Method in class org.hibernate.collection.PersistentIdentifierBag

addAll(Collection) - Method in class org.hibernate.collection.PersistentIdentifierBag

addAll(Collection) - Method in class org.hibernate.collection.PersistentList

addAll(int, Collection) - Method in class org.hibernate.collection.PersistentList

addAll(Collection) - Method in class org.hibernate.collection.PersistentSet

addAll(Collection, Object[]) - Static method in class org.hibernate.util.ArrayHelper

addAll(Properties, Map) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

addAll(Collection) - Method in class org.hibernate.util.IdentitySet

addAssociation(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.PathExpressionParser

addAttribute(String, String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

addAttribute(QName, String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

addAttribute(String, String) - Method in class org.hibernate.tuple.ElementWrapper

addAttribute(QName, String) - Method in class org.hibernate.tuple.ElementWrapper

addAuxiliaryDatabaseObject(AuxiliaryDatabaseObject) - Method in class org.hibernate.cfg.Configuration

addAuxiliaryDatabaseObject(AuxiliaryDatabaseObject) - Method in class org.hibernate.cfg.Mappings

addBatchLoadableEntityKey(EntityKey) - Method in class org.hibernate.engine.BatchFetchQueue
If an EntityKey represents a batch loadable entity, add it to the queue.
addCDATA(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

addCDATA(String) - Method in class org.hibernate.tuple.ElementWrapper

addCacheableFile(File) - Method in class org.hibernate.cfg.Configuration
If a cached xmlFile + ".bin" exists and is newer than xmlFile the ".bin" file will be read directly.
addCacheableFile(String) - Method in class org.hibernate.cfg.Configuration

addCheckConstraint(String) - Method in class org.hibernate.mapping.Table

addClass(Class) - Method in class org.hibernate.cfg.Configuration
Read a mapping from an application resource, using a convention.
addClass(PersistentClass) - Method in class org.hibernate.cfg.Mappings

addCollection(Collection) - Method in class org.hibernate.cfg.Mappings

addCollectionHolder(PersistentCollection) - Method in interface org.hibernate.engine.PersistenceContext
Register a PersistentCollection object for an array.
addCollectionHolder(PersistentCollection) - Method in class org.hibernate.engine.StatefulPersistenceContext
Register a PersistentCollection object for an array.
addColumn(Column) - Method in class org.hibernate.mapping.Component

addColumn(Column) - Method in class org.hibernate.mapping.Constraint

addColumn(Column) - Method in class org.hibernate.mapping.Index

addColumn(Column) - Method in class org.hibernate.mapping.SimpleValue

addColumn(Column) - Method in class org.hibernate.mapping.Table

addColumn(String) - Method in class org.hibernate.sql.Insert

addColumn(String, String) - Method in class org.hibernate.sql.Insert

addColumn(String, Object, LiteralType) - Method in class org.hibernate.sql.Insert

addColumn(String) - Method in class org.hibernate.sql.InsertSelect

addColumn(String) - Method in class org.hibernate.sql.SelectFragment

addColumn(String, String) - Method in class org.hibernate.sql.SelectFragment

addColumn(String, String, String) - Method in class org.hibernate.sql.SelectFragment

addColumn(String) - Method in class org.hibernate.sql.SimpleSelect

addColumn(String, String) - Method in class org.hibernate.sql.SimpleSelect

addColumn(String) - Method in class org.hibernate.sql.Update

addColumn(String, String) - Method in class org.hibernate.sql.Update

addColumn(String, Object, LiteralType) - Method in class org.hibernate.sql.Update

addColumn(ResultSet) - Method in class org.hibernate.tool.hbm2ddl.TableMetadata

addColumnBinding(String, Column, Table) - Method in class org.hibernate.cfg.Mappings

addColumns(Iterator) - Method in class org.hibernate.mapping.Constraint

addColumns(Iterator) - Method in class org.hibernate.mapping.Index

addColumns(String[]) - Method in class org.hibernate.sql.Insert

addColumns(String[], boolean[]) - Method in class org.hibernate.sql.Insert

addColumns(String[]) - Method in class org.hibernate.sql.InsertSelect

addColumns(String[]) - Method in class org.hibernate.sql.SelectFragment

addColumns(String, String[]) - Method in class org.hibernate.sql.SelectFragment

addColumns(String, String[], String[]) - Method in class org.hibernate.sql.SelectFragment

addColumns(String[], String[]) - Method in class org.hibernate.sql.SimpleSelect

addColumns(String[], String[], boolean[]) - Method in class org.hibernate.sql.SimpleSelect

addColumns(String[]) - Method in class org.hibernate.sql.SimpleSelect

addColumns(String[]) - Method in class org.hibernate.sql.Update

addColumns(String[], boolean[]) - Method in class org.hibernate.sql.Update

addColumns(String[], String) - Method in class org.hibernate.sql.Update

addComment(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

addComment(String) - Method in class org.hibernate.tuple.ElementWrapper

addComponentTypedValues(String, Object, AbstractComponentType, List, Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.Example

addCondition(String) - Method in class org.hibernate.engine.JoinSequence

addCondition(String, String[], String) - Method in class org.hibernate.engine.JoinSequence

addCondition(String, String[], String) - Method in class org.hibernate.sql.ANSIJoinFragment

addCondition(String, String[], String[]) - Method in class org.hibernate.sql.ANSIJoinFragment

addCondition(String) - Method in class org.hibernate.sql.ANSIJoinFragment

addCondition(ConditionFragment) - Method in class org.hibernate.sql.DisjunctionFragment

addCondition(String, String[], String[]) - Method in class org.hibernate.sql.JoinFragment

addCondition(String) - Method in class org.hibernate.sql.JoinFragment

addCondition(StringBuffer, String) - Method in class org.hibernate.sql.JoinFragment
Appends the 'on' condition to the buffer, returning true if the condition was added.
addCondition(String, String[], String) - Method in class org.hibernate.sql.OracleJoinFragment

addCondition(String, String[], String[]) - Method in class org.hibernate.sql.OracleJoinFragment

addCondition(String) - Method in class org.hibernate.sql.OracleJoinFragment

addCondition(String, String[], String) - Method in class org.hibernate.sql.QueryJoinFragment

addCondition(String, String[], String[]) - Method in class org.hibernate.sql.QueryJoinFragment

addCondition(String) - Method in class org.hibernate.sql.QueryJoinFragment
Add the condition string to the join fragment.
addCondition(String, String, String) - Method in class org.hibernate.sql.SimpleSelect

addCondition(String, String) - Method in class org.hibernate.sql.SimpleSelect

addCondition(String[], String, String[]) - Method in class org.hibernate.sql.SimpleSelect

addCondition(String[], String) - Method in class org.hibernate.sql.SimpleSelect

addCondition(String, String[], String) - Method in class org.hibernate.sql.Sybase11JoinFragment

addCondition(String, String[], String[]) - Method in class org.hibernate.sql.Sybase11JoinFragment

addCondition(String) - Method in class org.hibernate.sql.Sybase11JoinFragment

addCrossJoin(String, String) - Method in class org.hibernate.sql.ANSIJoinFragment

addCrossJoin(String, String) - Method in class org.hibernate.sql.JoinFragment

addCrossJoin(String, String) - Method in class org.hibernate.sql.OracleJoinFragment

addCrossJoin(String, String) - Method in class org.hibernate.sql.QueryJoinFragment

addCrossJoin(String, String) - Method in class org.hibernate.sql.Sybase11JoinFragment

addDenormalizedTable(String, String, String, boolean, String, Table) - Method in class org.hibernate.cfg.Mappings

addDialectScope(String) - Method in class org.hibernate.mapping.AbstractAuxiliaryDatabaseObject

addDialectScope(String) - Method in interface org.hibernate.mapping.AuxiliaryDatabaseObject
Add the given dialect name to the scope of dialects to which this database object applies.
addDirectory(File) - Method in class org.hibernate.cfg.Configuration
Read all mapping documents from a directory tree.
addDiscriminatorToInsert(Insert) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

addDiscriminatorToInsert(Insert) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

addDiscriminatorToSelect(SelectFragment, String, String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

addDiscriminatorToSelect(SelectFragment, String, String) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

addDiscriminatorToSelect(SelectFragment, String, String) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

addDiscriminatorToSelect(SelectFragment, String, String) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

addDiscriminatorWhereFragment(RestrictableStatement, Queryable, Map, String) - Method in class org.hibernate.hql.ast.util.SyntheticAndFactory

addDocument(Document) - Method in class org.hibernate.cfg.Configuration
Read mappings from a DOM Document
addElement(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

addElement(QName) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

addElement(String, String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

addElement(String) - Method in class org.hibernate.tuple.ElementWrapper

addElement(QName) - Method in class org.hibernate.tuple.ElementWrapper

addElement(String, String) - Method in class org.hibernate.tuple.ElementWrapper

addEntity(String) - Method in interface org.hibernate.SQLQuery
Declare a "root" entity, without specifying an alias
addEntity(String, String) - Method in interface org.hibernate.SQLQuery
Declare a "root" entity
addEntity(String, String, LockMode) - Method in interface org.hibernate.SQLQuery
Declare a "root" entity, specifying a lock mode
addEntity(Class) - Method in interface org.hibernate.SQLQuery
Declare a "root" entity, without specifying an alias
addEntity(String, Class) - Method in interface org.hibernate.SQLQuery
Declare a "root" entity
addEntity(String, Class, LockMode) - Method in interface org.hibernate.SQLQuery
Declare a "root" entity, specifying a lock mode
addEntity(EntityKey, Object) - Method in interface org.hibernate.engine.PersistenceContext
Add a canonical mapping from entity key to entity instance
addEntity(EntityUniqueKey, Object) - Method in interface org.hibernate.engine.PersistenceContext
Add an entity to the cache by unique key
addEntity(Object, Status, Object[], EntityKey, Object, LockMode, boolean, EntityPersister, boolean, boolean) - Method in interface org.hibernate.engine.PersistenceContext
Adds an entity to the internal caches.
addEntity(EntityKey, Object) - Method in class org.hibernate.engine.StatefulPersistenceContext

addEntity(EntityUniqueKey, Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Add an entity to the cache by unique key
addEntity(Object, Status, Object[], EntityKey, Object, LockMode, boolean, EntityPersister, boolean, boolean) - Method in class org.hibernate.engine.StatefulPersistenceContext
Adds an entity to the internal caches.
addEntity(Class) - Method in class org.hibernate.impl.SQLQueryImpl

addEntity(String) - Method in class org.hibernate.impl.SQLQueryImpl

addEntity(String, String) - Method in class org.hibernate.impl.SQLQueryImpl

addEntity(String, Class) - Method in class org.hibernate.impl.SQLQueryImpl

addEntity(String, String, LockMode) - Method in class org.hibernate.impl.SQLQueryImpl

addEntity(String, Class, LockMode) - Method in class org.hibernate.impl.SQLQueryImpl

addEntity(String, String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

addEntity(String, String) - Method in class org.hibernate.tuple.ElementWrapper

addEntry(Object, Status, Object[], Object, Serializable, Object, LockMode, boolean, EntityPersister, boolean, boolean) - Method in interface org.hibernate.engine.PersistenceContext
Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.
addEntry(Object, Status, Object[], Object, Serializable, Object, LockMode, boolean, EntityPersister, boolean, boolean) - Method in class org.hibernate.engine.StatefulPersistenceContext
Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.
addFile(String) - Method in class org.hibernate.cfg.Configuration
Read mappings from a particular XML file
addFile(File) - Method in class org.hibernate.cfg.Configuration
Read mappings from a particular XML file
addFileset(FileSet) - Method in class org.hibernate.tool.hbm2ddl.SchemaExportTask

addFileset(FileSet) - Method in class org.hibernate.tool.hbm2ddl.SchemaUpdateTask

addFileset(FileSet) - Method in class org.hibernate.tool.hbm2ddl.SchemaValidatorTask

addFileset(FileSet) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

addFilter(String, String) - Method in class org.hibernate.mapping.Collection

addFilter(String, String) - Method in interface org.hibernate.mapping.Filterable

addFilter(String, String) - Method in class org.hibernate.mapping.PersistentClass

addFilterDefinition(FilterDefinition) - Method in class org.hibernate.cfg.Configuration

addFilterDefinition(FilterDefinition) - Method in class org.hibernate.cfg.Mappings

addFormula(Formula) - Method in class org.hibernate.mapping.SimpleValue

addFormula(String, String, String) - Method in class org.hibernate.sql.SelectFragment

addFormulas(String, String[], String[]) - Method in class org.hibernate.sql.SelectFragment

addFragment(JoinFragment) - Method in class org.hibernate.sql.JoinFragment

addFromAssociation(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.PathExpressionParser

addFromCollection(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.PathExpressionParser

addFromElement(String, AST) - Method in class org.hibernate.hql.ast.tree.FromClause
Adds a new from element to the from node.
addFromFragmentString(String) - Method in class org.hibernate.sql.ANSIJoinFragment

addFromFragmentString(String) - Method in class org.hibernate.sql.OracleJoinFragment

addFromFragmentString(String) - Method in class org.hibernate.sql.QueryJoinFragment

addFromFragmentString(String) - Method in class org.hibernate.sql.Sybase11JoinFragment

addIdentityColumn(String) - Method in class org.hibernate.sql.Insert

addImpliedFromElement(FromElement) - Method in class org.hibernate.hql.ast.tree.FromClause

addImport(String, String) - Method in class org.hibernate.cfg.Mappings

addIndex(Index) - Method in class org.hibernate.mapping.Table

addInitializedCollection(CollectionPersister, PersistentCollection, Serializable) - Method in interface org.hibernate.engine.PersistenceContext
add a collection we just pulled out of the cache (does not need initializing)
addInitializedCollection(CollectionPersister, PersistentCollection, Serializable) - Method in class org.hibernate.engine.StatefulPersistenceContext
add a collection we just pulled out of the cache (does not need initializing)
addInitializedDetachedCollection(CollectionPersister, PersistentCollection) - Method in interface org.hibernate.engine.PersistenceContext
add an (initialized) collection that was created by another session and passed into update() (ie.
addInitializedDetachedCollection(CollectionPersister, PersistentCollection) - Method in class org.hibernate.engine.StatefulPersistenceContext
add an (initialized) collection that was created by another session and passed into update() (ie.
addInputStream(InputStream) - Method in class org.hibernate.cfg.Configuration
Read mappings from an InputStream
addInstance(String, String, SessionFactory, Properties) - Static method in class org.hibernate.impl.SessionFactoryObjectFactory

addJar(File) - Method in class org.hibernate.cfg.Configuration
Read all mappings from a jar file
addJoin(String, String) - Method in interface org.hibernate.SQLQuery
Declare a "joined" entity
addJoin(String, String, LockMode) - Method in interface org.hibernate.SQLQuery
Declare a "joined" entity, specifying a lock mode
addJoin(AssociationType, String, int, String[]) - Method in class org.hibernate.engine.JoinSequence

addJoin(String, String) - Method in class org.hibernate.impl.SQLQueryImpl

addJoin(String, String, LockMode) - Method in class org.hibernate.impl.SQLQueryImpl

addJoin(Join) - Method in class org.hibernate.mapping.PersistentClass

addJoin(Join) - Method in class org.hibernate.mapping.Subclass

addJoin(String, String, String[], String[], int) - Method in class org.hibernate.sql.ANSIJoinFragment

addJoin(String, String, String[], String[], int, String) - Method in class org.hibernate.sql.ANSIJoinFragment

addJoin(String, String, String[], String[], int) - Method in class org.hibernate.sql.JoinFragment

addJoin(String, String, String[], String[], int, String) - Method in class org.hibernate.sql.JoinFragment

addJoin(String, String, String[], String[], int) - Method in class org.hibernate.sql.OracleJoinFragment

addJoin(String, String, String[], String[], int, String) - Method in class org.hibernate.sql.OracleJoinFragment

addJoin(String, String, String[], String[], int) - Method in class org.hibernate.sql.QueryJoinFragment

addJoin(String, String, String[], String[], int, String) - Method in class org.hibernate.sql.QueryJoinFragment

addJoin(String, String, String[], String[], int) - Method in class org.hibernate.sql.Sybase11JoinFragment

addJoin(String, String, String[], String[], int, String) - Method in class org.hibernate.sql.Sybase11JoinFragment

addJoins(JoinFragment) - Method in class org.hibernate.loader.OuterJoinableAssociation

addJoins(String, String) - Method in class org.hibernate.sql.ANSIJoinFragment

addJoins(String, String) - Method in class org.hibernate.sql.JoinFragment

addJoins(String, String) - Method in class org.hibernate.sql.OracleJoinFragment

addJoins(String, String) - Method in class org.hibernate.sql.QueryJoinFragment

addJoins(String, String) - Method in class org.hibernate.sql.Sybase11JoinFragment

addManyToManyFilter(String, String) - Method in class org.hibernate.mapping.Collection

addManyToManyJoin(JoinFragment, QueryableCollection) - Method in class org.hibernate.loader.OuterJoinableAssociation

addMapResource(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Add a mapping file
addMapResource(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

addNamespace(String, String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

addNamespace(String, String) - Method in class org.hibernate.tuple.ElementWrapper

addNewCollection(CollectionPersister, PersistentCollection) - Method in interface org.hibernate.engine.PersistenceContext
Add a new collection (ie.
addNewCollection(CollectionPersister, PersistentCollection) - Method in class org.hibernate.engine.StatefulPersistenceContext
Add a new collection (ie.
addNonLazyCollection(PersistentCollection) - Method in interface org.hibernate.engine.PersistenceContext
Register a collection for non-lazy loading at the end of the two-phase load
addNonLazyCollection(PersistentCollection) - Method in class org.hibernate.engine.StatefulPersistenceContext
Register a collection for non-lazy loading at the end of the two-phase load
addNullProperty(EntityKey, String) - Method in interface org.hibernate.engine.PersistenceContext
Record the fact that the association belonging to the keyed entity is null.
addNullProperty(EntityKey, String) - Method in class org.hibernate.engine.StatefulPersistenceContext
Record the fact that the association belonging to the keyed entity is null.
addOrder(Order) - Method in interface org.hibernate.Criteria
Add an ordering to the result set.
addOrder(Order) - Method in class org.hibernate.criterion.DetachedCriteria

addOrder(Order) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

addOrder(Order) - Method in class org.hibernate.impl.CriteriaImpl

addOrderBy(String) - Method in class org.hibernate.sql.QuerySelect

addOrderFragment(String) - Method in class org.hibernate.hql.ast.tree.OrderByClause

addPermission(String, String, String) - Method in class org.hibernate.secure.JACCConfiguration

addProcessingInstruction(String, String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

addProcessingInstruction(String, Map) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

addProcessingInstruction(String, String) - Method in class org.hibernate.tuple.ElementWrapper

addProcessingInstruction(String, Map) - Method in class org.hibernate.tuple.ElementWrapper

addProperties(Properties) - Method in class org.hibernate.cfg.Configuration
Set the given properties
addProperty(Property) - Method in class org.hibernate.mapping.Component

addProperty(Property) - Method in class org.hibernate.mapping.Join

addProperty(Property) - Method in class org.hibernate.mapping.PersistentClass

addProperty(Property) - Method in class org.hibernate.mapping.Subclass

addPropertyPath(String, Type, String[], String[]) - Method in class org.hibernate.persister.entity.AbstractPropertyMapping

addPropertyTypedValue(Object, Type, List) - Method in class org.hibernate.criterion.Example

addProxy(EntityKey, Object) - Method in interface org.hibernate.engine.PersistenceContext
Add a proxy to the session cache
addProxy(EntityKey, Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Add a proxy to the session cache
addQuery(String, NamedQueryDefinition) - Method in class org.hibernate.cfg.Mappings

addQueryReturn(NativeSQLQueryReturn) - Method in class org.hibernate.engine.ResultSetMappingDefinition

addQuerySpaces(Serializable[]) - Method in class org.hibernate.hql.ast.HqlSqlWalker

addReferencedColumns(Iterator) - Method in class org.hibernate.mapping.ForeignKey

addResource(String, ClassLoader) - Method in class org.hibernate.cfg.Configuration
Read mappings from an application resource
addResource(String) - Method in class org.hibernate.cfg.Configuration
Read mappings from an application resource trying different classloaders.
addResultSetMapping(ResultSetMappingDefinition) - Method in class org.hibernate.cfg.Mappings

addSQLQuery(String, NamedSQLQueryDefinition) - Method in class org.hibernate.cfg.Mappings

addScalar(String, Type) - Method in interface org.hibernate.SQLQuery
Declare a scalar query result
addScalar(String) - Method in interface org.hibernate.SQLQuery
Declare a scalar query.
addScalar(String, Type) - Method in class org.hibernate.impl.SQLQueryImpl

addScalar(String) - Method in class org.hibernate.impl.SQLQueryImpl

addSecondPass(SecondPass) - Method in class org.hibernate.cfg.Mappings

addSecondPass(SecondPass, boolean) - Method in class org.hibernate.cfg.Mappings

addSelectColumn(String, String) - Method in class org.hibernate.sql.QuerySelect

addSelectFragmentString(String) - Method in class org.hibernate.sql.QuerySelect

addSqlFunction(String, SQLFunction) - Method in class org.hibernate.cfg.Configuration

addSubclass(Subclass) - Method in class org.hibernate.mapping.PersistentClass

addSubclass(Subclass) - Method in class org.hibernate.mapping.RootClass

addSubclassJoin(Join) - Method in class org.hibernate.mapping.PersistentClass

addSubclassJoin(Join) - Method in class org.hibernate.mapping.Subclass

addSubclassProperty(Property) - Method in class org.hibernate.mapping.PersistentClass

addSubclassProperty(Property) - Method in class org.hibernate.mapping.Subclass

addSubclassTable(Table) - Method in class org.hibernate.mapping.PersistentClass

addSubclassTable(Table) - Method in class org.hibernate.mapping.Subclass

addSubselect(EntityKey, SubselectFetch) - Method in class org.hibernate.engine.BatchFetchQueue
Adds a subselect fetch decriptor for the given entity key.
addSynchronizedTable(String) - Method in class org.hibernate.mapping.PersistentClass

addTable(String, String, String, String, boolean) - Method in class org.hibernate.cfg.Mappings

addTableAlias(String) - Method in class org.hibernate.sql.ForUpdateFragment

addTableBinding(String, String, String, String, Table) - Method in class org.hibernate.cfg.Mappings

addText(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

addText(String) - Method in class org.hibernate.tuple.ElementWrapper

addToBatch(Expectation) - Method in interface org.hibernate.jdbc.Batcher
Add an insert / delete / update to the current batch (might be called multiple times for single prepareBatchStatement())
addToBatch(Expectation) - Method in class org.hibernate.jdbc.BatchingBatcher

addToBatch(Expectation) - Method in class org.hibernate.jdbc.NonBatchingBatcher

addToExtendsQueue(ExtendsQueueEntry) - Method in class org.hibernate.cfg.Mappings

addTuplizer(EntityMode, String) - Method in class org.hibernate.mapping.Component

addTuplizer(EntityMode, String) - Method in class org.hibernate.mapping.PersistentClass

addTuplizer(EntityMode, Tuplizer) - Method in class org.hibernate.tuple.EntityModeToTuplizerMapping

addTypeDef(String, String, Properties) - Method in class org.hibernate.cfg.Mappings

addURL(URL) - Method in class org.hibernate.cfg.Configuration
Read mappings from a URL
addUnderscores(String) - Static method in class org.hibernate.cfg.ImprovedNamingStrategy

addUninitializedCachedEntity(EntityKey, Object, EntityPersister, LockMode, boolean, Object, SessionImplementor) - Static method in class org.hibernate.engine.TwoPhaseLoad

addUninitializedCollection(CollectionPersister, PersistentCollection, Serializable) - Method in interface org.hibernate.engine.PersistenceContext
add a collection we just loaded up (still needs initializing)
addUninitializedCollection(CollectionPersister, PersistentCollection, Serializable) - Method in class org.hibernate.engine.StatefulPersistenceContext
add a collection we just loaded up (still needs initializing)
addUninitializedDetachedCollection(CollectionPersister, PersistentCollection) - Method in interface org.hibernate.engine.PersistenceContext
add a detached uninitialized collection
addUninitializedDetachedCollection(CollectionPersister, PersistentCollection) - Method in class org.hibernate.engine.StatefulPersistenceContext
add a detached uninitialized collection
addUninitializedEntity(EntityKey, Object, EntityPersister, LockMode, boolean, SessionImplementor) - Static method in class org.hibernate.engine.TwoPhaseLoad
Add an uninitialized instance of an entity class, as a placeholder to ensure object identity.
addUniqueKey(UniqueKey) - Method in class org.hibernate.mapping.Table

addUnownedCollection(CollectionKey, PersistentCollection) - Method in interface org.hibernate.engine.PersistenceContext
Add a collection which has no owner loaded
addUnownedCollection(CollectionKey, PersistentCollection) - Method in class org.hibernate.engine.StatefulPersistenceContext

addValue(String) - Method in class org.hibernate.mapping.MetaAttribute

addValue(Object) - Method in class org.hibernate.sql.InFragment

addWhenColumnNotNull(String, String, String) - Method in class org.hibernate.sql.CaseFragment

addWhereColumn(String) - Method in class org.hibernate.sql.Update

addWhereColumn(String, String) - Method in class org.hibernate.sql.Update

addWhereColumns(String[]) - Method in class org.hibernate.sql.Update

addWhereColumns(String[], String) - Method in class org.hibernate.sql.Update

addWhereFragment(JoinFragment, String, QueryNode, FromElement) - Method in class org.hibernate.hql.ast.util.SyntheticAndFactory

addWhereFragment(String) - Method in class org.hibernate.sql.Delete

addWhereToken(String) - Method in class org.hibernate.sql.SimpleSelect

addXML(String) - Method in class org.hibernate.cfg.Configuration
Read mappings from a String
additionalNamespaces() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

additionalNamespaces() - Method in class org.hibernate.tuple.ElementWrapper

additiveExpr(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

additiveExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

addrExpr(AST, boolean) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

addrExpr(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

addrExprLhs(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

affectsTable(String) - Method in class org.hibernate.hql.ast.tree.AssignmentSpecification

after() - Method in class org.hibernate.impl.AbstractQueryImpl

after() - Method in class org.hibernate.impl.CriteriaImpl

afterAction(PersistentCollection) - Method in class org.hibernate.engine.CollectionEntry
Called after execution of an action
afterCompletion(int) - Method in class org.hibernate.context.JTASessionContext.CleanupSynch

afterCompletion(int) - Method in class org.hibernate.context.ThreadLocalSessionContext.CleanupSynch

afterCompletion(int) - Method in class org.hibernate.transaction.CacheSynchronization

afterInitialize() - Method in class org.hibernate.collection.AbstractPersistentCollection

afterInitialize() - Method in interface org.hibernate.collection.PersistentCollection
Called after initializing from cache
afterInitialize(Object, boolean, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

afterInitialize(Object, boolean, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Called just after the entities properties have been initialized
afterInitialize(Object, boolean, SessionImplementor) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

afterInitialize(Object, boolean, SessionImplementor) - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Called just after the entities properties have been initialized.
afterInitialize(Object, boolean, SessionImplementor) - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

afterInsert(Object, Object, Object) - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Called after an item has been inserted (after the transaction completes), instead of calling release().
afterInsert(Object, Object, Object) - Method in class org.hibernate.cache.NonstrictReadWriteCache
Do nothing.
afterInsert(Object, Object, Object) - Method in class org.hibernate.cache.ReadOnlyCache
Do nothing.
afterInsert(Object, Object, Object) - Method in class org.hibernate.cache.ReadWriteCache
Add the new item to the cache, checking that no other transaction has accessed the item.
afterInsert(Object, Object, Object) - Method in class org.hibernate.cache.TransactionalCache
Do nothing.
afterLast() - Method in interface org.hibernate.ScrollableResults
Go to a location just after the last result
afterLast() - Method in class org.hibernate.impl.FetchingScrollableResultsImpl
Go to a location just after the last result
afterLast() - Method in class org.hibernate.impl.ScrollableResultsImpl

afterLast() - Method in class org.hibernate.jdbc.ResultSetWrapper

afterLoad() - Method in interface org.hibernate.engine.PersistenceContext
Call this after finishing a two-phase load
afterLoad() - Method in class org.hibernate.engine.StatefulPersistenceContext
Call this after finishing a two-phase load
afterNontransactionalQuery(boolean) - Method in class org.hibernate.jdbc.JDBCContext
Called after executing a query outside the scope of a Hibernate or JTA transaction
afterOperation(boolean) - Method in class org.hibernate.impl.SessionImpl
Check if there is a Hibernate or JTA transaction in progress and, if there is not, flush if necessary, make sure the connection has been committed (if it is not in autocommit mode) and run the after completion processing
afterOperation(boolean) - Method in class org.hibernate.impl.StatelessSessionImpl

afterReassociate(Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

afterReassociate(Object, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Called just after the entity has been reassociated with the session
afterRowInsert(CollectionPersister, Object, int) - Method in class org.hibernate.collection.AbstractPersistentCollection
Called after inserting a row, to fetch the natively generated id
afterRowInsert(CollectionPersister, Object, int) - Method in interface org.hibernate.collection.PersistentCollection
Called after inserting a row, to fetch the natively generated id
afterRowInsert(CollectionPersister, Object, int) - Method in class org.hibernate.collection.PersistentIdentifierBag

afterScrollOperation() - Method in interface org.hibernate.engine.SessionImplementor

afterScrollOperation() - Method in class org.hibernate.impl.AbstractScrollableResults

afterScrollOperation() - Method in class org.hibernate.impl.SessionImpl

afterScrollOperation() - Method in class org.hibernate.impl.StatelessSessionImpl

afterStatement() - Method in class org.hibernate.jdbc.ConnectionManager
To be called after execution of each JDBC statement.
afterTransaction() - Method in class org.hibernate.jdbc.ConnectionManager
To be called after local transaction completion.
afterTransactionBegin(Transaction) - Method in class org.hibernate.EmptyInterceptor

afterTransactionBegin(Transaction) - Method in interface org.hibernate.Interceptor
Called when a Hibernate transaction is begun via the Hibernate Transaction API.
afterTransactionBegin(Transaction) - Method in class org.hibernate.impl.SessionImpl

afterTransactionBegin(Transaction) - Method in class org.hibernate.impl.StatelessSessionImpl

afterTransactionBegin(Transaction) - Method in interface org.hibernate.jdbc.JDBCContext.Context
We cannot rely upon this method being called! It is only called if we are using Hibernate Transaction API.
afterTransactionBegin(Transaction) - Method in class org.hibernate.jdbc.JDBCContext
We cannot rely upon this method being called! It is only called if we are using Hibernate Transaction API.
afterTransactionCompletion(Transaction) - Method in class org.hibernate.EmptyInterceptor

afterTransactionCompletion(Transaction) - Method in interface org.hibernate.Interceptor
Called after a transaction is committed or rolled back.
afterTransactionCompletion(boolean) - Method in class org.hibernate.action.BulkOperationCleanupAction

afterTransactionCompletion(boolean) - Method in class org.hibernate.action.CollectionAction

afterTransactionCompletion(boolean) - Method in class org.hibernate.action.EntityDeleteAction

afterTransactionCompletion(boolean) - Method in class org.hibernate.action.EntityIdentityInsertAction

afterTransactionCompletion(boolean) - Method in class org.hibernate.action.EntityInsertAction

afterTransactionCompletion(boolean) - Method in class org.hibernate.action.EntityUpdateAction

afterTransactionCompletion(boolean) - Method in interface org.hibernate.action.Executable
Called after the transaction completes
afterTransactionCompletion(boolean) - Method in class org.hibernate.engine.ActionQueue
Performs cleanup of any held cache softlocks.
afterTransactionCompletion() - Method in interface org.hibernate.engine.PersistenceContext
Called after transactions end
afterTransactionCompletion(boolean, Transaction) - Method in interface org.hibernate.engine.SessionImplementor
Notify the session that the transaction completed, so we no longer own the old locks.
afterTransactionCompletion() - Method in class org.hibernate.engine.StatefulPersistenceContext

afterTransactionCompletion(boolean, Transaction) - Method in class org.hibernate.impl.SessionImpl

afterTransactionCompletion(boolean, Transaction) - Method in class org.hibernate.impl.StatelessSessionImpl

afterTransactionCompletion(boolean, Transaction) - Method in interface org.hibernate.jdbc.JDBCContext.Context

afterTransactionCompletion(boolean, Transaction) - Method in class org.hibernate.jdbc.JDBCContext

afterUpdate(Object, Object, Object, CacheConcurrencyStrategy.SoftLock) - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Called after an item has been updated (after the transaction completes), instead of calling release().
afterUpdate(Object, Object, Object, CacheConcurrencyStrategy.SoftLock) - Method in class org.hibernate.cache.NonstrictReadWriteCache
Invalidate the item (again, for safety).
afterUpdate(Object, Object, Object, CacheConcurrencyStrategy.SoftLock) - Method in class org.hibernate.cache.ReadOnlyCache
Unsupported!
afterUpdate(Object, Object, Object, CacheConcurrencyStrategy.SoftLock) - Method in class org.hibernate.cache.ReadWriteCache
Re-cache the updated state, if and only if there there are no other concurrent soft locks.
afterUpdate(Object, Object, Object, CacheConcurrencyStrategy.SoftLock) - Method in class org.hibernate.cache.TransactionalCache
Do nothing.
aggregate() - Method in class org.hibernate.hql.antlr.HqlBaseParser

aggregate(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

aggregateExpr(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

aggregateFuncNoArgsHasParenthesis(String, QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.SelectParser

aggregateHasArgs(String, QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.SelectParser

aggregateType(List, Type, QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.SelectParser

alias(Projection, String) - Static method in class org.hibernate.criterion.Projections
Assign an alias to a projection, by wrapping it
alias() - Method in class org.hibernate.hql.antlr.HqlBaseParser

aliasRef(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

aliasToBean(Class) - Static method in class org.hibernate.transform.Transformers
Creates a resulttransformer that will inject aliased values into instances of Class via property methods or fields.
aliasedExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

aliasedSelectExpr(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

aliases - Variable in class org.hibernate.loader.JoinWalker

aliases - Variable in class org.hibernate.loader.OuterJoinLoader

alignColumns() - Method in class org.hibernate.mapping.ForeignKey
Validates that columnspan of the foreignkey and the primarykey is the same.
allEq(Map) - Static method in class org.hibernate.criterion.Restrictions
Apply an "equals" constraint to each property in the key set of a Map
altWhenClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

and(Criterion, Criterion) - Static method in class org.hibernate.criterion.Restrictions
Return the conjuction of two expressions
any(Type, Type) - Static method in class org.hibernate.Hibernate
A Hibernate any type.
append(int, String, boolean) - Method in class org.hibernate.hql.ast.util.ASTAppender

append(AST) - Method in class org.hibernate.hql.ast.util.ASTAppender

appendAssignmentFragment(String) - Method in class org.hibernate.sql.Update

appendAttributes(Element) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

appendAttributes(Element) - Method in class org.hibernate.tuple.ElementWrapper

appendComponentCondition(String, Object, AbstractComponentType, Criteria, CriteriaQuery, StringBuffer) - Method in class org.hibernate.criterion.Example

appendContent(Branch) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

appendContent(Branch) - Method in class org.hibernate.tuple.ElementWrapper

appendDisplayText(StringBuffer) - Method in class org.hibernate.hql.ast.tree.FromElement

appendElementColumns(SelectFragment, String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

appendEscapedMultibyteChars(String, StringBuffer) - Static method in class org.hibernate.hql.ast.util.ASTPrinter

appendIdentifierColumns(SelectFragment, String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

appendIdentitySelectToInsert(String) - Method in class org.hibernate.dialect.Dialect
Append a clause to retrieve the generated identity value for the given INSERT statement.
appendIdentitySelectToInsert(String) - Method in class org.hibernate.dialect.SQLServerDialect
Use insert table(...) values(...) select SCOPE_IDENTITY()
appendIdentitySelectToInsert(String) - Method in class org.hibernate.dialect.SybaseDialect

appendIndexColumns(SelectFragment, String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

appendLockHint(LockMode, String) - Method in class org.hibernate.dialect.Dialect
Method appendLockHint appends according to the given lock mode a lock hint behind the given table name, if this dialect needs this.
appendLockHint(LockMode, String) - Method in class org.hibernate.dialect.SQLServerDialect

appendLockHint(LockMode, String) - Method in class org.hibernate.dialect.SybaseDialect

appendPropertyCondition(String, Object, Criteria, CriteriaQuery, StringBuffer) - Method in class org.hibernate.criterion.Example

appendSibling(AST, AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil

appliesToDialect(Dialect) - Method in class org.hibernate.mapping.AbstractAuxiliaryDatabaseObject

appliesToDialect(Dialect) - Method in interface org.hibernate.mapping.AuxiliaryDatabaseObject
Does this database object apply to the given dialect?
applyLocks(String, Map, Dialect) - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

applyLocks(String, Map, Dialect) - Method in class org.hibernate.loader.Loader
Append FOR UPDATE OF clause, if necessary.
applyLocks(String, Map, Dialect) - Method in class org.hibernate.loader.criteria.CriteriaLoader

applyLocks(String, Map, Dialect) - Method in class org.hibernate.loader.hql.QueryLoader

appropriateExpectation(ExecuteUpdateResultCheckStyle) - Static method in class org.hibernate.jdbc.Expectations

areCallbacksLocalToHibernateTransactions() - Method in class org.hibernate.transaction.CMTTransactionFactory

areCallbacksLocalToHibernateTransactions() - Method in class org.hibernate.transaction.JDBCTransactionFactory

areCallbacksLocalToHibernateTransactions() - Method in class org.hibernate.transaction.JTATransactionFactory

areCallbacksLocalToHibernateTransactions() - Method in interface org.hibernate.transaction.TransactionFactory
Are all transaction callbacks local to Hibernate Transactions? Or can the callbacks originate from some other source (e.g.
areInsertionsOrDeletionsQueued() - Method in class org.hibernate.engine.ActionQueue
Check whether any insertion or deletion actions are currently queued.
areLazyPropertiesUnfetched() - Method in class org.hibernate.cache.entry.CacheEntry

areTablesToBeUpdated(Set) - Method in class org.hibernate.engine.ActionQueue
Check whether the given tables/query-spaces are to be executed against given the currently queued actions.
arguments(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

arithmeticExpr(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

arithmeticExpr(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

array - Variable in class org.hibernate.collection.PersistentArrayHolder

array(String, String, boolean, Class) - Static method in class org.hibernate.type.TypeFactory

as(String) - Method in class org.hibernate.criterion.SimpleProjection

asAlias() - Method in class org.hibernate.hql.antlr.HqlBaseParser

asXML() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

asXML() - Method in class org.hibernate.tuple.ElementWrapper

asXPathResult(Element) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

asXPathResult(Element) - Method in class org.hibernate.tuple.ElementWrapper

asc(String) - Static method in class org.hibernate.criterion.Order
Ascending order
asc() - Method in class org.hibernate.criterion.Property

ascendingOrDescending() - Method in class org.hibernate.hql.antlr.HqlBaseParser

assemble(Object, Serializable, EntityPersister, Interceptor, EventSource) - Method in class org.hibernate.cache.entry.CacheEntry

assemble(PersistentCollection, CollectionPersister, Object) - Method in class org.hibernate.cache.entry.CollectionCacheEntry

assemble(Serializable, SessionImplementor, Object) - Method in class org.hibernate.type.AbstractType

assemble(Serializable, SessionImplementor, Object) - Method in class org.hibernate.type.AnyType

assemble(Serializable, SessionImplementor, Object) - Method in class org.hibernate.type.CollectionType

assemble(Serializable, SessionImplementor, Object) - Method in class org.hibernate.type.ComponentType

assemble(Serializable, SessionImplementor, Object) - Method in class org.hibernate.type.CompositeCustomType

assemble(Serializable, SessionImplementor, Object) - Method in class org.hibernate.type.CustomType

assemble(Serializable, SessionImplementor, Object) - Method in class org.hibernate.type.ManyToOneType

assemble(Serializable, SessionImplementor, Object) - Method in class org.hibernate.type.OneToOneType

assemble(Serializable, SessionImplementor, Object) - Method in class org.hibernate.type.SerializableType

assemble(Serializable, SessionImplementor, Object) - Method in class org.hibernate.type.SpecialOneToOneType

assemble(Serializable, SessionImplementor, Object) - Method in interface org.hibernate.type.Type
Reconstruct the object from its cached "disassembled" state.
assemble(Serializable[], Type[], SessionImplementor, Object) - Static method in class org.hibernate.type.TypeFactory

assemble(Serializable, SessionImplementor, Object) - Method in interface org.hibernate.usertype.CompositeUserType
Reconstruct an object from the cacheable representation.
assemble(Serializable, Object) - Method in interface org.hibernate.usertype.UserType
Reconstruct an object from the cacheable representation.
assignment() - Method in class org.hibernate.hql.antlr.HqlBaseParser

assignment(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

associations - Variable in class org.hibernate.loader.JoinWalker

atom() - Method in class org.hibernate.hql.antlr.HqlBaseParser

attribute(int) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

attribute(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

attribute(QName) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

attribute(int) - Method in class org.hibernate.tuple.ElementWrapper

attribute(String) - Method in class org.hibernate.tuple.ElementWrapper

attribute(QName) - Method in class org.hibernate.tuple.ElementWrapper

attributeCount() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

attributeCount() - Method in class org.hibernate.tuple.ElementWrapper

attributeIterator() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

attributeIterator() - Method in class org.hibernate.tuple.ElementWrapper

attributeValue(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

attributeValue(String, String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

attributeValue(QName) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

attributeValue(QName, String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

attributeValue(String) - Method in class org.hibernate.tuple.ElementWrapper

attributeValue(String, String) - Method in class org.hibernate.tuple.ElementWrapper

attributeValue(QName) - Method in class org.hibernate.tuple.ElementWrapper

attributeValue(QName, String) - Method in class org.hibernate.tuple.ElementWrapper

attributes() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

attributes() - Method in class org.hibernate.tuple.ElementWrapper

autoDiscoverTypes(ResultSet) - Method in class org.hibernate.loader.Loader

autoDiscoverTypes(ResultSet) - Method in class org.hibernate.loader.custom.CustomLoader

autoFlushIfRequired(Set) - Method in class org.hibernate.impl.SessionImpl
detect in-memory changes, determine if the changes are to tables named in the query and, if so, complete execution the flush
autoFlushIfRequired(Set) - Method in class org.hibernate.impl.StatelessSessionImpl

autoImport - Variable in class org.hibernate.cfg.Mappings

auxiliaryDatabaseObjects - Variable in class org.hibernate.cfg.Configuration

auxiliaryDatabaseObjects - Variable in class org.hibernate.cfg.Mappings

avg(String) - Static method in class org.hibernate.criterion.Projections
A property average value
avg() - Method in class org.hibernate.criterion.Property

B

BASIC - Static variable in class org.hibernate.jdbc.Expectations

BATCH_STRATEGY - Static variable in class org.hibernate.cfg.Environment
Select a custom batcher.
BATCH_VERSIONED_DATA - Static variable in class org.hibernate.cfg.Environment
Should versioned data be included in batching?
BEFORE_FLUSH - Static variable in class org.hibernate.engine.Cascade
A cascade point that occurs just before the session is flushed
BEFORE_INSERT_AFTER_DELETE - Static variable in class org.hibernate.engine.Cascade
A cascade point that occurs just before the insertion of the parent entity and just after deletion
BEFORE_MERGE - Static variable in class org.hibernate.engine.Cascade
A cascade point that occurs just before merging from a transient parent entity into the object in the session cache
BEFORE_REFRESH - Static variable in class org.hibernate.engine.Cascade
A cascade point that occurs just after locking a transient parent entity into the session cache
BESTransactionManagerLookup - class org.hibernate.transaction.BESTransactionManagerLookup.
A TransactionManager lookup strategy for Borland ES.
BESTransactionManagerLookup() - Constructor for class org.hibernate.transaction.BESTransactionManagerLookup

BETWEEN - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

BETWEEN - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

BETWEEN - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

BIG_DECIMAL - Static variable in class org.hibernate.Hibernate
Hibernate big_decimal type.
BIG_INTEGER - Static variable in class org.hibernate.Hibernate
Hibernate big_integer type.
BINARY - Static variable in class org.hibernate.Hibernate
Hibernate binary type.
BLOB - Static variable in class org.hibernate.Hibernate
Hibernate blob type.
BOGUS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

BOGUS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

BOOLEAN - Static variable in class org.hibernate.Hibernate
Hibernate boolean type.
BOTH - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

BOTH - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

BOTH - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

BYTE - Static variable in class org.hibernate.Hibernate
Hibernate byte type.
BYTECODE_PROVIDER - Static variable in class org.hibernate.cfg.Environment

Backref - class org.hibernate.mapping.Backref.

Backref() - Constructor for class org.hibernate.mapping.Backref

BackrefPropertyAccessor - class org.hibernate.property.BackrefPropertyAccessor.
Represents a "back-reference" to the id of a collection owner.
BackrefPropertyAccessor(String, String) - Constructor for class org.hibernate.property.BackrefPropertyAccessor
Constructs a new instance of BackrefPropertyAccessor.
BackrefPropertyAccessor.BackrefGetter - class org.hibernate.property.BackrefPropertyAccessor.BackrefGetter.
The Getter implementation for id backrefs.
BackrefPropertyAccessor.BackrefGetter() - Constructor for class org.hibernate.property.BackrefPropertyAccessor.BackrefGetter

BackrefPropertyAccessor.BackrefSetter - class org.hibernate.property.BackrefPropertyAccessor.BackrefSetter.
The Setter implementation for id backrefs.
BackrefPropertyAccessor.BackrefSetter() - Constructor for class org.hibernate.property.BackrefPropertyAccessor.BackrefSetter

Bag - class org.hibernate.mapping.Bag.
A bag permits duplicates, so it has no primary key
Bag(PersistentClass) - Constructor for class org.hibernate.mapping.Bag

BagType - class org.hibernate.type.BagType.

BagType(String, String, boolean) - Constructor for class org.hibernate.type.BagType

BasicClassFilter - class org.hibernate.bytecode.util.BasicClassFilter.
BasicClassFilter provides class filtering based on a series of packages to be included and/or a series of explicit class names to be included.
BasicClassFilter() - Constructor for class org.hibernate.bytecode.util.BasicClassFilter

BasicClassFilter(String[], String[]) - Constructor for class org.hibernate.bytecode.util.BasicClassFilter

BasicCollectionJoinWalker - class org.hibernate.loader.collection.BasicCollectionJoinWalker.
Walker for collections of values and many-to-many associations
BasicCollectionJoinWalker(QueryableCollection, int, String, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.collection.BasicCollectionJoinWalker

BasicCollectionLoader - class org.hibernate.loader.collection.BasicCollectionLoader.
Loads a collection of values or a many-to-many association.
BasicCollectionLoader(QueryableCollection, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.collection.BasicCollectionLoader

BasicCollectionLoader(QueryableCollection, int, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.collection.BasicCollectionLoader

BasicCollectionLoader(QueryableCollection, int, String, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.collection.BasicCollectionLoader

BasicCollectionPersister - class org.hibernate.persister.collection.BasicCollectionPersister.
Collection persister for collections of values and many-to-many associations.
BasicCollectionPersister(Collection, CacheConcurrencyStrategy, Configuration, SessionFactoryImplementor) - Constructor for class org.hibernate.persister.collection.BasicCollectionPersister

BasicEntityPropertyMapping - class org.hibernate.persister.entity.BasicEntityPropertyMapping.

BasicEntityPropertyMapping(AbstractEntityPersister) - Constructor for class org.hibernate.persister.entity.BasicEntityPropertyMapping

BasicExecutor - class org.hibernate.hql.ast.exec.BasicExecutor.
Implementation of BasicExecutor.
BasicExecutor(HqlSqlWalker, Queryable) - Constructor for class org.hibernate.hql.ast.exec.BasicExecutor

BasicInstrumentationTask - class org.hibernate.tool.instrument.BasicInstrumentationTask.
Super class for all Hibernate instrumentation tasks.
BasicInstrumentationTask() - Constructor for class org.hibernate.tool.instrument.BasicInstrumentationTask

BasicInstrumentationTask.CustomFieldFilter - class org.hibernate.tool.instrument.BasicInstrumentationTask.CustomFieldFilter.

BasicInstrumentationTask.CustomFieldFilter(ClassDescriptor) - Constructor for class org.hibernate.tool.instrument.BasicInstrumentationTask.CustomFieldFilter

BasicInstrumentationTask.Logger - class org.hibernate.tool.instrument.BasicInstrumentationTask.Logger.

BasicInstrumentationTask.Logger() - Constructor for class org.hibernate.tool.instrument.BasicInstrumentationTask.Logger

BasicLazyInitializer - class org.hibernate.proxy.pojo.BasicLazyInitializer.
Lazy initializer for POJOs
BasicLazyInitializer(String, Class, Serializable, Method, Method, AbstractComponentType, SessionImplementor) - Constructor for class org.hibernate.proxy.pojo.BasicLazyInitializer

BasicLoader - class org.hibernate.loader.BasicLoader.
Uses the default mapping from property to result set column alias defined by the entities' persisters.
BasicLoader(SessionFactoryImplementor) - Constructor for class org.hibernate.loader.BasicLoader

BasicPropertyAccessor - class org.hibernate.property.BasicPropertyAccessor.
Accesses property values via a get/set pair, which may be nonpublic.
BasicPropertyAccessor() - Constructor for class org.hibernate.property.BasicPropertyAccessor

BasicPropertyAccessor.BasicGetter - class org.hibernate.property.BasicPropertyAccessor.BasicGetter.

BasicPropertyAccessor.BasicSetter - class org.hibernate.property.BasicPropertyAccessor.BasicSetter.

BasicProxyFactory - interface org.hibernate.bytecode.BasicProxyFactory.
A proxy factory for "basic proxy" generation
BatchFailedException - exception org.hibernate.jdbc.BatchFailedException.
Indicates a failed batch entry (-3 return).
BatchFailedException(String) - Constructor for class org.hibernate.jdbc.BatchFailedException

BatchFailedException(String, Throwable) - Constructor for class org.hibernate.jdbc.BatchFailedException

BatchFetchQueue - class org.hibernate.engine.BatchFetchQueue.
Tracks entity and collection keys that are available for batch fetching, and the queries which were used to load entities, which can be re-used as a subquery for loading owned collections.
BatchFetchQueue(PersistenceContext) - Constructor for class org.hibernate.engine.BatchFetchQueue
Constructs a queue for the given context.
BatchedTooManyRowsAffectedException - exception org.hibernate.jdbc.BatchedTooManyRowsAffectedException.
Much like TooManyRowsAffectedException, indicates that more rows than what we were expcecting were affected.
BatchedTooManyRowsAffectedException(String, int, int, int) - Constructor for class org.hibernate.jdbc.BatchedTooManyRowsAffectedException

Batcher - interface org.hibernate.jdbc.Batcher.
Manages PreparedStatements for a session.
BatcherFactory - interface org.hibernate.jdbc.BatcherFactory.
Factory for Batcher instances.
BatchingBatcher - class org.hibernate.jdbc.BatchingBatcher.
An implementation of the Batcher interface that actually uses batching
BatchingBatcher(ConnectionManager, Interceptor) - Constructor for class org.hibernate.jdbc.BatchingBatcher

BatchingBatcherFactory - class org.hibernate.jdbc.BatchingBatcherFactory.
A BatcherFactory implementation which constructs Batcher instances capable of actually performing batch operations.
BatchingBatcherFactory() - Constructor for class org.hibernate.jdbc.BatchingBatcherFactory

BatchingCollectionInitializer - class org.hibernate.loader.collection.BatchingCollectionInitializer.
"Batch" loads collections, using multiple foreign key values in the SQL where clause.
BatchingCollectionInitializer(CollectionPersister, int[], Loader[]) - Constructor for class org.hibernate.loader.collection.BatchingCollectionInitializer

BatchingEntityLoader - class org.hibernate.loader.entity.BatchingEntityLoader.
"Batch" loads entities, using multiple primary key values in the SQL where clause.
BatchingEntityLoader(EntityPersister, int[], Loader[]) - Constructor for class org.hibernate.loader.entity.BatchingEntityLoader

BetweenExpression - class org.hibernate.criterion.BetweenExpression.
Constrains a property to between two values
BetweenExpression(String, Object, Object) - Constructor for class org.hibernate.criterion.BetweenExpression

BetweenOperatorNode - class org.hibernate.hql.ast.tree.BetweenOperatorNode.
Contract for nodes representing logcial BETWEEN (ternary) operators.
BetweenOperatorNode() - Constructor for class org.hibernate.hql.ast.tree.BetweenOperatorNode

BigDecimalType - class org.hibernate.type.BigDecimalType.
big_decimal: A type that maps an SQL NUMERIC to a java.math.BigDecimal
BigDecimalType() - Constructor for class org.hibernate.type.BigDecimalType

BigIntegerType - class org.hibernate.type.BigIntegerType.
big_integer: A type that maps an SQL NUMERIC to a java.math.BigInteger
BigIntegerType() - Constructor for class org.hibernate.type.BigIntegerType

BinaryArithmeticOperatorNode - class org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode.
Nodes which represent binary arithmetic operators.
BinaryArithmeticOperatorNode() - Constructor for class org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode

BinaryLogicOperatorNode - class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode.
Contract for nodes representing binary operators.
BinaryLogicOperatorNode() - Constructor for class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode

BinaryOperatorNode - interface org.hibernate.hql.ast.tree.BinaryOperatorNode.
Contract for nodes representing binary operators.
BinaryType - class org.hibernate.type.BinaryType.
binary: A type that maps an SQL VARBINARY to a Java byte[].
BinaryType() - Constructor for class org.hibernate.type.BinaryType

Binder - interface org.hibernate.id.insert.Binder.

BlobImpl - class org.hibernate.lob.BlobImpl.
A dummy implementation of java.sql.Blob that may be used to insert new data into a BLOB.
BlobImpl(byte[]) - Constructor for class org.hibernate.lob.BlobImpl

BlobImpl(InputStream, int) - Constructor for class org.hibernate.lob.BlobImpl

BlobType - class org.hibernate.type.BlobType.
blob: A type that maps an SQL BLOB to a java.sql.Blob.
BlobType() - Constructor for class org.hibernate.type.BlobType

BooleanLiteralNode - class org.hibernate.hql.ast.tree.BooleanLiteralNode.
Represents a boolean literal within a query.
BooleanLiteralNode() - Constructor for class org.hibernate.hql.ast.tree.BooleanLiteralNode

BooleanType - class org.hibernate.type.BooleanType.
boolean: A type that maps an SQL BIT to a Java Boolean.
BooleanType() - Constructor for class org.hibernate.type.BooleanType

BorrowedConnectionProxy - class org.hibernate.jdbc.BorrowedConnectionProxy.
A proxy for borrowed connections which funnels all requests back into the ConnectionManager from which it was borrowed to be properly handled (in terms of connection release modes).
BorrowedConnectionProxy(ConnectionManager) - Constructor for class org.hibernate.jdbc.BorrowedConnectionProxy

BulkAccessor - class org.hibernate.bytecode.javassist.BulkAccessor.
A JavaBean accessor.
BulkAccessor() - Constructor for class org.hibernate.bytecode.javassist.BulkAccessor

BulkAccessorException - exception org.hibernate.bytecode.javassist.BulkAccessorException.
An exception thrown while generating a bulk accessor.
BulkAccessorException(String) - Constructor for class org.hibernate.bytecode.javassist.BulkAccessorException
Constructs an exception.
BulkAccessorException(String, int) - Constructor for class org.hibernate.bytecode.javassist.BulkAccessorException
Constructs an exception.
BulkAccessorException(String, Throwable) - Constructor for class org.hibernate.bytecode.javassist.BulkAccessorException
Constructs an exception.
BulkAccessorException(Throwable, int) - Constructor for class org.hibernate.bytecode.javassist.BulkAccessorException
Constructs an exception.
BulkOperationCleanupAction - class org.hibernate.action.BulkOperationCleanupAction.
Implementation of BulkOperationCleanupAction.
BulkOperationCleanupAction(SessionImplementor, Queryable[]) - Constructor for class org.hibernate.action.BulkOperationCleanupAction

BulkOperationCleanupAction(SessionImplementor, Set) - Constructor for class org.hibernate.action.BulkOperationCleanupAction
Create an action that will evict collection and entity regions based on queryspaces (table names).
ByteCodeHelper - class org.hibernate.bytecode.util.ByteCodeHelper.
A helper for reading byte code from various input sources.
ByteType - class org.hibernate.type.ByteType.
byte: A type that maps an SQL TINYINT to a Java Byte.
ByteType() - Constructor for class org.hibernate.type.ByteType

BytecodeProvider - interface org.hibernate.bytecode.BytecodeProvider.
Contract for providers of bytecode services to Hibernate.
BytecodeProviderImpl - class org.hibernate.bytecode.cglib.BytecodeProviderImpl.
Bytecode provider implementation for CGLIB.
BytecodeProviderImpl() - Constructor for class org.hibernate.bytecode.cglib.BytecodeProviderImpl

BytecodeProviderImpl - class org.hibernate.bytecode.javassist.BytecodeProviderImpl.
Bytecode provider implementation for Javassist.
BytecodeProviderImpl() - Constructor for class org.hibernate.bytecode.javassist.BytecodeProviderImpl

BytesHelper - class org.hibernate.util.BytesHelper.

bag - Variable in class org.hibernate.collection.PersistentBag

bag(String, String, boolean) - Static method in class org.hibernate.type.TypeFactory

basic(String) - Static method in class org.hibernate.type.TypeFactory
Given the name of a Hibernate basic type, return an instance of org.hibernate.type.Type.
batchSize - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

before() - Method in class org.hibernate.impl.AbstractQueryImpl

before() - Method in class org.hibernate.impl.CriteriaImpl

beforeAssemble(Serializable, SessionImplementor) - Method in class org.hibernate.type.AbstractType

beforeAssemble(Serializable, SessionImplementor) - Method in class org.hibernate.type.ManyToOneType

beforeAssemble(Serializable, SessionImplementor) - Method in interface org.hibernate.type.Type
Called before assembling a query result set from the query cache, to allow batch fetching of entities missing from the second-level cache.
beforeAssemble(Serializable[], Type[], SessionImplementor) - Static method in class org.hibernate.type.TypeFactory
Determine if any of the given field values are modified, returning an array containing indexes of the dirty fields or null if no fields are dirty.
beforeCompletion() - Method in class org.hibernate.context.JTASessionContext.CleanupSynch

beforeCompletion() - Method in class org.hibernate.context.ThreadLocalSessionContext.CleanupSynch

beforeCompletion() - Method in class org.hibernate.transaction.CacheSynchronization

beforeExecutions() - Method in class org.hibernate.action.BulkOperationCleanupAction

beforeExecutions() - Method in class org.hibernate.action.CollectionAction

beforeExecutions() - Method in class org.hibernate.action.EntityAction

beforeExecutions() - Method in interface org.hibernate.action.Executable
Called before executing any actions
beforeFirst() - Method in interface org.hibernate.ScrollableResults
Go to a location just before first result (this is the initial location)
beforeFirst() - Method in class org.hibernate.impl.FetchingScrollableResultsImpl
Go to a location just before first result (this is the initial location)
beforeFirst() - Method in class org.hibernate.impl.ScrollableResultsImpl

beforeFirst() - Method in class org.hibernate.jdbc.ResultSetWrapper

beforeInitialize(CollectionPersister, int) - Method in class org.hibernate.collection.PersistentArrayHolder

beforeInitialize(CollectionPersister, int) - Method in class org.hibernate.collection.PersistentBag

beforeInitialize(CollectionPersister, int) - Method in interface org.hibernate.collection.PersistentCollection
Called before any elements are read into the collection, allowing appropriate initializations to occur.
beforeInitialize(CollectionPersister, int) - Method in class org.hibernate.collection.PersistentElementHolder

beforeInitialize(CollectionPersister, int) - Method in class org.hibernate.collection.PersistentIdentifierBag

beforeInitialize(CollectionPersister, int) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

beforeInitialize(CollectionPersister, int) - Method in class org.hibernate.collection.PersistentList

beforeInitialize(CollectionPersister, int) - Method in class org.hibernate.collection.PersistentMap

beforeInitialize(CollectionPersister, int) - Method in class org.hibernate.collection.PersistentSet

beforeLoad() - Method in interface org.hibernate.engine.PersistenceContext
Call this before begining a two-phase load
beforeLoad() - Method in class org.hibernate.engine.StatefulPersistenceContext
Call this before begining a two-phase load
beforeSelectClause() - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

beforeSelectClause() - Method in class org.hibernate.hql.ast.HqlSqlWalker

beforeTransactionCompletion(Transaction) - Method in class org.hibernate.EmptyInterceptor

beforeTransactionCompletion(Transaction) - Method in interface org.hibernate.Interceptor
Called before a transaction is committed (but not before rollback).
beforeTransactionCompletion(Transaction) - Method in interface org.hibernate.engine.SessionImplementor
Notify the session that the transaction is about to complete
beforeTransactionCompletion(Transaction) - Method in class org.hibernate.impl.SessionImpl

beforeTransactionCompletion(Transaction) - Method in class org.hibernate.impl.StatelessSessionImpl

beforeTransactionCompletion(Transaction) - Method in interface org.hibernate.jdbc.JDBCContext.Context

beforeTransactionCompletion(Transaction) - Method in class org.hibernate.jdbc.JDBCContext

begin() - Method in interface org.hibernate.Transaction
Begin a new transaction.
begin() - Method in class org.hibernate.transaction.CMTTransaction

begin() - Method in class org.hibernate.transaction.JDBCTransaction

begin() - Method in class org.hibernate.transaction.JTATransaction

begin() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter

beginFunctionTemplate(AST, AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

beginFunctionTemplate(AST, AST) - Method in class org.hibernate.hql.ast.SqlGenerator

beginRead() - Method in class org.hibernate.collection.AbstractPersistentCollection
Called just before reading any rows from the JDBC result set
beginRead() - Method in class org.hibernate.collection.PersistentArrayHolder

beginRead() - Method in interface org.hibernate.collection.PersistentCollection
Called just before reading any rows from the JDBC result set
beginRead() - Method in class org.hibernate.collection.PersistentSet

beginTransaction() - Method in interface org.hibernate.Session
Begin a unit of work and return the associated Transaction object.
beginTransaction() - Method in interface org.hibernate.StatelessSession
Begin a Hibernate transaction.
beginTransaction() - Method in class org.hibernate.impl.SessionImpl

beginTransaction() - Method in class org.hibernate.impl.StatelessSessionImpl

bestGuessEntityName(Object) - Method in interface org.hibernate.engine.SessionImplementor
The best guess entity name for an entity not in an association
bestGuessEntityName(Object) - Method in class org.hibernate.impl.SessionImpl

bestGuessEntityName(Object) - Method in class org.hibernate.impl.StatelessSessionImpl

between(Object, Object) - Method in class org.hibernate.criterion.Property

between(String, Object, Object) - Static method in class org.hibernate.criterion.Restrictions
Apply a "between" constraint to the named property
betweenList() - Method in class org.hibernate.hql.antlr.HqlBaseParser

binaryComparisonExpression(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

bind(Session) - Static method in class org.hibernate.context.ManagedSessionContext
Binds the given session to the current context for its session factory.
bind(Session) - Static method in class org.hibernate.context.ThreadLocalSessionContext
Associates the given session with the current thread of execution.
bind(PreparedStatement, QueryParameters, SessionImplementor, int) - Method in class org.hibernate.param.NamedParameterSpecification
Bind the appropriate value into the given statement at the specified position.
bind(PreparedStatement, QueryParameters, SessionImplementor, int) - Method in interface org.hibernate.param.ParameterSpecification
Bind the appropriate value into the given statement at the specified position.
bind(PreparedStatement, QueryParameters, SessionImplementor, int) - Method in class org.hibernate.param.PositionalParameterSpecification
Bind the appropriate value into the given statement at the specified position.
bind(PreparedStatement, QueryParameters, SessionImplementor, int) - Method in class org.hibernate.param.VersionTypeSeedParameterSpecification

bind(Context, String, Object) - Static method in class org.hibernate.util.NamingHelper
Bind val to name in ctx, and make sure that all intermediate contexts exist.
bindAny(Element, Any, boolean, Mappings) - Static method in class org.hibernate.cfg.HbmBinder

bindArray(Element, Array, String, String, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder
Called for arrays and primitive arrays
bindClass(Element, PersistentClass, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder

bindCollection(Element, Collection, String, String, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder
Called for all collections
bindCollectionSecondPass(Element, Collection, Map, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder
Called for all collections
bindColumn(Element, Column, boolean) - Static method in class org.hibernate.cfg.HbmBinder

bindColumns(Element, SimpleValue, boolean, boolean, String, Mappings) - Static method in class org.hibernate.cfg.HbmBinder

bindComponent(Element, Component, String, String, String, boolean, boolean, Mappings, Map, boolean) - Static method in class org.hibernate.cfg.HbmBinder

bindComposite(Element, Component, String, boolean, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder

bindCompositeId(Element, Component, PersistentClass, String, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder

bindIdentifierCollectionSecondPass(Element, IdentifierCollection, Map, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder

bindJoinedSubclass(Element, JoinedSubclass, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder

bindLimitParametersFirst() - Method in class org.hibernate.dialect.Dialect
Does the LIMIT clause come at the start of the SELECT statement, rather than at the end?
bindLimitParametersFirst() - Method in class org.hibernate.dialect.FirebirdDialect

bindLimitParametersFirst() - Method in class org.hibernate.dialect.H2Dialect

bindLimitParametersFirst() - Method in class org.hibernate.dialect.HSQLDialect

bindLimitParametersFirst() - Method in class org.hibernate.dialect.InterbaseDialect

bindLimitParametersInReverseOrder() - Method in class org.hibernate.dialect.Dialect
Does the LIMIT clause specify arguments in the "reverse" order limit, offset instead of offset, limit?
bindLimitParametersInReverseOrder() - Method in class org.hibernate.dialect.FirebirdDialect

bindLimitParametersInReverseOrder() - Method in class org.hibernate.dialect.H2Dialect

bindLimitParametersInReverseOrder() - Method in class org.hibernate.dialect.InterbaseDialect

bindLimitParametersInReverseOrder() - Method in class org.hibernate.dialect.Oracle9Dialect

bindLimitParametersInReverseOrder() - Method in class org.hibernate.dialect.PostgreSQLDialect

bindListSecondPass(Element, List, Map, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder
Called for Lists, arrays, primitive arrays
bindManyToOne(Element, ManyToOne, String, boolean, Mappings) - Static method in class org.hibernate.cfg.HbmBinder

bindMapSecondPass(Element, Map, Map, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder
Called for Maps
bindNamedParameters(PreparedStatement, QueryParameters, int, ParameterBinder.NamedParameterSource, SessionImplementor) - Static method in class org.hibernate.engine.ParameterBinder

bindNamedParameters(PreparedStatement, Map, int, ParameterBinder.NamedParameterSource, SessionImplementor) - Static method in class org.hibernate.engine.ParameterBinder

bindNamedParameters(PreparedStatement, Map, int, SessionImplementor) - Method in class org.hibernate.loader.Loader
Bind named parameters to the PreparedStatement.
bindNamedParameters(PreparedStatement, Map, int, SessionImplementor) - Method in class org.hibernate.loader.hql.QueryLoader

bindOneToMany(Element, OneToMany, Mappings) - Static method in class org.hibernate.cfg.HbmBinder

bindOneToOne(Element, OneToOne, String, boolean, Mappings) - Static method in class org.hibernate.cfg.HbmBinder

bindParameters(SessionImplementor, PreparedStatement, Object) - Method in class org.hibernate.id.SelectGenerator.SelectGeneratorDelegate

bindParameters(SessionImplementor, PreparedStatement, Object) - Method in class org.hibernate.id.insert.AbstractSelectingDelegate
Bind any required parameter values into the SQL command AbstractSelectingDelegate.getSelectSQL().
bindPositionalParameters(PreparedStatement, QueryParameters, int, SessionImplementor) - Static method in class org.hibernate.engine.ParameterBinder

bindPositionalParameters(PreparedStatement, Object[], Type[], int, SessionImplementor) - Static method in class org.hibernate.engine.ParameterBinder

bindPositionalParameters(PreparedStatement, QueryParameters, int, SessionImplementor) - Method in class org.hibernate.loader.Loader
Bind positional parameter values to the PreparedStatement (these are parameters specified by a JDBC-style ?).
bindProperty(Element, Property, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder

bindQueryParameters(PreparedStatement, QueryParameters, int, ParameterBinder.NamedParameterSource, SessionImplementor) - Static method in class org.hibernate.engine.ParameterBinder

bindRoot(Document, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder
The main contract into the hbm.xml-based binder.
bindRootClass(Element, RootClass, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder
Responsible for perfoming the bind operation related to an <class/> mapping element.
bindSimpleValue(Element, SimpleValue, boolean, String, Mappings) - Static method in class org.hibernate.cfg.HbmBinder

bindSubclass(Element, Subclass, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder

bindUnionSubclass(Element, UnionSubclass, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder

bindValues(PreparedStatement) - Method in interface org.hibernate.id.insert.Binder

booleanExpr(AST, boolean) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

booleanOp(AST, boolean) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

booleanValue(String) - Static method in class org.hibernate.util.StringHelper

borrowConnection() - Method in class org.hibernate.jdbc.ConnectionManager

borrowConnection() - Method in class org.hibernate.jdbc.JDBCContext

buildBasicProxyFactory(Class, Class[]) - Method in interface org.hibernate.bytecode.ProxyFactoryFactory
Build a proxy factory for basic proxy concerns.
buildBasicProxyFactory(Class, Class[]) - Method in class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl

buildBasicProxyFactory(Class, Class[]) - Method in class org.hibernate.bytecode.javassist.ProxyFactoryFactoryImpl

buildBytecodeProvider(Properties) - Static method in class org.hibernate.cfg.Environment

buildBytecodeProvider(String) - Method in class org.hibernate.cfg.SettingsFactory

buildCache(String, Properties) - Method in interface org.hibernate.cache.CacheProvider
Configure the cache
buildCache(String, Properties) - Method in class org.hibernate.cache.EhCacheProvider
Builds a Cache.
buildCache(String, Properties) - Method in class org.hibernate.cache.HashtableCacheProvider

buildCache(String, Properties) - Method in class org.hibernate.cache.JndiBoundTreeCacheProvider
Construct a Cache representing the "region" within in the underlying cache provider.
buildCache(String, Properties) - Method in class org.hibernate.cache.NoCacheProvider
Configure the cache
buildCache(String, Properties) - Method in class org.hibernate.cache.OSCacheProvider
Builds a new Cache instance, and gets it's properties from the OSCache Config which reads the properties file (oscache.properties) from the classpath.
buildCache(String, Properties) - Method in class org.hibernate.cache.OptimisticTreeCacheProvider
Construct and configure the Cache representation of a named cache region.
buildCache(String, Properties) - Method in class org.hibernate.cache.SwarmCacheProvider

buildCache(String, Properties) - Method in class org.hibernate.cache.TreeCacheProvider
Construct and configure the Cache representation of a named cache region.
buildCleanupSynch() - Method in class org.hibernate.context.ThreadLocalSessionContext

buildConfiguration() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

buildDialect(Properties, String, int) - Static method in class org.hibernate.dialect.DialectFactory
Builds an appropriate Dialect instance.
buildDialect(String) - Static method in class org.hibernate.dialect.DialectFactory
Returns a dialect instance given the name of the class to use.
buildGetter(Component, Property) - Method in class org.hibernate.tuple.component.AbstractComponentTuplizer

buildGetter(Component, Property) - Method in class org.hibernate.tuple.component.Dom4jComponentTuplizer

buildGetter(Component, Property) - Method in class org.hibernate.tuple.component.DynamicMapComponentTuplizer

buildGetter(Component, Property) - Method in class org.hibernate.tuple.component.PojoComponentTuplizer

buildIdentifierProperty(PersistentClass, IdentifierGenerator) - Static method in class org.hibernate.tuple.PropertyFactory
Generates an IdentifierProperty representation of the for a given entity mapping.
buildInstantiator(Component) - Method in class org.hibernate.tuple.component.AbstractComponentTuplizer

buildInstantiator(Component) - Method in class org.hibernate.tuple.component.Dom4jComponentTuplizer

buildInstantiator(Component) - Method in class org.hibernate.tuple.component.DynamicMapComponentTuplizer

buildInstantiator(Component) - Method in class org.hibernate.tuple.component.PojoComponentTuplizer

buildInstantiator(PersistentClass) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer
Build an appropriate Instantiator for the given mapped entity.
buildInstantiator(PersistentClass) - Method in class org.hibernate.tuple.entity.Dom4jEntityTuplizer

buildInstantiator(PersistentClass) - Method in class org.hibernate.tuple.entity.DynamicMapEntityTuplizer

buildInstantiator(PersistentClass) - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

buildMapping() - Method in class org.hibernate.cfg.Configuration

buildMappings() - Method in class org.hibernate.cfg.Configuration
Call this to ensure the mappings are fully compiled/built.
buildMinimalSQLExceptionConverter() - Static method in class org.hibernate.exception.SQLExceptionConverterFactory
Builds a minimal converter.
buildOrObtainSession() - Method in class org.hibernate.context.JTASessionContext
Strictly provided for subclassing purposes; specifically to allow long-session support.
buildOrObtainSession() - Method in class org.hibernate.context.ThreadLocalSessionContext
Strictly provided for subclassing purposes; specifically to allow long-session support.
buildPositionsArray() - Method in class org.hibernate.engine.query.ParamLocationRecognizer.NamedParameterDescription

buildProperties() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

buildPropertyGetter(Property, PersistentClass) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer
Build an appropriate Getter for the given property.
buildPropertyGetter(Property, PersistentClass) - Method in class org.hibernate.tuple.entity.Dom4jEntityTuplizer

buildPropertyGetter(Property, PersistentClass) - Method in class org.hibernate.tuple.entity.DynamicMapEntityTuplizer

buildPropertyGetter(Property, PersistentClass) - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

buildPropertyPath(String, String) - Static method in class org.hibernate.PropertyValueException
Return a well formed property path.
buildPropertySetter(Property, PersistentClass) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer
Build an appropriate Setter for the given property.
buildPropertySetter(Property, PersistentClass) - Method in class org.hibernate.tuple.entity.Dom4jEntityTuplizer

buildPropertySetter(Property, PersistentClass) - Method in class org.hibernate.tuple.entity.DynamicMapEntityTuplizer

buildPropertySetter(Property, PersistentClass) - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

buildProxyFactory() - Method in interface org.hibernate.bytecode.ProxyFactoryFactory
Build a proxy factory specifically for handling runtime lazy loading.
buildProxyFactory() - Method in class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl
Builds a CGLIB-based proxy factory.
buildProxyFactory() - Method in class org.hibernate.bytecode.javassist.ProxyFactoryFactoryImpl
Builds a Javassist-based proxy factory.
buildProxyFactory(PersistentClass, Getter, Setter) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer
Build an appropriate ProxyFactory for the given mapped entity.
buildProxyFactory(PersistentClass, Getter, Setter) - Method in class org.hibernate.tuple.entity.Dom4jEntityTuplizer

buildProxyFactory(PersistentClass, Getter, Setter) - Method in class org.hibernate.tuple.entity.DynamicMapEntityTuplizer

buildProxyFactory(PersistentClass, Getter, Setter) - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

buildProxyFactoryInternal(PersistentClass, Getter, Setter) - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

buildResultRow(Object[], ResultSet, boolean, SessionImplementor) - Method in class org.hibernate.loader.custom.CustomLoader.ResultRowProcessor
Build a logical result row.
buildResultSetMappingDefinition(Element, String, Mappings) - Static method in class org.hibernate.cfg.ResultSetMappingBinder
Build a ResultSetMappingDefinition given a containing element for the "return-XXX" elements
buildSQLExceptionConverter() - Method in class org.hibernate.dialect.Dialect
Build an instance of the SQLExceptionConverter preferred by this dialect for converting SQLExceptions into Hibernate's JDBCException hierarchy.
buildSQLExceptionConverter(Dialect, Properties) - Static method in class org.hibernate.exception.SQLExceptionConverterFactory
Build a SQLExceptionConverter instance.
buildSessionFactory() - Method in class org.hibernate.cfg.Configuration
Instantiate a new SessionFactory, using the properties and mappings in this configuration.
buildSetter(Component, Property) - Method in class org.hibernate.tuple.component.AbstractComponentTuplizer

buildSetter(Component, Property) - Method in class org.hibernate.tuple.component.Dom4jComponentTuplizer

buildSetter(Component, Property) - Method in class org.hibernate.tuple.component.DynamicMapComponentTuplizer

buildSetter(Component, Property) - Method in class org.hibernate.tuple.component.PojoComponentTuplizer

buildSettings() - Method in class org.hibernate.cfg.Configuration
Create an object-oriented view of the configuration properties
buildSettings(Properties) - Method in class org.hibernate.cfg.Configuration

buildSettings(Properties) - Method in class org.hibernate.cfg.SettingsFactory

buildSqlCreateIndexString(Dialect, String, Table, Iterator, boolean, String, String) - Static method in class org.hibernate.mapping.Index

buildSqlDropIndexString(Dialect, Table, String, String, String) - Static method in class org.hibernate.mapping.Index

buildStandardProperty(Property, boolean) - Static method in class org.hibernate.tuple.PropertyFactory
Generate a "standard" (i.e., non-identifier and non-version) based on the given mapped property.
buildTokenTypeASTClassMap() - Method in class org.hibernate.hql.antlr.HqlBaseParser

buildTransactionFactory(Properties) - Static method in class org.hibernate.transaction.TransactionFactoryFactory
Obtain a TransactionFactory with the transaction handling strategy specified by the given Properties.
buildVersionProperty(Property, boolean) - Static method in class org.hibernate.tuple.PropertyFactory
Generates a VersionProperty representation for an entity mapping given its version mapping Property.

C

C3P0ConnectionProvider - class org.hibernate.connection.C3P0ConnectionProvider.
A connection provider that uses a C3P0 connection pool.
C3P0ConnectionProvider() - Constructor for class org.hibernate.connection.C3P0ConnectionProvider

C3P0_ACQUIRE_INCREMENT - Static variable in class org.hibernate.cfg.Environment
Number of connections acquired when pool is exhausted
C3P0_IDLE_TEST_PERIOD - Static variable in class org.hibernate.cfg.Environment
Idle time before a C3P0 pooled connection is validated
C3P0_MAX_SIZE - Static variable in class org.hibernate.cfg.Environment
Maximum size of C3P0 connection pool
C3P0_MAX_STATEMENTS - Static variable in class org.hibernate.cfg.Environment
Maximum size of C3P0 statement cache
C3P0_MIN_SIZE - Static variable in class org.hibernate.cfg.Environment
Minimum size of C3P0 connection pool
C3P0_TIMEOUT - Static variable in class org.hibernate.cfg.Environment
Maximum idle time for C3P0 connection pool
CACHE_NAMESPACE - Static variable in class org.hibernate.cfg.Environment
The CacheProvider JNDI namespace, if pre-bound to JNDI.
CACHE_PROVIDER - Static variable in class org.hibernate.cfg.Environment
The CacheProvider implementation class
CACHE_PROVIDER_CONFIG - Static variable in class org.hibernate.cfg.Environment
The CacheProvider implementation class
CACHE_REGION_PREFIX - Static variable in class org.hibernate.cfg.Environment
The CacheProvider region name prefix
CALENDAR - Static variable in class org.hibernate.Hibernate
Hibernate calendar type.
CALENDAR_DATE - Static variable in class org.hibernate.Hibernate
Hibernate calendar_date type.
CASE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

CASE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

CASE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

CASE2 - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

CASE2 - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

CASE2 - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

CATALOG - Static variable in interface org.hibernate.id.PersistentIdentifierGenerator
The configuration parameter holding the catalog name
CGLIBHelper - class org.hibernate.intercept.cglib.CGLIBHelper.

CGLIBLazyInitializer - class org.hibernate.proxy.pojo.cglib.CGLIBLazyInitializer.
A LazyInitializer implemented using the CGLIB bytecode generation library
CGLIBProxyFactory - class org.hibernate.proxy.pojo.cglib.CGLIBProxyFactory.

CGLIBProxyFactory() - Constructor for class org.hibernate.proxy.pojo.cglib.CGLIBProxyFactory

CHARACTER - Static variable in class org.hibernate.Hibernate
Hibernate character type.
CHARACTER_ARRAY - Static variable in class org.hibernate.Hibernate
Hibernate Character[] type.
CHAR_ARRAY - Static variable in class org.hibernate.Hibernate
Hibernate char[] type.
CLASS - Static variable in class org.hibernate.Hibernate
Hibernate class type.
CLASS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

CLASS - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

CLASS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

CLOB - Static variable in class org.hibernate.Hibernate
Hibernate clob type.
CLOSE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

CLOSE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

CLOSE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

CLOSED_QUOTE - Static variable in class org.hibernate.dialect.Dialect

CLOSE_BRACKET - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

CLOSE_BRACKET - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

CLOSE_BRACKET - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

CMTTransaction - class org.hibernate.transaction.CMTTransaction.
Implements a basic transaction strategy for CMT transactions.
CMTTransaction(JDBCContext, TransactionFactory.Context) - Constructor for class org.hibernate.transaction.CMTTransaction

CMTTransactionFactory - class org.hibernate.transaction.CMTTransactionFactory.
Factory for CMTTransaction.
CMTTransactionFactory() - Constructor for class org.hibernate.transaction.CMTTransactionFactory

COLLECTION_ELEMENTS - Static variable in class org.hibernate.persister.collection.CollectionPropertyNames

COLLECTION_INDEX - Static variable in class org.hibernate.persister.collection.CollectionPropertyNames

COLLECTION_INDICES - Static variable in class org.hibernate.persister.collection.CollectionPropertyNames

COLLECTION_MAX_ELEMENT - Static variable in class org.hibernate.persister.collection.CollectionPropertyNames

COLLECTION_MAX_INDEX - Static variable in class org.hibernate.persister.collection.CollectionPropertyNames

COLLECTION_MIN_ELEMENT - Static variable in class org.hibernate.persister.collection.CollectionPropertyNames

COLLECTION_MIN_INDEX - Static variable in class org.hibernate.persister.collection.CollectionPropertyNames

COLLECTION_SIZE - Static variable in class org.hibernate.persister.collection.CollectionPropertyNames

COLON - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

COLON - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

COLON - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

COLUMN - Static variable in class org.hibernate.id.TableGenerator
The column parameter
COMMA - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

COMMA - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

COMMA - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

COMMIT - Static variable in class org.hibernate.FlushMode
The Session is flushed when Transaction.commit() is called.
CONCAT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

CONCAT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

CONCAT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

CONFIG_RESOURCE - Static variable in class org.hibernate.cache.OptimisticTreeCacheProvider
Deprecated. use Environment.CACHE_PROVIDER_CONFIG
CONFIG_RESOURCE - Static variable in class org.hibernate.cache.TreeCacheProvider
Deprecated. use org.hibernate.cfg.Environment.CACHE_PROVIDER_CONFIG
CONNECTION_PREFIX - Static variable in class org.hibernate.cfg.Environment
prefix for arbitrary JDBC connection properties
CONNECTION_PROVIDER - Static variable in class org.hibernate.cfg.Environment
ConnectionProvider implementor to use when obtaining connections
CONSTANT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

CONSTANT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

CONSTANT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

CONSTRUCTOR - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

CONSTRUCTOR - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

CONSTRUCTOR - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

COUNT - Static variable in class org.hibernate.engine.ExecuteUpdateResultCheckStyle
Perform row-count checking.
COUNT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

COUNT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

COUNT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

CURRENCY - Static variable in class org.hibernate.Hibernate
Hibernate currency type.
CURRENCY_CLASS - Static variable in class org.hibernate.type.CurrencyType

CURRENT_SESSION_CONTEXT_CLASS - Static variable in class org.hibernate.cfg.Environment
Context scoping impl for SessionFactory.getCurrentSession() processing.
Cache - interface org.hibernate.cache.Cache.
Implementors define a caching algorithm.
CacheConcurrencyStrategy - interface org.hibernate.cache.CacheConcurrencyStrategy.
Implementors manage transactional access to cached data.
CacheConcurrencyStrategy.SoftLock - interface org.hibernate.cache.CacheConcurrencyStrategy.SoftLock.
Marker interface, denoting a client-visible "soft lock" on a cached item.
CacheEntry - class org.hibernate.cache.entry.CacheEntry.
A cached instance of a persistent class
CacheEntry(Object[], EntityPersister, boolean, Object, SessionImplementor, Object) - Constructor for class org.hibernate.cache.entry.CacheEntry

CacheEntryStructure - interface org.hibernate.cache.entry.CacheEntryStructure.

CacheException - exception org.hibernate.cache.CacheException.
Something went wrong in the cache
CacheException(String) - Constructor for class org.hibernate.cache.CacheException

CacheException(String, Exception) - Constructor for class org.hibernate.cache.CacheException

CacheException(Exception) - Constructor for class org.hibernate.cache.CacheException

CacheFactory - class org.hibernate.cache.CacheFactory.

CacheKey - class org.hibernate.cache.CacheKey.
Allows multiple entity classes / collection roles to be stored in the same cache region.
CacheKey(Serializable, Type, String, EntityMode, SessionFactoryImplementor) - Constructor for class org.hibernate.cache.CacheKey
Construct a new key for a collection or entity instance.
CacheMode - class org.hibernate.CacheMode.
Controls how the session interacts with the second-level cache and query cache.
CacheProvider - interface org.hibernate.cache.CacheProvider.
Support for pluggable caches.
CacheSynchronization - class org.hibernate.transaction.CacheSynchronization.

CacheSynchronization(TransactionFactory.Context, JDBCContext, Transaction, Transaction) - Constructor for class org.hibernate.transaction.CacheSynchronization

CalendarComparator - class org.hibernate.util.CalendarComparator.

CalendarComparator() - Constructor for class org.hibernate.util.CalendarComparator

CalendarDateType - class org.hibernate.type.CalendarDateType.
calendar_date: A type mapping for a Calendar object that represents a date.
CalendarDateType() - Constructor for class org.hibernate.type.CalendarDateType

CalendarType - class org.hibernate.type.CalendarType.
calendar: A type mapping for a Calendar object that represents a datetime.
CalendarType() - Constructor for class org.hibernate.type.CalendarType

CallbackException - exception org.hibernate.CallbackException.
Should be thrown by persistent objects from Lifecycle or Interceptor callbacks.
CallbackException(Exception) - Constructor for class org.hibernate.CallbackException

CallbackException(String) - Constructor for class org.hibernate.CallbackException

CallbackException(String, Exception) - Constructor for class org.hibernate.CallbackException

Cascade - class org.hibernate.engine.Cascade.
Delegate responsible for, in conjunction with the various actions, implementing cascade processing.
Cascade(CascadingAction, int, EventSource) - Constructor for class org.hibernate.engine.Cascade

CascadeEntityJoinWalker - class org.hibernate.loader.entity.CascadeEntityJoinWalker.

CascadeEntityJoinWalker(OuterJoinLoadable, CascadingAction, SessionFactoryImplementor) - Constructor for class org.hibernate.loader.entity.CascadeEntityJoinWalker

CascadeEntityLoader - class org.hibernate.loader.entity.CascadeEntityLoader.

CascadeEntityLoader(OuterJoinLoadable, CascadingAction, SessionFactoryImplementor) - Constructor for class org.hibernate.loader.entity.CascadeEntityLoader

CascadeStyle - class org.hibernate.engine.CascadeStyle.
A style of cascade that can be specified by the mapping for an association.
CascadeStyle.MultipleCascadeStyle - class org.hibernate.engine.CascadeStyle.MultipleCascadeStyle.

CascadeStyle.MultipleCascadeStyle(CascadeStyle[]) - Constructor for class org.hibernate.engine.CascadeStyle.MultipleCascadeStyle

CascadingAction - class org.hibernate.engine.CascadingAction.
A session action that may be cascaded from parent entity to its children
Case2Node - class org.hibernate.hql.ast.tree.Case2Node.
Represents a case ...
Case2Node() - Constructor for class org.hibernate.hql.ast.tree.Case2Node

CaseFragment - class org.hibernate.sql.CaseFragment.
Abstract SQL case fragment renderer
CaseFragment() - Constructor for class org.hibernate.sql.CaseFragment

CaseNode - class org.hibernate.hql.ast.tree.CaseNode.
Represents a case ...
CaseNode() - Constructor for class org.hibernate.hql.ast.tree.CaseNode

CastFunction - class org.hibernate.dialect.function.CastFunction.
ANSI-SQL style cast(foo as type) where the type is a Hibernate type
CastFunction() - Constructor for class org.hibernate.dialect.function.CastFunction

CategorizedStatistics - class org.hibernate.stat.CategorizedStatistics.
Statistics for a particular "category" (a named entity, collection role, second level cache region or query).
CglibClassTransformer - class org.hibernate.bytecode.cglib.CglibClassTransformer.
Enhance the classes allowing them to implements InterceptFieldEnabled This interface is then used by Hibernate for some optimizations.
CglibClassTransformer(ClassFilter, FieldFilter) - Constructor for class org.hibernate.bytecode.cglib.CglibClassTransformer

ChainedPropertyAccessor - class org.hibernate.property.ChainedPropertyAccessor.

ChainedPropertyAccessor(PropertyAccessor[]) - Constructor for class org.hibernate.property.ChainedPropertyAccessor

CharArrayType - class org.hibernate.type.CharArrayType.
put char[] into VARCHAR
CharArrayType() - Constructor for class org.hibernate.type.CharArrayType

CharBooleanType - class org.hibernate.type.CharBooleanType.
Superclass for types that map Java boolean to SQL CHAR(1).
CharBooleanType() - Constructor for class org.hibernate.type.CharBooleanType

CharIndexFunction - class org.hibernate.dialect.function.CharIndexFunction.
Emulation of locate() on Sybase
CharIndexFunction() - Constructor for class org.hibernate.dialect.function.CharIndexFunction

CharacterArrayType - class org.hibernate.type.CharacterArrayType.
Bridge Character[] and VARCHAR
CharacterArrayType() - Constructor for class org.hibernate.type.CharacterArrayType

CharacterType - class org.hibernate.type.CharacterType.
character: A type that maps an SQL CHAR(1) to a Java Character.
CharacterType() - Constructor for class org.hibernate.type.CharacterType

ClassDescriptor - interface org.hibernate.bytecode.util.ClassDescriptor.
Contract describing the information Hibernate needs in terms of instrumenting a class, either via ant task or dynamic classloader.
ClassFilter - interface org.hibernate.bytecode.util.ClassFilter.
Used to determine whether a class should be instrumented.
ClassMetadata - interface org.hibernate.metadata.ClassMetadata.
Exposes entity class metadata to the application
ClassTransformer - interface org.hibernate.bytecode.ClassTransformer.
A persistence provider provides an instance of this interface to the PersistenceUnitInfo.addTransformer method.
ClassType - class org.hibernate.type.ClassType.
class: A type that maps an SQL VARCHAR to a Java Class.
ClassType() - Constructor for class org.hibernate.type.ClassType

ClassicAvgFunction - class org.hibernate.dialect.function.ClassicAvgFunction.
Classic AVG sqlfunction that return types as it was done in Hibernate 3.1
ClassicAvgFunction() - Constructor for class org.hibernate.dialect.function.ClassicAvgFunction

ClassicCountFunction - class org.hibernate.dialect.function.ClassicCountFunction.
Classic COUNT sqlfunction that return types as it was done in Hibernate 3.1
ClassicCountFunction() - Constructor for class org.hibernate.dialect.function.ClassicCountFunction

ClassicQueryTranslatorFactory - class org.hibernate.hql.classic.ClassicQueryTranslatorFactory.
Generates translators which uses the older hand-written parser to perform the translation.
ClassicQueryTranslatorFactory() - Constructor for class org.hibernate.hql.classic.ClassicQueryTranslatorFactory

ClassicSumFunction - class org.hibernate.dialect.function.ClassicSumFunction.
Classic SUM sqlfunction that return types as it was done in Hibernate 3.1
ClassicSumFunction() - Constructor for class org.hibernate.dialect.function.ClassicSumFunction

ClauseParser - class org.hibernate.hql.classic.ClauseParser.
Parses the Hibernate query into its constituent clauses.
ClauseParser() - Constructor for class org.hibernate.hql.classic.ClauseParser

ClobImpl - class org.hibernate.lob.ClobImpl.
A dummy implementation of java.sql.Clob that may be used to insert new data into a CLOB.
ClobImpl(String) - Constructor for class org.hibernate.lob.ClobImpl

ClobImpl(Reader, int) - Constructor for class org.hibernate.lob.ClobImpl

ClobType - class org.hibernate.type.ClobType.
clob: A type that maps an SQL CLOB to a java.sql.Clob.
ClobType() - Constructor for class org.hibernate.type.ClobType

Cloneable - class org.hibernate.util.Cloneable.
An object that is shallow-coneable
Cloneable() - Constructor for class org.hibernate.util.Cloneable

Collection - class org.hibernate.mapping.Collection.
Mapping for a collection.
Collection(PersistentClass) - Constructor for class org.hibernate.mapping.Collection

CollectionAction - class org.hibernate.action.CollectionAction.
Any action relating to insert/update/delete of a collection
CollectionAction(CollectionPersister, PersistentCollection, Serializable, SessionImplementor) - Constructor for class org.hibernate.action.CollectionAction

CollectionAliases - interface org.hibernate.loader.CollectionAliases.
Type definition of CollectionAliases.
CollectionCacheEntry - class org.hibernate.cache.entry.CollectionCacheEntry.

CollectionCacheEntry(PersistentCollection, CollectionPersister) - Constructor for class org.hibernate.cache.entry.CollectionCacheEntry

CollectionElementLoader - class org.hibernate.loader.entity.CollectionElementLoader.

CollectionElementLoader(QueryableCollection, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.entity.CollectionElementLoader

CollectionEntry - class org.hibernate.engine.CollectionEntry.
We need an entry to tell us all about the current state of a collection with respect to its persistent state
CollectionEntry(CollectionPersister, PersistentCollection) - Constructor for class org.hibernate.engine.CollectionEntry
For newly wrapped collections, or dereferenced collection wrappers
CollectionEntry(PersistentCollection, CollectionPersister, Serializable, boolean) - Constructor for class org.hibernate.engine.CollectionEntry
For collections just loaded from the database
CollectionEntry(CollectionPersister, Serializable) - Constructor for class org.hibernate.engine.CollectionEntry
For uninitialized detached collections
CollectionFetchReturn - class org.hibernate.loader.custom.CollectionFetchReturn.
Spefically a fetch return that refers to a collection association.
CollectionFetchReturn(String, NonScalarReturn, String, CollectionAliases, EntityAliases, LockMode) - Constructor for class org.hibernate.loader.custom.CollectionFetchReturn

CollectionFilterImpl - class org.hibernate.impl.CollectionFilterImpl.
implementation of the Query interface for collection filters
CollectionFilterImpl(String, Object, SessionImplementor, ParameterMetadata) - Constructor for class org.hibernate.impl.CollectionFilterImpl

CollectionFunction - class org.hibernate.hql.ast.tree.CollectionFunction.
Represents 'elements()' or 'indices()'.
CollectionFunction() - Constructor for class org.hibernate.hql.ast.tree.CollectionFunction

CollectionHelper - class org.hibernate.util.CollectionHelper.

CollectionInitializer - interface org.hibernate.loader.collection.CollectionInitializer.
An interface for collection loaders
CollectionJoinWalker - class org.hibernate.loader.collection.CollectionJoinWalker.
Superclass of walkers for collection initializers
CollectionJoinWalker(SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.collection.CollectionJoinWalker

CollectionKey - class org.hibernate.engine.CollectionKey.
Uniquely identifies a collection instance in a particular session.
CollectionKey(CollectionPersister, Serializable, EntityMode) - Constructor for class org.hibernate.engine.CollectionKey

CollectionLoadContext - class org.hibernate.engine.CollectionLoadContext.
Represents the state of collections currently being loaded.
CollectionLoadContext(PersistenceContext) - Constructor for class org.hibernate.engine.CollectionLoadContext

CollectionLoader - class org.hibernate.loader.collection.CollectionLoader.
Superclass for loaders that initialize collections
CollectionLoader(QueryableCollection, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.collection.CollectionLoader

CollectionMetadata - interface org.hibernate.metadata.CollectionMetadata.
Exposes collection metadata to the application
CollectionPersister - interface org.hibernate.persister.collection.CollectionPersister.
A strategy for persisting a collection role.
CollectionProperties - class org.hibernate.hql.CollectionProperties.
Provides a map of collection function names to the corresponding property names.
CollectionPropertyMapping - class org.hibernate.persister.collection.CollectionPropertyMapping.

CollectionPropertyMapping(QueryableCollection) - Constructor for class org.hibernate.persister.collection.CollectionPropertyMapping

CollectionPropertyNames - class org.hibernate.persister.collection.CollectionPropertyNames.
The names of all the collection properties.
CollectionPropertyNames() - Constructor for class org.hibernate.persister.collection.CollectionPropertyNames

CollectionRecreateAction - class org.hibernate.action.CollectionRecreateAction.

CollectionRecreateAction(PersistentCollection, CollectionPersister, Serializable, SessionImplementor) - Constructor for class org.hibernate.action.CollectionRecreateAction

CollectionRemoveAction - class org.hibernate.action.CollectionRemoveAction.

CollectionRemoveAction(PersistentCollection, CollectionPersister, Serializable, boolean, SessionImplementor) - Constructor for class org.hibernate.action.CollectionRemoveAction

CollectionReturn - class org.hibernate.loader.custom.CollectionReturn.
Represents a return which names a collection role; it is used in defining a custom query for loading an entity's collection in non-fetching scenarios (i.e., loading the collection itself as the "root" of the result).
CollectionReturn(String, String, String, CollectionAliases, EntityAliases, LockMode) - Constructor for class org.hibernate.loader.custom.CollectionReturn

CollectionSecondPass - class org.hibernate.cfg.CollectionSecondPass.
Collection second pass
CollectionSecondPass(Mappings, Collection, Map) - Constructor for class org.hibernate.cfg.CollectionSecondPass

CollectionSecondPass(Mappings, Collection) - Constructor for class org.hibernate.cfg.CollectionSecondPass

CollectionStatistics - class org.hibernate.stat.CollectionStatistics.
Collection related statistics
CollectionSubqueryFactory - class org.hibernate.hql.CollectionSubqueryFactory.
Provides the SQL for collection subqueries.
CollectionType - class org.hibernate.type.CollectionType.
A type that handles Hibernate PersistentCollections (including arrays).
CollectionType(String, String, boolean) - Constructor for class org.hibernate.type.CollectionType

CollectionUpdateAction - class org.hibernate.action.CollectionUpdateAction.

CollectionUpdateAction(PersistentCollection, CollectionPersister, Serializable, boolean, SessionImplementor) - Constructor for class org.hibernate.action.CollectionUpdateAction

Collections - class org.hibernate.engine.Collections.
Implements book-keeping for the collection persistence by reachability algorithm
Column - class org.hibernate.mapping.Column.
A column of a relational database table
Column() - Constructor for class org.hibernate.mapping.Column

Column(String) - Constructor for class org.hibernate.mapping.Column

ColumnCollectionAliases - class org.hibernate.loader.custom.ColumnCollectionAliases.
CollectionAliases that uses columnnames instead of generated aliases.
ColumnCollectionAliases(Map, SQLLoadableCollection) - Constructor for class org.hibernate.loader.custom.ColumnCollectionAliases

ColumnEntityAliases - class org.hibernate.loader.ColumnEntityAliases.
EntityAliases that chooses the column names over the alias names.
ColumnEntityAliases(Map, Loadable, String) - Constructor for class org.hibernate.loader.ColumnEntityAliases

ColumnHelper - class org.hibernate.hql.ast.util.ColumnHelper.
Provides utility methods for dealing with arrays of SQL column names.
ColumnMetadata - class org.hibernate.tool.hbm2ddl.ColumnMetadata.
JDBC column metadata
ColumnNameCache - class org.hibernate.jdbc.ColumnNameCache.
Implementation of ColumnNameCache.
ColumnNameCache(int) - Constructor for class org.hibernate.jdbc.ColumnNameCache

ComparableComparator - class org.hibernate.util.ComparableComparator.
Delegates to Comparable
ComparableComparator() - Constructor for class org.hibernate.util.ComparableComparator

Component - class org.hibernate.mapping.Component.
The mapping for a component, composite element, composite identifier, etc.
Component(PersistentClass) - Constructor for class org.hibernate.mapping.Component

Component(Component) - Constructor for class org.hibernate.mapping.Component

Component(Join) - Constructor for class org.hibernate.mapping.Component

Component(Collection) - Constructor for class org.hibernate.mapping.Component

ComponentMetamodel - class org.hibernate.tuple.component.ComponentMetamodel.
Centralizes metamodel information about a component.
ComponentMetamodel(Component) - Constructor for class org.hibernate.tuple.component.ComponentMetamodel

ComponentTuplizer - interface org.hibernate.tuple.component.ComponentTuplizer.
Defines further responsibilities reagarding tuplization based on a mapped components.
ComponentType - class org.hibernate.type.ComponentType.
Handles "component" mappings
ComponentType(ComponentMetamodel) - Constructor for class org.hibernate.type.ComponentType

CompositeCustomType - class org.hibernate.type.CompositeCustomType.
Adapts CompositeUserType to Type interface
CompositeCustomType(Class, Properties) - Constructor for class org.hibernate.type.CompositeCustomType

CompositeElementPropertyMapping - class org.hibernate.persister.collection.CompositeElementPropertyMapping.

CompositeElementPropertyMapping(String[], String[], AbstractComponentType, Mapping) - Constructor for class org.hibernate.persister.collection.CompositeElementPropertyMapping

CompositeUserType - interface org.hibernate.usertype.CompositeUserType.
A UserType that may be dereferenced in a query.
ConditionFragment - class org.hibernate.sql.ConditionFragment.

ConditionFragment() - Constructor for class org.hibernate.sql.ConditionFragment

ConfigHelper - class org.hibernate.util.ConfigHelper.
A simple class to centralize logic needed to locate config files on the system.
Configurable - interface org.hibernate.exception.Configurable.
The Configurable interface defines the contract for SQLExceptionConverter impls that want to be configured prior to usage given the currently defined Hibernate properties.
Configurable - interface org.hibernate.id.Configurable.
An IdentifierGenerator that supports "configuration".
Configuration - class org.hibernate.cfg.Configuration.
An instance of Configuration allows the application to specify properties and mapping documents to be used when creating a SessionFactory.
Configuration(SettingsFactory) - Constructor for class org.hibernate.cfg.Configuration

Configuration() - Constructor for class org.hibernate.cfg.Configuration

Conjunction - class org.hibernate.criterion.Conjunction.

Conjunction() - Constructor for class org.hibernate.criterion.Conjunction

ConnectionManager - class org.hibernate.jdbc.ConnectionManager.
Encapsulates JDBC Connection management logic needed by Hibernate.
ConnectionManager(SessionFactoryImplementor, ConnectionManager.Callback, ConnectionReleaseMode, Connection, Interceptor) - Constructor for class org.hibernate.jdbc.ConnectionManager
Constructs a ConnectionManager.
ConnectionManager.Callback - interface org.hibernate.jdbc.ConnectionManager.Callback.

ConnectionProvider - interface org.hibernate.connection.ConnectionProvider.
A strategy for obtaining JDBC connections.
ConnectionProviderFactory - class org.hibernate.connection.ConnectionProviderFactory.
Instantiates a connection provider given either System properties or a java.util.Properties instance.
ConnectionReleaseMode - class org.hibernate.ConnectionReleaseMode.
Defines the various policies by which Hibernate might release its underlying JDBC connection.
Constraint - class org.hibernate.mapping.Constraint.
A relational constraint.
Constraint() - Constructor for class org.hibernate.mapping.Constraint

ConstraintViolationException - exception org.hibernate.exception.ConstraintViolationException.
Implementation of JDBCException indicating that the requested DML operation resulted in a violation of a defined integrity constraint.
ConstraintViolationException(String, SQLException, String) - Constructor for class org.hibernate.exception.ConstraintViolationException

ConstraintViolationException(String, SQLException, String, String) - Constructor for class org.hibernate.exception.ConstraintViolationException

ConstructorNode - class org.hibernate.hql.ast.tree.ConstructorNode.
Represents a constructor (new) in a SELECT.
ConstructorNode() - Constructor for class org.hibernate.hql.ast.tree.ConstructorNode

CountNode - class org.hibernate.hql.ast.tree.CountNode.
Represents a COUNT expression in a select.
CountNode() - Constructor for class org.hibernate.hql.ast.tree.CountNode

CountProjection - class org.hibernate.criterion.CountProjection.
A count
CountProjection(String) - Constructor for class org.hibernate.criterion.CountProjection

Criteria - interface org.hibernate.Criteria.
Criteria is a simplified API for retrieving entities by composing Criterion objects.
CriteriaImpl - class org.hibernate.impl.CriteriaImpl.
Implementation of the Criteria interface
CriteriaImpl(String, SessionImplementor) - Constructor for class org.hibernate.impl.CriteriaImpl

CriteriaImpl(String, String, SessionImplementor) - Constructor for class org.hibernate.impl.CriteriaImpl

CriteriaImpl.CriterionEntry - class org.hibernate.impl.CriteriaImpl.CriterionEntry.

CriteriaImpl.OrderEntry - class org.hibernate.impl.CriteriaImpl.OrderEntry.

CriteriaImpl.Subcriteria - class org.hibernate.impl.CriteriaImpl.Subcriteria.

CriteriaJoinWalker - class org.hibernate.loader.criteria.CriteriaJoinWalker.
A JoinWalker for Criteria queries.
CriteriaJoinWalker(OuterJoinLoadable, CriteriaQueryTranslator, SessionFactoryImplementor, CriteriaImpl, String, Map) - Constructor for class org.hibernate.loader.criteria.CriteriaJoinWalker

CriteriaLoader - class org.hibernate.loader.criteria.CriteriaLoader.
A Loader for Criteria queries.
CriteriaLoader(OuterJoinLoadable, SessionFactoryImplementor, CriteriaImpl, String, Map) - Constructor for class org.hibernate.loader.criteria.CriteriaLoader

CriteriaQuery - interface org.hibernate.criterion.CriteriaQuery.
An instance of CriteriaQuery is passed to criterion, order and projection instances when actually compiling and executing the query.
CriteriaQueryTranslator - class org.hibernate.loader.criteria.CriteriaQueryTranslator.

CriteriaQueryTranslator(SessionFactoryImplementor, CriteriaImpl, String, String, CriteriaQuery) - Constructor for class org.hibernate.loader.criteria.CriteriaQueryTranslator

CriteriaQueryTranslator(SessionFactoryImplementor, CriteriaImpl, String, String) - Constructor for class org.hibernate.loader.criteria.CriteriaQueryTranslator

CriteriaSpecification - interface org.hibernate.criterion.CriteriaSpecification.

Criterion - interface org.hibernate.criterion.Criterion.
An object-oriented representation of a query criterion that may be used as a restriction in a Criteria query.
CurrencyType - class org.hibernate.type.CurrencyType.
currency: A type that maps an SQL VARCHAR to a java.util.Currency
CurrencyType() - Constructor for class org.hibernate.type.CurrencyType

CurrentSessionContext - interface org.hibernate.context.CurrentSessionContext.
Defines the contract for implementations which know how to scope the notion of a current session.
CustomCollectionType - class org.hibernate.type.CustomCollectionType.
A custom type for mapping user-written classes that implement PersistentCollection
CustomCollectionType(Class, String, String, boolean) - Constructor for class org.hibernate.type.CustomCollectionType

CustomLoader - class org.hibernate.loader.custom.CustomLoader.
Extension point for loaders which use a SQL result set with "unexpected" column aliases.
CustomLoader(CustomQuery, SessionFactoryImplementor) - Constructor for class org.hibernate.loader.custom.CustomLoader

CustomLoader.NonScalarResultColumnProcessor - class org.hibernate.loader.custom.CustomLoader.NonScalarResultColumnProcessor.

CustomLoader.NonScalarResultColumnProcessor(int) - Constructor for class org.hibernate.loader.custom.CustomLoader.NonScalarResultColumnProcessor

CustomLoader.ResultRowProcessor - class org.hibernate.loader.custom.CustomLoader.ResultRowProcessor.

CustomLoader.ResultRowProcessor(boolean, CustomLoader.ResultColumnProcessor[]) - Constructor for class org.hibernate.loader.custom.CustomLoader.ResultRowProcessor

CustomLoader.ScalarResultColumnProcessor - class org.hibernate.loader.custom.CustomLoader.ScalarResultColumnProcessor.

CustomLoader.ScalarResultColumnProcessor(int) - Constructor for class org.hibernate.loader.custom.CustomLoader.ScalarResultColumnProcessor

CustomLoader.ScalarResultColumnProcessor(String, Type) - Constructor for class org.hibernate.loader.custom.CustomLoader.ScalarResultColumnProcessor

CustomQuery - interface org.hibernate.loader.custom.CustomQuery.
Extension point allowing any SQL query with named and positional parameters to be executed by Hibernate, returning managed entities, collections and simple scalar values.
CustomType - class org.hibernate.type.CustomType.
Adapts UserType to the generic Type interface, in order to isolate user code from changes in the internal Type contracts.
CustomType(Class, Properties) - Constructor for class org.hibernate.type.CustomType

canBeBatched() - Method in interface org.hibernate.jdbc.Expectation

canBeBatched() - Method in class org.hibernate.jdbc.Expectations.BasicExpectation

canBeBatched() - Method in class org.hibernate.jdbc.Expectations.BasicParamExpectation

canExtractIdOutOfEntity() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

canExtractIdOutOfEntity() - Method in interface org.hibernate.persister.entity.EntityPersister
Do detached instances of this class carry their own identifier value?
cancelLastQuery() - Method in class org.hibernate.jdbc.AbstractBatcher

cancelLastQuery() - Method in interface org.hibernate.jdbc.Batcher
Cancel the current query statement
cancelQuery() - Method in interface org.hibernate.Session
Cancel execution of the current query.
cancelQuery() - Method in class org.hibernate.impl.SessionImpl

cancelRowUpdates() - Method in class org.hibernate.jdbc.ResultSetWrapper

cascade(EntityPersister, Object) - Method in class org.hibernate.engine.Cascade
Cascade an action from the parent entity instance to all its children.
cascade(EntityPersister, Object, Object) - Method in class org.hibernate.engine.Cascade
Cascade an action from the parent entity instance to all its children.
cascade(EventSource, Object, String, Object, boolean) - Method in class org.hibernate.engine.CascadingAction
Cascade the action to the child object.
cascadeAfterDelete(EventSource, EntityPersister, Object, Set) - Method in class org.hibernate.event.def.DefaultDeleteEventListener

cascadeAfterSave(EventSource, EntityPersister, Object, Object) - Method in class org.hibernate.event.def.AbstractSaveEventListener
Handles to calls needed to perform post-save cascades.
cascadeAfterSave(EventSource, EntityPersister, Object, Object) - Method in class org.hibernate.event.def.DefaultMergeEventListener
Cascade behavior is redefined by this subclass, disable superclass behavior
cascadeBeforeDelete(EventSource, EntityPersister, Object, EntityEntry, Set) - Method in class org.hibernate.event.def.DefaultDeleteEventListener

cascadeBeforeSave(EventSource, EntityPersister, Object, Object) - Method in class org.hibernate.event.def.AbstractSaveEventListener
Handles the calls needed to perform pre-save cascades for the given entity.
cascadeBeforeSave(EventSource, EntityPersister, Object, Object) - Method in class org.hibernate.event.def.DefaultMergeEventListener
Cascade behavior is redefined by this subclass, disable superclass behavior
cascadeNow(int) - Method in class org.hibernate.type.ForeignKeyDirection
Should we cascade at this cascade point?
cascadeOnMerge(EventSource, EntityPersister, Object, Map) - Method in class org.hibernate.event.def.DefaultMergeEventListener
Perform any cascades needed as part of this copy event.
caseExpr(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

caseExpr(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

caseExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

cases - Variable in class org.hibernate.sql.CaseFragment

catalogName - Variable in class org.hibernate.cfg.Mappings

check(int, Serializable, int, Expectation, PreparedStatement) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

checkColumnDuplication(Set, Iterator) - Method in class org.hibernate.mapping.PersistentClass

checkColumnDuplication() - Method in class org.hibernate.mapping.PersistentClass

checkId(Object, EntityPersister, Serializable, EntityMode) - Method in class org.hibernate.event.def.DefaultFlushEntityEventListener
make sure user didn't mangle the id
checkMagic(File, long) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

checkNullability(Object[], EntityPersister, boolean) - Method in class org.hibernate.engine.Nullability
Check nullability of the class persister properties
checkPermission(Class, String, EJBMethodPermission) - Static method in class org.hibernate.secure.JACCPermissions

checkPropertyColumnDuplication(Set, Iterator) - Method in class org.hibernate.mapping.PersistentClass

checkScrollability() - Method in class org.hibernate.loader.Loader
Check whether the current loader can support returning ScrollableResults.
checkUniqueness(EntityKey, Object) - Method in interface org.hibernate.engine.PersistenceContext
Attempts to check whether the given key represents an entity already loaded within the current session.
checkUniqueness(EntityKey, Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Attempts to check whether the given key represents an entity already loaded within the current session.
classFilter - Variable in class org.hibernate.bytecode.AbstractClassTransformerImpl

classForName(String) - Static method in class org.hibernate.util.ReflectHelper

classForName(String, Class) - Static method in class org.hibernate.util.ReflectHelper

classToTableName(String) - Method in class org.hibernate.cfg.DefaultNamingStrategy
Return the unqualified class name
classToTableName(String) - Method in class org.hibernate.cfg.ImprovedNamingStrategy
Return the unqualified class name, mixed case converted to underscores
classToTableName(String) - Method in interface org.hibernate.cfg.NamingStrategy
Return a table name for an entity class
classes - Variable in class org.hibernate.cfg.Configuration

classes - Variable in class org.hibernate.cfg.Mappings

clear() - Method in interface org.hibernate.Session
Completely clear the session.
clear() - Method in interface org.hibernate.cache.Cache
Clear the cache
clear() - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Evict all items from the cache immediately.
clear() - Method in class org.hibernate.cache.EhCache
Remove all elements in the cache, but leave the cache in a useable state.
clear() - Method in class org.hibernate.cache.HashtableCache

clear() - Method in class org.hibernate.cache.NonstrictReadWriteCache

clear() - Method in class org.hibernate.cache.OSCache

clear() - Method in class org.hibernate.cache.OptimisticTreeCache

clear() - Method in interface org.hibernate.cache.QueryCache

clear() - Method in class org.hibernate.cache.ReadOnlyCache

clear() - Method in class org.hibernate.cache.ReadWriteCache

clear() - Method in class org.hibernate.cache.StandardQueryCache

clear() - Method in class org.hibernate.cache.SwarmCache
Clear the cache
clear() - Method in class org.hibernate.cache.TransactionalCache

clear() - Method in class org.hibernate.cache.TreeCache

clear() - Method in class org.hibernate.cache.UpdateTimestampsCache

clear() - Method in class org.hibernate.collection.PersistentBag

clear() - Method in class org.hibernate.collection.PersistentIdentifierBag

clear() - Method in class org.hibernate.collection.PersistentList

clear() - Method in class org.hibernate.collection.PersistentMap

clear() - Method in class org.hibernate.collection.PersistentSet

clear() - Method in class org.hibernate.engine.ActionQueue

clear() - Method in class org.hibernate.engine.BatchFetchQueue
Clears all entries from this fetch queue.
clear() - Method in interface org.hibernate.engine.PersistenceContext
Clear the state of the persistence context
clear() - Method in class org.hibernate.engine.StatefulPersistenceContext

clear() - Method in class org.hibernate.impl.SessionImpl

clear() - Method in class org.hibernate.jmx.StatisticsService

clear() - Method in class org.hibernate.proxy.map.MapProxy

clear() - Method in interface org.hibernate.stat.Statistics
reset all statistics
clear() - Method in class org.hibernate.stat.StatisticsImpl
reset all statistics
clear() - Method in class org.hibernate.util.FastHashMap
Remove all mappings from this map.
clear() - Method in class org.hibernate.util.IdentityMap

clear() - Method in class org.hibernate.util.IdentitySet

clear() - Method in class org.hibernate.util.SimpleMRUCache

clear() - Method in class org.hibernate.util.SoftLimitMRUCache

clearContent() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

clearContent() - Method in class org.hibernate.tuple.ElementWrapper

clearDirty() - Method in class org.hibernate.collection.AbstractPersistentCollection

clearDirty() - Method in interface org.hibernate.collection.PersistentCollection
Clear the dirty flag, after flushing changes to the database.
clearDirty() - Method in class org.hibernate.intercept.AbstractFieldInterceptor

clearDirty(Object) - Static method in class org.hibernate.intercept.FieldInterceptionHelper

clearDirty() - Method in interface org.hibernate.intercept.FieldInterceptor
Clear the internal dirty flag.
clearFromFlushNeededCheck(int) - Method in class org.hibernate.engine.ActionQueue

clearSubselects() - Method in class org.hibernate.engine.BatchFetchQueue
Clears all pending subselect fetches from the queue.
clearWarnings() - Method in class org.hibernate.jdbc.ResultSetWrapper

clearWherePart() - Method in class org.hibernate.sql.QueryJoinFragment

clone() - Method in class org.hibernate.mapping.Column
Shallow copy, the value is not copied
clone() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

clone() - Method in class org.hibernate.tuple.ElementWrapper

clone() - Method in class org.hibernate.util.FastHashMap
Return a shallow copy of this FastHashMap instance.
clone(Serializable) - Static method in class org.hibernate.util.SerializationHelper
Deep clone an Object using serialization.
cloneDeletions() - Method in class org.hibernate.engine.ActionQueue

close(Iterator) - Static method in class org.hibernate.Hibernate
Close an Iterator created by iterate() immediately, instead of waiting until the session is closed or disconnected.
close() - Method in interface org.hibernate.ScrollableResults
Release resources immediately.
close() - Method in interface org.hibernate.Session
End the Session by disconnecting from the JDBC connection and cleaning up.
close() - Method in interface org.hibernate.SessionFactory
Destroy this SessionFactory and release all resources (caches, connection pools, etc).
close() - Method in interface org.hibernate.StatelessSession
Close the stateless session and release the JDBC connection.
close() - Method in class org.hibernate.connection.C3P0ConnectionProvider

close() - Method in interface org.hibernate.connection.ConnectionProvider
Release all resources held by this provider.
close() - Method in class org.hibernate.connection.DatasourceConnectionProvider

close() - Method in class org.hibernate.connection.DriverManagerConnectionProvider

close() - Method in class org.hibernate.connection.ProxoolConnectionProvider
Release all resources held by this provider.
close() - Method in class org.hibernate.connection.UserSuppliedConnectionProvider

close() - Method in interface org.hibernate.engine.HibernateIterator

close() - Method in class org.hibernate.impl.AbstractScrollableResults

close() - Method in class org.hibernate.impl.IteratorImpl

close() - Method in class org.hibernate.impl.SessionFactoryImpl
Closes the session factory, releasing all held resources.
close() - Method in class org.hibernate.impl.SessionImpl

close() - Method in class org.hibernate.impl.StatelessSessionImpl

close() - Method in class org.hibernate.jdbc.ConnectionManager
To be called after Session completion.
close() - Method in class org.hibernate.jdbc.ResultSetWrapper

close() - Method in class org.hibernate.jmx.SessionFactoryStub

closeConnection(Connection) - Method in class org.hibernate.connection.C3P0ConnectionProvider

closeConnection(Connection) - Method in interface org.hibernate.connection.ConnectionProvider
Dispose of a used connection.
closeConnection(Connection) - Method in class org.hibernate.connection.DatasourceConnectionProvider

closeConnection(Connection) - Method in class org.hibernate.connection.DriverManagerConnectionProvider

closeConnection(Connection) - Method in class org.hibernate.connection.ProxoolConnectionProvider
Dispose of a used connection.
closeConnection(Connection) - Method in class org.hibernate.connection.UserSuppliedConnectionProvider

closeConnection(Connection) - Method in class org.hibernate.jdbc.AbstractBatcher

closeConnection(Connection) - Method in interface org.hibernate.jdbc.Batcher
Dispose of the JDBC connection
closeQueryStatement(PreparedStatement, ResultSet) - Method in class org.hibernate.jdbc.AbstractBatcher

closeQueryStatement(PreparedStatement, ResultSet) - Method in interface org.hibernate.jdbc.Batcher
Close a prepared statement opened with prepareQueryStatement()
closeQuote() - Method in class org.hibernate.dialect.Dialect
The closing quote for a quoted identifier
closeQuote() - Method in class org.hibernate.dialect.MySQLDialect

closeQuote() - Method in class org.hibernate.dialect.SQLServerDialect

closeSession() - Method in class org.hibernate.stat.StatisticsImpl

closeSession() - Method in interface org.hibernate.stat.StatisticsImplementor

closeStatement(PreparedStatement) - Method in class org.hibernate.jdbc.AbstractBatcher

closeStatement(PreparedStatement) - Method in interface org.hibernate.jdbc.Batcher
Close a prepared or callable statement opened using prepareStatement() or prepareCallableStatement()
closeStatement() - Method in class org.hibernate.stat.StatisticsImpl

closeStatement() - Method in interface org.hibernate.stat.StatisticsImplementor

closeStatements() - Method in class org.hibernate.jdbc.AbstractBatcher
Actually releases the batcher, allowing it to cleanup internally held resources.
closeStatements() - Method in interface org.hibernate.jdbc.Batcher
Close any query statements that were left lying around
collectChildren(AST, ASTUtil.FilterPredicate) - Static method in class org.hibernate.hql.ast.util.ASTUtil

collectSelectExpressions() - Method in class org.hibernate.hql.ast.tree.SelectExpressionList
Returns an array of SelectExpressions gathered from the children of the given parent AST node.
collectSqlStrings() - Method in interface org.hibernate.hql.QueryTranslator

collectSqlStrings() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

collectSqlStrings() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

collectionExpr() - Method in class org.hibernate.hql.antlr.HqlBaseParser

collectionFunction(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

collectionFunctionOrSubselect(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

collectionInfoString(CollectionPersister, Serializable[], SessionFactoryImplementor) - Static method in class org.hibernate.pretty.MessageHelper
Generate an info message string relating to a series of managed collections.
collectionInfoString(CollectionPersister, Serializable, SessionFactoryImplementor) - Static method in class org.hibernate.pretty.MessageHelper
Generate an info message string relating to a particular managed collection.
collectionInfoString(String, Serializable) - Static method in class org.hibernate.pretty.MessageHelper
Generate an info message string relating to a particular managed collection.
collectionOwners - Variable in class org.hibernate.loader.JoinWalker

collectionOwners - Variable in class org.hibernate.loader.OuterJoinLoader

collectionPersisters - Variable in class org.hibernate.loader.JoinWalker

collectionPersisters - Variable in class org.hibernate.loader.OuterJoinLoader

collectionSuffixes - Variable in class org.hibernate.loader.JoinWalker

collectionSuffixes - Variable in class org.hibernate.loader.OuterJoinLoader

collectionTableName(String, String, String, String, String) - Method in class org.hibernate.cfg.DefaultNamingStrategy
Return the unqualified property name, not the best strategy but a backward compatible one
collectionTableName(String, String, String, String, String) - Method in class org.hibernate.cfg.ImprovedNamingStrategy

collectionTableName(String, String, String, String, String) - Method in interface org.hibernate.cfg.NamingStrategy
Return a collection table name ie an association having a join table
collections - Variable in class org.hibernate.cfg.Configuration

collections - Variable in class org.hibernate.cfg.Mappings

columnIterator() - Method in class org.hibernate.mapping.Constraint

columnName(String) - Method in class org.hibernate.cfg.DefaultNamingStrategy
Return the argument
columnName(String) - Method in class org.hibernate.cfg.ImprovedNamingStrategy
Convert mixed case to underscores
columnName(String) - Method in interface org.hibernate.cfg.NamingStrategy
Alter the column name given in the mapping document
columnNameBindingPerTable - Variable in class org.hibernate.cfg.Configuration

columnNameBindingPerTable - Variable in class org.hibernate.cfg.Mappings
binding table between the logical column name and the name out of the naming strategy for each table.
commaBetweenParameters(String) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

commaBetweenParameters(String) - Method in class org.hibernate.hql.ast.SqlGenerator

commit() - Method in interface org.hibernate.Transaction
Flush the associated Session and end the unit of work (unless we are in FlushMode.NEVER.
commit() - Method in class org.hibernate.transaction.CMTTransaction

commit() - Method in class org.hibernate.transaction.JDBCTransaction

commit() - Method in class org.hibernate.transaction.JTATransaction

commit() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter

commit() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter

comparator - Variable in class org.hibernate.collection.PersistentSortedMap

comparator() - Method in class org.hibernate.collection.PersistentSortedMap

comparator - Variable in class org.hibernate.collection.PersistentSortedSet

comparator() - Method in class org.hibernate.collection.PersistentSortedSet

compare(Object, Object) - Method in class org.hibernate.type.AbstractBynaryType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.AbstractBynaryType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.AbstractType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.AdaptedImmutableType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.AnyType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.BlobType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.CalendarDateType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.CalendarType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.ClobType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.CollectionType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.ComponentType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.EntityType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.LocaleType

compare(Object, Object, EntityMode) - Method in class org.hibernate.type.TimeZoneType

compare(Object, Object, EntityMode) - Method in interface org.hibernate.type.Type
compare two instances of the type
compare(Object, Object) - Method in class org.hibernate.util.CalendarComparator

compare(Object, Object) - Method in class org.hibernate.util.ComparableComparator

compareTo(Object) - Method in class org.hibernate.action.CollectionAction

compareTo(Object) - Method in class org.hibernate.action.EntityAction

comparisonExpr(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

comparisonExpr(AST, boolean) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

compile(String, Map, boolean) - Method in interface org.hibernate.hql.FilterTranslator
Compile a filter.
compile(Map, boolean) - Method in interface org.hibernate.hql.QueryTranslator
Compile a "normal" query.
compile(Map, boolean) - Method in class org.hibernate.hql.ast.QueryTranslatorImpl
Compile a "normal" query.
compile(String, Map, boolean) - Method in class org.hibernate.hql.ast.QueryTranslatorImpl
Compile a filter.
compile(Map, boolean) - Method in class org.hibernate.hql.classic.QueryTranslatorImpl
Compile a "normal" query.
compile(String, Map, boolean) - Method in class org.hibernate.hql.classic.QueryTranslatorImpl
Compile a filter.
componentIdType - Variable in class org.hibernate.proxy.pojo.BasicLazyInitializer

compoundExpr() - Method in class org.hibernate.hql.antlr.HqlBaseParser

concatenation() - Method in class org.hibernate.hql.antlr.HqlBaseParser

concretePropertySelectFragment(String, boolean[]) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

concretePropertySelectFragmentSansLeadingComma(String, boolean[]) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

concreteQueries(String, SessionFactoryImplementor) - Static method in class org.hibernate.hql.QuerySplitter
Handle Hibernate "implicit" polymorphism, by translating the query string into several "concrete" queries against mapped classes.
concurrentEntries(Map) - Static method in class org.hibernate.util.IdentityMap
Return the map entries (as instances of Map.Entry in a collection that is safe from concurrent modification).
conditionList(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

configure() - Method in class org.hibernate.cfg.Configuration
Use the mappings and properties specified in an application resource named hibernate.cfg.xml.
configure(String) - Method in class org.hibernate.cfg.Configuration
Use the mappings and properties specified in the given application resource.
configure(URL) - Method in class org.hibernate.cfg.Configuration
Use the mappings and properties specified in the given document.
configure(File) - Method in class org.hibernate.cfg.Configuration
Use the mappings and properties specified in the given application file.
configure(Document) - Method in class org.hibernate.cfg.Configuration
Use the mappings and properties specified in the given XML document.
configure(Properties) - Method in class org.hibernate.connection.C3P0ConnectionProvider

configure(Properties) - Method in interface org.hibernate.connection.ConnectionProvider
Initialize the connection provider from given properties.
configure(Properties) - Method in class org.hibernate.connection.DatasourceConnectionProvider

configure(Properties) - Method in class org.hibernate.connection.DriverManagerConnectionProvider

configure(Properties) - Method in class org.hibernate.connection.ProxoolConnectionProvider
Initialize the connection provider from given properties.
configure(Properties) - Method in class org.hibernate.connection.UserSuppliedConnectionProvider

configure(Properties) - Method in interface org.hibernate.exception.Configurable
Configure the component, using the given settings and properties.
configure(Type, Properties, Dialect) - Method in class org.hibernate.id.Assigned

configure(Type, Properties, Dialect) - Method in interface org.hibernate.id.Configurable
Configure this instance, given the value of parameters specified by the user as <param> elements.
configure(Type, Properties, Dialect) - Method in class org.hibernate.id.ForeignGenerator

configure(Type, Properties, Dialect) - Method in class org.hibernate.id.IncrementGenerator

configure(Type, Properties, Dialect) - Method in class org.hibernate.id.MultipleHiLoPerTableGenerator

configure(Type, Properties, Dialect) - Method in class org.hibernate.id.SelectGenerator

configure(Type, Properties, Dialect) - Method in class org.hibernate.id.SequenceGenerator

configure(Type, Properties, Dialect) - Method in class org.hibernate.id.SequenceHiLoGenerator

configure(Type, Properties, Dialect) - Method in class org.hibernate.id.SequenceIdentityGenerator

configure(Type, Properties, Dialect) - Method in class org.hibernate.id.TableGenerator

configure(Type, Properties, Dialect) - Method in class org.hibernate.id.TableHiLoGenerator

configure(Type, Properties, Dialect) - Method in class org.hibernate.id.UUIDHexGenerator

configure(Properties) - Method in class org.hibernate.transaction.CMTTransactionFactory

configure(Properties) - Method in class org.hibernate.transaction.JDBCTransactionFactory

configure(Properties) - Method in class org.hibernate.transaction.JTATransactionFactory

configure(Properties) - Method in interface org.hibernate.transaction.TransactionFactory
Configure from the given properties.
conjunction() - Static method in class org.hibernate.criterion.Restrictions
Group expressions together in a single conjunction (A and B and C...)
connect() - Method in class org.hibernate.stat.StatisticsImpl

connect() - Method in interface org.hibernate.stat.StatisticsImplementor

connection() - Method in interface org.hibernate.Session
Get the JDBC connection of this Session.

If the session is using aggressive collection release (as in a CMT environment), it is the application's responsibility to close the connection returned by this call.
connection() - Method in interface org.hibernate.StatelessSession
Returns the current JDBC connection associated with this instance.

If the session is using aggressive connection release (as in a CMT environment), it is the application's responsibility to close the connection returned by this call.
connection() - Method in interface org.hibernate.engine.SessionImplementor

connection() - Method in class org.hibernate.impl.SessionImpl

connection() - Method in class org.hibernate.impl.StatelessSessionImpl

connection() - Method in class org.hibernate.jdbc.JDBCContext

connectionCleanedUp() - Method in interface org.hibernate.jdbc.ConnectionManager.Callback

connectionCleanedUp() - Method in class org.hibernate.jdbc.JDBCContext

connectionOpened() - Method in interface org.hibernate.jdbc.ConnectionManager.Callback

connectionOpened() - Method in class org.hibernate.jdbc.JDBCContext

constant() - Method in class org.hibernate.hql.antlr.HqlBaseParser

constant(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

constant(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

constructor(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

consumesCollectionAlias() - Method in class org.hibernate.persister.collection.BasicCollectionPersister

consumesCollectionAlias() - Method in class org.hibernate.persister.collection.OneToManyPersister

consumesCollectionAlias() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

consumesCollectionAlias() - Method in interface org.hibernate.persister.entity.Joinable
Very, very, very ugly...
consumesEntityAlias() - Method in class org.hibernate.persister.collection.BasicCollectionPersister

consumesEntityAlias() - Method in class org.hibernate.persister.collection.OneToManyPersister

consumesEntityAlias() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

consumesEntityAlias() - Method in interface org.hibernate.persister.entity.Joinable
Very, very, very ugly...
contains(Object) - Method in interface org.hibernate.Session
Check if this instance is associated with this Session.
contains(Object) - Method in class org.hibernate.collection.PersistentBag

contains(Object) - Method in class org.hibernate.collection.PersistentIdentifierBag

contains(Object) - Method in class org.hibernate.collection.PersistentList

contains(Object) - Method in class org.hibernate.collection.PersistentSet

contains(Object) - Method in class org.hibernate.impl.SessionImpl

contains(Object, Object, SessionImplementor) - Method in class org.hibernate.type.CollectionType

contains(Object, Object, SessionImplementor) - Method in class org.hibernate.type.CustomCollectionType

contains(Object, Object) - Method in interface org.hibernate.usertype.UserCollectionType
Optional operation.
contains(Object) - Method in class org.hibernate.util.IdentitySet

containsAll(Collection) - Method in class org.hibernate.collection.PersistentBag

containsAll(Collection) - Method in class org.hibernate.collection.PersistentIdentifierBag

containsAll(Collection) - Method in class org.hibernate.collection.PersistentList

containsAll(Collection) - Method in class org.hibernate.collection.PersistentSet

containsAll(Collection) - Method in class org.hibernate.util.IdentitySet

containsClassAlias(String) - Method in class org.hibernate.hql.ast.tree.FromClause
Returns true if the from node contains the class alias name.
containsCollection(PersistentCollection) - Method in interface org.hibernate.engine.PersistenceContext
Is the given collection associated with this persistence context?
containsCollection(PersistentCollection) - Method in class org.hibernate.engine.StatefulPersistenceContext

containsCollectionFetches() - Method in interface org.hibernate.hql.QueryTranslator
Does the translated query contain collection fetches?
containsCollectionFetches() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

containsCollectionFetches() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

containsColumn(Column) - Method in class org.hibernate.mapping.Constraint

containsColumn(Column) - Method in class org.hibernate.mapping.DenormalizedTable

containsColumn(Column) - Method in class org.hibernate.mapping.Index

containsColumn(Column) - Method in class org.hibernate.mapping.Table

containsEntity(EntityKey) - Method in interface org.hibernate.engine.PersistenceContext
Is there an entity with the given key in the persistence context
containsEntity(EntityKey) - Method in class org.hibernate.engine.StatefulPersistenceContext

containsKey(Object) - Method in class org.hibernate.collection.PersistentMap

containsKey(Object) - Method in class org.hibernate.proxy.map.MapProxy

containsKey(Object) - Method in class org.hibernate.util.FastHashMap
Return true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class org.hibernate.util.IdentityMap

containsProperty(Property) - Method in class org.hibernate.mapping.Join

containsProxy(Object) - Method in interface org.hibernate.engine.PersistenceContext
Is the given proxy associated with this persistence context?
containsProxy(Object) - Method in class org.hibernate.engine.StatefulPersistenceContext

containsTableAlias(String) - Method in class org.hibernate.hql.ast.tree.FromClause
Returns true if the from node contains the table alias name.
containsValue(Object) - Method in class org.hibernate.collection.PersistentMap

containsValue(Object) - Method in class org.hibernate.proxy.map.MapProxy

containsValue(Object) - Method in class org.hibernate.util.FastHashMap
Return true if this map contains one or more keys mapping to the specified value.
containsValue(Object) - Method in class org.hibernate.util.IdentityMap

content() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

content() - Method in class org.hibernate.tuple.ElementWrapper

context - Variable in class org.hibernate.transaction.JTATransactionFactory

convert(SQLExceptionConverter, SQLException, String) - Static method in class org.hibernate.exception.JDBCExceptionHelper
Converts the given SQLException into Hibernate's JDBCException hierarchy, as well as performing appropriate logging.
convert(SQLExceptionConverter, SQLException, String, String) - Static method in class org.hibernate.exception.JDBCExceptionHelper
Converts the given SQLException into Hibernate's JDBCException hierarchy, as well as performing appropriate logging.
convert(SQLException, String, String) - Method in interface org.hibernate.exception.SQLExceptionConverter
Convert the given SQLException into Hibernate's JDBCException hierarchy.
convert(SQLException, String, String) - Method in class org.hibernate.exception.SQLStateConverter
Convert the given SQLException into Hibernate's JDBCException hierarchy.
convert(RecognitionException) - Static method in class org.hibernate.hql.ast.QuerySyntaxException

convert(RecognitionException, String) - Static method in class org.hibernate.hql.ast.QuerySyntaxException

coordinateSharedCacheCleanup(SessionImplementor) - Method in class org.hibernate.engine.query.NativeSQLQueryPlan

coordinateSharedCacheCleanup(SessionImplementor) - Method in class org.hibernate.hql.ast.exec.AbstractStatementExecutor

copy() - Method in class org.hibernate.engine.JoinSequence

copy() - Method in class org.hibernate.sql.ANSIJoinFragment

copy() - Method in class org.hibernate.sql.JoinFragment

copy() - Method in class org.hibernate.sql.OracleJoinFragment

copy() - Method in class org.hibernate.sql.QueryJoinFragment

copy() - Method in class org.hibernate.sql.QuerySelect

copy() - Method in class org.hibernate.sql.Sybase11JoinFragment

copyValues(EntityPersister, Object, Object, SessionImplementor, Map) - Method in class org.hibernate.event.def.DefaultMergeEventListener

copyValues(EntityPersister, Object, Object, SessionImplementor, Map, ForeignKeyDirection) - Method in class org.hibernate.event.def.DefaultMergeEventListener

count(String) - Static method in class org.hibernate.criterion.Projections
A property value count
count() - Method in class org.hibernate.criterion.Property

count(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

count(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

countCollectionPersisters(List) - Static method in class org.hibernate.loader.JoinWalker
Count the number of instances of Joinable which are actually also instances of PersistentCollection which are being fetched by outer join
countDistinct(String) - Static method in class org.hibernate.criterion.Projections
A distinct property value count
countEntityPersisters(List) - Static method in class org.hibernate.loader.JoinWalker
Count the number of instances of Joinable which are actually also instances of Loadable, or are one-to-many associations
countExpr(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

countSubclassProperties() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

countSubclassProperties() - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
How many properties are there, for this class and all subclasses?
countTrue(boolean[]) - Static method in class org.hibernate.util.ArrayHelper

countUnquoted(String, char) - Static method in class org.hibernate.util.StringHelper

create(Class, String[], String[], Class[]) - Static method in class org.hibernate.bytecode.javassist.BulkAccessor
Creates a new instance of BulkAccessor.
create(Class) - Static method in class org.hibernate.bytecode.javassist.FastClass

create(Object) - Static method in class org.hibernate.criterion.Example
Create a new instance, which includes all non-null properties by default
create() - Method in class org.hibernate.criterion.ProjectionList

create(Class) - Method in class org.hibernate.hql.ast.SqlASTFactory
Actually instantiate the AST node.
create(ASTFactory, int, String) - Static method in class org.hibernate.hql.ast.util.ASTUtil
Creates a single node AST.
create(String, Type, Properties, Dialect) - Static method in class org.hibernate.id.IdentifierGeneratorFactory

create(boolean, boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaExport
Run the schema creation script.
createAlias(String, String) - Method in interface org.hibernate.Criteria
Join an association, assigning an alias to the joined association.
createAlias(String, String, int) - Method in interface org.hibernate.Criteria
Join an association using the specified join-type, assigning an alias to the joined association.
createAlias(String, String) - Method in class org.hibernate.criterion.DetachedCriteria

createAlias(String, String) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

createAlias(String, String, int) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

createAlias(String, String) - Method in class org.hibernate.impl.CriteriaImpl

createAlias(String, String, int) - Method in class org.hibernate.impl.CriteriaImpl

createAllKeys() - Method in class org.hibernate.mapping.Collection

createAllKeys() - Method in class org.hibernate.mapping.Map

createBatcher(ConnectionManager, Interceptor) - Method in interface org.hibernate.jdbc.BatcherFactory

createBatcher(ConnectionManager, Interceptor) - Method in class org.hibernate.jdbc.BatchingBatcherFactory

createBatcher(ConnectionManager, Interceptor) - Method in class org.hibernate.jdbc.NonBatchingBatcherFactory

createBatcherFactory(Properties, int) - Method in class org.hibernate.cfg.SettingsFactory

createBatchingCollectionInitializer(QueryableCollection, int, SessionFactoryImplementor, Map) - Static method in class org.hibernate.loader.collection.BatchingCollectionInitializer

createBatchingEntityLoader(OuterJoinLoadable, int, LockMode, SessionFactoryImplementor, Map) - Static method in class org.hibernate.loader.entity.BatchingEntityLoader

createBatchingOneToManyInitializer(QueryableCollection, int, SessionFactoryImplementor, Map) - Static method in class org.hibernate.loader.collection.BatchingCollectionInitializer

createBinarySubtree(ASTFactory, int, String, AST, AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil
Creates a 'binary operator' subtree, given the information about the parent and the two child nodex.
createBlob(byte[]) - Static method in class org.hibernate.Hibernate
Create a new Blob.
createBlob(InputStream, int) - Static method in class org.hibernate.Hibernate
Create a new Blob.
createBlob(InputStream) - Static method in class org.hibernate.Hibernate
Create a new Blob.
createCache(String, String, boolean, Settings, Properties) - Static method in class org.hibernate.cache.CacheFactory

createCacheProvider(Properties) - Method in class org.hibernate.cfg.SettingsFactory

createCaseFragment() - Method in class org.hibernate.dialect.DerbyDialect
Return the case statement modified for Cloudscape.
createCaseFragment() - Method in class org.hibernate.dialect.Dialect
Create a CaseFragment for this dialect.
createCaseFragment() - Method in class org.hibernate.dialect.MckoiDialect

createCaseFragment() - Method in class org.hibernate.dialect.OracleDialect

createCaseFragment() - Method in class org.hibernate.dialect.RDMSOS2200Dialect

createCaseFragment() - Method in class org.hibernate.dialect.SAPDBDialect

createClassPersister(PersistentClass, CacheConcurrencyStrategy, SessionFactoryImplementor, Mapping) - Static method in class org.hibernate.persister.PersisterFactory

createClassProperties(Element, PersistentClass, Mappings, Map) - Static method in class org.hibernate.cfg.HbmBinder

createClassProperties(Element, PersistentClass, Mappings, Map, UniqueKey, boolean, boolean, boolean) - Static method in class org.hibernate.cfg.HbmBinder

createClassicHolderInstantiator(Constructor, ResultTransformer) - Static method in class org.hibernate.hql.HolderInstantiator

createClob(String) - Static method in class org.hibernate.Hibernate
Create a new Clob.
createClob(Reader, int) - Static method in class org.hibernate.Hibernate
Create a new Clob.
createCollectionInitializer(Map) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

createCollectionInitializer(Map) - Method in class org.hibernate.persister.collection.BasicCollectionPersister
Create the CollectionLoader
createCollectionInitializer(Map) - Method in class org.hibernate.persister.collection.OneToManyPersister
Create the OneToManyLoader
createCollectionJoinSequence(QueryableCollection, String) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Create a join sequence rooted at the given collection.
createCollectionPersister(Configuration, Collection, CacheConcurrencyStrategy, SessionFactoryImplementor) - Static method in class org.hibernate.persister.PersisterFactory

createCollectionSubquery(JoinSequence, Map, String[]) - Static method in class org.hibernate.hql.CollectionSubqueryFactory

createConnectionProvider(Properties) - Method in class org.hibernate.cfg.SettingsFactory

createCopy() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

createCopy(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

createCopy(QName) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

createCopy() - Method in class org.hibernate.tuple.ElementWrapper

createCopy(String) - Method in class org.hibernate.tuple.ElementWrapper

createCopy(QName) - Method in class org.hibernate.tuple.ElementWrapper

createCopyUsing(RowSelection) - Method in class org.hibernate.engine.QueryParameters

createCriteria(String) - Method in interface org.hibernate.Criteria
Create a new Criteria, "rooted" at the associated entity.
createCriteria(String, int) - Method in interface org.hibernate.Criteria
Create a new Criteria, "rooted" at the associated entity, using the specified join type.
createCriteria(String, String) - Method in interface org.hibernate.Criteria
Create a new Criteria, "rooted" at the associated entity, assigning the given alias.
createCriteria(String, String, int) - Method in interface org.hibernate.Criteria
Create a new Criteria, "rooted" at the associated entity, assigning the given alias and using the specified join type.
createCriteria(Class) - Method in interface org.hibernate.Session
Create a new Criteria instance, for the given entity class, or a superclass of an entity class.
createCriteria(Class, String) - Method in interface org.hibernate.Session
Create a new Criteria instance, for the given entity class, or a superclass of an entity class, with the given alias.
createCriteria(String) - Method in interface org.hibernate.Session
Create a new Criteria instance, for the given entity name.
createCriteria(String, String) - Method in interface org.hibernate.Session
Create a new Criteria instance, for the given entity name, with the given alias.
createCriteria(Class) - Method in interface org.hibernate.StatelessSession
Create a new Criteria instance, for the given entity class, or a superclass of an entity class.
createCriteria(Class, String) - Method in interface org.hibernate.StatelessSession
Create a new Criteria instance, for the given entity class, or a superclass of an entity class, with the given alias.
createCriteria(String) - Method in interface org.hibernate.StatelessSession
Create a new Criteria instance, for the given entity name.
createCriteria(String, String) - Method in interface org.hibernate.StatelessSession
Create a new Criteria instance, for the given entity name, with the given alias.
createCriteria(String, String) - Method in class org.hibernate.criterion.DetachedCriteria

createCriteria(String) - Method in class org.hibernate.criterion.DetachedCriteria

createCriteria(String) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

createCriteria(String, int) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

createCriteria(String, String) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

createCriteria(String, String, int) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

createCriteria(String) - Method in class org.hibernate.impl.CriteriaImpl

createCriteria(String, int) - Method in class org.hibernate.impl.CriteriaImpl

createCriteria(String, String) - Method in class org.hibernate.impl.CriteriaImpl

createCriteria(String, String, int) - Method in class org.hibernate.impl.CriteriaImpl

createCriteria(Class, String) - Method in class org.hibernate.impl.SessionImpl

createCriteria(String, String) - Method in class org.hibernate.impl.SessionImpl

createCriteria(Class) - Method in class org.hibernate.impl.SessionImpl

createCriteria(String) - Method in class org.hibernate.impl.SessionImpl

createCriteria(Class, String) - Method in class org.hibernate.impl.StatelessSessionImpl

createCriteria(String, String) - Method in class org.hibernate.impl.StatelessSessionImpl

createCriteria(Class) - Method in class org.hibernate.impl.StatelessSessionImpl

createCriteria(String) - Method in class org.hibernate.impl.StatelessSessionImpl

createDOMReader() - Method in class org.hibernate.util.XMLHelper
Create a dom4j DOMReader
createEntityLoader(LockMode, Map) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

createEntityLoader(LockMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

createFilter(Object, String) - Method in interface org.hibernate.Session
Create a new instance of Query for the given collection and filter string.
createFilter(Object, String) - Method in class org.hibernate.impl.SessionImpl

createFilterKeys(Map, EntityMode) - Static method in class org.hibernate.cache.FilterKey

createFilterTranslator(String, String, Map, SessionFactoryImplementor) - Method in interface org.hibernate.hql.QueryTranslatorFactory
Construct a FilterTranslator instance capable of translating an HQL filter string.
createFilterTranslator(String, String, Map, SessionFactoryImplementor) - Method in class org.hibernate.hql.ast.ASTQueryTranslatorFactory

createFilterTranslator(String, String, Map, SessionFactoryImplementor) - Method in class org.hibernate.hql.classic.ClassicQueryTranslatorFactory

createForeignKey() - Method in class org.hibernate.mapping.Collection

createForeignKey() - Method in class org.hibernate.mapping.Join

createForeignKey() - Method in class org.hibernate.mapping.ManyToOne

createForeignKey() - Method in class org.hibernate.mapping.OneToMany

createForeignKey() - Method in class org.hibernate.mapping.OneToOne

createForeignKey() - Method in class org.hibernate.mapping.SimpleValue

createForeignKey() - Method in class org.hibernate.mapping.Subclass

createForeignKey(String, List, String) - Method in class org.hibernate.mapping.Table

createForeignKey(String, List, String, List) - Method in class org.hibernate.mapping.Table

createForeignKey() - Method in class org.hibernate.mapping.ToOne

createForeignKey() - Method in interface org.hibernate.mapping.Value

createForeignKeyOfEntity(String) - Method in interface org.hibernate.mapping.KeyValue

createForeignKeyOfEntity(String) - Method in class org.hibernate.mapping.SimpleValue

createForeignKeys() - Method in class org.hibernate.mapping.DenormalizedTable

createForeignKeys() - Method in class org.hibernate.mapping.Table

createFrom(int, String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

createFromElement(String, AST, AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

createFromElement(String, AST, AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

createFromFilterElement(AST, AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

createFromFilterElement(AST, AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

createFromJoinElement(AST, AST, int, AST, AST, AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

createFromJoinElement(AST, AST, int, AST, AST, AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

createGetter(Class, String) - Static method in class org.hibernate.property.BasicPropertyAccessor

createIdentifierGenerator(Dialect, String, String, RootClass) - Method in interface org.hibernate.mapping.KeyValue

createIdentifierGenerator(Dialect, String, String, RootClass) - Method in class org.hibernate.mapping.SimpleValue

createIntoClause(String, AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

createIntoClause(String, AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

createJoin(String, boolean, boolean) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

createJoin(int[], String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

createJoinSequence() - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Generate an empty join sequence instance.
createJoinSequence(boolean, AssociationType, String, int, String[]) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Generate a join sequence representing the given association type.
createLinkedHashMap() - Static method in class org.hibernate.util.LinkedHashCollectionHelper

createLinkedHashMap(int) - Static method in class org.hibernate.util.LinkedHashCollectionHelper

createLinkedHashSet() - Static method in class org.hibernate.util.LinkedHashCollectionHelper

createLinkedHashSet(int) - Static method in class org.hibernate.util.LinkedHashCollectionHelper

createMappings() - Method in class org.hibernate.cfg.Configuration
Create a new Mappings to add class and collection mappings to.
createName(String) - Method in class org.hibernate.hql.ast.util.AliasGenerator

createNumber(long, Class) - Static method in class org.hibernate.id.IdentifierGeneratorFactory

createOuterJoinFragment() - Method in class org.hibernate.dialect.Dialect
Create an OuterJoinGenerator for this dialect.
createOuterJoinFragment() - Method in class org.hibernate.dialect.OracleDialect

createOuterJoinFragment() - Method in class org.hibernate.dialect.SAPDBDialect

createOuterJoinFragment() - Method in class org.hibernate.dialect.Sybase11Dialect

createOuterJoinFragment() - Method in class org.hibernate.dialect.TimesTenDialect

createParent(ASTFactory, int, String, AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil
Creates a single parent of the specified child (i.e.
createPrimaryKey() - Method in class org.hibernate.mapping.Join

createPrimaryKey() - Method in class org.hibernate.mapping.PersistentClass

createPropertyRefConstraints(Map) - Method in class org.hibernate.mapping.ManyToOne

createProxy(Serializable, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

createProxy(Serializable, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Create a new proxy instance
createProxy(Serializable, SessionImplementor) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

createProxy(Serializable, SessionImplementor) - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Generates an appropriate proxy representation of this entity for this entity-mode.
createQuery(String) - Method in interface org.hibernate.Session
Create a new instance of Query for the given HQL query string.
createQuery(String) - Method in interface org.hibernate.StatelessSession
Create a new instance of Query for the given HQL query string.
createQuery(String) - Method in class org.hibernate.impl.AbstractSessionImpl

createQuery(String) - Method in class org.hibernate.impl.SessionImpl

createQueryCacheFactory(Properties) - Method in class org.hibernate.cfg.SettingsFactory

createQueryLoader() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

createQueryTranslator(String, String, Map, SessionFactoryImplementor) - Method in interface org.hibernate.hql.QueryTranslatorFactory
Construct a QueryTranslator instance capable of translating an HQL query string.
createQueryTranslator(String, String, Map, SessionFactoryImplementor) - Method in class org.hibernate.hql.ast.ASTQueryTranslatorFactory

createQueryTranslator(String, String, Map, SessionFactoryImplementor) - Method in class org.hibernate.hql.classic.ClassicQueryTranslatorFactory

createQueryTranslatorFactory(Properties) - Method in class org.hibernate.cfg.SettingsFactory

createSAXReader(String, List, EntityResolver) - Method in class org.hibernate.util.XMLHelper
Create a dom4j SAXReader which will append all validation errors to errorList
createSQLQuery(String) - Method in interface org.hibernate.Session
Create a new instance of SQLQuery for the given SQL query string.
createSQLQuery(String) - Method in interface org.hibernate.StatelessSession
Create a new instance of SQLQuery for the given SQL query string.
createSQLQuery(String, String, Class) - Method in interface org.hibernate.classic.Session
Deprecated. will be replaced with a more Query like interface in later release
createSQLQuery(String, String[], Class[]) - Method in interface org.hibernate.classic.Session
Deprecated. will be replaced with a more Query like interface in later release
createSQLQuery(String) - Method in class org.hibernate.impl.AbstractSessionImpl

createSQLQuery(String) - Method in class org.hibernate.impl.SessionImpl

createSQLQuery(String, String, Class) - Method in class org.hibernate.impl.SessionImpl

createSQLQuery(String, String[], Class[]) - Method in class org.hibernate.impl.SessionImpl

createSchema() - Method in class org.hibernate.jmx.HibernateService

createSchema() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Export the CREATE DDL to the database
createSelect(int[], int[]) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

createSelectNewTransformer(Constructor, boolean, boolean) - Static method in class org.hibernate.hql.HolderInstantiator

createSibling(ASTFactory, int, String, AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil
Creates a single node AST as a sibling.
createSubselectInitializer(SubselectFetch, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

createSubselectInitializer(SubselectFetch, SessionImplementor) - Method in class org.hibernate.persister.collection.BasicCollectionPersister

createSubselectInitializer(SubselectFetch, SessionImplementor) - Method in class org.hibernate.persister.collection.OneToManyPersister

createTemporaryTableIfNecessary(Queryable, SessionImplementor) - Method in class org.hibernate.hql.ast.exec.AbstractStatementExecutor

createTransaction(JDBCContext, TransactionFactory.Context) - Method in class org.hibernate.transaction.CMTTransactionFactory

createTransaction(JDBCContext, TransactionFactory.Context) - Method in class org.hibernate.transaction.JDBCTransactionFactory

createTransaction(JDBCContext, TransactionFactory.Context) - Method in class org.hibernate.transaction.JTATransactionFactory

createTransaction(JDBCContext, TransactionFactory.Context) - Method in interface org.hibernate.transaction.TransactionFactory
Begin a transaction and return the associated Transaction instance.
createTransactionFactory(Properties) - Method in class org.hibernate.cfg.SettingsFactory

createTransactionManagerLookup(Properties) - Method in class org.hibernate.cfg.SettingsFactory

createTree(ASTFactory, AST[]) - Static method in class org.hibernate.hql.ast.util.ASTUtil

createUniqueKey(List) - Method in class org.hibernate.mapping.Table

createUniqueKeyLoaders() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

createUsingCtor(Token, String) - Method in class org.hibernate.hql.ast.SqlASTFactory

createWhereByKey(int, String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

createXPath(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

createXPath(String) - Method in class org.hibernate.tuple.ElementWrapper

currentColumns() - Method in class org.hibernate.hql.classic.PathExpressionParser

currentSession() - Method in interface org.hibernate.context.CurrentSessionContext
Retrieve the current session according to the scoping defined by this implementation.
currentSession() - Method in class org.hibernate.context.JTASessionContext

currentSession() - Method in class org.hibernate.context.ManagedSessionContext

currentSession() - Method in class org.hibernate.context.ThreadLocalSessionContext

custom(Class) - Static method in class org.hibernate.Hibernate
A Hibernate custom type.
custom(Class, String[], String[]) - Static method in class org.hibernate.Hibernate
A Hibernate parameterizable custom type.
custom(Class, Properties) - Static method in class org.hibernate.Hibernate
A Hibernate parameterizable custom type.
customCollection(String, String, String, boolean) - Static method in class org.hibernate.type.TypeFactory

customSQLDelete - Variable in class org.hibernate.persister.entity.AbstractEntityPersister

customSQLInsert - Variable in class org.hibernate.persister.entity.AbstractEntityPersister

customSQLUpdate - Variable in class org.hibernate.persister.entity.AbstractEntityPersister

D

DATASOURCE - Static variable in class org.hibernate.cfg.Environment
java.sql.Datasource JNDI name
DATE - Static variable in class org.hibernate.Hibernate
Hibernate date type.
DB2390Dialect - class org.hibernate.dialect.DB2390Dialect.
An SQL dialect for DB2/390.
DB2390Dialect() - Constructor for class org.hibernate.dialect.DB2390Dialect

DB2400Dialect - class org.hibernate.dialect.DB2400Dialect.
An SQL dialect for DB2/400
DB2400Dialect() - Constructor for class org.hibernate.dialect.DB2400Dialect

DB2Dialect - class org.hibernate.dialect.DB2Dialect.
An SQL dialect for DB2.
DB2Dialect() - Constructor for class org.hibernate.dialect.DB2Dialect

DDLFormatter - class org.hibernate.pretty.DDLFormatter.

DDLFormatter(String) - Constructor for class org.hibernate.pretty.DDLFormatter

DECIMAL_LITERAL_FORMAT - Static variable in class org.hibernate.hql.ast.util.LiteralProcessor
In what format should Float and Double literal values be sent to the database?
DEFAULT - Static variable in class org.hibernate.FetchMode
Default to the setting configured in the mapping file.
DEFAULT_BATCH_FETCH_SIZE - Static variable in class org.hibernate.cfg.Environment
The default batch size for batch fetching
DEFAULT_CATALOG - Static variable in class org.hibernate.cfg.Environment
A default database catalog name to use for unqualified tablenames
DEFAULT_COLUMN_NAME - Static variable in class org.hibernate.id.TableGenerator
Default column name
DEFAULT_CONFIG - Static variable in class org.hibernate.cache.OptimisticTreeCacheProvider

DEFAULT_CONFIG - Static variable in class org.hibernate.cache.TreeCacheProvider

DEFAULT_DISCRIMINATOR_COLUMN_NAME - Static variable in class org.hibernate.mapping.RootClass

DEFAULT_DTD_RESOLVER - Static variable in class org.hibernate.util.XMLHelper

DEFAULT_ELEMENT_COLUMN_NAME - Static variable in class org.hibernate.mapping.Collection

DEFAULT_ENTITY_MODE - Static variable in class org.hibernate.cfg.Environment
The EntityMode in which set the Session opened from the SessionFactory.
DEFAULT_EXCEPTION_MSG - Static variable in class org.hibernate.util.JDBCExceptionReporter

DEFAULT_IDENTIFIER_COLUMN_NAME - Static variable in class org.hibernate.mapping.IdentifierCollection

DEFAULT_IDENTIFIER_COLUMN_NAME - Static variable in class org.hibernate.mapping.RootClass

DEFAULT_INDEX_COLUMN_NAME - Static variable in class org.hibernate.mapping.IndexedCollection

DEFAULT_KEY_COLUMN_NAME - Static variable in class org.hibernate.mapping.Collection

DEFAULT_LENGTH - Static variable in class org.hibernate.mapping.Column

DEFAULT_LOCK_MODE - Static variable in class org.hibernate.event.LoadEvent

DEFAULT_LOCK_MODE - Static variable in class org.hibernate.event.def.DefaultLoadEventListener

DEFAULT_PRECISION - Static variable in class org.hibernate.mapping.Column

DEFAULT_SCALE - Static variable in class org.hibernate.mapping.Column

DEFAULT_SCHEMA - Static variable in class org.hibernate.cfg.Environment
A default database schema (owner) name to use for unqualified tablenames
DEFAULT_STRONG_REF_COUNT - Static variable in class org.hibernate.util.SimpleMRUCache

DEFAULT_STRONG_REF_COUNT - Static variable in class org.hibernate.util.SoftLimitMRUCache

DEFAULT_TABLE - Static variable in class org.hibernate.id.MultipleHiLoPerTableGenerator

DEFAULT_TABLE_NAME - Static variable in class org.hibernate.id.TableGenerator
Default table name
DEFAULT_WARNING_MSG - Static variable in class org.hibernate.util.JDBCExceptionReporter

DEF_CACHE_PROVIDER - Static variable in class org.hibernate.cfg.SettingsFactory

DELETE - Static variable in class org.hibernate.engine.CascadeStyle
delete
DELETE - Static variable in class org.hibernate.engine.CascadingAction

DELETE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

DELETE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

DELETE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

DELETE - Static variable in class org.hibernate.secure.HibernatePermission

DELETED - Static variable in class org.hibernate.engine.Status

DELETED - Static variable in class org.hibernate.event.def.AbstractSaveEventListener

DELETE_ORPHAN - Static variable in class org.hibernate.engine.CascadeStyle
delete + delete orphans
DESCENDING - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

DESCENDING - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

DESCENDING - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

DETACHED - Static variable in class org.hibernate.event.def.AbstractSaveEventListener

DIALECT - Static variable in class org.hibernate.cfg.Environment
Hibernate SQL Dialect class
DISTINCT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

DISTINCT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

DISTINCT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

DISTINCT_ROOT_ENTITY - Static variable in interface org.hibernate.criterion.CriteriaSpecification
Each row of results is a distinct instance of the root entity
DIV - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

DIV - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

DIV - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

DOM4J - Static variable in class org.hibernate.EntityMode

DOT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

DOT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

DOT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

DOUBLE - Static variable in class org.hibernate.Hibernate
Hibernate double type.
DRIVER - Static variable in class org.hibernate.cfg.Environment
JDBC driver class
DTDEntityResolver - class org.hibernate.util.DTDEntityResolver.
An EntityResolver implementation which attempts to resolve various systemId URLs to local classpath lookups Any systemId URL beginning with http://hibernate.sourceforge.net/ is searched for as a classpath resource in the classloader which loaded the Hibernate classes. Any systemId URL using classpath as the scheme (i.e.
DTDEntityResolver() - Constructor for class org.hibernate.util.DTDEntityResolver

DataDirectOracle9Dialect - class org.hibernate.dialect.DataDirectOracle9Dialect.

DataDirectOracle9Dialect() - Constructor for class org.hibernate.dialect.DataDirectOracle9Dialect

DataException - exception org.hibernate.exception.DataException.
Implementation of JDBCException indicating that evaluation of the valid SQL statement against the given data resulted in some illegal operation, mismatched types or incorrect cardinality.
DataException(String, SQLException) - Constructor for class org.hibernate.exception.DataException
Constructor for JDBCException.
DataException(String, SQLException, String) - Constructor for class org.hibernate.exception.DataException
Constructor for JDBCException.
DatabaseMetadata - class org.hibernate.tool.hbm2ddl.DatabaseMetadata.
JDBC database metadata
DatabaseMetadata(Connection, Dialect) - Constructor for class org.hibernate.tool.hbm2ddl.DatabaseMetadata

DatabaseMetadata(Connection, Dialect, boolean) - Constructor for class org.hibernate.tool.hbm2ddl.DatabaseMetadata

DatasourceConnectionProvider - class org.hibernate.connection.DatasourceConnectionProvider.
A connection provider that uses a DataSource registered with JNDI.
DatasourceConnectionProvider() - Constructor for class org.hibernate.connection.DatasourceConnectionProvider

DateType - class org.hibernate.type.DateType.
date: A type that maps an SQL DATE to a Java Date.
DateType() - Constructor for class org.hibernate.type.DateType

DbTimestampType - class org.hibernate.type.DbTimestampType.
dbtimestamp: An extension of TimestampType which maps to the database's current timestamp, rather than the jvm's current timestamp.
DbTimestampType() - Constructor for class org.hibernate.type.DbTimestampType

DecodeCaseFragment - class org.hibernate.sql.DecodeCaseFragment.
An Oracle-style DECODE function.
DecodeCaseFragment() - Constructor for class org.hibernate.sql.DecodeCaseFragment

DefaultAutoFlushEventListener - class org.hibernate.event.def.DefaultAutoFlushEventListener.
Defines the default flush event listeners used by hibernate for flushing session state in response to generated auto-flush events.
DefaultAutoFlushEventListener() - Constructor for class org.hibernate.event.def.DefaultAutoFlushEventListener

DefaultDeleteEventListener - class org.hibernate.event.def.DefaultDeleteEventListener.
Defines the default delete event listener used by hibernate for deleting entities from the datastore in response to generated delete events.
DefaultDeleteEventListener() - Constructor for class org.hibernate.event.def.DefaultDeleteEventListener

DefaultDirtyCheckEventListener - class org.hibernate.event.def.DefaultDirtyCheckEventListener.
Defines the default dirty-check event listener used by hibernate for checking the session for dirtiness in response to generated dirty-check events.
DefaultDirtyCheckEventListener() - Constructor for class org.hibernate.event.def.DefaultDirtyCheckEventListener

DefaultEntityAliases - class org.hibernate.loader.DefaultEntityAliases.
EntityAliases which handles the logic of selecting user provided aliases (via return-property), before using the default aliases.
DefaultEntityAliases(Loadable, String) - Constructor for class org.hibernate.loader.DefaultEntityAliases

DefaultEntityAliases(Map, Loadable, String) - Constructor for class org.hibernate.loader.DefaultEntityAliases
Calculate and cache select-clause suffixes.
DefaultEvictEventListener - class org.hibernate.event.def.DefaultEvictEventListener.
Defines the default evict event listener used by hibernate for evicting entities in response to generated flush events.
DefaultEvictEventListener() - Constructor for class org.hibernate.event.def.DefaultEvictEventListener

DefaultFlushEntityEventListener - class org.hibernate.event.def.DefaultFlushEntityEventListener.
An event that occurs for each entity instance at flush time
DefaultFlushEntityEventListener() - Constructor for class org.hibernate.event.def.DefaultFlushEntityEventListener

DefaultFlushEventListener - class org.hibernate.event.def.DefaultFlushEventListener.
Defines the default flush event listeners used by hibernate for flushing session state in response to generated flush events.
DefaultFlushEventListener() - Constructor for class org.hibernate.event.def.DefaultFlushEventListener

DefaultInitializeCollectionEventListener - class org.hibernate.event.def.DefaultInitializeCollectionEventListener.

DefaultInitializeCollectionEventListener() - Constructor for class org.hibernate.event.def.DefaultInitializeCollectionEventListener

DefaultLoadEventListener - class org.hibernate.event.def.DefaultLoadEventListener.
Defines the default load event listeners used by hibernate for loading entities in response to generated load events.
DefaultLoadEventListener() - Constructor for class org.hibernate.event.def.DefaultLoadEventListener

DefaultLockEventListener - class org.hibernate.event.def.DefaultLockEventListener.
Defines the default lock event listeners used by hibernate to lock entities in response to generated lock events.
DefaultLockEventListener() - Constructor for class org.hibernate.event.def.DefaultLockEventListener

DefaultMergeEventListener - class org.hibernate.event.def.DefaultMergeEventListener.
Defines the default copy event listener used by hibernate for copying entities in response to generated copy events.
DefaultMergeEventListener() - Constructor for class org.hibernate.event.def.DefaultMergeEventListener

DefaultNamingStrategy - class org.hibernate.cfg.DefaultNamingStrategy.
The default NamingStrategy
DefaultNamingStrategy() - Constructor for class org.hibernate.cfg.DefaultNamingStrategy

DefaultPersistEventListener - class org.hibernate.event.def.DefaultPersistEventListener.
Defines the default create event listener used by hibernate for creating transient entities in response to generated create events.
DefaultPersistEventListener() - Constructor for class org.hibernate.event.def.DefaultPersistEventListener

DefaultPersistOnFlushEventListener - class org.hibernate.event.def.DefaultPersistOnFlushEventListener.
When persist is used as the cascade action, persistOnFlush should be used
DefaultPersistOnFlushEventListener() - Constructor for class org.hibernate.event.def.DefaultPersistOnFlushEventListener

DefaultPostLoadEventListener - class org.hibernate.event.def.DefaultPostLoadEventListener.
Call Lifecycle interface if necessary
DefaultPostLoadEventListener() - Constructor for class org.hibernate.event.def.DefaultPostLoadEventListener

DefaultPreLoadEventListener - class org.hibernate.event.def.DefaultPreLoadEventListener.
Called before injecting property values into a newly loaded entity instance.
DefaultPreLoadEventListener() - Constructor for class org.hibernate.event.def.DefaultPreLoadEventListener

DefaultRefreshEventListener - class org.hibernate.event.def.DefaultRefreshEventListener.
Defines the default refresh event listener used by hibernate for refreshing entities in response to generated refresh events.
DefaultRefreshEventListener() - Constructor for class org.hibernate.event.def.DefaultRefreshEventListener

DefaultReplicateEventListener - class org.hibernate.event.def.DefaultReplicateEventListener.
Defines the default replicate event listener used by Hibernate to replicate entities in response to generated replicate events.
DefaultReplicateEventListener() - Constructor for class org.hibernate.event.def.DefaultReplicateEventListener

DefaultSaveEventListener - class org.hibernate.event.def.DefaultSaveEventListener.
An event handler for save() events
DefaultSaveEventListener() - Constructor for class org.hibernate.event.def.DefaultSaveEventListener

DefaultSaveOrUpdateCopyEventListener - class org.hibernate.event.def.DefaultSaveOrUpdateCopyEventListener.

DefaultSaveOrUpdateCopyEventListener() - Constructor for class org.hibernate.event.def.DefaultSaveOrUpdateCopyEventListener

DefaultSaveOrUpdateEventListener - class org.hibernate.event.def.DefaultSaveOrUpdateEventListener.
Defines the default update event listener used by hibernate for updating transient entities in response to generated update events.
DefaultSaveOrUpdateEventListener() - Constructor for class org.hibernate.event.def.DefaultSaveOrUpdateEventListener

DefaultUpdateEventListener - class org.hibernate.event.def.DefaultUpdateEventListener.
An event handler for update() events
DefaultUpdateEventListener() - Constructor for class org.hibernate.event.def.DefaultUpdateEventListener

DelayedPostInsertIdentifier - class org.hibernate.action.DelayedPostInsertIdentifier.
Acts as a stand-in for an entity identifier which is supposed to be generated on insert (like an IDENTITY column) where the insert needed to be delayed because we were outside a transaction when the persist occurred (save currently still performs the insert).
DelayedPostInsertIdentifier() - Constructor for class org.hibernate.action.DelayedPostInsertIdentifier

Delete - class org.hibernate.sql.Delete.
An SQL DELETE statement
Delete() - Constructor for class org.hibernate.sql.Delete

DeleteEvent - class org.hibernate.event.DeleteEvent.
Defines an event class for the deletion of an entity.
DeleteEvent(Object, EventSource) - Constructor for class org.hibernate.event.DeleteEvent
Constructs a new DeleteEvent instance.
DeleteEvent(String, Object, EventSource) - Constructor for class org.hibernate.event.DeleteEvent

DeleteEvent(String, Object, boolean, EventSource) - Constructor for class org.hibernate.event.DeleteEvent

DeleteEventListener - interface org.hibernate.event.DeleteEventListener.
Defines the contract for handling of deletion events generated from a session.
DeleteStatement - class org.hibernate.hql.ast.tree.DeleteStatement.
Defines a top-level AST node representing an HQL delete statement.
DeleteStatement() - Constructor for class org.hibernate.hql.ast.tree.DeleteStatement

DenormalizedTable - class org.hibernate.mapping.DenormalizedTable.

DenormalizedTable(Table) - Constructor for class org.hibernate.mapping.DenormalizedTable

DependantValue - class org.hibernate.mapping.DependantValue.
A value which is "typed" by reference to some other value (for example, a foreign key is typed by the referenced primary key).
DependantValue(Table, KeyValue) - Constructor for class org.hibernate.mapping.DependantValue

DerbyCaseFragment - class org.hibernate.sql.DerbyCaseFragment.

DerbyCaseFragment() - Constructor for class org.hibernate.sql.DerbyCaseFragment

DerbyDialect - class org.hibernate.dialect.DerbyDialect.

DerbyDialect() - Constructor for class org.hibernate.dialect.DerbyDialect

DerbyDialect.DerbyTrimFunctionEmulation - class org.hibernate.dialect.DerbyDialect.DerbyTrimFunctionEmulation.
A specialized function template to emulate the ANSI trim function on Derby DB since it does not support the full trim specification.
DerbyDialect.DerbyTrimFunctionEmulation() - Constructor for class org.hibernate.dialect.DerbyDialect.DerbyTrimFunctionEmulation

DetachedCriteria - class org.hibernate.criterion.DetachedCriteria.
Some applications need to create criteria queries in "detached mode", where the Hibernate session is not available.
DetachedCriteria(String) - Constructor for class org.hibernate.criterion.DetachedCriteria

DetachedCriteria(String, String) - Constructor for class org.hibernate.criterion.DetachedCriteria

DetachedCriteria(CriteriaImpl, Criteria) - Constructor for class org.hibernate.criterion.DetachedCriteria

DetailedSemanticException - exception org.hibernate.hql.ast.DetailedSemanticException.
Thrown when a call to the underlying Hibernate engine fails, indicating some form of semantic exception (e.g.
DetailedSemanticException(String) - Constructor for class org.hibernate.hql.ast.DetailedSemanticException

DetailedSemanticException(String, Throwable) - Constructor for class org.hibernate.hql.ast.DetailedSemanticException

Dialect - class org.hibernate.dialect.Dialect.
Represents a dialect of SQL implemented by a particular RDBMS.
Dialect() - Constructor for class org.hibernate.dialect.Dialect

DialectFactory - class org.hibernate.dialect.DialectFactory.
A factory for generating Dialect instances.
DialectFactory() - Constructor for class org.hibernate.dialect.DialectFactory

DialectFactory.DatabaseDialectMapper - interface org.hibernate.dialect.DialectFactory.DatabaseDialectMapper.
For a given database product name, instances of DatabaseDialectMapper know which Dialect to use for different versions.
DialectFactory.VersionInsensitiveMapper - class org.hibernate.dialect.DialectFactory.VersionInsensitiveMapper.
A simple DatabaseDialectMapper for dialects which are independent of the underlying database product version.
DialectFactory.VersionInsensitiveMapper(String) - Constructor for class org.hibernate.dialect.DialectFactory.VersionInsensitiveMapper

DirectPropertyAccessor - class org.hibernate.property.DirectPropertyAccessor.
Accesses fields directly.
DirectPropertyAccessor() - Constructor for class org.hibernate.property.DirectPropertyAccessor

DirectPropertyAccessor.DirectGetter - class org.hibernate.property.DirectPropertyAccessor.DirectGetter.

DirectPropertyAccessor.DirectSetter - class org.hibernate.property.DirectPropertyAccessor.DirectSetter.

DirtyCheckEvent - class org.hibernate.event.DirtyCheckEvent.
Defines an event class for the dirty-checking of a session.
DirtyCheckEvent(EventSource) - Constructor for class org.hibernate.event.DirtyCheckEvent

DirtyCheckEventListener - interface org.hibernate.event.DirtyCheckEventListener.
Defines the contract for handling of session dirty-check events.
DirtyCollectionSearchVisitor - class org.hibernate.event.def.DirtyCollectionSearchVisitor.
Do we have a dirty collection here? 1.
DiscriminatorType - interface org.hibernate.type.DiscriminatorType.
A Type that may be used for a discriminator column.
Disjunction - class org.hibernate.criterion.Disjunction.

Disjunction() - Constructor for class org.hibernate.criterion.Disjunction

DisjunctionFragment - class org.hibernate.sql.DisjunctionFragment.
A disjunctive string of conditions
DisjunctionFragment() - Constructor for class org.hibernate.sql.DisjunctionFragment

DisplayableNode - interface org.hibernate.hql.ast.tree.DisplayableNode.
Implementors will return additional display text, which will be used by the ASTPrinter to display information (besides the node type and node text).
Distinct - class org.hibernate.criterion.Distinct.

Distinct(Projection) - Constructor for class org.hibernate.criterion.Distinct

DistinctRootEntityResultTransformer - class org.hibernate.transform.DistinctRootEntityResultTransformer.

DistinctRootEntityResultTransformer() - Constructor for class org.hibernate.transform.DistinctRootEntityResultTransformer

Dom4jAccessor - class org.hibernate.property.Dom4jAccessor.
Responsible for accessing property values represented as a dom4j Element or Attribute.
Dom4jAccessor(String, Type, SessionFactoryImplementor) - Constructor for class org.hibernate.property.Dom4jAccessor

Dom4jAccessor.AttributeGetter - class org.hibernate.property.Dom4jAccessor.AttributeGetter.
For nodes like "@bar"
Dom4jAccessor.AttributeSetter - class org.hibernate.property.Dom4jAccessor.AttributeSetter.
For nodes like "@bar"
Dom4jAccessor.Dom4jGetter - class org.hibernate.property.Dom4jAccessor.Dom4jGetter.
Defines the strategy for getting property values out of a dom4j Node.
Dom4jAccessor.Dom4jSetter - class org.hibernate.property.Dom4jAccessor.Dom4jSetter.

Dom4jAccessor.ElementAttributeGetter - class org.hibernate.property.Dom4jAccessor.ElementAttributeGetter.
For nodes like "foo/@bar"
Dom4jAccessor.ElementAttributeSetter - class org.hibernate.property.Dom4jAccessor.ElementAttributeSetter.
For nodes like "foo/@bar"
Dom4jAccessor.ElementGetter - class org.hibernate.property.Dom4jAccessor.ElementGetter.
For nodes like "foo"
Dom4jAccessor.ElementSetter - class org.hibernate.property.Dom4jAccessor.ElementSetter.
For nodes like "foo"
Dom4jAccessor.TextGetter - class org.hibernate.property.Dom4jAccessor.TextGetter.
For nodes like "."
Dom4jAccessor.TextSetter - class org.hibernate.property.Dom4jAccessor.TextSetter.
For nodes like "."
Dom4jComponentTuplizer - class org.hibernate.tuple.component.Dom4jComponentTuplizer.
A ComponentTuplizer specific to the dom4j entity mode.
Dom4jComponentTuplizer(Component) - Constructor for class org.hibernate.tuple.component.Dom4jComponentTuplizer

Dom4jEntityTuplizer - class org.hibernate.tuple.entity.Dom4jEntityTuplizer.
An EntityTuplizer specific to the dom4j entity mode.
Dom4jInstantiator - class org.hibernate.tuple.Dom4jInstantiator.
Performs "instantiation" based on DOM4J elements.
Dom4jInstantiator(Component) - Constructor for class org.hibernate.tuple.Dom4jInstantiator

Dom4jInstantiator(PersistentClass) - Constructor for class org.hibernate.tuple.Dom4jInstantiator

Dom4jLazyInitializer - class org.hibernate.proxy.dom4j.Dom4jLazyInitializer.
Lazy initializer for "dom4j" entity representations.
Dom4jProxy - class org.hibernate.proxy.dom4j.Dom4jProxy.
Proxy for "dom4j" entity representations.
Dom4jProxy(Dom4jLazyInitializer) - Constructor for class org.hibernate.proxy.dom4j.Dom4jProxy

Dom4jProxyFactory - class org.hibernate.proxy.dom4j.Dom4jProxyFactory.
Builds proxies for "dom4j" entity representations.
Dom4jProxyFactory() - Constructor for class org.hibernate.proxy.dom4j.Dom4jProxyFactory

DotNode - class org.hibernate.hql.ast.tree.DotNode.
Represents a reference to a property or alias expression.
DotNode() - Constructor for class org.hibernate.hql.ast.tree.DotNode

DoubleType - class org.hibernate.type.DoubleType.
double: A type that maps an SQL DOUBLE to a Java Double.
DoubleType() - Constructor for class org.hibernate.type.DoubleType

DriverManagerConnectionProvider - class org.hibernate.connection.DriverManagerConnectionProvider.
A connection provider that uses java.sql.DriverManager.
DriverManagerConnectionProvider() - Constructor for class org.hibernate.connection.DriverManagerConnectionProvider

DuplicateMappingException - exception org.hibernate.DuplicateMappingException.
Raised whenever a duplicate for a certain type occurs.
DuplicateMappingException(String, String, String) - Constructor for class org.hibernate.DuplicateMappingException

DuplicateMappingException(String, String) - Constructor for class org.hibernate.DuplicateMappingException

DynamicMapComponentTuplizer - class org.hibernate.tuple.component.DynamicMapComponentTuplizer.
A ComponentTuplizer specific to the dynamic-map entity mode.
DynamicMapComponentTuplizer(Component) - Constructor for class org.hibernate.tuple.component.DynamicMapComponentTuplizer

DynamicMapEntityTuplizer - class org.hibernate.tuple.entity.DynamicMapEntityTuplizer.
An EntityTuplizer specific to the dynamic-map entity mode.
DynamicMapInstantiator - class org.hibernate.tuple.DynamicMapInstantiator.

DynamicMapInstantiator() - Constructor for class org.hibernate.tuple.DynamicMapInstantiator

DynamicMapInstantiator(PersistentClass) - Constructor for class org.hibernate.tuple.DynamicMapInstantiator

debug(String) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask.Logger

declaredNamespaces() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

declaredNamespaces() - Method in class org.hibernate.tuple.ElementWrapper

decrementCascadeLevel() - Method in interface org.hibernate.engine.PersistenceContext
Called after cascading
decrementCascadeLevel() - Method in class org.hibernate.engine.StatefulPersistenceContext

decrementIndexByBase(Object) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

deepCopy(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.AnyType

deepCopy(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.BlobType

deepCopy(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.ClobType

deepCopy(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.CollectionType

deepCopy(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.ComponentType

deepCopy(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.CompositeCustomType

deepCopy(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.CustomType

deepCopy(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.EntityType

deepCopy(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.ImmutableType

deepCopy(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.MetaType

deepCopy(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.MutableType

deepCopy(Object, EntityMode, SessionFactoryImplementor) - Method in interface org.hibernate.type.Type
Return a deep copy of the persistent state, stopping at entities and at collections.
deepCopy(Object[], Type[], boolean[], Object[], SessionImplementor) - Static method in class org.hibernate.type.TypeFactory
Deep copy values in the first array into the second
deepCopy(Object) - Method in interface org.hibernate.usertype.CompositeUserType
Return a deep copy of the persistent state, stopping at entities and at collections.
deepCopy(Object) - Method in interface org.hibernate.usertype.UserType
Return a deep copy of the persistent state, stopping at entities and at collections.
deepCopyNotNull(Object) - Method in class org.hibernate.type.AbstractBynaryType

deepCopyNotNull(Object) - Method in class org.hibernate.type.AbstractCharArrayType

deepCopyNotNull(Object) - Method in class org.hibernate.type.CalendarDateType

deepCopyNotNull(Object) - Method in class org.hibernate.type.CalendarType

deepCopyNotNull(Object) - Method in class org.hibernate.type.DateType

deepCopyNotNull(Object) - Method in class org.hibernate.type.MutableType

deepCopyNotNull(Object) - Method in class org.hibernate.type.SerializableType

deepCopyNotNull(Object) - Method in class org.hibernate.type.TimeType

deepCopyNotNull(Object) - Method in class org.hibernate.type.TimestampType

defaultAccess - Variable in class org.hibernate.cfg.Mappings

defaultCascade - Variable in class org.hibernate.cfg.Mappings

defaultLazy - Variable in class org.hibernate.cfg.Mappings

defaultPackage - Variable in class org.hibernate.cfg.Mappings

definesLimits() - Method in class org.hibernate.engine.RowSelection

dehydrate(Serializable, Object[], boolean[], boolean[][], int, PreparedStatement, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

dehydrate(Serializable, Object[], Object, boolean[], boolean[][], int, PreparedStatement, SessionImplementor, int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Marshall the fields of a persistent instance to a prepared statement
delegate - Variable in class org.hibernate.exception.NestableException
The helper instance which contains much of the code which we delegate to.
delegate - Variable in class org.hibernate.exception.NestableRuntimeException
The helper instance which contains much of the code which we delegate to.
delegateWork(IsolatedWork, boolean) - Method in class org.hibernate.engine.transaction.Isolater.JdbcDelegate

delegateWork(IsolatedWork, boolean) - Method in class org.hibernate.engine.transaction.Isolater.JtaDelegate

delete(Object) - Method in interface org.hibernate.Session
Remove a persistent instance from the datastore.
delete(String, Object) - Method in interface org.hibernate.Session
Remove a persistent instance from the datastore.
delete(Object) - Method in interface org.hibernate.StatelessSession
Delete a row.
delete(String, Object) - Method in interface org.hibernate.StatelessSession
Delete a row.
delete(String) - Method in interface org.hibernate.classic.Session
Deprecated. consider using HQL delete statements
delete(String, Object, Type) - Method in interface org.hibernate.classic.Session
Deprecated. consider using HQL delete statements
delete(String, Object[], Type[]) - Method in interface org.hibernate.classic.Session
Deprecated. consider using HQL delete statements
delete(String, Object, boolean, Set) - Method in interface org.hibernate.event.EventSource
Cascade delete an entity instance
delete(Object) - Method in class org.hibernate.impl.SessionImpl
Delete a persistent object
delete(String, Object) - Method in class org.hibernate.impl.SessionImpl
Delete a persistent object (by explicit entity name)
delete(String, Object, boolean, Set) - Method in class org.hibernate.impl.SessionImpl
Delete a persistent object
delete(String) - Method in class org.hibernate.impl.SessionImpl

delete(String, Object, Type) - Method in class org.hibernate.impl.SessionImpl

delete(String, Object[], Type[]) - Method in class org.hibernate.impl.SessionImpl

delete(Object) - Method in class org.hibernate.impl.StatelessSessionImpl

delete(String, Object) - Method in class org.hibernate.impl.StatelessSessionImpl

delete(Serializable, Object, int, Object, String, SessionImplementor, Object[]) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Perform an SQL DELETE
delete(Serializable, Object, Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Delete an object
delete(Serializable, Object, Object, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Delete a persistent instance
deleteCallable - Variable in class org.hibernate.persister.entity.AbstractEntityPersister

deleteEntity(EventSource, Object, EntityEntry, boolean, EntityPersister, Set) - Method in class org.hibernate.event.def.DefaultDeleteEventListener

deleteEntity(String) - Method in class org.hibernate.stat.StatisticsImpl

deleteEntity(String) - Method in interface org.hibernate.stat.StatisticsImplementor

deleteOrphans() - Method in class org.hibernate.engine.CascadingAction
Does this action potentially extrapolate to orphan deletes?
deleteResultCheckStyles - Variable in class org.hibernate.persister.entity.AbstractEntityPersister

deleteRow() - Method in class org.hibernate.jdbc.ResultSetWrapper

deleteRows(PersistentCollection, Serializable, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

deleteRows(PersistentCollection, Serializable, SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister
Delete the persistent state of any elements that were removed from the collection
deleteStatement() - Method in class org.hibernate.hql.antlr.HqlBaseParser

deleteStatement(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

deleteStatement(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

deleteTransientEntity(EventSource, Object, boolean, EntityPersister, Set) - Method in class org.hibernate.event.def.DefaultDeleteEventListener
We encountered a delete request on a transient instance.
delistResource(XAResource, int) - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter

denormalizedSupertable - Variable in class org.hibernate.cfg.Mappings.TableDescription

desc(String) - Static method in class org.hibernate.criterion.Order
Descending order
desc() - Method in class org.hibernate.criterion.Property

deserialize(ObjectInputStream, SessionImplementor) - Static method in class org.hibernate.engine.ActionQueue
Used by the owning session to explicitly control deserialization of the action queue
deserialize(ObjectInputStream, SessionImplementor) - Static method in class org.hibernate.engine.StatefulPersistenceContext

deserialize(ObjectInputStream, SessionFactoryImplementor, Interceptor, ConnectionReleaseMode, JDBCContext) - Static method in class org.hibernate.jdbc.ConnectionManager

deserialize(ObjectInputStream, JDBCContext.Context, Interceptor) - Static method in class org.hibernate.jdbc.JDBCContext
Custom deserialization routine used during deserialization of a Session/PersistenceContext for increased performance.
deserialize(Object) - Static method in class org.hibernate.util.IdentityMap
Workaround for a JDK 1.4.1 bug where IdentityHashMaps are not correctly deserialized.
deserialize(InputStream) - Static method in class org.hibernate.util.SerializationHelper
Deserializes an Object from the specified stream.
deserialize(byte[]) - Static method in class org.hibernate.util.SerializationHelper
Deserializes a single Object from an array of bytes.
destroy() - Method in interface org.hibernate.cache.Cache
Clean up
destroy() - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Clean up all resources.
destroy() - Method in class org.hibernate.cache.EhCache
Remove the cache and make it unuseable.
destroy() - Method in class org.hibernate.cache.HashtableCache

destroy() - Method in class org.hibernate.cache.NonstrictReadWriteCache

destroy() - Method in class org.hibernate.cache.OSCache

destroy() - Method in class org.hibernate.cache.OptimisticTreeCache

destroy() - Method in interface org.hibernate.cache.QueryCache

destroy() - Method in class org.hibernate.cache.ReadOnlyCache

destroy() - Method in class org.hibernate.cache.ReadWriteCache

destroy() - Method in class org.hibernate.cache.StandardQueryCache

destroy() - Method in class org.hibernate.cache.SwarmCache
Clean up
destroy() - Method in class org.hibernate.cache.TransactionalCache

destroy() - Method in class org.hibernate.cache.TreeCache

destroy() - Method in class org.hibernate.cache.UpdateTimestampsCache

destructure(Object, SessionFactoryImplementor) - Method in interface org.hibernate.cache.entry.CacheEntryStructure

destructure(Object, SessionFactoryImplementor) - Method in class org.hibernate.cache.entry.StructuredCacheEntry

destructure(Object, SessionFactoryImplementor) - Method in class org.hibernate.cache.entry.StructuredCollectionCacheEntry

destructure(Object, SessionFactoryImplementor) - Method in class org.hibernate.cache.entry.StructuredMapCacheEntry

destructure(Object, SessionFactoryImplementor) - Method in class org.hibernate.cache.entry.UnstructuredCacheEntry

detach() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

detach() - Method in class org.hibernate.tuple.ElementWrapper

determineDecimalRepresentation(String, int) - Method in class org.hibernate.hql.ast.util.LiteralProcessor

determineDefault(String, boolean) - Static method in class org.hibernate.engine.ExecuteUpdateResultCheckStyle

determineDialect(String, int) - Static method in class org.hibernate.dialect.DialectFactory
Determine the appropriate Dialect to use given the database product name and major version.
determineGeneratedIdentifier(SessionImplementor, Object) - Method in class org.hibernate.id.IdentityGenerator.InsertSelectDelegate

determineRowCount(int, PreparedStatement) - Method in class org.hibernate.jdbc.Expectations.BasicExpectation

determineRowCount(int, PreparedStatement) - Method in class org.hibernate.jdbc.Expectations.BasicParamExpectation

determineSqlStateClassCode(String) - Static method in class org.hibernate.exception.JDBCExceptionHelper

determineType(int, Object, Type) - Method in class org.hibernate.impl.AbstractQueryImpl

determineType(int, Object) - Method in class org.hibernate.impl.AbstractQueryImpl

determineType(String, Object, Type) - Method in class org.hibernate.impl.AbstractQueryImpl

determineType(String, Object) - Method in class org.hibernate.impl.AbstractQueryImpl

determineType(String, Class) - Method in class org.hibernate.impl.AbstractQueryImpl

dialect - Variable in class org.hibernate.sql.Select

dirty() - Method in class org.hibernate.collection.AbstractPersistentCollection

dirty() - Method in interface org.hibernate.collection.PersistentCollection
Mark the collection as dirty
dirty() - Method in class org.hibernate.intercept.AbstractFieldInterceptor

dirty() - Method in interface org.hibernate.intercept.FieldInterceptor
Forcefully mark the entity as being dirty.
dirtyCheck(FlushEntityEvent) - Method in class org.hibernate.event.def.DefaultFlushEntityEventListener
Perform a dirty check, and attach the results to the event
disableFilter(String) - Method in interface org.hibernate.Session
Disable the named filter for the current session.
disableFilter(String) - Method in class org.hibernate.impl.SessionImpl

disassemble(CollectionPersister) - Method in class org.hibernate.collection.PersistentArrayHolder

disassemble(CollectionPersister) - Method in class org.hibernate.collection.PersistentBag

disassemble(CollectionPersister) - Method in interface org.hibernate.collection.PersistentCollection
Disassemble the collection, ready for the cache
disassemble(CollectionPersister) - Method in class org.hibernate.collection.PersistentElementHolder

disassemble(CollectionPersister) - Method in class org.hibernate.collection.PersistentIdentifierBag

disassemble(CollectionPersister) - Method in class org.hibernate.collection.PersistentList

disassemble(CollectionPersister) - Method in class org.hibernate.collection.PersistentListElementHolder

disassemble(CollectionPersister) - Method in class org.hibernate.collection.PersistentMap

disassemble(CollectionPersister) - Method in class org.hibernate.collection.PersistentMapElementHolder

disassemble(CollectionPersister) - Method in class org.hibernate.collection.PersistentSet

disassemble(Object, SessionImplementor, Object) - Method in class org.hibernate.type.AbstractType

disassemble(Object, SessionImplementor, Object) - Method in class org.hibernate.type.AnyType

disassemble(Object, SessionImplementor, Object) - Method in class org.hibernate.type.BlobType

disassemble(Object, SessionImplementor, Object) - Method in class org.hibernate.type.ClobType

disassemble(Object, SessionImplementor, Object) - Method in class org.hibernate.type.CollectionType

disassemble(Object, SessionImplementor, Object) - Method in class org.hibernate.type.ComponentType

disassemble(Object, SessionImplementor, Object) - Method in class org.hibernate.type.CompositeCustomType

disassemble(Object, SessionImplementor, Object) - Method in class org.hibernate.type.CustomType

disassemble(Object, SessionImplementor, Object) - Method in class org.hibernate.type.ManyToOneType

disassemble(Object, SessionImplementor, Object) - Method in class org.hibernate.type.OneToOneType

disassemble(Object, SessionImplementor, Object) - Method in class org.hibernate.type.SerializableType

disassemble(Object, SessionImplementor, Object) - Method in class org.hibernate.type.SpecialOneToOneType

disassemble(Object, SessionImplementor, Object) - Method in interface org.hibernate.type.Type
Return a cacheable "disassembled" representation of the object.
disassemble(Object[], Type[], boolean[], SessionImplementor, Object) - Static method in class org.hibernate.type.TypeFactory

disassemble(Object, SessionImplementor) - Method in interface org.hibernate.usertype.CompositeUserType
Transform the object into its cacheable representation.
disassemble(Object) - Method in interface org.hibernate.usertype.UserType
Transform the object into its cacheable representation.
disconnect() - Method in interface org.hibernate.Session
Disconnect the Session from the current JDBC connection.
disconnect() - Method in class org.hibernate.impl.SessionImpl

disjunction() - Static method in class org.hibernate.criterion.Restrictions
Group expressions together in a single disjunction (A or B or C...)
distinct(Projection) - Static method in class org.hibernate.criterion.Projections
Create a distinct projection from a projection
distinctOrAll(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

doCascade(CascadingAction) - Method in class org.hibernate.engine.CascadeStyle.MultipleCascadeStyle

doCascade(CascadingAction) - Method in class org.hibernate.engine.CascadeStyle
Should the given action be cascaded?
doConfigure(InputStream, String) - Method in class org.hibernate.cfg.Configuration
Use the mappings and properties specified in the given application resource.
doConfigure(Document) - Method in class org.hibernate.cfg.Configuration

doEvict(Object, EntityKey, EntityPersister, EventSource) - Method in class org.hibernate.event.def.DefaultEvictEventListener

doExecuteBatch(PreparedStatement) - Method in class org.hibernate.jdbc.AbstractBatcher

doExecuteBatch(PreparedStatement) - Method in class org.hibernate.jdbc.BatchingBatcher

doExecuteBatch(PreparedStatement) - Method in class org.hibernate.jdbc.NonBatchingBatcher

doIsolatedWork(IsolatedWork, SessionImplementor) - Static method in class org.hibernate.engine.transaction.Isolater
Ensures that all processing actually performed by the given work will occur on a seperate transaction.
doList(SessionImplementor, QueryParameters) - Method in class org.hibernate.loader.Loader
Actually execute a query, ignoring the query cache
doLoad(LoadEvent, EntityPersister, EntityKey, LoadEventListener.LoadType) - Method in class org.hibernate.event.def.DefaultLoadEventListener
Coordinates the efforts to load a given entity.
doNonTransactedWork(IsolatedWork, SessionImplementor) - Static method in class org.hibernate.engine.transaction.Isolater
Ensures that all processing actually performed by the given work will occur outside of a transaction.
doSecondPass(Map) - Method in class org.hibernate.cfg.CollectionSecondPass

doSecondPass(Map) - Method in class org.hibernate.cfg.NamedSQLQuerySecondPass

doSecondPass(Map) - Method in class org.hibernate.cfg.ResultSetMappingSecondPass

doSecondPass(Map) - Method in interface org.hibernate.cfg.SecondPass

doTransform(ClassLoader, String, Class, ProtectionDomain, byte[]) - Method in class org.hibernate.bytecode.AbstractClassTransformerImpl

doTransform(ClassLoader, String, Class, ProtectionDomain, byte[]) - Method in class org.hibernate.bytecode.cglib.CglibClassTransformer

doTransform(ClassLoader, String, Class, ProtectionDomain, byte[]) - Method in class org.hibernate.bytecode.javassist.JavassistClassTransformer

doUpdateRows(Serializable, PersistentCollection, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

doUpdateRows(Serializable, PersistentCollection, SessionImplementor) - Method in class org.hibernate.persister.collection.BasicCollectionPersister

doUpdateRows(Serializable, PersistentCollection, SessionImplementor) - Method in class org.hibernate.persister.collection.OneToManyPersister

doWork(Connection) - Method in interface org.hibernate.engine.transaction.IsolatedWork
Perform the actual work to be done.
doWorkInCurrentTransaction(Connection, String) - Method in class org.hibernate.engine.TransactionHelper
The work to be done
doWorkInCurrentTransaction(Connection, String) - Method in class org.hibernate.id.MultipleHiLoPerTableGenerator

doWorkInCurrentTransaction(Connection, String) - Method in class org.hibernate.id.TableGenerator

doWorkInNewTransaction(SessionImplementor) - Method in class org.hibernate.engine.TransactionHelper
Suspend the current transaction and perform work in a new transaction
drop(boolean, boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaExport
Run the drop schema script.
dropConstraints() - Method in class org.hibernate.dialect.DB2Dialect

dropConstraints() - Method in class org.hibernate.dialect.DerbyDialect

dropConstraints() - Method in class org.hibernate.dialect.Dialect
Do we need to drop constraints before dropping tables in this dialect?
dropConstraints() - Method in class org.hibernate.dialect.FrontBaseDialect

dropConstraints() - Method in class org.hibernate.dialect.IngresDialect
Do we need to drop constraints before dropping tables in this dialect?
dropConstraints() - Method in class org.hibernate.dialect.JDataStoreDialect

dropConstraints() - Method in class org.hibernate.dialect.MimerSQLDialect
We do not have to drop constraints before we drop the table
dropConstraints() - Method in class org.hibernate.dialect.MySQLMyISAMDialect

dropConstraints() - Method in class org.hibernate.dialect.Oracle9Dialect

dropConstraints() - Method in class org.hibernate.dialect.PointbaseDialect

dropConstraints() - Method in class org.hibernate.dialect.PostgreSQLDialect

dropConstraints() - Method in class org.hibernate.dialect.SAPDBDialect

dropConstraints() - Method in class org.hibernate.dialect.SybaseAnywhereDialect
ASA does not require to drop constraint before dropping tables, and DROP statement syntax used by Hibernate to drop constraint is not compatible with ASA, so disable it
dropConstraints() - Method in class org.hibernate.dialect.TimesTenDialect

dropSchema() - Method in class org.hibernate.jmx.HibernateService

dropSchema() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Export the DROP DDL to the database
dropTemporaryTableAfterUse() - Method in class org.hibernate.dialect.Dialect

dropTemporaryTableAfterUse() - Method in class org.hibernate.dialect.Oracle9Dialect

dropTemporaryTableAfterUse() - Method in class org.hibernate.dialect.SybaseDialect

dropTemporaryTableIfNecessary(Queryable, SessionImplementor) - Method in class org.hibernate.hql.ast.exec.AbstractStatementExecutor

dump(Element) - Static method in class org.hibernate.util.XMLHelper

E

EAGER - Static variable in class org.hibernate.FetchMode
Deprecated. use FetchMode.JOIN
ELEMENTS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ELEMENTS - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ELEMENTS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ELSE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ELSE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ELSE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

EMPTY - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

EMPTY - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

EMPTY - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

EMPTY_BOOLEAN_ARRAY - Static variable in class org.hibernate.util.ArrayHelper

EMPTY_CLASS_ARRAY - Static variable in class org.hibernate.util.ArrayHelper

EMPTY_COLLECTION - Static variable in class org.hibernate.util.CollectionHelper

EMPTY_INT_ARRAY - Static variable in class org.hibernate.util.ArrayHelper

EMPTY_LIST - Static variable in class org.hibernate.util.CollectionHelper

EMPTY_MAP - Static variable in class org.hibernate.util.CollectionHelper

EMPTY_OBJECT_ARRAY - Static variable in class org.hibernate.util.ArrayHelper

EMPTY_STRING_ARRAY - Static variable in class org.hibernate.util.ArrayHelper

EMPTY_TYPE_ARRAY - Static variable in class org.hibernate.util.ArrayHelper

END - Static variable in class org.hibernate.criterion.MatchMode
Match the end of the string to the pattern
END - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

END - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

END - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ENTITY_CLASS - Static variable in class org.hibernate.persister.entity.AbstractEntityPersister

ENTITY_ID - Static variable in interface org.hibernate.persister.entity.EntityPersister
The property name of the "special" identifier property in HQL
ENTITY_NAME - Static variable in interface org.hibernate.id.IdentifierGenerator
The configuration parameter holding the entity name
EOF - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

EOF - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

EOF - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

EQ - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

EQ - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

EQ - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ERROR_CANNOT_DETERMINE_TYPE - Static variable in interface org.hibernate.hql.QueryTranslator

ERROR_CANNOT_FETCH_WITH_ITERATE - Static variable in interface org.hibernate.hql.QueryTranslator

ERROR_CANNOT_FORMAT_LITERAL - Static variable in interface org.hibernate.hql.QueryTranslator

ERROR_NAMED_PARAMETER_DOES_NOT_APPEAR - Static variable in interface org.hibernate.hql.QueryTranslator

ESCAPE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ESCAPE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ESCAPE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ESCqs - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ESCqs - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ESCqs - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

EVICT - Static variable in class org.hibernate.engine.CascadeStyle
evict
EVICT - Static variable in class org.hibernate.engine.CascadingAction

EXACT - Static variable in class org.hibernate.criterion.MatchMode
Match the entire string to the pattern
EXACT - Static variable in class org.hibernate.hql.ast.util.LiteralProcessor
Indicates that Float and Double literal values should be treated using the SQL "exact" format (i.e., '.001')
EXCEPTION - Static variable in class org.hibernate.ReplicationMode
Throw an exception when a row already exists.
EXISTS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

EXISTS - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

EXISTS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

EXPONENT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

EXPONENT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

EXPONENT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

EXPR_LIST - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

EXPR_LIST - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

EXPR_LIST - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

EhCache - class org.hibernate.cache.EhCache.
EHCache plugin for Hibernate
EHCache uses a MemoryStore and a DiskStore.
EhCache(Cache) - Constructor for class org.hibernate.cache.EhCache
Creates a new Hibernate pluggable cache based on a cache name.
EhCacheProvider - class org.hibernate.cache.EhCacheProvider.
Cache Provider plugin for ehcache-1.2.
EhCacheProvider() - Constructor for class org.hibernate.cache.EhCacheProvider

ElementPropertyMapping - class org.hibernate.persister.collection.ElementPropertyMapping.

ElementPropertyMapping(String[], Type) - Constructor for class org.hibernate.persister.collection.ElementPropertyMapping

ElementWrapper - class org.hibernate.tuple.ElementWrapper.
Wraps dom4j elements, allowing them to exist in a non-hierarchical structure.
ElementWrapper(Element) - Constructor for class org.hibernate.tuple.ElementWrapper

EmbeddedComponentType - class org.hibernate.type.EmbeddedComponentType.

EmbeddedComponentType(ComponentMetamodel) - Constructor for class org.hibernate.type.EmbeddedComponentType

EmbeddedPropertyAccessor - class org.hibernate.property.EmbeddedPropertyAccessor.

EmbeddedPropertyAccessor() - Constructor for class org.hibernate.property.EmbeddedPropertyAccessor

EmbeddedPropertyAccessor.EmbeddedGetter - class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter.

EmbeddedPropertyAccessor.EmbeddedSetter - class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedSetter.

EmptyExpression - class org.hibernate.criterion.EmptyExpression.

EmptyExpression(String) - Constructor for class org.hibernate.criterion.EmptyExpression

EmptyInterceptor - class org.hibernate.EmptyInterceptor.
An interceptor that does nothing.
EmptyInterceptor() - Constructor for class org.hibernate.EmptyInterceptor

EmptyIterator - class org.hibernate.util.EmptyIterator.

EnhancedUserType - interface org.hibernate.usertype.EnhancedUserType.
A custom type that may function as an identifier or discriminator type, or may be marshalled to and from an XML document
EntityAction - class org.hibernate.action.EntityAction.
Any action relating to insert/update/delete of an entity instance
EntityAction(SessionImplementor, Serializable, Object, EntityPersister) - Constructor for class org.hibernate.action.EntityAction

EntityAliases - interface org.hibernate.loader.EntityAliases.
Metadata describing the SQL result set column aliases for a particular entity.
EntityDeleteAction - class org.hibernate.action.EntityDeleteAction.

EntityDeleteAction(Serializable, Object[], Object, Object, EntityPersister, boolean, SessionImplementor) - Constructor for class org.hibernate.action.EntityDeleteAction

EntityEntityModeToTuplizerMapping - class org.hibernate.tuple.entity.EntityEntityModeToTuplizerMapping.
Handles mapping EntityModes to EntityTuplizers.
EntityEntityModeToTuplizerMapping(PersistentClass, EntityMetamodel) - Constructor for class org.hibernate.tuple.entity.EntityEntityModeToTuplizerMapping
Instantiates a EntityEntityModeToTuplizerMapping based on the given entity mapping and metamodel definitions.
EntityEntry - class org.hibernate.engine.EntityEntry.
We need an entry to tell us all about the current state of an object with respect to its persistent state
EntityFetchReturn - class org.hibernate.loader.custom.EntityFetchReturn.
Spefically a fetch return that refers to an entity association.
EntityFetchReturn(String, EntityAliases, NonScalarReturn, String, LockMode) - Constructor for class org.hibernate.loader.custom.EntityFetchReturn

EntityIdentityInsertAction - class org.hibernate.action.EntityIdentityInsertAction.

EntityIdentityInsertAction(Object[], Object, EntityPersister, SessionImplementor, boolean) - Constructor for class org.hibernate.action.EntityIdentityInsertAction

EntityInsertAction - class org.hibernate.action.EntityInsertAction.

EntityInsertAction(Serializable, Object[], Object, Object, EntityPersister, SessionImplementor) - Constructor for class org.hibernate.action.EntityInsertAction

EntityJoinWalker - class org.hibernate.loader.entity.EntityJoinWalker.
A walker for loaders that fetch entities
EntityJoinWalker(OuterJoinLoadable, String[], int, LockMode, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.entity.EntityJoinWalker

EntityKey - class org.hibernate.engine.EntityKey.
Uniquely identifies of an entity instance in a particular session by identifier.
EntityKey(Serializable, EntityPersister, EntityMode) - Constructor for class org.hibernate.engine.EntityKey
Construct a unique identifier for an entity class instance
EntityLoader - class org.hibernate.loader.entity.EntityLoader.
Loads an entity instance using outerjoin fetching to fetch associated entities.
EntityLoader(OuterJoinLoadable, LockMode, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.entity.EntityLoader

EntityLoader(OuterJoinLoadable, int, LockMode, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.entity.EntityLoader

EntityLoader(OuterJoinLoadable, String[], Type, int, LockMode, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.entity.EntityLoader

EntityMetamodel - class org.hibernate.tuple.entity.EntityMetamodel.
Centralizes metamodel information about an entity.
EntityMetamodel(PersistentClass, SessionFactoryImplementor) - Constructor for class org.hibernate.tuple.entity.EntityMetamodel

EntityMode - class org.hibernate.EntityMode.
Defines the representation modes available for entities.
EntityMode(String) - Constructor for class org.hibernate.EntityMode

EntityModeToTuplizerMapping - class org.hibernate.tuple.EntityModeToTuplizerMapping.
Centralizes handling of EntityMode to Tuplizer mappings.
EntityModeToTuplizerMapping() - Constructor for class org.hibernate.tuple.EntityModeToTuplizerMapping

EntityNotFoundDelegate - interface org.hibernate.proxy.EntityNotFoundDelegate.
Delegate to handle the scenario of an entity not found by a specified id.
EntityPersister - interface org.hibernate.persister.entity.EntityPersister.
Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.
EntityStatistics - class org.hibernate.stat.EntityStatistics.
Entity related statistics
EntityTuplizer - interface org.hibernate.tuple.entity.EntityTuplizer.
Defines further responsibilities reagarding tuplization based on a mapped entity.
EntityType - class org.hibernate.type.EntityType.
A reference to an entity class
EntityType(String, String, boolean, boolean, boolean) - Constructor for class org.hibernate.type.EntityType

EntityUniqueKey - class org.hibernate.engine.EntityUniqueKey.
Used to uniquely key an entity instance in relation to a particular session by some unique property reference, as opposed to identifier.
EntityUniqueKey(String, String, Object, Type, EntityMode, SessionFactoryImplementor) - Constructor for class org.hibernate.engine.EntityUniqueKey

EntityUpdateAction - class org.hibernate.action.EntityUpdateAction.

EntityUpdateAction(Serializable, Object[], int[], boolean, Object[], Object, Object, Object, Object, EntityPersister, SessionImplementor) - Constructor for class org.hibernate.action.EntityUpdateAction

Environment - class org.hibernate.cfg.Environment.
Provides access to configuration info passed in Properties objects.
EqualsHelper - class org.hibernate.util.EqualsHelper.

ErrorCounter - class org.hibernate.hql.ast.ErrorCounter.
An error handler that counts parsing errors and warnings.
ErrorCounter() - Constructor for class org.hibernate.hql.ast.ErrorCounter

ErrorReporter - interface org.hibernate.hql.ast.ErrorReporter.
Implementations will report or handle errors invoked by an ANTLR base parser.
EventListeners - class org.hibernate.event.EventListeners.
A convience holder for all defined session event listeners.
EventListeners() - Constructor for class org.hibernate.event.EventListeners

EventSource - interface org.hibernate.event.EventSource.

EvictEvent - class org.hibernate.event.EvictEvent.
Defines an event class for the evicting of an entity.
EvictEvent(Object, EventSource) - Constructor for class org.hibernate.event.EvictEvent

EvictEventListener - interface org.hibernate.event.EvictEventListener.
Defines the contract for handling of evict events generated from a session.
EvictVisitor - class org.hibernate.event.def.EvictVisitor.
Evict any collections referenced by the object from the session cache.
Example - class org.hibernate.criterion.Example.
Support for query by example.
Example(Object, Example.PropertySelector) - Constructor for class org.hibernate.criterion.Example

Example.PropertySelector - interface org.hibernate.criterion.Example.PropertySelector.
A strategy for choosing property values for inclusion in the query criteria
ExceptionUtils - class org.hibernate.exception.ExceptionUtils.
Provides utilities for manipulating and examining Throwable objects.
Executable - interface org.hibernate.action.Executable.
An operation which may be scheduled for later execution.
ExecuteUpdateResultCheckStyle - class org.hibernate.engine.ExecuteUpdateResultCheckStyle.
For persistence operations (INSERT, UPDATE, DELETE) what style of determining results (success/failure) is to be used.
ExistsSubqueryExpression - class org.hibernate.criterion.ExistsSubqueryExpression.

ExistsSubqueryExpression(String, DetachedCriteria) - Constructor for class org.hibernate.criterion.ExistsSubqueryExpression

Expectation - interface org.hibernate.jdbc.Expectation.
Defines an expected DML operation outcome.
Expectations - class org.hibernate.jdbc.Expectations.
Holds various often used Expectations.BasicExpectation definitions.
Expectations.BasicExpectation - class org.hibernate.jdbc.Expectations.BasicExpectation.

Expectations.BasicExpectation(int) - Constructor for class org.hibernate.jdbc.Expectations.BasicExpectation

Expectations.BasicParamExpectation - class org.hibernate.jdbc.Expectations.BasicParamExpectation.

Expectations.BasicParamExpectation(int, int) - Constructor for class org.hibernate.jdbc.Expectations.BasicParamExpectation

ExpectedTypeAwareNode - interface org.hibernate.hql.ast.tree.ExpectedTypeAwareNode.
Interface for nodes which wish to be made aware of any determined "expected type" based on the context within they appear in the query.
ExplicitParameterSpecification - interface org.hibernate.param.ExplicitParameterSpecification.
An additional contract for parameters which originate from parameters explicitly encountered in the source statement (HQL or native-SQL).
Expression - class org.hibernate.criterion.Expression.
This class is semi-deprecated.
ExtendsQueueEntry - class org.hibernate.cfg.ExtendsQueueEntry.
Represents a mapping queued for delayed processing to await processing of an extends entity upon which it depends.
ExtendsQueueEntry(String, String, Document) - Constructor for class org.hibernate.cfg.ExtendsQueueEntry

ExternalSessionFactoryConfig - class org.hibernate.util.ExternalSessionFactoryConfig.
Defines support for various externally configurable SessionFactory(s), for example, JMX or the JCA adapter.
ExternalSessionFactoryConfig() - Constructor for class org.hibernate.util.ExternalSessionFactoryConfig

element - Variable in class org.hibernate.collection.PersistentElementHolder

element - Variable in class org.hibernate.collection.PersistentIndexedElementHolder

element(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

element(QName) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

element(String) - Method in class org.hibernate.tuple.ElementWrapper

element(QName) - Method in class org.hibernate.tuple.ElementWrapper

elementByID(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

elementByID(String) - Method in class org.hibernate.tuple.ElementWrapper

elementColumnAliases - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

elementColumnIsInPrimaryKey - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

elementColumnIsSettable - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

elementColumnNames - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

elementExists(Serializable, Object, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

elementExists(Serializable, Object, SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister

elementFormulaTemplates - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

elementFormulas - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

elementIsPureFormula - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

elementIterator() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

elementIterator(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

elementIterator(QName) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

elementIterator() - Method in class org.hibernate.tuple.ElementWrapper

elementIterator(String) - Method in class org.hibernate.tuple.ElementWrapper

elementIterator(QName) - Method in class org.hibernate.tuple.ElementWrapper

elementText(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

elementText(QName) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

elementText(String) - Method in class org.hibernate.tuple.ElementWrapper

elementText(QName) - Method in class org.hibernate.tuple.ElementWrapper

elementTextTrim(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

elementTextTrim(QName) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

elementTextTrim(String) - Method in class org.hibernate.tuple.ElementWrapper

elementTextTrim(QName) - Method in class org.hibernate.tuple.ElementWrapper

elementType - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

elements() - Method in class org.hibernate.collection.PersistentArrayHolder

elements() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

elements(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

elements(QName) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

elements() - Method in class org.hibernate.tuple.ElementWrapper

elements(String) - Method in class org.hibernate.tuple.ElementWrapper

elements(QName) - Method in class org.hibernate.tuple.ElementWrapper

elseClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

empty() - Method in class org.hibernate.collection.AbstractPersistentCollection
Is the initialized collection empty?
empty() - Method in class org.hibernate.collection.PersistentArrayHolder

empty() - Method in class org.hibernate.collection.PersistentBag

empty() - Method in interface org.hibernate.collection.PersistentCollection
Is the collection empty? (don't try to initialize the collection)
empty() - Method in class org.hibernate.collection.PersistentElementHolder

empty() - Method in class org.hibernate.collection.PersistentIdentifierBag

empty() - Method in class org.hibernate.collection.PersistentIndexedElementHolder

empty() - Method in class org.hibernate.collection.PersistentList

empty() - Method in class org.hibernate.collection.PersistentMap

empty() - Method in class org.hibernate.collection.PersistentSet

enableFilter(String) - Method in interface org.hibernate.Session
Enable the named filter for this current session.
enableFilter(String) - Method in class org.hibernate.impl.SessionImpl

enableLike(MatchMode) - Method in class org.hibernate.criterion.Example
Use the "like" operator for all string-valued properties
enableLike() - Method in class org.hibernate.criterion.Example
Use the "like" operator for all string-valued properties
end(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.ClauseParser

end(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.FromParser

end(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.FromPathExpressionParser

end(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.GroupByParser

end(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.OrderByParser

end(QueryTranslatorImpl) - Method in interface org.hibernate.hql.classic.Parser

end(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.PathExpressionParser

end(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.PreprocessingParser

end(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.SelectParser

end(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.SelectPathExpressionParser

end(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.WhereParser

endFunctionTemplate(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

endFunctionTemplate(AST) - Method in class org.hibernate.hql.ast.SqlGenerator

endLoadingCollections(CollectionPersister, Object, SessionImplementor) - Method in class org.hibernate.engine.CollectionLoadContext
Finish the process of loading collections for a particular result set
endRead() - Method in class org.hibernate.collection.AbstractPersistentCollection
Called after reading all rows from the JDBC result set
endRead() - Method in class org.hibernate.collection.PersistentArrayHolder

endRead() - Method in interface org.hibernate.collection.PersistentCollection
Called after reading all rows from the JDBC result set
endRead() - Method in class org.hibernate.collection.PersistentSet

endTransaction(boolean) - Method in class org.hibernate.stat.StatisticsImpl

endTransaction(boolean) - Method in interface org.hibernate.stat.StatisticsImplementor

enlistResource(XAResource) - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter

entity(Class) - Static method in class org.hibernate.Hibernate
A Hibernate persistent object (entity) type.
entity(String) - Static method in class org.hibernate.Hibernate
A Hibernate persistent object (entity) type.
entityIsDetached(MergeEvent, Map) - Method in class org.hibernate.event.def.DefaultMergeEventListener

entityIsDetached(SaveOrUpdateEvent) - Method in class org.hibernate.event.def.DefaultSaveOrUpdateEventListener
Handle the given update event.
entityIsPersistent(MergeEvent, Map) - Method in class org.hibernate.event.def.DefaultMergeEventListener

entityIsPersistent(PersistEvent, Map) - Method in class org.hibernate.event.def.DefaultPersistEventListener

entityIsPersistent(SaveOrUpdateEvent) - Method in class org.hibernate.event.def.DefaultSaveOrUpdateEventListener

entityIsTransient(MergeEvent, Map) - Method in class org.hibernate.event.def.DefaultMergeEventListener

entityIsTransient(PersistEvent, Map) - Method in class org.hibernate.event.def.DefaultPersistEventListener
Handle the given create event.
entityIsTransient(SaveOrUpdateEvent) - Method in class org.hibernate.event.def.DefaultSaveOrUpdateEventListener
Handle the given save event.
entityName - Variable in class org.hibernate.loader.entity.AbstractEntityLoader

entries(CollectionPersister) - Method in class org.hibernate.collection.PersistentArrayHolder

entries(CollectionPersister) - Method in class org.hibernate.collection.PersistentBag

entries(CollectionPersister) - Method in interface org.hibernate.collection.PersistentCollection
Iterate all collection entries, during update of the database
entries(CollectionPersister) - Method in class org.hibernate.collection.PersistentElementHolder

entries(CollectionPersister) - Method in class org.hibernate.collection.PersistentIdentifierBag

entries(CollectionPersister) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

entries(CollectionPersister) - Method in class org.hibernate.collection.PersistentList

entries(CollectionPersister) - Method in class org.hibernate.collection.PersistentMap

entries(CollectionPersister) - Method in class org.hibernate.collection.PersistentSet

entries(Map) - Static method in class org.hibernate.util.IdentityMap

entryArray() - Method in class org.hibernate.util.IdentityMap

entryExists(Object, int) - Method in class org.hibernate.collection.PersistentArrayHolder

entryExists(Object, int) - Method in class org.hibernate.collection.PersistentBag

entryExists(Object, int) - Method in interface org.hibernate.collection.PersistentCollection
Does an element exist at this entry in the collection?
entryExists(Object, int) - Method in class org.hibernate.collection.PersistentElementHolder

entryExists(Object, int) - Method in class org.hibernate.collection.PersistentIdentifierBag

entryExists(Object, int) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

entryExists(Object, int) - Method in class org.hibernate.collection.PersistentList

entryExists(Object, int) - Method in class org.hibernate.collection.PersistentMap

entryExists(Object, int) - Method in class org.hibernate.collection.PersistentSet

entryList() - Method in class org.hibernate.util.IdentityMap

entrySet() - Method in class org.hibernate.collection.PersistentMap

entrySet() - Method in class org.hibernate.proxy.map.MapProxy

entrySet() - Method in class org.hibernate.util.FastHashMap
Return a collection view of the mappings contained in this map.
entrySet() - Method in class org.hibernate.util.IdentityMap

eq(Object) - Method in class org.hibernate.criterion.Property

eq(DetachedCriteria) - Method in class org.hibernate.criterion.Property

eq(String, Object) - Static method in class org.hibernate.criterion.Restrictions
Apply an "equal" constraint to the named property
eq(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

eqAll(DetachedCriteria) - Method in class org.hibernate.criterion.Property

eqAll(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

eqProperty(Property) - Method in class org.hibernate.criterion.Property

eqProperty(String) - Method in class org.hibernate.criterion.Property

eqProperty(String, String) - Static method in class org.hibernate.criterion.Restrictions
Apply an "equal" constraint to two properties
equalityExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

equals(Object) - Method in class org.hibernate.action.DelayedPostInsertIdentifier

equals(Object) - Method in class org.hibernate.bytecode.javassist.FastClass

equals(Object) - Method in class org.hibernate.cache.CacheKey

equals(Object) - Method in class org.hibernate.cache.FilterKey

equals(Object) - Method in class org.hibernate.cache.QueryKey

equals(Object) - Method in class org.hibernate.collection.PersistentBag
Bag does not respect the collection API and do an JVM instance comparison to do the equals.
equals(Object) - Method in class org.hibernate.collection.PersistentList

equals(Object) - Method in class org.hibernate.collection.PersistentMap

equals(Object) - Method in class org.hibernate.collection.PersistentSet

equals(Object) - Method in class org.hibernate.engine.CollectionKey

equals(Object) - Method in class org.hibernate.engine.EntityKey

equals(Object) - Method in class org.hibernate.engine.EntityUniqueKey

equals(Object) - Method in class org.hibernate.engine.TypedValue

equals(Object) - Method in class org.hibernate.engine.query.sql.NativeSQLQuerySpecification

equals(Object) - Method in class org.hibernate.hql.ast.tree.FromElement

equals(Object) - Method in class org.hibernate.mapping.Column

equals(Column) - Method in class org.hibernate.mapping.Column

equals(Object) - Method in class org.hibernate.secure.HibernatePermission

equals(Object) - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter

equals(Object) - Method in class org.hibernate.tuple.ElementWrapper

equals(Object, Object) - Method in interface org.hibernate.usertype.CompositeUserType
Compare two instances of the class mapped by this type for persistence "equality".
equals(Object, Object) - Method in interface org.hibernate.usertype.UserType
Compare two instances of the class mapped by this type for persistence "equality".
equals(Object, Object) - Static method in class org.hibernate.util.EqualsHelper

equals(Object) - Method in class org.hibernate.util.FastHashMap
Compare the specified object with this list for equality.
equals(Object) - Method in class org.hibernate.util.IdentityMap.IdentityKey

equalsSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentArrayHolder

equalsSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentBag

equalsSnapshot(CollectionPersister) - Method in interface org.hibernate.collection.PersistentCollection
Does the current state exactly match the snapshot?
equalsSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentElementHolder

equalsSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentIdentifierBag

equalsSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

equalsSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentList

equalsSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentMap

equalsSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentSet

error(SAXParseException) - Method in class org.hibernate.util.XMLHelper.ErrorLogger

errorIfClosed() - Method in class org.hibernate.impl.AbstractSessionImpl

escapeMultibyteChars(String) - Static method in class org.hibernate.hql.ast.util.ASTPrinter

evaluateAssignment(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

evaluateAssignment(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

evict(Object) - Method in interface org.hibernate.Session
Remove this instance from the session cache.
evict(Class) - Method in interface org.hibernate.SessionFactory
Evict all entries from the second-level cache.
evict(Class, Serializable) - Method in interface org.hibernate.SessionFactory
Evict an entry from the second-level cache.
evict() - Method in class org.hibernate.action.CollectionAction

evict(Object) - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Called after an item has become stale (before the transaction completes).
evict(Object) - Method in class org.hibernate.cache.NonstrictReadWriteCache
Invalidate the item
evict(Object) - Method in class org.hibernate.cache.ReadOnlyCache
Do nothing.
evict(Object) - Method in class org.hibernate.cache.ReadWriteCache
Do nothing.
evict(Object) - Method in class org.hibernate.cache.TransactionalCache

evict(Class, Serializable) - Method in class org.hibernate.impl.SessionFactoryImpl

evict(Class) - Method in class org.hibernate.impl.SessionFactoryImpl

evict(Object) - Method in class org.hibernate.impl.SessionImpl
remove any hard references to the entity that are held by the infrastructure (references held by application or other persistant instances are okay)
evict(Class, Serializable) - Method in class org.hibernate.jmx.SessionFactoryStub

evict(Class) - Method in class org.hibernate.jmx.SessionFactoryStub

evictCollection(String) - Method in interface org.hibernate.SessionFactory
Evict all entries from the second-level cache.
evictCollection(String, Serializable) - Method in interface org.hibernate.SessionFactory
Evict an entry from the second-level cache.
evictCollection(Object, CollectionType) - Method in class org.hibernate.event.def.EvictVisitor

evictCollection(String, Serializable) - Method in class org.hibernate.impl.SessionFactoryImpl

evictCollection(String) - Method in class org.hibernate.impl.SessionFactoryImpl

evictCollection(String, Serializable) - Method in class org.hibernate.jmx.SessionFactoryStub

evictCollection(String) - Method in class org.hibernate.jmx.SessionFactoryStub

evictEntity(String) - Method in interface org.hibernate.SessionFactory
Evict all entries from the second-level cache.
evictEntity(String, Serializable) - Method in interface org.hibernate.SessionFactory
Evict an entry from the second-level cache.
evictEntity(String, Serializable) - Method in class org.hibernate.impl.SessionFactoryImpl

evictEntity(String) - Method in class org.hibernate.impl.SessionFactoryImpl

evictEntity(String, Serializable) - Method in class org.hibernate.jmx.SessionFactoryStub

evictEntity(String) - Method in class org.hibernate.jmx.SessionFactoryStub

evictQueries() - Method in interface org.hibernate.SessionFactory
Evict any query result sets cached in the default query cache region.
evictQueries(String) - Method in interface org.hibernate.SessionFactory
Evict any query result sets cached in the named query cache region.
evictQueries() - Method in class org.hibernate.impl.SessionFactoryImpl

evictQueries(String) - Method in class org.hibernate.impl.SessionFactoryImpl

evictQueries() - Method in class org.hibernate.jmx.SessionFactoryStub

evictQueries(String) - Method in class org.hibernate.jmx.SessionFactoryStub

exclude(AST) - Method in interface org.hibernate.hql.ast.util.ASTUtil.FilterPredicate
Returns true if the node should be filtered out.
exclude(AST) - Method in class org.hibernate.hql.ast.util.ASTUtil.IncludePredicate

excludeEmpty() - Method in class org.hibernate.criterion.AbstractEmptinessExpression

excludeEmpty() - Method in class org.hibernate.criterion.EmptyExpression

excludeEmpty() - Method in class org.hibernate.criterion.NotEmptyExpression

excludeNone() - Method in class org.hibernate.criterion.Example
Don't exclude null or zero-valued properties
excludeProperty(String) - Method in class org.hibernate.criterion.Example
Exclude a particular named property
excludeZeroes() - Method in class org.hibernate.criterion.Example
Exclude zero-valued properties
execute() - Method in class org.hibernate.action.BulkOperationCleanupAction

execute() - Method in class org.hibernate.action.CollectionRecreateAction

execute() - Method in class org.hibernate.action.CollectionRemoveAction

execute() - Method in class org.hibernate.action.CollectionUpdateAction

execute() - Method in class org.hibernate.action.EntityDeleteAction

execute() - Method in class org.hibernate.action.EntityIdentityInsertAction

execute() - Method in class org.hibernate.action.EntityInsertAction

execute() - Method in class org.hibernate.action.EntityUpdateAction

execute() - Method in interface org.hibernate.action.Executable
Execute this action
execute(Executable) - Method in class org.hibernate.engine.ActionQueue

execute(QueryParameters, SessionImplementor) - Method in class org.hibernate.hql.ast.exec.BasicExecutor

execute(QueryParameters, SessionImplementor) - Method in class org.hibernate.hql.ast.exec.MultiTableDeleteExecutor

execute(QueryParameters, SessionImplementor) - Method in class org.hibernate.hql.ast.exec.MultiTableUpdateExecutor

execute(QueryParameters, SessionImplementor) - Method in interface org.hibernate.hql.ast.exec.StatementExecutor
Execute the sql managed by this executor using the given parameters.
execute(boolean, boolean, boolean, boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaExport

execute() - Method in class org.hibernate.tool.hbm2ddl.SchemaExportTask
Execute the task
execute(boolean, boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaUpdate
Execute the schema updates
execute() - Method in class org.hibernate.tool.hbm2ddl.SchemaUpdateTask
Execute the task
execute() - Method in class org.hibernate.tool.hbm2ddl.SchemaValidatorTask
Execute the task
execute() - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

executeActions() - Method in class org.hibernate.engine.ActionQueue
Perform all currently queued actions.
executeAndExtract(PreparedStatement) - Method in class org.hibernate.id.IdentityGenerator.GetGeneratedKeysDelegate

executeAndExtract(PreparedStatement) - Method in class org.hibernate.id.IdentityGenerator.InsertSelectDelegate

executeAndExtract(PreparedStatement) - Method in class org.hibernate.id.SequenceIdentityGenerator.Delegate

executeAndExtract(PreparedStatement) - Method in class org.hibernate.id.insert.AbstractReturningDelegate

executeBatch() - Method in class org.hibernate.jdbc.AbstractBatcher

executeBatch() - Method in interface org.hibernate.jdbc.Batcher
Execute the batch
executeInserts() - Method in class org.hibernate.engine.ActionQueue
Perform all currently queued entity-insertion actions.
executeNativeUpdate(NativeSQLQuerySpecification, QueryParameters) - Method in interface org.hibernate.engine.SessionImplementor
Execute a native SQL update or delete query
executeNativeUpdate(NativeSQLQuerySpecification, QueryParameters) - Method in class org.hibernate.impl.SessionImpl

executeNativeUpdate(NativeSQLQuerySpecification, QueryParameters) - Method in class org.hibernate.impl.StatelessSessionImpl

executeUpdate() - Method in interface org.hibernate.Query
Execute the update or delete statement.
executeUpdate(String, QueryParameters) - Method in interface org.hibernate.engine.SessionImplementor
Execute a HQL update or delete query
executeUpdate(QueryParameters, SessionImplementor) - Method in interface org.hibernate.hql.QueryTranslator
Perform a bulk update/delete operation given the underlying query defintion.
executeUpdate(QueryParameters, SessionImplementor) - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

executeUpdate(QueryParameters, SessionImplementor) - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

executeUpdate() - Method in class org.hibernate.impl.QueryImpl

executeUpdate() - Method in class org.hibernate.impl.SQLQueryImpl

executeUpdate(String, QueryParameters) - Method in class org.hibernate.impl.SessionImpl

executeUpdate(String, QueryParameters) - Method in class org.hibernate.impl.StatelessSessionImpl

exists(DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

exoticComparisonExpression(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

expandParameterLists(Map) - Method in class org.hibernate.impl.AbstractQueryImpl
Warning: adds new parameters to the argument by side-effect, as well as mutating the query string!
expr(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

expr(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

exprList() - Method in class org.hibernate.hql.antlr.HqlBaseParser

exprOrSubquery(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

expression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

expressionOrVector() - Method in class org.hibernate.hql.antlr.HqlBaseParser

extendsQueue - Variable in class org.hibernate.cfg.Configuration

extendsQueue - Variable in class org.hibernate.cfg.Mappings

extract(Object[], ResultSet, SessionImplementor) - Method in class org.hibernate.loader.custom.CustomLoader.NonScalarResultColumnProcessor

extract(Object[], ResultSet, SessionImplementor) - Method in class org.hibernate.loader.custom.CustomLoader.ScalarResultColumnProcessor

extractConstraintName(SQLException) - Method in interface org.hibernate.exception.ViolatedConstraintNameExtracter
Extract the name of the violated constraint from the given SQLException.
extractDataType(Node) - Method in class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode

extractErrorCode(SQLException) - Static method in class org.hibernate.exception.JDBCExceptionHelper
For the given SQLException, locates the vendor-specific error code.
extractFieldInterceptor(Object) - Static method in class org.hibernate.intercept.FieldInterceptionHelper

extractFieldInterceptor(Object) - Static method in class org.hibernate.intercept.cglib.CGLIBHelper

extractFieldInterceptor(Object) - Static method in class org.hibernate.intercept.javassist.JavassistHelper

extractSqlState(SQLException) - Static method in class org.hibernate.exception.JDBCExceptionHelper
For the given SQLException, locates the X/Open-compliant SQLState.
extractSqlStateClassCode(SQLException) - Static method in class org.hibernate.exception.JDBCExceptionHelper
For the given SQLException, locates the X/Open-compliant SQLState's class code.
extractUsingTemplate(String, String, String) - Method in class org.hibernate.exception.TemplatedViolatedConstraintNameExtracter
Extracts the constraint name based on a template (i.e., templateStart constraintName templateEnd).

F

FALSE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

FALSE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

FALSE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

FALSE - Static variable in class org.hibernate.util.ArrayHelper

FETCH - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

FETCH - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

FETCH - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

FILTERS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

FILTERS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

FILTER_ENTITY - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

FILTER_ENTITY - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

FILTER_ENTITY - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

FLOAT - Static variable in class org.hibernate.Hibernate
Hibernate float type.
FLOAT_SUFFIX - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

FLOAT_SUFFIX - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

FLOAT_SUFFIX - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

FLUSH_BEFORE_COMPLETION - Static variable in class org.hibernate.cfg.Environment
Enable automatic flush during the JTA beforeCompletion() callback
FORCE - Static variable in class org.hibernate.LockMode
Similiar to LockMode.UPGRADE except that, for versioned entities, it results in a forced version increment.
FOREIGN_KEY_FROM_PARENT - Static variable in class org.hibernate.type.ForeignKeyDirection
A foreign key from parent to child
FOREIGN_KEY_TO_PARENT - Static variable in class org.hibernate.type.ForeignKeyDirection
A foreign key from child to parent
FORMAT_SQL - Static variable in class org.hibernate.cfg.Environment
Enable formatting of SQL logged to the console
FORWARD_ONLY - Static variable in class org.hibernate.ScrollMode

FROM - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

FROM - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

FROM - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

FROM_FRAGMENT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

FROM_FRAGMENT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

FULL - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

FULL - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

FULL - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

FULL_JOIN - Static variable in interface org.hibernate.criterion.CriteriaSpecification
Specifies joining to an entity based on a full join.
FULL_JOIN - Static variable in class org.hibernate.sql.JoinFragment

FastClass - class org.hibernate.bytecode.javassist.FastClass.

FastHashMap - class org.hibernate.util.FastHashMap.
A customized implementation of java.util.HashMap designed to operate in a multithreaded environment where the large majority of method calls are read-only, instead of structural changes.
FastHashMap() - Constructor for class org.hibernate.util.FastHashMap
Construct a an empty map.
FastHashMap(int) - Constructor for class org.hibernate.util.FastHashMap
Construct an empty map with the specified capacity.
FastHashMap(int, float) - Constructor for class org.hibernate.util.FastHashMap
Construct an empty map with the specified capacity and load factor.
FastHashMap(Map) - Constructor for class org.hibernate.util.FastHashMap
Construct a new map with the same mappings as the specified map.
FetchMode - class org.hibernate.FetchMode.
Represents an association fetching strategy.
FetchReturn - class org.hibernate.loader.custom.FetchReturn.
Represents a return which names a fetched association.
FetchReturn(NonScalarReturn, String, String, LockMode) - Constructor for class org.hibernate.loader.custom.FetchReturn
Creates a return descriptor for an association fetch.
Fetchable - interface org.hibernate.mapping.Fetchable.
Any mapping with an outer-join attribute
FetchingScrollableResultsImpl - class org.hibernate.impl.FetchingScrollableResultsImpl.
Implementation of ScrollableResults which can handle collection fetches.
FetchingScrollableResultsImpl(ResultSet, PreparedStatement, SessionImplementor, Loader, QueryParameters, Type[], HolderInstantiator) - Constructor for class org.hibernate.impl.FetchingScrollableResultsImpl

FieldFilter - interface org.hibernate.bytecode.javassist.FieldFilter.
Contract for deciding whether fields should be read and/or write intercepted.
FieldFilter - interface org.hibernate.bytecode.util.FieldFilter.
Used to determine whether a field reference should be instrumented.
FieldHandled - interface org.hibernate.bytecode.javassist.FieldHandled.
Interface introduced to the enhanced class in order to be able to inject a FieldHandler to define the interception behavior.
FieldHandler - interface org.hibernate.bytecode.javassist.FieldHandler.
The interface defining how interception of a field should be handled.
FieldInterceptionHelper - class org.hibernate.intercept.FieldInterceptionHelper.
Helper class for dealing with enhanced entity classes.
FieldInterceptor - interface org.hibernate.intercept.FieldInterceptor.
Contract for field interception handlers.
FieldInterceptorImpl - class org.hibernate.intercept.cglib.FieldInterceptorImpl.
A field-level interceptor that initializes lazily fetched properties.
FieldInterceptorImpl - class org.hibernate.intercept.javassist.FieldInterceptorImpl.
A field-level interceptor that initializes lazily fetched properties.
FieldTransformer - class org.hibernate.bytecode.javassist.FieldTransformer.
The thing that handles actual class enhancement in regards to intercepting field accesses.
FieldTransformer() - Constructor for class org.hibernate.bytecode.javassist.FieldTransformer

FieldTransformer(FieldFilter) - Constructor for class org.hibernate.bytecode.javassist.FieldTransformer

Filter - interface org.hibernate.Filter.
Type definition of Filter.
FilterDefinition - class org.hibernate.engine.FilterDefinition.
A FilterDefinition defines the global attributes of a dynamic filter.
FilterDefinition(String, String, Map) - Constructor for class org.hibernate.engine.FilterDefinition
Construct a new FilterDefinition instance.
FilterHelper - class org.hibernate.util.FilterHelper.
Implementation of FilterHelper.
FilterHelper(Map, Dialect, SQLFunctionRegistry) - Constructor for class org.hibernate.util.FilterHelper
The map of defined filters.
FilterImpl - class org.hibernate.impl.FilterImpl.
Implementation of FilterImpl.
FilterImpl(FilterDefinition) - Constructor for class org.hibernate.impl.FilterImpl
Constructs a new FilterImpl.
FilterKey - class org.hibernate.cache.FilterKey.
Allows cached queries to be keyed by enabled filters.
FilterKey(String, Map, Map, EntityMode) - Constructor for class org.hibernate.cache.FilterKey

FilterQueryPlan - class org.hibernate.engine.query.FilterQueryPlan.
Extends an HQLQueryPlan to maintain a reference to the collection-role name being filtered.
FilterQueryPlan(String, String, boolean, Map, SessionFactoryImplementor) - Constructor for class org.hibernate.engine.query.FilterQueryPlan

FilterTranslator - interface org.hibernate.hql.FilterTranslator.
Specialized interface for filters.
Filterable - interface org.hibernate.mapping.Filterable.
Defines mapping elements to which filters may be applied.
FirebirdDialect - class org.hibernate.dialect.FirebirdDialect.
An SQL dialect for Firebird.
FirebirdDialect() - Constructor for class org.hibernate.dialect.FirebirdDialect

FloatType - class org.hibernate.type.FloatType.
float: A type that maps an SQL FLOAT to a Java Float.
FloatType() - Constructor for class org.hibernate.type.FloatType

FlushEntityEvent - class org.hibernate.event.FlushEntityEvent.

FlushEntityEvent(EventSource, Object, EntityEntry) - Constructor for class org.hibernate.event.FlushEntityEvent

FlushEntityEventListener - interface org.hibernate.event.FlushEntityEventListener.

FlushEvent - class org.hibernate.event.FlushEvent.
Defines an event class for the flushing of a session.
FlushEvent(EventSource) - Constructor for class org.hibernate.event.FlushEvent

FlushEventListener - interface org.hibernate.event.FlushEventListener.
Defines the contract for handling of session flush events.
FlushMode - class org.hibernate.FlushMode.
Represents a flushing strategy.
FlushVisitor - class org.hibernate.event.def.FlushVisitor.
Process collections reachable from an entity.
ForUpdateFragment - class org.hibernate.sql.ForUpdateFragment.

ForUpdateFragment(Dialect) - Constructor for class org.hibernate.sql.ForUpdateFragment

ForUpdateFragment(Dialect, Map, Map) - Constructor for class org.hibernate.sql.ForUpdateFragment

ForeignGenerator - class org.hibernate.id.ForeignGenerator.
foreign

An Identifier generator that uses the value of the id property of an associated object

One mapping parameter is required: property.
ForeignGenerator() - Constructor for class org.hibernate.id.ForeignGenerator

ForeignKey - class org.hibernate.mapping.ForeignKey.
A foreign key constraint
ForeignKey() - Constructor for class org.hibernate.mapping.ForeignKey

ForeignKeyDirection - class org.hibernate.type.ForeignKeyDirection.
Represents directionality of the foreign key constraint
ForeignKeyDirection() - Constructor for class org.hibernate.type.ForeignKeyDirection

ForeignKeyMetadata - class org.hibernate.tool.hbm2ddl.ForeignKeyMetadata.
JDBC foreign key metadata
ForeignKeys - class org.hibernate.engine.ForeignKeys.
Algorithms related to foreign key constraint transparency
ForeignKeys.Nullifier - class org.hibernate.engine.ForeignKeys.Nullifier.

ForeignKeys.Nullifier(Object, boolean, boolean, SessionImplementor) - Constructor for class org.hibernate.engine.ForeignKeys.Nullifier

Formatter - class org.hibernate.pretty.Formatter.

Formatter(String) - Constructor for class org.hibernate.pretty.Formatter

Formula - class org.hibernate.mapping.Formula.
A formula is a derived column value
Formula() - Constructor for class org.hibernate.mapping.Formula

FromClause - class org.hibernate.hql.ast.tree.FromClause.
Represents the 'FROM' part of a query or subquery, containing all mapped class references.
FromClause() - Constructor for class org.hibernate.hql.ast.tree.FromClause

FromElement - class org.hibernate.hql.ast.tree.FromElement.
Represents a single mapped class mentioned in an HQL FROM clause.
FromElement() - Constructor for class org.hibernate.hql.ast.tree.FromElement

FromParser - class org.hibernate.hql.classic.FromParser.
Parses the from clause of a hibernate query, looking for tables and aliases for the SQL query.
FromParser() - Constructor for class org.hibernate.hql.classic.FromParser

FromPathExpressionParser - class org.hibernate.hql.classic.FromPathExpressionParser.

FromPathExpressionParser() - Constructor for class org.hibernate.hql.classic.FromPathExpressionParser

FromReferenceNode - class org.hibernate.hql.ast.tree.FromReferenceNode.
Represents a reference to a FROM element, for example a class alias in a WHERE clause.
FromReferenceNode() - Constructor for class org.hibernate.hql.ast.tree.FromReferenceNode

FrontBaseDialect - class org.hibernate.dialect.FrontBaseDialect.
An SQL Dialect for Frontbase.
FrontBaseDialect() - Constructor for class org.hibernate.dialect.FrontBaseDialect

factory - Variable in class org.hibernate.context.JTASessionContext

factory - Variable in class org.hibernate.context.ThreadLocalSessionContext.CleanupSynch

factory - Variable in class org.hibernate.context.ThreadLocalSessionContext

factory - Variable in class org.hibernate.impl.AbstractSessionImpl

factory - Variable in class org.hibernate.property.Dom4jAccessor.Dom4jGetter

fatalError(SAXParseException) - Method in class org.hibernate.util.XMLHelper.ErrorLogger

fetch(QueryTranslatorImpl, String) - Method in class org.hibernate.hql.classic.PathExpressionParser

fetchCollection(String) - Method in class org.hibernate.stat.StatisticsImpl

fetchCollection(String) - Method in interface org.hibernate.stat.StatisticsImplementor

fetchEntity(String) - Method in class org.hibernate.stat.StatisticsImpl

fetchEntity(String) - Method in interface org.hibernate.stat.StatisticsImplementor

fieldFilter - Variable in class org.hibernate.bytecode.AbstractClassTransformerImpl

filesets() - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

fillArray(String, int) - Static method in class org.hibernate.util.ArrayHelper

fillArray(int, int) - Static method in class org.hibernate.util.ArrayHelper

fillArray(LockMode, int) - Static method in class org.hibernate.util.ArrayHelper

filter(Object, String) - Method in interface org.hibernate.classic.Session
Deprecated. use Session.createFilter(Object, String).Query.list()
filter(Object, String, Object, Type) - Method in interface org.hibernate.classic.Session
Deprecated. use Session.createFilter(Object, String).setXYZ.Query.list()
filter(Object, String, Object[], Type[]) - Method in interface org.hibernate.classic.Session
Deprecated. use Session.createFilter(Object, String).setXYZ.Query.list()
filter(Object, String) - Method in class org.hibernate.impl.SessionImpl

filter(Object, String, Object, Type) - Method in class org.hibernate.impl.SessionImpl

filter(Object, String, Object[], Type[]) - Method in class org.hibernate.impl.SessionImpl

filterDefinitions - Variable in class org.hibernate.cfg.Configuration

filterDefinitions - Variable in class org.hibernate.cfg.Mappings

filterFragment(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

filterFragment(String, Map) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

filterFragment(String) - Method in class org.hibernate.persister.collection.OneToManyPersister

filterFragment(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

filterFragment(String, Map) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

filterFragment(String, Map) - Method in interface org.hibernate.persister.entity.Joinable
Get the where clause filter, given a query alias and considering enabled session filters
filterFragment(String) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

filterFragment(String) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

filterFragment(String) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

filters(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

finalize() - Method in class org.hibernate.connection.DriverManagerConnectionProvider

find(String) - Method in interface org.hibernate.classic.Session
Deprecated. use Session.createQuery(java.lang.String).Query.list()
find(String, Object, Type) - Method in interface org.hibernate.classic.Session
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.list()
find(String, Object[], Type[]) - Method in interface org.hibernate.classic.Session
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.list()
find(String) - Method in class org.hibernate.impl.SessionImpl
Retrieve a list of persistent objects using a hibernate query
find(String, Object, Type) - Method in class org.hibernate.impl.SessionImpl

find(String, Object[], Type[]) - Method in class org.hibernate.impl.SessionImpl

findAsResource(String) - Static method in class org.hibernate.util.ConfigHelper
Try to locate a local URL representing the incoming path.
findClass(String) - Method in class org.hibernate.bytecode.javassist.TransformingClassLoader

findColumn(String) - Method in class org.hibernate.jdbc.ResultSetWrapper
Overridden version to utilize local caching of the column indexes by name to improve performance for those drivers which are known to not support such caching by themselves.
findDirty(Object, Serializable, Object[], Object[], String[], Type[]) - Method in class org.hibernate.EmptyInterceptor

findDirty(Object, Serializable, Object[], Object[], String[], Type[]) - Method in interface org.hibernate.Interceptor
Called from flush().
findDirty(Object[], Object[], Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Locate the property-indices of all properties considered to be dirty.
findDirty(Object[], Object[], Object, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Compare two snapshots of the state of an instance to determine if the persistent state was modified
findDirty(StandardProperty[], Object[], Object[], boolean[][], boolean, SessionImplementor) - Static method in class org.hibernate.type.TypeFactory
Determine if any of the given field values are dirty, returning an array containing indexes of the dirty fields or null if no fields are dirty.
findFunctionReturnType(String, AST) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Find the function return type given the function name and the first argument expression node.
findModified(Object[], Object[], Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Locate the property-indices of all properties considered to be dirty.
findModified(Object[], Object[], Object, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Compare the state of an instance to the current database state
findModified(StandardProperty[], Object[], Object[], boolean[][], boolean, SessionImplementor) - Static method in class org.hibernate.type.TypeFactory
Determine if any of the given field values are modified, returning an array containing indexes of the dirty fields or null if no fields are dirty.
findPossibleExtends() - Method in class org.hibernate.cfg.Configuration
Find the first possible element in the queue of extends.
findPreviousSibling(AST, AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil
Find the previous sibling in the parent for the given child.
findQueryableUsingImports(String) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Given a (potentially unqualified) class name, locate its persister.
findQueryableUsingImports(SessionFactoryImplementor, String) - Static method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Given a (potentially unqualified) class name, locate its persister.
findSQLFunction(String) - Method in class org.hibernate.dialect.function.SQLFunctionRegistry

findSQLFunction(String) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Locate a registered sql function by name.
findTypeInChildren(AST, int) - Static method in class org.hibernate.hql.ast.util.ASTUtil
Finds the first node of the specified type in the chain of children.
first() - Method in interface org.hibernate.ScrollableResults
Go to the first result
first() - Method in class org.hibernate.collection.PersistentSortedSet

first() - Method in class org.hibernate.impl.FetchingScrollableResultsImpl
Go to the first result
first() - Method in class org.hibernate.impl.ScrollableResultsImpl

first() - Method in class org.hibernate.jdbc.ResultSetWrapper

firstIndexOfChar(String, String, int) - Static method in class org.hibernate.util.StringHelper

firstKey() - Method in class org.hibernate.collection.PersistentSortedMap

flush() - Method in interface org.hibernate.Session
Force the Session to flush.
flush() - Method in interface org.hibernate.engine.SessionImplementor

flush() - Method in class org.hibernate.impl.SessionImpl

flush() - Method in class org.hibernate.impl.StatelessSessionImpl

flush() - Method in class org.hibernate.stat.StatisticsImpl

flush() - Method in interface org.hibernate.stat.StatisticsImplementor

flushBeginning() - Method in class org.hibernate.jdbc.ConnectionManager
Callback to let us know that a flush is beginning.
flushEnding() - Method in class org.hibernate.jdbc.ConnectionManager
Callback to let us know that a flush is ending.
flushEverythingToExecutions(FlushEvent) - Method in class org.hibernate.event.def.AbstractFlushingEventListener
Coordinates the processing necessary to get things ready for executions as db calls by preping the session caches and moving the appropriate entities and collections to their respective execution queues.
forClass(Class) - Static method in class org.hibernate.criterion.DetachedCriteria

forClass(Class, String) - Static method in class org.hibernate.criterion.DetachedCriteria

forEntityName(String) - Static method in class org.hibernate.criterion.DetachedCriteria

forEntityName(String, String) - Static method in class org.hibernate.criterion.DetachedCriteria

forName(String) - Static method in class org.hibernate.criterion.Property

forUpdateOfColumns() - Method in class org.hibernate.dialect.Dialect
Does the FOR UPDATE OF syntax specify particular columns?
forUpdateOfColumns() - Method in class org.hibernate.dialect.MimerSQLDialect
Does the FOR UPDATE OF syntax specify particular columns?
forUpdateOfColumns() - Method in class org.hibernate.dialect.Oracle9Dialect

forUpdateOfColumns() - Method in class org.hibernate.dialect.RDMSOS2200Dialect
The RDMS DB supports the 'FOR UPDATE OF' clause.
forceFlush(EntityEntry) - Method in interface org.hibernate.event.EventSource
Force an immediate flush
forceFlush(EntityEntry) - Method in class org.hibernate.impl.SessionImpl

forceInitialization() - Method in class org.hibernate.collection.AbstractPersistentCollection
To be called internally by the session, forcing immediate initialization.
forceInitialization() - Method in interface org.hibernate.collection.PersistentCollection
To be called internally by the session, forcing immediate initialization.
forceLocked(Object, Object) - Method in class org.hibernate.engine.EntityEntry

forceVersionIncrement(Serializable, Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

forceVersionIncrement(Serializable, Object, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister

foreignKeyColumnName(String, String, String, String) - Method in class org.hibernate.cfg.DefaultNamingStrategy
Return the property name or propertyTableName
foreignKeyColumnName(String, String, String, String) - Method in class org.hibernate.cfg.ImprovedNamingStrategy
Return the property name or propertyTableName
foreignKeyColumnName(String, String, String, String) - Method in interface org.hibernate.cfg.NamingStrategy
Return the foreign key column name for the given parameters
format(int) - Method in class org.hibernate.id.UUIDHexGenerator

format(short) - Method in class org.hibernate.id.UUIDHexGenerator

format() - Method in class org.hibernate.pretty.DDLFormatter
Format an SQL statement using simple rules: a) Insert newline after each comma; b) Indent three spaces after each inserted newline; If the statement contains single/double quotes return unchanged, it is too complex and could be broken by simple formatting.
format() - Method in class org.hibernate.pretty.Formatter

from(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

fromClassOrOuterQueryPath() - Method in class org.hibernate.hql.antlr.HqlBaseParser

fromClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

fromClause(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

fromElement(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

fromElementList(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

fromFragmentSeparator(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

fromFragmentSeparator(AST) - Method in class org.hibernate.hql.ast.SqlGenerator

fromJoin() - Method in class org.hibernate.hql.antlr.HqlBaseParser

fromJoinFragment(String, boolean, boolean) - Method in class org.hibernate.persister.collection.BasicCollectionPersister

fromJoinFragment(String, boolean, boolean) - Method in class org.hibernate.persister.collection.OneToManyPersister

fromJoinFragment(String, boolean, boolean) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

fromJoinFragment(String, boolean, boolean) - Method in interface org.hibernate.persister.entity.Joinable
Get the from clause part of any joins (optional operation)
fromRange() - Method in class org.hibernate.hql.antlr.HqlBaseParser

fromStringValue(String) - Method in class org.hibernate.type.AbstractBynaryType

fromStringValue(String) - Method in class org.hibernate.type.AbstractCharArrayType

fromStringValue(String) - Method in class org.hibernate.type.AdaptedImmutableType

fromStringValue(String) - Method in class org.hibernate.type.BigDecimalType

fromStringValue(String) - Method in class org.hibernate.type.BigIntegerType

fromStringValue(String) - Method in class org.hibernate.type.BooleanType

fromStringValue(String) - Method in class org.hibernate.type.ByteType

fromStringValue(String) - Method in class org.hibernate.type.CalendarDateType

fromStringValue(String) - Method in class org.hibernate.type.CalendarType

fromStringValue(String) - Method in class org.hibernate.type.CharacterType

fromStringValue(String) - Method in class org.hibernate.type.ClassType

fromStringValue(String) - Method in class org.hibernate.type.CurrencyType

fromStringValue(String) - Method in class org.hibernate.type.DateType

fromStringValue(String) - Method in class org.hibernate.type.DoubleType

fromStringValue(String) - Method in class org.hibernate.type.FloatType

fromStringValue(String) - Method in class org.hibernate.type.IntegerType

fromStringValue(String) - Method in class org.hibernate.type.LocaleType

fromStringValue(String) - Method in class org.hibernate.type.LongType

fromStringValue(String) - Method in class org.hibernate.type.NullableType

fromStringValue(String) - Method in class org.hibernate.type.SerializableType

fromStringValue(String) - Method in class org.hibernate.type.ShortType

fromStringValue(String) - Method in class org.hibernate.type.StringType

fromStringValue(String) - Method in class org.hibernate.type.TextType

fromStringValue(String) - Method in class org.hibernate.type.TimeType

fromStringValue(String) - Method in class org.hibernate.type.TimeZoneType

fromStringValue(String) - Method in class org.hibernate.type.TimestampType

fromTable(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

fromTableFragment(String) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

fromTableFragment(String) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
Get the main from table fragment, given a query alias.
fromTableFragment(String) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

fromTableFragment(String) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

fromXMLNode(Node, Mapping) - Method in class org.hibernate.type.AnyType

fromXMLNode(Node, Mapping) - Method in class org.hibernate.type.BlobType

fromXMLNode(Node, Mapping) - Method in class org.hibernate.type.ClobType

fromXMLNode(Node, Mapping) - Method in class org.hibernate.type.CollectionType

fromXMLNode(Node, Mapping) - Method in class org.hibernate.type.ComponentType

fromXMLNode(Node, Mapping) - Method in class org.hibernate.type.CompositeCustomType

fromXMLNode(Node, Mapping) - Method in class org.hibernate.type.CustomType

fromXMLNode(Node, Mapping) - Method in class org.hibernate.type.EntityType

fromXMLNode(Node, Mapping) - Method in class org.hibernate.type.MetaType

fromXMLNode(Node, Mapping) - Method in class org.hibernate.type.NullableType

fromXMLNode(Node, Mapping) - Method in interface org.hibernate.type.Type
Parse the XML representation of an instance.
fromXMLString(String, Mapping) - Method in class org.hibernate.type.CustomType

fromXMLString(String, Mapping) - Method in class org.hibernate.type.MetaType

fromXMLString(String, Mapping) - Method in class org.hibernate.type.NullableType

fromXMLString(String) - Method in interface org.hibernate.usertype.EnhancedUserType
Parse a string representation of this value, as it appears in an XML document
functionCall(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

G

GE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

GE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

GE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

GENERATE_STATISTICS - Static variable in class org.hibernate.cfg.Environment
Enable statistics collection
GET - Static variable in class org.hibernate.CacheMode
The session may read items from the cache, but will not add items, except to invalidate items when updates occur
GET - Static variable in interface org.hibernate.event.LoadEventListener

GONE - Static variable in class org.hibernate.engine.Status

GROUP - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

GROUP - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

GROUP - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

GT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

GT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

GT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

GUIDGenerator - class org.hibernate.id.GUIDGenerator.
Generates string values using the SQL Server NEWID() function.
GUIDGenerator() - Constructor for class org.hibernate.id.GUIDGenerator

GeneratedCollectionAliases - class org.hibernate.loader.GeneratedCollectionAliases.
CollectionAliases which handles the logic of selecting user provided aliases (via return-property), before using the default aliases.
GeneratedCollectionAliases(Map, CollectionPersister, String) - Constructor for class org.hibernate.loader.GeneratedCollectionAliases

GeneratedCollectionAliases(CollectionPersister, String) - Constructor for class org.hibernate.loader.GeneratedCollectionAliases

GenericJDBCException - exception org.hibernate.exception.GenericJDBCException.
Generic, non-specific JDBCException.
GenericJDBCException(String, SQLException) - Constructor for class org.hibernate.exception.GenericJDBCException

GenericJDBCException(String, SQLException, String) - Constructor for class org.hibernate.exception.GenericJDBCException

GetGeneratedKeysHelper - class org.hibernate.util.GetGeneratedKeysHelper.

Getter - interface org.hibernate.property.Getter.
Gets values of a particular property
GroupByParser - class org.hibernate.hql.classic.GroupByParser.
Parses the GROUP BY clause of an aggregate query
GroupByParser() - Constructor for class org.hibernate.hql.classic.GroupByParser

ge(Object) - Method in class org.hibernate.criterion.Property

ge(DetachedCriteria) - Method in class org.hibernate.criterion.Property

ge(String, Object) - Static method in class org.hibernate.criterion.Restrictions
Apply a "greater than or equal" constraint to the named property
ge(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

geAll(DetachedCriteria) - Method in class org.hibernate.criterion.Property

geAll(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

geProperty(Property) - Method in class org.hibernate.criterion.Property

geProperty(String) - Method in class org.hibernate.criterion.Property

geProperty(String, String) - Static method in class org.hibernate.criterion.Restrictions
Apply a "greater than or equal" constraint to two properties
geSome(DetachedCriteria) - Method in class org.hibernate.criterion.Property

geSome(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

generate(SessionImplementor, Object) - Method in class org.hibernate.id.AbstractPostInsertGenerator

generate(SessionImplementor, Object) - Method in class org.hibernate.id.Assigned

generate(SessionImplementor, Object) - Method in class org.hibernate.id.ForeignGenerator

generate(SessionImplementor, Object) - Method in class org.hibernate.id.GUIDGenerator

generate(SessionImplementor, Object) - Method in interface org.hibernate.id.IdentifierGenerator
Generate a new identifier.
generate(SessionImplementor, Object) - Method in class org.hibernate.id.IncrementGenerator

generate(SessionImplementor, Object) - Method in class org.hibernate.id.MultipleHiLoPerTableGenerator

generate(SessionImplementor, Object) - Method in class org.hibernate.id.SequenceGenerator

generate(SessionImplementor, Object) - Method in class org.hibernate.id.SequenceHiLoGenerator

generate(SessionImplementor, Object) - Method in class org.hibernate.id.SequenceIdentityGenerator

generate(SessionImplementor, Object) - Method in class org.hibernate.id.TableGenerator

generate(SessionImplementor, Object) - Method in class org.hibernate.id.TableHiLoGenerator

generate(SessionImplementor, Object) - Method in class org.hibernate.id.UUIDHexGenerator

generateAlias(String) - Static method in class org.hibernate.util.StringHelper

generateAlias(String, int) - Static method in class org.hibernate.util.StringHelper
Generate a nice alias for the given class name or collection role name and unique integer.
generateColumnNames(Type[], SessionFactoryImplementor) - Static method in class org.hibernate.hql.NameGenerator

generateColumnNames(Type[]) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper

generateCustomReturns(boolean) - Method in class org.hibernate.loader.custom.sql.SQLQueryReturnProcessor

generateDeleteRowString() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

generateDeleteRowString() - Method in class org.hibernate.persister.collection.BasicCollectionPersister
Generate the SQL DELETE that deletes a particular row
generateDeleteRowString() - Method in class org.hibernate.persister.collection.OneToManyPersister
Generate the SQL UPDATE that updates a particular row's foreign key to null
generateDeleteString() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

generateDeleteString() - Method in class org.hibernate.persister.collection.BasicCollectionPersister
Generate the SQL DELETE that deletes all rows
generateDeleteString() - Method in class org.hibernate.persister.collection.OneToManyPersister
Generate the SQL UPDATE that updates all the foreign keys to null
generateDeleteString(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Generate the SQL that deletes a row by id (and version)
generateDetectRowByElementString() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

generateDetectRowByIndexString() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

generateDom4jElement(String) - Static method in class org.hibernate.util.XMLHelper

generateDropSchemaScript(Dialect) - Method in class org.hibernate.cfg.Configuration
Generate DDL for dropping tables
generateFilterConditionAlias(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

generateFilterConditionAlias(String) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

generateFilterConditionAlias(String) - Method in interface org.hibernate.persister.entity.Queryable
The alias used for any filter conditions (mapped where-fragments or enabled-filters).
generateHashCode() - Method in class org.hibernate.engine.CollectionKey

generateHashCode(SessionFactoryImplementor) - Method in class org.hibernate.engine.EntityUniqueKey

generateIdInsertSelect(Queryable, String, AST) - Method in class org.hibernate.hql.ast.exec.AbstractStatementExecutor

generateIdSubselect(Queryable) - Method in class org.hibernate.hql.ast.exec.AbstractStatementExecutor

generateIdentityInsertString(boolean[]) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Used to generate an insery statement against the root table in the case of identifier generation strategies where the insert statement executions actually generates the identifier value.
generateInsertGeneratedValuesSelectString() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

generateInsertRowString() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

generateInsertRowString() - Method in class org.hibernate.persister.collection.BasicCollectionPersister
Generate the SQL INSERT that creates a new row
generateInsertRowString() - Method in class org.hibernate.persister.collection.OneToManyPersister
Generate the SQL UPDATE that updates a foreign key to a value
generateInsertString(boolean[], int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

generateInsertString(boolean, boolean[]) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

generateInsertString(boolean, boolean[], int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Generate the SQL that inserts a row
generateLazySelectString() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

generateLockString() - Method in class org.hibernate.dialect.lock.SelectLockingStrategy

generateLockString() - Method in class org.hibernate.dialect.lock.UpdateLockingStrategy

generateLocker(LockMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

generateMap() - Method in class org.hibernate.tuple.DynamicMapInstantiator

generateNamedParameter(AST, AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

generateNamedParameter(AST, AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

generatePositionalParameter(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

generatePositionalParameter(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

generateProxy(ConnectionManager) - Static method in class org.hibernate.jdbc.BorrowedConnectionProxy

generateRootAlias(String) - Method in class org.hibernate.loader.JoinWalker

generateRootAlias(String) - Method in class org.hibernate.loader.criteria.CriteriaJoinWalker

generateSQLAlias() - Method in interface org.hibernate.criterion.CriteriaQuery

generateSQLAlias() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

generateScalarColumns(HqlSqlWalkerNode, String[], int) - Static method in class org.hibernate.hql.ast.util.ColumnHelper
Generates the scalar column AST nodes for a given array of SQL columns
generateSchemaCreationScript(Dialect) - Method in class org.hibernate.cfg.Configuration
Generate DDL for creating tables
generateSchemaUpdateScript(Dialect, DatabaseMetadata) - Method in class org.hibernate.cfg.Configuration
Generate DDL for altering tables
generateSelectFragment(String, String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

generateSelectRowByIndexString() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

generateSelectSizeString(boolean) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

generateSelectString(LockMode) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister
Generate the SQL that selects a row by id
generateSelectVersionString() - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Generate the SQL that selects the version number by id
generateSingleScalarColumn(HqlSqlWalkerNode, int) - Static method in class org.hibernate.hql.ast.util.ColumnHelper

generateSnapshotSelectString() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

generateSubquery(PersistentClass, Mapping) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

generateSuffixes(int) - Static method in class org.hibernate.loader.BasicLoader
Utility method that generates 0_, 1_ suffixes.
generateSuffixes(int, int) - Static method in class org.hibernate.loader.BasicLoader

generateTableAlias(int, String, Joinable) - Method in class org.hibernate.loader.JoinWalker

generateTableAlias(int, String, Joinable) - Method in class org.hibernate.loader.criteria.CriteriaJoinWalker

generateTableAlias(String, int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

generateTemporaryTableName(String) - Method in class org.hibernate.dialect.DB2Dialect

generateTemporaryTableName(String) - Method in class org.hibernate.dialect.Dialect

generateTemporaryTableName(String) - Method in class org.hibernate.dialect.Oracle9Dialect

generateTemporaryTableName(String) - Method in class org.hibernate.dialect.SAPDBDialect

generateTemporaryTableName(String) - Method in class org.hibernate.dialect.SybaseDialect

generateTemporaryTableName(String) - Method in class org.hibernate.dialect.TimesTenDialect

generateUpdateGeneratedValuesSelectString() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

generateUpdateRowString() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

generateUpdateRowString() - Method in class org.hibernate.persister.collection.BasicCollectionPersister
Generate the SQL UPDATE that updates a row
generateUpdateRowString() - Method in class org.hibernate.persister.collection.OneToManyPersister
Not needed for one-to-many association
generateUpdateString(boolean[], int, boolean) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

generateUpdateString(boolean[], int, Object[], boolean) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Generate the SQL that updates a row by id (and version)
generatorKey() - Method in class org.hibernate.id.MultipleHiLoPerTableGenerator

generatorKey() - Method in interface org.hibernate.id.PersistentIdentifierGenerator
Return a key unique to the underlying database objects.
generatorKey() - Method in class org.hibernate.id.SequenceGenerator

generatorKey() - Method in class org.hibernate.id.TableGenerator

get() - Method in interface org.hibernate.ScrollableResults
Get the current row of results
get(int) - Method in interface org.hibernate.ScrollableResults
Get the ith object in the current row of results, without initializing any other results in the row.
get(Class, Serializable) - Method in interface org.hibernate.Session
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
get(Class, Serializable, LockMode) - Method in interface org.hibernate.Session
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
get(String, Serializable) - Method in interface org.hibernate.Session
Return the persistent instance of the given named entity with the given identifier, or null if there is no such persistent instance.
get(String, Serializable, LockMode) - Method in interface org.hibernate.Session
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
get(String, Serializable) - Method in interface org.hibernate.StatelessSession
Retrieve a row.
get(Class, Serializable) - Method in interface org.hibernate.StatelessSession
Retrieve a row.
get(String, Serializable, LockMode) - Method in interface org.hibernate.StatelessSession
Retrieve a row, obtaining the specified lock mode.
get(Class, Serializable, LockMode) - Method in interface org.hibernate.StatelessSession
Retrieve a row, obtaining the specified lock mode.
get(Object) - Method in interface org.hibernate.cache.Cache
Get an item from the cache, nontransactionally
get(Object, long) - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Attempt to retrieve an object from the cache.
get(Object) - Method in class org.hibernate.cache.EhCache
Gets a value of an element which matches the given key.
get(Object) - Method in class org.hibernate.cache.HashtableCache

get(Object, long) - Method in class org.hibernate.cache.NonstrictReadWriteCache
Get the most recent version, if available.
get(Object) - Method in class org.hibernate.cache.OSCache

get(Object) - Method in class org.hibernate.cache.OptimisticTreeCache

get(QueryKey, Type[], boolean, Set, SessionImplementor) - Method in interface org.hibernate.cache.QueryCache

get(Object, long) - Method in class org.hibernate.cache.ReadOnlyCache

get(Object, long) - Method in class org.hibernate.cache.ReadWriteCache
Do not return an item whose timestamp is later than the current transaction timestamp.
get(QueryKey, Type[], boolean, Set, SessionImplementor) - Method in class org.hibernate.cache.StandardQueryCache

get(Object) - Method in class org.hibernate.cache.SwarmCache
Get an item from the cache
get(Object, long) - Method in class org.hibernate.cache.TransactionalCache

get(Object) - Method in class org.hibernate.cache.TreeCache

get(int) - Method in class org.hibernate.collection.PersistentBag

get(int) - Method in class org.hibernate.collection.PersistentIdentifierBag

get(int) - Method in class org.hibernate.collection.PersistentList

get(Object) - Method in class org.hibernate.collection.PersistentMap

get(int) - Method in class org.hibernate.dialect.TypeNames
get default type name for specified type
get(int, int, int, int) - Method in class org.hibernate.dialect.TypeNames
get type name for specified type and size
get(ResultSet, Type) - Static method in class org.hibernate.id.IdentifierGeneratorFactory

get() - Method in class org.hibernate.impl.AbstractScrollableResults

get(int) - Method in class org.hibernate.impl.AbstractScrollableResults

get(Class, Serializable) - Method in class org.hibernate.impl.SessionImpl

get(String, Serializable) - Method in class org.hibernate.impl.SessionImpl

get(Class, Serializable, LockMode) - Method in class org.hibernate.impl.SessionImpl

get(String, Serializable, LockMode) - Method in class org.hibernate.impl.SessionImpl

get(Class, Serializable) - Method in class org.hibernate.impl.StatelessSessionImpl

get(Class, Serializable, LockMode) - Method in class org.hibernate.impl.StatelessSessionImpl

get(String, Serializable) - Method in class org.hibernate.impl.StatelessSessionImpl

get(String, Serializable, LockMode) - Method in class org.hibernate.impl.StatelessSessionImpl

get(Object) - Method in class org.hibernate.property.BackrefPropertyAccessor.BackrefGetter

get(Object) - Method in class org.hibernate.property.BasicPropertyAccessor.BasicGetter

get(Object) - Method in class org.hibernate.property.DirectPropertyAccessor.DirectGetter

get(Object) - Method in class org.hibernate.property.Dom4jAccessor.AttributeGetter

get(Object) - Method in class org.hibernate.property.Dom4jAccessor.ElementAttributeGetter

get(Object) - Method in class org.hibernate.property.Dom4jAccessor.ElementGetter

get(Object) - Method in class org.hibernate.property.Dom4jAccessor.TextGetter

get(Object) - Method in class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter

get(Object) - Method in interface org.hibernate.property.Getter
Get the property value from the given instance .
get(Object) - Method in class org.hibernate.property.IndexPropertyAccessor.IndexGetter

get(Object) - Method in class org.hibernate.property.MapAccessor.MapGetter

get(Object) - Method in class org.hibernate.proxy.map.MapProxy

get(ResultSet, String) - Method in class org.hibernate.type.AbstractBynaryType

get(ResultSet, String) - Method in class org.hibernate.type.AbstractCharArrayType

get(ResultSet, String) - Method in class org.hibernate.type.AdaptedImmutableType

get(ResultSet, String) - Method in class org.hibernate.type.BigDecimalType

get(ResultSet, String) - Method in class org.hibernate.type.BigIntegerType

get(ResultSet, String) - Method in class org.hibernate.type.BlobType

get(ResultSet, String) - Method in class org.hibernate.type.BooleanType

get(ResultSet, String) - Method in class org.hibernate.type.ByteType

get(ResultSet, String) - Method in class org.hibernate.type.CalendarDateType

get(ResultSet, String) - Method in class org.hibernate.type.CalendarType

get(ResultSet, String) - Method in class org.hibernate.type.CharBooleanType

get(ResultSet, String) - Method in class org.hibernate.type.CharacterType

get(ResultSet, String) - Method in class org.hibernate.type.ClassType

get(ResultSet, String) - Method in class org.hibernate.type.ClobType

get(ResultSet, String) - Method in class org.hibernate.type.CurrencyType

get(ResultSet, String) - Method in class org.hibernate.type.DateType

get(ResultSet, String) - Method in class org.hibernate.type.DoubleType

get(ResultSet, String) - Method in class org.hibernate.type.FloatType

get(ResultSet, String) - Method in class org.hibernate.type.IntegerType

get(ResultSet, String) - Method in class org.hibernate.type.LocaleType

get(ResultSet, String) - Method in class org.hibernate.type.LongType

get(ResultSet, String) - Method in class org.hibernate.type.NullableType
Get a column value from a result set, without worrying about the possibility of null values
get(ResultSet, String) - Method in class org.hibernate.type.SerializableType

get(ResultSet, String) - Method in class org.hibernate.type.ShortType

get(ResultSet, String) - Method in class org.hibernate.type.StringType

get(ResultSet, String) - Method in class org.hibernate.type.TextType

get(ResultSet, String) - Method in class org.hibernate.type.TimeType

get(ResultSet, String) - Method in class org.hibernate.type.TimeZoneType

get(ResultSet, String) - Method in class org.hibernate.type.TimestampType

get(Object) - Method in class org.hibernate.util.FastHashMap
Return the value to which this map maps the specified key.
get(Object) - Method in class org.hibernate.util.IdentityMap

get(Object) - Method in class org.hibernate.util.SimpleMRUCache

get(Object) - Method in class org.hibernate.util.SoftLimitMRUCache

getASTFactory() - Method in class org.hibernate.hql.ast.tree.HqlSqlWalkerNode

getASTNodeType(int) - Method in class org.hibernate.hql.ast.HqlASTFactory
Returns the class for a given token type (a.k.a.
getASTNodeType(int) - Method in class org.hibernate.hql.ast.SqlASTFactory
Returns the class for a given token type (a.k.a.
getASTPrinter() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getAccessOptimizer() - Method in interface org.hibernate.bytecode.ReflectionOptimizer

getAccessOptimizer() - Method in class org.hibernate.bytecode.cglib.ReflectionOptimizerImpl

getAccessOptimizer() - Method in class org.hibernate.bytecode.javassist.ReflectionOptimizerImpl

getAccessorPropertyName(EntityMode) - Method in class org.hibernate.mapping.Property

getActionQueue() - Method in interface org.hibernate.event.EventSource
Get the ActionQueue for this session
getActionQueue() - Method in class org.hibernate.impl.SessionImpl

getActions() - Method in class org.hibernate.secure.HibernatePermission

getActualRowCount() - Method in class org.hibernate.jdbc.TooManyRowsAffectedException

getAddColumnString() - Method in class org.hibernate.dialect.DB2Dialect

getAddColumnString() - Method in class org.hibernate.dialect.Dialect
The syntax used to add a column to a table (optional).
getAddColumnString() - Method in class org.hibernate.dialect.FrontBaseDialect

getAddColumnString() - Method in class org.hibernate.dialect.H2Dialect

getAddColumnString() - Method in class org.hibernate.dialect.HSQLDialect

getAddColumnString() - Method in class org.hibernate.dialect.InformixDialect

getAddColumnString() - Method in class org.hibernate.dialect.IngresDialect
The syntax used to add a column to a table (optional).
getAddColumnString() - Method in class org.hibernate.dialect.InterbaseDialect

getAddColumnString() - Method in class org.hibernate.dialect.JDataStoreDialect

getAddColumnString() - Method in class org.hibernate.dialect.MckoiDialect

getAddColumnString() - Method in class org.hibernate.dialect.MimerSQLDialect
The syntax used to add a column to a table
getAddColumnString() - Method in class org.hibernate.dialect.MySQLDialect

getAddColumnString() - Method in class org.hibernate.dialect.Oracle9Dialect

getAddColumnString() - Method in class org.hibernate.dialect.PointbaseDialect

getAddColumnString() - Method in class org.hibernate.dialect.PostgreSQLDialect

getAddColumnString() - Method in class org.hibernate.dialect.ProgressDialect

getAddColumnString() - Method in class org.hibernate.dialect.RDMSOS2200Dialect

getAddColumnString() - Method in class org.hibernate.dialect.SAPDBDialect

getAddColumnString() - Method in class org.hibernate.dialect.SybaseDialect

getAddColumnString() - Method in class org.hibernate.dialect.TimesTenDialect

getAddForeignKeyConstraintString(String, String[], String, String[], boolean) - Method in class org.hibernate.dialect.Dialect
The syntax used to add a foreign key constraint to a table.
getAddForeignKeyConstraintString(String, String[], String, String[], boolean) - Method in class org.hibernate.dialect.InformixDialect
The syntax used to add a foreign key constraint to a table.
getAddForeignKeyConstraintString(String, String[], String, String[], boolean) - Method in class org.hibernate.dialect.MySQLDialect

getAddForeignKeyConstraintString(String, String[], String, String[], boolean) - Method in class org.hibernate.dialect.SAPDBDialect

getAddPrimaryKeyConstraintString(String) - Method in class org.hibernate.dialect.Dialect
The syntax used to add a primary key constraint to a table.
getAddPrimaryKeyConstraintString(String) - Method in class org.hibernate.dialect.InformixDialect
The syntax used to add a primary key constraint to a table.
getAddPrimaryKeyConstraintString(String) - Method in class org.hibernate.dialect.SAPDBDialect

getAddedInstance() - Method in interface org.hibernate.collection.AbstractPersistentCollection.DelayedOperation

getAffectedQueryable() - Method in class org.hibernate.hql.ast.exec.MultiTableUpdateExecutor

getAffectedQueryables() - Method in class org.hibernate.hql.ast.exec.AbstractStatementExecutor

getAffectedQueryables() - Method in class org.hibernate.hql.ast.exec.BasicExecutor

getAffectedQueryables() - Method in class org.hibernate.hql.ast.exec.MultiTableDeleteExecutor

getAffectedQueryables() - Method in class org.hibernate.hql.ast.exec.MultiTableUpdateExecutor

getAlias() - Method in interface org.hibernate.Criteria
Get the alias of the entity encapsulated by this criteria instance.
getAlias() - Method in class org.hibernate.criterion.DetachedCriteria

getAlias() - Method in class org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn
Retrieve the defined result alias
getAlias() - Method in class org.hibernate.hql.ast.tree.AbstractSelectExpression

getAlias() - Method in class org.hibernate.hql.ast.tree.ConstructorNode

getAlias() - Method in class org.hibernate.hql.ast.tree.QueryNode

getAlias() - Method in interface org.hibernate.hql.ast.tree.SelectExpression

getAlias(String) - Static method in class org.hibernate.hql.ast.util.PathHelper

getAlias() - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

getAlias() - Method in class org.hibernate.impl.CriteriaImpl

getAlias() - Method in class org.hibernate.loader.AbstractEntityJoinWalker

getAlias() - Method in class org.hibernate.loader.custom.NonScalarReturn

getAlias(Dialect) - Method in class org.hibernate.mapping.Column
For any column name, generate an alias that is unique to that column name, and also 10 characters or less in length.
getAlias(Dialect, Table) - Method in class org.hibernate.mapping.Column
Generate a column alias that is unique across multiple tables
getAlias(Dialect) - Method in class org.hibernate.mapping.Formula

getAlias(Dialect, Table) - Method in class org.hibernate.mapping.Formula

getAlias(Dialect) - Method in interface org.hibernate.mapping.Selectable

getAlias(Dialect, Table) - Method in interface org.hibernate.mapping.Selectable

getAliasGenerator() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getAliasGenerator() - Method in class org.hibernate.hql.ast.tree.HqlSqlWalkerNode

getAliasName(String) - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getAliasedLHSColumnNames(AssociationType, String, int, OuterJoinLoadable, Mapping) - Static method in class org.hibernate.engine.JoinHelper
Get the aliased columns of the owning entity which are to be used in the join
getAliasedLHSColumnNames(AssociationType, String, int, int, OuterJoinLoadable, Mapping) - Static method in class org.hibernate.engine.JoinHelper
Get the aliased columns of the owning entity which are to be used in the join
getAliases() - Method in class org.hibernate.criterion.AliasedProjection

getAliases() - Method in class org.hibernate.criterion.Distinct

getAliases() - Method in interface org.hibernate.criterion.Projection
Get the user-visible aliases for this projection (ie.
getAliases() - Method in class org.hibernate.criterion.ProjectionList

getAliases() - Method in class org.hibernate.criterion.SQLProjection

getAliases() - Method in class org.hibernate.criterion.SimpleProjection

getAliases() - Method in class org.hibernate.hql.ast.tree.ConstructorNode

getAliases() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getAliases() - Method in class org.hibernate.loader.JoinWalker

getAliases() - Method in class org.hibernate.loader.Loader
Get the SQL table aliases of entities whose associations are subselect-loadable, returning null if this loader does not support subselect loading
getAliases() - Method in class org.hibernate.loader.OuterJoinLoader

getAliases() - Method in class org.hibernate.loader.hql.QueryLoader

getAllClassMetadata() - Method in interface org.hibernate.SessionFactory
Get all ClassMetadata as a Map from entityname String to metadata object
getAllClassMetadata() - Method in class org.hibernate.impl.SessionFactoryImpl

getAllClassMetadata() - Method in class org.hibernate.jmx.SessionFactoryStub

getAllCollectionMetadata() - Method in interface org.hibernate.SessionFactory
Get all CollectionMetadata as a Map from role name to metadata object
getAllCollectionMetadata() - Method in class org.hibernate.impl.SessionFactoryImpl

getAllCollectionMetadata() - Method in class org.hibernate.jmx.SessionFactoryStub

getAllSecondLevelCacheRegions() - Method in interface org.hibernate.engine.SessionFactoryImplementor

getAllSecondLevelCacheRegions() - Method in class org.hibernate.impl.SessionFactoryImpl

getAnything() - Method in class org.hibernate.event.def.AbstractFlushingEventListener

getAppropriateInitializer(Serializable, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getArray() - Method in class org.hibernate.collection.PersistentArrayHolder

getArray(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getArray(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getAsciiStream(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getAsciiStream(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getAsciiStream() - Method in class org.hibernate.lob.ClobImpl

getAsciiStream() - Method in class org.hibernate.lob.SerializableClob

getAssignmentSpecifications() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getAssociatedClass() - Method in class org.hibernate.mapping.OneToMany

getAssociatedEntityName(CollectionType) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Given a collection type, determine the entity name of the elements contained within instance of that collection.
getAssociatedEntityName(SessionFactoryImplementor) - Method in class org.hibernate.type.AnyType

getAssociatedEntityName(SessionFactoryImplementor) - Method in interface org.hibernate.type.AssociationType
Get the entity name of the associated entity
getAssociatedEntityName(SessionFactoryImplementor) - Method in class org.hibernate.type.CollectionType

getAssociatedEntityName() - Method in class org.hibernate.type.EntityType

getAssociatedEntityName(SessionFactoryImplementor) - Method in class org.hibernate.type.EntityType

getAssociatedJoinable(SessionFactoryImplementor) - Method in class org.hibernate.type.AnyType

getAssociatedJoinable(SessionFactoryImplementor) - Method in interface org.hibernate.type.AssociationType
Get the "persister" for this association - a class or collection persister
getAssociatedJoinable(SessionFactoryImplementor) - Method in class org.hibernate.type.CollectionType

getAssociatedJoinable(SessionFactoryImplementor) - Method in class org.hibernate.type.EntityType

getAssumedUnsaved() - Method in class org.hibernate.event.def.AbstractSaveEventListener

getAssumedUnsaved() - Method in class org.hibernate.event.def.DefaultMergeEventListener

getAssumedUnsaved() - Method in class org.hibernate.event.def.DefaultPersistEventListener

getAutoCloseSessionEnabled() - Method in class org.hibernate.jmx.HibernateService

getAutoCloseSessionEnabled() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Is automatic Session closing enabled?
getAutoFlushEventListeners() - Method in class org.hibernate.event.EventListeners

getBaseIndex() - Method in class org.hibernate.mapping.List

getBatchFetchQueue() - Method in interface org.hibernate.engine.PersistenceContext
Get the BatchFetchQueue, instantiating one if necessary.
getBatchFetchQueue() - Method in class org.hibernate.engine.StatefulPersistenceContext
Get the BatchFetchQueue, instantiating one if necessary.
getBatchPosition() - Method in class org.hibernate.jdbc.BatchedTooManyRowsAffectedException

getBatchSize() - Method in class org.hibernate.mapping.Collection

getBatchSize() - Method in class org.hibernate.mapping.PersistentClass

getBatchSizes(int) - Static method in class org.hibernate.util.ArrayHelper

getBatchVersionedDataEnabled() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Is JDBC batch update for versioned entities enabled?
getBatchVersionedDataEnabled() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getBatcher() - Method in interface org.hibernate.engine.SessionImplementor
Get the prepared statement Batcher for this session
getBatcher() - Method in class org.hibernate.impl.SessionImpl

getBatcher() - Method in class org.hibernate.impl.StatelessSessionImpl

getBatcher() - Method in class org.hibernate.jdbc.ConnectionManager
The batcher managed by this ConnectionManager.
getBatcherFactory() - Method in class org.hibernate.cfg.Settings

getBatcherFactory() - Method in class org.hibernate.impl.SessionFactoryImpl

getBigDecimal(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a big_decimal
getBigDecimal(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getBigDecimal(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBigDecimal(String, int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBigDecimal(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBigDecimal(int, int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBigInteger(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a big_integer
getBigInteger(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getBinary(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a binary
getBinary(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getBinaryStream(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBinaryStream(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBinaryStream() - Method in class org.hibernate.lob.BlobImpl

getBinaryStream() - Method in class org.hibernate.lob.SerializableBlob

getBlob(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a blob
getBlob(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getBlob(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBlob(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBoolean(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a boolean
getBoolean(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getBoolean(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBoolean(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBoolean(String, Properties) - Static method in class org.hibernate.util.PropertiesHelper

getBoolean(String, Properties, boolean) - Static method in class org.hibernate.util.PropertiesHelper

getByte(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a byte
getByte(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getByte(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getByte(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBytecodeProvider() - Static method in class org.hibernate.cfg.Environment

getBytes() - Method in interface org.hibernate.bytecode.util.ClassDescriptor
The bytes making up the class' bytecode.
getBytes(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBytes(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getBytes(long, int) - Method in class org.hibernate.lob.BlobImpl

getBytes(long, int) - Method in class org.hibernate.lob.SerializableBlob

getCache() - Method in class org.hibernate.cache.AbstractJndiBoundCacheProvider

getCache() - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Get the wrapped cache implementation
getCache() - Method in class org.hibernate.cache.NonstrictReadWriteCache

getCache() - Method in interface org.hibernate.cache.QueryCache

getCache() - Method in class org.hibernate.cache.ReadOnlyCache

getCache() - Method in class org.hibernate.cache.ReadWriteCache

getCache() - Method in class org.hibernate.cache.StandardQueryCache

getCache() - Method in class org.hibernate.cache.TransactionalCache

getCache() - Method in class org.hibernate.cache.UpdateTimestampsCache

getCache() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getCache() - Method in interface org.hibernate.persister.collection.CollectionPersister
Get the cache
getCache() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getCache() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the cache (optional operation)
getCacheConcurrencyStrategy() - Method in class org.hibernate.mapping.Collection

getCacheConcurrencyStrategy() - Method in class org.hibernate.mapping.PersistentClass

getCacheConcurrencyStrategy() - Method in class org.hibernate.mapping.RootClass

getCacheConcurrencyStrategy() - Method in class org.hibernate.mapping.Subclass

getCacheEntryStructure() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getCacheEntryStructure() - Method in interface org.hibernate.persister.collection.CollectionPersister
Get the cache structure
getCacheEntryStructure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getCacheEntryStructure() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the cache structure
getCacheHitCount() - Method in class org.hibernate.stat.QueryStatistics
Queries retrieved successfully from the cache
getCacheMissCount() - Method in class org.hibernate.stat.QueryStatistics

getCacheMode() - Method in interface org.hibernate.Session
Get the current cache mode.
getCacheMode(String) - Static method in class org.hibernate.cfg.HbmBinder

getCacheMode() - Method in class org.hibernate.engine.NamedQueryDefinition

getCacheMode() - Method in interface org.hibernate.engine.SessionImplementor

getCacheMode() - Method in class org.hibernate.impl.SessionImpl

getCacheMode() - Method in class org.hibernate.impl.StatelessSessionImpl

getCacheProvider() - Method in class org.hibernate.cfg.Settings

getCacheProviderClass() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Get the second-level cache provider class name
getCacheProviderClass() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getCachePutCount() - Method in class org.hibernate.stat.QueryStatistics

getCacheRegion() - Method in class org.hibernate.engine.NamedQueryDefinition

getCacheRegion() - Method in class org.hibernate.engine.QueryParameters

getCacheRegion() - Method in class org.hibernate.impl.CriteriaImpl

getCacheRegionName() - Method in class org.hibernate.mapping.Collection

getCacheRegionName() - Method in class org.hibernate.mapping.RootClass

getCacheRegionPrefix() - Method in class org.hibernate.cfg.Settings

getCacheRegionPrefix() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Get the cache region prefix
getCacheRegionPrefix() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getCacheable() - Method in class org.hibernate.impl.CriteriaImpl

getCachedDatabaseSnapshot(EntityKey) - Method in interface org.hibernate.engine.PersistenceContext

getCachedDatabaseSnapshot(EntityKey) - Method in class org.hibernate.engine.StatefulPersistenceContext

getCachedSize() - Method in class org.hibernate.collection.AbstractPersistentCollection

getCalendar(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a calendar or calendar_date
getCalendar(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getCanonicalName() - Method in class org.hibernate.mapping.Column

getCascadableChildrenIterator(EventSource, CollectionType, Object) - Method in class org.hibernate.engine.CascadingAction
Given a collection, get an iterator of the children upon which the current cascading action should be visited.
getCascade() - Method in class org.hibernate.mapping.Property

getCascadeAction() - Method in class org.hibernate.event.def.AbstractSaveEventListener

getCascadeAction() - Method in class org.hibernate.event.def.DefaultMergeEventListener

getCascadeAction() - Method in class org.hibernate.event.def.DefaultPersistEventListener

getCascadeAction() - Method in class org.hibernate.event.def.DefaultPersistOnFlushEventListener

getCascadeAction() - Method in class org.hibernate.event.def.DefaultReplicateEventListener

getCascadeAction() - Method in class org.hibernate.event.def.DefaultSaveOrUpdateCopyEventListener

getCascadeAction() - Method in class org.hibernate.event.def.DefaultSaveOrUpdateEventListener

getCascadeConstraintsString() - Method in class org.hibernate.dialect.Dialect
Completely optional cascading drop clause
getCascadeConstraintsString() - Method in class org.hibernate.dialect.FrontBaseDialect

getCascadeConstraintsString() - Method in class org.hibernate.dialect.JDataStoreDialect

getCascadeConstraintsString() - Method in class org.hibernate.dialect.MimerSQLDialect
The syntax for using cascade on constraints
getCascadeConstraintsString() - Method in class org.hibernate.dialect.Oracle9Dialect

getCascadeConstraintsString() - Method in class org.hibernate.dialect.PointbaseDialect

getCascadeConstraintsString() - Method in class org.hibernate.dialect.PostgreSQLDialect

getCascadeConstraintsString() - Method in class org.hibernate.dialect.RDMSOS2200Dialect

getCascadeLevel() - Method in interface org.hibernate.engine.PersistenceContext
How deep are we cascaded?
getCascadeLevel() - Method in class org.hibernate.engine.StatefulPersistenceContext
Do we already know that the entity does not exist in the database?
getCascadeStyle(String) - Static method in class org.hibernate.engine.CascadeStyle

getCascadeStyle() - Method in class org.hibernate.mapping.Property

getCascadeStyle(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getCascadeStyle(int) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
Get the cascade style of this (subclass closure) property
getCascadeStyle() - Method in class org.hibernate.tuple.StandardProperty

getCascadeStyle(int) - Method in interface org.hibernate.type.AbstractComponentType

getCascadeStyle(int) - Method in class org.hibernate.type.AnyType

getCascadeStyle(int) - Method in class org.hibernate.type.ComponentType

getCascadeStyle(int) - Method in class org.hibernate.type.CompositeCustomType

getCascadeStyles() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getCascadingAction() - Method in class org.hibernate.event.def.AbstractFlushingEventListener

getCastTypeName(int) - Method in class org.hibernate.dialect.Dialect

getCastTypeName(int) - Method in class org.hibernate.dialect.MySQLDialect

getCatalog() - Method in class org.hibernate.mapping.Table

getCatalogName() - Method in class org.hibernate.cfg.Mappings

getCategoryName() - Method in class org.hibernate.stat.CategorizedStatistics

getCause() - Method in class org.hibernate.bytecode.javassist.BulkAccessorException
Gets the cause of this throwable.
getCause(Throwable) - Static method in class org.hibernate.exception.ExceptionUtils
Introspects the Throwable to obtain the cause.
getCause(Throwable, String[]) - Static method in class org.hibernate.exception.ExceptionUtils
Introspects the Throwable to obtain the cause.
getCause() - Method in interface org.hibernate.exception.Nestable
Returns the reference to the exception or error that caused the exception implementing the Nestable to be thrown.
getCause() - Method in class org.hibernate.exception.NestableException

getCause() - Method in class org.hibernate.exception.NestableRuntimeException

getCharacter(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a character
getCharacter(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getCharacterStream(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getCharacterStream(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getCharacterStream() - Method in class org.hibernate.lob.ClobImpl

getCharacterStream() - Method in class org.hibernate.lob.SerializableClob

getCheckConstraint() - Method in class org.hibernate.mapping.Column

getCheckConstraintsIterator() - Method in class org.hibernate.mapping.Table

getClass(Object) - Static method in class org.hibernate.Hibernate
Get the true, underlying class of a proxied persistent class.
getClass(String) - Method in class org.hibernate.cfg.Mappings

getClassAlias() - Method in class org.hibernate.hql.ast.tree.FromElement

getClassDescriptor(byte[]) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

getClassDescriptor(byte[]) - Method in class org.hibernate.tool.instrument.cglib.InstrumentTask

getClassDescriptor(byte[]) - Method in class org.hibernate.tool.instrument.javassist.InstrumentTask

getClassMapping(String) - Method in class org.hibernate.cfg.Configuration
Get the mapping for a particular class
getClassMappings() - Method in class org.hibernate.cfg.Configuration
Iterate the class mappings
getClassMetadata(Class) - Method in interface org.hibernate.SessionFactory
Get the ClassMetadata associated with the given entity class
getClassMetadata(String) - Method in interface org.hibernate.SessionFactory
Get the ClassMetadata associated with the given entity name
getClassMetadata(Class) - Method in class org.hibernate.impl.SessionFactoryImpl

getClassMetadata(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getClassMetadata(Class) - Method in class org.hibernate.jmx.SessionFactoryStub

getClassMetadata(String) - Method in class org.hibernate.jmx.SessionFactoryStub

getClassMetadata() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getClassMetadata() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the user-visible metadata for the class (optional operation)
getClassName(String, Mappings) - Static method in class org.hibernate.cfg.HbmBinder

getClassName(String, String) - Static method in class org.hibernate.cfg.HbmBinder

getClassName() - Method in class org.hibernate.hql.ast.tree.FromElement

getClassName() - Method in class org.hibernate.mapping.PersistentClass

getClassTransformer(ClassDescriptor) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

getClassTransformer(ClassDescriptor) - Method in class org.hibernate.tool.instrument.cglib.InstrumentTask

getClassTransformer(ClassDescriptor) - Method in class org.hibernate.tool.instrument.javassist.InstrumentTask

getClassWithoutInitializingProxy(Object) - Static method in class org.hibernate.proxy.HibernateProxyHelper
Get the class of an instance or the underlying class of a proxy (without initializing the proxy!).
getClob(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a clob
getClob(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getClob(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getClob(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getCloseStatementCount() - Method in class org.hibernate.jmx.StatisticsService

getCloseStatementCount() - Method in interface org.hibernate.stat.Statistics
The number of prepared statements that were released
getCloseStatementCount() - Method in class org.hibernate.stat.StatisticsImpl

getCollection() - Method in class org.hibernate.action.CollectionAction

getCollection(String) - Method in class org.hibernate.cfg.Mappings

getCollection(CollectionKey) - Method in interface org.hibernate.engine.PersistenceContext
Get the collection instance associated with the CollectionKey
getCollection(CollectionKey) - Method in class org.hibernate.engine.StatefulPersistenceContext
Get the collection instance associated with the CollectionKey
getCollection() - Method in class org.hibernate.event.InitializeCollectionEvent

getCollection(Serializable, SessionImplementor, Object) - Method in class org.hibernate.type.CollectionType
instantiate a collection wrapper (called when loading an object)
getCollectionAliases() - Method in class org.hibernate.loader.BasicLoader

getCollectionAliases() - Method in class org.hibernate.loader.Loader

getCollectionAliases() - Method in class org.hibernate.loader.custom.CollectionFetchReturn

getCollectionAliases() - Method in class org.hibernate.loader.custom.CollectionReturn

getCollectionAliases() - Method in class org.hibernate.loader.custom.CustomLoader

getCollectionBatch(CollectionPersister, Serializable, int, EntityMode) - Method in class org.hibernate.engine.BatchFetchQueue
Get a batch of uninitialized collection keys for a given role
getCollectionCount() - Method in interface org.hibernate.stat.SessionStatistics
Get the number of collection instances associated with the session
getCollectionCount() - Method in class org.hibernate.stat.SessionStatisticsImpl

getCollectionElementColumns(String, String) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Retrieves the column names corresponding to the collection elements for the given collection role.
getCollectionEntries() - Method in interface org.hibernate.engine.PersistenceContext
Get the mapping from collection instance to collection entry
getCollectionEntries() - Method in class org.hibernate.engine.StatefulPersistenceContext

getCollectionEntry(PersistentCollection) - Method in interface org.hibernate.engine.PersistenceContext
Get the collection entry for a persistent collection
getCollectionEntry(PersistentCollection) - Method in class org.hibernate.engine.StatefulPersistenceContext
Get the collection entry for a persistent collection
getCollectionEntryOrNull(Object) - Method in interface org.hibernate.engine.PersistenceContext
Get the collection entry for a collection passed to filter, which might be a collection wrapper, an array, or an unwrapped collection.
getCollectionEntryOrNull(Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Get the collection entry for a collection passed to filter, which might be a collection wrapper, an array, or an unwrapped collection.
getCollectionFetchCount() - Method in class org.hibernate.jmx.StatisticsService

getCollectionFetchCount() - Method in interface org.hibernate.stat.Statistics
Global number of collections fetched
getCollectionFetchCount() - Method in class org.hibernate.stat.StatisticsImpl

getCollectionFetches() - Method in class org.hibernate.hql.ast.tree.FromClause

getCollectionFromElements() - Method in class org.hibernate.hql.ast.tree.SelectClause

getCollectionHolder(Object) - Method in interface org.hibernate.engine.PersistenceContext
Get the PersistentCollection object for an array
getCollectionHolder(Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Get the PersistentCollection object for an array
getCollectionKeys() - Method in class org.hibernate.engine.QueryParameters

getCollectionKeys() - Method in interface org.hibernate.stat.SessionStatistics
Get the set of all CollectionKeys
getCollectionKeys() - Method in class org.hibernate.stat.SessionStatisticsImpl

getCollectionLoadContext() - Method in interface org.hibernate.engine.PersistenceContext
Get the context for collection loading
getCollectionLoadContext() - Method in class org.hibernate.engine.StatefulPersistenceContext

getCollectionLoadCount() - Method in class org.hibernate.jmx.StatisticsService

getCollectionLoadCount() - Method in interface org.hibernate.stat.Statistics
Global number of collections loaded
getCollectionLoadCount() - Method in class org.hibernate.stat.StatisticsImpl

getCollectionMapping(String) - Method in class org.hibernate.cfg.Configuration
Get the mapping for a particular collection role
getCollectionMappings() - Method in class org.hibernate.cfg.Configuration
Iterate the collection mappings
getCollectionMetadata(String) - Method in interface org.hibernate.SessionFactory
Get the CollectionMetadata associated with the named collection role
getCollectionMetadata(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getCollectionMetadata(String) - Method in class org.hibernate.jmx.SessionFactoryStub

getCollectionMetadata() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getCollectionMetadata() - Method in interface org.hibernate.persister.collection.CollectionPersister

getCollectionOwner(Serializable, CollectionPersister) - Method in interface org.hibernate.engine.PersistenceContext
Get the entity that owns this persistent collection
getCollectionOwner(Serializable, CollectionPersister) - Method in class org.hibernate.engine.StatefulPersistenceContext
Get the entity that owns this persistent collection
getCollectionOwners() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getCollectionOwners() - Method in class org.hibernate.loader.JoinWalker

getCollectionOwners() - Method in class org.hibernate.loader.Loader
Get the index of the entity that owns the collection, or -1 if there is no owner in the query results (ie.
getCollectionOwners() - Method in class org.hibernate.loader.OuterJoinLoader

getCollectionOwners() - Method in class org.hibernate.loader.custom.CustomLoader

getCollectionOwners() - Method in class org.hibernate.loader.hql.QueryLoader

getCollectionPersister(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get the persister object for a collection role
getCollectionPersister(String) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Locate the collection persister by the collection role.
getCollectionPersister(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getCollectionPersisterClass() - Method in class org.hibernate.mapping.Collection

getCollectionPersisters() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl
Overrides method from Loader
getCollectionPersisters() - Method in class org.hibernate.loader.JoinWalker

getCollectionPersisters() - Method in class org.hibernate.loader.Loader
An (optional) persister for a collection to be initialized; only collection loaders return a non-null value
getCollectionPersisters() - Method in class org.hibernate.loader.OuterJoinLoader

getCollectionPersisters() - Method in class org.hibernate.loader.custom.CustomLoader

getCollectionPersisters() - Method in class org.hibernate.loader.hql.QueryLoader
An (optional) persister for a collection to be initialized; only collection loaders return a non-null value
getCollectionPropertyColumnAliases(String, String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getCollectionPropertyColumnAliases(String, String) - Method in interface org.hibernate.persister.collection.SQLLoadableCollection

getCollectionRecreateCount() - Method in class org.hibernate.jmx.StatisticsService

getCollectionRecreateCount() - Method in interface org.hibernate.stat.Statistics
Global number of collections recreated
getCollectionRecreateCount() - Method in class org.hibernate.stat.StatisticsImpl

getCollectionRemoveCount() - Method in class org.hibernate.jmx.StatisticsService

getCollectionRemoveCount() - Method in interface org.hibernate.stat.Statistics
Global number of collections removed
getCollectionRemoveCount() - Method in class org.hibernate.stat.StatisticsImpl

getCollectionRole() - Method in class org.hibernate.engine.query.FilterQueryPlan

getCollectionRole() - Method in class org.hibernate.mapping.Backref

getCollectionRole() - Method in class org.hibernate.mapping.IndexBackref

getCollectionRoleNames() - Method in class org.hibernate.jmx.StatisticsService

getCollectionRoleNames() - Method in interface org.hibernate.stat.Statistics
Get the names of all collection roles
getCollectionRoleNames() - Method in class org.hibernate.stat.StatisticsImpl
Get the names of all collection roles
getCollectionRolesByEntityParticipant(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor
Retrieves a set of all the collection roles in which the given entity is a participant, as either an index or an element.
getCollectionRolesByEntityParticipant(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getCollectionSpaces() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getCollectionSpaces() - Method in interface org.hibernate.persister.collection.CollectionPersister
Get the "space" that holds the persistent state
getCollectionStatistics(String) - Method in class org.hibernate.jmx.StatisticsService

getCollectionStatistics(String) - Method in interface org.hibernate.stat.Statistics
Get collection statistics per role
getCollectionStatistics(String) - Method in class org.hibernate.stat.StatisticsImpl
Get collection statistics per role
getCollectionSubquery(Map) - Method in class org.hibernate.hql.classic.PathExpressionParser

getCollectionSuffix() - Method in class org.hibernate.hql.ast.tree.FromElement

getCollectionSuffixes() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getCollectionSuffixes() - Method in class org.hibernate.loader.BasicLoader

getCollectionSuffixes() - Method in class org.hibernate.loader.JoinWalker

getCollectionSuffixes() - Method in class org.hibernate.loader.OuterJoinLoader

getCollectionSuffixes() - Method in class org.hibernate.loader.hql.QueryLoader

getCollectionTable() - Method in class org.hibernate.mapping.Collection

getCollectionTableAlias() - Method in class org.hibernate.hql.ast.tree.FromElement

getCollectionType() - Method in class org.hibernate.mapping.Collection

getCollectionType() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getCollectionType() - Method in interface org.hibernate.persister.collection.CollectionPersister
Get the associated Type
getCollectionUpdateCount() - Method in class org.hibernate.jmx.StatisticsService

getCollectionUpdateCount() - Method in interface org.hibernate.stat.Statistics
Global number of collections updated
getCollectionUpdateCount() - Method in class org.hibernate.stat.StatisticsImpl

getCollectionsByKey() - Method in interface org.hibernate.engine.PersistenceContext
Get the mapping from collection key to collection instance
getCollectionsByKey() - Method in class org.hibernate.engine.StatefulPersistenceContext

getColumn(Criteria, String) - Method in interface org.hibernate.criterion.CriteriaQuery
Get the names of the columns mapped by a property path, ignoring projection aliases
getColumn() - Method in class org.hibernate.hql.ast.tree.Node

getColumn(Criteria, String) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getColumn(int) - Method in class org.hibernate.mapping.Constraint

getColumn(Column) - Method in class org.hibernate.mapping.Table
Return the column which is identified by column provided as argument.
getColumn(int) - Method in class org.hibernate.mapping.Table

getColumnAlias() - Method in class org.hibernate.engine.query.sql.NativeSQLQueryScalarReturn

getColumnAlias() - Method in class org.hibernate.loader.custom.ScalarReturn

getColumnAliases(int) - Method in class org.hibernate.criterion.AliasedProjection

getColumnAliases(String, int) - Method in class org.hibernate.criterion.AliasedProjection

getColumnAliases(int) - Method in class org.hibernate.criterion.Distinct

getColumnAliases(String, int) - Method in class org.hibernate.criterion.Distinct

getColumnAliases(int) - Method in interface org.hibernate.criterion.Projection
Get the SQL select clause column aliases
getColumnAliases(String, int) - Method in interface org.hibernate.criterion.Projection
Get the SQL select clause column aliases for a particular user-visible alias
getColumnAliases(int) - Method in class org.hibernate.criterion.ProjectionList

getColumnAliases(String, int) - Method in class org.hibernate.criterion.ProjectionList

getColumnAliases(int) - Method in class org.hibernate.criterion.SQLProjection

getColumnAliases(String, int) - Method in class org.hibernate.criterion.SQLProjection

getColumnAliases(String, int) - Method in class org.hibernate.criterion.SimpleProjection

getColumnAliases(int) - Method in class org.hibernate.criterion.SimpleProjection

getColumnComment(String) - Method in class org.hibernate.dialect.Dialect

getColumnComment(String) - Method in class org.hibernate.dialect.MySQLDialect

getColumnInsertability() - Method in class org.hibernate.mapping.Collection

getColumnInsertability() - Method in class org.hibernate.mapping.Component

getColumnInsertability() - Method in class org.hibernate.mapping.OneToMany

getColumnInsertability() - Method in class org.hibernate.mapping.SimpleValue

getColumnInsertability() - Method in interface org.hibernate.mapping.Value

getColumnIterator() - Method in class org.hibernate.mapping.Collection

getColumnIterator() - Method in class org.hibernate.mapping.Component

getColumnIterator() - Method in class org.hibernate.mapping.Constraint

getColumnIterator() - Method in class org.hibernate.mapping.DenormalizedTable

getColumnIterator() - Method in class org.hibernate.mapping.Index

getColumnIterator() - Method in class org.hibernate.mapping.OneToMany

getColumnIterator() - Method in class org.hibernate.mapping.Property

getColumnIterator() - Method in class org.hibernate.mapping.SimpleValue

getColumnIterator() - Method in class org.hibernate.mapping.Table

getColumnIterator() - Method in interface org.hibernate.mapping.Value

getColumnMetadata(String) - Method in class org.hibernate.tool.hbm2ddl.TableMetadata

getColumnNames() - Method in interface org.hibernate.hql.QueryTranslator
Returns the column names in the generated SQL.
getColumnNames() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

getColumnNames() - Method in class org.hibernate.hql.ast.tree.SelectClause
The column alias names being used in the generated SQL.
getColumnNames() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getColumnNames(String) - Method in class org.hibernate.persister.entity.AbstractPropertyMapping

getColumnSize() - Method in class org.hibernate.tool.hbm2ddl.ColumnMetadata

getColumnSpan(Type) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Retreive the number of columns represented by this type.
getColumnSpan() - Method in class org.hibernate.mapping.Collection

getColumnSpan() - Method in class org.hibernate.mapping.Component

getColumnSpan() - Method in class org.hibernate.mapping.Constraint

getColumnSpan() - Method in class org.hibernate.mapping.Index

getColumnSpan() - Method in class org.hibernate.mapping.OneToMany

getColumnSpan() - Method in class org.hibernate.mapping.Property

getColumnSpan() - Method in class org.hibernate.mapping.SimpleValue

getColumnSpan() - Method in class org.hibernate.mapping.Table

getColumnSpan() - Method in interface org.hibernate.mapping.Value

getColumnSpan(Mapping) - Method in class org.hibernate.type.AnyType

getColumnSpan(Mapping) - Method in class org.hibernate.type.BlobType

getColumnSpan(Mapping) - Method in class org.hibernate.type.ClobType

getColumnSpan(Mapping) - Method in class org.hibernate.type.CollectionType

getColumnSpan(Mapping) - Method in class org.hibernate.type.ComponentType

getColumnSpan(Mapping) - Method in class org.hibernate.type.CompositeCustomType

getColumnSpan(Mapping) - Method in class org.hibernate.type.CustomType

getColumnSpan(Mapping) - Method in class org.hibernate.type.ManyToOneType

getColumnSpan(Mapping) - Method in class org.hibernate.type.MetaType

getColumnSpan(Mapping) - Method in class org.hibernate.type.NullableType

getColumnSpan(Mapping) - Method in class org.hibernate.type.OneToOneType

getColumnSpan(Mapping) - Method in class org.hibernate.type.SpecialOneToOneType

getColumnSpan(Mapping) - Method in interface org.hibernate.type.Type
How many columns are used to persist this type.
getColumnUpdateability() - Method in class org.hibernate.mapping.Collection

getColumnUpdateability() - Method in class org.hibernate.mapping.Component

getColumnUpdateability() - Method in class org.hibernate.mapping.OneToMany

getColumnUpdateability() - Method in class org.hibernate.mapping.SimpleValue

getColumnUpdateability() - Method in interface org.hibernate.mapping.Value

getColumns() - Method in class org.hibernate.mapping.Constraint

getColumns() - Method in class org.hibernate.tool.hbm2ddl.ForeignKeyMetadata

getColumns() - Method in class org.hibernate.tool.hbm2ddl.IndexMetadata

getColumnsUsingProjection(Criteria, String) - Method in interface org.hibernate.criterion.CriteriaQuery
Get the names of the columns mapped by a property path
getColumnsUsingProjection(Criteria, String) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator
Get the names of the columns constrained by this criterion.
getComment() - Method in class org.hibernate.engine.NamedQueryDefinition

getComment() - Method in class org.hibernate.engine.QueryParameters

getComment() - Method in class org.hibernate.impl.CriteriaImpl

getComment() - Method in class org.hibernate.loader.AbstractEntityJoinWalker

getComment() - Method in class org.hibernate.loader.criteria.CriteriaJoinWalker

getComment() - Method in class org.hibernate.loader.entity.CascadeEntityJoinWalker

getComment() - Method in class org.hibernate.loader.entity.EntityJoinWalker

getComment() - Method in class org.hibernate.mapping.Column

getComment() - Method in class org.hibernate.mapping.Table

getCommentsEnabled() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Are SQL comments enabled?
getCommentsEnabled() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getComparator() - Method in class org.hibernate.mapping.Collection

getComparator() - Method in class org.hibernate.type.AbstractBynaryType

getComparator() - Method in class org.hibernate.type.ByteType

getComparator() - Method in class org.hibernate.type.CalendarType

getComparator() - Method in class org.hibernate.type.CustomType

getComparator() - Method in class org.hibernate.type.IntegerType

getComparator() - Method in class org.hibernate.type.LongType

getComparator() - Method in class org.hibernate.type.ShortType

getComparator() - Method in class org.hibernate.type.TimestampType

getComparator() - Method in interface org.hibernate.type.VersionType
Get a comparator for version values.
getComparatorClassName() - Method in class org.hibernate.mapping.Collection

getComponentClass() - Method in class org.hibernate.mapping.Component

getComponentClassName() - Method in class org.hibernate.mapping.Component

getComponentValue(ComponentType, Object, String) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer
Extract a component property value.
getConcreteProxyClass(EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getConcreteProxyClass(EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Get the proxy interface that instances of this concrete class will be cast to (optional operation).
getConcreteProxyClass() - Method in class org.hibernate.tuple.entity.Dom4jEntityTuplizer

getConcreteProxyClass() - Method in class org.hibernate.tuple.entity.DynamicMapEntityTuplizer

getConcreteProxyClass() - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Returns the java class to which generated proxies will be typed.
getConcreteProxyClass() - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

getConcurrency() - Method in class org.hibernate.jdbc.ResultSetWrapper

getConfigProperties(String) - Static method in class org.hibernate.util.ConfigHelper
Loads a properties instance based on the data at the incoming config location.
getConfigStream(String) - Static method in class org.hibernate.util.ConfigHelper
Open an InputStream to the URL represented by the incoming path.
getConfigStreamReader(String) - Static method in class org.hibernate.util.ConfigHelper
Open an Reader to the URL represented by the incoming path.
getConfigurationInputStream(String) - Method in class org.hibernate.cfg.Configuration
Get the configuration file as an InputStream.
getConnectCount() - Method in class org.hibernate.jmx.StatisticsService

getConnectCount() - Method in interface org.hibernate.stat.Statistics
Get the global number of connections asked by the sessions (the actual number of connections used may be much smaller depending whether you use a connection pool or not)
getConnectCount() - Method in class org.hibernate.stat.StatisticsImpl

getConnection() - Method in class org.hibernate.connection.C3P0ConnectionProvider

getConnection() - Method in interface org.hibernate.connection.ConnectionProvider
Grab a connection, with the autocommit mode specified by hibernate.connection.autocommit.
getConnection() - Method in class org.hibernate.connection.DatasourceConnectionProvider

getConnection() - Method in class org.hibernate.connection.DriverManagerConnectionProvider

getConnection() - Method in class org.hibernate.connection.ProxoolConnectionProvider
Grab a connection
getConnection() - Method in class org.hibernate.connection.UserSuppliedConnectionProvider

getConnection() - Method in class org.hibernate.jdbc.ConnectionManager
Retrieves the connection currently managed by this ConnectionManager.
getConnectionManager() - Method in class org.hibernate.jdbc.JDBCContext

getConnectionProperties(Properties) - Static method in class org.hibernate.connection.ConnectionProviderFactory
Transform JDBC connection properties.
getConnectionProvider() - Method in class org.hibernate.cfg.Settings

getConnectionProvider() - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get the connection provider
getConnectionProvider() - Method in class org.hibernate.impl.SessionFactoryImpl

getConnectionReleaseMode() - Method in class org.hibernate.cfg.Settings

getConnectionReleaseMode() - Method in class org.hibernate.context.JTASessionContext
Mainly for subclass usage.
getConnectionReleaseMode() - Method in class org.hibernate.context.ThreadLocalSessionContext
Mainly for subclass usage.
getConnectionReleaseMode() - Method in class org.hibernate.impl.SessionImpl

getConnectionReleaseMode() - Method in class org.hibernate.impl.StatelessSessionImpl

getConnectionReleaseMode() - Method in interface org.hibernate.jdbc.JDBCContext.Context

getConstantName(Class, int) - Static method in class org.hibernate.hql.ast.util.ASTPrinter
Get a single token type name in the specified set of token type constants (interface).
getConstantValue(String) - Static method in class org.hibernate.util.ReflectHelper

getConstraintColumns() - Method in class org.hibernate.mapping.OneToOne

getConstraintColumns() - Method in class org.hibernate.mapping.SimpleValue

getConstraintName() - Method in class org.hibernate.exception.ConstraintViolationException
Returns the name of the violated constraint, if known.
getConstraintOrderedTableNameClosure() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getConstraintOrderedTableNameClosure() - Method in interface org.hibernate.persister.entity.Queryable
Get the names of all tables used in the hierarchy (up and down) ordered such that deletes in the given order would not cause contraint violations.
getConstraintOrderedTableNameClosure() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getConstraintOrderedTableNameClosure() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getConstructor() - Method in class org.hibernate.hql.ast.tree.ConstructorNode

getConstructor() - Method in class org.hibernate.hql.ast.tree.SelectClause
The constructor to use for dynamic instantiation queries.
getConstructor(Class, Type[]) - Static method in class org.hibernate.util.ReflectHelper

getConstructorArgumentTypeList() - Method in class org.hibernate.hql.ast.tree.ConstructorNode

getContextEntityIdentifier(Object) - Method in interface org.hibernate.engine.SessionImplementor
Return the identifier of the persistent object, or null if not associated with the session
getContextEntityIdentifier(Object) - Method in class org.hibernate.impl.SessionImpl
Get the id value for an object that is actually associated with the session.
getContextEntityIdentifier(Object) - Method in class org.hibernate.impl.StatelessSessionImpl

getContraintOrderedTableKeyColumnClosure() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getContraintOrderedTableKeyColumnClosure() - Method in interface org.hibernate.persister.entity.Queryable
For each table specified in Queryable.getConstraintOrderedTableNameClosure(), get the columns that define the key between the various hierarchy classes.
getContraintOrderedTableKeyColumnClosure() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getContraintOrderedTableKeyColumnClosure() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getCount() - Method in class org.hibernate.id.AbstractUUIDGenerator
Unique in a millisecond for this JVM instance (unless there are > Short.MAX_VALUE instances created in a millisecond)
getCreateSequenceString(String) - Method in class org.hibernate.dialect.DB2Dialect

getCreateSequenceString(String) - Method in class org.hibernate.dialect.Dialect
The syntax used to create a sequence, if sequences are supported.
getCreateSequenceString(String) - Method in class org.hibernate.dialect.InformixDialect

getCreateSequenceString(String) - Method in class org.hibernate.dialect.IngresDialect
The syntax used to create a sequence, if sequences are supported.
getCreateSequenceString(String) - Method in class org.hibernate.dialect.InterbaseDialect

getCreateSequenceString(String) - Method in class org.hibernate.dialect.MckoiDialect

getCreateSequenceString(String) - Method in class org.hibernate.dialect.MimerSQLDialect
The syntax used to create a sequence.
getCreateSequenceString(String) - Method in class org.hibernate.dialect.Oracle9Dialect

getCreateSequenceString(String) - Method in class org.hibernate.dialect.PostgreSQLDialect

getCreateSequenceString(String) - Method in class org.hibernate.dialect.RDMSOS2200Dialect

getCreateSequenceString(String) - Method in class org.hibernate.dialect.SAPDBDialect

getCreateSequenceString(String) - Method in class org.hibernate.dialect.TimesTenDialect

getCreateSequenceStrings(String) - Method in class org.hibernate.dialect.Dialect
The multiline script used to create a sequence, if sequences are supported.
getCreateSequenceStrings(String) - Method in class org.hibernate.dialect.H2Dialect

getCreateSequenceStrings(String) - Method in class org.hibernate.dialect.HSQLDialect

getCreateTemporaryTablePostfix() - Method in class org.hibernate.dialect.DB2Dialect

getCreateTemporaryTablePostfix() - Method in class org.hibernate.dialect.Dialect

getCreateTemporaryTablePostfix() - Method in class org.hibernate.dialect.Oracle9Dialect

getCreateTemporaryTablePostfix() - Method in class org.hibernate.dialect.PostgreSQLDialect

getCreateTemporaryTablePostfix() - Method in class org.hibernate.dialect.SAPDBDialect

getCreateTemporaryTablePostfix() - Method in class org.hibernate.dialect.TimesTenDialect

getCreateTemporaryTableString() - Method in class org.hibernate.dialect.DB2Dialect

getCreateTemporaryTableString() - Method in class org.hibernate.dialect.Dialect

getCreateTemporaryTableString() - Method in class org.hibernate.dialect.H2Dialect

getCreateTemporaryTableString() - Method in class org.hibernate.dialect.MySQLDialect

getCreateTemporaryTableString() - Method in class org.hibernate.dialect.Oracle9Dialect

getCreateTemporaryTableString() - Method in class org.hibernate.dialect.PostgreSQLDialect

getCreateTemporaryTableString() - Method in class org.hibernate.dialect.TimesTenDialect

getCriteria() - Method in class org.hibernate.impl.CriteriaImpl.CriterionEntry

getCriteria() - Method in class org.hibernate.impl.CriteriaImpl.OrderEntry

getCriteria(String) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getCriterion() - Method in class org.hibernate.impl.CriteriaImpl.CriterionEntry

getCurrentClauseType() - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

getCurrentFromClause() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getCurrentKey() - Method in class org.hibernate.engine.CollectionEntry
This is only available late during the flush cycle
getCurrentLockMode(Object) - Method in interface org.hibernate.Session
Determine the current lock mode of the given object.
getCurrentLockMode(Object) - Method in class org.hibernate.impl.SessionImpl

getCurrentPersister() - Method in class org.hibernate.engine.CollectionEntry

getCurrentRow() - Method in class org.hibernate.impl.AbstractScrollableResults

getCurrentRow() - Method in class org.hibernate.impl.FetchingScrollableResultsImpl

getCurrentRow() - Method in class org.hibernate.impl.ScrollableResultsImpl

getCurrentSession() - Method in interface org.hibernate.SessionFactory
Obtains the current session.
getCurrentSession() - Method in class org.hibernate.impl.SessionFactoryImpl

getCurrentSession() - Method in class org.hibernate.jmx.SessionFactoryStub

getCurrentStatementType() - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

getCurrentTimestampCallString() - Method in class org.hibernate.dialect.FrontBaseDialect

getCurrentTimestampCallString() - Method in class org.hibernate.dialect.InterbaseDialect

getCurrentTimestampSQLFunctionName() - Method in class org.hibernate.dialect.DB2Dialect

getCurrentTimestampSQLFunctionName() - Method in class org.hibernate.dialect.Dialect
The name of the database-specific SQL function for retrieving the current timestamp.
getCurrentTimestampSQLFunctionName() - Method in class org.hibernate.dialect.OracleDialect

getCurrentTimestampSelectString() - Method in class org.hibernate.dialect.DB2Dialect

getCurrentTimestampSelectString() - Method in class org.hibernate.dialect.Dialect

getCurrentTimestampSelectString() - Method in class org.hibernate.dialect.H2Dialect

getCurrentTimestampSelectString() - Method in class org.hibernate.dialect.InformixDialect

getCurrentTimestampSelectString() - Method in class org.hibernate.dialect.MySQLDialect

getCurrentTimestampSelectString() - Method in class org.hibernate.dialect.Oracle9Dialect

getCurrentTimestampSelectString() - Method in class org.hibernate.dialect.OracleDialect

getCurrentTimestampSelectString() - Method in class org.hibernate.dialect.PostgreSQLDialect

getCurrentTimestampSelectString() - Method in class org.hibernate.dialect.SQLServerDialect

getCurrentTimestampSelectString() - Method in class org.hibernate.dialect.SybaseDialect

getCurrentTimestampSelectString() - Method in class org.hibernate.dialect.TimesTenDialect

getCurrentTopLevelClauseType() - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

getCurrentVersion(Serializable, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Retrieve the version number
getCurrentVersion(Serializable, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Get the current version of the object, or return null if there is no row for the given identifier.
getCursorName() - Method in class org.hibernate.jdbc.ResultSetWrapper

getCustomListeners() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getCustomQuery() - Method in class org.hibernate.engine.query.NativeSQLQueryPlan

getCustomQueryReturns() - Method in interface org.hibernate.loader.custom.CustomQuery
A collection of descriptors describing the JDBC result set to be expected and how to map this result set.
getCustomQueryReturns() - Method in class org.hibernate.loader.custom.sql.SQLCustomQuery

getCustomSQLDelete() - Method in class org.hibernate.mapping.Collection

getCustomSQLDelete() - Method in class org.hibernate.mapping.Join

getCustomSQLDelete() - Method in class org.hibernate.mapping.PersistentClass

getCustomSQLDeleteAll() - Method in class org.hibernate.mapping.Collection

getCustomSQLDeleteAllCheckStyle() - Method in class org.hibernate.mapping.Collection

getCustomSQLDeleteCheckStyle() - Method in class org.hibernate.mapping.Collection

getCustomSQLDeleteCheckStyle() - Method in class org.hibernate.mapping.Join

getCustomSQLDeleteCheckStyle() - Method in class org.hibernate.mapping.PersistentClass

getCustomSQLInsert() - Method in class org.hibernate.mapping.Collection

getCustomSQLInsert() - Method in class org.hibernate.mapping.Join

getCustomSQLInsert() - Method in class org.hibernate.mapping.PersistentClass

getCustomSQLInsertCheckStyle() - Method in class org.hibernate.mapping.Collection

getCustomSQLInsertCheckStyle() - Method in class org.hibernate.mapping.Join

getCustomSQLInsertCheckStyle() - Method in class org.hibernate.mapping.PersistentClass

getCustomSQLUpdate() - Method in class org.hibernate.mapping.Collection

getCustomSQLUpdate() - Method in class org.hibernate.mapping.Join

getCustomSQLUpdate() - Method in class org.hibernate.mapping.PersistentClass

getCustomSQLUpdateCheckStyle() - Method in class org.hibernate.mapping.Collection

getCustomSQLUpdateCheckStyle() - Method in class org.hibernate.mapping.Join

getCustomSQLUpdateCheckStyle() - Method in class org.hibernate.mapping.PersistentClass

getData() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getData() - Method in class org.hibernate.tuple.ElementWrapper

getDataSource() - Method in class org.hibernate.connection.DatasourceConnectionProvider

getDataType() - Method in class org.hibernate.hql.ast.tree.AggregateNode

getDataType() - Method in class org.hibernate.hql.ast.tree.BetweenOperatorNode

getDataType() - Method in class org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode
Figure out the type of the binary expression by looking at the types of the operands.
getDataType() - Method in class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode

getDataType() - Method in class org.hibernate.hql.ast.tree.BooleanLiteralNode

getDataType() - Method in class org.hibernate.hql.ast.tree.Case2Node

getDataType() - Method in class org.hibernate.hql.ast.tree.CaseNode

getDataType() - Method in class org.hibernate.hql.ast.tree.ConstructorNode
Deprecated. (tell clover to ignore this method)
getDataType() - Method in class org.hibernate.hql.ast.tree.CountNode

getDataType() - Method in class org.hibernate.hql.ast.tree.DotNode

getDataType() - Method in class org.hibernate.hql.ast.tree.FromElement

getDataType() - Method in class org.hibernate.hql.ast.tree.IdentNode

getDataType() - Method in class org.hibernate.hql.ast.tree.LiteralNode

getDataType() - Method in interface org.hibernate.hql.ast.tree.OperatorNode
Retrieves the data type for the overall operator expression.
getDataType() - Method in class org.hibernate.hql.ast.tree.QueryNode

getDataType() - Method in interface org.hibernate.hql.ast.tree.SelectExpression
Returns the data type of the select expression.
getDataType() - Method in class org.hibernate.hql.ast.tree.SqlNode

getDataType() - Method in class org.hibernate.hql.ast.tree.UnaryArithmeticNode

getDataType() - Method in class org.hibernate.hql.ast.tree.UnaryLogicOperatorNode

getDatabaseSnapshot(Serializable, EntityPersister) - Method in interface org.hibernate.engine.PersistenceContext
Get the current state of the entity as known to the underlying database, or null if there is no corresponding row
getDatabaseSnapshot(Serializable, EntityPersister) - Method in class org.hibernate.engine.StatefulPersistenceContext
Get the current state of the entity as known to the underlying database, or null if there is no corresponding row
getDatabaseSnapshot() - Method in class org.hibernate.event.FlushEntityEvent

getDatabaseSnapshot(Serializable, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getDatabaseSnapshot(Serializable, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Get the current database state of the object, in a "hydrated" form, without resolving identifiers
getDatasource() - Method in class org.hibernate.jmx.HibernateService

getDatasource() - Method in interface org.hibernate.jmx.HibernateServiceMBean
The JNDI name of the datasource to use in this SessionFactory
getDate(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a date, time or timestamp
getDate(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getDate(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getDate(String, Calendar) - Method in class org.hibernate.jdbc.ResultSetWrapper

getDate(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getDate(int, Calendar) - Method in class org.hibernate.jdbc.ResultSetWrapper

getDebugString(AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil
Returns the 'list' representation with some brackets around it for debugging.
getDecimalDigits() - Method in class org.hibernate.tool.hbm2ddl.ColumnMetadata

getDefaultAccess() - Method in class org.hibernate.cfg.Mappings

getDefaultBatchFetchSize() - Method in class org.hibernate.cfg.Settings

getDefaultCascade() - Method in class org.hibernate.cfg.Mappings

getDefaultCatalog() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Get the default catalog
getDefaultCatalog() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getDefaultCatalogName() - Method in class org.hibernate.cfg.Settings

getDefaultCollectionType() - Method in class org.hibernate.mapping.Array

getDefaultCollectionType() - Method in class org.hibernate.mapping.Bag

getDefaultCollectionType() - Method in class org.hibernate.mapping.Collection

getDefaultCollectionType() - Method in class org.hibernate.mapping.IdentifierBag

getDefaultCollectionType() - Method in class org.hibernate.mapping.List

getDefaultCollectionType() - Method in class org.hibernate.mapping.Map

getDefaultCollectionType() - Method in class org.hibernate.mapping.Set

getDefaultConstructor(Class) - Static method in class org.hibernate.util.ReflectHelper

getDefaultEntityMode() - Method in class org.hibernate.cfg.Settings

getDefaultFilterCondition() - Method in class org.hibernate.engine.FilterDefinition

getDefaultPackage() - Method in class org.hibernate.cfg.Mappings

getDefaultProperties() - Method in class org.hibernate.dialect.Dialect
Retrieve a set of default Hibernate properties for this database.
getDefaultReleaseMode() - Method in class org.hibernate.transaction.CMTTransactionFactory

getDefaultReleaseMode() - Method in class org.hibernate.transaction.JDBCTransactionFactory

getDefaultReleaseMode() - Method in class org.hibernate.transaction.JTATransactionFactory

getDefaultReleaseMode() - Method in interface org.hibernate.transaction.TransactionFactory
Get the default connection release mode
getDefaultSchema() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Get the default schema
getDefaultSchema() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getDefaultSchemaName() - Method in class org.hibernate.cfg.Settings

getDefaultValue(Serializable) - Method in class org.hibernate.engine.IdentifierValue

getDefaultValue(Object) - Method in class org.hibernate.engine.VersionValue

getDefaultValue() - Method in class org.hibernate.mapping.Column

getDefaultValue() - Method in class org.hibernate.type.BooleanType

getDefaultValue() - Method in class org.hibernate.type.ByteType

getDefaultValue() - Method in class org.hibernate.type.CharacterType

getDefaultValue() - Method in class org.hibernate.type.DoubleType

getDefaultValue() - Method in class org.hibernate.type.FloatType

getDefaultValue() - Method in class org.hibernate.type.IntegerType

getDefaultValue() - Method in class org.hibernate.type.LongType

getDefaultValue() - Method in class org.hibernate.type.PrimitiveType

getDefaultValue() - Method in class org.hibernate.type.ShortType

getDefinedFilterNames() - Method in interface org.hibernate.SessionFactory
Obtain a set of the names of all filters defined on this SessionFactory.
getDefinedFilterNames() - Method in class org.hibernate.impl.SessionFactoryImpl

getDefinedFilterNames() - Method in class org.hibernate.jmx.SessionFactoryStub

getDelayedEntityKey() - Method in class org.hibernate.action.EntityIdentityInsertAction

getDeleteAllCheckStyle() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getDeleteCheckStyle() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getDeleteCount() - Method in class org.hibernate.stat.EntityStatistics

getDeleteEventListeners() - Method in class org.hibernate.event.EventListeners

getDeletedState() - Method in class org.hibernate.engine.EntityEntry

getDeletedState() - Method in class org.hibernate.event.PostDeleteEvent

getDeletedState() - Method in class org.hibernate.event.PreDeleteEvent

getDeletes(CollectionPersister, boolean) - Method in class org.hibernate.collection.PersistentArrayHolder

getDeletes(CollectionPersister, boolean) - Method in class org.hibernate.collection.PersistentBag

getDeletes(CollectionPersister, boolean) - Method in interface org.hibernate.collection.PersistentCollection
Get all the elements that need deleting
getDeletes(CollectionPersister, boolean) - Method in class org.hibernate.collection.PersistentElementHolder

getDeletes(CollectionPersister, boolean) - Method in class org.hibernate.collection.PersistentIdentifierBag

getDeletes(CollectionPersister, boolean) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

getDeletes(CollectionPersister, boolean) - Method in class org.hibernate.collection.PersistentList

getDeletes(CollectionPersister, boolean) - Method in class org.hibernate.collection.PersistentMap

getDeletes(CollectionPersister, boolean) - Method in class org.hibernate.collection.PersistentSet

getDestinations() - Method in class org.hibernate.hql.ast.tree.FromElement

getDialect() - Method in class org.hibernate.cfg.Settings

getDialect() - Static method in class org.hibernate.dialect.Dialect
Get the Dialect specified by the current System properties.
getDialect(Properties) - Static method in class org.hibernate.dialect.Dialect
Get the Dialect specified by the given properties or system properties.
getDialect() - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get the SQL Dialect
getDialect() - Method in class org.hibernate.impl.SessionFactoryImpl

getDialect() - Method in interface org.hibernate.jmx.HibernateServiceMBean
The JNDI name of the dialect class to use in this SessionFactory
getDialect() - Method in class org.hibernate.loader.JoinWalker

getDialect() - Method in class org.hibernate.loader.OuterJoinLoader

getDialect() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getDialect() - Method in class org.hibernate.sql.Insert

getDialect() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getDialectClass(int) - Method in interface org.hibernate.dialect.DialectFactory.DatabaseDialectMapper

getDialectClass(int) - Method in class org.hibernate.dialect.DialectFactory.VersionInsensitiveMapper

getDialectScopes() - Method in class org.hibernate.mapping.AbstractAuxiliaryDatabaseObject

getDirectSubclasses() - Method in class org.hibernate.mapping.PersistentClass

getDirtyCheckEventListeners() - Method in class org.hibernate.event.EventListeners

getDirtyProperties() - Method in class org.hibernate.event.FlushEntityEvent

getDisassembledState() - Method in class org.hibernate.cache.entry.CacheEntry

getDiscriminator() - Method in class org.hibernate.mapping.PersistentClass

getDiscriminator() - Method in class org.hibernate.mapping.RootClass

getDiscriminator() - Method in class org.hibernate.mapping.Subclass

getDiscriminatorAlias(Loadable, String) - Method in class org.hibernate.loader.ColumnEntityAliases

getDiscriminatorAlias(Loadable, String) - Method in class org.hibernate.loader.DefaultEntityAliases

getDiscriminatorAlias() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getDiscriminatorAlias(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getDiscriminatorAlias(String) - Method in interface org.hibernate.persister.entity.Loadable
Get the result set aliases used for the identifier columns, given a suffix
getDiscriminatorAlias() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getDiscriminatorColumnIterator() - Method in class org.hibernate.mapping.PersistentClass

getDiscriminatorColumnIterator() - Method in class org.hibernate.mapping.SingleTableSubclass

getDiscriminatorColumnName() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getDiscriminatorColumnName() - Method in interface org.hibernate.persister.entity.Loadable

getDiscriminatorColumnName() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getDiscriminatorFormula() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getDiscriminatorFormula() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getDiscriminatorFormulaTemplate() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getDiscriminatorFormulaTemplate() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getDiscriminatorSQLValue() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getDiscriminatorSQLValue() - Method in interface org.hibernate.persister.entity.Queryable
Get the discriminator value for this particular concrete subclass, as a string that may be embedded in a select statement
getDiscriminatorSQLValue() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getDiscriminatorSQLValue() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getDiscriminatorType() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getDiscriminatorType() - Method in interface org.hibernate.persister.entity.Loadable
Get the discriminator type
getDiscriminatorType() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getDiscriminatorType() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getDiscriminatorValue() - Method in class org.hibernate.mapping.PersistentClass

getDisplayText() - Method in class org.hibernate.hql.ast.tree.AbstractStatement
Returns additional display text for the AST node.
getDisplayText() - Method in class org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode

getDisplayText() - Method in interface org.hibernate.hql.ast.tree.DisplayableNode
Returns additional display text for the AST node.
getDisplayText() - Method in class org.hibernate.hql.ast.tree.DotNode

getDisplayText() - Method in class org.hibernate.hql.ast.tree.FromClause

getDisplayText() - Method in class org.hibernate.hql.ast.tree.FromElement
Returns additional display text for the AST node.
getDisplayText() - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

getDisplayText() - Method in class org.hibernate.hql.ast.tree.IdentNode

getDisplayText() - Method in class org.hibernate.hql.ast.tree.ImpliedFromElement
Returns additional display text for the AST node.
getDisplayText() - Method in class org.hibernate.hql.ast.tree.IntoClause
Returns additional display text for the AST node.
getDisplayText() - Method in class org.hibernate.hql.ast.tree.MethodNode

getDisplayText() - Method in class org.hibernate.hql.ast.tree.ParameterNode

getDocument() - Method in class org.hibernate.cfg.ExtendsQueueEntry

getDocument() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getDocument() - Method in class org.hibernate.tuple.ElementWrapper

getDom4jPropertyAccessor(String, Type, SessionFactoryImplementor) - Static method in class org.hibernate.property.PropertyAccessorFactory

getDontFlushFromFind() - Method in interface org.hibernate.engine.SessionImplementor

getDontFlushFromFind() - Method in class org.hibernate.impl.SessionImpl

getDontFlushFromFind() - Method in class org.hibernate.impl.StatelessSessionImpl

getDouble(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a double
getDouble(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getDouble(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getDouble(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getDropForeignKeyString() - Method in class org.hibernate.dialect.Dialect

getDropForeignKeyString() - Method in class org.hibernate.dialect.MySQLDialect

getDropSequenceString(String) - Method in class org.hibernate.dialect.DB2Dialect

getDropSequenceString(String) - Method in class org.hibernate.dialect.Dialect
The syntax used to drop a sequence, if sequences are supported.
getDropSequenceString(String) - Method in class org.hibernate.dialect.FirebirdDialect

getDropSequenceString(String) - Method in class org.hibernate.dialect.InformixDialect

getDropSequenceString(String) - Method in class org.hibernate.dialect.IngresDialect
The syntax used to drop a sequence, if sequences are supported.
getDropSequenceString(String) - Method in class org.hibernate.dialect.InterbaseDialect

getDropSequenceString(String) - Method in class org.hibernate.dialect.MckoiDialect

getDropSequenceString(String) - Method in class org.hibernate.dialect.MimerSQLDialect
The syntax used to drop sequences
getDropSequenceString(String) - Method in class org.hibernate.dialect.Oracle9Dialect

getDropSequenceString(String) - Method in class org.hibernate.dialect.PostgreSQLDialect

getDropSequenceString(String) - Method in class org.hibernate.dialect.RDMSOS2200Dialect

getDropSequenceString(String) - Method in class org.hibernate.dialect.SAPDBDialect

getDropSequenceString(String) - Method in class org.hibernate.dialect.TimesTenDialect

getDropSequenceStrings(String) - Method in class org.hibernate.dialect.Dialect
The multiline script used to drop a sequence, if sequences are supported.
getDropSequenceStrings(String) - Method in class org.hibernate.dialect.H2Dialect

getDropSequenceStrings(String) - Method in class org.hibernate.dialect.HSQLDialect

getDynamicMapPropertyAccessor() - Static method in class org.hibernate.property.PropertyAccessorFactory

getElement(Object) - Method in class org.hibernate.collection.PersistentArrayHolder

getElement(Object) - Method in class org.hibernate.collection.PersistentBag

getElement(Object) - Method in interface org.hibernate.collection.PersistentCollection
Get the value of the given collection entry
getElement(Object) - Method in class org.hibernate.collection.PersistentElementHolder

getElement(Object) - Method in class org.hibernate.collection.PersistentIdentifierBag

getElement(Object) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

getElement(Object) - Method in class org.hibernate.collection.PersistentList

getElement(Object) - Method in class org.hibernate.collection.PersistentMap

getElement(Object) - Method in class org.hibernate.collection.PersistentSet

getElement() - Method in class org.hibernate.mapping.Collection

getElement() - Method in class org.hibernate.proxy.dom4j.Dom4jLazyInitializer

getElement() - Method in class org.hibernate.tuple.ElementWrapper

getElementAssociationType(CollectionType) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Essentially the same as #getElementType, but requiring that the element type be an association type.
getElementByIndex(Serializable, Object, SessionImplementor, Object) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getElementByIndex(Serializable, Object, SessionImplementor, Object) - Method in interface org.hibernate.persister.collection.CollectionPersister

getElementByIndex(Serializable, Object, SessionImplementor, Object) - Method in class org.hibernate.persister.collection.OneToManyPersister

getElementClass() - Method in class org.hibernate.mapping.Array

getElementClass() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister
Return the element class of an array, or null otherwise
getElementClass() - Method in interface org.hibernate.persister.collection.CollectionPersister
Return the element class of an array, or null otherwise
getElementClassName() - Method in class org.hibernate.mapping.Array

getElementColumnAliases(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getElementColumnAliases(String) - Method in interface org.hibernate.persister.collection.CollectionPersister
Generates the collection's element column aliases, based on the given suffix.
getElementColumnNames(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getElementColumnNames() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getElementColumnNames(String) - Method in interface org.hibernate.persister.collection.QueryableCollection
Get the names of the collection element columns (or the primary key columns in the case of a one-to-many association), aliased by the given table alias
getElementColumnNames() - Method in interface org.hibernate.persister.collection.QueryableCollection
Get the names of the collection element columns (or the primary key columns in the case of a one-to-many association)
getElementCountInMemory() - Method in interface org.hibernate.cache.Cache
The count of entries currently contained in the regions in-memory store.
getElementCountInMemory() - Method in class org.hibernate.cache.EhCache

getElementCountInMemory() - Method in class org.hibernate.cache.HashtableCache

getElementCountInMemory() - Method in class org.hibernate.cache.OSCache

getElementCountInMemory() - Method in class org.hibernate.cache.OptimisticTreeCache

getElementCountInMemory() - Method in class org.hibernate.cache.SwarmCache

getElementCountInMemory() - Method in class org.hibernate.cache.TreeCache

getElementCountInMemory() - Method in class org.hibernate.stat.SecondLevelCacheStatistics

getElementCountOnDisk() - Method in interface org.hibernate.cache.Cache
The count of entries currently contained in the regions disk store.
getElementCountOnDisk() - Method in class org.hibernate.cache.EhCache

getElementCountOnDisk() - Method in class org.hibernate.cache.HashtableCache

getElementCountOnDisk() - Method in class org.hibernate.cache.OSCache

getElementCountOnDisk() - Method in class org.hibernate.cache.OptimisticTreeCache

getElementCountOnDisk() - Method in class org.hibernate.cache.SwarmCache

getElementCountOnDisk() - Method in class org.hibernate.cache.TreeCache

getElementCountOnDisk() - Method in class org.hibernate.stat.SecondLevelCacheStatistics

getElementEntityAliases() - Method in class org.hibernate.loader.custom.CollectionFetchReturn

getElementEntityAliases() - Method in class org.hibernate.loader.custom.CollectionReturn

getElementNodeName() - Method in class org.hibernate.mapping.Collection

getElementNodeName() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getElementNodeName() - Method in interface org.hibernate.persister.collection.CollectionPersister

getElementPersister() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getElementPersister() - Method in interface org.hibernate.persister.collection.QueryableCollection
Get the persister of the element class, if this is a collection of entities (optional operation).
getElementType() - Method in interface org.hibernate.metadata.CollectionMetadata
The collection element type
getElementType() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getElementType() - Method in interface org.hibernate.persister.collection.CollectionPersister
Get the "element" type
getElementType(SessionFactoryImplementor) - Method in class org.hibernate.type.CollectionType
Get the Hibernate type of the collection elements
getElementsIterator(Object) - Method in class org.hibernate.type.ArrayType
Not defined for collections of primitive type
getElementsIterator(Object, SessionImplementor) - Method in class org.hibernate.type.CollectionType
Get an iterator over the element set of the collection, which may not yet be wrapped
getElementsIterator(Object) - Method in class org.hibernate.type.CollectionType
Get an iterator over the element set of the collection in POJO mode
getElementsIterator(Object) - Method in class org.hibernate.type.CustomCollectionType

getElementsIterator(Object) - Method in class org.hibernate.type.MapType

getElementsIterator(Object) - Method in interface org.hibernate.usertype.UserCollectionType
Return an iterator over the elements of this collection - the passed collection instance may or may not be a wrapper
getEnabledFilter(String) - Method in interface org.hibernate.Session
Retrieve a currently enabled filter by name.
getEnabledFilter(String) - Method in class org.hibernate.impl.SessionImpl

getEnabledFilterNames() - Method in class org.hibernate.engine.query.HQLQueryPlan

getEnabledFilters() - Method in interface org.hibernate.engine.SessionImplementor
Return the currently enabled filters.
getEnabledFilters() - Method in interface org.hibernate.hql.QueryTranslator
Returns the filters enabled for this query translator.
getEnabledFilters() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getEnabledFilters() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

getEnabledFilters() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getEnabledFilters() - Method in class org.hibernate.impl.SessionImpl

getEnabledFilters() - Method in class org.hibernate.impl.StatelessSessionImpl

getEnabledFilters() - Method in class org.hibernate.loader.JoinWalker

getEnabledFilters() - Method in class org.hibernate.loader.OuterJoinLoader

getEntitiesByKey() - Method in interface org.hibernate.engine.PersistenceContext
Get the mapping from key value to entity instance
getEntitiesByKey() - Method in class org.hibernate.engine.StatefulPersistenceContext

getEntity(String, Serializable) - Method in class org.hibernate.EmptyInterceptor

getEntity(String, Serializable) - Method in interface org.hibernate.Interceptor
Get a fully loaded entity instance that is cached externally
getEntity(EntityKey) - Method in interface org.hibernate.engine.PersistenceContext
Get the entity instance associated with the given EntityKey
getEntity(EntityUniqueKey) - Method in interface org.hibernate.engine.PersistenceContext
Get an entity cached by unique key
getEntity(EntityKey) - Method in class org.hibernate.engine.StatefulPersistenceContext
Get the entity instance associated with the given EntityKey
getEntity(EntityUniqueKey) - Method in class org.hibernate.engine.StatefulPersistenceContext
Get an entity cached by unique key
getEntity() - Method in class org.hibernate.event.FlushEntityEvent

getEntity() - Method in class org.hibernate.event.MergeEvent

getEntity() - Method in class org.hibernate.event.PostDeleteEvent

getEntity() - Method in class org.hibernate.event.PostInsertEvent

getEntity() - Method in class org.hibernate.event.PostLoadEvent

getEntity() - Method in class org.hibernate.event.PostUpdateEvent

getEntity() - Method in class org.hibernate.event.PreDeleteEvent

getEntity() - Method in class org.hibernate.event.PreInsertEvent

getEntity() - Method in class org.hibernate.event.PreLoadEvent

getEntity() - Method in class org.hibernate.event.PreUpdateEvent

getEntity() - Method in class org.hibernate.event.SaveOrUpdateEvent

getEntity() - Method in interface org.hibernate.id.insert.Binder

getEntityAliases() - Method in class org.hibernate.loader.BasicLoader

getEntityAliases() - Method in class org.hibernate.loader.Loader
Get the result set descriptor
getEntityAliases() - Method in class org.hibernate.loader.custom.CustomLoader

getEntityAliases() - Method in class org.hibernate.loader.custom.EntityFetchReturn

getEntityAliases() - Method in class org.hibernate.loader.custom.RootReturn

getEntityBatch(EntityPersister, Serializable, int, EntityMode) - Method in class org.hibernate.engine.BatchFetchQueue
Get a batch of unloaded identifiers for this class, using a slightly complex algorithm that tries to grab keys registered immediately after the given key.
getEntityClassName() - Method in class org.hibernate.event.LoadEvent

getEntityCount() - Method in interface org.hibernate.stat.SessionStatistics
Get the number of entity instances associated with the session
getEntityCount() - Method in class org.hibernate.stat.SessionStatisticsImpl

getEntityDeleteCount() - Method in class org.hibernate.jmx.StatisticsService

getEntityDeleteCount() - Method in interface org.hibernate.stat.Statistics
Get global number of entity deletes
getEntityDeleteCount() - Method in class org.hibernate.stat.StatisticsImpl

getEntityEagerPropertyFetches() - Method in class org.hibernate.loader.Loader
An array indicating whether the entities have eager property fetching enabled
getEntityEagerPropertyFetches() - Method in class org.hibernate.loader.hql.QueryLoader

getEntityEntries() - Method in interface org.hibernate.engine.PersistenceContext
Get the mapping from entity instance to entity entry
getEntityEntries() - Method in class org.hibernate.engine.StatefulPersistenceContext

getEntityEntry() - Method in class org.hibernate.event.FlushEntityEvent

getEntityFetchCount() - Method in class org.hibernate.jmx.StatisticsService

getEntityFetchCount() - Method in interface org.hibernate.stat.Statistics
Get global number of entity fetchs
getEntityFetchCount() - Method in class org.hibernate.stat.StatisticsImpl

getEntityId() - Method in class org.hibernate.event.LoadEvent

getEntityIdentifierIfNotUnsaved(String, Object, SessionImplementor) - Static method in class org.hibernate.engine.ForeignKeys
Return the identifier of the persistent or transient object, or throw an exception if the instance is "unsaved" Used by OneToOneType and ManyToOneType to determine what id value should be used for an object that may or may not be associated with the session.
getEntityInsertCount() - Method in class org.hibernate.jmx.StatisticsService

getEntityInsertCount() - Method in interface org.hibernate.stat.Statistics
Get global number of entity inserts
getEntityInsertCount() - Method in class org.hibernate.stat.StatisticsImpl

getEntityKeys() - Method in interface org.hibernate.stat.SessionStatistics
Get the set of all EntityKeys
getEntityKeys() - Method in class org.hibernate.stat.SessionStatisticsImpl

getEntityLoadCount() - Method in class org.hibernate.jmx.StatisticsService

getEntityLoadCount() - Method in interface org.hibernate.stat.Statistics
Get global number of entity loads
getEntityLoadCount() - Method in class org.hibernate.stat.StatisticsImpl

getEntityMetamodel() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getEntityMetamodel() - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

getEntityMode() - Method in interface org.hibernate.Session
Retrieve the entity mode in effect for this session.
getEntityMode() - Method in interface org.hibernate.engine.SessionImplementor

getEntityMode() - Method in class org.hibernate.impl.SessionImpl

getEntityMode() - Method in class org.hibernate.impl.StatelessSessionImpl

getEntityMode() - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer
Return the entity-mode handled by this tuplizer instance.
getEntityMode() - Method in class org.hibernate.tuple.entity.Dom4jEntityTuplizer

getEntityMode() - Method in class org.hibernate.tuple.entity.DynamicMapEntityTuplizer

getEntityMode() - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

getEntityName(Object) - Method in class org.hibernate.EmptyInterceptor

getEntityName(Object) - Method in interface org.hibernate.Interceptor
Get the entity name for a persistent or transient instance
getEntityName() - Method in class org.hibernate.NonUniqueObjectException

getEntityName() - Method in class org.hibernate.PropertyValueException

getEntityName(Object) - Method in interface org.hibernate.Session
Return the entity name for a persistent entity
getEntityName() - Method in class org.hibernate.StaleObjectStateException

getEntityName() - Method in class org.hibernate.UnresolvableObjectException

getEntityName() - Method in class org.hibernate.WrongClassException

getEntityName(Element, Mappings) - Static method in class org.hibernate.cfg.HbmBinder

getEntityName(Criteria) - Method in interface org.hibernate.criterion.CriteriaQuery
Get the entity name of an entity
getEntityName(Criteria, String) - Method in interface org.hibernate.criterion.CriteriaQuery
Get the entity name of an entity, taking into account the qualifier of the property path
getEntityName() - Method in class org.hibernate.engine.EntityEntry

getEntityName() - Method in class org.hibernate.engine.EntityKey

getEntityName() - Method in class org.hibernate.engine.EntityUniqueKey

getEntityName() - Method in class org.hibernate.event.DeleteEvent

getEntityName() - Method in class org.hibernate.event.LockEvent

getEntityName() - Method in class org.hibernate.event.MergeEvent

getEntityName() - Method in class org.hibernate.event.PersistEvent

getEntityName() - Method in class org.hibernate.event.ReplicateEvent

getEntityName() - Method in class org.hibernate.event.SaveOrUpdateEvent

getEntityName() - Method in class org.hibernate.hql.ast.tree.IntoClause

getEntityName(Object) - Method in class org.hibernate.impl.SessionImpl

getEntityName() - Method in class org.hibernate.intercept.AbstractFieldInterceptor

getEntityName(Criteria) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getEntityName(Criteria, String) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getEntityName() - Method in class org.hibernate.loader.custom.RootReturn

getEntityName() - Method in class org.hibernate.mapping.Backref

getEntityName() - Method in class org.hibernate.mapping.IndexBackref

getEntityName() - Method in class org.hibernate.mapping.OneToOne

getEntityName() - Method in class org.hibernate.mapping.PersistentClass

getEntityName() - Method in interface org.hibernate.metadata.ClassMetadata
The name of the entity
getEntityName() - Method in class org.hibernate.persister.collection.CompositeElementPropertyMapping

getEntityName() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getEntityName() - Method in class org.hibernate.persister.entity.AbstractPropertyMapping

getEntityName() - Method in class org.hibernate.persister.entity.BasicEntityPropertyMapping

getEntityName() - Method in interface org.hibernate.persister.entity.EntityPersister
The classname of the persistent class (used only for messages)
getEntityName() - Method in class org.hibernate.proxy.AbstractLazyInitializer

getEntityName() - Method in interface org.hibernate.proxy.LazyInitializer
Get the entity name
getEntityName() - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer
Retreives the defined entity-name for the tuplized entity.
getEntityNames() - Method in class org.hibernate.jmx.StatisticsService

getEntityNames() - Method in interface org.hibernate.stat.Statistics
Get the names of all entities
getEntityNames() - Method in class org.hibernate.stat.StatisticsImpl
Get the names of all entities
getEntityNotFoundDelegate() - Method in class org.hibernate.cfg.Configuration
Retrieve the user-supplied delegate to handle non-existent entity scenarios.
getEntityNotFoundDelegate() - Method in interface org.hibernate.engine.SessionFactoryImplementor

getEntityNotFoundDelegate() - Method in class org.hibernate.impl.SessionFactoryImpl

getEntityOrClassName() - Method in class org.hibernate.impl.CriteriaImpl

getEntityOrRoleName() - Method in class org.hibernate.cache.CacheKey

getEntityPersister(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get the persister for the named entity
getEntityPersister(String, Object) - Method in interface org.hibernate.engine.SessionImplementor
Get the EntityPersister for any instance
getEntityPersister() - Method in class org.hibernate.hql.ast.tree.FromElement

getEntityPersister(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getEntityPersister(String, Object) - Method in class org.hibernate.impl.SessionImpl

getEntityPersister(String, Object) - Method in class org.hibernate.impl.StatelessSessionImpl

getEntityPersisterClass() - Method in class org.hibernate.mapping.PersistentClass

getEntityPersisterClass() - Method in class org.hibernate.mapping.RootClass

getEntityPersisterClass() - Method in class org.hibernate.mapping.Subclass

getEntityPersisters() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl
Persisters for the return values of a find() style query.
getEntityPersisters() - Method in class org.hibernate.loader.Loader
An array of persisters of entity classes contained in each row of results; implemented by all subclasses
getEntityPersisters() - Method in class org.hibernate.loader.OuterJoinLoader

getEntityPersisters() - Method in class org.hibernate.loader.custom.CustomLoader

getEntityPersisters() - Method in class org.hibernate.loader.hql.QueryLoader

getEntityResolver() - Method in class org.hibernate.cfg.Configuration

getEntityState(Object, String, EntityEntry, SessionImplementor) - Method in class org.hibernate.event.def.AbstractSaveEventListener
Determine whether the entity is persistent, detached, or transient
getEntityStatistics(String) - Method in class org.hibernate.jmx.StatisticsService

getEntityStatistics(String) - Method in interface org.hibernate.stat.Statistics
find entity statistics per name
getEntityStatistics(String) - Method in class org.hibernate.stat.StatisticsImpl
find entity statistics per name
getEntityType() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getEntityType() - Method in interface org.hibernate.persister.entity.OuterJoinLoadable

getEntityType() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getEntityUpdateCount() - Method in class org.hibernate.jmx.StatisticsService

getEntityUpdateCount() - Method in interface org.hibernate.stat.Statistics
Get global number of entity updates
getEntityUpdateCount() - Method in class org.hibernate.stat.StatisticsImpl

getEntityUsingInterceptor(EntityKey) - Method in interface org.hibernate.engine.SessionImplementor
Get the entity instance associated with the given Key, calling the Interceptor if necessary
getEntityUsingInterceptor(EntityKey) - Method in class org.hibernate.impl.SessionImpl

getEntityUsingInterceptor(EntityKey) - Method in class org.hibernate.impl.StatelessSessionImpl

getEntries() - Method in class org.hibernate.stat.SecondLevelCacheStatistics

getEntry(Object) - Method in interface org.hibernate.engine.PersistenceContext
Retreive the EntityEntry representation of the given entity.
getEntry(Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Retreive the EntityEntry representation of the given entity.
getEntry() - Method in class org.hibernate.event.SaveOrUpdateEvent

getErrorCode() - Method in class org.hibernate.JDBCException
Get the errorCode of the underlying SQLException.
getErrorCount() - Method in class org.hibernate.hql.ast.ErrorCounter

getErrorCount() - Method in interface org.hibernate.hql.ast.ParseErrorHandler

getEventListeners() - Method in class org.hibernate.cfg.Configuration

getEventListeners() - Method in class org.hibernate.impl.SessionFactoryImpl

getEvictEventListeners() - Method in class org.hibernate.event.EventListeners

getExceptions() - Method in class org.hibernate.tool.hbm2ddl.SchemaExport
Returns a List of all Exceptions which occured during the export.
getExceptions() - Method in class org.hibernate.tool.hbm2ddl.SchemaUpdate
Returns a List of all Exceptions which occured during the export.
getExcludedPropertyNames() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getExecutableCriteria(Session) - Method in class org.hibernate.criterion.DetachedCriteria
Get an executable instance of Criteria, to actually run the query.
getExecutionAvgTime() - Method in class org.hibernate.stat.QueryStatistics
average time in ms taken by the excution of this query onto the DB
getExecutionCount() - Method in class org.hibernate.stat.QueryStatistics
queries executed to the DB
getExecutionMaxTime() - Method in class org.hibernate.stat.QueryStatistics
max time in ms taken by the excution of this query onto the DB
getExecutionMinTime() - Method in class org.hibernate.stat.QueryStatistics
min time in ms taken by the excution of this query onto the DB
getExecutionRowCount() - Method in class org.hibernate.stat.QueryStatistics
Number of lines returned by all the executions of this query (from DB) For now, Query.iterate() and Query.scroll()() do not fill this statistic
getExpectedRowCount() - Method in class org.hibernate.jdbc.TooManyRowsAffectedException

getExpectedType() - Method in class org.hibernate.engine.query.NamedParameterDescriptor

getExpectedType() - Method in class org.hibernate.engine.query.OrdinalParameterDescriptor

getExpectedType() - Method in class org.hibernate.hql.ast.ParameterTranslationsImpl.ParameterInfo

getExpectedType() - Method in class org.hibernate.hql.ast.tree.BooleanLiteralNode

getExpectedType() - Method in interface org.hibernate.hql.ast.tree.ExpectedTypeAwareNode

getExpectedType() - Method in class org.hibernate.hql.ast.tree.JavaConstantNode

getExpectedType() - Method in class org.hibernate.hql.ast.tree.ParameterNode

getExpectedType() - Method in class org.hibernate.param.AbstractExplicitParameterSpecification

getExpectedType() - Method in interface org.hibernate.param.ParameterSpecification

getExpectedType() - Method in class org.hibernate.param.VersionTypeSeedParameterSpecification

getExplicitFromElements() - Method in class org.hibernate.hql.ast.tree.FromClause

getExplicitName() - Method in class org.hibernate.cfg.ExtendsQueueEntry

getExtendsNeeded(Document, Mappings) - Static method in class org.hibernate.cfg.HbmBinder
For the given document, locate all extends attributes which refer to entities (entity-name or class-name) not defined within said document.
getExtraProperties() - Method in class org.hibernate.jmx.HibernateService

getExtraProperties() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getFactory() - Method in class org.hibernate.context.ThreadLocalSessionContext

getFactory() - Method in interface org.hibernate.criterion.CriteriaQuery

getFactory() - Method in interface org.hibernate.engine.SessionImplementor
Get the creating SessionFactoryImplementor
getFactory() - Method in class org.hibernate.hql.ast.exec.AbstractStatementExecutor

getFactory() - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Get a handle to the encapsulated SessionFactory.
getFactory() - Method in class org.hibernate.impl.AbstractSessionImpl

getFactory() - Method in class org.hibernate.jdbc.AbstractBatcher

getFactory() - Method in class org.hibernate.jdbc.ConnectionManager
The session factory.
getFactory() - Method in class org.hibernate.jdbc.JDBCContext

getFactory() - Method in class org.hibernate.loader.JoinWalker

getFactory() - Method in class org.hibernate.loader.Loader

getFactory() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getFactory() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getFactory() - Method in interface org.hibernate.persister.collection.CollectionPersister

getFactory() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getFactory() - Method in interface org.hibernate.persister.entity.EntityPersister
Return the SessionFactory to which this persister "belongs".
getFactory() - Method in interface org.hibernate.transaction.TransactionFactory.Context

getFactory() - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

getFalseString() - Method in class org.hibernate.type.CharBooleanType

getFalseString() - Method in class org.hibernate.type.TrueFalseType

getFalseString() - Method in class org.hibernate.type.YesNoType

getFetchCount() - Method in class org.hibernate.stat.CollectionStatistics

getFetchCount() - Method in class org.hibernate.stat.EntityStatistics

getFetchDirection() - Method in class org.hibernate.jdbc.ResultSetWrapper

getFetchMode(String) - Method in class org.hibernate.impl.CriteriaImpl

getFetchMode() - Method in class org.hibernate.mapping.Collection

getFetchMode() - Method in interface org.hibernate.mapping.Fetchable

getFetchMode() - Method in class org.hibernate.mapping.OneToMany

getFetchMode() - Method in class org.hibernate.mapping.SimpleValue

getFetchMode() - Method in class org.hibernate.mapping.ToOne

getFetchMode() - Method in interface org.hibernate.mapping.Value

getFetchMode() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getFetchMode() - Method in interface org.hibernate.persister.collection.QueryableCollection
Should we load this collection role by outerjoining?
getFetchMode(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getFetchMode(int) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
May this (subclass closure) property be fetched using an SQL outerjoin?
getFetchMode() - Method in class org.hibernate.tuple.StandardProperty

getFetchMode(int) - Method in interface org.hibernate.type.AbstractComponentType

getFetchMode(int) - Method in class org.hibernate.type.AnyType

getFetchMode(int) - Method in class org.hibernate.type.ComponentType

getFetchMode(int) - Method in class org.hibernate.type.CompositeCustomType

getFetchProfile() - Method in interface org.hibernate.engine.SessionImplementor

getFetchProfile() - Method in class org.hibernate.impl.SessionImpl

getFetchProfile() - Method in class org.hibernate.impl.StatelessSessionImpl

getFetchSize() - Method in class org.hibernate.engine.NamedQueryDefinition

getFetchSize() - Method in class org.hibernate.engine.RowSelection

getFetchSize() - Method in class org.hibernate.impl.CriteriaImpl

getFetchSize() - Method in class org.hibernate.jdbc.ResultSetWrapper

getFieldHandler() - Method in interface org.hibernate.bytecode.javassist.FieldHandled
Access to the current field interception handler.
getFieldTransformer(ClassFile) - Method in class org.hibernate.bytecode.javassist.JavassistClassTransformer

getFilename() - Method in class org.hibernate.hql.ast.tree.Node

getFilterDefinition() - Method in interface org.hibernate.Filter
Get the filter definition containing additional information about the filter (such as default-condition and expected parameter names/types).
getFilterDefinition(String) - Method in interface org.hibernate.SessionFactory
Obtain the definition of a filter by name.
getFilterDefinition(String) - Method in class org.hibernate.cfg.Mappings

getFilterDefinition() - Method in class org.hibernate.impl.FilterImpl

getFilterDefinition(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getFilterDefinition(String) - Method in class org.hibernate.jmx.SessionFactoryStub

getFilterDefinitions() - Method in class org.hibernate.cfg.Configuration

getFilterDefinitions() - Method in class org.hibernate.cfg.Mappings

getFilterMap() - Method in class org.hibernate.mapping.Collection

getFilterMap() - Method in interface org.hibernate.mapping.Filterable

getFilterMap() - Method in class org.hibernate.mapping.PersistentClass

getFilterMap() - Method in class org.hibernate.mapping.Subclass

getFilterName() - Method in class org.hibernate.engine.FilterDefinition
Get the name of the filter this configuration defines.
getFilterParameterType(String) - Method in interface org.hibernate.engine.SessionImplementor
Retreive the type for a given filter parrameter.
getFilterParameterType(String) - Method in class org.hibernate.impl.SessionImpl

getFilterParameterType(String) - Method in class org.hibernate.impl.StatelessSessionImpl

getFilterParameterValue(String) - Method in interface org.hibernate.engine.SessionImplementor
Retreive the currently set value for a filter parameter.
getFilterParameterValue(String) - Method in class org.hibernate.impl.SessionImpl

getFilterParameterValue(String) - Method in class org.hibernate.impl.StatelessSessionImpl

getFilterQueryPlan(String, String, boolean, Map) - Method in class org.hibernate.engine.query.QueryPlanCache

getFilteredPositionalParameterTypes() - Method in class org.hibernate.engine.QueryParameters

getFilteredPositionalParameterValues() - Method in class org.hibernate.engine.QueryParameters

getFilteredSQL() - Method in class org.hibernate.engine.QueryParameters

getFinal(int, Type) - Method in class org.hibernate.impl.AbstractScrollableResults
Check that the requested type is compatible with the result type, and return the column value.
getFinalFromClause() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getFirstResult() - Method in class org.hibernate.impl.CriteriaImpl

getFirstRow() - Method in class org.hibernate.engine.RowSelection

getFirstSelectExpression() - Method in class org.hibernate.hql.ast.tree.ConstructorNode

getFirstSelectExpression() - Method in class org.hibernate.hql.ast.tree.SelectClause

getFirstSelectExpression() - Method in class org.hibernate.hql.ast.tree.SelectExpressionList
Returns the first select expression node that should be considered when building the array of select expressions.
getFixtureOperand() - Method in class org.hibernate.hql.ast.tree.BetweenOperatorNode

getFloat(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a float
getFloat(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getFloat(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getFloat(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getFlushBeforeCompletionEnabled() - Method in class org.hibernate.jmx.HibernateService

getFlushBeforeCompletionEnabled() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Is automatic Session flusing enabled?
getFlushCount() - Method in class org.hibernate.jmx.StatisticsService

getFlushCount() - Method in interface org.hibernate.stat.Statistics
Get the global number of flush executed by sessions (either implicit or explicit)
getFlushCount() - Method in class org.hibernate.stat.StatisticsImpl

getFlushEntityEventListeners() - Method in class org.hibernate.event.EventListeners

getFlushEventListeners() - Method in class org.hibernate.event.EventListeners

getFlushMode() - Method in interface org.hibernate.Session
Get the current flush mode.
getFlushMode(String) - Static method in class org.hibernate.cfg.HbmBinder

getFlushMode() - Method in class org.hibernate.engine.NamedQueryDefinition

getFlushMode() - Method in interface org.hibernate.engine.SessionImplementor

getFlushMode() - Method in class org.hibernate.impl.SessionImpl

getFlushMode() - Method in class org.hibernate.impl.StatelessSessionImpl

getForInsert(Object, Map, SessionImplementor) - Method in class org.hibernate.property.BackrefPropertyAccessor.BackrefGetter

getForInsert(Object, Map, SessionImplementor) - Method in class org.hibernate.property.BasicPropertyAccessor.BasicGetter

getForInsert(Object, Map, SessionImplementor) - Method in class org.hibernate.property.DirectPropertyAccessor.DirectGetter

getForInsert(Object, Map, SessionImplementor) - Method in class org.hibernate.property.Dom4jAccessor.Dom4jGetter

getForInsert(Object, Map, SessionImplementor) - Method in class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter

getForInsert(Object, Map, SessionImplementor) - Method in interface org.hibernate.property.Getter
Get the property value from the given owner instance.
getForInsert(Object, Map, SessionImplementor) - Method in class org.hibernate.property.IndexPropertyAccessor.IndexGetter

getForInsert(Object, Map, SessionImplementor) - Method in class org.hibernate.property.MapAccessor.MapGetter

getForUpdateNowaitString(String) - Method in class org.hibernate.dialect.Dialect
Retrieves the FOR UPDATE OF column_list NOWAIT syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.
getForUpdateNowaitString() - Method in class org.hibernate.dialect.Dialect
Retrieves the FOR UPDATE NOWAIT syntax specific to this dialect.
getForUpdateNowaitString() - Method in class org.hibernate.dialect.Oracle9Dialect

getForUpdateNowaitString(String) - Method in class org.hibernate.dialect.Oracle9Dialect

getForUpdateString() - Method in class org.hibernate.dialect.DB2Dialect

getForUpdateString(String) - Method in class org.hibernate.dialect.Dialect
Retrieves the FOR UPDATE OF column_list syntax specific to this dialect, where the given aliases represent the aliases of the columns which are to be write locked.
getForUpdateString() - Method in class org.hibernate.dialect.Dialect
Retrieves the FOR UPDATE syntax specific to this dialect.
getForUpdateString(LockMode) - Method in class org.hibernate.dialect.Dialect

getForUpdateString() - Method in class org.hibernate.dialect.FrontBaseDialect
Does this dialect support the FOR UPDATE syntax.
getForUpdateString() - Method in class org.hibernate.dialect.H2Dialect

getForUpdateString() - Method in class org.hibernate.dialect.HSQLDialect

getForUpdateString() - Method in class org.hibernate.dialect.InterbaseDialect

getForUpdateString(String) - Method in class org.hibernate.dialect.InterbaseDialect

getForUpdateString() - Method in class org.hibernate.dialect.MckoiDialect

getForUpdateString(String) - Method in class org.hibernate.dialect.Oracle9Dialect

getForUpdateString() - Method in class org.hibernate.dialect.PointbaseDialect

getForUpdateString(String) - Method in class org.hibernate.dialect.PostgreSQLDialect

getForUpdateString() - Method in class org.hibernate.dialect.RDMSOS2200Dialect
Since the RDMS-JDBC driver does not support for updates, this string is set to an empty string.
getForUpdateString() - Method in class org.hibernate.dialect.SybaseDialect

getForUpdateString() - Method in class org.hibernate.dialect.TimesTenDialect

getForeignKeyDirection() - Method in class org.hibernate.type.AnyType

getForeignKeyDirection() - Method in interface org.hibernate.type.AssociationType
Get the foreign key directionality of this association
getForeignKeyDirection() - Method in class org.hibernate.type.CollectionType

getForeignKeyDirection() - Method in class org.hibernate.type.ManyToOneType

getForeignKeyDirection() - Method in class org.hibernate.type.OneToOneType

getForeignKeyIterator() - Method in class org.hibernate.mapping.Table

getForeignKeyMetadata(String) - Method in class org.hibernate.tool.hbm2ddl.TableMetadata

getForeignKeyName() - Method in class org.hibernate.mapping.SimpleValue

getForeignKeyType() - Method in class org.hibernate.mapping.OneToOne
Returns the foreignKeyType.
getFormula() - Method in class org.hibernate.mapping.Formula

getFreshTimestamp() - Method in class org.hibernate.cache.ReadWriteCache.Item
The timestamp on the cached data
getFromClause() - Method in class org.hibernate.hql.ast.tree.AbstractRestrictableStatement

getFromClause() - Method in class org.hibernate.hql.ast.tree.FromElement

getFromClause() - Method in interface org.hibernate.hql.ast.tree.RestrictableStatement
Retreives the from-clause in effect for this statement.
getFromElement() - Method in class org.hibernate.hql.ast.tree.AbstractSelectExpression

getFromElement() - Method in class org.hibernate.hql.ast.tree.ConstructorNode

getFromElement(String) - Method in class org.hibernate.hql.ast.tree.FromClause
Retreives the from-element represented by the given alias.
getFromElement() - Method in class org.hibernate.hql.ast.tree.FromClause

getFromElement() - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

getFromElement() - Method in class org.hibernate.hql.ast.tree.MethodNode

getFromElement() - Method in class org.hibernate.hql.ast.tree.QueryNode

getFromElement() - Method in interface org.hibernate.hql.ast.tree.SelectExpression
Returns the FROM element that this expression refers to.
getFromElement() - Method in class org.hibernate.hql.ast.tree.SqlFragment

getFromElements() - Method in class org.hibernate.hql.ast.tree.FromClause
Returns the list of from elements in order.
getFromElementsForLoad() - Method in class org.hibernate.hql.ast.tree.SelectClause
FromElements which need to be accounted for in the load phase (either for return or for fetch).
getFromPart() - Method in class org.hibernate.engine.JoinSequence

getFullStackTrace(Throwable) - Static method in class org.hibernate.exception.ExceptionUtils
A way to get the entire nested stack-trace of an throwable.
getFunctions() - Method in class org.hibernate.dialect.Dialect
SQL functions as defined in general.
getGeneratedId() - Method in class org.hibernate.action.EntityIdentityInsertAction

getGeneratedIdentity(ResultSet, Type) - Static method in class org.hibernate.id.IdentifierGeneratorFactory
Get the generated identifier when using identity columns
getGeneratedKey(PreparedStatement) - Static method in class org.hibernate.util.GetGeneratedKeysHelper

getGeneratedKey(PreparedStatement) - Static method in class org.hibernate.util.NamedGeneratedKeysHelper

getGeneration() - Method in class org.hibernate.mapping.Property

getGetGeneratedKeysEnabled() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Is use of JDBC3 getGeneratedKeys() enabled?
getGetGeneratedKeysEnabled() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getGetter(Class) - Method in class org.hibernate.mapping.Property

getGetter(Class, String) - Method in class org.hibernate.property.BackrefPropertyAccessor

getGetter(Class, String) - Method in class org.hibernate.property.BasicPropertyAccessor

getGetter(Class, String) - Method in class org.hibernate.property.ChainedPropertyAccessor

getGetter(Class, String) - Method in class org.hibernate.property.DirectPropertyAccessor

getGetter(Class, String) - Method in class org.hibernate.property.Dom4jAccessor
Create a "getter" for the named attribute
getGetter(Class, String) - Method in class org.hibernate.property.EmbeddedPropertyAccessor

getGetter(Class, String) - Method in class org.hibernate.property.IndexPropertyAccessor

getGetter(Class, String) - Method in class org.hibernate.property.MapAccessor

getGetter(Class, String) - Method in class org.hibernate.property.NoopAccessor

getGetter(Class, String) - Method in interface org.hibernate.property.PropertyAccessor
Create a "getter" for the named attribute
getGetter(Class, String) - Static method in class org.hibernate.util.ReflectHelper

getGetters() - Method in class org.hibernate.bytecode.javassist.BulkAccessor
Returns the setter names of properties.
getGroupBy() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getHQLQueryPlan(String, boolean, Map) - Method in class org.hibernate.engine.query.QueryPlanCache

getHQLQueryPlan(String, boolean) - Method in class org.hibernate.impl.AbstractSessionImpl

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.AbstractBynaryType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.AbstractType

getHashCode(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.AbstractType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.AdaptedImmutableType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.BigDecimalType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.BigIntegerType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.BlobType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.CalendarDateType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.CalendarType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.ClobType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.CollectionType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.ComponentType

getHashCode(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.ComponentType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.CompositeCustomType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.CustomType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.DateType

getHashCode(Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.EntityType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.SerializableType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.TimeType

getHashCode(Object, EntityMode) - Method in class org.hibernate.type.TimestampType

getHashCode(Object, EntityMode) - Method in interface org.hibernate.type.Type
Get a hashcode, consistent with persistence "equality"
getHashCode(Object, EntityMode, SessionFactoryImplementor) - Method in interface org.hibernate.type.Type
Get a hashcode, consistent with persistence "equality"
getHiTime() - Method in class org.hibernate.id.AbstractUUIDGenerator
Unique down to millisecond
getHibernateLazyInitializer() - Method in interface org.hibernate.proxy.HibernateProxy
Get the underlying lazy initialization handler.
getHibernateLazyInitializer() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getHibernateLazyInitializer() - Method in class org.hibernate.proxy.map.MapProxy

getHibernateTypeName(int) - Method in class org.hibernate.dialect.Dialect

getHibernateTypeName(int, int, int, int) - Method in class org.hibernate.dialect.Dialect

getHighOperand() - Method in class org.hibernate.hql.ast.tree.BetweenOperatorNode

getHitCount() - Method in class org.hibernate.stat.SecondLevelCacheStatistics

getHolderClass() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getHolderInstantiator(ResultTransformer, ResultTransformer, String[]) - Static method in class org.hibernate.hql.HolderInstantiator

getHolderInstantiator() - Method in class org.hibernate.impl.AbstractScrollableResults

getHqlParameterSpecification() - Method in class org.hibernate.hql.ast.tree.ParameterNode

getHqlPosition() - Method in class org.hibernate.param.PositionalParameterSpecification

getIP() - Method in class org.hibernate.id.AbstractUUIDGenerator
Unique in a local network
getId() - Method in class org.hibernate.action.EntityAction

getId() - Method in class org.hibernate.cache.ReadWriteCache.Lock

getId() - Method in class org.hibernate.engine.EntityEntry

getId() - Method in class org.hibernate.event.PostDeleteEvent

getId() - Method in class org.hibernate.event.PostInsertEvent

getId() - Method in class org.hibernate.event.PostLoadEvent

getId() - Method in class org.hibernate.event.PostUpdateEvent

getId() - Method in class org.hibernate.event.PreDeleteEvent

getId() - Method in class org.hibernate.event.PreInsertEvent

getId() - Method in class org.hibernate.event.PreLoadEvent

getId() - Method in class org.hibernate.event.PreUpdateEvent

getIdentifier() - Method in class org.hibernate.NonUniqueObjectException

getIdentifier(Object) - Method in interface org.hibernate.Session
Return the identifier of an entity instance cached by the Session, or throw an exception if the instance is transient or associated with a different Session.
getIdentifier() - Method in class org.hibernate.StaleObjectStateException

getIdentifier() - Method in class org.hibernate.UnresolvableObjectException

getIdentifier() - Method in class org.hibernate.WrongClassException

getIdentifier(Object, int) - Method in class org.hibernate.collection.AbstractPersistentCollection

getIdentifier(Object, int) - Method in interface org.hibernate.collection.PersistentCollection
Get the index of the given collection entry
getIdentifier(Object, int) - Method in class org.hibernate.collection.PersistentIdentifierBag

getIdentifier() - Method in class org.hibernate.engine.EntityKey
Get the user-visible identifier
getIdentifier(Object) - Method in class org.hibernate.impl.SessionImpl

getIdentifier() - Method in class org.hibernate.mapping.IdentifierCollection

getIdentifier() - Method in class org.hibernate.mapping.OneToOne
Returns the identifier.
getIdentifier() - Method in class org.hibernate.mapping.PersistentClass

getIdentifier() - Method in class org.hibernate.mapping.RootClass

getIdentifier() - Method in class org.hibernate.mapping.Subclass

getIdentifier(Object, EntityMode) - Method in interface org.hibernate.metadata.ClassMetadata
Get the identifier of an instance (throw an exception if no identifier property)
getIdentifier(Object, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getIdentifier(Object, EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Get the identifier of an instance (throw an exception if no identifier property)
getIdentifier() - Method in class org.hibernate.proxy.AbstractLazyInitializer

getIdentifier() - Method in interface org.hibernate.proxy.LazyInitializer
Get the identifier held by the proxy
getIdentifier(Object) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

getIdentifier(Object) - Method in class org.hibernate.tuple.entity.Dom4jEntityTuplizer

getIdentifier(Object) - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Extract the identifier value from the given entity.
getIdentifier(Object, SessionImplementor) - Method in class org.hibernate.type.EntityType

getIdentifierAliases(Loadable, String) - Method in class org.hibernate.loader.ColumnEntityAliases

getIdentifierAliases(Loadable, String) - Method in class org.hibernate.loader.DefaultEntityAliases

getIdentifierAliases() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getIdentifierAliases(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getIdentifierAliases(String) - Method in interface org.hibernate.persister.entity.Loadable
Get the result set aliases used for the identifier columns, given a suffix
getIdentifierColumnAlias(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getIdentifierColumnAlias(String) - Method in interface org.hibernate.persister.collection.CollectionPersister
Generates the collection's identifier column aliases, based on the given suffix.
getIdentifierColumnName() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getIdentifierColumnName() - Method in interface org.hibernate.persister.collection.SQLLoadableCollection

getIdentifierColumnNames() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getIdentifierColumnNames() - Method in class org.hibernate.persister.entity.AbstractPropertyMapping

getIdentifierColumnNames() - Method in class org.hibernate.persister.entity.BasicEntityPropertyMapping

getIdentifierColumnNames() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getIdentifierColumnNames() - Method in interface org.hibernate.persister.entity.Loadable
Get the names of columns used to persist the identifier
getIdentifierColumnNames() - Method in interface org.hibernate.persister.entity.Queryable
Get the names of columns used to persist the identifier
getIdentifierColumnSpan() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getIdentifierColumns(Criteria) - Method in interface org.hibernate.criterion.CriteriaQuery
Get the identifier column names of this entity
getIdentifierColumns(Criteria) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getIdentifierGenerator(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get the identifier generator for the hierarchy
getIdentifierGenerator(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getIdentifierGenerator() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getIdentifierGenerator() - Method in interface org.hibernate.persister.collection.CollectionPersister
Get the surrogate key generation strategy (optional operation)
getIdentifierGenerator() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getIdentifierGenerator() - Method in interface org.hibernate.persister.entity.EntityPersister
Return the IdentifierGenerator for the class
getIdentifierGenerator() - Method in class org.hibernate.tuple.IdentifierProperty

getIdentifierGeneratorClass(String, Dialect) - Static method in class org.hibernate.id.IdentifierGeneratorFactory

getIdentifierGeneratorProperties() - Method in class org.hibernate.mapping.SimpleValue

getIdentifierGeneratorStrategy() - Method in class org.hibernate.mapping.SimpleValue
Returns the identifierGeneratorStrategy.
getIdentifierMapper() - Method in class org.hibernate.mapping.PersistentClass

getIdentifierMapper() - Method in class org.hibernate.mapping.Subclass

getIdentifierMethod - Variable in class org.hibernate.proxy.pojo.BasicLazyInitializer

getIdentifierOrUniqueKeyPropertyName(EntityType) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Determine the name of the property for the entity encapsulated by the given type which represents the id or unique-key.
getIdentifierOrUniqueKeyPropertyName(Mapping) - Method in class org.hibernate.type.EntityType

getIdentifierOrUniqueKeyType(Mapping) - Method in class org.hibernate.type.EntityType

getIdentifierProperty() - Method in class org.hibernate.mapping.PersistentClass

getIdentifierProperty() - Method in class org.hibernate.mapping.RootClass

getIdentifierProperty() - Method in class org.hibernate.mapping.Subclass

getIdentifierProperty() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getIdentifierPropertyName(String) - Method in interface org.hibernate.engine.Mapping

getIdentifierPropertyName(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getIdentifierPropertyName() - Method in interface org.hibernate.metadata.ClassMetadata
Get the name of the identifier property (or return null)
getIdentifierPropertyName() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getIdentifierPropertyName() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the name of the identifier property (or return null) - need not return the name of an actual Java property
getIdentifierType(Criteria) - Method in interface org.hibernate.criterion.CriteriaQuery
Get the identifier type of this entity
getIdentifierType(String) - Method in interface org.hibernate.engine.Mapping

getIdentifierType(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getIdentifierType(Criteria) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getIdentifierType() - Method in class org.hibernate.mapping.Any

getIdentifierType() - Method in interface org.hibernate.metadata.ClassMetadata
Get the identifier Hibernate type
getIdentifierType() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getIdentifierType() - Method in interface org.hibernate.persister.collection.CollectionPersister
Get the type of the surrogate key
getIdentifierType() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getIdentifierType() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the identifier type
getIdentifierValue() - Method in class org.hibernate.mapping.Table

getIdentityColumn() - Method in class org.hibernate.hql.ast.tree.FromElement

getIdentityColumnString() - Method in class org.hibernate.dialect.DB2Dialect

getIdentityColumnString() - Method in class org.hibernate.dialect.DerbyDialect
This is different in Cloudscape to DB2.
getIdentityColumnString() - Method in class org.hibernate.dialect.Dialect

getIdentityColumnString(int) - Method in class org.hibernate.dialect.Dialect
The keyword used to specify an identity column, if identity column key generation is supported.
getIdentityColumnString() - Method in class org.hibernate.dialect.H2Dialect

getIdentityColumnString() - Method in class org.hibernate.dialect.HSQLDialect

getIdentityColumnString(int) - Method in class org.hibernate.dialect.InformixDialect

getIdentityColumnString() - Method in class org.hibernate.dialect.JDataStoreDialect

getIdentityColumnString() - Method in class org.hibernate.dialect.MySQLDialect

getIdentityColumnString(int) - Method in class org.hibernate.dialect.PostgreSQLDialect

getIdentityColumnString() - Method in class org.hibernate.dialect.SybaseDialect

getIdentityInsertString() - Method in class org.hibernate.dialect.DB2Dialect

getIdentityInsertString() - Method in class org.hibernate.dialect.Dialect
The keyword used to insert a generated value into an identity column (or null).
getIdentityInsertString() - Method in class org.hibernate.dialect.H2Dialect

getIdentityInsertString() - Method in class org.hibernate.dialect.HSQLDialect

getIdentitySelectString() - Method in class org.hibernate.dialect.DB2390Dialect

getIdentitySelectString() - Method in class org.hibernate.dialect.DB2400Dialect

getIdentitySelectString() - Method in class org.hibernate.dialect.DB2Dialect

getIdentitySelectString() - Method in class org.hibernate.dialect.Dialect

getIdentitySelectString(String, String, int) - Method in class org.hibernate.dialect.Dialect
The syntax that returns the identity value of the last insert, if identity column key generation is supported.
getIdentitySelectString() - Method in class org.hibernate.dialect.H2Dialect

getIdentitySelectString() - Method in class org.hibernate.dialect.HSQLDialect

getIdentitySelectString(String, String, int) - Method in class org.hibernate.dialect.InformixDialect

getIdentitySelectString() - Method in class org.hibernate.dialect.JDataStoreDialect

getIdentitySelectString() - Method in class org.hibernate.dialect.MySQLDialect

getIdentitySelectString(String, String, int) - Method in class org.hibernate.dialect.PostgreSQLDialect

getIdentitySelectString() - Method in class org.hibernate.dialect.SybaseDialect

getIdentitySelectString() - Method in interface org.hibernate.id.PostInsertIdentityPersister
Get the database-specific SQL command to retrieve the last generated IDENTITY value.
getIdentitySelectString() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getIdentityTable() - Method in class org.hibernate.mapping.PersistentClass

getIdentityTable() - Method in class org.hibernate.mapping.UnionSubclass

getIdentityTables() - Method in class org.hibernate.mapping.RootClass

getImplementation() - Method in class org.hibernate.proxy.AbstractLazyInitializer
Return the underlying persistent object, initializing if necessary
getImplementation(SessionImplementor) - Method in class org.hibernate.proxy.AbstractLazyInitializer
Return the underlying persistent object in the given Session, or null, do not initialize the proxy
getImplementation() - Method in interface org.hibernate.proxy.LazyInitializer
Return the underlying persistent object, initializing if necessary
getImplementation(SessionImplementor) - Method in interface org.hibernate.proxy.LazyInitializer
Return the underlying persistent object in the given Session, or null
getImplementors(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get the names of all persistent classes that implement/extend the given interface/class
getImplementors(String) - Method in class org.hibernate.impl.SessionFactoryImpl
Return the names of all persistent (mapped) classes that extend or implement the given class or interface, accounting for implicit/explicit polymorphism settings and excluding mapped subclasses/joined-subclasses of other classes in the result.
getImpliedJoin() - Method in class org.hibernate.hql.ast.tree.DotNode

getImpliedJoin() - Method in class org.hibernate.hql.ast.tree.FromReferenceNode
Sub-classes can override this method if they produce implied joins (e.g.
getImpliedJoinType() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getImportedClass(String, SessionFactoryImplementor) - Static method in class org.hibernate.hql.QuerySplitter

getImportedClassName(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get a class name, using query language imports
getImportedClassName(String) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Given a (potentially unqualified) class name, locate its imported qualified name.
getImportedClassName(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getImports() - Method in class org.hibernate.cfg.Configuration
Get the query language imports
getInList() - Method in class org.hibernate.hql.ast.tree.InLogicOperatorNode

getIndex() - Method in class org.hibernate.bytecode.javassist.BulkAccessorException
Returns the index of the property that causes this exception.
getIndex(String, Class[]) - Method in class org.hibernate.bytecode.javassist.FastClass

getIndex(Class[]) - Method in class org.hibernate.bytecode.javassist.FastClass

getIndex(Object, int, CollectionPersister) - Method in class org.hibernate.collection.PersistentArrayHolder

getIndex(Object, int, CollectionPersister) - Method in class org.hibernate.collection.PersistentBag

getIndex(Object, int, CollectionPersister) - Method in interface org.hibernate.collection.PersistentCollection
Get the index of the given collection entry
getIndex(Object, int, CollectionPersister) - Method in class org.hibernate.collection.PersistentElementHolder

getIndex(Object, int, CollectionPersister) - Method in class org.hibernate.collection.PersistentIdentifierBag

getIndex(Element, String, int) - Static method in class org.hibernate.collection.PersistentIndexedElementHolder

getIndex(Object, int, CollectionPersister) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

getIndex(Object, int, CollectionPersister) - Method in class org.hibernate.collection.PersistentList

getIndex(Object, int, CollectionPersister) - Method in class org.hibernate.collection.PersistentMap

getIndex(Object, int, CollectionPersister) - Method in class org.hibernate.collection.PersistentSet

getIndex() - Method in class org.hibernate.mapping.IndexedCollection

getIndex(String) - Method in class org.hibernate.mapping.Table

getIndexAttributeName(CollectionPersister) - Static method in class org.hibernate.collection.PersistentIndexedElementHolder

getIndexColumnAliases(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getIndexColumnAliases(String) - Method in interface org.hibernate.persister.collection.CollectionPersister
Generates the collection's index column aliases, based on the given suffix.
getIndexColumnNames() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getIndexColumnNames(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getIndexColumnNames() - Method in interface org.hibernate.persister.collection.QueryableCollection
Get the names of the collection index columns if this is an indexed collection (optional operation)
getIndexColumnNames(String) - Method in interface org.hibernate.persister.collection.QueryableCollection
Get the names of the collection index columns if this is an indexed collection (optional operation), aliased by the given table alias
getIndexForColumnName(String, ResultSetWrapper) - Method in class org.hibernate.jdbc.ColumnNameCache

getIndexFormulas() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getIndexFormulas() - Method in interface org.hibernate.persister.collection.QueryableCollection
Get the index formulas if this is an indexed collection (optional operation)
getIndexInOwner(String, String, Object, Map) - Method in interface org.hibernate.engine.PersistenceContext
Search the persistence context for an index of the child object, given a collection role
getIndexInOwner(String, String, Object, Map) - Method in class org.hibernate.engine.StatefulPersistenceContext
Search the persistence context for an index of the child object, given a collection role
getIndexIterator() - Method in class org.hibernate.mapping.DenormalizedTable

getIndexIterator() - Method in class org.hibernate.mapping.Table

getIndexMetadata(String) - Method in class org.hibernate.tool.hbm2ddl.TableMetadata

getIndexNodeName() - Method in class org.hibernate.mapping.IndexedCollection

getIndexNodeName() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getIndexNodeName() - Method in interface org.hibernate.persister.collection.CollectionPersister

getIndexType() - Method in interface org.hibernate.metadata.CollectionMetadata
The collection index type (or null if the collection has no index)
getIndexType() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getIndexType() - Method in interface org.hibernate.persister.collection.CollectionPersister
Get the "index" type for a list or map (optional operation)
getInitialContext(Properties) - Static method in class org.hibernate.util.NamingHelper

getInitializeCollectionEventListeners() - Method in class org.hibernate.event.EventListeners

getInsertCheckStyle() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getInsertCount() - Method in class org.hibernate.stat.EntityStatistics

getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister, Dialect, boolean) - Method in class org.hibernate.id.IdentityGenerator

getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister, Dialect, boolean) - Method in interface org.hibernate.id.PostInsertIdentifierGenerator

getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister, Dialect, boolean) - Method in class org.hibernate.id.SelectGenerator

getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister, Dialect, boolean) - Method in class org.hibernate.id.SequenceIdentityGenerator

getInsertionTypes() - Method in class org.hibernate.hql.ast.tree.IntoClause

getInstance() - Method in class org.hibernate.action.EntityAction

getInstance(String) - Static method in class org.hibernate.hql.ast.HqlParser

getInstance(String) - Static method in class org.hibernate.impl.SessionFactoryObjectFactory

getInstanceToLoad() - Method in class org.hibernate.event.LoadEvent

getInstantiationOptimizer() - Method in interface org.hibernate.bytecode.ReflectionOptimizer

getInstantiationOptimizer() - Method in class org.hibernate.bytecode.cglib.ReflectionOptimizerImpl

getInstantiationOptimizer() - Method in class org.hibernate.bytecode.javassist.ReflectionOptimizerImpl

getInstantiator() - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

getInt(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getInt(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getInt(String, Properties, int) - Static method in class org.hibernate.util.PropertiesHelper

getInteger(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read an integer
getInteger(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getInteger(String, Properties) - Static method in class org.hibernate.util.PropertiesHelper

getInterceptor() - Method in class org.hibernate.cfg.Configuration
Return the configured Interceptor
getInterceptor() - Method in interface org.hibernate.engine.SessionFactoryImplementor

getInterceptor() - Method in interface org.hibernate.engine.SessionImplementor
Retrieves the interceptor currently in use by this event source.
getInterceptor() - Method in class org.hibernate.impl.SessionFactoryImpl

getInterceptor() - Method in class org.hibernate.impl.SessionImpl

getInterceptor() - Method in class org.hibernate.impl.StatelessSessionImpl

getIntoClause() - Method in class org.hibernate.hql.ast.tree.InsertStatement
Retreive this insert statement's into-clause.
getJDBCContext() - Method in interface org.hibernate.engine.SessionImplementor

getJDBCContext() - Method in class org.hibernate.impl.SessionImpl

getJDBCContext() - Method in class org.hibernate.impl.StatelessSessionImpl

getJVM() - Method in class org.hibernate.id.AbstractUUIDGenerator
Unique across JVMs on this machine (unless they load this class in the same quater second - very unlikely)
getJavaClass() - Method in class org.hibernate.bytecode.javassist.FastClass

getJdbcBatchSize() - Method in class org.hibernate.cfg.Settings

getJdbcBatchSize() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Get the maximum JDBC batch size
getJdbcBatchSize() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getJdbcFetchSize() - Method in class org.hibernate.cfg.Settings

getJdbcFetchSize() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Get the JDBC fetch size
getJdbcFetchSize() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getJdbcScrollableResultSetEnabled() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Is use of scrollable resultsets enabled?
getJdbcScrollableResultSetEnabled() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getJndiName() - Method in class org.hibernate.jmx.HibernateService

getJndiName() - Method in interface org.hibernate.jmx.HibernateServiceMBean
The JNDI name to bind to the SessionFactory
getJndiProperties(Properties) - Static method in class org.hibernate.util.NamingHelper
Transform JNDI properties passed in the form hibernate.jndi.* to the format accepted by InitialContext by triming the leading "hibernate.jndi".
getJoinClosureIterator() - Method in class org.hibernate.mapping.PersistentClass

getJoinClosureIterator() - Method in class org.hibernate.mapping.Subclass

getJoinClosureSpan() - Method in class org.hibernate.mapping.PersistentClass

getJoinClosureSpan() - Method in class org.hibernate.mapping.Subclass

getJoinCount() - Method in class org.hibernate.engine.JoinSequence

getJoinFragment() - Method in class org.hibernate.sql.QuerySelect

getJoinIterator() - Method in class org.hibernate.mapping.PersistentClass

getJoinNumber(Property) - Method in class org.hibernate.mapping.PersistentClass

getJoinSequence() - Method in class org.hibernate.hql.ast.tree.FromElement

getJoinType() - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

getJoinType(AssociationType, FetchMode, String, String, String[], boolean, int, CascadeStyle) - Method in class org.hibernate.loader.JoinWalker
Get the join type (inner, outer, etc) or -1 if the association should not be joined.
getJoinType(boolean, int) - Method in class org.hibernate.loader.JoinWalker
Use an inner join if it is a non-null association and this is the "first" join in a series
getJoinType() - Method in class org.hibernate.loader.OuterJoinableAssociation

getJoinType(AssociationType, FetchMode, String, Set, String, String[], boolean, int) - Method in class org.hibernate.loader.collection.BasicCollectionJoinWalker
We can use an inner join for first many-to-many association
getJoinType(AssociationType, FetchMode, String, String, String[], boolean, int, CascadeStyle) - Method in class org.hibernate.loader.criteria.CriteriaJoinWalker

getJoinType(String) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getJoinable() - Method in class org.hibernate.loader.OuterJoinableAssociation

getJoinableType() - Method in class org.hibernate.loader.OuterJoinableAssociation

getKey() - Method in class org.hibernate.action.CollectionAction

getKey() - Method in class org.hibernate.cache.CacheKey

getKey() - Method in class org.hibernate.collection.AbstractPersistentCollection

getKey() - Method in interface org.hibernate.collection.PersistentCollection
Get the current collection key value
getKey() - Method in class org.hibernate.engine.CollectionEntry

getKey() - Method in class org.hibernate.engine.CollectionKey

getKey() - Method in class org.hibernate.engine.EntityUniqueKey

getKey() - Method in class org.hibernate.mapping.Collection

getKey() - Method in class org.hibernate.mapping.Join

getKey() - Method in class org.hibernate.mapping.JoinedSubclass

getKey() - Method in class org.hibernate.mapping.PersistentClass

getKey() - Method in class org.hibernate.mapping.RootClass

getKey() - Method in class org.hibernate.mapping.Subclass

getKey() - Method in class org.hibernate.util.IdentityMap.IdentityMapEntry

getKeyClosureIterator() - Method in class org.hibernate.mapping.PersistentClass

getKeyClosureIterator() - Method in class org.hibernate.mapping.RootClass

getKeyClosureIterator() - Method in class org.hibernate.mapping.Subclass

getKeyColumnAliases(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getKeyColumnAliases(String) - Method in interface org.hibernate.persister.collection.CollectionPersister
Generates the collection's key column aliases, based on the given suffix.
getKeyColumnNames() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getKeyColumnNames() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getKeyColumnNames() - Method in interface org.hibernate.persister.entity.Joinable
The columns to join on
getKeyColumns(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getKeyColumns(int) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getKeyColumns(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getKeyColumns(int) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getKeyOfOwner(Object, SessionImplementor) - Method in class org.hibernate.type.CollectionType
Get the key value from the owning entity instance, usually the identifier, but might be some other unique key, in the case of property-ref
getKeyType() - Method in class org.hibernate.loader.collection.CollectionLoader

getKeyType() - Method in interface org.hibernate.metadata.CollectionMetadata
The collection key type
getKeyType() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getKeyType() - Method in interface org.hibernate.persister.collection.CollectionPersister
Get the "key" type (the type of the foreign key)
getKeywords() - Method in class org.hibernate.dialect.Dialect

getLHSColumnNames(AssociationType, int, OuterJoinLoadable, Mapping) - Static method in class org.hibernate.engine.JoinHelper
Get the columns of the owning entity which are to be used in the join
getLHSColumnNames(AssociationType, int, int, OuterJoinLoadable, Mapping) - Static method in class org.hibernate.engine.JoinHelper
Get the columns of the owning entity which are to be used in the join
getLHSPropertyName() - Method in class org.hibernate.type.AnyType

getLHSPropertyName() - Method in interface org.hibernate.type.AssociationType
Get the name of a property in the owning entity that provides the join key (null if the identifier)
getLHSPropertyName() - Method in class org.hibernate.type.CollectionType

getLHSPropertyName() - Method in class org.hibernate.type.EntityType

getLHSTableName(AssociationType, int, OuterJoinLoadable) - Static method in class org.hibernate.engine.JoinHelper

getLastChar() - Method in class org.hibernate.hql.antlr.SqlGeneratorBase
Returns the last character written to the output, or -1 if there isn't one.
getLastChild(AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil
Returns the last direct child of 'n'.
getLazyProperties() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getLeftHandOperand() - Method in class org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode
Retrieves the left-hand operand of the operator.
getLeftHandOperand() - Method in class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode
Retrieves the left-hand operand of the operator.
getLeftHandOperand() - Method in interface org.hibernate.hql.ast.tree.BinaryOperatorNode
Retrieves the left-hand operand of the operator.
getLength() - Method in class org.hibernate.criterion.ProjectionList

getLength() - Method in class org.hibernate.mapping.Column

getLevel() - Method in class org.hibernate.hql.ast.tree.FromClause

getLhs() - Method in class org.hibernate.hql.ast.tree.DotNode

getLimitString(String, int, int) - Method in class org.hibernate.dialect.DB2390Dialect

getLimitString(String, int, int) - Method in class org.hibernate.dialect.DB2400Dialect

getLimitString(String, boolean) - Method in class org.hibernate.dialect.DB2Dialect

getLimitString(String, boolean) - Method in class org.hibernate.dialect.Dialect
Add a LIMIT clause to the given SQL SELECT
getLimitString(String, int, int) - Method in class org.hibernate.dialect.Dialect

getLimitString(String, boolean) - Method in class org.hibernate.dialect.FirebirdDialect

getLimitString(String, boolean) - Method in class org.hibernate.dialect.H2Dialect

getLimitString(String, boolean) - Method in class org.hibernate.dialect.HSQLDialect

getLimitString(String, int, int) - Method in class org.hibernate.dialect.InformixDialect

getLimitString(String, int, int) - Method in class org.hibernate.dialect.IngresDialect
Add a LIMIT clause to the given SQL SELECT
getLimitString(String, boolean) - Method in class org.hibernate.dialect.InterbaseDialect

getLimitString(String, boolean) - Method in class org.hibernate.dialect.MySQLDialect

getLimitString(String, boolean) - Method in class org.hibernate.dialect.Oracle9Dialect

getLimitString(String, boolean) - Method in class org.hibernate.dialect.OracleDialect

getLimitString(String, boolean) - Method in class org.hibernate.dialect.PostgreSQLDialect

getLimitString(String, int, int) - Method in class org.hibernate.dialect.RDMSOS2200Dialect

getLimitString(String, int, int) - Method in class org.hibernate.dialect.SQLServerDialect

getLimitString(String, int, int) - Method in class org.hibernate.dialect.TimesTenDialect

getLine() - Method in class org.hibernate.hql.ast.tree.Node

getListenerClassFor(String) - Method in class org.hibernate.event.EventListeners

getListeners() - Method in interface org.hibernate.engine.SessionImplementor
Retrieves the configured event listeners from this event source.
getListeners() - Method in class org.hibernate.impl.SessionImpl

getListeners() - Method in class org.hibernate.impl.StatelessSessionImpl

getLiteralProcessor() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getLoTime() - Method in class org.hibernate.id.AbstractUUIDGenerator

getLoadCount() - Method in class org.hibernate.stat.CollectionStatistics

getLoadCount() - Method in class org.hibernate.stat.EntityStatistics

getLoadEventListeners() - Method in class org.hibernate.event.EventListeners

getLoadedElementsIterator(SessionImplementor, CollectionType, Object) - Static method in class org.hibernate.engine.CascadingAction
Iterate just the elements of the collection that are already there.
getLoadedKey() - Method in class org.hibernate.engine.CollectionEntry

getLoadedPersister() - Method in class org.hibernate.engine.CollectionEntry
This is only available late during the flush cycle
getLoadedState() - Method in class org.hibernate.engine.EntityEntry

getLoadedValue(String) - Method in class org.hibernate.engine.EntityEntry

getLoader() - Method in class org.hibernate.impl.AbstractScrollableResults

getLoaderName() - Method in class org.hibernate.mapping.Collection

getLoaderName() - Method in class org.hibernate.mapping.PersistentClass

getLoadingCollection(CollectionPersister, Serializable, Object, EntityMode) - Method in class org.hibernate.engine.CollectionLoadContext
Retrieve a collection that is in the process of being loaded, instantiating a new collection if there is nothing for the given id, or returning null if the collection with the given id is already fully loaded in the session
getLoadingCollection(CollectionPersister, Serializable, EntityMode) - Method in class org.hibernate.engine.CollectionLoadContext
Retrieve a collection that is in the process of being loaded, returning null if there is no loading collection with the given id
getLocale(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a locale
getLocale(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getLockEventListeners() - Method in class org.hibernate.event.EventListeners

getLockMode() - Method in class org.hibernate.dialect.lock.SelectLockingStrategy

getLockMode() - Method in class org.hibernate.dialect.lock.UpdateLockingStrategy

getLockMode() - Method in class org.hibernate.engine.EntityEntry

getLockMode() - Method in class org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn
Retrieve the lock-mode to apply to this return
getLockMode() - Method in class org.hibernate.event.LoadEvent

getLockMode() - Method in class org.hibernate.event.LockEvent

getLockMode() - Method in class org.hibernate.event.RefreshEvent

getLockMode() - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

getLockMode() - Method in class org.hibernate.loader.custom.NonScalarReturn

getLockMode() - Method in class org.hibernate.sql.Select

getLockModeArray() - Method in class org.hibernate.loader.JoinWalker

getLockModes() - Method in class org.hibernate.engine.QueryParameters

getLockModes(Map) - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getLockModes() - Method in class org.hibernate.impl.AbstractQueryImpl

getLockModes() - Method in class org.hibernate.impl.CriteriaImpl

getLockModes() - Method in class org.hibernate.impl.QueryImpl

getLockModes() - Method in class org.hibernate.impl.SQLQueryImpl

getLockModes(Map) - Method in class org.hibernate.loader.Loader
What lock mode does this load entities with?
getLockModes(Map) - Method in class org.hibernate.loader.OuterJoinLoader

getLockModes(Map) - Method in class org.hibernate.loader.criteria.CriteriaLoader

getLockModes(Map) - Method in class org.hibernate.loader.custom.CustomLoader

getLockModes(Map) - Method in class org.hibernate.loader.hql.QueryLoader

getLockingStrategy(Lockable, LockMode) - Method in class org.hibernate.dialect.Dialect
Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.
getLockingStrategy(Lockable, LockMode) - Method in class org.hibernate.dialect.FrontBaseDialect

getLockingStrategy(Lockable, LockMode) - Method in class org.hibernate.dialect.HSQLDialect

getLockingStrategy(Lockable, LockMode) - Method in class org.hibernate.dialect.MckoiDialect

getLockingStrategy(Lockable, LockMode) - Method in class org.hibernate.dialect.PointbaseDialect

getLockingStrategy(Lockable, LockMode) - Method in class org.hibernate.dialect.RDMSOS2200Dialect

getLockingStrategy(Lockable, LockMode) - Method in class org.hibernate.dialect.TimesTenDialect

getLog() - Method in class org.hibernate.hql.ast.tree.AbstractRestrictableStatement

getLog() - Method in class org.hibernate.hql.ast.tree.DeleteStatement

getLog() - Method in class org.hibernate.hql.ast.tree.QueryNode

getLog() - Method in class org.hibernate.hql.ast.tree.UpdateStatement

getLoggableName(String, Object) - Method in class org.hibernate.event.def.AbstractSaveEventListener

getLogicalColumnName(String, Table) - Method in class org.hibernate.cfg.Mappings

getLogicalTableName(Table) - Method in class org.hibernate.cfg.Mappings

getLong(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a long
getLong(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getLong(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getLong(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getLowOperand() - Method in class org.hibernate.hql.ast.tree.BetweenOperatorNode

getLowercaseFunction() - Method in class org.hibernate.dialect.DB2Dialect

getLowercaseFunction() - Method in class org.hibernate.dialect.Dialect
The name of the SQL function that transforms a string to lowercase
getLowercaseFunction() - Method in class org.hibernate.dialect.IngresDialect
The name of the SQL function that transforms a string to lowercase
getManyToManyFilterFragment(String, Map) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getManyToManyFilterFragment(String, Map) - Method in interface org.hibernate.persister.collection.CollectionPersister

getManyToManyFilterMap() - Method in class org.hibernate.mapping.Collection

getManyToManyOrderByString(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getManyToManyOrderByString(String) - Method in interface org.hibernate.persister.collection.QueryableCollection
Get the order-by to be applied at the target table of a many to many
getManyToManyOrdering() - Method in class org.hibernate.mapping.Collection

getManyToManyWhere() - Method in class org.hibernate.mapping.Collection

getMap() - Method in class org.hibernate.proxy.map.MapLazyInitializer

getMapResources() - Method in interface org.hibernate.jmx.HibernateServiceMBean
The Hibernate mapping files (might be overridden by subclasses that want to specify the mapping files by some other mechanism)
getMapResources() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getMappedClass() - Method in class org.hibernate.mapping.PersistentClass

getMappedClass(EntityMode) - Method in interface org.hibernate.metadata.ClassMetadata
The persistent class, or null
getMappedClass(EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getMappedClass(EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
The persistent class, or null
getMappedClass() - Method in interface org.hibernate.tuple.Tuplizer
Return the pojo class managed by this tuplizer.
getMappedClass() - Method in class org.hibernate.tuple.component.Dom4jComponentTuplizer

getMappedClass() - Method in class org.hibernate.tuple.component.DynamicMapComponentTuplizer

getMappedClass() - Method in class org.hibernate.tuple.component.PojoComponentTuplizer

getMappedClass() - Method in class org.hibernate.tuple.entity.Dom4jEntityTuplizer

getMappedClass() - Method in class org.hibernate.tuple.entity.DynamicMapEntityTuplizer

getMappedClass() - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

getMappedSuperclass() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getMappedSuperclass() - Method in interface org.hibernate.persister.entity.Queryable
Get the class that this class is mapped as a subclass of - not necessarily the direct superclass
getMappingPackage() - Method in class org.hibernate.cfg.ExtendsQueueEntry

getMaxAliasLength() - Method in class org.hibernate.dialect.Dialect

getMaxIndex() - Method in class org.hibernate.bytecode.javassist.FastClass

getMaxResults() - Method in class org.hibernate.impl.CriteriaImpl

getMaxRows() - Method in class org.hibernate.engine.RowSelection

getMaximumFetchDepth() - Method in class org.hibernate.cfg.Settings

getMaximumFetchDepth() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Get the maximum outer join fetch depth
getMaximumFetchDepth() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getMergeEventListeners() - Method in class org.hibernate.event.EventListeners

getMergeMap(Object) - Method in class org.hibernate.event.def.AbstractSaveEventListener

getMergeMap(Object) - Method in class org.hibernate.event.def.DefaultMergeEventListener

getMessage() - Method in class org.hibernate.InstantiationException

getMessage() - Method in class org.hibernate.NonUniqueObjectException

getMessage() - Method in class org.hibernate.PropertyAccessException

getMessage() - Method in class org.hibernate.PropertyValueException

getMessage() - Method in class org.hibernate.QueryException

getMessage() - Method in class org.hibernate.StaleObjectStateException

getMessage() - Method in class org.hibernate.UnresolvableObjectException

getMessage() - Method in class org.hibernate.WrongClassException

getMessage() - Method in interface org.hibernate.exception.Nestable
Returns the error message of this and any nested Throwable.
getMessage(int) - Method in interface org.hibernate.exception.Nestable
Returns the error message of the Throwable in the chain of Throwables at the specified index, numbererd from 0.
getMessage(int) - Method in class org.hibernate.exception.NestableDelegate
Returns the error message of the Throwable in the chain of Throwables at the specified index, numbererd from 0.
getMessage(String) - Method in class org.hibernate.exception.NestableDelegate
Returns the full message contained by the Nestable and any nested Throwables.
getMessage() - Method in class org.hibernate.exception.NestableException
Returns the detail message string of this throwable.
getMessage(int) - Method in class org.hibernate.exception.NestableException

getMessage() - Method in class org.hibernate.exception.NestableRuntimeException
Returns the detail message string of this throwable.
getMessage(int) - Method in class org.hibernate.exception.NestableRuntimeException

getMessages() - Method in interface org.hibernate.exception.Nestable
Returns the error message of this and any nested Throwables in an array of Strings, one element for each message.
getMessages() - Method in class org.hibernate.exception.NestableDelegate
Returns the error message of this and any nested Throwables in an array of Strings, one element for each message.
getMessages() - Method in class org.hibernate.exception.NestableException

getMessages() - Method in class org.hibernate.exception.NestableRuntimeException

getMetaAttribute(String) - Method in class org.hibernate.mapping.Component

getMetaAttribute(String) - Method in interface org.hibernate.mapping.MetaAttributable

getMetaAttribute(String) - Method in class org.hibernate.mapping.PersistentClass

getMetaAttribute(String) - Method in class org.hibernate.mapping.Property

getMetaAttributes() - Method in class org.hibernate.mapping.Component

getMetaAttributes() - Method in interface org.hibernate.mapping.MetaAttributable

getMetaAttributes() - Method in class org.hibernate.mapping.PersistentClass

getMetaAttributes() - Method in class org.hibernate.mapping.Property

getMetaData() - Method in class org.hibernate.jdbc.ResultSetWrapper

getMetaType() - Method in class org.hibernate.mapping.Any

getMetaValues() - Method in class org.hibernate.mapping.Any

getMetas(Element, Map, boolean) - Static method in class org.hibernate.cfg.HbmBinder

getMethod() - Method in class org.hibernate.property.BackrefPropertyAccessor.BackrefGetter

getMethod() - Method in class org.hibernate.property.BackrefPropertyAccessor.BackrefSetter

getMethod() - Method in class org.hibernate.property.BasicPropertyAccessor.BasicGetter

getMethod() - Method in class org.hibernate.property.BasicPropertyAccessor.BasicSetter

getMethod() - Method in class org.hibernate.property.DirectPropertyAccessor.DirectGetter

getMethod() - Method in class org.hibernate.property.DirectPropertyAccessor.DirectSetter

getMethod() - Method in class org.hibernate.property.Dom4jAccessor.Dom4jGetter
Optional operation (return null)
getMethod() - Method in class org.hibernate.property.Dom4jAccessor.Dom4jSetter
Optional operation (return null)
getMethod() - Method in class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter

getMethod() - Method in class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedSetter

getMethod() - Method in interface org.hibernate.property.Getter
Optional operation (return null)
getMethod() - Method in class org.hibernate.property.IndexPropertyAccessor.IndexGetter

getMethod() - Method in class org.hibernate.property.IndexPropertyAccessor.IndexSetter

getMethod() - Method in class org.hibernate.property.MapAccessor.MapGetter

getMethod() - Method in class org.hibernate.property.MapAccessor.MapSetter

getMethod() - Method in interface org.hibernate.property.Setter
Optional operation (return null)
getMethod(Class, Method) - Static method in class org.hibernate.util.ReflectHelper

getMethodName() - Method in class org.hibernate.property.BackrefPropertyAccessor.BackrefGetter

getMethodName() - Method in class org.hibernate.property.BackrefPropertyAccessor.BackrefSetter

getMethodName() - Method in class org.hibernate.property.BasicPropertyAccessor.BasicGetter

getMethodName() - Method in class org.hibernate.property.BasicPropertyAccessor.BasicSetter

getMethodName() - Method in class org.hibernate.property.DirectPropertyAccessor.DirectGetter

getMethodName() - Method in class org.hibernate.property.DirectPropertyAccessor.DirectSetter

getMethodName() - Method in class org.hibernate.property.Dom4jAccessor.Dom4jGetter
Optional operation (return null)
getMethodName() - Method in class org.hibernate.property.Dom4jAccessor.Dom4jSetter
Optional operation (return null)
getMethodName() - Method in class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter

getMethodName() - Method in class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedSetter

getMethodName() - Method in interface org.hibernate.property.Getter
Optional operation (return null)
getMethodName() - Method in class org.hibernate.property.IndexPropertyAccessor.IndexGetter

getMethodName() - Method in class org.hibernate.property.IndexPropertyAccessor.IndexSetter

getMethodName() - Method in class org.hibernate.property.MapAccessor.MapGetter

getMethodName() - Method in class org.hibernate.property.MapAccessor.MapSetter

getMethodName() - Method in interface org.hibernate.property.Setter
Optional operation (return null)
getMinimalPutsEnabled() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Is the second-level cache optimized for miminal puts?
getMinimalPutsEnabled() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getMissCount() - Method in class org.hibernate.stat.SecondLevelCacheStatistics

getName() - Method in class org.hibernate.DuplicateMappingException

getName() - Method in interface org.hibernate.Filter
Get the name of this filter.
getName() - Method in class org.hibernate.bytecode.javassist.FastClass

getName() - Method in interface org.hibernate.bytecode.util.ClassDescriptor
The name of the class.
getName() - Method in class org.hibernate.engine.ResultSetMappingDefinition

getName() - Method in class org.hibernate.engine.query.NamedParameterDescriptor

getName() - Method in class org.hibernate.event.LoadEventListener.LoadType

getName() - Method in class org.hibernate.hql.classic.PathExpressionParser

getName() - Method in class org.hibernate.impl.FilterImpl
Get the name of this filter.
getName() - Method in class org.hibernate.jmx.HibernateService

getName() - Method in class org.hibernate.mapping.Column

getName() - Method in class org.hibernate.mapping.Constraint

getName() - Method in class org.hibernate.mapping.Index

getName() - Method in class org.hibernate.mapping.MetaAttribute

getName() - Method in class org.hibernate.mapping.Property

getName() - Method in class org.hibernate.mapping.PropertyGeneration

getName() - Method in class org.hibernate.mapping.Table

getName() - Method in class org.hibernate.param.NamedParameterSpecification

getName() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getName() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getName() - Method in interface org.hibernate.persister.entity.Joinable
An identifying name; a class name or collection role name.
getName() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getName() - Method in class org.hibernate.tool.hbm2ddl.ColumnMetadata

getName() - Method in class org.hibernate.tool.hbm2ddl.ForeignKeyMetadata

getName() - Method in class org.hibernate.tool.hbm2ddl.IndexMetadata

getName() - Method in class org.hibernate.tool.hbm2ddl.TableMetadata

getName() - Method in class org.hibernate.transaction.BESTransactionManagerLookup

getName() - Method in class org.hibernate.transaction.JBossTransactionManagerLookup

getName() - Method in class org.hibernate.transaction.JNDITransactionManagerLookup

getName() - Method in class org.hibernate.transaction.JRun4TransactionManagerLookup

getName() - Method in class org.hibernate.transaction.OC4JTransactionManagerLookup

getName() - Method in class org.hibernate.transaction.OrionTransactionManagerLookup

getName() - Method in class org.hibernate.transaction.ResinTransactionManagerLookup

getName() - Method in class org.hibernate.transaction.SunONETransactionManagerLookup

getName() - Method in class org.hibernate.transaction.WeblogicTransactionManagerLookup

getName() - Method in class org.hibernate.tuple.ElementWrapper

getName() - Method in class org.hibernate.tuple.Property

getName() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getName() - Method in class org.hibernate.type.AbstractBynaryType

getName() - Method in class org.hibernate.type.AdaptedImmutableType

getName() - Method in class org.hibernate.type.AnyType

getName() - Method in class org.hibernate.type.BigDecimalType

getName() - Method in class org.hibernate.type.BigIntegerType

getName() - Method in class org.hibernate.type.BinaryType

getName() - Method in class org.hibernate.type.BlobType

getName() - Method in class org.hibernate.type.BooleanType

getName() - Method in class org.hibernate.type.ByteType

getName() - Method in class org.hibernate.type.CalendarDateType

getName() - Method in class org.hibernate.type.CalendarType

getName() - Method in class org.hibernate.type.CharArrayType

getName() - Method in class org.hibernate.type.CharacterArrayType

getName() - Method in class org.hibernate.type.CharacterType

getName() - Method in class org.hibernate.type.ClassType

getName() - Method in class org.hibernate.type.ClobType

getName() - Method in class org.hibernate.type.CollectionType

getName() - Method in class org.hibernate.type.ComponentType

getName() - Method in class org.hibernate.type.CompositeCustomType

getName() - Method in class org.hibernate.type.CurrencyType

getName() - Method in class org.hibernate.type.CustomType

getName() - Method in class org.hibernate.type.DateType

getName() - Method in class org.hibernate.type.DbTimestampType

getName() - Method in class org.hibernate.type.DoubleType

getName() - Method in class org.hibernate.type.EntityType

getName() - Method in class org.hibernate.type.FloatType

getName() - Method in class org.hibernate.type.IntegerType

getName() - Method in class org.hibernate.type.LocaleType

getName() - Method in class org.hibernate.type.LongType

getName() - Method in class org.hibernate.type.MetaType

getName() - Method in class org.hibernate.type.SerializableType

getName() - Method in class org.hibernate.type.ShortType

getName() - Method in class org.hibernate.type.StringType

getName() - Method in class org.hibernate.type.TextType

getName() - Method in class org.hibernate.type.TimeType

getName() - Method in class org.hibernate.type.TimeZoneType

getName() - Method in class org.hibernate.type.TimestampType

getName() - Method in class org.hibernate.type.TrueFalseType

getName() - Method in interface org.hibernate.type.Type
Returns the abbreviated name of the type.
getName() - Method in class org.hibernate.type.WrapperBinaryType

getName() - Method in class org.hibernate.type.YesNoType

getNamedInstance(String) - Static method in class org.hibernate.impl.SessionFactoryObjectFactory

getNamedParameterBindPoints() - Method in interface org.hibernate.loader.custom.CustomQuery
A map representing positions within the supplied query to which we need to bind named parameters.
getNamedParameterBindPoints() - Method in class org.hibernate.loader.custom.sql.SQLCustomQuery

getNamedParameterDescriptionMap() - Method in class org.hibernate.engine.query.ParamLocationRecognizer
Returns the map of named parameter locations.
getNamedParameterDescriptor(String) - Method in class org.hibernate.engine.query.ParameterMetadata

getNamedParameterExpectedType(String) - Method in class org.hibernate.engine.query.ParameterMetadata

getNamedParameterExpectedType(String) - Method in interface org.hibernate.hql.ParameterTranslations

getNamedParameterExpectedType(String) - Method in class org.hibernate.hql.ast.ParameterTranslationsImpl

getNamedParameterInfo(String) - Method in class org.hibernate.hql.ast.ParameterTranslationsImpl

getNamedParameterLists() - Method in class org.hibernate.impl.AbstractQueryImpl
Retreive the value map for any named parameter lists (i.e., for auto-expansion) bound to this query.
getNamedParameterLocMap() - Method in class org.hibernate.engine.SubselectFetch

getNamedParameterLocations(String) - Method in interface org.hibernate.engine.ParameterBinder.NamedParameterSource

getNamedParameterLocations(String) - Method in class org.hibernate.hql.ast.HqlSqlWalker
Returns the locations of all occurrences of the named parameter.
getNamedParameterLocs(String) - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

getNamedParameterLocs(String) - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getNamedParameterLocs(String) - Method in class org.hibernate.loader.Loader

getNamedParameterLocs(String) - Method in class org.hibernate.loader.collection.SubselectCollectionLoader

getNamedParameterLocs(String) - Method in class org.hibernate.loader.collection.SubselectOneToManyLoader

getNamedParameterLocs(String) - Method in class org.hibernate.loader.custom.CustomLoader

getNamedParameterLocs(String) - Method in class org.hibernate.loader.hql.QueryLoader
Returns the locations of all occurrences of the named parameter.
getNamedParameterNames() - Method in class org.hibernate.engine.query.ParameterMetadata

getNamedParameterNames() - Method in interface org.hibernate.hql.ParameterTranslations

getNamedParameterNames() - Method in class org.hibernate.hql.ast.ParameterTranslationsImpl

getNamedParameterSourceLocations(String) - Method in class org.hibernate.engine.query.ParameterMetadata

getNamedParameterSqlLocations(String) - Method in interface org.hibernate.hql.ParameterTranslations

getNamedParameterSqlLocations(String) - Method in class org.hibernate.hql.ast.ParameterTranslationsImpl

getNamedParameters() - Method in interface org.hibernate.Query
Return the names of all named parameters of the query.
getNamedParameters() - Method in class org.hibernate.engine.QueryParameters

getNamedParameters() - Method in class org.hibernate.impl.AbstractQueryImpl
Returns an array representing all named parameter names encountered during (intial) parsing of the query.
getNamedParameters() - Method in class org.hibernate.loader.custom.sql.SQLQueryParser

getNamedParams() - Method in class org.hibernate.impl.AbstractQueryImpl
Returns a shallow copy of the named parameter value map.
getNamedQueries() - Method in class org.hibernate.cfg.Configuration
Get the named queries
getNamedQuery(String) - Method in interface org.hibernate.Session
Obtain an instance of Query for a named query string defined in the mapping file.
getNamedQuery(String) - Method in interface org.hibernate.StatelessSession
Obtain an instance of Query for a named query string defined in the mapping file.
getNamedQuery(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor

getNamedQuery(String) - Method in interface org.hibernate.engine.SessionImplementor
Get a Query instance for a named query or named native SQL query
getNamedQuery(String) - Method in class org.hibernate.impl.AbstractSessionImpl

getNamedQuery(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getNamedQuery(String) - Method in class org.hibernate.impl.SessionImpl

getNamedSQLQueries() - Method in class org.hibernate.cfg.Configuration

getNamedSQLQuery(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor

getNamedSQLQuery(String) - Method in interface org.hibernate.engine.SessionImplementor
Get a Query instance for a named native SQL query
getNamedSQLQuery(String) - Method in class org.hibernate.impl.AbstractSessionImpl

getNamedSQLQuery(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getNamespace() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getNamespace() - Method in class org.hibernate.tuple.ElementWrapper

getNamespaceForPrefix(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getNamespaceForPrefix(String) - Method in class org.hibernate.tuple.ElementWrapper

getNamespaceForURI(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getNamespaceForURI(String) - Method in class org.hibernate.tuple.ElementWrapper

getNamespacePrefix() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getNamespacePrefix() - Method in class org.hibernate.tuple.ElementWrapper

getNamespaceURI() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getNamespaceURI() - Method in class org.hibernate.tuple.ElementWrapper

getNamespacesForURI(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getNamespacesForURI(String) - Method in class org.hibernate.tuple.ElementWrapper

getNamingStrategy() - Method in class org.hibernate.cfg.Configuration

getNamingStrategy() - Method in class org.hibernate.cfg.Mappings

getNativeIdentifierGeneratorClass() - Method in class org.hibernate.dialect.DerbyDialect

getNativeIdentifierGeneratorClass() - Method in class org.hibernate.dialect.Dialect

getNativeIdentifierGeneratorClass() - Method in class org.hibernate.dialect.PostgreSQLDialect

getNativeSQLQueryPlan(NativeSQLQuerySpecification) - Method in class org.hibernate.engine.query.QueryPlanCache

getNativeSQLQueryPlan(NativeSQLQuerySpecification) - Method in class org.hibernate.impl.AbstractSessionImpl

getNaturalIdSnapshot(Serializable, EntityPersister) - Method in interface org.hibernate.engine.PersistenceContext

getNaturalIdSnapshot(Serializable, EntityPersister) - Method in class org.hibernate.engine.StatefulPersistenceContext

getNaturalIdentifierProperties() - Method in interface org.hibernate.metadata.ClassMetadata
Which properties hold the natural id?
getNaturalIdentifierProperties() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getNaturalIdentifierProperties() - Method in interface org.hibernate.persister.entity.EntityPersister
Which properties hold the natural id?
getNaturalIdentifierProperties() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getNaturalIdentifierSnapshot(Serializable, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getNaturalIdentifierSnapshot(Serializable, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Retrieve the current state of the natural-id properties from the database.
getNoColumnsInsertString() - Method in class org.hibernate.dialect.Dialect
The keyword used to insert a row without specifying any column values.
getNoColumnsInsertString() - Method in class org.hibernate.dialect.JDataStoreDialect

getNoColumnsInsertString() - Method in class org.hibernate.dialect.PostgreSQLDialect

getNoColumnsInsertString() - Method in class org.hibernate.dialect.SQLServerDialect

getNoColumnsInsertString() - Method in class org.hibernate.dialect.SybaseAnywhereDialect
Sybase Anywhere syntax would require a "DEFAULT" for each column specified, but I suppose Hibernate use this syntax only with tables with just 1 column
getNode() - Method in class org.hibernate.tuple.Property

getNodeName() - Method in class org.hibernate.mapping.Collection

getNodeName() - Method in class org.hibernate.mapping.Component

getNodeName() - Method in class org.hibernate.mapping.PersistentClass

getNodeName() - Method in class org.hibernate.mapping.Property

getNodeName() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getNodeName() - Method in interface org.hibernate.persister.collection.CollectionPersister

getNodeType() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getNodeType() - Method in class org.hibernate.tuple.ElementWrapper

getNodeTypeName() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getNodeTypeName() - Method in class org.hibernate.tuple.ElementWrapper

getNonDuplicatedPropertyIterator() - Method in class org.hibernate.mapping.PersistentClass

getNonDuplicatedPropertyIterator() - Method in class org.hibernate.mapping.SingleTableSubclass

getNonDuplicatedPropertyIterator() - Method in class org.hibernate.mapping.UnionSubclass

getNonFinal(int, Type) - Method in class org.hibernate.impl.AbstractScrollableResults
Check that the requested type is compatible with the result type, and return the column value.
getNonLazyPropertyUpdateability() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getNonlazyPropertyUpdateability() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getNormalizedPropertyName(String) - Static method in class org.hibernate.hql.CollectionProperties

getNullColumnString() - Method in class org.hibernate.dialect.Dialect
The keyword used to specify a nullable column.
getNullColumnString() - Method in class org.hibernate.dialect.IngresDialect
The keyword used to specify a nullable column.
getNullColumnString() - Method in class org.hibernate.dialect.RDMSOS2200Dialect

getNullColumnString() - Method in class org.hibernate.dialect.SAPDBDialect

getNullColumnString() - Method in class org.hibernate.dialect.SybaseDialect

getNullValue() - Method in interface org.hibernate.mapping.KeyValue

getNullValue() - Method in class org.hibernate.mapping.SimpleValue

getNullable() - Method in class org.hibernate.tool.hbm2ddl.ColumnMetadata

getNullifiableEntityKeys() - Method in interface org.hibernate.engine.PersistenceContext
Retrieve the set of EntityKeys representing nullifiable references
getNullifiableEntityKeys() - Method in class org.hibernate.engine.StatefulPersistenceContext
Retrieve the set of EntityKeys representing nullifiable references
getNumberOfParametersInSetClause() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getObject() - Method in class org.hibernate.event.DeleteEvent
Returns the encapsulated entity to be deleed.
getObject() - Method in class org.hibernate.event.EvictEvent

getObject() - Method in class org.hibernate.event.LockEvent

getObject() - Method in class org.hibernate.event.PersistEvent

getObject() - Method in class org.hibernate.event.RefreshEvent

getObject() - Method in class org.hibernate.event.ReplicateEvent

getObject() - Method in class org.hibernate.event.SaveOrUpdateEvent

getObject(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getObject(String, Map) - Method in class org.hibernate.jdbc.ResultSetWrapper

getObject(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getObject(int, Map) - Method in class org.hibernate.jdbc.ResultSetWrapper

getObjectInstance(Object, Name, Context, Hashtable) - Method in class org.hibernate.impl.SessionFactoryObjectFactory

getOldState() - Method in class org.hibernate.event.PostUpdateEvent

getOldState() - Method in class org.hibernate.event.PreUpdateEvent

getOnCondition(String, SessionFactoryImplementor, Map) - Method in class org.hibernate.type.AnyType

getOnCondition(String, SessionFactoryImplementor, Map) - Method in interface org.hibernate.type.AssociationType
Get the "filtering" SQL fragment that is applied in the SQL on clause, in addition to the usual join condition
getOnCondition(String, SessionFactoryImplementor, Map) - Method in class org.hibernate.type.CollectionType

getOnCondition(String, SessionFactoryImplementor, Map) - Method in class org.hibernate.type.EntityType

getOp() - Method in class org.hibernate.criterion.Junction

getOp() - Method in class org.hibernate.criterion.LogicalExpression

getOp() - Method in class org.hibernate.criterion.PropertyExpression

getOp() - Method in class org.hibernate.criterion.SimpleExpression

getOperand() - Method in class org.hibernate.hql.ast.tree.UnaryArithmeticNode

getOperand() - Method in class org.hibernate.hql.ast.tree.UnaryLogicOperatorNode

getOperand() - Method in interface org.hibernate.hql.ast.tree.UnaryOperatorNode
Retrievs the node representing the operator's single operand.
getOptimisticFailureCount() - Method in class org.hibernate.jmx.StatisticsService

getOptimisticFailureCount() - Method in class org.hibernate.stat.EntityStatistics

getOptimisticFailureCount() - Method in interface org.hibernate.stat.Statistics
The number of StaleObjectStateExceptions that occurred
getOptimisticFailureCount() - Method in class org.hibernate.stat.StatisticsImpl

getOptimisticLockMode() - Method in class org.hibernate.mapping.PersistentClass

getOptimisticLockMode() - Method in class org.hibernate.mapping.RootClass

getOptimisticLockMode() - Method in class org.hibernate.mapping.Subclass

getOptimisticLockMode() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getOptionalEntityName() - Method in class org.hibernate.engine.QueryParameters

getOptionalId() - Method in class org.hibernate.engine.QueryParameters

getOptionalObject() - Method in class org.hibernate.engine.QueryParameters

getOrCreateIndex(String) - Method in class org.hibernate.mapping.Table

getOrCreateUniqueKey(String) - Method in class org.hibernate.mapping.Table

getOrder() - Method in class org.hibernate.impl.CriteriaImpl.OrderEntry

getOrderBy() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getOrderBy() - Method in class org.hibernate.mapping.Collection

getOrderByClause() - Method in class org.hibernate.hql.ast.tree.QueryNode

getOrdinalParameterCount() - Method in class org.hibernate.engine.query.ParameterMetadata

getOrdinalParameterCount() - Method in interface org.hibernate.hql.ParameterTranslations

getOrdinalParameterCount() - Method in class org.hibernate.hql.ast.ParameterTranslationsImpl

getOrdinalParameterDescriptor(int) - Method in class org.hibernate.engine.query.ParameterMetadata

getOrdinalParameterExpectedType(int) - Method in class org.hibernate.engine.query.ParameterMetadata

getOrdinalParameterExpectedType(int) - Method in interface org.hibernate.hql.ParameterTranslations

getOrdinalParameterExpectedType(int) - Method in class org.hibernate.hql.ast.ParameterTranslationsImpl

getOrdinalParameterInfo(int) - Method in class org.hibernate.hql.ast.ParameterTranslationsImpl

getOrdinalParameterLocationList() - Method in class org.hibernate.engine.query.ParamLocationRecognizer
Returns the list of ordinal parameter locations.
getOrdinalParameterSourceLocation(int) - Method in class org.hibernate.engine.query.ParameterMetadata

getOrdinalParameterSqlLocation(int) - Method in interface org.hibernate.hql.ParameterTranslations

getOrdinalParameterSqlLocation(int) - Method in class org.hibernate.hql.ast.ParameterTranslationsImpl

getOrdinalPosition() - Method in class org.hibernate.engine.query.OrdinalParameterDescriptor

getOrigin() - Method in class org.hibernate.hql.ast.tree.FromElement

getOriginal() - Method in class org.hibernate.event.MergeEvent

getOriginalText() - Method in class org.hibernate.hql.ast.tree.SqlNode

getOrphan() - Method in interface org.hibernate.collection.AbstractPersistentCollection.DelayedOperation

getOrphans(Serializable, String) - Method in class org.hibernate.collection.AbstractPersistentCollection
get all "orphaned" elements
getOrphans(Collection, Collection, String, SessionImplementor) - Static method in class org.hibernate.collection.AbstractPersistentCollection
Given a collection of entity instances that used to belong to the collection, and a collection of instances that currently belong, return a collection of orphans
getOrphans(Serializable, String) - Method in class org.hibernate.collection.PersistentArrayHolder

getOrphans(Serializable, String) - Method in class org.hibernate.collection.PersistentBag

getOrphans(Serializable, String) - Method in interface org.hibernate.collection.PersistentCollection
get all "orphaned" elements
getOrphans(Serializable, String) - Method in class org.hibernate.collection.PersistentElementHolder

getOrphans(Serializable, String) - Method in class org.hibernate.collection.PersistentIdentifierBag

getOrphans(Serializable, String) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

getOrphans(Serializable, String) - Method in class org.hibernate.collection.PersistentList

getOrphans(Serializable, String) - Method in class org.hibernate.collection.PersistentMap

getOrphans(Serializable, String) - Method in class org.hibernate.collection.PersistentSet

getOrphans(String, PersistentCollection) - Method in class org.hibernate.engine.CollectionEntry
Get the collection orphans (entities which were removed from the collection)
getOwner() - Method in class org.hibernate.collection.AbstractPersistentCollection

getOwner() - Method in interface org.hibernate.collection.PersistentCollection
Get the owning entity.
getOwner(List) - Method in class org.hibernate.loader.OuterJoinableAssociation

getOwner() - Method in class org.hibernate.loader.custom.FetchReturn
Retrieves the return descriptor for the owner of this fetch.
getOwner() - Method in class org.hibernate.mapping.Collection

getOwner() - Method in class org.hibernate.mapping.Component

getOwnerAlias() - Method in class org.hibernate.engine.query.sql.NativeSQLQueryJoinReturn
Retrieve the alias of the owner of this fetched association.
getOwnerAssociationTypes() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getOwnerAssociationTypes() - Method in class org.hibernate.loader.JoinWalker

getOwnerAssociationTypes() - Method in class org.hibernate.loader.Loader
An array of unique key property names by which the corresponding entities are referenced by other entities in the result set
getOwnerAssociationTypes() - Method in class org.hibernate.loader.OuterJoinLoader

getOwnerAssociationTypes() - Method in class org.hibernate.loader.hql.QueryLoader

getOwnerEntityName() - Method in class org.hibernate.engine.query.sql.NativeSQLQueryCollectionReturn
Returns the class owning the collection.
getOwnerEntityName() - Method in class org.hibernate.loader.custom.CollectionReturn
Returns the class owning the collection.
getOwnerEntityName() - Method in class org.hibernate.mapping.Collection

getOwnerEntityName() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getOwnerEntityPersister() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getOwnerEntityPersister() - Method in interface org.hibernate.persister.collection.CollectionPersister
Get the persister of the entity that "owns" this collection
getOwnerId(String, String, Object, Map) - Method in interface org.hibernate.engine.PersistenceContext
Search the persistence context for an owner for the child object, given a collection role
getOwnerId(String, String, Object, Map) - Method in class org.hibernate.engine.StatefulPersistenceContext
Search the persistence context for an owner for the child object, given a collection role.
getOwnerProperty() - Method in class org.hibernate.engine.query.sql.NativeSQLQueryCollectionReturn
Returns the name of the property representing the collection from the NativeSQLQueryCollectionReturn.getOwnerEntityName().
getOwnerProperty() - Method in class org.hibernate.engine.query.sql.NativeSQLQueryJoinReturn
Retrieve the property name (relative to the owner) which maps to the association to be fetched.
getOwnerProperty() - Method in class org.hibernate.loader.custom.CollectionReturn
Returns the name of the property representing the collection from the CollectionReturn.getOwnerEntityName().
getOwnerProperty() - Method in class org.hibernate.loader.custom.FetchReturn
The name of the property on the owner which represents this association.
getOwners() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getOwners() - Method in class org.hibernate.loader.JoinWalker

getOwners() - Method in class org.hibernate.loader.Loader
An array of indexes of the entity that owns a one-to-one association to the entity at the given index (-1 if there is no "owner")
getOwners() - Method in class org.hibernate.loader.OuterJoinLoader

getOwners() - Method in class org.hibernate.loader.custom.CustomLoader

getOwners() - Method in class org.hibernate.loader.hql.QueryLoader
An array of indexes of the entity that owns a one-to-one association to the entity at the given index (-1 if there is no "owner")
getParameter(String) - Method in class org.hibernate.impl.FilterImpl
Get the value of the named parameter for the current filter.
getParameterMetadata() - Method in class org.hibernate.engine.query.HQLQueryPlan

getParameterMetadata() - Method in class org.hibernate.engine.query.QueryMetadata

getParameterNames() - Method in class org.hibernate.engine.FilterDefinition
Get a set of the parameters defined by this configuration.
getParameterTranslations() - Method in interface org.hibernate.hql.QueryTranslator
Return information about any parameters encountered during translation.
getParameterTranslations() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

getParameterTranslations() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getParameterType(String) - Method in class org.hibernate.engine.FilterDefinition
Retreive the type of the named parameter defined for this filter.
getParameterTypes(Element) - Static method in class org.hibernate.cfg.HbmBinder

getParameterTypes() - Method in class org.hibernate.engine.FilterDefinition

getParameterTypes() - Method in class org.hibernate.engine.NamedQueryDefinition

getParameters() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getParameters() - Method in class org.hibernate.hql.ast.tree.AssignmentSpecification

getParameters() - Method in class org.hibernate.impl.FilterImpl

getParameters() - Method in class org.hibernate.mapping.TypeDef

getParent() - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

getParent() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getParent() - Method in class org.hibernate.tuple.ElementWrapper

getParent(Object) - Method in class org.hibernate.tuple.component.AbstractComponentTuplizer

getParent(Object) - Method in interface org.hibernate.tuple.component.ComponentTuplizer
Retreive the current value of the parent property.
getParent(Object) - Method in class org.hibernate.tuple.component.PojoComponentTuplizer

getParentFromClause() - Method in class org.hibernate.hql.ast.tree.FromClause

getParentProperty() - Method in class org.hibernate.mapping.Component

getParseErrorHandler() - Method in class org.hibernate.hql.ast.HqlParser

getParseErrorHandler() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getParseErrorHandler() - Method in class org.hibernate.hql.ast.SqlGenerator

getPassword() - Method in class org.hibernate.jmx.HibernateService

getPassword() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Log into the database with this password
getPath() - Method in class org.hibernate.InvalidMappingException

getPath() - Method in class org.hibernate.MappingNotFoundException

getPath() - Method in class org.hibernate.hql.ast.tree.DotNode
Returns the full path of the node.
getPath() - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

getPath() - Method in interface org.hibernate.hql.ast.tree.PathNode
Returns the full path name represented by the node.
getPath() - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

getPath() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getPath(Element) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getPath() - Method in class org.hibernate.tuple.ElementWrapper

getPath(Element) - Method in class org.hibernate.tuple.ElementWrapper

getPathText(AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil

getPersistEventListeners() - Method in class org.hibernate.event.EventListeners

getPersistOnFlushEventListeners() - Method in class org.hibernate.event.EventListeners

getPersistenceContext() - Method in interface org.hibernate.engine.SessionImplementor
Get the persistence context for this session
getPersistenceContext() - Method in class org.hibernate.impl.SessionImpl

getPersistenceContext() - Method in class org.hibernate.impl.StatelessSessionImpl

getPersistentClass() - Method in class org.hibernate.InstantiationException

getPersistentClass() - Method in class org.hibernate.PropertyAccessException

getPersistentClass() - Method in class org.hibernate.mapping.Join

getPersistentClass() - Method in class org.hibernate.mapping.Property

getPersistentClass() - Method in interface org.hibernate.proxy.LazyInitializer
Get the actual class of the entity (don't use this, use the entityName)
getPersistentClass() - Method in class org.hibernate.proxy.dom4j.Dom4jLazyInitializer

getPersistentClass() - Method in class org.hibernate.proxy.map.MapLazyInitializer

getPersistentClass() - Method in class org.hibernate.proxy.pojo.BasicLazyInitializer

getPersister() - Method in class org.hibernate.action.CollectionAction

getPersister() - Method in class org.hibernate.action.EntityAction

getPersister() - Method in class org.hibernate.engine.EntityEntry

getPersister() - Method in class org.hibernate.event.PostDeleteEvent

getPersister() - Method in class org.hibernate.event.PostInsertEvent

getPersister() - Method in class org.hibernate.event.PostLoadEvent

getPersister() - Method in class org.hibernate.event.PostUpdateEvent

getPersister() - Method in class org.hibernate.event.PreDeleteEvent

getPersister() - Method in class org.hibernate.event.PreInsertEvent

getPersister() - Method in class org.hibernate.event.PreLoadEvent

getPersister() - Method in class org.hibernate.event.PreUpdateEvent

getPersister() - Method in class org.hibernate.id.insert.AbstractReturningDelegate

getPersister() - Method in class org.hibernate.loader.AbstractEntityJoinWalker

getPersisters() - Method in class org.hibernate.loader.JoinWalker

getPhysicalColumnName(String, Table) - Method in class org.hibernate.cfg.Mappings

getPositionalParameterTypes() - Method in class org.hibernate.engine.QueryParameters

getPositionalParameterValues() - Method in class org.hibernate.engine.QueryParameters

getPostCommitDeleteEventListeners() - Method in class org.hibernate.event.EventListeners

getPostCommitInsertEventListeners() - Method in class org.hibernate.event.EventListeners

getPostCommitUpdateEventListeners() - Method in class org.hibernate.event.EventListeners

getPostDeleteEventListeners() - Method in class org.hibernate.event.EventListeners

getPostInsertEventListeners() - Method in class org.hibernate.event.EventListeners

getPostLoadEventListeners() - Method in class org.hibernate.event.EventListeners

getPostUpdateEventListeners() - Method in class org.hibernate.event.EventListeners

getPreDeleteEventListeners() - Method in class org.hibernate.event.EventListeners

getPreInsertEventListeners() - Method in class org.hibernate.event.EventListeners

getPreLoadEventListeners() - Method in class org.hibernate.event.EventListeners

getPreUpdateEventListeners() - Method in class org.hibernate.event.EventListeners

getPrecision() - Method in class org.hibernate.mapping.Column

getPrepareStatementCount() - Method in class org.hibernate.jmx.StatisticsService

getPrepareStatementCount() - Method in interface org.hibernate.stat.Statistics
The number of prepared statements that were acquired
getPrepareStatementCount() - Method in class org.hibernate.stat.StatisticsImpl

getPrimaryKey() - Method in class org.hibernate.mapping.DenormalizedTable

getPrimaryKey() - Method in class org.hibernate.mapping.Table

getPrimitiveClass() - Method in class org.hibernate.type.BooleanType

getPrimitiveClass() - Method in class org.hibernate.type.ByteType

getPrimitiveClass() - Method in class org.hibernate.type.CharacterType

getPrimitiveClass() - Method in class org.hibernate.type.DoubleType

getPrimitiveClass() - Method in class org.hibernate.type.FloatType

getPrimitiveClass() - Method in class org.hibernate.type.IntegerType

getPrimitiveClass() - Method in class org.hibernate.type.LongType

getPrimitiveClass() - Method in class org.hibernate.type.PrimitiveType

getPrimitiveClass() - Method in class org.hibernate.type.ShortType

getProjectedAliases() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getProjectedColumnAliases() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getProjectedTypes() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getProjection(int) - Method in class org.hibernate.criterion.ProjectionList

getProjection() - Method in class org.hibernate.impl.CriteriaImpl

getProjectionCriteria() - Method in class org.hibernate.impl.CriteriaImpl

getProjectionList() - Method in class org.hibernate.hql.ast.tree.FromClause
Returns the list of from elements that will be part of the result set.
getProperties() - Method in class org.hibernate.cfg.Configuration
Get all properties
getProperties() - Static method in class org.hibernate.cfg.Environment
Return System properties, extended by any properties specified in hibernate.properties.
getProperties() - Method in class org.hibernate.jmx.HibernateService

getProperties() - Method in class org.hibernate.tuple.component.ComponentMetamodel

getProperties() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertiesToInsert(Object[]) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Transform the array of property indexes to an array of booleans, true when the property is insertable and non-null
getPropertiesToUpdate(int[], boolean) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Transform the array of property indexes to an array of booleans, true when the property is dirty
getProperty(String) - Method in class org.hibernate.cfg.Configuration
Get a property
getProperty(String) - Method in class org.hibernate.criterion.Property
Get a component attribute of this property
getProperty(String) - Method in class org.hibernate.jmx.HibernateService

getProperty(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Get a property
getProperty(String) - Method in class org.hibernate.mapping.Component

getProperty(String) - Method in class org.hibernate.mapping.PersistentClass

getProperty(int) - Method in class org.hibernate.tuple.component.ComponentMetamodel

getProperty(String) - Method in class org.hibernate.tuple.component.ComponentMetamodel

getPropertyAccessor(Class) - Method in class org.hibernate.mapping.Backref

getPropertyAccessor(Class) - Method in class org.hibernate.mapping.IndexBackref

getPropertyAccessor(Class) - Method in class org.hibernate.mapping.Property

getPropertyAccessor(Property, EntityMode) - Static method in class org.hibernate.property.PropertyAccessorFactory
Retrieves a PropertyAccessor instance based on the given property definition and entity mode.
getPropertyAccessor(Class, String) - Static method in class org.hibernate.property.PropertyAccessorFactory

getPropertyAccessor(String) - Static method in class org.hibernate.property.PropertyAccessorFactory

getPropertyAccessorName() - Method in class org.hibernate.mapping.Property

getPropertyAliases(Loadable, int) - Method in class org.hibernate.loader.ColumnEntityAliases

getPropertyAliases(Loadable, int) - Method in class org.hibernate.loader.DefaultEntityAliases

getPropertyAliases(String, int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyAliases(String, int) - Method in interface org.hibernate.persister.entity.Loadable
Get the result set aliases used for the property columns, given a suffix (properties of this class, only).
getPropertyCascadeStyles() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyCascadeStyles() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the cascade styles of the propertes (optional operation)
getPropertyCheckability() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyCheckability() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the "checkability" of the properties of this class (is the property dirty checked, does the cache need to be updated)
getPropertyCheckability() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertyClosureIterator() - Method in class org.hibernate.mapping.PersistentClass

getPropertyClosureIterator() - Method in class org.hibernate.mapping.RootClass

getPropertyClosureIterator() - Method in class org.hibernate.mapping.Subclass

getPropertyClosureSpan() - Method in class org.hibernate.mapping.PersistentClass

getPropertyClosureSpan() - Method in class org.hibernate.mapping.Subclass

getPropertyColumnNames(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyColumnNames(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyColumnNames(int) - Method in interface org.hibernate.persister.entity.Loadable
Get the result set column names mapped for this property (properties of this class, only).
getPropertyColumnNames(String) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
Get the column names for the given property path
getPropertyColumnSpan(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyIndex(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyIndex(String) - Method in interface org.hibernate.persister.entity.UniqueKeyLoadable
Get the property number of the unique key property
getPropertyIndex(String) - Method in class org.hibernate.tuple.component.ComponentMetamodel

getPropertyIndex(String) - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertyIndexOrNull(String) - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertyInsertGeneration() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyInsertGeneration() - Method in interface org.hibernate.persister.entity.EntityPersister
Which of the properties of this class are database generated values on insert?
getPropertyInsertGeneration() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertyInsertability() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyInsertability() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the "insertability" of the properties of this class (does the property appear in an SQL INSERT)
getPropertyInsertability() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertyIterator() - Method in class org.hibernate.mapping.Component

getPropertyIterator() - Method in class org.hibernate.mapping.Join

getPropertyIterator() - Method in class org.hibernate.mapping.PersistentClass

getPropertyLaziness() - Method in interface org.hibernate.metadata.ClassMetadata
Get the "laziness" of the properties of this class
getPropertyLaziness() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyLaziness() - Method in interface org.hibernate.persister.entity.EntityPersister

getPropertyLaziness() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertyList() - Method in class org.hibernate.jmx.HibernateService

getPropertyList() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Display the properties
getPropertyMapping(String) - Method in class org.hibernate.hql.ast.tree.FromElement

getPropertyName() - Method in class org.hibernate.PropertyAccessException

getPropertyName() - Method in class org.hibernate.PropertyValueException

getPropertyName(String) - Method in interface org.hibernate.criterion.CriteriaQuery
Get the property name, given a possibly qualified property name
getPropertyName() - Method in class org.hibernate.criterion.PropertyProjection

getPropertyName(String) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getPropertyName() - Method in class org.hibernate.mapping.OneToOne

getPropertyName() - Method in class org.hibernate.type.EntityType

getPropertyName() - Method in class org.hibernate.type.OneToOneType

getPropertyNames() - Method in interface org.hibernate.bytecode.ReflectionOptimizer.AccessOptimizer

getPropertyNames() - Method in class org.hibernate.bytecode.cglib.AccessOptimizerAdapter

getPropertyNames() - Method in class org.hibernate.bytecode.javassist.AccessOptimizerAdapter

getPropertyNames() - Method in interface org.hibernate.metadata.ClassMetadata
Get the names of the class' persistent properties
getPropertyNames() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyNames() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the names of the class properties - doesn't have to be the names of the actual Java properties (used for XML generation only)
getPropertyNames() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertyNames() - Method in interface org.hibernate.type.AbstractComponentType
Get the names of the component properties
getPropertyNames() - Method in class org.hibernate.type.AnyType

getPropertyNames() - Method in class org.hibernate.type.ComponentType

getPropertyNames() - Method in class org.hibernate.type.CompositeCustomType

getPropertyNames() - Method in interface org.hibernate.usertype.CompositeUserType
Get the "property names" that may be used in a query.
getPropertyNullability() - Method in interface org.hibernate.metadata.ClassMetadata
Get the nullability of the class' persistent properties
getPropertyNullability() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyNullability() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the nullability of the properties of this class
getPropertyNullability() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertyNullability() - Method in interface org.hibernate.type.AbstractComponentType
Optional operation
getPropertyNullability() - Method in class org.hibernate.type.AnyType

getPropertyNullability() - Method in class org.hibernate.type.ComponentType

getPropertyNullability() - Method in class org.hibernate.type.CompositeCustomType

getPropertyPath() - Method in class org.hibernate.hql.ast.tree.DotNode

getPropertyResultsMap() - Method in class org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn
Retrieve the user-supplied column->property mappings.
getPropertySpaces() - Method in class org.hibernate.action.BulkOperationCleanupAction

getPropertySpaces() - Method in class org.hibernate.action.CollectionAction

getPropertySpaces() - Method in class org.hibernate.action.EntityAction

getPropertySpaces() - Method in interface org.hibernate.action.Executable
What spaces (tables) are affected by this action?
getPropertySpaces() - Method in interface org.hibernate.persister.entity.EntityPersister
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class only.
getPropertySpaces() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getPropertySpaces() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getPropertySpaces() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getPropertySpan() - Method in class org.hibernate.mapping.Component

getPropertySpan() - Method in class org.hibernate.mapping.Join

getPropertySpan() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertySpan() - Method in class org.hibernate.tuple.component.ComponentMetamodel

getPropertySpan() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertySubclassNames() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyTableName(String) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getPropertyTableName(String) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
Get the table name for the given property path
getPropertyTableName(String) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getPropertyTableName(String) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getPropertyTableNumbers() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyTableNumbers() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getPropertyTableNumbers() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getPropertyTableNumbers() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getPropertyTableNumbersInSelect() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyTableNumbersInSelect() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getPropertyTableNumbersInSelect() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getPropertyTableNumbersInSelect() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getPropertyType(String, String) - Method in class org.hibernate.hql.ast.tree.FromElement
Returns the type of a property, given it's name (the last part) and the full path.
getPropertyType() - Method in class org.hibernate.hql.classic.PathExpressionParser

getPropertyType(String) - Method in interface org.hibernate.metadata.ClassMetadata
Get the type of a particular (named) property
getPropertyType(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyType(String) - Method in interface org.hibernate.persister.entity.EntityPersister
Get the type of a particular property
getPropertyTypes() - Method in class org.hibernate.bytecode.javassist.BulkAccessor
Returns the types of properties.
getPropertyTypes() - Method in interface org.hibernate.metadata.ClassMetadata
Get the Hibernate types of the class properties
getPropertyTypes() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyTypes() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the Hibernate types of the class properties
getPropertyTypes() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertyTypes() - Method in interface org.hibernate.usertype.CompositeUserType
Get the corresponding "property types".
getPropertyUpdateGeneration() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyUpdateGeneration() - Method in interface org.hibernate.persister.entity.EntityPersister
Which of the properties of this class are database generated values on update?
getPropertyUpdateGeneration() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertyUpdateability(Object, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Which properties appear in the SQL update? (Initialized, updateable ones!)
getPropertyUpdateability() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyUpdateability() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the "updateability" of the properties of this class (does the property appear in an SQL UPDATE)
getPropertyUpdateability() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getPropertyValue(Object, String, EntityMode) - Method in interface org.hibernate.metadata.ClassMetadata
Get the value of a particular (named) property
getPropertyValue(Object, int, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyValue(Object, String, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyValue(Object, int, EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Get the value of a particular property
getPropertyValue(Object, String, EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Get the value of a particular property
getPropertyValue(Object, int) - Method in interface org.hibernate.tuple.Tuplizer
Extract the value of a particular property from the given entity.
getPropertyValue(Object, int) - Method in class org.hibernate.tuple.component.AbstractComponentTuplizer

getPropertyValue(Object, int) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

getPropertyValue(Object, String) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

getPropertyValue(Object, String) - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Extract the value of a particular property from the given entity.
getPropertyValue(Object, int, SessionImplementor) - Method in interface org.hibernate.type.AbstractComponentType

getPropertyValue(Object, int, SessionImplementor) - Method in class org.hibernate.type.AnyType

getPropertyValue(Object, int, SessionImplementor) - Method in class org.hibernate.type.ComponentType

getPropertyValue(Object, int, EntityMode) - Method in class org.hibernate.type.ComponentType

getPropertyValue(Object, int, SessionImplementor) - Method in class org.hibernate.type.CompositeCustomType

getPropertyValue(Object, int) - Method in class org.hibernate.type.CompositeCustomType

getPropertyValue(Object, int) - Method in interface org.hibernate.usertype.CompositeUserType
Get the value of a property.
getPropertyValues(Object) - Method in interface org.hibernate.bytecode.ReflectionOptimizer.AccessOptimizer

getPropertyValues(Object) - Method in class org.hibernate.bytecode.cglib.AccessOptimizerAdapter

getPropertyValues(Object) - Method in class org.hibernate.bytecode.javassist.AccessOptimizerAdapter

getPropertyValues(Object, Object[]) - Method in class org.hibernate.bytecode.javassist.BulkAccessor
Obtains the values of properties of a given bean.
getPropertyValues(Object) - Method in class org.hibernate.bytecode.javassist.BulkAccessor
Returns the values of properties of a given bean.
getPropertyValues() - Method in class org.hibernate.event.FlushEntityEvent

getPropertyValues(Object, EntityMode) - Method in interface org.hibernate.metadata.ClassMetadata
Extract the property values from the given entity.
getPropertyValues(Object, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyValues(Object, EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Return the (loaded) values of the mapped properties of the object (not including backrefs)
getPropertyValues(Object) - Method in interface org.hibernate.tuple.Tuplizer
Extract the current values contained on the given entity.
getPropertyValues(Object) - Method in class org.hibernate.tuple.component.AbstractComponentTuplizer

getPropertyValues(Object) - Method in class org.hibernate.tuple.component.PojoComponentTuplizer

getPropertyValues(Object) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

getPropertyValues(Object) - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

getPropertyValues(Object, SessionImplementor) - Method in interface org.hibernate.type.AbstractComponentType
Get the values of the component properties of a component instance
getPropertyValues(Object, EntityMode) - Method in interface org.hibernate.type.AbstractComponentType
Optional operation
getPropertyValues(Object, SessionImplementor) - Method in class org.hibernate.type.AnyType

getPropertyValues(Object, EntityMode) - Method in class org.hibernate.type.AnyType

getPropertyValues(Object, SessionImplementor) - Method in class org.hibernate.type.ComponentType

getPropertyValues(Object, EntityMode) - Method in class org.hibernate.type.ComponentType

getPropertyValues(Object, SessionImplementor) - Method in class org.hibernate.type.CompositeCustomType

getPropertyValues(Object, EntityMode) - Method in class org.hibernate.type.CompositeCustomType

getPropertyValuesToInsert(Object, Map, SessionImplementor) - Method in interface org.hibernate.metadata.ClassMetadata
Return the values of the mapped properties of the object
getPropertyValuesToInsert(Object, Map, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyValuesToInsert(Object, Map, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Return the values of the insertable properties of the object (including backrefs)
getPropertyValuesToInsert(Object, Map, SessionImplementor) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

getPropertyValuesToInsert(Object, Map, SessionImplementor) - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Extract the values of the insertable properties of the entity (including backrefs)
getPropertyValuesToInsert(Object, Map, SessionImplementor) - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

getPropertyValuesWithOptimizer(Object) - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

getPropertyVersionability() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getPropertyVersionability() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the "versionability" of the properties of this class (is the property optimistic-locked)
getPropertyVersionability() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getProxy() - Method in interface org.hibernate.bytecode.BasicProxyFactory

getProxy() - Method in class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl.BasicProxyFactoryImpl

getProxy(EntityKey) - Method in interface org.hibernate.engine.PersistenceContext
Get an existing proxy by key
getProxy(EntityKey) - Method in class org.hibernate.engine.StatefulPersistenceContext
Get an existing proxy by key
getProxy(Serializable, SessionImplementor) - Method in interface org.hibernate.proxy.ProxyFactory
Create a new proxy instance
getProxy(Serializable, SessionImplementor) - Method in class org.hibernate.proxy.dom4j.Dom4jProxyFactory
Create a new proxy
getProxy(Serializable, SessionImplementor) - Method in class org.hibernate.proxy.map.MapProxyFactory

getProxy(Class, String, Class, Class[], Method, Method, AbstractComponentType, Serializable, SessionImplementor) - Static method in class org.hibernate.proxy.pojo.cglib.CGLIBLazyInitializer

getProxy(Serializable, SessionImplementor) - Method in class org.hibernate.proxy.pojo.cglib.CGLIBProxyFactory

getProxy(String, Class, Class[], Method, Method, AbstractComponentType, Serializable, SessionImplementor) - Static method in class org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer

getProxy(Class, String, Class, Class[], Method, Method, AbstractComponentType, Serializable, SessionImplementor) - Static method in class org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer

getProxy(Serializable, SessionImplementor) - Method in class org.hibernate.proxy.pojo.javassist.JavassistProxyFactory

getProxyFactory(Class, Class[]) - Static method in class org.hibernate.proxy.pojo.cglib.CGLIBLazyInitializer

getProxyFactory(Class, Class[]) - Static method in class org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer

getProxyFactory() - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

getProxyFactoryFactory() - Method in interface org.hibernate.bytecode.BytecodeProvider
Retrieve the specific factory for this provider capable of generating run-time proxies for lazy-loading purposes.
getProxyFactoryFactory() - Method in class org.hibernate.bytecode.cglib.BytecodeProviderImpl

getProxyFactoryFactory() - Method in class org.hibernate.bytecode.javassist.BytecodeProviderImpl

getProxyInterface() - Method in class org.hibernate.mapping.PersistentClass

getProxyInterfaceName() - Method in class org.hibernate.mapping.PersistentClass

getPs() - Method in class org.hibernate.impl.AbstractScrollableResults

getPutCount() - Method in class org.hibernate.stat.SecondLevelCacheStatistics

getQName() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getQName(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getQName() - Method in class org.hibernate.tuple.ElementWrapper

getQName(String) - Method in class org.hibernate.tuple.ElementWrapper

getQualifiedName(Dialect, String, String) - Method in class org.hibernate.mapping.Table

getQualifiedName() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getQualifiedName() - Method in class org.hibernate.tuple.ElementWrapper

getQueries() - Method in class org.hibernate.jmx.StatisticsService

getQueries() - Method in interface org.hibernate.stat.Statistics
Get all executed query strings
getQueries() - Method in class org.hibernate.stat.StatisticsImpl
Get all executed query strings
getQuery(String) - Method in class org.hibernate.cfg.Mappings

getQuery() - Method in class org.hibernate.engine.NamedQueryDefinition

getQueryCache(String, UpdateTimestampsCache, Settings, Properties) - Method in interface org.hibernate.cache.QueryCacheFactory

getQueryCache(String, UpdateTimestampsCache, Settings, Properties) - Method in class org.hibernate.cache.StandardQueryCacheFactory

getQueryCache() - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get the default query cache
getQueryCache(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get a particular named query cache, or the default cache
getQueryCache() - Method in class org.hibernate.impl.SessionFactoryImpl

getQueryCache(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getQueryCacheEnabled() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Is the query cache enabled?
getQueryCacheEnabled() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getQueryCacheFactory() - Method in class org.hibernate.cfg.Settings

getQueryCacheHitCount() - Method in class org.hibernate.jmx.StatisticsService

getQueryCacheHitCount() - Method in interface org.hibernate.stat.Statistics
Get the global number of cached queries successfully retrieved from cache
getQueryCacheHitCount() - Method in class org.hibernate.stat.StatisticsImpl

getQueryCacheMissCount() - Method in class org.hibernate.jmx.StatisticsService

getQueryCacheMissCount() - Method in interface org.hibernate.stat.Statistics
Get the global number of cached queries *not* found in cache
getQueryCacheMissCount() - Method in class org.hibernate.stat.StatisticsImpl

getQueryCachePutCount() - Method in class org.hibernate.jmx.StatisticsService

getQueryCachePutCount() - Method in interface org.hibernate.stat.Statistics
Get the global number of cacheable queries put in cache
getQueryCachePutCount() - Method in class org.hibernate.stat.StatisticsImpl

getQueryExecutionCount() - Method in class org.hibernate.jmx.StatisticsService

getQueryExecutionCount() - Method in interface org.hibernate.stat.Statistics
Get global number of executed queries
getQueryExecutionCount() - Method in class org.hibernate.stat.StatisticsImpl

getQueryExecutionMaxTime() - Method in class org.hibernate.jmx.StatisticsService

getQueryExecutionMaxTime() - Method in interface org.hibernate.stat.Statistics
Get the time in milliseconds of the slowest query.
getQueryExecutionMaxTime() - Method in class org.hibernate.stat.StatisticsImpl

getQueryExecutionMaxTimeQueryString() - Method in class org.hibernate.jmx.StatisticsService

getQueryExecutionMaxTimeQueryString() - Method in interface org.hibernate.stat.Statistics
Get the query string for the slowest query.
getQueryExecutionMaxTimeQueryString() - Method in class org.hibernate.stat.StatisticsImpl

getQueryIdentifier() - Method in interface org.hibernate.hql.QueryTranslator
Retrieve the query identifier for this translator.
getQueryIdentifier() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

getQueryIdentifier() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getQueryIdentifier() - Method in class org.hibernate.loader.Loader
Identifies the query for statistics reporting, if null, no statistics will be reported
getQueryIdentifier() - Method in class org.hibernate.loader.custom.CustomLoader

getQueryIdentifier() - Method in class org.hibernate.loader.hql.QueryLoader

getQueryParameters() - Method in class org.hibernate.engine.SubselectFetch

getQueryParameters(Map) - Method in class org.hibernate.impl.AbstractQueryImpl

getQueryParameters() - Method in class org.hibernate.impl.AbstractScrollableResults

getQueryParameters(Map) - Method in class org.hibernate.impl.SQLQueryImpl

getQueryParameters() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getQueryPlanCache() - Method in interface org.hibernate.engine.SessionFactoryImplementor

getQueryPlanCache() - Method in class org.hibernate.impl.SessionFactoryImpl

getQueryReturnAliases() - Method in class org.hibernate.hql.HolderInstantiator

getQueryReturnAliases() - Method in class org.hibernate.hql.ast.tree.SelectClause
The HQL aliases, or generated aliases
getQueryReturnTypes() - Method in class org.hibernate.hql.ast.tree.SelectClause
The types actually being returned from this query at the "object level".
getQueryReturns() - Method in class org.hibernate.engine.NamedSQLQueryDefinition

getQueryReturns() - Method in class org.hibernate.engine.ResultSetMappingDefinition

getQueryReturns() - Method in class org.hibernate.engine.query.sql.NativeSQLQuerySpecification

getQuerySequencesString() - Method in class org.hibernate.dialect.DB2Dialect

getQuerySequencesString() - Method in class org.hibernate.dialect.DerbyDialect

getQuerySequencesString() - Method in class org.hibernate.dialect.Dialect
A query used to find all sequences
getQuerySequencesString() - Method in class org.hibernate.dialect.H2Dialect

getQuerySequencesString() - Method in class org.hibernate.dialect.HSQLDialect

getQuerySequencesString() - Method in class org.hibernate.dialect.IngresDialect
A query used to find all sequences
getQuerySequencesString() - Method in class org.hibernate.dialect.InterbaseDialect

getQuerySequencesString() - Method in class org.hibernate.dialect.MimerSQLDialect
The syntax for fetching all sequnces avialable in the current schema.
getQuerySequencesString() - Method in class org.hibernate.dialect.Oracle9Dialect

getQuerySequencesString() - Method in class org.hibernate.dialect.PostgreSQLDialect

getQuerySequencesString() - Method in class org.hibernate.dialect.SAPDBDialect

getQuerySequencesString() - Method in class org.hibernate.dialect.TimesTenDialect

getQuerySpaces() - Method in class org.hibernate.engine.NamedSQLQueryDefinition

getQuerySpaces() - Method in class org.hibernate.engine.query.HQLQueryPlan

getQuerySpaces() - Method in class org.hibernate.engine.query.QueryMetadata
The set of query spaces affected by this source query.
getQuerySpaces() - Method in class org.hibernate.engine.query.sql.NativeSQLQuerySpecification

getQuerySpaces() - Method in class org.hibernate.event.AutoFlushEvent

getQuerySpaces() - Method in interface org.hibernate.hql.QueryTranslator
Returns the set of query spaces (table names) that the query referrs to.
getQuerySpaces() - Method in class org.hibernate.hql.ast.HqlSqlWalker
Returns the set of unique query spaces (a.k.a.
getQuerySpaces() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

getQuerySpaces() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getQuerySpaces() - Method in class org.hibernate.loader.criteria.CriteriaJoinWalker

getQuerySpaces() - Method in class org.hibernate.loader.criteria.CriteriaLoader

getQuerySpaces() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getQuerySpaces() - Method in class org.hibernate.loader.custom.CustomLoader

getQuerySpaces() - Method in interface org.hibernate.loader.custom.CustomQuery
Any query spaces to apply to the query execution.
getQuerySpaces() - Method in class org.hibernate.loader.custom.sql.SQLCustomQuery

getQuerySpaces() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getQuerySpaces() - Method in interface org.hibernate.persister.entity.EntityPersister
Returns an array of objects that identify spaces in which properties of this class are persisted, for instances of this class and its subclasses.
getQuerySpaces() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getQueryStatistics(String) - Method in class org.hibernate.jmx.StatisticsService

getQueryStatistics(String) - Method in interface org.hibernate.stat.Statistics
Query statistics from query string (HQL or SQL)
getQueryStatistics(String) - Method in class org.hibernate.stat.StatisticsImpl
Query statistics from query string (HQL or SQL)
getQueryString() - Method in interface org.hibernate.Query
Get the query string.
getQueryString() - Method in class org.hibernate.QueryException

getQueryString() - Method in class org.hibernate.engine.NamedQueryDefinition

getQueryString() - Method in class org.hibernate.engine.query.sql.NativeSQLQuerySpecification

getQueryString() - Method in interface org.hibernate.hql.QueryTranslator
Returns the HQL string processed by the translator.
getQueryString() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

getQueryString() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getQueryString() - Method in class org.hibernate.impl.AbstractQueryImpl

getQuerySubstitutions() - Method in class org.hibernate.cfg.Settings

getQuerySubstitutions() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Get the query language substitutions
getQuerySubstitutions() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getQueryTranslatorFactory() - Method in class org.hibernate.cfg.Settings

getQueryable() - Method in class org.hibernate.hql.ast.tree.FromElement

getQueryable() - Method in class org.hibernate.hql.ast.tree.IntoClause

getQueryableCollection(String, String, SessionFactoryImplementor) - Method in class org.hibernate.criterion.AbstractEmptinessExpression

getQueryableCollection() - Method in class org.hibernate.hql.ast.tree.FromElement

getQueuedOrphans(String) - Method in class org.hibernate.collection.AbstractPersistentCollection
Iterate the "queued" additions
getQueuedOrphans(String) - Method in interface org.hibernate.collection.PersistentCollection
Get the "queued" orphans
getQuotedName() - Method in class org.hibernate.mapping.Column
returns quoted name as it would be in the mapping file.
getQuotedName(Dialect) - Method in class org.hibernate.mapping.Column

getQuotedName() - Method in class org.hibernate.mapping.Table
returns quoted name as it would be in the mapping file.
getQuotedName(Dialect) - Method in class org.hibernate.mapping.Table

getQuotedSchema() - Method in class org.hibernate.mapping.Table
returns quoted name as it is in the mapping file.
getQuotedSchema(Dialect) - Method in class org.hibernate.mapping.Table

getRHSAlias() - Method in class org.hibernate.loader.OuterJoinableAssociation

getRHSColumnNames(AssociationType, SessionFactoryImplementor) - Static method in class org.hibernate.engine.JoinHelper
Get the columns of the associated table which are to be used in the join
getRHSUniqueKeyName() - Method in class org.hibernate.loader.OuterJoinableAssociation

getRHSUniqueKeyPropertyName() - Method in class org.hibernate.type.AnyType

getRHSUniqueKeyPropertyName() - Method in interface org.hibernate.type.AssociationType
The name of a unique property of the associated entity that provides the join key (null if the identifier of an entity, or key of a collection)
getRHSUniqueKeyPropertyName() - Method in class org.hibernate.type.CollectionType

getRHSUniqueKeyPropertyName() - Method in class org.hibernate.type.EntityType

getRealKey() - Method in class org.hibernate.util.IdentityMap.IdentityKey

getRealOrigin() - Method in class org.hibernate.hql.ast.tree.FromElement

getRecreateCount() - Method in class org.hibernate.stat.CollectionStatistics

getRecursiveProperty(String) - Method in class org.hibernate.mapping.PersistentClass

getRef(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getRef(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getReference() - Method in class org.hibernate.impl.SessionFactoryImpl

getReference() - Method in class org.hibernate.jmx.SessionFactoryStub

getReferenceablePropertyIterator() - Method in class org.hibernate.mapping.JoinedSubclass

getReferenceablePropertyIterator() - Method in class org.hibernate.mapping.PersistentClass

getReferencedColumns() - Method in class org.hibernate.mapping.ForeignKey
Returns the referenced columns if the foreignkey does not refer to the primary key
getReferencedEntityName() - Method in class org.hibernate.mapping.ForeignKey

getReferencedEntityName() - Method in class org.hibernate.mapping.OneToMany

getReferencedEntityName() - Method in class org.hibernate.mapping.ToOne

getReferencedProperty(String) - Method in class org.hibernate.mapping.PersistentClass

getReferencedPropertyName() - Method in class org.hibernate.mapping.Collection

getReferencedPropertyName() - Method in class org.hibernate.mapping.ToOne

getReferencedPropertyType(String, String) - Method in interface org.hibernate.engine.Mapping

getReferencedPropertyType(String, String) - Method in class org.hibernate.impl.SessionFactoryImpl

getReferencedTable() - Method in class org.hibernate.mapping.ForeignKey

getReflectionOptimizationEnabled() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getReflectionOptimizer(Class, String[], String[], Class[]) - Method in interface org.hibernate.bytecode.BytecodeProvider
Retrieve the ReflectionOptimizer delegate for this provider capable of generating reflection optimization components.
getReflectionOptimizer(Class, String[], String[], Class[]) - Method in class org.hibernate.bytecode.cglib.BytecodeProviderImpl

getReflectionOptimizer(Class, String[], String[], Class[]) - Method in class org.hibernate.bytecode.javassist.BytecodeProviderImpl

getRefreshEventListeners() - Method in class org.hibernate.event.EventListeners

getRegionName() - Method in interface org.hibernate.cache.Cache
Get the name of the cache region
getRegionName() - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Get the cache region name
getRegionName() - Method in class org.hibernate.cache.EhCache

getRegionName() - Method in class org.hibernate.cache.HashtableCache

getRegionName() - Method in class org.hibernate.cache.NonstrictReadWriteCache

getRegionName() - Method in class org.hibernate.cache.OSCache

getRegionName() - Method in class org.hibernate.cache.OptimisticTreeCache

getRegionName() - Method in interface org.hibernate.cache.QueryCache

getRegionName() - Method in class org.hibernate.cache.ReadOnlyCache

getRegionName() - Method in class org.hibernate.cache.ReadWriteCache

getRegionName() - Method in class org.hibernate.cache.StandardQueryCache

getRegionName() - Method in class org.hibernate.cache.SwarmCache

getRegionName() - Method in class org.hibernate.cache.TransactionalCache

getRegionName() - Method in class org.hibernate.cache.TreeCache

getRegionName() - Method in class org.hibernate.cache.UpdateTimestampsCache

getRemoveCount() - Method in class org.hibernate.stat.CollectionStatistics

getRenderText(SessionFactoryImplementor) - Method in class org.hibernate.hql.ast.tree.BooleanLiteralNode

getRenderText(SessionFactoryImplementor) - Method in class org.hibernate.hql.ast.tree.JavaConstantNode

getRenderText(SessionFactoryImplementor) - Method in class org.hibernate.hql.ast.tree.Node
Retrieve the text to be used for rendering this particular node.
getRenderText(SessionFactoryImplementor) - Method in class org.hibernate.hql.ast.tree.ParameterNode

getReplicateEventListeners() - Method in class org.hibernate.event.EventListeners

getReplicationMode() - Method in class org.hibernate.event.ReplicateEvent

getRequestedId() - Method in class org.hibernate.event.MergeEvent

getRequestedId() - Method in class org.hibernate.event.SaveOrUpdateEvent

getResourceAsStream(String) - Static method in class org.hibernate.util.ConfigHelper

getResult() - Method in class org.hibernate.engine.SubselectFetch
Get the Set of EntityKeys
getResult() - Method in class org.hibernate.event.LoadEvent

getResult() - Method in class org.hibernate.event.MergeEvent

getResult(SessionImplementor, ResultSet, Object) - Method in class org.hibernate.id.IdentityGenerator.BasicDelegate

getResult(SessionImplementor, ResultSet, Object) - Method in class org.hibernate.id.SelectGenerator.SelectGeneratorDelegate

getResult(SessionImplementor, ResultSet, Object) - Method in class org.hibernate.id.insert.AbstractSelectingDelegate
Extract the generated key value from the given result set.
getResultColumnOrRow(Object[], ResultTransformer, ResultSet, SessionImplementor) - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getResultColumnOrRow(Object[], ResultTransformer, ResultSet, SessionImplementor) - Method in class org.hibernate.loader.Loader
Get the actual object that is returned in the user-visible result list.
getResultColumnOrRow(Object[], ResultTransformer, ResultSet, SessionImplementor) - Method in class org.hibernate.loader.criteria.CriteriaLoader

getResultColumnOrRow(Object[], ResultTransformer, ResultSet, SessionImplementor) - Method in class org.hibernate.loader.custom.CustomLoader

getResultColumnOrRow(Object[], ResultTransformer, ResultSet, SessionImplementor) - Method in class org.hibernate.loader.entity.AbstractEntityLoader

getResultColumnOrRow(Object[], ResultTransformer, ResultSet, SessionImplementor) - Method in class org.hibernate.loader.entity.CollectionElementLoader

getResultColumnOrRow(Object[], ResultTransformer, ResultSet, SessionImplementor) - Method in class org.hibernate.loader.hql.QueryLoader

getResultId() - Method in class org.hibernate.event.SaveOrUpdateEvent

getResultList(List, ResultTransformer) - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getResultList(List, ResultTransformer) - Method in class org.hibernate.loader.Loader

getResultList(List, ResultTransformer) - Method in class org.hibernate.loader.criteria.CriteriaLoader

getResultList(List, ResultTransformer) - Method in class org.hibernate.loader.custom.CustomLoader

getResultList(List, ResultTransformer) - Method in class org.hibernate.loader.hql.QueryLoader

getResultSet(CallableStatement) - Method in class org.hibernate.dialect.DB2Dialect

getResultSet(CallableStatement) - Method in class org.hibernate.dialect.DataDirectOracle9Dialect

getResultSet(CallableStatement) - Method in class org.hibernate.dialect.Dialect

getResultSet(CallableStatement) - Method in class org.hibernate.dialect.MySQLDialect

getResultSet(CallableStatement) - Method in class org.hibernate.dialect.Oracle9Dialect

getResultSet(CallableStatement) - Method in class org.hibernate.dialect.SybaseDialect

getResultSet() - Method in class org.hibernate.impl.AbstractScrollableResults

getResultSet(PreparedStatement) - Method in class org.hibernate.jdbc.AbstractBatcher

getResultSet(CallableStatement, Dialect) - Method in class org.hibernate.jdbc.AbstractBatcher

getResultSet(PreparedStatement) - Method in interface org.hibernate.jdbc.Batcher
Execute the statement and return the result set
getResultSet(CallableStatement, Dialect) - Method in interface org.hibernate.jdbc.Batcher
Execute the statement and return the result set from a callable statement
getResultSet(PreparedStatement, boolean, boolean, RowSelection, SessionImplementor) - Method in class org.hibernate.loader.Loader
Fetch a PreparedStatement, call setMaxRows and then execute it, advance to the first result and return an SQL ResultSet
getResultSetMapping(String) - Method in class org.hibernate.cfg.Mappings

getResultSetMapping(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor

getResultSetMapping(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getResultSetRef() - Method in class org.hibernate.engine.NamedSQLQueryDefinition

getResultTransformer() - Method in class org.hibernate.engine.QueryParameters

getResultTransformer() - Method in class org.hibernate.hql.HolderInstantiator

getResultTransformer() - Method in class org.hibernate.impl.CriteriaImpl

getResultTypes() - Method in class org.hibernate.loader.criteria.CriteriaJoinWalker

getReturnAliases() - Method in interface org.hibernate.Query
Return the HQL select clause aliases (if any)
getReturnAliases(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get the return aliases of a query
getReturnAliases() - Method in class org.hibernate.engine.query.QueryMetadata
Return source query select clause aliases (if any)
getReturnAliases() - Method in class org.hibernate.engine.query.ReturnMetadata

getReturnAliases() - Method in interface org.hibernate.hql.QueryTranslator
Returns an array of HQL aliases
getReturnAliases() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getReturnAliases() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

getReturnAliases() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getReturnAliases() - Method in class org.hibernate.impl.AbstractQueryImpl

getReturnAliases() - Method in class org.hibernate.impl.SQLQueryImpl

getReturnAliases(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getReturnEntityName() - Method in class org.hibernate.engine.query.sql.NativeSQLQueryRootReturn
The name of the entity to be returned.
getReturnMetadata() - Method in class org.hibernate.engine.query.HQLQueryPlan

getReturnType(Type, Mapping) - Method in class org.hibernate.dialect.DerbyDialect.DerbyTrimFunctionEmulation

getReturnType(Type, Mapping) - Method in class org.hibernate.dialect.function.AnsiTrimEmulationFunction

getReturnType(Type, Mapping) - Method in class org.hibernate.dialect.function.CastFunction

getReturnType(Type, Mapping) - Method in class org.hibernate.dialect.function.CharIndexFunction

getReturnType(Type, Mapping) - Method in class org.hibernate.dialect.function.ClassicAvgFunction

getReturnType(Type, Mapping) - Method in class org.hibernate.dialect.function.ClassicCountFunction

getReturnType(Type, Mapping) - Method in class org.hibernate.dialect.function.NoArgSQLFunction

getReturnType(Type, Mapping) - Method in class org.hibernate.dialect.function.NvlFunction

getReturnType(Type, Mapping) - Method in class org.hibernate.dialect.function.PositionSubstringFunction

getReturnType(Type, Mapping) - Method in interface org.hibernate.dialect.function.SQLFunction
The function return type
getReturnType(Type, Mapping) - Method in class org.hibernate.dialect.function.SQLFunctionTemplate

getReturnType(Type, Mapping) - Method in class org.hibernate.dialect.function.StandardSQLFunction

getReturnType(Type, Mapping) - Method in class org.hibernate.dialect.function.VarArgsSQLFunction

getReturnType() - Method in class org.hibernate.property.BackrefPropertyAccessor.BackrefGetter

getReturnType() - Method in class org.hibernate.property.BasicPropertyAccessor.BasicGetter

getReturnType() - Method in class org.hibernate.property.DirectPropertyAccessor.DirectGetter

getReturnType() - Method in class org.hibernate.property.Dom4jAccessor.Dom4jGetter
Get the declared Java type
getReturnType() - Method in class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter

getReturnType() - Method in interface org.hibernate.property.Getter
Get the declared Java type
getReturnType() - Method in class org.hibernate.property.IndexPropertyAccessor.IndexGetter

getReturnType() - Method in class org.hibernate.property.MapAccessor.MapGetter

getReturnTypes() - Method in interface org.hibernate.Query
Return the Hibernate types of the query result set.
getReturnTypes(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get the return types of a query
getReturnTypes() - Method in class org.hibernate.engine.query.QueryMetadata
An array of types describing the returns of the source query.
getReturnTypes() - Method in class org.hibernate.engine.query.ReturnMetadata

getReturnTypes() - Method in interface org.hibernate.hql.QueryTranslator
Returns an array of Types represented in the query result.
getReturnTypes() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getReturnTypes() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl
Types of the return values of an iterate() style query.
getReturnTypes() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl
Types of the return values of an iterate() style query.
getReturnTypes() - Method in class org.hibernate.impl.AbstractQueryImpl

getReturnTypes() - Method in class org.hibernate.impl.SQLQueryImpl

getReturnTypes(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getReturnedClass() - Method in class org.hibernate.type.AbstractCharArrayType

getReturnedClass() - Method in class org.hibernate.type.AdaptedImmutableType

getReturnedClass() - Method in class org.hibernate.type.AnyType

getReturnedClass() - Method in class org.hibernate.type.ArrayType

getReturnedClass() - Method in class org.hibernate.type.BagType

getReturnedClass() - Method in class org.hibernate.type.BigDecimalType

getReturnedClass() - Method in class org.hibernate.type.BigIntegerType

getReturnedClass() - Method in class org.hibernate.type.BinaryType

getReturnedClass() - Method in class org.hibernate.type.BlobType

getReturnedClass() - Method in class org.hibernate.type.BooleanType

getReturnedClass() - Method in class org.hibernate.type.ByteType

getReturnedClass() - Method in class org.hibernate.type.CalendarDateType

getReturnedClass() - Method in class org.hibernate.type.CalendarType

getReturnedClass() - Method in class org.hibernate.type.CharArrayType

getReturnedClass() - Method in class org.hibernate.type.CharacterArrayType

getReturnedClass() - Method in class org.hibernate.type.CharacterType

getReturnedClass() - Method in class org.hibernate.type.ClassType

getReturnedClass() - Method in class org.hibernate.type.ClobType

getReturnedClass() - Method in class org.hibernate.type.ComponentType

getReturnedClass() - Method in class org.hibernate.type.CompositeCustomType

getReturnedClass() - Method in class org.hibernate.type.CurrencyType

getReturnedClass() - Method in class org.hibernate.type.CustomCollectionType

getReturnedClass() - Method in class org.hibernate.type.CustomType

getReturnedClass() - Method in class org.hibernate.type.DateType

getReturnedClass() - Method in class org.hibernate.type.DoubleType

getReturnedClass() - Method in class org.hibernate.type.EntityType
This returns the wrong class for an entity with a proxy, or for a named entity.
getReturnedClass() - Method in class org.hibernate.type.FloatType

getReturnedClass() - Method in class org.hibernate.type.IdentifierBagType

getReturnedClass() - Method in class org.hibernate.type.IntegerType

getReturnedClass() - Method in class org.hibernate.type.ListType

getReturnedClass() - Method in class org.hibernate.type.LocaleType

getReturnedClass() - Method in class org.hibernate.type.LongType

getReturnedClass() - Method in class org.hibernate.type.MapType

getReturnedClass() - Method in class org.hibernate.type.MetaType

getReturnedClass() - Method in class org.hibernate.type.SerializableType

getReturnedClass() - Method in class org.hibernate.type.SetType

getReturnedClass() - Method in class org.hibernate.type.ShortType

getReturnedClass() - Method in class org.hibernate.type.SortedMapType

getReturnedClass() - Method in class org.hibernate.type.SortedSetType

getReturnedClass() - Method in class org.hibernate.type.StringType

getReturnedClass() - Method in class org.hibernate.type.TextType

getReturnedClass() - Method in class org.hibernate.type.TimeType

getReturnedClass() - Method in class org.hibernate.type.TimeZoneType

getReturnedClass() - Method in class org.hibernate.type.TimestampType

getReturnedClass() - Method in interface org.hibernate.type.Type
The class returned by nullSafeGet() methods.
getReturnedClass() - Method in class org.hibernate.type.WrapperBinaryType

getRightHandOperand() - Method in class org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode
Retrieves the right-hand operand of the operator.
getRightHandOperand() - Method in class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode
Retrieves the right-hand operand of the operator.
getRightHandOperand() - Method in interface org.hibernate.hql.ast.tree.BinaryOperatorNode
Retrieves the right-hand operand of the operator.
getRole() - Method in class org.hibernate.collection.AbstractPersistentCollection

getRole() - Method in interface org.hibernate.collection.PersistentCollection
Get the current role name
getRole() - Method in class org.hibernate.engine.CollectionEntry

getRole() - Method in class org.hibernate.engine.CollectionKey

getRole() - Method in class org.hibernate.mapping.Collection

getRole() - Method in interface org.hibernate.metadata.CollectionMetadata
The name of this collection role
getRole() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getRole() - Method in interface org.hibernate.persister.collection.CollectionPersister
Get the name of this collection role (the fully qualified class name, extended by a "property path")
getRole() - Method in class org.hibernate.type.CollectionType

getRoleName() - Method in class org.hibernate.mapping.Component

getRootCause(Throwable) - Static method in class org.hibernate.exception.ExceptionUtils
Introspects the Throwable to obtain the root cause.
getRootCauseStackTrace(Throwable) - Static method in class org.hibernate.exception.ExceptionUtils
Creates a compact stack trace for the root cause of the supplied Throwable.
getRootClass() - Method in class org.hibernate.mapping.PersistentClass

getRootClass() - Method in class org.hibernate.mapping.RootClass

getRootClass() - Method in class org.hibernate.mapping.Subclass

getRootCriteria() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getRootEntityName() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getRootEntityName() - Method in interface org.hibernate.persister.entity.EntityPersister
Returns an object that identifies the space in which identifiers of this class hierarchy are unique.
getRootName() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getRootSQLALias() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getRootTable() - Method in class org.hibernate.mapping.PersistentClass

getRootTable() - Method in class org.hibernate.mapping.RootClass

getRootTable() - Method in class org.hibernate.mapping.Subclass

getRootTableIdentifierColumnNames() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getRootTableIdentifierColumnNames() - Method in interface org.hibernate.persister.entity.Lockable
Get the names of columns on the root table used to persist the identifier.
getRootTableKeyColumnNames() - Method in interface org.hibernate.id.PostInsertIdentityPersister
The names of the primary key columns in the root table.
getRootTableKeyColumnNames() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getRootTableName() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getRootTableName() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getRootTableName() - Method in interface org.hibernate.persister.entity.Lockable
Locks are always applied to the "root table".
getRow() - Method in class org.hibernate.jdbc.ResultSetWrapper

getRowId() - Method in class org.hibernate.engine.EntityEntry

getRowId() - Method in class org.hibernate.mapping.Table

getRowIdAlias() - Method in class org.hibernate.loader.DefaultEntityAliases

getRowIdAlias() - Method in interface org.hibernate.loader.EntityAliases
The result set column alias for the Oracle row id
getRowNumber() - Method in interface org.hibernate.ScrollableResults
Get the current location in the result set.
getRowNumber() - Method in class org.hibernate.impl.FetchingScrollableResultsImpl
Get the current location in the result set.
getRowNumber() - Method in class org.hibernate.impl.ScrollableResultsImpl

getRowSelection() - Method in class org.hibernate.engine.QueryParameters

getRowSelection() - Method in class org.hibernate.impl.AbstractQueryImpl

getSQL() - Method in class org.hibernate.JDBCException
Get the actual SQL statement that caused the exception (may be null)
getSQL() - Method in class org.hibernate.hql.ast.SqlGenerator

getSQL() - Method in interface org.hibernate.loader.custom.CustomQuery
The SQL query string to be performed.
getSQL() - Method in class org.hibernate.loader.custom.sql.SQLCustomQuery

getSQLAlias(Criteria) - Method in interface org.hibernate.criterion.CriteriaQuery
Get the root table alias of an entity
getSQLAlias(Criteria, String) - Method in interface org.hibernate.criterion.CriteriaQuery
Get the root table alias of an entity, taking into account the qualifier of the property path
getSQLAlias(Criteria) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getSQLAlias(Criteria, String) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getSQLAliasCount() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getSQLDeleteRowString() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getSQLDeleteString() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getSQLDeleteStrings() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSQLException() - Method in class org.hibernate.JDBCException
Get the underlying SQLException.
getSQLExceptionConverter() - Method in class org.hibernate.cfg.Settings

getSQLExceptionConverter() - Method in interface org.hibernate.engine.SessionFactoryImplementor
Retrieves the SQLExceptionConverter in effect for this SessionFactory.
getSQLExceptionConverter() - Method in class org.hibernate.impl.SessionFactoryImpl

getSQLExceptionConverter() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getSQLFunction() - Method in class org.hibernate.hql.ast.tree.MethodNode

getSQLIdentityInsertString() - Method in class org.hibernate.persister.entity.AbstractEntityPersister
The query that inserts a row, letting the database generate an id
getSQLInsertRowString() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getSQLInsertStrings() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSQLLazySelectString() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSQLLazyUpdateByRowIdStrings() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSQLLazyUpdateStrings() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSQLOrderByString(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getSQLOrderByString(String) - Method in interface org.hibernate.persister.collection.QueryableCollection
Get the order by SQL
getSQLParameterMetadata(String) - Method in class org.hibernate.engine.query.QueryPlanCache

getSQLSnapshotSelectString() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSQLState() - Method in class org.hibernate.JDBCException
Get the SQLState of the underlying SQLException.
getSQLString() - Method in interface org.hibernate.hql.QueryTranslator
Returns the SQL string generated by the translator.
getSQLString() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl
The SQL query string to be called; implemented by all subclasses
getSQLString() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getSQLString() - Method in class org.hibernate.loader.JoinWalker

getSQLString() - Method in class org.hibernate.loader.Loader
The SQL query string to be called; implemented by all subclasses
getSQLString() - Method in class org.hibernate.loader.OuterJoinLoader

getSQLString() - Method in class org.hibernate.loader.custom.CustomLoader

getSQLString() - Method in class org.hibernate.loader.hql.QueryLoader
The SQL query string to be called.
getSQLUpdateByRowIdStrings() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSQLUpdateRowString() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getSQLUpdateStrings() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSQLWhereString(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getSQLWhereString(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSaveEventListeners() - Method in class org.hibernate.event.EventListeners

getSaveOrUpdateCopyEventListeners() - Method in class org.hibernate.event.EventListeners

getSaveOrUpdateEventListeners() - Method in class org.hibernate.event.EventListeners

getScale() - Method in class org.hibernate.mapping.Column

getSchema() - Method in class org.hibernate.mapping.Table

getSchemaName() - Method in class org.hibernate.cfg.Mappings

getScrollMode() - Method in class org.hibernate.engine.QueryParameters

getSecondLevelCacheEnabled() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Is the second-level cache enabled?
getSecondLevelCacheEnabled() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getSecondLevelCacheHitCount() - Method in class org.hibernate.jmx.StatisticsService

getSecondLevelCacheHitCount() - Method in interface org.hibernate.stat.Statistics
Global number of cacheable entities/collections successfully retrieved from the cache
getSecondLevelCacheHitCount() - Method in class org.hibernate.stat.StatisticsImpl

getSecondLevelCacheMissCount() - Method in class org.hibernate.jmx.StatisticsService

getSecondLevelCacheMissCount() - Method in interface org.hibernate.stat.Statistics
Global number of cacheable entities/collections not found in the cache and loaded from the database.
getSecondLevelCacheMissCount() - Method in class org.hibernate.stat.StatisticsImpl

getSecondLevelCachePutCount() - Method in class org.hibernate.jmx.StatisticsService

getSecondLevelCachePutCount() - Method in interface org.hibernate.stat.Statistics
Global number of cacheable entities/collections put in the cache
getSecondLevelCachePutCount() - Method in class org.hibernate.stat.StatisticsImpl

getSecondLevelCacheRegion(String) - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get a named second-level cache region
getSecondLevelCacheRegion(String) - Method in class org.hibernate.impl.SessionFactoryImpl

getSecondLevelCacheRegionNames() - Method in class org.hibernate.jmx.StatisticsService

getSecondLevelCacheRegionNames() - Method in interface org.hibernate.stat.Statistics
Get all second-level cache region names
getSecondLevelCacheRegionNames() - Method in class org.hibernate.stat.StatisticsImpl
Get all second-level cache region names
getSecondLevelCacheStatistics(String) - Method in class org.hibernate.jmx.StatisticsService

getSecondLevelCacheStatistics(String) - Method in interface org.hibernate.stat.Statistics
Second level cache statistics per region
getSecondLevelCacheStatistics(String) - Method in class org.hibernate.stat.StatisticsImpl
Second level cache statistics per region
getSelect() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getSelectByUniqueKeyString(String) - Method in interface org.hibernate.id.PostInsertIdentityPersister
Get a SQL select string that performs a select based on a unique key determined by the given property name).
getSelectByUniqueKeyString(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSelectClause() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getSelectClause() - Method in class org.hibernate.hql.ast.tree.InsertStatement
Retreive this insert statement's select-clause.
getSelectClause() - Method in class org.hibernate.hql.ast.tree.QueryNode
Locate the select clause that is part of this select statement.
getSelectClauseNullString(int) - Method in class org.hibernate.dialect.DB2Dialect

getSelectClauseNullString(int) - Method in class org.hibernate.dialect.Dialect

getSelectClauseNullString(int) - Method in class org.hibernate.dialect.OracleDialect

getSelectClauseNullString(int) - Method in class org.hibernate.dialect.PostgreSQLDialect
Workaround for postgres bug #1453
getSelectGUIDString() - Method in class org.hibernate.dialect.Dialect

getSelectGUIDString() - Method in class org.hibernate.dialect.MySQLDialect

getSelectGUIDString() - Method in class org.hibernate.dialect.Oracle9Dialect

getSelectGUIDString() - Method in class org.hibernate.dialect.SQLServerDialect

getSelectName() - Method in class org.hibernate.hql.classic.SelectPathExpressionParser

getSelectSQL() - Method in class org.hibernate.id.IdentityGenerator.BasicDelegate

getSelectSQL() - Method in class org.hibernate.id.SelectGenerator.SelectGeneratorDelegate

getSelectSQL() - Method in class org.hibernate.id.insert.AbstractSelectingDelegate
Get the SQL statement to be used to retrieve generated key values.
getSelectSequenceNextValString(String) - Method in class org.hibernate.dialect.Dialect
Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.
getSelectSequenceNextValString(String) - Method in class org.hibernate.dialect.H2Dialect

getSelectSequenceNextValString(String) - Method in class org.hibernate.dialect.HSQLDialect

getSelectSequenceNextValString(String) - Method in class org.hibernate.dialect.InformixDialect

getSelectSequenceNextValString(String) - Method in class org.hibernate.dialect.InterbaseDialect

getSelectSequenceNextValString(String) - Method in class org.hibernate.dialect.MckoiDialect

getSelectSequenceNextValString(String) - Method in class org.hibernate.dialect.Oracle9Dialect

getSelectSequenceNextValString(String) - Method in class org.hibernate.dialect.PostgreSQLDialect

getSelectSequenceNextValString(String) - Method in class org.hibernate.dialect.SAPDBDialect

getSelectSequenceNextValString(String) - Method in class org.hibernate.dialect.TimesTenDialect

getSelectType() - Method in class org.hibernate.hql.ast.tree.FromElement

getSelection() - Method in class org.hibernate.impl.AbstractQueryImpl

getSemiResolvedType(SessionFactoryImplementor) - Method in class org.hibernate.type.AbstractType

getSemiResolvedType(SessionFactoryImplementor) - Method in class org.hibernate.type.EntityType

getSemiResolvedType(SessionFactoryImplementor) - Method in interface org.hibernate.type.Type
Get the type of a semi-resolved value.
getSequence() - Method in class org.hibernate.hql.ast.tree.FromElement

getSequenceName() - Method in class org.hibernate.id.SequenceGenerator

getSequenceNextValString(String) - Method in class org.hibernate.dialect.DB2Dialect

getSequenceNextValString(String) - Method in class org.hibernate.dialect.Dialect
Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
getSequenceNextValString(String) - Method in class org.hibernate.dialect.H2Dialect

getSequenceNextValString(String) - Method in class org.hibernate.dialect.HSQLDialect

getSequenceNextValString(String) - Method in class org.hibernate.dialect.InformixDialect

getSequenceNextValString(String) - Method in class org.hibernate.dialect.IngresDialect
The syntax that fetches the next value of a sequence, if sequences are supported.
getSequenceNextValString(String) - Method in class org.hibernate.dialect.InterbaseDialect

getSequenceNextValString(String) - Method in class org.hibernate.dialect.MckoiDialect

getSequenceNextValString(String) - Method in class org.hibernate.dialect.MimerSQLDialect
The syntax used to get the next value of a sequence in Mimer SQL
getSequenceNextValString(String) - Method in class org.hibernate.dialect.Oracle9Dialect

getSequenceNextValString(String) - Method in class org.hibernate.dialect.PostgreSQLDialect

getSequenceNextValString(String) - Method in class org.hibernate.dialect.RDMSOS2200Dialect

getSequenceNextValString(String) - Method in class org.hibernate.dialect.SAPDBDialect

getSequenceNextValString(String) - Method in class org.hibernate.dialect.TimesTenDialect

getSequentialSelect(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSequentialSelect(String) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getSession(EntityMode) - Method in interface org.hibernate.Session
Starts a new Session with the given entity mode in effect.
getSession() - Method in class org.hibernate.action.CollectionAction

getSession() - Method in class org.hibernate.action.EntityAction

getSession() - Method in class org.hibernate.collection.AbstractPersistentCollection
Get the current session
getSession() - Method in interface org.hibernate.engine.PersistenceContext
Get the session
getSession() - Method in class org.hibernate.engine.StatefulPersistenceContext

getSession() - Method in class org.hibernate.event.AbstractEvent
Returns the session event source for this event.
getSession() - Method in class org.hibernate.impl.AbstractScrollableResults

getSession() - Method in class org.hibernate.impl.CriteriaImpl

getSession(EntityMode) - Method in class org.hibernate.impl.SessionImpl

getSession() - Method in class org.hibernate.intercept.AbstractFieldInterceptor

getSession() - Method in class org.hibernate.proxy.AbstractLazyInitializer

getSession() - Method in interface org.hibernate.proxy.LazyInitializer
Get the session, if this proxy is attached
getSessionCloseCount() - Method in class org.hibernate.jmx.StatisticsService

getSessionCloseCount() - Method in interface org.hibernate.stat.Statistics
Global number of sessions closed
getSessionCloseCount() - Method in class org.hibernate.stat.StatisticsImpl

getSessionFactory() - Method in interface org.hibernate.Session
Get the SessionFactory that created this instance.
getSessionFactory() - Method in class org.hibernate.impl.SessionImpl

getSessionFactory() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getSessionFactoryHelper() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getSessionFactoryHelper() - Method in class org.hibernate.hql.ast.tree.HqlSqlWalkerNode

getSessionFactoryName() - Method in class org.hibernate.cfg.Settings

getSessionOpenCount() - Method in class org.hibernate.jmx.StatisticsService

getSessionOpenCount() - Method in interface org.hibernate.stat.Statistics
Global number of sessions opened
getSessionOpenCount() - Method in class org.hibernate.stat.StatisticsImpl

getSetClause() - Method in class org.hibernate.hql.ast.tree.UpdateStatement

getSetter(Class) - Method in class org.hibernate.mapping.Property

getSetter(Class, String) - Method in class org.hibernate.property.BackrefPropertyAccessor

getSetter(Class, String) - Method in class org.hibernate.property.BasicPropertyAccessor

getSetter(Class, String) - Method in class org.hibernate.property.ChainedPropertyAccessor

getSetter(Class, String) - Method in class org.hibernate.property.DirectPropertyAccessor

getSetter(Class, String) - Method in class org.hibernate.property.Dom4jAccessor
Create a "setter" for the named attribute
getSetter(Class, String) - Method in class org.hibernate.property.EmbeddedPropertyAccessor

getSetter(Class, String) - Method in class org.hibernate.property.IndexPropertyAccessor

getSetter(Class, String) - Method in class org.hibernate.property.MapAccessor

getSetter(Class, String) - Method in class org.hibernate.property.NoopAccessor

getSetter(Class, String) - Method in interface org.hibernate.property.PropertyAccessor
Create a "setter" for the named attribute
getSetters() - Method in class org.hibernate.bytecode.javassist.BulkAccessor
Returns the getter names of the properties.
getSettings() - Method in interface org.hibernate.engine.SessionFactoryImplementor

getSettings() - Method in class org.hibernate.impl.SessionFactoryImpl

getShort(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a short
getShort(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getShort(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getShort(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getShowSqlEnabled() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Is SQL logging enabled?
getShowSqlEnabled() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getSize(Serializable, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getSize(Serializable, SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister

getSizeInMemory() - Method in interface org.hibernate.cache.Cache
The number of bytes is this cache region currently consuming in memory.
getSizeInMemory() - Method in class org.hibernate.cache.EhCache
Warning: This method can be very expensive to run.
getSizeInMemory() - Method in class org.hibernate.cache.HashtableCache

getSizeInMemory() - Method in class org.hibernate.cache.OSCache

getSizeInMemory() - Method in class org.hibernate.cache.OptimisticTreeCache

getSizeInMemory() - Method in class org.hibernate.cache.SwarmCache

getSizeInMemory() - Method in class org.hibernate.cache.TreeCache

getSizeInMemory() - Method in class org.hibernate.stat.SecondLevelCacheStatistics

getSnapshot() - Method in class org.hibernate.collection.AbstractPersistentCollection
Get the current snapshot from the session
getSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentArrayHolder

getSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentBag

getSnapshot(CollectionPersister) - Method in interface org.hibernate.collection.PersistentCollection
Return a new snapshot of the current state of the collection
getSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentElementHolder

getSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentIdentifierBag

getSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

getSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentList

getSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentMap

getSnapshot(CollectionPersister) - Method in class org.hibernate.collection.PersistentSet

getSnapshot() - Method in class org.hibernate.engine.CollectionEntry

getSnapshot(PersistentCollection) - Method in interface org.hibernate.engine.PersistenceContext
Get the snapshot of the pre-flush collection state
getSnapshot(PersistentCollection) - Method in class org.hibernate.engine.StatefulPersistenceContext
Get the snapshot of the pre-flush collection state
getSnapshotElement(Object, int) - Method in class org.hibernate.collection.PersistentArrayHolder

getSnapshotElement(Object, int) - Method in class org.hibernate.collection.PersistentBag

getSnapshotElement(Object, int) - Method in interface org.hibernate.collection.PersistentCollection
Get the snapshot value of the given collection entry
getSnapshotElement(Object, int) - Method in class org.hibernate.collection.PersistentElementHolder

getSnapshotElement(Object, int) - Method in class org.hibernate.collection.PersistentIdentifierBag

getSnapshotElement(Object, int) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

getSnapshotElement(Object, int) - Method in class org.hibernate.collection.PersistentList

getSnapshotElement(Object, int) - Method in class org.hibernate.collection.PersistentMap

getSnapshotElement(Object, int) - Method in class org.hibernate.collection.PersistentSet

getSource() - Method in class org.hibernate.event.PreInsertEvent

getSource() - Method in class org.hibernate.event.PreUpdateEvent

getSourceColumn() - Method in class org.hibernate.param.AbstractExplicitParameterSpecification

getSourceColumn() - Method in interface org.hibernate.param.ExplicitParameterSpecification

getSourceLine() - Method in class org.hibernate.param.AbstractExplicitParameterSpecification

getSourceLine() - Method in interface org.hibernate.param.ExplicitParameterSpecification

getSourceLocation() - Method in class org.hibernate.engine.query.OrdinalParameterDescriptor

getSourceLocations() - Method in class org.hibernate.engine.query.NamedParameterDescriptor

getSourceQuery() - Method in class org.hibernate.engine.query.HQLQueryPlan

getSourceQuery() - Method in class org.hibernate.engine.query.NativeSQLQueryPlan

getSourceQuery() - Method in class org.hibernate.engine.query.QueryMetadata
Get the source HQL or native-SQL query.
getSqlAST() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

getSqlAliasSuffixes() - Method in class org.hibernate.loader.hql.QueryLoader

getSqlAssignmentFragment() - Method in class org.hibernate.hql.ast.tree.AssignmentSpecification

getSqlFunctionRegistry() - Method in interface org.hibernate.engine.SessionFactoryImplementor

getSqlFunctionRegistry() - Method in class org.hibernate.impl.SessionFactoryImpl

getSqlFunctions() - Method in class org.hibernate.cfg.Configuration

getSqlLocations() - Method in class org.hibernate.hql.ast.ParameterTranslationsImpl.ParameterInfo

getSqlResultSetMappings() - Method in class org.hibernate.cfg.Configuration

getSqlStatements() - Method in class org.hibernate.hql.ast.exec.BasicExecutor

getSqlStatements() - Method in class org.hibernate.hql.ast.exec.MultiTableDeleteExecutor

getSqlStatements() - Method in class org.hibernate.hql.ast.exec.MultiTableUpdateExecutor

getSqlStatements() - Method in interface org.hibernate.hql.ast.exec.StatementExecutor

getSqlStrings() - Method in class org.hibernate.engine.query.HQLQueryPlan

getSqlType(Dialect, Mapping) - Method in class org.hibernate.mapping.Column

getSqlType() - Method in class org.hibernate.mapping.Column

getSqlTypeCode(Mapping) - Method in class org.hibernate.mapping.Column

getSqlTypeCode() - Method in class org.hibernate.mapping.Column
Returns the underlying columns sqltypecode.
getStackFrames(Throwable) - Static method in class org.hibernate.exception.ExceptionUtils
Captures the stack trace associated with the specified Throwable object, decomposing it into a list of stack frames.
getStackFrames(Throwable) - Method in class org.hibernate.exception.NestableDelegate
Captures the stack trace associated with the specified Throwable object, decomposing it into a list of stack frames.
getStackTrace(Throwable) - Static method in class org.hibernate.exception.ExceptionUtils
Gets the stack trace from a Throwable as a String.
getStartTime() - Method in class org.hibernate.jmx.StatisticsService

getStartTime() - Method in interface org.hibernate.stat.Statistics

getStartTime() - Method in class org.hibernate.stat.StatisticsImpl

getState() - Method in class org.hibernate.cache.entry.CollectionCacheEntry

getState() - Method in class org.hibernate.event.PostInsertEvent

getState() - Method in class org.hibernate.event.PostUpdateEvent

getState() - Method in class org.hibernate.event.PreInsertEvent

getState() - Method in class org.hibernate.event.PreLoadEvent

getState() - Method in class org.hibernate.event.PreUpdateEvent

getStatement() - Method in class org.hibernate.jdbc.AbstractBatcher

getStatement() - Method in class org.hibernate.jdbc.ResultSetWrapper

getStatementType() - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

getStatementType() - Method in class org.hibernate.hql.ast.tree.DeleteStatement

getStatementType() - Method in class org.hibernate.hql.ast.tree.InsertStatement

getStatementType() - Method in class org.hibernate.hql.ast.tree.QueryNode

getStatementType() - Method in interface org.hibernate.hql.ast.tree.Statement
Return the main token type representing the type of this statement.
getStatementType() - Method in class org.hibernate.hql.ast.tree.UpdateStatement

getStatistics() - Method in interface org.hibernate.Session
Get the statistics for this session.
getStatistics() - Method in interface org.hibernate.SessionFactory
Get the statistics for this session factory
getStatistics() - Method in class org.hibernate.impl.SessionFactoryImpl

getStatistics() - Method in class org.hibernate.impl.SessionImpl

getStatistics() - Method in class org.hibernate.jmx.SessionFactoryStub

getStatisticsImplementor() - Method in interface org.hibernate.engine.SessionFactoryImplementor
Statistics SPI
getStatisticsImplementor() - Method in class org.hibernate.impl.SessionFactoryImpl

getStatus() - Method in class org.hibernate.engine.EntityEntry

getStatus() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter

getStatus() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter

getStoredSnapshot() - Method in class org.hibernate.collection.AbstractPersistentCollection

getStoredSnapshot() - Method in interface org.hibernate.collection.PersistentCollection
Get the snapshot cached by the collection instance
getStreamsForBinaryEnabled() - Method in class org.hibernate.util.ExternalSessionFactoryConfig

getString(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a string
getString(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getString(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getString(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getString(String, Properties, String) - Static method in class org.hibernate.util.PropertiesHelper

getStringBuffer() - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

getStringValue() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getStringValue() - Method in class org.hibernate.tuple.ElementWrapper

getSubString(long, int) - Method in class org.hibernate.lob.ClobImpl

getSubString(long, int) - Method in class org.hibernate.lob.SerializableClob

getSubclass() - Method in class org.hibernate.cache.entry.CacheEntry

getSubclassClosure() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getSubclassClosure() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getSubclassClosureIterator() - Method in class org.hibernate.mapping.PersistentClass

getSubclassColumnAliasClosure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassColumnClosure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassColumnLazyiness() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassColumnTableNumberClosure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassColumnTableNumberClosure() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getSubclassColumnTableNumberClosure() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getSubclassColumnTableNumberClosure() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getSubclassEntityNames() - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer
Retreives the defined entity-names for any subclasses defined for this entity.
getSubclassEntityNames() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getSubclassEntityPersister(Object, SessionFactoryImplementor, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassEntityPersister(Object, SessionFactoryImplementor, EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Get the persister for an instance of this class or a subclass
getSubclassForDiscriminatorValue(Object) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getSubclassForDiscriminatorValue(Object) - Method in interface org.hibernate.persister.entity.Loadable
Get the concrete subclass corresponding to the given discriminator value
getSubclassForDiscriminatorValue(Object) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getSubclassForDiscriminatorValue(Object) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getSubclassFormulaAliasClosure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassFormulaClosure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassFormulaLazyiness() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassFormulaTableNumberClosure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassFormulaTableNumberClosure() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getSubclassFormulaTableNumberClosure() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getSubclassFormulaTableNumberClosure() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getSubclassFormulaTemplateClosure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassId() - Method in class org.hibernate.mapping.PersistentClass

getSubclassId() - Method in class org.hibernate.mapping.RootClass

getSubclassId() - Method in class org.hibernate.mapping.Subclass

getSubclassIterator() - Method in class org.hibernate.mapping.PersistentClass
Iterate over subclasses in a special 'order', most derived subclasses first.
getSubclassJoinClosureIterator() - Method in class org.hibernate.mapping.PersistentClass

getSubclassPropertyClosureIterator() - Method in class org.hibernate.mapping.PersistentClass

getSubclassPropertyColumnAliases(String, String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassPropertyColumnAliases(String, String) - Method in interface org.hibernate.persister.entity.SQLLoadable
Return the column alias names used to persist/query the named property of the class or a subclass (optional operation).
getSubclassPropertyColumnNameClosure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassPropertyColumnNames(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassPropertyColumnNames(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassPropertyColumnNames(int) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
Return the column names used to persist the numbered property of the class or a subclass.
getSubclassPropertyColumnNames(String) - Method in interface org.hibernate.persister.entity.SQLLoadable
Return the column names used to persist/query the named property of the class or a subclass (optional operation).
getSubclassPropertyFormulaTemplateClosure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassPropertyName(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassPropertyName(int) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
Get the name of the numbered property of the class or a subclass.
getSubclassPropertyNameClosure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassPropertySubclassNameClosure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassPropertyTableName(int) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getSubclassPropertyTableName(int) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
Return the table name used to persist the numbered property of the class or a subclass.
getSubclassPropertyTableName(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getSubclassPropertyTableName(int) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getSubclassPropertyTableNumber(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassPropertyTableNumber(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Warning: When there are duplicated property names in the subclasses of the class, this method may return the wrong table number for the duplicated subclass property (note that SingleTableEntityPersister defines an overloaded form which takes the entity name.
getSubclassPropertyTableNumber(int) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getSubclassPropertyTableNumber(String) - Method in interface org.hibernate.persister.entity.Queryable
Given a property name, determine the number of the table which contains the column to which this property is mapped.
getSubclassPropertyTableNumber(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getSubclassPropertyTableNumber(int) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getSubclassPropertyTableNumber(String) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getSubclassPropertyType(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassPropertyType(int) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
Get the type of the numbered property of the class or a subclass.
getSubclassPropertyTypeClosure() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassSpan() - Method in class org.hibernate.mapping.PersistentClass

getSubclassTableClosureIterator() - Method in class org.hibernate.mapping.PersistentClass

getSubclassTableKeyColumns(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassTableKeyColumns(int) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getSubclassTableKeyColumns(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getSubclassTableKeyColumns(int) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getSubclassTableName(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassTableName(int) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getSubclassTableName(int) - Method in interface org.hibernate.persister.entity.Queryable
Get the name of the table with the given index from the internal array.
getSubclassTableName(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getSubclassTableName(int) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getSubclassTableSpan() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getSubclassTableSpan() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getSubclassTableSpan() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getSubclassTableSpan() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getSubselect(EntityKey) - Method in class org.hibernate.engine.BatchFetchQueue
Retrieve the fetch descriptor associated with the given entity key.
getSubselect() - Method in class org.hibernate.mapping.Table

getSubtypes() - Method in interface org.hibernate.type.AbstractComponentType
Get the types of the component properties
getSubtypes() - Method in class org.hibernate.type.AnyType

getSubtypes() - Method in class org.hibernate.type.ComponentType

getSubtypes() - Method in class org.hibernate.type.CompositeCustomType

getSuccessfulTransactionCount() - Method in class org.hibernate.jmx.StatisticsService

getSuccessfulTransactionCount() - Method in interface org.hibernate.stat.Statistics
The number of transactions we know to have been successful
getSuccessfulTransactionCount() - Method in class org.hibernate.stat.StatisticsImpl

getSuffix() - Method in interface org.hibernate.loader.CollectionAliases
Returns the suffix used to unique the column aliases for this particular alias set.
getSuffix() - Method in class org.hibernate.loader.GeneratedCollectionAliases
Returns the suffix used to unique the column aliases for this particular alias set.
getSuffix() - Method in class org.hibernate.loader.custom.ColumnCollectionAliases
Returns the suffix used to unique the column aliases for this particular alias set.
getSuffixedDiscriminatorAlias() - Method in class org.hibernate.loader.DefaultEntityAliases

getSuffixedDiscriminatorAlias() - Method in interface org.hibernate.loader.EntityAliases
The result set column aliases for the discriminator columns
getSuffixedElementAliases() - Method in interface org.hibernate.loader.CollectionAliases
Returns the suffixed result-set column-aliases for the columns making up the collection's elements.
getSuffixedElementAliases() - Method in class org.hibernate.loader.GeneratedCollectionAliases
Returns the suffixed result-set column-aliases for the columns making up the collection's elements.
getSuffixedElementAliases() - Method in class org.hibernate.loader.custom.ColumnCollectionAliases
Returns the suffixed result-set column-aliases for the columns making up the collection's elements.
getSuffixedIdentifierAlias() - Method in interface org.hibernate.loader.CollectionAliases
Returns the suffixed result-set column-aliases for the column defining the collection's identifier (if any).
getSuffixedIdentifierAlias() - Method in class org.hibernate.loader.GeneratedCollectionAliases
Returns the suffixed result-set column-aliases for the column defining the collection's identifier (if any).
getSuffixedIdentifierAlias() - Method in class org.hibernate.loader.custom.ColumnCollectionAliases
Returns the suffixed result-set column-aliases for the column defining the collection's identifier (if any).
getSuffixedIndexAliases() - Method in interface org.hibernate.loader.CollectionAliases
Returns the suffixed result-set column-aliases for the collumns making up the collection's index (map or list).
getSuffixedIndexAliases() - Method in class org.hibernate.loader.GeneratedCollectionAliases
Returns the suffixed result-set column-aliases for the collumns making up the collection's index (map or list).
getSuffixedIndexAliases() - Method in class org.hibernate.loader.custom.ColumnCollectionAliases
Returns the suffixed result-set column-aliases for the collumns making up the collection's index (map or list).
getSuffixedKeyAliases() - Method in interface org.hibernate.loader.CollectionAliases
Returns the suffixed result-set column-aliases for columns making up the key for this collection (i.e., its FK to its owner).
getSuffixedKeyAliases() - Method in class org.hibernate.loader.DefaultEntityAliases

getSuffixedKeyAliases() - Method in interface org.hibernate.loader.EntityAliases
The result set column aliases for the primary key columns
getSuffixedKeyAliases() - Method in class org.hibernate.loader.GeneratedCollectionAliases
Returns the suffixed result-set column-aliases for columns making up the key for this collection (i.e., its FK to its owner).
getSuffixedKeyAliases() - Method in class org.hibernate.loader.custom.ColumnCollectionAliases
Returns the suffixed result-set column-aliases for columns making up the key for this collection (i.e., its FK to its owner).
getSuffixedPropertyAliases(Loadable) - Method in class org.hibernate.loader.DefaultEntityAliases

getSuffixedPropertyAliases() - Method in class org.hibernate.loader.DefaultEntityAliases

getSuffixedPropertyAliases() - Method in interface org.hibernate.loader.EntityAliases
The result set column aliases for the property columns
getSuffixedPropertyAliases(Loadable) - Method in interface org.hibernate.loader.EntityAliases
The result set column aliases for the property columns of a subclass
getSuffixedVersionAliases() - Method in class org.hibernate.loader.DefaultEntityAliases

getSuffixedVersionAliases() - Method in interface org.hibernate.loader.EntityAliases
The result set column aliases for the version columns
getSuffixes() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

getSuffixes() - Method in class org.hibernate.loader.BasicLoader

getSuffixes() - Method in class org.hibernate.loader.JoinWalker

getSuffixes() - Method in class org.hibernate.loader.OuterJoinLoader

getSuffixes() - Method in class org.hibernate.loader.hql.QueryLoader

getSuperclass() - Method in class org.hibernate.mapping.PersistentClass

getSuperclass() - Method in class org.hibernate.mapping.RootClass

getSuperclass() - Method in class org.hibernate.mapping.Subclass

getSuperclass() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getSynchronizedTables() - Method in class org.hibernate.mapping.Collection

getSynchronizedTables() - Method in class org.hibernate.mapping.PersistentClass

getSynchronizedTables() - Method in class org.hibernate.mapping.RootClass

getSynchronizedTables() - Method in class org.hibernate.mapping.Subclass

getSynchronizedTables() - Method in class org.hibernate.mapping.UnionSubclass

getTable(String, String, String) - Method in class org.hibernate.cfg.Mappings

getTable() - Method in class org.hibernate.mapping.Collection

getTable() - Method in class org.hibernate.mapping.Constraint

getTable() - Method in class org.hibernate.mapping.Index

getTable() - Method in class org.hibernate.mapping.Join

getTable() - Method in class org.hibernate.mapping.JoinedSubclass

getTable() - Method in class org.hibernate.mapping.OneToMany
Table of the owner entity (the "one" side)
getTable() - Method in class org.hibernate.mapping.PersistentClass

getTable() - Method in class org.hibernate.mapping.RootClass

getTable() - Method in class org.hibernate.mapping.SimpleValue

getTable() - Method in class org.hibernate.mapping.Subclass

getTable() - Method in class org.hibernate.mapping.UnionSubclass

getTable() - Method in interface org.hibernate.mapping.Value

getTableAlias() - Method in class org.hibernate.hql.ast.tree.FromElement

getTableClosureIterator() - Method in class org.hibernate.mapping.PersistentClass

getTableClosureIterator() - Method in class org.hibernate.mapping.RootClass

getTableClosureIterator() - Method in class org.hibernate.mapping.Subclass

getTableComment(String) - Method in class org.hibernate.dialect.Dialect

getTableComment(String) - Method in class org.hibernate.dialect.MySQLDialect

getTableHasColumns() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getTableMappings() - Method in class org.hibernate.cfg.Configuration
Iterate the table mappings
getTableMetadata(String, String, String) - Method in class org.hibernate.tool.hbm2ddl.DatabaseMetadata

getTableName() - Method in class org.hibernate.hql.ast.tree.IntoClause

getTableName() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getTableName() - Method in class org.hibernate.persister.collection.OneToManyPersister

getTableName(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getTableName() - Method in interface org.hibernate.persister.entity.Joinable
The table to join to.
getTableName(int) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getTableName() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getTableName() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getTableName(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getTableName() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getTableName(int) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getTableName() - Method in class org.hibernate.sql.Update

getTableSpan() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getTableSpan() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

getTableSpan() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

getTableSpan() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

getTableTypeString() - Method in class org.hibernate.dialect.Dialect

getTableTypeString() - Method in class org.hibernate.dialect.MySQL5InnoDBDialect

getTableTypeString() - Method in class org.hibernate.dialect.MySQLInnoDBDialect

getTableTypeString() - Method in class org.hibernate.dialect.MySQLMyISAMDialect

getTableUpdateNeeded(int[], boolean) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Decide which tables need to be updated
getTarget() - Method in class org.hibernate.proxy.AbstractLazyInitializer

getTemplate(Dialect, SQLFunctionRegistry) - Method in class org.hibernate.mapping.Column

getTemplate(Dialect, SQLFunctionRegistry) - Method in class org.hibernate.mapping.Formula

getTemplate(Dialect, SQLFunctionRegistry) - Method in interface org.hibernate.mapping.Selectable

getTemporaryIdTableDDL() - Method in class org.hibernate.mapping.PersistentClass

getTemporaryIdTableDDL() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getTemporaryIdTableDDL() - Method in interface org.hibernate.persister.entity.Queryable
Get the appropriate DDL command for generating the temporary table to be used to (potentially) store id values when performing bulk update/deletes.
getTemporaryIdTableName() - Method in class org.hibernate.mapping.PersistentClass

getTemporaryIdTableName() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getTemporaryIdTableName() - Method in interface org.hibernate.persister.entity.Queryable
Get the name of the temporary table to be used to (potentially) store id values when performing bulk update/deletes.
getText(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read text
getText(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getText(Dialect) - Method in class org.hibernate.mapping.Column

getText() - Method in class org.hibernate.mapping.Column

getText(Dialect) - Method in class org.hibernate.mapping.Formula

getText() - Method in class org.hibernate.mapping.Formula

getText(Dialect) - Method in interface org.hibernate.mapping.Selectable

getText() - Method in interface org.hibernate.mapping.Selectable

getText() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getText() - Method in class org.hibernate.tuple.ElementWrapper

getTextLength() - Method in class org.hibernate.hql.ast.tree.Node

getTextTrim() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getTextTrim() - Method in class org.hibernate.tuple.ElementWrapper

getThrowable(int) - Method in interface org.hibernate.exception.Nestable
Returns the Throwable in the chain of Throwables at the specified index, numbererd from 0.
getThrowable(int) - Method in class org.hibernate.exception.NestableDelegate
Returns the Throwable in the chain of Throwables at the specified index, numbererd from 0.
getThrowable(int) - Method in class org.hibernate.exception.NestableException

getThrowable(int) - Method in class org.hibernate.exception.NestableRuntimeException

getThrowableCount(Throwable) - Static method in class org.hibernate.exception.ExceptionUtils
Counts the number of Throwable objects in the exception chain.
getThrowableCount() - Method in interface org.hibernate.exception.Nestable
Returns the number of nested Throwables represented by this Nestable, including this Nestable.
getThrowableCount() - Method in class org.hibernate.exception.NestableDelegate
Returns the number of Throwables contained in the Nestable contained by this delegate.
getThrowableCount() - Method in class org.hibernate.exception.NestableException

getThrowableCount() - Method in class org.hibernate.exception.NestableRuntimeException

getThrowables(Throwable) - Static method in class org.hibernate.exception.ExceptionUtils
Returns the list of Throwable objects in the exception chain.
getThrowables() - Method in interface org.hibernate.exception.Nestable
Returns this Nestable and any nested Throwables in an array of Throwables, one element for each Throwable.
getThrowables() - Method in class org.hibernate.exception.NestableDelegate
Returns this delegate's Nestable and any nested Throwables in an array of Throwables, one element for each Throwable.
getThrowables() - Method in class org.hibernate.exception.NestableException

getThrowables() - Method in class org.hibernate.exception.NestableRuntimeException

getTime(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getTime(String, Calendar) - Method in class org.hibernate.jdbc.ResultSetWrapper

getTime(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getTime(int, Calendar) - Method in class org.hibernate.jdbc.ResultSetWrapper

getTimeZone(int) - Method in interface org.hibernate.ScrollableResults
Convenience method to read a timezone
getTimeZone(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getTimeout() - Method in interface org.hibernate.cache.Cache
Get a reasonable "lock timeout"
getTimeout() - Method in class org.hibernate.cache.EhCache
Returns the lock timeout for this cache.
getTimeout() - Method in class org.hibernate.cache.HashtableCache

getTimeout() - Method in class org.hibernate.cache.OSCache

getTimeout() - Method in class org.hibernate.cache.OptimisticTreeCache

getTimeout() - Method in class org.hibernate.cache.SwarmCache
Get a reasonable "lock timeout"
getTimeout() - Method in class org.hibernate.cache.TreeCache

getTimeout() - Method in class org.hibernate.engine.NamedQueryDefinition

getTimeout() - Method in class org.hibernate.engine.RowSelection

getTimeout() - Method in class org.hibernate.impl.CriteriaImpl

getTimestamp() - Method in interface org.hibernate.engine.SessionImplementor
System time before the start of the transaction
getTimestamp() - Method in class org.hibernate.impl.SessionImpl

getTimestamp() - Method in class org.hibernate.impl.StatelessSessionImpl

getTimestamp(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getTimestamp(String, Calendar) - Method in class org.hibernate.jdbc.ResultSetWrapper

getTimestamp(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getTimestamp(int, Calendar) - Method in class org.hibernate.jdbc.ResultSetWrapper

getTokenReplacements() - Method in class org.hibernate.hql.ast.HqlSqlWalker

getTransaction() - Method in interface org.hibernate.Session
Get the Transaction instance associated with this session.
getTransaction() - Method in interface org.hibernate.StatelessSession
Get the current Hibernate transaction.
getTransaction() - Method in class org.hibernate.impl.SessionImpl

getTransaction() - Method in class org.hibernate.impl.StatelessSessionImpl

getTransaction() - Method in class org.hibernate.jdbc.JDBCContext

getTransaction() - Method in class org.hibernate.transaction.CMTTransaction

getTransaction() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter

getTransactionCount() - Method in class org.hibernate.jmx.StatisticsService

getTransactionCount() - Method in interface org.hibernate.stat.Statistics
The number of transactions we know to have completed
getTransactionCount() - Method in class org.hibernate.stat.StatisticsImpl

getTransactionFactory() - Method in class org.hibernate.cfg.Settings

getTransactionFactory() - Method in class org.hibernate.impl.SessionFactoryImpl

getTransactionManager() - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get the JTA transaction manager
getTransactionManager() - Method in class org.hibernate.impl.SessionFactoryImpl

getTransactionManager(Properties) - Method in class org.hibernate.transaction.JNDITransactionManagerLookup

getTransactionManager(Properties) - Method in class org.hibernate.transaction.JOTMTransactionManagerLookup

getTransactionManager(Properties) - Method in class org.hibernate.transaction.JOnASTransactionManagerLookup

getTransactionManager(Properties) - Method in interface org.hibernate.transaction.TransactionManagerLookup
Obtain the JTA TransactionManager
getTransactionManager(Properties) - Static method in class org.hibernate.transaction.TransactionManagerLookupFactory

getTransactionManager(Properties) - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup

getTransactionManager(Properties) - Method in class org.hibernate.transaction.WebSphereTransactionManagerLookup

getTransactionManagerLookup() - Method in class org.hibernate.cfg.Settings

getTransactionManagerLookup(Properties) - Static method in class org.hibernate.transaction.TransactionManagerLookupFactory

getTransactionManagerLookupStrategy() - Method in class org.hibernate.jmx.HibernateService

getTransactionManagerLookupStrategy() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Get the strategy for obtaining the JTA TransactionManager
getTransactionStrategy() - Method in class org.hibernate.jmx.HibernateService

getTransactionStrategy() - Method in interface org.hibernate.jmx.HibernateServiceMBean
The fully qualified class name of the Hibernate TransactionFactory implementation
getTransformer(ClassFilter, FieldFilter) - Method in interface org.hibernate.bytecode.BytecodeProvider
Generate a ClassTransformer capable of performing bytecode manipulation.
getTransformer(ClassFilter, FieldFilter) - Method in class org.hibernate.bytecode.cglib.BytecodeProviderImpl

getTransformer(ClassFilter, FieldFilter) - Method in class org.hibernate.bytecode.javassist.BytecodeProviderImpl

getTranslators() - Method in class org.hibernate.engine.query.HQLQueryPlan

getTreeCacheInstance() - Method in class org.hibernate.cache.JndiBoundTreeCacheProvider

getTrueString() - Method in class org.hibernate.type.CharBooleanType

getTrueString() - Method in class org.hibernate.type.TrueFalseType

getTrueString() - Method in class org.hibernate.type.YesNoType

getTuplizer(SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getTuplizer(EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getTuplizer(EntityMode) - Method in class org.hibernate.tuple.EntityModeToTuplizerMapping
Locate the tuplizer contained within this mapping which is responsible for the given entity-mode.
getTuplizer(EntityMode) - Method in class org.hibernate.tuple.entity.EntityMetamodel

getTuplizerImplClassName(EntityMode) - Method in class org.hibernate.mapping.Component

getTuplizerImplClassName(EntityMode) - Method in class org.hibernate.mapping.PersistentClass

getTuplizerImplClassName(EntityMode) - Method in class org.hibernate.mapping.Subclass

getTuplizerMap() - Method in class org.hibernate.mapping.Component

getTuplizerMap() - Method in class org.hibernate.mapping.PersistentClass

getTuplizerMap() - Method in class org.hibernate.mapping.Subclass

getTuplizerMapping() - Method in class org.hibernate.tuple.component.ComponentMetamodel

getTuplizerOrNull(EntityMode) - Method in class org.hibernate.tuple.EntityModeToTuplizerMapping
Locate the contained tuplizer responsible for the given entity-mode.
getTuplizerOrNull(EntityMode) - Method in class org.hibernate.tuple.entity.EntityMetamodel

getType() - Method in class org.hibernate.DuplicateMappingException

getType() - Method in class org.hibernate.InvalidMappingException

getType() - Method in class org.hibernate.MappingNotFoundException

getType(int) - Method in interface org.hibernate.ScrollableResults
Get the type of the ith column of results
getType(Criteria, String) - Method in interface org.hibernate.criterion.CriteriaQuery
Get the type of a property path, ignoring projection aliases
getType() - Method in class org.hibernate.engine.TypedValue

getType() - Method in class org.hibernate.engine.query.sql.NativeSQLQueryScalarReturn

getType(int) - Method in class org.hibernate.impl.AbstractScrollableResults

getType() - Method in class org.hibernate.jdbc.ResultSetWrapper

getType(Criteria, String) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getType() - Method in class org.hibernate.loader.custom.ScalarReturn

getType() - Method in class org.hibernate.mapping.Any

getType() - Method in class org.hibernate.mapping.Collection

getType() - Method in class org.hibernate.mapping.Component

getType() - Method in class org.hibernate.mapping.DependantValue

getType() - Method in class org.hibernate.mapping.ManyToOne

getType() - Method in class org.hibernate.mapping.OneToMany

getType() - Method in class org.hibernate.mapping.OneToOne

getType() - Method in class org.hibernate.mapping.Property

getType() - Method in class org.hibernate.mapping.SimpleValue

getType() - Method in class org.hibernate.mapping.ToOne

getType() - Method in interface org.hibernate.mapping.Value

getType() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getType() - Method in class org.hibernate.persister.collection.CollectionPropertyMapping

getType() - Method in class org.hibernate.persister.collection.CompositeElementPropertyMapping

getType() - Method in class org.hibernate.persister.collection.ElementPropertyMapping

getType() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getType() - Method in class org.hibernate.persister.entity.BasicEntityPropertyMapping

getType() - Method in interface org.hibernate.persister.entity.PropertyMapping
Get the type of the thing containing the properties
getType() - Method in interface org.hibernate.persister.entity.SQLLoadable
Get the type
getType() - Method in class org.hibernate.tuple.Property

getTypeClass() - Method in class org.hibernate.mapping.TypeDef

getTypeCode() - Method in class org.hibernate.tool.hbm2ddl.ColumnMetadata

getTypeDef(String) - Method in class org.hibernate.cfg.Mappings

getTypeFromXML(Element) - Static method in class org.hibernate.cfg.HbmBinder

getTypeIndex() - Method in class org.hibernate.mapping.Column

getTypeInternal() - Method in class org.hibernate.hql.ast.tree.BooleanLiteralNode

getTypeName(int) - Method in class org.hibernate.dialect.Dialect
Get the name of the database type associated with the given java.sql.Types typecode.
getTypeName(int, int, int, int) - Method in class org.hibernate.dialect.Dialect
Get the name of the database type associated with the given java.sql.Types typecode.
getTypeName() - Method in class org.hibernate.mapping.Collection

getTypeName() - Method in class org.hibernate.mapping.SimpleValue

getTypeName() - Method in class org.hibernate.tool.hbm2ddl.ColumnMetadata

getTypeParameters() - Method in class org.hibernate.mapping.SimpleValue

getTypeUsingProjection(Criteria, String) - Method in interface org.hibernate.criterion.CriteriaQuery
Get the type of a property path
getTypeUsingProjection(Criteria, String) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getTypedIdentifierValue(Criteria, Object) - Method in interface org.hibernate.criterion.CriteriaQuery

getTypedIdentifierValue(Criteria, Object) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getTypedValue(Criteria, String, Object) - Method in interface org.hibernate.criterion.CriteriaQuery
Get the a typed value for the given property value.
getTypedValue(Criteria, String, Object) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator
Get the a typed value for the given property value.
getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.AbstractEmptinessExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.BetweenExpression

getTypedValues(Criteria, CriteriaQuery) - Method in interface org.hibernate.criterion.Criterion
Return typed values for all parameters in the rendered SQL fragment
getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.Example

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.IdentifierEqExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.IlikeExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.InExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.Junction

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.LikeExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.LogicalExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.NaturalIdentifier

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.NotExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.NotNullExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.NullExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.PropertyExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SQLCriterion

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SimpleExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SimpleSubqueryExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SizeExpression

getTypedValues(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SubqueryExpression

getTypes(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.AggregateProjection

getTypes(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.AliasedProjection

getTypes(String, Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.AliasedProjection

getTypes(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.AvgProjection

getTypes(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.CountProjection

getTypes(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.Distinct

getTypes(String, Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.Distinct

getTypes(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.IdentifierProjection

getTypes(Criteria, CriteriaQuery) - Method in interface org.hibernate.criterion.Projection
Return types returned by the rendered SQL fragment
getTypes(String, Criteria, CriteriaQuery) - Method in interface org.hibernate.criterion.Projection
Return types for a particular user-visible alias
getTypes(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.ProjectionList

getTypes(String, Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.ProjectionList

getTypes(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.PropertyProjection

getTypes(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.RowCountProjection

getTypes(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SQLProjection

getTypes(String, Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SQLProjection

getTypes(String, Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SimpleProjection

getTypes() - Method in class org.hibernate.criterion.SubqueryExpression

getTypes() - Method in class org.hibernate.impl.AbstractQueryImpl
Retreives the list of parameter types bound to this query for ordinal parameters.
getTypes() - Method in class org.hibernate.impl.AbstractScrollableResults

getURL(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getURL(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getUnderlyingCache() - Method in class org.hibernate.cache.OptimisticTreeCacheProvider

getUnderlyingCache() - Method in class org.hibernate.cache.TreeCacheProvider

getUnicodeStream(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

getUnicodeStream(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

getUninitializedFields() - Method in class org.hibernate.intercept.AbstractFieldInterceptor

getUniqueInteger() - Method in class org.hibernate.mapping.Table

getUniqueKey(String) - Method in class org.hibernate.mapping.Table

getUniqueKeyIterator() - Method in class org.hibernate.mapping.DenormalizedTable

getUniqueKeyIterator() - Method in class org.hibernate.mapping.Table

getUniqueKeyName() - Method in class org.hibernate.engine.EntityUniqueKey

getUniquePath() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getUniquePath(Element) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getUniquePath() - Method in class org.hibernate.tuple.ElementWrapper

getUniquePath(Element) - Method in class org.hibernate.tuple.ElementWrapper

getUnjoinedPropertyIterator() - Method in class org.hibernate.mapping.PersistentClass

getUnlockTimestamp() - Method in class org.hibernate.cache.ReadWriteCache.Lock

getUnsavedIdentifierValue(String, Getter, Type, Constructor) - Static method in class org.hibernate.engine.UnsavedValueFactory
Return an IdentifierValue for the specified unsaved-value.
getUnsavedValue() - Method in class org.hibernate.tuple.IdentifierProperty

getUnsavedValue() - Method in class org.hibernate.tuple.VersionProperty

getUnsavedVersionValue(String, Getter, VersionType, Constructor) - Static method in class org.hibernate.engine.UnsavedValueFactory

getUpdateCheckStyle() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

getUpdateCount() - Method in class org.hibernate.stat.CollectionStatistics

getUpdateCount() - Method in class org.hibernate.stat.EntityStatistics

getUpdateEventListeners() - Method in class org.hibernate.event.EventListeners

getUpdateId(Object, EntityPersister, Serializable, EntityMode) - Method in class org.hibernate.event.def.DefaultSaveOrUpdateEventListener

getUpdateId(Object, EntityPersister, Serializable, EntityMode) - Method in class org.hibernate.event.def.DefaultUpdateEventListener
If the user specified an id, assign it to the instance and use that, otherwise use the id already assigned to the instance
getUpdateTimestampsCache() - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get the cache of table update timestamps
getUpdateTimestampsCache() - Method in class org.hibernate.impl.SessionFactoryImpl

getUserAliases() - Method in class org.hibernate.loader.criteria.CriteriaJoinWalker

getUserName() - Method in class org.hibernate.jmx.HibernateService

getUserName() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Log into the database with this name
getUserResourceAsStream(String) - Static method in class org.hibernate.util.ConfigHelper

getUserTransaction() - Method in class org.hibernate.transaction.JTATransaction

getUserTransactionName() - Method in class org.hibernate.jmx.HibernateService

getUserTransactionName() - Method in interface org.hibernate.jmx.HibernateServiceMBean
The JNDI name of the JTA UserTransaction object (used only be JTATransaction).
getUserTransactionName() - Method in class org.hibernate.transaction.BESTransactionManagerLookup

getUserTransactionName() - Method in class org.hibernate.transaction.JBossTransactionManagerLookup

getUserTransactionName() - Method in class org.hibernate.transaction.JOTMTransactionManagerLookup

getUserTransactionName() - Method in class org.hibernate.transaction.JOnASTransactionManagerLookup

getUserTransactionName() - Method in class org.hibernate.transaction.JRun4TransactionManagerLookup

getUserTransactionName() - Method in class org.hibernate.transaction.OC4JTransactionManagerLookup

getUserTransactionName() - Method in class org.hibernate.transaction.OrionTransactionManagerLookup

getUserTransactionName() - Method in class org.hibernate.transaction.ResinTransactionManagerLookup

getUserTransactionName() - Method in class org.hibernate.transaction.SunONETransactionManagerLookup

getUserTransactionName() - Method in interface org.hibernate.transaction.TransactionManagerLookup
Return the JNDI name of the JTA UserTransaction or null (optional operation).
getUserTransactionName() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup

getUserTransactionName() - Method in class org.hibernate.transaction.WebSphereTransactionManagerLookup

getUserTransactionName() - Method in class org.hibernate.transaction.WeblogicTransactionManagerLookup

getUtilizedFilterNames() - Method in class org.hibernate.engine.query.HQLQueryPlan

getValue() - Method in class org.hibernate.cache.ReadWriteCache.Item
The actual cached data
getValue() - Method in class org.hibernate.collection.AbstractPersistentCollection
return the user-visible collection (or array) instance
getValue() - Method in class org.hibernate.collection.PersistentArrayHolder

getValue() - Method in interface org.hibernate.collection.PersistentCollection
return the user-visible collection (or array) instance
getValue() - Method in class org.hibernate.collection.PersistentElementHolder

getValue() - Method in class org.hibernate.collection.PersistentIndexedElementHolder

getValue() - Method in class org.hibernate.engine.TypedValue

getValue() - Method in class org.hibernate.hql.ast.tree.BooleanLiteralNode

getValue() - Method in class org.hibernate.mapping.Column

getValue() - Method in class org.hibernate.mapping.MetaAttribute

getValue() - Method in class org.hibernate.mapping.Property

getValue() - Method in class org.hibernate.util.IdentityMap.IdentityMapEntry

getValues() - Method in class org.hibernate.impl.AbstractQueryImpl
Retreives the list of parameter values bound to this query for ordinal parameters.
getValues() - Method in class org.hibernate.mapping.MetaAttribute

getVersion() - Method in class org.hibernate.cache.entry.CacheEntry

getVersion() - Method in class org.hibernate.engine.EntityEntry

getVersion(Object[], EntityPersister) - Static method in class org.hibernate.engine.Versioning
Get the version number of the given instance state snapshot
getVersion() - Method in class org.hibernate.mapping.PersistentClass

getVersion() - Method in class org.hibernate.mapping.RootClass

getVersion() - Method in class org.hibernate.mapping.Subclass

getVersion(Object, EntityMode) - Method in interface org.hibernate.metadata.ClassMetadata
Get the version number (or timestamp) from the object's version property (or return null if not versioned)
getVersion(Object, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getVersion(Object, EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Get the version number (or timestamp) from the object's version property (or return null if not versioned)
getVersion(Object) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

getVersion(Object) - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Extract the value of the version property from the given entity.
getVersionColumnName() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getVersionColumnName() - Method in interface org.hibernate.persister.entity.Lockable
For versioned entities, get the name of the column (again, expected on the root table) used to store the version values.
getVersionComparator() - Method in interface org.hibernate.cache.OptimisticCacheSource
Get the comparator used to compare two different version values together.
getVersionComparator() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getVersionProperty() - Method in interface org.hibernate.metadata.ClassMetadata
Get the index of the version property
getVersionProperty() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getVersionProperty() - Method in interface org.hibernate.persister.entity.EntityPersister
Which property holds the version number (optional operation).
getVersionProperty() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getVersionPropertyIndex() - Method in class org.hibernate.tuple.entity.EntityMetamodel

getVersionSelectString() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getVersionType() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getVersionType() - Method in interface org.hibernate.persister.entity.EntityPersister
Get the type of versioning (optional operation)
getVersionedTableName() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

getViolatedConstraintNameExtracter() - Method in class org.hibernate.dialect.Dialect

getViolatedConstraintNameExtracter() - Method in class org.hibernate.dialect.H2Dialect

getViolatedConstraintNameExtracter() - Method in class org.hibernate.dialect.HSQLDialect

getViolatedConstraintNameExtracter() - Method in class org.hibernate.dialect.InformixDialect

getViolatedConstraintNameExtracter() - Method in class org.hibernate.dialect.Oracle9Dialect

getViolatedConstraintNameExtracter() - Method in class org.hibernate.dialect.PostgreSQLDialect

getWalker() - Method in class org.hibernate.hql.ast.exec.AbstractStatementExecutor

getWalker() - Method in class org.hibernate.hql.ast.tree.HqlSqlWalkerNode

getWalker() - Method in interface org.hibernate.hql.ast.tree.Statement
Retreive the "phase 2" walker which generated this statement tree.
getWarnings() - Method in class org.hibernate.jdbc.ResultSetWrapper

getWhere() - Method in class org.hibernate.mapping.Collection

getWhere() - Method in class org.hibernate.mapping.PersistentClass

getWhere() - Method in class org.hibernate.mapping.RootClass

getWhere() - Method in class org.hibernate.mapping.Subclass

getWhereClause() - Method in class org.hibernate.hql.ast.tree.AbstractRestrictableStatement

getWhereClause() - Method in interface org.hibernate.hql.ast.tree.RestrictableStatement
Retreives the where-clause defining the restriction(s) in effect for this statement.
getWhereClauseParentTokenType() - Method in class org.hibernate.hql.ast.tree.AbstractRestrictableStatement

getWhereClauseParentTokenType() - Method in class org.hibernate.hql.ast.tree.DeleteStatement

getWhereClauseParentTokenType() - Method in class org.hibernate.hql.ast.tree.QueryNode

getWhereClauseParentTokenType() - Method in class org.hibernate.hql.ast.tree.UpdateStatement

getWhereColumn() - Method in class org.hibernate.hql.classic.PathExpressionParser

getWhereColumnType() - Method in class org.hibernate.hql.classic.PathExpressionParser

getWhereColumns() - Method in class org.hibernate.hql.classic.PathExpressionParser

getWhereCondition() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

getWhereFragment() - Method in class org.hibernate.loader.AbstractEntityJoinWalker
Don't bother with the discriminator, unless overridded by subclass
getWhereFragment() - Method in class org.hibernate.loader.criteria.CriteriaJoinWalker
Use the discriminator, to narrow the select to instances of the queried subclass, also applying any filters.
getWhereJoin() - Method in class org.hibernate.hql.classic.PathExpressionParser

getWithClauseFragment() - Method in class org.hibernate.hql.ast.tree.FromElement

getWithClauseJoinAlias() - Method in class org.hibernate.hql.ast.tree.FromElement

getWrappedBlob() - Method in class org.hibernate.lob.SerializableBlob

getWrappedClob() - Method in class org.hibernate.lob.SerializableClob

getXPathResult(int) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

getXPathResult(int) - Method in class org.hibernate.tuple.ElementWrapper

getters - Variable in class org.hibernate.bytecode.javassist.BulkAccessor

getters - Variable in class org.hibernate.tuple.component.AbstractComponentTuplizer

getters - Variable in class org.hibernate.tuple.entity.AbstractEntityTuplizer

greaterThan(LockMode) - Method in class org.hibernate.LockMode
Check if this lock mode is more restrictive than the given lock mode.
group() - Method in class org.hibernate.criterion.Property

groupByClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

groupClause(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

groupExprs(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

groupProperty(String) - Static method in class org.hibernate.criterion.Projections
A grouping property value
gt(Object) - Method in class org.hibernate.criterion.Property

gt(DetachedCriteria) - Method in class org.hibernate.criterion.Property

gt(String, Object) - Static method in class org.hibernate.criterion.Restrictions
Apply a "greater than" constraint to the named property
gt(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

gtAll(DetachedCriteria) - Method in class org.hibernate.criterion.Property

gtAll(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

gtProperty(Property) - Method in class org.hibernate.criterion.Property

gtProperty(String) - Method in class org.hibernate.criterion.Property

gtProperty(String, String) - Static method in class org.hibernate.criterion.Restrictions
Apply a "greater than" constraint to two properties
gtSome(DetachedCriteria) - Method in class org.hibernate.criterion.Property

gtSome(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

guessEntityMode(Object) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

guessEntityMode(Object) - Method in interface org.hibernate.persister.entity.EntityPersister
Try to discover the entity mode from the entity instance
guessEntityMode(Object) - Method in class org.hibernate.tuple.EntityModeToTuplizerMapping
Given a supposed instance of an entity/component, guess its entity mode.
guessEntityMode(Object) - Method in class org.hibernate.tuple.entity.EntityMetamodel

guessEntityName(Object) - Method in interface org.hibernate.engine.SessionImplementor
The guessed entity name for an entity not in an association
guessEntityName(Object) - Method in class org.hibernate.impl.SessionImpl

guessEntityName(Object) - Method in class org.hibernate.impl.StatelessSessionImpl

H

H2Dialect - class org.hibernate.dialect.H2Dialect.
A dialect compatible with the H2 database.
H2Dialect() - Constructor for class org.hibernate.dialect.H2Dialect

HAVING - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

HAVING - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

HAVING - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

HBM2DDL_AUTO - Static variable in class org.hibernate.cfg.Environment
Auto export/update schema using hbm2ddl tool.
HEX_DIGIT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

HEX_DIGIT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

HEX_DIGIT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

HQLQueryPlan - class org.hibernate.engine.query.HQLQueryPlan.
Defines a query execution plan for an HQL query (or filter).
HQLQueryPlan(String, boolean, Map, SessionFactoryImplementor) - Constructor for class org.hibernate.engine.query.HQLQueryPlan

HQLQueryPlan(String, String, boolean, Map, SessionFactoryImplementor) - Constructor for class org.hibernate.engine.query.HQLQueryPlan

HQL_COLLECTION_PROPERTIES - Static variable in class org.hibernate.hql.CollectionProperties

HQL_SEPARATORS - Static variable in class org.hibernate.hql.classic.ParserHelper

HQL_VARIABLE_PREFIX - Static variable in class org.hibernate.hql.classic.ParserHelper

HSQLCaseFragment - class org.hibernate.sql.HSQLCaseFragment.
The HSQL CASEWHEN function.
HSQLCaseFragment() - Constructor for class org.hibernate.sql.HSQLCaseFragment

HSQLDialect - class org.hibernate.dialect.HSQLDialect.
An SQL dialect compatible with HSQLDB (Hypersonic SQL).
HSQLDialect() - Constructor for class org.hibernate.dialect.HSQLDialect

HSQLDialect.ReadUncommittedLockingStrategy - class org.hibernate.dialect.HSQLDialect.ReadUncommittedLockingStrategy.

HSQLDialect.ReadUncommittedLockingStrategy(Lockable, LockMode) - Constructor for class org.hibernate.dialect.HSQLDialect.ReadUncommittedLockingStrategy

HashtableCache - class org.hibernate.cache.HashtableCache.
A lightweight implementation of the Cache interface
HashtableCache(String) - Constructor for class org.hibernate.cache.HashtableCache

HashtableCacheProvider - class org.hibernate.cache.HashtableCacheProvider.
A simple in-memory Hashtable-based cache impl.
HashtableCacheProvider() - Constructor for class org.hibernate.cache.HashtableCacheProvider

HavingParser - class org.hibernate.hql.classic.HavingParser.
Parses the having clause of a hibernate query and translates it to an SQL having clause.
HavingParser() - Constructor for class org.hibernate.hql.classic.HavingParser

HbmBinder - class org.hibernate.cfg.HbmBinder.
Walks an XML mapping document and produces the Hibernate configuration-time metamodel (the classes in the mapping package)
Hibernate - class org.hibernate.Hibernate.
Provides access to the full range of Hibernate built-in types.
HibernateException - exception org.hibernate.HibernateException.
Any exception that occurs inside the persistence layer or JDBC driver.
HibernateException(Throwable) - Constructor for class org.hibernate.HibernateException

HibernateException(String, Throwable) - Constructor for class org.hibernate.HibernateException

HibernateException(String) - Constructor for class org.hibernate.HibernateException

HibernateIterator - interface org.hibernate.engine.HibernateIterator.
An iterator that may be "closed"
HibernatePermission - class org.hibernate.secure.HibernatePermission.

HibernatePermission(String, String) - Constructor for class org.hibernate.secure.HibernatePermission

HibernateProxy - interface org.hibernate.proxy.HibernateProxy.
Marker interface for entity proxies
HibernateProxyHelper - class org.hibernate.proxy.HibernateProxyHelper.
Utility methods for working with proxies.
HibernateService - class org.hibernate.jmx.HibernateService.
Implementation of HibernateServiceMBean.
HibernateService() - Constructor for class org.hibernate.jmx.HibernateService

HibernateServiceMBean - interface org.hibernate.jmx.HibernateServiceMBean.
Hibernate JMX Management API
HolderInstantiator - class org.hibernate.hql.HolderInstantiator.

HolderInstantiator(ResultTransformer, String[]) - Constructor for class org.hibernate.hql.HolderInstantiator

HqlASTFactory - class org.hibernate.hql.ast.HqlASTFactory.
User: Joshua Davis
Date: Sep 23, 2005
Time: 12:30:01 PM

HqlASTFactory() - Constructor for class org.hibernate.hql.ast.HqlASTFactory

HqlBaseLexer - class org.hibernate.hql.antlr.HqlBaseLexer.
Hibernate Query Language Lexer
This lexer provides the HQL parser with tokens.
HqlBaseLexer(InputStream) - Constructor for class org.hibernate.hql.antlr.HqlBaseLexer

HqlBaseLexer(Reader) - Constructor for class org.hibernate.hql.antlr.HqlBaseLexer

HqlBaseLexer(InputBuffer) - Constructor for class org.hibernate.hql.antlr.HqlBaseLexer

HqlBaseLexer(LexerSharedInputState) - Constructor for class org.hibernate.hql.antlr.HqlBaseLexer

HqlBaseParser - class org.hibernate.hql.antlr.HqlBaseParser.
Hibernate Query Language Grammar
This grammar parses the query language for Hibernate (an Open Source, Object-Relational mapping library).
HqlBaseParser(TokenBuffer, int) - Constructor for class org.hibernate.hql.antlr.HqlBaseParser

HqlBaseParser(TokenBuffer) - Constructor for class org.hibernate.hql.antlr.HqlBaseParser

HqlBaseParser(TokenStream, int) - Constructor for class org.hibernate.hql.antlr.HqlBaseParser

HqlBaseParser(TokenStream) - Constructor for class org.hibernate.hql.antlr.HqlBaseParser

HqlBaseParser(ParserSharedInputState) - Constructor for class org.hibernate.hql.antlr.HqlBaseParser

HqlParser - class org.hibernate.hql.ast.HqlParser.
Implements the semantic action methods defined in the HQL base parser to keep the grammar source file a little cleaner.
HqlSqlBaseWalker - class org.hibernate.hql.antlr.HqlSqlBaseWalker.
Hibernate Query Language to SQL Tree Transform.
This is a tree grammar that transforms an HQL AST into a intermediate SQL AST with bindings to Hibernate interfaces (Queryable, etc.).
HqlSqlBaseWalker() - Constructor for class org.hibernate.hql.antlr.HqlSqlBaseWalker

HqlSqlTokenTypes - interface org.hibernate.hql.antlr.HqlSqlTokenTypes.

HqlSqlWalker - class org.hibernate.hql.ast.HqlSqlWalker.
Implements methods used by the HQL->SQL tree transform grammar (a.k.a.
HqlSqlWalker(QueryTranslatorImpl, SessionFactoryImplementor, HqlParser, Map, String) - Constructor for class org.hibernate.hql.ast.HqlSqlWalker
Create a new tree transformer.
HqlSqlWalkerNode - class org.hibernate.hql.ast.tree.HqlSqlWalkerNode.
A semantic analysis node, that points back to the main analyzer.
HqlSqlWalkerNode() - Constructor for class org.hibernate.hql.ast.tree.HqlSqlWalkerNode

HqlToken - class org.hibernate.hql.ast.HqlToken.
A custom token class for the HQL grammar.
HqlToken() - Constructor for class org.hibernate.hql.ast.HqlToken

HqlTokenTypes - interface org.hibernate.hql.antlr.HqlTokenTypes.

handleDotIdent() - Method in class org.hibernate.hql.antlr.HqlBaseParser
This method looks ahead and converts .
handleDotIdent() - Method in class org.hibernate.hql.ast.HqlParser

handleEntityNotFound(String, Serializable) - Method in interface org.hibernate.proxy.EntityNotFoundDelegate

handleIdentifierError(Token, RecognitionException) - Method in class org.hibernate.hql.antlr.HqlBaseParser
This method is overriden in the sub class in order to provide the 'keyword as identifier' hack.
handleIdentifierError(Token, RecognitionException) - Method in class org.hibernate.hql.ast.HqlParser
Overrides the base behavior to retry keywords as identifiers.
handleInterception(FlushEntityEvent) - Method in class org.hibernate.event.def.DefaultFlushEntityEventListener

handleRead(String, String) - Method in interface org.hibernate.bytecode.javassist.FieldFilter
Should the given field be read intercepted?
handleWrite(String, String) - Method in interface org.hibernate.bytecode.javassist.FieldFilter
Should the given field be write intercepted?
handledNonSpecificException(SQLException, String, String) - Method in class org.hibernate.exception.SQLStateConverter
Handle an exception not converted to a specific type based on the SQLState.
hasAfterTransactionCompletion() - Method in class org.hibernate.action.BulkOperationCleanupAction

hasAfterTransactionCompletion() - Method in class org.hibernate.action.CollectionAction

hasAfterTransactionCompletion() - Method in class org.hibernate.action.EntityAction

hasAfterTransactionCompletion() - Method in class org.hibernate.action.EntityIdentityInsertAction

hasAfterTransactionCompletion() - Method in interface org.hibernate.action.Executable
Do we need to retain this instance until after the transaction completes?
hasAlterTable() - Method in class org.hibernate.dialect.Dialect
Does this dialect support the ALTER TABLE syntax?
hasAlterTable() - Method in class org.hibernate.dialect.ProgressDialect

hasAnyQueuedActions() - Method in class org.hibernate.engine.ActionQueue

hasArguments() - Method in class org.hibernate.dialect.DerbyDialect.DerbyTrimFunctionEmulation

hasArguments() - Method in class org.hibernate.dialect.function.AnsiTrimEmulationFunction

hasArguments() - Method in class org.hibernate.dialect.function.CastFunction

hasArguments() - Method in class org.hibernate.dialect.function.CharIndexFunction

hasArguments() - Method in class org.hibernate.dialect.function.NoArgSQLFunction

hasArguments() - Method in class org.hibernate.dialect.function.NvlFunction

hasArguments() - Method in class org.hibernate.dialect.function.PositionSubstringFunction

hasArguments() - Method in interface org.hibernate.dialect.function.SQLFunction
Does this function have any arguments?
hasArguments() - Method in class org.hibernate.dialect.function.SQLFunctionTemplate

hasArguments() - Method in class org.hibernate.dialect.function.StandardSQLFunction

hasArguments() - Method in class org.hibernate.dialect.function.VarArgsSQLFunction

hasAutoDiscoverScalarTypes() - Method in class org.hibernate.engine.QueryParameters

hasBind(SessionFactory) - Static method in class org.hibernate.context.ManagedSessionContext
Check to see if there is already a session associated with the current thread for the given session factory.
hasBorrowedConnection() - Method in class org.hibernate.jdbc.ConnectionManager

hasCache() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

hasCache() - Method in interface org.hibernate.persister.collection.CollectionPersister
Is this collection role cacheable
hasCache() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasCache() - Method in interface org.hibernate.persister.entity.EntityPersister
Does this class have a cache.
hasCacheablePersister() - Method in class org.hibernate.hql.ast.tree.FromElement

hasCascades() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasCascades() - Method in interface org.hibernate.persister.entity.EntityPersister
Does this class declare any cascading save/update/deletes.
hasCascades() - Method in class org.hibernate.tuple.entity.EntityMetamodel

hasCheckConstraint() - Method in class org.hibernate.mapping.Column

hasCollectionFecthes() - Method in class org.hibernate.hql.ast.tree.FromClause

hasCollections() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasCollections() - Method in interface org.hibernate.persister.entity.EntityPersister
Do instances of this class contain collections.
hasCollections() - Method in class org.hibernate.tuple.entity.EntityMetamodel

hasContent() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

hasContent() - Method in class org.hibernate.tuple.ElementWrapper

hasCustomAccessors - Variable in class org.hibernate.tuple.component.AbstractComponentTuplizer

hasCustomAccessors - Variable in class org.hibernate.tuple.entity.AbstractEntityTuplizer

hasDataTypeInIdentityColumn() - Method in class org.hibernate.dialect.Dialect
Whether this dialect have an Identity clause added to the data type or a completely seperate identity data type
hasDataTypeInIdentityColumn() - Method in class org.hibernate.dialect.InformixDialect

hasDataTypeInIdentityColumn() - Method in class org.hibernate.dialect.PostgreSQLDialect

hasDatabaseSnapshot() - Method in class org.hibernate.event.FlushEntityEvent

hasDenormalizedTables() - Method in class org.hibernate.mapping.Table

hasDirtyCollection() - Method in class org.hibernate.event.FlushEntityEvent

hasDom4jRepresentation() - Method in class org.hibernate.mapping.PersistentClass

hasEmbeddedCompositeIdentifier() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasEmbeddedIdentifier() - Method in class org.hibernate.mapping.PersistentClass

hasEmbeddedIdentifier() - Method in class org.hibernate.mapping.RootClass

hasEmbeddedIdentifier() - Method in class org.hibernate.mapping.Subclass

hasExactlyOneChild(AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil

hasFilterCondition() - Method in class org.hibernate.hql.ast.tree.SqlFragment

hasFilterCondition() - Method in class org.hibernate.sql.JoinFragment
True if the where fragment is from a filter condition.
hasFormula() - Method in class org.hibernate.mapping.Collection

hasFormula() - Method in class org.hibernate.mapping.OneToMany

hasFormula() - Method in class org.hibernate.mapping.SimpleValue

hasFormula() - Method in interface org.hibernate.mapping.Value

hasFormulaProperties() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasFunction(String) - Method in class org.hibernate.dialect.function.SQLFunctionRegistry

hasHolder(EntityMode) - Method in class org.hibernate.type.ArrayType

hasHolder(EntityMode) - Method in class org.hibernate.type.CollectionType

hasIdentifier - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

hasIdentifierMapper() - Method in class org.hibernate.mapping.PersistentClass

hasIdentifierMapper() - Method in class org.hibernate.tuple.IdentifierProperty

hasIdentifierProperty() - Method in class org.hibernate.mapping.PersistentClass

hasIdentifierProperty() - Method in class org.hibernate.mapping.RootClass

hasIdentifierProperty() - Method in class org.hibernate.mapping.Subclass

hasIdentifierProperty() - Method in interface org.hibernate.metadata.ClassMetadata
Does this class have an identifier property?
hasIdentifierProperty() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasIdentifierProperty() - Method in interface org.hibernate.persister.entity.EntityPersister
Does the class have a property holding the identifier value?
hasIndex() - Method in interface org.hibernate.metadata.CollectionMetadata
Is this collection indexed?
hasIndex - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

hasIndex() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

hasIndex() - Method in interface org.hibernate.persister.collection.CollectionPersister
Is this an "indexed" collection? (list or map)
hasInsertGeneratedProperties() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasInsertGeneratedProperties() - Method in interface org.hibernate.persister.entity.EntityPersister
Does this entity define any properties as being database generated on insert?
hasLazyProperties() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasLazyProperties() - Method in interface org.hibernate.persister.entity.EntityPersister
Does this entity define some lazy attributes?
hasLazyProperties() - Method in class org.hibernate.tuple.entity.EntityMetamodel

hasManyToManyOrdering() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

hasManyToManyOrdering() - Method in interface org.hibernate.persister.collection.CollectionPersister

hasMixedContent() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

hasMixedContent() - Method in class org.hibernate.tuple.ElementWrapper

hasMutableProperties() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasMutableProperties() - Method in interface org.hibernate.persister.entity.EntityPersister
Does this entity declare any properties of mutable type?
hasMutableProperties() - Method in class org.hibernate.tuple.entity.EntityMetamodel

hasNamedParameters() - Method in class org.hibernate.impl.AbstractQueryImpl
Does this query contain named parameters?
hasNaturalId() - Method in class org.hibernate.mapping.PersistentClass

hasNaturalIdentifier() - Method in interface org.hibernate.metadata.ClassMetadata
Does this entity declare a natural id?
hasNaturalIdentifier() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasNaturalIdentifier() - Method in interface org.hibernate.persister.entity.EntityPersister
Does this entity declare a natural id?
hasNaturalIdentifier() - Method in class org.hibernate.tuple.entity.EntityMetamodel

hasNext() - Method in class org.hibernate.hql.ast.util.ASTIterator

hasNext() - Method in class org.hibernate.hql.ast.util.ASTParentsFirstIterator

hasNext() - Method in class org.hibernate.impl.IteratorImpl

hasNext() - Method in class org.hibernate.util.EmptyIterator

hasNext() - Method in class org.hibernate.util.JoinedIterator

hasNext() - Method in class org.hibernate.util.LazyIterator

hasNext() - Method in class org.hibernate.util.SingletonIterator

hasNonReadOnlyEntities() - Method in interface org.hibernate.engine.PersistenceContext

hasNonReadOnlyEntities() - Method in class org.hibernate.engine.StatefulPersistenceContext

hasOpenResources() - Method in class org.hibernate.jdbc.AbstractBatcher

hasOpenResources() - Method in interface org.hibernate.jdbc.Batcher

hasOrder() - Method in class org.hibernate.mapping.Collection

hasOrderByClause() - Method in class org.hibernate.hql.ast.tree.QueryNode

hasOrdering() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

hasOrdering() - Method in interface org.hibernate.persister.collection.CollectionPersister
Is this an ordered collection? (An ordered collection is ordered by the initialization operation, not by sorting that happens in memory, as in the case of a sorted collection.)
hasOrphanDelete() - Method in class org.hibernate.engine.CascadeStyle.MultipleCascadeStyle

hasOrphanDelete() - Method in class org.hibernate.engine.CascadeStyle
Do we need to delete orphaned collection elements?
hasOrphanDelete() - Method in class org.hibernate.mapping.Collection

hasOrphanDelete() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

hasOrphanDelete() - Method in interface org.hibernate.persister.collection.CollectionPersister
Does this collection implement "orphan delete"?
hasParentProperty() - Method in class org.hibernate.tuple.component.AbstractComponentTuplizer

hasParentProperty() - Method in interface org.hibernate.tuple.component.ComponentTuplizer
Does the component managed by this tuuplizer contain a parent property?
hasParentProperty() - Method in class org.hibernate.tuple.component.PojoComponentTuplizer

hasParenthesesIfNoArguments() - Method in class org.hibernate.dialect.DerbyDialect.DerbyTrimFunctionEmulation

hasParenthesesIfNoArguments() - Method in class org.hibernate.dialect.function.AnsiTrimEmulationFunction

hasParenthesesIfNoArguments() - Method in class org.hibernate.dialect.function.CastFunction

hasParenthesesIfNoArguments() - Method in class org.hibernate.dialect.function.CharIndexFunction

hasParenthesesIfNoArguments() - Method in class org.hibernate.dialect.function.NoArgSQLFunction

hasParenthesesIfNoArguments() - Method in class org.hibernate.dialect.function.NvlFunction

hasParenthesesIfNoArguments() - Method in class org.hibernate.dialect.function.PositionSubstringFunction

hasParenthesesIfNoArguments() - Method in interface org.hibernate.dialect.function.SQLFunction
If there are no arguments, are parens required?
hasParenthesesIfNoArguments() - Method in class org.hibernate.dialect.function.SQLFunctionTemplate

hasParenthesesIfNoArguments() - Method in class org.hibernate.dialect.function.StandardSQLFunction

hasParenthesesIfNoArguments() - Method in class org.hibernate.dialect.function.VarArgsSQLFunction

hasPhysicalDiscriminatorColumn(Queryable) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Does the given persister define a physical discriminator column for the purpose of inheritence discrimination?
hasPojoRepresentation() - Method in class org.hibernate.mapping.Component

hasPojoRepresentation() - Method in class org.hibernate.mapping.PersistentClass

hasPostCommitEventListeners() - Method in class org.hibernate.action.EntityAction

hasPostCommitEventListeners() - Method in class org.hibernate.action.EntityDeleteAction

hasPostCommitEventListeners() - Method in class org.hibernate.action.EntityIdentityInsertAction

hasPostCommitEventListeners() - Method in class org.hibernate.action.EntityInsertAction

hasPostCommitEventListeners() - Method in class org.hibernate.action.EntityUpdateAction

hasPrimaryKey() - Method in class org.hibernate.mapping.Table

hasProjection() - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

hasProxy() - Method in interface org.hibernate.metadata.ClassMetadata
Does this class support dynamic proxies?
hasProxy() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasProxy() - Method in interface org.hibernate.persister.entity.EntityPersister
Does this class support dynamic proxies.
hasProxy() - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

hasProxy() - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Does this entity, for this mode, present a possibility for proxying?
hasQueuedOperations() - Method in class org.hibernate.collection.AbstractPersistentCollection
Does this instance have any "queued" additions?
hasQueuedOperations() - Method in interface org.hibernate.collection.PersistentCollection
Does this instance have any "queued" additions?
hasRowId() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasRowId() - Method in interface org.hibernate.persister.entity.Loadable
Does the result set contain rowids?
hasRowSelection() - Method in class org.hibernate.engine.QueryParameters

hasSelectBeforeUpdate() - Method in class org.hibernate.mapping.PersistentClass

hasSelfReferentialForeignKeyBug() - Method in class org.hibernate.dialect.Dialect

hasSelfReferentialForeignKeyBug() - Method in class org.hibernate.dialect.MySQL5InnoDBDialect

hasSelfReferentialForeignKeyBug() - Method in class org.hibernate.dialect.MySQLInnoDBDialect

hasSequentialSelect() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasSequentialSelect() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

hasSubclasses() - Method in class org.hibernate.mapping.PersistentClass

hasSubclasses() - Method in interface org.hibernate.metadata.ClassMetadata
Does this entity have mapped subclasses?
hasSubclasses() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasSubclasses() - Method in interface org.hibernate.persister.entity.Loadable
Does this persistent class have subclasses?
hasSubclasses() - Method in class org.hibernate.tuple.entity.EntityMetamodel

hasSubselectLoadableCollections() - Method in class org.hibernate.loader.Loader

hasSubselectLoadableCollections() - Method in class org.hibernate.mapping.PersistentClass

hasSubselectLoadableCollections() - Method in class org.hibernate.mapping.Subclass

hasSubselectLoadableCollections() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasSubselectLoadableCollections() - Method in interface org.hibernate.persister.entity.EntityPersister
Does this entity own any collections which are fetchable by subselect?
hasText(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

hasThetaJoins() - Method in class org.hibernate.sql.JoinFragment

hasUninitializedLazyProperties(Object, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasUninitializedLazyProperties(Object, EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Does the given instance have any uninitialized lazy properties?
hasUninitializedLazyProperties(Object) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

hasUninitializedLazyProperties(Object) - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Does the given entity instance have any currently uninitialized lazy properties?
hasUninitializedLazyProperties(Object) - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

hasUpdateGeneratedProperties() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasUpdateGeneratedProperties() - Method in interface org.hibernate.persister.entity.EntityPersister
Does this entity define any properties as being database generated on update?
hasWhere - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

hasWhere() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

hasWhere() - Method in interface org.hibernate.persister.collection.QueryableCollection
Does this collection role have a where clause filter?
hasWhere() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

hasWhereClause() - Method in class org.hibernate.hql.ast.tree.AbstractRestrictableStatement

hasWhereClause() - Method in interface org.hibernate.hql.ast.tree.RestrictableStatement
Does this statement tree currently contain a where clause?
hash(Object[]) - Static method in class org.hibernate.util.ArrayHelper
calculate the array hash (only the first level)
hash(char[]) - Static method in class org.hibernate.util.ArrayHelper
calculate the array hash (only the first level)
hash(byte[]) - Static method in class org.hibernate.util.ArrayHelper
calculate the array hash (only the first level)
hashCode() - Method in class org.hibernate.action.DelayedPostInsertIdentifier

hashCode() - Method in class org.hibernate.bytecode.javassist.FastClass

hashCode() - Method in class org.hibernate.cache.CacheKey

hashCode() - Method in class org.hibernate.cache.FilterKey

hashCode() - Method in class org.hibernate.cache.QueryKey

hashCode() - Method in class org.hibernate.collection.PersistentBag

hashCode() - Method in class org.hibernate.collection.PersistentList

hashCode() - Method in class org.hibernate.collection.PersistentMap

hashCode() - Method in class org.hibernate.collection.PersistentSet

hashCode() - Method in class org.hibernate.engine.CollectionKey

hashCode() - Method in class org.hibernate.engine.EntityKey

hashCode() - Method in class org.hibernate.engine.EntityUniqueKey

hashCode() - Method in class org.hibernate.engine.TypedValue

hashCode() - Method in class org.hibernate.engine.query.sql.NativeSQLQuerySpecification

hashCode() - Method in class org.hibernate.hql.ast.tree.FromElement

hashCode() - Method in class org.hibernate.mapping.Column

hashCode() - Method in class org.hibernate.secure.HibernatePermission

hashCode() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter

hashCode() - Method in class org.hibernate.tuple.ElementWrapper

hashCode(Object) - Method in interface org.hibernate.usertype.CompositeUserType
Get a hashcode for the instance, consistent with persistence "equality"
hashCode(Object) - Method in interface org.hibernate.usertype.UserType
Get a hashcode for the instance, consistent with persistence "equality"
hashCode() - Method in class org.hibernate.util.FastHashMap
Return the hash code value for this map.
hashCode() - Method in class org.hibernate.util.IdentityMap.IdentityKey

havingClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

headMap(Object) - Method in class org.hibernate.collection.PersistentSortedMap

headSet(Object) - Method in class org.hibernate.collection.PersistentSortedSet

heuristicType(String) - Static method in class org.hibernate.type.TypeFactory
Uses heuristics to deduce a Hibernate type given a string naming the type or Java class.
heuristicType(String, Properties) - Static method in class org.hibernate.type.TypeFactory
Uses heuristics to deduce a Hibernate type given a string naming the type or Java class.
hydrate(ResultSet, Serializable, Object, Loadable, String[][], boolean, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Unmarshall the fields of a persistent instance from a result set, without resolving associations or collections.
hydrate(ResultSet, Serializable, Object, Loadable, String[][], boolean, SessionImplementor) - Method in interface org.hibernate.persister.entity.Loadable
Retrieve property values from one row of a result set
hydrate(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.AbstractType

hydrate(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.AnyType

hydrate(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.CollectionType

hydrate(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.ComponentType

hydrate(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.ManyToOneType

hydrate(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.OneToOneType

hydrate(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.SpecialOneToOneType

hydrate(ResultSet, String[], SessionImplementor, Object) - Method in interface org.hibernate.type.Type
Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset.

I

IDENT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

IDENT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

IDENT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ID_LETTER - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ID_LETTER - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ID_LETTER - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ID_START_LETTER - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ID_START_LETTER - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ID_START_LETTER - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ID_TABLE - Static variable in class org.hibernate.id.MultipleHiLoPerTableGenerator

IGNORE - Static variable in class org.hibernate.CacheMode
The session will never interact with the cache, except to invalidate cache items when updates occur
IGNORE - Static variable in class org.hibernate.ReplicationMode
Ignore replicated entities when a row already exists.
IMMEDIATE_LOAD - Static variable in interface org.hibernate.event.LoadEventListener

IMPLIED_FROM - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

IMPLIED_FROM - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

IN - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

IN - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

IN - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

INDEX_OP - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

INDEX_OP - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

INDEX_OP - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

INDICES - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

INDICES - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

INDICES - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

INNER - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

INNER - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

INNER - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

INNER_JOIN - Static variable in interface org.hibernate.criterion.CriteriaSpecification
Specifies joining to an entity based on an inner join.
INNER_JOIN - Static variable in class org.hibernate.sql.JoinFragment

INSERT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

INSERT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

INSERT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

INSERT - Static variable in class org.hibernate.mapping.PropertyGeneration
Values for this property are generated by the database on insert.
INSERT - Static variable in class org.hibernate.secure.HibernatePermission

INSTANCE - Static variable in class org.hibernate.EmptyInterceptor

INSTANCE - Static variable in class org.hibernate.cache.OptimisticTreeCache.CircumventChecksDataVersion

INSTANCE - Static variable in class org.hibernate.cache.OptimisticTreeCache.NonLockingDataVersion

INSTANCE - Static variable in class org.hibernate.cfg.DefaultNamingStrategy
The singleton instance
INSTANCE - Static variable in class org.hibernate.cfg.ImprovedNamingStrategy
A convenient singleton instance
INSTANCE - Static variable in class org.hibernate.transform.ToListResultTransformer

INSTANCE - Static variable in class org.hibernate.util.CalendarComparator

INSTANCE - Static variable in class org.hibernate.util.ComparableComparator

INSTANCE - Static variable in class org.hibernate.util.EmptyIterator

INTEGER - Static variable in class org.hibernate.Hibernate
Hibernate integer type.
INTERNAL_LOAD_EAGER - Static variable in interface org.hibernate.event.LoadEventListener

INTERNAL_LOAD_LAZY - Static variable in interface org.hibernate.event.LoadEventListener

INTERNAL_LOAD_NULLABLE - Static variable in interface org.hibernate.event.LoadEventListener

INTO - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

INTO - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

INTO - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

INVOKE_IMPLEMENTATION - Static variable in class org.hibernate.proxy.pojo.BasicLazyInitializer

IN_LIST - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

IN_LIST - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

IN_LIST - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

IS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

IS - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

IS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ISOLATION - Static variable in class org.hibernate.cfg.Environment
JDBC transaction isolation level
IS_NOT_NULL - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

IS_NOT_NULL - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

IS_NOT_NULL - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

IS_NULL - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

IS_NULL - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

IS_NULL - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

IdentNode - class org.hibernate.hql.ast.tree.IdentNode.
Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.
IdentNode() - Constructor for class org.hibernate.hql.ast.tree.IdentNode

IdentifierBag - class org.hibernate.mapping.IdentifierBag.
An IdentifierBag has a primary key consisting of just the identifier column
IdentifierBag(PersistentClass) - Constructor for class org.hibernate.mapping.IdentifierBag

IdentifierBagType - class org.hibernate.type.IdentifierBagType.

IdentifierBagType(String, String, boolean) - Constructor for class org.hibernate.type.IdentifierBagType

IdentifierCollection - class org.hibernate.mapping.IdentifierCollection.
A collection with a synthetic "identifier" column
IdentifierCollection(PersistentClass) - Constructor for class org.hibernate.mapping.IdentifierCollection

IdentifierEqExpression - class org.hibernate.criterion.IdentifierEqExpression.
An identifier constraint
IdentifierEqExpression(Object) - Constructor for class org.hibernate.criterion.IdentifierEqExpression

IdentifierGeneratingInsert - class org.hibernate.id.insert.IdentifierGeneratingInsert.
Nothing more than a distinguishing subclass of Insert used to indicate intent.
IdentifierGeneratingInsert(Dialect) - Constructor for class org.hibernate.id.insert.IdentifierGeneratingInsert

IdentifierGenerationException - exception org.hibernate.id.IdentifierGenerationException.
Thrown by IdentifierGenerator implementation class when ID generation fails.
IdentifierGenerationException(String) - Constructor for class org.hibernate.id.IdentifierGenerationException

IdentifierGenerationException(String, Throwable) - Constructor for class org.hibernate.id.IdentifierGenerationException

IdentifierGenerator - interface org.hibernate.id.IdentifierGenerator.
The general contract between a class that generates unique identifiers and the Session.
IdentifierGeneratorFactory - class org.hibernate.id.IdentifierGeneratorFactory.
Factory and helper methods for IdentifierGenerator framework.
IdentifierProjection - class org.hibernate.criterion.IdentifierProjection.
A property value, or grouped property value
IdentifierProjection(boolean) - Constructor for class org.hibernate.criterion.IdentifierProjection

IdentifierProjection() - Constructor for class org.hibernate.criterion.IdentifierProjection

IdentifierProperty - class org.hibernate.tuple.IdentifierProperty.
Represents a defined entity identifier property within the Hibernate runtime-metamodel.
IdentifierProperty(String, String, Type, boolean, IdentifierValue, IdentifierGenerator) - Constructor for class org.hibernate.tuple.IdentifierProperty
Construct a non-virtual identifier property.
IdentifierProperty(Type, boolean, boolean, IdentifierValue, IdentifierGenerator) - Constructor for class org.hibernate.tuple.IdentifierProperty
Construct a virtual IdentifierProperty.
IdentifierType - interface org.hibernate.type.IdentifierType.
A Type that may be used as an identifier.
IdentifierValue - class org.hibernate.engine.IdentifierValue.
A strategy for determining if an identifier value is an identifier of a new transient instance or a previously persistent transient instance.
IdentifierValue() - Constructor for class org.hibernate.engine.IdentifierValue

IdentifierValue(Serializable) - Constructor for class org.hibernate.engine.IdentifierValue
Assume the transient instance is newly instantiated if its identifier is null or equal to value
IdentityGenerator - class org.hibernate.id.IdentityGenerator.
A generator for use with ANSI-SQL IDENTITY columns used as the primary key.
IdentityGenerator() - Constructor for class org.hibernate.id.IdentityGenerator

IdentityGenerator.BasicDelegate - class org.hibernate.id.IdentityGenerator.BasicDelegate.
Delegate for dealing with IDENTITY columns where the dialect requires an additional command execution to retrieve the generated IDENTITY value
IdentityGenerator.BasicDelegate(PostInsertIdentityPersister, Dialect) - Constructor for class org.hibernate.id.IdentityGenerator.BasicDelegate

IdentityGenerator.GetGeneratedKeysDelegate - class org.hibernate.id.IdentityGenerator.GetGeneratedKeysDelegate.
Delegate for dealing with IDENTITY columns using JDBC3 getGeneratedKeys
IdentityGenerator.GetGeneratedKeysDelegate(PostInsertIdentityPersister, Dialect) - Constructor for class org.hibernate.id.IdentityGenerator.GetGeneratedKeysDelegate

IdentityGenerator.InsertSelectDelegate - class org.hibernate.id.IdentityGenerator.InsertSelectDelegate.
Delegate for dealing with IDENTITY columns where the dialect supports returning the generated IDENTITY value directly from the insert statement.
IdentityGenerator.InsertSelectDelegate(PostInsertIdentityPersister, Dialect) - Constructor for class org.hibernate.id.IdentityGenerator.InsertSelectDelegate

IdentityMap - class org.hibernate.util.IdentityMap.
A Map where keys are compared by object identity, rather than equals().
IdentityMap.IdentityKey - class org.hibernate.util.IdentityMap.IdentityKey.

IdentityMap.IdentityMapEntry - class org.hibernate.util.IdentityMap.IdentityMapEntry.

IdentitySet - class org.hibernate.util.IdentitySet.
Set implementation that use == instead of equals() as its comparison mechanism that base its implementation of IdentityMap
IdentitySet() - Constructor for class org.hibernate.util.IdentitySet

IlikeExpression - class org.hibernate.criterion.IlikeExpression.
A case-insensitive "like"
IlikeExpression(String, Object) - Constructor for class org.hibernate.criterion.IlikeExpression

IlikeExpression(String, String, MatchMode) - Constructor for class org.hibernate.criterion.IlikeExpression

ImmutableType - class org.hibernate.type.ImmutableType.
Superclass of nullable immutable types.
ImmutableType() - Constructor for class org.hibernate.type.ImmutableType

ImpliedFromElement - class org.hibernate.hql.ast.tree.ImpliedFromElement.
Represents a FROM element implied by a path expression or a collection reference.
ImpliedFromElement() - Constructor for class org.hibernate.hql.ast.tree.ImpliedFromElement

ImprovedNamingStrategy - class org.hibernate.cfg.ImprovedNamingStrategy.
An improved naming strategy that prefers embedded underscores to mixed case names
ImprovedNamingStrategy() - Constructor for class org.hibernate.cfg.ImprovedNamingStrategy

InExpression - class org.hibernate.criterion.InExpression.
Constrains the property to a specified list of values
InExpression(String, Object[]) - Constructor for class org.hibernate.criterion.InExpression

InFragment - class org.hibernate.sql.InFragment.
An SQL IN expression.
InFragment() - Constructor for class org.hibernate.sql.InFragment

InLogicOperatorNode - class org.hibernate.hql.ast.tree.InLogicOperatorNode.

InLogicOperatorNode() - Constructor for class org.hibernate.hql.ast.tree.InLogicOperatorNode

IncrementGenerator - class org.hibernate.id.IncrementGenerator.
increment

An IdentifierGenerator that returns a long, constructed by counting from the maximum primary key value at startup.
IncrementGenerator() - Constructor for class org.hibernate.id.IncrementGenerator

Index - class org.hibernate.mapping.Index.
A relational table index
Index() - Constructor for class org.hibernate.mapping.Index

IndexBackref - class org.hibernate.mapping.IndexBackref.

IndexBackref() - Constructor for class org.hibernate.mapping.IndexBackref

IndexMetadata - class org.hibernate.tool.hbm2ddl.IndexMetadata.
JDBC index metadata
IndexNode - class org.hibernate.hql.ast.tree.IndexNode.
Represents the [] operator and provides it's semantics.
IndexNode() - Constructor for class org.hibernate.hql.ast.tree.IndexNode

IndexPropertyAccessor - class org.hibernate.property.IndexPropertyAccessor.
Represents a "back-reference" to the index of a collection.
IndexPropertyAccessor(String, String) - Constructor for class org.hibernate.property.IndexPropertyAccessor
Constructs a new instance of IndexPropertyAccessor.
IndexPropertyAccessor.IndexGetter - class org.hibernate.property.IndexPropertyAccessor.IndexGetter.
The Getter implementation for index backrefs.
IndexPropertyAccessor.IndexGetter() - Constructor for class org.hibernate.property.IndexPropertyAccessor.IndexGetter

IndexPropertyAccessor.IndexSetter - class org.hibernate.property.IndexPropertyAccessor.IndexSetter.
The Setter implementation for index backrefs.
IndexPropertyAccessor.IndexSetter() - Constructor for class org.hibernate.property.IndexPropertyAccessor.IndexSetter

IndexedCollection - class org.hibernate.mapping.IndexedCollection.
Indexed collections include Lists, Maps, arrays and primitive arrays.
IndexedCollection(PersistentClass) - Constructor for class org.hibernate.mapping.IndexedCollection

InformixDialect - class org.hibernate.dialect.InformixDialect.
Informix dialect.

Seems to work with Informix Dynamic Server Version 7.31.UD3, Informix JDBC driver version 2.21JC3.
InformixDialect() - Constructor for class org.hibernate.dialect.InformixDialect
Creates new InformixDialect instance.
IngresDialect - class org.hibernate.dialect.IngresDialect.
An Ingres SQL dialect
IngresDialect() - Constructor for class org.hibernate.dialect.IngresDialect

Initializable - interface org.hibernate.event.Initializable.
An event listener that requires access to mappings to initialize state at initialization time.
InitializeCollectionEvent - class org.hibernate.event.InitializeCollectionEvent.
An event that occurs when a collection wants to be initialized
InitializeCollectionEvent(PersistentCollection, EventSource) - Constructor for class org.hibernate.event.InitializeCollectionEvent

InitializeCollectionEventListener - interface org.hibernate.event.InitializeCollectionEventListener.
Defines the contract for handling of collection initialization events generated by a session.
InitializeableNode - interface org.hibernate.hql.ast.tree.InitializeableNode.
An interface for initializeable AST nodes.
Insert - class org.hibernate.sql.Insert.
An SQL INSERT statement
Insert(Dialect) - Constructor for class org.hibernate.sql.Insert

InsertGeneratedIdentifierDelegate - interface org.hibernate.id.insert.InsertGeneratedIdentifierDelegate.
Responsible for handling delegation relating to variants in how insert-generated-identifier generator strategies dictate processing: building the sql insert statement determination of the generated identifier value
InsertSelect - class org.hibernate.sql.InsertSelect.
Implementation of InsertSelect.
InsertSelect(Dialect) - Constructor for class org.hibernate.sql.InsertSelect

InsertSelectIdentityInsert - class org.hibernate.id.insert.InsertSelectIdentityInsert.
Specialized IdentifierGeneratingInsert which appends the database specific clause which signifies to return generated IDENTITY values to the end of the insert statement.
InsertSelectIdentityInsert(Dialect) - Constructor for class org.hibernate.id.insert.InsertSelectIdentityInsert

InsertStatement - class org.hibernate.hql.ast.tree.InsertStatement.
Defines a top-level AST node representing an HQL "insert select" statement.
InsertStatement() - Constructor for class org.hibernate.hql.ast.tree.InsertStatement

InstantiationException - exception org.hibernate.InstantiationException.
Thrown if Hibernate can't instantiate an entity or component class at runtime.
InstantiationException(String, Class, Throwable) - Constructor for class org.hibernate.InstantiationException

InstantiationException(String, Class) - Constructor for class org.hibernate.InstantiationException

InstantiationException(String, Class, Exception) - Constructor for class org.hibernate.InstantiationException

InstantiationOptimizerAdapter - class org.hibernate.bytecode.cglib.InstantiationOptimizerAdapter.
The ReflectionOptimizer.InstantiationOptimizer implementation for CGLIB which simply acts as an adpater to the FastClass class.
InstantiationOptimizerAdapter(FastClass) - Constructor for class org.hibernate.bytecode.cglib.InstantiationOptimizerAdapter

InstantiationOptimizerAdapter - class org.hibernate.bytecode.javassist.InstantiationOptimizerAdapter.
The ReflectionOptimizer.InstantiationOptimizer implementation for Javassist which simply acts as an adpater to the FastClass class.
InstantiationOptimizerAdapter(FastClass) - Constructor for class org.hibernate.bytecode.javassist.InstantiationOptimizerAdapter

Instantiator - interface org.hibernate.tuple.Instantiator.
Contract for implementors responsible for instantiating entity/component instances.
InstrumentTask - class org.hibernate.tool.instrument.cglib.InstrumentTask.
An Ant task for instrumenting persistent classes in order to enable field-level interception using CGLIB.
InstrumentTask() - Constructor for class org.hibernate.tool.instrument.cglib.InstrumentTask

InstrumentTask - class org.hibernate.tool.instrument.javassist.InstrumentTask.
An Ant task for instrumenting persistent classes in order to enable field-level interception using Javassist.
InstrumentTask() - Constructor for class org.hibernate.tool.instrument.javassist.InstrumentTask

InstrumentedClassLoader - class org.hibernate.bytecode.InstrumentedClassLoader.
A specialized classloader which performs bytecode enhancement on class definitions as they are loaded into the classloader scope.
InstrumentedClassLoader(ClassLoader, ClassTransformer) - Constructor for class org.hibernate.bytecode.InstrumentedClassLoader

IntegerType - class org.hibernate.type.IntegerType.
integer: A type that maps an SQL INT to a Java Integer.
IntegerType() - Constructor for class org.hibernate.type.IntegerType

InterbaseDialect - class org.hibernate.dialect.InterbaseDialect.
An SQL dialect for Interbase.
InterbaseDialect() - Constructor for class org.hibernate.dialect.InterbaseDialect

Interceptor - interface org.hibernate.Interceptor.
Allows user code to inspect and/or change property values.
IntoClause - class org.hibernate.hql.ast.tree.IntoClause.
Represents an entity referenced in the INTO clause of an HQL INSERT statement.
IntoClause() - Constructor for class org.hibernate.hql.ast.tree.IntoClause

InvalidMappingException - exception org.hibernate.InvalidMappingException.
Thrown when a mapping is found to be invalid.
InvalidMappingException(String, String, String, Throwable) - Constructor for class org.hibernate.InvalidMappingException

InvalidMappingException(String, String, String) - Constructor for class org.hibernate.InvalidMappingException

InvalidMappingException(String, String) - Constructor for class org.hibernate.InvalidMappingException

InvalidMappingException(String, String, Throwable) - Constructor for class org.hibernate.InvalidMappingException

InvalidPathException - exception org.hibernate.hql.ast.InvalidPathException.
Exception thrown when an invalid path is found in a query.
InvalidPathException(String) - Constructor for class org.hibernate.hql.ast.InvalidPathException

IsolatedWork - interface org.hibernate.engine.transaction.IsolatedWork.
Represents work that needs to be performed in a manner which isolates it from any current application unit of work transaction.
Isolater - class org.hibernate.engine.transaction.Isolater.
Class which provides the isolation semantics required by an IsolatedWork.
Isolater() - Constructor for class org.hibernate.engine.transaction.Isolater

Isolater.JdbcDelegate - class org.hibernate.engine.transaction.Isolater.JdbcDelegate.
An isolation delegate for JDBC-based transactions.
Isolater.JdbcDelegate(SessionImplementor) - Constructor for class org.hibernate.engine.transaction.Isolater.JdbcDelegate

Isolater.JtaDelegate - class org.hibernate.engine.transaction.Isolater.JtaDelegate.
An isolation delegate for JTA-based transactions.
Isolater.JtaDelegate(SessionImplementor) - Constructor for class org.hibernate.engine.transaction.Isolater.JtaDelegate

IteratorImpl - class org.hibernate.impl.IteratorImpl.
An implementation of java.util.Iterator that is returned by iterate() query execution methods.
IteratorImpl(ResultSet, PreparedStatement, EventSource, Type[], String[][], HolderInstantiator) - Constructor for class org.hibernate.impl.IteratorImpl

id() - Static method in class org.hibernate.criterion.Projections
A projected identifier value
idEq(Object) - Static method in class org.hibernate.criterion.Restrictions
Apply an "equal" constraint to the identifier property
idbag(String, String, boolean) - Static method in class org.hibernate.type.TypeFactory

identPrimary() - Method in class org.hibernate.hql.antlr.HqlBaseParser

identifier() - Method in class org.hibernate.hql.antlr.HqlBaseParser

identifier(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

identifierColumnName - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

identifierSelectFragment(String, String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

identifierSelectFragment(String, String) - Method in interface org.hibernate.persister.entity.Queryable
Given a query alias and an identifying suffix, render the intentifier select fragment.
identifiers - Variable in class org.hibernate.collection.PersistentIdentifierBag

ignoreCase() - Method in class org.hibernate.criterion.Example
Ignore case for all string-valued properties
ignoreCase() - Method in class org.hibernate.criterion.Order

ignoreCase() - Method in class org.hibernate.criterion.SimpleExpression

ignoreInitialJoin() - Method in class org.hibernate.hql.classic.PathExpressionParser

ilike(String, String, MatchMode) - Static method in class org.hibernate.criterion.Restrictions
A case-insensitive "like", similar to Postgres ilike operator
ilike(String, Object) - Static method in class org.hibernate.criterion.Restrictions
A case-insensitive "like", similar to Postgres ilike operator
immediateLoad(String, Serializable) - Method in interface org.hibernate.engine.SessionImplementor
Load an instance immediately.
immediateLoad(String, Serializable) - Method in class org.hibernate.impl.SessionImpl
Load the data for the object with the specified id into a newly created object.
immediateLoad(String, Serializable) - Method in class org.hibernate.impl.StatelessSessionImpl

implementsLifecycle(EntityMode) - Method in interface org.hibernate.metadata.ClassMetadata
Does the class implement the Lifecycle interface?
implementsLifecycle(EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

implementsLifecycle(EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Does the class implement the Lifecycle interface.
implementsValidatable(EntityMode) - Method in interface org.hibernate.metadata.ClassMetadata
Does the class implement the Validatable interface?
implementsValidatable(EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

implementsValidatable(EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Does the class implement the Validatable interface.
implies(Permission) - Method in class org.hibernate.secure.HibernatePermission

imports - Variable in class org.hibernate.cfg.Configuration

imports - Variable in class org.hibernate.cfg.Mappings

in(Collection) - Method in class org.hibernate.criterion.Property

in(Object[]) - Method in class org.hibernate.criterion.Property

in(DetachedCriteria) - Method in class org.hibernate.criterion.Property

in(String, Object[]) - Static method in class org.hibernate.criterion.Restrictions
Apply an "in" constraint to the named property
in(String, Collection) - Static method in class org.hibernate.criterion.Restrictions
Apply an "in" constraint to the named property
in(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

inClassDeclaration() - Method in class org.hibernate.hql.antlr.HqlBaseParser

inCollectionDeclaration() - Method in class org.hibernate.hql.antlr.HqlBaseParser

inCollectionElementsDeclaration() - Method in class org.hibernate.hql.antlr.HqlBaseParser

inList() - Method in class org.hibernate.hql.antlr.HqlBaseParser

inList(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

inProjectionList() - Method in class org.hibernate.hql.ast.tree.FromElement
Returns true if this element should be in the projection list.
inProjectionList() - Method in class org.hibernate.hql.ast.tree.ImpliedFromElement

inRhs(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

include(Object, String, Type) - Method in interface org.hibernate.criterion.Example.PropertySelector

include(AST) - Method in class org.hibernate.hql.ast.util.ASTUtil.IncludePredicate

includeSubclasses(String) - Method in interface org.hibernate.engine.JoinSequence.Selector

increment(Object, VersionType, SessionImplementor) - Static method in class org.hibernate.engine.Versioning
Increment the given version number
incrementCascadeLevel() - Method in interface org.hibernate.engine.PersistenceContext
Called before cascading
incrementCascadeLevel() - Method in class org.hibernate.engine.StatefulPersistenceContext

incrementIndexByBase(Object) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

indexColumnAliases - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

indexColumnIsSettable - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

indexColumnNames - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

indexContainsFormula - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

indexExists(Serializable, Object, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

indexExists(Serializable, Object, SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister

indexFormulaTemplates - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

indexFormulas - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

indexOf(Object) - Method in class org.hibernate.collection.PersistentBag

indexOf(Object) - Method in class org.hibernate.collection.PersistentIdentifierBag

indexOf(Object) - Method in class org.hibernate.collection.PersistentList

indexOf(Node) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

indexOf(Node) - Method in class org.hibernate.tuple.ElementWrapper

indexOf(Object, Object) - Method in class org.hibernate.type.ArrayType

indexOf(Object, Object) - Method in class org.hibernate.type.CollectionType

indexOf(Object, Object) - Method in class org.hibernate.type.CustomCollectionType

indexOf(Object, Object) - Method in class org.hibernate.type.ListType

indexOf(Object, Object) - Method in class org.hibernate.type.MapType

indexOf(Object, Object) - Method in interface org.hibernate.usertype.UserCollectionType
Optional operation.
indexOf(Object[], Object) - Static method in class org.hibernate.util.ArrayHelper

indexOfThrowable(Throwable, Class) - Static method in class org.hibernate.exception.ExceptionUtils
Returns the (zero based) index of the first Throwable that matches the specified type in the exception chain.
indexOfThrowable(Throwable, Class, int) - Static method in class org.hibernate.exception.ExceptionUtils
Returns the (zero based) index of the first Throwable that matches the specified type in the exception chain from a specified index.
indexOfThrowable(Class) - Method in interface org.hibernate.exception.Nestable
Returns the index, numbered from 0, of the first occurrence of the specified type in the chain of Throwables, or -1 if the specified type is not found in the chain.
indexOfThrowable(Class, int) - Method in interface org.hibernate.exception.Nestable
Returns the index, numbered from 0, of the first Throwable that matches the specified type in the chain of Throwables with an index greater than or equal to the specified index, or -1 if the type is not found.
indexOfThrowable(Class, int) - Method in class org.hibernate.exception.NestableDelegate
Returns the index, numbered from 0, of the first Throwable that matches the specified type in the chain of Throwables held in this delegate's Nestable with an index greater than or equal to the specified index, or -1 if the type is not found.
indexOfThrowable(Class) - Method in class org.hibernate.exception.NestableException

indexOfThrowable(Class, int) - Method in class org.hibernate.exception.NestableException

indexOfThrowable(Class) - Method in class org.hibernate.exception.NestableRuntimeException

indexOfThrowable(Class, int) - Method in class org.hibernate.exception.NestableRuntimeException

info(String) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask.Logger

infoString(String, Serializable) - Static method in class org.hibernate.pretty.MessageHelper
Generate an info message string relating to a particular entity, based on the given entityName and id.
infoString(EntityPersister, Object, SessionFactoryImplementor) - Static method in class org.hibernate.pretty.MessageHelper
Generate an info message string relating to a particular entity.
infoString(EntityPersister, Object, Type, SessionFactoryImplementor) - Static method in class org.hibernate.pretty.MessageHelper
Generate an info message string relating to a particular entity,.
infoString(EntityPersister, Serializable[], SessionFactoryImplementor) - Static method in class org.hibernate.pretty.MessageHelper
Generate an info message string relating to a series of entities.
infoString(EntityPersister) - Static method in class org.hibernate.pretty.MessageHelper
Generate an info message string relating to given entity persister.
infoString(String, String, Object) - Static method in class org.hibernate.pretty.MessageHelper
Generate an info message string relating to a given property value for an entity.
init() - Method in class org.hibernate.action.BulkOperationCleanupAction

initAll(String, String, LockMode) - Method in class org.hibernate.loader.AbstractEntityJoinWalker

initCause(Throwable) - Method in class org.hibernate.bytecode.javassist.BulkAccessorException
Initializes the cause of this throwable.
initCollectionPropertyMap() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

initComponentPropertyPaths(String, AbstractComponentType, String[], String[], Mapping) - Method in class org.hibernate.persister.entity.AbstractPropertyMapping

initFromWalker(JoinWalker) - Method in class org.hibernate.loader.OuterJoinLoader

initIdentifierPropertyPaths(String, EntityType, String[], Mapping) - Method in class org.hibernate.persister.entity.AbstractPropertyMapping

initLockers() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

initPersisters(List, LockMode) - Method in class org.hibernate.loader.JoinWalker

initProjection(String, String, String, String, LockMode) - Method in class org.hibernate.loader.AbstractEntityJoinWalker

initPropertyPaths(Mapping) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

initPropertyPaths(String, Type, String[], String[], Mapping) - Method in class org.hibernate.persister.entity.AbstractPropertyMapping

initSubclassPropertyAliasesMap(PersistentClass) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Must be called by subclasses, at the end of their constructors
initialize(Object) - Static method in class org.hibernate.Hibernate
Force initialization of a proxy or persistent collection.
initialize(boolean) - Method in class org.hibernate.collection.AbstractPersistentCollection
Initialize the collection, if possible, wrapping any exceptions in a runtime exception
initialize(Configuration) - Method in interface org.hibernate.event.Initializable

initialize() - Method in class org.hibernate.hql.ast.tree.BetweenOperatorNode

initialize() - Method in class org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode

initialize() - Method in class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode
Performs the operator node initialization by seeking out any parameter nodes and setting their expected type, if possible.
initialize(Object) - Method in class org.hibernate.hql.ast.tree.HqlSqlWalkerNode

initialize() - Method in class org.hibernate.hql.ast.tree.InLogicOperatorNode

initialize(Object) - Method in interface org.hibernate.hql.ast.tree.InitializeableNode
Initializes the node with the parameter.
initialize(Queryable) - Method in class org.hibernate.hql.ast.tree.IntoClause

initialize(Token) - Method in class org.hibernate.hql.ast.tree.Node

initialize(AST) - Method in class org.hibernate.hql.ast.tree.Node

initialize() - Method in interface org.hibernate.hql.ast.tree.OperatorNode
Called by the tree walker during hql-sql semantic analysis after the operator sub-tree is completely built.
initialize() - Method in class org.hibernate.hql.ast.tree.UnaryArithmeticNode

initialize() - Method in class org.hibernate.hql.ast.tree.UnaryLogicOperatorNode

initialize(Serializable, SessionImplementor) - Method in class org.hibernate.loader.collection.BatchingCollectionInitializer

initialize(Serializable, SessionImplementor) - Method in interface org.hibernate.loader.collection.CollectionInitializer
Initialize the given collection
initialize(Serializable, SessionImplementor) - Method in class org.hibernate.loader.collection.CollectionLoader

initialize(Serializable, SessionImplementor) - Method in class org.hibernate.loader.collection.SubselectCollectionLoader

initialize(Serializable, SessionImplementor) - Method in class org.hibernate.loader.collection.SubselectOneToManyLoader

initialize(Serializable, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

initialize(Serializable, SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister
Initialize the given collection with the given key
initialize(Serializable, SessionImplementor) - Method in class org.hibernate.persister.collection.NamedQueryCollectionInitializer

initialize() - Method in class org.hibernate.proxy.AbstractLazyInitializer

initialize() - Method in interface org.hibernate.proxy.LazyInitializer
Initialize the proxy, fetching the target entity if necessary
initialize(Configuration) - Method in class org.hibernate.secure.JACCPreDeleteEventListener

initialize(Configuration) - Method in class org.hibernate.secure.JACCPreInsertEventListener

initialize(Configuration) - Method in class org.hibernate.secure.JACCPreLoadEventListener

initialize(Configuration) - Method in class org.hibernate.secure.JACCPreUpdateEventListener

initializeCollection(PersistentCollection, boolean) - Method in interface org.hibernate.engine.SessionImplementor
Initialize the collection (if not already initialized)
initializeCollection(FromClause, String, String) - Method in class org.hibernate.hql.ast.tree.FromElement

initializeCollection(PersistentCollection, boolean) - Method in class org.hibernate.impl.SessionImpl

initializeCollection(PersistentCollection, boolean) - Method in class org.hibernate.impl.StatelessSessionImpl

initializeDerivedSelectClause(FromClause) - Method in class org.hibernate.hql.ast.tree.SelectClause
Prepares a derived (i.e., not explicitly defined in the query) select clause.
initializeEntity(Object, boolean, SessionImplementor, PreLoadEvent, PostLoadEvent) - Static method in class org.hibernate.engine.TwoPhaseLoad
Perform the second step of 2-phase load.
initializeEntity(FromClause, String, EntityPersister, EntityType, String, String) - Method in class org.hibernate.hql.ast.tree.FromElement

initializeExplicitSelectClause(FromClause) - Method in class org.hibernate.hql.ast.tree.SelectClause
Prepares an explicitly defined select clause.
initializeFromCache(CollectionPersister, Serializable, Object) - Method in class org.hibernate.collection.PersistentArrayHolder

initializeFromCache(CollectionPersister, Serializable, Object) - Method in class org.hibernate.collection.PersistentBag

initializeFromCache(CollectionPersister, Serializable, Object) - Method in interface org.hibernate.collection.PersistentCollection
Read the state of the collection from a disassembled cached value
initializeFromCache(CollectionPersister, Serializable, Object) - Method in class org.hibernate.collection.PersistentElementHolder

initializeFromCache(CollectionPersister, Serializable, Object) - Method in class org.hibernate.collection.PersistentIdentifierBag

initializeFromCache(CollectionPersister, Serializable, Object) - Method in class org.hibernate.collection.PersistentList

initializeFromCache(CollectionPersister, Serializable, Object) - Method in class org.hibernate.collection.PersistentListElementHolder

initializeFromCache(CollectionPersister, Serializable, Object) - Method in class org.hibernate.collection.PersistentMap

initializeFromCache(CollectionPersister, Serializable, Object) - Method in class org.hibernate.collection.PersistentMapElementHolder

initializeFromCache(CollectionPersister, Serializable, Object) - Method in class org.hibernate.collection.PersistentSet

initializeImmediately(EntityMode) - Method in class org.hibernate.type.ArrayType

initializeImmediately(EntityMode) - Method in class org.hibernate.type.CollectionType

initializeLazyProperty(String, Object, SessionImplementor) - Method in interface org.hibernate.intercept.LazyPropertyInitializer
Initialize the property, and return its new value
initializeLazyProperty(String, Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

initializeListeners(Configuration) - Method in class org.hibernate.event.EventListeners
Call initialize() on any listeners that implement Initializable.
initializeMethodNode(AST, boolean) - Method in class org.hibernate.hql.ast.tree.MethodNode

initializeNonLazyCollections() - Method in interface org.hibernate.engine.PersistenceContext
Force initialization of all non-lazy collections encountered during the current two-phase load (actually, this is a no-op, unless this is the "outermost" load)
initializeNonLazyCollections() - Method in class org.hibernate.engine.StatefulPersistenceContext
Force initialization of all non-lazy collections encountered during the current two-phase load (actually, this is a no-op, unless this is the "outermost" load)
injectFieldInterceptor(Object, String, Set, SessionImplementor) - Static method in class org.hibernate.intercept.FieldInterceptionHelper

injectFieldInterceptor(Object, String, Set, SessionImplementor) - Static method in class org.hibernate.intercept.cglib.CGLIBHelper

injectFieldInterceptor(Object, String, Set, SessionImplementor) - Static method in class org.hibernate.intercept.javassist.JavassistHelper

injectParameters(Object, Properties) - Static method in class org.hibernate.type.TypeFactory

insert(Object) - Method in interface org.hibernate.StatelessSession
Insert a row.
insert(String, Object) - Method in interface org.hibernate.StatelessSession
Insert a row.
insert(Object, Object, Object) - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Called after an item has been inserted (before the transaction completes), instead of calling evict().
insert(Object, Object, Object) - Method in class org.hibernate.cache.NonstrictReadWriteCache
Invalidate the item
insert(Object, Object, Object) - Method in class org.hibernate.cache.ReadOnlyCache
Do nothing.
insert(Object, Object, Object) - Method in class org.hibernate.cache.ReadWriteCache
Do nothing.
insert(Object, Object, Object) - Method in class org.hibernate.cache.TransactionalCache

insert(Object) - Method in class org.hibernate.impl.StatelessSessionImpl

insert(String, Object) - Method in class org.hibernate.impl.StatelessSessionImpl

insert(Object[], boolean[], String, Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Perform an SQL INSERT, and then retrieve a generated identifier.
insert(Serializable, Object[], boolean[], int, String, Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Perform an SQL INSERT.
insert(Object[], Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

insert(Serializable, Object[], Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

insert(Serializable, Object[], Object, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Persist an instance
insert(Object[], Object, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Persist an instance, using a natively generated identifier (optional operation)
insertCallable - Variable in class org.hibernate.persister.entity.AbstractEntityPersister

insertChild(AST, AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil
Inserts the child as the first child of the parent, all other children are shifted over to the 'right'.
insertEntity(String) - Method in class org.hibernate.stat.StatisticsImpl

insertEntity(String) - Method in interface org.hibernate.stat.StatisticsImplementor

insertResultCheckStyles - Variable in class org.hibernate.persister.entity.AbstractEntityPersister

insertRow() - Method in class org.hibernate.jdbc.ResultSetWrapper

insertRows(PersistentCollection, Serializable, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

insertRows(PersistentCollection, Serializable, SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister
Insert the persistent state of any new collection elements
insertSibling(AST, AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil

insertStatement() - Method in class org.hibernate.hql.antlr.HqlBaseParser

insertStatement(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

insertStatement(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

insertablePropertySpec() - Method in class org.hibernate.hql.antlr.HqlBaseParser

insertablePropertySpec(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

instantiate(String, EntityMode, Serializable) - Method in class org.hibernate.EmptyInterceptor

instantiate(String, EntityMode, Serializable) - Method in interface org.hibernate.Interceptor
Instantiate the entity class.
instantiate(String, Serializable) - Method in interface org.hibernate.engine.SessionImplementor
Instantiate the entity class, initializing with the given identifier
instantiate(EntityPersister, Serializable) - Method in interface org.hibernate.event.EventSource
Instantiate an entity instance, using either an interceptor, or the given persister
instantiate(Object[]) - Method in class org.hibernate.hql.HolderInstantiator

instantiate(String, Serializable) - Method in class org.hibernate.impl.SessionImpl

instantiate(EntityPersister, Serializable) - Method in class org.hibernate.impl.SessionImpl
give the interceptor an opportunity to override the default instantiation
instantiate(String, Serializable) - Method in class org.hibernate.impl.StatelessSessionImpl

instantiate(Serializable, EntityMode) - Method in interface org.hibernate.metadata.ClassMetadata
Create a class instance initialized with the given identifier
instantiate(Serializable, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

instantiate(Serializable, EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Create a class instance initialized with the given identifier
instantiate(Serializable) - Method in class org.hibernate.tuple.Dom4jInstantiator

instantiate() - Method in class org.hibernate.tuple.Dom4jInstantiator

instantiate(Serializable) - Method in class org.hibernate.tuple.DynamicMapInstantiator

instantiate() - Method in class org.hibernate.tuple.DynamicMapInstantiator

instantiate(Serializable) - Method in interface org.hibernate.tuple.Instantiator
Perform the requested entity instantiation.
instantiate() - Method in interface org.hibernate.tuple.Instantiator
Perform the requested instantiation.
instantiate() - Method in class org.hibernate.tuple.PojoInstantiator

instantiate(Serializable) - Method in class org.hibernate.tuple.PojoInstantiator

instantiate() - Method in interface org.hibernate.tuple.Tuplizer
Generate a new, empty entity.
instantiate() - Method in class org.hibernate.tuple.component.AbstractComponentTuplizer
This method does not populate the component parent
instantiate(Serializable) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

instantiate() - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

instantiate(Serializable) - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Create an entity instance initialized with the given identifier.
instantiate(SessionImplementor, CollectionPersister, Serializable) - Method in class org.hibernate.type.ArrayType

instantiate(int) - Method in class org.hibernate.type.ArrayType

instantiate(SessionImplementor, CollectionPersister, Serializable) - Method in class org.hibernate.type.BagType

instantiate(int) - Method in class org.hibernate.type.BagType

instantiate(SessionImplementor, CollectionPersister, Serializable) - Method in class org.hibernate.type.CollectionType
Instantiate an uninitialized collection wrapper or holder.
instantiate(int) - Method in class org.hibernate.type.CollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
instantiate(EntityMode) - Method in class org.hibernate.type.ComponentType
This method does not populate the component parent
instantiate(Object, SessionImplementor) - Method in class org.hibernate.type.ComponentType

instantiate(SessionImplementor, CollectionPersister, Serializable) - Method in class org.hibernate.type.CustomCollectionType

instantiate(int) - Method in class org.hibernate.type.CustomCollectionType

instantiate(Object, SessionImplementor) - Method in class org.hibernate.type.EmbeddedComponentType

instantiate(SessionImplementor, CollectionPersister, Serializable) - Method in class org.hibernate.type.IdentifierBagType

instantiate(int) - Method in class org.hibernate.type.IdentifierBagType

instantiate(SessionImplementor, CollectionPersister, Serializable) - Method in class org.hibernate.type.ListType

instantiate(int) - Method in class org.hibernate.type.ListType

instantiate(SessionImplementor, CollectionPersister, Serializable) - Method in class org.hibernate.type.MapType

instantiate(int) - Method in class org.hibernate.type.MapType

instantiate(int) - Method in class org.hibernate.type.OrderedMapType

instantiate(int) - Method in class org.hibernate.type.OrderedSetType

instantiate(SessionImplementor, CollectionPersister, Serializable) - Method in class org.hibernate.type.SetType

instantiate(int) - Method in class org.hibernate.type.SetType

instantiate(SessionImplementor, CollectionPersister, Serializable) - Method in class org.hibernate.type.SortedMapType

instantiate(int) - Method in class org.hibernate.type.SortedMapType

instantiate(SessionImplementor, CollectionPersister, Serializable) - Method in class org.hibernate.type.SortedSetType

instantiate(int) - Method in class org.hibernate.type.SortedSetType

instantiate(SessionImplementor, CollectionPersister) - Method in interface org.hibernate.usertype.UserCollectionType
Instantiate an uninitialized instance of the collection wrapper
instantiate(int) - Method in interface org.hibernate.usertype.UserCollectionType
Instantiate an empty instance of the "underlying" collection (not a wrapper), but with the given anticipated size (i.e.
instantiate(int) - Static method in class org.hibernate.util.IdentityMap
Return a new instance of this class, with an undefined iteration order
instantiateResult(Object) - Method in class org.hibernate.type.ArrayType

instantiateResult(Object) - Method in class org.hibernate.type.CollectionType
Instantiate a new "underlying" collection exhibiting the same capacity charactersitcs and the passed "original".
instantiateSequenced(int) - Static method in class org.hibernate.util.IdentityMap
Return a new instance of this class, with iteration order defined by the order that entries were added
instantiator - Variable in class org.hibernate.tuple.component.AbstractComponentTuplizer

intercept(Object, String, Object) - Method in class org.hibernate.intercept.AbstractFieldInterceptor

internalLoad(String, Serializable, boolean, boolean) - Method in interface org.hibernate.engine.SessionImplementor
Load an instance without checking if it was deleted.
internalLoad(String, Serializable, boolean, boolean) - Method in class org.hibernate.impl.SessionImpl

internalLoad(String, Serializable, boolean, boolean) - Method in class org.hibernate.impl.StatelessSessionImpl

intoClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

intoClause(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

invalidate(Serializable[]) - Method in class org.hibernate.cache.UpdateTimestampsCache

invert(Map) - Static method in class org.hibernate.util.IdentityMap

invoke(String, Class[], Object, Object[]) - Method in class org.hibernate.bytecode.javassist.FastClass

invoke(int, Object, Object[]) - Method in class org.hibernate.bytecode.javassist.FastClass

invoke(Object, Method, Object[]) - Method in class org.hibernate.jdbc.BorrowedConnectionProxy

invoke(Method, Object[], Object) - Method in class org.hibernate.proxy.pojo.BasicLazyInitializer

invoke(Object, Method, Object[]) - Method in class org.hibernate.proxy.pojo.cglib.CGLIBLazyInitializer

invoke(Object, Method, Method, Object[]) - Method in class org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer

invokeDeleteLifecycle(EventSource, Object, EntityPersister) - Method in class org.hibernate.event.def.DefaultDeleteEventListener

invokeInterceptor(SessionImplementor, Object, EntityEntry, Object[], EntityPersister) - Method in class org.hibernate.event.def.DefaultFlushEntityEventListener

invokeSaveLifecycle(Object, EntityPersister, EventSource) - Method in class org.hibernate.event.def.AbstractSaveEventListener

invokeUpdateLifecycle(Object, EntityPersister, EventSource) - Method in class org.hibernate.event.def.DefaultSaveOrUpdateEventListener

isAbstract() - Method in class org.hibernate.mapping.PersistentClass

isAbstract() - Method in class org.hibernate.mapping.Table

isAbstract() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isAbstract() - Method in interface org.hibernate.persister.entity.Loadable

isAbstract() - Method in interface org.hibernate.persister.entity.Queryable
Is this an abstract class?
isAbstract() - Method in class org.hibernate.tuple.entity.EntityMetamodel

isAbstractClass(Class) - Static method in class org.hibernate.util.ReflectHelper

isAbstractUnionTable() - Method in class org.hibernate.mapping.Table

isActive() - Method in interface org.hibernate.Transaction
Is this transaction still active?
Again, this only returns information in relation to the local transaction, not the actual underlying transaction.
isActive() - Method in class org.hibernate.transaction.CMTTransaction

isActive() - Method in class org.hibernate.transaction.JDBCTransaction

isActive() - Method in class org.hibernate.transaction.JTATransaction

isAffectedBy(Map) - Method in class org.hibernate.util.FilterHelper

isAffectedByEnabledFilters(SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isAffectedByEnabledFilters(SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister

isAfterLast() - Method in class org.hibernate.jdbc.ResultSetWrapper

isAggressiveRelease() - Method in class org.hibernate.jdbc.ConnectionManager
Will connections be released after each statement execution?
Connections will be released after each statement if either: the defined release-mode is ConnectionReleaseMode.AFTER_STATEMENT; or the defined release-mode is ConnectionReleaseMode.AFTER_TRANSACTION but we are in auto-commit mode.
isAlias(String) - Method in class org.hibernate.hql.ast.util.LiteralProcessor

isAllFalse(boolean[]) - Static method in class org.hibernate.util.ArrayHelper

isAllNegative(int[]) - Static method in class org.hibernate.util.ArrayHelper

isAllPropertyFetch() - Method in class org.hibernate.hql.ast.tree.FromElement

isAllTrue(boolean[]) - Static method in class org.hibernate.util.ArrayHelper

isAllowNulls() - Method in class org.hibernate.event.LoadEventListener.LoadType

isAllowProxyCreation() - Method in class org.hibernate.event.LoadEventListener.LoadType

isAlternateUniqueKey() - Method in class org.hibernate.mapping.Collection

isAlternateUniqueKey() - Method in class org.hibernate.mapping.OneToMany

isAlternateUniqueKey() - Method in class org.hibernate.mapping.SimpleValue

isAlternateUniqueKey() - Method in interface org.hibernate.mapping.Value

isAlwaysDirtyChecked() - Method in class org.hibernate.type.AnyType

isAlwaysDirtyChecked() - Method in interface org.hibernate.type.AssociationType
Do we dirty check this association, even when there are no columns to be updated?
isAlwaysDirtyChecked() - Method in class org.hibernate.type.CollectionType
We always need to dirty check the collection because we sometimes need to incremement version number of owner and also because of how assemble/disassemble is implemented for uks
isAlwaysDirtyChecked() - Method in class org.hibernate.type.ManyToOneType

isAlwaysDirtyChecked() - Method in class org.hibernate.type.OneToOneType
We don't need to dirty check one-to-one because of how assemble/disassemble is implemented and because a one-to-one association is never dirty
isAnyCollectionProperty(String) - Static method in class org.hibernate.hql.CollectionProperties

isAnyType() - Method in class org.hibernate.type.AbstractType

isAnyType() - Method in class org.hibernate.type.AnyType

isAnyType() - Method in interface org.hibernate.type.Type
Is this an "any" type.
isArray() - Method in class org.hibernate.mapping.Array

isArray() - Method in class org.hibernate.mapping.Collection

isArray() - Method in interface org.hibernate.metadata.CollectionMetadata
Is the collection an array?
isArray() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isArray() - Method in interface org.hibernate.persister.collection.CollectionPersister
Is this an array?
isArrayType() - Method in class org.hibernate.type.ArrayType

isArrayType() - Method in class org.hibernate.type.CollectionType

isAssociationFetch() - Method in class org.hibernate.event.LoadEvent

isAssociationType() - Method in class org.hibernate.type.AbstractType

isAssociationType() - Method in class org.hibernate.type.AnyType

isAssociationType() - Method in class org.hibernate.type.CollectionType
Note: return true because this type is castable to AssociationType.
isAssociationType() - Method in class org.hibernate.type.EntityType

isAssociationType() - Method in interface org.hibernate.type.Type
Return true if the implementation is castable to AssociationType.
isAutoCloseEnabled() - Method in class org.hibernate.context.JTASessionContext
Mainly for subclass usage.
isAutoCloseEnabled() - Method in class org.hibernate.context.ThreadLocalSessionContext
Mainly for subclass usage.
isAutoCloseSessionEnabled() - Method in class org.hibernate.cfg.Settings

isAutoCloseSessionEnabled() - Method in class org.hibernate.impl.SessionImpl

isAutoCloseSessionEnabled() - Method in class org.hibernate.impl.StatelessSessionImpl

isAutoCloseSessionEnabled() - Method in interface org.hibernate.jdbc.JDBCContext.Context

isAutoCommit() - Method in class org.hibernate.jdbc.ConnectionManager
Is the connection considered "auto-commit"?
isAutoCreateSchema() - Method in class org.hibernate.cfg.Settings

isAutoDropSchema() - Method in class org.hibernate.cfg.Settings

isAutoFlushEnabled() - Method in class org.hibernate.context.JTASessionContext
Mainly for subclass usage.
isAutoFlushEnabled() - Method in class org.hibernate.context.ThreadLocalSessionContext
Mainly for subclass usage.
isAutoImport() - Method in class org.hibernate.cfg.Mappings
Returns the autoImport.
isAutoUpdateSchema() - Method in class org.hibernate.cfg.Settings

isAutoValidateSchema() - Method in class org.hibernate.cfg.Settings

isBackRef() - Method in class org.hibernate.mapping.Backref

isBackRef() - Method in class org.hibernate.mapping.IndexBackref

isBackRef() - Method in class org.hibernate.mapping.Property

isBasicPropertyAccessor() - Method in class org.hibernate.mapping.Backref

isBasicPropertyAccessor() - Method in class org.hibernate.mapping.IndexBackref

isBasicPropertyAccessor() - Method in class org.hibernate.mapping.Property

isBatchLoadable() - Method in class org.hibernate.engine.EntityKey

isBatchLoadable() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isBatchLoadable() - Method in interface org.hibernate.persister.entity.EntityPersister
Is batch loading enabled?
isBatchable() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isBeforeFirst() - Method in class org.hibernate.jdbc.ResultSetWrapper

isBeingIntrumented(String) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

isBeingReplicated() - Method in class org.hibernate.engine.EntityEntry

isCacheInvalidationRequired() - Method in class org.hibernate.persister.entity.AbstractEntityPersister
We can't immediately add to the cache if we have formulas which must be evaluated, or if we have the possibility of two concurrent updates to the same item being merged on the database.
isCacheInvalidationRequired() - Method in interface org.hibernate.persister.entity.EntityPersister
Should we always invalidate the cache instead of recaching updated state
isCacheable() - Method in class org.hibernate.engine.NamedQueryDefinition

isCacheable() - Method in class org.hibernate.engine.QueryParameters

isCallable() - Method in class org.hibernate.engine.NamedSQLQueryDefinition

isCallable() - Method in class org.hibernate.engine.QueryParameters

isCascadeDeleteEnabled() - Method in class org.hibernate.event.DeleteEvent

isCascadeDeleteEnabled() - Method in class org.hibernate.mapping.ForeignKey

isCascadeDeleteEnabled() - Method in interface org.hibernate.mapping.KeyValue

isCascadeDeleteEnabled() - Method in class org.hibernate.mapping.SimpleValue

isCascadeDeleteEnabled() - Method in class org.hibernate.persister.collection.BasicCollectionPersister

isCascadeDeleteEnabled() - Method in interface org.hibernate.persister.collection.CollectionPersister
Is cascade delete handled by the database-level foreign key constraint definition?
isCascadeDeleteEnabled() - Method in class org.hibernate.persister.collection.OneToManyPersister

isCheckDeleted() - Method in class org.hibernate.event.LoadEventListener.LoadType

isClassFile(File) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

isClassOrSuperclassJoin(Join) - Method in class org.hibernate.mapping.PersistentClass

isClassOrSuperclassJoin(Join) - Method in class org.hibernate.mapping.Subclass

isClassOrSuperclassTable(Table) - Method in class org.hibernate.mapping.PersistentClass

isClassOrSuperclassTable(Table) - Method in class org.hibernate.mapping.Subclass

isClassOrSuperclassTable(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isClassOrSuperclassTable(int) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

isClassOrSuperclassTable(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

isClassOrSuperclassTable(int) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

isClearQueueEnabled() - Method in class org.hibernate.collection.AbstractPersistentCollection
Is this collection in a state that would allow us to "queue" clear? This is a special case, because of orphan delete.
isClosed() - Method in interface org.hibernate.SessionFactory
Was this SessionFactory already closed?
isClosed() - Method in interface org.hibernate.engine.SessionImplementor
Determine whether the session is closed.
isClosed() - Method in class org.hibernate.impl.AbstractSessionImpl

isClosed() - Method in class org.hibernate.impl.SessionFactoryImpl

isClosed() - Method in class org.hibernate.jmx.SessionFactoryStub

isClosed() - Method in interface org.hibernate.transaction.TransactionFactory.Context

isCollection() - Method in class org.hibernate.loader.OuterJoinableAssociation

isCollection() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isCollection() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isCollection() - Method in interface org.hibernate.persister.entity.Joinable
Is this instance actually a CollectionPersister?
isCollectionJoin() - Method in class org.hibernate.hql.ast.tree.FromElement

isCollectionOfValuesOrComponents() - Method in class org.hibernate.hql.ast.tree.FromElement

isCollectionProperty(String) - Static method in class org.hibernate.hql.CollectionProperties

isCollectionPropertyMethod() - Method in class org.hibernate.hql.ast.tree.MethodNode

isCollectionType() - Method in class org.hibernate.type.AbstractType

isCollectionType() - Method in class org.hibernate.type.CollectionType

isCollectionType() - Method in interface org.hibernate.type.Type
Is this type a collection type.
isCollectionValued() - Method in class org.hibernate.hql.classic.PathExpressionParser

isCommentsEnabled() - Method in class org.hibernate.cfg.Settings

isComparativeExpressionClause() - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

isCompiled() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

isComponentType() - Method in class org.hibernate.type.AbstractType

isComponentType() - Method in class org.hibernate.type.AnyType

isComponentType() - Method in class org.hibernate.type.ComponentType

isComponentType() - Method in class org.hibernate.type.CompositeCustomType

isComponentType() - Method in interface org.hibernate.type.Type
Is this type a component type.
isComposite() - Method in class org.hibernate.mapping.Property

isConnected() - Method in interface org.hibernate.Session
Check if the Session is currently connected.
isConnected() - Method in interface org.hibernate.engine.SessionImplementor

isConnected() - Method in class org.hibernate.impl.SessionImpl

isConnected() - Method in class org.hibernate.impl.StatelessSessionImpl

isConnectedToSession() - Method in class org.hibernate.proxy.AbstractLazyInitializer

isConstrained() - Method in class org.hibernate.mapping.OneToOne
Returns the constrained.
isConstructor() - Method in class org.hibernate.hql.ast.tree.AbstractSelectExpression

isConstructor() - Method in class org.hibernate.hql.ast.tree.ConstructorNode

isConstructor() - Method in class org.hibernate.hql.ast.tree.QueryNode

isConstructor() - Method in interface org.hibernate.hql.ast.tree.SelectExpression
Returns true if the element is a constructor (e.g.
isCurrentTimestampSelectStringCallable() - Method in class org.hibernate.dialect.DB2Dialect

isCurrentTimestampSelectStringCallable() - Method in class org.hibernate.dialect.Dialect

isCurrentTimestampSelectStringCallable() - Method in class org.hibernate.dialect.FrontBaseDialect

isCurrentTimestampSelectStringCallable() - Method in class org.hibernate.dialect.H2Dialect

isCurrentTimestampSelectStringCallable() - Method in class org.hibernate.dialect.InformixDialect

isCurrentTimestampSelectStringCallable() - Method in class org.hibernate.dialect.InterbaseDialect

isCurrentTimestampSelectStringCallable() - Method in class org.hibernate.dialect.MySQLDialect

isCurrentTimestampSelectStringCallable() - Method in class org.hibernate.dialect.Oracle9Dialect

isCurrentTimestampSelectStringCallable() - Method in class org.hibernate.dialect.PostgreSQLDialect

isCurrentTimestampSelectStringCallable() - Method in class org.hibernate.dialect.SybaseDialect

isCurrentTimestampSelectStringCallable() - Method in class org.hibernate.dialect.TimesTenDialect

isCurrentlyConnected() - Method in class org.hibernate.jdbc.ConnectionManager
Is this ConnectionManager instance "logically" connected.
isCustomDeleteAllCallable() - Method in class org.hibernate.mapping.Collection

isCustomDeleteCallable() - Method in class org.hibernate.mapping.Collection

isCustomDeleteCallable() - Method in class org.hibernate.mapping.Join

isCustomDeleteCallable() - Method in class org.hibernate.mapping.PersistentClass

isCustomInsertCallable() - Method in class org.hibernate.mapping.Collection

isCustomInsertCallable() - Method in class org.hibernate.mapping.Join

isCustomInsertCallable() - Method in class org.hibernate.mapping.PersistentClass

isCustomUpdateCallable() - Method in class org.hibernate.mapping.Collection

isCustomUpdateCallable() - Method in class org.hibernate.mapping.Join

isCustomUpdateCallable() - Method in class org.hibernate.mapping.PersistentClass

isDataDefinitionImplicitCommit() - Method in class org.hibernate.cfg.Settings

isDataDefinitionInTransactionSupported() - Method in class org.hibernate.cfg.Settings

isDefaultLazy() - Method in class org.hibernate.cfg.Mappings

isDefinedOnSubclass(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isDefinedOnSubclass(int) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
Is this property defined on a subclass of the mapped class.
isDeleteAllCallable() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isDeleteCallable() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isDeleteCallable(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isDirectChild(AST, AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil
Determine if a given node (test) is a direct (throtle to one level down) child of another given node (fixture).
isDirectlyAccessible() - Method in class org.hibernate.collection.AbstractPersistentCollection
Could the application possibly have a direct reference to the underlying collection implementation?
isDirectlyAccessible() - Method in class org.hibernate.collection.PersistentArrayHolder

isDirectlyAccessible() - Method in interface org.hibernate.collection.PersistentCollection
Could the application possibly have a direct reference to the underlying collection implementation?
isDirectlyAccessible() - Method in class org.hibernate.collection.PersistentElementHolder

isDirectlyAccessible() - Method in class org.hibernate.collection.PersistentIndexedElementHolder

isDirty() - Method in interface org.hibernate.Session
Does this Session contain any changes which must be synchronized with the database? Would any SQL be executed if we flushed this session?
isDirty() - Method in class org.hibernate.collection.AbstractPersistentCollection

isDirty() - Method in interface org.hibernate.collection.PersistentCollection
Is the collection dirty? Note that this is only reliable during the flush cycle, after the collection elements are dirty checked against the snapshot.
isDirty() - Method in class org.hibernate.event.DirtyCheckEvent

isDirty() - Method in class org.hibernate.impl.SessionImpl

isDirty() - Method in class org.hibernate.intercept.AbstractFieldInterceptor

isDirty() - Method in interface org.hibernate.intercept.FieldInterceptor
Is the entity considered dirty?
isDirty(Object, Object, SessionImplementor) - Method in class org.hibernate.type.AbstractType

isDirty(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.AnyType

isDirty(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.BlobType

isDirty(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.ClobType

isDirty(Object, Object, SessionImplementor) - Method in class org.hibernate.type.CollectionType

isDirty(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.CollectionType

isDirty(Object, Object, SessionImplementor) - Method in class org.hibernate.type.ComponentType

isDirty(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.ComponentType

isDirty(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.CompositeCustomType

isDirty(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.CustomType

isDirty(Object, Object, SessionImplementor) - Method in class org.hibernate.type.ManyToOneType

isDirty(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.ManyToOneType

isDirty(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.MetaType

isDirty(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.NullableType

isDirty(Object, Object, SessionImplementor) - Method in class org.hibernate.type.OneToOneType

isDirty(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.OneToOneType

isDirty(Object, Object, SessionImplementor) - Method in interface org.hibernate.type.Type
Should the parent be considered dirty, given both the old and current field or element value?
isDirty(Object, Object, boolean[], SessionImplementor) - Method in interface org.hibernate.type.Type
Should the parent be considered dirty, given both the old and current field or element value?
isDirtyCheckHandledByInterceptor() - Method in class org.hibernate.event.FlushEntityEvent

isDirtyCheckPossible() - Method in class org.hibernate.event.FlushEntityEvent

isDirtyCheckable(boolean) - Method in class org.hibernate.tuple.StandardProperty

isDirtyCheckable() - Method in class org.hibernate.tuple.StandardProperty

isDiscriminated() - Method in class org.hibernate.hql.ast.tree.IntoClause

isDiscriminatorFormula() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

isDiscriminatorFormula() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

isDiscriminatorInsertable() - Method in class org.hibernate.mapping.PersistentClass

isDiscriminatorInsertable() - Method in class org.hibernate.mapping.RootClass

isDiscriminatorInsertable() - Method in class org.hibernate.mapping.Subclass

isDiscriminatorValueNotNull() - Method in class org.hibernate.mapping.PersistentClass

isDiscriminatorValueNull() - Method in class org.hibernate.mapping.PersistentClass

isDistinct() - Method in class org.hibernate.hql.ast.tree.SelectClause

isDorecreate() - Method in class org.hibernate.engine.CollectionEntry

isDoremove() - Method in class org.hibernate.engine.CollectionEntry

isDoupdate() - Method in class org.hibernate.engine.CollectionEntry

isDuplicateAssociation(String, String[]) - Method in class org.hibernate.loader.JoinWalker
Used to detect circularities in the joined graph, note that this method is side-effecty
isDuplicateAssociation(String, String[], AssociationType) - Method in class org.hibernate.loader.JoinWalker
Used to detect circularities in the joined graph, note that this method is side-effecty
isDuplicateAssociation(String, String[]) - Method in class org.hibernate.loader.collection.OneToManyJoinWalker

isDynamic() - Method in class org.hibernate.mapping.Component

isDynamicInsert() - Method in class org.hibernate.tuple.entity.EntityMetamodel

isDynamicUpdate() - Method in class org.hibernate.tuple.entity.EntityMetamodel

isEmbedded() - Method in class org.hibernate.mapping.Collection

isEmbedded() - Method in class org.hibernate.mapping.Component

isEmbedded() - Method in class org.hibernate.mapping.OneToMany

isEmbedded() - Method in class org.hibernate.mapping.ToOne

isEmbedded() - Method in class org.hibernate.tuple.IdentifierProperty

isEmbedded() - Method in interface org.hibernate.type.AbstractComponentType

isEmbedded() - Method in class org.hibernate.type.AnyType

isEmbedded() - Method in class org.hibernate.type.ComponentType

isEmbedded() - Method in class org.hibernate.type.CompositeCustomType

isEmbedded() - Method in class org.hibernate.type.EmbeddedComponentType

isEmbeddedInXML() - Method in class org.hibernate.type.AnyType

isEmbeddedInXML() - Method in interface org.hibernate.type.AssociationType

isEmbeddedInXML() - Method in class org.hibernate.type.CollectionType

isEmbeddedInXML - Variable in class org.hibernate.type.EntityType

isEmbeddedInXML() - Method in class org.hibernate.type.EntityType

isEmpty() - Method in class org.hibernate.collection.PersistentBag

isEmpty() - Method in class org.hibernate.collection.PersistentIdentifierBag

isEmpty() - Method in class org.hibernate.collection.PersistentList

isEmpty() - Method in class org.hibernate.collection.PersistentMap

isEmpty() - Method in class org.hibernate.collection.PersistentSet

isEmpty() - Method in class org.hibernate.criterion.Property

isEmpty(String) - Static method in class org.hibernate.criterion.Restrictions
Constrain a collection valued property to be empty
isEmpty() - Method in class org.hibernate.proxy.map.MapProxy

isEmpty() - Method in class org.hibernate.util.FastHashMap
Return true if this map contains no mappings.
isEmpty() - Method in class org.hibernate.util.IdentityMap

isEmpty() - Method in class org.hibernate.util.IdentitySet

isEmpty(String) - Static method in class org.hibernate.util.StringHelper

isEntity() - Method in class org.hibernate.hql.ast.tree.FromElement

isEntityType() - Method in class org.hibernate.type.AbstractType

isEntityType() - Method in class org.hibernate.type.EntityType

isEntityType() - Method in interface org.hibernate.type.Type
Is this type an entity type?
isEntryFor(Object) - Method in interface org.hibernate.engine.PersistenceContext
Is there an EntityEntry for this instance?
isEntryFor(Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Is there an EntityEntry for this instance?
isEqual(Object, Object) - Method in class org.hibernate.type.AbstractBynaryType

isEqual(Object, Object, EntityMode) - Method in class org.hibernate.type.AbstractType

isEqual(Object, Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.AbstractType

isEqual(Object, Object) - Method in class org.hibernate.type.AdaptedImmutableType

isEqual(Object, Object) - Method in class org.hibernate.type.BigDecimalType

isEqual(Object, Object) - Method in class org.hibernate.type.BigIntegerType

isEqual(Object, Object, EntityMode) - Method in class org.hibernate.type.BlobType

isEqual(Object, Object) - Method in class org.hibernate.type.CalendarDateType

isEqual(Object, Object) - Method in class org.hibernate.type.CalendarType

isEqual(Object, Object, EntityMode) - Method in class org.hibernate.type.ClobType

isEqual(Object, Object, EntityMode) - Method in class org.hibernate.type.CollectionType

isEqual(Object, Object, EntityMode) - Method in class org.hibernate.type.ComponentType

isEqual(Object, Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.ComponentType

isEqual(Object, Object, EntityMode) - Method in class org.hibernate.type.CompositeCustomType

isEqual(Object, Object) - Method in class org.hibernate.type.CustomType

isEqual(Object, Object, EntityMode) - Method in class org.hibernate.type.CustomType

isEqual(Object, Object) - Method in class org.hibernate.type.DateType

isEqual(Object, Object, EntityMode, SessionFactoryImplementor) - Method in class org.hibernate.type.EntityType

isEqual(Object, Object, EntityMode) - Method in class org.hibernate.type.NullableType

isEqual(Object, Object) - Method in class org.hibernate.type.NullableType

isEqual(Object, Object) - Method in class org.hibernate.type.SerializableType

isEqual(Object, Object) - Method in class org.hibernate.type.TimeType

isEqual(Object, Object) - Method in class org.hibernate.type.TimestampType

isEqual(Object, Object, EntityMode) - Method in interface org.hibernate.type.Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
isEqual(Object, Object, EntityMode, SessionFactoryImplementor) - Method in interface org.hibernate.type.Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
isEqual(Object, Object) - Method in interface org.hibernate.type.VersionType
Are the two version values considered equal?
isEquals(Object[], Object[]) - Static method in class org.hibernate.util.ArrayHelper
Compare 2 arrays only at the first level
isEquals(char[], char[]) - Static method in class org.hibernate.util.ArrayHelper
Compare 2 arrays only at the first level
isEquals(byte[], byte[]) - Static method in class org.hibernate.util.ArrayHelper
Compare 2 arrays only at the first level
isEventSource() - Method in interface org.hibernate.engine.SessionImplementor

isEventSource() - Method in class org.hibernate.impl.SessionImpl

isEventSource() - Method in class org.hibernate.impl.StatelessSessionImpl

isExistsInDatabase() - Method in class org.hibernate.engine.EntityEntry

isExpectingCollectionIndex() - Method in class org.hibernate.hql.classic.PathExpressionParser

isExplicitIdInsertion() - Method in class org.hibernate.hql.ast.tree.IntoClause

isExplicitPolymorphism() - Method in class org.hibernate.mapping.PersistentClass

isExplicitPolymorphism() - Method in class org.hibernate.mapping.RootClass

isExplicitPolymorphism() - Method in class org.hibernate.mapping.Subclass

isExplicitPolymorphism() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isExplicitPolymorphism() - Method in interface org.hibernate.persister.entity.Queryable
Is this class explicit polymorphism only?
isExplicitPolymorphism() - Method in class org.hibernate.tuple.entity.EntityMetamodel

isExplicitVersionInsertion() - Method in class org.hibernate.hql.ast.tree.IntoClause

isExtended() - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

isExtraLazy() - Method in class org.hibernate.mapping.Collection

isExtraLazy() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isExtraLazy() - Method in interface org.hibernate.persister.collection.CollectionPersister

isFetch() - Method in class org.hibernate.hql.ast.tree.FromElement

isFilter() - Method in class org.hibernate.hql.antlr.HqlBaseParser
Returns true if this is a filter query, false if not.
isFilter() - Method in class org.hibernate.hql.ast.tree.FromElement

isFinalClass(Class) - Static method in class org.hibernate.util.ReflectHelper

isFirst() - Method in interface org.hibernate.ScrollableResults
Is this the first result?
isFirst() - Method in class org.hibernate.impl.FetchingScrollableResultsImpl
Is this the first result?
isFirst() - Method in class org.hibernate.impl.ScrollableResultsImpl

isFirst() - Method in class org.hibernate.jdbc.ResultSetWrapper

isFlushBeforeCompletionEnabled() - Method in class org.hibernate.cfg.Settings

isFlushBeforeCompletionEnabled() - Method in class org.hibernate.impl.SessionImpl

isFlushBeforeCompletionEnabled() - Method in class org.hibernate.impl.StatelessSessionImpl

isFlushBeforeCompletionEnabled() - Method in interface org.hibernate.transaction.TransactionFactory.Context

isFlushModeNever() - Method in class org.hibernate.impl.SessionImpl

isFlushModeNever() - Method in class org.hibernate.impl.StatelessSessionImpl

isFlushModeNever() - Method in interface org.hibernate.transaction.TransactionFactory.Context

isFlushRequired() - Method in class org.hibernate.event.AutoFlushEvent

isFlushing() - Method in interface org.hibernate.engine.PersistenceContext
Is a flush cycle currently in process?
isFlushing() - Method in class org.hibernate.engine.StatefulPersistenceContext

isForceDiscriminator() - Method in class org.hibernate.mapping.PersistentClass

isForceDiscriminator() - Method in class org.hibernate.mapping.RootClass

isForceDiscriminator() - Method in class org.hibernate.mapping.Subclass

isFormatSqlEnabled() - Method in class org.hibernate.cfg.Settings

isFormula() - Method in class org.hibernate.mapping.Column

isFormula() - Method in class org.hibernate.mapping.Formula

isFormula() - Method in interface org.hibernate.mapping.Selectable

isFromElementAlias(String) - Method in class org.hibernate.hql.ast.tree.FromClause
Convenience method to check whether a given token represents a from-element alias.
isFromOrJoinFragment() - Method in class org.hibernate.hql.ast.tree.FromElement

isGetEnabled() - Method in class org.hibernate.CacheMode

isGetGeneratedKeysEnabled() - Method in class org.hibernate.cfg.Settings

isGettable(long) - Method in class org.hibernate.cache.ReadWriteCache.Item
Is this item visible to the timestamped transaction?
isGettable(long) - Method in class org.hibernate.cache.ReadWriteCache.Lock
locks are not returned to the client!
isGettable(long) - Method in interface org.hibernate.cache.ReadWriteCache.Lockable

isGrouped() - Method in class org.hibernate.criterion.AliasedProjection

isGrouped() - Method in class org.hibernate.criterion.Distinct

isGrouped() - Method in class org.hibernate.criterion.IdentifierProjection

isGrouped() - Method in interface org.hibernate.criterion.Projection
Does this projection specify grouping attributes?
isGrouped() - Method in class org.hibernate.criterion.ProjectionList

isGrouped() - Method in class org.hibernate.criterion.PropertyProjection

isGrouped() - Method in class org.hibernate.criterion.SQLProjection

isGrouped() - Method in class org.hibernate.criterion.SimpleProjection

isIdentified() - Method in class org.hibernate.mapping.Collection

isIdentified() - Method in class org.hibernate.mapping.IdentifierCollection

isIdentifierAssignedByInsert() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isIdentifierAssignedByInsert() - Method in interface org.hibernate.persister.entity.EntityPersister
Is the identifier assigned before the insert by an IDGenerator.
isIdentifierAssignedByInsert() - Method in class org.hibernate.tuple.IdentifierProperty

isIdentifierRollbackEnabled() - Method in class org.hibernate.cfg.Settings

isIdentityColumn(Dialect) - Method in interface org.hibernate.mapping.KeyValue

isIdentityColumn(Dialect) - Method in class org.hibernate.mapping.SimpleValue

isIgnore() - Method in class org.hibernate.engine.CollectionEntry

isIgnoreNotFound() - Method in class org.hibernate.mapping.ManyToOne

isIgnoreNotFound() - Method in class org.hibernate.mapping.OneToMany

isImplied() - Method in class org.hibernate.hql.ast.tree.FromElement
Returns true if this FromElement was implied by a path, or false if this FROM element is explicitly declared in the FROM clause.
isImplied() - Method in class org.hibernate.hql.ast.tree.ImpliedFromElement

isImpliedInFromClause() - Method in class org.hibernate.hql.ast.tree.FromElement

isImpliedInFromClause() - Method in class org.hibernate.hql.ast.tree.ImpliedFromElement

isInCase() - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

isInFrom() - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

isInFunctionCall() - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

isInProgress(int) - Static method in class org.hibernate.util.JTAHelper

isInSelect() - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

isIncludeSubclasses() - Method in class org.hibernate.hql.ast.tree.FromElement

isIncludeSubclasses() - Method in class org.hibernate.hql.ast.tree.ImpliedFromElement

isIndexed() - Method in class org.hibernate.mapping.Collection

isIndexed() - Method in class org.hibernate.mapping.IndexedCollection

isInherited() - Method in class org.hibernate.mapping.PersistentClass

isInherited() - Method in class org.hibernate.mapping.RootClass

isInherited() - Method in class org.hibernate.mapping.Subclass

isInherited() - Method in interface org.hibernate.metadata.ClassMetadata
Does this entity extend a mapped superclass?
isInherited() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isInherited() - Method in interface org.hibernate.persister.entity.EntityPersister
Is this class mapped as a subclass of another class?
isInherited() - Method in class org.hibernate.tuple.entity.EntityMetamodel

isInitialized(Object) - Static method in class org.hibernate.Hibernate
Check if the proxy or persistent collection is initialized.
isInitialized() - Method in class org.hibernate.intercept.AbstractFieldInterceptor

isInitialized(String) - Method in class org.hibernate.intercept.AbstractFieldInterceptor

isInitialized() - Method in interface org.hibernate.intercept.FieldInterceptor
Is the entity to which we are bound completely initialized?
isInitialized(String) - Method in interface org.hibernate.intercept.FieldInterceptor
The the given field initialized for the entity to which we are bound?
isInitializing() - Method in class org.hibernate.intercept.AbstractFieldInterceptor

isInsertCallable() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isInsertCallable(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isInsertGenerated() - Method in class org.hibernate.tuple.StandardProperty

isInsertable() - Method in class org.hibernate.mapping.Property

isInsertable() - Method in class org.hibernate.tuple.StandardProperty

isInstance(Object, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isInstance(Object, EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Is the given object an instance of this entity?
isInstance(Object) - Method in class org.hibernate.tuple.Dom4jInstantiator

isInstance(Object) - Method in class org.hibernate.tuple.DynamicMapInstantiator

isInstance(Object) - Method in interface org.hibernate.tuple.Instantiator
Performs check to see if the given object is an instance of the entity or component which this Instantiator instantiates.
isInstance(Object) - Method in class org.hibernate.tuple.PojoInstantiator

isInstance(Object) - Method in interface org.hibernate.tuple.Tuplizer
Is the given object considered an instance of the the entity (acconting for entity-mode) managed by this tuplizer.
isInstance(Object) - Method in class org.hibernate.tuple.component.AbstractComponentTuplizer

isInstance(Object) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

isInstrumented() - Method in interface org.hibernate.bytecode.util.ClassDescriptor
Determine if the class is already instrumented.
isInstrumented(Class) - Static method in class org.hibernate.intercept.FieldInterceptionHelper

isInstrumented(Object) - Static method in class org.hibernate.intercept.FieldInterceptionHelper

isInstrumented(EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isInstrumented(EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Has the class actually been bytecode instrumented?
isInstrumented() - Method in class org.hibernate.tuple.entity.Dom4jEntityTuplizer

isInstrumented() - Method in class org.hibernate.tuple.entity.DynamicMapEntityTuplizer

isInstrumented() - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Is it an instrumented POJO?
isInstrumented() - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

isInverse() - Method in class org.hibernate.mapping.Collection

isInverse() - Method in class org.hibernate.mapping.Join

isInverse() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isInverse() - Method in interface org.hibernate.persister.collection.CollectionPersister
Is this collection "inverse", so state changes are not propogated to the database.
isInverseSubclassTable(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isInverseSubclassTable(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

isInverseTable(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isInverseTable(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

isJarFile(File) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

isJdbcBatchVersionedData() - Method in class org.hibernate.cfg.Settings

isJoin(String) - Method in class org.hibernate.loader.criteria.CriteriaQueryTranslator

isJoinable(int, Set, String, String[], AssociationType, int) - Method in class org.hibernate.loader.JoinWalker
Should we join this association?
isJoinedFetchEnabled(AssociationType, FetchMode, CascadeStyle) - Method in class org.hibernate.loader.AbstractEntityJoinWalker
The superclass deliberately excludes collections
isJoinedFetchEnabled(AssociationType, FetchMode, CascadeStyle) - Method in class org.hibernate.loader.JoinWalker
Override on subclasses to enable or suppress joining of certain association types
isJoinedFetchEnabled(AssociationType, FetchMode, CascadeStyle) - Method in class org.hibernate.loader.entity.CascadeEntityJoinWalker

isJoinedFetchEnabled(AssociationType, FetchMode, CascadeStyle) - Method in class org.hibernate.loader.entity.EntityJoinWalker
Disable outer join fetching if this loader obtains an upgrade lock mode
isJoinedFetchEnabledInMapping(FetchMode, AssociationType) - Method in class org.hibernate.loader.JoinWalker
Does the mapping, and Hibernate default semantics, specify that this association should be fetched by outer joining
isJoinedSubclass() - Method in class org.hibernate.mapping.PersistentClass

isJoinedSubclass() - Method in class org.hibernate.mapping.RootClass

isJoinedSubclass() - Method in class org.hibernate.mapping.Subclass

isJpaStyle() - Method in class org.hibernate.engine.query.NamedParameterDescriptor

isJpaStyle() - Method in class org.hibernate.engine.query.ParamLocationRecognizer.NamedParameterDescription

isKey() - Method in class org.hibernate.mapping.Component

isKey() - Method in class org.hibernate.tuple.component.ComponentMetamodel

isLast() - Method in interface org.hibernate.ScrollableResults
Is this the last result?
isLast() - Method in class org.hibernate.impl.FetchingScrollableResultsImpl
Is this the last result?
isLast() - Method in class org.hibernate.impl.ScrollableResultsImpl

isLast() - Method in class org.hibernate.jdbc.ResultSetWrapper

isLazy() - Method in class org.hibernate.mapping.Collection

isLazy() - Method in interface org.hibernate.mapping.Fetchable

isLazy() - Method in class org.hibernate.mapping.Join

isLazy() - Method in class org.hibernate.mapping.PersistentClass

isLazy() - Method in class org.hibernate.mapping.Property

isLazy() - Method in class org.hibernate.mapping.ToOne

isLazy() - Method in interface org.hibernate.metadata.CollectionMetadata
Is the collection lazily initialized?
isLazy() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isLazy() - Method in interface org.hibernate.persister.collection.CollectionPersister
Is this collection lazyily initialized?
isLazy() - Method in class org.hibernate.tuple.StandardProperty

isLazy() - Method in class org.hibernate.tuple.entity.EntityMetamodel

isLazyPropertiesCacheable() - Method in class org.hibernate.mapping.PersistentClass

isLazyPropertiesCacheable() - Method in class org.hibernate.mapping.RootClass

isLazyPropertiesCacheable() - Method in class org.hibernate.mapping.Subclass

isLazyPropertiesCacheable() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isLazyPropertiesCacheable() - Method in interface org.hibernate.persister.entity.EntityPersister
Should lazy properties of this entity be cached?
isLifecycleImplementor() - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

isLifecycleImplementor() - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Does the class managed by this tuplizer implement the Lifecycle interface.
isLifecycleImplementor() - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

isList() - Method in class org.hibernate.hql.ast.tree.ConstructorNode

isList() - Method in class org.hibernate.hql.ast.tree.SelectClause

isList() - Method in class org.hibernate.mapping.IndexedCollection

isList() - Method in class org.hibernate.mapping.List

isLoadedWithLazyPropertiesUnfetched() - Method in class org.hibernate.engine.EntityEntry

isLock() - Method in class org.hibernate.cache.ReadWriteCache.Item
Not a lock!
isLock() - Method in class org.hibernate.cache.ReadWriteCache.Lock
Yes, this is a lock
isLock() - Method in interface org.hibernate.cache.ReadWriteCache.Lockable

isLookupByNaturalKey() - Method in class org.hibernate.impl.CriteriaImpl

isManipulationStatement() - Method in interface org.hibernate.hql.QueryTranslator

isManipulationStatement() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

isManipulationStatement() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

isManualFlushMode(FlushMode) - Static method in class org.hibernate.FlushMode

isManyToMany() - Method in class org.hibernate.hql.ast.tree.FromElement

isManyToMany() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isManyToMany() - Method in class org.hibernate.persister.collection.BasicCollectionPersister

isManyToMany() - Method in interface org.hibernate.persister.collection.CollectionPersister
Is this a many-to-many association? Note that this is mainly a convenience feature as the single persister does not conatin all the information needed to handle a many-to-many itself, as internally it is looked at as two many-to-ones.
isManyToMany() - Method in class org.hibernate.persister.collection.OneToManyPersister

isManyToManyWith(OuterJoinableAssociation) - Method in class org.hibernate.loader.OuterJoinableAssociation

isMap() - Method in class org.hibernate.hql.ast.tree.ConstructorNode

isMap() - Method in class org.hibernate.hql.ast.tree.SelectClause

isMap() - Method in class org.hibernate.mapping.Collection

isMap() - Method in class org.hibernate.mapping.Map

isMarkedForRollback(int) - Static method in class org.hibernate.util.JTAHelper

isMarkedForRollback(Transaction) - Static method in class org.hibernate.util.JTAHelper

isMethodOf(Method) - Method in class org.hibernate.tuple.component.AbstractComponentTuplizer

isMethodOf(Method) - Method in interface org.hibernate.tuple.component.ComponentTuplizer
Is the given method available via the managed component as a property getter?
isMethodOf(Method) - Method in class org.hibernate.tuple.component.PojoComponentTuplizer

isMethodOf(Method) - Method in interface org.hibernate.type.AbstractComponentType

isMethodOf(Method) - Method in class org.hibernate.type.AnyType

isMethodOf(Method) - Method in class org.hibernate.type.ComponentType

isMethodOf(Method) - Method in class org.hibernate.type.CompositeCustomType

isMethodOf(Method) - Method in class org.hibernate.type.EmbeddedComponentType

isMinimalPutsEnabled() - Method in class org.hibernate.cfg.Settings

isMinimalPutsEnabledByDefault() - Method in interface org.hibernate.cache.CacheProvider

isMinimalPutsEnabledByDefault() - Method in class org.hibernate.cache.EhCacheProvider

isMinimalPutsEnabledByDefault() - Method in class org.hibernate.cache.HashtableCacheProvider

isMinimalPutsEnabledByDefault() - Method in class org.hibernate.cache.JndiBoundTreeCacheProvider
By default, should minimal-puts mode be enabled when using this cache.
isMinimalPutsEnabledByDefault() - Method in class org.hibernate.cache.NoCacheProvider

isMinimalPutsEnabledByDefault() - Method in class org.hibernate.cache.OSCacheProvider

isMinimalPutsEnabledByDefault() - Method in class org.hibernate.cache.OptimisticTreeCacheProvider

isMinimalPutsEnabledByDefault() - Method in class org.hibernate.cache.SwarmCacheProvider

isMinimalPutsEnabledByDefault() - Method in class org.hibernate.cache.TreeCacheProvider

isModified(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.AbstractType

isModified(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.AnyType

isModified(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.CollectionType

isModified(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.ComponentType

isModified(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.ManyToOneType

isModified(Object, Object, boolean[], SessionImplementor) - Method in class org.hibernate.type.OneToOneType

isModified(Object, Object, boolean[], SessionImplementor) - Method in interface org.hibernate.type.Type
Has the parent object been modified, compared to the current database state?
isMultiTable() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isMultiTable() - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

isMultiTable() - Method in interface org.hibernate.persister.entity.Queryable
Is the inheritence hierarchy described by this persister contained across multiple tables?
isMultiTable() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

isMultiTable() - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

isMultiValued() - Method in class org.hibernate.mapping.MetaAttribute

isMutable() - Method in class org.hibernate.mapping.Collection

isMutable() - Method in class org.hibernate.mapping.PersistentClass

isMutable() - Method in class org.hibernate.mapping.RootClass

isMutable() - Method in class org.hibernate.mapping.Subclass

isMutable() - Method in interface org.hibernate.metadata.ClassMetadata
Are instances of this class mutable?
isMutable() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isMutable() - Method in interface org.hibernate.persister.collection.CollectionPersister
Can the elements of this collection change?
isMutable() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isMutable() - Method in interface org.hibernate.persister.entity.EntityPersister
Are instances of this class mutable.
isMutable() - Method in class org.hibernate.tuple.entity.EntityMetamodel

isMutable() - Method in class org.hibernate.type.AnyType

isMutable() - Method in class org.hibernate.type.BlobType

isMutable() - Method in class org.hibernate.type.ClobType

isMutable() - Method in class org.hibernate.type.CollectionType

isMutable() - Method in class org.hibernate.type.ComponentType

isMutable() - Method in class org.hibernate.type.CompositeCustomType

isMutable() - Method in class org.hibernate.type.CustomType

isMutable() - Method in class org.hibernate.type.EntityType

isMutable() - Method in class org.hibernate.type.ImmutableType

isMutable() - Method in class org.hibernate.type.MetaType

isMutable() - Method in class org.hibernate.type.MutableType

isMutable() - Method in interface org.hibernate.type.Type
Are objects of this type mutable.
isMutable() - Method in interface org.hibernate.usertype.CompositeUserType
Check if objects of this type mutable.
isMutable() - Method in interface org.hibernate.usertype.UserType
Are objects of this type mutable?
isNakedEntityReturned() - Method in class org.hibernate.event.LoadEventListener.LoadType

isNaturalIdentifier() - Method in class org.hibernate.mapping.Property

isNaturalKeyLookup() - Method in class org.hibernate.engine.QueryParameters

isNestedThrowable(Throwable) - Static method in class org.hibernate.exception.ExceptionUtils
Checks whether this Throwable class can store a cause.
isNonQualifiedPropertyRef(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

isNonQualifiedPropertyRef(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

isNotEmbedded(SessionImplementor) - Method in class org.hibernate.type.EntityType

isNotEmpty() - Method in class org.hibernate.criterion.Property

isNotEmpty(String) - Static method in class org.hibernate.criterion.Restrictions
Constrain a collection valued property to be non-empty
isNotEmpty(String) - Static method in class org.hibernate.util.StringHelper

isNotNull() - Method in class org.hibernate.criterion.Property

isNotNull(String) - Static method in class org.hibernate.criterion.Restrictions
Apply an "is not null" constraint to the named property
isNotTransient(String, Object, Boolean, SessionImplementor) - Static method in class org.hibernate.engine.ForeignKeys
Is this instance persistent or detached? If assumed is non-null, don't hit the database to make the determination, instead assume that value; the client code must be prepared to "recover" in the case that this assumed result is incorrect.
isNull() - Method in class org.hibernate.criterion.Property

isNull(String) - Static method in class org.hibernate.criterion.Restrictions
Apply an "is null" constraint to the named property
isNull(Object, SessionImplementor) - Method in class org.hibernate.type.EntityType

isNull(Object, SessionImplementor) - Method in class org.hibernate.type.OneToOneType

isNullable() - Method in class org.hibernate.mapping.Collection

isNullable() - Method in class org.hibernate.mapping.Column

isNullable() - Method in class org.hibernate.mapping.DependantValue

isNullable() - Method in class org.hibernate.mapping.OneToMany

isNullable() - Method in class org.hibernate.mapping.OneToOne

isNullable() - Method in class org.hibernate.mapping.SimpleValue

isNullable() - Method in interface org.hibernate.mapping.Value

isNullable() - Method in class org.hibernate.tuple.StandardProperty

isNullable() - Method in class org.hibernate.type.EntityType

isNullable() - Method in class org.hibernate.type.ManyToOneType

isNullable() - Method in class org.hibernate.type.OneToOneType

isNullableSubclassTable(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isNullableSubclassTable(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

isNullableTable(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isNullableTable(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

isNullifiable(boolean, SessionImplementor) - Method in class org.hibernate.engine.EntityEntry

isOneToMany() - Method in class org.hibernate.mapping.Collection

isOneToMany() - Method in class org.hibernate.persister.collection.BasicCollectionPersister

isOneToMany() - Method in interface org.hibernate.persister.collection.CollectionPersister
Is this a one-to-many association?
isOneToMany() - Method in class org.hibernate.persister.collection.OneToManyPersister

isOneToOne() - Method in class org.hibernate.type.EntityType

isOneToOne() - Method in class org.hibernate.type.ManyToOneType

isOneToOne() - Method in class org.hibernate.type.OneToOneType

isOpen() - Method in interface org.hibernate.Session
Check if the Session is still open.
isOpen() - Method in interface org.hibernate.engine.SessionImplementor

isOpen() - Method in class org.hibernate.impl.SessionImpl

isOpen() - Method in class org.hibernate.impl.StatelessSessionImpl

isOperationQueueEnabled() - Method in class org.hibernate.collection.AbstractPersistentCollection
Is this collection in a state that would allow us to "queue" operations?
isOptimisticLocked() - Method in class org.hibernate.mapping.Collection

isOptimisticLocked() - Method in class org.hibernate.mapping.Property

isOptional() - Method in class org.hibernate.mapping.Join

isOptional() - Method in class org.hibernate.mapping.Property

isOrderUpdatesEnabled() - Method in class org.hibernate.cfg.Settings

isOwnerUnchanged(PersistentCollection, CollectionPersister, Serializable) - Static method in class org.hibernate.event.def.ProxyVisitor
Has the owner of the collection changed since the collection was snapshotted and detached?
isPhysicalConstraint() - Method in class org.hibernate.mapping.ForeignKey

isPhysicalTable() - Method in class org.hibernate.mapping.Table

isPolymorphic() - Method in class org.hibernate.mapping.PersistentClass

isPolymorphic() - Method in class org.hibernate.mapping.RootClass

isPolymorphic() - Method in class org.hibernate.mapping.Subclass

isPolymorphic() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isPolymorphic() - Method in class org.hibernate.tuple.entity.EntityMetamodel

isPossibleID() - Method in class org.hibernate.hql.ast.HqlToken
Returns true if the token could be an identifier.
isPrimitive(Class) - Method in class org.hibernate.mapping.Property

isPrimitiveArray() - Method in class org.hibernate.mapping.Collection

isPrimitiveArray() - Method in class org.hibernate.mapping.PrimitiveArray

isPrimitiveArray() - Method in interface org.hibernate.metadata.CollectionMetadata
Is the collection a primitive array?
isPrimitiveArray() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isPrimitiveArray() - Method in interface org.hibernate.persister.collection.CollectionPersister
Is this an array or primitive values?
isProcessed() - Method in class org.hibernate.engine.CollectionEntry

isPropertyInitialized(Object, String) - Static method in class org.hibernate.Hibernate
Check if the property is initialized.
isPropertyNull(EntityKey, String) - Method in interface org.hibernate.engine.PersistenceContext
Is the association property belonging to the keyed entity null?
isPropertyNull(EntityKey, String) - Method in class org.hibernate.engine.StatefulPersistenceContext
Is the association property belonging to the keyed entity null?
isPropertyOfTable(int, int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isPropertyOfTable(int, int) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

isPropertyOfTable(int, int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

isPropertyOfTable(int, int) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

isPublic(Class, Member) - Static method in class org.hibernate.util.ReflectHelper

isPutEnabled() - Method in class org.hibernate.CacheMode

isPutQueueEnabled() - Method in class org.hibernate.collection.AbstractPersistentCollection
Is this collection in a state that would allow us to "queue" puts? This is a special case, because of orphan delete.
isPuttable(long, Object, Comparator) - Method in class org.hibernate.cache.ReadWriteCache.Item
Don't overwite already cached items
isPuttable(long, Object, Comparator) - Method in class org.hibernate.cache.ReadWriteCache.Lock
Can the timestamped transaction re-cache this locked item now?
isPuttable(long, Object, Comparator) - Method in interface org.hibernate.cache.ReadWriteCache.Lockable

isQueryCacheEnabled() - Method in class org.hibernate.cfg.Settings

isQuoted() - Method in class org.hibernate.mapping.Column

isQuoted() - Method in class org.hibernate.mapping.Table

isReached() - Method in class org.hibernate.engine.CollectionEntry

isReadOnly() - Method in class org.hibernate.engine.NamedQueryDefinition

isReadOnly() - Method in class org.hibernate.engine.QueryParameters

isReadOnly() - Method in class org.hibernate.impl.AbstractQueryImpl

isReadOnly() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

isReadOnly() - Method in class org.hibernate.tuple.ElementWrapper

isReadyForSerialization() - Method in class org.hibernate.jdbc.ConnectionManager

isReferenceToPrimaryKey() - Method in class org.hibernate.mapping.ForeignKey
Does this foreignkey reference the primary key of the reference table
isReferenceToPrimaryKey() - Method in class org.hibernate.type.AnyType

isReferenceToPrimaryKey() - Method in class org.hibernate.type.EntityType
Does this association foreign key reference the primary key of the other table?
isRequired() - Method in class org.hibernate.hql.HolderInstantiator

isResolved() - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

isReturnableEntity() - Method in class org.hibernate.hql.ast.tree.AbstractSelectExpression

isReturnableEntity() - Method in class org.hibernate.hql.ast.tree.ConstructorNode

isReturnableEntity() - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

isReturnableEntity() - Method in class org.hibernate.hql.ast.tree.QueryNode

isReturnableEntity() - Method in interface org.hibernate.hql.ast.tree.SelectExpression
Returns true if this select expression represents an entity that can be returned.
isRollback(int) - Static method in class org.hibernate.util.JTAHelper

isRootElement() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

isRootElement() - Method in class org.hibernate.tuple.ElementWrapper

isRowDeleteEnabled() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isRowDeleteEnabled() - Method in class org.hibernate.persister.collection.OneToManyPersister

isRowInsertEnabled() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isRowInsertEnabled() - Method in class org.hibernate.persister.collection.OneToManyPersister

isRowUpdatePossible() - Method in class org.hibernate.collection.AbstractPersistentCollection

isRowUpdatePossible() - Method in class org.hibernate.collection.PersistentBag

isRowUpdatePossible() - Method in interface org.hibernate.collection.PersistentCollection

isRowUpdatePossible() - Method in class org.hibernate.collection.PersistentSet

isSame(Object, Object, EntityMode) - Method in class org.hibernate.type.AbstractType

isSame(Object, Object, EntityMode) - Method in class org.hibernate.type.AnyType

isSame(Object, Object, EntityMode) - Method in class org.hibernate.type.ComponentType

isSame(Object, Object, EntityMode) - Method in class org.hibernate.type.EntityType

isSame(Object, Object, EntityMode) - Method in interface org.hibernate.type.Type
Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.
isScalar() - Method in class org.hibernate.hql.ast.tree.AbstractSelectExpression

isScalar() - Method in class org.hibernate.hql.ast.tree.ConstructorNode

isScalar() - Method in class org.hibernate.hql.ast.tree.MethodNode

isScalar() - Method in class org.hibernate.hql.ast.tree.QueryNode

isScalar() - Method in interface org.hibernate.hql.ast.tree.SelectExpression

isScalarSelect() - Method in class org.hibernate.hql.ast.tree.SelectClause
Does this SelectClause represent a scalar query
isSchemaQuoted() - Method in class org.hibernate.mapping.Table

isScrollableResultSetsEnabled() - Method in class org.hibernate.cfg.Settings

isSecondLevelCacheEnabled() - Method in class org.hibernate.cfg.Settings

isSelectBeforeUpdate() - Method in class org.hibernate.tuple.entity.EntityMetamodel

isSelectBeforeUpdateRequired() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isSelectBeforeUpdateRequired() - Method in interface org.hibernate.persister.entity.EntityPersister
Is select snapshot before update enabled?
isSelectStatement() - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

isSelectable() - Method in class org.hibernate.mapping.Property

isSequence(Object) - Method in class org.hibernate.tool.hbm2ddl.DatabaseMetadata

isSequentialSelect() - Method in class org.hibernate.mapping.Join

isSet() - Method in class org.hibernate.mapping.Collection

isSet() - Method in class org.hibernate.mapping.Set

isShallow() - Method in class org.hibernate.engine.query.HQLQueryPlan

isShallowQuery() - Method in class org.hibernate.hql.ast.HqlSqlWalker

isShallowQuery() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

isShowClassNames() - Method in class org.hibernate.hql.ast.util.ASTPrinter
Returns true if the node class names will be displayed.
isShowSqlEnabled() - Method in class org.hibernate.cfg.Settings

isSimpleValue() - Method in class org.hibernate.mapping.Collection

isSimpleValue() - Method in class org.hibernate.mapping.OneToMany

isSimpleValue() - Method in class org.hibernate.mapping.SimpleValue

isSimpleValue() - Method in interface org.hibernate.mapping.Value

isSingleRowLoader() - Method in class org.hibernate.loader.Loader
Return false is this loader is a batch entity loader
isSingleRowLoader() - Method in class org.hibernate.loader.entity.AbstractEntityLoader

isSingleRowLoader() - Method in class org.hibernate.loader.entity.CollectionElementLoader

isSingleRowLoader() - Method in class org.hibernate.loader.entity.EntityLoader

isSnapshotEmpty(Serializable) - Method in class org.hibernate.collection.PersistentArrayHolder

isSnapshotEmpty(Serializable) - Method in class org.hibernate.collection.PersistentBag

isSnapshotEmpty(Serializable) - Method in interface org.hibernate.collection.PersistentCollection
Is the snapshot empty?
isSnapshotEmpty(Serializable) - Method in class org.hibernate.collection.PersistentElementHolder

isSnapshotEmpty(Serializable) - Method in class org.hibernate.collection.PersistentIdentifierBag

isSnapshotEmpty(Serializable) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

isSnapshotEmpty(Serializable) - Method in class org.hibernate.collection.PersistentList

isSnapshotEmpty(Serializable) - Method in class org.hibernate.collection.PersistentMap

isSnapshotEmpty(Serializable) - Method in class org.hibernate.collection.PersistentSet

isSnapshotEmpty(PersistentCollection) - Method in class org.hibernate.engine.CollectionEntry

isSorted() - Method in class org.hibernate.mapping.Collection

isStateless() - Method in interface org.hibernate.engine.PersistenceContext

isStateless() - Method in class org.hibernate.engine.StatefulPersistenceContext

isStatisticsEnabled() - Method in class org.hibernate.cfg.Settings

isStatisticsEnabled() - Method in class org.hibernate.jmx.StatisticsService

isStatisticsEnabled() - Method in interface org.hibernate.stat.Statistics
Are statistics logged
isStatisticsEnabled() - Method in class org.hibernate.stat.StatisticsImpl
Are statistics logged
isStrictJPAQLCompliance() - Method in class org.hibernate.cfg.Settings

isStrictJPAQLComplianceEnabled() - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper

isStructuredCacheEntriesEnabled() - Method in class org.hibernate.cfg.Settings

isSubQuery() - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

isSubQuery() - Method in class org.hibernate.hql.ast.tree.FromClause

isSubclassEntityName(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isSubclassEntityName(String) - Method in interface org.hibernate.persister.entity.EntityPersister
Is the given entity name the name of a subclass, or this class?
isSubclassPropertyDeferred(String, String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isSubclassPropertyDeferred(String, String) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

isSubclassPropertyNullable(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isSubclassPropertyNullable(int) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
Is the numbered property of the class of subclass nullable?
isSubclassTableLazy(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isSubclassTableLazy(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

isSubclassTableSequentialSelect(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isSubclassTableSequentialSelect(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

isSubselect() - Method in class org.hibernate.mapping.Table

isSubselectLoadable() - Method in class org.hibernate.mapping.Collection

isSubselectLoadable() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isSubselectLoadingEnabled() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

isSubselectLoadingEnabled() - Method in class org.hibernate.loader.Loader

isSubselectLoadingEnabled() - Method in class org.hibernate.loader.collection.CollectionLoader

isSubselectLoadingEnabled() - Method in class org.hibernate.loader.criteria.CriteriaLoader

isSubselectLoadingEnabled() - Method in class org.hibernate.loader.hql.QueryLoader

isSubtreeChild(AST, AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil
Determine if a given node (test) is contained anywhere in the subtree of another given node (fixture).
isSuppliedConnection() - Method in class org.hibernate.jdbc.ConnectionManager
Was the connection being used here supplied by the user?
isTable(Object) - Method in class org.hibernate.tool.hbm2ddl.DatabaseMetadata

isTableCascadeDeleteEnabled(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isTableCascadeDeleteEnabled(int) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

isTableCascadeDeleteEnabled(int) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

isTableCascadeDeleteEnabled(int) - Method in class org.hibernate.persister.entity.UnionSubclassEntityPersister

isTextOnly() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

isTextOnly() - Method in class org.hibernate.tuple.ElementWrapper

isThetaStyle() - Method in class org.hibernate.engine.JoinSequence

isThrowableNested() - Static method in class org.hibernate.exception.ExceptionUtils
Checks if the Throwable class has a getCause method.
isTooDeep(int) - Method in class org.hibernate.loader.JoinWalker

isTooManyCollections() - Method in class org.hibernate.loader.JoinWalker

isTooManyCollections() - Method in class org.hibernate.loader.entity.CascadeEntityJoinWalker

isTransactionInProgress() - Method in interface org.hibernate.engine.SessionImplementor
Does this Session have an active Hibernate transaction or is there a JTA transaction in progress?
isTransactionInProgress() - Method in class org.hibernate.impl.SessionImpl

isTransactionInProgress() - Method in class org.hibernate.impl.StatelessSessionImpl

isTransactionInProgress() - Method in interface org.hibernate.jdbc.ConnectionManager.Callback

isTransactionInProgress() - Method in class org.hibernate.jdbc.JDBCContext

isTransactionInProgress(JDBCContext, TransactionFactory.Context, Transaction) - Method in class org.hibernate.transaction.CMTTransactionFactory

isTransactionInProgress(JDBCContext, TransactionFactory.Context, Transaction) - Method in class org.hibernate.transaction.JDBCTransactionFactory

isTransactionInProgress(JDBCContext, TransactionFactory.Context, Transaction) - Method in class org.hibernate.transaction.JTATransactionFactory

isTransactionInProgress(JDBCContext, TransactionFactory.Context, Transaction) - Method in interface org.hibernate.transaction.TransactionFactory
Determine whether an underlying transaction is in progress.
isTransactionInProgress(SessionFactoryImplementor) - Static method in class org.hibernate.util.JTAHelper
Return true if a JTA transaction is in progress and false in *every* other cases (including in a JDBC transaction).
isTransactionInProgress(Transaction) - Static method in class org.hibernate.util.JTAHelper

isTransactionManagerRequired() - Method in class org.hibernate.transaction.CMTTransactionFactory

isTransactionManagerRequired() - Method in class org.hibernate.transaction.JDBCTransactionFactory

isTransactionManagerRequired() - Method in class org.hibernate.transaction.JTATransactionFactory

isTransactionManagerRequired() - Method in interface org.hibernate.transaction.TransactionFactory
Do we require access to the JTA TransactionManager for this strategy?
isTransient(Object) - Method in class org.hibernate.EmptyInterceptor

isTransient(Object) - Method in interface org.hibernate.Interceptor
Called to distinguish between transient and detached entities.
isTransient(String, Object, Boolean, SessionImplementor) - Static method in class org.hibernate.engine.ForeignKeys
Is this instance, which we know is not persistent, actually transient? If assumed is non-null, don't hit the database to make the determination, instead assume that value; the client code must be prepared to "recover" in the case that this assumed result is incorrect.
isTransient(Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isTransient(Object, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Is this a new transient instance?
isTypeSpecified() - Method in class org.hibernate.mapping.SimpleValue

isTypeSpecified() - Method in class org.hibernate.mapping.ToOne

isUninitialized() - Method in class org.hibernate.proxy.AbstractLazyInitializer

isUninitialized() - Method in interface org.hibernate.proxy.LazyInitializer
Is the proxy uninitialzed?
isUnique() - Method in class org.hibernate.mapping.Column

isUnreferenced() - Method in class org.hibernate.collection.AbstractPersistentCollection

isUnreferenced() - Method in interface org.hibernate.collection.PersistentCollection
Is the collection unreferenced?
isUnsaved(Serializable) - Method in class org.hibernate.engine.IdentifierValue
Does the given identifier belong to a new instance?
isUnsaved(Object) - Method in class org.hibernate.engine.VersionValue
Does the given version belong to a new instance?
isUnwrap() - Method in class org.hibernate.proxy.AbstractLazyInitializer

isUnwrap() - Method in interface org.hibernate.proxy.LazyInitializer

isUnwrapProxy() - Method in class org.hibernate.mapping.ToOne

isUpToDate(Set, Long) - Method in class org.hibernate.cache.StandardQueryCache

isUpToDate(Set, Long) - Method in class org.hibernate.cache.UpdateTimestampsCache

isUpdateCallable() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isUpdateCallable(int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isUpdateGenerated() - Method in class org.hibernate.tuple.StandardProperty

isUpdateNecessary(FlushEntityEvent) - Method in class org.hibernate.event.def.DefaultFlushEntityEventListener
Performs all necessary checking to determine if an entity needs an SQL update to synchronize its state to the database.
isUpdateable() - Method in class org.hibernate.mapping.DependantValue

isUpdateable() - Method in interface org.hibernate.mapping.KeyValue

isUpdateable() - Method in class org.hibernate.mapping.Property

isUpdateable() - Method in class org.hibernate.mapping.SimpleValue

isUpdateable() - Method in class org.hibernate.tuple.StandardProperty

isValid(Mapping) - Method in class org.hibernate.mapping.Collection

isValid(Mapping) - Method in class org.hibernate.mapping.OneToMany

isValid(Mapping) - Method in class org.hibernate.mapping.Property

isValid(Mapping) - Method in class org.hibernate.mapping.SimpleValue

isValid(Mapping) - Method in class org.hibernate.mapping.ToOne

isValid(Mapping) - Method in interface org.hibernate.mapping.Value

isValidatableImplementor() - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

isValidatableImplementor() - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Does the class managed by this tuplizer implement the Validatable interface.
isValidatableImplementor() - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

isVerbose() - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

isVersionIncrementDisabled() - Method in class org.hibernate.event.def.AbstractSaveEventListener
After the save, will te version number be incremented if the instance is modified?
isVersionIncrementDisabled() - Method in class org.hibernate.event.def.DefaultReplicateEventListener

isVersionIncrementRequired(int[], boolean, boolean[]) - Static method in class org.hibernate.engine.Versioning
Do we need to increment the version number, given the dirty properties?
isVersionPropertyGenerated() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isVersionPropertyGenerated() - Method in interface org.hibernate.persister.entity.EntityPersister
Does this entity contain a version property that is defined to be database generated?
isVersionPropertyInsertable() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isVersionPropertyInsertable() - Method in interface org.hibernate.persister.entity.Queryable
Is the version property included in insert statements?
isVersionable() - Method in class org.hibernate.tuple.StandardProperty

isVersioned() - Method in interface org.hibernate.cache.OptimisticCacheSource
Does this source represent versioned (i.e., and thus optimistically lockable) data?
isVersioned() - Method in class org.hibernate.mapping.PersistentClass

isVersioned() - Method in class org.hibernate.mapping.RootClass

isVersioned() - Method in class org.hibernate.mapping.Subclass

isVersioned() - Method in interface org.hibernate.metadata.ClassMetadata
Are instances of this class versioned by a timestamp or version number column?
isVersioned() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

isVersioned() - Method in interface org.hibernate.persister.collection.CollectionPersister
Does this collection cause version increment of the owning entity?
isVersioned() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

isVersioned() - Method in interface org.hibernate.persister.entity.EntityPersister
Are instances of this class versioned by a timestamp or version number column.
isVersioned() - Method in class org.hibernate.tuple.entity.EntityMetamodel

isVirtual() - Method in class org.hibernate.tuple.IdentifierProperty

isWhitespace(String) - Static method in class org.hibernate.hql.classic.ParserHelper

isWrapResultSetsEnabled() - Method in class org.hibernate.cfg.Settings

isWrapper(Object) - Method in class org.hibernate.collection.PersistentArrayHolder

isWrapper(Object) - Method in class org.hibernate.collection.PersistentBag

isWrapper(Object) - Method in interface org.hibernate.collection.PersistentCollection
Is this the wrapper for the given underlying collection instance?
isWrapper(Object) - Method in class org.hibernate.collection.PersistentElementHolder

isWrapper(Object) - Method in class org.hibernate.collection.PersistentIdentifierBag

isWrapper(Object) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

isWrapper(Object) - Method in class org.hibernate.collection.PersistentList

isWrapper(Object) - Method in class org.hibernate.collection.PersistentMap

isWrapper(Object) - Method in class org.hibernate.collection.PersistentSet

isXMLElement() - Method in class org.hibernate.type.AbstractType

isXMLElement() - Method in class org.hibernate.type.CollectionType

isXMLElement() - Method in class org.hibernate.type.ComponentType

isXMLElement() - Method in class org.hibernate.type.EntityType

isXMLElement() - Method in interface org.hibernate.type.Type

isolationLevelToString(int) - Static method in class org.hibernate.cfg.Environment
Get the name of a JDBC transaction isolation level
iterate() - Method in interface org.hibernate.Query
Return the query results as an Iterator.
iterate(String) - Method in interface org.hibernate.classic.Session
Deprecated. use Session.createQuery(java.lang.String).Query.iterate()
iterate(String, Object, Type) - Method in interface org.hibernate.classic.Session
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.iterate()
iterate(String, Object[], Type[]) - Method in interface org.hibernate.classic.Session
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.iterate()
iterate(String, QueryParameters) - Method in interface org.hibernate.engine.SessionImplementor
Execute an iterate() query
iterate(QueryParameters, EventSource) - Method in interface org.hibernate.hql.QueryTranslator
Perform an iterate operation given the underlying query defintion.
iterate(QueryParameters, EventSource) - Method in class org.hibernate.hql.ast.QueryTranslatorImpl
Return the query results as an iterator
iterate(QueryParameters, EventSource) - Method in class org.hibernate.hql.classic.QueryTranslatorImpl
Return the query results as an iterator
iterate() - Method in class org.hibernate.impl.CollectionFilterImpl

iterate() - Method in class org.hibernate.impl.QueryImpl

iterate() - Method in class org.hibernate.impl.SQLQueryImpl

iterate(String) - Method in class org.hibernate.impl.SessionImpl

iterate(String, Object, Type) - Method in class org.hibernate.impl.SessionImpl

iterate(String, Object[], Type[]) - Method in class org.hibernate.impl.SessionImpl

iterate(String, QueryParameters) - Method in class org.hibernate.impl.SessionImpl

iterate(String, QueryParameters) - Method in class org.hibernate.impl.StatelessSessionImpl

iterate(QueryParameters, EventSource) - Method in class org.hibernate.loader.hql.QueryLoader
Return the query results as an iterator
iterateCollections() - Method in class org.hibernate.cfg.Mappings

iterateExpressionEntries() - Method in class org.hibernate.impl.CriteriaImpl

iterateFilter(Object, String, QueryParameters) - Method in interface org.hibernate.engine.SessionImplementor
Iterate a filter
iterateFilter(Object, String, QueryParameters) - Method in class org.hibernate.impl.SessionImpl

iterateFilter(Object, String, QueryParameters) - Method in class org.hibernate.impl.StatelessSessionImpl

iterateOrderings() - Method in class org.hibernate.impl.CriteriaImpl

iterateSubcriteria() - Method in class org.hibernate.impl.CriteriaImpl

iterateTables() - Method in class org.hibernate.cfg.Mappings

iterator() - Method in class org.hibernate.collection.PersistentBag

iterator() - Method in class org.hibernate.collection.PersistentIdentifierBag

iterator() - Method in class org.hibernate.collection.PersistentList

iterator() - Method in class org.hibernate.collection.PersistentSet

iterator() - Method in class org.hibernate.util.IdentitySet

J

JACCConfiguration - class org.hibernate.secure.JACCConfiguration.
Adds Hibernate permissions to roles via JACC
JACCConfiguration(String) - Constructor for class org.hibernate.secure.JACCConfiguration

JACCPermissions - class org.hibernate.secure.JACCPermissions.
Copied from JBoss org.jboss.ejb3.security.JaccHelper and org.jboss.ejb3.security.SecurityActions
JACCPermissions() - Constructor for class org.hibernate.secure.JACCPermissions

JACCPreDeleteEventListener - class org.hibernate.secure.JACCPreDeleteEventListener.
Check security before any deletion
JACCPreDeleteEventListener() - Constructor for class org.hibernate.secure.JACCPreDeleteEventListener

JACCPreInsertEventListener - class org.hibernate.secure.JACCPreInsertEventListener.
Check security before an insertion
JACCPreInsertEventListener() - Constructor for class org.hibernate.secure.JACCPreInsertEventListener

JACCPreLoadEventListener - class org.hibernate.secure.JACCPreLoadEventListener.
Check security before any load
JACCPreLoadEventListener() - Constructor for class org.hibernate.secure.JACCPreLoadEventListener

JACCPreUpdateEventListener - class org.hibernate.secure.JACCPreUpdateEventListener.
Check security before any update
JACCPreUpdateEventListener() - Constructor for class org.hibernate.secure.JACCPreUpdateEventListener

JACCSecurityListener - interface org.hibernate.secure.JACCSecurityListener.
Marker interface for JACC event listeners
JACC_CONTEXTID - Static variable in class org.hibernate.cfg.Environment
The jacc context id of the deployment
JAVA_CONSTANT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

JAVA_CONSTANT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

JAVA_CONSTANT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

JBossTransactionManagerLookup - class org.hibernate.transaction.JBossTransactionManagerLookup.
A TransactionManager lookup strategy for JBoss
JBossTransactionManagerLookup() - Constructor for class org.hibernate.transaction.JBossTransactionManagerLookup

JDBCConnectionException - exception org.hibernate.exception.JDBCConnectionException.
Implementation of JDBCException indicating problems with communicating with the database (can also include incorrect JDBC setup).
JDBCConnectionException(String, SQLException) - Constructor for class org.hibernate.exception.JDBCConnectionException

JDBCConnectionException(String, SQLException, String) - Constructor for class org.hibernate.exception.JDBCConnectionException

JDBCContext - class org.hibernate.jdbc.JDBCContext.
Acts as the mediary between "entity-mode related" sessions in terms of their interaction with the JDBC data store.
JDBCContext(JDBCContext.Context, Connection, Interceptor) - Constructor for class org.hibernate.jdbc.JDBCContext

JDBCContext.Context - interface org.hibernate.jdbc.JDBCContext.Context.

JDBCException - exception org.hibernate.JDBCException.
Wraps an SQLException.
JDBCException(String, SQLException) - Constructor for class org.hibernate.JDBCException

JDBCException(String, SQLException, String) - Constructor for class org.hibernate.JDBCException

JDBCExceptionHelper - class org.hibernate.exception.JDBCExceptionHelper.
Implementation of JDBCExceptionHelper.
JDBCExceptionReporter - class org.hibernate.util.JDBCExceptionReporter.

JDBCTransaction - class org.hibernate.transaction.JDBCTransaction.
Implements a basic transaction strategy for JDBC connections.This is the default Transaction implementation used if none is explicitly specified.
JDBCTransaction(JDBCContext, TransactionFactory.Context) - Constructor for class org.hibernate.transaction.JDBCTransaction

JDBCTransactionFactory - class org.hibernate.transaction.JDBCTransactionFactory.
Factory for JDBCTransaction.
JDBCTransactionFactory() - Constructor for class org.hibernate.transaction.JDBCTransactionFactory

JDataStoreDialect - class org.hibernate.dialect.JDataStoreDialect.
A Dialect for JDataStore.
JDataStoreDialect() - Constructor for class org.hibernate.dialect.JDataStoreDialect
Creates new JDataStoreDialect
JNDITransactionManagerLookup - class org.hibernate.transaction.JNDITransactionManagerLookup.
Locates a TransactionManager in JNDI.
JNDITransactionManagerLookup() - Constructor for class org.hibernate.transaction.JNDITransactionManagerLookup

JNDI_CLASS - Static variable in class org.hibernate.cfg.Environment
JNDI initial context class, Context.INITIAL_CONTEXT_FACTORY
JNDI_PREFIX - Static variable in class org.hibernate.cfg.Environment
prefix for arbitrary JNDI InitialContext properties
JNDI_URL - Static variable in class org.hibernate.cfg.Environment
JNDI provider URL, Context.PROVIDER_URL
JOIN - Static variable in class org.hibernate.FetchMode
Fetch using an outer join.
JOIN - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

JOIN - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

JOIN - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

JOIN_FRAGMENT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

JOIN_FRAGMENT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

JOTMTransactionManagerLookup - class org.hibernate.transaction.JOTMTransactionManagerLookup.
TransactionManager lookup strategy for JOTM
JOTMTransactionManagerLookup() - Constructor for class org.hibernate.transaction.JOTMTransactionManagerLookup

JOnASTransactionManagerLookup - class org.hibernate.transaction.JOnASTransactionManagerLookup.
TransactionManager lookup strategy for JOnAS
JOnASTransactionManagerLookup() - Constructor for class org.hibernate.transaction.JOnASTransactionManagerLookup

JPAQL_STRICT_COMPLIANCE - Static variable in class org.hibernate.cfg.Environment

JRun4TransactionManagerLookup - class org.hibernate.transaction.JRun4TransactionManagerLookup.
TransactionManager lookup strategy for JRun4
JRun4TransactionManagerLookup() - Constructor for class org.hibernate.transaction.JRun4TransactionManagerLookup

JTAHelper - class org.hibernate.util.JTAHelper.

JTASessionContext - class org.hibernate.context.JTASessionContext.
An implementation of CurrentSessionContext which scopes the notion of a current session to a JTA transaction.
JTASessionContext(SessionFactoryImplementor) - Constructor for class org.hibernate.context.JTASessionContext

JTASessionContext.CleanupSynch - class org.hibernate.context.JTASessionContext.CleanupSynch.
JTA transaction synch used for cleanup of the internal session map.
JTASessionContext.CleanupSynch(Transaction, JTASessionContext) - Constructor for class org.hibernate.context.JTASessionContext.CleanupSynch

JTATransaction - class org.hibernate.transaction.JTATransaction.
Implements a basic transaction strategy for JTA transactions.
JTATransaction(InitialContext, String, JDBCContext, TransactionFactory.Context) - Constructor for class org.hibernate.transaction.JTATransaction

JTATransactionFactory - class org.hibernate.transaction.JTATransactionFactory.
Factory for JTATransaction.
JTATransactionFactory() - Constructor for class org.hibernate.transaction.JTATransactionFactory

JavaConstantNode - class org.hibernate.hql.ast.tree.JavaConstantNode.
A node representing a static Java constant.
JavaConstantNode() - Constructor for class org.hibernate.hql.ast.tree.JavaConstantNode

JavassistClassTransformer - class org.hibernate.bytecode.javassist.JavassistClassTransformer.
Enhance the classes allowing them to implements InterceptFieldEnabled This interface is then used by Hibernate for some optimizations.
JavassistClassTransformer(ClassFilter, FieldFilter) - Constructor for class org.hibernate.bytecode.javassist.JavassistClassTransformer

JavassistHelper - class org.hibernate.intercept.javassist.JavassistHelper.

JavassistLazyInitializer - class org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer.
A Javassist-based lazy initializer proxy.
JavassistProxyFactory - class org.hibernate.proxy.pojo.javassist.JavassistProxyFactory.
A ProxyFactory implementation for producing Javassist-based proxies.
JavassistProxyFactory() - Constructor for class org.hibernate.proxy.pojo.javassist.JavassistProxyFactory

JndiBoundTreeCacheProvider - class org.hibernate.cache.JndiBoundTreeCacheProvider.
Support for JBossCache (TreeCache), where the cache instance is available via JNDI lookup.
JndiBoundTreeCacheProvider() - Constructor for class org.hibernate.cache.JndiBoundTreeCacheProvider

Join - class org.hibernate.mapping.Join.

Join() - Constructor for class org.hibernate.mapping.Join

JoinFragment - class org.hibernate.sql.JoinFragment.
An abstract SQL join fragment renderer
JoinFragment() - Constructor for class org.hibernate.sql.JoinFragment

JoinHelper - class org.hibernate.engine.JoinHelper.

JoinProcessor - class org.hibernate.hql.ast.util.JoinProcessor.
Performs the post-processing of the join information gathered during semantic analysis.
JoinProcessor(ASTFactory, QueryTranslatorImpl) - Constructor for class org.hibernate.hql.ast.util.JoinProcessor
Constructs a new JoinProcessor.
JoinSequence - class org.hibernate.engine.JoinSequence.

JoinSequence(SessionFactoryImplementor) - Constructor for class org.hibernate.engine.JoinSequence

JoinSequence.Selector - interface org.hibernate.engine.JoinSequence.Selector.

JoinWalker - class org.hibernate.loader.JoinWalker.
Walks the metamodel, searching for joins, and collecting together information needed by OuterJoinLoader.
JoinWalker(SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.JoinWalker

Joinable - interface org.hibernate.persister.entity.Joinable.
Anything that can be loaded by outer join - namely persisters for classes or collections.
JoinedIterator - class org.hibernate.util.JoinedIterator.
An JoinedIterator is an Iterator that wraps a number of Iterators.
JoinedIterator(List) - Constructor for class org.hibernate.util.JoinedIterator

JoinedIterator(Iterator[]) - Constructor for class org.hibernate.util.JoinedIterator

JoinedIterator(Iterator, Iterator) - Constructor for class org.hibernate.util.JoinedIterator

JoinedSubclass - class org.hibernate.mapping.JoinedSubclass.
A subclass in a table-per-subclass mapping
JoinedSubclass(PersistentClass) - Constructor for class org.hibernate.mapping.JoinedSubclass

JoinedSubclassEntityPersister - class org.hibernate.persister.entity.JoinedSubclassEntityPersister.
An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
JoinedSubclassEntityPersister(PersistentClass, CacheConcurrencyStrategy, SessionFactoryImplementor, Mapping) - Constructor for class org.hibernate.persister.entity.JoinedSubclassEntityPersister

Junction - class org.hibernate.criterion.Junction.
A sequence of a logical expressions combined by some associative logical operator
Junction(String) - Constructor for class org.hibernate.criterion.Junction

jdbcContext - Variable in class org.hibernate.transaction.CMTTransaction

join(String[], String[]) - Static method in class org.hibernate.util.ArrayHelper

join(String[], String[], boolean[]) - Static method in class org.hibernate.util.ArrayHelper

join(int[], int[]) - Static method in class org.hibernate.util.ArrayHelper

join(String, String[]) - Static method in class org.hibernate.util.StringHelper

join(String, Iterator) - Static method in class org.hibernate.util.StringHelper

joinElement(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

joinKeyColumnName(String, String) - Method in class org.hibernate.cfg.DefaultNamingStrategy
Return the argument
joinKeyColumnName(String, String) - Method in class org.hibernate.cfg.ImprovedNamingStrategy
Return the argument
joinKeyColumnName(String, String) - Method in interface org.hibernate.cfg.NamingStrategy
Return the join key column name ie a FK column used in a JOINED strategy or for a secondary table
joinType(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

jpaPositionalParameter(String, int) - Method in class org.hibernate.engine.query.ParamLocationRecognizer

jpaPositionalParameter(String, int) - Method in interface org.hibernate.engine.query.ParameterParser.Recognizer

jpaPositionalParameter(String, int) - Method in class org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer

jvmHasJDK14Timestamp() - Static method in class org.hibernate.cfg.Environment
Does this JVM handle Timestamp in the JDK 1.4 compliant way?
jvmHasTimestampBug() - Static method in class org.hibernate.cfg.Environment
Does this JVM have the IBM JDK 1.3.1.
jvmSupportsGetGeneratedKeys() - Static method in class org.hibernate.cfg.Environment

jvmSupportsLinkedHashCollections() - Static method in class org.hibernate.cfg.Environment
Does this JVM support LinkedHashSet, LinkedHashMap.

K

KEY - Static variable in class org.hibernate.tuple.DynamicMapInstantiator

KeyValue - interface org.hibernate.mapping.KeyValue.
Represents an identifying key of a table: the value for primary key of an entity, or a foreign key of a collection or join table or joined subclass table.
keyColumnAliases - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

keyColumnNames - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

keyIterator(Map) - Static method in class org.hibernate.util.IdentityMap

keyIterator() - Method in class org.hibernate.util.IdentityMap

keySet() - Method in class org.hibernate.collection.PersistentMap

keySet() - Method in class org.hibernate.proxy.map.MapProxy

keySet() - Method in class org.hibernate.util.FastHashMap
Return a set view of the keys contained in this map.
keySet() - Method in class org.hibernate.util.IdentityMap

L

LATEST_VERSION - Static variable in class org.hibernate.ReplicationMode
When a row already exists, choose the latest version.
LAZY - Static variable in class org.hibernate.FetchMode
Deprecated. use FetchMode.SELECT
LE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

LE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

LE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

LEADING - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

LEADING - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

LEADING - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

LEFT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

LEFT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

LEFT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

LEFT_JOIN - Static variable in interface org.hibernate.criterion.CriteriaSpecification
Specifies joining to an entity based on a left outer join.
LEFT_OUTER - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

LEFT_OUTER - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

LEFT_OUTER_JOIN - Static variable in class org.hibernate.sql.JoinFragment

LIKE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

LIKE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

LIKE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

LITERAL_ascending - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

LITERAL_ascending - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

LITERAL_ascending - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

LITERAL_by - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

LITERAL_by - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

LITERAL_by - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

LITERAL_descending - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

LITERAL_descending - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

LITERAL_descending - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

LOAD - Static variable in interface org.hibernate.event.LoadEventListener

LOADING - Static variable in class org.hibernate.engine.Status

LOCALE - Static variable in class org.hibernate.Hibernate
Hibernate locale type.
LOCK - Static variable in class org.hibernate.engine.CascadeStyle
lock
LOCK - Static variable in class org.hibernate.engine.CascadingAction

LONG - Static variable in class org.hibernate.Hibernate
Hibernate long type.
LT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

LT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

LT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

LazyInitializationException - exception org.hibernate.LazyInitializationException.
Indicates access to unfetched data outside of a session context.
LazyInitializationException(String) - Constructor for class org.hibernate.LazyInitializationException

LazyInitializer - interface org.hibernate.proxy.LazyInitializer.
Handles fetching of the underlying entity for a proxy
LazyIterator - class org.hibernate.util.LazyIterator.

LazyIterator(Map) - Constructor for class org.hibernate.util.LazyIterator

LazyPropertyInitializer - interface org.hibernate.intercept.LazyPropertyInitializer.
Contract for controlling how lazy properties get initialized.
Lifecycle - interface org.hibernate.classic.Lifecycle.
Provides callbacks from the Session to the persistent object.
LikeExpression - class org.hibernate.criterion.LikeExpression.
A criterion representing a "like" expression
LikeExpression(String, String, Character, boolean) - Constructor for class org.hibernate.criterion.LikeExpression

LikeExpression(String, String) - Constructor for class org.hibernate.criterion.LikeExpression

LikeExpression(String, String, MatchMode) - Constructor for class org.hibernate.criterion.LikeExpression

LikeExpression(String, String, MatchMode, Character, boolean) - Constructor for class org.hibernate.criterion.LikeExpression

LinkedHashCollectionHelper - class org.hibernate.util.LinkedHashCollectionHelper.

List - class org.hibernate.mapping.List.
A list mapping has a primary key consisting of the key columns + index column.
List(PersistentClass) - Constructor for class org.hibernate.mapping.List

ListType - class org.hibernate.type.ListType.

ListType(String, String, boolean) - Constructor for class org.hibernate.type.ListType

LiteralNode - class org.hibernate.hql.ast.tree.LiteralNode.
Represents a literal.
LiteralNode() - Constructor for class org.hibernate.hql.ast.tree.LiteralNode

LiteralProcessor - class org.hibernate.hql.ast.util.LiteralProcessor.
A delegate that handles literals and constants for HqlSqlWalker, performing the token replacement functions and classifying literals.
LiteralProcessor(HqlSqlWalker) - Constructor for class org.hibernate.hql.ast.util.LiteralProcessor

LiteralType - interface org.hibernate.type.LiteralType.
A type that may appear as an SQL literal
LoadEvent - class org.hibernate.event.LoadEvent.
Defines an event class for the loading of an entity.
LoadEvent(Serializable, Object, EventSource) - Constructor for class org.hibernate.event.LoadEvent

LoadEvent(Serializable, String, LockMode, EventSource) - Constructor for class org.hibernate.event.LoadEvent

LoadEvent(Serializable, String, boolean, EventSource) - Constructor for class org.hibernate.event.LoadEvent

LoadEventListener - interface org.hibernate.event.LoadEventListener.
Defines the contract for handling of load events generated from a session.
LoadEventListener.LoadType - class org.hibernate.event.LoadEventListener.LoadType.

Loadable - interface org.hibernate.persister.entity.Loadable.
Implemented by a EntityPersister that may be loaded using Loader.
Loader - class org.hibernate.loader.Loader.
Abstract superclass of object loading (and querying) strategies.
Loader(SessionFactoryImplementor) - Constructor for class org.hibernate.loader.Loader

LocaleType - class org.hibernate.type.LocaleType.
locale: A type that maps an SQL VARCHAR to a Java Locale.
LocaleType() - Constructor for class org.hibernate.type.LocaleType

LockAcquisitionException - exception org.hibernate.exception.LockAcquisitionException.
Implementation of JDBCException indicating a problem acquiring lock on the database.
LockAcquisitionException(String, SQLException) - Constructor for class org.hibernate.exception.LockAcquisitionException

LockAcquisitionException(String, SQLException, String) - Constructor for class org.hibernate.exception.LockAcquisitionException

LockEvent - class org.hibernate.event.LockEvent.
Defines an event class for the locking of an entity.
LockEvent(String, Object, LockMode, EventSource) - Constructor for class org.hibernate.event.LockEvent

LockEvent(Object, LockMode, EventSource) - Constructor for class org.hibernate.event.LockEvent

LockEventListener - interface org.hibernate.event.LockEventListener.
Defines the contract for handling of lock events generated from a session.
LockMode - class org.hibernate.LockMode.
Instances represent a lock mode for a row of a relational database table.
Lockable - interface org.hibernate.persister.entity.Lockable.
Contract for things that can be locked via a LockingStrategy
LockingStrategy - interface org.hibernate.dialect.lock.LockingStrategy.
A strategy abstraction for how locks are obtained in the underlying database.
LoggableUserType - interface org.hibernate.usertype.LoggableUserType.
Marker interface for user types which want to perform custom logging of their corresponding values
LogicalExpression - class org.hibernate.criterion.LogicalExpression.
Superclass of binary logical expressions
LogicalExpression(Criterion, Criterion, String) - Constructor for class org.hibernate.criterion.LogicalExpression

LongType - class org.hibernate.type.LongType.
long: A type that maps an SQL BIGINT to a Java Long.
LongType() - Constructor for class org.hibernate.type.LongType

last() - Method in interface org.hibernate.ScrollableResults
Go to the last result
last() - Method in class org.hibernate.collection.PersistentSortedSet

last() - Method in class org.hibernate.impl.FetchingScrollableResultsImpl
Go to the last result
last() - Method in class org.hibernate.impl.ScrollableResultsImpl

last() - Method in class org.hibernate.jdbc.ResultSetWrapper

lastCollectionElement() - Method in class org.hibernate.hql.classic.PathExpressionParser

lastIndexOf(Object) - Method in class org.hibernate.collection.PersistentBag

lastIndexOf(Object) - Method in class org.hibernate.collection.PersistentIdentifierBag

lastIndexOf(Object) - Method in class org.hibernate.collection.PersistentList

lastIndexOfLetter(String) - Static method in class org.hibernate.util.StringHelper

lastKey() - Method in class org.hibernate.collection.PersistentSortedMap

le(Object) - Method in class org.hibernate.criterion.Property

le(DetachedCriteria) - Method in class org.hibernate.criterion.Property

le(String, Object) - Static method in class org.hibernate.criterion.Restrictions
Apply a "less than or equal" constraint to the named property
le(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

leAll(DetachedCriteria) - Method in class org.hibernate.criterion.Property

leAll(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

leProperty(Property) - Method in class org.hibernate.criterion.Property

leProperty(String) - Method in class org.hibernate.criterion.Property

leProperty(String, String) - Static method in class org.hibernate.criterion.Restrictions
Apply a "less than or equal" constraint to two properties
leSome(DetachedCriteria) - Method in class org.hibernate.criterion.Property

leSome(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

length() - Method in class org.hibernate.lob.BlobImpl

length() - Method in class org.hibernate.lob.ClobImpl

length() - Method in class org.hibernate.lob.SerializableBlob

length() - Method in class org.hibernate.lob.SerializableClob

lessThan(FlushMode) - Method in class org.hibernate.FlushMode

lessThan(LockMode) - Method in class org.hibernate.LockMode
Check if this lock mode is less restrictive than the given lock mode.
lessThan(ScrollMode) - Method in class org.hibernate.ScrollMode

like(Object) - Method in class org.hibernate.criterion.Property

like(String, MatchMode) - Method in class org.hibernate.criterion.Property

like(String, Object) - Static method in class org.hibernate.criterion.Restrictions
Apply a "like" constraint to the named property
like(String, String, MatchMode) - Static method in class org.hibernate.criterion.Restrictions
Apply a "like" constraint to the named property
likeEscape() - Method in class org.hibernate.hql.antlr.HqlBaseParser

likeEscape(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

list() - Method in interface org.hibernate.Criteria
Get the results.
list() - Method in interface org.hibernate.Query
Return the query results as a List.
list - Variable in class org.hibernate.collection.PersistentList

list(String, QueryParameters) - Method in interface org.hibernate.engine.SessionImplementor
Execute a find() query
list(CriteriaImpl) - Method in interface org.hibernate.engine.SessionImplementor
Execute a criteria query
list(NativeSQLQuerySpecification, QueryParameters) - Method in interface org.hibernate.engine.SessionImplementor
Execute a native SQL query, and return the results as a fully built list.
list(SessionImplementor, QueryParameters) - Method in interface org.hibernate.hql.QueryTranslator
Perform a list operation given the underlying query definition.
list(SessionImplementor, QueryParameters) - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

list(SessionImplementor, QueryParameters) - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

list(NativeSQLQuerySpecification, QueryParameters) - Method in class org.hibernate.impl.AbstractSessionImpl

list() - Method in class org.hibernate.impl.CollectionFilterImpl

list() - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

list() - Method in class org.hibernate.impl.CriteriaImpl

list() - Method in class org.hibernate.impl.QueryImpl

list() - Method in class org.hibernate.impl.SQLQueryImpl

list(String, QueryParameters) - Method in class org.hibernate.impl.SessionImpl

list(CriteriaImpl) - Method in class org.hibernate.impl.SessionImpl

list(String, QueryParameters) - Method in class org.hibernate.impl.StatelessSessionImpl

list(CriteriaImpl) - Method in class org.hibernate.impl.StatelessSessionImpl

list(SessionImplementor, QueryParameters, Set, Type[]) - Method in class org.hibernate.loader.Loader
Return the query results, using the query cache, called by subclasses that implement cacheable queries
list(SessionImplementor) - Method in class org.hibernate.loader.criteria.CriteriaLoader

list(SessionImplementor, QueryParameters) - Method in class org.hibernate.loader.custom.CustomLoader

list(SessionImplementor, QueryParameters) - Method in class org.hibernate.loader.hql.QueryLoader
Delegats
list(String, String, boolean) - Static method in class org.hibernate.type.TypeFactory

listCustomQuery(CustomQuery, QueryParameters) - Method in interface org.hibernate.engine.SessionImplementor
Execute an SQL Query
listCustomQuery(CustomQuery, QueryParameters) - Method in class org.hibernate.impl.SessionImpl

listCustomQuery(CustomQuery, QueryParameters) - Method in class org.hibernate.impl.StatelessSessionImpl

listFilter(Object, String, QueryParameters) - Method in interface org.hibernate.engine.SessionImplementor
Execute a filter
listFilter(Object, String, QueryParameters) - Method in class org.hibernate.impl.SessionImpl

listFilter(Object, String, QueryParameters) - Method in class org.hibernate.impl.StatelessSessionImpl

listIterator() - Method in class org.hibernate.collection.PersistentBag

listIterator(int) - Method in class org.hibernate.collection.PersistentBag

listIterator() - Method in class org.hibernate.collection.PersistentIdentifierBag

listIterator(int) - Method in class org.hibernate.collection.PersistentIdentifierBag

listIterator() - Method in class org.hibernate.collection.PersistentList

listIterator(int) - Method in class org.hibernate.collection.PersistentList

literal(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

load(Class, Serializable, LockMode) - Method in interface org.hibernate.Session
Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.
load(String, Serializable, LockMode) - Method in interface org.hibernate.Session
Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.
load(Class, Serializable) - Method in interface org.hibernate.Session
Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.
load(String, Serializable) - Method in interface org.hibernate.Session
Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.
load(Object, Serializable) - Method in interface org.hibernate.Session
Read the persistent state associated with the given identifier into the given transient instance.
load(LoadEvent, EntityPersister, EntityKey, LoadEventListener.LoadType) - Method in class org.hibernate.event.def.DefaultLoadEventListener
Perfoms the load of an entity.
load(Object, Serializable) - Method in class org.hibernate.impl.SessionImpl

load(Class, Serializable) - Method in class org.hibernate.impl.SessionImpl

load(String, Serializable) - Method in class org.hibernate.impl.SessionImpl

load(Class, Serializable, LockMode) - Method in class org.hibernate.impl.SessionImpl

load(String, Serializable, LockMode) - Method in class org.hibernate.impl.SessionImpl

load(Serializable, Object, SessionImplementor) - Method in class org.hibernate.loader.entity.AbstractEntityLoader

load(SessionImplementor, Object, Object, Serializable) - Method in class org.hibernate.loader.entity.AbstractEntityLoader

load(Serializable, Object, SessionImplementor) - Method in class org.hibernate.loader.entity.BatchingEntityLoader

load(Serializable, Object, SessionImplementor) - Method in interface org.hibernate.loader.entity.UniqueEntityLoader
Load an entity instance.
load(Serializable, Object, LockMode, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Load an instance using either the forUpdateLoader or the outer joining loader, depending upon the value of the lock parameter
load(Serializable, Object, LockMode, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Load an instance of the persistent class.
load(Serializable, Object, SessionImplementor) - Method in class org.hibernate.persister.entity.NamedQueryLoader

loadByUniqueKey(SessionImplementor, Object) - Method in class org.hibernate.loader.entity.EntityLoader

loadByUniqueKey(String, Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

loadByUniqueKey(String, Object, SessionImplementor) - Method in interface org.hibernate.persister.entity.UniqueKeyLoadable
Load an instance of the persistent class, by a unique key other than the primary key.
loadByUniqueKey(String, String, Object, SessionImplementor) - Method in class org.hibernate.type.EntityType
Load an instance by a unique key that is not the primary key.
loadClass(String) - Method in class org.hibernate.bytecode.InstrumentedClassLoader

loadCollection(SessionImplementor, Serializable, Type) - Method in class org.hibernate.loader.Loader
Called by subclasses that initialize collections
loadCollection(String) - Method in class org.hibernate.stat.StatisticsImpl

loadCollection(String) - Method in interface org.hibernate.stat.StatisticsImplementor

loadCollectionBatch(SessionImplementor, Serializable[], Type) - Method in class org.hibernate.loader.Loader
Called by wrappers that batch initialize collections
loadCollectionSubselect(SessionImplementor, Serializable[], Object[], Type[], Map, Type) - Method in class org.hibernate.loader.Loader
Called by subclasses that batch initialize collections
loadElement(SessionImplementor, Object, Object) - Method in class org.hibernate.loader.entity.CollectionElementLoader

loadEntity(SessionImplementor, Object, Type, Object, String, Serializable, EntityPersister) - Method in class org.hibernate.loader.Loader
Called by subclasses that load entities
loadEntity(SessionImplementor, Object, Object, Type, Type, EntityPersister) - Method in class org.hibernate.loader.Loader
Called by subclasses that load entities
loadEntity(String) - Method in class org.hibernate.stat.StatisticsImpl

loadEntity(String) - Method in interface org.hibernate.stat.StatisticsImplementor

loadEntityBatch(SessionImplementor, Serializable[], Type, Object, String, Serializable, EntityPersister) - Method in class org.hibernate.loader.Loader
Called by wrappers that batch load entities
loadFromDatasource(LoadEvent, EntityPersister, EntityKey, LoadEventListener.LoadType) - Method in class org.hibernate.event.def.DefaultLoadEventListener
Performs the process of loading an entity from the configured underlying datasource.
loadFromSecondLevelCache(LoadEvent, EntityPersister, LoadEventListener.LoadType) - Method in class org.hibernate.event.def.DefaultLoadEventListener
Attempts to load the entity from the second-level cache.
loadFromSessionCache(LoadEvent, EntityKey, LoadEventListener.LoadType) - Method in class org.hibernate.event.def.DefaultLoadEventListener
Attempts to locate the entity in the session-level cache.
loadSequentialRowsForward(ResultSet, SessionImplementor, QueryParameters, boolean) - Method in class org.hibernate.loader.Loader
Loads a single logical row from the result set moving forward.
loadSequentialRowsReverse(ResultSet, SessionImplementor, QueryParameters, boolean, boolean) - Method in class org.hibernate.loader.Loader
Loads a single logical row from the result set moving forward.
loadSingleRow(ResultSet, SessionImplementor, QueryParameters, boolean) - Method in class org.hibernate.loader.Loader
Loads a single row from the result set.
locateChildFromClauseWithJoinByPath(String) - Method in class org.hibernate.hql.ast.tree.FromClause

locateConfig(String) - Static method in class org.hibernate.util.ConfigHelper
Try to locate a local URL representing the incoming path.
locatePersistentClassByEntityName(String) - Method in class org.hibernate.cfg.Mappings

locateUnquoted(String, char) - Static method in class org.hibernate.util.StringHelper

locateWhereClause() - Method in class org.hibernate.hql.ast.tree.AbstractRestrictableStatement

lock(Object, LockMode) - Method in interface org.hibernate.Session
Obtain the specified lock level upon the given object.
lock(String, Object, LockMode) - Method in interface org.hibernate.Session
Obtain the specified lock level upon the given object.
lock(Object) - Method in interface org.hibernate.cache.Cache
If this is a clustered cache, lock the item
lock(Object, Object) - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
We are going to attempt to update/delete the keyed object.
lock(Object) - Method in class org.hibernate.cache.EhCache
Calls to this method should perform there own synchronization.
lock(Object) - Method in class org.hibernate.cache.HashtableCache

lock(Object, Object) - Method in class org.hibernate.cache.NonstrictReadWriteCache
Do nothing.
lock(Object) - Method in class org.hibernate.cache.OSCache

lock(Object) - Method in class org.hibernate.cache.OptimisticTreeCache

lock(Object, Object) - Method in class org.hibernate.cache.ReadOnlyCache
Unsupported!
lock(long, int) - Method in class org.hibernate.cache.ReadWriteCache.Item
Lock the item
lock(long, int) - Method in class org.hibernate.cache.ReadWriteCache.Lock
Increment the lock, setting the new lock timeout
lock(long, int) - Method in interface org.hibernate.cache.ReadWriteCache.Lockable

lock(Object, Object) - Method in class org.hibernate.cache.ReadWriteCache
Stop any other transactions reading or writing this item to/from the cache.
lock(Object) - Method in class org.hibernate.cache.SwarmCache
If this is a clustered cache, lock the item
lock(Object, Object) - Method in class org.hibernate.cache.TransactionalCache
Do nothing, returning null.
lock(Object) - Method in class org.hibernate.cache.TreeCache

lock(Serializable, Object, Object, SessionImplementor) - Method in class org.hibernate.dialect.HSQLDialect.ReadUncommittedLockingStrategy

lock(Serializable, Object, Object, SessionImplementor) - Method in interface org.hibernate.dialect.lock.LockingStrategy
Acquire an appropriate type of lock on the underlying data that will endure until the end of the current transaction.
lock(Serializable, Object, Object, SessionImplementor) - Method in class org.hibernate.dialect.lock.SelectLockingStrategy

lock(Serializable, Object, Object, SessionImplementor) - Method in class org.hibernate.dialect.lock.UpdateLockingStrategy

lock(String, Object, LockMode) - Method in class org.hibernate.impl.SessionImpl

lock(Object, LockMode) - Method in class org.hibernate.impl.SessionImpl

lock(Serializable, Object, Object, LockMode, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

lock(Serializable, Object, Object, LockMode, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Do a version check (optional operation)
lockAndLoad(LoadEvent, EntityPersister, EntityKey, LoadEventListener.LoadType, SessionImplementor) - Method in class org.hibernate.event.def.DefaultLoadEventListener
If the class to be loaded has been configured with a cache, then lock given id in that cache and then perform the load.
lockModeArray - Variable in class org.hibernate.loader.JoinWalker

lockModeArray - Variable in class org.hibernate.loader.OuterJoinLoader

log - Static variable in class org.hibernate.jdbc.AbstractBatcher

log - Static variable in class org.hibernate.loader.custom.sql.SQLCustomQuery

log - Static variable in class org.hibernate.loader.custom.sql.SQLQueryReturnProcessor

log - Static variable in class org.hibernate.loader.entity.AbstractEntityLoader

log - Static variable in class org.hibernate.util.JDBCExceptionReporter

logAndClearWarnings(Connection) - Static method in class org.hibernate.util.JDBCExceptionReporter

logExceptions(SQLException) - Static method in class org.hibernate.util.JDBCExceptionReporter

logExceptions(SQLException, String) - Static method in class org.hibernate.util.JDBCExceptionReporter

logStaticSQL() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

logStaticSQL() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

logSummary() - Method in class org.hibernate.jmx.StatisticsService

logSummary() - Method in interface org.hibernate.stat.Statistics
log in info level the main statistics
logSummary() - Method in class org.hibernate.stat.StatisticsImpl
log in info level the main statistics
logWarnings(SQLWarning) - Static method in class org.hibernate.util.JDBCExceptionReporter

logWarnings(SQLWarning, String) - Static method in class org.hibernate.util.JDBCExceptionReporter

logger - Variable in class org.hibernate.tool.instrument.BasicInstrumentationTask

logicalAndExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

logicalCollectionColumnName(String, String, String) - Method in class org.hibernate.cfg.DefaultNamingStrategy
Return the column name if explicit or the concatenation of the property name and the referenced column
logicalCollectionColumnName(String, String, String) - Method in class org.hibernate.cfg.ImprovedNamingStrategy
Return the column name if explicit or the concatenation of the property name and the referenced column
logicalCollectionColumnName(String, String, String) - Method in interface org.hibernate.cfg.NamingStrategy
Returns the logical foreign key column name used to refer to this column in the mapping metadata
logicalCollectionTableName(String, String, String, String) - Method in class org.hibernate.cfg.DefaultNamingStrategy
Returns either the table name if explicit or if there is an associated table, the concatenation of owner entity table and associated table otherwise the concatenation of owner entity table and the unqualified property name
logicalCollectionTableName(String, String, String, String) - Method in class org.hibernate.cfg.ImprovedNamingStrategy
Returns either the table name if explicit or if there is an associated table, the concatenation of owner entity table and associated table otherwise the concatenation of owner entity table and the unqualified property name
logicalCollectionTableName(String, String, String, String) - Method in interface org.hibernate.cfg.NamingStrategy
Returns the logical collection table name used to refer to a table in the mapping metadata
logicalColumnName(String, String) - Method in class org.hibernate.cfg.DefaultNamingStrategy
Return the column name or the unqualified property name
logicalColumnName(String, String) - Method in class org.hibernate.cfg.ImprovedNamingStrategy
Return the column name or the unqualified property name
logicalColumnName(String, String) - Method in interface org.hibernate.cfg.NamingStrategy
Return the logical column name used to refer to a column in the metadata (like index, unique constraints etc) A full bijection is required between logicalNames and physical ones logicalName have to be case insersitively unique for a given table
logicalExpr(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

logicalExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

logicalName - Variable in class org.hibernate.cfg.Mappings.TableDescription

logicalOrExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

logicalToPhysical - Variable in class org.hibernate.cfg.Mappings.ColumnNames

lookupAlias(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

lookupAlias(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

lookupConstant(DotNode) - Method in class org.hibernate.hql.ast.util.LiteralProcessor

lookupNonQualifiedProperty(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

lookupNonQualifiedProperty(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

lookupProperty(AST, boolean, boolean) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

lookupProperty(AST, boolean, boolean) - Method in class org.hibernate.hql.ast.HqlSqlWalker

lt(Object) - Method in class org.hibernate.criterion.Property

lt(DetachedCriteria) - Method in class org.hibernate.criterion.Property

lt(String, Object) - Static method in class org.hibernate.criterion.Restrictions
Apply a "less than" constraint to the named property
lt(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

ltAll(DetachedCriteria) - Method in class org.hibernate.criterion.Property

ltAll(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

ltProperty(Property) - Method in class org.hibernate.criterion.Property

ltProperty(String) - Method in class org.hibernate.criterion.Property

ltProperty(String, String) - Static method in class org.hibernate.criterion.Restrictions
Apply a "less than" constraint to two properties
ltSome(DetachedCriteria) - Method in class org.hibernate.criterion.Property

ltSome(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

M

MANAGED - Static variable in class org.hibernate.engine.Status

MANUAL - Static variable in class org.hibernate.FlushMode
The Session is only ever flushed when Session.flush() is explicitly called by the application.
MAP - Static variable in class org.hibernate.EntityMode

MARKER - Static variable in class org.hibernate.engine.BatchFetchQueue

MARKER - Static variable in class org.hibernate.impl.FilterImpl

MAX - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

MAX - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

MAX - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

MAX_FETCH_DEPTH - Static variable in class org.hibernate.cfg.Environment
Maximum depth of outer join fetching
MAX_LO - Static variable in class org.hibernate.id.MultipleHiLoPerTableGenerator

MAX_LO - Static variable in class org.hibernate.id.SequenceHiLoGenerator

MAX_LO - Static variable in class org.hibernate.id.TableHiLoGenerator
The max_lo parameter
MEMBER - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

MEMBER - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

MEMBER - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

MERGE - Static variable in class org.hibernate.engine.CascadeStyle
merge
MERGE - Static variable in class org.hibernate.engine.CascadingAction

METHOD_CALL - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

METHOD_CALL - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

METHOD_CALL - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

METHOD_NAME - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

METHOD_NAME - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

MIN - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

MIN - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

MIN - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

MINUS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

MINUS - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

MINUS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ManagedSessionContext - class org.hibernate.context.ManagedSessionContext.
Represents a CurrentSessionContext the notion of a contextual session is managed by some external entity (generally some form of interceptor, etc).
ManagedSessionContext(SessionFactoryImplementor) - Constructor for class org.hibernate.context.ManagedSessionContext

ManyToOne - class org.hibernate.mapping.ManyToOne.
A many-to-one association mapping
ManyToOne(Table) - Constructor for class org.hibernate.mapping.ManyToOne

ManyToOneType - class org.hibernate.type.ManyToOneType.
A many-to-one association to an entity.
ManyToOneType(String) - Constructor for class org.hibernate.type.ManyToOneType

ManyToOneType(String, boolean) - Constructor for class org.hibernate.type.ManyToOneType

ManyToOneType(String, String, boolean, boolean, boolean, boolean) - Constructor for class org.hibernate.type.ManyToOneType

Map - class org.hibernate.mapping.Map.
A map has a primary key consisting of the key columns + index columns.
Map(PersistentClass) - Constructor for class org.hibernate.mapping.Map

MapAccessor - class org.hibernate.property.MapAccessor.

MapAccessor() - Constructor for class org.hibernate.property.MapAccessor

MapAccessor.MapGetter - class org.hibernate.property.MapAccessor.MapGetter.

MapAccessor.MapSetter - class org.hibernate.property.MapAccessor.MapSetter.

MapLazyInitializer - class org.hibernate.proxy.map.MapLazyInitializer.
Lazy initializer for "dynamic-map" entity representations.
MapProxy - class org.hibernate.proxy.map.MapProxy.
Proxy for "dynamic-map" entity representations.
MapProxyFactory - class org.hibernate.proxy.map.MapProxyFactory.

MapProxyFactory() - Constructor for class org.hibernate.proxy.map.MapProxyFactory

MapType - class org.hibernate.type.MapType.

MapType(String, String, boolean) - Constructor for class org.hibernate.type.MapType

Mapping - interface org.hibernate.engine.Mapping.
Defines operations common to "compiled" mappings (ie.
MappingException - exception org.hibernate.MappingException.
An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
MappingException(String, Throwable) - Constructor for class org.hibernate.MappingException

MappingException(Throwable) - Constructor for class org.hibernate.MappingException

MappingException(String) - Constructor for class org.hibernate.MappingException

MappingNotFoundException - exception org.hibernate.MappingNotFoundException.
Thrown when a resource for a mapping could not be found.
MappingNotFoundException(String, String, String, Throwable) - Constructor for class org.hibernate.MappingNotFoundException

MappingNotFoundException(String, String, String) - Constructor for class org.hibernate.MappingNotFoundException

MappingNotFoundException(String, String) - Constructor for class org.hibernate.MappingNotFoundException

MappingNotFoundException(String, String, Throwable) - Constructor for class org.hibernate.MappingNotFoundException

Mappings - class org.hibernate.cfg.Mappings.
A collection of mappings from classes and collections to relational database tables.
Mappings.ColumnNames - class org.hibernate.cfg.Mappings.ColumnNames.

Mappings.ColumnNames() - Constructor for class org.hibernate.cfg.Mappings.ColumnNames

Mappings.TableDescription - class org.hibernate.cfg.Mappings.TableDescription.

Mappings.TableDescription(String, Table) - Constructor for class org.hibernate.cfg.Mappings.TableDescription

MarkerObject - class org.hibernate.util.MarkerObject.

MarkerObject(String) - Constructor for class org.hibernate.util.MarkerObject

MatchMode - class org.hibernate.criterion.MatchMode.
Represents an strategy for matching strings using "like".
MatchMode(String) - Constructor for class org.hibernate.criterion.MatchMode

MckoiCaseFragment - class org.hibernate.sql.MckoiCaseFragment.
A Mckoi IF function.
MckoiCaseFragment() - Constructor for class org.hibernate.sql.MckoiCaseFragment

MckoiDialect - class org.hibernate.dialect.MckoiDialect.
An SQL dialect compatible with McKoi SQL
MckoiDialect() - Constructor for class org.hibernate.dialect.MckoiDialect

MergeEvent - class org.hibernate.event.MergeEvent.
An event class for merge() and saveOrUpdateCopy()
MergeEvent(String, Object, EventSource) - Constructor for class org.hibernate.event.MergeEvent

MergeEvent(String, Object, Serializable, EventSource) - Constructor for class org.hibernate.event.MergeEvent

MergeEvent(Object, EventSource) - Constructor for class org.hibernate.event.MergeEvent

MergeEventListener - interface org.hibernate.event.MergeEventListener.
Defines the contract for handling of merge events generated from a session.
MessageHelper - class org.hibernate.pretty.MessageHelper.
MessageHelper methods for rendering log messages relating to managed entities and collections typically used in log statements and exception messages.
MetaAttributable - interface org.hibernate.mapping.MetaAttributable.
Common interface for things that can handle meta attributes.
MetaAttribute - class org.hibernate.mapping.MetaAttribute.
A meta attribute is a named value or values.
MetaAttribute(String) - Constructor for class org.hibernate.mapping.MetaAttribute

MetaType - class org.hibernate.type.MetaType.

MetaType(Map, Type) - Constructor for class org.hibernate.type.MetaType

MethodNode - class org.hibernate.hql.ast.tree.MethodNode.
Represents a method call.
MethodNode() - Constructor for class org.hibernate.hql.ast.tree.MethodNode

MimerSQLDialect - class org.hibernate.dialect.MimerSQLDialect.
An Hibernate 3 SQL dialect for Mimer SQL.
MimerSQLDialect() - Constructor for class org.hibernate.dialect.MimerSQLDialect
Even thoug Mimer SQL supports character and binary columns up to 15 000 in lenght, this is also the maximum width of the table (exluding LOBs).
MultiTableDeleteExecutor - class org.hibernate.hql.ast.exec.MultiTableDeleteExecutor.
Implementation of MultiTableDeleteExecutor.
MultiTableDeleteExecutor(HqlSqlWalker) - Constructor for class org.hibernate.hql.ast.exec.MultiTableDeleteExecutor

MultiTableUpdateExecutor - class org.hibernate.hql.ast.exec.MultiTableUpdateExecutor.
Implementation of MultiTableUpdateExecutor.
MultiTableUpdateExecutor(HqlSqlWalker) - Constructor for class org.hibernate.hql.ast.exec.MultiTableUpdateExecutor

MultipleHiLoPerTableGenerator - class org.hibernate.id.MultipleHiLoPerTableGenerator.
A hilo IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.
MultipleHiLoPerTableGenerator() - Constructor for class org.hibernate.id.MultipleHiLoPerTableGenerator

MutableType - class org.hibernate.type.MutableType.
Superclass for mutable nullable types
MutableType() - Constructor for class org.hibernate.type.MutableType

MySQL5Dialect - class org.hibernate.dialect.MySQL5Dialect.
An SQL dialect for MySQL 5.x specific features.
MySQL5Dialect() - Constructor for class org.hibernate.dialect.MySQL5Dialect

MySQL5InnoDBDialect - class org.hibernate.dialect.MySQL5InnoDBDialect.

MySQL5InnoDBDialect() - Constructor for class org.hibernate.dialect.MySQL5InnoDBDialect

MySQLDialect - class org.hibernate.dialect.MySQLDialect.
An SQL dialect for MySQL (prior to 5.x).
MySQLDialect() - Constructor for class org.hibernate.dialect.MySQLDialect

MySQLInnoDBDialect - class org.hibernate.dialect.MySQLInnoDBDialect.

MySQLInnoDBDialect() - Constructor for class org.hibernate.dialect.MySQLInnoDBDialect

MySQLMyISAMDialect - class org.hibernate.dialect.MySQLMyISAMDialect.

MySQLMyISAMDialect() - Constructor for class org.hibernate.dialect.MySQLMyISAMDialect

mCLOSE(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mCLOSE_BRACKET(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mCOLON(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mCOMMA(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mCONCAT(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mDIV(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mEQ(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mESCqs(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mEXPONENT(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mFLOAT_SUFFIX(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mGE(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mGT(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mHEX_DIGIT(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mIDENT(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mID_LETTER(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mID_START_LETTER(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mLE(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mLT(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mMINUS(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mNE(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mNUM_INT(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mOPEN(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mOPEN_BRACKET(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mPARAM(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mPLUS(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mQUOTED_STRING(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mSQL_NE(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mSTAR(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

mWS(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

main(String[]) - Static method in class org.hibernate.dialect.DB2Dialect

main(String[]) - Static method in class org.hibernate.id.UUIDHexGenerator

main(String[]) - Static method in class org.hibernate.pretty.Formatter

main(String[]) - Static method in class org.hibernate.tool.hbm2ddl.SchemaExport

main(String[]) - Static method in class org.hibernate.tool.hbm2ddl.SchemaUpdate

main(String[]) - Static method in class org.hibernate.tool.hbm2ddl.SchemaValidator

makeSiblingOfParent(AST, AST) - Static method in class org.hibernate.hql.ast.util.ASTUtil
Makes the child node a sibling of the parent, reconnecting all siblings.
managedClose() - Method in class org.hibernate.impl.SessionImpl

managedClose() - Method in class org.hibernate.impl.StatelessSessionImpl

managedClose() - Method in interface org.hibernate.transaction.TransactionFactory.Context

managedFlush() - Method in class org.hibernate.impl.SessionImpl

managedFlush() - Method in class org.hibernate.impl.StatelessSessionImpl

managedFlush() - Method in interface org.hibernate.transaction.TransactionFactory.Context

manualDisconnect() - Method in class org.hibernate.jdbc.ConnectionManager
Manually disconnect the underlying JDBC Connection.
manualReconnect() - Method in class org.hibernate.jdbc.ConnectionManager
Manually reconnect the underlying JDBC Connection.
manualReconnect(Connection) - Method in class org.hibernate.jdbc.ConnectionManager
Manually reconnect the underlying JDBC Connection.
manyToOne(String) - Static method in class org.hibernate.type.TypeFactory
A many-to-one association type for the given class
manyToOne(String, boolean) - Static method in class org.hibernate.type.TypeFactory
A many-to-one association type for the given class
manyToOne(String, String, boolean, boolean, boolean, boolean) - Static method in class org.hibernate.type.TypeFactory
A many-to-one association type for the given class
map - Variable in class org.hibernate.collection.PersistentMap

map(String, String, boolean) - Static method in class org.hibernate.type.TypeFactory

markDirty(Object) - Static method in class org.hibernate.intercept.FieldInterceptionHelper

maskOut(Properties, String) - Static method in class org.hibernate.util.PropertiesHelper
replace a property by a starred version
matches(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

matches(String) - Method in class org.hibernate.tuple.ElementWrapper

max(String) - Static method in class org.hibernate.criterion.Projections
A property maximum value
max() - Method in class org.hibernate.criterion.Property

merge(Object) - Method in interface org.hibernate.Session
Copy the state of the given object onto the persistent object with the same identifier.
merge(String, Object) - Method in interface org.hibernate.Session
Copy the state of the given object onto the persistent object with the same identifier.
merge(String, Object, Map) - Method in interface org.hibernate.event.EventSource
Cascade merge an entity instance
merge(String, Object) - Method in class org.hibernate.impl.SessionImpl

merge(Object) - Method in class org.hibernate.impl.SessionImpl

merge(String, Object, Map) - Method in class org.hibernate.impl.SessionImpl

mergeOrderings(String, String) - Static method in class org.hibernate.loader.JoinWalker

mergeOuterJoins(List) - Method in class org.hibernate.loader.JoinWalker
Generate a sequence of LEFT OUTER JOIN clauses for the given associations.
mergeProperties(Properties) - Method in class org.hibernate.cfg.Configuration
Adds the incoming properties to the internap properties structure, as long as the internal structure does not already contain an entry for the given key.
methodCall(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

min(String) - Static method in class org.hibernate.criterion.Projections
A property minimum value
min() - Method in class org.hibernate.criterion.Property

moveAndToBeginning(String) - Static method in class org.hibernate.util.StringHelper

moveToCurrentRow() - Method in class org.hibernate.jdbc.ResultSetWrapper

moveToInsertRow() - Method in class org.hibernate.jdbc.ResultSetWrapper

multiplicativeExpr(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

multiply(String, Iterator, Iterator) - Static method in class org.hibernate.util.StringHelper

multiplyExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

mutateRowValueConstructorSyntaxesIfNecessary(Type, Type) - Method in class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode

N

NAMED_PARAM - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NAMED_PARAM - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

NE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NEGATIVE - Static variable in class org.hibernate.engine.VersionValue
Assume the transient instance is newly instantiated if the version is negative, otherwise assume it is a detached instance.
NEVER - Static variable in class org.hibernate.FlushMode
Deprecated. use FlushMode.MANUAL instead.
NEVER - Static variable in class org.hibernate.mapping.PropertyGeneration
Values for this property are never generated by the database.
NEW - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NEW - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

NEW - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NONE - Static variable in class org.hibernate.LockMode
No lock required.
NONE - Static variable in class org.hibernate.engine.CascadeStyle
no cascades
NONE - Static variable in class org.hibernate.engine.ExecuteUpdateResultCheckStyle
Do not perform checking.
NONE - Static variable in class org.hibernate.engine.IdentifierValue
Never assume the transient instance is newly instantiated
NONE - Static variable in class org.hibernate.jdbc.Expectations

NONSTRICT_READ_WRITE - Static variable in class org.hibernate.cache.CacheFactory

NOOP_INSTANTIATOR - Static variable in class org.hibernate.hql.HolderInstantiator

NORMAL - Static variable in class org.hibernate.CacheMode
The session may read items from the cache, and add items to the cache
NOT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NOT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

NOT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NOT_BETWEEN - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NOT_BETWEEN - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

NOT_BETWEEN - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NOT_IN - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NOT_IN - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

NOT_IN - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NOT_LIKE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NOT_LIKE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

NOT_LIKE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NOT_NULL - Static variable in class org.hibernate.sql.InFragment

NOT_NULL_DISCRIMINATOR_MAPPING - Static variable in class org.hibernate.mapping.PersistentClass

NO_CLASSES - Static variable in class org.hibernate.proxy.pojo.cglib.CGLIBProxyFactory

NO_CLASSES - Static variable in class org.hibernate.proxy.pojo.javassist.JavassistProxyFactory

NO_ROW - Static variable in class org.hibernate.engine.StatefulPersistenceContext

NO_SUFFIX - Static variable in class org.hibernate.loader.BasicLoader

NO_VETO - Static variable in interface org.hibernate.classic.Lifecycle
Return value to accept the action (false)
NULL - Static variable in class org.hibernate.engine.IdentifierValue
Assume the transient instance is newly instantiated if the identifier is null.
NULL - Static variable in class org.hibernate.engine.VersionValue
Assume the transient instance is newly instantiated if the version is null, otherwise assume it is a detached instance.
NULL - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NULL - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

NULL - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NULL - Static variable in class org.hibernate.sql.InFragment

NULL_DISCRIMINATOR_MAPPING - Static variable in class org.hibernate.mapping.PersistentClass

NULL_TREE_LOOKAHEAD - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NULL_TREE_LOOKAHEAD - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

NULL_TREE_LOOKAHEAD - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NUM_DOUBLE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NUM_DOUBLE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

NUM_DOUBLE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NUM_FLOAT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NUM_FLOAT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

NUM_FLOAT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NUM_INT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NUM_INT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

NUM_INT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NUM_LONG - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

NUM_LONG - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

NUM_LONG - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

NameGenerator - class org.hibernate.hql.NameGenerator.
Provides utility methods for generating HQL / SQL names.
NamedGeneratedKeysHelper - class org.hibernate.util.NamedGeneratedKeysHelper.

NamedParameterDescriptor - class org.hibernate.engine.query.NamedParameterDescriptor.
Descriptor regarding a named parameter.
NamedParameterDescriptor(String, Type, int[], boolean) - Constructor for class org.hibernate.engine.query.NamedParameterDescriptor

NamedParameterSpecification - class org.hibernate.param.NamedParameterSpecification.
Relates to an explicit query named-parameter.
NamedParameterSpecification(int, int, String) - Constructor for class org.hibernate.param.NamedParameterSpecification

NamedQueryCollectionInitializer - class org.hibernate.persister.collection.NamedQueryCollectionInitializer.
A wrapper around a named query.
NamedQueryCollectionInitializer(String, CollectionPersister) - Constructor for class org.hibernate.persister.collection.NamedQueryCollectionInitializer

NamedQueryDefinition - class org.hibernate.engine.NamedQueryDefinition.
Definition of a named query, defined in the mapping metadata.
NamedQueryDefinition(String, boolean, String, Integer, Integer, FlushMode, Map) - Constructor for class org.hibernate.engine.NamedQueryDefinition

NamedQueryDefinition(String, boolean, String, Integer, Integer, FlushMode, CacheMode, boolean, String, Map) - Constructor for class org.hibernate.engine.NamedQueryDefinition

NamedQueryLoader - class org.hibernate.persister.entity.NamedQueryLoader.
Not really a Loader, just a wrapper around a named query.
NamedQueryLoader(String, EntityPersister) - Constructor for class org.hibernate.persister.entity.NamedQueryLoader

NamedSQLQueryDefinition - class org.hibernate.engine.NamedSQLQueryDefinition.
Definition of a named native SQL query, defined in the mapping metadata.
NamedSQLQueryDefinition(String, NativeSQLQueryReturn[], List, boolean, String, Integer, Integer, FlushMode, CacheMode, boolean, String, Map, boolean) - Constructor for class org.hibernate.engine.NamedSQLQueryDefinition
This form used to construct a NamedSQLQueryDefinition from the binder code when a the result-set mapping information is explicitly provided in the query definition (i.e., no resultset-mapping used)
NamedSQLQueryDefinition(String, String, List, boolean, String, Integer, Integer, FlushMode, CacheMode, boolean, String, Map, boolean) - Constructor for class org.hibernate.engine.NamedSQLQueryDefinition
This form used to construct a NamedSQLQueryDefinition from the binder code when a resultset-mapping reference is used.
NamedSQLQueryDefinition(String, String, List, boolean, String, Integer, Integer, FlushMode, Map, boolean) - Constructor for class org.hibernate.engine.NamedSQLQueryDefinition
This form used from annotations (?).
NamedSQLQuerySecondPass - class org.hibernate.cfg.NamedSQLQuerySecondPass.

NamedSQLQuerySecondPass(Element, String, Mappings) - Constructor for class org.hibernate.cfg.NamedSQLQuerySecondPass

NamingHelper - class org.hibernate.util.NamingHelper.

NamingStrategy - interface org.hibernate.cfg.NamingStrategy.
A set of rules for determining the physical column and table names given the information in the mapping document.
NativeSQLQueryCollectionReturn - class org.hibernate.engine.query.sql.NativeSQLQueryCollectionReturn.
Represents a return defined as part of a native sql query which names a collection role in the form {classname}.{collectionrole}; it is used in defining a custom sql query for loading an entity's collection in non-fetching scenarios (i.e., loading the collection itself as the "root" of the result).
NativeSQLQueryCollectionReturn(String, String, String, Map, LockMode) - Constructor for class org.hibernate.engine.query.sql.NativeSQLQueryCollectionReturn
Construct a native-sql return representing a collection initializer
NativeSQLQueryJoinReturn - class org.hibernate.engine.query.sql.NativeSQLQueryJoinReturn.
Represents a return defined as part of a native sql query which names a fetched role.
NativeSQLQueryJoinReturn(String, String, String, Map, LockMode) - Constructor for class org.hibernate.engine.query.sql.NativeSQLQueryJoinReturn
Construct a return descriptor representing some form of fetch.
NativeSQLQueryNonScalarReturn - class org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn.
Represents the base information for a non-scalar return defined as part of a native sql query.
NativeSQLQueryNonScalarReturn(String, Map, LockMode) - Constructor for class org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn
Constructs some form of non-scalar return descriptor
NativeSQLQueryPlan - class org.hibernate.engine.query.NativeSQLQueryPlan.
Defines a query execution plan for a native-SQL query.
NativeSQLQueryPlan(NativeSQLQuerySpecification, SessionFactoryImplementor) - Constructor for class org.hibernate.engine.query.NativeSQLQueryPlan

NativeSQLQueryReturn - interface org.hibernate.engine.query.sql.NativeSQLQueryReturn.
Describes a return in a native SQL query.
NativeSQLQueryRootReturn - class org.hibernate.engine.query.sql.NativeSQLQueryRootReturn.
Represents a return defined as part of a native sql query which names a "root" entity.
NativeSQLQueryRootReturn(String, String, LockMode) - Constructor for class org.hibernate.engine.query.sql.NativeSQLQueryRootReturn
Construct a return representing an entity returned at the root of the result.
NativeSQLQueryRootReturn(String, String, Map, LockMode) - Constructor for class org.hibernate.engine.query.sql.NativeSQLQueryRootReturn

NativeSQLQueryScalarReturn - class org.hibernate.engine.query.sql.NativeSQLQueryScalarReturn.
Describes a scalar return in a native SQL query.
NativeSQLQueryScalarReturn(String, Type) - Constructor for class org.hibernate.engine.query.sql.NativeSQLQueryScalarReturn

NativeSQLQuerySpecification - class org.hibernate.engine.query.sql.NativeSQLQuerySpecification.
Defines the specification or blue-print for a native-sql query.
NativeSQLQuerySpecification(String, NativeSQLQueryReturn[], Collection) - Constructor for class org.hibernate.engine.query.sql.NativeSQLQuerySpecification

NaturalIdentifier - class org.hibernate.criterion.NaturalIdentifier.

NaturalIdentifier() - Constructor for class org.hibernate.criterion.NaturalIdentifier

Nestable - interface org.hibernate.exception.Nestable.
An interface to be implemented by Throwable extensions which would like to be able to nest root exceptions inside themselves.
NestableDelegate - class org.hibernate.exception.NestableDelegate.
A shared implementation of the nestable exception functionality.
NestableDelegate(Nestable) - Constructor for class org.hibernate.exception.NestableDelegate
Constructs a new NestableDelegate instance to manage the specified Nestable.
NestableException - exception org.hibernate.exception.NestableException.
The base class of all exceptions which can contain other exceptions.
NestableException() - Constructor for class org.hibernate.exception.NestableException
Constructs a new NestableException without specified detail message.
NestableException(String) - Constructor for class org.hibernate.exception.NestableException
Constructs a new NestableException with specified detail message.
NestableException(Throwable) - Constructor for class org.hibernate.exception.NestableException
Constructs a new NestableException with specified nested Throwable.
NestableException(String, Throwable) - Constructor for class org.hibernate.exception.NestableException
Constructs a new NestableException with specified detail message and nested Throwable.
NestableRuntimeException - exception org.hibernate.exception.NestableRuntimeException.
The base class of all runtime exceptions which can contain other exceptions.
NestableRuntimeException() - Constructor for class org.hibernate.exception.NestableRuntimeException
Constructs a new NestableRuntimeException without specified detail message.
NestableRuntimeException(String) - Constructor for class org.hibernate.exception.NestableRuntimeException
Constructs a new NestableRuntimeException with specified detail message.
NestableRuntimeException(Throwable) - Constructor for class org.hibernate.exception.NestableRuntimeException
Constructs a new NestableRuntimeException with specified nested Throwable.
NestableRuntimeException(String, Throwable) - Constructor for class org.hibernate.exception.NestableRuntimeException
Constructs a new NestableRuntimeException with specified detail message and nested Throwable.
NoArgSQLFunction - class org.hibernate.dialect.function.NoArgSQLFunction.
A function which takes no arguments
NoArgSQLFunction(String, Type) - Constructor for class org.hibernate.dialect.function.NoArgSQLFunction

NoArgSQLFunction(String, Type, boolean) - Constructor for class org.hibernate.dialect.function.NoArgSQLFunction

NoCacheProvider - class org.hibernate.cache.NoCacheProvider.
Implementation of NoCacheProvider.
NoCacheProvider() - Constructor for class org.hibernate.cache.NoCacheProvider

NoCachingEnabledException - exception org.hibernate.cache.NoCachingEnabledException.
Implementation of NoCachingEnabledException.
NoCachingEnabledException() - Constructor for class org.hibernate.cache.NoCachingEnabledException

Node - class org.hibernate.hql.ast.tree.Node.
Base node class for use by Hibernate within its AST trees.
Node() - Constructor for class org.hibernate.hql.ast.tree.Node

Node(Token) - Constructor for class org.hibernate.hql.ast.tree.Node

NodeTraverser - class org.hibernate.hql.ast.util.NodeTraverser.
A visitor for traversing an AST tree.
NodeTraverser(NodeTraverser.VisitationStrategy) - Constructor for class org.hibernate.hql.ast.util.NodeTraverser

NodeTraverser.VisitationStrategy - interface org.hibernate.hql.ast.util.NodeTraverser.VisitationStrategy.

NonBatchingBatcher - class org.hibernate.jdbc.NonBatchingBatcher.
An implementation of the Batcher interface that does no batching
NonBatchingBatcher(ConnectionManager, Interceptor) - Constructor for class org.hibernate.jdbc.NonBatchingBatcher

NonBatchingBatcherFactory - class org.hibernate.jdbc.NonBatchingBatcherFactory.
A BatcherFactory implementation which constructs Batcher instances that do not perform batch operations.
NonBatchingBatcherFactory() - Constructor for class org.hibernate.jdbc.NonBatchingBatcherFactory

NonScalarReturn - class org.hibernate.loader.custom.NonScalarReturn.
Represents some non-scalar (entity/collection) return within the query result.
NonScalarReturn(String, LockMode) - Constructor for class org.hibernate.loader.custom.NonScalarReturn

NonUniqueObjectException - exception org.hibernate.NonUniqueObjectException.
This exception is thrown when an operation would break session-scoped identity.
NonUniqueObjectException(String, Serializable, String) - Constructor for class org.hibernate.NonUniqueObjectException

NonUniqueObjectException(Serializable, String) - Constructor for class org.hibernate.NonUniqueObjectException

NonUniqueResultException - exception org.hibernate.NonUniqueResultException.
Thrown when the application calls Query.uniqueResult() and the query returned more than one result.
NonUniqueResultException(int) - Constructor for class org.hibernate.NonUniqueResultException

NonstrictReadWriteCache - class org.hibernate.cache.NonstrictReadWriteCache.
Caches data that is sometimes updated without ever locking the cache.
NonstrictReadWriteCache() - Constructor for class org.hibernate.cache.NonstrictReadWriteCache

NoopAccessor - class org.hibernate.property.NoopAccessor.
Used to declare properties not represented at the pojo level
NoopAccessor() - Constructor for class org.hibernate.property.NoopAccessor

NotEmptyExpression - class org.hibernate.criterion.NotEmptyExpression.

NotEmptyExpression(String) - Constructor for class org.hibernate.criterion.NotEmptyExpression

NotExpression - class org.hibernate.criterion.NotExpression.
Negates another criterion
NotExpression(Criterion) - Constructor for class org.hibernate.criterion.NotExpression

NotNullExpression - class org.hibernate.criterion.NotNullExpression.
Constrains a property to be non-null
NotNullExpression(String) - Constructor for class org.hibernate.criterion.NotNullExpression

NullExpression - class org.hibernate.criterion.NullExpression.
Constrains a property to be null
NullExpression(String) - Constructor for class org.hibernate.criterion.NullExpression

Nullability - class org.hibernate.engine.Nullability.
Implements the algorithm for validating property values for illegal null values
Nullability(SessionImplementor) - Constructor for class org.hibernate.engine.Nullability

NullableType - class org.hibernate.type.NullableType.
Superclass of single-column nullable types.
NullableType() - Constructor for class org.hibernate.type.NullableType

NvlFunction - class org.hibernate.dialect.function.NvlFunction.
Emulation of coalesce() on Oracle, using multiple nvl() calls
NvlFunction() - Constructor for class org.hibernate.dialect.function.NvlFunction

namedParameter(String, int) - Method in class org.hibernate.engine.query.ParamLocationRecognizer

namedParameter(String, int) - Method in interface org.hibernate.engine.query.ParameterParser.Recognizer

namedParameter(String, int) - Method in class org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer

namedQueries - Variable in class org.hibernate.cfg.Configuration

namedSqlQueries - Variable in class org.hibernate.cfg.Configuration

namingStrategy - Variable in class org.hibernate.cfg.Configuration

namingStrategy - Variable in class org.hibernate.cfg.Mappings

narrowProxy(Object, EntityPersister, EntityKey, Object) - Method in interface org.hibernate.engine.PersistenceContext
If the existing proxy is insufficiently "narrow" (derived), instantiate a new proxy and overwrite the registration of the old one.
narrowProxy(Object, EntityPersister, EntityKey, Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
If the existing proxy is insufficiently "narrow" (derived), instantiate a new proxy and overwrite the registration of the old one.
naturalId() - Static method in class org.hibernate.criterion.Restrictions

ne(Object) - Method in class org.hibernate.criterion.Property

ne(DetachedCriteria) - Method in class org.hibernate.criterion.Property

ne(String, Object) - Static method in class org.hibernate.criterion.Restrictions
Apply a "not equal" constraint to the named property
ne(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

neProperty(Property) - Method in class org.hibernate.criterion.Property

neProperty(String) - Method in class org.hibernate.criterion.Property

neProperty(String, String) - Static method in class org.hibernate.criterion.Restrictions
Apply a "not equal" constraint to two properties
needsExecutor() - Method in class org.hibernate.hql.ast.tree.DeleteStatement

needsExecutor() - Method in class org.hibernate.hql.ast.tree.InsertStatement

needsExecutor() - Method in class org.hibernate.hql.ast.tree.QueryNode

needsExecutor() - Method in interface org.hibernate.hql.ast.tree.Statement
Does this statement require the StatementExecutor?
needsExecutor() - Method in class org.hibernate.hql.ast.tree.UpdateStatement

needsFetchingScroll() - Method in class org.hibernate.loader.Loader
Does the result set to be scrolled contain collection fetches?
needsFetchingScroll() - Method in class org.hibernate.loader.hql.QueryLoader

needsInserting(Object, int, Type) - Method in class org.hibernate.collection.PersistentArrayHolder

needsInserting(Object, int, Type) - Method in class org.hibernate.collection.PersistentBag

needsInserting(Object, int, Type) - Method in interface org.hibernate.collection.PersistentCollection
Do we need to insert this element?
needsInserting(Object, int, Type) - Method in class org.hibernate.collection.PersistentElementHolder

needsInserting(Object, int, Type) - Method in class org.hibernate.collection.PersistentIdentifierBag

needsInserting(Object, int, Type) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

needsInserting(Object, int, Type) - Method in class org.hibernate.collection.PersistentList

needsInserting(Object, int, Type) - Method in class org.hibernate.collection.PersistentMap

needsInserting(Object, int, Type) - Method in class org.hibernate.collection.PersistentSet

needsRecreate(CollectionPersister) - Method in class org.hibernate.collection.AbstractPersistentCollection
Do we need to completely recreate this collection when it changes?
needsRecreate(CollectionPersister) - Method in class org.hibernate.collection.PersistentBag

needsRecreate(CollectionPersister) - Method in interface org.hibernate.collection.PersistentCollection
Do we need to completely recreate this collection when it changes?
needsUpdating(Object, int, Type) - Method in class org.hibernate.collection.PersistentArrayHolder

needsUpdating(Object, int, Type) - Method in class org.hibernate.collection.PersistentBag

needsUpdating(Object, int, Type) - Method in interface org.hibernate.collection.PersistentCollection
Do we need to update this element?
needsUpdating(Object, int, Type) - Method in class org.hibernate.collection.PersistentElementHolder

needsUpdating(Object, int, Type) - Method in class org.hibernate.collection.PersistentIdentifierBag

needsUpdating(Object, int, Type) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

needsUpdating(Object, int, Type) - Method in class org.hibernate.collection.PersistentList

needsUpdating(Object, int, Type) - Method in class org.hibernate.collection.PersistentMap

needsUpdating(Object, int, Type) - Method in class org.hibernate.collection.PersistentSet

negateNode(AST) - Method in class org.hibernate.hql.antlr.HqlBaseParser
Returns the negated equivalent of the expression.
negateNode(AST) - Method in class org.hibernate.hql.ast.HqlParser
Returns an equivalent tree for (NOT (a relop b) ), for example:
negatedExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

nestedExpr(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

nestedExprAfterMinusDiv(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

nestedFromFragment(AST, AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

nestedFromFragment(AST, AST) - Method in class org.hibernate.hql.ast.SqlGenerator

newConnectionProvider() - Static method in class org.hibernate.connection.ConnectionProviderFactory
Instantiate a ConnectionProvider using System properties.
newConnectionProvider(Properties) - Static method in class org.hibernate.connection.ConnectionProviderFactory
Instantiate a ConnectionProvider using given properties.
newConnectionProvider(Properties, Map) - Static method in class org.hibernate.connection.ConnectionProviderFactory
Instantiate a ConnectionProvider using given properties.
newExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

newInstance() - Method in interface org.hibernate.bytecode.ReflectionOptimizer.InstantiationOptimizer
Perform instantiation of an instance of the underlying class.
newInstance() - Method in class org.hibernate.bytecode.cglib.InstantiationOptimizerAdapter

newInstance() - Method in class org.hibernate.bytecode.javassist.FastClass

newInstance(Class[], Object[]) - Method in class org.hibernate.bytecode.javassist.FastClass

newInstance(int, Object[]) - Method in class org.hibernate.bytecode.javassist.FastClass

newInstance() - Method in class org.hibernate.bytecode.javassist.InstantiationOptimizerAdapter

newValue() - Method in class org.hibernate.hql.antlr.HqlBaseParser

newValue(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

newerThan(DataVersion) - Method in class org.hibernate.cache.OptimisticTreeCache.CircumventChecksDataVersion

newerThan(DataVersion) - Method in class org.hibernate.cache.OptimisticTreeCache.DataVersionAdapter
newerThan() call is dispatched against the DataVersion currently associated with the node; the passed dataVersion param is the DataVersion associated with the data we are trying to put into the node.
newerThan(DataVersion) - Method in class org.hibernate.cache.OptimisticTreeCache.NonLockingDataVersion

next() - Method in interface org.hibernate.ScrollableResults
Advance to the next result
next() - Static method in class org.hibernate.cache.Timestamper

next() - Method in class org.hibernate.hql.ast.util.ASTIterator

next() - Method in class org.hibernate.hql.ast.util.ASTParentsFirstIterator

next() - Method in class org.hibernate.impl.FetchingScrollableResultsImpl
Advance to the next result
next() - Method in class org.hibernate.impl.IteratorImpl

next() - Method in class org.hibernate.impl.ScrollableResultsImpl

next() - Method in class org.hibernate.jdbc.ResultSetWrapper

next(Object, SessionImplementor) - Method in class org.hibernate.type.AbstractBynaryType

next(Object, SessionImplementor) - Method in class org.hibernate.type.ByteType

next(Object, SessionImplementor) - Method in class org.hibernate.type.CalendarType

next(Object, SessionImplementor) - Method in class org.hibernate.type.CustomType

next(Object, SessionImplementor) - Method in class org.hibernate.type.IntegerType

next(Object, SessionImplementor) - Method in class org.hibernate.type.LongType

next(Object, SessionImplementor) - Method in class org.hibernate.type.ShortType

next(Object, SessionImplementor) - Method in class org.hibernate.type.TimestampType

next(Object, SessionImplementor) - Method in interface org.hibernate.type.VersionType
Increment the version.
next(Object, SessionImplementor) - Method in interface org.hibernate.usertype.UserVersionType
Increment the version.
next() - Method in class org.hibernate.util.EmptyIterator

next() - Method in class org.hibernate.util.JoinedIterator

next() - Method in class org.hibernate.util.LazyIterator

next() - Method in class org.hibernate.util.SingletonIterator

nextFromElementCounter() - Method in class org.hibernate.hql.ast.tree.FromClause

nextNode() - Method in class org.hibernate.hql.ast.util.ASTIterator

nextNode() - Method in class org.hibernate.hql.ast.util.ASTParentsFirstIterator

nextTimestamp() - Method in interface org.hibernate.cache.Cache
Generate a timestamp
nextTimestamp() - Method in interface org.hibernate.cache.CacheProvider
Generate a timestamp
nextTimestamp() - Method in class org.hibernate.cache.EhCache
Gets the next timestamp;
nextTimestamp() - Method in class org.hibernate.cache.EhCacheProvider
Returns the next timestamp.
nextTimestamp() - Method in class org.hibernate.cache.HashtableCache

nextTimestamp() - Method in class org.hibernate.cache.HashtableCacheProvider

nextTimestamp() - Method in class org.hibernate.cache.JndiBoundTreeCacheProvider
Generate a timestamp
nextTimestamp() - Method in class org.hibernate.cache.NoCacheProvider
Generate a timestamp
nextTimestamp() - Method in class org.hibernate.cache.OSCache

nextTimestamp() - Method in class org.hibernate.cache.OSCacheProvider

nextTimestamp() - Method in class org.hibernate.cache.OptimisticTreeCache

nextTimestamp() - Method in class org.hibernate.cache.OptimisticTreeCacheProvider

nextTimestamp() - Method in class org.hibernate.cache.SwarmCache
Generate a (coarse) timestamp
nextTimestamp() - Method in class org.hibernate.cache.SwarmCacheProvider

nextTimestamp() - Method in class org.hibernate.cache.TreeCache

nextTimestamp() - Method in class org.hibernate.cache.TreeCacheProvider

nextToken() - Method in class org.hibernate.hql.antlr.HqlBaseLexer

noCascade(EventSource, Object, Object, EntityPersister, int) - Method in class org.hibernate.engine.CascadingAction
Called (in the case of CascadingAction.requiresNoCascadeChecking() returning true) to validate that no cascade on the given property is considered a valid semantic.
node(int) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

node(int) - Method in class org.hibernate.tuple.ElementWrapper

nodeCount() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

nodeCount() - Method in class org.hibernate.tuple.ElementWrapper

nodeIterator() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

nodeIterator() - Method in class org.hibernate.tuple.ElementWrapper

nodeToString(AST, boolean) - Method in class org.hibernate.hql.ast.util.ASTPrinter

normalize() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

normalize() - Method in class org.hibernate.tuple.ElementWrapper

not(Criterion) - Static method in class org.hibernate.criterion.Restrictions
Return the negation of an expression
notExists(DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

notIn(DetachedCriteria) - Method in class org.hibernate.criterion.Property

notIn(Object, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

nullSafeGet(ResultSet, String, SessionImplementor, Object) - Method in class org.hibernate.type.AnyType

nullSafeGet(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.AnyType

nullSafeGet(ResultSet, String, SessionImplementor, Object) - Method in class org.hibernate.type.BlobType

nullSafeGet(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.BlobType

nullSafeGet(ResultSet, String, SessionImplementor, Object) - Method in class org.hibernate.type.ClobType

nullSafeGet(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.ClobType

nullSafeGet(ResultSet, String, SessionImplementor, Object) - Method in class org.hibernate.type.CollectionType

nullSafeGet(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.CollectionType

nullSafeGet(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.ComponentType

nullSafeGet(ResultSet, String, SessionImplementor, Object) - Method in class org.hibernate.type.ComponentType

nullSafeGet(ResultSet, String, SessionImplementor, Object) - Method in class org.hibernate.type.CompositeCustomType

nullSafeGet(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.CompositeCustomType

nullSafeGet(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.CustomType

nullSafeGet(ResultSet, String, SessionImplementor, Object) - Method in class org.hibernate.type.CustomType

nullSafeGet(ResultSet, String, SessionImplementor, Object) - Method in class org.hibernate.type.EntityType

nullSafeGet(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.EntityType

nullSafeGet(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.MetaType

nullSafeGet(ResultSet, String, SessionImplementor, Object) - Method in class org.hibernate.type.MetaType

nullSafeGet(ResultSet, String[], SessionImplementor, Object) - Method in class org.hibernate.type.NullableType

nullSafeGet(ResultSet, String[]) - Method in class org.hibernate.type.NullableType

nullSafeGet(ResultSet, String) - Method in class org.hibernate.type.NullableType

nullSafeGet(ResultSet, String, SessionImplementor, Object) - Method in class org.hibernate.type.NullableType

nullSafeGet(ResultSet, String[], SessionImplementor, Object) - Method in interface org.hibernate.type.Type
Retrieve an instance of the mapped class from a JDBC resultset.
nullSafeGet(ResultSet, String, SessionImplementor, Object) - Method in interface org.hibernate.type.Type
Retrieve an instance of the mapped class from a JDBC resultset.
nullSafeGet(ResultSet, String[], SessionImplementor, Object) - Method in interface org.hibernate.usertype.CompositeUserType
Retrieve an instance of the mapped class from a JDBC resultset.
nullSafeGet(ResultSet, String[], Object) - Method in interface org.hibernate.usertype.UserType
Retrieve an instance of the mapped class from a JDBC resultset.
nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.AnyType

nullSafeSet(PreparedStatement, Object, int, boolean[], SessionImplementor) - Method in class org.hibernate.type.AnyType

nullSafeSet(PreparedStatement, Object, int, boolean[], SessionImplementor) - Method in class org.hibernate.type.BlobType

nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.BlobType

nullSafeSet(PreparedStatement, Object, int, boolean[], SessionImplementor) - Method in class org.hibernate.type.ClobType

nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.ClobType

nullSafeSet(PreparedStatement, Object, int, boolean[], SessionImplementor) - Method in class org.hibernate.type.CollectionType

nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.CollectionType

nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.ComponentType

nullSafeSet(PreparedStatement, Object, int, boolean[], SessionImplementor) - Method in class org.hibernate.type.ComponentType

nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.CompositeCustomType

nullSafeSet(PreparedStatement, Object, int, boolean[], SessionImplementor) - Method in class org.hibernate.type.CompositeCustomType

nullSafeSet(PreparedStatement, Object, int, boolean[], SessionImplementor) - Method in class org.hibernate.type.CustomType

nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.CustomType

nullSafeSet(PreparedStatement, Object, int, boolean[], SessionImplementor) - Method in class org.hibernate.type.ManyToOneType

nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.ManyToOneType

nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.MetaType

nullSafeSet(PreparedStatement, Object, int, boolean[], SessionImplementor) - Method in class org.hibernate.type.MetaType

nullSafeSet(PreparedStatement, Object, int, boolean[], SessionImplementor) - Method in class org.hibernate.type.NullableType

nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.NullableType

nullSafeSet(PreparedStatement, Object, int) - Method in class org.hibernate.type.NullableType

nullSafeSet(PreparedStatement, Object, int, boolean[], SessionImplementor) - Method in class org.hibernate.type.OneToOneType

nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.OneToOneType

nullSafeSet(PreparedStatement, Object, int, boolean[], SessionImplementor) - Method in interface org.hibernate.type.Type
Write an instance of the mapped class to a prepared statement, ignoring some columns.
nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in interface org.hibernate.type.Type
Write an instance of the mapped class to a prepared statement.
nullSafeSet(PreparedStatement, Object, int, SessionImplementor) - Method in interface org.hibernate.usertype.CompositeUserType
Write an instance of the mapped class to a prepared statement.
nullSafeSet(PreparedStatement, Object, int) - Method in interface org.hibernate.usertype.UserType
Write an instance of the mapped class to a prepared statement.
nullifyTransientReferences(Object[], Type[]) - Method in class org.hibernate.engine.ForeignKeys.Nullifier
Nullify all references to entities that have not yet been inserted in the database, where the foreign key points toward that entity
numberOfCollectionCreations() - Method in class org.hibernate.engine.ActionQueue

numberOfCollectionRemovals() - Method in class org.hibernate.engine.ActionQueue

numberOfCollectionUpdates() - Method in class org.hibernate.engine.ActionQueue

numberOfDeletions() - Method in class org.hibernate.engine.ActionQueue

numberOfInsertions() - Method in class org.hibernate.engine.ActionQueue

numberOfUpdates() - Method in class org.hibernate.engine.ActionQueue

numberValueOf(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

numberValueOf(String) - Method in class org.hibernate.tuple.ElementWrapper

numericInteger(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

nyi(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

O

OBJECT - Static variable in class org.hibernate.Hibernate
Hibernate object type.
OBJECT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

OBJECT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

OBJECT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

OC4JTransactionManagerLookup - class org.hibernate.transaction.OC4JTransactionManagerLookup.
TransactionManagerLookup for the OC4J (Oracle) app-server.
OC4JTransactionManagerLookup() - Constructor for class org.hibernate.transaction.OC4JTransactionManagerLookup

OF - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

OF - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

OF - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ON - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ON - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ON - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ONE_MS - Static variable in class org.hibernate.cache.Timestamper

ON_CLOSE - Static variable in class org.hibernate.ConnectionReleaseMode
Indicates that connections should only be released when the Session is explicitly closed or disconnected; this is the legacy (Hibernate2 and pre-3.1) behavior.
OPEN - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

OPEN - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

OPEN - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

OPEN_BRACKET - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

OPEN_BRACKET - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

OPEN_BRACKET - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

OPTIMISTIC_LOCK_ALL - Static variable in class org.hibernate.engine.Versioning

OPTIMISTIC_LOCK_DIRTY - Static variable in class org.hibernate.engine.Versioning

OPTIMISTIC_LOCK_NONE - Static variable in class org.hibernate.engine.Versioning

OPTIMISTIC_LOCK_VERSION - Static variable in class org.hibernate.engine.Versioning

OR - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

OR - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

OR - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ORDER - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ORDER - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ORDER - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ORDER_ELEMENT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ORDER_ELEMENT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ORDER_ELEMENT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

ORDER_UPDATES - Static variable in class org.hibernate.cfg.Environment
Enable ordering of update statements by primary key value
OSCACHE_CAPACITY - Static variable in class org.hibernate.cache.OSCacheProvider
The OSCache cache capacity property suffix.
OSCACHE_CRON - Static variable in class org.hibernate.cache.OSCacheProvider
The OSCache CRON expression property suffix.
OSCACHE_REFRESH_PERIOD - Static variable in class org.hibernate.cache.OSCacheProvider
The OSCache refresh period property suffix.
OSCache - class org.hibernate.cache.OSCache.

OSCache(int, String, String) - Constructor for class org.hibernate.cache.OSCache

OSCacheProvider - class org.hibernate.cache.OSCacheProvider.
Support for OpenSymphony OSCache.
OSCacheProvider() - Constructor for class org.hibernate.cache.OSCacheProvider

OUTER - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

OUTER - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

OUTER - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

OUTPUT_STYLESHEET - Static variable in class org.hibernate.cfg.Environment
An XSLT resource used to generate "custom" XML
OVERWRITE - Static variable in class org.hibernate.ReplicationMode
Overwrite existing rows when a row already exists.
ObjectDeletedException - exception org.hibernate.ObjectDeletedException.
Thrown when the user tries to do something illegal with a deleted object.
ObjectDeletedException(String, Serializable, String) - Constructor for class org.hibernate.ObjectDeletedException

ObjectNotFoundException - exception org.hibernate.ObjectNotFoundException.
Thrown when Session.load() fails to select a row with the given primary key (identifier value).
ObjectNotFoundException(Serializable, String) - Constructor for class org.hibernate.ObjectNotFoundException

OnLockVisitor - class org.hibernate.event.def.OnLockVisitor.
When a transient entity is passed to lock(), we must inspect all its collections and 1.
OnLockVisitor(EventSource, Serializable) - Constructor for class org.hibernate.event.def.OnLockVisitor

OnReplicateVisitor - class org.hibernate.event.def.OnReplicateVisitor.
When an entity is passed to replicate(), and there is an existing row, we must inspect all its collections and 1.
OnUpdateVisitor - class org.hibernate.event.def.OnUpdateVisitor.
When an entity is passed to update(), we must inspect all its collections and 1.
OneToMany - class org.hibernate.mapping.OneToMany.
A mapping for a one-to-many association
OneToMany(PersistentClass) - Constructor for class org.hibernate.mapping.OneToMany

OneToManyJoinWalker - class org.hibernate.loader.collection.OneToManyJoinWalker.
Walker for one-to-many associations
OneToManyJoinWalker(QueryableCollection, int, String, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.collection.OneToManyJoinWalker

OneToManyLoader - class org.hibernate.loader.collection.OneToManyLoader.
Loads one-to-many associations

The collection persister must implement QueryableCOllection.
OneToManyLoader(QueryableCollection, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.collection.OneToManyLoader

OneToManyLoader(QueryableCollection, int, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.collection.OneToManyLoader

OneToManyLoader(QueryableCollection, int, String, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.collection.OneToManyLoader

OneToManyPersister - class org.hibernate.persister.collection.OneToManyPersister.
Collection persister for one-to-many associations.
OneToManyPersister(Collection, CacheConcurrencyStrategy, Configuration, SessionFactoryImplementor) - Constructor for class org.hibernate.persister.collection.OneToManyPersister

OneToOne - class org.hibernate.mapping.OneToOne.
A one-to-one association mapping
OneToOne(Table, PersistentClass) - Constructor for class org.hibernate.mapping.OneToOne

OneToOneType - class org.hibernate.type.OneToOneType.
A one-to-one association to an entity
OneToOneType(String, ForeignKeyDirection, String, boolean, boolean, boolean, String, String) - Constructor for class org.hibernate.type.OneToOneType

OperatorNode - interface org.hibernate.hql.ast.tree.OperatorNode.
Contract for nodes representing operators (logic or arithmetic).
OptimisticCache - interface org.hibernate.cache.OptimisticCache.
A contract for transactional cache implementations which support optimistic locking of items within the cache.
OptimisticCacheSource - interface org.hibernate.cache.OptimisticCacheSource.
Contract for sources of optimistically lockable data sent to the second level cache.
OptimisticTreeCache - class org.hibernate.cache.OptimisticTreeCache.
Represents a particular region within the given JBossCache TreeCache utilizing TreeCache's optimistic locking capabilities.
OptimisticTreeCache(TreeCache, String) - Constructor for class org.hibernate.cache.OptimisticTreeCache

OptimisticTreeCache.CircumventChecksDataVersion - class org.hibernate.cache.OptimisticTreeCache.CircumventChecksDataVersion.
Used to signal to a DataVersionAdapter to simply not perform any checks.
OptimisticTreeCache.CircumventChecksDataVersion() - Constructor for class org.hibernate.cache.OptimisticTreeCache.CircumventChecksDataVersion

OptimisticTreeCache.DataVersionAdapter - class org.hibernate.cache.OptimisticTreeCache.DataVersionAdapter.

OptimisticTreeCache.DataVersionAdapter(Object, Object, Comparator, String) - Constructor for class org.hibernate.cache.OptimisticTreeCache.DataVersionAdapter

OptimisticTreeCache.NonLockingDataVersion - class org.hibernate.cache.OptimisticTreeCache.NonLockingDataVersion.
Used in regions where no locking should ever occur.
OptimisticTreeCache.NonLockingDataVersion() - Constructor for class org.hibernate.cache.OptimisticTreeCache.NonLockingDataVersion

OptimisticTreeCacheProvider - class org.hibernate.cache.OptimisticTreeCacheProvider.
Support for a standalone JBossCache TreeCache instance utilizing TreeCache's optimistic locking capabilities.
OptimisticTreeCacheProvider() - Constructor for class org.hibernate.cache.OptimisticTreeCacheProvider

Oracle9Dialect - class org.hibernate.dialect.Oracle9Dialect.
An SQL dialect for Oracle 9 (uses ANSI-style syntax where possible).
Oracle9Dialect() - Constructor for class org.hibernate.dialect.Oracle9Dialect

OracleDialect - class org.hibernate.dialect.OracleDialect.
An SQL dialect for Oracle, compatible with Oracle 8.
OracleDialect() - Constructor for class org.hibernate.dialect.OracleDialect

OracleJoinFragment - class org.hibernate.sql.OracleJoinFragment.
An Oracle-style (theta) join
OracleJoinFragment() - Constructor for class org.hibernate.sql.OracleJoinFragment

Order - class org.hibernate.criterion.Order.
Represents an order imposed upon a Criteria result set
Order(String, boolean) - Constructor for class org.hibernate.criterion.Order
Constructor for Order.
OrderByClause - class org.hibernate.hql.ast.tree.OrderByClause.
Implementation of OrderByClause.
OrderByClause() - Constructor for class org.hibernate.hql.ast.tree.OrderByClause

OrderByParser - class org.hibernate.hql.classic.OrderByParser.
Parses the ORDER BY clause of a query
OrderByParser() - Constructor for class org.hibernate.hql.classic.OrderByParser

OrderedMapType - class org.hibernate.type.OrderedMapType.

OrderedMapType(String, String, boolean) - Constructor for class org.hibernate.type.OrderedMapType

OrderedSetType - class org.hibernate.type.OrderedSetType.

OrderedSetType(String, String, boolean) - Constructor for class org.hibernate.type.OrderedSetType

OrdinalParameterDescriptor - class org.hibernate.engine.query.OrdinalParameterDescriptor.

OrdinalParameterDescriptor(int, Type, int) - Constructor for class org.hibernate.engine.query.OrdinalParameterDescriptor

OrionTransactionManagerLookup - class org.hibernate.transaction.OrionTransactionManagerLookup.
TransactionManager lookup strategy for Orion
OrionTransactionManagerLookup() - Constructor for class org.hibernate.transaction.OrionTransactionManagerLookup

OuterJoinLoadable - interface org.hibernate.persister.entity.OuterJoinLoadable.
A EntityPersister that may be loaded by outer join using the OuterJoinLoader hierarchy and may be an element of a one-to-many association.
OuterJoinLoader - class org.hibernate.loader.OuterJoinLoader.
Implements logic for walking a tree of associated classes.
OuterJoinLoader(SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.OuterJoinLoader

OuterJoinableAssociation - class org.hibernate.loader.OuterJoinableAssociation.

OuterJoinableAssociation(AssociationType, String, String[], String, int, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.OuterJoinableAssociation

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.AbstractCharArrayType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.BigIntegerType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.BooleanType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.ByteType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.CharBooleanType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.CharacterType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.CurrencyType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.CustomType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.DateType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.DoubleType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.FloatType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.IntegerType

objectToSQLString(Object, Dialect) - Method in interface org.hibernate.type.LiteralType
String representation of the value, suitable for embedding in an SQL statement.
objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.LocaleType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.LongType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.ShortType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.StringType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.TimeType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.TimeZoneType

objectToSQLString(Object, Dialect) - Method in class org.hibernate.type.TimestampType

objectToSQLString(Object) - Method in interface org.hibernate.usertype.EnhancedUserType
Return an SQL literal representation of the value
occurrences(Object) - Method in class org.hibernate.collection.PersistentBag

onAutoFlush(AutoFlushEvent) - Method in interface org.hibernate.event.AutoFlushEventListener
Handle the given auto-flush event.
onAutoFlush(AutoFlushEvent) - Method in class org.hibernate.event.def.DefaultAutoFlushEventListener
Handle the given auto-flush event.
onCollectionRecreate(Object, Serializable) - Method in class org.hibernate.EmptyInterceptor

onCollectionRecreate(Object, Serializable) - Method in interface org.hibernate.Interceptor
Called before a collection is (re)created.
onCollectionRemove(Object, Serializable) - Method in class org.hibernate.EmptyInterceptor

onCollectionRemove(Object, Serializable) - Method in interface org.hibernate.Interceptor
Called before a collection is deleted.
onCollectionUpdate(Object, Serializable) - Method in class org.hibernate.EmptyInterceptor

onCollectionUpdate(Object, Serializable) - Method in interface org.hibernate.Interceptor
Called before a collection is updated.
onDelete(Object, Serializable, Object[], String[], Type[]) - Method in class org.hibernate.EmptyInterceptor

onDelete(Object, Serializable, Object[], String[], Type[]) - Method in interface org.hibernate.Interceptor
Called before an object is deleted.
onDelete(Session) - Method in interface org.hibernate.classic.Lifecycle
Called when an entity is deleted.
onDelete(DeleteEvent) - Method in interface org.hibernate.event.DeleteEventListener
Handle the given delete event.
onDelete(DeleteEvent, Set) - Method in interface org.hibernate.event.DeleteEventListener

onDelete(DeleteEvent) - Method in class org.hibernate.event.def.DefaultDeleteEventListener
Handle the given delete event.
onDelete(DeleteEvent, Set) - Method in class org.hibernate.event.def.DefaultDeleteEventListener

onDirtyCheck(DirtyCheckEvent) - Method in interface org.hibernate.event.DirtyCheckEventListener
Handle the given dirty-check event.
onDirtyCheck(DirtyCheckEvent) - Method in class org.hibernate.event.def.DefaultDirtyCheckEventListener
Handle the given dirty-check event.
onEvict(EvictEvent) - Method in interface org.hibernate.event.EvictEventListener
Handle the given evict event.
onEvict(EvictEvent) - Method in class org.hibernate.event.def.DefaultEvictEventListener
Handle the given evict event.
onFlush(FlushEvent) - Method in interface org.hibernate.event.FlushEventListener
Handle the given flush event.
onFlush(FlushEvent) - Method in class org.hibernate.event.def.DefaultFlushEventListener
Handle the given flush event.
onFlushDirty(Object, Serializable, Object[], Object[], String[], Type[]) - Method in class org.hibernate.EmptyInterceptor

onFlushDirty(Object, Serializable, Object[], Object[], String[], Type[]) - Method in interface org.hibernate.Interceptor
Called when an object is detected to be dirty, during a flush.
onFlushEntity(FlushEntityEvent) - Method in interface org.hibernate.event.FlushEntityEventListener

onFlushEntity(FlushEntityEvent) - Method in class org.hibernate.event.def.DefaultFlushEntityEventListener
Flushes a single entity's state to the database, by scheduling an update action, if necessary
onInitializeCollection(InitializeCollectionEvent) - Method in interface org.hibernate.event.InitializeCollectionEventListener

onInitializeCollection(InitializeCollectionEvent) - Method in class org.hibernate.event.def.DefaultInitializeCollectionEventListener
called by a collection that wants to initialize itself
onLoad(Object, Serializable, Object[], String[], Type[]) - Method in class org.hibernate.EmptyInterceptor

onLoad(Object, Serializable, Object[], String[], Type[]) - Method in interface org.hibernate.Interceptor
Called just before an object is initialized.
onLoad(Session, Serializable) - Method in interface org.hibernate.classic.Lifecycle
Called after an entity is loaded.
onLoad(LoadEvent, LoadEventListener.LoadType) - Method in interface org.hibernate.event.LoadEventListener
Handle the given load event.
onLoad(LoadEvent, LoadEventListener.LoadType) - Method in class org.hibernate.event.def.DefaultLoadEventListener
Handle the given load event.
onLock(LockEvent) - Method in interface org.hibernate.event.LockEventListener
Handle the given lock event.
onLock(LockEvent) - Method in class org.hibernate.event.def.DefaultLockEventListener
Handle the given lock event.
onMerge(MergeEvent) - Method in interface org.hibernate.event.MergeEventListener
Handle the given merge event.
onMerge(MergeEvent, Map) - Method in interface org.hibernate.event.MergeEventListener
Handle the given merge event.
onMerge(MergeEvent) - Method in class org.hibernate.event.def.DefaultMergeEventListener
Handle the given merge event.
onMerge(MergeEvent, Map) - Method in class org.hibernate.event.def.DefaultMergeEventListener
Handle the given merge event.
onPersist(PersistEvent) - Method in interface org.hibernate.event.PersistEventListener
Handle the given create event.
onPersist(PersistEvent, Map) - Method in interface org.hibernate.event.PersistEventListener
Handle the given create event.
onPersist(PersistEvent) - Method in class org.hibernate.event.def.DefaultPersistEventListener
Handle the given create event.
onPersist(PersistEvent, Map) - Method in class org.hibernate.event.def.DefaultPersistEventListener
Handle the given create event.
onPostDelete(PostDeleteEvent) - Method in interface org.hibernate.event.PostDeleteEventListener

onPostInsert(PostInsertEvent) - Method in interface org.hibernate.event.PostInsertEventListener

onPostLoad(PostLoadEvent) - Method in interface org.hibernate.event.PostLoadEventListener

onPostLoad(PostLoadEvent) - Method in class org.hibernate.event.def.DefaultPostLoadEventListener

onPostUpdate(PostUpdateEvent) - Method in interface org.hibernate.event.PostUpdateEventListener

onPreDelete(PreDeleteEvent) - Method in interface org.hibernate.event.PreDeleteEventListener

onPreDelete(PreDeleteEvent) - Method in class org.hibernate.secure.JACCPreDeleteEventListener

onPreInsert(PreInsertEvent) - Method in interface org.hibernate.event.PreInsertEventListener

onPreInsert(PreInsertEvent) - Method in class org.hibernate.secure.JACCPreInsertEventListener

onPreLoad(PreLoadEvent) - Method in interface org.hibernate.event.PreLoadEventListener

onPreLoad(PreLoadEvent) - Method in class org.hibernate.event.def.DefaultPreLoadEventListener

onPreLoad(PreLoadEvent) - Method in class org.hibernate.secure.JACCPreLoadEventListener

onPreUpdate(PreUpdateEvent) - Method in interface org.hibernate.event.PreUpdateEventListener

onPreUpdate(PreUpdateEvent) - Method in class org.hibernate.secure.JACCPreUpdateEventListener

onPrepareStatement(String) - Method in class org.hibernate.EmptyInterceptor

onPrepareStatement(String) - Method in interface org.hibernate.Interceptor
Called when sql string is being prepared.
onRefresh(RefreshEvent) - Method in interface org.hibernate.event.RefreshEventListener
Handle the given refresh event.
onRefresh(RefreshEvent, Map) - Method in interface org.hibernate.event.RefreshEventListener

onRefresh(RefreshEvent) - Method in class org.hibernate.event.def.DefaultRefreshEventListener

onRefresh(RefreshEvent, Map) - Method in class org.hibernate.event.def.DefaultRefreshEventListener
Handle the given refresh event.
onReplicate(ReplicateEvent) - Method in interface org.hibernate.event.ReplicateEventListener
Handle the given replicate event.
onReplicate(ReplicateEvent) - Method in class org.hibernate.event.def.DefaultReplicateEventListener
Handle the given replicate event.
onSave(Object, Serializable, Object[], String[], Type[]) - Method in class org.hibernate.EmptyInterceptor

onSave(Object, Serializable, Object[], String[], Type[]) - Method in interface org.hibernate.Interceptor
Called before an object is saved.
onSave(Session) - Method in interface org.hibernate.classic.Lifecycle
Called when an entity is saved.
onSaveOrUpdate(SaveOrUpdateEvent) - Method in interface org.hibernate.event.SaveOrUpdateEventListener
Handle the given update event.
onSaveOrUpdate(SaveOrUpdateEvent) - Method in class org.hibernate.event.def.DefaultSaveOrUpdateEventListener
Handle the given update event.
onUpdate(Session) - Method in interface org.hibernate.classic.Lifecycle
Called when an entity is passed to Session.update().
oneToManyFilterFragment(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

oneToManyFilterFragment(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

oneToManyFilterFragment(String) - Method in interface org.hibernate.persister.entity.Joinable

oneToManyFilterFragment(String) - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

oneToOne(String, ForeignKeyDirection, String, boolean, boolean, boolean, String, String) - Static method in class org.hibernate.type.TypeFactory
A one-to-one association type for the given class
openConnection() - Method in class org.hibernate.jdbc.AbstractBatcher

openConnection() - Method in interface org.hibernate.jdbc.Batcher
Obtain a JDBC connection
openQuote() - Method in class org.hibernate.dialect.Dialect
The opening quote for a quoted identifier
openQuote() - Method in class org.hibernate.dialect.MySQLDialect

openQuote() - Method in class org.hibernate.dialect.SQLServerDialect

openResourceStatsAsString() - Method in class org.hibernate.jdbc.AbstractBatcher

openResourceStatsAsString() - Method in interface org.hibernate.jdbc.Batcher

openSession(Connection) - Method in interface org.hibernate.SessionFactory
Open a Session on the given connection.
openSession(Interceptor) - Method in interface org.hibernate.SessionFactory
Create database connection and open a Session on it, specifying an interceptor.
openSession(Connection, Interceptor) - Method in interface org.hibernate.SessionFactory
Open a Session on the given connection, specifying an interceptor.
openSession() - Method in interface org.hibernate.SessionFactory
Create database connection and open a Session on it.
openSession(Connection, boolean, boolean, ConnectionReleaseMode) - Method in interface org.hibernate.engine.SessionFactoryImplementor
Open a session conforming to the given parameters.
openSession(Connection, Interceptor) - Method in class org.hibernate.impl.SessionFactoryImpl

openSession(Interceptor) - Method in class org.hibernate.impl.SessionFactoryImpl

openSession(Connection) - Method in class org.hibernate.impl.SessionFactoryImpl

openSession() - Method in class org.hibernate.impl.SessionFactoryImpl

openSession(Connection, boolean, boolean, ConnectionReleaseMode) - Method in class org.hibernate.impl.SessionFactoryImpl

openSession(Connection, Interceptor) - Method in class org.hibernate.jmx.SessionFactoryStub

openSession(Interceptor) - Method in class org.hibernate.jmx.SessionFactoryStub

openSession() - Method in class org.hibernate.jmx.SessionFactoryStub

openSession(Connection) - Method in class org.hibernate.jmx.SessionFactoryStub

openSession() - Method in class org.hibernate.stat.StatisticsImpl

openSession() - Method in interface org.hibernate.stat.StatisticsImplementor

openStatelessSession() - Method in interface org.hibernate.SessionFactory
Get a new stateless session.
openStatelessSession(Connection) - Method in interface org.hibernate.SessionFactory
Get a new stateless session for the given JDBC connection.
openStatelessSession() - Method in class org.hibernate.impl.SessionFactoryImpl

openStatelessSession(Connection) - Method in class org.hibernate.impl.SessionFactoryImpl

openStatelessSession() - Method in class org.hibernate.jmx.SessionFactoryStub

openStatelessSession(Connection) - Method in class org.hibernate.jmx.SessionFactoryStub

openTemporarySession() - Method in interface org.hibernate.engine.SessionFactoryImplementor
Get a nontransactional "current" session for Hibernate EntityManager
openTemporarySession() - Method in class org.hibernate.impl.SessionFactoryImpl

operate() - Method in interface org.hibernate.collection.AbstractPersistentCollection.DelayedOperation

optimisticFailure(String) - Method in class org.hibernate.stat.StatisticsImpl

optimisticFailure(String) - Method in interface org.hibernate.stat.StatisticsImplementor

optimisticLockMode - Variable in class org.hibernate.mapping.PersistentClass

optimisticLockMode() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

optionalFromTokenFromClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

optionalSpace() - Method in class org.hibernate.hql.antlr.SqlGeneratorBase
Add a aspace if the previous token was not a space or a parenthesis.
optionalSpace() - Method in class org.hibernate.hql.ast.SqlGenerator

or(Criterion, Criterion) - Static method in class org.hibernate.criterion.Restrictions
Return the disjuction of two expressions
orderBy(List, String) - Method in class org.hibernate.loader.JoinWalker

orderBy(List) - Static method in class org.hibernate.loader.JoinWalker
Get the order by string required for collection fetching
orderByClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

orderClause(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

orderDirection(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

orderElement() - Method in class org.hibernate.hql.antlr.HqlBaseParser

orderExprs(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

orderExprs(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

orderedMap(String, String, boolean) - Static method in class org.hibernate.type.TypeFactory

orderedSet(String, String, boolean) - Static method in class org.hibernate.type.TypeFactory

ordinalParameter(int) - Method in class org.hibernate.engine.query.ParamLocationRecognizer

ordinalParameter(int) - Method in interface org.hibernate.engine.query.ParameterParser.Recognizer

ordinalParameter(int) - Method in class org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer

org.hibernate - package org.hibernate
This package defines the central Hibernate APIs.
org.hibernate.action - package org.hibernate.action
This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.bytecode - package org.hibernate.bytecode
This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib - package org.hibernate.bytecode.cglib

org.hibernate.bytecode.javassist - package org.hibernate.bytecode.javassist

org.hibernate.bytecode.util - package org.hibernate.bytecode.util

org.hibernate.cache - package org.hibernate.cache
This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cache.entry - package org.hibernate.cache.entry
This package defines formats for disassembled state kept in the second level cache.
org.hibernate.cfg - package org.hibernate.cfg
This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.classic - package org.hibernate.classic
This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.
org.hibernate.collection - package org.hibernate.collection
This package defines a framework for collection wrappers.
org.hibernate.connection - package org.hibernate.connection
This package abstracts the mechanism for obtaining a JDBC connection.
org.hibernate.context - package org.hibernate.context

org.hibernate.criterion - package org.hibernate.criterion
A framework for defining restriction criteria and order criteria.
org.hibernate.dialect - package org.hibernate.dialect
This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function - package org.hibernate.dialect.function
A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.dialect.lock - package org.hibernate.dialect.lock

org.hibernate.engine - package org.hibernate.engine
This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query - package org.hibernate.engine.query

org.hibernate.engine.query.sql - package org.hibernate.engine.query.sql

org.hibernate.engine.transaction - package org.hibernate.engine.transaction

org.hibernate.event - package org.hibernate.event
This package defines an event framework for Hibernate.
org.hibernate.event.def - package org.hibernate.event.def
This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.exception - package org.hibernate.exception
This package is a fork of Apache commons-lang nestable exceptions.
org.hibernate.hql - package org.hibernate.hql
This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.antlr - package org.hibernate.hql.antlr
A special package for ANTLR-generated parser classes.
org.hibernate.hql.ast - package org.hibernate.hql.ast
An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.exec - package org.hibernate.hql.ast.exec

org.hibernate.hql.ast.tree - package org.hibernate.hql.ast.tree

org.hibernate.hql.ast.util - package org.hibernate.hql.ast.util

org.hibernate.hql.classic - package org.hibernate.hql.classic
This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.id - package org.hibernate.id
This package contains internal implementation classes for the main API interfaces.
org.hibernate.id.insert - package org.hibernate.id.insert

org.hibernate.impl - package org.hibernate.impl
This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.intercept - package org.hibernate.intercept
This package implements an interception mechanism for lazy property fetching, based on CGLIB bytecode instrumentation.
org.hibernate.intercept.cglib - package org.hibernate.intercept.cglib

org.hibernate.intercept.javassist - package org.hibernate.intercept.javassist

org.hibernate.jdbc - package org.hibernate.jdbc
This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.jmx - package org.hibernate.jmx
This package exposes a Hibernate instance via JMX.
org.hibernate.loader - package org.hibernate.loader
This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection - package org.hibernate.loader.collection
This package defines collection initializers
org.hibernate.loader.criteria - package org.hibernate.loader.criteria
This package defines the criteria query compiler and loader
org.hibernate.loader.custom - package org.hibernate.loader.custom
This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.custom.sql - package org.hibernate.loader.custom.sql

org.hibernate.loader.entity - package org.hibernate.loader.entity
This package defines entity loaders
org.hibernate.loader.hql - package org.hibernate.loader.hql
This package defines a loader for the AST-based query parser
org.hibernate.lob - package org.hibernate.lob
This package defines dummy and wrapper implementations of java.sql.Clob and java.sql.Blob.
org.hibernate.mapping - package org.hibernate.mapping
This package defines the Hibernate configuration-time metamodel.
org.hibernate.metadata - package org.hibernate.metadata
This package defines an API for accessing the Hibernate runtime metamodel.
org.hibernate.param - package org.hibernate.param

org.hibernate.persister - package org.hibernate.persister
A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection - package org.hibernate.persister.collection
This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity - package org.hibernate.persister.entity
This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.pretty - package org.hibernate.pretty
Classes for pretty printing things for exception and log messages.
org.hibernate.property - package org.hibernate.property
This package abstracts the notion of a "property" of an entity.
org.hibernate.proxy - package org.hibernate.proxy
This package defines a framework for lazy-initializing entity proxies.
org.hibernate.proxy.dom4j - package org.hibernate.proxy.dom4j

org.hibernate.proxy.map - package org.hibernate.proxy.map

org.hibernate.proxy.pojo - package org.hibernate.proxy.pojo

org.hibernate.proxy.pojo.cglib - package org.hibernate.proxy.pojo.cglib

org.hibernate.proxy.pojo.javassist - package org.hibernate.proxy.pojo.javassist

org.hibernate.secure - package org.hibernate.secure
Declarative security for CRUD operations on entities.
org.hibernate.sql - package org.hibernate.sql
This package defines helper classes for rendering SQL fragments and SQL statements.
org.hibernate.stat - package org.hibernate.stat
This package exposes statistics about a running Hibernate instance to the application.
org.hibernate.tool.hbm2ddl - package org.hibernate.tool.hbm2ddl
The hbm2ddl tool.
org.hibernate.tool.instrument - package org.hibernate.tool.instrument
The instrument tool for adding field-interception hooks to persistent classes using built-time bytecode processing.
org.hibernate.tool.instrument.cglib - package org.hibernate.tool.instrument.cglib

org.hibernate.tool.instrument.javassist - package org.hibernate.tool.instrument.javassist

org.hibernate.transaction - package org.hibernate.transaction
This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.
org.hibernate.transform - package org.hibernate.transform
Defines strategies for post-processing criteria query result sets into a form convenient to the application.
org.hibernate.tuple - package org.hibernate.tuple
This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.component - package org.hibernate.tuple.component

org.hibernate.tuple.entity - package org.hibernate.tuple.entity

org.hibernate.type - package org.hibernate.type
A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.usertype - package org.hibernate.usertype
Interfaces for user-defined custom types.
org.hibernate.util - package org.hibernate.util
Utility classes.
other(char) - Method in class org.hibernate.engine.query.ParamLocationRecognizer

other(char) - Method in interface org.hibernate.engine.query.ParameterParser.Recognizer

other(char) - Method in class org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer

out(String) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

out(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

out(String) - Method in class org.hibernate.hql.ast.SqlGenerator

out(AST) - Method in class org.hibernate.hql.ast.SqlGenerator

outParameter(int) - Method in class org.hibernate.engine.query.ParamLocationRecognizer

outParameter(int) - Method in interface org.hibernate.engine.query.ParameterParser.Recognizer

outParameter(int) - Method in class org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer

overridesEquals - Variable in class org.hibernate.proxy.pojo.BasicLazyInitializer

overridesEquals(Class) - Static method in class org.hibernate.util.ReflectHelper

overridesHashCode(Class) - Static method in class org.hibernate.util.ReflectHelper

ownerAssociationTypes - Variable in class org.hibernate.loader.JoinWalker

ownerAssociationTypes - Variable in class org.hibernate.loader.OuterJoinLoader

owners - Variable in class org.hibernate.loader.JoinWalker

owners - Variable in class org.hibernate.loader.OuterJoinLoader

P

PARAM - Static variable in class org.hibernate.engine.ExecuteUpdateResultCheckStyle
Essentially the same as ExecuteUpdateResultCheckStyle.COUNT except that the row count actually comes from an output parameter registered as part of a CallableStatement.
PARAM - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

PARAM - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

PARAM - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

PARAM - Static variable in class org.hibernate.jdbc.Expectations

PARAMETERS - Static variable in class org.hibernate.id.SequenceGenerator
The parameters parameter, appended to the create sequence DDL.
PASS - Static variable in class org.hibernate.cfg.Environment
JDBC password
PATH_SEPARATORS - Static variable in class org.hibernate.hql.classic.ParserHelper

PERSIST - Static variable in class org.hibernate.engine.CascadeStyle
create
PERSIST - Static variable in class org.hibernate.engine.CascadingAction

PERSISTENT - Static variable in class org.hibernate.event.def.AbstractSaveEventListener

PERSIST_ON_FLUSH - Static variable in class org.hibernate.engine.CascadingAction
Execute persist during flush time
PK - Static variable in interface org.hibernate.id.PersistentIdentifierGenerator
The configuration parameter holding the primary key column name of the generated id
PK_COLUMN_NAME - Static variable in class org.hibernate.id.MultipleHiLoPerTableGenerator

PK_LENGTH_NAME - Static variable in class org.hibernate.id.MultipleHiLoPerTableGenerator

PK_VALUE_NAME - Static variable in class org.hibernate.id.MultipleHiLoPerTableGenerator

PLUS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

PLUS - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

PLUS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

POJO - Static variable in class org.hibernate.EntityMode

POOL_SIZE - Static variable in class org.hibernate.cfg.Environment
Maximum number of inactive connections for Hibernate's connection pool
POST_INSERT_INDICATOR - Static variable in class org.hibernate.id.IdentifierGeneratorFactory

PROJECTION - Static variable in interface org.hibernate.criterion.CriteriaSpecification
This result transformer is selected implicitly by calling setProjection()
PROPERTIES - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

PROPERTIES - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

PROPERTIES - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

PROPERTY_GET_EXCEPTION - Static variable in class org.hibernate.bytecode.cglib.AccessOptimizerAdapter

PROPERTY_GET_EXCEPTION - Static variable in class org.hibernate.bytecode.javassist.AccessOptimizerAdapter

PROPERTY_REF - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

PROPERTY_REF - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

PROPERTY_SET_EXCEPTION - Static variable in class org.hibernate.bytecode.cglib.AccessOptimizerAdapter

PROPERTY_SET_EXCEPTION - Static variable in class org.hibernate.bytecode.javassist.AccessOptimizerAdapter

PROXOOL_EXISTING_POOL - Static variable in class org.hibernate.cfg.Environment
Proxool property to configure the Proxool Provider from an already existing pool (true / false)
PROXOOL_POOL_ALIAS - Static variable in class org.hibernate.cfg.Environment
Proxool property with the Proxool pool alias to use (Required for PROXOOL_EXISTING_POOL, PROXOOL_PROPERTIES, or PROXOOL_XML)
PROXOOL_PREFIX - Static variable in class org.hibernate.cfg.Environment
Proxool/Hibernate property prefix
PROXOOL_PROPERTIES - Static variable in class org.hibernate.cfg.Environment
Proxool property to configure the Proxool Provider using a properties file (/path/to/proxool.properties)
PROXOOL_XML - Static variable in class org.hibernate.cfg.Environment
Proxool property to configure the Proxool Provider using an XML (/path/to/file.xml)
PUT - Static variable in class org.hibernate.CacheMode
The session will never read items from the cache, but will add items to the cache as it reads them from the database.
ParamLocationRecognizer - class org.hibernate.engine.query.ParamLocationRecognizer.
Implements a parameter parser recognizer specifically for the purpose of journaling parameter locations.
ParamLocationRecognizer() - Constructor for class org.hibernate.engine.query.ParamLocationRecognizer

ParamLocationRecognizer.NamedParameterDescription - class org.hibernate.engine.query.ParamLocationRecognizer.NamedParameterDescription.

ParamLocationRecognizer.NamedParameterDescription(boolean) - Constructor for class org.hibernate.engine.query.ParamLocationRecognizer.NamedParameterDescription

ParameterBinder - class org.hibernate.engine.ParameterBinder.
Centralizes the commonality regarding binding of parameter values into PreparedStatements as this logic is used in many places.
ParameterBinder.NamedParameterSource - interface org.hibernate.engine.ParameterBinder.NamedParameterSource.

ParameterMetadata - class org.hibernate.engine.query.ParameterMetadata.
Encapsulates metadata about parameters encountered within a query.
ParameterMetadata(OrdinalParameterDescriptor[], Map) - Constructor for class org.hibernate.engine.query.ParameterMetadata
Instantiates a ParameterMetadata container.
ParameterNode - class org.hibernate.hql.ast.tree.ParameterNode.
Implementation of ParameterNode.
ParameterNode() - Constructor for class org.hibernate.hql.ast.tree.ParameterNode

ParameterParser - class org.hibernate.engine.query.ParameterParser.
The single available method ParameterParser.parse(java.lang.String, org.hibernate.engine.query.ParameterParser.Recognizer) is responsible for parsing a query string and recognizing tokens in relation to parameters (either named, JPA-style, or ordinal) and providing callbacks about such recognitions.
ParameterParser.Recognizer - interface org.hibernate.engine.query.ParameterParser.Recognizer.

ParameterSpecification - interface org.hibernate.param.ParameterSpecification.
Maintains information relating to parameters which need to get bound into a JDBC PreparedStatement.
ParameterTranslations - interface org.hibernate.hql.ParameterTranslations.
Defines available information about the parameters encountered during query translation.
ParameterTranslationsImpl - class org.hibernate.hql.ast.ParameterTranslationsImpl.
Defines the information available for parameters encountered during query translation through the antlr-based parser.
ParameterTranslationsImpl(List) - Constructor for class org.hibernate.hql.ast.ParameterTranslationsImpl
Constructs a parameter metadata object given a list of parameter specifications.
ParameterTranslationsImpl.ParameterInfo - class org.hibernate.hql.ast.ParameterTranslationsImpl.ParameterInfo.

ParameterTranslationsImpl.ParameterInfo(int[], Type) - Constructor for class org.hibernate.hql.ast.ParameterTranslationsImpl.ParameterInfo

ParameterTranslationsImpl.ParameterInfo(int, Type) - Constructor for class org.hibernate.hql.ast.ParameterTranslationsImpl.ParameterInfo

ParameterizedType - interface org.hibernate.usertype.ParameterizedType.
Support for parameterizable types.
ParseErrorHandler - interface org.hibernate.hql.ast.ParseErrorHandler.
Defines the behavior of an error handler for the HQL parsers.
Parser - interface org.hibernate.hql.classic.Parser.
A parser is a state machine that accepts a string of tokens, bounded by start() and end() and modifies a QueryTranslator.
ParserHelper - class org.hibernate.hql.classic.ParserHelper.

PassThroughResultTransformer - class org.hibernate.transform.PassThroughResultTransformer.

PassThroughResultTransformer() - Constructor for class org.hibernate.transform.PassThroughResultTransformer

PathExpressionParser - class org.hibernate.hql.classic.PathExpressionParser.
Parses an expression of the form foo.bar.baz and builds up an expression involving two less table joins than there are path components.
PathExpressionParser() - Constructor for class org.hibernate.hql.classic.PathExpressionParser

PathHelper - class org.hibernate.hql.ast.util.PathHelper.
Provides utility methods for paths.
PathNode - interface org.hibernate.hql.ast.tree.PathNode.
An AST node with a path property.
PersistEvent - class org.hibernate.event.PersistEvent.
An event class for persist()
PersistEvent(String, Object, EventSource) - Constructor for class org.hibernate.event.PersistEvent

PersistEvent(Object, EventSource) - Constructor for class org.hibernate.event.PersistEvent

PersistEventListener - interface org.hibernate.event.PersistEventListener.
Defines the contract for handling of create events generated from a session.
PersistenceContext - interface org.hibernate.engine.PersistenceContext.
Holds the state of the persistence context, including the first-level cache, entries, snapshots, proxies, etc.
PersistentArrayHolder - class org.hibernate.collection.PersistentArrayHolder.
A persistent wrapper for an array.
PersistentArrayHolder(SessionImplementor, Object) - Constructor for class org.hibernate.collection.PersistentArrayHolder

PersistentArrayHolder(SessionImplementor, CollectionPersister) - Constructor for class org.hibernate.collection.PersistentArrayHolder

PersistentBag - class org.hibernate.collection.PersistentBag.
An unordered, unkeyed collection that can contain the same element multiple times.
PersistentBag(SessionImplementor) - Constructor for class org.hibernate.collection.PersistentBag

PersistentBag(SessionImplementor, Collection) - Constructor for class org.hibernate.collection.PersistentBag

PersistentBag() - Constructor for class org.hibernate.collection.PersistentBag

PersistentClass - class org.hibernate.mapping.PersistentClass.
Mapping for an entity.
PersistentClass() - Constructor for class org.hibernate.mapping.PersistentClass

PersistentClassVisitor - interface org.hibernate.mapping.PersistentClassVisitor.

PersistentCollection - interface org.hibernate.collection.PersistentCollection.
Persistent collections are treated as value objects by Hibernate.
PersistentElementHolder - class org.hibernate.collection.PersistentElementHolder.
A persistent wrapper for an XML element
PersistentElementHolder(SessionImplementor, Element) - Constructor for class org.hibernate.collection.PersistentElementHolder

PersistentElementHolder(SessionImplementor, CollectionPersister, Serializable) - Constructor for class org.hibernate.collection.PersistentElementHolder

PersistentIdentifierBag - class org.hibernate.collection.PersistentIdentifierBag.
An IdentifierBag implements "bag" semantics more efficiently than a regular Bag by adding a synthetic identifier column to the table.
PersistentIdentifierBag(SessionImplementor) - Constructor for class org.hibernate.collection.PersistentIdentifierBag

PersistentIdentifierBag() - Constructor for class org.hibernate.collection.PersistentIdentifierBag

PersistentIdentifierBag(SessionImplementor, Collection) - Constructor for class org.hibernate.collection.PersistentIdentifierBag

PersistentIdentifierGenerator - interface org.hibernate.id.PersistentIdentifierGenerator.
An IdentifierGenerator that requires creation of database objects.
PersistentIndexedElementHolder - class org.hibernate.collection.PersistentIndexedElementHolder.
A persistent wrapper for an XML element
PersistentIndexedElementHolder(SessionImplementor, Element) - Constructor for class org.hibernate.collection.PersistentIndexedElementHolder

PersistentIndexedElementHolder(SessionImplementor, CollectionPersister, Serializable) - Constructor for class org.hibernate.collection.PersistentIndexedElementHolder

PersistentIndexedElementHolder.IndexedValue - class org.hibernate.collection.PersistentIndexedElementHolder.IndexedValue.

PersistentList - class org.hibernate.collection.PersistentList.
A persistent wrapper for a java.util.List.
PersistentList(SessionImplementor) - Constructor for class org.hibernate.collection.PersistentList

PersistentList(SessionImplementor, List) - Constructor for class org.hibernate.collection.PersistentList

PersistentList() - Constructor for class org.hibernate.collection.PersistentList

PersistentListElementHolder - class org.hibernate.collection.PersistentListElementHolder.

PersistentListElementHolder(SessionImplementor, Element) - Constructor for class org.hibernate.collection.PersistentListElementHolder

PersistentListElementHolder(SessionImplementor, CollectionPersister, Serializable) - Constructor for class org.hibernate.collection.PersistentListElementHolder

PersistentMap - class org.hibernate.collection.PersistentMap.
A persistent wrapper for a java.util.Map.
PersistentMap() - Constructor for class org.hibernate.collection.PersistentMap
Empty constructor.
PersistentMap(SessionImplementor) - Constructor for class org.hibernate.collection.PersistentMap
Instantiates a lazy map (the underlying map is un-initialized).
PersistentMap(SessionImplementor, Map) - Constructor for class org.hibernate.collection.PersistentMap
Instantiates a non-lazy map (the underlying map is constructed from the incoming map reference).
PersistentMapElementHolder - class org.hibernate.collection.PersistentMapElementHolder.

PersistentMapElementHolder(SessionImplementor, Element) - Constructor for class org.hibernate.collection.PersistentMapElementHolder

PersistentMapElementHolder(SessionImplementor, CollectionPersister, Serializable) - Constructor for class org.hibernate.collection.PersistentMapElementHolder

PersistentObjectException - exception org.hibernate.PersistentObjectException.
Thrown when the user passes a persistent instance to a Session method that expects a transient instance.
PersistentObjectException(String) - Constructor for class org.hibernate.PersistentObjectException

PersistentSet - class org.hibernate.collection.PersistentSet.
A persistent wrapper for a java.util.Set.
PersistentSet() - Constructor for class org.hibernate.collection.PersistentSet
Empty constructor.
PersistentSet(SessionImplementor) - Constructor for class org.hibernate.collection.PersistentSet
Constructor matching super.
PersistentSet(SessionImplementor, Set) - Constructor for class org.hibernate.collection.PersistentSet
Instantiates a non-lazy set (the underlying set is constructed from the incoming set reference).
PersistentSortedMap - class org.hibernate.collection.PersistentSortedMap.
A persistent wrapper for a java.util.SortedMap.
PersistentSortedMap(SessionImplementor) - Constructor for class org.hibernate.collection.PersistentSortedMap

PersistentSortedMap(SessionImplementor, SortedMap) - Constructor for class org.hibernate.collection.PersistentSortedMap

PersistentSortedMap() - Constructor for class org.hibernate.collection.PersistentSortedMap

PersistentSortedSet - class org.hibernate.collection.PersistentSortedSet.
A persistent wrapper for a java.util.SortedSet.
PersistentSortedSet(SessionImplementor) - Constructor for class org.hibernate.collection.PersistentSortedSet

PersistentSortedSet(SessionImplementor, SortedSet) - Constructor for class org.hibernate.collection.PersistentSortedSet

PersistentSortedSet() - Constructor for class org.hibernate.collection.PersistentSortedSet

PersisterFactory - class org.hibernate.persister.PersisterFactory.
Factory for EntityPersister and CollectionPersister instances
PointbaseDialect - class org.hibernate.dialect.PointbaseDialect.
A Dialect for Pointbase.
PointbaseDialect() - Constructor for class org.hibernate.dialect.PointbaseDialect
Creates new PointbaseDialect
PojoComponentTuplizer - class org.hibernate.tuple.component.PojoComponentTuplizer.
A ComponentTuplizer specific to the pojo entity mode.
PojoComponentTuplizer(Component) - Constructor for class org.hibernate.tuple.component.PojoComponentTuplizer

PojoEntityTuplizer - class org.hibernate.tuple.entity.PojoEntityTuplizer.
An EntityTuplizer specific to the pojo entity mode.
PojoEntityTuplizer(EntityMetamodel, PersistentClass) - Constructor for class org.hibernate.tuple.entity.PojoEntityTuplizer

PojoInstantiator - class org.hibernate.tuple.PojoInstantiator.
Defines a POJO-based instantiator for use from the tuplizers.
PojoInstantiator(Component, ReflectionOptimizer.InstantiationOptimizer) - Constructor for class org.hibernate.tuple.PojoInstantiator

PojoInstantiator(PersistentClass, ReflectionOptimizer.InstantiationOptimizer) - Constructor for class org.hibernate.tuple.PojoInstantiator

PositionSubstringFunction - class org.hibernate.dialect.function.PositionSubstringFunction.
Emulation of locate() on PostgreSQL
PositionSubstringFunction() - Constructor for class org.hibernate.dialect.function.PositionSubstringFunction

PositionalParameterSpecification - class org.hibernate.param.PositionalParameterSpecification.
Relates to an explicit query positional (or ordinal) parameter.
PositionalParameterSpecification(int, int, int) - Constructor for class org.hibernate.param.PositionalParameterSpecification

PostDeleteEvent - class org.hibernate.event.PostDeleteEvent.
Occurs after deleting an item from the datastore
PostDeleteEvent(Object, Serializable, Object[], EntityPersister) - Constructor for class org.hibernate.event.PostDeleteEvent

PostDeleteEventListener - interface org.hibernate.event.PostDeleteEventListener.
Called after deleting an item from the datastore
PostInsertEvent - class org.hibernate.event.PostInsertEvent.
Occurs after inserting an item in the datastore
PostInsertEvent(Object, Serializable, Object[], EntityPersister) - Constructor for class org.hibernate.event.PostInsertEvent

PostInsertEventListener - interface org.hibernate.event.PostInsertEventListener.
Called after insterting an item in the datastore
PostInsertIdentifierGenerator - interface org.hibernate.id.PostInsertIdentifierGenerator.

PostInsertIdentityPersister - interface org.hibernate.id.PostInsertIdentityPersister.
A persister that may have an identity assigned by execution of a SQL INSERT.
PostLoadEvent - class org.hibernate.event.PostLoadEvent.
Occurs after an an entity instance is fully loaded.
PostLoadEvent(EventSource) - Constructor for class org.hibernate.event.PostLoadEvent

PostLoadEventListener - interface org.hibernate.event.PostLoadEventListener.
Occurs after an an entity instance is fully loaded.
PostUpdateEvent - class org.hibernate.event.PostUpdateEvent.
Occurs after the datastore is updated
PostUpdateEvent(Object, Serializable, Object[], Object[], EntityPersister, EventSource) - Constructor for class org.hibernate.event.PostUpdateEvent

PostUpdateEventListener - interface org.hibernate.event.PostUpdateEventListener.
Called after updating the datastore
PostgreSQLDialect - class org.hibernate.dialect.PostgreSQLDialect.
An SQL dialect for Postgres
PostgreSQLDialect() - Constructor for class org.hibernate.dialect.PostgreSQLDialect

PreDeleteEvent - class org.hibernate.event.PreDeleteEvent.
Occurs before deleting an item from the datastore
PreDeleteEvent(Object, Serializable, Object[], EntityPersister) - Constructor for class org.hibernate.event.PreDeleteEvent

PreDeleteEventListener - interface org.hibernate.event.PreDeleteEventListener.
Called before deleting an item from the datastore
PreInsertEvent - class org.hibernate.event.PreInsertEvent.
Occurs before inserting an item in the datastore
PreInsertEvent(Object, Serializable, Object[], EntityPersister, SessionImplementor) - Constructor for class org.hibernate.event.PreInsertEvent

PreInsertEventListener - interface org.hibernate.event.PreInsertEventListener.
Called before inserting an item in the datastore
PreLoadEvent - class org.hibernate.event.PreLoadEvent.
Called before injecting property values into a newly loaded entity instance.
PreLoadEvent(EventSource) - Constructor for class org.hibernate.event.PreLoadEvent

PreLoadEventListener - interface org.hibernate.event.PreLoadEventListener.
Called before injecting property values into a newly loaded entity instance.
PreUpdateEvent - class org.hibernate.event.PreUpdateEvent.
Occurs before updating the datastore
PreUpdateEvent(Object, Serializable, Object[], Object[], EntityPersister, SessionImplementor) - Constructor for class org.hibernate.event.PreUpdateEvent

PreUpdateEventListener - interface org.hibernate.event.PreUpdateEventListener.
Called before updating the datastore
PreprocessingParser - class org.hibernate.hql.classic.PreprocessingParser.

PreprocessingParser(Map) - Constructor for class org.hibernate.hql.classic.PreprocessingParser

PrimaryKey - class org.hibernate.mapping.PrimaryKey.
A primary key constraint
PrimaryKey() - Constructor for class org.hibernate.mapping.PrimaryKey

PrimitiveArray - class org.hibernate.mapping.PrimitiveArray.
A primitive array has a primary key consisting of the key columns + index column.
PrimitiveArray(PersistentClass) - Constructor for class org.hibernate.mapping.PrimitiveArray

PrimitiveType - class org.hibernate.type.PrimitiveType.
Superclass of primitive / primitive wrapper types.
PrimitiveType() - Constructor for class org.hibernate.type.PrimitiveType

Printer - class org.hibernate.pretty.Printer.
Renders entities to a nicely readable string.
Printer(SessionFactoryImplementor) - Constructor for class org.hibernate.pretty.Printer

ProgressDialect - class org.hibernate.dialect.ProgressDialect.
An SQL dialect compatible with Progress 9.1C

Connection Parameters required: hibernate.dialect org.hibernate.sql.ProgressDialect hibernate.driver com.progress.sql.jdbc.JdbcProgressDriver hibernate.url jdbc:JdbcProgress:T:host:port:dbname;WorkArounds=536870912 hibernate.username username hibernate.password password The WorkArounds parameter in the URL is required to avoid an error in the Progress 9.1C JDBC driver related to PreparedStatements.
ProgressDialect() - Constructor for class org.hibernate.dialect.ProgressDialect

Projection - interface org.hibernate.criterion.Projection.
An object-oriented representation of a query result set projection in a Criteria query.
ProjectionList - class org.hibernate.criterion.ProjectionList.

ProjectionList() - Constructor for class org.hibernate.criterion.ProjectionList

Projections - class org.hibernate.criterion.Projections.
The criterion package may be used by applications as a framework for building new kinds of Projection.
PropertiesHelper - class org.hibernate.util.PropertiesHelper.

Property - class org.hibernate.criterion.Property.
A factory for property-specific criterion and projection instances
Property(String) - Constructor for class org.hibernate.criterion.Property

Property - class org.hibernate.mapping.Property.
Represents a property as part of an entity or a component.
Property() - Constructor for class org.hibernate.mapping.Property

Property - class org.hibernate.tuple.Property.
Defines the basic contract of a Property within the runtime metamodel.
Property(String, String, Type) - Constructor for class org.hibernate.tuple.Property
Constructor for Property instances.
PropertyAccessException - exception org.hibernate.PropertyAccessException.
A problem occurred accessing a property of an instance of a persistent class by reflection, or via CGLIB.
PropertyAccessException(Throwable, String, boolean, Class, String) - Constructor for class org.hibernate.PropertyAccessException

PropertyAccessor - interface org.hibernate.property.PropertyAccessor.
Abstracts the notion of a "property".
PropertyAccessorFactory - class org.hibernate.property.PropertyAccessorFactory.
A factory for building/retrieving PropertyAccessor instances.
PropertyExpression - class org.hibernate.criterion.PropertyExpression.
superclass for comparisons between two properties (with SQL binary operators)
PropertyExpression(String, String, String) - Constructor for class org.hibernate.criterion.PropertyExpression

PropertyFactory - class org.hibernate.tuple.PropertyFactory.
Responsible for generation of runtime metamodel Property representations.
PropertyFactory() - Constructor for class org.hibernate.tuple.PropertyFactory

PropertyGeneration - class org.hibernate.mapping.PropertyGeneration.
Indicates whether given properties are generated by the database and, if so, at what time(s) they are generated.
PropertyMapping - interface org.hibernate.persister.entity.PropertyMapping.
Abstraction of all mappings that define properties: entities, collection elements.
PropertyNotFoundException - exception org.hibernate.PropertyNotFoundException.
Indicates that an expected getter or setter method could not be found on a class.
PropertyNotFoundException(String) - Constructor for class org.hibernate.PropertyNotFoundException

PropertyProjection - class org.hibernate.criterion.PropertyProjection.
A property value, or grouped property value
PropertyProjection(String, boolean) - Constructor for class org.hibernate.criterion.PropertyProjection

PropertyProjection(String) - Constructor for class org.hibernate.criterion.PropertyProjection

PropertySubqueryExpression - class org.hibernate.criterion.PropertySubqueryExpression.
A comparison between a property value in the outer query and the result of a subquery
PropertySubqueryExpression(String, String, String, DetachedCriteria) - Constructor for class org.hibernate.criterion.PropertySubqueryExpression

PropertyValueException - exception org.hibernate.PropertyValueException.
Thrown when the (illegal) value of a property can not be persisted.
PropertyValueException(String, String, String) - Constructor for class org.hibernate.PropertyValueException

ProxoolConnectionProvider - class org.hibernate.connection.ProxoolConnectionProvider.
A connection provider that uses a Proxool connection pool.
ProxoolConnectionProvider() - Constructor for class org.hibernate.connection.ProxoolConnectionProvider

ProxyFactory - interface org.hibernate.proxy.ProxyFactory.
Contract for run-time, proxy-based lazy initialization proxies.
ProxyFactoryFactory - interface org.hibernate.bytecode.ProxyFactoryFactory.
An interface for factories of proxy factory instances.
ProxyFactoryFactoryImpl - class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl.
A factory for CGLIB-based ProxyFactory instances.
ProxyFactoryFactoryImpl() - Constructor for class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl

ProxyFactoryFactoryImpl - class org.hibernate.bytecode.javassist.ProxyFactoryFactoryImpl.
A factory for Javassist-based ProxyFactory instances.
ProxyFactoryFactoryImpl() - Constructor for class org.hibernate.bytecode.javassist.ProxyFactoryFactoryImpl

ProxyFactoryFactoryImpl.BasicProxyFactoryImpl - class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl.BasicProxyFactoryImpl.

ProxyFactoryFactoryImpl.BasicProxyFactoryImpl(Class, Class[]) - Constructor for class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl.BasicProxyFactoryImpl

ProxyVisitor - class org.hibernate.event.def.ProxyVisitor.
Reassociates uninitialized proxies with the session
ProxyVisitor(EventSource) - Constructor for class org.hibernate.event.def.ProxyVisitor

panic() - Static method in class org.hibernate.hql.ast.HqlParser

panic() - Static method in class org.hibernate.hql.ast.HqlSqlWalker

panic() - Static method in class org.hibernate.hql.ast.SqlGenerator

parameter(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

parameter(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

parameterMetadata - Variable in class org.hibernate.impl.AbstractQueryImpl

parenSelect(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

parse(String) - Static method in class org.hibernate.CacheMode

parse(String) - Static method in class org.hibernate.ConnectionReleaseMode
Determine the correct ConnectionReleaseMode instance based on the given name.
parse(String) - Static method in class org.hibernate.EntityMode

parse(String) - Static method in class org.hibernate.FlushMode

parse(String) - Static method in class org.hibernate.LockMode

parse(String) - Static method in class org.hibernate.engine.ExecuteUpdateResultCheckStyle

parse(String) - Static method in class org.hibernate.engine.Status

parse(String, ParameterParser.Recognizer) - Static method in class org.hibernate.engine.query.ParameterParser
Performs the actual parsing and tokenizing of the query string making appropriate callbacks to the given recognizer upon recognition of the various tokens.
parse(Parser, String, String, QueryTranslatorImpl) - Static method in class org.hibernate.hql.classic.ParserHelper

parse(String) - Static method in class org.hibernate.mapping.PropertyGeneration

parseLocations(String) - Static method in class org.hibernate.engine.query.ParamLocationRecognizer
Convenience method for creating a param location recognizer and initiating the parse.
parseMappingElement(Element, String) - Method in class org.hibernate.cfg.Configuration

parsePath(String, ASTFactory) - Static method in class org.hibernate.hql.ast.util.PathHelper
Turns a path into an AST.
path() - Method in class org.hibernate.hql.antlr.HqlBaseParser

path(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

pathAsIdent(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

performDetachedEntityDeletionCheck(DeleteEvent) - Method in class org.hibernate.event.def.DefaultDeleteEventListener

performDiscovery(CustomLoader.Metadata, List, List) - Method in class org.hibernate.loader.custom.CustomLoader.NonScalarResultColumnProcessor

performDiscovery(CustomLoader.Metadata, List, List) - Method in class org.hibernate.loader.custom.CustomLoader.ScalarResultColumnProcessor

performExecuteUpdate(QueryParameters, SessionImplementor) - Method in class org.hibernate.engine.query.HQLQueryPlan

performExecuteUpdate(QueryParameters, SessionImplementor) - Method in class org.hibernate.engine.query.NativeSQLQueryPlan

performExecutions(EventSource) - Method in class org.hibernate.event.def.AbstractFlushingEventListener
Execute all SQL and second-level cache updates, in a special order so that foreign-key constraints cannot be violated: Inserts, in the order they were performed Updates Deletion of collection elements Insertion of collection elements Deletes, in the order they were performed
performInsert(String, SessionImplementor, Binder) - Method in class org.hibernate.id.insert.AbstractReturningDelegate

performInsert(String, SessionImplementor, Binder) - Method in class org.hibernate.id.insert.AbstractSelectingDelegate

performInsert(String, SessionImplementor, Binder) - Method in interface org.hibernate.id.insert.InsertGeneratedIdentifierDelegate
Perform the indicated insert SQL statement and determine the identifier value generated.
performIterate(QueryParameters, EventSource) - Method in class org.hibernate.engine.query.HQLQueryPlan

performList(QueryParameters, SessionImplementor) - Method in class org.hibernate.engine.query.HQLQueryPlan

performOnLazyProperty() - Method in class org.hibernate.engine.CascadingAction
Should this action be performed (or noCascade consulted) in the case of lazy properties.
performQueuedOperations() - Method in class org.hibernate.collection.AbstractPersistentCollection
After reading all existing elements from the database, add the queued elements to the underlying collection.
performSave(Object, Serializable, EntityPersister, boolean, Object, EventSource, boolean) - Method in class org.hibernate.event.def.AbstractSaveEventListener
Ppepares the save call by checking the session caches for a pre-existing entity and performing any lifecycle callbacks.
performSaveOrReplicate(Object, EntityKey, EntityPersister, boolean, Object, EventSource, boolean) - Method in class org.hibernate.event.def.AbstractSaveEventListener
Performs all the actual work needed to save an entity (well to get the save moved to the execution queue).
performSaveOrUpdate(SaveOrUpdateEvent) - Method in class org.hibernate.event.def.DefaultSaveEventListener

performSaveOrUpdate(SaveOrUpdateEvent) - Method in class org.hibernate.event.def.DefaultSaveOrUpdateEventListener

performSaveOrUpdate(SaveOrUpdateEvent) - Method in class org.hibernate.event.def.DefaultUpdateEventListener

performScroll(QueryParameters, SessionImplementor) - Method in class org.hibernate.engine.query.HQLQueryPlan

performTemporaryTableDDLInIsolation() - Method in class org.hibernate.dialect.Dialect

performUpdate(SaveOrUpdateEvent, Object, EntityPersister) - Method in class org.hibernate.event.def.DefaultSaveOrUpdateEventListener

persist(Object) - Method in interface org.hibernate.Session
Make a transient instance persistent.
persist(String, Object) - Method in interface org.hibernate.Session
Make a transient instance persistent.
persist(String, Object, Map) - Method in interface org.hibernate.event.EventSource
Cascade persist an entity instance
persist(String, Object) - Method in class org.hibernate.impl.SessionImpl

persist(Object) - Method in class org.hibernate.impl.SessionImpl

persist(String, Object, Map) - Method in class org.hibernate.impl.SessionImpl

persistOnFlush(String, Object, Map) - Method in interface org.hibernate.event.EventSource
Cascade persist an entity instance during the flush process
persistOnFlush(String, Object) - Method in class org.hibernate.impl.SessionImpl

persistOnFlush(Object) - Method in class org.hibernate.impl.SessionImpl

persistOnFlush(String, Object, Map) - Method in class org.hibernate.impl.SessionImpl

persistentClass - Variable in class org.hibernate.proxy.pojo.BasicLazyInitializer

persister - Variable in class org.hibernate.loader.entity.AbstractEntityLoader

persisters - Variable in class org.hibernate.loader.JoinWalker

persisters - Variable in class org.hibernate.loader.OuterJoinLoader

physicalToLogical - Variable in class org.hibernate.cfg.Mappings.ColumnNames

position(byte[], long) - Method in class org.hibernate.lob.BlobImpl

position(Blob, long) - Method in class org.hibernate.lob.BlobImpl

position(String, long) - Method in class org.hibernate.lob.ClobImpl

position(Clob, long) - Method in class org.hibernate.lob.ClobImpl

position(byte[], long) - Method in class org.hibernate.lob.SerializableBlob

position(Blob, long) - Method in class org.hibernate.lob.SerializableBlob

position(String, long) - Method in class org.hibernate.lob.SerializableClob

position(Clob, long) - Method in class org.hibernate.lob.SerializableClob

postAction() - Method in class org.hibernate.collection.AbstractPersistentCollection
After flushing, clear any "queued" additions, since the database state is now synchronized with the memory state.
postAction() - Method in interface org.hibernate.collection.PersistentCollection
After flushing, clear any "queued" additions, since the database state is now synchronized with the memory state.
postConstruct(Mapping) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

postDelete() - Method in class org.hibernate.engine.EntityEntry
After actually deleting a row, record the fact that the instance no longer exists in the database
postFlush(Iterator) - Method in class org.hibernate.EmptyInterceptor

postFlush(Iterator) - Method in interface org.hibernate.Interceptor
Called after a flush that actually ends in execution of the SQL statements required to synchronize in-memory state with the database.
postFlush(PersistentCollection) - Method in class org.hibernate.engine.CollectionEntry
Called after a successful flush
postFlush(SessionImplementor) - Method in class org.hibernate.event.def.AbstractFlushingEventListener
1.
postHydrate(EntityPersister, Serializable, Object[], Object, Object, LockMode, boolean, SessionImplementor) - Static method in class org.hibernate.engine.TwoPhaseLoad
Register the "hydrated" state of an entity instance, after the first step of 2-phase loading.
postInitialize(PersistentCollection) - Method in class org.hibernate.engine.CollectionEntry

postInsert() - Method in class org.hibernate.engine.EntityEntry
After actually inserting a row, record the fact that the instance exists on the database (needed for identity-column key generation)
postInstantiate() - Method in class org.hibernate.loader.BasicLoader

postInstantiate() - Method in class org.hibernate.loader.Loader
Calculate and cache select-clause suffixes.
postInstantiate() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

postInstantiate() - Method in interface org.hibernate.persister.collection.CollectionPersister

postInstantiate() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

postInstantiate() - Method in interface org.hibernate.persister.entity.EntityPersister
Finish the initialization of this object, once all ClassPersisters have been instantiated.
postInstantiate() - Method in class org.hibernate.persister.entity.SingleTableEntityPersister

postInstantiate(String, Class, Set, Method, Method, AbstractComponentType) - Method in interface org.hibernate.proxy.ProxyFactory
Called immediately after instantiation of this factory.
postInstantiate(String, Class, Set, Method, Method, AbstractComponentType) - Method in class org.hibernate.proxy.dom4j.Dom4jProxyFactory
Called immediately after instantiation
postInstantiate(String, Class, Set, Method, Method, AbstractComponentType) - Method in class org.hibernate.proxy.map.MapProxyFactory

postInstantiate(String, Class, Set, Method, Method, AbstractComponentType) - Method in class org.hibernate.proxy.pojo.cglib.CGLIBProxyFactory

postInstantiate(String, Class, Set, Method, Method, AbstractComponentType) - Method in class org.hibernate.proxy.pojo.javassist.JavassistProxyFactory

postProcessDML(RestrictableStatement) - Method in class org.hibernate.hql.ast.HqlSqlWalker

postProcessDelete(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

postProcessDelete(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

postProcessInsert(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

postProcessInsert(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

postProcessUpdate(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

postProcessUpdate(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

postUpdate(Object, Object[], Object) - Method in class org.hibernate.engine.EntityEntry
After actually updating the database, update the snapshot information, and escalate the lock mode
preFlush(Iterator) - Method in class org.hibernate.EmptyInterceptor

preFlush(Iterator) - Method in interface org.hibernate.Interceptor
Called before a flush
preFlush(PersistentCollection) - Method in class org.hibernate.engine.CollectionEntry

preInsert(CollectionPersister) - Method in class org.hibernate.collection.AbstractPersistentCollection
Called before inserting rows, to ensure that any surrogate keys are fully generated
preInsert(CollectionPersister) - Method in interface org.hibernate.collection.PersistentCollection
Called before inserting rows, to ensure that any surrogate keys are fully generated
preInsert(CollectionPersister) - Method in class org.hibernate.collection.PersistentIdentifierBag

preinvalidate(Serializable[]) - Method in class org.hibernate.cache.UpdateTimestampsCache

prepare(Properties) - Method in class org.hibernate.cache.AbstractJndiBoundCacheProvider

prepare(Properties) - Method in class org.hibernate.cache.JndiBoundTreeCacheProvider

prepare() - Method in class org.hibernate.hql.ast.tree.ConstructorNode

prepare(String, SessionImplementor) - Method in class org.hibernate.id.IdentityGenerator.GetGeneratedKeysDelegate

prepare(String, SessionImplementor) - Method in class org.hibernate.id.IdentityGenerator.InsertSelectDelegate

prepare(String, SessionImplementor) - Method in class org.hibernate.id.SequenceIdentityGenerator.Delegate

prepare(String, SessionImplementor) - Method in class org.hibernate.id.insert.AbstractReturningDelegate

prepare(PreparedStatement) - Method in interface org.hibernate.jdbc.Expectation

prepare(PreparedStatement) - Method in class org.hibernate.jdbc.Expectations.BasicExpectation

prepare(PreparedStatement) - Method in class org.hibernate.jdbc.Expectations.BasicParamExpectation

prepareActions() - Method in class org.hibernate.engine.ActionQueue
Prepares the internal action queues for execution.
prepareArithmeticOperator(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

prepareArithmeticOperator(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

prepareBatchCallableStatement(String) - Method in class org.hibernate.jdbc.AbstractBatcher

prepareBatchCallableStatement(String) - Method in interface org.hibernate.jdbc.Batcher
Get a batchable callable statement to use for inserting / deleting / updating (might be called many times before a single call to executeBatch()).
prepareBatchStatement(String) - Method in class org.hibernate.jdbc.AbstractBatcher

prepareBatchStatement(String) - Method in interface org.hibernate.jdbc.Batcher
Get a batchable prepared statement to use for inserting / deleting / updating (might be called many times before a single call to executeBatch()).
prepareCallableQueryStatement(String, boolean, ScrollMode) - Method in class org.hibernate.jdbc.AbstractBatcher

prepareCallableQueryStatement(String, boolean, ScrollMode) - Method in interface org.hibernate.jdbc.Batcher
Get a prepared statement for use in loading / querying.
prepareCallableStatement(String) - Method in class org.hibernate.jdbc.AbstractBatcher

prepareCallableStatement(String) - Method in interface org.hibernate.jdbc.Batcher
Get a non-batchable callable statement to use for inserting / deleting / updating.
prepareForAutoDiscovery(CustomLoader.Metadata) - Method in class org.hibernate.loader.custom.CustomLoader.ResultRowProcessor

prepareForDot(String) - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

prepareForDot(String) - Method in class org.hibernate.hql.ast.tree.IndexNode

prepareFromClauseInputTree(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker
Pre-process the from clause input tree.
prepareFromClauseInputTree(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

prepareIdentifierGeneratingInsert() - Method in class org.hibernate.id.IdentityGenerator.BasicDelegate

prepareIdentifierGeneratingInsert() - Method in class org.hibernate.id.IdentityGenerator.GetGeneratedKeysDelegate

prepareIdentifierGeneratingInsert() - Method in class org.hibernate.id.IdentityGenerator.InsertSelectDelegate

prepareIdentifierGeneratingInsert() - Method in class org.hibernate.id.SelectGenerator.SelectGeneratorDelegate

prepareIdentifierGeneratingInsert() - Method in class org.hibernate.id.SequenceIdentityGenerator.Delegate

prepareIdentifierGeneratingInsert() - Method in interface org.hibernate.id.insert.InsertGeneratedIdentifierDelegate
Build a Insert specific to the delegate's mode of handling generated key values.
prepareLogicOperator(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

prepareLogicOperator(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

prepareQueryStatement(String, boolean, ScrollMode) - Method in class org.hibernate.jdbc.AbstractBatcher

prepareQueryStatement(String, boolean, ScrollMode) - Method in interface org.hibernate.jdbc.Batcher
Get a prepared statement for use in loading / querying.
prepareQueryStatement(QueryParameters, boolean, SessionImplementor) - Method in class org.hibernate.loader.Loader
Obtain a PreparedStatement with all parameters pre-bound.
prepareSelectColumns(String[]) - Method in class org.hibernate.hql.ast.tree.CollectionFunction

prepareSelectColumns(String[]) - Method in class org.hibernate.hql.ast.tree.MethodNode

prepareSelectStatement(String) - Method in class org.hibernate.jdbc.AbstractBatcher

prepareSelectStatement(String) - Method in interface org.hibernate.jdbc.Batcher
Get a non-batchable prepared statement to use for selecting.
prepareStatement(String) - Method in class org.hibernate.jdbc.AbstractBatcher

prepareStatement(String, boolean) - Method in class org.hibernate.jdbc.AbstractBatcher

prepareStatement(String, String[]) - Method in class org.hibernate.jdbc.AbstractBatcher

prepareStatement(String, boolean) - Method in interface org.hibernate.jdbc.Batcher
Get a non-batchable prepared statement to use for inserting / deleting / updating, using JDBC3 getGeneratedKeys (Connection.prepareStatement(String, int)).
prepareStatement(String, String[]) - Method in interface org.hibernate.jdbc.Batcher
Get a non-batchable prepared statement to use for inserting / deleting / updating.
prepareStatement(String) - Method in interface org.hibernate.jdbc.Batcher
Get a non-batchable prepared statement to use for inserting / deleting / updating.
prepareStatement() - Method in class org.hibernate.stat.StatisticsImpl

prepareStatement() - Method in interface org.hibernate.stat.StatisticsImplementor

prepareStatement(Connection, String) - Static method in class org.hibernate.util.GetGeneratedKeysHelper

prepareStatement(Connection, String, String[]) - Static method in class org.hibernate.util.NamedGeneratedKeysHelper

prepareTemporaryTables(Mapping, Dialect) - Method in class org.hibernate.mapping.PersistentClass

prepareVersioned(AST, AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

prepareVersioned(AST, AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

prependIdColumnSpec() - Method in class org.hibernate.hql.ast.tree.IntoClause

prependVersionColumnSpec() - Method in class org.hibernate.hql.ast.tree.IntoClause

prependWhereConditions(String) - Method in class org.hibernate.sql.QuerySelect

preprocessSQL(String, QueryParameters, Dialect) - Method in class org.hibernate.loader.Loader
Modify the SQL, adding lock hints and comments, if necessary
previous() - Method in interface org.hibernate.ScrollableResults
Retreat to the previous result
previous() - Method in class org.hibernate.impl.FetchingScrollableResultsImpl
Retreat to the previous result
previous() - Method in class org.hibernate.impl.ScrollableResultsImpl

previous() - Method in class org.hibernate.jdbc.ResultSetWrapper

primaryExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

printPartialStackTrace(PrintWriter) - Method in interface org.hibernate.exception.Nestable
Prints the stack trace for this exception only--root cause not included--using the provided writer.
printPartialStackTrace(PrintWriter) - Method in class org.hibernate.exception.NestableException

printPartialStackTrace(PrintWriter) - Method in class org.hibernate.exception.NestableRuntimeException

printRootCauseStackTrace(Throwable) - Static method in class org.hibernate.exception.ExceptionUtils
Prints a compact stack trace for the root cause of a throwable to System.err.
printRootCauseStackTrace(Throwable, PrintStream) - Static method in class org.hibernate.exception.ExceptionUtils
Prints a compact stack trace for the root cause of a throwable.
printRootCauseStackTrace(Throwable, PrintWriter) - Static method in class org.hibernate.exception.ExceptionUtils
Prints a compact stack trace for the root cause of a throwable.
printStackTrace(PrintWriter) - Method in interface org.hibernate.exception.Nestable
Prints the stack trace of this exception to the specified print writer.
printStackTrace(PrintStream) - Method in interface org.hibernate.exception.Nestable
Prints the stack trace of this exception to the specified print stream.
printStackTrace() - Method in class org.hibernate.exception.NestableDelegate
Prints the stack trace of this exception the the standar error stream.
printStackTrace(PrintStream) - Method in class org.hibernate.exception.NestableDelegate
Prints the stack trace of this exception to the specified stream.
printStackTrace(PrintWriter) - Method in class org.hibernate.exception.NestableDelegate
Prints the stack trace of this exception to the specified writer.
printStackTrace() - Method in class org.hibernate.exception.NestableException

printStackTrace(PrintStream) - Method in class org.hibernate.exception.NestableException

printStackTrace(PrintWriter) - Method in class org.hibernate.exception.NestableException

printStackTrace() - Method in class org.hibernate.exception.NestableRuntimeException

printStackTrace(PrintStream) - Method in class org.hibernate.exception.NestableRuntimeException

printStackTrace(PrintWriter) - Method in class org.hibernate.exception.NestableRuntimeException

printStackTrace() - Method in class org.hibernate.hql.ast.DetailedSemanticException
Prints a stack trace.
printStackTrace(PrintStream) - Method in class org.hibernate.hql.ast.DetailedSemanticException
Prints a stack trace to the specified print stream.
printStackTrace(PrintWriter) - Method in class org.hibernate.hql.ast.DetailedSemanticException
Prints this throwable and its backtrace to the specified print writer.
process() - Method in class org.hibernate.loader.custom.sql.SQLQueryParser

process() - Method in class org.hibernate.loader.custom.sql.SQLQueryReturnProcessor

processBoolean(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

processBoolean(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

processBoolean(AST) - Method in class org.hibernate.hql.ast.util.LiteralProcessor

processClassFile(File) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

processConstant(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

processConstant(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

processConstant(AST, boolean) - Method in class org.hibernate.hql.ast.util.LiteralProcessor

processConstructor(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

processConstructor(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

processEntityPropertyValues(Object[], Type[]) - Method in class org.hibernate.event.def.AbstractVisitor
Dispatch each property value to processValue().
processEqualityExpression(AST) - Method in class org.hibernate.hql.antlr.HqlBaseParser
Returns the 'cleaned up' version of a comparison operator sub-tree.
processEqualityExpression(AST) - Method in class org.hibernate.hql.ast.HqlParser
Post process equality expressions, clean up the subtree.
processFile(File) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

processFilters(String, SessionImplementor) - Method in class org.hibernate.engine.QueryParameters

processFunction(AST, boolean) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

processFunction(AST, boolean) - Method in class org.hibernate.hql.ast.HqlSqlWalker

processIndex(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

processIndex(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

processInsertGeneratedProperties(Serializable, Object, Object[], SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

processInsertGeneratedProperties(Serializable, Object, Object[], SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Perform a select to retrieve the values of any generated properties back from the database, injecting these generated values into the given entity as well as writing this state to the PersistenceContext.
processJarFile(File) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

processJoins(QueryNode, boolean) - Method in class org.hibernate.hql.ast.util.JoinProcessor

processMemberOf(Token, AST, ASTPair) - Method in class org.hibernate.hql.antlr.HqlBaseParser

processMemberOf(Token, AST, ASTPair) - Method in class org.hibernate.hql.ast.HqlParser

processNumeric(AST) - Method in class org.hibernate.hql.ast.util.LiteralProcessor

processNumericLiteral(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

processNumericLiteral(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

processQuery(AST, AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

processQuery(AST, AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

processReachableCollection(PersistentCollection, CollectionType, Object, SessionImplementor) - Static method in class org.hibernate.engine.Collections
Initialize the role of the collection.
processUnreachableCollection(PersistentCollection, SessionImplementor) - Static method in class org.hibernate.engine.Collections
record the fact that this collection was dereferenced
processUpdateGeneratedProperties(Serializable, Object, Object[], SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

processUpdateGeneratedProperties(Serializable, Object, Object[], SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Perform a select to retrieve the values of any generated properties back from the database, injecting these generated values into the given entity as well as writing this state to the PersistenceContext.
processingInstruction(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

processingInstruction(String) - Method in class org.hibernate.tuple.ElementWrapper

processingInstructions() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

processingInstructions(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

processingInstructions() - Method in class org.hibernate.tuple.ElementWrapper

processingInstructions(String) - Method in class org.hibernate.tuple.ElementWrapper

projectionList() - Static method in class org.hibernate.criterion.Projections
Create a new projection list
promoteJoin(FromElement) - Method in class org.hibernate.hql.ast.tree.FromClause

property(String) - Static method in class org.hibernate.criterion.Projections
A projected property value
propertyEq(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyEqAll(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyFetch() - Method in class org.hibernate.hql.antlr.HqlBaseParser

propertyGe(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyGeAll(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyGeSome(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyGt(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyGtAll(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyGtSome(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyIn(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyLe(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyLeAll(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyLeSome(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyLt(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyLtAll(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyLtSome(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyMapping - Variable in class org.hibernate.persister.entity.AbstractEntityPersister

propertyName - Variable in class org.hibernate.criterion.AbstractEmptinessExpression

propertyName - Variable in class org.hibernate.criterion.AggregateProjection

propertyName(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

propertyNe(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyNotIn(String, DetachedCriteria) - Static method in class org.hibernate.criterion.Subqueries

propertyRef(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

propertyRefLhs(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

propertyReferences - Variable in class org.hibernate.cfg.Configuration

propertyReferences - Variable in class org.hibernate.cfg.Mappings

propertySelectFragment(String, String, boolean) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

propertySelectFragment(String, String, boolean) - Method in interface org.hibernate.persister.entity.Queryable
Given a query alias and an identifying suffix, render the property select fragment.
propertySpan - Variable in class org.hibernate.tuple.component.AbstractComponentTuplizer

propertySpan - Variable in class org.hibernate.tuple.entity.AbstractEntityTuplizer

propertySpan - Variable in class org.hibernate.type.ComponentType

propertyToColumnName(String) - Method in class org.hibernate.cfg.DefaultNamingStrategy
Return the unqualified property name
propertyToColumnName(String) - Method in class org.hibernate.cfg.ImprovedNamingStrategy
Return the full property path with underscore seperators, mixed case converted to underscores
propertyToColumnName(String) - Method in interface org.hibernate.cfg.NamingStrategy
Return a column name for a property path expression
propertyType - Variable in class org.hibernate.property.Dom4jAccessor.Dom4jGetter

propertyType - Variable in class org.hibernate.property.Dom4jAccessor.Dom4jSetter

proxyFor(EntityPersister, EntityKey, Object) - Method in interface org.hibernate.engine.PersistenceContext
Return the existing proxy associated with the given EntityKey, or the third argument (the entity associated with the key) if no proxy exists.
proxyFor(Object) - Method in interface org.hibernate.engine.PersistenceContext
Return the existing proxy associated with the given EntityKey, or the argument (the entity associated with the key) if no proxy exists.
proxyFor(EntityPersister, EntityKey, Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Return the existing proxy associated with the given EntityKey, or the third argument (the entity associated with the key) if no proxy exists.
proxyFor(Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Return the existing proxy associated with the given EntityKey, or the argument (the entity associated with the key) if no proxy exists.
proxyOrLoad(LoadEvent, EntityPersister, EntityKey, LoadEventListener.LoadType) - Method in class org.hibernate.event.def.DefaultLoadEventListener
Based on configured options, will either return a pre-existing proxy, generate a new proxy, or perform an actual load.
pushFromClause(AST, AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker
Sets the current 'FROM' context.
pushFromClause(AST, AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker
Sets the current 'FROM' context.
put(Object, Object) - Method in interface org.hibernate.cache.Cache
Add an item to the cache, nontransactionally, with failfast semantics
put(Object, Object, long, Object, Comparator, boolean) - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Attempt to cache an object, after loading from the database.
put(Object, Object) - Method in class org.hibernate.cache.EhCache
Puts an object into the cache.
put(Object, Object) - Method in class org.hibernate.cache.HashtableCache

put(Object, Object, long, Object, Comparator, boolean) - Method in class org.hibernate.cache.NonstrictReadWriteCache
Add an item to the cache.
put(Object, Object) - Method in class org.hibernate.cache.OSCache

put(Object, Object) - Method in class org.hibernate.cache.OptimisticTreeCache

put(QueryKey, Type[], List, boolean, SessionImplementor) - Method in interface org.hibernate.cache.QueryCache

put(Object, Object, long, Object, Comparator, boolean) - Method in class org.hibernate.cache.ReadOnlyCache

put(Object, Object, long, Object, Comparator, boolean) - Method in class org.hibernate.cache.ReadWriteCache
Do not add an item to the cache unless the current transaction timestamp is later than the timestamp at which the item was invalidated.
put(QueryKey, Type[], List, boolean, SessionImplementor) - Method in class org.hibernate.cache.StandardQueryCache

put(Object, Object) - Method in class org.hibernate.cache.SwarmCache
Add an item to the cache
put(Object, Object, long, Object, Comparator, boolean) - Method in class org.hibernate.cache.TransactionalCache

put(Object, Object) - Method in class org.hibernate.cache.TreeCache

put(Object, Object) - Method in class org.hibernate.collection.PersistentMap

put(int, int, String) - Method in class org.hibernate.dialect.TypeNames
set a type name for specified type key and capacity
put(int, String) - Method in class org.hibernate.dialect.TypeNames
set a default type name for specified type key
put(Object, Object) - Method in class org.hibernate.proxy.map.MapProxy

put(Object, Object) - Method in class org.hibernate.util.FastHashMap
Associate the specified value with the specified key in this map.
put(Object, Object) - Method in class org.hibernate.util.IdentityMap

put(Object, Object) - Method in class org.hibernate.util.SimpleMRUCache

put(Object, Object) - Method in class org.hibernate.util.SoftLimitMRUCache

putAll(Map) - Method in class org.hibernate.collection.PersistentMap

putAll(Map) - Method in class org.hibernate.proxy.map.MapProxy

putAll(Map) - Method in class org.hibernate.util.FastHashMap
Copy all of the mappings from the specified map to this one, replacing any mappings with the same keys.
putAll(Map) - Method in class org.hibernate.util.IdentityMap

Q

QUERY - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

QUERY - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

QUERY - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

QUERY_CACHE_FACTORY - Static variable in class org.hibernate.cfg.Environment
The QueryCacheFactory implementation class.
QUERY_SUBSTITUTIONS - Static variable in class org.hibernate.cfg.Environment
A comma-seperated list of token substitutions to use when translating a Hibernate query to SQL
QUERY_TRANSLATOR - Static variable in class org.hibernate.cfg.Environment
The classname of the HQL query parser factory
QUOTE - Static variable in class org.hibernate.dialect.Dialect
Characters used for quoting SQL identifiers
QUOTED_STRING - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

QUOTED_STRING - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

QUOTED_STRING - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

Query - interface org.hibernate.Query.
An object-oriented representation of a Hibernate query.
QueryCache - interface org.hibernate.cache.QueryCache.
Defines the contract for caches capable of storing query results.
QueryCacheFactory - interface org.hibernate.cache.QueryCacheFactory.
Defines a factory for query cache instances.
QueryException - exception org.hibernate.QueryException.
A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
QueryException(String) - Constructor for class org.hibernate.QueryException

QueryException(String, Throwable) - Constructor for class org.hibernate.QueryException

QueryException(String, String) - Constructor for class org.hibernate.QueryException

QueryException(Exception) - Constructor for class org.hibernate.QueryException

QueryExecutionRequestException - exception org.hibernate.hql.QueryExecutionRequestException.
Expecting to execute an illegal operation regarding the query type
QueryExecutionRequestException(String, String) - Constructor for class org.hibernate.hql.QueryExecutionRequestException

QueryImpl - class org.hibernate.impl.QueryImpl.
default implementation of the Query interface, for "ordinary" HQL queries (not collection filters)
QueryImpl(String, FlushMode, SessionImplementor, ParameterMetadata) - Constructor for class org.hibernate.impl.QueryImpl

QueryImpl(String, SessionImplementor, ParameterMetadata) - Constructor for class org.hibernate.impl.QueryImpl

QueryJoinFragment - class org.hibernate.sql.QueryJoinFragment.
A join that appears in a translated HQL query
QueryJoinFragment(Dialect, boolean) - Constructor for class org.hibernate.sql.QueryJoinFragment

QueryKey - class org.hibernate.cache.QueryKey.
A key that identifies a particular query with bound parameter values
QueryKey(String, QueryParameters, Set, EntityMode) - Constructor for class org.hibernate.cache.QueryKey

QueryLoader - class org.hibernate.loader.hql.QueryLoader.
A delegate that implements the Loader part of QueryTranslator.
QueryLoader(QueryTranslator, SessionFactoryImplementor, SelectClause) - Constructor for class org.hibernate.loader.hql.QueryLoader
Creates a new Loader implementation.
QueryMetadata - class org.hibernate.engine.query.QueryMetadata.
Defines metadata regarding a translated HQL or native-SQL query.
QueryMetadata(String, ParameterMetadata, String[], Type[], Set) - Constructor for class org.hibernate.engine.query.QueryMetadata

QueryNode - class org.hibernate.hql.ast.tree.QueryNode.
Defines a top-level AST node representing an HQL select statement.
QueryNode() - Constructor for class org.hibernate.hql.ast.tree.QueryNode

QueryParameterException - exception org.hibernate.QueryParameterException.
Parameter invalid or not found in the query
QueryParameterException(Exception) - Constructor for class org.hibernate.QueryParameterException

QueryParameterException(String) - Constructor for class org.hibernate.QueryParameterException

QueryParameterException(String, Throwable) - Constructor for class org.hibernate.QueryParameterException

QueryParameterException(String, String) - Constructor for class org.hibernate.QueryParameterException

QueryParameters - class org.hibernate.engine.QueryParameters.

QueryParameters() - Constructor for class org.hibernate.engine.QueryParameters

QueryParameters(Type, Object) - Constructor for class org.hibernate.engine.QueryParameters

QueryParameters(Type[], Object[], Object, String, Serializable) - Constructor for class org.hibernate.engine.QueryParameters

QueryParameters(Type[], Object[]) - Constructor for class org.hibernate.engine.QueryParameters

QueryParameters(Type[], Object[], Serializable[]) - Constructor for class org.hibernate.engine.QueryParameters

QueryParameters(Type[], Object[], Map, Serializable[]) - Constructor for class org.hibernate.engine.QueryParameters

QueryParameters(Type[], Object[], Map, RowSelection, boolean, String, String, boolean, ResultTransformer) - Constructor for class org.hibernate.engine.QueryParameters

QueryParameters(Type[], Object[], Map, Map, RowSelection, boolean, boolean, String, String, Serializable[], ResultTransformer) - Constructor for class org.hibernate.engine.QueryParameters

QueryParameters(Type[], Object[], Map, Map, RowSelection, boolean, boolean, String, String, Serializable[], Object, String, Serializable, ResultTransformer) - Constructor for class org.hibernate.engine.QueryParameters

QueryPlanCache - class org.hibernate.engine.query.QueryPlanCache.
Acts as a cache for compiled query plans, as well as query-parameter metadata.
QueryPlanCache(SessionFactoryImplementor) - Constructor for class org.hibernate.engine.query.QueryPlanCache

QuerySecondPass - interface org.hibernate.cfg.QuerySecondPass.
Bind query
QuerySelect - class org.hibernate.sql.QuerySelect.
A translated HQL query
QuerySelect(Dialect) - Constructor for class org.hibernate.sql.QuerySelect

QuerySplitter - class org.hibernate.hql.QuerySplitter.
Provides query splitting methods, which were originally in QueryTranslator.
QueryStatistics - class org.hibernate.stat.QueryStatistics.
Query statistics (HQL and SQL) Note that for a cached query, the cache miss is equals to the db count
QuerySyntaxException - exception org.hibernate.hql.ast.QuerySyntaxException.
Exception thrown when there is a syntax error in the HQL.
QuerySyntaxException(String) - Constructor for class org.hibernate.hql.ast.QuerySyntaxException

QuerySyntaxException(String, String) - Constructor for class org.hibernate.hql.ast.QuerySyntaxException

QueryTranslator - interface org.hibernate.hql.QueryTranslator.
Defines the constract of an HQL->SQL translator.
QueryTranslatorFactory - interface org.hibernate.hql.QueryTranslatorFactory.
Facade for generation of QueryTranslator and FilterTranslator instances.
QueryTranslatorImpl - class org.hibernate.hql.ast.QueryTranslatorImpl.
A QueryTranslator that uses an Antlr-based parser.
QueryTranslatorImpl(String, String, Map, SessionFactoryImplementor) - Constructor for class org.hibernate.hql.ast.QueryTranslatorImpl
Creates a new AST-based query translator.
QueryTranslatorImpl - class org.hibernate.hql.classic.QueryTranslatorImpl.
An instance of QueryTranslator translates a Hibernate query string to SQL.
QueryTranslatorImpl(String, String, Map, SessionFactoryImplementor) - Constructor for class org.hibernate.hql.classic.QueryTranslatorImpl
Construct a query translator
QueryTranslatorImpl(String, Map, SessionFactoryImplementor) - Constructor for class org.hibernate.hql.classic.QueryTranslatorImpl
Construct a query translator
QueryTranslatorImpl.JavaConstantConverter - class org.hibernate.hql.ast.QueryTranslatorImpl.JavaConstantConverter.

QueryTranslatorImpl.JavaConstantConverter() - Constructor for class org.hibernate.hql.ast.QueryTranslatorImpl.JavaConstantConverter

Queryable - interface org.hibernate.persister.entity.Queryable.
Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language
QueryableCollection - interface org.hibernate.persister.collection.QueryableCollection.
A collection role that may be queried or loaded by outer join.
qualifiedTableName - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

qualifier(String) - Static method in class org.hibernate.util.StringHelper

qualify(String, String, String) - Static method in class org.hibernate.mapping.Table

qualify(String, String) - Static method in class org.hibernate.util.StringHelper

qualify(String, String[]) - Static method in class org.hibernate.util.StringHelper

qualifyIndexName() - Method in class org.hibernate.dialect.Dialect
Do we need to qualify index names with the schema name?
qualifyIndexName() - Method in class org.hibernate.dialect.MySQLDialect

qualifyIndexName() - Method in class org.hibernate.dialect.ProgressDialect

qualifyIndexName() - Method in class org.hibernate.dialect.RDMSOS2200Dialect
RDMS does not support qualifing index names with the schema name.
qualifyIndexName() - Method in class org.hibernate.dialect.SybaseDialect

qualifyIndexName() - Method in class org.hibernate.dialect.TimesTenDialect

quantified(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

quantifiedExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

queries - Variable in class org.hibernate.cfg.Mappings

query(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

queryCacheHit(String, String) - Method in class org.hibernate.stat.StatisticsImpl

queryCacheHit(String, String) - Method in interface org.hibernate.stat.StatisticsImplementor

queryCacheMiss(String, String) - Method in class org.hibernate.stat.StatisticsImpl

queryCacheMiss(String, String) - Method in interface org.hibernate.stat.StatisticsImplementor

queryCachePut(String, String) - Method in class org.hibernate.stat.StatisticsImpl

queryCachePut(String, String) - Method in interface org.hibernate.stat.StatisticsImplementor

queryExecuted(String, int, long) - Method in class org.hibernate.stat.StatisticsImpl

queryExecuted(String, int, long) - Method in interface org.hibernate.stat.StatisticsImplementor

queryHasAliases() - Method in class org.hibernate.loader.custom.sql.SQLQueryParser

queryRule() - Method in class org.hibernate.hql.antlr.HqlBaseParser

queueOperation(Object) - Method in class org.hibernate.collection.AbstractPersistentCollection
Queue an addition
queuedAdditionIterator() - Method in class org.hibernate.collection.AbstractPersistentCollection
Iterate the "queued" additions
queuedAdditionIterator() - Method in interface org.hibernate.collection.PersistentCollection
Iterate the "queued" additions
quote(String) - Method in class org.hibernate.dialect.Dialect

R

RANGE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

RANGE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

RANGE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

RDMSOS2200Dialect - class org.hibernate.dialect.RDMSOS2200Dialect.

RDMSOS2200Dialect() - Constructor for class org.hibernate.dialect.RDMSOS2200Dialect

READ - Static variable in class org.hibernate.LockMode
A shared lock.
READ - Static variable in class org.hibernate.secure.HibernatePermission

READ_ONLY - Static variable in class org.hibernate.cache.CacheFactory

READ_ONLY - Static variable in class org.hibernate.engine.Status

READ_WRITE - Static variable in class org.hibernate.cache.CacheFactory

REFRESH - Static variable in class org.hibernate.CacheMode
The session will never read items from the cache, but will add items to the cache as it reads them from the database.
REFRESH - Static variable in class org.hibernate.engine.CascadeStyle
refresh
REFRESH - Static variable in class org.hibernate.engine.CascadingAction

REGION_NAME - Static variable in class org.hibernate.cache.UpdateTimestampsCache

RELEASE_CONNECTIONS - Static variable in class org.hibernate.cfg.Environment
Specifies how Hibernate should release JDBC connections.
RELOAD - Static variable in interface org.hibernate.event.LoadEventListener

REMOVED_ENTITY_MARKER - Static variable in class org.hibernate.event.def.DefaultLoadEventListener

REPLICATE - Static variable in class org.hibernate.engine.CascadeStyle
replicate
REPLICATE - Static variable in class org.hibernate.engine.CascadingAction

RIGHT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

RIGHT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

RIGHT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

RIGHT_OUTER - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

RIGHT_OUTER - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

RIGHT_OUTER_JOIN - Static variable in class org.hibernate.sql.JoinFragment

ROOT_ALIAS - Static variable in interface org.hibernate.criterion.CriteriaSpecification
The alias that refers to the "root" entity of the criteria query.
ROOT_ENTITY - Static variable in interface org.hibernate.criterion.CriteriaSpecification
Each row of results is an instance of the root entity
ROOT_LEVEL - Static variable in class org.hibernate.hql.ast.tree.FromClause

ROOT_LEVEL - Static variable in class org.hibernate.hql.ast.tree.FromReferenceNode

ROOT_SQL_ALIAS - Static variable in class org.hibernate.loader.criteria.CriteriaQueryTranslator

ROWID_ALIAS - Static variable in interface org.hibernate.persister.entity.Loadable

ROW_STAR - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

ROW_STAR - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

ROW_STAR - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

Range - class org.hibernate.util.Range.

ReadOnlyCache - class org.hibernate.cache.ReadOnlyCache.
Caches data that is never updated.
ReadOnlyCache() - Constructor for class org.hibernate.cache.ReadOnlyCache

ReadWriteCache - class org.hibernate.cache.ReadWriteCache.
Caches data that is sometimes updated while maintaining the semantics of "read committed" isolation level.
ReadWriteCache() - Constructor for class org.hibernate.cache.ReadWriteCache

ReadWriteCache.Item - class org.hibernate.cache.ReadWriteCache.Item.
An item of cached data, timestamped with the time it was cached,.
ReadWriteCache.Item(Object, Object, long) - Constructor for class org.hibernate.cache.ReadWriteCache.Item

ReadWriteCache.Lock - class org.hibernate.cache.ReadWriteCache.Lock.
A soft lock which supports concurrent locking, timestamped with the time it was released
ReadWriteCache.Lock(long, int, Object) - Constructor for class org.hibernate.cache.ReadWriteCache.Lock

ReadWriteCache.Lockable - interface org.hibernate.cache.ReadWriteCache.Lockable.

ReaderInputStream - class org.hibernate.lob.ReaderInputStream.
Exposes a Reader as an InputStream
ReaderInputStream(Reader) - Constructor for class org.hibernate.lob.ReaderInputStream

ReattachVisitor - class org.hibernate.event.def.ReattachVisitor.
Abstract superclass of visitors that reattach collections
ReattachVisitor(EventSource, Serializable) - Constructor for class org.hibernate.event.def.ReattachVisitor

ReflectHelper - class org.hibernate.util.ReflectHelper.

ReflectionOptimizer - interface org.hibernate.bytecode.ReflectionOptimizer.
Represents reflection optimization for a particular class.
ReflectionOptimizer.AccessOptimizer - interface org.hibernate.bytecode.ReflectionOptimizer.AccessOptimizer.
Represents optimized entity property access.
ReflectionOptimizer.InstantiationOptimizer - interface org.hibernate.bytecode.ReflectionOptimizer.InstantiationOptimizer.
Represents optimized entity instantiation.
ReflectionOptimizerImpl - class org.hibernate.bytecode.cglib.ReflectionOptimizerImpl.
ReflectionOptimizer implementation for CGLIB.
ReflectionOptimizerImpl(InstantiationOptimizerAdapter, AccessOptimizerAdapter) - Constructor for class org.hibernate.bytecode.cglib.ReflectionOptimizerImpl

ReflectionOptimizerImpl - class org.hibernate.bytecode.javassist.ReflectionOptimizerImpl.
ReflectionOptimizer implementation for Javassist.
ReflectionOptimizerImpl(ReflectionOptimizer.InstantiationOptimizer, ReflectionOptimizer.AccessOptimizer) - Constructor for class org.hibernate.bytecode.javassist.ReflectionOptimizerImpl

RefreshEvent - class org.hibernate.event.RefreshEvent.
Defines an event class for the refreshing of an object.
RefreshEvent(Object, EventSource) - Constructor for class org.hibernate.event.RefreshEvent

RefreshEvent(Object, LockMode, EventSource) - Constructor for class org.hibernate.event.RefreshEvent

RefreshEventListener - interface org.hibernate.event.RefreshEventListener.
Defines the contract for handling of refresh events generated from a session.
RelationalModel - interface org.hibernate.mapping.RelationalModel.
A relational object which may be created using DDL
ReplicateEvent - class org.hibernate.event.ReplicateEvent.
Defines an event class for the replication of an entity.
ReplicateEvent(Object, ReplicationMode, EventSource) - Constructor for class org.hibernate.event.ReplicateEvent

ReplicateEvent(String, Object, ReplicationMode, EventSource) - Constructor for class org.hibernate.event.ReplicateEvent

ReplicateEventListener - interface org.hibernate.event.ReplicateEventListener.
Defines the contract for handling of replicate events generated from a session.
ReplicationMode - class org.hibernate.ReplicationMode.
Represents a replication strategy.
ReplicationMode(String) - Constructor for class org.hibernate.ReplicationMode

ResinTransactionManagerLookup - class org.hibernate.transaction.ResinTransactionManagerLookup.
TransactionManager lookup strategy for Resin
ResinTransactionManagerLookup() - Constructor for class org.hibernate.transaction.ResinTransactionManagerLookup

ResolvableNode - interface org.hibernate.hql.ast.tree.ResolvableNode.
The contract for expression sub-trees that can resolve themselves.
RestrictableStatement - interface org.hibernate.hql.ast.tree.RestrictableStatement.
Type definition for Statements which are restrictable via a where-clause (and thus also having a from-clause).
Restrictions - class org.hibernate.criterion.Restrictions.
The criterion package may be used by applications as a framework for building new kinds of Criterion.
ResultSetMappingBinder - class org.hibernate.cfg.ResultSetMappingBinder.

ResultSetMappingBinder() - Constructor for class org.hibernate.cfg.ResultSetMappingBinder

ResultSetMappingDefinition - class org.hibernate.engine.ResultSetMappingDefinition.
Keep a description of the resultset mapping
ResultSetMappingDefinition(String) - Constructor for class org.hibernate.engine.ResultSetMappingDefinition

ResultSetMappingSecondPass - class org.hibernate.cfg.ResultSetMappingSecondPass.

ResultSetMappingSecondPass(Element, String, Mappings) - Constructor for class org.hibernate.cfg.ResultSetMappingSecondPass

ResultSetWrapper - class org.hibernate.jdbc.ResultSetWrapper.
A ResultSet delegate, responsible for locally caching the columnName-to-columnIndex resolution that has been found to be inefficient in a few vendor's drivers (i.e., Oracle and Postgres).
ResultSetWrapper(ResultSet, ColumnNameCache) - Constructor for class org.hibernate.jdbc.ResultSetWrapper

ResultTransformer - interface org.hibernate.transform.ResultTransformer.
Implementors define a strategy for transforming criteria query results into the actual application-visible query result list.
Return - interface org.hibernate.loader.custom.Return.
Represents a return in a custom query.
ReturnMetadata - class org.hibernate.engine.query.ReturnMetadata.

ReturnMetadata(String[], Type[]) - Constructor for class org.hibernate.engine.query.ReturnMetadata

RootClass - class org.hibernate.mapping.RootClass.
The root class of an inheritance hierarchy
RootClass() - Constructor for class org.hibernate.mapping.RootClass

RootEntityResultTransformer - class org.hibernate.transform.RootEntityResultTransformer.

RootEntityResultTransformer() - Constructor for class org.hibernate.transform.RootEntityResultTransformer

RootReturn - class org.hibernate.loader.custom.RootReturn.
Represents a return which names a "root" entity.
RootReturn(String, String, EntityAliases, LockMode) - Constructor for class org.hibernate.loader.custom.RootReturn

RowCountProjection - class org.hibernate.criterion.RowCountProjection.
A row count
RowCountProjection() - Constructor for class org.hibernate.criterion.RowCountProjection

RowSelection - class org.hibernate.engine.RowSelection.
Represents a selection of rows in a JDBC ResultSet
RowSelection() - Constructor for class org.hibernate.engine.RowSelection

range(int, int) - Static method in class org.hibernate.util.Range

read(Object) - Method in interface org.hibernate.cache.Cache
Get an item from the cache
read(Object) - Method in class org.hibernate.cache.EhCache

read(Object) - Method in class org.hibernate.cache.HashtableCache

read(Object) - Method in class org.hibernate.cache.OSCache

read(Object) - Method in class org.hibernate.cache.OptimisticTreeCache

read(Object) - Method in class org.hibernate.cache.SwarmCache

read(Object) - Method in class org.hibernate.cache.TreeCache

read() - Method in class org.hibernate.collection.AbstractPersistentCollection
Called by any read-only method of the collection interface
read() - Method in class org.hibernate.lob.ReaderInputStream

readBoolean(Object, String, boolean) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

readBoolean(Object, String, boolean) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

readBoolean(Object, String, boolean) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

readByte(Object, String, byte) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

readByte(Object, String, byte) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

readByte(Object, String, byte) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

readByteCode(InputStream) - Static method in class org.hibernate.bytecode.util.ByteCodeHelper
Reads class byte array info from the given input stream.
readByteCode(File) - Static method in class org.hibernate.bytecode.util.ByteCodeHelper

readByteCode(ZipInputStream) - Static method in class org.hibernate.bytecode.util.ByteCodeHelper

readChar(Object, String, char) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

readChar(Object, String, char) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

readChar(Object, String, char) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

readDouble(Object, String, double) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

readDouble(Object, String, double) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

readDouble(Object, String, double) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

readElement(ResultSet, Object, String[], SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

readElement(ResultSet, Object, String[], SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister
Read the element from a row of the JDBC ResultSet
readElementByIndex(Object) - Method in class org.hibernate.collection.AbstractPersistentCollection

readElementExistence(Object) - Method in class org.hibernate.collection.AbstractPersistentCollection

readFloat(Object, String, float) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

readFloat(Object, String, float) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

readFloat(Object, String, float) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

readFrom(ResultSet, CollectionPersister, CollectionAliases, Object) - Method in class org.hibernate.collection.PersistentArrayHolder

readFrom(ResultSet, CollectionPersister, CollectionAliases, Object) - Method in class org.hibernate.collection.PersistentBag

readFrom(ResultSet, CollectionPersister, CollectionAliases, Object) - Method in interface org.hibernate.collection.PersistentCollection
Read a row from the JDBC result set
readFrom(ResultSet, CollectionPersister, CollectionAliases, Object) - Method in class org.hibernate.collection.PersistentElementHolder

readFrom(ResultSet, CollectionPersister, CollectionAliases, Object) - Method in class org.hibernate.collection.PersistentIdentifierBag

readFrom(ResultSet, CollectionPersister, CollectionAliases, Object) - Method in class org.hibernate.collection.PersistentIndexedElementHolder

readFrom(ResultSet, CollectionPersister, CollectionAliases, Object) - Method in class org.hibernate.collection.PersistentList

readFrom(ResultSet, CollectionPersister, CollectionAliases, Object) - Method in class org.hibernate.collection.PersistentMap

readFrom(ResultSet, CollectionPersister, CollectionAliases, Object) - Method in class org.hibernate.collection.PersistentSet

readIdentifier(ResultSet, String, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

readIdentifier(ResultSet, String, SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister
Read the identifier from a row of the JDBC ResultSet
readIndex(ResultSet, String[], SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

readIndex(ResultSet, String[], SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister
Read the index from a row of the JDBC ResultSet
readIndexExistence(Object) - Method in class org.hibernate.collection.AbstractPersistentCollection

readInt(Object, String, int) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

readInt(Object, String, int) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

readInt(Object, String, int) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

readKey(ResultSet, String[], SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

readKey(ResultSet, String[], SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister
Read the key from a row of the JDBC ResultSet
readLong(Object, String, long) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

readLong(Object, String, long) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

readLong(Object, String, long) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

readObject(Object, String, Object) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

readObject(Object, String, Object) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

readObject(Object, String, Object) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

readShort(Object, String, short) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

readShort(Object, String, short) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

readShort(Object, String, short) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

readSize() - Method in class org.hibernate.collection.AbstractPersistentCollection
Called by the size() method
reallyDoCascade(CascadingAction) - Method in class org.hibernate.engine.CascadeStyle.MultipleCascadeStyle

reallyDoCascade(CascadingAction) - Method in class org.hibernate.engine.CascadeStyle
Should the given action really, really be cascaded?
reassociate(AbstractEvent, Object, Serializable, EntityPersister) - Method in class org.hibernate.event.def.AbstractReassociateEventListener
Associates a given entity (either transient or associated with another session) to the given session.
reassociateIfUninitializedProxy(Object) - Method in interface org.hibernate.engine.PersistenceContext
Takes the given object and, if it represents a proxy, reassociates it with this event source.
reassociateIfUninitializedProxy(Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Takes the given object and, if it represents a proxy, reassociates it with this event source.
reassociateIfUninitializedProxy(Object, SessionImplementor) - Method in class org.hibernate.event.def.DefaultSaveEventListener

reassociateIfUninitializedProxy(Object, SessionImplementor) - Method in class org.hibernate.event.def.DefaultSaveOrUpdateEventListener

reassociateProxy(Object, Serializable) - Method in interface org.hibernate.engine.PersistenceContext
If a deleted entity instance is re-saved, and it has a proxy, we need to reset the identifier of the proxy
reassociateProxy(Object, Serializable) - Method in class org.hibernate.engine.StatefulPersistenceContext
If a deleted entity instance is re-saved, and it has a proxy, we need to reset the identifier of the proxy
reattachCollection(PersistentCollection, CollectionType) - Method in class org.hibernate.event.def.ProxyVisitor
Reattach a detached (disassociated) initialized or uninitialized collection wrapper, using a snapshot carried with the collection wrapper
reconnect() - Method in interface org.hibernate.Session
Deprecated. Manual reconnection is only needed in the case of application-supplied connections, in which case the Session.reconnect(java.sql.Connection) for should be used.
reconnect(Connection) - Method in interface org.hibernate.Session
Reconnect to the given JDBC connection.
reconnect() - Method in class org.hibernate.impl.SessionImpl

reconnect(Connection) - Method in class org.hibernate.impl.SessionImpl

recreate(PersistentCollection, Serializable, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

recreate(PersistentCollection, Serializable, SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister
(Re)create the collection's persistent state
recreateCollection(String) - Method in class org.hibernate.stat.StatisticsImpl

recreateCollection(String) - Method in interface org.hibernate.stat.StatisticsImplementor

recursiveResolve(int, boolean, String) - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

recursiveResolve(int, boolean, String, AST) - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

referencedPropertyName - Variable in class org.hibernate.mapping.ToOne

reflectedPropertyClass(String, String) - Static method in class org.hibernate.util.ReflectHelper

refresh(Object) - Method in interface org.hibernate.Session
Re-read the state of the given instance from the underlying database.
refresh(Object, LockMode) - Method in interface org.hibernate.Session
Re-read the state of the given instance from the underlying database, with the given LockMode.
refresh(Object) - Method in interface org.hibernate.StatelessSession
Refresh the entity instance state from the database.
refresh(String, Object) - Method in interface org.hibernate.StatelessSession
Refresh the entity instance state from the database.
refresh(Object, LockMode) - Method in interface org.hibernate.StatelessSession
Refresh the entity instance state from the database.
refresh(String, Object, LockMode) - Method in interface org.hibernate.StatelessSession
Refresh the entity instance state from the database.
refresh(Object, Map) - Method in interface org.hibernate.event.EventSource
Cascade refesh an entity instance
refresh(Object) - Method in class org.hibernate.impl.SessionImpl

refresh(Object, LockMode) - Method in class org.hibernate.impl.SessionImpl

refresh(Object, Map) - Method in class org.hibernate.impl.SessionImpl

refresh(Object) - Method in class org.hibernate.impl.StatelessSessionImpl

refresh(String, Object) - Method in class org.hibernate.impl.StatelessSessionImpl

refresh(Object, LockMode) - Method in class org.hibernate.impl.StatelessSessionImpl

refresh(String, Object, LockMode) - Method in class org.hibernate.impl.StatelessSessionImpl

refreshRow() - Method in class org.hibernate.jdbc.ResultSetWrapper

registerCallbackIfNecessary() - Method in class org.hibernate.jdbc.JDBCContext

registerColumnType(int, int, String) - Method in class org.hibernate.dialect.Dialect
Subclasses register a typename for the given type code and maximum column length.
registerColumnType(int, String) - Method in class org.hibernate.dialect.Dialect
Subclasses register a typename for the given type code.
registerFunction(String, SQLFunction) - Method in class org.hibernate.dialect.Dialect

registerHibernateType(int, String) - Method in class org.hibernate.dialect.Dialect

registerHibernateType(int, int, String) - Method in class org.hibernate.dialect.Dialect

registerKeyword(String) - Method in class org.hibernate.dialect.Dialect

registerResultSetOutParameter(CallableStatement, int) - Method in class org.hibernate.dialect.DB2Dialect

registerResultSetOutParameter(CallableStatement, int) - Method in class org.hibernate.dialect.DataDirectOracle9Dialect

registerResultSetOutParameter(CallableStatement, int) - Method in class org.hibernate.dialect.Dialect

registerResultSetOutParameter(CallableStatement, int) - Method in class org.hibernate.dialect.MySQLDialect

registerResultSetOutParameter(CallableStatement, int) - Method in class org.hibernate.dialect.Oracle9Dialect

registerResultSetOutParameter(CallableStatement, int) - Method in class org.hibernate.dialect.SybaseDialect

registerSynchronization(Synchronization) - Method in interface org.hibernate.Transaction
Register a user synchronization callback for this transaction.
registerSynchronization(Synchronization) - Method in class org.hibernate.transaction.CMTTransaction

registerSynchronization(Synchronization) - Method in class org.hibernate.transaction.JDBCTransaction

registerSynchronization(Synchronization) - Method in class org.hibernate.transaction.JTATransaction

registerSynchronization(Synchronization) - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter

registerSynchronizationIfPossible() - Method in class org.hibernate.jdbc.JDBCContext

registerVarcharTypes() - Method in class org.hibernate.dialect.MySQL5Dialect

registerVarcharTypes() - Method in class org.hibernate.dialect.MySQLDialect

relationalExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

relative(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

release() - Method in class org.hibernate.bytecode.javassist.TransformingClassLoader

release() - Method in class org.hibernate.cache.AbstractJndiBoundCacheProvider

release(Object, CacheConcurrencyStrategy.SoftLock) - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Called when we have finished the attempted update/delete (which may or may not have been successful), after transaction completion.
release(Object, CacheConcurrencyStrategy.SoftLock) - Method in class org.hibernate.cache.NonstrictReadWriteCache
Invalidate the item (again, for safety).
release(Object, CacheConcurrencyStrategy.SoftLock) - Method in class org.hibernate.cache.ReadOnlyCache
Unsupported!
release(Object, CacheConcurrencyStrategy.SoftLock) - Method in class org.hibernate.cache.ReadWriteCache
Release the soft lock on the item.
release(Object, CacheConcurrencyStrategy.SoftLock) - Method in class org.hibernate.cache.TransactionalCache
Do nothing.
releaseBorrowedConnection() - Method in class org.hibernate.jdbc.ConnectionManager

releaseStatement(PreparedStatement, SessionImplementor) - Method in class org.hibernate.id.insert.AbstractReturningDelegate

remove(Object) - Method in interface org.hibernate.cache.Cache
Remove an item from the cache
remove(Object) - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Evict an item from the cache immediately (without regard for transaction isolation).
remove(Object) - Method in class org.hibernate.cache.EhCache
Removes the element which matches the key.
remove(Object) - Method in class org.hibernate.cache.HashtableCache

remove(Object) - Method in class org.hibernate.cache.NonstrictReadWriteCache

remove(Object) - Method in class org.hibernate.cache.OSCache

remove(Object) - Method in class org.hibernate.cache.OptimisticTreeCache

remove(Object) - Method in class org.hibernate.cache.ReadOnlyCache

remove(Object) - Method in class org.hibernate.cache.ReadWriteCache

remove(Object) - Method in class org.hibernate.cache.SwarmCache
Remove an item from the cache
remove(Object) - Method in class org.hibernate.cache.TransactionalCache

remove(Object) - Method in class org.hibernate.cache.TreeCache

remove(Object) - Method in class org.hibernate.collection.PersistentBag

remove(int) - Method in class org.hibernate.collection.PersistentBag

remove(Object) - Method in class org.hibernate.collection.PersistentIdentifierBag

remove(int) - Method in class org.hibernate.collection.PersistentIdentifierBag

remove(Object) - Method in class org.hibernate.collection.PersistentList

remove(int) - Method in class org.hibernate.collection.PersistentList

remove(Object) - Method in class org.hibernate.collection.PersistentMap

remove(Object) - Method in class org.hibernate.collection.PersistentSet

remove() - Method in class org.hibernate.hql.ast.util.ASTIterator

remove() - Method in class org.hibernate.hql.ast.util.ASTParentsFirstIterator

remove() - Method in class org.hibernate.impl.IteratorImpl

remove(Serializable, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

remove(Serializable, SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister
Completely remove the persistent state of the collection
remove(Attribute) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

remove(CDATA) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

remove(Entity) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

remove(Namespace) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

remove(Text) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

remove(Node) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

remove(Comment) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

remove(Element) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

remove(ProcessingInstruction) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

remove(Object) - Method in class org.hibernate.proxy.map.MapProxy

remove(Attribute) - Method in class org.hibernate.tuple.ElementWrapper

remove(CDATA) - Method in class org.hibernate.tuple.ElementWrapper

remove(Entity) - Method in class org.hibernate.tuple.ElementWrapper

remove(Namespace) - Method in class org.hibernate.tuple.ElementWrapper

remove(Text) - Method in class org.hibernate.tuple.ElementWrapper

remove(Node) - Method in class org.hibernate.tuple.ElementWrapper

remove(Comment) - Method in class org.hibernate.tuple.ElementWrapper

remove(Element) - Method in class org.hibernate.tuple.ElementWrapper

remove(ProcessingInstruction) - Method in class org.hibernate.tuple.ElementWrapper

remove() - Method in class org.hibernate.util.EmptyIterator

remove(Object) - Method in class org.hibernate.util.FastHashMap
Remove any mapping for this key, and return any previously mapped value.
remove(Object) - Method in class org.hibernate.util.IdentityMap

remove(Object) - Method in class org.hibernate.util.IdentitySet

remove() - Method in class org.hibernate.util.JoinedIterator

remove() - Method in class org.hibernate.util.LazyIterator

remove() - Method in class org.hibernate.util.SingletonIterator

removeAll(Collection) - Method in class org.hibernate.collection.PersistentBag

removeAll(Collection) - Method in class org.hibernate.collection.PersistentIdentifierBag

removeAll(Collection) - Method in class org.hibernate.collection.PersistentList

removeAll(Collection) - Method in class org.hibernate.collection.PersistentSet

removeAll(Collection) - Method in class org.hibernate.util.IdentitySet

removeBatchLoadableEntityKey(EntityKey) - Method in class org.hibernate.engine.BatchFetchQueue
After evicting or deleting or loading an entity, we don't need to batch fetch it anymore, remove it from the queue if necessary
removeCollection(CollectionPersister, Serializable, EventSource) - Method in class org.hibernate.event.def.ReattachVisitor
Schedules a collection for deletion.
removeCollection(String) - Method in class org.hibernate.stat.StatisticsImpl

removeCollection(String) - Method in interface org.hibernate.stat.StatisticsImplementor

removeCollectionHolder(Object) - Method in interface org.hibernate.engine.PersistenceContext
Remove the mapping of collection to holder during eviction of the owning entity
removeCollectionHolder(Object) - Method in class org.hibernate.engine.StatefulPersistenceContext

removeCommonFrames(List, List) - Static method in class org.hibernate.exception.ExceptionUtils
Removes common frames from the cause trace given the two stack traces.
removeEntity(EntityKey) - Method in interface org.hibernate.engine.PersistenceContext
Remove an entity from the session cache, also clear up other state associated with the entity, all except for the EntityEntry
removeEntity(EntityKey) - Method in class org.hibernate.engine.StatefulPersistenceContext
Remove an entity from the session cache, also clear up other state associated with the entity, all except for the EntityEntry
removeEntry(Object) - Method in interface org.hibernate.engine.PersistenceContext
Remove an entity entry from the session cache
removeEntry(Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Remove an entity entry from the session cache
removeInstance(String, String, Properties) - Static method in class org.hibernate.impl.SessionFactoryObjectFactory

removeProcessingInstruction(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

removeProcessingInstruction(String) - Method in class org.hibernate.tuple.ElementWrapper

removeProxy(EntityKey) - Method in interface org.hibernate.engine.PersistenceContext
Remove a proxy from the session cache
removeProxy(EntityKey) - Method in class org.hibernate.engine.StatefulPersistenceContext
Remove a proxy from the session cache
removeSubselect(EntityKey) - Method in class org.hibernate.engine.BatchFetchQueue
After evicting or deleting an entity, we don't need to know the query that was used to load it anymore (don't call this after loading the entity, since we might still need to load its collections)
render(List, SessionFactoryImplementor) - Method in class org.hibernate.dialect.DerbyDialect.DerbyTrimFunctionEmulation

render(List, SessionFactoryImplementor) - Method in class org.hibernate.dialect.function.AnsiTrimEmulationFunction

render(List, SessionFactoryImplementor) - Method in class org.hibernate.dialect.function.CastFunction

render(List, SessionFactoryImplementor) - Method in class org.hibernate.dialect.function.CharIndexFunction

render(List, SessionFactoryImplementor) - Method in class org.hibernate.dialect.function.NoArgSQLFunction

render(List, SessionFactoryImplementor) - Method in class org.hibernate.dialect.function.NvlFunction

render(List, SessionFactoryImplementor) - Method in class org.hibernate.dialect.function.PositionSubstringFunction

render(List, SessionFactoryImplementor) - Method in interface org.hibernate.dialect.function.SQLFunction
Render the function call as SQL
render(List, SessionFactoryImplementor) - Method in class org.hibernate.dialect.function.SQLFunctionTemplate
Applies the template to passed in arguments.
render(List, SessionFactoryImplementor) - Method in class org.hibernate.dialect.function.StandardSQLFunction

render(List, SessionFactoryImplementor) - Method in class org.hibernate.dialect.function.VarArgsSQLFunction

render(String, Map) - Method in class org.hibernate.util.FilterHelper

render(StringBuffer, String, Map) - Method in class org.hibernate.util.FilterHelper

renderDisplayInfo() - Method in class org.hibernate.param.NamedParameterSpecification

renderDisplayInfo() - Method in interface org.hibernate.param.ParameterSpecification

renderDisplayInfo() - Method in class org.hibernate.param.PositionalParameterSpecification

renderDisplayInfo() - Method in class org.hibernate.param.VersionTypeSeedParameterSpecification

renderLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.CollectionType

renderLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.CustomCollectionType

renderOrderByStringTemplate(String, Dialect, SQLFunctionRegistry) - Static method in class org.hibernate.sql.Template
Takes order by clause provided in the mapping attribute and interpolates the alias.
renderSelect(int[], int[], int[]) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

renderUnuseable(Connection) - Static method in class org.hibernate.jdbc.BorrowedConnectionProxy

renderWhereStringTemplate(String, Dialect, SQLFunctionRegistry) - Static method in class org.hibernate.sql.Template

renderWhereStringTemplate(String, String, Dialect) - Static method in class org.hibernate.sql.Template
Deprecated. Only intended for annotations usage; use Template.renderWhereStringTemplate(String, String, Dialect, SQLFunctionRegistry) instead
renderWhereStringTemplate(String, String, Dialect, SQLFunctionRegistry) - Static method in class org.hibernate.sql.Template
Takes the where condition provided in the mapping attribute and interpolates the alias.
repeat(String, int) - Static method in class org.hibernate.util.StringHelper

replace(Object, Object, SessionImplementor, Object, Map, ForeignKeyDirection) - Method in class org.hibernate.type.AbstractType

replace(Object, Object, SessionImplementor, Object, Map) - Method in class org.hibernate.type.AnyType

replace(Object, Object, SessionImplementor, Object, Map) - Method in class org.hibernate.type.BlobType

replace(Object, Object, SessionImplementor, Object, Map) - Method in class org.hibernate.type.ClobType

replace(Object, Object, SessionImplementor, Object, Map) - Method in class org.hibernate.type.CollectionType

replace(Object, Object, SessionImplementor, Object, Map) - Method in class org.hibernate.type.ComponentType

replace(Object, Object, SessionImplementor, Object, Map, ForeignKeyDirection) - Method in class org.hibernate.type.ComponentType

replace(Object, Object, SessionImplementor, Object, Map) - Method in class org.hibernate.type.CompositeCustomType

replace(Object, Object, SessionImplementor, Object, Map) - Method in class org.hibernate.type.CustomType

replace(Object, Object, SessionImplementor, Object, Map) - Method in class org.hibernate.type.EntityType

replace(Object, Object, SessionImplementor, Object, Map) - Method in class org.hibernate.type.ImmutableType

replace(Object, Object, SessionImplementor, Object, Map) - Method in class org.hibernate.type.MetaType

replace(Object, Object, SessionImplementor, Object, Map) - Method in class org.hibernate.type.MutableType

replace(Object, Object, SessionImplementor, Object, Map) - Method in interface org.hibernate.type.Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
replace(Object, Object, SessionImplementor, Object, Map, ForeignKeyDirection) - Method in interface org.hibernate.type.Type
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
replace(Object[], Object[], Type[], SessionImplementor, Object, Map) - Static method in class org.hibernate.type.TypeFactory

replace(Object[], Object[], Type[], SessionImplementor, Object, Map, ForeignKeyDirection) - Static method in class org.hibernate.type.TypeFactory

replace(Object, Object, SessionImplementor, Object) - Method in interface org.hibernate.usertype.CompositeUserType
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
replace(Object, Object, Object) - Method in interface org.hibernate.usertype.UserType
During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
replace(String, String, String) - Static method in class org.hibernate.util.StringHelper

replace(String[], String, String) - Static method in class org.hibernate.util.StringHelper

replace(String, String, String, boolean) - Static method in class org.hibernate.util.StringHelper

replaceDelayedEntityIdentityInsertKeys(EntityKey, Serializable) - Method in interface org.hibernate.engine.PersistenceContext

replaceDelayedEntityIdentityInsertKeys(EntityKey, Serializable) - Method in class org.hibernate.engine.StatefulPersistenceContext

replaceElements(Object, Object, Object, Map, SessionImplementor) - Method in class org.hibernate.type.ArrayType

replaceElements(Object, Object, Object, Map, SessionImplementor) - Method in class org.hibernate.type.CollectionType
Replace the elements of a collection with the elements of another collection
replaceElements(Object, Object, Object, Map, SessionImplementor) - Method in class org.hibernate.type.CustomCollectionType

replaceElements(Object, Object, Object, Map, SessionImplementor) - Method in class org.hibernate.type.MapType

replaceElements(Object, Object, CollectionPersister, Object, Map, SessionImplementor) - Method in interface org.hibernate.usertype.UserCollectionType
Replace the elements of a collection with the elements of another collection
replaceNode(Node, Element) - Static method in class org.hibernate.type.AbstractType

replaceOnce(String, String, String) - Static method in class org.hibernate.util.StringHelper

replicate(Object, ReplicationMode) - Method in interface org.hibernate.Session
Persist the state of the given detached instance, reusing the current identifier value.
replicate(String, Object, ReplicationMode) - Method in interface org.hibernate.Session
Persist the state of the given detached instance, reusing the current identifier value.
replicate(Object, ReplicationMode) - Method in class org.hibernate.impl.SessionImpl

replicate(String, Object, ReplicationMode) - Method in class org.hibernate.impl.SessionImpl

reportError(RecognitionException) - Method in class org.hibernate.hql.ast.ErrorCounter

reportError(String) - Method in class org.hibernate.hql.ast.ErrorCounter

reportError(RecognitionException) - Method in interface org.hibernate.hql.ast.ErrorReporter

reportError(String) - Method in interface org.hibernate.hql.ast.ErrorReporter

reportError(RecognitionException) - Method in class org.hibernate.hql.ast.HqlParser

reportError(String) - Method in class org.hibernate.hql.ast.HqlParser

reportError(RecognitionException) - Method in class org.hibernate.hql.ast.HqlSqlWalker

reportError(String) - Method in class org.hibernate.hql.ast.HqlSqlWalker

reportError(RecognitionException) - Method in class org.hibernate.hql.ast.SqlGenerator

reportError(String) - Method in class org.hibernate.hql.ast.SqlGenerator

reportWarning(String) - Method in class org.hibernate.hql.ast.ErrorCounter

reportWarning(String) - Method in interface org.hibernate.hql.ast.ErrorReporter

reportWarning(String) - Method in class org.hibernate.hql.ast.HqlParser

reportWarning(String) - Method in class org.hibernate.hql.ast.HqlSqlWalker

reportWarning(String) - Method in class org.hibernate.hql.ast.SqlGenerator

requireClassPersister(String) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Locate the persister by class or entity name, requiring that such a persister exist.
requireQueryableCollection(String) - Method in class org.hibernate.hql.ast.util.SessionFactoryHelper
Locate the collection persister by the collection role, requiring that such a persister exist.
requiresDirtyCheck(Object) - Method in class org.hibernate.engine.EntityEntry

requiresNoCascadeChecking() - Method in class org.hibernate.engine.CascadingAction
Does the specified cascading action require verification of no cascade validity?
reset() - Method in class org.hibernate.cfg.Configuration

resetIdentifier(Object, Serializable, Object, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

resetIdentifier(Object, Serializable, Object, EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Set the identifier and version of the given instance back to its "unsaved" value, returning the id
resetIdentifier(Object, Serializable, Object) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

resetIdentifier(Object, Serializable, Object) - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Inject the given identifier and version into the entity, in order to "roll back" to their original values.
resolve(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

resolve(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

resolve(boolean) - Method in class org.hibernate.hql.ast.tree.CollectionFunction

resolve(boolean, boolean, String, AST) - Method in class org.hibernate.hql.ast.tree.DotNode

resolve() - Method in class org.hibernate.hql.ast.tree.FromClause

resolve(boolean, boolean) - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

resolve(boolean, boolean, String) - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

resolve(boolean, boolean, String, AST) - Method in class org.hibernate.hql.ast.tree.IdentNode

resolve(boolean, boolean, String, AST) - Method in class org.hibernate.hql.ast.tree.IndexNode

resolve(boolean) - Method in class org.hibernate.hql.ast.tree.MethodNode

resolve(boolean, boolean, String, AST) - Method in interface org.hibernate.hql.ast.tree.ResolvableNode
Does the work of resolving an identifier or a dot
resolve(boolean, boolean, String) - Method in interface org.hibernate.hql.ast.tree.ResolvableNode
Does the work of resolving an identifier or a dot, but without a parent node
resolve(boolean, boolean) - Method in interface org.hibernate.hql.ast.tree.ResolvableNode
Does the work of resolving an identifier or a dot, but without a parent node or alias
resolve(boolean, boolean, String, AST) - Method in class org.hibernate.hql.ast.tree.SelectExpressionImpl

resolve(Object, SessionImplementor, Object) - Method in class org.hibernate.type.AbstractType

resolve(Object, SessionImplementor, Object) - Method in class org.hibernate.type.AnyType

resolve(Object, SessionImplementor, Object) - Method in class org.hibernate.type.CollectionType

resolve(Object, SessionImplementor, Object) - Method in class org.hibernate.type.ComponentType

resolve(Object, SessionImplementor, Object) - Method in class org.hibernate.type.EntityType
Resolve an identifier or unique key value
resolve(Object, SessionImplementor, Object) - Method in interface org.hibernate.type.Type
Map identifiers to entities or collections.
resolveCollectionProperty(AST) - Method in class org.hibernate.hql.ast.tree.MethodNode

resolveEntity(String, String) - Method in class org.hibernate.util.DTDEntityResolver

resolveFirstChild() - Method in class org.hibernate.hql.ast.tree.DotNode
Resolves the left hand side of the DOT.
resolveFirstChild() - Method in class org.hibernate.hql.ast.tree.FromReferenceNode
Resolves the left hand side of the DOT.
resolveIdentifier(Serializable, SessionImplementor) - Method in class org.hibernate.type.EntityType
Resolve an identifier
resolveInFunctionCall(boolean, boolean) - Method in class org.hibernate.hql.ast.tree.DotNode

resolveInFunctionCall(boolean, boolean) - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

resolveInFunctionCall(boolean, boolean) - Method in interface org.hibernate.hql.ast.tree.ResolvableNode
Does the work of resolving inside of the scope of a function call
resolveInHibernateNamespace(String) - Method in class org.hibernate.util.DTDEntityResolver

resolveInLocalNamespace(String) - Method in class org.hibernate.util.DTDEntityResolver

resolveIndex(AST) - Method in class org.hibernate.hql.ast.tree.DotNode

resolveIndex(AST) - Method in class org.hibernate.hql.ast.tree.IdentNode

resolveIndex(AST) - Method in class org.hibernate.hql.ast.tree.IndexNode

resolveIndex(AST) - Method in interface org.hibernate.hql.ast.tree.ResolvableNode
Does the work of resolving an an index [].
resolveIndex(AST) - Method in class org.hibernate.hql.ast.tree.SelectExpressionImpl

resolvePlaceHolder(String) - Static method in class org.hibernate.util.PropertiesHelper

resolvePlaceHolders(Properties) - Static method in class org.hibernate.util.PropertiesHelper

resolveSelectExpression(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

resolveSelectExpression(AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

resolveSelectExpression() - Method in class org.hibernate.hql.ast.tree.DotNode
Special method to resolve expressions in the SELECT list.
resultSetMappings - Variable in class org.hibernate.cfg.Mappings

resume(Transaction) - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter

retainAll(Collection) - Method in class org.hibernate.collection.PersistentBag

retainAll(Collection) - Method in class org.hibernate.collection.PersistentIdentifierBag

retainAll(Collection) - Method in class org.hibernate.collection.PersistentList

retainAll(Collection) - Method in class org.hibernate.collection.PersistentSet

retainAll(Collection) - Method in class org.hibernate.util.IdentitySet

returnColumnName - Variable in class org.hibernate.sql.CaseFragment

returnedClass() - Method in interface org.hibernate.usertype.CompositeUserType
The class returned by nullSafeGet().
returnedClass() - Method in interface org.hibernate.usertype.UserType
The class returned by nullSafeGet().
rollback() - Method in interface org.hibernate.Transaction
Force the underlying transaction to roll back.
rollback() - Method in class org.hibernate.transaction.CMTTransaction

rollback() - Method in class org.hibernate.transaction.JDBCTransaction

rollback() - Method in class org.hibernate.transaction.JTATransaction

rollback() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter

rollback() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter

root(String) - Static method in class org.hibernate.util.StringHelper

rowCount() - Static method in class org.hibernate.criterion.Projections
The query row count, ie.
rowDeleted() - Method in class org.hibernate.jdbc.ResultSetWrapper

rowIdName - Variable in class org.hibernate.persister.entity.AbstractEntityPersister

rowInserted() - Method in class org.hibernate.jdbc.ResultSetWrapper

rowUpdated() - Method in class org.hibernate.jdbc.ResultSetWrapper

S

SAPDBDialect - class org.hibernate.dialect.SAPDBDialect.
An SQL dialect compatible with SAP DB.
SAPDBDialect() - Constructor for class org.hibernate.dialect.SAPDBDialect

SAVE_UPDATE - Static variable in class org.hibernate.engine.CascadingAction

SAVE_UPDATE_COPY - Static variable in class org.hibernate.engine.CascadingAction

SAVING - Static variable in class org.hibernate.engine.Status

SCHEMA - Static variable in interface org.hibernate.id.PersistentIdentifierGenerator
The configuration parameter holding the schema name
SCROLL_INSENSITIVE - Static variable in class org.hibernate.ScrollMode
Note that since the Hibernate session acts as a cache, you might need to expicitly evict objects, if you need to see changes made by other transactions.
SCROLL_SENSITIVE - Static variable in class org.hibernate.ScrollMode

SELECT - Static variable in class org.hibernate.FetchMode
Fetch eagerly, using a separate select.
SELECT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

SELECT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

SELECT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

SELECT_CLAUSE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

SELECT_CLAUSE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

SELECT_COLUMNS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

SELECT_COLUMNS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

SELECT_EXPR - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

SELECT_EXPR - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

SELECT_FROM - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

SELECT_FROM - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

SELECT_FROM - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

SEQUENCE - Static variable in class org.hibernate.id.SequenceGenerator
The sequence parameter
SERIALIZABLE - Static variable in class org.hibernate.Hibernate
Hibernate serializable type.
SESSION_FACTORY_NAME - Static variable in class org.hibernate.cfg.Environment
JNDI name to bind to SessionFactory
SET - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

SET - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

SET - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

SHORT - Static variable in class org.hibernate.Hibernate
Hibernate short type.
SHORT_CIRCUIT_INDICATOR - Static variable in class org.hibernate.id.IdentifierGeneratorFactory

SHOW_SQL - Static variable in class org.hibernate.cfg.Environment
Enable logging of generated SQL to the console
SOME - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

SOME - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

SOME - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

SQL - Static variable in interface org.hibernate.id.PersistentIdentifierGenerator

SQLCriterion - class org.hibernate.criterion.SQLCriterion.
A SQL fragment.
SQLCriterion(String, Object[], Type[]) - Constructor for class org.hibernate.criterion.SQLCriterion

SQLCustomQuery - class org.hibernate.loader.custom.sql.SQLCustomQuery.
Implements Hibernate's built-in support for native SQL queries.
SQLCustomQuery(String, NativeSQLQueryReturn[], Collection, SessionFactoryImplementor) - Constructor for class org.hibernate.loader.custom.sql.SQLCustomQuery

SQLExceptionConverter - interface org.hibernate.exception.SQLExceptionConverter.
Defines a contract for implementations that know how to convert a SQLException into Hibernate's JDBCException hierarchy.
SQLExceptionConverterFactory - class org.hibernate.exception.SQLExceptionConverterFactory.
A factory for building SQLExceptionConverter instances.
SQLFunction - interface org.hibernate.dialect.function.SQLFunction.
Provides support routines for the HQL functions as used in the various SQL Dialects Provides an interface for supporting various HQL functions that are translated to SQL.
SQLFunctionRegistry - class org.hibernate.dialect.function.SQLFunctionRegistry.

SQLFunctionRegistry(Dialect, Map) - Constructor for class org.hibernate.dialect.function.SQLFunctionRegistry

SQLFunctionTemplate - class org.hibernate.dialect.function.SQLFunctionTemplate.
Represents HQL functions that can have different representations in different SQL dialects.
SQLFunctionTemplate(Type, String) - Constructor for class org.hibernate.dialect.function.SQLFunctionTemplate

SQLFunctionTemplate(Type, String, boolean) - Constructor for class org.hibernate.dialect.function.SQLFunctionTemplate

SQLGrammarException - exception org.hibernate.exception.SQLGrammarException.
Implementation of JDBCException indicating that the SQL sent to the database server was invalid (syntax error, invalid object references, etc).
SQLGrammarException(String, SQLException) - Constructor for class org.hibernate.exception.SQLGrammarException
Constructor for JDBCException.
SQLGrammarException(String, SQLException, String) - Constructor for class org.hibernate.exception.SQLGrammarException
Constructor for JDBCException.
SQLLoadable - interface org.hibernate.persister.entity.SQLLoadable.
A class persister that supports queries expressed in the platform native SQL dialect
SQLLoadableCollection - interface org.hibernate.persister.collection.SQLLoadableCollection.

SQLProjection - class org.hibernate.criterion.SQLProjection.
A SQL fragment.
SQLProjection(String, String[], Type[]) - Constructor for class org.hibernate.criterion.SQLProjection

SQLProjection(String, String, String[], Type[]) - Constructor for class org.hibernate.criterion.SQLProjection

SQLQuery - interface org.hibernate.SQLQuery.
Allows the user to declare the types and select list injection points of all entities returned by the query.
SQLQueryImpl - class org.hibernate.impl.SQLQueryImpl.
Implements SQL query passthrough.
SQLQueryParser - class org.hibernate.loader.custom.sql.SQLQueryParser.

SQLQueryParser(String, SQLQueryParser.ParserContext) - Constructor for class org.hibernate.loader.custom.sql.SQLQueryParser

SQLQueryParser.ParameterSubstitutionRecognizer - class org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer.

SQLQueryParser.ParameterSubstitutionRecognizer() - Constructor for class org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer

SQLQueryReturnProcessor - class org.hibernate.loader.custom.sql.SQLQueryReturnProcessor.
Responsible for processing the series of returns defined by a NativeSQLQuerySpecification and breaking them down into a series of returns for use within the CustomLoader.
SQLQueryReturnProcessor(NativeSQLQueryReturn[], SessionFactoryImplementor) - Constructor for class org.hibernate.loader.custom.sql.SQLQueryReturnProcessor

SQLServerDialect - class org.hibernate.dialect.SQLServerDialect.
A dialect for Microsoft SQL Server 2000
SQLServerDialect() - Constructor for class org.hibernate.dialect.SQLServerDialect

SQLStateConverter - class org.hibernate.exception.SQLStateConverter.
A SQLExceptionConverter implementation which performs converion based on the underlying SQLState.
SQLStateConverter(ViolatedConstraintNameExtracter) - Constructor for class org.hibernate.exception.SQLStateConverter

SQL_EXCEPTION_CONVERTER - Static variable in class org.hibernate.cfg.Environment
The SQLExceptionConverter to use for converting SQLExceptions to Hibernate's JDBCException hierarchy.
SQL_LOG - Static variable in class org.hibernate.jdbc.AbstractBatcher

SQL_NE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

SQL_NE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

SQL_NE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

SQL_NODE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

SQL_TOKEN - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

SQL_TOKEN - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

STAR - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

STAR - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

STAR - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

START - Static variable in class org.hibernate.criterion.MatchMode
Match the start of the string to the pattern
STATEMENT_BATCH_SIZE - Static variable in class org.hibernate.cfg.Environment
Maximum JDBC batch size.
STATEMENT_FETCH_SIZE - Static variable in class org.hibernate.cfg.Environment
Gives the JDBC driver a hint as to the number of rows that should be fetched from the database when more rows are needed.
STRING - Static variable in class org.hibernate.Hibernate
Hibernate string type.
SUM - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

SUM - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

SUM - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

SaveOrUpdateEvent - class org.hibernate.event.SaveOrUpdateEvent.
An event class for saveOrUpdate()
SaveOrUpdateEvent(String, Object, EventSource) - Constructor for class org.hibernate.event.SaveOrUpdateEvent

SaveOrUpdateEvent(String, Object, Serializable, EventSource) - Constructor for class org.hibernate.event.SaveOrUpdateEvent

SaveOrUpdateEvent(Object, EventSource) - Constructor for class org.hibernate.event.SaveOrUpdateEvent

SaveOrUpdateEventListener - interface org.hibernate.event.SaveOrUpdateEventListener.
Defines the contract for handling of update events generated from a session.
ScalarReturn - class org.hibernate.loader.custom.ScalarReturn.
Represent a scalar (aka simple value) return within a query result.
ScalarReturn(Type, String) - Constructor for class org.hibernate.loader.custom.ScalarReturn

SchemaExport - class org.hibernate.tool.hbm2ddl.SchemaExport.
Commandline tool to export table schema to the database.
SchemaExport(Configuration) - Constructor for class org.hibernate.tool.hbm2ddl.SchemaExport
Create a schema exporter for the given Configuration
SchemaExport(Configuration, Settings) - Constructor for class org.hibernate.tool.hbm2ddl.SchemaExport
Create a schema exporter for the given Configuration and given settings
SchemaExport(Configuration, Properties) - Constructor for class org.hibernate.tool.hbm2ddl.SchemaExport
Deprecated. properties may be specified via the Configuration object
SchemaExport(Configuration, Connection) - Constructor for class org.hibernate.tool.hbm2ddl.SchemaExport

SchemaExportTask - class org.hibernate.tool.hbm2ddl.SchemaExportTask.
An Ant task for SchemaExport.
SchemaExportTask() - Constructor for class org.hibernate.tool.hbm2ddl.SchemaExportTask

SchemaUpdate - class org.hibernate.tool.hbm2ddl.SchemaUpdate.
A commandline tool to update a database schema.
SchemaUpdate(Configuration) - Constructor for class org.hibernate.tool.hbm2ddl.SchemaUpdate

SchemaUpdate(Configuration, Properties) - Constructor for class org.hibernate.tool.hbm2ddl.SchemaUpdate

SchemaUpdate(Configuration, Settings) - Constructor for class org.hibernate.tool.hbm2ddl.SchemaUpdate

SchemaUpdateTask - class org.hibernate.tool.hbm2ddl.SchemaUpdateTask.
An Ant task for SchemaUpdate.
SchemaUpdateTask() - Constructor for class org.hibernate.tool.hbm2ddl.SchemaUpdateTask

SchemaValidator - class org.hibernate.tool.hbm2ddl.SchemaValidator.
A commandline tool to update a database schema.
SchemaValidator(Configuration) - Constructor for class org.hibernate.tool.hbm2ddl.SchemaValidator

SchemaValidator(Configuration, Properties) - Constructor for class org.hibernate.tool.hbm2ddl.SchemaValidator

SchemaValidator(Configuration, Settings) - Constructor for class org.hibernate.tool.hbm2ddl.SchemaValidator

SchemaValidatorTask - class org.hibernate.tool.hbm2ddl.SchemaValidatorTask.
An Ant task for SchemaUpdate.
SchemaValidatorTask() - Constructor for class org.hibernate.tool.hbm2ddl.SchemaValidatorTask

ScrollMode - class org.hibernate.ScrollMode.
Specifies the type of JDBC scrollable result set to use underneath a ScrollableResults
ScrollableResults - interface org.hibernate.ScrollableResults.
A result iterator that allows moving around within the results by arbitrary increments.
ScrollableResultsImpl - class org.hibernate.impl.ScrollableResultsImpl.
Implementation of the ScrollableResults interface
ScrollableResultsImpl(ResultSet, PreparedStatement, SessionImplementor, Loader, QueryParameters, Type[], HolderInstantiator) - Constructor for class org.hibernate.impl.ScrollableResultsImpl

SecondLevelCacheStatistics - class org.hibernate.stat.SecondLevelCacheStatistics.
Second level cache statistics of a specific region
SecondPass - interface org.hibernate.cfg.SecondPass.
Second pass operation
Select - class org.hibernate.sql.Select.
A simple SQL SELECT statement
Select(Dialect) - Constructor for class org.hibernate.sql.Select

SelectClause - class org.hibernate.hql.ast.tree.SelectClause.
Represents the list of expressions in a SELECT clause.
SelectClause() - Constructor for class org.hibernate.hql.ast.tree.SelectClause

SelectExpression - interface org.hibernate.hql.ast.tree.SelectExpression.
Represents an element of a projection list, i.e.
SelectExpressionImpl - class org.hibernate.hql.ast.tree.SelectExpressionImpl.
A select expression that was generated by a FROM element.
SelectExpressionImpl() - Constructor for class org.hibernate.hql.ast.tree.SelectExpressionImpl

SelectExpressionList - class org.hibernate.hql.ast.tree.SelectExpressionList.
Common behavior - a node that contains a list of select expressions.
SelectExpressionList() - Constructor for class org.hibernate.hql.ast.tree.SelectExpressionList

SelectFragment - class org.hibernate.sql.SelectFragment.
A fragment of an SQL SELECT clause
SelectFragment() - Constructor for class org.hibernate.sql.SelectFragment

SelectGenerator - class org.hibernate.id.SelectGenerator.
A generator that selects the just inserted row to determine the identifier value assigned by the database.
SelectGenerator() - Constructor for class org.hibernate.id.SelectGenerator

SelectGenerator.SelectGeneratorDelegate - class org.hibernate.id.SelectGenerator.SelectGeneratorDelegate.
The delegate for the select generation strategy.
SelectLockingStrategy - class org.hibernate.dialect.lock.SelectLockingStrategy.
A locking strategy where the locks are obtained through select statements.
SelectLockingStrategy(Lockable, LockMode) - Constructor for class org.hibernate.dialect.lock.SelectLockingStrategy
Construct a locking strategy based on SQL SELECT statements.
SelectParser - class org.hibernate.hql.classic.SelectParser.
Parsers the select clause of a Hibernate query.
SelectParser() - Constructor for class org.hibernate.hql.classic.SelectParser

SelectPathExpressionParser - class org.hibernate.hql.classic.SelectPathExpressionParser.

SelectPathExpressionParser() - Constructor for class org.hibernate.hql.classic.SelectPathExpressionParser

Selectable - interface org.hibernate.mapping.Selectable.

SequenceGenerator - class org.hibernate.id.SequenceGenerator.
sequence

Generates long values using an oracle-style sequence.
SequenceGenerator() - Constructor for class org.hibernate.id.SequenceGenerator

SequenceHiLoGenerator - class org.hibernate.id.SequenceHiLoGenerator.
seqhilo

An IdentifierGenerator that combines a hi/lo algorithm with an underlying oracle-style sequence that generates hi values.
SequenceHiLoGenerator() - Constructor for class org.hibernate.id.SequenceHiLoGenerator

SequenceIdentityGenerator - class org.hibernate.id.SequenceIdentityGenerator.
A generator which combines sequence generation with immediate retrieval through JDBC3 getGeneratedKeys.
SequenceIdentityGenerator() - Constructor for class org.hibernate.id.SequenceIdentityGenerator

SequenceIdentityGenerator.Delegate - class org.hibernate.id.SequenceIdentityGenerator.Delegate.

SequenceIdentityGenerator.Delegate(PostInsertIdentityPersister, Dialect, String) - Constructor for class org.hibernate.id.SequenceIdentityGenerator.Delegate

SequenceIdentityGenerator.NoCommentsInsert - class org.hibernate.id.SequenceIdentityGenerator.NoCommentsInsert.

SequenceIdentityGenerator.NoCommentsInsert(Dialect) - Constructor for class org.hibernate.id.SequenceIdentityGenerator.NoCommentsInsert

SerializableBlob - class org.hibernate.lob.SerializableBlob.

SerializableBlob(Blob) - Constructor for class org.hibernate.lob.SerializableBlob

SerializableClob - class org.hibernate.lob.SerializableClob.

SerializableClob(Clob) - Constructor for class org.hibernate.lob.SerializableClob

SerializableProxy - class org.hibernate.proxy.pojo.cglib.SerializableProxy.
Serializable placeholder for CGLIB proxies
SerializableProxy() - Constructor for class org.hibernate.proxy.pojo.cglib.SerializableProxy

SerializableProxy(String, Class, Class[], Serializable, Method, Method, AbstractComponentType) - Constructor for class org.hibernate.proxy.pojo.cglib.SerializableProxy

SerializableProxy - class org.hibernate.proxy.pojo.javassist.SerializableProxy.
Serializable placeholder for Javassist proxies
SerializableProxy() - Constructor for class org.hibernate.proxy.pojo.javassist.SerializableProxy

SerializableProxy(String, Class, Class[], Serializable, Method, Method, AbstractComponentType) - Constructor for class org.hibernate.proxy.pojo.javassist.SerializableProxy

SerializableType - class org.hibernate.type.SerializableType.
serializable: A type that maps an SQL VARBINARY to a serializable Java object.
SerializableType(Class) - Constructor for class org.hibernate.type.SerializableType

SerializationException - exception org.hibernate.type.SerializationException.
Thrown when a property cannot be serializaed/deserialized
SerializationException(String, Exception) - Constructor for class org.hibernate.type.SerializationException

SerializationHelper - class org.hibernate.util.SerializationHelper.
Assists with the serialization process and performs additional functionality based on serialization.
Session - interface org.hibernate.Session.
The main runtime interface between a Java application and Hibernate.
Session - interface org.hibernate.classic.Session.
An extension of the Session API, including all deprecated methods from Hibernate2.
SessionException - exception org.hibernate.SessionException.
Thrown when the user calls a method of a Session that is in an inappropropriate state for the given call (for example, the the session is closed or disconnected).
SessionException(String) - Constructor for class org.hibernate.SessionException
Constructs a new SessionException with the given message.
SessionFactory - interface org.hibernate.SessionFactory.
Creates Sessions.
SessionFactoryAwareNode - interface org.hibernate.hql.ast.tree.SessionFactoryAwareNode.
Interface for nodes which require access to the SessionFactory
SessionFactoryHelper - class org.hibernate.hql.ast.util.SessionFactoryHelper.
Wraps SessionFactoryImpl, adding more lookup behaviors and encapsulating some of the error handling.
SessionFactoryHelper(SessionFactoryImplementor) - Constructor for class org.hibernate.hql.ast.util.SessionFactoryHelper
Construct a new SessionFactoryHelper instance.
SessionFactoryImpl - class org.hibernate.impl.SessionFactoryImpl.
Concrete implementation of the SessionFactory interface.
SessionFactoryImpl(Configuration, Mapping, Settings, EventListeners) - Constructor for class org.hibernate.impl.SessionFactoryImpl

SessionFactoryImplementor - interface org.hibernate.engine.SessionFactoryImplementor.
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.
SessionFactoryObjectFactory - class org.hibernate.impl.SessionFactoryObjectFactory.
Resolves SessionFactory JNDI lookups and deserialization
SessionFactoryObjectFactory() - Constructor for class org.hibernate.impl.SessionFactoryObjectFactory

SessionFactoryStub - class org.hibernate.jmx.SessionFactoryStub.
A flyweight for SessionFactory.
SessionImpl - class org.hibernate.impl.SessionImpl.
Concrete implementation of a Session, and also the central, organizing component of Hibernate's internal implementation.
SessionImplementor - interface org.hibernate.engine.SessionImplementor.
Defines the internal contract between the Session and other parts of Hibernate such as implementors of Type or EntityPersister.
SessionStatistics - interface org.hibernate.stat.SessionStatistics.
Information about the first-level (session) cache for a particular session instance
SessionStatisticsImpl - class org.hibernate.stat.SessionStatisticsImpl.

SessionStatisticsImpl(SessionImplementor) - Constructor for class org.hibernate.stat.SessionStatisticsImpl

Set - class org.hibernate.mapping.Set.
A set with no nullable element columns.
Set(PersistentClass) - Constructor for class org.hibernate.mapping.Set
Constructor for Set.
SetType - class org.hibernate.type.SetType.

SetType(String, String, boolean) - Constructor for class org.hibernate.type.SetType

Setter - interface org.hibernate.property.Setter.
Sets values to a particular property.
Settings - class org.hibernate.cfg.Settings.
Settings that affect the behaviour of Hibernate at runtime.
SettingsFactory - class org.hibernate.cfg.SettingsFactory.
Reads configuration properties and configures a Settings instance.
SettingsFactory() - Constructor for class org.hibernate.cfg.SettingsFactory

ShortType - class org.hibernate.type.ShortType.
short: A type that maps an SQL SMALLINT to a Java Short.
ShortType() - Constructor for class org.hibernate.type.ShortType

SimpleAuxiliaryDatabaseObject - class org.hibernate.mapping.SimpleAuxiliaryDatabaseObject.
A simple implementation of AbstractAuxiliaryDatabaseObject in which the CREATE and DROP strings are provided up front.
SimpleAuxiliaryDatabaseObject(String, String) - Constructor for class org.hibernate.mapping.SimpleAuxiliaryDatabaseObject

SimpleAuxiliaryDatabaseObject(String, String, HashSet) - Constructor for class org.hibernate.mapping.SimpleAuxiliaryDatabaseObject

SimpleExpression - class org.hibernate.criterion.SimpleExpression.
superclass for "simple" comparisons (with SQL binary operators)
SimpleExpression(String, Object, String) - Constructor for class org.hibernate.criterion.SimpleExpression

SimpleExpression(String, Object, String, boolean) - Constructor for class org.hibernate.criterion.SimpleExpression

SimpleMRUCache - class org.hibernate.util.SimpleMRUCache.
Cache following a "Most Recently Used" (MRU) algorithm for maintaining a bounded in-memory size; the "Least Recently Used" (LRU) entry is the first available for removal from the cache.
SimpleMRUCache() - Constructor for class org.hibernate.util.SimpleMRUCache

SimpleMRUCache(int) - Constructor for class org.hibernate.util.SimpleMRUCache

SimpleProjection - class org.hibernate.criterion.SimpleProjection.
A single-column projection that may be aliased
SimpleProjection() - Constructor for class org.hibernate.criterion.SimpleProjection

SimpleSelect - class org.hibernate.sql.SimpleSelect.
An SQL SELECT statement with no table joins
SimpleSelect(Dialect) - Constructor for class org.hibernate.sql.SimpleSelect

SimpleSubqueryExpression - class org.hibernate.criterion.SimpleSubqueryExpression.
A comparison between a constant value and the the result of a subquery
SimpleSubqueryExpression(Object, String, String, DetachedCriteria) - Constructor for class org.hibernate.criterion.SimpleSubqueryExpression

SimpleValue - class org.hibernate.mapping.SimpleValue.
Any value that maps to columns.
SimpleValue(Table) - Constructor for class org.hibernate.mapping.SimpleValue

SimpleValue() - Constructor for class org.hibernate.mapping.SimpleValue

SingleTableEntityPersister - class org.hibernate.persister.entity.SingleTableEntityPersister.
The default implementation of the EntityPersister interface.
SingleTableEntityPersister(PersistentClass, CacheConcurrencyStrategy, SessionFactoryImplementor, Mapping) - Constructor for class org.hibernate.persister.entity.SingleTableEntityPersister

SingleTableSubclass - class org.hibernate.mapping.SingleTableSubclass.

SingleTableSubclass(PersistentClass) - Constructor for class org.hibernate.mapping.SingleTableSubclass

SingletonIterator - class org.hibernate.util.SingletonIterator.

SingletonIterator(Object) - Constructor for class org.hibernate.util.SingletonIterator

SizeExpression - class org.hibernate.criterion.SizeExpression.

SizeExpression(String, int, String) - Constructor for class org.hibernate.criterion.SizeExpression

SoftLimitMRUCache - class org.hibernate.util.SoftLimitMRUCache.
Cache following a "Most Recently Used" (MRY) algorithm for maintaining a bounded in-memory size; the "Least Recently Used" (LRU) entry is the first available for removal from the cache.
SoftLimitMRUCache() - Constructor for class org.hibernate.util.SoftLimitMRUCache

SoftLimitMRUCache(int) - Constructor for class org.hibernate.util.SoftLimitMRUCache

SortedMapType - class org.hibernate.type.SortedMapType.

SortedMapType(String, String, Comparator, boolean) - Constructor for class org.hibernate.type.SortedMapType

SortedSetType - class org.hibernate.type.SortedSetType.

SortedSetType(String, String, Comparator, boolean) - Constructor for class org.hibernate.type.SortedSetType

SpecialOneToOneType - class org.hibernate.type.SpecialOneToOneType.
A one-to-one association that maps to specific formula(s) instead of the primary key column of the owning entity.
SpecialOneToOneType(String, ForeignKeyDirection, String, boolean, boolean, String, String) - Constructor for class org.hibernate.type.SpecialOneToOneType

SqlASTFactory - class org.hibernate.hql.ast.SqlASTFactory.
Custom AST factory the intermediate tree that causes ANTLR to create specialized AST nodes, given the AST node type (from HqlSqlTokenTypes).
SqlASTFactory(HqlSqlWalker) - Constructor for class org.hibernate.hql.ast.SqlASTFactory
Create factory with a specific mapping from token type to Java AST node type.
SqlFragment - class org.hibernate.hql.ast.tree.SqlFragment.
Represents an SQL fragment in the AST.
SqlFragment() - Constructor for class org.hibernate.hql.ast.tree.SqlFragment

SqlGenerator - class org.hibernate.hql.ast.SqlGenerator.
Generates SQL by overriding callback methods in the base class, which does the actual SQL AST walking.
SqlGenerator(SessionFactoryImplementor) - Constructor for class org.hibernate.hql.ast.SqlGenerator

SqlGeneratorBase - class org.hibernate.hql.antlr.SqlGeneratorBase.
SQL Generator Tree Parser, providing SQL rendering of SQL ASTs produced by the previous phase, HqlSqlWalker.
SqlGeneratorBase() - Constructor for class org.hibernate.hql.antlr.SqlGeneratorBase

SqlNode - class org.hibernate.hql.ast.tree.SqlNode.
A base AST node for the intermediate tree.
SqlNode() - Constructor for class org.hibernate.hql.ast.tree.SqlNode

SqlTokenTypes - interface org.hibernate.hql.antlr.SqlTokenTypes.

StaleObjectStateException - exception org.hibernate.StaleObjectStateException.
A StaleStateException that carries information about a particular entity instance that was the source of the failure.
StaleObjectStateException(String, Serializable) - Constructor for class org.hibernate.StaleObjectStateException

StaleStateException - exception org.hibernate.StaleStateException.
Thrown when a version number or timestamp check failed, indicating that the Session contained stale data (when using long transactions with versioning).
StaleStateException(String) - Constructor for class org.hibernate.StaleStateException

StandardProperty - class org.hibernate.tuple.StandardProperty.
Represents a basic property within the Hibernate runtime-metamodel.
StandardProperty(String, String, Type, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean, CascadeStyle, FetchMode) - Constructor for class org.hibernate.tuple.StandardProperty
Constructs StandardProperty instances.
StandardQueryCache - class org.hibernate.cache.StandardQueryCache.
The standard implementation of the Hibernate QueryCache interface.
StandardQueryCache(Settings, Properties, UpdateTimestampsCache, String) - Constructor for class org.hibernate.cache.StandardQueryCache

StandardQueryCacheFactory - class org.hibernate.cache.StandardQueryCacheFactory.
Standard Hibernate implementation of the QueryCacheFactory interface.
StandardQueryCacheFactory() - Constructor for class org.hibernate.cache.StandardQueryCacheFactory

StandardSQLFunction - class org.hibernate.dialect.function.StandardSQLFunction.
Provides a standard implementation that supports the majority of the HQL functions that are translated to SQL.
StandardSQLFunction(String) - Constructor for class org.hibernate.dialect.function.StandardSQLFunction

StandardSQLFunction(String, Type) - Constructor for class org.hibernate.dialect.function.StandardSQLFunction

StatefulPersistenceContext - class org.hibernate.engine.StatefulPersistenceContext.
A PersistenceContext represents the state of persistent "stuff" which Hibernate is tracking.
StatefulPersistenceContext(SessionImplementor) - Constructor for class org.hibernate.engine.StatefulPersistenceContext
Constructs a PersistentContext, bound to the given session.
StatelessSession - interface org.hibernate.StatelessSession.
A command-oriented API for performing bulk operations against a database.

A stateless session does not implement a first-level cache nor interact with any second-level cache, nor does it implement transactional write-behind or automatic dirty checking, nor do operations cascade to associated instances.
StatelessSessionImpl - class org.hibernate.impl.StatelessSessionImpl.

Statement - interface org.hibernate.hql.ast.tree.Statement.
Common interface modeling the different HQL statements (i.e., INSERT, UPDATE, DELETE, SELECT).
StatementExecutor - interface org.hibernate.hql.ast.exec.StatementExecutor.
Encapsulates the strategy required to execute various types of update, delete, and insert statements issued through HQL.
Statistics - interface org.hibernate.stat.Statistics.
Statistics for a particular SessionFactory.
StatisticsImpl - class org.hibernate.stat.StatisticsImpl.

StatisticsImpl() - Constructor for class org.hibernate.stat.StatisticsImpl

StatisticsImpl(SessionFactoryImplementor) - Constructor for class org.hibernate.stat.StatisticsImpl

StatisticsImplementor - interface org.hibernate.stat.StatisticsImplementor.
Statistics SPI for the Hibernate core
StatisticsService - class org.hibernate.jmx.StatisticsService.
JMX service for Hibernate statistics

Register this MBean in your JMX server for a specific session factory
StatisticsService() - Constructor for class org.hibernate.jmx.StatisticsService

StatisticsServiceMBean - interface org.hibernate.jmx.StatisticsServiceMBean.
MBean exposing Session Factory statistics
Status - class org.hibernate.engine.Status.
Represents the status of an entity with respect to this session.
StringHelper - class org.hibernate.util.StringHelper.

StringType - class org.hibernate.type.StringType.
string: A type that maps an SQL VARCHAR to a Java String.
StringType() - Constructor for class org.hibernate.type.StringType

StructuredCacheEntry - class org.hibernate.cache.entry.StructuredCacheEntry.

StructuredCacheEntry(EntityPersister) - Constructor for class org.hibernate.cache.entry.StructuredCacheEntry

StructuredCollectionCacheEntry - class org.hibernate.cache.entry.StructuredCollectionCacheEntry.

StructuredCollectionCacheEntry() - Constructor for class org.hibernate.cache.entry.StructuredCollectionCacheEntry

StructuredMapCacheEntry - class org.hibernate.cache.entry.StructuredMapCacheEntry.

StructuredMapCacheEntry() - Constructor for class org.hibernate.cache.entry.StructuredMapCacheEntry

Subclass - class org.hibernate.mapping.Subclass.
A sublass in a table-per-class-hierarchy mapping
Subclass(PersistentClass) - Constructor for class org.hibernate.mapping.Subclass

Subqueries - class org.hibernate.criterion.Subqueries.
Factory class for criterion instances that represent expressions involving subqueries.
Subqueries() - Constructor for class org.hibernate.criterion.Subqueries

SubqueryExpression - class org.hibernate.criterion.SubqueryExpression.

SubqueryExpression(String, String, DetachedCriteria) - Constructor for class org.hibernate.criterion.SubqueryExpression

SubselectCollectionLoader - class org.hibernate.loader.collection.SubselectCollectionLoader.
Implements subselect fetching for a collection
SubselectCollectionLoader(QueryableCollection, String, Collection, QueryParameters, Map, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.collection.SubselectCollectionLoader

SubselectFetch - class org.hibernate.engine.SubselectFetch.

SubselectFetch(String, Loadable, QueryParameters, Set, Map) - Constructor for class org.hibernate.engine.SubselectFetch

SubselectOneToManyLoader - class org.hibernate.loader.collection.SubselectOneToManyLoader.
Implements subselect fetching for a one to many association
SubselectOneToManyLoader(QueryableCollection, String, Collection, QueryParameters, Map, SessionFactoryImplementor, Map) - Constructor for class org.hibernate.loader.collection.SubselectOneToManyLoader

SunONETransactionManagerLookup - class org.hibernate.transaction.SunONETransactionManagerLookup.
TransactionManager lookup strategy for Sun ONE Application Server 7
SunONETransactionManagerLookup() - Constructor for class org.hibernate.transaction.SunONETransactionManagerLookup

SwarmCache - class org.hibernate.cache.SwarmCache.

SwarmCache(ObjectCache, String) - Constructor for class org.hibernate.cache.SwarmCache

SwarmCacheProvider - class org.hibernate.cache.SwarmCacheProvider.
Support for SwarmCache replicated cache.
SwarmCacheProvider() - Constructor for class org.hibernate.cache.SwarmCacheProvider

Sybase11Dialect - class org.hibernate.dialect.Sybase11Dialect.
A SQL dialect suitable for use with Sybase 11.9.2 (specifically: avoids ANSI JOIN syntax)
Sybase11Dialect() - Constructor for class org.hibernate.dialect.Sybase11Dialect

Sybase11JoinFragment - class org.hibernate.sql.Sybase11JoinFragment.
An old Sybase-style join (before Sybase supported the ANSI style "inner join" etc syntax) This is needed for Sybase 11.9.2 and earlier, using the HQL 2.* syntax with Collections.
Sybase11JoinFragment() - Constructor for class org.hibernate.sql.Sybase11JoinFragment

SybaseAnywhereDialect - class org.hibernate.dialect.SybaseAnywhereDialect.
SQL Dialect for Sybase Anywhere extending Sybase (Enterprise) Dialect (Tested on ASA 8.x)
SybaseAnywhereDialect() - Constructor for class org.hibernate.dialect.SybaseAnywhereDialect

SybaseDialect - class org.hibernate.dialect.SybaseDialect.
An SQL dialect compatible with Sybase and MS SQL Server.
SybaseDialect() - Constructor for class org.hibernate.dialect.SybaseDialect

SyntheticAndFactory - class org.hibernate.hql.ast.util.SyntheticAndFactory.
Creates synthetic and nodes based on the where fragment part of a JoinSequence.
SyntheticAndFactory(ASTFactory) - Constructor for class org.hibernate.hql.ast.util.SyntheticAndFactory

save(Object) - Method in interface org.hibernate.Session
Persist the given transient instance, first assigning a generated identifier.
save(String, Object) - Method in interface org.hibernate.Session
Persist the given transient instance, first assigning a generated identifier.
save(Object, Serializable) - Method in interface org.hibernate.classic.Session
Deprecated. declare identifier properties for all classes
save(String, Object, Serializable) - Method in interface org.hibernate.classic.Session
Deprecated. declare identifier properties for all classes
save(Object, Serializable) - Method in class org.hibernate.impl.SessionImpl

save(Object) - Method in class org.hibernate.impl.SessionImpl

save(String, Object) - Method in class org.hibernate.impl.SessionImpl

save(String, Object, Serializable) - Method in class org.hibernate.impl.SessionImpl

saveOrUpdate(Object) - Method in interface org.hibernate.Session
Either save() or update() the given instance, depending upon the value of its identifier property.
saveOrUpdate(String, Object) - Method in interface org.hibernate.Session
Either save() or update() the given instance, depending upon the value of its identifier property.
saveOrUpdate(Object) - Method in class org.hibernate.impl.SessionImpl

saveOrUpdate(String, Object) - Method in class org.hibernate.impl.SessionImpl

saveOrUpdateCopy(Object) - Method in interface org.hibernate.classic.Session
Deprecated. use Session.merge(Object)
saveOrUpdateCopy(Object, Serializable) - Method in interface org.hibernate.classic.Session
Deprecated. with no replacement
saveOrUpdateCopy(String, Object) - Method in interface org.hibernate.classic.Session
Deprecated. use Session.merge(String, Object)
saveOrUpdateCopy(String, Object, Serializable) - Method in interface org.hibernate.classic.Session
Deprecated. with no replacement
saveOrUpdateCopy(String, Object, Map) - Method in interface org.hibernate.event.EventSource
Cascade copy an entity instance
saveOrUpdateCopy(String, Object) - Method in class org.hibernate.impl.SessionImpl

saveOrUpdateCopy(Object) - Method in class org.hibernate.impl.SessionImpl

saveOrUpdateCopy(String, Object, Serializable) - Method in class org.hibernate.impl.SessionImpl

saveOrUpdateCopy(Object, Serializable) - Method in class org.hibernate.impl.SessionImpl

saveOrUpdateCopy(String, Object, Map) - Method in class org.hibernate.impl.SessionImpl

saveWithGeneratedId(Object, String, Object, EventSource, boolean) - Method in class org.hibernate.event.def.AbstractSaveEventListener
Prepares the save call using a newly generated id.
saveWithGeneratedOrRequestedId(SaveOrUpdateEvent) - Method in class org.hibernate.event.def.DefaultSaveEventListener

saveWithGeneratedOrRequestedId(SaveOrUpdateEvent) - Method in class org.hibernate.event.def.DefaultSaveOrUpdateEventListener
Save the transient instance, assigning the right identifier
saveWithRequestedId(Object, Serializable, String, Object, EventSource) - Method in class org.hibernate.event.def.AbstractSaveEventListener
Prepares the save call using the given requested id.
scalarName(int, int) - Static method in class org.hibernate.hql.NameGenerator

schemaName - Variable in class org.hibernate.cfg.Mappings

scroll() - Method in interface org.hibernate.Criteria
Get the results as an instance of ScrollableResults
scroll(ScrollMode) - Method in interface org.hibernate.Criteria
Get the results as an instance of ScrollableResults based on the given scroll mode.
scroll() - Method in interface org.hibernate.Query
Return the query results as ScrollableResults.
scroll(ScrollMode) - Method in interface org.hibernate.Query
Return the query results as ScrollableResults.
scroll(int) - Method in interface org.hibernate.ScrollableResults
Scroll an arbitrary number of locations
scroll(String, QueryParameters) - Method in interface org.hibernate.engine.SessionImplementor
Execute a scroll() query
scroll(CriteriaImpl, ScrollMode) - Method in interface org.hibernate.engine.SessionImplementor
Execute a criteria query
scroll(NativeSQLQuerySpecification, QueryParameters) - Method in interface org.hibernate.engine.SessionImplementor
Execute a native SQL query, and return the results as a scrollable result.
scroll(QueryParameters, SessionImplementor) - Method in interface org.hibernate.hql.QueryTranslator
Perform a scroll operation given the underlying query defintion.
scroll(QueryParameters, SessionImplementor) - Method in class org.hibernate.hql.ast.QueryTranslatorImpl
Return the query results, as an instance of ScrollableResults
scroll(QueryParameters, SessionImplementor) - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

scroll(NativeSQLQuerySpecification, QueryParameters) - Method in class org.hibernate.impl.AbstractSessionImpl

scroll() - Method in class org.hibernate.impl.CollectionFilterImpl

scroll() - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

scroll(ScrollMode) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

scroll() - Method in class org.hibernate.impl.CriteriaImpl

scroll(ScrollMode) - Method in class org.hibernate.impl.CriteriaImpl

scroll(int) - Method in class org.hibernate.impl.FetchingScrollableResultsImpl
Scroll an arbitrary number of locations
scroll() - Method in class org.hibernate.impl.QueryImpl

scroll(ScrollMode) - Method in class org.hibernate.impl.QueryImpl

scroll(ScrollMode) - Method in class org.hibernate.impl.SQLQueryImpl

scroll() - Method in class org.hibernate.impl.SQLQueryImpl

scroll(int) - Method in class org.hibernate.impl.ScrollableResultsImpl

scroll(String, QueryParameters) - Method in class org.hibernate.impl.SessionImpl

scroll(CriteriaImpl, ScrollMode) - Method in class org.hibernate.impl.SessionImpl

scroll(CriteriaImpl, ScrollMode) - Method in class org.hibernate.impl.StatelessSessionImpl

scroll(String, QueryParameters) - Method in class org.hibernate.impl.StatelessSessionImpl

scroll(QueryParameters, Type[], HolderInstantiator, SessionImplementor) - Method in class org.hibernate.loader.Loader
Return the query results, as an instance of ScrollableResults
scroll(SessionImplementor, ScrollMode) - Method in class org.hibernate.loader.criteria.CriteriaLoader

scroll(QueryParameters, SessionImplementor) - Method in class org.hibernate.loader.custom.CustomLoader

scroll(QueryParameters, SessionImplementor) - Method in class org.hibernate.loader.hql.QueryLoader

scrollCustomQuery(CustomQuery, QueryParameters) - Method in interface org.hibernate.engine.SessionImplementor
Execute an SQL Query
scrollCustomQuery(CustomQuery, QueryParameters) - Method in class org.hibernate.impl.SessionImpl

scrollCustomQuery(CustomQuery, QueryParameters) - Method in class org.hibernate.impl.StatelessSessionImpl

secondLevelCacheHit(String) - Method in class org.hibernate.stat.StatisticsImpl

secondLevelCacheHit(String) - Method in interface org.hibernate.stat.StatisticsImplementor

secondLevelCacheMiss(String) - Method in class org.hibernate.stat.StatisticsImpl

secondLevelCacheMiss(String) - Method in interface org.hibernate.stat.StatisticsImplementor

secondLevelCachePut(String) - Method in class org.hibernate.stat.StatisticsImpl

secondLevelCachePut(String) - Method in interface org.hibernate.stat.StatisticsImplementor

secondPass(Map, Map) - Method in class org.hibernate.cfg.CollectionSecondPass

secondPassCompile() - Method in class org.hibernate.cfg.Configuration

secondPassCompileForeignKeys(Table, Set) - Method in class org.hibernate.cfg.Configuration

secondPasses - Variable in class org.hibernate.cfg.Configuration

secondPasses - Variable in class org.hibernate.cfg.Mappings

seed(SessionImplementor) - Method in class org.hibernate.type.AbstractBynaryType

seed(SessionImplementor) - Method in class org.hibernate.type.ByteType

seed(SessionImplementor) - Method in class org.hibernate.type.CalendarType

seed(SessionImplementor) - Method in class org.hibernate.type.CustomType

seed(SessionImplementor) - Method in class org.hibernate.type.DbTimestampType

seed(SessionImplementor) - Method in class org.hibernate.type.IntegerType

seed(SessionImplementor) - Method in class org.hibernate.type.LongType

seed(SessionImplementor) - Method in class org.hibernate.type.ShortType

seed(SessionImplementor) - Method in class org.hibernate.type.TimestampType

seed(SessionImplementor) - Method in interface org.hibernate.type.VersionType
Generate an initial version.
seed(SessionImplementor) - Method in interface org.hibernate.usertype.UserVersionType
Generate an initial version.
seedVersion(Object[], int, VersionType, SessionImplementor) - Static method in class org.hibernate.engine.Versioning
Seed the given instance state snapshot with an initial version number
selectAtom(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

selectClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

selectClause(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

selectClause(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

selectColumn(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

selectExpr(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

selectExpr(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

selectExprList(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

selectFragment(String, String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister
Generate a list of collection index, key and element columns
selectFragment(Joinable, String, String, String, String, boolean) - Method in class org.hibernate.persister.collection.BasicCollectionPersister

selectFragment(Joinable, String, String, String, String, boolean) - Method in class org.hibernate.persister.collection.OneToManyPersister

selectFragment(String, String) - Method in interface org.hibernate.persister.collection.QueryableCollection
Generate a list of collection index and element columns
selectFragment(String, String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

selectFragment(Joinable, String, String, String, String, boolean) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

selectFragment(Joinable, String, String, String, String, boolean) - Method in interface org.hibernate.persister.entity.Joinable
All columns to select, when loading.
selectFragment(String, String) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
Generate a list of collection index, key and element columns
selectFragment(String, String) - Method in interface org.hibernate.persister.entity.SQLLoadable
All columns to select, when loading.
selectFrom() - Method in class org.hibernate.hql.antlr.HqlBaseParser

selectNodes(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

selectNodes(String, String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

selectNodes(String, String, boolean) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

selectNodes(String) - Method in class org.hibernate.tuple.ElementWrapper

selectNodes(String, String) - Method in class org.hibernate.tuple.ElementWrapper

selectNodes(String, String, boolean) - Method in class org.hibernate.tuple.ElementWrapper

selectObject() - Method in class org.hibernate.hql.antlr.HqlBaseParser

selectObject(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

selectObject(String) - Method in class org.hibernate.tuple.ElementWrapper

selectSingleNode(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

selectSingleNode(String) - Method in class org.hibernate.tuple.ElementWrapper

selectStatement() - Method in class org.hibernate.hql.antlr.HqlBaseParser

selectStatement(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

selectStatement(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

selectString(List) - Method in class org.hibernate.loader.JoinWalker
Generate a select list of columns containing all properties of the entity classes
selectedPropertiesList() - Method in class org.hibernate.hql.antlr.HqlBaseParser

semiResolve(Object, SessionImplementor, Object) - Method in class org.hibernate.type.AbstractType

semiResolve(Object, SessionImplementor, Object) - Method in class org.hibernate.type.AnyType

semiResolve(Object, SessionImplementor, Object) - Method in class org.hibernate.type.CollectionType

semiResolve(Object, SessionImplementor, Object) - Method in class org.hibernate.type.ComponentType

semiResolve(Object, SessionImplementor, Object) - Method in interface org.hibernate.type.Type
Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.
separator(AST, String) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

serializable(Class) - Static method in class org.hibernate.Hibernate
A Hibernate serializable type.
serializableProxy() - Method in class org.hibernate.proxy.pojo.BasicLazyInitializer

serializableProxy() - Method in class org.hibernate.proxy.pojo.cglib.CGLIBLazyInitializer

serializableProxy() - Method in class org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer

serialize(ObjectOutputStream) - Method in class org.hibernate.engine.ActionQueue
Used by the owning session to explicitly control serialization of the action queue
serialize(ObjectOutputStream) - Method in class org.hibernate.engine.StatefulPersistenceContext
Used by the owning session to explicitly control serialization of the persistence context.
serialize(ObjectOutputStream) - Method in class org.hibernate.jdbc.ConnectionManager

serialize(ObjectOutputStream) - Method in class org.hibernate.jdbc.JDBCContext
Custom serialization routine used during serialization of a Session/PersistenceContext for increased performance.
serialize(Map) - Static method in class org.hibernate.util.IdentityMap
Workaround for a JDK 1.4.1 bug where IdentityHashMaps are not correctly deserialized.
serialize(Serializable, OutputStream) - Static method in class org.hibernate.util.SerializationHelper
Serializes an Object to the specified stream.
serialize(Serializable) - Static method in class org.hibernate.util.SerializationHelper
Serializes an Object to a byte array for storage/serialization.
session - Variable in class org.hibernate.impl.AbstractQueryImpl

sessionMap() - Static method in class org.hibernate.context.ManagedSessionContext

sessionMap() - Static method in class org.hibernate.context.ThreadLocalSessionContext

set(int, Object) - Method in class org.hibernate.collection.PersistentBag

set(int, Object) - Method in class org.hibernate.collection.PersistentIdentifierBag

set(int, Object) - Method in class org.hibernate.collection.PersistentList

set - Variable in class org.hibernate.collection.PersistentSet

set(String, Object) - Method in class org.hibernate.criterion.NaturalIdentifier

set(Object, Object, SessionFactoryImplementor) - Method in class org.hibernate.property.BackrefPropertyAccessor.BackrefSetter

set(Object, Object, SessionFactoryImplementor) - Method in class org.hibernate.property.BasicPropertyAccessor.BasicSetter

set(Object, Object, SessionFactoryImplementor) - Method in class org.hibernate.property.DirectPropertyAccessor.DirectSetter

set(Object, Object, SessionFactoryImplementor) - Method in class org.hibernate.property.Dom4jAccessor.AttributeSetter

set(Object, Object, SessionFactoryImplementor) - Method in class org.hibernate.property.Dom4jAccessor.ElementAttributeSetter

set(Object, Object, SessionFactoryImplementor) - Method in class org.hibernate.property.Dom4jAccessor.ElementSetter

set(Object, Object, SessionFactoryImplementor) - Method in class org.hibernate.property.Dom4jAccessor.TextSetter

set(Object, Object, SessionFactoryImplementor) - Method in class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedSetter

set(Object, Object) - Method in class org.hibernate.property.IndexPropertyAccessor.IndexSetter

set(Object, Object, SessionFactoryImplementor) - Method in class org.hibernate.property.IndexPropertyAccessor.IndexSetter

set(Object, Object, SessionFactoryImplementor) - Method in class org.hibernate.property.MapAccessor.MapSetter

set(Object, Object, SessionFactoryImplementor) - Method in interface org.hibernate.property.Setter
Set the property value from the given instance
set(PreparedStatement, Object, int) - Method in class org.hibernate.type.AbstractBynaryType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.AbstractCharArrayType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.AdaptedImmutableType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.BigDecimalType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.BigIntegerType

set(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.BlobType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.BooleanType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.ByteType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.CalendarDateType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.CalendarType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.CharBooleanType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.CharacterType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.ClassType

set(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.type.ClobType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.CurrencyType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.DateType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.DoubleType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.FloatType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.IntegerType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.LocaleType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.LongType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.NullableType
Get a parameter value without worrying about the possibility of null values
set(PreparedStatement, Object, int) - Method in class org.hibernate.type.SerializableType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.ShortType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.StringType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.TextType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.TimeType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.TimeZoneType

set(PreparedStatement, Object, int) - Method in class org.hibernate.type.TimestampType

set(String, String, boolean) - Static method in class org.hibernate.type.TypeFactory

setAbstract(Boolean) - Method in class org.hibernate.mapping.PersistentClass

setAbstract(boolean) - Method in class org.hibernate.mapping.Table

setAlias(AST, AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

setAlias(AST, AST) - Method in class org.hibernate.hql.ast.HqlSqlWalker

setAlias(String) - Method in class org.hibernate.hql.ast.tree.AbstractSelectExpression

setAlias(String) - Method in class org.hibernate.hql.ast.tree.ConstructorNode

setAlias(String) - Method in class org.hibernate.hql.ast.tree.QueryNode

setAlias(String) - Method in interface org.hibernate.hql.ast.tree.SelectExpression

setAlias(String) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setAliases(String[]) - Method in class org.hibernate.loader.JoinWalker

setAllPropertyFetch(boolean) - Method in class org.hibernate.hql.ast.tree.FromElement

setAlternateUniqueKey(boolean) - Method in class org.hibernate.mapping.SimpleValue

setAsciiStream(long) - Method in class org.hibernate.lob.ClobImpl

setAsciiStream(long) - Method in class org.hibernate.lob.SerializableClob

setAssociatedClass(PersistentClass) - Method in class org.hibernate.mapping.OneToMany
Associated entity on the many side
setAttributeValue(String, String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy
Deprecated.
setAttributeValue(QName, String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy
Deprecated.
setAttributeValue(String, String) - Method in class org.hibernate.tuple.ElementWrapper
Deprecated.
setAttributeValue(QName, String) - Method in class org.hibernate.tuple.ElementWrapper
Deprecated.
setAttributes(List) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

setAttributes(List) - Method in class org.hibernate.tuple.ElementWrapper

setAutoClear(boolean) - Method in interface org.hibernate.engine.SessionImplementor
Enable/disable automatic cache clearing from after transaction completion (for EJB3)
setAutoClear(boolean) - Method in class org.hibernate.impl.SessionImpl

setAutoClear(boolean) - Method in class org.hibernate.impl.StatelessSessionImpl

setAutoCloseSessionEnabled(String) - Method in class org.hibernate.jmx.HibernateService

setAutoCloseSessionEnabled(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Enable automatic closing of Session when JTA transaction ends.
setAutoDiscoverScalarTypes(boolean) - Method in class org.hibernate.engine.QueryParameters

setAutoFlushEventListeners(AutoFlushEventListener[]) - Method in class org.hibernate.event.EventListeners

setAutoImport(boolean) - Method in class org.hibernate.cfg.Mappings
Sets the autoImport.
setBaseIndex(int) - Method in class org.hibernate.mapping.List

setBatchSize(int) - Method in class org.hibernate.mapping.Collection

setBatchSize(int) - Method in class org.hibernate.mapping.PersistentClass

setBatchVersionedDataEnabled(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Enable or disable the use of batch updates for versioned entities
setBatchVersionedDataEnabled(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setBigDecimal(int, BigDecimal) - Method in interface org.hibernate.Query

setBigDecimal(String, BigDecimal) - Method in interface org.hibernate.Query

setBigDecimal(int, BigDecimal) - Method in class org.hibernate.impl.AbstractQueryImpl

setBigDecimal(String, BigDecimal) - Method in class org.hibernate.impl.AbstractQueryImpl

setBigInteger(int, BigInteger) - Method in interface org.hibernate.Query

setBigInteger(String, BigInteger) - Method in interface org.hibernate.Query

setBigInteger(int, BigInteger) - Method in class org.hibernate.impl.AbstractQueryImpl

setBigInteger(String, BigInteger) - Method in class org.hibernate.impl.AbstractQueryImpl

setBinary(int, byte[]) - Method in interface org.hibernate.Query

setBinary(String, byte[]) - Method in interface org.hibernate.Query

setBinary(int, byte[]) - Method in class org.hibernate.impl.AbstractQueryImpl

setBinary(String, byte[]) - Method in class org.hibernate.impl.AbstractQueryImpl

setBinaryStream(long) - Method in class org.hibernate.lob.BlobImpl

setBinaryStream(long) - Method in class org.hibernate.lob.SerializableBlob

setBoolean(int, boolean) - Method in interface org.hibernate.Query

setBoolean(String, boolean) - Method in interface org.hibernate.Query

setBoolean(int, boolean) - Method in class org.hibernate.impl.AbstractQueryImpl

setBoolean(String, boolean) - Method in class org.hibernate.impl.AbstractQueryImpl

setByte(int, byte) - Method in interface org.hibernate.Query

setByte(String, byte) - Method in interface org.hibernate.Query

setByte(int, byte) - Method in class org.hibernate.impl.AbstractQueryImpl

setByte(String, byte) - Method in class org.hibernate.impl.AbstractQueryImpl

setBytes(long, byte[]) - Method in class org.hibernate.lob.BlobImpl

setBytes(long, byte[], int, int) - Method in class org.hibernate.lob.BlobImpl

setBytes(long, byte[]) - Method in class org.hibernate.lob.SerializableBlob

setBytes(long, byte[], int, int) - Method in class org.hibernate.lob.SerializableBlob

setCache(Cache) - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Set the underlying cache implementation.
setCache(Cache) - Method in class org.hibernate.cache.NonstrictReadWriteCache

setCache(Cache) - Method in class org.hibernate.cache.ReadOnlyCache

setCache(Cache) - Method in class org.hibernate.cache.ReadWriteCache

setCache(Cache) - Method in class org.hibernate.cache.TransactionalCache

setCacheCapacity(int) - Method in class org.hibernate.cache.OSCache

setCacheConcurrencyStrategy(String, String) - Method in class org.hibernate.cfg.Configuration
Set up a cache for an entity class
setCacheConcurrencyStrategy(String, String, String) - Method in class org.hibernate.cfg.Configuration

setCacheConcurrencyStrategy(String) - Method in class org.hibernate.mapping.Collection

setCacheConcurrencyStrategy(String) - Method in class org.hibernate.mapping.RootClass

setCacheMode(CacheMode) - Method in interface org.hibernate.Criteria
Override the cache mode for this particular query.
setCacheMode(CacheMode) - Method in interface org.hibernate.Query
Override the current session cache mode, just for this query.
setCacheMode(CacheMode) - Method in interface org.hibernate.Session
Set the cache mode.
setCacheMode(CacheMode) - Method in interface org.hibernate.engine.SessionImplementor

setCacheMode(CacheMode) - Method in class org.hibernate.impl.AbstractQueryImpl

setCacheMode(CacheMode) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setCacheMode(CacheMode) - Method in class org.hibernate.impl.CriteriaImpl

setCacheMode(CacheMode) - Method in class org.hibernate.impl.SessionImpl

setCacheMode(CacheMode) - Method in class org.hibernate.impl.StatelessSessionImpl

setCacheProviderClass(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set the second-level cache provider class name
setCacheProviderClass(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setCacheRegion(String) - Method in interface org.hibernate.Criteria
Set the name of the cache region to use for query result caching.
setCacheRegion(String) - Method in interface org.hibernate.Query
Set the name of the cache region.
setCacheRegion(String) - Method in class org.hibernate.engine.QueryParameters

setCacheRegion(String) - Method in class org.hibernate.impl.AbstractQueryImpl

setCacheRegion(String) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setCacheRegion(String) - Method in class org.hibernate.impl.CriteriaImpl

setCacheRegionName(String) - Method in class org.hibernate.mapping.Collection

setCacheRegionName(String) - Method in class org.hibernate.mapping.RootClass

setCacheRegionPrefix(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set the cache region prefix
setCacheRegionPrefix(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setCacheable(boolean) - Method in interface org.hibernate.Criteria
Enable caching of this query result, provided query caching is enabled for the underlying session factory.
setCacheable(boolean) - Method in interface org.hibernate.Query
Enable caching of this query result set.
setCacheable(boolean) - Method in class org.hibernate.engine.QueryParameters

setCacheable(boolean) - Method in class org.hibernate.impl.AbstractQueryImpl

setCacheable(boolean) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setCacheable(boolean) - Method in class org.hibernate.impl.CriteriaImpl

setCalendar(int, Calendar) - Method in interface org.hibernate.Query

setCalendar(String, Calendar) - Method in interface org.hibernate.Query

setCalendar(int, Calendar) - Method in class org.hibernate.impl.AbstractQueryImpl

setCalendar(String, Calendar) - Method in class org.hibernate.impl.AbstractQueryImpl

setCalendarDate(int, Calendar) - Method in interface org.hibernate.Query

setCalendarDate(String, Calendar) - Method in interface org.hibernate.Query

setCalendarDate(int, Calendar) - Method in class org.hibernate.impl.AbstractQueryImpl

setCalendarDate(String, Calendar) - Method in class org.hibernate.impl.AbstractQueryImpl

setCallable(boolean) - Method in class org.hibernate.engine.QueryParameters

setCascade(String) - Method in class org.hibernate.mapping.Property

setCascadeDeleteEnabled(boolean) - Method in class org.hibernate.mapping.ForeignKey

setCascadeDeleteEnabled(boolean) - Method in class org.hibernate.mapping.SimpleValue

setCatalog(String) - Method in class org.hibernate.mapping.Table

setCatalogName(String) - Method in class org.hibernate.cfg.Mappings
Sets the catalogName.
setCharacter(int, char) - Method in interface org.hibernate.Query

setCharacter(String, char) - Method in interface org.hibernate.Query

setCharacter(int, char) - Method in class org.hibernate.impl.AbstractQueryImpl

setCharacter(String, char) - Method in class org.hibernate.impl.AbstractQueryImpl

setCharacterStream(long) - Method in class org.hibernate.lob.ClobImpl

setCharacterStream(long) - Method in class org.hibernate.lob.SerializableClob

setCheckConstraint(String) - Method in class org.hibernate.mapping.Column

setClassName(String) - Method in class org.hibernate.mapping.PersistentClass

setClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

setClause(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

setClause(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

setClosed() - Method in class org.hibernate.impl.AbstractSessionImpl

setCollectionCacheConcurrencyStrategy(String, String) - Method in class org.hibernate.cfg.Configuration
Set up a cache for a collection role
setCollectionCacheConcurrencyStrategy(String, String, String) - Method in class org.hibernate.cfg.Configuration

setCollectionJoin(boolean) - Method in class org.hibernate.hql.ast.tree.FromElement

setCollectionKey(Serializable) - Method in class org.hibernate.impl.AbstractQueryImpl

setCollectionKeys(Serializable[]) - Method in class org.hibernate.engine.QueryParameters

setCollectionOwners(int[]) - Method in class org.hibernate.loader.JoinWalker

setCollectionPersisterClass(Class) - Method in class org.hibernate.mapping.Collection

setCollectionPersisters(CollectionPersister[]) - Method in class org.hibernate.loader.JoinWalker

setCollectionRole(String) - Method in class org.hibernate.mapping.Backref

setCollectionRole(String) - Method in class org.hibernate.mapping.IndexBackref

setCollectionSuffix(String) - Method in class org.hibernate.hql.ast.tree.FromElement

setCollectionSuffixes(String[]) - Method in class org.hibernate.loader.JoinWalker

setCollectionTable(Table) - Method in class org.hibernate.mapping.Collection

setCollectionTableAlias(String) - Method in class org.hibernate.hql.ast.tree.FromElement

setColumn(String) - Method in class org.hibernate.sql.InFragment

setColumn(String, String) - Method in class org.hibernate.sql.InFragment

setColumns(String[]) - Method in class org.hibernate.hql.ast.tree.FromElement

setComment(String) - Method in interface org.hibernate.Criteria
Add a comment to the generated SQL.
setComment(String) - Method in interface org.hibernate.Query
Add a comment to the generated SQL.
setComment(String) - Method in class org.hibernate.engine.QueryParameters

setComment(String) - Method in class org.hibernate.id.SequenceIdentityGenerator.NoCommentsInsert

setComment(String) - Method in class org.hibernate.impl.AbstractQueryImpl

setComment(String) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setComment(String) - Method in class org.hibernate.impl.CriteriaImpl

setComment(String) - Method in class org.hibernate.mapping.Column

setComment(String) - Method in class org.hibernate.mapping.Table

setComment(String) - Method in class org.hibernate.sql.Delete

setComment(String) - Method in class org.hibernate.sql.Insert

setComment(String) - Method in class org.hibernate.sql.InsertSelect

setComment(String) - Method in class org.hibernate.sql.QuerySelect

setComment(String) - Method in class org.hibernate.sql.Select

setComment(String) - Method in class org.hibernate.sql.SimpleSelect

setComment(String) - Method in class org.hibernate.sql.Update

setCommentsEnabled(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Enable or disable the inclusion of comments in generated SQL
setCommentsEnabled(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setComparator(Comparator) - Method in class org.hibernate.collection.PersistentSortedMap

setComparator(Comparator) - Method in class org.hibernate.collection.PersistentSortedSet

setComparator(Comparator) - Method in class org.hibernate.mapping.Collection

setComparatorClassName(String) - Method in class org.hibernate.mapping.Collection

setComponentClassName(String) - Method in class org.hibernate.mapping.Component

setCondition(String[], String[]) - Method in class org.hibernate.sql.ConditionFragment

setCondition(String[], String) - Method in class org.hibernate.sql.ConditionFragment

setConfig(File) - Method in class org.hibernate.tool.hbm2ddl.SchemaExportTask
Set a .cfg.xml file, which will be loaded as a resource, from the classpath
setConfig(File) - Method in class org.hibernate.tool.hbm2ddl.SchemaUpdateTask
Set a .cfg.xml file
setConfig(File) - Method in class org.hibernate.tool.hbm2ddl.SchemaValidatorTask
Set a .cfg.xml file
setConstrained(boolean) - Method in class org.hibernate.mapping.OneToOne
Sets the constrained.
setContent(List) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

setContent(List) - Method in class org.hibernate.tuple.ElementWrapper

setCreate(boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaExportTask
Enable "create" mode.
setCurrentKey(Serializable) - Method in class org.hibernate.engine.CollectionEntry

setCurrentPersister(CollectionPersister) - Method in class org.hibernate.engine.CollectionEntry

setCurrentSession(SessionImplementor) - Method in class org.hibernate.collection.AbstractPersistentCollection
Associate the collection with the given session.
setCurrentSession(SessionImplementor) - Method in interface org.hibernate.collection.PersistentCollection
Associate the collection with the given session.
setCustomListener(String, String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setCustomListeners(Map) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setCustomListenersAsString(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setCustomSQLDelete(String, boolean, ExecuteUpdateResultCheckStyle) - Method in class org.hibernate.mapping.Collection

setCustomSQLDelete(String, boolean, ExecuteUpdateResultCheckStyle) - Method in class org.hibernate.mapping.Join

setCustomSQLDelete(String, boolean, ExecuteUpdateResultCheckStyle) - Method in class org.hibernate.mapping.PersistentClass

setCustomSQLDeleteAll(String, boolean, ExecuteUpdateResultCheckStyle) - Method in class org.hibernate.mapping.Collection

setCustomSQLInsert(String, boolean, ExecuteUpdateResultCheckStyle) - Method in class org.hibernate.mapping.Collection

setCustomSQLInsert(String, boolean, ExecuteUpdateResultCheckStyle) - Method in class org.hibernate.mapping.Join

setCustomSQLInsert(String, boolean, ExecuteUpdateResultCheckStyle) - Method in class org.hibernate.mapping.PersistentClass

setCustomSQLUpdate(String, boolean, ExecuteUpdateResultCheckStyle) - Method in class org.hibernate.mapping.Collection

setCustomSQLUpdate(String, boolean, ExecuteUpdateResultCheckStyle) - Method in class org.hibernate.mapping.Join

setCustomSQLUpdate(String, boolean, ExecuteUpdateResultCheckStyle) - Method in class org.hibernate.mapping.PersistentClass

setData(Object) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

setData(Object) - Method in class org.hibernate.tuple.ElementWrapper

setDataSource(DataSource) - Method in class org.hibernate.connection.DatasourceConnectionProvider

setDataType(Type) - Method in class org.hibernate.hql.ast.tree.SqlNode

setDatabaseSnapshot(Object[]) - Method in class org.hibernate.event.FlushEntityEvent

setDatasource(String) - Method in class org.hibernate.jmx.HibernateService

setDatasource(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set the JNDI name of the datasource to use in this SessionFactory
setDate(int, Date) - Method in interface org.hibernate.Query

setDate(String, Date) - Method in interface org.hibernate.Query

setDate(int, Date) - Method in class org.hibernate.impl.AbstractQueryImpl

setDate(String, Date) - Method in class org.hibernate.impl.AbstractQueryImpl

setDefaultAccess(String) - Method in class org.hibernate.cfg.Mappings
sets the default access strategy
setDefaultCascade(String) - Method in class org.hibernate.cfg.Mappings
Sets the defaultCascade.
setDefaultCatalog(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set the default catalog
setDefaultCatalog(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setDefaultLazy(boolean) - Method in class org.hibernate.cfg.Mappings

setDefaultPackage(String) - Method in class org.hibernate.cfg.Mappings

setDefaultSchema(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set the default schema
setDefaultSchema(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setDefaultValue(String) - Method in class org.hibernate.mapping.Column

setDeleteEventListeners(DeleteEventListener[]) - Method in class org.hibernate.event.EventListeners

setDeletedState(Object[]) - Method in class org.hibernate.engine.EntityEntry

setDelimiter(String) - Method in class org.hibernate.tool.hbm2ddl.SchemaExport
Set the end of statement delimiter
setDelimiter(String) - Method in class org.hibernate.tool.hbm2ddl.SchemaExportTask
Set the end of statement delimiter for the generated script
setDialect(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
The name of the dialect class to use in this SessionFactory
setDialect(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setDirectlyAccessible(boolean) - Method in class org.hibernate.collection.AbstractPersistentCollection

setDirty(boolean) - Method in class org.hibernate.event.DirtyCheckEvent

setDirtyCheckEventListeners(DirtyCheckEventListener[]) - Method in class org.hibernate.event.EventListeners

setDirtyCheckHandledByInterceptor(boolean) - Method in class org.hibernate.event.FlushEntityEvent

setDirtyCheckPossible(boolean) - Method in class org.hibernate.event.FlushEntityEvent

setDirtyProperties(int[]) - Method in class org.hibernate.event.FlushEntityEvent

setDiscriminator(Value) - Method in class org.hibernate.mapping.RootClass

setDiscriminatorInsertable(boolean) - Method in class org.hibernate.mapping.RootClass

setDiscriminatorValue(String) - Method in class org.hibernate.mapping.PersistentClass

setDistinct() - Method in class org.hibernate.criterion.CountProjection

setDistinct(boolean) - Method in class org.hibernate.sql.QuerySelect

setDocument(Document) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

setDocument(Document) - Method in class org.hibernate.tuple.ElementWrapper

setDorecreate(boolean) - Method in class org.hibernate.engine.CollectionEntry

setDoremove(boolean) - Method in class org.hibernate.engine.CollectionEntry

setDouble(int, double) - Method in interface org.hibernate.Query

setDouble(String, double) - Method in interface org.hibernate.Query

setDouble(int, double) - Method in class org.hibernate.impl.AbstractQueryImpl

setDouble(String, double) - Method in class org.hibernate.impl.AbstractQueryImpl

setDoupdate(boolean) - Method in class org.hibernate.engine.CollectionEntry

setDrop(boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaExportTask
Enable "drop" mode.
setDynamic(boolean) - Method in class org.hibernate.mapping.Component

setDynamicInsert(boolean) - Method in class org.hibernate.mapping.PersistentClass

setDynamicUpdate(boolean) - Method in class org.hibernate.mapping.PersistentClass

setElement(Value) - Method in class org.hibernate.mapping.Collection

setElementClassName(String) - Method in class org.hibernate.mapping.Array

setElementNodeName(String) - Method in class org.hibernate.mapping.Collection

setEmbedded(boolean) - Method in class org.hibernate.mapping.Collection

setEmbedded(boolean) - Method in class org.hibernate.mapping.Component

setEmbedded(boolean) - Method in class org.hibernate.mapping.OneToMany

setEmbedded(boolean) - Method in class org.hibernate.mapping.ToOne

setEmbeddedIdentifier(boolean) - Method in class org.hibernate.mapping.RootClass

setEntity(int, Object) - Method in interface org.hibernate.Query
Bind an instance of a mapped persistent class to a JDBC-style query parameter.
setEntity(String, Object) - Method in interface org.hibernate.Query
Bind an instance of a mapped persistent class to a named query parameter.
setEntity(Object) - Method in class org.hibernate.event.MergeEvent

setEntity(Object) - Method in class org.hibernate.event.PostLoadEvent

setEntity(Object) - Method in class org.hibernate.event.PreLoadEvent

setEntity(Object) - Method in class org.hibernate.event.SaveOrUpdateEvent

setEntity(int, Object) - Method in class org.hibernate.impl.AbstractQueryImpl

setEntity(String, Object) - Method in class org.hibernate.impl.AbstractQueryImpl

setEntityClassName(String) - Method in class org.hibernate.event.LoadEvent

setEntityId(Serializable) - Method in class org.hibernate.event.LoadEvent

setEntityName(String) - Method in class org.hibernate.event.LockEvent

setEntityName(String) - Method in class org.hibernate.event.MergeEvent

setEntityName(String) - Method in class org.hibernate.event.PersistEvent

setEntityName(String) - Method in class org.hibernate.event.ReplicateEvent

setEntityName(String) - Method in class org.hibernate.event.SaveOrUpdateEvent

setEntityName(String) - Method in class org.hibernate.mapping.Backref

setEntityName(String) - Method in class org.hibernate.mapping.IndexBackref

setEntityName(String) - Method in class org.hibernate.mapping.OneToOne

setEntityName(String) - Method in class org.hibernate.mapping.PersistentClass

setEntityNotFoundDelegate(EntityNotFoundDelegate) - Method in class org.hibernate.cfg.Configuration
Specify a user-supplied delegate to be used to handle scenarios where an entity could not be located by specified id.
setEntityPersisterClass(Class) - Method in class org.hibernate.mapping.PersistentClass

setEntityPersisterClass(Class) - Method in class org.hibernate.mapping.RootClass

setEntityPersisterClass(Class) - Method in class org.hibernate.mapping.Subclass

setEntityResolver(EntityResolver) - Method in class org.hibernate.cfg.Configuration
Set a custom entity resolver.
setEntry(EntityEntry) - Method in class org.hibernate.event.SaveOrUpdateEvent

setEntryStatus(EntityEntry, Status) - Method in interface org.hibernate.engine.PersistenceContext
Set the status of an entry
setEntryStatus(EntityEntry, Status) - Method in class org.hibernate.engine.StatefulPersistenceContext

setEscapeCharacter(Character) - Method in class org.hibernate.criterion.Example
Set escape character for "like" clause
setEvictEventListeners(EvictEventListener[]) - Method in class org.hibernate.event.EventListeners

setExpectedType(Type) - Method in class org.hibernate.hql.ast.tree.BooleanLiteralNode
Expected-types really only pertinent here for boolean literals...
setExpectedType(Type) - Method in interface org.hibernate.hql.ast.tree.ExpectedTypeAwareNode

setExpectedType(Type) - Method in class org.hibernate.hql.ast.tree.JavaConstantNode

setExpectedType(Type) - Method in class org.hibernate.hql.ast.tree.ParameterNode

setExpectedType(Type) - Method in class org.hibernate.param.AbstractExplicitParameterSpecification

setExpectedType(Type) - Method in interface org.hibernate.param.ParameterSpecification

setExpectedType(Type) - Method in class org.hibernate.param.VersionTypeSeedParameterSpecification

setExpectingCollectionIndex() - Method in class org.hibernate.hql.classic.FromPathExpressionParser

setExpectingCollectionIndex() - Method in class org.hibernate.hql.classic.PathExpressionParser

setExpectingCollectionIndex() - Method in class org.hibernate.hql.classic.SelectPathExpressionParser

setExplicitPolymorphism(boolean) - Method in class org.hibernate.mapping.RootClass

setExtended(boolean) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

setExtraLazy(boolean) - Method in class org.hibernate.mapping.Collection

setExtraSelectList(String) - Method in class org.hibernate.sql.SelectFragment

setExtraSelectList(CaseFragment, String) - Method in class org.hibernate.sql.SelectFragment

setFetch(boolean) - Method in class org.hibernate.hql.ast.tree.DotNode

setFetch(boolean) - Method in class org.hibernate.hql.ast.tree.FromElement

setFetchDirection(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

setFetchMode(String, FetchMode) - Method in interface org.hibernate.Criteria
Specify an association fetching strategy for an association or a collection of values.
setFetchMode(String, FetchMode) - Method in class org.hibernate.criterion.DetachedCriteria

setFetchMode(String, FetchMode) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setFetchMode(String, FetchMode) - Method in class org.hibernate.impl.CriteriaImpl

setFetchMode(FetchMode) - Method in class org.hibernate.mapping.Collection

setFetchMode(FetchMode) - Method in interface org.hibernate.mapping.Fetchable

setFetchMode(FetchMode) - Method in class org.hibernate.mapping.ToOne

setFetchProfile(String) - Method in interface org.hibernate.engine.SessionImplementor

setFetchProfile(String) - Method in class org.hibernate.impl.SessionImpl

setFetchProfile(String) - Method in class org.hibernate.impl.StatelessSessionImpl

setFetchSize(int) - Method in interface org.hibernate.Criteria
Set a fetch size for the underlying JDBC query.
setFetchSize(int) - Method in interface org.hibernate.Query
Set a fetch size for the underlying JDBC query.
setFetchSize(Integer) - Method in class org.hibernate.engine.RowSelection

setFetchSize(int) - Method in class org.hibernate.impl.AbstractQueryImpl

setFetchSize(int) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setFetchSize(int) - Method in class org.hibernate.impl.CriteriaImpl

setFetchSize(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

setFieldFilter(FieldFilter) - Method in class org.hibernate.bytecode.javassist.FieldTransformer

setFieldHandler(FieldHandler) - Method in interface org.hibernate.bytecode.javassist.FieldHandled
Inject the field interception handler to be used.
setFilter(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseParser
Sets the filter flag.
setFilter(boolean) - Method in class org.hibernate.hql.ast.tree.FromElement

setFirstResult(int) - Method in interface org.hibernate.Criteria
Set the first result to be retrieved.
setFirstResult(int) - Method in interface org.hibernate.Query
Set the first row to retrieve.
setFirstResult(int) - Method in class org.hibernate.impl.AbstractQueryImpl

setFirstResult(int) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setFirstResult(int) - Method in class org.hibernate.impl.CriteriaImpl

setFirstRow(Integer) - Method in class org.hibernate.engine.RowSelection

setFloat(int, float) - Method in interface org.hibernate.Query

setFloat(String, float) - Method in interface org.hibernate.Query

setFloat(int, float) - Method in class org.hibernate.impl.AbstractQueryImpl

setFloat(String, float) - Method in class org.hibernate.impl.AbstractQueryImpl

setFlushBeforeCompletionEnabled(String) - Method in class org.hibernate.jmx.HibernateService

setFlushBeforeCompletionEnabled(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Enable automatic flushing of the Session when JTA transaction ends.
setFlushEntityEventListeners(FlushEntityEventListener[]) - Method in class org.hibernate.event.EventListeners

setFlushEventListeners(FlushEventListener[]) - Method in class org.hibernate.event.EventListeners

setFlushMode(FlushMode) - Method in interface org.hibernate.Criteria
Override the flush mode for this particular query.
setFlushMode(FlushMode) - Method in interface org.hibernate.Query
Override the current session flush mode, just for this query.
setFlushMode(FlushMode) - Method in interface org.hibernate.Session
Set the flush mode.
setFlushMode(FlushMode) - Method in interface org.hibernate.engine.SessionImplementor

setFlushMode(FlushMode) - Method in class org.hibernate.impl.AbstractQueryImpl

setFlushMode(FlushMode) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setFlushMode(FlushMode) - Method in class org.hibernate.impl.CriteriaImpl

setFlushMode(FlushMode) - Method in class org.hibernate.impl.SessionImpl

setFlushMode(FlushMode) - Method in class org.hibernate.impl.StatelessSessionImpl

setFlushRequired(boolean) - Method in class org.hibernate.event.AutoFlushEvent

setFlushing(boolean) - Method in interface org.hibernate.engine.PersistenceContext
Called before and after the flushcycle
setFlushing(boolean) - Method in class org.hibernate.engine.StatefulPersistenceContext

setForceDiscriminator(boolean) - Method in class org.hibernate.mapping.RootClass

setForeignKeyName(String) - Method in class org.hibernate.mapping.SimpleValue

setForeignKeyType(ForeignKeyDirection) - Method in class org.hibernate.mapping.OneToOne
Sets the foreignKeyType.
setFormat(boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaExport

setFormula(String) - Method in class org.hibernate.mapping.Formula

setFormula(String, String) - Method in class org.hibernate.sql.InFragment

setFromClause(String) - Method in class org.hibernate.sql.Select
Sets the fromClause.
setFromClause(String, String) - Method in class org.hibernate.sql.Select

setFromElement(FromElement) - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

setFromElement(FromElement) - Method in class org.hibernate.hql.ast.tree.SqlFragment

setGeneration(PropertyGeneration) - Method in class org.hibernate.mapping.Property

setGetGeneratedKeysEnabled(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Enable or disable the use getGeneratedKeys()
setGetGeneratedKeysEnabled(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setGroupByClause(String) - Method in class org.hibernate.sql.Select

setGroupByTokens(Iterator) - Method in class org.hibernate.sql.QuerySelect

setHaltOnError(boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaExport

setHaltonerror(boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaExportTask

setHasDirtyCollection(boolean) - Method in class org.hibernate.event.FlushEntityEvent

setHasFilterCondition(boolean) - Method in class org.hibernate.sql.JoinFragment

setHasThetaJoins(boolean) - Method in class org.hibernate.sql.JoinFragment

setHavingTokens(Iterator) - Method in class org.hibernate.sql.QuerySelect

setHqlParameterSpecification(ParameterSpecification) - Method in class org.hibernate.hql.ast.tree.ParameterNode

setId(Serializable) - Method in class org.hibernate.event.PostLoadEvent

setId(Serializable) - Method in class org.hibernate.event.PreLoadEvent

setIdentifier(KeyValue) - Method in class org.hibernate.mapping.IdentifierCollection

setIdentifier(KeyValue) - Method in class org.hibernate.mapping.OneToOne
Sets the identifier.
setIdentifier(KeyValue) - Method in class org.hibernate.mapping.RootClass

setIdentifier(Object, Serializable, EntityMode) - Method in interface org.hibernate.metadata.ClassMetadata
Set the identifier of an instance (or do nothing if no identifier property)
setIdentifier(Object, Serializable, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

setIdentifier(Object, Serializable, EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Set the identifier of an instance (or do nothing if no identifier property)
setIdentifier(Serializable) - Method in class org.hibernate.proxy.AbstractLazyInitializer

setIdentifier(Serializable) - Method in interface org.hibernate.proxy.LazyInitializer
Set the identifier property of the proxy
setIdentifier(Object, Serializable) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

setIdentifier(Object, Serializable) - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Inject the identifier value into the given entity.
setIdentifierGeneratorProperties(Properties) - Method in class org.hibernate.mapping.SimpleValue
Sets the identifierGeneratorProperties.
setIdentifierGeneratorStrategy(String) - Method in class org.hibernate.mapping.SimpleValue
Sets the identifierGeneratorStrategy.
setIdentifierMapper(Component) - Method in class org.hibernate.mapping.PersistentClass

setIdentifierMethod - Variable in class org.hibernate.proxy.pojo.BasicLazyInitializer

setIdentifierProperty(Property) - Method in class org.hibernate.mapping.RootClass

setIdentifierType(String) - Method in class org.hibernate.mapping.Any

setIdentifierValue(KeyValue) - Method in class org.hibernate.mapping.Table

setIgnoreNotFound(boolean) - Method in class org.hibernate.mapping.ManyToOne

setIgnoreNotFound(boolean) - Method in class org.hibernate.mapping.OneToMany

setImplementation(Object) - Method in class org.hibernate.proxy.AbstractLazyInitializer

setImplementation(Object) - Method in interface org.hibernate.proxy.LazyInitializer
Initialize the proxy manually
setImpliedInFromClause(boolean) - Method in class org.hibernate.hql.ast.tree.FromElement

setImpliedInFromClause(boolean) - Method in class org.hibernate.hql.ast.tree.ImpliedFromElement

setImpliedJoinType(int) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

setImpliedJoinType(int) - Method in class org.hibernate.hql.ast.HqlSqlWalker

setImportFile(String) - Method in class org.hibernate.tool.hbm2ddl.SchemaExport

setInProjectionList(boolean) - Method in class org.hibernate.hql.ast.tree.FromElement

setInProjectionList(boolean) - Method in class org.hibernate.hql.ast.tree.ImpliedFromElement

setIncludeSubclasses(boolean) - Method in class org.hibernate.hql.ast.tree.FromElement

setIndentString(String) - Method in class org.hibernate.pretty.Formatter

setIndex(Element, String, String) - Static method in class org.hibernate.collection.PersistentIndexedElementHolder

setIndex(Value) - Method in class org.hibernate.mapping.IndexedCollection

setIndexNodeName(String) - Method in class org.hibernate.mapping.IndexedCollection

setInitialString(String) - Method in class org.hibernate.pretty.Formatter

setInitializeCollectionEventListeners(InitializeCollectionEventListener[]) - Method in class org.hibernate.event.EventListeners

setInitialized() - Method in class org.hibernate.collection.AbstractPersistentCollection

setInsertable(boolean) - Method in class org.hibernate.mapping.Property

setInstanceToLoad(Object) - Method in class org.hibernate.event.LoadEvent

setInteger(int, int) - Method in interface org.hibernate.Query

setInteger(String, int) - Method in interface org.hibernate.Query

setInteger(int, int) - Method in class org.hibernate.impl.AbstractQueryImpl

setInteger(String, int) - Method in class org.hibernate.impl.AbstractQueryImpl

setInterceptor(Interceptor) - Method in class org.hibernate.cfg.Configuration
Configure an Interceptor
setInverse(boolean) - Method in class org.hibernate.mapping.Collection

setInverse(boolean) - Method in class org.hibernate.mapping.Join

setJdbcBatchSize(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set the maximum JDBC batch size
setJdbcBatchSize(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setJdbcFetchSize(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set the JDBC fetch size
setJdbcFetchSize(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setJdbcScrollableResultSetEnabled(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Enable or disable the use of scrollable resultsets
setJdbcScrollableResultSetEnabled(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setJndiName(String) - Method in class org.hibernate.jmx.HibernateService

setJndiName(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
The JNDI name to bind to the SessionFactory
setJoinFragment(JoinFragment) - Method in class org.hibernate.hql.ast.tree.SqlFragment

setJoinSequence(JoinSequence) - Method in class org.hibernate.hql.ast.tree.FromElement

setJoinType(int) - Method in class org.hibernate.hql.ast.tree.DotNode
Sets the join type for the '.' node (JoinFragment.XXX).
setKey(KeyValue) - Method in class org.hibernate.mapping.Collection

setKey(boolean) - Method in class org.hibernate.mapping.Component

setKey(KeyValue) - Method in class org.hibernate.mapping.Join

setKey(KeyValue) - Method in class org.hibernate.mapping.JoinedSubclass

setLastCollectionElementIndexValue(String) - Method in class org.hibernate.hql.classic.PathExpressionParser

setLazy(boolean) - Method in class org.hibernate.mapping.Collection

setLazy(boolean) - Method in interface org.hibernate.mapping.Fetchable

setLazy(boolean) - Method in class org.hibernate.mapping.PersistentClass

setLazy(boolean) - Method in class org.hibernate.mapping.Property

setLazy(boolean) - Method in class org.hibernate.mapping.ToOne

setLazy(boolean) - Method in class org.hibernate.tuple.entity.EntityMetamodel

setLazyPropertiesCacheable(boolean) - Method in class org.hibernate.mapping.RootClass

setLength(int) - Method in class org.hibernate.mapping.Column

setListener(String, Object) - Method in class org.hibernate.cfg.Configuration

setListeners(String, String[]) - Method in class org.hibernate.cfg.Configuration

setListeners(String, Object[]) - Method in class org.hibernate.cfg.Configuration

setLoadEventListeners(LoadEventListener[]) - Method in class org.hibernate.event.EventListeners

setLoaderName(String) - Method in class org.hibernate.mapping.Collection

setLoaderName(String) - Method in class org.hibernate.mapping.PersistentClass

setLocale(int, Locale) - Method in interface org.hibernate.Query

setLocale(String, Locale) - Method in interface org.hibernate.Query

setLocale(int, Locale) - Method in class org.hibernate.impl.AbstractQueryImpl

setLocale(String, Locale) - Method in class org.hibernate.impl.AbstractQueryImpl

setLockEventListeners(LockEventListener[]) - Method in class org.hibernate.event.EventListeners

setLockMode(LockMode) - Method in interface org.hibernate.Criteria
Set the lock mode of the current entity
setLockMode(String, LockMode) - Method in interface org.hibernate.Criteria
Set the lock mode of the aliased entity
setLockMode(String, LockMode) - Method in interface org.hibernate.Query
Set the lockmode for the objects idententified by the given alias that appears in the FROM clause.
setLockMode(LockMode) - Method in class org.hibernate.engine.EntityEntry

setLockMode(LockMode) - Method in class org.hibernate.event.LoadEvent

setLockMode(LockMode) - Method in class org.hibernate.event.LockEvent

setLockMode(LockMode) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setLockMode(String, LockMode) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setLockMode(LockMode) - Method in class org.hibernate.impl.CriteriaImpl

setLockMode(String, LockMode) - Method in class org.hibernate.impl.CriteriaImpl

setLockMode(String, LockMode) - Method in class org.hibernate.impl.QueryImpl

setLockMode(String, LockMode) - Method in class org.hibernate.impl.SQLQueryImpl

setLockMode(LockMode) - Method in class org.hibernate.sql.Select

setLockMode(LockMode) - Method in class org.hibernate.sql.SimpleSelect

setLockModeArray(LockMode[]) - Method in class org.hibernate.loader.JoinWalker

setLockModes(Map) - Method in class org.hibernate.engine.QueryParameters

setLong(int, long) - Method in interface org.hibernate.Query

setLong(String, long) - Method in interface org.hibernate.Query

setLong(int, long) - Method in class org.hibernate.impl.AbstractQueryImpl

setLong(String, long) - Method in class org.hibernate.impl.AbstractQueryImpl

setManyToManyOrdering(String) - Method in class org.hibernate.mapping.Collection

setManyToManyWhere(String) - Method in class org.hibernate.mapping.Collection

setMapResources(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Specify the Hibernate mapping files
setMapResources(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setMaxResults(int) - Method in interface org.hibernate.Criteria
Set a limit upon the number of objects to be retrieved.
setMaxResults(int) - Method in interface org.hibernate.Query
Set the maximum number of rows to retrieve.
setMaxResults(int) - Method in class org.hibernate.impl.AbstractQueryImpl

setMaxResults(int) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setMaxResults(int) - Method in class org.hibernate.impl.CriteriaImpl

setMaxRows(Integer) - Method in class org.hibernate.engine.RowSelection

setMaximumFetchDepth(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set the maximum outer join fetch depth
setMaximumFetchDepth(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setMergeEventListeners(MergeEventListener[]) - Method in class org.hibernate.event.EventListeners

setMetaAttributes(Map) - Method in class org.hibernate.mapping.Component

setMetaAttributes(Map) - Method in interface org.hibernate.mapping.MetaAttributable

setMetaAttributes(Map) - Method in class org.hibernate.mapping.PersistentClass

setMetaAttributes(Map) - Method in class org.hibernate.mapping.Property

setMetaType(String) - Method in class org.hibernate.mapping.Any

setMetaValues(Map) - Method in class org.hibernate.mapping.Any

setMinimalPutsEnabled(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Enable or disable optimization of second-level cache for minimal puts
setMinimalPutsEnabled(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setMutable(boolean) - Method in class org.hibernate.mapping.Collection

setMutable(boolean) - Method in class org.hibernate.mapping.RootClass

setName(String) - Method in class org.hibernate.mapping.Column

setName(String) - Method in class org.hibernate.mapping.Constraint

setName(String) - Method in class org.hibernate.mapping.Index

setName(String) - Method in class org.hibernate.mapping.Property

setName(String) - Method in class org.hibernate.mapping.Table

setName(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

setName(String) - Method in class org.hibernate.tuple.ElementWrapper

setNamedParameters(Map) - Method in class org.hibernate.engine.QueryParameters

setNamingStrategy(NamingStrategy) - Method in class org.hibernate.cfg.Configuration
Set a custom naming strategy
setNamingStrategy(String) - Method in class org.hibernate.tool.hbm2ddl.SchemaExportTask

setNamingStrategy(String) - Method in class org.hibernate.tool.hbm2ddl.SchemaUpdateTask

setNamingStrategy(String) - Method in class org.hibernate.tool.hbm2ddl.SchemaValidatorTask

setNaturalIdentifier(boolean) - Method in class org.hibernate.mapping.Property

setNaturalKeyLookup(boolean) - Method in class org.hibernate.engine.QueryParameters

setNext(JoinSequence) - Method in class org.hibernate.engine.JoinSequence

setNodeName(String) - Method in class org.hibernate.mapping.Collection

setNodeName(String) - Method in class org.hibernate.mapping.Component

setNodeName(String) - Method in class org.hibernate.mapping.PersistentClass

setNodeName(String) - Method in class org.hibernate.mapping.Property

setNowaitEnabled(boolean) - Method in class org.hibernate.sql.ForUpdateFragment

setNullValue(String) - Method in class org.hibernate.mapping.SimpleValue
Sets the nullValue.
setNullable(boolean) - Method in class org.hibernate.mapping.Column

setNullable(boolean) - Method in class org.hibernate.mapping.DependantValue

setObject(Object) - Method in class org.hibernate.event.EvictEvent

setObject(Object) - Method in class org.hibernate.event.LockEvent

setObject(Object) - Method in class org.hibernate.event.PersistEvent

setObject(Object) - Method in class org.hibernate.event.ReplicateEvent

setObject(Object) - Method in class org.hibernate.event.SaveOrUpdateEvent

setOp(String) - Method in class org.hibernate.sql.ConditionFragment
Sets the op.
setOptimisticLockMode(int) - Method in class org.hibernate.mapping.PersistentClass

setOptimisticLocked(boolean) - Method in class org.hibernate.mapping.Collection

setOptimisticLocked(boolean) - Method in class org.hibernate.mapping.Property

setOptional(boolean) - Method in class org.hibernate.mapping.Join

setOptional(boolean) - Method in class org.hibernate.mapping.Property

setOptionalEntityName(String) - Method in class org.hibernate.engine.QueryParameters

setOptionalEntityName(String) - Method in class org.hibernate.impl.AbstractQueryImpl

setOptionalId(Serializable) - Method in class org.hibernate.engine.QueryParameters

setOptionalId(Serializable) - Method in class org.hibernate.impl.AbstractQueryImpl

setOptionalObject(Object) - Method in class org.hibernate.engine.QueryParameters

setOptionalObject(Object) - Method in class org.hibernate.impl.AbstractQueryImpl

setOrderBy(String) - Method in class org.hibernate.mapping.Collection

setOrderBy(String) - Method in class org.hibernate.sql.SimpleSelect

setOrderByClause(String) - Method in class org.hibernate.sql.Select

setOrderByTokens(Iterator) - Method in class org.hibernate.sql.QuerySelect

setOrigin(FromElement, boolean) - Method in class org.hibernate.hql.ast.tree.FromElement

setOriginal(Object) - Method in class org.hibernate.event.MergeEvent

setOrphanDelete(boolean) - Method in class org.hibernate.mapping.Collection

setOuterJoins(String, String) - Method in class org.hibernate.sql.Select

setOutput(File) - Method in class org.hibernate.tool.hbm2ddl.SchemaExportTask
Set the script output file
setOutputFile(String) - Method in class org.hibernate.tool.hbm2ddl.SchemaExport
Set an output filename.
setOwner(Object) - Method in class org.hibernate.collection.AbstractPersistentCollection

setOwner(Object) - Method in interface org.hibernate.collection.PersistentCollection
Set the reference to the owning entity
setOwner(PersistentClass) - Method in class org.hibernate.mapping.Collection

setOwner(PersistentClass) - Method in class org.hibernate.mapping.Component

setOwnerAssociationTypes(EntityType[]) - Method in class org.hibernate.loader.JoinWalker

setOwners(int[]) - Method in class org.hibernate.loader.JoinWalker

setParameter(String, Object) - Method in interface org.hibernate.Filter
Set the named parameter's value for this filter.
setParameter(int, Object, Type) - Method in interface org.hibernate.Query
Bind a value to a JDBC-style query parameter.
setParameter(String, Object, Type) - Method in interface org.hibernate.Query
Bind a value to a named query parameter.
setParameter(int, Object) - Method in interface org.hibernate.Query
Bind a value to a JDBC-style query parameter, guessing the Hibernate type from the class of the given object.
setParameter(String, Object) - Method in interface org.hibernate.Query
Bind a value to a named query parameter, guessing the Hibernate type from the class of the given object.
setParameter(int, Object, Type) - Method in class org.hibernate.impl.AbstractQueryImpl

setParameter(String, Object, Type) - Method in class org.hibernate.impl.AbstractQueryImpl

setParameter(int, Object) - Method in class org.hibernate.impl.AbstractQueryImpl

setParameter(String, Object) - Method in class org.hibernate.impl.AbstractQueryImpl

setParameter(String, Object) - Method in class org.hibernate.impl.FilterImpl
Set the named parameter's value for this filter.
setParameterList(String, Collection) - Method in interface org.hibernate.Filter
Set the named parameter's value list for this filter.
setParameterList(String, Object[]) - Method in interface org.hibernate.Filter
Set the named parameter's value list for this filter.
setParameterList(String, Collection, Type) - Method in interface org.hibernate.Query
Bind multiple values to a named query parameter.
setParameterList(String, Collection) - Method in interface org.hibernate.Query
Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the collection.
setParameterList(String, Object[], Type) - Method in interface org.hibernate.Query
Bind multiple values to a named query parameter.
setParameterList(String, Object[]) - Method in interface org.hibernate.Query
Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the array.
setParameterList(String, Collection, Type) - Method in class org.hibernate.impl.AbstractQueryImpl

setParameterList(String, Collection) - Method in class org.hibernate.impl.AbstractQueryImpl

setParameterList(String, Object[], Type) - Method in class org.hibernate.impl.AbstractQueryImpl

setParameterList(String, Object[]) - Method in class org.hibernate.impl.AbstractQueryImpl

setParameterList(String, Collection) - Method in class org.hibernate.impl.FilterImpl
Set the named parameter's value list for this filter.
setParameterList(String, Object[]) - Method in class org.hibernate.impl.FilterImpl
Set the named parameter's value list for this filter.
setParameterValues(Properties) - Method in interface org.hibernate.usertype.ParameterizedType
Gets called by Hibernate to pass the configured type parameters to the implementation.
setParameters(Object[], Type[]) - Method in interface org.hibernate.Query
Bind values and types to positional parameters.
setParameters(Object[], Type[]) - Method in class org.hibernate.impl.AbstractQueryImpl

setParent(Element) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

setParent(Element) - Method in class org.hibernate.tuple.ElementWrapper

setParent(Object, Object, SessionFactoryImplementor) - Method in class org.hibernate.tuple.component.AbstractComponentTuplizer

setParent(Object, Object, SessionFactoryImplementor) - Method in interface org.hibernate.tuple.component.ComponentTuplizer
Set the value of the parent property.
setParent(Object, Object, SessionFactoryImplementor) - Method in class org.hibernate.tuple.component.PojoComponentTuplizer

setParentFromClause(FromClause) - Method in class org.hibernate.hql.ast.tree.FromClause

setParentProperty(String) - Method in class org.hibernate.mapping.Component

setPassword(String) - Method in class org.hibernate.jmx.HibernateService

setPassword(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Log into the database with this password
setPersistEventListeners(PersistEventListener[]) - Method in class org.hibernate.event.EventListeners

setPersistOnFlushEventListeners(PersistEventListener[]) - Method in class org.hibernate.event.EventListeners

setPersistentClass(PersistentClass) - Method in class org.hibernate.mapping.Join

setPersistentClass(PersistentClass) - Method in class org.hibernate.mapping.Property

setPersister(EntityPersister) - Method in class org.hibernate.event.PostLoadEvent

setPersister(EntityPersister) - Method in class org.hibernate.event.PreLoadEvent

setPersisters(Loadable[]) - Method in class org.hibernate.loader.JoinWalker

setPolymorphic(boolean) - Method in class org.hibernate.mapping.RootClass

setPositionalParameterTypes(Type[]) - Method in class org.hibernate.engine.QueryParameters

setPositionalParameterValues(Object[]) - Method in class org.hibernate.engine.QueryParameters

setPossibleID(boolean) - Method in class org.hibernate.hql.antlr.HqlBaseLexer

setPossibleID(boolean) - Method in class org.hibernate.hql.ast.HqlToken
Set to true if this token can be interpreted as an identifier, false if not.
setPostCommitDeleteEventListeners(PostDeleteEventListener[]) - Method in class org.hibernate.event.EventListeners

setPostCommitInsertEventListeners(PostInsertEventListener[]) - Method in class org.hibernate.event.EventListeners

setPostCommitUpdateEventListeners(PostUpdateEventListener[]) - Method in class org.hibernate.event.EventListeners

setPostDeleteEventListeners(PostDeleteEventListener[]) - Method in class org.hibernate.event.EventListeners

setPostInsertEventListeners(PostInsertEventListener[]) - Method in class org.hibernate.event.EventListeners

setPostLoadEventListeners(PostLoadEventListener[]) - Method in class org.hibernate.event.EventListeners

setPostUpdateEventListeners(PostUpdateEventListener[]) - Method in class org.hibernate.event.EventListeners

setPreDeleteEventListeners(PreDeleteEventListener[]) - Method in class org.hibernate.event.EventListeners

setPreInsertEventListeners(PreInsertEventListener[]) - Method in class org.hibernate.event.EventListeners

setPreLoadEventListeners(PreLoadEventListener[]) - Method in class org.hibernate.event.EventListeners

setPreUpdateEventListeners(PreUpdateEventListener[]) - Method in class org.hibernate.event.EventListeners

setPrecision(int) - Method in class org.hibernate.mapping.Column

setPrimaryKey(PrimaryKey) - Method in class org.hibernate.mapping.Table

setPrimaryKeyColumnNames(String[]) - Method in class org.hibernate.sql.Delete

setPrimaryKeyColumnNames(String[]) - Method in class org.hibernate.sql.Update

setProcessed(boolean) - Method in class org.hibernate.engine.CollectionEntry

setProcessingInstructions(List) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

setProcessingInstructions(List) - Method in class org.hibernate.tuple.ElementWrapper

setProjection(Projection) - Method in interface org.hibernate.Criteria
Used to specify that the query results will be a projection (scalar in nature).
setProjection(Projection) - Method in class org.hibernate.criterion.DetachedCriteria

setProjection(Projection) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setProjection(Projection) - Method in class org.hibernate.impl.CriteriaImpl

setProperties(Object) - Method in interface org.hibernate.Query
Bind the property values of the given bean to named parameters of the query, matching property names with parameter names and mapping property types to Hibernate types using hueristics.
setProperties(Properties) - Method in class org.hibernate.cfg.Configuration
Specify a completely new set of properties
setProperties(Object) - Method in class org.hibernate.impl.AbstractQueryImpl

setProperties(File) - Method in class org.hibernate.tool.hbm2ddl.SchemaExportTask
Set a properties file
setProperties(File) - Method in class org.hibernate.tool.hbm2ddl.SchemaUpdateTask
Set a properties file
setProperties(File) - Method in class org.hibernate.tool.hbm2ddl.SchemaValidatorTask
Set a properties file
setProperty(String, String) - Method in class org.hibernate.cfg.Configuration
Set a property
setProperty(String, String) - Method in class org.hibernate.jmx.HibernateService

setProperty(String, String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set a property
setPropertyAccessorName(String) - Method in class org.hibernate.mapping.Property

setPropertyName(String) - Method in class org.hibernate.mapping.OneToOne

setPropertyPath(String) - Method in class org.hibernate.hql.ast.tree.DotNode

setPropertySelector(Example.PropertySelector) - Method in class org.hibernate.criterion.Example
Set the property selector
setPropertyValue(Object, String, Object, EntityMode) - Method in interface org.hibernate.metadata.ClassMetadata
Set the value of a particular (named) property
setPropertyValue(Object, int, Object, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

setPropertyValue(Object, String, Object, EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

setPropertyValue(Object, int, Object, EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Set the value of a particular property
setPropertyValue(Object, int, Object) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

setPropertyValue(Object, String, Object) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

setPropertyValue(Object, int, Object) - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Inject the value of a particular property.
setPropertyValue(Object, String, Object) - Method in interface org.hibernate.tuple.entity.EntityTuplizer
Inject the value of a particular property.
setPropertyValue(Object, int, Object) - Method in interface org.hibernate.usertype.CompositeUserType
Set the value of a property.
setPropertyValues(Object, Object[]) - Method in interface org.hibernate.bytecode.ReflectionOptimizer.AccessOptimizer

setPropertyValues(Object, Object[]) - Method in class org.hibernate.bytecode.cglib.AccessOptimizerAdapter

setPropertyValues(Object, Object[]) - Method in class org.hibernate.bytecode.javassist.AccessOptimizerAdapter

setPropertyValues(Object, Object[]) - Method in class org.hibernate.bytecode.javassist.BulkAccessor
Sets properties of a given bean to specified values.
setPropertyValues(Object[]) - Method in class org.hibernate.event.FlushEntityEvent

setPropertyValues(Object, Object[], EntityMode) - Method in interface org.hibernate.metadata.ClassMetadata
Set the given values to the mapped properties of the given object
setPropertyValues(Object, Object[], EntityMode) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

setPropertyValues(Object, Object[], EntityMode) - Method in interface org.hibernate.persister.entity.EntityPersister
Set the given values to the mapped properties of the given object
setPropertyValues(Object, Object[]) - Method in interface org.hibernate.tuple.Tuplizer
Inject the given values into the given entity.
setPropertyValues(Object, Object[]) - Method in class org.hibernate.tuple.component.AbstractComponentTuplizer

setPropertyValues(Object, Object[]) - Method in class org.hibernate.tuple.component.PojoComponentTuplizer

setPropertyValues(Object, Object[]) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

setPropertyValues(Object, Object[]) - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

setPropertyValues(Object, Object[], EntityMode) - Method in interface org.hibernate.type.AbstractComponentType
Optional operation
setPropertyValues(Object, Object[], EntityMode) - Method in class org.hibernate.type.AnyType

setPropertyValues(Object, Object[], EntityMode) - Method in class org.hibernate.type.ComponentType

setPropertyValues(Object, Object[], EntityMode) - Method in class org.hibernate.type.CompositeCustomType

setPropertyValuesWithOptimizer(Object, Object[]) - Method in class org.hibernate.tuple.entity.PojoEntityTuplizer

setProxyInterfaceName(String) - Method in class org.hibernate.mapping.PersistentClass

setQName(QName) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

setQName(QName) - Method in class org.hibernate.tuple.ElementWrapper

setQueryCacheEnabled(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Enable or disable the query cache
setQueryCacheEnabled(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setQuerySpaces(Set) - Method in class org.hibernate.event.AutoFlushEvent

setQueryString(String) - Method in class org.hibernate.QueryException

setQuerySubstitutions(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set the query language substitutions
setQuerySubstitutions(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setQueryableCollection(QueryableCollection) - Method in class org.hibernate.hql.ast.tree.FromElement

setQuiet(boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaExportTask
Enable "quiet" mode.
setQuiet(boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaUpdateTask
Enable "quiet" mode.
setQuoted(boolean) - Method in class org.hibernate.mapping.Table

setReached(boolean) - Method in class org.hibernate.engine.CollectionEntry

setReadOnly(boolean) - Method in interface org.hibernate.Query
Entities retrieved by this query will be loaded in a read-only mode where Hibernate will never dirty-check them or make changes persistent.
setReadOnly(Object, boolean) - Method in interface org.hibernate.Session
Set an unmodified persistent object to read only mode, or a read only object to modifiable mode.
setReadOnly(boolean, Object) - Method in class org.hibernate.engine.EntityEntry

setReadOnly(Object, boolean) - Method in interface org.hibernate.engine.PersistenceContext
Set the object to read only and discard it's snapshot
setReadOnly(boolean) - Method in class org.hibernate.engine.QueryParameters

setReadOnly(Object, boolean) - Method in class org.hibernate.engine.StatefulPersistenceContext

setReadOnly(boolean) - Method in class org.hibernate.impl.AbstractQueryImpl

setReadOnly(Object, boolean) - Method in class org.hibernate.impl.SessionImpl

setReferencedEntityName(String) - Method in class org.hibernate.mapping.ForeignKey

setReferencedEntityName(String) - Method in class org.hibernate.mapping.OneToMany
Associated entity on the "many" side
setReferencedEntityName(String) - Method in class org.hibernate.mapping.ToOne

setReferencedPropertyName(String) - Method in class org.hibernate.mapping.Collection

setReferencedPropertyName(String) - Method in class org.hibernate.mapping.ToOne

setReferencedTable(Table) - Method in class org.hibernate.mapping.ForeignKey

setReflectionOptimizationEnabled(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setRefreshEventListeners(RefreshEventListener[]) - Method in class org.hibernate.event.EventListeners

setReplicateEventListeners(ReplicateEventListener[]) - Method in class org.hibernate.event.EventListeners

setReplicationMode(ReplicationMode) - Method in class org.hibernate.event.ReplicateEvent

setRequestedId(Serializable) - Method in class org.hibernate.event.MergeEvent

setRequestedId(Serializable) - Method in class org.hibernate.event.SaveOrUpdateEvent

setResolved() - Method in class org.hibernate.hql.ast.tree.FromReferenceNode

setResolvedConstant(String) - Method in class org.hibernate.hql.ast.tree.DotNode

setResult(Object) - Method in class org.hibernate.event.LoadEvent

setResult(Object) - Method in class org.hibernate.event.MergeEvent

setResultId(Serializable) - Method in class org.hibernate.event.SaveOrUpdateEvent

setResultSetMapping(String) - Method in interface org.hibernate.SQLQuery
Use a predefined named ResultSetMapping
setResultSetMapping(String) - Method in class org.hibernate.impl.SQLQueryImpl

setResultTransformer(ResultTransformer) - Method in interface org.hibernate.Criteria
Set a strategy for handling the query results.
setResultTransformer(ResultTransformer) - Method in interface org.hibernate.Query
Set a strategy for handling the query results.
setResultTransformer(ResultTransformer) - Method in class org.hibernate.criterion.DetachedCriteria

setResultTransformer(ResultTransformer) - Method in class org.hibernate.impl.AbstractQueryImpl

setResultTransformer(ResultTransformer) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setResultTransformer(ResultTransformer) - Method in class org.hibernate.impl.CriteriaImpl

setReturnColumnName(String) - Method in class org.hibernate.sql.CaseFragment

setReturnColumnName(String, String) - Method in class org.hibernate.sql.CaseFragment

setRole(String) - Method in class org.hibernate.engine.CollectionEntry

setRole(String) - Method in class org.hibernate.hql.ast.tree.FromElement

setRole(String) - Method in class org.hibernate.mapping.Collection

setRoleName(String) - Method in class org.hibernate.mapping.Component

setRollbackOnly() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter

setRollbackOnly() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter

setRoot(Joinable, String) - Method in class org.hibernate.engine.JoinSequence

setRowId(String) - Method in class org.hibernate.mapping.Table

setRowNumber(int) - Method in interface org.hibernate.ScrollableResults
Set the current location in the result set, numbered from either the first row (row number 0), or the last row (row number -1).
setRowNumber(int) - Method in class org.hibernate.impl.FetchingScrollableResultsImpl
Set the current location in the result set, numbered from either the first row (row number 0), or the last row (row number -1).
setRowNumber(int) - Method in class org.hibernate.impl.ScrollableResultsImpl

setRowSelection(RowSelection) - Method in class org.hibernate.engine.QueryParameters

setSaveEventListeners(SaveOrUpdateEventListener[]) - Method in class org.hibernate.event.EventListeners

setSaveOrUpdateCopyEventListeners(MergeEventListener[]) - Method in class org.hibernate.event.EventListeners

setSaveOrUpdateEventListeners(SaveOrUpdateEventListener[]) - Method in class org.hibernate.event.EventListeners

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.AggregateNode

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.Case2Node

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.CaseNode

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.ConstructorNode

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.CountNode

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.DotNode

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.IdentNode

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.IndexNode

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.LiteralNode

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.MethodNode

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.QueryNode

setScalarColumnText(int) - Method in interface org.hibernate.hql.ast.tree.SelectExpression
Appends AST nodes that represent the columns after the current AST node.
setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.SelectExpressionImpl

setScalarColumnText(int) - Method in class org.hibernate.hql.ast.tree.UnaryArithmeticNode

setScale(int) - Method in class org.hibernate.mapping.Column

setSchema(String) - Method in class org.hibernate.mapping.Table

setSchemaName(String) - Method in class org.hibernate.cfg.Mappings
Sets the schemaName.
setScrollMode(ScrollMode) - Method in class org.hibernate.engine.QueryParameters

setSecondLevelCacheEnabled(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Enable or disable the second-level cache
setSecondLevelCacheEnabled(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setSelect(Select) - Method in class org.hibernate.sql.InsertSelect

setSelectBeforeUpdate(boolean) - Method in class org.hibernate.mapping.PersistentClass

setSelectClause(String) - Method in class org.hibernate.sql.Select
Sets the selectClause.
setSelectable(boolean) - Method in class org.hibernate.mapping.Property

setSelector(JoinSequence.Selector) - Method in class org.hibernate.engine.JoinSequence

setSequentialSelect(boolean) - Method in class org.hibernate.mapping.Join

setSerializable(int, Serializable) - Method in interface org.hibernate.Query

setSerializable(String, Serializable) - Method in interface org.hibernate.Query

setSerializable(int, Serializable) - Method in class org.hibernate.impl.AbstractQueryImpl

setSerializable(String, Serializable) - Method in class org.hibernate.impl.AbstractQueryImpl

setSession(SessionImplementor) - Method in class org.hibernate.impl.CriteriaImpl

setSession(SessionImplementor) - Method in class org.hibernate.intercept.AbstractFieldInterceptor

setSession(SessionImplementor) - Method in interface org.hibernate.intercept.FieldInterceptor
Use to associate the entity to which we are bound to the given session.
setSession(SessionImplementor) - Method in class org.hibernate.proxy.AbstractLazyInitializer

setSession(SessionImplementor) - Method in interface org.hibernate.proxy.LazyInitializer
Attach the proxy to a session
setSessionFactory(SessionFactoryImplementor) - Method in class org.hibernate.hql.ast.tree.JavaConstantNode

setSessionFactory(SessionFactoryImplementor) - Method in interface org.hibernate.hql.ast.tree.SessionFactoryAwareNode

setSessionFactory(SessionFactory) - Method in class org.hibernate.jmx.StatisticsService
Useful to init this MBean wo a JNDI session factory name
setSessionFactoryJNDIName(String) - Method in class org.hibernate.jmx.StatisticsService

setSessionFactoryJNDIName(String) - Method in interface org.hibernate.jmx.StatisticsServiceMBean
Publish the statistics of a session factory bound to the default JNDI context
setShort(int, short) - Method in interface org.hibernate.Query

setShort(String, short) - Method in interface org.hibernate.Query

setShort(int, short) - Method in class org.hibernate.impl.AbstractQueryImpl

setShort(String, short) - Method in class org.hibernate.impl.AbstractQueryImpl

setShowClassNames(boolean) - Method in class org.hibernate.hql.ast.util.ASTPrinter
Enables or disables AST node class name display.
setShowSqlEnabled(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Enable logging of SQL to console
setShowSqlEnabled(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setSnapshot(Serializable, String, Serializable) - Method in class org.hibernate.collection.AbstractPersistentCollection
After flushing, re-init snapshot state.
setSnapshot(Serializable, String, Serializable) - Method in interface org.hibernate.collection.PersistentCollection
After flushing, re-init snapshot state.
setSorted(boolean) - Method in class org.hibernate.mapping.Collection

setSource(OptimisticCacheSource) - Method in interface org.hibernate.cache.OptimisticCache
Indicates the "source" of the cached data.
setSource(OptimisticCacheSource) - Method in class org.hibernate.cache.OptimisticTreeCache

setSql(String) - Method in class org.hibernate.loader.JoinWalker

setSqlType(String) - Method in class org.hibernate.mapping.Column

setSqlTypeCode(Integer) - Method in class org.hibernate.mapping.Column

setState(Object[]) - Method in class org.hibernate.event.PreLoadEvent

setStatisticsEnabled(boolean) - Method in class org.hibernate.jmx.StatisticsService

setStatisticsEnabled(boolean) - Method in interface org.hibernate.stat.Statistics
Enable statistics logs (this is a dynamic parameter)
setStatisticsEnabled(boolean) - Method in class org.hibernate.stat.StatisticsImpl
Enable statistics logs (this is a dynamic parameter)
setStatus(Status) - Method in class org.hibernate.engine.EntityEntry

setStreamsForBinaryEnabled(String) - Method in class org.hibernate.util.ExternalSessionFactoryConfig

setString(int, String) - Method in interface org.hibernate.Query

setString(String, String) - Method in interface org.hibernate.Query

setString(int, String) - Method in class org.hibernate.impl.AbstractQueryImpl

setString(String, String) - Method in class org.hibernate.impl.AbstractQueryImpl

setString(long, String) - Method in class org.hibernate.lob.ClobImpl

setString(long, String, int, int) - Method in class org.hibernate.lob.ClobImpl

setString(long, String) - Method in class org.hibernate.lob.SerializableClob

setString(long, String, int, int) - Method in class org.hibernate.lob.SerializableClob

setSubselect(String) - Method in class org.hibernate.mapping.Table

setSubselectLoadable(boolean) - Method in class org.hibernate.mapping.Collection

setSubselectLoadableCollections(boolean) - Method in class org.hibernate.mapping.PersistentClass

setSuffix(String) - Method in class org.hibernate.sql.SelectFragment

setSuffixes(String[]) - Method in class org.hibernate.loader.JoinWalker

setSuperclass(PersistentClass) - Method in class org.hibernate.mapping.Subclass

setTable(Table) - Method in class org.hibernate.mapping.Constraint

setTable(Table) - Method in class org.hibernate.mapping.Index

setTable(Table) - Method in class org.hibernate.mapping.Join

setTable(Table) - Method in class org.hibernate.mapping.JoinedSubclass

setTable(Table) - Method in class org.hibernate.mapping.RootClass

setTable(Table) - Method in class org.hibernate.mapping.SimpleValue

setTable(Table) - Method in interface org.hibernate.mapping.TableOwner

setTable(Table) - Method in class org.hibernate.mapping.UnionSubclass

setTableAlias(String) - Method in class org.hibernate.sql.ConditionFragment
Sets the tableAlias.
setTableName(String) - Method in class org.hibernate.sql.Delete

setTableName(String) - Method in class org.hibernate.sql.Insert

setTableName(String) - Method in class org.hibernate.sql.InsertSelect

setTableName(String) - Method in class org.hibernate.sql.SimpleSelect

setTableName(String) - Method in class org.hibernate.sql.Update

setText(int, String) - Method in interface org.hibernate.Query

setText(String, String) - Method in interface org.hibernate.Query

setText(String) - Method in class org.hibernate.hql.ast.tree.JavaConstantNode

setText(String) - Method in interface org.hibernate.hql.ast.tree.SelectExpression
Sets the text of the node.
setText(String) - Method in class org.hibernate.hql.ast.tree.SqlNode

setText(int, String) - Method in class org.hibernate.impl.AbstractQueryImpl

setText(String, String) - Method in class org.hibernate.impl.AbstractQueryImpl

setText(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

setText(boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaExportTask
Enable "text-only" mode.
setText(boolean) - Method in class org.hibernate.tool.hbm2ddl.SchemaUpdateTask
Enable "text-only" mode.
setText(String) - Method in class org.hibernate.tuple.ElementWrapper

setTime(int, Date) - Method in interface org.hibernate.Query

setTime(String, Date) - Method in interface org.hibernate.Query

setTime(int, Date) - Method in class org.hibernate.impl.AbstractQueryImpl

setTime(String, Date) - Method in class org.hibernate.impl.AbstractQueryImpl

setTimeout(int) - Method in interface org.hibernate.Criteria
Set a timeout for the underlying JDBC query.
setTimeout(int) - Method in interface org.hibernate.Query
Set a timeout for the underlying JDBC query.
setTimeout(int) - Method in interface org.hibernate.Transaction
Set the transaction timeout for any transaction started by a subsequent call to begin() on this instance.
setTimeout(Integer) - Method in class org.hibernate.engine.RowSelection

setTimeout(int) - Method in class org.hibernate.impl.AbstractQueryImpl

setTimeout(int) - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

setTimeout(int) - Method in class org.hibernate.impl.CriteriaImpl

setTimeout(int) - Method in class org.hibernate.transaction.CMTTransaction

setTimeout(int) - Method in class org.hibernate.transaction.JDBCTransaction

setTimeout(int) - Method in class org.hibernate.transaction.JTATransaction

setTimestamp(int, Date) - Method in interface org.hibernate.Query

setTimestamp(String, Date) - Method in interface org.hibernate.Query

setTimestamp(int, Date) - Method in class org.hibernate.impl.AbstractQueryImpl

setTimestamp(String, Date) - Method in class org.hibernate.impl.AbstractQueryImpl

setToXMLNode(Node, Object, SessionFactoryImplementor) - Method in class org.hibernate.type.AnyType

setToXMLNode(Node, Object, SessionFactoryImplementor) - Method in class org.hibernate.type.BlobType

setToXMLNode(Node, Object, SessionFactoryImplementor) - Method in class org.hibernate.type.ClobType

setToXMLNode(Node, Object, SessionFactoryImplementor) - Method in class org.hibernate.type.CollectionType

setToXMLNode(Node, Object, SessionFactoryImplementor) - Method in class org.hibernate.type.ComponentType

setToXMLNode(Node, Object, SessionFactoryImplementor) - Method in class org.hibernate.type.CompositeCustomType

setToXMLNode(Node, Object, SessionFactoryImplementor) - Method in class org.hibernate.type.CustomType

setToXMLNode(Node, Object, SessionFactoryImplementor) - Method in class org.hibernate.type.EntityType

setToXMLNode(Node, Object, SessionFactoryImplementor) - Method in class org.hibernate.type.MetaType

setToXMLNode(Node, Object, SessionFactoryImplementor) - Method in class org.hibernate.type.NullableType

setToXMLNode(Node, Object, SessionFactoryImplementor) - Method in interface org.hibernate.type.Type
A representation of the value to be embedded in an XML element.
setTransactionManagerLookupStrategy(String) - Method in class org.hibernate.jmx.HibernateService

setTransactionManagerLookupStrategy(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set the strategy for obtaining the JTA TransactionManager
setTransactionStrategy(String) - Method in class org.hibernate.jmx.HibernateService

setTransactionStrategy(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set the fully qualified class name of the Hibernate TransactionFactory implementation
setTransactionTimeout(int) - Method in class org.hibernate.jdbc.AbstractBatcher

setTransactionTimeout(int) - Method in interface org.hibernate.jdbc.Batcher
Set the transaction timeout to seconds later than the current system time.
setTransactionTimeout(int) - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter

setType(int) - Method in class org.hibernate.hql.ast.HqlToken
Sets the type of the token, remembering the previous type.
setTypeByReflection(String, String) - Method in class org.hibernate.mapping.Any

setTypeByReflection(String, String) - Method in class org.hibernate.mapping.Component

setTypeIndex(int) - Method in class org.hibernate.mapping.Column

setTypeName(String) - Method in class org.hibernate.mapping.Collection

setTypeName(String) - Method in class org.hibernate.mapping.SimpleValue

setTypeParameters(Properties) - Method in class org.hibernate.mapping.SimpleValue

setTypeUsingReflection(String, String) - Method in class org.hibernate.mapping.Any

setTypeUsingReflection(String, String) - Method in class org.hibernate.mapping.Collection

setTypeUsingReflection(String, String) - Method in class org.hibernate.mapping.Component

setTypeUsingReflection(String, String) - Method in class org.hibernate.mapping.DependantValue

setTypeUsingReflection(String, String) - Method in class org.hibernate.mapping.OneToMany

setTypeUsingReflection(String, String) - Method in class org.hibernate.mapping.SimpleValue

setTypeUsingReflection(String, String) - Method in class org.hibernate.mapping.ToOne

setTypeUsingReflection(String, String) - Method in interface org.hibernate.mapping.Value

setUnique(boolean) - Method in class org.hibernate.mapping.Column

setUnwrap(boolean) - Method in class org.hibernate.proxy.AbstractLazyInitializer

setUnwrap(boolean) - Method in interface org.hibernate.proxy.LazyInitializer

setUnwrapProxy(boolean) - Method in class org.hibernate.mapping.ToOne

setUpdateEventListeners(SaveOrUpdateEventListener[]) - Method in class org.hibernate.event.EventListeners

setUpdateable(boolean) - Method in class org.hibernate.mapping.DependantValue

setUpdateable(boolean) - Method in class org.hibernate.mapping.Property

setUseFromFragment(boolean) - Method in class org.hibernate.hql.ast.tree.FromElement

setUseThetaStyle(boolean) - Method in class org.hibernate.engine.JoinSequence

setUseWhereFragment(boolean) - Method in class org.hibernate.hql.ast.tree.FromElement

setUsedAliases(String[]) - Method in class org.hibernate.sql.SelectFragment

setUserName(String) - Method in class org.hibernate.jmx.HibernateService

setUserName(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Log into the database with this name
setUserTransactionName(String) - Method in class org.hibernate.jmx.HibernateService

setUserTransactionName(String) - Method in interface org.hibernate.jmx.HibernateServiceMBean
Set the JNDI name of the JTA UserTransaction object (used only by JTATransaction).
setValue(Value) - Method in class org.hibernate.mapping.Column

setValue(Value) - Method in class org.hibernate.mapping.Property

setValue(Object) - Method in class org.hibernate.util.IdentityMap.IdentityMapEntry

setVerbose(boolean) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask

setVersion(Object[], Object, EntityPersister) - Static method in class org.hibernate.engine.Versioning
Set the version number of the given instance state snapshot
setVersion(Property) - Method in class org.hibernate.mapping.RootClass

setVersionColumnName(String) - Method in class org.hibernate.sql.Delete

setVersionColumnName(String) - Method in class org.hibernate.sql.Update

setWhere(String) - Method in class org.hibernate.mapping.Collection

setWhere(String) - Method in class org.hibernate.mapping.RootClass

setWhere(String) - Method in class org.hibernate.sql.Delete

setWhere(String) - Method in class org.hibernate.sql.Update

setWhereClause(String) - Method in class org.hibernate.sql.Select
Sets the whereClause.
setWhereTokens(Iterator) - Method in class org.hibernate.sql.QuerySelect

setWithClauseFragment(String, String) - Method in class org.hibernate.hql.ast.tree.FromElement

setters - Variable in class org.hibernate.bytecode.javassist.BulkAccessor

setters - Variable in class org.hibernate.tuple.component.AbstractComponentTuplizer

setters - Variable in class org.hibernate.tuple.entity.AbstractEntityTuplizer

settingsFactory - Variable in class org.hibernate.cfg.Configuration

shallowCopy() - Method in class org.hibernate.util.Cloneable
Essentially performs a shallow copy of this SessionEventListenerConfig instance; meaning the SessionEventListenerConfig itself is cloned, but the individual listeners are not cloned.
shouldAutoClose() - Method in class org.hibernate.impl.SessionImpl

shouldAutoClose() - Method in class org.hibernate.impl.StatelessSessionImpl

shouldAutoClose() - Method in interface org.hibernate.transaction.TransactionFactory.Context

shouldGetAllProperties(Object) - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

shouldInstrumentClass(String) - Method in class org.hibernate.bytecode.util.BasicClassFilter

shouldInstrumentClass(String) - Method in interface org.hibernate.bytecode.util.ClassFilter

shouldInstrumentField(String, String) - Method in interface org.hibernate.bytecode.util.FieldFilter
Should this field definition be instrumented?
shouldInstrumentField(String, String) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask.CustomFieldFilter

shouldOverwriteCurrentVersion(Object, Object, Object, VersionType) - Method in class org.hibernate.ReplicationMode

shouldTransformFieldAccess(String, String, String) - Method in interface org.hibernate.bytecode.util.FieldFilter
Should we instrument *access to* the given field.
shouldTransformFieldAccess(String, String, String) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask.CustomFieldFilter

showAsString(AST, String) - Method in class org.hibernate.hql.ast.util.ASTPrinter
Prints the AST in 'ASCII art' tree form into a string.
showAst(AST, PrintStream) - Method in class org.hibernate.hql.ast.HqlParser

showAst(AST, PrintWriter) - Method in class org.hibernate.hql.ast.util.ASTPrinter
Prints the AST in 'ASCII art' tree form to the specified print writer.
simpleExpr(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

simpleExprList(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

size() - Method in class org.hibernate.collection.PersistentBag

size() - Method in class org.hibernate.collection.PersistentIdentifierBag

size() - Method in class org.hibernate.collection.PersistentList

size() - Method in class org.hibernate.collection.PersistentMap

size() - Method in class org.hibernate.collection.PersistentSet

size() - Method in class org.hibernate.proxy.map.MapProxy

size() - Method in class org.hibernate.util.FastHashMap
Return the number of key-value mappings in this map.
size() - Method in class org.hibernate.util.IdentityMap

size() - Method in class org.hibernate.util.IdentitySet

size() - Method in class org.hibernate.util.SimpleMRUCache

size() - Method in class org.hibernate.util.SoftLimitMRUCache

sizeEq(String, int) - Static method in class org.hibernate.criterion.Restrictions
Constrain a collection valued property by size
sizeGe(String, int) - Static method in class org.hibernate.criterion.Restrictions
Constrain a collection valued property by size
sizeGt(String, int) - Static method in class org.hibernate.criterion.Restrictions
Constrain a collection valued property by size
sizeLe(String, int) - Static method in class org.hibernate.criterion.Restrictions
Constrain a collection valued property by size
sizeLt(String, int) - Static method in class org.hibernate.criterion.Restrictions
Constrain a collection valued property by size
sizeNe(String, int) - Static method in class org.hibernate.criterion.Restrictions
Constrain a collection valued property by size
slice(String[], int, int) - Static method in class org.hibernate.util.ArrayHelper

slice(Object[], int, int) - Static method in class org.hibernate.util.ArrayHelper

snapshot(BasicCollectionPersister, EntityMode) - Method in class org.hibernate.collection.PersistentSortedMap

snapshot(BasicCollectionPersister, EntityMode) - Method in class org.hibernate.collection.PersistentSortedSet

softSize() - Method in class org.hibernate.util.SoftLimitMRUCache

sortCollectionActions() - Method in class org.hibernate.engine.ActionQueue

sortUpdateActions() - Method in class org.hibernate.engine.ActionQueue

sortedMap(String, String, boolean, Comparator) - Static method in class org.hibernate.type.TypeFactory

sortedSet(String, String, boolean, Comparator) - Static method in class org.hibernate.type.TypeFactory

split(String, String) - Static method in class org.hibernate.util.StringHelper

split(String, String, boolean) - Static method in class org.hibernate.util.StringHelper

sql(String, Object[], Type[]) - Static method in class org.hibernate.criterion.Expression
Apply a constraint expressed in SQL, with the given JDBC parameters.
sql(String, Object, Type) - Static method in class org.hibernate.criterion.Expression
Apply a constraint expressed in SQL, with the given JDBC parameter.
sql(String) - Static method in class org.hibernate.criterion.Expression
Apply a constraint expressed in SQL.
sql - Variable in class org.hibernate.loader.JoinWalker

sql - Variable in class org.hibernate.loader.OuterJoinLoader

sqlAlterStrings(Dialect, Mapping, TableMetadata, String, String) - Method in class org.hibernate.mapping.Table

sqlCommentStrings(Dialect, String, String) - Method in class org.hibernate.mapping.Table

sqlConstraintString(Dialect, String, String, String) - Method in class org.hibernate.mapping.Constraint

sqlConstraintString(Dialect, String, String, String) - Method in class org.hibernate.mapping.ForeignKey

sqlConstraintString(Dialect) - Method in class org.hibernate.mapping.Index

sqlConstraintString(Dialect) - Method in class org.hibernate.mapping.PrimaryKey

sqlConstraintString(Dialect, String, String, String) - Method in class org.hibernate.mapping.PrimaryKey

sqlConstraintString(Dialect) - Method in class org.hibernate.mapping.UniqueKey

sqlConstraintString(Dialect, String, String, String) - Method in class org.hibernate.mapping.UniqueKey

sqlCreateString(Dialect, Mapping, String, String) - Method in class org.hibernate.mapping.Constraint

sqlCreateString(Dialect, Mapping, String, String) - Method in class org.hibernate.mapping.Index

sqlCreateString(Dialect, Mapping, String, String) - Method in interface org.hibernate.mapping.RelationalModel

sqlCreateString(Dialect, Mapping, String, String) - Method in class org.hibernate.mapping.SimpleAuxiliaryDatabaseObject

sqlCreateString(Dialect, Mapping, String, String) - Method in class org.hibernate.mapping.Table

sqlCreateString(Dialect, Mapping, String, String) - Method in class org.hibernate.mapping.UniqueKey

sqlCreateStrings(Dialect) - Method in class org.hibernate.id.MultipleHiLoPerTableGenerator

sqlCreateStrings(Dialect) - Method in interface org.hibernate.id.PersistentIdentifierGenerator
The SQL required to create the underlying database objects.
sqlCreateStrings(Dialect) - Method in class org.hibernate.id.SequenceGenerator

sqlCreateStrings(Dialect) - Method in class org.hibernate.id.TableGenerator

sqlDropString(Dialect, String, String) - Method in class org.hibernate.mapping.Constraint

sqlDropString(Dialect, String, String) - Method in class org.hibernate.mapping.ForeignKey

sqlDropString(Dialect, String, String) - Method in class org.hibernate.mapping.Index

sqlDropString(Dialect, String, String) - Method in interface org.hibernate.mapping.RelationalModel

sqlDropString(Dialect, String, String) - Method in class org.hibernate.mapping.SimpleAuxiliaryDatabaseObject

sqlDropString(Dialect, String, String) - Method in class org.hibernate.mapping.Table

sqlDropString(Dialect, String, String) - Method in class org.hibernate.mapping.UniqueKey

sqlDropStrings(Dialect) - Method in class org.hibernate.id.MultipleHiLoPerTableGenerator

sqlDropStrings(Dialect) - Method in interface org.hibernate.id.PersistentIdentifierGenerator
The SQL required to remove the underlying database objects.
sqlDropStrings(Dialect) - Method in class org.hibernate.id.SequenceGenerator

sqlDropStrings(Dialect) - Method in class org.hibernate.id.TableGenerator

sqlFunctions - Variable in class org.hibernate.cfg.Configuration

sqlGroupProjection(String, String, String[], Type[]) - Static method in class org.hibernate.criterion.Projections
A grouping SQL projection, specifying both select clause and group by clause fragments
sqlProjection(String, String[], Type[]) - Static method in class org.hibernate.criterion.Projections
A SQL projection, a typed select clause fragment
sqlRestriction(String, Object[], Type[]) - Static method in class org.hibernate.criterion.Restrictions
Apply a constraint expressed in SQL, with the given JDBC parameters.
sqlRestriction(String, Object, Type) - Static method in class org.hibernate.criterion.Restrictions
Apply a constraint expressed in SQL, with the given JDBC parameter.
sqlRestriction(String) - Static method in class org.hibernate.criterion.Restrictions
Apply a constraint expressed in SQL.
sqlResultSetMappings - Variable in class org.hibernate.cfg.Configuration
Map result set name, result set description
sqlTemporaryTableCreateString(Dialect, Mapping) - Method in class org.hibernate.mapping.Table

sqlToken(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

sqlType() - Method in class org.hibernate.type.AbstractBynaryType

sqlType() - Method in class org.hibernate.type.AbstractCharArrayType

sqlType() - Method in class org.hibernate.type.AdaptedImmutableType

sqlType() - Method in class org.hibernate.type.BigDecimalType

sqlType() - Method in class org.hibernate.type.BigIntegerType

sqlType() - Method in class org.hibernate.type.BooleanType

sqlType() - Method in class org.hibernate.type.ByteType

sqlType() - Method in class org.hibernate.type.CalendarDateType

sqlType() - Method in class org.hibernate.type.CalendarType

sqlType() - Method in class org.hibernate.type.CharBooleanType

sqlType() - Method in class org.hibernate.type.CharacterType

sqlType() - Method in class org.hibernate.type.ClassType

sqlType() - Method in class org.hibernate.type.CurrencyType

sqlType() - Method in class org.hibernate.type.DateType

sqlType() - Method in class org.hibernate.type.DoubleType

sqlType() - Method in class org.hibernate.type.FloatType

sqlType() - Method in class org.hibernate.type.IntegerType

sqlType() - Method in class org.hibernate.type.LocaleType

sqlType() - Method in class org.hibernate.type.LongType

sqlType() - Method in class org.hibernate.type.NullableType

sqlType() - Method in class org.hibernate.type.SerializableType

sqlType() - Method in class org.hibernate.type.ShortType

sqlType() - Method in class org.hibernate.type.StringType

sqlType() - Method in class org.hibernate.type.TextType

sqlType() - Method in class org.hibernate.type.TimeType

sqlType() - Method in class org.hibernate.type.TimeZoneType

sqlType() - Method in class org.hibernate.type.TimestampType

sqlTypes(Mapping) - Method in class org.hibernate.type.AnyType

sqlTypes(Mapping) - Method in class org.hibernate.type.BlobType

sqlTypes(Mapping) - Method in class org.hibernate.type.ClobType

sqlTypes(Mapping) - Method in class org.hibernate.type.CollectionType

sqlTypes(Mapping) - Method in class org.hibernate.type.ComponentType

sqlTypes(Mapping) - Method in class org.hibernate.type.CompositeCustomType

sqlTypes(Mapping) - Method in class org.hibernate.type.CustomType

sqlTypes(Mapping) - Method in class org.hibernate.type.ManyToOneType

sqlTypes(Mapping) - Method in class org.hibernate.type.MetaType

sqlTypes(Mapping) - Method in class org.hibernate.type.NullableType

sqlTypes(Mapping) - Method in class org.hibernate.type.OneToOneType

sqlTypes(Mapping) - Method in class org.hibernate.type.SpecialOneToOneType

sqlTypes(Mapping) - Method in interface org.hibernate.type.Type
Return the SQL type codes for the columns mapped by this type.
sqlTypes() - Method in interface org.hibernate.usertype.UserType
Return the SQL type codes for the columns mapped by this type.
sqlWhereString - Variable in class org.hibernate.persister.collection.AbstractCollectionPersister

sqlqueries - Variable in class org.hibernate.cfg.Mappings

start(Properties) - Method in class org.hibernate.cache.AbstractJndiBoundCacheProvider
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
start(Properties) - Method in interface org.hibernate.cache.CacheProvider
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
start(Properties) - Method in class org.hibernate.cache.EhCacheProvider
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
start(Properties) - Method in class org.hibernate.cache.HashtableCacheProvider
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
start(Properties) - Method in class org.hibernate.cache.NoCacheProvider
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
start(Properties) - Method in class org.hibernate.cache.OSCacheProvider
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
start(Properties) - Method in class org.hibernate.cache.OptimisticTreeCacheProvider
Prepare the underlying JBossCache TreeCache instance.
start(Properties) - Method in class org.hibernate.cache.SwarmCacheProvider
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
start(Properties) - Method in class org.hibernate.cache.TreeCacheProvider
Prepare the underlying JBossCache TreeCache instance.
start(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.ClauseParser

start(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.FromParser

start(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.GroupByParser

start(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.OrderByParser

start(QueryTranslatorImpl) - Method in interface org.hibernate.hql.classic.Parser

start(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.PathExpressionParser

start(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.PreprocessingParser

start(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.SelectParser

start(QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.WhereParser

start() - Method in class org.hibernate.jmx.HibernateService

start() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Create the SessionFactory and bind to the jndi name on startup
stateField() - Method in class org.hibernate.hql.antlr.HqlBaseParser

statement() - Method in class org.hibernate.hql.antlr.HqlBaseParser

statement(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

statement(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

stop() - Method in class org.hibernate.cache.AbstractJndiBoundCacheProvider
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
stop() - Method in interface org.hibernate.cache.CacheProvider
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
stop() - Method in class org.hibernate.cache.EhCacheProvider
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
stop() - Method in class org.hibernate.cache.HashtableCacheProvider
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
stop() - Method in class org.hibernate.cache.NoCacheProvider
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
stop() - Method in class org.hibernate.cache.OSCacheProvider
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
stop() - Method in class org.hibernate.cache.OptimisticTreeCacheProvider

stop() - Method in class org.hibernate.cache.SwarmCacheProvider
Callback to perform any necessary cleanup of the underlying cache implementation during SessionFactory.close().
stop() - Method in class org.hibernate.cache.TreeCacheProvider

stop() - Method in class org.hibernate.jmx.HibernateService

stop() - Method in interface org.hibernate.jmx.HibernateServiceMBean
Unbind the SessionFactory or stub from JNDI
stringToObject(String) - Method in class org.hibernate.type.AbstractCharArrayType

stringToObject(String) - Method in class org.hibernate.type.BigIntegerType

stringToObject(String) - Method in class org.hibernate.type.BooleanType

stringToObject(String) - Method in class org.hibernate.type.ByteType

stringToObject(String) - Method in class org.hibernate.type.CharBooleanType

stringToObject(String) - Method in class org.hibernate.type.CharacterType

stringToObject(String) - Method in class org.hibernate.type.CustomType

stringToObject(String) - Method in class org.hibernate.type.DateType

stringToObject(String) - Method in interface org.hibernate.type.IdentifierType
Convert the value from the mapping file to a Java object.
stringToObject(String) - Method in class org.hibernate.type.IntegerType

stringToObject(String) - Method in class org.hibernate.type.LongType

stringToObject(String) - Method in class org.hibernate.type.ShortType

stringToObject(String) - Method in class org.hibernate.type.StringType

structure(Object) - Method in interface org.hibernate.cache.entry.CacheEntryStructure

structure(Object) - Method in class org.hibernate.cache.entry.StructuredCacheEntry

structure(Object) - Method in class org.hibernate.cache.entry.StructuredCollectionCacheEntry

structure(Object) - Method in class org.hibernate.cache.entry.StructuredMapCacheEntry

structure(Object) - Method in class org.hibernate.cache.entry.UnstructuredCacheEntry

subList(int, int) - Method in class org.hibernate.collection.PersistentBag

subList(int, int) - Method in class org.hibernate.collection.PersistentIdentifierBag

subList(int, int) - Method in class org.hibernate.collection.PersistentList

subMap(Object, Object) - Method in class org.hibernate.collection.PersistentSortedMap

subQuery() - Method in class org.hibernate.hql.antlr.HqlBaseParser

subSet(Object, Object) - Method in class org.hibernate.collection.PersistentSortedSet

substituteValuesIfNecessary(Object, Serializable, Object[], EntityPersister, SessionImplementor) - Method in class org.hibernate.event.def.AbstractSaveEventListener
Perform any property value substitution that is necessary (interceptor callback, version initialization...)
substituteValuesIfNecessary(Object, Serializable, Object[], EntityPersister, SessionImplementor) - Method in class org.hibernate.event.def.DefaultReplicateEventListener

suffix(String[], String) - Static method in class org.hibernate.util.StringHelper

suffixes - Variable in class org.hibernate.loader.JoinWalker

suffixes - Variable in class org.hibernate.loader.OuterJoinLoader

sum(String) - Static method in class org.hibernate.criterion.Projections
A property value sum
supportsAggressiveRelease() - Method in class org.hibernate.connection.C3P0ConnectionProvider

supportsAggressiveRelease() - Method in interface org.hibernate.connection.ConnectionProvider
Does this connection provider support aggressive release of JDBC connections and re-acquistion of those connections (if need be) later?
This is used in conjunction with org.hibernate.cfg.Environment.RELEASE_CONNECTIONS to aggressively release JDBC connections.
supportsAggressiveRelease() - Method in class org.hibernate.connection.DatasourceConnectionProvider

supportsAggressiveRelease() - Method in class org.hibernate.connection.DriverManagerConnectionProvider

supportsAggressiveRelease() - Method in class org.hibernate.connection.ProxoolConnectionProvider

supportsAggressiveRelease() - Method in class org.hibernate.connection.UserSuppliedConnectionProvider

supportsCascadeDelete() - Method in class org.hibernate.dialect.Dialect

supportsCascadeDelete() - Method in class org.hibernate.dialect.MySQL5InnoDBDialect

supportsCascadeDelete() - Method in class org.hibernate.dialect.MySQLDialect

supportsCascadeDelete() - Method in class org.hibernate.dialect.MySQLInnoDBDialect

supportsCascadeDelete() - Method in class org.hibernate.dialect.RDMSOS2200Dialect
RDMS does not support Cascade Deletes.
supportsColumnCheck() - Method in class org.hibernate.dialect.Dialect
Does this dialect support column-level check constraints?
supportsColumnCheck() - Method in class org.hibernate.dialect.HSQLDialect

supportsColumnCheck() - Method in class org.hibernate.dialect.JDataStoreDialect

supportsColumnCheck() - Method in class org.hibernate.dialect.TimesTenDialect

supportsCommentOn() - Method in class org.hibernate.dialect.DB2Dialect

supportsCommentOn() - Method in class org.hibernate.dialect.Dialect

supportsCommentOn() - Method in class org.hibernate.dialect.Oracle9Dialect

supportsCommentOn() - Method in class org.hibernate.dialect.PostgreSQLDialect

supportsCurrentTimestampSelection() - Method in class org.hibernate.dialect.DB2Dialect

supportsCurrentTimestampSelection() - Method in class org.hibernate.dialect.Dialect

supportsCurrentTimestampSelection() - Method in class org.hibernate.dialect.H2Dialect

supportsCurrentTimestampSelection() - Method in class org.hibernate.dialect.HSQLDialect

supportsCurrentTimestampSelection() - Method in class org.hibernate.dialect.InformixDialect

supportsCurrentTimestampSelection() - Method in class org.hibernate.dialect.MySQLDialect

supportsCurrentTimestampSelection() - Method in class org.hibernate.dialect.Oracle9Dialect

supportsCurrentTimestampSelection() - Method in class org.hibernate.dialect.PostgreSQLDialect

supportsCurrentTimestampSelection() - Method in class org.hibernate.dialect.SybaseDialect

supportsCurrentTimestampSelection() - Method in class org.hibernate.dialect.TimesTenDialect

supportsForUpdate() - Method in class org.hibernate.dialect.MimerSQLDialect
Support the FOR UPDATE syntax? For now, returns false since the current version of the Mimer SQL JDBC Driver does not support updatable resultsets.
supportsForUpdateOf() - Method in class org.hibernate.dialect.IngresDialect
Does this dialect support FOR UPDATE OF, allowing particular rows to be locked?
supportsIdGenWithBulkInsertion(IdentifierGenerator) - Static method in class org.hibernate.hql.ast.HqlSqlWalker

supportsIdentityColumns() - Method in class org.hibernate.dialect.DB2Dialect

supportsIdentityColumns() - Method in class org.hibernate.dialect.Dialect
Does this dialect support identity column key generation?
supportsIdentityColumns() - Method in class org.hibernate.dialect.H2Dialect

supportsIdentityColumns() - Method in class org.hibernate.dialect.HSQLDialect

supportsIdentityColumns() - Method in class org.hibernate.dialect.InformixDialect

supportsIdentityColumns() - Method in class org.hibernate.dialect.JDataStoreDialect

supportsIdentityColumns() - Method in class org.hibernate.dialect.MimerSQLDialect
TODO: Check if Mimer SQL cannot handle the way DB2 does
supportsIdentityColumns() - Method in class org.hibernate.dialect.MySQLDialect

supportsIdentityColumns() - Method in class org.hibernate.dialect.PostgreSQLDialect

supportsIdentityColumns() - Method in class org.hibernate.dialect.SybaseDialect

supportsIfExistsAfterTableName() - Method in class org.hibernate.dialect.Dialect

supportsIfExistsAfterTableName() - Method in class org.hibernate.dialect.H2Dialect

supportsIfExistsAfterTableName() - Method in class org.hibernate.dialect.HSQLDialect

supportsIfExistsBeforeTableName() - Method in class org.hibernate.dialect.Dialect

supportsIfExistsBeforeTableName() - Method in class org.hibernate.dialect.MySQLDialect

supportsInsertSelectIdentity() - Method in class org.hibernate.dialect.Dialect

supportsInsertSelectIdentity() - Method in class org.hibernate.dialect.SybaseAnywhereDialect

supportsInsertSelectIdentity() - Method in class org.hibernate.dialect.SybaseDialect

supportsLimit() - Method in class org.hibernate.dialect.DB2390Dialect

supportsLimit() - Method in class org.hibernate.dialect.DB2400Dialect

supportsLimit() - Method in class org.hibernate.dialect.DB2Dialect

supportsLimit() - Method in class org.hibernate.dialect.DerbyDialect

supportsLimit() - Method in class org.hibernate.dialect.Dialect
Does this Dialect have some kind of LIMIT syntax?
supportsLimit() - Method in class org.hibernate.dialect.H2Dialect

supportsLimit() - Method in class org.hibernate.dialect.HSQLDialect

supportsLimit() - Method in class org.hibernate.dialect.InformixDialect

supportsLimit() - Method in class org.hibernate.dialect.IngresDialect
Does this Dialect have some kind of LIMIT syntax?
supportsLimit() - Method in class org.hibernate.dialect.InterbaseDialect

supportsLimit() - Method in class org.hibernate.dialect.MimerSQLDialect
Mimer SQL does not support limit
supportsLimit() - Method in class org.hibernate.dialect.MySQLDialect

supportsLimit() - Method in class org.hibernate.dialect.Oracle9Dialect

supportsLimit() - Method in class org.hibernate.dialect.PostgreSQLDialect

supportsLimit() - Method in class org.hibernate.dialect.RDMSOS2200Dialect

supportsLimit() - Method in class org.hibernate.dialect.SQLServerDialect

supportsLimit() - Method in class org.hibernate.dialect.TimesTenDialect

supportsLimitOffset() - Method in class org.hibernate.dialect.DB2390Dialect

supportsLimitOffset() - Method in class org.hibernate.dialect.DB2400Dialect

supportsLimitOffset() - Method in class org.hibernate.dialect.DerbyDialect

supportsLimitOffset() - Method in class org.hibernate.dialect.Dialect
Does this dialect support an offset?
supportsLimitOffset() - Method in class org.hibernate.dialect.InformixDialect

supportsLimitOffset() - Method in class org.hibernate.dialect.IngresDialect
Does this dialect support an offset?
supportsLimitOffset() - Method in class org.hibernate.dialect.RDMSOS2200Dialect

supportsLimitOffset() - Method in class org.hibernate.dialect.SQLServerDialect

supportsLimitOffset() - Method in class org.hibernate.dialect.TimesTenDialect

supportsNotNullUnique() - Method in class org.hibernate.dialect.DB2Dialect

supportsNotNullUnique() - Method in class org.hibernate.dialect.Dialect

supportsOrdinalParameterMetadata() - Method in interface org.hibernate.hql.ParameterTranslations

supportsOrdinalParameterMetadata() - Method in class org.hibernate.hql.ast.ParameterTranslationsImpl

supportsOuterJoinForUpdate() - Method in class org.hibernate.dialect.DB2Dialect

supportsOuterJoinForUpdate() - Method in class org.hibernate.dialect.Dialect

supportsOuterJoinForUpdate() - Method in class org.hibernate.dialect.MimerSQLDialect
For now, simply return false since we don't updatable result sets.
supportsOuterJoinForUpdate() - Method in class org.hibernate.dialect.PostgreSQLDialect

supportsOuterJoinForUpdate() - Method in class org.hibernate.dialect.RDMSOS2200Dialect
Currently, RDMS-JDBC does not support ForUpdate.
supportsParametersInInsertSelect() - Method in class org.hibernate.dialect.DB2Dialect

supportsParametersInInsertSelect() - Method in class org.hibernate.dialect.Dialect
Does this dialect support parameters within the select clause of INSERT ...
supportsParent() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

supportsParent() - Method in class org.hibernate.tuple.ElementWrapper

supportsRowValueConstructorSyntax() - Method in class org.hibernate.dialect.Dialect
Is this dialect known to support what ANSI-SQL terms "row value constructor" syntax; sometimes called tuple syntax.
supportsRowValueConstructorSyntax() - Method in class org.hibernate.dialect.MySQLDialect

supportsRowValueConstructorSyntax() - Method in class org.hibernate.dialect.PostgreSQLDialect

supportsSequences() - Method in class org.hibernate.dialect.DB2390Dialect

supportsSequences() - Method in class org.hibernate.dialect.DB2400Dialect

supportsSequences() - Method in class org.hibernate.dialect.DB2Dialect

supportsSequences() - Method in class org.hibernate.dialect.DerbyDialect

supportsSequences() - Method in class org.hibernate.dialect.Dialect
Does this dialect support sequences?
supportsSequences() - Method in class org.hibernate.dialect.H2Dialect

supportsSequences() - Method in class org.hibernate.dialect.HSQLDialect

supportsSequences() - Method in class org.hibernate.dialect.InformixDialect

supportsSequences() - Method in class org.hibernate.dialect.IngresDialect
Does this dialect support sequences?
supportsSequences() - Method in class org.hibernate.dialect.InterbaseDialect

supportsSequences() - Method in class org.hibernate.dialect.MckoiDialect

supportsSequences() - Method in class org.hibernate.dialect.MimerSQLDialect
Mimer SQL supports sequences
supportsSequences() - Method in class org.hibernate.dialect.Oracle9Dialect

supportsSequences() - Method in class org.hibernate.dialect.PostgreSQLDialect

supportsSequences() - Method in class org.hibernate.dialect.RDMSOS2200Dialect

supportsSequences() - Method in class org.hibernate.dialect.SAPDBDialect

supportsSequences() - Method in class org.hibernate.dialect.TimesTenDialect

supportsTableCheck() - Method in class org.hibernate.dialect.Dialect
Does this dialect support table-level check constraints?
supportsTableCheck() - Method in class org.hibernate.dialect.JDataStoreDialect

supportsTableCheck() - Method in class org.hibernate.dialect.TimesTenDialect

supportsTemporaryTables() - Method in class org.hibernate.dialect.DB2Dialect

supportsTemporaryTables() - Method in class org.hibernate.dialect.Dialect

supportsTemporaryTables() - Method in class org.hibernate.dialect.H2Dialect

supportsTemporaryTables() - Method in class org.hibernate.dialect.HSQLDialect
HSQL does not really support temp tables; just take advantage of the fact that it is a single user db...
supportsTemporaryTables() - Method in class org.hibernate.dialect.MySQLDialect

supportsTemporaryTables() - Method in class org.hibernate.dialect.Oracle9Dialect

supportsTemporaryTables() - Method in class org.hibernate.dialect.PostgreSQLDialect

supportsTemporaryTables() - Method in class org.hibernate.dialect.SAPDBDialect

supportsTemporaryTables() - Method in class org.hibernate.dialect.SybaseDialect

supportsTemporaryTables() - Method in class org.hibernate.dialect.TimesTenDialect

supportsUnionAll() - Method in class org.hibernate.dialect.DB2Dialect

supportsUnionAll() - Method in class org.hibernate.dialect.Dialect

supportsUnionAll() - Method in class org.hibernate.dialect.H2Dialect

supportsUnionAll() - Method in class org.hibernate.dialect.Oracle9Dialect

supportsUnionAll() - Method in class org.hibernate.dialect.PostgreSQLDialect

supportsUnionAll() - Method in class org.hibernate.dialect.RDMSOS2200Dialect

supportsUnique() - Method in class org.hibernate.dialect.Dialect
Does this dialect support the UNIQUE column syntax?
supportsUnique() - Method in class org.hibernate.dialect.H2Dialect

supportsUnique() - Method in class org.hibernate.dialect.HSQLDialect

supportsUnique() - Method in class org.hibernate.dialect.TimesTenDialect

supportsUniqueConstraintInCreateAlterTable() - Method in class org.hibernate.dialect.Dialect
Does this dialect support adding Unique constraints via create and alter table ?
supportsUniqueConstraintInCreateAlterTable() - Method in class org.hibernate.dialect.RDMSOS2200Dialect
RDMS does not support adding Unique constraints via create and alter table.
supportsUniqueConstraintInCreateAlterTable() - Method in class org.hibernate.dialect.TimesTenDialect

supportsVariableLimit() - Method in class org.hibernate.dialect.DB2390Dialect

supportsVariableLimit() - Method in class org.hibernate.dialect.DB2400Dialect

supportsVariableLimit() - Method in class org.hibernate.dialect.Dialect

supportsVariableLimit() - Method in class org.hibernate.dialect.InformixDialect

supportsVariableLimit() - Method in class org.hibernate.dialect.IngresDialect

supportsVariableLimit() - Method in class org.hibernate.dialect.RDMSOS2200Dialect

supportsVariableLimit() - Method in class org.hibernate.dialect.SQLServerDialect

supportsVariableLimit() - Method in class org.hibernate.dialect.TimesTenDialect

suspend() - Method in class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter

synchronizedTables - Variable in class org.hibernate.mapping.PersistentClass

T

TABLE - Static variable in interface org.hibernate.id.PersistentIdentifierGenerator
The configuration parameter holding the table name for the generated id
TABLE - Static variable in class org.hibernate.id.TableGenerator
The table parameter
TABLES - Static variable in interface org.hibernate.id.PersistentIdentifierGenerator
The configuration parameter holding the table names for all tables for which the id must be unique
TEMPLATE - Static variable in class org.hibernate.sql.Template

TEXT - Static variable in class org.hibernate.Hibernate
Hibernate text type.
THEN - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

THEN - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

THEN - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

THETA_JOINS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

THETA_JOINS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

TIME - Static variable in class org.hibernate.Hibernate
Hibernate time type.
TIMESTAMP - Static variable in class org.hibernate.Hibernate
Hibernate timestamp type.
TIMEZONE - Static variable in class org.hibernate.Hibernate
Hibernate timezone type.
TO_LIST - Static variable in class org.hibernate.transform.Transformers
Each row of results is a List
TRAILING - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

TRAILING - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

TRAILING - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

TRANSACTIONAL - Static variable in class org.hibernate.cache.CacheFactory

TRANSACTION_MANAGER_STRATEGY - Static variable in class org.hibernate.cfg.Environment
TransactionManagerLookup implementor to use for obtaining the TransactionManager
TRANSACTION_STRATEGY - Static variable in class org.hibernate.cfg.Environment
TransactionFactory implementor to use for creating Transactions
TRANSIENT - Static variable in class org.hibernate.event.def.AbstractSaveEventListener

TRUE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

TRUE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

TRUE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

TRUE - Static variable in class org.hibernate.util.ArrayHelper

TRUE_FALSE - Static variable in class org.hibernate.Hibernate
Hibernate true_false type.
Table - class org.hibernate.mapping.Table.
A relational table
Table() - Constructor for class org.hibernate.mapping.Table

Table(String) - Constructor for class org.hibernate.mapping.Table

TableGenerator - class org.hibernate.id.TableGenerator.
An IdentifierGenerator that uses a database table to store the last generated value.
TableGenerator() - Constructor for class org.hibernate.id.TableGenerator

TableHiLoGenerator - class org.hibernate.id.TableHiLoGenerator.
hilo

An IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.
TableHiLoGenerator() - Constructor for class org.hibernate.id.TableHiLoGenerator

TableMetadata - class org.hibernate.tool.hbm2ddl.TableMetadata.
JDBC table metadata
TableOwner - interface org.hibernate.mapping.TableOwner.
Interface allowing to differenciate SubClasses from Classes, JoinedSubClasses and UnionSubClasses The first one has not its own table while the others have
Template - class org.hibernate.sql.Template.
Parses SQL fragments specified in mapping documents
TemplatedViolatedConstraintNameExtracter - class org.hibernate.exception.TemplatedViolatedConstraintNameExtracter.
Knows how to extract a violated constraint name from an error message based on the fact that the constraint name is templated within the message.
TemplatedViolatedConstraintNameExtracter() - Constructor for class org.hibernate.exception.TemplatedViolatedConstraintNameExtracter

TextType - class org.hibernate.type.TextType.
text: A type that maps an SQL CLOB to a Java String.
TextType() - Constructor for class org.hibernate.type.TextType

ThreadLocalSessionContext - class org.hibernate.context.ThreadLocalSessionContext.
A CurrentSessionContext impl which scopes the notion of current session by the current thread of execution.
ThreadLocalSessionContext(SessionFactoryImplementor) - Constructor for class org.hibernate.context.ThreadLocalSessionContext

ThreadLocalSessionContext.CleanupSynch - class org.hibernate.context.ThreadLocalSessionContext.CleanupSynch.
JTA transaction synch used for cleanup of the internal session map.
ThreadLocalSessionContext.CleanupSynch(SessionFactory) - Constructor for class org.hibernate.context.ThreadLocalSessionContext.CleanupSynch

TimeType - class org.hibernate.type.TimeType.
time: A type that maps an SQL TIME to a Java java.util.Date or java.sql.Time.
TimeType() - Constructor for class org.hibernate.type.TimeType

TimeZoneType - class org.hibernate.type.TimeZoneType.
timezone: A type that maps an SQL VARCHAR to a java.util.TimeZone
TimeZoneType() - Constructor for class org.hibernate.type.TimeZoneType

TimesTenDialect - class org.hibernate.dialect.TimesTenDialect.
A SQL dialect for TimesTen 5.1.
TimesTenDialect() - Constructor for class org.hibernate.dialect.TimesTenDialect

TimestampType - class org.hibernate.type.TimestampType.
timestamp: A type that maps an SQL TIMESTAMP to a Java java.util.Date or java.sql.Timestamp.
TimestampType() - Constructor for class org.hibernate.type.TimestampType

Timestamper - class org.hibernate.cache.Timestamper.
Generates increasing identifiers (in a single VM only).
ToListResultTransformer - class org.hibernate.transform.ToListResultTransformer.

ToOne - class org.hibernate.mapping.ToOne.
A simple-point association (ie.
ToOne(Table) - Constructor for class org.hibernate.mapping.ToOne

TooManyRowsAffectedException - exception org.hibernate.jdbc.TooManyRowsAffectedException.
Indicates that more rows were affected then we were expecting to be.
TooManyRowsAffectedException(String, int, int) - Constructor for class org.hibernate.jdbc.TooManyRowsAffectedException

Transaction - interface org.hibernate.Transaction.
Allows the application to define units of work, while maintaining abstraction from the underlying transaction implementation (eg.
TransactionException - exception org.hibernate.TransactionException.
Indicates that a transaction could not be begun, committed or rolled back.
TransactionException(String, Exception) - Constructor for class org.hibernate.TransactionException

TransactionException(String) - Constructor for class org.hibernate.TransactionException

TransactionFactory - interface org.hibernate.transaction.TransactionFactory.
An abstract factory for Transaction instances.
TransactionFactory.Context - interface org.hibernate.transaction.TransactionFactory.Context.

TransactionFactoryFactory - class org.hibernate.transaction.TransactionFactoryFactory.

TransactionHelper - class org.hibernate.engine.TransactionHelper.
Allows work to be done outside the current transaction, by suspending it, and performing work in a new transaction
TransactionHelper() - Constructor for class org.hibernate.engine.TransactionHelper

TransactionManagerLookup - interface org.hibernate.transaction.TransactionManagerLookup.
Concrete implementations locate and return the JTA TransactionManager.
TransactionManagerLookupFactory - class org.hibernate.transaction.TransactionManagerLookupFactory.

TransactionalCache - class org.hibernate.cache.TransactionalCache.
Support for fully transactional cache implementations like JBoss TreeCache.
TransactionalCache() - Constructor for class org.hibernate.cache.TransactionalCache

Transformers - class org.hibernate.transform.Transformers.

TransformingClassLoader - class org.hibernate.bytecode.javassist.TransformingClassLoader.

TransientObjectException - exception org.hibernate.TransientObjectException.
Thrown when the user passes a transient instance to a Session method that expects a persistent instance.
TransientObjectException(String) - Constructor for class org.hibernate.TransientObjectException

TreeCache - class org.hibernate.cache.TreeCache.
Represents a particular region within the given JBossCache TreeCache.
TreeCache(TreeCache, String, TransactionManager) - Constructor for class org.hibernate.cache.TreeCache

TreeCacheProvider - class org.hibernate.cache.TreeCacheProvider.
Support for a standalone JBossCache (TreeCache) instance.
TreeCacheProvider() - Constructor for class org.hibernate.cache.TreeCacheProvider

TrueFalseType - class org.hibernate.type.TrueFalseType.
true_false: A type that maps an SQL CHAR(1) to a Java Boolean.
TrueFalseType() - Constructor for class org.hibernate.type.TrueFalseType

Tuplizer - interface org.hibernate.tuple.Tuplizer.
A tuplizer defines the contract for things which know how to manage a particular representation of a piece of data, given that representation's EntityMode (the entity-mode essentially defining which representation).
TwoPhaseLoad - class org.hibernate.engine.TwoPhaseLoad.
Functionality relating to Hibernate's two-phase loading process, that may be reused by persisters that do not use the Loader framework
Type - interface org.hibernate.type.Type.
Defines a mapping from a Java type to an JDBC datatype.
TypeDef - class org.hibernate.mapping.TypeDef.
Placeholder for typedef information
TypeDef(String, Properties) - Constructor for class org.hibernate.mapping.TypeDef

TypeFactory - class org.hibernate.type.TypeFactory.
Used internally to obtain instances of Type.
TypeMismatchException - exception org.hibernate.TypeMismatchException.
Used when a user provided type does not match the expected one
TypeMismatchException(Throwable) - Constructor for class org.hibernate.TypeMismatchException

TypeMismatchException(String) - Constructor for class org.hibernate.TypeMismatchException

TypeMismatchException(String, Throwable) - Constructor for class org.hibernate.TypeMismatchException

TypeNames - class org.hibernate.dialect.TypeNames.
This class maps a type to names.
TypeNames() - Constructor for class org.hibernate.dialect.TypeNames

TypedValue - class org.hibernate.engine.TypedValue.
An ordered pair of a value and its Hibernate type.
TypedValue(Type, Object, EntityMode) - Constructor for class org.hibernate.engine.TypedValue

tableJoin(AST, AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

tableName(String) - Method in class org.hibernate.cfg.DefaultNamingStrategy
Return the argument
tableName(String) - Method in class org.hibernate.cfg.ImprovedNamingStrategy
Convert mixed case to underscores
tableName(String) - Method in interface org.hibernate.cfg.NamingStrategy
Alter the table name given in the mapping document
tableNameBinding - Variable in class org.hibernate.cfg.Configuration

tableNameBinding - Variable in class org.hibernate.cfg.Mappings
binding between logical table name and physical one (ie after the naming strategy has been applied)
tables - Variable in class org.hibernate.cfg.Configuration

tables - Variable in class org.hibernate.cfg.Mappings

tailMap(Object) - Method in class org.hibernate.collection.PersistentSortedMap

tailSet(Object) - Method in class org.hibernate.collection.PersistentSortedSet

target - Variable in class org.hibernate.bytecode.javassist.BulkAccessor

tempList - Variable in class org.hibernate.collection.PersistentSet

thetaJoins(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

throwIfNull(Object, Serializable, String) - Static method in class org.hibernate.UnresolvableObjectException

throwPropertyException(String) - Method in class org.hibernate.persister.entity.AbstractPropertyMapping

throwQueryException() - Method in class org.hibernate.hql.ast.ErrorCounter

throwQueryException() - Method in interface org.hibernate.hql.ast.ParseErrorHandler

to2DIntArray(Collection) - Static method in class org.hibernate.util.ArrayHelper

to2DStringArray(Collection) - Static method in class org.hibernate.util.ArrayHelper

toAliasString(String) - Method in class org.hibernate.sql.Alias

toAliasStrings(String[]) - Method in class org.hibernate.sql.Alias

toArray() - Method in class org.hibernate.collection.PersistentBag

toArray(Object[]) - Method in class org.hibernate.collection.PersistentBag

toArray() - Method in class org.hibernate.collection.PersistentIdentifierBag

toArray(Object[]) - Method in class org.hibernate.collection.PersistentIdentifierBag

toArray() - Method in class org.hibernate.collection.PersistentList

toArray(Object[]) - Method in class org.hibernate.collection.PersistentList

toArray() - Method in class org.hibernate.collection.PersistentSet

toArray(Object[]) - Method in class org.hibernate.collection.PersistentSet

toArray() - Method in class org.hibernate.util.IdentitySet

toArray(Object[]) - Method in class org.hibernate.util.IdentitySet

toBooleanArray(Collection) - Static method in class org.hibernate.util.ArrayHelper

toBooleanValueString(boolean) - Method in class org.hibernate.dialect.Dialect
The SQL value that the JDBC driver maps boolean values to
toBooleanValueString(boolean) - Method in class org.hibernate.dialect.PostgreSQLDialect

toColumnNullness(Object, Mapping) - Method in class org.hibernate.type.AnyType

toColumnNullness(Object, Mapping) - Method in class org.hibernate.type.BlobType

toColumnNullness(Object, Mapping) - Method in class org.hibernate.type.ClobType

toColumnNullness(Object, Mapping) - Method in class org.hibernate.type.CollectionType

toColumnNullness(Object, Mapping) - Method in class org.hibernate.type.ComponentType

toColumnNullness(Object, Mapping) - Method in class org.hibernate.type.CompositeCustomType

toColumnNullness(Object, Mapping) - Method in class org.hibernate.type.CustomType

toColumnNullness(Object, Mapping) - Method in class org.hibernate.type.ManyToOneType

toColumnNullness(Object, Mapping) - Method in class org.hibernate.type.MetaType

toColumnNullness(Object, Mapping) - Method in class org.hibernate.type.NullableType

toColumnNullness(Object, Mapping) - Method in class org.hibernate.type.OneToOneType

toColumnNullness(Object, Mapping) - Method in interface org.hibernate.type.Type
Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
toColumns(String, String, boolean) - Method in class org.hibernate.hql.ast.tree.FromElement

toColumns(String, String, boolean, boolean) - Method in class org.hibernate.hql.ast.tree.FromElement

toColumns(String, String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

toColumns(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

toColumns(String, String) - Method in class org.hibernate.persister.collection.CollectionPropertyMapping

toColumns(String) - Method in class org.hibernate.persister.collection.CollectionPropertyMapping
Given a property path, return the corresponding column name(s).
toColumns(String, String) - Method in class org.hibernate.persister.collection.ElementPropertyMapping

toColumns(String) - Method in class org.hibernate.persister.collection.ElementPropertyMapping
Given a property path, return the corresponding column name(s).
toColumns(String, String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

toColumns(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

toColumns(String, int) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

toColumns(String, String) - Method in class org.hibernate.persister.entity.AbstractPropertyMapping

toColumns(String) - Method in class org.hibernate.persister.entity.AbstractPropertyMapping

toColumns(String, String) - Method in class org.hibernate.persister.entity.BasicEntityPropertyMapping

toColumns(String, String) - Method in class org.hibernate.persister.entity.JoinedSubclassEntityPersister

toColumns(String, int) - Method in interface org.hibernate.persister.entity.OuterJoinLoadable
Given the number of a property of a subclass, and a table alias, return the aliased column names.
toColumns(String, String) - Method in interface org.hibernate.persister.entity.PropertyMapping
Given a query alias and a property path, return the qualified column name
toColumns(String) - Method in interface org.hibernate.persister.entity.PropertyMapping
Given a property path, return the corresponding column name(s).
toExternalFormat(byte[]) - Method in class org.hibernate.type.AbstractBynaryType
Convert the byte[] into the expected object type
toExternalFormat(char[]) - Method in class org.hibernate.type.AbstractCharArrayType
Convert the char[] into the expected object type
toExternalFormat(byte[]) - Method in class org.hibernate.type.BinaryType

toExternalFormat(char[]) - Method in class org.hibernate.type.CharArrayType

toExternalFormat(char[]) - Method in class org.hibernate.type.CharacterArrayType

toExternalFormat(byte[]) - Method in class org.hibernate.type.WrapperBinaryType

toFragmentString() - Method in class org.hibernate.sql.ANSICaseFragment

toFragmentString() - Method in class org.hibernate.sql.CaseFragment

toFragmentString() - Method in class org.hibernate.sql.ConditionFragment

toFragmentString() - Method in class org.hibernate.sql.DecodeCaseFragment

toFragmentString() - Method in class org.hibernate.sql.DerbyCaseFragment
From http://www.jroller.com/comments/kenlars99/Weblog/cloudscape_soon_to_be_derby
The problem we had, was when Hibernate does a select with a case statement, for joined subclasses.
toFragmentString() - Method in class org.hibernate.sql.DisjunctionFragment

toFragmentString() - Method in class org.hibernate.sql.ForUpdateFragment

toFragmentString() - Method in class org.hibernate.sql.HSQLCaseFragment

toFragmentString() - Method in class org.hibernate.sql.InFragment

toFragmentString() - Method in class org.hibernate.sql.MckoiCaseFragment

toFragmentString() - Method in class org.hibernate.sql.SelectFragment

toFromFragmentString() - Method in class org.hibernate.sql.ANSIJoinFragment

toFromFragmentString() - Method in class org.hibernate.sql.JoinFragment

toFromFragmentString() - Method in class org.hibernate.sql.OracleJoinFragment

toFromFragmentString() - Method in class org.hibernate.sql.QueryJoinFragment

toFromFragmentString() - Method in class org.hibernate.sql.Sybase11JoinFragment

toGroupSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.AliasedProjection

toGroupSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.Distinct

toGroupSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.IdentifierProjection

toGroupSqlString(Criteria, CriteriaQuery) - Method in interface org.hibernate.criterion.Projection
Render the SQL fragment to be used in the group by clause
toGroupSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.ProjectionList

toGroupSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.PropertyProjection

toGroupSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SQLProjection

toGroupSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SimpleProjection

toHibernateJoinType(int) - Static method in class org.hibernate.hql.ast.util.JoinProcessor
Translates an AST join type (i.e., the token type) into a JoinFragment.XXX join type.
toInt(byte[]) - Static method in class org.hibernate.util.BytesHelper

toIntArray(Collection) - Static method in class org.hibernate.util.ArrayHelper

toInternalFormat(Object) - Method in class org.hibernate.type.AbstractBynaryType
Convert the object into the internal byte[] representation
toInternalFormat(Object) - Method in class org.hibernate.type.AbstractCharArrayType
Convert the object into the internal char[] representation
toInternalFormat(Object) - Method in class org.hibernate.type.BinaryType

toInternalFormat(Object) - Method in class org.hibernate.type.CharArrayType

toInternalFormat(Object) - Method in class org.hibernate.type.CharacterArrayType

toInternalFormat(Object) - Method in class org.hibernate.type.WrapperBinaryType

toJoinFragment() - Method in class org.hibernate.engine.JoinSequence

toJoinFragment(Map, boolean) - Method in class org.hibernate.engine.JoinSequence

toJoinFragment(Map, boolean, String, String) - Method in class org.hibernate.engine.JoinSequence

toLeftSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.ExistsSubqueryExpression

toLeftSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.PropertySubqueryExpression

toLeftSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SimpleSubqueryExpression

toLeftSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SubqueryExpression

toList(Object) - Static method in class org.hibernate.util.ArrayHelper

toList(Iterator) - Static method in class org.hibernate.util.ArrayHelper

toLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.AnyType

toLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.ArrayType

toLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.BlobType

toLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.ClobType

toLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.CollectionType

toLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.ComponentType

toLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.CompositeCustomType

toLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.CustomType

toLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.EntityType

toLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.MetaType

toLoggableString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.NullableType

toLoggableString(Object, SessionFactoryImplementor) - Method in interface org.hibernate.type.Type
A representation of the value to be embedded in a log file.
toLoggableString(Object, SessionFactoryImplementor) - Method in interface org.hibernate.usertype.LoggableUserType
Generate a loggable string representation of the collection (value).
toLowerCase(String) - Static method in class org.hibernate.util.StringHelper

toMap() - Method in interface org.hibernate.cache.Cache
optional operation
toMap() - Method in class org.hibernate.cache.EhCache

toMap() - Method in class org.hibernate.cache.HashtableCache

toMap() - Method in class org.hibernate.cache.OSCache

toMap() - Method in class org.hibernate.cache.OptimisticTreeCache

toMap() - Method in class org.hibernate.cache.SwarmCache

toMap() - Method in class org.hibernate.cache.TreeCache

toMap(String, String, Properties) - Static method in class org.hibernate.util.PropertiesHelper

toMatchString(String) - Method in class org.hibernate.criterion.MatchMode
convert the pattern, by appending/prepending "%"
toQueryString() - Method in class org.hibernate.sql.QuerySelect

toResultSetType() - Method in class org.hibernate.ScrollMode

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.AbstractEmptinessExpression

toSqlString(Criteria, int, CriteriaQuery) - Method in class org.hibernate.criterion.AggregateProjection

toSqlString(Criteria, int, CriteriaQuery) - Method in class org.hibernate.criterion.AliasedProjection

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.BetweenExpression

toSqlString(Criteria, int, CriteriaQuery) - Method in class org.hibernate.criterion.CountProjection

toSqlString(Criteria, CriteriaQuery) - Method in interface org.hibernate.criterion.Criterion
Render the SQL fragment
toSqlString(Criteria, int, CriteriaQuery) - Method in class org.hibernate.criterion.Distinct

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.Example

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.IdentifierEqExpression

toSqlString(Criteria, int, CriteriaQuery) - Method in class org.hibernate.criterion.IdentifierProjection

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.IlikeExpression

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.InExpression

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.Junction

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.LikeExpression

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.LogicalExpression

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.NaturalIdentifier

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.NotExpression

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.NotNullExpression

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.NullExpression

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.Order
Render the SQL fragment
toSqlString(Criteria, int, CriteriaQuery) - Method in interface org.hibernate.criterion.Projection
Render the SQL fragment
toSqlString(Criteria, int, CriteriaQuery) - Method in class org.hibernate.criterion.ProjectionList

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.PropertyExpression

toSqlString(Criteria, int, CriteriaQuery) - Method in class org.hibernate.criterion.PropertyProjection

toSqlString(Criteria, int, CriteriaQuery) - Method in class org.hibernate.criterion.RowCountProjection

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SQLCriterion

toSqlString(Criteria, int, CriteriaQuery) - Method in class org.hibernate.criterion.SQLProjection

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SimpleExpression

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SizeExpression

toSqlString(Criteria, CriteriaQuery) - Method in class org.hibernate.criterion.SubqueryExpression

toStatementString() - Method in class org.hibernate.id.insert.InsertSelectIdentityInsert

toStatementString() - Method in class org.hibernate.sql.Delete

toStatementString() - Method in class org.hibernate.sql.Insert

toStatementString() - Method in class org.hibernate.sql.InsertSelect

toStatementString() - Method in class org.hibernate.sql.Select
Construct an SQL SELECT statement from the given clauses
toStatementString() - Method in class org.hibernate.sql.SimpleSelect

toStatementString() - Method in class org.hibernate.sql.Update

toString() - Method in class org.hibernate.CacheMode

toString() - Method in class org.hibernate.ConnectionReleaseMode
Override of Object.toString().
toString() - Method in class org.hibernate.EntityMode

toString() - Method in class org.hibernate.FetchMode

toString() - Method in class org.hibernate.FlushMode

toString() - Method in class org.hibernate.LockMode

toString() - Method in class org.hibernate.ReplicationMode

toString() - Method in class org.hibernate.ScrollMode

toString() - Method in class org.hibernate.action.CollectionAction

toString() - Method in class org.hibernate.action.DelayedPostInsertIdentifier

toString() - Method in class org.hibernate.action.EntityAction

toString() - Method in class org.hibernate.bytecode.javassist.FastClass

toString() - Method in class org.hibernate.cache.CacheKey

toString() - Method in class org.hibernate.cache.EhCache

toString() - Method in class org.hibernate.cache.FilterKey

toString() - Method in class org.hibernate.cache.HashtableCache

toString() - Method in class org.hibernate.cache.NonstrictReadWriteCache

toString() - Method in class org.hibernate.cache.OSCache

toString() - Method in class org.hibernate.cache.OptimisticTreeCache.DataVersionAdapter

toString() - Method in class org.hibernate.cache.OptimisticTreeCache

toString() - Method in class org.hibernate.cache.QueryKey

toString() - Method in class org.hibernate.cache.ReadOnlyCache

toString() - Method in class org.hibernate.cache.ReadWriteCache.Item

toString() - Method in class org.hibernate.cache.ReadWriteCache.Lock

toString() - Method in class org.hibernate.cache.ReadWriteCache

toString() - Method in class org.hibernate.cache.StandardQueryCache

toString() - Method in class org.hibernate.cache.SwarmCache

toString() - Method in class org.hibernate.cache.TransactionalCache

toString() - Method in class org.hibernate.cache.TreeCache

toString() - Method in class org.hibernate.cache.UpdateTimestampsCache

toString() - Method in class org.hibernate.cache.entry.CacheEntry

toString() - Method in class org.hibernate.cache.entry.CollectionCacheEntry

toString() - Method in class org.hibernate.collection.PersistentBag

toString() - Method in class org.hibernate.collection.PersistentList

toString() - Method in class org.hibernate.collection.PersistentMap

toString() - Method in class org.hibernate.collection.PersistentSet

toString() - Method in class org.hibernate.criterion.AbstractEmptinessExpression

toString() - Method in class org.hibernate.criterion.AggregateProjection

toString() - Method in class org.hibernate.criterion.AliasedProjection

toString() - Method in class org.hibernate.criterion.BetweenExpression

toString() - Method in class org.hibernate.criterion.CountProjection

toString() - Method in class org.hibernate.criterion.DetachedCriteria

toString() - Method in class org.hibernate.criterion.Distinct

toString() - Method in class org.hibernate.criterion.Example

toString() - Method in class org.hibernate.criterion.IdentifierEqExpression

toString() - Method in class org.hibernate.criterion.IdentifierProjection

toString() - Method in class org.hibernate.criterion.IlikeExpression

toString() - Method in class org.hibernate.criterion.InExpression

toString() - Method in class org.hibernate.criterion.Junction

toString() - Method in class org.hibernate.criterion.LogicalExpression

toString() - Method in class org.hibernate.criterion.MatchMode

toString() - Method in class org.hibernate.criterion.NotExpression

toString() - Method in class org.hibernate.criterion.NotNullExpression

toString() - Method in class org.hibernate.criterion.NullExpression

toString() - Method in class org.hibernate.criterion.Order

toString() - Method in class org.hibernate.criterion.ProjectionList

toString() - Method in class org.hibernate.criterion.PropertyExpression

toString() - Method in class org.hibernate.criterion.PropertyProjection

toString() - Method in class org.hibernate.criterion.RowCountProjection

toString() - Method in class org.hibernate.criterion.SQLCriterion

toString() - Method in class org.hibernate.criterion.SQLProjection

toString() - Method in class org.hibernate.criterion.SimpleExpression

toString() - Method in class org.hibernate.criterion.SizeExpression

toString() - Method in class org.hibernate.dialect.Dialect

toString() - Method in class org.hibernate.dialect.function.SQLFunctionTemplate

toString() - Method in class org.hibernate.dialect.function.StandardSQLFunction

toString() - Method in class org.hibernate.engine.ActionQueue
Returns a string representation of the object.
toString() - Method in class org.hibernate.engine.CascadeStyle.MultipleCascadeStyle

toString() - Method in class org.hibernate.engine.CollectionEntry

toString() - Method in class org.hibernate.engine.CollectionKey

toString() - Method in class org.hibernate.engine.EntityEntry

toString() - Method in class org.hibernate.engine.EntityKey

toString() - Method in class org.hibernate.engine.EntityUniqueKey

toString() - Method in class org.hibernate.engine.IdentifierValue

toString() - Method in class org.hibernate.engine.JoinSequence

toString() - Method in class org.hibernate.engine.NamedQueryDefinition

toString() - Method in interface org.hibernate.engine.PersistenceContext
Returns a string representation of the object.
toString() - Method in class org.hibernate.engine.StatefulPersistenceContext
Returns a string representation of the object.
toString() - Method in class org.hibernate.engine.Status

toString() - Method in class org.hibernate.engine.SubselectFetch

toString() - Method in class org.hibernate.engine.TypedValue

toString() - Method in class org.hibernate.engine.VersionValue

toString() - Method in class org.hibernate.event.LoadEventListener.LoadType

toString() - Method in class org.hibernate.hql.ast.DetailedSemanticException
Converts everything to a string.
toString() - Method in class org.hibernate.hql.ast.HqlToken
Returns a string representation of the object.
toString() - Method in class org.hibernate.hql.ast.tree.FromClause

toString() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

toString() - Method in class org.hibernate.impl.AbstractQueryImpl

toString() - Method in class org.hibernate.impl.CriteriaImpl.CriterionEntry

toString() - Method in class org.hibernate.impl.CriteriaImpl.OrderEntry

toString() - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

toString() - Method in class org.hibernate.impl.CriteriaImpl

toString() - Method in class org.hibernate.impl.SessionImpl

toString() - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

toString() - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

toString() - Method in class org.hibernate.loader.AbstractEntityJoinWalker

toString() - Method in class org.hibernate.loader.GeneratedCollectionAliases

toString() - Method in class org.hibernate.loader.Loader

toString() - Method in class org.hibernate.loader.collection.BasicCollectionJoinWalker

toString() - Method in class org.hibernate.loader.collection.CollectionLoader

toString() - Method in class org.hibernate.loader.collection.OneToManyJoinWalker

toString() - Method in class org.hibernate.loader.custom.ColumnCollectionAliases

toString() - Method in class org.hibernate.mapping.Collection

toString() - Method in class org.hibernate.mapping.Column

toString() - Method in class org.hibernate.mapping.Component

toString() - Method in class org.hibernate.mapping.Constraint

toString() - Method in class org.hibernate.mapping.ForeignKey

toString() - Method in class org.hibernate.mapping.Formula

toString() - Method in class org.hibernate.mapping.Index

toString() - Method in class org.hibernate.mapping.Join

toString() - Method in class org.hibernate.mapping.MetaAttribute

toString() - Method in class org.hibernate.mapping.PersistentClass

toString() - Method in class org.hibernate.mapping.Property

toString() - Method in class org.hibernate.mapping.PropertyGeneration

toString() - Method in class org.hibernate.mapping.SimpleValue

toString() - Method in class org.hibernate.mapping.Table

toString() - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

toString() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

toString(Object, EntityMode) - Method in class org.hibernate.pretty.Printer

toString(Type[], Object[]) - Method in class org.hibernate.pretty.Printer

toString(Map) - Method in class org.hibernate.pretty.Printer

toString(Iterator, EntityMode) - Method in class org.hibernate.pretty.Printer

toString() - Method in class org.hibernate.property.BasicPropertyAccessor.BasicGetter

toString() - Method in class org.hibernate.property.BasicPropertyAccessor.BasicSetter

toString() - Method in class org.hibernate.property.DirectPropertyAccessor.DirectGetter

toString() - Method in class org.hibernate.property.DirectPropertyAccessor.DirectSetter

toString() - Method in class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter

toString() - Method in class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedSetter

toString() - Method in class org.hibernate.secure.HibernatePermission

toString() - Method in class org.hibernate.stat.CollectionStatistics

toString() - Method in class org.hibernate.stat.EntityStatistics

toString() - Method in class org.hibernate.stat.QueryStatistics

toString() - Method in class org.hibernate.stat.SecondLevelCacheStatistics

toString() - Method in class org.hibernate.stat.SessionStatisticsImpl

toString() - Method in class org.hibernate.stat.StatisticsImpl

toString() - Method in class org.hibernate.tool.hbm2ddl.ColumnMetadata

toString() - Method in class org.hibernate.tool.hbm2ddl.DatabaseMetadata

toString() - Method in class org.hibernate.tool.hbm2ddl.ForeignKeyMetadata

toString() - Method in class org.hibernate.tool.hbm2ddl.IndexMetadata

toString() - Method in class org.hibernate.tool.hbm2ddl.TableMetadata

toString() - Method in class org.hibernate.transaction.CacheSynchronization

toString() - Method in class org.hibernate.tuple.ElementWrapper

toString() - Method in class org.hibernate.tuple.Property

toString() - Method in class org.hibernate.tuple.entity.AbstractEntityTuplizer

toString() - Method in class org.hibernate.tuple.entity.EntityMetamodel

toString(Object) - Method in class org.hibernate.type.AbstractBynaryType

toString(Object) - Method in class org.hibernate.type.AbstractCharArrayType

toString(Object) - Method in class org.hibernate.type.AdaptedImmutableType

toString(Object) - Method in class org.hibernate.type.BigDecimalType

toString(Object) - Method in class org.hibernate.type.BigIntegerType

toString(Object) - Method in class org.hibernate.type.CalendarDateType

toString(Object) - Method in class org.hibernate.type.CalendarType

toString(Object) - Method in class org.hibernate.type.ClassType

toString() - Method in class org.hibernate.type.CollectionType

toString(Object) - Method in class org.hibernate.type.CurrencyType

toString(Object) - Method in class org.hibernate.type.DateType

toString() - Method in class org.hibernate.type.EntityType

toString(Object) - Method in class org.hibernate.type.LocaleType

toString(Object) - Method in class org.hibernate.type.NullableType

toString(Object) - Method in class org.hibernate.type.PrimitiveType

toString(Object) - Method in class org.hibernate.type.SerializableType

toString(Object) - Method in class org.hibernate.type.StringType

toString(Object) - Method in class org.hibernate.type.TextType

toString(Object) - Method in class org.hibernate.type.TimeType

toString(Object) - Method in class org.hibernate.type.TimeZoneType

toString(Object) - Method in class org.hibernate.type.TimestampType

toString(Object[]) - Static method in class org.hibernate.util.ArrayHelper

toString() - Method in class org.hibernate.util.FastHashMap

toString() - Method in class org.hibernate.util.IdentityMap.IdentityKey

toString() - Method in class org.hibernate.util.IdentityMap

toString() - Method in class org.hibernate.util.MarkerObject

toString(Object[]) - Static method in class org.hibernate.util.StringHelper

toStringArray(Object[]) - Static method in class org.hibernate.util.ArrayHelper

toStringArray(Collection) - Static method in class org.hibernate.util.ArrayHelper

toStringArray(String, String, Properties) - Static method in class org.hibernate.util.PropertiesHelper

toStringArray(String, String) - Static method in class org.hibernate.util.PropertiesHelper

toSubselectString(String) - Method in class org.hibernate.engine.SubselectFetch

toType(String) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

toType(String) - Method in class org.hibernate.persister.collection.CollectionPropertyMapping

toType(String) - Method in class org.hibernate.persister.collection.ElementPropertyMapping

toType(String) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

toType(String) - Method in class org.hibernate.persister.entity.AbstractPropertyMapping

toType(String) - Method in interface org.hibernate.persister.entity.PropertyMapping
Given a component path expression, get the type of the property
toTypeArray(Collection) - Static method in class org.hibernate.util.ArrayHelper

toUnquotedAliasString(String) - Method in class org.hibernate.sql.Alias

toUnquotedAliasStrings(String[]) - Method in class org.hibernate.sql.Alias

toUpperCase(String) - Static method in class org.hibernate.util.StringHelper

toWhereClause() - Method in class org.hibernate.sql.SimpleSelect

toWhereFragmentString() - Method in class org.hibernate.sql.ANSIJoinFragment

toWhereFragmentString() - Method in class org.hibernate.sql.JoinFragment

toWhereFragmentString() - Method in class org.hibernate.sql.OracleJoinFragment

toWhereFragmentString() - Method in class org.hibernate.sql.QueryJoinFragment

toWhereFragmentString() - Method in class org.hibernate.sql.Sybase11JoinFragment

toXMLString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.CustomType

toXMLString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.MetaType

toXMLString(Object, SessionFactoryImplementor) - Method in class org.hibernate.type.NullableType

toXMLString(Object) - Method in interface org.hibernate.usertype.EnhancedUserType
Return a string representation of this value, as it should appear in an XML document
token(String, QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.ClauseParser

token(String, QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.FromParser

token(String, QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.GroupByParser

token(String, QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.OrderByParser

token(String, QueryTranslatorImpl) - Method in interface org.hibernate.hql.classic.Parser

token(String, QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.PathExpressionParser

token(String, QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.PreprocessingParser

token(String, QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.SelectParser

token(String, QueryTranslatorImpl) - Method in class org.hibernate.hql.classic.WhereParser

traceParameters(SessionFactoryImplementor) - Method in class org.hibernate.engine.QueryParameters

transactionContext - Variable in class org.hibernate.transaction.CMTTransaction

transform(ClassLoader, String, Class, ProtectionDomain, byte[]) - Method in class org.hibernate.bytecode.AbstractClassTransformerImpl

transform(ClassLoader, String, Class, ProtectionDomain, byte[]) - Method in interface org.hibernate.bytecode.ClassTransformer
Invoked when a class is being loaded or redefined to add hooks for persistence bytecode manipulation
transform(File) - Method in class org.hibernate.bytecode.javassist.FieldTransformer

transform(ClassFile) - Method in class org.hibernate.bytecode.javassist.FieldTransformer

transformList(List) - Method in class org.hibernate.transform.AliasToBeanConstructorResultTransformer

transformList(List) - Method in class org.hibernate.transform.AliasToBeanResultTransformer

transformList(List) - Method in class org.hibernate.transform.AliasToEntityMapResultTransformer

transformList(List) - Method in class org.hibernate.transform.DistinctRootEntityResultTransformer

transformList(List) - Method in class org.hibernate.transform.PassThroughResultTransformer

transformList(List) - Method in interface org.hibernate.transform.ResultTransformer

transformList(List) - Method in class org.hibernate.transform.RootEntityResultTransformer

transformList(List) - Method in class org.hibernate.transform.ToListResultTransformer

transformSelectString(String) - Method in class org.hibernate.dialect.Dialect

transformTuple(Object[], String[]) - Method in class org.hibernate.transform.AliasToBeanConstructorResultTransformer

transformTuple(Object[], String[]) - Method in class org.hibernate.transform.AliasToBeanResultTransformer

transformTuple(Object[], String[]) - Method in class org.hibernate.transform.AliasToEntityMapResultTransformer

transformTuple(Object[], String[]) - Method in class org.hibernate.transform.DistinctRootEntityResultTransformer

transformTuple(Object[], String[]) - Method in class org.hibernate.transform.PassThroughResultTransformer

transformTuple(Object[], String[]) - Method in interface org.hibernate.transform.ResultTransformer

transformTuple(Object[], String[]) - Method in class org.hibernate.transform.RootEntityResultTransformer

transformTuple(Object[], String[]) - Method in class org.hibernate.transform.ToListResultTransformer

traverseDepthFirst(AST) - Method in class org.hibernate.hql.ast.util.NodeTraverser
Traverse the AST tree depth first.
trimStackFrames(List) - Method in class org.hibernate.exception.NestableDelegate
Trims the stack frames.
truncate(long) - Method in class org.hibernate.lob.BlobImpl

truncate(long) - Method in class org.hibernate.lob.ClobImpl

truncate(long) - Method in class org.hibernate.lob.SerializableBlob

truncate(long) - Method in class org.hibernate.lob.SerializableClob

truncate(String, int) - Static method in class org.hibernate.util.StringHelper

tuplizerMapping - Variable in class org.hibernate.type.ComponentType

typeArray() - Method in class org.hibernate.impl.AbstractQueryImpl

typeArray() - Method in class org.hibernate.impl.CollectionFilterImpl

typeDefs - Variable in class org.hibernate.cfg.Configuration

typeDefs - Variable in class org.hibernate.cfg.Mappings

typecast(Object[], Object[]) - Static method in class org.hibernate.util.ArrayHelper

types - Variable in class org.hibernate.bytecode.javassist.BulkAccessor

U

UNARY_MINUS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

UNARY_MINUS - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

UNARY_MINUS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

UNARY_PLUS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

UNARY_PLUS - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

UNARY_PLUS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

UNDEFINED - Static variable in class org.hibernate.engine.IdentifierValue
Assume nothing.
UNDEFINED - Static variable in class org.hibernate.engine.VersionValue
Assume the transient instance is newly instantiated if the version is null, otherwise defer to the identifier unsaved-value.
UNFETCHED_COLLECTION - Static variable in class org.hibernate.type.CollectionType

UNFETCHED_PROPERTY - Static variable in interface org.hibernate.intercept.LazyPropertyInitializer
Marker value for uninitialized properties
UNION - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

UNION - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

UNION - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

UNKNOWN - Static variable in class org.hibernate.collection.AbstractPersistentCollection

UNKNOWN - Static variable in class org.hibernate.property.BackrefPropertyAccessor
A placeholder for a property value, indicating that we don't know the value of the back reference
UPDATE - Static variable in class org.hibernate.engine.CascadeStyle
save / update
UPDATE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

UPDATE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

UPDATE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

UPDATE - Static variable in class org.hibernate.secure.HibernatePermission

UPGRADE - Static variable in class org.hibernate.LockMode
An upgrade lock.
UPGRADE_NOWAIT - Static variable in class org.hibernate.LockMode
Attempt to obtain an upgrade lock, using an Oracle-style select for update nowait.
URL - Static variable in class org.hibernate.cfg.Environment
JDBC URL
USER - Static variable in class org.hibernate.cfg.Environment
JDBC user
USER_TRANSACTION - Static variable in class org.hibernate.cfg.Environment
JNDI name of JTA UserTransaction object
USE_GET_GENERATED_KEYS - Static variable in class org.hibernate.cfg.Environment
Tells the JDBC driver to attempt to retrieve row Id with the JDBC 3.0 PreparedStatement.getGeneratedKeys() method.
USE_IDENTIFIER_ROLLBACK - Static variable in class org.hibernate.cfg.Environment

USE_MINIMAL_PUTS - Static variable in class org.hibernate.cfg.Environment
Optimize the cache for mimimal puts instead of minimal gets
USE_QUERY_CACHE - Static variable in class org.hibernate.cfg.Environment
Enable the query cache (disabled by default)
USE_REFLECTION_OPTIMIZER - Static variable in class org.hibernate.cfg.Environment
Use bytecode libraries optimized property access
USE_SCROLLABLE_RESULTSET - Static variable in class org.hibernate.cfg.Environment
Use JDBC scrollable ResultSets.
USE_SECOND_LEVEL_CACHE - Static variable in class org.hibernate.cfg.Environment
Enable the second-level cache (enabled by default)
USE_SQL_COMMENTS - Static variable in class org.hibernate.cfg.Environment
Add comments to the generated SQL
USE_STREAMS_FOR_BINARY - Static variable in class org.hibernate.cfg.Environment
Use java.io streams to read / write binary data from / to JDBC
USE_STRUCTURED_CACHE - Static variable in class org.hibernate.cfg.Environment
Enable use of structured second-level cache entries
USUAL_EXPECTED_COUNT - Static variable in class org.hibernate.jdbc.Expectations

USUAL_PARAM_POSITION - Static variable in class org.hibernate.jdbc.Expectations

UUIDHexGenerator - class org.hibernate.id.UUIDHexGenerator.
uuid

A UUIDGenerator that returns a string of length 32, This string will consist of only hex digits.
UUIDHexGenerator() - Constructor for class org.hibernate.id.UUIDHexGenerator

UnaryArithmeticNode - class org.hibernate.hql.ast.tree.UnaryArithmeticNode.

UnaryArithmeticNode() - Constructor for class org.hibernate.hql.ast.tree.UnaryArithmeticNode

UnaryLogicOperatorNode - class org.hibernate.hql.ast.tree.UnaryLogicOperatorNode.

UnaryLogicOperatorNode() - Constructor for class org.hibernate.hql.ast.tree.UnaryLogicOperatorNode

UnaryOperatorNode - interface org.hibernate.hql.ast.tree.UnaryOperatorNode.
Contract for nodes representing unary operators.
UnionSubclass - class org.hibernate.mapping.UnionSubclass.
A subclass in a table-per-concrete-class mapping
UnionSubclass(PersistentClass) - Constructor for class org.hibernate.mapping.UnionSubclass

UnionSubclassEntityPersister - class org.hibernate.persister.entity.UnionSubclassEntityPersister.
Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.
UnionSubclassEntityPersister(PersistentClass, CacheConcurrencyStrategy, SessionFactoryImplementor, Mapping) - Constructor for class org.hibernate.persister.entity.UnionSubclassEntityPersister

UniqueEntityLoader - interface org.hibernate.loader.entity.UniqueEntityLoader.
Loads entities for a EntityPersister
UniqueKey - class org.hibernate.mapping.UniqueKey.
A relational unique key constraint
UniqueKey() - Constructor for class org.hibernate.mapping.UniqueKey

UniqueKeyLoadable - interface org.hibernate.persister.entity.UniqueKeyLoadable.

UnresolvableObjectException - exception org.hibernate.UnresolvableObjectException.
Thrown when Hibernate could not resolve an object by id, especially when loading an association.
UnresolvableObjectException(Serializable, String) - Constructor for class org.hibernate.UnresolvableObjectException

UnsavedValueFactory - class org.hibernate.engine.UnsavedValueFactory.

UnsavedValueFactory() - Constructor for class org.hibernate.engine.UnsavedValueFactory

UnstructuredCacheEntry - class org.hibernate.cache.entry.UnstructuredCacheEntry.

UnstructuredCacheEntry() - Constructor for class org.hibernate.cache.entry.UnstructuredCacheEntry

Update - class org.hibernate.sql.Update.
An SQL UPDATE statement
Update(Dialect) - Constructor for class org.hibernate.sql.Update

UpdateLockingStrategy - class org.hibernate.dialect.lock.UpdateLockingStrategy.
A locking strategy where the locks are obtained through update statements.
UpdateLockingStrategy(Lockable, LockMode) - Constructor for class org.hibernate.dialect.lock.UpdateLockingStrategy
Construct a locking strategy based on SQL UPDATE statements.
UpdateStatement - class org.hibernate.hql.ast.tree.UpdateStatement.
Defines a top-level AST node representing an HQL update statement.
UpdateStatement() - Constructor for class org.hibernate.hql.ast.tree.UpdateStatement

UpdateTimestampsCache - class org.hibernate.cache.UpdateTimestampsCache.
Tracks the timestamps of the most recent updates to particular tables.
UpdateTimestampsCache(Settings, Properties) - Constructor for class org.hibernate.cache.UpdateTimestampsCache

UserCollectionType - interface org.hibernate.usertype.UserCollectionType.
A custom type for mapping user-written classes that implement PersistentCollection
UserSuppliedConnectionProvider - class org.hibernate.connection.UserSuppliedConnectionProvider.
An implementation of the ConnectionProvider interface that simply throws an exception when a connection is requested.
UserSuppliedConnectionProvider() - Constructor for class org.hibernate.connection.UserSuppliedConnectionProvider

UserType - interface org.hibernate.usertype.UserType.
This interface should be implemented by user-defined "types".
UserVersionType - interface org.hibernate.usertype.UserVersionType.
A user type that may be used for a version property
unaryExpression() - Method in class org.hibernate.hql.antlr.HqlBaseParser

unbind(SessionFactory) - Static method in class org.hibernate.context.ManagedSessionContext
Unbinds the session (if one) current associated with the context for the given session.
unbind(SessionFactory) - Static method in class org.hibernate.context.ThreadLocalSessionContext
Unassociate a previously bound session from the current thread of execution.
union() - Method in class org.hibernate.hql.antlr.HqlBaseParser

uniqueColumnString(Iterator) - Method in class org.hibernate.mapping.Table

uniqueColumnString(Iterator, String) - Method in class org.hibernate.mapping.Table

uniqueKeyPropertyName - Variable in class org.hibernate.type.EntityType

uniqueKeyType - Variable in class org.hibernate.loader.entity.AbstractEntityLoader

uniqueResult() - Method in interface org.hibernate.Criteria
Convenience method to return a single instance that matches the query, or null if the query returns no results.
uniqueResult() - Method in interface org.hibernate.Query
Convenience method to return a single instance that matches the query, or null if the query returns no results.
uniqueResult() - Method in class org.hibernate.impl.AbstractQueryImpl

uniqueResult() - Method in class org.hibernate.impl.CriteriaImpl.Subcriteria

uniqueResult() - Method in class org.hibernate.impl.CriteriaImpl

unlock(Object) - Method in interface org.hibernate.cache.Cache
If this is a clustered cache, unlock the item
unlock(Object) - Method in class org.hibernate.cache.EhCache
Calls to this method should perform there own synchronization.
unlock(Object) - Method in class org.hibernate.cache.HashtableCache

unlock(Object) - Method in class org.hibernate.cache.OSCache

unlock(Object) - Method in class org.hibernate.cache.OptimisticTreeCache

unlock(long) - Method in class org.hibernate.cache.ReadWriteCache.Lock
Decrement the lock, setting the unlock timestamp if now unlocked
unlock(Object) - Method in class org.hibernate.cache.SwarmCache
If this is a clustered cache, unlock the item
unlock(Object) - Method in class org.hibernate.cache.TreeCache

unproxy(Object) - Method in interface org.hibernate.engine.PersistenceContext
Get the entity instance underlying the given proxy, throwing an exception if the proxy is uninitialized.
unproxy(Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Get the entity instance underlying the given proxy, throwing an exception if the proxy is uninitialized.
unproxyAndReassociate(Object) - Method in interface org.hibernate.engine.PersistenceContext
Possibly unproxy the given reference and reassociate it with the current session.
unproxyAndReassociate(Object) - Method in class org.hibernate.engine.StatefulPersistenceContext
Possibly unproxy the given reference and reassociate it with the current session.
unqualify(String) - Static method in class org.hibernate.util.StringHelper

unqualifyEntityName(String) - Static method in class org.hibernate.util.StringHelper

unroot(String) - Static method in class org.hibernate.util.StringHelper

unsetSession(SessionImplementor) - Method in class org.hibernate.collection.AbstractPersistentCollection
Disassociate this collection from the given session.
unsetSession(SessionImplementor) - Method in interface org.hibernate.collection.PersistentCollection
Disassociate this collection from the given session.
unsetTransactionTimeout() - Method in class org.hibernate.jdbc.AbstractBatcher

unsetTransactionTimeout() - Method in interface org.hibernate.jdbc.Batcher
Unset the transaction timeout, called after the end of a transaction.
unwrapProxy - Variable in class org.hibernate.mapping.ToOne

update(Object) - Method in interface org.hibernate.Session
Update the persistent instance with the identifier of the given detached instance.
update(String, Object) - Method in interface org.hibernate.Session
Update the persistent instance with the identifier of the given detached instance.
update(Object) - Method in interface org.hibernate.StatelessSession
Update a row.
update(String, Object) - Method in interface org.hibernate.StatelessSession
Update a row.
update(Object, Object) - Method in interface org.hibernate.cache.Cache
Add an item to the cache
update(Object, Object, Object, Object) - Method in interface org.hibernate.cache.CacheConcurrencyStrategy
Called after an item has been updated (before the transaction completes), instead of calling evict().
update(Object, Object) - Method in class org.hibernate.cache.EhCache
Puts an object into the cache.
update(Object, Object) - Method in class org.hibernate.cache.HashtableCache

update(Object, Object, Object, Object) - Method in class org.hibernate.cache.NonstrictReadWriteCache
Do nothing.
update(Object, Object) - Method in class org.hibernate.cache.OSCache

update(Object, Object) - Method in class org.hibernate.cache.OptimisticTreeCache

update(Object, Object, Object, Object) - Method in class org.hibernate.cache.ReadOnlyCache
Unsupported!
update(Object, Object, Object, Object) - Method in class org.hibernate.cache.ReadWriteCache
Do nothing.
update(Object, Object) - Method in class org.hibernate.cache.SwarmCache
Add an item to the cache
update(Object, Object, Object, Object) - Method in class org.hibernate.cache.TransactionalCache

update(Object, Object) - Method in class org.hibernate.cache.TreeCache

update(Object, Serializable) - Method in interface org.hibernate.classic.Session
Deprecated. declare identifier properties for all classes
update(String, Object, Serializable) - Method in interface org.hibernate.classic.Session
Deprecated. declare identifier properties for all classes
update(Object) - Method in class org.hibernate.impl.SessionImpl

update(Object, Serializable) - Method in class org.hibernate.impl.SessionImpl

update(String, Object) - Method in class org.hibernate.impl.SessionImpl

update(String, Object, Serializable) - Method in class org.hibernate.impl.SessionImpl

update(Object) - Method in class org.hibernate.impl.StatelessSessionImpl

update(String, Object) - Method in class org.hibernate.impl.StatelessSessionImpl

update(Serializable, Object[], Object[], Object, boolean[], int, Object, Object, String, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

update(Serializable, Object[], int[], boolean, Object[], Object, Object, Object, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Update an object
update(Serializable, Object[], int[], boolean, Object[], Object, Object, Object, SessionImplementor) - Method in interface org.hibernate.persister.entity.EntityPersister
Update a persistent instance
updateArray(String, Array) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateArray(int, Array) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateAsciiStream(String, InputStream, int) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateAsciiStream(int, InputStream, int) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateBigDecimal(String, BigDecimal) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateBigDecimal(int, BigDecimal) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateBinaryStream(String, InputStream, int) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateBinaryStream(int, InputStream, int) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateBlob(String, Blob) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateBlob(int, Blob) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateBoolean(String, boolean) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateBoolean(int, boolean) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateByte(String, byte) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateByte(int, byte) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateBytes(String, byte[]) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateBytes(int, byte[]) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateCallable - Variable in class org.hibernate.persister.entity.AbstractEntityPersister

updateCharacterStream(String, Reader, int) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateCharacterStream(int, Reader, int) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateClob(String, Clob) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateClob(int, Clob) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateCollection(String) - Method in class org.hibernate.stat.StatisticsImpl

updateCollection(String) - Method in interface org.hibernate.stat.StatisticsImplementor

updateCurrentIterator() - Method in class org.hibernate.util.JoinedIterator

updateDate(String, Date) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateDate(int, Date) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateDouble(String, double) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateDouble(int, double) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateEntity(String) - Method in class org.hibernate.stat.StatisticsImpl

updateEntity(String) - Method in interface org.hibernate.stat.StatisticsImplementor

updateFloat(String, float) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateFloat(int, float) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateInt(String, int) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateInt(int, int) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateLong(String, long) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateLong(int, long) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateNull(String) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateNull(int) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateObject(String, Object) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateObject(String, Object, int) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateObject(int, Object) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateObject(int, Object, int) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateOrInsert(Serializable, Object[], Object[], Object, boolean[], int, Object, Object, String, SessionImplementor) - Method in class org.hibernate.persister.entity.AbstractEntityPersister
Perform an SQL UPDATE or SQL INSERT
updateRef(String, Ref) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateRef(int, Ref) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateResultCheckStyles - Variable in class org.hibernate.persister.entity.AbstractEntityPersister

updateRow() - Method in class org.hibernate.jdbc.ResultSetWrapper

updateRows(PersistentCollection, Serializable, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister

updateRows(PersistentCollection, Serializable, SessionImplementor) - Method in interface org.hibernate.persister.collection.CollectionPersister
Update the persistent state of any elements that were modified
updateShort(String, short) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateShort(int, short) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateStatement() - Method in class org.hibernate.hql.antlr.HqlBaseParser

updateStatement(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

updateStatement(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

updateString(String, String) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateString(int, String) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateTime(String, Time) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateTime(int, Time) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateTimestamp(String, Timestamp) - Method in class org.hibernate.jdbc.ResultSetWrapper

updateTimestamp(int, Timestamp) - Method in class org.hibernate.jdbc.ResultSetWrapper

upgradeLock(Object, EntityEntry, LockMode, SessionImplementor) - Method in class org.hibernate.event.def.AbstractLockUpgradeEventListener
Performs a pessimistic lock upgrade on a given entity, if needed.
upgradeLocks() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

upgradeLocks() - Method in class org.hibernate.loader.Loader
Does this query return objects that might be already cached by the session, whose lock mode may need upgrading
upgradeLocks() - Method in class org.hibernate.loader.hql.QueryLoader

useDynamicInsert() - Method in class org.hibernate.mapping.PersistentClass

useDynamicInsert() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

useDynamicUpdate() - Method in class org.hibernate.mapping.PersistentClass

useDynamicUpdate() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

useFromFragment() - Method in class org.hibernate.hql.ast.tree.FromElement
Returns true if the from fragment should be included in the from clause.
useGetGeneratedKeys() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

useInputStreamToInsertBlob() - Method in class org.hibernate.dialect.Dialect

useInputStreamToInsertBlob() - Method in class org.hibernate.dialect.PostgreSQLDialect

useInsertSelectIdentity() - Method in class org.hibernate.persister.entity.AbstractEntityPersister

useLHSPrimaryKey() - Method in class org.hibernate.type.AnyType

useLHSPrimaryKey() - Method in interface org.hibernate.type.AssociationType
Is the primary key of the owning entity table to be used in the join?
useLHSPrimaryKey() - Method in class org.hibernate.type.CollectionType

useLHSPrimaryKey() - Method in class org.hibernate.type.ManyToOneType

useLHSPrimaryKey() - Method in class org.hibernate.type.OneToOneType

useLHSPrimaryKey() - Method in class org.hibernate.type.SpecialOneToOneType

useMaxForLimit() - Method in class org.hibernate.dialect.DB2390Dialect

useMaxForLimit() - Method in class org.hibernate.dialect.DB2400Dialect

useMaxForLimit() - Method in class org.hibernate.dialect.DB2Dialect

useMaxForLimit() - Method in class org.hibernate.dialect.Dialect
Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?
useMaxForLimit() - Method in class org.hibernate.dialect.InformixDialect

useMaxForLimit() - Method in class org.hibernate.dialect.IngresDialect
Does the LIMIT clause take a "maximum" row number instead of a total number of returned rows?
useMaxForLimit() - Method in class org.hibernate.dialect.Oracle9Dialect

useMaxForLimit() - Method in class org.hibernate.dialect.SQLServerDialect

useMaxForLimit() - Method in class org.hibernate.dialect.TimesTenDialect

useReflectionOptimizer() - Static method in class org.hibernate.cfg.Environment
Should we use CGLIB reflection optimizer.
useStreamsForBinary() - Static method in class org.hibernate.cfg.Environment
Should we use streams to bind binary types to JDBC IN parameters.
useThetaStyleImplicitJoins - Static variable in class org.hibernate.hql.ast.tree.DotNode
Used ONLY for regression testing!
useUnownedCollection(CollectionKey) - Method in interface org.hibernate.engine.PersistenceContext
Get and remove a collection whose owner is not yet loaded, when its owner is being loaded
useUnownedCollection(CollectionKey) - Method in class org.hibernate.engine.StatefulPersistenceContext

useWhereFragment() - Method in class org.hibernate.hql.ast.tree.FromElement

utName - Variable in class org.hibernate.transaction.JTATransactionFactory

V

VALUE_COLUMN_NAME - Static variable in class org.hibernate.id.MultipleHiLoPerTableGenerator

VECTOR_EXPR - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

VECTOR_EXPR - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

VECTOR_EXPR - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

VERSION - Static variable in class org.hibernate.cfg.Environment

VERSION2_SQL - Static variable in class org.hibernate.hql.ast.tree.SelectClause

VERSIONED - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

VERSIONED - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

VERSIONED - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

VETO - Static variable in interface org.hibernate.classic.Lifecycle
Return value to veto the action (true)
Validatable - interface org.hibernate.classic.Validatable.
Implemented by persistent classes with invariants that must be checked before inserting into or updating the database.
ValidationFailure - exception org.hibernate.classic.ValidationFailure.
Thrown from Validatable.validate() when an invariant was violated.
ValidationFailure(String) - Constructor for class org.hibernate.classic.ValidationFailure

ValidationFailure(String, Exception) - Constructor for class org.hibernate.classic.ValidationFailure

ValidationFailure(Exception) - Constructor for class org.hibernate.classic.ValidationFailure

Value - interface org.hibernate.mapping.Value.
A value is anything that is persisted by value, instead of by reference.
ValueVisitor - interface org.hibernate.mapping.ValueVisitor.

VarArgsSQLFunction - class org.hibernate.dialect.function.VarArgsSQLFunction.
Support for slightly more general templating than StandardSQLFunction, with an unlimited number of arguments.
VarArgsSQLFunction(Type, String, String, String) - Constructor for class org.hibernate.dialect.function.VarArgsSQLFunction

VarArgsSQLFunction(String, String, String) - Constructor for class org.hibernate.dialect.function.VarArgsSQLFunction

VersionProperty - class org.hibernate.tuple.VersionProperty.
Represents a version property within the Hibernate runtime-metamodel.
VersionProperty(String, String, Type, boolean, boolean, boolean, boolean, boolean, boolean, boolean, boolean, CascadeStyle, VersionValue) - Constructor for class org.hibernate.tuple.VersionProperty
Constructs VersionProperty instances.
VersionType - interface org.hibernate.type.VersionType.
A Type that may be used to version data.
VersionTypeSeedParameterSpecification - class org.hibernate.param.VersionTypeSeedParameterSpecification.
Implementation of VersionTypeSeedParameterSpecification.
VersionTypeSeedParameterSpecification(VersionType) - Constructor for class org.hibernate.param.VersionTypeSeedParameterSpecification

VersionValue - class org.hibernate.engine.VersionValue.
A strategy for determining if a version value is an version of a new transient instance or a previously persistent transient instance.
VersionValue() - Constructor for class org.hibernate.engine.VersionValue

VersionValue(Object) - Constructor for class org.hibernate.engine.VersionValue
Assume the transient instance is newly instantiated if its version is null or equal to value
Versioning - class org.hibernate.engine.Versioning.
Utility methods for managing versions and timestamps
ViolatedConstraintNameExtracter - interface org.hibernate.exception.ViolatedConstraintNameExtracter.
Defines a contract for implementations that can extract the name of a violated constraint from a SQLException that is the result of that constraint violation.
validate() - Method in interface org.hibernate.Filter
Perform validation of the filter state.
validate() - Method in interface org.hibernate.classic.Validatable
Validate the state of the object before persisting it.
validate(Object, EntityPersister, EventSource) - Method in class org.hibernate.event.def.AbstractSaveEventListener

validate(Object, EntityPersister, Status, EntityMode) - Method in class org.hibernate.event.def.DefaultFlushEntityEventListener

validate() - Method in class org.hibernate.hql.ast.tree.InsertStatement
Performs detailed semantic validation on this insert statement tree.
validate() - Method in class org.hibernate.impl.FilterImpl
Perform validation of the filter state.
validate(Mapping) - Method in class org.hibernate.mapping.Collection

validate(Mapping) - Method in class org.hibernate.mapping.IdentifierCollection

validate(Mapping) - Method in class org.hibernate.mapping.IndexedCollection

validate(Mapping) - Method in class org.hibernate.mapping.JoinedSubclass

validate(Mapping) - Method in class org.hibernate.mapping.PersistentClass

validate(Mapping) - Method in class org.hibernate.mapping.RootClass

validate(Mapping) - Method in class org.hibernate.mapping.Set

validate(Mapping) - Method in class org.hibernate.mapping.SingleTableSubclass

validate(Mapping) - Method in class org.hibernate.mapping.UnionSubclass

validate() - Method in class org.hibernate.tool.hbm2ddl.SchemaValidator
Perform the validations.
validate() - Method in class org.hibernate.util.Cloneable
Checks to ensure the SessionEventListenerConfig is fully configured (basically, that none of the listeners is null).
validateColumns(Dialect, Mapping, TableMetadata) - Method in class org.hibernate.mapping.Table

validateJoin(String) - Method in class org.hibernate.loader.OuterJoinableAssociation

validateParameters() - Method in class org.hibernate.engine.QueryParameters

validateSchema(Dialect, DatabaseMetadata) - Method in class org.hibernate.cfg.Configuration

validateScrollability() - Method in interface org.hibernate.hql.QueryTranslator
Validate the scrollability of the translated query.
validateScrollability() - Method in class org.hibernate.hql.ast.QueryTranslatorImpl

validateScrollability() - Method in class org.hibernate.hql.classic.QueryTranslatorImpl

validateScrollability() - Method in class org.hibernate.loader.hql.QueryLoader

validateTypes(SelectClause) - Method in class org.hibernate.hql.ast.tree.IntoClause

valueArray() - Method in class org.hibernate.impl.AbstractQueryImpl

valueArray() - Method in class org.hibernate.impl.CollectionFilterImpl

valueOf(String) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

valueOf(String) - Method in class org.hibernate.tuple.ElementWrapper

values - Variable in class org.hibernate.collection.PersistentIdentifierBag

values() - Method in class org.hibernate.collection.PersistentMap

values() - Method in class org.hibernate.proxy.map.MapProxy

values() - Method in class org.hibernate.util.FastHashMap
Return a collection view of the values contained in this map.
values() - Method in class org.hibernate.util.IdentityMap

vectorExpr() - Method in class org.hibernate.hql.antlr.HqlBaseParser

verbose(String) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask.Logger

verifyOutcome(int, PreparedStatement, int) - Method in interface org.hibernate.jdbc.Expectation

verifyOutcome(int, PreparedStatement, int) - Method in class org.hibernate.jdbc.Expectations.BasicExpectation

verifyParameters() - Method in class org.hibernate.impl.AbstractQueryImpl
Perform parameter validation.
verifyParameters(boolean) - Method in class org.hibernate.impl.AbstractQueryImpl
Perform parameter validation.
verifyParameters() - Method in class org.hibernate.impl.SQLQueryImpl

verifyProperties(Properties) - Static method in class org.hibernate.cfg.Environment
Issues warnings to the user when any obsolete property names are used.
visit(AST) - Method in class org.hibernate.hql.ast.QueryTranslatorImpl.JavaConstantConverter

visit(AST) - Method in interface org.hibernate.hql.ast.util.NodeTraverser.VisitationStrategy

visitCollectionsBeforeSave(Serializable, Object[], Type[], EventSource) - Method in class org.hibernate.event.def.AbstractSaveEventListener

visitCollectionsBeforeSave(Serializable, Object[], Type[], EventSource) - Method in class org.hibernate.event.def.DefaultReplicateEventListener

W

WEIRD_IDENT - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

WEIRD_IDENT - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

WEIRD_IDENT - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

WHEN - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

WHEN - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

WHEN - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

WHERE - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

WHERE - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

WHERE - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

WHITESPACE - Static variable in class org.hibernate.util.StringHelper

WITH - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

WITH - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

WITH - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

WRAPPER_BINARY - Static variable in class org.hibernate.Hibernate
Hibernate wrapper-binary type.
WRAP_RESULT_SETS - Static variable in class org.hibernate.cfg.Environment
Enable wrapping of JDBC result sets in order to speed up column name lookups for broken JDBC drivers
WRITE - Static variable in class org.hibernate.LockMode
A WRITE lock is obtained when an object is updated or inserted.
WS - Static variable in interface org.hibernate.hql.antlr.HqlSqlTokenTypes

WS - Static variable in interface org.hibernate.hql.antlr.HqlTokenTypes

WS - Static variable in interface org.hibernate.hql.antlr.SqlTokenTypes

WebSphereExtendedJTATransactionLookup - class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.
Support for proprietary interfaces for registering synchronizations in WebSphere 6.
WebSphereExtendedJTATransactionLookup() - Constructor for class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup

WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter - class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.

WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter - class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter.

WebSphereTransactionManagerLookup - class org.hibernate.transaction.WebSphereTransactionManagerLookup.
TransactionManager lookup strategy for WebSphere (versions 4, 5.0 and 5.1)
WebSphereTransactionManagerLookup() - Constructor for class org.hibernate.transaction.WebSphereTransactionManagerLookup

WeblogicTransactionManagerLookup - class org.hibernate.transaction.WeblogicTransactionManagerLookup.
TransactionManager lookup strategy for WebLogic
WeblogicTransactionManagerLookup() - Constructor for class org.hibernate.transaction.WeblogicTransactionManagerLookup

WhereParser - class org.hibernate.hql.classic.WhereParser.
Parses the where clause of a hibernate query and translates it to an SQL where clause.
WhereParser() - Constructor for class org.hibernate.hql.classic.WhereParser

WrapVisitor - class org.hibernate.event.def.WrapVisitor.
Wrap collections in a Hibernate collection wrapper.
WrapperBinaryType - class org.hibernate.type.WrapperBinaryType.

WrapperBinaryType() - Constructor for class org.hibernate.type.WrapperBinaryType

WrongClassException - exception org.hibernate.WrongClassException.
Thrown when Session.load() selects a row with the given primary key (identifier value) but the row's discriminator value specifies a subclass that is not assignable to the class requested by the user.
WrongClassException(String, Serializable, String) - Constructor for class org.hibernate.WrongClassException

walkCollectionTree(QueryableCollection, String) - Method in class org.hibernate.loader.JoinWalker
For a collection role, return a list of associations to be fetched by outerjoin
walkEntityTree(OuterJoinLoadable, String) - Method in class org.hibernate.loader.JoinWalker
For an entity class, return a list of associations to be fetched by outerjoin
warn(String) - Method in class org.hibernate.tool.instrument.BasicInstrumentationTask.Logger

warning(SAXParseException) - Method in class org.hibernate.util.XMLHelper.ErrorLogger

wasCommitted() - Method in interface org.hibernate.Transaction
Check if this transaction was successfully committed.
wasCommitted() - Method in class org.hibernate.transaction.CMTTransaction

wasCommitted() - Method in class org.hibernate.transaction.JDBCTransaction

wasCommitted() - Method in class org.hibernate.transaction.JTATransaction

wasDereferenced() - Method in class org.hibernate.engine.CollectionEntry

wasInitialized() - Method in class org.hibernate.collection.AbstractPersistentCollection
Is this instance initialized?
wasInitialized() - Method in interface org.hibernate.collection.PersistentCollection
Is this instance initialized?
wasLockedConcurrently() - Method in class org.hibernate.cache.ReadWriteCache.Lock
Was this lock held concurrently by multiple transactions?
wasNull() - Method in class org.hibernate.jdbc.ResultSetWrapper

wasRolledBack() - Method in interface org.hibernate.Transaction
Was this transaction rolled back or set to rollback only?
This only accounts for actions initiated from this local transaction.
wasRolledBack() - Method in class org.hibernate.transaction.CMTTransaction

wasRolledBack() - Method in class org.hibernate.transaction.JDBCTransaction

wasRolledBack() - Method in class org.hibernate.transaction.JTATransaction

weakKeywords() - Method in class org.hibernate.hql.antlr.HqlBaseParser

weakKeywords() - Method in class org.hibernate.hql.ast.HqlParser

whenClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

whereClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

whereClause(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

whereClause(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

whereClauseExpr(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

whereExpr(AST) - Method in class org.hibernate.hql.antlr.SqlGeneratorBase

whereJoinFragment(String, boolean, boolean) - Method in class org.hibernate.persister.collection.BasicCollectionPersister

whereJoinFragment(String, boolean, boolean) - Method in class org.hibernate.persister.collection.OneToManyPersister

whereJoinFragment(String, boolean, boolean) - Method in class org.hibernate.persister.entity.AbstractEntityPersister

whereJoinFragment(String, boolean, boolean) - Method in interface org.hibernate.persister.entity.Joinable
Get the where clause part of any joins (optional operation)
whereString(String, String[], int) - Method in class org.hibernate.loader.JoinWalker
Render the where condition for a (batch) load by identifier / collection key
whereString(String, String[], String, int) - Method in class org.hibernate.loader.collection.CollectionJoinWalker

withClause() - Method in class org.hibernate.hql.antlr.HqlBaseParser

withClause(AST) - Method in class org.hibernate.hql.antlr.HqlSqlBaseWalker

wrap(Session) - Method in class org.hibernate.context.ThreadLocalSessionContext

wrap(SessionImplementor, Object) - Method in class org.hibernate.type.ArrayType

wrap(SessionImplementor, Object) - Method in class org.hibernate.type.BagType

wrap(SessionImplementor, Object) - Method in class org.hibernate.type.CollectionType
Wrap the naked collection instance in a wrapper, or instantiate a holder.
wrap(SessionImplementor, Object) - Method in class org.hibernate.type.CustomCollectionType

wrap(SessionImplementor, Object) - Method in class org.hibernate.type.IdentifierBagType

wrap(SessionImplementor, Object) - Method in class org.hibernate.type.ListType

wrap(SessionImplementor, Object) - Method in class org.hibernate.type.MapType

wrap(SessionImplementor, Object) - Method in class org.hibernate.type.SetType

wrap(SessionImplementor, Object) - Method in class org.hibernate.type.SortedMapType

wrap(SessionImplementor, Object) - Method in class org.hibernate.type.SortedSetType

wrap(SessionImplementor, Object) - Method in interface org.hibernate.usertype.UserCollectionType
Wrap an instance of a collection
write() - Method in class org.hibernate.collection.AbstractPersistentCollection
Called by any writer method of the collection interface
write(Writer) - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

write(Writer) - Method in class org.hibernate.tuple.ElementWrapper

writeBoolean(Object, String, boolean, boolean) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

writeBoolean(Object, String, boolean, boolean) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

writeBoolean(Object, String, boolean, boolean) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

writeByte(Object, String, byte, byte) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

writeByte(Object, String, byte, byte) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

writeByte(Object, String, byte, byte) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

writeChar(Object, String, char, char) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

writeChar(Object, String, char, char) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

writeChar(Object, String, char, char) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

writeDouble(Object, String, double, double) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

writeDouble(Object, String, double, double) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

writeDouble(Object, String, double, double) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

writeElement(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister
Write the element to a JDBC PreparedStatement
writeElementToWhere(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister
Write the element to a JDBC PreparedStatement
writeFloat(Object, String, float, float) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

writeFloat(Object, String, float, float) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

writeFloat(Object, String, float, float) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

writeIdentifier(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister
Write the identifier to a JDBC PreparedStatement
writeIndex(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister
Write the index to a JDBC PreparedStatement
writeIndexToWhere(PreparedStatement, Object, int, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister
Write the index to a JDBC PreparedStatement
writeInsert(Object, Object, Object) - Method in interface org.hibernate.cache.OptimisticCache
Called during CacheConcurrencyStrategy.insert(java.lang.Object, java.lang.Object, java.lang.Object) processing for transactional strategies.
writeInsert(Object, Object, Object) - Method in class org.hibernate.cache.OptimisticTreeCache

writeInt(Object, String, int, int) - Method in interface org.hibernate.bytecode.javassist.FieldHandler
Called to handle writing an int value to a given field.
writeInt(Object, String, int, int) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

writeInt(Object, String, int, int) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

writeKey(PreparedStatement, Serializable, int, SessionImplementor) - Method in class org.hibernate.persister.collection.AbstractCollectionPersister
Write the key to a JDBC PreparedStatement
writeLoad(Object, Object, Object) - Method in interface org.hibernate.cache.OptimisticCache
Called during CacheConcurrencyStrategy.put(java.lang.Object, java.lang.Object, long, java.lang.Object, java.util.Comparator, boolean) processing for transactional strategies.
writeLoad(Object, Object, Object) - Method in class org.hibernate.cache.OptimisticTreeCache

writeLong(Object, String, long, long) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

writeLong(Object, String, long, long) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

writeLong(Object, String, long, long) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

writeObject(Object, String, Object, Object) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

writeObject(Object, String, Object, Object) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

writeObject(Object, String, Object, Object) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

writeReplace() - Method in interface org.hibernate.proxy.HibernateProxy
Perform serialization-time write-replacement of this proxy.
writeReplace() - Method in class org.hibernate.proxy.dom4j.Dom4jProxy

writeReplace() - Method in class org.hibernate.proxy.map.MapProxy

writeShort(Object, String, short, short) - Method in interface org.hibernate.bytecode.javassist.FieldHandler

writeShort(Object, String, short, short) - Method in class org.hibernate.intercept.cglib.FieldInterceptorImpl

writeShort(Object, String, short, short) - Method in class org.hibernate.intercept.javassist.FieldInterceptorImpl

writeUpdate(Object, Object, Object, Object) - Method in interface org.hibernate.cache.OptimisticCache
Called during CacheConcurrencyStrategy.update(java.lang.Object, java.lang.Object, java.lang.Object, java.lang.Object) processing for transactional strategies.
writeUpdate(Object, Object, Object, Object) - Method in class org.hibernate.cache.OptimisticTreeCache

X

XMLHelper - class org.hibernate.util.XMLHelper.
Small helper class that lazy loads DOM and SAX reader and keep them for fast use afterwards.
XMLHelper() - Constructor for class org.hibernate.util.XMLHelper

XMLHelper.ErrorLogger - class org.hibernate.util.XMLHelper.ErrorLogger.

xmlHelper - Variable in class org.hibernate.cfg.Configuration

Y

YES_NO - Static variable in class org.hibernate.Hibernate
Hibernate yes_no type.
YesNoType - class org.hibernate.type.YesNoType.
yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.
YesNoType() - Constructor for class org.hibernate.type.YesNoType

_

_tokenNames - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenNames - Static variable in class org.hibernate.hql.antlr.HqlSqlBaseWalker

_tokenNames - Static variable in class org.hibernate.hql.antlr.SqlGeneratorBase

_tokenSet_0 - Static variable in class org.hibernate.hql.antlr.HqlBaseLexer

_tokenSet_0 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_0 - Static variable in class org.hibernate.hql.antlr.HqlSqlBaseWalker

_tokenSet_0 - Static variable in class org.hibernate.hql.antlr.SqlGeneratorBase

_tokenSet_1 - Static variable in class org.hibernate.hql.antlr.HqlBaseLexer

_tokenSet_1 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_1 - Static variable in class org.hibernate.hql.antlr.SqlGeneratorBase

_tokenSet_10 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_11 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_12 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_13 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_14 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_15 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_16 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_17 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_18 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_19 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_2 - Static variable in class org.hibernate.hql.antlr.HqlBaseLexer

_tokenSet_2 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_2 - Static variable in class org.hibernate.hql.antlr.SqlGeneratorBase

_tokenSet_20 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_21 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_22 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_23 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_24 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_25 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_26 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_27 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_28 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_29 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_3 - Static variable in class org.hibernate.hql.antlr.HqlBaseLexer

_tokenSet_3 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_3 - Static variable in class org.hibernate.hql.antlr.SqlGeneratorBase

_tokenSet_30 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_31 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_32 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_33 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_34 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_35 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_4 - Static variable in class org.hibernate.hql.antlr.HqlBaseLexer

_tokenSet_4 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_4 - Static variable in class org.hibernate.hql.antlr.SqlGeneratorBase

_tokenSet_5 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_5 - Static variable in class org.hibernate.hql.antlr.SqlGeneratorBase

_tokenSet_6 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_7 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_8 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

_tokenSet_9 - Static variable in class org.hibernate.hql.antlr.HqlBaseParser

A B C D E F G H I J K L M N O P Q R S T U V W X Y _

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

PREV   NEXT

FRAMES    NO FRAMES


Overview (Hibernate API Documentation)

All Classes

Packages
org.hibernate
org.hibernate.action
org.hibernate.bytecode
org.hibernate.bytecode.cglib
org.hibernate.bytecode.javassist
org.hibernate.bytecode.util
org.hibernate.cache
org.hibernate.cache.entry
org.hibernate.cfg
org.hibernate.classic
org.hibernate.collection
org.hibernate.connection
org.hibernate.context
org.hibernate.criterion
org.hibernate.dialect
org.hibernate.dialect.function
org.hibernate.dialect.lock
org.hibernate.engine
org.hibernate.engine.query
org.hibernate.engine.query.sql
org.hibernate.engine.transaction
org.hibernate.event
org.hibernate.event.def
org.hibernate.exception
org.hibernate.hql
org.hibernate.hql.antlr
org.hibernate.hql.ast
org.hibernate.hql.ast.exec
org.hibernate.hql.ast.tree
org.hibernate.hql.ast.util
org.hibernate.hql.classic
org.hibernate.id
org.hibernate.id.insert
org.hibernate.impl
org.hibernate.intercept
org.hibernate.intercept.cglib
org.hibernate.intercept.javassist
org.hibernate.jdbc
org.hibernate.jmx
org.hibernate.loader
org.hibernate.loader.collection
org.hibernate.loader.criteria
org.hibernate.loader.custom
org.hibernate.loader.custom.sql
org.hibernate.loader.entity
org.hibernate.loader.hql
org.hibernate.lob
org.hibernate.mapping
org.hibernate.metadata
org.hibernate.param
org.hibernate.persister
org.hibernate.persister.collection
org.hibernate.persister.entity
org.hibernate.pretty
org.hibernate.property
org.hibernate.proxy
org.hibernate.proxy.dom4j
org.hibernate.proxy.map
org.hibernate.proxy.pojo
org.hibernate.proxy.pojo.cglib
org.hibernate.proxy.pojo.javassist
org.hibernate.secure
org.hibernate.sql
org.hibernate.stat
org.hibernate.tool.hbm2ddl
org.hibernate.tool.instrument
org.hibernate.tool.instrument.cglib
org.hibernate.tool.instrument.javassist
org.hibernate.transaction
org.hibernate.transform
org.hibernate.tuple
org.hibernate.tuple.component
org.hibernate.tuple.entity
org.hibernate.type
org.hibernate.usertype
org.hibernate.util


Hibernate API

This documentation concentrates upon the following Core API interfaces:
  • org.hibernate.Hibernate
  • org.hibernate.Session
  • org.hibernate.SessionFactory
  • org.hibernate.Transaction
  • org.hibernate.Query
  • org.hibernate.Criteria
  • org.hibernate.ScrollableResults
  • org.hibernate.cfg.Configuration
  • org.hibernate.expression.Expression
  • org.hibernate.expression.Order
  • org.hibernate.expression.Example
    • These interfaces are fully intended to be exposed to application code.

    The Extension API is intended to be used by application programmers to extend Hibernate functionality. None of these interfaces are intended to be called by the application - they are called internally by Hibernate. This API is less stable than the Core API. The safest way to extend functionality is to contribute extensions back to the project; that way extensions will be updated when the Extension API changes.

    Full Hibernate documentation may be found at hibernate.org. @see org.hibernate.Hibernate @see org.hibernate.Session @see org.hibernate.SessionFactory @see org.hibernate.Transaction @see org.hibernate.Query @see org.hibernate.Criteria @see org.hibernate.ScrollableResults @see org.hibernate.cfg.Configuration @see org.hibernate.expression.Expression @see org.hibernate.expression.Order @see org.hibernate.expression.Example


(Hibernate API Documentation)

The front page has been relocated.Please see:
Frame version
Non-frame version.


Serialized Form (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Serialized Form

Package org.hibernate

Class org.hibernate.AssertionFailure extends NestableRuntimeException implements Serializable

Class org.hibernate.CacheMode extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

name

String name

isPutEnabled

boolean isPutEnabled

isGetEnabled

boolean isGetEnabled

Class org.hibernate.CallbackException extends HibernateException implements Serializable

Class org.hibernate.ConnectionReleaseMode extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

name

String name

Class org.hibernate.DuplicateMappingException extends MappingException implements Serializable

Serialized Fields

name

String name

type

String type

Class org.hibernate.EmptyInterceptor extends Object implements Serializable

Class org.hibernate.EntityMode extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

name

String name

Class org.hibernate.FetchMode extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

name

String name

Class org.hibernate.FlushMode extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

level

int level

name

String name

Class org.hibernate.HibernateException extends NestableRuntimeException implements Serializable

Class org.hibernate.InstantiationException extends HibernateException implements Serializable

Serialized Fields

clazz

Class clazz

Class org.hibernate.InvalidMappingException extends MappingException implements Serializable

Serialized Fields

path

String path

type

String type

Class org.hibernate.JDBCException extends HibernateException implements Serializable

Serialized Fields

sqle

SQLException sqle

sql

String sql

Class org.hibernate.LazyInitializationException extends HibernateException implements Serializable

Class org.hibernate.LockMode extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

level

int level

name

String name

Class org.hibernate.MappingException extends HibernateException implements Serializable

Class org.hibernate.MappingNotFoundException extends MappingException implements Serializable

Serialized Fields

path

String path

type

String type

Class org.hibernate.NonUniqueObjectException extends HibernateException implements Serializable

Serialized Fields

identifier

Serializable identifier

entityName

String entityName

Class org.hibernate.NonUniqueResultException extends HibernateException implements Serializable

Class org.hibernate.ObjectDeletedException extends UnresolvableObjectException implements Serializable

Class org.hibernate.ObjectNotFoundException extends UnresolvableObjectException implements Serializable

Class org.hibernate.PersistentObjectException extends HibernateException implements Serializable

Class org.hibernate.PropertyAccessException extends HibernateException implements Serializable

Serialized Fields

persistentClass

Class persistentClass

propertyName

String propertyName

wasSetter

boolean wasSetter

Class org.hibernate.PropertyNotFoundException extends MappingException implements Serializable

Class org.hibernate.PropertyValueException extends HibernateException implements Serializable

Serialized Fields

entityName

String entityName

propertyName

String propertyName

Class org.hibernate.QueryException extends HibernateException implements Serializable

Serialized Fields

queryString

String queryString

Class org.hibernate.QueryParameterException extends QueryException implements Serializable

Class org.hibernate.ReplicationMode extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

name

String name

Class org.hibernate.ScrollMode extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

resultSetType

int resultSetType

name

String name

Class org.hibernate.SessionException extends HibernateException implements Serializable

Class org.hibernate.StaleObjectStateException extends StaleStateException implements Serializable

Serialized Fields

entityName

String entityName

identifier

Serializable identifier

Class org.hibernate.StaleStateException extends HibernateException implements Serializable

Class org.hibernate.TransactionException extends HibernateException implements Serializable

Class org.hibernate.TransientObjectException extends HibernateException implements Serializable

Class org.hibernate.TypeMismatchException extends HibernateException implements Serializable

Class org.hibernate.UnresolvableObjectException extends HibernateException implements Serializable

Serialized Fields

identifier

Serializable identifier

entityName

String entityName

Class org.hibernate.WrongClassException extends HibernateException implements Serializable

Serialized Fields

identifier

Serializable identifier

entityName

String entityName

Package org.hibernate.action

Class org.hibernate.action.BulkOperationCleanupAction extends Object implements Serializable

Serialized Fields

session

SessionImplementor session

affectedEntityNames

Set affectedEntityNames

affectedCollectionRoles

Set affectedCollectionRoles

spaces

Serializable[] spaces

Class org.hibernate.action.CollectionAction extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
Serialized Fields

key

Serializable key

finalKey

Serializable finalKey

session

SessionImplementor session

lock

CacheConcurrencyStrategy.SoftLock lock

collectionRole

String collectionRole

collection

PersistentCollection collection

Class org.hibernate.action.CollectionRecreateAction extends CollectionAction implements Serializable

Class org.hibernate.action.CollectionRemoveAction extends CollectionAction implements Serializable

Serialized Fields

emptySnapshot

boolean emptySnapshot

Class org.hibernate.action.CollectionUpdateAction extends CollectionAction implements Serializable

Serialized Fields

emptySnapshot

boolean emptySnapshot

Class org.hibernate.action.DelayedPostInsertIdentifier extends Object implements Serializable

Serialized Fields

sequence

long sequence

Class org.hibernate.action.EntityAction extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
Serialized Fields

session

SessionImplementor session

id

Serializable id

instance

Object instance

entityName

String entityName

Class org.hibernate.action.EntityDeleteAction extends EntityAction implements Serializable

Serialized Fields

version

Object version

lock

CacheConcurrencyStrategy.SoftLock lock

isCascadeDeleteEnabled

boolean isCascadeDeleteEnabled

state

Object[] state

Class org.hibernate.action.EntityIdentityInsertAction extends EntityAction implements Serializable

Serialized Fields

state

Object[] state

isDelayed

boolean isDelayed

delayedEntityKey

EntityKey delayedEntityKey

generatedId

Serializable generatedId

Class org.hibernate.action.EntityInsertAction extends EntityAction implements Serializable

Serialized Fields

state

Object[] state

version

Object version

cacheEntry

Object cacheEntry

Class org.hibernate.action.EntityUpdateAction extends EntityAction implements Serializable

Serialized Fields

state

Object[] state

previousState

Object[] previousState

previousVersion

Object previousVersion

nextVersion

Object nextVersion

dirtyFields

int[] dirtyFields

hasDirtyCollection

boolean hasDirtyCollection

rowId

Object rowId

cacheEntry

Object cacheEntry

lock

CacheConcurrencyStrategy.SoftLock lock

Package org.hibernate.bytecode.cglib

Class org.hibernate.bytecode.cglib.AccessOptimizerAdapter extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serialized Fields

mappedClass

Class mappedClass

bulkBean

net.sf.cglib.beans.BulkBean bulkBean

Class org.hibernate.bytecode.cglib.InstantiationOptimizerAdapter extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serialized Fields

fastClass

net.sf.cglib.reflect.FastClass fastClass

Class org.hibernate.bytecode.cglib.ReflectionOptimizerImpl extends Object implements Serializable

Package org.hibernate.bytecode.javassist

Class org.hibernate.bytecode.javassist.AccessOptimizerAdapter extends Object implements Serializable

Serialized Fields

bulkAccessor

BulkAccessor bulkAccessor

mappedClass

Class mappedClass

Class org.hibernate.bytecode.javassist.BulkAccessor extends Object implements Serializable

Serialized Fields

target

Class target

getters

String[] getters

setters

String[] setters

types

Class[] types

Class org.hibernate.bytecode.javassist.BulkAccessorException extends RuntimeException implements Serializable

Serialized Fields

myCause

Throwable myCause

index

int index

Class org.hibernate.bytecode.javassist.FastClass extends Object implements Serializable

Serialized Fields

type

Class type

Class org.hibernate.bytecode.javassist.InstantiationOptimizerAdapter extends Object implements Serializable

Serialized Fields

fastClass

FastClass fastClass

Class org.hibernate.bytecode.javassist.ReflectionOptimizerImpl extends Object implements Serializable

Serialized Fields

instantiationOptimizer

ReflectionOptimizer.InstantiationOptimizer instantiationOptimizer

accessOptimizer

ReflectionOptimizer.AccessOptimizer accessOptimizer

Package org.hibernate.cache

Class org.hibernate.cache.CacheException extends HibernateException implements Serializable

Class org.hibernate.cache.CacheKey extends Object implements Serializable

Serialized Fields

key

Serializable key

type

Type type

entityOrRoleName

String entityOrRoleName

entityMode

EntityMode entityMode

hashCode

int hashCode

Class org.hibernate.cache.FilterKey extends Object implements Serializable

Serialized Fields

filterName

String filterName

filterParameters

Map filterParameters

Class org.hibernate.cache.NoCachingEnabledException extends CacheException implements Serializable

Class org.hibernate.cache.OptimisticTreeCache.CircumventChecksDataVersion extends Object implements Serializable

Class org.hibernate.cache.OptimisticTreeCache.DataVersionAdapter extends Object implements Serializable

Serialized Fields

currentVersion

Object currentVersion

previousVersion

Object previousVersion

versionComparator

Comparator versionComparator

sourceIdentifer

String sourceIdentifer

Class org.hibernate.cache.OptimisticTreeCache.NonLockingDataVersion extends Object implements Serializable

Class org.hibernate.cache.QueryKey extends Object implements Serializable

Serialized Fields

sqlQueryString

String sqlQueryString

types

Type[] types

values

Object[] values

firstRow

Integer firstRow

maxRows

Integer maxRows

namedParameters

Map namedParameters

entityMode

EntityMode entityMode

filters

Set filters

hashCode

int hashCode

customTransformer

ResultTransformer customTransformer

Class org.hibernate.cache.ReadWriteCache.Item extends Object implements Serializable

Serialized Fields

freshTimestamp

long freshTimestamp

value

Object value

version

Object version

Class org.hibernate.cache.ReadWriteCache.Lock extends Object implements Serializable

Serialized Fields

unlockTimestamp

long unlockTimestamp

multiplicity

int multiplicity

concurrentLock

boolean concurrentLock

timeout

long timeout

id

int id

version

Object version

Package org.hibernate.cache.entry

Class org.hibernate.cache.entry.CacheEntry extends Object implements Serializable

Serialized Fields

disassembledState

Serializable[] disassembledState

subclass

String subclass

lazyPropertiesAreUnfetched

boolean lazyPropertiesAreUnfetched

version

Object version

Class org.hibernate.cache.entry.CollectionCacheEntry extends Object implements Serializable

Serialized Fields

state

Serializable state

Package org.hibernate.cfg

Class org.hibernate.cfg.CollectionSecondPass extends Object implements Serializable

Serialized Fields

mappings

Mappings mappings

collection

Collection collection

localInheritedMetas

Map localInheritedMetas

Class org.hibernate.cfg.Configuration extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
Serialized Fields

classes

Map classes

imports

Map imports

collections

Map collections

tables

Map tables

auxiliaryDatabaseObjects

List auxiliaryDatabaseObjects

sqlFunctions

Map sqlFunctions

namedQueries

Map namedQueries

namedSqlQueries

Map namedSqlQueries

sqlResultSetMappings

Map sqlResultSetMappings
Map result set name, result set description

filterDefinitions

Map filterDefinitions

secondPasses

List secondPasses

propertyReferences

List propertyReferences

extendsQueue

Map extendsQueue

tableNameBinding

Map tableNameBinding

columnNameBindingPerTable

Map columnNameBindingPerTable

interceptor

Interceptor interceptor

properties

Properties properties

entityResolver

org.xml.sax.EntityResolver entityResolver

entityNotFoundDelegate

EntityNotFoundDelegate entityNotFoundDelegate

namingStrategy

NamingStrategy namingStrategy

eventListeners

EventListeners eventListeners

settingsFactory

SettingsFactory settingsFactory

Class org.hibernate.cfg.DefaultNamingStrategy extends Object implements Serializable

Class org.hibernate.cfg.ImprovedNamingStrategy extends Object implements Serializable

Class org.hibernate.cfg.Mappings extends Object implements Serializable

Serialized Fields

classes

Map classes

collections

Map collections

tables

Map tables

queries

Map queries

sqlqueries

Map sqlqueries

resultSetMappings

Map resultSetMappings

typeDefs

Map typeDefs

secondPasses

List secondPasses

imports

Map imports

schemaName

String schemaName

catalogName

String catalogName

defaultCascade

String defaultCascade

defaultPackage

String defaultPackage

defaultAccess

String defaultAccess

autoImport

boolean autoImport

defaultLazy

boolean defaultLazy

propertyReferences

List propertyReferences

namingStrategy

NamingStrategy namingStrategy

filterDefinitions

Map filterDefinitions

auxiliaryDatabaseObjects

List auxiliaryDatabaseObjects

extendsQueue

Map extendsQueue

columnNameBindingPerTable

Map columnNameBindingPerTable
binding table between the logical column name and the name out of the naming strategy for each table. According that when the column name is not set, the property name is considered as such This means that while theorically possible through the naming strategy contract, it is forbidden to have 2 real columns having the same logical name

tableNameBinding

Map tableNameBinding
binding between logical table name and physical one (ie after the naming strategy has been applied)

Class org.hibernate.cfg.Mappings.ColumnNames extends Object implements Serializable

Serialized Fields

logicalToPhysical

Map logicalToPhysical

physicalToLogical

Map physicalToLogical

Class org.hibernate.cfg.Mappings.TableDescription extends Object implements Serializable

Serialized Fields

logicalName

String logicalName

denormalizedSupertable

Table denormalizedSupertable

Class org.hibernate.cfg.NamedSQLQuerySecondPass extends ResultSetMappingBinder implements Serializable

Serialized Fields

queryElem

org.dom4j.Element queryElem

path

String path

mappings

Mappings mappings

Class org.hibernate.cfg.ResultSetMappingSecondPass extends ResultSetMappingBinder implements Serializable

Serialized Fields

element

org.dom4j.Element element

path

String path

mappings

Mappings mappings

Class org.hibernate.cfg.SettingsFactory extends Object implements Serializable

Package org.hibernate.classic

Class org.hibernate.classic.ValidationFailure extends HibernateException implements Serializable

Package org.hibernate.collection

Class org.hibernate.collection.AbstractPersistentCollection extends Object implements Serializable

Serialized Fields

initialized

boolean initialized

owner

Object owner

cachedSize

int cachedSize

role

String role

key

Serializable key

dirty

boolean dirty

storedSnapshot

Serializable storedSnapshot

Class org.hibernate.collection.PersistentArrayHolder extends AbstractPersistentCollection implements Serializable

Serialized Fields

array

Object array

Class org.hibernate.collection.PersistentBag extends AbstractPersistentCollection implements Serializable

Serialized Fields

bag

List bag

Class org.hibernate.collection.PersistentElementHolder extends AbstractPersistentCollection implements Serializable

Serialized Fields

element

org.dom4j.Element element

Class org.hibernate.collection.PersistentIdentifierBag extends AbstractPersistentCollection implements Serializable

Serialized Fields

values

List values

identifiers

Map identifiers

Class org.hibernate.collection.PersistentIndexedElementHolder extends AbstractPersistentCollection implements Serializable

Serialized Fields

element

org.dom4j.Element element

Class org.hibernate.collection.PersistentList extends AbstractPersistentCollection implements Serializable

Serialized Fields

list

List list

Class org.hibernate.collection.PersistentListElementHolder extends PersistentIndexedElementHolder implements Serializable

Class org.hibernate.collection.PersistentMap extends AbstractPersistentCollection implements Serializable

Serialized Fields

map

Map map

Class org.hibernate.collection.PersistentMapElementHolder extends PersistentIndexedElementHolder implements Serializable

Class org.hibernate.collection.PersistentSet extends AbstractPersistentCollection implements Serializable

Serialized Fields

set

Set set

Class org.hibernate.collection.PersistentSortedMap extends PersistentMap implements Serializable

Serialized Fields

comparator

Comparator comparator

Class org.hibernate.collection.PersistentSortedSet extends PersistentSet implements Serializable

Serialized Fields

comparator

Comparator comparator

Package org.hibernate.context

Class org.hibernate.context.JTASessionContext extends Object implements Serializable

Serialized Fields

factory

SessionFactoryImplementor factory

Class org.hibernate.context.ManagedSessionContext extends Object implements Serializable

Serialized Fields

factory

SessionFactoryImplementor factory

Class org.hibernate.context.ThreadLocalSessionContext extends Object implements Serializable

Serialized Fields

factory

SessionFactoryImplementor factory

Class org.hibernate.context.ThreadLocalSessionContext.CleanupSynch extends Object implements Serializable

Serialized Fields

factory

SessionFactory factory

Package org.hibernate.criterion

Class org.hibernate.criterion.AbstractEmptinessExpression extends Object implements Serializable

Serialized Fields

propertyName

String propertyName

Class org.hibernate.criterion.AggregateProjection extends SimpleProjection implements Serializable

Serialized Fields

propertyName

String propertyName

aggregate

String aggregate

Class org.hibernate.criterion.AliasedProjection extends Object implements Serializable

Serialized Fields

projection

Projection projection

alias

String alias

Class org.hibernate.criterion.AvgProjection extends AggregateProjection implements Serializable

Class org.hibernate.criterion.BetweenExpression extends Object implements Serializable

Serialized Fields

propertyName

String propertyName

lo

Object lo

hi

Object hi

Class org.hibernate.criterion.Conjunction extends Junction implements Serializable

Class org.hibernate.criterion.CountProjection extends AggregateProjection implements Serializable

Serialized Fields

distinct

boolean distinct

Class org.hibernate.criterion.DetachedCriteria extends Object implements Serializable

Serialized Fields

impl

CriteriaImpl impl

criteria

Criteria criteria

Class org.hibernate.criterion.Disjunction extends Junction implements Serializable

Class org.hibernate.criterion.Distinct extends Object implements Serializable

Serialized Fields

projection

Projection projection

Class org.hibernate.criterion.EmptyExpression extends AbstractEmptinessExpression implements Serializable

Class org.hibernate.criterion.Example extends Object implements Serializable

Serialized Fields

entity

Object entity

excludedProperties

Set excludedProperties

selector

Example.PropertySelector selector

isLikeEnabled

boolean isLikeEnabled

escapeCharacter

Character escapeCharacter

isIgnoreCaseEnabled

boolean isIgnoreCaseEnabled

matchMode

MatchMode matchMode

Class org.hibernate.criterion.ExistsSubqueryExpression extends SubqueryExpression implements Serializable

Class org.hibernate.criterion.IdentifierEqExpression extends Object implements Serializable

Serialized Fields

value

Object value

Class org.hibernate.criterion.IdentifierProjection extends SimpleProjection implements Serializable

Serialized Fields

grouped

boolean grouped

Class org.hibernate.criterion.IlikeExpression extends Object implements Serializable

Serialized Fields

propertyName

String propertyName

value

Object value

Class org.hibernate.criterion.InExpression extends Object implements Serializable

Serialized Fields

propertyName

String propertyName

values

Object[] values

Class org.hibernate.criterion.Junction extends Object implements Serializable

Serialized Fields

criteria

List criteria

op

String op

Class org.hibernate.criterion.LikeExpression extends Object implements Serializable

Serialized Fields

propertyName

String propertyName

value

Object value

escapeChar

Character escapeChar

ignoreCase

boolean ignoreCase

Class org.hibernate.criterion.LogicalExpression extends Object implements Serializable

Serialized Fields

lhs

Criterion lhs

rhs

Criterion rhs

op

String op

Class org.hibernate.criterion.MatchMode extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

name

String name

Class org.hibernate.criterion.NaturalIdentifier extends Object implements Serializable

Serialized Fields

conjunction

Junction conjunction

Class org.hibernate.criterion.NotEmptyExpression extends AbstractEmptinessExpression implements Serializable

Class org.hibernate.criterion.NotExpression extends Object implements Serializable

Serialized Fields

criterion

Criterion criterion

Class org.hibernate.criterion.NotNullExpression extends Object implements Serializable

Serialized Fields

propertyName

String propertyName

Class org.hibernate.criterion.NullExpression extends Object implements Serializable

Serialized Fields

propertyName

String propertyName

Class org.hibernate.criterion.Order extends Object implements Serializable

Serialized Fields

ascending

boolean ascending

ignoreCase

boolean ignoreCase

propertyName

String propertyName

Class org.hibernate.criterion.ProjectionList extends Object implements Serializable

Serialized Fields

elements

List elements

Class org.hibernate.criterion.Property extends PropertyProjection implements Serializable

Class org.hibernate.criterion.PropertyExpression extends Object implements Serializable

Serialized Fields

propertyName

String propertyName

otherPropertyName

String otherPropertyName

op

String op

Class org.hibernate.criterion.PropertyProjection extends SimpleProjection implements Serializable

Serialized Fields

propertyName

String propertyName

grouped

boolean grouped

Class org.hibernate.criterion.PropertySubqueryExpression extends SubqueryExpression implements Serializable

Serialized Fields

propertyName

String propertyName

Class org.hibernate.criterion.RowCountProjection extends SimpleProjection implements Serializable

Class org.hibernate.criterion.SimpleExpression extends Object implements Serializable

Serialized Fields

propertyName

String propertyName

value

Object value

ignoreCase

boolean ignoreCase

op

String op

Class org.hibernate.criterion.SimpleProjection extends Object implements Serializable

Class org.hibernate.criterion.SimpleSubqueryExpression extends SubqueryExpression implements Serializable

Serialized Fields

value

Object value

Class org.hibernate.criterion.SizeExpression extends Object implements Serializable

Serialized Fields

propertyName

String propertyName

size

int size

op

String op

Class org.hibernate.criterion.SQLCriterion extends Object implements Serializable

Serialized Fields

sql

String sql

typedValues

TypedValue[] typedValues

Class org.hibernate.criterion.SQLProjection extends Object implements Serializable

Serialized Fields

sql

String sql

groupBy

String groupBy

types

Type[] types

aliases

String[] aliases

columnAliases

String[] columnAliases

grouped

boolean grouped

Class org.hibernate.criterion.SubqueryExpression extends Object implements Serializable

Serialized Fields

criteriaImpl

CriteriaImpl criteriaImpl

quantifier

String quantifier

op

String op

params

QueryParameters params

types

Type[] types

Package org.hibernate.engine

Class org.hibernate.engine.CascadeStyle extends Object implements Serializable

Class org.hibernate.engine.CascadeStyle.MultipleCascadeStyle extends CascadeStyle implements Serializable

Serialized Fields

styles

CascadeStyle[] styles

Class org.hibernate.engine.CollectionEntry extends Object implements Serializable

Serialized Fields

snapshot

Serializable snapshot

role

String role

loadedKey

Serializable loadedKey

Class org.hibernate.engine.CollectionKey extends Object implements Serializable

Serialized Fields

role

String role

key

Serializable key

keyType

Type keyType

factory

SessionFactoryImplementor factory

hashCode

int hashCode

entityMode

EntityMode entityMode

Class org.hibernate.engine.EntityEntry extends Object implements Serializable

Serialized Fields

lockMode

LockMode lockMode

status

Status status

id

Serializable id

loadedState

Object[] loadedState

deletedState

Object[] deletedState

existsInDatabase

boolean existsInDatabase

version

Object version

entityMode

EntityMode entityMode

entityName

String entityName

isBeingReplicated

boolean isBeingReplicated

loadedWithLazyPropertiesUnfetched

boolean loadedWithLazyPropertiesUnfetched

Class org.hibernate.engine.EntityKey extends Object implements Serializable

Serialized Fields

identifier

Serializable identifier

rootEntityName

String rootEntityName

entityName

String entityName

identifierType

Type identifierType

isBatchLoadable

boolean isBatchLoadable

factory

SessionFactoryImplementor factory

hashCode

int hashCode

entityMode

EntityMode entityMode

Class org.hibernate.engine.EntityUniqueKey extends Object implements Serializable

Serialization Methods

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Serialized Fields

uniqueKeyName

String uniqueKeyName

entityName

String entityName

key

Object key

keyType

Type keyType

entityMode

EntityMode entityMode

hashCode

int hashCode

Class org.hibernate.engine.ExecuteUpdateResultCheckStyle extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
                    throws ObjectStreamException
Serialized Fields

name

String name

Class org.hibernate.engine.FilterDefinition extends Object implements Serializable

Serialized Fields

filterName

String filterName

defaultFilterCondition

String defaultFilterCondition

parameterTypes

Map parameterTypes

Class org.hibernate.engine.NamedQueryDefinition extends Object implements Serializable

Serialized Fields

query

String query

cacheable

boolean cacheable

cacheRegion

String cacheRegion

timeout

Integer timeout

fetchSize

Integer fetchSize

flushMode

FlushMode flushMode

parameterTypes

Map parameterTypes

cacheMode

CacheMode cacheMode

readOnly

boolean readOnly

comment

String comment

Class org.hibernate.engine.NamedSQLQueryDefinition extends NamedQueryDefinition implements Serializable

Serialized Fields

queryReturns

NativeSQLQueryReturn[] queryReturns

querySpaces

List querySpaces

callable

boolean callable

resultSetRef

String resultSetRef

Class org.hibernate.engine.ResultSetMappingDefinition extends Object implements Serializable

Serialized Fields

name

String name

queryReturns

List queryReturns

Class org.hibernate.engine.Status extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
                    throws ObjectStreamException
Serialized Fields

name

String name

Class org.hibernate.engine.TypedValue extends Object implements Serializable

Serialized Fields

type

Type type

value

Object value

entityMode

EntityMode entityMode

Package org.hibernate.engine.query

Class org.hibernate.engine.query.FilterQueryPlan extends HQLQueryPlan implements Serializable

Serialized Fields

collectionRole

String collectionRole

Class org.hibernate.engine.query.HQLQueryPlan extends Object implements Serializable

Serialized Fields

sourceQuery

String sourceQuery

translators

QueryTranslator[] translators

sqlStrings

String[] sqlStrings

parameterMetadata

ParameterMetadata parameterMetadata

returnMetadata

ReturnMetadata returnMetadata

querySpaces

Set querySpaces

enabledFilterNames

Set enabledFilterNames

shallow

boolean shallow

Class org.hibernate.engine.query.NamedParameterDescriptor extends Object implements Serializable

Serialized Fields

name

String name

expectedType

Type expectedType

sourceLocations

int[] sourceLocations

jpaStyle

boolean jpaStyle

Class org.hibernate.engine.query.NativeSQLQueryPlan extends Object implements Serializable

Serialized Fields

sourceQuery

String sourceQuery

customQuery

SQLCustomQuery customQuery

Class org.hibernate.engine.query.OrdinalParameterDescriptor extends Object implements Serializable

Serialized Fields

ordinalPosition

int ordinalPosition

expectedType

Type expectedType

sourceLocation

int sourceLocation

Class org.hibernate.engine.query.ParameterMetadata extends Object implements Serializable

Serialized Fields

ordinalDescriptors

OrdinalParameterDescriptor[] ordinalDescriptors

namedDescriptorMap

Map namedDescriptorMap

Class org.hibernate.engine.query.QueryMetadata extends Object implements Serializable

Serialized Fields

sourceQuery

String sourceQuery

parameterMetadata

ParameterMetadata parameterMetadata

returnAliases

String[] returnAliases

returnTypes

Type[] returnTypes

querySpaces

Set querySpaces

Class org.hibernate.engine.query.QueryPlanCache extends Object implements Serializable

Serialized Fields

factory

SessionFactoryImplementor factory

sqlParamMetadataCache

SimpleMRUCache sqlParamMetadataCache

planCache

SoftLimitMRUCache planCache

Class org.hibernate.engine.query.ReturnMetadata extends Object implements Serializable

Serialized Fields

returnAliases

String[] returnAliases

returnTypes

Type[] returnTypes

Package org.hibernate.engine.query.sql

Class org.hibernate.engine.query.sql.NativeSQLQueryCollectionReturn extends NativeSQLQueryNonScalarReturn implements Serializable

Serialized Fields

ownerEntityName

String ownerEntityName

ownerProperty

String ownerProperty

Class org.hibernate.engine.query.sql.NativeSQLQueryJoinReturn extends NativeSQLQueryNonScalarReturn implements Serializable

Serialized Fields

ownerAlias

String ownerAlias

ownerProperty

String ownerProperty

Class org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn extends Object implements Serializable

Serialized Fields

alias

String alias

lockMode

LockMode lockMode

propertyResults

Map propertyResults

Class org.hibernate.engine.query.sql.NativeSQLQueryRootReturn extends NativeSQLQueryNonScalarReturn implements Serializable

Serialized Fields

returnEntityName

String returnEntityName

Package org.hibernate.event

Class org.hibernate.event.AbstractEvent extends Object implements Serializable

Serialized Fields

session

EventSource session

Class org.hibernate.event.AutoFlushEvent extends FlushEvent implements Serializable

Serialized Fields

querySpaces

Set querySpaces

flushRequired

boolean flushRequired

Class org.hibernate.event.DeleteEvent extends AbstractEvent implements Serializable

Serialized Fields

object

Object object

entityName

String entityName

cascadeDeleteEnabled

boolean cascadeDeleteEnabled

Class org.hibernate.event.DirtyCheckEvent extends FlushEvent implements Serializable

Serialized Fields

dirty

boolean dirty

Class org.hibernate.event.EventListeners extends Cloneable implements Serializable

Serialized Fields

loadEventListeners

LoadEventListener[] loadEventListeners

saveOrUpdateEventListeners

SaveOrUpdateEventListener[] saveOrUpdateEventListeners

mergeEventListeners

MergeEventListener[] mergeEventListeners

persistEventListeners

PersistEventListener[] persistEventListeners

persistOnFlushEventListeners

PersistEventListener[] persistOnFlushEventListeners

replicateEventListeners

ReplicateEventListener[] replicateEventListeners

deleteEventListeners

DeleteEventListener[] deleteEventListeners

autoFlushEventListeners

AutoFlushEventListener[] autoFlushEventListeners

dirtyCheckEventListeners

DirtyCheckEventListener[] dirtyCheckEventListeners

flushEventListeners

FlushEventListener[] flushEventListeners

evictEventListeners

EvictEventListener[] evictEventListeners

lockEventListeners

LockEventListener[] lockEventListeners

refreshEventListeners

RefreshEventListener[] refreshEventListeners

flushEntityEventListeners

FlushEntityEventListener[] flushEntityEventListeners

initializeCollectionEventListeners

InitializeCollectionEventListener[] initializeCollectionEventListeners

postLoadEventListeners

PostLoadEventListener[] postLoadEventListeners

preLoadEventListeners

PreLoadEventListener[] preLoadEventListeners

preDeleteEventListeners

PreDeleteEventListener[] preDeleteEventListeners

preUpdateEventListeners

PreUpdateEventListener[] preUpdateEventListeners

preInsertEventListeners

PreInsertEventListener[] preInsertEventListeners

postDeleteEventListeners

PostDeleteEventListener[] postDeleteEventListeners

postUpdateEventListeners

PostUpdateEventListener[] postUpdateEventListeners

postInsertEventListeners

PostInsertEventListener[] postInsertEventListeners

postCommitDeleteEventListeners

PostDeleteEventListener[] postCommitDeleteEventListeners

postCommitUpdateEventListeners

PostUpdateEventListener[] postCommitUpdateEventListeners

postCommitInsertEventListeners

PostInsertEventListener[] postCommitInsertEventListeners

saveEventListeners

SaveOrUpdateEventListener[] saveEventListeners

updateEventListeners

SaveOrUpdateEventListener[] updateEventListeners

saveOrUpdateCopyEventListeners

MergeEventListener[] saveOrUpdateCopyEventListeners

Class org.hibernate.event.EvictEvent extends AbstractEvent implements Serializable

Serialized Fields

object

Object object

Class org.hibernate.event.FlushEntityEvent extends AbstractEvent implements Serializable

Serialized Fields

entity

Object entity

propertyValues

Object[] propertyValues

databaseSnapshot

Object[] databaseSnapshot

dirtyProperties

int[] dirtyProperties

hasDirtyCollection

boolean hasDirtyCollection

dirtyCheckPossible

boolean dirtyCheckPossible

dirtyCheckHandledByInterceptor

boolean dirtyCheckHandledByInterceptor

entityEntry

EntityEntry entityEntry

Class org.hibernate.event.FlushEvent extends AbstractEvent implements Serializable

Class org.hibernate.event.InitializeCollectionEvent extends AbstractEvent implements Serializable

Serialized Fields

collection

PersistentCollection collection

Class org.hibernate.event.LoadEvent extends AbstractEvent implements Serializable

Serialized Fields

entityId

Serializable entityId

entityClassName

String entityClassName

instanceToLoad

Object instanceToLoad

lockMode

LockMode lockMode

isAssociationFetch

boolean isAssociationFetch

result

Object result

Class org.hibernate.event.LockEvent extends AbstractEvent implements Serializable

Serialized Fields

object

Object object

lockMode

LockMode lockMode

entityName

String entityName

Class org.hibernate.event.MergeEvent extends AbstractEvent implements Serializable

Serialized Fields

original

Object original

requestedId

Serializable requestedId

entityName

String entityName

entity

Object entity

result

Object result

Class org.hibernate.event.PersistEvent extends AbstractEvent implements Serializable

Serialized Fields

object

Object object

entityName

String entityName

Class org.hibernate.event.PostLoadEvent extends AbstractEvent implements Serializable

Serialized Fields

entity

Object entity

id

Serializable id

persister

EntityPersister persister

Class org.hibernate.event.PostUpdateEvent extends AbstractEvent implements Serializable

Serialized Fields

entity

Object entity

persister

EntityPersister persister

state

Object[] state

oldState

Object[] oldState

id

Serializable id

Class org.hibernate.event.PreLoadEvent extends AbstractEvent implements Serializable

Serialized Fields

entity

Object entity

state

Object[] state

id

Serializable id

persister

EntityPersister persister

Class org.hibernate.event.RefreshEvent extends AbstractEvent implements Serializable

Serialized Fields

object

Object object

lockMode

LockMode lockMode

Class org.hibernate.event.ReplicateEvent extends AbstractEvent implements Serializable

Serialized Fields

object

Object object

replicationMode

ReplicationMode replicationMode

entityName

String entityName

Class org.hibernate.event.SaveOrUpdateEvent extends AbstractEvent implements Serializable

Serialized Fields

object

Object object

requestedId

Serializable requestedId

entityName

String entityName

entity

Object entity

entry

EntityEntry entry

resultId

Serializable resultId

Package org.hibernate.event.def

Class org.hibernate.event.def.AbstractFlushingEventListener extends Object implements Serializable

Class org.hibernate.event.def.AbstractLockUpgradeEventListener extends AbstractReassociateEventListener implements Serializable

Class org.hibernate.event.def.AbstractReassociateEventListener extends Object implements Serializable

Class org.hibernate.event.def.AbstractSaveEventListener extends AbstractReassociateEventListener implements Serializable

Class org.hibernate.event.def.DefaultAutoFlushEventListener extends AbstractFlushingEventListener implements Serializable

Class org.hibernate.event.def.DefaultDeleteEventListener extends Object implements Serializable

Class org.hibernate.event.def.DefaultDirtyCheckEventListener extends AbstractFlushingEventListener implements Serializable

Class org.hibernate.event.def.DefaultEvictEventListener extends Object implements Serializable

Class org.hibernate.event.def.DefaultFlushEntityEventListener extends Object implements Serializable

Class org.hibernate.event.def.DefaultFlushEventListener extends AbstractFlushingEventListener implements Serializable

Class org.hibernate.event.def.DefaultInitializeCollectionEventListener extends Object implements Serializable

Class org.hibernate.event.def.DefaultLoadEventListener extends AbstractLockUpgradeEventListener implements Serializable

Class org.hibernate.event.def.DefaultLockEventListener extends AbstractLockUpgradeEventListener implements Serializable

Class org.hibernate.event.def.DefaultMergeEventListener extends AbstractSaveEventListener implements Serializable

Class org.hibernate.event.def.DefaultPersistEventListener extends AbstractSaveEventListener implements Serializable

Class org.hibernate.event.def.DefaultPersistOnFlushEventListener extends DefaultPersistEventListener implements Serializable

Class org.hibernate.event.def.DefaultPostLoadEventListener extends Object implements Serializable

Class org.hibernate.event.def.DefaultPreLoadEventListener extends Object implements Serializable

Class org.hibernate.event.def.DefaultRefreshEventListener extends Object implements Serializable

Class org.hibernate.event.def.DefaultReplicateEventListener extends AbstractSaveEventListener implements Serializable

Class org.hibernate.event.def.DefaultSaveEventListener extends DefaultSaveOrUpdateEventListener implements Serializable

Class org.hibernate.event.def.DefaultSaveOrUpdateCopyEventListener extends DefaultMergeEventListener implements Serializable

Class org.hibernate.event.def.DefaultSaveOrUpdateEventListener extends AbstractSaveEventListener implements Serializable

Class org.hibernate.event.def.DefaultUpdateEventListener extends DefaultSaveOrUpdateEventListener implements Serializable

Package org.hibernate.exception

Class org.hibernate.exception.ConstraintViolationException extends JDBCException implements Serializable

Serialized Fields

constraintName

String constraintName

Class org.hibernate.exception.DataException extends JDBCException implements Serializable

Class org.hibernate.exception.GenericJDBCException extends JDBCException implements Serializable

Class org.hibernate.exception.JDBCConnectionException extends JDBCException implements Serializable

Class org.hibernate.exception.LockAcquisitionException extends JDBCException implements Serializable

Class org.hibernate.exception.NestableDelegate extends Object implements Serializable

Serialized Fields

nestable

Throwable nestable
Holds the reference to the exception or error that we're wrapping (which must be a org.apache.commons.lang.exception.Nestable implementation).

Class org.hibernate.exception.NestableException extends Exception implements Serializable

Serialized Fields

delegate

NestableDelegate delegate
The helper instance which contains much of the code which we delegate to.

cause

Throwable cause
Holds the reference to the exception or error that caused this exception to be thrown.

Class org.hibernate.exception.NestableRuntimeException extends RuntimeException implements Serializable

Serialization Methods

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Serialized Fields

delegate

NestableDelegate delegate
The helper instance which contains much of the code which we delegate to.

cause

Throwable cause
Holds the reference to the exception or error that caused this exception to be thrown.

Class org.hibernate.exception.SQLGrammarException extends JDBCException implements Serializable

Package org.hibernate.hql

Class org.hibernate.hql.QueryExecutionRequestException extends QueryException implements Serializable

Package org.hibernate.hql.ast

Class org.hibernate.hql.ast.DetailedSemanticException extends antlr.SemanticException implements Serializable

Serialized Fields

cause

Throwable cause

showCauseMessage

boolean showCauseMessage

Class org.hibernate.hql.ast.InvalidPathException extends antlr.SemanticException implements Serializable

Class org.hibernate.hql.ast.ParameterTranslationsImpl.ParameterInfo extends Object implements Serializable

Serialized Fields

sqlLocations

int[] sqlLocations

expectedType

Type expectedType

Class org.hibernate.hql.ast.QuerySyntaxException extends QueryException implements Serializable

Package org.hibernate.hql.ast.tree

Class org.hibernate.hql.ast.tree.AbstractRestrictableStatement extends AbstractStatement implements Serializable

Serialized Fields

fromClause

FromClause fromClause

whereClause

antlr.collections.AST whereClause

Class org.hibernate.hql.ast.tree.AbstractSelectExpression extends HqlSqlWalkerNode implements Serializable

Serialized Fields

alias

String alias

Class org.hibernate.hql.ast.tree.AbstractStatement extends HqlSqlWalkerNode implements Serializable

Class org.hibernate.hql.ast.tree.AggregateNode extends AbstractSelectExpression implements Serializable

Class org.hibernate.hql.ast.tree.BetweenOperatorNode extends SqlNode implements Serializable

Class org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode extends AbstractSelectExpression implements Serializable

Class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode extends HqlSqlWalkerNode implements Serializable

Class org.hibernate.hql.ast.tree.BooleanLiteralNode extends LiteralNode implements Serializable

Serialized Fields

expectedType

Type expectedType

Class org.hibernate.hql.ast.tree.Case2Node extends AbstractSelectExpression implements Serializable

Class org.hibernate.hql.ast.tree.CaseNode extends AbstractSelectExpression implements Serializable

Class org.hibernate.hql.ast.tree.CollectionFunction extends MethodNode implements Serializable

Class org.hibernate.hql.ast.tree.ConstructorNode extends SelectExpressionList implements Serializable

Serialized Fields

constructor

Constructor constructor

constructorArgumentTypes

Type[] constructorArgumentTypes

isMap

boolean isMap

isList

boolean isList

Class org.hibernate.hql.ast.tree.CountNode extends AbstractSelectExpression implements Serializable

Class org.hibernate.hql.ast.tree.DeleteStatement extends AbstractRestrictableStatement implements Serializable

Class org.hibernate.hql.ast.tree.DotNode extends FromReferenceNode implements Serializable

Serialized Fields

propertyName

String propertyName
The identifier that is the name of the property.

path

String path
The full path, to the root alias of this dot node.

propertyPath

String propertyPath
The unresolved property path relative to this dot node.

columns

String[] columns
The column names that this resolves to.

joinType

int joinType
The type of join to create. Default is an inner join.

fetch

boolean fetch
Fetch join or not.

dereferenceType

int dereferenceType
The type of dereference that hapened (DEREF_xxx).

impliedJoin

FromElement impliedJoin

Class org.hibernate.hql.ast.tree.FromClause extends HqlSqlWalkerNode implements Serializable

Serialized Fields

level

int level

fromElements

Set fromElements

fromElementByClassAlias

Map fromElementByClassAlias

fromElementByTableAlias

Map fromElementByTableAlias

fromElementsByPath

Map fromElementsByPath

collectionJoinFromElementsByPath

Map collectionJoinFromElementsByPath
All of the implicit FROM xxx JOIN yyy elements that are the destination of a collection. These are created from index operators on collection property references.

parentFromClause

FromClause parentFromClause
Pointer to the parent FROM clause, if there is one.

childFromClauses

Set childFromClauses
Collection of FROM clauses of which this is the parent.

fromElementCounter

int fromElementCounter
Counts the from elements as they are added.

impliedElements

List impliedElements
Implied FROM elements to add onto the end of the FROM clause.

Class org.hibernate.hql.ast.tree.FromElement extends HqlSqlWalkerNode implements Serializable

Serialized Fields

className

String className

classAlias

String classAlias

tableAlias

String tableAlias

collectionTableAlias

String collectionTableAlias

fromClause

FromClause fromClause

includeSubclasses

boolean includeSubclasses

collectionJoin

boolean collectionJoin

origin

FromElement origin

columns

String[] columns

role

String role

fetch

boolean fetch

isAllPropertyFetch

boolean isAllPropertyFetch

filter

boolean filter

sequence

int sequence

useFromFragment

boolean useFromFragment

initialized

boolean initialized

elementType

FromElementType elementType

useWhereFragment

boolean useWhereFragment

destinations

List destinations

manyToMany

boolean manyToMany

withClauseFragment

String withClauseFragment

withClauseJoinAlias

String withClauseJoinAlias

Class org.hibernate.hql.ast.tree.FromReferenceNode extends AbstractSelectExpression implements Serializable

Serialized Fields

fromElement

FromElement fromElement

resolved

boolean resolved

Class org.hibernate.hql.ast.tree.HqlSqlWalkerNode extends SqlNode implements Serializable

Serialized Fields

walker

HqlSqlWalker walker
A pointer back to the phase 2 processor.

Class org.hibernate.hql.ast.tree.IdentNode extends FromReferenceNode implements Serializable

Serialized Fields

nakedPropertyRef

boolean nakedPropertyRef

Class org.hibernate.hql.ast.tree.ImpliedFromElement extends FromElement implements Serializable

Serialized Fields

impliedInFromClause

boolean impliedInFromClause
True if this from element was implied from a path in the FROM clause, but not explicitly declard in the from clause.

inProjectionList

boolean inProjectionList
True if this implied from element should be included in the projection list.

Class org.hibernate.hql.ast.tree.IndexNode extends FromReferenceNode implements Serializable

Class org.hibernate.hql.ast.tree.InLogicOperatorNode extends BinaryLogicOperatorNode implements Serializable

Class org.hibernate.hql.ast.tree.InsertStatement extends AbstractStatement implements Serializable

Class org.hibernate.hql.ast.tree.IntoClause extends HqlSqlWalkerNode implements Serializable

Serialized Fields

persister

Queryable persister

columnSpec

String columnSpec

types

Type[] types

discriminated

boolean discriminated

explicitIdInsertion

boolean explicitIdInsertion

explicitVersionInsertion

boolean explicitVersionInsertion

Class org.hibernate.hql.ast.tree.JavaConstantNode extends Node implements Serializable

Serialized Fields

factory

SessionFactoryImplementor factory

constantExpression

String constantExpression

constantValue

Object constantValue

heuristicType

Type heuristicType

expectedType

Type expectedType

Class org.hibernate.hql.ast.tree.LiteralNode extends AbstractSelectExpression implements Serializable

Class org.hibernate.hql.ast.tree.MethodNode extends AbstractSelectExpression implements Serializable

Serialized Fields

methodName

String methodName

fromElement

FromElement fromElement

selectColumns

String[] selectColumns

function

SQLFunction function

inSelect

boolean inSelect

Class org.hibernate.hql.ast.tree.Node extends antlr.CommonAST implements Serializable

Serialized Fields

filename

String filename

line

int line

column

int column

textLength

int textLength

Class org.hibernate.hql.ast.tree.OrderByClause extends HqlSqlWalkerNode implements Serializable

Class org.hibernate.hql.ast.tree.ParameterNode extends HqlSqlWalkerNode implements Serializable

Serialized Fields

parameterSpecification

ParameterSpecification parameterSpecification

Class org.hibernate.hql.ast.tree.QueryNode extends AbstractRestrictableStatement implements Serializable

Serialized Fields

orderByClause

OrderByClause orderByClause

alias

String alias

Class org.hibernate.hql.ast.tree.SelectClause extends SelectExpressionList implements Serializable

Serialized Fields

prepared

boolean prepared

scalarSelect

boolean scalarSelect

fromElementsForLoad

List fromElementsForLoad

queryReturnTypes

Type[] queryReturnTypes

columnNames

String[][] columnNames

constructorNode

ConstructorNode constructorNode

collectionFromElements

List collectionFromElements

aliases

String[] aliases

Class org.hibernate.hql.ast.tree.SelectExpressionImpl extends FromReferenceNode implements Serializable

Class org.hibernate.hql.ast.tree.SelectExpressionList extends HqlSqlWalkerNode implements Serializable

Class org.hibernate.hql.ast.tree.SqlFragment extends Node implements Serializable

Serialized Fields

joinFragment

JoinFragment joinFragment

fromElement

FromElement fromElement

Class org.hibernate.hql.ast.tree.SqlNode extends Node implements Serializable

Serialized Fields

originalText

String originalText
The original text for the node, mostly for debugging.

dataType

Type dataType
The data type of this node. Null for 'no type'.

Class org.hibernate.hql.ast.tree.UnaryArithmeticNode extends AbstractSelectExpression implements Serializable

Class org.hibernate.hql.ast.tree.UnaryLogicOperatorNode extends SqlNode implements Serializable

Class org.hibernate.hql.ast.tree.UpdateStatement extends AbstractRestrictableStatement implements Serializable

Package org.hibernate.id

Class org.hibernate.id.IdentifierGenerationException extends HibernateException implements Serializable

Package org.hibernate.impl

Class org.hibernate.impl.AbstractSessionImpl extends Object implements Serializable

Serialized Fields

closed

boolean closed

Class org.hibernate.impl.CriteriaImpl extends Object implements Serializable

Serialized Fields

entityOrClassName

String entityOrClassName

rootAlias

String rootAlias

criterionEntries

List criterionEntries

orderEntries

List orderEntries

projection

Projection projection

projectionCriteria

Criteria projectionCriteria

subcriteriaList

List subcriteriaList

fetchModes

Map fetchModes

lockModes

Map lockModes

maxResults

Integer maxResults

firstResult

Integer firstResult

timeout

Integer timeout

fetchSize

Integer fetchSize

cacheable

boolean cacheable

cacheRegion

String cacheRegion

comment

String comment

flushMode

FlushMode flushMode

cacheMode

CacheMode cacheMode

sessionFlushMode

FlushMode sessionFlushMode

sessionCacheMode

CacheMode sessionCacheMode

resultTransformer

ResultTransformer resultTransformer

Class org.hibernate.impl.CriteriaImpl.CriterionEntry extends Object implements Serializable

Serialized Fields

criterion

Criterion criterion

criteria

Criteria criteria

Class org.hibernate.impl.CriteriaImpl.OrderEntry extends Object implements Serializable

Serialized Fields

order

Order order

criteria

Criteria criteria

Class org.hibernate.impl.CriteriaImpl.Subcriteria extends Object implements Serializable

Serialized Fields

alias

String alias

path

String path

parent

Criteria parent

lockMode

LockMode lockMode

joinType

int joinType

Class org.hibernate.impl.FilterImpl extends Object implements Serializable

Serialized Fields

filterName

String filterName

parameters

Map parameters

Class org.hibernate.impl.SessionFactoryImpl extends Object implements Serializable

Serialization Methods

readObject

private final void readObject(ObjectInputStream in)
                       throws IOException,
                              ClassNotFoundException

writeObject

private final void writeObject(ObjectOutputStream out)
                        throws IOException

readResolve

private Object readResolve()
                    throws ObjectStreamException
Serialized Fields

name

String name

uuid

String uuid

queryPlanCache

QueryPlanCache queryPlanCache

Class org.hibernate.impl.SessionImpl extends AbstractSessionImpl implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
Used by JDK serialization...

Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Used by JDK serialization...

Throws:
IOException

Class org.hibernate.impl.StatelessSessionImpl extends AbstractSessionImpl implements Serializable

Serialized Fields

jdbcContext

JDBCContext jdbcContext

temporaryPersistenceContext

PersistenceContext temporaryPersistenceContext

Package org.hibernate.intercept

Class org.hibernate.intercept.AbstractFieldInterceptor extends Object implements Serializable

Serialized Fields

uninitializedFields

Set uninitializedFields

entityName

String entityName

dirty

boolean dirty

Package org.hibernate.intercept.cglib

Class org.hibernate.intercept.cglib.FieldInterceptorImpl extends AbstractFieldInterceptor implements Serializable

Serialization Methods

readObject

public Object readObject(Object target,
                         String name,
                         Object oldValue)

writeObject

public Object writeObject(Object target,
                          String name,
                          Object oldValue,
                          Object newValue)

Package org.hibernate.intercept.javassist

Class org.hibernate.intercept.javassist.FieldInterceptorImpl extends AbstractFieldInterceptor implements Serializable

Serialization Methods

readObject

public Object readObject(Object target,
                         String name,
                         Object oldValue)

writeObject

public Object writeObject(Object target,
                          String name,
                          Object oldValue,
                          Object newValue)

Package org.hibernate.jdbc

Class org.hibernate.jdbc.BatchedTooManyRowsAffectedException extends TooManyRowsAffectedException implements Serializable

Serialized Fields

batchPosition

int batchPosition

Class org.hibernate.jdbc.BatchFailedException extends HibernateException implements Serializable

Class org.hibernate.jdbc.ConnectionManager extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
Used during deserialization.

Throws:
IOException - Indicates an I/O error reading the stream
ClassNotFoundException - Indicates resource class resolution.

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Used during serialization.

Throws:
IOException - Indicates an I/O error writing to the stream
Serialized Fields

callback

ConnectionManager.Callback callback

releaseMode

ConnectionReleaseMode releaseMode

wasConnectionSupplied

boolean wasConnectionSupplied

isClosed

boolean isClosed

Class org.hibernate.jdbc.JDBCContext extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Serialized Fields

owner

JDBCContext.Context owner

connectionManager

ConnectionManager connectionManager

Class org.hibernate.jdbc.TooManyRowsAffectedException extends HibernateException implements Serializable

Serialized Fields

expectedRowCount

int expectedRowCount

actualRowCount

int actualRowCount

Package org.hibernate.jmx

Class org.hibernate.jmx.SessionFactoryStub extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
                    throws ObjectStreamException
Serialized Fields

uuid

String uuid

name

String name

Package org.hibernate.lob

Class org.hibernate.lob.SerializableBlob extends Object implements Serializable

Class org.hibernate.lob.SerializableClob extends Object implements Serializable

Package org.hibernate.mapping

Class org.hibernate.mapping.AbstractAuxiliaryDatabaseObject extends Object implements Serializable

Serialized Fields

dialectScopes

HashSet dialectScopes

Class org.hibernate.mapping.Any extends SimpleValue implements Serializable

Serialized Fields

identifierTypeName

String identifierTypeName

metaTypeName

String metaTypeName

metaValues

Map metaValues

Class org.hibernate.mapping.Array extends List implements Serializable

Serialized Fields

elementClassName

String elementClassName

Class org.hibernate.mapping.Backref extends Property implements Serializable

Serialized Fields

collectionRole

String collectionRole

entityName

String entityName

Class org.hibernate.mapping.Bag extends Collection implements Serializable

Class org.hibernate.mapping.Collection extends Object implements Serializable

Serialized Fields

key

KeyValue key

element

Value element

collectionTable

Table collectionTable

role

String role

lazy

boolean lazy

extraLazy

boolean extraLazy

inverse

boolean inverse

mutable

boolean mutable

subselectLoadable

boolean subselectLoadable

cacheConcurrencyStrategy

String cacheConcurrencyStrategy

cacheRegionName

String cacheRegionName

orderBy

String orderBy

where

String where

manyToManyWhere

String manyToManyWhere

manyToManyOrderBy

String manyToManyOrderBy

owner

PersistentClass owner

referencedPropertyName

String referencedPropertyName

nodeName

String nodeName

elementNodeName

String elementNodeName

sorted

boolean sorted

comparator

Comparator comparator

comparatorClassName

String comparatorClassName

orphanDelete

boolean orphanDelete

batchSize

int batchSize

fetchMode

FetchMode fetchMode

embedded

boolean embedded

optimisticLocked

boolean optimisticLocked

collectionPersisterClass

Class collectionPersisterClass

typeName

String typeName

filters

Map filters

manyToManyFilters

Map manyToManyFilters

synchronizedTables

Set synchronizedTables

customSQLInsert

String customSQLInsert

customInsertCallable

boolean customInsertCallable

insertCheckStyle

ExecuteUpdateResultCheckStyle insertCheckStyle

customSQLUpdate

String customSQLUpdate

customUpdateCallable

boolean customUpdateCallable

updateCheckStyle

ExecuteUpdateResultCheckStyle updateCheckStyle

customSQLDelete

String customSQLDelete

customDeleteCallable

boolean customDeleteCallable

deleteCheckStyle

ExecuteUpdateResultCheckStyle deleteCheckStyle

customSQLDeleteAll

String customSQLDeleteAll

customDeleteAllCallable

boolean customDeleteAllCallable

deleteAllCheckStyle

ExecuteUpdateResultCheckStyle deleteAllCheckStyle

loaderName

String loaderName

Class org.hibernate.mapping.Column extends Object implements Serializable

Serialized Fields

length

int length

precision

int precision

scale

int scale

value

Value value

typeIndex

int typeIndex

name

String name

nullable

boolean nullable

unique

boolean unique

sqlType

String sqlType

sqlTypeCode

Integer sqlTypeCode

quoted

boolean quoted

uniqueInteger

int uniqueInteger

checkConstraint

String checkConstraint

comment

String comment

defaultValue

String defaultValue

Class org.hibernate.mapping.Component extends SimpleValue implements Serializable

Serialized Fields

properties

ArrayList properties

componentClassName

String componentClassName

embedded

boolean embedded

parentProperty

String parentProperty

owner

PersistentClass owner

dynamic

boolean dynamic

metaAttributes

Map metaAttributes

nodeName

String nodeName

isKey

boolean isKey

roleName

String roleName

tuplizerImpls

Map tuplizerImpls

type

Type type

Class org.hibernate.mapping.Constraint extends Object implements Serializable

Serialized Fields

name

String name

columns

List columns

table

Table table

Class org.hibernate.mapping.DenormalizedTable extends Table implements Serializable

Serialized Fields

includedTable

Table includedTable

Class org.hibernate.mapping.DependantValue extends SimpleValue implements Serializable

Serialized Fields

wrappedValue

KeyValue wrappedValue

nullable

boolean nullable

updateable

boolean updateable

Class org.hibernate.mapping.ForeignKey extends Constraint implements Serializable

Serialized Fields

referencedTable

Table referencedTable

referencedEntityName

String referencedEntityName

cascadeDeleteEnabled

boolean cascadeDeleteEnabled

referencedColumns

List referencedColumns

Class org.hibernate.mapping.Formula extends Object implements Serializable

Serialized Fields

formula

String formula

uniqueInteger

int uniqueInteger

Class org.hibernate.mapping.IdentifierBag extends IdentifierCollection implements Serializable

Class org.hibernate.mapping.IdentifierCollection extends Collection implements Serializable

Serialized Fields

identifier

KeyValue identifier

Class org.hibernate.mapping.Index extends Object implements Serializable

Serialized Fields

table

Table table

columns

List columns

name

String name

Class org.hibernate.mapping.IndexBackref extends Property implements Serializable

Serialized Fields

collectionRole

String collectionRole

entityName

String entityName

Class org.hibernate.mapping.IndexedCollection extends Collection implements Serializable

Serialized Fields

index

Value index

indexNodeName

String indexNodeName

Class org.hibernate.mapping.Join extends Object implements Serializable

Serialized Fields

properties

ArrayList properties

table

Table table

key

KeyValue key

persistentClass

PersistentClass persistentClass

sequentialSelect

boolean sequentialSelect

inverse

boolean inverse

optional

boolean optional

customSQLInsert

String customSQLInsert

customInsertCallable

boolean customInsertCallable

insertCheckStyle

ExecuteUpdateResultCheckStyle insertCheckStyle

customSQLUpdate

String customSQLUpdate

customUpdateCallable

boolean customUpdateCallable

updateCheckStyle

ExecuteUpdateResultCheckStyle updateCheckStyle

customSQLDelete

String customSQLDelete

customDeleteCallable

boolean customDeleteCallable

deleteCheckStyle

ExecuteUpdateResultCheckStyle deleteCheckStyle

Class org.hibernate.mapping.JoinedSubclass extends Subclass implements Serializable

Serialized Fields

table

Table table

key

KeyValue key

Class org.hibernate.mapping.List extends IndexedCollection implements Serializable

Serialized Fields

baseIndex

int baseIndex

Class org.hibernate.mapping.ManyToOne extends ToOne implements Serializable

Serialized Fields

ignoreNotFound

boolean ignoreNotFound

Class org.hibernate.mapping.Map extends IndexedCollection implements Serializable

Class org.hibernate.mapping.MetaAttribute extends Object implements Serializable

Serialized Fields

name

String name

values

List values

Class org.hibernate.mapping.OneToMany extends Object implements Serializable

Serialized Fields

referencedEntityName

String referencedEntityName

referencingTable

Table referencingTable

associatedClass

PersistentClass associatedClass

embedded

boolean embedded

ignoreNotFound

boolean ignoreNotFound

Class org.hibernate.mapping.OneToOne extends ToOne implements Serializable

Serialized Fields

constrained

boolean constrained

foreignKeyType

ForeignKeyDirection foreignKeyType

identifier

KeyValue identifier

propertyName

String propertyName

entityName

String entityName

Class org.hibernate.mapping.PersistentClass extends Object implements Serializable

Serialized Fields

entityName

String entityName

className

String className

proxyInterfaceName

String proxyInterfaceName

nodeName

String nodeName

discriminatorValue

String discriminatorValue

lazy

boolean lazy

properties

ArrayList properties

subclasses

ArrayList subclasses

subclassProperties

ArrayList subclassProperties

subclassTables

ArrayList subclassTables

dynamicInsert

boolean dynamicInsert

dynamicUpdate

boolean dynamicUpdate

batchSize

int batchSize

selectBeforeUpdate

boolean selectBeforeUpdate

metaAttributes

Map metaAttributes

joins

ArrayList joins

subclassJoins

ArrayList subclassJoins

filters

Map filters

synchronizedTables

Set synchronizedTables

loaderName

String loaderName

isAbstract

Boolean isAbstract

hasSubselectLoadableCollections

boolean hasSubselectLoadableCollections

identifierMapper

Component identifierMapper

customSQLInsert

String customSQLInsert

customInsertCallable

boolean customInsertCallable

insertCheckStyle

ExecuteUpdateResultCheckStyle insertCheckStyle

customSQLUpdate

String customSQLUpdate

customUpdateCallable

boolean customUpdateCallable

updateCheckStyle

ExecuteUpdateResultCheckStyle updateCheckStyle

customSQLDelete

String customSQLDelete

customDeleteCallable

boolean customDeleteCallable

deleteCheckStyle

ExecuteUpdateResultCheckStyle deleteCheckStyle

temporaryIdTableName

String temporaryIdTableName

temporaryIdTableDDL

String temporaryIdTableDDL

tuplizerImpls

Map tuplizerImpls

optimisticLockMode

int optimisticLockMode

Class org.hibernate.mapping.PrimaryKey extends Constraint implements Serializable

Class org.hibernate.mapping.PrimitiveArray extends Array implements Serializable

Class org.hibernate.mapping.Property extends Object implements Serializable

Serialized Fields

name

String name

value

Value value

cascade

String cascade

updateable

boolean updateable

insertable

boolean insertable

selectable

boolean selectable

optimisticLocked

boolean optimisticLocked

generation

PropertyGeneration generation

propertyAccessorName

String propertyAccessorName

lazy

boolean lazy

optional

boolean optional

nodeName

String nodeName

metaAttributes

Map metaAttributes

persistentClass

PersistentClass persistentClass

naturalIdentifier

boolean naturalIdentifier

Class org.hibernate.mapping.PropertyGeneration extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

name

String name

Class org.hibernate.mapping.RootClass extends PersistentClass implements Serializable

Serialized Fields

identifierProperty

Property identifierProperty

identifier

KeyValue identifier

version

Property version

polymorphic

boolean polymorphic

cacheConcurrencyStrategy

String cacheConcurrencyStrategy

cacheRegionName

String cacheRegionName

lazyPropertiesCacheable

boolean lazyPropertiesCacheable

discriminator

Value discriminator

mutable

boolean mutable

embeddedIdentifier

boolean embeddedIdentifier

explicitPolymorphism

boolean explicitPolymorphism

entityPersisterClass

Class entityPersisterClass

forceDiscriminator

boolean forceDiscriminator

where

String where

table

Table table

discriminatorInsertable

boolean discriminatorInsertable

nextSubclassId

int nextSubclassId

Class org.hibernate.mapping.Set extends Collection implements Serializable

Class org.hibernate.mapping.SimpleAuxiliaryDatabaseObject extends AbstractAuxiliaryDatabaseObject implements Serializable

Serialized Fields

sqlCreateString

String sqlCreateString

sqlDropString

String sqlDropString

Class org.hibernate.mapping.SimpleValue extends Object implements Serializable

Serialized Fields

columns

List columns

typeName

String typeName

identifierGeneratorProperties

Properties identifierGeneratorProperties

identifierGeneratorStrategy

String identifierGeneratorStrategy

nullValue

String nullValue

table

Table table

foreignKeyName

String foreignKeyName

alternateUniqueKey

boolean alternateUniqueKey

typeParameters

Properties typeParameters

cascadeDeleteEnabled

boolean cascadeDeleteEnabled

Class org.hibernate.mapping.SingleTableSubclass extends Subclass implements Serializable

Class org.hibernate.mapping.Subclass extends PersistentClass implements Serializable

Serialized Fields

superclass

PersistentClass superclass

classPersisterClass

Class classPersisterClass

subclassId

int subclassId

Class org.hibernate.mapping.Table extends Object implements Serializable

Serialized Fields

name

String name

schema

String schema

catalog

String catalog

columns

Map columns
contains all columns, including the primary key

idValue

KeyValue idValue

primaryKey

PrimaryKey primaryKey

indexes

Map indexes

foreignKeys

Map foreignKeys

uniqueKeys

Map uniqueKeys

uniqueInteger

int uniqueInteger

quoted

boolean quoted

schemaQuoted

boolean schemaQuoted

checkConstraints

List checkConstraints

rowId

String rowId

subselect

String subselect

isAbstract

boolean isAbstract

hasDenormalizedTables

boolean hasDenormalizedTables

comment

String comment

Class org.hibernate.mapping.ToOne extends SimpleValue implements Serializable

Serialized Fields

fetchMode

FetchMode fetchMode

referencedPropertyName

String referencedPropertyName

referencedEntityName

String referencedEntityName

embedded

boolean embedded

lazy

boolean lazy

unwrapProxy

boolean unwrapProxy

Class org.hibernate.mapping.TypeDef extends Object implements Serializable

Serialized Fields

typeClass

String typeClass

parameters

Properties parameters

Class org.hibernate.mapping.UnionSubclass extends Subclass implements Serializable

Serialized Fields

table

Table table

key

KeyValue key

Class org.hibernate.mapping.UniqueKey extends Constraint implements Serializable

Package org.hibernate.property

Class org.hibernate.property.BackrefPropertyAccessor.BackrefGetter extends Object implements Serializable

Class org.hibernate.property.BackrefPropertyAccessor.BackrefSetter extends Object implements Serializable

Class org.hibernate.property.BasicPropertyAccessor.BasicGetter extends Object implements Serializable

Serialization Methods

readResolve

Object readResolve()
Serialized Fields

clazz

Class clazz

propertyName

String propertyName

Class org.hibernate.property.BasicPropertyAccessor.BasicSetter extends Object implements Serializable

Serialization Methods

readResolve

Object readResolve()
Serialized Fields

clazz

Class clazz

propertyName

String propertyName

Class org.hibernate.property.DirectPropertyAccessor.DirectGetter extends Object implements Serializable

Serialization Methods

readResolve

Object readResolve()
Serialized Fields

clazz

Class clazz

name

String name

Class org.hibernate.property.DirectPropertyAccessor.DirectSetter extends Object implements Serializable

Serialization Methods

readResolve

Object readResolve()
Serialized Fields

clazz

Class clazz

name

String name

Class org.hibernate.property.Dom4jAccessor.AttributeGetter extends Dom4jAccessor.Dom4jGetter implements Serializable

Serialized Fields

attributeName

String attributeName

Class org.hibernate.property.Dom4jAccessor.AttributeSetter extends Dom4jAccessor.Dom4jSetter implements Serializable

Serialized Fields

attributeName

String attributeName

Class org.hibernate.property.Dom4jAccessor.Dom4jGetter extends Object implements Serializable

Serialized Fields

propertyType

Type propertyType

factory

SessionFactoryImplementor factory

Class org.hibernate.property.Dom4jAccessor.Dom4jSetter extends Object implements Serializable

Serialized Fields

propertyType

Type propertyType

Class org.hibernate.property.Dom4jAccessor.ElementAttributeGetter extends Dom4jAccessor.Dom4jGetter implements Serializable

Serialized Fields

elementName

String elementName

attributeName

String attributeName

Class org.hibernate.property.Dom4jAccessor.ElementAttributeSetter extends Dom4jAccessor.Dom4jSetter implements Serializable

Serialized Fields

elementName

String elementName

attributeName

String attributeName

Class org.hibernate.property.Dom4jAccessor.ElementGetter extends Dom4jAccessor.Dom4jGetter implements Serializable

Serialized Fields

elementName

String elementName

Class org.hibernate.property.Dom4jAccessor.ElementSetter extends Dom4jAccessor.Dom4jSetter implements Serializable

Serialized Fields

elementName

String elementName

Class org.hibernate.property.Dom4jAccessor.TextGetter extends Dom4jAccessor.Dom4jGetter implements Serializable

Class org.hibernate.property.Dom4jAccessor.TextSetter extends Dom4jAccessor.Dom4jSetter implements Serializable

Class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter extends Object implements Serializable

Serialized Fields

clazz

Class clazz

Class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedSetter extends Object implements Serializable

Serialized Fields

clazz

Class clazz

Class org.hibernate.property.IndexPropertyAccessor.IndexGetter extends Object implements Serializable

Class org.hibernate.property.IndexPropertyAccessor.IndexSetter extends Object implements Serializable

Class org.hibernate.property.MapAccessor.MapGetter extends Object implements Serializable

Serialized Fields

name

String name

Class org.hibernate.property.MapAccessor.MapSetter extends Object implements Serializable

Serialized Fields

name

String name

Package org.hibernate.proxy.dom4j

Class org.hibernate.proxy.dom4j.Dom4jLazyInitializer extends AbstractLazyInitializer implements Serializable

Class org.hibernate.proxy.dom4j.Dom4jProxy extends Object implements Serializable

Serialization Methods

writeReplace

public Object writeReplace()
Description copied from interface: HibernateProxy
Perform serialization-time write-replacement of this proxy.

Serialized Fields

li

Dom4jLazyInitializer li

Package org.hibernate.proxy.map

Class org.hibernate.proxy.map.MapLazyInitializer extends AbstractLazyInitializer implements Serializable

Class org.hibernate.proxy.map.MapProxy extends Object implements Serializable

Serialization Methods

writeReplace

public Object writeReplace()
Description copied from interface: HibernateProxy
Perform serialization-time write-replacement of this proxy.

Serialized Fields

li

MapLazyInitializer li

Package org.hibernate.proxy.pojo.cglib

Class org.hibernate.proxy.pojo.cglib.SerializableProxy extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

entityName

String entityName

persistentClass

Class persistentClass

interfaces

Class[] interfaces

id

Serializable id

getIdentifierMethodClass

Class getIdentifierMethodClass

setIdentifierMethodClass

Class setIdentifierMethodClass

getIdentifierMethodName

String getIdentifierMethodName

setIdentifierMethodName

String setIdentifierMethodName

setIdentifierMethodParams

Class[] setIdentifierMethodParams

componentIdType

AbstractComponentType componentIdType

Package org.hibernate.proxy.pojo.javassist

Class org.hibernate.proxy.pojo.javassist.JavassistProxyFactory extends Object implements Serializable

Serialized Fields

persistentClass

Class persistentClass

entityName

String entityName

interfaces

Class[] interfaces

getIdentifierMethod

Method getIdentifierMethod

setIdentifierMethod

Method setIdentifierMethod

componentIdType

AbstractComponentType componentIdType

factory

Class factory

Class org.hibernate.proxy.pojo.javassist.SerializableProxy extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

entityName

String entityName

persistentClass

Class persistentClass

interfaces

Class[] interfaces

id

Serializable id

getIdentifierMethodClass

Class getIdentifierMethodClass

setIdentifierMethodClass

Class setIdentifierMethodClass

getIdentifierMethodName

String getIdentifierMethodName

setIdentifierMethodName

String setIdentifierMethodName

setIdentifierMethodParams

Class[] setIdentifierMethodParams

componentIdType

AbstractComponentType componentIdType

Package org.hibernate.secure

Class org.hibernate.secure.HibernatePermission extends Permission implements Serializable

Serialized Fields

actions

String actions

Class org.hibernate.secure.JACCPreDeleteEventListener extends Object implements Serializable

Serialized Fields

contextID

String contextID

Class org.hibernate.secure.JACCPreInsertEventListener extends Object implements Serializable

Serialized Fields

contextID

String contextID

Class org.hibernate.secure.JACCPreLoadEventListener extends Object implements Serializable

Serialized Fields

contextID

String contextID

Class org.hibernate.secure.JACCPreUpdateEventListener extends Object implements Serializable

Serialized Fields

contextID

String contextID

Package org.hibernate.stat

Class org.hibernate.stat.CategorizedStatistics extends Object implements Serializable

Serialized Fields

categoryName

String categoryName

Class org.hibernate.stat.CollectionStatistics extends CategorizedStatistics implements Serializable

Serialized Fields

loadCount

long loadCount

fetchCount

long fetchCount

updateCount

long updateCount

removeCount

long removeCount

recreateCount

long recreateCount

Class org.hibernate.stat.EntityStatistics extends CategorizedStatistics implements Serializable

Serialized Fields

loadCount

long loadCount

updateCount

long updateCount

insertCount

long insertCount

deleteCount

long deleteCount

fetchCount

long fetchCount

optimisticFailureCount

long optimisticFailureCount

Class org.hibernate.stat.QueryStatistics extends CategorizedStatistics implements Serializable

Serialized Fields

cacheHitCount

long cacheHitCount

cacheMissCount

long cacheMissCount

cachePutCount

long cachePutCount

executionCount

long executionCount

executionRowCount

long executionRowCount

executionAvgTime

long executionAvgTime

executionMaxTime

long executionMaxTime

executionMinTime

long executionMinTime

Class org.hibernate.stat.SecondLevelCacheStatistics extends CategorizedStatistics implements Serializable

Serialized Fields

hitCount

long hitCount

missCount

long missCount

putCount

long putCount

Package org.hibernate.transform

Class org.hibernate.transform.AliasToBeanConstructorResultTransformer extends Object implements Serializable

Serialized Fields

constructor

Constructor constructor

Class org.hibernate.transform.AliasToBeanResultTransformer extends Object implements Serializable

Serialized Fields

resultClass

Class resultClass

setters

Setter[] setters

propertyAccessor

PropertyAccessor propertyAccessor

Class org.hibernate.transform.AliasToEntityMapResultTransformer extends Object implements Serializable

Class org.hibernate.transform.DistinctRootEntityResultTransformer extends Object implements Serializable

Class org.hibernate.transform.PassThroughResultTransformer extends Object implements Serializable

Class org.hibernate.transform.RootEntityResultTransformer extends Object implements Serializable

Class org.hibernate.transform.ToListResultTransformer extends Object implements Serializable

Package org.hibernate.tuple

Class org.hibernate.tuple.Dom4jInstantiator extends Object implements Serializable

Serialized Fields

nodeName

String nodeName

isInstanceNodeNames

HashSet isInstanceNodeNames

Class org.hibernate.tuple.DynamicMapInstantiator extends Object implements Serializable

Serialized Fields

entityName

String entityName

isInstanceEntityNames

Set isInstanceEntityNames

Class org.hibernate.tuple.ElementWrapper extends Object implements Serializable

Serialized Fields

element

org.dom4j.Element element

parent

org.dom4j.Element parent

Class org.hibernate.tuple.EntityModeToTuplizerMapping extends Object implements Serializable

Serialized Fields

tuplizers

Map tuplizers

Class org.hibernate.tuple.IdentifierProperty extends Property implements Serializable

Serialized Fields

virtual

boolean virtual

embedded

boolean embedded

unsavedValue

IdentifierValue unsavedValue

identifierGenerator

IdentifierGenerator identifierGenerator

identifierAssignedByInsert

boolean identifierAssignedByInsert

hasIdentifierMapper

boolean hasIdentifierMapper

Class org.hibernate.tuple.PojoInstantiator extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream stream)
                 throws ClassNotFoundException,
                        IOException
Serialized Fields

mappedClass

Class mappedClass

embeddedIdentifier

boolean embeddedIdentifier

proxyInterface

Class proxyInterface

Class org.hibernate.tuple.Property extends Object implements Serializable

Serialized Fields

name

String name

node

String node

type

Type type

Class org.hibernate.tuple.StandardProperty extends Property implements Serializable

Serialized Fields

lazy

boolean lazy

insertable

boolean insertable

updateable

boolean updateable

insertGenerated

boolean insertGenerated

updateGenerated

boolean updateGenerated

nullable

boolean nullable

dirtyCheckable

boolean dirtyCheckable

versionable

boolean versionable

cascadeStyle

CascadeStyle cascadeStyle

fetchMode

FetchMode fetchMode

Class org.hibernate.tuple.VersionProperty extends StandardProperty implements Serializable

Serialized Fields

unsavedValue

VersionValue unsavedValue

Package org.hibernate.tuple.component

Class org.hibernate.tuple.component.AbstractComponentTuplizer extends Object implements Serializable

Serialized Fields

getters

Getter[] getters

setters

Setter[] setters

propertySpan

int propertySpan

instantiator

Instantiator instantiator

hasCustomAccessors

boolean hasCustomAccessors

Class org.hibernate.tuple.component.ComponentMetamodel extends Object implements Serializable

Serialized Fields

role

String role

isKey

boolean isKey

properties

StandardProperty[] properties

tuplizerMapping

ComponentEntityModeToTuplizerMapping tuplizerMapping

propertySpan

int propertySpan

propertyIndexes

Map propertyIndexes

Class org.hibernate.tuple.component.Dom4jComponentTuplizer extends AbstractComponentTuplizer implements Serializable

Class org.hibernate.tuple.component.DynamicMapComponentTuplizer extends AbstractComponentTuplizer implements Serializable

Class org.hibernate.tuple.component.PojoComponentTuplizer extends AbstractComponentTuplizer implements Serializable

Serialized Fields

componentClass

Class componentClass

optimizer

ReflectionOptimizer optimizer

parentGetter

Getter parentGetter

parentSetter

Setter parentSetter

Package org.hibernate.tuple.entity

Class org.hibernate.tuple.entity.EntityEntityModeToTuplizerMapping extends EntityModeToTuplizerMapping implements Serializable

Class org.hibernate.tuple.entity.EntityMetamodel extends Object implements Serializable

Serialized Fields

sessionFactory

SessionFactoryImplementor sessionFactory

name

String name

rootName

String rootName

entityType

EntityType entityType

identifierProperty

IdentifierProperty identifierProperty

versioned

boolean versioned

propertySpan

int propertySpan

versionPropertyIndex

int versionPropertyIndex

properties

StandardProperty[] properties

propertyNames

String[] propertyNames

propertyTypes

Type[] propertyTypes

propertyLaziness

boolean[] propertyLaziness

propertyUpdateability

boolean[] propertyUpdateability

nonlazyPropertyUpdateability

boolean[] nonlazyPropertyUpdateability

propertyCheckability

boolean[] propertyCheckability

propertyInsertability

boolean[] propertyInsertability

propertyInsertGeneration

boolean[] propertyInsertGeneration

propertyUpdateGeneration

boolean[] propertyUpdateGeneration

propertyNullability

boolean[] propertyNullability

propertyVersionability

boolean[] propertyVersionability

cascadeStyles

CascadeStyle[] cascadeStyles

propertyIndexes

Map propertyIndexes

hasCollections

boolean hasCollections

hasMutableProperties

boolean hasMutableProperties

hasLazyProperties

boolean hasLazyProperties

naturalIdPropertyNumbers

int[] naturalIdPropertyNumbers

lazy

boolean lazy

hasCascades

boolean hasCascades

mutable

boolean mutable

isAbstract

boolean isAbstract

selectBeforeUpdate

boolean selectBeforeUpdate

dynamicUpdate

boolean dynamicUpdate

dynamicInsert

boolean dynamicInsert

optimisticLockMode

int optimisticLockMode

polymorphic

boolean polymorphic

superclass

String superclass

explicitPolymorphism

boolean explicitPolymorphism

inherited

boolean inherited

hasSubclasses

boolean hasSubclasses

subclassEntityNames

Set subclassEntityNames

tuplizerMapping

EntityEntityModeToTuplizerMapping tuplizerMapping

Package org.hibernate.type

Class org.hibernate.type.AbstractBynaryType extends MutableType implements Serializable

Class org.hibernate.type.AbstractCharArrayType extends MutableType implements Serializable

Class org.hibernate.type.AbstractType extends Object implements Serializable

Class org.hibernate.type.AdaptedImmutableType extends ImmutableType implements Serializable

Serialized Fields

mutableType

NullableType mutableType

Class org.hibernate.type.AnyType extends AbstractType implements Serializable

Serialized Fields

identifierType

Type identifierType

metaType

Type metaType

Class org.hibernate.type.AnyType.ObjectTypeCacheEntry extends Object implements Serializable

Serialized Fields

entityName

String entityName

id

Serializable id

Class org.hibernate.type.ArrayType extends CollectionType implements Serializable

Serialized Fields

elementClass

Class elementClass

arrayClass

Class arrayClass

Class org.hibernate.type.BagType extends CollectionType implements Serializable

Class org.hibernate.type.BigDecimalType extends ImmutableType implements Serializable

Class org.hibernate.type.BigIntegerType extends ImmutableType implements Serializable

Class org.hibernate.type.BinaryType extends AbstractBynaryType implements Serializable

Class org.hibernate.type.BlobType extends AbstractType implements Serializable

Class org.hibernate.type.BooleanType extends PrimitiveType implements Serializable

Class org.hibernate.type.ByteType extends PrimitiveType implements Serializable

Class org.hibernate.type.CalendarDateType extends MutableType implements Serializable

Class org.hibernate.type.CalendarType extends MutableType implements Serializable

Class org.hibernate.type.CharacterArrayType extends AbstractCharArrayType implements Serializable

Class org.hibernate.type.CharacterType extends PrimitiveType implements Serializable

Class org.hibernate.type.CharArrayType extends AbstractCharArrayType implements Serializable

Class org.hibernate.type.CharBooleanType extends BooleanType implements Serializable

Class org.hibernate.type.ClassType extends ImmutableType implements Serializable

Class org.hibernate.type.ClobType extends AbstractType implements Serializable

Class org.hibernate.type.CollectionType extends AbstractType implements Serializable

Serialized Fields

role

String role

foreignKeyPropertyName

String foreignKeyPropertyName

isEmbeddedInXML

boolean isEmbeddedInXML

Class org.hibernate.type.ComponentType extends AbstractType implements Serializable

Serialized Fields

propertyNames

String[] propertyNames

propertyTypes

Type[] propertyTypes

propertyNullability

boolean[] propertyNullability

propertySpan

int propertySpan

cascade

CascadeStyle[] cascade

joinedFetch

FetchMode[] joinedFetch

isKey

boolean isKey

tuplizerMapping

EntityModeToTuplizerMapping tuplizerMapping

Class org.hibernate.type.CompositeCustomType extends AbstractType implements Serializable

Serialized Fields

userType

CompositeUserType userType

name

String name

Class org.hibernate.type.CurrencyType extends ImmutableType implements Serializable

Class org.hibernate.type.CustomCollectionType extends CollectionType implements Serializable

Serialized Fields

userType

UserCollectionType userType

customLogging

boolean customLogging

Class org.hibernate.type.CustomType extends AbstractType implements Serializable

Serialized Fields

userType

UserType userType

name

String name

types

int[] types

customLogging

boolean customLogging

Class org.hibernate.type.DateType extends MutableType implements Serializable

Class org.hibernate.type.DbTimestampType extends TimestampType implements Serializable

Class org.hibernate.type.DoubleType extends PrimitiveType implements Serializable

Class org.hibernate.type.EmbeddedComponentType extends ComponentType implements Serializable

Class org.hibernate.type.EntityType extends AbstractType implements Serializable

Serialized Fields

associatedEntityName

String associatedEntityName

uniqueKeyPropertyName

String uniqueKeyPropertyName

isEmbeddedInXML

boolean isEmbeddedInXML

eager

boolean eager

unwrapProxy

boolean unwrapProxy

Class org.hibernate.type.FloatType extends PrimitiveType implements Serializable

Class org.hibernate.type.ForeignKeyDirection extends Object implements Serializable

Class org.hibernate.type.IdentifierBagType extends CollectionType implements Serializable

Class org.hibernate.type.ImmutableType extends NullableType implements Serializable

Class org.hibernate.type.IntegerType extends PrimitiveType implements Serializable

Class org.hibernate.type.ListType extends CollectionType implements Serializable

Class org.hibernate.type.LocaleType extends ImmutableType implements Serializable

Class org.hibernate.type.LongType extends PrimitiveType implements Serializable

Class org.hibernate.type.ManyToOneType extends EntityType implements Serializable

Serialized Fields

ignoreNotFound

boolean ignoreNotFound

Class org.hibernate.type.MapType extends CollectionType implements Serializable

Class org.hibernate.type.MetaType extends AbstractType implements Serializable

Serialized Fields

values

Map values

keys

Map keys

baseType

Type baseType

Class org.hibernate.type.MutableType extends NullableType implements Serializable

Class org.hibernate.type.NullableType extends AbstractType implements Serializable

Class org.hibernate.type.OneToOneType extends EntityType implements Serializable

Serialized Fields

foreignKeyType

ForeignKeyDirection foreignKeyType

propertyName

String propertyName

entityName

String entityName

Class org.hibernate.type.OrderedMapType extends MapType implements Serializable

Class org.hibernate.type.OrderedSetType extends SetType implements Serializable

Class org.hibernate.type.PrimitiveType extends ImmutableType implements Serializable

Class org.hibernate.type.SerializableType extends MutableType implements Serializable

Serialized Fields

serializableClass

Class serializableClass

Class org.hibernate.type.SerializationException extends HibernateException implements Serializable

Class org.hibernate.type.SetType extends CollectionType implements Serializable

Class org.hibernate.type.ShortType extends PrimitiveType implements Serializable

Class org.hibernate.type.SortedMapType extends MapType implements Serializable

Serialized Fields

comparator

Comparator comparator

Class org.hibernate.type.SortedSetType extends SetType implements Serializable

Serialized Fields

comparator

Comparator comparator

Class org.hibernate.type.SpecialOneToOneType extends OneToOneType implements Serializable

Class org.hibernate.type.StringType extends ImmutableType implements Serializable

Class org.hibernate.type.TextType extends ImmutableType implements Serializable

Class org.hibernate.type.TimestampType extends MutableType implements Serializable

Class org.hibernate.type.TimeType extends MutableType implements Serializable

Class org.hibernate.type.TimeZoneType extends ImmutableType implements Serializable

Class org.hibernate.type.TrueFalseType extends CharBooleanType implements Serializable

Class org.hibernate.type.WrapperBinaryType extends AbstractBynaryType implements Serializable

Class org.hibernate.type.YesNoType extends CharBooleanType implements Serializable

Package org.hibernate.util

Class org.hibernate.util.DTDEntityResolver extends Object implements Serializable

Class org.hibernate.util.FastHashMap extends Object implements Serializable

Serialized Fields

map

HashMap map
The underlying map we are managing.

Class org.hibernate.util.IdentityMap.IdentityKey extends Object implements Serializable

Serialized Fields

key

Object key

Class org.hibernate.util.SimpleMRUCache extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Serialized Fields

strongReferenceCount

int strongReferenceCount

Class org.hibernate.util.SoftLimitMRUCache extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Serialized Fields

strongReferenceCount

int strongReferenceCount

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate (Hibernate API Documentation)

 org.hibernate
Interfaces
Criteria
Filter
Interceptor
Query
ScrollableResults
Session
SessionFactory
SQLQuery
StatelessSession
Transaction
Classes
CacheMode
ConnectionReleaseMode
EmptyInterceptor
EntityMode
FetchMode
FlushMode
Hibernate
LockMode
ReplicationMode
ScrollMode
Exceptions
AssertionFailure
CallbackException
DuplicateMappingException
HibernateException
InstantiationException
InvalidMappingException
JDBCException
LazyInitializationException
MappingException
MappingNotFoundException
NonUniqueObjectException
NonUniqueResultException
ObjectDeletedException
ObjectNotFoundException
PersistentObjectException
PropertyAccessException
PropertyNotFoundException
PropertyValueException
QueryException
QueryParameterException
SessionException
StaleObjectStateException
StaleStateException
TransactionException
TransientObjectException
TypeMismatchException
UnresolvableObjectException
WrongClassException


org.hibernate.action (Hibernate API Documentation)

 org.hibernate.action
Interfaces
Executable
Classes
BulkOperationCleanupAction
CollectionAction
CollectionRecreateAction
CollectionRemoveAction
CollectionUpdateAction
DelayedPostInsertIdentifier
EntityAction
EntityDeleteAction
EntityIdentityInsertAction
EntityInsertAction
EntityUpdateAction


Uses of Class org.hibernate.action.BulkOperationCleanupAction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.action.BulkOperationCleanupAction

Packages that use BulkOperationCleanupAction
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of BulkOperationCleanupAction in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type BulkOperationCleanupAction
 void ActionQueue.addAction(BulkOperationCleanupAction cleanupAction)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.action.CollectionAction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.action.CollectionAction

Packages that use CollectionAction
org.hibernate.action This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.

Uses of CollectionAction in org.hibernate.action

Subclasses of CollectionAction in org.hibernate.action
class | CollectionRecreateAction
class | CollectionRemoveAction
class | CollectionUpdateAction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.action.CollectionRecreateAction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.action.CollectionRecreateAction

Packages that use CollectionRecreateAction
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of CollectionRecreateAction in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type CollectionRecreateAction
 void ActionQueue.addAction(CollectionRecreateAction action)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.action.CollectionRemoveAction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.action.CollectionRemoveAction

Packages that use CollectionRemoveAction
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of CollectionRemoveAction in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type CollectionRemoveAction
 void ActionQueue.addAction(CollectionRemoveAction action)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.action.CollectionUpdateAction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.action.CollectionUpdateAction

Packages that use CollectionUpdateAction
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of CollectionUpdateAction in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type CollectionUpdateAction
 void ActionQueue.addAction(CollectionUpdateAction action)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.action.DelayedPostInsertIdentifier (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.action.DelayedPostInsertIdentifier

No usage of org.hibernate.action.DelayedPostInsertIdentifier

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.action.EntityAction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.action.EntityAction

Packages that use EntityAction
org.hibernate.action This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.

Uses of EntityAction in org.hibernate.action

Subclasses of EntityAction in org.hibernate.action
class | EntityDeleteAction
class | EntityIdentityInsertAction
class | EntityInsertAction
class | EntityUpdateAction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.action.EntityDeleteAction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.action.EntityDeleteAction

Packages that use EntityDeleteAction
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of EntityDeleteAction in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type EntityDeleteAction
 void ActionQueue.addAction(EntityDeleteAction action)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.action.EntityIdentityInsertAction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.action.EntityIdentityInsertAction

Packages that use EntityIdentityInsertAction
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of EntityIdentityInsertAction in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type EntityIdentityInsertAction
 void ActionQueue.addAction(EntityIdentityInsertAction insert)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.action.EntityInsertAction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.action.EntityInsertAction

Packages that use EntityInsertAction
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of EntityInsertAction in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type EntityInsertAction
 void ActionQueue.addAction(EntityInsertAction action)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.action.EntityUpdateAction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.action.EntityUpdateAction

Packages that use EntityUpdateAction
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of EntityUpdateAction in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type EntityUpdateAction
 void ActionQueue.addAction(EntityUpdateAction action)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.action.Executable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.action.Executable

Packages that use Executable
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of Executable in org.hibernate.action

Classes in org.hibernate.action that implement Executable
class | BulkOperationCleanupAction Implementation of BulkOperationCleanupAction.
class | CollectionAction Any action relating to insert/update/delete of a collection
class | CollectionRecreateAction
class | CollectionRemoveAction
class | CollectionUpdateAction
class | EntityAction Any action relating to insert/update/delete of an entity instance
class | EntityDeleteAction
class | EntityIdentityInsertAction
class | EntityInsertAction
class | EntityUpdateAction

Uses of Executable in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type Executable
 void ActionQueue.execute(Executable executable)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.bytecode (Hibernate API Documentation)

 org.hibernate.bytecode
Interfaces
BasicProxyFactory
BytecodeProvider
ClassTransformer
ProxyFactoryFactory
ReflectionOptimizer
ReflectionOptimizer.AccessOptimizer
ReflectionOptimizer.InstantiationOptimizer
Classes
AbstractClassTransformerImpl
InstrumentedClassLoader


org.hibernate.bytecode.cglib (Hibernate API Documentation)

 org.hibernate.bytecode.cglib
Classes
AccessOptimizerAdapter
BytecodeProviderImpl
CglibClassTransformer
InstantiationOptimizerAdapter
ProxyFactoryFactoryImpl
ProxyFactoryFactoryImpl.BasicProxyFactoryImpl
ReflectionOptimizerImpl


Uses of Class org.hibernate.bytecode.cglib.AccessOptimizerAdapter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.cglib.AccessOptimizerAdapter

Packages that use AccessOptimizerAdapter
org.hibernate.bytecode.cglib

Uses of AccessOptimizerAdapter in org.hibernate.bytecode.cglib

Constructors in org.hibernate.bytecode.cglib with parameters of type AccessOptimizerAdapter
ReflectionOptimizerImpl(InstantiationOptimizerAdapter instantiationOptimizer, AccessOptimizerAdapter accessOptimizer)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.cglib.BytecodeProviderImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.cglib.BytecodeProviderImpl

No usage of org.hibernate.bytecode.cglib.BytecodeProviderImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.cglib.CglibClassTransformer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.cglib.CglibClassTransformer

No usage of org.hibernate.bytecode.cglib.CglibClassTransformer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.cglib.InstantiationOptimizerAdapter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.cglib.InstantiationOptimizerAdapter

Packages that use InstantiationOptimizerAdapter
org.hibernate.bytecode.cglib

Uses of InstantiationOptimizerAdapter in org.hibernate.bytecode.cglib

Constructors in org.hibernate.bytecode.cglib with parameters of type InstantiationOptimizerAdapter
ReflectionOptimizerImpl(InstantiationOptimizerAdapter instantiationOptimizer, AccessOptimizerAdapter accessOptimizer)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl

No usage of org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl.BasicProxyFactoryImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl.BasicProxyFactoryImpl

No usage of org.hibernate.bytecode.cglib.ProxyFactoryFactoryImpl.BasicProxyFactoryImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.cglib.ReflectionOptimizerImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.cglib.ReflectionOptimizerImpl

No usage of org.hibernate.bytecode.cglib.ReflectionOptimizerImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.AbstractClassTransformerImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.AbstractClassTransformerImpl

Packages that use AbstractClassTransformerImpl
org.hibernate.bytecode.cglib
org.hibernate.bytecode.javassist

Uses of AbstractClassTransformerImpl in org.hibernate.bytecode.cglib

Subclasses of AbstractClassTransformerImpl in org.hibernate.bytecode.cglib
 class CglibClassTransformer
Enhance the classes allowing them to implements InterceptFieldEnabled This interface is then used by Hibernate for some optimizations.

Uses of AbstractClassTransformerImpl in org.hibernate.bytecode.javassist

Subclasses of AbstractClassTransformerImpl in org.hibernate.bytecode.javassist
 class JavassistClassTransformer
Enhance the classes allowing them to implements InterceptFieldEnabled This interface is then used by Hibernate for some optimizations.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.BasicProxyFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.BasicProxyFactory

Packages that use BasicProxyFactory
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.bytecode.javassist |

Uses of BasicProxyFactory in org.hibernate.bytecode

Methods in org.hibernate.bytecode that return BasicProxyFactory
 BasicProxyFactory ProxyFactoryFactory.buildBasicProxyFactory(Class superClass, Class[] interfaces)
Build a proxy factory for basic proxy concerns.

Uses of BasicProxyFactory in org.hibernate.bytecode.cglib

Classes in org.hibernate.bytecode.cglib that implement BasicProxyFactory
static class ProxyFactoryFactoryImpl.BasicProxyFactoryImpl

Methods in org.hibernate.bytecode.cglib that return BasicProxyFactory
 BasicProxyFactory ProxyFactoryFactoryImpl.buildBasicProxyFactory(Class superClass, Class[] interfaces)

Uses of BasicProxyFactory in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist that return BasicProxyFactory
 BasicProxyFactory ProxyFactoryFactoryImpl.buildBasicProxyFactory(Class superClass, Class[] interfaces)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.BytecodeProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.BytecodeProvider

Packages that use BytecodeProvider
org.hibernate.bytecode.cglib |
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of BytecodeProvider in org.hibernate.bytecode.cglib

Classes in org.hibernate.bytecode.cglib that implement BytecodeProvider
 class BytecodeProviderImpl
Bytecode provider implementation for CGLIB.

Uses of BytecodeProvider in org.hibernate.cfg

Methods in org.hibernate.cfg that return BytecodeProvider
protected BytecodeProvider | SettingsFactory.buildBytecodeProvider(String providerName)
static BytecodeProvider | Environment.getBytecodeProvider()
static BytecodeProvider | Environment.buildBytecodeProvider(Properties properties)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.ClassTransformer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.ClassTransformer

Packages that use ClassTransformer
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.bytecode.javassist |
org.hibernate.tool.instrument | The instrument tool for adding field-interception hooks to persistent classes using built-time bytecode processing.
org.hibernate.tool.instrument.cglib |
org.hibernate.tool.instrument.javassist |

Uses of ClassTransformer in org.hibernate.bytecode

Classes in org.hibernate.bytecode that implement ClassTransformer
 class AbstractClassTransformerImpl

Methods in org.hibernate.bytecode that return ClassTransformer
 ClassTransformer BytecodeProvider.getTransformer(ClassFilter classFilter, FieldFilter fieldFilter)
Generate a ClassTransformer capable of performing bytecode manipulation.

Constructors in org.hibernate.bytecode with parameters of type ClassTransformer
InstrumentedClassLoader(ClassLoader parent, ClassTransformer classTransformer)

Uses of ClassTransformer in org.hibernate.bytecode.cglib

Classes in org.hibernate.bytecode.cglib that implement ClassTransformer
 class CglibClassTransformer
Enhance the classes allowing them to implements InterceptFieldEnabled This interface is then used by Hibernate for some optimizations.

Methods in org.hibernate.bytecode.cglib that return ClassTransformer
 ClassTransformer BytecodeProviderImpl.getTransformer(ClassFilter classFilter, FieldFilter fieldFilter)

Uses of ClassTransformer in org.hibernate.bytecode.javassist

Classes in org.hibernate.bytecode.javassist that implement ClassTransformer
 class JavassistClassTransformer
Enhance the classes allowing them to implements InterceptFieldEnabled This interface is then used by Hibernate for some optimizations.

Methods in org.hibernate.bytecode.javassist that return ClassTransformer
 ClassTransformer BytecodeProviderImpl.getTransformer(ClassFilter classFilter, FieldFilter fieldFilter)

Uses of ClassTransformer in org.hibernate.tool.instrument

Methods in org.hibernate.tool.instrument that return ClassTransformer
protected abstract  ClassTransformer BasicInstrumentationTask.getClassTransformer(ClassDescriptor descriptor)

Uses of ClassTransformer in org.hibernate.tool.instrument.cglib

Methods in org.hibernate.tool.instrument.cglib that return ClassTransformer
protected  ClassTransformer InstrumentTask.getClassTransformer(ClassDescriptor descriptor)

Uses of ClassTransformer in org.hibernate.tool.instrument.javassist

Methods in org.hibernate.tool.instrument.javassist that return ClassTransformer
protected  ClassTransformer InstrumentTask.getClassTransformer(ClassDescriptor descriptor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.InstrumentedClassLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.InstrumentedClassLoader

No usage of org.hibernate.bytecode.InstrumentedClassLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.ProxyFactoryFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.ProxyFactoryFactory

Packages that use ProxyFactoryFactory
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.bytecode.javassist |

Uses of ProxyFactoryFactory in org.hibernate.bytecode

Methods in org.hibernate.bytecode that return ProxyFactoryFactory
 ProxyFactoryFactory BytecodeProvider.getProxyFactoryFactory()
Retrieve the specific factory for this provider capable of generating run-time proxies for lazy-loading purposes.

Uses of ProxyFactoryFactory in org.hibernate.bytecode.cglib

Classes in org.hibernate.bytecode.cglib that implement ProxyFactoryFactory
 class ProxyFactoryFactoryImpl
A factory for CGLIB-based ProxyFactory instances.

Methods in org.hibernate.bytecode.cglib that return ProxyFactoryFactory
 ProxyFactoryFactory BytecodeProviderImpl.getProxyFactoryFactory()

Uses of ProxyFactoryFactory in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist that return ProxyFactoryFactory
 ProxyFactoryFactory BytecodeProviderImpl.getProxyFactoryFactory()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.ReflectionOptimizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.ReflectionOptimizer

Packages that use ReflectionOptimizer
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.bytecode.javassist |

Uses of ReflectionOptimizer in org.hibernate.bytecode

Methods in org.hibernate.bytecode that return ReflectionOptimizer
 ReflectionOptimizer BytecodeProvider.getReflectionOptimizer(Class clazz, String[] getterNames, String[] setterNames, Class[] types)
Retrieve the ReflectionOptimizer delegate for this provider capable of generating reflection optimization components.

Uses of ReflectionOptimizer in org.hibernate.bytecode.cglib

Classes in org.hibernate.bytecode.cglib that implement ReflectionOptimizer
 class ReflectionOptimizerImpl
ReflectionOptimizer implementation for CGLIB.

Methods in org.hibernate.bytecode.cglib that return ReflectionOptimizer
 ReflectionOptimizer BytecodeProviderImpl.getReflectionOptimizer(Class clazz, String[] getterNames, String[] setterNames, Class[] types)

Uses of ReflectionOptimizer in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist that return ReflectionOptimizer
 ReflectionOptimizer BytecodeProviderImpl.getReflectionOptimizer(Class clazz, String[] getterNames, String[] setterNames, Class[] types)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.ReflectionOptimizer.AccessOptimizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.ReflectionOptimizer.AccessOptimizer

Packages that use ReflectionOptimizer.AccessOptimizer
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.bytecode.javassist |

Uses of ReflectionOptimizer.AccessOptimizer in org.hibernate.bytecode

Methods in org.hibernate.bytecode that return ReflectionOptimizer.AccessOptimizer
 ReflectionOptimizer.AccessOptimizer ReflectionOptimizer.getAccessOptimizer()

Uses of ReflectionOptimizer.AccessOptimizer in org.hibernate.bytecode.cglib

Classes in org.hibernate.bytecode.cglib that implement ReflectionOptimizer.AccessOptimizer
 class AccessOptimizerAdapter
The ReflectionOptimizer.AccessOptimizer implementation for CGLIB which simply acts as an adpater to the BulkBean class.

Methods in org.hibernate.bytecode.cglib that return ReflectionOptimizer.AccessOptimizer
 ReflectionOptimizer.AccessOptimizer ReflectionOptimizerImpl.getAccessOptimizer()

Uses of ReflectionOptimizer.AccessOptimizer in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist that return ReflectionOptimizer.AccessOptimizer
 ReflectionOptimizer.AccessOptimizer ReflectionOptimizerImpl.getAccessOptimizer()

Constructors in org.hibernate.bytecode.javassist with parameters of type ReflectionOptimizer.AccessOptimizer
ReflectionOptimizerImpl(ReflectionOptimizer.InstantiationOptimizer instantiationOptimizer, ReflectionOptimizer.AccessOptimizer accessOptimizer)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.ReflectionOptimizer.InstantiationOptimizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.ReflectionOptimizer.InstantiationOptimizer

Packages that use ReflectionOptimizer.InstantiationOptimizer
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.bytecode.javassist |
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.

Uses of ReflectionOptimizer.InstantiationOptimizer in org.hibernate.bytecode

Methods in org.hibernate.bytecode that return ReflectionOptimizer.InstantiationOptimizer
 ReflectionOptimizer.InstantiationOptimizer ReflectionOptimizer.getInstantiationOptimizer()

Uses of ReflectionOptimizer.InstantiationOptimizer in org.hibernate.bytecode.cglib

Classes in org.hibernate.bytecode.cglib that implement ReflectionOptimizer.InstantiationOptimizer
 class InstantiationOptimizerAdapter
The ReflectionOptimizer.InstantiationOptimizer implementation for CGLIB which simply acts as an adpater to the FastClass class.

Methods in org.hibernate.bytecode.cglib that return ReflectionOptimizer.InstantiationOptimizer
 ReflectionOptimizer.InstantiationOptimizer ReflectionOptimizerImpl.getInstantiationOptimizer()

Uses of ReflectionOptimizer.InstantiationOptimizer in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist that return ReflectionOptimizer.InstantiationOptimizer
 ReflectionOptimizer.InstantiationOptimizer ReflectionOptimizerImpl.getInstantiationOptimizer()

Constructors in org.hibernate.bytecode.javassist with parameters of type ReflectionOptimizer.InstantiationOptimizer
ReflectionOptimizerImpl(ReflectionOptimizer.InstantiationOptimizer instantiationOptimizer, ReflectionOptimizer.AccessOptimizer accessOptimizer)

Uses of ReflectionOptimizer.InstantiationOptimizer in org.hibernate.tuple

Constructors in org.hibernate.tuple with parameters of type ReflectionOptimizer.InstantiationOptimizer
PojoInstantiator(Component component, ReflectionOptimizer.InstantiationOptimizer optimizer)
PojoInstantiator(PersistentClass persistentClass, ReflectionOptimizer.InstantiationOptimizer optimizer)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.bytecode.javassist (Hibernate API Documentation)

 org.hibernate.bytecode.javassist
Interfaces
FieldFilter
FieldHandled
FieldHandler
Classes
AccessOptimizerAdapter
BulkAccessor
BytecodeProviderImpl
FastClass
FieldTransformer
InstantiationOptimizerAdapter
JavassistClassTransformer
ProxyFactoryFactoryImpl
ReflectionOptimizerImpl
TransformingClassLoader
Exceptions
BulkAccessorException


Uses of Class org.hibernate.bytecode.javassist.AccessOptimizerAdapter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.javassist.AccessOptimizerAdapter

No usage of org.hibernate.bytecode.javassist.AccessOptimizerAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.javassist.BulkAccessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.javassist.BulkAccessor

Packages that use BulkAccessor
org.hibernate.bytecode.javassist

Uses of BulkAccessor in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist that return BulkAccessor
static BulkAccessor BulkAccessor.create(Class beanClass, String[] getters, String[] setters, Class[] types)
Creates a new instance of BulkAccessor.

Constructors in org.hibernate.bytecode.javassist with parameters of type BulkAccessor
AccessOptimizerAdapter(BulkAccessor bulkAccessor, Class mappedClass)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.javassist.BulkAccessorException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.javassist.BulkAccessorException

No usage of org.hibernate.bytecode.javassist.BulkAccessorException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.javassist.BytecodeProviderImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.javassist.BytecodeProviderImpl

No usage of org.hibernate.bytecode.javassist.BytecodeProviderImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.javassist.FastClass (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.javassist.FastClass

Packages that use FastClass
org.hibernate.bytecode.javassist

Uses of FastClass in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist that return FastClass
static FastClass FastClass.create(Class type)

Constructors in org.hibernate.bytecode.javassist with parameters of type FastClass
InstantiationOptimizerAdapter(FastClass fastClass)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.javassist.FieldFilter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.javassist.FieldFilter

Packages that use FieldFilter
org.hibernate.bytecode.javassist

Uses of FieldFilter in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist with parameters of type FieldFilter
 void FieldTransformer.setFieldFilter(FieldFilter f)

Constructors in org.hibernate.bytecode.javassist with parameters of type FieldFilter
FieldTransformer(FieldFilter f)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.javassist.FieldHandled (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.javassist.FieldHandled

No usage of org.hibernate.bytecode.javassist.FieldHandled

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.javassist.FieldHandler (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.javassist.FieldHandler

Packages that use FieldHandler
org.hibernate.bytecode.javassist
org.hibernate.intercept.javassist

Uses of FieldHandler in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist that return FieldHandler
 FieldHandler FieldHandled.getFieldHandler()
Access to the current field interception handler.

Methods in org.hibernate.bytecode.javassist with parameters of type FieldHandler
 void FieldHandled.setFieldHandler(FieldHandler handler)
Inject the field interception handler to be used.

Uses of FieldHandler in org.hibernate.intercept.javassist

Classes in org.hibernate.intercept.javassist that implement FieldHandler
 class FieldInterceptorImpl
A field-level interceptor that initializes lazily fetched properties.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.javassist.FieldTransformer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.javassist.FieldTransformer

Packages that use FieldTransformer
org.hibernate.bytecode.javassist

Uses of FieldTransformer in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist that return FieldTransformer
protected  FieldTransformer JavassistClassTransformer.getFieldTransformer(javassist.bytecode.ClassFile classfile)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.javassist.InstantiationOptimizerAdapter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.javassist.InstantiationOptimizerAdapter

No usage of org.hibernate.bytecode.javassist.InstantiationOptimizerAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.javassist.JavassistClassTransformer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.javassist.JavassistClassTransformer

No usage of org.hibernate.bytecode.javassist.JavassistClassTransformer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.javassist.ProxyFactoryFactoryImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.javassist.ProxyFactoryFactoryImpl

No usage of org.hibernate.bytecode.javassist.ProxyFactoryFactoryImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.javassist.ReflectionOptimizerImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.javassist.ReflectionOptimizerImpl

No usage of org.hibernate.bytecode.javassist.ReflectionOptimizerImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.javassist.TransformingClassLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.javassist.TransformingClassLoader

No usage of org.hibernate.bytecode.javassist.TransformingClassLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.bytecode.util (Hibernate API Documentation)

 org.hibernate.bytecode.util
Interfaces
ClassDescriptor
ClassFilter
FieldFilter
Classes
BasicClassFilter
ByteCodeHelper


Uses of Class org.hibernate.bytecode.util.BasicClassFilter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.util.BasicClassFilter

No usage of org.hibernate.bytecode.util.BasicClassFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.bytecode.util.ByteCodeHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.bytecode.util.ByteCodeHelper

No usage of org.hibernate.bytecode.util.ByteCodeHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.util.ClassDescriptor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.util.ClassDescriptor

Packages that use ClassDescriptor
org.hibernate.tool.instrument | The instrument tool for adding field-interception hooks to persistent classes using built-time bytecode processing.
org.hibernate.tool.instrument.cglib |
org.hibernate.tool.instrument.javassist |

Uses of ClassDescriptor in org.hibernate.tool.instrument

Methods in org.hibernate.tool.instrument that return ClassDescriptor
protected abstract  ClassDescriptor BasicInstrumentationTask.getClassDescriptor(byte[] byecode)

Methods in org.hibernate.tool.instrument with parameters of type ClassDescriptor
protected abstract  ClassTransformer BasicInstrumentationTask.getClassTransformer(ClassDescriptor descriptor)

Constructors in org.hibernate.tool.instrument with parameters of type ClassDescriptor
BasicInstrumentationTask.CustomFieldFilter(ClassDescriptor descriptor)

Uses of ClassDescriptor in org.hibernate.tool.instrument.cglib

Methods in org.hibernate.tool.instrument.cglib that return ClassDescriptor
protected  ClassDescriptor InstrumentTask.getClassDescriptor(byte[] byecode)

Methods in org.hibernate.tool.instrument.cglib with parameters of type ClassDescriptor
protected  ClassTransformer InstrumentTask.getClassTransformer(ClassDescriptor descriptor)

Uses of ClassDescriptor in org.hibernate.tool.instrument.javassist

Methods in org.hibernate.tool.instrument.javassist that return ClassDescriptor
protected  ClassDescriptor InstrumentTask.getClassDescriptor(byte[] bytecode)

Methods in org.hibernate.tool.instrument.javassist with parameters of type ClassDescriptor
protected  ClassTransformer InstrumentTask.getClassTransformer(ClassDescriptor descriptor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.util.ClassFilter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.util.ClassFilter

Packages that use ClassFilter
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.bytecode.javassist |
org.hibernate.bytecode.util |

Uses of ClassFilter in org.hibernate.bytecode

Fields in org.hibernate.bytecode declared as ClassFilter
protected  ClassFilter AbstractClassTransformerImpl.classFilter

Methods in org.hibernate.bytecode with parameters of type ClassFilter
 ClassTransformer BytecodeProvider.getTransformer(ClassFilter classFilter, FieldFilter fieldFilter)
Generate a ClassTransformer capable of performing bytecode manipulation.

Constructors in org.hibernate.bytecode with parameters of type ClassFilter
AbstractClassTransformerImpl(ClassFilter classFilter, FieldFilter fieldFilter)

Uses of ClassFilter in org.hibernate.bytecode.cglib

Methods in org.hibernate.bytecode.cglib with parameters of type ClassFilter
 ClassTransformer BytecodeProviderImpl.getTransformer(ClassFilter classFilter, FieldFilter fieldFilter)

Constructors in org.hibernate.bytecode.cglib with parameters of type ClassFilter
CglibClassTransformer(ClassFilter classFilter, FieldFilter fieldFilter)

Uses of ClassFilter in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist with parameters of type ClassFilter
 ClassTransformer BytecodeProviderImpl.getTransformer(ClassFilter classFilter, FieldFilter fieldFilter)

Constructors in org.hibernate.bytecode.javassist with parameters of type ClassFilter
JavassistClassTransformer(ClassFilter classFilter, FieldFilter fieldFilter)

Uses of ClassFilter in org.hibernate.bytecode.util

Classes in org.hibernate.bytecode.util that implement ClassFilter
 class BasicClassFilter
BasicClassFilter provides class filtering based on a series of packages to be included and/or a series of explicit class names to be included.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.bytecode.util.FieldFilter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.bytecode.util.FieldFilter

Packages that use FieldFilter
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.bytecode.javassist |
org.hibernate.tool.instrument | The instrument tool for adding field-interception hooks to persistent classes using built-time bytecode processing.

Uses of FieldFilter in org.hibernate.bytecode

Fields in org.hibernate.bytecode declared as FieldFilter
protected  FieldFilter AbstractClassTransformerImpl.fieldFilter

Methods in org.hibernate.bytecode with parameters of type FieldFilter
 ClassTransformer BytecodeProvider.getTransformer(ClassFilter classFilter, FieldFilter fieldFilter)
Generate a ClassTransformer capable of performing bytecode manipulation.

Constructors in org.hibernate.bytecode with parameters of type FieldFilter
AbstractClassTransformerImpl(ClassFilter classFilter, FieldFilter fieldFilter)

Uses of FieldFilter in org.hibernate.bytecode.cglib

Methods in org.hibernate.bytecode.cglib with parameters of type FieldFilter
 ClassTransformer BytecodeProviderImpl.getTransformer(ClassFilter classFilter, FieldFilter fieldFilter)

Constructors in org.hibernate.bytecode.cglib with parameters of type FieldFilter
CglibClassTransformer(ClassFilter classFilter, FieldFilter fieldFilter)

Uses of FieldFilter in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist with parameters of type FieldFilter
 ClassTransformer BytecodeProviderImpl.getTransformer(ClassFilter classFilter, FieldFilter fieldFilter)

Constructors in org.hibernate.bytecode.javassist with parameters of type FieldFilter
JavassistClassTransformer(ClassFilter classFilter, FieldFilter fieldFilter)

Uses of FieldFilter in org.hibernate.tool.instrument

Classes in org.hibernate.tool.instrument that implement FieldFilter
protected  class BasicInstrumentationTask.CustomFieldFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.cache (Hibernate API Documentation)

 org.hibernate.cache
Interfaces
Cache
CacheConcurrencyStrategy
CacheConcurrencyStrategy.SoftLock
CacheProvider
OptimisticCache
OptimisticCacheSource
QueryCache
QueryCacheFactory
ReadWriteCache.Lockable
Classes
AbstractJndiBoundCacheProvider
CacheFactory
CacheKey
EhCache
EhCacheProvider
FilterKey
HashtableCache
HashtableCacheProvider
JndiBoundTreeCacheProvider
NoCacheProvider
NonstrictReadWriteCache
OptimisticTreeCache
OptimisticTreeCache.CircumventChecksDataVersion
OptimisticTreeCache.DataVersionAdapter
OptimisticTreeCache.NonLockingDataVersion
OptimisticTreeCacheProvider
OSCache
OSCacheProvider
QueryKey
ReadOnlyCache
ReadWriteCache
ReadWriteCache.Item
ReadWriteCache.Lock
StandardQueryCache
StandardQueryCacheFactory
SwarmCache
SwarmCacheProvider
Timestamper
TransactionalCache
TreeCache
TreeCacheProvider
UpdateTimestampsCache
Exceptions
CacheException
NoCachingEnabledException


Uses of Class org.hibernate.cache.AbstractJndiBoundCacheProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.AbstractJndiBoundCacheProvider

Packages that use AbstractJndiBoundCacheProvider
org.hibernate.cache This package defines APIs and implementations for the second-level cache and query cache.

Uses of AbstractJndiBoundCacheProvider in org.hibernate.cache

Subclasses of AbstractJndiBoundCacheProvider in org.hibernate.cache
 class JndiBoundTreeCacheProvider
Support for JBossCache (TreeCache), where the cache instance is available via JNDI lookup.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cache.Cache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cache.Cache

Packages that use Cache
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of Cache in org.hibernate.cache

Subinterfaces of Cache in org.hibernate.cache
 interface OptimisticCache
A contract for transactional cache implementations which support optimistic locking of items within the cache.

Classes in org.hibernate.cache that implement Cache
class | EhCache EHCache plugin for Hibernate EHCache uses a MemoryStore and a DiskStore.
class | HashtableCache A lightweight implementation of the Cache interface
class | OptimisticTreeCache Represents a particular region within the given JBossCache TreeCache utilizing TreeCache's optimistic locking capabilities.
class | OSCache
class | SwarmCache
class | TreeCache Represents a particular region within the given JBossCache TreeCache.

Methods in org.hibernate.cache that return Cache
Cache | UpdateTimestampsCache.getCache()
Cache | TreeCacheProvider.buildCache(String regionName, Properties properties) Construct and configure the Cache representation of a named cache region.
Cache | TransactionalCache.getCache()
Cache | SwarmCacheProvider.buildCache(String regionName, Properties properties)
Cache | StandardQueryCache.getCache()
Cache | ReadWriteCache.getCache()
Cache | ReadOnlyCache.getCache()
Cache | QueryCache.getCache()
Cache | OSCacheProvider.buildCache(String region, Properties properties) Builds a new Cache instance, and gets it's properties from the OSCache Config which reads the properties file (oscache.properties) from the classpath.
Cache | OptimisticTreeCacheProvider.buildCache(String regionName, Properties properties) Construct and configure the Cache representation of a named cache region.
Cache | NonstrictReadWriteCache.getCache()
Cache | NoCacheProvider.buildCache(String regionName, Properties properties) Configure the cache
Cache | JndiBoundTreeCacheProvider.buildCache(String regionName, Properties properties) Construct a Cache representing the "region" within in the underlying cache provider.
Cache | HashtableCacheProvider.buildCache(String regionName, Properties properties)
Cache | EhCacheProvider.buildCache(String name, Properties properties) Builds a Cache.
Cache | CacheProvider.buildCache(String regionName, Properties properties) Configure the cache
Cache | CacheConcurrencyStrategy.getCache() Get the wrapped cache implementation

Methods in org.hibernate.cache with parameters of type Cache
void | TransactionalCache.setCache(Cache cache)
void | ReadWriteCache.setCache(Cache cache)
void | ReadOnlyCache.setCache(Cache cache)
void | NonstrictReadWriteCache.setCache(Cache cache)
void | CacheConcurrencyStrategy.setCache(Cache cache) Set the underlying cache implementation.

Uses of Cache in org.hibernate.engine

Methods in org.hibernate.engine that return Cache
 Cache SessionFactoryImplementor.getSecondLevelCacheRegion(String regionName)
Get a named second-level cache region

Uses of Cache in org.hibernate.impl

Methods in org.hibernate.impl that return Cache
 Cache SessionFactoryImpl.getSecondLevelCacheRegion(String regionName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cache.CacheConcurrencyStrategy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cache.CacheConcurrencyStrategy

Packages that use CacheConcurrencyStrategy
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of CacheConcurrencyStrategy in org.hibernate.cache

Classes in org.hibernate.cache that implement CacheConcurrencyStrategy
class | NonstrictReadWriteCache Caches data that is sometimes updated without ever locking the cache.
class | ReadOnlyCache Caches data that is never updated.
class | ReadWriteCache Caches data that is sometimes updated while maintaining the semantics of "read committed" isolation level.
class | TransactionalCache Support for fully transactional cache implementations like JBoss TreeCache.

Methods in org.hibernate.cache that return CacheConcurrencyStrategy
static CacheConcurrencyStrategy CacheFactory.createCache(String concurrencyStrategy, String regionName, boolean mutable, Settings settings, Properties properties)

Uses of CacheConcurrencyStrategy in org.hibernate.persister

Methods in org.hibernate.persister with parameters of type CacheConcurrencyStrategy
static EntityPersister | PersisterFactory.createClassPersister(PersistentClass model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping cfg)
static CollectionPersister | PersisterFactory.createCollectionPersister(Configuration cfg, Collection model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory)

Uses of CacheConcurrencyStrategy in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that return CacheConcurrencyStrategy
CacheConcurrencyStrategy | CollectionPersister.getCache() Get the cache
CacheConcurrencyStrategy | AbstractCollectionPersister.getCache()

Constructors in org.hibernate.persister.collection with parameters of type CacheConcurrencyStrategy
OneToManyPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
BasicCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
AbstractCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)

Uses of CacheConcurrencyStrategy in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return CacheConcurrencyStrategy
CacheConcurrencyStrategy | EntityPersister.getCache() Get the cache (optional operation)
CacheConcurrencyStrategy | AbstractEntityPersister.getCache()

Constructors in org.hibernate.persister.entity with parameters of type CacheConcurrencyStrategy
UnionSubclassEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
SingleTableEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
JoinedSubclassEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
AbstractEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cache.CacheConcurrencyStrategy.SoftLock (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cache.CacheConcurrencyStrategy.SoftLock

Packages that use CacheConcurrencyStrategy.SoftLock
org.hibernate.cache This package defines APIs and implementations for the second-level cache and query cache.

Uses of CacheConcurrencyStrategy.SoftLock in org.hibernate.cache

Classes in org.hibernate.cache that implement CacheConcurrencyStrategy.SoftLock
static class ReadWriteCache.Lock
A soft lock which supports concurrent locking, timestamped with the time it was released

Methods in org.hibernate.cache that return CacheConcurrencyStrategy.SoftLock
CacheConcurrencyStrategy.SoftLock | TransactionalCache.lock(Object key, Object version) Do nothing, returning null.
CacheConcurrencyStrategy.SoftLock | ReadWriteCache.lock(Object key, Object version) Stop any other transactions reading or writing this item to/from the cache.
CacheConcurrencyStrategy.SoftLock | ReadOnlyCache.lock(Object key, Object version) Unsupported!
CacheConcurrencyStrategy.SoftLock | NonstrictReadWriteCache.lock(Object key, Object version) Do nothing.
CacheConcurrencyStrategy.SoftLock | CacheConcurrencyStrategy.lock(Object key, Object version) We are going to attempt to update/delete the keyed object.

Methods in org.hibernate.cache with parameters of type CacheConcurrencyStrategy.SoftLock
 void TransactionalCache.release(Object key, CacheConcurrencyStrategy.SoftLock clientLock)
Do nothing.
 boolean TransactionalCache.afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock clientLock)
Do nothing.
 void ReadWriteCache.release(Object key, CacheConcurrencyStrategy.SoftLock clientLock)
Release the soft lock on the item.
 boolean ReadWriteCache.afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock clientLock)
Re-cache the updated state, if and only if there there are no other concurrent soft locks.
 void ReadOnlyCache.release(Object key, CacheConcurrencyStrategy.SoftLock lock)
Unsupported!
 boolean ReadOnlyCache.afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock lock)
Unsupported!
 void NonstrictReadWriteCache.release(Object key, CacheConcurrencyStrategy.SoftLock lock)
Invalidate the item (again, for safety).
 boolean NonstrictReadWriteCache.afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock lock)
Invalidate the item (again, for safety).
 void CacheConcurrencyStrategy.release(Object key, CacheConcurrencyStrategy.SoftLock lock)
Called when we have finished the attempted update/delete (which may or may not have been successful), after transaction completion.
 boolean CacheConcurrencyStrategy.afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock lock)
Called after an item has been updated (after the transaction completes), instead of calling release().

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.CacheException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.CacheException

Packages that use CacheException
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.

Uses of CacheException in org.hibernate.action

Methods in org.hibernate.action that throw CacheException
void | EntityUpdateAction.afterTransactionCompletion(boolean success)
void | CollectionAction.afterTransactionCompletion(boolean success)
void | CollectionAction.beforeExecutions()
protected void | CollectionAction.evict()

Constructors in org.hibernate.action that throw CacheException
CollectionUpdateAction(PersistentCollection collection, CollectionPersister persister, Serializable id, boolean emptySnapshot, SessionImplementor session)
CollectionRemoveAction(PersistentCollection collection, CollectionPersister persister, Serializable id, boolean emptySnapshot, SessionImplementor session)
CollectionRecreateAction(PersistentCollection collection, CollectionPersister persister, Serializable id, SessionImplementor session)
CollectionAction(CollectionPersister persister, PersistentCollection collection, Serializable key, SessionImplementor session)

Uses of CacheException in org.hibernate.cache

Subclasses of CacheException in org.hibernate.cache
 class NoCachingEnabledException
Implementation of NoCachingEnabledException.

Methods in org.hibernate.cache that throw CacheException
 void UpdateTimestampsCache.clear()
 void UpdateTimestampsCache.preinvalidate(Serializable[] spaces)
 void UpdateTimestampsCache.invalidate(Serializable[] spaces)
 Cache TreeCacheProvider.buildCache(String regionName, Properties properties)
Construct and configure the Cache representation of a named cache region.
 Object TreeCache.get(Object key)
 Object TreeCache.read(Object key)
 void TreeCache.update(Object key, Object value)
 void TreeCache.put(Object key, Object value)
 void TreeCache.remove(Object key)
 void TreeCache.clear()
 void TreeCache.destroy()
 void TreeCache.lock(Object key)
 void TreeCache.unlock(Object key)
 Object TransactionalCache.get(Object key, long txTimestamp)
 boolean TransactionalCache.put(Object key, Object value, long txTimestamp, Object version, Comparator versionComparator, boolean minimalPut)
 CacheConcurrencyStrategy.SoftLock TransactionalCache.lock(Object key, Object version)
Do nothing, returning null.
 void TransactionalCache.release(Object key, CacheConcurrencyStrategy.SoftLock clientLock)
Do nothing.
 boolean TransactionalCache.update(Object key, Object value, Object currentVersion, Object previousVersion)
 boolean TransactionalCache.insert(Object key, Object value, Object currentVersion)
 void TransactionalCache.evict(Object key)
 void TransactionalCache.remove(Object key)
 void TransactionalCache.clear()
 boolean TransactionalCache.afterInsert(Object key, Object value, Object version)
Do nothing.
 boolean TransactionalCache.afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock clientLock)
Do nothing.
 Cache SwarmCacheProvider.buildCache(String regionName, Properties properties)
 void SwarmCacheProvider.start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 Object SwarmCache.get(Object key)
Get an item from the cache
 Object SwarmCache.read(Object key)
 void SwarmCache.update(Object key, Object value)
Add an item to the cache
 void SwarmCache.put(Object key, Object value)
Add an item to the cache
 void SwarmCache.remove(Object key)
Remove an item from the cache
 void SwarmCache.clear()
Clear the cache
 void SwarmCache.destroy()
Clean up
 void SwarmCache.lock(Object key)
If this is a clustered cache, lock the item
 void SwarmCache.unlock(Object key)
If this is a clustered cache, unlock the item
 void StandardQueryCache.clear()
 Object ReadWriteCache.get(Object key, long txTimestamp)
Do not return an item whose timestamp is later than the current transaction timestamp.
 CacheConcurrencyStrategy.SoftLock ReadWriteCache.lock(Object key, Object version)
Stop any other transactions reading or writing this item to/from the cache.
 boolean ReadWriteCache.put(Object key, Object value, long txTimestamp, Object version, Comparator versionComparator, boolean minimalPut)
Do not add an item to the cache unless the current transaction timestamp is later than the timestamp at which the item was invalidated.
 void ReadWriteCache.release(Object key, CacheConcurrencyStrategy.SoftLock clientLock)
Release the soft lock on the item.
 void ReadWriteCache.clear()
 void ReadWriteCache.remove(Object key)
 boolean ReadWriteCache.afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock clientLock)
Re-cache the updated state, if and only if there there are no other concurrent soft locks.
 boolean ReadWriteCache.afterInsert(Object key, Object value, Object version)
Add the new item to the cache, checking that no other transaction has accessed the item.
 void ReadWriteCache.evict(Object key)
Do nothing.
 Object ReadOnlyCache.get(Object key, long timestamp)
 boolean ReadOnlyCache.put(Object key, Object value, long timestamp, Object version, Comparator versionComparator, boolean minimalPut)
 void ReadOnlyCache.clear()
 void ReadOnlyCache.remove(Object key)
 boolean ReadOnlyCache.afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock lock)
Unsupported!
 boolean ReadOnlyCache.afterInsert(Object key, Object value, Object version)
Do nothing.
 void ReadOnlyCache.evict(Object key)
Do nothing.
 void QueryCache.clear()
 Cache OSCacheProvider.buildCache(String region, Properties properties)
Builds a new Cache instance, and gets it's properties from the OSCache Config which reads the properties file (oscache.properties) from the classpath.
 void OSCacheProvider.start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 Object OSCache.get(Object key)
 Object OSCache.read(Object key)
 void OSCache.update(Object key, Object value)
 void OSCache.put(Object key, Object value)
 void OSCache.remove(Object key)
 void OSCache.clear()
 void OSCache.destroy()
 void OSCache.lock(Object key)
 void OSCache.unlock(Object key)
 Cache OptimisticTreeCacheProvider.buildCache(String regionName, Properties properties)
Construct and configure the Cache representation of a named cache region.
 Object OptimisticTreeCache.get(Object key)
 Object OptimisticTreeCache.read(Object key)
 void OptimisticTreeCache.update(Object key, Object value)
 void OptimisticTreeCache.put(Object key, Object value)
 void OptimisticTreeCache.remove(Object key)
 void OptimisticTreeCache.clear()
 void OptimisticTreeCache.destroy()
 void OptimisticTreeCache.lock(Object key)
 void OptimisticTreeCache.unlock(Object key)
 Object NonstrictReadWriteCache.get(Object key, long txTimestamp)
Get the most recent version, if available.
 boolean NonstrictReadWriteCache.put(Object key, Object value, long txTimestamp, Object version, Comparator versionComparator, boolean minimalPut)
Add an item to the cache.
 CacheConcurrencyStrategy.SoftLock NonstrictReadWriteCache.lock(Object key, Object version)
Do nothing.
 void NonstrictReadWriteCache.remove(Object key)
 void NonstrictReadWriteCache.clear()
 void NonstrictReadWriteCache.evict(Object key)
Invalidate the item
 void NonstrictReadWriteCache.release(Object key, CacheConcurrencyStrategy.SoftLock lock)
Invalidate the item (again, for safety).
 boolean NonstrictReadWriteCache.afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock lock)
Invalidate the item (again, for safety).
 boolean NonstrictReadWriteCache.afterInsert(Object key, Object value, Object version)
Do nothing.
 Cache NoCacheProvider.buildCache(String regionName, Properties properties)
Configure the cache
 void NoCacheProvider.start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 Cache JndiBoundTreeCacheProvider.buildCache(String regionName, Properties properties)
Construct a Cache representing the "region" within in the underlying cache provider.
 void JndiBoundTreeCacheProvider.prepare(Properties properties)
 Cache HashtableCacheProvider.buildCache(String regionName, Properties properties)
 void HashtableCacheProvider.start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 Object HashtableCache.read(Object key)
 Object HashtableCache.get(Object key)
 void HashtableCache.update(Object key, Object value)
 void HashtableCache.put(Object key, Object value)
 void HashtableCache.remove(Object key)
 void HashtableCache.clear()
 void HashtableCache.destroy()
 void HashtableCache.lock(Object key)
 void HashtableCache.unlock(Object key)
 Cache EhCacheProvider.buildCache(String name, Properties properties)
Builds a Cache.
 void EhCacheProvider.start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 Object EhCache.get(Object key)
Gets a value of an element which matches the given key.
 Object EhCache.read(Object key)
 void EhCache.update(Object key, Object value)
Puts an object into the cache.
 void EhCache.put(Object key, Object value)
Puts an object into the cache.
 void EhCache.remove(Object key)
Removes the element which matches the key.
 void EhCache.clear()
Remove all elements in the cache, but leave the cache in a useable state.
 void EhCache.destroy()
Remove the cache and make it unuseable.
 void EhCache.lock(Object key)
Calls to this method should perform there own synchronization.
 void EhCache.unlock(Object key)
Calls to this method should perform there own synchronization.
 Cache CacheProvider.buildCache(String regionName, Properties properties)
Configure the cache
 void CacheProvider.start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.
 Object CacheConcurrencyStrategy.get(Object key, long txTimestamp)
Attempt to retrieve an object from the cache.
 boolean CacheConcurrencyStrategy.put(Object key, Object value, long txTimestamp, Object version, Comparator versionComparator, boolean minimalPut)
Attempt to cache an object, after loading from the database.
 CacheConcurrencyStrategy.SoftLock CacheConcurrencyStrategy.lock(Object key, Object version)
We are going to attempt to update/delete the keyed object.
 void CacheConcurrencyStrategy.evict(Object key)
Called after an item has become stale (before the transaction completes).
 boolean CacheConcurrencyStrategy.update(Object key, Object value, Object currentVersion, Object previousVersion)
Called after an item has been updated (before the transaction completes), instead of calling evict().
 boolean CacheConcurrencyStrategy.insert(Object key, Object value, Object currentVersion)
Called after an item has been inserted (before the transaction completes), instead of calling evict().
 void CacheConcurrencyStrategy.release(Object key, CacheConcurrencyStrategy.SoftLock lock)
Called when we have finished the attempted update/delete (which may or may not have been successful), after transaction completion.
 boolean CacheConcurrencyStrategy.afterUpdate(Object key, Object value, Object version, CacheConcurrencyStrategy.SoftLock lock)
Called after an item has been updated (after the transaction completes), instead of calling release().
 boolean CacheConcurrencyStrategy.afterInsert(Object key, Object value, Object version)
Called after an item has been inserted (after the transaction completes), instead of calling release().
 void CacheConcurrencyStrategy.remove(Object key)
Evict an item from the cache immediately (without regard for transaction isolation).
 void CacheConcurrencyStrategy.clear()
Evict all items from the cache immediately.
 Object Cache.read(Object key)
Get an item from the cache
 Object Cache.get(Object key)
Get an item from the cache, nontransactionally
 void Cache.put(Object key, Object value)
Add an item to the cache, nontransactionally, with failfast semantics
 void Cache.update(Object key, Object value)
Add an item to the cache
 void Cache.remove(Object key)
Remove an item from the cache
 void Cache.clear()
Clear the cache
 void Cache.destroy()
Clean up
 void Cache.lock(Object key)
If this is a clustered cache, lock the item
 void Cache.unlock(Object key)
If this is a clustered cache, unlock the item
 void AbstractJndiBoundCacheProvider.start(Properties properties)
Callback to perform any necessary initialization of the underlying cache implementation during SessionFactory construction.

Constructors in org.hibernate.cache that throw CacheException
TreeCache(org.jboss.cache.TreeCache cache, String regionName, TransactionManager transactionManager)
OptimisticTreeCache(org.jboss.cache.TreeCache cache, String regionName)

Uses of CacheException in org.hibernate.persister.collection

Constructors in org.hibernate.persister.collection that throw CacheException
OneToManyPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
BasicCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
AbstractCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.CacheFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.CacheFactory

No usage of org.hibernate.cache.CacheFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.CacheKey (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.CacheKey

No usage of org.hibernate.cache.CacheKey

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cache.CacheProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cache.CacheProvider

Packages that use CacheProvider
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of CacheProvider in org.hibernate.cache

Classes in org.hibernate.cache that implement CacheProvider
class | AbstractJndiBoundCacheProvider Support for CacheProvider implementations which are backed by caches bound into JNDI namespace.
class | EhCacheProvider Cache Provider plugin for ehcache-1.2.
class | HashtableCacheProvider A simple in-memory Hashtable-based cache impl.
class | JndiBoundTreeCacheProvider Support for JBossCache (TreeCache), where the cache instance is available via JNDI lookup.
class | NoCacheProvider Implementation of NoCacheProvider.
class | OptimisticTreeCacheProvider Support for a standalone JBossCache TreeCache instance utilizing TreeCache's optimistic locking capabilities.
class | OSCacheProvider Support for OpenSymphony OSCache.
class | SwarmCacheProvider Support for SwarmCache replicated cache.
class | TreeCacheProvider Support for a standalone JBossCache (TreeCache) instance.

Uses of CacheProvider in org.hibernate.cfg

Methods in org.hibernate.cfg that return CacheProvider
protected CacheProvider | SettingsFactory.createCacheProvider(Properties properties)
CacheProvider | Settings.getCacheProvider()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.EhCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.EhCache

No usage of org.hibernate.cache.EhCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.EhCacheProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.EhCacheProvider

No usage of org.hibernate.cache.EhCacheProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.FilterKey (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.FilterKey

No usage of org.hibernate.cache.FilterKey

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.HashtableCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.HashtableCache

No usage of org.hibernate.cache.HashtableCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.HashtableCacheProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.HashtableCacheProvider

No usage of org.hibernate.cache.HashtableCacheProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.JndiBoundTreeCacheProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.JndiBoundTreeCacheProvider

No usage of org.hibernate.cache.JndiBoundTreeCacheProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.NoCacheProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.NoCacheProvider

No usage of org.hibernate.cache.NoCacheProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.NoCachingEnabledException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.NoCachingEnabledException

No usage of org.hibernate.cache.NoCachingEnabledException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.NonstrictReadWriteCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.NonstrictReadWriteCache

No usage of org.hibernate.cache.NonstrictReadWriteCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cache.OptimisticCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cache.OptimisticCache

Packages that use OptimisticCache
org.hibernate.cache This package defines APIs and implementations for the second-level cache and query cache.

Uses of OptimisticCache in org.hibernate.cache

Classes in org.hibernate.cache that implement OptimisticCache
 class OptimisticTreeCache
Represents a particular region within the given JBossCache TreeCache utilizing TreeCache's optimistic locking capabilities.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cache.OptimisticCacheSource (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cache.OptimisticCacheSource

Packages that use OptimisticCacheSource
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of OptimisticCacheSource in org.hibernate.cache

Methods in org.hibernate.cache with parameters of type OptimisticCacheSource
void | OptimisticTreeCache.setSource(OptimisticCacheSource source)
void | OptimisticCache.setSource(OptimisticCacheSource source) Indicates the "source" of the cached data.

Uses of OptimisticCacheSource in org.hibernate.id

Subinterfaces of OptimisticCacheSource in org.hibernate.id
 interface PostInsertIdentityPersister
A persister that may have an identity assigned by execution of a SQL INSERT.

Uses of OptimisticCacheSource in org.hibernate.persister.entity

Subinterfaces of OptimisticCacheSource in org.hibernate.persister.entity
interface | EntityPersister Concrete EntityPersisters implement mapping and persistence logic for a particular persistent class.
interface | Loadable Implemented by a EntityPersister that may be loaded using Loader.
interface | Lockable Contract for things that can be locked via a LockingStrategy
interface | OuterJoinLoadable A EntityPersister that may be loaded by outer join using the OuterJoinLoader hierarchy and may be an element of a one-to-many association.
interface | Queryable Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language
interface | SQLLoadable A class persister that supports queries expressed in the platform native SQL dialect
interface | UniqueKeyLoadable

Classes in org.hibernate.persister.entity that implement OptimisticCacheSource
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.OptimisticTreeCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.OptimisticTreeCache

No usage of org.hibernate.cache.OptimisticTreeCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.OptimisticTreeCache.CircumventChecksDataVersion (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.OptimisticTreeCache.CircumventChecksDataVersion

No usage of org.hibernate.cache.OptimisticTreeCache.CircumventChecksDataVersion

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.OptimisticTreeCache.DataVersionAdapter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.OptimisticTreeCache.DataVersionAdapter

No usage of org.hibernate.cache.OptimisticTreeCache.DataVersionAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.OptimisticTreeCache.NonLockingDataVersion (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.OptimisticTreeCache.NonLockingDataVersion

No usage of org.hibernate.cache.OptimisticTreeCache.NonLockingDataVersion

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.OptimisticTreeCacheProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.OptimisticTreeCacheProvider

No usage of org.hibernate.cache.OptimisticTreeCacheProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.OSCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.OSCache

No usage of org.hibernate.cache.OSCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.OSCacheProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.OSCacheProvider

No usage of org.hibernate.cache.OSCacheProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cache.QueryCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cache.QueryCache

Packages that use QueryCache
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of QueryCache in org.hibernate.cache

Classes in org.hibernate.cache that implement QueryCache
 class StandardQueryCache
The standard implementation of the Hibernate QueryCache interface.

Methods in org.hibernate.cache that return QueryCache
QueryCache | StandardQueryCacheFactory.getQueryCache(String regionName, UpdateTimestampsCache updateTimestampsCache, Settings settings, Properties props)
QueryCache | QueryCacheFactory.getQueryCache(String regionName, UpdateTimestampsCache updateTimestampsCache, Settings settings, Properties props)

Uses of QueryCache in org.hibernate.engine

Methods in org.hibernate.engine that return QueryCache
QueryCache | SessionFactoryImplementor.getQueryCache() Get the default query cache
QueryCache | SessionFactoryImplementor.getQueryCache(String regionName) Get a particular named query cache, or the default cache

Uses of QueryCache in org.hibernate.impl

Methods in org.hibernate.impl that return QueryCache
QueryCache | SessionFactoryImpl.getQueryCache()
QueryCache | SessionFactoryImpl.getQueryCache(String cacheRegion)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cache.QueryCacheFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cache.QueryCacheFactory

Packages that use QueryCacheFactory
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of QueryCacheFactory in org.hibernate.cache

Classes in org.hibernate.cache that implement QueryCacheFactory
 class StandardQueryCacheFactory
Standard Hibernate implementation of the QueryCacheFactory interface.

Uses of QueryCacheFactory in org.hibernate.cfg

Methods in org.hibernate.cfg that return QueryCacheFactory
protected QueryCacheFactory | SettingsFactory.createQueryCacheFactory(Properties properties)
QueryCacheFactory | Settings.getQueryCacheFactory()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.QueryKey (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.QueryKey

Packages that use QueryKey
org.hibernate.cache This package defines APIs and implementations for the second-level cache and query cache.

Uses of QueryKey in org.hibernate.cache

Methods in org.hibernate.cache with parameters of type QueryKey
boolean | StandardQueryCache.put(QueryKey key, Type[] returnTypes, List result, boolean isNaturalKeyLookup, SessionImplementor session)
List | StandardQueryCache.get(QueryKey key, Type[] returnTypes, boolean isNaturalKeyLookup, Set spaces, SessionImplementor session)
boolean | QueryCache.put(QueryKey key, Type[] returnTypes, List result, boolean isNaturalKeyLookup, SessionImplementor session)
List | QueryCache.get(QueryKey key, Type[] returnTypes, boolean isNaturalKeyLookup, Set spaces, SessionImplementor session)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.ReadOnlyCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.ReadOnlyCache

No usage of org.hibernate.cache.ReadOnlyCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.ReadWriteCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.ReadWriteCache

No usage of org.hibernate.cache.ReadWriteCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.ReadWriteCache.Item (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.ReadWriteCache.Item

No usage of org.hibernate.cache.ReadWriteCache.Item

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.ReadWriteCache.Lock (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.ReadWriteCache.Lock

Packages that use ReadWriteCache.Lock
org.hibernate.cache This package defines APIs and implementations for the second-level cache and query cache.

Uses of ReadWriteCache.Lock in org.hibernate.cache

Methods in org.hibernate.cache that return ReadWriteCache.Lock
ReadWriteCache.Lock | ReadWriteCache.Lockable.lock(long timeout, int id)
ReadWriteCache.Lock | ReadWriteCache.Item.lock(long timeout, int id) Lock the item
ReadWriteCache.Lock | ReadWriteCache.Lock.lock(long timeout, int id) Increment the lock, setting the new lock timeout

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cache.ReadWriteCache.Lockable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cache.ReadWriteCache.Lockable

Packages that use ReadWriteCache.Lockable
org.hibernate.cache This package defines APIs and implementations for the second-level cache and query cache.

Uses of ReadWriteCache.Lockable in org.hibernate.cache

Classes in org.hibernate.cache that implement ReadWriteCache.Lockable
static class | ReadWriteCache.Item An item of cached data, timestamped with the time it was cached,.
static class | ReadWriteCache.Lock A soft lock which supports concurrent locking, timestamped with the time it was released

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.StandardQueryCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.StandardQueryCache

No usage of org.hibernate.cache.StandardQueryCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.StandardQueryCacheFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.StandardQueryCacheFactory

No usage of org.hibernate.cache.StandardQueryCacheFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.SwarmCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.SwarmCache

No usage of org.hibernate.cache.SwarmCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.SwarmCacheProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.SwarmCacheProvider

No usage of org.hibernate.cache.SwarmCacheProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.Timestamper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.Timestamper

No usage of org.hibernate.cache.Timestamper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.TransactionalCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.TransactionalCache

No usage of org.hibernate.cache.TransactionalCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.TreeCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.TreeCache

No usage of org.hibernate.cache.TreeCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.TreeCacheProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.TreeCacheProvider

No usage of org.hibernate.cache.TreeCacheProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.UpdateTimestampsCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.UpdateTimestampsCache

Packages that use UpdateTimestampsCache
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of UpdateTimestampsCache in org.hibernate.cache

Methods in org.hibernate.cache with parameters of type UpdateTimestampsCache
QueryCache | StandardQueryCacheFactory.getQueryCache(String regionName, UpdateTimestampsCache updateTimestampsCache, Settings settings, Properties props)
QueryCache | QueryCacheFactory.getQueryCache(String regionName, UpdateTimestampsCache updateTimestampsCache, Settings settings, Properties props)

Constructors in org.hibernate.cache with parameters of type UpdateTimestampsCache
StandardQueryCache(Settings settings, Properties props, UpdateTimestampsCache updateTimestampsCache, String regionName)

Uses of UpdateTimestampsCache in org.hibernate.engine

Methods in org.hibernate.engine that return UpdateTimestampsCache
 UpdateTimestampsCache SessionFactoryImplementor.getUpdateTimestampsCache()
Get the cache of table update timestamps

Uses of UpdateTimestampsCache in org.hibernate.impl

Methods in org.hibernate.impl that return UpdateTimestampsCache
 UpdateTimestampsCache SessionFactoryImpl.getUpdateTimestampsCache()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.cache.entry (Hibernate API Documentation)

 org.hibernate.cache.entry
Interfaces
CacheEntryStructure
Classes
CacheEntry
CollectionCacheEntry
StructuredCacheEntry
StructuredCollectionCacheEntry
StructuredMapCacheEntry
UnstructuredCacheEntry


Uses of Class org.hibernate.cache.entry.CacheEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.entry.CacheEntry

No usage of org.hibernate.cache.entry.CacheEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cache.entry.CacheEntryStructure (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cache.entry.CacheEntryStructure

Packages that use CacheEntryStructure
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of CacheEntryStructure in org.hibernate.cache.entry

Classes in org.hibernate.cache.entry that implement CacheEntryStructure
class | StructuredCacheEntry
class | StructuredCollectionCacheEntry
class | StructuredMapCacheEntry
class | UnstructuredCacheEntry

Uses of CacheEntryStructure in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that return CacheEntryStructure
CacheEntryStructure | CollectionPersister.getCacheEntryStructure() Get the cache structure
CacheEntryStructure | AbstractCollectionPersister.getCacheEntryStructure()

Uses of CacheEntryStructure in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return CacheEntryStructure
CacheEntryStructure | EntityPersister.getCacheEntryStructure() Get the cache structure
CacheEntryStructure | AbstractEntityPersister.getCacheEntryStructure()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.entry.CollectionCacheEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.entry.CollectionCacheEntry

No usage of org.hibernate.cache.entry.CollectionCacheEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.entry.StructuredCacheEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.entry.StructuredCacheEntry

No usage of org.hibernate.cache.entry.StructuredCacheEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.entry.StructuredCollectionCacheEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.entry.StructuredCollectionCacheEntry

No usage of org.hibernate.cache.entry.StructuredCollectionCacheEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.entry.StructuredMapCacheEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.entry.StructuredMapCacheEntry

No usage of org.hibernate.cache.entry.StructuredMapCacheEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cache.entry.UnstructuredCacheEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cache.entry.UnstructuredCacheEntry

No usage of org.hibernate.cache.entry.UnstructuredCacheEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.cfg (Hibernate API Documentation)

 org.hibernate.cfg
Interfaces
NamingStrategy
QuerySecondPass
SecondPass
Classes
CollectionSecondPass
Configuration
DefaultNamingStrategy
Environment
ExtendsQueueEntry
HbmBinder
ImprovedNamingStrategy
Mappings
Mappings.ColumnNames
Mappings.TableDescription
NamedSQLQuerySecondPass
ResultSetMappingBinder
ResultSetMappingSecondPass
Settings
SettingsFactory


Uses of Class org.hibernate.cfg.CollectionSecondPass (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.CollectionSecondPass

No usage of org.hibernate.cfg.CollectionSecondPass

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.Configuration (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.Configuration

Packages that use Configuration
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.secure | Declarative security for CRUD operations on entities.
org.hibernate.tool.hbm2ddl | The hbm2ddl tool.
org.hibernate.util | Utility classes.

Uses of Configuration in org.hibernate.cfg

Methods in org.hibernate.cfg that return Configuration
Configuration | Configuration.addFile(String xmlFile) Read mappings from a particular XML file
Configuration | Configuration.addFile(File xmlFile) Read mappings from a particular XML file
Configuration | Configuration.addCacheableFile(File xmlFile) If a cached xmlFile + ".bin" exists and is newer than xmlFile the ".bin" file will be read directly.
Configuration | Configuration.addCacheableFile(String xmlFile)
Configuration | Configuration.addXML(String xml) Read mappings from a String
Configuration | Configuration.addURL(URL url) Read mappings from a URL
Configuration | Configuration.addDocument(org.w3c.dom.Document doc) Read mappings from a DOM Document
Configuration | Configuration.addInputStream(InputStream xmlInputStream) Read mappings from an InputStream
Configuration | Configuration.addResource(String path, ClassLoader classLoader) Read mappings from an application resource
Configuration | Configuration.addResource(String path) Read mappings from an application resource trying different classloaders.
Configuration | Configuration.addClass(Class persistentClass) Read a mapping from an application resource, using a convention.
Configuration | Configuration.addJar(File jar) Read all mappings from a jar file
Configuration | Configuration.addDirectory(File dir) Read all mapping documents from a directory tree.
Configuration | Configuration.setInterceptor(Interceptor interceptor) Configure an Interceptor
Configuration | Configuration.setProperties(Properties properties) Specify a completely new set of properties
Configuration | Configuration.addProperties(Properties extraProperties) Set the given properties
Configuration | Configuration.mergeProperties(Properties properties) Adds the incoming properties to the internap properties structure, as long as the internal structure does not already contain an entry for the given key.
Configuration | Configuration.setProperty(String propertyName, String value) Set a property
Configuration | Configuration.configure() Use the mappings and properties specified in an application resource named hibernate.cfg.xml.
Configuration | Configuration.configure(String resource) Use the mappings and properties specified in the given application resource.
Configuration | Configuration.configure(URL url) Use the mappings and properties specified in the given document.
Configuration | Configuration.configure(File configFile) Use the mappings and properties specified in the given application file.
protected Configuration | Configuration.doConfigure(InputStream stream, String resourceName) Use the mappings and properties specified in the given application resource.
Configuration | Configuration.configure(org.w3c.dom.Document document) Use the mappings and properties specified in the given XML document.
protected Configuration | Configuration.doConfigure(org.dom4j.Document doc)
Configuration | Configuration.setCacheConcurrencyStrategy(String clazz, String concurrencyStrategy) Set up a cache for an entity class
Configuration | Configuration.setCollectionCacheConcurrencyStrategy(String collectionRole, String concurrencyStrategy) Set up a cache for a collection role
Configuration | Configuration.setNamingStrategy(NamingStrategy namingStrategy) Set a custom naming strategy

Uses of Configuration in org.hibernate.event

Methods in org.hibernate.event with parameters of type Configuration
 void Initializable.initialize(Configuration cfg)
 void EventListeners.initializeListeners(Configuration cfg)
Call initialize() on any listeners that implement Initializable.

Uses of Configuration in org.hibernate.impl

Constructors in org.hibernate.impl with parameters of type Configuration
SessionFactoryImpl(Configuration cfg, Mapping mapping, Settings settings, EventListeners listeners)

Uses of Configuration in org.hibernate.persister

Methods in org.hibernate.persister with parameters of type Configuration
static CollectionPersister PersisterFactory.createCollectionPersister(Configuration cfg, Collection model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory)

Uses of Configuration in org.hibernate.persister.collection

Constructors in org.hibernate.persister.collection with parameters of type Configuration
OneToManyPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
BasicCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
AbstractCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)

Uses of Configuration in org.hibernate.secure

Methods in org.hibernate.secure with parameters of type Configuration
void | JACCPreUpdateEventListener.initialize(Configuration cfg)
void | JACCPreLoadEventListener.initialize(Configuration cfg)
void | JACCPreInsertEventListener.initialize(Configuration cfg)
void | JACCPreDeleteEventListener.initialize(Configuration cfg)

Uses of Configuration in org.hibernate.tool.hbm2ddl

Constructors in org.hibernate.tool.hbm2ddl with parameters of type Configuration
SchemaValidator(Configuration cfg)
SchemaValidator(Configuration cfg, Properties connectionProperties)
SchemaValidator(Configuration cfg, Settings settings)
SchemaUpdate(Configuration cfg)
SchemaUpdate(Configuration cfg, Properties connectionProperties)
SchemaUpdate(Configuration cfg, Settings settings)
SchemaExport(Configuration cfg)
Create a schema exporter for the given Configuration
SchemaExport(Configuration cfg, Settings settings)
Create a schema exporter for the given Configuration and given settings
SchemaExport(Configuration cfg, Properties properties)
Deprecated. properties may be specified via the Configuration object
SchemaExport(Configuration cfg, Connection connection)

Uses of Configuration in org.hibernate.util

Methods in org.hibernate.util that return Configuration
protected  Configuration ExternalSessionFactoryConfig.buildConfiguration()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.DefaultNamingStrategy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.DefaultNamingStrategy

No usage of org.hibernate.cfg.DefaultNamingStrategy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.Environment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.Environment

No usage of org.hibernate.cfg.Environment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.ExtendsQueueEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.ExtendsQueueEntry

Packages that use ExtendsQueueEntry
org.hibernate.cfg This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of ExtendsQueueEntry in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type ExtendsQueueEntry
 void Mappings.addToExtendsQueue(ExtendsQueueEntry entry)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.HbmBinder (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.HbmBinder

No usage of org.hibernate.cfg.HbmBinder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.ImprovedNamingStrategy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.ImprovedNamingStrategy

No usage of org.hibernate.cfg.ImprovedNamingStrategy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.Mappings (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.Mappings

Packages that use Mappings
org.hibernate.cfg This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of Mappings in org.hibernate.cfg

Methods in org.hibernate.cfg that return Mappings
 Mappings Configuration.createMappings()
Create a new Mappings to add class and collection mappings to.

Methods in org.hibernate.cfg with parameters of type Mappings
protected static ResultSetMappingDefinition | ResultSetMappingBinder.buildResultSetMappingDefinition(org.dom4j.Element resultSetElem, String path, Mappings mappings) Build a ResultSetMappingDefinition given a containing element for the "return-XXX" elements
static void | HbmBinder.bindRoot(org.dom4j.Document doc, Mappings mappings, Map inheritedMetas) The main contract into the hbm.xml-based binder.
static void | HbmBinder.bindRootClass(org.dom4j.Element node, RootClass rootClass, Mappings mappings, Map inheritedMetas) Responsible for perfoming the bind operation related to an <class/> mapping element.
static void | HbmBinder.bindClass(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindUnionSubclass(org.dom4j.Element node, UnionSubclass unionSubclass, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindSubclass(org.dom4j.Element node, Subclass subclass, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindJoinedSubclass(org.dom4j.Element node, JoinedSubclass joinedSubclass, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindColumns(org.dom4j.Element node, SimpleValue simpleValue, boolean isNullable, boolean autoColumn, String propertyPath, Mappings mappings)
static void | HbmBinder.bindSimpleValue(org.dom4j.Element node, SimpleValue simpleValue, boolean isNullable, String path, Mappings mappings)
static void | HbmBinder.bindProperty(org.dom4j.Element node, Property property, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindCollection(org.dom4j.Element node, Collection collection, String className, String path, Mappings mappings, Map inheritedMetas) Called for all collections
static void | HbmBinder.bindManyToOne(org.dom4j.Element node, ManyToOne manyToOne, String path, boolean isNullable, Mappings mappings)
static void | HbmBinder.bindAny(org.dom4j.Element node, Any any, boolean isNullable, Mappings mappings)
static void | HbmBinder.bindOneToOne(org.dom4j.Element node, OneToOne oneToOne, String path, boolean isNullable, Mappings mappings)
static void | HbmBinder.bindOneToMany(org.dom4j.Element node, OneToMany oneToMany, Mappings mappings)
static void | HbmBinder.bindArray(org.dom4j.Element node, Array array, String prefix, String path, Mappings mappings, Map inheritedMetas) Called for arrays and primitive arrays
static void | HbmBinder.bindComposite(org.dom4j.Element node, Component component, String path, boolean isNullable, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindCompositeId(org.dom4j.Element node, Component component, PersistentClass persistentClass, String propertyName, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindComponent(org.dom4j.Element node, Component component, String ownerClassName, String parentProperty, String path, boolean isNullable, boolean isEmbedded, Mappings mappings, Map inheritedMetas, boolean isIdentifierMapper)
protected static void | HbmBinder.createClassProperties(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas)
protected static void | HbmBinder.createClassProperties(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas, UniqueKey uniqueKey, boolean mutable, boolean nullable, boolean naturalId)
static void | HbmBinder.bindListSecondPass(org.dom4j.Element node, List list, Map classes, Mappings mappings, Map inheritedMetas) Called for Lists, arrays, primitive arrays
static void | HbmBinder.bindIdentifierCollectionSecondPass(org.dom4j.Element node, IdentifierCollection collection, Map persistentClasses, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindMapSecondPass(org.dom4j.Element node, Map map, Map classes, Mappings mappings, Map inheritedMetas) Called for Maps
static void | HbmBinder.bindCollectionSecondPass(org.dom4j.Element node, Collection collection, Map persistentClasses, Mappings mappings, Map inheritedMetas) Called for all collections
static String | HbmBinder.getEntityName(org.dom4j.Element elem, Mappings model)
static String | HbmBinder.getClassName(String unqualifiedName, Mappings model)
static List | HbmBinder.getExtendsNeeded(org.dom4j.Document doc, Mappings mappings) For the given document, locate all extends attributes which refer to entities (entity-name or class-name) not defined within said document.

Constructors in org.hibernate.cfg with parameters of type Mappings
ResultSetMappingSecondPass(org.dom4j.Element element, String path, Mappings mappings)
NamedSQLQuerySecondPass(org.dom4j.Element queryElem, String path, Mappings mappings)
CollectionSecondPass(Mappings mappings, Collection collection, Map inheritedMetas)
CollectionSecondPass(Mappings mappings, Collection collection)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.Mappings.ColumnNames (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.Mappings.ColumnNames

No usage of org.hibernate.cfg.Mappings.ColumnNames

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.Mappings.TableDescription (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.Mappings.TableDescription

No usage of org.hibernate.cfg.Mappings.TableDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.NamedSQLQuerySecondPass (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.NamedSQLQuerySecondPass

No usage of org.hibernate.cfg.NamedSQLQuerySecondPass

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cfg.NamingStrategy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cfg.NamingStrategy

Packages that use NamingStrategy
org.hibernate.cfg This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of NamingStrategy in org.hibernate.cfg

Classes in org.hibernate.cfg that implement NamingStrategy
class | DefaultNamingStrategy The default NamingStrategy
class | ImprovedNamingStrategy An improved naming strategy that prefers embedded underscores to mixed case names

Fields in org.hibernate.cfg declared as NamingStrategy
protected NamingStrategy | Mappings.namingStrategy
static NamingStrategy | ImprovedNamingStrategy.INSTANCE A convenient singleton instance
static NamingStrategy | DefaultNamingStrategy.INSTANCE The singleton instance
protected NamingStrategy | Configuration.namingStrategy

Methods in org.hibernate.cfg that return NamingStrategy
NamingStrategy | Mappings.getNamingStrategy()
NamingStrategy | Configuration.getNamingStrategy()

Methods in org.hibernate.cfg with parameters of type NamingStrategy
 Configuration Configuration.setNamingStrategy(NamingStrategy namingStrategy)
Set a custom naming strategy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cfg.QuerySecondPass (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cfg.QuerySecondPass

Packages that use QuerySecondPass
org.hibernate.cfg This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of QuerySecondPass in org.hibernate.cfg

Classes in org.hibernate.cfg that implement QuerySecondPass
class | NamedSQLQuerySecondPass
class | ResultSetMappingSecondPass

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.ResultSetMappingBinder (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.ResultSetMappingBinder

Packages that use ResultSetMappingBinder
org.hibernate.cfg This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of ResultSetMappingBinder in org.hibernate.cfg

Subclasses of ResultSetMappingBinder in org.hibernate.cfg
class | NamedSQLQuerySecondPass
class | ResultSetMappingSecondPass

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.ResultSetMappingSecondPass (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.ResultSetMappingSecondPass

No usage of org.hibernate.cfg.ResultSetMappingSecondPass

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.cfg.SecondPass (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.cfg.SecondPass

Packages that use SecondPass
org.hibernate.cfg This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of SecondPass in org.hibernate.cfg

Subinterfaces of SecondPass in org.hibernate.cfg
 interface QuerySecondPass
Bind query

Classes in org.hibernate.cfg that implement SecondPass
class | CollectionSecondPass Collection second pass
class | NamedSQLQuerySecondPass
class | ResultSetMappingSecondPass

Methods in org.hibernate.cfg with parameters of type SecondPass
void | Mappings.addSecondPass(SecondPass sp)
void | Mappings.addSecondPass(SecondPass sp, boolean onTopOfTheQueue)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.Settings (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.Settings

Packages that use Settings
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.tool.hbm2ddl | The hbm2ddl tool.

Uses of Settings in org.hibernate.cache

Methods in org.hibernate.cache with parameters of type Settings
QueryCache | StandardQueryCacheFactory.getQueryCache(String regionName, UpdateTimestampsCache updateTimestampsCache, Settings settings, Properties props)
QueryCache | QueryCacheFactory.getQueryCache(String regionName, UpdateTimestampsCache updateTimestampsCache, Settings settings, Properties props)
static CacheConcurrencyStrategy | CacheFactory.createCache(String concurrencyStrategy, String regionName, boolean mutable, Settings settings, Properties properties)

Constructors in org.hibernate.cache with parameters of type Settings
UpdateTimestampsCache(Settings settings, Properties props)
StandardQueryCache(Settings settings, Properties props, UpdateTimestampsCache updateTimestampsCache, String regionName)

Uses of Settings in org.hibernate.cfg

Methods in org.hibernate.cfg that return Settings
Settings | SettingsFactory.buildSettings(Properties props)
Settings | Configuration.buildSettings() Create an object-oriented view of the configuration properties
Settings | Configuration.buildSettings(Properties props)

Uses of Settings in org.hibernate.engine

Methods in org.hibernate.engine that return Settings
 Settings SessionFactoryImplementor.getSettings()

Uses of Settings in org.hibernate.impl

Methods in org.hibernate.impl that return Settings
 Settings SessionFactoryImpl.getSettings()

Constructors in org.hibernate.impl with parameters of type Settings
SessionFactoryImpl(Configuration cfg, Mapping mapping, Settings settings, EventListeners listeners)

Uses of Settings in org.hibernate.tool.hbm2ddl

Constructors in org.hibernate.tool.hbm2ddl with parameters of type Settings
SchemaValidator(Configuration cfg, Settings settings)
SchemaUpdate(Configuration cfg, Settings settings)
SchemaExport(Configuration cfg, Settings settings)
Create a schema exporter for the given Configuration and given settings

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.cfg.SettingsFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.cfg.SettingsFactory

Packages that use SettingsFactory
org.hibernate.cfg This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of SettingsFactory in org.hibernate.cfg

Fields in org.hibernate.cfg declared as SettingsFactory
protected  SettingsFactory Configuration.settingsFactory

Constructors in org.hibernate.cfg with parameters of type SettingsFactory
Configuration(SettingsFactory settingsFactory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.AssertionFailure (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.AssertionFailure

No usage of org.hibernate.AssertionFailure

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.CacheMode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.CacheMode

Packages that use CacheMode
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of CacheMode in org.hibernate

Fields in org.hibernate declared as CacheMode
static CacheMode | CacheMode.NORMAL The session may read items from the cache, and add items to the cache
static CacheMode | CacheMode.IGNORE The session will never interact with the cache, except to invalidate cache items when updates occur
static CacheMode | CacheMode.GET The session may read items from the cache, but will not add items, except to invalidate items when updates occur
static CacheMode | CacheMode.PUT The session will never read items from the cache, but will add items to the cache as it reads them from the database.
static CacheMode | CacheMode.REFRESH The session will never read items from the cache, but will add items to the cache as it reads them from the database.

Methods in org.hibernate that return CacheMode
CacheMode | Session.getCacheMode() Get the current cache mode.
static CacheMode | CacheMode.parse(String name)

Methods in org.hibernate with parameters of type CacheMode
void | Session.setCacheMode(CacheMode cacheMode) Set the cache mode.
Query | Query.setCacheMode(CacheMode cacheMode) Override the current session cache mode, just for this query.
Criteria | Criteria.setCacheMode(CacheMode cacheMode) Override the cache mode for this particular query.

Uses of CacheMode in org.hibernate.cfg

Methods in org.hibernate.cfg that return CacheMode
static CacheMode HbmBinder.getCacheMode(String cacheMode)

Uses of CacheMode in org.hibernate.engine

Methods in org.hibernate.engine that return CacheMode
CacheMode | SessionImplementor.getCacheMode()
CacheMode | NamedQueryDefinition.getCacheMode()

Methods in org.hibernate.engine with parameters of type CacheMode
 void SessionImplementor.setCacheMode(CacheMode cm)

Constructors in org.hibernate.engine with parameters of type CacheMode
NamedSQLQueryDefinition(String query, NativeSQLQueryReturn[] queryReturns, List querySpaces, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, CacheMode cacheMode, boolean readOnly, String comment, Map parameterTypes, boolean callable)
This form used to construct a NamedSQLQueryDefinition from the binder code when a the result-set mapping information is explicitly provided in the query definition (i.e., no resultset-mapping used)
NamedSQLQueryDefinition(String query, String resultSetRef, List querySpaces, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, CacheMode cacheMode, boolean readOnly, String comment, Map parameterTypes, boolean callable)
This form used to construct a NamedSQLQueryDefinition from the binder code when a resultset-mapping reference is used.
NamedQueryDefinition(String query, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, CacheMode cacheMode, boolean readOnly, String comment, Map parameterTypes)

Uses of CacheMode in org.hibernate.impl

Methods in org.hibernate.impl that return CacheMode
CacheMode | StatelessSessionImpl.getCacheMode()
CacheMode | SessionImpl.getCacheMode()

Methods in org.hibernate.impl with parameters of type CacheMode
void | StatelessSessionImpl.setCacheMode(CacheMode cm)
void | SessionImpl.setCacheMode(CacheMode cacheMode)
Criteria | CriteriaImpl.setCacheMode(CacheMode cacheMode)
Criteria | CriteriaImpl.Subcriteria.setCacheMode(CacheMode cacheMode)
Query | AbstractQueryImpl.setCacheMode(CacheMode cacheMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.CallbackException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.CallbackException

Packages that use CallbackException
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.classic | This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.

Uses of CallbackException in org.hibernate

Methods in org.hibernate that throw CallbackException
boolean | Interceptor.onLoad(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types) Called just before an object is initialized.
boolean | Interceptor.onFlushDirty(Object entity, Serializable id, Object[] currentState, Object[] previousState, String[] propertyNames, Type[] types) Called when an object is detected to be dirty, during a flush.
boolean | Interceptor.onSave(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types) Called before an object is saved.
void | Interceptor.onDelete(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types) Called before an object is deleted.
void | Interceptor.onCollectionRecreate(Object collection, Serializable key) Called before a collection is (re)created.
void | Interceptor.onCollectionRemove(Object collection, Serializable key) Called before a collection is deleted.
void | Interceptor.onCollectionUpdate(Object collection, Serializable key) Called before a collection is updated.
void | Interceptor.preFlush(Iterator entities) Called before a flush
void | Interceptor.postFlush(Iterator entities) Called after a flush that actually ends in execution of the SQL statements required to synchronize in-memory state with the database.
Object | Interceptor.instantiate(String entityName, EntityMode entityMode, Serializable id) Instantiate the entity class.
String | Interceptor.getEntityName(Object object) Get the entity name for a persistent or transient instance
Object | Interceptor.getEntity(String entityName, Serializable id) Get a fully loaded entity instance that is cached externally
void | EmptyInterceptor.onCollectionRemove(Object collection, Serializable key)
void | EmptyInterceptor.onCollectionRecreate(Object collection, Serializable key)
void | EmptyInterceptor.onCollectionUpdate(Object collection, Serializable key)

Uses of CallbackException in org.hibernate.classic

Methods in org.hibernate.classic that throw CallbackException
 boolean Lifecycle.onSave(Session s)
Called when an entity is saved.
 boolean Lifecycle.onUpdate(Session s)
Called when an entity is passed to Session.update().
 boolean Lifecycle.onDelete(Session s)
Called when an entity is deleted.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.ConnectionReleaseMode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.ConnectionReleaseMode

Packages that use ConnectionReleaseMode
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.context |
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.

Uses of ConnectionReleaseMode in org.hibernate

Fields in org.hibernate declared as ConnectionReleaseMode
static ConnectionReleaseMode | ConnectionReleaseMode.AFTER_STATEMENT Indicates that JDBC connection should be aggressively released after each SQL statement is executed.
static ConnectionReleaseMode | ConnectionReleaseMode.AFTER_TRANSACTION Indicates that JDBC connections should be released after each transaction ends (works with both JTA-registered synch and HibernateTransaction API).
static ConnectionReleaseMode | ConnectionReleaseMode.ON_CLOSE Indicates that connections should only be released when the Session is explicitly closed or disconnected; this is the legacy (Hibernate2 and pre-3.1) behavior.

Methods in org.hibernate that return ConnectionReleaseMode
static ConnectionReleaseMode ConnectionReleaseMode.parse(String modeName)
Determine the correct ConnectionReleaseMode instance based on the given name.

Uses of ConnectionReleaseMode in org.hibernate.cfg

Methods in org.hibernate.cfg that return ConnectionReleaseMode
 ConnectionReleaseMode Settings.getConnectionReleaseMode()

Uses of ConnectionReleaseMode in org.hibernate.context

Methods in org.hibernate.context that return ConnectionReleaseMode
protected ConnectionReleaseMode | ThreadLocalSessionContext.getConnectionReleaseMode() Mainly for subclass usage.
protected ConnectionReleaseMode | JTASessionContext.getConnectionReleaseMode() Mainly for subclass usage.

Uses of ConnectionReleaseMode in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type ConnectionReleaseMode
 Session SessionFactoryImplementor.openSession(Connection connection, boolean flushBeforeCompletionEnabled, boolean autoCloseSessionEnabled, ConnectionReleaseMode connectionReleaseMode)
Open a session conforming to the given parameters.

Uses of ConnectionReleaseMode in org.hibernate.impl

Methods in org.hibernate.impl that return ConnectionReleaseMode
ConnectionReleaseMode | StatelessSessionImpl.getConnectionReleaseMode()
ConnectionReleaseMode | SessionImpl.getConnectionReleaseMode()

Methods in org.hibernate.impl with parameters of type ConnectionReleaseMode
 Session SessionFactoryImpl.openSession(Connection connection, boolean flushBeforeCompletionEnabled, boolean autoCloseSessionEnabled, ConnectionReleaseMode connectionReleaseMode)

Uses of ConnectionReleaseMode in org.hibernate.jdbc

Methods in org.hibernate.jdbc that return ConnectionReleaseMode
 ConnectionReleaseMode JDBCContext.Context.getConnectionReleaseMode()

Methods in org.hibernate.jdbc with parameters of type ConnectionReleaseMode
static ConnectionManager ConnectionManager.deserialize(ObjectInputStream ois, SessionFactoryImplementor factory, Interceptor interceptor, ConnectionReleaseMode connectionReleaseMode, JDBCContext jdbcContext)

Constructors in org.hibernate.jdbc with parameters of type ConnectionReleaseMode
ConnectionManager(SessionFactoryImplementor factory, ConnectionManager.Callback callback, ConnectionReleaseMode releaseMode, Connection connection, Interceptor interceptor)
Constructs a ConnectionManager.

Uses of ConnectionReleaseMode in org.hibernate.transaction

Methods in org.hibernate.transaction that return ConnectionReleaseMode
ConnectionReleaseMode | TransactionFactory.getDefaultReleaseMode() Get the default connection release mode
ConnectionReleaseMode | JTATransactionFactory.getDefaultReleaseMode()
ConnectionReleaseMode | JDBCTransactionFactory.getDefaultReleaseMode()
ConnectionReleaseMode | CMTTransactionFactory.getDefaultReleaseMode()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.Criteria (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.Criteria

Packages that use Criteria
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader

Uses of Criteria in org.hibernate

Methods in org.hibernate that return Criteria
Criteria | StatelessSession.createCriteria(Class persistentClass) Create a new Criteria instance, for the given entity class, or a superclass of an entity class.
Criteria | StatelessSession.createCriteria(Class persistentClass, String alias) Create a new Criteria instance, for the given entity class, or a superclass of an entity class, with the given alias.
Criteria | StatelessSession.createCriteria(String entityName) Create a new Criteria instance, for the given entity name.
Criteria | StatelessSession.createCriteria(String entityName, String alias) Create a new Criteria instance, for the given entity name, with the given alias.
Criteria | Session.createCriteria(Class persistentClass) Create a new Criteria instance, for the given entity class, or a superclass of an entity class.
Criteria | Session.createCriteria(Class persistentClass, String alias) Create a new Criteria instance, for the given entity class, or a superclass of an entity class, with the given alias.
Criteria | Session.createCriteria(String entityName) Create a new Criteria instance, for the given entity name.
Criteria | Session.createCriteria(String entityName, String alias) Create a new Criteria instance, for the given entity name, with the given alias.
Criteria | Criteria.setProjection(Projection projection) Used to specify that the query results will be a projection (scalar in nature).
Criteria | Criteria.add(Criterion criterion) Add a restriction to constrain the results to be retrieved.
Criteria | Criteria.addOrder(Order order) Add an ordering to the result set.
Criteria | Criteria.setFetchMode(String associationPath, FetchMode mode) Specify an association fetching strategy for an association or a collection of values.
Criteria | Criteria.setLockMode(LockMode lockMode) Set the lock mode of the current entity
Criteria | Criteria.setLockMode(String alias, LockMode lockMode) Set the lock mode of the aliased entity
Criteria | Criteria.createAlias(String associationPath, String alias) Join an association, assigning an alias to the joined association.
Criteria | Criteria.createAlias(String associationPath, String alias, int joinType) Join an association using the specified join-type, assigning an alias to the joined association.
Criteria | Criteria.createCriteria(String associationPath) Create a new Criteria, "rooted" at the associated entity.
Criteria | Criteria.createCriteria(String associationPath, int joinType) Create a new Criteria, "rooted" at the associated entity, using the specified join type.
Criteria | Criteria.createCriteria(String associationPath, String alias) Create a new Criteria, "rooted" at the associated entity, assigning the given alias.
Criteria | Criteria.createCriteria(String associationPath, String alias, int joinType) Create a new Criteria, "rooted" at the associated entity, assigning the given alias and using the specified join type.
Criteria | Criteria.setResultTransformer(ResultTransformer resultTransformer) Set a strategy for handling the query results.
Criteria | Criteria.setMaxResults(int maxResults) Set a limit upon the number of objects to be retrieved.
Criteria | Criteria.setFirstResult(int firstResult) Set the first result to be retrieved.
Criteria | Criteria.setFetchSize(int fetchSize) Set a fetch size for the underlying JDBC query.
Criteria | Criteria.setTimeout(int timeout) Set a timeout for the underlying JDBC query.
Criteria | Criteria.setCacheable(boolean cacheable) Enable caching of this query result, provided query caching is enabled for the underlying session factory.
Criteria | Criteria.setCacheRegion(String cacheRegion) Set the name of the cache region to use for query result caching.
Criteria | Criteria.setComment(String comment) Add a comment to the generated SQL.
Criteria | Criteria.setFlushMode(FlushMode flushMode) Override the flush mode for this particular query.
Criteria | Criteria.setCacheMode(CacheMode cacheMode) Override the cache mode for this particular query.

Uses of Criteria in org.hibernate.criterion

Methods in org.hibernate.criterion that return Criteria
 Criteria DetachedCriteria.getExecutableCriteria(Session session)
Get an executable instance of Criteria, to actually run the query.

Methods in org.hibernate.criterion with parameters of type Criteria
protected abstract String | SubqueryExpression.toLeftSqlString(Criteria criteria, CriteriaQuery outerQuery)
String | SubqueryExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SubqueryExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | SQLProjection.toSqlString(Criteria criteria, int loc, CriteriaQuery criteriaQuery)
String | SQLProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | SQLProjection.getTypes(Criteria crit, CriteriaQuery criteriaQuery)
Type[] | SQLProjection.getTypes(String alias, Criteria crit, CriteriaQuery criteriaQuery)
String | SQLCriterion.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SQLCriterion.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | SizeExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SizeExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SimpleSubqueryExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
protected String | SimpleSubqueryExpression.toLeftSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | SimpleProjection.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
String | SimpleProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | SimpleExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SimpleExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | RowCountProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | RowCountProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
protected String | PropertySubqueryExpression.toLeftSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | PropertyProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | PropertyProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | PropertyProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | PropertyExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | PropertyExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | ProjectionList.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | ProjectionList.toSqlString(Criteria criteria, int loc, CriteriaQuery criteriaQuery)
String | ProjectionList.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | ProjectionList.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
String | Projection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery) Render the SQL fragment
String | Projection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment to be used in the group by clause
Type[] | Projection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
Type[] | Projection.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery) Return types for a particular user-visible alias
String | Order.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | NullExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NullExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | NotNullExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NotNullExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | NotExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NotExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NaturalIdentifier.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | NaturalIdentifier.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | LogicalExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | LogicalExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | LikeExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | LikeExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | Junction.getTypedValues(Criteria crit, CriteriaQuery criteriaQuery)
String | Junction.toSqlString(Criteria crit, CriteriaQuery criteriaQuery)
String | InExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | InExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | IlikeExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | IlikeExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | IdentifierProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | IdentifierProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | IdentifierProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | IdentifierEqExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | IdentifierEqExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
protected String | ExistsSubqueryExpression.toLeftSqlString(Criteria criteria, CriteriaQuery outerQuery)
String | Example.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | Example.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
protected void | Example.addComponentTypedValues(String path, Object component, AbstractComponentType type, List list, Criteria criteria, CriteriaQuery criteriaQuery)
protected void | Example.appendPropertyCondition(String propertyName, Object propertyValue, Criteria criteria, CriteriaQuery cq, StringBuffer buf)
protected void | Example.appendComponentCondition(String path, Object component, AbstractComponentType type, Criteria criteria, CriteriaQuery criteriaQuery, StringBuffer buf)
String | Distinct.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | Distinct.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | Distinct.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | Distinct.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
String | Criterion.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
TypedValue[] | Criterion.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | CriteriaQuery.getColumn(Criteria criteria, String propertyPath) Get the names of the columns mapped by a property path, ignoring projection aliases
Type | CriteriaQuery.getType(Criteria criteria, String propertyPath) Get the type of a property path, ignoring projection aliases
String[] | CriteriaQuery.getColumnsUsingProjection(Criteria criteria, String propertyPath) Get the names of the columns mapped by a property path
Type | CriteriaQuery.getTypeUsingProjection(Criteria criteria, String propertyPath) Get the type of a property path
TypedValue | CriteriaQuery.getTypedValue(Criteria criteria, String propertyPath, Object value) Get the a typed value for the given property value.
String | CriteriaQuery.getEntityName(Criteria criteria) Get the entity name of an entity
String | CriteriaQuery.getEntityName(Criteria criteria, String propertyPath) Get the entity name of an entity, taking into account the qualifier of the property path
String | CriteriaQuery.getSQLAlias(Criteria subcriteria) Get the root table alias of an entity
String | CriteriaQuery.getSQLAlias(Criteria criteria, String propertyPath) Get the root table alias of an entity, taking into account the qualifier of the property path
String[] | CriteriaQuery.getIdentifierColumns(Criteria subcriteria) Get the identifier column names of this entity
Type | CriteriaQuery.getIdentifierType(Criteria subcriteria) Get the identifier type of this entity
TypedValue | CriteriaQuery.getTypedIdentifierValue(Criteria subcriteria, Object value)
Type[] | CountProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | CountProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | BetweenExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | BetweenExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AvgProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | AliasedProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | AliasedProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AliasedProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AliasedProjection.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AggregateProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | AggregateProjection.toSqlString(Criteria criteria, int loc, CriteriaQuery criteriaQuery)
String | AbstractEmptinessExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | AbstractEmptinessExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)

Constructors in org.hibernate.criterion with parameters of type Criteria
DetachedCriteria(CriteriaImpl impl, Criteria criteria)

Uses of Criteria in org.hibernate.impl

Classes in org.hibernate.impl that implement Criteria
class | CriteriaImpl Implementation of the Criteria interface
class | CriteriaImpl.Subcriteria

Methods in org.hibernate.impl that return Criteria
Criteria | StatelessSessionImpl.createCriteria(Class persistentClass, String alias)
Criteria | StatelessSessionImpl.createCriteria(String entityName, String alias)
Criteria | StatelessSessionImpl.createCriteria(Class persistentClass)
Criteria | StatelessSessionImpl.createCriteria(String entityName)
Criteria | SessionImpl.createCriteria(Class persistentClass, String alias)
Criteria | SessionImpl.createCriteria(String entityName, String alias)
Criteria | SessionImpl.createCriteria(Class persistentClass)
Criteria | SessionImpl.createCriteria(String entityName)
Criteria | CriteriaImpl.getProjectionCriteria()
Criteria | CriteriaImpl.add(Criteria criteriaInst, Criterion expression)
Criteria | CriteriaImpl.setProjection(Projection projection)
Criteria | CriteriaImpl.add(Criterion expression)
Criteria | CriteriaImpl.addOrder(Order ordering)
Criteria | CriteriaImpl.setFetchMode(String associationPath, FetchMode mode)
Criteria | CriteriaImpl.setLockMode(LockMode lockMode)
Criteria | CriteriaImpl.setLockMode(String alias, LockMode lockMode)
Criteria | CriteriaImpl.createAlias(String associationPath, String alias)
Criteria | CriteriaImpl.createAlias(String associationPath, String alias, int joinType)
Criteria | CriteriaImpl.createCriteria(String associationPath)
Criteria | CriteriaImpl.createCriteria(String associationPath, int joinType)
Criteria | CriteriaImpl.createCriteria(String associationPath, String alias)
Criteria | CriteriaImpl.createCriteria(String associationPath, String alias, int joinType)
Criteria | CriteriaImpl.setResultTransformer(ResultTransformer tupleMapper)
Criteria | CriteriaImpl.setMaxResults(int maxResults)
Criteria | CriteriaImpl.setFirstResult(int firstResult)
Criteria | CriteriaImpl.setFetchSize(int fetchSize)
Criteria | CriteriaImpl.setTimeout(int timeout)
Criteria | CriteriaImpl.setCacheable(boolean cacheable)
Criteria | CriteriaImpl.setCacheRegion(String cacheRegion)
Criteria | CriteriaImpl.setComment(String comment)
Criteria | CriteriaImpl.setFlushMode(FlushMode flushMode)
Criteria | CriteriaImpl.setCacheMode(CacheMode cacheMode)
Criteria | CriteriaImpl.Subcriteria.getParent()
Criteria | CriteriaImpl.Subcriteria.setLockMode(LockMode lockMode)
Criteria | CriteriaImpl.Subcriteria.add(Criterion expression)
Criteria | CriteriaImpl.Subcriteria.addOrder(Order order)
Criteria | CriteriaImpl.Subcriteria.createAlias(String associationPath, String alias)
Criteria | CriteriaImpl.Subcriteria.createAlias(String associationPath, String alias, int joinType)
Criteria | CriteriaImpl.Subcriteria.createCriteria(String associationPath)
Criteria | CriteriaImpl.Subcriteria.createCriteria(String associationPath, int joinType)
Criteria | CriteriaImpl.Subcriteria.createCriteria(String associationPath, String alias)
Criteria | CriteriaImpl.Subcriteria.createCriteria(String associationPath, String alias, int joinType)
Criteria | CriteriaImpl.Subcriteria.setCacheable(boolean cacheable)
Criteria | CriteriaImpl.Subcriteria.setCacheRegion(String cacheRegion)
Criteria | CriteriaImpl.Subcriteria.setFetchMode(String associationPath, FetchMode mode)
Criteria | CriteriaImpl.Subcriteria.setFlushMode(FlushMode flushMode)
Criteria | CriteriaImpl.Subcriteria.setCacheMode(CacheMode cacheMode)
Criteria | CriteriaImpl.Subcriteria.setFirstResult(int firstResult)
Criteria | CriteriaImpl.Subcriteria.setMaxResults(int maxResults)
Criteria | CriteriaImpl.Subcriteria.setTimeout(int timeout)
Criteria | CriteriaImpl.Subcriteria.setFetchSize(int fetchSize)
Criteria | CriteriaImpl.Subcriteria.setLockMode(String alias, LockMode lockMode)
Criteria | CriteriaImpl.Subcriteria.setResultTransformer(ResultTransformer resultProcessor)
Criteria | CriteriaImpl.Subcriteria.setComment(String comment)
Criteria | CriteriaImpl.Subcriteria.setProjection(Projection projection)
Criteria | CriteriaImpl.CriterionEntry.getCriteria()
Criteria | CriteriaImpl.OrderEntry.getCriteria()

Methods in org.hibernate.impl with parameters of type Criteria
 Criteria CriteriaImpl.add(Criteria criteriaInst, Criterion expression)

Uses of Criteria in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria that return Criteria
 Criteria CriteriaQueryTranslator.getCriteria(String path)

Methods in org.hibernate.loader.criteria with parameters of type Criteria
String | CriteriaQueryTranslator.getSQLAlias(Criteria criteria)
String | CriteriaQueryTranslator.getEntityName(Criteria criteria)
String | CriteriaQueryTranslator.getColumn(Criteria criteria, String propertyName)
String[] | CriteriaQueryTranslator.getColumnsUsingProjection(Criteria subcriteria, String propertyName) Get the names of the columns constrained by this criterion.
String[] | CriteriaQueryTranslator.getIdentifierColumns(Criteria subcriteria)
Type | CriteriaQueryTranslator.getIdentifierType(Criteria subcriteria)
TypedValue | CriteriaQueryTranslator.getTypedIdentifierValue(Criteria subcriteria, Object value)
Type | CriteriaQueryTranslator.getTypeUsingProjection(Criteria subcriteria, String propertyName)
Type | CriteriaQueryTranslator.getType(Criteria subcriteria, String propertyName)
TypedValue | CriteriaQueryTranslator.getTypedValue(Criteria subcriteria, String propertyName, Object value) Get the a typed value for the given property value.
String | CriteriaQueryTranslator.getEntityName(Criteria subcriteria, String propertyName)
String | CriteriaQueryTranslator.getSQLAlias(Criteria criteria, String propertyName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.DuplicateMappingException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.DuplicateMappingException

No usage of org.hibernate.DuplicateMappingException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.EmptyInterceptor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.EmptyInterceptor

No usage of org.hibernate.EmptyInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.EntityMode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.EntityMode

Packages that use EntityMode
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.metadata | This package defines an API for accessing the Hibernate runtime metamodel.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.pretty | Classes for pretty printing things for exception and log messages.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of EntityMode in org.hibernate

Fields in org.hibernate declared as EntityMode
static EntityMode | EntityMode.POJO
static EntityMode | EntityMode.DOM4J
static EntityMode | EntityMode.MAP

Methods in org.hibernate that return EntityMode
EntityMode | Session.getEntityMode() Retrieve the entity mode in effect for this session.
static EntityMode | EntityMode.parse(String name)

Methods in org.hibernate with parameters of type EntityMode
Session | Session.getSession(EntityMode entityMode) Starts a new Session with the given entity mode in effect.
Object | Interceptor.instantiate(String entityName, EntityMode entityMode, Serializable id) Instantiate the entity class.
Object | EmptyInterceptor.instantiate(String entityName, EntityMode entityMode, Serializable id)

Uses of EntityMode in org.hibernate.cache

Methods in org.hibernate.cache with parameters of type EntityMode
static Set FilterKey.createFilterKeys(Map enabledFilters, EntityMode entityMode)

Constructors in org.hibernate.cache with parameters of type EntityMode
QueryKey(String queryString, QueryParameters queryParameters, Set filters, EntityMode entityMode)
FilterKey(String name, Map params, Map types, EntityMode entityMode)
CacheKey(Serializable id, Type type, String entityOrRoleName, EntityMode entityMode, SessionFactoryImplementor factory)
Construct a new key for a collection or entity instance.

Uses of EntityMode in org.hibernate.cfg

Methods in org.hibernate.cfg that return EntityMode
 EntityMode Settings.getDefaultEntityMode()

Uses of EntityMode in org.hibernate.collection

Methods in org.hibernate.collection with parameters of type EntityMode
protected Serializable | PersistentSortedSet.snapshot(BasicCollectionPersister persister, EntityMode entityMode)
protected Serializable | PersistentSortedMap.snapshot(BasicCollectionPersister persister, EntityMode entityMode)

Uses of EntityMode in org.hibernate.engine

Methods in org.hibernate.engine that return EntityMode
 EntityMode SessionImplementor.getEntityMode()

Methods in org.hibernate.engine with parameters of type EntityMode
PersistentCollection | CollectionLoadContext.getLoadingCollection(CollectionPersister persister, Serializable key, Object resultSetId, EntityMode em) Retrieve a collection that is in the process of being loaded, instantiating a new collection if there is nothing for the given id, or returning null if the collection with the given id is already fully loaded in the session
PersistentCollection | CollectionLoadContext.getLoadingCollection(CollectionPersister persister, Serializable id, EntityMode em) Retrieve a collection that is in the process of being loaded, returning null if there is no loading collection with the given id
Serializable[] | BatchFetchQueue.getCollectionBatch(CollectionPersister collectionPersister, Serializable id, int batchSize, EntityMode entityMode) Get a batch of uninitialized collection keys for a given role
Serializable[] | BatchFetchQueue.getEntityBatch(EntityPersister persister, Serializable id, int batchSize, EntityMode entityMode) Get a batch of unloaded identifiers for this class, using a slightly complex algorithm that tries to grab keys registered immediately after the given key.

Constructors in org.hibernate.engine with parameters of type EntityMode
TypedValue(Type type, Object value, EntityMode entityMode)
EntityUniqueKey(String entityName, String uniqueKeyName, Object semiResolvedKey, Type keyType, EntityMode entityMode, SessionFactoryImplementor factory)
EntityKey(Serializable id, EntityPersister persister, EntityMode entityMode)
Construct a unique identifier for an entity class instance
CollectionKey(CollectionPersister persister, Serializable key, EntityMode em)

Uses of EntityMode in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type EntityMode
protected Serializable | DefaultUpdateEventListener.getUpdateId(Object entity, EntityPersister persister, Serializable requestedId, EntityMode entityMode) If the user specified an id, assign it to the instance and use that, otherwise use the id already assigned to the instance
protected Serializable | DefaultSaveOrUpdateEventListener.getUpdateId(Object entity, EntityPersister persister, Serializable requestedId, EntityMode entityMode)
void | DefaultFlushEntityEventListener.checkId(Object object, EntityPersister persister, Serializable id, EntityMode entityMode) make sure user didn't mangle the id
protected void | DefaultFlushEntityEventListener.validate(Object entity, EntityPersister persister, Status status, EntityMode entityMode)

Uses of EntityMode in org.hibernate.impl

Methods in org.hibernate.impl that return EntityMode
EntityMode | StatelessSessionImpl.getEntityMode()
EntityMode | SessionImpl.getEntityMode()

Methods in org.hibernate.impl with parameters of type EntityMode
 Session SessionImpl.getSession(EntityMode entityMode)

Uses of EntityMode in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type EntityMode
String | Subclass.getTuplizerImplClassName(EntityMode mode)
String | Property.getAccessorPropertyName(EntityMode mode)
void | PersistentClass.addTuplizer(EntityMode entityMode, String implClassName)
String | PersistentClass.getTuplizerImplClassName(EntityMode mode)
void | Component.addTuplizer(EntityMode entityMode, String implClassName)
String | Component.getTuplizerImplClassName(EntityMode mode)

Uses of EntityMode in org.hibernate.metadata

Methods in org.hibernate.metadata with parameters of type EntityMode
Class | ClassMetadata.getMappedClass(EntityMode entityMode) The persistent class, or null
Object | ClassMetadata.instantiate(Serializable id, EntityMode entityMode) Create a class instance initialized with the given identifier
Object | ClassMetadata.getPropertyValue(Object object, String propertyName, EntityMode entityMode) Get the value of a particular (named) property
Object[] | ClassMetadata.getPropertyValues(Object entity, EntityMode entityMode) Extract the property values from the given entity.
void | ClassMetadata.setPropertyValue(Object object, String propertyName, Object value, EntityMode entityMode) Set the value of a particular (named) property
void | ClassMetadata.setPropertyValues(Object object, Object[] values, EntityMode entityMode) Set the given values to the mapped properties of the given object
Serializable | ClassMetadata.getIdentifier(Object entity, EntityMode entityMode) Get the identifier of an instance (throw an exception if no identifier property)
void | ClassMetadata.setIdentifier(Object object, Serializable id, EntityMode entityMode) Set the identifier of an instance (or do nothing if no identifier property)
boolean | ClassMetadata.implementsLifecycle(EntityMode entityMode) Does the class implement the Lifecycle interface?
boolean | ClassMetadata.implementsValidatable(EntityMode entityMode) Does the class implement the Validatable interface?
Object | ClassMetadata.getVersion(Object object, EntityMode entityMode) Get the version number (or timestamp) from the object's version property (or return null if not versioned)

Uses of EntityMode in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return EntityMode
EntityMode | EntityPersister.guessEntityMode(Object object) Try to discover the entity mode from the entity instance
EntityMode | AbstractEntityPersister.guessEntityMode(Object object)

Methods in org.hibernate.persister.entity with parameters of type EntityMode
boolean | EntityPersister.isInstrumented(EntityMode entityMode) Has the class actually been bytecode instrumented?
Class | EntityPersister.getMappedClass(EntityMode entityMode) The persistent class, or null
boolean | EntityPersister.implementsLifecycle(EntityMode entityMode) Does the class implement the Lifecycle interface.
boolean | EntityPersister.implementsValidatable(EntityMode entityMode) Does the class implement the Validatable interface.
Class | EntityPersister.getConcreteProxyClass(EntityMode entityMode) Get the proxy interface that instances of this concrete class will be cast to (optional operation).
void | EntityPersister.setPropertyValues(Object object, Object[] values, EntityMode entityMode) Set the given values to the mapped properties of the given object
void | EntityPersister.setPropertyValue(Object object, int i, Object value, EntityMode entityMode) Set the value of a particular property
Object[] | EntityPersister.getPropertyValues(Object object, EntityMode entityMode) Return the (loaded) values of the mapped properties of the object (not including backrefs)
Object | EntityPersister.getPropertyValue(Object object, int i, EntityMode entityMode) Get the value of a particular property
Object | EntityPersister.getPropertyValue(Object object, String propertyName, EntityMode entityMode) Get the value of a particular property
Serializable | EntityPersister.getIdentifier(Object object, EntityMode entityMode) Get the identifier of an instance (throw an exception if no identifier property)
void | EntityPersister.setIdentifier(Object object, Serializable id, EntityMode entityMode) Set the identifier of an instance (or do nothing if no identifier property)
Object | EntityPersister.getVersion(Object object, EntityMode entityMode) Get the version number (or timestamp) from the object's version property (or return null if not versioned)
Object | EntityPersister.instantiate(Serializable id, EntityMode entityMode) Create a class instance initialized with the given identifier
boolean | EntityPersister.isInstance(Object object, EntityMode entityMode) Is the given object an instance of this entity?
boolean | EntityPersister.hasUninitializedLazyProperties(Object object, EntityMode entityMode) Does the given instance have any uninitialized lazy properties?
void | EntityPersister.resetIdentifier(Object entity, Serializable currentId, Object currentVersion, EntityMode entityMode) Set the identifier and version of the given instance back to its "unsaved" value, returning the id
EntityPersister | EntityPersister.getSubclassEntityPersister(Object instance, SessionFactoryImplementor factory, EntityMode entityMode) Get the persister for an instance of this class or a subclass
protected boolean[] | AbstractEntityPersister.getPropertyUpdateability(Object entity, EntityMode entityMode) Which properties appear in the SQL update? (Initialized, updateable ones!)
protected EntityTuplizer | AbstractEntityPersister.getTuplizer(EntityMode entityMode)
boolean | AbstractEntityPersister.isInstrumented(EntityMode entityMode)
Class | AbstractEntityPersister.getMappedClass(EntityMode entityMode)
boolean | AbstractEntityPersister.implementsLifecycle(EntityMode entityMode)
boolean | AbstractEntityPersister.implementsValidatable(EntityMode entityMode)
Class | AbstractEntityPersister.getConcreteProxyClass(EntityMode entityMode)
void | AbstractEntityPersister.setPropertyValues(Object object, Object[] values, EntityMode entityMode)
void | AbstractEntityPersister.setPropertyValue(Object object, int i, Object value, EntityMode entityMode)
Object[] | AbstractEntityPersister.getPropertyValues(Object object, EntityMode entityMode)
Object | AbstractEntityPersister.getPropertyValue(Object object, int i, EntityMode entityMode)
Object | AbstractEntityPersister.getPropertyValue(Object object, String propertyName, EntityMode entityMode)
Serializable | AbstractEntityPersister.getIdentifier(Object object, EntityMode entityMode)
void | AbstractEntityPersister.setIdentifier(Object object, Serializable id, EntityMode entityMode)
Object | AbstractEntityPersister.getVersion(Object object, EntityMode entityMode)
Object | AbstractEntityPersister.instantiate(Serializable id, EntityMode entityMode)
boolean | AbstractEntityPersister.isInstance(Object object, EntityMode entityMode)
boolean | AbstractEntityPersister.hasUninitializedLazyProperties(Object object, EntityMode entityMode)
void | AbstractEntityPersister.resetIdentifier(Object entity, Serializable currentId, Object currentVersion, EntityMode entityMode)
EntityPersister | AbstractEntityPersister.getSubclassEntityPersister(Object instance, SessionFactoryImplementor factory, EntityMode entityMode)
void | AbstractEntityPersister.setPropertyValue(Object object, String propertyName, Object value, EntityMode entityMode)

Uses of EntityMode in org.hibernate.pretty

Methods in org.hibernate.pretty with parameters of type EntityMode
String | Printer.toString(Object entity, EntityMode entityMode)
void | Printer.toString(Iterator iter, EntityMode entityMode)

Uses of EntityMode in org.hibernate.property

Methods in org.hibernate.property with parameters of type EntityMode
static PropertyAccessor PropertyAccessorFactory.getPropertyAccessor(Property property, EntityMode mode)
Retrieves a PropertyAccessor instance based on the given property definition and entity mode.

Uses of EntityMode in org.hibernate.tuple

Methods in org.hibernate.tuple that return EntityMode
 EntityMode EntityModeToTuplizerMapping.guessEntityMode(Object object)
Given a supposed instance of an entity/component, guess its entity mode.

Methods in org.hibernate.tuple with parameters of type EntityMode
protected void | EntityModeToTuplizerMapping.addTuplizer(EntityMode entityMode, Tuplizer tuplizer)
Tuplizer | EntityModeToTuplizerMapping.getTuplizerOrNull(EntityMode entityMode) Locate the contained tuplizer responsible for the given entity-mode.
Tuplizer | EntityModeToTuplizerMapping.getTuplizer(EntityMode entityMode) Locate the tuplizer contained within this mapping which is responsible for the given entity-mode.

Uses of EntityMode in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity that return EntityMode
EntityMode | PojoEntityTuplizer.getEntityMode()
EntityMode | EntityMetamodel.guessEntityMode(Object object)
EntityMode | DynamicMapEntityTuplizer.getEntityMode()
EntityMode | Dom4jEntityTuplizer.getEntityMode()
protected abstract EntityMode | AbstractEntityTuplizer.getEntityMode() Return the entity-mode handled by this tuplizer instance.

Methods in org.hibernate.tuple.entity with parameters of type EntityMode
EntityTuplizer | EntityMetamodel.getTuplizer(EntityMode entityMode)
EntityTuplizer | EntityMetamodel.getTuplizerOrNull(EntityMode entityMode)

Uses of EntityMode in org.hibernate.type

Methods in org.hibernate.type with parameters of type EntityMode
boolean | Type.isSame(Object x, Object y, EntityMode entityMode) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.
boolean | Type.isEqual(Object x, Object y, EntityMode entityMode) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
boolean | Type.isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
int | Type.getHashCode(Object x, EntityMode entityMode) Get a hashcode, consistent with persistence "equality"
int | Type.getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory) Get a hashcode, consistent with persistence "equality"
int | Type.compare(Object x, Object y, EntityMode entityMode) compare two instances of the type
Object | Type.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory) Return a deep copy of the persistent state, stopping at entities and at collections.
int | TimeZoneType.compare(Object x, Object y, EntityMode entityMode)
int | TimeType.getHashCode(Object x, EntityMode entityMode)
int | TimestampType.getHashCode(Object x, EntityMode entityMode)
int | SerializableType.getHashCode(Object x, EntityMode entityMode)
boolean | NullableType.isEqual(Object x, Object y, EntityMode entityMode)
Object | MutableType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Object | MetaType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
int | LocaleType.compare(Object x, Object y, EntityMode entityMode)
Object | ImmutableType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
boolean | EntityType.isSame(Object x, Object y, EntityMode entityMode)
int | EntityType.compare(Object x, Object y, EntityMode entityMode)
Object | EntityType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
int | EntityType.getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory)
boolean | EntityType.isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory)
int | DateType.getHashCode(Object x, EntityMode entityMode)
boolean | CustomType.isEqual(Object x, Object y, EntityMode entityMode)
int | CustomType.getHashCode(Object x, EntityMode entityMode)
Object | CustomType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Object[] | CompositeCustomType.getPropertyValues(Object component, EntityMode entityMode)
void | CompositeCustomType.setPropertyValues(Object component, Object[] values, EntityMode entityMode)
Object | CompositeCustomType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
boolean | CompositeCustomType.isEqual(Object x, Object y, EntityMode entityMode)
int | CompositeCustomType.getHashCode(Object x, EntityMode entityMode)
boolean | ComponentType.isSame(Object x, Object y, EntityMode entityMode)
boolean | ComponentType.isEqual(Object x, Object y, EntityMode entityMode)
boolean | ComponentType.isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory)
int | ComponentType.compare(Object x, Object y, EntityMode entityMode)
int | ComponentType.getHashCode(Object x, EntityMode entityMode)
int | ComponentType.getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory)
Object | ComponentType.getPropertyValue(Object component, int i, EntityMode entityMode)
Object[] | ComponentType.getPropertyValues(Object component, EntityMode entityMode)
void | ComponentType.setPropertyValues(Object component, Object[] values, EntityMode entityMode)
Object | ComponentType.deepCopy(Object component, EntityMode entityMode, SessionFactoryImplementor factory)
Object | ComponentType.instantiate(EntityMode entityMode) This method does not populate the component parent
boolean | CollectionType.isEqual(Object x, Object y, EntityMode entityMode)
int | CollectionType.compare(Object x, Object y, EntityMode entityMode)
int | CollectionType.getHashCode(Object x, EntityMode entityMode)
Object | CollectionType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
boolean | CollectionType.hasHolder(EntityMode entityMode)
protected boolean | CollectionType.initializeImmediately(EntityMode entityMode)
boolean | ClobType.isEqual(Object x, Object y, EntityMode entityMode)
int | ClobType.getHashCode(Object x, EntityMode entityMode)
int | ClobType.compare(Object x, Object y, EntityMode entityMode)
Object | ClobType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
int | CalendarType.compare(Object x, Object y, EntityMode entityMode)
int | CalendarType.getHashCode(Object x, EntityMode entityMode)
int | CalendarDateType.compare(Object x, Object y, EntityMode entityMode)
int | CalendarDateType.getHashCode(Object x, EntityMode entityMode)
boolean | BlobType.isEqual(Object x, Object y, EntityMode entityMode)
int | BlobType.getHashCode(Object x, EntityMode entityMode)
int | BlobType.compare(Object x, Object y, EntityMode entityMode)
Object | BlobType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
int | BigIntegerType.getHashCode(Object x, EntityMode entityMode)
int | BigDecimalType.getHashCode(Object x, EntityMode entityMode)
protected boolean | ArrayType.initializeImmediately(EntityMode entityMode)
boolean | ArrayType.hasHolder(EntityMode entityMode)
Object | AnyType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
boolean | AnyType.isSame(Object x, Object y, EntityMode entityMode)
int | AnyType.compare(Object x, Object y, EntityMode entityMode)
void | AnyType.setPropertyValues(Object component, Object[] values, EntityMode entityMode)
Object[] | AnyType.getPropertyValues(Object component, EntityMode entityMode)
int | AdaptedImmutableType.getHashCode(Object x, EntityMode entityMode)
int | AdaptedImmutableType.compare(Object x, Object y, EntityMode entityMode)
int | AbstractType.compare(Object x, Object y, EntityMode entityMode)
boolean | AbstractType.isSame(Object x, Object y, EntityMode entityMode)
boolean | AbstractType.isEqual(Object x, Object y, EntityMode entityMode)
int | AbstractType.getHashCode(Object x, EntityMode entityMode)
boolean | AbstractType.isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory)
int | AbstractType.getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory)
Object[] | AbstractComponentType.getPropertyValues(Object component, EntityMode entityMode) Optional operation
void | AbstractComponentType.setPropertyValues(Object component, Object[] values, EntityMode entityMode) Optional operation
int | AbstractBynaryType.getHashCode(Object x, EntityMode entityMode)
int | AbstractBynaryType.compare(Object x, Object y, EntityMode entityMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.FetchMode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.FetchMode

Packages that use FetchMode
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of FetchMode in org.hibernate

Fields in org.hibernate declared as FetchMode
static FetchMode | FetchMode.DEFAULT Default to the setting configured in the mapping file.
static FetchMode | FetchMode.JOIN Fetch using an outer join.
static FetchMode | FetchMode.SELECT Fetch eagerly, using a separate select.
static FetchMode | FetchMode.LAZY Deprecated. use FetchMode.SELECT
static FetchMode | FetchMode.EAGER Deprecated. use FetchMode.JOIN

Methods in org.hibernate with parameters of type FetchMode
 Criteria Criteria.setFetchMode(String associationPath, FetchMode mode)
Specify an association fetching strategy for an association or a collection of values.

Uses of FetchMode in org.hibernate.criterion

Methods in org.hibernate.criterion with parameters of type FetchMode
 DetachedCriteria DetachedCriteria.setFetchMode(String associationPath, FetchMode mode)

Uses of FetchMode in org.hibernate.impl

Methods in org.hibernate.impl that return FetchMode
 FetchMode CriteriaImpl.getFetchMode(String path)

Methods in org.hibernate.impl with parameters of type FetchMode
Criteria | CriteriaImpl.setFetchMode(String associationPath, FetchMode mode)
Criteria | CriteriaImpl.Subcriteria.setFetchMode(String associationPath, FetchMode mode)

Uses of FetchMode in org.hibernate.loader

Methods in org.hibernate.loader with parameters of type FetchMode
protected int | JoinWalker.getJoinType(AssociationType type, FetchMode config, String path, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth, CascadeStyle cascadeStyle) Get the join type (inner, outer, etc) or -1 if the association should not be joined.
protected boolean | JoinWalker.isJoinedFetchEnabledInMapping(FetchMode config, AssociationType type) Does the mapping, and Hibernate default semantics, specify that this association should be fetched by outer joining
protected boolean | JoinWalker.isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) Override on subclasses to enable or suppress joining of certain association types
protected boolean | AbstractEntityJoinWalker.isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) The superclass deliberately excludes collections

Uses of FetchMode in org.hibernate.loader.collection

Methods in org.hibernate.loader.collection with parameters of type FetchMode
protected  int BasicCollectionJoinWalker.getJoinType(AssociationType type, FetchMode config, String path, Set visitedAssociations, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth)
We can use an inner join for first many-to-many association

Uses of FetchMode in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria with parameters of type FetchMode
protected  int CriteriaJoinWalker.getJoinType(AssociationType type, FetchMode config, String path, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth, CascadeStyle cascadeStyle)

Uses of FetchMode in org.hibernate.loader.entity

Methods in org.hibernate.loader.entity with parameters of type FetchMode
protected boolean | EntityJoinWalker.isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) Disable outer join fetching if this loader obtains an upgrade lock mode
protected boolean | CascadeEntityJoinWalker.isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle)

Uses of FetchMode in org.hibernate.mapping

Methods in org.hibernate.mapping that return FetchMode
FetchMode | Value.getFetchMode()
FetchMode | ToOne.getFetchMode()
FetchMode | SimpleValue.getFetchMode()
FetchMode | OneToMany.getFetchMode()
FetchMode | Fetchable.getFetchMode()
FetchMode | Collection.getFetchMode()

Methods in org.hibernate.mapping with parameters of type FetchMode
void | ToOne.setFetchMode(FetchMode fetchMode)
void | Fetchable.setFetchMode(FetchMode joinedFetch)
void | Collection.setFetchMode(FetchMode fetchMode)

Uses of FetchMode in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that return FetchMode
FetchMode | QueryableCollection.getFetchMode() Should we load this collection role by outerjoining?
FetchMode | AbstractCollectionPersister.getFetchMode()

Uses of FetchMode in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return FetchMode
FetchMode | OuterJoinLoadable.getFetchMode(int i) May this (subclass closure) property be fetched using an SQL outerjoin?
FetchMode | AbstractEntityPersister.getFetchMode(int i)

Uses of FetchMode in org.hibernate.tuple

Methods in org.hibernate.tuple that return FetchMode
 FetchMode StandardProperty.getFetchMode()

Constructors in org.hibernate.tuple with parameters of type FetchMode
StandardProperty(String name, String node, Type type, boolean lazy, boolean insertable, boolean updateable, boolean insertGenerated, boolean updateGenerated, boolean nullable, boolean checkable, boolean versionable, CascadeStyle cascadeStyle, FetchMode fetchMode)
Constructs StandardProperty instances.

Uses of FetchMode in org.hibernate.type

Methods in org.hibernate.type that return FetchMode
FetchMode | CompositeCustomType.getFetchMode(int i)
FetchMode | ComponentType.getFetchMode(int i)
FetchMode | AnyType.getFetchMode(int i)
FetchMode | AbstractComponentType.getFetchMode(int i)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.Filter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.Filter

Packages that use Filter
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of Filter in org.hibernate

Methods in org.hibernate that return Filter
Filter | Session.enableFilter(String filterName) Enable the named filter for this current session.
Filter | Session.getEnabledFilter(String filterName) Retrieve a currently enabled filter by name.
Filter | Filter.setParameter(String name, Object value) Set the named parameter's value for this filter.
Filter | Filter.setParameterList(String name, Collection values) Set the named parameter's value list for this filter.
Filter | Filter.setParameterList(String name, Object[] values) Set the named parameter's value list for this filter.

Uses of Filter in org.hibernate.impl

Classes in org.hibernate.impl that implement Filter
 class FilterImpl
Implementation of FilterImpl.

Methods in org.hibernate.impl that return Filter
Filter | SessionImpl.getEnabledFilter(String filterName)
Filter | SessionImpl.enableFilter(String filterName)
Filter | FilterImpl.setParameter(String name, Object value) Set the named parameter's value for this filter.
Filter | FilterImpl.setParameterList(String name, Collection values) Set the named parameter's value list for this filter.
Filter | FilterImpl.setParameterList(String name, Object[] values) Set the named parameter's value list for this filter.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.FlushMode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.FlushMode

Packages that use FlushMode
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of FlushMode in org.hibernate

Fields in org.hibernate declared as FlushMode
static FlushMode | FlushMode.NEVER Deprecated. use MANUAL instead.
static FlushMode | FlushMode.MANUAL The Session is only ever flushed when Session.flush() is explicitly called by the application.
static FlushMode | FlushMode.COMMIT The Session is flushed when Transaction.commit() is called.
static FlushMode | FlushMode.AUTO The Session is sometimes flushed before query execution in order to ensure that queries never return stale state.
static FlushMode | FlushMode.ALWAYS The Session is flushed before every query.

Methods in org.hibernate that return FlushMode
FlushMode | Session.getFlushMode() Get the current flush mode.
static FlushMode | FlushMode.parse(String name)

Methods in org.hibernate with parameters of type FlushMode
void | Session.setFlushMode(FlushMode flushMode) Set the flush mode.
Query | Query.setFlushMode(FlushMode flushMode) Override the current session flush mode, just for this query.
boolean | FlushMode.lessThan(FlushMode other)
static boolean | FlushMode.isManualFlushMode(FlushMode mode)
Criteria | Criteria.setFlushMode(FlushMode flushMode) Override the flush mode for this particular query.

Uses of FlushMode in org.hibernate.cfg

Methods in org.hibernate.cfg that return FlushMode
static FlushMode HbmBinder.getFlushMode(String flushMode)

Uses of FlushMode in org.hibernate.engine

Methods in org.hibernate.engine that return FlushMode
FlushMode | SessionImplementor.getFlushMode()
FlushMode | NamedQueryDefinition.getFlushMode()

Methods in org.hibernate.engine with parameters of type FlushMode
 void SessionImplementor.setFlushMode(FlushMode fm)

Constructors in org.hibernate.engine with parameters of type FlushMode
NamedSQLQueryDefinition(String query, NativeSQLQueryReturn[] queryReturns, List querySpaces, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, CacheMode cacheMode, boolean readOnly, String comment, Map parameterTypes, boolean callable)
This form used to construct a NamedSQLQueryDefinition from the binder code when a the result-set mapping information is explicitly provided in the query definition (i.e., no resultset-mapping used)
NamedSQLQueryDefinition(String query, String resultSetRef, List querySpaces, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, CacheMode cacheMode, boolean readOnly, String comment, Map parameterTypes, boolean callable)
This form used to construct a NamedSQLQueryDefinition from the binder code when a resultset-mapping reference is used.
NamedSQLQueryDefinition(String query, String resultSetRef, List querySpaces, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, Map parameterTypes, boolean callable)
This form used from annotations (?).
NamedQueryDefinition(String query, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, Map parameterTypes)
NamedQueryDefinition(String query, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, CacheMode cacheMode, boolean readOnly, String comment, Map parameterTypes)

Uses of FlushMode in org.hibernate.impl

Methods in org.hibernate.impl that return FlushMode
FlushMode | StatelessSessionImpl.getFlushMode()
FlushMode | SessionImpl.getFlushMode()

Methods in org.hibernate.impl with parameters of type FlushMode
void | StatelessSessionImpl.setFlushMode(FlushMode fm)
void | SessionImpl.setFlushMode(FlushMode flushMode)
Criteria | CriteriaImpl.setFlushMode(FlushMode flushMode)
Criteria | CriteriaImpl.Subcriteria.setFlushMode(FlushMode flushMode)
Query | AbstractQueryImpl.setFlushMode(FlushMode flushMode)

Constructors in org.hibernate.impl with parameters of type FlushMode
QueryImpl(String queryString, FlushMode flushMode, SessionImplementor session, ParameterMetadata parameterMetadata)
AbstractQueryImpl(String queryString, FlushMode flushMode, SessionImplementor session, ParameterMetadata parameterMetadata)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.Hibernate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.Hibernate

No usage of org.hibernate.Hibernate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.HibernateException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.HibernateException

Packages that use HibernateException
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.classic | This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.connection | This package abstracts the mechanism for obtaining a JDBC connection.
org.hibernate.context |
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.engine.transaction |
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.exception | This package is a fork of Apache commons-lang nestable exceptions.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.exec |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.intercept | This package implements an interception mechanism for lazy property fetching, based on CGLIB bytecode instrumentation.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.custom.sql |
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.metadata | This package defines an API for accessing the Hibernate runtime metamodel.
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.pretty | Classes for pretty printing things for exception and log messages.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.proxy | This package defines a framework for lazy-initializing entity proxies.
org.hibernate.proxy.dom4j |
org.hibernate.proxy.map |
org.hibernate.proxy.pojo.cglib |
org.hibernate.proxy.pojo.javassist |
org.hibernate.secure | Declarative security for CRUD operations on entities.
org.hibernate.tool.hbm2ddl | The hbm2ddl tool.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.usertype | Interfaces for user-defined custom types.
org.hibernate.util | Utility classes.

Uses of HibernateException in org.hibernate

Subclasses of HibernateException in org.hibernate
class | CallbackException Should be thrown by persistent objects from Lifecycle or Interceptor callbacks.
class | DuplicateMappingException Raised whenever a duplicate for a certain type occurs.
class | InstantiationException Thrown if Hibernate can't instantiate an entity or component class at runtime.
class | InvalidMappingException Thrown when a mapping is found to be invalid.
class | JDBCException Wraps an SQLException.
class | LazyInitializationException Indicates access to unfetched data outside of a session context.
class | MappingException An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
class | MappingNotFoundException Thrown when a resource for a mapping could not be found.
class | NonUniqueObjectException This exception is thrown when an operation would break session-scoped identity.
class | NonUniqueResultException Thrown when the application calls Query.uniqueResult() and the query returned more than one result.
class | ObjectDeletedException Thrown when the user tries to do something illegal with a deleted object.
class | ObjectNotFoundException Thrown when Session.load() fails to select a row with the given primary key (identifier value).
class | PersistentObjectException Thrown when the user passes a persistent instance to a Session method that expects a transient instance.
class | PropertyAccessException A problem occurred accessing a property of an instance of a persistent class by reflection, or via CGLIB.
class | PropertyNotFoundException Indicates that an expected getter or setter method could not be found on a class.
class | PropertyValueException Thrown when the (illegal) value of a property can not be persisted.
class | QueryException A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
class | QueryParameterException Parameter invalid or not found in the query
class | SessionException Thrown when the user calls a method of a Session that is in an inappropropriate state for the given call (for example, the the session is closed or disconnected).
class | StaleObjectStateException A StaleStateException that carries information about a particular entity instance that was the source of the failure.
class | StaleStateException Thrown when a version number or timestamp check failed, indicating that the Session contained stale data (when using long transactions with versioning).
class | TransactionException Indicates that a transaction could not be begun, committed or rolled back.
class | TransientObjectException Thrown when the user passes a transient instance to a Session method that expects a persistent instance.
class | TypeMismatchException Used when a user provided type does not match the expected one
class | UnresolvableObjectException Thrown when Hibernate could not resolve an object by id, especially when loading an association.
class | WrongClassException Thrown when Session.load() selects a row with the given primary key (identifier value) but the row's discriminator value specifies a subclass that is not assignable to the class requested by the user.

Methods in org.hibernate that throw HibernateException
 void Transaction.begin()
Begin a new transaction.
 void Transaction.commit()
Flush the associated Session and end the unit of work (unless we are in FlushMode.NEVER.
 void Transaction.rollback()
Force the underlying transaction to roll back.
 boolean Transaction.wasRolledBack()
Was this transaction rolled back or set to rollback only?

This only accounts for actions initiated from this local transaction.

 boolean Transaction.wasCommitted()
Check if this transaction was successfully committed.
 boolean Transaction.isActive()
Is this transaction still active?

Again, this only returns information in relation to the local transaction, not the actual underlying transaction.

 void Transaction.registerSynchronization(Synchronization synchronization)
Register a user synchronization callback for this transaction.
 SQLQuery StatelessSession.createSQLQuery(String queryString)
Create a new instance of SQLQuery for the given SQL query string.
 Session SessionFactory.openSession(Interceptor interceptor)
Create database connection and open a Session on it, specifying an interceptor.
 Session SessionFactory.openSession()
Create database connection and open a Session on it.
 Session SessionFactory.getCurrentSession()
Obtains the current session.
 ClassMetadata SessionFactory.getClassMetadata(Class persistentClass)
Get the ClassMetadata associated with the given entity class
 ClassMetadata SessionFactory.getClassMetadata(String entityName)
Get the ClassMetadata associated with the given entity name
 CollectionMetadata SessionFactory.getCollectionMetadata(String roleName)
Get the CollectionMetadata associated with the named collection role
 Map SessionFactory.getAllClassMetadata()
Get all ClassMetadata as a Map from entityname String to metadata object
 Map SessionFactory.getAllCollectionMetadata()
Get all CollectionMetadata as a Map from role name to metadata object
 void SessionFactory.close()
Destroy this SessionFactory and release all resources (caches, connection pools, etc).
 void SessionFactory.evict(Class persistentClass)
Evict all entries from the second-level cache.
 void SessionFactory.evict(Class persistentClass, Serializable id)
Evict an entry from the second-level cache.
 void SessionFactory.evictEntity(String entityName)
Evict all entries from the second-level cache.
 void SessionFactory.evictEntity(String entityName, Serializable id)
Evict an entry from the second-level cache.
 void SessionFactory.evictCollection(String roleName)
Evict all entries from the second-level cache.
 void SessionFactory.evictCollection(String roleName, Serializable id)
Evict an entry from the second-level cache.
 void SessionFactory.evictQueries()
Evict any query result sets cached in the default query cache region.
 void SessionFactory.evictQueries(String cacheRegion)
Evict any query result sets cached in the named query cache region.
 FilterDefinition SessionFactory.getFilterDefinition(String filterName)
Obtain the definition of a filter by name.
 void Session.flush()
Force the Session to flush.
 Connection Session.connection()
Get the JDBC connection of this Session.

If the session is using aggressive collection release (as in a CMT environment), it is the application's responsibility to close the connection returned by this call.
 Connection Session.close()
End the Session by disconnecting from the JDBC connection and cleaning up.
 void Session.cancelQuery()
Cancel execution of the current query.
 boolean Session.isDirty()
Does this Session contain any changes which must be synchronized with the database? Would any SQL be executed if we flushed this session?
 Serializable Session.getIdentifier(Object object)
Return the identifier of an entity instance cached by the Session, or throw an exception if the instance is transient or associated with a different Session.
 void Session.evict(Object object)
Remove this instance from the session cache.
 Object Session.load(Class theClass, Serializable id, LockMode lockMode)
Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.
 Object Session.load(String entityName, Serializable id, LockMode lockMode)
Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.
 Object Session.load(Class theClass, Serializable id)
Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.
 Object Session.load(String entityName, Serializable id)
Return the persistent instance of the given entity class with the given identifier, assuming that the instance exists.
 void Session.load(Object object, Serializable id)
Read the persistent state associated with the given identifier into the given transient instance.
 void Session.replicate(Object object, ReplicationMode replicationMode)
Persist the state of the given detached instance, reusing the current identifier value.
 void Session.replicate(String entityName, Object object, ReplicationMode replicationMode)
Persist the state of the given detached instance, reusing the current identifier value.
 Serializable Session.save(Object object)
Persist the given transient instance, first assigning a generated identifier.
 Serializable Session.save(String entityName, Object object)
Persist the given transient instance, first assigning a generated identifier.
 void Session.saveOrUpdate(Object object)
Either save() or update() the given instance, depending upon the value of its identifier property.
 void Session.saveOrUpdate(String entityName, Object object)
Either save() or update() the given instance, depending upon the value of its identifier property.
 void Session.update(Object object)
Update the persistent instance with the identifier of the given detached instance.
 void Session.update(String entityName, Object object)
Update the persistent instance with the identifier of the given detached instance.
 Object Session.merge(Object object)
Copy the state of the given object onto the persistent object with the same identifier.
 Object Session.merge(String entityName, Object object)
Copy the state of the given object onto the persistent object with the same identifier.
 void Session.persist(Object object)
Make a transient instance persistent.
 void Session.persist(String entityName, Object object)
Make a transient instance persistent.
 void Session.delete(Object object)
Remove a persistent instance from the datastore.
 void Session.delete(String entityName, Object object)
Remove a persistent instance from the datastore.
 void Session.lock(Object object, LockMode lockMode)
Obtain the specified lock level upon the given object.
 void Session.lock(String entityName, Object object, LockMode lockMode)
Obtain the specified lock level upon the given object.
 void Session.refresh(Object object)
Re-read the state of the given instance from the underlying database.
 void Session.refresh(Object object, LockMode lockMode)
Re-read the state of the given instance from the underlying database, with the given LockMode.
 LockMode Session.getCurrentLockMode(Object object)
Determine the current lock mode of the given object.
 Transaction Session.beginTransaction()
Begin a unit of work and return the associated Transaction object.
 Query Session.createQuery(String queryString)
Create a new instance of Query for the given HQL query string.
 SQLQuery Session.createSQLQuery(String queryString)
Create a new instance of SQLQuery for the given SQL query string.
 Query Session.createFilter(Object collection, String queryString)
Create a new instance of Query for the given collection and filter string.
 Query Session.getNamedQuery(String queryName)
Obtain an instance of Query for a named query string defined in the mapping file.
 Object Session.get(Class clazz, Serializable id)
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
 Object Session.get(Class clazz, Serializable id, LockMode lockMode)
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
 Object Session.get(String entityName, Serializable id)
Return the persistent instance of the given named entity with the given identifier, or null if there is no such persistent instance.
 Object Session.get(String entityName, Serializable id, LockMode lockMode)
Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
 String Session.getEntityName(Object object)
Return the entity name for a persistent entity
 Connection Session.disconnect()
Disconnect the Session from the current JDBC connection.
 void Session.reconnect()
Deprecated. Manual reconnection is only needed in the case of application-supplied connections, in which case the Session.reconnect(java.sql.Connection) for should be used.
 void Session.reconnect(Connection connection)
Reconnect to the given JDBC connection.
 boolean ScrollableResults.next()
Advance to the next result
 boolean ScrollableResults.previous()
Retreat to the previous result
 boolean ScrollableResults.scroll(int i)
Scroll an arbitrary number of locations
 boolean ScrollableResults.last()
Go to the last result
 boolean ScrollableResults.first()
Go to the first result
 void ScrollableResults.beforeFirst()
Go to a location just before first result (this is the initial location)
 void ScrollableResults.afterLast()
Go to a location just after the last result
 boolean ScrollableResults.isFirst()
Is this the first result?
 boolean ScrollableResults.isLast()
Is this the last result?
 void ScrollableResults.close()
Release resources immediately.
 Object[] ScrollableResults.get()
Get the current row of results
 Object ScrollableResults.get(int i)
Get the ith object in the current row of results, without initializing any other results in the row.
 Integer ScrollableResults.getInteger(int col)
Convenience method to read an integer
 Long ScrollableResults.getLong(int col)
Convenience method to read a long
 Float ScrollableResults.getFloat(int col)
Convenience method to read a float
 Boolean ScrollableResults.getBoolean(int col)
Convenience method to read a boolean
 Double ScrollableResults.getDouble(int col)
Convenience method to read a double
 Short ScrollableResults.getShort(int col)
Convenience method to read a short
 Byte ScrollableResults.getByte(int col)
Convenience method to read a byte
 Character ScrollableResults.getCharacter(int col)
Convenience method to read a character
 byte[] ScrollableResults.getBinary(int col)
Convenience method to read a binary
 String ScrollableResults.getText(int col)
Convenience method to read text
 Blob ScrollableResults.getBlob(int col)
Convenience method to read a blob
 Clob ScrollableResults.getClob(int col)
Convenience method to read a clob
 String ScrollableResults.getString(int col)
Convenience method to read a string
 BigDecimal ScrollableResults.getBigDecimal(int col)
Convenience method to read a big_decimal
 BigInteger ScrollableResults.getBigInteger(int col)
Convenience method to read a big_integer
 Date ScrollableResults.getDate(int col)
Convenience method to read a date, time or timestamp
 Locale ScrollableResults.getLocale(int col)
Convenience method to read a locale
 Calendar ScrollableResults.getCalendar(int col)
Convenience method to read a calendar or calendar_date
 TimeZone ScrollableResults.getTimeZone(int col)
Convenience method to read a timezone
 int ScrollableResults.getRowNumber()
Get the current location in the result set.
 boolean ScrollableResults.setRowNumber(int rowNumber)
Set the current location in the result set, numbered from either the first row (row number 0), or the last row (row number -1).
 Type[] Query.getReturnTypes()
Return the Hibernate types of the query result set.
 String[] Query.getReturnAliases()
Return the HQL select clause aliases (if any)
 String[] Query.getNamedParameters()
Return the names of all named parameters of the query.
 Iterator Query.iterate()
Return the query results as an Iterator.
 ScrollableResults Query.scroll()
Return the query results as ScrollableResults.
 ScrollableResults Query.scroll(ScrollMode scrollMode)
Return the query results as ScrollableResults.
 List Query.list()
Return the query results as a List.
 Object Query.uniqueResult()
Convenience method to return a single instance that matches the query, or null if the query returns no results.
 int Query.executeUpdate()
Execute the update or delete statement.
 Query Query.setParameter(int position, Object val)
Bind a value to a JDBC-style query parameter, guessing the Hibernate type from the class of the given object.
 Query Query.setParameter(String name, Object val)
Bind a value to a named query parameter, guessing the Hibernate type from the class of the given object.
 Query Query.setParameters(Object[] values, Type[] types)
Bind values and types to positional parameters.
 Query Query.setParameterList(String name, Collection vals, Type type)
Bind multiple values to a named query parameter.
 Query Query.setParameterList(String name, Collection vals)
Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the collection.
 Query Query.setParameterList(String name, Object[] vals, Type type)
Bind multiple values to a named query parameter.
 Query Query.setParameterList(String name, Object[] vals)
Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the array.
 Query Query.setProperties(Object bean)
Bind the property values of the given bean to named parameters of the query, matching property names with parameter names and mapping property types to Hibernate types using hueristics.
static Type Hibernate.custom(Class userTypeClass)
A Hibernate custom type.
static Type Hibernate.custom(Class userTypeClass, String[] parameterNames, String[] parameterValues)
A Hibernate parameterizable custom type.
static Type Hibernate.custom(Class userTypeClass, Properties parameters)
A Hibernate parameterizable custom type.
static void Hibernate.initialize(Object proxy)
Force initialization of a proxy or persistent collection.
static void Hibernate.close(Iterator iterator)
Close an Iterator created by iterate() immediately, instead of waiting until the session is closed or disconnected.
 void Filter.validate()
Perform validation of the filter state.
 Criteria Criteria.setFetchMode(String associationPath, FetchMode mode)
Specify an association fetching strategy for an association or a collection of values.
 Criteria Criteria.createAlias(String associationPath, String alias)
Join an association, assigning an alias to the joined association.
 Criteria Criteria.createAlias(String associationPath, String alias, int joinType)
Join an association using the specified join-type, assigning an alias to the joined association.
 Criteria Criteria.createCriteria(String associationPath)
Create a new Criteria, "rooted" at the associated entity.
 Criteria Criteria.createCriteria(String associationPath, int joinType)
Create a new Criteria, "rooted" at the associated entity, using the specified join type.
 Criteria Criteria.createCriteria(String associationPath, String alias)
Create a new Criteria, "rooted" at the associated entity, assigning the given alias.
 Criteria Criteria.createCriteria(String associationPath, String alias, int joinType)
Create a new Criteria, "rooted" at the associated entity, assigning the given alias and using the specified join type.
 List Criteria.list()
Get the results.
 ScrollableResults Criteria.scroll()
Get the results as an instance of ScrollableResults
 ScrollableResults Criteria.scroll(ScrollMode scrollMode)
Get the results as an instance of ScrollableResults based on the given scroll mode.
 Object Criteria.uniqueResult()
Convenience method to return a single instance that matches the query, or null if the query returns no results.
static ConnectionReleaseMode ConnectionReleaseMode.parse(String modeName)
Determine the correct ConnectionReleaseMode instance based on the given name.

Uses of HibernateException in org.hibernate.action

Methods in org.hibernate.action that throw HibernateException
void | Executable.beforeExecutions() Called before executing any actions
void | Executable.execute() Execute this action
void | Executable.afterTransactionCompletion(boolean success) Called after the transaction completes
void | EntityUpdateAction.execute()
void | EntityInsertAction.execute()
void | EntityInsertAction.afterTransactionCompletion(boolean success)
void | EntityIdentityInsertAction.execute()
void | EntityIdentityInsertAction.afterTransactionCompletion(boolean success)
void | EntityDeleteAction.execute()
void | EntityDeleteAction.afterTransactionCompletion(boolean success)
void | CollectionUpdateAction.execute()
void | CollectionRemoveAction.execute()
void | CollectionRecreateAction.execute()
void | BulkOperationCleanupAction.afterTransactionCompletion(boolean success)
void | BulkOperationCleanupAction.beforeExecutions()
void | BulkOperationCleanupAction.execute()

Constructors in org.hibernate.action that throw HibernateException
EntityUpdateAction(Serializable id, Object[] state, int[] dirtyProperties, boolean hasDirtyCollection, Object[] previousState, Object previousVersion, Object nextVersion, Object instance, Object rowId, EntityPersister persister, SessionImplementor session)
EntityInsertAction(Serializable id, Object[] state, Object instance, Object version, EntityPersister persister, SessionImplementor session)
EntityIdentityInsertAction(Object[] state, Object instance, EntityPersister persister, SessionImplementor session, boolean isDelayed)

Uses of HibernateException in org.hibernate.cache

Subclasses of HibernateException in org.hibernate.cache
class | CacheException Something went wrong in the cache
class | NoCachingEnabledException Implementation of NoCachingEnabledException.

Methods in org.hibernate.cache that throw HibernateException
boolean | UpdateTimestampsCache.isUpToDate(Set spaces, Long timestamp)
QueryCache | StandardQueryCacheFactory.getQueryCache(String regionName, UpdateTimestampsCache updateTimestampsCache, Settings settings, Properties props)
boolean | StandardQueryCache.put(QueryKey key, Type[] returnTypes, List result, boolean isNaturalKeyLookup, SessionImplementor session)
List | StandardQueryCache.get(QueryKey key, Type[] returnTypes, boolean isNaturalKeyLookup, Set spaces, SessionImplementor session)
QueryCache | QueryCacheFactory.getQueryCache(String regionName, UpdateTimestampsCache updateTimestampsCache, Settings settings, Properties props)
boolean | QueryCache.put(QueryKey key, Type[] returnTypes, List result, boolean isNaturalKeyLookup, SessionImplementor session)
List | QueryCache.get(QueryKey key, Type[] returnTypes, boolean isNaturalKeyLookup, Set spaces, SessionImplementor session)
static CacheConcurrencyStrategy | CacheFactory.createCache(String concurrencyStrategy, String regionName, boolean mutable, Settings settings, Properties properties)

Constructors in org.hibernate.cache that throw HibernateException
UpdateTimestampsCache(Settings settings, Properties props)
StandardQueryCache(Settings settings, Properties props, UpdateTimestampsCache updateTimestampsCache, String regionName)

Uses of HibernateException in org.hibernate.cache.entry

Methods in org.hibernate.cache.entry that throw HibernateException
 Object[] CacheEntry.assemble(Object instance, Serializable id, EntityPersister persister, Interceptor interceptor, EventSource session)

Constructors in org.hibernate.cache.entry that throw HibernateException
CacheEntry(Object[] state, EntityPersister persister, boolean unfetched, Object version, SessionImplementor session, Object owner)

Uses of HibernateException in org.hibernate.cfg

Methods in org.hibernate.cfg that throw HibernateException
String[] | Configuration.generateDropSchemaScript(Dialect dialect) Generate DDL for dropping tables
String[] | Configuration.generateSchemaCreationScript(Dialect dialect) Generate DDL for creating tables
String[] | Configuration.generateSchemaUpdateScript(Dialect dialect, DatabaseMetadata databaseMetadata) Generate DDL for altering tables
void | Configuration.validateSchema(Dialect dialect, DatabaseMetadata databaseMetadata)
SessionFactory | Configuration.buildSessionFactory() Instantiate a new SessionFactory, using the properties and mappings in this configuration.
protected InputStream | Configuration.getConfigurationInputStream(String resource) Get the configuration file as an InputStream.
Configuration | Configuration.configure() Use the mappings and properties specified in an application resource named hibernate.cfg.xml.
Configuration | Configuration.configure(String resource) Use the mappings and properties specified in the given application resource.
Configuration | Configuration.configure(URL url) Use the mappings and properties specified in the given document.
Configuration | Configuration.configure(File configFile) Use the mappings and properties specified in the given application file.
protected Configuration | Configuration.doConfigure(InputStream stream, String resourceName) Use the mappings and properties specified in the given application resource.
Configuration | Configuration.configure(org.w3c.dom.Document document) Use the mappings and properties specified in the given XML document.
protected Configuration | Configuration.doConfigure(org.dom4j.Document doc)
Settings | Configuration.buildSettings() Create an object-oriented view of the configuration properties
Settings | Configuration.buildSettings(Properties props)

Constructors in org.hibernate.cfg that throw HibernateException
SettingsFactory()

Uses of HibernateException in org.hibernate.classic

Subclasses of HibernateException in org.hibernate.classic
 class ValidationFailure
Thrown from Validatable.validate() when an invariant was violated.

Methods in org.hibernate.classic that throw HibernateException
 Object Session.saveOrUpdateCopy(Object object)
Deprecated. use Session.merge(Object)
 Object Session.saveOrUpdateCopy(Object object, Serializable id)
Deprecated. with no replacement
 Object Session.saveOrUpdateCopy(String entityName, Object object)
Deprecated. use Session.merge(String, Object)
 Object Session.saveOrUpdateCopy(String entityName, Object object, Serializable id)
Deprecated. with no replacement
 List Session.find(String query)
Deprecated. use Session.createQuery(java.lang.String).Query.list()
 List Session.find(String query, Object value, Type type)
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.list()
 List Session.find(String query, Object[] values, Type[] types)
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.list()
 Iterator Session.iterate(String query)
Deprecated. use Session.createQuery(java.lang.String).Query.iterate()
 Iterator Session.iterate(String query, Object value, Type type)
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.iterate()
 Iterator Session.iterate(String query, Object[] values, Type[] types)
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.iterate()
 Collection Session.filter(Object collection, String filter)
Deprecated. use Session.createFilter(Object, String).Query.list()
 Collection Session.filter(Object collection, String filter, Object value, Type type)
Deprecated. use Session.createFilter(Object, String).setXYZ.Query.list()
 Collection Session.filter(Object collection, String filter, Object[] values, Type[] types)
Deprecated. use Session.createFilter(Object, String).setXYZ.Query.list()
 int Session.delete(String query)
Deprecated. consider using HQL delete statements
 int Session.delete(String query, Object value, Type type)
Deprecated. consider using HQL delete statements
 int Session.delete(String query, Object[] values, Type[] types)
Deprecated. consider using HQL delete statements
 void Session.save(Object object, Serializable id)
Deprecated. declare identifier properties for all classes
 void Session.save(String entityName, Object object, Serializable id)
Deprecated. declare identifier properties for all classes
 void Session.update(Object object, Serializable id)
Deprecated. declare identifier properties for all classes
 void Session.update(String entityName, Object object, Serializable id)
Deprecated. declare identifier properties for all classes

Uses of HibernateException in org.hibernate.collection

Methods in org.hibernate.collection that throw HibernateException
protected Serializable | PersistentSortedSet.snapshot(BasicCollectionPersister persister, EntityMode entityMode)
protected Serializable | PersistentSortedMap.snapshot(BasicCollectionPersister persister, EntityMode entityMode)
Serializable | PersistentSet.getSnapshot(CollectionPersister persister)
Collection | PersistentSet.getOrphans(Serializable snapshot, String entityName)
boolean | PersistentSet.equalsSnapshot(CollectionPersister persister)
void | PersistentSet.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Object | PersistentSet.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Serializable | PersistentSet.disassemble(CollectionPersister persister)
Iterator | PersistentSet.getDeletes(CollectionPersister persister, boolean indexIsFormula)
boolean | PersistentSet.needsInserting(Object entry, int i, Type elemType)
void | PersistentMapElementHolder.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentMapElementHolder.disassemble(CollectionPersister persister)
Serializable | PersistentMap.getSnapshot(CollectionPersister persister)
Collection | PersistentMap.getOrphans(Serializable snapshot, String entityName)
boolean | PersistentMap.equalsSnapshot(CollectionPersister persister)
Object | PersistentMap.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
void | PersistentMap.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentMap.disassemble(CollectionPersister persister)
Iterator | PersistentMap.getDeletes(CollectionPersister persister, boolean indexIsFormula)
boolean | PersistentMap.needsInserting(Object entry, int i, Type elemType)
boolean | PersistentMap.needsUpdating(Object entry, int i, Type elemType)
void | PersistentListElementHolder.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentListElementHolder.disassemble(CollectionPersister persister)
Serializable | PersistentList.getSnapshot(CollectionPersister persister)
Collection | PersistentList.getOrphans(Serializable snapshot, String entityName)
boolean | PersistentList.equalsSnapshot(CollectionPersister persister)
Object | PersistentList.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
void | PersistentList.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentList.disassemble(CollectionPersister persister)
Iterator | PersistentList.getDeletes(CollectionPersister persister, boolean indexIsFormula)
boolean | PersistentList.needsInserting(Object entry, int i, Type elemType)
boolean | PersistentList.needsUpdating(Object entry, int i, Type elemType)
Serializable | PersistentIndexedElementHolder.getSnapshot(CollectionPersister persister)
Collection | PersistentIndexedElementHolder.getOrphans(Serializable snapshot, String entityName)
boolean | PersistentIndexedElementHolder.equalsSnapshot(CollectionPersister persister)
Object | PersistentIndexedElementHolder.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Iterator | PersistentIndexedElementHolder.getDeletes(CollectionPersister persister, boolean indexIsFormula)
boolean | PersistentIndexedElementHolder.needsInserting(Object entry, int i, Type elementType)
boolean | PersistentIndexedElementHolder.needsUpdating(Object entry, int i, Type elementType)
void | PersistentIdentifierBag.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentIdentifierBag.disassemble(CollectionPersister persister)
boolean | PersistentIdentifierBag.equalsSnapshot(CollectionPersister persister)
Iterator | PersistentIdentifierBag.getDeletes(CollectionPersister persister, boolean indexIsFormula)
boolean | PersistentIdentifierBag.needsInserting(Object entry, int i, Type elemType)
boolean | PersistentIdentifierBag.needsUpdating(Object entry, int i, Type elemType)
Object | PersistentIdentifierBag.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Serializable | PersistentIdentifierBag.getSnapshot(CollectionPersister persister)
Collection | PersistentIdentifierBag.getOrphans(Serializable snapshot, String entityName)
void | PersistentIdentifierBag.preInsert(CollectionPersister persister)
void | PersistentIdentifierBag.afterRowInsert(CollectionPersister persister, Object entry, int i)
Serializable | PersistentElementHolder.getSnapshot(CollectionPersister persister)
Collection | PersistentElementHolder.getOrphans(Serializable snapshot, String entityName)
boolean | PersistentElementHolder.equalsSnapshot(CollectionPersister persister)
Object | PersistentElementHolder.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
void | PersistentElementHolder.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentElementHolder.disassemble(CollectionPersister persister)
Iterator | PersistentElementHolder.getDeletes(CollectionPersister persister, boolean indexIsFormula)
boolean | PersistentElementHolder.needsInserting(Object entry, int i, Type elementType)
boolean | PersistentElementHolder.needsUpdating(Object entry, int i, Type elementType)
boolean | PersistentCollection.setCurrentSession(SessionImplementor session) Associate the collection with the given session.
void | PersistentCollection.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner) Read the state of the collection from a disassembled cached value
Object | PersistentCollection.readFrom(ResultSet rs, CollectionPersister role, CollectionAliases descriptor, Object owner) Read a row from the JDBC result set
boolean | PersistentCollection.equalsSnapshot(CollectionPersister persister) Does the current state exactly match the snapshot?
Serializable | PersistentCollection.disassemble(CollectionPersister persister) Disassemble the collection, ready for the cache
Serializable | PersistentCollection.getSnapshot(CollectionPersister persister) Return a new snapshot of the current state of the collection
void | PersistentCollection.forceInitialization() To be called internally by the session, forcing immediate initialization.
boolean | PersistentCollection.needsInserting(Object entry, int i, Type elemType) Do we need to insert this element?
boolean | PersistentCollection.needsUpdating(Object entry, int i, Type elemType) Do we need to update this element?
Iterator | PersistentCollection.getDeletes(CollectionPersister persister, boolean indexIsFormula) Get all the elements that need deleting
void | PersistentCollection.preInsert(CollectionPersister persister) Called before inserting rows, to ensure that any surrogate keys are fully generated
void | PersistentCollection.afterRowInsert(CollectionPersister persister, Object entry, int i) Called after inserting a row, to fetch the natively generated id
Collection | PersistentCollection.getOrphans(Serializable snapshot, String entityName) get all "orphaned" elements
Object | PersistentBag.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
boolean | PersistentBag.equalsSnapshot(CollectionPersister persister)
Serializable | PersistentBag.getSnapshot(CollectionPersister persister)
Collection | PersistentBag.getOrphans(Serializable snapshot, String entityName)
Serializable | PersistentBag.disassemble(CollectionPersister persister)
void | PersistentBag.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Iterator | PersistentBag.getDeletes(CollectionPersister persister, boolean indexIsFormula)
boolean | PersistentBag.needsInserting(Object entry, int i, Type elemType)
Serializable | PersistentArrayHolder.getSnapshot(CollectionPersister persister)
Collection | PersistentArrayHolder.getOrphans(Serializable snapshot, String entityName)
boolean | PersistentArrayHolder.equalsSnapshot(CollectionPersister persister)
Object | PersistentArrayHolder.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
void | PersistentArrayHolder.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentArrayHolder.disassemble(CollectionPersister persister)
Iterator | PersistentArrayHolder.getDeletes(CollectionPersister persister, boolean indexIsFormula)
boolean | PersistentArrayHolder.needsInserting(Object entry, int i, Type elemType)
boolean | PersistentArrayHolder.needsUpdating(Object entry, int i, Type elemType)
boolean | AbstractPersistentCollection.setCurrentSession(SessionImplementor session) Associate the collection with the given session.
void | AbstractPersistentCollection.forceInitialization() To be called internally by the session, forcing immediate initialization.
void | AbstractPersistentCollection.preInsert(CollectionPersister persister) Called before inserting rows, to ensure that any surrogate keys are fully generated
void | AbstractPersistentCollection.afterRowInsert(CollectionPersister persister, Object entry, int i) Called after inserting a row, to fetch the natively generated id
abstract Collection | AbstractPersistentCollection.getOrphans(Serializable snapshot, String entityName) get all "orphaned" elements
protected static Collection | AbstractPersistentCollection.getOrphans(Collection oldElements, Collection currentElements, String entityName, SessionImplementor session) Given a collection of entity instances that used to belong to the collection, and a collection of instances that currently belong, return a collection of orphans

Constructors in org.hibernate.collection that throw HibernateException
PersistentMapElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentListElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentIndexedElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentArrayHolder(SessionImplementor session, CollectionPersister persister)

Uses of HibernateException in org.hibernate.connection

Methods in org.hibernate.connection that throw HibernateException
void | UserSuppliedConnectionProvider.configure(Properties props)
void | ProxoolConnectionProvider.configure(Properties props) Initialize the connection provider from given properties.
void | ProxoolConnectionProvider.close() Release all resources held by this provider.
void | DriverManagerConnectionProvider.configure(Properties props)
void | DatasourceConnectionProvider.configure(Properties props)
static ConnectionProvider | ConnectionProviderFactory.newConnectionProvider() Instantiate a ConnectionProvider using System properties.
static ConnectionProvider | ConnectionProviderFactory.newConnectionProvider(Properties properties) Instantiate a ConnectionProvider using given properties.
static ConnectionProvider | ConnectionProviderFactory.newConnectionProvider(Properties properties, Map connectionProviderInjectionData) Instantiate a ConnectionProvider using given properties.
void | ConnectionProvider.configure(Properties props) Initialize the connection provider from given properties.
void | ConnectionProvider.close() Release all resources held by this provider.
void | C3P0ConnectionProvider.configure(Properties props)

Uses of HibernateException in org.hibernate.context

Methods in org.hibernate.context that throw HibernateException
Session | ThreadLocalSessionContext.currentSession()
Session | JTASessionContext.currentSession()
Session | CurrentSessionContext.currentSession() Retrieve the current session according to the scoping defined by this implementation.

Uses of HibernateException in org.hibernate.criterion

Methods in org.hibernate.criterion that throw HibernateException
String | SubqueryExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SubqueryExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | SQLProjection.toSqlString(Criteria criteria, int loc, CriteriaQuery criteriaQuery)
String | SQLProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | SQLProjection.getTypes(Criteria crit, CriteriaQuery criteriaQuery)
String | SQLCriterion.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SQLCriterion.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | SizeExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SizeExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SimpleSubqueryExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | SimpleProjection.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
String | SimpleProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | SimpleExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SimpleExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | RowCountProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | RowCountProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
Type[] | PropertyProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | PropertyProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | PropertyProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | PropertyExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | PropertyExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | ProjectionList.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | ProjectionList.toSqlString(Criteria criteria, int loc, CriteriaQuery criteriaQuery)
String | ProjectionList.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | Projection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery) Render the SQL fragment
String | Projection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment to be used in the group by clause
Type[] | Projection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
Type[] | Projection.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery) Return types for a particular user-visible alias
String | Order.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | NullExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NullExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | NotNullExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NotNullExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | NotExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NotExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NaturalIdentifier.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | NaturalIdentifier.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | LogicalExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | LogicalExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | LikeExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | LikeExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | Junction.getTypedValues(Criteria crit, CriteriaQuery criteriaQuery)
String | Junction.toSqlString(Criteria crit, CriteriaQuery criteriaQuery)
String | InExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | InExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | IlikeExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | IlikeExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | IdentifierProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | IdentifierProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | IdentifierProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | IdentifierEqExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | IdentifierEqExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | Example.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | Example.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
protected void | Example.addComponentTypedValues(String path, Object component, AbstractComponentType type, List list, Criteria criteria, CriteriaQuery criteriaQuery)
protected void | Example.appendPropertyCondition(String propertyName, Object propertyValue, Criteria criteria, CriteriaQuery cq, StringBuffer buf)
protected void | Example.appendComponentCondition(String path, Object component, AbstractComponentType type, Criteria criteria, CriteriaQuery criteriaQuery, StringBuffer buf)
String | Distinct.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | Distinct.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | Distinct.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | Distinct.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
DetachedCriteria | DetachedCriteria.createAlias(String associationPath, String alias)
DetachedCriteria | DetachedCriteria.createCriteria(String associationPath, String alias)
DetachedCriteria | DetachedCriteria.createCriteria(String associationPath)
DetachedCriteria | DetachedCriteria.setFetchMode(String associationPath, FetchMode mode)
String | Criterion.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
TypedValue[] | Criterion.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
String | CriteriaQuery.getColumn(Criteria criteria, String propertyPath) Get the names of the columns mapped by a property path, ignoring projection aliases
Type | CriteriaQuery.getType(Criteria criteria, String propertyPath) Get the type of a property path, ignoring projection aliases
String[] | CriteriaQuery.getColumnsUsingProjection(Criteria criteria, String propertyPath) Get the names of the columns mapped by a property path
Type | CriteriaQuery.getTypeUsingProjection(Criteria criteria, String propertyPath) Get the type of a property path
TypedValue | CriteriaQuery.getTypedValue(Criteria criteria, String propertyPath, Object value) Get the a typed value for the given property value.
Type[] | CountProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | CountProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | BetweenExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | BetweenExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AvgProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | AliasedProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | AliasedProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AliasedProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AliasedProjection.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AggregateProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | AggregateProjection.toSqlString(Criteria criteria, int loc, CriteriaQuery criteriaQuery)
String | AbstractEmptinessExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
protected QueryableCollection | AbstractEmptinessExpression.getQueryableCollection(String entityName, String propertyName, SessionFactoryImplementor factory)
TypedValue[] | AbstractEmptinessExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)

Uses of HibernateException in org.hibernate.dialect

Methods in org.hibernate.dialect that throw HibernateException
static Dialect | DialectFactory.buildDialect(Properties props, String databaseName, int databaseMajorVersion) Builds an appropriate Dialect instance.
String | Dialect.getTypeName(int code) Get the name of the database type associated with the given java.sql.Types typecode.
String | Dialect.getHibernateTypeName(int code)
String | Dialect.getHibernateTypeName(int code, int length, int precision, int scale)
String | Dialect.getTypeName(int code, int length, int precision, int scale) Get the name of the database type associated with the given java.sql.Types typecode.
static Dialect | Dialect.getDialect() Get the Dialect specified by the current System properties.
static Dialect | Dialect.getDialect(Properties props) Get the Dialect specified by the given properties or system properties.

Uses of HibernateException in org.hibernate.engine

Methods in org.hibernate.engine that throw HibernateException
static Object Versioning.getVersion(Object[] fields, EntityPersister persister)
Get the version number of the given instance state snapshot
static void TwoPhaseLoad.postHydrate(EntityPersister persister, Serializable id, Object[] values, Object rowId, Object object, LockMode lockMode, boolean lazyPropertiesAreUnfetched, SessionImplementor session)
Register the "hydrated" state of an entity instance, after the first step of 2-phase loading.
static void TwoPhaseLoad.initializeEntity(Object entity, boolean readOnly, SessionImplementor session, PreLoadEvent preLoadEvent, PostLoadEvent postLoadEvent)
Perform the second step of 2-phase load.
 Serializable TransactionHelper.doWorkInNewTransaction(SessionImplementor session)
Suspend the current transaction and perform work in a new transaction
 Object[] StatefulPersistenceContext.getDatabaseSnapshot(Serializable id, EntityPersister persister)
Get the current state of the entity as known to the underlying database, or null if there is no corresponding row
 Object[] StatefulPersistenceContext.getNaturalIdSnapshot(Serializable id, EntityPersister persister)
 Object StatefulPersistenceContext.unproxy(Object maybeProxy)
Get the entity instance underlying the given proxy, throwing an exception if the proxy is uninitialized.
 Object StatefulPersistenceContext.unproxyAndReassociate(Object maybeProxy)
Possibly unproxy the given reference and reassociate it with the current session.
 void StatefulPersistenceContext.checkUniqueness(EntityKey key, Object object)
Attempts to check whether the given key represents an entity already loaded within the current session.
 Object StatefulPersistenceContext.narrowProxy(Object proxy, EntityPersister persister, EntityKey key, Object object)
If the existing proxy is insufficiently "narrow" (derived), instantiate a new proxy and overwrite the registration of the old one.
 Object StatefulPersistenceContext.proxyFor(EntityPersister persister, EntityKey key, Object impl)
Return the existing proxy associated with the given EntityKey, or the third argument (the entity associated with the key) if no proxy exists.
 Object StatefulPersistenceContext.proxyFor(Object impl)
Return the existing proxy associated with the given EntityKey, or the argument (the entity associated with the key) if no proxy exists.
 void StatefulPersistenceContext.addNewCollection(CollectionPersister persister, PersistentCollection collection)
Add a new collection (ie.
 void StatefulPersistenceContext.addInitializedDetachedCollection(CollectionPersister collectionPersister, PersistentCollection collection)
add an (initialized) collection that was created by another session and passed into update() (ie.
 CollectionEntry StatefulPersistenceContext.addInitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just pulled out of the cache (does not need initializing)
 void StatefulPersistenceContext.initializeNonLazyCollections()
Force initialization of all non-lazy collections encountered during the current two-phase load (actually, this is a no-op, unless this is the "outermost" load)
 void SessionImplementor.initializeCollection(PersistentCollection collection, boolean writing)
Initialize the collection (if not already initialized)
 Object SessionImplementor.internalLoad(String entityName, Serializable id, boolean eager, boolean nullable)
Load an instance without checking if it was deleted.
 Object SessionImplementor.immediateLoad(String entityName, Serializable id)
Load an instance immediately.
 List SessionImplementor.list(String query, QueryParameters queryParameters)
Execute a find() query
 Iterator SessionImplementor.iterate(String query, QueryParameters queryParameters)
Execute an iterate() query
 ScrollableResults SessionImplementor.scroll(String query, QueryParameters queryParameters)
Execute a scroll() query
 List SessionImplementor.listFilter(Object collection, String filter, QueryParameters queryParameters)
Execute a filter
 Iterator SessionImplementor.iterateFilter(Object collection, String filter, QueryParameters queryParameters)
Iterate a filter
 EntityPersister SessionImplementor.getEntityPersister(String entityName, Object object)
Get the EntityPersister for any instance
 Object SessionImplementor.getEntityUsingInterceptor(EntityKey key)
Get the entity instance associated with the given Key, calling the Interceptor if necessary
 String SessionImplementor.guessEntityName(Object entity)
The guessed entity name for an entity not in an association
 Object SessionImplementor.instantiate(String entityName, Serializable id)
Instantiate the entity class, initializing with the given identifier
 List SessionImplementor.listCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
Execute an SQL Query
 ScrollableResults SessionImplementor.scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
Execute an SQL Query
 List SessionImplementor.list(NativeSQLQuerySpecification spec, QueryParameters queryParameters)
Execute a native SQL query, and return the results as a fully built list.
 ScrollableResults SessionImplementor.scroll(NativeSQLQuerySpecification spec, QueryParameters queryParameters)
Execute a native SQL query, and return the results as a scrollable result.
 int SessionImplementor.executeUpdate(String query, QueryParameters queryParameters)
Execute a HQL update or delete query
 int SessionImplementor.executeNativeUpdate(NativeSQLQuerySpecification specification, QueryParameters queryParameters)
Execute a native SQL update or delete query
 Type[] SessionFactoryImplementor.getReturnTypes(String queryString)
Get the return types of a query
 String[] SessionFactoryImplementor.getReturnAliases(String queryString)
Get the return aliases of a query
 QueryCache SessionFactoryImplementor.getQueryCache(String regionName)
Get a particular named query cache, or the default cache
 Session SessionFactoryImplementor.openTemporarySession()
Get a nontransactional "current" session for Hibernate EntityManager
 Session SessionFactoryImplementor.openSession(Connection connection, boolean flushBeforeCompletionEnabled, boolean autoCloseSessionEnabled, ConnectionReleaseMode connectionReleaseMode)
Open a session conforming to the given parameters.
 void QueryParameters.traceParameters(SessionFactoryImplementor factory)
 Object[] PersistenceContext.getDatabaseSnapshot(Serializable id, EntityPersister persister)
Get the current state of the entity as known to the underlying database, or null if there is no corresponding row
 Object[] PersistenceContext.getNaturalIdSnapshot(Serializable id, EntityPersister persister)
 Object PersistenceContext.unproxy(Object maybeProxy)
Get the entity instance underlying the given proxy, throwing an exception if the proxy is uninitialized.
 Object PersistenceContext.unproxyAndReassociate(Object maybeProxy)
Possibly unproxy the given reference and reassociate it with the current session.
 void PersistenceContext.checkUniqueness(EntityKey key, Object object)
Attempts to check whether the given key represents an entity already loaded within the current session.
 Object PersistenceContext.narrowProxy(Object proxy, EntityPersister persister, EntityKey key, Object object)
If the existing proxy is insufficiently "narrow" (derived), instantiate a new proxy and overwrite the registration of the old one.
 Object PersistenceContext.proxyFor(EntityPersister persister, EntityKey key, Object impl)
Return the existing proxy associated with the given EntityKey, or the third argument (the entity associated with the key) if no proxy exists.
 Object PersistenceContext.proxyFor(Object impl)
Return the existing proxy associated with the given EntityKey, or the argument (the entity associated with the key) if no proxy exists.
 void PersistenceContext.addNewCollection(CollectionPersister persister, PersistentCollection collection)
Add a new collection (ie.
 void PersistenceContext.addInitializedDetachedCollection(CollectionPersister collectionPersister, PersistentCollection collection)
add an (initialized) collection that was created by another session and passed into update() (ie.
 CollectionEntry PersistenceContext.addInitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just pulled out of the cache (does not need initializing)
 void PersistenceContext.initializeNonLazyCollections()
Force initialization of all non-lazy collections encountered during the current two-phase load (actually, this is a no-op, unless this is the "outermost" load)
static int ParameterBinder.bindQueryParameters(PreparedStatement st, QueryParameters queryParameters, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)
static int ParameterBinder.bindPositionalParameters(PreparedStatement st, QueryParameters queryParameters, int start, SessionImplementor session)
static int ParameterBinder.bindPositionalParameters(PreparedStatement st, Object[] values, Type[] types, int start, SessionImplementor session)
static int ParameterBinder.bindNamedParameters(PreparedStatement ps, QueryParameters queryParameters, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)
static int ParameterBinder.bindNamedParameters(PreparedStatement ps, Map namedParams, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)
 void Nullability.checkNullability(Object[] values, EntityPersister persister, boolean isUpdate)
Check nullability of the class persister properties
static boolean ForeignKeys.isNotTransient(String entityName, Object entity, Boolean assumed, SessionImplementor session)
Is this instance persistent or detached? If assumed is non-null, don't hit the database to make the determination, instead assume that value; the client code must be prepared to "recover" in the case that this assumed result is incorrect.
static boolean ForeignKeys.isTransient(String entityName, Object entity, Boolean assumed, SessionImplementor session)
Is this instance, which we know is not persistent, actually transient? If assumed is non-null, don't hit the database to make the determination, instead assume that value; the client code must be prepared to "recover" in the case that this assumed result is incorrect.
static Serializable ForeignKeys.getEntityIdentifierIfNotUnsaved(String entityName, Object object, SessionImplementor session)
Return the identifier of the persistent or transient object, or throw an exception if the instance is "unsaved" Used by OneToOneType and ManyToOneType to determine what id value should be used for an object that may or may not be associated with the session.
 void ForeignKeys.Nullifier.nullifyTransientReferences(Object[] values, Type[] types)
Nullify all references to entities that have not yet been inserted in the database, where the foreign key points toward that entity
static void Collections.processUnreachableCollection(PersistentCollection coll, SessionImplementor session)
record the fact that this collection was dereferenced
static void Collections.processReachableCollection(PersistentCollection collection, CollectionType type, Object entity, SessionImplementor session)
Initialize the role of the collection.
 PersistentCollection CollectionLoadContext.getLoadingCollection(CollectionPersister persister, Serializable key, Object resultSetId, EntityMode em)
Retrieve a collection that is in the process of being loaded, instantiating a new collection if there is nothing for the given id, or returning null if the collection with the given id is already fully loaded in the session
 void CollectionLoadContext.endLoadingCollections(CollectionPersister persister, Object resultSetId, SessionImplementor session)
Finish the process of loading collections for a particular result set
 void CollectionEntry.preFlush(PersistentCollection collection)
 void CollectionEntry.postInitialize(PersistentCollection collection)
 void CollectionEntry.postFlush(PersistentCollection collection)
Called after a successful flush
 Collection CollectionEntry.getOrphans(String entityName, PersistentCollection collection)
Get the collection orphans (entities which were removed from the collection)
abstract  void CascadingAction.cascade(EventSource session, Object child, String entityName, Object anything, boolean isCascadeDeleteEnabled)
Cascade the action to the child object.
 void Cascade.cascade(EntityPersister persister, Object parent)
Cascade an action from the parent entity instance to all its children.
 void Cascade.cascade(EntityPersister persister, Object parent, Object anything)
Cascade an action from the parent entity instance to all its children.
 void ActionQueue.executeInserts()
Perform all currently queued entity-insertion actions.
 void ActionQueue.executeActions()
Perform all currently queued actions.
 void ActionQueue.prepareActions()
Prepares the internal action queues for execution.

Uses of HibernateException in org.hibernate.engine.query

Methods in org.hibernate.engine.query that throw HibernateException
int | NativeSQLQueryPlan.performExecuteUpdate(QueryParameters queryParameters, SessionImplementor session)
List | HQLQueryPlan.performList(QueryParameters queryParameters, SessionImplementor session)
Iterator | HQLQueryPlan.performIterate(QueryParameters queryParameters, EventSource session)
ScrollableResults | HQLQueryPlan.performScroll(QueryParameters queryParameters, SessionImplementor session)
int | HQLQueryPlan.performExecuteUpdate(QueryParameters queryParameters, SessionImplementor session)

Uses of HibernateException in org.hibernate.engine.transaction

Methods in org.hibernate.engine.transaction that throw HibernateException
static void | Isolater.doIsolatedWork(IsolatedWork work, SessionImplementor session) Ensures that all processing actually performed by the given work will occur on a seperate transaction.
static void | Isolater.doNonTransactedWork(IsolatedWork work, SessionImplementor session) Ensures that all processing actually performed by the given work will occur outside of a transaction.
void | Isolater.JtaDelegate.delegateWork(IsolatedWork work, boolean transacted)
void | Isolater.JdbcDelegate.delegateWork(IsolatedWork work, boolean transacted)
void | IsolatedWork.doWork(Connection connection) Perform the actual work to be done.

Uses of HibernateException in org.hibernate.event

Methods in org.hibernate.event that throw HibernateException
void | SaveOrUpdateEventListener.onSaveOrUpdate(SaveOrUpdateEvent event) Handle the given update event.
void | ReplicateEventListener.onReplicate(ReplicateEvent event) Handle the given replicate event.
void | RefreshEventListener.onRefresh(RefreshEvent event) Handle the given refresh event.
void | RefreshEventListener.onRefresh(RefreshEvent event, Map refreshedAlready)
void | PersistEventListener.onPersist(PersistEvent event) Handle the given create event.
void | PersistEventListener.onPersist(PersistEvent event, Map createdAlready) Handle the given create event.
void | MergeEventListener.onMerge(MergeEvent event) Handle the given merge event.
void | MergeEventListener.onMerge(MergeEvent event, Map copiedAlready) Handle the given merge event.
void | LockEventListener.onLock(LockEvent event) Handle the given lock event.
void | LoadEventListener.onLoad(LoadEvent event, LoadEventListener.LoadType loadType) Handle the given load event.
void | InitializeCollectionEventListener.onInitializeCollection(InitializeCollectionEvent event)
void | FlushEventListener.onFlush(FlushEvent event) Handle the given flush event.
void | FlushEntityEventListener.onFlushEntity(FlushEntityEvent event)
void | EvictEventListener.onEvict(EvictEvent event) Handle the given evict event.
Object | EventSource.instantiate(EntityPersister persister, Serializable id) Instantiate an entity instance, using either an interceptor, or the given persister
void | EventSource.forceFlush(EntityEntry e) Force an immediate flush
void | EventSource.merge(String entityName, Object object, Map copiedAlready) Cascade merge an entity instance
void | EventSource.persist(String entityName, Object object, Map createdAlready) Cascade persist an entity instance
void | EventSource.refresh(Object object, Map refreshedAlready) Cascade refesh an entity instance
void | EventSource.saveOrUpdateCopy(String entityName, Object object, Map copiedAlready) Cascade copy an entity instance
void | DirtyCheckEventListener.onDirtyCheck(DirtyCheckEvent event) Handle the given dirty-check event.
void | DeleteEventListener.onDelete(DeleteEvent event) Handle the given delete event.
void | DeleteEventListener.onDelete(DeleteEvent event, Set transientEntities)
void | AutoFlushEventListener.onAutoFlush(AutoFlushEvent event) Handle the given auto-flush event.

Uses of HibernateException in org.hibernate.event.def

Methods in org.hibernate.event.def that throw HibernateException
 void ReattachVisitor.removeCollection(CollectionPersister role, Serializable id, EventSource source)
Schedules a collection for deletion.
protected  void ProxyVisitor.reattachCollection(PersistentCollection collection, CollectionType type)
Reattach a detached (disassociated) initialized or uninitialized collection wrapper, using a snapshot carried with the collection wrapper
protected  Serializable DefaultUpdateEventListener.getUpdateId(Object entity, EntityPersister persister, Serializable requestedId, EntityMode entityMode)
If the user specified an id, assign it to the instance and use that, otherwise use the id already assigned to the instance
 void DefaultSaveOrUpdateEventListener.onSaveOrUpdate(SaveOrUpdateEvent event)
Handle the given update event.
protected  Serializable DefaultSaveOrUpdateEventListener.entityIsPersistent(SaveOrUpdateEvent event)
protected  Serializable DefaultSaveOrUpdateEventListener.entityIsTransient(SaveOrUpdateEvent event)
Handle the given save event.
protected  void DefaultSaveOrUpdateEventListener.entityIsDetached(SaveOrUpdateEvent event)
Handle the given update event.
protected  Serializable DefaultSaveOrUpdateEventListener.getUpdateId(Object entity, EntityPersister persister, Serializable requestedId, EntityMode entityMode)
protected  void DefaultSaveOrUpdateEventListener.performUpdate(SaveOrUpdateEvent event, Object entity, EntityPersister persister)
 void DefaultReplicateEventListener.onReplicate(ReplicateEvent event)
Handle the given replicate event.
 void DefaultRefreshEventListener.onRefresh(RefreshEvent event)
 void DefaultRefreshEventListener.onRefresh(RefreshEvent event, Map refreshedAlready)
Handle the given refresh event.
 void DefaultPersistEventListener.onPersist(PersistEvent event)
Handle the given create event.
 void DefaultPersistEventListener.onPersist(PersistEvent event, Map createCache)
Handle the given create event.
protected  void DefaultPersistEventListener.entityIsTransient(PersistEvent event, Map createCache)
Handle the given create event.
 void DefaultMergeEventListener.onMerge(MergeEvent event)
Handle the given merge event.
 void DefaultMergeEventListener.onMerge(MergeEvent event, Map copyCache)
Handle the given merge event.
protected  void DefaultMergeEventListener.cascadeAfterSave(EventSource source, EntityPersister persister, Object entity, Object anything)
Cascade behavior is redefined by this subclass, disable superclass behavior
protected  void DefaultMergeEventListener.cascadeBeforeSave(EventSource source, EntityPersister persister, Object entity, Object anything)
Cascade behavior is redefined by this subclass, disable superclass behavior
 void DefaultLockEventListener.onLock(LockEvent event)
Handle the given lock event.
 void DefaultLoadEventListener.onLoad(LoadEvent event, LoadEventListener.LoadType loadType)
Handle the given load event.
protected  Object DefaultLoadEventListener.load(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options)
Perfoms the load of an entity.
protected  Object DefaultLoadEventListener.proxyOrLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options)
Based on configured options, will either return a pre-existing proxy, generate a new proxy, or perform an actual load.
protected  Object DefaultLoadEventListener.lockAndLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options, SessionImplementor source)
If the class to be loaded has been configured with a cache, then lock given id in that cache and then perform the load.
protected  Object DefaultLoadEventListener.doLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options)
Coordinates the efforts to load a given entity.
protected  Object DefaultLoadEventListener.loadFromDatasource(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options)
Performs the process of loading an entity from the configured underlying datasource.
protected  Object DefaultLoadEventListener.loadFromSessionCache(LoadEvent event, EntityKey keyToLoad, LoadEventListener.LoadType options)
Attempts to locate the entity in the session-level cache.
protected  Object DefaultLoadEventListener.loadFromSecondLevelCache(LoadEvent event, EntityPersister persister, LoadEventListener.LoadType options)
Attempts to load the entity from the second-level cache.
 void DefaultInitializeCollectionEventListener.onInitializeCollection(InitializeCollectionEvent event)
called by a collection that wants to initialize itself
 void DefaultFlushEventListener.onFlush(FlushEvent event)
Handle the given flush event.
 void DefaultFlushEntityEventListener.checkId(Object object, EntityPersister persister, Serializable id, EntityMode entityMode)
make sure user didn't mangle the id
 void DefaultFlushEntityEventListener.onFlushEntity(FlushEntityEvent event)
Flushes a single entity's state to the database, by scheduling an update action, if necessary
protected  boolean DefaultFlushEntityEventListener.isUpdateNecessary(FlushEntityEvent event)
Performs all necessary checking to determine if an entity needs an SQL update to synchronize its state to the database.
protected  void DefaultFlushEntityEventListener.dirtyCheck(FlushEntityEvent event)
Perform a dirty check, and attach the results to the event
 void DefaultEvictEventListener.onEvict(EvictEvent event)
Handle the given evict event.
protected  void DefaultEvictEventListener.doEvict(Object object, EntityKey key, EntityPersister persister, EventSource session)
 void DefaultDirtyCheckEventListener.onDirtyCheck(DirtyCheckEvent event)
Handle the given dirty-check event.
 void DefaultDeleteEventListener.onDelete(DeleteEvent event)
Handle the given delete event.
 void DefaultDeleteEventListener.onDelete(DeleteEvent event, Set transientEntities)
protected  void DefaultDeleteEventListener.deleteEntity(EventSource session, Object entity, EntityEntry entityEntry, boolean isCascadeDeleteEnabled, EntityPersister persister, Set transientEntities)
protected  void DefaultDeleteEventListener.cascadeBeforeDelete(EventSource session, EntityPersister persister, Object entity, EntityEntry entityEntry, Set transientEntities)
protected  void DefaultDeleteEventListener.cascadeAfterDelete(EventSource session, EntityPersister persister, Object entity, Set transientEntities)
 void DefaultAutoFlushEventListener.onAutoFlush(AutoFlushEvent event)
Handle the given auto-flush event.
 void AbstractVisitor.processEntityPropertyValues(Object[] values, Type[] types)
Dispatch each property value to processValue().
protected  Serializable AbstractSaveEventListener.saveWithRequestedId(Object entity, Serializable requestedId, String entityName, Object anything, EventSource source)
Prepares the save call using the given requested id.
protected  Serializable AbstractSaveEventListener.saveWithGeneratedId(Object entity, String entityName, Object anything, EventSource source, boolean requiresImmediateIdAccess)
Prepares the save call using a newly generated id.
protected  Serializable AbstractSaveEventListener.performSave(Object entity, Serializable id, EntityPersister persister, boolean useIdentityColumn, Object anything, EventSource source, boolean requiresImmediateIdAccess)
Ppepares the save call by checking the session caches for a pre-existing entity and performing any lifecycle callbacks.
protected  Serializable AbstractSaveEventListener.performSaveOrReplicate(Object entity, EntityKey key, EntityPersister persister, boolean useIdentityColumn, Object anything, EventSource source, boolean requiresImmediateIdAccess)
Performs all the actual work needed to save an entity (well to get the save moved to the execution queue).
protected  void AbstractSaveEventListener.cascadeBeforeSave(EventSource source, EntityPersister persister, Object entity, Object anything)
Handles the calls needed to perform pre-save cascades for the given entity.
protected  void AbstractSaveEventListener.cascadeAfterSave(EventSource source, EntityPersister persister, Object entity, Object anything)
Handles to calls needed to perform post-save cascades.
protected  EntityEntry AbstractReassociateEventListener.reassociate(AbstractEvent event, Object object, Serializable id, EntityPersister persister)
Associates a given entity (either transient or associated with another session) to the given session.
protected  void AbstractLockUpgradeEventListener.upgradeLock(Object object, EntityEntry entry, LockMode requestedLockMode, SessionImplementor source)
Performs a pessimistic lock upgrade on a given entity, if needed.
protected  void AbstractFlushingEventListener.flushEverythingToExecutions(FlushEvent event)
Coordinates the processing necessary to get things ready for executions as db calls by preping the session caches and moving the appropriate entities and collections to their respective execution queues.
protected  void AbstractFlushingEventListener.performExecutions(EventSource session)
Execute all SQL and second-level cache updates, in a special order so that foreign-key constraints cannot be violated: Inserts, in the order they were performed Updates Deletion of collection elements Insertion of collection elements Deletes, in the order they were performed
protected  void AbstractFlushingEventListener.postFlush(SessionImplementor session)
1.

Uses of HibernateException in org.hibernate.exception

Subclasses of HibernateException in org.hibernate.exception
class | ConstraintViolationException Implementation of JDBCException indicating that the requested DML operation resulted in a violation of a defined integrity constraint.
class | DataException Implementation of JDBCException indicating that evaluation of the valid SQL statement against the given data resulted in some illegal operation, mismatched types or incorrect cardinality.
class | GenericJDBCException Generic, non-specific JDBCException.
class | JDBCConnectionException Implementation of JDBCException indicating problems with communicating with the database (can also include incorrect JDBC setup).
class | LockAcquisitionException Implementation of JDBCException indicating a problem acquiring lock on the database.
class | SQLGrammarException Implementation of JDBCException indicating that the SQL sent to the database server was invalid (syntax error, invalid object references, etc).

Methods in org.hibernate.exception that throw HibernateException
static SQLExceptionConverter | SQLExceptionConverterFactory.buildSQLExceptionConverter(Dialect dialect, Properties properties) Build a SQLExceptionConverter instance.
void | Configurable.configure(Properties properties) Configure the component, using the given settings and properties.

Uses of HibernateException in org.hibernate.hql

Subclasses of HibernateException in org.hibernate.hql
 class QueryExecutionRequestException
Expecting to execute an illegal operation regarding the query type

Methods in org.hibernate.hql that throw HibernateException
List | QueryTranslator.list(SessionImplementor session, QueryParameters queryParameters) Perform a list operation given the underlying query definition.
Iterator | QueryTranslator.iterate(QueryParameters queryParameters, EventSource session) Perform an iterate operation given the underlying query defintion.
ScrollableResults | QueryTranslator.scroll(QueryParameters queryParameters, SessionImplementor session) Perform a scroll operation given the underlying query defintion.
int | QueryTranslator.executeUpdate(QueryParameters queryParameters, SessionImplementor session) Perform a bulk update/delete operation given the underlying query defintion.
void | QueryTranslator.validateScrollability() Validate the scrollability of the translated query.

Uses of HibernateException in org.hibernate.hql.ast

Subclasses of HibernateException in org.hibernate.hql.ast
 class QuerySyntaxException
Exception thrown when there is a syntax error in the HQL.

Methods in org.hibernate.hql.ast that throw HibernateException
List | QueryTranslatorImpl.list(SessionImplementor session, QueryParameters queryParameters)
Iterator | QueryTranslatorImpl.iterate(QueryParameters queryParameters, EventSource session) Return the query results as an iterator
ScrollableResults | QueryTranslatorImpl.scroll(QueryParameters queryParameters, SessionImplementor session) Return the query results, as an instance of ScrollableResults
int | QueryTranslatorImpl.executeUpdate(QueryParameters queryParameters, SessionImplementor session)
void | QueryTranslatorImpl.validateScrollability()

Uses of HibernateException in org.hibernate.hql.ast.exec

Methods in org.hibernate.hql.ast.exec that throw HibernateException
int | StatementExecutor.execute(QueryParameters parameters, SessionImplementor session) Execute the sql managed by this executor using the given parameters.
int | MultiTableUpdateExecutor.execute(QueryParameters parameters, SessionImplementor session)
int | MultiTableDeleteExecutor.execute(QueryParameters parameters, SessionImplementor session)
int | BasicExecutor.execute(QueryParameters parameters, SessionImplementor session)

Uses of HibernateException in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that throw HibernateException
List | QueryTranslatorImpl.list(SessionImplementor session, QueryParameters queryParameters)
Iterator | QueryTranslatorImpl.iterate(QueryParameters queryParameters, EventSource session) Return the query results as an iterator
int | QueryTranslatorImpl.executeUpdate(QueryParameters queryParameters, SessionImplementor session)
protected Object | QueryTranslatorImpl.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
ScrollableResults | QueryTranslatorImpl.scroll(QueryParameters queryParameters, SessionImplementor session)
void | QueryTranslatorImpl.validateScrollability()

Uses of HibernateException in org.hibernate.id

Subclasses of HibernateException in org.hibernate.id
 class IdentifierGenerationException
Thrown by IdentifierGenerator implementation class when ID generation fails.

Methods in org.hibernate.id that throw HibernateException
Serializable | TableHiLoGenerator.generate(SessionImplementor session, Object obj)
Serializable | TableGenerator.generate(SessionImplementor session, Object object)
String[] | TableGenerator.sqlCreateStrings(Dialect dialect)
InsertGeneratedIdentifierDelegate | SequenceIdentityGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
Serializable | SequenceHiLoGenerator.generate(SessionImplementor session, Object obj)
Serializable | SequenceGenerator.generate(SessionImplementor session, Object obj)
String[] | SequenceGenerator.sqlCreateStrings(Dialect dialect)
String[] | SequenceGenerator.sqlDropStrings(Dialect dialect)
InsertGeneratedIdentifierDelegate | SelectGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
InsertGeneratedIdentifierDelegate | PostInsertIdentifierGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
String[] | PersistentIdentifierGenerator.sqlCreateStrings(Dialect dialect) The SQL required to create the underlying database objects.
String[] | PersistentIdentifierGenerator.sqlDropStrings(Dialect dialect) The SQL required to remove the underlying database objects.
String[] | MultipleHiLoPerTableGenerator.sqlCreateStrings(Dialect dialect)
String[] | MultipleHiLoPerTableGenerator.sqlDropStrings(Dialect dialect)
Serializable | MultipleHiLoPerTableGenerator.generate(SessionImplementor session, Object obj)
Serializable | IncrementGenerator.generate(SessionImplementor session, Object object)
InsertGeneratedIdentifierDelegate | IdentityGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
static Serializable | IdentifierGeneratorFactory.getGeneratedIdentity(ResultSet rs, Type type) Get the generated identifier when using identity columns
Serializable | IdentifierGenerator.generate(SessionImplementor session, Object object) Generate a new identifier.
Serializable | GUIDGenerator.generate(SessionImplementor session, Object obj)
Serializable | ForeignGenerator.generate(SessionImplementor sessionImplementor, Object object)
Serializable | Assigned.generate(SessionImplementor session, Object obj)

Uses of HibernateException in org.hibernate.impl

Methods in org.hibernate.impl that throw HibernateException
Object | StatelessSessionImpl.immediateLoad(String entityName, Serializable id)
void | StatelessSessionImpl.initializeCollection(PersistentCollection collection, boolean writing)
Object | StatelessSessionImpl.instantiate(String entityName, Serializable id)
Object | StatelessSessionImpl.internalLoad(String entityName, Serializable id, boolean eager, boolean nullable)
Iterator | StatelessSessionImpl.iterate(String query, QueryParameters queryParameters)
Iterator | StatelessSessionImpl.iterateFilter(Object collection, String filter, QueryParameters queryParameters)
List | StatelessSessionImpl.listFilter(Object collection, String filter, QueryParameters queryParameters)
int | StatelessSessionImpl.executeUpdate(String query, QueryParameters queryParameters)
EntityPersister | StatelessSessionImpl.getEntityPersister(String entityName, Object object)
Object | StatelessSessionImpl.getEntityUsingInterceptor(EntityKey key)
String | StatelessSessionImpl.guessEntityName(Object entity)
Transaction | StatelessSessionImpl.getTransaction()
Transaction | StatelessSessionImpl.beginTransaction()
List | StatelessSessionImpl.list(String query, QueryParameters queryParameters)
List | StatelessSessionImpl.list(CriteriaImpl criteria)
List | StatelessSessionImpl.listCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
ScrollableResults | StatelessSessionImpl.scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
ScrollableResults | StatelessSessionImpl.scroll(String query, QueryParameters queryParameters)
protected boolean | StatelessSessionImpl.autoFlushIfRequired(Set querySpaces)
int | StatelessSessionImpl.executeNativeUpdate(NativeSQLQuerySpecification nativeSQLQuerySpecification, QueryParameters queryParameters)
List | SQLQueryImpl.list()
ScrollableResults | SQLQueryImpl.scroll(ScrollMode scrollMode)
ScrollableResults | SQLQueryImpl.scroll()
Iterator | SQLQueryImpl.iterate()
String[] | SQLQueryImpl.getReturnAliases()
Type[] | SQLQueryImpl.getReturnTypes()
int | SQLQueryImpl.executeUpdate()
Connection | SessionImpl.close()
Connection | SessionImpl.connection()
Connection | SessionImpl.disconnect()
void | SessionImpl.reconnect()
void | SessionImpl.reconnect(Connection conn)
LockMode | SessionImpl.getCurrentLockMode(Object object)
Object | SessionImpl.getEntityUsingInterceptor(EntityKey key)
void | SessionImpl.saveOrUpdate(Object object)
void | SessionImpl.saveOrUpdate(String entityName, Object obj)
void | SessionImpl.save(Object obj, Serializable id)
Serializable | SessionImpl.save(Object obj)
Serializable | SessionImpl.save(String entityName, Object object)
void | SessionImpl.save(String entityName, Object object, Serializable id)
void | SessionImpl.update(Object obj)
void | SessionImpl.update(Object obj, Serializable id)
void | SessionImpl.update(String entityName, Object object)
void | SessionImpl.update(String entityName, Object object, Serializable id)
void | SessionImpl.lock(String entityName, Object object, LockMode lockMode)
void | SessionImpl.lock(Object object, LockMode lockMode)
void | SessionImpl.persist(String entityName, Object object)
void | SessionImpl.persist(Object object)
void | SessionImpl.persist(String entityName, Object object, Map copiedAlready)
void | SessionImpl.persistOnFlush(String entityName, Object object)
void | SessionImpl.persistOnFlush(Object object)
void | SessionImpl.persistOnFlush(String entityName, Object object, Map copiedAlready)
Object | SessionImpl.merge(String entityName, Object object)
Object | SessionImpl.merge(Object object)
void | SessionImpl.merge(String entityName, Object object, Map copiedAlready)
Object | SessionImpl.saveOrUpdateCopy(String entityName, Object object)
Object | SessionImpl.saveOrUpdateCopy(Object object)
Object | SessionImpl.saveOrUpdateCopy(String entityName, Object object, Serializable id)
Object | SessionImpl.saveOrUpdateCopy(Object object, Serializable id)
void | SessionImpl.saveOrUpdateCopy(String entityName, Object object, Map copiedAlready)
void | SessionImpl.delete(Object object) Delete a persistent object
void | SessionImpl.delete(String entityName, Object object) Delete a persistent object (by explicit entity name)
void | SessionImpl.delete(String entityName, Object object, boolean isCascadeDeleteEnabled, Set transientEntities) Delete a persistent object
void | SessionImpl.load(Object object, Serializable id)
Object | SessionImpl.load(Class entityClass, Serializable id)
Object | SessionImpl.load(String entityName, Serializable id)
Object | SessionImpl.get(Class entityClass, Serializable id)
Object | SessionImpl.get(String entityName, Serializable id)
Object | SessionImpl.immediateLoad(String entityName, Serializable id) Load the data for the object with the specified id into a newly created object.
Object | SessionImpl.internalLoad(String entityName, Serializable id, boolean eager, boolean nullable)
Object | SessionImpl.load(Class entityClass, Serializable id, LockMode lockMode)
Object | SessionImpl.load(String entityName, Serializable id, LockMode lockMode)
Object | SessionImpl.get(Class entityClass, Serializable id, LockMode lockMode)
Object | SessionImpl.get(String entityName, Serializable id, LockMode lockMode)
void | SessionImpl.refresh(Object object)
void | SessionImpl.refresh(Object object, LockMode lockMode)
void | SessionImpl.refresh(Object object, Map refreshedAlready)
void | SessionImpl.replicate(Object obj, ReplicationMode replicationMode)
void | SessionImpl.replicate(String entityName, Object obj, ReplicationMode replicationMode)
void | SessionImpl.evict(Object object) remove any hard references to the entity that are held by the infrastructure (references held by application or other persistant instances are okay)
protected boolean | SessionImpl.autoFlushIfRequired(Set querySpaces) detect in-memory changes, determine if the changes are to tables named in the query and, if so, complete execution the flush
boolean | SessionImpl.isDirty()
void | SessionImpl.flush()
void | SessionImpl.forceFlush(EntityEntry entityEntry)
List | SessionImpl.find(String query) Retrieve a list of persistent objects using a hibernate query
List | SessionImpl.find(String query, Object value, Type type)
List | SessionImpl.find(String query, Object[] values, Type[] types)
List | SessionImpl.list(String query, QueryParameters queryParameters)
int | SessionImpl.executeUpdate(String query, QueryParameters queryParameters)
int | SessionImpl.executeNativeUpdate(NativeSQLQuerySpecification nativeQuerySpecification, QueryParameters queryParameters)
Iterator | SessionImpl.iterate(String query)
Iterator | SessionImpl.iterate(String query, Object value, Type type)
Iterator | SessionImpl.iterate(String query, Object[] values, Type[] types)
Iterator | SessionImpl.iterate(String query, QueryParameters queryParameters)
ScrollableResults | SessionImpl.scroll(String query, QueryParameters queryParameters)
int | SessionImpl.delete(String query)
int | SessionImpl.delete(String query, Object value, Type type)
int | SessionImpl.delete(String query, Object[] values, Type[] types)
Object | SessionImpl.instantiate(String entityName, Serializable id)
Object | SessionImpl.instantiate(EntityPersister persister, Serializable id) give the interceptor an opportunity to override the default instantiation
Transaction | SessionImpl.getTransaction()
Transaction | SessionImpl.beginTransaction()
Serializable | SessionImpl.getIdentifier(Object object)
Collection | SessionImpl.filter(Object collection, String filter)
Collection | SessionImpl.filter(Object collection, String filter, Object value, Type type)
Collection | SessionImpl.filter(Object collection, String filter, Object[] values, Type[] types)
List | SessionImpl.listFilter(Object collection, String filter, QueryParameters queryParameters)
Iterator | SessionImpl.iterateFilter(Object collection, String filter, QueryParameters queryParameters)
List | SessionImpl.list(CriteriaImpl criteria)
ScrollableResults | SessionImpl.scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
List | SessionImpl.listCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
void | SessionImpl.initializeCollection(PersistentCollection collection, boolean writing)
String | SessionImpl.guessEntityName(Object object)
void | SessionImpl.cancelQuery()
Session | SessionFactoryImpl.openSession(Interceptor sessionLocalInterceptor)
Session | SessionFactoryImpl.openSession()
Session | SessionFactoryImpl.openTemporarySession()
Session | SessionFactoryImpl.openSession(Connection connection, boolean flushBeforeCompletionEnabled, boolean autoCloseSessionEnabled, ConnectionReleaseMode connectionReleaseMode)
Session | SessionFactoryImpl.getCurrentSession()
Type[] | SessionFactoryImpl.getReturnTypes(String queryString)
String[] | SessionFactoryImpl.getReturnAliases(String queryString)
ClassMetadata | SessionFactoryImpl.getClassMetadata(Class persistentClass)
CollectionMetadata | SessionFactoryImpl.getCollectionMetadata(String roleName)
ClassMetadata | SessionFactoryImpl.getClassMetadata(String entityName)
Map | SessionFactoryImpl.getAllClassMetadata()
Map | SessionFactoryImpl.getAllCollectionMetadata()
void | SessionFactoryImpl.close() Closes the session factory, releasing all held resources.
void | SessionFactoryImpl.evictEntity(String entityName, Serializable id)
void | SessionFactoryImpl.evictEntity(String entityName)
void | SessionFactoryImpl.evict(Class persistentClass, Serializable id)
void | SessionFactoryImpl.evict(Class persistentClass)
void | SessionFactoryImpl.evictCollection(String roleName, Serializable id)
void | SessionFactoryImpl.evictCollection(String roleName)
QueryCache | SessionFactoryImpl.getQueryCache(String cacheRegion)
void | SessionFactoryImpl.evictQueries()
void | SessionFactoryImpl.evictQueries(String cacheRegion)
FilterDefinition | SessionFactoryImpl.getFilterDefinition(String filterName)
boolean | ScrollableResultsImpl.scroll(int i)
boolean | ScrollableResultsImpl.first()
boolean | ScrollableResultsImpl.last()
boolean | ScrollableResultsImpl.next()
boolean | ScrollableResultsImpl.previous()
void | ScrollableResultsImpl.afterLast()
void | ScrollableResultsImpl.beforeFirst()
boolean | ScrollableResultsImpl.isFirst()
boolean | ScrollableResultsImpl.isLast()
int | ScrollableResultsImpl.getRowNumber()
boolean | ScrollableResultsImpl.setRowNumber(int rowNumber)
Iterator | QueryImpl.iterate()
ScrollableResults | QueryImpl.scroll()
ScrollableResults | QueryImpl.scroll(ScrollMode scrollMode)
List | QueryImpl.list()
int | QueryImpl.executeUpdate()
Filter | FilterImpl.setParameterList(String name, Collection values) Set the named parameter's value list for this filter.
void | FilterImpl.validate() Perform validation of the filter state.
boolean | FetchingScrollableResultsImpl.next() Advance to the next result
boolean | FetchingScrollableResultsImpl.previous() Retreat to the previous result
boolean | FetchingScrollableResultsImpl.scroll(int positions) Scroll an arbitrary number of locations
boolean | FetchingScrollableResultsImpl.last() Go to the last result
boolean | FetchingScrollableResultsImpl.first() Go to the first result
void | FetchingScrollableResultsImpl.beforeFirst() Go to a location just before first result (this is the initial location)
void | FetchingScrollableResultsImpl.afterLast() Go to a location just after the last result
boolean | FetchingScrollableResultsImpl.isFirst() Is this the first result?
boolean | FetchingScrollableResultsImpl.isLast() Is this the last result?
int | FetchingScrollableResultsImpl.getRowNumber() Get the current location in the result set.
boolean | FetchingScrollableResultsImpl.setRowNumber(int rowNumber) Set the current location in the result set, numbered from either the first row (row number 0), or the last row (row number -1).
List | CriteriaImpl.list()
Object | CriteriaImpl.uniqueResult()
Criteria | CriteriaImpl.Subcriteria.createAlias(String associationPath, String alias, int joinType)
Criteria | CriteriaImpl.Subcriteria.createCriteria(String associationPath, int joinType)
Criteria | CriteriaImpl.Subcriteria.createCriteria(String associationPath, String alias, int joinType)
List | CriteriaImpl.Subcriteria.list()
ScrollableResults | CriteriaImpl.Subcriteria.scroll()
ScrollableResults | CriteriaImpl.Subcriteria.scroll(ScrollMode scrollMode)
Object | CriteriaImpl.Subcriteria.uniqueResult()
Criteria | CriteriaImpl.Subcriteria.setFetchMode(String associationPath, FetchMode mode)
Iterator | CollectionFilterImpl.iterate()
List | CollectionFilterImpl.list()
ScrollableResults | CollectionFilterImpl.scroll()
protected HQLQueryPlan | AbstractSessionImpl.getHQLQueryPlan(String query, boolean shallow)
protected NativeSQLQueryPlan | AbstractSessionImpl.getNativeSQLQueryPlan(NativeSQLQuerySpecification spec)
List | AbstractSessionImpl.list(NativeSQLQuerySpecification spec, QueryParameters queryParameters)
ScrollableResults | AbstractSessionImpl.scroll(NativeSQLQuerySpecification spec, QueryParameters queryParameters)
void | AbstractScrollableResults.close()
Object[] | AbstractScrollableResults.get()
Object | AbstractScrollableResults.get(int col)
protected Object | AbstractScrollableResults.getFinal(int col, Type returnType) Check that the requested type is compatible with the result type, and return the column value.
protected Object | AbstractScrollableResults.getNonFinal(int col, Type returnType) Check that the requested type is compatible with the result type, and return the column value.
BigDecimal | AbstractScrollableResults.getBigDecimal(int col)
BigInteger | AbstractScrollableResults.getBigInteger(int col)
byte[] | AbstractScrollableResults.getBinary(int col)
String | AbstractScrollableResults.getText(int col)
Blob | AbstractScrollableResults.getBlob(int col)
Clob | AbstractScrollableResults.getClob(int col)
Boolean | AbstractScrollableResults.getBoolean(int col)
Byte | AbstractScrollableResults.getByte(int col)
Character | AbstractScrollableResults.getCharacter(int col)
Date | AbstractScrollableResults.getDate(int col)
Calendar | AbstractScrollableResults.getCalendar(int col)
Double | AbstractScrollableResults.getDouble(int col)
Float | AbstractScrollableResults.getFloat(int col)
Integer | AbstractScrollableResults.getInteger(int col)
Long | AbstractScrollableResults.getLong(int col)
Short | AbstractScrollableResults.getShort(int col)
String | AbstractScrollableResults.getString(int col)
Locale | AbstractScrollableResults.getLocale(int col)
TimeZone | AbstractScrollableResults.getTimeZone(int col)
Type[] | AbstractQueryImpl.getReturnTypes()
String[] | AbstractQueryImpl.getReturnAliases()
String[] | AbstractQueryImpl.getNamedParameters() Returns an array representing all named parameter names encountered during (intial) parsing of the query.
protected void | AbstractQueryImpl.verifyParameters(boolean reserveFirstParameter) Perform parameter validation.
Query | AbstractQueryImpl.setParameter(int position, Object val)
Query | AbstractQueryImpl.setParameter(String name, Object val)
protected Type | AbstractQueryImpl.determineType(int paramPosition, Object paramValue)
protected Type | AbstractQueryImpl.determineType(String paramName, Object paramValue)
protected Type | AbstractQueryImpl.determineType(String paramName, Class clazz)
Query | AbstractQueryImpl.setParameterList(String name, Collection vals, Type type)
Query | AbstractQueryImpl.setParameterList(String name, Collection vals)
Query | AbstractQueryImpl.setParameterList(String name, Object[] vals, Type type)
Query | AbstractQueryImpl.setParameterList(String name, Object[] vals)
Query | AbstractQueryImpl.setProperties(Object bean)
Object | AbstractQueryImpl.uniqueResult()

Constructors in org.hibernate.impl that throw HibernateException
SessionFactoryImpl(Configuration cfg, Mapping mapping, Settings settings, EventListeners listeners)
IteratorImpl(ResultSet rs, PreparedStatement ps, EventSource sess, Type[] types, String[][] columnNames, HolderInstantiator holderInstantiator)

Uses of HibernateException in org.hibernate.intercept

Methods in org.hibernate.intercept that throw HibernateException
 Object LazyPropertyInitializer.initializeLazyProperty(String fieldName, Object entity, SessionImplementor session)
Initialize the property, and return its new value

Uses of HibernateException in org.hibernate.jdbc

Subclasses of HibernateException in org.hibernate.jdbc
class | BatchedTooManyRowsAffectedException Much like TooManyRowsAffectedException, indicates that more rows than what we were expcecting were affected.
class | BatchFailedException Indicates a failed batch entry (-3 return).
class | TooManyRowsAffectedException Indicates that more rows were affected then we were expecting to be.

Methods in org.hibernate.jdbc that throw HibernateException
 void NonBatchingBatcher.addToBatch(Expectation expectation)
protected  void NonBatchingBatcher.doExecuteBatch(PreparedStatement ps)
 Connection JDBCContext.connection()
 Transaction JDBCContext.getTransaction()
 int Expectations.BasicExpectation.prepare(PreparedStatement statement)
 int Expectations.BasicParamExpectation.prepare(PreparedStatement statement)
 void Expectation.verifyOutcome(int rowCount, PreparedStatement statement, int batchPosition)
 int Expectation.prepare(PreparedStatement statement)
 Connection ConnectionManager.getConnection()
Retrieves the connection currently managed by this ConnectionManager.
 void BatchingBatcher.addToBatch(Expectation expectation)
protected  void BatchingBatcher.doExecuteBatch(PreparedStatement ps)
 PreparedStatement Batcher.prepareQueryStatement(String sql, boolean scrollable, ScrollMode scrollMode)
Get a prepared statement for use in loading / querying.
 CallableStatement Batcher.prepareCallableQueryStatement(String sql, boolean scrollable, ScrollMode scrollMode)
Get a prepared statement for use in loading / querying.
 PreparedStatement Batcher.prepareSelectStatement(String sql)
Get a non-batchable prepared statement to use for selecting.
 PreparedStatement Batcher.prepareStatement(String sql, boolean useGetGeneratedKeys)
Get a non-batchable prepared statement to use for inserting / deleting / updating, using JDBC3 getGeneratedKeys (Connection.prepareStatement(String, int)).
 PreparedStatement Batcher.prepareStatement(String sql, String[] columnNames)
Get a non-batchable prepared statement to use for inserting / deleting / updating.
 PreparedStatement Batcher.prepareStatement(String sql)
Get a non-batchable prepared statement to use for inserting / deleting / updating.
 CallableStatement Batcher.prepareCallableStatement(String sql)
Get a non-batchable callable statement to use for inserting / deleting / updating.
 PreparedStatement Batcher.prepareBatchStatement(String sql)
Get a batchable prepared statement to use for inserting / deleting / updating (might be called many times before a single call to executeBatch()).
 CallableStatement Batcher.prepareBatchCallableStatement(String sql)
Get a batchable callable statement to use for inserting / deleting / updating (might be called many times before a single call to executeBatch()).
 void Batcher.addToBatch(Expectation expectation)
Add an insert / delete / update to the current batch (might be called multiple times for single prepareBatchStatement())
 void Batcher.executeBatch()
Execute the batch
 void Batcher.cancelLastQuery()
Cancel the current query statement
 Connection Batcher.openConnection()
Obtain a JDBC connection
 void Batcher.closeConnection(Connection conn)
Dispose of the JDBC connection
 CallableStatement AbstractBatcher.prepareCallableStatement(String sql)
 PreparedStatement AbstractBatcher.prepareStatement(String sql)
 PreparedStatement AbstractBatcher.prepareStatement(String sql, boolean getGeneratedKeys)
 PreparedStatement AbstractBatcher.prepareStatement(String sql, String[] columnNames)
 PreparedStatement AbstractBatcher.prepareSelectStatement(String sql)
 PreparedStatement AbstractBatcher.prepareQueryStatement(String sql, boolean scrollable, ScrollMode scrollMode)
 CallableStatement AbstractBatcher.prepareCallableQueryStatement(String sql, boolean scrollable, ScrollMode scrollMode)
 PreparedStatement AbstractBatcher.prepareBatchStatement(String sql)
 CallableStatement AbstractBatcher.prepareBatchCallableStatement(String sql)
 void AbstractBatcher.executeBatch()
protected abstract  void AbstractBatcher.doExecuteBatch(PreparedStatement ps)
 Connection AbstractBatcher.openConnection()
 void AbstractBatcher.closeConnection(Connection conn)
 void AbstractBatcher.cancelLastQuery()

Uses of HibernateException in org.hibernate.jmx

Methods in org.hibernate.jmx that throw HibernateException
Session | SessionFactoryStub.openSession(Interceptor interceptor)
Session | SessionFactoryStub.openSession()
ClassMetadata | SessionFactoryStub.getClassMetadata(Class persistentClass)
ClassMetadata | SessionFactoryStub.getClassMetadata(String entityName)
CollectionMetadata | SessionFactoryStub.getCollectionMetadata(String roleName)
Map | SessionFactoryStub.getAllClassMetadata()
Map | SessionFactoryStub.getAllCollectionMetadata()
void | SessionFactoryStub.close()
void | SessionFactoryStub.evict(Class persistentClass, Serializable id)
void | SessionFactoryStub.evict(Class persistentClass)
void | SessionFactoryStub.evictEntity(String entityName, Serializable id)
void | SessionFactoryStub.evictEntity(String entityName)
void | SessionFactoryStub.evictCollection(String roleName, Serializable id)
void | SessionFactoryStub.evictCollection(String roleName)
void | SessionFactoryStub.evictQueries()
void | SessionFactoryStub.evictQueries(String cacheRegion)
FilterDefinition | SessionFactoryStub.getFilterDefinition(String filterName)
void | HibernateServiceMBean.createSchema() Export the CREATE DDL to the database
void | HibernateServiceMBean.dropSchema() Export the DROP DDL to the database
void | HibernateServiceMBean.start() Create the SessionFactory and bind to the jndi name on startup
void | HibernateService.start()

Uses of HibernateException in org.hibernate.loader

Methods in org.hibernate.loader that throw HibernateException
protected String | Loader.applyLocks(String sql, Map lockModes, Dialect dialect) Append FOR UPDATE OF clause, if necessary.
protected String | Loader.preprocessSQL(String sql, QueryParameters parameters, Dialect dialect) Modify the SQL, adding lock hints and comments, if necessary
Object | Loader.loadSingleRow(ResultSet resultSet, SessionImplementor session, QueryParameters queryParameters, boolean returnProxies) Loads a single row from the result set.
Object | Loader.loadSequentialRowsForward(ResultSet resultSet, SessionImplementor session, QueryParameters queryParameters, boolean returnProxies) Loads a single logical row from the result set moving forward.
Object | Loader.loadSequentialRowsReverse(ResultSet resultSet, SessionImplementor session, QueryParameters queryParameters, boolean returnProxies, boolean isLogicallyAfterLast) Loads a single logical row from the result set moving forward.
protected Object | Loader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session) Get the actual object that is returned in the user-visible result list.
protected int | Loader.bindPositionalParameters(PreparedStatement st, QueryParameters queryParameters, int start, SessionImplementor session) Bind positional parameter values to the PreparedStatement (these are parameters specified by a JDBC-style ?).
protected PreparedStatement | Loader.prepareQueryStatement(QueryParameters queryParameters, boolean scroll, SessionImplementor session) Obtain a PreparedStatement with all parameters pre-bound.
protected ResultSet | Loader.getResultSet(PreparedStatement st, boolean autodiscovertypes, boolean callable, RowSelection selection, SessionImplementor session) Fetch a PreparedStatement, call setMaxRows and then execute it, advance to the first result and return an SQL ResultSet
protected int | Loader.bindNamedParameters(PreparedStatement ps, Map namedParams, int start, SessionImplementor session) Bind named parameters to the PreparedStatement.
protected List | Loader.loadEntity(SessionImplementor session, Object id, Type identifierType, Object optionalObject, String optionalEntityName, Serializable optionalIdentifier, EntityPersister persister) Called by subclasses that load entities
protected List | Loader.loadEntity(SessionImplementor session, Object key, Object index, Type keyType, Type indexType, EntityPersister persister) Called by subclasses that load entities
List | Loader.loadEntityBatch(SessionImplementor session, Serializable[] ids, Type idType, Object optionalObject, String optionalEntityName, Serializable optionalId, EntityPersister persister) Called by wrappers that batch load entities
void | Loader.loadCollection(SessionImplementor session, Serializable id, Type type) Called by subclasses that initialize collections
void | Loader.loadCollectionBatch(SessionImplementor session, Serializable[] ids, Type type) Called by wrappers that batch initialize collections
protected void | Loader.loadCollectionSubselect(SessionImplementor session, Serializable[] ids, Object[] parameterValues, Type[] parameterTypes, Map namedParameters, Type type) Called by subclasses that batch initialize collections
protected List | Loader.list(SessionImplementor session, QueryParameters queryParameters, Set querySpaces, Type[] resultTypes) Return the query results, using the query cache, called by subclasses that implement cacheable queries
protected List | Loader.doList(SessionImplementor session, QueryParameters queryParameters) Actually execute a query, ignoring the query cache
protected void | Loader.checkScrollability() Check whether the current loader can support returning ScrollableResults.
protected ScrollableResults | Loader.scroll(QueryParameters queryParameters, Type[] returnTypes, HolderInstantiator holderInstantiator, SessionImplementor session) Return the query results, as an instance of ScrollableResults

Uses of HibernateException in org.hibernate.loader.collection

Methods in org.hibernate.loader.collection that throw HibernateException
void | SubselectOneToManyLoader.initialize(Serializable id, SessionImplementor session)
void | SubselectCollectionLoader.initialize(Serializable id, SessionImplementor session)
void | CollectionLoader.initialize(Serializable id, SessionImplementor session)
void | CollectionInitializer.initialize(Serializable id, SessionImplementor session) Initialize the given collection
void | BatchingCollectionInitializer.initialize(Serializable id, SessionImplementor session)

Uses of HibernateException in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria that throw HibernateException
String[] | CriteriaQueryTranslator.getColumnsUsingProjection(Criteria subcriteria, String propertyName) Get the names of the columns constrained by this criterion.
Type | CriteriaQueryTranslator.getTypeUsingProjection(Criteria subcriteria, String propertyName)
Type | CriteriaQueryTranslator.getType(Criteria subcriteria, String propertyName)
TypedValue | CriteriaQueryTranslator.getTypedValue(Criteria subcriteria, String propertyName, Object value) Get the a typed value for the given property value.
ScrollableResults | CriteriaLoader.scroll(SessionImplementor session, ScrollMode scrollMode)
List | CriteriaLoader.list(SessionImplementor session)
protected Object | CriteriaLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)

Constructors in org.hibernate.loader.criteria that throw HibernateException
CriteriaQueryTranslator(SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, String rootSQLAlias, CriteriaQuery outerQuery)
CriteriaQueryTranslator(SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, String rootSQLAlias)
CriteriaLoader(OuterJoinLoadable persister, SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, Map enabledFilters)
CriteriaJoinWalker(OuterJoinLoadable persister, CriteriaQueryTranslator translator, SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, Map enabledFilters)

Uses of HibernateException in org.hibernate.loader.custom

Methods in org.hibernate.loader.custom that throw HibernateException
List | CustomLoader.list(SessionImplementor session, QueryParameters queryParameters)
ScrollableResults | CustomLoader.scroll(QueryParameters queryParameters, SessionImplementor session)
protected Object | CustomLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
Object | CustomLoader.ResultRowProcessor.buildResultRow(Object[] data, ResultSet resultSet, boolean hasTransformer, SessionImplementor session) Build a logical result row.
Object | CustomLoader.NonScalarResultColumnProcessor.extract(Object[] data, ResultSet resultSet, SessionImplementor session)
Object | CustomLoader.ScalarResultColumnProcessor.extract(Object[] data, ResultSet resultSet, SessionImplementor session)

Uses of HibernateException in org.hibernate.loader.custom.sql

Constructors in org.hibernate.loader.custom.sql that throw HibernateException
SQLCustomQuery(String sqlQuery, NativeSQLQueryReturn[] queryReturns, Collection additionalQuerySpaces, SessionFactoryImplementor factory)

Uses of HibernateException in org.hibernate.loader.entity

Methods in org.hibernate.loader.entity that throw HibernateException
Object | UniqueEntityLoader.load(Serializable id, Object optionalObject, SessionImplementor session) Load an entity instance.
Object | EntityLoader.loadByUniqueKey(SessionImplementor session, Object key)
Object | CollectionElementLoader.loadElement(SessionImplementor session, Object key, Object index)
protected Object | CollectionElementLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
Object | BatchingEntityLoader.load(Serializable id, Object optionalObject, SessionImplementor session)
Object | AbstractEntityLoader.load(Serializable id, Object optionalObject, SessionImplementor session)
protected Object | AbstractEntityLoader.load(SessionImplementor session, Object id, Object optionalObject, Serializable optionalId)
protected Object | AbstractEntityLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)

Uses of HibernateException in org.hibernate.loader.hql

Methods in org.hibernate.loader.hql that throw HibernateException
void | QueryLoader.validateScrollability()
protected Object | QueryLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
List | QueryLoader.list(SessionImplementor session, QueryParameters queryParameters) Delegats
Iterator | QueryLoader.iterate(QueryParameters queryParameters, EventSource session) Return the query results as an iterator
ScrollableResults | QueryLoader.scroll(QueryParameters queryParameters, SessionImplementor session)
protected int | QueryLoader.bindNamedParameters(PreparedStatement ps, Map namedParams, int start, SessionImplementor session)

Uses of HibernateException in org.hibernate.mapping

Methods in org.hibernate.mapping that throw HibernateException
Iterator | Table.sqlAlterStrings(Dialect dialect, Mapping p, TableMetadata tableInfo, String defaultCatalog, String defaultSchema)
String | Table.sqlTemporaryTableCreateString(Dialect dialect, Mapping mapping)
String | Table.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
String | SimpleAuxiliaryDatabaseObject.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
String | RelationalModel.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
String | Index.sqlCreateString(Dialect dialect, Mapping mapping, String defaultCatalog, String defaultSchema)
String | Column.getSqlType(Dialect dialect, Mapping mapping)

Uses of HibernateException in org.hibernate.metadata

Methods in org.hibernate.metadata that throw HibernateException
Type | ClassMetadata.getPropertyType(String propertyName) Get the type of a particular (named) property
Object[] | ClassMetadata.getPropertyValuesToInsert(Object entity, Map mergeMap, SessionImplementor session) Return the values of the mapped properties of the object
Object | ClassMetadata.instantiate(Serializable id, EntityMode entityMode) Create a class instance initialized with the given identifier
Object | ClassMetadata.getPropertyValue(Object object, String propertyName, EntityMode entityMode) Get the value of a particular (named) property
Object[] | ClassMetadata.getPropertyValues(Object entity, EntityMode entityMode) Extract the property values from the given entity.
void | ClassMetadata.setPropertyValue(Object object, String propertyName, Object value, EntityMode entityMode) Set the value of a particular (named) property
void | ClassMetadata.setPropertyValues(Object object, Object[] values, EntityMode entityMode) Set the given values to the mapped properties of the given object
Serializable | ClassMetadata.getIdentifier(Object entity, EntityMode entityMode) Get the identifier of an instance (throw an exception if no identifier property)
void | ClassMetadata.setIdentifier(Object object, Serializable id, EntityMode entityMode) Set the identifier of an instance (or do nothing if no identifier property)
Object | ClassMetadata.getVersion(Object object, EntityMode entityMode) Get the version number (or timestamp) from the object's version property (or return null if not versioned)

Uses of HibernateException in org.hibernate.persister

Methods in org.hibernate.persister that throw HibernateException
static EntityPersister | PersisterFactory.createClassPersister(PersistentClass model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping cfg)
static CollectionPersister | PersisterFactory.createCollectionPersister(Configuration cfg, Collection model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory)

Uses of HibernateException in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that throw HibernateException
protected int | OneToManyPersister.doUpdateRows(Serializable id, PersistentCollection collection, SessionImplementor session)
void | NamedQueryCollectionInitializer.initialize(Serializable key, SessionImplementor session)
void | CollectionPersister.initialize(Serializable key, SessionImplementor session) Initialize the given collection with the given key
Object | CollectionPersister.readKey(ResultSet rs, String[] keyAliases, SessionImplementor session) Read the key from a row of the JDBC ResultSet
Object | CollectionPersister.readElement(ResultSet rs, Object owner, String[] columnAliases, SessionImplementor session) Read the element from a row of the JDBC ResultSet
Object | CollectionPersister.readIndex(ResultSet rs, String[] columnAliases, SessionImplementor session) Read the index from a row of the JDBC ResultSet
Object | CollectionPersister.readIdentifier(ResultSet rs, String columnAlias, SessionImplementor session) Read the identifier from a row of the JDBC ResultSet
void | CollectionPersister.remove(Serializable id, SessionImplementor session) Completely remove the persistent state of the collection
void | CollectionPersister.recreate(PersistentCollection collection, Serializable key, SessionImplementor session) (Re)create the collection's persistent state
void | CollectionPersister.deleteRows(PersistentCollection collection, Serializable key, SessionImplementor session) Delete the persistent state of any elements that were removed from the collection
void | CollectionPersister.updateRows(PersistentCollection collection, Serializable key, SessionImplementor session) Update the persistent state of any elements that were modified
void | CollectionPersister.insertRows(PersistentCollection collection, Serializable key, SessionImplementor session) Insert the persistent state of any new collection elements
protected int | BasicCollectionPersister.doUpdateRows(Serializable id, PersistentCollection collection, SessionImplementor session)
void | AbstractCollectionPersister.initialize(Serializable key, SessionImplementor session)
Object | AbstractCollectionPersister.readElement(ResultSet rs, Object owner, String[] aliases, SessionImplementor session)
Object | AbstractCollectionPersister.readIndex(ResultSet rs, String[] aliases, SessionImplementor session)
Object | AbstractCollectionPersister.readIdentifier(ResultSet rs, String alias, SessionImplementor session)
Object | AbstractCollectionPersister.readKey(ResultSet rs, String[] aliases, SessionImplementor session)
protected int | AbstractCollectionPersister.writeKey(PreparedStatement st, Serializable key, int i, SessionImplementor session) Write the key to a JDBC PreparedStatement
protected int | AbstractCollectionPersister.writeElement(PreparedStatement st, Object elt, int i, SessionImplementor session) Write the element to a JDBC PreparedStatement
protected int | AbstractCollectionPersister.writeIndex(PreparedStatement st, Object index, int i, SessionImplementor session) Write the index to a JDBC PreparedStatement
protected int | AbstractCollectionPersister.writeElementToWhere(PreparedStatement st, Object elt, int i, SessionImplementor session) Write the element to a JDBC PreparedStatement
protected int | AbstractCollectionPersister.writeIndexToWhere(PreparedStatement st, Object index, int i, SessionImplementor session) Write the index to a JDBC PreparedStatement
int | AbstractCollectionPersister.writeIdentifier(PreparedStatement st, Object id, int i, SessionImplementor session) Write the identifier to a JDBC PreparedStatement
void | AbstractCollectionPersister.remove(Serializable id, SessionImplementor session)
void | AbstractCollectionPersister.recreate(PersistentCollection collection, Serializable id, SessionImplementor session)
void | AbstractCollectionPersister.deleteRows(PersistentCollection collection, Serializable id, SessionImplementor session)
void | AbstractCollectionPersister.insertRows(PersistentCollection collection, Serializable id, SessionImplementor session)
void | AbstractCollectionPersister.updateRows(PersistentCollection collection, Serializable id, SessionImplementor session)
protected abstract int | AbstractCollectionPersister.doUpdateRows(Serializable key, PersistentCollection collection, SessionImplementor session)

Uses of HibernateException in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that throw HibernateException
Object | UniqueKeyLoadable.loadByUniqueKey(String propertyName, Object uniqueKey, SessionImplementor session) Load an instance of the persistent class, by a unique key other than the primary key.
Object | NamedQueryLoader.load(Serializable id, Object optionalObject, SessionImplementor session)
Object[] | Loadable.hydrate(ResultSet rs, Serializable id, Object object, Loadable rootLoadable, String[][] suffixedPropertyColumns, boolean allProperties, SessionImplementor session) Retrieve property values from one row of a result set
int[] | EntityPersister.findDirty(Object[] x, Object[] y, Object owner, SessionImplementor session) Compare two snapshots of the state of an instance to determine if the persistent state was modified
int[] | EntityPersister.findModified(Object[] old, Object[] current, Object object, SessionImplementor session) Compare the state of an instance to the current database state
Object[] | EntityPersister.getNaturalIdentifierSnapshot(Serializable id, SessionImplementor session) Retrieve the current state of the natural-id properties from the database.
IdentifierGenerator | EntityPersister.getIdentifierGenerator() Return the IdentifierGenerator for the class
Object | EntityPersister.load(Serializable id, Object optionalObject, LockMode lockMode, SessionImplementor session) Load an instance of the persistent class.
void | EntityPersister.lock(Serializable id, Object version, Object object, LockMode lockMode, SessionImplementor session) Do a version check (optional operation)
void | EntityPersister.insert(Serializable id, Object[] fields, Object object, SessionImplementor session) Persist an instance
Serializable | EntityPersister.insert(Object[] fields, Object object, SessionImplementor session) Persist an instance, using a natively generated identifier (optional operation)
void | EntityPersister.delete(Serializable id, Object version, Object object, SessionImplementor session) Delete a persistent instance
void | EntityPersister.update(Serializable id, Object[] fields, int[] dirtyFields, boolean hasDirtyCollection, Object[] oldFields, Object oldVersion, Object object, Object rowId, SessionImplementor session) Update a persistent instance
Object[] | EntityPersister.getDatabaseSnapshot(Serializable id, SessionImplementor session) Get the current database state of the object, in a "hydrated" form, without resolving identifiers
Object | EntityPersister.getCurrentVersion(Serializable id, SessionImplementor session) Get the current version of the object, or return null if there is no row for the given identifier.
Object | EntityPersister.forceVersionIncrement(Serializable id, Object currentVersion, SessionImplementor session)
Object | EntityPersister.createProxy(Serializable id, SessionImplementor session) Create a new proxy instance
Boolean | EntityPersister.isTransient(Object object, SessionImplementor session) Is this a new transient instance?
Object[] | EntityPersister.getPropertyValuesToInsert(Object object, Map mergeMap, SessionImplementor session) Return the values of the insertable properties of the object (including backrefs)
void | EntityPersister.setPropertyValues(Object object, Object[] values, EntityMode entityMode) Set the given values to the mapped properties of the given object
void | EntityPersister.setPropertyValue(Object object, int i, Object value, EntityMode entityMode) Set the value of a particular property
Object[] | EntityPersister.getPropertyValues(Object object, EntityMode entityMode) Return the (loaded) values of the mapped properties of the object (not including backrefs)
Object | EntityPersister.getPropertyValue(Object object, int i, EntityMode entityMode) Get the value of a particular property
Object | EntityPersister.getPropertyValue(Object object, String propertyName, EntityMode entityMode) Get the value of a particular property
Serializable | EntityPersister.getIdentifier(Object object, EntityMode entityMode) Get the identifier of an instance (throw an exception if no identifier property)
void | EntityPersister.setIdentifier(Object object, Serializable id, EntityMode entityMode) Set the identifier of an instance (or do nothing if no identifier property)
Object | EntityPersister.getVersion(Object object, EntityMode entityMode) Get the version number (or timestamp) from the object's version property (or return null if not versioned)
Object | EntityPersister.instantiate(Serializable id, EntityMode entityMode) Create a class instance initialized with the given identifier
Object | AbstractEntityPersister.initializeLazyProperty(String fieldName, Object entity, SessionImplementor session)
Object[] | AbstractEntityPersister.getDatabaseSnapshot(Serializable id, SessionImplementor session)
Object | AbstractEntityPersister.getCurrentVersion(Serializable id, SessionImplementor session) Retrieve the version number
void | AbstractEntityPersister.lock(Serializable id, Object version, Object object, LockMode lockMode, SessionImplementor session)
Object | AbstractEntityPersister.loadByUniqueKey(String propertyName, Object uniqueKey, SessionImplementor session)
protected boolean | AbstractEntityPersister.check(int rows, Serializable id, int tableNumber, Expectation expectation, PreparedStatement statement)
protected int | AbstractEntityPersister.dehydrate(Serializable id, Object[] fields, boolean[] includeProperty, boolean[][] includeColumns, int j, PreparedStatement st, SessionImplementor session)
protected int | AbstractEntityPersister.dehydrate(Serializable id, Object[] fields, Object rowId, boolean[] includeProperty, boolean[][] includeColumns, int j, PreparedStatement ps, SessionImplementor session, int index) Marshall the fields of a persistent instance to a prepared statement
Object[] | AbstractEntityPersister.hydrate(ResultSet rs, Serializable id, Object object, Loadable rootLoadable, String[][] suffixedPropertyColumns, boolean allProperties, SessionImplementor session) Unmarshall the fields of a persistent instance from a result set, without resolving associations or collections.
protected Serializable | AbstractEntityPersister.insert(Object[] fields, boolean[] notNull, String sql, Object object, SessionImplementor session) Perform an SQL INSERT, and then retrieve a generated identifier.
protected void | AbstractEntityPersister.insert(Serializable id, Object[] fields, boolean[] notNull, int j, String sql, Object object, SessionImplementor session) Perform an SQL INSERT.
protected void | AbstractEntityPersister.updateOrInsert(Serializable id, Object[] fields, Object[] oldFields, Object rowId, boolean[] includeProperty, int j, Object oldVersion, Object object, String sql, SessionImplementor session) Perform an SQL UPDATE or SQL INSERT
protected boolean | AbstractEntityPersister.update(Serializable id, Object[] fields, Object[] oldFields, Object rowId, boolean[] includeProperty, int j, Object oldVersion, Object object, String sql, SessionImplementor session)
protected void | AbstractEntityPersister.delete(Serializable id, Object version, int j, Object object, String sql, SessionImplementor session, Object[] loadedState) Perform an SQL DELETE
void | AbstractEntityPersister.update(Serializable id, Object[] fields, int[] dirtyFields, boolean hasDirtyCollection, Object[] oldFields, Object oldVersion, Object object, Object rowId, SessionImplementor session) Update an object
Serializable | AbstractEntityPersister.insert(Object[] fields, Object object, SessionImplementor session)
void | AbstractEntityPersister.insert(Serializable id, Object[] fields, Object object, SessionImplementor session)
void | AbstractEntityPersister.delete(Serializable id, Object version, Object object, SessionImplementor session) Delete an object
Object | AbstractEntityPersister.load(Serializable id, Object optionalObject, LockMode lockMode, SessionImplementor session) Load an instance using either the forUpdateLoader or the outer joining loader, depending upon the value of the lock parameter
int[] | AbstractEntityPersister.findDirty(Object[] currentState, Object[] previousState, Object entity, SessionImplementor session) Locate the property-indices of all properties considered to be dirty.
int[] | AbstractEntityPersister.findModified(Object[] old, Object[] current, Object entity, SessionImplementor session) Locate the property-indices of all properties considered to be dirty.
Boolean | AbstractEntityPersister.isTransient(Object entity, SessionImplementor session)
IdentifierGenerator | AbstractEntityPersister.getIdentifierGenerator()
Object | AbstractEntityPersister.createProxy(Serializable id, SessionImplementor session)
void | AbstractEntityPersister.setPropertyValues(Object object, Object[] values, EntityMode entityMode)
void | AbstractEntityPersister.setPropertyValue(Object object, int i, Object value, EntityMode entityMode)
Object[] | AbstractEntityPersister.getPropertyValues(Object object, EntityMode entityMode)
Object | AbstractEntityPersister.getPropertyValue(Object object, int i, EntityMode entityMode)
Object | AbstractEntityPersister.getPropertyValue(Object object, String propertyName, EntityMode entityMode)
Serializable | AbstractEntityPersister.getIdentifier(Object object, EntityMode entityMode)
void | AbstractEntityPersister.setIdentifier(Object object, Serializable id, EntityMode entityMode)
Object | AbstractEntityPersister.getVersion(Object object, EntityMode entityMode)
Object | AbstractEntityPersister.instantiate(Serializable id, EntityMode entityMode)
Object[] | AbstractEntityPersister.getPropertyValuesToInsert(Object object, Map mergeMap, SessionImplementor session)
Object[] | AbstractEntityPersister.getNaturalIdentifierSnapshot(Serializable id, SessionImplementor session)
void | AbstractEntityPersister.setPropertyValue(Object object, String propertyName, Object value, EntityMode entityMode)

Constructors in org.hibernate.persister.entity that throw HibernateException
UnionSubclassEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
SingleTableEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
JoinedSubclassEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
AbstractEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory)

Uses of HibernateException in org.hibernate.pretty

Methods in org.hibernate.pretty that throw HibernateException
String | Printer.toString(Object entity, EntityMode entityMode)
String | Printer.toString(Type[] types, Object[] values)
String | Printer.toString(Map namedTypedValues)
void | Printer.toString(Iterator iter, EntityMode entityMode)

Uses of HibernateException in org.hibernate.property

Methods in org.hibernate.property that throw HibernateException
void | Setter.set(Object target, Object value, SessionFactoryImplementor factory) Set the property value from the given instance
void | MapAccessor.MapSetter.set(Object target, Object value, SessionFactoryImplementor factory)
Object | MapAccessor.MapGetter.get(Object target)
void | IndexPropertyAccessor.IndexSetter.set(Object target, Object value, SessionFactoryImplementor factory)
Object | IndexPropertyAccessor.IndexGetter.getForInsert(Object target, Map mergeMap, SessionImplementor session)
Object | Getter.get(Object owner) Get the property value from the given instance .
Object | Getter.getForInsert(Object owner, Map mergeMap, SessionImplementor session) Get the property value from the given owner instance.
Object | EmbeddedPropertyAccessor.EmbeddedGetter.get(Object target)
void | EmbeddedPropertyAccessor.EmbeddedSetter.set(Object target, Object value, SessionFactoryImplementor factory)
Object | Dom4jAccessor.Dom4jGetter.getForInsert(Object owner, Map mergeMap, SessionImplementor session)
Object | Dom4jAccessor.TextGetter.get(Object owner)
Object | Dom4jAccessor.AttributeGetter.get(Object owner)
Object | Dom4jAccessor.ElementGetter.get(Object owner)
Object | Dom4jAccessor.ElementAttributeGetter.get(Object owner)
void | Dom4jAccessor.TextSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | Dom4jAccessor.AttributeSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | Dom4jAccessor.ElementSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | Dom4jAccessor.ElementAttributeSetter.set(Object target, Object value, SessionFactoryImplementor factory)
Object | DirectPropertyAccessor.DirectGetter.get(Object target)
void | DirectPropertyAccessor.DirectSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | BasicPropertyAccessor.BasicSetter.set(Object target, Object value, SessionFactoryImplementor factory)
Object | BasicPropertyAccessor.BasicGetter.get(Object target)
Object | BackrefPropertyAccessor.BackrefGetter.getForInsert(Object target, Map mergeMap, SessionImplementor session)

Uses of HibernateException in org.hibernate.proxy

Methods in org.hibernate.proxy that throw HibernateException
void | ProxyFactory.postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType) Called immediately after instantiation of this factory.
HibernateProxy | ProxyFactory.getProxy(Serializable id, SessionImplementor session) Create a new proxy instance
void | LazyInitializer.initialize() Initialize the proxy, fetching the target entity if necessary
void | LazyInitializer.setSession(SessionImplementor s) Attach the proxy to a session
Object | LazyInitializer.getImplementation(SessionImplementor s) Return the underlying persistent object in the given Session, or null
void | AbstractLazyInitializer.initialize()
void | AbstractLazyInitializer.setSession(SessionImplementor s)
Object | AbstractLazyInitializer.getImplementation(SessionImplementor s) Return the underlying persistent object in the given Session, or null, do not initialize the proxy

Uses of HibernateException in org.hibernate.proxy.dom4j

Methods in org.hibernate.proxy.dom4j that throw HibernateException
void | Dom4jProxyFactory.postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType) Called immediately after instantiation
HibernateProxy | Dom4jProxyFactory.getProxy(Serializable id, SessionImplementor session) Create a new proxy

Uses of HibernateException in org.hibernate.proxy.map

Methods in org.hibernate.proxy.map that throw HibernateException
void | MapProxyFactory.postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType)
HibernateProxy | MapProxyFactory.getProxy(Serializable id, SessionImplementor session)

Uses of HibernateException in org.hibernate.proxy.pojo.cglib

Methods in org.hibernate.proxy.pojo.cglib that throw HibernateException
void | CGLIBProxyFactory.postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType)
HibernateProxy | CGLIBProxyFactory.getProxy(Serializable id, SessionImplementor session)
static HibernateProxy | CGLIBLazyInitializer.getProxy(Class factory, String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)
static Class | CGLIBLazyInitializer.getProxyFactory(Class persistentClass, Class[] interfaces)

Uses of HibernateException in org.hibernate.proxy.pojo.javassist

Methods in org.hibernate.proxy.pojo.javassist that throw HibernateException
void | JavassistProxyFactory.postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType)
HibernateProxy | JavassistProxyFactory.getProxy(Serializable id, SessionImplementor session)
static HibernateProxy | JavassistLazyInitializer.getProxy(String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)
static HibernateProxy | JavassistLazyInitializer.getProxy(Class factory, String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)
static Class | JavassistLazyInitializer.getProxyFactory(Class persistentClass, Class[] interfaces)

Uses of HibernateException in org.hibernate.secure

Constructors in org.hibernate.secure that throw HibernateException
JACCConfiguration(String contextId)

Uses of HibernateException in org.hibernate.tool.hbm2ddl

Methods in org.hibernate.tool.hbm2ddl that throw HibernateException
TableMetadata | DatabaseMetadata.getTableMetadata(String name, String schema, String catalog)
boolean | DatabaseMetadata.isTable(Object key)

Constructors in org.hibernate.tool.hbm2ddl that throw HibernateException
SchemaValidator(Configuration cfg)
SchemaValidator(Configuration cfg, Properties connectionProperties)
SchemaValidator(Configuration cfg, Settings settings)
SchemaUpdate(Configuration cfg)
SchemaUpdate(Configuration cfg, Properties connectionProperties)
SchemaUpdate(Configuration cfg, Settings settings)
SchemaExport(Configuration cfg)
Create a schema exporter for the given Configuration
SchemaExport(Configuration cfg, Settings settings)
Create a schema exporter for the given Configuration and given settings
SchemaExport(Configuration cfg, Properties properties)
Deprecated. properties may be specified via the Configuration object

Uses of HibernateException in org.hibernate.transaction

Methods in org.hibernate.transaction that throw HibernateException
TransactionManager | WebSphereTransactionManagerLookup.getTransactionManager(Properties props)
TransactionManager | WebSphereExtendedJTATransactionLookup.getTransactionManager(Properties props)
static TransactionManager | TransactionManagerLookupFactory.getTransactionManager(Properties props)
static TransactionManagerLookup | TransactionManagerLookupFactory.getTransactionManagerLookup(Properties props)
TransactionManager | TransactionManagerLookup.getTransactionManager(Properties props) Obtain the JTA TransactionManager
static TransactionFactory | TransactionFactoryFactory.buildTransactionFactory(Properties transactionProps) Obtain a TransactionFactory with the transaction handling strategy specified by the given Properties.
Transaction | TransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context context) Begin a transaction and return the associated Transaction instance.
void | TransactionFactory.configure(Properties props) Configure from the given properties.
void | JTATransactionFactory.configure(Properties props)
Transaction | JTATransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
void | JTATransaction.begin()
void | JTATransaction.commit()
void | JTATransaction.rollback()
void | JTATransaction.registerSynchronization(Synchronization sync)
TransactionManager | JOTMTransactionManagerLookup.getTransactionManager(Properties props)
TransactionManager | JOnASTransactionManagerLookup.getTransactionManager(Properties props)
TransactionManager | JNDITransactionManagerLookup.getTransactionManager(Properties props)
Transaction | JDBCTransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
void | JDBCTransactionFactory.configure(Properties props)
void | JDBCTransaction.begin()
void | JDBCTransaction.commit()
void | JDBCTransaction.rollback()
void | JDBCTransaction.registerSynchronization(Synchronization sync)
void | CMTTransactionFactory.configure(Properties props)
Transaction | CMTTransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
void | CMTTransaction.begin()
void | CMTTransaction.commit()
void | CMTTransaction.rollback()
void | CMTTransaction.registerSynchronization(Synchronization sync)

Uses of HibernateException in org.hibernate.tuple

Methods in org.hibernate.tuple that throw HibernateException
Object[] | Tuplizer.getPropertyValues(Object entity) Extract the current values contained on the given entity.
void | Tuplizer.setPropertyValues(Object entity, Object[] values) Inject the given values into the given entity.
Object | Tuplizer.getPropertyValue(Object entity, int i) Extract the value of a particular property from the given entity.
Object | Tuplizer.instantiate() Generate a new, empty entity.

Uses of HibernateException in org.hibernate.tuple.component

Methods in org.hibernate.tuple.component that throw HibernateException
Object[] | PojoComponentTuplizer.getPropertyValues(Object component)
void | PojoComponentTuplizer.setPropertyValues(Object component, Object[] values)
Object | AbstractComponentTuplizer.getPropertyValue(Object component, int i)
Object[] | AbstractComponentTuplizer.getPropertyValues(Object component)
void | AbstractComponentTuplizer.setPropertyValues(Object component, Object[] values)
Object | AbstractComponentTuplizer.instantiate() This method does not populate the component parent

Uses of HibernateException in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity that throw HibernateException
void | PojoEntityTuplizer.setPropertyValues(Object entity, Object[] values)
Object[] | PojoEntityTuplizer.getPropertyValues(Object entity)
Object[] | PojoEntityTuplizer.getPropertyValuesToInsert(Object entity, Map mergeMap, SessionImplementor session)
Object | EntityTuplizer.instantiate(Serializable id) Create an entity instance initialized with the given identifier.
Serializable | EntityTuplizer.getIdentifier(Object entity) Extract the identifier value from the given entity.
void | EntityTuplizer.setIdentifier(Object entity, Serializable id) Inject the identifier value into the given entity.
Object | EntityTuplizer.getVersion(Object entity) Extract the value of the version property from the given entity.
void | EntityTuplizer.setPropertyValue(Object entity, int i, Object value) Inject the value of a particular property.
void | EntityTuplizer.setPropertyValue(Object entity, String propertyName, Object value) Inject the value of a particular property.
Object[] | EntityTuplizer.getPropertyValuesToInsert(Object entity, Map mergeMap, SessionImplementor session) Extract the values of the insertable properties of the entity (including backrefs)
Object | EntityTuplizer.getPropertyValue(Object entity, String propertyName) Extract the value of a particular property from the given entity.
Object | EntityTuplizer.createProxy(Serializable id, SessionImplementor session) Generates an appropriate proxy representation of this entity for this entity-mode.
Serializable | Dom4jEntityTuplizer.getIdentifier(Object entityOrId)
Serializable | AbstractEntityTuplizer.getIdentifier(Object entity)
void | AbstractEntityTuplizer.setIdentifier(Object entity, Serializable id)
Object | AbstractEntityTuplizer.getVersion(Object entity)
Object[] | AbstractEntityTuplizer.getPropertyValues(Object entity)
Object[] | AbstractEntityTuplizer.getPropertyValuesToInsert(Object entity, Map mergeMap, SessionImplementor session)
Object | AbstractEntityTuplizer.getPropertyValue(Object entity, int i)
Object | AbstractEntityTuplizer.getPropertyValue(Object entity, String propertyPath)
void | AbstractEntityTuplizer.setPropertyValues(Object entity, Object[] values)
void | AbstractEntityTuplizer.setPropertyValue(Object entity, int i, Object value)
void | AbstractEntityTuplizer.setPropertyValue(Object entity, String propertyName, Object value)
Object | AbstractEntityTuplizer.instantiate(Serializable id)
Object | AbstractEntityTuplizer.instantiate()
Object | AbstractEntityTuplizer.createProxy(Serializable id, SessionImplementor session)

Uses of HibernateException in org.hibernate.type

Subclasses of HibernateException in org.hibernate.type
 class SerializationException
Thrown when a property cannot be serializaed/deserialized

Methods in org.hibernate.type that throw HibernateException
static void | TypeFactory.deepCopy(Object[] values, Type[] types, boolean[] copy, Object[] target, SessionImplementor session) Deep copy values in the first array into the second
static void | TypeFactory.beforeAssemble(Serializable[] row, Type[] types, SessionImplementor session) Determine if any of the given field values are modified, returning an array containing indexes of the dirty fields or null if no fields are dirty.
static Object[] | TypeFactory.assemble(Serializable[] row, Type[] types, SessionImplementor session, Object owner)
static Serializable[] | TypeFactory.disassemble(Object[] row, Type[] types, boolean[] nonCacheable, SessionImplementor session, Object owner)
static Object[] | TypeFactory.replace(Object[] original, Object[] target, Type[] types, SessionImplementor session, Object owner, Map copyCache)
static Object[] | TypeFactory.replace(Object[] original, Object[] target, Type[] types, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)
static int[] | TypeFactory.findDirty(StandardProperty[] properties, Object[] x, Object[] y, boolean[][] includeColumns, boolean anyUninitializedProperties, SessionImplementor session) Determine if any of the given field values are dirty, returning an array containing indexes of the dirty fields or null if no fields are dirty.
static int[] | TypeFactory.findModified(StandardProperty[] properties, Object[] x, Object[] y, boolean[][] includeColumns, boolean anyUninitializedProperties, SessionImplementor session) Determine if any of the given field values are modified, returning an array containing indexes of the dirty fields or null if no fields are dirty.
boolean | Type.isSame(Object x, Object y, EntityMode entityMode) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state - taking a shortcut for entity references.
boolean | Type.isEqual(Object x, Object y, EntityMode entityMode) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
boolean | Type.isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
int | Type.getHashCode(Object x, EntityMode entityMode) Get a hashcode, consistent with persistence "equality"
int | Type.getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory) Get a hashcode, consistent with persistence "equality"
boolean | Type.isDirty(Object old, Object current, SessionImplementor session) Should the parent be considered dirty, given both the old and current field or element value?
boolean | Type.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session) Should the parent be considered dirty, given both the old and current field or element value?
boolean | Type.isModified(Object oldHydratedState, Object currentState, boolean[] checkable, SessionImplementor session) Has the parent object been modified, compared to the current database state?
Object | Type.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
Object | Type.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
void | Type.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session) Write an instance of the mapped class to a prepared statement, ignoring some columns.
void | Type.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session) Write an instance of the mapped class to a prepared statement.
void | Type.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory) A representation of the value to be embedded in an XML element.
String | Type.toLoggableString(Object value, SessionFactoryImplementor factory) A representation of the value to be embedded in a log file.
Object | Type.fromXMLNode(org.dom4j.Node xml, Mapping factory) Parse the XML representation of an instance.
Object | Type.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory) Return a deep copy of the persistent state, stopping at entities and at collections.
Serializable | Type.disassemble(Object value, SessionImplementor session, Object owner) Return a cacheable "disassembled" representation of the object.
Object | Type.assemble(Serializable cached, SessionImplementor session, Object owner) Reconstruct the object from its cached "disassembled" state.
Object | Type.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner) Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset.
Object | Type.resolve(Object value, SessionImplementor session, Object owner) Map identifiers to entities or collections.
Object | Type.semiResolve(Object value, SessionImplementor session, Object owner) Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.
Object | Type.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
Object | Type.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
Object | TimeZoneType.get(ResultSet rs, String name)
void | TimeZoneType.set(PreparedStatement st, Object value, int index)
String | TimeZoneType.toString(Object value)
Object | TimeZoneType.fromStringValue(String xml)
Object | TimeType.fromStringValue(String xml)
Object | TimestampType.fromStringValue(String xml)
void | TextType.set(PreparedStatement st, Object value, int index)
Object | TextType.get(ResultSet rs, String name)
Object | SpecialOneToOneType.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Serializable | SpecialOneToOneType.disassemble(Object value, SessionImplementor session, Object owner)
Object | SpecialOneToOneType.assemble(Serializable oid, SessionImplementor session, Object owner)
void | SerializableType.set(PreparedStatement st, Object value, int index)
Object | SerializableType.get(ResultSet rs, String name)
boolean | SerializableType.isEqual(Object x, Object y)
String | SerializableType.toString(Object value)
Object | SerializableType.fromStringValue(String xml)
Object | SerializableType.deepCopyNotNull(Object value)
Object | SerializableType.assemble(Serializable cached, SessionImplementor session, Object owner)
Serializable | SerializableType.disassemble(Object value, SessionImplementor session, Object owner)
Object | OneToOneType.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Serializable | OneToOneType.disassemble(Object value, SessionImplementor session, Object owner)
Object | OneToOneType.assemble(Serializable oid, SessionImplementor session, Object owner)
abstract Object | NullableType.get(ResultSet rs, String name) Get a column value from a result set, without worrying about the possibility of null values
abstract void | NullableType.set(PreparedStatement st, Object value, int index) Get a parameter value without worrying about the possibility of null values
abstract String | NullableType.toString(Object value)
abstract Object | NullableType.fromStringValue(String xml)
void | NullableType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | NullableType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
void | NullableType.nullSafeSet(PreparedStatement st, Object value, int index)
Object | NullableType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | NullableType.nullSafeGet(ResultSet rs, String[] names)
Object | NullableType.nullSafeGet(ResultSet rs, String name)
Object | NullableType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
String | NullableType.toXMLString(Object value, SessionFactoryImplementor pc)
Object | NullableType.fromXMLString(String xml, Mapping factory)
Object | NullableType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
void | NullableType.setToXMLNode(org.dom4j.Node xml, Object value, SessionFactoryImplementor factory)
boolean | NullableType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
protected abstract Object | MutableType.deepCopyNotNull(Object value)
Object | MutableType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Object | MutableType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
Object | MetaType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | MetaType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
void | MetaType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
void | MetaType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
String | MetaType.toLoggableString(Object value, SessionFactoryImplementor factory)
String | MetaType.toXMLString(Object value, SessionFactoryImplementor factory)
Object | MetaType.fromXMLString(String xml, Mapping factory)
Object | MetaType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Object | MetaType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
void | MetaType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
boolean | MetaType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | MapType.replaceElements(Object original, Object target, Object owner, Map copyCache, SessionImplementor session)
void | ManyToOneType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | ManyToOneType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Object | ManyToOneType.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
boolean | ManyToOneType.isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
Serializable | ManyToOneType.disassemble(Object value, SessionImplementor session, Object owner)
Object | ManyToOneType.assemble(Serializable oid, SessionImplementor session, Object owner)
boolean | ManyToOneType.isDirty(Object old, Object current, SessionImplementor session)
boolean | ManyToOneType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | LocaleType.get(ResultSet rs, String name)
void | LocaleType.set(PreparedStatement st, Object value, int index)
String | LocaleType.toString(Object value)
Object | ImmutableType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
PersistentCollection | IdentifierBagType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
Object | EntityType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
protected Object | EntityType.getIdentifier(Object value, SessionImplementor session)
String | EntityType.toLoggableString(Object value, SessionFactoryImplementor factory)
Object | EntityType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
Object | EntityType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
protected Object | EntityType.resolveIdentifier(Serializable id, SessionImplementor session) Resolve an identifier
Object | EntityType.resolve(Object value, SessionImplementor session, Object owner) Resolve an identifier or unique key value
Object | EntityType.loadByUniqueKey(String entityName, String uniqueKeyPropertyName, Object key, SessionImplementor session) Load an instance by a unique key that is not the primary key.
Object | EntityType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
void | EntityType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
Object | EmbeddedComponentType.instantiate(Object parent, SessionImplementor session)
Object | DateType.fromStringValue(String xml)
boolean | CustomType.isEqual(Object x, Object y)
boolean | CustomType.isEqual(Object x, Object y, EntityMode entityMode)
Object | CustomType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | CustomType.nullSafeGet(ResultSet rs, String columnName, SessionImplementor session, Object owner)
Object | CustomType.assemble(Serializable cached, SessionImplementor session, Object owner)
Serializable | CustomType.disassemble(Object value, SessionImplementor session, Object owner)
Object | CustomType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
void | CustomType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | CustomType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Object | CustomType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Object | CustomType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
void | CustomType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
String | CustomType.toLoggableString(Object value, SessionFactoryImplementor factory)
boolean | CustomType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
PersistentCollection | CustomCollectionType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
Object | CustomCollectionType.replaceElements(Object original, Object target, Object owner, Map copyCache, SessionImplementor session)
protected String | CustomCollectionType.renderLoggableString(Object value, SessionFactoryImplementor factory)
Object | CurrencyType.get(ResultSet rs, String name)
void | CurrencyType.set(PreparedStatement st, Object value, int index)
String | CurrencyType.toString(Object value)
Object | CurrencyType.fromStringValue(String xml)
Object[] | CompositeCustomType.getPropertyValues(Object component, SessionImplementor session)
Object[] | CompositeCustomType.getPropertyValues(Object component, EntityMode entityMode)
void | CompositeCustomType.setPropertyValues(Object component, Object[] values, EntityMode entityMode)
Object | CompositeCustomType.getPropertyValue(Object component, int i, SessionImplementor session)
Object | CompositeCustomType.getPropertyValue(Object component, int i)
Object | CompositeCustomType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Object | CompositeCustomType.assemble(Serializable cached, SessionImplementor session, Object owner)
Serializable | CompositeCustomType.disassemble(Object value, SessionImplementor session, Object owner)
Object | CompositeCustomType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
boolean | CompositeCustomType.isEqual(Object x, Object y, EntityMode entityMode)
Object | CompositeCustomType.nullSafeGet(ResultSet rs, String columnName, SessionImplementor session, Object owner)
Object | CompositeCustomType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
void | CompositeCustomType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
void | CompositeCustomType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
String | CompositeCustomType.toLoggableString(Object value, SessionFactoryImplementor factory)
Object | CompositeCustomType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
void | CompositeCustomType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
boolean | CompositeCustomType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
boolean | ComponentType.isSame(Object x, Object y, EntityMode entityMode)
boolean | ComponentType.isEqual(Object x, Object y, EntityMode entityMode)
boolean | ComponentType.isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory)
boolean | ComponentType.isDirty(Object x, Object y, SessionImplementor session)
boolean | ComponentType.isDirty(Object x, Object y, boolean[] checkable, SessionImplementor session)
boolean | ComponentType.isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | ComponentType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
void | ComponentType.nullSafeSet(PreparedStatement st, Object value, int begin, SessionImplementor session)
void | ComponentType.nullSafeSet(PreparedStatement st, Object value, int begin, boolean[] settable, SessionImplementor session)
Object | ComponentType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Object | ComponentType.getPropertyValue(Object component, int i, SessionImplementor session)
Object | ComponentType.getPropertyValue(Object component, int i, EntityMode entityMode)
Object[] | ComponentType.getPropertyValues(Object component, SessionImplementor session)
Object[] | ComponentType.getPropertyValues(Object component, EntityMode entityMode)
void | ComponentType.setPropertyValues(Object component, Object[] values, EntityMode entityMode)
String | ComponentType.toLoggableString(Object value, SessionFactoryImplementor factory)
Object | ComponentType.deepCopy(Object component, EntityMode entityMode, SessionFactoryImplementor factory)
Object | ComponentType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
Object | ComponentType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)
Object | ComponentType.instantiate(EntityMode entityMode) This method does not populate the component parent
Object | ComponentType.instantiate(Object parent, SessionImplementor session)
Serializable | ComponentType.disassemble(Object value, SessionImplementor session, Object owner)
Object | ComponentType.assemble(Serializable object, SessionImplementor session, Object owner)
Object | ComponentType.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | ComponentType.resolve(Object value, SessionImplementor session, Object owner)
Object | ComponentType.semiResolve(Object value, SessionImplementor session, Object owner)
Object | ComponentType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
void | ComponentType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
abstract PersistentCollection | CollectionType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key) Instantiate an uninitialized collection wrapper or holder.
Object | CollectionType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Object | CollectionType.nullSafeGet(ResultSet rs, String[] name, SessionImplementor session, Object owner)
void | CollectionType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | CollectionType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
String | CollectionType.toLoggableString(Object value, SessionFactoryImplementor factory)
protected String | CollectionType.renderLoggableString(Object value, SessionFactoryImplementor factory)
Object | CollectionType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Serializable | CollectionType.disassemble(Object value, SessionImplementor session, Object owner)
Object | CollectionType.assemble(Serializable cached, SessionImplementor session, Object owner)
boolean | CollectionType.isDirty(Object old, Object current, SessionImplementor session)
boolean | CollectionType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | CollectionType.resolve(Object value, SessionImplementor session, Object owner)
Object | CollectionType.semiResolve(Object value, SessionImplementor session, Object owner)
boolean | CollectionType.isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | CollectionType.replaceElements(Object original, Object target, Object owner, Map copyCache, SessionImplementor session) Replace the elements of a collection with the elements of another collection
Object | CollectionType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
Object | CollectionType.getCollection(Serializable key, SessionImplementor session, Object owner) instantiate a collection wrapper (called when loading an object)
Object | CollectionType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
void | CollectionType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
void | ClobType.set(PreparedStatement st, Object value, int index, SessionImplementor session)
Object | ClobType.get(ResultSet rs, String name)
Serializable | ClobType.disassemble(Object value, SessionImplementor session, Object owner)
Object | ClobType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Object | ClobType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
void | ClobType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | ClobType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Object | ClobType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
String | ClobType.toLoggableString(Object value, SessionFactoryImplementor factory)
boolean | ClobType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | ClassType.get(ResultSet rs, String name)
void | ClassType.set(PreparedStatement st, Object value, int index)
String | ClassType.toString(Object value)
Object | ClassType.fromStringValue(String xml)
Object | CalendarType.get(ResultSet rs, String name)
void | CalendarType.set(PreparedStatement st, Object value, int index)
String | CalendarType.toString(Object value)
Object | CalendarType.fromStringValue(String xml)
Object | CalendarType.deepCopyNotNull(Object value)
Object | CalendarDateType.get(ResultSet rs, String name)
void | CalendarDateType.set(PreparedStatement st, Object value, int index)
String | CalendarDateType.toString(Object value)
Object | CalendarDateType.fromStringValue(String xml)
void | BlobType.set(PreparedStatement st, Object value, int index, SessionImplementor session)
Object | BlobType.get(ResultSet rs, String name)
Serializable | BlobType.disassemble(Object value, SessionImplementor session, Object owner)
Object | BlobType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Object | BlobType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
void | BlobType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | BlobType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Object | BlobType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
String | BlobType.toLoggableString(Object value, SessionFactoryImplementor factory)
boolean | BlobType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | BigIntegerType.get(ResultSet rs, String name)
void | BigIntegerType.set(PreparedStatement st, Object value, int index)
String | BigIntegerType.toString(Object value)
Object | BigDecimalType.get(ResultSet rs, String name)
void | BigDecimalType.set(PreparedStatement st, Object value, int index)
String | BigDecimalType.toString(Object value)
PersistentCollection | BagType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | ArrayType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
String | ArrayType.toLoggableString(Object value, SessionFactoryImplementor factory)
Object | ArrayType.replaceElements(Object original, Object target, Object owner, Map copyCache, SessionImplementor session)
Object | AnyType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
boolean | AnyType.isSame(Object x, Object y, EntityMode entityMode)
Object | AnyType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Object | AnyType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | AnyType.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | AnyType.resolve(Object value, SessionImplementor session, Object owner)
Object | AnyType.semiResolve(Object value, SessionImplementor session, Object owner)
void | AnyType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
void | AnyType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
String | AnyType.toLoggableString(Object value, SessionFactoryImplementor factory)
Object | AnyType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
Object | AnyType.assemble(Serializable cached, SessionImplementor session, Object owner)
Serializable | AnyType.disassemble(Object value, SessionImplementor session, Object owner)
Object | AnyType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
Object | AnyType.getPropertyValue(Object component, int i, SessionImplementor session)
Object[] | AnyType.getPropertyValues(Object component, SessionImplementor session)
void | AnyType.setPropertyValues(Object component, Object[] values, EntityMode entityMode)
boolean | AnyType.isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
boolean | AnyType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | AdaptedImmutableType.get(ResultSet rs, String name)
void | AdaptedImmutableType.set(PreparedStatement st, Object value, int index)
String | AdaptedImmutableType.toString(Object value)
Object | AdaptedImmutableType.fromStringValue(String xml)
Serializable | AbstractType.disassemble(Object value, SessionImplementor session, Object owner)
Object | AbstractType.assemble(Serializable cached, SessionImplementor session, Object owner)
boolean | AbstractType.isDirty(Object old, Object current, SessionImplementor session)
Object | AbstractType.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | AbstractType.resolve(Object value, SessionImplementor session, Object owner)
Object | AbstractType.semiResolve(Object value, SessionImplementor session, Object owner)
boolean | AbstractType.isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
boolean | AbstractType.isSame(Object x, Object y, EntityMode entityMode)
Object | AbstractType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)
Object[] | AbstractComponentType.getPropertyValues(Object component, SessionImplementor session) Get the values of the component properties of a component instance
Object[] | AbstractComponentType.getPropertyValues(Object component, EntityMode entityMode) Optional operation
void | AbstractComponentType.setPropertyValues(Object component, Object[] values, EntityMode entityMode) Optional operation
Object | AbstractComponentType.getPropertyValue(Object component, int i, SessionImplementor session)
protected Object | AbstractCharArrayType.deepCopyNotNull(Object value)
void | AbstractBynaryType.set(PreparedStatement st, Object value, int index)
Object | AbstractBynaryType.get(ResultSet rs, String name)
Object | AbstractBynaryType.fromStringValue(String xml)

Uses of HibernateException in org.hibernate.usertype

Methods in org.hibernate.usertype that throw HibernateException
boolean | UserType.equals(Object x, Object y) Compare two instances of the class mapped by this type for persistence "equality".
int | UserType.hashCode(Object x) Get a hashcode for the instance, consistent with persistence "equality"
Object | UserType.nullSafeGet(ResultSet rs, String[] names, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
void | UserType.nullSafeSet(PreparedStatement st, Object value, int index) Write an instance of the mapped class to a prepared statement.
Object | UserType.deepCopy(Object value) Return a deep copy of the persistent state, stopping at entities and at collections.
Serializable | UserType.disassemble(Object value) Transform the object into its cacheable representation.
Object | UserType.assemble(Serializable cached, Object owner) Reconstruct an object from the cacheable representation.
Object | UserType.replace(Object original, Object target, Object owner) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
PersistentCollection | UserCollectionType.instantiate(SessionImplementor session, CollectionPersister persister) Instantiate an uninitialized instance of the collection wrapper
Object | UserCollectionType.replaceElements(Object original, Object target, CollectionPersister persister, Object owner, Map copyCache, SessionImplementor session) Replace the elements of a collection with the elements of another collection
Object | CompositeUserType.getPropertyValue(Object component, int property) Get the value of a property.
void | CompositeUserType.setPropertyValue(Object component, int property, Object value) Set the value of a property.
boolean | CompositeUserType.equals(Object x, Object y) Compare two instances of the class mapped by this type for persistence "equality".
int | CompositeUserType.hashCode(Object x) Get a hashcode for the instance, consistent with persistence "equality"
Object | CompositeUserType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
void | CompositeUserType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session) Write an instance of the mapped class to a prepared statement.
Object | CompositeUserType.deepCopy(Object value) Return a deep copy of the persistent state, stopping at entities and at collections.
Serializable | CompositeUserType.disassemble(Object value, SessionImplementor session) Transform the object into its cacheable representation.
Object | CompositeUserType.assemble(Serializable cached, SessionImplementor session, Object owner) Reconstruct an object from the cacheable representation.
Object | CompositeUserType.replace(Object original, Object target, SessionImplementor session, Object owner) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.

Uses of HibernateException in org.hibernate.util

Methods in org.hibernate.util that throw HibernateException
static InputStream | ConfigHelper.getConfigStream(String path) Open an InputStream to the URL represented by the incoming path.
static Reader | ConfigHelper.getConfigStreamReader(String path) Open an Reader to the URL represented by the incoming path.
static Properties | ConfigHelper.getConfigProperties(String path) Loads a properties instance based on the data at the incoming config location.
void | Cloneable.validate() Checks to ensure the SessionEventListenerConfig is fully configured (basically, that none of the listeners is null).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.InstantiationException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.InstantiationException

No usage of org.hibernate.InstantiationException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.Interceptor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.Interceptor

Packages that use Interceptor
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.

Uses of Interceptor in org.hibernate

Classes in org.hibernate that implement Interceptor
 class EmptyInterceptor
An interceptor that does nothing.

Fields in org.hibernate declared as Interceptor
static Interceptor EmptyInterceptor.INSTANCE

Methods in org.hibernate with parameters of type Interceptor
Session | SessionFactory.openSession(Interceptor interceptor) Create database connection and open a Session on it, specifying an interceptor.
Session | SessionFactory.openSession(Connection connection, Interceptor interceptor) Open a Session on the given connection, specifying an interceptor.

Uses of Interceptor in org.hibernate.cache.entry

Methods in org.hibernate.cache.entry with parameters of type Interceptor
 Object[] CacheEntry.assemble(Object instance, Serializable id, EntityPersister persister, Interceptor interceptor, EventSource session)

Uses of Interceptor in org.hibernate.cfg

Methods in org.hibernate.cfg that return Interceptor
 Interceptor Configuration.getInterceptor()
Return the configured Interceptor

Methods in org.hibernate.cfg with parameters of type Interceptor
 Configuration Configuration.setInterceptor(Interceptor interceptor)
Configure an Interceptor

Uses of Interceptor in org.hibernate.engine

Methods in org.hibernate.engine that return Interceptor
Interceptor | SessionImplementor.getInterceptor() Retrieves the interceptor currently in use by this event source.
Interceptor | SessionFactoryImplementor.getInterceptor()

Uses of Interceptor in org.hibernate.impl

Methods in org.hibernate.impl that return Interceptor
Interceptor | StatelessSessionImpl.getInterceptor()
Interceptor | SessionImpl.getInterceptor()
Interceptor | SessionFactoryImpl.getInterceptor()

Methods in org.hibernate.impl with parameters of type Interceptor
Session | SessionFactoryImpl.openSession(Connection connection, Interceptor sessionLocalInterceptor)
Session | SessionFactoryImpl.openSession(Interceptor sessionLocalInterceptor)

Uses of Interceptor in org.hibernate.jdbc

Methods in org.hibernate.jdbc with parameters of type Interceptor
Batcher | NonBatchingBatcherFactory.createBatcher(ConnectionManager connectionManager, Interceptor interceptor)
static JDBCContext | JDBCContext.deserialize(ObjectInputStream ois, JDBCContext.Context context, Interceptor interceptor) Custom deserialization routine used during deserialization of a Session/PersistenceContext for increased performance.
static ConnectionManager | ConnectionManager.deserialize(ObjectInputStream ois, SessionFactoryImplementor factory, Interceptor interceptor, ConnectionReleaseMode connectionReleaseMode, JDBCContext jdbcContext)
Batcher | BatchingBatcherFactory.createBatcher(ConnectionManager connectionManager, Interceptor interceptor)
Batcher | BatcherFactory.createBatcher(ConnectionManager connectionManager, Interceptor interceptor)

Constructors in org.hibernate.jdbc with parameters of type Interceptor
NonBatchingBatcher(ConnectionManager connectionManager, Interceptor interceptor)
JDBCContext(JDBCContext.Context owner, Connection connection, Interceptor interceptor)
ConnectionManager(SessionFactoryImplementor factory, ConnectionManager.Callback callback, ConnectionReleaseMode releaseMode, Connection connection, Interceptor interceptor)
Constructs a ConnectionManager.
BatchingBatcher(ConnectionManager connectionManager, Interceptor interceptor)
AbstractBatcher(ConnectionManager connectionManager, Interceptor interceptor)

Uses of Interceptor in org.hibernate.jmx

Methods in org.hibernate.jmx with parameters of type Interceptor
Session | SessionFactoryStub.openSession(Connection connection, Interceptor interceptor)
Session | SessionFactoryStub.openSession(Interceptor interceptor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.InvalidMappingException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.InvalidMappingException

No usage of org.hibernate.InvalidMappingException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.JDBCException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.JDBCException

Packages that use JDBCException
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.lock |
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.exception | This package is a fork of Apache commons-lang nestable exceptions.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of JDBCException in org.hibernate.dialect

Methods in org.hibernate.dialect that throw JDBCException
 void HSQLDialect.ReadUncommittedLockingStrategy.lock(Serializable id, Object version, Object object, SessionImplementor session)

Uses of JDBCException in org.hibernate.dialect.lock

Methods in org.hibernate.dialect.lock that throw JDBCException
void | UpdateLockingStrategy.lock(Serializable id, Object version, Object object, SessionImplementor session)
void | SelectLockingStrategy.lock(Serializable id, Object version, Object object, SessionImplementor session)
void | LockingStrategy.lock(Serializable id, Object version, Object object, SessionImplementor session) Acquire an appropriate type of lock on the underlying data that will endure until the end of the current transaction.

Uses of JDBCException in org.hibernate.engine

Methods in org.hibernate.engine that throw JDBCException
 void HibernateIterator.close()

Uses of JDBCException in org.hibernate.exception

Subclasses of JDBCException in org.hibernate.exception
class | ConstraintViolationException Implementation of JDBCException indicating that the requested DML operation resulted in a violation of a defined integrity constraint.
class | DataException Implementation of JDBCException indicating that evaluation of the valid SQL statement against the given data resulted in some illegal operation, mismatched types or incorrect cardinality.
class | GenericJDBCException Generic, non-specific JDBCException.
class | JDBCConnectionException Implementation of JDBCException indicating problems with communicating with the database (can also include incorrect JDBC setup).
class | LockAcquisitionException Implementation of JDBCException indicating a problem acquiring lock on the database.
class | SQLGrammarException Implementation of JDBCException indicating that the SQL sent to the database server was invalid (syntax error, invalid object references, etc).

Methods in org.hibernate.exception that return JDBCException
JDBCException | SQLStateConverter.convert(SQLException sqlException, String message, String sql) Convert the given SQLException into Hibernate's JDBCException hierarchy.
protected JDBCException | SQLStateConverter.handledNonSpecificException(SQLException sqlException, String message, String sql) Handle an exception not converted to a specific type based on the SQLState.
JDBCException | SQLExceptionConverter.convert(SQLException sqlException, String message, String sql) Convert the given SQLException into Hibernate's JDBCException hierarchy.
static JDBCException | JDBCExceptionHelper.convert(SQLExceptionConverter converter, SQLException sqlException, String message) Converts the given SQLException into Hibernate's JDBCException hierarchy, as well as performing appropriate logging.
static JDBCException | JDBCExceptionHelper.convert(SQLExceptionConverter converter, SQLException sqlException, String message, String sql) Converts the given SQLException into Hibernate's JDBCException hierarchy, as well as performing appropriate logging.

Uses of JDBCException in org.hibernate.impl

Methods in org.hibernate.impl that throw JDBCException
 void IteratorImpl.close()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.LazyInitializationException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.LazyInitializationException

No usage of org.hibernate.LazyInitializationException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.LockMode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.LockMode

Packages that use LockMode
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.lock |
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query.sql |
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.
org.hibernate.util | Utility classes.

Uses of LockMode in org.hibernate

Fields in org.hibernate declared as LockMode
static LockMode | LockMode.NONE No lock required.
static LockMode | LockMode.READ A shared lock.
static LockMode | LockMode.UPGRADE An upgrade lock.
static LockMode | LockMode.UPGRADE_NOWAIT Attempt to obtain an upgrade lock, using an Oracle-style select for update nowait.
static LockMode | LockMode.WRITE A WRITE lock is obtained when an object is updated or inserted.
static LockMode | LockMode.FORCE Similiar to UPGRADE except that, for versioned entities, it results in a forced version increment.

Methods in org.hibernate that return LockMode
LockMode | Session.getCurrentLockMode(Object object) Determine the current lock mode of the given object.
static LockMode | LockMode.parse(String name)

Methods in org.hibernate with parameters of type LockMode
Object | StatelessSession.get(String entityName, Serializable id, LockMode lockMode) Retrieve a row, obtaining the specified lock mode.
Object | StatelessSession.get(Class entityClass, Serializable id, LockMode lockMode) Retrieve a row, obtaining the specified lock mode.
void | StatelessSession.refresh(Object entity, LockMode lockMode) Refresh the entity instance state from the database.
void | StatelessSession.refresh(String entityName, Object entity, LockMode lockMode) Refresh the entity instance state from the database.
SQLQuery | SQLQuery.addEntity(String alias, String entityName, LockMode lockMode) Declare a "root" entity, specifying a lock mode
SQLQuery | SQLQuery.addEntity(String alias, Class entityClass, LockMode lockMode) Declare a "root" entity, specifying a lock mode
SQLQuery | SQLQuery.addJoin(String alias, String path, LockMode lockMode) Declare a "joined" entity, specifying a lock mode
Object | Session.load(Class theClass, Serializable id, LockMode lockMode) Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.
Object | Session.load(String entityName, Serializable id, LockMode lockMode) Return the persistent instance of the given entity class with the given identifier, obtaining the specified lock mode, assuming the instance exists.
void | Session.lock(Object object, LockMode lockMode) Obtain the specified lock level upon the given object.
void | Session.lock(String entityName, Object object, LockMode lockMode) Obtain the specified lock level upon the given object.
void | Session.refresh(Object object, LockMode lockMode) Re-read the state of the given instance from the underlying database, with the given LockMode.
Object | Session.get(Class clazz, Serializable id, LockMode lockMode) Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
Object | Session.get(String entityName, Serializable id, LockMode lockMode) Return the persistent instance of the given entity class with the given identifier, or null if there is no such persistent instance.
Query | Query.setLockMode(String alias, LockMode lockMode) Set the lockmode for the objects idententified by the given alias that appears in the FROM clause.
boolean | LockMode.greaterThan(LockMode mode) Check if this lock mode is more restrictive than the given lock mode.
boolean | LockMode.lessThan(LockMode mode) Check if this lock mode is less restrictive than the given lock mode.
Criteria | Criteria.setLockMode(LockMode lockMode) Set the lock mode of the current entity
Criteria | Criteria.setLockMode(String alias, LockMode lockMode) Set the lock mode of the aliased entity

Uses of LockMode in org.hibernate.dialect

Methods in org.hibernate.dialect with parameters of type LockMode
LockingStrategy | TimesTenDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
String | SybaseDialect.appendLockHint(LockMode mode, String tableName)
String | SQLServerDialect.appendLockHint(LockMode mode, String tableName)
LockingStrategy | RDMSOS2200Dialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | PointbaseDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | MckoiDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | HSQLDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | FrontBaseDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
String | Dialect.appendLockHint(LockMode mode, String tableName) Method appendLockHint appends according to the given lock mode a lock hint behind the given table name, if this dialect needs this.
String | Dialect.getForUpdateString(LockMode lockMode)
LockingStrategy | Dialect.getLockingStrategy(Lockable lockable, LockMode lockMode) Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.

Constructors in org.hibernate.dialect with parameters of type LockMode
HSQLDialect.ReadUncommittedLockingStrategy(Lockable lockable, LockMode lockMode)

Uses of LockMode in org.hibernate.dialect.lock

Methods in org.hibernate.dialect.lock that return LockMode
protected LockMode | UpdateLockingStrategy.getLockMode()
protected LockMode | SelectLockingStrategy.getLockMode()

Constructors in org.hibernate.dialect.lock with parameters of type LockMode
UpdateLockingStrategy(Lockable lockable, LockMode lockMode)
Construct a locking strategy based on SQL UPDATE statements.
SelectLockingStrategy(Lockable lockable, LockMode lockMode)
Construct a locking strategy based on SQL SELECT statements.

Uses of LockMode in org.hibernate.engine

Methods in org.hibernate.engine that return LockMode
 LockMode EntityEntry.getLockMode()

Methods in org.hibernate.engine with parameters of type LockMode
static void | TwoPhaseLoad.postHydrate(EntityPersister persister, Serializable id, Object[] values, Object rowId, Object object, LockMode lockMode, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Register the "hydrated" state of an entity instance, after the first step of 2-phase loading.
static void | TwoPhaseLoad.addUninitializedEntity(EntityKey key, Object object, EntityPersister persister, LockMode lockMode, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Add an uninitialized instance of an entity class, as a placeholder to ensure object identity.
static void | TwoPhaseLoad.addUninitializedCachedEntity(EntityKey key, Object object, EntityPersister persister, LockMode lockMode, boolean lazyPropertiesAreUnfetched, Object version, SessionImplementor session)
EntityEntry | StatefulPersistenceContext.addEntity(Object entity, Status status, Object[] loadedState, EntityKey entityKey, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Adds an entity to the internal caches.
EntityEntry | StatefulPersistenceContext.addEntry(Object entity, Status status, Object[] loadedState, Object rowId, Serializable id, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.
EntityEntry | PersistenceContext.addEntity(Object entity, Status status, Object[] loadedState, EntityKey entityKey, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Adds an entity to the internal caches.
EntityEntry | PersistenceContext.addEntry(Object entity, Status status, Object[] loadedState, Object rowId, Serializable id, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.
void | EntityEntry.setLockMode(LockMode lockMode)

Uses of LockMode in org.hibernate.engine.query.sql

Methods in org.hibernate.engine.query.sql that return LockMode
 LockMode NativeSQLQueryNonScalarReturn.getLockMode()
Retrieve the lock-mode to apply to this return

Constructors in org.hibernate.engine.query.sql with parameters of type LockMode
NativeSQLQueryRootReturn(String alias, String entityName, LockMode lockMode)
Construct a return representing an entity returned at the root of the result.
NativeSQLQueryRootReturn(String alias, String entityName, Map propertyResults, LockMode lockMode)
NativeSQLQueryNonScalarReturn(String alias, Map propertyResults, LockMode lockMode)
Constructs some form of non-scalar return descriptor
NativeSQLQueryJoinReturn(String alias, String ownerAlias, String ownerProperty, Map propertyResults, LockMode lockMode)
Construct a return descriptor representing some form of fetch.
NativeSQLQueryCollectionReturn(String alias, String ownerEntityName, String ownerProperty, Map propertyResults, LockMode lockMode)
Construct a native-sql return representing a collection initializer

Uses of LockMode in org.hibernate.event

Fields in org.hibernate.event declared as LockMode
static LockMode LoadEvent.DEFAULT_LOCK_MODE

Methods in org.hibernate.event that return LockMode
LockMode | RefreshEvent.getLockMode()
LockMode | LockEvent.getLockMode()
LockMode | LoadEvent.getLockMode()

Methods in org.hibernate.event with parameters of type LockMode
void | LockEvent.setLockMode(LockMode lockMode)
void | LoadEvent.setLockMode(LockMode lockMode)

Constructors in org.hibernate.event with parameters of type LockMode
RefreshEvent(Object object, LockMode lockMode, EventSource source)
LockEvent(String entityName, Object original, LockMode lockMode, EventSource source)
LockEvent(Object object, LockMode lockMode, EventSource source)
LoadEvent(Serializable entityId, String entityClassName, LockMode lockMode, EventSource source)

Uses of LockMode in org.hibernate.event.def

Fields in org.hibernate.event.def declared as LockMode
static LockMode DefaultLoadEventListener.DEFAULT_LOCK_MODE

Methods in org.hibernate.event.def with parameters of type LockMode
protected  void AbstractLockUpgradeEventListener.upgradeLock(Object object, EntityEntry entry, LockMode requestedLockMode, SessionImplementor source)
Performs a pessimistic lock upgrade on a given entity, if needed.

Uses of LockMode in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that return LockMode
protected  LockMode[] QueryTranslatorImpl.getLockModes(Map lockModes)

Uses of LockMode in org.hibernate.impl

Methods in org.hibernate.impl that return LockMode
LockMode | SessionImpl.getCurrentLockMode(Object object)
LockMode | CriteriaImpl.Subcriteria.getLockMode()

Methods in org.hibernate.impl with parameters of type LockMode
Object | StatelessSessionImpl.get(Class entityClass, Serializable id, LockMode lockMode)
Object | StatelessSessionImpl.get(String entityName, Serializable id, LockMode lockMode)
void | StatelessSessionImpl.refresh(Object entity, LockMode lockMode)
void | StatelessSessionImpl.refresh(String entityName, Object entity, LockMode lockMode)
Query | SQLQueryImpl.setLockMode(String alias, LockMode lockMode)
SQLQuery | SQLQueryImpl.addJoin(String alias, String path, LockMode lockMode)
SQLQuery | SQLQueryImpl.addEntity(String alias, String entityName, LockMode lockMode)
SQLQuery | SQLQueryImpl.addEntity(String alias, Class entityClass, LockMode lockMode)
void | SessionImpl.lock(String entityName, Object object, LockMode lockMode)
void | SessionImpl.lock(Object object, LockMode lockMode)
Object | SessionImpl.load(Class entityClass, Serializable id, LockMode lockMode)
Object | SessionImpl.load(String entityName, Serializable id, LockMode lockMode)
Object | SessionImpl.get(Class entityClass, Serializable id, LockMode lockMode)
Object | SessionImpl.get(String entityName, Serializable id, LockMode lockMode)
void | SessionImpl.refresh(Object object, LockMode lockMode)
Query | QueryImpl.setLockMode(String alias, LockMode lockMode)
Criteria | CriteriaImpl.setLockMode(LockMode lockMode)
Criteria | CriteriaImpl.setLockMode(String alias, LockMode lockMode)
Criteria | CriteriaImpl.Subcriteria.setLockMode(LockMode lockMode)
Criteria | CriteriaImpl.Subcriteria.setLockMode(String alias, LockMode lockMode)

Uses of LockMode in org.hibernate.loader

Fields in org.hibernate.loader declared as LockMode
protected LockMode[] | OuterJoinLoader.lockModeArray
protected LockMode[] | JoinWalker.lockModeArray

Methods in org.hibernate.loader that return LockMode
protected LockMode[] | OuterJoinLoader.getLockModes(Map lockModes)
protected abstract LockMode[] | Loader.getLockModes(Map lockModes) What lock mode does this load entities with?
LockMode[] | JoinWalker.getLockModeArray()

Methods in org.hibernate.loader with parameters of type LockMode
void | JoinWalker.setLockModeArray(LockMode[] lockModeArray)
protected void | JoinWalker.initPersisters(List associations, LockMode lockMode)
protected void | AbstractEntityJoinWalker.initAll(String whereString, String orderByString, LockMode lockMode)
protected void | AbstractEntityJoinWalker.initProjection(String projectionString, String whereString, String orderByString, String groupByString, LockMode lockMode)

Uses of LockMode in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria that return LockMode
protected  LockMode[] CriteriaLoader.getLockModes(Map lockModes)

Uses of LockMode in org.hibernate.loader.custom

Methods in org.hibernate.loader.custom that return LockMode
LockMode | NonScalarReturn.getLockMode()
protected LockMode[] | CustomLoader.getLockModes(Map lockModesMap)

Constructors in org.hibernate.loader.custom with parameters of type LockMode
RootReturn(String alias, String entityName, EntityAliases entityAliases, LockMode lockMode)
NonScalarReturn(String alias, LockMode lockMode)
FetchReturn(NonScalarReturn owner, String ownerProperty, String alias, LockMode lockMode)
Creates a return descriptor for an association fetch.
EntityFetchReturn(String alias, EntityAliases entityAliases, NonScalarReturn owner, String ownerProperty, LockMode lockMode)
CollectionReturn(String alias, String ownerEntityName, String ownerProperty, CollectionAliases collectionAliases, EntityAliases elementEntityAliases, LockMode lockMode)
CollectionFetchReturn(String alias, NonScalarReturn owner, String ownerProperty, CollectionAliases collectionAliases, EntityAliases elementEntityAliases, LockMode lockMode)

Uses of LockMode in org.hibernate.loader.entity

Methods in org.hibernate.loader.entity with parameters of type LockMode
static UniqueEntityLoader BatchingEntityLoader.createBatchingEntityLoader(OuterJoinLoadable persister, int maxBatchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)

Constructors in org.hibernate.loader.entity with parameters of type LockMode
EntityLoader(OuterJoinLoadable persister, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityLoader(OuterJoinLoadable persister, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityLoader(OuterJoinLoadable persister, String[] uniqueKey, Type uniqueKeyType, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityJoinWalker(OuterJoinLoadable persister, String[] uniqueKey, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)

Uses of LockMode in org.hibernate.loader.hql

Methods in org.hibernate.loader.hql that return LockMode
protected  LockMode[] QueryLoader.getLockModes(Map lockModes)

Uses of LockMode in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity with parameters of type LockMode
protected String | UnionSubclassEntityPersister.generateSelectString(LockMode lockMode) Generate the SQL that selects a row by id
Object | EntityPersister.load(Serializable id, Object optionalObject, LockMode lockMode, SessionImplementor session) Load an instance of the persistent class.
void | EntityPersister.lock(Serializable id, Object version, Object object, LockMode lockMode, SessionImplementor session) Do a version check (optional operation)
protected LockingStrategy | AbstractEntityPersister.generateLocker(LockMode lockMode)
void | AbstractEntityPersister.lock(Serializable id, Object version, Object object, LockMode lockMode, SessionImplementor session)
protected UniqueEntityLoader | AbstractEntityPersister.createEntityLoader(LockMode lockMode, Map enabledFilters)
protected UniqueEntityLoader | AbstractEntityPersister.createEntityLoader(LockMode lockMode)
Object | AbstractEntityPersister.load(Serializable id, Object optionalObject, LockMode lockMode, SessionImplementor session) Load an instance using either the forUpdateLoader or the outer joining loader, depending upon the value of the lock parameter

Uses of LockMode in org.hibernate.sql

Methods in org.hibernate.sql that return LockMode
 LockMode Select.getLockMode()

Methods in org.hibernate.sql with parameters of type LockMode
SimpleSelect | SimpleSelect.setLockMode(LockMode lockMode)
Select | Select.setLockMode(LockMode lockMode)

Uses of LockMode in org.hibernate.util

Methods in org.hibernate.util that return LockMode
static LockMode[] ArrayHelper.fillArray(LockMode lockMode, int length)

Methods in org.hibernate.util with parameters of type LockMode
static LockMode[] ArrayHelper.fillArray(LockMode lockMode, int length)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.MappingException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.MappingException

Packages that use MappingException
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.util | Utility classes.

Uses of MappingException in org.hibernate

Subclasses of MappingException in org.hibernate
class | DuplicateMappingException Raised whenever a duplicate for a certain type occurs.
class | InvalidMappingException Thrown when a mapping is found to be invalid.
class | MappingNotFoundException Thrown when a resource for a mapping could not be found.
class | PropertyNotFoundException Indicates that an expected getter or setter method could not be found on a class.

Uses of MappingException in org.hibernate.cfg

Methods in org.hibernate.cfg that throw MappingException
void | SecondPass.doSecondPass(Map persistentClasses)
void | ResultSetMappingSecondPass.doSecondPass(Map persistentClasses)
void | NamedSQLQuerySecondPass.doSecondPass(Map persistentClasses)
void | Mappings.addClass(PersistentClass persistentClass)
void | Mappings.addCollection(Collection collection)
void | Mappings.addImport(String className, String rename)
Table | Mappings.addDenormalizedTable(String schema, String catalog, String name, boolean isAbstract, String subselect, Table includedTable)
void | Mappings.addQuery(String name, NamedQueryDefinition query)
void | Mappings.addSQLQuery(String name, NamedSQLQueryDefinition query)
static void | HbmBinder.bindRoot(org.dom4j.Document doc, Mappings mappings, Map inheritedMetas) The main contract into the hbm.xml-based binder.
static void | HbmBinder.bindRootClass(org.dom4j.Element node, RootClass rootClass, Mappings mappings, Map inheritedMetas) Responsible for perfoming the bind operation related to an <class/> mapping element.
static void | HbmBinder.bindClass(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindUnionSubclass(org.dom4j.Element node, UnionSubclass unionSubclass, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindSubclass(org.dom4j.Element node, Subclass subclass, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindJoinedSubclass(org.dom4j.Element node, JoinedSubclass joinedSubclass, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindColumns(org.dom4j.Element node, SimpleValue simpleValue, boolean isNullable, boolean autoColumn, String propertyPath, Mappings mappings)
static void | HbmBinder.bindSimpleValue(org.dom4j.Element node, SimpleValue simpleValue, boolean isNullable, String path, Mappings mappings)
static void | HbmBinder.bindProperty(org.dom4j.Element node, Property property, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindCollection(org.dom4j.Element node, Collection collection, String className, String path, Mappings mappings, Map inheritedMetas) Called for all collections
static void | HbmBinder.bindManyToOne(org.dom4j.Element node, ManyToOne manyToOne, String path, boolean isNullable, Mappings mappings)
static void | HbmBinder.bindAny(org.dom4j.Element node, Any any, boolean isNullable, Mappings mappings)
static void | HbmBinder.bindOneToOne(org.dom4j.Element node, OneToOne oneToOne, String path, boolean isNullable, Mappings mappings)
static void | HbmBinder.bindOneToMany(org.dom4j.Element node, OneToMany oneToMany, Mappings mappings)
static void | HbmBinder.bindArray(org.dom4j.Element node, Array array, String prefix, String path, Mappings mappings, Map inheritedMetas) Called for arrays and primitive arrays
static void | HbmBinder.bindComposite(org.dom4j.Element node, Component component, String path, boolean isNullable, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindCompositeId(org.dom4j.Element node, Component component, PersistentClass persistentClass, String propertyName, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindComponent(org.dom4j.Element node, Component component, String ownerClassName, String parentProperty, String path, boolean isNullable, boolean isEmbedded, Mappings mappings, Map inheritedMetas, boolean isIdentifierMapper)
static String | HbmBinder.getTypeFromXML(org.dom4j.Element node)
protected static void | HbmBinder.createClassProperties(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas)
protected static void | HbmBinder.createClassProperties(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas, UniqueKey uniqueKey, boolean mutable, boolean nullable, boolean naturalId)
static void | HbmBinder.bindListSecondPass(org.dom4j.Element node, List list, Map classes, Mappings mappings, Map inheritedMetas) Called for Lists, arrays, primitive arrays
static void | HbmBinder.bindIdentifierCollectionSecondPass(org.dom4j.Element node, IdentifierCollection collection, Map persistentClasses, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindMapSecondPass(org.dom4j.Element node, Map map, Map classes, Mappings mappings, Map inheritedMetas) Called for Maps
static void | HbmBinder.bindCollectionSecondPass(org.dom4j.Element node, Collection collection, Map persistentClasses, Mappings mappings, Map inheritedMetas) Called for all collections
Configuration | Configuration.addFile(String xmlFile) Read mappings from a particular XML file
Configuration | Configuration.addFile(File xmlFile) Read mappings from a particular XML file
Configuration | Configuration.addCacheableFile(File xmlFile) If a cached xmlFile + ".bin" exists and is newer than xmlFile the ".bin" file will be read directly.
Configuration | Configuration.addCacheableFile(String xmlFile)
Configuration | Configuration.addXML(String xml) Read mappings from a String
Configuration | Configuration.addURL(URL url) Read mappings from a URL
Configuration | Configuration.addDocument(org.w3c.dom.Document doc) Read mappings from a DOM Document
protected void | Configuration.add(org.dom4j.Document doc)
Configuration | Configuration.addInputStream(InputStream xmlInputStream) Read mappings from an InputStream
Configuration | Configuration.addResource(String path, ClassLoader classLoader) Read mappings from an application resource
Configuration | Configuration.addResource(String path) Read mappings from an application resource trying different classloaders.
Configuration | Configuration.addClass(Class persistentClass) Read a mapping from an application resource, using a convention.
Configuration | Configuration.addJar(File jar) Read all mappings from a jar file
Configuration | Configuration.addDirectory(File dir) Read all mapping documents from a directory tree.
protected void | Configuration.secondPassCompile()
protected void | Configuration.secondPassCompileForeignKeys(Table table, Set done)
Configuration | Configuration.setCacheConcurrencyStrategy(String clazz, String concurrencyStrategy) Set up a cache for an entity class
void | Configuration.setCacheConcurrencyStrategy(String clazz, String concurrencyStrategy, String region)
Configuration | Configuration.setCollectionCacheConcurrencyStrategy(String collectionRole, String concurrencyStrategy) Set up a cache for a collection role
void | Configuration.setCollectionCacheConcurrencyStrategy(String collectionRole, String concurrencyStrategy, String region)
void | CollectionSecondPass.doSecondPass(Map persistentClasses)
abstract void | CollectionSecondPass.secondPass(Map persistentClasses, Map inheritedMetas)

Uses of MappingException in org.hibernate.dialect

Methods in org.hibernate.dialect that throw MappingException
String | TypeNames.get(int typecode) get default type name for specified type
String | TypeNames.get(int typecode, int size, int precision, int scale) get type name for specified type and size
String | InformixDialect.getIdentitySelectString(String table, String column, int type)
String | InformixDialect.getIdentityColumnString(int type)
protected String | Dialect.getIdentitySelectString()
String | Dialect.getIdentitySelectString(String table, String column, int type) The syntax that returns the identity value of the last insert, if identity column key generation is supported.
protected String | Dialect.getIdentityColumnString()
String | Dialect.getIdentityColumnString(int type) The keyword used to specify an identity column, if identity column key generation is supported.
String | Dialect.getSequenceNextValString(String sequenceName) Generate the appropriate select statement to to retreive the next value of a sequence, if sequences are supported.
String | Dialect.getSelectSequenceNextValString(String sequenceName) Generate the select expression fragment that will retreive the next value of a sequence, if sequences are supported.
protected String | Dialect.getCreateSequenceString(String sequenceName) The syntax used to create a sequence, if sequences are supported.
String[] | Dialect.getCreateSequenceStrings(String sequenceName) The multiline script used to create a sequence, if sequences are supported.
protected String | Dialect.getDropSequenceString(String sequenceName) The syntax used to drop a sequence, if sequences are supported.
String[] | Dialect.getDropSequenceStrings(String sequenceName) The multiline script used to drop a sequence, if sequences are supported.

Uses of MappingException in org.hibernate.engine

Methods in org.hibernate.engine that throw MappingException
Boolean | VersionValue.isUnsaved(Object version) Does the given version belong to a new instance?
boolean | StatefulPersistenceContext.reassociateIfUninitializedProxy(Object value) Takes the given object and, if it represents a proxy, reassociates it with this event source.
void | StatefulPersistenceContext.reassociateProxy(Object value, Serializable id) If a deleted entity instance is re-saved, and it has a proxy, we need to reset the identifier of the proxy
Object | StatefulPersistenceContext.getCollectionOwner(Serializable key, CollectionPersister collectionPersister) Get the entity that owns this persistent collection
EntityPersister | SessionFactoryImplementor.getEntityPersister(String entityName) Get the persister for the named entity
CollectionPersister | SessionFactoryImplementor.getCollectionPersister(String role) Get the persister object for a collection role
String[] | SessionFactoryImplementor.getImplementors(String className) Get the names of all persistent classes that implement/extend the given interface/class
boolean | PersistenceContext.reassociateIfUninitializedProxy(Object value) Takes the given object and, if it represents a proxy, reassociates it with this event source.
void | PersistenceContext.reassociateProxy(Object value, Serializable id) If a deleted entity instance is re-saved, and it has a proxy, we need to reset the identifier of the proxy
Object | PersistenceContext.getCollectionOwner(Serializable key, CollectionPersister collectionPersister) Get the entity that owns this persistent collection
Type | Mapping.getIdentifierType(String className)
String | Mapping.getIdentifierPropertyName(String className)
Type | Mapping.getReferencedPropertyType(String className, String propertyName)
JoinSequence | JoinSequence.addJoin(AssociationType associationType, String alias, int joinType, String[] referencingKey)
JoinFragment | JoinSequence.toJoinFragment()
JoinFragment | JoinSequence.toJoinFragment(Map enabledFilters, boolean includeExtraJoins)
JoinFragment | JoinSequence.toJoinFragment(Map enabledFilters, boolean includeExtraJoins, String withClauseFragment, String withClauseJoinAlias)

Uses of MappingException in org.hibernate.engine.query

Methods in org.hibernate.engine.query that throw MappingException
HQLQueryPlan | QueryPlanCache.getHQLQueryPlan(String queryString, boolean shallow, Map enabledFilters)
FilterQueryPlan | QueryPlanCache.getFilterQueryPlan(String filterString, String collectionRole, boolean shallow, Map enabledFilters)

Uses of MappingException in org.hibernate.hql

Methods in org.hibernate.hql that throw MappingException
void | QueryTranslator.compile(Map replacements, boolean shallow) Compile a "normal" query.
static String[] | QuerySplitter.concreteQueries(String query, SessionFactoryImplementor factory) Handle Hibernate "implicit" polymorphism, by translating the query string into several "concrete" queries against mapped classes.
static String[][] | NameGenerator.generateColumnNames(Type[] types, SessionFactoryImplementor f)
void | FilterTranslator.compile(String collectionRole, Map replacements, boolean shallow) Compile a filter.

Uses of MappingException in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that throw MappingException
void | QueryTranslatorImpl.compile(Map replacements, boolean shallow) Compile a "normal" query.
void | QueryTranslatorImpl.compile(String collectionRole, Map replacements, boolean shallow) Compile a filter.

Uses of MappingException in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that throw MappingException
void | QueryTranslatorImpl.compile(Map replacements, boolean scalar) Compile a "normal" query.
void | QueryTranslatorImpl.compile(String collectionRole, Map replacements, boolean scalar) Compile a filter.

Uses of MappingException in org.hibernate.id

Methods in org.hibernate.id that throw MappingException
void | SequenceIdentityGenerator.configure(Type type, Properties params, Dialect dialect)
void | SequenceHiLoGenerator.configure(Type type, Properties params, Dialect d)
void | SequenceGenerator.configure(Type type, Properties params, Dialect dialect)
void | SelectGenerator.configure(Type type, Properties params, Dialect d)
void | MultipleHiLoPerTableGenerator.configure(Type type, Properties params, Dialect dialect)
void | IncrementGenerator.configure(Type type, Properties params, Dialect dialect)
static IdentifierGenerator | IdentifierGeneratorFactory.create(String strategy, Type type, Properties params, Dialect dialect)
void | ForeignGenerator.configure(Type type, Properties params, Dialect d)
void | Configurable.configure(Type type, Properties params, Dialect d) Configure this instance, given the value of parameters specified by the user as <param> elements.
void | Assigned.configure(Type type, Properties params, Dialect d)

Uses of MappingException in org.hibernate.impl

Methods in org.hibernate.impl that throw MappingException
Query | SessionImpl.getNamedQuery(String queryName)
EntityPersister | SessionFactoryImpl.getEntityPersister(String entityName)
CollectionPersister | SessionFactoryImpl.getCollectionPersister(String role)
Type | SessionFactoryImpl.getIdentifierType(String className)
String | SessionFactoryImpl.getIdentifierPropertyName(String className)
String[] | SessionFactoryImpl.getImplementors(String className) Return the names of all persistent (mapped) classes that extend or implement the given class or interface, accounting for implicit/explicit polymorphism settings and excluding mapped subclasses/joined-subclasses of other classes in the result.
Type | SessionFactoryImpl.getReferencedPropertyType(String className, String propertyName)
Query | AbstractSessionImpl.getNamedQuery(String queryName)
Query | AbstractSessionImpl.getNamedSQLQuery(String queryName)

Constructors in org.hibernate.impl that throw MappingException
ScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
FetchingScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
AbstractScrollableResults(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)

Uses of MappingException in org.hibernate.loader

Methods in org.hibernate.loader that throw MappingException
void | OuterJoinableAssociation.addJoins(JoinFragment outerjoin)
void | OuterJoinableAssociation.validateJoin(String path)
void | OuterJoinableAssociation.addManyToManyJoin(JoinFragment outerjoin, QueryableCollection collection)
protected void | JoinWalker.walkEntityTree(OuterJoinLoadable persister, String alias) For an entity class, return a list of associations to be fetched by outerjoin
protected void | JoinWalker.walkCollectionTree(QueryableCollection persister, String alias) For a collection role, return a list of associations to be fetched by outerjoin
protected int | JoinWalker.getJoinType(AssociationType type, FetchMode config, String path, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth, CascadeStyle cascadeStyle) Get the join type (inner, outer, etc) or -1 if the association should not be joined.
protected boolean | JoinWalker.isJoinedFetchEnabledInMapping(FetchMode config, AssociationType type) Does the mapping, and Hibernate default semantics, specify that this association should be fetched by outer joining
protected JoinFragment | JoinWalker.mergeOuterJoins(List associations) Generate a sequence of LEFT OUTER JOIN clauses for the given associations.
protected static int | JoinWalker.countEntityPersisters(List associations) Count the number of instances of Joinable which are actually also instances of Loadable, or are one-to-many associations
protected static int | JoinWalker.countCollectionPersisters(List associations) Count the number of instances of Joinable which are actually also instances of PersistentCollection which are being fetched by outer join
protected static String | JoinWalker.orderBy(List associations) Get the order by string required for collection fetching
protected void | JoinWalker.initPersisters(List associations, LockMode lockMode)
protected String | JoinWalker.selectString(List associations) Generate a select list of columns containing all properties of the entity classes
protected void | AbstractEntityJoinWalker.initAll(String whereString, String orderByString, LockMode lockMode)
protected void | AbstractEntityJoinWalker.initProjection(String projectionString, String whereString, String orderByString, String groupByString, LockMode lockMode)
protected String | AbstractEntityJoinWalker.getWhereFragment() Don't bother with the discriminator, unless overridded by subclass

Constructors in org.hibernate.loader that throw MappingException
OuterJoinableAssociation(AssociationType joinableType, String lhsAlias, String[] lhsColumns, String rhsAlias, int joinType, SessionFactoryImplementor factory, Map enabledFilters)

Uses of MappingException in org.hibernate.loader.collection

Methods in org.hibernate.loader.collection that throw MappingException
static CollectionInitializer | BatchingCollectionInitializer.createBatchingOneToManyInitializer(QueryableCollection persister, int maxBatchSize, SessionFactoryImplementor factory, Map enabledFilters)
static CollectionInitializer | BatchingCollectionInitializer.createBatchingCollectionInitializer(QueryableCollection persister, int maxBatchSize, SessionFactoryImplementor factory, Map enabledFilters)
protected int | BasicCollectionJoinWalker.getJoinType(AssociationType type, FetchMode config, String path, Set visitedAssociations, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth) We can use an inner join for first many-to-many association

Constructors in org.hibernate.loader.collection that throw MappingException
SubselectOneToManyLoader(QueryableCollection persister, String subquery, Collection entityKeys, QueryParameters queryParameters, Map namedParameterLocMap, SessionFactoryImplementor factory, Map enabledFilters)
SubselectCollectionLoader(QueryableCollection persister, String subquery, Collection entityKeys, QueryParameters queryParameters, Map namedParameterLocMap, SessionFactoryImplementor factory, Map enabledFilters)
OneToManyLoader(QueryableCollection oneToManyPersister, SessionFactoryImplementor session, Map enabledFilters)
OneToManyLoader(QueryableCollection oneToManyPersister, int batchSize, SessionFactoryImplementor factory, Map enabledFilters)
OneToManyLoader(QueryableCollection oneToManyPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)
OneToManyJoinWalker(QueryableCollection oneToManyPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)
BasicCollectionLoader(QueryableCollection collectionPersister, SessionFactoryImplementor session, Map enabledFilters)
BasicCollectionLoader(QueryableCollection collectionPersister, int batchSize, SessionFactoryImplementor factory, Map enabledFilters)
BasicCollectionLoader(QueryableCollection collectionPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)
BasicCollectionJoinWalker(QueryableCollection collectionPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)

Uses of MappingException in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria that throw MappingException
protected int | CriteriaJoinWalker.getJoinType(AssociationType type, FetchMode config, String path, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth, CascadeStyle cascadeStyle)
protected String | CriteriaJoinWalker.getWhereFragment() Use the discriminator, to narrow the select to instances of the queried subclass, also applying any filters.

Uses of MappingException in org.hibernate.loader.entity

Methods in org.hibernate.loader.entity that throw MappingException
static UniqueEntityLoader BatchingEntityLoader.createBatchingEntityLoader(OuterJoinLoadable persister, int maxBatchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)

Constructors in org.hibernate.loader.entity that throw MappingException
EntityLoader(OuterJoinLoadable persister, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityLoader(OuterJoinLoadable persister, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityLoader(OuterJoinLoadable persister, String[] uniqueKey, Type uniqueKeyType, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityJoinWalker(OuterJoinLoadable persister, String[] uniqueKey, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
CollectionElementLoader(QueryableCollection collectionPersister, SessionFactoryImplementor factory, Map enabledFilters)
CascadeEntityLoader(OuterJoinLoadable persister, CascadingAction action, SessionFactoryImplementor factory)
CascadeEntityJoinWalker(OuterJoinLoadable persister, CascadingAction action, SessionFactoryImplementor factory)

Uses of MappingException in org.hibernate.mapping

Methods in org.hibernate.mapping that throw MappingException
Type | Value.getType()
void | Value.createForeignKey()
boolean | Value.isValid(Mapping mapping)
void | Value.setTypeUsingReflection(String className, String propertyName)
void | UnionSubclass.validate(Mapping mapping)
abstract void | ToOne.createForeignKey()
abstract Type | ToOne.getType()
void | ToOne.setTypeUsingReflection(String className, String propertyName)
boolean | ToOne.isValid(Mapping mapping)
void | SingleTableSubclass.validate(Mapping mapping)
void | SimpleValue.createForeignKey()
IdentifierGenerator | SimpleValue.createIdentifierGenerator(Dialect dialect, String defaultCatalog, String defaultSchema, RootClass rootClass)
boolean | SimpleValue.isValid(Mapping mapping)
Type | SimpleValue.getType()
void | SimpleValue.setTypeUsingReflection(String className, String propertyName)
void | Set.validate(Mapping mapping)
void | RootClass.addSubclass(Subclass subclass)
void | RootClass.validate(Mapping mapping)
Type | Property.getType()
CascadeStyle | Property.getCascadeStyle()
boolean | Property.isValid(Mapping mapping)
Getter | Property.getGetter(Class clazz)
Setter | Property.getSetter(Class clazz)
PropertyAccessor | Property.getPropertyAccessor(Class clazz)
Class | PersistentClass.getMappedClass()
void | PersistentClass.addSubclass(Subclass subclass)
Property | PersistentClass.getReferencedProperty(String propertyPath)
Property | PersistentClass.getRecursiveProperty(String propertyPath)
Property | PersistentClass.getProperty(String propertyName)
void | PersistentClass.validate(Mapping mapping)
protected void | PersistentClass.checkColumnDuplication(Set distinctColumns, Iterator columns)
protected void | PersistentClass.checkPropertyColumnDuplication(Set distinctColumns, Iterator properties)
Type | OneToOne.getType()
void | OneToOne.createForeignKey()
boolean | OneToMany.isValid(Mapping mapping)
void | Map.createAllKeys()
Type | ManyToOne.getType()
void | ManyToOne.createForeignKey()
CollectionType | List.getDefaultCollectionType()
IdentifierGenerator | KeyValue.createIdentifierGenerator(Dialect dialect, String defaultCatalog, String defaultSchema, RootClass rootClass)
void | JoinedSubclass.validate(Mapping mapping)
void | IndexedCollection.validate(Mapping mapping)
void | IdentifierCollection.validate(Mapping mapping)
void | ForeignKey.setReferencedTable(Table referencedTable)
Type | DependantValue.getType()
Class | Component.getComponentClass()
Type | Component.getType()
void | Component.setTypeUsingReflection(String className, String propertyName)
Property | Component.getProperty(String propertyName)
int | Column.getSqlTypeCode(Mapping mapping)
abstract CollectionType | Collection.getDefaultCollectionType()
void | Collection.validate(Mapping mapping)
Type | Collection.getType()
boolean | Collection.isValid(Mapping mapping)
void | Collection.createAllKeys()
Class | Array.getElementClass()
CollectionType | Array.getDefaultCollectionType()
Type | Any.getType()
void | Any.setTypeUsingReflection(String className, String propertyName)

Constructors in org.hibernate.mapping that throw MappingException
OneToOne(Table table, PersistentClass owner)
OneToMany(PersistentClass owner)
Component(PersistentClass owner)
Component(Component component)
Component(Join join)
Component(Collection collection)

Uses of MappingException in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that throw MappingException
protected CollectionInitializer | OneToManyPersister.createCollectionInitializer(Map enabledFilters) Create the OneToManyLoader
String | OneToManyPersister.filterFragment(String alias)
void | CollectionPersister.postInstantiate()
protected CollectionInitializer | BasicCollectionPersister.createCollectionInitializer(Map enabledFilters) Create the CollectionLoader
void | AbstractCollectionPersister.postInstantiate()
protected abstract CollectionInitializer | AbstractCollectionPersister.createCollectionInitializer(Map enabledFilters)
protected String | AbstractCollectionPersister.filterFragment(String alias)
String | AbstractCollectionPersister.filterFragment(String alias, Map enabledFilters)
String | AbstractCollectionPersister.oneToManyFilterFragment(String alias)

Constructors in org.hibernate.persister.collection that throw MappingException
OneToManyPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
ElementPropertyMapping(String[] elementColumns, Type type)
CompositeElementPropertyMapping(String[] elementColumns, String[] elementFormulaTemplates, AbstractComponentType compositeType, Mapping factory)
BasicCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
AbstractCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)

Uses of MappingException in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that throw MappingException
String | SingleTableEntityPersister.filterFragment(String alias)
String | SingleTableEntityPersister.oneToManyFilterFragment(String alias)
String | Joinable.filterFragment(String alias, Map enabledFilters) Get the where clause filter, given a query alias and considering enabled session filters
String | Joinable.oneToManyFilterFragment(String alias)
void | EntityPersister.postInstantiate() Finish the initialization of this object, once all ClassPersisters have been instantiated.
Type | EntityPersister.getPropertyType(String propertyName) Get the type of a particular property
protected void | AbstractPropertyMapping.initPropertyPaths(String path, Type type, String[] columns, String[] formulaTemplates, Mapping factory)
protected void | AbstractPropertyMapping.initIdentifierPropertyPaths(String path, EntityType etype, String[] columns, Mapping factory)
protected void | AbstractPropertyMapping.initComponentPropertyPaths(String path, AbstractComponentType type, String[] columns, String[] formulaTemplates, Mapping factory)
protected abstract String | AbstractEntityPersister.filterFragment(String alias)
protected void | AbstractEntityPersister.initSubclassPropertyAliasesMap(PersistentClass model) Must be called by subclasses, at the end of their constructors
protected void | AbstractEntityPersister.createUniqueKeyLoaders()
protected void | AbstractEntityPersister.initPropertyPaths(Mapping mapping)
protected UniqueEntityLoader | AbstractEntityPersister.createEntityLoader(LockMode lockMode, Map enabledFilters)
protected UniqueEntityLoader | AbstractEntityPersister.createEntityLoader(LockMode lockMode)
String | AbstractEntityPersister.filterFragment(String alias, Map enabledFilters)
String | AbstractEntityPersister.oneToManyFilterFragment(String alias)
protected void | AbstractEntityPersister.postConstruct(Mapping mapping)
void | AbstractEntityPersister.postInstantiate()
Type | AbstractEntityPersister.getPropertyType(String propertyName)

Uses of MappingException in org.hibernate.property

Methods in org.hibernate.property that throw MappingException
static PropertyAccessor | PropertyAccessorFactory.getPropertyAccessor(Property property, EntityMode mode) Retrieves a PropertyAccessor instance based on the given property definition and entity mode.
static PropertyAccessor | PropertyAccessorFactory.getDynamicMapPropertyAccessor()
static PropertyAccessor | PropertyAccessorFactory.getDom4jPropertyAccessor(String nodeName, Type type, SessionFactoryImplementor factory)
static PropertyAccessor | PropertyAccessorFactory.getPropertyAccessor(Class optionalClass, String type)
static PropertyAccessor | PropertyAccessorFactory.getPropertyAccessor(String type)

Uses of MappingException in org.hibernate.type

Methods in org.hibernate.type that throw MappingException
static Type | TypeFactory.heuristicType(String typeName) Uses heuristics to deduce a Hibernate type given a string naming the type or Java class.
static Type | TypeFactory.heuristicType(String typeName, Properties parameters) Uses heuristics to deduce a Hibernate type given a string naming the type or Java class.
int[] | Type.sqlTypes(Mapping mapping) Return the SQL type codes for the columns mapped by this type.
int | Type.getColumnSpan(Mapping mapping) How many columns are used to persist this type.
int | SpecialOneToOneType.getColumnSpan(Mapping mapping)
int[] | SpecialOneToOneType.sqlTypes(Mapping mapping)
int | OneToOneType.getColumnSpan(Mapping session)
int[] | OneToOneType.sqlTypes(Mapping session)
int[] | MetaType.sqlTypes(Mapping mapping)
int | MetaType.getColumnSpan(Mapping mapping)
int | ManyToOneType.getColumnSpan(Mapping mapping)
int[] | ManyToOneType.sqlTypes(Mapping mapping)
Joinable | EntityType.getAssociatedJoinable(SessionFactoryImplementor factory)
Type | EntityType.getIdentifierOrUniqueKeyType(Mapping factory)
String | EntityType.getIdentifierOrUniqueKeyPropertyName(Mapping factory)
String | EntityType.getOnCondition(String alias, SessionFactoryImplementor factory, Map enabledFilters)
int | CompositeCustomType.getColumnSpan(Mapping mapping)
int[] | CompositeCustomType.sqlTypes(Mapping mapping)
int[] | ComponentType.sqlTypes(Mapping mapping)
int | ComponentType.getColumnSpan(Mapping mapping)
int[] | CollectionType.sqlTypes(Mapping session)
int | CollectionType.getColumnSpan(Mapping session)
Joinable | CollectionType.getAssociatedJoinable(SessionFactoryImplementor factory)
String | CollectionType.getAssociatedEntityName(SessionFactoryImplementor factory)
Type | CollectionType.getElementType(SessionFactoryImplementor factory) Get the Hibernate type of the collection elements
String | CollectionType.getOnCondition(String alias, SessionFactoryImplementor factory, Map enabledFilters)
int[] | ClobType.sqlTypes(Mapping mapping)
int[] | BlobType.sqlTypes(Mapping mapping)
Joinable | AssociationType.getAssociatedJoinable(SessionFactoryImplementor factory) Get the "persister" for this association - a class or collection persister
String | AssociationType.getAssociatedEntityName(SessionFactoryImplementor factory) Get the entity name of the associated entity
String | AssociationType.getOnCondition(String alias, SessionFactoryImplementor factory, Map enabledFilters) Get the "filtering" SQL fragment that is applied in the SQL on clause, in addition to the usual join condition
int | AnyType.getColumnSpan(Mapping session)
int[] | AnyType.sqlTypes(Mapping mapping)
String | AnyType.getAssociatedEntityName(SessionFactoryImplementor factory)
String | AnyType.getOnCondition(String alias, SessionFactoryImplementor factory, Map enabledFilters)

Constructors in org.hibernate.type that throw MappingException
CustomType(Class userTypeClass, Properties parameters)
CompositeCustomType(Class userTypeClass, Properties parameters)

Uses of MappingException in org.hibernate.util

Methods in org.hibernate.util that throw MappingException
static Class | ReflectHelper.reflectedPropertyClass(String className, String name)
static Getter | ReflectHelper.getGetter(Class theClass, String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.MappingNotFoundException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.MappingNotFoundException

No usage of org.hibernate.MappingNotFoundException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.NonUniqueObjectException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.NonUniqueObjectException

No usage of org.hibernate.NonUniqueObjectException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.NonUniqueResultException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.NonUniqueResultException

No usage of org.hibernate.NonUniqueResultException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.ObjectDeletedException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.ObjectDeletedException

No usage of org.hibernate.ObjectDeletedException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.ObjectNotFoundException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.ObjectNotFoundException

No usage of org.hibernate.ObjectNotFoundException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.PersistentObjectException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.PersistentObjectException

No usage of org.hibernate.PersistentObjectException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.PropertyAccessException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.PropertyAccessException

No usage of org.hibernate.PropertyAccessException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.PropertyNotFoundException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.PropertyNotFoundException

Packages that use PropertyNotFoundException
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.util | Utility classes.

Uses of PropertyNotFoundException in org.hibernate.mapping

Methods in org.hibernate.mapping that throw PropertyNotFoundException
Getter | Property.getGetter(Class clazz)
Setter | Property.getSetter(Class clazz)

Uses of PropertyNotFoundException in org.hibernate.property

Methods in org.hibernate.property that throw PropertyNotFoundException
Getter | PropertyAccessor.getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Setter | PropertyAccessor.getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute
Getter | NoopAccessor.getGetter(Class arg0, String arg1)
Setter | NoopAccessor.getSetter(Class arg0, String arg1)
Getter | MapAccessor.getGetter(Class theClass, String propertyName)
Setter | MapAccessor.getSetter(Class theClass, String propertyName)
Getter | EmbeddedPropertyAccessor.getGetter(Class theClass, String propertyName)
Setter | EmbeddedPropertyAccessor.getSetter(Class theClass, String propertyName)
Getter | Dom4jAccessor.getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Setter | Dom4jAccessor.getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute
Getter | DirectPropertyAccessor.getGetter(Class theClass, String propertyName)
Setter | DirectPropertyAccessor.getSetter(Class theClass, String propertyName)
Getter | ChainedPropertyAccessor.getGetter(Class theClass, String propertyName)
Setter | ChainedPropertyAccessor.getSetter(Class theClass, String propertyName)
Setter | BasicPropertyAccessor.getSetter(Class theClass, String propertyName)
Getter | BasicPropertyAccessor.getGetter(Class theClass, String propertyName)
static Getter | BasicPropertyAccessor.createGetter(Class theClass, String propertyName)

Uses of PropertyNotFoundException in org.hibernate.util

Methods in org.hibernate.util that throw PropertyNotFoundException
static Constructor | ReflectHelper.getDefaultConstructor(Class clazz)
static Constructor | ReflectHelper.getConstructor(Class clazz, Type[] types)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.PropertyValueException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.PropertyValueException

Packages that use PropertyValueException
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of PropertyValueException in org.hibernate.engine

Methods in org.hibernate.engine that throw PropertyValueException
 void Nullability.checkNullability(Object[] values, EntityPersister persister, boolean isUpdate)
Check nullability of the class persister properties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.Query (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.Query

Packages that use Query
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.classic | This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of Query in org.hibernate

Subinterfaces of Query in org.hibernate
 interface SQLQuery
Allows the user to declare the types and select list injection points of all entities returned by the query.

Methods in org.hibernate that return Query
Query | StatelessSession.createQuery(String queryString) Create a new instance of Query for the given HQL query string.
Query | StatelessSession.getNamedQuery(String queryName) Obtain an instance of Query for a named query string defined in the mapping file.
Query | Session.createQuery(String queryString) Create a new instance of Query for the given HQL query string.
Query | Session.createFilter(Object collection, String queryString) Create a new instance of Query for the given collection and filter string.
Query | Session.getNamedQuery(String queryName) Obtain an instance of Query for a named query string defined in the mapping file.
Query | Query.setMaxResults(int maxResults) Set the maximum number of rows to retrieve.
Query | Query.setFirstResult(int firstResult) Set the first row to retrieve.
Query | Query.setReadOnly(boolean readOnly) Entities retrieved by this query will be loaded in a read-only mode where Hibernate will never dirty-check them or make changes persistent.
Query | Query.setCacheable(boolean cacheable) Enable caching of this query result set.
Query | Query.setCacheRegion(String cacheRegion) Set the name of the cache region.
Query | Query.setTimeout(int timeout) Set a timeout for the underlying JDBC query.
Query | Query.setFetchSize(int fetchSize) Set a fetch size for the underlying JDBC query.
Query | Query.setLockMode(String alias, LockMode lockMode) Set the lockmode for the objects idententified by the given alias that appears in the FROM clause.
Query | Query.setComment(String comment) Add a comment to the generated SQL.
Query | Query.setFlushMode(FlushMode flushMode) Override the current session flush mode, just for this query.
Query | Query.setCacheMode(CacheMode cacheMode) Override the current session cache mode, just for this query.
Query | Query.setParameter(int position, Object val, Type type) Bind a value to a JDBC-style query parameter.
Query | Query.setParameter(String name, Object val, Type type) Bind a value to a named query parameter.
Query | Query.setParameter(int position, Object val) Bind a value to a JDBC-style query parameter, guessing the Hibernate type from the class of the given object.
Query | Query.setParameter(String name, Object val) Bind a value to a named query parameter, guessing the Hibernate type from the class of the given object.
Query | Query.setParameters(Object[] values, Type[] types) Bind values and types to positional parameters.
Query | Query.setParameterList(String name, Collection vals, Type type) Bind multiple values to a named query parameter.
Query | Query.setParameterList(String name, Collection vals) Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the collection.
Query | Query.setParameterList(String name, Object[] vals, Type type) Bind multiple values to a named query parameter.
Query | Query.setParameterList(String name, Object[] vals) Bind multiple values to a named query parameter, guessing the Hibernate type from the class of the first object in the array.
Query | Query.setProperties(Object bean) Bind the property values of the given bean to named parameters of the query, matching property names with parameter names and mapping property types to Hibernate types using hueristics.
Query | Query.setString(int position, String val)
Query | Query.setCharacter(int position, char val)
Query | Query.setBoolean(int position, boolean val)
Query | Query.setByte(int position, byte val)
Query | Query.setShort(int position, short val)
Query | Query.setInteger(int position, int val)
Query | Query.setLong(int position, long val)
Query | Query.setFloat(int position, float val)
Query | Query.setDouble(int position, double val)
Query | Query.setBinary(int position, byte[] val)
Query | Query.setText(int position, String val)
Query | Query.setSerializable(int position, Serializable val)
Query | Query.setLocale(int position, Locale locale)
Query | Query.setBigDecimal(int position, BigDecimal number)
Query | Query.setBigInteger(int position, BigInteger number)
Query | Query.setDate(int position, Date date)
Query | Query.setTime(int position, Date date)
Query | Query.setTimestamp(int position, Date date)
Query | Query.setCalendar(int position, Calendar calendar)
Query | Query.setCalendarDate(int position, Calendar calendar)
Query | Query.setString(String name, String val)
Query | Query.setCharacter(String name, char val)
Query | Query.setBoolean(String name, boolean val)
Query | Query.setByte(String name, byte val)
Query | Query.setShort(String name, short val)
Query | Query.setInteger(String name, int val)
Query | Query.setLong(String name, long val)
Query | Query.setFloat(String name, float val)
Query | Query.setDouble(String name, double val)
Query | Query.setBinary(String name, byte[] val)
Query | Query.setText(String name, String val)
Query | Query.setSerializable(String name, Serializable val)
Query | Query.setLocale(String name, Locale locale)
Query | Query.setBigDecimal(String name, BigDecimal number)
Query | Query.setBigInteger(String name, BigInteger number)
Query | Query.setDate(String name, Date date)
Query | Query.setTime(String name, Date date)
Query | Query.setTimestamp(String name, Date date)
Query | Query.setCalendar(String name, Calendar calendar)
Query | Query.setCalendarDate(String name, Calendar calendar)
Query | Query.setEntity(int position, Object val) Bind an instance of a mapped persistent class to a JDBC-style query parameter.
Query | Query.setEntity(String name, Object val) Bind an instance of a mapped persistent class to a named query parameter.
Query | Query.setResultTransformer(ResultTransformer transformer) Set a strategy for handling the query results.

Uses of Query in org.hibernate.classic

Methods in org.hibernate.classic that return Query
Query | Session.createSQLQuery(String sql, String returnAlias, Class returnClass) Deprecated. will be replaced with a more Query like interface in later release
Query | Session.createSQLQuery(String sql, String[] returnAliases, Class[] returnClasses) Deprecated. will be replaced with a more Query like interface in later release

Uses of Query in org.hibernate.engine

Methods in org.hibernate.engine that return Query
Query | SessionImplementor.getNamedQuery(String name) Get a Query instance for a named query or named native SQL query
Query | SessionImplementor.getNamedSQLQuery(String name) Get a Query instance for a named native SQL query

Uses of Query in org.hibernate.impl

Classes in org.hibernate.impl that implement Query
class | AbstractQueryImpl Abstract implementation of the Query interface.
class | CollectionFilterImpl implementation of the Query interface for collection filters
class | QueryImpl default implementation of the Query interface, for "ordinary" HQL queries (not collection filters)
class | SQLQueryImpl Implements SQL query passthrough.

Methods in org.hibernate.impl that return Query
Query | SQLQueryImpl.setLockMode(String alias, LockMode lockMode)
Query | SessionImpl.createFilter(Object collection, String queryString)
Query | SessionImpl.getNamedQuery(String queryName)
Query | SessionImpl.createQuery(String queryString)
Query | SessionImpl.createSQLQuery(String sql, String returnAlias, Class returnClass)
Query | SessionImpl.createSQLQuery(String sql, String[] returnAliases, Class[] returnClasses)
Query | QueryImpl.setLockMode(String alias, LockMode lockMode)
Query | AbstractSessionImpl.getNamedQuery(String queryName)
Query | AbstractSessionImpl.getNamedSQLQuery(String queryName)
Query | AbstractSessionImpl.createQuery(String queryString)
Query | AbstractQueryImpl.setFlushMode(FlushMode flushMode)
Query | AbstractQueryImpl.setCacheMode(CacheMode cacheMode)
Query | AbstractQueryImpl.setCacheable(boolean cacheable)
Query | AbstractQueryImpl.setCacheRegion(String cacheRegion)
Query | AbstractQueryImpl.setComment(String comment)
Query | AbstractQueryImpl.setFirstResult(int firstResult)
Query | AbstractQueryImpl.setMaxResults(int maxResults)
Query | AbstractQueryImpl.setTimeout(int timeout)
Query | AbstractQueryImpl.setFetchSize(int fetchSize)
Query | AbstractQueryImpl.setCollectionKey(Serializable collectionKey)
Query | AbstractQueryImpl.setReadOnly(boolean readOnly)
Query | AbstractQueryImpl.setResultTransformer(ResultTransformer transformer)
Query | AbstractQueryImpl.setParameter(int position, Object val, Type type)
Query | AbstractQueryImpl.setParameter(String name, Object val, Type type)
Query | AbstractQueryImpl.setParameter(int position, Object val)
Query | AbstractQueryImpl.setParameter(String name, Object val)
Query | AbstractQueryImpl.setString(int position, String val)
Query | AbstractQueryImpl.setCharacter(int position, char val)
Query | AbstractQueryImpl.setBoolean(int position, boolean val)
Query | AbstractQueryImpl.setByte(int position, byte val)
Query | AbstractQueryImpl.setShort(int position, short val)
Query | AbstractQueryImpl.setInteger(int position, int val)
Query | AbstractQueryImpl.setLong(int position, long val)
Query | AbstractQueryImpl.setFloat(int position, float val)
Query | AbstractQueryImpl.setDouble(int position, double val)
Query | AbstractQueryImpl.setBinary(int position, byte[] val)
Query | AbstractQueryImpl.setText(int position, String val)
Query | AbstractQueryImpl.setSerializable(int position, Serializable val)
Query | AbstractQueryImpl.setDate(int position, Date date)
Query | AbstractQueryImpl.setTime(int position, Date date)
Query | AbstractQueryImpl.setTimestamp(int position, Date date)
Query | AbstractQueryImpl.setEntity(int position, Object val)
Query | AbstractQueryImpl.setLocale(int position, Locale locale)
Query | AbstractQueryImpl.setCalendar(int position, Calendar calendar)
Query | AbstractQueryImpl.setCalendarDate(int position, Calendar calendar)
Query | AbstractQueryImpl.setBinary(String name, byte[] val)
Query | AbstractQueryImpl.setText(String name, String val)
Query | AbstractQueryImpl.setBoolean(String name, boolean val)
Query | AbstractQueryImpl.setByte(String name, byte val)
Query | AbstractQueryImpl.setCharacter(String name, char val)
Query | AbstractQueryImpl.setDate(String name, Date date)
Query | AbstractQueryImpl.setDouble(String name, double val)
Query | AbstractQueryImpl.setEntity(String name, Object val)
Query | AbstractQueryImpl.setFloat(String name, float val)
Query | AbstractQueryImpl.setInteger(String name, int val)
Query | AbstractQueryImpl.setLocale(String name, Locale locale)
Query | AbstractQueryImpl.setCalendar(String name, Calendar calendar)
Query | AbstractQueryImpl.setCalendarDate(String name, Calendar calendar)
Query | AbstractQueryImpl.setLong(String name, long val)
Query | AbstractQueryImpl.setSerializable(String name, Serializable val)
Query | AbstractQueryImpl.setShort(String name, short val)
Query | AbstractQueryImpl.setString(String name, String val)
Query | AbstractQueryImpl.setTime(String name, Date date)
Query | AbstractQueryImpl.setTimestamp(String name, Date date)
Query | AbstractQueryImpl.setBigDecimal(int position, BigDecimal number)
Query | AbstractQueryImpl.setBigDecimal(String name, BigDecimal number)
Query | AbstractQueryImpl.setBigInteger(int position, BigInteger number)
Query | AbstractQueryImpl.setBigInteger(String name, BigInteger number)
Query | AbstractQueryImpl.setParameterList(String name, Collection vals, Type type)
Query | AbstractQueryImpl.setParameterList(String name, Collection vals)
Query | AbstractQueryImpl.setParameterList(String name, Object[] vals, Type type)
Query | AbstractQueryImpl.setParameterList(String name, Object[] vals)
Query | AbstractQueryImpl.setProperties(Object bean)
Query | AbstractQueryImpl.setParameters(Object[] values, Type[] types)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.QueryException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.QueryException

Packages that use QueryException
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function | A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of QueryException in org.hibernate

Subclasses of QueryException in org.hibernate
 class QueryParameterException
Parameter invalid or not found in the query

Uses of QueryException in org.hibernate.dialect

Methods in org.hibernate.dialect that throw QueryException
Type | DerbyDialect.DerbyTrimFunctionEmulation.getReturnType(Type columnType, Mapping mapping)
String | DerbyDialect.DerbyTrimFunctionEmulation.render(List args, SessionFactoryImplementor factory)

Uses of QueryException in org.hibernate.dialect.function

Methods in org.hibernate.dialect.function that throw QueryException
Type | VarArgsSQLFunction.getReturnType(Type columnType, Mapping mapping)
String | VarArgsSQLFunction.render(List args, SessionFactoryImplementor factory)
Type | SQLFunctionTemplate.getReturnType(Type columnType, Mapping mapping)
Type | SQLFunction.getReturnType(Type columnType, Mapping mapping) The function return type
String | SQLFunction.render(List args, SessionFactoryImplementor factory) Render the function call as SQL
Type | PositionSubstringFunction.getReturnType(Type columnType, Mapping mapping)
String | PositionSubstringFunction.render(List args, SessionFactoryImplementor factory)
Type | NvlFunction.getReturnType(Type columnType, Mapping mapping)
String | NvlFunction.render(List args, SessionFactoryImplementor factory)
Type | NoArgSQLFunction.getReturnType(Type columnType, Mapping mapping)
String | NoArgSQLFunction.render(List args, SessionFactoryImplementor factory)
Type | ClassicAvgFunction.getReturnType(Type columnType, Mapping mapping)
Type | CharIndexFunction.getReturnType(Type columnType, Mapping mapping)
String | CharIndexFunction.render(List args, SessionFactoryImplementor factory)
Type | CastFunction.getReturnType(Type columnType, Mapping mapping)
String | CastFunction.render(List args, SessionFactoryImplementor factory)
Type | AnsiTrimEmulationFunction.getReturnType(Type columnType, Mapping mapping)
String | AnsiTrimEmulationFunction.render(List args, SessionFactoryImplementor factory)

Uses of QueryException in org.hibernate.engine

Methods in org.hibernate.engine that throw QueryException
 void QueryParameters.validateParameters()

Uses of QueryException in org.hibernate.engine.query

Methods in org.hibernate.engine.query that throw QueryException
HQLQueryPlan | QueryPlanCache.getHQLQueryPlan(String queryString, boolean shallow, Map enabledFilters)
FilterQueryPlan | QueryPlanCache.getFilterQueryPlan(String filterString, String collectionRole, boolean shallow, Map enabledFilters)
static void | ParameterParser.parse(String sqlString, ParameterParser.Recognizer recognizer) Performs the actual parsing and tokenizing of the query string making appropriate callbacks to the given recognizer upon recognition of the various tokens.

Uses of QueryException in org.hibernate.hql

Subclasses of QueryException in org.hibernate.hql
 class QueryExecutionRequestException
Expecting to execute an illegal operation regarding the query type

Methods in org.hibernate.hql that throw QueryException
void | QueryTranslator.compile(Map replacements, boolean shallow) Compile a "normal" query.
void | FilterTranslator.compile(String collectionRole, Map replacements, boolean shallow) Compile a filter.

Uses of QueryException in org.hibernate.hql.ast

Subclasses of QueryException in org.hibernate.hql.ast
 class QuerySyntaxException
Exception thrown when there is a syntax error in the HQL.

Methods in org.hibernate.hql.ast that throw QueryException
void | QueryTranslatorImpl.compile(Map replacements, boolean shallow) Compile a "normal" query.
void | QueryTranslatorImpl.compile(String collectionRole, Map replacements, boolean shallow) Compile a filter.
void | ParseErrorHandler.throwQueryException()
protected void | HqlSqlWalker.postProcessInsert(antlr.collections.AST insert)
int[] | HqlSqlWalker.getNamedParameterLocations(String name) Returns the locations of all occurrences of the named parameter.
void | ErrorCounter.throwQueryException()

Uses of QueryException in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that throw QueryException
void | IntoClause.validateTypes(SelectClause selectClause)
void | InsertStatement.validate() Performs detailed semantic validation on this insert statement tree.

Uses of QueryException in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util that throw QueryException
 QueryableCollection SessionFactoryHelper.requireQueryableCollection(String role)
Locate the collection persister by the collection role, requiring that such a persister exist.

Uses of QueryException in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that throw QueryException
void | WhereParser.token(String token, QueryTranslatorImpl q)
void | WhereParser.start(QueryTranslatorImpl q)
void | WhereParser.end(QueryTranslatorImpl q)
void | SelectPathExpressionParser.end(QueryTranslatorImpl q)
protected void | SelectPathExpressionParser.setExpectingCollectionIndex()
void | SelectParser.token(String token, QueryTranslatorImpl q)
Type | SelectParser.aggregateType(List funcTokenList, Type type, QueryTranslatorImpl q)
void | QueryTranslatorImpl.compile(Map replacements, boolean scalar) Compile a "normal" query.
void | QueryTranslatorImpl.compile(String collectionRole, Map replacements, boolean scalar) Compile a filter.
int[] | QueryTranslatorImpl.getNamedParameterLocs(String name)
protected List | QueryTranslatorImpl.getResultList(List results, ResultTransformer resultTransformer)
protected String | QueryTranslatorImpl.applyLocks(String sql, Map lockModes, Dialect dialect)
void | PreprocessingParser.token(String token, QueryTranslatorImpl q)
void | PreprocessingParser.start(QueryTranslatorImpl q)
void | PreprocessingParser.end(QueryTranslatorImpl q)
void | PathExpressionParser.token(String token, QueryTranslatorImpl q)
protected Type | PathExpressionParser.getPropertyType()
protected String[] | PathExpressionParser.currentColumns()
void | PathExpressionParser.end(QueryTranslatorImpl q)
protected void | PathExpressionParser.setExpectingCollectionIndex()
String | PathExpressionParser.getWhereColumn()
String | PathExpressionParser.getCollectionSubquery(Map enabledFilters)
boolean | PathExpressionParser.isCollectionValued()
void | PathExpressionParser.addAssociation(QueryTranslatorImpl q)
String | PathExpressionParser.addFromAssociation(QueryTranslatorImpl q)
String | PathExpressionParser.addFromCollection(QueryTranslatorImpl q)
void | PathExpressionParser.fetch(QueryTranslatorImpl q, String entityName)
static void | ParserHelper.parse(Parser p, String text, String seperators, QueryTranslatorImpl q)
void | Parser.token(String token, QueryTranslatorImpl q)
void | Parser.start(QueryTranslatorImpl q)
void | Parser.end(QueryTranslatorImpl q)
void | OrderByParser.token(String token, QueryTranslatorImpl q)
void | OrderByParser.start(QueryTranslatorImpl q)
void | OrderByParser.end(QueryTranslatorImpl q)
void | GroupByParser.token(String token, QueryTranslatorImpl q)
void | GroupByParser.start(QueryTranslatorImpl q)
void | GroupByParser.end(QueryTranslatorImpl q)
void | FromPathExpressionParser.end(QueryTranslatorImpl q)
protected void | FromPathExpressionParser.setExpectingCollectionIndex()
void | FromParser.token(String token, QueryTranslatorImpl q)
void | ClauseParser.token(String token, QueryTranslatorImpl q)
void | ClauseParser.end(QueryTranslatorImpl q)

Uses of QueryException in org.hibernate.impl

Methods in org.hibernate.impl that throw QueryException
protected  void AbstractQueryImpl.verifyParameters()
Perform parameter validation.

Uses of QueryException in org.hibernate.loader

Methods in org.hibernate.loader that throw QueryException
protected  List Loader.getResultList(List results, ResultTransformer resultTransformer)

Uses of QueryException in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria that throw QueryException
protected  String CriteriaLoader.applyLocks(String sqlSelectString, Map lockModes, Dialect dialect)

Uses of QueryException in org.hibernate.loader.custom

Methods in org.hibernate.loader.custom that throw QueryException
protected List | CustomLoader.getResultList(List results, ResultTransformer resultTransformer)
int[] | CustomLoader.getNamedParameterLocs(String name)

Uses of QueryException in org.hibernate.loader.hql

Methods in org.hibernate.loader.hql that throw QueryException
protected String | QueryLoader.applyLocks(String sql, Map lockModes, Dialect dialect)
protected List | QueryLoader.getResultList(List results, ResultTransformer resultTransformer)
int[] | QueryLoader.getNamedParameterLocs(String name) Returns the locations of all occurrences of the named parameter.

Uses of QueryException in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that throw QueryException
Type | ElementPropertyMapping.toType(String propertyName)
String[] | ElementPropertyMapping.toColumns(String alias, String propertyName)
String[] | ElementPropertyMapping.toColumns(String propertyName) Given a property path, return the corresponding column name(s).
Type | CollectionPropertyMapping.toType(String propertyName)
String[] | CollectionPropertyMapping.toColumns(String alias, String propertyName)
String[] | CollectionPropertyMapping.toColumns(String propertyName) Given a property path, return the corresponding column name(s).
Type | AbstractCollectionPersister.toType(String propertyName)
String[] | AbstractCollectionPersister.toColumns(String alias, String propertyName)
String[] | AbstractCollectionPersister.toColumns(String propertyName)

Uses of QueryException in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that throw QueryException
Type | PropertyMapping.toType(String propertyName) Given a component path expression, get the type of the property
String[] | PropertyMapping.toColumns(String alias, String propertyName) Given a query alias and a property path, return the qualified column name
String[] | PropertyMapping.toColumns(String propertyName) Given a property path, return the corresponding column name(s).
String[] | JoinedSubclassEntityPersister.toColumns(String alias, String propertyName)
String[] | BasicEntityPropertyMapping.toColumns(String alias, String propertyName)
Type | AbstractPropertyMapping.toType(String propertyName)
protected void | AbstractPropertyMapping.throwPropertyException(String propertyName)
String[] | AbstractPropertyMapping.toColumns(String alias, String propertyName)
String[] | AbstractPropertyMapping.toColumns(String propertyName)
String[] | AbstractEntityPersister.toColumns(String alias, String propertyName)
String[] | AbstractEntityPersister.toColumns(String propertyName)
Type | AbstractEntityPersister.toType(String propertyName)

Uses of QueryException in org.hibernate.sql

Constructors in org.hibernate.sql that throw QueryException
ForUpdateFragment(Dialect dialect, Map lockModes, Map keyColumnNames)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.QueryParameterException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.QueryParameterException

No usage of org.hibernate.QueryParameterException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.ReplicationMode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.ReplicationMode

Packages that use ReplicationMode
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of ReplicationMode in org.hibernate

Fields in org.hibernate declared as ReplicationMode
static ReplicationMode | ReplicationMode.EXCEPTION Throw an exception when a row already exists.
static ReplicationMode | ReplicationMode.IGNORE Ignore replicated entities when a row already exists.
static ReplicationMode | ReplicationMode.OVERWRITE Overwrite existing rows when a row already exists.
static ReplicationMode | ReplicationMode.LATEST_VERSION When a row already exists, choose the latest version.

Methods in org.hibernate with parameters of type ReplicationMode
void | Session.replicate(Object object, ReplicationMode replicationMode) Persist the state of the given detached instance, reusing the current identifier value.
void | Session.replicate(String entityName, Object object, ReplicationMode replicationMode) Persist the state of the given detached instance, reusing the current identifier value.

Uses of ReplicationMode in org.hibernate.event

Methods in org.hibernate.event that return ReplicationMode
 ReplicationMode ReplicateEvent.getReplicationMode()

Methods in org.hibernate.event with parameters of type ReplicationMode
 void ReplicateEvent.setReplicationMode(ReplicationMode replicationMode)

Constructors in org.hibernate.event with parameters of type ReplicationMode
ReplicateEvent(Object object, ReplicationMode replicationMode, EventSource source)
ReplicateEvent(String entityName, Object object, ReplicationMode replicationMode, EventSource source)

Uses of ReplicationMode in org.hibernate.impl

Methods in org.hibernate.impl with parameters of type ReplicationMode
void | SessionImpl.replicate(Object obj, ReplicationMode replicationMode)
void | SessionImpl.replicate(String entityName, Object obj, ReplicationMode replicationMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.ScrollableResults (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.ScrollableResults

Packages that use ScrollableResults
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser

Uses of ScrollableResults in org.hibernate

Methods in org.hibernate that return ScrollableResults
ScrollableResults | Query.scroll() Return the query results as ScrollableResults.
ScrollableResults | Query.scroll(ScrollMode scrollMode) Return the query results as ScrollableResults.
ScrollableResults | Criteria.scroll() Get the results as an instance of ScrollableResults
ScrollableResults | Criteria.scroll(ScrollMode scrollMode) Get the results as an instance of ScrollableResults based on the given scroll mode.

Uses of ScrollableResults in org.hibernate.engine

Methods in org.hibernate.engine that return ScrollableResults
 ScrollableResults SessionImplementor.scroll(String query, QueryParameters queryParameters)
Execute a scroll() query
 ScrollableResults SessionImplementor.scroll(CriteriaImpl criteria, ScrollMode scrollMode)
Execute a criteria query
 ScrollableResults SessionImplementor.scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
Execute an SQL Query
 ScrollableResults SessionImplementor.scroll(NativeSQLQuerySpecification spec, QueryParameters queryParameters)
Execute a native SQL query, and return the results as a scrollable result.

Uses of ScrollableResults in org.hibernate.engine.query

Methods in org.hibernate.engine.query that return ScrollableResults
 ScrollableResults HQLQueryPlan.performScroll(QueryParameters queryParameters, SessionImplementor session)

Uses of ScrollableResults in org.hibernate.hql

Methods in org.hibernate.hql that return ScrollableResults
 ScrollableResults QueryTranslator.scroll(QueryParameters queryParameters, SessionImplementor session)
Perform a scroll operation given the underlying query defintion.

Uses of ScrollableResults in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that return ScrollableResults
 ScrollableResults QueryTranslatorImpl.scroll(QueryParameters queryParameters, SessionImplementor session)
Return the query results, as an instance of ScrollableResults

Uses of ScrollableResults in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that return ScrollableResults
 ScrollableResults QueryTranslatorImpl.scroll(QueryParameters queryParameters, SessionImplementor session)

Uses of ScrollableResults in org.hibernate.impl

Classes in org.hibernate.impl that implement ScrollableResults
class | AbstractScrollableResults Implementation of the ScrollableResults interface
class | FetchingScrollableResultsImpl Implementation of ScrollableResults which can handle collection fetches.
class | ScrollableResultsImpl Implementation of the ScrollableResults interface

Methods in org.hibernate.impl that return ScrollableResults
ScrollableResults | StatelessSessionImpl.scroll(CriteriaImpl criteria, ScrollMode scrollMode)
ScrollableResults | StatelessSessionImpl.scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
ScrollableResults | StatelessSessionImpl.scroll(String query, QueryParameters queryParameters)
ScrollableResults | SQLQueryImpl.scroll(ScrollMode scrollMode)
ScrollableResults | SQLQueryImpl.scroll()
ScrollableResults | SessionImpl.scroll(String query, QueryParameters queryParameters)
ScrollableResults | SessionImpl.scroll(CriteriaImpl criteria, ScrollMode scrollMode)
ScrollableResults | SessionImpl.scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
ScrollableResults | QueryImpl.scroll()
ScrollableResults | QueryImpl.scroll(ScrollMode scrollMode)
ScrollableResults | CriteriaImpl.scroll()
ScrollableResults | CriteriaImpl.scroll(ScrollMode scrollMode)
ScrollableResults | CriteriaImpl.Subcriteria.scroll()
ScrollableResults | CriteriaImpl.Subcriteria.scroll(ScrollMode scrollMode)
ScrollableResults | CollectionFilterImpl.scroll()
ScrollableResults | AbstractSessionImpl.scroll(NativeSQLQuerySpecification spec, QueryParameters queryParameters)

Uses of ScrollableResults in org.hibernate.loader

Methods in org.hibernate.loader that return ScrollableResults
protected  ScrollableResults Loader.scroll(QueryParameters queryParameters, Type[] returnTypes, HolderInstantiator holderInstantiator, SessionImplementor session)
Return the query results, as an instance of ScrollableResults

Uses of ScrollableResults in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria that return ScrollableResults
 ScrollableResults CriteriaLoader.scroll(SessionImplementor session, ScrollMode scrollMode)

Uses of ScrollableResults in org.hibernate.loader.custom

Methods in org.hibernate.loader.custom that return ScrollableResults
 ScrollableResults CustomLoader.scroll(QueryParameters queryParameters, SessionImplementor session)

Uses of ScrollableResults in org.hibernate.loader.hql

Methods in org.hibernate.loader.hql that return ScrollableResults
 ScrollableResults QueryLoader.scroll(QueryParameters queryParameters, SessionImplementor session)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.ScrollMode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.ScrollMode

Packages that use ScrollMode
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader

Uses of ScrollMode in org.hibernate

Fields in org.hibernate declared as ScrollMode
static ScrollMode | ScrollMode.FORWARD_ONLY
static ScrollMode | ScrollMode.SCROLL_SENSITIVE
static ScrollMode | ScrollMode.SCROLL_INSENSITIVE Note that since the Hibernate session acts as a cache, you might need to expicitly evict objects, if you need to see changes made by other transactions.

Methods in org.hibernate with parameters of type ScrollMode
boolean | ScrollMode.lessThan(ScrollMode other)
ScrollableResults | Query.scroll(ScrollMode scrollMode) Return the query results as ScrollableResults.
ScrollableResults | Criteria.scroll(ScrollMode scrollMode) Get the results as an instance of ScrollableResults based on the given scroll mode.

Uses of ScrollMode in org.hibernate.engine

Methods in org.hibernate.engine that return ScrollMode
 ScrollMode QueryParameters.getScrollMode()

Methods in org.hibernate.engine with parameters of type ScrollMode
ScrollableResults | SessionImplementor.scroll(CriteriaImpl criteria, ScrollMode scrollMode) Execute a criteria query
void | QueryParameters.setScrollMode(ScrollMode scrollMode)

Uses of ScrollMode in org.hibernate.impl

Methods in org.hibernate.impl with parameters of type ScrollMode
ScrollableResults | StatelessSessionImpl.scroll(CriteriaImpl criteria, ScrollMode scrollMode)
ScrollableResults | SQLQueryImpl.scroll(ScrollMode scrollMode)
ScrollableResults | SessionImpl.scroll(CriteriaImpl criteria, ScrollMode scrollMode)
ScrollableResults | QueryImpl.scroll(ScrollMode scrollMode)
ScrollableResults | CriteriaImpl.scroll(ScrollMode scrollMode)
ScrollableResults | CriteriaImpl.Subcriteria.scroll(ScrollMode scrollMode)

Uses of ScrollMode in org.hibernate.jdbc

Methods in org.hibernate.jdbc with parameters of type ScrollMode
PreparedStatement | Batcher.prepareQueryStatement(String sql, boolean scrollable, ScrollMode scrollMode) Get a prepared statement for use in loading / querying.
CallableStatement | Batcher.prepareCallableQueryStatement(String sql, boolean scrollable, ScrollMode scrollMode) Get a prepared statement for use in loading / querying.
PreparedStatement | AbstractBatcher.prepareQueryStatement(String sql, boolean scrollable, ScrollMode scrollMode)
CallableStatement | AbstractBatcher.prepareCallableQueryStatement(String sql, boolean scrollable, ScrollMode scrollMode)

Uses of ScrollMode in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria with parameters of type ScrollMode
 ScrollableResults CriteriaLoader.scroll(SessionImplementor session, ScrollMode scrollMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.Session (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.Session

Packages that use Session
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.classic | This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.
org.hibernate.context |
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of Session in org.hibernate

Methods in org.hibernate that return Session
 Session Session.getSession(EntityMode entityMode)
Starts a new Session with the given entity mode in effect.

Uses of Session in org.hibernate.classic

Subinterfaces of Session in org.hibernate.classic
 interface Session
An extension of the Session API, including all deprecated methods from Hibernate2.

Methods in org.hibernate.classic with parameters of type Session
 boolean Lifecycle.onSave(Session s)
Called when an entity is saved.
 boolean Lifecycle.onUpdate(Session s)
Called when an entity is passed to Session.update().
 boolean Lifecycle.onDelete(Session s)
Called when an entity is deleted.
 void Lifecycle.onLoad(Session s, Serializable id)
Called after an entity is loaded.

Uses of Session in org.hibernate.context

Methods in org.hibernate.context with parameters of type Session
static void ThreadLocalSessionContext.bind(Session session)
Associates the given session with the current thread of execution.

Uses of Session in org.hibernate.criterion

Methods in org.hibernate.criterion with parameters of type Session
 Criteria DetachedCriteria.getExecutableCriteria(Session session)
Get an executable instance of Criteria, to actually run the query.

Uses of Session in org.hibernate.event

Subinterfaces of Session in org.hibernate.event
 interface EventSource

Uses of Session in org.hibernate.impl

Classes in org.hibernate.impl that implement Session
 class SessionImpl
Concrete implementation of a Session, and also the central, organizing component of Hibernate's internal implementation.

Methods in org.hibernate.impl that return Session
 Session SessionImpl.getSession(EntityMode entityMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.SessionException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.SessionException

No usage of org.hibernate.SessionException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.SessionFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.SessionFactory

Packages that use SessionFactory
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.context |
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.

Uses of SessionFactory in org.hibernate

Methods in org.hibernate that return SessionFactory
 SessionFactory Session.getSessionFactory()
Get the SessionFactory that created this instance.

Uses of SessionFactory in org.hibernate.cfg

Methods in org.hibernate.cfg that return SessionFactory
 SessionFactory Configuration.buildSessionFactory()
Instantiate a new SessionFactory, using the properties and mappings in this configuration.

Uses of SessionFactory in org.hibernate.context

Fields in org.hibernate.context declared as SessionFactory
protected  SessionFactory ThreadLocalSessionContext.CleanupSynch.factory

Methods in org.hibernate.context with parameters of type SessionFactory
static Session | ThreadLocalSessionContext.unbind(SessionFactory factory) Unassociate a previously bound session from the current thread of execution.
static boolean | ManagedSessionContext.hasBind(SessionFactory factory) Check to see if there is already a session associated with the current thread for the given session factory.
static Session | ManagedSessionContext.unbind(SessionFactory factory) Unbinds the session (if one) current associated with the context for the given session.

Constructors in org.hibernate.context with parameters of type SessionFactory
ThreadLocalSessionContext.CleanupSynch(SessionFactory factory)

Uses of SessionFactory in org.hibernate.engine

Subinterfaces of SessionFactory in org.hibernate.engine
 interface SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Uses of SessionFactory in org.hibernate.impl

Classes in org.hibernate.impl that implement SessionFactory
 class SessionFactoryImpl
Concrete implementation of the SessionFactory interface.

Methods in org.hibernate.impl that return SessionFactory
 SessionFactory SessionImpl.getSessionFactory()

Methods in org.hibernate.impl with parameters of type SessionFactory
static void SessionFactoryObjectFactory.addInstance(String uid, String name, SessionFactory instance, Properties properties)

Uses of SessionFactory in org.hibernate.jmx

Classes in org.hibernate.jmx that implement SessionFactory
 class SessionFactoryStub
A flyweight for SessionFactory.

Methods in org.hibernate.jmx with parameters of type SessionFactory
 void StatisticsService.setSessionFactory(SessionFactory sf)
Useful to init this MBean wo a JNDI session factory name

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.SQLQuery (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.SQLQuery

Packages that use SQLQuery
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of SQLQuery in org.hibernate

Methods in org.hibernate that return SQLQuery
SQLQuery | StatelessSession.createSQLQuery(String queryString) Create a new instance of SQLQuery for the given SQL query string.
SQLQuery | SQLQuery.addEntity(String entityName) Declare a "root" entity, without specifying an alias
SQLQuery | SQLQuery.addEntity(String alias, String entityName) Declare a "root" entity
SQLQuery | SQLQuery.addEntity(String alias, String entityName, LockMode lockMode) Declare a "root" entity, specifying a lock mode
SQLQuery | SQLQuery.addEntity(Class entityClass) Declare a "root" entity, without specifying an alias
SQLQuery | SQLQuery.addEntity(String alias, Class entityClass) Declare a "root" entity
SQLQuery | SQLQuery.addEntity(String alias, Class entityClass, LockMode lockMode) Declare a "root" entity, specifying a lock mode
SQLQuery | SQLQuery.addJoin(String alias, String path) Declare a "joined" entity
SQLQuery | SQLQuery.addJoin(String alias, String path, LockMode lockMode) Declare a "joined" entity, specifying a lock mode
SQLQuery | SQLQuery.addScalar(String columnAlias, Type type) Declare a scalar query result
SQLQuery | SQLQuery.addScalar(String columnAlias) Declare a scalar query.
SQLQuery | SQLQuery.setResultSetMapping(String name) Use a predefined named ResultSetMapping
SQLQuery | Session.createSQLQuery(String queryString) Create a new instance of SQLQuery for the given SQL query string.

Uses of SQLQuery in org.hibernate.impl

Classes in org.hibernate.impl that implement SQLQuery
 class SQLQueryImpl
Implements SQL query passthrough.

Methods in org.hibernate.impl that return SQLQuery
SQLQuery | SQLQueryImpl.addScalar(String columnAlias, Type type)
SQLQuery | SQLQueryImpl.addScalar(String columnAlias)
SQLQuery | SQLQueryImpl.addJoin(String alias, String path)
SQLQuery | SQLQueryImpl.addEntity(Class entityClass)
SQLQuery | SQLQueryImpl.addEntity(String entityName)
SQLQuery | SQLQueryImpl.addEntity(String alias, String entityName)
SQLQuery | SQLQueryImpl.addEntity(String alias, Class entityClass)
SQLQuery | SQLQueryImpl.addJoin(String alias, String path, LockMode lockMode)
SQLQuery | SQLQueryImpl.addEntity(String alias, String entityName, LockMode lockMode)
SQLQuery | SQLQueryImpl.addEntity(String alias, Class entityClass, LockMode lockMode)
SQLQuery | SQLQueryImpl.setResultSetMapping(String name)
SQLQuery | SessionImpl.createSQLQuery(String sql)
SQLQuery | AbstractSessionImpl.createSQLQuery(String sql)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.StaleObjectStateException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.StaleObjectStateException

Packages that use StaleObjectStateException
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.lock |

Uses of StaleObjectStateException in org.hibernate.dialect

Methods in org.hibernate.dialect that throw StaleObjectStateException
 void HSQLDialect.ReadUncommittedLockingStrategy.lock(Serializable id, Object version, Object object, SessionImplementor session)

Uses of StaleObjectStateException in org.hibernate.dialect.lock

Methods in org.hibernate.dialect.lock that throw StaleObjectStateException
void | UpdateLockingStrategy.lock(Serializable id, Object version, Object object, SessionImplementor session)
void | SelectLockingStrategy.lock(Serializable id, Object version, Object object, SessionImplementor session)
void | LockingStrategy.lock(Serializable id, Object version, Object object, SessionImplementor session) Acquire an appropriate type of lock on the underlying data that will endure until the end of the current transaction.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.StaleStateException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.StaleStateException

Packages that use StaleStateException
org.hibernate This package defines the central Hibernate APIs.

Uses of StaleStateException in org.hibernate

Subclasses of StaleStateException in org.hibernate
 class StaleObjectStateException
A StaleStateException that carries information about a particular entity instance that was the source of the failure.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.StatelessSession (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.StatelessSession

Packages that use StatelessSession
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.

Uses of StatelessSession in org.hibernate

Methods in org.hibernate that return StatelessSession
StatelessSession | SessionFactory.openStatelessSession() Get a new stateless session.
StatelessSession | SessionFactory.openStatelessSession(Connection connection) Get a new stateless session for the given JDBC connection.

Uses of StatelessSession in org.hibernate.impl

Classes in org.hibernate.impl that implement StatelessSession
 class StatelessSessionImpl

Methods in org.hibernate.impl that return StatelessSession
StatelessSession | SessionFactoryImpl.openStatelessSession()
StatelessSession | SessionFactoryImpl.openStatelessSession(Connection connection)

Uses of StatelessSession in org.hibernate.jmx

Methods in org.hibernate.jmx that return StatelessSession
StatelessSession | SessionFactoryStub.openStatelessSession()
StatelessSession | SessionFactoryStub.openStatelessSession(Connection conn)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.Transaction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.Transaction

Packages that use Transaction
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.

Uses of Transaction in org.hibernate

Methods in org.hibernate that return Transaction
Transaction | StatelessSession.beginTransaction() Begin a Hibernate transaction.
Transaction | StatelessSession.getTransaction() Get the current Hibernate transaction.
Transaction | Session.beginTransaction() Begin a unit of work and return the associated Transaction object.
Transaction | Session.getTransaction() Get the Transaction instance associated with this session.

Methods in org.hibernate with parameters of type Transaction
void | Interceptor.afterTransactionBegin(Transaction tx) Called when a Hibernate transaction is begun via the Hibernate Transaction API.
void | Interceptor.beforeTransactionCompletion(Transaction tx) Called before a transaction is committed (but not before rollback).
void | Interceptor.afterTransactionCompletion(Transaction tx) Called after a transaction is committed or rolled back.
void | EmptyInterceptor.afterTransactionBegin(Transaction tx)
void | EmptyInterceptor.afterTransactionCompletion(Transaction tx)
void | EmptyInterceptor.beforeTransactionCompletion(Transaction tx)

Uses of Transaction in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type Transaction
void | SessionImplementor.afterTransactionCompletion(boolean successful, Transaction tx) Notify the session that the transaction completed, so we no longer own the old locks.
void | SessionImplementor.beforeTransactionCompletion(Transaction tx) Notify the session that the transaction is about to complete

Uses of Transaction in org.hibernate.impl

Methods in org.hibernate.impl that return Transaction
Transaction | StatelessSessionImpl.getTransaction()
Transaction | StatelessSessionImpl.beginTransaction()
Transaction | SessionImpl.getTransaction()
Transaction | SessionImpl.beginTransaction()

Methods in org.hibernate.impl with parameters of type Transaction
void | StatelessSessionImpl.afterTransactionCompletion(boolean successful, Transaction tx)
void | StatelessSessionImpl.beforeTransactionCompletion(Transaction tx)
void | StatelessSessionImpl.afterTransactionBegin(Transaction tx)
void | SessionImpl.beforeTransactionCompletion(Transaction tx)
void | SessionImpl.afterTransactionCompletion(boolean success, Transaction tx)
void | SessionImpl.afterTransactionBegin(Transaction tx)

Uses of Transaction in org.hibernate.jdbc

Methods in org.hibernate.jdbc that return Transaction
 Transaction JDBCContext.getTransaction()

Methods in org.hibernate.jdbc with parameters of type Transaction
void | JDBCContext.beforeTransactionCompletion(Transaction tx)
void | JDBCContext.afterTransactionBegin(Transaction tx) We cannot rely upon this method being called! It is only called if we are using Hibernate Transaction API.
void | JDBCContext.afterTransactionCompletion(boolean success, Transaction tx)
void | JDBCContext.Context.afterTransactionBegin(Transaction tx) We cannot rely upon this method being called! It is only called if we are using Hibernate Transaction API.
void | JDBCContext.Context.beforeTransactionCompletion(Transaction tx)
void | JDBCContext.Context.afterTransactionCompletion(boolean success, Transaction tx)

Uses of Transaction in org.hibernate.transaction

Classes in org.hibernate.transaction that implement Transaction
class | CMTTransaction Implements a basic transaction strategy for CMT transactions.
class | JDBCTransaction Implements a basic transaction strategy for JDBC connections.This is the default Transaction implementation used if none is explicitly specified.
class | JTATransaction Implements a basic transaction strategy for JTA transactions.

Methods in org.hibernate.transaction that return Transaction
Transaction | TransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context context) Begin a transaction and return the associated Transaction instance.
Transaction | JTATransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
Transaction | JDBCTransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
Transaction | CMTTransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)

Methods in org.hibernate.transaction with parameters of type Transaction
boolean | TransactionFactory.isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction) Determine whether an underlying transaction is in progress.
boolean | JTATransactionFactory.isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction)
boolean | JDBCTransactionFactory.isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction)
boolean | CMTTransactionFactory.isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction)

Constructors in org.hibernate.transaction with parameters of type Transaction
CacheSynchronization(TransactionFactory.Context ctx, JDBCContext jdbcContext, Transaction transaction, Transaction tx)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.TransactionException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.TransactionException

Packages that use TransactionException
org.hibernate.transaction This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.

Uses of TransactionException in org.hibernate.transaction

Methods in org.hibernate.transaction that throw TransactionException
boolean | JTATransaction.wasRolledBack()
boolean | JTATransaction.wasCommitted()
boolean | JTATransaction.isActive()
boolean | CMTTransaction.isActive()
boolean | CMTTransaction.wasRolledBack()
boolean | CMTTransaction.wasCommitted()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.TransientObjectException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.TransientObjectException

No usage of org.hibernate.TransientObjectException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.TypeMismatchException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.TypeMismatchException

No usage of org.hibernate.TypeMismatchException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.UnresolvableObjectException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.UnresolvableObjectException

Packages that use UnresolvableObjectException
org.hibernate This package defines the central Hibernate APIs.

Uses of UnresolvableObjectException in org.hibernate

Subclasses of UnresolvableObjectException in org.hibernate
class | ObjectDeletedException Thrown when the user tries to do something illegal with a deleted object.
class | ObjectNotFoundException Thrown when Session.load() fails to select a row with the given primary key (identifier value).

Methods in org.hibernate that throw UnresolvableObjectException
static void UnresolvableObjectException.throwIfNull(Object o, Serializable id, String clazz)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.WrongClassException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.WrongClassException

No usage of org.hibernate.WrongClassException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.classic (Hibernate API Documentation)

 org.hibernate.classic
Interfaces
Lifecycle
Session
Validatable
Exceptions
ValidationFailure


Uses of Interface org.hibernate.classic.Lifecycle (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.classic.Lifecycle

No usage of org.hibernate.classic.Lifecycle

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.classic.Session (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.classic.Session

Packages that use Session
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.context |
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.

Uses of Session in org.hibernate

Methods in org.hibernate that return Session
Session | SessionFactory.openSession(Connection connection) Open a Session on the given connection.
Session | SessionFactory.openSession(Interceptor interceptor) Create database connection and open a Session on it, specifying an interceptor.
Session | SessionFactory.openSession(Connection connection, Interceptor interceptor) Open a Session on the given connection, specifying an interceptor.
Session | SessionFactory.openSession() Create database connection and open a Session on it.
Session | SessionFactory.getCurrentSession() Obtains the current session.

Uses of Session in org.hibernate.context

Methods in org.hibernate.context that return Session
Session | ThreadLocalSessionContext.currentSession()
protected Session | ThreadLocalSessionContext.buildOrObtainSession() Strictly provided for subclassing purposes; specifically to allow long-session support.
protected Session | ThreadLocalSessionContext.wrap(Session session)
static Session | ThreadLocalSessionContext.unbind(SessionFactory factory) Unassociate a previously bound session from the current thread of execution.
Session | ManagedSessionContext.currentSession()
static Session | ManagedSessionContext.bind(Session session) Binds the given session to the current context for its session factory.
static Session | ManagedSessionContext.unbind(SessionFactory factory) Unbinds the session (if one) current associated with the context for the given session.
Session | JTASessionContext.currentSession()
protected Session | JTASessionContext.buildOrObtainSession() Strictly provided for subclassing purposes; specifically to allow long-session support.
Session | CurrentSessionContext.currentSession() Retrieve the current session according to the scoping defined by this implementation.

Methods in org.hibernate.context with parameters of type Session
protected Session | ThreadLocalSessionContext.wrap(Session session)
static Session | ManagedSessionContext.bind(Session session) Binds the given session to the current context for its session factory.

Uses of Session in org.hibernate.engine

Methods in org.hibernate.engine that return Session
Session | SessionFactoryImplementor.openTemporarySession() Get a nontransactional "current" session for Hibernate EntityManager
Session | SessionFactoryImplementor.openSession(Connection connection, boolean flushBeforeCompletionEnabled, boolean autoCloseSessionEnabled, ConnectionReleaseMode connectionReleaseMode) Open a session conforming to the given parameters.

Uses of Session in org.hibernate.impl

Classes in org.hibernate.impl that implement Session
 class SessionImpl
Concrete implementation of a Session, and also the central, organizing component of Hibernate's internal implementation.

Methods in org.hibernate.impl that return Session
Session | SessionFactoryImpl.openSession(Connection connection, Interceptor sessionLocalInterceptor)
Session | SessionFactoryImpl.openSession(Interceptor sessionLocalInterceptor)
Session | SessionFactoryImpl.openSession(Connection connection)
Session | SessionFactoryImpl.openSession()
Session | SessionFactoryImpl.openTemporarySession()
Session | SessionFactoryImpl.openSession(Connection connection, boolean flushBeforeCompletionEnabled, boolean autoCloseSessionEnabled, ConnectionReleaseMode connectionReleaseMode)
Session | SessionFactoryImpl.getCurrentSession()

Uses of Session in org.hibernate.jmx

Methods in org.hibernate.jmx that return Session
Session | SessionFactoryStub.openSession(Connection connection, Interceptor interceptor)
Session | SessionFactoryStub.openSession(Interceptor interceptor)
Session | SessionFactoryStub.openSession()
Session | SessionFactoryStub.openSession(Connection conn)
Session | SessionFactoryStub.getCurrentSession()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.classic.Validatable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.classic.Validatable

No usage of org.hibernate.classic.Validatable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.classic.ValidationFailure (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.classic.ValidationFailure

Packages that use ValidationFailure
org.hibernate.classic This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.

Uses of ValidationFailure in org.hibernate.classic

Methods in org.hibernate.classic that throw ValidationFailure
 void Validatable.validate()
Validate the state of the object before persisting it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.collection (Hibernate API Documentation)

 org.hibernate.collection
Interfaces
AbstractPersistentCollection.DelayedOperation
PersistentCollection
Classes
AbstractPersistentCollection
PersistentArrayHolder
PersistentBag
PersistentElementHolder
PersistentIdentifierBag
PersistentIndexedElementHolder
PersistentIndexedElementHolder.IndexedValue
PersistentList
PersistentListElementHolder
PersistentMap
PersistentMapElementHolder
PersistentSet
PersistentSortedMap
PersistentSortedSet


Uses of Class org.hibernate.collection.AbstractPersistentCollection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.AbstractPersistentCollection

Packages that use AbstractPersistentCollection
org.hibernate.collection This package defines a framework for collection wrappers.

Uses of AbstractPersistentCollection in org.hibernate.collection

Subclasses of AbstractPersistentCollection in org.hibernate.collection
class | PersistentArrayHolder A persistent wrapper for an array.
class | PersistentBag An unordered, unkeyed collection that can contain the same element multiple times.
class | PersistentElementHolder A persistent wrapper for an XML element
class | PersistentIdentifierBag An IdentifierBag implements "bag" semantics more efficiently than a regular Bag by adding a synthetic identifier column to the table.
class | PersistentIndexedElementHolder A persistent wrapper for an XML element
class | PersistentList A persistent wrapper for a java.util.List.
class | PersistentListElementHolder
class | PersistentMap A persistent wrapper for a java.util.Map.
class | PersistentMapElementHolder
class | PersistentSet A persistent wrapper for a java.util.Set.
class | PersistentSortedMap A persistent wrapper for a java.util.SortedMap.
class | PersistentSortedSet A persistent wrapper for a java.util.SortedSet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.collection.AbstractPersistentCollection.DelayedOperation (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.collection.AbstractPersistentCollection.DelayedOperation

No usage of org.hibernate.collection.AbstractPersistentCollection.DelayedOperation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentArrayHolder (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentArrayHolder

No usage of org.hibernate.collection.PersistentArrayHolder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentBag (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentBag

No usage of org.hibernate.collection.PersistentBag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.collection.PersistentCollection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.collection.PersistentCollection

Packages that use PersistentCollection
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.usertype | Interfaces for user-defined custom types.

Uses of PersistentCollection in org.hibernate.action

Methods in org.hibernate.action that return PersistentCollection
protected  PersistentCollection CollectionAction.getCollection()

Constructors in org.hibernate.action with parameters of type PersistentCollection
CollectionUpdateAction(PersistentCollection collection, CollectionPersister persister, Serializable id, boolean emptySnapshot, SessionImplementor session)
CollectionRemoveAction(PersistentCollection collection, CollectionPersister persister, Serializable id, boolean emptySnapshot, SessionImplementor session)
CollectionRecreateAction(PersistentCollection collection, CollectionPersister persister, Serializable id, SessionImplementor session)
CollectionAction(CollectionPersister persister, PersistentCollection collection, Serializable key, SessionImplementor session)

Uses of PersistentCollection in org.hibernate.cache.entry

Methods in org.hibernate.cache.entry with parameters of type PersistentCollection
 void CollectionCacheEntry.assemble(PersistentCollection collection, CollectionPersister persister, Object owner)

Constructors in org.hibernate.cache.entry with parameters of type PersistentCollection
CollectionCacheEntry(PersistentCollection collection, CollectionPersister persister)

Uses of PersistentCollection in org.hibernate.collection

Classes in org.hibernate.collection that implement PersistentCollection
class | AbstractPersistentCollection Base class implementing PersistentCollection
class | PersistentArrayHolder A persistent wrapper for an array.
class | PersistentBag An unordered, unkeyed collection that can contain the same element multiple times.
class | PersistentElementHolder A persistent wrapper for an XML element
class | PersistentIdentifierBag An IdentifierBag implements "bag" semantics more efficiently than a regular Bag by adding a synthetic identifier column to the table.
class | PersistentIndexedElementHolder A persistent wrapper for an XML element
class | PersistentList A persistent wrapper for a java.util.List.
class | PersistentListElementHolder
class | PersistentMap A persistent wrapper for a java.util.Map.
class | PersistentMapElementHolder
class | PersistentSet A persistent wrapper for a java.util.Set.
class | PersistentSortedMap A persistent wrapper for a java.util.SortedMap.
class | PersistentSortedSet A persistent wrapper for a java.util.SortedSet.

Uses of PersistentCollection in org.hibernate.engine

Methods in org.hibernate.engine that return PersistentCollection
PersistentCollection | StatefulPersistenceContext.useUnownedCollection(CollectionKey key)
PersistentCollection | StatefulPersistenceContext.getCollection(CollectionKey collectionKey) Get the collection instance associated with the CollectionKey
PersistentCollection | StatefulPersistenceContext.getCollectionHolder(Object array) Get the PersistentCollection object for an array
PersistentCollection | StatefulPersistenceContext.removeCollectionHolder(Object array)
PersistentCollection | PersistenceContext.useUnownedCollection(CollectionKey key) Get and remove a collection whose owner is not yet loaded, when its owner is being loaded
PersistentCollection | PersistenceContext.getCollection(CollectionKey collectionKey) Get the collection instance associated with the CollectionKey
PersistentCollection | PersistenceContext.getCollectionHolder(Object array) Get the PersistentCollection object for an array
PersistentCollection | PersistenceContext.removeCollectionHolder(Object array) Remove the mapping of collection to holder during eviction of the owning entity
PersistentCollection | CollectionLoadContext.getLoadingCollection(CollectionPersister persister, Serializable key, Object resultSetId, EntityMode em) Retrieve a collection that is in the process of being loaded, instantiating a new collection if there is nothing for the given id, or returning null if the collection with the given id is already fully loaded in the session
PersistentCollection | CollectionLoadContext.getLoadingCollection(CollectionPersister persister, Serializable id, EntityMode em) Retrieve a collection that is in the process of being loaded, returning null if there is no loading collection with the given id

Methods in org.hibernate.engine with parameters of type PersistentCollection
 void StatefulPersistenceContext.addUnownedCollection(CollectionKey key, PersistentCollection collection)
 CollectionEntry StatefulPersistenceContext.getCollectionEntry(PersistentCollection coll)
Get the collection entry for a persistent collection
 boolean StatefulPersistenceContext.containsCollection(PersistentCollection collection)
 void StatefulPersistenceContext.addUninitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just loaded up (still needs initializing)
 void StatefulPersistenceContext.addUninitializedDetachedCollection(CollectionPersister persister, PersistentCollection collection)
add a detached uninitialized collection
 void StatefulPersistenceContext.addNewCollection(CollectionPersister persister, PersistentCollection collection)
Add a new collection (ie.
 void StatefulPersistenceContext.addInitializedDetachedCollection(CollectionPersister collectionPersister, PersistentCollection collection)
add an (initialized) collection that was created by another session and passed into update() (ie.
 CollectionEntry StatefulPersistenceContext.addInitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just pulled out of the cache (does not need initializing)
 void StatefulPersistenceContext.addNonLazyCollection(PersistentCollection collection)
Register a collection for non-lazy loading at the end of the two-phase load
 void StatefulPersistenceContext.addCollectionHolder(PersistentCollection holder)
Register a PersistentCollection object for an array.
 Serializable StatefulPersistenceContext.getSnapshot(PersistentCollection coll)
Get the snapshot of the pre-flush collection state
 void SessionImplementor.initializeCollection(PersistentCollection collection, boolean writing)
Initialize the collection (if not already initialized)
 void PersistenceContext.addUnownedCollection(CollectionKey key, PersistentCollection collection)
Add a collection which has no owner loaded
 CollectionEntry PersistenceContext.getCollectionEntry(PersistentCollection coll)
Get the collection entry for a persistent collection
 boolean PersistenceContext.containsCollection(PersistentCollection collection)
Is the given collection associated with this persistence context?
 void PersistenceContext.addUninitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just loaded up (still needs initializing)
 void PersistenceContext.addUninitializedDetachedCollection(CollectionPersister persister, PersistentCollection collection)
add a detached uninitialized collection
 void PersistenceContext.addNewCollection(CollectionPersister persister, PersistentCollection collection)
Add a new collection (ie.
 void PersistenceContext.addInitializedDetachedCollection(CollectionPersister collectionPersister, PersistentCollection collection)
add an (initialized) collection that was created by another session and passed into update() (ie.
 CollectionEntry PersistenceContext.addInitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just pulled out of the cache (does not need initializing)
 void PersistenceContext.addNonLazyCollection(PersistentCollection collection)
Register a collection for non-lazy loading at the end of the two-phase load
 void PersistenceContext.addCollectionHolder(PersistentCollection holder)
Register a PersistentCollection object for an array.
 Serializable PersistenceContext.getSnapshot(PersistentCollection coll)
Get the snapshot of the pre-flush collection state
static void Collections.processUnreachableCollection(PersistentCollection coll, SessionImplementor session)
record the fact that this collection was dereferenced
static void Collections.processReachableCollection(PersistentCollection collection, CollectionType type, Object entity, SessionImplementor session)
Initialize the role of the collection.
 void CollectionEntry.preFlush(PersistentCollection collection)
 void CollectionEntry.postInitialize(PersistentCollection collection)
 void CollectionEntry.postFlush(PersistentCollection collection)
Called after a successful flush
 void CollectionEntry.afterAction(PersistentCollection collection)
Called after execution of an action
 Collection CollectionEntry.getOrphans(String entityName, PersistentCollection collection)
Get the collection orphans (entities which were removed from the collection)
 boolean CollectionEntry.isSnapshotEmpty(PersistentCollection collection)

Constructors in org.hibernate.engine with parameters of type PersistentCollection
CollectionEntry(CollectionPersister persister, PersistentCollection collection)
For newly wrapped collections, or dereferenced collection wrappers
CollectionEntry(PersistentCollection collection, CollectionPersister loadedPersister, Serializable loadedKey, boolean ignore)
For collections just loaded from the database

Uses of PersistentCollection in org.hibernate.event

Methods in org.hibernate.event that return PersistentCollection
 PersistentCollection InitializeCollectionEvent.getCollection()

Constructors in org.hibernate.event with parameters of type PersistentCollection
InitializeCollectionEvent(PersistentCollection collection, EventSource source)

Uses of PersistentCollection in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type PersistentCollection
protected static boolean | ProxyVisitor.isOwnerUnchanged(PersistentCollection snapshot, CollectionPersister persister, Serializable id) Has the owner of the collection changed since the collection was snapshotted and detached?
protected void | ProxyVisitor.reattachCollection(PersistentCollection collection, CollectionType type) Reattach a detached (disassociated) initialized or uninitialized collection wrapper, using a snapshot carried with the collection wrapper

Uses of PersistentCollection in org.hibernate.impl

Methods in org.hibernate.impl with parameters of type PersistentCollection
void | StatelessSessionImpl.initializeCollection(PersistentCollection collection, boolean writing)
void | SessionImpl.initializeCollection(PersistentCollection collection, boolean writing)

Uses of PersistentCollection in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection with parameters of type PersistentCollection
protected int | OneToManyPersister.doUpdateRows(Serializable id, PersistentCollection collection, SessionImplementor session)
void | CollectionPersister.recreate(PersistentCollection collection, Serializable key, SessionImplementor session) (Re)create the collection's persistent state
void | CollectionPersister.deleteRows(PersistentCollection collection, Serializable key, SessionImplementor session) Delete the persistent state of any elements that were removed from the collection
void | CollectionPersister.updateRows(PersistentCollection collection, Serializable key, SessionImplementor session) Update the persistent state of any elements that were modified
void | CollectionPersister.insertRows(PersistentCollection collection, Serializable key, SessionImplementor session) Insert the persistent state of any new collection elements
protected int | BasicCollectionPersister.doUpdateRows(Serializable id, PersistentCollection collection, SessionImplementor session)
void | AbstractCollectionPersister.recreate(PersistentCollection collection, Serializable id, SessionImplementor session)
void | AbstractCollectionPersister.deleteRows(PersistentCollection collection, Serializable id, SessionImplementor session)
void | AbstractCollectionPersister.insertRows(PersistentCollection collection, Serializable id, SessionImplementor session)
void | AbstractCollectionPersister.updateRows(PersistentCollection collection, Serializable id, SessionImplementor session)
protected abstract int | AbstractCollectionPersister.doUpdateRows(Serializable key, PersistentCollection collection, SessionImplementor session)

Uses of PersistentCollection in org.hibernate.type

Methods in org.hibernate.type that return PersistentCollection
PersistentCollection | SortedSetType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | SortedSetType.wrap(SessionImplementor session, Object collection)
PersistentCollection | SortedMapType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | SortedMapType.wrap(SessionImplementor session, Object collection)
PersistentCollection | SetType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | SetType.wrap(SessionImplementor session, Object collection)
PersistentCollection | MapType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | MapType.wrap(SessionImplementor session, Object collection)
PersistentCollection | ListType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | ListType.wrap(SessionImplementor session, Object collection)
PersistentCollection | IdentifierBagType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | IdentifierBagType.wrap(SessionImplementor session, Object collection)
PersistentCollection | CustomCollectionType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | CustomCollectionType.wrap(SessionImplementor session, Object collection)
abstract PersistentCollection | CollectionType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key) Instantiate an uninitialized collection wrapper or holder.
abstract PersistentCollection | CollectionType.wrap(SessionImplementor session, Object collection) Wrap the naked collection instance in a wrapper, or instantiate a holder.
PersistentCollection | BagType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | BagType.wrap(SessionImplementor session, Object collection)
PersistentCollection | ArrayType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | ArrayType.wrap(SessionImplementor session, Object array)

Uses of PersistentCollection in org.hibernate.usertype

Methods in org.hibernate.usertype that return PersistentCollection
PersistentCollection | UserCollectionType.instantiate(SessionImplementor session, CollectionPersister persister) Instantiate an uninitialized instance of the collection wrapper
PersistentCollection | UserCollectionType.wrap(SessionImplementor session, Object collection) Wrap an instance of a collection

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentElementHolder (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentElementHolder

No usage of org.hibernate.collection.PersistentElementHolder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentIdentifierBag (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentIdentifierBag

No usage of org.hibernate.collection.PersistentIdentifierBag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentIndexedElementHolder (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentIndexedElementHolder

Packages that use PersistentIndexedElementHolder
org.hibernate.collection This package defines a framework for collection wrappers.

Uses of PersistentIndexedElementHolder in org.hibernate.collection

Subclasses of PersistentIndexedElementHolder in org.hibernate.collection
class | PersistentListElementHolder
class | PersistentMapElementHolder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentIndexedElementHolder.IndexedValue (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentIndexedElementHolder.IndexedValue

No usage of org.hibernate.collection.PersistentIndexedElementHolder.IndexedValue

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentList (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentList

No usage of org.hibernate.collection.PersistentList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentListElementHolder (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentListElementHolder

No usage of org.hibernate.collection.PersistentListElementHolder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentMap (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentMap

Packages that use PersistentMap
org.hibernate.collection This package defines a framework for collection wrappers.

Uses of PersistentMap in org.hibernate.collection

Subclasses of PersistentMap in org.hibernate.collection
 class PersistentSortedMap
A persistent wrapper for a java.util.SortedMap.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentMapElementHolder (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentMapElementHolder

No usage of org.hibernate.collection.PersistentMapElementHolder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentSet (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentSet

Packages that use PersistentSet
org.hibernate.collection This package defines a framework for collection wrappers.

Uses of PersistentSet in org.hibernate.collection

Subclasses of PersistentSet in org.hibernate.collection
 class PersistentSortedSet
A persistent wrapper for a java.util.SortedSet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentSortedMap (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentSortedMap

No usage of org.hibernate.collection.PersistentSortedMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.collection.PersistentSortedSet (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.collection.PersistentSortedSet

No usage of org.hibernate.collection.PersistentSortedSet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.connection (Hibernate API Documentation)

 org.hibernate.connection
Interfaces
ConnectionProvider
Classes
C3P0ConnectionProvider
ConnectionProviderFactory
DatasourceConnectionProvider
DriverManagerConnectionProvider
ProxoolConnectionProvider
UserSuppliedConnectionProvider


Uses of Class org.hibernate.connection.C3P0ConnectionProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.connection.C3P0ConnectionProvider

No usage of org.hibernate.connection.C3P0ConnectionProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.connection.ConnectionProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.connection.ConnectionProvider

Packages that use ConnectionProvider
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.connection | This package abstracts the mechanism for obtaining a JDBC connection.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of ConnectionProvider in org.hibernate.cfg

Methods in org.hibernate.cfg that return ConnectionProvider
protected ConnectionProvider | SettingsFactory.createConnectionProvider(Properties properties)
ConnectionProvider | Settings.getConnectionProvider()

Uses of ConnectionProvider in org.hibernate.connection

Classes in org.hibernate.connection that implement ConnectionProvider
class | C3P0ConnectionProvider A connection provider that uses a C3P0 connection pool.
class | DatasourceConnectionProvider A connection provider that uses a DataSource registered with JNDI.
class | DriverManagerConnectionProvider A connection provider that uses java.sql.DriverManager.
class | ProxoolConnectionProvider A connection provider that uses a Proxool connection pool.
class | UserSuppliedConnectionProvider An implementation of the ConnectionProvider interface that simply throws an exception when a connection is requested.

Methods in org.hibernate.connection that return ConnectionProvider
static ConnectionProvider | ConnectionProviderFactory.newConnectionProvider() Instantiate a ConnectionProvider using System properties.
static ConnectionProvider | ConnectionProviderFactory.newConnectionProvider(Properties properties) Instantiate a ConnectionProvider using given properties.
static ConnectionProvider | ConnectionProviderFactory.newConnectionProvider(Properties properties, Map connectionProviderInjectionData) Instantiate a ConnectionProvider using given properties.

Uses of ConnectionProvider in org.hibernate.engine

Methods in org.hibernate.engine that return ConnectionProvider
 ConnectionProvider SessionFactoryImplementor.getConnectionProvider()
Get the connection provider

Uses of ConnectionProvider in org.hibernate.impl

Methods in org.hibernate.impl that return ConnectionProvider
 ConnectionProvider SessionFactoryImpl.getConnectionProvider()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.connection.ConnectionProviderFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.connection.ConnectionProviderFactory

No usage of org.hibernate.connection.ConnectionProviderFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.connection.DatasourceConnectionProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.connection.DatasourceConnectionProvider

No usage of org.hibernate.connection.DatasourceConnectionProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.connection.DriverManagerConnectionProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.connection.DriverManagerConnectionProvider

No usage of org.hibernate.connection.DriverManagerConnectionProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.connection.ProxoolConnectionProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.connection.ProxoolConnectionProvider

No usage of org.hibernate.connection.ProxoolConnectionProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.connection.UserSuppliedConnectionProvider (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.connection.UserSuppliedConnectionProvider

No usage of org.hibernate.connection.UserSuppliedConnectionProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.context (Hibernate API Documentation)

 org.hibernate.context
Interfaces
CurrentSessionContext
Classes
JTASessionContext
JTASessionContext.CleanupSynch
ManagedSessionContext
ThreadLocalSessionContext
ThreadLocalSessionContext.CleanupSynch


Uses of Interface org.hibernate.context.CurrentSessionContext (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.context.CurrentSessionContext

Packages that use CurrentSessionContext
org.hibernate.context

Uses of CurrentSessionContext in org.hibernate.context

Classes in org.hibernate.context that implement CurrentSessionContext
class | JTASessionContext An implementation of CurrentSessionContext which scopes the notion of a current session to a JTA transaction.
class | ManagedSessionContext Represents a CurrentSessionContext the notion of a contextual session is managed by some external entity (generally some form of interceptor, etc).
class | ThreadLocalSessionContext A CurrentSessionContext impl which scopes the notion of current session by the current thread of execution.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.context.JTASessionContext (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.context.JTASessionContext

Packages that use JTASessionContext
org.hibernate.context

Uses of JTASessionContext in org.hibernate.context

Constructors in org.hibernate.context with parameters of type JTASessionContext
JTASessionContext.CleanupSynch(Transaction txn, JTASessionContext context)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.context.JTASessionContext.CleanupSynch (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.context.JTASessionContext.CleanupSynch

No usage of org.hibernate.context.JTASessionContext.CleanupSynch

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.context.ManagedSessionContext (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.context.ManagedSessionContext

No usage of org.hibernate.context.ManagedSessionContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.context.ThreadLocalSessionContext (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.context.ThreadLocalSessionContext

No usage of org.hibernate.context.ThreadLocalSessionContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.context.ThreadLocalSessionContext.CleanupSynch (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.context.ThreadLocalSessionContext.CleanupSynch

Packages that use ThreadLocalSessionContext.CleanupSynch
org.hibernate.context

Uses of ThreadLocalSessionContext.CleanupSynch in org.hibernate.context

Methods in org.hibernate.context that return ThreadLocalSessionContext.CleanupSynch
protected  ThreadLocalSessionContext.CleanupSynch ThreadLocalSessionContext.buildCleanupSynch()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.criterion (Hibernate API Documentation)

 org.hibernate.criterion
Interfaces
CriteriaQuery
CriteriaSpecification
Criterion
Example.PropertySelector
Projection
Classes
AbstractEmptinessExpression
AggregateProjection
AliasedProjection
AvgProjection
BetweenExpression
Conjunction
CountProjection
DetachedCriteria
Disjunction
Distinct
EmptyExpression
Example
ExistsSubqueryExpression
Expression
IdentifierEqExpression
IdentifierProjection
IlikeExpression
InExpression
Junction
LikeExpression
LogicalExpression
MatchMode
NaturalIdentifier
NotEmptyExpression
NotExpression
NotNullExpression
NullExpression
Order
ProjectionList
Projections
Property
PropertyExpression
PropertyProjection
PropertySubqueryExpression
Restrictions
RowCountProjection
SimpleExpression
SimpleProjection
SimpleSubqueryExpression
SizeExpression
SQLCriterion
SQLProjection
Subqueries
SubqueryExpression


Uses of Class org.hibernate.criterion.AbstractEmptinessExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.AbstractEmptinessExpression

Packages that use AbstractEmptinessExpression
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of AbstractEmptinessExpression in org.hibernate.criterion

Subclasses of AbstractEmptinessExpression in org.hibernate.criterion
class | EmptyExpression
class | NotEmptyExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.AggregateProjection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.AggregateProjection

Packages that use AggregateProjection
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of AggregateProjection in org.hibernate.criterion

Subclasses of AggregateProjection in org.hibernate.criterion
class | AvgProjection
class | CountProjection A count

Methods in org.hibernate.criterion that return AggregateProjection
AggregateProjection | Property.max()
AggregateProjection | Property.min()
AggregateProjection | Property.avg()
static AggregateProjection | Projections.max(String propertyName) A property maximum value
static AggregateProjection | Projections.min(String propertyName) A property minimum value
static AggregateProjection | Projections.avg(String propertyName) A property average value
static AggregateProjection | Projections.sum(String propertyName) A property value sum

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.AliasedProjection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.AliasedProjection

No usage of org.hibernate.criterion.AliasedProjection

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.AvgProjection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.AvgProjection

No usage of org.hibernate.criterion.AvgProjection

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.BetweenExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.BetweenExpression

No usage of org.hibernate.criterion.BetweenExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.Conjunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.Conjunction

Packages that use Conjunction
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of Conjunction in org.hibernate.criterion

Methods in org.hibernate.criterion that return Conjunction
static Conjunction Restrictions.conjunction()
Group expressions together in a single conjunction (A and B and C...)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.CountProjection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.CountProjection

Packages that use CountProjection
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of CountProjection in org.hibernate.criterion

Methods in org.hibernate.criterion that return CountProjection
CountProjection | Property.count()
static CountProjection | Projections.count(String propertyName) A property value count
static CountProjection | Projections.countDistinct(String propertyName) A distinct property value count
CountProjection | CountProjection.setDistinct()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.criterion.CriteriaQuery (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.criterion.CriteriaQuery

Packages that use CriteriaQuery
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader

Uses of CriteriaQuery in org.hibernate.criterion

Methods in org.hibernate.criterion with parameters of type CriteriaQuery
protected abstract String | SubqueryExpression.toLeftSqlString(Criteria criteria, CriteriaQuery outerQuery)
String | SubqueryExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SubqueryExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | SQLProjection.toSqlString(Criteria criteria, int loc, CriteriaQuery criteriaQuery)
String | SQLProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | SQLProjection.getTypes(Criteria crit, CriteriaQuery criteriaQuery)
Type[] | SQLProjection.getTypes(String alias, Criteria crit, CriteriaQuery criteriaQuery)
String | SQLCriterion.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SQLCriterion.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | SizeExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SizeExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SimpleSubqueryExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
protected String | SimpleSubqueryExpression.toLeftSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | SimpleProjection.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
String | SimpleProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | SimpleExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SimpleExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | RowCountProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | RowCountProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
protected String | PropertySubqueryExpression.toLeftSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | PropertyProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | PropertyProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | PropertyProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | PropertyExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | PropertyExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | ProjectionList.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | ProjectionList.toSqlString(Criteria criteria, int loc, CriteriaQuery criteriaQuery)
String | ProjectionList.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | ProjectionList.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
String | Projection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery) Render the SQL fragment
String | Projection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment to be used in the group by clause
Type[] | Projection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
Type[] | Projection.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery) Return types for a particular user-visible alias
String | Order.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
String | NullExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NullExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | NotNullExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NotNullExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | NotExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NotExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NaturalIdentifier.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | NaturalIdentifier.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | LogicalExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | LogicalExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | LikeExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | LikeExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | Junction.getTypedValues(Criteria crit, CriteriaQuery criteriaQuery)
String | Junction.toSqlString(Criteria crit, CriteriaQuery criteriaQuery)
String | InExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | InExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
String | IlikeExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | IlikeExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | IdentifierProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | IdentifierProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | IdentifierProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
String | IdentifierEqExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | IdentifierEqExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
protected String | ExistsSubqueryExpression.toLeftSqlString(Criteria criteria, CriteriaQuery outerQuery)
String | Example.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | Example.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
protected void | Example.addComponentTypedValues(String path, Object component, AbstractComponentType type, List list, Criteria criteria, CriteriaQuery criteriaQuery)
protected void | Example.appendPropertyCondition(String propertyName, Object propertyValue, Criteria criteria, CriteriaQuery cq, StringBuffer buf)
protected void | Example.appendComponentCondition(String path, Object component, AbstractComponentType type, Criteria criteria, CriteriaQuery criteriaQuery, StringBuffer buf)
String | Distinct.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | Distinct.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | Distinct.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | Distinct.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
String | Criterion.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery) Render the SQL fragment
TypedValue[] | Criterion.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
Type[] | CountProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | CountProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | BetweenExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | BetweenExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AvgProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | AliasedProjection.toSqlString(Criteria criteria, int position, CriteriaQuery criteriaQuery)
String | AliasedProjection.toGroupSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AliasedProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AliasedProjection.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AggregateProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
String | AggregateProjection.toSqlString(Criteria criteria, int loc, CriteriaQuery criteriaQuery)
String | AbstractEmptinessExpression.toSqlString(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | AbstractEmptinessExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)

Uses of CriteriaQuery in org.hibernate.loader.criteria

Classes in org.hibernate.loader.criteria that implement CriteriaQuery
 class CriteriaQueryTranslator

Constructors in org.hibernate.loader.criteria with parameters of type CriteriaQuery
CriteriaQueryTranslator(SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, String rootSQLAlias, CriteriaQuery outerQuery)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.criterion.CriteriaSpecification (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.criterion.CriteriaSpecification

Packages that use CriteriaSpecification
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of CriteriaSpecification in org.hibernate

Subinterfaces of CriteriaSpecification in org.hibernate
 interface Criteria
Criteria is a simplified API for retrieving entities by composing Criterion objects.

Uses of CriteriaSpecification in org.hibernate.criterion

Classes in org.hibernate.criterion that implement CriteriaSpecification
 class DetachedCriteria
Some applications need to create criteria queries in "detached mode", where the Hibernate session is not available.

Uses of CriteriaSpecification in org.hibernate.impl

Classes in org.hibernate.impl that implement CriteriaSpecification
class | CriteriaImpl Implementation of the Criteria interface
class | CriteriaImpl.Subcriteria

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.criterion.Criterion (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.criterion.Criterion

Packages that use Criterion
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of Criterion in org.hibernate

Methods in org.hibernate with parameters of type Criterion
 Criteria Criteria.add(Criterion criterion)
Add a restriction to constrain the results to be retrieved.

Uses of Criterion in org.hibernate.criterion

Classes in org.hibernate.criterion that implement Criterion
class | AbstractEmptinessExpression Implementation of AbstractEmptinessExpression.
class | BetweenExpression Constrains a property to between two values
class | Conjunction
class | Disjunction
class | EmptyExpression
class | Example Support for query by example.
class | ExistsSubqueryExpression
class | IdentifierEqExpression An identifier constraint
class | IlikeExpression A case-insensitive "like"
class | InExpression Constrains the property to a specified list of values
class | Junction A sequence of a logical expressions combined by some associative logical operator
class | LikeExpression A criterion representing a "like" expression
class | LogicalExpression Superclass of binary logical expressions
class | NaturalIdentifier
class | NotEmptyExpression
class | NotExpression Negates another criterion
class | NotNullExpression Constrains a property to be non-null
class | NullExpression Constrains a property to be null
class | PropertyExpression superclass for comparisons between two properties (with SQL binary operators)
class | PropertySubqueryExpression A comparison between a property value in the outer query and the result of a subquery
class | SimpleExpression superclass for "simple" comparisons (with SQL binary operators)
class | SimpleSubqueryExpression A comparison between a constant value and the the result of a subquery
class | SizeExpression
class | SQLCriterion A SQL fragment.
class | SubqueryExpression

Methods in org.hibernate.criterion that return Criterion
static Criterion | Subqueries.exists(DetachedCriteria dc)
static Criterion | Subqueries.notExists(DetachedCriteria dc)
static Criterion | Subqueries.propertyEqAll(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyIn(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyNotIn(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyEq(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyNe(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyGt(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyLt(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyGe(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyLe(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyGtAll(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyLtAll(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyGeAll(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyLeAll(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyGtSome(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyLtSome(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyGeSome(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyLeSome(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.eqAll(Object value, DetachedCriteria dc)
static Criterion | Subqueries.in(Object value, DetachedCriteria dc)
static Criterion | Subqueries.notIn(Object value, DetachedCriteria dc)
static Criterion | Subqueries.eq(Object value, DetachedCriteria dc)
static Criterion | Subqueries.gt(Object value, DetachedCriteria dc)
static Criterion | Subqueries.lt(Object value, DetachedCriteria dc)
static Criterion | Subqueries.ge(Object value, DetachedCriteria dc)
static Criterion | Subqueries.le(Object value, DetachedCriteria dc)
static Criterion | Subqueries.ne(Object value, DetachedCriteria dc)
static Criterion | Subqueries.gtAll(Object value, DetachedCriteria dc)
static Criterion | Subqueries.ltAll(Object value, DetachedCriteria dc)
static Criterion | Subqueries.geAll(Object value, DetachedCriteria dc)
static Criterion | Subqueries.leAll(Object value, DetachedCriteria dc)
static Criterion | Subqueries.gtSome(Object value, DetachedCriteria dc)
static Criterion | Subqueries.ltSome(Object value, DetachedCriteria dc)
static Criterion | Subqueries.geSome(Object value, DetachedCriteria dc)
static Criterion | Subqueries.leSome(Object value, DetachedCriteria dc)
static Criterion | Restrictions.idEq(Object value) Apply an "equal" constraint to the identifier property
static Criterion | Restrictions.ilike(String propertyName, String value, MatchMode matchMode) A case-insensitive "like", similar to Postgres ilike operator
static Criterion | Restrictions.ilike(String propertyName, Object value) A case-insensitive "like", similar to Postgres ilike operator
static Criterion | Restrictions.between(String propertyName, Object lo, Object hi) Apply a "between" constraint to the named property
static Criterion | Restrictions.in(String propertyName, Object[] values) Apply an "in" constraint to the named property
static Criterion | Restrictions.in(String propertyName, Collection values) Apply an "in" constraint to the named property
static Criterion | Restrictions.isNull(String propertyName) Apply an "is null" constraint to the named property
static Criterion | Restrictions.isNotNull(String propertyName) Apply an "is not null" constraint to the named property
static Criterion | Restrictions.not(Criterion expression) Return the negation of an expression
static Criterion | Restrictions.sqlRestriction(String sql, Object[] values, Type[] types) Apply a constraint expressed in SQL, with the given JDBC parameters.
static Criterion | Restrictions.sqlRestriction(String sql, Object value, Type type) Apply a constraint expressed in SQL, with the given JDBC parameter.
static Criterion | Restrictions.sqlRestriction(String sql) Apply a constraint expressed in SQL.
static Criterion | Restrictions.allEq(Map propertyNameValues) Apply an "equals" constraint to each property in the key set of a Map
static Criterion | Restrictions.isEmpty(String propertyName) Constrain a collection valued property to be empty
static Criterion | Restrictions.isNotEmpty(String propertyName) Constrain a collection valued property to be non-empty
static Criterion | Restrictions.sizeEq(String propertyName, int size) Constrain a collection valued property by size
static Criterion | Restrictions.sizeNe(String propertyName, int size) Constrain a collection valued property by size
static Criterion | Restrictions.sizeGt(String propertyName, int size) Constrain a collection valued property by size
static Criterion | Restrictions.sizeLt(String propertyName, int size) Constrain a collection valued property by size
static Criterion | Restrictions.sizeGe(String propertyName, int size) Constrain a collection valued property by size
static Criterion | Restrictions.sizeLe(String propertyName, int size) Constrain a collection valued property by size
Criterion | Property.between(Object min, Object max)
Criterion | Property.in(Collection values)
Criterion | Property.in(Object[] values)
Criterion | Property.isNull()
Criterion | Property.isNotNull()
Criterion | Property.isEmpty()
Criterion | Property.isNotEmpty()
Criterion | Property.eq(DetachedCriteria subselect)
Criterion | Property.ne(DetachedCriteria subselect)
Criterion | Property.lt(DetachedCriteria subselect)
Criterion | Property.le(DetachedCriteria subselect)
Criterion | Property.gt(DetachedCriteria subselect)
Criterion | Property.ge(DetachedCriteria subselect)
Criterion | Property.notIn(DetachedCriteria subselect)
Criterion | Property.in(DetachedCriteria subselect)
Criterion | Property.eqAll(DetachedCriteria subselect)
Criterion | Property.gtAll(DetachedCriteria subselect)
Criterion | Property.ltAll(DetachedCriteria subselect)
Criterion | Property.leAll(DetachedCriteria subselect)
Criterion | Property.geAll(DetachedCriteria subselect)
Criterion | Property.gtSome(DetachedCriteria subselect)
Criterion | Property.ltSome(DetachedCriteria subselect)
Criterion | Property.leSome(DetachedCriteria subselect)
Criterion | Property.geSome(DetachedCriteria subselect)
static Criterion | Expression.sql(String sql, Object[] values, Type[] types) Apply a constraint expressed in SQL, with the given JDBC parameters.
static Criterion | Expression.sql(String sql, Object value, Type type) Apply a constraint expressed in SQL, with the given JDBC parameter.
static Criterion | Expression.sql(String sql) Apply a constraint expressed in SQL.

Methods in org.hibernate.criterion with parameters of type Criterion
static LogicalExpression | Restrictions.and(Criterion lhs, Criterion rhs) Return the conjuction of two expressions
static LogicalExpression | Restrictions.or(Criterion lhs, Criterion rhs) Return the disjuction of two expressions
static Criterion | Restrictions.not(Criterion expression) Return the negation of an expression
Junction | Junction.add(Criterion criterion)
DetachedCriteria | DetachedCriteria.add(Criterion criterion)

Constructors in org.hibernate.criterion with parameters of type Criterion
NotExpression(Criterion criterion)
LogicalExpression(Criterion lhs, Criterion rhs, String op)

Uses of Criterion in org.hibernate.impl

Methods in org.hibernate.impl that return Criterion
 Criterion CriteriaImpl.CriterionEntry.getCriterion()

Methods in org.hibernate.impl with parameters of type Criterion
Criteria | CriteriaImpl.add(Criteria criteriaInst, Criterion expression)
Criteria | CriteriaImpl.add(Criterion expression)
Criteria | CriteriaImpl.Subcriteria.add(Criterion expression)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.DetachedCriteria (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.DetachedCriteria

Packages that use DetachedCriteria
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of DetachedCriteria in org.hibernate.criterion

Methods in org.hibernate.criterion that return DetachedCriteria
static DetachedCriteria | DetachedCriteria.forEntityName(String entityName)
static DetachedCriteria | DetachedCriteria.forEntityName(String entityName, String alias)
static DetachedCriteria | DetachedCriteria.forClass(Class clazz)
static DetachedCriteria | DetachedCriteria.forClass(Class clazz, String alias)
DetachedCriteria | DetachedCriteria.add(Criterion criterion)
DetachedCriteria | DetachedCriteria.addOrder(Order order)
DetachedCriteria | DetachedCriteria.createAlias(String associationPath, String alias)
DetachedCriteria | DetachedCriteria.createCriteria(String associationPath, String alias)
DetachedCriteria | DetachedCriteria.createCriteria(String associationPath)
DetachedCriteria | DetachedCriteria.setFetchMode(String associationPath, FetchMode mode)
DetachedCriteria | DetachedCriteria.setProjection(Projection projection)
DetachedCriteria | DetachedCriteria.setResultTransformer(ResultTransformer resultTransformer)

Methods in org.hibernate.criterion with parameters of type DetachedCriteria
static Criterion | Subqueries.exists(DetachedCriteria dc)
static Criterion | Subqueries.notExists(DetachedCriteria dc)
static Criterion | Subqueries.propertyEqAll(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyIn(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyNotIn(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyEq(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyNe(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyGt(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyLt(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyGe(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyLe(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyGtAll(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyLtAll(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyGeAll(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyLeAll(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyGtSome(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyLtSome(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyGeSome(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.propertyLeSome(String propertyName, DetachedCriteria dc)
static Criterion | Subqueries.eqAll(Object value, DetachedCriteria dc)
static Criterion | Subqueries.in(Object value, DetachedCriteria dc)
static Criterion | Subqueries.notIn(Object value, DetachedCriteria dc)
static Criterion | Subqueries.eq(Object value, DetachedCriteria dc)
static Criterion | Subqueries.gt(Object value, DetachedCriteria dc)
static Criterion | Subqueries.lt(Object value, DetachedCriteria dc)
static Criterion | Subqueries.ge(Object value, DetachedCriteria dc)
static Criterion | Subqueries.le(Object value, DetachedCriteria dc)
static Criterion | Subqueries.ne(Object value, DetachedCriteria dc)
static Criterion | Subqueries.gtAll(Object value, DetachedCriteria dc)
static Criterion | Subqueries.ltAll(Object value, DetachedCriteria dc)
static Criterion | Subqueries.geAll(Object value, DetachedCriteria dc)
static Criterion | Subqueries.leAll(Object value, DetachedCriteria dc)
static Criterion | Subqueries.gtSome(Object value, DetachedCriteria dc)
static Criterion | Subqueries.ltSome(Object value, DetachedCriteria dc)
static Criterion | Subqueries.geSome(Object value, DetachedCriteria dc)
static Criterion | Subqueries.leSome(Object value, DetachedCriteria dc)
Criterion | Property.eq(DetachedCriteria subselect)
Criterion | Property.ne(DetachedCriteria subselect)
Criterion | Property.lt(DetachedCriteria subselect)
Criterion | Property.le(DetachedCriteria subselect)
Criterion | Property.gt(DetachedCriteria subselect)
Criterion | Property.ge(DetachedCriteria subselect)
Criterion | Property.notIn(DetachedCriteria subselect)
Criterion | Property.in(DetachedCriteria subselect)
Criterion | Property.eqAll(DetachedCriteria subselect)
Criterion | Property.gtAll(DetachedCriteria subselect)
Criterion | Property.ltAll(DetachedCriteria subselect)
Criterion | Property.leAll(DetachedCriteria subselect)
Criterion | Property.geAll(DetachedCriteria subselect)
Criterion | Property.gtSome(DetachedCriteria subselect)
Criterion | Property.ltSome(DetachedCriteria subselect)
Criterion | Property.leSome(DetachedCriteria subselect)
Criterion | Property.geSome(DetachedCriteria subselect)

Constructors in org.hibernate.criterion with parameters of type DetachedCriteria
SubqueryExpression(String op, String quantifier, DetachedCriteria dc)
SimpleSubqueryExpression(Object value, String op, String quantifier, DetachedCriteria dc)
PropertySubqueryExpression(String propertyName, String op, String quantifier, DetachedCriteria dc)
ExistsSubqueryExpression(String quantifier, DetachedCriteria dc)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.Disjunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.Disjunction

Packages that use Disjunction
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of Disjunction in org.hibernate.criterion

Methods in org.hibernate.criterion that return Disjunction
static Disjunction Restrictions.disjunction()
Group expressions together in a single disjunction (A or B or C...)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.Distinct (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.Distinct

No usage of org.hibernate.criterion.Distinct

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.EmptyExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.EmptyExpression

No usage of org.hibernate.criterion.EmptyExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.Example (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.Example

Packages that use Example
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of Example in org.hibernate.criterion

Methods in org.hibernate.criterion that return Example
Example | Example.setEscapeCharacter(Character escapeCharacter) Set escape character for "like" clause
Example | Example.setPropertySelector(Example.PropertySelector selector) Set the property selector
Example | Example.excludeZeroes() Exclude zero-valued properties
Example | Example.excludeNone() Don't exclude null or zero-valued properties
Example | Example.enableLike(MatchMode matchMode) Use the "like" operator for all string-valued properties
Example | Example.enableLike() Use the "like" operator for all string-valued properties
Example | Example.ignoreCase() Ignore case for all string-valued properties
Example | Example.excludeProperty(String name) Exclude a particular named property
static Example | Example.create(Object entity) Create a new instance, which includes all non-null properties by default

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.criterion.Example.PropertySelector (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.criterion.Example.PropertySelector

Packages that use Example.PropertySelector
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of Example.PropertySelector in org.hibernate.criterion

Methods in org.hibernate.criterion with parameters of type Example.PropertySelector
 Example Example.setPropertySelector(Example.PropertySelector selector)
Set the property selector

Constructors in org.hibernate.criterion with parameters of type Example.PropertySelector
Example(Object entity, Example.PropertySelector selector)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.ExistsSubqueryExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.ExistsSubqueryExpression

No usage of org.hibernate.criterion.ExistsSubqueryExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.Expression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.Expression

No usage of org.hibernate.criterion.Expression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.IdentifierEqExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.IdentifierEqExpression

No usage of org.hibernate.criterion.IdentifierEqExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.IdentifierProjection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.IdentifierProjection

Packages that use IdentifierProjection
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of IdentifierProjection in org.hibernate.criterion

Methods in org.hibernate.criterion that return IdentifierProjection
static IdentifierProjection Projections.id()
A projected identifier value

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.IlikeExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.IlikeExpression

No usage of org.hibernate.criterion.IlikeExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.InExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.InExpression

No usage of org.hibernate.criterion.InExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.Junction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.Junction

Packages that use Junction
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of Junction in org.hibernate.criterion

Subclasses of Junction in org.hibernate.criterion
class | Conjunction
class | Disjunction

Methods in org.hibernate.criterion that return Junction
 Junction Junction.add(Criterion criterion)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.LikeExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.LikeExpression

No usage of org.hibernate.criterion.LikeExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.LogicalExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.LogicalExpression

Packages that use LogicalExpression
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of LogicalExpression in org.hibernate.criterion

Methods in org.hibernate.criterion that return LogicalExpression
static LogicalExpression | Restrictions.and(Criterion lhs, Criterion rhs) Return the conjuction of two expressions
static LogicalExpression | Restrictions.or(Criterion lhs, Criterion rhs) Return the disjuction of two expressions

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.MatchMode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.MatchMode

Packages that use MatchMode
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of MatchMode in org.hibernate.criterion

Fields in org.hibernate.criterion declared as MatchMode
static MatchMode | MatchMode.EXACT Match the entire string to the pattern
static MatchMode | MatchMode.START Match the start of the string to the pattern
static MatchMode | MatchMode.END Match the end of the string to the pattern
static MatchMode | MatchMode.ANYWHERE Match the pattern anywhere in the string

Methods in org.hibernate.criterion with parameters of type MatchMode
static SimpleExpression | Restrictions.like(String propertyName, String value, MatchMode matchMode) Apply a "like" constraint to the named property
static Criterion | Restrictions.ilike(String propertyName, String value, MatchMode matchMode) A case-insensitive "like", similar to Postgres ilike operator
SimpleExpression | Property.like(String value, MatchMode matchMode)
Example | Example.enableLike(MatchMode matchMode) Use the "like" operator for all string-valued properties

Constructors in org.hibernate.criterion with parameters of type MatchMode
LikeExpression(String propertyName, String value, MatchMode matchMode)
LikeExpression(String propertyName, String value, MatchMode matchMode, Character escapeChar, boolean ignoreCase)
IlikeExpression(String propertyName, String value, MatchMode matchMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.NaturalIdentifier (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.NaturalIdentifier

Packages that use NaturalIdentifier
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of NaturalIdentifier in org.hibernate.criterion

Methods in org.hibernate.criterion that return NaturalIdentifier
static NaturalIdentifier | Restrictions.naturalId()
NaturalIdentifier | NaturalIdentifier.set(String property, Object value)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.NotEmptyExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.NotEmptyExpression

No usage of org.hibernate.criterion.NotEmptyExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.NotExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.NotExpression

No usage of org.hibernate.criterion.NotExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.NotNullExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.NotNullExpression

No usage of org.hibernate.criterion.NotNullExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.NullExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.NullExpression

No usage of org.hibernate.criterion.NullExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.Order (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.Order

Packages that use Order
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of Order in org.hibernate

Methods in org.hibernate with parameters of type Order
 Criteria Criteria.addOrder(Order order)
Add an ordering to the result set.

Uses of Order in org.hibernate.criterion

Methods in org.hibernate.criterion that return Order
Order | Property.asc()
Order | Property.desc()
Order | Order.ignoreCase()
static Order | Order.asc(String propertyName) Ascending order
static Order | Order.desc(String propertyName) Descending order

Methods in org.hibernate.criterion with parameters of type Order
 DetachedCriteria DetachedCriteria.addOrder(Order order)

Uses of Order in org.hibernate.impl

Methods in org.hibernate.impl that return Order
 Order CriteriaImpl.OrderEntry.getOrder()

Methods in org.hibernate.impl with parameters of type Order
Criteria | CriteriaImpl.addOrder(Order ordering)
Criteria | CriteriaImpl.Subcriteria.addOrder(Order order)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.criterion.Projection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.criterion.Projection

Packages that use Projection
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of Projection in org.hibernate

Methods in org.hibernate with parameters of type Projection
 Criteria Criteria.setProjection(Projection projection)
Used to specify that the query results will be a projection (scalar in nature).

Uses of Projection in org.hibernate.criterion

Classes in org.hibernate.criterion that implement Projection
class | AggregateProjection An aggregation
class | AliasedProjection
class | AvgProjection
class | CountProjection A count
class | Distinct
class | IdentifierProjection A property value, or grouped property value
class | ProjectionList
class | Property A factory for property-specific criterion and projection instances
class | PropertyProjection A property value, or grouped property value
class | RowCountProjection A row count
class | SimpleProjection A single-column projection that may be aliased
class | SQLProjection A SQL fragment.

Methods in org.hibernate.criterion that return Projection
Projection | SimpleProjection.as(String alias)
static Projection | Projections.distinct(Projection proj) Create a distinct projection from a projection
static Projection | Projections.rowCount() The query row count, ie.
static Projection | Projections.sqlProjection(String sql, String[] columnAliases, Type[] types) A SQL projection, a typed select clause fragment
static Projection | Projections.sqlGroupProjection(String sql, String groupBy, String[] columnAliases, Type[] types) A grouping SQL projection, specifying both select clause and group by clause fragments
static Projection | Projections.alias(Projection projection, String alias) Assign an alias to a projection, by wrapping it
Projection | ProjectionList.getProjection(int i)

Methods in org.hibernate.criterion with parameters of type Projection
static Projection | Projections.distinct(Projection proj) Create a distinct projection from a projection
static Projection | Projections.alias(Projection projection, String alias) Assign an alias to a projection, by wrapping it
ProjectionList | ProjectionList.add(Projection proj)
ProjectionList | ProjectionList.add(Projection projection, String alias)
DetachedCriteria | DetachedCriteria.setProjection(Projection projection)

Constructors in org.hibernate.criterion with parameters of type Projection
Distinct(Projection proj)
AliasedProjection(Projection projection, String alias)

Uses of Projection in org.hibernate.impl

Methods in org.hibernate.impl that return Projection
 Projection CriteriaImpl.getProjection()

Methods in org.hibernate.impl with parameters of type Projection
Criteria | CriteriaImpl.setProjection(Projection projection)
Criteria | CriteriaImpl.Subcriteria.setProjection(Projection projection)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.ProjectionList (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.ProjectionList

Packages that use ProjectionList
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of ProjectionList in org.hibernate.criterion

Methods in org.hibernate.criterion that return ProjectionList
static ProjectionList | Projections.projectionList() Create a new projection list
ProjectionList | ProjectionList.create()
ProjectionList | ProjectionList.add(Projection proj)
ProjectionList | ProjectionList.add(Projection projection, String alias)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.Projections (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.Projections

No usage of org.hibernate.criterion.Projections

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.Property (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.Property

Packages that use Property
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of Property in org.hibernate.criterion

Methods in org.hibernate.criterion that return Property
static Property | Property.forName(String propertyName)
Property | Property.getProperty(String propertyName) Get a component attribute of this property

Methods in org.hibernate.criterion with parameters of type Property
PropertyExpression | Property.eqProperty(Property other)
PropertyExpression | Property.neProperty(Property other)
PropertyExpression | Property.leProperty(Property other)
PropertyExpression | Property.geProperty(Property other)
PropertyExpression | Property.ltProperty(Property other)
PropertyExpression | Property.gtProperty(Property other)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.PropertyExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.PropertyExpression

Packages that use PropertyExpression
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of PropertyExpression in org.hibernate.criterion

Methods in org.hibernate.criterion that return PropertyExpression
static PropertyExpression | Restrictions.eqProperty(String propertyName, String otherPropertyName) Apply an "equal" constraint to two properties
static PropertyExpression | Restrictions.neProperty(String propertyName, String otherPropertyName) Apply a "not equal" constraint to two properties
static PropertyExpression | Restrictions.ltProperty(String propertyName, String otherPropertyName) Apply a "less than" constraint to two properties
static PropertyExpression | Restrictions.leProperty(String propertyName, String otherPropertyName) Apply a "less than or equal" constraint to two properties
static PropertyExpression | Restrictions.gtProperty(String propertyName, String otherPropertyName) Apply a "greater than" constraint to two properties
static PropertyExpression | Restrictions.geProperty(String propertyName, String otherPropertyName) Apply a "greater than or equal" constraint to two properties
PropertyExpression | Property.eqProperty(Property other)
PropertyExpression | Property.neProperty(Property other)
PropertyExpression | Property.leProperty(Property other)
PropertyExpression | Property.geProperty(Property other)
PropertyExpression | Property.ltProperty(Property other)
PropertyExpression | Property.gtProperty(Property other)
PropertyExpression | Property.eqProperty(String other)
PropertyExpression | Property.neProperty(String other)
PropertyExpression | Property.leProperty(String other)
PropertyExpression | Property.geProperty(String other)
PropertyExpression | Property.ltProperty(String other)
PropertyExpression | Property.gtProperty(String other)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.PropertyProjection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.PropertyProjection

Packages that use PropertyProjection
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of PropertyProjection in org.hibernate.criterion

Subclasses of PropertyProjection in org.hibernate.criterion
 class Property
A factory for property-specific criterion and projection instances

Methods in org.hibernate.criterion that return PropertyProjection
PropertyProjection | Property.group()
static PropertyProjection | Projections.groupProperty(String propertyName) A grouping property value
static PropertyProjection | Projections.property(String propertyName) A projected property value

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.PropertySubqueryExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.PropertySubqueryExpression

No usage of org.hibernate.criterion.PropertySubqueryExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.Restrictions (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.Restrictions

Packages that use Restrictions
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of Restrictions in org.hibernate.criterion

Subclasses of Restrictions in org.hibernate.criterion
 class Expression
This class is semi-deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.RowCountProjection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.RowCountProjection

No usage of org.hibernate.criterion.RowCountProjection

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.SimpleExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.SimpleExpression

Packages that use SimpleExpression
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of SimpleExpression in org.hibernate.criterion

Methods in org.hibernate.criterion that return SimpleExpression
SimpleExpression | SimpleExpression.ignoreCase()
static SimpleExpression | Restrictions.eq(String propertyName, Object value) Apply an "equal" constraint to the named property
static SimpleExpression | Restrictions.ne(String propertyName, Object value) Apply a "not equal" constraint to the named property
static SimpleExpression | Restrictions.like(String propertyName, Object value) Apply a "like" constraint to the named property
static SimpleExpression | Restrictions.like(String propertyName, String value, MatchMode matchMode) Apply a "like" constraint to the named property
static SimpleExpression | Restrictions.gt(String propertyName, Object value) Apply a "greater than" constraint to the named property
static SimpleExpression | Restrictions.lt(String propertyName, Object value) Apply a "less than" constraint to the named property
static SimpleExpression | Restrictions.le(String propertyName, Object value) Apply a "less than or equal" constraint to the named property
static SimpleExpression | Restrictions.ge(String propertyName, Object value) Apply a "greater than or equal" constraint to the named property
SimpleExpression | Property.like(Object value)
SimpleExpression | Property.like(String value, MatchMode matchMode)
SimpleExpression | Property.eq(Object value)
SimpleExpression | Property.ne(Object value)
SimpleExpression | Property.gt(Object value)
SimpleExpression | Property.lt(Object value)
SimpleExpression | Property.le(Object value)
SimpleExpression | Property.ge(Object value)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.SimpleProjection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.SimpleProjection

Packages that use SimpleProjection
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of SimpleProjection in org.hibernate.criterion

Subclasses of SimpleProjection in org.hibernate.criterion
class | AggregateProjection An aggregation
class | AvgProjection
class | CountProjection A count
class | IdentifierProjection A property value, or grouped property value
class | Property A factory for property-specific criterion and projection instances
class | PropertyProjection A property value, or grouped property value
class | RowCountProjection A row count

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.SimpleSubqueryExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.SimpleSubqueryExpression

No usage of org.hibernate.criterion.SimpleSubqueryExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.SizeExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.SizeExpression

No usage of org.hibernate.criterion.SizeExpression

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.SQLCriterion (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.SQLCriterion

No usage of org.hibernate.criterion.SQLCriterion

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.SQLProjection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.SQLProjection

No usage of org.hibernate.criterion.SQLProjection

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.Subqueries (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.Subqueries

No usage of org.hibernate.criterion.Subqueries

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.criterion.SubqueryExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.criterion.SubqueryExpression

Packages that use SubqueryExpression
org.hibernate.criterion A framework for defining restriction criteria and order criteria.

Uses of SubqueryExpression in org.hibernate.criterion

Subclasses of SubqueryExpression in org.hibernate.criterion
class | ExistsSubqueryExpression
class | PropertySubqueryExpression A comparison between a property value in the outer query and the result of a subquery
class | SimpleSubqueryExpression A comparison between a constant value and the the result of a subquery

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.dialect (Hibernate API Documentation)

 org.hibernate.dialect
Interfaces
DialectFactory.DatabaseDialectMapper
Classes
DataDirectOracle9Dialect
DB2390Dialect
DB2400Dialect
DB2Dialect
DerbyDialect
DerbyDialect.DerbyTrimFunctionEmulation
Dialect
DialectFactory
DialectFactory.VersionInsensitiveMapper
FirebirdDialect
FrontBaseDialect
H2Dialect
HSQLDialect
HSQLDialect.ReadUncommittedLockingStrategy
InformixDialect
IngresDialect
InterbaseDialect
JDataStoreDialect
MckoiDialect
MimerSQLDialect
MySQL5Dialect
MySQL5InnoDBDialect
MySQLDialect
MySQLInnoDBDialect
MySQLMyISAMDialect
Oracle9Dialect
OracleDialect
PointbaseDialect
PostgreSQLDialect
ProgressDialect
RDMSOS2200Dialect
SAPDBDialect
SQLServerDialect
Sybase11Dialect
SybaseAnywhereDialect
SybaseDialect
TimesTenDialect
TypeNames


Uses of Class org.hibernate.dialect.DataDirectOracle9Dialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.DataDirectOracle9Dialect

No usage of org.hibernate.dialect.DataDirectOracle9Dialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.DB2Dialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.DB2Dialect

Packages that use DB2Dialect
org.hibernate.dialect This package abstracts the SQL dialect of the underlying database.

Uses of DB2Dialect in org.hibernate.dialect

Subclasses of DB2Dialect in org.hibernate.dialect
class | DB2390Dialect An SQL dialect for DB2/390.
class | DB2400Dialect An SQL dialect for DB2/400
class | DerbyDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.DB2390Dialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.DB2390Dialect

No usage of org.hibernate.dialect.DB2390Dialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.DB2400Dialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.DB2400Dialect

No usage of org.hibernate.dialect.DB2400Dialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.DerbyDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.DerbyDialect

No usage of org.hibernate.dialect.DerbyDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.DerbyDialect.DerbyTrimFunctionEmulation (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.DerbyDialect.DerbyTrimFunctionEmulation

No usage of org.hibernate.dialect.DerbyDialect.DerbyTrimFunctionEmulation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.Dialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.Dialect

Packages that use Dialect
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function | A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.exception | This package is a fork of Apache commons-lang nestable exceptions.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.id.insert |
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.
org.hibernate.tool.hbm2ddl | The hbm2ddl tool.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.util | Utility classes.

Uses of Dialect in org.hibernate.cfg

Methods in org.hibernate.cfg that return Dialect
 Dialect Settings.getDialect()

Methods in org.hibernate.cfg with parameters of type Dialect
String[] | Configuration.generateDropSchemaScript(Dialect dialect) Generate DDL for dropping tables
String[] | Configuration.generateSchemaCreationScript(Dialect dialect) Generate DDL for creating tables
String[] | Configuration.generateSchemaUpdateScript(Dialect dialect, DatabaseMetadata databaseMetadata) Generate DDL for altering tables
void | Configuration.validateSchema(Dialect dialect, DatabaseMetadata databaseMetadata)

Uses of Dialect in org.hibernate.dialect

Subclasses of Dialect in org.hibernate.dialect
class | DataDirectOracle9Dialect
class | DB2390Dialect An SQL dialect for DB2/390.
class | DB2400Dialect An SQL dialect for DB2/400
class | DB2Dialect An SQL dialect for DB2.
class | DerbyDialect
class | FirebirdDialect An SQL dialect for Firebird.
class | FrontBaseDialect An SQL Dialect for Frontbase.
class | H2Dialect A dialect compatible with the H2 database.
class | HSQLDialect An SQL dialect compatible with HSQLDB (Hypersonic SQL).
class | InformixDialect Informix dialect. Seems to work with Informix Dynamic Server Version 7.31.UD3, Informix JDBC driver version 2.21JC3.
class | IngresDialect An Ingres SQL dialect
class | InterbaseDialect An SQL dialect for Interbase.
class | JDataStoreDialect A Dialect for JDataStore.
class | MckoiDialect An SQL dialect compatible with McKoi SQL
class | MimerSQLDialect An Hibernate 3 SQL dialect for Mimer SQL.
class | MySQL5Dialect An SQL dialect for MySQL 5.x specific features.
class | MySQL5InnoDBDialect
class | MySQLDialect An SQL dialect for MySQL (prior to 5.x).
class | MySQLInnoDBDialect
class | MySQLMyISAMDialect
class | Oracle9Dialect An SQL dialect for Oracle 9 (uses ANSI-style syntax where possible).
class | OracleDialect An SQL dialect for Oracle, compatible with Oracle 8.
class | PointbaseDialect A Dialect for Pointbase.
class | PostgreSQLDialect An SQL dialect for Postgres
class | ProgressDialect An SQL dialect compatible with Progress 9.1C Connection Parameters required: hibernate.dialect org.hibernate.sql.ProgressDialect hibernate.driver com.progress.sql.jdbc.JdbcProgressDriver hibernate.url jdbc:JdbcProgress:T:host:port:dbname;WorkArounds=536870912 hibernate.username username hibernate.password password The WorkArounds parameter in the URL is required to avoid an error in the Progress 9.1C JDBC driver related to PreparedStatements.
class | RDMSOS2200Dialect
class | SAPDBDialect An SQL dialect compatible with SAP DB.
class | SQLServerDialect A dialect for Microsoft SQL Server 2000
class | Sybase11Dialect A SQL dialect suitable for use with Sybase 11.9.2 (specifically: avoids ANSI JOIN syntax)
class | SybaseAnywhereDialect SQL Dialect for Sybase Anywhere extending Sybase (Enterprise) Dialect (Tested on ASA 8.x)
class | SybaseDialect An SQL dialect compatible with Sybase and MS SQL Server.
class | TimesTenDialect A SQL dialect for TimesTen 5.1.

Methods in org.hibernate.dialect that return Dialect
static Dialect | DialectFactory.buildDialect(Properties props, String databaseName, int databaseMajorVersion) Builds an appropriate Dialect instance.
static Dialect | DialectFactory.determineDialect(String databaseName, int databaseMajorVersion) Determine the appropriate Dialect to use given the database product name and major version.
static Dialect | DialectFactory.buildDialect(String dialectName) Returns a dialect instance given the name of the class to use.
static Dialect | Dialect.getDialect() Get the Dialect specified by the current System properties.
static Dialect | Dialect.getDialect(Properties props) Get the Dialect specified by the given properties or system properties.

Uses of Dialect in org.hibernate.dialect.function

Constructors in org.hibernate.dialect.function with parameters of type Dialect
SQLFunctionRegistry(Dialect dialect, Map userFunctions)

Uses of Dialect in org.hibernate.engine

Methods in org.hibernate.engine that return Dialect
 Dialect SessionFactoryImplementor.getDialect()
Get the SQL Dialect

Uses of Dialect in org.hibernate.exception

Methods in org.hibernate.exception with parameters of type Dialect
static SQLExceptionConverter SQLExceptionConverterFactory.buildSQLExceptionConverter(Dialect dialect, Properties properties)
Build a SQLExceptionConverter instance.

Uses of Dialect in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic with parameters of type Dialect
protected  String QueryTranslatorImpl.applyLocks(String sql, Map lockModes, Dialect dialect)

Uses of Dialect in org.hibernate.id

Methods in org.hibernate.id with parameters of type Dialect
void | UUIDHexGenerator.configure(Type type, Properties params, Dialect d)
void | TableHiLoGenerator.configure(Type type, Properties params, Dialect d)
void | TableGenerator.configure(Type type, Properties params, Dialect dialect)
String[] | TableGenerator.sqlCreateStrings(Dialect dialect)
String[] | TableGenerator.sqlDropStrings(Dialect dialect)
InsertGeneratedIdentifierDelegate | SequenceIdentityGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
void | SequenceIdentityGenerator.configure(Type type, Properties params, Dialect dialect)
void | SequenceHiLoGenerator.configure(Type type, Properties params, Dialect d)
void | SequenceGenerator.configure(Type type, Properties params, Dialect dialect)
String[] | SequenceGenerator.sqlCreateStrings(Dialect dialect)
String[] | SequenceGenerator.sqlDropStrings(Dialect dialect)
void | SelectGenerator.configure(Type type, Properties params, Dialect d)
InsertGeneratedIdentifierDelegate | SelectGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
InsertGeneratedIdentifierDelegate | PostInsertIdentifierGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
String[] | PersistentIdentifierGenerator.sqlCreateStrings(Dialect dialect) The SQL required to create the underlying database objects.
String[] | PersistentIdentifierGenerator.sqlDropStrings(Dialect dialect) The SQL required to remove the underlying database objects.
String[] | MultipleHiLoPerTableGenerator.sqlCreateStrings(Dialect dialect)
String[] | MultipleHiLoPerTableGenerator.sqlDropStrings(Dialect dialect)
void | MultipleHiLoPerTableGenerator.configure(Type type, Properties params, Dialect dialect)
void | IncrementGenerator.configure(Type type, Properties params, Dialect dialect)
InsertGeneratedIdentifierDelegate | IdentityGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
static IdentifierGenerator | IdentifierGeneratorFactory.create(String strategy, Type type, Properties params, Dialect dialect)
static Class | IdentifierGeneratorFactory.getIdentifierGeneratorClass(String strategy, Dialect dialect)
void | ForeignGenerator.configure(Type type, Properties params, Dialect d)
void | Configurable.configure(Type type, Properties params, Dialect d) Configure this instance, given the value of parameters specified by the user as <param> elements.
void | Assigned.configure(Type type, Properties params, Dialect d)

Constructors in org.hibernate.id with parameters of type Dialect
SequenceIdentityGenerator.Delegate(PostInsertIdentityPersister persister, Dialect dialect, String sequenceName)
SequenceIdentityGenerator.NoCommentsInsert(Dialect dialect)
IdentityGenerator.GetGeneratedKeysDelegate(PostInsertIdentityPersister persister, Dialect dialect)
IdentityGenerator.InsertSelectDelegate(PostInsertIdentityPersister persister, Dialect dialect)
IdentityGenerator.BasicDelegate(PostInsertIdentityPersister persister, Dialect dialect)

Uses of Dialect in org.hibernate.id.insert

Constructors in org.hibernate.id.insert with parameters of type Dialect
InsertSelectIdentityInsert(Dialect dialect)
IdentifierGeneratingInsert(Dialect dialect)

Uses of Dialect in org.hibernate.impl

Methods in org.hibernate.impl that return Dialect
 Dialect SessionFactoryImpl.getDialect()

Uses of Dialect in org.hibernate.jdbc

Methods in org.hibernate.jdbc with parameters of type Dialect
ResultSet | Batcher.getResultSet(CallableStatement ps, Dialect dialect) Execute the statement and return the result set from a callable statement
ResultSet | AbstractBatcher.getResultSet(CallableStatement ps, Dialect dialect)

Uses of Dialect in org.hibernate.loader

Methods in org.hibernate.loader that return Dialect
protected Dialect | OuterJoinLoader.getDialect()
protected Dialect | JoinWalker.getDialect()

Methods in org.hibernate.loader with parameters of type Dialect
protected String | Loader.applyLocks(String sql, Map lockModes, Dialect dialect) Append FOR UPDATE OF clause, if necessary.
protected String | Loader.preprocessSQL(String sql, QueryParameters parameters, Dialect dialect) Modify the SQL, adding lock hints and comments, if necessary

Uses of Dialect in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria with parameters of type Dialect
protected  String CriteriaLoader.applyLocks(String sqlSelectString, Map lockModes, Dialect dialect)

Uses of Dialect in org.hibernate.loader.hql

Methods in org.hibernate.loader.hql with parameters of type Dialect
protected  String QueryLoader.applyLocks(String sql, Map lockModes, Dialect dialect)

Uses of Dialect in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type Dialect
String | UniqueKey.sqlConstraintString(Dialect dialect)
String | UniqueKey.sqlConstraintString(Dialect dialect, String constraintName, String defaultCatalog, String defaultSchema)
String | UniqueKey.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
String | UniqueKey.sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
String | Table.getQualifiedName(Dialect dialect, String defaultCatalog, String defaultSchema)
String | Table.getQuotedName(Dialect dialect)
String | Table.getQuotedSchema(Dialect dialect)
void | Table.validateColumns(Dialect dialect, Mapping mapping, TableMetadata tableInfo)
Iterator | Table.sqlAlterStrings(Dialect dialect, Mapping p, TableMetadata tableInfo, String defaultCatalog, String defaultSchema)
String | Table.sqlTemporaryTableCreateString(Dialect dialect, Mapping mapping)
String | Table.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
String | Table.sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
Iterator | Table.sqlCommentStrings(Dialect dialect, String defaultCatalog, String defaultSchema)
IdentifierGenerator | SimpleValue.createIdentifierGenerator(Dialect dialect, String defaultCatalog, String defaultSchema, RootClass rootClass)
boolean | SimpleValue.isIdentityColumn(Dialect dialect)
String | SimpleAuxiliaryDatabaseObject.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
String | SimpleAuxiliaryDatabaseObject.sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
String | Selectable.getAlias(Dialect dialect)
String | Selectable.getAlias(Dialect dialect, Table table)
String | Selectable.getTemplate(Dialect dialect, SQLFunctionRegistry functionRegistry)
String | Selectable.getText(Dialect dialect)
String | RelationalModel.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
String | RelationalModel.sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
String | PrimaryKey.sqlConstraintString(Dialect dialect)
String | PrimaryKey.sqlConstraintString(Dialect dialect, String constraintName, String defaultCatalog, String defaultSchema)
void | PersistentClass.prepareTemporaryTables(Mapping mapping, Dialect dialect)
boolean | KeyValue.isIdentityColumn(Dialect dialect)
IdentifierGenerator | KeyValue.createIdentifierGenerator(Dialect dialect, String defaultCatalog, String defaultSchema, RootClass rootClass)
String | Index.sqlCreateString(Dialect dialect, Mapping mapping, String defaultCatalog, String defaultSchema)
static String | Index.buildSqlDropIndexString(Dialect dialect, Table table, String name, String defaultCatalog, String defaultSchema)
static String | Index.buildSqlCreateIndexString(Dialect dialect, String name, Table table, Iterator columns, boolean unique, String defaultCatalog, String defaultSchema)
String | Index.sqlConstraintString(Dialect dialect)
String | Index.sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
String | Formula.getTemplate(Dialect dialect, SQLFunctionRegistry functionRegistry)
String | Formula.getText(Dialect dialect)
String | Formula.getAlias(Dialect dialect)
String | Formula.getAlias(Dialect dialect, Table table)
String | ForeignKey.sqlConstraintString(Dialect dialect, String constraintName, String defaultCatalog, String defaultSchema)
String | ForeignKey.sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
String | Constraint.sqlDropString(Dialect dialect, String defaultCatalog, String defaultSchema)
String | Constraint.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
abstract String | Constraint.sqlConstraintString(Dialect d, String constraintName, String defaultCatalog, String defaultSchema)
String | Column.getQuotedName(Dialect d)
String | Column.getAlias(Dialect dialect) For any column name, generate an alias that is unique to that column name, and also 10 characters or less in length.
String | Column.getAlias(Dialect dialect, Table table) Generate a column alias that is unique across multiple tables
String | Column.getSqlType(Dialect dialect, Mapping mapping)
String | Column.getTemplate(Dialect dialect, SQLFunctionRegistry functionRegistry)
String | Column.getText(Dialect d)
boolean | AuxiliaryDatabaseObject.appliesToDialect(Dialect dialect) Does this database object apply to the given dialect?
boolean | AbstractAuxiliaryDatabaseObject.appliesToDialect(Dialect dialect)

Uses of Dialect in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that return Dialect
protected  Dialect AbstractCollectionPersister.getDialect()

Uses of Dialect in org.hibernate.sql

Fields in org.hibernate.sql declared as Dialect
 Dialect Select.dialect

Methods in org.hibernate.sql that return Dialect
protected  Dialect Insert.getDialect()

Methods in org.hibernate.sql with parameters of type Dialect
static String Template.renderWhereStringTemplate(String sqlWhereString, Dialect dialect, SQLFunctionRegistry functionRegistry)
static String Template.renderWhereStringTemplate(String sqlWhereString, String placeholder, Dialect dialect)
Deprecated. Only intended for annotations usage; use Template.renderWhereStringTemplate(String, String, Dialect, SQLFunctionRegistry) instead
static String Template.renderWhereStringTemplate(String sqlWhereString, String placeholder, Dialect dialect, SQLFunctionRegistry functionRegistry)
Takes the where condition provided in the mapping attribute and interpolates the alias.
static String Template.renderOrderByStringTemplate(String sqlOrderByString, Dialect dialect, SQLFunctionRegistry functionRegistry)
Takes order by clause provided in the mapping attribute and interpolates the alias.

Constructors in org.hibernate.sql with parameters of type Dialect
Update(Dialect dialect)
SimpleSelect(Dialect dialect)
Select(Dialect dialect)
QuerySelect(Dialect dialect)
QueryJoinFragment(Dialect dialect, boolean useThetaStyleInnerJoins)
InsertSelect(Dialect dialect)
Insert(Dialect dialect)
ForUpdateFragment(Dialect dialect)
ForUpdateFragment(Dialect dialect, Map lockModes, Map keyColumnNames)

Uses of Dialect in org.hibernate.tool.hbm2ddl

Constructors in org.hibernate.tool.hbm2ddl with parameters of type Dialect
DatabaseMetadata(Connection connection, Dialect dialect)
DatabaseMetadata(Connection connection, Dialect dialect, boolean extras)

Uses of Dialect in org.hibernate.type

Methods in org.hibernate.type with parameters of type Dialect
String | TimeZoneType.objectToSQLString(Object value, Dialect dialect)
String | TimeType.objectToSQLString(Object value, Dialect dialect)
String | TimestampType.objectToSQLString(Object value, Dialect dialect)
String | StringType.objectToSQLString(Object value, Dialect dialect)
String | ShortType.objectToSQLString(Object value, Dialect dialect)
String | LongType.objectToSQLString(Object value, Dialect dialect)
String | LocaleType.objectToSQLString(Object value, Dialect dialect)
String | LiteralType.objectToSQLString(Object value, Dialect dialect) String representation of the value, suitable for embedding in an SQL statement.
String | IntegerType.objectToSQLString(Object value, Dialect dialect)
String | FloatType.objectToSQLString(Object value, Dialect dialect)
String | DoubleType.objectToSQLString(Object value, Dialect dialect)
String | DateType.objectToSQLString(Object value, Dialect dialect)
String | CustomType.objectToSQLString(Object value, Dialect dialect)
String | CurrencyType.objectToSQLString(Object value, Dialect dialect)
String | CharBooleanType.objectToSQLString(Object value, Dialect dialect)
String | CharacterType.objectToSQLString(Object value, Dialect dialect)
String | ByteType.objectToSQLString(Object value, Dialect dialect)
String | BooleanType.objectToSQLString(Object value, Dialect dialect)
String | BigIntegerType.objectToSQLString(Object value, Dialect dialect)
String | AbstractCharArrayType.objectToSQLString(Object value, Dialect dialect)

Uses of Dialect in org.hibernate.util

Constructors in org.hibernate.util with parameters of type Dialect
FilterHelper(Map filters, Dialect dialect, SQLFunctionRegistry functionRegistry)
The map of defined filters.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.DialectFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.DialectFactory

No usage of org.hibernate.dialect.DialectFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.dialect.DialectFactory.DatabaseDialectMapper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.dialect.DialectFactory.DatabaseDialectMapper

Packages that use DialectFactory.DatabaseDialectMapper
org.hibernate.dialect This package abstracts the SQL dialect of the underlying database.

Uses of DialectFactory.DatabaseDialectMapper in org.hibernate.dialect

Classes in org.hibernate.dialect that implement DialectFactory.DatabaseDialectMapper
static class DialectFactory.VersionInsensitiveMapper
A simple DatabaseDialectMapper for dialects which are independent of the underlying database product version.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.DialectFactory.VersionInsensitiveMapper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.DialectFactory.VersionInsensitiveMapper

No usage of org.hibernate.dialect.DialectFactory.VersionInsensitiveMapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.FirebirdDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.FirebirdDialect

No usage of org.hibernate.dialect.FirebirdDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.FrontBaseDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.FrontBaseDialect

No usage of org.hibernate.dialect.FrontBaseDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.H2Dialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.H2Dialect

No usage of org.hibernate.dialect.H2Dialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.HSQLDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.HSQLDialect

No usage of org.hibernate.dialect.HSQLDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.HSQLDialect.ReadUncommittedLockingStrategy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.HSQLDialect.ReadUncommittedLockingStrategy

No usage of org.hibernate.dialect.HSQLDialect.ReadUncommittedLockingStrategy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.InformixDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.InformixDialect

No usage of org.hibernate.dialect.InformixDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.IngresDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.IngresDialect

No usage of org.hibernate.dialect.IngresDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.InterbaseDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.InterbaseDialect

Packages that use InterbaseDialect
org.hibernate.dialect This package abstracts the SQL dialect of the underlying database.

Uses of InterbaseDialect in org.hibernate.dialect

Subclasses of InterbaseDialect in org.hibernate.dialect
 class FirebirdDialect
An SQL dialect for Firebird.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.JDataStoreDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.JDataStoreDialect

No usage of org.hibernate.dialect.JDataStoreDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.MckoiDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.MckoiDialect

No usage of org.hibernate.dialect.MckoiDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.MimerSQLDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.MimerSQLDialect

No usage of org.hibernate.dialect.MimerSQLDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.MySQL5Dialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.MySQL5Dialect

Packages that use MySQL5Dialect
org.hibernate.dialect This package abstracts the SQL dialect of the underlying database.

Uses of MySQL5Dialect in org.hibernate.dialect

Subclasses of MySQL5Dialect in org.hibernate.dialect
 class MySQL5InnoDBDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.MySQL5InnoDBDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.MySQL5InnoDBDialect

No usage of org.hibernate.dialect.MySQL5InnoDBDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.MySQLDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.MySQLDialect

Packages that use MySQLDialect
org.hibernate.dialect This package abstracts the SQL dialect of the underlying database.

Uses of MySQLDialect in org.hibernate.dialect

Subclasses of MySQLDialect in org.hibernate.dialect
class | MySQL5Dialect An SQL dialect for MySQL 5.x specific features.
class | MySQL5InnoDBDialect
class | MySQLInnoDBDialect
class | MySQLMyISAMDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.MySQLInnoDBDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.MySQLInnoDBDialect

No usage of org.hibernate.dialect.MySQLInnoDBDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.MySQLMyISAMDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.MySQLMyISAMDialect

No usage of org.hibernate.dialect.MySQLMyISAMDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.Oracle9Dialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.Oracle9Dialect

Packages that use Oracle9Dialect
org.hibernate.dialect This package abstracts the SQL dialect of the underlying database.

Uses of Oracle9Dialect in org.hibernate.dialect

Subclasses of Oracle9Dialect in org.hibernate.dialect
class | DataDirectOracle9Dialect
class | OracleDialect An SQL dialect for Oracle, compatible with Oracle 8.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.OracleDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.OracleDialect

No usage of org.hibernate.dialect.OracleDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.PointbaseDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.PointbaseDialect

No usage of org.hibernate.dialect.PointbaseDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.PostgreSQLDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.PostgreSQLDialect

No usage of org.hibernate.dialect.PostgreSQLDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.ProgressDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.ProgressDialect

No usage of org.hibernate.dialect.ProgressDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.RDMSOS2200Dialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.RDMSOS2200Dialect

No usage of org.hibernate.dialect.RDMSOS2200Dialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.SAPDBDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.SAPDBDialect

No usage of org.hibernate.dialect.SAPDBDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.SQLServerDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.SQLServerDialect

No usage of org.hibernate.dialect.SQLServerDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.Sybase11Dialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.Sybase11Dialect

No usage of org.hibernate.dialect.Sybase11Dialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.SybaseAnywhereDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.SybaseAnywhereDialect

No usage of org.hibernate.dialect.SybaseAnywhereDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.SybaseDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.SybaseDialect

Packages that use SybaseDialect
org.hibernate.dialect This package abstracts the SQL dialect of the underlying database.

Uses of SybaseDialect in org.hibernate.dialect

Subclasses of SybaseDialect in org.hibernate.dialect
class | SQLServerDialect A dialect for Microsoft SQL Server 2000
class | Sybase11Dialect A SQL dialect suitable for use with Sybase 11.9.2 (specifically: avoids ANSI JOIN syntax)
class | SybaseAnywhereDialect SQL Dialect for Sybase Anywhere extending Sybase (Enterprise) Dialect (Tested on ASA 8.x)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.TimesTenDialect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.TimesTenDialect

No usage of org.hibernate.dialect.TimesTenDialect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.TypeNames (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.TypeNames

No usage of org.hibernate.dialect.TypeNames

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.dialect.function (Hibernate API Documentation)

 org.hibernate.dialect.function
Interfaces
SQLFunction
Classes
AnsiTrimEmulationFunction
CastFunction
CharIndexFunction
ClassicAvgFunction
ClassicCountFunction
ClassicSumFunction
NoArgSQLFunction
NvlFunction
PositionSubstringFunction
SQLFunctionRegistry
SQLFunctionTemplate
StandardSQLFunction
VarArgsSQLFunction


Uses of Class org.hibernate.dialect.function.AnsiTrimEmulationFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.AnsiTrimEmulationFunction

No usage of org.hibernate.dialect.function.AnsiTrimEmulationFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.function.CastFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.CastFunction

No usage of org.hibernate.dialect.function.CastFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.function.CharIndexFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.CharIndexFunction

No usage of org.hibernate.dialect.function.CharIndexFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.function.ClassicAvgFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.ClassicAvgFunction

No usage of org.hibernate.dialect.function.ClassicAvgFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.function.ClassicCountFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.ClassicCountFunction

No usage of org.hibernate.dialect.function.ClassicCountFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.function.ClassicSumFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.ClassicSumFunction

No usage of org.hibernate.dialect.function.ClassicSumFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.function.NoArgSQLFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.NoArgSQLFunction

No usage of org.hibernate.dialect.function.NoArgSQLFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.function.NvlFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.NvlFunction

No usage of org.hibernate.dialect.function.NvlFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.function.PositionSubstringFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.PositionSubstringFunction

No usage of org.hibernate.dialect.function.PositionSubstringFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.dialect.function.SQLFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.dialect.function.SQLFunction

Packages that use SQLFunction
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function | A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |

Uses of SQLFunction in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type SQLFunction
 void Configuration.addSqlFunction(String functionName, SQLFunction function)

Uses of SQLFunction in org.hibernate.dialect

Classes in org.hibernate.dialect that implement SQLFunction
static class DerbyDialect.DerbyTrimFunctionEmulation
A specialized function template to emulate the ANSI trim function on Derby DB since it does not support the full trim specification.

Methods in org.hibernate.dialect with parameters of type SQLFunction
protected  void Dialect.registerFunction(String name, SQLFunction function)

Uses of SQLFunction in org.hibernate.dialect.function

Classes in org.hibernate.dialect.function that implement SQLFunction
class | AnsiTrimEmulationFunction A SQLFunction implementation that emulates the ANSI SQL trim function on dialects which do not support the full definition.
class | CastFunction ANSI-SQL style cast(foo as type) where the type is a Hibernate type
class | CharIndexFunction Emulation of locate() on Sybase
class | ClassicAvgFunction Classic AVG sqlfunction that return types as it was done in Hibernate 3.1
class | ClassicCountFunction Classic COUNT sqlfunction that return types as it was done in Hibernate 3.1
class | ClassicSumFunction Classic SUM sqlfunction that return types as it was done in Hibernate 3.1
class | NoArgSQLFunction A function which takes no arguments
class | NvlFunction Emulation of coalesce() on Oracle, using multiple nvl() calls
class | PositionSubstringFunction Emulation of locate() on PostgreSQL
class | SQLFunctionTemplate Represents HQL functions that can have different representations in different SQL dialects.
class | StandardSQLFunction Provides a standard implementation that supports the majority of the HQL functions that are translated to SQL.
class | VarArgsSQLFunction Support for slightly more general templating than StandardSQLFunction, with an unlimited number of arguments.

Methods in org.hibernate.dialect.function that return SQLFunction
 SQLFunction SQLFunctionRegistry.findSQLFunction(String functionName)

Uses of SQLFunction in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return SQLFunction
 SQLFunction MethodNode.getSQLFunction()

Uses of SQLFunction in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util that return SQLFunction
 SQLFunction SessionFactoryHelper.findSQLFunction(String functionName)
Locate a registered sql function by name.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.function.SQLFunctionRegistry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.SQLFunctionRegistry

Packages that use SQLFunctionRegistry
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.
org.hibernate.util | Utility classes.

Uses of SQLFunctionRegistry in org.hibernate.engine

Methods in org.hibernate.engine that return SQLFunctionRegistry
 SQLFunctionRegistry SessionFactoryImplementor.getSqlFunctionRegistry()

Uses of SQLFunctionRegistry in org.hibernate.impl

Methods in org.hibernate.impl that return SQLFunctionRegistry
 SQLFunctionRegistry SessionFactoryImpl.getSqlFunctionRegistry()

Uses of SQLFunctionRegistry in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type SQLFunctionRegistry
String | Selectable.getTemplate(Dialect dialect, SQLFunctionRegistry functionRegistry)
String | Formula.getTemplate(Dialect dialect, SQLFunctionRegistry functionRegistry)
String | Column.getTemplate(Dialect dialect, SQLFunctionRegistry functionRegistry)

Uses of SQLFunctionRegistry in org.hibernate.sql

Methods in org.hibernate.sql with parameters of type SQLFunctionRegistry
static String | Template.renderWhereStringTemplate(String sqlWhereString, Dialect dialect, SQLFunctionRegistry functionRegistry)
static String | Template.renderWhereStringTemplate(String sqlWhereString, String placeholder, Dialect dialect, SQLFunctionRegistry functionRegistry) Takes the where condition provided in the mapping attribute and interpolates the alias.
static String | Template.renderOrderByStringTemplate(String sqlOrderByString, Dialect dialect, SQLFunctionRegistry functionRegistry) Takes order by clause provided in the mapping attribute and interpolates the alias.

Uses of SQLFunctionRegistry in org.hibernate.util

Constructors in org.hibernate.util with parameters of type SQLFunctionRegistry
FilterHelper(Map filters, Dialect dialect, SQLFunctionRegistry functionRegistry)
The map of defined filters.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.function.SQLFunctionTemplate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.SQLFunctionTemplate

No usage of org.hibernate.dialect.function.SQLFunctionTemplate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.function.StandardSQLFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.StandardSQLFunction

Packages that use StandardSQLFunction
org.hibernate.dialect.function A framework for defining database-specific SQL functions that are available via the dialect.

Uses of StandardSQLFunction in org.hibernate.dialect.function

Subclasses of StandardSQLFunction in org.hibernate.dialect.function
class | ClassicAvgFunction Classic AVG sqlfunction that return types as it was done in Hibernate 3.1
class | ClassicCountFunction Classic COUNT sqlfunction that return types as it was done in Hibernate 3.1
class | ClassicSumFunction Classic SUM sqlfunction that return types as it was done in Hibernate 3.1

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.function.VarArgsSQLFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.function.VarArgsSQLFunction

No usage of org.hibernate.dialect.function.VarArgsSQLFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.dialect.lock (Hibernate API Documentation)

 org.hibernate.dialect.lock
Interfaces
LockingStrategy
Classes
SelectLockingStrategy
UpdateLockingStrategy


Uses of Interface org.hibernate.dialect.lock.LockingStrategy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.dialect.lock.LockingStrategy

Packages that use LockingStrategy
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.lock |
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of LockingStrategy in org.hibernate.dialect

Classes in org.hibernate.dialect that implement LockingStrategy
static class HSQLDialect.ReadUncommittedLockingStrategy

Methods in org.hibernate.dialect that return LockingStrategy
LockingStrategy | TimesTenDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | RDMSOS2200Dialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | PointbaseDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | MckoiDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | HSQLDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | FrontBaseDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | Dialect.getLockingStrategy(Lockable lockable, LockMode lockMode) Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.

Uses of LockingStrategy in org.hibernate.dialect.lock

Classes in org.hibernate.dialect.lock that implement LockingStrategy
class | SelectLockingStrategy A locking strategy where the locks are obtained through select statements.
class | UpdateLockingStrategy A locking strategy where the locks are obtained through update statements.

Uses of LockingStrategy in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return LockingStrategy
protected  LockingStrategy AbstractEntityPersister.generateLocker(LockMode lockMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.lock.SelectLockingStrategy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.lock.SelectLockingStrategy

Packages that use SelectLockingStrategy
org.hibernate.dialect This package abstracts the SQL dialect of the underlying database.

Uses of SelectLockingStrategy in org.hibernate.dialect

Subclasses of SelectLockingStrategy in org.hibernate.dialect
static class HSQLDialect.ReadUncommittedLockingStrategy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.dialect.lock.UpdateLockingStrategy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.dialect.lock.UpdateLockingStrategy

No usage of org.hibernate.dialect.lock.UpdateLockingStrategy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.engine (Hibernate API Documentation)

 org.hibernate.engine
Interfaces
HibernateIterator
JoinSequence.Selector
Mapping
ParameterBinder.NamedParameterSource
PersistenceContext
SessionFactoryImplementor
SessionImplementor
Classes
ActionQueue
BatchFetchQueue
Cascade
CascadeStyle
CascadeStyle.MultipleCascadeStyle
CascadingAction
CollectionEntry
CollectionKey
CollectionLoadContext
Collections
EntityEntry
EntityKey
EntityUniqueKey
ExecuteUpdateResultCheckStyle
FilterDefinition
ForeignKeys
ForeignKeys.Nullifier
IdentifierValue
JoinHelper
JoinSequence
NamedQueryDefinition
NamedSQLQueryDefinition
Nullability
ParameterBinder
QueryParameters
ResultSetMappingDefinition
RowSelection
StatefulPersistenceContext
Status
SubselectFetch
TransactionHelper
TwoPhaseLoad
TypedValue
UnsavedValueFactory
Versioning
VersionValue


Uses of Class org.hibernate.engine.ActionQueue (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.ActionQueue

Packages that use ActionQueue
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of ActionQueue in org.hibernate.engine

Methods in org.hibernate.engine that return ActionQueue
static ActionQueue ActionQueue.deserialize(ObjectInputStream ois, SessionImplementor session)
Used by the owning session to explicitly control deserialization of the action queue

Uses of ActionQueue in org.hibernate.event

Methods in org.hibernate.event that return ActionQueue
 ActionQueue EventSource.getActionQueue()
Get the ActionQueue for this session

Uses of ActionQueue in org.hibernate.impl

Methods in org.hibernate.impl that return ActionQueue
 ActionQueue SessionImpl.getActionQueue()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.BatchFetchQueue (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.BatchFetchQueue

Packages that use BatchFetchQueue
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of BatchFetchQueue in org.hibernate.engine

Methods in org.hibernate.engine that return BatchFetchQueue
BatchFetchQueue | StatefulPersistenceContext.getBatchFetchQueue() Get the BatchFetchQueue, instantiating one if necessary.
BatchFetchQueue | PersistenceContext.getBatchFetchQueue() Get the BatchFetchQueue, instantiating one if necessary.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.Cascade (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.Cascade

No usage of org.hibernate.engine.Cascade

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.CascadeStyle (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.CascadeStyle

Packages that use CascadeStyle
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of CascadeStyle in org.hibernate.engine

Subclasses of CascadeStyle in org.hibernate.engine
static class CascadeStyle.MultipleCascadeStyle

Fields in org.hibernate.engine declared as CascadeStyle
static CascadeStyle | CascadeStyle.ALL_DELETE_ORPHAN save / delete / update / evict / lock / replicate / merge / persist + delete orphans
static CascadeStyle | CascadeStyle.ALL save / delete / update / evict / lock / replicate / merge / persist
static CascadeStyle | CascadeStyle.UPDATE save / update
static CascadeStyle | CascadeStyle.LOCK lock
static CascadeStyle | CascadeStyle.REFRESH refresh
static CascadeStyle | CascadeStyle.EVICT evict
static CascadeStyle | CascadeStyle.REPLICATE replicate
static CascadeStyle | CascadeStyle.MERGE merge
static CascadeStyle | CascadeStyle.PERSIST create
static CascadeStyle | CascadeStyle.DELETE delete
static CascadeStyle | CascadeStyle.DELETE_ORPHAN delete + delete orphans
static CascadeStyle | CascadeStyle.NONE no cascades

Methods in org.hibernate.engine that return CascadeStyle
static CascadeStyle CascadeStyle.getCascadeStyle(String cascade)

Constructors in org.hibernate.engine with parameters of type CascadeStyle
CascadeStyle.MultipleCascadeStyle(CascadeStyle[] styles)

Uses of CascadeStyle in org.hibernate.loader

Methods in org.hibernate.loader with parameters of type CascadeStyle
protected int | JoinWalker.getJoinType(AssociationType type, FetchMode config, String path, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth, CascadeStyle cascadeStyle) Get the join type (inner, outer, etc) or -1 if the association should not be joined.
protected boolean | JoinWalker.isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) Override on subclasses to enable or suppress joining of certain association types
protected boolean | AbstractEntityJoinWalker.isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) The superclass deliberately excludes collections

Uses of CascadeStyle in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria with parameters of type CascadeStyle
protected  int CriteriaJoinWalker.getJoinType(AssociationType type, FetchMode config, String path, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth, CascadeStyle cascadeStyle)

Uses of CascadeStyle in org.hibernate.loader.entity

Methods in org.hibernate.loader.entity with parameters of type CascadeStyle
protected boolean | EntityJoinWalker.isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) Disable outer join fetching if this loader obtains an upgrade lock mode
protected boolean | CascadeEntityJoinWalker.isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle)

Uses of CascadeStyle in org.hibernate.mapping

Methods in org.hibernate.mapping that return CascadeStyle
 CascadeStyle Property.getCascadeStyle()

Uses of CascadeStyle in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return CascadeStyle
CascadeStyle | OuterJoinLoadable.getCascadeStyle(int i) Get the cascade style of this (subclass closure) property
CascadeStyle[] | EntityPersister.getPropertyCascadeStyles() Get the cascade styles of the propertes (optional operation)
CascadeStyle | AbstractEntityPersister.getCascadeStyle(int i)
CascadeStyle[] | AbstractEntityPersister.getPropertyCascadeStyles()

Uses of CascadeStyle in org.hibernate.tuple

Methods in org.hibernate.tuple that return CascadeStyle
 CascadeStyle StandardProperty.getCascadeStyle()

Constructors in org.hibernate.tuple with parameters of type CascadeStyle
VersionProperty(String name, String node, Type type, boolean lazy, boolean insertable, boolean updateable, boolean insertGenerated, boolean updateGenerated, boolean nullable, boolean checkable, boolean versionable, CascadeStyle cascadeStyle, VersionValue unsavedValue)
Constructs VersionProperty instances.
StandardProperty(String name, String node, Type type, boolean lazy, boolean insertable, boolean updateable, boolean insertGenerated, boolean updateGenerated, boolean nullable, boolean checkable, boolean versionable, CascadeStyle cascadeStyle, FetchMode fetchMode)
Constructs StandardProperty instances.

Uses of CascadeStyle in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity that return CascadeStyle
 CascadeStyle[] EntityMetamodel.getCascadeStyles()

Uses of CascadeStyle in org.hibernate.type

Methods in org.hibernate.type that return CascadeStyle
CascadeStyle | CompositeCustomType.getCascadeStyle(int i)
CascadeStyle | ComponentType.getCascadeStyle(int i)
CascadeStyle | AnyType.getCascadeStyle(int i)
CascadeStyle | AbstractComponentType.getCascadeStyle(int i)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.CascadeStyle.MultipleCascadeStyle (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.CascadeStyle.MultipleCascadeStyle

No usage of org.hibernate.engine.CascadeStyle.MultipleCascadeStyle

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.CascadingAction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.CascadingAction

Packages that use CascadingAction
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.loader.entity | This package defines entity loaders

Uses of CascadingAction in org.hibernate.engine

Fields in org.hibernate.engine declared as CascadingAction
static CascadingAction | CascadingAction.DELETE
static CascadingAction | CascadingAction.LOCK
static CascadingAction | CascadingAction.REFRESH
static CascadingAction | CascadingAction.EVICT
static CascadingAction | CascadingAction.SAVE_UPDATE
static CascadingAction | CascadingAction.MERGE
static CascadingAction | CascadingAction.SAVE_UPDATE_COPY
static CascadingAction | CascadingAction.PERSIST
static CascadingAction | CascadingAction.PERSIST_ON_FLUSH Execute persist during flush time
static CascadingAction | CascadingAction.REPLICATE

Methods in org.hibernate.engine with parameters of type CascadingAction
abstract boolean | CascadeStyle.doCascade(CascadingAction action) Should the given action be cascaded?
boolean | CascadeStyle.reallyDoCascade(CascadingAction action) Should the given action really, really be cascaded?
boolean | CascadeStyle.MultipleCascadeStyle.doCascade(CascadingAction action)
boolean | CascadeStyle.MultipleCascadeStyle.reallyDoCascade(CascadingAction action)

Constructors in org.hibernate.engine with parameters of type CascadingAction
Cascade(CascadingAction action, int cascadeTo, EventSource eventSource)

Uses of CascadingAction in org.hibernate.event.def

Methods in org.hibernate.event.def that return CascadingAction
protected CascadingAction | DefaultSaveOrUpdateEventListener.getCascadeAction()
protected CascadingAction | DefaultSaveOrUpdateCopyEventListener.getCascadeAction()
protected CascadingAction | DefaultReplicateEventListener.getCascadeAction()
protected CascadingAction | DefaultPersistOnFlushEventListener.getCascadeAction()
protected CascadingAction | DefaultPersistEventListener.getCascadeAction()
protected CascadingAction | DefaultMergeEventListener.getCascadeAction()
protected abstract CascadingAction | AbstractSaveEventListener.getCascadeAction()
protected CascadingAction | AbstractFlushingEventListener.getCascadingAction()

Uses of CascadingAction in org.hibernate.loader.entity

Constructors in org.hibernate.loader.entity with parameters of type CascadingAction
CascadeEntityLoader(OuterJoinLoadable persister, CascadingAction action, SessionFactoryImplementor factory)
CascadeEntityJoinWalker(OuterJoinLoadable persister, CascadingAction action, SessionFactoryImplementor factory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.CollectionEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.CollectionEntry

Packages that use CollectionEntry
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of CollectionEntry in org.hibernate.engine

Methods in org.hibernate.engine that return CollectionEntry
CollectionEntry | StatefulPersistenceContext.getCollectionEntry(PersistentCollection coll) Get the collection entry for a persistent collection
CollectionEntry | StatefulPersistenceContext.addInitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id) add a collection we just pulled out of the cache (does not need initializing)
CollectionEntry | StatefulPersistenceContext.getCollectionEntryOrNull(Object collection) Get the collection entry for a collection passed to filter, which might be a collection wrapper, an array, or an unwrapped collection.
CollectionEntry | PersistenceContext.getCollectionEntry(PersistentCollection coll) Get the collection entry for a persistent collection
CollectionEntry | PersistenceContext.addInitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id) add a collection we just pulled out of the cache (does not need initializing)
CollectionEntry | PersistenceContext.getCollectionEntryOrNull(Object collection) Get the collection entry for a collection passed to filter, which might be a collection wrapper, an array, or an unwrapped collection.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.CollectionKey (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.CollectionKey

Packages that use CollectionKey
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of CollectionKey in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type CollectionKey
void | StatefulPersistenceContext.addUnownedCollection(CollectionKey key, PersistentCollection collection)
PersistentCollection | StatefulPersistenceContext.useUnownedCollection(CollectionKey key)
PersistentCollection | StatefulPersistenceContext.getCollection(CollectionKey collectionKey) Get the collection instance associated with the CollectionKey
void | PersistenceContext.addUnownedCollection(CollectionKey key, PersistentCollection collection) Add a collection which has no owner loaded
PersistentCollection | PersistenceContext.useUnownedCollection(CollectionKey key) Get and remove a collection whose owner is not yet loaded, when its owner is being loaded
PersistentCollection | PersistenceContext.getCollection(CollectionKey collectionKey) Get the collection instance associated with the CollectionKey

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.CollectionLoadContext (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.CollectionLoadContext

Packages that use CollectionLoadContext
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of CollectionLoadContext in org.hibernate.engine

Methods in org.hibernate.engine that return CollectionLoadContext
CollectionLoadContext | StatefulPersistenceContext.getCollectionLoadContext()
CollectionLoadContext | PersistenceContext.getCollectionLoadContext() Get the context for collection loading

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.Collections (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.Collections

No usage of org.hibernate.engine.Collections

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.EntityEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.EntityEntry

Packages that use EntityEntry
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of EntityEntry in org.hibernate.engine

Methods in org.hibernate.engine that return EntityEntry
EntityEntry | StatefulPersistenceContext.getEntry(Object entity) Retreive the EntityEntry representation of the given entity.
EntityEntry | StatefulPersistenceContext.removeEntry(Object entity) Remove an entity entry from the session cache
EntityEntry | StatefulPersistenceContext.addEntity(Object entity, Status status, Object[] loadedState, EntityKey entityKey, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Adds an entity to the internal caches.
EntityEntry | StatefulPersistenceContext.addEntry(Object entity, Status status, Object[] loadedState, Object rowId, Serializable id, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.
EntityEntry | PersistenceContext.getEntry(Object entity) Retreive the EntityEntry representation of the given entity.
EntityEntry | PersistenceContext.removeEntry(Object entity) Remove an entity entry from the session cache
EntityEntry | PersistenceContext.addEntity(Object entity, Status status, Object[] loadedState, EntityKey entityKey, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Adds an entity to the internal caches.
EntityEntry | PersistenceContext.addEntry(Object entity, Status status, Object[] loadedState, Object rowId, Serializable id, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.

Methods in org.hibernate.engine with parameters of type EntityEntry
void | StatefulPersistenceContext.setEntryStatus(EntityEntry entry, Status status)
void | PersistenceContext.setEntryStatus(EntityEntry entry, Status status) Set the status of an entry

Uses of EntityEntry in org.hibernate.event

Methods in org.hibernate.event that return EntityEntry
EntityEntry | SaveOrUpdateEvent.getEntry()
EntityEntry | FlushEntityEvent.getEntityEntry()

Methods in org.hibernate.event with parameters of type EntityEntry
void | SaveOrUpdateEvent.setEntry(EntityEntry entry)
void | EventSource.forceFlush(EntityEntry e) Force an immediate flush

Constructors in org.hibernate.event with parameters of type EntityEntry
FlushEntityEvent(EventSource source, Object entity, EntityEntry entry)

Uses of EntityEntry in org.hibernate.event.def

Methods in org.hibernate.event.def that return EntityEntry
protected  EntityEntry AbstractReassociateEventListener.reassociate(AbstractEvent event, Object object, Serializable id, EntityPersister persister)
Associates a given entity (either transient or associated with another session) to the given session.

Methods in org.hibernate.event.def with parameters of type EntityEntry
protected boolean | DefaultFlushEntityEventListener.invokeInterceptor(SessionImplementor session, Object entity, EntityEntry entry, Object[] values, EntityPersister persister)
protected void | DefaultDeleteEventListener.deleteEntity(EventSource session, Object entity, EntityEntry entityEntry, boolean isCascadeDeleteEnabled, EntityPersister persister, Set transientEntities)
protected void | DefaultDeleteEventListener.cascadeBeforeDelete(EventSource session, EntityPersister persister, Object entity, EntityEntry entityEntry, Set transientEntities)
protected int | AbstractSaveEventListener.getEntityState(Object entity, String entityName, EntityEntry entry, SessionImplementor source) Determine whether the entity is persistent, detached, or transient
protected void | AbstractLockUpgradeEventListener.upgradeLock(Object object, EntityEntry entry, LockMode requestedLockMode, SessionImplementor source) Performs a pessimistic lock upgrade on a given entity, if needed.

Uses of EntityEntry in org.hibernate.impl

Methods in org.hibernate.impl with parameters of type EntityEntry
 void SessionImpl.forceFlush(EntityEntry entityEntry)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.EntityKey (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.EntityKey

Packages that use EntityKey
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of EntityKey in org.hibernate.action

Methods in org.hibernate.action that return EntityKey
 EntityKey EntityIdentityInsertAction.getDelayedEntityKey()

Uses of EntityKey in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type EntityKey
static void | TwoPhaseLoad.addUninitializedEntity(EntityKey key, Object object, EntityPersister persister, LockMode lockMode, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Add an uninitialized instance of an entity class, as a placeholder to ensure object identity.
static void | TwoPhaseLoad.addUninitializedCachedEntity(EntityKey key, Object object, EntityPersister persister, LockMode lockMode, boolean lazyPropertiesAreUnfetched, Object version, SessionImplementor session)
Object[] | StatefulPersistenceContext.getCachedDatabaseSnapshot(EntityKey key)
void | StatefulPersistenceContext.addEntity(EntityKey key, Object entity)
Object | StatefulPersistenceContext.getEntity(EntityKey key) Get the entity instance associated with the given EntityKey
boolean | StatefulPersistenceContext.containsEntity(EntityKey key)
Object | StatefulPersistenceContext.removeEntity(EntityKey key) Remove an entity from the session cache, also clear up other state associated with the entity, all except for the EntityEntry
EntityEntry | StatefulPersistenceContext.addEntity(Object entity, Status status, Object[] loadedState, EntityKey entityKey, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Adds an entity to the internal caches.
void | StatefulPersistenceContext.checkUniqueness(EntityKey key, Object object) Attempts to check whether the given key represents an entity already loaded within the current session.
Object | StatefulPersistenceContext.narrowProxy(Object proxy, EntityPersister persister, EntityKey key, Object object) If the existing proxy is insufficiently "narrow" (derived), instantiate a new proxy and overwrite the registration of the old one.
Object | StatefulPersistenceContext.proxyFor(EntityPersister persister, EntityKey key, Object impl) Return the existing proxy associated with the given EntityKey, or the third argument (the entity associated with the key) if no proxy exists.
Object | StatefulPersistenceContext.getProxy(EntityKey key) Get an existing proxy by key
void | StatefulPersistenceContext.addProxy(EntityKey key, Object proxy) Add a proxy to the session cache
Object | StatefulPersistenceContext.removeProxy(EntityKey key) Remove a proxy from the session cache
void | StatefulPersistenceContext.addNullProperty(EntityKey ownerKey, String propertyName) Record the fact that the association belonging to the keyed entity is null.
boolean | StatefulPersistenceContext.isPropertyNull(EntityKey ownerKey, String propertyName) Is the association property belonging to the keyed entity null?
void | StatefulPersistenceContext.replaceDelayedEntityIdentityInsertKeys(EntityKey oldKey, Serializable generatedId)
Object | SessionImplementor.getEntityUsingInterceptor(EntityKey key) Get the entity instance associated with the given Key, calling the Interceptor if necessary
Object[] | PersistenceContext.getCachedDatabaseSnapshot(EntityKey key)
void | PersistenceContext.addEntity(EntityKey key, Object entity) Add a canonical mapping from entity key to entity instance
Object | PersistenceContext.getEntity(EntityKey key) Get the entity instance associated with the given EntityKey
boolean | PersistenceContext.containsEntity(EntityKey key) Is there an entity with the given key in the persistence context
Object | PersistenceContext.removeEntity(EntityKey key) Remove an entity from the session cache, also clear up other state associated with the entity, all except for the EntityEntry
EntityEntry | PersistenceContext.addEntity(Object entity, Status status, Object[] loadedState, EntityKey entityKey, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Adds an entity to the internal caches.
void | PersistenceContext.checkUniqueness(EntityKey key, Object object) Attempts to check whether the given key represents an entity already loaded within the current session.
Object | PersistenceContext.narrowProxy(Object proxy, EntityPersister persister, EntityKey key, Object object) If the existing proxy is insufficiently "narrow" (derived), instantiate a new proxy and overwrite the registration of the old one.
Object | PersistenceContext.proxyFor(EntityPersister persister, EntityKey key, Object impl) Return the existing proxy associated with the given EntityKey, or the third argument (the entity associated with the key) if no proxy exists.
Object | PersistenceContext.getProxy(EntityKey key) Get an existing proxy by key
void | PersistenceContext.addProxy(EntityKey key, Object proxy) Add a proxy to the session cache
Object | PersistenceContext.removeProxy(EntityKey key) Remove a proxy from the session cache
void | PersistenceContext.addNullProperty(EntityKey ownerKey, String propertyName) Record the fact that the association belonging to the keyed entity is null.
boolean | PersistenceContext.isPropertyNull(EntityKey ownerKey, String propertyName) Is the association property belonging to the keyed entity null?
void | PersistenceContext.replaceDelayedEntityIdentityInsertKeys(EntityKey oldKey, Serializable generatedId)
SubselectFetch | BatchFetchQueue.getSubselect(EntityKey key) Retrieve the fetch descriptor associated with the given entity key.
void | BatchFetchQueue.addSubselect(EntityKey key, SubselectFetch subquery) Adds a subselect fetch decriptor for the given entity key.
void | BatchFetchQueue.removeSubselect(EntityKey key) After evicting or deleting an entity, we don't need to know the query that was used to load it anymore (don't call this after loading the entity, since we might still need to load its collections)
void | BatchFetchQueue.addBatchLoadableEntityKey(EntityKey key) If an EntityKey represents a batch loadable entity, add it to the queue.
void | BatchFetchQueue.removeBatchLoadableEntityKey(EntityKey key) After evicting or deleting or loading an entity, we don't need to batch fetch it anymore, remove it from the queue if necessary

Uses of EntityKey in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type EntityKey
protected Object | DefaultLoadEventListener.load(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Perfoms the load of an entity.
protected Object | DefaultLoadEventListener.proxyOrLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Based on configured options, will either return a pre-existing proxy, generate a new proxy, or perform an actual load.
protected Object | DefaultLoadEventListener.lockAndLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options, SessionImplementor source) If the class to be loaded has been configured with a cache, then lock given id in that cache and then perform the load.
protected Object | DefaultLoadEventListener.doLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Coordinates the efforts to load a given entity.
protected Object | DefaultLoadEventListener.loadFromDatasource(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Performs the process of loading an entity from the configured underlying datasource.
protected Object | DefaultLoadEventListener.loadFromSessionCache(LoadEvent event, EntityKey keyToLoad, LoadEventListener.LoadType options) Attempts to locate the entity in the session-level cache.
protected void | DefaultEvictEventListener.doEvict(Object object, EntityKey key, EntityPersister persister, EventSource session)
protected Serializable | AbstractSaveEventListener.performSaveOrReplicate(Object entity, EntityKey key, EntityPersister persister, boolean useIdentityColumn, Object anything, EventSource source, boolean requiresImmediateIdAccess) Performs all the actual work needed to save an entity (well to get the save moved to the execution queue).

Uses of EntityKey in org.hibernate.impl

Methods in org.hibernate.impl with parameters of type EntityKey
Object | StatelessSessionImpl.getEntityUsingInterceptor(EntityKey key)
Object | SessionImpl.getEntityUsingInterceptor(EntityKey key)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.EntityUniqueKey (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.EntityUniqueKey

Packages that use EntityUniqueKey
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of EntityUniqueKey in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type EntityUniqueKey
Object | StatefulPersistenceContext.getEntity(EntityUniqueKey euk) Get an entity cached by unique key
void | StatefulPersistenceContext.addEntity(EntityUniqueKey euk, Object entity) Add an entity to the cache by unique key
Object | PersistenceContext.getEntity(EntityUniqueKey euk) Get an entity cached by unique key
void | PersistenceContext.addEntity(EntityUniqueKey euk, Object entity) Add an entity to the cache by unique key

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.ExecuteUpdateResultCheckStyle (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.ExecuteUpdateResultCheckStyle

Packages that use ExecuteUpdateResultCheckStyle
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of ExecuteUpdateResultCheckStyle in org.hibernate.engine

Fields in org.hibernate.engine declared as ExecuteUpdateResultCheckStyle
static ExecuteUpdateResultCheckStyle | ExecuteUpdateResultCheckStyle.NONE Do not perform checking.
static ExecuteUpdateResultCheckStyle | ExecuteUpdateResultCheckStyle.COUNT Perform row-count checking.
static ExecuteUpdateResultCheckStyle | ExecuteUpdateResultCheckStyle.PARAM Essentially the same as COUNT except that the row count actually comes from an output parameter registered as part of a CallableStatement.

Methods in org.hibernate.engine that return ExecuteUpdateResultCheckStyle
static ExecuteUpdateResultCheckStyle | ExecuteUpdateResultCheckStyle.parse(String name)
static ExecuteUpdateResultCheckStyle | ExecuteUpdateResultCheckStyle.determineDefault(String customSql, boolean callable)

Uses of ExecuteUpdateResultCheckStyle in org.hibernate.jdbc

Methods in org.hibernate.jdbc with parameters of type ExecuteUpdateResultCheckStyle
static Expectation Expectations.appropriateExpectation(ExecuteUpdateResultCheckStyle style)

Uses of ExecuteUpdateResultCheckStyle in org.hibernate.mapping

Methods in org.hibernate.mapping that return ExecuteUpdateResultCheckStyle
ExecuteUpdateResultCheckStyle | PersistentClass.getCustomSQLInsertCheckStyle()
ExecuteUpdateResultCheckStyle | PersistentClass.getCustomSQLUpdateCheckStyle()
ExecuteUpdateResultCheckStyle | PersistentClass.getCustomSQLDeleteCheckStyle()
ExecuteUpdateResultCheckStyle | Join.getCustomSQLInsertCheckStyle()
ExecuteUpdateResultCheckStyle | Join.getCustomSQLUpdateCheckStyle()
ExecuteUpdateResultCheckStyle | Join.getCustomSQLDeleteCheckStyle()
ExecuteUpdateResultCheckStyle | Collection.getCustomSQLInsertCheckStyle()
ExecuteUpdateResultCheckStyle | Collection.getCustomSQLUpdateCheckStyle()
ExecuteUpdateResultCheckStyle | Collection.getCustomSQLDeleteCheckStyle()
ExecuteUpdateResultCheckStyle | Collection.getCustomSQLDeleteAllCheckStyle()

Methods in org.hibernate.mapping with parameters of type ExecuteUpdateResultCheckStyle
void | PersistentClass.setCustomSQLInsert(String customSQLInsert, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | PersistentClass.setCustomSQLUpdate(String customSQLUpdate, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | PersistentClass.setCustomSQLDelete(String customSQLDelete, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | Join.setCustomSQLInsert(String customSQLInsert, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | Join.setCustomSQLUpdate(String customSQLUpdate, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | Join.setCustomSQLDelete(String customSQLDelete, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | Collection.setCustomSQLInsert(String customSQLInsert, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | Collection.setCustomSQLUpdate(String customSQLUpdate, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | Collection.setCustomSQLDelete(String customSQLDelete, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)
void | Collection.setCustomSQLDeleteAll(String customSQLDeleteAll, boolean callable, ExecuteUpdateResultCheckStyle checkStyle)

Uses of ExecuteUpdateResultCheckStyle in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that return ExecuteUpdateResultCheckStyle
protected ExecuteUpdateResultCheckStyle | AbstractCollectionPersister.getInsertCheckStyle()
protected ExecuteUpdateResultCheckStyle | AbstractCollectionPersister.getUpdateCheckStyle()
protected ExecuteUpdateResultCheckStyle | AbstractCollectionPersister.getDeleteCheckStyle()
protected ExecuteUpdateResultCheckStyle | AbstractCollectionPersister.getDeleteAllCheckStyle()

Uses of ExecuteUpdateResultCheckStyle in org.hibernate.persister.entity

Fields in org.hibernate.persister.entity declared as ExecuteUpdateResultCheckStyle
protected ExecuteUpdateResultCheckStyle[] | AbstractEntityPersister.insertResultCheckStyles
protected ExecuteUpdateResultCheckStyle[] | AbstractEntityPersister.updateResultCheckStyles
protected ExecuteUpdateResultCheckStyle[] | AbstractEntityPersister.deleteResultCheckStyles

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.FilterDefinition (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.FilterDefinition

Packages that use FilterDefinition
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.

Uses of FilterDefinition in org.hibernate

Methods in org.hibernate that return FilterDefinition
FilterDefinition | SessionFactory.getFilterDefinition(String filterName) Obtain the definition of a filter by name.
FilterDefinition | Filter.getFilterDefinition() Get the filter definition containing additional information about the filter (such as default-condition and expected parameter names/types).

Uses of FilterDefinition in org.hibernate.cfg

Methods in org.hibernate.cfg that return FilterDefinition
 FilterDefinition Mappings.getFilterDefinition(String name)

Methods in org.hibernate.cfg with parameters of type FilterDefinition
void | Mappings.addFilterDefinition(FilterDefinition definition)
void | Configuration.addFilterDefinition(FilterDefinition definition)

Uses of FilterDefinition in org.hibernate.impl

Methods in org.hibernate.impl that return FilterDefinition
FilterDefinition | SessionFactoryImpl.getFilterDefinition(String filterName)
FilterDefinition | FilterImpl.getFilterDefinition()

Constructors in org.hibernate.impl with parameters of type FilterDefinition
FilterImpl(FilterDefinition configuration)
Constructs a new FilterImpl.

Uses of FilterDefinition in org.hibernate.jmx

Methods in org.hibernate.jmx that return FilterDefinition
 FilterDefinition SessionFactoryStub.getFilterDefinition(String filterName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.ForeignKeys (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.ForeignKeys

No usage of org.hibernate.engine.ForeignKeys

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.ForeignKeys.Nullifier (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.ForeignKeys.Nullifier

No usage of org.hibernate.engine.ForeignKeys.Nullifier

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.engine.HibernateIterator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.engine.HibernateIterator

Packages that use HibernateIterator
org.hibernate.impl This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of HibernateIterator in org.hibernate.impl

Classes in org.hibernate.impl that implement HibernateIterator
 class IteratorImpl
An implementation of java.util.Iterator that is returned by iterate() query execution methods.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.IdentifierValue (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.IdentifierValue

Packages that use IdentifierValue
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.

Uses of IdentifierValue in org.hibernate.engine

Fields in org.hibernate.engine declared as IdentifierValue
static IdentifierValue | IdentifierValue.ANY Always assume the transient instance is newly instantiated
static IdentifierValue | IdentifierValue.NONE Never assume the transient instance is newly instantiated
static IdentifierValue | IdentifierValue.NULL Assume the transient instance is newly instantiated if the identifier is null.
static IdentifierValue | IdentifierValue.UNDEFINED Assume nothing.

Methods in org.hibernate.engine that return IdentifierValue
static IdentifierValue UnsavedValueFactory.getUnsavedIdentifierValue(String unsavedValue, Getter identifierGetter, Type identifierType, Constructor constructor)
Return an IdentifierValue for the specified unsaved-value.

Uses of IdentifierValue in org.hibernate.tuple

Methods in org.hibernate.tuple that return IdentifierValue
 IdentifierValue IdentifierProperty.getUnsavedValue()

Constructors in org.hibernate.tuple with parameters of type IdentifierValue
IdentifierProperty(String name, String node, Type type, boolean embedded, IdentifierValue unsavedValue, IdentifierGenerator identifierGenerator)
Construct a non-virtual identifier property.
IdentifierProperty(Type type, boolean embedded, boolean hasIdentifierMapper, IdentifierValue unsavedValue, IdentifierGenerator identifierGenerator)
Construct a virtual IdentifierProperty.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.JoinHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.JoinHelper

No usage of org.hibernate.engine.JoinHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.JoinSequence (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.JoinSequence

Packages that use JoinSequence
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.

Uses of JoinSequence in org.hibernate.engine

Methods in org.hibernate.engine that return JoinSequence
JoinSequence | JoinSequence.getFromPart()
JoinSequence | JoinSequence.copy()
JoinSequence | JoinSequence.addJoin(AssociationType associationType, String alias, int joinType, String[] referencingKey)
JoinSequence | JoinSequence.addCondition(String condition)
JoinSequence | JoinSequence.addCondition(String alias, String[] columns, String condition)
JoinSequence | JoinSequence.setRoot(Joinable joinable, String alias)
JoinSequence | JoinSequence.setNext(JoinSequence next)
JoinSequence | JoinSequence.setSelector(JoinSequence.Selector s)
JoinSequence | JoinSequence.setUseThetaStyle(boolean useThetaStyle)

Methods in org.hibernate.engine with parameters of type JoinSequence
 JoinSequence JoinSequence.setNext(JoinSequence next)

Uses of JoinSequence in org.hibernate.hql

Methods in org.hibernate.hql with parameters of type JoinSequence
static String CollectionSubqueryFactory.createCollectionSubquery(JoinSequence joinSequence, Map enabledFilters, String[] columns)

Uses of JoinSequence in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return JoinSequence
 JoinSequence FromElement.getJoinSequence()

Methods in org.hibernate.hql.ast.tree with parameters of type JoinSequence
 void FromElement.setJoinSequence(JoinSequence joinSequence)

Uses of JoinSequence in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util that return JoinSequence
JoinSequence | SessionFactoryHelper.createJoinSequence() Generate an empty join sequence instance.
JoinSequence | SessionFactoryHelper.createJoinSequence(boolean implicit, AssociationType associationType, String tableAlias, int joinType, String[] columns) Generate a join sequence representing the given association type.
JoinSequence | SessionFactoryHelper.createCollectionJoinSequence(QueryableCollection collPersister, String collectionName) Create a join sequence rooted at the given collection.

Uses of JoinSequence in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that return JoinSequence
 JoinSequence PathExpressionParser.getWhereJoin()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.engine.JoinSequence.Selector (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.engine.JoinSequence.Selector

Packages that use JoinSequence.Selector
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of JoinSequence.Selector in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type JoinSequence.Selector
 JoinSequence JoinSequence.setSelector(JoinSequence.Selector s)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.engine.Mapping (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.engine.Mapping

Packages that use Mapping
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function | A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of Mapping in org.hibernate.cfg

Methods in org.hibernate.cfg that return Mapping
 Mapping Configuration.buildMapping()

Uses of Mapping in org.hibernate.dialect

Methods in org.hibernate.dialect with parameters of type Mapping
 Type DerbyDialect.DerbyTrimFunctionEmulation.getReturnType(Type columnType, Mapping mapping)

Uses of Mapping in org.hibernate.dialect.function

Methods in org.hibernate.dialect.function with parameters of type Mapping
Type | VarArgsSQLFunction.getReturnType(Type columnType, Mapping mapping)
Type | StandardSQLFunction.getReturnType(Type columnType, Mapping mapping)
Type | SQLFunctionTemplate.getReturnType(Type columnType, Mapping mapping)
Type | SQLFunction.getReturnType(Type columnType, Mapping mapping) The function return type
Type | PositionSubstringFunction.getReturnType(Type columnType, Mapping mapping)
Type | NvlFunction.getReturnType(Type columnType, Mapping mapping)
Type | NoArgSQLFunction.getReturnType(Type columnType, Mapping mapping)
Type | ClassicCountFunction.getReturnType(Type columnType, Mapping mapping)
Type | ClassicAvgFunction.getReturnType(Type columnType, Mapping mapping)
Type | CharIndexFunction.getReturnType(Type columnType, Mapping mapping)
Type | CastFunction.getReturnType(Type columnType, Mapping mapping)
Type | AnsiTrimEmulationFunction.getReturnType(Type columnType, Mapping mapping)

Uses of Mapping in org.hibernate.engine

Subinterfaces of Mapping in org.hibernate.engine
 interface SessionFactoryImplementor
Defines the internal contract between the SessionFactory and other parts of Hibernate such as implementors of Type.

Methods in org.hibernate.engine with parameters of type Mapping
static String[] | JoinHelper.getAliasedLHSColumnNames(AssociationType type, String alias, int property, OuterJoinLoadable lhsPersister, Mapping mapping) Get the aliased columns of the owning entity which are to be used in the join
static String[] | JoinHelper.getLHSColumnNames(AssociationType type, int property, OuterJoinLoadable lhsPersister, Mapping mapping) Get the columns of the owning entity which are to be used in the join
static String[] | JoinHelper.getAliasedLHSColumnNames(AssociationType type, String alias, int property, int begin, OuterJoinLoadable lhsPersister, Mapping mapping) Get the aliased columns of the owning entity which are to be used in the join
static String[] | JoinHelper.getLHSColumnNames(AssociationType type, int property, int begin, OuterJoinLoadable lhsPersister, Mapping mapping) Get the columns of the owning entity which are to be used in the join

Uses of Mapping in org.hibernate.impl

Classes in org.hibernate.impl that implement Mapping
 class SessionFactoryImpl
Concrete implementation of the SessionFactory interface.

Constructors in org.hibernate.impl with parameters of type Mapping
SessionFactoryImpl(Configuration cfg, Mapping mapping, Settings settings, EventListeners listeners)

Uses of Mapping in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type Mapping
boolean | Value.isValid(Mapping mapping)
String | UniqueKey.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
void | UnionSubclass.validate(Mapping mapping)
boolean | ToOne.isValid(Mapping mapping)
void | Table.validateColumns(Dialect dialect, Mapping mapping, TableMetadata tableInfo)
Iterator | Table.sqlAlterStrings(Dialect dialect, Mapping p, TableMetadata tableInfo, String defaultCatalog, String defaultSchema)
String | Table.sqlTemporaryTableCreateString(Dialect dialect, Mapping mapping)
String | Table.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
void | SingleTableSubclass.validate(Mapping mapping)
boolean | SimpleValue.isValid(Mapping mapping)
String | SimpleAuxiliaryDatabaseObject.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
void | Set.validate(Mapping mapping)
void | RootClass.validate(Mapping mapping)
String | RelationalModel.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
boolean | Property.isValid(Mapping mapping)
void | PersistentClass.validate(Mapping mapping)
void | PersistentClass.prepareTemporaryTables(Mapping mapping, Dialect dialect)
boolean | OneToMany.isValid(Mapping mapping)
void | JoinedSubclass.validate(Mapping mapping)
void | IndexedCollection.validate(Mapping mapping)
String | Index.sqlCreateString(Dialect dialect, Mapping mapping, String defaultCatalog, String defaultSchema)
void | IdentifierCollection.validate(Mapping mapping)
String | Constraint.sqlCreateString(Dialect dialect, Mapping p, String defaultCatalog, String defaultSchema)
int | Column.getSqlTypeCode(Mapping mapping)
String | Column.getSqlType(Dialect dialect, Mapping mapping)
void | Collection.validate(Mapping mapping)
boolean | Collection.isValid(Mapping mapping)

Uses of Mapping in org.hibernate.persister

Methods in org.hibernate.persister with parameters of type Mapping
static EntityPersister PersisterFactory.createClassPersister(PersistentClass model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping cfg)

Uses of Mapping in org.hibernate.persister.collection

Constructors in org.hibernate.persister.collection with parameters of type Mapping
CompositeElementPropertyMapping(String[] elementColumns, String[] elementFormulaTemplates, AbstractComponentType compositeType, Mapping factory)

Uses of Mapping in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity with parameters of type Mapping
protected String | UnionSubclassEntityPersister.generateSubquery(PersistentClass model, Mapping mapping)
protected void | AbstractPropertyMapping.initPropertyPaths(String path, Type type, String[] columns, String[] formulaTemplates, Mapping factory)
protected void | AbstractPropertyMapping.initIdentifierPropertyPaths(String path, EntityType etype, String[] columns, Mapping factory)
protected void | AbstractPropertyMapping.initComponentPropertyPaths(String path, AbstractComponentType type, String[] columns, String[] formulaTemplates, Mapping factory)
protected void | AbstractEntityPersister.initPropertyPaths(Mapping mapping)
protected void | AbstractEntityPersister.postConstruct(Mapping mapping)

Constructors in org.hibernate.persister.entity with parameters of type Mapping
UnionSubclassEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
SingleTableEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
JoinedSubclassEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)

Uses of Mapping in org.hibernate.type

Methods in org.hibernate.type with parameters of type Mapping
int[] | Type.sqlTypes(Mapping mapping) Return the SQL type codes for the columns mapped by this type.
int | Type.getColumnSpan(Mapping mapping) How many columns are used to persist this type.
Object | Type.fromXMLNode(org.dom4j.Node xml, Mapping factory) Parse the XML representation of an instance.
boolean[] | Type.toColumnNullness(Object value, Mapping mapping) Given an instance of the type, return an array of boolean, indicating which mapped columns would be null.
int | SpecialOneToOneType.getColumnSpan(Mapping mapping)
int[] | SpecialOneToOneType.sqlTypes(Mapping mapping)
int | OneToOneType.getColumnSpan(Mapping session)
int[] | OneToOneType.sqlTypes(Mapping session)
boolean[] | OneToOneType.toColumnNullness(Object value, Mapping mapping)
Object | NullableType.fromXMLString(String xml, Mapping factory)
int | NullableType.getColumnSpan(Mapping session)
int[] | NullableType.sqlTypes(Mapping session)
Object | NullableType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
boolean[] | NullableType.toColumnNullness(Object value, Mapping mapping)
int[] | MetaType.sqlTypes(Mapping mapping)
int | MetaType.getColumnSpan(Mapping mapping)
Object | MetaType.fromXMLString(String xml, Mapping factory)
Object | MetaType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
boolean[] | MetaType.toColumnNullness(Object value, Mapping mapping)
int | ManyToOneType.getColumnSpan(Mapping mapping)
int[] | ManyToOneType.sqlTypes(Mapping mapping)
boolean[] | ManyToOneType.toColumnNullness(Object value, Mapping mapping)
Type | EntityType.getIdentifierOrUniqueKeyType(Mapping factory)
String | EntityType.getIdentifierOrUniqueKeyPropertyName(Mapping factory)
Object | EntityType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
int[] | CustomType.sqlTypes(Mapping pi)
int | CustomType.getColumnSpan(Mapping session)
Object | CustomType.fromXMLString(String xml, Mapping factory)
Object | CustomType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
boolean[] | CustomType.toColumnNullness(Object value, Mapping mapping)
int | CompositeCustomType.getColumnSpan(Mapping mapping)
int[] | CompositeCustomType.sqlTypes(Mapping mapping)
Object | CompositeCustomType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
boolean[] | CompositeCustomType.toColumnNullness(Object value, Mapping mapping)
int[] | ComponentType.sqlTypes(Mapping mapping)
int | ComponentType.getColumnSpan(Mapping mapping)
Object | ComponentType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
boolean[] | ComponentType.toColumnNullness(Object value, Mapping mapping)
int[] | CollectionType.sqlTypes(Mapping session)
int | CollectionType.getColumnSpan(Mapping session)
Object | CollectionType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
boolean[] | CollectionType.toColumnNullness(Object value, Mapping mapping)
Object | ClobType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
int | ClobType.getColumnSpan(Mapping mapping)
int[] | ClobType.sqlTypes(Mapping mapping)
boolean[] | ClobType.toColumnNullness(Object value, Mapping mapping)
Object | BlobType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
int | BlobType.getColumnSpan(Mapping mapping)
int[] | BlobType.sqlTypes(Mapping mapping)
boolean[] | BlobType.toColumnNullness(Object value, Mapping mapping)
int | AnyType.getColumnSpan(Mapping session)
int[] | AnyType.sqlTypes(Mapping mapping)
Object | AnyType.fromXMLNode(org.dom4j.Node xml, Mapping factory)
boolean[] | AnyType.toColumnNullness(Object value, Mapping mapping)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.NamedQueryDefinition (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.NamedQueryDefinition

Packages that use NamedQueryDefinition
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of NamedQueryDefinition in org.hibernate.cfg

Methods in org.hibernate.cfg that return NamedQueryDefinition
 NamedQueryDefinition Mappings.getQuery(String name)

Methods in org.hibernate.cfg with parameters of type NamedQueryDefinition
 void Mappings.addQuery(String name, NamedQueryDefinition query)

Uses of NamedQueryDefinition in org.hibernate.engine

Subclasses of NamedQueryDefinition in org.hibernate.engine
 class NamedSQLQueryDefinition
Definition of a named native SQL query, defined in the mapping metadata.

Methods in org.hibernate.engine that return NamedQueryDefinition
 NamedQueryDefinition SessionFactoryImplementor.getNamedQuery(String queryName)

Uses of NamedQueryDefinition in org.hibernate.impl

Methods in org.hibernate.impl that return NamedQueryDefinition
 NamedQueryDefinition SessionFactoryImpl.getNamedQuery(String queryName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.NamedSQLQueryDefinition (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.NamedSQLQueryDefinition

Packages that use NamedSQLQueryDefinition
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of NamedSQLQueryDefinition in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type NamedSQLQueryDefinition
 void Mappings.addSQLQuery(String name, NamedSQLQueryDefinition query)

Uses of NamedSQLQueryDefinition in org.hibernate.engine

Methods in org.hibernate.engine that return NamedSQLQueryDefinition
 NamedSQLQueryDefinition SessionFactoryImplementor.getNamedSQLQuery(String queryName)

Uses of NamedSQLQueryDefinition in org.hibernate.impl

Methods in org.hibernate.impl that return NamedSQLQueryDefinition
 NamedSQLQueryDefinition SessionFactoryImpl.getNamedSQLQuery(String queryName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.Nullability (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.Nullability

No usage of org.hibernate.engine.Nullability

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.ParameterBinder (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.ParameterBinder

No usage of org.hibernate.engine.ParameterBinder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.engine.ParameterBinder.NamedParameterSource (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.engine.ParameterBinder.NamedParameterSource

Packages that use ParameterBinder.NamedParameterSource
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.

Uses of ParameterBinder.NamedParameterSource in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type ParameterBinder.NamedParameterSource
static int | ParameterBinder.bindQueryParameters(PreparedStatement st, QueryParameters queryParameters, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)
static int | ParameterBinder.bindNamedParameters(PreparedStatement ps, QueryParameters queryParameters, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)
static int | ParameterBinder.bindNamedParameters(PreparedStatement ps, Map namedParams, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)

Uses of ParameterBinder.NamedParameterSource in org.hibernate.hql.ast

Classes in org.hibernate.hql.ast that implement ParameterBinder.NamedParameterSource
 class HqlSqlWalker
Implements methods used by the HQL->SQL tree transform grammar (a.k.a.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.engine.PersistenceContext (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.engine.PersistenceContext

Packages that use PersistenceContext
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of PersistenceContext in org.hibernate.engine

Classes in org.hibernate.engine that implement PersistenceContext
 class StatefulPersistenceContext
A PersistenceContext represents the state of persistent "stuff" which Hibernate is tracking.

Methods in org.hibernate.engine that return PersistenceContext
 PersistenceContext SessionImplementor.getPersistenceContext()
Get the persistence context for this session

Constructors in org.hibernate.engine with parameters of type PersistenceContext
CollectionLoadContext(PersistenceContext context)
BatchFetchQueue(PersistenceContext context)
Constructs a queue for the given context.

Uses of PersistenceContext in org.hibernate.impl

Methods in org.hibernate.impl that return PersistenceContext
PersistenceContext | StatelessSessionImpl.getPersistenceContext()
PersistenceContext | SessionImpl.getPersistenceContext()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.QueryParameters (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.QueryParameters

Packages that use QueryParameters
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.exec |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.param |

Uses of QueryParameters in org.hibernate.cache

Constructors in org.hibernate.cache with parameters of type QueryParameters
QueryKey(String queryString, QueryParameters queryParameters, Set filters, EntityMode entityMode)

Uses of QueryParameters in org.hibernate.engine

Methods in org.hibernate.engine that return QueryParameters
QueryParameters | SubselectFetch.getQueryParameters()
QueryParameters | QueryParameters.createCopyUsing(RowSelection selection)

Methods in org.hibernate.engine with parameters of type QueryParameters
 List SessionImplementor.list(String query, QueryParameters queryParameters)
Execute a find() query
 Iterator SessionImplementor.iterate(String query, QueryParameters queryParameters)
Execute an iterate() query
 ScrollableResults SessionImplementor.scroll(String query, QueryParameters queryParameters)
Execute a scroll() query
 List SessionImplementor.listFilter(Object collection, String filter, QueryParameters queryParameters)
Execute a filter
 Iterator SessionImplementor.iterateFilter(Object collection, String filter, QueryParameters queryParameters)
Iterate a filter
 List SessionImplementor.listCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
Execute an SQL Query
 ScrollableResults SessionImplementor.scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
Execute an SQL Query
 List SessionImplementor.list(NativeSQLQuerySpecification spec, QueryParameters queryParameters)
Execute a native SQL query, and return the results as a fully built list.
 ScrollableResults SessionImplementor.scroll(NativeSQLQuerySpecification spec, QueryParameters queryParameters)
Execute a native SQL query, and return the results as a scrollable result.
 int SessionImplementor.executeUpdate(String query, QueryParameters queryParameters)
Execute a HQL update or delete query
 int SessionImplementor.executeNativeUpdate(NativeSQLQuerySpecification specification, QueryParameters queryParameters)
Execute a native SQL update or delete query
static int ParameterBinder.bindQueryParameters(PreparedStatement st, QueryParameters queryParameters, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)
static int ParameterBinder.bindPositionalParameters(PreparedStatement st, QueryParameters queryParameters, int start, SessionImplementor session)
static int ParameterBinder.bindNamedParameters(PreparedStatement ps, QueryParameters queryParameters, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)

Constructors in org.hibernate.engine with parameters of type QueryParameters
SubselectFetch(String alias, Loadable loadable, QueryParameters queryParameters, Set resultingEntityKeys, Map namedParameterLocMap)

Uses of QueryParameters in org.hibernate.engine.query

Methods in org.hibernate.engine.query with parameters of type QueryParameters
int | NativeSQLQueryPlan.performExecuteUpdate(QueryParameters queryParameters, SessionImplementor session)
List | HQLQueryPlan.performList(QueryParameters queryParameters, SessionImplementor session)
Iterator | HQLQueryPlan.performIterate(QueryParameters queryParameters, EventSource session)
ScrollableResults | HQLQueryPlan.performScroll(QueryParameters queryParameters, SessionImplementor session)
int | HQLQueryPlan.performExecuteUpdate(QueryParameters queryParameters, SessionImplementor session)

Uses of QueryParameters in org.hibernate.hql

Methods in org.hibernate.hql with parameters of type QueryParameters
List | QueryTranslator.list(SessionImplementor session, QueryParameters queryParameters) Perform a list operation given the underlying query definition.
Iterator | QueryTranslator.iterate(QueryParameters queryParameters, EventSource session) Perform an iterate operation given the underlying query defintion.
ScrollableResults | QueryTranslator.scroll(QueryParameters queryParameters, SessionImplementor session) Perform a scroll operation given the underlying query defintion.
int | QueryTranslator.executeUpdate(QueryParameters queryParameters, SessionImplementor session) Perform a bulk update/delete operation given the underlying query defintion.

Uses of QueryParameters in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast with parameters of type QueryParameters
List | QueryTranslatorImpl.list(SessionImplementor session, QueryParameters queryParameters)
Iterator | QueryTranslatorImpl.iterate(QueryParameters queryParameters, EventSource session) Return the query results as an iterator
ScrollableResults | QueryTranslatorImpl.scroll(QueryParameters queryParameters, SessionImplementor session) Return the query results, as an instance of ScrollableResults
int | QueryTranslatorImpl.executeUpdate(QueryParameters queryParameters, SessionImplementor session)

Uses of QueryParameters in org.hibernate.hql.ast.exec

Methods in org.hibernate.hql.ast.exec with parameters of type QueryParameters
int | StatementExecutor.execute(QueryParameters parameters, SessionImplementor session) Execute the sql managed by this executor using the given parameters.
int | MultiTableUpdateExecutor.execute(QueryParameters parameters, SessionImplementor session)
int | MultiTableDeleteExecutor.execute(QueryParameters parameters, SessionImplementor session)
int | BasicExecutor.execute(QueryParameters parameters, SessionImplementor session)

Uses of QueryParameters in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic with parameters of type QueryParameters
List | QueryTranslatorImpl.list(SessionImplementor session, QueryParameters queryParameters)
Iterator | QueryTranslatorImpl.iterate(QueryParameters queryParameters, EventSource session) Return the query results as an iterator
int | QueryTranslatorImpl.executeUpdate(QueryParameters queryParameters, SessionImplementor session)
ScrollableResults | QueryTranslatorImpl.scroll(QueryParameters queryParameters, SessionImplementor session)

Uses of QueryParameters in org.hibernate.impl

Methods in org.hibernate.impl that return QueryParameters
QueryParameters | SQLQueryImpl.getQueryParameters(Map namedParams)
protected QueryParameters | AbstractScrollableResults.getQueryParameters()
QueryParameters | AbstractQueryImpl.getQueryParameters(Map namedParams)

Methods in org.hibernate.impl with parameters of type QueryParameters
Iterator | StatelessSessionImpl.iterate(String query, QueryParameters queryParameters)
Iterator | StatelessSessionImpl.iterateFilter(Object collection, String filter, QueryParameters queryParameters)
List | StatelessSessionImpl.listFilter(Object collection, String filter, QueryParameters queryParameters)
int | StatelessSessionImpl.executeUpdate(String query, QueryParameters queryParameters)
List | StatelessSessionImpl.list(String query, QueryParameters queryParameters)
List | StatelessSessionImpl.listCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
ScrollableResults | StatelessSessionImpl.scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
ScrollableResults | StatelessSessionImpl.scroll(String query, QueryParameters queryParameters)
int | StatelessSessionImpl.executeNativeUpdate(NativeSQLQuerySpecification nativeSQLQuerySpecification, QueryParameters queryParameters)
List | SessionImpl.list(String query, QueryParameters queryParameters)
int | SessionImpl.executeUpdate(String query, QueryParameters queryParameters)
int | SessionImpl.executeNativeUpdate(NativeSQLQuerySpecification nativeQuerySpecification, QueryParameters queryParameters)
Iterator | SessionImpl.iterate(String query, QueryParameters queryParameters)
ScrollableResults | SessionImpl.scroll(String query, QueryParameters queryParameters)
List | SessionImpl.listFilter(Object collection, String filter, QueryParameters queryParameters)
Iterator | SessionImpl.iterateFilter(Object collection, String filter, QueryParameters queryParameters)
ScrollableResults | SessionImpl.scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
List | SessionImpl.listCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
List | AbstractSessionImpl.list(NativeSQLQuerySpecification spec, QueryParameters queryParameters)
ScrollableResults | AbstractSessionImpl.scroll(NativeSQLQuerySpecification spec, QueryParameters queryParameters)

Constructors in org.hibernate.impl with parameters of type QueryParameters
ScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
FetchingScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
AbstractScrollableResults(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)

Uses of QueryParameters in org.hibernate.loader

Methods in org.hibernate.loader with parameters of type QueryParameters
protected String | Loader.preprocessSQL(String sql, QueryParameters parameters, Dialect dialect) Modify the SQL, adding lock hints and comments, if necessary
Object | Loader.loadSingleRow(ResultSet resultSet, SessionImplementor session, QueryParameters queryParameters, boolean returnProxies) Loads a single row from the result set.
Object | Loader.loadSequentialRowsForward(ResultSet resultSet, SessionImplementor session, QueryParameters queryParameters, boolean returnProxies) Loads a single logical row from the result set moving forward.
Object | Loader.loadSequentialRowsReverse(ResultSet resultSet, SessionImplementor session, QueryParameters queryParameters, boolean returnProxies, boolean isLogicallyAfterLast) Loads a single logical row from the result set moving forward.
protected int | Loader.bindPositionalParameters(PreparedStatement st, QueryParameters queryParameters, int start, SessionImplementor session) Bind positional parameter values to the PreparedStatement (these are parameters specified by a JDBC-style ?).
protected PreparedStatement | Loader.prepareQueryStatement(QueryParameters queryParameters, boolean scroll, SessionImplementor session) Obtain a PreparedStatement with all parameters pre-bound.
protected List | Loader.list(SessionImplementor session, QueryParameters queryParameters, Set querySpaces, Type[] resultTypes) Return the query results, using the query cache, called by subclasses that implement cacheable queries
protected List | Loader.doList(SessionImplementor session, QueryParameters queryParameters) Actually execute a query, ignoring the query cache
protected ScrollableResults | Loader.scroll(QueryParameters queryParameters, Type[] returnTypes, HolderInstantiator holderInstantiator, SessionImplementor session) Return the query results, as an instance of ScrollableResults

Uses of QueryParameters in org.hibernate.loader.collection

Constructors in org.hibernate.loader.collection with parameters of type QueryParameters
SubselectOneToManyLoader(QueryableCollection persister, String subquery, Collection entityKeys, QueryParameters queryParameters, Map namedParameterLocMap, SessionFactoryImplementor factory, Map enabledFilters)
SubselectCollectionLoader(QueryableCollection persister, String subquery, Collection entityKeys, QueryParameters queryParameters, Map namedParameterLocMap, SessionFactoryImplementor factory, Map enabledFilters)

Uses of QueryParameters in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria that return QueryParameters
 QueryParameters CriteriaQueryTranslator.getQueryParameters()

Uses of QueryParameters in org.hibernate.loader.custom

Methods in org.hibernate.loader.custom with parameters of type QueryParameters
List | CustomLoader.list(SessionImplementor session, QueryParameters queryParameters)
ScrollableResults | CustomLoader.scroll(QueryParameters queryParameters, SessionImplementor session)

Uses of QueryParameters in org.hibernate.loader.hql

Methods in org.hibernate.loader.hql with parameters of type QueryParameters
List | QueryLoader.list(SessionImplementor session, QueryParameters queryParameters) Delegats
Iterator | QueryLoader.iterate(QueryParameters queryParameters, EventSource session) Return the query results as an iterator
ScrollableResults | QueryLoader.scroll(QueryParameters queryParameters, SessionImplementor session)

Uses of QueryParameters in org.hibernate.param

Methods in org.hibernate.param with parameters of type QueryParameters
int | VersionTypeSeedParameterSpecification.bind(PreparedStatement statement, QueryParameters qp, SessionImplementor session, int position)
int | PositionalParameterSpecification.bind(PreparedStatement statement, QueryParameters qp, SessionImplementor session, int position) Bind the appropriate value into the given statement at the specified position.
int | ParameterSpecification.bind(PreparedStatement statement, QueryParameters qp, SessionImplementor session, int position) Bind the appropriate value into the given statement at the specified position.
int | NamedParameterSpecification.bind(PreparedStatement statement, QueryParameters qp, SessionImplementor session, int position) Bind the appropriate value into the given statement at the specified position.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.ResultSetMappingDefinition (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.ResultSetMappingDefinition

Packages that use ResultSetMappingDefinition
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of ResultSetMappingDefinition in org.hibernate.cfg

Methods in org.hibernate.cfg that return ResultSetMappingDefinition
protected static ResultSetMappingDefinition | ResultSetMappingBinder.buildResultSetMappingDefinition(org.dom4j.Element resultSetElem, String path, Mappings mappings) Build a ResultSetMappingDefinition given a containing element for the "return-XXX" elements
ResultSetMappingDefinition | Mappings.getResultSetMapping(String name)

Methods in org.hibernate.cfg with parameters of type ResultSetMappingDefinition
 void Mappings.addResultSetMapping(ResultSetMappingDefinition sqlResultSetMapping)

Uses of ResultSetMappingDefinition in org.hibernate.engine

Methods in org.hibernate.engine that return ResultSetMappingDefinition
 ResultSetMappingDefinition SessionFactoryImplementor.getResultSetMapping(String name)

Uses of ResultSetMappingDefinition in org.hibernate.impl

Methods in org.hibernate.impl that return ResultSetMappingDefinition
 ResultSetMappingDefinition SessionFactoryImpl.getResultSetMapping(String resultSetName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.RowSelection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.RowSelection

Packages that use RowSelection
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.

Uses of RowSelection in org.hibernate.engine

Methods in org.hibernate.engine that return RowSelection
 RowSelection QueryParameters.getRowSelection()

Methods in org.hibernate.engine with parameters of type RowSelection
void | QueryParameters.setRowSelection(RowSelection selection)
QueryParameters | QueryParameters.createCopyUsing(RowSelection selection)

Constructors in org.hibernate.engine with parameters of type RowSelection
QueryParameters(Type[] positionalParameterTypes, Object[] positionalParameterValues, Map lockModes, RowSelection rowSelection, boolean cacheable, String cacheRegion, String comment, boolean isLookupByNaturalKey, ResultTransformer transformer)
QueryParameters(Type[] positionalParameterTypes, Object[] positionalParameterValues, Map namedParameters, Map lockModes, RowSelection rowSelection, boolean readOnly, boolean cacheable, String cacheRegion, String comment, Serializable[] collectionKeys, ResultTransformer transformer)
QueryParameters(Type[] positionalParameterTypes, Object[] positionalParameterValues, Map namedParameters, Map lockModes, RowSelection rowSelection, boolean readOnly, boolean cacheable, String cacheRegion, String comment, Serializable[] collectionKeys, Object optionalObject, String optionalEntityName, Serializable optionalId, ResultTransformer transformer)

Uses of RowSelection in org.hibernate.impl

Methods in org.hibernate.impl that return RowSelection
RowSelection | AbstractQueryImpl.getSelection()
protected RowSelection | AbstractQueryImpl.getRowSelection()

Uses of RowSelection in org.hibernate.loader

Methods in org.hibernate.loader with parameters of type RowSelection
protected  ResultSet Loader.getResultSet(PreparedStatement st, boolean autodiscovertypes, boolean callable, RowSelection selection, SessionImplementor session)
Fetch a PreparedStatement, call setMaxRows and then execute it, advance to the first result and return an SQL ResultSet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.engine.SessionFactoryImplementor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.engine.SessionFactoryImplementor

Packages that use SessionFactoryImplementor
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.context |
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function | A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.exec |
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.custom.sql |
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.pretty | Classes for pretty printing things for exception and log messages.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.stat | This package exposes statistics about a running Hibernate instance to the application.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.usertype | Interfaces for user-defined custom types.
org.hibernate.util | Utility classes.

Uses of SessionFactoryImplementor in org.hibernate.cache

Constructors in org.hibernate.cache with parameters of type SessionFactoryImplementor
CacheKey(Serializable id, Type type, String entityOrRoleName, EntityMode entityMode, SessionFactoryImplementor factory)
Construct a new key for a collection or entity instance.

Uses of SessionFactoryImplementor in org.hibernate.cache.entry

Methods in org.hibernate.cache.entry with parameters of type SessionFactoryImplementor
Object | UnstructuredCacheEntry.destructure(Object map, SessionFactoryImplementor factory)
Object | StructuredMapCacheEntry.destructure(Object item, SessionFactoryImplementor factory)
Object | StructuredCollectionCacheEntry.destructure(Object item, SessionFactoryImplementor factory)
Object | StructuredCacheEntry.destructure(Object item, SessionFactoryImplementor factory)
Object | CacheEntryStructure.destructure(Object map, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.context

Fields in org.hibernate.context declared as SessionFactoryImplementor
protected SessionFactoryImplementor | ThreadLocalSessionContext.factory
protected SessionFactoryImplementor | JTASessionContext.factory

Methods in org.hibernate.context that return SessionFactoryImplementor
protected  SessionFactoryImplementor ThreadLocalSessionContext.getFactory()

Constructors in org.hibernate.context with parameters of type SessionFactoryImplementor
ThreadLocalSessionContext(SessionFactoryImplementor factory)
ManagedSessionContext(SessionFactoryImplementor factory)
JTASessionContext(SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.criterion

Methods in org.hibernate.criterion that return SessionFactoryImplementor
 SessionFactoryImplementor CriteriaQuery.getFactory()

Methods in org.hibernate.criterion with parameters of type SessionFactoryImplementor
protected  QueryableCollection AbstractEmptinessExpression.getQueryableCollection(String entityName, String propertyName, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.dialect

Methods in org.hibernate.dialect with parameters of type SessionFactoryImplementor
 String DerbyDialect.DerbyTrimFunctionEmulation.render(List args, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.dialect.function

Methods in org.hibernate.dialect.function with parameters of type SessionFactoryImplementor
String | VarArgsSQLFunction.render(List args, SessionFactoryImplementor factory)
String | StandardSQLFunction.render(List args, SessionFactoryImplementor factory)
String | SQLFunctionTemplate.render(List args, SessionFactoryImplementor factory) Applies the template to passed in arguments.
String | SQLFunction.render(List args, SessionFactoryImplementor factory) Render the function call as SQL
String | PositionSubstringFunction.render(List args, SessionFactoryImplementor factory)
String | NvlFunction.render(List args, SessionFactoryImplementor factory)
String | NoArgSQLFunction.render(List args, SessionFactoryImplementor factory)
String | CharIndexFunction.render(List args, SessionFactoryImplementor factory)
String | CastFunction.render(List args, SessionFactoryImplementor factory)
String | AnsiTrimEmulationFunction.render(List args, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.engine

Methods in org.hibernate.engine that return SessionFactoryImplementor
 SessionFactoryImplementor SessionImplementor.getFactory()
Get the creating SessionFactoryImplementor

Methods in org.hibernate.engine with parameters of type SessionFactoryImplementor
void | QueryParameters.traceParameters(SessionFactoryImplementor factory)
static String[] | JoinHelper.getRHSColumnNames(AssociationType type, SessionFactoryImplementor factory) Get the columns of the associated table which are to be used in the join
int | EntityUniqueKey.generateHashCode(SessionFactoryImplementor factory)

Constructors in org.hibernate.engine with parameters of type SessionFactoryImplementor
JoinSequence(SessionFactoryImplementor factory)
EntityUniqueKey(String entityName, String uniqueKeyName, Object semiResolvedKey, Type keyType, EntityMode entityMode, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.engine.query

Constructors in org.hibernate.engine.query with parameters of type SessionFactoryImplementor
QueryPlanCache(SessionFactoryImplementor factory)
NativeSQLQueryPlan(NativeSQLQuerySpecification specification, SessionFactoryImplementor factory)
HQLQueryPlan(String hql, boolean shallow, Map enabledFilters, SessionFactoryImplementor factory)
HQLQueryPlan(String hql, String collectionRole, boolean shallow, Map enabledFilters, SessionFactoryImplementor factory)
FilterQueryPlan(String hql, String collectionRole, boolean shallow, Map enabledFilters, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.hql

Methods in org.hibernate.hql with parameters of type SessionFactoryImplementor
QueryTranslator | QueryTranslatorFactory.createQueryTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory) Construct a QueryTranslator instance capable of translating an HQL query string.
FilterTranslator | QueryTranslatorFactory.createFilterTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory) Construct a FilterTranslator instance capable of translating an HQL filter string.
static String[] | QuerySplitter.concreteQueries(String query, SessionFactoryImplementor factory) Handle Hibernate "implicit" polymorphism, by translating the query string into several "concrete" queries against mapped classes.
static String | QuerySplitter.getImportedClass(String name, SessionFactoryImplementor factory)
static String[][] | NameGenerator.generateColumnNames(Type[] types, SessionFactoryImplementor f)

Uses of SessionFactoryImplementor in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast with parameters of type SessionFactoryImplementor
QueryTranslator | ASTQueryTranslatorFactory.createQueryTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory)
FilterTranslator | ASTQueryTranslatorFactory.createFilterTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory)

Constructors in org.hibernate.hql.ast with parameters of type SessionFactoryImplementor
SqlGenerator(SessionFactoryImplementor sfi)
QueryTranslatorImpl(String queryIdentifier, String query, Map enabledFilters, SessionFactoryImplementor factory)
Creates a new AST-based query translator.
HqlSqlWalker(QueryTranslatorImpl qti, SessionFactoryImplementor sfi, HqlParser parser, Map tokenReplacements, String collectionRole)
Create a new tree transformer.

Uses of SessionFactoryImplementor in org.hibernate.hql.ast.exec

Methods in org.hibernate.hql.ast.exec that return SessionFactoryImplementor
protected  SessionFactoryImplementor AbstractStatementExecutor.getFactory()

Uses of SessionFactoryImplementor in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree with parameters of type SessionFactoryImplementor
void | SessionFactoryAwareNode.setSessionFactory(SessionFactoryImplementor sessionFactory)
String | ParameterNode.getRenderText(SessionFactoryImplementor sessionFactory)
String | Node.getRenderText(SessionFactoryImplementor sessionFactory) Retrieve the text to be used for rendering this particular node.
void | JavaConstantNode.setSessionFactory(SessionFactoryImplementor factory)
String | JavaConstantNode.getRenderText(SessionFactoryImplementor sessionFactory)
String | BooleanLiteralNode.getRenderText(SessionFactoryImplementor sessionFactory)

Uses of SessionFactoryImplementor in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util that return SessionFactoryImplementor
 SessionFactoryImplementor SessionFactoryHelper.getFactory()
Get a handle to the encapsulated SessionFactory.

Methods in org.hibernate.hql.ast.util with parameters of type SessionFactoryImplementor
static Queryable SessionFactoryHelper.findQueryableUsingImports(SessionFactoryImplementor sfi, String className)
Given a (potentially unqualified) class name, locate its persister.

Constructors in org.hibernate.hql.ast.util with parameters of type SessionFactoryImplementor
SessionFactoryHelper(SessionFactoryImplementor sfi)
Construct a new SessionFactoryHelper instance.

Uses of SessionFactoryImplementor in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic with parameters of type SessionFactoryImplementor
QueryTranslator | ClassicQueryTranslatorFactory.createQueryTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory)
FilterTranslator | ClassicQueryTranslatorFactory.createFilterTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory)

Constructors in org.hibernate.hql.classic with parameters of type SessionFactoryImplementor
QueryTranslatorImpl(String queryIdentifier, String queryString, Map enabledFilters, SessionFactoryImplementor factory)
Construct a query translator
QueryTranslatorImpl(String queryString, Map enabledFilters, SessionFactoryImplementor factory)
Construct a query translator

Uses of SessionFactoryImplementor in org.hibernate.impl

Classes in org.hibernate.impl that implement SessionFactoryImplementor
 class SessionFactoryImpl
Concrete implementation of the SessionFactory interface.

Methods in org.hibernate.impl that return SessionFactoryImplementor
 SessionFactoryImplementor AbstractSessionImpl.getFactory()

Uses of SessionFactoryImplementor in org.hibernate.jdbc

Methods in org.hibernate.jdbc that return SessionFactoryImplementor
SessionFactoryImplementor | JDBCContext.getFactory()
SessionFactoryImplementor | ConnectionManager.getFactory() The session factory.
protected SessionFactoryImplementor | AbstractBatcher.getFactory()

Methods in org.hibernate.jdbc with parameters of type SessionFactoryImplementor
static ConnectionManager ConnectionManager.deserialize(ObjectInputStream ois, SessionFactoryImplementor factory, Interceptor interceptor, ConnectionReleaseMode connectionReleaseMode, JDBCContext jdbcContext)

Constructors in org.hibernate.jdbc with parameters of type SessionFactoryImplementor
ConnectionManager(SessionFactoryImplementor factory, ConnectionManager.Callback callback, ConnectionReleaseMode releaseMode, Connection connection, Interceptor interceptor)
Constructs a ConnectionManager.

Uses of SessionFactoryImplementor in org.hibernate.loader

Methods in org.hibernate.loader that return SessionFactoryImplementor
SessionFactoryImplementor | Loader.getFactory()
protected SessionFactoryImplementor | JoinWalker.getFactory()

Constructors in org.hibernate.loader with parameters of type SessionFactoryImplementor
OuterJoinLoader(SessionFactoryImplementor factory, Map enabledFilters)
OuterJoinableAssociation(AssociationType joinableType, String lhsAlias, String[] lhsColumns, String rhsAlias, int joinType, SessionFactoryImplementor factory, Map enabledFilters)
Loader(SessionFactoryImplementor factory)
JoinWalker(SessionFactoryImplementor factory, Map enabledFilters)
BasicLoader(SessionFactoryImplementor factory)
AbstractEntityJoinWalker(OuterJoinLoadable persister, SessionFactoryImplementor factory, Map enabledFilters)

Uses of SessionFactoryImplementor in org.hibernate.loader.collection

Methods in org.hibernate.loader.collection with parameters of type SessionFactoryImplementor
static CollectionInitializer | BatchingCollectionInitializer.createBatchingOneToManyInitializer(QueryableCollection persister, int maxBatchSize, SessionFactoryImplementor factory, Map enabledFilters)
static CollectionInitializer | BatchingCollectionInitializer.createBatchingCollectionInitializer(QueryableCollection persister, int maxBatchSize, SessionFactoryImplementor factory, Map enabledFilters)

Constructors in org.hibernate.loader.collection with parameters of type SessionFactoryImplementor
SubselectOneToManyLoader(QueryableCollection persister, String subquery, Collection entityKeys, QueryParameters queryParameters, Map namedParameterLocMap, SessionFactoryImplementor factory, Map enabledFilters)
SubselectCollectionLoader(QueryableCollection persister, String subquery, Collection entityKeys, QueryParameters queryParameters, Map namedParameterLocMap, SessionFactoryImplementor factory, Map enabledFilters)
OneToManyLoader(QueryableCollection oneToManyPersister, SessionFactoryImplementor session, Map enabledFilters)
OneToManyLoader(QueryableCollection oneToManyPersister, int batchSize, SessionFactoryImplementor factory, Map enabledFilters)
OneToManyLoader(QueryableCollection oneToManyPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)
OneToManyJoinWalker(QueryableCollection oneToManyPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)
CollectionLoader(QueryableCollection collectionPersister, SessionFactoryImplementor factory, Map enabledFilters)
CollectionJoinWalker(SessionFactoryImplementor factory, Map enabledFilters)
BasicCollectionLoader(QueryableCollection collectionPersister, SessionFactoryImplementor session, Map enabledFilters)
BasicCollectionLoader(QueryableCollection collectionPersister, int batchSize, SessionFactoryImplementor factory, Map enabledFilters)
BasicCollectionLoader(QueryableCollection collectionPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)
BasicCollectionJoinWalker(QueryableCollection collectionPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)

Uses of SessionFactoryImplementor in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria that return SessionFactoryImplementor
 SessionFactoryImplementor CriteriaQueryTranslator.getFactory()

Constructors in org.hibernate.loader.criteria with parameters of type SessionFactoryImplementor
CriteriaQueryTranslator(SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, String rootSQLAlias, CriteriaQuery outerQuery)
CriteriaQueryTranslator(SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, String rootSQLAlias)
CriteriaLoader(OuterJoinLoadable persister, SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, Map enabledFilters)
CriteriaJoinWalker(OuterJoinLoadable persister, CriteriaQueryTranslator translator, SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, Map enabledFilters)

Uses of SessionFactoryImplementor in org.hibernate.loader.custom

Constructors in org.hibernate.loader.custom with parameters of type SessionFactoryImplementor
CustomLoader(CustomQuery customQuery, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.loader.custom.sql

Constructors in org.hibernate.loader.custom.sql with parameters of type SessionFactoryImplementor
SQLQueryReturnProcessor(NativeSQLQueryReturn[] queryReturns, SessionFactoryImplementor factory)
SQLCustomQuery(String sqlQuery, NativeSQLQueryReturn[] queryReturns, Collection additionalQuerySpaces, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.loader.entity

Methods in org.hibernate.loader.entity with parameters of type SessionFactoryImplementor
static UniqueEntityLoader BatchingEntityLoader.createBatchingEntityLoader(OuterJoinLoadable persister, int maxBatchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)

Constructors in org.hibernate.loader.entity with parameters of type SessionFactoryImplementor
EntityLoader(OuterJoinLoadable persister, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityLoader(OuterJoinLoadable persister, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityLoader(OuterJoinLoadable persister, String[] uniqueKey, Type uniqueKeyType, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityJoinWalker(OuterJoinLoadable persister, String[] uniqueKey, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
CollectionElementLoader(QueryableCollection collectionPersister, SessionFactoryImplementor factory, Map enabledFilters)
CascadeEntityLoader(OuterJoinLoadable persister, CascadingAction action, SessionFactoryImplementor factory)
CascadeEntityJoinWalker(OuterJoinLoadable persister, CascadingAction action, SessionFactoryImplementor factory)
AbstractEntityLoader(OuterJoinLoadable persister, Type uniqueKeyType, SessionFactoryImplementor factory, Map enabledFilters)

Uses of SessionFactoryImplementor in org.hibernate.loader.hql

Constructors in org.hibernate.loader.hql with parameters of type SessionFactoryImplementor
QueryLoader(QueryTranslator queryTranslator, SessionFactoryImplementor factory, SelectClause selectClause)
Creates a new Loader implementation.

Uses of SessionFactoryImplementor in org.hibernate.persister

Methods in org.hibernate.persister with parameters of type SessionFactoryImplementor
static EntityPersister | PersisterFactory.createClassPersister(PersistentClass model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping cfg)
static CollectionPersister | PersisterFactory.createCollectionPersister(Configuration cfg, Collection model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that return SessionFactoryImplementor
SessionFactoryImplementor | CollectionPersister.getFactory()
SessionFactoryImplementor | AbstractCollectionPersister.getFactory()

Constructors in org.hibernate.persister.collection with parameters of type SessionFactoryImplementor
OneToManyPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
BasicCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
AbstractCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return SessionFactoryImplementor
SessionFactoryImplementor | EntityPersister.getFactory() Return the SessionFactory to which this persister "belongs".
SessionFactoryImplementor | AbstractEntityPersister.getFactory()

Methods in org.hibernate.persister.entity with parameters of type SessionFactoryImplementor
EntityPersister | EntityPersister.getSubclassEntityPersister(Object instance, SessionFactoryImplementor factory, EntityMode entityMode) Get the persister for an instance of this class or a subclass
EntityPersister | AbstractEntityPersister.getSubclassEntityPersister(Object instance, SessionFactoryImplementor factory, EntityMode entityMode)

Constructors in org.hibernate.persister.entity with parameters of type SessionFactoryImplementor
UnionSubclassEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
SingleTableEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
JoinedSubclassEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
AbstractEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.pretty

Methods in org.hibernate.pretty with parameters of type SessionFactoryImplementor
static String | MessageHelper.infoString(EntityPersister persister, Object id, SessionFactoryImplementor factory) Generate an info message string relating to a particular entity.
static String | MessageHelper.infoString(EntityPersister persister, Object id, Type identifierType, SessionFactoryImplementor factory) Generate an info message string relating to a particular entity,.
static String | MessageHelper.infoString(EntityPersister persister, Serializable[] ids, SessionFactoryImplementor factory) Generate an info message string relating to a series of entities.
static String | MessageHelper.collectionInfoString(CollectionPersister persister, Serializable[] ids, SessionFactoryImplementor factory) Generate an info message string relating to a series of managed collections.
static String | MessageHelper.collectionInfoString(CollectionPersister persister, Serializable id, SessionFactoryImplementor factory) Generate an info message string relating to a particular managed collection.

Constructors in org.hibernate.pretty with parameters of type SessionFactoryImplementor
Printer(SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.property

Fields in org.hibernate.property declared as SessionFactoryImplementor
protected  SessionFactoryImplementor Dom4jAccessor.Dom4jGetter.factory

Methods in org.hibernate.property with parameters of type SessionFactoryImplementor
void | Setter.set(Object target, Object value, SessionFactoryImplementor factory) Set the property value from the given instance
static PropertyAccessor | PropertyAccessorFactory.getDom4jPropertyAccessor(String nodeName, Type type, SessionFactoryImplementor factory)
void | MapAccessor.MapSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | IndexPropertyAccessor.IndexSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | EmbeddedPropertyAccessor.EmbeddedSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | Dom4jAccessor.TextSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | Dom4jAccessor.AttributeSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | Dom4jAccessor.ElementSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | Dom4jAccessor.ElementAttributeSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | DirectPropertyAccessor.DirectSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | BasicPropertyAccessor.BasicSetter.set(Object target, Object value, SessionFactoryImplementor factory)
void | BackrefPropertyAccessor.BackrefSetter.set(Object target, Object value, SessionFactoryImplementor factory)

Constructors in org.hibernate.property with parameters of type SessionFactoryImplementor
Dom4jAccessor(String nodeName, Type propertyType, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.stat

Constructors in org.hibernate.stat with parameters of type SessionFactoryImplementor
StatisticsImpl(SessionFactoryImplementor sessionFactory)

Uses of SessionFactoryImplementor in org.hibernate.transaction

Methods in org.hibernate.transaction that return SessionFactoryImplementor
 SessionFactoryImplementor TransactionFactory.Context.getFactory()

Uses of SessionFactoryImplementor in org.hibernate.tuple.component

Methods in org.hibernate.tuple.component with parameters of type SessionFactoryImplementor
void | PojoComponentTuplizer.setParent(Object component, Object parent, SessionFactoryImplementor factory)
void | ComponentTuplizer.setParent(Object component, Object parent, SessionFactoryImplementor factory) Set the value of the parent property.
void | AbstractComponentTuplizer.setParent(Object component, Object parent, SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity that return SessionFactoryImplementor
SessionFactoryImplementor | EntityMetamodel.getSessionFactory()
protected SessionFactoryImplementor | AbstractEntityTuplizer.getFactory()

Constructors in org.hibernate.tuple.entity with parameters of type SessionFactoryImplementor
EntityMetamodel(PersistentClass persistentClass, SessionFactoryImplementor sessionFactory)

Uses of SessionFactoryImplementor in org.hibernate.type

Methods in org.hibernate.type with parameters of type SessionFactoryImplementor
boolean | Type.isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory) Compare two instances of the class mapped by this type for persistence "equality" - equality of persistent state.
int | Type.getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory) Get a hashcode, consistent with persistence "equality"
void | Type.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory) A representation of the value to be embedded in an XML element.
String | Type.toLoggableString(Object value, SessionFactoryImplementor factory) A representation of the value to be embedded in a log file.
Object | Type.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory) Return a deep copy of the persistent state, stopping at entities and at collections.
Type | Type.getSemiResolvedType(SessionFactoryImplementor factory) Get the type of a semi-resolved value.
String | NullableType.toXMLString(Object value, SessionFactoryImplementor pc)
String | NullableType.toLoggableString(Object value, SessionFactoryImplementor factory)
void | NullableType.setToXMLNode(org.dom4j.Node xml, Object value, SessionFactoryImplementor factory)
Object | MutableType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
String | MetaType.toLoggableString(Object value, SessionFactoryImplementor factory)
String | MetaType.toXMLString(Object value, SessionFactoryImplementor factory)
Object | MetaType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
void | MetaType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
Object | ImmutableType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
String | EntityType.toLoggableString(Object value, SessionFactoryImplementor factory)
Object | EntityType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Joinable | EntityType.getAssociatedJoinable(SessionFactoryImplementor factory)
String | EntityType.getAssociatedEntityName(SessionFactoryImplementor factory)
String | EntityType.getOnCondition(String alias, SessionFactoryImplementor factory, Map enabledFilters)
Type | EntityType.getSemiResolvedType(SessionFactoryImplementor factory)
int | EntityType.getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory)
boolean | EntityType.isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory)
void | EntityType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
String | CustomType.toXMLString(Object value, SessionFactoryImplementor factory)
Object | CustomType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
void | CustomType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
String | CustomType.toLoggableString(Object value, SessionFactoryImplementor factory)
protected String | CustomCollectionType.renderLoggableString(Object value, SessionFactoryImplementor factory)
Object | CompositeCustomType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
String | CompositeCustomType.toLoggableString(Object value, SessionFactoryImplementor factory)
void | CompositeCustomType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
boolean | ComponentType.isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory)
int | ComponentType.getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory)
String | ComponentType.toLoggableString(Object value, SessionFactoryImplementor factory)
Object | ComponentType.deepCopy(Object component, EntityMode entityMode, SessionFactoryImplementor factory)
void | ComponentType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
String | CollectionType.toLoggableString(Object value, SessionFactoryImplementor factory)
protected String | CollectionType.renderLoggableString(Object value, SessionFactoryImplementor factory)
Object | CollectionType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
Joinable | CollectionType.getAssociatedJoinable(SessionFactoryImplementor factory)
String | CollectionType.getAssociatedEntityName(SessionFactoryImplementor factory)
Type | CollectionType.getElementType(SessionFactoryImplementor factory) Get the Hibernate type of the collection elements
String | CollectionType.getOnCondition(String alias, SessionFactoryImplementor factory, Map enabledFilters)
void | CollectionType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
Object | ClobType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
void | ClobType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
String | ClobType.toLoggableString(Object value, SessionFactoryImplementor factory)
Object | BlobType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
void | BlobType.setToXMLNode(org.dom4j.Node node, Object value, SessionFactoryImplementor factory)
String | BlobType.toLoggableString(Object value, SessionFactoryImplementor factory)
Joinable | AssociationType.getAssociatedJoinable(SessionFactoryImplementor factory) Get the "persister" for this association - a class or collection persister
String | AssociationType.getAssociatedEntityName(SessionFactoryImplementor factory) Get the entity name of the associated entity
String | AssociationType.getOnCondition(String alias, SessionFactoryImplementor factory, Map enabledFilters) Get the "filtering" SQL fragment that is applied in the SQL on clause, in addition to the usual join condition
String | ArrayType.toLoggableString(Object value, SessionFactoryImplementor factory)
Object | AnyType.deepCopy(Object value, EntityMode entityMode, SessionFactoryImplementor factory)
void | AnyType.setToXMLNode(org.dom4j.Node xml, Object value, SessionFactoryImplementor factory)
String | AnyType.toLoggableString(Object value, SessionFactoryImplementor factory)
Joinable | AnyType.getAssociatedJoinable(SessionFactoryImplementor factory)
String | AnyType.getAssociatedEntityName(SessionFactoryImplementor factory)
String | AnyType.getOnCondition(String alias, SessionFactoryImplementor factory, Map enabledFilters)
boolean | AbstractType.isEqual(Object x, Object y, EntityMode entityMode, SessionFactoryImplementor factory)
int | AbstractType.getHashCode(Object x, EntityMode entityMode, SessionFactoryImplementor factory)
Type | AbstractType.getSemiResolvedType(SessionFactoryImplementor factory)

Uses of SessionFactoryImplementor in org.hibernate.usertype

Methods in org.hibernate.usertype with parameters of type SessionFactoryImplementor
 String LoggableUserType.toLoggableString(Object value, SessionFactoryImplementor factory)
Generate a loggable string representation of the collection (value).

Uses of SessionFactoryImplementor in org.hibernate.util

Methods in org.hibernate.util with parameters of type SessionFactoryImplementor
static boolean JTAHelper.isTransactionInProgress(SessionFactoryImplementor factory)
Return true if a JTA transaction is in progress and false in *every* other cases (including in a JDBC transaction).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.engine.SessionImplementor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.engine.SessionImplementor

Packages that use SessionImplementor
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.lock |
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.engine.transaction |
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.exec |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.id.insert |
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.intercept | This package implements an interception mechanism for lazy property fetching, based on CGLIB bytecode instrumentation.
org.hibernate.intercept.cglib |
org.hibernate.intercept.javassist |
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.metadata | This package defines an API for accessing the Hibernate runtime metamodel.
org.hibernate.param |
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.proxy | This package defines a framework for lazy-initializing entity proxies.
org.hibernate.proxy.dom4j |
org.hibernate.proxy.map |
org.hibernate.proxy.pojo |
org.hibernate.proxy.pojo.cglib |
org.hibernate.proxy.pojo.javassist |
org.hibernate.stat | This package exposes statistics about a running Hibernate instance to the application.
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.usertype | Interfaces for user-defined custom types.

Uses of SessionImplementor in org.hibernate.action

Methods in org.hibernate.action that return SessionImplementor
protected SessionImplementor | EntityAction.getSession()
protected SessionImplementor | CollectionAction.getSession()

Constructors in org.hibernate.action with parameters of type SessionImplementor
EntityUpdateAction(Serializable id, Object[] state, int[] dirtyProperties, boolean hasDirtyCollection, Object[] previousState, Object previousVersion, Object nextVersion, Object instance, Object rowId, EntityPersister persister, SessionImplementor session)
EntityInsertAction(Serializable id, Object[] state, Object instance, Object version, EntityPersister persister, SessionImplementor session)
EntityIdentityInsertAction(Object[] state, Object instance, EntityPersister persister, SessionImplementor session, boolean isDelayed)
EntityDeleteAction(Serializable id, Object[] state, Object version, Object instance, EntityPersister persister, boolean isCascadeDeleteEnabled, SessionImplementor session)
EntityAction(SessionImplementor session, Serializable id, Object instance, EntityPersister persister)
CollectionUpdateAction(PersistentCollection collection, CollectionPersister persister, Serializable id, boolean emptySnapshot, SessionImplementor session)
CollectionRemoveAction(PersistentCollection collection, CollectionPersister persister, Serializable id, boolean emptySnapshot, SessionImplementor session)
CollectionRecreateAction(PersistentCollection collection, CollectionPersister persister, Serializable id, SessionImplementor session)
CollectionAction(CollectionPersister persister, PersistentCollection collection, Serializable key, SessionImplementor session)
BulkOperationCleanupAction(SessionImplementor session, Queryable[] affectedQueryables)
BulkOperationCleanupAction(SessionImplementor session, Set querySpaces)
Create an action that will evict collection and entity regions based on queryspaces (table names).

Uses of SessionImplementor in org.hibernate.cache

Methods in org.hibernate.cache with parameters of type SessionImplementor
boolean | StandardQueryCache.put(QueryKey key, Type[] returnTypes, List result, boolean isNaturalKeyLookup, SessionImplementor session)
List | StandardQueryCache.get(QueryKey key, Type[] returnTypes, boolean isNaturalKeyLookup, Set spaces, SessionImplementor session)
boolean | QueryCache.put(QueryKey key, Type[] returnTypes, List result, boolean isNaturalKeyLookup, SessionImplementor session)
List | QueryCache.get(QueryKey key, Type[] returnTypes, boolean isNaturalKeyLookup, Set spaces, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.cache.entry

Constructors in org.hibernate.cache.entry with parameters of type SessionImplementor
CacheEntry(Object[] state, EntityPersister persister, boolean unfetched, Object version, SessionImplementor session, Object owner)

Uses of SessionImplementor in org.hibernate.collection

Methods in org.hibernate.collection that return SessionImplementor
protected  SessionImplementor AbstractPersistentCollection.getSession()
Get the current session

Methods in org.hibernate.collection with parameters of type SessionImplementor
boolean | PersistentCollection.unsetSession(SessionImplementor currentSession) Disassociate this collection from the given session.
boolean | PersistentCollection.setCurrentSession(SessionImplementor session) Associate the collection with the given session.
boolean | AbstractPersistentCollection.unsetSession(SessionImplementor currentSession) Disassociate this collection from the given session.
boolean | AbstractPersistentCollection.setCurrentSession(SessionImplementor session) Associate the collection with the given session.
protected static Collection | AbstractPersistentCollection.getOrphans(Collection oldElements, Collection currentElements, String entityName, SessionImplementor session) Given a collection of entity instances that used to belong to the collection, and a collection of instances that currently belong, return a collection of orphans

Constructors in org.hibernate.collection with parameters of type SessionImplementor
PersistentSortedSet(SessionImplementor session)
PersistentSortedSet(SessionImplementor session, SortedSet set)
PersistentSortedMap(SessionImplementor session)
PersistentSortedMap(SessionImplementor session, SortedMap map)
PersistentSet(SessionImplementor session)
Constructor matching super.
PersistentSet(SessionImplementor session, Set set)
Instantiates a non-lazy set (the underlying set is constructed from the incoming set reference).
PersistentMapElementHolder(SessionImplementor session, org.dom4j.Element element)
PersistentMapElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentMap(SessionImplementor session)
Instantiates a lazy map (the underlying map is un-initialized).
PersistentMap(SessionImplementor session, Map map)
Instantiates a non-lazy map (the underlying map is constructed from the incoming map reference).
PersistentListElementHolder(SessionImplementor session, org.dom4j.Element element)
PersistentListElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentList(SessionImplementor session)
PersistentList(SessionImplementor session, List list)
PersistentIndexedElementHolder(SessionImplementor session, org.dom4j.Element element)
PersistentIndexedElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentIdentifierBag(SessionImplementor session)
PersistentIdentifierBag(SessionImplementor session, Collection coll)
PersistentElementHolder(SessionImplementor session, org.dom4j.Element element)
PersistentElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentBag(SessionImplementor session)
PersistentBag(SessionImplementor session, Collection coll)
PersistentArrayHolder(SessionImplementor session, Object array)
PersistentArrayHolder(SessionImplementor session, CollectionPersister persister)
AbstractPersistentCollection(SessionImplementor session)

Uses of SessionImplementor in org.hibernate.dialect

Methods in org.hibernate.dialect with parameters of type SessionImplementor
 void HSQLDialect.ReadUncommittedLockingStrategy.lock(Serializable id, Object version, Object object, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.dialect.lock

Methods in org.hibernate.dialect.lock with parameters of type SessionImplementor
void | UpdateLockingStrategy.lock(Serializable id, Object version, Object object, SessionImplementor session)
void | SelectLockingStrategy.lock(Serializable id, Object version, Object object, SessionImplementor session)
void | LockingStrategy.lock(Serializable id, Object version, Object object, SessionImplementor session) Acquire an appropriate type of lock on the underlying data that will endure until the end of the current transaction.

Uses of SessionImplementor in org.hibernate.engine

Methods in org.hibernate.engine that return SessionImplementor
SessionImplementor | StatefulPersistenceContext.getSession()
SessionImplementor | PersistenceContext.getSession() Get the session

Methods in org.hibernate.engine with parameters of type SessionImplementor
static Object | Versioning.increment(Object version, VersionType versionType, SessionImplementor session) Increment the given version number
static boolean | Versioning.seedVersion(Object[] fields, int versionProperty, VersionType versionType, SessionImplementor session) Seed the given instance state snapshot with an initial version number
static void | TwoPhaseLoad.postHydrate(EntityPersister persister, Serializable id, Object[] values, Object rowId, Object object, LockMode lockMode, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Register the "hydrated" state of an entity instance, after the first step of 2-phase loading.
static void | TwoPhaseLoad.initializeEntity(Object entity, boolean readOnly, SessionImplementor session, PreLoadEvent preLoadEvent, PostLoadEvent postLoadEvent) Perform the second step of 2-phase load.
static void | TwoPhaseLoad.addUninitializedEntity(EntityKey key, Object object, EntityPersister persister, LockMode lockMode, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Add an uninitialized instance of an entity class, as a placeholder to ensure object identity.
static void | TwoPhaseLoad.addUninitializedCachedEntity(EntityKey key, Object object, EntityPersister persister, LockMode lockMode, boolean lazyPropertiesAreUnfetched, Object version, SessionImplementor session)
Serializable | TransactionHelper.doWorkInNewTransaction(SessionImplementor session) Suspend the current transaction and perform work in a new transaction
static StatefulPersistenceContext | StatefulPersistenceContext.deserialize(ObjectInputStream ois, SessionImplementor session)
void | QueryParameters.processFilters(String sql, SessionImplementor session)
static int | ParameterBinder.bindQueryParameters(PreparedStatement st, QueryParameters queryParameters, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)
static int | ParameterBinder.bindPositionalParameters(PreparedStatement st, QueryParameters queryParameters, int start, SessionImplementor session)
static int | ParameterBinder.bindPositionalParameters(PreparedStatement st, Object[] values, Type[] types, int start, SessionImplementor session)
static int | ParameterBinder.bindNamedParameters(PreparedStatement ps, QueryParameters queryParameters, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)
static int | ParameterBinder.bindNamedParameters(PreparedStatement ps, Map namedParams, int start, ParameterBinder.NamedParameterSource source, SessionImplementor session)
static boolean | ForeignKeys.isNotTransient(String entityName, Object entity, Boolean assumed, SessionImplementor session) Is this instance persistent or detached? If assumed is non-null, don't hit the database to make the determination, instead assume that value; the client code must be prepared to "recover" in the case that this assumed result is incorrect.
static boolean | ForeignKeys.isTransient(String entityName, Object entity, Boolean assumed, SessionImplementor session) Is this instance, which we know is not persistent, actually transient? If assumed is non-null, don't hit the database to make the determination, instead assume that value; the client code must be prepared to "recover" in the case that this assumed result is incorrect.
static Serializable | ForeignKeys.getEntityIdentifierIfNotUnsaved(String entityName, Object object, SessionImplementor session) Return the identifier of the persistent or transient object, or throw an exception if the instance is "unsaved" Used by OneToOneType and ManyToOneType to determine what id value should be used for an object that may or may not be associated with the session.
boolean | EntityEntry.isNullifiable(boolean earlyInsert, SessionImplementor session)
static void | Collections.processUnreachableCollection(PersistentCollection coll, SessionImplementor session) record the fact that this collection was dereferenced
static void | Collections.processReachableCollection(PersistentCollection collection, CollectionType type, Object entity, SessionImplementor session) Initialize the role of the collection.
void | CollectionLoadContext.endLoadingCollections(CollectionPersister persister, Object resultSetId, SessionImplementor session) Finish the process of loading collections for a particular result set
static Iterator | CascadingAction.getLoadedElementsIterator(SessionImplementor session, CollectionType collectionType, Object collection) Iterate just the elements of the collection that are already there.
static ActionQueue | ActionQueue.deserialize(ObjectInputStream ois, SessionImplementor session) Used by the owning session to explicitly control deserialization of the action queue

Constructors in org.hibernate.engine with parameters of type SessionImplementor
StatefulPersistenceContext(SessionImplementor session)
Constructs a PersistentContext, bound to the given session.
Nullability(SessionImplementor session)
ForeignKeys.Nullifier(Object self, boolean isDelete, boolean isEarlyInsert, SessionImplementor session)
ActionQueue(SessionImplementor session)
Constructs an action queue bound to the given session.

Uses of SessionImplementor in org.hibernate.engine.query

Methods in org.hibernate.engine.query with parameters of type SessionImplementor
protected void | NativeSQLQueryPlan.coordinateSharedCacheCleanup(SessionImplementor session)
int | NativeSQLQueryPlan.performExecuteUpdate(QueryParameters queryParameters, SessionImplementor session)
List | HQLQueryPlan.performList(QueryParameters queryParameters, SessionImplementor session)
ScrollableResults | HQLQueryPlan.performScroll(QueryParameters queryParameters, SessionImplementor session)
int | HQLQueryPlan.performExecuteUpdate(QueryParameters queryParameters, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.engine.transaction

Methods in org.hibernate.engine.transaction with parameters of type SessionImplementor
static void | Isolater.doIsolatedWork(IsolatedWork work, SessionImplementor session) Ensures that all processing actually performed by the given work will occur on a seperate transaction.
static void | Isolater.doNonTransactedWork(IsolatedWork work, SessionImplementor session) Ensures that all processing actually performed by the given work will occur outside of a transaction.

Constructors in org.hibernate.engine.transaction with parameters of type SessionImplementor
Isolater.JtaDelegate(SessionImplementor session)
Isolater.JdbcDelegate(SessionImplementor session)

Uses of SessionImplementor in org.hibernate.event

Subinterfaces of SessionImplementor in org.hibernate.event
 interface EventSource

Methods in org.hibernate.event that return SessionImplementor
SessionImplementor | PreUpdateEvent.getSource()
SessionImplementor | PreInsertEvent.getSource()

Constructors in org.hibernate.event with parameters of type SessionImplementor
PreUpdateEvent(Object entity, Serializable id, Object[] state, Object[] oldState, EntityPersister persister, SessionImplementor source)
PreInsertEvent(Object entity, Serializable id, Object[] state, EntityPersister persister, SessionImplementor source)

Uses of SessionImplementor in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type SessionImplementor
protected boolean | DefaultSaveOrUpdateEventListener.reassociateIfUninitializedProxy(Object object, SessionImplementor source)
protected boolean | DefaultSaveEventListener.reassociateIfUninitializedProxy(Object object, SessionImplementor source)
protected boolean | DefaultReplicateEventListener.substituteValuesIfNecessary(Object entity, Serializable id, Object[] values, EntityPersister persister, SessionImplementor source)
protected void | DefaultMergeEventListener.copyValues(EntityPersister persister, Object entity, Object target, SessionImplementor source, Map copyCache)
protected void | DefaultMergeEventListener.copyValues(EntityPersister persister, Object entity, Object target, SessionImplementor source, Map copyCache, ForeignKeyDirection foreignKeyDirection)
protected Object | DefaultLoadEventListener.lockAndLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options, SessionImplementor source) If the class to be loaded has been configured with a cache, then lock given id in that cache and then perform the load.
protected boolean | DefaultFlushEntityEventListener.invokeInterceptor(SessionImplementor session, Object entity, EntityEntry entry, Object[] values, EntityPersister persister)
protected boolean | AbstractSaveEventListener.substituteValuesIfNecessary(Object entity, Serializable id, Object[] values, EntityPersister persister, SessionImplementor source) Perform any property value substitution that is necessary (interceptor callback, version initialization...)
protected int | AbstractSaveEventListener.getEntityState(Object entity, String entityName, EntityEntry entry, SessionImplementor source) Determine whether the entity is persistent, detached, or transient
protected void | AbstractLockUpgradeEventListener.upgradeLock(Object object, EntityEntry entry, LockMode requestedLockMode, SessionImplementor source) Performs a pessimistic lock upgrade on a given entity, if needed.
protected void | AbstractFlushingEventListener.postFlush(SessionImplementor session) 1.

Uses of SessionImplementor in org.hibernate.hql

Methods in org.hibernate.hql with parameters of type SessionImplementor
List | QueryTranslator.list(SessionImplementor session, QueryParameters queryParameters) Perform a list operation given the underlying query definition.
ScrollableResults | QueryTranslator.scroll(QueryParameters queryParameters, SessionImplementor session) Perform a scroll operation given the underlying query defintion.
int | QueryTranslator.executeUpdate(QueryParameters queryParameters, SessionImplementor session) Perform a bulk update/delete operation given the underlying query defintion.

Uses of SessionImplementor in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast with parameters of type SessionImplementor
List | QueryTranslatorImpl.list(SessionImplementor session, QueryParameters queryParameters)
ScrollableResults | QueryTranslatorImpl.scroll(QueryParameters queryParameters, SessionImplementor session) Return the query results, as an instance of ScrollableResults
int | QueryTranslatorImpl.executeUpdate(QueryParameters queryParameters, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.hql.ast.exec

Methods in org.hibernate.hql.ast.exec with parameters of type SessionImplementor
int | StatementExecutor.execute(QueryParameters parameters, SessionImplementor session) Execute the sql managed by this executor using the given parameters.
int | MultiTableUpdateExecutor.execute(QueryParameters parameters, SessionImplementor session)
int | MultiTableDeleteExecutor.execute(QueryParameters parameters, SessionImplementor session)
int | BasicExecutor.execute(QueryParameters parameters, SessionImplementor session)
protected void | AbstractStatementExecutor.createTemporaryTableIfNecessary(Queryable persister, SessionImplementor session)
protected void | AbstractStatementExecutor.dropTemporaryTableIfNecessary(Queryable persister, SessionImplementor session)
protected void | AbstractStatementExecutor.coordinateSharedCacheCleanup(SessionImplementor session)

Uses of SessionImplementor in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic with parameters of type SessionImplementor
List | QueryTranslatorImpl.list(SessionImplementor session, QueryParameters queryParameters)
int | QueryTranslatorImpl.executeUpdate(QueryParameters queryParameters, SessionImplementor session)
protected Object | QueryTranslatorImpl.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
ScrollableResults | QueryTranslatorImpl.scroll(QueryParameters queryParameters, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.id

Methods in org.hibernate.id with parameters of type SessionImplementor
Serializable | UUIDHexGenerator.generate(SessionImplementor session, Object obj)
Serializable | TableHiLoGenerator.generate(SessionImplementor session, Object obj)
Serializable | TableGenerator.generate(SessionImplementor session, Object object)
Serializable | SequenceIdentityGenerator.generate(SessionImplementor s, Object obj)
protected PreparedStatement | SequenceIdentityGenerator.Delegate.prepare(String insertSQL, SessionImplementor session)
Serializable | SequenceHiLoGenerator.generate(SessionImplementor session, Object obj)
Serializable | SequenceGenerator.generate(SessionImplementor session, Object obj)
protected void | SelectGenerator.SelectGeneratorDelegate.bindParameters(SessionImplementor session, PreparedStatement ps, Object entity)
protected Serializable | SelectGenerator.SelectGeneratorDelegate.getResult(SessionImplementor session, ResultSet rs, Object entity)
Serializable | MultipleHiLoPerTableGenerator.generate(SessionImplementor session, Object obj)
Serializable | IncrementGenerator.generate(SessionImplementor session, Object object)
protected PreparedStatement | IdentityGenerator.GetGeneratedKeysDelegate.prepare(String insertSQL, SessionImplementor session)
protected PreparedStatement | IdentityGenerator.InsertSelectDelegate.prepare(String insertSQL, SessionImplementor session)
Serializable | IdentityGenerator.InsertSelectDelegate.determineGeneratedIdentifier(SessionImplementor session, Object entity)
protected Serializable | IdentityGenerator.BasicDelegate.getResult(SessionImplementor session, ResultSet rs, Object object)
Serializable | IdentifierGenerator.generate(SessionImplementor session, Object object) Generate a new identifier.
Serializable | GUIDGenerator.generate(SessionImplementor session, Object obj)
Serializable | ForeignGenerator.generate(SessionImplementor sessionImplementor, Object object)
Serializable | Assigned.generate(SessionImplementor session, Object obj)
Serializable | AbstractPostInsertGenerator.generate(SessionImplementor s, Object obj)

Uses of SessionImplementor in org.hibernate.id.insert

Methods in org.hibernate.id.insert with parameters of type SessionImplementor
 Serializable InsertGeneratedIdentifierDelegate.performInsert(String insertSQL, SessionImplementor session, Binder binder)
Perform the indicated insert SQL statement and determine the identifier value generated.
 Serializable AbstractSelectingDelegate.performInsert(String insertSQL, SessionImplementor session, Binder binder)
protected  void AbstractSelectingDelegate.bindParameters(SessionImplementor session, PreparedStatement ps, Object entity)
Bind any required parameter values into the SQL command AbstractSelectingDelegate.getSelectSQL().
protected abstract  Serializable AbstractSelectingDelegate.getResult(SessionImplementor session, ResultSet rs, Object entity)
Extract the generated key value from the given result set.
 Serializable AbstractReturningDelegate.performInsert(String insertSQL, SessionImplementor session, Binder binder)
protected abstract  PreparedStatement AbstractReturningDelegate.prepare(String insertSQL, SessionImplementor session)
protected  void AbstractReturningDelegate.releaseStatement(PreparedStatement insert, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.impl

Classes in org.hibernate.impl that implement SessionImplementor
class | AbstractSessionImpl Functionality common to stateless and stateful sessions
class | SessionImpl Concrete implementation of a Session, and also the central, organizing component of Hibernate's internal implementation.
class | StatelessSessionImpl

Fields in org.hibernate.impl declared as SessionImplementor
protected  SessionImplementor AbstractQueryImpl.session

Methods in org.hibernate.impl that return SessionImplementor
SessionImplementor | CriteriaImpl.getSession()
protected SessionImplementor | AbstractScrollableResults.getSession()

Methods in org.hibernate.impl with parameters of type SessionImplementor
 void CriteriaImpl.setSession(SessionImplementor session)

Constructors in org.hibernate.impl with parameters of type SessionImplementor
ScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
QueryImpl(String queryString, FlushMode flushMode, SessionImplementor session, ParameterMetadata parameterMetadata)
QueryImpl(String queryString, SessionImplementor session, ParameterMetadata parameterMetadata)
FetchingScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
CriteriaImpl(String entityOrClassName, SessionImplementor session)
CriteriaImpl(String entityOrClassName, String alias, SessionImplementor session)
CollectionFilterImpl(String queryString, Object collection, SessionImplementor session, ParameterMetadata parameterMetadata)
AbstractScrollableResults(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
AbstractQueryImpl(String queryString, FlushMode flushMode, SessionImplementor session, ParameterMetadata parameterMetadata)

Uses of SessionImplementor in org.hibernate.intercept

Methods in org.hibernate.intercept that return SessionImplementor
 SessionImplementor AbstractFieldInterceptor.getSession()

Methods in org.hibernate.intercept with parameters of type SessionImplementor
Object | LazyPropertyInitializer.initializeLazyProperty(String fieldName, Object entity, SessionImplementor session) Initialize the property, and return its new value
void | FieldInterceptor.setSession(SessionImplementor session) Use to associate the entity to which we are bound to the given session.
static FieldInterceptor | FieldInterceptionHelper.injectFieldInterceptor(Object entity, String entityName, Set uninitializedFieldNames, SessionImplementor session)
void | AbstractFieldInterceptor.setSession(SessionImplementor session)

Constructors in org.hibernate.intercept with parameters of type SessionImplementor
AbstractFieldInterceptor(SessionImplementor session, Set uninitializedFields, String entityName)

Uses of SessionImplementor in org.hibernate.intercept.cglib

Methods in org.hibernate.intercept.cglib with parameters of type SessionImplementor
static FieldInterceptor CGLIBHelper.injectFieldInterceptor(Object entity, String entityName, Set uninitializedFieldNames, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.intercept.javassist

Methods in org.hibernate.intercept.javassist with parameters of type SessionImplementor
static FieldInterceptor JavassistHelper.injectFieldInterceptor(Object entity, String entityName, Set uninitializedFieldNames, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.loader

Methods in org.hibernate.loader with parameters of type SessionImplementor
Object | Loader.loadSingleRow(ResultSet resultSet, SessionImplementor session, QueryParameters queryParameters, boolean returnProxies) Loads a single row from the result set.
Object | Loader.loadSequentialRowsForward(ResultSet resultSet, SessionImplementor session, QueryParameters queryParameters, boolean returnProxies) Loads a single logical row from the result set moving forward.
Object | Loader.loadSequentialRowsReverse(ResultSet resultSet, SessionImplementor session, QueryParameters queryParameters, boolean returnProxies, boolean isLogicallyAfterLast) Loads a single logical row from the result set moving forward.
protected Object | Loader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session) Get the actual object that is returned in the user-visible result list.
protected int | Loader.bindPositionalParameters(PreparedStatement st, QueryParameters queryParameters, int start, SessionImplementor session) Bind positional parameter values to the PreparedStatement (these are parameters specified by a JDBC-style ?).
protected PreparedStatement | Loader.prepareQueryStatement(QueryParameters queryParameters, boolean scroll, SessionImplementor session) Obtain a PreparedStatement with all parameters pre-bound.
protected ResultSet | Loader.getResultSet(PreparedStatement st, boolean autodiscovertypes, boolean callable, RowSelection selection, SessionImplementor session) Fetch a PreparedStatement, call setMaxRows and then execute it, advance to the first result and return an SQL ResultSet
protected int | Loader.bindNamedParameters(PreparedStatement ps, Map namedParams, int start, SessionImplementor session) Bind named parameters to the PreparedStatement.
protected List | Loader.loadEntity(SessionImplementor session, Object id, Type identifierType, Object optionalObject, String optionalEntityName, Serializable optionalIdentifier, EntityPersister persister) Called by subclasses that load entities
protected List | Loader.loadEntity(SessionImplementor session, Object key, Object index, Type keyType, Type indexType, EntityPersister persister) Called by subclasses that load entities
List | Loader.loadEntityBatch(SessionImplementor session, Serializable[] ids, Type idType, Object optionalObject, String optionalEntityName, Serializable optionalId, EntityPersister persister) Called by wrappers that batch load entities
void | Loader.loadCollection(SessionImplementor session, Serializable id, Type type) Called by subclasses that initialize collections
void | Loader.loadCollectionBatch(SessionImplementor session, Serializable[] ids, Type type) Called by wrappers that batch initialize collections
protected void | Loader.loadCollectionSubselect(SessionImplementor session, Serializable[] ids, Object[] parameterValues, Type[] parameterTypes, Map namedParameters, Type type) Called by subclasses that batch initialize collections
protected List | Loader.list(SessionImplementor session, QueryParameters queryParameters, Set querySpaces, Type[] resultTypes) Return the query results, using the query cache, called by subclasses that implement cacheable queries
protected List | Loader.doList(SessionImplementor session, QueryParameters queryParameters) Actually execute a query, ignoring the query cache
protected ScrollableResults | Loader.scroll(QueryParameters queryParameters, Type[] returnTypes, HolderInstantiator holderInstantiator, SessionImplementor session) Return the query results, as an instance of ScrollableResults

Uses of SessionImplementor in org.hibernate.loader.collection

Methods in org.hibernate.loader.collection with parameters of type SessionImplementor
void | SubselectOneToManyLoader.initialize(Serializable id, SessionImplementor session)
void | SubselectCollectionLoader.initialize(Serializable id, SessionImplementor session)
void | CollectionLoader.initialize(Serializable id, SessionImplementor session)
void | CollectionInitializer.initialize(Serializable id, SessionImplementor session) Initialize the given collection
void | BatchingCollectionInitializer.initialize(Serializable id, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria with parameters of type SessionImplementor
ScrollableResults | CriteriaLoader.scroll(SessionImplementor session, ScrollMode scrollMode)
List | CriteriaLoader.list(SessionImplementor session)
protected Object | CriteriaLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.loader.custom

Methods in org.hibernate.loader.custom with parameters of type SessionImplementor
List | CustomLoader.list(SessionImplementor session, QueryParameters queryParameters)
ScrollableResults | CustomLoader.scroll(QueryParameters queryParameters, SessionImplementor session)
protected Object | CustomLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
Object | CustomLoader.ResultRowProcessor.buildResultRow(Object[] data, ResultSet resultSet, boolean hasTransformer, SessionImplementor session) Build a logical result row.
Object | CustomLoader.NonScalarResultColumnProcessor.extract(Object[] data, ResultSet resultSet, SessionImplementor session)
Object | CustomLoader.ScalarResultColumnProcessor.extract(Object[] data, ResultSet resultSet, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.loader.entity

Methods in org.hibernate.loader.entity with parameters of type SessionImplementor
Object | UniqueEntityLoader.load(Serializable id, Object optionalObject, SessionImplementor session) Load an entity instance.
Object | EntityLoader.loadByUniqueKey(SessionImplementor session, Object key)
Object | CollectionElementLoader.loadElement(SessionImplementor session, Object key, Object index)
protected Object | CollectionElementLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
Object | BatchingEntityLoader.load(Serializable id, Object optionalObject, SessionImplementor session)
Object | AbstractEntityLoader.load(Serializable id, Object optionalObject, SessionImplementor session)
protected Object | AbstractEntityLoader.load(SessionImplementor session, Object id, Object optionalObject, Serializable optionalId)
protected Object | AbstractEntityLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.loader.hql

Methods in org.hibernate.loader.hql with parameters of type SessionImplementor
protected Object | QueryLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
List | QueryLoader.list(SessionImplementor session, QueryParameters queryParameters) Delegats
ScrollableResults | QueryLoader.scroll(QueryParameters queryParameters, SessionImplementor session)
protected int | QueryLoader.bindNamedParameters(PreparedStatement ps, Map namedParams, int start, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.metadata

Methods in org.hibernate.metadata with parameters of type SessionImplementor
 Object[] ClassMetadata.getPropertyValuesToInsert(Object entity, Map mergeMap, SessionImplementor session)
Return the values of the mapped properties of the object

Uses of SessionImplementor in org.hibernate.param

Methods in org.hibernate.param with parameters of type SessionImplementor
int | VersionTypeSeedParameterSpecification.bind(PreparedStatement statement, QueryParameters qp, SessionImplementor session, int position)
int | PositionalParameterSpecification.bind(PreparedStatement statement, QueryParameters qp, SessionImplementor session, int position) Bind the appropriate value into the given statement at the specified position.
int | ParameterSpecification.bind(PreparedStatement statement, QueryParameters qp, SessionImplementor session, int position) Bind the appropriate value into the given statement at the specified position.
int | NamedParameterSpecification.bind(PreparedStatement statement, QueryParameters qp, SessionImplementor session, int position) Bind the appropriate value into the given statement at the specified position.

Uses of SessionImplementor in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection with parameters of type SessionImplementor
protected int | OneToManyPersister.doUpdateRows(Serializable id, PersistentCollection collection, SessionImplementor session)
protected CollectionInitializer | OneToManyPersister.createSubselectInitializer(SubselectFetch subselect, SessionImplementor session)
Object | OneToManyPersister.getElementByIndex(Serializable key, Object index, SessionImplementor session, Object owner)
void | NamedQueryCollectionInitializer.initialize(Serializable key, SessionImplementor session)
void | CollectionPersister.initialize(Serializable key, SessionImplementor session) Initialize the given collection with the given key
Object | CollectionPersister.readKey(ResultSet rs, String[] keyAliases, SessionImplementor session) Read the key from a row of the JDBC ResultSet
Object | CollectionPersister.readElement(ResultSet rs, Object owner, String[] columnAliases, SessionImplementor session) Read the element from a row of the JDBC ResultSet
Object | CollectionPersister.readIndex(ResultSet rs, String[] columnAliases, SessionImplementor session) Read the index from a row of the JDBC ResultSet
Object | CollectionPersister.readIdentifier(ResultSet rs, String columnAlias, SessionImplementor session) Read the identifier from a row of the JDBC ResultSet
void | CollectionPersister.remove(Serializable id, SessionImplementor session) Completely remove the persistent state of the collection
void | CollectionPersister.recreate(PersistentCollection collection, Serializable key, SessionImplementor session) (Re)create the collection's persistent state
void | CollectionPersister.deleteRows(PersistentCollection collection, Serializable key, SessionImplementor session) Delete the persistent state of any elements that were removed from the collection
void | CollectionPersister.updateRows(PersistentCollection collection, Serializable key, SessionImplementor session) Update the persistent state of any elements that were modified
void | CollectionPersister.insertRows(PersistentCollection collection, Serializable key, SessionImplementor session) Insert the persistent state of any new collection elements
boolean | CollectionPersister.isAffectedByEnabledFilters(SessionImplementor session)
int | CollectionPersister.getSize(Serializable key, SessionImplementor session)
boolean | CollectionPersister.indexExists(Serializable key, Object index, SessionImplementor session)
boolean | CollectionPersister.elementExists(Serializable key, Object element, SessionImplementor session)
Object | CollectionPersister.getElementByIndex(Serializable key, Object index, SessionImplementor session, Object owner)
protected int | BasicCollectionPersister.doUpdateRows(Serializable id, PersistentCollection collection, SessionImplementor session)
protected CollectionInitializer | BasicCollectionPersister.createSubselectInitializer(SubselectFetch subselect, SessionImplementor session)
void | AbstractCollectionPersister.initialize(Serializable key, SessionImplementor session)
protected CollectionInitializer | AbstractCollectionPersister.getAppropriateInitializer(Serializable key, SessionImplementor session)
protected abstract CollectionInitializer | AbstractCollectionPersister.createSubselectInitializer(SubselectFetch subselect, SessionImplementor session)
Object | AbstractCollectionPersister.readElement(ResultSet rs, Object owner, String[] aliases, SessionImplementor session)
Object | AbstractCollectionPersister.readIndex(ResultSet rs, String[] aliases, SessionImplementor session)
Object | AbstractCollectionPersister.readIdentifier(ResultSet rs, String alias, SessionImplementor session)
Object | AbstractCollectionPersister.readKey(ResultSet rs, String[] aliases, SessionImplementor session)
protected int | AbstractCollectionPersister.writeKey(PreparedStatement st, Serializable key, int i, SessionImplementor session) Write the key to a JDBC PreparedStatement
protected int | AbstractCollectionPersister.writeElement(PreparedStatement st, Object elt, int i, SessionImplementor session) Write the element to a JDBC PreparedStatement
protected int | AbstractCollectionPersister.writeIndex(PreparedStatement st, Object index, int i, SessionImplementor session) Write the index to a JDBC PreparedStatement
protected int | AbstractCollectionPersister.writeElementToWhere(PreparedStatement st, Object elt, int i, SessionImplementor session) Write the element to a JDBC PreparedStatement
protected int | AbstractCollectionPersister.writeIndexToWhere(PreparedStatement st, Object index, int i, SessionImplementor session) Write the index to a JDBC PreparedStatement
int | AbstractCollectionPersister.writeIdentifier(PreparedStatement st, Object id, int i, SessionImplementor session) Write the identifier to a JDBC PreparedStatement
void | AbstractCollectionPersister.remove(Serializable id, SessionImplementor session)
void | AbstractCollectionPersister.recreate(PersistentCollection collection, Serializable id, SessionImplementor session)
void | AbstractCollectionPersister.deleteRows(PersistentCollection collection, Serializable id, SessionImplementor session)
void | AbstractCollectionPersister.insertRows(PersistentCollection collection, Serializable id, SessionImplementor session)
void | AbstractCollectionPersister.updateRows(PersistentCollection collection, Serializable id, SessionImplementor session)
protected abstract int | AbstractCollectionPersister.doUpdateRows(Serializable key, PersistentCollection collection, SessionImplementor session)
boolean | AbstractCollectionPersister.isAffectedByEnabledFilters(SessionImplementor session)
int | AbstractCollectionPersister.getSize(Serializable key, SessionImplementor session)
boolean | AbstractCollectionPersister.indexExists(Serializable key, Object index, SessionImplementor session)
boolean | AbstractCollectionPersister.elementExists(Serializable key, Object element, SessionImplementor session)
Object | AbstractCollectionPersister.getElementByIndex(Serializable key, Object index, SessionImplementor session, Object owner)

Uses of SessionImplementor in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity with parameters of type SessionImplementor
Object | UniqueKeyLoadable.loadByUniqueKey(String propertyName, Object uniqueKey, SessionImplementor session) Load an instance of the persistent class, by a unique key other than the primary key.
Object | NamedQueryLoader.load(Serializable id, Object optionalObject, SessionImplementor session)
Object[] | Loadable.hydrate(ResultSet rs, Serializable id, Object object, Loadable rootLoadable, String[][] suffixedPropertyColumns, boolean allProperties, SessionImplementor session) Retrieve property values from one row of a result set
int[] | EntityPersister.findDirty(Object[] x, Object[] y, Object owner, SessionImplementor session) Compare two snapshots of the state of an instance to determine if the persistent state was modified
int[] | EntityPersister.findModified(Object[] old, Object[] current, Object object, SessionImplementor session) Compare the state of an instance to the current database state
Object[] | EntityPersister.getNaturalIdentifierSnapshot(Serializable id, SessionImplementor session) Retrieve the current state of the natural-id properties from the database.
Object | EntityPersister.load(Serializable id, Object optionalObject, LockMode lockMode, SessionImplementor session) Load an instance of the persistent class.
void | EntityPersister.lock(Serializable id, Object version, Object object, LockMode lockMode, SessionImplementor session) Do a version check (optional operation)
void | EntityPersister.insert(Serializable id, Object[] fields, Object object, SessionImplementor session) Persist an instance
Serializable | EntityPersister.insert(Object[] fields, Object object, SessionImplementor session) Persist an instance, using a natively generated identifier (optional operation)
void | EntityPersister.delete(Serializable id, Object version, Object object, SessionImplementor session) Delete a persistent instance
void | EntityPersister.update(Serializable id, Object[] fields, int[] dirtyFields, boolean hasDirtyCollection, Object[] oldFields, Object oldVersion, Object object, Object rowId, SessionImplementor session) Update a persistent instance
Object[] | EntityPersister.getDatabaseSnapshot(Serializable id, SessionImplementor session) Get the current database state of the object, in a "hydrated" form, without resolving identifiers
Object | EntityPersister.getCurrentVersion(Serializable id, SessionImplementor session) Get the current version of the object, or return null if there is no row for the given identifier.
Object | EntityPersister.forceVersionIncrement(Serializable id, Object currentVersion, SessionImplementor session)
void | EntityPersister.afterInitialize(Object entity, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Called just after the entities properties have been initialized
void | EntityPersister.afterReassociate(Object entity, SessionImplementor session) Called just after the entity has been reassociated with the session
Object | EntityPersister.createProxy(Serializable id, SessionImplementor session) Create a new proxy instance
Boolean | EntityPersister.isTransient(Object object, SessionImplementor session) Is this a new transient instance?
Object[] | EntityPersister.getPropertyValuesToInsert(Object object, Map mergeMap, SessionImplementor session) Return the values of the insertable properties of the object (including backrefs)
void | EntityPersister.processInsertGeneratedProperties(Serializable id, Object entity, Object[] state, SessionImplementor session) Perform a select to retrieve the values of any generated properties back from the database, injecting these generated values into the given entity as well as writing this state to the PersistenceContext.
void | EntityPersister.processUpdateGeneratedProperties(Serializable id, Object entity, Object[] state, SessionImplementor session) Perform a select to retrieve the values of any generated properties back from the database, injecting these generated values into the given entity as well as writing this state to the PersistenceContext.
Object | AbstractEntityPersister.initializeLazyProperty(String fieldName, Object entity, SessionImplementor session)
Object[] | AbstractEntityPersister.getDatabaseSnapshot(Serializable id, SessionImplementor session)
Object | AbstractEntityPersister.forceVersionIncrement(Serializable id, Object currentVersion, SessionImplementor session)
Object | AbstractEntityPersister.getCurrentVersion(Serializable id, SessionImplementor session) Retrieve the version number
void | AbstractEntityPersister.lock(Serializable id, Object version, Object object, LockMode lockMode, SessionImplementor session)
Object | AbstractEntityPersister.loadByUniqueKey(String propertyName, Object uniqueKey, SessionImplementor session)
protected int | AbstractEntityPersister.dehydrate(Serializable id, Object[] fields, boolean[] includeProperty, boolean[][] includeColumns, int j, PreparedStatement st, SessionImplementor session)
protected int | AbstractEntityPersister.dehydrate(Serializable id, Object[] fields, Object rowId, boolean[] includeProperty, boolean[][] includeColumns, int j, PreparedStatement ps, SessionImplementor session, int index) Marshall the fields of a persistent instance to a prepared statement
Object[] | AbstractEntityPersister.hydrate(ResultSet rs, Serializable id, Object object, Loadable rootLoadable, String[][] suffixedPropertyColumns, boolean allProperties, SessionImplementor session) Unmarshall the fields of a persistent instance from a result set, without resolving associations or collections.
protected Serializable | AbstractEntityPersister.insert(Object[] fields, boolean[] notNull, String sql, Object object, SessionImplementor session) Perform an SQL INSERT, and then retrieve a generated identifier.
protected void | AbstractEntityPersister.insert(Serializable id, Object[] fields, boolean[] notNull, int j, String sql, Object object, SessionImplementor session) Perform an SQL INSERT.
protected void | AbstractEntityPersister.updateOrInsert(Serializable id, Object[] fields, Object[] oldFields, Object rowId, boolean[] includeProperty, int j, Object oldVersion, Object object, String sql, SessionImplementor session) Perform an SQL UPDATE or SQL INSERT
protected boolean | AbstractEntityPersister.update(Serializable id, Object[] fields, Object[] oldFields, Object rowId, boolean[] includeProperty, int j, Object oldVersion, Object object, String sql, SessionImplementor session)
protected void | AbstractEntityPersister.delete(Serializable id, Object version, int j, Object object, String sql, SessionImplementor session, Object[] loadedState) Perform an SQL DELETE
void | AbstractEntityPersister.update(Serializable id, Object[] fields, int[] dirtyFields, boolean hasDirtyCollection, Object[] oldFields, Object oldVersion, Object object, Object rowId, SessionImplementor session) Update an object
Serializable | AbstractEntityPersister.insert(Object[] fields, Object object, SessionImplementor session)
void | AbstractEntityPersister.insert(Serializable id, Object[] fields, Object object, SessionImplementor session)
void | AbstractEntityPersister.delete(Serializable id, Object version, Object object, SessionImplementor session) Delete an object
Object | AbstractEntityPersister.load(Serializable id, Object optionalObject, LockMode lockMode, SessionImplementor session) Load an instance using either the forUpdateLoader or the outer joining loader, depending upon the value of the lock parameter
int[] | AbstractEntityPersister.findDirty(Object[] currentState, Object[] previousState, Object entity, SessionImplementor session) Locate the property-indices of all properties considered to be dirty.
int[] | AbstractEntityPersister.findModified(Object[] old, Object[] current, Object entity, SessionImplementor session) Locate the property-indices of all properties considered to be dirty.
protected EntityTuplizer | AbstractEntityPersister.getTuplizer(SessionImplementor session)
void | AbstractEntityPersister.afterReassociate(Object entity, SessionImplementor session)
Boolean | AbstractEntityPersister.isTransient(Object entity, SessionImplementor session)
Object | AbstractEntityPersister.createProxy(Serializable id, SessionImplementor session)
void | AbstractEntityPersister.afterInitialize(Object entity, boolean lazyPropertiesAreUnfetched, SessionImplementor session)
Object[] | AbstractEntityPersister.getPropertyValuesToInsert(Object object, Map mergeMap, SessionImplementor session)
void | AbstractEntityPersister.processInsertGeneratedProperties(Serializable id, Object entity, Object[] state, SessionImplementor session)
void | AbstractEntityPersister.processUpdateGeneratedProperties(Serializable id, Object entity, Object[] state, SessionImplementor session)
Object[] | AbstractEntityPersister.getNaturalIdentifierSnapshot(Serializable id, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.property

Methods in org.hibernate.property with parameters of type SessionImplementor
Object | MapAccessor.MapGetter.getForInsert(Object target, Map mergeMap, SessionImplementor session)
Object | IndexPropertyAccessor.IndexGetter.getForInsert(Object target, Map mergeMap, SessionImplementor session)
Object | Getter.getForInsert(Object owner, Map mergeMap, SessionImplementor session) Get the property value from the given owner instance.
Object | EmbeddedPropertyAccessor.EmbeddedGetter.getForInsert(Object target, Map mergeMap, SessionImplementor session)
Object | Dom4jAccessor.Dom4jGetter.getForInsert(Object owner, Map mergeMap, SessionImplementor session)
Object | DirectPropertyAccessor.DirectGetter.getForInsert(Object target, Map mergeMap, SessionImplementor session)
Object | BasicPropertyAccessor.BasicGetter.getForInsert(Object target, Map mergeMap, SessionImplementor session)
Object | BackrefPropertyAccessor.BackrefGetter.getForInsert(Object target, Map mergeMap, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.proxy

Methods in org.hibernate.proxy that return SessionImplementor
SessionImplementor | LazyInitializer.getSession() Get the session, if this proxy is attached
SessionImplementor | AbstractLazyInitializer.getSession()

Methods in org.hibernate.proxy with parameters of type SessionImplementor
HibernateProxy | ProxyFactory.getProxy(Serializable id, SessionImplementor session) Create a new proxy instance
void | LazyInitializer.setSession(SessionImplementor s) Attach the proxy to a session
Object | LazyInitializer.getImplementation(SessionImplementor s) Return the underlying persistent object in the given Session, or null
void | AbstractLazyInitializer.setSession(SessionImplementor s)
Object | AbstractLazyInitializer.getImplementation(SessionImplementor s) Return the underlying persistent object in the given Session, or null, do not initialize the proxy

Constructors in org.hibernate.proxy with parameters of type SessionImplementor
AbstractLazyInitializer(String entityName, Serializable id, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.proxy.dom4j

Methods in org.hibernate.proxy.dom4j with parameters of type SessionImplementor
 HibernateProxy Dom4jProxyFactory.getProxy(Serializable id, SessionImplementor session)
Create a new proxy

Uses of SessionImplementor in org.hibernate.proxy.map

Methods in org.hibernate.proxy.map with parameters of type SessionImplementor
 HibernateProxy MapProxyFactory.getProxy(Serializable id, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.proxy.pojo

Constructors in org.hibernate.proxy.pojo with parameters of type SessionImplementor
BasicLazyInitializer(String entityName, Class persistentClass, Serializable id, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.proxy.pojo.cglib

Methods in org.hibernate.proxy.pojo.cglib with parameters of type SessionImplementor
HibernateProxy | CGLIBProxyFactory.getProxy(Serializable id, SessionImplementor session)
static HibernateProxy | CGLIBLazyInitializer.getProxy(Class factory, String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.proxy.pojo.javassist

Methods in org.hibernate.proxy.pojo.javassist with parameters of type SessionImplementor
HibernateProxy | JavassistProxyFactory.getProxy(Serializable id, SessionImplementor session)
static HibernateProxy | JavassistLazyInitializer.getProxy(String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)
static HibernateProxy | JavassistLazyInitializer.getProxy(Class factory, String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.stat

Constructors in org.hibernate.stat with parameters of type SessionImplementor
SessionStatisticsImpl(SessionImplementor session)

Uses of SessionImplementor in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity with parameters of type SessionImplementor
Object[] | PojoEntityTuplizer.getPropertyValuesToInsert(Object entity, Map mergeMap, SessionImplementor session)
void | PojoEntityTuplizer.afterInitialize(Object entity, boolean lazyPropertiesAreUnfetched, SessionImplementor session)
Object[] | EntityTuplizer.getPropertyValuesToInsert(Object entity, Map mergeMap, SessionImplementor session) Extract the values of the insertable properties of the entity (including backrefs)
void | EntityTuplizer.afterInitialize(Object entity, boolean lazyPropertiesAreUnfetched, SessionImplementor session) Called just after the entities properties have been initialized.
Object | EntityTuplizer.createProxy(Serializable id, SessionImplementor session) Generates an appropriate proxy representation of this entity for this entity-mode.
Object[] | AbstractEntityTuplizer.getPropertyValuesToInsert(Object entity, Map mergeMap, SessionImplementor session)
void | AbstractEntityTuplizer.afterInitialize(Object entity, boolean lazyPropertiesAreUnfetched, SessionImplementor session)
Object | AbstractEntityTuplizer.createProxy(Serializable id, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.type

Methods in org.hibernate.type with parameters of type SessionImplementor
Object | VersionType.seed(SessionImplementor session) Generate an initial version.
Object | VersionType.next(Object current, SessionImplementor session) Increment the version.
static void | TypeFactory.deepCopy(Object[] values, Type[] types, boolean[] copy, Object[] target, SessionImplementor session) Deep copy values in the first array into the second
static void | TypeFactory.beforeAssemble(Serializable[] row, Type[] types, SessionImplementor session) Determine if any of the given field values are modified, returning an array containing indexes of the dirty fields or null if no fields are dirty.
static Object[] | TypeFactory.assemble(Serializable[] row, Type[] types, SessionImplementor session, Object owner)
static Serializable[] | TypeFactory.disassemble(Object[] row, Type[] types, boolean[] nonCacheable, SessionImplementor session, Object owner)
static Object[] | TypeFactory.replace(Object[] original, Object[] target, Type[] types, SessionImplementor session, Object owner, Map copyCache)
static Object[] | TypeFactory.replace(Object[] original, Object[] target, Type[] types, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)
static int[] | TypeFactory.findDirty(StandardProperty[] properties, Object[] x, Object[] y, boolean[][] includeColumns, boolean anyUninitializedProperties, SessionImplementor session) Determine if any of the given field values are dirty, returning an array containing indexes of the dirty fields or null if no fields are dirty.
static int[] | TypeFactory.findModified(StandardProperty[] properties, Object[] x, Object[] y, boolean[][] includeColumns, boolean anyUninitializedProperties, SessionImplementor session) Determine if any of the given field values are modified, returning an array containing indexes of the dirty fields or null if no fields are dirty.
boolean | Type.isDirty(Object old, Object current, SessionImplementor session) Should the parent be considered dirty, given both the old and current field or element value?
boolean | Type.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session) Should the parent be considered dirty, given both the old and current field or element value?
boolean | Type.isModified(Object oldHydratedState, Object currentState, boolean[] checkable, SessionImplementor session) Has the parent object been modified, compared to the current database state?
Object | Type.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
Object | Type.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
void | Type.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session) Write an instance of the mapped class to a prepared statement, ignoring some columns.
void | Type.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session) Write an instance of the mapped class to a prepared statement.
Serializable | Type.disassemble(Object value, SessionImplementor session, Object owner) Return a cacheable "disassembled" representation of the object.
Object | Type.assemble(Serializable cached, SessionImplementor session, Object owner) Reconstruct the object from its cached "disassembled" state.
void | Type.beforeAssemble(Serializable cached, SessionImplementor session) Called before assembling a query result set from the query cache, to allow batch fetching of entities missing from the second-level cache.
Object | Type.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner) Retrieve an instance of the mapped class, or the identifier of an entity or collection, from a JDBC resultset.
Object | Type.resolve(Object value, SessionImplementor session, Object owner) Map identifiers to entities or collections.
Object | Type.semiResolve(Object value, SessionImplementor session, Object owner) Given a hydrated, but unresolved value, return a value that may be used to reconstruct property-ref associations.
Object | Type.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
Object | Type.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
Object | TimestampType.next(Object current, SessionImplementor session)
Object | TimestampType.seed(SessionImplementor session)
Object | SpecialOneToOneType.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Serializable | SpecialOneToOneType.disassemble(Object value, SessionImplementor session, Object owner)
Object | SpecialOneToOneType.assemble(Serializable oid, SessionImplementor session, Object owner)
PersistentCollection | SortedSetType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | SortedSetType.wrap(SessionImplementor session, Object collection)
PersistentCollection | SortedMapType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | SortedMapType.wrap(SessionImplementor session, Object collection)
Object | ShortType.next(Object current, SessionImplementor session)
Object | ShortType.seed(SessionImplementor session)
PersistentCollection | SetType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | SetType.wrap(SessionImplementor session, Object collection)
Object | SerializableType.assemble(Serializable cached, SessionImplementor session, Object owner)
Serializable | SerializableType.disassemble(Object value, SessionImplementor session, Object owner)
boolean | OneToOneType.isNull(Object owner, SessionImplementor session)
void | OneToOneType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | OneToOneType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
boolean | OneToOneType.isDirty(Object old, Object current, SessionImplementor session)
boolean | OneToOneType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
boolean | OneToOneType.isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | OneToOneType.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Serializable | OneToOneType.disassemble(Object value, SessionImplementor session, Object owner)
Object | OneToOneType.assemble(Serializable oid, SessionImplementor session, Object owner)
void | NullableType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | NullableType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Object | NullableType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | NullableType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
boolean | NullableType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | MutableType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
Object | MetaType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | MetaType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
void | MetaType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
void | MetaType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
Object | MetaType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
boolean | MetaType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
PersistentCollection | MapType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | MapType.wrap(SessionImplementor session, Object collection)
Object | MapType.replaceElements(Object original, Object target, Object owner, Map copyCache, SessionImplementor session)
void | ManyToOneType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | ManyToOneType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Object | ManyToOneType.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
boolean | ManyToOneType.isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
Serializable | ManyToOneType.disassemble(Object value, SessionImplementor session, Object owner)
Object | ManyToOneType.assemble(Serializable oid, SessionImplementor session, Object owner)
void | ManyToOneType.beforeAssemble(Serializable oid, SessionImplementor session)
boolean | ManyToOneType.isDirty(Object old, Object current, SessionImplementor session)
boolean | ManyToOneType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | LongType.next(Object current, SessionImplementor session)
Object | LongType.seed(SessionImplementor session)
PersistentCollection | ListType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | ListType.wrap(SessionImplementor session, Object collection)
Object | IntegerType.next(Object current, SessionImplementor session)
Object | IntegerType.seed(SessionImplementor session)
Object | ImmutableType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
PersistentCollection | IdentifierBagType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | IdentifierBagType.wrap(SessionImplementor session, Object collection)
Object | EntityType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
protected Object | EntityType.getIdentifier(Object value, SessionImplementor session)
protected boolean | EntityType.isNotEmbedded(SessionImplementor session)
Object | EntityType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
Object | EntityType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
protected Object | EntityType.resolveIdentifier(Serializable id, SessionImplementor session) Resolve an identifier
protected boolean | EntityType.isNull(Object owner, SessionImplementor session)
Object | EntityType.resolve(Object value, SessionImplementor session, Object owner) Resolve an identifier or unique key value
Object | EntityType.loadByUniqueKey(String entityName, String uniqueKeyPropertyName, Object key, SessionImplementor session) Load an instance by a unique key that is not the primary key.
Object | EmbeddedComponentType.instantiate(Object parent, SessionImplementor session)
Object | DbTimestampType.seed(SessionImplementor session)
Object | CustomType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | CustomType.nullSafeGet(ResultSet rs, String columnName, SessionImplementor session, Object owner)
Object | CustomType.assemble(Serializable cached, SessionImplementor session, Object owner)
Serializable | CustomType.disassemble(Object value, SessionImplementor session, Object owner)
Object | CustomType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
void | CustomType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | CustomType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Object | CustomType.next(Object current, SessionImplementor session)
Object | CustomType.seed(SessionImplementor session)
boolean | CustomType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
PersistentCollection | CustomCollectionType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | CustomCollectionType.wrap(SessionImplementor session, Object collection)
boolean | CustomCollectionType.contains(Object collection, Object entity, SessionImplementor session)
Object | CustomCollectionType.replaceElements(Object original, Object target, Object owner, Map copyCache, SessionImplementor session)
Object[] | CompositeCustomType.getPropertyValues(Object component, SessionImplementor session)
Object | CompositeCustomType.getPropertyValue(Object component, int i, SessionImplementor session)
Object | CompositeCustomType.assemble(Serializable cached, SessionImplementor session, Object owner)
Serializable | CompositeCustomType.disassemble(Object value, SessionImplementor session, Object owner)
Object | CompositeCustomType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
Object | CompositeCustomType.nullSafeGet(ResultSet rs, String columnName, SessionImplementor session, Object owner)
Object | CompositeCustomType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
void | CompositeCustomType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
void | CompositeCustomType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
boolean | CompositeCustomType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
boolean | ComponentType.isDirty(Object x, Object y, SessionImplementor session)
boolean | ComponentType.isDirty(Object x, Object y, boolean[] checkable, SessionImplementor session)
boolean | ComponentType.isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | ComponentType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
void | ComponentType.nullSafeSet(PreparedStatement st, Object value, int begin, SessionImplementor session)
void | ComponentType.nullSafeSet(PreparedStatement st, Object value, int begin, boolean[] settable, SessionImplementor session)
Object | ComponentType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Object | ComponentType.getPropertyValue(Object component, int i, SessionImplementor session)
Object[] | ComponentType.getPropertyValues(Object component, SessionImplementor session)
Object | ComponentType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
Object | ComponentType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)
Object | ComponentType.instantiate(Object parent, SessionImplementor session)
Serializable | ComponentType.disassemble(Object value, SessionImplementor session, Object owner)
Object | ComponentType.assemble(Serializable object, SessionImplementor session, Object owner)
Object | ComponentType.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | ComponentType.resolve(Object value, SessionImplementor session, Object owner)
Object | ComponentType.semiResolve(Object value, SessionImplementor session, Object owner)
boolean | CollectionType.contains(Object collection, Object childObject, SessionImplementor session)
abstract PersistentCollection | CollectionType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key) Instantiate an uninitialized collection wrapper or holder.
Object | CollectionType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Object | CollectionType.nullSafeGet(ResultSet rs, String[] name, SessionImplementor session, Object owner)
void | CollectionType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | CollectionType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Iterator | CollectionType.getElementsIterator(Object collection, SessionImplementor session) Get an iterator over the element set of the collection, which may not yet be wrapped
Serializable | CollectionType.disassemble(Object value, SessionImplementor session, Object owner)
Object | CollectionType.assemble(Serializable cached, SessionImplementor session, Object owner)
boolean | CollectionType.isDirty(Object old, Object current, SessionImplementor session)
boolean | CollectionType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
abstract PersistentCollection | CollectionType.wrap(SessionImplementor session, Object collection) Wrap the naked collection instance in a wrapper, or instantiate a holder.
Serializable | CollectionType.getKeyOfOwner(Object owner, SessionImplementor session) Get the key value from the owning entity instance, usually the identifier, but might be some other unique key, in the case of property-ref
Object | CollectionType.hydrate(ResultSet rs, String[] name, SessionImplementor session, Object owner)
Object | CollectionType.resolve(Object value, SessionImplementor session, Object owner)
Object | CollectionType.semiResolve(Object value, SessionImplementor session, Object owner)
boolean | CollectionType.isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | CollectionType.replaceElements(Object original, Object target, Object owner, Map copyCache, SessionImplementor session) Replace the elements of a collection with the elements of another collection
Object | CollectionType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
Object | CollectionType.getCollection(Serializable key, SessionImplementor session, Object owner) instantiate a collection wrapper (called when loading an object)
void | ClobType.set(PreparedStatement st, Object value, int index, SessionImplementor session)
Serializable | ClobType.disassemble(Object value, SessionImplementor session, Object owner)
Object | ClobType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Object | ClobType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
void | ClobType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | ClobType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Object | ClobType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
boolean | ClobType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | CalendarType.next(Object current, SessionImplementor session)
Object | CalendarType.seed(SessionImplementor session)
Object | ByteType.next(Object current, SessionImplementor session)
Object | ByteType.seed(SessionImplementor session)
void | BlobType.set(PreparedStatement st, Object value, int index, SessionImplementor session)
Serializable | BlobType.disassemble(Object value, SessionImplementor session, Object owner)
Object | BlobType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Object | BlobType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
void | BlobType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
void | BlobType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
Object | BlobType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
boolean | BlobType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
PersistentCollection | BagType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | BagType.wrap(SessionImplementor session, Object collection)
PersistentCollection | ArrayType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | ArrayType.wrap(SessionImplementor session, Object array)
Object | ArrayType.replaceElements(Object original, Object target, Object owner, Map copyCache, SessionImplementor session)
Object | AnyType.nullSafeGet(ResultSet rs, String name, SessionImplementor session, Object owner)
Object | AnyType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | AnyType.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | AnyType.resolve(Object value, SessionImplementor session, Object owner)
Object | AnyType.semiResolve(Object value, SessionImplementor session, Object owner)
void | AnyType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session)
void | AnyType.nullSafeSet(PreparedStatement st, Object value, int index, boolean[] settable, SessionImplementor session)
Object | AnyType.assemble(Serializable cached, SessionImplementor session, Object owner)
Serializable | AnyType.disassemble(Object value, SessionImplementor session, Object owner)
Object | AnyType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache)
Object | AnyType.getPropertyValue(Object component, int i, SessionImplementor session)
Object[] | AnyType.getPropertyValues(Object component, SessionImplementor session)
boolean | AnyType.isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
boolean | AnyType.isDirty(Object old, Object current, boolean[] checkable, SessionImplementor session)
Serializable | AbstractType.disassemble(Object value, SessionImplementor session, Object owner)
Object | AbstractType.assemble(Serializable cached, SessionImplementor session, Object owner)
boolean | AbstractType.isDirty(Object old, Object current, SessionImplementor session)
Object | AbstractType.hydrate(ResultSet rs, String[] names, SessionImplementor session, Object owner)
Object | AbstractType.resolve(Object value, SessionImplementor session, Object owner)
Object | AbstractType.semiResolve(Object value, SessionImplementor session, Object owner)
boolean | AbstractType.isModified(Object old, Object current, boolean[] checkable, SessionImplementor session)
Object | AbstractType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)
void | AbstractType.beforeAssemble(Serializable cached, SessionImplementor session)
Object[] | AbstractComponentType.getPropertyValues(Object component, SessionImplementor session) Get the values of the component properties of a component instance
Object | AbstractComponentType.getPropertyValue(Object component, int i, SessionImplementor session)
Object | AbstractBynaryType.seed(SessionImplementor session)
Object | AbstractBynaryType.next(Object current, SessionImplementor session)

Uses of SessionImplementor in org.hibernate.usertype

Methods in org.hibernate.usertype with parameters of type SessionImplementor
Object | UserVersionType.seed(SessionImplementor session) Generate an initial version.
Object | UserVersionType.next(Object current, SessionImplementor session) Increment the version.
PersistentCollection | UserCollectionType.instantiate(SessionImplementor session, CollectionPersister persister) Instantiate an uninitialized instance of the collection wrapper
PersistentCollection | UserCollectionType.wrap(SessionImplementor session, Object collection) Wrap an instance of a collection
Object | UserCollectionType.replaceElements(Object original, Object target, CollectionPersister persister, Object owner, Map copyCache, SessionImplementor session) Replace the elements of a collection with the elements of another collection
Object | CompositeUserType.nullSafeGet(ResultSet rs, String[] names, SessionImplementor session, Object owner) Retrieve an instance of the mapped class from a JDBC resultset.
void | CompositeUserType.nullSafeSet(PreparedStatement st, Object value, int index, SessionImplementor session) Write an instance of the mapped class to a prepared statement.
Serializable | CompositeUserType.disassemble(Object value, SessionImplementor session) Transform the object into its cacheable representation.
Object | CompositeUserType.assemble(Serializable cached, SessionImplementor session, Object owner) Reconstruct an object from the cacheable representation.
Object | CompositeUserType.replace(Object original, Object target, SessionImplementor session, Object owner) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.StatefulPersistenceContext (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.StatefulPersistenceContext

Packages that use StatefulPersistenceContext
org.hibernate.engine This package contains classes that are "shared" by other packages, and implementations of some key algorithms.

Uses of StatefulPersistenceContext in org.hibernate.engine

Methods in org.hibernate.engine that return StatefulPersistenceContext
static StatefulPersistenceContext StatefulPersistenceContext.deserialize(ObjectInputStream ois, SessionImplementor session)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.Status (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.Status

Packages that use Status
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of Status in org.hibernate.engine

Fields in org.hibernate.engine declared as Status
static Status | Status.MANAGED
static Status | Status.READ_ONLY
static Status | Status.DELETED
static Status | Status.GONE
static Status | Status.LOADING
static Status | Status.SAVING

Methods in org.hibernate.engine that return Status
static Status | Status.parse(String name)
Status | EntityEntry.getStatus()

Methods in org.hibernate.engine with parameters of type Status
void | StatefulPersistenceContext.setEntryStatus(EntityEntry entry, Status status)
EntityEntry | StatefulPersistenceContext.addEntity(Object entity, Status status, Object[] loadedState, EntityKey entityKey, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Adds an entity to the internal caches.
EntityEntry | StatefulPersistenceContext.addEntry(Object entity, Status status, Object[] loadedState, Object rowId, Serializable id, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.
void | PersistenceContext.setEntryStatus(EntityEntry entry, Status status) Set the status of an entry
EntityEntry | PersistenceContext.addEntity(Object entity, Status status, Object[] loadedState, EntityKey entityKey, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Adds an entity to the internal caches.
EntityEntry | PersistenceContext.addEntry(Object entity, Status status, Object[] loadedState, Object rowId, Serializable id, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched) Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.
void | EntityEntry.setStatus(Status status)

Uses of Status in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type Status
protected  void DefaultFlushEntityEventListener.validate(Object entity, EntityPersister persister, Status status, EntityMode entityMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.SubselectFetch (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.SubselectFetch

Packages that use SubselectFetch
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.

Uses of SubselectFetch in org.hibernate.engine

Methods in org.hibernate.engine that return SubselectFetch
 SubselectFetch BatchFetchQueue.getSubselect(EntityKey key)
Retrieve the fetch descriptor associated with the given entity key.

Methods in org.hibernate.engine with parameters of type SubselectFetch
 void BatchFetchQueue.addSubselect(EntityKey key, SubselectFetch subquery)
Adds a subselect fetch decriptor for the given entity key.

Uses of SubselectFetch in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection with parameters of type SubselectFetch
protected CollectionInitializer | OneToManyPersister.createSubselectInitializer(SubselectFetch subselect, SessionImplementor session)
protected CollectionInitializer | BasicCollectionPersister.createSubselectInitializer(SubselectFetch subselect, SessionImplementor session)
protected abstract CollectionInitializer | AbstractCollectionPersister.createSubselectInitializer(SubselectFetch subselect, SessionImplementor session)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.TransactionHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.TransactionHelper

Packages that use TransactionHelper
org.hibernate.id This package contains internal implementation classes for the main API interfaces.

Uses of TransactionHelper in org.hibernate.id

Subclasses of TransactionHelper in org.hibernate.id
class | MultipleHiLoPerTableGenerator A hilo IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.
class | TableGenerator An IdentifierGenerator that uses a database table to store the last generated value.
class | TableHiLoGenerator hilo An IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.TwoPhaseLoad (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.TwoPhaseLoad

No usage of org.hibernate.engine.TwoPhaseLoad

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.TypedValue (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.TypedValue

Packages that use TypedValue
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader

Uses of TypedValue in org.hibernate.criterion

Methods in org.hibernate.criterion that return TypedValue
TypedValue[] | SubqueryExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SQLCriterion.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SizeExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SimpleSubqueryExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | SimpleExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | PropertyExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NullExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NotNullExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NotExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | NaturalIdentifier.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | LogicalExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | LikeExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | Junction.getTypedValues(Criteria crit, CriteriaQuery criteriaQuery)
TypedValue[] | InExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | IlikeExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | IdentifierEqExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | Example.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | Criterion.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery) Return typed values for all parameters in the rendered SQL fragment
TypedValue | CriteriaQuery.getTypedValue(Criteria criteria, String propertyPath, Object value) Get the a typed value for the given property value.
TypedValue | CriteriaQuery.getTypedIdentifierValue(Criteria subcriteria, Object value)
TypedValue[] | BetweenExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)
TypedValue[] | AbstractEmptinessExpression.getTypedValues(Criteria criteria, CriteriaQuery criteriaQuery)

Uses of TypedValue in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria that return TypedValue
TypedValue | CriteriaQueryTranslator.getTypedIdentifierValue(Criteria subcriteria, Object value)
TypedValue | CriteriaQueryTranslator.getTypedValue(Criteria subcriteria, String propertyName, Object value) Get the a typed value for the given property value.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.UnsavedValueFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.UnsavedValueFactory

No usage of org.hibernate.engine.UnsavedValueFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.Versioning (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.Versioning

No usage of org.hibernate.engine.Versioning

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.VersionValue (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.VersionValue

Packages that use VersionValue
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.

Uses of VersionValue in org.hibernate.engine

Fields in org.hibernate.engine declared as VersionValue
static VersionValue | VersionValue.NULL Assume the transient instance is newly instantiated if the version is null, otherwise assume it is a detached instance.
static VersionValue | VersionValue.UNDEFINED Assume the transient instance is newly instantiated if the version is null, otherwise defer to the identifier unsaved-value.
static VersionValue | VersionValue.NEGATIVE Assume the transient instance is newly instantiated if the version is negative, otherwise assume it is a detached instance.

Methods in org.hibernate.engine that return VersionValue
static VersionValue UnsavedValueFactory.getUnsavedVersionValue(String versionUnsavedValue, Getter versionGetter, VersionType versionType, Constructor constructor)

Uses of VersionValue in org.hibernate.tuple

Methods in org.hibernate.tuple that return VersionValue
 VersionValue VersionProperty.getUnsavedValue()

Constructors in org.hibernate.tuple with parameters of type VersionValue
VersionProperty(String name, String node, Type type, boolean lazy, boolean insertable, boolean updateable, boolean insertGenerated, boolean updateGenerated, boolean nullable, boolean checkable, boolean versionable, CascadeStyle cascadeStyle, VersionValue unsavedValue)
Constructs VersionProperty instances.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.engine.query (Hibernate API Documentation)

 org.hibernate.engine.query
Interfaces
ParameterParser.Recognizer
Classes
FilterQueryPlan
HQLQueryPlan
NamedParameterDescriptor
NativeSQLQueryPlan
OrdinalParameterDescriptor
ParameterMetadata
ParameterParser
ParamLocationRecognizer
ParamLocationRecognizer.NamedParameterDescription
QueryMetadata
QueryPlanCache
ReturnMetadata


Uses of Class org.hibernate.engine.query.FilterQueryPlan (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.FilterQueryPlan

Packages that use FilterQueryPlan
org.hibernate.engine.query

Uses of FilterQueryPlan in org.hibernate.engine.query

Methods in org.hibernate.engine.query that return FilterQueryPlan
 FilterQueryPlan QueryPlanCache.getFilterQueryPlan(String filterString, String collectionRole, boolean shallow, Map enabledFilters)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.HQLQueryPlan (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.HQLQueryPlan

Packages that use HQLQueryPlan
org.hibernate.engine.query |
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of HQLQueryPlan in org.hibernate.engine.query

Subclasses of HQLQueryPlan in org.hibernate.engine.query
 class FilterQueryPlan
Extends an HQLQueryPlan to maintain a reference to the collection-role name being filtered.

Methods in org.hibernate.engine.query that return HQLQueryPlan
 HQLQueryPlan QueryPlanCache.getHQLQueryPlan(String queryString, boolean shallow, Map enabledFilters)

Uses of HQLQueryPlan in org.hibernate.impl

Methods in org.hibernate.impl that return HQLQueryPlan
protected  HQLQueryPlan AbstractSessionImpl.getHQLQueryPlan(String query, boolean shallow)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.NamedParameterDescriptor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.NamedParameterDescriptor

Packages that use NamedParameterDescriptor
org.hibernate.engine.query

Uses of NamedParameterDescriptor in org.hibernate.engine.query

Methods in org.hibernate.engine.query that return NamedParameterDescriptor
 NamedParameterDescriptor ParameterMetadata.getNamedParameterDescriptor(String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.NativeSQLQueryPlan (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.NativeSQLQueryPlan

Packages that use NativeSQLQueryPlan
org.hibernate.engine.query |
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of NativeSQLQueryPlan in org.hibernate.engine.query

Methods in org.hibernate.engine.query that return NativeSQLQueryPlan
 NativeSQLQueryPlan QueryPlanCache.getNativeSQLQueryPlan(NativeSQLQuerySpecification spec)

Uses of NativeSQLQueryPlan in org.hibernate.impl

Methods in org.hibernate.impl that return NativeSQLQueryPlan
protected  NativeSQLQueryPlan AbstractSessionImpl.getNativeSQLQueryPlan(NativeSQLQuerySpecification spec)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.OrdinalParameterDescriptor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.OrdinalParameterDescriptor

Packages that use OrdinalParameterDescriptor
org.hibernate.engine.query

Uses of OrdinalParameterDescriptor in org.hibernate.engine.query

Methods in org.hibernate.engine.query that return OrdinalParameterDescriptor
 OrdinalParameterDescriptor ParameterMetadata.getOrdinalParameterDescriptor(int position)

Constructors in org.hibernate.engine.query with parameters of type OrdinalParameterDescriptor
ParameterMetadata(OrdinalParameterDescriptor[] ordinalDescriptors, Map namedDescriptorMap)
Instantiates a ParameterMetadata container.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.ParameterMetadata (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.ParameterMetadata

Packages that use ParameterMetadata
org.hibernate.engine.query |
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of ParameterMetadata in org.hibernate.engine.query

Methods in org.hibernate.engine.query that return ParameterMetadata
ParameterMetadata | QueryPlanCache.getSQLParameterMetadata(String query)
ParameterMetadata | QueryMetadata.getParameterMetadata()
ParameterMetadata | HQLQueryPlan.getParameterMetadata()

Constructors in org.hibernate.engine.query with parameters of type ParameterMetadata
QueryMetadata(String sourceQuery, ParameterMetadata parameterMetadata, String[] returnAliases, Type[] returnTypes, Set querySpaces)

Uses of ParameterMetadata in org.hibernate.impl

Fields in org.hibernate.impl declared as ParameterMetadata
protected  ParameterMetadata AbstractQueryImpl.parameterMetadata

Constructors in org.hibernate.impl with parameters of type ParameterMetadata
QueryImpl(String queryString, FlushMode flushMode, SessionImplementor session, ParameterMetadata parameterMetadata)
QueryImpl(String queryString, SessionImplementor session, ParameterMetadata parameterMetadata)
CollectionFilterImpl(String queryString, Object collection, SessionImplementor session, ParameterMetadata parameterMetadata)
AbstractQueryImpl(String queryString, FlushMode flushMode, SessionImplementor session, ParameterMetadata parameterMetadata)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.ParameterParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.ParameterParser

No usage of org.hibernate.engine.query.ParameterParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.engine.query.ParameterParser.Recognizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.engine.query.ParameterParser.Recognizer

Packages that use ParameterParser.Recognizer
org.hibernate.engine.query
org.hibernate.loader.custom.sql

Uses of ParameterParser.Recognizer in org.hibernate.engine.query

Classes in org.hibernate.engine.query that implement ParameterParser.Recognizer
 class ParamLocationRecognizer
Implements a parameter parser recognizer specifically for the purpose of journaling parameter locations.

Methods in org.hibernate.engine.query with parameters of type ParameterParser.Recognizer
static void ParameterParser.parse(String sqlString, ParameterParser.Recognizer recognizer)
Performs the actual parsing and tokenizing of the query string making appropriate callbacks to the given recognizer upon recognition of the various tokens.

Uses of ParameterParser.Recognizer in org.hibernate.loader.custom.sql

Classes in org.hibernate.loader.custom.sql that implement ParameterParser.Recognizer
static class SQLQueryParser.ParameterSubstitutionRecognizer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.ParamLocationRecognizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.ParamLocationRecognizer

Packages that use ParamLocationRecognizer
org.hibernate.engine.query

Uses of ParamLocationRecognizer in org.hibernate.engine.query

Methods in org.hibernate.engine.query that return ParamLocationRecognizer
static ParamLocationRecognizer ParamLocationRecognizer.parseLocations(String query)
Convenience method for creating a param location recognizer and initiating the parse.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.ParamLocationRecognizer.NamedParameterDescription (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.ParamLocationRecognizer.NamedParameterDescription

No usage of org.hibernate.engine.query.ParamLocationRecognizer.NamedParameterDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.QueryMetadata (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.QueryMetadata

No usage of org.hibernate.engine.query.QueryMetadata

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.QueryPlanCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.QueryPlanCache

Packages that use QueryPlanCache
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of QueryPlanCache in org.hibernate.engine

Methods in org.hibernate.engine that return QueryPlanCache
 QueryPlanCache SessionFactoryImplementor.getQueryPlanCache()

Uses of QueryPlanCache in org.hibernate.impl

Methods in org.hibernate.impl that return QueryPlanCache
 QueryPlanCache SessionFactoryImpl.getQueryPlanCache()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.ReturnMetadata (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.ReturnMetadata

Packages that use ReturnMetadata
org.hibernate.engine.query

Uses of ReturnMetadata in org.hibernate.engine.query

Methods in org.hibernate.engine.query that return ReturnMetadata
 ReturnMetadata HQLQueryPlan.getReturnMetadata()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.engine.query.sql (Hibernate API Documentation)

 org.hibernate.engine.query.sql
Interfaces
NativeSQLQueryReturn
Classes
NativeSQLQueryCollectionReturn
NativeSQLQueryJoinReturn
NativeSQLQueryNonScalarReturn
NativeSQLQueryRootReturn
NativeSQLQueryScalarReturn
NativeSQLQuerySpecification


Uses of Class org.hibernate.engine.query.sql.NativeSQLQueryCollectionReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.sql.NativeSQLQueryCollectionReturn

No usage of org.hibernate.engine.query.sql.NativeSQLQueryCollectionReturn

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.sql.NativeSQLQueryJoinReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.sql.NativeSQLQueryJoinReturn

No usage of org.hibernate.engine.query.sql.NativeSQLQueryJoinReturn

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.sql.NativeSQLQueryNonScalarReturn

Packages that use NativeSQLQueryNonScalarReturn
org.hibernate.engine.query.sql

Uses of NativeSQLQueryNonScalarReturn in org.hibernate.engine.query.sql

Subclasses of NativeSQLQueryNonScalarReturn in org.hibernate.engine.query.sql
class | NativeSQLQueryCollectionReturn Represents a return defined as part of a native sql query which names a collection role in the form {classname}.{collectionrole}; it is used in defining a custom sql query for loading an entity's collection in non-fetching scenarios (i.e., loading the collection itself as the "root" of the result).
class | NativeSQLQueryJoinReturn Represents a return defined as part of a native sql query which names a fetched role.
class | NativeSQLQueryRootReturn Represents a return defined as part of a native sql query which names a "root" entity.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.engine.query.sql.NativeSQLQueryReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.engine.query.sql.NativeSQLQueryReturn

Packages that use NativeSQLQueryReturn
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query.sql |
org.hibernate.loader.custom.sql |

Uses of NativeSQLQueryReturn in org.hibernate.engine

Methods in org.hibernate.engine that return NativeSQLQueryReturn
NativeSQLQueryReturn[] | ResultSetMappingDefinition.getQueryReturns()
NativeSQLQueryReturn[] | NamedSQLQueryDefinition.getQueryReturns()

Methods in org.hibernate.engine with parameters of type NativeSQLQueryReturn
 void ResultSetMappingDefinition.addQueryReturn(NativeSQLQueryReturn queryReturn)

Constructors in org.hibernate.engine with parameters of type NativeSQLQueryReturn
NamedSQLQueryDefinition(String query, NativeSQLQueryReturn[] queryReturns, List querySpaces, boolean cacheable, String cacheRegion, Integer timeout, Integer fetchSize, FlushMode flushMode, CacheMode cacheMode, boolean readOnly, String comment, Map parameterTypes, boolean callable)
This form used to construct a NamedSQLQueryDefinition from the binder code when a the result-set mapping information is explicitly provided in the query definition (i.e., no resultset-mapping used)

Uses of NativeSQLQueryReturn in org.hibernate.engine.query.sql

Classes in org.hibernate.engine.query.sql that implement NativeSQLQueryReturn
class | NativeSQLQueryCollectionReturn Represents a return defined as part of a native sql query which names a collection role in the form {classname}.{collectionrole}; it is used in defining a custom sql query for loading an entity's collection in non-fetching scenarios (i.e., loading the collection itself as the "root" of the result).
class | NativeSQLQueryJoinReturn Represents a return defined as part of a native sql query which names a fetched role.
class | NativeSQLQueryNonScalarReturn Represents the base information for a non-scalar return defined as part of a native sql query.
class | NativeSQLQueryRootReturn Represents a return defined as part of a native sql query which names a "root" entity.
class | NativeSQLQueryScalarReturn Describes a scalar return in a native SQL query.

Methods in org.hibernate.engine.query.sql that return NativeSQLQueryReturn
 NativeSQLQueryReturn[] NativeSQLQuerySpecification.getQueryReturns()

Constructors in org.hibernate.engine.query.sql with parameters of type NativeSQLQueryReturn
NativeSQLQuerySpecification(String queryString, NativeSQLQueryReturn[] queryReturns, Collection querySpaces)

Uses of NativeSQLQueryReturn in org.hibernate.loader.custom.sql

Constructors in org.hibernate.loader.custom.sql with parameters of type NativeSQLQueryReturn
SQLQueryReturnProcessor(NativeSQLQueryReturn[] queryReturns, SessionFactoryImplementor factory)
SQLCustomQuery(String sqlQuery, NativeSQLQueryReturn[] queryReturns, Collection additionalQuerySpaces, SessionFactoryImplementor factory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.sql.NativeSQLQueryRootReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.sql.NativeSQLQueryRootReturn

No usage of org.hibernate.engine.query.sql.NativeSQLQueryRootReturn

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.sql.NativeSQLQueryScalarReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.sql.NativeSQLQueryScalarReturn

No usage of org.hibernate.engine.query.sql.NativeSQLQueryScalarReturn

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.query.sql.NativeSQLQuerySpecification (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.query.sql.NativeSQLQuerySpecification

Packages that use NativeSQLQuerySpecification
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of NativeSQLQuerySpecification in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type NativeSQLQuerySpecification
List | SessionImplementor.list(NativeSQLQuerySpecification spec, QueryParameters queryParameters) Execute a native SQL query, and return the results as a fully built list.
ScrollableResults | SessionImplementor.scroll(NativeSQLQuerySpecification spec, QueryParameters queryParameters) Execute a native SQL query, and return the results as a scrollable result.
int | SessionImplementor.executeNativeUpdate(NativeSQLQuerySpecification specification, QueryParameters queryParameters) Execute a native SQL update or delete query

Uses of NativeSQLQuerySpecification in org.hibernate.engine.query

Methods in org.hibernate.engine.query with parameters of type NativeSQLQuerySpecification
 NativeSQLQueryPlan QueryPlanCache.getNativeSQLQueryPlan(NativeSQLQuerySpecification spec)

Constructors in org.hibernate.engine.query with parameters of type NativeSQLQuerySpecification
NativeSQLQueryPlan(NativeSQLQuerySpecification specification, SessionFactoryImplementor factory)

Uses of NativeSQLQuerySpecification in org.hibernate.impl

Methods in org.hibernate.impl with parameters of type NativeSQLQuerySpecification
int | StatelessSessionImpl.executeNativeUpdate(NativeSQLQuerySpecification nativeSQLQuerySpecification, QueryParameters queryParameters)
int | SessionImpl.executeNativeUpdate(NativeSQLQuerySpecification nativeQuerySpecification, QueryParameters queryParameters)
protected NativeSQLQueryPlan | AbstractSessionImpl.getNativeSQLQueryPlan(NativeSQLQuerySpecification spec)
List | AbstractSessionImpl.list(NativeSQLQuerySpecification spec, QueryParameters queryParameters)
ScrollableResults | AbstractSessionImpl.scroll(NativeSQLQuerySpecification spec, QueryParameters queryParameters)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.engine.transaction (Hibernate API Documentation)

 org.hibernate.engine.transaction
Interfaces
IsolatedWork
Classes
Isolater
Isolater.JdbcDelegate
Isolater.JtaDelegate


Uses of Interface org.hibernate.engine.transaction.IsolatedWork (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.engine.transaction.IsolatedWork

Packages that use IsolatedWork
org.hibernate.engine.transaction

Uses of IsolatedWork in org.hibernate.engine.transaction

Methods in org.hibernate.engine.transaction with parameters of type IsolatedWork
static void | Isolater.doIsolatedWork(IsolatedWork work, SessionImplementor session) Ensures that all processing actually performed by the given work will occur on a seperate transaction.
static void | Isolater.doNonTransactedWork(IsolatedWork work, SessionImplementor session) Ensures that all processing actually performed by the given work will occur outside of a transaction.
void | Isolater.JtaDelegate.delegateWork(IsolatedWork work, boolean transacted)
void | Isolater.JdbcDelegate.delegateWork(IsolatedWork work, boolean transacted)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.transaction.Isolater (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.transaction.Isolater

No usage of org.hibernate.engine.transaction.Isolater

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.transaction.Isolater.JdbcDelegate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.transaction.Isolater.JdbcDelegate

No usage of org.hibernate.engine.transaction.Isolater.JdbcDelegate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.engine.transaction.Isolater.JtaDelegate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.engine.transaction.Isolater.JtaDelegate

No usage of org.hibernate.engine.transaction.Isolater.JtaDelegate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.event (Hibernate API Documentation)

 org.hibernate.event
Interfaces
AutoFlushEventListener
DeleteEventListener
DirtyCheckEventListener
EventSource
EvictEventListener
FlushEntityEventListener
FlushEventListener
Initializable
InitializeCollectionEventListener
LoadEventListener
LockEventListener
MergeEventListener
PersistEventListener
PostDeleteEventListener
PostInsertEventListener
PostLoadEventListener
PostUpdateEventListener
PreDeleteEventListener
PreInsertEventListener
PreLoadEventListener
PreUpdateEventListener
RefreshEventListener
ReplicateEventListener
SaveOrUpdateEventListener
Classes
AbstractEvent
AutoFlushEvent
DeleteEvent
DirtyCheckEvent
EventListeners
EvictEvent
FlushEntityEvent
FlushEvent
InitializeCollectionEvent
LoadEvent
LoadEventListener.LoadType
LockEvent
MergeEvent
PersistEvent
PostDeleteEvent
PostInsertEvent
PostLoadEvent
PostUpdateEvent
PreDeleteEvent
PreInsertEvent
PreLoadEvent
PreUpdateEvent
RefreshEvent
ReplicateEvent
SaveOrUpdateEvent


Uses of Class org.hibernate.event.AbstractEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.AbstractEvent

Packages that use AbstractEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of AbstractEvent in org.hibernate.event

Subclasses of AbstractEvent in org.hibernate.event
class | AutoFlushEvent Defines an event class for the auto-flushing of a session.
class | DeleteEvent Defines an event class for the deletion of an entity.
class | DirtyCheckEvent Defines an event class for the dirty-checking of a session.
class | EvictEvent Defines an event class for the evicting of an entity.
class | FlushEntityEvent
class | FlushEvent Defines an event class for the flushing of a session.
class | InitializeCollectionEvent An event that occurs when a collection wants to be initialized
class | LoadEvent Defines an event class for the loading of an entity.
class | LockEvent Defines an event class for the locking of an entity.
class | MergeEvent An event class for merge() and saveOrUpdateCopy()
class | PersistEvent An event class for persist()
class | PostLoadEvent Occurs after an an entity instance is fully loaded.
class | PostUpdateEvent Occurs after the datastore is updated
class | PreLoadEvent Called before injecting property values into a newly loaded entity instance.
class | RefreshEvent Defines an event class for the refreshing of an object.
class | ReplicateEvent Defines an event class for the replication of an entity.
class | SaveOrUpdateEvent An event class for saveOrUpdate()

Uses of AbstractEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type AbstractEvent
protected  EntityEntry AbstractReassociateEventListener.reassociate(AbstractEvent event, Object object, Serializable id, EntityPersister persister)
Associates a given entity (either transient or associated with another session) to the given session.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.AutoFlushEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.AutoFlushEvent

Packages that use AutoFlushEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of AutoFlushEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type AutoFlushEvent
 void AutoFlushEventListener.onAutoFlush(AutoFlushEvent event)
Handle the given auto-flush event.

Uses of AutoFlushEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type AutoFlushEvent
 void DefaultAutoFlushEventListener.onAutoFlush(AutoFlushEvent event)
Handle the given auto-flush event.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.AutoFlushEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.AutoFlushEventListener

Packages that use AutoFlushEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of AutoFlushEventListener in org.hibernate.event

Methods in org.hibernate.event that return AutoFlushEventListener
 AutoFlushEventListener[] EventListeners.getAutoFlushEventListeners()

Methods in org.hibernate.event with parameters of type AutoFlushEventListener
 void EventListeners.setAutoFlushEventListeners(AutoFlushEventListener[] autoFlushEventListener)

Uses of AutoFlushEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement AutoFlushEventListener
 class DefaultAutoFlushEventListener
Defines the default flush event listeners used by hibernate for flushing session state in response to generated auto-flush events.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.DeleteEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.DeleteEvent

Packages that use DeleteEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of DeleteEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type DeleteEvent
void | DeleteEventListener.onDelete(DeleteEvent event) Handle the given delete event.
void | DeleteEventListener.onDelete(DeleteEvent event, Set transientEntities)

Uses of DeleteEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type DeleteEvent
void | DefaultDeleteEventListener.onDelete(DeleteEvent event) Handle the given delete event.
void | DefaultDeleteEventListener.onDelete(DeleteEvent event, Set transientEntities)
protected void | DefaultDeleteEventListener.performDetachedEntityDeletionCheck(DeleteEvent event)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.DeleteEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.DeleteEventListener

Packages that use DeleteEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of DeleteEventListener in org.hibernate.event

Methods in org.hibernate.event that return DeleteEventListener
 DeleteEventListener[] EventListeners.getDeleteEventListeners()

Methods in org.hibernate.event with parameters of type DeleteEventListener
 void EventListeners.setDeleteEventListeners(DeleteEventListener[] deleteEventListener)

Uses of DeleteEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement DeleteEventListener
 class DefaultDeleteEventListener
Defines the default delete event listener used by hibernate for deleting entities from the datastore in response to generated delete events.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.DirtyCheckEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.DirtyCheckEvent

Packages that use DirtyCheckEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of DirtyCheckEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type DirtyCheckEvent
 void DirtyCheckEventListener.onDirtyCheck(DirtyCheckEvent event)
Handle the given dirty-check event.

Uses of DirtyCheckEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type DirtyCheckEvent
 void DefaultDirtyCheckEventListener.onDirtyCheck(DirtyCheckEvent event)
Handle the given dirty-check event.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.DirtyCheckEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.DirtyCheckEventListener

Packages that use DirtyCheckEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of DirtyCheckEventListener in org.hibernate.event

Methods in org.hibernate.event that return DirtyCheckEventListener
 DirtyCheckEventListener[] EventListeners.getDirtyCheckEventListeners()

Methods in org.hibernate.event with parameters of type DirtyCheckEventListener
 void EventListeners.setDirtyCheckEventListeners(DirtyCheckEventListener[] dirtyCheckEventListener)

Uses of DirtyCheckEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement DirtyCheckEventListener
 class DefaultDirtyCheckEventListener
Defines the default dirty-check event listener used by hibernate for checking the session for dirtiness in response to generated dirty-check events.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.EventListeners (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.EventListeners

Packages that use EventListeners
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of EventListeners in org.hibernate.cfg

Methods in org.hibernate.cfg that return EventListeners
 EventListeners Configuration.getEventListeners()

Uses of EventListeners in org.hibernate.engine

Methods in org.hibernate.engine that return EventListeners
 EventListeners SessionImplementor.getListeners()
Retrieves the configured event listeners from this event source.

Uses of EventListeners in org.hibernate.impl

Methods in org.hibernate.impl that return EventListeners
EventListeners | StatelessSessionImpl.getListeners()
EventListeners | SessionImpl.getListeners()
EventListeners | SessionFactoryImpl.getEventListeners()

Constructors in org.hibernate.impl with parameters of type EventListeners
SessionFactoryImpl(Configuration cfg, Mapping mapping, Settings settings, EventListeners listeners)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.EventSource (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.EventSource

Packages that use EventSource
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser

Uses of EventSource in org.hibernate.cache.entry

Methods in org.hibernate.cache.entry with parameters of type EventSource
 Object[] CacheEntry.assemble(Object instance, Serializable id, EntityPersister persister, Interceptor interceptor, EventSource session)

Uses of EventSource in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type EventSource
abstract  void CascadingAction.cascade(EventSource session, Object child, String entityName, Object anything, boolean isCascadeDeleteEnabled)
Cascade the action to the child object.
abstract  Iterator CascadingAction.getCascadableChildrenIterator(EventSource session, CollectionType collectionType, Object collection)
Given a collection, get an iterator of the children upon which the current cascading action should be visited.
 void CascadingAction.noCascade(EventSource session, Object child, Object parent, EntityPersister persister, int propertyIndex)
Called (in the case of CascadingAction.requiresNoCascadeChecking() returning true) to validate that no cascade on the given property is considered a valid semantic.

Constructors in org.hibernate.engine with parameters of type EventSource
Cascade(CascadingAction action, int cascadeTo, EventSource eventSource)

Uses of EventSource in org.hibernate.engine.query

Methods in org.hibernate.engine.query with parameters of type EventSource
 Iterator HQLQueryPlan.performIterate(QueryParameters queryParameters, EventSource session)

Uses of EventSource in org.hibernate.event

Methods in org.hibernate.event that return EventSource
 EventSource AbstractEvent.getSession()
Returns the session event source for this event.

Constructors in org.hibernate.event with parameters of type EventSource
SaveOrUpdateEvent(String entityName, Object original, EventSource source)
SaveOrUpdateEvent(String entityName, Object original, Serializable id, EventSource source)
SaveOrUpdateEvent(Object object, EventSource source)
ReplicateEvent(Object object, ReplicationMode replicationMode, EventSource source)
ReplicateEvent(String entityName, Object object, ReplicationMode replicationMode, EventSource source)
RefreshEvent(Object object, EventSource source)
RefreshEvent(Object object, LockMode lockMode, EventSource source)
PreLoadEvent(EventSource session)
PostUpdateEvent(Object entity, Serializable id, Object[] state, Object[] oldState, EntityPersister persister, EventSource source)
PostLoadEvent(EventSource session)
PersistEvent(String entityName, Object original, EventSource source)
PersistEvent(Object object, EventSource source)
MergeEvent(String entityName, Object original, EventSource source)
MergeEvent(String entityName, Object original, Serializable id, EventSource source)
MergeEvent(Object object, EventSource source)
LockEvent(String entityName, Object original, LockMode lockMode, EventSource source)
LockEvent(Object object, LockMode lockMode, EventSource source)
LoadEvent(Serializable entityId, Object instanceToLoad, EventSource source)
LoadEvent(Serializable entityId, String entityClassName, LockMode lockMode, EventSource source)
LoadEvent(Serializable entityId, String entityClassName, boolean isAssociationFetch, EventSource source)
InitializeCollectionEvent(PersistentCollection collection, EventSource source)
FlushEvent(EventSource source)
FlushEntityEvent(EventSource source, Object entity, EntityEntry entry)
EvictEvent(Object object, EventSource source)
DirtyCheckEvent(EventSource source)
DeleteEvent(Object object, EventSource source)
Constructs a new DeleteEvent instance.
DeleteEvent(String entityName, Object object, EventSource source)
DeleteEvent(String entityName, Object object, boolean isCascadeDeleteEnabled, EventSource source)
AutoFlushEvent(Set querySpaces, EventSource source)
AbstractEvent(EventSource source)
Constructs an event from the given event session.

Uses of EventSource in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type EventSource
void | ReattachVisitor.removeCollection(CollectionPersister role, Serializable id, EventSource source) Schedules a collection for deletion.
protected boolean | DefaultSaveOrUpdateEventListener.invokeUpdateLifecycle(Object entity, EntityPersister persister, EventSource source)
protected boolean | DefaultReplicateEventListener.visitCollectionsBeforeSave(Serializable id, Object[] values, Type[] types, EventSource source)
protected void | DefaultMergeEventListener.cascadeOnMerge(EventSource source, EntityPersister persister, Object entity, Map copyCache) Perform any cascades needed as part of this copy event.
protected void | DefaultMergeEventListener.cascadeAfterSave(EventSource source, EntityPersister persister, Object entity, Object anything) Cascade behavior is redefined by this subclass, disable superclass behavior
protected void | DefaultMergeEventListener.cascadeBeforeSave(EventSource source, EntityPersister persister, Object entity, Object anything) Cascade behavior is redefined by this subclass, disable superclass behavior
protected void | DefaultEvictEventListener.doEvict(Object object, EntityKey key, EntityPersister persister, EventSource session)
protected void | DefaultDeleteEventListener.deleteTransientEntity(EventSource session, Object entity, boolean cascadeDeleteEnabled, EntityPersister persister, Set transientEntities) We encountered a delete request on a transient instance.
protected void | DefaultDeleteEventListener.deleteEntity(EventSource session, Object entity, EntityEntry entityEntry, boolean isCascadeDeleteEnabled, EntityPersister persister, Set transientEntities)
protected boolean | DefaultDeleteEventListener.invokeDeleteLifecycle(EventSource session, Object entity, EntityPersister persister)
protected void | DefaultDeleteEventListener.cascadeBeforeDelete(EventSource session, EntityPersister persister, Object entity, EntityEntry entityEntry, Set transientEntities)
protected void | DefaultDeleteEventListener.cascadeAfterDelete(EventSource session, EntityPersister persister, Object entity, Set transientEntities)
protected Serializable | AbstractSaveEventListener.saveWithRequestedId(Object entity, Serializable requestedId, String entityName, Object anything, EventSource source) Prepares the save call using the given requested id.
protected Serializable | AbstractSaveEventListener.saveWithGeneratedId(Object entity, String entityName, Object anything, EventSource source, boolean requiresImmediateIdAccess) Prepares the save call using a newly generated id.
protected Serializable | AbstractSaveEventListener.performSave(Object entity, Serializable id, EntityPersister persister, boolean useIdentityColumn, Object anything, EventSource source, boolean requiresImmediateIdAccess) Ppepares the save call by checking the session caches for a pre-existing entity and performing any lifecycle callbacks.
protected boolean | AbstractSaveEventListener.invokeSaveLifecycle(Object entity, EntityPersister persister, EventSource source)
protected void | AbstractSaveEventListener.validate(Object entity, EntityPersister persister, EventSource source)
protected Serializable | AbstractSaveEventListener.performSaveOrReplicate(Object entity, EntityKey key, EntityPersister persister, boolean useIdentityColumn, Object anything, EventSource source, boolean requiresImmediateIdAccess) Performs all the actual work needed to save an entity (well to get the save moved to the execution queue).
protected boolean | AbstractSaveEventListener.visitCollectionsBeforeSave(Serializable id, Object[] values, Type[] types, EventSource source)
protected void | AbstractSaveEventListener.cascadeBeforeSave(EventSource source, EntityPersister persister, Object entity, Object anything) Handles the calls needed to perform pre-save cascades for the given entity.
protected void | AbstractSaveEventListener.cascadeAfterSave(EventSource source, EntityPersister persister, Object entity, Object anything) Handles to calls needed to perform post-save cascades.
protected void | AbstractFlushingEventListener.performExecutions(EventSource session) Execute all SQL and second-level cache updates, in a special order so that foreign-key constraints cannot be violated: Inserts, in the order they were performed Updates Deletion of collection elements Insertion of collection elements Deletes, in the order they were performed

Constructors in org.hibernate.event.def with parameters of type EventSource
ReattachVisitor(EventSource session, Serializable key)
ProxyVisitor(EventSource session)
OnLockVisitor(EventSource session, Serializable key)

Uses of EventSource in org.hibernate.hql

Methods in org.hibernate.hql with parameters of type EventSource
 Iterator QueryTranslator.iterate(QueryParameters queryParameters, EventSource session)
Perform an iterate operation given the underlying query defintion.

Uses of EventSource in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast with parameters of type EventSource
 Iterator QueryTranslatorImpl.iterate(QueryParameters queryParameters, EventSource session)
Return the query results as an iterator

Uses of EventSource in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic with parameters of type EventSource
 Iterator QueryTranslatorImpl.iterate(QueryParameters queryParameters, EventSource session)
Return the query results as an iterator

Uses of EventSource in org.hibernate.impl

Classes in org.hibernate.impl that implement EventSource
 class SessionImpl
Concrete implementation of a Session, and also the central, organizing component of Hibernate's internal implementation.

Constructors in org.hibernate.impl with parameters of type EventSource
IteratorImpl(ResultSet rs, PreparedStatement ps, EventSource sess, Type[] types, String[][] columnNames, HolderInstantiator holderInstantiator)

Uses of EventSource in org.hibernate.loader.hql

Methods in org.hibernate.loader.hql with parameters of type EventSource
 Iterator QueryLoader.iterate(QueryParameters queryParameters, EventSource session)
Return the query results as an iterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.EvictEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.EvictEvent

Packages that use EvictEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of EvictEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type EvictEvent
 void EvictEventListener.onEvict(EvictEvent event)
Handle the given evict event.

Uses of EvictEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type EvictEvent
 void DefaultEvictEventListener.onEvict(EvictEvent event)
Handle the given evict event.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.EvictEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.EvictEventListener

Packages that use EvictEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of EvictEventListener in org.hibernate.event

Methods in org.hibernate.event that return EvictEventListener
 EvictEventListener[] EventListeners.getEvictEventListeners()

Methods in org.hibernate.event with parameters of type EvictEventListener
 void EventListeners.setEvictEventListeners(EvictEventListener[] evictEventListener)

Uses of EvictEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement EvictEventListener
 class DefaultEvictEventListener
Defines the default evict event listener used by hibernate for evicting entities in response to generated flush events.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.FlushEntityEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.FlushEntityEvent

Packages that use FlushEntityEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of FlushEntityEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type FlushEntityEvent
 void FlushEntityEventListener.onFlushEntity(FlushEntityEvent event)

Uses of FlushEntityEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type FlushEntityEvent
void | DefaultFlushEntityEventListener.onFlushEntity(FlushEntityEvent event) Flushes a single entity's state to the database, by scheduling an update action, if necessary
protected boolean | DefaultFlushEntityEventListener.handleInterception(FlushEntityEvent event)
protected boolean | DefaultFlushEntityEventListener.isUpdateNecessary(FlushEntityEvent event) Performs all necessary checking to determine if an entity needs an SQL update to synchronize its state to the database.
protected void | DefaultFlushEntityEventListener.dirtyCheck(FlushEntityEvent event) Perform a dirty check, and attach the results to the event

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.FlushEntityEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.FlushEntityEventListener

Packages that use FlushEntityEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of FlushEntityEventListener in org.hibernate.event

Methods in org.hibernate.event that return FlushEntityEventListener
 FlushEntityEventListener[] EventListeners.getFlushEntityEventListeners()

Methods in org.hibernate.event with parameters of type FlushEntityEventListener
 void EventListeners.setFlushEntityEventListeners(FlushEntityEventListener[] flushEntityEventListener)

Uses of FlushEntityEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement FlushEntityEventListener
 class DefaultFlushEntityEventListener
An event that occurs for each entity instance at flush time

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.FlushEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.FlushEvent

Packages that use FlushEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of FlushEvent in org.hibernate.event

Subclasses of FlushEvent in org.hibernate.event
class | AutoFlushEvent Defines an event class for the auto-flushing of a session.
class | DirtyCheckEvent Defines an event class for the dirty-checking of a session.

Methods in org.hibernate.event with parameters of type FlushEvent
 void FlushEventListener.onFlush(FlushEvent event)
Handle the given flush event.

Uses of FlushEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type FlushEvent
void | DefaultFlushEventListener.onFlush(FlushEvent event) Handle the given flush event.
protected void | AbstractFlushingEventListener.flushEverythingToExecutions(FlushEvent event) Coordinates the processing necessary to get things ready for executions as db calls by preping the session caches and moving the appropriate entities and collections to their respective execution queues.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.FlushEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.FlushEventListener

Packages that use FlushEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of FlushEventListener in org.hibernate.event

Methods in org.hibernate.event that return FlushEventListener
 FlushEventListener[] EventListeners.getFlushEventListeners()

Methods in org.hibernate.event with parameters of type FlushEventListener
 void EventListeners.setFlushEventListeners(FlushEventListener[] flushEventListener)

Uses of FlushEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement FlushEventListener
 class DefaultFlushEventListener
Defines the default flush event listeners used by hibernate for flushing session state in response to generated flush events.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.Initializable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.Initializable

Packages that use Initializable
org.hibernate.secure Declarative security for CRUD operations on entities.

Uses of Initializable in org.hibernate.secure

Classes in org.hibernate.secure that implement Initializable
class | JACCPreDeleteEventListener Check security before any deletion
class | JACCPreInsertEventListener Check security before an insertion
class | JACCPreLoadEventListener Check security before any load
class | JACCPreUpdateEventListener Check security before any update

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.InitializeCollectionEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.InitializeCollectionEvent

Packages that use InitializeCollectionEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of InitializeCollectionEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type InitializeCollectionEvent
 void InitializeCollectionEventListener.onInitializeCollection(InitializeCollectionEvent event)

Uses of InitializeCollectionEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type InitializeCollectionEvent
 void DefaultInitializeCollectionEventListener.onInitializeCollection(InitializeCollectionEvent event)
called by a collection that wants to initialize itself

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.InitializeCollectionEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.InitializeCollectionEventListener

Packages that use InitializeCollectionEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of InitializeCollectionEventListener in org.hibernate.event

Methods in org.hibernate.event that return InitializeCollectionEventListener
 InitializeCollectionEventListener[] EventListeners.getInitializeCollectionEventListeners()

Methods in org.hibernate.event with parameters of type InitializeCollectionEventListener
 void EventListeners.setInitializeCollectionEventListeners(InitializeCollectionEventListener[] initializeCollectionEventListener)

Uses of InitializeCollectionEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement InitializeCollectionEventListener
 class DefaultInitializeCollectionEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.LoadEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.LoadEvent

Packages that use LoadEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of LoadEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type LoadEvent
 void LoadEventListener.onLoad(LoadEvent event, LoadEventListener.LoadType loadType)
Handle the given load event.

Uses of LoadEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type LoadEvent
void | DefaultLoadEventListener.onLoad(LoadEvent event, LoadEventListener.LoadType loadType) Handle the given load event.
protected Object | DefaultLoadEventListener.load(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Perfoms the load of an entity.
protected Object | DefaultLoadEventListener.proxyOrLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Based on configured options, will either return a pre-existing proxy, generate a new proxy, or perform an actual load.
protected Object | DefaultLoadEventListener.lockAndLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options, SessionImplementor source) If the class to be loaded has been configured with a cache, then lock given id in that cache and then perform the load.
protected Object | DefaultLoadEventListener.doLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Coordinates the efforts to load a given entity.
protected Object | DefaultLoadEventListener.loadFromDatasource(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Performs the process of loading an entity from the configured underlying datasource.
protected Object | DefaultLoadEventListener.loadFromSessionCache(LoadEvent event, EntityKey keyToLoad, LoadEventListener.LoadType options) Attempts to locate the entity in the session-level cache.
protected Object | DefaultLoadEventListener.loadFromSecondLevelCache(LoadEvent event, EntityPersister persister, LoadEventListener.LoadType options) Attempts to load the entity from the second-level cache.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.LoadEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.LoadEventListener

Packages that use LoadEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of LoadEventListener in org.hibernate.event

Methods in org.hibernate.event that return LoadEventListener
 LoadEventListener[] EventListeners.getLoadEventListeners()

Methods in org.hibernate.event with parameters of type LoadEventListener
 void EventListeners.setLoadEventListeners(LoadEventListener[] loadEventListener)

Uses of LoadEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement LoadEventListener
 class DefaultLoadEventListener
Defines the default load event listeners used by hibernate for loading entities in response to generated load events.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.LoadEventListener.LoadType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.LoadEventListener.LoadType

Packages that use LoadEventListener.LoadType
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of LoadEventListener.LoadType in org.hibernate.event

Fields in org.hibernate.event declared as LoadEventListener.LoadType
static LoadEventListener.LoadType | LoadEventListener.RELOAD
static LoadEventListener.LoadType | LoadEventListener.GET
static LoadEventListener.LoadType | LoadEventListener.LOAD
static LoadEventListener.LoadType | LoadEventListener.IMMEDIATE_LOAD
static LoadEventListener.LoadType | LoadEventListener.INTERNAL_LOAD_EAGER
static LoadEventListener.LoadType | LoadEventListener.INTERNAL_LOAD_LAZY
static LoadEventListener.LoadType | LoadEventListener.INTERNAL_LOAD_NULLABLE

Methods in org.hibernate.event with parameters of type LoadEventListener.LoadType
 void LoadEventListener.onLoad(LoadEvent event, LoadEventListener.LoadType loadType)
Handle the given load event.

Uses of LoadEventListener.LoadType in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type LoadEventListener.LoadType
void | DefaultLoadEventListener.onLoad(LoadEvent event, LoadEventListener.LoadType loadType) Handle the given load event.
protected Object | DefaultLoadEventListener.load(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Perfoms the load of an entity.
protected Object | DefaultLoadEventListener.proxyOrLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Based on configured options, will either return a pre-existing proxy, generate a new proxy, or perform an actual load.
protected Object | DefaultLoadEventListener.lockAndLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options, SessionImplementor source) If the class to be loaded has been configured with a cache, then lock given id in that cache and then perform the load.
protected Object | DefaultLoadEventListener.doLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Coordinates the efforts to load a given entity.
protected Object | DefaultLoadEventListener.loadFromDatasource(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Performs the process of loading an entity from the configured underlying datasource.
protected Object | DefaultLoadEventListener.loadFromSessionCache(LoadEvent event, EntityKey keyToLoad, LoadEventListener.LoadType options) Attempts to locate the entity in the session-level cache.
protected Object | DefaultLoadEventListener.loadFromSecondLevelCache(LoadEvent event, EntityPersister persister, LoadEventListener.LoadType options) Attempts to load the entity from the second-level cache.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.LockEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.LockEvent

Packages that use LockEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of LockEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type LockEvent
 void LockEventListener.onLock(LockEvent event)
Handle the given lock event.

Uses of LockEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type LockEvent
 void DefaultLockEventListener.onLock(LockEvent event)
Handle the given lock event.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.LockEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.LockEventListener

Packages that use LockEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of LockEventListener in org.hibernate.event

Methods in org.hibernate.event that return LockEventListener
 LockEventListener[] EventListeners.getLockEventListeners()

Methods in org.hibernate.event with parameters of type LockEventListener
 void EventListeners.setLockEventListeners(LockEventListener[] lockEventListener)

Uses of LockEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement LockEventListener
 class DefaultLockEventListener
Defines the default lock event listeners used by hibernate to lock entities in response to generated lock events.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.MergeEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.MergeEvent

Packages that use MergeEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of MergeEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type MergeEvent
void | MergeEventListener.onMerge(MergeEvent event) Handle the given merge event.
void | MergeEventListener.onMerge(MergeEvent event, Map copiedAlready) Handle the given merge event.

Uses of MergeEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type MergeEvent
void | DefaultMergeEventListener.onMerge(MergeEvent event) Handle the given merge event.
void | DefaultMergeEventListener.onMerge(MergeEvent event, Map copyCache) Handle the given merge event.
protected void | DefaultMergeEventListener.entityIsPersistent(MergeEvent event, Map copyCache)
protected void | DefaultMergeEventListener.entityIsTransient(MergeEvent event, Map copyCache)
protected void | DefaultMergeEventListener.entityIsDetached(MergeEvent event, Map copyCache)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.MergeEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.MergeEventListener

Packages that use MergeEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of MergeEventListener in org.hibernate.event

Methods in org.hibernate.event that return MergeEventListener
MergeEventListener[] | EventListeners.getMergeEventListeners()
MergeEventListener[] | EventListeners.getSaveOrUpdateCopyEventListeners()

Methods in org.hibernate.event with parameters of type MergeEventListener
void | EventListeners.setMergeEventListeners(MergeEventListener[] mergeEventListener)
void | EventListeners.setSaveOrUpdateCopyEventListeners(MergeEventListener[] saveOrUpdateCopyEventListener)

Uses of MergeEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement MergeEventListener
class | DefaultMergeEventListener Defines the default copy event listener used by hibernate for copying entities in response to generated copy events.
class | DefaultSaveOrUpdateCopyEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.PersistEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.PersistEvent

Packages that use PersistEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of PersistEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type PersistEvent
void | PersistEventListener.onPersist(PersistEvent event) Handle the given create event.
void | PersistEventListener.onPersist(PersistEvent event, Map createdAlready) Handle the given create event.

Uses of PersistEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type PersistEvent
void | DefaultPersistEventListener.onPersist(PersistEvent event) Handle the given create event.
void | DefaultPersistEventListener.onPersist(PersistEvent event, Map createCache) Handle the given create event.
protected void | DefaultPersistEventListener.entityIsPersistent(PersistEvent event, Map createCache)
protected void | DefaultPersistEventListener.entityIsTransient(PersistEvent event, Map createCache) Handle the given create event.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.PersistEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.PersistEventListener

Packages that use PersistEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of PersistEventListener in org.hibernate.event

Methods in org.hibernate.event that return PersistEventListener
PersistEventListener[] | EventListeners.getPersistEventListeners()
PersistEventListener[] | EventListeners.getPersistOnFlushEventListeners()

Methods in org.hibernate.event with parameters of type PersistEventListener
void | EventListeners.setPersistEventListeners(PersistEventListener[] createEventListener)
void | EventListeners.setPersistOnFlushEventListeners(PersistEventListener[] createEventListener)

Uses of PersistEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement PersistEventListener
class | DefaultPersistEventListener Defines the default create event listener used by hibernate for creating transient entities in response to generated create events.
class | DefaultPersistOnFlushEventListener When persist is used as the cascade action, persistOnFlush should be used

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.PostDeleteEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.PostDeleteEvent

Packages that use PostDeleteEvent
org.hibernate.event This package defines an event framework for Hibernate.

Uses of PostDeleteEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type PostDeleteEvent
 void PostDeleteEventListener.onPostDelete(PostDeleteEvent event)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.PostDeleteEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.PostDeleteEventListener

Packages that use PostDeleteEventListener
org.hibernate.event This package defines an event framework for Hibernate.

Uses of PostDeleteEventListener in org.hibernate.event

Methods in org.hibernate.event that return PostDeleteEventListener
PostDeleteEventListener[] | EventListeners.getPostDeleteEventListeners()
PostDeleteEventListener[] | EventListeners.getPostCommitDeleteEventListeners()

Methods in org.hibernate.event with parameters of type PostDeleteEventListener
void | EventListeners.setPostDeleteEventListeners(PostDeleteEventListener[] postDeleteEventListener)
void | EventListeners.setPostCommitDeleteEventListeners(PostDeleteEventListener[] postCommitDeleteEventListeners)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.PostInsertEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.PostInsertEvent

Packages that use PostInsertEvent
org.hibernate.event This package defines an event framework for Hibernate.

Uses of PostInsertEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type PostInsertEvent
 void PostInsertEventListener.onPostInsert(PostInsertEvent event)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.PostInsertEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.PostInsertEventListener

Packages that use PostInsertEventListener
org.hibernate.event This package defines an event framework for Hibernate.

Uses of PostInsertEventListener in org.hibernate.event

Methods in org.hibernate.event that return PostInsertEventListener
PostInsertEventListener[] | EventListeners.getPostInsertEventListeners()
PostInsertEventListener[] | EventListeners.getPostCommitInsertEventListeners()

Methods in org.hibernate.event with parameters of type PostInsertEventListener
void | EventListeners.setPostInsertEventListeners(PostInsertEventListener[] postInsertEventListener)
void | EventListeners.setPostCommitInsertEventListeners(PostInsertEventListener[] postCommitInsertEventListeners)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.PostLoadEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.PostLoadEvent

Packages that use PostLoadEvent
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of PostLoadEvent in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type PostLoadEvent
static void TwoPhaseLoad.initializeEntity(Object entity, boolean readOnly, SessionImplementor session, PreLoadEvent preLoadEvent, PostLoadEvent postLoadEvent)
Perform the second step of 2-phase load.

Uses of PostLoadEvent in org.hibernate.event

Methods in org.hibernate.event that return PostLoadEvent
PostLoadEvent | PostLoadEvent.setEntity(Object entity)
PostLoadEvent | PostLoadEvent.setId(Serializable id)
PostLoadEvent | PostLoadEvent.setPersister(EntityPersister persister)

Methods in org.hibernate.event with parameters of type PostLoadEvent
 void PostLoadEventListener.onPostLoad(PostLoadEvent event)

Uses of PostLoadEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type PostLoadEvent
 void DefaultPostLoadEventListener.onPostLoad(PostLoadEvent event)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.PostLoadEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.PostLoadEventListener

Packages that use PostLoadEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of PostLoadEventListener in org.hibernate.event

Methods in org.hibernate.event that return PostLoadEventListener
 PostLoadEventListener[] EventListeners.getPostLoadEventListeners()

Methods in org.hibernate.event with parameters of type PostLoadEventListener
 void EventListeners.setPostLoadEventListeners(PostLoadEventListener[] postLoadEventListener)

Uses of PostLoadEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement PostLoadEventListener
 class DefaultPostLoadEventListener
Call Lifecycle interface if necessary

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.PostUpdateEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.PostUpdateEvent

Packages that use PostUpdateEvent
org.hibernate.event This package defines an event framework for Hibernate.

Uses of PostUpdateEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type PostUpdateEvent
 void PostUpdateEventListener.onPostUpdate(PostUpdateEvent event)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.PostUpdateEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.PostUpdateEventListener

Packages that use PostUpdateEventListener
org.hibernate.event This package defines an event framework for Hibernate.

Uses of PostUpdateEventListener in org.hibernate.event

Methods in org.hibernate.event that return PostUpdateEventListener
PostUpdateEventListener[] | EventListeners.getPostUpdateEventListeners()
PostUpdateEventListener[] | EventListeners.getPostCommitUpdateEventListeners()

Methods in org.hibernate.event with parameters of type PostUpdateEventListener
void | EventListeners.setPostUpdateEventListeners(PostUpdateEventListener[] postUpdateEventListener)
void | EventListeners.setPostCommitUpdateEventListeners(PostUpdateEventListener[] postCommitUpdateEventListeners)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.PreDeleteEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.PreDeleteEvent

Packages that use PreDeleteEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.secure | Declarative security for CRUD operations on entities.

Uses of PreDeleteEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type PreDeleteEvent
 boolean PreDeleteEventListener.onPreDelete(PreDeleteEvent event)

Uses of PreDeleteEvent in org.hibernate.secure

Methods in org.hibernate.secure with parameters of type PreDeleteEvent
 boolean JACCPreDeleteEventListener.onPreDelete(PreDeleteEvent event)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.PreDeleteEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.PreDeleteEventListener

Packages that use PreDeleteEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.secure | Declarative security for CRUD operations on entities.

Uses of PreDeleteEventListener in org.hibernate.event

Methods in org.hibernate.event that return PreDeleteEventListener
 PreDeleteEventListener[] EventListeners.getPreDeleteEventListeners()

Methods in org.hibernate.event with parameters of type PreDeleteEventListener
 void EventListeners.setPreDeleteEventListeners(PreDeleteEventListener[] preDeleteEventListener)

Uses of PreDeleteEventListener in org.hibernate.secure

Classes in org.hibernate.secure that implement PreDeleteEventListener
 class JACCPreDeleteEventListener
Check security before any deletion

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.PreInsertEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.PreInsertEvent

Packages that use PreInsertEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.secure | Declarative security for CRUD operations on entities.

Uses of PreInsertEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type PreInsertEvent
 boolean PreInsertEventListener.onPreInsert(PreInsertEvent event)

Uses of PreInsertEvent in org.hibernate.secure

Methods in org.hibernate.secure with parameters of type PreInsertEvent
 boolean JACCPreInsertEventListener.onPreInsert(PreInsertEvent event)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.PreInsertEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.PreInsertEventListener

Packages that use PreInsertEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.secure | Declarative security for CRUD operations on entities.

Uses of PreInsertEventListener in org.hibernate.event

Methods in org.hibernate.event that return PreInsertEventListener
 PreInsertEventListener[] EventListeners.getPreInsertEventListeners()

Methods in org.hibernate.event with parameters of type PreInsertEventListener
 void EventListeners.setPreInsertEventListeners(PreInsertEventListener[] preInsertEventListener)

Uses of PreInsertEventListener in org.hibernate.secure

Classes in org.hibernate.secure that implement PreInsertEventListener
 class JACCPreInsertEventListener
Check security before an insertion

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.PreLoadEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.PreLoadEvent

Packages that use PreLoadEvent
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.secure | Declarative security for CRUD operations on entities.

Uses of PreLoadEvent in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type PreLoadEvent
static void TwoPhaseLoad.initializeEntity(Object entity, boolean readOnly, SessionImplementor session, PreLoadEvent preLoadEvent, PostLoadEvent postLoadEvent)
Perform the second step of 2-phase load.

Uses of PreLoadEvent in org.hibernate.event

Methods in org.hibernate.event that return PreLoadEvent
PreLoadEvent | PreLoadEvent.setEntity(Object entity)
PreLoadEvent | PreLoadEvent.setId(Serializable id)
PreLoadEvent | PreLoadEvent.setPersister(EntityPersister persister)
PreLoadEvent | PreLoadEvent.setState(Object[] state)

Methods in org.hibernate.event with parameters of type PreLoadEvent
 void PreLoadEventListener.onPreLoad(PreLoadEvent event)

Uses of PreLoadEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type PreLoadEvent
 void DefaultPreLoadEventListener.onPreLoad(PreLoadEvent event)

Uses of PreLoadEvent in org.hibernate.secure

Methods in org.hibernate.secure with parameters of type PreLoadEvent
 void JACCPreLoadEventListener.onPreLoad(PreLoadEvent event)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.PreLoadEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.PreLoadEventListener

Packages that use PreLoadEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.secure | Declarative security for CRUD operations on entities.

Uses of PreLoadEventListener in org.hibernate.event

Methods in org.hibernate.event that return PreLoadEventListener
 PreLoadEventListener[] EventListeners.getPreLoadEventListeners()

Methods in org.hibernate.event with parameters of type PreLoadEventListener
 void EventListeners.setPreLoadEventListeners(PreLoadEventListener[] preLoadEventListener)

Uses of PreLoadEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement PreLoadEventListener
 class DefaultPreLoadEventListener
Called before injecting property values into a newly loaded entity instance.

Uses of PreLoadEventListener in org.hibernate.secure

Classes in org.hibernate.secure that implement PreLoadEventListener
 class JACCPreLoadEventListener
Check security before any load

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.PreUpdateEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.PreUpdateEvent

Packages that use PreUpdateEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.secure | Declarative security for CRUD operations on entities.

Uses of PreUpdateEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type PreUpdateEvent
 boolean PreUpdateEventListener.onPreUpdate(PreUpdateEvent event)

Uses of PreUpdateEvent in org.hibernate.secure

Methods in org.hibernate.secure with parameters of type PreUpdateEvent
 boolean JACCPreUpdateEventListener.onPreUpdate(PreUpdateEvent event)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.PreUpdateEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.PreUpdateEventListener

Packages that use PreUpdateEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.secure | Declarative security for CRUD operations on entities.

Uses of PreUpdateEventListener in org.hibernate.event

Methods in org.hibernate.event that return PreUpdateEventListener
 PreUpdateEventListener[] EventListeners.getPreUpdateEventListeners()

Methods in org.hibernate.event with parameters of type PreUpdateEventListener
 void EventListeners.setPreUpdateEventListeners(PreUpdateEventListener[] preUpdateEventListener)

Uses of PreUpdateEventListener in org.hibernate.secure

Classes in org.hibernate.secure that implement PreUpdateEventListener
 class JACCPreUpdateEventListener
Check security before any update

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.RefreshEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.RefreshEvent

Packages that use RefreshEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of RefreshEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type RefreshEvent
void | RefreshEventListener.onRefresh(RefreshEvent event) Handle the given refresh event.
void | RefreshEventListener.onRefresh(RefreshEvent event, Map refreshedAlready)

Uses of RefreshEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type RefreshEvent
void | DefaultRefreshEventListener.onRefresh(RefreshEvent event)
void | DefaultRefreshEventListener.onRefresh(RefreshEvent event, Map refreshedAlready) Handle the given refresh event.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.RefreshEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.RefreshEventListener

Packages that use RefreshEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of RefreshEventListener in org.hibernate.event

Methods in org.hibernate.event that return RefreshEventListener
 RefreshEventListener[] EventListeners.getRefreshEventListeners()

Methods in org.hibernate.event with parameters of type RefreshEventListener
 void EventListeners.setRefreshEventListeners(RefreshEventListener[] refreshEventListener)

Uses of RefreshEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement RefreshEventListener
 class DefaultRefreshEventListener
Defines the default refresh event listener used by hibernate for refreshing entities in response to generated refresh events.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.ReplicateEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.ReplicateEvent

Packages that use ReplicateEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of ReplicateEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type ReplicateEvent
 void ReplicateEventListener.onReplicate(ReplicateEvent event)
Handle the given replicate event.

Uses of ReplicateEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type ReplicateEvent
 void DefaultReplicateEventListener.onReplicate(ReplicateEvent event)
Handle the given replicate event.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.ReplicateEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.ReplicateEventListener

Packages that use ReplicateEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of ReplicateEventListener in org.hibernate.event

Methods in org.hibernate.event that return ReplicateEventListener
 ReplicateEventListener[] EventListeners.getReplicateEventListeners()

Methods in org.hibernate.event with parameters of type ReplicateEventListener
 void EventListeners.setReplicateEventListeners(ReplicateEventListener[] replicateEventListener)

Uses of ReplicateEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement ReplicateEventListener
 class DefaultReplicateEventListener
Defines the default replicate event listener used by Hibernate to replicate entities in response to generated replicate events.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.SaveOrUpdateEvent (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.SaveOrUpdateEvent

Packages that use SaveOrUpdateEvent
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of SaveOrUpdateEvent in org.hibernate.event

Methods in org.hibernate.event with parameters of type SaveOrUpdateEvent
 void SaveOrUpdateEventListener.onSaveOrUpdate(SaveOrUpdateEvent event)
Handle the given update event.

Uses of SaveOrUpdateEvent in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type SaveOrUpdateEvent
protected Serializable | DefaultUpdateEventListener.performSaveOrUpdate(SaveOrUpdateEvent event)
void | DefaultSaveOrUpdateEventListener.onSaveOrUpdate(SaveOrUpdateEvent event) Handle the given update event.
protected Serializable | DefaultSaveOrUpdateEventListener.performSaveOrUpdate(SaveOrUpdateEvent event)
protected Serializable | DefaultSaveOrUpdateEventListener.entityIsPersistent(SaveOrUpdateEvent event)
protected Serializable | DefaultSaveOrUpdateEventListener.entityIsTransient(SaveOrUpdateEvent event) Handle the given save event.
protected Serializable | DefaultSaveOrUpdateEventListener.saveWithGeneratedOrRequestedId(SaveOrUpdateEvent event) Save the transient instance, assigning the right identifier
protected void | DefaultSaveOrUpdateEventListener.entityIsDetached(SaveOrUpdateEvent event) Handle the given update event.
protected void | DefaultSaveOrUpdateEventListener.performUpdate(SaveOrUpdateEvent event, Object entity, EntityPersister persister)
protected Serializable | DefaultSaveEventListener.performSaveOrUpdate(SaveOrUpdateEvent event)
protected Serializable | DefaultSaveEventListener.saveWithGeneratedOrRequestedId(SaveOrUpdateEvent event)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.event.SaveOrUpdateEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.event.SaveOrUpdateEventListener

Packages that use SaveOrUpdateEventListener
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of SaveOrUpdateEventListener in org.hibernate.event

Methods in org.hibernate.event that return SaveOrUpdateEventListener
SaveOrUpdateEventListener[] | EventListeners.getSaveOrUpdateEventListeners()
SaveOrUpdateEventListener[] | EventListeners.getSaveEventListeners()
SaveOrUpdateEventListener[] | EventListeners.getUpdateEventListeners()

Methods in org.hibernate.event with parameters of type SaveOrUpdateEventListener
void | EventListeners.setSaveOrUpdateEventListeners(SaveOrUpdateEventListener[] saveOrUpdateEventListener)
void | EventListeners.setSaveEventListeners(SaveOrUpdateEventListener[] saveEventListener)
void | EventListeners.setUpdateEventListeners(SaveOrUpdateEventListener[] updateEventListener)

Uses of SaveOrUpdateEventListener in org.hibernate.event.def

Classes in org.hibernate.event.def that implement SaveOrUpdateEventListener
class | DefaultSaveEventListener An event handler for save() events
class | DefaultSaveOrUpdateEventListener Defines the default update event listener used by hibernate for updating transient entities in response to generated update events.
class | DefaultUpdateEventListener An event handler for update() events

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.event.def (Hibernate API Documentation)

 org.hibernate.event.def
Classes
AbstractFlushingEventListener
AbstractLockUpgradeEventListener
AbstractReassociateEventListener
AbstractSaveEventListener
AbstractVisitor
DefaultAutoFlushEventListener
DefaultDeleteEventListener
DefaultDirtyCheckEventListener
DefaultEvictEventListener
DefaultFlushEntityEventListener
DefaultFlushEventListener
DefaultInitializeCollectionEventListener
DefaultLoadEventListener
DefaultLockEventListener
DefaultMergeEventListener
DefaultPersistEventListener
DefaultPersistOnFlushEventListener
DefaultPostLoadEventListener
DefaultPreLoadEventListener
DefaultRefreshEventListener
DefaultReplicateEventListener
DefaultSaveEventListener
DefaultSaveOrUpdateCopyEventListener
DefaultSaveOrUpdateEventListener
DefaultUpdateEventListener
DirtyCollectionSearchVisitor
EvictVisitor
FlushVisitor
OnLockVisitor
OnReplicateVisitor
OnUpdateVisitor
ProxyVisitor
ReattachVisitor
WrapVisitor


Uses of Class org.hibernate.event.def.AbstractFlushingEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.AbstractFlushingEventListener

Packages that use AbstractFlushingEventListener
org.hibernate.event.def This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of AbstractFlushingEventListener in org.hibernate.event.def

Subclasses of AbstractFlushingEventListener in org.hibernate.event.def
class | DefaultAutoFlushEventListener Defines the default flush event listeners used by hibernate for flushing session state in response to generated auto-flush events.
class | DefaultDirtyCheckEventListener Defines the default dirty-check event listener used by hibernate for checking the session for dirtiness in response to generated dirty-check events.
class | DefaultFlushEventListener Defines the default flush event listeners used by hibernate for flushing session state in response to generated flush events.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.AbstractLockUpgradeEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.AbstractLockUpgradeEventListener

Packages that use AbstractLockUpgradeEventListener
org.hibernate.event.def This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of AbstractLockUpgradeEventListener in org.hibernate.event.def

Subclasses of AbstractLockUpgradeEventListener in org.hibernate.event.def
class | DefaultLoadEventListener Defines the default load event listeners used by hibernate for loading entities in response to generated load events.
class | DefaultLockEventListener Defines the default lock event listeners used by hibernate to lock entities in response to generated lock events.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.AbstractReassociateEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.AbstractReassociateEventListener

Packages that use AbstractReassociateEventListener
org.hibernate.event.def This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of AbstractReassociateEventListener in org.hibernate.event.def

Subclasses of AbstractReassociateEventListener in org.hibernate.event.def
class | AbstractLockUpgradeEventListener A convenience base class for listeners that respond to requests to perform a pessimistic lock upgrade on an entity.
class | AbstractSaveEventListener A convenience bas class for listeners responding to save events.
class | DefaultLoadEventListener Defines the default load event listeners used by hibernate for loading entities in response to generated load events.
class | DefaultLockEventListener Defines the default lock event listeners used by hibernate to lock entities in response to generated lock events.
class | DefaultMergeEventListener Defines the default copy event listener used by hibernate for copying entities in response to generated copy events.
class | DefaultPersistEventListener Defines the default create event listener used by hibernate for creating transient entities in response to generated create events.
class | DefaultPersistOnFlushEventListener When persist is used as the cascade action, persistOnFlush should be used
class | DefaultReplicateEventListener Defines the default replicate event listener used by Hibernate to replicate entities in response to generated replicate events.
class | DefaultSaveEventListener An event handler for save() events
class | DefaultSaveOrUpdateCopyEventListener
class | DefaultSaveOrUpdateEventListener Defines the default update event listener used by hibernate for updating transient entities in response to generated update events.
class | DefaultUpdateEventListener An event handler for update() events

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.AbstractSaveEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.AbstractSaveEventListener

Packages that use AbstractSaveEventListener
org.hibernate.event.def This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of AbstractSaveEventListener in org.hibernate.event.def

Subclasses of AbstractSaveEventListener in org.hibernate.event.def
class | DefaultMergeEventListener Defines the default copy event listener used by hibernate for copying entities in response to generated copy events.
class | DefaultPersistEventListener Defines the default create event listener used by hibernate for creating transient entities in response to generated create events.
class | DefaultPersistOnFlushEventListener When persist is used as the cascade action, persistOnFlush should be used
class | DefaultReplicateEventListener Defines the default replicate event listener used by Hibernate to replicate entities in response to generated replicate events.
class | DefaultSaveEventListener An event handler for save() events
class | DefaultSaveOrUpdateCopyEventListener
class | DefaultSaveOrUpdateEventListener Defines the default update event listener used by hibernate for updating transient entities in response to generated update events.
class | DefaultUpdateEventListener An event handler for update() events

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.AbstractVisitor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.AbstractVisitor

Packages that use AbstractVisitor
org.hibernate.event.def This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of AbstractVisitor in org.hibernate.event.def

Subclasses of AbstractVisitor in org.hibernate.event.def
class | DirtyCollectionSearchVisitor Do we have a dirty collection here? 1.
class | EvictVisitor Evict any collections referenced by the object from the session cache.
class | FlushVisitor Process collections reachable from an entity.
class | OnLockVisitor When a transient entity is passed to lock(), we must inspect all its collections and 1.
class | OnReplicateVisitor When an entity is passed to replicate(), and there is an existing row, we must inspect all its collections and 1.
class | OnUpdateVisitor When an entity is passed to update(), we must inspect all its collections and 1.
class | ProxyVisitor Reassociates uninitialized proxies with the session
class | ReattachVisitor Abstract superclass of visitors that reattach collections
class | WrapVisitor Wrap collections in a Hibernate collection wrapper.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultAutoFlushEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultAutoFlushEventListener

No usage of org.hibernate.event.def.DefaultAutoFlushEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultDeleteEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultDeleteEventListener

No usage of org.hibernate.event.def.DefaultDeleteEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultDirtyCheckEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultDirtyCheckEventListener

No usage of org.hibernate.event.def.DefaultDirtyCheckEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultEvictEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultEvictEventListener

No usage of org.hibernate.event.def.DefaultEvictEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultFlushEntityEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultFlushEntityEventListener

No usage of org.hibernate.event.def.DefaultFlushEntityEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultFlushEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultFlushEventListener

No usage of org.hibernate.event.def.DefaultFlushEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultInitializeCollectionEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultInitializeCollectionEventListener

No usage of org.hibernate.event.def.DefaultInitializeCollectionEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultLoadEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultLoadEventListener

No usage of org.hibernate.event.def.DefaultLoadEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultLockEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultLockEventListener

No usage of org.hibernate.event.def.DefaultLockEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultMergeEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultMergeEventListener

Packages that use DefaultMergeEventListener
org.hibernate.event.def This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of DefaultMergeEventListener in org.hibernate.event.def

Subclasses of DefaultMergeEventListener in org.hibernate.event.def
 class DefaultSaveOrUpdateCopyEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultPersistEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultPersistEventListener

Packages that use DefaultPersistEventListener
org.hibernate.event.def This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of DefaultPersistEventListener in org.hibernate.event.def

Subclasses of DefaultPersistEventListener in org.hibernate.event.def
 class DefaultPersistOnFlushEventListener
When persist is used as the cascade action, persistOnFlush should be used

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultPersistOnFlushEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultPersistOnFlushEventListener

No usage of org.hibernate.event.def.DefaultPersistOnFlushEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultPostLoadEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultPostLoadEventListener

No usage of org.hibernate.event.def.DefaultPostLoadEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultPreLoadEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultPreLoadEventListener

No usage of org.hibernate.event.def.DefaultPreLoadEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultRefreshEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultRefreshEventListener

No usage of org.hibernate.event.def.DefaultRefreshEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultReplicateEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultReplicateEventListener

No usage of org.hibernate.event.def.DefaultReplicateEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultSaveEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultSaveEventListener

No usage of org.hibernate.event.def.DefaultSaveEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultSaveOrUpdateCopyEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultSaveOrUpdateCopyEventListener

No usage of org.hibernate.event.def.DefaultSaveOrUpdateCopyEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultSaveOrUpdateEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultSaveOrUpdateEventListener

Packages that use DefaultSaveOrUpdateEventListener
org.hibernate.event.def This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of DefaultSaveOrUpdateEventListener in org.hibernate.event.def

Subclasses of DefaultSaveOrUpdateEventListener in org.hibernate.event.def
class | DefaultSaveEventListener An event handler for save() events
class | DefaultUpdateEventListener An event handler for update() events

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DefaultUpdateEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DefaultUpdateEventListener

No usage of org.hibernate.event.def.DefaultUpdateEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.DirtyCollectionSearchVisitor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.DirtyCollectionSearchVisitor

No usage of org.hibernate.event.def.DirtyCollectionSearchVisitor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.EvictVisitor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.EvictVisitor

No usage of org.hibernate.event.def.EvictVisitor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.FlushVisitor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.FlushVisitor

No usage of org.hibernate.event.def.FlushVisitor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.OnLockVisitor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.OnLockVisitor

No usage of org.hibernate.event.def.OnLockVisitor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.OnReplicateVisitor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.OnReplicateVisitor

No usage of org.hibernate.event.def.OnReplicateVisitor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.OnUpdateVisitor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.OnUpdateVisitor

No usage of org.hibernate.event.def.OnUpdateVisitor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.ProxyVisitor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.ProxyVisitor

Packages that use ProxyVisitor
org.hibernate.event.def This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of ProxyVisitor in org.hibernate.event.def

Subclasses of ProxyVisitor in org.hibernate.event.def
class | OnLockVisitor When a transient entity is passed to lock(), we must inspect all its collections and 1.
class | OnReplicateVisitor When an entity is passed to replicate(), and there is an existing row, we must inspect all its collections and 1.
class | OnUpdateVisitor When an entity is passed to update(), we must inspect all its collections and 1.
class | ReattachVisitor Abstract superclass of visitors that reattach collections
class | WrapVisitor Wrap collections in a Hibernate collection wrapper.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.ReattachVisitor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.ReattachVisitor

Packages that use ReattachVisitor
org.hibernate.event.def This package defines a default set of event listeners that implements the default behaviors of Hibernate.

Uses of ReattachVisitor in org.hibernate.event.def

Subclasses of ReattachVisitor in org.hibernate.event.def
class | OnLockVisitor When a transient entity is passed to lock(), we must inspect all its collections and 1.
class | OnReplicateVisitor When an entity is passed to replicate(), and there is an existing row, we must inspect all its collections and 1.
class | OnUpdateVisitor When an entity is passed to update(), we must inspect all its collections and 1.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.event.def.WrapVisitor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.event.def.WrapVisitor

No usage of org.hibernate.event.def.WrapVisitor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.exception (Hibernate API Documentation)

 org.hibernate.exception
Interfaces
Configurable
Nestable
SQLExceptionConverter
ViolatedConstraintNameExtracter
Classes
ExceptionUtils
JDBCExceptionHelper
NestableDelegate
SQLExceptionConverterFactory
SQLStateConverter
TemplatedViolatedConstraintNameExtracter
Exceptions
ConstraintViolationException
DataException
GenericJDBCException
JDBCConnectionException
LockAcquisitionException
NestableException
NestableRuntimeException
SQLGrammarException


Uses of Interface org.hibernate.exception.Configurable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.exception.Configurable

No usage of org.hibernate.exception.Configurable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.ConstraintViolationException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.ConstraintViolationException

No usage of org.hibernate.exception.ConstraintViolationException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.DataException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.DataException

No usage of org.hibernate.exception.DataException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.ExceptionUtils (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.ExceptionUtils

No usage of org.hibernate.exception.ExceptionUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.GenericJDBCException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.GenericJDBCException

No usage of org.hibernate.exception.GenericJDBCException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.JDBCConnectionException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.JDBCConnectionException

No usage of org.hibernate.exception.JDBCConnectionException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.JDBCExceptionHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.JDBCExceptionHelper

No usage of org.hibernate.exception.JDBCExceptionHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.LockAcquisitionException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.LockAcquisitionException

No usage of org.hibernate.exception.LockAcquisitionException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.exception.Nestable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.exception.Nestable

Packages that use Nestable
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.classic | This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.
org.hibernate.exception | This package is a fork of Apache commons-lang nestable exceptions.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of Nestable in org.hibernate

Classes in org.hibernate that implement Nestable
class | AssertionFailure Indicates failure of an assertion: a possible bug in Hibernate.
class | CallbackException Should be thrown by persistent objects from Lifecycle or Interceptor callbacks.
class | DuplicateMappingException Raised whenever a duplicate for a certain type occurs.
class | HibernateException Any exception that occurs inside the persistence layer or JDBC driver.
class | InstantiationException Thrown if Hibernate can't instantiate an entity or component class at runtime.
class | InvalidMappingException Thrown when a mapping is found to be invalid.
class | JDBCException Wraps an SQLException.
class | LazyInitializationException Indicates access to unfetched data outside of a session context.
class | MappingException An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
class | MappingNotFoundException Thrown when a resource for a mapping could not be found.
class | NonUniqueObjectException This exception is thrown when an operation would break session-scoped identity.
class | NonUniqueResultException Thrown when the application calls Query.uniqueResult() and the query returned more than one result.
class | ObjectDeletedException Thrown when the user tries to do something illegal with a deleted object.
class | ObjectNotFoundException Thrown when Session.load() fails to select a row with the given primary key (identifier value).
class | PersistentObjectException Thrown when the user passes a persistent instance to a Session method that expects a transient instance.
class | PropertyAccessException A problem occurred accessing a property of an instance of a persistent class by reflection, or via CGLIB.
class | PropertyNotFoundException Indicates that an expected getter or setter method could not be found on a class.
class | PropertyValueException Thrown when the (illegal) value of a property can not be persisted.
class | QueryException A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
class | QueryParameterException Parameter invalid or not found in the query
class | SessionException Thrown when the user calls a method of a Session that is in an inappropropriate state for the given call (for example, the the session is closed or disconnected).
class | StaleObjectStateException A StaleStateException that carries information about a particular entity instance that was the source of the failure.
class | StaleStateException Thrown when a version number or timestamp check failed, indicating that the Session contained stale data (when using long transactions with versioning).
class | TransactionException Indicates that a transaction could not be begun, committed or rolled back.
class | TransientObjectException Thrown when the user passes a transient instance to a Session method that expects a persistent instance.
class | TypeMismatchException Used when a user provided type does not match the expected one
class | UnresolvableObjectException Thrown when Hibernate could not resolve an object by id, especially when loading an association.
class | WrongClassException Thrown when Session.load() selects a row with the given primary key (identifier value) but the row's discriminator value specifies a subclass that is not assignable to the class requested by the user.

Uses of Nestable in org.hibernate.cache

Classes in org.hibernate.cache that implement Nestable
class | CacheException Something went wrong in the cache
class | NoCachingEnabledException Implementation of NoCachingEnabledException.

Uses of Nestable in org.hibernate.classic

Classes in org.hibernate.classic that implement Nestable
 class ValidationFailure
Thrown from Validatable.validate() when an invariant was violated.

Uses of Nestable in org.hibernate.exception

Classes in org.hibernate.exception that implement Nestable
class | ConstraintViolationException Implementation of JDBCException indicating that the requested DML operation resulted in a violation of a defined integrity constraint.
class | DataException Implementation of JDBCException indicating that evaluation of the valid SQL statement against the given data resulted in some illegal operation, mismatched types or incorrect cardinality.
class | GenericJDBCException Generic, non-specific JDBCException.
class | JDBCConnectionException Implementation of JDBCException indicating problems with communicating with the database (can also include incorrect JDBC setup).
class | LockAcquisitionException Implementation of JDBCException indicating a problem acquiring lock on the database.
class | NestableException The base class of all exceptions which can contain other exceptions.
class | NestableRuntimeException The base class of all runtime exceptions which can contain other exceptions.
class | SQLGrammarException Implementation of JDBCException indicating that the SQL sent to the database server was invalid (syntax error, invalid object references, etc).

Constructors in org.hibernate.exception with parameters of type Nestable
NestableDelegate(Nestable nestable)
Constructs a new NestableDelegate instance to manage the specified Nestable.

Uses of Nestable in org.hibernate.hql

Classes in org.hibernate.hql that implement Nestable
 class QueryExecutionRequestException
Expecting to execute an illegal operation regarding the query type

Uses of Nestable in org.hibernate.hql.ast

Classes in org.hibernate.hql.ast that implement Nestable
 class QuerySyntaxException
Exception thrown when there is a syntax error in the HQL.

Uses of Nestable in org.hibernate.id

Classes in org.hibernate.id that implement Nestable
 class IdentifierGenerationException
Thrown by IdentifierGenerator implementation class when ID generation fails.

Uses of Nestable in org.hibernate.jdbc

Classes in org.hibernate.jdbc that implement Nestable
class | BatchedTooManyRowsAffectedException Much like TooManyRowsAffectedException, indicates that more rows than what we were expcecting were affected.
class | BatchFailedException Indicates a failed batch entry (-3 return).
class | TooManyRowsAffectedException Indicates that more rows were affected then we were expecting to be.

Uses of Nestable in org.hibernate.type

Classes in org.hibernate.type that implement Nestable
 class SerializationException
Thrown when a property cannot be serializaed/deserialized

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.NestableDelegate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.NestableDelegate

Packages that use NestableDelegate
org.hibernate.exception This package is a fork of Apache commons-lang nestable exceptions.

Uses of NestableDelegate in org.hibernate.exception

Fields in org.hibernate.exception declared as NestableDelegate
protected NestableDelegate | NestableRuntimeException.delegate The helper instance which contains much of the code which we delegate to.
protected NestableDelegate | NestableException.delegate The helper instance which contains much of the code which we delegate to.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.NestableException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.NestableException

No usage of org.hibernate.exception.NestableException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.NestableRuntimeException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.NestableRuntimeException

Packages that use NestableRuntimeException
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.classic | This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.
org.hibernate.exception | This package is a fork of Apache commons-lang nestable exceptions.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of NestableRuntimeException in org.hibernate

Subclasses of NestableRuntimeException in org.hibernate
class | AssertionFailure Indicates failure of an assertion: a possible bug in Hibernate.
class | CallbackException Should be thrown by persistent objects from Lifecycle or Interceptor callbacks.
class | DuplicateMappingException Raised whenever a duplicate for a certain type occurs.
class | HibernateException Any exception that occurs inside the persistence layer or JDBC driver.
class | InstantiationException Thrown if Hibernate can't instantiate an entity or component class at runtime.
class | InvalidMappingException Thrown when a mapping is found to be invalid.
class | JDBCException Wraps an SQLException.
class | LazyInitializationException Indicates access to unfetched data outside of a session context.
class | MappingException An exception that usually occurs at configuration time, rather than runtime, as a result of something screwy in the O-R mappings.
class | MappingNotFoundException Thrown when a resource for a mapping could not be found.
class | NonUniqueObjectException This exception is thrown when an operation would break session-scoped identity.
class | NonUniqueResultException Thrown when the application calls Query.uniqueResult() and the query returned more than one result.
class | ObjectDeletedException Thrown when the user tries to do something illegal with a deleted object.
class | ObjectNotFoundException Thrown when Session.load() fails to select a row with the given primary key (identifier value).
class | PersistentObjectException Thrown when the user passes a persistent instance to a Session method that expects a transient instance.
class | PropertyAccessException A problem occurred accessing a property of an instance of a persistent class by reflection, or via CGLIB.
class | PropertyNotFoundException Indicates that an expected getter or setter method could not be found on a class.
class | PropertyValueException Thrown when the (illegal) value of a property can not be persisted.
class | QueryException A problem occurred translating a Hibernate query to SQL due to invalid query syntax, etc.
class | QueryParameterException Parameter invalid or not found in the query
class | SessionException Thrown when the user calls a method of a Session that is in an inappropropriate state for the given call (for example, the the session is closed or disconnected).
class | StaleObjectStateException A StaleStateException that carries information about a particular entity instance that was the source of the failure.
class | StaleStateException Thrown when a version number or timestamp check failed, indicating that the Session contained stale data (when using long transactions with versioning).
class | TransactionException Indicates that a transaction could not be begun, committed or rolled back.
class | TransientObjectException Thrown when the user passes a transient instance to a Session method that expects a persistent instance.
class | TypeMismatchException Used when a user provided type does not match the expected one
class | UnresolvableObjectException Thrown when Hibernate could not resolve an object by id, especially when loading an association.
class | WrongClassException Thrown when Session.load() selects a row with the given primary key (identifier value) but the row's discriminator value specifies a subclass that is not assignable to the class requested by the user.

Uses of NestableRuntimeException in org.hibernate.cache

Subclasses of NestableRuntimeException in org.hibernate.cache
class | CacheException Something went wrong in the cache
class | NoCachingEnabledException Implementation of NoCachingEnabledException.

Uses of NestableRuntimeException in org.hibernate.classic

Subclasses of NestableRuntimeException in org.hibernate.classic
 class ValidationFailure
Thrown from Validatable.validate() when an invariant was violated.

Uses of NestableRuntimeException in org.hibernate.exception

Subclasses of NestableRuntimeException in org.hibernate.exception
class | ConstraintViolationException Implementation of JDBCException indicating that the requested DML operation resulted in a violation of a defined integrity constraint.
class | DataException Implementation of JDBCException indicating that evaluation of the valid SQL statement against the given data resulted in some illegal operation, mismatched types or incorrect cardinality.
class | GenericJDBCException Generic, non-specific JDBCException.
class | JDBCConnectionException Implementation of JDBCException indicating problems with communicating with the database (can also include incorrect JDBC setup).
class | LockAcquisitionException Implementation of JDBCException indicating a problem acquiring lock on the database.
class | SQLGrammarException Implementation of JDBCException indicating that the SQL sent to the database server was invalid (syntax error, invalid object references, etc).

Uses of NestableRuntimeException in org.hibernate.hql

Subclasses of NestableRuntimeException in org.hibernate.hql
 class QueryExecutionRequestException
Expecting to execute an illegal operation regarding the query type

Uses of NestableRuntimeException in org.hibernate.hql.ast

Subclasses of NestableRuntimeException in org.hibernate.hql.ast
 class QuerySyntaxException
Exception thrown when there is a syntax error in the HQL.

Uses of NestableRuntimeException in org.hibernate.id

Subclasses of NestableRuntimeException in org.hibernate.id
 class IdentifierGenerationException
Thrown by IdentifierGenerator implementation class when ID generation fails.

Uses of NestableRuntimeException in org.hibernate.jdbc

Subclasses of NestableRuntimeException in org.hibernate.jdbc
class | BatchedTooManyRowsAffectedException Much like TooManyRowsAffectedException, indicates that more rows than what we were expcecting were affected.
class | BatchFailedException Indicates a failed batch entry (-3 return).
class | TooManyRowsAffectedException Indicates that more rows were affected then we were expecting to be.

Uses of NestableRuntimeException in org.hibernate.type

Subclasses of NestableRuntimeException in org.hibernate.type
 class SerializationException
Thrown when a property cannot be serializaed/deserialized

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.exception.SQLExceptionConverter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.exception.SQLExceptionConverter

Packages that use SQLExceptionConverter
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.exception | This package is a fork of Apache commons-lang nestable exceptions.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.

Uses of SQLExceptionConverter in org.hibernate.cfg

Methods in org.hibernate.cfg that return SQLExceptionConverter
 SQLExceptionConverter Settings.getSQLExceptionConverter()

Uses of SQLExceptionConverter in org.hibernate.dialect

Methods in org.hibernate.dialect that return SQLExceptionConverter
 SQLExceptionConverter Dialect.buildSQLExceptionConverter()
Build an instance of the SQLExceptionConverter preferred by this dialect for converting SQLExceptions into Hibernate's JDBCException hierarchy.

Uses of SQLExceptionConverter in org.hibernate.engine

Methods in org.hibernate.engine that return SQLExceptionConverter
 SQLExceptionConverter SessionFactoryImplementor.getSQLExceptionConverter()
Retrieves the SQLExceptionConverter in effect for this SessionFactory.

Uses of SQLExceptionConverter in org.hibernate.exception

Classes in org.hibernate.exception that implement SQLExceptionConverter
 class SQLStateConverter
A SQLExceptionConverter implementation which performs converion based on the underlying SQLState.

Methods in org.hibernate.exception that return SQLExceptionConverter
static SQLExceptionConverter | SQLExceptionConverterFactory.buildSQLExceptionConverter(Dialect dialect, Properties properties) Build a SQLExceptionConverter instance.
static SQLExceptionConverter | SQLExceptionConverterFactory.buildMinimalSQLExceptionConverter() Builds a minimal converter.

Methods in org.hibernate.exception with parameters of type SQLExceptionConverter
static JDBCException | JDBCExceptionHelper.convert(SQLExceptionConverter converter, SQLException sqlException, String message) Converts the given SQLException into Hibernate's JDBCException hierarchy, as well as performing appropriate logging.
static JDBCException | JDBCExceptionHelper.convert(SQLExceptionConverter converter, SQLException sqlException, String message, String sql) Converts the given SQLException into Hibernate's JDBCException hierarchy, as well as performing appropriate logging.

Uses of SQLExceptionConverter in org.hibernate.impl

Methods in org.hibernate.impl that return SQLExceptionConverter
 SQLExceptionConverter SessionFactoryImpl.getSQLExceptionConverter()

Uses of SQLExceptionConverter in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that return SQLExceptionConverter
protected  SQLExceptionConverter AbstractCollectionPersister.getSQLExceptionConverter()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.SQLExceptionConverterFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.SQLExceptionConverterFactory

No usage of org.hibernate.exception.SQLExceptionConverterFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.SQLGrammarException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.SQLGrammarException

No usage of org.hibernate.exception.SQLGrammarException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.SQLStateConverter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.SQLStateConverter

No usage of org.hibernate.exception.SQLStateConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.exception.TemplatedViolatedConstraintNameExtracter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.exception.TemplatedViolatedConstraintNameExtracter

No usage of org.hibernate.exception.TemplatedViolatedConstraintNameExtracter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.exception.ViolatedConstraintNameExtracter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.exception.ViolatedConstraintNameExtracter

Packages that use ViolatedConstraintNameExtracter
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.exception | This package is a fork of Apache commons-lang nestable exceptions.

Uses of ViolatedConstraintNameExtracter in org.hibernate.dialect

Methods in org.hibernate.dialect that return ViolatedConstraintNameExtracter
ViolatedConstraintNameExtracter | PostgreSQLDialect.getViolatedConstraintNameExtracter()
ViolatedConstraintNameExtracter | Oracle9Dialect.getViolatedConstraintNameExtracter()
ViolatedConstraintNameExtracter | InformixDialect.getViolatedConstraintNameExtracter()
ViolatedConstraintNameExtracter | HSQLDialect.getViolatedConstraintNameExtracter()
ViolatedConstraintNameExtracter | H2Dialect.getViolatedConstraintNameExtracter()
ViolatedConstraintNameExtracter | Dialect.getViolatedConstraintNameExtracter()

Uses of ViolatedConstraintNameExtracter in org.hibernate.exception

Classes in org.hibernate.exception that implement ViolatedConstraintNameExtracter
 class TemplatedViolatedConstraintNameExtracter
Knows how to extract a violated constraint name from an error message based on the fact that the constraint name is templated within the message.

Constructors in org.hibernate.exception with parameters of type ViolatedConstraintNameExtracter
SQLStateConverter(ViolatedConstraintNameExtracter extracter)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.hql (Hibernate API Documentation)

 org.hibernate.hql
Interfaces
FilterTranslator
ParameterTranslations
QueryTranslator
QueryTranslatorFactory
Classes
CollectionProperties
CollectionSubqueryFactory
HolderInstantiator
NameGenerator
QuerySplitter
Exceptions
QueryExecutionRequestException


org.hibernate.hql.antlr (Hibernate API Documentation)

 org.hibernate.hql.antlr
Interfaces
HqlSqlTokenTypes
HqlTokenTypes
SqlTokenTypes
Classes
HqlBaseLexer
HqlBaseParser
HqlSqlBaseWalker
SqlGeneratorBase


Uses of Class org.hibernate.hql.antlr.HqlBaseLexer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.antlr.HqlBaseLexer

No usage of org.hibernate.hql.antlr.HqlBaseLexer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.antlr.HqlBaseParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.antlr.HqlBaseParser

Packages that use HqlBaseParser
org.hibernate.hql.ast An ANTLR-based parser for Hibernate Query Language.

Uses of HqlBaseParser in org.hibernate.hql.ast

Subclasses of HqlBaseParser in org.hibernate.hql.ast
 class HqlParser
Implements the semantic action methods defined in the HQL base parser to keep the grammar source file a little cleaner.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.antlr.HqlSqlBaseWalker (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.antlr.HqlSqlBaseWalker

Packages that use HqlSqlBaseWalker
org.hibernate.hql.ast An ANTLR-based parser for Hibernate Query Language.

Uses of HqlSqlBaseWalker in org.hibernate.hql.ast

Subclasses of HqlSqlBaseWalker in org.hibernate.hql.ast
 class HqlSqlWalker
Implements methods used by the HQL->SQL tree transform grammar (a.k.a.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.antlr.HqlSqlTokenTypes (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.antlr.HqlSqlTokenTypes

Packages that use HqlSqlTokenTypes
org.hibernate.hql.antlr | A special package for ANTLR-generated parser classes.
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |

Uses of HqlSqlTokenTypes in org.hibernate.hql.antlr

Classes in org.hibernate.hql.antlr that implement HqlSqlTokenTypes
 class HqlSqlBaseWalker
Hibernate Query Language to SQL Tree Transform.
This is a tree grammar that transforms an HQL AST into a intermediate SQL AST with bindings to Hibernate interfaces (Queryable, etc.).

Uses of HqlSqlTokenTypes in org.hibernate.hql.ast

Classes in org.hibernate.hql.ast that implement HqlSqlTokenTypes
class | HqlSqlWalker Implements methods used by the HQL->SQL tree transform grammar (a.k.a.
class | SqlASTFactory Custom AST factory the intermediate tree that causes ANTLR to create specialized AST nodes, given the AST node type (from HqlSqlTokenTypes).

Uses of HqlSqlTokenTypes in org.hibernate.hql.ast.tree

Classes in org.hibernate.hql.ast.tree that implement HqlSqlTokenTypes
class | BooleanLiteralNode Represents a boolean literal within a query.
class | FromClause Represents the 'FROM' part of a query or subquery, containing all mapped class references.
class | LiteralNode Represents a literal.
class | OrderByClause Implementation of OrderByClause.

Uses of HqlSqlTokenTypes in org.hibernate.hql.ast.util

Classes in org.hibernate.hql.ast.util that implement HqlSqlTokenTypes
class | LiteralProcessor A delegate that handles literals and constants for HqlSqlWalker, performing the token replacement functions and classifying literals.
class | SyntheticAndFactory Creates synthetic and nodes based on the where fragment part of a JoinSequence.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.antlr.HqlTokenTypes (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.antlr.HqlTokenTypes

Packages that use HqlTokenTypes
org.hibernate.hql.antlr | A special package for ANTLR-generated parser classes.
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.

Uses of HqlTokenTypes in org.hibernate.hql.antlr

Classes in org.hibernate.hql.antlr that implement HqlTokenTypes
class | HqlBaseLexer Hibernate Query Language Lexer This lexer provides the HQL parser with tokens.
class | HqlBaseParser Hibernate Query Language Grammar This grammar parses the query language for Hibernate (an Open Source, Object-Relational mapping library).

Uses of HqlTokenTypes in org.hibernate.hql.ast

Classes in org.hibernate.hql.ast that implement HqlTokenTypes
 class HqlParser
Implements the semantic action methods defined in the HQL base parser to keep the grammar source file a little cleaner.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.antlr.SqlGeneratorBase (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.antlr.SqlGeneratorBase

Packages that use SqlGeneratorBase
org.hibernate.hql.ast An ANTLR-based parser for Hibernate Query Language.

Uses of SqlGeneratorBase in org.hibernate.hql.ast

Subclasses of SqlGeneratorBase in org.hibernate.hql.ast
 class SqlGenerator
Generates SQL by overriding callback methods in the base class, which does the actual SQL AST walking.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.antlr.SqlTokenTypes (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.antlr.SqlTokenTypes

Packages that use SqlTokenTypes
org.hibernate.hql.antlr | A special package for ANTLR-generated parser classes.
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.util |

Uses of SqlTokenTypes in org.hibernate.hql.antlr

Classes in org.hibernate.hql.antlr that implement SqlTokenTypes
 class SqlGeneratorBase
SQL Generator Tree Parser, providing SQL rendering of SQL ASTs produced by the previous phase, HqlSqlWalker.

Uses of SqlTokenTypes in org.hibernate.hql.ast

Classes in org.hibernate.hql.ast that implement SqlTokenTypes
 class SqlGenerator
Generates SQL by overriding callback methods in the base class, which does the actual SQL AST walking.

Uses of SqlTokenTypes in org.hibernate.hql.ast.util

Classes in org.hibernate.hql.ast.util that implement SqlTokenTypes
 class JoinProcessor
Performs the post-processing of the join information gathered during semantic analysis.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.hql.ast (Hibernate API Documentation)

 org.hibernate.hql.ast
Interfaces
ErrorReporter
ParseErrorHandler
Classes
ASTQueryTranslatorFactory
ErrorCounter
HqlASTFactory
HqlParser
HqlSqlWalker
HqlToken
ParameterTranslationsImpl
ParameterTranslationsImpl.ParameterInfo
QueryTranslatorImpl
QueryTranslatorImpl.JavaConstantConverter
SqlASTFactory
SqlGenerator
Exceptions
DetailedSemanticException
InvalidPathException
QuerySyntaxException


Uses of Class org.hibernate.hql.ast.ASTQueryTranslatorFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.ASTQueryTranslatorFactory

No usage of org.hibernate.hql.ast.ASTQueryTranslatorFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.DetailedSemanticException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.DetailedSemanticException

No usage of org.hibernate.hql.ast.DetailedSemanticException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.ErrorCounter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.ErrorCounter

No usage of org.hibernate.hql.ast.ErrorCounter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.ErrorReporter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.ErrorReporter

Packages that use ErrorReporter
org.hibernate.hql.ast An ANTLR-based parser for Hibernate Query Language.

Uses of ErrorReporter in org.hibernate.hql.ast

Subinterfaces of ErrorReporter in org.hibernate.hql.ast
 interface ParseErrorHandler
Defines the behavior of an error handler for the HQL parsers.

Classes in org.hibernate.hql.ast that implement ErrorReporter
class | ErrorCounter An error handler that counts parsing errors and warnings.
class | HqlSqlWalker Implements methods used by the HQL->SQL tree transform grammar (a.k.a.
class | SqlGenerator Generates SQL by overriding callback methods in the base class, which does the actual SQL AST walking.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.HqlASTFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.HqlASTFactory

No usage of org.hibernate.hql.ast.HqlASTFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.HqlParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.HqlParser

Packages that use HqlParser
org.hibernate.hql.ast An ANTLR-based parser for Hibernate Query Language.

Uses of HqlParser in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that return HqlParser
static HqlParser HqlParser.getInstance(String hql)

Constructors in org.hibernate.hql.ast with parameters of type HqlParser
HqlSqlWalker(QueryTranslatorImpl qti, SessionFactoryImplementor sfi, HqlParser parser, Map tokenReplacements, String collectionRole)
Create a new tree transformer.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.HqlSqlWalker (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.HqlSqlWalker

Packages that use HqlSqlWalker
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.exec |
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |

Uses of HqlSqlWalker in org.hibernate.hql.ast

Constructors in org.hibernate.hql.ast with parameters of type HqlSqlWalker
SqlASTFactory(HqlSqlWalker walker)
Create factory with a specific mapping from token type to Java AST node type.

Uses of HqlSqlWalker in org.hibernate.hql.ast.exec

Methods in org.hibernate.hql.ast.exec that return HqlSqlWalker
protected  HqlSqlWalker AbstractStatementExecutor.getWalker()

Constructors in org.hibernate.hql.ast.exec with parameters of type HqlSqlWalker
MultiTableUpdateExecutor(HqlSqlWalker walker)
MultiTableDeleteExecutor(HqlSqlWalker walker)
BasicExecutor(HqlSqlWalker walker, Queryable persister)
AbstractStatementExecutor(HqlSqlWalker walker, org.apache.commons.logging.Log log)

Uses of HqlSqlWalker in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return HqlSqlWalker
HqlSqlWalker | Statement.getWalker() Retreive the "phase 2" walker which generated this statement tree.
HqlSqlWalker | HqlSqlWalkerNode.getWalker()

Uses of HqlSqlWalker in org.hibernate.hql.ast.util

Constructors in org.hibernate.hql.ast.util with parameters of type HqlSqlWalker
LiteralProcessor(HqlSqlWalker hqlSqlWalker)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.HqlToken (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.HqlToken

No usage of org.hibernate.hql.ast.HqlToken

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.InvalidPathException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.InvalidPathException

No usage of org.hibernate.hql.ast.InvalidPathException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.ParameterTranslationsImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.ParameterTranslationsImpl

No usage of org.hibernate.hql.ast.ParameterTranslationsImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.ParameterTranslationsImpl.ParameterInfo (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.ParameterTranslationsImpl.ParameterInfo

Packages that use ParameterTranslationsImpl.ParameterInfo
org.hibernate.hql.ast An ANTLR-based parser for Hibernate Query Language.

Uses of ParameterTranslationsImpl.ParameterInfo in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that return ParameterTranslationsImpl.ParameterInfo
ParameterTranslationsImpl.ParameterInfo | ParameterTranslationsImpl.getOrdinalParameterInfo(int ordinalPosition)
ParameterTranslationsImpl.ParameterInfo | ParameterTranslationsImpl.getNamedParameterInfo(String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.ParseErrorHandler (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.ParseErrorHandler

Packages that use ParseErrorHandler
org.hibernate.hql.ast An ANTLR-based parser for Hibernate Query Language.

Uses of ParseErrorHandler in org.hibernate.hql.ast

Classes in org.hibernate.hql.ast that implement ParseErrorHandler
 class ErrorCounter
An error handler that counts parsing errors and warnings.

Methods in org.hibernate.hql.ast that return ParseErrorHandler
ParseErrorHandler | SqlGenerator.getParseErrorHandler()
ParseErrorHandler | HqlSqlWalker.getParseErrorHandler()
ParseErrorHandler | HqlParser.getParseErrorHandler()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.QuerySyntaxException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.QuerySyntaxException

Packages that use QuerySyntaxException
org.hibernate.hql.ast An ANTLR-based parser for Hibernate Query Language.

Uses of QuerySyntaxException in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that return QuerySyntaxException
static QuerySyntaxException | QuerySyntaxException.convert(antlr.RecognitionException e)
static QuerySyntaxException | QuerySyntaxException.convert(antlr.RecognitionException e, String hql)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.QueryTranslatorImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.QueryTranslatorImpl

Packages that use QueryTranslatorImpl
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.util |

Uses of QueryTranslatorImpl in org.hibernate.hql.ast

Constructors in org.hibernate.hql.ast with parameters of type QueryTranslatorImpl
HqlSqlWalker(QueryTranslatorImpl qti, SessionFactoryImplementor sfi, HqlParser parser, Map tokenReplacements, String collectionRole)
Create a new tree transformer.

Uses of QueryTranslatorImpl in org.hibernate.hql.ast.util

Constructors in org.hibernate.hql.ast.util with parameters of type QueryTranslatorImpl
JoinProcessor(antlr.ASTFactory astFactory, QueryTranslatorImpl queryTranslatorImpl)
Constructs a new JoinProcessor.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.QueryTranslatorImpl.JavaConstantConverter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.QueryTranslatorImpl.JavaConstantConverter

No usage of org.hibernate.hql.ast.QueryTranslatorImpl.JavaConstantConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.SqlASTFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.SqlASTFactory

No usage of org.hibernate.hql.ast.SqlASTFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.SqlGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.SqlGenerator

No usage of org.hibernate.hql.ast.SqlGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.hql.ast.exec (Hibernate API Documentation)

 org.hibernate.hql.ast.exec
Interfaces
StatementExecutor
Classes
AbstractStatementExecutor
BasicExecutor
MultiTableDeleteExecutor
MultiTableUpdateExecutor


Uses of Class org.hibernate.hql.ast.exec.AbstractStatementExecutor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.exec.AbstractStatementExecutor

Packages that use AbstractStatementExecutor
org.hibernate.hql.ast.exec

Uses of AbstractStatementExecutor in org.hibernate.hql.ast.exec

Subclasses of AbstractStatementExecutor in org.hibernate.hql.ast.exec
class | BasicExecutor Implementation of BasicExecutor.
class | MultiTableDeleteExecutor Implementation of MultiTableDeleteExecutor.
class | MultiTableUpdateExecutor Implementation of MultiTableUpdateExecutor.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.exec.BasicExecutor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.exec.BasicExecutor

No usage of org.hibernate.hql.ast.exec.BasicExecutor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.exec.MultiTableDeleteExecutor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.exec.MultiTableDeleteExecutor

No usage of org.hibernate.hql.ast.exec.MultiTableDeleteExecutor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.exec.MultiTableUpdateExecutor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.exec.MultiTableUpdateExecutor

No usage of org.hibernate.hql.ast.exec.MultiTableUpdateExecutor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.exec.StatementExecutor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.exec.StatementExecutor

Packages that use StatementExecutor
org.hibernate.hql.ast.exec

Uses of StatementExecutor in org.hibernate.hql.ast.exec

Classes in org.hibernate.hql.ast.exec that implement StatementExecutor
class | AbstractStatementExecutor Implementation of AbstractStatementExecutor.
class | BasicExecutor Implementation of BasicExecutor.
class | MultiTableDeleteExecutor Implementation of MultiTableDeleteExecutor.
class | MultiTableUpdateExecutor Implementation of MultiTableUpdateExecutor.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.hql.ast.tree (Hibernate API Documentation)

 org.hibernate.hql.ast.tree
Interfaces
BinaryOperatorNode
DisplayableNode
ExpectedTypeAwareNode
InitializeableNode
OperatorNode
PathNode
ResolvableNode
RestrictableStatement
SelectExpression
SessionFactoryAwareNode
Statement
UnaryOperatorNode
Classes
AbstractRestrictableStatement
AbstractSelectExpression
AbstractStatement
AggregateNode
AssignmentSpecification
BetweenOperatorNode
BinaryArithmeticOperatorNode
BinaryLogicOperatorNode
BooleanLiteralNode
Case2Node
CaseNode
CollectionFunction
ConstructorNode
CountNode
DeleteStatement
DotNode
FromClause
FromElement
FromReferenceNode
HqlSqlWalkerNode
IdentNode
ImpliedFromElement
IndexNode
InLogicOperatorNode
InsertStatement
IntoClause
JavaConstantNode
LiteralNode
MethodNode
Node
OrderByClause
ParameterNode
QueryNode
SelectClause
SelectExpressionImpl
SelectExpressionList
SqlFragment
SqlNode
UnaryArithmeticNode
UnaryLogicOperatorNode
UpdateStatement


Uses of Class org.hibernate.hql.ast.tree.AbstractRestrictableStatement (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.AbstractRestrictableStatement

Packages that use AbstractRestrictableStatement
org.hibernate.hql.ast.tree

Uses of AbstractRestrictableStatement in org.hibernate.hql.ast.tree

Subclasses of AbstractRestrictableStatement in org.hibernate.hql.ast.tree
class | DeleteStatement Defines a top-level AST node representing an HQL delete statement.
class | QueryNode Defines a top-level AST node representing an HQL select statement.
class | UpdateStatement Defines a top-level AST node representing an HQL update statement.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.AbstractSelectExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.AbstractSelectExpression

Packages that use AbstractSelectExpression
org.hibernate.hql.ast.tree

Uses of AbstractSelectExpression in org.hibernate.hql.ast.tree

Subclasses of AbstractSelectExpression in org.hibernate.hql.ast.tree
class | AggregateNode Represents an aggregate function i.e.
class | BinaryArithmeticOperatorNode Nodes which represent binary arithmetic operators.
class | BooleanLiteralNode Represents a boolean literal within a query.
class | Case2Node Represents a case ...
class | CaseNode Represents a case ...
class | CollectionFunction Represents 'elements()' or 'indices()'.
class | CountNode Represents a COUNT expression in a select.
class | DotNode Represents a reference to a property or alias expression.
class | FromReferenceNode Represents a reference to a FROM element, for example a class alias in a WHERE clause.
class | IdentNode Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.
class | IndexNode Represents the [] operator and provides it's semantics.
class | LiteralNode Represents a literal.
class | MethodNode Represents a method call.
class | SelectExpressionImpl A select expression that was generated by a FROM element.
class | UnaryArithmeticNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.AbstractStatement (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.AbstractStatement

Packages that use AbstractStatement
org.hibernate.hql.ast.tree

Uses of AbstractStatement in org.hibernate.hql.ast.tree

Subclasses of AbstractStatement in org.hibernate.hql.ast.tree
class | AbstractRestrictableStatement Convenience implementation of RestrictableStatement to centralize common functionality.
class | DeleteStatement Defines a top-level AST node representing an HQL delete statement.
class | InsertStatement Defines a top-level AST node representing an HQL "insert select" statement.
class | QueryNode Defines a top-level AST node representing an HQL select statement.
class | UpdateStatement Defines a top-level AST node representing an HQL update statement.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.AggregateNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.AggregateNode

No usage of org.hibernate.hql.ast.tree.AggregateNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.AssignmentSpecification (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.AssignmentSpecification

No usage of org.hibernate.hql.ast.tree.AssignmentSpecification

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.BetweenOperatorNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.BetweenOperatorNode

No usage of org.hibernate.hql.ast.tree.BetweenOperatorNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode

No usage of org.hibernate.hql.ast.tree.BinaryArithmeticOperatorNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.BinaryLogicOperatorNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.BinaryLogicOperatorNode

Packages that use BinaryLogicOperatorNode
org.hibernate.hql.ast.tree

Uses of BinaryLogicOperatorNode in org.hibernate.hql.ast.tree

Subclasses of BinaryLogicOperatorNode in org.hibernate.hql.ast.tree
 class InLogicOperatorNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.tree.BinaryOperatorNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.tree.BinaryOperatorNode

Packages that use BinaryOperatorNode
org.hibernate.hql.ast.tree

Uses of BinaryOperatorNode in org.hibernate.hql.ast.tree

Classes in org.hibernate.hql.ast.tree that implement BinaryOperatorNode
class | BinaryArithmeticOperatorNode Nodes which represent binary arithmetic operators.
class | BinaryLogicOperatorNode Contract for nodes representing binary operators.
class | InLogicOperatorNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.BooleanLiteralNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.BooleanLiteralNode

No usage of org.hibernate.hql.ast.tree.BooleanLiteralNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.Case2Node (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.Case2Node

No usage of org.hibernate.hql.ast.tree.Case2Node

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.CaseNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.CaseNode

No usage of org.hibernate.hql.ast.tree.CaseNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.CollectionFunction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.CollectionFunction

No usage of org.hibernate.hql.ast.tree.CollectionFunction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.ConstructorNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.ConstructorNode

No usage of org.hibernate.hql.ast.tree.ConstructorNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.CountNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.CountNode

No usage of org.hibernate.hql.ast.tree.CountNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.DeleteStatement (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.DeleteStatement

No usage of org.hibernate.hql.ast.tree.DeleteStatement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.tree.DisplayableNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.tree.DisplayableNode

Packages that use DisplayableNode
org.hibernate.hql.ast.tree

Uses of DisplayableNode in org.hibernate.hql.ast.tree

Classes in org.hibernate.hql.ast.tree that implement DisplayableNode
class | AbstractRestrictableStatement Convenience implementation of RestrictableStatement to centralize common functionality.
class | AbstractStatement Convenience implementation of Statement to centralize common functionality.
class | BinaryArithmeticOperatorNode Nodes which represent binary arithmetic operators.
class | CollectionFunction Represents 'elements()' or 'indices()'.
class | DeleteStatement Defines a top-level AST node representing an HQL delete statement.
class | DotNode Represents a reference to a property or alias expression.
class | FromClause Represents the 'FROM' part of a query or subquery, containing all mapped class references.
class | FromElement Represents a single mapped class mentioned in an HQL FROM clause.
class | FromReferenceNode Represents a reference to a FROM element, for example a class alias in a WHERE clause.
class | IdentNode Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.
class | ImpliedFromElement Represents a FROM element implied by a path expression or a collection reference.
class | IndexNode Represents the [] operator and provides it's semantics.
class | InsertStatement Defines a top-level AST node representing an HQL "insert select" statement.
class | IntoClause Represents an entity referenced in the INTO clause of an HQL INSERT statement.
class | ParameterNode Implementation of ParameterNode.
class | QueryNode Defines a top-level AST node representing an HQL select statement.
class | SelectExpressionImpl A select expression that was generated by a FROM element.
class | UpdateStatement Defines a top-level AST node representing an HQL update statement.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.DotNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.DotNode

Packages that use DotNode
org.hibernate.hql.ast.util

Uses of DotNode in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util with parameters of type DotNode
 void LiteralProcessor.lookupConstant(DotNode node)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.tree.ExpectedTypeAwareNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.tree.ExpectedTypeAwareNode

Packages that use ExpectedTypeAwareNode
org.hibernate.hql.ast.tree

Uses of ExpectedTypeAwareNode in org.hibernate.hql.ast.tree

Classes in org.hibernate.hql.ast.tree that implement ExpectedTypeAwareNode
class | BooleanLiteralNode Represents a boolean literal within a query.
class | JavaConstantNode A node representing a static Java constant.
class | ParameterNode Implementation of ParameterNode.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.FromClause (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.FromClause

Packages that use FromClause
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |

Uses of FromClause in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that return FromClause
FromClause | HqlSqlWalker.getCurrentFromClause()
FromClause | HqlSqlWalker.getFinalFromClause()

Uses of FromClause in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return FromClause
FromClause | RestrictableStatement.getFromClause() Retreives the from-clause in effect for this statement.
FromClause | FromElement.getFromClause()
FromClause | FromClause.locateChildFromClauseWithJoinByPath(String path)
FromClause | FromClause.getParentFromClause()
FromClause | AbstractRestrictableStatement.getFromClause()

Methods in org.hibernate.hql.ast.tree with parameters of type FromClause
void | SelectClause.initializeExplicitSelectClause(FromClause fromClause) Prepares an explicitly defined select clause.
void | SelectClause.initializeDerivedSelectClause(FromClause fromClause) Prepares a derived (i.e., not explicitly defined in the query) select clause.
void | FromElement.initializeCollection(FromClause fromClause, String classAlias, String tableAlias)
void | FromElement.initializeEntity(FromClause fromClause, String className, EntityPersister persister, EntityType type, String classAlias, String tableAlias)
void | FromClause.setParentFromClause(FromClause parentFromClause)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.FromElement (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.FromElement

Packages that use FromElement
org.hibernate.hql.ast.tree
org.hibernate.hql.ast.util

Uses of FromElement in org.hibernate.hql.ast.tree

Subclasses of FromElement in org.hibernate.hql.ast.tree
 class ImpliedFromElement
Represents a FROM element implied by a path expression or a collection reference.

Methods in org.hibernate.hql.ast.tree that return FromElement
FromElement | SqlFragment.getFromElement()
FromElement | SelectExpression.getFromElement() Returns the FROM element that this expression refers to.
FromElement | QueryNode.getFromElement()
FromElement | MethodNode.getFromElement()
FromElement | FromReferenceNode.getFromElement()
FromElement | FromReferenceNode.getImpliedJoin() Sub-classes can override this method if they produce implied joins (e.g.
FromElement | FromElement.getOrigin()
FromElement | FromElement.getRealOrigin()
FromElement | FromClause.addFromElement(String path, antlr.collections.AST alias) Adds a new from element to the from node.
FromElement | FromClause.getFromElement(String aliasOrClassName) Retreives the from-element represented by the given alias.
FromElement | FromClause.getFromElement()
FromElement | DotNode.getImpliedJoin()
FromElement | ConstructorNode.getFromElement()
FromElement | AbstractSelectExpression.getFromElement()

Methods in org.hibernate.hql.ast.tree with parameters of type FromElement
void | SqlFragment.setFromElement(FromElement fromElement)
void | FromReferenceNode.setFromElement(FromElement fromElement)
void | FromElement.setOrigin(FromElement origin, boolean manyToMany)
void | FromClause.promoteJoin(FromElement elem)
void | FromClause.addImpliedFromElement(FromElement element)

Uses of FromElement in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util with parameters of type FromElement
 void SyntheticAndFactory.addWhereFragment(JoinFragment joinFragment, String whereFragment, QueryNode query, FromElement fromElement)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.FromReferenceNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.FromReferenceNode

Packages that use FromReferenceNode
org.hibernate.hql.ast.tree

Uses of FromReferenceNode in org.hibernate.hql.ast.tree

Subclasses of FromReferenceNode in org.hibernate.hql.ast.tree
class | DotNode Represents a reference to a property or alias expression.
class | IdentNode Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.
class | IndexNode Represents the [] operator and provides it's semantics.
class | SelectExpressionImpl A select expression that was generated by a FROM element.

Methods in org.hibernate.hql.ast.tree that return FromReferenceNode
 FromReferenceNode DotNode.getLhs()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.HqlSqlWalkerNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.HqlSqlWalkerNode

Packages that use HqlSqlWalkerNode
org.hibernate.hql.ast.tree
org.hibernate.hql.ast.util

Uses of HqlSqlWalkerNode in org.hibernate.hql.ast.tree

Subclasses of HqlSqlWalkerNode in org.hibernate.hql.ast.tree
class | AbstractRestrictableStatement Convenience implementation of RestrictableStatement to centralize common functionality.
class | AbstractSelectExpression Partial implementation of SelectExpression for all the nodes that aren't constructors.
class | AbstractStatement Convenience implementation of Statement to centralize common functionality.
class | AggregateNode Represents an aggregate function i.e.
class | BinaryArithmeticOperatorNode Nodes which represent binary arithmetic operators.
class | BinaryLogicOperatorNode Contract for nodes representing binary operators.
class | BooleanLiteralNode Represents a boolean literal within a query.
class | Case2Node Represents a case ...
class | CaseNode Represents a case ...
class | CollectionFunction Represents 'elements()' or 'indices()'.
class | ConstructorNode Represents a constructor (new) in a SELECT.
class | CountNode Represents a COUNT expression in a select.
class | DeleteStatement Defines a top-level AST node representing an HQL delete statement.
class | DotNode Represents a reference to a property or alias expression.
class | FromClause Represents the 'FROM' part of a query or subquery, containing all mapped class references.
class | FromElement Represents a single mapped class mentioned in an HQL FROM clause.
class | FromReferenceNode Represents a reference to a FROM element, for example a class alias in a WHERE clause.
class | IdentNode Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.
class | ImpliedFromElement Represents a FROM element implied by a path expression or a collection reference.
class | IndexNode Represents the [] operator and provides it's semantics.
class | InLogicOperatorNode
class | InsertStatement Defines a top-level AST node representing an HQL "insert select" statement.
class | IntoClause Represents an entity referenced in the INTO clause of an HQL INSERT statement.
class | LiteralNode Represents a literal.
class | MethodNode Represents a method call.
class | OrderByClause Implementation of OrderByClause.
class | ParameterNode Implementation of ParameterNode.
class | QueryNode Defines a top-level AST node representing an HQL select statement.
class | SelectClause Represents the list of expressions in a SELECT clause.
class | SelectExpressionImpl A select expression that was generated by a FROM element.
class | SelectExpressionList Common behavior - a node that contains a list of select expressions.
class | UnaryArithmeticNode
class | UpdateStatement Defines a top-level AST node representing an HQL update statement.

Uses of HqlSqlWalkerNode in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util with parameters of type HqlSqlWalkerNode
static void | ColumnHelper.generateSingleScalarColumn(HqlSqlWalkerNode node, int i)
static void | ColumnHelper.generateScalarColumns(HqlSqlWalkerNode node, String[] sqlColumns, int i) Generates the scalar column AST nodes for a given array of SQL columns

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.IdentNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.IdentNode

No usage of org.hibernate.hql.ast.tree.IdentNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.ImpliedFromElement (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.ImpliedFromElement

No usage of org.hibernate.hql.ast.tree.ImpliedFromElement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.IndexNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.IndexNode

No usage of org.hibernate.hql.ast.tree.IndexNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.tree.InitializeableNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.tree.InitializeableNode

Packages that use InitializeableNode
org.hibernate.hql.ast.tree

Uses of InitializeableNode in org.hibernate.hql.ast.tree

Classes in org.hibernate.hql.ast.tree that implement InitializeableNode
class | AbstractRestrictableStatement Convenience implementation of RestrictableStatement to centralize common functionality.
class | AbstractSelectExpression Partial implementation of SelectExpression for all the nodes that aren't constructors.
class | AbstractStatement Convenience implementation of Statement to centralize common functionality.
class | AggregateNode Represents an aggregate function i.e.
class | BinaryArithmeticOperatorNode Nodes which represent binary arithmetic operators.
class | BinaryLogicOperatorNode Contract for nodes representing binary operators.
class | BooleanLiteralNode Represents a boolean literal within a query.
class | Case2Node Represents a case ...
class | CaseNode Represents a case ...
class | CollectionFunction Represents 'elements()' or 'indices()'.
class | ConstructorNode Represents a constructor (new) in a SELECT.
class | CountNode Represents a COUNT expression in a select.
class | DeleteStatement Defines a top-level AST node representing an HQL delete statement.
class | DotNode Represents a reference to a property or alias expression.
class | FromClause Represents the 'FROM' part of a query or subquery, containing all mapped class references.
class | FromElement Represents a single mapped class mentioned in an HQL FROM clause.
class | FromReferenceNode Represents a reference to a FROM element, for example a class alias in a WHERE clause.
class | HqlSqlWalkerNode A semantic analysis node, that points back to the main analyzer.
class | IdentNode Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.
class | ImpliedFromElement Represents a FROM element implied by a path expression or a collection reference.
class | IndexNode Represents the [] operator and provides it's semantics.
class | InLogicOperatorNode
class | InsertStatement Defines a top-level AST node representing an HQL "insert select" statement.
class | IntoClause Represents an entity referenced in the INTO clause of an HQL INSERT statement.
class | LiteralNode Represents a literal.
class | MethodNode Represents a method call.
class | OrderByClause Implementation of OrderByClause.
class | ParameterNode Implementation of ParameterNode.
class | QueryNode Defines a top-level AST node representing an HQL select statement.
class | SelectClause Represents the list of expressions in a SELECT clause.
class | SelectExpressionImpl A select expression that was generated by a FROM element.
class | SelectExpressionList Common behavior - a node that contains a list of select expressions.
class | UnaryArithmeticNode
class | UpdateStatement Defines a top-level AST node representing an HQL update statement.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.InLogicOperatorNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.InLogicOperatorNode

No usage of org.hibernate.hql.ast.tree.InLogicOperatorNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.InsertStatement (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.InsertStatement

No usage of org.hibernate.hql.ast.tree.InsertStatement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.IntoClause (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.IntoClause

Packages that use IntoClause
org.hibernate.hql.ast.tree

Uses of IntoClause in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return IntoClause
 IntoClause InsertStatement.getIntoClause()
Retreive this insert statement's into-clause.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.JavaConstantNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.JavaConstantNode

No usage of org.hibernate.hql.ast.tree.JavaConstantNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.LiteralNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.LiteralNode

Packages that use LiteralNode
org.hibernate.hql.ast.tree

Uses of LiteralNode in org.hibernate.hql.ast.tree

Subclasses of LiteralNode in org.hibernate.hql.ast.tree
 class BooleanLiteralNode
Represents a boolean literal within a query.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.MethodNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.MethodNode

Packages that use MethodNode
org.hibernate.hql.ast.tree

Uses of MethodNode in org.hibernate.hql.ast.tree

Subclasses of MethodNode in org.hibernate.hql.ast.tree
 class CollectionFunction
Represents 'elements()' or 'indices()'.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.Node (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.Node

Packages that use Node
org.hibernate.hql.ast.tree

Uses of Node in org.hibernate.hql.ast.tree

Subclasses of Node in org.hibernate.hql.ast.tree
class | AbstractRestrictableStatement Convenience implementation of RestrictableStatement to centralize common functionality.
class | AbstractSelectExpression Partial implementation of SelectExpression for all the nodes that aren't constructors.
class | AbstractStatement Convenience implementation of Statement to centralize common functionality.
class | AggregateNode Represents an aggregate function i.e.
class | BetweenOperatorNode Contract for nodes representing logcial BETWEEN (ternary) operators.
class | BinaryArithmeticOperatorNode Nodes which represent binary arithmetic operators.
class | BinaryLogicOperatorNode Contract for nodes representing binary operators.
class | BooleanLiteralNode Represents a boolean literal within a query.
class | Case2Node Represents a case ...
class | CaseNode Represents a case ...
class | CollectionFunction Represents 'elements()' or 'indices()'.
class | ConstructorNode Represents a constructor (new) in a SELECT.
class | CountNode Represents a COUNT expression in a select.
class | DeleteStatement Defines a top-level AST node representing an HQL delete statement.
class | DotNode Represents a reference to a property or alias expression.
class | FromClause Represents the 'FROM' part of a query or subquery, containing all mapped class references.
class | FromElement Represents a single mapped class mentioned in an HQL FROM clause.
class | FromReferenceNode Represents a reference to a FROM element, for example a class alias in a WHERE clause.
class | HqlSqlWalkerNode A semantic analysis node, that points back to the main analyzer.
class | IdentNode Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.
class | ImpliedFromElement Represents a FROM element implied by a path expression or a collection reference.
class | IndexNode Represents the [] operator and provides it's semantics.
class | InLogicOperatorNode
class | InsertStatement Defines a top-level AST node representing an HQL "insert select" statement.
class | IntoClause Represents an entity referenced in the INTO clause of an HQL INSERT statement.
class | JavaConstantNode A node representing a static Java constant.
class | LiteralNode Represents a literal.
class | MethodNode Represents a method call.
class | OrderByClause Implementation of OrderByClause.
class | ParameterNode Implementation of ParameterNode.
class | QueryNode Defines a top-level AST node representing an HQL select statement.
class | SelectClause Represents the list of expressions in a SELECT clause.
class | SelectExpressionImpl A select expression that was generated by a FROM element.
class | SelectExpressionList Common behavior - a node that contains a list of select expressions.
class | SqlFragment Represents an SQL fragment in the AST.
class | SqlNode A base AST node for the intermediate tree.
class | UnaryArithmeticNode
class | UnaryLogicOperatorNode
class | UpdateStatement Defines a top-level AST node representing an HQL update statement.

Methods in org.hibernate.hql.ast.tree that return Node
Node | UnaryOperatorNode.getOperand() Retrievs the node representing the operator's single operand.
Node | UnaryLogicOperatorNode.getOperand()
Node | UnaryArithmeticNode.getOperand()
Node | InLogicOperatorNode.getInList()
Node | BinaryOperatorNode.getLeftHandOperand() Retrieves the left-hand operand of the operator.
Node | BinaryOperatorNode.getRightHandOperand() Retrieves the right-hand operand of the operator.
Node | BinaryLogicOperatorNode.getLeftHandOperand() Retrieves the left-hand operand of the operator.
Node | BinaryLogicOperatorNode.getRightHandOperand() Retrieves the right-hand operand of the operator.
Node | BinaryArithmeticOperatorNode.getLeftHandOperand() Retrieves the left-hand operand of the operator.
Node | BinaryArithmeticOperatorNode.getRightHandOperand() Retrieves the right-hand operand of the operator.
Node | BetweenOperatorNode.getFixtureOperand()
Node | BetweenOperatorNode.getLowOperand()
Node | BetweenOperatorNode.getHighOperand()

Methods in org.hibernate.hql.ast.tree with parameters of type Node
protected  Type BinaryLogicOperatorNode.extractDataType(Node operand)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.tree.OperatorNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.tree.OperatorNode

Packages that use OperatorNode
org.hibernate.hql.ast.tree

Uses of OperatorNode in org.hibernate.hql.ast.tree

Subinterfaces of OperatorNode in org.hibernate.hql.ast.tree
interface | BinaryOperatorNode Contract for nodes representing binary operators.
interface | UnaryOperatorNode Contract for nodes representing unary operators.

Classes in org.hibernate.hql.ast.tree that implement OperatorNode
class | BetweenOperatorNode Contract for nodes representing logcial BETWEEN (ternary) operators.
class | BinaryArithmeticOperatorNode Nodes which represent binary arithmetic operators.
class | BinaryLogicOperatorNode Contract for nodes representing binary operators.
class | InLogicOperatorNode
class | UnaryArithmeticNode
class | UnaryLogicOperatorNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.OrderByClause (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.OrderByClause

Packages that use OrderByClause
org.hibernate.hql.ast.tree

Uses of OrderByClause in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return OrderByClause
 OrderByClause QueryNode.getOrderByClause()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.ParameterNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.ParameterNode

No usage of org.hibernate.hql.ast.tree.ParameterNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.tree.PathNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.tree.PathNode

Packages that use PathNode
org.hibernate.hql.ast.tree

Uses of PathNode in org.hibernate.hql.ast.tree

Classes in org.hibernate.hql.ast.tree that implement PathNode
class | DotNode Represents a reference to a property or alias expression.
class | FromReferenceNode Represents a reference to a FROM element, for example a class alias in a WHERE clause.
class | IdentNode Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.
class | IndexNode Represents the [] operator and provides it's semantics.
class | SelectExpressionImpl A select expression that was generated by a FROM element.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.QueryNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.QueryNode

Packages that use QueryNode
org.hibernate.hql.ast.util

Uses of QueryNode in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util with parameters of type QueryNode
void | SyntheticAndFactory.addWhereFragment(JoinFragment joinFragment, String whereFragment, QueryNode query, FromElement fromElement)
void | JoinProcessor.processJoins(QueryNode query, boolean inSubquery)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.tree.ResolvableNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.tree.ResolvableNode

Packages that use ResolvableNode
org.hibernate.hql.ast.tree

Uses of ResolvableNode in org.hibernate.hql.ast.tree

Classes in org.hibernate.hql.ast.tree that implement ResolvableNode
class | DotNode Represents a reference to a property or alias expression.
class | FromReferenceNode Represents a reference to a FROM element, for example a class alias in a WHERE clause.
class | IdentNode Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.
class | IndexNode Represents the [] operator and provides it's semantics.
class | SelectExpressionImpl A select expression that was generated by a FROM element.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.tree.RestrictableStatement (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.tree.RestrictableStatement

Packages that use RestrictableStatement
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |

Uses of RestrictableStatement in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast with parameters of type RestrictableStatement
protected  void HqlSqlWalker.postProcessDML(RestrictableStatement statement)

Uses of RestrictableStatement in org.hibernate.hql.ast.tree

Classes in org.hibernate.hql.ast.tree that implement RestrictableStatement
class | AbstractRestrictableStatement Convenience implementation of RestrictableStatement to centralize common functionality.
class | DeleteStatement Defines a top-level AST node representing an HQL delete statement.
class | QueryNode Defines a top-level AST node representing an HQL select statement.
class | UpdateStatement Defines a top-level AST node representing an HQL update statement.

Uses of RestrictableStatement in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util with parameters of type RestrictableStatement
 void SyntheticAndFactory.addDiscriminatorWhereFragment(RestrictableStatement statement, Queryable persister, Map enabledFilters, String alias)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.SelectClause (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.SelectClause

Packages that use SelectClause
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser

Uses of SelectClause in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that return SelectClause
 SelectClause HqlSqlWalker.getSelectClause()

Uses of SelectClause in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return SelectClause
SelectClause | QueryNode.getSelectClause() Locate the select clause that is part of this select statement.
SelectClause | InsertStatement.getSelectClause() Retreive this insert statement's select-clause.

Methods in org.hibernate.hql.ast.tree with parameters of type SelectClause
 void IntoClause.validateTypes(SelectClause selectClause)

Uses of SelectClause in org.hibernate.loader.hql

Constructors in org.hibernate.loader.hql with parameters of type SelectClause
QueryLoader(QueryTranslator queryTranslator, SessionFactoryImplementor factory, SelectClause selectClause)
Creates a new Loader implementation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.tree.SelectExpression (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.tree.SelectExpression

Packages that use SelectExpression
org.hibernate.hql.ast.tree

Uses of SelectExpression in org.hibernate.hql.ast.tree

Classes in org.hibernate.hql.ast.tree that implement SelectExpression
class | AbstractSelectExpression Partial implementation of SelectExpression for all the nodes that aren't constructors.
class | AggregateNode Represents an aggregate function i.e.
class | BinaryArithmeticOperatorNode Nodes which represent binary arithmetic operators.
class | BooleanLiteralNode Represents a boolean literal within a query.
class | Case2Node Represents a case ...
class | CaseNode Represents a case ...
class | CollectionFunction Represents 'elements()' or 'indices()'.
class | ConstructorNode Represents a constructor (new) in a SELECT.
class | CountNode Represents a COUNT expression in a select.
class | DotNode Represents a reference to a property or alias expression.
class | FromReferenceNode Represents a reference to a FROM element, for example a class alias in a WHERE clause.
class | IdentNode Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.
class | IndexNode Represents the [] operator and provides it's semantics.
class | LiteralNode Represents a literal.
class | MethodNode Represents a method call.
class | QueryNode Defines a top-level AST node representing an HQL select statement.
class | SelectExpressionImpl A select expression that was generated by a FROM element.
class | UnaryArithmeticNode

Methods in org.hibernate.hql.ast.tree that return SelectExpression
 SelectExpression[] SelectExpressionList.collectSelectExpressions()
Returns an array of SelectExpressions gathered from the children of the given parent AST node.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.SelectExpressionImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.SelectExpressionImpl

No usage of org.hibernate.hql.ast.tree.SelectExpressionImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.SelectExpressionList (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.SelectExpressionList

Packages that use SelectExpressionList
org.hibernate.hql.ast.tree

Uses of SelectExpressionList in org.hibernate.hql.ast.tree

Subclasses of SelectExpressionList in org.hibernate.hql.ast.tree
class | ConstructorNode Represents a constructor (new) in a SELECT.
class | SelectClause Represents the list of expressions in a SELECT clause.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.tree.SessionFactoryAwareNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.tree.SessionFactoryAwareNode

Packages that use SessionFactoryAwareNode
org.hibernate.hql.ast.tree

Uses of SessionFactoryAwareNode in org.hibernate.hql.ast.tree

Classes in org.hibernate.hql.ast.tree that implement SessionFactoryAwareNode
 class JavaConstantNode
A node representing a static Java constant.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.SqlFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.SqlFragment

No usage of org.hibernate.hql.ast.tree.SqlFragment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.SqlNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.SqlNode

Packages that use SqlNode
org.hibernate.hql.ast.tree

Uses of SqlNode in org.hibernate.hql.ast.tree

Subclasses of SqlNode in org.hibernate.hql.ast.tree
class | AbstractRestrictableStatement Convenience implementation of RestrictableStatement to centralize common functionality.
class | AbstractSelectExpression Partial implementation of SelectExpression for all the nodes that aren't constructors.
class | AbstractStatement Convenience implementation of Statement to centralize common functionality.
class | AggregateNode Represents an aggregate function i.e.
class | BetweenOperatorNode Contract for nodes representing logcial BETWEEN (ternary) operators.
class | BinaryArithmeticOperatorNode Nodes which represent binary arithmetic operators.
class | BinaryLogicOperatorNode Contract for nodes representing binary operators.
class | BooleanLiteralNode Represents a boolean literal within a query.
class | Case2Node Represents a case ...
class | CaseNode Represents a case ...
class | CollectionFunction Represents 'elements()' or 'indices()'.
class | ConstructorNode Represents a constructor (new) in a SELECT.
class | CountNode Represents a COUNT expression in a select.
class | DeleteStatement Defines a top-level AST node representing an HQL delete statement.
class | DotNode Represents a reference to a property or alias expression.
class | FromClause Represents the 'FROM' part of a query or subquery, containing all mapped class references.
class | FromElement Represents a single mapped class mentioned in an HQL FROM clause.
class | FromReferenceNode Represents a reference to a FROM element, for example a class alias in a WHERE clause.
class | HqlSqlWalkerNode A semantic analysis node, that points back to the main analyzer.
class | IdentNode Represents an identifier all by itself, which may be a function name, a class alias, or a form of naked property-ref depending on the context.
class | ImpliedFromElement Represents a FROM element implied by a path expression or a collection reference.
class | IndexNode Represents the [] operator and provides it's semantics.
class | InLogicOperatorNode
class | InsertStatement Defines a top-level AST node representing an HQL "insert select" statement.
class | IntoClause Represents an entity referenced in the INTO clause of an HQL INSERT statement.
class | LiteralNode Represents a literal.
class | MethodNode Represents a method call.
class | OrderByClause Implementation of OrderByClause.
class | ParameterNode Implementation of ParameterNode.
class | QueryNode Defines a top-level AST node representing an HQL select statement.
class | SelectClause Represents the list of expressions in a SELECT clause.
class | SelectExpressionImpl A select expression that was generated by a FROM element.
class | SelectExpressionList Common behavior - a node that contains a list of select expressions.
class | UnaryArithmeticNode
class | UnaryLogicOperatorNode
class | UpdateStatement Defines a top-level AST node representing an HQL update statement.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.tree.Statement (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.tree.Statement

Packages that use Statement
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |

Uses of Statement in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that return Statement
 Statement QueryTranslatorImpl.getSqlAST()

Uses of Statement in org.hibernate.hql.ast.tree

Subinterfaces of Statement in org.hibernate.hql.ast.tree
 interface RestrictableStatement
Type definition for Statements which are restrictable via a where-clause (and thus also having a from-clause).

Classes in org.hibernate.hql.ast.tree that implement Statement
class | AbstractRestrictableStatement Convenience implementation of RestrictableStatement to centralize common functionality.
class | AbstractStatement Convenience implementation of Statement to centralize common functionality.
class | DeleteStatement Defines a top-level AST node representing an HQL delete statement.
class | InsertStatement Defines a top-level AST node representing an HQL "insert select" statement.
class | QueryNode Defines a top-level AST node representing an HQL select statement.
class | UpdateStatement Defines a top-level AST node representing an HQL update statement.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.UnaryArithmeticNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.UnaryArithmeticNode

No usage of org.hibernate.hql.ast.tree.UnaryArithmeticNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.UnaryLogicOperatorNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.UnaryLogicOperatorNode

No usage of org.hibernate.hql.ast.tree.UnaryLogicOperatorNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.tree.UnaryOperatorNode (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.tree.UnaryOperatorNode

Packages that use UnaryOperatorNode
org.hibernate.hql.ast.tree

Uses of UnaryOperatorNode in org.hibernate.hql.ast.tree

Classes in org.hibernate.hql.ast.tree that implement UnaryOperatorNode
class | UnaryArithmeticNode
class | UnaryLogicOperatorNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.tree.UpdateStatement (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.tree.UpdateStatement

No usage of org.hibernate.hql.ast.tree.UpdateStatement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.hql.ast.util (Hibernate API Documentation)

 org.hibernate.hql.ast.util
Interfaces
ASTUtil.FilterPredicate
NodeTraverser.VisitationStrategy
Classes
AliasGenerator
ASTAppender
ASTIterator
ASTParentsFirstIterator
ASTPrinter
ASTUtil
ASTUtil.IncludePredicate
ColumnHelper
JoinProcessor
LiteralProcessor
NodeTraverser
PathHelper
SessionFactoryHelper
SyntheticAndFactory


Uses of Class org.hibernate.hql.ast.util.AliasGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.AliasGenerator

Packages that use AliasGenerator
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |

Uses of AliasGenerator in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that return AliasGenerator
 AliasGenerator HqlSqlWalker.getAliasGenerator()

Uses of AliasGenerator in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return AliasGenerator
 AliasGenerator HqlSqlWalkerNode.getAliasGenerator()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.ASTAppender (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.ASTAppender

No usage of org.hibernate.hql.ast.util.ASTAppender

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.ASTIterator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.ASTIterator

No usage of org.hibernate.hql.ast.util.ASTIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.ASTParentsFirstIterator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.ASTParentsFirstIterator

No usage of org.hibernate.hql.ast.util.ASTParentsFirstIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.ASTPrinter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.ASTPrinter

Packages that use ASTPrinter
org.hibernate.hql.ast An ANTLR-based parser for Hibernate Query Language.

Uses of ASTPrinter in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that return ASTPrinter
 ASTPrinter HqlSqlWalker.getASTPrinter()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.ASTUtil (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.ASTUtil

No usage of org.hibernate.hql.ast.util.ASTUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.util.ASTUtil.FilterPredicate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.util.ASTUtil.FilterPredicate

Packages that use ASTUtil.FilterPredicate
org.hibernate.hql.ast.util

Uses of ASTUtil.FilterPredicate in org.hibernate.hql.ast.util

Classes in org.hibernate.hql.ast.util that implement ASTUtil.FilterPredicate
static class ASTUtil.IncludePredicate
A predicate that uses inclusion, rather than exclusion semantics.

Methods in org.hibernate.hql.ast.util with parameters of type ASTUtil.FilterPredicate
static List ASTUtil.collectChildren(antlr.collections.AST root, ASTUtil.FilterPredicate predicate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.ASTUtil.IncludePredicate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.ASTUtil.IncludePredicate

No usage of org.hibernate.hql.ast.util.ASTUtil.IncludePredicate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.ColumnHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.ColumnHelper

No usage of org.hibernate.hql.ast.util.ColumnHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.JoinProcessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.JoinProcessor

No usage of org.hibernate.hql.ast.util.JoinProcessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.LiteralProcessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.LiteralProcessor

Packages that use LiteralProcessor
org.hibernate.hql.ast An ANTLR-based parser for Hibernate Query Language.

Uses of LiteralProcessor in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that return LiteralProcessor
 LiteralProcessor HqlSqlWalker.getLiteralProcessor()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.NodeTraverser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.NodeTraverser

No usage of org.hibernate.hql.ast.util.NodeTraverser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ast.util.NodeTraverser.VisitationStrategy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ast.util.NodeTraverser.VisitationStrategy

Packages that use NodeTraverser.VisitationStrategy
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.util |

Uses of NodeTraverser.VisitationStrategy in org.hibernate.hql.ast

Classes in org.hibernate.hql.ast that implement NodeTraverser.VisitationStrategy
static class QueryTranslatorImpl.JavaConstantConverter

Uses of NodeTraverser.VisitationStrategy in org.hibernate.hql.ast.util

Constructors in org.hibernate.hql.ast.util with parameters of type NodeTraverser.VisitationStrategy
NodeTraverser(NodeTraverser.VisitationStrategy strategy)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.PathHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.PathHelper

No usage of org.hibernate.hql.ast.util.PathHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.SessionFactoryHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.SessionFactoryHelper

Packages that use SessionFactoryHelper
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |

Uses of SessionFactoryHelper in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that return SessionFactoryHelper
 SessionFactoryHelper HqlSqlWalker.getSessionFactoryHelper()

Uses of SessionFactoryHelper in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return SessionFactoryHelper
 SessionFactoryHelper HqlSqlWalkerNode.getSessionFactoryHelper()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.ast.util.SyntheticAndFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.ast.util.SyntheticAndFactory

No usage of org.hibernate.hql.ast.util.SyntheticAndFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.CollectionProperties (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.CollectionProperties

No usage of org.hibernate.hql.CollectionProperties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.CollectionSubqueryFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.CollectionSubqueryFactory

No usage of org.hibernate.hql.CollectionSubqueryFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.FilterTranslator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.FilterTranslator

Packages that use FilterTranslator
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.

Uses of FilterTranslator in org.hibernate.hql

Methods in org.hibernate.hql that return FilterTranslator
 FilterTranslator QueryTranslatorFactory.createFilterTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory)
Construct a FilterTranslator instance capable of translating an HQL filter string.

Uses of FilterTranslator in org.hibernate.hql.ast

Classes in org.hibernate.hql.ast that implement FilterTranslator
 class QueryTranslatorImpl
A QueryTranslator that uses an Antlr-based parser.

Methods in org.hibernate.hql.ast that return FilterTranslator
 FilterTranslator ASTQueryTranslatorFactory.createFilterTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory)

Uses of FilterTranslator in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that return FilterTranslator
 FilterTranslator ClassicQueryTranslatorFactory.createFilterTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.HolderInstantiator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.HolderInstantiator

Packages that use HolderInstantiator
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.

Uses of HolderInstantiator in org.hibernate.hql

Fields in org.hibernate.hql declared as HolderInstantiator
static HolderInstantiator HolderInstantiator.NOOP_INSTANTIATOR

Methods in org.hibernate.hql that return HolderInstantiator
static HolderInstantiator | HolderInstantiator.getHolderInstantiator(ResultTransformer selectNewTransformer, ResultTransformer customTransformer, String[] queryReturnAliases)
static HolderInstantiator | HolderInstantiator.createClassicHolderInstantiator(Constructor constructor, ResultTransformer transformer)

Uses of HolderInstantiator in org.hibernate.impl

Methods in org.hibernate.impl that return HolderInstantiator
protected  HolderInstantiator AbstractScrollableResults.getHolderInstantiator()

Constructors in org.hibernate.impl with parameters of type HolderInstantiator
ScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
IteratorImpl(ResultSet rs, PreparedStatement ps, EventSource sess, Type[] types, String[][] columnNames, HolderInstantiator holderInstantiator)
FetchingScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
AbstractScrollableResults(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)

Uses of HolderInstantiator in org.hibernate.loader

Methods in org.hibernate.loader with parameters of type HolderInstantiator
protected  ScrollableResults Loader.scroll(QueryParameters queryParameters, Type[] returnTypes, HolderInstantiator holderInstantiator, SessionImplementor session)
Return the query results, as an instance of ScrollableResults

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.NameGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.NameGenerator

No usage of org.hibernate.hql.NameGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.ParameterTranslations (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.ParameterTranslations

Packages that use ParameterTranslations
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.

Uses of ParameterTranslations in org.hibernate.hql

Methods in org.hibernate.hql that return ParameterTranslations
 ParameterTranslations QueryTranslator.getParameterTranslations()
Return information about any parameters encountered during translation.

Uses of ParameterTranslations in org.hibernate.hql.ast

Classes in org.hibernate.hql.ast that implement ParameterTranslations
 class ParameterTranslationsImpl
Defines the information available for parameters encountered during query translation through the antlr-based parser.

Methods in org.hibernate.hql.ast that return ParameterTranslations
 ParameterTranslations QueryTranslatorImpl.getParameterTranslations()

Uses of ParameterTranslations in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that return ParameterTranslations
 ParameterTranslations QueryTranslatorImpl.getParameterTranslations()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.QueryExecutionRequestException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.QueryExecutionRequestException

No usage of org.hibernate.hql.QueryExecutionRequestException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.QuerySplitter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.QuerySplitter

No usage of org.hibernate.hql.QuerySplitter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.QueryTranslator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.QueryTranslator

Packages that use QueryTranslator
org.hibernate.engine.query |
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser

Uses of QueryTranslator in org.hibernate.engine.query

Methods in org.hibernate.engine.query that return QueryTranslator
 QueryTranslator[] HQLQueryPlan.getTranslators()

Uses of QueryTranslator in org.hibernate.hql

Subinterfaces of QueryTranslator in org.hibernate.hql
 interface FilterTranslator
Specialized interface for filters.

Methods in org.hibernate.hql that return QueryTranslator
 QueryTranslator QueryTranslatorFactory.createQueryTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory)
Construct a QueryTranslator instance capable of translating an HQL query string.

Uses of QueryTranslator in org.hibernate.hql.ast

Classes in org.hibernate.hql.ast that implement QueryTranslator
 class QueryTranslatorImpl
A QueryTranslator that uses an Antlr-based parser.

Methods in org.hibernate.hql.ast that return QueryTranslator
 QueryTranslator ASTQueryTranslatorFactory.createQueryTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory)

Uses of QueryTranslator in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that return QueryTranslator
 QueryTranslator ClassicQueryTranslatorFactory.createQueryTranslator(String queryIdentifier, String queryString, Map filters, SessionFactoryImplementor factory)

Uses of QueryTranslator in org.hibernate.loader.hql

Constructors in org.hibernate.loader.hql with parameters of type QueryTranslator
QueryLoader(QueryTranslator queryTranslator, SessionFactoryImplementor factory, SelectClause selectClause)
Creates a new Loader implementation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.QueryTranslatorFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.QueryTranslatorFactory

Packages that use QueryTranslatorFactory
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.

Uses of QueryTranslatorFactory in org.hibernate.cfg

Methods in org.hibernate.cfg that return QueryTranslatorFactory
protected QueryTranslatorFactory | SettingsFactory.createQueryTranslatorFactory(Properties properties)
QueryTranslatorFactory | Settings.getQueryTranslatorFactory()

Uses of QueryTranslatorFactory in org.hibernate.hql.ast

Classes in org.hibernate.hql.ast that implement QueryTranslatorFactory
 class ASTQueryTranslatorFactory
Generates translators which uses the Antlr-based parser to perform the translation.

Uses of QueryTranslatorFactory in org.hibernate.hql.classic

Classes in org.hibernate.hql.classic that implement QueryTranslatorFactory
 class ClassicQueryTranslatorFactory
Generates translators which uses the older hand-written parser to perform the translation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.hql.classic (Hibernate API Documentation)

 org.hibernate.hql.classic
Interfaces
Parser
Classes
ClassicQueryTranslatorFactory
ClauseParser
FromParser
FromPathExpressionParser
GroupByParser
HavingParser
OrderByParser
ParserHelper
PathExpressionParser
PreprocessingParser
QueryTranslatorImpl
SelectParser
SelectPathExpressionParser
WhereParser


Uses of Class org.hibernate.hql.classic.ClassicQueryTranslatorFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.ClassicQueryTranslatorFactory

No usage of org.hibernate.hql.classic.ClassicQueryTranslatorFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.ClauseParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.ClauseParser

No usage of org.hibernate.hql.classic.ClauseParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.FromParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.FromParser

No usage of org.hibernate.hql.classic.FromParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.FromPathExpressionParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.FromPathExpressionParser

No usage of org.hibernate.hql.classic.FromPathExpressionParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.GroupByParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.GroupByParser

No usage of org.hibernate.hql.classic.GroupByParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.HavingParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.HavingParser

No usage of org.hibernate.hql.classic.HavingParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.OrderByParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.OrderByParser

No usage of org.hibernate.hql.classic.OrderByParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.hql.classic.Parser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.hql.classic.Parser

Packages that use Parser
org.hibernate.hql.classic This package contains the Hibernate 2.x query parser which is being end-of-lifed.

Uses of Parser in org.hibernate.hql.classic

Classes in org.hibernate.hql.classic that implement Parser
class | ClauseParser Parses the Hibernate query into its constituent clauses.
class | FromParser Parses the from clause of a hibernate query, looking for tables and aliases for the SQL query.
class | FromPathExpressionParser
class | GroupByParser Parses the GROUP BY clause of an aggregate query
class | HavingParser Parses the having clause of a hibernate query and translates it to an SQL having clause.
class | OrderByParser Parses the ORDER BY clause of a query
class | PathExpressionParser Parses an expression of the form foo.bar.baz and builds up an expression involving two less table joins than there are path components.
class | PreprocessingParser
class | SelectParser Parsers the select clause of a Hibernate query.
class | SelectPathExpressionParser
class | WhereParser Parses the where clause of a hibernate query and translates it to an SQL where clause.

Methods in org.hibernate.hql.classic with parameters of type Parser
static void ParserHelper.parse(Parser p, String text, String seperators, QueryTranslatorImpl q)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.ParserHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.ParserHelper

No usage of org.hibernate.hql.classic.ParserHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.PathExpressionParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.PathExpressionParser

Packages that use PathExpressionParser
org.hibernate.hql.classic This package contains the Hibernate 2.x query parser which is being end-of-lifed.

Uses of PathExpressionParser in org.hibernate.hql.classic

Subclasses of PathExpressionParser in org.hibernate.hql.classic
class | FromPathExpressionParser
class | SelectPathExpressionParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.PreprocessingParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.PreprocessingParser

No usage of org.hibernate.hql.classic.PreprocessingParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.QueryTranslatorImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.QueryTranslatorImpl

Packages that use QueryTranslatorImpl
org.hibernate.hql.classic This package contains the Hibernate 2.x query parser which is being end-of-lifed.

Uses of QueryTranslatorImpl in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic with parameters of type QueryTranslatorImpl
void | WhereParser.token(String token, QueryTranslatorImpl q)
void | WhereParser.start(QueryTranslatorImpl q)
void | WhereParser.end(QueryTranslatorImpl q)
void | SelectPathExpressionParser.end(QueryTranslatorImpl q)
void | SelectParser.token(String token, QueryTranslatorImpl q)
boolean | SelectParser.aggregateHasArgs(String funcToken, QueryTranslatorImpl q)
boolean | SelectParser.aggregateFuncNoArgsHasParenthesis(String funcToken, QueryTranslatorImpl q)
Type | SelectParser.aggregateType(List funcTokenList, Type type, QueryTranslatorImpl q)
void | SelectParser.start(QueryTranslatorImpl q)
void | SelectParser.end(QueryTranslatorImpl q)
void | PreprocessingParser.token(String token, QueryTranslatorImpl q)
void | PreprocessingParser.start(QueryTranslatorImpl q)
void | PreprocessingParser.end(QueryTranslatorImpl q)
void | PathExpressionParser.token(String token, QueryTranslatorImpl q)
void | PathExpressionParser.start(QueryTranslatorImpl q)
void | PathExpressionParser.end(QueryTranslatorImpl q)
void | PathExpressionParser.addAssociation(QueryTranslatorImpl q)
String | PathExpressionParser.addFromAssociation(QueryTranslatorImpl q)
String | PathExpressionParser.addFromCollection(QueryTranslatorImpl q)
void | PathExpressionParser.fetch(QueryTranslatorImpl q, String entityName)
static void | ParserHelper.parse(Parser p, String text, String seperators, QueryTranslatorImpl q)
void | Parser.token(String token, QueryTranslatorImpl q)
void | Parser.start(QueryTranslatorImpl q)
void | Parser.end(QueryTranslatorImpl q)
void | OrderByParser.token(String token, QueryTranslatorImpl q)
void | OrderByParser.start(QueryTranslatorImpl q)
void | OrderByParser.end(QueryTranslatorImpl q)
void | GroupByParser.token(String token, QueryTranslatorImpl q)
void | GroupByParser.start(QueryTranslatorImpl q)
void | GroupByParser.end(QueryTranslatorImpl q)
void | FromPathExpressionParser.end(QueryTranslatorImpl q)
void | FromParser.token(String token, QueryTranslatorImpl q)
void | FromParser.start(QueryTranslatorImpl q)
void | FromParser.end(QueryTranslatorImpl q)
void | ClauseParser.token(String token, QueryTranslatorImpl q)
void | ClauseParser.start(QueryTranslatorImpl q)
void | ClauseParser.end(QueryTranslatorImpl q)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.SelectParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.SelectParser

No usage of org.hibernate.hql.classic.SelectParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.SelectPathExpressionParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.SelectPathExpressionParser

No usage of org.hibernate.hql.classic.SelectPathExpressionParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.hql.classic.WhereParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.hql.classic.WhereParser

Packages that use WhereParser
org.hibernate.hql.classic This package contains the Hibernate 2.x query parser which is being end-of-lifed.

Uses of WhereParser in org.hibernate.hql.classic

Subclasses of WhereParser in org.hibernate.hql.classic
 class HavingParser
Parses the having clause of a hibernate query and translates it to an SQL having clause.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.id (Hibernate API Documentation)

 org.hibernate.id
Interfaces
Configurable
IdentifierGenerator
PersistentIdentifierGenerator
PostInsertIdentifierGenerator
PostInsertIdentityPersister
Classes
AbstractPostInsertGenerator
AbstractUUIDGenerator
Assigned
ForeignGenerator
GUIDGenerator
IdentifierGeneratorFactory
IdentityGenerator
IdentityGenerator.BasicDelegate
IdentityGenerator.GetGeneratedKeysDelegate
IdentityGenerator.InsertSelectDelegate
IncrementGenerator
MultipleHiLoPerTableGenerator
SelectGenerator
SelectGenerator.SelectGeneratorDelegate
SequenceGenerator
SequenceHiLoGenerator
SequenceIdentityGenerator
SequenceIdentityGenerator.Delegate
SequenceIdentityGenerator.NoCommentsInsert
TableGenerator
TableHiLoGenerator
UUIDHexGenerator
Exceptions
IdentifierGenerationException


Uses of Class org.hibernate.id.AbstractPostInsertGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.AbstractPostInsertGenerator

Packages that use AbstractPostInsertGenerator
org.hibernate.id This package contains internal implementation classes for the main API interfaces.

Uses of AbstractPostInsertGenerator in org.hibernate.id

Subclasses of AbstractPostInsertGenerator in org.hibernate.id
class | IdentityGenerator A generator for use with ANSI-SQL IDENTITY columns used as the primary key.
class | SelectGenerator A generator that selects the just inserted row to determine the identifier value assigned by the database.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.AbstractUUIDGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.AbstractUUIDGenerator

Packages that use AbstractUUIDGenerator
org.hibernate.id This package contains internal implementation classes for the main API interfaces.

Uses of AbstractUUIDGenerator in org.hibernate.id

Subclasses of AbstractUUIDGenerator in org.hibernate.id
 class UUIDHexGenerator
uuid

A UUIDGenerator that returns a string of length 32, This string will consist of only hex digits.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.Assigned (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.Assigned

No usage of org.hibernate.id.Assigned

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.id.Configurable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.id.Configurable

Packages that use Configurable
org.hibernate.id This package contains internal implementation classes for the main API interfaces.

Uses of Configurable in org.hibernate.id

Classes in org.hibernate.id that implement Configurable
class | Assigned assigned An IdentifierGenerator that returns the current identifier assigned to an instance.
class | ForeignGenerator foreign An Identifier generator that uses the value of the id property of an associated object One mapping parameter is required: property.
class | IncrementGenerator increment An IdentifierGenerator that returns a long, constructed by counting from the maximum primary key value at startup.
class | MultipleHiLoPerTableGenerator A hilo IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.
class | SelectGenerator A generator that selects the just inserted row to determine the identifier value assigned by the database.
class | SequenceGenerator sequence Generates long values using an oracle-style sequence.
class | SequenceHiLoGenerator seqhilo An IdentifierGenerator that combines a hi/lo algorithm with an underlying oracle-style sequence that generates hi values.
class | SequenceIdentityGenerator A generator which combines sequence generation with immediate retrieval through JDBC3 getGeneratedKeys.
class | TableGenerator An IdentifierGenerator that uses a database table to store the last generated value.
class | TableHiLoGenerator hilo An IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.
class | UUIDHexGenerator uuid A UUIDGenerator that returns a string of length 32, This string will consist of only hex digits.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.ForeignGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.ForeignGenerator

No usage of org.hibernate.id.ForeignGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.GUIDGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.GUIDGenerator

No usage of org.hibernate.id.GUIDGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.IdentifierGenerationException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.IdentifierGenerationException

Packages that use IdentifierGenerationException
org.hibernate.id This package contains internal implementation classes for the main API interfaces.

Uses of IdentifierGenerationException in org.hibernate.id

Methods in org.hibernate.id that throw IdentifierGenerationException
static Serializable | IdentifierGeneratorFactory.getGeneratedIdentity(ResultSet rs, Type type) Get the generated identifier when using identity columns
static Serializable | IdentifierGeneratorFactory.get(ResultSet rs, Type type)
static Number | IdentifierGeneratorFactory.createNumber(long value, Class clazz)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.id.IdentifierGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.id.IdentifierGenerator

Packages that use IdentifierGenerator
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.

Uses of IdentifierGenerator in org.hibernate.engine

Methods in org.hibernate.engine that return IdentifierGenerator
 IdentifierGenerator SessionFactoryImplementor.getIdentifierGenerator(String rootEntityName)
Get the identifier generator for the hierarchy

Uses of IdentifierGenerator in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast with parameters of type IdentifierGenerator
static boolean HqlSqlWalker.supportsIdGenWithBulkInsertion(IdentifierGenerator generator)

Uses of IdentifierGenerator in org.hibernate.id

Subinterfaces of IdentifierGenerator in org.hibernate.id
interface | PersistentIdentifierGenerator An IdentifierGenerator that requires creation of database objects.
interface | PostInsertIdentifierGenerator

Classes in org.hibernate.id that implement IdentifierGenerator
class | AbstractPostInsertGenerator
class | AbstractUUIDGenerator The base class for identifier generators that use a UUID algorithm.
class | Assigned assigned An IdentifierGenerator that returns the current identifier assigned to an instance.
class | ForeignGenerator foreign An Identifier generator that uses the value of the id property of an associated object One mapping parameter is required: property.
class | GUIDGenerator Generates string values using the SQL Server NEWID() function.
class | IdentityGenerator A generator for use with ANSI-SQL IDENTITY columns used as the primary key.
class | IncrementGenerator increment An IdentifierGenerator that returns a long, constructed by counting from the maximum primary key value at startup.
class | MultipleHiLoPerTableGenerator A hilo IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.
class | SelectGenerator A generator that selects the just inserted row to determine the identifier value assigned by the database.
class | SequenceGenerator sequence Generates long values using an oracle-style sequence.
class | SequenceHiLoGenerator seqhilo An IdentifierGenerator that combines a hi/lo algorithm with an underlying oracle-style sequence that generates hi values.
class | SequenceIdentityGenerator A generator which combines sequence generation with immediate retrieval through JDBC3 getGeneratedKeys.
class | TableGenerator An IdentifierGenerator that uses a database table to store the last generated value.
class | TableHiLoGenerator hilo An IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.
class | UUIDHexGenerator uuid A UUIDGenerator that returns a string of length 32, This string will consist of only hex digits.

Methods in org.hibernate.id that return IdentifierGenerator
static IdentifierGenerator IdentifierGeneratorFactory.create(String strategy, Type type, Properties params, Dialect dialect)

Uses of IdentifierGenerator in org.hibernate.impl

Methods in org.hibernate.impl that return IdentifierGenerator
 IdentifierGenerator SessionFactoryImpl.getIdentifierGenerator(String rootEntityName)

Uses of IdentifierGenerator in org.hibernate.mapping

Methods in org.hibernate.mapping that return IdentifierGenerator
IdentifierGenerator | SimpleValue.createIdentifierGenerator(Dialect dialect, String defaultCatalog, String defaultSchema, RootClass rootClass)
IdentifierGenerator | KeyValue.createIdentifierGenerator(Dialect dialect, String defaultCatalog, String defaultSchema, RootClass rootClass)

Uses of IdentifierGenerator in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that return IdentifierGenerator
IdentifierGenerator | CollectionPersister.getIdentifierGenerator() Get the surrogate key generation strategy (optional operation)
IdentifierGenerator | AbstractCollectionPersister.getIdentifierGenerator()

Uses of IdentifierGenerator in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return IdentifierGenerator
IdentifierGenerator | EntityPersister.getIdentifierGenerator() Return the IdentifierGenerator for the class
IdentifierGenerator | AbstractEntityPersister.getIdentifierGenerator()

Uses of IdentifierGenerator in org.hibernate.tuple

Methods in org.hibernate.tuple that return IdentifierGenerator
 IdentifierGenerator IdentifierProperty.getIdentifierGenerator()

Methods in org.hibernate.tuple with parameters of type IdentifierGenerator
static IdentifierProperty PropertyFactory.buildIdentifierProperty(PersistentClass mappedEntity, IdentifierGenerator generator)
Generates an IdentifierProperty representation of the for a given entity mapping.

Constructors in org.hibernate.tuple with parameters of type IdentifierGenerator
IdentifierProperty(String name, String node, Type type, boolean embedded, IdentifierValue unsavedValue, IdentifierGenerator identifierGenerator)
Construct a non-virtual identifier property.
IdentifierProperty(Type type, boolean embedded, boolean hasIdentifierMapper, IdentifierValue unsavedValue, IdentifierGenerator identifierGenerator)
Construct a virtual IdentifierProperty.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.IdentifierGeneratorFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.IdentifierGeneratorFactory

No usage of org.hibernate.id.IdentifierGeneratorFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.IdentityGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.IdentityGenerator

No usage of org.hibernate.id.IdentityGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.IdentityGenerator.BasicDelegate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.IdentityGenerator.BasicDelegate

No usage of org.hibernate.id.IdentityGenerator.BasicDelegate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.IdentityGenerator.GetGeneratedKeysDelegate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.IdentityGenerator.GetGeneratedKeysDelegate

No usage of org.hibernate.id.IdentityGenerator.GetGeneratedKeysDelegate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.IdentityGenerator.InsertSelectDelegate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.IdentityGenerator.InsertSelectDelegate

No usage of org.hibernate.id.IdentityGenerator.InsertSelectDelegate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.IncrementGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.IncrementGenerator

No usage of org.hibernate.id.IncrementGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.MultipleHiLoPerTableGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.MultipleHiLoPerTableGenerator

No usage of org.hibernate.id.MultipleHiLoPerTableGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.id.PersistentIdentifierGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.id.PersistentIdentifierGenerator

Packages that use PersistentIdentifierGenerator
org.hibernate.id This package contains internal implementation classes for the main API interfaces.

Uses of PersistentIdentifierGenerator in org.hibernate.id

Classes in org.hibernate.id that implement PersistentIdentifierGenerator
class | MultipleHiLoPerTableGenerator A hilo IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.
class | SequenceGenerator sequence Generates long values using an oracle-style sequence.
class | SequenceHiLoGenerator seqhilo An IdentifierGenerator that combines a hi/lo algorithm with an underlying oracle-style sequence that generates hi values.
class | SequenceIdentityGenerator A generator which combines sequence generation with immediate retrieval through JDBC3 getGeneratedKeys.
class | TableGenerator An IdentifierGenerator that uses a database table to store the last generated value.
class | TableHiLoGenerator hilo An IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.id.PostInsertIdentifierGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.id.PostInsertIdentifierGenerator

Packages that use PostInsertIdentifierGenerator
org.hibernate.id This package contains internal implementation classes for the main API interfaces.

Uses of PostInsertIdentifierGenerator in org.hibernate.id

Classes in org.hibernate.id that implement PostInsertIdentifierGenerator
class | AbstractPostInsertGenerator
class | IdentityGenerator A generator for use with ANSI-SQL IDENTITY columns used as the primary key.
class | SelectGenerator A generator that selects the just inserted row to determine the identifier value assigned by the database.
class | SequenceIdentityGenerator A generator which combines sequence generation with immediate retrieval through JDBC3 getGeneratedKeys.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.id.PostInsertIdentityPersister (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.id.PostInsertIdentityPersister

Packages that use PostInsertIdentityPersister
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.id.insert |
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of PostInsertIdentityPersister in org.hibernate.id

Methods in org.hibernate.id with parameters of type PostInsertIdentityPersister
InsertGeneratedIdentifierDelegate | SequenceIdentityGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
InsertGeneratedIdentifierDelegate | SelectGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
InsertGeneratedIdentifierDelegate | PostInsertIdentifierGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
InsertGeneratedIdentifierDelegate | IdentityGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)

Constructors in org.hibernate.id with parameters of type PostInsertIdentityPersister
SequenceIdentityGenerator.Delegate(PostInsertIdentityPersister persister, Dialect dialect, String sequenceName)
IdentityGenerator.GetGeneratedKeysDelegate(PostInsertIdentityPersister persister, Dialect dialect)
IdentityGenerator.InsertSelectDelegate(PostInsertIdentityPersister persister, Dialect dialect)
IdentityGenerator.BasicDelegate(PostInsertIdentityPersister persister, Dialect dialect)

Uses of PostInsertIdentityPersister in org.hibernate.id.insert

Methods in org.hibernate.id.insert that return PostInsertIdentityPersister
protected  PostInsertIdentityPersister AbstractReturningDelegate.getPersister()

Constructors in org.hibernate.id.insert with parameters of type PostInsertIdentityPersister
AbstractSelectingDelegate(PostInsertIdentityPersister persister)
AbstractReturningDelegate(PostInsertIdentityPersister persister)

Uses of PostInsertIdentityPersister in org.hibernate.persister.entity

Classes in org.hibernate.persister.entity that implement PostInsertIdentityPersister
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.SelectGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.SelectGenerator

No usage of org.hibernate.id.SelectGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.SelectGenerator.SelectGeneratorDelegate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.SelectGenerator.SelectGeneratorDelegate

No usage of org.hibernate.id.SelectGenerator.SelectGeneratorDelegate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.SequenceGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.SequenceGenerator

Packages that use SequenceGenerator
org.hibernate.id This package contains internal implementation classes for the main API interfaces.

Uses of SequenceGenerator in org.hibernate.id

Subclasses of SequenceGenerator in org.hibernate.id
class | SequenceHiLoGenerator seqhilo An IdentifierGenerator that combines a hi/lo algorithm with an underlying oracle-style sequence that generates hi values.
class | SequenceIdentityGenerator A generator which combines sequence generation with immediate retrieval through JDBC3 getGeneratedKeys.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.SequenceHiLoGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.SequenceHiLoGenerator

No usage of org.hibernate.id.SequenceHiLoGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.SequenceIdentityGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.SequenceIdentityGenerator

No usage of org.hibernate.id.SequenceIdentityGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.SequenceIdentityGenerator.Delegate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.SequenceIdentityGenerator.Delegate

No usage of org.hibernate.id.SequenceIdentityGenerator.Delegate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.SequenceIdentityGenerator.NoCommentsInsert (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.SequenceIdentityGenerator.NoCommentsInsert

No usage of org.hibernate.id.SequenceIdentityGenerator.NoCommentsInsert

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.TableGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.TableGenerator

Packages that use TableGenerator
org.hibernate.id This package contains internal implementation classes for the main API interfaces.

Uses of TableGenerator in org.hibernate.id

Subclasses of TableGenerator in org.hibernate.id
 class TableHiLoGenerator
hilo

An IdentifierGenerator that returns a Long, constructed using a hi/lo algorithm.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.TableHiLoGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.TableHiLoGenerator

No usage of org.hibernate.id.TableHiLoGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.UUIDHexGenerator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.UUIDHexGenerator

No usage of org.hibernate.id.UUIDHexGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.id.insert (Hibernate API Documentation)

 org.hibernate.id.insert
Interfaces
Binder
InsertGeneratedIdentifierDelegate
Classes
AbstractReturningDelegate
AbstractSelectingDelegate
IdentifierGeneratingInsert
InsertSelectIdentityInsert


Uses of Class org.hibernate.id.insert.AbstractReturningDelegate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.insert.AbstractReturningDelegate

Packages that use AbstractReturningDelegate
org.hibernate.id This package contains internal implementation classes for the main API interfaces.

Uses of AbstractReturningDelegate in org.hibernate.id

Subclasses of AbstractReturningDelegate in org.hibernate.id
static class | IdentityGenerator.GetGeneratedKeysDelegate Delegate for dealing with IDENTITY columns using JDBC3 getGeneratedKeys
static class | IdentityGenerator.InsertSelectDelegate Delegate for dealing with IDENTITY columns where the dialect supports returning the generated IDENTITY value directly from the insert statement.
static class | SequenceIdentityGenerator.Delegate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.insert.AbstractSelectingDelegate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.insert.AbstractSelectingDelegate

Packages that use AbstractSelectingDelegate
org.hibernate.id This package contains internal implementation classes for the main API interfaces.

Uses of AbstractSelectingDelegate in org.hibernate.id

Subclasses of AbstractSelectingDelegate in org.hibernate.id
static class | IdentityGenerator.BasicDelegate Delegate for dealing with IDENTITY columns where the dialect requires an additional command execution to retrieve the generated IDENTITY value
static class | SelectGenerator.SelectGeneratorDelegate The delegate for the select generation strategy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.id.insert.Binder (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.id.insert.Binder

Packages that use Binder
org.hibernate.id.insert

Uses of Binder in org.hibernate.id.insert

Methods in org.hibernate.id.insert with parameters of type Binder
Serializable | InsertGeneratedIdentifierDelegate.performInsert(String insertSQL, SessionImplementor session, Binder binder) Perform the indicated insert SQL statement and determine the identifier value generated.
Serializable | AbstractSelectingDelegate.performInsert(String insertSQL, SessionImplementor session, Binder binder)
Serializable | AbstractReturningDelegate.performInsert(String insertSQL, SessionImplementor session, Binder binder)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.insert.IdentifierGeneratingInsert (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.insert.IdentifierGeneratingInsert

Packages that use IdentifierGeneratingInsert
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.id.insert |

Uses of IdentifierGeneratingInsert in org.hibernate.id

Subclasses of IdentifierGeneratingInsert in org.hibernate.id
static class SequenceIdentityGenerator.NoCommentsInsert

Methods in org.hibernate.id that return IdentifierGeneratingInsert
IdentifierGeneratingInsert | SequenceIdentityGenerator.Delegate.prepareIdentifierGeneratingInsert()
IdentifierGeneratingInsert | SelectGenerator.SelectGeneratorDelegate.prepareIdentifierGeneratingInsert()
IdentifierGeneratingInsert | IdentityGenerator.GetGeneratedKeysDelegate.prepareIdentifierGeneratingInsert()
IdentifierGeneratingInsert | IdentityGenerator.InsertSelectDelegate.prepareIdentifierGeneratingInsert()
IdentifierGeneratingInsert | IdentityGenerator.BasicDelegate.prepareIdentifierGeneratingInsert()

Uses of IdentifierGeneratingInsert in org.hibernate.id.insert

Subclasses of IdentifierGeneratingInsert in org.hibernate.id.insert
 class InsertSelectIdentityInsert
Specialized IdentifierGeneratingInsert which appends the database specific clause which signifies to return generated IDENTITY values to the end of the insert statement.

Methods in org.hibernate.id.insert that return IdentifierGeneratingInsert
 IdentifierGeneratingInsert InsertGeneratedIdentifierDelegate.prepareIdentifierGeneratingInsert()
Build a Insert specific to the delegate's mode of handling generated key values.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.id.insert.InsertGeneratedIdentifierDelegate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.id.insert.InsertGeneratedIdentifierDelegate

Packages that use InsertGeneratedIdentifierDelegate
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.id.insert |

Uses of InsertGeneratedIdentifierDelegate in org.hibernate.id

Classes in org.hibernate.id that implement InsertGeneratedIdentifierDelegate
static class | IdentityGenerator.BasicDelegate Delegate for dealing with IDENTITY columns where the dialect requires an additional command execution to retrieve the generated IDENTITY value
static class | IdentityGenerator.GetGeneratedKeysDelegate Delegate for dealing with IDENTITY columns using JDBC3 getGeneratedKeys
static class | IdentityGenerator.InsertSelectDelegate Delegate for dealing with IDENTITY columns where the dialect supports returning the generated IDENTITY value directly from the insert statement.
static class | SelectGenerator.SelectGeneratorDelegate The delegate for the select generation strategy.
static class | SequenceIdentityGenerator.Delegate

Methods in org.hibernate.id that return InsertGeneratedIdentifierDelegate
InsertGeneratedIdentifierDelegate | SequenceIdentityGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
InsertGeneratedIdentifierDelegate | SelectGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
InsertGeneratedIdentifierDelegate | PostInsertIdentifierGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)
InsertGeneratedIdentifierDelegate | IdentityGenerator.getInsertGeneratedIdentifierDelegate(PostInsertIdentityPersister persister, Dialect dialect, boolean isGetGeneratedKeysEnabled)

Uses of InsertGeneratedIdentifierDelegate in org.hibernate.id.insert

Classes in org.hibernate.id.insert that implement InsertGeneratedIdentifierDelegate
class | AbstractReturningDelegate Abstract InsertGeneratedIdentifierDelegate implementation where the underlying strategy causes the enerated identitifer to be returned as an effect of performing the insert statement.
class | AbstractSelectingDelegate Abstract InsertGeneratedIdentifierDelegate implementation where the underlying strategy requires an subsequent select after the insert to determine the generated identifier.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.id.insert.InsertSelectIdentityInsert (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.id.insert.InsertSelectIdentityInsert

No usage of org.hibernate.id.insert.InsertSelectIdentityInsert

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.impl (Hibernate API Documentation)

 org.hibernate.impl
Classes
AbstractQueryImpl
AbstractScrollableResults
AbstractSessionImpl
CollectionFilterImpl
CriteriaImpl
CriteriaImpl.CriterionEntry
CriteriaImpl.OrderEntry
FetchingScrollableResultsImpl
FilterImpl
IteratorImpl
QueryImpl
ScrollableResultsImpl
SessionFactoryImpl
SessionFactoryObjectFactory
SessionImpl
SQLQueryImpl
StatelessSessionImpl


Uses of Class org.hibernate.impl.AbstractQueryImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.AbstractQueryImpl

Packages that use AbstractQueryImpl
org.hibernate.impl This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of AbstractQueryImpl in org.hibernate.impl

Subclasses of AbstractQueryImpl in org.hibernate.impl
class | CollectionFilterImpl implementation of the Query interface for collection filters
class | QueryImpl default implementation of the Query interface, for "ordinary" HQL queries (not collection filters)
class | SQLQueryImpl Implements SQL query passthrough.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.AbstractScrollableResults (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.AbstractScrollableResults

Packages that use AbstractScrollableResults
org.hibernate.impl This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of AbstractScrollableResults in org.hibernate.impl

Subclasses of AbstractScrollableResults in org.hibernate.impl
class | FetchingScrollableResultsImpl Implementation of ScrollableResults which can handle collection fetches.
class | ScrollableResultsImpl Implementation of the ScrollableResults interface

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.AbstractSessionImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.AbstractSessionImpl

Packages that use AbstractSessionImpl
org.hibernate.impl This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of AbstractSessionImpl in org.hibernate.impl

Subclasses of AbstractSessionImpl in org.hibernate.impl
class | SessionImpl Concrete implementation of a Session, and also the central, organizing component of Hibernate's internal implementation.
class | StatelessSessionImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.CollectionFilterImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.CollectionFilterImpl

No usage of org.hibernate.impl.CollectionFilterImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.CriteriaImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.CriteriaImpl

Packages that use CriteriaImpl
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader

Uses of CriteriaImpl in org.hibernate.criterion

Constructors in org.hibernate.criterion with parameters of type CriteriaImpl
DetachedCriteria(CriteriaImpl impl, Criteria criteria)

Uses of CriteriaImpl in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type CriteriaImpl
ScrollableResults | SessionImplementor.scroll(CriteriaImpl criteria, ScrollMode scrollMode) Execute a criteria query
List | SessionImplementor.list(CriteriaImpl criteria) Execute a criteria query

Uses of CriteriaImpl in org.hibernate.impl

Methods in org.hibernate.impl with parameters of type CriteriaImpl
ScrollableResults | StatelessSessionImpl.scroll(CriteriaImpl criteria, ScrollMode scrollMode)
List | StatelessSessionImpl.list(CriteriaImpl criteria)
ScrollableResults | SessionImpl.scroll(CriteriaImpl criteria, ScrollMode scrollMode)
List | SessionImpl.list(CriteriaImpl criteria)

Uses of CriteriaImpl in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria that return CriteriaImpl
 CriteriaImpl CriteriaQueryTranslator.getRootCriteria()

Constructors in org.hibernate.loader.criteria with parameters of type CriteriaImpl
CriteriaQueryTranslator(SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, String rootSQLAlias, CriteriaQuery outerQuery)
CriteriaQueryTranslator(SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, String rootSQLAlias)
CriteriaLoader(OuterJoinLoadable persister, SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, Map enabledFilters)
CriteriaJoinWalker(OuterJoinLoadable persister, CriteriaQueryTranslator translator, SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, Map enabledFilters)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.CriteriaImpl.CriterionEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.CriteriaImpl.CriterionEntry

No usage of org.hibernate.impl.CriteriaImpl.CriterionEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.CriteriaImpl.OrderEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.CriteriaImpl.OrderEntry

No usage of org.hibernate.impl.CriteriaImpl.OrderEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.CriteriaImpl.Subcriteria (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.CriteriaImpl.Subcriteria

No usage of org.hibernate.impl.CriteriaImpl.Subcriteria

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.FetchingScrollableResultsImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.FetchingScrollableResultsImpl

No usage of org.hibernate.impl.FetchingScrollableResultsImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.FilterImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.FilterImpl

No usage of org.hibernate.impl.FilterImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.IteratorImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.IteratorImpl

No usage of org.hibernate.impl.IteratorImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.QueryImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.QueryImpl

Packages that use QueryImpl
org.hibernate.impl This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of QueryImpl in org.hibernate.impl

Subclasses of QueryImpl in org.hibernate.impl
 class CollectionFilterImpl
implementation of the Query interface for collection filters

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.ScrollableResultsImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.ScrollableResultsImpl

No usage of org.hibernate.impl.ScrollableResultsImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.SessionFactoryImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.SessionFactoryImpl

Packages that use SessionFactoryImpl
org.hibernate.impl This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of SessionFactoryImpl in org.hibernate.impl

Fields in org.hibernate.impl declared as SessionFactoryImpl
protected  SessionFactoryImpl AbstractSessionImpl.factory

Constructors in org.hibernate.impl with parameters of type SessionFactoryImpl
AbstractSessionImpl(SessionFactoryImpl factory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.SessionFactoryObjectFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.SessionFactoryObjectFactory

No usage of org.hibernate.impl.SessionFactoryObjectFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.SessionImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.SessionImpl

No usage of org.hibernate.impl.SessionImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.SQLQueryImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.SQLQueryImpl

No usage of org.hibernate.impl.SQLQueryImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.impl.StatelessSessionImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.impl.StatelessSessionImpl

No usage of org.hibernate.impl.StatelessSessionImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.intercept (Hibernate API Documentation)

 org.hibernate.intercept
Interfaces
FieldInterceptor
LazyPropertyInitializer
Classes
AbstractFieldInterceptor
FieldInterceptionHelper


org.hibernate.intercept.cglib (Hibernate API Documentation)

 org.hibernate.intercept.cglib
Classes
CGLIBHelper
FieldInterceptorImpl


Uses of Class org.hibernate.intercept.cglib.CGLIBHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.intercept.cglib.CGLIBHelper

No usage of org.hibernate.intercept.cglib.CGLIBHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.intercept.cglib.FieldInterceptorImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.intercept.cglib.FieldInterceptorImpl

No usage of org.hibernate.intercept.cglib.FieldInterceptorImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.intercept.AbstractFieldInterceptor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.intercept.AbstractFieldInterceptor

Packages that use AbstractFieldInterceptor
org.hibernate.intercept.cglib

Uses of AbstractFieldInterceptor in org.hibernate.intercept.cglib

Subclasses of AbstractFieldInterceptor in org.hibernate.intercept.cglib
 class FieldInterceptorImpl
A field-level interceptor that initializes lazily fetched properties.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.intercept.FieldInterceptionHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.intercept.FieldInterceptionHelper

No usage of org.hibernate.intercept.FieldInterceptionHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.intercept.FieldInterceptor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.intercept.FieldInterceptor

Packages that use FieldInterceptor
org.hibernate.intercept | This package implements an interception mechanism for lazy property fetching, based on CGLIB bytecode instrumentation.
org.hibernate.intercept.cglib |
org.hibernate.intercept.javassist |

Uses of FieldInterceptor in org.hibernate.intercept

Classes in org.hibernate.intercept that implement FieldInterceptor
 class AbstractFieldInterceptor

Methods in org.hibernate.intercept that return FieldInterceptor
static FieldInterceptor | FieldInterceptionHelper.extractFieldInterceptor(Object entity)
static FieldInterceptor | FieldInterceptionHelper.injectFieldInterceptor(Object entity, String entityName, Set uninitializedFieldNames, SessionImplementor session)

Uses of FieldInterceptor in org.hibernate.intercept.cglib

Classes in org.hibernate.intercept.cglib that implement FieldInterceptor
 class FieldInterceptorImpl
A field-level interceptor that initializes lazily fetched properties.

Methods in org.hibernate.intercept.cglib that return FieldInterceptor
static FieldInterceptor | CGLIBHelper.extractFieldInterceptor(Object entity)
static FieldInterceptor | CGLIBHelper.injectFieldInterceptor(Object entity, String entityName, Set uninitializedFieldNames, SessionImplementor session)

Uses of FieldInterceptor in org.hibernate.intercept.javassist

Methods in org.hibernate.intercept.javassist that return FieldInterceptor
static FieldInterceptor | JavassistHelper.extractFieldInterceptor(Object entity)
static FieldInterceptor | JavassistHelper.injectFieldInterceptor(Object entity, String entityName, Set uninitializedFieldNames, SessionImplementor session)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.intercept.LazyPropertyInitializer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.intercept.LazyPropertyInitializer

Packages that use LazyPropertyInitializer
org.hibernate.persister.entity This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of LazyPropertyInitializer in org.hibernate.persister.entity

Classes in org.hibernate.persister.entity that implement LazyPropertyInitializer
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.intercept.javassist (Hibernate API Documentation)

 org.hibernate.intercept.javassist
Classes
FieldInterceptorImpl
JavassistHelper


Uses of Class org.hibernate.intercept.javassist.FieldInterceptorImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.intercept.javassist.FieldInterceptorImpl

No usage of org.hibernate.intercept.javassist.FieldInterceptorImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.intercept.javassist.JavassistHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.intercept.javassist.JavassistHelper

No usage of org.hibernate.intercept.javassist.JavassistHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.jdbc (Hibernate API Documentation)

 org.hibernate.jdbc
Interfaces
Batcher
BatcherFactory
ConnectionManager.Callback
Expectation
JDBCContext.Context
Classes
AbstractBatcher
BatchingBatcher
BatchingBatcherFactory
BorrowedConnectionProxy
ColumnNameCache
ConnectionManager
Expectations
Expectations.BasicExpectation
Expectations.BasicParamExpectation
JDBCContext
NonBatchingBatcher
NonBatchingBatcherFactory
ResultSetWrapper
Exceptions
BatchedTooManyRowsAffectedException
BatchFailedException
TooManyRowsAffectedException


Uses of Class org.hibernate.jdbc.AbstractBatcher (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.AbstractBatcher

Packages that use AbstractBatcher
org.hibernate.jdbc This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.

Uses of AbstractBatcher in org.hibernate.jdbc

Subclasses of AbstractBatcher in org.hibernate.jdbc
class | BatchingBatcher An implementation of the Batcher interface that actually uses batching
class | NonBatchingBatcher An implementation of the Batcher interface that does no batching

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.BatchedTooManyRowsAffectedException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.BatchedTooManyRowsAffectedException

No usage of org.hibernate.jdbc.BatchedTooManyRowsAffectedException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.jdbc.Batcher (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.jdbc.Batcher

Packages that use Batcher
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.

Uses of Batcher in org.hibernate.engine

Methods in org.hibernate.engine that return Batcher
 Batcher SessionImplementor.getBatcher()
Get the prepared statement Batcher for this session

Uses of Batcher in org.hibernate.impl

Methods in org.hibernate.impl that return Batcher
Batcher | StatelessSessionImpl.getBatcher()
Batcher | SessionImpl.getBatcher()

Uses of Batcher in org.hibernate.jdbc

Classes in org.hibernate.jdbc that implement Batcher
class | AbstractBatcher Manages prepared statements and batching.
class | BatchingBatcher An implementation of the Batcher interface that actually uses batching
class | NonBatchingBatcher An implementation of the Batcher interface that does no batching

Methods in org.hibernate.jdbc that return Batcher
Batcher | NonBatchingBatcherFactory.createBatcher(ConnectionManager connectionManager, Interceptor interceptor)
Batcher | ConnectionManager.getBatcher() The batcher managed by this ConnectionManager.
Batcher | BatchingBatcherFactory.createBatcher(ConnectionManager connectionManager, Interceptor interceptor)
Batcher | BatcherFactory.createBatcher(ConnectionManager connectionManager, Interceptor interceptor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.jdbc.BatcherFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.jdbc.BatcherFactory

Packages that use BatcherFactory
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.

Uses of BatcherFactory in org.hibernate.cfg

Methods in org.hibernate.cfg that return BatcherFactory
protected BatcherFactory | SettingsFactory.createBatcherFactory(Properties properties, int batchSize)
BatcherFactory | Settings.getBatcherFactory()

Uses of BatcherFactory in org.hibernate.impl

Methods in org.hibernate.impl that return BatcherFactory
 BatcherFactory SessionFactoryImpl.getBatcherFactory()

Uses of BatcherFactory in org.hibernate.jdbc

Classes in org.hibernate.jdbc that implement BatcherFactory
class | BatchingBatcherFactory A BatcherFactory implementation which constructs Batcher instances capable of actually performing batch operations.
class | NonBatchingBatcherFactory A BatcherFactory implementation which constructs Batcher instances that do not perform batch operations.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.BatchFailedException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.BatchFailedException

No usage of org.hibernate.jdbc.BatchFailedException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.BatchingBatcher (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.BatchingBatcher

No usage of org.hibernate.jdbc.BatchingBatcher

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.BatchingBatcherFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.BatchingBatcherFactory

No usage of org.hibernate.jdbc.BatchingBatcherFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.BorrowedConnectionProxy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.BorrowedConnectionProxy

No usage of org.hibernate.jdbc.BorrowedConnectionProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.ColumnNameCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.ColumnNameCache

Packages that use ColumnNameCache
org.hibernate.jdbc This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.

Uses of ColumnNameCache in org.hibernate.jdbc

Constructors in org.hibernate.jdbc with parameters of type ColumnNameCache
ResultSetWrapper(ResultSet resultSet, ColumnNameCache columnNameCache)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.ConnectionManager (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.ConnectionManager

Packages that use ConnectionManager
org.hibernate.jdbc This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.

Uses of ConnectionManager in org.hibernate.jdbc

Methods in org.hibernate.jdbc that return ConnectionManager
ConnectionManager | JDBCContext.getConnectionManager()
static ConnectionManager | ConnectionManager.deserialize(ObjectInputStream ois, SessionFactoryImplementor factory, Interceptor interceptor, ConnectionReleaseMode connectionReleaseMode, JDBCContext jdbcContext)

Methods in org.hibernate.jdbc with parameters of type ConnectionManager
Batcher | NonBatchingBatcherFactory.createBatcher(ConnectionManager connectionManager, Interceptor interceptor)
static Connection | BorrowedConnectionProxy.generateProxy(ConnectionManager connectionManager)
Batcher | BatchingBatcherFactory.createBatcher(ConnectionManager connectionManager, Interceptor interceptor)
Batcher | BatcherFactory.createBatcher(ConnectionManager connectionManager, Interceptor interceptor)

Constructors in org.hibernate.jdbc with parameters of type ConnectionManager
NonBatchingBatcher(ConnectionManager connectionManager, Interceptor interceptor)
BorrowedConnectionProxy(ConnectionManager connectionManager)
BatchingBatcher(ConnectionManager connectionManager, Interceptor interceptor)
AbstractBatcher(ConnectionManager connectionManager, Interceptor interceptor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.jdbc.ConnectionManager.Callback (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.jdbc.ConnectionManager.Callback

Packages that use ConnectionManager.Callback
org.hibernate.jdbc This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.

Uses of ConnectionManager.Callback in org.hibernate.jdbc

Classes in org.hibernate.jdbc that implement ConnectionManager.Callback
 class JDBCContext
Acts as the mediary between "entity-mode related" sessions in terms of their interaction with the JDBC data store.

Constructors in org.hibernate.jdbc with parameters of type ConnectionManager.Callback
ConnectionManager(SessionFactoryImplementor factory, ConnectionManager.Callback callback, ConnectionReleaseMode releaseMode, Connection connection, Interceptor interceptor)
Constructs a ConnectionManager.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.jdbc.Expectation (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.jdbc.Expectation

Packages that use Expectation
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of Expectation in org.hibernate.jdbc

Classes in org.hibernate.jdbc that implement Expectation
static class | Expectations.BasicExpectation
static class | Expectations.BasicParamExpectation

Fields in org.hibernate.jdbc declared as Expectation
static Expectation | Expectations.NONE
static Expectation | Expectations.BASIC
static Expectation | Expectations.PARAM

Methods in org.hibernate.jdbc that return Expectation
static Expectation Expectations.appropriateExpectation(ExecuteUpdateResultCheckStyle style)

Methods in org.hibernate.jdbc with parameters of type Expectation
 void NonBatchingBatcher.addToBatch(Expectation expectation)
 void BatchingBatcher.addToBatch(Expectation expectation)
 void Batcher.addToBatch(Expectation expectation)
Add an insert / delete / update to the current batch (might be called multiple times for single prepareBatchStatement())

Uses of Expectation in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity with parameters of type Expectation
protected  boolean AbstractEntityPersister.check(int rows, Serializable id, int tableNumber, Expectation expectation, PreparedStatement statement)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.Expectations (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.Expectations

No usage of org.hibernate.jdbc.Expectations

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.Expectations.BasicExpectation (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.Expectations.BasicExpectation

Packages that use Expectations.BasicExpectation
org.hibernate.jdbc This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.

Uses of Expectations.BasicExpectation in org.hibernate.jdbc

Subclasses of Expectations.BasicExpectation in org.hibernate.jdbc
static class Expectations.BasicParamExpectation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.Expectations.BasicParamExpectation (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.Expectations.BasicParamExpectation

No usage of org.hibernate.jdbc.Expectations.BasicParamExpectation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.JDBCContext (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.JDBCContext

Packages that use JDBCContext
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.

Uses of JDBCContext in org.hibernate.engine

Methods in org.hibernate.engine that return JDBCContext
 JDBCContext SessionImplementor.getJDBCContext()

Uses of JDBCContext in org.hibernate.impl

Methods in org.hibernate.impl that return JDBCContext
JDBCContext | StatelessSessionImpl.getJDBCContext()
JDBCContext | SessionImpl.getJDBCContext()

Uses of JDBCContext in org.hibernate.jdbc

Methods in org.hibernate.jdbc that return JDBCContext
static JDBCContext JDBCContext.deserialize(ObjectInputStream ois, JDBCContext.Context context, Interceptor interceptor)
Custom deserialization routine used during deserialization of a Session/PersistenceContext for increased performance.

Methods in org.hibernate.jdbc with parameters of type JDBCContext
static ConnectionManager ConnectionManager.deserialize(ObjectInputStream ois, SessionFactoryImplementor factory, Interceptor interceptor, ConnectionReleaseMode connectionReleaseMode, JDBCContext jdbcContext)

Uses of JDBCContext in org.hibernate.transaction

Fields in org.hibernate.transaction declared as JDBCContext
protected  JDBCContext CMTTransaction.jdbcContext

Methods in org.hibernate.transaction with parameters of type JDBCContext
Transaction | TransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context context) Begin a transaction and return the associated Transaction instance.
boolean | TransactionFactory.isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction) Determine whether an underlying transaction is in progress.
Transaction | JTATransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
boolean | JTATransactionFactory.isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction)
Transaction | JDBCTransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
boolean | JDBCTransactionFactory.isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction)
Transaction | CMTTransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
boolean | CMTTransactionFactory.isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction)

Constructors in org.hibernate.transaction with parameters of type JDBCContext
JTATransaction(InitialContext context, String utName, JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
JDBCTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
CMTTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
CacheSynchronization(TransactionFactory.Context ctx, JDBCContext jdbcContext, Transaction transaction, Transaction tx)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.jdbc.JDBCContext.Context (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.jdbc.JDBCContext.Context

Packages that use JDBCContext.Context
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.

Uses of JDBCContext.Context in org.hibernate.impl

Classes in org.hibernate.impl that implement JDBCContext.Context
class | SessionImpl Concrete implementation of a Session, and also the central, organizing component of Hibernate's internal implementation.
class | StatelessSessionImpl

Uses of JDBCContext.Context in org.hibernate.jdbc

Methods in org.hibernate.jdbc with parameters of type JDBCContext.Context
static JDBCContext JDBCContext.deserialize(ObjectInputStream ois, JDBCContext.Context context, Interceptor interceptor)
Custom deserialization routine used during deserialization of a Session/PersistenceContext for increased performance.

Constructors in org.hibernate.jdbc with parameters of type JDBCContext.Context
JDBCContext(JDBCContext.Context owner, Connection connection, Interceptor interceptor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.NonBatchingBatcher (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.NonBatchingBatcher

No usage of org.hibernate.jdbc.NonBatchingBatcher

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.NonBatchingBatcherFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.NonBatchingBatcherFactory

No usage of org.hibernate.jdbc.NonBatchingBatcherFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.ResultSetWrapper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.ResultSetWrapper

Packages that use ResultSetWrapper
org.hibernate.jdbc This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.

Uses of ResultSetWrapper in org.hibernate.jdbc

Methods in org.hibernate.jdbc with parameters of type ResultSetWrapper
 int ColumnNameCache.getIndexForColumnName(String columnName, ResultSetWrapper rs)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jdbc.TooManyRowsAffectedException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jdbc.TooManyRowsAffectedException

Packages that use TooManyRowsAffectedException
org.hibernate.jdbc This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.

Uses of TooManyRowsAffectedException in org.hibernate.jdbc

Subclasses of TooManyRowsAffectedException in org.hibernate.jdbc
 class BatchedTooManyRowsAffectedException
Much like TooManyRowsAffectedException, indicates that more rows than what we were expcecting were affected.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.jmx (Hibernate API Documentation)

 org.hibernate.jmx
Interfaces
HibernateServiceMBean
StatisticsServiceMBean
Classes
HibernateService
SessionFactoryStub
StatisticsService


Uses of Class org.hibernate.jmx.HibernateService (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jmx.HibernateService

No usage of org.hibernate.jmx.HibernateService

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.jmx.HibernateServiceMBean (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.jmx.HibernateServiceMBean

Packages that use HibernateServiceMBean
org.hibernate.jmx This package exposes a Hibernate instance via JMX.

Uses of HibernateServiceMBean in org.hibernate.jmx

Classes in org.hibernate.jmx that implement HibernateServiceMBean
 class HibernateService
Implementation of HibernateServiceMBean.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jmx.SessionFactoryStub (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jmx.SessionFactoryStub

No usage of org.hibernate.jmx.SessionFactoryStub

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.jmx.StatisticsService (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.jmx.StatisticsService

No usage of org.hibernate.jmx.StatisticsService

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.jmx.StatisticsServiceMBean (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.jmx.StatisticsServiceMBean

Packages that use StatisticsServiceMBean
org.hibernate.jmx This package exposes a Hibernate instance via JMX.

Uses of StatisticsServiceMBean in org.hibernate.jmx

Classes in org.hibernate.jmx that implement StatisticsServiceMBean
 class StatisticsService
JMX service for Hibernate statistics

Register this MBean in your JMX server for a specific session factory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.loader (Hibernate API Documentation)

 org.hibernate.loader
Interfaces
CollectionAliases
EntityAliases
Classes
AbstractEntityJoinWalker
BasicLoader
ColumnEntityAliases
DefaultEntityAliases
GeneratedCollectionAliases
JoinWalker
Loader
OuterJoinableAssociation
OuterJoinLoader


Uses of Class org.hibernate.loader.AbstractEntityJoinWalker (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.AbstractEntityJoinWalker

Packages that use AbstractEntityJoinWalker
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.entity | This package defines entity loaders

Uses of AbstractEntityJoinWalker in org.hibernate.loader.criteria

Subclasses of AbstractEntityJoinWalker in org.hibernate.loader.criteria
 class CriteriaJoinWalker
A JoinWalker for Criteria queries.

Uses of AbstractEntityJoinWalker in org.hibernate.loader.entity

Subclasses of AbstractEntityJoinWalker in org.hibernate.loader.entity
class | CascadeEntityJoinWalker
class | EntityJoinWalker A walker for loaders that fetch entities

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.BasicLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.BasicLoader

Packages that use BasicLoader
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser

Uses of BasicLoader in org.hibernate.hql.classic

Subclasses of BasicLoader in org.hibernate.hql.classic
 class QueryTranslatorImpl
An instance of QueryTranslator translates a Hibernate query string to SQL.

Uses of BasicLoader in org.hibernate.loader

Subclasses of BasicLoader in org.hibernate.loader
 class OuterJoinLoader
Implements logic for walking a tree of associated classes.

Uses of BasicLoader in org.hibernate.loader.collection

Subclasses of BasicLoader in org.hibernate.loader.collection
class | BasicCollectionLoader Loads a collection of values or a many-to-many association.
class | CollectionLoader Superclass for loaders that initialize collections
class | OneToManyLoader Loads one-to-many associations The collection persister must implement QueryableCOllection.
class | SubselectCollectionLoader Implements subselect fetching for a collection
class | SubselectOneToManyLoader Implements subselect fetching for a one to many association

Uses of BasicLoader in org.hibernate.loader.criteria

Subclasses of BasicLoader in org.hibernate.loader.criteria
 class CriteriaLoader
A Loader for Criteria queries.

Uses of BasicLoader in org.hibernate.loader.entity

Subclasses of BasicLoader in org.hibernate.loader.entity
class | AbstractEntityLoader
class | CascadeEntityLoader
class | CollectionElementLoader
class | EntityLoader Loads an entity instance using outerjoin fetching to fetch associated entities.

Uses of BasicLoader in org.hibernate.loader.hql

Subclasses of BasicLoader in org.hibernate.loader.hql
 class QueryLoader
A delegate that implements the Loader part of QueryTranslator.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.loader.CollectionAliases (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.loader.CollectionAliases

Packages that use CollectionAliases
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL

Uses of CollectionAliases in org.hibernate.collection

Methods in org.hibernate.collection with parameters of type CollectionAliases
Object | PersistentSet.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Object | PersistentMap.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Object | PersistentList.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Object | PersistentIndexedElementHolder.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Object | PersistentIdentifierBag.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Object | PersistentElementHolder.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Object | PersistentCollection.readFrom(ResultSet rs, CollectionPersister role, CollectionAliases descriptor, Object owner) Read a row from the JDBC result set
Object | PersistentBag.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Object | PersistentArrayHolder.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)

Uses of CollectionAliases in org.hibernate.loader

Classes in org.hibernate.loader that implement CollectionAliases
 class GeneratedCollectionAliases
CollectionAliases which handles the logic of selecting user provided aliases (via return-property), before using the default aliases.

Methods in org.hibernate.loader that return CollectionAliases
protected abstract CollectionAliases[] | Loader.getCollectionAliases()
protected CollectionAliases[] | BasicLoader.getCollectionAliases()

Uses of CollectionAliases in org.hibernate.loader.custom

Classes in org.hibernate.loader.custom that implement CollectionAliases
 class ColumnCollectionAliases
CollectionAliases that uses columnnames instead of generated aliases.

Methods in org.hibernate.loader.custom that return CollectionAliases
protected CollectionAliases[] | CustomLoader.getCollectionAliases()
CollectionAliases | CollectionReturn.getCollectionAliases()
CollectionAliases | CollectionFetchReturn.getCollectionAliases()

Constructors in org.hibernate.loader.custom with parameters of type CollectionAliases
CollectionReturn(String alias, String ownerEntityName, String ownerProperty, CollectionAliases collectionAliases, EntityAliases elementEntityAliases, LockMode lockMode)
CollectionFetchReturn(String alias, NonScalarReturn owner, String ownerProperty, CollectionAliases collectionAliases, EntityAliases elementEntityAliases, LockMode lockMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.ColumnEntityAliases (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.ColumnEntityAliases

No usage of org.hibernate.loader.ColumnEntityAliases

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.DefaultEntityAliases (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.DefaultEntityAliases

Packages that use DefaultEntityAliases
org.hibernate.loader This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.

Uses of DefaultEntityAliases in org.hibernate.loader

Subclasses of DefaultEntityAliases in org.hibernate.loader
 class ColumnEntityAliases
EntityAliases that chooses the column names over the alias names.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.loader.EntityAliases (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.loader.EntityAliases

Packages that use EntityAliases
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL

Uses of EntityAliases in org.hibernate.loader

Classes in org.hibernate.loader that implement EntityAliases
class | ColumnEntityAliases EntityAliases that chooses the column names over the alias names.
class | DefaultEntityAliases EntityAliases which handles the logic of selecting user provided aliases (via return-property), before using the default aliases.

Methods in org.hibernate.loader that return EntityAliases
protected abstract EntityAliases[] | Loader.getEntityAliases() Get the result set descriptor
protected EntityAliases[] | BasicLoader.getEntityAliases()

Uses of EntityAliases in org.hibernate.loader.custom

Methods in org.hibernate.loader.custom that return EntityAliases
EntityAliases | RootReturn.getEntityAliases()
EntityAliases | EntityFetchReturn.getEntityAliases()
protected EntityAliases[] | CustomLoader.getEntityAliases()
EntityAliases | CollectionReturn.getElementEntityAliases()
EntityAliases | CollectionFetchReturn.getElementEntityAliases()

Constructors in org.hibernate.loader.custom with parameters of type EntityAliases
RootReturn(String alias, String entityName, EntityAliases entityAliases, LockMode lockMode)
EntityFetchReturn(String alias, EntityAliases entityAliases, NonScalarReturn owner, String ownerProperty, LockMode lockMode)
CollectionReturn(String alias, String ownerEntityName, String ownerProperty, CollectionAliases collectionAliases, EntityAliases elementEntityAliases, LockMode lockMode)
CollectionFetchReturn(String alias, NonScalarReturn owner, String ownerProperty, CollectionAliases collectionAliases, EntityAliases elementEntityAliases, LockMode lockMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.GeneratedCollectionAliases (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.GeneratedCollectionAliases

No usage of org.hibernate.loader.GeneratedCollectionAliases

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.JoinWalker (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.JoinWalker

Packages that use JoinWalker
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.entity | This package defines entity loaders

Uses of JoinWalker in org.hibernate.loader

Subclasses of JoinWalker in org.hibernate.loader
 class AbstractEntityJoinWalker
Abstract walker for walkers which begin at an entity (criteria queries and entity loaders).

Methods in org.hibernate.loader with parameters of type JoinWalker
protected  void OuterJoinLoader.initFromWalker(JoinWalker walker)

Uses of JoinWalker in org.hibernate.loader.collection

Subclasses of JoinWalker in org.hibernate.loader.collection
class | BasicCollectionJoinWalker Walker for collections of values and many-to-many associations
class | CollectionJoinWalker Superclass of walkers for collection initializers
class | OneToManyJoinWalker Walker for one-to-many associations

Uses of JoinWalker in org.hibernate.loader.criteria

Subclasses of JoinWalker in org.hibernate.loader.criteria
 class CriteriaJoinWalker
A JoinWalker for Criteria queries.

Uses of JoinWalker in org.hibernate.loader.entity

Subclasses of JoinWalker in org.hibernate.loader.entity
class | CascadeEntityJoinWalker
class | EntityJoinWalker A walker for loaders that fetch entities

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.Loader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.Loader

Packages that use Loader
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser

Uses of Loader in org.hibernate.hql.classic

Subclasses of Loader in org.hibernate.hql.classic
 class QueryTranslatorImpl
An instance of QueryTranslator translates a Hibernate query string to SQL.

Uses of Loader in org.hibernate.impl

Methods in org.hibernate.impl that return Loader
protected  Loader AbstractScrollableResults.getLoader()

Constructors in org.hibernate.impl with parameters of type Loader
ScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
FetchingScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
AbstractScrollableResults(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)

Uses of Loader in org.hibernate.loader

Subclasses of Loader in org.hibernate.loader
class | BasicLoader Uses the default mapping from property to result set column alias defined by the entities' persisters.
class | OuterJoinLoader Implements logic for walking a tree of associated classes.

Uses of Loader in org.hibernate.loader.collection

Subclasses of Loader in org.hibernate.loader.collection
class | BasicCollectionLoader Loads a collection of values or a many-to-many association.
class | CollectionLoader Superclass for loaders that initialize collections
class | OneToManyLoader Loads one-to-many associations The collection persister must implement QueryableCOllection.
class | SubselectCollectionLoader Implements subselect fetching for a collection
class | SubselectOneToManyLoader Implements subselect fetching for a one to many association

Constructors in org.hibernate.loader.collection with parameters of type Loader
BatchingCollectionInitializer(CollectionPersister collPersister, int[] batchSizes, Loader[] loaders)

Uses of Loader in org.hibernate.loader.criteria

Subclasses of Loader in org.hibernate.loader.criteria
 class CriteriaLoader
A Loader for Criteria queries.

Uses of Loader in org.hibernate.loader.custom

Subclasses of Loader in org.hibernate.loader.custom
 class CustomLoader
Extension point for loaders which use a SQL result set with "unexpected" column aliases.

Uses of Loader in org.hibernate.loader.entity

Subclasses of Loader in org.hibernate.loader.entity
class | AbstractEntityLoader
class | CascadeEntityLoader
class | CollectionElementLoader
class | EntityLoader Loads an entity instance using outerjoin fetching to fetch associated entities.

Constructors in org.hibernate.loader.entity with parameters of type Loader
BatchingEntityLoader(EntityPersister persister, int[] batchSizes, Loader[] loaders)

Uses of Loader in org.hibernate.loader.hql

Subclasses of Loader in org.hibernate.loader.hql
 class QueryLoader
A delegate that implements the Loader part of QueryTranslator.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.OuterJoinableAssociation (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.OuterJoinableAssociation

Packages that use OuterJoinableAssociation
org.hibernate.loader This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.

Uses of OuterJoinableAssociation in org.hibernate.loader

Methods in org.hibernate.loader with parameters of type OuterJoinableAssociation
 boolean OuterJoinableAssociation.isManyToManyWith(OuterJoinableAssociation other)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.OuterJoinLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.OuterJoinLoader

Packages that use OuterJoinLoader
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.entity | This package defines entity loaders

Uses of OuterJoinLoader in org.hibernate.loader.collection

Subclasses of OuterJoinLoader in org.hibernate.loader.collection
class | BasicCollectionLoader Loads a collection of values or a many-to-many association.
class | CollectionLoader Superclass for loaders that initialize collections
class | OneToManyLoader Loads one-to-many associations The collection persister must implement QueryableCOllection.
class | SubselectCollectionLoader Implements subselect fetching for a collection
class | SubselectOneToManyLoader Implements subselect fetching for a one to many association

Uses of OuterJoinLoader in org.hibernate.loader.criteria

Subclasses of OuterJoinLoader in org.hibernate.loader.criteria
 class CriteriaLoader
A Loader for Criteria queries.

Uses of OuterJoinLoader in org.hibernate.loader.entity

Subclasses of OuterJoinLoader in org.hibernate.loader.entity
class | AbstractEntityLoader
class | CascadeEntityLoader
class | CollectionElementLoader
class | EntityLoader Loads an entity instance using outerjoin fetching to fetch associated entities.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.loader.collection (Hibernate API Documentation)

 org.hibernate.loader.collection
Interfaces
CollectionInitializer
Classes
BasicCollectionJoinWalker
BasicCollectionLoader
BatchingCollectionInitializer
CollectionJoinWalker
CollectionLoader
OneToManyJoinWalker
OneToManyLoader
SubselectCollectionLoader
SubselectOneToManyLoader


Uses of Class org.hibernate.loader.collection.BasicCollectionJoinWalker (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.collection.BasicCollectionJoinWalker

No usage of org.hibernate.loader.collection.BasicCollectionJoinWalker

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.collection.BasicCollectionLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.collection.BasicCollectionLoader

Packages that use BasicCollectionLoader
org.hibernate.loader.collection This package defines collection initializers

Uses of BasicCollectionLoader in org.hibernate.loader.collection

Subclasses of BasicCollectionLoader in org.hibernate.loader.collection
 class SubselectCollectionLoader
Implements subselect fetching for a collection

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.collection.BatchingCollectionInitializer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.collection.BatchingCollectionInitializer

No usage of org.hibernate.loader.collection.BatchingCollectionInitializer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.loader.collection.CollectionInitializer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.loader.collection.CollectionInitializer

Packages that use CollectionInitializer
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.

Uses of CollectionInitializer in org.hibernate.loader.collection

Classes in org.hibernate.loader.collection that implement CollectionInitializer
class | BasicCollectionLoader Loads a collection of values or a many-to-many association.
class | BatchingCollectionInitializer "Batch" loads collections, using multiple foreign key values in the SQL where clause.
class | CollectionLoader Superclass for loaders that initialize collections
class | OneToManyLoader Loads one-to-many associations The collection persister must implement QueryableCOllection.
class | SubselectCollectionLoader Implements subselect fetching for a collection
class | SubselectOneToManyLoader Implements subselect fetching for a one to many association

Methods in org.hibernate.loader.collection that return CollectionInitializer
static CollectionInitializer | BatchingCollectionInitializer.createBatchingOneToManyInitializer(QueryableCollection persister, int maxBatchSize, SessionFactoryImplementor factory, Map enabledFilters)
static CollectionInitializer | BatchingCollectionInitializer.createBatchingCollectionInitializer(QueryableCollection persister, int maxBatchSize, SessionFactoryImplementor factory, Map enabledFilters)

Uses of CollectionInitializer in org.hibernate.persister.collection

Classes in org.hibernate.persister.collection that implement CollectionInitializer
 class NamedQueryCollectionInitializer
A wrapper around a named query.

Methods in org.hibernate.persister.collection that return CollectionInitializer
protected CollectionInitializer | OneToManyPersister.createCollectionInitializer(Map enabledFilters) Create the OneToManyLoader
protected CollectionInitializer | OneToManyPersister.createSubselectInitializer(SubselectFetch subselect, SessionImplementor session)
protected CollectionInitializer | BasicCollectionPersister.createCollectionInitializer(Map enabledFilters) Create the CollectionLoader
protected CollectionInitializer | BasicCollectionPersister.createSubselectInitializer(SubselectFetch subselect, SessionImplementor session)
protected CollectionInitializer | AbstractCollectionPersister.getAppropriateInitializer(Serializable key, SessionImplementor session)
protected abstract CollectionInitializer | AbstractCollectionPersister.createSubselectInitializer(SubselectFetch subselect, SessionImplementor session)
protected abstract CollectionInitializer | AbstractCollectionPersister.createCollectionInitializer(Map enabledFilters)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.collection.CollectionJoinWalker (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.collection.CollectionJoinWalker

Packages that use CollectionJoinWalker
org.hibernate.loader.collection This package defines collection initializers

Uses of CollectionJoinWalker in org.hibernate.loader.collection

Subclasses of CollectionJoinWalker in org.hibernate.loader.collection
class | BasicCollectionJoinWalker Walker for collections of values and many-to-many associations
class | OneToManyJoinWalker Walker for one-to-many associations

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.collection.CollectionLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.collection.CollectionLoader

Packages that use CollectionLoader
org.hibernate.loader.collection This package defines collection initializers

Uses of CollectionLoader in org.hibernate.loader.collection

Subclasses of CollectionLoader in org.hibernate.loader.collection
class | BasicCollectionLoader Loads a collection of values or a many-to-many association.
class | OneToManyLoader Loads one-to-many associations The collection persister must implement QueryableCOllection.
class | SubselectCollectionLoader Implements subselect fetching for a collection
class | SubselectOneToManyLoader Implements subselect fetching for a one to many association

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.collection.OneToManyJoinWalker (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.collection.OneToManyJoinWalker

No usage of org.hibernate.loader.collection.OneToManyJoinWalker

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.collection.OneToManyLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.collection.OneToManyLoader

Packages that use OneToManyLoader
org.hibernate.loader.collection This package defines collection initializers

Uses of OneToManyLoader in org.hibernate.loader.collection

Subclasses of OneToManyLoader in org.hibernate.loader.collection
 class SubselectOneToManyLoader
Implements subselect fetching for a one to many association

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.collection.SubselectCollectionLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.collection.SubselectCollectionLoader

No usage of org.hibernate.loader.collection.SubselectCollectionLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.collection.SubselectOneToManyLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.collection.SubselectOneToManyLoader

No usage of org.hibernate.loader.collection.SubselectOneToManyLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.loader.criteria (Hibernate API Documentation)

 org.hibernate.loader.criteria
Classes
CriteriaJoinWalker
CriteriaLoader
CriteriaQueryTranslator


Uses of Class org.hibernate.loader.criteria.CriteriaJoinWalker (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.criteria.CriteriaJoinWalker

No usage of org.hibernate.loader.criteria.CriteriaJoinWalker

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.criteria.CriteriaLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.criteria.CriteriaLoader

No usage of org.hibernate.loader.criteria.CriteriaLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.criteria.CriteriaQueryTranslator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.criteria.CriteriaQueryTranslator

Packages that use CriteriaQueryTranslator
org.hibernate.loader.criteria This package defines the criteria query compiler and loader

Uses of CriteriaQueryTranslator in org.hibernate.loader.criteria

Constructors in org.hibernate.loader.criteria with parameters of type CriteriaQueryTranslator
CriteriaJoinWalker(OuterJoinLoadable persister, CriteriaQueryTranslator translator, SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, Map enabledFilters)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.loader.custom (Hibernate API Documentation)

 org.hibernate.loader.custom
Interfaces
CustomQuery
Return
Classes
CollectionFetchReturn
CollectionReturn
ColumnCollectionAliases
CustomLoader
EntityFetchReturn
FetchReturn
NonScalarReturn
RootReturn
ScalarReturn


Uses of Class org.hibernate.loader.custom.CollectionFetchReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.CollectionFetchReturn

No usage of org.hibernate.loader.custom.CollectionFetchReturn

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.CollectionReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.CollectionReturn

No usage of org.hibernate.loader.custom.CollectionReturn

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.ColumnCollectionAliases (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.ColumnCollectionAliases

No usage of org.hibernate.loader.custom.ColumnCollectionAliases

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.CustomLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.CustomLoader

No usage of org.hibernate.loader.custom.CustomLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.CustomLoader.NonScalarResultColumnProcessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.CustomLoader.NonScalarResultColumnProcessor

No usage of org.hibernate.loader.custom.CustomLoader.NonScalarResultColumnProcessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.CustomLoader.ResultRowProcessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.CustomLoader.ResultRowProcessor

No usage of org.hibernate.loader.custom.CustomLoader.ResultRowProcessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.CustomLoader.ScalarResultColumnProcessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.CustomLoader.ScalarResultColumnProcessor

No usage of org.hibernate.loader.custom.CustomLoader.ScalarResultColumnProcessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.loader.custom.CustomQuery (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.loader.custom.CustomQuery

Packages that use CustomQuery
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.custom.sql |

Uses of CustomQuery in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type CustomQuery
List | SessionImplementor.listCustomQuery(CustomQuery customQuery, QueryParameters queryParameters) Execute an SQL Query
ScrollableResults | SessionImplementor.scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters) Execute an SQL Query

Uses of CustomQuery in org.hibernate.impl

Methods in org.hibernate.impl with parameters of type CustomQuery
List | StatelessSessionImpl.listCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
ScrollableResults | StatelessSessionImpl.scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
ScrollableResults | SessionImpl.scrollCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)
List | SessionImpl.listCustomQuery(CustomQuery customQuery, QueryParameters queryParameters)

Uses of CustomQuery in org.hibernate.loader.custom

Constructors in org.hibernate.loader.custom with parameters of type CustomQuery
CustomLoader(CustomQuery customQuery, SessionFactoryImplementor factory)

Uses of CustomQuery in org.hibernate.loader.custom.sql

Classes in org.hibernate.loader.custom.sql that implement CustomQuery
 class SQLCustomQuery
Implements Hibernate's built-in support for native SQL queries.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.EntityFetchReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.EntityFetchReturn

No usage of org.hibernate.loader.custom.EntityFetchReturn

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.FetchReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.FetchReturn

Packages that use FetchReturn
org.hibernate.loader.custom This package defines a framework for custom loaders that accept handwritten SQL

Uses of FetchReturn in org.hibernate.loader.custom

Subclasses of FetchReturn in org.hibernate.loader.custom
class | CollectionFetchReturn Spefically a fetch return that refers to a collection association.
class | EntityFetchReturn Spefically a fetch return that refers to an entity association.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.NonScalarReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.NonScalarReturn

Packages that use NonScalarReturn
org.hibernate.loader.custom This package defines a framework for custom loaders that accept handwritten SQL

Uses of NonScalarReturn in org.hibernate.loader.custom

Subclasses of NonScalarReturn in org.hibernate.loader.custom
class | CollectionFetchReturn Spefically a fetch return that refers to a collection association.
class | CollectionReturn Represents a return which names a collection role; it is used in defining a custom query for loading an entity's collection in non-fetching scenarios (i.e., loading the collection itself as the "root" of the result).
class | EntityFetchReturn Spefically a fetch return that refers to an entity association.
class | FetchReturn Represents a return which names a fetched association.
class | RootReturn Represents a return which names a "root" entity.

Methods in org.hibernate.loader.custom that return NonScalarReturn
 NonScalarReturn FetchReturn.getOwner()
Retrieves the return descriptor for the owner of this fetch.

Constructors in org.hibernate.loader.custom with parameters of type NonScalarReturn
FetchReturn(NonScalarReturn owner, String ownerProperty, String alias, LockMode lockMode)
Creates a return descriptor for an association fetch.
EntityFetchReturn(String alias, EntityAliases entityAliases, NonScalarReturn owner, String ownerProperty, LockMode lockMode)
CollectionFetchReturn(String alias, NonScalarReturn owner, String ownerProperty, CollectionAliases collectionAliases, EntityAliases elementEntityAliases, LockMode lockMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.loader.custom.Return (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.loader.custom.Return

Packages that use Return
org.hibernate.loader.custom This package defines a framework for custom loaders that accept handwritten SQL

Uses of Return in org.hibernate.loader.custom

Classes in org.hibernate.loader.custom that implement Return
class | CollectionFetchReturn Spefically a fetch return that refers to a collection association.
class | CollectionReturn Represents a return which names a collection role; it is used in defining a custom query for loading an entity's collection in non-fetching scenarios (i.e., loading the collection itself as the "root" of the result).
class | EntityFetchReturn Spefically a fetch return that refers to an entity association.
class | FetchReturn Represents a return which names a fetched association.
class | NonScalarReturn Represents some non-scalar (entity/collection) return within the query result.
class | RootReturn Represents a return which names a "root" entity.
class | ScalarReturn Represent a scalar (aka simple value) return within a query result.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.RootReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.RootReturn

No usage of org.hibernate.loader.custom.RootReturn

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.ScalarReturn (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.ScalarReturn

No usage of org.hibernate.loader.custom.ScalarReturn

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.loader.custom.sql (Hibernate API Documentation)

 org.hibernate.loader.custom.sql
Classes
SQLCustomQuery
SQLQueryParser
SQLQueryParser.ParameterSubstitutionRecognizer
SQLQueryReturnProcessor


Uses of Class org.hibernate.loader.custom.sql.SQLCustomQuery (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.sql.SQLCustomQuery

Packages that use SQLCustomQuery
org.hibernate.engine.query

Uses of SQLCustomQuery in org.hibernate.engine.query

Methods in org.hibernate.engine.query that return SQLCustomQuery
 SQLCustomQuery NativeSQLQueryPlan.getCustomQuery()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.sql.SQLQueryParser (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.sql.SQLQueryParser

No usage of org.hibernate.loader.custom.sql.SQLQueryParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer

No usage of org.hibernate.loader.custom.sql.SQLQueryParser.ParameterSubstitutionRecognizer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.custom.sql.SQLQueryReturnProcessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.custom.sql.SQLQueryReturnProcessor

No usage of org.hibernate.loader.custom.sql.SQLQueryReturnProcessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.loader.entity (Hibernate API Documentation)

 org.hibernate.loader.entity
Interfaces
UniqueEntityLoader
Classes
AbstractEntityLoader
BatchingEntityLoader
CascadeEntityJoinWalker
CascadeEntityLoader
CollectionElementLoader
EntityJoinWalker
EntityLoader


Uses of Class org.hibernate.loader.entity.AbstractEntityLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.entity.AbstractEntityLoader

Packages that use AbstractEntityLoader
org.hibernate.loader.entity This package defines entity loaders

Uses of AbstractEntityLoader in org.hibernate.loader.entity

Subclasses of AbstractEntityLoader in org.hibernate.loader.entity
class | CascadeEntityLoader
class | EntityLoader Loads an entity instance using outerjoin fetching to fetch associated entities.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.entity.BatchingEntityLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.entity.BatchingEntityLoader

No usage of org.hibernate.loader.entity.BatchingEntityLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.entity.CascadeEntityJoinWalker (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.entity.CascadeEntityJoinWalker

No usage of org.hibernate.loader.entity.CascadeEntityJoinWalker

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.entity.CascadeEntityLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.entity.CascadeEntityLoader

No usage of org.hibernate.loader.entity.CascadeEntityLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.entity.CollectionElementLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.entity.CollectionElementLoader

No usage of org.hibernate.loader.entity.CollectionElementLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.entity.EntityJoinWalker (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.entity.EntityJoinWalker

No usage of org.hibernate.loader.entity.EntityJoinWalker

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.loader.entity.EntityLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.entity.EntityLoader

No usage of org.hibernate.loader.entity.EntityLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.loader.entity.UniqueEntityLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.loader.entity.UniqueEntityLoader

Packages that use UniqueEntityLoader
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of UniqueEntityLoader in org.hibernate.loader.entity

Classes in org.hibernate.loader.entity that implement UniqueEntityLoader
class | AbstractEntityLoader
class | BatchingEntityLoader "Batch" loads entities, using multiple primary key values in the SQL where clause.
class | CascadeEntityLoader
class | EntityLoader Loads an entity instance using outerjoin fetching to fetch associated entities.

Methods in org.hibernate.loader.entity that return UniqueEntityLoader
static UniqueEntityLoader BatchingEntityLoader.createBatchingEntityLoader(OuterJoinLoadable persister, int maxBatchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)

Uses of UniqueEntityLoader in org.hibernate.persister.entity

Classes in org.hibernate.persister.entity that implement UniqueEntityLoader
 class NamedQueryLoader
Not really a Loader, just a wrapper around a named query.

Methods in org.hibernate.persister.entity that return UniqueEntityLoader
protected UniqueEntityLoader | AbstractEntityPersister.createEntityLoader(LockMode lockMode, Map enabledFilters)
protected UniqueEntityLoader | AbstractEntityPersister.createEntityLoader(LockMode lockMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.loader.hql (Hibernate API Documentation)

 org.hibernate.loader.hql
Classes
QueryLoader


Uses of Class org.hibernate.loader.hql.QueryLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.loader.hql.QueryLoader

No usage of org.hibernate.loader.hql.QueryLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.lob (Hibernate API Documentation)

 org.hibernate.lob
Classes
BlobImpl
ClobImpl
ReaderInputStream
SerializableBlob
SerializableClob


Uses of Class org.hibernate.lob.BlobImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.lob.BlobImpl

No usage of org.hibernate.lob.BlobImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.lob.ClobImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.lob.ClobImpl

No usage of org.hibernate.lob.ClobImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.lob.ReaderInputStream (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.lob.ReaderInputStream

No usage of org.hibernate.lob.ReaderInputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.lob.SerializableBlob (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.lob.SerializableBlob

No usage of org.hibernate.lob.SerializableBlob

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.lob.SerializableClob (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.lob.SerializableClob

No usage of org.hibernate.lob.SerializableClob

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.mapping (Hibernate API Documentation)

 org.hibernate.mapping
Interfaces
AuxiliaryDatabaseObject
Fetchable
Filterable
KeyValue
MetaAttributable
PersistentClassVisitor
RelationalModel
Selectable
TableOwner
Value
ValueVisitor
Classes
AbstractAuxiliaryDatabaseObject
Any
Array
Backref
Bag
Collection
Column
Component
Constraint
DenormalizedTable
DependantValue
ForeignKey
Formula
IdentifierBag
IdentifierCollection
Index
IndexBackref
IndexedCollection
Join
JoinedSubclass
List
ManyToOne
Map
MetaAttribute
OneToMany
OneToOne
PersistentClass
PrimaryKey
PrimitiveArray
Property
PropertyGeneration
RootClass
Set
SimpleAuxiliaryDatabaseObject
SimpleValue
SingleTableSubclass
Subclass
Table
ToOne
TypeDef
UnionSubclass
UniqueKey


Uses of Class org.hibernate.mapping.AbstractAuxiliaryDatabaseObject (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.AbstractAuxiliaryDatabaseObject

Packages that use AbstractAuxiliaryDatabaseObject
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of AbstractAuxiliaryDatabaseObject in org.hibernate.mapping

Subclasses of AbstractAuxiliaryDatabaseObject in org.hibernate.mapping
 class SimpleAuxiliaryDatabaseObject
A simple implementation of AbstractAuxiliaryDatabaseObject in which the CREATE and DROP strings are provided up front.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Any (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Any

Packages that use Any
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of Any in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type Any
static void HbmBinder.bindAny(org.dom4j.Element node, Any any, boolean isNullable, Mappings mappings)

Uses of Any in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type Any
 Object ValueVisitor.accept(Any any)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Array (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Array

Packages that use Array
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of Array in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type Array
static void HbmBinder.bindArray(org.dom4j.Element node, Array array, String prefix, String path, Mappings mappings, Map inheritedMetas)
Called for arrays and primitive arrays

Uses of Array in org.hibernate.mapping

Subclasses of Array in org.hibernate.mapping
 class PrimitiveArray
A primitive array has a primary key consisting of the key columns + index column.

Methods in org.hibernate.mapping with parameters of type Array
 Object ValueVisitor.accept(Array list)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.mapping.AuxiliaryDatabaseObject (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.mapping.AuxiliaryDatabaseObject

Packages that use AuxiliaryDatabaseObject
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of AuxiliaryDatabaseObject in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type AuxiliaryDatabaseObject
void | Mappings.addAuxiliaryDatabaseObject(AuxiliaryDatabaseObject auxiliaryDatabaseObject)
void | Configuration.addAuxiliaryDatabaseObject(AuxiliaryDatabaseObject object)

Uses of AuxiliaryDatabaseObject in org.hibernate.mapping

Classes in org.hibernate.mapping that implement AuxiliaryDatabaseObject
class | AbstractAuxiliaryDatabaseObject Convenience base class for AuxiliaryDatabaseObjects.
class | SimpleAuxiliaryDatabaseObject A simple implementation of AbstractAuxiliaryDatabaseObject in which the CREATE and DROP strings are provided up front.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Backref (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Backref

No usage of org.hibernate.mapping.Backref

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Bag (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Bag

Packages that use Bag
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of Bag in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type Bag
 Object ValueVisitor.accept(Bag bag)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Collection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Collection

Packages that use Collection
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.

Uses of Collection in org.hibernate.cfg

Methods in org.hibernate.cfg that return Collection
Collection | Mappings.getCollection(String role)
Collection | Configuration.getCollectionMapping(String role) Get the mapping for a particular collection role

Methods in org.hibernate.cfg with parameters of type Collection
void | Mappings.addCollection(Collection collection)
static void | HbmBinder.bindCollection(org.dom4j.Element node, Collection collection, String className, String path, Mappings mappings, Map inheritedMetas) Called for all collections
static void | HbmBinder.bindCollectionSecondPass(org.dom4j.Element node, Collection collection, Map persistentClasses, Mappings mappings, Map inheritedMetas) Called for all collections

Constructors in org.hibernate.cfg with parameters of type Collection
CollectionSecondPass(Mappings mappings, Collection collection, Map inheritedMetas)
CollectionSecondPass(Mappings mappings, Collection collection)

Uses of Collection in org.hibernate.mapping

Subclasses of Collection in org.hibernate.mapping
class | Array An array mapping has a primary key consisting of the key columns + index column.
class | Bag A bag permits duplicates, so it has no primary key
class | IdentifierBag An IdentifierBag has a primary key consisting of just the identifier column
class | IdentifierCollection A collection with a synthetic "identifier" column
class | IndexedCollection Indexed collections include Lists, Maps, arrays and primitive arrays.
class | List A list mapping has a primary key consisting of the key columns + index column.
class | Map A map has a primary key consisting of the key columns + index columns.
class | PrimitiveArray A primitive array has a primary key consisting of the key columns + index column.
class | Set A set with no nullable element columns.

Constructors in org.hibernate.mapping with parameters of type Collection
Component(Collection collection)

Uses of Collection in org.hibernate.persister

Methods in org.hibernate.persister with parameters of type Collection
static CollectionPersister PersisterFactory.createCollectionPersister(Configuration cfg, Collection model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory)

Uses of Collection in org.hibernate.persister.collection

Constructors in org.hibernate.persister.collection with parameters of type Collection
OneToManyPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
BasicCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)
AbstractCollectionPersister(Collection collection, CacheConcurrencyStrategy cache, Configuration cfg, SessionFactoryImplementor factory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Column (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Column

Packages that use Column
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of Column in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type Column
void | Mappings.addColumnBinding(String logicalName, Column finalColumn, Table table)
static void | HbmBinder.bindColumn(org.dom4j.Element node, Column column, boolean isNullable)

Uses of Column in org.hibernate.mapping

Methods in org.hibernate.mapping that return Column
Column | Table.getColumn(Column column) Return the column which is identified by column provided as argument.
Column | Table.getColumn(int n)
Column | Constraint.getColumn(int i)

Methods in org.hibernate.mapping with parameters of type Column
Column | Table.getColumn(Column column) Return the column which is identified by column provided as argument.
void | Table.addColumn(Column column)
boolean | Table.containsColumn(Column column)
void | SimpleValue.addColumn(Column column)
void | Index.addColumn(Column column)
boolean | Index.containsColumn(Column column)
boolean | DenormalizedTable.containsColumn(Column column)
void | Constraint.addColumn(Column column)
boolean | Constraint.containsColumn(Column column)
void | Component.addColumn(Column column)
boolean | Column.equals(Column column)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Component (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Component

Packages that use Component
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.component |

Uses of Component in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type Component
static void | HbmBinder.bindComposite(org.dom4j.Element node, Component component, String path, boolean isNullable, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindCompositeId(org.dom4j.Element node, Component component, PersistentClass persistentClass, String propertyName, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindComponent(org.dom4j.Element node, Component component, String ownerClassName, String parentProperty, String path, boolean isNullable, boolean isEmbedded, Mappings mappings, Map inheritedMetas, boolean isIdentifierMapper)

Uses of Component in org.hibernate.mapping

Methods in org.hibernate.mapping that return Component
Component | Subclass.getIdentifierMapper()
Component | PersistentClass.getIdentifierMapper()

Methods in org.hibernate.mapping with parameters of type Component
Object | ValueVisitor.accept(Component component)
void | PersistentClass.setIdentifierMapper(Component handle)

Constructors in org.hibernate.mapping with parameters of type Component
Component(Component component)

Uses of Component in org.hibernate.tuple

Constructors in org.hibernate.tuple with parameters of type Component
PojoInstantiator(Component component, ReflectionOptimizer.InstantiationOptimizer optimizer)
Dom4jInstantiator(Component component)

Uses of Component in org.hibernate.tuple.component

Methods in org.hibernate.tuple.component with parameters of type Component
protected Instantiator | PojoComponentTuplizer.buildInstantiator(Component component)
protected Getter | PojoComponentTuplizer.buildGetter(Component component, Property prop)
protected Setter | PojoComponentTuplizer.buildSetter(Component component, Property prop)
protected Instantiator | DynamicMapComponentTuplizer.buildInstantiator(Component component)
protected Getter | DynamicMapComponentTuplizer.buildGetter(Component component, Property prop)
protected Setter | DynamicMapComponentTuplizer.buildSetter(Component component, Property prop)
protected Instantiator | Dom4jComponentTuplizer.buildInstantiator(Component component)
protected Getter | Dom4jComponentTuplizer.buildGetter(Component component, Property prop)
protected Setter | Dom4jComponentTuplizer.buildSetter(Component component, Property prop)
protected abstract Instantiator | AbstractComponentTuplizer.buildInstantiator(Component component)
protected abstract Getter | AbstractComponentTuplizer.buildGetter(Component component, Property prop)
protected abstract Setter | AbstractComponentTuplizer.buildSetter(Component component, Property prop)

Constructors in org.hibernate.tuple.component with parameters of type Component
PojoComponentTuplizer(Component component)
DynamicMapComponentTuplizer(Component component)
Dom4jComponentTuplizer(Component component)
ComponentMetamodel(Component component)
AbstractComponentTuplizer(Component component)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Constraint (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Constraint

Packages that use Constraint
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of Constraint in org.hibernate.mapping

Subclasses of Constraint in org.hibernate.mapping
class | ForeignKey A foreign key constraint
class | PrimaryKey A primary key constraint
class | UniqueKey A relational unique key constraint

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.DenormalizedTable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.DenormalizedTable

No usage of org.hibernate.mapping.DenormalizedTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.DependantValue (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.DependantValue

Packages that use DependantValue
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of DependantValue in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type DependantValue
 Object ValueVisitor.accept(DependantValue value)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.mapping.Fetchable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.mapping.Fetchable

Packages that use Fetchable
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of Fetchable in org.hibernate.mapping

Classes in org.hibernate.mapping that implement Fetchable
class | Array An array mapping has a primary key consisting of the key columns + index column.
class | Bag A bag permits duplicates, so it has no primary key
class | Collection Mapping for a collection.
class | IdentifierBag An IdentifierBag has a primary key consisting of just the identifier column
class | IdentifierCollection A collection with a synthetic "identifier" column
class | IndexedCollection Indexed collections include Lists, Maps, arrays and primitive arrays.
class | List A list mapping has a primary key consisting of the key columns + index column.
class | ManyToOne A many-to-one association mapping
class | Map A map has a primary key consisting of the key columns + index columns.
class | OneToOne A one-to-one association mapping
class | PrimitiveArray A primitive array has a primary key consisting of the key columns + index column.
class | Set A set with no nullable element columns.
class | ToOne A simple-point association (ie.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.mapping.Filterable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.mapping.Filterable

Packages that use Filterable
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of Filterable in org.hibernate.mapping

Classes in org.hibernate.mapping that implement Filterable
class | Array An array mapping has a primary key consisting of the key columns + index column.
class | Bag A bag permits duplicates, so it has no primary key
class | Collection Mapping for a collection.
class | IdentifierBag An IdentifierBag has a primary key consisting of just the identifier column
class | IdentifierCollection A collection with a synthetic "identifier" column
class | IndexedCollection Indexed collections include Lists, Maps, arrays and primitive arrays.
class | JoinedSubclass A subclass in a table-per-subclass mapping
class | List A list mapping has a primary key consisting of the key columns + index column.
class | Map A map has a primary key consisting of the key columns + index columns.
class | PersistentClass Mapping for an entity.
class | PrimitiveArray A primitive array has a primary key consisting of the key columns + index column.
class | RootClass The root class of an inheritance hierarchy
class | Set A set with no nullable element columns.
class | SingleTableSubclass
class | Subclass A sublass in a table-per-class-hierarchy mapping
class | UnionSubclass A subclass in a table-per-concrete-class mapping

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.ForeignKey (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.ForeignKey

Packages that use ForeignKey
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of ForeignKey in org.hibernate.mapping

Methods in org.hibernate.mapping that return ForeignKey
ForeignKey | Table.createForeignKey(String keyName, List keyColumns, String referencedEntityName)
ForeignKey | Table.createForeignKey(String keyName, List keyColumns, String referencedEntityName, List referencedColumns)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Formula (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Formula

Packages that use Formula
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of Formula in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type Formula
 void SimpleValue.addFormula(Formula formula)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.IdentifierBag (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.IdentifierBag

Packages that use IdentifierBag
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of IdentifierBag in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type IdentifierBag
 Object ValueVisitor.accept(IdentifierBag bag)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.IdentifierCollection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.IdentifierCollection

Packages that use IdentifierCollection
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of IdentifierCollection in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type IdentifierCollection
static void HbmBinder.bindIdentifierCollectionSecondPass(org.dom4j.Element node, IdentifierCollection collection, Map persistentClasses, Mappings mappings, Map inheritedMetas)

Uses of IdentifierCollection in org.hibernate.mapping

Subclasses of IdentifierCollection in org.hibernate.mapping
 class IdentifierBag
An IdentifierBag has a primary key consisting of just the identifier column

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Index (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Index

Packages that use Index
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of Index in org.hibernate.mapping

Methods in org.hibernate.mapping that return Index
Index | Table.getOrCreateIndex(String indexName)
Index | Table.getIndex(String indexName)
Index | Table.addIndex(Index index)

Methods in org.hibernate.mapping with parameters of type Index
 Index Table.addIndex(Index index)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.IndexBackref (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.IndexBackref

No usage of org.hibernate.mapping.IndexBackref

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.IndexedCollection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.IndexedCollection

Packages that use IndexedCollection
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of IndexedCollection in org.hibernate.mapping

Subclasses of IndexedCollection in org.hibernate.mapping
class | Array An array mapping has a primary key consisting of the key columns + index column.
class | List A list mapping has a primary key consisting of the key columns + index column.
class | Map A map has a primary key consisting of the key columns + index columns.
class | PrimitiveArray A primitive array has a primary key consisting of the key columns + index column.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Join (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Join

Packages that use Join
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of Join in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type Join
void | Subclass.addJoin(Join j)
protected void | Subclass.addSubclassJoin(Join j)
boolean | Subclass.isClassOrSuperclassJoin(Join join)
protected void | PersistentClass.addSubclassJoin(Join join)
boolean | PersistentClass.isClassOrSuperclassJoin(Join join)
void | PersistentClass.addJoin(Join join)

Constructors in org.hibernate.mapping with parameters of type Join
Component(Join join)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.JoinedSubclass (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.JoinedSubclass

Packages that use JoinedSubclass
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of JoinedSubclass in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type JoinedSubclass
static void HbmBinder.bindJoinedSubclass(org.dom4j.Element node, JoinedSubclass joinedSubclass, Mappings mappings, Map inheritedMetas)

Uses of JoinedSubclass in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type JoinedSubclass
 Object PersistentClassVisitor.accept(JoinedSubclass subclass)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.mapping.KeyValue (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.mapping.KeyValue

Packages that use KeyValue
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of KeyValue in org.hibernate.mapping

Classes in org.hibernate.mapping that implement KeyValue
class | Any A Hibernate "any" type (ie.
class | Component The mapping for a component, composite element, composite identifier, etc.
class | DependantValue A value which is "typed" by reference to some other value (for example, a foreign key is typed by the referenced primary key).
class | ManyToOne A many-to-one association mapping
class | OneToOne A one-to-one association mapping
class | SimpleValue Any value that maps to columns.
class | ToOne A simple-point association (ie.

Methods in org.hibernate.mapping that return KeyValue
KeyValue | Table.getIdentifierValue()
KeyValue | Subclass.getIdentifier()
KeyValue | Subclass.getKey()
KeyValue | RootClass.getIdentifier()
KeyValue | RootClass.getKey()
abstract KeyValue | PersistentClass.getIdentifier()
abstract KeyValue | PersistentClass.getKey()
KeyValue | OneToOne.getIdentifier() Returns the identifier.
KeyValue | JoinedSubclass.getKey()
KeyValue | Join.getKey()
KeyValue | IdentifierCollection.getIdentifier()
KeyValue | Collection.getKey()

Methods in org.hibernate.mapping with parameters of type KeyValue
void | Table.setIdentifierValue(KeyValue idValue)
void | RootClass.setIdentifier(KeyValue identifier)
void | OneToOne.setIdentifier(KeyValue identifier) Sets the identifier.
void | JoinedSubclass.setKey(KeyValue key)
void | Join.setKey(KeyValue key)
void | IdentifierCollection.setIdentifier(KeyValue identifier)
void | Collection.setKey(KeyValue key)

Constructors in org.hibernate.mapping with parameters of type KeyValue
DependantValue(Table table, KeyValue prototype)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.List (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.List

Packages that use List
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of List in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type List
static void HbmBinder.bindListSecondPass(org.dom4j.Element node, List list, Map classes, Mappings mappings, Map inheritedMetas)
Called for Lists, arrays, primitive arrays

Uses of List in org.hibernate.mapping

Subclasses of List in org.hibernate.mapping
class | Array An array mapping has a primary key consisting of the key columns + index column.
class | PrimitiveArray A primitive array has a primary key consisting of the key columns + index column.

Methods in org.hibernate.mapping with parameters of type List
 Object ValueVisitor.accept(List list)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.ManyToOne (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.ManyToOne

Packages that use ManyToOne
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of ManyToOne in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type ManyToOne
static void HbmBinder.bindManyToOne(org.dom4j.Element node, ManyToOne manyToOne, String path, boolean isNullable, Mappings mappings)

Uses of ManyToOne in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type ManyToOne
 Object ValueVisitor.accept(ManyToOne mto)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Map (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Map

Packages that use Map
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of Map in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type Map
static void HbmBinder.bindMapSecondPass(org.dom4j.Element node, Map map, Map classes, Mappings mappings, Map inheritedMetas)
Called for Maps

Uses of Map in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type Map
 Object ValueVisitor.accept(Map map)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.mapping.MetaAttributable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.mapping.MetaAttributable

Packages that use MetaAttributable
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of MetaAttributable in org.hibernate.mapping

Classes in org.hibernate.mapping that implement MetaAttributable
class | Backref
class | Component The mapping for a component, composite element, composite identifier, etc.
class | IndexBackref
class | JoinedSubclass A subclass in a table-per-subclass mapping
class | PersistentClass Mapping for an entity.
class | Property Represents a property as part of an entity or a component.
class | RootClass The root class of an inheritance hierarchy
class | SingleTableSubclass
class | Subclass A sublass in a table-per-class-hierarchy mapping
class | UnionSubclass A subclass in a table-per-concrete-class mapping

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.MetaAttribute (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.MetaAttribute

Packages that use MetaAttribute
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of MetaAttribute in org.hibernate.mapping

Methods in org.hibernate.mapping that return MetaAttribute
MetaAttribute | Property.getMetaAttribute(String attributeName)
MetaAttribute | PersistentClass.getMetaAttribute(String name)
MetaAttribute | MetaAttributable.getMetaAttribute(String name)
MetaAttribute | Component.getMetaAttribute(String attributeName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.OneToMany (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.OneToMany

Packages that use OneToMany
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of OneToMany in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type OneToMany
static void HbmBinder.bindOneToMany(org.dom4j.Element node, OneToMany oneToMany, Mappings mappings)

Uses of OneToMany in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type OneToMany
 Object ValueVisitor.accept(OneToMany many)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.OneToOne (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.OneToOne

Packages that use OneToOne
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of OneToOne in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type OneToOne
static void HbmBinder.bindOneToOne(org.dom4j.Element node, OneToOne oneToOne, String path, boolean isNullable, Mappings mappings)

Uses of OneToOne in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type OneToOne
 Object ValueVisitor.accept(OneToOne oto)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.PersistentClass (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.PersistentClass

Packages that use PersistentClass
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.entity |

Uses of PersistentClass in org.hibernate.cfg

Methods in org.hibernate.cfg that return PersistentClass
PersistentClass | Mappings.getClass(String className)
PersistentClass | Mappings.locatePersistentClassByEntityName(String entityName)
PersistentClass | Configuration.getClassMapping(String persistentClass) Get the mapping for a particular class

Methods in org.hibernate.cfg with parameters of type PersistentClass
void | Mappings.addClass(PersistentClass persistentClass)
static void | HbmBinder.bindClass(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas)
static void | HbmBinder.bindCompositeId(org.dom4j.Element node, Component component, PersistentClass persistentClass, String propertyName, Mappings mappings, Map inheritedMetas)
protected static void | HbmBinder.createClassProperties(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas)
protected static void | HbmBinder.createClassProperties(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas, UniqueKey uniqueKey, boolean mutable, boolean nullable, boolean naturalId)

Uses of PersistentClass in org.hibernate.mapping

Subclasses of PersistentClass in org.hibernate.mapping
class | JoinedSubclass A subclass in a table-per-subclass mapping
class | RootClass The root class of an inheritance hierarchy
class | SingleTableSubclass
class | Subclass A sublass in a table-per-class-hierarchy mapping
class | UnionSubclass A subclass in a table-per-concrete-class mapping

Methods in org.hibernate.mapping that return PersistentClass
PersistentClass | Subclass.getSuperclass()
PersistentClass | RootClass.getSuperclass()
PersistentClass | Property.getPersistentClass()
abstract PersistentClass | PersistentClass.getSuperclass()
PersistentClass | OneToMany.getAssociatedClass()
PersistentClass | Join.getPersistentClass()
PersistentClass | Component.getOwner()
PersistentClass | Collection.getOwner()

Methods in org.hibernate.mapping with parameters of type PersistentClass
void | Subclass.setSuperclass(PersistentClass superclass)
void | Property.setPersistentClass(PersistentClass persistentClass)
void | OneToMany.setAssociatedClass(PersistentClass associatedClass) Associated entity on the many side
void | Join.setPersistentClass(PersistentClass persistentClass)
void | Component.setOwner(PersistentClass owner)
void | Collection.setOwner(PersistentClass owner)

Constructors in org.hibernate.mapping with parameters of type PersistentClass
UnionSubclass(PersistentClass superclass)
Subclass(PersistentClass superclass)
SingleTableSubclass(PersistentClass superclass)
Set(PersistentClass owner)
Constructor for Set.
PrimitiveArray(PersistentClass owner)
OneToOne(Table table, PersistentClass owner)
OneToMany(PersistentClass owner)
Map(PersistentClass owner)
List(PersistentClass owner)
JoinedSubclass(PersistentClass superclass)
IndexedCollection(PersistentClass owner)
IdentifierCollection(PersistentClass owner)
IdentifierBag(PersistentClass owner)
Component(PersistentClass owner)
Collection(PersistentClass owner)
Bag(PersistentClass owner)
Array(PersistentClass owner)
Constructor for Array.

Uses of PersistentClass in org.hibernate.persister

Methods in org.hibernate.persister with parameters of type PersistentClass
static EntityPersister PersisterFactory.createClassPersister(PersistentClass model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping cfg)

Uses of PersistentClass in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity with parameters of type PersistentClass
protected String | UnionSubclassEntityPersister.generateSubquery(PersistentClass model, Mapping mapping)
protected void | AbstractEntityPersister.initSubclassPropertyAliasesMap(PersistentClass model) Must be called by subclasses, at the end of their constructors

Constructors in org.hibernate.persister.entity with parameters of type PersistentClass
UnionSubclassEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
SingleTableEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
JoinedSubclassEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping mapping)
AbstractEntityPersister(PersistentClass persistentClass, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory)

Uses of PersistentClass in org.hibernate.tuple

Methods in org.hibernate.tuple with parameters of type PersistentClass
static IdentifierProperty PropertyFactory.buildIdentifierProperty(PersistentClass mappedEntity, IdentifierGenerator generator)
Generates an IdentifierProperty representation of the for a given entity mapping.

Constructors in org.hibernate.tuple with parameters of type PersistentClass
PojoInstantiator(PersistentClass persistentClass, ReflectionOptimizer.InstantiationOptimizer optimizer)
DynamicMapInstantiator(PersistentClass mappingInfo)
Dom4jInstantiator(PersistentClass mappingInfo)

Uses of PersistentClass in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity with parameters of type PersistentClass
protected ProxyFactory | PojoEntityTuplizer.buildProxyFactory(PersistentClass persistentClass, Getter idGetter, Setter idSetter)
protected ProxyFactory | PojoEntityTuplizer.buildProxyFactoryInternal(PersistentClass persistentClass, Getter idGetter, Setter idSetter)
protected Instantiator | PojoEntityTuplizer.buildInstantiator(PersistentClass persistentClass)
protected Getter | PojoEntityTuplizer.buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity)
protected Setter | PojoEntityTuplizer.buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity)
protected Getter | DynamicMapEntityTuplizer.buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity)
protected Setter | DynamicMapEntityTuplizer.buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity)
protected Instantiator | DynamicMapEntityTuplizer.buildInstantiator(PersistentClass mappingInfo)
protected ProxyFactory | DynamicMapEntityTuplizer.buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter)
protected Getter | Dom4jEntityTuplizer.buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity)
protected Setter | Dom4jEntityTuplizer.buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity)
protected Instantiator | Dom4jEntityTuplizer.buildInstantiator(PersistentClass persistentClass)
protected ProxyFactory | Dom4jEntityTuplizer.buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter)
protected abstract Getter | AbstractEntityTuplizer.buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Getter for the given property.
protected abstract Setter | AbstractEntityTuplizer.buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Setter for the given property.
protected abstract Instantiator | AbstractEntityTuplizer.buildInstantiator(PersistentClass mappingInfo) Build an appropriate Instantiator for the given mapped entity.
protected abstract ProxyFactory | AbstractEntityTuplizer.buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter) Build an appropriate ProxyFactory for the given mapped entity.

Constructors in org.hibernate.tuple.entity with parameters of type PersistentClass
PojoEntityTuplizer(EntityMetamodel entityMetamodel, PersistentClass mappedEntity)
EntityMetamodel(PersistentClass persistentClass, SessionFactoryImplementor sessionFactory)
EntityEntityModeToTuplizerMapping(PersistentClass mappedEntity, EntityMetamodel em)
Instantiates a EntityEntityModeToTuplizerMapping based on the given entity mapping and metamodel definitions.
AbstractEntityTuplizer(EntityMetamodel entityMetamodel, PersistentClass mappingInfo)
Constructs a new AbstractEntityTuplizer instance.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.mapping.PersistentClassVisitor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.mapping.PersistentClassVisitor

Packages that use PersistentClassVisitor
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of PersistentClassVisitor in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type PersistentClassVisitor
Object | UnionSubclass.accept(PersistentClassVisitor mv)
Object | Subclass.accept(PersistentClassVisitor mv)
Object | SingleTableSubclass.accept(PersistentClassVisitor mv)
Object | RootClass.accept(PersistentClassVisitor mv)
abstract Object | PersistentClass.accept(PersistentClassVisitor mv)
Object | JoinedSubclass.accept(PersistentClassVisitor mv)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.PrimaryKey (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.PrimaryKey

Packages that use PrimaryKey
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of PrimaryKey in org.hibernate.mapping

Methods in org.hibernate.mapping that return PrimaryKey
PrimaryKey | Table.getPrimaryKey()
PrimaryKey | DenormalizedTable.getPrimaryKey()

Methods in org.hibernate.mapping with parameters of type PrimaryKey
 void Table.setPrimaryKey(PrimaryKey primaryKey)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.PrimitiveArray (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.PrimitiveArray

Packages that use PrimitiveArray
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of PrimitiveArray in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type PrimitiveArray
 Object ValueVisitor.accept(PrimitiveArray primitiveArray)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Property (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Property

Packages that use Property
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |

Uses of Property in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type Property
static void HbmBinder.bindProperty(org.dom4j.Element node, Property property, Mappings mappings, Map inheritedMetas)

Uses of Property in org.hibernate.mapping

Subclasses of Property in org.hibernate.mapping
class | Backref
class | IndexBackref

Methods in org.hibernate.mapping that return Property
Property | Subclass.getIdentifierProperty()
Property | Subclass.getVersion()
Property | RootClass.getIdentifierProperty()
Property | RootClass.getVersion()
abstract Property | PersistentClass.getIdentifierProperty()
abstract Property | PersistentClass.getVersion()
Property | PersistentClass.getReferencedProperty(String propertyPath)
Property | PersistentClass.getRecursiveProperty(String propertyPath)
Property | PersistentClass.getProperty(String propertyName)
Property | Component.getProperty(String propertyName)

Methods in org.hibernate.mapping with parameters of type Property
void | Subclass.addProperty(Property p)
protected void | Subclass.addSubclassProperty(Property p)
void | RootClass.setVersion(Property version)
void | RootClass.setIdentifierProperty(Property identifierProperty)
void | PersistentClass.addProperty(Property p)
protected void | PersistentClass.addSubclassProperty(Property prop)
int | PersistentClass.getJoinNumber(Property prop)
void | Join.addProperty(Property prop)
boolean | Join.containsProperty(Property prop)
void | Component.addProperty(Property p)

Uses of Property in org.hibernate.property

Methods in org.hibernate.property with parameters of type Property
static PropertyAccessor PropertyAccessorFactory.getPropertyAccessor(Property property, EntityMode mode)
Retrieves a PropertyAccessor instance based on the given property definition and entity mode.

Uses of Property in org.hibernate.tuple

Methods in org.hibernate.tuple with parameters of type Property
static VersionProperty | PropertyFactory.buildVersionProperty(Property property, boolean lazyAvailable) Generates a VersionProperty representation for an entity mapping given its version mapping Property.
static StandardProperty | PropertyFactory.buildStandardProperty(Property property, boolean lazyAvailable) Generate a "standard" (i.e., non-identifier and non-version) based on the given mapped property.

Uses of Property in org.hibernate.tuple.component

Methods in org.hibernate.tuple.component with parameters of type Property
protected Getter | PojoComponentTuplizer.buildGetter(Component component, Property prop)
protected Setter | PojoComponentTuplizer.buildSetter(Component component, Property prop)
protected Getter | DynamicMapComponentTuplizer.buildGetter(Component component, Property prop)
protected Setter | DynamicMapComponentTuplizer.buildSetter(Component component, Property prop)
protected Getter | Dom4jComponentTuplizer.buildGetter(Component component, Property prop)
protected Setter | Dom4jComponentTuplizer.buildSetter(Component component, Property prop)
protected abstract Getter | AbstractComponentTuplizer.buildGetter(Component component, Property prop)
protected abstract Setter | AbstractComponentTuplizer.buildSetter(Component component, Property prop)

Uses of Property in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity with parameters of type Property
protected Getter | PojoEntityTuplizer.buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity)
protected Setter | PojoEntityTuplizer.buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity)
protected Getter | DynamicMapEntityTuplizer.buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity)
protected Setter | DynamicMapEntityTuplizer.buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity)
protected Getter | Dom4jEntityTuplizer.buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity)
protected Setter | Dom4jEntityTuplizer.buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity)
protected abstract Getter | AbstractEntityTuplizer.buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Getter for the given property.
protected abstract Setter | AbstractEntityTuplizer.buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Setter for the given property.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.PropertyGeneration (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.PropertyGeneration

Packages that use PropertyGeneration
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of PropertyGeneration in org.hibernate.mapping

Fields in org.hibernate.mapping declared as PropertyGeneration
static PropertyGeneration | PropertyGeneration.NEVER Values for this property are never generated by the database.
static PropertyGeneration | PropertyGeneration.INSERT Values for this property are generated by the database on insert.
static PropertyGeneration | PropertyGeneration.ALWAYS Values for this property are generated by the database on both insert and update.

Methods in org.hibernate.mapping that return PropertyGeneration
static PropertyGeneration | PropertyGeneration.parse(String name)
PropertyGeneration | Property.getGeneration()

Methods in org.hibernate.mapping with parameters of type PropertyGeneration
 void Property.setGeneration(PropertyGeneration generation)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.mapping.RelationalModel (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.mapping.RelationalModel

Packages that use RelationalModel
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of RelationalModel in org.hibernate.mapping

Subinterfaces of RelationalModel in org.hibernate.mapping
 interface AuxiliaryDatabaseObject
Auxiliary database objects (i.e., triggers, stored procedures, etc) defined in the mappings.

Classes in org.hibernate.mapping that implement RelationalModel
class | AbstractAuxiliaryDatabaseObject Convenience base class for AuxiliaryDatabaseObjects.
class | Constraint A relational constraint.
class | DenormalizedTable
class | ForeignKey A foreign key constraint
class | Index A relational table index
class | PrimaryKey A primary key constraint
class | SimpleAuxiliaryDatabaseObject A simple implementation of AbstractAuxiliaryDatabaseObject in which the CREATE and DROP strings are provided up front.
class | Table A relational table
class | UniqueKey A relational unique key constraint

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.RootClass (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.RootClass

Packages that use RootClass
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of RootClass in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type RootClass
static void HbmBinder.bindRootClass(org.dom4j.Element node, RootClass rootClass, Mappings mappings, Map inheritedMetas)
Responsible for perfoming the bind operation related to an <class/> mapping element.

Uses of RootClass in org.hibernate.mapping

Methods in org.hibernate.mapping that return RootClass
RootClass | Subclass.getRootClass()
RootClass | RootClass.getRootClass()
abstract RootClass | PersistentClass.getRootClass()

Methods in org.hibernate.mapping with parameters of type RootClass
IdentifierGenerator | SimpleValue.createIdentifierGenerator(Dialect dialect, String defaultCatalog, String defaultSchema, RootClass rootClass)
Object | PersistentClassVisitor.accept(RootClass class1)
IdentifierGenerator | KeyValue.createIdentifierGenerator(Dialect dialect, String defaultCatalog, String defaultSchema, RootClass rootClass)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.mapping.Selectable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.mapping.Selectable

Packages that use Selectable
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of Selectable in org.hibernate.mapping

Classes in org.hibernate.mapping that implement Selectable
class | Column A column of a relational database table
class | Formula A formula is a derived column value

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Set (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Set

Packages that use Set
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of Set in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type Set
 Object ValueVisitor.accept(Set set)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.SimpleAuxiliaryDatabaseObject (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.SimpleAuxiliaryDatabaseObject

No usage of org.hibernate.mapping.SimpleAuxiliaryDatabaseObject

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.SimpleValue (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.SimpleValue

Packages that use SimpleValue
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of SimpleValue in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type SimpleValue
static void | HbmBinder.bindColumns(org.dom4j.Element node, SimpleValue simpleValue, boolean isNullable, boolean autoColumn, String propertyPath, Mappings mappings)
static void | HbmBinder.bindSimpleValue(org.dom4j.Element node, SimpleValue simpleValue, boolean isNullable, String path, Mappings mappings)

Uses of SimpleValue in org.hibernate.mapping

Subclasses of SimpleValue in org.hibernate.mapping
class | Any A Hibernate "any" type (ie.
class | Component The mapping for a component, composite element, composite identifier, etc.
class | DependantValue A value which is "typed" by reference to some other value (for example, a foreign key is typed by the referenced primary key).
class | ManyToOne A many-to-one association mapping
class | OneToOne A one-to-one association mapping
class | ToOne A simple-point association (ie.

Methods in org.hibernate.mapping with parameters of type SimpleValue
 Object ValueVisitor.accept(SimpleValue value)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.SingleTableSubclass (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.SingleTableSubclass

Packages that use SingleTableSubclass
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of SingleTableSubclass in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type SingleTableSubclass
 Object PersistentClassVisitor.accept(SingleTableSubclass subclass)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Subclass (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Subclass

Packages that use Subclass
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of Subclass in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type Subclass
static void HbmBinder.bindSubclass(org.dom4j.Element node, Subclass subclass, Mappings mappings, Map inheritedMetas)

Uses of Subclass in org.hibernate.mapping

Subclasses of Subclass in org.hibernate.mapping
class | JoinedSubclass A subclass in a table-per-subclass mapping
class | SingleTableSubclass
class | UnionSubclass A subclass in a table-per-concrete-class mapping

Methods in org.hibernate.mapping with parameters of type Subclass
void | RootClass.addSubclass(Subclass subclass)
Object | PersistentClassVisitor.accept(Subclass subclass)
void | PersistentClass.addSubclass(Subclass subclass)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.Table (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.Table

Packages that use Table
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of Table in org.hibernate.cfg

Fields in org.hibernate.cfg declared as Table
 Table Mappings.TableDescription.denormalizedSupertable

Methods in org.hibernate.cfg that return Table
Table | Mappings.addTable(String schema, String catalog, String name, String subselect, boolean isAbstract)
Table | Mappings.addDenormalizedTable(String schema, String catalog, String name, boolean isAbstract, String subselect, Table includedTable)
Table | Mappings.getTable(String schema, String catalog, String name)

Methods in org.hibernate.cfg with parameters of type Table
Table | Mappings.addDenormalizedTable(String schema, String catalog, String name, boolean isAbstract, String subselect, Table includedTable)
void | Mappings.addTableBinding(String schema, String catalog, String logicalName, String physicalName, Table denormalizedSuperTable)
void | Mappings.addColumnBinding(String logicalName, Column finalColumn, Table table)
String | Mappings.getPhysicalColumnName(String logicalName, Table table)
String | Mappings.getLogicalColumnName(String physicalName, Table table)
String | Mappings.getLogicalTableName(Table table)
protected void | Configuration.secondPassCompileForeignKeys(Table table, Set done)

Constructors in org.hibernate.cfg with parameters of type Table
Mappings.TableDescription(String logicalName, Table denormalizedSupertable)

Uses of Table in org.hibernate.mapping

Subclasses of Table in org.hibernate.mapping
 class DenormalizedTable

Methods in org.hibernate.mapping that return Table
Table | Value.getTable()
Table | UnionSubclass.getTable()
Table | UnionSubclass.getIdentityTable()
Table | Subclass.getRootTable()
Table | Subclass.getTable()
Table | SimpleValue.getTable()
Table | RootClass.getTable()
Table | RootClass.getRootTable()
Table | PersistentClass.getIdentityTable()
abstract Table | PersistentClass.getTable()
abstract Table | PersistentClass.getRootTable()
Table | OneToMany.getTable() Table of the owner entity (the "one" side)
Table | JoinedSubclass.getTable()
Table | Join.getTable()
Table | Index.getTable()
Table | ForeignKey.getReferencedTable()
Table | Constraint.getTable()
Table | Collection.getCollectionTable()
Table | Collection.getTable()

Methods in org.hibernate.mapping with parameters of type Table
void | UnionSubclass.setTable(Table table)
void | TableOwner.setTable(Table table)
protected void | Subclass.addSubclassTable(Table table)
boolean | Subclass.isClassOrSuperclassTable(Table table)
void | SimpleValue.setTable(Table table)
String | Selectable.getAlias(Dialect dialect, Table table)
void | RootClass.setTable(Table table)
protected void | PersistentClass.addSubclassTable(Table subclassTable)
boolean | PersistentClass.isClassOrSuperclassTable(Table closureTable)
void | JoinedSubclass.setTable(Table table)
void | Join.setTable(Table table)
static String | Index.buildSqlDropIndexString(Dialect dialect, Table table, String name, String defaultCatalog, String defaultSchema)
static String | Index.buildSqlCreateIndexString(Dialect dialect, String name, Table table, Iterator columns, boolean unique, String defaultCatalog, String defaultSchema)
void | Index.setTable(Table table)
String | Formula.getAlias(Dialect dialect, Table table)
void | ForeignKey.setReferencedTable(Table referencedTable)
void | Constraint.setTable(Table table)
String | Column.getAlias(Dialect dialect, Table table) Generate a column alias that is unique across multiple tables
void | Collection.setCollectionTable(Table table)

Constructors in org.hibernate.mapping with parameters of type Table
ToOne(Table table)
SimpleValue(Table table)
OneToOne(Table table, PersistentClass owner)
ManyToOne(Table table)
DependantValue(Table table, KeyValue prototype)
DenormalizedTable(Table includedTable)
Any(Table table)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.mapping.TableOwner (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.mapping.TableOwner

Packages that use TableOwner
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of TableOwner in org.hibernate.mapping

Classes in org.hibernate.mapping that implement TableOwner
class | JoinedSubclass A subclass in a table-per-subclass mapping
class | RootClass The root class of an inheritance hierarchy
class | UnionSubclass A subclass in a table-per-concrete-class mapping

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.ToOne (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.ToOne

Packages that use ToOne
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of ToOne in org.hibernate.mapping

Subclasses of ToOne in org.hibernate.mapping
class | ManyToOne A many-to-one association mapping
class | OneToOne A one-to-one association mapping

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.TypeDef (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.TypeDef

Packages that use TypeDef
org.hibernate.cfg This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of TypeDef in org.hibernate.cfg

Methods in org.hibernate.cfg that return TypeDef
 TypeDef Mappings.getTypeDef(String typeName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.UnionSubclass (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.UnionSubclass

Packages that use UnionSubclass
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of UnionSubclass in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type UnionSubclass
static void HbmBinder.bindUnionSubclass(org.dom4j.Element node, UnionSubclass unionSubclass, Mappings mappings, Map inheritedMetas)

Uses of UnionSubclass in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type UnionSubclass
 Object PersistentClassVisitor.accept(UnionSubclass subclass)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.mapping.UniqueKey (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.mapping.UniqueKey

Packages that use UniqueKey
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.

Uses of UniqueKey in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type UniqueKey
protected static void HbmBinder.createClassProperties(org.dom4j.Element node, PersistentClass persistentClass, Mappings mappings, Map inheritedMetas, UniqueKey uniqueKey, boolean mutable, boolean nullable, boolean naturalId)

Uses of UniqueKey in org.hibernate.mapping

Methods in org.hibernate.mapping that return UniqueKey
UniqueKey | Table.addUniqueKey(UniqueKey uniqueKey)
UniqueKey | Table.createUniqueKey(List keyColumns)
UniqueKey | Table.getUniqueKey(String keyName)
UniqueKey | Table.getOrCreateUniqueKey(String keyName)

Methods in org.hibernate.mapping with parameters of type UniqueKey
 UniqueKey Table.addUniqueKey(UniqueKey uniqueKey)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.mapping.Value (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.mapping.Value

Packages that use Value
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of Value in org.hibernate.mapping

Subinterfaces of Value in org.hibernate.mapping
 interface KeyValue
Represents an identifying key of a table: the value for primary key of an entity, or a foreign key of a collection or join table or joined subclass table.

Classes in org.hibernate.mapping that implement Value
class | Any A Hibernate "any" type (ie.
class | Array An array mapping has a primary key consisting of the key columns + index column.
class | Bag A bag permits duplicates, so it has no primary key
class | Collection Mapping for a collection.
class | Component The mapping for a component, composite element, composite identifier, etc.
class | DependantValue A value which is "typed" by reference to some other value (for example, a foreign key is typed by the referenced primary key).
class | IdentifierBag An IdentifierBag has a primary key consisting of just the identifier column
class | IdentifierCollection A collection with a synthetic "identifier" column
class | IndexedCollection Indexed collections include Lists, Maps, arrays and primitive arrays.
class | List A list mapping has a primary key consisting of the key columns + index column.
class | ManyToOne A many-to-one association mapping
class | Map A map has a primary key consisting of the key columns + index columns.
class | OneToMany A mapping for a one-to-many association
class | OneToOne A one-to-one association mapping
class | PrimitiveArray A primitive array has a primary key consisting of the key columns + index column.
class | Set A set with no nullable element columns.
class | SimpleValue Any value that maps to columns.
class | ToOne A simple-point association (ie.

Methods in org.hibernate.mapping that return Value
Value | Subclass.getDiscriminator()
Value | RootClass.getDiscriminator()
Value | Property.getValue()
abstract Value | PersistentClass.getDiscriminator()
Value | IndexedCollection.getIndex()
Value | Column.getValue()
Value | Collection.getElement()

Methods in org.hibernate.mapping with parameters of type Value
void | RootClass.setDiscriminator(Value discriminator)
void | Property.setValue(Value value)
void | IndexedCollection.setIndex(Value index)
void | Column.setValue(Value value)
void | Collection.setElement(Value element)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.mapping.ValueVisitor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.mapping.ValueVisitor

Packages that use ValueVisitor
org.hibernate.mapping This package defines the Hibernate configuration-time metamodel.

Uses of ValueVisitor in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type ValueVisitor
Object | Value.accept(ValueVisitor visitor)
Object | ToOne.accept(ValueVisitor visitor)
Object | SimpleValue.accept(ValueVisitor visitor)
Object | Set.accept(ValueVisitor visitor)
Object | PrimitiveArray.accept(ValueVisitor visitor)
Object | OneToOne.accept(ValueVisitor visitor)
Object | OneToMany.accept(ValueVisitor visitor)
Object | Map.accept(ValueVisitor visitor)
Object | ManyToOne.accept(ValueVisitor visitor)
Object | List.accept(ValueVisitor visitor)
Object | IdentifierBag.accept(ValueVisitor visitor)
Object | DependantValue.accept(ValueVisitor visitor)
Object | Component.accept(ValueVisitor visitor)
Object | Bag.accept(ValueVisitor visitor)
Object | Array.accept(ValueVisitor visitor)
Object | Any.accept(ValueVisitor visitor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.metadata (Hibernate API Documentation)

 org.hibernate.metadata
Interfaces
ClassMetadata
CollectionMetadata


Uses of Interface org.hibernate.metadata.ClassMetadata (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.metadata.ClassMetadata

Packages that use ClassMetadata
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of ClassMetadata in org.hibernate

Methods in org.hibernate that return ClassMetadata
ClassMetadata | SessionFactory.getClassMetadata(Class persistentClass) Get the ClassMetadata associated with the given entity class
ClassMetadata | SessionFactory.getClassMetadata(String entityName) Get the ClassMetadata associated with the given entity name

Uses of ClassMetadata in org.hibernate.impl

Methods in org.hibernate.impl that return ClassMetadata
ClassMetadata | SessionFactoryImpl.getClassMetadata(Class persistentClass)
ClassMetadata | SessionFactoryImpl.getClassMetadata(String entityName)

Uses of ClassMetadata in org.hibernate.jmx

Methods in org.hibernate.jmx that return ClassMetadata
ClassMetadata | SessionFactoryStub.getClassMetadata(Class persistentClass)
ClassMetadata | SessionFactoryStub.getClassMetadata(String entityName)

Uses of ClassMetadata in org.hibernate.persister.entity

Classes in org.hibernate.persister.entity that implement ClassMetadata
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Methods in org.hibernate.persister.entity that return ClassMetadata
ClassMetadata | EntityPersister.getClassMetadata() Get the user-visible metadata for the class (optional operation)
ClassMetadata | AbstractEntityPersister.getClassMetadata()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.metadata.CollectionMetadata (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.metadata.CollectionMetadata

Packages that use CollectionMetadata
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.

Uses of CollectionMetadata in org.hibernate

Methods in org.hibernate that return CollectionMetadata
 CollectionMetadata SessionFactory.getCollectionMetadata(String roleName)
Get the CollectionMetadata associated with the named collection role

Uses of CollectionMetadata in org.hibernate.impl

Methods in org.hibernate.impl that return CollectionMetadata
 CollectionMetadata SessionFactoryImpl.getCollectionMetadata(String roleName)

Uses of CollectionMetadata in org.hibernate.jmx

Methods in org.hibernate.jmx that return CollectionMetadata
 CollectionMetadata SessionFactoryStub.getCollectionMetadata(String roleName)

Uses of CollectionMetadata in org.hibernate.persister.collection

Classes in org.hibernate.persister.collection that implement CollectionMetadata
class | AbstractCollectionPersister Base implementation of the QueryableCollection interface.
class | BasicCollectionPersister Collection persister for collections of values and many-to-many associations.
class | OneToManyPersister Collection persister for one-to-many associations.

Methods in org.hibernate.persister.collection that return CollectionMetadata
CollectionMetadata | CollectionPersister.getCollectionMetadata()
CollectionMetadata | AbstractCollectionPersister.getCollectionMetadata()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.param (Hibernate API Documentation)

 org.hibernate.param
Interfaces
ExplicitParameterSpecification
ParameterSpecification
Classes
AbstractExplicitParameterSpecification
NamedParameterSpecification
PositionalParameterSpecification
VersionTypeSeedParameterSpecification


Uses of Class org.hibernate.param.AbstractExplicitParameterSpecification (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.param.AbstractExplicitParameterSpecification

Packages that use AbstractExplicitParameterSpecification
org.hibernate.param

Uses of AbstractExplicitParameterSpecification in org.hibernate.param

Subclasses of AbstractExplicitParameterSpecification in org.hibernate.param
class | NamedParameterSpecification Relates to an explicit query named-parameter.
class | PositionalParameterSpecification Relates to an explicit query positional (or ordinal) parameter.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.param.ExplicitParameterSpecification (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.param.ExplicitParameterSpecification

Packages that use ExplicitParameterSpecification
org.hibernate.param

Uses of ExplicitParameterSpecification in org.hibernate.param

Classes in org.hibernate.param that implement ExplicitParameterSpecification
class | AbstractExplicitParameterSpecification Convenience base class for explicitly defined query parameters.
class | NamedParameterSpecification Relates to an explicit query named-parameter.
class | PositionalParameterSpecification Relates to an explicit query positional (or ordinal) parameter.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.param.NamedParameterSpecification (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.param.NamedParameterSpecification

No usage of org.hibernate.param.NamedParameterSpecification

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.param.ParameterSpecification (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.param.ParameterSpecification

Packages that use ParameterSpecification
org.hibernate.hql.ast.tree
org.hibernate.param

Uses of ParameterSpecification in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return ParameterSpecification
ParameterSpecification | ParameterNode.getHqlParameterSpecification()
ParameterSpecification[] | AssignmentSpecification.getParameters()

Methods in org.hibernate.hql.ast.tree with parameters of type ParameterSpecification
 void ParameterNode.setHqlParameterSpecification(ParameterSpecification parameterSpecification)

Uses of ParameterSpecification in org.hibernate.param

Subinterfaces of ParameterSpecification in org.hibernate.param
 interface ExplicitParameterSpecification
An additional contract for parameters which originate from parameters explicitly encountered in the source statement (HQL or native-SQL).

Classes in org.hibernate.param that implement ParameterSpecification
class | AbstractExplicitParameterSpecification Convenience base class for explicitly defined query parameters.
class | NamedParameterSpecification Relates to an explicit query named-parameter.
class | PositionalParameterSpecification Relates to an explicit query positional (or ordinal) parameter.
class | VersionTypeSeedParameterSpecification Implementation of VersionTypeSeedParameterSpecification.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.param.PositionalParameterSpecification (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.param.PositionalParameterSpecification

No usage of org.hibernate.param.PositionalParameterSpecification

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.param.VersionTypeSeedParameterSpecification (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.param.VersionTypeSeedParameterSpecification

No usage of org.hibernate.param.VersionTypeSeedParameterSpecification

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.persister (Hibernate API Documentation)

 org.hibernate.persister
Classes
PersisterFactory


Uses of Class org.hibernate.persister.PersisterFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.PersisterFactory

No usage of org.hibernate.persister.PersisterFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.persister.collection (Hibernate API Documentation)

 org.hibernate.persister.collection
Interfaces
CollectionPersister
QueryableCollection
SQLLoadableCollection
Classes
AbstractCollectionPersister
BasicCollectionPersister
CollectionPropertyMapping
CollectionPropertyNames
CompositeElementPropertyMapping
ElementPropertyMapping
NamedQueryCollectionInitializer
OneToManyPersister


Uses of Class org.hibernate.persister.collection.AbstractCollectionPersister (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.collection.AbstractCollectionPersister

Packages that use AbstractCollectionPersister
org.hibernate.persister.collection This package abstracts the persistence mechanism for collections.

Uses of AbstractCollectionPersister in org.hibernate.persister.collection

Subclasses of AbstractCollectionPersister in org.hibernate.persister.collection
class | BasicCollectionPersister Collection persister for collections of values and many-to-many associations.
class | OneToManyPersister Collection persister for one-to-many associations.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.collection.BasicCollectionPersister (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.collection.BasicCollectionPersister

Packages that use BasicCollectionPersister
org.hibernate.collection This package defines a framework for collection wrappers.

Uses of BasicCollectionPersister in org.hibernate.collection

Methods in org.hibernate.collection with parameters of type BasicCollectionPersister
protected Serializable | PersistentSortedSet.snapshot(BasicCollectionPersister persister, EntityMode entityMode)
protected Serializable | PersistentSortedMap.snapshot(BasicCollectionPersister persister, EntityMode entityMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.persister.collection.CollectionPersister (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.persister.collection.CollectionPersister

Packages that use CollectionPersister
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.pretty | Classes for pretty printing things for exception and log messages.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.usertype | Interfaces for user-defined custom types.

Uses of CollectionPersister in org.hibernate.action

Methods in org.hibernate.action that return CollectionPersister
protected  CollectionPersister CollectionAction.getPersister()

Constructors in org.hibernate.action with parameters of type CollectionPersister
CollectionUpdateAction(PersistentCollection collection, CollectionPersister persister, Serializable id, boolean emptySnapshot, SessionImplementor session)
CollectionRemoveAction(PersistentCollection collection, CollectionPersister persister, Serializable id, boolean emptySnapshot, SessionImplementor session)
CollectionRecreateAction(PersistentCollection collection, CollectionPersister persister, Serializable id, SessionImplementor session)
CollectionAction(CollectionPersister persister, PersistentCollection collection, Serializable key, SessionImplementor session)

Uses of CollectionPersister in org.hibernate.cache.entry

Methods in org.hibernate.cache.entry with parameters of type CollectionPersister
 void CollectionCacheEntry.assemble(PersistentCollection collection, CollectionPersister persister, Object owner)

Constructors in org.hibernate.cache.entry with parameters of type CollectionPersister
CollectionCacheEntry(PersistentCollection collection, CollectionPersister persister)

Uses of CollectionPersister in org.hibernate.collection

Methods in org.hibernate.collection with parameters of type CollectionPersister
Serializable | PersistentSet.getSnapshot(CollectionPersister persister)
boolean | PersistentSet.equalsSnapshot(CollectionPersister persister)
void | PersistentSet.beforeInitialize(CollectionPersister persister, int anticipatedSize)
void | PersistentSet.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Object | PersistentSet.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Iterator | PersistentSet.entries(CollectionPersister persister)
Serializable | PersistentSet.disassemble(CollectionPersister persister)
Iterator | PersistentSet.getDeletes(CollectionPersister persister, boolean indexIsFormula)
Object | PersistentSet.getIndex(Object entry, int i, CollectionPersister persister)
void | PersistentMapElementHolder.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentMapElementHolder.disassemble(CollectionPersister persister)
Serializable | PersistentMap.getSnapshot(CollectionPersister persister)
boolean | PersistentMap.equalsSnapshot(CollectionPersister persister)
void | PersistentMap.beforeInitialize(CollectionPersister persister, int anticipatedSize)
Object | PersistentMap.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Iterator | PersistentMap.entries(CollectionPersister persister)
void | PersistentMap.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentMap.disassemble(CollectionPersister persister)
Iterator | PersistentMap.getDeletes(CollectionPersister persister, boolean indexIsFormula)
Object | PersistentMap.getIndex(Object entry, int i, CollectionPersister persister)
void | PersistentListElementHolder.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentListElementHolder.disassemble(CollectionPersister persister)
Serializable | PersistentList.getSnapshot(CollectionPersister persister)
boolean | PersistentList.equalsSnapshot(CollectionPersister persister)
void | PersistentList.beforeInitialize(CollectionPersister persister, int anticipatedSize)
Object | PersistentList.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Iterator | PersistentList.entries(CollectionPersister persister)
void | PersistentList.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentList.disassemble(CollectionPersister persister)
Iterator | PersistentList.getDeletes(CollectionPersister persister, boolean indexIsFormula)
Object | PersistentList.getIndex(Object entry, int i, CollectionPersister persister)
protected static String | PersistentIndexedElementHolder.getIndexAttributeName(CollectionPersister persister)
Serializable | PersistentIndexedElementHolder.getSnapshot(CollectionPersister persister)
boolean | PersistentIndexedElementHolder.equalsSnapshot(CollectionPersister persister)
Object | PersistentIndexedElementHolder.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Iterator | PersistentIndexedElementHolder.entries(CollectionPersister persister)
void | PersistentIndexedElementHolder.beforeInitialize(CollectionPersister persister, int anticipatedSize)
Iterator | PersistentIndexedElementHolder.getDeletes(CollectionPersister persister, boolean indexIsFormula)
Object | PersistentIndexedElementHolder.getIndex(Object entry, int i, CollectionPersister persister)
void | PersistentIdentifierBag.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
void | PersistentIdentifierBag.beforeInitialize(CollectionPersister persister, int anticipatedSize)
Serializable | PersistentIdentifierBag.disassemble(CollectionPersister persister)
Iterator | PersistentIdentifierBag.entries(CollectionPersister persister)
boolean | PersistentIdentifierBag.equalsSnapshot(CollectionPersister persister)
Iterator | PersistentIdentifierBag.getDeletes(CollectionPersister persister, boolean indexIsFormula)
Object | PersistentIdentifierBag.getIndex(Object entry, int i, CollectionPersister persister)
Object | PersistentIdentifierBag.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Serializable | PersistentIdentifierBag.getSnapshot(CollectionPersister persister)
void | PersistentIdentifierBag.preInsert(CollectionPersister persister)
void | PersistentIdentifierBag.afterRowInsert(CollectionPersister persister, Object entry, int i)
Serializable | PersistentElementHolder.getSnapshot(CollectionPersister persister)
boolean | PersistentElementHolder.equalsSnapshot(CollectionPersister persister)
Object | PersistentElementHolder.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Iterator | PersistentElementHolder.entries(CollectionPersister persister)
void | PersistentElementHolder.beforeInitialize(CollectionPersister persister, int anticipatedSize)
void | PersistentElementHolder.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentElementHolder.disassemble(CollectionPersister persister)
Iterator | PersistentElementHolder.getDeletes(CollectionPersister persister, boolean indexIsFormula)
Object | PersistentElementHolder.getIndex(Object entry, int i, CollectionPersister persister)
void | PersistentCollection.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner) Read the state of the collection from a disassembled cached value
Iterator | PersistentCollection.entries(CollectionPersister persister) Iterate all collection entries, during update of the database
Object | PersistentCollection.readFrom(ResultSet rs, CollectionPersister role, CollectionAliases descriptor, Object owner) Read a row from the JDBC result set
Object | PersistentCollection.getIndex(Object entry, int i, CollectionPersister persister) Get the index of the given collection entry
void | PersistentCollection.beforeInitialize(CollectionPersister persister, int anticipatedSize) Called before any elements are read into the collection, allowing appropriate initializations to occur.
boolean | PersistentCollection.equalsSnapshot(CollectionPersister persister) Does the current state exactly match the snapshot?
Serializable | PersistentCollection.disassemble(CollectionPersister persister) Disassemble the collection, ready for the cache
boolean | PersistentCollection.needsRecreate(CollectionPersister persister) Do we need to completely recreate this collection when it changes?
Serializable | PersistentCollection.getSnapshot(CollectionPersister persister) Return a new snapshot of the current state of the collection
Iterator | PersistentCollection.getDeletes(CollectionPersister persister, boolean indexIsFormula) Get all the elements that need deleting
void | PersistentCollection.preInsert(CollectionPersister persister) Called before inserting rows, to ensure that any surrogate keys are fully generated
void | PersistentCollection.afterRowInsert(CollectionPersister persister, Object entry, int i) Called after inserting a row, to fetch the natively generated id
Iterator | PersistentBag.entries(CollectionPersister persister)
Object | PersistentBag.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
void | PersistentBag.beforeInitialize(CollectionPersister persister, int anticipatedSize)
boolean | PersistentBag.equalsSnapshot(CollectionPersister persister)
Serializable | PersistentBag.getSnapshot(CollectionPersister persister)
Serializable | PersistentBag.disassemble(CollectionPersister persister)
void | PersistentBag.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
boolean | PersistentBag.needsRecreate(CollectionPersister persister)
Iterator | PersistentBag.getDeletes(CollectionPersister persister, boolean indexIsFormula)
Object | PersistentBag.getIndex(Object entry, int i, CollectionPersister persister)
Serializable | PersistentArrayHolder.getSnapshot(CollectionPersister persister)
boolean | PersistentArrayHolder.equalsSnapshot(CollectionPersister persister)
Object | PersistentArrayHolder.readFrom(ResultSet rs, CollectionPersister persister, CollectionAliases descriptor, Object owner)
Iterator | PersistentArrayHolder.entries(CollectionPersister persister)
void | PersistentArrayHolder.beforeInitialize(CollectionPersister persister, int anticipatedSize)
void | PersistentArrayHolder.initializeFromCache(CollectionPersister persister, Serializable disassembled, Object owner)
Serializable | PersistentArrayHolder.disassemble(CollectionPersister persister)
Iterator | PersistentArrayHolder.getDeletes(CollectionPersister persister, boolean indexIsFormula)
Object | PersistentArrayHolder.getIndex(Object entry, int i, CollectionPersister persister)
boolean | AbstractPersistentCollection.needsRecreate(CollectionPersister persister) Do we need to completely recreate this collection when it changes?
void | AbstractPersistentCollection.preInsert(CollectionPersister persister) Called before inserting rows, to ensure that any surrogate keys are fully generated
void | AbstractPersistentCollection.afterRowInsert(CollectionPersister persister, Object entry, int i) Called after inserting a row, to fetch the natively generated id

Constructors in org.hibernate.collection with parameters of type CollectionPersister
PersistentMapElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentListElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentIndexedElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentElementHolder(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentArrayHolder(SessionImplementor session, CollectionPersister persister)

Uses of CollectionPersister in org.hibernate.engine

Methods in org.hibernate.engine that return CollectionPersister
CollectionPersister | SessionFactoryImplementor.getCollectionPersister(String role) Get the persister object for a collection role
CollectionPersister | CollectionEntry.getCurrentPersister()
CollectionPersister | CollectionEntry.getLoadedPersister() This is only available late during the flush cycle

Methods in org.hibernate.engine with parameters of type CollectionPersister
 Object StatefulPersistenceContext.getCollectionOwner(Serializable key, CollectionPersister collectionPersister)
Get the entity that owns this persistent collection
 void StatefulPersistenceContext.addUninitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just loaded up (still needs initializing)
 void StatefulPersistenceContext.addUninitializedDetachedCollection(CollectionPersister persister, PersistentCollection collection)
add a detached uninitialized collection
 void StatefulPersistenceContext.addNewCollection(CollectionPersister persister, PersistentCollection collection)
Add a new collection (ie.
 void StatefulPersistenceContext.addInitializedDetachedCollection(CollectionPersister collectionPersister, PersistentCollection collection)
add an (initialized) collection that was created by another session and passed into update() (ie.
 CollectionEntry StatefulPersistenceContext.addInitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just pulled out of the cache (does not need initializing)
 Object PersistenceContext.getCollectionOwner(Serializable key, CollectionPersister collectionPersister)
Get the entity that owns this persistent collection
 void PersistenceContext.addUninitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just loaded up (still needs initializing)
 void PersistenceContext.addUninitializedDetachedCollection(CollectionPersister persister, PersistentCollection collection)
add a detached uninitialized collection
 void PersistenceContext.addNewCollection(CollectionPersister persister, PersistentCollection collection)
Add a new collection (ie.
 void PersistenceContext.addInitializedDetachedCollection(CollectionPersister collectionPersister, PersistentCollection collection)
add an (initialized) collection that was created by another session and passed into update() (ie.
 CollectionEntry PersistenceContext.addInitializedCollection(CollectionPersister persister, PersistentCollection collection, Serializable id)
add a collection we just pulled out of the cache (does not need initializing)
 PersistentCollection CollectionLoadContext.getLoadingCollection(CollectionPersister persister, Serializable key, Object resultSetId, EntityMode em)
Retrieve a collection that is in the process of being loaded, instantiating a new collection if there is nothing for the given id, or returning null if the collection with the given id is already fully loaded in the session
 PersistentCollection CollectionLoadContext.getLoadingCollection(CollectionPersister persister, Serializable id, EntityMode em)
Retrieve a collection that is in the process of being loaded, returning null if there is no loading collection with the given id
 void CollectionLoadContext.endLoadingCollections(CollectionPersister persister, Object resultSetId, SessionImplementor session)
Finish the process of loading collections for a particular result set
 void CollectionEntry.setCurrentPersister(CollectionPersister currentPersister)
 Serializable[] BatchFetchQueue.getCollectionBatch(CollectionPersister collectionPersister, Serializable id, int batchSize, EntityMode entityMode)
Get a batch of uninitialized collection keys for a given role

Constructors in org.hibernate.engine with parameters of type CollectionPersister
CollectionKey(CollectionPersister persister, Serializable key, EntityMode em)
CollectionEntry(CollectionPersister persister, PersistentCollection collection)
For newly wrapped collections, or dereferenced collection wrappers
CollectionEntry(PersistentCollection collection, CollectionPersister loadedPersister, Serializable loadedKey, boolean ignore)
For collections just loaded from the database
CollectionEntry(CollectionPersister loadedPersister, Serializable loadedKey)
For uninitialized detached collections

Uses of CollectionPersister in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type CollectionPersister
void | ReattachVisitor.removeCollection(CollectionPersister role, Serializable id, EventSource source) Schedules a collection for deletion.
protected static boolean | ProxyVisitor.isOwnerUnchanged(PersistentCollection snapshot, CollectionPersister persister, Serializable id) Has the owner of the collection changed since the collection was snapshotted and detached?

Uses of CollectionPersister in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that return CollectionPersister
 CollectionPersister[] QueryTranslatorImpl.getCollectionPersisters()
Overrides method from Loader

Uses of CollectionPersister in org.hibernate.impl

Methods in org.hibernate.impl that return CollectionPersister
 CollectionPersister SessionFactoryImpl.getCollectionPersister(String role)

Uses of CollectionPersister in org.hibernate.loader

Fields in org.hibernate.loader declared as CollectionPersister
protected CollectionPersister[] | OuterJoinLoader.collectionPersisters
protected CollectionPersister[] | JoinWalker.collectionPersisters

Methods in org.hibernate.loader that return CollectionPersister
protected CollectionPersister[] | OuterJoinLoader.getCollectionPersisters()
protected CollectionPersister[] | Loader.getCollectionPersisters() An (optional) persister for a collection to be initialized; only collection loaders return a non-null value
CollectionPersister[] | JoinWalker.getCollectionPersisters()

Methods in org.hibernate.loader with parameters of type CollectionPersister
 void JoinWalker.setCollectionPersisters(CollectionPersister[] collectionPersisters)

Constructors in org.hibernate.loader with parameters of type CollectionPersister
GeneratedCollectionAliases(Map userProvidedAliases, CollectionPersister persister, String suffix)
GeneratedCollectionAliases(CollectionPersister persister, String string)

Uses of CollectionPersister in org.hibernate.loader.collection

Constructors in org.hibernate.loader.collection with parameters of type CollectionPersister
BatchingCollectionInitializer(CollectionPersister collPersister, int[] batchSizes, Loader[] loaders)

Uses of CollectionPersister in org.hibernate.loader.custom

Methods in org.hibernate.loader.custom that return CollectionPersister
protected  CollectionPersister[] CustomLoader.getCollectionPersisters()

Uses of CollectionPersister in org.hibernate.loader.hql

Methods in org.hibernate.loader.hql that return CollectionPersister
protected  CollectionPersister[] QueryLoader.getCollectionPersisters()
An (optional) persister for a collection to be initialized; only collection loaders return a non-null value

Uses of CollectionPersister in org.hibernate.persister

Methods in org.hibernate.persister that return CollectionPersister
static CollectionPersister PersisterFactory.createCollectionPersister(Configuration cfg, Collection model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory)

Uses of CollectionPersister in org.hibernate.persister.collection

Subinterfaces of CollectionPersister in org.hibernate.persister.collection
interface | QueryableCollection A collection role that may be queried or loaded by outer join.
interface | SQLLoadableCollection

Classes in org.hibernate.persister.collection that implement CollectionPersister
class | AbstractCollectionPersister Base implementation of the QueryableCollection interface.
class | BasicCollectionPersister Collection persister for collections of values and many-to-many associations.
class | OneToManyPersister Collection persister for one-to-many associations.

Constructors in org.hibernate.persister.collection with parameters of type CollectionPersister
NamedQueryCollectionInitializer(String queryName, CollectionPersister persister)

Uses of CollectionPersister in org.hibernate.pretty

Methods in org.hibernate.pretty with parameters of type CollectionPersister
static String | MessageHelper.collectionInfoString(CollectionPersister persister, Serializable[] ids, SessionFactoryImplementor factory) Generate an info message string relating to a series of managed collections.
static String | MessageHelper.collectionInfoString(CollectionPersister persister, Serializable id, SessionFactoryImplementor factory) Generate an info message string relating to a particular managed collection.

Uses of CollectionPersister in org.hibernate.type

Methods in org.hibernate.type with parameters of type CollectionPersister
PersistentCollection | SortedSetType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | SortedMapType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | SetType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | MapType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | ListType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | IdentifierBagType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | CustomCollectionType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
abstract PersistentCollection | CollectionType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key) Instantiate an uninitialized collection wrapper or holder.
PersistentCollection | BagType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)
PersistentCollection | ArrayType.instantiate(SessionImplementor session, CollectionPersister persister, Serializable key)

Uses of CollectionPersister in org.hibernate.usertype

Methods in org.hibernate.usertype with parameters of type CollectionPersister
PersistentCollection | UserCollectionType.instantiate(SessionImplementor session, CollectionPersister persister) Instantiate an uninitialized instance of the collection wrapper
Object | UserCollectionType.replaceElements(Object original, Object target, CollectionPersister persister, Object owner, Map copyCache, SessionImplementor session) Replace the elements of a collection with the elements of another collection

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.collection.CollectionPropertyMapping (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.collection.CollectionPropertyMapping

No usage of org.hibernate.persister.collection.CollectionPropertyMapping

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.collection.CollectionPropertyNames (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.collection.CollectionPropertyNames

No usage of org.hibernate.persister.collection.CollectionPropertyNames

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.collection.CompositeElementPropertyMapping (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.collection.CompositeElementPropertyMapping

No usage of org.hibernate.persister.collection.CompositeElementPropertyMapping

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.collection.ElementPropertyMapping (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.collection.ElementPropertyMapping

No usage of org.hibernate.persister.collection.ElementPropertyMapping

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.collection.NamedQueryCollectionInitializer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.collection.NamedQueryCollectionInitializer

No usage of org.hibernate.persister.collection.NamedQueryCollectionInitializer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.collection.OneToManyPersister (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.collection.OneToManyPersister

No usage of org.hibernate.persister.collection.OneToManyPersister

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.persister.collection.QueryableCollection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.persister.collection.QueryableCollection

Packages that use QueryableCollection
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.

Uses of QueryableCollection in org.hibernate.criterion

Methods in org.hibernate.criterion that return QueryableCollection
protected  QueryableCollection AbstractEmptinessExpression.getQueryableCollection(String entityName, String propertyName, SessionFactoryImplementor factory)

Uses of QueryableCollection in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return QueryableCollection
 QueryableCollection FromElement.getQueryableCollection()

Methods in org.hibernate.hql.ast.tree with parameters of type QueryableCollection
 void FromElement.setQueryableCollection(QueryableCollection queryableCollection)

Uses of QueryableCollection in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util that return QueryableCollection
QueryableCollection | SessionFactoryHelper.getCollectionPersister(String role) Locate the collection persister by the collection role.
QueryableCollection | SessionFactoryHelper.requireQueryableCollection(String role) Locate the collection persister by the collection role, requiring that such a persister exist.

Methods in org.hibernate.hql.ast.util with parameters of type QueryableCollection
 JoinSequence SessionFactoryHelper.createCollectionJoinSequence(QueryableCollection collPersister, String collectionName)
Create a join sequence rooted at the given collection.

Uses of QueryableCollection in org.hibernate.loader

Methods in org.hibernate.loader with parameters of type QueryableCollection
void | OuterJoinableAssociation.addManyToManyJoin(JoinFragment outerjoin, QueryableCollection collection)
protected void | JoinWalker.walkCollectionTree(QueryableCollection persister, String alias) For a collection role, return a list of associations to be fetched by outerjoin

Uses of QueryableCollection in org.hibernate.loader.collection

Methods in org.hibernate.loader.collection with parameters of type QueryableCollection
static CollectionInitializer | BatchingCollectionInitializer.createBatchingOneToManyInitializer(QueryableCollection persister, int maxBatchSize, SessionFactoryImplementor factory, Map enabledFilters)
static CollectionInitializer | BatchingCollectionInitializer.createBatchingCollectionInitializer(QueryableCollection persister, int maxBatchSize, SessionFactoryImplementor factory, Map enabledFilters)

Constructors in org.hibernate.loader.collection with parameters of type QueryableCollection
SubselectOneToManyLoader(QueryableCollection persister, String subquery, Collection entityKeys, QueryParameters queryParameters, Map namedParameterLocMap, SessionFactoryImplementor factory, Map enabledFilters)
SubselectCollectionLoader(QueryableCollection persister, String subquery, Collection entityKeys, QueryParameters queryParameters, Map namedParameterLocMap, SessionFactoryImplementor factory, Map enabledFilters)
OneToManyLoader(QueryableCollection oneToManyPersister, SessionFactoryImplementor session, Map enabledFilters)
OneToManyLoader(QueryableCollection oneToManyPersister, int batchSize, SessionFactoryImplementor factory, Map enabledFilters)
OneToManyLoader(QueryableCollection oneToManyPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)
OneToManyJoinWalker(QueryableCollection oneToManyPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)
CollectionLoader(QueryableCollection collectionPersister, SessionFactoryImplementor factory, Map enabledFilters)
BasicCollectionLoader(QueryableCollection collectionPersister, SessionFactoryImplementor session, Map enabledFilters)
BasicCollectionLoader(QueryableCollection collectionPersister, int batchSize, SessionFactoryImplementor factory, Map enabledFilters)
BasicCollectionLoader(QueryableCollection collectionPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)
BasicCollectionJoinWalker(QueryableCollection collectionPersister, int batchSize, String subquery, SessionFactoryImplementor factory, Map enabledFilters)

Uses of QueryableCollection in org.hibernate.loader.entity

Constructors in org.hibernate.loader.entity with parameters of type QueryableCollection
CollectionElementLoader(QueryableCollection collectionPersister, SessionFactoryImplementor factory, Map enabledFilters)

Uses of QueryableCollection in org.hibernate.persister.collection

Subinterfaces of QueryableCollection in org.hibernate.persister.collection
 interface SQLLoadableCollection

Classes in org.hibernate.persister.collection that implement QueryableCollection
class | AbstractCollectionPersister Base implementation of the QueryableCollection interface.
class | BasicCollectionPersister Collection persister for collections of values and many-to-many associations.
class | OneToManyPersister Collection persister for one-to-many associations.

Constructors in org.hibernate.persister.collection with parameters of type QueryableCollection
CollectionPropertyMapping(QueryableCollection memberPersister)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.persister.collection.SQLLoadableCollection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.persister.collection.SQLLoadableCollection

Packages that use SQLLoadableCollection
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.

Uses of SQLLoadableCollection in org.hibernate.loader.custom

Constructors in org.hibernate.loader.custom with parameters of type SQLLoadableCollection
ColumnCollectionAliases(Map userProvidedAliases, SQLLoadableCollection persister)

Uses of SQLLoadableCollection in org.hibernate.persister.collection

Classes in org.hibernate.persister.collection that implement SQLLoadableCollection
class | AbstractCollectionPersister Base implementation of the QueryableCollection interface.
class | BasicCollectionPersister Collection persister for collections of values and many-to-many associations.
class | OneToManyPersister Collection persister for one-to-many associations.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.persister.entity (Hibernate API Documentation)

 org.hibernate.persister.entity
Interfaces
EntityPersister
Joinable
Loadable
Lockable
OuterJoinLoadable
PropertyMapping
Queryable
SQLLoadable
UniqueKeyLoadable
Classes
AbstractEntityPersister
AbstractPropertyMapping
BasicEntityPropertyMapping
JoinedSubclassEntityPersister
NamedQueryLoader
SingleTableEntityPersister
UnionSubclassEntityPersister


Uses of Class org.hibernate.persister.entity.AbstractEntityPersister (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.entity.AbstractEntityPersister

Packages that use AbstractEntityPersister
org.hibernate.persister.entity This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of AbstractEntityPersister in org.hibernate.persister.entity

Subclasses of AbstractEntityPersister in org.hibernate.persister.entity
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Constructors in org.hibernate.persister.entity with parameters of type AbstractEntityPersister
BasicEntityPropertyMapping(AbstractEntityPersister persister)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.entity.AbstractPropertyMapping (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.entity.AbstractPropertyMapping

Packages that use AbstractPropertyMapping
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of AbstractPropertyMapping in org.hibernate.persister.collection

Subclasses of AbstractPropertyMapping in org.hibernate.persister.collection
 class CompositeElementPropertyMapping

Uses of AbstractPropertyMapping in org.hibernate.persister.entity

Subclasses of AbstractPropertyMapping in org.hibernate.persister.entity
 class BasicEntityPropertyMapping

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.entity.BasicEntityPropertyMapping (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.entity.BasicEntityPropertyMapping

Packages that use BasicEntityPropertyMapping
org.hibernate.persister.entity This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of BasicEntityPropertyMapping in org.hibernate.persister.entity

Fields in org.hibernate.persister.entity declared as BasicEntityPropertyMapping
protected  BasicEntityPropertyMapping AbstractEntityPersister.propertyMapping

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.persister.entity.EntityPersister (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.persister.entity.EntityPersister

Packages that use EntityPersister
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.cache.entry | This package defines formats for disassembled state kept in the second level cache.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event | This package defines an event framework for Hibernate.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.persister | A persister defines a mapping strategy for a collection or entity.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.pretty | Classes for pretty printing things for exception and log messages.

Uses of EntityPersister in org.hibernate.action

Methods in org.hibernate.action that return EntityPersister
protected  EntityPersister EntityAction.getPersister()

Constructors in org.hibernate.action with parameters of type EntityPersister
EntityUpdateAction(Serializable id, Object[] state, int[] dirtyProperties, boolean hasDirtyCollection, Object[] previousState, Object previousVersion, Object nextVersion, Object instance, Object rowId, EntityPersister persister, SessionImplementor session)
EntityInsertAction(Serializable id, Object[] state, Object instance, Object version, EntityPersister persister, SessionImplementor session)
EntityIdentityInsertAction(Object[] state, Object instance, EntityPersister persister, SessionImplementor session, boolean isDelayed)
EntityDeleteAction(Serializable id, Object[] state, Object version, Object instance, EntityPersister persister, boolean isCascadeDeleteEnabled, SessionImplementor session)
EntityAction(SessionImplementor session, Serializable id, Object instance, EntityPersister persister)

Uses of EntityPersister in org.hibernate.cache.entry

Methods in org.hibernate.cache.entry with parameters of type EntityPersister
 Object[] CacheEntry.assemble(Object instance, Serializable id, EntityPersister persister, Interceptor interceptor, EventSource session)

Constructors in org.hibernate.cache.entry with parameters of type EntityPersister
StructuredCacheEntry(EntityPersister persister)
CacheEntry(Object[] state, EntityPersister persister, boolean unfetched, Object version, SessionImplementor session, Object owner)

Uses of EntityPersister in org.hibernate.engine

Methods in org.hibernate.engine that return EntityPersister
EntityPersister | SessionImplementor.getEntityPersister(String entityName, Object object) Get the EntityPersister for any instance
EntityPersister | SessionFactoryImplementor.getEntityPersister(String entityName) Get the persister for the named entity
EntityPersister | EntityEntry.getPersister()

Methods in org.hibernate.engine with parameters of type EntityPersister
static void Versioning.setVersion(Object[] fields, Object version, EntityPersister persister)
Set the version number of the given instance state snapshot
static Object Versioning.getVersion(Object[] fields, EntityPersister persister)
Get the version number of the given instance state snapshot
static void TwoPhaseLoad.postHydrate(EntityPersister persister, Serializable id, Object[] values, Object rowId, Object object, LockMode lockMode, boolean lazyPropertiesAreUnfetched, SessionImplementor session)
Register the "hydrated" state of an entity instance, after the first step of 2-phase loading.
static void TwoPhaseLoad.addUninitializedEntity(EntityKey key, Object object, EntityPersister persister, LockMode lockMode, boolean lazyPropertiesAreUnfetched, SessionImplementor session)
Add an uninitialized instance of an entity class, as a placeholder to ensure object identity.
static void TwoPhaseLoad.addUninitializedCachedEntity(EntityKey key, Object object, EntityPersister persister, LockMode lockMode, boolean lazyPropertiesAreUnfetched, Object version, SessionImplementor session)
 Object[] StatefulPersistenceContext.getDatabaseSnapshot(Serializable id, EntityPersister persister)
Get the current state of the entity as known to the underlying database, or null if there is no corresponding row
 Object[] StatefulPersistenceContext.getNaturalIdSnapshot(Serializable id, EntityPersister persister)
 EntityEntry StatefulPersistenceContext.addEntity(Object entity, Status status, Object[] loadedState, EntityKey entityKey, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched)
Adds an entity to the internal caches.
 EntityEntry StatefulPersistenceContext.addEntry(Object entity, Status status, Object[] loadedState, Object rowId, Serializable id, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched)
Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.
 Object StatefulPersistenceContext.narrowProxy(Object proxy, EntityPersister persister, EntityKey key, Object object)
If the existing proxy is insufficiently "narrow" (derived), instantiate a new proxy and overwrite the registration of the old one.
 Object StatefulPersistenceContext.proxyFor(EntityPersister persister, EntityKey key, Object impl)
Return the existing proxy associated with the given EntityKey, or the third argument (the entity associated with the key) if no proxy exists.
 Object[] PersistenceContext.getDatabaseSnapshot(Serializable id, EntityPersister persister)
Get the current state of the entity as known to the underlying database, or null if there is no corresponding row
 Object[] PersistenceContext.getNaturalIdSnapshot(Serializable id, EntityPersister persister)
 EntityEntry PersistenceContext.addEntity(Object entity, Status status, Object[] loadedState, EntityKey entityKey, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched)
Adds an entity to the internal caches.
 EntityEntry PersistenceContext.addEntry(Object entity, Status status, Object[] loadedState, Object rowId, Serializable id, Object version, LockMode lockMode, boolean existsInDatabase, EntityPersister persister, boolean disableVersionIncrement, boolean lazyPropertiesAreUnfetched)
Generates an appropriate EntityEntry instance and adds it to the event source's internal caches.
 Object PersistenceContext.narrowProxy(Object proxy, EntityPersister persister, EntityKey key, Object object)
If the existing proxy is insufficiently "narrow" (derived), instantiate a new proxy and overwrite the registration of the old one.
 Object PersistenceContext.proxyFor(EntityPersister persister, EntityKey key, Object impl)
Return the existing proxy associated with the given EntityKey, or the third argument (the entity associated with the key) if no proxy exists.
 void Nullability.checkNullability(Object[] values, EntityPersister persister, boolean isUpdate)
Check nullability of the class persister properties
 void CascadingAction.noCascade(EventSource session, Object child, Object parent, EntityPersister persister, int propertyIndex)
Called (in the case of CascadingAction.requiresNoCascadeChecking() returning true) to validate that no cascade on the given property is considered a valid semantic.
 void Cascade.cascade(EntityPersister persister, Object parent)
Cascade an action from the parent entity instance to all its children.
 void Cascade.cascade(EntityPersister persister, Object parent, Object anything)
Cascade an action from the parent entity instance to all its children.
 Serializable[] BatchFetchQueue.getEntityBatch(EntityPersister persister, Serializable id, int batchSize, EntityMode entityMode)
Get a batch of unloaded identifiers for this class, using a slightly complex algorithm that tries to grab keys registered immediately after the given key.

Constructors in org.hibernate.engine with parameters of type EntityPersister
EntityKey(Serializable id, EntityPersister persister, EntityMode entityMode)
Construct a unique identifier for an entity class instance

Uses of EntityPersister in org.hibernate.event

Methods in org.hibernate.event that return EntityPersister
EntityPersister | PreUpdateEvent.getPersister()
EntityPersister | PreLoadEvent.getPersister()
EntityPersister | PreInsertEvent.getPersister()
EntityPersister | PreDeleteEvent.getPersister()
EntityPersister | PostUpdateEvent.getPersister()
EntityPersister | PostLoadEvent.getPersister()
EntityPersister | PostInsertEvent.getPersister()
EntityPersister | PostDeleteEvent.getPersister()

Methods in org.hibernate.event with parameters of type EntityPersister
PreLoadEvent | PreLoadEvent.setPersister(EntityPersister persister)
PostLoadEvent | PostLoadEvent.setPersister(EntityPersister persister)
Object | EventSource.instantiate(EntityPersister persister, Serializable id) Instantiate an entity instance, using either an interceptor, or the given persister

Constructors in org.hibernate.event with parameters of type EntityPersister
PreUpdateEvent(Object entity, Serializable id, Object[] state, Object[] oldState, EntityPersister persister, SessionImplementor source)
PreInsertEvent(Object entity, Serializable id, Object[] state, EntityPersister persister, SessionImplementor source)
PreDeleteEvent(Object entity, Serializable id, Object[] deletedState, EntityPersister persister)
PostUpdateEvent(Object entity, Serializable id, Object[] state, Object[] oldState, EntityPersister persister, EventSource source)
PostInsertEvent(Object entity, Serializable id, Object[] state, EntityPersister persister)
PostDeleteEvent(Object entity, Serializable id, Object[] deletedState, EntityPersister persister)

Uses of EntityPersister in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type EntityPersister
protected Serializable | DefaultUpdateEventListener.getUpdateId(Object entity, EntityPersister persister, Serializable requestedId, EntityMode entityMode) If the user specified an id, assign it to the instance and use that, otherwise use the id already assigned to the instance
protected Serializable | DefaultSaveOrUpdateEventListener.getUpdateId(Object entity, EntityPersister persister, Serializable requestedId, EntityMode entityMode)
protected void | DefaultSaveOrUpdateEventListener.performUpdate(SaveOrUpdateEvent event, Object entity, EntityPersister persister)
protected boolean | DefaultSaveOrUpdateEventListener.invokeUpdateLifecycle(Object entity, EntityPersister persister, EventSource source)
protected boolean | DefaultReplicateEventListener.substituteValuesIfNecessary(Object entity, Serializable id, Object[] values, EntityPersister persister, SessionImplementor source)
protected void | DefaultMergeEventListener.copyValues(EntityPersister persister, Object entity, Object target, SessionImplementor source, Map copyCache)
protected void | DefaultMergeEventListener.copyValues(EntityPersister persister, Object entity, Object target, SessionImplementor source, Map copyCache, ForeignKeyDirection foreignKeyDirection)
protected void | DefaultMergeEventListener.cascadeOnMerge(EventSource source, EntityPersister persister, Object entity, Map copyCache) Perform any cascades needed as part of this copy event.
protected void | DefaultMergeEventListener.cascadeAfterSave(EventSource source, EntityPersister persister, Object entity, Object anything) Cascade behavior is redefined by this subclass, disable superclass behavior
protected void | DefaultMergeEventListener.cascadeBeforeSave(EventSource source, EntityPersister persister, Object entity, Object anything) Cascade behavior is redefined by this subclass, disable superclass behavior
protected Object | DefaultLoadEventListener.load(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Perfoms the load of an entity.
protected Object | DefaultLoadEventListener.proxyOrLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Based on configured options, will either return a pre-existing proxy, generate a new proxy, or perform an actual load.
protected Object | DefaultLoadEventListener.lockAndLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options, SessionImplementor source) If the class to be loaded has been configured with a cache, then lock given id in that cache and then perform the load.
protected Object | DefaultLoadEventListener.doLoad(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Coordinates the efforts to load a given entity.
protected Object | DefaultLoadEventListener.loadFromDatasource(LoadEvent event, EntityPersister persister, EntityKey keyToLoad, LoadEventListener.LoadType options) Performs the process of loading an entity from the configured underlying datasource.
protected Object | DefaultLoadEventListener.loadFromSecondLevelCache(LoadEvent event, EntityPersister persister, LoadEventListener.LoadType options) Attempts to load the entity from the second-level cache.
void | DefaultFlushEntityEventListener.checkId(Object object, EntityPersister persister, Serializable id, EntityMode entityMode) make sure user didn't mangle the id
protected void | DefaultFlushEntityEventListener.validate(Object entity, EntityPersister persister, Status status, EntityMode entityMode)
protected boolean | DefaultFlushEntityEventListener.invokeInterceptor(SessionImplementor session, Object entity, EntityEntry entry, Object[] values, EntityPersister persister)
protected void | DefaultEvictEventListener.doEvict(Object object, EntityKey key, EntityPersister persister, EventSource session)
protected void | DefaultDeleteEventListener.deleteTransientEntity(EventSource session, Object entity, boolean cascadeDeleteEnabled, EntityPersister persister, Set transientEntities) We encountered a delete request on a transient instance.
protected void | DefaultDeleteEventListener.deleteEntity(EventSource session, Object entity, EntityEntry entityEntry, boolean isCascadeDeleteEnabled, EntityPersister persister, Set transientEntities)
protected boolean | DefaultDeleteEventListener.invokeDeleteLifecycle(EventSource session, Object entity, EntityPersister persister)
protected void | DefaultDeleteEventListener.cascadeBeforeDelete(EventSource session, EntityPersister persister, Object entity, EntityEntry entityEntry, Set transientEntities)
protected void | DefaultDeleteEventListener.cascadeAfterDelete(EventSource session, EntityPersister persister, Object entity, Set transientEntities)
protected Serializable | AbstractSaveEventListener.performSave(Object entity, Serializable id, EntityPersister persister, boolean useIdentityColumn, Object anything, EventSource source, boolean requiresImmediateIdAccess) Ppepares the save call by checking the session caches for a pre-existing entity and performing any lifecycle callbacks.
protected boolean | AbstractSaveEventListener.invokeSaveLifecycle(Object entity, EntityPersister persister, EventSource source)
protected void | AbstractSaveEventListener.validate(Object entity, EntityPersister persister, EventSource source)
protected Serializable | AbstractSaveEventListener.performSaveOrReplicate(Object entity, EntityKey key, EntityPersister persister, boolean useIdentityColumn, Object anything, EventSource source, boolean requiresImmediateIdAccess) Performs all the actual work needed to save an entity (well to get the save moved to the execution queue).
protected boolean | AbstractSaveEventListener.substituteValuesIfNecessary(Object entity, Serializable id, Object[] values, EntityPersister persister, SessionImplementor source) Perform any property value substitution that is necessary (interceptor callback, version initialization...)
protected void | AbstractSaveEventListener.cascadeBeforeSave(EventSource source, EntityPersister persister, Object entity, Object anything) Handles the calls needed to perform pre-save cascades for the given entity.
protected void | AbstractSaveEventListener.cascadeAfterSave(EventSource source, EntityPersister persister, Object entity, Object anything) Handles to calls needed to perform post-save cascades.
protected EntityEntry | AbstractReassociateEventListener.reassociate(AbstractEvent event, Object object, Serializable id, EntityPersister persister) Associates a given entity (either transient or associated with another session) to the given session.

Uses of EntityPersister in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return EntityPersister
 EntityPersister FromElement.getEntityPersister()

Methods in org.hibernate.hql.ast.tree with parameters of type EntityPersister
 void FromElement.initializeEntity(FromClause fromClause, String className, EntityPersister persister, EntityType type, String classAlias, String tableAlias)

Uses of EntityPersister in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util that return EntityPersister
 EntityPersister SessionFactoryHelper.requireClassPersister(String name)
Locate the persister by class or entity name, requiring that such a persister exist.

Uses of EntityPersister in org.hibernate.id

Subinterfaces of EntityPersister in org.hibernate.id
 interface PostInsertIdentityPersister
A persister that may have an identity assigned by execution of a SQL INSERT.

Uses of EntityPersister in org.hibernate.impl

Methods in org.hibernate.impl that return EntityPersister
EntityPersister | StatelessSessionImpl.getEntityPersister(String entityName, Object object)
EntityPersister | SessionImpl.getEntityPersister(String entityName, Object object)
EntityPersister | SessionFactoryImpl.getEntityPersister(String entityName)

Methods in org.hibernate.impl with parameters of type EntityPersister
 Object SessionImpl.instantiate(EntityPersister persister, Serializable id)
give the interceptor an opportunity to override the default instantiation

Uses of EntityPersister in org.hibernate.loader

Methods in org.hibernate.loader with parameters of type EntityPersister
protected List | Loader.loadEntity(SessionImplementor session, Object id, Type identifierType, Object optionalObject, String optionalEntityName, Serializable optionalIdentifier, EntityPersister persister) Called by subclasses that load entities
protected List | Loader.loadEntity(SessionImplementor session, Object key, Object index, Type keyType, Type indexType, EntityPersister persister) Called by subclasses that load entities
List | Loader.loadEntityBatch(SessionImplementor session, Serializable[] ids, Type idType, Object optionalObject, String optionalEntityName, Serializable optionalId, EntityPersister persister) Called by wrappers that batch load entities

Uses of EntityPersister in org.hibernate.loader.entity

Constructors in org.hibernate.loader.entity with parameters of type EntityPersister
BatchingEntityLoader(EntityPersister persister, int[] batchSizes, Loader[] loaders)

Uses of EntityPersister in org.hibernate.persister

Methods in org.hibernate.persister that return EntityPersister
static EntityPersister PersisterFactory.createClassPersister(PersistentClass model, CacheConcurrencyStrategy cache, SessionFactoryImplementor factory, Mapping cfg)

Uses of EntityPersister in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that return EntityPersister
EntityPersister | QueryableCollection.getElementPersister() Get the persister of the element class, if this is a collection of entities (optional operation).
EntityPersister | CollectionPersister.getOwnerEntityPersister() Get the persister of the entity that "owns" this collection
EntityPersister | AbstractCollectionPersister.getOwnerEntityPersister()
EntityPersister | AbstractCollectionPersister.getElementPersister()

Uses of EntityPersister in org.hibernate.persister.entity

Subinterfaces of EntityPersister in org.hibernate.persister.entity
interface | Loadable Implemented by a EntityPersister that may be loaded using Loader.
interface | Lockable Contract for things that can be locked via a LockingStrategy
interface | OuterJoinLoadable A EntityPersister that may be loaded by outer join using the OuterJoinLoader hierarchy and may be an element of a one-to-many association.
interface | Queryable Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language
interface | SQLLoadable A class persister that supports queries expressed in the platform native SQL dialect
interface | UniqueKeyLoadable

Classes in org.hibernate.persister.entity that implement EntityPersister
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Methods in org.hibernate.persister.entity that return EntityPersister
EntityPersister | EntityPersister.getSubclassEntityPersister(Object instance, SessionFactoryImplementor factory, EntityMode entityMode) Get the persister for an instance of this class or a subclass
EntityPersister | AbstractEntityPersister.getSubclassEntityPersister(Object instance, SessionFactoryImplementor factory, EntityMode entityMode)

Constructors in org.hibernate.persister.entity with parameters of type EntityPersister
NamedQueryLoader(String queryName, EntityPersister persister)

Uses of EntityPersister in org.hibernate.pretty

Methods in org.hibernate.pretty with parameters of type EntityPersister
static String | MessageHelper.infoString(EntityPersister persister, Object id, SessionFactoryImplementor factory) Generate an info message string relating to a particular entity.
static String | MessageHelper.infoString(EntityPersister persister, Object id, Type identifierType, SessionFactoryImplementor factory) Generate an info message string relating to a particular entity,.
static String | MessageHelper.infoString(EntityPersister persister, Serializable[] ids, SessionFactoryImplementor factory) Generate an info message string relating to a series of entities.
static String | MessageHelper.infoString(EntityPersister persister) Generate an info message string relating to given entity persister.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.persister.entity.Joinable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.persister.entity.Joinable

Packages that use Joinable
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of Joinable in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type Joinable
 JoinSequence JoinSequence.setRoot(Joinable joinable, String alias)

Uses of Joinable in org.hibernate.loader

Methods in org.hibernate.loader that return Joinable
 Joinable OuterJoinableAssociation.getJoinable()

Methods in org.hibernate.loader with parameters of type Joinable
protected  String JoinWalker.generateTableAlias(int n, String path, Joinable joinable)

Uses of Joinable in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria with parameters of type Joinable
protected  String CriteriaJoinWalker.generateTableAlias(int n, String path, Joinable joinable)

Uses of Joinable in org.hibernate.persister.collection

Subinterfaces of Joinable in org.hibernate.persister.collection
interface | QueryableCollection A collection role that may be queried or loaded by outer join.
interface | SQLLoadableCollection

Classes in org.hibernate.persister.collection that implement Joinable
class | AbstractCollectionPersister Base implementation of the QueryableCollection interface.
class | BasicCollectionPersister Collection persister for collections of values and many-to-many associations.
class | OneToManyPersister Collection persister for one-to-many associations.

Methods in org.hibernate.persister.collection with parameters of type Joinable
String | OneToManyPersister.selectFragment(Joinable rhs, String rhsAlias, String lhsAlias, String entitySuffix, String collectionSuffix, boolean includeCollectionColumns)
String | BasicCollectionPersister.selectFragment(Joinable rhs, String rhsAlias, String lhsAlias, String entitySuffix, String collectionSuffix, boolean includeCollectionColumns)

Uses of Joinable in org.hibernate.persister.entity

Subinterfaces of Joinable in org.hibernate.persister.entity
interface | OuterJoinLoadable A EntityPersister that may be loaded by outer join using the OuterJoinLoader hierarchy and may be an element of a one-to-many association.
interface | Queryable Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language

Classes in org.hibernate.persister.entity that implement Joinable
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Methods in org.hibernate.persister.entity with parameters of type Joinable
String | Joinable.selectFragment(Joinable rhs, String rhsAlias, String lhsAlias, String currentEntitySuffix, String currentCollectionSuffix, boolean includeCollectionColumns) All columns to select, when loading.
String | AbstractEntityPersister.selectFragment(Joinable rhs, String rhsAlias, String lhsAlias, String entitySuffix, String collectionSuffix, boolean includeCollectionColumns)

Uses of Joinable in org.hibernate.type

Methods in org.hibernate.type that return Joinable
Joinable | EntityType.getAssociatedJoinable(SessionFactoryImplementor factory)
Joinable | CollectionType.getAssociatedJoinable(SessionFactoryImplementor factory)
Joinable | AssociationType.getAssociatedJoinable(SessionFactoryImplementor factory) Get the "persister" for this association - a class or collection persister
Joinable | AnyType.getAssociatedJoinable(SessionFactoryImplementor factory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.entity.JoinedSubclassEntityPersister (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.entity.JoinedSubclassEntityPersister

No usage of org.hibernate.persister.entity.JoinedSubclassEntityPersister

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.persister.entity.Loadable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.persister.entity.Loadable

Packages that use Loadable
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of Loadable in org.hibernate.engine

Constructors in org.hibernate.engine with parameters of type Loadable
SubselectFetch(String alias, Loadable loadable, QueryParameters queryParameters, Set resultingEntityKeys, Map namedParameterLocMap)

Uses of Loadable in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that return Loadable
protected  Loadable[] QueryTranslatorImpl.getEntityPersisters()
Persisters for the return values of a find() style query.

Uses of Loadable in org.hibernate.loader

Fields in org.hibernate.loader declared as Loadable
protected Loadable[] | OuterJoinLoader.persisters
protected Loadable[] | JoinWalker.persisters

Methods in org.hibernate.loader that return Loadable
protected Loadable[] | OuterJoinLoader.getEntityPersisters()
protected abstract Loadable[] | Loader.getEntityPersisters() An array of persisters of entity classes contained in each row of results; implemented by all subclasses
Loadable[] | JoinWalker.getPersisters()
protected Loadable | AbstractEntityJoinWalker.getPersister()

Methods in org.hibernate.loader with parameters of type Loadable
void | JoinWalker.setPersisters(Loadable[] persisters)
String[][] | EntityAliases.getSuffixedPropertyAliases(Loadable persister) The result set column aliases for the property columns of a subclass
protected String | DefaultEntityAliases.getDiscriminatorAlias(Loadable persister, String suffix)
protected String[] | DefaultEntityAliases.getIdentifierAliases(Loadable persister, String suffix)
protected String[] | DefaultEntityAliases.getPropertyAliases(Loadable persister, int j)
String[][] | DefaultEntityAliases.getSuffixedPropertyAliases(Loadable persister)
protected String[] | ColumnEntityAliases.getIdentifierAliases(Loadable persister, String suffix)
protected String | ColumnEntityAliases.getDiscriminatorAlias(Loadable persister, String suffix)
protected String[] | ColumnEntityAliases.getPropertyAliases(Loadable persister, int j)

Constructors in org.hibernate.loader with parameters of type Loadable
DefaultEntityAliases(Loadable persister, String suffix)
DefaultEntityAliases(Map userProvidedAliases, Loadable persister, String suffix)
Calculate and cache select-clause suffixes.
ColumnEntityAliases(Map returnProperties, Loadable persister, String suffix)

Uses of Loadable in org.hibernate.loader.custom

Methods in org.hibernate.loader.custom that return Loadable
protected  Loadable[] CustomLoader.getEntityPersisters()

Uses of Loadable in org.hibernate.loader.hql

Methods in org.hibernate.loader.hql that return Loadable
 Loadable[] QueryLoader.getEntityPersisters()

Uses of Loadable in org.hibernate.persister.entity

Subinterfaces of Loadable in org.hibernate.persister.entity
interface | OuterJoinLoadable A EntityPersister that may be loaded by outer join using the OuterJoinLoader hierarchy and may be an element of a one-to-many association.
interface | Queryable Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language
interface | SQLLoadable A class persister that supports queries expressed in the platform native SQL dialect
interface | UniqueKeyLoadable

Classes in org.hibernate.persister.entity that implement Loadable
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Methods in org.hibernate.persister.entity with parameters of type Loadable
Object[] | Loadable.hydrate(ResultSet rs, Serializable id, Object object, Loadable rootLoadable, String[][] suffixedPropertyColumns, boolean allProperties, SessionImplementor session) Retrieve property values from one row of a result set
Object[] | AbstractEntityPersister.hydrate(ResultSet rs, Serializable id, Object object, Loadable rootLoadable, String[][] suffixedPropertyColumns, boolean allProperties, SessionImplementor session) Unmarshall the fields of a persistent instance from a result set, without resolving associations or collections.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.persister.entity.Lockable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.persister.entity.Lockable

Packages that use Lockable
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.lock |
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of Lockable in org.hibernate.dialect

Methods in org.hibernate.dialect with parameters of type Lockable
LockingStrategy | TimesTenDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | RDMSOS2200Dialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | PointbaseDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | MckoiDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | HSQLDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | FrontBaseDialect.getLockingStrategy(Lockable lockable, LockMode lockMode)
LockingStrategy | Dialect.getLockingStrategy(Lockable lockable, LockMode lockMode) Get a strategy instance which knows how to acquire a database-level lock of the specified mode for this dialect.

Constructors in org.hibernate.dialect with parameters of type Lockable
HSQLDialect.ReadUncommittedLockingStrategy(Lockable lockable, LockMode lockMode)

Uses of Lockable in org.hibernate.dialect.lock

Constructors in org.hibernate.dialect.lock with parameters of type Lockable
UpdateLockingStrategy(Lockable lockable, LockMode lockMode)
Construct a locking strategy based on SQL UPDATE statements.
SelectLockingStrategy(Lockable lockable, LockMode lockMode)
Construct a locking strategy based on SQL SELECT statements.

Uses of Lockable in org.hibernate.persister.entity

Classes in org.hibernate.persister.entity that implement Lockable
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.entity.NamedQueryLoader (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.entity.NamedQueryLoader

No usage of org.hibernate.persister.entity.NamedQueryLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.persister.entity.OuterJoinLoadable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.persister.entity.OuterJoinLoadable

Packages that use OuterJoinLoadable
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of OuterJoinLoadable in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type OuterJoinLoadable
static String[] | JoinHelper.getAliasedLHSColumnNames(AssociationType type, String alias, int property, OuterJoinLoadable lhsPersister, Mapping mapping) Get the aliased columns of the owning entity which are to be used in the join
static String[] | JoinHelper.getLHSColumnNames(AssociationType type, int property, OuterJoinLoadable lhsPersister, Mapping mapping) Get the columns of the owning entity which are to be used in the join
static String[] | JoinHelper.getAliasedLHSColumnNames(AssociationType type, String alias, int property, int begin, OuterJoinLoadable lhsPersister, Mapping mapping) Get the aliased columns of the owning entity which are to be used in the join
static String[] | JoinHelper.getLHSColumnNames(AssociationType type, int property, int begin, OuterJoinLoadable lhsPersister, Mapping mapping) Get the columns of the owning entity which are to be used in the join
static String | JoinHelper.getLHSTableName(AssociationType type, int property, OuterJoinLoadable lhsPersister)

Uses of OuterJoinLoadable in org.hibernate.loader

Methods in org.hibernate.loader with parameters of type OuterJoinLoadable
protected  void JoinWalker.walkEntityTree(OuterJoinLoadable persister, String alias)
For an entity class, return a list of associations to be fetched by outerjoin

Constructors in org.hibernate.loader with parameters of type OuterJoinLoadable
AbstractEntityJoinWalker(OuterJoinLoadable persister, SessionFactoryImplementor factory, Map enabledFilters)

Uses of OuterJoinLoadable in org.hibernate.loader.criteria

Constructors in org.hibernate.loader.criteria with parameters of type OuterJoinLoadable
CriteriaLoader(OuterJoinLoadable persister, SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, Map enabledFilters)
CriteriaJoinWalker(OuterJoinLoadable persister, CriteriaQueryTranslator translator, SessionFactoryImplementor factory, CriteriaImpl criteria, String rootEntityName, Map enabledFilters)

Uses of OuterJoinLoadable in org.hibernate.loader.entity

Fields in org.hibernate.loader.entity declared as OuterJoinLoadable
protected  OuterJoinLoadable AbstractEntityLoader.persister

Methods in org.hibernate.loader.entity with parameters of type OuterJoinLoadable
static UniqueEntityLoader BatchingEntityLoader.createBatchingEntityLoader(OuterJoinLoadable persister, int maxBatchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)

Constructors in org.hibernate.loader.entity with parameters of type OuterJoinLoadable
EntityLoader(OuterJoinLoadable persister, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityLoader(OuterJoinLoadable persister, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityLoader(OuterJoinLoadable persister, String[] uniqueKey, Type uniqueKeyType, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
EntityJoinWalker(OuterJoinLoadable persister, String[] uniqueKey, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
CascadeEntityLoader(OuterJoinLoadable persister, CascadingAction action, SessionFactoryImplementor factory)
CascadeEntityJoinWalker(OuterJoinLoadable persister, CascadingAction action, SessionFactoryImplementor factory)
AbstractEntityLoader(OuterJoinLoadable persister, Type uniqueKeyType, SessionFactoryImplementor factory, Map enabledFilters)

Uses of OuterJoinLoadable in org.hibernate.persister.entity

Classes in org.hibernate.persister.entity that implement OuterJoinLoadable
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.persister.entity.PropertyMapping (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.persister.entity.PropertyMapping

Packages that use PropertyMapping
org.hibernate.hql.ast.tree |
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of PropertyMapping in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return PropertyMapping
 PropertyMapping FromElement.getPropertyMapping(String propertyName)

Uses of PropertyMapping in org.hibernate.persister.collection

Subinterfaces of PropertyMapping in org.hibernate.persister.collection
interface | QueryableCollection A collection role that may be queried or loaded by outer join.
interface | SQLLoadableCollection

Classes in org.hibernate.persister.collection that implement PropertyMapping
class | AbstractCollectionPersister Base implementation of the QueryableCollection interface.
class | BasicCollectionPersister Collection persister for collections of values and many-to-many associations.
class | CollectionPropertyMapping
class | CompositeElementPropertyMapping
class | ElementPropertyMapping
class | OneToManyPersister Collection persister for one-to-many associations.

Uses of PropertyMapping in org.hibernate.persister.entity

Subinterfaces of PropertyMapping in org.hibernate.persister.entity
 interface Queryable
Extends the generic EntityPersister contract to add operations required by the Hibernate Query Language

Classes in org.hibernate.persister.entity that implement PropertyMapping
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | AbstractPropertyMapping Base implementation of a PropertyMapping
class | BasicEntityPropertyMapping
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.persister.entity.Queryable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.persister.entity.Queryable

Packages that use Queryable
org.hibernate.action | This package defines "actions" that are scheduled for asycnchronous execution by the event listeners.
org.hibernate.hql.ast.exec |
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of Queryable in org.hibernate.action

Constructors in org.hibernate.action with parameters of type Queryable
BulkOperationCleanupAction(SessionImplementor session, Queryable[] affectedQueryables)

Uses of Queryable in org.hibernate.hql.ast.exec

Methods in org.hibernate.hql.ast.exec that return Queryable
Queryable | MultiTableUpdateExecutor.getAffectedQueryable()
protected Queryable[] | MultiTableUpdateExecutor.getAffectedQueryables()
protected Queryable[] | MultiTableDeleteExecutor.getAffectedQueryables()
protected Queryable[] | BasicExecutor.getAffectedQueryables()
protected abstract Queryable[] | AbstractStatementExecutor.getAffectedQueryables()

Methods in org.hibernate.hql.ast.exec with parameters of type Queryable
protected String | AbstractStatementExecutor.generateIdInsertSelect(Queryable persister, String tableAlias, antlr.collections.AST whereClause)
protected String | AbstractStatementExecutor.generateIdSubselect(Queryable persister)
protected void | AbstractStatementExecutor.createTemporaryTableIfNecessary(Queryable persister, SessionImplementor session)
protected void | AbstractStatementExecutor.dropTemporaryTableIfNecessary(Queryable persister, SessionImplementor session)

Constructors in org.hibernate.hql.ast.exec with parameters of type Queryable
BasicExecutor(HqlSqlWalker walker, Queryable persister)

Uses of Queryable in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return Queryable
Queryable | IntoClause.getQueryable()
Queryable | FromElement.getQueryable()

Methods in org.hibernate.hql.ast.tree with parameters of type Queryable
 void IntoClause.initialize(Queryable persister)

Constructors in org.hibernate.hql.ast.tree with parameters of type Queryable
AssignmentSpecification(antlr.collections.AST eq, Queryable persister)

Uses of Queryable in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util that return Queryable
Queryable | SessionFactoryHelper.findQueryableUsingImports(String className) Given a (potentially unqualified) class name, locate its persister.
static Queryable | SessionFactoryHelper.findQueryableUsingImports(SessionFactoryImplementor sfi, String className) Given a (potentially unqualified) class name, locate its persister.

Methods in org.hibernate.hql.ast.util with parameters of type Queryable
void | SyntheticAndFactory.addDiscriminatorWhereFragment(RestrictableStatement statement, Queryable persister, Map enabledFilters, String alias)
boolean | SessionFactoryHelper.hasPhysicalDiscriminatorColumn(Queryable persister) Does the given persister define a physical discriminator column for the purpose of inheritence discrimination?

Uses of Queryable in org.hibernate.persister.entity

Classes in org.hibernate.persister.entity that implement Queryable
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.entity.SingleTableEntityPersister (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.entity.SingleTableEntityPersister

No usage of org.hibernate.persister.entity.SingleTableEntityPersister

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.persister.entity.SQLLoadable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.persister.entity.SQLLoadable

Packages that use SQLLoadable
org.hibernate.persister.entity This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of SQLLoadable in org.hibernate.persister.entity

Classes in org.hibernate.persister.entity that implement SQLLoadable
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.persister.entity.UnionSubclassEntityPersister (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.persister.entity.UnionSubclassEntityPersister

No usage of org.hibernate.persister.entity.UnionSubclassEntityPersister

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.persister.entity.UniqueKeyLoadable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.persister.entity.UniqueKeyLoadable

Packages that use UniqueKeyLoadable
org.hibernate.persister.entity This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.

Uses of UniqueKeyLoadable in org.hibernate.persister.entity

Classes in org.hibernate.persister.entity that implement UniqueKeyLoadable
class | AbstractEntityPersister Basic functionality for persisting an entity via JDBC through either generated or custom SQL
class | JoinedSubclassEntityPersister An EntityPersister implementing the normalized "table-per-subclass" mapping strategy
class | SingleTableEntityPersister The default implementation of the EntityPersister interface.
class | UnionSubclassEntityPersister Implementation of the "table-per-concrete-class" or "roll-down" mapping strategy for an entity and its inheritence hierarchy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.pretty (Hibernate API Documentation)

 org.hibernate.pretty
Classes
DDLFormatter
Formatter
MessageHelper
Printer


Uses of Class org.hibernate.pretty.DDLFormatter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.pretty.DDLFormatter

No usage of org.hibernate.pretty.DDLFormatter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.pretty.Formatter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.pretty.Formatter

Packages that use Formatter
org.hibernate.pretty Classes for pretty printing things for exception and log messages.

Uses of Formatter in org.hibernate.pretty

Methods in org.hibernate.pretty that return Formatter
Formatter | Formatter.setInitialString(String initial)
Formatter | Formatter.setIndentString(String indent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.pretty.MessageHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.pretty.MessageHelper

No usage of org.hibernate.pretty.MessageHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.pretty.Printer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.pretty.Printer

No usage of org.hibernate.pretty.Printer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.property (Hibernate API Documentation)

 org.hibernate.property
Interfaces
Getter
PropertyAccessor
Setter
Classes
BackrefPropertyAccessor
BackrefPropertyAccessor.BackrefSetter
BasicPropertyAccessor
BasicPropertyAccessor.BasicGetter
BasicPropertyAccessor.BasicSetter
ChainedPropertyAccessor
DirectPropertyAccessor
DirectPropertyAccessor.DirectGetter
DirectPropertyAccessor.DirectSetter
Dom4jAccessor
Dom4jAccessor.AttributeGetter
Dom4jAccessor.AttributeSetter
Dom4jAccessor.Dom4jGetter
Dom4jAccessor.Dom4jSetter
Dom4jAccessor.ElementAttributeGetter
Dom4jAccessor.ElementAttributeSetter
Dom4jAccessor.ElementGetter
Dom4jAccessor.ElementSetter
Dom4jAccessor.TextGetter
Dom4jAccessor.TextSetter
EmbeddedPropertyAccessor
EmbeddedPropertyAccessor.EmbeddedGetter
EmbeddedPropertyAccessor.EmbeddedSetter
IndexPropertyAccessor
IndexPropertyAccessor.IndexSetter
MapAccessor
MapAccessor.MapGetter
MapAccessor.MapSetter
NoopAccessor
PropertyAccessorFactory


Uses of Class org.hibernate.property.BackrefPropertyAccessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.BackrefPropertyAccessor

No usage of org.hibernate.property.BackrefPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.BackrefPropertyAccessor.BackrefGetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.BackrefPropertyAccessor.BackrefGetter

No usage of org.hibernate.property.BackrefPropertyAccessor.BackrefGetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.BackrefPropertyAccessor.BackrefSetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.BackrefPropertyAccessor.BackrefSetter

No usage of org.hibernate.property.BackrefPropertyAccessor.BackrefSetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.BasicPropertyAccessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.BasicPropertyAccessor

No usage of org.hibernate.property.BasicPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.BasicPropertyAccessor.BasicGetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.BasicPropertyAccessor.BasicGetter

No usage of org.hibernate.property.BasicPropertyAccessor.BasicGetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.BasicPropertyAccessor.BasicSetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.BasicPropertyAccessor.BasicSetter

No usage of org.hibernate.property.BasicPropertyAccessor.BasicSetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.ChainedPropertyAccessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.ChainedPropertyAccessor

No usage of org.hibernate.property.ChainedPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.DirectPropertyAccessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.DirectPropertyAccessor

No usage of org.hibernate.property.DirectPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.DirectPropertyAccessor.DirectGetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.DirectPropertyAccessor.DirectGetter

No usage of org.hibernate.property.DirectPropertyAccessor.DirectGetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.DirectPropertyAccessor.DirectSetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.DirectPropertyAccessor.DirectSetter

No usage of org.hibernate.property.DirectPropertyAccessor.DirectSetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.Dom4jAccessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.Dom4jAccessor

No usage of org.hibernate.property.Dom4jAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.Dom4jAccessor.AttributeGetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.Dom4jAccessor.AttributeGetter

No usage of org.hibernate.property.Dom4jAccessor.AttributeGetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.Dom4jAccessor.AttributeSetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.Dom4jAccessor.AttributeSetter

No usage of org.hibernate.property.Dom4jAccessor.AttributeSetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.Dom4jAccessor.Dom4jGetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.Dom4jAccessor.Dom4jGetter

Packages that use Dom4jAccessor.Dom4jGetter
org.hibernate.property This package abstracts the notion of a "property" of an entity.

Uses of Dom4jAccessor.Dom4jGetter in org.hibernate.property

Subclasses of Dom4jAccessor.Dom4jGetter in org.hibernate.property
static class | Dom4jAccessor.AttributeGetter For nodes like "@bar"
static class | Dom4jAccessor.ElementAttributeGetter For nodes like "foo/@bar"
static class | Dom4jAccessor.ElementGetter For nodes like "foo"
static class | Dom4jAccessor.TextGetter For nodes like "."

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.Dom4jAccessor.Dom4jSetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.Dom4jAccessor.Dom4jSetter

Packages that use Dom4jAccessor.Dom4jSetter
org.hibernate.property This package abstracts the notion of a "property" of an entity.

Uses of Dom4jAccessor.Dom4jSetter in org.hibernate.property

Subclasses of Dom4jAccessor.Dom4jSetter in org.hibernate.property
static class | Dom4jAccessor.AttributeSetter For nodes like "@bar"
static class | Dom4jAccessor.ElementAttributeSetter For nodes like "foo/@bar"
static class | Dom4jAccessor.ElementSetter For nodes like "foo"
static class | Dom4jAccessor.TextSetter For nodes like "."

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.Dom4jAccessor.ElementAttributeGetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.Dom4jAccessor.ElementAttributeGetter

No usage of org.hibernate.property.Dom4jAccessor.ElementAttributeGetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.Dom4jAccessor.ElementAttributeSetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.Dom4jAccessor.ElementAttributeSetter

No usage of org.hibernate.property.Dom4jAccessor.ElementAttributeSetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.Dom4jAccessor.ElementGetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.Dom4jAccessor.ElementGetter

No usage of org.hibernate.property.Dom4jAccessor.ElementGetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.Dom4jAccessor.ElementSetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.Dom4jAccessor.ElementSetter

No usage of org.hibernate.property.Dom4jAccessor.ElementSetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.Dom4jAccessor.TextGetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.Dom4jAccessor.TextGetter

No usage of org.hibernate.property.Dom4jAccessor.TextGetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.Dom4jAccessor.TextSetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.Dom4jAccessor.TextSetter

No usage of org.hibernate.property.Dom4jAccessor.TextSetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.EmbeddedPropertyAccessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.EmbeddedPropertyAccessor

No usage of org.hibernate.property.EmbeddedPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter

No usage of org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedGetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedSetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedSetter

No usage of org.hibernate.property.EmbeddedPropertyAccessor.EmbeddedSetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.property.Getter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.property.Getter

Packages that use Getter
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |
org.hibernate.util | Utility classes.

Uses of Getter in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type Getter
static IdentifierValue | UnsavedValueFactory.getUnsavedIdentifierValue(String unsavedValue, Getter identifierGetter, Type identifierType, Constructor constructor) Return an IdentifierValue for the specified unsaved-value.
static VersionValue | UnsavedValueFactory.getUnsavedVersionValue(String versionUnsavedValue, Getter versionGetter, VersionType versionType, Constructor constructor)

Uses of Getter in org.hibernate.mapping

Methods in org.hibernate.mapping that return Getter
 Getter Property.getGetter(Class clazz)

Uses of Getter in org.hibernate.property

Classes in org.hibernate.property that implement Getter
class | BackrefPropertyAccessor.BackrefGetter The Getter implementation for id backrefs.
static class | BasicPropertyAccessor.BasicGetter
static class | DirectPropertyAccessor.DirectGetter
static class | Dom4jAccessor.AttributeGetter For nodes like "@bar"
static class | Dom4jAccessor.Dom4jGetter Defines the strategy for getting property values out of a dom4j Node.
static class | Dom4jAccessor.ElementAttributeGetter For nodes like "foo/@bar"
static class | Dom4jAccessor.ElementGetter For nodes like "foo"
static class | Dom4jAccessor.TextGetter For nodes like "."
static class | EmbeddedPropertyAccessor.EmbeddedGetter
class | IndexPropertyAccessor.IndexGetter The Getter implementation for index backrefs.
static class | MapAccessor.MapGetter

Methods in org.hibernate.property that return Getter
Getter | PropertyAccessor.getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Getter | NoopAccessor.getGetter(Class arg0, String arg1)
Getter | MapAccessor.getGetter(Class theClass, String propertyName)
Getter | IndexPropertyAccessor.getGetter(Class theClass, String propertyName)
Getter | EmbeddedPropertyAccessor.getGetter(Class theClass, String propertyName)
Getter | Dom4jAccessor.getGetter(Class theClass, String propertyName) Create a "getter" for the named attribute
Getter | DirectPropertyAccessor.getGetter(Class theClass, String propertyName)
Getter | ChainedPropertyAccessor.getGetter(Class theClass, String propertyName)
Getter | BasicPropertyAccessor.getGetter(Class theClass, String propertyName)
static Getter | BasicPropertyAccessor.createGetter(Class theClass, String propertyName)
Getter | BackrefPropertyAccessor.getGetter(Class theClass, String propertyName)

Uses of Getter in org.hibernate.tuple.component

Fields in org.hibernate.tuple.component declared as Getter
protected  Getter[] AbstractComponentTuplizer.getters

Methods in org.hibernate.tuple.component that return Getter
protected Getter | PojoComponentTuplizer.buildGetter(Component component, Property prop)
protected Getter | DynamicMapComponentTuplizer.buildGetter(Component component, Property prop)
protected Getter | Dom4jComponentTuplizer.buildGetter(Component component, Property prop)
protected abstract Getter | AbstractComponentTuplizer.buildGetter(Component component, Property prop)

Uses of Getter in org.hibernate.tuple.entity

Fields in org.hibernate.tuple.entity declared as Getter
protected  Getter[] AbstractEntityTuplizer.getters

Methods in org.hibernate.tuple.entity that return Getter
protected Getter | PojoEntityTuplizer.buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity)
protected Getter | DynamicMapEntityTuplizer.buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity)
protected Getter | Dom4jEntityTuplizer.buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity)
protected abstract Getter | AbstractEntityTuplizer.buildPropertyGetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Getter for the given property.

Methods in org.hibernate.tuple.entity with parameters of type Getter
protected ProxyFactory | PojoEntityTuplizer.buildProxyFactory(PersistentClass persistentClass, Getter idGetter, Setter idSetter)
protected ProxyFactory | PojoEntityTuplizer.buildProxyFactoryInternal(PersistentClass persistentClass, Getter idGetter, Setter idSetter)
protected ProxyFactory | DynamicMapEntityTuplizer.buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter)
protected ProxyFactory | Dom4jEntityTuplizer.buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter)
protected abstract ProxyFactory | AbstractEntityTuplizer.buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter) Build an appropriate ProxyFactory for the given mapped entity.

Uses of Getter in org.hibernate.util

Methods in org.hibernate.util that return Getter
static Getter ReflectHelper.getGetter(Class theClass, String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.IndexPropertyAccessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.IndexPropertyAccessor

No usage of org.hibernate.property.IndexPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.IndexPropertyAccessor.IndexGetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.IndexPropertyAccessor.IndexGetter

No usage of org.hibernate.property.IndexPropertyAccessor.IndexGetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.IndexPropertyAccessor.IndexSetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.IndexPropertyAccessor.IndexSetter

No usage of org.hibernate.property.IndexPropertyAccessor.IndexSetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.MapAccessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.MapAccessor

No usage of org.hibernate.property.MapAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.MapAccessor.MapGetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.MapAccessor.MapGetter

No usage of org.hibernate.property.MapAccessor.MapGetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.MapAccessor.MapSetter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.MapAccessor.MapSetter

No usage of org.hibernate.property.MapAccessor.MapSetter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.NoopAccessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.NoopAccessor

No usage of org.hibernate.property.NoopAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.property.PropertyAccessor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.property.PropertyAccessor

Packages that use PropertyAccessor
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.

Uses of PropertyAccessor in org.hibernate.mapping

Methods in org.hibernate.mapping that return PropertyAccessor
PropertyAccessor | Property.getPropertyAccessor(Class clazz)
PropertyAccessor | IndexBackref.getPropertyAccessor(Class clazz)
PropertyAccessor | Backref.getPropertyAccessor(Class clazz)

Uses of PropertyAccessor in org.hibernate.property

Classes in org.hibernate.property that implement PropertyAccessor
class | BackrefPropertyAccessor Represents a "back-reference" to the id of a collection owner.
class | BasicPropertyAccessor Accesses property values via a get/set pair, which may be nonpublic.
class | ChainedPropertyAccessor
class | DirectPropertyAccessor Accesses fields directly.
class | Dom4jAccessor Responsible for accessing property values represented as a dom4j Element or Attribute.
class | EmbeddedPropertyAccessor
class | IndexPropertyAccessor Represents a "back-reference" to the index of a collection.
class | MapAccessor
class | NoopAccessor Used to declare properties not represented at the pojo level

Methods in org.hibernate.property that return PropertyAccessor
static PropertyAccessor | PropertyAccessorFactory.getPropertyAccessor(Property property, EntityMode mode) Retrieves a PropertyAccessor instance based on the given property definition and entity mode.
static PropertyAccessor | PropertyAccessorFactory.getDynamicMapPropertyAccessor()
static PropertyAccessor | PropertyAccessorFactory.getDom4jPropertyAccessor(String nodeName, Type type, SessionFactoryImplementor factory)
static PropertyAccessor | PropertyAccessorFactory.getPropertyAccessor(Class optionalClass, String type)
static PropertyAccessor | PropertyAccessorFactory.getPropertyAccessor(String type)

Constructors in org.hibernate.property with parameters of type PropertyAccessor
ChainedPropertyAccessor(PropertyAccessor[] chain)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.property.PropertyAccessorFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.property.PropertyAccessorFactory

No usage of org.hibernate.property.PropertyAccessorFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.property.Setter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.property.Setter

Packages that use Setter
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |

Uses of Setter in org.hibernate.mapping

Methods in org.hibernate.mapping that return Setter
 Setter Property.getSetter(Class clazz)

Uses of Setter in org.hibernate.property

Classes in org.hibernate.property that implement Setter
static class | BackrefPropertyAccessor.BackrefSetter The Setter implementation for id backrefs.
static class | BasicPropertyAccessor.BasicSetter
static class | DirectPropertyAccessor.DirectSetter
static class | Dom4jAccessor.AttributeSetter For nodes like "@bar"
static class | Dom4jAccessor.Dom4jSetter
static class | Dom4jAccessor.ElementAttributeSetter For nodes like "foo/@bar"
static class | Dom4jAccessor.ElementSetter For nodes like "foo"
static class | Dom4jAccessor.TextSetter For nodes like "."
static class | EmbeddedPropertyAccessor.EmbeddedSetter
static class | IndexPropertyAccessor.IndexSetter The Setter implementation for index backrefs.
static class | MapAccessor.MapSetter

Methods in org.hibernate.property that return Setter
Setter | PropertyAccessor.getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute
Setter | NoopAccessor.getSetter(Class arg0, String arg1)
Setter | MapAccessor.getSetter(Class theClass, String propertyName)
Setter | IndexPropertyAccessor.getSetter(Class theClass, String propertyName)
Setter | EmbeddedPropertyAccessor.getSetter(Class theClass, String propertyName)
Setter | Dom4jAccessor.getSetter(Class theClass, String propertyName) Create a "setter" for the named attribute
Setter | DirectPropertyAccessor.getSetter(Class theClass, String propertyName)
Setter | ChainedPropertyAccessor.getSetter(Class theClass, String propertyName)
Setter | BasicPropertyAccessor.getSetter(Class theClass, String propertyName)
Setter | BackrefPropertyAccessor.getSetter(Class theClass, String propertyName)

Uses of Setter in org.hibernate.tuple.component

Fields in org.hibernate.tuple.component declared as Setter
protected  Setter[] AbstractComponentTuplizer.setters

Methods in org.hibernate.tuple.component that return Setter
protected Setter | PojoComponentTuplizer.buildSetter(Component component, Property prop)
protected Setter | DynamicMapComponentTuplizer.buildSetter(Component component, Property prop)
protected Setter | Dom4jComponentTuplizer.buildSetter(Component component, Property prop)
protected abstract Setter | AbstractComponentTuplizer.buildSetter(Component component, Property prop)

Uses of Setter in org.hibernate.tuple.entity

Fields in org.hibernate.tuple.entity declared as Setter
protected  Setter[] AbstractEntityTuplizer.setters

Methods in org.hibernate.tuple.entity that return Setter
protected Setter | PojoEntityTuplizer.buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity)
protected Setter | DynamicMapEntityTuplizer.buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity)
protected Setter | Dom4jEntityTuplizer.buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity)
protected abstract Setter | AbstractEntityTuplizer.buildPropertySetter(Property mappedProperty, PersistentClass mappedEntity) Build an appropriate Setter for the given property.

Methods in org.hibernate.tuple.entity with parameters of type Setter
protected ProxyFactory | PojoEntityTuplizer.buildProxyFactory(PersistentClass persistentClass, Getter idGetter, Setter idSetter)
protected ProxyFactory | PojoEntityTuplizer.buildProxyFactoryInternal(PersistentClass persistentClass, Getter idGetter, Setter idSetter)
protected ProxyFactory | DynamicMapEntityTuplizer.buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter)
protected ProxyFactory | Dom4jEntityTuplizer.buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter)
protected abstract ProxyFactory | AbstractEntityTuplizer.buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter) Build an appropriate ProxyFactory for the given mapped entity.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.proxy (Hibernate API Documentation)

 org.hibernate.proxy
Interfaces
EntityNotFoundDelegate
HibernateProxy
LazyInitializer
ProxyFactory
Classes
AbstractLazyInitializer
HibernateProxyHelper


Uses of Class org.hibernate.proxy.AbstractLazyInitializer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.AbstractLazyInitializer

Packages that use AbstractLazyInitializer
org.hibernate.proxy.dom4j
org.hibernate.proxy.map
org.hibernate.proxy.pojo
org.hibernate.proxy.pojo.cglib
org.hibernate.proxy.pojo.javassist

Uses of AbstractLazyInitializer in org.hibernate.proxy.dom4j

Subclasses of AbstractLazyInitializer in org.hibernate.proxy.dom4j
 class Dom4jLazyInitializer
Lazy initializer for "dom4j" entity representations.

Uses of AbstractLazyInitializer in org.hibernate.proxy.map

Subclasses of AbstractLazyInitializer in org.hibernate.proxy.map
 class MapLazyInitializer
Lazy initializer for "dynamic-map" entity representations.

Uses of AbstractLazyInitializer in org.hibernate.proxy.pojo

Subclasses of AbstractLazyInitializer in org.hibernate.proxy.pojo
 class BasicLazyInitializer
Lazy initializer for POJOs

Uses of AbstractLazyInitializer in org.hibernate.proxy.pojo.cglib

Subclasses of AbstractLazyInitializer in org.hibernate.proxy.pojo.cglib
 class CGLIBLazyInitializer
A LazyInitializer implemented using the CGLIB bytecode generation library

Uses of AbstractLazyInitializer in org.hibernate.proxy.pojo.javassist

Subclasses of AbstractLazyInitializer in org.hibernate.proxy.pojo.javassist
 class JavassistLazyInitializer
A Javassist-based lazy initializer proxy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.proxy.EntityNotFoundDelegate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.proxy.EntityNotFoundDelegate

Packages that use EntityNotFoundDelegate
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.

Uses of EntityNotFoundDelegate in org.hibernate.cfg

Methods in org.hibernate.cfg that return EntityNotFoundDelegate
 EntityNotFoundDelegate Configuration.getEntityNotFoundDelegate()
Retrieve the user-supplied delegate to handle non-existent entity scenarios.

Methods in org.hibernate.cfg with parameters of type EntityNotFoundDelegate
 void Configuration.setEntityNotFoundDelegate(EntityNotFoundDelegate entityNotFoundDelegate)
Specify a user-supplied delegate to be used to handle scenarios where an entity could not be located by specified id.

Uses of EntityNotFoundDelegate in org.hibernate.engine

Methods in org.hibernate.engine that return EntityNotFoundDelegate
 EntityNotFoundDelegate SessionFactoryImplementor.getEntityNotFoundDelegate()

Uses of EntityNotFoundDelegate in org.hibernate.impl

Methods in org.hibernate.impl that return EntityNotFoundDelegate
 EntityNotFoundDelegate SessionFactoryImpl.getEntityNotFoundDelegate()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.proxy.HibernateProxy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.proxy.HibernateProxy

Packages that use HibernateProxy
org.hibernate.proxy | This package defines a framework for lazy-initializing entity proxies.
org.hibernate.proxy.dom4j |
org.hibernate.proxy.map |
org.hibernate.proxy.pojo.cglib |
org.hibernate.proxy.pojo.javassist |

Uses of HibernateProxy in org.hibernate.proxy

Methods in org.hibernate.proxy that return HibernateProxy
 HibernateProxy ProxyFactory.getProxy(Serializable id, SessionImplementor session)
Create a new proxy instance

Uses of HibernateProxy in org.hibernate.proxy.dom4j

Classes in org.hibernate.proxy.dom4j that implement HibernateProxy
 class Dom4jProxy
Proxy for "dom4j" entity representations.

Methods in org.hibernate.proxy.dom4j that return HibernateProxy
 HibernateProxy Dom4jProxyFactory.getProxy(Serializable id, SessionImplementor session)
Create a new proxy

Uses of HibernateProxy in org.hibernate.proxy.map

Classes in org.hibernate.proxy.map that implement HibernateProxy
 class MapProxy
Proxy for "dynamic-map" entity representations.

Methods in org.hibernate.proxy.map that return HibernateProxy
 HibernateProxy MapProxyFactory.getProxy(Serializable id, SessionImplementor session)

Uses of HibernateProxy in org.hibernate.proxy.pojo.cglib

Methods in org.hibernate.proxy.pojo.cglib that return HibernateProxy
HibernateProxy | CGLIBProxyFactory.getProxy(Serializable id, SessionImplementor session)
static HibernateProxy | CGLIBLazyInitializer.getProxy(Class factory, String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)

Uses of HibernateProxy in org.hibernate.proxy.pojo.javassist

Methods in org.hibernate.proxy.pojo.javassist that return HibernateProxy
HibernateProxy | JavassistProxyFactory.getProxy(Serializable id, SessionImplementor session)
static HibernateProxy | JavassistLazyInitializer.getProxy(String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)
static HibernateProxy | JavassistLazyInitializer.getProxy(Class factory, String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.proxy.HibernateProxyHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.HibernateProxyHelper

No usage of org.hibernate.proxy.HibernateProxyHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.proxy.LazyInitializer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.proxy.LazyInitializer

Packages that use LazyInitializer
org.hibernate.proxy | This package defines a framework for lazy-initializing entity proxies.
org.hibernate.proxy.dom4j |
org.hibernate.proxy.map |
org.hibernate.proxy.pojo |
org.hibernate.proxy.pojo.cglib |
org.hibernate.proxy.pojo.javassist |

Uses of LazyInitializer in org.hibernate.proxy

Classes in org.hibernate.proxy that implement LazyInitializer
 class AbstractLazyInitializer
Convenience base class for lazy initialization handlers.

Methods in org.hibernate.proxy that return LazyInitializer
 LazyInitializer HibernateProxy.getHibernateLazyInitializer()
Get the underlying lazy initialization handler.

Uses of LazyInitializer in org.hibernate.proxy.dom4j

Classes in org.hibernate.proxy.dom4j that implement LazyInitializer
 class Dom4jLazyInitializer
Lazy initializer for "dom4j" entity representations.

Methods in org.hibernate.proxy.dom4j that return LazyInitializer
 LazyInitializer Dom4jProxy.getHibernateLazyInitializer()

Uses of LazyInitializer in org.hibernate.proxy.map

Classes in org.hibernate.proxy.map that implement LazyInitializer
 class MapLazyInitializer
Lazy initializer for "dynamic-map" entity representations.

Methods in org.hibernate.proxy.map that return LazyInitializer
 LazyInitializer MapProxy.getHibernateLazyInitializer()

Uses of LazyInitializer in org.hibernate.proxy.pojo

Classes in org.hibernate.proxy.pojo that implement LazyInitializer
 class BasicLazyInitializer
Lazy initializer for POJOs

Uses of LazyInitializer in org.hibernate.proxy.pojo.cglib

Classes in org.hibernate.proxy.pojo.cglib that implement LazyInitializer
 class CGLIBLazyInitializer
A LazyInitializer implemented using the CGLIB bytecode generation library

Uses of LazyInitializer in org.hibernate.proxy.pojo.javassist

Classes in org.hibernate.proxy.pojo.javassist that implement LazyInitializer
 class JavassistLazyInitializer
A Javassist-based lazy initializer proxy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.proxy.ProxyFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.proxy.ProxyFactory

Packages that use ProxyFactory
org.hibernate.bytecode | This package defines the API for plugging in bytecode libraries for usage by Hibernate.
org.hibernate.bytecode.cglib |
org.hibernate.bytecode.javassist |
org.hibernate.proxy.dom4j |
org.hibernate.proxy.map |
org.hibernate.proxy.pojo.cglib |
org.hibernate.proxy.pojo.javassist |
org.hibernate.tuple.entity |

Uses of ProxyFactory in org.hibernate.bytecode

Methods in org.hibernate.bytecode that return ProxyFactory
 ProxyFactory ProxyFactoryFactory.buildProxyFactory()
Build a proxy factory specifically for handling runtime lazy loading.

Uses of ProxyFactory in org.hibernate.bytecode.cglib

Methods in org.hibernate.bytecode.cglib that return ProxyFactory
 ProxyFactory ProxyFactoryFactoryImpl.buildProxyFactory()
Builds a CGLIB-based proxy factory.

Uses of ProxyFactory in org.hibernate.bytecode.javassist

Methods in org.hibernate.bytecode.javassist that return ProxyFactory
 ProxyFactory ProxyFactoryFactoryImpl.buildProxyFactory()
Builds a Javassist-based proxy factory.

Uses of ProxyFactory in org.hibernate.proxy.dom4j

Classes in org.hibernate.proxy.dom4j that implement ProxyFactory
 class Dom4jProxyFactory
Builds proxies for "dom4j" entity representations.

Uses of ProxyFactory in org.hibernate.proxy.map

Classes in org.hibernate.proxy.map that implement ProxyFactory
 class MapProxyFactory

Uses of ProxyFactory in org.hibernate.proxy.pojo.cglib

Classes in org.hibernate.proxy.pojo.cglib that implement ProxyFactory
 class CGLIBProxyFactory

Uses of ProxyFactory in org.hibernate.proxy.pojo.javassist

Classes in org.hibernate.proxy.pojo.javassist that implement ProxyFactory
 class JavassistProxyFactory
A ProxyFactory implementation for producing Javassist-based proxies.

Uses of ProxyFactory in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity that return ProxyFactory
protected ProxyFactory | PojoEntityTuplizer.buildProxyFactory(PersistentClass persistentClass, Getter idGetter, Setter idSetter)
protected ProxyFactory | PojoEntityTuplizer.buildProxyFactoryInternal(PersistentClass persistentClass, Getter idGetter, Setter idSetter)
protected ProxyFactory | DynamicMapEntityTuplizer.buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter)
protected ProxyFactory | Dom4jEntityTuplizer.buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter)
protected abstract ProxyFactory | AbstractEntityTuplizer.buildProxyFactory(PersistentClass mappingInfo, Getter idGetter, Setter idSetter) Build an appropriate ProxyFactory for the given mapped entity.
protected ProxyFactory | AbstractEntityTuplizer.getProxyFactory()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.proxy.dom4j (Hibernate API Documentation)

 org.hibernate.proxy.dom4j
Classes
Dom4jLazyInitializer
Dom4jProxy
Dom4jProxyFactory


Uses of Class org.hibernate.proxy.dom4j.Dom4jLazyInitializer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.dom4j.Dom4jLazyInitializer

Packages that use Dom4jLazyInitializer
org.hibernate.proxy.dom4j

Uses of Dom4jLazyInitializer in org.hibernate.proxy.dom4j

Constructors in org.hibernate.proxy.dom4j with parameters of type Dom4jLazyInitializer
Dom4jProxy(Dom4jLazyInitializer li)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.proxy.dom4j.Dom4jProxy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.dom4j.Dom4jProxy

No usage of org.hibernate.proxy.dom4j.Dom4jProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.proxy.dom4j.Dom4jProxyFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.dom4j.Dom4jProxyFactory

No usage of org.hibernate.proxy.dom4j.Dom4jProxyFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.proxy.map (Hibernate API Documentation)

 org.hibernate.proxy.map
Classes
MapLazyInitializer
MapProxy
MapProxyFactory


Uses of Class org.hibernate.proxy.map.MapLazyInitializer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.map.MapLazyInitializer

No usage of org.hibernate.proxy.map.MapLazyInitializer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.proxy.map.MapProxy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.map.MapProxy

No usage of org.hibernate.proxy.map.MapProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.proxy.map.MapProxyFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.map.MapProxyFactory

No usage of org.hibernate.proxy.map.MapProxyFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.proxy.pojo (Hibernate API Documentation)

 org.hibernate.proxy.pojo
Classes
BasicLazyInitializer


org.hibernate.proxy.pojo.cglib (Hibernate API Documentation)

 org.hibernate.proxy.pojo.cglib
Classes
CGLIBLazyInitializer
CGLIBProxyFactory
SerializableProxy


Uses of Class org.hibernate.proxy.pojo.cglib.CGLIBLazyInitializer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.pojo.cglib.CGLIBLazyInitializer

No usage of org.hibernate.proxy.pojo.cglib.CGLIBLazyInitializer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.proxy.pojo.cglib.CGLIBProxyFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.pojo.cglib.CGLIBProxyFactory

No usage of org.hibernate.proxy.pojo.cglib.CGLIBProxyFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.proxy.pojo.cglib.SerializableProxy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.pojo.cglib.SerializableProxy

No usage of org.hibernate.proxy.pojo.cglib.SerializableProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.proxy.pojo.BasicLazyInitializer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.pojo.BasicLazyInitializer

Packages that use BasicLazyInitializer
org.hibernate.proxy.pojo.cglib
org.hibernate.proxy.pojo.javassist

Uses of BasicLazyInitializer in org.hibernate.proxy.pojo.cglib

Subclasses of BasicLazyInitializer in org.hibernate.proxy.pojo.cglib
 class CGLIBLazyInitializer
A LazyInitializer implemented using the CGLIB bytecode generation library

Uses of BasicLazyInitializer in org.hibernate.proxy.pojo.javassist

Subclasses of BasicLazyInitializer in org.hibernate.proxy.pojo.javassist
 class JavassistLazyInitializer
A Javassist-based lazy initializer proxy.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.proxy.pojo.javassist (Hibernate API Documentation)

 org.hibernate.proxy.pojo.javassist
Classes
JavassistLazyInitializer
JavassistProxyFactory
SerializableProxy


Uses of Class org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer

No usage of org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.proxy.pojo.javassist.JavassistProxyFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.pojo.javassist.JavassistProxyFactory

No usage of org.hibernate.proxy.pojo.javassist.JavassistProxyFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.proxy.pojo.javassist.SerializableProxy (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.proxy.pojo.javassist.SerializableProxy

No usage of org.hibernate.proxy.pojo.javassist.SerializableProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.secure (Hibernate API Documentation)

 org.hibernate.secure
Interfaces
JACCSecurityListener
Classes
HibernatePermission
JACCConfiguration
JACCPermissions
JACCPreDeleteEventListener
JACCPreInsertEventListener
JACCPreLoadEventListener
JACCPreUpdateEventListener


Uses of Class org.hibernate.secure.HibernatePermission (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.secure.HibernatePermission

No usage of org.hibernate.secure.HibernatePermission

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.secure.JACCConfiguration (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.secure.JACCConfiguration

No usage of org.hibernate.secure.JACCConfiguration

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.secure.JACCPermissions (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.secure.JACCPermissions

No usage of org.hibernate.secure.JACCPermissions

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.secure.JACCPreDeleteEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.secure.JACCPreDeleteEventListener

No usage of org.hibernate.secure.JACCPreDeleteEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.secure.JACCPreInsertEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.secure.JACCPreInsertEventListener

No usage of org.hibernate.secure.JACCPreInsertEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.secure.JACCPreLoadEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.secure.JACCPreLoadEventListener

No usage of org.hibernate.secure.JACCPreLoadEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.secure.JACCPreUpdateEventListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.secure.JACCPreUpdateEventListener

No usage of org.hibernate.secure.JACCPreUpdateEventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.secure.JACCSecurityListener (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.secure.JACCSecurityListener

Packages that use JACCSecurityListener
org.hibernate.secure Declarative security for CRUD operations on entities.

Uses of JACCSecurityListener in org.hibernate.secure

Classes in org.hibernate.secure that implement JACCSecurityListener
class | JACCPreDeleteEventListener Check security before any deletion
class | JACCPreInsertEventListener Check security before an insertion
class | JACCPreLoadEventListener Check security before any load
class | JACCPreUpdateEventListener Check security before any update

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.sql (Hibernate API Documentation)

 org.hibernate.sql
Classes
Alias
ANSICaseFragment
ANSIJoinFragment
CaseFragment
ConditionFragment
DecodeCaseFragment
Delete
DerbyCaseFragment
DisjunctionFragment
ForUpdateFragment
HSQLCaseFragment
InFragment
Insert
InsertSelect
JoinFragment
MckoiCaseFragment
OracleJoinFragment
QueryJoinFragment
QuerySelect
Select
SelectFragment
SimpleSelect
Sybase11JoinFragment
Template
Update


Uses of Class org.hibernate.sql.Alias (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.Alias

No usage of org.hibernate.sql.Alias

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.ANSICaseFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.ANSICaseFragment

No usage of org.hibernate.sql.ANSICaseFragment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.ANSIJoinFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.ANSIJoinFragment

No usage of org.hibernate.sql.ANSIJoinFragment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.CaseFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.CaseFragment

Packages that use CaseFragment
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of CaseFragment in org.hibernate.dialect

Methods in org.hibernate.dialect that return CaseFragment
CaseFragment | SAPDBDialect.createCaseFragment()
CaseFragment | RDMSOS2200Dialect.createCaseFragment()
CaseFragment | OracleDialect.createCaseFragment()
CaseFragment | MckoiDialect.createCaseFragment()
CaseFragment | Dialect.createCaseFragment() Create a CaseFragment for this dialect.
CaseFragment | DerbyDialect.createCaseFragment() Return the case statement modified for Cloudscape.

Uses of CaseFragment in org.hibernate.sql

Subclasses of CaseFragment in org.hibernate.sql
class | ANSICaseFragment An ANSI SQL CASE expression.
class | DecodeCaseFragment An Oracle-style DECODE function.
class | DerbyCaseFragment
class | HSQLCaseFragment The HSQL CASEWHEN function.
class | MckoiCaseFragment A Mckoi IF function.

Methods in org.hibernate.sql that return CaseFragment
CaseFragment | CaseFragment.setReturnColumnName(String returnColumnName)
CaseFragment | CaseFragment.setReturnColumnName(String returnColumnName, String suffix)
CaseFragment | CaseFragment.addWhenColumnNotNull(String alias, String columnName, String value)

Methods in org.hibernate.sql with parameters of type CaseFragment
 SelectFragment SelectFragment.setExtraSelectList(CaseFragment caseFragment, String fragmentAlias)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.ConditionFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.ConditionFragment

Packages that use ConditionFragment
org.hibernate.sql This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of ConditionFragment in org.hibernate.sql

Methods in org.hibernate.sql that return ConditionFragment
ConditionFragment | ConditionFragment.setOp(String op) Sets the op.
ConditionFragment | ConditionFragment.setTableAlias(String tableAlias) Sets the tableAlias.
ConditionFragment | ConditionFragment.setCondition(String[] lhs, String[] rhs)
ConditionFragment | ConditionFragment.setCondition(String[] lhs, String rhs)

Methods in org.hibernate.sql with parameters of type ConditionFragment
 DisjunctionFragment DisjunctionFragment.addCondition(ConditionFragment fragment)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.DecodeCaseFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.DecodeCaseFragment

No usage of org.hibernate.sql.DecodeCaseFragment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.Delete (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.Delete

Packages that use Delete
org.hibernate.sql This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of Delete in org.hibernate.sql

Methods in org.hibernate.sql that return Delete
Delete | Delete.setComment(String comment)
Delete | Delete.setTableName(String tableName)
Delete | Delete.setWhere(String where)
Delete | Delete.addWhereFragment(String fragment)
Delete | Delete.setPrimaryKeyColumnNames(String[] primaryKeyColumnNames)
Delete | Delete.setVersionColumnName(String versionColumnName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.DerbyCaseFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.DerbyCaseFragment

No usage of org.hibernate.sql.DerbyCaseFragment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.DisjunctionFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.DisjunctionFragment

Packages that use DisjunctionFragment
org.hibernate.sql This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of DisjunctionFragment in org.hibernate.sql

Methods in org.hibernate.sql that return DisjunctionFragment
 DisjunctionFragment DisjunctionFragment.addCondition(ConditionFragment fragment)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.ForUpdateFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.ForUpdateFragment

Packages that use ForUpdateFragment
org.hibernate.sql This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of ForUpdateFragment in org.hibernate.sql

Methods in org.hibernate.sql that return ForUpdateFragment
ForUpdateFragment | ForUpdateFragment.addTableAlias(String alias)
ForUpdateFragment | ForUpdateFragment.setNowaitEnabled(boolean nowait)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.HSQLCaseFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.HSQLCaseFragment

No usage of org.hibernate.sql.HSQLCaseFragment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.InFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.InFragment

Packages that use InFragment
org.hibernate.sql This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of InFragment in org.hibernate.sql

Methods in org.hibernate.sql that return InFragment
InFragment | InFragment.addValue(Object value)
InFragment | InFragment.setColumn(String columnName)
InFragment | InFragment.setColumn(String alias, String columnName)
InFragment | InFragment.setFormula(String alias, String formulaTemplate)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.Insert (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.Insert

Packages that use Insert
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.id.insert |
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of Insert in org.hibernate.id

Subclasses of Insert in org.hibernate.id
static class SequenceIdentityGenerator.NoCommentsInsert

Methods in org.hibernate.id that return Insert
 Insert SequenceIdentityGenerator.NoCommentsInsert.setComment(String comment)

Uses of Insert in org.hibernate.id.insert

Subclasses of Insert in org.hibernate.id.insert
class | IdentifierGeneratingInsert Nothing more than a distinguishing subclass of Insert used to indicate intent.
class | InsertSelectIdentityInsert Specialized IdentifierGeneratingInsert which appends the database specific clause which signifies to return generated IDENTITY values to the end of the insert statement.

Uses of Insert in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity with parameters of type Insert
protected void | SingleTableEntityPersister.addDiscriminatorToInsert(Insert insert)
protected void | AbstractEntityPersister.addDiscriminatorToInsert(Insert insert)

Uses of Insert in org.hibernate.sql

Methods in org.hibernate.sql that return Insert
Insert | Insert.setComment(String comment)
Insert | Insert.addColumn(String columnName)
Insert | Insert.addColumns(String[] columnNames)
Insert | Insert.addColumns(String[] columnNames, boolean[] insertable)
Insert | Insert.addColumn(String columnName, String value)
Insert | Insert.addColumn(String columnName, Object value, LiteralType type)
Insert | Insert.addIdentityColumn(String columnName)
Insert | Insert.setTableName(String tableName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.InsertSelect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.InsertSelect

Packages that use InsertSelect
org.hibernate.sql This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of InsertSelect in org.hibernate.sql

Methods in org.hibernate.sql that return InsertSelect
InsertSelect | InsertSelect.setTableName(String tableName)
InsertSelect | InsertSelect.setComment(String comment)
InsertSelect | InsertSelect.addColumn(String columnName)
InsertSelect | InsertSelect.addColumns(String[] columnNames)
InsertSelect | InsertSelect.setSelect(Select select)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.JoinFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.JoinFragment

Packages that use JoinFragment
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of JoinFragment in org.hibernate.dialect

Methods in org.hibernate.dialect that return JoinFragment
JoinFragment | TimesTenDialect.createOuterJoinFragment()
JoinFragment | Sybase11Dialect.createOuterJoinFragment()
JoinFragment | SAPDBDialect.createOuterJoinFragment()
JoinFragment | OracleDialect.createOuterJoinFragment()
JoinFragment | Dialect.createOuterJoinFragment() Create an OuterJoinGenerator for this dialect.

Uses of JoinFragment in org.hibernate.engine

Methods in org.hibernate.engine that return JoinFragment
JoinFragment | JoinSequence.toJoinFragment()
JoinFragment | JoinSequence.toJoinFragment(Map enabledFilters, boolean includeExtraJoins)
JoinFragment | JoinSequence.toJoinFragment(Map enabledFilters, boolean includeExtraJoins, String withClauseFragment, String withClauseJoinAlias)

Uses of JoinFragment in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree with parameters of type JoinFragment
 void SqlFragment.setJoinFragment(JoinFragment joinFragment)

Uses of JoinFragment in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util with parameters of type JoinFragment
 void SyntheticAndFactory.addWhereFragment(JoinFragment joinFragment, String whereFragment, QueryNode query, FromElement fromElement)

Uses of JoinFragment in org.hibernate.loader

Methods in org.hibernate.loader that return JoinFragment
protected  JoinFragment JoinWalker.mergeOuterJoins(List associations)
Generate a sequence of LEFT OUTER JOIN clauses for the given associations.

Methods in org.hibernate.loader with parameters of type JoinFragment
void | OuterJoinableAssociation.addJoins(JoinFragment outerjoin)
void | OuterJoinableAssociation.addManyToManyJoin(JoinFragment outerjoin, QueryableCollection collection)

Uses of JoinFragment in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return JoinFragment
protected JoinFragment | AbstractEntityPersister.createJoin(String name, boolean innerJoin, boolean includeSubclasses)
protected JoinFragment | AbstractEntityPersister.createJoin(int[] tableNumbers, String drivingAlias)

Uses of JoinFragment in org.hibernate.sql

Subclasses of JoinFragment in org.hibernate.sql
class | ANSIJoinFragment An ANSI-style join
class | OracleJoinFragment An Oracle-style (theta) join
class | QueryJoinFragment A join that appears in a translated HQL query
class | Sybase11JoinFragment An old Sybase-style join (before Sybase supported the ANSI style "inner join" etc syntax) This is needed for Sybase 11.9.2 and earlier, using the HQL 2.* syntax with Collections.

Methods in org.hibernate.sql that return JoinFragment
JoinFragment | Sybase11JoinFragment.copy()
JoinFragment | QuerySelect.getJoinFragment()
JoinFragment | QueryJoinFragment.copy()
JoinFragment | OracleJoinFragment.copy()
abstract JoinFragment | JoinFragment.copy()
JoinFragment | ANSIJoinFragment.copy()

Methods in org.hibernate.sql with parameters of type JoinFragment
 void JoinFragment.addFragment(JoinFragment ojf)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.MckoiCaseFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.MckoiCaseFragment

No usage of org.hibernate.sql.MckoiCaseFragment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.OracleJoinFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.OracleJoinFragment

No usage of org.hibernate.sql.OracleJoinFragment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.QueryJoinFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.QueryJoinFragment

No usage of org.hibernate.sql.QueryJoinFragment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.QuerySelect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.QuerySelect

Packages that use QuerySelect
org.hibernate.sql This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of QuerySelect in org.hibernate.sql

Methods in org.hibernate.sql that return QuerySelect
 QuerySelect QuerySelect.copy()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.Select (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.Select

Packages that use Select
org.hibernate.sql This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of Select in org.hibernate.sql

Methods in org.hibernate.sql that return Select
Select | Select.setFromClause(String fromClause) Sets the fromClause.
Select | Select.setFromClause(String tableName, String alias)
Select | Select.setOrderByClause(String orderByClause)
Select | Select.setGroupByClause(String groupByClause)
Select | Select.setOuterJoins(String outerJoinsAfterFrom, String outerJoinsAfterWhere)
Select | Select.setSelectClause(String selectClause) Sets the selectClause.
Select | Select.setWhereClause(String whereClause) Sets the whereClause.
Select | Select.setComment(String comment)
Select | Select.setLockMode(LockMode lockMode)

Methods in org.hibernate.sql with parameters of type Select
 InsertSelect InsertSelect.setSelect(Select select)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.SelectFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.SelectFragment

Packages that use SelectFragment
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of SelectFragment in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that return SelectFragment
protected  SelectFragment AbstractCollectionPersister.generateSelectFragment(String alias, String columnSuffix)

Methods in org.hibernate.persister.collection with parameters of type SelectFragment
protected void | AbstractCollectionPersister.appendElementColumns(SelectFragment frag, String elemAlias)
protected void | AbstractCollectionPersister.appendIndexColumns(SelectFragment frag, String alias)
protected void | AbstractCollectionPersister.appendIdentifierColumns(SelectFragment frag, String alias)

Uses of SelectFragment in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return SelectFragment
protected  SelectFragment AbstractEntityPersister.createSelect(int[] subclassColumnNumbers, int[] subclassFormulaNumbers)

Methods in org.hibernate.persister.entity with parameters of type SelectFragment
protected void | UnionSubclassEntityPersister.addDiscriminatorToSelect(SelectFragment select, String name, String suffix)
protected void | SingleTableEntityPersister.addDiscriminatorToSelect(SelectFragment select, String name, String suffix)
void | JoinedSubclassEntityPersister.addDiscriminatorToSelect(SelectFragment select, String name, String suffix)
protected void | AbstractEntityPersister.addDiscriminatorToSelect(SelectFragment select, String name, String suffix)

Uses of SelectFragment in org.hibernate.sql

Methods in org.hibernate.sql that return SelectFragment
SelectFragment | SelectFragment.setUsedAliases(String[] aliases)
SelectFragment | SelectFragment.setExtraSelectList(String extraSelectList)
SelectFragment | SelectFragment.setExtraSelectList(CaseFragment caseFragment, String fragmentAlias)
SelectFragment | SelectFragment.setSuffix(String suffix)
SelectFragment | SelectFragment.addColumn(String columnName)
SelectFragment | SelectFragment.addColumns(String[] columnNames)
SelectFragment | SelectFragment.addColumn(String tableAlias, String columnName)
SelectFragment | SelectFragment.addColumn(String tableAlias, String columnName, String columnAlias)
SelectFragment | SelectFragment.addColumns(String tableAlias, String[] columnNames)
SelectFragment | SelectFragment.addColumns(String tableAlias, String[] columnNames, String[] columnAliases)
SelectFragment | SelectFragment.addFormulas(String tableAlias, String[] formulas, String[] formulaAliases)
SelectFragment | SelectFragment.addFormula(String tableAlias, String formula, String formulaAlias)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.SimpleSelect (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.SimpleSelect

Packages that use SimpleSelect
org.hibernate.sql This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of SimpleSelect in org.hibernate.sql

Methods in org.hibernate.sql that return SimpleSelect
SimpleSelect | SimpleSelect.addColumns(String[] columnNames, String[] columnAliases)
SimpleSelect | SimpleSelect.addColumns(String[] columns, String[] aliases, boolean[] ignore)
SimpleSelect | SimpleSelect.addColumns(String[] columnNames)
SimpleSelect | SimpleSelect.addColumn(String columnName)
SimpleSelect | SimpleSelect.addColumn(String columnName, String alias)
SimpleSelect | SimpleSelect.setTableName(String tableName)
SimpleSelect | SimpleSelect.setLockMode(LockMode lockMode)
SimpleSelect | SimpleSelect.addWhereToken(String token)
SimpleSelect | SimpleSelect.addCondition(String lhs, String op, String rhs)
SimpleSelect | SimpleSelect.addCondition(String lhs, String condition)
SimpleSelect | SimpleSelect.addCondition(String[] lhs, String op, String[] rhs)
SimpleSelect | SimpleSelect.addCondition(String[] lhs, String condition)
SimpleSelect | SimpleSelect.setOrderBy(String orderBy)
SimpleSelect | SimpleSelect.setComment(String comment)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.Sybase11JoinFragment (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.Sybase11JoinFragment

No usage of org.hibernate.sql.Sybase11JoinFragment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.Template (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.Template

No usage of org.hibernate.sql.Template

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.sql.Update (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.sql.Update

Packages that use Update
org.hibernate.sql This package defines helper classes for rendering SQL fragments and SQL statements.

Uses of Update in org.hibernate.sql

Methods in org.hibernate.sql that return Update
Update | Update.appendAssignmentFragment(String fragment)
Update | Update.setTableName(String tableName)
Update | Update.setPrimaryKeyColumnNames(String[] primaryKeyColumnNames)
Update | Update.setVersionColumnName(String versionColumnName)
Update | Update.setComment(String comment)
Update | Update.addColumns(String[] columnNames)
Update | Update.addColumns(String[] columnNames, boolean[] updateable)
Update | Update.addColumns(String[] columnNames, String value)
Update | Update.addColumn(String columnName)
Update | Update.addColumn(String columnName, String value)
Update | Update.addColumn(String columnName, Object value, LiteralType type)
Update | Update.addWhereColumns(String[] columnNames)
Update | Update.addWhereColumns(String[] columnNames, String value)
Update | Update.addWhereColumn(String columnName)
Update | Update.addWhereColumn(String columnName, String value)
Update | Update.setWhere(String where)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.stat (Hibernate API Documentation)

 org.hibernate.stat
Interfaces
SessionStatistics
Statistics
StatisticsImplementor
Classes
CategorizedStatistics
CollectionStatistics
EntityStatistics
QueryStatistics
SecondLevelCacheStatistics
SessionStatisticsImpl
StatisticsImpl


Uses of Class org.hibernate.stat.CategorizedStatistics (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.stat.CategorizedStatistics

Packages that use CategorizedStatistics
org.hibernate.stat This package exposes statistics about a running Hibernate instance to the application.

Uses of CategorizedStatistics in org.hibernate.stat

Subclasses of CategorizedStatistics in org.hibernate.stat
class | CollectionStatistics Collection related statistics
class | EntityStatistics Entity related statistics
class | QueryStatistics Query statistics (HQL and SQL) Note that for a cached query, the cache miss is equals to the db count
class | SecondLevelCacheStatistics Second level cache statistics of a specific region

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.stat.CollectionStatistics (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.stat.CollectionStatistics

Packages that use CollectionStatistics
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.stat | This package exposes statistics about a running Hibernate instance to the application.

Uses of CollectionStatistics in org.hibernate.jmx

Methods in org.hibernate.jmx that return CollectionStatistics
 CollectionStatistics StatisticsService.getCollectionStatistics(String role)

Uses of CollectionStatistics in org.hibernate.stat

Methods in org.hibernate.stat that return CollectionStatistics
CollectionStatistics | StatisticsImpl.getCollectionStatistics(String role) Get collection statistics per role
CollectionStatistics | Statistics.getCollectionStatistics(String role) Get collection statistics per role

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.stat.EntityStatistics (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.stat.EntityStatistics

Packages that use EntityStatistics
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.stat | This package exposes statistics about a running Hibernate instance to the application.

Uses of EntityStatistics in org.hibernate.jmx

Methods in org.hibernate.jmx that return EntityStatistics
 EntityStatistics StatisticsService.getEntityStatistics(String entityName)

Uses of EntityStatistics in org.hibernate.stat

Methods in org.hibernate.stat that return EntityStatistics
EntityStatistics | StatisticsImpl.getEntityStatistics(String entityName) find entity statistics per name
EntityStatistics | Statistics.getEntityStatistics(String entityName) find entity statistics per name

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.stat.QueryStatistics (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.stat.QueryStatistics

Packages that use QueryStatistics
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.stat | This package exposes statistics about a running Hibernate instance to the application.

Uses of QueryStatistics in org.hibernate.jmx

Methods in org.hibernate.jmx that return QueryStatistics
 QueryStatistics StatisticsService.getQueryStatistics(String hql)

Uses of QueryStatistics in org.hibernate.stat

Methods in org.hibernate.stat that return QueryStatistics
QueryStatistics | StatisticsImpl.getQueryStatistics(String queryString) Query statistics from query string (HQL or SQL)
QueryStatistics | Statistics.getQueryStatistics(String queryString) Query statistics from query string (HQL or SQL)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.stat.SecondLevelCacheStatistics (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.stat.SecondLevelCacheStatistics

Packages that use SecondLevelCacheStatistics
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.stat | This package exposes statistics about a running Hibernate instance to the application.

Uses of SecondLevelCacheStatistics in org.hibernate.jmx

Methods in org.hibernate.jmx that return SecondLevelCacheStatistics
 SecondLevelCacheStatistics StatisticsService.getSecondLevelCacheStatistics(String regionName)

Uses of SecondLevelCacheStatistics in org.hibernate.stat

Methods in org.hibernate.stat that return SecondLevelCacheStatistics
SecondLevelCacheStatistics | StatisticsImpl.getSecondLevelCacheStatistics(String regionName) Second level cache statistics per region
SecondLevelCacheStatistics | Statistics.getSecondLevelCacheStatistics(String regionName) Second level cache statistics per region

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.stat.SessionStatistics (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.stat.SessionStatistics

Packages that use SessionStatistics
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.stat | This package exposes statistics about a running Hibernate instance to the application.

Uses of SessionStatistics in org.hibernate

Methods in org.hibernate that return SessionStatistics
 SessionStatistics Session.getStatistics()
Get the statistics for this session.

Uses of SessionStatistics in org.hibernate.impl

Methods in org.hibernate.impl that return SessionStatistics
 SessionStatistics SessionImpl.getStatistics()

Uses of SessionStatistics in org.hibernate.stat

Classes in org.hibernate.stat that implement SessionStatistics
 class SessionStatisticsImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.stat.SessionStatisticsImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.stat.SessionStatisticsImpl

No usage of org.hibernate.stat.SessionStatisticsImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.stat.Statistics (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.stat.Statistics

Packages that use Statistics
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jmx | This package exposes a Hibernate instance via JMX.
org.hibernate.stat | This package exposes statistics about a running Hibernate instance to the application.

Uses of Statistics in org.hibernate

Methods in org.hibernate that return Statistics
 Statistics SessionFactory.getStatistics()
Get the statistics for this session factory

Uses of Statistics in org.hibernate.impl

Methods in org.hibernate.impl that return Statistics
 Statistics SessionFactoryImpl.getStatistics()

Uses of Statistics in org.hibernate.jmx

Subinterfaces of Statistics in org.hibernate.jmx
 interface StatisticsServiceMBean
MBean exposing Session Factory statistics

Classes in org.hibernate.jmx that implement Statistics
 class StatisticsService
JMX service for Hibernate statistics

Register this MBean in your JMX server for a specific session factory

Methods in org.hibernate.jmx that return Statistics
 Statistics SessionFactoryStub.getStatistics()

Uses of Statistics in org.hibernate.stat

Classes in org.hibernate.stat that implement Statistics
 class StatisticsImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.stat.StatisticsImpl (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.stat.StatisticsImpl

No usage of org.hibernate.stat.StatisticsImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.stat.StatisticsImplementor (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.stat.StatisticsImplementor

Packages that use StatisticsImplementor
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.stat | This package exposes statistics about a running Hibernate instance to the application.

Uses of StatisticsImplementor in org.hibernate.engine

Methods in org.hibernate.engine that return StatisticsImplementor
 StatisticsImplementor SessionFactoryImplementor.getStatisticsImplementor()
Statistics SPI

Uses of StatisticsImplementor in org.hibernate.impl

Methods in org.hibernate.impl that return StatisticsImplementor
 StatisticsImplementor SessionFactoryImpl.getStatisticsImplementor()

Uses of StatisticsImplementor in org.hibernate.stat

Classes in org.hibernate.stat that implement StatisticsImplementor
 class StatisticsImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.tool.hbm2ddl (Hibernate API Documentation)

 org.hibernate.tool.hbm2ddl
Classes
ColumnMetadata
DatabaseMetadata
ForeignKeyMetadata
IndexMetadata
SchemaExport
SchemaExportTask
SchemaUpdate
SchemaUpdateTask
SchemaValidator
SchemaValidatorTask
TableMetadata


Uses of Class org.hibernate.tool.hbm2ddl.ColumnMetadata (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.hbm2ddl.ColumnMetadata

Packages that use ColumnMetadata
org.hibernate.tool.hbm2ddl The hbm2ddl tool.

Uses of ColumnMetadata in org.hibernate.tool.hbm2ddl

Methods in org.hibernate.tool.hbm2ddl that return ColumnMetadata
ColumnMetadata | TableMetadata.getColumnMetadata(String columnName)
ColumnMetadata[] | IndexMetadata.getColumns()
ColumnMetadata[] | ForeignKeyMetadata.getColumns()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.hbm2ddl.DatabaseMetadata (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.hbm2ddl.DatabaseMetadata

Packages that use DatabaseMetadata
org.hibernate.cfg This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of DatabaseMetadata in org.hibernate.cfg

Methods in org.hibernate.cfg with parameters of type DatabaseMetadata
String[] | Configuration.generateSchemaUpdateScript(Dialect dialect, DatabaseMetadata databaseMetadata) Generate DDL for altering tables
void | Configuration.validateSchema(Dialect dialect, DatabaseMetadata databaseMetadata)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.hbm2ddl.ForeignKeyMetadata (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.hbm2ddl.ForeignKeyMetadata

Packages that use ForeignKeyMetadata
org.hibernate.tool.hbm2ddl The hbm2ddl tool.

Uses of ForeignKeyMetadata in org.hibernate.tool.hbm2ddl

Methods in org.hibernate.tool.hbm2ddl that return ForeignKeyMetadata
 ForeignKeyMetadata TableMetadata.getForeignKeyMetadata(String keyName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.hbm2ddl.IndexMetadata (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.hbm2ddl.IndexMetadata

Packages that use IndexMetadata
org.hibernate.tool.hbm2ddl The hbm2ddl tool.

Uses of IndexMetadata in org.hibernate.tool.hbm2ddl

Methods in org.hibernate.tool.hbm2ddl that return IndexMetadata
 IndexMetadata TableMetadata.getIndexMetadata(String indexName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.hbm2ddl.SchemaExport (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.hbm2ddl.SchemaExport

Packages that use SchemaExport
org.hibernate.tool.hbm2ddl The hbm2ddl tool.

Uses of SchemaExport in org.hibernate.tool.hbm2ddl

Methods in org.hibernate.tool.hbm2ddl that return SchemaExport
SchemaExport | SchemaExport.setOutputFile(String filename) Set an output filename.
SchemaExport | SchemaExport.setImportFile(String filename)
SchemaExport | SchemaExport.setDelimiter(String delimiter) Set the end of statement delimiter
SchemaExport | SchemaExport.setFormat(boolean format)
SchemaExport | SchemaExport.setHaltOnError(boolean haltOnError)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.hbm2ddl.SchemaExportTask (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.hbm2ddl.SchemaExportTask

No usage of org.hibernate.tool.hbm2ddl.SchemaExportTask

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.hbm2ddl.SchemaUpdate (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.hbm2ddl.SchemaUpdate

No usage of org.hibernate.tool.hbm2ddl.SchemaUpdate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.hbm2ddl.SchemaUpdateTask (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.hbm2ddl.SchemaUpdateTask

No usage of org.hibernate.tool.hbm2ddl.SchemaUpdateTask

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.hbm2ddl.SchemaValidator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.hbm2ddl.SchemaValidator

No usage of org.hibernate.tool.hbm2ddl.SchemaValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.hbm2ddl.SchemaValidatorTask (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.hbm2ddl.SchemaValidatorTask

No usage of org.hibernate.tool.hbm2ddl.SchemaValidatorTask

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.hbm2ddl.TableMetadata (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.hbm2ddl.TableMetadata

Packages that use TableMetadata
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.tool.hbm2ddl | The hbm2ddl tool.

Uses of TableMetadata in org.hibernate.mapping

Methods in org.hibernate.mapping with parameters of type TableMetadata
void | Table.validateColumns(Dialect dialect, Mapping mapping, TableMetadata tableInfo)
Iterator | Table.sqlAlterStrings(Dialect dialect, Mapping p, TableMetadata tableInfo, String defaultCatalog, String defaultSchema)

Uses of TableMetadata in org.hibernate.tool.hbm2ddl

Methods in org.hibernate.tool.hbm2ddl that return TableMetadata
 TableMetadata DatabaseMetadata.getTableMetadata(String name, String schema, String catalog)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.tool.instrument (Hibernate API Documentation)

 org.hibernate.tool.instrument
Classes
BasicInstrumentationTask


org.hibernate.tool.instrument.cglib (Hibernate API Documentation)

 org.hibernate.tool.instrument.cglib
Classes
InstrumentTask


Uses of Class org.hibernate.tool.instrument.cglib.InstrumentTask (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.instrument.cglib.InstrumentTask

No usage of org.hibernate.tool.instrument.cglib.InstrumentTask

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.instrument.BasicInstrumentationTask (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.instrument.BasicInstrumentationTask

Packages that use BasicInstrumentationTask
org.hibernate.tool.instrument.cglib

Uses of BasicInstrumentationTask in org.hibernate.tool.instrument.cglib

Subclasses of BasicInstrumentationTask in org.hibernate.tool.instrument.cglib
 class InstrumentTask
An Ant task for instrumenting persistent classes in order to enable field-level interception using CGLIB.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.instrument.BasicInstrumentationTask.CustomFieldFilter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.instrument.BasicInstrumentationTask.CustomFieldFilter

No usage of org.hibernate.tool.instrument.BasicInstrumentationTask.CustomFieldFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tool.instrument.BasicInstrumentationTask.Logger (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.instrument.BasicInstrumentationTask.Logger

Packages that use BasicInstrumentationTask.Logger
org.hibernate.tool.instrument The instrument tool for adding field-interception hooks to persistent classes using built-time bytecode processing.

Uses of BasicInstrumentationTask.Logger in org.hibernate.tool.instrument

Fields in org.hibernate.tool.instrument declared as BasicInstrumentationTask.Logger
protected  BasicInstrumentationTask.Logger BasicInstrumentationTask.logger

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.tool.instrument.javassist (Hibernate API Documentation)

 org.hibernate.tool.instrument.javassist
Classes
InstrumentTask


Uses of Class org.hibernate.tool.instrument.javassist.InstrumentTask (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tool.instrument.javassist.InstrumentTask

No usage of org.hibernate.tool.instrument.javassist.InstrumentTask

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.transaction (Hibernate API Documentation)

 org.hibernate.transaction
Interfaces
TransactionFactory
TransactionFactory.Context
TransactionManagerLookup
Classes
BESTransactionManagerLookup
CacheSynchronization
CMTTransaction
CMTTransactionFactory
JBossTransactionManagerLookup
JDBCTransaction
JDBCTransactionFactory
JNDITransactionManagerLookup
JOnASTransactionManagerLookup
JOTMTransactionManagerLookup
JRun4TransactionManagerLookup
JTATransaction
JTATransactionFactory
OC4JTransactionManagerLookup
OrionTransactionManagerLookup
ResinTransactionManagerLookup
SunONETransactionManagerLookup
TransactionFactoryFactory
TransactionManagerLookupFactory
WeblogicTransactionManagerLookup
WebSphereExtendedJTATransactionLookup
WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter
WebSphereTransactionManagerLookup


WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter (Hibernate API Documentation)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.hibernate.transaction
Class WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter

java.lang.Object
    extended by org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter
All Implemented Interfaces:
Transaction
Enclosing class:
WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter
public class WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter
extends Object
implements Transaction

Method Summary
void | commit()
boolean | delistResource(XAResource resource, int i)
boolean | enlistResource(XAResource resource)
boolean | equals(Object other)
int | getStatus()
int | hashCode()
void | registerSynchronization(Synchronization synchronization)
void | rollback()
void | setRollbackOnly()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Method Detail

registerSynchronization

public void registerSynchronization(Synchronization synchronization)
                             throws RollbackException,
                                    IllegalStateException,
                                    SystemException
Specified by:
registerSynchronization in interface Transaction
Throws:
RollbackException
IllegalStateException
SystemException

hashCode

public int hashCode()

equals

public boolean equals(Object other)

commit

public void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
Specified by:
commit in interface Transaction
Throws:
RollbackException
HeuristicMixedException
HeuristicRollbackException
SecurityException
IllegalStateException
SystemException

delistResource

public boolean delistResource(XAResource resource,
                              int i)
                       throws IllegalStateException,
                              SystemException
Specified by:
delistResource in interface Transaction
Throws:
IllegalStateException
SystemException

enlistResource

public boolean enlistResource(XAResource resource)
                       throws RollbackException,
                              IllegalStateException,
                              SystemException
Specified by:
enlistResource in interface Transaction
Throws:
RollbackException
IllegalStateException
SystemException

getStatus

public int getStatus()
              throws SystemException
Specified by:
getStatus in interface Transaction
Throws:
SystemException

rollback

public void rollback()
              throws IllegalStateException,
                     SystemException
Specified by:
rollback in interface Transaction
Throws:
IllegalStateException
SystemException

setRollbackOnly

public void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
Specified by:
setRollbackOnly in interface Transaction
Throws:
IllegalStateException
SystemException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Uses of Class org.hibernate.transaction.BESTransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.BESTransactionManagerLookup

No usage of org.hibernate.transaction.BESTransactionManagerLookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.CacheSynchronization (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.CacheSynchronization

No usage of org.hibernate.transaction.CacheSynchronization

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.CMTTransaction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.CMTTransaction

No usage of org.hibernate.transaction.CMTTransaction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.CMTTransactionFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.CMTTransactionFactory

No usage of org.hibernate.transaction.CMTTransactionFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.JBossTransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.JBossTransactionManagerLookup

No usage of org.hibernate.transaction.JBossTransactionManagerLookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.JDBCTransaction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.JDBCTransaction

No usage of org.hibernate.transaction.JDBCTransaction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.JDBCTransactionFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.JDBCTransactionFactory

No usage of org.hibernate.transaction.JDBCTransactionFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.JNDITransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.JNDITransactionManagerLookup

Packages that use JNDITransactionManagerLookup
org.hibernate.transaction This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.

Uses of JNDITransactionManagerLookup in org.hibernate.transaction

Subclasses of JNDITransactionManagerLookup in org.hibernate.transaction
class | BESTransactionManagerLookup A TransactionManager lookup strategy for Borland ES.
class | JBossTransactionManagerLookup A TransactionManager lookup strategy for JBoss
class | JRun4TransactionManagerLookup TransactionManager lookup strategy for JRun4
class | OC4JTransactionManagerLookup TransactionManagerLookup for the OC4J (Oracle) app-server.
class | OrionTransactionManagerLookup TransactionManager lookup strategy for Orion
class | ResinTransactionManagerLookup TransactionManager lookup strategy for Resin
class | SunONETransactionManagerLookup TransactionManager lookup strategy for Sun ONE Application Server 7
class | WeblogicTransactionManagerLookup TransactionManager lookup strategy for WebLogic

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.JOnASTransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.JOnASTransactionManagerLookup

No usage of org.hibernate.transaction.JOnASTransactionManagerLookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.JOTMTransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.JOTMTransactionManagerLookup

No usage of org.hibernate.transaction.JOTMTransactionManagerLookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.JRun4TransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.JRun4TransactionManagerLookup

No usage of org.hibernate.transaction.JRun4TransactionManagerLookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.JTATransaction (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.JTATransaction

No usage of org.hibernate.transaction.JTATransaction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.JTATransactionFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.JTATransactionFactory

No usage of org.hibernate.transaction.JTATransactionFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.OC4JTransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.OC4JTransactionManagerLookup

No usage of org.hibernate.transaction.OC4JTransactionManagerLookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.OrionTransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.OrionTransactionManagerLookup

No usage of org.hibernate.transaction.OrionTransactionManagerLookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.ResinTransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.ResinTransactionManagerLookup

No usage of org.hibernate.transaction.ResinTransactionManagerLookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.SunONETransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.SunONETransactionManagerLookup

No usage of org.hibernate.transaction.SunONETransactionManagerLookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.transaction.TransactionFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.transaction.TransactionFactory

Packages that use TransactionFactory
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.

Uses of TransactionFactory in org.hibernate.cfg

Methods in org.hibernate.cfg that return TransactionFactory
protected TransactionFactory | SettingsFactory.createTransactionFactory(Properties properties)
TransactionFactory | Settings.getTransactionFactory()

Uses of TransactionFactory in org.hibernate.impl

Methods in org.hibernate.impl that return TransactionFactory
 TransactionFactory SessionFactoryImpl.getTransactionFactory()

Uses of TransactionFactory in org.hibernate.transaction

Classes in org.hibernate.transaction that implement TransactionFactory
class | CMTTransactionFactory Factory for CMTTransaction.
class | JDBCTransactionFactory Factory for JDBCTransaction.
class | JTATransactionFactory Factory for JTATransaction.

Methods in org.hibernate.transaction that return TransactionFactory
static TransactionFactory TransactionFactoryFactory.buildTransactionFactory(Properties transactionProps)
Obtain a TransactionFactory with the transaction handling strategy specified by the given Properties.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.transaction.TransactionFactory.Context (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.transaction.TransactionFactory.Context

Packages that use TransactionFactory.Context
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.jdbc | This package abstracts the mechanism for dispatching SQL statements to the database, and implements interaction with JDBC.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.

Uses of TransactionFactory.Context in org.hibernate.impl

Classes in org.hibernate.impl that implement TransactionFactory.Context
class | SessionImpl Concrete implementation of a Session, and also the central, organizing component of Hibernate's internal implementation.
class | StatelessSessionImpl

Uses of TransactionFactory.Context in org.hibernate.jdbc

Subinterfaces of TransactionFactory.Context in org.hibernate.jdbc
static interface JDBCContext.Context

Uses of TransactionFactory.Context in org.hibernate.transaction

Fields in org.hibernate.transaction declared as TransactionFactory.Context
protected  TransactionFactory.Context CMTTransaction.transactionContext

Methods in org.hibernate.transaction with parameters of type TransactionFactory.Context
Transaction | TransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context context) Begin a transaction and return the associated Transaction instance.
boolean | TransactionFactory.isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction) Determine whether an underlying transaction is in progress.
Transaction | JTATransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
boolean | JTATransactionFactory.isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction)
Transaction | JDBCTransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
boolean | JDBCTransactionFactory.isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction)
Transaction | CMTTransactionFactory.createTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
boolean | CMTTransactionFactory.isTransactionInProgress(JDBCContext jdbcContext, TransactionFactory.Context transactionContext, Transaction transaction)

Constructors in org.hibernate.transaction with parameters of type TransactionFactory.Context
JTATransaction(InitialContext context, String utName, JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
JDBCTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
CMTTransaction(JDBCContext jdbcContext, TransactionFactory.Context transactionContext)
CacheSynchronization(TransactionFactory.Context ctx, JDBCContext jdbcContext, Transaction transaction, Transaction tx)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.TransactionFactoryFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.TransactionFactoryFactory

No usage of org.hibernate.transaction.TransactionFactoryFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.transaction.TransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.transaction.TransactionManagerLookup

Packages that use TransactionManagerLookup
org.hibernate.cfg | This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.
org.hibernate.transaction | This package abstracts the underlying transaction mechanism (JTA or JDBC) and provides strategies for obtaining application server TransactionManagers.

Uses of TransactionManagerLookup in org.hibernate.cfg

Methods in org.hibernate.cfg that return TransactionManagerLookup
protected TransactionManagerLookup | SettingsFactory.createTransactionManagerLookup(Properties properties)
TransactionManagerLookup | Settings.getTransactionManagerLookup()

Uses of TransactionManagerLookup in org.hibernate.transaction

Classes in org.hibernate.transaction that implement TransactionManagerLookup
class | BESTransactionManagerLookup A TransactionManager lookup strategy for Borland ES.
class | JBossTransactionManagerLookup A TransactionManager lookup strategy for JBoss
class | JNDITransactionManagerLookup Locates a TransactionManager in JNDI.
class | JOnASTransactionManagerLookup TransactionManager lookup strategy for JOnAS
class | JOTMTransactionManagerLookup TransactionManager lookup strategy for JOTM
class | JRun4TransactionManagerLookup TransactionManager lookup strategy for JRun4
class | OC4JTransactionManagerLookup TransactionManagerLookup for the OC4J (Oracle) app-server.
class | OrionTransactionManagerLookup TransactionManager lookup strategy for Orion
class | ResinTransactionManagerLookup TransactionManager lookup strategy for Resin
class | SunONETransactionManagerLookup TransactionManager lookup strategy for Sun ONE Application Server 7
class | WeblogicTransactionManagerLookup TransactionManager lookup strategy for WebLogic
class | WebSphereExtendedJTATransactionLookup Support for proprietary interfaces for registering synchronizations in WebSphere 6.
class | WebSphereTransactionManagerLookup TransactionManager lookup strategy for WebSphere (versions 4, 5.0 and 5.1)

Methods in org.hibernate.transaction that return TransactionManagerLookup
static TransactionManagerLookup TransactionManagerLookupFactory.getTransactionManagerLookup(Properties props)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.TransactionManagerLookupFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.TransactionManagerLookupFactory

No usage of org.hibernate.transaction.TransactionManagerLookupFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.WeblogicTransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.WeblogicTransactionManagerLookup

No usage of org.hibernate.transaction.WeblogicTransactionManagerLookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.WebSphereExtendedJTATransactionLookup

No usage of org.hibernate.transaction.WebSphereExtendedJTATransactionLookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter

No usage of org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter

No usage of org.hibernate.transaction.WebSphereExtendedJTATransactionLookup.TransactionManagerAdapter.TransactionAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transaction.WebSphereTransactionManagerLookup (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transaction.WebSphereTransactionManagerLookup

No usage of org.hibernate.transaction.WebSphereTransactionManagerLookup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.transform (Hibernate API Documentation)

 org.hibernate.transform
Interfaces
ResultTransformer
Classes
AliasToBeanConstructorResultTransformer
AliasToBeanResultTransformer
AliasToEntityMapResultTransformer
DistinctRootEntityResultTransformer
PassThroughResultTransformer
RootEntityResultTransformer
ToListResultTransformer
Transformers


Uses of Class org.hibernate.transform.AliasToBeanConstructorResultTransformer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transform.AliasToBeanConstructorResultTransformer

No usage of org.hibernate.transform.AliasToBeanConstructorResultTransformer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transform.AliasToBeanResultTransformer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transform.AliasToBeanResultTransformer

No usage of org.hibernate.transform.AliasToBeanResultTransformer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transform.AliasToEntityMapResultTransformer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transform.AliasToEntityMapResultTransformer

No usage of org.hibernate.transform.AliasToEntityMapResultTransformer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transform.DistinctRootEntityResultTransformer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transform.DistinctRootEntityResultTransformer

No usage of org.hibernate.transform.DistinctRootEntityResultTransformer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transform.PassThroughResultTransformer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transform.PassThroughResultTransformer

No usage of org.hibernate.transform.PassThroughResultTransformer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.transform.ResultTransformer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.transform.ResultTransformer

Packages that use ResultTransformer
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.transform | Defines strategies for post-processing criteria query result sets into a form convenient to the application.

Uses of ResultTransformer in org.hibernate

Methods in org.hibernate with parameters of type ResultTransformer
Query | Query.setResultTransformer(ResultTransformer transformer) Set a strategy for handling the query results.
Criteria | Criteria.setResultTransformer(ResultTransformer resultTransformer) Set a strategy for handling the query results.

Uses of ResultTransformer in org.hibernate.criterion

Fields in org.hibernate.criterion declared as ResultTransformer
static ResultTransformer | CriteriaSpecification.ALIAS_TO_ENTITY_MAP Each row of results is a Map from alias to entity instance
static ResultTransformer | CriteriaSpecification.ROOT_ENTITY Each row of results is an instance of the root entity
static ResultTransformer | CriteriaSpecification.DISTINCT_ROOT_ENTITY Each row of results is a distinct instance of the root entity
static ResultTransformer | CriteriaSpecification.PROJECTION This result transformer is selected implicitly by calling setProjection()

Methods in org.hibernate.criterion with parameters of type ResultTransformer
 DetachedCriteria DetachedCriteria.setResultTransformer(ResultTransformer resultTransformer)

Uses of ResultTransformer in org.hibernate.engine

Methods in org.hibernate.engine that return ResultTransformer
 ResultTransformer QueryParameters.getResultTransformer()

Constructors in org.hibernate.engine with parameters of type ResultTransformer
QueryParameters(Type[] positionalParameterTypes, Object[] positionalParameterValues, Map lockModes, RowSelection rowSelection, boolean cacheable, String cacheRegion, String comment, boolean isLookupByNaturalKey, ResultTransformer transformer)
QueryParameters(Type[] positionalParameterTypes, Object[] positionalParameterValues, Map namedParameters, Map lockModes, RowSelection rowSelection, boolean readOnly, boolean cacheable, String cacheRegion, String comment, Serializable[] collectionKeys, ResultTransformer transformer)
QueryParameters(Type[] positionalParameterTypes, Object[] positionalParameterValues, Map namedParameters, Map lockModes, RowSelection rowSelection, boolean readOnly, boolean cacheable, String cacheRegion, String comment, Serializable[] collectionKeys, Object optionalObject, String optionalEntityName, Serializable optionalId, ResultTransformer transformer)

Uses of ResultTransformer in org.hibernate.hql

Methods in org.hibernate.hql that return ResultTransformer
static ResultTransformer | HolderInstantiator.createSelectNewTransformer(Constructor constructor, boolean returnMaps, boolean returnLists)
ResultTransformer | HolderInstantiator.getResultTransformer()

Methods in org.hibernate.hql with parameters of type ResultTransformer
static HolderInstantiator | HolderInstantiator.getHolderInstantiator(ResultTransformer selectNewTransformer, ResultTransformer customTransformer, String[] queryReturnAliases)
static HolderInstantiator | HolderInstantiator.createClassicHolderInstantiator(Constructor constructor, ResultTransformer transformer)

Constructors in org.hibernate.hql with parameters of type ResultTransformer
HolderInstantiator(ResultTransformer transformer, String[] queryReturnAliases)

Uses of ResultTransformer in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic with parameters of type ResultTransformer
protected Object | QueryTranslatorImpl.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
protected List | QueryTranslatorImpl.getResultList(List results, ResultTransformer resultTransformer)

Uses of ResultTransformer in org.hibernate.impl

Methods in org.hibernate.impl that return ResultTransformer
 ResultTransformer CriteriaImpl.getResultTransformer()

Methods in org.hibernate.impl with parameters of type ResultTransformer
Criteria | CriteriaImpl.setResultTransformer(ResultTransformer tupleMapper)
Criteria | CriteriaImpl.Subcriteria.setResultTransformer(ResultTransformer resultProcessor)
Query | AbstractQueryImpl.setResultTransformer(ResultTransformer transformer)

Uses of ResultTransformer in org.hibernate.loader

Methods in org.hibernate.loader with parameters of type ResultTransformer
protected List | Loader.getResultList(List results, ResultTransformer resultTransformer)
protected Object | Loader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session) Get the actual object that is returned in the user-visible result list.

Uses of ResultTransformer in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria with parameters of type ResultTransformer
protected Object | CriteriaLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
protected List | CriteriaLoader.getResultList(List results, ResultTransformer resultTransformer)

Uses of ResultTransformer in org.hibernate.loader.custom

Methods in org.hibernate.loader.custom with parameters of type ResultTransformer
protected Object | CustomLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
protected List | CustomLoader.getResultList(List results, ResultTransformer resultTransformer)

Uses of ResultTransformer in org.hibernate.loader.entity

Methods in org.hibernate.loader.entity with parameters of type ResultTransformer
protected Object | CollectionElementLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
protected Object | AbstractEntityLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)

Uses of ResultTransformer in org.hibernate.loader.hql

Methods in org.hibernate.loader.hql with parameters of type ResultTransformer
protected Object | QueryLoader.getResultColumnOrRow(Object[] row, ResultTransformer transformer, ResultSet rs, SessionImplementor session)
protected List | QueryLoader.getResultList(List results, ResultTransformer resultTransformer)

Uses of ResultTransformer in org.hibernate.transform

Classes in org.hibernate.transform that implement ResultTransformer
class | AliasToBeanConstructorResultTransformer
class | AliasToBeanResultTransformer Result transformer that allows to transform a result to a user specified class which will be populated via setter methods or fields matching the alias names.
class | AliasToEntityMapResultTransformer
class | DistinctRootEntityResultTransformer
class | PassThroughResultTransformer
class | RootEntityResultTransformer
class | ToListResultTransformer

Fields in org.hibernate.transform declared as ResultTransformer
static ResultTransformer | Transformers.ALIAS_TO_ENTITY_MAP Each row of results is a Map from alias to values/entities
static ResultTransformer | Transformers.TO_LIST Each row of results is a List
static ResultTransformer | ToListResultTransformer.INSTANCE

Methods in org.hibernate.transform that return ResultTransformer
static ResultTransformer Transformers.aliasToBean(Class target)
Creates a resulttransformer that will inject aliased values into instances of Class via property methods or fields.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transform.RootEntityResultTransformer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transform.RootEntityResultTransformer

No usage of org.hibernate.transform.RootEntityResultTransformer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transform.ToListResultTransformer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transform.ToListResultTransformer

No usage of org.hibernate.transform.ToListResultTransformer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.transform.Transformers (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.transform.Transformers

No usage of org.hibernate.transform.Transformers

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.tuple (Hibernate API Documentation)

 org.hibernate.tuple
Interfaces
Instantiator
Tuplizer
Classes
Dom4jInstantiator
DynamicMapInstantiator
ElementWrapper
EntityModeToTuplizerMapping
IdentifierProperty
PojoInstantiator
Property
PropertyFactory
StandardProperty
VersionProperty


Uses of Class org.hibernate.tuple.Dom4jInstantiator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.Dom4jInstantiator

No usage of org.hibernate.tuple.Dom4jInstantiator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.DynamicMapInstantiator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.DynamicMapInstantiator

No usage of org.hibernate.tuple.DynamicMapInstantiator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.ElementWrapper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.ElementWrapper

No usage of org.hibernate.tuple.ElementWrapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.EntityModeToTuplizerMapping (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.EntityModeToTuplizerMapping

Packages that use EntityModeToTuplizerMapping
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of EntityModeToTuplizerMapping in org.hibernate.tuple.entity

Subclasses of EntityModeToTuplizerMapping in org.hibernate.tuple.entity
 class EntityEntityModeToTuplizerMapping
Handles mapping EntityModes to EntityTuplizers.

Uses of EntityModeToTuplizerMapping in org.hibernate.type

Fields in org.hibernate.type declared as EntityModeToTuplizerMapping
protected  EntityModeToTuplizerMapping ComponentType.tuplizerMapping

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.IdentifierProperty (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.IdentifierProperty

Packages that use IdentifierProperty
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.entity |

Uses of IdentifierProperty in org.hibernate.tuple

Methods in org.hibernate.tuple that return IdentifierProperty
static IdentifierProperty PropertyFactory.buildIdentifierProperty(PersistentClass mappedEntity, IdentifierGenerator generator)
Generates an IdentifierProperty representation of the for a given entity mapping.

Uses of IdentifierProperty in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity that return IdentifierProperty
 IdentifierProperty EntityMetamodel.getIdentifierProperty()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.tuple.Instantiator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.tuple.Instantiator

Packages that use Instantiator
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |

Uses of Instantiator in org.hibernate.tuple

Classes in org.hibernate.tuple that implement Instantiator
class | Dom4jInstantiator Performs "instantiation" based on DOM4J elements.
class | DynamicMapInstantiator
class | PojoInstantiator Defines a POJO-based instantiator for use from the tuplizers.

Uses of Instantiator in org.hibernate.tuple.component

Fields in org.hibernate.tuple.component declared as Instantiator
protected  Instantiator AbstractComponentTuplizer.instantiator

Methods in org.hibernate.tuple.component that return Instantiator
protected Instantiator | PojoComponentTuplizer.buildInstantiator(Component component)
protected Instantiator | DynamicMapComponentTuplizer.buildInstantiator(Component component)
protected Instantiator | Dom4jComponentTuplizer.buildInstantiator(Component component)
protected abstract Instantiator | AbstractComponentTuplizer.buildInstantiator(Component component)

Uses of Instantiator in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity that return Instantiator
protected Instantiator | PojoEntityTuplizer.buildInstantiator(PersistentClass persistentClass)
protected Instantiator | DynamicMapEntityTuplizer.buildInstantiator(PersistentClass mappingInfo)
protected Instantiator | Dom4jEntityTuplizer.buildInstantiator(PersistentClass persistentClass)
protected abstract Instantiator | AbstractEntityTuplizer.buildInstantiator(PersistentClass mappingInfo) Build an appropriate Instantiator for the given mapped entity.
protected Instantiator | AbstractEntityTuplizer.getInstantiator()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.PojoInstantiator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.PojoInstantiator

No usage of org.hibernate.tuple.PojoInstantiator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.Property (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.Property

Packages that use Property
org.hibernate.tuple This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.

Uses of Property in org.hibernate.tuple

Subclasses of Property in org.hibernate.tuple
class | IdentifierProperty Represents a defined entity identifier property within the Hibernate runtime-metamodel.
class | StandardProperty Represents a basic property within the Hibernate runtime-metamodel.
class | VersionProperty Represents a version property within the Hibernate runtime-metamodel.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.PropertyFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.PropertyFactory

No usage of org.hibernate.tuple.PropertyFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.StandardProperty (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.StandardProperty

Packages that use StandardProperty
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of StandardProperty in org.hibernate.tuple

Subclasses of StandardProperty in org.hibernate.tuple
 class VersionProperty
Represents a version property within the Hibernate runtime-metamodel.

Methods in org.hibernate.tuple that return StandardProperty
static StandardProperty PropertyFactory.buildStandardProperty(Property property, boolean lazyAvailable)
Generate a "standard" (i.e., non-identifier and non-version) based on the given mapped property.

Uses of StandardProperty in org.hibernate.tuple.component

Methods in org.hibernate.tuple.component that return StandardProperty
StandardProperty[] | ComponentMetamodel.getProperties()
StandardProperty | ComponentMetamodel.getProperty(int index)
StandardProperty | ComponentMetamodel.getProperty(String propertyName)

Uses of StandardProperty in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity that return StandardProperty
 StandardProperty[] EntityMetamodel.getProperties()

Uses of StandardProperty in org.hibernate.type

Methods in org.hibernate.type with parameters of type StandardProperty
static int[] | TypeFactory.findDirty(StandardProperty[] properties, Object[] x, Object[] y, boolean[][] includeColumns, boolean anyUninitializedProperties, SessionImplementor session) Determine if any of the given field values are dirty, returning an array containing indexes of the dirty fields or null if no fields are dirty.
static int[] | TypeFactory.findModified(StandardProperty[] properties, Object[] x, Object[] y, boolean[][] includeColumns, boolean anyUninitializedProperties, SessionImplementor session) Determine if any of the given field values are modified, returning an array containing indexes of the dirty fields or null if no fields are dirty.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.tuple.Tuplizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.tuple.Tuplizer

Packages that use Tuplizer
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.component |
org.hibernate.tuple.entity |

Uses of Tuplizer in org.hibernate.tuple

Methods in org.hibernate.tuple that return Tuplizer
Tuplizer | EntityModeToTuplizerMapping.getTuplizerOrNull(EntityMode entityMode) Locate the contained tuplizer responsible for the given entity-mode.
Tuplizer | EntityModeToTuplizerMapping.getTuplizer(EntityMode entityMode) Locate the tuplizer contained within this mapping which is responsible for the given entity-mode.

Methods in org.hibernate.tuple with parameters of type Tuplizer
protected  void EntityModeToTuplizerMapping.addTuplizer(EntityMode entityMode, Tuplizer tuplizer)

Uses of Tuplizer in org.hibernate.tuple.component

Subinterfaces of Tuplizer in org.hibernate.tuple.component
 interface ComponentTuplizer
Defines further responsibilities reagarding tuplization based on a mapped components.

Classes in org.hibernate.tuple.component that implement Tuplizer
class | AbstractComponentTuplizer Support for tuplizers relating to components.
class | Dom4jComponentTuplizer A ComponentTuplizer specific to the dom4j entity mode.
class | DynamicMapComponentTuplizer A ComponentTuplizer specific to the dynamic-map entity mode.
class | PojoComponentTuplizer A ComponentTuplizer specific to the pojo entity mode.

Uses of Tuplizer in org.hibernate.tuple.entity

Subinterfaces of Tuplizer in org.hibernate.tuple.entity
 interface EntityTuplizer
Defines further responsibilities reagarding tuplization based on a mapped entity.

Classes in org.hibernate.tuple.entity that implement Tuplizer
class | AbstractEntityTuplizer Support for tuplizers relating to entities.
class | Dom4jEntityTuplizer An EntityTuplizer specific to the dom4j entity mode.
class | DynamicMapEntityTuplizer An EntityTuplizer specific to the dynamic-map entity mode.
class | PojoEntityTuplizer An EntityTuplizer specific to the pojo entity mode.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.VersionProperty (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.VersionProperty

Packages that use VersionProperty
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.entity |

Uses of VersionProperty in org.hibernate.tuple

Methods in org.hibernate.tuple that return VersionProperty
static VersionProperty PropertyFactory.buildVersionProperty(Property property, boolean lazyAvailable)
Generates a VersionProperty representation for an entity mapping given its version mapping Property.

Uses of VersionProperty in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity that return VersionProperty
 VersionProperty EntityMetamodel.getVersionProperty()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.tuple.component (Hibernate API Documentation)

 org.hibernate.tuple.component
Interfaces
ComponentTuplizer
Classes
AbstractComponentTuplizer
ComponentMetamodel
Dom4jComponentTuplizer
DynamicMapComponentTuplizer
PojoComponentTuplizer


Uses of Class org.hibernate.tuple.component.AbstractComponentTuplizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.component.AbstractComponentTuplizer

Packages that use AbstractComponentTuplizer
org.hibernate.tuple.component

Uses of AbstractComponentTuplizer in org.hibernate.tuple.component

Subclasses of AbstractComponentTuplizer in org.hibernate.tuple.component
class | Dom4jComponentTuplizer A ComponentTuplizer specific to the dom4j entity mode.
class | DynamicMapComponentTuplizer A ComponentTuplizer specific to the dynamic-map entity mode.
class | PojoComponentTuplizer A ComponentTuplizer specific to the pojo entity mode.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.component.ComponentMetamodel (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.component.ComponentMetamodel

Packages that use ComponentMetamodel
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of ComponentMetamodel in org.hibernate.type

Constructors in org.hibernate.type with parameters of type ComponentMetamodel
EmbeddedComponentType(ComponentMetamodel metamodel)
ComponentType(ComponentMetamodel metamodel)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.tuple.component.ComponentTuplizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.tuple.component.ComponentTuplizer

Packages that use ComponentTuplizer
org.hibernate.tuple.component

Uses of ComponentTuplizer in org.hibernate.tuple.component

Classes in org.hibernate.tuple.component that implement ComponentTuplizer
class | AbstractComponentTuplizer Support for tuplizers relating to components.
class | Dom4jComponentTuplizer A ComponentTuplizer specific to the dom4j entity mode.
class | DynamicMapComponentTuplizer A ComponentTuplizer specific to the dynamic-map entity mode.
class | PojoComponentTuplizer A ComponentTuplizer specific to the pojo entity mode.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.component.Dom4jComponentTuplizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.component.Dom4jComponentTuplizer

No usage of org.hibernate.tuple.component.Dom4jComponentTuplizer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.component.DynamicMapComponentTuplizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.component.DynamicMapComponentTuplizer

No usage of org.hibernate.tuple.component.DynamicMapComponentTuplizer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.component.PojoComponentTuplizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.component.PojoComponentTuplizer

No usage of org.hibernate.tuple.component.PojoComponentTuplizer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.tuple.entity (Hibernate API Documentation)

 org.hibernate.tuple.entity
Interfaces
EntityTuplizer
Classes
AbstractEntityTuplizer
Dom4jEntityTuplizer
DynamicMapEntityTuplizer
EntityEntityModeToTuplizerMapping
EntityMetamodel
PojoEntityTuplizer


Uses of Class org.hibernate.tuple.entity.AbstractEntityTuplizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.entity.AbstractEntityTuplizer

Packages that use AbstractEntityTuplizer
org.hibernate.tuple.entity

Uses of AbstractEntityTuplizer in org.hibernate.tuple.entity

Subclasses of AbstractEntityTuplizer in org.hibernate.tuple.entity
class | Dom4jEntityTuplizer An EntityTuplizer specific to the dom4j entity mode.
class | DynamicMapEntityTuplizer An EntityTuplizer specific to the dynamic-map entity mode.
class | PojoEntityTuplizer An EntityTuplizer specific to the pojo entity mode.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.entity.Dom4jEntityTuplizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.entity.Dom4jEntityTuplizer

No usage of org.hibernate.tuple.entity.Dom4jEntityTuplizer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.entity.DynamicMapEntityTuplizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.entity.DynamicMapEntityTuplizer

No usage of org.hibernate.tuple.entity.DynamicMapEntityTuplizer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.entity.EntityEntityModeToTuplizerMapping (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.entity.EntityEntityModeToTuplizerMapping

No usage of org.hibernate.tuple.entity.EntityEntityModeToTuplizerMapping

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.entity.EntityMetamodel (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.entity.EntityMetamodel

Packages that use EntityMetamodel
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.tuple.entity |

Uses of EntityMetamodel in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return EntityMetamodel
protected  EntityMetamodel AbstractEntityPersister.getEntityMetamodel()

Uses of EntityMetamodel in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity that return EntityMetamodel
protected  EntityMetamodel AbstractEntityTuplizer.getEntityMetamodel()

Constructors in org.hibernate.tuple.entity with parameters of type EntityMetamodel
PojoEntityTuplizer(EntityMetamodel entityMetamodel, PersistentClass mappedEntity)
EntityEntityModeToTuplizerMapping(PersistentClass mappedEntity, EntityMetamodel em)
Instantiates a EntityEntityModeToTuplizerMapping based on the given entity mapping and metamodel definitions.
AbstractEntityTuplizer(EntityMetamodel entityMetamodel, PersistentClass mappingInfo)
Constructs a new AbstractEntityTuplizer instance.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.tuple.entity.EntityTuplizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.tuple.entity.EntityTuplizer

Packages that use EntityTuplizer
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.tuple.entity |

Uses of EntityTuplizer in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return EntityTuplizer
protected EntityTuplizer | AbstractEntityPersister.getTuplizer(SessionImplementor session)
protected EntityTuplizer | AbstractEntityPersister.getTuplizer(EntityMode entityMode)

Uses of EntityTuplizer in org.hibernate.tuple.entity

Classes in org.hibernate.tuple.entity that implement EntityTuplizer
class | AbstractEntityTuplizer Support for tuplizers relating to entities.
class | Dom4jEntityTuplizer An EntityTuplizer specific to the dom4j entity mode.
class | DynamicMapEntityTuplizer An EntityTuplizer specific to the dynamic-map entity mode.
class | PojoEntityTuplizer An EntityTuplizer specific to the pojo entity mode.

Methods in org.hibernate.tuple.entity that return EntityTuplizer
EntityTuplizer | EntityMetamodel.getTuplizer(EntityMode entityMode)
EntityTuplizer | EntityMetamodel.getTuplizerOrNull(EntityMode entityMode)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.tuple.entity.PojoEntityTuplizer (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.tuple.entity.PojoEntityTuplizer

No usage of org.hibernate.tuple.entity.PojoEntityTuplizer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.type (Hibernate API Documentation)

 org.hibernate.type
Interfaces
AbstractComponentType
AssociationType
DiscriminatorType
IdentifierType
LiteralType
Type
VersionType
Classes
AbstractBynaryType
AbstractCharArrayType
AbstractType
AdaptedImmutableType
AnyType
AnyType.ObjectTypeCacheEntry
ArrayType
BagType
BigDecimalType
BigIntegerType
BinaryType
BlobType
BooleanType
ByteType
CalendarDateType
CalendarType
CharacterArrayType
CharacterType
CharArrayType
CharBooleanType
ClassType
ClobType
CollectionType
ComponentType
CompositeCustomType
CurrencyType
CustomCollectionType
CustomType
DateType
DbTimestampType
DoubleType
EmbeddedComponentType
EntityType
FloatType
ForeignKeyDirection
IdentifierBagType
ImmutableType
IntegerType
ListType
LocaleType
LongType
ManyToOneType
MapType
MetaType
MutableType
NullableType
OneToOneType
OrderedMapType
OrderedSetType
PrimitiveType
SerializableType
SetType
ShortType
SortedMapType
SortedSetType
SpecialOneToOneType
StringType
TextType
TimestampType
TimeType
TimeZoneType
TrueFalseType
TypeFactory
WrapperBinaryType
YesNoType
Exceptions
SerializationException


Uses of Class org.hibernate.type.AbstractBynaryType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.AbstractBynaryType

Packages that use AbstractBynaryType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of AbstractBynaryType in org.hibernate.type

Subclasses of AbstractBynaryType in org.hibernate.type
class | BinaryType binary: A type that maps an SQL VARBINARY to a Java byte[].
class | WrapperBinaryType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.AbstractCharArrayType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.AbstractCharArrayType

Packages that use AbstractCharArrayType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of AbstractCharArrayType in org.hibernate.type

Subclasses of AbstractCharArrayType in org.hibernate.type
class | CharacterArrayType Bridge Character[] and VARCHAR
class | CharArrayType put char[] into VARCHAR

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.type.AbstractComponentType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.type.AbstractComponentType

Packages that use AbstractComponentType
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.proxy | This package defines a framework for lazy-initializing entity proxies.
org.hibernate.proxy.dom4j |
org.hibernate.proxy.map |
org.hibernate.proxy.pojo |
org.hibernate.proxy.pojo.cglib |
org.hibernate.proxy.pojo.javassist |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of AbstractComponentType in org.hibernate.criterion

Methods in org.hibernate.criterion with parameters of type AbstractComponentType
protected void | Example.addComponentTypedValues(String path, Object component, AbstractComponentType type, List list, Criteria criteria, CriteriaQuery criteriaQuery)
protected void | Example.appendComponentCondition(String path, Object component, AbstractComponentType type, Criteria criteria, CriteriaQuery criteriaQuery, StringBuffer buf)

Uses of AbstractComponentType in org.hibernate.persister.collection

Constructors in org.hibernate.persister.collection with parameters of type AbstractComponentType
CompositeElementPropertyMapping(String[] elementColumns, String[] elementFormulaTemplates, AbstractComponentType compositeType, Mapping factory)

Uses of AbstractComponentType in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity with parameters of type AbstractComponentType
protected  void AbstractPropertyMapping.initComponentPropertyPaths(String path, AbstractComponentType type, String[] columns, String[] formulaTemplates, Mapping factory)

Uses of AbstractComponentType in org.hibernate.proxy

Methods in org.hibernate.proxy with parameters of type AbstractComponentType
 void ProxyFactory.postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType)
Called immediately after instantiation of this factory.

Uses of AbstractComponentType in org.hibernate.proxy.dom4j

Methods in org.hibernate.proxy.dom4j with parameters of type AbstractComponentType
 void Dom4jProxyFactory.postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType)
Called immediately after instantiation

Uses of AbstractComponentType in org.hibernate.proxy.map

Methods in org.hibernate.proxy.map with parameters of type AbstractComponentType
 void MapProxyFactory.postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType)

Uses of AbstractComponentType in org.hibernate.proxy.pojo

Fields in org.hibernate.proxy.pojo declared as AbstractComponentType
protected  AbstractComponentType BasicLazyInitializer.componentIdType

Constructors in org.hibernate.proxy.pojo with parameters of type AbstractComponentType
BasicLazyInitializer(String entityName, Class persistentClass, Serializable id, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, SessionImplementor session)

Uses of AbstractComponentType in org.hibernate.proxy.pojo.cglib

Methods in org.hibernate.proxy.pojo.cglib with parameters of type AbstractComponentType
void | CGLIBProxyFactory.postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType)
static HibernateProxy | CGLIBLazyInitializer.getProxy(Class factory, String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)

Constructors in org.hibernate.proxy.pojo.cglib with parameters of type AbstractComponentType
SerializableProxy(String entityName, Class persistentClass, Class[] interfaces, Serializable id, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType)

Uses of AbstractComponentType in org.hibernate.proxy.pojo.javassist

Methods in org.hibernate.proxy.pojo.javassist with parameters of type AbstractComponentType
void | JavassistProxyFactory.postInstantiate(String entityName, Class persistentClass, Set interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType)
static HibernateProxy | JavassistLazyInitializer.getProxy(String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)
static HibernateProxy | JavassistLazyInitializer.getProxy(Class factory, String entityName, Class persistentClass, Class[] interfaces, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType, Serializable id, SessionImplementor session)

Constructors in org.hibernate.proxy.pojo.javassist with parameters of type AbstractComponentType
SerializableProxy(String entityName, Class persistentClass, Class[] interfaces, Serializable id, Method getIdentifierMethod, Method setIdentifierMethod, AbstractComponentType componentIdType)

Uses of AbstractComponentType in org.hibernate.type

Classes in org.hibernate.type that implement AbstractComponentType
class | AnyType Handles "any" mappings and the old deprecated "object" type
class | ComponentType Handles "component" mappings
class | CompositeCustomType Adapts CompositeUserType to Type interface
class | EmbeddedComponentType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.AbstractType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.AbstractType

Packages that use AbstractType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of AbstractType in org.hibernate.type

Subclasses of AbstractType in org.hibernate.type
class | AbstractBynaryType Logic to bind stream of byte into a VARBINARY
class | AbstractCharArrayType Logic to bind stream of char into a VARCHAR
class | AdaptedImmutableType Optimize a mutable type, if the user promises not to mutable the instances.
class | AnyType Handles "any" mappings and the old deprecated "object" type
class | ArrayType A type for persistent arrays.
class | BagType
class | BigDecimalType big_decimal: A type that maps an SQL NUMERIC to a java.math.BigDecimal
class | BigIntegerType big_integer: A type that maps an SQL NUMERIC to a java.math.BigInteger
class | BinaryType binary: A type that maps an SQL VARBINARY to a Java byte[].
class | BlobType blob: A type that maps an SQL BLOB to a java.sql.Blob.
class | BooleanType boolean: A type that maps an SQL BIT to a Java Boolean.
class | ByteType byte: A type that maps an SQL TINYINT to a Java Byte.
class | CalendarDateType calendar_date: A type mapping for a Calendar object that represents a date.
class | CalendarType calendar: A type mapping for a Calendar object that represents a datetime.
class | CharacterArrayType Bridge Character[] and VARCHAR
class | CharacterType character: A type that maps an SQL CHAR(1) to a Java Character.
class | CharArrayType put char[] into VARCHAR
class | CharBooleanType Superclass for types that map Java boolean to SQL CHAR(1).
class | ClassType class: A type that maps an SQL VARCHAR to a Java Class.
class | ClobType clob: A type that maps an SQL CLOB to a java.sql.Clob.
class | CollectionType A type that handles Hibernate PersistentCollections (including arrays).
class | ComponentType Handles "component" mappings
class | CompositeCustomType Adapts CompositeUserType to Type interface
class | CurrencyType currency: A type that maps an SQL VARCHAR to a java.util.Currency
class | CustomCollectionType A custom type for mapping user-written classes that implement PersistentCollection
class | CustomType Adapts UserType to the generic Type interface, in order to isolate user code from changes in the internal Type contracts.
class | DateType date: A type that maps an SQL DATE to a Java Date.
class | DbTimestampType dbtimestamp: An extension of TimestampType which maps to the database's current timestamp, rather than the jvm's current timestamp.
class | DoubleType double: A type that maps an SQL DOUBLE to a Java Double.
class | EmbeddedComponentType
class | EntityType A reference to an entity class
class | FloatType float: A type that maps an SQL FLOAT to a Java Float.
class | IdentifierBagType
class | ImmutableType Superclass of nullable immutable types.
class | IntegerType integer: A type that maps an SQL INT to a Java Integer.
class | ListType
class | LocaleType locale: A type that maps an SQL VARCHAR to a Java Locale.
class | LongType long: A type that maps an SQL BIGINT to a Java Long.
class | ManyToOneType A many-to-one association to an entity.
class | MapType
class | MetaType
class | MutableType Superclass for mutable nullable types
class | NullableType Superclass of single-column nullable types.
class | OneToOneType A one-to-one association to an entity
class | OrderedMapType
class | OrderedSetType
class | PrimitiveType Superclass of primitive / primitive wrapper types.
class | SerializableType serializable: A type that maps an SQL VARBINARY to a serializable Java object.
class | SetType
class | ShortType short: A type that maps an SQL SMALLINT to a Java Short.
class | SortedMapType
class | SortedSetType
class | SpecialOneToOneType A one-to-one association that maps to specific formula(s) instead of the primary key column of the owning entity.
class | StringType string: A type that maps an SQL VARCHAR to a Java String.
class | TextType text: A type that maps an SQL CLOB to a Java String.
class | TimestampType timestamp: A type that maps an SQL TIMESTAMP to a Java java.util.Date or java.sql.Timestamp.
class | TimeType time: A type that maps an SQL TIME to a Java java.util.Date or java.sql.Time.
class | TimeZoneType timezone: A type that maps an SQL VARCHAR to a java.util.TimeZone
class | TrueFalseType true_false: A type that maps an SQL CHAR(1) to a Java Boolean.
class | WrapperBinaryType
class | YesNoType yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.AdaptedImmutableType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.AdaptedImmutableType

No usage of org.hibernate.type.AdaptedImmutableType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.AnyType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.AnyType

No usage of org.hibernate.type.AnyType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.AnyType.ObjectTypeCacheEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.AnyType.ObjectTypeCacheEntry

No usage of org.hibernate.type.AnyType.ObjectTypeCacheEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.ArrayType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.ArrayType

No usage of org.hibernate.type.ArrayType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.type.AssociationType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.type.AssociationType

Packages that use AssociationType
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.hql.ast.util |
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of AssociationType in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type AssociationType
JoinSequence | JoinSequence.addJoin(AssociationType associationType, String alias, int joinType, String[] referencingKey)
static String[] | JoinHelper.getAliasedLHSColumnNames(AssociationType type, String alias, int property, OuterJoinLoadable lhsPersister, Mapping mapping) Get the aliased columns of the owning entity which are to be used in the join
static String[] | JoinHelper.getLHSColumnNames(AssociationType type, int property, OuterJoinLoadable lhsPersister, Mapping mapping) Get the columns of the owning entity which are to be used in the join
static String[] | JoinHelper.getAliasedLHSColumnNames(AssociationType type, String alias, int property, int begin, OuterJoinLoadable lhsPersister, Mapping mapping) Get the aliased columns of the owning entity which are to be used in the join
static String[] | JoinHelper.getLHSColumnNames(AssociationType type, int property, int begin, OuterJoinLoadable lhsPersister, Mapping mapping) Get the columns of the owning entity which are to be used in the join
static String | JoinHelper.getLHSTableName(AssociationType type, int property, OuterJoinLoadable lhsPersister)
static String[] | JoinHelper.getRHSColumnNames(AssociationType type, SessionFactoryImplementor factory) Get the columns of the associated table which are to be used in the join

Uses of AssociationType in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util that return AssociationType
 AssociationType SessionFactoryHelper.getElementAssociationType(CollectionType collectionType)
Essentially the same as #getElementType, but requiring that the element type be an association type.

Methods in org.hibernate.hql.ast.util with parameters of type AssociationType
 JoinSequence SessionFactoryHelper.createJoinSequence(boolean implicit, AssociationType associationType, String tableAlias, int joinType, String[] columns)
Generate a join sequence representing the given association type.

Uses of AssociationType in org.hibernate.loader

Methods in org.hibernate.loader that return AssociationType
 AssociationType OuterJoinableAssociation.getJoinableType()

Methods in org.hibernate.loader with parameters of type AssociationType
protected int | JoinWalker.getJoinType(AssociationType type, FetchMode config, String path, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth, CascadeStyle cascadeStyle) Get the join type (inner, outer, etc) or -1 if the association should not be joined.
protected boolean | JoinWalker.isJoinedFetchEnabledInMapping(FetchMode config, AssociationType type) Does the mapping, and Hibernate default semantics, specify that this association should be fetched by outer joining
protected boolean | JoinWalker.isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) Override on subclasses to enable or suppress joining of certain association types
protected boolean | JoinWalker.isDuplicateAssociation(String lhsTable, String[] lhsColumnNames, AssociationType type) Used to detect circularities in the joined graph, note that this method is side-effecty
protected boolean | JoinWalker.isJoinable(int joinType, Set visitedAssociationKeys, String lhsTable, String[] lhsColumnNames, AssociationType type, int depth) Should we join this association?
protected boolean | AbstractEntityJoinWalker.isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) The superclass deliberately excludes collections

Constructors in org.hibernate.loader with parameters of type AssociationType
OuterJoinableAssociation(AssociationType joinableType, String lhsAlias, String[] lhsColumns, String rhsAlias, int joinType, SessionFactoryImplementor factory, Map enabledFilters)

Uses of AssociationType in org.hibernate.loader.collection

Methods in org.hibernate.loader.collection with parameters of type AssociationType
protected  int BasicCollectionJoinWalker.getJoinType(AssociationType type, FetchMode config, String path, Set visitedAssociations, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth)
We can use an inner join for first many-to-many association

Uses of AssociationType in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria with parameters of type AssociationType
protected  int CriteriaJoinWalker.getJoinType(AssociationType type, FetchMode config, String path, String lhsTable, String[] lhsColumns, boolean nullable, int currentDepth, CascadeStyle cascadeStyle)

Uses of AssociationType in org.hibernate.loader.entity

Methods in org.hibernate.loader.entity with parameters of type AssociationType
protected boolean | EntityJoinWalker.isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle) Disable outer join fetching if this loader obtains an upgrade lock mode
protected boolean | CascadeEntityJoinWalker.isJoinedFetchEnabled(AssociationType type, FetchMode config, CascadeStyle cascadeStyle)

Uses of AssociationType in org.hibernate.type

Classes in org.hibernate.type that implement AssociationType
class | AnyType Handles "any" mappings and the old deprecated "object" type
class | ArrayType A type for persistent arrays.
class | BagType
class | CollectionType A type that handles Hibernate PersistentCollections (including arrays).
class | CustomCollectionType A custom type for mapping user-written classes that implement PersistentCollection
class | EntityType A reference to an entity class
class | IdentifierBagType
class | ListType
class | ManyToOneType A many-to-one association to an entity.
class | MapType
class | OneToOneType A one-to-one association to an entity
class | OrderedMapType
class | OrderedSetType
class | SetType
class | SortedMapType
class | SortedSetType
class | SpecialOneToOneType A one-to-one association that maps to specific formula(s) instead of the primary key column of the owning entity.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.BagType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.BagType

No usage of org.hibernate.type.BagType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.BigDecimalType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.BigDecimalType

No usage of org.hibernate.type.BigDecimalType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.BigIntegerType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.BigIntegerType

No usage of org.hibernate.type.BigIntegerType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.BinaryType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.BinaryType

No usage of org.hibernate.type.BinaryType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.BlobType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.BlobType

No usage of org.hibernate.type.BlobType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.BooleanType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.BooleanType

Packages that use BooleanType
org.hibernate.hql.ast.tree |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of BooleanType in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return BooleanType
 BooleanType BooleanLiteralNode.getTypeInternal()

Uses of BooleanType in org.hibernate.type

Subclasses of BooleanType in org.hibernate.type
class | CharBooleanType Superclass for types that map Java boolean to SQL CHAR(1).
class | TrueFalseType true_false: A type that maps an SQL CHAR(1) to a Java Boolean.
class | YesNoType yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.ByteType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.ByteType

No usage of org.hibernate.type.ByteType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.CalendarDateType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.CalendarDateType

No usage of org.hibernate.type.CalendarDateType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.CalendarType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.CalendarType

No usage of org.hibernate.type.CalendarType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.CharacterArrayType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.CharacterArrayType

No usage of org.hibernate.type.CharacterArrayType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.CharacterType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.CharacterType

No usage of org.hibernate.type.CharacterType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.CharArrayType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.CharArrayType

No usage of org.hibernate.type.CharArrayType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.CharBooleanType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.CharBooleanType

Packages that use CharBooleanType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of CharBooleanType in org.hibernate.type

Subclasses of CharBooleanType in org.hibernate.type
class | TrueFalseType true_false: A type that maps an SQL CHAR(1) to a Java Boolean.
class | YesNoType yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.ClassType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.ClassType

No usage of org.hibernate.type.ClassType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.ClobType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.ClobType

No usage of org.hibernate.type.ClobType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.CollectionType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.CollectionType

Packages that use CollectionType
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.hql.ast.util |
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of CollectionType in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type CollectionType
static void | Collections.processReachableCollection(PersistentCollection collection, CollectionType type, Object entity, SessionImplementor session) Initialize the role of the collection.
abstract Iterator | CascadingAction.getCascadableChildrenIterator(EventSource session, CollectionType collectionType, Object collection) Given a collection, get an iterator of the children upon which the current cascading action should be visited.
static Iterator | CascadingAction.getLoadedElementsIterator(SessionImplementor session, CollectionType collectionType, Object collection) Iterate just the elements of the collection that are already there.

Uses of CollectionType in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type CollectionType
protected void | ProxyVisitor.reattachCollection(PersistentCollection collection, CollectionType type) Reattach a detached (disassociated) initialized or uninitialized collection wrapper, using a snapshot carried with the collection wrapper
void | EvictVisitor.evictCollection(Object value, CollectionType type)

Uses of CollectionType in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util with parameters of type CollectionType
String | SessionFactoryHelper.getAssociatedEntityName(CollectionType collectionType) Given a collection type, determine the entity name of the elements contained within instance of that collection.
AssociationType | SessionFactoryHelper.getElementAssociationType(CollectionType collectionType) Essentially the same as #getElementType, but requiring that the element type be an association type.

Uses of CollectionType in org.hibernate.mapping

Methods in org.hibernate.mapping that return CollectionType
CollectionType | Set.getDefaultCollectionType()
CollectionType | Map.getDefaultCollectionType()
CollectionType | List.getDefaultCollectionType()
CollectionType | IdentifierBag.getDefaultCollectionType()
abstract CollectionType | Collection.getDefaultCollectionType()
CollectionType | Collection.getCollectionType()
CollectionType | Bag.getDefaultCollectionType()
CollectionType | Array.getDefaultCollectionType()

Uses of CollectionType in org.hibernate.persister.collection

Methods in org.hibernate.persister.collection that return CollectionType
CollectionType | CollectionPersister.getCollectionType() Get the associated Type
CollectionType | AbstractCollectionPersister.getCollectionType()

Uses of CollectionType in org.hibernate.type

Subclasses of CollectionType in org.hibernate.type
class | ArrayType A type for persistent arrays.
class | BagType
class | CustomCollectionType A custom type for mapping user-written classes that implement PersistentCollection
class | IdentifierBagType
class | ListType
class | MapType
class | OrderedMapType
class | OrderedSetType
class | SetType
class | SortedMapType
class | SortedSetType

Methods in org.hibernate.type that return CollectionType
static CollectionType | TypeFactory.customCollection(String typeName, String role, String propertyRef, boolean embedded)
static CollectionType | TypeFactory.array(String role, String propertyRef, boolean embedded, Class elementClass)
static CollectionType | TypeFactory.list(String role, String propertyRef, boolean embedded)
static CollectionType | TypeFactory.bag(String role, String propertyRef, boolean embedded)
static CollectionType | TypeFactory.idbag(String role, String propertyRef, boolean embedded)
static CollectionType | TypeFactory.map(String role, String propertyRef, boolean embedded)
static CollectionType | TypeFactory.orderedMap(String role, String propertyRef, boolean embedded)
static CollectionType | TypeFactory.set(String role, String propertyRef, boolean embedded)
static CollectionType | TypeFactory.orderedSet(String role, String propertyRef, boolean embedded)
static CollectionType | TypeFactory.sortedMap(String role, String propertyRef, boolean embedded, Comparator comparator)
static CollectionType | TypeFactory.sortedSet(String role, String propertyRef, boolean embedded, Comparator comparator)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.ComponentType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.ComponentType

Packages that use ComponentType
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of ComponentType in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity with parameters of type ComponentType
protected  Object AbstractEntityTuplizer.getComponentValue(ComponentType type, Object component, String propertyPath)
Extract a component property value.

Uses of ComponentType in org.hibernate.type

Subclasses of ComponentType in org.hibernate.type
 class EmbeddedComponentType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.CompositeCustomType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.CompositeCustomType

No usage of org.hibernate.type.CompositeCustomType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.CurrencyType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.CurrencyType

No usage of org.hibernate.type.CurrencyType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.CustomCollectionType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.CustomCollectionType

No usage of org.hibernate.type.CustomCollectionType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.CustomType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.CustomType

No usage of org.hibernate.type.CustomType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.DateType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.DateType

No usage of org.hibernate.type.DateType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.DbTimestampType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.DbTimestampType

No usage of org.hibernate.type.DbTimestampType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.type.DiscriminatorType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.type.DiscriminatorType

Packages that use DiscriminatorType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of DiscriminatorType in org.hibernate.type

Classes in org.hibernate.type that implement DiscriminatorType
class | BigIntegerType big_integer: A type that maps an SQL NUMERIC to a java.math.BigInteger
class | BooleanType boolean: A type that maps an SQL BIT to a Java Boolean.
class | ByteType byte: A type that maps an SQL TINYINT to a Java Byte.
class | CharacterType character: A type that maps an SQL CHAR(1) to a Java Character.
class | CharBooleanType Superclass for types that map Java boolean to SQL CHAR(1).
class | CustomType Adapts UserType to the generic Type interface, in order to isolate user code from changes in the internal Type contracts.
class | IntegerType integer: A type that maps an SQL INT to a Java Integer.
class | LongType long: A type that maps an SQL BIGINT to a Java Long.
class | ShortType short: A type that maps an SQL SMALLINT to a Java Short.
class | StringType string: A type that maps an SQL VARCHAR to a Java String.
class | TrueFalseType true_false: A type that maps an SQL CHAR(1) to a Java Boolean.
class | YesNoType yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.DoubleType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.DoubleType

No usage of org.hibernate.type.DoubleType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.EmbeddedComponentType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.EmbeddedComponentType

No usage of org.hibernate.type.EmbeddedComponentType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.EntityType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.EntityType

Packages that use EntityType
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.hql | This package defines a loader for the AST-based query parser
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of EntityType in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree with parameters of type EntityType
 void FromElement.initializeEntity(FromClause fromClause, String className, EntityPersister persister, EntityType type, String classAlias, String tableAlias)

Uses of EntityType in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util with parameters of type EntityType
 String SessionFactoryHelper.getIdentifierOrUniqueKeyPropertyName(EntityType entityType)
Determine the name of the property for the entity encapsulated by the given type which represents the id or unique-key.

Uses of EntityType in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that return EntityType
protected  EntityType[] QueryTranslatorImpl.getOwnerAssociationTypes()

Uses of EntityType in org.hibernate.loader

Fields in org.hibernate.loader declared as EntityType
protected EntityType[] | OuterJoinLoader.ownerAssociationTypes
protected EntityType[] | JoinWalker.ownerAssociationTypes

Methods in org.hibernate.loader that return EntityType
protected EntityType[] | OuterJoinLoader.getOwnerAssociationTypes()
protected EntityType[] | Loader.getOwnerAssociationTypes() An array of unique key property names by which the corresponding entities are referenced by other entities in the result set
EntityType[] | JoinWalker.getOwnerAssociationTypes()

Methods in org.hibernate.loader with parameters of type EntityType
 void JoinWalker.setOwnerAssociationTypes(EntityType[] ownerAssociationType)

Uses of EntityType in org.hibernate.loader.hql

Methods in org.hibernate.loader.hql that return EntityType
protected  EntityType[] QueryLoader.getOwnerAssociationTypes()

Uses of EntityType in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return EntityType
EntityType | OuterJoinLoadable.getEntityType()
EntityType | AbstractEntityPersister.getEntityType()

Methods in org.hibernate.persister.entity with parameters of type EntityType
protected  void AbstractPropertyMapping.initIdentifierPropertyPaths(String path, EntityType etype, String[] columns, Mapping factory)

Uses of EntityType in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity that return EntityType
 EntityType EntityMetamodel.getEntityType()

Uses of EntityType in org.hibernate.type

Subclasses of EntityType in org.hibernate.type
class | ManyToOneType A many-to-one association to an entity.
class | OneToOneType A one-to-one association to an entity
class | SpecialOneToOneType A one-to-one association that maps to specific formula(s) instead of the primary key column of the owning entity.

Methods in org.hibernate.type that return EntityType
static EntityType | TypeFactory.oneToOne(String persistentClass, ForeignKeyDirection foreignKeyType, String uniqueKeyPropertyName, boolean lazy, boolean unwrapProxy, boolean isEmbeddedInXML, String entityName, String propertyName) A one-to-one association type for the given class
static EntityType | TypeFactory.manyToOne(String persistentClass) A many-to-one association type for the given class
static EntityType | TypeFactory.manyToOne(String persistentClass, boolean lazy) A many-to-one association type for the given class
static EntityType | TypeFactory.manyToOne(String persistentClass, String uniqueKeyPropertyName, boolean lazy, boolean unwrapProxy, boolean isEmbeddedInXML, boolean ignoreNotFound) A many-to-one association type for the given class

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.FloatType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.FloatType

No usage of org.hibernate.type.FloatType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.ForeignKeyDirection (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.ForeignKeyDirection

Packages that use ForeignKeyDirection
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of ForeignKeyDirection in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type ForeignKeyDirection
protected  void DefaultMergeEventListener.copyValues(EntityPersister persister, Object entity, Object target, SessionImplementor source, Map copyCache, ForeignKeyDirection foreignKeyDirection)

Uses of ForeignKeyDirection in org.hibernate.mapping

Methods in org.hibernate.mapping that return ForeignKeyDirection
 ForeignKeyDirection OneToOne.getForeignKeyType()
Returns the foreignKeyType.

Methods in org.hibernate.mapping with parameters of type ForeignKeyDirection
 void OneToOne.setForeignKeyType(ForeignKeyDirection foreignKeyType)
Sets the foreignKeyType.

Uses of ForeignKeyDirection in org.hibernate.type

Fields in org.hibernate.type declared as ForeignKeyDirection
static ForeignKeyDirection | ForeignKeyDirection.FOREIGN_KEY_TO_PARENT A foreign key from child to parent
static ForeignKeyDirection | ForeignKeyDirection.FOREIGN_KEY_FROM_PARENT A foreign key from parent to child

Methods in org.hibernate.type that return ForeignKeyDirection
ForeignKeyDirection | OneToOneType.getForeignKeyDirection()
ForeignKeyDirection | ManyToOneType.getForeignKeyDirection()
ForeignKeyDirection | CollectionType.getForeignKeyDirection()
ForeignKeyDirection | AssociationType.getForeignKeyDirection() Get the foreign key directionality of this association
ForeignKeyDirection | AnyType.getForeignKeyDirection()

Methods in org.hibernate.type with parameters of type ForeignKeyDirection
static EntityType | TypeFactory.oneToOne(String persistentClass, ForeignKeyDirection foreignKeyType, String uniqueKeyPropertyName, boolean lazy, boolean unwrapProxy, boolean isEmbeddedInXML, String entityName, String propertyName) A one-to-one association type for the given class
static Object[] | TypeFactory.replace(Object[] original, Object[] target, Type[] types, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)
Object | Type.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection) During merge, replace the existing (target) value in the entity we are merging to with a new (original) value from the detached entity we are merging.
Object | ComponentType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)
Object | AbstractType.replace(Object original, Object target, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)

Constructors in org.hibernate.type with parameters of type ForeignKeyDirection
SpecialOneToOneType(String referencedEntityName, ForeignKeyDirection foreignKeyType, String uniqueKeyPropertyName, boolean lazy, boolean unwrapProxy, String entityName, String propertyName)
OneToOneType(String referencedEntityName, ForeignKeyDirection foreignKeyType, String uniqueKeyPropertyName, boolean lazy, boolean unwrapProxy, boolean isEmbeddedInXML, String entityName, String propertyName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.IdentifierBagType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.IdentifierBagType

No usage of org.hibernate.type.IdentifierBagType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.type.IdentifierType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.type.IdentifierType

Packages that use IdentifierType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of IdentifierType in org.hibernate.type

Subinterfaces of IdentifierType in org.hibernate.type
 interface DiscriminatorType
A Type that may be used for a discriminator column.

Classes in org.hibernate.type that implement IdentifierType
class | BigIntegerType big_integer: A type that maps an SQL NUMERIC to a java.math.BigInteger
class | BooleanType boolean: A type that maps an SQL BIT to a Java Boolean.
class | ByteType byte: A type that maps an SQL TINYINT to a Java Byte.
class | CharacterType character: A type that maps an SQL CHAR(1) to a Java Character.
class | CharBooleanType Superclass for types that map Java boolean to SQL CHAR(1).
class | CustomType Adapts UserType to the generic Type interface, in order to isolate user code from changes in the internal Type contracts.
class | DateType date: A type that maps an SQL DATE to a Java Date.
class | IntegerType integer: A type that maps an SQL INT to a Java Integer.
class | LongType long: A type that maps an SQL BIGINT to a Java Long.
class | ShortType short: A type that maps an SQL SMALLINT to a Java Short.
class | StringType string: A type that maps an SQL VARCHAR to a Java String.
class | TrueFalseType true_false: A type that maps an SQL CHAR(1) to a Java Boolean.
class | YesNoType yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.ImmutableType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.ImmutableType

Packages that use ImmutableType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of ImmutableType in org.hibernate.type

Subclasses of ImmutableType in org.hibernate.type
class | AdaptedImmutableType Optimize a mutable type, if the user promises not to mutable the instances.
class | BigDecimalType big_decimal: A type that maps an SQL NUMERIC to a java.math.BigDecimal
class | BigIntegerType big_integer: A type that maps an SQL NUMERIC to a java.math.BigInteger
class | BooleanType boolean: A type that maps an SQL BIT to a Java Boolean.
class | ByteType byte: A type that maps an SQL TINYINT to a Java Byte.
class | CharacterType character: A type that maps an SQL CHAR(1) to a Java Character.
class | CharBooleanType Superclass for types that map Java boolean to SQL CHAR(1).
class | ClassType class: A type that maps an SQL VARCHAR to a Java Class.
class | CurrencyType currency: A type that maps an SQL VARCHAR to a java.util.Currency
class | DoubleType double: A type that maps an SQL DOUBLE to a Java Double.
class | FloatType float: A type that maps an SQL FLOAT to a Java Float.
class | IntegerType integer: A type that maps an SQL INT to a Java Integer.
class | LocaleType locale: A type that maps an SQL VARCHAR to a Java Locale.
class | LongType long: A type that maps an SQL BIGINT to a Java Long.
class | PrimitiveType Superclass of primitive / primitive wrapper types.
class | ShortType short: A type that maps an SQL SMALLINT to a Java Short.
class | StringType string: A type that maps an SQL VARCHAR to a Java String.
class | TextType text: A type that maps an SQL CLOB to a Java String.
class | TimeZoneType timezone: A type that maps an SQL VARCHAR to a java.util.TimeZone
class | TrueFalseType true_false: A type that maps an SQL CHAR(1) to a Java Boolean.
class | YesNoType yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.IntegerType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.IntegerType

No usage of org.hibernate.type.IntegerType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.ListType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.ListType

No usage of org.hibernate.type.ListType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.type.LiteralType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.type.LiteralType

Packages that use LiteralType
org.hibernate.sql | This package defines helper classes for rendering SQL fragments and SQL statements.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of LiteralType in org.hibernate.sql

Methods in org.hibernate.sql with parameters of type LiteralType
Update | Update.addColumn(String columnName, Object value, LiteralType type)
Insert | Insert.addColumn(String columnName, Object value, LiteralType type)

Uses of LiteralType in org.hibernate.type

Subinterfaces of LiteralType in org.hibernate.type
 interface DiscriminatorType
A Type that may be used for a discriminator column.

Classes in org.hibernate.type that implement LiteralType
class | BigIntegerType big_integer: A type that maps an SQL NUMERIC to a java.math.BigInteger
class | BooleanType boolean: A type that maps an SQL BIT to a Java Boolean.
class | ByteType byte: A type that maps an SQL TINYINT to a Java Byte.
class | CharacterType character: A type that maps an SQL CHAR(1) to a Java Character.
class | CharBooleanType Superclass for types that map Java boolean to SQL CHAR(1).
class | CurrencyType currency: A type that maps an SQL VARCHAR to a java.util.Currency
class | CustomType Adapts UserType to the generic Type interface, in order to isolate user code from changes in the internal Type contracts.
class | DateType date: A type that maps an SQL DATE to a Java Date.
class | DbTimestampType dbtimestamp: An extension of TimestampType which maps to the database's current timestamp, rather than the jvm's current timestamp.
class | DoubleType double: A type that maps an SQL DOUBLE to a Java Double.
class | FloatType float: A type that maps an SQL FLOAT to a Java Float.
class | IntegerType integer: A type that maps an SQL INT to a Java Integer.
class | LocaleType locale: A type that maps an SQL VARCHAR to a Java Locale.
class | LongType long: A type that maps an SQL BIGINT to a Java Long.
class | PrimitiveType Superclass of primitive / primitive wrapper types.
class | ShortType short: A type that maps an SQL SMALLINT to a Java Short.
class | StringType string: A type that maps an SQL VARCHAR to a Java String.
class | TimestampType timestamp: A type that maps an SQL TIMESTAMP to a Java java.util.Date or java.sql.Timestamp.
class | TimeType time: A type that maps an SQL TIME to a Java java.util.Date or java.sql.Time.
class | TimeZoneType timezone: A type that maps an SQL VARCHAR to a java.util.TimeZone
class | TrueFalseType true_false: A type that maps an SQL CHAR(1) to a Java Boolean.
class | YesNoType yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.LocaleType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.LocaleType

No usage of org.hibernate.type.LocaleType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.LongType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.LongType

No usage of org.hibernate.type.LongType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.ManyToOneType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.ManyToOneType

No usage of org.hibernate.type.ManyToOneType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.MapType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.MapType

Packages that use MapType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of MapType in org.hibernate.type

Subclasses of MapType in org.hibernate.type
class | OrderedMapType
class | SortedMapType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.MetaType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.MetaType

No usage of org.hibernate.type.MetaType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.MutableType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.MutableType

Packages that use MutableType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of MutableType in org.hibernate.type

Subclasses of MutableType in org.hibernate.type
class | AbstractBynaryType Logic to bind stream of byte into a VARBINARY
class | AbstractCharArrayType Logic to bind stream of char into a VARCHAR
class | BinaryType binary: A type that maps an SQL VARBINARY to a Java byte[].
class | CalendarDateType calendar_date: A type mapping for a Calendar object that represents a date.
class | CalendarType calendar: A type mapping for a Calendar object that represents a datetime.
class | CharacterArrayType Bridge Character[] and VARCHAR
class | CharArrayType put char[] into VARCHAR
class | DateType date: A type that maps an SQL DATE to a Java Date.
class | DbTimestampType dbtimestamp: An extension of TimestampType which maps to the database's current timestamp, rather than the jvm's current timestamp.
class | SerializableType serializable: A type that maps an SQL VARBINARY to a serializable Java object.
class | TimestampType timestamp: A type that maps an SQL TIMESTAMP to a Java java.util.Date or java.sql.Timestamp.
class | TimeType time: A type that maps an SQL TIME to a Java java.util.Date or java.sql.Time.
class | WrapperBinaryType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.NullableType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.NullableType

Packages that use NullableType
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of NullableType in org.hibernate

Fields in org.hibernate declared as NullableType
static NullableType | Hibernate.LONG Hibernate long type.
static NullableType | Hibernate.SHORT Hibernate short type.
static NullableType | Hibernate.INTEGER Hibernate integer type.
static NullableType | Hibernate.BYTE Hibernate byte type.
static NullableType | Hibernate.FLOAT Hibernate float type.
static NullableType | Hibernate.DOUBLE Hibernate double type.
static NullableType | Hibernate.CHARACTER Hibernate character type.
static NullableType | Hibernate.STRING Hibernate string type.
static NullableType | Hibernate.TIME Hibernate time type.
static NullableType | Hibernate.DATE Hibernate date type.
static NullableType | Hibernate.TIMESTAMP Hibernate timestamp type.
static NullableType | Hibernate.BOOLEAN Hibernate boolean type.
static NullableType | Hibernate.TRUE_FALSE Hibernate true_false type.
static NullableType | Hibernate.YES_NO Hibernate yes_no type.
static NullableType | Hibernate.BIG_DECIMAL Hibernate big_decimal type.
static NullableType | Hibernate.BIG_INTEGER Hibernate big_integer type.
static NullableType | Hibernate.BINARY Hibernate binary type.
static NullableType | Hibernate.WRAPPER_BINARY Hibernate wrapper-binary type.
static NullableType | Hibernate.CHAR_ARRAY Hibernate char[] type.
static NullableType | Hibernate.CHARACTER_ARRAY Hibernate Character[] type.
static NullableType | Hibernate.TEXT Hibernate text type.
static NullableType | Hibernate.CALENDAR Hibernate calendar type.
static NullableType | Hibernate.CALENDAR_DATE Hibernate calendar_date type.
static NullableType | Hibernate.LOCALE Hibernate locale type.
static NullableType | Hibernate.CURRENCY Hibernate currency type.
static NullableType | Hibernate.TIMEZONE Hibernate timezone type.
static NullableType | Hibernate.CLASS Hibernate class type.
static NullableType | Hibernate.SERIALIZABLE Hibernate serializable type.

Uses of NullableType in org.hibernate.type

Subclasses of NullableType in org.hibernate.type
class | AbstractBynaryType Logic to bind stream of byte into a VARBINARY
class | AbstractCharArrayType Logic to bind stream of char into a VARCHAR
class | AdaptedImmutableType Optimize a mutable type, if the user promises not to mutable the instances.
class | BigDecimalType big_decimal: A type that maps an SQL NUMERIC to a java.math.BigDecimal
class | BigIntegerType big_integer: A type that maps an SQL NUMERIC to a java.math.BigInteger
class | BinaryType binary: A type that maps an SQL VARBINARY to a Java byte[].
class | BooleanType boolean: A type that maps an SQL BIT to a Java Boolean.
class | ByteType byte: A type that maps an SQL TINYINT to a Java Byte.
class | CalendarDateType calendar_date: A type mapping for a Calendar object that represents a date.
class | CalendarType calendar: A type mapping for a Calendar object that represents a datetime.
class | CharacterArrayType Bridge Character[] and VARCHAR
class | CharacterType character: A type that maps an SQL CHAR(1) to a Java Character.
class | CharArrayType put char[] into VARCHAR
class | CharBooleanType Superclass for types that map Java boolean to SQL CHAR(1).
class | ClassType class: A type that maps an SQL VARCHAR to a Java Class.
class | CurrencyType currency: A type that maps an SQL VARCHAR to a java.util.Currency
class | DateType date: A type that maps an SQL DATE to a Java Date.
class | DbTimestampType dbtimestamp: An extension of TimestampType which maps to the database's current timestamp, rather than the jvm's current timestamp.
class | DoubleType double: A type that maps an SQL DOUBLE to a Java Double.
class | FloatType float: A type that maps an SQL FLOAT to a Java Float.
class | ImmutableType Superclass of nullable immutable types.
class | IntegerType integer: A type that maps an SQL INT to a Java Integer.
class | LocaleType locale: A type that maps an SQL VARCHAR to a Java Locale.
class | LongType long: A type that maps an SQL BIGINT to a Java Long.
class | MutableType Superclass for mutable nullable types
class | PrimitiveType Superclass of primitive / primitive wrapper types.
class | SerializableType serializable: A type that maps an SQL VARBINARY to a serializable Java object.
class | ShortType short: A type that maps an SQL SMALLINT to a Java Short.
class | StringType string: A type that maps an SQL VARCHAR to a Java String.
class | TextType text: A type that maps an SQL CLOB to a Java String.
class | TimestampType timestamp: A type that maps an SQL TIMESTAMP to a Java java.util.Date or java.sql.Timestamp.
class | TimeType time: A type that maps an SQL TIME to a Java java.util.Date or java.sql.Time.
class | TimeZoneType timezone: A type that maps an SQL VARCHAR to a java.util.TimeZone
class | TrueFalseType true_false: A type that maps an SQL CHAR(1) to a Java Boolean.
class | WrapperBinaryType
class | YesNoType yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.

Constructors in org.hibernate.type with parameters of type NullableType
AdaptedImmutableType(NullableType mutableType)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.OneToOneType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.OneToOneType

Packages that use OneToOneType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of OneToOneType in org.hibernate.type

Subclasses of OneToOneType in org.hibernate.type
 class SpecialOneToOneType
A one-to-one association that maps to specific formula(s) instead of the primary key column of the owning entity.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.OrderedMapType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.OrderedMapType

No usage of org.hibernate.type.OrderedMapType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.OrderedSetType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.OrderedSetType

No usage of org.hibernate.type.OrderedSetType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.PrimitiveType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.PrimitiveType

Packages that use PrimitiveType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of PrimitiveType in org.hibernate.type

Subclasses of PrimitiveType in org.hibernate.type
class | BooleanType boolean: A type that maps an SQL BIT to a Java Boolean.
class | ByteType byte: A type that maps an SQL TINYINT to a Java Byte.
class | CharacterType character: A type that maps an SQL CHAR(1) to a Java Character.
class | CharBooleanType Superclass for types that map Java boolean to SQL CHAR(1).
class | DoubleType double: A type that maps an SQL DOUBLE to a Java Double.
class | FloatType float: A type that maps an SQL FLOAT to a Java Float.
class | IntegerType integer: A type that maps an SQL INT to a Java Integer.
class | LongType long: A type that maps an SQL BIGINT to a Java Long.
class | ShortType short: A type that maps an SQL SMALLINT to a Java Short.
class | TrueFalseType true_false: A type that maps an SQL CHAR(1) to a Java Boolean.
class | YesNoType yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.SerializableType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.SerializableType

No usage of org.hibernate.type.SerializableType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.SerializationException (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.SerializationException

Packages that use SerializationException
org.hibernate.util Utility classes.

Uses of SerializationException in org.hibernate.util

Methods in org.hibernate.util that throw SerializationException
static Object | SerializationHelper.clone(Serializable object) Deep clone an Object using serialization.
static void | SerializationHelper.serialize(Serializable obj, OutputStream outputStream) Serializes an Object to the specified stream.
static byte[] | SerializationHelper.serialize(Serializable obj) Serializes an Object to a byte array for storage/serialization.
static Object | SerializationHelper.deserialize(InputStream inputStream) Deserializes an Object from the specified stream.
static Object | SerializationHelper.deserialize(byte[] objectData) Deserializes a single Object from an array of bytes.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.SetType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.SetType

Packages that use SetType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of SetType in org.hibernate.type

Subclasses of SetType in org.hibernate.type
class | OrderedSetType
class | SortedSetType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.ShortType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.ShortType

No usage of org.hibernate.type.ShortType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.SortedMapType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.SortedMapType

No usage of org.hibernate.type.SortedMapType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.SortedSetType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.SortedSetType

No usage of org.hibernate.type.SortedSetType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.SpecialOneToOneType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.SpecialOneToOneType

No usage of org.hibernate.type.SpecialOneToOneType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.StringType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.StringType

No usage of org.hibernate.type.StringType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.TextType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.TextType

No usage of org.hibernate.type.TextType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.TimestampType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.TimestampType

Packages that use TimestampType
org.hibernate.type A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of TimestampType in org.hibernate.type

Subclasses of TimestampType in org.hibernate.type
 class DbTimestampType
dbtimestamp: An extension of TimestampType which maps to the database's current timestamp, rather than the jvm's current timestamp.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.TimeType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.TimeType

No usage of org.hibernate.type.TimeType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.TimeZoneType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.TimeZoneType

No usage of org.hibernate.type.TimeZoneType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.TrueFalseType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.TrueFalseType

No usage of org.hibernate.type.TrueFalseType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.type.Type (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.type.Type

Packages that use Type
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.cache | This package defines APIs and implementations for the second-level cache and query cache.
org.hibernate.classic | This package implements backward-compatibility with Hibernate 2.1 APIs now deprecated in Hibernate3.
org.hibernate.collection | This package defines a framework for collection wrappers.
org.hibernate.criterion | A framework for defining restriction criteria and order criteria.
org.hibernate.dialect | This package abstracts the SQL dialect of the underlying database.
org.hibernate.dialect.function | A framework for defining database-specific SQL functions that are available via the dialect.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.engine.query |
org.hibernate.engine.query.sql |
org.hibernate.event.def | This package defines a default set of event listeners that implements the default behaviors of Hibernate.
org.hibernate.hql | This package defines the interface between Hibernate and the HQL query parser implementation (to allow switching between the 2.x and 3.0 HQL parsers).
org.hibernate.hql.ast | An ANTLR-based parser for Hibernate Query Language.
org.hibernate.hql.ast.tree |
org.hibernate.hql.ast.util |
org.hibernate.hql.classic | This package contains the Hibernate 2.x query parser which is being end-of-lifed.
org.hibernate.id | This package contains internal implementation classes for the main API interfaces.
org.hibernate.impl | This package contains implementations of the central Hibernate APIs, especially the Hibernate session.
org.hibernate.loader | This package defines functionality for processing JDBC result sets and returning complex graphs of persistent objects.
org.hibernate.loader.collection | This package defines collection initializers
org.hibernate.loader.criteria | This package defines the criteria query compiler and loader
org.hibernate.loader.custom | This package defines a framework for custom loaders that accept handwritten SQL
org.hibernate.loader.entity | This package defines entity loaders
org.hibernate.mapping | This package defines the Hibernate configuration-time metamodel.
org.hibernate.metadata | This package defines an API for accessing the Hibernate runtime metamodel.
org.hibernate.param |
org.hibernate.persister.collection | This package abstracts the persistence mechanism for collections.
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.pretty | Classes for pretty printing things for exception and log messages.
org.hibernate.property | This package abstracts the notion of a "property" of an entity.
org.hibernate.tuple | This package defines a runtime metamodel for entities at the object level and abstracts the differences between the various entity modes.
org.hibernate.tuple.entity |
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.
org.hibernate.usertype | Interfaces for user-defined custom types.
org.hibernate.util | Utility classes.

Uses of Type in org.hibernate

Fields in org.hibernate declared as Type
static Type | Hibernate.BLOB Hibernate blob type.
static Type | Hibernate.CLOB Hibernate clob type.
static Type | Hibernate.OBJECT Hibernate object type.

Methods in org.hibernate that return Type
Type | ScrollableResults.getType(int i) Get the type of the ith column of results
Type[] | Query.getReturnTypes() Return the Hibernate types of the query result set.
static Type | Hibernate.serializable(Class serializableClass) A Hibernate serializable type.
static Type | Hibernate.any(Type metaType, Type identifierType) A Hibernate any type.
static Type | Hibernate.entity(Class persistentClass) A Hibernate persistent object (entity) type.
static Type | Hibernate.entity(String entityName) A Hibernate persistent object (entity) type.
static Type | Hibernate.custom(Class userTypeClass) A Hibernate custom type.
static Type | Hibernate.custom(Class userTypeClass, String[] parameterNames, String[] parameterValues) A Hibernate parameterizable custom type.
static Type | Hibernate.custom(Class userTypeClass, Properties parameters) A Hibernate parameterizable custom type.

Methods in org.hibernate with parameters of type Type
 SQLQuery SQLQuery.addScalar(String columnAlias, Type type)
Declare a scalar query result
 Query Query.setParameter(int position, Object val, Type type)
Bind a value to a JDBC-style query parameter.
 Query Query.setParameter(String name, Object val, Type type)
Bind a value to a named query parameter.
 Query Query.setParameters(Object[] values, Type[] types)
Bind values and types to positional parameters.
 Query Query.setParameterList(String name, Collection vals, Type type)
Bind multiple values to a named query parameter.
 Query Query.setParameterList(String name, Object[] vals, Type type)
Bind multiple values to a named query parameter.
 boolean Interceptor.onLoad(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types)
Called just before an object is initialized.
 boolean Interceptor.onFlushDirty(Object entity, Serializable id, Object[] currentState, Object[] previousState, String[] propertyNames, Type[] types)
Called when an object is detected to be dirty, during a flush.
 boolean Interceptor.onSave(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types)
Called before an object is saved.
 void Interceptor.onDelete(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types)
Called before an object is deleted.
 int[] Interceptor.findDirty(Object entity, Serializable id, Object[] currentState, Object[] previousState, String[] propertyNames, Type[] types)
Called from flush().
static Type Hibernate.any(Type metaType, Type identifierType)
A Hibernate any type.
 void EmptyInterceptor.onDelete(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types)
 boolean EmptyInterceptor.onFlushDirty(Object entity, Serializable id, Object[] currentState, Object[] previousState, String[] propertyNames, Type[] types)
 boolean EmptyInterceptor.onLoad(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types)
 boolean EmptyInterceptor.onSave(Object entity, Serializable id, Object[] state, String[] propertyNames, Type[] types)
 int[] EmptyInterceptor.findDirty(Object entity, Serializable id, Object[] currentState, Object[] previousState, String[] propertyNames, Type[] types)

Uses of Type in org.hibernate.cache

Methods in org.hibernate.cache with parameters of type Type
boolean | StandardQueryCache.put(QueryKey key, Type[] returnTypes, List result, boolean isNaturalKeyLookup, SessionImplementor session)
List | StandardQueryCache.get(QueryKey key, Type[] returnTypes, boolean isNaturalKeyLookup, Set spaces, SessionImplementor session)
boolean | QueryCache.put(QueryKey key, Type[] returnTypes, List result, boolean isNaturalKeyLookup, SessionImplementor session)
List | QueryCache.get(QueryKey key, Type[] returnTypes, boolean isNaturalKeyLookup, Set spaces, SessionImplementor session)

Constructors in org.hibernate.cache with parameters of type Type
CacheKey(Serializable id, Type type, String entityOrRoleName, EntityMode entityMode, SessionFactoryImplementor factory)
Construct a new key for a collection or entity instance.

Uses of Type in org.hibernate.classic

Methods in org.hibernate.classic with parameters of type Type
 List Session.find(String query, Object value, Type type)
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.list()
 List Session.find(String query, Object[] values, Type[] types)
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.list()
 Iterator Session.iterate(String query, Object value, Type type)
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.iterate()
 Iterator Session.iterate(String query, Object[] values, Type[] types)
Deprecated. use Session.createQuery(java.lang.String).setXYZ.Query.iterate()
 Collection Session.filter(Object collection, String filter, Object value, Type type)
Deprecated. use Session.createFilter(Object, String).setXYZ.Query.list()
 Collection Session.filter(Object collection, String filter, Object[] values, Type[] types)
Deprecated. use Session.createFilter(Object, String).setXYZ.Query.list()
 int Session.delete(String query, Object value, Type type)
Deprecated. consider using HQL delete statements
 int Session.delete(String query, Object[] values, Type[] types)
Deprecated. consider using HQL delete statements

Uses of Type in org.hibernate.collection

Methods in org.hibernate.collection with parameters of type Type
boolean | PersistentSet.needsInserting(Object entry, int i, Type elemType)
boolean | PersistentSet.needsUpdating(Object entry, int i, Type elemType)
boolean | PersistentMap.needsInserting(Object entry, int i, Type elemType)
boolean | PersistentMap.needsUpdating(Object entry, int i, Type elemType)
boolean | PersistentList.needsInserting(Object entry, int i, Type elemType)
boolean | PersistentList.needsUpdating(Object entry, int i, Type elemType)
boolean | PersistentIndexedElementHolder.needsInserting(Object entry, int i, Type elementType)
boolean | PersistentIndexedElementHolder.needsUpdating(Object entry, int i, Type elementType)
boolean | PersistentIdentifierBag.needsInserting(Object entry, int i, Type elemType)
boolean | PersistentIdentifierBag.needsUpdating(Object entry, int i, Type elemType)
boolean | PersistentElementHolder.needsInserting(Object entry, int i, Type elementType)
boolean | PersistentElementHolder.needsUpdating(Object entry, int i, Type elementType)
boolean | PersistentCollection.needsInserting(Object entry, int i, Type elemType) Do we need to insert this element?
boolean | PersistentCollection.needsUpdating(Object entry, int i, Type elemType) Do we need to update this element?
boolean | PersistentBag.needsInserting(Object entry, int i, Type elemType)
boolean | PersistentBag.needsUpdating(Object entry, int i, Type elemType)
boolean | PersistentArrayHolder.needsInserting(Object entry, int i, Type elemType)
boolean | PersistentArrayHolder.needsUpdating(Object entry, int i, Type elemType)

Uses of Type in org.hibernate.criterion

Methods in org.hibernate.criterion that return Type
protected Type[] | SubqueryExpression.getTypes()
Type[] | SQLProjection.getTypes(Criteria crit, CriteriaQuery criteriaQuery)
Type[] | SQLProjection.getTypes(String alias, Criteria crit, CriteriaQuery criteriaQuery)
Type[] | SimpleProjection.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | RowCountProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | PropertyProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | ProjectionList.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | ProjectionList.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | Projection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery) Return types returned by the rendered SQL fragment
Type[] | Projection.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery) Return types for a particular user-visible alias
Type[] | IdentifierProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | Distinct.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | Distinct.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
Type | CriteriaQuery.getType(Criteria criteria, String propertyPath) Get the type of a property path, ignoring projection aliases
Type | CriteriaQuery.getTypeUsingProjection(Criteria criteria, String propertyPath) Get the type of a property path
Type | CriteriaQuery.getIdentifierType(Criteria subcriteria) Get the identifier type of this entity
Type[] | CountProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AvgProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AliasedProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AliasedProjection.getTypes(String alias, Criteria criteria, CriteriaQuery criteriaQuery)
Type[] | AggregateProjection.getTypes(Criteria criteria, CriteriaQuery criteriaQuery)

Methods in org.hibernate.criterion with parameters of type Type
static Criterion | Restrictions.sqlRestriction(String sql, Object[] values, Type[] types) Apply a constraint expressed in SQL, with the given JDBC parameters.
static Criterion | Restrictions.sqlRestriction(String sql, Object value, Type type) Apply a constraint expressed in SQL, with the given JDBC parameter.
static Projection | Projections.sqlProjection(String sql, String[] columnAliases, Type[] types) A SQL projection, a typed select clause fragment
static Projection | Projections.sqlGroupProjection(String sql, String groupBy, String[] columnAliases, Type[] types) A grouping SQL projection, specifying both select clause and group by clause fragments
static Criterion | Expression.sql(String sql, Object[] values, Type[] types) Apply a constraint expressed in SQL, with the given JDBC parameters.
static Criterion | Expression.sql(String sql, Object value, Type type) Apply a constraint expressed in SQL, with the given JDBC parameter.
protected void | Example.addPropertyTypedValue(Object value, Type type, List list)
boolean | Example.PropertySelector.include(Object propertyValue, String propertyName, Type type)

Constructors in org.hibernate.criterion with parameters of type Type
SQLProjection(String sql, String[] columnAliases, Type[] types)
SQLProjection(String sql, String groupBy, String[] columnAliases, Type[] types)
SQLCriterion(String sql, Object[] values, Type[] types)

Uses of Type in org.hibernate.dialect

Methods in org.hibernate.dialect that return Type
 Type DerbyDialect.DerbyTrimFunctionEmulation.getReturnType(Type columnType, Mapping mapping)

Methods in org.hibernate.dialect with parameters of type Type
 Type DerbyDialect.DerbyTrimFunctionEmulation.getReturnType(Type columnType, Mapping mapping)

Uses of Type in org.hibernate.dialect.function

Methods in org.hibernate.dialect.function that return Type
Type | VarArgsSQLFunction.getReturnType(Type columnType, Mapping mapping)
Type | StandardSQLFunction.getReturnType(Type columnType, Mapping mapping)
Type | SQLFunctionTemplate.getReturnType(Type columnType, Mapping mapping)
Type | SQLFunction.getReturnType(Type columnType, Mapping mapping) The function return type
Type | PositionSubstringFunction.getReturnType(Type columnType, Mapping mapping)
Type | NvlFunction.getReturnType(Type columnType, Mapping mapping)
Type | NoArgSQLFunction.getReturnType(Type columnType, Mapping mapping)
Type | ClassicCountFunction.getReturnType(Type columnType, Mapping mapping)
Type | ClassicAvgFunction.getReturnType(Type columnType, Mapping mapping)
Type | CharIndexFunction.getReturnType(Type columnType, Mapping mapping)
Type | CastFunction.getReturnType(Type columnType, Mapping mapping)
Type | AnsiTrimEmulationFunction.getReturnType(Type columnType, Mapping mapping)

Methods in org.hibernate.dialect.function with parameters of type Type
Type | VarArgsSQLFunction.getReturnType(Type columnType, Mapping mapping)
Type | StandardSQLFunction.getReturnType(Type columnType, Mapping mapping)
Type | SQLFunctionTemplate.getReturnType(Type columnType, Mapping mapping)
Type | SQLFunction.getReturnType(Type columnType, Mapping mapping) The function return type
Type | PositionSubstringFunction.getReturnType(Type columnType, Mapping mapping)
Type | NvlFunction.getReturnType(Type columnType, Mapping mapping)
Type | NoArgSQLFunction.getReturnType(Type columnType, Mapping mapping)
Type | ClassicCountFunction.getReturnType(Type columnType, Mapping mapping)
Type | ClassicAvgFunction.getReturnType(Type columnType, Mapping mapping)
Type | CharIndexFunction.getReturnType(Type columnType, Mapping mapping)
Type | CastFunction.getReturnType(Type columnType, Mapping mapping)
Type | AnsiTrimEmulationFunction.getReturnType(Type columnType, Mapping mapping)

Constructors in org.hibernate.dialect.function with parameters of type Type
VarArgsSQLFunction(Type type, String begin, String sep, String end)
StandardSQLFunction(String name, Type typeValue)
SQLFunctionTemplate(Type type, String template)
SQLFunctionTemplate(Type type, String template, boolean hasParenthesesIfNoArgs)
NoArgSQLFunction(String name, Type returnType)
NoArgSQLFunction(String name, Type returnType, boolean hasParenthesesIfNoArguments)

Uses of Type in org.hibernate.engine

Methods in org.hibernate.engine that return Type
Type | TypedValue.getType()
Type | SessionImplementor.getFilterParameterType(String filterParameterName) Retreive the type for a given filter parrameter.
Type[] | SessionFactoryImplementor.getReturnTypes(String queryString) Get the return types of a query
Type[] | QueryParameters.getPositionalParameterTypes()
Type[] | QueryParameters.getFilteredPositionalParameterTypes()
Type | Mapping.getIdentifierType(String className)
Type | Mapping.getReferencedPropertyType(String className, String propertyName)
Type | FilterDefinition.getParameterType(String parameterName) Retreive the type of the named parameter defined for this filter.

Methods in org.hibernate.engine with parameters of type Type
static IdentifierValue | UnsavedValueFactory.getUnsavedIdentifierValue(String unsavedValue, Getter identifierGetter, Type identifierType, Constructor constructor) Return an IdentifierValue for the specified unsaved-value.
void | QueryParameters.setPositionalParameterTypes(Type[] types)
static int | ParameterBinder.bindPositionalParameters(PreparedStatement st, Object[] values, Type[] types, int start, SessionImplementor session)
void | ForeignKeys.Nullifier.nullifyTransientReferences(Object[] values, Type[] types) Nullify all references to entities that have not yet been inserted in the database, where the foreign key points toward that entity

Constructors in org.hibernate.engine with parameters of type Type
TypedValue(Type type, Object value, EntityMode entityMode)
QueryParameters(Type type, Object value)
QueryParameters(Type[] positionalParameterTypes, Object[] postionalParameterValues, Object optionalObject, String optionalEntityName, Serializable optionalObjectId)
QueryParameters(Type[] positionalParameterTypes, Object[] postionalParameterValues)
QueryParameters(Type[] positionalParameterTypes, Object[] postionalParameterValues, Serializable[] collectionKeys)
QueryParameters(Type[] positionalParameterTypes, Object[] postionalParameterValues, Map namedParameters, Serializable[] collectionKeys)
QueryParameters(Type[] positionalParameterTypes, Object[] positionalParameterValues, Map lockModes, RowSelection rowSelection, boolean cacheable, String cacheRegion, String comment, boolean isLookupByNaturalKey, ResultTransformer transformer)
QueryParameters(Type[] positionalParameterTypes, Object[] positionalParameterValues, Map namedParameters, Map lockModes, RowSelection rowSelection, boolean readOnly, boolean cacheable, String cacheRegion, String comment, Serializable[] collectionKeys, ResultTransformer transformer)
QueryParameters(Type[] positionalParameterTypes, Object[] positionalParameterValues, Map namedParameters, Map lockModes, RowSelection rowSelection, boolean readOnly, boolean cacheable, String cacheRegion, String comment, Serializable[] collectionKeys, Object optionalObject, String optionalEntityName, Serializable optionalId, ResultTransformer transformer)
EntityUniqueKey(String entityName, String uniqueKeyName, Object semiResolvedKey, Type keyType, EntityMode entityMode, SessionFactoryImplementor factory)

Uses of Type in org.hibernate.engine.query

Methods in org.hibernate.engine.query that return Type
Type[] | ReturnMetadata.getReturnTypes()
Type[] | QueryMetadata.getReturnTypes() An array of types describing the returns of the source query.
Type | ParameterMetadata.getOrdinalParameterExpectedType(int position)
Type | ParameterMetadata.getNamedParameterExpectedType(String name)
Type | OrdinalParameterDescriptor.getExpectedType()
Type | NamedParameterDescriptor.getExpectedType()

Constructors in org.hibernate.engine.query with parameters of type Type
ReturnMetadata(String[] returnAliases, Type[] returnTypes)
QueryMetadata(String sourceQuery, ParameterMetadata parameterMetadata, String[] returnAliases, Type[] returnTypes, Set querySpaces)
OrdinalParameterDescriptor(int ordinalPosition, Type expectedType, int sourceLocation)
NamedParameterDescriptor(String name, Type expectedType, int[] sourceLocations, boolean jpaStyle)

Uses of Type in org.hibernate.engine.query.sql

Methods in org.hibernate.engine.query.sql that return Type
 Type NativeSQLQueryScalarReturn.getType()

Constructors in org.hibernate.engine.query.sql with parameters of type Type
NativeSQLQueryScalarReturn(String alias, Type type)

Uses of Type in org.hibernate.event.def

Methods in org.hibernate.event.def with parameters of type Type
protected  boolean DefaultReplicateEventListener.visitCollectionsBeforeSave(Serializable id, Object[] values, Type[] types, EventSource source)
 void AbstractVisitor.processEntityPropertyValues(Object[] values, Type[] types)
Dispatch each property value to processValue().
protected  boolean AbstractSaveEventListener.visitCollectionsBeforeSave(Serializable id, Object[] values, Type[] types, EventSource source)

Uses of Type in org.hibernate.hql

Methods in org.hibernate.hql that return Type
Type[] | QueryTranslator.getReturnTypes() Returns an array of Types represented in the query result.
Type | ParameterTranslations.getOrdinalParameterExpectedType(int ordinalPosition)
Type | ParameterTranslations.getNamedParameterExpectedType(String name)

Methods in org.hibernate.hql with parameters of type Type
static String[][] NameGenerator.generateColumnNames(Type[] types, SessionFactoryImplementor f)

Uses of Type in org.hibernate.hql.ast

Methods in org.hibernate.hql.ast that return Type
 Type[] QueryTranslatorImpl.getReturnTypes()
Types of the return values of an iterate() style query.
 Type ParameterTranslationsImpl.getOrdinalParameterExpectedType(int ordinalPosition)
 Type ParameterTranslationsImpl.getNamedParameterExpectedType(String name)
 Type ParameterTranslationsImpl.ParameterInfo.getExpectedType()
 Type[] HqlSqlWalker.getReturnTypes()

Constructors in org.hibernate.hql.ast with parameters of type Type
ParameterTranslationsImpl.ParameterInfo(int[] sqlPositions, Type expectedType)
ParameterTranslationsImpl.ParameterInfo(int sqlPosition, Type expectedType)

Uses of Type in org.hibernate.hql.ast.tree

Methods in org.hibernate.hql.ast.tree that return Type
Type | UnaryLogicOperatorNode.getDataType()
Type | UnaryArithmeticNode.getDataType()
Type | SqlNode.getDataType()
Type | SelectExpression.getDataType() Returns the data type of the select expression.
Type[] | SelectClause.getQueryReturnTypes() The types actually being returned from this query at the "object level".
Type | QueryNode.getDataType()
Type | ParameterNode.getExpectedType()
Type | OperatorNode.getDataType() Retrieves the data type for the overall operator expression.
Type | LiteralNode.getDataType()
Type | JavaConstantNode.getExpectedType()
Type[] | IntoClause.getInsertionTypes()
Type | IdentNode.getDataType()
Type | FromElement.getDataType()
Type | FromElement.getSelectType()
Type | FromElement.getPropertyType(String propertyName, String propertyPath) Returns the type of a property, given it's name (the last part) and the full path.
Type | ExpectedTypeAwareNode.getExpectedType()
Type | DotNode.getDataType()
Type | CountNode.getDataType()
Type | ConstructorNode.getDataType() Deprecated. (tell clover to ignore this method)
Type | CaseNode.getDataType()
Type | Case2Node.getDataType()
Type | BooleanLiteralNode.getDataType()
Type | BooleanLiteralNode.getExpectedType()
protected Type | BinaryLogicOperatorNode.extractDataType(Node operand)
Type | BinaryLogicOperatorNode.getDataType()
Type | BinaryArithmeticOperatorNode.getDataType() Figure out the type of the binary expression by looking at the types of the operands.
Type | BetweenOperatorNode.getDataType()
Type | AggregateNode.getDataType()

Methods in org.hibernate.hql.ast.tree with parameters of type Type
void | SqlNode.setDataType(Type dataType)
void | ParameterNode.setExpectedType(Type expectedType)
void | JavaConstantNode.setExpectedType(Type expectedType)
void | ExpectedTypeAwareNode.setExpectedType(Type expectedType)
void | BooleanLiteralNode.setExpectedType(Type expectedType) Expected-types really only pertinent here for boolean literals...
protected void | BinaryLogicOperatorNode.mutateRowValueConstructorSyntaxesIfNecessary(Type lhsType, Type rhsType)

Uses of Type in org.hibernate.hql.ast.util

Methods in org.hibernate.hql.ast.util that return Type
 Type SessionFactoryHelper.findFunctionReturnType(String functionName, antlr.collections.AST first)
Find the function return type given the function name and the first argument expression node.

Methods in org.hibernate.hql.ast.util with parameters of type Type
int | SessionFactoryHelper.getColumnSpan(Type type) Retreive the number of columns represented by this type.
String[][] | SessionFactoryHelper.generateColumnNames(Type[] sqlResultTypes)

Uses of Type in org.hibernate.hql.classic

Methods in org.hibernate.hql.classic that return Type
 Type SelectParser.aggregateType(List funcTokenList, Type type, QueryTranslatorImpl q)
 Type[] QueryTranslatorImpl.getReturnTypes()
Types of the return values of an iterate() style query.
protected  Type PathExpressionParser.getPropertyType()
 Type PathExpressionParser.getWhereColumnType()

Methods in org.hibernate.hql.classic with parameters of type Type
 Type SelectParser.aggregateType(List funcTokenList, Type type, QueryTranslatorImpl q)

Uses of Type in org.hibernate.id

Methods in org.hibernate.id with parameters of type Type
void | UUIDHexGenerator.configure(Type type, Properties params, Dialect d)
void | TableHiLoGenerator.configure(Type type, Properties params, Dialect d)
void | TableGenerator.configure(Type type, Properties params, Dialect dialect)
void | SequenceIdentityGenerator.configure(Type type, Properties params, Dialect dialect)
void | SequenceHiLoGenerator.configure(Type type, Properties params, Dialect d)
void | SequenceGenerator.configure(Type type, Properties params, Dialect dialect)
void | SelectGenerator.configure(Type type, Properties params, Dialect d)
void | MultipleHiLoPerTableGenerator.configure(Type type, Properties params, Dialect dialect)
void | IncrementGenerator.configure(Type type, Properties params, Dialect dialect)
static Serializable | IdentifierGeneratorFactory.getGeneratedIdentity(ResultSet rs, Type type) Get the generated identifier when using identity columns
static Serializable | IdentifierGeneratorFactory.get(ResultSet rs, Type type)
static IdentifierGenerator | IdentifierGeneratorFactory.create(String strategy, Type type, Properties params, Dialect dialect)
void | ForeignGenerator.configure(Type type, Properties params, Dialect d)
void | Configurable.configure(Type type, Properties params, Dialect d) Configure this instance, given the value of parameters specified by the user as <param> elements.
void | Assigned.configure(Type type, Properties params, Dialect d)

Uses of Type in org.hibernate.impl

Methods in org.hibernate.impl that return Type
Type | StatelessSessionImpl.getFilterParameterType(String filterParameterName)
Type[] | SQLQueryImpl.getReturnTypes()
Type | SessionImpl.getFilterParameterType(String filterParameterName)
Type | SessionFactoryImpl.getIdentifierType(String className)
Type[] | SessionFactoryImpl.getReturnTypes(String queryString)
Type | SessionFactoryImpl.getReferencedPropertyType(String className, String propertyName)
Type[] | CollectionFilterImpl.typeArray()
protected Type[] | AbstractScrollableResults.getTypes()
Type | AbstractScrollableResults.getType(int i)
Type[] | AbstractQueryImpl.getReturnTypes()
protected Type | AbstractQueryImpl.determineType(int paramPosition, Object paramValue, Type defaultType)
protected Type | AbstractQueryImpl.determineType(int paramPosition, Object paramValue)
protected Type | AbstractQueryImpl.determineType(String paramName, Object paramValue, Type defaultType)
protected Type | AbstractQueryImpl.determineType(String paramName, Object paramValue)
protected Type | AbstractQueryImpl.determineType(String paramName, Class clazz)
Type[] | AbstractQueryImpl.typeArray()

Methods in org.hibernate.impl with parameters of type Type
SQLQuery | SQLQueryImpl.addScalar(String columnAlias, Type type)
List | SessionImpl.find(String query, Object value, Type type)
List | SessionImpl.find(String query, Object[] values, Type[] types)
Iterator | SessionImpl.iterate(String query, Object value, Type type)
Iterator | SessionImpl.iterate(String query, Object[] values, Type[] types)
int | SessionImpl.delete(String query, Object value, Type type)
int | SessionImpl.delete(String query, Object[] values, Type[] types)
Collection | SessionImpl.filter(Object collection, String filter, Object value, Type type)
Collection | SessionImpl.filter(Object collection, String filter, Object[] values, Type[] types)
protected Object | AbstractScrollableResults.getFinal(int col, Type returnType) Check that the requested type is compatible with the result type, and return the column value.
protected Object | AbstractScrollableResults.getNonFinal(int col, Type returnType) Check that the requested type is compatible with the result type, and return the column value.
Query | AbstractQueryImpl.setParameter(int position, Object val, Type type)
Query | AbstractQueryImpl.setParameter(String name, Object val, Type type)
protected Type | AbstractQueryImpl.determineType(int paramPosition, Object paramValue, Type defaultType)
protected Type | AbstractQueryImpl.determineType(String paramName, Object paramValue, Type defaultType)
Query | AbstractQueryImpl.setParameterList(String name, Collection vals, Type type)
Query | AbstractQueryImpl.setParameterList(String name, Object[] vals, Type type)
Query | AbstractQueryImpl.setParameters(Object[] values, Type[] types)

Constructors in org.hibernate.impl with parameters of type Type
ScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
IteratorImpl(ResultSet rs, PreparedStatement ps, EventSource sess, Type[] types, String[][] columnNames, HolderInstantiator holderInstantiator)
FetchingScrollableResultsImpl(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)
AbstractScrollableResults(ResultSet rs, PreparedStatement ps, SessionImplementor sess, Loader loader, QueryParameters queryParameters, Type[] types, HolderInstantiator holderInstantiator)

Uses of Type in org.hibernate.loader

Methods in org.hibernate.loader with parameters of type Type
protected List | Loader.loadEntity(SessionImplementor session, Object id, Type identifierType, Object optionalObject, String optionalEntityName, Serializable optionalIdentifier, EntityPersister persister) Called by subclasses that load entities
protected List | Loader.loadEntity(SessionImplementor session, Object key, Object index, Type keyType, Type indexType, EntityPersister persister) Called by subclasses that load entities
List | Loader.loadEntityBatch(SessionImplementor session, Serializable[] ids, Type idType, Object optionalObject, String optionalEntityName, Serializable optionalId, EntityPersister persister) Called by wrappers that batch load entities
void | Loader.loadCollection(SessionImplementor session, Serializable id, Type type) Called by subclasses that initialize collections
void | Loader.loadCollectionBatch(SessionImplementor session, Serializable[] ids, Type type) Called by wrappers that batch initialize collections
protected void | Loader.loadCollectionSubselect(SessionImplementor session, Serializable[] ids, Object[] parameterValues, Type[] parameterTypes, Map namedParameters, Type type) Called by subclasses that batch initialize collections
protected List | Loader.list(SessionImplementor session, QueryParameters queryParameters, Set querySpaces, Type[] resultTypes) Return the query results, using the query cache, called by subclasses that implement cacheable queries
protected ScrollableResults | Loader.scroll(QueryParameters queryParameters, Type[] returnTypes, HolderInstantiator holderInstantiator, SessionImplementor session) Return the query results, as an instance of ScrollableResults

Uses of Type in org.hibernate.loader.collection

Methods in org.hibernate.loader.collection that return Type
protected  Type CollectionLoader.getKeyType()

Uses of Type in org.hibernate.loader.criteria

Methods in org.hibernate.loader.criteria that return Type
Type[] | CriteriaQueryTranslator.getProjectedTypes()
Type | CriteriaQueryTranslator.getIdentifierType(Criteria subcriteria)
Type | CriteriaQueryTranslator.getTypeUsingProjection(Criteria subcriteria, String propertyName)
Type | CriteriaQueryTranslator.getType(Criteria subcriteria, String propertyName)
Type[] | CriteriaJoinWalker.getResultTypes()

Uses of Type in org.hibernate.loader.custom

Methods in org.hibernate.loader.custom that return Type
 Type ScalarReturn.getType()

Constructors in org.hibernate.loader.custom with parameters of type Type
ScalarReturn(Type type, String columnAlias)
CustomLoader.ScalarResultColumnProcessor(String alias, Type type)

Uses of Type in org.hibernate.loader.entity

Fields in org.hibernate.loader.entity declared as Type
protected  Type AbstractEntityLoader.uniqueKeyType

Constructors in org.hibernate.loader.entity with parameters of type Type
EntityLoader(OuterJoinLoadable persister, String[] uniqueKey, Type uniqueKeyType, int batchSize, LockMode lockMode, SessionFactoryImplementor factory, Map enabledFilters)
AbstractEntityLoader(OuterJoinLoadable persister, Type uniqueKeyType, SessionFactoryImplementor factory, Map enabledFilters)

Uses of Type in org.hibernate.mapping

Methods in org.hibernate.mapping that return Type
Type | Value.getType()
abstract Type | ToOne.getType()
Type | SimpleValue.getType()
Type | Property.getType()
Type | OneToOne.getType()
Type | OneToMany.getType()
Type | ManyToOne.getType()
Type | DependantValue.getType()
Type | Component.getType()
Type | Collection.getType()
Type | Any.getType()

Uses of Type in org.hibernate.metadata

Methods in org.hibernate.metadata that return Type
Type | CollectionMetadata.getKeyType() The collection key type
Type | CollectionMetadata.getElementType() The collection element type
Type | CollectionMetadata.getIndexType() The collection index type (or null if the collection has no index)
Type | ClassMetadata.getIdentifierType() Get the identifier Hibernate type
Type[] | ClassMetadata.getPropertyTypes() Get the Hibernate types of the class properties
Type | ClassMetadata.getPropertyType(String propertyName) Get the type of a particular (named) property

Uses of Type in org.hibernate.param

Methods in org.hibernate.param that return Type
Type | VersionTypeSeedParameterSpecification.getExpectedType()
Type | ParameterSpecification.getExpectedType()
Type | AbstractExplicitParameterSpecification.getExpectedType()

Methods in org.hibernate.param with parameters of type Type
void | VersionTypeSeedParameterSpecification.setExpectedType(Type expectedType)
void | ParameterSpecification.setExpectedType(Type expectedType)
void | AbstractExplicitParameterSpecification.setExpectedType(Type expectedType)

Uses of Type in org.hibernate.persister.collection

Fields in org.hibernate.persister.collection declared as Type
protected  Type AbstractCollectionPersister.elementType

Methods in org.hibernate.persister.collection that return Type
Type | ElementPropertyMapping.toType(String propertyName)
Type | ElementPropertyMapping.getType()
Type | CompositeElementPropertyMapping.getType()
Type | CollectionPropertyMapping.toType(String propertyName)
Type | CollectionPropertyMapping.getType()
Type | CollectionPersister.getKeyType() Get the "key" type (the type of the foreign key)
Type | CollectionPersister.getIndexType() Get the "index" type for a list or map (optional operation)
Type | CollectionPersister.getElementType() Get the "element" type
Type | CollectionPersister.getIdentifierType() Get the type of the surrogate key
Type | AbstractCollectionPersister.getKeyType()
Type | AbstractCollectionPersister.getIndexType()
Type | AbstractCollectionPersister.getElementType()
Type | AbstractCollectionPersister.getIdentifierType()
Type | AbstractCollectionPersister.toType(String propertyName)
Type | AbstractCollectionPersister.getType()

Constructors in org.hibernate.persister.collection with parameters of type Type
ElementPropertyMapping(String[] elementColumns, Type type)

Uses of Type in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return Type
Type | UnionSubclassEntityPersister.getDiscriminatorType()
Type | SQLLoadable.getType() Get the type
Type | SingleTableEntityPersister.getDiscriminatorType()
Type | PropertyMapping.toType(String propertyName) Given a component path expression, get the type of the property
Type | PropertyMapping.getType() Get the type of the thing containing the properties
Type | OuterJoinLoadable.getSubclassPropertyType(int i) Get the type of the numbered property of the class or a subclass.
Type | Loadable.getDiscriminatorType() Get the discriminator type
Type | JoinedSubclassEntityPersister.getDiscriminatorType()
Type | EntityPersister.getPropertyType(String propertyName) Get the type of a particular property
Type[] | EntityPersister.getPropertyTypes() Get the Hibernate types of the class properties
Type | EntityPersister.getIdentifierType() Get the identifier type
Type | BasicEntityPropertyMapping.getType()
Type | AbstractPropertyMapping.toType(String propertyName)
Type | AbstractEntityPersister.toType(String propertyName)
Type | AbstractEntityPersister.getSubclassPropertyType(int i)
protected Type[] | AbstractEntityPersister.getSubclassPropertyTypeClosure()
Type | AbstractEntityPersister.getPropertyType(String propertyName)
Type | AbstractEntityPersister.getType()
Type[] | AbstractEntityPersister.getPropertyTypes()
Type | AbstractEntityPersister.getIdentifierType()

Methods in org.hibernate.persister.entity with parameters of type Type
protected void | AbstractPropertyMapping.addPropertyPath(String path, Type type, String[] columns, String[] formulaTemplates)
protected void | AbstractPropertyMapping.initPropertyPaths(String path, Type type, String[] columns, String[] formulaTemplates, Mapping factory)

Uses of Type in org.hibernate.pretty

Methods in org.hibernate.pretty with parameters of type Type
String | Printer.toString(Type[] types, Object[] values)
static String | MessageHelper.infoString(EntityPersister persister, Object id, Type identifierType, SessionFactoryImplementor factory) Generate an info message string relating to a particular entity,.

Uses of Type in org.hibernate.property

Fields in org.hibernate.property declared as Type
protected Type | Dom4jAccessor.Dom4jGetter.propertyType
protected Type | Dom4jAccessor.Dom4jSetter.propertyType

Methods in org.hibernate.property with parameters of type Type
static PropertyAccessor PropertyAccessorFactory.getDom4jPropertyAccessor(String nodeName, Type type, SessionFactoryImplementor factory)

Constructors in org.hibernate.property with parameters of type Type
Dom4jAccessor(String nodeName, Type propertyType, SessionFactoryImplementor factory)

Uses of Type in org.hibernate.tuple

Methods in org.hibernate.tuple that return Type
 Type Property.getType()

Constructors in org.hibernate.tuple with parameters of type Type
VersionProperty(String name, String node, Type type, boolean lazy, boolean insertable, boolean updateable, boolean insertGenerated, boolean updateGenerated, boolean nullable, boolean checkable, boolean versionable, CascadeStyle cascadeStyle, VersionValue unsavedValue)
Constructs VersionProperty instances.
StandardProperty(String name, String node, Type type, boolean lazy, boolean insertable, boolean updateable, boolean insertGenerated, boolean updateGenerated, boolean nullable, boolean checkable, boolean versionable, CascadeStyle cascadeStyle, FetchMode fetchMode)
Constructs StandardProperty instances.
Property(String name, String node, Type type)
Constructor for Property instances.
IdentifierProperty(String name, String node, Type type, boolean embedded, IdentifierValue unsavedValue, IdentifierGenerator identifierGenerator)
Construct a non-virtual identifier property.
IdentifierProperty(Type type, boolean embedded, boolean hasIdentifierMapper, IdentifierValue unsavedValue, IdentifierGenerator identifierGenerator)
Construct a virtual IdentifierProperty.

Uses of Type in org.hibernate.tuple.entity

Methods in org.hibernate.tuple.entity that return Type
 Type[] EntityMetamodel.getPropertyTypes()

Uses of Type in org.hibernate.type

Subinterfaces of Type in org.hibernate.type
interface | AbstractComponentType Enables other Component-like types to hold collections and have cascades, etc.
interface | AssociationType A type that represents some kind of association between entities.
interface | DiscriminatorType A Type that may be used for a discriminator column.
interface | IdentifierType A Type that may be used as an identifier.
interface | VersionType A Type that may be used to version data.

Classes in org.hibernate.type that implement Type
class | AbstractBynaryType Logic to bind stream of byte into a VARBINARY
class | AbstractCharArrayType Logic to bind stream of char into a VARCHAR
class | AbstractType Abstract superclass of the built in Type hierarchy.
class | AdaptedImmutableType Optimize a mutable type, if the user promises not to mutable the instances.
class | AnyType Handles "any" mappings and the old deprecated "object" type
class | ArrayType A type for persistent arrays.
class | BagType
class | BigDecimalType big_decimal: A type that maps an SQL NUMERIC to a java.math.BigDecimal
class | BigIntegerType big_integer: A type that maps an SQL NUMERIC to a java.math.BigInteger
class | BinaryType binary: A type that maps an SQL VARBINARY to a Java byte[].
class | BlobType blob: A type that maps an SQL BLOB to a java.sql.Blob.
class | BooleanType boolean: A type that maps an SQL BIT to a Java Boolean.
class | ByteType byte: A type that maps an SQL TINYINT to a Java Byte.
class | CalendarDateType calendar_date: A type mapping for a Calendar object that represents a date.
class | CalendarType calendar: A type mapping for a Calendar object that represents a datetime.
class | CharacterArrayType Bridge Character[] and VARCHAR
class | CharacterType character: A type that maps an SQL CHAR(1) to a Java Character.
class | CharArrayType put char[] into VARCHAR
class | CharBooleanType Superclass for types that map Java boolean to SQL CHAR(1).
class | ClassType class: A type that maps an SQL VARCHAR to a Java Class.
class | ClobType clob: A type that maps an SQL CLOB to a java.sql.Clob.
class | CollectionType A type that handles Hibernate PersistentCollections (including arrays).
class | ComponentType Handles "component" mappings
class | CompositeCustomType Adapts CompositeUserType to Type interface
class | CurrencyType currency: A type that maps an SQL VARCHAR to a java.util.Currency
class | CustomCollectionType A custom type for mapping user-written classes that implement PersistentCollection
class | CustomType Adapts UserType to the generic Type interface, in order to isolate user code from changes in the internal Type contracts.
class | DateType date: A type that maps an SQL DATE to a Java Date.
class | DbTimestampType dbtimestamp: An extension of TimestampType which maps to the database's current timestamp, rather than the jvm's current timestamp.
class | DoubleType double: A type that maps an SQL DOUBLE to a Java Double.
class | EmbeddedComponentType
class | EntityType A reference to an entity class
class | FloatType float: A type that maps an SQL FLOAT to a Java Float.
class | IdentifierBagType
class | ImmutableType Superclass of nullable immutable types.
class | IntegerType integer: A type that maps an SQL INT to a Java Integer.
class | ListType
class | LocaleType locale: A type that maps an SQL VARCHAR to a Java Locale.
class | LongType long: A type that maps an SQL BIGINT to a Java Long.
class | ManyToOneType A many-to-one association to an entity.
class | MapType
class | MetaType
class | MutableType Superclass for mutable nullable types
class | NullableType Superclass of single-column nullable types.
class | OneToOneType A one-to-one association to an entity
class | OrderedMapType
class | OrderedSetType
class | PrimitiveType Superclass of primitive / primitive wrapper types.
class | SerializableType serializable: A type that maps an SQL VARBINARY to a serializable Java object.
class | SetType
class | ShortType short: A type that maps an SQL SMALLINT to a Java Short.
class | SortedMapType
class | SortedSetType
class | SpecialOneToOneType A one-to-one association that maps to specific formula(s) instead of the primary key column of the owning entity.
class | StringType string: A type that maps an SQL VARCHAR to a Java String.
class | TextType text: A type that maps an SQL CLOB to a Java String.
class | TimestampType timestamp: A type that maps an SQL TIMESTAMP to a Java java.util.Date or java.sql.Timestamp.
class | TimeType time: A type that maps an SQL TIME to a Java java.util.Date or java.sql.Time.
class | TimeZoneType timezone: A type that maps an SQL VARCHAR to a java.util.TimeZone
class | TrueFalseType true_false: A type that maps an SQL CHAR(1) to a Java Boolean.
class | WrapperBinaryType
class | YesNoType yes_no: A type that maps an SQL CHAR(1) to a Java Boolean.

Methods in org.hibernate.type that return Type
static Type | TypeFactory.basic(String name) Given the name of a Hibernate basic type, return an instance of org.hibernate.type.Type.
static Type | TypeFactory.heuristicType(String typeName) Uses heuristics to deduce a Hibernate type given a string naming the type or Java class.
static Type | TypeFactory.heuristicType(String typeName, Properties parameters) Uses heuristics to deduce a Hibernate type given a string naming the type or Java class.
Type | Type.getSemiResolvedType(SessionFactoryImplementor factory) Get the type of a semi-resolved value.
Type | EntityType.getIdentifierOrUniqueKeyType(Mapping factory)
Type | EntityType.getSemiResolvedType(SessionFactoryImplementor factory)
Type[] | CompositeCustomType.getSubtypes()
Type[] | ComponentType.getSubtypes()
Type | CollectionType.getElementType(SessionFactoryImplementor factory) Get the Hibernate type of the collection elements
Type[] | AnyType.getSubtypes()
Type | AbstractType.getSemiResolvedType(SessionFactoryImplementor factory)
Type[] | AbstractComponentType.getSubtypes() Get the types of the component properties

Methods in org.hibernate.type with parameters of type Type
static void | TypeFactory.deepCopy(Object[] values, Type[] types, boolean[] copy, Object[] target, SessionImplementor session) Deep copy values in the first array into the second
static void | TypeFactory.beforeAssemble(Serializable[] row, Type[] types, SessionImplementor session) Determine if any of the given field values are modified, returning an array containing indexes of the dirty fields or null if no fields are dirty.
static Object[] | TypeFactory.assemble(Serializable[] row, Type[] types, SessionImplementor session, Object owner)
static Serializable[] | TypeFactory.disassemble(Object[] row, Type[] types, boolean[] nonCacheable, SessionImplementor session, Object owner)
static Object[] | TypeFactory.replace(Object[] original, Object[] target, Type[] types, SessionImplementor session, Object owner, Map copyCache)
static Object[] | TypeFactory.replace(Object[] original, Object[] target, Type[] types, SessionImplementor session, Object owner, Map copyCache, ForeignKeyDirection foreignKeyDirection)

Constructors in org.hibernate.type with parameters of type Type
MetaType(Map values, Type baseType)
AnyType(Type metaType, Type identifierType)

Uses of Type in org.hibernate.usertype

Methods in org.hibernate.usertype that return Type
 Type[] CompositeUserType.getPropertyTypes()
Get the corresponding "property types".

Uses of Type in org.hibernate.util

Fields in org.hibernate.util declared as Type
static Type[] ArrayHelper.EMPTY_TYPE_ARRAY

Methods in org.hibernate.util that return Type
static Type[] ArrayHelper.toTypeArray(Collection coll)

Methods in org.hibernate.util with parameters of type Type
static Constructor ReflectHelper.getConstructor(Class clazz, Type[] types)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.TypeFactory (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.TypeFactory

No usage of org.hibernate.type.TypeFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.type.VersionType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.type.VersionType

Packages that use VersionType
org.hibernate | This package defines the central Hibernate APIs.
org.hibernate.engine | This package contains classes that are "shared" by other packages, and implementations of some key algorithms.
org.hibernate.param |
org.hibernate.persister.entity | This package abstracts persistence mechanisms for entities, and defines the Hibernate runtime metamodel.
org.hibernate.type | A Hibernate Type is a strategy for mapping a Java property type to a JDBC type or types.

Uses of VersionType in org.hibernate

Methods in org.hibernate with parameters of type VersionType
abstract  boolean ReplicationMode.shouldOverwriteCurrentVersion(Object entity, Object currentVersion, Object newVersion, VersionType versionType)

Uses of VersionType in org.hibernate.engine

Methods in org.hibernate.engine with parameters of type VersionType
static Object | Versioning.increment(Object version, VersionType versionType, SessionImplementor session) Increment the given version number
static boolean | Versioning.seedVersion(Object[] fields, int versionProperty, VersionType versionType, SessionImplementor session) Seed the given instance state snapshot with an initial version number
static VersionValue | UnsavedValueFactory.getUnsavedVersionValue(String versionUnsavedValue, Getter versionGetter, VersionType versionType, Constructor constructor)

Uses of VersionType in org.hibernate.param

Constructors in org.hibernate.param with parameters of type VersionType
VersionTypeSeedParameterSpecification(VersionType type)

Uses of VersionType in org.hibernate.persister.entity

Methods in org.hibernate.persister.entity that return VersionType
VersionType | EntityPersister.getVersionType() Get the type of versioning (optional operation)
VersionType | AbstractEntityPersister.getVersionType()

Uses of VersionType in org.hibernate.type

Classes in org.hibernate.type that implement VersionType
class | AbstractBynaryType Logic to bind stream of byte into a VARBINARY
class | BinaryType binary: A type that maps an SQL VARBINARY to a Java byte[].
class | ByteType byte: A type that maps an SQL TINYINT to a Java Byte.
class | CalendarType calendar: A type mapping for a Calendar object that represents a datetime.
class | CustomType Adapts UserType to the generic Type interface, in order to isolate user code from changes in the internal Type contracts.
class | DbTimestampType dbtimestamp: An extension of TimestampType which maps to the database's current timestamp, rather than the jvm's current timestamp.
class | IntegerType integer: A type that maps an SQL INT to a Java Integer.
class | LongType long: A type that maps an SQL BIGINT to a Java Long.
class | ShortType short: A type that maps an SQL SMALLINT to a Java Short.
class | TimestampType timestamp: A type that maps an SQL TIMESTAMP to a Java java.util.Date or java.sql.Timestamp.
class | WrapperBinaryType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.WrapperBinaryType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.WrapperBinaryType

No usage of org.hibernate.type.WrapperBinaryType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.type.YesNoType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.type.YesNoType

No usage of org.hibernate.type.YesNoType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.usertype (Hibernate API Documentation)

 org.hibernate.usertype
Interfaces
CompositeUserType
EnhancedUserType
LoggableUserType
ParameterizedType
UserCollectionType
UserType
UserVersionType


Uses of Interface org.hibernate.usertype.CompositeUserType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.usertype.CompositeUserType

No usage of org.hibernate.usertype.CompositeUserType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.usertype.EnhancedUserType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.usertype.EnhancedUserType

No usage of org.hibernate.usertype.EnhancedUserType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.usertype.LoggableUserType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.usertype.LoggableUserType

No usage of org.hibernate.usertype.LoggableUserType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.usertype.ParameterizedType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.usertype.ParameterizedType

No usage of org.hibernate.usertype.ParameterizedType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.usertype.UserCollectionType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.usertype.UserCollectionType

No usage of org.hibernate.usertype.UserCollectionType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.usertype.UserType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.usertype.UserType

Packages that use UserType
org.hibernate.usertype Interfaces for user-defined custom types.

Uses of UserType in org.hibernate.usertype

Subinterfaces of UserType in org.hibernate.usertype
interface | EnhancedUserType A custom type that may function as an identifier or discriminator type, or may be marshalled to and from an XML document
interface | UserVersionType A user type that may be used for a version property

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.hibernate.usertype.UserVersionType (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.hibernate.usertype.UserVersionType

No usage of org.hibernate.usertype.UserVersionType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.hibernate.util (Hibernate API Documentation)

 org.hibernate.util
Classes
ArrayHelper
BytesHelper
CalendarComparator
Cloneable
CollectionHelper
ComparableComparator
ConfigHelper
DTDEntityResolver
EmptyIterator
EqualsHelper
ExternalSessionFactoryConfig
FastHashMap
FilterHelper
GetGeneratedKeysHelper
IdentityMap
IdentityMap.IdentityKey
IdentityMap.IdentityMapEntry
IdentitySet
JDBCExceptionReporter
JoinedIterator
JTAHelper
LazyIterator
LinkedHashCollectionHelper
MarkerObject
NamedGeneratedKeysHelper
NamingHelper
PropertiesHelper
Range
ReflectHelper
SerializationHelper
SimpleMRUCache
SingletonIterator
SoftLimitMRUCache
StringHelper
XMLHelper
XMLHelper.ErrorLogger


Uses of Class org.hibernate.util.ArrayHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.ArrayHelper

No usage of org.hibernate.util.ArrayHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.BytesHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.BytesHelper

No usage of org.hibernate.util.BytesHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.CalendarComparator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.CalendarComparator

No usage of org.hibernate.util.CalendarComparator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.Cloneable (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.Cloneable

Packages that use Cloneable
org.hibernate.event This package defines an event framework for Hibernate.

Uses of Cloneable in org.hibernate.event

Subclasses of Cloneable in org.hibernate.event
 class EventListeners
A convience holder for all defined session event listeners.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.CollectionHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.CollectionHelper

No usage of org.hibernate.util.CollectionHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.ComparableComparator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.ComparableComparator

No usage of org.hibernate.util.ComparableComparator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.ConfigHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.ConfigHelper

No usage of org.hibernate.util.ConfigHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.DTDEntityResolver (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.DTDEntityResolver

No usage of org.hibernate.util.DTDEntityResolver

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.EmptyIterator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.EmptyIterator

No usage of org.hibernate.util.EmptyIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.EqualsHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.EqualsHelper

No usage of org.hibernate.util.EqualsHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.ExternalSessionFactoryConfig (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.ExternalSessionFactoryConfig

Packages that use ExternalSessionFactoryConfig
org.hibernate.jmx This package exposes a Hibernate instance via JMX.

Uses of ExternalSessionFactoryConfig in org.hibernate.jmx

Subclasses of ExternalSessionFactoryConfig in org.hibernate.jmx
 class HibernateService
Implementation of HibernateServiceMBean.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.FastHashMap (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.FastHashMap

No usage of org.hibernate.util.FastHashMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.FilterHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.FilterHelper

No usage of org.hibernate.util.FilterHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.GetGeneratedKeysHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.GetGeneratedKeysHelper

No usage of org.hibernate.util.GetGeneratedKeysHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.IdentityMap (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.IdentityMap

No usage of org.hibernate.util.IdentityMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.IdentityMap.IdentityKey (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.IdentityMap.IdentityKey

No usage of org.hibernate.util.IdentityMap.IdentityKey

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.IdentityMap.IdentityMapEntry (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.IdentityMap.IdentityMapEntry

No usage of org.hibernate.util.IdentityMap.IdentityMapEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.IdentitySet (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.IdentitySet

No usage of org.hibernate.util.IdentitySet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.JDBCExceptionReporter (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.JDBCExceptionReporter

No usage of org.hibernate.util.JDBCExceptionReporter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.JoinedIterator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.JoinedIterator

No usage of org.hibernate.util.JoinedIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.JTAHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.JTAHelper

No usage of org.hibernate.util.JTAHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.LazyIterator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.LazyIterator

No usage of org.hibernate.util.LazyIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.LinkedHashCollectionHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.LinkedHashCollectionHelper

No usage of org.hibernate.util.LinkedHashCollectionHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.MarkerObject (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.MarkerObject

No usage of org.hibernate.util.MarkerObject

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.NamedGeneratedKeysHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.NamedGeneratedKeysHelper

No usage of org.hibernate.util.NamedGeneratedKeysHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.NamingHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.NamingHelper

No usage of org.hibernate.util.NamingHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.PropertiesHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.PropertiesHelper

No usage of org.hibernate.util.PropertiesHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.Range (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.Range

No usage of org.hibernate.util.Range

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.ReflectHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.ReflectHelper

No usage of org.hibernate.util.ReflectHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.SerializationHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.SerializationHelper

No usage of org.hibernate.util.SerializationHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.SimpleMRUCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.SimpleMRUCache

No usage of org.hibernate.util.SimpleMRUCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.SingletonIterator (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.SingletonIterator

No usage of org.hibernate.util.SingletonIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.SoftLimitMRUCache (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.SoftLimitMRUCache

No usage of org.hibernate.util.SoftLimitMRUCache

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.StringHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.StringHelper

No usage of org.hibernate.util.StringHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.XMLHelper (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.XMLHelper

Packages that use XMLHelper
org.hibernate.cfg This package defines APIs for configuring Hibernate, and classes for building the Hibernate configuration-time metamodel.

Uses of XMLHelper in org.hibernate.cfg

Fields in org.hibernate.cfg declared as XMLHelper
protected  XMLHelper Configuration.xmlHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.hibernate.util.XMLHelper.ErrorLogger (Hibernate API Documentation)

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.hibernate.util.XMLHelper.ErrorLogger

No usage of org.hibernate.util.XMLHelper.ErrorLogger

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES