首页

本书由 中华电脑书库 整理制作， 仅供个人学习研究交流之用
版权归原作者所有，严禁作商业用途。否则一切后果自理！
中华电脑书库
http://www.pcbookcn.com


（1）HTML注释

JSP语法（1）——HTML注释

作者：飞刀/ aspcn.com

HTML 注释

在客户端显示一个注释.

JSP 语法

<!-- comment [ <%= expression %> ] -->

例子 1

<!-- This file displays the user login screen -->

在客户端的HTML源代码中产生和上面一样的数据：

<!-- This file displays the user login screen -->

例子 2

<!-- This page was loaded on <%= (new java.util.Date()).toLocaleString() %> -->

在客户端的HTML源代码中显示为:

<!-- This page was loaded on January 1, 2000 -->

描述

这种注释和HTML中很像，也就是它可以在"查看源代码"中看到。

唯一有些不同的就是，你可以在这个注释中用表达式（例子2所示)。这个表达示是不定的，由页面不同而不同，你能够使用各种表达式，只要是合法的就行。

[下一页]

[返回]


（2）隐藏注释

JSP语法（2）——隐藏注释

隐藏注释

写在JSP程序中，但不是发给客户。

JSP 语法

<%-- comment --%>

例子：

<%@ page language="java" %>
<html>
<head><title>A Comment Test</title></head>
<body>
<h2>A Test of Comments</h2>
<%-- This comment will not be visible in the page source --%>
</body>
</html>

描述

用隐藏注释标记的字符会在JSP编译时被忽略掉。这个注释在你希望隐藏或注释你的JSP程序时是很有用的。

JSP编译器不是会对<%--and--%>之间的语句进行编译的，它不会显示在客户的浏览器中，也不会在源代码中看到在<%-- --%>之间，你可以任意写注释语句，但是不能使用 "--%>",如果你非要使用请用"--%\>".

[上一页] [下一页]


（3）声明

JSP语法（3）——声明

声明

在JSP程序中声明合法的变量和方法

JSP 语法

<%! declaration; [ declaration; ]+ ... %>

例子

<%! int i = 0; %>
<%! int a, b, c; %>
<%! Circle a = new Circle(2.0); %>

描述

声明你将要在JSP程序中用到的变量和方法。你也必须这样做，不然会出错.

你可以一次性声明多个变量和方法，只要以";"结尾就行，当然这些声明在Java中要是合法的。

当你声明方法或变量时，请注意以下的一些规则:

声明必须以";"结尾(Scriptlet有同样的规则，但是 表达式就不同了).
你可以直接使用在<% @ page %>中被包含进来的已经声明的变量和方法，不需要对它们重新进行声明.

一个声明仅在一个页面中有效。如果你想每个页面都用到一些声明，最好把它们写成一个单独的文件，然后用<%@ include %>或<jsp:include >元素包含进来。


（4）表达式

JSP语法（4）——表达式

表达式

包含一个符合JSP语法的表达式

JSP 语法

<%= expression %>

例子

<font color="blue"><%= map.size() %></font>
<b><%= numguess.getHint() %></b>.

描述

表达式元素表示的是一个在脚本语言中被定义的表达式，在运行后被自动转化为字符串，然后插入到这个表达示在JSP文件的位置显示。因为这个表达式的值已经被转化为字符串，所以你能在一行文本中插入这个表达式（形式和ASP完全一样).

当你在JSP中使用表达式时请记住以下几点：

你不能用一个分号（"；"）来作为表达式的结束符.但是同样的表达式用在scriptlet中就需要以分号来结尾了！查看Scriptlet 这个表达式元素能够包括任何在Java Language Specification中有效的表达式.

有时候表达式也能做为其它JSP元素的属性值.一个表达式能够变得很复杂，它可能由一个或多个表达式组成，这些表达式的顺序是从左到右。


（5）Scriptlet

JSP语法（5）——Scriptlet

Scriptlet

包含一个有效的程序段.

JSP 语法

<% code fragment %>

例子

<%
String name = null;
if (request.getParameter("name") == null) {
%>
<%@ include file="error.html" %>
<%
} else {
foo.setName(request.getParameter("name"));
if (foo.getName().equalsIgnoreCase("integra"))
name = "acura";
if (name.equalsIgnoreCase( "acura" )) {
%>

描述

一个scriptlet能够包含多个jsp语句，方法，变量，表达式

因为scriptlet,我们便能做以下的事:

声明将要用到的变量或方法（参考 声明).
编写JSP表达式（参考 表达式).
使用任何隐含的对象和任何用<jsp:useBean>声明过的对象
编写JSP语句 (如果你在使用Java语言，这些语句必须遵从Java Language Specification,).
任何文本，HTML标记，JSP元素必须在scriptlet之外
当JSP收到客户的请求时，scriptlet就会被执行，如果scriptlet有显示的内容，这些显示的内容就被存在out对象中。


（6）Page指令

JSP语法（6）——Page指令

  Page 指令

定义JSP文件中的全局属性.

JSP 语法
<%@ page
[ language="java" ]
[ extends="package.class" ]
[ import="{package.class | package.*}, ..." ]
[ session="true | false" ]
[ buffer="none | 8kb | sizekb" ]
[ autoFlush="true | false" ]
[ isThreadSafe="true | false" ]
[ info="text" ]
[ errorPage="relativeURL" ]
[ contentType="mimeType [ ;charset=characterSet ]" | "text/html ; charset=ISO-8859-1" ]
[ isErrorPage="true | false" ]
%>
例子
<%@ page import="java.util.*, java.lang.*" %>
<%@ page buffer="5kb" autoFlush="false" %>
<%@ page errorPage="error.jsp" %>
描述
<%@ page %>指令作用于整个JSP页面，同样包括静态的包含文件。但是<% @ page %>指令不能作用于动态的包含文件，比如 <jsp:include>

你可以在一个页面中用上多个<% @ page %>指令，但是其中的属性只能用一次，不过也有个例外，那就是import属性。因为import属性和Java中的import语句差不多(参照Java Language)，所以你就能多用此属性几次了.

无论你把<% @ page %>指令放在JSP的文件的哪个地方，它的作用范围都是整个JSP页面。不过，为了JSP程序的可读性，以及好的编程习惯，最好还是把它放在JSP文件的顶部.


（7）Taglib指令

JSP语法（7）——Taglib指令

Taglib 指令

定义一个标签库以及其自定义标签的前缀.

JSP 语法

<%@ taglib uri="URIToTagLibrary" prefix="tagPrefix" %>

例子

<%@ taglib uri="http://www.jspcentral.com/tags" prefix="public" %>
<public:loop>
.
.
</public:loop>

描述

<% @ taglib %>指令声明此JSP文件使用了自定义的标签，同时引用标签库，也指定了他们的标签的前缀。

这里自定义的标签含有标签和元素之分。因为JSP文件能够转化为XML,所以了解标签和元素之间的联系很重要。标签只不过是一个在意义上被抬高了点的标记，是JSP元素的一部分。JSP元素是JSP语法的一部分，和XML一样有开始标记和结束标记。元素也可以包含其它的文本，标记，元素。比如，一个jsp:plugin元素有<jsp:plugin>开始标记和</jsp:plugin>结束标记，同样也可以有<jsp:params>和<jsp:fallback>元素.

你必须在使用自定义标签之前使用<% @ taglib %>指令，而且你可以在一个页面中多次使用，但是前缀只能使用一次

属性

uri="URIToTagLibrary"
Uniform Resource Identifier (URI)根据标签的前缀对自定义的标签进行唯一的命名，URI可以是以下的内容:

Uniform Resource Locator (URL), 由 RFC 2396 定义, 查看 http://www.hut.fi/u/jkorpela/rfc/2396/full.html

Uniform Resource Name (URN), 由 RFC 2396定义

一个相对或绝对的路径
prefix="tagPrefix"
在自定义标签之前的前缀，比如，在<public:loop>中的public，如果这里不写public，那么这就是不合法的。请不要用jsp, jspx, java, javax, servlet, sun, 和sunw做为你的前缀


（8）<jsp:forward>

JSP语法（8）——<jsp:forward>

<jsp:forward>

重定向一个HTML文件，JSP文件，或者是一个程序段.

JSP 语法

<jsp:forward page={"relativeURL" | "<%= expression %>"} />

or

<jsp:forward page={"relativeURL" | "<%= expression %>"} >

<jsp:param name="parameterName"

value="{parameterValue | <%= expression %>}" />+

</jsp:forward>

例子

<jsp:forward page="/servlet/login" />

<jsp:forward page="/servlet/login">

<jsp:param name="username" value="jsmith" />

</jsp:forward>

描述

<jsp:forward>标签从一个JSP文件向另一个文件传递一个包含用户请求的request对象.<jsp:forward>标签以下的代码，将不能执行.

你能够向目标文件传送参数和值，在这个例子中我们传递的参数名为username,值为scott,如果你使用了<jsp:param>标签的话，目标文件必须是一个动态的文件，能够处理参数.

如果你使用了非缓冲输出的话，那么使用<jsp:forward>时就要小心。如果在你使用<jsp:forward>之前，jsp文件已经有了数据，那么文件执行就会出错.

属性

  • page="{relativeURL | <%= expression %>}"

    这里是一个表达式或是一个字符串用于说明你将要定向的文件或URL.这个文件可以是JSP,程序段，或者其它能够处理request对象的文件(如asp,cgi,php).

  • <jsp:param name="parameterName" value="{parameterValue | <%= expression %>}" />+

    向一个动态文件发送一个或多个参数，这个文件一定是动态文件.

    如果你想传递多个参数，你可以在一个JSP文件中使用多个<jsp:param>。name指定参数名，value指定参数值.


（9）<jsp:getProperty>

JSP语法（9）——<jsp:getProperty>

<jsp:getProperty>

获取Bean的属性值，用于显示在页面中

JSP 语法

<jsp:getProperty name="beanInstanceName" property="propertyName" />

例子

<jsp:useBean id="calendar" scope="page" class="employee.Calendar" />

<h2>

Calendar of <jsp:getProperty name="calendar" property="username" />

</h2>

描述

这个<jsp:getProperty>元素将获得Bean的属性值，并可以将其使用或显示在JSP页面中.在你使用<jsp:getProperty>之前，你必须用<jsp:useBean>创建它.

<jsp:getProperty>元素有一些限制:

  • 你不能使用<jsp:getProperty>来检索一个已经被索引了的属性

  • 你能够和JavaBeans组件一起使用<jsp:getProperty>,但是不能与Enterprise

    Bean一起使用。

属性

  • name="beanInstanceName"

    bean的名字,由<jsp:useBean>指定

  • property="propertyName"

    所指定的Bean的属性名。

技巧:

  • 在sun的JSP参考中提到，如果你使用<jsp:getProperty>来检索的值是空值，那么NullPointerException将会出现，同时如果使用程序段或表达式来检索其值，那么在浏览器上出现的是null（空).


（10）<jsp:include>

JSP语法（10）——<jsp:include>

<jsp:include>

包含一个静态或动态文件.

JSP 语法

<jsp:include page="{relativeURL | <%= expression%>}" flush="true" />

or

<jsp:include page="{relativeURL | <%= expression %>}" flush="true" >

<jsp:param name="parameterName"

value="{parameterValue | <%= expression %>}" />+

</jsp:include>

Examples

<jsp:include page="scripts/login.jsp" />

<jsp:include page="copyright.html" />

<jsp:include page="/index.html" />

<jsp:include page="scripts/login.jsp">

<jsp:param name="username" value="jsmith" />

</jsp:include>

描述

<jsp:include>元素允许你包含动态文件和静态，这两种包含文件的结果是不同的。如果文件仅是静态文件，那么这种包含仅仅是把包含文件的内容加到jsp文件中去，而如果这个文件动态的，那么这个被包含文件也会被Jsp编译器执行(这一切与asp相似)

你不能从文件名上判断一个文件是动态的还是静态的，比如aspcn.asp

就有可能只是包含一些信息而已，而不需要执行。<jsp:include>能够同时处理这两种文件，因此你就不需要包含时还要判断此文件是动态的还是静态的.

如果这个包含文件是动态的，那么你还可以用<jsp:param>还传递参数名和参数值。

属性

  • page="{relativeURL | <%= expression %>}"

    参数为一相对路径，或者是代表相对路径的表达式.

  • flush="true"

    这里你必须使用flush="true",你不能使用false值.缺省值为false

  • <jsp:param name="parameterName" value="{parameterValue | <%= expression %> }" />+

    <jsp:param>子句能让你传递一个或多个参数给动态文件

    你能在一个页面中使用多个<jsp:param>来传递多个参数。


（11）<jsp:plugin>

JSP语法（11）——<jsp:plugin>

<jsp:plugin>

执行一个applet或Bean,有可能的话还要下载一个Java插件用于执行它.

JSP 语法

<jsp:plugin

type="bean | applet"

code="classFileName"

codebase="classFileDirectoryName"

[ name="instanceName" ]

[ archive="URIToArchive, ..." ]

[ align="bottom | top | middle | left | right" ]

[ height="displayPixels" ]

[ width="displayPixels" ]

[ hspace="leftRightPixels" ]

[ vspace="topBottomPixels" ]

[ jreversion="JREVersionNumber | 1.1" ]

[ nspluginurl="URLToPlugin" ]

[ iepluginurl="URLToPlugin" ] >

[ <jsp:params>

[ <jsp:param name="parameterName"

value="{parameterValue | <%= expression %>}" /> ]+

</jsp:params> ]

[ <jsp:fallback> text message for user </jsp:fallback> ]

</jsp:plugin>

例子

<jsp:plugin type=applet code="Molecule.class" codebase="/html">

<jsp:params>

<jsp:param name="molecule" value="molecules/benzene.mol" />

</jsp:params>

<jsp:fallback>

<p>Unable to load applet</p>

</jsp:fallback>

</jsp:plugin>

描述

<jsp:plugin>元素用于在浏览器中播放或显示一个对象（典型的就是applet和Bean),而这种显示需要在浏览器的java插件。

当Jsp文件被编译，送往浏览器时，<jsp:plugin>元素将会根据浏览器的版本替换成<object>或者<embed>元素。注意，<object>用于HTML 4.0 ，<embed>用于HTML 3.2.

一般来说，<jsp:plugin>元素会指定对象是Applet还是Bean,同样也会指定class的名字，还有位置，另外还会指定将从哪里下载这个Java插件。具体如下:

属性

  • type="bean | applet"

    .将被执行的插件对象的类型，你必须得指定这个是Bean还是applet,因为这个属性没有缺省值.

  • code="classFileName"

    将会被Java插件执行的Java Class的名字，必须以.class结尾。这个文件必须存在于codebase属性指定的目录中.

  • codebase="classFileDirectoryName"

    将会被执行的Java Class文件的目录（或者是路径)，如果你没有提供此属性，那么使用<jsp:plugin>的jsp文件的目录将会被使用.

  • name="instanceName"

    这个Bean或applet实例的名字，它将会在Jsp其它的地方调用.

  • archive="URIToArchive, ..."

    一些由逗号分开的路径名，这些路径名用于预装一些将要使用的class,这会提高applet的性能.

  • align="bottom | top | middle | left | right"

    图形，对象，Applet的位置,有以下值:

    • bottom
    • top
    • middle
    • left
    • right
  • height="displayPixels" width="displayPixels"

    Applet或Bean将要显示的长宽的值，此值为数字，单位为象素.

  • hspace="leftRightPixels" vspace="topBottomPixels"

    Applet或Bean显示时在屏幕左右，上下所需留下的空间，单位为象素.

  • jreversion="JREVersionNumber | 1.1"

    Applet或Bean运行所需的Java Runtime Environment (JRE) 的版本.

    缺省值是 1.1.

  • nspluginurl="URLToPlugin"

    Netscape Navigator用户能够使用的JRE的下载地址，此值为一个标准的URL，如http://www.aspcn.com/jsp

  • iepluginurl="URLToPlugin"

    IE用户能够使用的JRE的下载地址，此值为一个标准的URL，如http://www.aspcn.com/jsp

  • <jsp:params> [ <jsp:param name="parameterName"

    value="{parameterValue | <%= expression %>}" /> ]+ </jsp:params>

    你需要向applet或Bean传送的参数或参数值。

  • <jsp:fallback> text message for user </jsp:fallback>

    一段文字用于Java

    插件不能启动时显示给用户的，如果插件能够启动而applet或Bean不能，那么浏览器会有一个出错信息弹出.


（12）<jsp:useBean>

JSP语法（12）——<jsp:useBean>

作者：飞刀/ aspcn中华网

<jsp:useBean>

创建一个Bean实例并指定它的名字和作用范围.

JSP 语法

<jsp:useBean

id="beanInstanceName"

scope="page | request | session | application"

{

class="package.class" |

type="package.class" |

class="package.class" type="package.class" |

beanName="{package.class | <%= expression %>}" type="package.class"

}

{

/> |

> other elements </jsp:useBean>

}

例子

<jsp:useBean id="cart" scope="session" class="session.Carts" />

<jsp:setProperty name="cart" property="*" />

<jsp:useBean id="checking" scope="session" class="bank.Checking" >

<jsp:setProperty name="checking" property="balance" value="0.0" />

</jsp:useBean>